
About FontViewer
FontViewer lets you browse all the fonts on your system at once, compare selected fonts to each other,
and use a variety of filters to quickly find the font you want.

This program first appeared in the May 26, 1998 issue of PC Magazine, U.S. Edition. Copyright © 1998
by Ziff-Davis, Inc. Programmed by Jake Richter.



Font Terminology
A font, in computer terms, is a logical assortment of shapes, usually representing numbers and letters 
of the alphabet, as well as a variety of other special characters. A collection of fonts of the same 
general type makes up a typeface.

However, because the delineation between the terms “Font” and “Typeface” is generally not important 
to most people, the two terms tend to be used interchangeably.

A font can have serifs, which are little extrusions at the tips and ends of each character, or it can be 
sans serif (meaning without serifs) where each character has ends that don’t have these extrusions.
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A font can have variable spacing between each character depending on the character’s size, or have 
fixed spacing, where each character takes up the same amount of space.
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A font may also be rendered (output) with a number of modifiers, the most important of which are 
Normal, Bold, and Italic. The latter two can be combined.
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It’s important to note that not each typeface is designed to have all these representations, but that 
software can create a version of a font that simulates these representations.



Basic Usage
To install FontViewer, copy its three program files¾FViewer.exe, FViewer.hlp, and 
FViewer.cnt¾to the folder of your choice. The program does not require access to the registry or
any system files, and can be run from any folder. To remove FontViewer from your system, 
simply delete its program files.

There are three components to the FontViewer interface:

· The toolbar 
· The main font window 
· The pull down and pop-up menus 



Point
A point is a term used by typographers to define the size of a given rendering of a font. The point size 
of a font is measured from the baseline of the characters in a font to the top of the tallest character, 
which means that fonts rendered at the same point size will more than likely differ in size compared to 
each other because the size of the tallest character may not be the same. Points are also actually a 
real unit of measure, and there happen to be 72 points per inch, and traditionally people use 12 point 
fonts in correspondence.



Toolbar
FontViewer's toolbar gives fast access to filters that let you control which fonts it displays. These
controls are also available through the Options|Display Settings menu option, which can be 
quickly accessed by pressing F2.

The first toolbar control lets you select the test string displayed to the right of each font name. 
You can select one of three preconfigured strings, or enter your own string of up to 50 
characters. The next control lets you change the size of the font used in the test string. Note that
because of a variety of font nuances, every font renders differently and there can be visible 
differences in height between fonts that were all rendered at a specific point size.
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Next on the toolbar is a pair of buttons that lets you tell FontViewer to display TrueType fonts, 
Bitmap/Other fonts or both. Since all fonts fall into one of these two categories, at least one of 
them must be selected.

ANSI Non-ANSI

The next pair of toolbar buttons lets you select what character sets to display. Different character
sets are needed for languages that use different alphabets. There are over a dozen and half 
different character sets defined for use in Windows, but FontViewer uses a simplified grouping of
just two categories: ANSI and non-ANSI. The ANSI character set is used to represent the Latin 
alphabet used in English and Western European languages. The non-ANSI group encompasses
everything else. By default, FontViewer shows only the ANSI character sets. Note that the ANSI 
designation is entered manually by the font designer. There is nothing to prevent a font designer
from labeling a "Symbol" character set as ANSI.

All non-unicode character sets contain a maximum of 256 characters. The first 128 characters 
contain the Latin alphabet, except in certain symbol and decorative fonts. The second 128 
characters (the "high" characters) contain different things, depending on the type of character 
set. In ANSI character sets, the high characters contain accented Latin characters used in 
Western languages other than English. In non-ANSI character sets, the high characters often 
contain alternate alphabets such as those used in Russian or Eastern European languages.
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You can control the style in which the font is rendered (normal, bold, italic, or bold-italic) using 
the next set of toolbar buttons. Depress multiple buttons to select multiple font styles for display. 
At least one of the style buttons must be selected. If you try to disable all the style variations, 
FontViewer will display an error message.
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Space & Other

If the font is TrueType, FontViewer can obtain descriptive details about the font and let you use 
these attributes as filters. Like the ANSI designation, this information is provided manually by the
font designers. The five attribute filters are next on the toolbar: Sans Serif, Serif, Fixed Space, 
Script, and Decorative & Other. 

A “serif” font has little extrusions at the tips and ends of each character¾for example, Courier or
Times New Roman. The term "sans serif" (French for "without serifs") refers to fonts that lack 
these extrusions¾for example, Arial or the System font.

Fixed space fonts such as Courier allot a fixed amount of horizontal space for each character. 
They are useful when you need to line up columns of numbers. Variable spaced fonts such as 
Times New Roman allot a varying amount of horizontal space for each character, depending on 
what it needs. So, for example, the letter “i” takes up less space than the letter “w”.

Script fonts are designed to look like cursive handwriting. The last category, "Decorative & 
Other" includes all manner of unique-looking and special-purpose fonts.

View Selected

The final button on the tool bar is “VS”, which stands for “View Selected”. This feature lets you 
compare a selected subset of the fonts on your system. If you move the mouse across the font 
display window, you’ll see a focus rectangle follow the mouse up and down, surrounding each 
font in turn. You can use standard item selection controls such as a left mouse button click to 
select a single entry. Selected fonts are highlighted in reverse color. Hold the Ctrl key while 
clicking to select or de-select a font without affecting other fonts. You can also select a font, then
hold down the Shift key and click on another font to select a range. Once you’ve selected the 
fonts you want, click on the View Selected button to display only those fonts you selected. The 
View Selected command is also available from the Options menu.

When you have finished selecting the fonts that interest you and adjusting the test string to your liking, 
you can print the font names and sample strings by selecting File|Print from the pull-down menu. If the 
test string is too long to fit on the page, it will be cut off. The print command will print whatever is 
currently viewable by scrolling the font window, so be careful with this function when displaying lots of 
fonts. Otherwise you may end up with many pages of unwanted printout.

For details on a number of the font attributes discussed above, look in Font Terminology

Note that all the controls on the toolbar are also accessible via the Display Settings dialog box.



Font Window
When you first launch FontViewer you'll see a list of font names on the left side of the window, 
and a sample of each font on the right. FontViewer divides the fonts on your system into two 
main categories: TrueType and Bitmap/Other. TrueType fonts are stored as a set of rules, and 
can be scaled to any size while maintaining a smooth shape. The TrueType standard also 
provides a way for Windows programs to access detailed information about a font.

Bitmapped fonts are defined pixel-by-pixel for one or more predefined sizes, and cannot be 
smoothly scaled. They were the first type of font available on computers, but are used 
infrequently today. FontViewer's "Bitmap/Other" category also includes non-TrueType scalable 
fonts such as Adobe Type 1 fonts, which are designed for use on multiple platforms.

You may press the right button on your mouse at any time to bring up the Option menu, or access 
many of the features of FontViewer via the toolbar.

Displaying Fonts in Greater Detail

You may want see more of a font than you can see in the regular FontViewer window. One such 
time is when you look at non-ANSI character sets in FontViewer's main window. You’ll notice 
that in most cases, you won't see the non-ANSI characters in the test string unless you've 
created a special test string that uses high characters. 

However, you can also view a font's character set by placing the mouse cursor over the font, 
right clicking to bring up the pop-up Options menu, and then choosing "Show Character Set". 
You can also bring up this display by clicking on the font to select it, and then choosing Options|
Show Character Set from the pull-down menu. FontViewer displays character sets in a 16x16 
grid. Though all character sets define a continuous range of at most 256 characters, not all 
characters within this range need to be defined. FontViewer grays out the cells for characters 
outside the font's range and uses a default character (usually a rectangle or line) for undefined 
characters. 

If you want to view only the most commonly used Latin characters, select "Show 
Alphanumerics". This will show the upper and lower case letters, as well as all ten digits and a 
sample of various punctuation marks. For a symbol font, this option shows the characters or 
symbols at the positions corresponding to the letters and numbers.



Menus

FontViewer offers several pull-down menus:

File
Options
Help

The File Menu

The File menu allows you to print all currently displayed fonts to your printer. Be careful using this 
option, as it can produce quite a number of pages of output when lots of fonts are displayed. Printing a 
list of fonts is useful because often you’ll get more detail in printed fonts than in the fonts displayed on 
your screen.

The File menu also provides the Exit selection, which lets you exit from FontViewer.

The Options Menu

The Options Menu, available both via the regular pull-down menu at the top of the FontViewer window, 
as well as via a click on your right mouse button, exposes a number of useful functions.

The first selection on this menu brings you to the Display Settings dialog box.

The next two selections allow you to display the currently highlighted font in one of two ways. 
The Show Character Set option pops up a window displaying the currently highlighted font in a 16x16 
grid so you can see all the characters in the font. Though all character sets define a continuous range 
of at most 256 characters, not all characters within this range need to be defined. FontViewer grays out
the cells for characters outside the font's range and uses a default character (usually a rectangle or 
line) for undefined characters. As you move your mouse across the grid, a display in the lower left 
corner of the window will show you the numeric ASCII value of the character the mouse cursor is over, 
as well as what keystroke or keystrokes you need to make to get that character in a word processing 
package. An “Alt xxxx” keystroke means you need to hold the Alt key down while entering the “xxxx” 
number on the numeric keypad of your keyboard. Clicking anywhere in the window, including on the 
OK button, will close the window and return you back to the main FontViewer font display.

The Show Alphanumerics option pops up a window which shows three lines of text in the currently 
highlighted font. The first line is all the upper case characters, A-Z, of the font. The second line is the 
lower case equivalent of the first line, a-z. The last line shows all ten digits, as well as a smattering of 



punctuation characters. Clicking anywhere in the window, including on the OK button, will close the 
window and return you back to the main FontViewer font display.

The View Selected option performs the same action as the View Selected button on the toolbar.

The Help Menu

The Help Menu lists Contents, which brings you to the contents section of this help file, while About 
FontViewer shows you the version number and copyright of the FontViewer utility.



Support for FontViewer
Support for the free utilities offered by PC Magazine can be obtained electronically in the discussion 
area of PC Magazine’s Web site. Go to the URL http://www.pcmag.com/discuss.htm and select the 
Utilities area. You can also access the Utilities discussion area from the utility’s download page. The 
authors of current utilities generally monitor the discussion area every day. You may find an answer to 
your question simply by reading the messages previously posted. If the author is not available and you 
have a question that the sysops can't answer, the editor of the Utilities column, who also checks the 
area each day, will contact the author for you.



Display Settings

The Display Settings dialog box, which can be called up via the Options Menu, or via the F2 key at any 
time, lets you control which fonts FontViewer will display in the Font Window. The controls in this dialog 
box are identical to those found on the toolbar :

· String to Display and Font Size 
· Style Variations 
· Type of Font 
· Character Set 
· Attribute Filters 

Also, pressing the Default button will restore the FontViewer Display Settings to the ones shown in the 
dialog box above.




