
##@QUERY_PRJ_USER [[Author]]#1$2+3 Contents
##--BEGIN-- (((@QUERY_APPL_MODEL == VALUE_DIALOG) && 
@QUERY_APPL_DLGCLIENT_MENU) || (@QUERY_APPL_MODEL != 
VALUE_DIALOG))
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File Menu
Edit Menu
Search Menu##@QUERY_APPL_MODEL == VALUE_MDI
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Help Menu
##--END-- (((@QUERY_APPL_MODEL == VALUE_DIALOG) && 
@QUERY_APPL_DLGCLIENT_MENU) || (@QUERY_APPL_MODEL != 
VALUE_DIALOG))##(((@QUERY_APPL_MODEL == VALUE_DIALOG) && 
@QUERY_APPL_DLGCLIENT_MENU) || (@QUERY_APPL_MODEL != 
VALUE_DIALOG))##@OPT_APPL_TOOLBAR 3
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##--BEGIN-- (@QUERY_APPL_MODEL != VALUE_DIALOG)
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Copying Text
Deleting Text
Exiting
Edit Window##@OPT_APPL_DRAGDROP
Drag/Drop from the File Manager##@OPT_APPL_PRINTING
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##--END-- (@QUERY_APPL_MODEL != VALUE_DIALOG)
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1# main_index
2$ Help Index
3+ index:0005



#4 For information on how to use Help, press F1 or select Using Help from the Help 
menu.

4# index_info



#5$6+7Edit Menu

The Edit menu provides commands to undo edits, access the clipboard, and to delete 
text.

Undo Undo the previous operation.
Cut Delete selected text and move it to the clipboard.
Copy Copy selected text to the clipboard.
Paste Move text from the clipboard to the current document.
Clear All Delete all text in document.
Delete Delete selected text.

5# menu_edit
6$ Edit Menu
7+ commands:010



#8$9+10File Menu

The File menu provides commands for creating new files, opening existing files, 
saving files, printing files, and exiting the application.
##@QUERY_APPL_MODEL == VALUE_MDI 2
New Create a new, untitled, document.
Open Open an existing file.##@QUERY_APPL_MODEL == VALUE_SDI 2
New Create a new, untitled, document.
Open Open an existing file.
Close Close the current document.
Save Save the current document if its contents have changed.
Save As Save the current document under a new name.##OPT_APPL_PRINTING 
3
Print Print the current document.
Print Preview View a sample printout of the current document.
Print Setup Set printer characteristics.##@QUERY_PRJ_NAME [[Target]]
Exit Exit [[Target]] application.

8# menu_file
9$ File Menu
10+ commands:020



#11$12+13Search Menu

The Search menu provides commands to find and replace text.

Find Find a pattern of text.
Replace Replace one pattern of text with another.
Next Find and/or replace the next occurrence of text pattern.

11# menu_search
12$ Search Menu
13+ commands:030



##--BEGIN-- @QUERY_APPL_MODEL == VALUE_MDI#14$15+16Window Menu

The Window menu provides commands to control the position and layout of 
application's windows.

Cascade Resize and position all windows in an overlapping pattern.
Tile Resize and position all windows in an non overlapping pattern.
Arrange Icons Align all iconized windows along a grid.
Close All Close all windows.

14# menu_windows
15$ Windows Menu
16+ commands:040



##--END-- @QUERY_APPL_MODEL == VALUE_MDI#17$18+19Help Menu

The Help menu provides access to the help system and the about dialog.

Contents Help topic contents.

17# menu_help
18$ Help Menu
19+ commands:040



#20$21+22K23Copying Text

To copy text to a document from the clipboard, position the cursor at the desired 
insertion point, and choose Edit|Copy from the menu.

20# proc_copying_text
21$ Copying Text
22+ procedures:010
23K copy;clipboard



#24$25+26K27Deleting Text

To delete text from a document, select the text, and choose Edit|Cut or Edit|Delete 
from the menu.    Cut will put the deleted text in the clipboard, and Delete will simply 
delete it.

24# proc_deleting_text
25$ Deleting Text
26+ procedures:020
27K delete;clipboard



#28$29Exiting

To exit the application, choose File|Exit from the menu.

28# proc_exiting
29$ Exiting



#30$31 Edit Window

The edit windows in this application allow reading, editing, printing and saving text 
files up to 64K characters in size.

30# client_window
31$ Edit Window



##--BEGIN-- @OPT_APPL_DRAGDROP#32$33 Drag/Drop from the File Manager
##@QUERY_PRJ_NAME [[Target]]
A file can be opened into an editor in the application by dragging the file from the File
Manager, and dropping it on [[Target]]'s main window.

32# drag_drop
33$ Drag/Drop from the Program Manager



##--END-- @OPT_APPL_DRAGDROP##--BEGIN-- @OPT_APPL_PRINTING#34$35 Printing

There are three commands on the File menu which support printing of documents 
from the application.    File|Print Setup is used to select and configure a printer device.
File|Print Preview displays a special preview window which shows how the document 
will appear when printed.    File|Print causes the current document to be printed.

34# print
35$ Printing



##--END-- @OPT_APPL_PRINTING#36$37+38Edit Copy Command

The Edit|Copy command leaves the selected text intact and places an exact copy of it
in the clipboard.    To paste the copied text into another document, choose Edit|Paste.

36# CM_EDITCOPY
37$ Edit Copy Command
38+ menu_edit:020



#39$40+41Edit Cut Command

The Edit|Cut command removes the selected text from your document and places the
text in the clipboard.    Choose Edit|Paste to paste the cut text into another document.
The text remains selected in the clipboard, and can be pasted multiple times. 

39# CM_EDITCUT
40$ Edit Cut Command
41+ menu_edit:030



#42$43+44Edit Paste Command

The Edit|Paste command inserts the text currently selected in the clipboard into the 
current window at the cursor position. 

42# CM_EDITPASTE
43$ Edit Paste Command
44+ menu_edit:040



#45$46+47Edit Undo Command

The Edit|Undo command restores the file in the current window to the way it was 
before your most recent edit operation.    Undo inserts any characters you deleted, 
deletes any characters you inserted, replaces any characters you overwrote, and 
moves your cursor back to a prior position.

45# CM_EDITUNDO
46$ Edit Undo Command 
47+ menu_edit:050



#48$49+50Edit Clear All Command

The Edit|Clear All command deletes the entire contents of the current document.    
Use Edit|Undo to restore the contents.

48# CM_EDITCLEAR
49$ Edit Clear All Command 
50+ menu_edit:060



#51$52+53Edit Delete Command

The Edit|Delete command deletes the currently selected text from the current 
document.    The text is not placed in the clipboard.    Use the Edit|Undo command to 
restore the text.

51# CM_EDITDELETE
52$ Edit Delete Command 
53+ menu_edit:070



#54$55+56File Close Command

File|Close closes the currently active window.

54# CM_FILECLOSE
55$ File Close Command
56+ menu_file:010



#57$58+59File Exit Command
##@QUERY_PRJ_NAME [[Target]]
The File|Exit command exits [[Target]].    If you've modified documents without saving,
you'll be prompted to save before exiting.
##@QUERY_APPL_MODEL == VALUE_MDI

57# CM_EXIT
58$ File Exit Command
59+ menu_file:020



#60$61+62File New Command##@QUERY_APPL_MODEL == VALUE_SDI

60# CM_MDIFILENEW
61$ File New Command
62+ menu_file:030



#63$64+65File New Command

The File|New command opens a new, untitled document, and makes it the active 
window. The application prompts you to name untitled documents when they are 
closed.
##@QUERY_APPL_MODEL == VALUE_MDI

63# CM_FILENEW
64$ File New Command
65+ menu_file:030



#66$67+68File Open Command##@QUERY_APPL_MODEL == VALUE_SDI

66# CM_MDIFILEOPEN
67$ File Open Command
68+ menu_file:040



#69$70+71File Open Command

The File|Open command displays the Open a File dialog box so you can select a file to
load into a new document window.    You can also create a new document by naming 
a file that doesn't currently exist.

69# CM_FILEOPEN
70$ File Open Command
71+ menu_file:040



##--BEGIN-- @OPT_APPL_PRINTING#72$73+74File Print Command

The File|Print command prints the contents of the active window.    Use File|Print 
Preview to see how the document will be laid out on printer pages.    Use File|Print 
Setup to select a printer, and to set printer options.

72# CM_FILEPRINT
73$ File Print Command
74+ menu_file:050



#75$76+77File Print Preview Command

File|Print Preview opens a special window that shows how the active document will 
appear when printed.    The preview window shows one or two pages of the active 
document as they would be laid out on printer pages.    Controls on the window allow 
you to page through the pages of the document.

75# CM_FILEPRINTPREVIEW
76$ File Print Preview Command
77+ menu_file:060



#78$79+80File Print Setup Command

The File|Printer Setup command displays the Printer Setup dialog box which allows 
you to select and configure the printer to be used to print documents in the 
application.

78# CM_FILEPRINTERSETUP
79$ File Print Setup Command
80+ menu_file:070



##--END-- @OPT_APPL_PRINTING#81$82+83File Save Command

The File|Save command saves the document in the active window to disk. If the 
document is unnamed, the Save File As dialog box is displayed so you can name the 
file, and choose where it is to be saved.

81# CM_FILESAVE
82$ File Save Command
83+ menu_file:080



#84$85+86File Save As Command

The File|Save As command allows you to save a document under an new name, or in 
a new location on disk.    The command displays the Save File As dialog box.    You can 
enter the new file name, including the drive and directory.    All windows containing 
this file are updated with the new name.    If you choose an existing file name, you are
asked if you want to overwrite the existing file. 

84# CM_FILESAVEAS
85$ File Save As Command
86+ menu_file:090



#87$88+89Search Find Command

The Search|Find command searches the current document for a text pattern.    The 
command displays the Find dialog which controls the search process.    Options in the 
dialog determine whether only whole words are to be matched, whether the case of 
characters is significant, and whether the search should be conducted forwards or 
backwards through the document.    As each match is found, it is highlighted in the 
document.

87# CM_EDITFIND
88$ Search Find Command
89+ menu_search:010



#90$91+92Search Next Command

The Search|Next command repeats the last Find or Replace operation.

90# CM_EDITFINDNEXT
91$ Search Next Command
92+ menu_search:020



#93$94+95Search Replace Command

The Search|Replace command searches the current document for a text pattern, and 
replaces occurrences of the of the pattern with new text.    The command displays the
Replace dialog which controls the search/replace process.    Options in the dialog 
determine whether only whole words are to be matched, and whether the case of 
characters is significant.    The dialog is also used to specify the pattern to search for, 
and the text to replace occurrences with.

93# CM_EDITREPLACE
94$ Search Replace Command
95+ menu_search:030



##--BEGIN-- @QUERY_APPL_MODEL == VALUE_MDI#96$97+98Window Arrange Icons 
Command

The Window|Arrange Icons command arranges all iconized windows into rows along 
the bottom of the application's main window.

96# CM_ARRANGEICONS
97$ Windows Arrange Icons Command
98+ menu_window:010



#99$100+101Window Cascade Command

The Window|Cascade command arranges all document windows from the top-left 
position of the application's main window so that the title bar of each is visible.

99# CM_CASCADECHILDREN
100$ Windows Cascade Command
101+ menu_window:020



#102$103+104Window Close All Command

The Window|Close All command closes all document windows open in the application.

102# CM_CLOSECHILDREN
103$ Windows Close All Command
104+ menu_window:030



#105$106+107Window Tile Command

The Window|Tile command arranges all document windows side-by-side in a non-
overlapping pattern.

105# CM_TILECHILDREN
106$ Windows Tile Command
107+ menu_window:040



##--END-- @QUERY_APPL_MODEL == VALUE_MDI#108$109+110Window Help table of 
contents

The Help|Contents displays the help contents page.

108# CM_HELPCONTENTS
109$ Help table of contents
110+ menu_help:010




