
Editor Shortcut Keys
The Editor supports shortcut keys for most frequently used functions.
For the key representation,refer to the manual.

Shortcut Keys Common to All Modes
Shortcut Keys for Editing Text Mode
Shortcut Keys for Viewing Text Mode
Shortcut Keys for Editing Hexadecimal Mode
Shortcut Keys for Viewing Hexadecimal Mode





Shortcut Keys Common to All Modes
The keys and key combinations listed below are available in all editor modes.

Up Arrow
Moves the cursor up by one line.

Down Arrow
Moves the cursor down by one line.

Right Arrow
Moves the cursor right by one character.

Left Arrow
Moves the cursor left by one character.

Ctrl +Up Arrow
Moves the cursor up,skipping the number of lines specified for "The Number of Lines the 
Cursor Moves at High Speed"in the Environment for Editor command of the Option menu.

Ctrl +Down Arrow
Moves the cursor down,skipping the number of lines specified for "The Number of Lines the 
Cursor Moves at High Speed"in the Environment for Editor command of the Option menu.

Ctrl +Right Arrow
Moves the cursor right,skipping the number of characters specified for "The Number of 
Columns the Cursor Moves at High Speed"of the Environment command in the Option menu.

Ctrl +Left Arrow
Moves the cursor left,skipping the number of characters specified for "The Number of 
Columns the Cursor Moves at High Speed"of the Environment command in the Option menu.

Page Up
Displays the previous page ("windowful")of text.

Page Down
Displays the next page ("windowful")of text.

F1
Executes the Contents command of the Help menu.

F2
Executes the Search Again command of the Locate menu.

F4
Executes the Goto Line command of the Locate menu.

Alt
Selects the first menu on the menu bar.

Alt +F4
Executes the Close command of the Control menu.If multiple edit windows are activated,all 



the edit windows are terminated before the editor is terminated.

Ctrl +F4
Executes the Close command of the File menu.

Ctrl +Home
Executes the Top command of the Locate Line menu.

Ctrl +End
Executes the Bottom command of the Locate Line menu.

Shift +F4
Executes the Tile command of the Window menu.All the edit windows are displayed on one 
screen.

Shift +F5
Executes the Cascade command of the Window menu.All the edit windows are cascaded.



Shortcut Keys for Editing Text Mode
The keys and key combinations listed below are available when editing text.

Delete
Deletes the selected text or the character at the current cursor position if no selection range
has been marked.

Insert
Switches between insert mode and overwrite mode.

Backspace
Deletes the preceding character.

Esc or Ctrl +Break
Cancels the previous character input or range selection.

Enter
Inserts a new line in insert mode,or moves the cursor to the beginning of the next line in 
overwrite mode.

Home
Moves the cursor to the beginning of the line.

End
Moves the cursor to the end of the line.

F3
Executes the Replace Again command of the Edit menu.

F5
Executes the Pair command of the Locate Line menu.

Ctrl +Z or Alt +Backspace
Executes the Redo command of the Edit menu.

Shift +Up Arrow
Performs upward range selection.

Shift +Down Arrow
Performs downward range selection.

Shift +Right Arrow
Performs rightward range selection.

Shift +Left Arrow
Performs leftward range selection.

Ctrl +Shift +Up Arrow
Performs upward range selection,skipping the number of lines specified for "The Number of 
Lines the Cursor Moves at High Speed"in the Environment for Editor command of the Option 
menu.



Ctrl +Shift +Down Arrow
Performs downward range selection,skipping the number of lines specified for "The Number 
of Lines the Cursor Moves at High Speed"in the Environment for Editor command of the 
Option menu.

Ctrl +Shift +Right Arrow
Executes rightward range selection,skipping the number of characters specified for "The 
Number of Columns the Cursor Moves at High Speed"of the Environment command in the 
Option menu.

Ctrl +Shift +Left Arrow
Executes leftward range selection,skipping the number of characters specified for "The 
Number of Columns the Cursor Moves at High Speed"of the Environment command in the 
Option menu.

Ctrl +Page Up
Scrolls the window to the left.

Ctrl +Page Down
Scrolls the window to the right.

Ctrl +C
Executes the Copy command of the Edit menu.

Ctrl +V
Executes the Paste command of the Edit menu.

Ctrl +X
Executes the Cut command of the Edit menu.

Ctrl +Delete
Deletes text from the current cursor position to the end of the line.



Shortcut Keys for Viewing Text Mode
The keys and key combinations listed below are available when viewing text.

Enter
Moves the cursor to the beginning of the next line.

Home
Moves the cursor to the beginning of the line.

End
Moves the cursor to the end of the line.

F5
Executes the Pair command of the Locate menu.

Ctrl +C
Executes the Copy command of the Edit menu.

Ctrl +Page Up
Scrolls the window to the left.

Ctrl +Page Down
Scrolls the window to the right.



Shortcut Keys for Editing Hexadecimal Mode
The keys and key combinations listed below are available when editing binary data.

Backspace
Moves the cursor left by one character when the cursor is in the character display area.

Esc or Ctrl +Break
Cancels the previous character input.

Enter
Moves the cursor to the beginning of the next line.

F3
Executes the Replace Again command of the Edit menu.

Ctrl +Z or Alt +Backspace
Executes the Redo command of the Edit menu.

Shift +Esc
Switches the cursor between the hexadecimal display area and the character display area.



Shortcut Keys for Viewing Hexadecimal Mode
The keys and key combinations listed below are available when viewing binary data.

Enter
Moves the cursor to the beginning of the next line.

Shift +Esc
Switches the cursor between the hexadecimal display area and the character display area.



Selecting the Text to Be Edited
Certain functions and commands operate on selected text.This topic explains the various 
ways of selecting text.
Text can be selected in line mode (standard mode)or box mode,explained below.
Either the mouse or the SHIFT key plus a cursor key can be used to select text.The selected 
text is displayed in reverse video.

Selecting and specifying a character string and line
To select and specify a character string and line,indicate the start and end point of the 
process range within the text edit area and line number display area.

Selecting text with the mouse
Selecting a character string in a text line
Move the mouse cursor to the first character of the string and click the left mouse 
button.Then,drag the mouse cursor to the end of the string and release the mouse button.

Selecting an area ranging from a midpoint of a text line to a midpoint of another 
text line
Move the mouse cursor to the first character of the area and click the left mouse 
button.Then,drag the mouse cursor to the end point on another text line and release the 
mouse button.

Selecting a text line
Move the mouse cursor to the beginning of the text line,and click the left mouse 
button.Then,drag the mouse cursor to the end of the line and release the mouse button.
Alternatively move the mouse cursor to the line number display area and click on the 
desired line number.
Move the mouse cursor to the line number display area and drag the mouse cursor to the 
upper or lower one line.

Selecting two or more text lines
Move the mouse cursor to the beginning of the first line,and click the left mouse 
button.Then,drag the mouse cursor so as to include the desired lines and release the mouse 
button.
Alternatively move the mouse cursor to the line number display area,and click the left 
mouse button.Then,drag the mouse cursor to the last line number in the desired range and 
release the mouse button.

Changing the selected range
To reduce or enlarge a selected range without changing the start point,move the cursor to 
the desired end point.Then,press the SHIFT key and the left mouse button.

Selecting a rectangular block of text
Select Box Mode on the Edit menu.When Box Mode is set a check is put before the command
name.To return from box mode to line mode,select Box Mode again.
To select a rectangular block,move the mouse cursor to the first character,and click the left 
mouse button.Then,drag the mouse cursor to the end point and release the mouse button.

Selecting text using the keyboard



Move the cursor to the start point of the text.Then,press the SHIFT key and move the cursor 
to the desired end point using cursor keys,keeping the SHIFT key depressed.When the SHIFT 
key is released,the range of selected text is determined.
The selected text can be changed by pressing the SHIFT key and a cursor key.
In selecting text,the cursor can be moved quickly by pressing the CTRL key,SHIFT key,and a 
cursor key.



Canceling and Reexecuting the Operation Last Executed
Previously executed edit operations can be canceled ("undone")to restore the text before the
operations were performed.The canceled edit operations can be reexecuted ("redone").The 
number of operations that can be canceled or restored can be set when a file is opened,or 
by the Environment for Editor command on the Options menu.

To cancel the operation last executed:
Select the Undocommand of the Edit menu.

To reexecute the operation last executed:
Select the Redocommand of the Edit menu.



Deleting Text
Selected text can be deleted.It is not copied to the clipboard.

To delete text:
1 Select the text to be deleted.
2 Select the Delete command on the Edit menu.Alternatively,press the DEL key.The selected

text is deleted.

See Also:
Delete



Cutting,Copying,and Pasting Text
Selected text can be cut,copied,and pasted by using the clipboard.

To cut text:
1 Select the text to be cut.
2 Select the Cutcommand of the Edit menu.Alternatively,press the CTRL +X keys.

The selected text is removed and stored in the clipboard.

To copy text:
1 Select the text to be copied.
2 Select the Copycommand of the Edit menu.Alternatively,press the CTRL +C keys.

The selected text is copied to the clipboard.

To paste text:
1 Move the cursor to the location where the text is to be inserted.
2 Select the Pastecommand of the Edit menu.Alternatively,press the CTRL +V keys.

The text stored on the clipboard is inserted at the cursor position.



Searching for and Changing Character Strings
To detect a particular character string in a text,execute the Findcommand on the Locate 
menu.To replace a particular character string with another character string,execute the 
Replacecommand on the Edit menu.
To repeat the search or change most recently executed,execute the Find Againcommand on 
the Locate menu or Replace Againcommand on the Edit menu.



Specifying Character Strings
When character strings are searched for or replaced,the character string can be specified by 
its value or pattern.This topic explains the following character string features:
- Character type
- Character definition
- Specifying character strings by a regular expression

1)Character type
The following character types are available:
Blank character
Alphanumeric character:A to Z,a to z,0 to 9,$,@,#
Symbols:Characters other than alphanumeric characters

2)Character definition
The following character definitions are available:
Open character string:An alphanumeric string that does not include a blank character or 
symbol
Quoted string:All characters enclosed by quotation marks ('),When the string includes 
quotation marks,specify two quotation marks within the quoted string.
A character string containing a blank character or symbol that cannot be specified in an 
open character string can be specified within a quoted string.
Hexadecimal character string:A character string enclosed by quotation marks and followed 
by H (0 to 9,A to F,and a to f of alphanumeric characters)
Word:Character string separated by a blank character,symbol except -or _,or a character of a
different type
Prefix:Character string containing the first character of a word
Suffix:Character string containing the last character of a word

Examples
Open character string:ABC,12345
Quoted character string:'ABC','+/*45',''(blank character),'''Hello'''(a set of quotation marks)
Hexadecimal character string:'01'H

Note:
- The line feed character and carriage return character (0x0d,0x0a)are not searched for.

('0d0a'h):An error message is "A character string to be searched is not found."

3)Specifying character strings by a regular expression
A regular expression is a character string that may include special symbols.Special symbols 
and a character string are specified in combination as shown below:

open-character-string, open-character-string
'quoted-character-string', 'quoted-character-string',

{(,(}{'hexadecimal-character-string'H ,}c [[&,|]{'hexadecimal-character-string'H ,}]{(,(}
%, %,
_, _



Parameters
(:Indicates the beginning of a regular expression.
):Indicates the end of a regular expression.
%:Indicates a set of characters.The number of characters can range from zero to the 
maximum number of columns of a single line minus 1.
_:Indicates a single character.The symbol does not represent a blank character or a symbol 
(except -or _).
&:Indicates that character string expressions (consisting of a character string,%,and _)before
and after the symbol are both included.
|:Indicates that a character string expression (consisting of a character string,%,and _)before
or after the symbol is included.

Notes:
- {}enclosing operands mean that one of the operands separated by a slash (/)must be 

selected.An operand enclosed by []can be omitted.
- Special symbol %cannot be used on its own.
- Multiple %(%%)are assumed as a single %.
- A blank character outside a quoted character string in a regular expression is 

ignored.Exceptions are a blank character for specifying a prefix,suffix,or word and a blank 
character for specifying open character string H immediately after a quoted character 
string.

See Also:
Find
Replace



Specifying the Line Number Input Field of a Command
One of the following can be specified in the line number input field of a command:
- Line number
- Offset from a particular line
- Offset from the first line of the data being edited
- Offset from the last line of the data being edited

1)Entire syntax
The syntax for inputting line numbers is:
line-number/@S/@E +line-count/-line-count
Where:
/ Indicates only one of the separated items can be used.
The other parameters are explained in the following paragraphs.

2)    Line-number
A numeric value from 1 to 99999999 can be specified as a line number.Some commands 
require an existing line number.
The line number to be specified is determined by the information specified in the Line 
Number Type of the Display Format command of the View menu.If absolute line numbers 
have been selected in the Display Format command of the View menu,you must input 
them.If relative line numbers have been selected,you must input them.
Absolute line numbers are line numbers within the text.
Relative line numbers are relative locations from the first line of text.

3)First line format
@S indicates the first line of the text.

4)Last line format
@E indicates the last line of the text.

5)Relative format
+line-count:Indicates a line that follows the reference line by an offset of line-count.
-line-count:Indicates a line that precedes the reference line by an offset of line-count.
A numeric value from 1 to 99999999 can be specified as the line count.
The relative format can be specified alone,only when the end point of a target processing 
range is being specified.
Goto,Search and Replace commands will accept a line-count that goes beyond either the 
first or the last line.In such cases the lines are treated as the first or last line.

6)Combined line format
The relative format is added to one of the preceding specification formats (line number 
format,first line format,last line format):
Syntax:
line-number+line-count:Indicates the line that is an offset of line-count after line-number.
line-number_line-count:Indicates a line that is an offset of line-count before line-number.
@S+line-count:Indicates the line that is an offset of line-count from the first line.



@E_line-count:Indicates the line that is an offset of line-count from the last line.



Moving to a Particular Location
The following can be used to move to a particular location:Goto,Top,and Bottom commands 
of the Locate menu,scroll bar,HOME key,END key,PAGE UP key,PAGE DOWN key,and cursor 
keys.

See Also:
Top
Bottom
Goto Line



Moving to a Particular Location of a Specified File
When the Tag Jump command of the Locate menu is used,a character string starting from 
the current cursor position is read as the target file name and line number.The command 
moves the cursor to the specified line in the specified file.

To execute a tag jump:
1    Move the cursor to the beginning of the destination file name.
2    Select the Tag Jump command on the Locate menu.

The format of the file name and line number for the tag jump is:
file-name (line-number)
Example:TEST.COB (100)

Notes:
- The line number is separated from the file name by a blank character,comma,or 

parentheses.
- If no line number is specified,the cursor is placed at the beginning of the file.
- If the file name does not contain a folder,the file is assumed to be in the current folder.

See Also:
Tag Jump



Editing with Command Keys
A command can be assigned to a combination of the CTRL key and an alphabetic key.Editing 
with the command key can be executed faster than the conventional editing with the 
keyboard and mouse.Use the Customize Command Key command on the Option menu to set
up command keys.

See Also:
Customize Command Key



Changing an Edit Window
Two or more files can be opened at the same time,and texts in different windows can be 
edited.

To change an edit window:
- Select an edit window using the mouse.
- Select a file name from the list on the Window menu.
- Select the Cascade or Tile command of the Window menu.
- Select another edit window by pressing the CTRL and TAB keys.



File Details
This topic describes the file details to which the editor is sensitive.

1)File type
The editor can edit files of the following types:
Text file:Text format files of COBOL,FORTRAN,C,etc.
Binary file:File containing non-text data such as a load module

2)File information related to the file extension
In PowerFRAMEVIEW the file extension defines the data type,the line format (fixed 
length,variable length),the maximum number of columns in a line,the presence of line 
numbers,and other information of the file.The New and Open commands of the File menu 
open a window according to the defined information.
These definitions can be added or deleted by using "Set File Information (PowerFRAMEVIEW 
Editor)"in the Setup Environment command of PowerFRAMEVIEW.
The following explains the details of the file information:

Data Type
Text type of the file is set.

Line format
Two line formats are available:variable length and fixed length.
In variable length format,text lines have different lengths.When text is written to file,a new-
line code is written at the end of each line.In this format,text occupies only the space it 
requires.The file size can be minimized.
In fixed length format,text lines have identical lengths.When text is written to file,all lines 
are stored with an identical length.

Maximum number of columns of a single line
Determines the maximum number of columns in a single line.The editor can create lines up 
to this length.

Line number position
You can specify None,Top,or Bottom as the position of line numbers within the text.Top 
indicates the line numbers are at the beginning of the lines,Bottom indicates that the line 
numbers are at the end of the lines.
Line numbers in the text are often referred to as absolute line numbers.

Line number length
If the line numbers are included in the text the line number length needs to be specified as 6
or 8.

See Also:
New
Open



Printing a File
The entire text being edited or the selected text is printed.
To print a file:
1 Select the text to be printed.

To print the whole of the text being edited,do not select any text.
To print part of the text being edited,select the range of text to be printed.

2 Select the Print command on the File menu.
3 Set any required options in the dialog box.Then,press the OK button.

See Also:
Print





New
This command displays the edit window for creating a new file.

Extension
Select the extension of the file to be created.
The extension can be added or deleted by using "Set Extension"in the Setup Environment 
function of PowerFRAMEVIEW.File informationis associated with extensions.The file 
information for each extension is set by using "Set File Information for PowerFRAMEVIEW 
Editor"in the Setup Environment function.
You can set file information for each extension in "Set File Information(PowerFRAMEVIEW 
Editor)"of Setup Environment command.To learn more about the file information,please refer
to related item 'File'.
If New is invoked from the Tool menu of Development Manager,the extension displayed is 
that associated with the specified file type.Otherwise the previously specified extension is 
displayed as the default.
The file information items when "(default)"is specified are as follows:

Maximum Column: "Maximum Column"defined by the Environment (Basis 
Status)command.When PowerFRAMEVIEW is installed,223 is defined.

Line number: None
Line format: Variable 

Undo Level
Specify restorable Max Level by using the [Undo]Command or [Redo]Command.
Select the check box,then Max Restored Level can be specified in the range of 0 to 99.
When the check box is not selected,[Undo]and [Redo]Commands are not available.
If 0 is specified,the value specified by the "Max Restore level of [Undo]/[Redo]"of the 
[Environment for Editor]Command(Basic Status)is regarded as the default.

Tab Interval
Specify the length of the Tab Interval with 0 or an integer from 2 to 99.
If 0 is specified,the value specified in the "Tab Interval"of the Environment for Editor (Basic 
Status)command is used as the default.

See Also:
File Details
Environment (Basic Status)



Open
This command opens the window for updating or displaying a file.

File Name
Enter or select the name of the file to be opened.
"*.*"is displayed as the default.
When the Editor is invoked from Development Manager,with "Specify Execution 
Options"checked,the selected file names are displayed.

List files of type
Select a kind of extension to be displayed in the file name list.
File kinds to be displayed in the list are specified in "Set Extension"of the PowerFRAMEVIEW 
Setup Environment.

Read Only
Specifying is required when a file is opened in the display mode.
When the file is edited checking "Specify Extension Options"command of the development 
manager,if specified attribution is Read Only or System or Hidden File,Read Only check box 
is checked as the Default.

Explanation of the option

Setup Environment defined Extension
Specify the attribution of the file to be opened with the extension.
The file information for each extension can be specified by using "Set File Information 
(PowerFRAMEVIEW Editor)"in the Setup Environment command.To learn more about the file 
information,please refer to related item 'File'.
As the default,"(default)"is displayed.For the default,file information obeys the extension of 
the file name.
The extension defines maximum column,existence of line number,line format 
(fixed,variable)and so on as the file information.
The extension can be added or deleted by using "Set Extension"in the PowerFRAMEVIEW 
Setup Environment.
The file information becomes valid in the order as shown below.
(1)The work space definition when the file is managed by PowerGEM
(2)The extension option defined on the Setup Environment 
(3)The default

Line Format: Variable
Maximum Column: "Maximum Column"defined by the [Environment for 

Editor ]command(Basic Status)
Line Number: Absent

Hexadecimal mode
Specify it when the file contents are displayed in hexadecimal mode.

Max Restored Level



Specify restorable Max Level by using the [Undo]Command or [Redo]Command.
Select the check box,then Max Restored Level can be specified in the range of 0 to 99.
When the check box is not selected,[Undo]and [Redo]Commands are not available.
If 0 is specified,the value specified in the "Max Restore level of [Undo]/[Redo]"of the 
[Environment for Editor]Command(Basic Status)is regarded as the default.

Tab Interval
Specify the length of the Tab Interval with 0 or an integer from 2 to 99.
If 0 is specified,the value specified in the "Tab Interval"of the [Environment for 
Editor]Command (Basic Status)is regarded as the default.
Notes:
- If the specified file is not present,the edit window for creating a new file is displayed.
- Up to 14 files can be opened.Whether 14 files can be opened,however,depends on the 

system environment.
- You cannot open a hexadecimal mode window using the New command.

See Also:
File Details
Environment (Basic Status)



Save As
Save As is also invoked when the Close command is used on a new file.Any options specified
in the Close dialog box are passed to the Save As dialog box.
Save As saves all or part of the text being edited into a new file,the file being edited,or 
another file.

File Name
Enter the name of the file into which the text is saved.
As the default,the name of the file being edited is displayed.

List files of type
Select a kind of extension to be displayed in the file name list.
File kinds to be displayed in the list are specified by "Set Extension"in the PowerFRAMEVIEW 
Setup Environment.

Explanation of the option

Replace Existing File
If a specified file name has already existed,this option indicates whether the existing file 
should be replaced.
If the check box is selected,the existing file is replaced when the text is saved.
If a specified file name has already existed when this function is not used,a message to 
confirm whether the existing file should be replaced is displayed.
By default,the existing file is not replaced.

Remove Trailing Blank
For variable length record files this option indicates whether blank characters from the last 
non-blank character to the line feed character are deleted.
If the check box is selected,blank characters at the end of text lines are deleted.
By default,blank characters at the end of text lines are not deleted.

Renumber
Specify whether absolute line numbers (line numbers in the text)are renumbered.
If the check box is selected,absolute line numbers are renumbered.By default,they are not 
renumbered.
For renumbering,enter the initial value and increment value for absolute line numbers in the 
text.
If the initial value and increment value are omitted,the values previously specified before are
used.If renumbering has not been performed,the values determined for basic operation of 
editor are used for renumbering.
Initial value:Enter the initial value with an integer from 1 to 999999 if the length of the 
absolute line number is 6 digits or with an integer from 1 to 99999999 if the length is 8 
digits.
Increment Value:Enter the increment value with an integer from 1 to 32767.

Save Range
Enter the range to be saved.If this option is omitted,the entire text is saved.
For how to specify the save range,see Specifying the Line Number Input Field of a Command.



Notes:
- If the line format is fixed,the option for "Remove Trailing Blank"cannot be selected.
- If the text has no absolute line numbers (line numbers in the text),the "Renumber"option 

cannot be selected.
- If the text is saved into the file being edited,the entire text is saved even if the start 

position and end position are specified.
- If renumber is specified when the text is saved into the file being edited,the text being 

edited is also renumbered.If the text is saved to another file,the text being edited is not 
renumbered.

- If absolute line numbers (line numbers in the text)overflow as the result of renumbering,a 
message is displayed,and the save processing is canceled.Then,renumbering is not 
executed.

- If the file which is being edited is overwritten in "Backup File Creation"of [Environment for  
Editor]Command,the file which has been edited before is saved to "file-name.BAK"in the 
same folder.

- If the text is saved in the file being edited,the restore information (for Undo and Redo)for 
previous edit operations is lost.

- The initial value and increment value specified for renumbering are valid during the 
editing session.

See Also:
Specifying the Line Number Input Field of a Command
Environment (Current Window)
Environment (Basic Status)



Save
This command saves the entire text being edited into a new file or the file being edited.

Notes:
- If the file which is being edited is overwritten in "Backup File Creation"of [Environment for  

Editor]Command,the file which has been edited before is saved to "file-name.BAK"in the 
same folder.

- If the text is saved in the file being edited,the restore information (for Undo and Redo)for 
previous edit operations is lost.

See Also:
Environment (Current Window)
Environment (Basic Status)



Merge
This command inserts an entire file,or part of a file,at the specified position.

File Name
Enter or select,from the Files list box,the name of the file to be imported.

List files of type
Select a kind of extension to be displayed in the file name list.
File kinds to be displayed in the list are specified in "Set Extension"of the PowerFRAMEVIEW 
Setup Environment.

Explanation of the option

Line number type
Enter the line number type of the file to be imported.
Follow the Setup Environment:Follow the line number type setup for the extension of the file 
to be imported.The file information for each extension is set by using "Set File Information 
(PowerFRAMEVIEW Editor)"in the Setup Environment function.
Relative:Relative line numbers (relative positions from the top of the text)are assumed.
Absolute:Absolute line numbers (line numbers in the text)are assumed.
The default is "Follow the Setup Environment."

Line number range
Enter the range of lines to be imported.
If only the From position is specified,only the text line of the From position is inserted.
If this option is omitted,the entire text is imported.
For information on how to specify the line number range,see Specifying the Line Number 
Input Field of a Command.

Column range
Enter the start and end column positions to import only the specified columns.Positions are 
specified by an integer from 0 to the maximum characters per line (record length).
If 0 is specified for the start column position,the first column of the text is assumed.If 0 is 
specified for the end column position,the last column of the text is assumed.
If only the start column position is specified,all the characters from the specified column are 
imported.
If this option is omitted,the entire text is imported.

Insert Line Number
Enter the insert line number.
If this option is omitted,the text is inserted at the line preceding the current cursor position.
For instructions on how to specify the insert position of destination,see Specifying the Line 
Number Input Field of a Command.

Notes:
- If a line beyond the last line of the text is specified for the end line position of the line 

number range,the last line of the text of the file to be imported is used for the last line 
position.



- If the text to be imported contains tabs,the text is imported after expanding the tabs to 
blanks.



Print
This command prints all or a part of the file being edited.

Explanation of Print Range
Specify the text range to be printed.
All: The All text is printed.
select: A certain part is selected and printed.

For how to specify the print range,refer to "How to Input Line Number of 
Command"of the operation procedure.

Relative Line Number
Select whether relative line numbers are printed on the left of the text.
The default is "No"relative line numbers are printed.

Folding
Select whether data that cannot be printed on one line is printed on the next line using word
wrap.
The default is "No"word wrapping is performed.

Hexadecimal
Select whether the text is printed in hexadecimal notation.
The default is "No"text is printed in hexadecimal notation.

Print Range
Enter the text range to be printed.If a range of text is selected when the Print command is 
invoked,the start and end points of the selected range are displayed.
If this option is omitted,the entire text is printed.
For how to specify the print range,see Specifying the Line Number Input Field of a Command.

Notes:
- For hexadecimal Edit/View,texts are printed only in hexadecimal notation.
- If hexadecimal printing is specified,printing relative line numbers,word wrapping,and print 

range cannot be specified.
- If the font information is specified by [Font]Dialog Box,the information is used next time 
again.
- Specify only the value of the List Box in the size item of [Font]Dialog Box.



Information
This command displays file information.

File Name
Displays the full pathname of the file being edited or viewed.
For a new file,"*"is display Displayed.

Data Type
Displays data type of text.For details see File Details.

Line Format
Displays whether the line format of the text is variable or fixed.For details see File Details.

Maximum Column
Displays the maximum columns in a line.
For hexadecimal Edit/View mode,"*"is displayed.For details see File Details.

Line Number Position
Displays the position of absolute line numbers (line numbers in the text),if they are 
present.For details see File Details.

Line Number Length
Displays the length of absolute line numbers (line numbers in the text)if they are present.For
details see File Details.

Global Server Code
Displays the "Global Server Code"setting from "Set Common Information"of 
PowerFRAMEVIEW Setup Environment .For work space files,the code defined for the work 
space is displayed.
If the Global Server Code is not defined,"none"is displayed.



Close
This command terminates the editing or viewing of the file in the current window.
If no changes have been made to the file,the window containing the file is closed.
If changes have been made to the file,or if the file is a new file,the Close dialog box is 
displayed.

Remove Trailing Blank
For variable length record files this option indicates whether blank characters from the last 
non-blank character to the line feed character are deleted.
If the check box is selected,blank characters at the end of text lines are deleted.
By default,blank characters at the end of text lines are not deleted.

Renumber
Indicates whether absolute line numbers (line numbers in the text)are renumbered.
If the check box is selected,absolute line numbers are renumbered.By default,they are not 
renumbered.
For renumbering,enter the initial value and increment value for absolute line numbers in the 
text.
If the initial value and increment value are omitted,the values previously specified before are
used.If renumbering has not been performed,the values determined for basic operation of 
editor are used for renumbering.
Initial value:Enter the initial value with an integer from 1 to 999999 if the length of the 
absolute line number is 6 digits or with an integer from 1 to 99999999 if the length is 8 
digits.
Increment Value:Enter the increment value with an integer from 1 to 32767.

Yes
Press the Yes button to save the file using the options set in the Close dialog box.For new 
files the Save Asdialog box is displayed using the options set in the Close dialog box.

No
Press the No button to close the current file window without saving any changes.

Cancel
Press the Cancel button to return to the current file window.

Notes:
- If the line format is fixed,the option for Remove Trailing Blank cannot be selected.
- If the text has no absolute line numbers (line numbers in the text),the renumber option 

cannot be selected.
- If the absolute line number (line number in the text)overflows as the result of 

renumbering,a message is displayed,and the terminate processing is 
canceled.Then,renumbering is not executed.

- If the text is not rewritten,it is closed without saving.In this case,the Close dialog box is 
not displayed.



Exit
This command closes all the windows,then terminates the editor.If unsaved changes have 
been made to any files,the close dialog box is displayed to inquire whether the text should 
be saved.



Undo
This command sequentially cancels the effects of the edit operations previously executed.
The maximum number of operations that can be canceled is set in the Undo Level field of 
the Environment for Editor (Basic Status).This number can be overridden by specifying a 
non-zero Undo Level in the New or Open dialog boxes.

Notes:
- This command cannot be executed if 0 is specified in both the Undo Level field in the 

Environment for Editor (Basic Status)and the Undo Level for the New or Open dialog box.
- This command cannot be executed if the Save or Save As commands are used to save 

text in the file itself or if the Renumber or Compile commands are executed.The command
cannot be executed because the edit operation history is cleared by these commands.

See Also:
Canceling and Reexecuting the Operation Last Executed
Environment (Basic Status)



Redo
This command reapplies edit operations that have been undone by the Undo command.

Note:
- This command can be executed only when the Undo command has been executed.

See Also:
Canceling and Reexecuting the Operation Last Executed



Cut
This command removes the text in the selected range,and writes it to the clipboard.

See Also:
Cutting,Copying,and Pasting Text (with the clipboard)



Copy
This command copies the text in the selected range to the clipboard.

See Also:
Cutting,Copying,and Pasting Text (with the clipboard)



Paste
This command pastes the contents of the clipboard to the text being currently edited.

See Also:
Cutting,Copying,and Pasting Text (with the clipboard)



Delete
This command deletes the selected text.

Note:
- An error occurs if a new line concatenated after the deletion of a line feed contains more 

than the maximum number of characters allowable per line.

See Also:
Deleting Text (without the clipboard)



Box Mode
This command changes the selection method from the normal line mode to Box Mode.When 
Box Mode is selected,a check mark is placed at the beginning of the command name.Box 
Mode selection creates a rectangle from the point selection is started to the point it is 
ended.Line Mode selection includes all the text on all the lines between the start and end 
points of selection.
To return from Box Mode to line mode,reselect the Box Mode command.



Replace
This command searches for the specified character string,and replaces it with another 
character string.

Find What
Enter a character string to be replaced.Note that the search is case-sensitive.
The last character string that was input for search is displayed as the default.

Replace With
Enter a character string to be used for replacement.Note that the search is case-sensitive.
The last character string that was input for replacement is displayed as the default.

Direction
Select the replacement direction in the text being edited.
Up:Searches upward from the current position 
Down:Searches downward from the current position
If this option is omitted,the value specified before is used.The default for the first 
replacement is "Down."

Replace Range
Select the replace range.
From Cursor Position:If the replacement direction is "Up,"the replace range is from the 
character immediately before the cursor to the first line.If the replace direction is "Down,"the
replace range is from the character immediately after the cursor to the last line.
Range:Replaces the character strings to be searched in the specified line range.
For how to specify the range,see Specifying the Line Number Input Field of a Command.
The default is "From Cursor Position."

Find
The cursor moves to the character string to be replaced.

Replace
The found character string is replaced.

Replace All
All the character strings to be replaced within the specified range are replaced and the 
number of character strings is displayed after they are replaced.

Notes:
- In hexadecimal mode,the search is performed in the display area (dump display area or 

character display area)where the cursor is located.
- If the character string to be searched for is not present in the text being edited,a message

is displayed.
- If the maximum column is exceeded as the result of replacement,a message is 

displayed.Take action by following the instructions of the message.

See Also:
Searching for and Changing Character Strings



Specifying Character Strings
Specifying the Line Number Input Field of a Command



Replace Again
This command successively performs replacement using the contents of the previous 
replacement.

Note:
- This command is not executed if the character string to be searched for is not set.Execute 

the Replace command before executing this command.

See Also:
Searching for and Changing Character Strings



Repeat
This command duplicates the lines in the selected range and inserts the duplicated lines 
immediately after the range.

Repeat Count
Specify the repetition count with an integer from 1 to 99.
The default is "1."

Repeat Range
Specify the line range of the text to be repeated.This option is required.
For how to specify the repetition range,see Specifying the Line Number Input Field of a 
Command.

Note:
- The range to be repeated is selected in units of lines of the text.Therefore,if a character 

string on one line of the text is selected,the whole line including the character string is 
assumed to be selected.



Shift Left
This commands shifts the text in the selected range to the left.

Number of Shifted Columns
Specify the number of columns the text should be shifted with an integer from 1 to the 
maximum column.
If a value exceeding the maximum column is specified,the maximum column is used.
The default is "1."

Shift Range
Specify the line range of the text to be shifted.This option is required.
For how to specify the shift range,see Specifying the Line Number Input Field of a Command.

Notes:
- No line numbers can be shifted.
- The range to be shifted is selected in units of lines of the text.Therefore,if a character 

string on one line of the text is selected as the range to be shifted,the whole line including
the character string is assumed to be selected.

- "Column Overflow at Command Execution"option of the Environment command can be 
used for the following purpose:To select whether overflow characters are deleted if 
characters other than blanks are shifted past the limits of the window.

See Also:
Specifying the Line Number Input Field of a Command
Environment (Current Window)
Environment (Basic Status)



Shift Right
This command shifts the text in the selected range to the right.

Number of Shifted Columns
Specify the number of columns the text should be shifted with an integer from 1 to the 
maximum column.
If a value exceeding the maximum column is specified,the maximum column is used.
The default is "1."

Shift Range
Specify the line range of the text to be shifted.This option is required.
For how to specify the shift range,see Specifying the Line Number Input Field of a Command.

Notes:
- No line numbers can be shifted.
- The range to be shifted is selected in units of lines of the text.Therefore,if a character 

string on one line of the text is selected as the range to be shifted,the line including the 
character string is assumed to be selected.

- "Column Overflow at Command Execution"option of the Environment command can be 
used for the following purpose:To select whether overflow characters are deleted if 
characters other than blanks are shifted past the limits of the window.

See Also:
Specifying the Line Number Input Field of a Command
Environment (Current Window)
Environment (Basic Status)



Renumber
This command resets the absolute line numbers (lines numbers in the text).
If the initial value and increment value are omitted,the previously specified values are used.
If renumbering has not been executed,the value defined in the system is used for 
renumbering.

Initial Value
Specify the initial value with an integer from 1 to 999999 if the line number length is 6 digits
or with an integer from 1 to 99999999 if the line number length is 8 digits.

Increment Value 
Specify the increment value with an integer from 1 to 32767.

Notes:
- This command cannot be used for files with no line numbers.
- If absolute line numbers are used in the line number display area,the display line numbers

are also renumbered as specified.
- If line numbers overflow as the result of renumbering,a message is displayed,then 

renumbering is canceled.
- The specified initial value and increment value are valid during the editing session.



Template
Inserts template in the upper line from the cursor position in the window to be edited.
Template which corresponds to data type of the file to be edited is displayed.
Template name is not displayed when template file which corresponds to data type of the file
to be edited is not set.

[Template name]
Selects sentence to be inserted in the text under editing or template name which is relevant 
to the sentence.The sentence which is relevant to the selected template name is displayed 
in Template viewer.

[Sort]
Sorts template names to be displayed in [Template name]in alphabetical order.

[Insert]
Inserts the sentence which was made relevant to the selected template name in the
[Template name]in the upper line from the cursor position in the file to be edited.





Top
The command moves the cursor to the first line of text.



Bottom
The command moves the cursor to a line after the last line of text.



Goto Line
The command positions the text of the specified line at the center of the window.In the 
standard editing (character)mode,the command moves the cursor to the beginning of the 
text.In hexadecimal mode,the command moves the cursor to a specified address.

Line Number
This option specifies the line number of the target text.
This option is required.
For information on specifying the line number,see "Specifying The Line Number Input Field of
a Command".

Note:
- If the specified text line number is not present,the text line with the next greater line 

number is displayed.If a larger line number is not found,the last line of the text is 
displayed.Zero cannot be specified.

See Also:
Moving to a Particular Location



Pair
The command positions the cursor at a character string that corresponds to the character 
string at the current cursor position.Pairs of strings are defined in the Corresponding 
Character String fields of the Environment for Editor command.

Notes:
- Pairs of parentheses (),braces {},and square brackets [],have already been defined in the 

editor.
- Uppercase and lowercase letters of the paired character strings are distinguished.
- If the character string to be displayed is not in the window,the following is displayed:

- If the character string to be displayed is the first of the paired character strings,it is 
displayed at the top of the window.

- If the character string to be displayed is the second of the paired character strings,it is 
displayed at the bottom of the window.

See Also:
Environment (Current Window)
Environment (Basic Status)



Find
The command searches for a specified find string.It either moves the cursor to the located 
string,or displays the number of matching strings.

Find What
A find string of up to 60 characters can be specified.Uppercase and lowercase letters of the 
find string are distinguished.
The character string that was most recently searched for is displayed as the default.

Direction
This option specifies the direction in which the character string is searched for.
Up:Search proceeds upwards from the current cursor position.
Down:Search proceeds downwards from the current cursor position.
The default direction of the first search is Down.

Search Range
This option specifies the line range to be searched.
From Cursor Position:If the search direction is Up,a range from the character before the 
cursor to the beginning of the text is searched.If the search direction is Down,a range from 
the character after the cursor to the Close of the text is searched.
Range:The specified line range is searched for the find string.
For the specification of the range,see Searching for and Changing Character Strings.
The default is "From Cursor Position".

Find
The cursor moves to the found character string.

Find All
All the character strings to be found within the specified range are found ,and the number of
character strings is displayed after they are found.

Note:
- In hexadecimal mode,the search is made within the display area (dump display area or 

character display area)where the cursor is located.

See Also:
Searching for and Changing Character Strings
Specifying Character Strings
Specifying the Line Number Input Field of a Command



Find Again
The command executes the same search as the last find.

Note:
- This command is executed only when a find string is specified.If the find string is not 

specified,execute the Find command,then select this command.

See Also:
Searching for and Changing Character Strings



Tag Jump
Tag jump reads the character string starting from the current cursor position as the target 
file name and line number.The command moves the cursor to the specified line in the 
specified file.

Notes:
- If a folder is not specified with the file name,the command assumes that the file is in the 

current    folder.The current folder is indicated in the dialog box of the Open command of 
the File menu.

- If no line number is specified,the command moves the cursor to the beginning of the file.

See Also:
Moving to a Particular Location of a Specified File



Display Format
This command sets whether the line column field,ruler field,and line number are 
displayed,and keywords are colored,and what character is used as a LF character is set.

Display Line/Column Field
The line column field is displayed at the top of the window.The format indicates the line 
number format,column,and tab positions .
When PowerFRAMEVIEW is installed,the Display Line Column Field option is enabled.

Display Line Number
A line number is displayed at the left side of the window.
A line number type can be selected only when the Display Line Number option is set.
When PowerFRAMEVIEW is installed,the Display Line Number option is enabled.

Coloring
Colors keywords and comments.
Keywords and comments are not colored when the Coloring option is not enabled.
When the keyword file which corresponds to data type of the file to be edited is not 
set,keywords and comments are not colored even if the Coloring option is enabled.
When PowerFRAMEVIEW is installed,the Coloring option is enabled.

Match case of keyword
Distinguishes upper cases and lower cases of keywords when the keywords are colored.
Upper cases and lower cases of the keywords are not distinguished when the Match case of 
keyword option is not enabled.
The Match case of keyword option is masked when it is not enabled.
When PowerFRAMEVIEW is installed,the Match case of keyword option is enabled.

Line Number Type
Absolute or Relative line numbers can be displayed.
The absolute indicates a line number in a text file.The relative indicates a relative location 
from the first text in the file.The extension of the file to be edited determines whether the 
file has absolute line numbers.For file information for each extension,see the description of 
File.
The absolute setting is ignored if the file to be edited does not contain absolute line 
numbers.
When PowerFRAMEVIEW is installed,relative are enabled.

LF Character
This option specifies what character is used to show the line feeds (LF)in the text.
When PowerFRAMEVIEW is installed,no character is set.

Window to Be Changed
This option specifies whether modifications to the view format are reflected to the Current 
Window only or to All Windows.

Save Setting
This option specifies whether the modifications to the Display format are valid in the window



displayed by a subsequent New or Open command.The modifications are also stored in the 
operating environment file of the editor.
When PowerFRAMEVIEW is installed,this field is not enabled.

See Also:
File Details



Font
Characters in the window are displayed in the selected font.

Window to be Changed
This option specifies whether the modifications to the Display format are reflected to the 
current window only or to all windows.

Save Setting
This option specifies whether the modifications to the Display format are valid in the window
displayed by subsequent New or Open commands.The modifications are also stored in the 
operating environment file of the editor.
When PowerFRAMEVIEW is installed,this field is not checked.

Note:
- Specify only the value of the List Box in the size item.



Toolbar
This command selects whether the Toolbar is displayed at the top of the window.When this 
field is checked,the Toolbar is displayed.
When PowerFRAMEVIEW is installed,this field is checked.



Statusbar
This command specifies whether the Status bar is displayed at the bottom of the window.If 
this field is checked,the Status bar is displayed.
When PowerFRAMEVIEW is installed,this field is checked.



Compile
This commands calls the builder and starts translation.For details of the builder,refer to the 
builder help.

Notes:
- This command can be selected when at least one line of text is present.
- When this command is selected,the file being edited is stored.The status before the file is 

opened cannot be restored.
- This command cannot be used when this command is activated from P-STAFF.



Environment
The command sets up the operating environment for tool linkage.

Position Request from the Tool
When a tool makes a position request while a file with absolute line numbers is being 
edited,the setting of this option becomes significant.The option specifies whether the line 
number specified in the request is treated as an absolute line number (line number within a 
text)or relative line number (relative position from the first text).
Positioning by absolute line number is executed when these conditions are satisfied:The file 
being edited is displayed with absolute line numbers;This option is set to Absolute Line.The 
information set here is valid for subsequent windows.
When PowerFRAMEVIEW is installed,Relative Line is set.

Notes:
- This command cannot be used when this command is activated from P-STAFF.



Customize Command Key
The command defines a command key.The command key is a set of CTRL key and an 
alphabetic key to which a command is assigned.
When defining a command key,select the desired alphabetic character from the Command 
Key List.Choose a command by selecting a Command Group Name and Command 
Name,then click on the Set button.To delete a definition,select the corresponding alphabetic 
character from the Command Key List,then click on the Delete button.

Command Key List
The list indicates the command keys that have already been defined.This list displays a 
command name next to the corresponding alphabetic character.If a command name is not 
displayed,the corresponding command key is not defined.
When a command key is selected,the corresponding Command Group Name and Command 
Name are displayed.The definitions of these command    keys cannot be changed:CTRL 
+C,CTRL +V,CTRL +X,and CTRL +Z.

Command Group Name
Lists the available command groups.The list includes the following group names:
- File
- Edit
- Locate
- View
- Tool
- Option
- Window
- Help

Command Name
Lists the command names related to the selected command group name.

Set Button
Press the Set button to register the selected command key.

Delete Button
Press the Delete button to clear a mapped command from the selected command key.

See Also:
Editing with command keys



Environment (Current Window)
This command sets the operating environment of the current window.

Vertical Range for the Number of Skipped Lines for Vertical Scrolling
When the CTRL key and the cursor up or cursor down keys are pressed,high-speed scroll is 
executed.This option specifies the horizontal range of the window subjected to the high-
speed scroll.The range can be specified by integer percent within the range from 0%to 
100%.Value 0%represents the left side of the displayed window.
Value 100%represents the right side of the displayed window.As the horizontal scroll range 
decreases,the drawing range in scrolling decreases,but the scrolling speed increases.
When PowerFRAMEVIEW is installed,100%is set.

The Number of Lines the Cursor Moves at High Speed
When the CTRL key and the cursor up or cursor down keys are pressed,the cursor moves up 
or down at high speed.This option specifies the vertical travel distance of the cursor.The 
movement can skip 1 to 50 lines.
When PowerFRAMEVIEW is installed,2 is set.

The Number of Columns the Cursor Moves at High Speed
When the CTRL key and the cursor right or cursor left keys are pressed,the cursor moves 
right or left at high speed.This option specifies the horizontal travel distance of the 
cursor.The movement can skip 1 to 50 columns.
When PowerFRAMEVIEW is installed,2 is set.

Tab Interval
This option specifies the length of a tab interval with an integer within the range of 2 to 
99.The tab interval is indicated by a triangle in the display ruler.
A value specified with the New or Open commands is indicated as the default.
This option cannot be set when the Open command is used to select hexadecimal mode.

Corresponding Character String
This option specifies a pair of character strings to be used with the Pair command,with up to 
eight alphanumeric characters.
Uppercase and lowercase letters are distinguished in the corresponding character strings.
The Pair command displays a character string in the window corresponding to the character 
string where the cursor is placed.The command also moves the cursor to the former 
character string.
Front:The first of the corresponding character strings is specified.
Rear:The second of the corresponding character strings is specified.
When PowerFRAMEVIEW is installed,this option is not enabled.
When the Open command is used to select hexadecimal mode,this option cannot be 
enabled.

Auto Indent
This option moves the cursor to the first character of the previous text line after the return 
key is pressed in line insert mode.
This option is not specified when PowerFRAMEVIEW is installed.
When the Open command is used to select hexadecimal mode or display mode,this option 



cannot be enabled.

Backup File Creation
This option stores the status before editing in a backup file when an existing file is edited 
and overwritten.The backup file is in the same directly and is assigned the same file name 
and extension "file-name.BAK".
Check box is not checked when PowerFRAMEVIEW is installed.
This option cannot be specified when the display mode is selected in [Open]Command.

Set CR Code
This option sets a return code ('0D'H)to the end of text when a text is stored to the file 
during the edit.
Check box is not checked when PowerFRAMEVIEW is installed.
This option cannot be specified when hexadecimal mode or display mode is selected in 
[Open]Command.

Set EOF Code
This option sets the EOF code ('1A'H)to the end of file when a text is stored to the file during 
the edit.
Check box is not checked when PowerFRAMEVIEW is installed.
It cannot be specified when hexadecimal mode or display mode is selected in 
[Open]Command.

Delete Column Overflow in Command Execution
This option deletes overflowing characters when Column Overflow occurs during command 
execution.When check box is not checked,the command becomes an error.
Check box is not checked when PowerFRAMEVIEW is installed.
This option cannot be specified when hexadecimal mode or display mode is selected in 
[Open]Command.

Window to be Modified
This option specifies whether the modifications to the operating environment are reflected to
the current window only or to all windows.

Save Setting
This option specifies whether the modifications to the operating environment are valid in the
window displayed by subsequent New or Open commands.The modifications are also stored 
in the environment file of the editor.
When PowerFRAMEVIEW is installed,this field is not checked.



Environment (Basic Status)
This command sets the basic operating environment of the editor.The setting becomes valid 
from windows displayed by using the next New or Open command.

Vertical Range for the Number of Skipped Lines for Vertical Scrolling
When the CTRL key and the cursor up or cursor down keys are pressed,high-speed scroll is 
executed.This option specifies the horizontal range of the window subject to high-speed 
scrolling.The range can be specified by integer percent values within the range of 0%to 
100%.
Value 0%represents the left side of the displayed window.Value 100%represents the right 
side of the displayed window.As the horizontal scroll range decreases,the drawing range of 
the scrolling decreases,but the scrolling speed increases.
When PowerFRAMEVIEW is installed,100%is set.

The Number of Lines the Cursor Moves at High Speed
When the CTRL key and the cursor up or cursor down keys are pressed,the cursor moves up 
or down at high speed.This option specifies the vertical travel distance of the cursor.The 
movement can skip 1 to 50 lines.
When PowerFRAMEVIEW is installed,2 is set.

The Number of Columns the Cursor Moves at High Speed
When the CTRL key and the cursor right or cursor left keys are pressed,the cursor moves 
right or left at high speed.This option specifies the horizontal travel distance of the 
cursor.The movement can skip 1 to 50 columns.
When PowerFRAMEVIEW is installed,2 is set.

Tab Interval
This option specifies the length of a tab interval with an integer within the range of 2 to 
99.The tab interval is indicated by a triangle in the display ruler.
A value specified with the New or Open commands is indicated as the default.
When PowerFRAMEVIEW is installed,8 is set.

Corresponding Character String
This option specifies a pair of character strings to be used by the Pair command,with up to 
eight alphanumeric characters.Uppercase and lowercase letters are distinguished in the 
corresponding character strings.
The Pair command displays in the window a character string corresponding to the character 
string where the cursor is placed.The command also moves the cursor to the former 
character string.
Front:The first of the corresponding character strings is specified.
Rear:The second of the corresponding character strings is specified.
When PowerFRAMEVIEW is installed,this option is not set.

Auto Indent
This option moves the cursor to the first character of the previous text line after the return 
key is pressed in line insert mode.
Check box is not checked when PowerFRAMEVIEW is installed.
This option cannot be specified when hexadecimal mode or display mode is selected in 
[Open]Command.



Backup File Creation
This option stores the status before editing in a backup file when an existing file is edited 
and overwritten.The backup file is in the same directly and is assigned the same file name 
and extension "file-name.BAK".
Check box is not checked when PowerFRAMEVIEW is installed.
This option cannot be specified when the display mode is selected in [Open]Command.

Set CR Code
This option sets a return code ('0D'H)to the end of text when a text is stored to the file 
during the edit.
Check box is not checked when PowerFRAMEVIEW is installed.
This option cannot be specified when hexadecimal mode or display mode is selected in 
[Open]Command.

Set EOF code
This option sets the EOF code ('1A'H)to the end of file when a text is stored to the file during 
the edit.
Check box is not checked when PowerFRAMEVIEW is installed.
It cannot be specified when hexadecimal mode or display mode is selected in 
[Open]Command.

Delete Column Overflow in Command Execution
This option deletes overflowing characters when Column Overflow occurs during command 
execution.When check box is not checked,the command becomes an error.
Check box is not checked when PowerFRAMEVIEW is installed.
This option cannot be specified when hexadecimal mode or display mode is selected in 
[Open]Command.

Insert Cursor Mode at Open Command Execution
The cursor mode can be set as the "Insert"mode by this option when a window is displayed 
in    [Open]Command.When check box is not checked,"Overwrite"mode is selected.
In hexadecimal editing,overwrite mode is unconditionally selected.
Check box is checked when PowerFRAMEVIEW is installed.

Undo Level
This option specifies a value within the range of 0 to 99 as the default value of Max Undo 
Level of the New or Open commands of the File menu.If 0 is specified,use of the Redo 
command is disabled.
Max Undo Level indicates the level that can be restored by the Redo or Undo commands.
When PowerFRAMEVIEW is installed,99 is set.

Maximum Column
This option specifies the maximum number of columns of a text line in the window.The Set 
File Information (PowerFRAMEVIEW Editor)option of the Setup Environment command of 
PowerFRAMEVIEW may not define the maximum number of columns,presence of line 
numbers,file    format,etc.,of each extension.If so,this field becomes valid.The value specified
in this field is assumed as the maximum number of columns of a text line in the window.
A value within the range of 1 to 32760 can be specified.In editing,a value exceeding 3176 is 



treated as 3176.
When PowerFRAMEVIEW is installed,223 is set.



Setup Environment for PowerFRAMEVIEW
This command sets up the environment in which PowerFRAMEVIEW operates.For details,refer
to the Setup Environment command help.



Cascade
This command displays all edit and view windows overlapping one another in such a manner
that the titles can be seen.



Tile
The command displays all edit and view windows side by side in a tiled fashion.



Arrange Icons
This command arranges the icons of minimized edit or view windows.



List File Names
The names of files being edited or viewed are listed below the Arrange command.To see a 
files window,select the corresponding file name from this list.




