
Configure the File Details that are Displayed
You can change the type of the file details to be displayed in the box at the right to either 
"name only" or "name and all file details" 
To change the displayed file details:
-    Select the List or Details command in the View menu.



Display Title
You can specify whether to display the title of the local Files List window or work space list.
When the Title command is selected in the View menu, the title is displayed.    When this 
option is selected, the check mark is displayed at the left.
The title of the local Files List window can be displayed only when the installed product has 
the title display function.



Display Repository Information
You can display the information on the repository associated with the work space.
To display repository information, select the Repository Information command in the 
Configuration Management submenu of the View menu.
The following files can be displayed.
Map Only:  Select the Map Only command in the Configuration Management submenu of 

the View menu.    Only mapped files and unregistered files are displayed.
All:  Select the All command in the Configuration Management submenu of the 

View menu.    All the files in the repository and unregistered files are displayed.



Change the File Display Order
You can change the order in which files are displayed.
To change the display order:
-    Select the desired item in the Sort submenu of the View menu.



Configure the File Grouping that is Displayed
You can limit the files to be displayed in the right-side box to a particular group.
To select a particular file grouping to be displayed.
- Activate a window in which the display is to be limited to a specified grouping.
- Select the Grouping command from the View menu.
- A dialog box is displayed.    In this dialog box, specify the desired group options.

See also:
Options (Local List)
Options (Repository List)
Options (Work Space List)
Options (Global Server File List)
Options (GEM File Member List)
Options (Partitioned File Member List)



Copying File
Copy files using the steps below.

Mouse
Select the file to be copied, hold down the Ctrl key, and drag the file to the copy destination,
if the copy destination is in the same drive as the copy source.    
If the copy destination is not in the same drive as the copy source, it is unnecessary to hold 
down the Ctrl key when dragging.

Keyboard
Select the file to be copied.    Then select the Copy command from the File menu.    A dialog 
box is displayed.    In this dialog box, specify options needed to copy the file.    The selected 
file is displayed in the From entry field in the dialog box.

See also:
Copy File(Local)
Copy File(Global Server)
Copy File(Send)
Copy File(Receive)
Select Multiple Files
Global Server Cooperation Operation



Editing/Viewing Local File
Lets you edit and view the contents of a file.    Refer to "Editor Help" for details.

Mouse
Double-click on the name of the file to be edited or displayed, if it is not an executable file.

Keyboard
Select the file to be edited and select the Edit command from the Tool menu.    Alternatively, 
if the file to be edited is not an executable file, select the Open command from the File 
menu, or press the Enter key.
If Specify Execution Options is selected on the Options menu, the editor starts, and a dialog 
box is displayed.    This dialog box displays the selected file as the file to be edited.    Specify 
options needed for editing.
If Specify Execution Options is not selected on the Options menu, the editor starts and loads 
the selected file.

See also:
Select Multiple Files
Specify Execution Options

Notes:
- If more than one file is selected only the first one will be opened for editing.



Moving File
Lets you move files.

Mouse
If the move destination is not in the same drive as the file to be moved select the file to be 
moved, hold down the Shift key, and drag the chosen file to the move destination,. 
If the move destination is in the same drive as the file to be moved, it is unnecessary to hold
down the Alt key when dragging.

Keyboard
Select the file to be moved.    Then select the Move command from the File menu.    A dialog 
box is displayed.    In this dialog box, specify options needed to move the file.    The specified 
file is displayed in the From field of the dialog box.

See also:
Move File(Local) 
Move File Member(Global Server)r
Select Multiple Files
Global Server Cooperation Operation



Running Local Applications
Development Manager lets you run Local applications.

Mouse
If the target application file is an executable file, double-click on the name of the application 
file.

Keyboard
Select the target application file, then select the Run command from the File menu.    
Alternatively, if the target application file is an executable file, select the Open command 
from the File menu, or press the Enter key.

See also:
Select Multiple Files

Notes:
- If more than one file is selected only the first file of those selected will be run.



Creating Folder
Lets you create Folder.

Mouse or Keyboard
Select the Create Folder command from the File menu.
In the displayed dialog box, specify the name of the Folder to be created.

See also:
Create Folder 



Creating Global Server File
Lets you create an Global Server file.

Keyboard
Select the Create Global Server File command from the File menu.
A dialog box is displayed.    In this dialog box, specify options needed to create the Global 
Server file.

See also:
Create Global Server File
Global Server Cooperation Operation



Deleting File
Lets you delete file.

Keyboard
Select the file to be deleted.    Select the Delete command from the File menu, or press the 
Del key.    
If Specify Execution Options is checked on the Options menu, a dialog box is displayed.    This
dialog box displays the selected file as the file to be deleted.    Press the Delete button to 
delete the file.
If Specify Execution Options is not checked on the Options menu, the selected file is deleted.

See also:
Delete File(Local) 
Delete File(Global Server)
Select Multiple Files
Specify Execution Options
Global Server Cooperation Operation



Renaming File
Lets you rename a file.

Mouse
Select the file to be renamed, and click the name of that file again.    Enter the new file 
name, and then press the Enter key.

Keyboard
Select the file to be renamed, then select the Rename command from the File menu.
A dialog box is displayed.    This dialog box displays the chosen file as the From name.    
Specify the new name for the file.

See also:
Rename File(Local)
Rename File(Global Server)
Select Multiple Files
Global Server Cooperation Operation



Printing Local Files
Lets you print the contents of a file.

Mouse or Keyboard
Select the file whose contents are to be printed, then select the Print command from the Tool
menu.    A dialog box is displayed.    This dialog box displays the selected file as the file 
whose contents are to be printed.    Specify the options needed to print the file.

See also:
Print File
Select Multiple Files



Reorganizing Global Server File
Lets you delete unnecessary areas from (reorganize) an Global Server partitioned file, or 
change the amount of space in the Global Server file or its storage volume.

Keyboard
Select a file, then select the Reorganize command from the File menu.
A dialog box is displayed.    This dialog box displays the chosen file as the file to be 
reorganized.    Specify the options needed for file reorganization.

See also:
Reorganization File(Global Server)
Select Multiple Files
Global Server Cooperation Operation



Printer Setup
Lets you set up printer information.

Mouse or Keyboard
Select Specify Execution Options on the Options menu, select a file, then select the Print 
command from the Tool menu.    A Print File dialog box is displayed.    In this dialog box, press
the Print Setup button.
When the print setup dialog box appears, specify printer information in it.

                              





Open Global Server List Window
The global server list window can be opened by performing one of the following operations 
for the left side box:

Mouse 
Double-click on the Global Server icon.

Keyboard      
Select the Global Server icon.    
Select the Open command from the File menu or press the Enter key.

Selecting the Specify Execution Options command in the Options menu displays a dialog box
for displaying the global server list.    Enter necessary options in the box.
When the Specify Execution Options command is not selected in the Options menu, the 
global server list window displays a list of the files having a name that starts with the user ID
specified in the Set LOGON Information.

Note:
If any file name includes "\," "$" is displayed instead.    Asterisks (*) are displayed for any 
volume serial number whose attribute cannot be obtained in the list.

See Also:
Get Files List(Global Server)
Global Server Cooperation Operation
Set LOGON Information (TCP/IP cooperation)
Specify Execution Options



Open Member List Window
When the following operation is performed in the Global Server file list window, the member 
list window can be opened.

Mouse      
Double-click on the file name of the GEM file or partitioned file. 

Keyboard    
Select the GEM file or partitioned file.    
Select the Open command from the File menu or press the Enter key.

Notes:
When the Specify Execution Options command is not selected in the Options menu, select 
the icon for the global server in the left side box to display the dialog box for displaying the 
global server list.    In this dialog box, specify the name of the file whose member list is to be 
displayed, and the desired member list will be displayed.
When multiple files are selected only the first file is processed.    
Asterisks (*) are displayed for any member whose attribute cannot be obtained in the list.



Execute Tool (Operation)
Selecting the Start command from the Tool menu displays the dialog box for executing the 
tool.    Specify the class of the tool to be executed and the file to be processed to execute the
tool.

See Also:
Start Tool



Start Tool
Starts a tool.
The following options can be specified:

File Name
This is valid when the check box for validating the file name as the start option is selected.
Specifies the absolute path name of the file name to be processed by the tool.
Multiple files and wild cards cannot be specified.
Press the Browse button to display the Browse File dialog box. 

Tool Class Name
Specifies the class name of the tool to be started.
Selecting a tool class in the list box displays the selected tool class name. 
When a file name is specified, the tool class names of the tool associated with its extension 
and the common tool denoted as "*" are displayed.

Validate File Name As Start Option
Specifying this option passes control to the tool that starts the file whose name is displayed 
in the file name area.



!!#+K$!!Select Folder
The name of the selected folder is highlighted.
Only a single folder can be selected in the left window.    The methods for selecting another 
folder are described below.

Mouse
Click the desired folder name.

Keyboard
Select the desired folder by using the following keys.

Up Arrow
The folder immediately above the currently selected folder

Down Arrow
The folder immediately below the currently selected folder

Home
The folder at the top of the list

End
The folder at the end of the list

Right Arrow
The first subfolder (if any) of the currently selected folder

Left Arrow
The folder (if any) immediately above the currently selected folder

Page Down
The folder at the bottom of the box

Page Up
The folder at the top of the box

 



Open Files List Window
The Files List window can be opened by performing one of the following actions:

Mouse
Click or double-click the desired folder.

Keyboard
Select the Folder to be displayed.    Then select the Open command of the File menu or press
the Enter key.

Note:
When the Open command of the File menu is selected or the Enter key is pressed while two 
or more files are selected, only the first file is processed.





Select Multiple Files
You can select multiple files that are consecutive or non-consecutive.
Selecting Consecutive Items

Mouse
Click on the first item to be selected.    Press and hold down the Shift and click on the last 
item of the desired group.

Keyboard
Press an arrow key to move the cursor to the first item to be selected.    Press and hold down 
the Shift key and press an arrow key to select the remaining items of the desired group.
Selecting Non-Consecutive Items

Mouse
Press and hold down the Ctrl and click on each desired item.

Keyboard
Hold down the Ctrl key and move the cursor to the desired item by using the arrow keys.    To
select the item, press the Space.



Release Selected File
Release a selected file as follows.

Mouse
Press and hold down the Ctrl and click on the item to be released.

Keyboard
Hold down the Ctrl key and move the cursor to the desired item by using the arrow keys.    To
release the item, press the Space.



Refresh Window
Selecting the refresh command in the View menu or pressing the F5 key displays the latest 
information on the screen.



Specify Execution Options
When a file manipulation command or development manager tool is selected a dialog box 
for specifying options can be displayed before the tool or command is invoked.
When Specify Execution Options on the Option menu is selected, the dialog box for 
specifying options is displayed.
When Specify Execution Options on the Option menu is not selected, the dialog box for 
specifying options is not displayed.    
Certain commands, such as Copy that always require input of options, are not affected by 
the setting of this item.



Replace File
Lets you specify whether attempts to overwrite existing files should proceed or bring up an 
error message.
When Replace on the Option menu is selected, files are overwritten with no confirmation 
messages.
When Replace on the Option menu is not selected, an error message is displayed when an 
attempt is made to overwrite an existing file.



Confirmation Message
A confirmation message can be displayed before file manipulation commands are executed.
When Confirmation on the Option menu is selected, confirmation messages are displayed.
When Confirmation on the Option menu is not selected, confirmation messages are not 
displayed.



Display Toolbar
Switches the display of the toolbar on and off.
When Toolbar on the View menu is selected, the toolbar is displayed.    
When Toolbar on the View menu is not selected, the toolbar is not displayed.



Display Statusbar
Switches the display of the status bar on and off.
When Statusbar on the View menu is selected, the status bar is displayed.    
When Statusbar on the View menu is not selected, the status bar is not displayed.



Save Settings on Exit
Saves the current settings on the Options menu and the list display status at exit.
Selecting the Save Settings from the Exit command in the Options menu saves the current 
menu settings and list display status.
When Save Settings on Exit on the Option menu is not selected, the settings are not saved.





Create Local File
Creates a new file.

Keyboard
From the Tool menu, select New.
The New dialog box is displayed.    Select the target file organization (extension) in the file 
organization list box.

See Also:
New



Build Local File
Builds a file.
For details, see the builder help.

Keyboard
Select the build target, then from the Tool menu, select Build.
The Build command runs the target build function of the builder.    The file name selected in 
the file list operation window is set as the target.



Add
Adds a work space file to a repository.
For details, see the Configuration Management Help.
After addition, the following icon is displayed in the files list.

Mouse or Keyboard
Select the work space file to add, then select the Add command from the Configuration 
Management menu.
When Specify Execution Options is checked on the Option menu, the dialog box for adding is 
displayed.    Enter the options required for adding.

See Also:
Select Multiple Files
Global Server Cooperation Operation
Specify Execution Options 



Check In
Reflects the updated result of a work space file in a repository.
For details, see the Configuration Management Help.
After Check In, the following icon is displayed in the files list.

Mouse or Keyboard
Select the work space file whose updated result is to be reflected in the repository, then 
select the Check In command from the Configuration Management menu.
When Specify Execution Options is checked on the Option menu, the Check In dialog box is 
displayed.    Enter the options required for Check In.

See Also:
Select Multiple Files
Global Server Cooperation Operation
Specify Execution Options 



Check Out
Fetches a resource from a repository to a work space file for updating.
For details, see the Configuration Management Help.
After Check Out, the following icon is displayed in the files list.

Mouse or Keyboard
Select the work space file to fetch a resource from the repository for updating, then select 
the Check Out command from the Configuration Management menu.
When Specify Execution Options is checked on the Option Menu, the Check Out dialog box is 
displayed.    Enter the required Check Out options.

See Also:
Select Multiple Files
Global Server Cooperation Operation
Specify Execution Options 



Retrieve
Retrieves a resource from a repository to a work space file for browsing.
For details, see the Configuration Management Help.
After Retrieval, the following Icon is displayed in the Files List.

Mouse or Keyboard
Select the work space file to Retrieve a resource from the repository for browsing, then 
select the Retrieve Command from the Configuration Management Menu.
When the Specify Execution Options Command is selected from the Option Menu, the 
Retrieve dialog box is displayed.    Enter the required Retrieve options.

See Also:
Select Multiple Files
Global Server Cooperation Operation
Specify Execution Options 



Delete
Deletes a work space file and resources of a repository Mapped to the work space file.
For details, see the Configuration Management Help.

Mouse or Keyboard
Select the work space file to Delete resources from the repository, then select the Delete 
command from the Configuration Management menu.
When Specify Execution Options command is checked on the Option menu, the deletion 
dialog box is displayed.    Enter the required Delete options. 

See Also:
Select Multiple Files
Global Server Cooperation Operation
Specify Execution Options 



Display File List
Displays a list of resources in a repository Mapped to a work space. 
For details, see the Configuration Management Help.

Mouse or Keyboard
Select the work space, then select the Display Files List command from the Configuration 
Management menu.
When Specify Execution Options is checked on the Option menu, the dialog box for 
displaying a files list is displayed.    Enter the options required for displaying a files list.

See Also:
Select Multiple Files
Global Server Cooperation Operation
Specify Execution Options 



History
Displays the update history of resources in a repository Mapped to a work space file.
For details, see the Configuration Management Help.

Mouse or Keyboard
Select the work space file to display the update history of resources, then select the Display 
History command from the Configuration Management menu.
When Specify Execution Options is checked on the Option menu, the Display History dialog 
box is displayed.    Enter the required options for displaying the update history.

See Also:
Select Multiple Files
Global Server Cooperation Operation
Specify Execution Options 



Compare
Compares the contents of a work space file to the contents of resources of the Mapped 
repository, then displays the differences.
For details, see the Configuration Management Help.

Mouse or Keyboard
Select the work space file to Compare with the contents of resources in the repository, then 
select the Compare command from the Configuration Management menu.
When Specify Execution Options is checked on the Option menu, the Compare dialog box is 
displayed.    Enter the options required for comparison.

See Also:
Select Multiple Files
Global Server Cooperation Operation
Specify Execution Options 



Map 
Maps a work space to each resource in a repository.
For details, see the Configuration Management Help.

Mouse or Keyboard
Select the work space to Map each resource in a repository, then select the Map command 
from the Configuration Management menu.
The Map dialog box is displayed.    Enter the required options for Mapping.

See Also:
Select Multiple Files
Global Server Cooperation Operation
Specify Execution Options 



Cancel Check Out
Releases the Check Out status of a work space file.
For details, see the Configuration Management Help.

Mouse or Keyboard
Select the work space file to release Check Out status, then select the Check Out command 
from the Configuration Management menu.
When Specify Execution Options is checked on the Option menu, the dialog box for canceling
Check Out is displayed.    Enter the options required for canceling Check Out.

See Also:
Select Multiple Files
Global Server Cooperation Operation
Specify Execution Options 



Cancel Mapping
Releases the Mapping between a work space and each resource in a repository.
For details, see the Configuration Management Help.

Mouse or Keyboard
Select the work space file Mapped to each resource in a repository, then select the Cancel 
Map command from the Configuration Management menu.

See Also:
Select Multiple Files
Global Server Cooperation Operation



Utility
Executes the GEM Utility.
For details, see the Configuration Management Help.
Select the Utility command from the Configuration Management menu.
The Utility dialog box is displayed.    Select the required utility function. 

See Also:
Select Multiple Files



Icons Used to Indicate Check Out Status
Development Manager uses the icons shown below to indicate the status of files in 
PowerGEM work spaces.
For details, see the    Configuration Management Help 
Icon Description

This file was Retrieved, or was Checked In.
This file was Checked Out.
This file was only Mapped.
This file cannot be modified because it is checked out to another work space.    This is

displayed only when the repository list is specified.
This file is in the repository but not in the work space.    This is displayed only when 

the repository list is specified.
This file is not registered in the repository.



Job Execution
Executes an Global Server job.

Keyboard
Select Global Server cooperation.    Then select the Run command on the Job submenu of the
File menu.
The dialog box for Exec Job is displayed.    Enter the necessary option.

See Also:
Global Server Cooperation Operation
Exec Job



Job Deletion
Deletes a job.
A job can be deleted as follows.

Keyboard
Select the Delete command in the Job submenu of the File menu.    When the dialog box for 
global server job deletion is displayed, enter the necessary option.

See Also:
Delete Job(Global Server)



Global Server Cooperation Operation
To use the global server cooperation feature of PowerGEM, global servers need to be 
connected as described below.    Global servers are connected using TCP/IP.

Specify Connection Method
Specify the connection method for the server cooperation using the Setup Environment 
command in the Options menu of the development manager.

Connection with Global Server (TCP/IP Cooperation)
Execute the Network command in the Control Panel, and assign TCP/IP in the network 
setting.
The global server is activated based on the options set in the Set LOGON information.

See Also:
Set LOGON Information (TCP/IP Cooperation) 



Copy File(Local)
Copies a Local file.
Notes

Options
The following options can be specified.
From File Name
To File Name
Replace



From File Name
Specifies the folder name and file name that you want to copy from.
Multiple files and wildcards can be specified.
When specifying two or more files, enclose them in quotation marks.



To File Name
Specifies the target folder name and file name.
Multiple files and wildcards cannot be specified.
When the Browse button for the "To" file is pressed, the folder name can be selected.



Replace
Specifies whether to replace an existing file specified as the "To" file.
When the check box is selected, the "To" file is replaced.
The default in the check box is the setting of Replace on the Option menu.



Notes
- If a folder is specified as "From", processing depends on whether the "To" folder exists.

If the "To" folder does not exist:
Creates a folder with the folder name specified as the "To" folder.    Then subfolder and 
files in the "From" folder are copied.
If the "To" folder exists:
Creates a folder with the same name as the "From" folder name in the "To" folder.    Then 
subfolder and files are copied "From" the from folder to the created folder.

- When a file is specified as "From" and a folder is specified as "To", the "From" file name is 
copied to the "To" folder. 

- When multiple files or wildcards are specified as "From", "To" must be a folder.



Copy File(Global Server)
Copies Global Server a file.
Notes

Options
The following options can be specified.
From File Name
From File Password
From Volume
To File Name
To File Password
To Volume
Member Password
Copy Member Alias
Truncate Record
Replace
See Also
Global Server Cooperation Operation



From File Name
Specify the "Copy From" file name and member name. 
Multiple members can be specified.
Choose the Browse button for the "Copy From" file to display the Browse File or Member 
dialog box.

See Also
How to Input Global Server File Names
How to Input Member Names



From File Password 
Specifies the file password when the "Copy From" file is protected by a password.



From Volume
Specifies the volume when the "Copy From" file is an uncataloged file.



To File Name
Specify the "Copy To" file name and member name.
Choose the Browse button for the "Copy To" file to display the Browse File dialog box.
When a new file is created, the new file attribute is created according to the "Copy From" file
attribute.
If the "Copy To" file does not exist, a sequential file is created unless the "Copy From" 
member name and "Copy To" member name are specified.
When a member name is specified as the "Copy To" file name, a sequential file or member 
name must be specified as the "Copy From" file.
When multiple members are specified as the "Copy From" file, a member name cannot be 
specified as the "Copy To" file.

See Also
How to Input Global Server File Names
How to Input Member Names



To File Password
Specifies the file password when the "Copy To" file is a protected by a password.



To Volume 
Specifies the volume when the "Copy To" file is an uncataloged file.



Replace
Specifies whether to overwrite the member or file when an existing file or member is 
specified as the "Copy To" file (partitioned file or GEM file).
When the check box is selected, the "Copy To" file is overwritten.
The default in the check box is not selected.
The value of the Replace command of the Option menu is reflected.



Member Password 
Specifies the member password when a protected GEM file member is specified as the "Copy
From" file or "Copy To" file.



Copy Member Alias
Specifies whether to copy the alias when a main name is selected as the member name.
When the check box is selected, the alias is also copied.
The default in the check box is not selected.



Truncate Record
Specifies whether to check the record lengths of the "Copy From" file and the "Copy To" file.   
Wen the check box is selected, the "Copy From" file records exceeding the record length of 
the "Copy To" file are truncated at copy.    If the record length of the "Copy From" file is 
greater than that of the "Copy To" file, an error occurs unless the check box is selected.
The default in the check box is not selected.



Notes
- When the "Copy To" file is a sequential file, it is replaced regardless of whether the 

overwrite option is specified.
- If the "Copy To" file does not exist, a new file with the specified name is created or an 

error occurs.    This depends on the Global Server AP/EF center customize specification. 
- When a partitioned file with no member name specified or GEM file is specified as the 

"Copy From" file, the "Copy To" file must also be a partitioned file (with no member name 
specified) or GEM file.

- When files with control characters are specified as the "Copy From" and "Copy To" files, 
the control character types must match.

- When a GEM file member name of nine or more characters is specified as the "Copy From"
file and a partitioned file with no member name is specified as the "Copy To" file, the first 
eight characters become the "Copy To" member name.

- Copying cannot be performed under the following conditions.
A file that cannot be moved is specified as the "Copy From" file.
A fixed-length standard record or variable-length spanned record file is specified as the 
"Copy From" or "Copy To" file.

- When a new file is created, the block length become as follows, except for when the "Copy
From" file is a GEM file and the "Copy To" file is not a GEM file.
When the "Copy From" file member has the fixed-length format:
Record length > 3,120 bytes : Record length
Record length <= 3,120 bytes: An integer multiple of up to a 3,120-byte record length 

closest to 3,120
When the "Copy From" file member has the variable-length format:
Record length > 3,116 bytes : Record length + 4
Record length <= 3,116 bytes: 3,120

- When the "Copy From" file is a GEM file and the "Copy To" file is not a GEM file, the record 
formats must be the same.

- When the "Copy To" volume option is specified and the file does not exist in the specified 
volume, a new file is created.    The catalog information is not registered, however.

- GEM file members that have different record formats cannot be copied.



Copy File(Send)
Copies a file from a local to the global server.
Notes

Options
The following options can be specified.
From File Name
Data Type
To File Name
To File Password
To Volume
Record Format
Record Length
Global Server File Code
Replace

Log Copy
Opening the Log tab setting screen from the Copy File (Send) dialog box displays the dialog 
box for setting Log Copy



From File Name
Specifies the name of the local file from which data is to be copied, as described below.
Specify the "Copy From" folder name and file name.
Multiple files and wildcards can be specified.
When specifying two or more files, enclose them in quotation marks.



Data Type
Specifies the data type: text or binary.    When text is selected, data is converted to the 
specified code.



To File Name
Specifies the name of the global server to which data is to be copied, as described below.
-    Specify the "Copy To" file name and member name.
-    Choose the Browse button for the "Copy To" file to display the Browse File dialog box.
-    When a new file is created, the new file attribute is created according to the "Copy From" 

file attribute.
-    When multiple files are specified as the "Copy From" file, a member name cannot be 

specified as the "Copy To" file.
-    Multiple files, multiple members, and wild cards cannot be specified.



To File Password
Specifies the file password when the "Copy To" file is an Global Server file protected by a 
password.



To Volume 
Specifies the volume when the "Copy To" file is an uncataloged Global Server file.



Replace
Specifies whether to overwrite the member or file when an existing file or member is 
specified as the "Copy To" file (partitioned file or GEM file).
When the check box is selected, the "Copy To" file is overwritten.
The default in the check box is not selected.
The value of the Replace command of the Option menu is reflected.



Record Format
Select the Global Server file record format from the default, variable length, or fixed length.   
The default for the text data type is variable length.    The default for the binary data type is 
fixed type.



Record Length
Specifies the length of the global server file record.    The maximum record length is 3176 for
the fixed length and 3180 for the variable length.
When 0 is specified, the length is set to 256.



Global Server File Code
Specifies the global server code.    This is valid when text is specified as the data type.
The following options can be specified.

EBCDIC (ASCII)
Specifies EBCDIC (ASCII).



Note
- When "Copy From" is a local and "Copy To" is a partitioned file with no member name 

specified, the file name from which the extension is excluded becomes the "Copy To" 
member name. however, that only those member names that are valid as partitioned file 
member names can be created.

- A local tab is converted to one blank character and stored in an Global Server.    Even if 
this file is copied from the Global Server to a local, the tab is not recovered.

-    To manipulate a GEM file, use the Configuration Management command.    The length of 
the file that can be copied is limited.

-    A variable length file with control characters cannot be copied correctly.



Log Copy
Sets the information necessary to log the copied (sent) file data.

Options
The following options can be specified.
Log
File Name
Logging Method



Log
Specifies whether to log the copied file data.
Select the check box to start logging.



File Name
Specifies the name of the file whose log is to be output.
Pressing the Browse button for the file displays the dialog box for Browse File.



Logging Method
Specifies the method of logging.
The following options can be specified.

Add
The new log is added to previously collected log data.

Replace
All previously collected log data are discarded as invalid and replaced by the new log.



Copy File(Receive)
Copies a file from the global server to a local.
Notes

Options
The following options can be specified.
From File Name
From File Password
From Volume
Data Type
Global Server File Code
To File Name
Replace



From File Name
Specifies the name of the global server file from which data is to be copied, as described 
below.
-    Specify the "Copy From" file name and member name.
-    Multiple files and wildcards can be specified. The member name must not contain a 

"character-string-*".
-    Choose the Browse button for the "Copy From" file to display the Browse File dialog box.
-    Multiple files cannot be specified.



From File Password 
Specifies the file password when the "Copy From" file is an Global Server file protected by a 
password.



From Volume
Specifies the volume when the "Copy From" file is an uncataloged Global Server file.



To File Name
Specifies the name of the local file to which data is to be copied, as described below.
-    Specify the "Copy From" folder name and file name.
-    Multiple files, multiple members, and wild cards cannot be specified.
-    Multiple files cannot be specified.
-    When multiple members or a partitioned file with no member name is specified as the 

"From" file, specify a folder as the "To" file.
-    If "*.extension" is specified when the "From" file is a partitioned file, the extension that is 

specified with the partitioned file member name is appended to member names.    If only 
one character "*" is specified, no extension is appended and the member name of the 
partitioned file is regarded as the name of the "To" file.

-    Pressing the Browse button for the "To" file lets you select the folder name.



Data Type
Specifies the data type: text or binary.    When text is selected, data is converted to the 
specified code.



Global Server File Code
Specifies the global server code.    This is valid when text is specified as the data type.
The following options can be specified.

EBCDIC (ASCII)
Specifies EBCDIC (ASCII).



Note
- When "Copy From" is a partitioned file and "Copy To" is a folder, for text, the partition file 

member name with extension TXT becomes the local name.    For binary, the partition file 
member name with extension BIN becomes the local name.    

- A local tab is converted to one blank character and stored in an Global Server.    Even if 
this file is copied from the Global Server to a local, the tab is not recovered.



Create Folder(Local)
Creates a folder.

Options
Current Folder
The following options can be specified.
Folder Name



Current Folder
The folder name selected in the Select folder dialog box is displayed.
As the default, the current folder name is displayed.



Folder Name
Specifies the name of the folder to create.
When the relative pathname of the folder is specified, the folder is created in the currently 
displayed folder.
When the absolute pathname of the folder is specified, the Folder is created in the specified 
path.
Multiple folders cannot be specified.



Create File(Global Server)
Creates a sequential file, partitioned file, or GEM file in a Global Server direct access device.  
Alternatively, only catalog information of an Global Server file can be registered.
Notes

Options
The following options can be specified.
File Name
Model File Name
File Attributes
Catalog Only

Detailed information of creation
Select the Options tab setting screen from the Create Global Server File dialog box to display
the dialog box for Options.

See Also:
Global Server Cooperation Operation



File Name
Specifies the name of the file to create.
Multiple files cannot be created.

See Also:
How to Input Global Server File Names



Model File Name
Specifies the name of the model file.
Multiple files cannot be created.
Press the Browse button to display the Browse File dialog box.
When this option is specified, a file is created according to the model file attributes.    The 
volume serial number of the model file is not used, however.    If another option is specified, 
the specified value becomes valid.

See Also:
How to Input Global Server File Names



File Attributes
Specifies the attribute of the file to be created.    The Model File attribute can only be 
selected when the Model File Name is specified.

Sequential File
Select this option to create a sequential file.    When this option is selected, the Directory 
Blocks and Library Name are cannot be input.

Partitioned File
Select this option to create a partitioned file.    When this option is selected, the 
Directory Blocks must be specified.    The Library Name is cannot be input.

GEM File
Select this option to create a GEM file.    When this option is selected, the Directory Blocks, 
Secondary Space, Record Format, Record Length, and Control Character are cannot be input.

Attribute of Model File
Create a file with the same file attribute as that of the file specified as the Model File Name.



Options
Sets the Options of the created Global Server file.

Options
The following options can be specified.
Directory Blocks
Library Name
Control Character
Space
Primary Space, Secondary Space
Record Format
Record Length
Block Length
Volume



Directory Blocks
Specifies the number of directory blocks of the partition file to be created.
When a file name is specified as the model file name, specifying 0 creates the same number 
of directories as the model file.



Library Name
Specifies the library name of the GEM file to be created.    Specify "Subproject-Name.Data-
Type.    Version-Name" as the library name in level 3 format.    Specify up to eight 
alphanumeric characters, beginning with a letter, as the Subproject Name, Data Type name, 
and Version Name.



Space
Specifies the unit of space size to be allocated.    The Model File can only be selected when 
the Model File Name is specified.

Blocks
Select this option when the primary space and secondary space option values indicate the 
number of blocks.    The size of one block is the block length specified by the Block Length 
option.

Tracks
Select this option when the primary space and secondary space size option values indicate 
the number of tracks.    

Cylinders
Select this option when the primary space and secondary space size option values indicate 
the number of cylinders.    

Model File
Select this option to allocate the same space size as that of the Model File.    When the 
Primary Space and Secondary Space size are specified, the specified values become valid.



Primary Space, Secondary Space
Specify the space size of the file to be created with the number of blocks, tracks, and 
cylinders.
When a file name is specified as the model file name, specifying 0 allocates the same space 
size as the model file.



Record Format
Select the record format of the file to be created.    The Model File format can only be 
selected when the Model File Name is specified.

Fixed
Select this option to create in fixed-length record format.

Variable
Select this option to create in variable-length record format.

Undefined
Select this option to create in undefined-length record format.

Model File
Select this option to create in Model File record format.



Record Length
Specifies the record length.    The maximum record length that can be specified is 32,760.
When a file name is specified as the model file name, specifying 0 selects the same record 
length as the model file.



Block Length
Specifies the block length.    The maximum block length that can be specified is 32,760.    The
default is unblocked format.
When a file name is specified as the model file name, specifying 0 selects the same block 
length as the model file.    However, if 0 is entered when a file name is not specified as the 
model file name, the file is unblocked.



Control Character
Select the control character type from the drop down list box.    The default is"(None)".    If 
the Model File Name is not specified, "Model File control character" is not displayed in the 
drop down list box.    When the Model File is specified, the default becomes the Model File 
control character.

(None)
Select this option to not create a file with control characters.

ANSI 
Select this option when an ANSI control character is at the beginning of each record.

Mechanical 
Select this option when a mechanical control character is at the beginning of each record.

FACOM 
Select this option when a FACOM control character is at the beginning of each record.

Model 
If the Model File contains no control character, a file with control characters is not created.    
If the Model File contains a control character, a file with control characters is created.    



Volume
Specifies the volume serial number of the volume used to create a file.    The default is the 
system default value.
When set in the operating set logon Information, the volume serial number can be selected 
from the drop down list box and specified.



Catalog Only
Specifies whether to add catalog information only.
When the check box is selected, only catalog information is added.    When this option is 
specified, the Volume option must be specified.
The default in the check box is not selected.



Notes
Options required depending on the specified option are described below.
- If the Model File option is omitted, the Primary Space and Record Format options must be 

specified.
- If the Model File option is omitted, the Record Length must be specified when creating a 

fixed-length or variable-length record file.
- If the Model File of the undefined-record format is specified, the Record Length must be 

specified when creating a fixed-length or variable-length record file.
- To create a fixed-length record file, the Block Length must be equal to or greater than the 

Record Length and must be an integer multiple of the Record Length.
- To create a variable-length record file, the Block Length must be equal to or greater than 

Record Length + 4 bytes.
- When the Global Server is OS IV/XSP, the directory format of the partitioned file to be 

created assumes a fixed entry length of 40 bytes.
- When the Model File name is specified, the Model File attribute is allocated regardless of 

the explicit specification of each file attribute.
 



Delete File(Local)
Deletes a Local file.
In file deletion, the following deletion processing is performed.
- When a folder is deleted, all folder files in that folder are also deleted.
- When Confirmation is checked on the Option menu, a message for confirming deletion is 

displayed.    To delete, choose the Yes button.    To cancel deletion, choose the No button.
-    A message for confirming deletion is displayed before deleting a write-protected, system, 

or hidden file.

Options
The following options can be specified.
File Name



File Name
Specifies the folder name and file name to delete.
Multiple files and wildcards can be specified.
When specifying two or more files,enclose them In quotation marks.



Delete File(Global Server)
Deletes an Global Server file.
Deletes Global Server partitioned files and GEM file members.
Deletes only catalog information of an Global Server file.
When Confirmation is checked on the Option menu, a message for confirming deletion is 
displayed.    To delete, choose the Yes button.    To cancel deletion, choose the No button.

Options
The following options can be specified.
File Name
Member Password
Volume
Delete Member Alias
Delete Catalog Only

See Also:
Global Server Cooperation Operation



File Name
Specifies the file name and member name to delete.
Multiple files and multiple members can be specified.
Press the Browse button to display the Browse File or Member dialog box.

See Also:
How to Input Global Server File Names
How to Input Member Names



Member Password
Specifies the write password to delete a GEM file member protected by a write password.



Volume
Specifies the volume serial number for an uncataloged file.



Delete Member Alias
Specifies whether to delete the alias when the main name of the member is specified.
When the check box is selected, the alias is also deleted.
The default in the check box is not selected.



Delete Catalog Only
Specifies whether to delete catalog information only.
When the check box is selected, only catalog information is deleted.    
The default in the check box is not selected.



Print File
Prints the contents of a file.

Options
The following options can be specified.
File Name
Print Relative Line Number
Folding Print

Font
Press the Font button to display the Font dialog box.

Print Setup
Press the Print Setup button to display the Print Setup dialog box.



File Name
Specifies the name of the file to print.
Press the Browse button to display the Browse File dialog box.
Multiple files and wildcards can be specified.
When specifying two or more files, enclose them in quotation marks.



Print Relative Line Number
Specifies whether to print the relative line numbers.
When the check box is selected, the relative line numbers are printed.
The default in the check box is not selected.



Folding Print
Specifies whether to fold the print data that does not fit on one line, and print it on the next 
line.
When the check box is selected, data is folded and printed.    When the check box is not 
selected, records are truncated.
The default in the check box is not selected.



Rename File(Local)
Renames a Local file.

Options
The following options can be specified.
From
To



From
Specifies the file name or folder name to rename.
Multiple files and wildcards cannot be specified.



To
Specifies the new file name or new folder name.
Drive names and pathnames cannot be specified.



Rename File(Global Server)
Renames an Global Server file.
Renames an Global Server partition file and GEM file member.
Notes

Options
The following options can be specified.
From
Member Password
Volume
To
Assign Member Alias

See Also:
Global Server Cooperation Operation



From
Specifies the file name or member name to rename.
Multiple files, multiple members, and wild cards cannot be specified.
Press the Browse button to display the Browse File or Member dialog box.

See Also:
How to Input Global Server File names
How to Input Member Names



Member Password
Specifies the member password to rename a GEM file member protected by a write 
password.



Volume
Specifies the volume serial number for an uncataloged file.



To
Specifies the new file name or new member name.
When a member name is not specified as the name to be renamed, the entered name is 
regarded as a new file name.    When a member name is specified, the entered name is 
regarded as a new member name.

Multiple files, multiple members, and wild cards cannot be specified.

See Also:
How to Input New File Names
How to Input New Member Names



Assign Member Alias
Specifies whether to add an alias to the Global Server partitioned file member.
When the check box is selected, the alias is added.
The default in the check box is not selected.



Notes
- An alias cannot be added to a load module format member.
- A file alias cannot be renamed.



Reorganize File(Global Server)
Deletes (reorganizes) unnecessary areas of an Global Server partitioned file.    
Changes the space size and storage volume of an Global Server file. 
Notes

Options
The following options can be specified.
File Name
File Password
Volume
Execute File Recovery

Detailed information of reorganization
Select the Options tab setting screen from the Reorganize Global Server File dialog box to 
display the dialog box for setting Options



File Name
Specifies the name of the file to reorganize.
Multiple files and wildcards cannot be specified.
Press the Browse button to display the Brows File dialog box.

See Also:
How to Input Global Server File Names



File Password
Specifies the file password for a file protected by a password.



Volume
Specifies the volume serial number for an uncataloged file.



Execute File Recovery
Specifies whether to execute a file from the work file.
When the check box is selected, the file is recovered from the work file (of previous file 
reorganization) interrupted for some reason. 
The work file name used at recovery is "User-ID.ROGFILE.BACKUP".
The default in the check box is not selected.



Options
The following options can be specified.
Space Unit
Primary, Secondary
Directory Blocks
New Volume



Space Unit
Specifies the unit of space size to be allocated to change the space size.    The options that 
can be specified are listed below.

Default    
Specify this option to use the unit used when the file was allocated.

Blocks    
Specify this option when the Primary and Secondary option values indicate the number of 
blocks.    The size of one block becomes the block length of the file to be reorganized.

Tracks
Specify this option when the Primary and Secondary option values indicate the number of 
tracks.    

Cylinders 
Specify this option when the Primary and Secondary option values indicate the number of 
cylinders.    



Primary, Secondary
Specifies the space size to allocate for changing the space size.
When 0 is specified, the space size remains unchanged.



Directory Blocks
Specifies the number of directory blocks to allocate for changing the number of partitioned 
file directory blocks.
When 0 is specified, the number of directory blocks remains unchanged.



New Volume
Specifies the volume serial number after movement to change the storage volume.



Notes
- When Confirmation is checked on the Option menu, a message for confirming 

reorganization is displayed.    To reorganize, choose the Yes button.    To cancel 
reorganization, choose the No button.

- When Execute File Recovery is specified, the file to reorganize is compared to the number 
of work file members.    When there are more work file members, recovery is based on the 
work file.    When there are fewer work file members, the work file is deleted and ordinary 
reorganization is performed. 

- When a GEM file is organized, NDS information becomes invalid.
- When the file is protected by a password, the Space and New Volume cannot be changed.



Move File(Local)
Moves a file or folder.
Notes

Options
The following options can be specified.
From
To
Replace



From
Specifies the name of the file or folder to be moved.
Multiple files and wildcards can be specified.
When specifying two or more files, enclose them in quotation marks.



To
Specifies the name of the folder or file to move to.
Press the Browse button for the "To" file to display the Browse for Folder dialog box.
Multiple files and wildcards cannot be specified.



Replace
Specifies whether to overwrite an existing file specified as the "To" file.
When the check box is selected, the "To" file is overwritten. 
The default in the check box is the setting of Replace on the Option menu.



Notes
The following move processing is performed according to the specified "From" or "To" file.
- When a folder is moved, all files and folder in that folder are also moved.
- When the "From" file is specified for a folder name, multiple files, and wildcards, specify a 

folder name as the "To" file.
- When a folder is specified as the "From" file, processing differs according to whether the 

"To" folder exists.
If the "To" folder does not exist:
A folder is created with the folder name specified as the "To" file.    Then subfolder and files
are from the "From" folder.
When the "To" folder exists:
A folder with the same name as the "From" folder is created in the "To" folder.    Then 
subfolder and files are moved from the "From" folder to the created folder.

 



Move File Member(Global Server)
Moves an Global Server partitioned file and GEM file member.
Notes

Options
The following options can be specified.
From File Name
From Member Password
From Volume
To File Name
To File Password
To Volume
Replace

See Also:
Global Server Cooperation Operation



From File Name
Specifies the file name and member name that you want to move from.
Multiple members can be specified.
Multiple files cannot be specified.
Press the Browse button for the "From File Name" file to display the Browse File or Member 
dialog box.

See Also:
How to Input Global Server File Names
How to Input Member Names



From Member Password
Specifies the member password when a GEM file member protected by a password is 
specified as the "From File Name" file.



From Volume
Specifies the volume serial number for an uncataloged "From File Name" file.



To File Name
Specifies the file name and member name that you want to move to.
Press the Browse button for the file to display the Browse File or Member dialog box.
When a new file is created, the new file attribute is created according to the "From File 
Name" file attribute.
If the "To File Name" file does not exist, a sequential file is created unless a member name is 
specified as the "To File Name" file name.
When a member name is specified as the "To File Name" file name, the member name must 
also be specified.
When multiple members are specified as the "From File Name" file, a member name cannot 
be specified as the "To File Name" file.
Multiple files, multiple members, and wild cards cannot be specified.

See Also:
How to Input Global Server File Names
How to Input Member Names



To File Password
Specifies the file password for a "To File Name" file protected by a password.



To Volume 
Specifies the volume serial number for an uncataloged "To File Name" file.



Replace
Specifies whether to overwrite the same member that exists in the "To File Name" 
partitioned file or GEM file.
When the check box is selected, the "To File Name" member is overwritten.
The default in the check box is the setting of Replace on the Option menu.



Notes
- When the "To File Name" file is a sequential file, it is replaced regardless of whether the 

overwrite option is specified.
- If the "To File Name" file does not exist, a new file with the specified name is created or an

error occurs.    This depends on the Global Server AP/EF center customize specification. 
- When multiple members are specified as the "From File Name" file, the "To File Name" file 

must also be a partitioned file or GEM file with no member name specified.
- When files with control characters are specified as the "From File Name" file and "To File 

Name" files, the control character types must match.
- When a GEM file member name of nine or more characters is specified as the "From File 

Name" file and a partitioned file with no member name is specified as the "To File Name" 
file, the first eight characters become the "To File Name" member name.

- Move cannot be performed under the following conditions.
A file that cannot be moved is specified as the "From File Name" file.
A fixed-length standard record or variable-length spanned record file is specified as the 
"From File Name" or "To File Name" file.

- When a new to file is created, the block length become as follows, except for when the 
"From File Name" file is a GEM file and the "To File Name" file is not a GEM file.
When the "From File Name" file member has the fixed-length format:
Record length > 3,120 bytes : Record length
Record length <= 3,120 bytes: An integer multiple of up to a 3,120-byte record length 

closest to 3,120
When the from file member has the variable-length format:
Record length > 3,116 bytes : Record length + 4
Record length <= 3,116 bytes: 3,120

- When the "From File Name" file is a GEM file and the "To File Name" file is not a GEM file, 
the record formats must be the same. 

- When the "To File Name" volume option is specified and the file does not exist in the 
specified volume, a new file is created.    The catalog information is not registered, 
however.

- GEM file members that have different record formats cannot be moved.



Options(Local List)
Files displayed in the files list window can be limited to particular groupings.

Options
The following options can be specified.
Name
Title
File Type
Hidden
Size
Modified
Save Settings

See Also:
Configure the File Grouping that is Displayed



Name
Specifies the name of the file to be displayed with a wildcard.
Multiple files cannot be specified.
When specifying two or more files, enclose them in quotation marks.



Title
Specifies the title of files to be displayed with a wildcard.
This item cannot be specified unless "Title" is checked in the By File Type dialog box.
This can be specified only when the titles of the local file list and work space list are 
displayed.



File Type
Specifies the type of file to be displayed.    Default is that both boxes are checked.

Normal File
When check box selection is canceled, normal files are not displayed.

Folder
When check box selection is canceled, folder are not displayed.



Hidden
Specifies that hidden files are to be displayed.    No default is set for the check box.    When 
the check box selection is canceled, hidden files are not displayed.



Size
Files within the specified size are displayed.
Folders are not included in size groupings.



Modified
Folders and files within the specified last modification date are displayed. 



Save Settings
Specifies whether to save the option values.
The default is that the check box is selected.



Options (Global Server File List)
Files displayed in the Global Server file list window can be limited to particular groupings.

Options
The following options can be specified.
Name
File Attributes
Volume
Save Settings

See Also:
Configure the File Grouping that is Displayed



Name
Specifies the name of the file to be displayed in the "specname.%" format.
Multiple files cannot be specified.



File Attribute
Specifies the attribute of files to be displayed.    The default is that all boxes are checked..

Sequential File
When check box selection is canceled, sequential files are not displayed.

Partitioned File
When check box selection is canceled, partitioned files are not displayed.

GEM File
When check box selection is canceled, GEM files are not displayed.

Other File
When check box selection is canceled, other files are not displayed.



Volume
Specifies the volume that contains the file to be displayed.
A wildcard can be specified.



Options(GEM File Member List)
Files displayed in the Global Server GEM file member list window can be limited to particular 
groupings.

Options
The following options can be specified.
Name
Level
Owner
Type
Records
Save Settings

See Also:
Configure the File Grouping that is Displayed



Name
Specifies the name of the member to be displayed with a wildcard.
Multiple files cannot be specified.



Level
Members within the specified level range are displayed.



Owner
Members that have the specified owner name are displayed.
Wildcards can be specified.



Type
Members that have the specified data type are displayed.
Wildcards can be specified.



Records
Members within the specified range of number of lines are displayed.



Options (Partitioned File Member List)
Files displayed in the Global Server partitioned file member list window can be limited to 
particular groupings.

Options
The following options can be specified.
Name
Modified
Type
Level
Save Settings

See Also:
Configure the File Grouping that is Displayed



Name
Specifies the name of the member to be displayed with a wildcard.
Multiple files cannot be specified.



Modified
Members within the specified range of the last modification date are displayed.



Type
Members that have the specified data type are displayed.
Wildcards can be specified.



Level
Members within the specified level range are displayed.



Options(Work Space List)
Files displayed in the work space files list window can be limited to particular groupings.

Options
The following options can be specified.
Name
Title
File Type
Hidden
Size
Modied
Save Settings
Configuration Management

Opening the Configuration Management tab setting screen from the Options dialog box 
displays the dialog box for grouping the Configuration Management file status.
See Also:
Configure the File Grouping that is Displayed



CM Options (Configuration Management Grouping)
Files displayed in work space file lists can be limited to particular groupings.
You can specify the status of files to be displayed.    The default is that all check boxes are 
selected.

Map
When check box selection is canceled, mapped files are not displayed.

Retrieve
When check box selection is canceled, files being retrieved are not displayed.

Check Out
When check box selection is canceled, checked out files are not displayed. 

Other
When check box selection is canceled, files not registered in PowerGEM are not displayed.



Setup Environment 
The Setup Environment command of the Option Menu lets you define the PowerFRAMEVIEW 
environment.
For details, see the Setup Environment help.



Open Global Server
Displayed if the user ID or password is omitted from the Set Logon Information command.    
Opens an Global Server cooperation session based on the entered options.

Host Name
Specifies a name or IP address that identifies a particular host server or gateway on the 
network.

User ID
Specifies the user ID to open an Global Server with up to seven alphanumeric characters, 
beginning with a letter.

Password
Specifies the password assigned to the user ID with up to eight alphanumeric characters.

See Also:
Global Server Cooperation Operation



Get Files List(Global Server)
Opens the Global Server list window.

Options
The following options can be specified.
File Name
Volume
File Password

Notes
- If "\" is included in the file name, "$" is displayed instead.    Asterisks (*) are displayed for 

any volume serial number whose attribute cannot be obtained in the list.

See Also
Global Server Cooperation Operation



File Name
Specifies the Global Server file name to display the file list. 
The following can be specified as the file name.

File Name
Specifies the file name to display.    When a GEM file or partitioned file is specified, the 
member list window is displayed.

Specname.%
A list of files that begin with the specified name is displayed.    For the specified name, a 
simple name (up to eight alphanumeric characters, beginning with a letter) delimited with a 
period can be specified. 

When the specified file name is not enclosed by quotation marks and when a "string to be 
added to the server file name" is specified in the Set LOGON Information of the Options 
menu, the specified string is added at the beginning of the file name.
When the specified file name is enclosed by quotation marks or when no string is specified 
to be added to the server file name, the specified file name is used as is.



Volume
Specifies the volume serial number for files listed on a specific volume or an uncataloged 
file.



File Password
Specifies the password for a file protected by a password.
When the file list is displayed, options are ignored.



New
Creates a new file.

Extension
Specifies the type (extension) of new file created.



Browse File or Member
Helps you select an Global Server file or member.

Options
Specname displays the specified name for the displayed file list.    When the file name is 
omitted, the user ID is assumed.

The following options can be specified.
File Name
Member Name



Browse File 
Helps you select an Global Server sequential file or member.

Options
Specname displays the specified name for the displayed file list.    When the file name is 
omitted, the user ID is assumed.
The following options can be specified.
File Name
Member Name



File Name
Specifies the file name.
The following can be specified as a file name.

File Name
When a GEM file or partitioned file is specified, the member list window is displayed.

Specname.% 
A list of files that begin with the specified name is displayed.    For the specified name, a 
simple name (up to eight alphanumeric characters, beginning with a letter) delimited with a 
period can be specified. 
When the file is selected in the file list box, the selected file name is displayed.
When the specified file name is not enclosed by quotation marks and when a "string to be 
added to the server file name" is specified in Set LOGON Information of the Options menu, 
the specified string is added at the beginning of the file name.
When the specified file name is enclosed by quotation marks or when no string is specified 
to be added to the server file name, the specified file name is used as is.

See Also:
How to Input Global Server File Names



Member Name
Specifies the member name.
A "character-string-*" cannot be specified as a member name.
When the member is selected in the member list box, the selected member name is 
displayed.

See Also:
How to Input Member Names



Browse File
Helps you select a file.

Options
Specname displays the specified name for the displayed file list.    When the file name is 
omitted, the user ID is assumed.
The following options can be specified.
File Name



Select File (Member Only)
Helps you select a partitioned file or GEM file member.

Options
The following options can be specified.
File Name
Member Name



File name
The file name is displayed.



How to Input Member Names(Global Server)
Specifies the member name enclosed in "(" and ")" after the file name.
To specify multiple members, specify member names delimited by blanks within "(" and ")".
When "character-string-*" is specified, all members whose name begins with the specified 
character string are processed.    When * is specified, all members are processed.    
If "character-string-*" or "*" is specified, however, multiple members cannot be specified.

Note:
- If any member name includes "\," input "$" instead.    



How to Input New Member Names(Global Server)
Specifies a member name.
Multiple members cannot be specified.

Note:
If a member name contains "\," enter "$" in place of it.



How to Input Global Server File Names
Specify the file name using a fully qualified name.    The file name need not be enclosed in 
quotation marks.    If the specified file name is not enclosed by quotation marks when "Add 
server file name additional character string" is specified in the Set LOGON Information, the 
specified string is added at the beginning of the file name.    
When specifying multiple files, delimit their names with blanks in the file name specification 
text box.
Wild cards cannot be specified.

Note:
- If a file name contains "\," enter "$" in place of it.



How to Input New Global Server File Names
Specify the file name using a fully qualified name.    The file name need not be enclosed in 
quotation marks.    If the specified file name is not enclosed by quotation marks when "Add 
server file name additional character string" is specified in Set LOGON Information, the 
specified string is added at the beginning of the file name.    
Multiple file names and wild cards cannot be specified.

Note:
If a file name contains "\," enter "$" in place of it.



Set LOGON Information (TCP/IP Cooperation)
Global Server cooperation information is used when an Global Server is opened.    The Global
Server cooperation information command of the Option menu is selected to set Global 
Server cooperation information. 
The option set on the Set General tab setting screen is valid when global server cooperation 
is specified.

Options
The following options can be specified.
Host Name
User Id
Password
Other Strings
Volume
Add Specname
Specname

Connection Information
Opening the Connection Information tab setting screen from the Set LOGON Information 
dialog box displays the dialog box for setting Information on Connection    The option set on 
the Connection Information tab setting screen becomes valid when the global server is 
started.

Operation Method
The host cooperation detailed group is operated as follows.

Add
- Use the mouse or keyboard to select the option to add.
- Change the character string currently displayed to the character string to add.
- Press the Add button.
Up to 10 items can be added.

Change
- Use the mouse or keyboard to select the option to change 
- Open the drop down list box and select the item to change.
- When the item to change is displayed in the box, overwrite the character string to change.
- Press the Modify button.

Delete
- Use the mouse or keyboard to select the option to delete.
- Open the drop down list box and select the item to delete.
- When the item to delete is displayed in the box, press the Delete button.

See Also:



Global Server Cooperation Operation



User ID
Specifies the user ID to open an Global Server session with up to seven alphanumeric 
characters, beginning with a letter.



Password
Specifies the password assigned to the user ID with up to eight alphanumeric characters.



Other Strings
Specifies operands for the LOGON command when an Global Server is opened.    
Specifying the "NOMAIL" and "NONOTICES" operands will increase processing speed. 



Add Specname
Specifies whether to add the host file name additional character string to the beginning of 
the specified host file name when the host file name specified in the dialog box is not 
enclosed in quotation marks.
When the check box is selected, the character string is added.    At addition, the host file 
name additional character string must be defined.
The default is that the check box is not selected.



Volume
Defines the default of the Global Server volume serial number specified in the dialog box for 
manipulating Global Server files.



Host Name
Specifies a name or IP address that identifies a particular host server or gateway on the 
network.



Specname
Specifies a character string of up to 42 alphanumeric characters to be added to the 
beginning of the specified file name.    The character string is added when the host file name 
specified in the dialog box is not enclosed in quotation marks even if "Add the host file name
additional character string" is specified.



Set Information on Connection
Sets information on TCP/IP connection.

Options
The following options can be specified.
System
AP/DF    Project Storage Data Set Name



System
Specifies the OS type of the Global Server system.



AP/DF    Project Storage Data Set Name
Specifies the name of the load module library in which AP/DF is installed.    The library name 
must be a fully qualified name enclosed in quotation marks.    When the library name is 
omitted, the load module library linked to the link list is searched for.



Exec Job
Executes a command procedure or batch job in an Global Server sequential file, partitioned 
file, or GEM file.
The command procedure can be executed in Synchronous Format or Asynchronous Format.
The first record of CLIST must be a PROC statement.

Options
The following options can be specified.
File Name
File Password
Volume
Format

Details of JCL
When the JCL Tab Setting screen is selected from the dialog box for specifying job execution, 
a dialog box for setting    Details of JCL is displayed.

Details of CLIST
When the CLIST Tab Setting screen is selected from the dialog box for specifying job 
execution, a dialog box for setting    Details of CLIST is displayed.

Operation Method
File Name can be added, changed, or deleted as described below.

Adding a File Name
- Select a File Name option by using the mouse or keyboard.
- Change the character string currently displayed to the desired File Name.
- Press the Add button.
Up to 10 items can be added.

Changing the File Name
- Select a File Name option by using the mouse or keyboard.
- Select the File Name to be changed.
- When the target File Name is displayed in the box, overwrite the File Name.
- Press the Change button.

Deleting File Name 
- Select a File Name option by using the mouse or keyboard.
- Select the File Name to be deleted.
- When the target File Name is displayed in the box, press the Delete button.

Note:
- CLIST containing a command that uses the screen in full screen mode cannot be executed.
-    Volume serial numbers cannot be specified for TCP/IP cooperation.



-    When a job is executed while a synchronous CLIST is specified for TCP/IP cooperation, the 
length of the buffer used to execute the global server command is limited; do not specify 
a long character string in a symbolic parameter.

See Also:
Global Server Cooperation Operation



File Name
Specifies the name of the Global Server file that contains the batch job (JCL) or command 
procedure (CLIST) to be started.
For a partitioned file or GEM file, specify a member name enclosed in parentheses ().
When the Browse button is chosen, the Browse File or Member dialog box is displayed.
When the job is started from a file list window, the file name selected from the list is 
displayed.

Examples:
'A3333.TOOL.CLIST(WORK)'



Format
Specifies the type of job to be executed.

Batch-JCL
A batch job (JCL) is to be executed.

Command-CLIST
A command procedure (CLIST) is to be executed.



JCL Options
When executing a command procedure (JCL), specify the following options.
JOB Statement



CLIST Options
When executing a command procedure (CLIST), specify the following options.
Execution Format
Display Result List
Symbolic Parameter
JOB Statement



Symbolic Parameter
Specify this when:
- a parameter must be passed to the command procedure (CLIST) to be executed.
Code each parameter with up to 126 alphanumeric characters enclosed in single quotation 
marks.

Example
'NUMBER MEMLIST'



JOB Statement
Specifies a JOB statement in the following cases.
- No JOB statement is coded in JCL of the Global Server.
- CLIST is executed in asynchronous format by using batch TMP.
If a JOB statement is coded in JCL of the Global Server, this specification is ignored.

Text
A JOB statement can be input directly.
Code the statement on up to three lines of up to 80 characters each.

Example
//job-name JOB 'account-information',CLASS=job-class,
// TIME=CPU-time,MSGCLASS=message-class,
// MSGLEVEL=contents-of-message,NOTIFY=user-ID

File
The JOB statement can be fetched from a file.    The fetched JOB statement contains the first 
three lines of the selected file.



Execution Format
Specifies the format in which a command procedure (CLIST) is to be executed.

Synchronous
The command procedure is to be executed in command format.

Asynchronous
The command procedure is to be executed in batch format by using batch TMP.



Display Result List
Specifies whether the results are to be displayed after a command procedure (CLIST) is 
executed in synchronous format.

YES
The execution results are to be displayed on the screen.

NO
The execution results are not to be displayed on the screen.    When this option is selected, 
the execution result, cannot be referenced.



Details of Exec Job
Specifies detailed information on job execution.

Volume



File Password
Specifies a password of up to eight alphanumeric characters when the file with the specified 
File Name is password-protected.



Volume
Specifies a volume serial number of up to six alphanumeric characters for the volume 
containing an uncataloged file with the specified File Name.



Synchronous Format
A command procedure (CLIST) is to be executed in command format.



Asynchronous Format
A command procedure (CLIST) is to be executed in batch format by using batch TMP.



Delete Job(Global Server)
Cancels jobs waiting for input, aborts running jobs, deletes results of jobs waiting for output.

Options
The following options can be specified.
Job Name
Job Code
Delete Results

See Also:
Global Server Cooperation Operation



Job Name
Specifies the name of the job to be deleted.
If the job name contains "\," enter "$" in place of it.



Job Code
Specifies the code that identifies the job to be deleted.
The job code cannot be specified when the global server is OSIV/XSP.



Delete Results
Specifies whether to delete the results of job execution.
This is used when you are aborting a running job and want to delete its execution results.
No default is set for the check box.



Options (Repository List)
Files displayed in the repository list window can be limited to particular groupings.

Options
The following options can be specified.
Name
Title
File Type
Hidden
Level
Update User 
Modified
Save Settings

Configuration Management
Opening the Configuration Management tab setting screen from the Options dialog box 
displays the dialog box for grouping the Configuration Management file status.
See Also:
Configure the File Grouping that is Displayed



Level
Displays the names of the files of the specified level when repository information is 
displayed.
Folders cannot be grouped.



Update User
Specifies the update user of the file to be displayed by using a wild card when repository 
information is displayed.
Folders cannot be grouped.



Configuration Management
Files displayed in work space file lists can be limited to particular groupings.
You can specify the status of files to be displayed.    The default is that all check boxes are 
selected.
Repository List

Map
When check box selection is canceled, mapped files are not displayed.

Retrieve
When check box selection is canceled, files being retrieved are not displayed.

Check Out
When check box selection is canceled, checked out files are not displayed. 

Lock
When the check box selection is canceled, the files checked out to other work spaces are not
displayed.

Unmapped 
When the check box selection is canceled, the files that are in the repository but not in the 
work space are not displayed.

Other
When the check box selection is canceled, the files that are not registered in the repository 
are not displayed.




