
Contents of Script Debugger Help
This section displays the list of help items related to the script debugger.    To view an item 
not displayed in the help window, use the scroll bar.
To learn how to use Help, press [F1] or select the [How to use help] command from the 
[Help] menu.

Keyboard
Script Debugger Keys

Commands
[File] Menu Commands
[Edit] Menu Commands
[Search] Menu Commands
[Execution Control] Menu Commands
[Variable] Menu Commands
[Other] Menu Commands
[Window] Menu Commands

How to...
Open Script Not Displayed
Select and Open Script Not Displayed
Cancel [Open] Command
Close Script Displayed on Top
Close Script Not Displayed on Top
Exit Script
Cancel [Exit] Command
Copy Script Text
Select All Script Text
Undo [Select All] Command
Search Script
Cancel [Search String] Command
Continue Script Search
Display Script from Specified Line
Cancel [Specified Line] Command
Display Script from Beginning
Display Last Line of Script
Set Interrupt Point in Script Displayed
Set Interrupt Point in Script Not Displayed
Undo Interrupt Point Setting
Release Interrupt Point in Script Displayed
Release Interrupt Point in Script Not Displayed
Undo Interrupt Point Release
Release All Interrupt Points in Script Displayed



Cancel [Release All Interrupt Points] Command
Execute Script from Start Point
Change Start Point of Script Displayed
Change Start Point of Script Not Displayed
Undo Start Point Change
Interrupt Script Execution
Execute One Step of Script from Start Point
Exit Script Execution
Cancel [Exit Script] Command
Validate Execution Trace
Invalidate Execution Trace
Validate Function Trace
Invalidate Function Trace
Save Window Exit Status
Change Trace Speed at Trace Execution
Cancel [Change Environment] Command
Sort and Display Script Displayed
Display [Display Variable] Window
Cut in Variable Display
Copy in Variable Display
Paste in Variable Display
Delete in Variable Display
Register Variable Name
Cancel [Register Variable Name] Command
Undo Variable Name Registration 
Select and Register Variable Name
Select and Register Multiple Variable Names
Cancel [Select and Register Variable Name] Command
Undo Variable Name Selection and Registration 
Delete Variable Name
Delete Multiple Variable Names
Undo Variable Name Deletion
Change Variable Value
Undo Variable Value Change 
Confirm Variable Value Change 
Undo Variable Value
Cancel Display Variable
Display [Execute Script Statement] Window
Cut in Script Statement Execution
Copy in Script Statement Execution
Paste in Script Statement Execution
Delete in Script Statement Execution



Execute Script Statement 
Undo Script Statement Execution
Exit Script Statement Execution
Interrupt Script Statement Execution
Cancel [Execute Script Statement] Command 
Display [Function Trace] Window
Copy in Function Trace
Exit [Function Trace] Window
Select and Display Script Displayed
Activate Script Display 





Script Debugger Keys
The script debugger uses the keys listed below.
To display the help for each command, select the corresponding menu.    To see an item not 
displayed, use the scroll bar.
Shortcut Keys



Shortcut Keys

Ctrl + Z
Cancels the previously executed command or operation.

Ctrl + X
Deletes and copies selected text to the clipboard.

Ctrl + C
Copies selected text to the clipboard.

Ctrl + V
Inserts clipboard text at the cursor position.

Delete
Deletes selected text.

F7
Sets an interrupt point.

F7
Releases an interrupt point.

F9
Executes a script.

F8
Changes the execution start point of the script.

Pause
Interrupts script execution.

F5
Executes one step of a script.

F3
Searches for the next character string.

F2
Selects the specified line command.

Ctrl + Home
Displays the beginning.

Ctrl + End
Displays the end.





Script Debugger Command List
To display the help for each command, select the corresponding menu.    To view an item not 
displayed, use the scroll bar.
[File] Menu Commands
[Open]
[Close]
[Exit]
[Edit] Menu Commands
[Undo]
[Cut]
[Copy]
[Paste]
[Delete]
[Select all]
[Search] Menu Commands
[Search string]
[Search next]
[Specified line]
[Beginning]
[End]
[Execution Control] Menu Commands
[Set interrupt point]
[Release interrupt point]
[Release all interrupt points]
[Execute]
[Change start point]
[Interrupt]
[Execute one step]
[Exit script]
[Execute trace]
[Function trace]
[Variable] Menu Commands
[Register variable name]
[Select and register variable name]
[Delete variable name]
[Other] Menu Commands
[Change environment]
[Window] Menu Commands
[Sort]
[Display variable]
[Execute script statement]



[Function trace]
[Select script (number) ]
[Display script]





[File] Menu Commands
The file menu contains commands for displaying script, not displaying script, exiting the 
script debugger, and exiting script execution.
For details, select the following file menu commands.
[Open]
[Close]
[Exit]
To view an item not displayed, use the scroll bar.



[Open] Command
This command opens a script that can be used by the script debugger.
Selecting the [Open] command displays the [Open] dialog box.    The object script can be 
specified or selected.
See Also
Open Script Not Displayed
Select and Open Script Not Displayed
Cancel [Open] Command 



[Close] Command
This command closes the specified script.
Selecting the [Close] command closes the script display and edit window displayed on top.
See Also
Close Script Displayed on Top
Close Script Not Displayed on Top



[Exit] Command
This command terminates the script debugger and, if specified, halts script execution.
Selecting the [Exit] command displays the [Exit] message box.    When the check box is 
specified and the [OK] button is selected, the script debugger and script execution can be 
terminated.
See Also
Exit Script 
Cancel [Exit] Command





[Edit] Menu Commands
The edit menu contains commands for operating the clipboard.
For details, select the following edit menu commands.
[Undo]
[Cut]
[Copy]
[Paste]
[Delete]
[Select All]



[Undo] Commands
These commands cancel the command executed immediately before or operation performed
immediately before.
Selecting the [Undo] command cancels the command executed immediately before.    After 
changing a variable value in the [Display variable] window or executing a script statement in
the [Execute script statement] window, the operation performed immediately before can be 
canceled.
See Also
Undo Interrupt Point Setting
Undo Interrupt Point Release
Undo Start Point Change 
Undo Variable Name Registration
Undo Variable Name Selection and Registration
Undo Variable Name Deletion
Undo Variable Value Change 
Undo [Cut] Command
Undo [Paste] Command
Undo [Delete] Command
Undo [Select All] Command
Undo Script Statement Execution



[Cut] Command
This command cuts selected text to the clipboard.
When the [Cut] command is selected, selected text is deleted and copied to the clipboard.
See Also
Cut in Variable Display
Cut in Script Statement Execution



[Copy] Command
This command copies the selected text to the clipboard.
When the [Copy] command is selected, selected text is copied to the clipboard without being
deleted.
See Also
Copy Script Text
Copy in Variable Display
Copy in Script Statement Execution
Copy in Function Trace



[Paste] Command
This command inserts clipboard text in the cursor position.
When the [Paste] command is selected, clipboard text is inserted before the specified cursor 
position or is replaced with the selection section.
See Also
Paste in Script Statement Execution
Paste in Variable Display



[Delete] Command
This command deletes the selected text.
When the [Delete] command is selected, selected text is deleted and the section that follows
is padded.
See Also
Delete in Variable Display
Delete in Script Statement Execution



[Select All] Command
This command selects the entire text.
When the [Select all] command is selected, the entire text is selected.
See Also
Select All Script Text





[Search] Menu Commands
The search menu contains commands are related to script search and display position.
For details, select the following search menu commands.
[Search String]
[Search Next]
[Specified Line]
[Beginning]
[End]



[Search String] Command
This command searches for the specified character string.
When the [Search string] command is selected, the search dialog box is displayed.    Specify 
the search string.    Press the OK button to start the search.    When the character string is 
found, the corresponding character string is selected.    If the character string is not found, 
the message box is displayed.
See Also
Search Script
Cancel [Search String] Command



[Search Next] Command
This command continues searching for the character string set by the Search command.
When the [Search next] command is selected, the specified search processing is continued.
See Also
Continue Script Search



[Specified Line] Command
This command enables display from the specified line.
When the [Specified line] command is selected, the specified line dialog box is displayed.    
Press the OK button after specifying the desired line enables display from that specified line. 
If a line beyond the last line is specified, the last line is assumed.
See Also
Display Script from Specified Line
Cancel [Specified Line] Command



[Beginning] Command
This command displays a script from the beginning.
When the [Beginning] command is selected, the script is displayed from the beginning.
See Also
Display Script from Beginning 



[End] Command
This command displays a script up to and including the last line.
When the [End] command is selected, the script (including the last line) is displayed.
See Also
Display Last Line of Script 





[Execution Control] Menu Commands
The execution control menu contains commands related to execution control of the script 
debugger.
For details, select the following execution control menu commands.
[Set Interrupt Point]
[Release Interrupt Point]
[Release All Interrupt Points]
[Execute]
[Change Start Point]
[Interrupt]
[Execute One Step]
[Exit Script]
[Execution Trace]
[Function Trace]



[Set Interrupt Point] Command
This command sets an interrupt point in the script.
When the [Set interrupt point] command is selected, an interrupt point can be set on each 
line of the script.
See Also
Set Interrupt Point in Script Displayed
Set Interrupt Point in Script Not Displayed



[Release Interrupt Point] Command
This command releases an interrupt point already set in the script.
When the [Release interrupt point] command is selected, the interrupt points set on each 
line of the script are released.
See Also
Release Interrupt Point in Script Displayed
Release Interrupt Point in Script Not Displayed



[Release All Interrupt Points] Command
This command releases all interrupt points already set in the script.
When the [Release all interrupt points] command is selected, the message box for releasing 
all interrupt points is displayed.    All interrupt points set are also released.
See Also
Release All Interrupt Points in Script Displayed
Cancel [Release All Interrupt Points] Command



[Execute] Command
This command restarts script execution.
When the [Execute] command is selected, the script is executed until the next interrupt 
event occurs.
See Also
Execute Script from Start Point



[Change Start Point] Command
This command changes the execution start point of a script.
When the [Change start point] command is selected, the execution start point is changed to 
the specified position.
See Also
Change Start Point of Script Displayed
Change Start Point of Script Not Displayed



[Interrupt] Command
This command interrupts script execution.
When the [Interrupt] command is selected, script execution is interrupted.    Control is also 
transferred to the script debugger.
See Also
Interrupt Script Execution



[Execute One Step] Command
This command executes one step of a script.
When the [Execute one step] command is selected, one step of the script is executed.    
Reverse video display of the control area switches to the next line and execution is 
interrupted.
See Also
Execute One Step of Script from Start Point



[Exit Script] Command
This command terminates script execution.
When the [Exit script] command is selected, the [Exit script] message box is displayed.    
Script execution can be terminated.
See Also
Exit Script Execution
Cancel [Exit Script] Command



[Execution Trace] Command
This command validates and invalidates an execution trace.
When the [Execution trace] command is selected, validation and invalidation are set 
alternately.
See Also
Validate Execution Trace
Invalidate Execution Trace
Change Trace Speed at Trace Execution 



[Function Trace] Command
This command validates and invalidates a function trace.
When the [Function trace] command is selected, validation and invalidation are set 
alternately.
See Also
Validate Function Trace
Invalidate Function Trace





[Variable] Menu Commands
The variable menu contains commands for controlling variable name display and changing 
variable values.
For details, select the following variable menu commands.
[Register Variable Name]
[Select and Register Variable Name]
[Delete Variable Name]



[Register Variable Name] Command
This command registers a variable name for variable display.
Selecting the [Register variable name] command displays the [Register variable name] 
dialog box.    The variable name can be input.
See Also
Register Variable Name
Cancel [Register Variable Name] Command



[Select and Register Variable Name] Command
This commands selects and registers variable names for variable display.
Selecting the [Select and register variable name] command displays the [Variable name list] 
list box.    The variable name can be selected from the variable name list.
See Also
Select and Register Variable Name
Select and Register Multiple Variable Names
Cancel [Select and Register Variable Name] command



[Delete Variable Name] Command
This command deletes the variable displayed.
When the [Delete variable name] command is selected, the variable name and displayed 
variable value specified in the [Display variable] window are deleted.
See Also
Delete Variable Name
Delete Multiple Variable Names





[Other] Menu Commands
Other menus containing commands related to environment setup.
For details, select the following another menu command.
[Change Environment]



[Change Environment] Command
This command changes the speed of saving and tracing the window exit status.
Selecting the [Change environment] command displays the [Change environment] dialog 
box.    The display speed of saving and tracing the window exit status can be set.
See Also
Save Window Exit Status
Change Trace Speed at Trace Execution 
Cancel [Change Environment] Command





[Window] Menu Commands
The window menu includes commands used to control individual window selections.
For details, select the following window menu commands.
[Sort]
[Display Variable]
[Execute Script Statement]
[Function Trace]
[Select Script (Number) ]
[Display Script]
To view a command not displayed in the window, use the scroll bar.



[Sort] Command
This command displays the title of the script display screen.
When the [Sort] command is selected, the script display and edit window displayed is sorted.
See Also
Sort and Display Script Displayed



[Display Variable] Command
This command displays the display variable window.
Selecting the [Display variable] command displays the [Display variable] window, if not 
already displayed.    When the [Display variable] window is already displayed, the window is 
activated.
See Also
Display [Display Variable] Window
Change Variable Value
Confirm Variable Value Change
Undo Variable Value
Cancel Display Variable



[Execute Script Statement] Command
This command displays the [Execute script statement] window.
Selecting the [Execute script statement] command displays the [Execute script statement] 
window, if not already displayed.    When the [Execute script statement] window is already 
displayed, the window is activated.
See Also
Display [Execute Script Statement] Window
Execute Script Statement
Cancel [Execute Script Statement] Command
Exit Script Statement Execution
Interrupt Script Statement Execution



[Function Trace] Command
This command traces a function.
Selecting the [Function trace] command displays the [Function trace] window, if not already 
displayed.    When the [Function trace] window is already displayed, the window is activated.
See Also
Display [Function Trace] Window
Exit [Function Trace] Window



[Select Script (Number)] Command
This command displays the specified script on top.
When the [Select script (number)] command is selected, the specified [Script display and 
edit] window is displayed on top.
See Also
Select and Display Script Displayed
Activate Script Displayed



[Display Script] Command
This command activates the script display and edit window.
When the [Display script] command is selected, the [Script display and edit] window is 
displayed.
See Also
Select and Display Script Displayed
Activate Script Displayed





Main Window Commands
Main window commands

[File] menu commands
[Open]
[Close]
[Exit]

[Edit] menu commands
[Undo]
[Copy]
[Select all]

[Search] menu commands
[Search string]
[Search next]
[Specified line]
[Beginning]
[End]

[Execution control] menu commands
[Set Interrupt Point]
[Release Interrupt Point]
[Release All Interrupt Points]
[Execute]
[Change Start Point]
[Interrupt]
[Execute One Step]
[Exit Script]
[Execute Trace]
[Function Trace]

[Other] menu commands
[Change Environment]

[Window] menu commands
[Sort]
[Display Variable]
[Execute Script Statement]
[Function Trace]
[Select Script (Number) ]





Display Variable Window Commands
[Edit] menu commands
[Undo]
[Cut]
[Copy]
[Paste]
[Delete]

[Variable] menu commands
[Register Variable Name]
[Select and Register    Variable Name]
[Delete Variable Name]

[Window] menu commands
[Execute Script Statement]
[Function Trace]
[Display Script]





Execute Script Statement Window Commands
[Edit] menu commands
[Undo]
[Cut]
[Copy]
[Paste]
[Delete]

[Window] menu commands
[Display Variable]
[Function Trace]
[Display Script]





Function Trace Window Commands
[Edit] menu commands
[Copy]

[Window] menu commands
[Display Variable]
[Execute Script Statement]
[Display Script]





Operating Procedure for Main Window
Operating procedure for main window
Open Script Not Displayed
Select and Open Script Not Displayed
Cancel [Open] Command
Close Script Displayed on Top
Close Script Not Displayed on Top
Exit Script
Cancel [Exit] Command
Copy Script Text
Select All Script Text
Undo [Select All] Command
Search Script
Cancel [Search String] Command
Search Next String
Display from Specified Line of Script
Cancel [Specified Line] Command
Display from Top of Script
Display Last Line of Script
Set Interrupt Point of Script Displayed
Set Interrupt Point of Script Not Displayed
Undo Interrupt Point setting
Release Interrupt Point of Script Displayed
Release Interrupt Point of Script Not Displayed
Undo Interrupt Point Release
Release All Interrupt Points of Script Displayed
Cancel [Release All Interrupt Points] Command
Execute Script from Start Point
Change Start Point of Script Displayed
Change Start Point of Script Not Displayed
Undo Start Point Change
Interrupt Script Execution
Execute One Step of Script from Start Point
Exit Script Execution
Cancel [Exit Script] Command
Validate Trace Execution
Invalidate Trace Execution
Validate Function Trace
Invalidate Function Trace
Save Window Termination Status
Change Trace Speed at Trace Execution



Cancel [Change Environment] Command
Sort and Display Script Displayed
Display [Display Variable] Window
Display [Execute Script Statement] Window
Display [Function Trace] Window
Select and Display Script Displayed





Operating Procedure for Display Variable Window
Operating procedure for display variable window
Register Variable Name
Select and Register Variable Name
Select and Register Multiple Variable Names
Undo Variable Name Registration
Undo Variable Name Selection and Registration
Delete Variable Name
Delete Multiple Variable Names
Undo Variable Name Deletion
Change Variable Value
Confirm Variable Value Change 
Undo Variable Value
Cancel Variable Display
Undo Variable Value Change
Cut in Variable Display
Copy in Variable Display
Paste in Variable Value
Delete in Variable Value
Undo [Cut] Command
Undo [Paste] Command
Undo [Delete] Command
Activate Script Display
Display [Execute Script Statement] Window
Display [Function Trace] Window
Cancel [Register Variable Name] Command
Cancel [Select and Register Variable Name] Command





Operating Procedure for Execute Script Statement Window
Operating procedure for execute script statement window
Execute Script Statement 
Exit Script Statement Execution
Interrupt Script Statement Execution
Undo Script Statement Execution
Cut in Script Statement Execution
Copy in Script Statement Execution
Paste in Script Statement Execution
Delete in Script Statement Execution
Undo [Cut] Command
Undo [Paste] Command
Undo [Delete] Command
Activate Script Display
Display [Display Variable] Window
Display [Function Trace] Window
Cancel [Execute Script Statement] Command





Operating Procedure for Function Trace Window
Operating procedure for function trace window
Exit [Function Trace] Window
Copy in Function Trace
Activate Script Display
Display [Display Variable] Window
Display [Execute Script Statement] Window





Open Script Not Displayed
To open the object script, operate as follows.
1 Select the [Open] command from the [File] menu.
2 Input the script name to open in the [Script name] text box.
3 Select the [OK] button.
The script name is added to the [Window] pop-up menu and a check mark is displayed.    If 
the specification is incorrect, the [Error] message box is displayed.



Select and Open Script Not Displayed
1 Select the [Open] command from the [File] menu.
2 Select one script from the [Script list] list box.    The selected script name is displayed in 

the [Script name] text box.
3 Select the [OK] button.
The script name is added to the [Window] pop-up menu and a check mark is displayed.    If 
the specification is incorrect, the [Error] message box is displayed.



Close Script Displayed on Top
To close the script display and edit window on top, operate as follows.
1 Select the [Close] command from the [File] menu.

If the corresponding script is not running, the [Script display and edit] window on top is 
closed.
The corresponding script name is deleted from the [Window] pop-up menu.

If the corresponding script is running, the [Error] message box is displayed and the 
command is invalidated.



Close Script Not Displayed on Top
To close the script display and edit window not displayed on top, operate as follows.
1 Display the corresponding script display and edit window on top.
2 Select the [Close] command from the [File] menu.

If the corresponding script is not running, the [Script display] window is closed.
The corresponding script name is deleted from the [Window] pop-up menu.

If the corresponding script is running, the [Error] message box is displayed and the 
command is invalidated.



Exit Script
To terminate the debugger and halt script execution, operate as follows.
1 Select the [Exit] command from the [File] menu.

The [Exit] message box is displayed.
2 To terminate the debugger and halt script execution, select the check box.    To terminate 

the debugger only, do not select the check mark in the check box.
3 Select the [OK] button.

If closing all displays under the debugger main window and halting script execution are 
specified, script execution also halts.





Undo Variable Name Registration
To undo variable name registration, operate as follows.
1 Select the [Undo] command from the [Edit] menu immediately after variable name 

registration.    The registered variable name is deleted.



Undo Variable Name Selection and Registration
To undo variable name selection and registration, operate as follows.
1 Select the [Undo] command from the [Edit] menu immediately after variable name 

selection and registration.    The registered variable name is deleted.



Undo Variable Name Deletion
To undo variable name deletion, operate as follows.
1 Select the [Undo] command from the [Edit] menu immediately after variable name 

deletion.    The deleted registered variable name is restored.



Undo [Cut] Command
To use the [Undo] command to cancel the [Cut] command, operate as follows.
1 Select the [Undo] command from the [Edit] menu immediately after cutting.    The status 

before Cut command execution is restored.



Undo [Paste] Command
To use the [Undo] command to cancel the [Paste] command, operate as follows.
1 Select the [Undo] command from the [Edit] menu immediately after pasting.    The status 

before Paste command execution is restored.



Undo [Delete] Command
To use the [Undo] command to cancel the [Delete] command, operate as follows.
1 Select the [Undo] command from the [Edit] menu immediately after deletion.    The status 

before Delete command execution is restored.



Undo [Select All] Command
To use the [Undo] command to cancel the [Select all] command, operate as follows.
1 Select the [Undo] command from the [Edit] menu immediately after command selection.    

The status before command execution is restored.



Undo Variable Value Change
To use the [Undo] command in the [Display variable] window to cancel the previous 
operation, operate as follows.
1 Select the [Undo] command from the [Edit] menu.

The variable value changed immediately before is restored the value before modification.
When the previous operation is a command, the status before command execution is 
restored.



Undo Script Statement Execution
The [Undo] command in the [Execute script statement] window restores the script statement
as follows.
1 Select the [Undo] command from the [Edit] menu.

The currently displayed script statement being input is restored to the status before 
modification.
If the previous operation is a command, the status before command execution is restored.

If the previous operation is an [Undo] command, the result of the last [Undo] command 
executed can be canceled.



Cut in Variable Display
To use the [Cut] command to cut the variable display window to the clipboard, operate as 
follows.
1 Select the text to cut.
2 Select the [Cut] command from the [Edit] menu.



Cut in Script Statement Execution
To use the [Cut] command to cut selected text to the clip board, operate as follows.
1 Select the text to cut.
2 Select the [Cut] command from the [Edit] menu.



Copy Script Text
To use the [Copy] command to copy selected text to the clip board, operate as follows.
1 Select the text to cut.
2 Select the [Copy] command from the [Edit] menu.



Copy in Variable Display
To use the [Copy] command to copy the variable display to the clipboard, operate as follows.
1 Select the variable to copy.
2 Select the [Copy] command from the [Edit] menu.



Copy in Script Statement Execution
To use the [Copy] command to copy selected text to the clipboard, operate as follows.
1 Select the variable to copy.
2 Select the [Copy] command from the [Edit] menu.



Copy in Function Trace
To use the [Copy] command to copy selected text to the clipboard, operate as follows.
1 Select the variable to copy.
2 Select the [Copy] command from the [Edit] menu.



Paste in Variable Display
To use the [Paste] command to copy the contents of the clipboard to the cursor position, 
operate as follows.
1 Move the cursor to the position to copy.
2 Select the [Paste] command from the [Edit] menu.



Paste in Script Statement Execution
To use the [Paste] command to copy the contents of the clipboard to the cursor position, 
operate as follows.
1 Move the cursor to the position to copy.
2 Select the [Paste] command from the [Edit] menu.



Delete in Variable Display
To use the [Delete] command to delete selected text, operate as follows.
1 Select the text to delete.
2 Select the [Delete] command from the [Edit] menu.



Delete in Script Statement Execution
To use the [Delete] command to delete selected text, operate as follows.
1 Select the text to delete.
2 Select the [Delete] command from the [Edit] menu.



Select All Script Text
To use the [Select all] command to select the entire text, operate as follows.
1 Activate the script display and edit window.
2 Select the [Select all] command from the [Edit] menu.





Search Script
To search the script display and edit window, operate as follows.
1 Select the [Search string] command from the [Search] menu.

The [Search] dialog box is displayed.    Specify the character string to search.
2 Select the [OK] button.    When the character string is found, the corresponding character 

string is set to the selected status.    If the character string is not found, the message box 
is displayed.



Continue Script Search
To search for the next string in the script display and edit window, operate as follows.
1 Select the [Search next] command from the [Search] menu.    When the character string is 

found, the corresponding character string is set to the selected status.    If the character 
string is not found, the message box is displayed.



Display Script from Specified Line
To display from the specified line of the script display and edit window, operate as follows.
1 Select the [Specified line] command from the [Search] menu.

The [Specified line] dialog box is displayed.    Specify the line to display.
2 Select the [OK] button.    If the specified line exceeds the last line, the last line is assumed.



Display Script from Beginning
To display from the top of the script display and edit window, operate as follows.
1 Select the [Beginning] command from the [Search] menu.
The script is displayed from the top.



Display Last Line of Script
To display the last line in the script display and edit window, operate as follows.
1 Select the [End] command from the [Search] menu.
The script that includes the last line is displayed.





Set Interrupt Point in Script Displayed
To set an interrupt point, operate as follows.
1 Position the I-character cursor on the script line to set an interrupt point. Otherwise, click 

the left mouse button in the control area of the corresponding line.
When the left mouse button is clicked, step 2 is not required.

2 Select the [Set interrupt point] command from the [Execution control] menu.
A check mark (*) is displayed in the script where the interrupt point is set.



Set Interrupt Point in Script Not Displayed
To set an interrupt point, operate as follows.
1 Select the [Script display and edit] window to set an interrupt point.
2 Position the I-character cursor on the script line to set an interrupt point. Otherwise, click 

the left mouse button in the control area of the corresponding line.
When the left mouse button is clicked, step 3 is not required.

3 Select the [Set interrupt point] command from the [Execution control] menu.
A check mark (*) is displayed in the script where the interrupt point is set.



Undo Interrupt Point Setting
To use the [Undo] command to undo an interrupt point setting, operate as follows.
1 Select the [Undo] command from the [Edit] menu immediately after setting the interrupt 

point.



Release Interrupt Point in Script Displayed
To release an interrupt point, operate as follows.
1 Position the I-character cursor on the script line to release the interrupt point. Otherwise, 

click the left mouse button on the display position (*).
When the left mouse button is clicked, step 2 is not required.

2 Select the [Release interrupt point] from the [Execution control] menu.
The interrupt point check mark (*) disappears from the script in which the interrupt point 
is released.



Release Interrupt Point in Script Not Displayed
To release an interrupt point, operate as follows.
1 Select the [Script display and edit] window to release the interrupt point.

The selected script is displayed.
2 Position the I-character cursor on the script line to release the interrupt point. Otherwise, 

click the left mouse button on the display position (*).
When the left mouse button is clicked, step 3 is not required.

3 Select the [Release interrupt point] from the [Execution control] menu.
The interrupt point check mark (*) disappears from the script in which the interrupt point 
is released.



Undo Interrupt Point Release
To use the [Undo] command to undo interrupt point release, operate as follows.
1 Select the [Undo] command from the [Edit] menu immediately after releasing the 

interrupt point.



Release All Interrupt Points in Script Displayed
To release all interrupt points, operate as follows.
1 Activate the script to release interrupt points.
2 Select the [Release all interrupt points] command from the [Execution control] menu.

The message box for releasing all interrupt points is displayed.
3 Select the [OK] button.

All interrupt points are released and interrupt point check marks (*) disappear from the 
script.



Execute Script from Start Point
To execute a script from the start point, operate as follows.
1 Select the [Execute] command from the [Execution control] menu.

Script execution resumes from the start point.
During an execution trace, the currently running script is displayed in reverse video.



Change Start Point of Script Displayed
To change the execution start point of a script to another specified position, operate as 
follows.
1 Position the I-character cursor on the script line to change the execution start point.
2 Select the [Change start point] command from the [Execution control] menu.

The execution start point is changed in the specified script.



Change Start Point of Script Not Displayed
To change the execution start point of a script to another specified position, operate as 
follows.
1 Select the [Script display and edit] window to change the execution start point.

The selected script is displayed.
2 Position the I-character cursor on the script line to change the execution start point.
3 Select the [Change start point] command from the [Execution control] menu.

The execution start point is changed in the specified script.



Undo Start Point Change
To use the [Undo] command to undo the changed execution start point, operate as follows.
1 Select the [Undo] command from the [Edit] menu immediately after changing the 

execution start point.



Interrupt Script Execution
To interrupt script execution, operate as follows.
1 Select the [Interrupt] command from the [Execution control] menu.

When execution of the currently running script is completed, processing is interrupted at 
the beginning of the next script line.



Execute One Step of Script from Start Point
To execute one step of a script from the start point, operate as follows.
1 Select the [Execute one step] command from the [Execution control] menu.

One line of script is executed from the start point.
Processing is interrupted at the beginning of the next script line.



Exit Script Execution
To terminate script execution, operate as follows.
1 Select the [Exit script] command from the [Execution control] menu.

The [Exit script] message box is displayed.
2 Selecting the [OK] button exits script execution.



Validate Execution Trace
To validate a script trace, operate as follows.
1 Select the [Execution trace] command from the [Execution control] menu with the 

execution trace in invalid status (with the menu trace check mark not displayed).
The script trace is validated and the running script is displayed in reverse video one line at
a time.



Invalidate Execution Trace
To invalidate a script trace, operate as follows.
1 Select the [Execution trace] command from the [Execution control] menu with the 

execution trace in valid status (with the trace menu check mark displayed).
The script trace is aborted and the running script is not displayed in reverse video.



Validate Function Trace
To validate a function trace, operate as follows.
1 Select the [Function trace] command from the [Execution control] menu with the function 

trace in invalid status (with the trace menu check mark not displayed).
The function trace is validated and the trace contents are displayed on the function trace 
display screen.



Invalidate Function Trace
To invalidate a function trace, operate as follows.
1 Select the [Function trace] command from the [Execution control] menu with the function 

trace in valid status (with the trace menu check mark displayed).
The function trace is aborted.





Register Variable Name
To register a variable name, operate as follows.
1 Select the [Register variable name] command from the [Variable] menu.

The [Register variable name] dialog box is displayed.
2 Enter the variable name to display in the [Register variable name] dialog box.
3 Select the [OK] button.



Select and Register Variable Name
To select and register a variable name, operate as follows.
1 Select the [Select and register variable name] command from the [Variable] menu.

The [Variable name list] dialog box is displayed.
2 Select the variable name to display from the [Variable name list] list box.
3 Select the [OK] button.



Select and Register Multiple Variable Names
To register multiple variable names, operate as follows.
1 Select the [Select and register variable name] command from the [Variable] menu.

The [Variable name list] dialog box is displayed.
2 Select the variable name to display from the [Variable name list] list box.
3 Select the [OK] button.



Delete Variable Name
To delete a variable name, operate as follows.
1 Select the variable name to delete from the [Variable name list] list box of the [Variable 

display] window.
2 Select the [Delete variable name] command from the [Variable] menu.



Delete Multiple Variable Names
To delete multiple variable names, operate as follows.
1 Select the variable name to delete from the [Variable name list] list box of the [Variable 

display] window.
2 Select the [Delete variable name] command from the [Variable] menu.



Change Variable Value
To change a variable value, operate as follows.
1 Select the variable whose value is to be changed from the [Variable name list] list box of 

the [Display variable] window.
2 Input the variable value to set.
3 To terminate input, select the [Apply] button.



Confirm Variable Value Change
To confirm the variable value change, operate as follows.
1 Select the [Apply] button from the [Display variable] window.



Undo Variable Value
To undo a variable value, operate as follows.
1 Select the [Restore] button from the [Display variable] window.



Cancel Display Variable
To close the [Display variable] window without changing any variable values, operate as 
follows.
1 Select closing of the control menu of the [Display variable] window.

The [Display variable] window is closed.





Save Window Exit Status
To save script window display, no display, display position, and size, operate as follows.
1 Select the [Change environment] command from the [Other] menu.

The [Change environment] dialog box is displayed.    Specify the window to save.
2 Select the [OK] button.



Change Trace Speed at Trace Execution
To specify the execution speed of one statement for executing a trace in the script window, 
operate as follows.
1 Select the [Change environment] command from the [Other] menu.

The [Change environment] dialog box is displayed.    Specify the speed to set.
2 Select the [OK] button.





Sort and Display Script Displayed
To display all windows without any overlapping, operate as follows.
1 Select the [Sort] command from the [Window] menu.



Display [Display Variable] Window
To display the [Display variable] window, operate as follows.
1 Select the [Display variable] command from the [Window] menu.



Display [Execute Script Statement] Window
To display the [Execute script statement] window, operate as follows.
1 Select the [Execute script statement] command from the [Window] menu.



Execute Script Statement
To execute a script, operate as follows.
1 Enter one line of script in the [Execute script statement] text box.
2 Select the [Execute] button.

The input script is interpreted and executed.



Exit Script Statement Execution
To close the [Execute script statement] window, operate as follows.
1 Select the [Close] command from the [Control] menu.

The [Execute script statement] window is closed.



Interrupt Script Statement Execution
To interrupt the execute script statement command, operate as follows.
1 Select the [Interrupt] button.

Script statement execution is interrupted and the input script is selected.



Display [Function Trace] Window
To display the function trace window, operate as follows.
1 Select the [Function trace] command from the [Window] menu.

The [Function trace] window is displayed.



Exit [Function Trace] Window
To close the function trace window, operate as follows.
1 Select the [Close] command from the [Control] menu.

The [Function trace] window is closed and the contents of all displayed messages are 
deleted.



Select and Display Script Displayed
To display an already opened script on top, operate as follows.
1 Select the script name to display on top of the [Window] menu.



Activate Script Displayed
To activate the script display window from the display variable window, execute script 
statement window, and message trace window, operate as follows.
1 Select the [Display script] command from the [Window] menu.

The last active window of the script display windows is displayed.





Cancel [Open] Command
This command invalidates the [Open] command as follows.
1 Select the [Cancel] button.

The [Open] dialog box is closed regardless of input in the [Script name] text box and the 
command is invalidated.



Cancel [Exit] Command
This command invalidates the [Exit] command as follows.
1 Select the [Cancel] button.

The [Exit] message box is closed and the command is invalidated.



Cancel [Release All Interrupt Points] Command
This command invalidates the [Release all interrupt points] command as follows.
1 Select the [Cancel] button.

The [Release all interrupt points] message box is closed and the command is invalidated.



Cancel [Exit Script] Command
This command invalidates the [Exit script] command as follows.
1 Select the [Cancel] button.

The [Exit script] message box is closed and the command is invalidated.



Cancel [Register Variable Name] Command
This command invalidates the [Register variable name] command as follows.
1 Select the [Cancel] button.

The [Register variable name] dialog box is closed and the command is invalidated.



Cancel [Select and Register Variable Name] Command
This command invalidates the [Select and register variable name] command as follows.
1 Select the [Cancel] button.

The [Select and register variable name] dialog box is closed and the command is 
invalidated.



Cancel [Execute Script Statement] Command
This command invalidates the [Execute script statement] command as follows.
1 Select closing of the control menu box.

The [Execute script statement] window is closed and the script inside the text box is 
invalidated.



Cancel [Search String] Command
This command invalidates the [Search string] command as follows.
1 Select the [Cancel] button.

The [Search] dialog box is closed and the command is invalidated.



Cancel [Specified Line] Command
This command invalidates the [Specified line] command as follows.
1 Select the [Cancel] button.

The [Specified line] dialog box is closed and the command is invalidated.



Cancel [Change Environment] Command
This command invalidates the [Change environment] command as follows.
1 Select the [Cancel] button.

The [Change environment] dialog box is closed and the command is invalidated.






