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 Introduction to KwikDraw

KwikDraw is a drawing program.    It is quite different from a painting program, in that it is object-oriented.  
This means that after drawing objects (such as rectangles, ellipses, lines, text, curves, polygons, or 
splines), you have the ability to select and modify them as independent entities.    You can resize them, 
stretch them, move them, rotate them, put them above and below each other, change their line styles, line
thickness, line color, fill patterns, and fill color.    You can even group them together in a hierarchy of more 
complex drawing entities.    In contrast, the drawing surface in a paint program is simply a bitmap (a 
regular grid of colored pixels).    Any shape that is drawn in a paint program loses its identity once it is put 
on the drawing surface.    Its line width and fill pattern cannot be modified; it cannot be resized; it cannot 
even be moved independent of its surroundings.    This is because the program does not treat it any 
different than the rest of the pixels in the drawing.    An additional problem with the bitmapped output of a 
paint program is that it doesnt scale very well.    This may be especially problematic if you wish to paste it 
into another application, like a word processor.

The object-oriented drawing paradigm is usually more appropriate for things like block diagrams, flow 
charts, org charts, mechanical drawings, and floorplans.    The painting paradigm uses colored pencils 
and brushes, an eraser, and a scissors.    This is often more appropriate for artistic work and manipulating 
photographed or scanned images.    While KwikDraw focuses heavily on the drawing paradigm, it does 
allow you to insert the output of a paint program (such as Microsoft Paintbrush) as an independent object. 
See How to: Insert Objects from Other Applications for more information on how to do this.    To see an 
example of the differences between a KwikDraw drawing and a bitmapped drawing, take a look at the 
example drawing "car.kwk."

The distribution disk contains several example drawings in files using the extension ".kwk".    Select the 
"Open" option on the KwikDraw "File" menu to look at these example drawings.    These examples 
illustrate how complex drawings can be produced as a conglomeration of simple objects such as lines, 
arcs, rectangles, polygons, ellipses, and spline curves, the fundamental building blocks provided by 
KwikDraw.    To get a feel for this take a look at "train.kwk" and "car.kwk.    Very artistic looking work can be
created as well.    For an example, take a look at swltail.kwk.

You may be thinking that it is a lot of work to build a complex drawing out of such simple objects.    
However, you are not restricted to building your drawings solely out of the shapes provided by KwikDraw.  
The "Group" feature allows you to create new building blocks out of more primitive ones.    For example, in
a drawing of a car you may combine two circles to form a tire, along with several ellipses for a custom 
wheel.    The objects that make up the tire and wheel may be "Grouped" to form a more complex building 
block.    This "Tire and Wheel" object may be duplicated and reused in your drawing.    "Grouped" objects 
may copied, moved, stretched, resized, flipped, filled, rotated, etc. just like the simple objects.    You may 
wish to create libraries of your own parts or components.    KwikDraw includes a "Parts Library Browser" 
that will allow you to scroll through the parts in your library while working on a drawing.    For an example 
library of TTL logic symbols, try using the "Open As Library" option on the "File" menu, and select the file 
"ssittl.kwk."

KwikDraw also allows you to attach a text description to any object, including grouped objects and their 
components.    This feature may be used to generate a parts list from your drawing.    For an example, try 
selecting the "Write Descriptions" option on the "File" menu after loading the drawing "landscp2.kwk."    
For more information on using object descriptions, see How To: Use Object Descriptions.

Feel free to experiment with the example drawings.    Any changes you make to them will not be 
permanent as long as you do not select "Save" from the "File" menu.



 Drawing Basics

See the Introduction to KwikDraw for a general overview of KwikDraw.

Much of your drawing activity will begin by selecting a tool from the toolbar (the collection of buttons along
the top edge of the drawing area).    The tool bar contains the Pointer Tool (at the extreme left), a 
collection of Drawing Tools, and a Help Button (at the extreme right).

 The Pointer Tool is used to Select previously drawn objects in preparation for any type of 
modification.

 

 

 

 

 

 

 

 

 

 

 

These Drawing Tools are used to draw objects.    KwikDraw gives you some visual clues as to which tool 
is currently in use.    First of all, the current tool's button is displayed with a pushed-in look.    In addition, 
when a Drawing Tool is in use, the cursor will appear as a cross-hair instead of a pointer.    Different 
cursors are also used during object movement and resizing.

Please take special note of the often overlooked behavior of the Edit Control Points mode which is on by 
default and can be turned on and off from the Edit menu.    Curved objects (Arcs, Chords, and Pie shapes)
CAN be modified to extend over distances other than one quarter of an ellipse AFTER they are initially 
drawn when the Edit Control Points mode is on.

 After you draw an object it will normally be automatically selected and the Tool Bar will revert to the 
Pointer Tool.    This makes it convenient for you to immediately move or resize the object.    If you would 
rather draw several objects of the same type in succession, without having to rechoose the tool, simply 
press the Tool Lock button.    When you want KwikDraw to return to its default behavior, press the Tool 
Lock button again.



 Contacting the Author

I may have moved or my email address may have changed in between the time this was written and the 
time you are reading this.    So if you have trouble reaching me, you should be able to find my current 
location and email address by doing a Web search with the keywords "Paul Schimpf" and/or "KwikDraw."  
No matter where I go, I will try to maintain a home page that is indexed by the more popular Web search 
engines.    Try the Alta Vista, Yahoo, or Web Crawler search engines.

As of November 1996, I can be reached by snail mail at:

Paul Schimpf
902 94th St. S.E.
Everett, WA    98208

or by email at one of the following:

schimpf@icsl.ee.washington.edu
Paul_Schimpf@atk.com



Known Problems

OK, bugs.    I am working on these.    If you see one not on this list, then please contact me.

1) Text Objects:

a) Text alignments other than Left Justified only work if the text is not rotated.    The current work 
around is that rotated objects are always shown left justified.

b) Text alignments other than left justified dont show up when embedded in some applications.    
There doesnt appear to be anything I can do since this is under the control of the receiving 
application.    If you embed, use left justified text until this problem is fixed.    Note that rotated text 
always works when embedded because it is displayed left justified (except for some misbehaving 
applications).

c) A few applications and older printer drivers rotate text objects in the wrong direction.    This wouldn't
be so bad except that the text then gets misplaced.    MS Word (TM) doesn't have this problem, but 
some older versions of MS Powerpoint (TM) do.    Some older HP printer drivers have the problem 
also.    I am working on a solution, but it may require a fundamental reworking of the coordinate 
system mapping mode used by KwikDraw.    Please send me an email if this is a major problem for 
you, so I can get an idea of how much of a priority to give this.



     Pointer Tool 

This tool is used to Select objects.    An object must be selected before it can be moved, resized, 
stretched, copied, cut, duplicated, edited, moved forward, moved backward, flipped, rotated, grouped, 
ungrouped, or had any of its attributes modified (such as pen style, pen width, fill pattern, font type, font 
style, or font size).



        Text Tool 

This tool is used to place a text object on the drawing.    After activating the tool, simply point to the entry 
point on your drawing, then click and release the left mouse button.    A text entry dialog box will pop up.    
Type the text desired and terminate by pressing the OK or Cancel buttons.    Pressing the <Enter> key on 
your keyboard has the same effect as pressing the OK button.

To start a new line in your text object, press <Ctrl-Enter> on your keyboard.    If you want a blank line of 
text, you should put at least one space character on the blank line.

You may also edit your text using the cursor keys, the <Bksp> key, and the <Delete> key.    To replace a 
block of text, simply highlight the block to be replaced and start typing the new text.

To edit an existing Text object, point at it and double-click the left mouse button.

To change the text color, use the Line Style dialog box, which is launched from the Pen menu.

To change the text background between opaque and transparent, use the Fill Style dialog box, which is 
launched from the Pen menu.



        Line Tool 

This tool is used to draw lines.    After activating the tool, simply point where you want the start of the line, 
click and hold down the left mouse button, drag the cursor to where you want the end of the line, and 
release the mouse button.    Arrowheads may be added to line objects using the options on the Pen Menu.
The line style or width may be altered using the Line Style option on the Pen Menu.    In the Constrain 
mode, lines may only be drawn horizontally, vertically, or at 45 degree angles.



     

    Rectangle Tools 

There are two tools to draw rectangles, one for regular rectangles and another for rectangles with 
rounded corners.    After activating one of these tools, simply point where you want one of the rectangle 
corners, click and hold the left mouse button, drag the cursor to where you want the opposite corner, and 
release the mouse button.    The rectangle fill pattern may be altered using the Fill Style option on the Pen
Menu.    The line style or width may altered using the Line Style option on the Pen Menu.



        Ellipse Tool 

This tool is used to draw ellipses or circles.    Drawing an ellipse is identical to drawing a rectangle that 
surrounds the desired ellipse.    After activating the tool, simply point where you want one of the 
surrounding rectangle corners, click and hold the left mouse button, drag the cursor to where you want 
the opposite corner, and release the mouse button.    The ellipse fill pattern may be altered using the Fill 
Style option on the Pen Menu.    The line style or width may altered using the Line Style option on the Pen
Menu.



     

 

    Arc, Chord, Pie Tools 

Arcs are drawn as a portion an ellipse.    A Chord is an Arc with the opposite ends connected by a straight 
line.    A Pie shape connects the ends of an Arc at the center of the surrounding ellipse, in a way that looks
a slice of pie.    After activating the tool, simply point where you want one of the arc endpoints, click and 
hold the left mouse button, drag the cursor to where you want the other endpoint, and release the mouse 
button.    When any of these objects is initially drawn, the endpoints of the arc will fall at two of the four 
quadrants of an ellipse, depending on which way you drag the mouse.    These endpoints may be 
extended in either direction around the ellipse when the Edit Control Points mode is selected on the Edit 
Menu.

The fill pattern for Chord and Pie objects may be altered using the Fill Style option on the Pen Menu.    
The line style or width may altered using the Line Style option on the Pen Menu.

For more complex curves that make changes in direction, you will find the Spline Tools more effective.



     

    Polygon Tools 

There are two tools to draw Polygons, one for Closed Polygons and another for Open Polygons.    After 
activating one of these tools, simply point where you want one of the polygon vertices, then click and 
release the left mouse button.    Now move the cursor to the next vertex and click and release again.    To 
finish the Polygon, you must double-click the left mouse button or single click the right mouse button on 
the last vertex.    Closed Polygons will automatically be connected back to the starting point.

After finishing the polygon, it's vertices may be individually moved when the Edit Control Points mode is 
selected on the Edit Menu.      Arrowheads may be added to the endpoints of an Open Polygon using the 
arrowhead options on the Pen Menu.    The Closed Polygon fill pattern may be altered using the Fill Style 
option on the Pen Menu.    The line style or width may altered using the Line Style option on the Pen 
Menu.



     

    Spline Tools 

These tools are used to draw Open or Closed Spline Curves.    Spline curves are smooth curves that may 
contain multiple changes in direction.    Drawing Splines is similar to drawing Polygons.    After activating 
the tool, simply point where you want the start of the Spline Curve, then click and release the left mouse 
button.    Now move the cursor to the next vertex and click and release again.    To finish the Spline, you 
must double-click the left mouse button or single click the right mouse button on the last vertex.    Although
you cannot see the resulting curvature until you finish the object, you can go back and edit the vertices 
later, in order to modify the curvature.

After finishing the spline, it's vertices may be individually moved when the Edit Control Points mode on 
the Edit Menu.    Arrowheads may be added to the endpoints of an Open Spline using the arrowhead 
options on the Pen Menu.    The line style or width may altered using the Line Style option on the Pen 
Menu.



        Tool Lock 

After you draw an object it will normally be automatically selected and the Tool Bar will revert to the 
Pointer Tool.    This makes it convenient for you to immediately move or resize the object.    If you would 
rather draw several objects of the same type in succession, without having to rechoose the tool, simply 
press the Tool Lock button.    When you want KwikDraw to return to its default behavior, press the Tool 
Lock button again.



        Help On... Tool

If you press this button, KwikDraw will give you help on the next button that you press or menu item that 
you select.

Shortcut
Keys: SHIFT+F1



File menu commands

The File menu contains the following commands:

New Creates a new (blank) drawing.
Open Opens an existing drawing.
Open Version 2.x Opens a KwikDraw version 2.x drawing.
Open As Library Opens a drawing into a Parts Library Browser
Close Closes an opened drawing.
Save Saves an opened drawing using the existing file name.
Save As Saves an opened drawing with a new file name.
Write Descriptions Writes the Object Descriptions to a file (for creating parts lists)
Print Prints a drawing.
Print Preview Displays the drawing on the screen as it would appear printed.
Print Setup Selects a printer and printer connection.
Recent Files Quick access to one of the four most recently opened drawings
Exit Exits KwikDraw.



Edit menu commands

The Edit menu contains the following commands:

Undo Reverses the previous editing operation.
Cut Deletes the selected objects and moves them to the clipboard.
Copy Copies the selected objects from the drawing to the clipboard.
Paste Pastes objects from the clipboard into the drawing.
Duplicate Duplicates the selected objects.
Insert From Library Inserts the object displayed in the Parts Library Browser into the 

drawing.
Show Clipboard Displays the contents of the clipboard
Insert OLE Object Embeds the document from another application into the drawing.
Edit Control Points When checked, allows you to modify the control points on Arcs, 

Polygons, and Splines.    When not checked, allows you to resize Arcs, 
Polygons, and Splines.

Edit Description Allows you to enter a text description of the selected object (useful for 
building parts lists).



Tools menu commands

The Tools menu contains selections that correspond to all of the drawing tools on the Toolbar.    In 
addition, it contains the following selections:

Convert Rectangles/Ellipses Converts between rectangles, rounded rectangles, and ellipses
Convert Arcs Converts between arcs, chords, and pies
Convert Polygons/Splines Converts between open polygons, closed polygons, open splines,

and closed splines



Layout menu commands

The Layout menu contains the following commands:

Show Grid Shows or hides the drawing grid for the current view.
Snap To Grid Toggles the drawing mode between snap-to-grid and no snap-to-grid.
Constrain Toggles the drawing mode between constained and unconstrained.
Drawing,    Grid Size Used to modify the current drawing size, orientation, grid type, and grid spacing 

for the current drawing.
Show Ruler Shows or hides rulers for the current view.
Zoom Levels (25-
400%)

Selects a zoom level for the current view.

Reduce View 20% Reduces the view size by an additional 20% (e.g., a 100% zoom level becomes 
an 80% zoom level).

Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.



Arrange menu commands

The Arrange menu contains the following commands:

Move Forward Moves the selected objects forwards (on top of the next overlapping object).
Move Backward Moves the selected objects backwards (behind the next overlapping object).
Move To Front Moves the selected objects to the front (on top of any overlapping objects).
Move To Back Moves the selected objects to the back (behind any overlapping objects).
Flip Horizontal Flips the selected objects horizontally.
Flip Vertical Flips the selected objects vertically.
Rotate Rotates the selected objects through 90 degrees.
Group Groups the selected objects into a single compound object.
Ungroup Ungroups a compound object one level.
Snap Selections Snaps the selected objects to the grid.



Pen menu commands

The selections and dialog boxes launched from this menu are context sensitive:

When no objects are selected, this menu and its associated dialog boxes show you (and allow you to 
modify) the current default settings for Fill Patterns, Line Styles, and Arrowheads.    These are the settings
that will be used when new objects are created.

When a single object is selected, the menu and dialog box items show and modify the attributes of only 
that object, WITHOUT changing the defaults that will be used for newly created objects.

When multiple objects or Grouped objects are selected, the menu and dialog boxes will show nothing 
checked, since the selected objects may all have different settings.    In this case, when you choose a 
menu or dialog box item, it will set the corresponding attribute of ALL currently selected items, again 
WITHOUT modifying the default attributes.

Fill Style Launches a dialog box for selecting fill patterns and colors.
Line Style Launches a dialog both for selecting line styles and colors.
Arrow Style Launches a dialog box for selecting arrowhead styles and sizes.
Arrow at Start Indicates and toggles arrowheads at the start of a line, open polygon, or open 

spline curve.
Arrow at End Indicates and toggles arrowheads at the end of a line, open polygon, or open 

spline curve.
Both Arrows Puts arrowheads at both ends of a line, open polygon, or open spline curve.
No Arrows Removes arrowheads at both ends of a line, open polygon, or open spline curve.



Font menu commands

This menu only applies to Text objects.    The selections are context sensitive:

When no objects are selected, this menu shows you (and allows you to modify) the current default 
settings for Font Type and Style.    These are the settings that will be used when the next text object is 
created.

When a single text object is selected, the menu shows and allows you to change the attributes of only that
object, WITHOUT changing the default setting that will be used for newly created Text objects.

When multiple objects or Grouped objects are selected, the menu will show nothing checked, since the 
selected objects may all have different settings.    In this case, when you choose a menu item, it will set 
the corresponding attribute of ALL currently selected text objects, again WITHOUT modifying the default 
attributes.

Courier Indicates or selects the Courier font (TrueType) for text objects.
Arial Indicates or selects the Arial font (TrueType) for text objects.
Times Roman Indicates or selects the Times Roman font (TrueType) for text objects.
Wing Dings Indicates or selects the Wing Dings font (TrueType) for text objects.
Symbol Indicates or selects the Symbol font (TrueType) for text objects.
Roman Indicates or selects the Roman stroke font for text objects.
Modern Indicates or selects the Modern stroke font for text objects.
Script Indicates or selects the Script stroke font for text objects.
Bold Indicates or toggles the use of the Bold text attribute.
Italic Indicates or toggles the use of the Italics text attribute.
Underline Indicates or toggles the use of the Underlined text attribute.
Justify Left Indicates or selects left justified text.
Justify Center Indicates or selects center justified text.
Justify Right Indicates or selects right justified text.



Size menu commands

This menu only applies to Text objects.    The selections are context sensitive:

When no objects are selected, this menu shows you (and allows you to modify) the current default setting 
for Font Size.    This is the font size that will be used for newly created text objects.

When a single object is selected, the menu shows (and allows you to modify) the Font Size of only that 
object, WITHOUT changing the default that will be used for newly created Text objects.

When multiple objects or Grouped objects are selected, the menu will show nothing checked, since the 
selected objects may all have different sizes.    In this case, when you choose a size, it will set the 
corresponding attribute of ALL currently selected text objects, again WITHOUT modifying the default size.

You can also change font sizes by dragging one corner of the selection box.    KwikDraw will try to 
maintain a reasonable aspect ratio for the font during this process.    You can help out by trying to scale 
the font equally in both dimensions or by turning the Constrain option on.



Window menu commands

Use the Window menu commands to arrange multiple views of multiple drawings:

New Window Creates a new window that views the same document.
Cascade Arranges windows in an overlapped fashion.
Tile Arranges windows in non-overlapped tiles.
Arrange Icons Arranges icons of closed windows.
Window 1, 2, ... Goes to specified window.



Help menu commands

The Help menu contains the following commands:

Index Presents an index to topics on which you can get help.
Using 
Help

Provides general instructions on using help.

About Displays information about KwikDraw, including the version 
number.

Count 
Objects

Displays a count of the number of objects in the drawing.



New command (File menu)

Use this command to create a new drawing.

You can open an existing drawing with the Open command.

You can open a KwikDraw version 2.x drawing with the Open Version 2.x command.

Shortcuts
Keys: CTRL+N



Open command (File menu)

Use this command to open an existing drawing in a new window.    You can open multiple drawings at 
once.

You can create new documents with the New command.

Shortcuts
Keys: CTRL+O



 Open Version 2.x command (File menu)

Use this command to open a drawing that was created using KwikDraw version 2.x.    When you Save the 
drawing, it will automatically be converted to the current version of KwikDraw.



Open As Library command (File menu)

Use this command to open a drawing into a Parts Library Browser window.    This will allow you to scroll 
through objects in a parts library and transfer copies into your current drawing.

See Also:
How to Create a parts library
How to Use a parts library



File Open dialog box

The following options allow you to specify which file to open:
File Name

Type or select the filename you want to open.    This box lists files with the extension you select in the 
List Files of Type box. 

List Files of Type
To see only KwikDraw files, leave this field with the default ".kwk" file extension selected.

Drives
Select the drive in which KwikDraw stores the file that you want to open. 

Directories
Select the directory in which KwikDraw stores the file that you want to open.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



Close command (File menu)

Use this command to close all windows displaying the active drawing.    KwikDraw suggests that you save
changes to your document before you close it.    If you close a document without saving, you lose all 
changes made since the last time you saved it.    Before closing an untitled document, KwikDraw displays 
the Save As dialog box and suggests that you name and save the document.

You can also close a document by using the Close icon on the document's window, as shown below:



Save command (File menu)

Use this command to save the active document to its current name and directory.    When you save a 
document for the first time, KwikDraw displays the Save As dialog box so you can name your document.   
If you want to change the name and directory of an existing document before you save it, choose the 
Save As command.

Shortcuts
Keys: CTRL+S



Save As command (File menu)

Use this command to save the active drawing with a new name.    KwikDraw displays the Save As dialog 
box so you can name your document.    

To save a document with its existing name and directory, use the Save command.



Write Descriptions command (File menu)

Use this command to write all of the object descriptions in the active drawing to a text file.    Attaching a 
description to objects in your drawing allows you to use this command to build a parts list.    KwikDraw 
displays the Save As dialog box so you can name this file.    After the file is written, the Windows notepad 
editor will be launched so that you can view the contents.



File Save As dialog box

The following options allow you to specify the name and location of the file you're about to save:
File Name

Type a new filename to save a document with a different name.    A filename can contain up to eight 
characters and an extension of up to three characters.    KwikDraw adds the extension you specify in 
the Save File As Type box.

Drives
Select the drive in which you want to store the document.

Directories
Select the directory in which you want to store the document.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



Recent File List (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open one the last four documents 
you closed.    Choose the number that corresponds with the document you want to open.



Exit command (File menu)

Use this command to end your KwikDraw session.    You can also use the Close command on the 
application Control menu.    KwikDraw prompts you to save documents with unsaved changes.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



Undo command (Edit menu)

This command will reverse the last change made to a drawing object or set of objects.    Use this option to
undo the following changes:    Deletion (via <Bksp> or <Delete>), Moving, Resizing, movement of Control 
Points, changes to Text objects, Arrowhead changes, Rotations, Flips, Fill Pattern changes, and Line style
changes.

To undo Group Objects, use Ungroup Objects (and visa-versa).    To undo Object Forward, use Object 
Backward (and visa-versa).    To undo Cut, use Paste (and visa-versa).    To undo Duplicate, use Cut or 
the Backspace or Delete keys.    Changes to object descriptions cannot be undone.

Shortcuts
Keys: CTRL+Z or

ALT-BACKSPACE



Cut command (Edit menu)

This command removes the currently selected objects from the drawing and places them on the 
clipboard.    This command is unavailable if there are no objects selected.

Cutting data to the clipboard replaces the contents previously stored there.

Shortcuts
Keys: CTRL+X



Copy command (Edit menu)

This command copies the selected objects onto the clipboard.    This command is unavailable if there are 
no objects selected.    One way to embed KwikDraw drawings into other applications (such as a Word 
Processor) is to select the portion of the drawing you want to embed, select the Copy command, activate 
the other application, and select the Paste command in the other application.

Copying data to the clipboard replaces the contents previously stored there.

Shortcuts
Keys: CTRL+C



Paste command (Edit menu)

Use this command to insert a copy of the clipboard contents into the drawing.    This will have various 
effects depending on what the clipboard currently contains:

If the clipboard contains KwikDraw objects they will be pasted into the drawing.

If the clipboard contains OLE data from another application, then this data will be embedded into the 
drawing as a distinct object, which can be moved and scaled as you wish.    This data may be edited from 
within the application that created it by pointing at the object and double-clicking the left mouse button.    
Another way to embed OLE objects into your drawing is to use the Insert OLE Object command.

This command is unavailable if the clipboard is empty.

Shortcuts
Keys: CTRL+V



Duplicate command (Edit menu)

This command will create duplicates of the currently selected objects.    The duplicates will be 
automatically selected.    If you move the duplicates without deselecting them, then KwikDraw will 
remember that offset, and selecting this command again will duplicate the next set at that same offset.    
This makes it convenient to generate a line of identical objects with identical spacing in an arbitrary 
direction.    As soon as you deselect an object after duplication, then KwikDraw will forget the offset.

This command is unavailable if the clipboard is empty.

Shortcuts
Keys: CTRL+D



Insert From Library command (Edit menu)

This command will insert a copy of the object currently displayed in the Parts Library Browser.    This 
command is unavailable if the Parts Library Browser is not open.

Shortcuts
Keys: CTRL+I

See Also:
How to Create a parts library
How to Use a parts library



 Show Clipboard command (Edit menu)

This command will launch the Windows clipboard viewer so that you can look at the contents of the 
clipboard.



 Insert OLE Object command (Edit menu)

This command will generate a dialog box listing the other Windows applications on your system that are 
OLE servers.    The data from any application on this list may be embedded in your drawing as a distinct 
object.    Some example applications that might be useful for embedding into a KwikDraw drawing are:    
equation editors, paint programs, word art, etc.    To see an example drawing containing an object inserted
from Microsoft Paintbrush, take a look at the example drawing "car.kwk."

The application that you select from the list of OLE servers will be started so that you can create the 
object that you wish to embed in your drawing.    When you exit the application, its data will appear in your
drawing as a separate object, which can be moved and scaled as you wish.    The embedded data may be
edited from within the application that created it by pointing at the object and double-clicking the left 
mouse button.

Another way to embed OLE objects into your drawing is to use the Paste command.



Edit Control Points command (Edit menu)

This menu item indicates the editing mode for Arcs, Chords, Pies, Polygons and Splines.    When this item
is checked, selecting one of the previously listed objects highlights the control points for that object.    You 
may then point at a control point and drag it to a new position.

On Arcs, Chords and Pies, these control points are the endpoints of the arc.    On Polygons, these control 
points are the vertices of the polygon.    On Splines these points control the local curvature of the spline.

When this item is not checked, selecting one of the previous items highlights the four resizing control 
points for the object.    You may then drag one of these control points to resize or stretch the object.    

When multiple objects are selected, the four resizing control points are highlighted regardless of the state 
of this menu item.    In order to modify the control points for an object, you must select ONLY that object.



Edit Description command (Edit menu)

This command will launch a dialog box into which you may type a text description of the selected object.    
All of the text descriptions in a drawing may be written to a text file using the Write Descriptions 
command.    This is a convenient way to build a parts list for your drawing.    This command is only 
available if a single object is selected.

Shortcuts
Keys: ALT+D



 Convert Rectangles/Ellipses command (Tools menu)

This command will convert the selected objects between Rectangles, Rounded Rectangles, and Ellipses.



 Convert Arcs command (Tools menu)

This command will convert the selected objects between Arcs, Chords, and Pie shapes.



 Convert Polygons/Splines command (Tools menu)

This command will convert the selected objects between Open Polygons, Closed Polygons, Open Splines
and Closed Splines.



Show Grid command (Layout menu)

Use this command to display or hide the drawing grid.    You can select a rectangular or 
triangular/hexahedral grid of various densities from the Drawing, Grid Size dialog box.



Snap To Grid command (Layout menu)

This command toggles the Snap-To-Grid mode on and off.    When Snap-To-Grid is on (as indicated by a 
check mark), all objects are snapped to the nearest grid point when drawn.

You can select a rectangular or triangular grid of various densities in the Drawing, Grid Size dialog box.

If you draw an object with snap-to-grid off, and later wish to snap it to the nearest grid points, then use the
Snap Selections item on the Arrange Menu.



Constrain command (Layout menu)

This command toggles the Constrain mode on and off.    When the Constrain mode is on (as indicated by 
a check mark), new objects other than Lines or Polygons will be drawn with a one-to-one aspect ratio.    
Thus only Squares will be drawn when using the Rectangle tool, and only Circles will be drawn when 
using the Ellipse tool, etc.    Line objects, and the line components of Polygon objects, will only be drawn 
horizontally, vertically, or at 45 degree angles when the Constrain mode is on.    When resizing or 
stretching previously drawn objects, the Constrain mode will prevent you from changing the aspect ratio 
of the object.    This means that changing the size of an object in one dimension can only occur with a 
proportionally equal change in the other dimension.



Drawing, Grid Size command (Layout menu)

This command displays a dialog box from which you can set the following drawing parameters:

Paper Size
You can select 8.5 x 11, A4, or 11 x 17 paper.    Note that you must also select the mathing paper 
tray in the Print Setup dialog box.

Drawing Size
You can select a drawing size that corresponds to a 1x1 or 2x2 array of the selected paper size 
(except for 11x17, for which only a single sheet is supported).

Orientation
You can select a Portrait or Landscape orientation.    Note that you must also select the same 
orientation in the Print Setup dialog box.

Drawing Units
You can select inches or centimeters as the basic drawing units.    This will affect the way that the 
ruler and grid are displayed

Grid Ticks
You can select a grid with 2, 5, or 10 ticks per inch or centimeter.

Grid Type
You can select a rectangular or triangular grid.    The triangular grid may also be used as a 
hexahedral grid.



Show Ruler command (Layout menu)

Use this command to display or hide the Ruler.    The ruler will be marked in inches or centimeters, 
depending on the drawing units selected in the Drawing, Grid Size dialog box.



Zoom Levels (Layout menu)

You may select a zoom level of 25%, 50%, 100%, 200%, or 400% of actual size.    You may edit your 
drawing at any of these zoom levels.    When you work in a zoomed-out view (e.g., 25% or 50%) with 
dense grid spacings (e.g., 10 ticks per inch or centimeter), some of the grid ticks may not be displayed, 
although drawing operations will still snap to them.



Reduce View 20% (Layout menu)

When checked, this option will reduce the current view of your drawing by an additional 20%.    For 
example, a selected zoom level of 100% becomes a zoom level of 80%.    This option allows you to adapt 
to the different view sizes produced by Windows 3.1 and Windows 95 or Windows NT.

Under Windows 3.1, leaving this item checked should result in a nearly true-to-size view at the 100% 
zoom level on most displays.

Under Windows 95 or Windows NT, leaving this item unchecked should result in a nearly true-to-size view
at the 100% zoom level on most displays.

Your monitor size will have some effect on the resulting view size as well.

Selecting the menu item will toggle the check mark on and off.



Toolbar command (Layout menu)

Use this command to display or hide the Toolbar, which includes buttons for the KwikDraw drawing tools.

See Toolbar for help on using the buttons on the Toolbar.



Status Bar command (Layout menu)

Use this command to display or hide the Status Bar.



Status Bar

The status bar is displayed at the bottom of the KwikDraw window.    To display or hide the status bar, use 
the Status Bar command on the Layout menu.

The left area of the status bar describes the action to be executed by a selected menu item or depressed 
toolbar button.    If after viewing the description of a toolbar button you wish to NOT execute the 
command, then release the mouse button while the pointer is off the toolbar button.

The right areas of the status bar indicate which of the following keys are latched down:

Indicator Description
CAP The Caps Lock key is latched down.

NUM The Num Lock key is latched down.

SCRL The Scroll Lock key is latched down.



Move Forward/Backward commands (Arrange menu)

Move Forward
This command will move the currently selected object in front of (or on top of) the first object found 
that is currently in front of it.

Move Backward
This command will move the currently selected object behind (or below) the first object found that is 
currently behind it.

Move To Front
This command will move the currently selected object to the front of (or on top of) all objects that are 
currently in front of it.

Move To Back
This command will move the currently selected object behind (or below) all objects that are currently 
behind it.

When multiple objects are selected, these procedures are applied to each object in the order that they 
were selected.    If the objects were selected all at once by drawing a selection box around them, then the 
procedure is applied to the bottom-most selected object first.    The results can be confusing when these 
commands are applied to multiple overlapping objects.



Flip commands (Arrange menu)

This commands will flip the selected objects either vertically (up and down) or horizontally (left and right) 
about their individual center points.    The items that make up a Grouped object will be flipped about the 
center of the Group, such that the entire object flips as a unit.



Rotate command (Arrange menu)

This commands will rotate the selected object 90 in a clockwise direction.    The items that make up a 
Grouped object will be rotated about the center of the Group, such that the entire object rotates as a unit.  
There is currently no way to rotate objects in increments smaller than 90.



Group/Ungroup commands (Arrange menu)

Group
Combines the selected objects into a grouped object, which can be moved, stretched, flipped, rotated,
etc as a single entity.    Groups of Groups can be formed to an arbitrary number of levels.

Ungroup
Ungroups the selected Grouped objects back one level into independent entities.    Note that 
Ungrouping a Group of Groups takes you back only one level instead of all the way back to the base 
object types.



Snap Selections command (Arrange menu)

This command will snap the selcted object to the nearest grid points.    This may be convenient when you 
inadvertently drew the object with the Grid Snap settings off (on the Layout Menu) or when you have 
changed the grid settings or drawing units and want to snap an already drawn object to the new settings.



Fill Style command (Pen menu)

This command launches a dialog box that allows you to change the Fill Pattern, the Fill Color, and the 
background mode for closed objects (rectangles, ellipses, chords, pies, and closed polygons).    The 
settings displayed in this dialog box and the effect of any changes made depend on whether any objects 
are selected, as explained in the intro to the Pen Menu.

The background mode (Opaque or Transparent) also applies to text objects.

To achieve a completely transparent object such that you can see any objects behind it, select the fill 
pattern labelled "none".

To achieve a solid white object that obscures anything behind it, select the solid fill pattern and change 
the color to white.

You can modify the fill colors by sliding the color bars or typing a number between 0 and 255 in each of 
the color boxes.

The background mode (Opaque or Transparent) only has an effect when one of the 6 hatched and cross-
hatched fill patterns is selected.



Line Style command (Pen menu)

This command launches a dialog box that allows you to change the Line Width, Line Style, and Line Color
for any object.    The settings displayed in this dialog box and the effect of any changes made depend on 
whether any objects are selected, as explained in the intro to the Pen Menu.

The line widths are measured in hundredths of an inch or centimeter, depending on the drawing units 
selected in the Drawing, Grid Size dialog box.    A width of 5, for example, will give a line that is one 
twentieth of an inch (or centimeter) wide.    A line width of 0 will produce a line that is a single pixel wide at 
any zoom level and in any view.    If you paste a KwikDraw drawing into another application (such as a 
Word Processor), then lines drawn with a width of 0 will not change thickness as you resize the drawing in
that application, whereas lines drawn with any nonzero width will scale.

The maximum line width allowed is 100.    Only solid lines may be given a width greater than 0.    If any of 
the dotted or dashed line styles is selected, the width will be forced to 0, and the width entry field on the 
dialog box will be disabled.

To create an object with no border around it, select the line style labelled "none".

You can modify the fill colors by sliding the color bars or typing a number between 0 and 255 in each of 
the color boxes.

For Text objects, only the color bars will have any effect.



Arrow Style command (Pen menu)

Launches a dialog box that allows you to change the Arrowhead style for Lines, Open Polygons, and 
Open Spline Curves.    The effect of any changes made to this dialog box depends on whether any 
objects are selected, as explained in the intro to the Pen Menu.



Arrow Placement commands (Pen menu)

These commands apply to Lines, Open Polygons, and Open Spline Curves.

The current state of the selected object is shown as a check mark next to the Left or Right Arrow menu 
items (or both).    If no objects are selected then the default settings that will be used for newly drawn 
objects are displayed.    If multiple objects are selected then no check marks will be displayed since the 
objects may have different settings.

Selecting one of these menu items will result in the following action:

Arrow at Start
Toggles the use of an arrowhead at the start of the Line, Polygon, or Spline.    The "start" is defined as
the first end drawn.    If an arrowhead is present, it will be removed.    If absent it will be added.

Arrow at End
Toggles the use of an arrowhead at the end of the Line, Polygon, or Spline.    The "end" is defined as 
the last end drawn.    If an arrowhead is present, it will be removed.    If absent it will be added.

Both Arrows
Removes arrowheads at both ends of the Line, Polygon, or Spline.

No Arrows
Adds arrowheads at both ends of the Line, Polygon, or Spline.



New command (Window menu)

Use this command to open a new window with the same contents as the active window.    You can open 
multiple document windows to display different parts or views of a document at the same time.    If you 
change the contents in one window, all other windows containing the same document reflect those 
changes.    When you open a new window, it becomes the active window and is displayed on top of all 
other open windows.



Cascade command (Window menu)

Use this command to arrange multiple opened windows in an overlapped fashion. 



Tile command (Window menu)

Use this command to arrange multiple opened windows in a non-overlapped fashion.



Tile Horizontal command (Window menu)

Use this command to vertically arrange multiple opened windows in a non-overlapped fashion.



Tile Vertical command (Window menu)

Use this command to arrange multiple opened windows side by side.



Window Arrange Icons Command

Use this command to arrange the icons for minimized windows at the bottom of the main window.    If 
there is an open document window at the bottom of the main window, then some or all of the icons may 
not be visible because they will be underneath this document window.



1, 2, ... command (Window menu)

KwikDraw displays a list of currently open document windows at the bottom of the Window menu.    A 
check mark appears in front of the document name of the active window.    Choose a document from this 
list to make its window active.    



Index command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can jump to 
step-by-step instructions for using KwikDraw and various types of reference information.    

Once you open Help, you can click the Contents button whenever you want to return to the opening 
screen.



Using Help command (Help menu)

Use this command for instructions about using Help.



About command (Help menu)

Use this command to launch a dialog box displaying the copyright notice and version number of your copy
of KwikDraw.



Text Entry Dialog

This dialog box is used to type the content of Text objects and to attach a Description to any object.    Type
the desired text and terminate your entry by pressing the OK or Cancel buttons.    Pressing the <Enter> 
key on your keyboard has the same effect as pressing the OK button.

To start a new line, press <Ctrl-Enter> on your keyboard.    You may also edit your text using the cursor 
keys, the <Bksp> key, and the <Delete> key.    To replace a block of text, simply highlight the block to be 
replaced and start typing the new text.



Parts Library Browser

This window displays the objects in a Parts Library.    Use the scrollbar to move through the parts.    To 
transfer a part from this window to your drawing, use the Insert From Library command on the Edit menu.

See Also:
How to Create a parts library
How to Use a parts library



Title Bar

The title bar is located along the top of a window.    It contains the name of the application and document.

To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging their title 
bars.

A title bar may contain the following elements:
Application Control-menu button
Document Control-menu button

Maximize button

Minimize button

Name of the application

Name of the document

Restore button



Scroll bars

When you are at a zoom level such that the drawing surface is larger than the KwikDraw window, you 
may scroll about the drawing using the scroll bars at the bottom and right edges of the KwikDraw window. 
There are three ways to use the scroll bars:

Clicking on the arrow buttons at either end of the Scroll Bar:
This method will scroll the window in incremental amounts.    It gives you a fine amount of control over the 
viewing position with visual feedback.    It is, however, the slowest scrolling method.

Pressing and moving the thumbscroll button in the Scroll Bar:
This method allows you to rapidly scroll to any arbitrary viewing position.    Unfortunately, you will not get 
visual feedback as you move the thumbscroll because the window does not update until you release it.

Clicking on the region between the arrow buttons and the thumbscroll button:
This method will scroll the window in coarser increments than clicking on the arrow buttons.    This is often
the best method for panning a drawing quickly with visual feedback.



Size command (System menu)

Use this command to display a four-headed arrow so you can size the active window with the arrow keys.

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer to the 

border you want to move.    
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or dialog box with 
the arrow keys.

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



Minimize command (application Control menu)

Use this command to reduce the KwikDraw window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9



Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title bar.
Keys: CTRL+F10 enlarges a document window.



Next Window command (document Control menu)

Use this command to switch to the next open document window.    KwikDraw determines which window is 
next according to the order in which you opened the windows.

Shortcut
Keys: CTRL+F6



Previous Window command (document Control menu)

Use this command to switch to the previous open document window.    KwikDraw determines which 
window is previous according to the order in which you opened the windows.

Shortcut
Keys: SHIFT+CTRL+F6



Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Note:    If you have multiple windows open for a single document, the Close command on the document 
Control menu closes only one window at a time.    You can close all windows at once with the Close 
command on the File menu.

Shortcuts
Keys: CTRL+F4 closes a document window

ALT+F4 closes the drawing window or dialog box



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the Maximize or 
Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to or close an 
application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the following 
options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap and you can see each title bar.    This option does not 
affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not affect 
applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.



    How Do I ...

Convert older KwikDraw files

Erase

Insert a KwikDraw drawing into another application
Insert objects from other applications into KwikDraw

Enter a multi-line text object
Edit an existing text object
Make text objects have an opaque background
Change text colors
Get a font size other than those on the Font menu

Select objects
Modify object attributes
Move objects
Resize or stretch an object

Make Arcs, Chords, and Pie Slices in other than 90 sections
Move Polygon vertices or Spline Curve control points

Draw several objects without having to reselect the same tool
Distribute several copies of an object with equal spacings
Draw several objects at the same offset from the grid snap

Make more complicated objects
Create a parts library
Use a parts library
Use object descriptions



    Selecting Objects

Normally, when an object is selected, the four corners of a rectangle that surrounds that object are 
highlighted.    There are a few exceptions:

- Line objects are only highlighted at the two endpoints when selected.
- When in the Edit Control Points mode, the vertices of a Polygon object are highlighted
- When in the Edit Control Points mode, the curvature control points of a Spline object are highlighted.
- When in the Edit Control Points mode, the endpoints of an Arc, Chord, or Pie object are highlighted.

To Select a Single Object:
Objects are selected using the Pointer Tool.    Closed objects such as Rectangles and Ellipses can 
normally be selected by pointing the cursor anywhere inside the object and clicking the left mouse button. 
However, if the object is not using a fill pattern (the default), then you must point near the boundary of the 
object to select it.    Note that a solid white fill pattern is not the same as no fill pattern.    Lines, Arcs, and 
Open Polygons are not closed objects, so they also must be selected by pointing near the lines that 
define them.    If the object you wish to select is overlapped by another object, click on an exposed 
portion.

To Select Multiple Objects:
You can select multiple objects in one of two ways.    One method is to simply follow the procedure for 
selecting single objects, except that you hold down the Shift key when selecting additional objects.    To 
use the second method, activate the Pointer Tool, point the cursor outside of any object, and press and 
hold the left mouse button.    This will initiate a selection box outline.    Now drag the mouse cursor, 
drawing an outline around all the objects that you wish to select.    When finished, release the mouse 
button.    All objects falling completely within the selection box outline will be selected.    While drawing a 
selection box, the view area will autoscroll when you drag the mouse pointer beyond the edge of the view 
window.

To Deselect Only One of Multiple Objects
If you need to deselect one object while keeping others selected, simply point at that object and click and 
release the left mouse button while holding down the Shift key.



    Modifying Objects

To make any changes to an existing object, you MUST first select it.    Once it is selected, various object 
attributes may be altered, as detailed below:

Changing Fill Patterns or Fill Color
After selecting the object, choose the Fill Style option on the Pen Menu.

Changing Line Style, Line Width, or Line Color
After selecting the object, choose the Line Style option on the Pen Menu.

Adding or Modifying Line Arrowheads
When a Line, Polygon, or Spline object is selected, choose one of the four arrowhead options on the Pen 
Menu.    To change the Arrowhead size or style choose the Arrow Style option on the Pen menu.

Changing Font Type, Style, or Size
After selecting the object, choose a Font Type or Style on the Font Menu, or a Font Size option on the 
Size Menu.    You can also change font sizes by dragging one corner of the selection box, as discussed 
under Resizing.    KwikDraw will try to maintain a reasonable aspect ratio for the font during this process.   
You can help out by trying to scale the font equally in both dimensions or by turning the Constrain option 
on.

Flipping or Rotating Objects
After selecting the object, choose one of the Flip or Rotate options on the Arrange Menu.

Changing Polygon Vertices or Spline Curvature
To change the vertices of a Polygon, you must be in the Edit Control Points mode.    After selecting the 
polygon, point at one of the highlighted vertices with the Pointer tool, press the mouse button (the cursor 
should change to a pointing hand), drag the vertex to the desired location, and release the mouse button.

Changing Extent of a Curve
To change the extent of an Arc, Pie, or Chord object, you must be in the Edit Control Points mode.    After 
selecting the object, point at one of the curve endpoints with the pointer tool, press the mouse button (the 
cursor should change to a pointing hand), drag the endpoint to the desired location, and release the 
mouse button.

Changing the Shape of a Spline Curve
To change the shape of a Spline Curve, you must be in the Edit Control Points mode.    After selecting the 
Spline Curve, point at one of the highlighted vertices with the Pointer tool, press the mouse button (the 
cursor should change to a pointing hand), drag the vertex to the desired location, and release the mouse 
button.



    Moving Objects

To move an object, or several objects at once, you MUST first select them.    Once the objects are 
selected, each will appear with "selection dots" at the four corners of a box that surrounds it.    To move 
the objects, point at one of them again, press the left mouse button (the cursor should change to an open 
hand), drag the outlines to the desired location, and release the mouse button.        While moving objects, 
the view area will autoscroll when you drag the mouse pointer beyond the edge of the view window.



    Resizing Objects

To resize an object, you MUST first select it.    Once the object is selected it will appear with "selection 
dots" at the four corners of a box that surrounds it.    To resize the object, point at one of the four corners, 
press the left mouse button (the cursor should change to a pointing hand), stretch or shrink the outline to 
the desired size, and release the mouse button.

To resize an Arc, Chord, Pie, Polygon or Spline Curve, the Edit Control Points mode must be turned off.

When the Constrain mode is on, the resized object will be constrained such that the aspect ratio is 
preserved.    This means that any change in object size in one dimension will be accompanied by a 
proportionally equal change in the other dimension.

You can only resize one object at a time, although that object can be a grouped object.



    Erasing

To remove an object completely, simply select it and hit the <Bksp> or <Delete> keys, or select Cut on the
Edit Menu.

For most technical drawings, there is not a need to erase part of an object.    Erasing is an activity more 
appropriate to Painting programs than Drawing programs.    If however, you really want to erase only part 
of an object or drawing, then you have the following options:

1)      Draw the appropriate portion of your drawing in a Paint program (such as MS Paint), and Embed it 
into your KwikDraw drawing as a distinct object.    If you have already drawn this part in KwikDraw, 
then you can easily transfer it to a Paint program by selecting it, copying it to the clipboard, and 
pasting it into your Paint program.    After you have manipulated it in the Paint program, you can bring 
the result back into KwikDraw by copying it to the clipboard from inside your Paint program and 
pasting it into your KwikDraw drawing.

2)      Cover up the part that you want to erase with any closed object (such as a closed Polygon) with a 
solid white Fill Pattern and no Line Style, as illustrated below:

For more discussion of the differences between Drawing and Painting programs, see the Introduction to 
KwikDraw.



    Creating a Parts Library

Creating your own Part Libraries is a very effective way to improve your drawing productivity.    
KwikDraw's Part Library capabilities provide you with a means of building and reusing using your own 
collection of drawing objects.    Creating a Part Library is as simple as creating a normal drawing.    

The library "parts" are those drawing objects at the highest grouping level, and may be placed anywhere 
on the drawing.    Simply draw the desired "part" and group its components so that it forms a single object.
Place a collection of logically related "parts," such as electronic symbols or flow chart symbols into a 
single drawing and save it as you would any normal drawing.

You should create your Library using the same drawing units (inches or centimeters) that you intend to 
use in your drawings.    This will ensure that the parts align in the same way relative to your grid when you
insert them into your drawing.



    Using a Parts Library

When a Parts Library file is opened using the Open As Library option on the File Menu, the parts will be 
displayed in a small browse window with a vertical scroll bar.    You may then scroll through the parts in 
the library for possible inclusion in your current drawing.    To place the currently viewed part into your 
drawing, simply select Insert From    Library from the Edit Menu.    The parts library browse window may 
be relocated and resized as desired.

The parts will appear in the browser in the order in which they were drawn in the library file.    You may 
change this ordering by using the Move Forward/Backward options on the Arrange Menu while editing 
your library file.    The objects on top are last in the browse order, while those on the bottom are first.    You
may wish to overlap the objects in the library file in order to better see which order they will browse in.

You should use the same drawing units (inches or centimeters) that the library was created with.    This 
will ensure that the parts align in the same way relative to your grid when you insert them into your 
drawing.



    Drawing objects at an offset from the grid snap

You may wish to draw several objects at the same offset from the grid snap setting.

Stating it in another way, you may want the objects to be separated by an integral number of grid ticks, 
but none of them should fall ON the grid ticks.

There are at least two ways to accomplish this.

If all the objects are identical, then I suggest this method:

1)    Draw one object with the grid snap o.
2)    Turn the grid snap off
3)    Move the object to the desired offset from the grid
4)    Turn the grid snap on
5)    Duplicate the object (Ctrl-D)
6)    Move the new copy to the proper offset
7)    Continue duplicating and moving as appropriate

If the objects are all different, then I suggest this method:

1)    Draw all the objects with the grid snap on
2)    Turn the grid snap off
3)    Select all the objects
4)    Point at one and move it to the desired offset from the grid.    Because the others are selected, they 
will move by the same offset.





Print command (File menu)

Use this command to print a document.      This command presents a Print dialog box, where 
you may specify the range of pages to be printed, the number of copies, the destination 
printer, and other printer setup options.

Shortcuts
Keys: CTRL+P



Print dialog box

The following options allow you to specify how the document should be printed:
Printer

This is the active printer and printer connection.    Choose the Setup option to change the
printer and printer connection.

Setup
Displays a Print Setup dialog box, so    you can select a printer and printer connection.

Print Range
Specify the pages you want to print:
All Prints the entire document.
Selectio
n

Prints the currently selected text.

Pages Prints the range of pages you specify in the From and To boxes.
Copies

Specify the number of copies you want to print for the above page range.
Collate Copies

Prints copies in page number order, instead of separated multiple copies of each page.
Print Quality

Select the quality of the printing.    Generally, lower quality printing takes less time to 
produce.



Print Progress Dialog

The Printing dialog box is shown during the time that KwikDraw is sending output to the 
printer.    The page number indicates the progress of the printing.

To abort printing, choose Cancel.



Print Preview command (File menu)

Use this command to display the active document as it would appear when printed.    When 
you choose this command, the main window will be replaced with a print preview window in 
which one or two pages will be displayed in their printed format.    The print preview toolbar 
offers you options to view either one or two pages at a time; move back and forth through 
the document; zoom in and out of pages; and initiate a print job.



Print Preview toolbar

The print preview toolbar offers you the following options:
Print

Bring up the print dialog box, to start a print job.
Next Page

Preview the next printed page.
Prev Page

Preview the previous printed page.
One Page / Two Page

Preview one or two printed pages at a time.
Zoom In

Take a closer look at the printed page.
Zoom Out

Take a larger look at the printed page.
Close

Return from print preview to the editing window.



Print Setup command (File menu)

Use this command to select a printer and a printer connection.    This command presents a 
Print Setup dialog box, where you specify the printer and its connection.



Print Setup dialog box

The following options allow you to select the destination printer and its connection.
Printer

Select the printer you want to use.    Choose the Default Printer; or choose the Specific 
Printer option and select one of the current installed printers shown in the box.    You 
install printers and configure ports using the Windows Control Panel. 

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the document is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources.    Specify the tray here.

Options
Displays a dialog box where you can make additional choices about printing, specific to 
the type of printer you have selected.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.




