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Introduction: What is PhotoMorph?

PhotoMorph is Windows software you can use in your own home to create the same kind of morphing and
warping effects used in Hollywood movies and TV commercials.

PhotoMorph is powerful enough to meet the needs of professionals but easy enough to have you making your
own morph movies in seconds. The interface is straightforward, and help is available at all times with a simple
point of the mouse. Full-scale online help through the Windows-based Help facility is also available.

PhotoMorph features include:

¢+ Morphing, warping, distortion, and transition effects

¢ Storyboarding and chaining of multiple clips

+ An AutoPlay feature for constructing multi-animation presentations

+ A complete Image Editing facility for cropping, rotating, scaling, and more

+ Importing of 11 popular picture formats, including PCX, GIF, Targa, TIFF, BMP, JPEG, Macintosh PICT
and Amiga IFF

¢ Output to Microsoft's Video for Windows AVI format, Autodesk's FLC Flick format, or individual 24-bit
frames

+ Video for Windows Runtime is included in the package, allowing you to distribute your movies as AVI
animations
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Getting Started with PhotoMorph

This section takes you through installation and gives you an overview of making movies. Important image
conversion features are outlined.

Requirements

To install PhotoMorph, you must have:

An IBM PC compatible 386SX or better
Microsoft Windows 3.1

4 megabytes free on your hard disk

4 megabytes of RAM

VGA display

A mouse or equivalent pointing device

* 6 ¢ & o o
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Installation Procedure

Installing PhotoMorph is quick and easy. PhotoMorph and Video For Windows Runtime are both included
on your installation disk. You will need to execute a separate installation for each of the two programs.

*** P EASE NOTE!! For PhotoMorph to run, you must have installed either:

Microsoft Video for Windows
¢ The runtime version of Video for Windows which is included in this package (installation procedure
follows)

To install PhotoMorph:

First of all:

MAKE A BACKUP COPY OF THE PHOTOMORPH PROGRAM DISK!!
Done? OK, now we can start...
1. Insert your backup copy of the PhotoMorph program disk into your floppy disk drive.
2. To begin installation from the Program Manager:

Go to the File Menu and choose Run...
+ A box entitled "Run” will appear. In the Command: edit box, type:

<source-drive>:\install

... Where <source-drive> is the appropriate floppy disk drive (A or B). For example, if the
PhotoMorph program disk is in drive A, type:
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a:\install
¢ Click OK.
To begin installation from the File Manager:
¢+ Double-click on the appropriate floppy disk icon (A or B). A window will open which will show the
A or B disk.
Double-click on the folder icon.

+ Double-click on the file "INSTALL.EXE"

3. A box entitled "PhotoMorph Installation” will appear. In this box, you may specify the directory into
which you want PhotoMorph to be installed. The default directory is c:\pmorph.

4. Click Continue. To cancel the installation procedure, click Cancel or hit the F3 key.

5. If the destination drive you specified in step 3 has insufficient space for installation, a message box will
appear: "Insufficient disk space on specified destination drive." Click OK, and the "PhotoMorph
Installation” box will reappear. You may specify a new destination drive and try again.

6. If the installation is successful, a new group will appear in your Program Manager. The new group will
be open and will include the PhotoMorph program icon.

To install the runtime version of Video for Windows:

IF YOU DO NOT HAVE THE FULL VERSION OF MICROSOFT VIDEO FOR WINDOWS INSTALLED,
YOU MUST INSTALL THE RUNTIME VERSION IN ORDER TO RUN PHOTOMORPH.

1. To begin installation from the Program Manager:
+ With your backup copy of the PhotoMorph program disk still in your floppy disk drive, again go to

the File Menu and choose Run...
+ A box entitled "Run” will appear. In the Command: edit box, type:
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<sour ce-drive>:\setup

... Wwhere <source-drive> is the appropriate floppy disk drive (A or B). For example, if the program
disk is in drive A, type:

a:\setup
Click OK.
To begin installation from the File Manager:
+ Double-click on the appropriate floppy disk icon (A or B). A window will open which will show the
A or B disk.
Double-click on the folder icon.
Double-click on the file "SETUP.EXE"

3. Specify the directory into which you want Video for Windows to be installed.

4. Follow the directions as the installation program runs.



PhotoMorph 1 Online Manual 19

Quick Tour - Create Movies

Here are a couple of quick run-throughs to get you up and making movies immediately.

Create and Display a Morph Movie
1. Open PhotoMorph. The Project Editor will be open on your screen.

= Project Editor

<<No Image>> !Il:ll |<<Nu Image>> !'l:ll

Filter

Type: [Morph |£I| Edit... I Flames:

Togole dizplay of Animstion Parameters |

iCreate Animation| Hide Window I

2. Click on the Load Project icon.

1
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3.

Select a PhotoMorph project from the Load dialog box (any file with the extension
.PMP).

Click on the Create Animation button of the Project Editor, which by default creates
a file with the extension .AVI. Name the file.

| Create Animation

Click on the AVI Player icon in the Project Editor tool bar.

e

Load the .AVI file you just created by clicking on its name in the file list.

Click on the Play button!

2]



PhotoMorph 1 Online Manual 21

Create a PhotoMorph Project and Movie
1. Open PhotoMorph. The Project Editor will be open on your screen.

Penjecy Edilor

2. Load the file SMLCAR2.JPG into the Start Image window.

¢+ (o to the Load Image icon below the Start Image window and click on it.

[is]

¢ Choose SMLCAR2.JPG from the file list.

3. Load BIGCAR2.JPG into the End Image window.

¢+ Go to the Load Image icon below the End Image window and click on it.

[s=]
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* Choose BIGCAR2.JPG from the file list.
= —

4. The Project Editor should now appear as pictured above. Note that the Morph filter
is chosen as the default filter in the Filter Type list box.

| Diztort |

Transition
Wwarp

5. Click on the Edit... button or on the right arrow between the image windows. This
opens the Morph Filter Editor, as pictured.

| Edit... Iﬂ
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6. Place points on the Start and End images.

+ Point to a spot on the bottom of the rear bumper of the car in the Start image. Click with the left
mouse button. A point appears on the image, and a corresponding point appears on the End
image.

+ Now move the cursor over to the End image and position it over the active (red) point you just
placed. Click and drag the point to the bottom of the rear bumper of the End car.

¢ Place points in a similar manner in the following locations:

Center of rear tire
Center of front tire
Bottom of front bumper
Top of front bumper
Front of hood

Bottom of windshield
Top of windshield

Top of back of car

Top of rear bumper

® 6 6 6 6 0 0 ¢

8. When you've placed all your point pairs, the images should appear as pictured.
Click OK.
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9. Now click on the Preview Window icon in the Project Editor tool bar.

©

The Preview Window appears. Use the slider to look through your animation's frames.

10. If you want to save the project so you can go back to it and work on it further, click
on the Save Project icon in the Project Editor tool bar.

=

11. Click on the Create Animation button of the Project Editor, which by default creates
an animation file with the extension .AVI. Name the file.

| Create Ammation
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12. Click on the AVI Player icon in the Project Editor tool bar.

i

13. Load the AVI file you just created.

=| V1 Pleges

EREEEE]

L] il Trioafs A1 88 I.

14. Click the Play button!

»
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Using Important Image Features

Help! Online and Context-Sensitive

Online Hel
Online help is useful for getting quick hints and information on PhotoMorph menu items and
operations.

Fids Edit Bookmaek Help

L
Photobdorph Help Bata 1.1
Copymght (53 1593, Hopth Comt 5 offwars, Ing
Al Bights B esareed

What is Fhoiobdomeh?
ik Dapactions
Swsbem B quremene:
Lzad Froject
e Frojack
Siart Image
End Inpgs
Lead ANT
Erowct Edibor Tol
Erereiers Wigchow Tox|
AT Flayer Toes]
Coloms Mam
Heip

PHoToMorpPH ONLINE HELP DiaLoG Box

To access online help, simply click on the Help menu heading in the title bar. Choose Index to locate
a particular topic you're interested in. Print a help section with the File option. Use the Edit option if

you want to copy a help section to the Clipboard. Click on Browse and use the sub-options for a
reading tour.
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If you need more information about using the Help facility, click on Using Help. This option will give
you basic information on how to get online help.

Context-Sensitive Help

You can choose to display context-sensitive help, which will give you information about whatever
menu item or option is currently active. Context-sensitive help is displayed in the "System/Help"
status bar at the bottom of the PhotoMorph window. To activate context-sensitive help, you must go
the the File menu and choose Settings. Go to the Status Bars group, and choose one of these two
options: Show Both Status Bars OR System/Help Status Bar.

‘Type: 24-Bit, Size: 450 x 433, Format: DIB - Windows 3.x Device Indep. Bitmap, Flags: Uncompressed; Color; Modified
‘Free System Resources: 69% Free Local Resources: 94% Free Memory: 5029

LocaL AND SysTEM/HELP STATUS BARS

For an example of context-sensitive help, open an image using the File menu's Image/Open option.
Click on the Edit menu. Click and hold down the left mouse button on the Copy option.
Context-sensitive help will display a short message about what the Copy option does: "Copy image
in active window and place in Clipboard."

Opening Image Files

Opening an image file reads in an image from your disk and displays it.
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Go to the File menu and choose Image/Open. A dialog box will appear. The current drive and directory
is displayed above the middle box at the bottom (the directories list box).

o= ]

—

(o ]
LieA F g o Tipsl Difzes .
[Windewz Edmap # [e=r 1]

THE OPEN IMAGE DIALOG BOX

To change directories or drives, double-click with the left mouse button on the drive or directory name in
the directories list box. Use the directories list box to move to your PMORPH directory.

To see a list of available file formats, click on the down-arrow button next to the file formats list. Scroll
the list by clicking on the up and down scroll arrows. Click on the file format PCX - PC Paintbrush
Format. PhotoMorph will display all of the files in the current directory that are in the PCX format. If you
want to see a list of all files in the directory, go to the top of the file formats list and choose * - List all files.

You may also type information into the Filename: box at the top of the Open dialog box. For example,
type *.pcx in the Filename: edit box and hit the Enter key. As above, all PCX files will appear in the file
list.

To open a file, double-click on its name in the file list at bottom left. You may also type the file's name
into the Filename: edit box (for example, typing r:\exampLE\IMAGE.TIF in the Filename: box, then hitting the
Enter key would load that particular file). Try opening some of the sample images that are provided with
your copy of PhotoMorph. They can be found in the PMORPH directory.
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Converting, Compressing, and Saving Images

Save As...
After loading an image, you can use Image/Save As... in the File menu to convert the image to
another format and to save it in compressed or decompressed form.

Load (open) the file COLORS1.TGA from your PMORPH directory. Now choose Image/Save As...
from the File menu. A dialog box will appear.

Fibmame:  |image! 5 BHF ] 10 Manschinms Edmasp
1 IE-Calsd Riwag
|BHP - Wisdesms 36 Hitmog B 26 cowenap
l:-' Lrl Hewes
e Ea B imag

0 5 D

1 ke

15 e

=5
L Ly

THE SAVE As... DIALOG BOX

If you wish to save the image to a new drive or directory, move to the new one by double-clicking with
the mouse in the directories list box. Choose a new file format for the image by clicking on the new
format's name in the formats list box (use the down-arrow and the scroll bars to browse through the
formats list box). Try choosing the format TIF - Tagged Image File Format from the formats list box.
Note that the output filename in the Filename: edit box has been changed to COLORS1.TIF. You
can use this edit box to change the output filename if you wish.

Instead of using the mouse to make changes, you may change the output filename and format by
simply typing the new name in the Filename: edit box. For example, to change the file
COLORS1.TGA to a PCX file, type coLorsl.pcx in the Filename: box.
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You can also change the file's compression state when saving. Click on the Format>> button.
Choose the Compressed radio button at the bottom to save your file in a compressed form.
De-select the radio button to save the file in an uncompressed form.

Note: There are some formats that cannot have their compression state changed by the user. For
these formats, the Compressed radio button will be grayed out (disabled). For more information on
compression states of specific formats, see the section in Chapter 5, Import/Export File Formats.

To save the file with your chosen parameters, click on the Save button. To cancel saving and exit
the Save As... dialog box, click on the Cancel button.

Color Reduction and Optimization

PhotoMorph has sophisticated options for changing the color configuration of your images. There are
two different ways to change color formats:

¢+ Use the main Colors menu or the pop-up Colors menu.
+ Use the Image/Save As... option in the File menu.

With both of these methods, you may choose between two color reduction algorithms, Flat Cut and
Optimized Cut, and you may choose whether or not to dither the image when reducing colors.
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The Colors Menu
Using this menu, you may quickly choose a color configuration for your current image. The current
configuration will be indicated in the menu with a check-mark.

Gray

Monochrome  »
16 Colors b
266 Colors k
16-Bit Color 3
+ 24-Bit Color 3
32-Bit Color »

Open the sample file, COLORS1.TGA. Now open the Colors menu and note that 24-Bit Color is
checked. Click on another color configuration; for example, 16 Colors. Now you may choose
between Flat Cut, Optimized Cut, Flat Cut with Dither, and Optimized Cut with Dither. Try choosing
one of these options, then use the Undo option under the Edit menu to get the original image back.
Then choose another method, then Undo, etc. This will give you an idea of the results each of the
four methods will give you.

You can also try choosing Gray at the top of the Colors list to convert the image to grayscale.

Pop-Up Colors Menu
A short-cut method of using the Colors menu: open an image, then point to the image with the

mouse and hold down the left button. The Colors menu will appear as a pop-up. Choose your
options in the same manner as above.

Save As...
In addition to being able to change filenames and compression states, the Save As... option in the
File menu can change color configurations.
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Fimame  [imageis GHF ] 1} Manzchinmes Edmap
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THE SAVE As... DIALOG BOX

Open the file COLORS1.TGA. Choose Image/Save As... under the File menu. Click on the
Format>> button. Note that 24-Bit Bitmap, Color, and Compressed radio buttons are selected,
showing the current configuration of the file. Note also that the Monochrome Bitmap and the
16-Color Bitmap are grayed out (disabled). This is because those two color configurations are illegal
for the current file format, Targa (in other words, Targa does not support them).

Now try going to the file formats list and choosing the TIF format. Notice that now all six color
configurations are enabled, since the TIF format supports them all.

You should notice that if you use the Save As... dialog box to convert files, there is no way to specify
the color reduction method (Flat Cut or Optimized Cut) or to select/de-select dithering. When a file is
converted using Save As..., PhotoMorph uses the methods that are specified in the Settings dialog

box under the File menu. To change the file saving settings for Save As..., go to Settings and find
the File Saving group.

If you choose a color configuration with fewer colors than the original image (anything less than 24-bit
color, in this case), PhotoMorph will use the File Saving specifications when saving the file.
However, if you choose a configuration with more colors than the original image (i.e., 32-Bit Bitmap in
this case), PhotoMorph simply stores the image in that color format. No color information is
discarded in this case.
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Screen Capture

The PhotoMorph screen capture utility will no doubt prove very useful to you in creating screen images
to use in animations.

The following sequence will capture an image of your entire screen and automatically paste it into a new
PhotoMorph window.

Go to the Capture menu and choose Entire Screen. Now click on Set Options... in the Capture menu.
In the Capture group, choose To Window. Click OK.
T |

Captmiu
DI ToFRe D) To DigBosd # 7o o |

Shee
e m—
010 - Wisdzwe % Devace Indug. Bimag (1]
[ sermemest e Mk D
- Caglue
1 Capluse Costasis
# Capluse Endan 'whindon

Hot Eey
|- Corttant: Bimelirnge [F11 £ [ m |
T [

THE CaPTURE MENU OPTIONS DIALOG BOX

Now simply hit the F11 key. PhotoMorph captures an image of your screen, opens a new window, and
pastes the image into it (all in one step!)

Please go to The Capture Menu section in Chapter 2 for explanations of all the PhotoMorph screen
capture options.
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Printing

To print an image, simply open an image file and choose Print from the File menu. You can use the Print

dialog box to scale, set print quality, and set up the printer.

I |

Pamter: f;Tell.l Frinte flkadata OL-408 on E
e

4l Gine| =
e s Lo |

L7 Arpuck:
lx

Pt fuakty: (308 s 5 Lo 1|

[ miest v Fie: [ coftets Gopsen

THE PRINT DIALOG BOX

PhotoMorph can print to any Windows-supported printing device.

Mistakes and Experiments: Undo

The Undo function under the Edit menu can be a lifesaver. It reverses the most recent operation
performed on an image. Note that the Undo operation only applies to image windows, not to project
windows!

Undo works on an image-by-image basis. In other words, if you have two images open, you can make a
change to Image #1, then make a change to Image #2, then go back to Image #1, choose Undo, and get
the original unchanged Image #1 back.

You can use Undo as a toggle between two versions of an image. Load an image, make a change, then
use Undo to switch back to the original image. Use Undo again to see the change again, and so forth.
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Undo is a great tool for trying out various operations on an image. Try loading an image and performing
the different color reduction options on it (Flat Cut, Optimized Cut, and the same two with dither), using
the Colors menu or the pop-up Colors menu.

Undo can also help you become familiar with the eight different dithering algorithms. You can change
dithering algorithms by choosing Settings under the File menu, then going to the Memory/Color Options
group and choosing from the Dither: list. Since there are no real guidelines for choosing a dithering
algorithm, it will be useful to you to try them all out on various images to become familiar with how they

work.
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Chapter 1: Standard Operations

This chapter discusses standard Windows file operations provided by the File and Edit menus:

Creating a new file

Loading files

Saving files

Renaming files

Printing files

Editing files (cut, copy, paste)

* & & ¢ o o

It also covers standard operations modified to fit PhotoMorph users' specific needs:

Creating a new animation project

Loading animation projects

Saving animation projects

Renaming animation projects

Setting up custom PhotoMorph operations

* 6 ¢ o o

The File Menu

The File menu provides standard operations for managing images and project files:
¢ creating a new image window
loading an existing image
¢ saving an image

¢ creating a new project
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loading an existing animation project
¢ saving an animation project

¢ printing images
setting up the printer
¢ setting up custom PhotoMorph operations

Image
Click on Image. A pop-up menu appears.

Ne

Choose New to create a empty image window. This command is most useful for pasting in
images from the clipboard.

Open

Choose Open to load an existing image from your disk.

To view a listing of the available file formats, click on the down-arrow button. Choose your
desired file format from this list box by clicking on the name of the desired file format. If you click
on the first option, *.* - List all files, PhotoMorph will list all files in the current directory.

Move among directories using the directory list box (double-click with the mouse to change
directories or drives). The files in the specified format and directory will be displayed in the file
list. Select your file by clicking on its name in the file list, then click OK.

Instead of using mouse clicks, you may choose your file by typing information into the Filename:
edit box. For example:

¢+ Type a file's name to load that particular file (e.g., FOO.PCX).
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+ Type an asterisk, a period, then the file format extension to see a list of all files in that
format (e.g., *.PCX).
¢+ Type *.* to see a list of all files in the current directory.

Click OK when you have specified your file.

While the file loads, a loading status box will appear which gives you information on: filename,
file format, file dimensions, palette, planes, color/gray, memory required, compression state, bits
per pixel, type, version, and creator.

The number of images that can be loaded at once is limited by the memaory required by the
images and the amount of memory available to Windows at that time. If there is insufficient
memory to load an image, PhotoMorph will post an "Insufficient Memory" message, and the
image will not be loaded.

The "last loaded" file type is saved between sessions, and will be the default file type in the Open
dialog box the next time you run PhotoMorph.

Shortcut: To quickly re-size a window to fit the image after loading, point to the window with the
mouse and click with the right mouse button.

Shortcut: Images can be scrolled using the keyboard as well as the scroll bars. Use the "Page
Up" and "Page Down" keys, and the right, left, up, and down arrow keys. Shift-Page-Up pages to
the right, and Shift-Page-Down pages to the left.

Close
Use Close to close the active image window. This has the same effect as double-clicking with
the mouse on the Control-menu box in the upper left-hand corner of the document window.

If you have not saved the current version of the image to a file, a message box will appear,
asking you if you want to save the image in its current form. You may choose Yes or No, or
Cancel the Close operation.
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Shortcut: If you wish to suppress the above-mentioned message box (i.e., if you just want to
close the window without saving any changes), hold down the Shift key as you click on Close.

Save

Use Save to save an image to a file. Click on Save to save the image and Cancel to cancel the
Save operation.

If the image is untitled, the dialog box that appears will be the same as the Save As... dialog box,
i.e., you may specify a filename, file format, number of colors, and compression state. (Please
see the section below on the Save As... menu entry for important information about automatic
color reduction and file compression).

If a message box appears indicating that there is insufficient space to save your image, you
should either:

Save the image to a different drive, or...
¢+ Go to the File Manager and delete some files from the current drive to free some space.

Save As...
Use Save As... to change an image's filename, to save to a different directory, and to convert to
a different file format. Use the Format>> options to change number of colors and compression
state. Click on the Save button to save the image as specified in the Save As... dialog box. Click
on the Cancel button to cancel the Save As... operation.
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THE SAVE As... DIALOG BOX

¢+ Change the image's filename and/or file format by typing the new name and extension in
the Filename: edit box. For example, if you wished to save the file FOO.TGA, a Targa
file, as a PCX file called BAR, you could type BAR.PCX. This would change the filename
and the file format in one step.

+ Use the directory list box to move among drives and directories (double-click with the
mouse to change directories or drives).

+ To see the list of file formats that are available, click on the down-arrow button. Use the
scroll bar buttons to look through the file formats list. Choose a new file format by clicking
on the format's name in the list. If the first item in the file formats list is chosen (*.* - List
all files), PhotoMorph will default to the image's original format when saving.

The "last saved" file type is stored between sessions, and will be the default file type in the Save
As... dialog box the next time you run PhotoMorph.

The Format>> button
If you click on Format>>, you will be presented with a list of options for saving the image. You
can use these options to:

Set number of colors (Monochrome, 16-Color, 256-Color, 16-Bit, 24-Bit, or 32-Bit).
Set the image to be Color or Gray.
¢ Turn file compression on or off.

** Please note that not all file formats support all options; those options that are illegal for the
current file format will be grayed out (disabled). For example, the GIF file format does not
support 24-bit color. Therefore, the 24-bit color option will be grayed out if the GIF format is
selected.

Important note on color reduction:

If the file formatting that you choose when saving your image requires it to undergo a color
reduction, PhotoMorph will automatically use the default color reduction options that are
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specified in File Saving under Settings in the File menu. You will receive a warning from
PhotoMorph if your image is about to undergo a color loss, which gives you a chance to cancel
the operation before color information is actually lost (discarded). (If you wish, you may suppress
this warning. Use File Saving under Settings in the File menu, and de-select the option Warn
user for color loss.) There are two instances in which an automatic color reduction can occur:

1. You click on Format>> and then choose a number of colors that is smaller than the number
of colors contained in the image.

2. You choose a file format from the file formats list which is incapable of saving the number of
colors contained in the image. If this occurs, PhotoMorph will first try to save the image in a
format with a higher number of colors. If it is successful, no warning will be issued since all
color information would have been preserved. (The only change in this case would be that
the image would have been saved in a format that can potentially encode more colors than
are contained in the image.) If there is no higher-number color format to choose from,
PhotoMorph would be forced to reduce the number of colors to the next-lowest number
available.

Here are a couple of real-life examples of 2) above:

Example #1: You paste an image from the Clipboard which was taken from a Targa file. Targa
images can contain as many as 16 million colors (24-bit color). You choose Save As... from the
File menu. You choose the GIF format from the file formats list, then click Save. At this point, a
color reduction must be performed (since GIF does not have a 24-bit color format). PhotoMorph
will use the information in Settings to tell it which method of color reduction to use, whether to
dither or not, and whether or not to display a warning that a color loss is about to occur.

Example #2: You load a 16-bit color image which is in the TIFF format. You choose Save As...
from the File menu. You choose the DIB format from the file formats list, then click Save. DIB
does not have a 16-bit color format, but it does have a 24-bit color format. In this case,
PhotoMorph will save the image as a 24-bit DIB. No warning will be issued since no color
information was discarded.
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** For information on modifying the default settings for automatic color reductions, see Settings
below. For a discussion of color reduction and dithering, see Chapter 5.

Important Note on compressing files:

You'll notice that with certain file formats, the Compressed option is grayed out. There are
actually four possibilities for file formats with regard to compression:

1.

The format is always compressed (i.e., GIF). The Compressed option will be grayed out and
selected for these formats.

The format cannot be compressed (i.e., CVP). The Compressed option will be grayed out
and de-selected for these formats.

Some subformats cannot be compressed and others can be either compressed or
uncompressed (i.e., 24-bit DIBs cannot be compressed, but 8-bit DIBs can be in either
compression state). The Compressed option will be grayed out and de-selected for the
subformats that cannot be compressed, and enabled for those that can be compressed or
uncompressed.

The format can be compressed or uncompressed (i.e., TGA). The Compressed option will
be enabled for these formats.

All you need to do to compress an image is to turn on the Compressed option under Save As...
when you save the image. The image's specific file format dictates which compression algorithm
PhotoMorph will use (with the exception of the TIFF file format).

For TIFF files only, you may change the default compression algorithm that PhotoMorph will use
when saving the file in compressed form. A different algorithm can be specified for each color
configuration (monochrome, 16 colors, 256 colors, 16-bit, and 24-bit/32-bit). Use Settings in the
File menu to change the compression defaults for TIFF files. For more information on
compression algorithms and how they affect you and your TIFF files, see Chapter 5.
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Project

Choose Project and a pop-up-menu appears.

Ne

Choose New to open the Project Editor and begin a new animation project.

If you were already working on a project when you click on File/Project/New, you will be
prompted to save it before the new project is loaded.

Open
Choose Open to load an existing animation project from your disk. Animation projects have the
extension .PMP.

Important: Project (.PMP) files keep pointers to the project's Start and End image files. If you
move the Start and End image files to a different directory or drive, the project will not be able to
find them and you will receive an error message.

(Remember that File/Project/Open can only open animation projects. If you want to open an
image file, you need to choose File/Image/Open.)

Move among directories using the directory list box (double-click with the mouse to change
directories or drives). The projects in the current directory will be displayed in the file list. Select
your project by clicking on its name in the file list, then click OK.

Instead of using mouse clicks, you may load your project by typing its filename into the Filename:
edit box.

Click OK to load your project.

When you load a project, PhotoMorph will first load its Start and End images. Loading status
boxes will appear which give you information on the Start and End images: filename, format, file
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dimensions, palette, planes, color/gray, memory required, compression state, bits per pixel, type,
version, and creator.

If for any reason PhotoMorph cannot load one of these images, a message box will appear with
the error message "Cannot load image file." The load operation will abort. Note the image's
filename in the title bar of the message box, rectify the problem, and then load the project again.

The number of images that can be loaded at once is limited by the memaory required by the
images and the amount of memory available to Windows at that time. If there is insufficient
memory to load an image, PhotoMorph will post an "Insufficient Memory" message, and the
image will not be loaded.

Save
Choose Save to save your current project to disk. Click on the Save button to save the project
and Cancel to cancel the operation.

If the project is untitled, you will be prompted to name it. You should give your animation projects
filenames with a .PMP extension.

If a message box appears indicating that there is insufficient space to save your project, you
should either:

Save the project to a different drive, or...
¢+ Go to the File Manager and delete files from the current drive to free some space.

Save As...
Use Save As... to change a project's filename or to save to a different directory. Click on the
Save button to save the project as specified in the dialog box. Click on the Cancel button to
cancel the Save As... operation.

+ Use the directory list box to move among drives and directories (double-click with the
mouse to change directories or drives).
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+ Change the project's filename by typing the new name in the Filename: edit box.

Print

Use Print to print any loaded image to an attached printer or to a file. A dialog box will appear when
you choose Print
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THE PRINT DIALOG BOX
This allows you to change parameters such as:

Size (use the Percentage option)
Aspect Ratio

Quality

Number of Copies

Destination (printer or file)

* 6 ¢ o o

The Setup button lets you adjust printer settings.
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Printer Setup

Adjust your printer's settings with Printer Setup. Available options will vary from printer to printer.
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THE PRINTER SETUP DIALOG BOX

Settings

Use the Settings options to customize certain PhotoMorph conversion operations to suit your
individual needs. These options affect speed and/or quality of the operations in question. You can
set options affecting screen bitmap use, color matching methods, dithering methods, TIFF file
compression, and default color reduction operations during file saving. The options you set will be
saved from run to run of PhotoMorph.
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THE FILE MENU SETTINGS DIALOG BOX

Screen Bitmaps
A screen bitmap is a device-specific copy of the image you are viewing. If you use screen

bitmaps, you will substantially speed up all your screen updating. The cost of using screen
bitmaps is extra memory, so if you are using mostly large or high-color images, you may wish to
turn this option off to avoid using too much memory.

If you have screen bitmaps turned on but PhotoMorph cannot create a screen bitmap because
memory is too low, a "Memory Getting Low" message will be posted. The screen bitmap will not
be created, so updating of the image will be slower.

Use on all images
Choose this option, and PhotoMorph will use screen bitmaps on each image you load.
Don't use on 16-bit and 24-bit images

This option disables screen bitmaps for high-color images. The memory you save allows you to
load a greater number of images, as well as larger files. Screen updates will be slower for 16-bit
and 24-bit images.

Don't use on any image

Disable screen bitmaps with this option. You will conserve memory at the cost of slowing screen
updates.
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Status Bars

Use the Status Bars group to set up display of the Local and System/Help informational status
bars. The System/Help bar's information includes valuable context-sensitive help messages. The
bars are displayed at the bottom of your PhotoMorph window.

The Local status bar displays information about the currently-active image. This information
includes:

+ Number of colors (monochrome, 16 colors, 256 colors, 16-bit color, 24-bit color, or 32-bit
color)

Image Size (width x height)

File Format (i.e., "BMP - Windows bitmap™)

Compressed/Uncompressed

Color/Gray

Modified

* 6 ¢ o o

The System/Help status bar displays context-sensitive help and global information about the
state of your system. This information includes:

Free memory

Free system resources

Free local resources
Context-sensitive help messages

* 6 ¢ o

There are four options for displaying these status bars:

No Status Bars

System/Help Status Bar

Local Status Bar

Show Both Status Bars (the default setting)

* 6 ¢ o

Note that you must choose either Show Both Status Bars or System/Help Status Bar in order to
activate context-sensitive help. If you wish to suppress context-sensitive help, you must choose
either No Status Bars or Local Status Bar.
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TIFF Compression

This option allows you to set the default file compression algorithm to be used when saving TIFF
files. You may choose a default compression algorithm for each possible color type:
monochrome, 16 colors, 256 colors, 16-bit color, and 24-bit/32-bit color. The compression
algorithms LZW and PackBits (RLE) are available for all color types. Group 3 (CCITT Fax 3) and
Group 4 (CCITT Fax 4) are available only for monochrome TIFFs.

The default compression setting for all color types is LZW. For more detailed information on
compression algorithms, see Chapter 5.

Memory/Color Options
Color

The Color: field can be used to specify how PhotoMorph should display higher-color images on
lower-color devices. There are two options:

+ Best Match
+ Halftone

Best Match will attempt to match the image's original colors to the available system colors.

If you choose Halftone, the image will generally look better, but the display operation will take
longer.

Dither
There are eight different dithering algorithms for you to choose from:

Halftone

NCS Fast
Floyd-Steinberg
Stucki

* 6 ¢ o
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Burkes

Sierra

Jarvis, Judice, + Ninke
Stevenson + Arce

* 6 ¢ o

There are no hard-and-fast rules for choosing a dithering algorithm. The results will vary,
depending on such variables as the image's number of colors and objects, the specific colors
used in the image, and your intended final use of the image.

Keep UNDO Buffers
If you really need to conserve memory, you can de-select this option. Undo buffers will not be

saved, thus some memory will be freed. Be warned: If you turn this option off, then the Undo
operation of the Edit menu will not function!

The default setting for Keep UNDO Buffers is on.

File Saving

Use this option to set defaults for the conversion operations that occur automatically when you
convert and save a file to a format with fewer colors. You have the following options:

Choose between Flat Cut and Optimized Cut color reduction
Turn dithering on or off
+ Send a warning (or not) if you are about to sustain a color loss when saving an image.

For more detailed information on color reduction and dithering, see Chapter 5.
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The Edit Menu

The Edit menu provides standard Windows editing operations for images loaded in PhotoMorph. These
include the Cut, Copy, and Paste operations, which allow you to move images from one window or application
to another. The Edit menu also includes the useful Undo and Delete operations.

Note: The Edit menu operates only on images. If you want to edit an animation project, this is done with the
Project Editor of the Tools menu.

Shortcut: To quickly access the Edit menu for an empty window, point with the mouse to the client area of
the window, and click with the left mouse button. This is useful when pasting an image from the clipboard
into an empty window.

Undo

Use Undo to reverse the most recent operation performed on a particular image. If you use Undo and
then change your mind, you can choose it again to undo the Undo. For instance, if you convert an image
from color to grayscale, Undo will change it back to color. If you then choose Undo again, the image will
go back to grayscale.

Undo works on an image-by-image basis. This means that if you have multiple windows (images) open,
you could change Image #1, go to another window and work on Image #2, then come back to Image #1
and still be able to use Undo to go back to the unchanged version of Image #1.

P)
c

t

Cut moves the entire image in the active window to the Windows Clipboard, from where it can be pasted
a PhotoMorph window or to any other Windows application.
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To cut a portion of an image, or a special part of the screen, use the screen capture facility and the
Capture menu (see next section, "The Capture Menu").

Copy

Copy makes a duplicate of the image in the active window and puts the duplicate in the Windows
Clipboard. The image can then be pasted back into a PhotoMorph window, or to any other Windows
application.

To copy a portion of an image, or a special part of the screen, use the screen capture facility and the
Capture menu (see next section, "The Capture Menu").

Paste

Paste takes whatever image is in the Clipboard (placed there by another application, by using the screen
capture facility, or via Copy or Cut in PhotoMorph) and pastes it to the active window. Paste can be
used to transfer files from one application to another, as well as between windows in a single application.

When you paste to a window, the pasted image will take up the entire window. Because of this, you will
probably want to open a new (empty) image window, using the Image/New option in the File menu, to
create the window you will paste into. If you paste into a window that already has an image in it, Paste
will annihilate the image that you pasted over. (To get it back, you can use Undo).

Note: If you regularly use Clipboard files (.CLP files) to transfer files from one device driver to another,
please see Chapter 5 for important information about device dependency.
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Delete

Delete removes the contents of a window. The contents will not be stored in the Clipboard if you use
Delete. If you use Delete by mistake and annihilate your image, you can bring it back by using Undo, as
long as you have not made any changes to the window in the interim.
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Chapter 2: Image Preparation

Once you have imported the images you want to use in PhotoMorph, you may want to do some additional
preparation and manipulation of the images. In this chapter, we discuss PhotoMorph's facilities for preparing still
images to use in creating special morphing effects. These include:

¢ Screen Capture
¢ Color Reduction
¢+ Image Manipulation (crop, scale, rotate, etc.)

The Capture Menu

Use the Capture menu to create screen captures and to set options for capturing images from any program
running under Microsoft Windows. (A screen capture is essentially a snapshot of your computer screen or a
portion thereof.) You can save the captured image to a file, to the Clipboard for pasting into any Windows
program, or to a new PhotoMorph window. Options allow you to set the capture area to be any region of the
screen you wish. The last capture area type selected will be stored between sessions, and will be the default
the next time you run PhotoMorph.

The Capture Key ("Hot Key")

The default capture key (the "hot key") is the "F11" function key. Use the Capture menu options to
specify what region of the
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screen you wish to capture, then use the hot key to execute the screen capture.

When you hit the hot key, the specified region of the screen will be captured, except in the case when
User-Defined Rectangle is the specified region. In this case, the regular cursor will change to a selection
cursor (crosshair), which you can use to outline your chosen rectangular region.

You can specify whether you want your captured image to be sent to a file, to the Clipboard, or to a new
PhotoMorph window by using Set Options (see below).

To change the hot key to be any of the 12 function keys, use Set Options (see below).

Active Window

This option captures an image of the window active at the time of the capture.

Active Application

This option captures an image of all windows enclosed in the running (active) application window
(including the application's own window).

Entire Screen

This option captures an image of the entire screen.

User-Defined Rectangle

Choose this option to capture any rectangular portion of the screen. When you press the Capture (hot)
key, the cursor will become a cross-hair. Hold the mouse button down and drag the mouse from one
corner of the desired area to the opposite diagonal corner. The rectangular portion of the screen you
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dragged over will be captured. As you drag the mouse, the dimensions of your selected rectangular area
will be displayed. If you want the chosen area to be a perfect square, hold the Shift key down while you
drag the mouse.

Note: If you drag over a square area by holding down the Shift key while dragging, the area may or may
not appear square on your monitor, depending on the monitor's aspect ratio (the ratio of its pixel height to
pixel width). However, it will be a square in that each side will measure the same number of pixels. For
more information on device dependency and how it affects images' appearances, see Chapter 5.

Window Under Mouse

Use this option to capture an image of whichever window is under the mouse at the time that the capture
key is hit.

This is the best option to use if you wish to capture a "control" or "client" window (such as a button, a list
box, etc.).
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Set Options
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THE CAPTURE OPTIONS DIALOG BOX

Capture
Use this option to direct your captured screen image. Choose:

¢ To File - Directs your captured image to a specified file on your disk. Use the Output File
group (see below) to set the filename, to add automatic incrementing of filenames, and to
specify the attributes of the output file.
To Clipboard - Pastes the captured image into the Windows Clipboard.

¢+ To New Window - Automatically creates a new window in PhotoMorph and places the
captured image in this window.

Output File
Use this group to set attributes of the output file, if you are sending your screen capture to a file.
(This group will be disabled if you have chosen to capture to the Clipboard or to a New Window.)
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Set the output filename by typing it in the Filename: box. Specify an output file type by clicking on
the File Type: down-arrow and then clicking again on the desired file type in the list.

You may opt to add an automatic increment number to your screen capture filenames. This is a
great time-saver if you plan to file several different screen captures, one after the other. To use the
auto increment, turn on the Increment File Number option. The default starting number will be 1.
Use the edit box to change the starting number if you wish. When the Increment File Number option
is selected and a screen capture occurs, PhotoMorph will save the image and append a two-digit
number to the end of the specified output filename. For example, if your output filename is set to be
"SCREEN.DIB" and you are incrementing file numbers, then the first screen capture image will be
saved in a file called "SCREENO1.DIB". The next screen capture would be saved as
"SCREENO02.DIB," and so on. The number in the Increment File Number option will be updated as
you work, so you may check it or change it at any time. Note: Filenames under DOS can be a
maximum of eight characters long. This means that if you specify an output filename that is more
than six characters long, PhotoMorph will truncate it in order to append the incremental two-digit
number.

Window Capture

Capture Contents. Choosing this option will cause the screen capture facility to save only the
contents of a window, excluding the window border and the title bar. This region is often referred to
as the Client Area.

Capture Entire Window. This option causes the screen capture facility to save the entire window,
including the border and title bar.

Hot Key
Set the "hot key" (capture key) to be any of the 12 function keys with this option. Current Binding

tells you what the hot key is at present (the default binding is F11). Click on the arrow key next to the
text box to get a list of all 12 function keys (F1-F12). Click on the key you want to select, then click
OK.
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The Colors Menu

Use the Colors menu to convert between color configurations. You will have various options for color
reduction schemes, and you may also choose whether or not to use dithering.

(Shortcut: To access the Colors menu quickly, simply point to an image with the mouse, and click with the
left mouse button. The menu will appear as a pop-up next to the image.)

You may choose to convert an image to a higher-color format by choosing the appropriate "Increase colors
to..." option.

Important Note: It is important to understand that simply converting an image to a format with more colors
does not "add" colors to an image, but merely changes its format. For example, if you load a 16-color image
and then choose "Increase colors to 256" under the Colors menu, you will not have 240 new colors in your
image!

The "Increase colors to..." options are useful if you need to convert a file in order to use it in another program
or with another device.

Another Important Note: Itis very important to understand the difference between 1) displaying a
higher-color image on a lower-color display device and 2) converting the image using a color reduction
method (Flat Cut or Optimized Cut). Color information is not lost if you merely display the image with a
device that cannot show all of its colors. However, when you choose to reduce the colors in an image by
clicking on a color reduction method, all the colors in the image are lost (discarded) except those that the
reduction operation keeps for the new reduced-color image.

For more information about color configurations, reduction algorithms, and dithering, see Chapter 5.



PhotoMorph 1 Online Manual 61

Color

Choose this option to convert the image to "color." (Some formats have a "color" tag and a "gray"
tag. This option will tag the image as a "color" image. It will not magically change a grayscale image to a
full-color onet)

Gray

Choose this option to convert the image to grayscale, and to tag the image as a "gray" image.

Monochrome

Converts the image to black-and-white. Choose Flat Cut or Flat Cut with Dither for color reduction.

16 Colors

Converts the image to a 16-color palette. Choose Flat Cut; Optimized Cut; Flat Cut with Dither; or
Optimized Cut with Dither for color reduction. (See Chapter 5 for more information on color reduction
methods and dithering.)

Choose Increase colors to 16 to save a monochrome format in 16-color format.

256 Colors

Converts the image to a 256-color image that has a palette. Choose Flat Cut; Optimized Cut; Flat Cut
with Dither; or Optimized Cut with Dither for color reduction. (See Chapter 5 for more information on
color reduction methods and dithering.)

Choose Increase colors to 256 to save lower-color formats in 256-color format.
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16-Bit Color

Converts the image to 16 bits (32,767 colors) with no palette. (This format is used only by certain video
boards, such as Sierra DAC-based video boards, the Targa-16 video board, and the IBM XGA video
board.) Choose Flat Cut or Flat Cut with Dither for color reduction. (See Chapter 5 for more information
on color reduction methods and dithering.)

Choose Increase color to 16-bit to save lower-color formats in 16-bit format.

24-Bit Color

Converts the image to 24-bit, or 16.7 million colors. Choose Increase color to 24-bit to save lower-color
formats in 24-bit format. Choose Decrease color to 24-bit to convert a 32-bit image to a 24-bit format.

32-Bit Color

Converts the image to 32-bit format. Choose Increase color to 32-bit to save lower-color formats in 32-bit
format.

PhotoMorph supports 32-bit images in both the Targa and TIFF format. A 32-bit image does not have
more colors than a 24-bit image, it contains an 8-bit Alpha channel in addition to a 24-bit image. That
Alpha channel overlays the image and specifies the transparency of parts of the image.



PhotoMorph 1 Online Manual 63

The Image Menu

With the Image menu, you can re-orient your image by rotating, change its size by cropping or scaling, and
perform a variety of other operations such as inverting colors, mirroring, framing, tiling, captioning, and
masking. Controls for contrast/brightness, hue/saturation provide a means of color correction for images. By
combining these operations, you can achieve great-looking special effects, too.

Digital re-sampling methods are used to create very high-quality rotated and scaled images.

On the next few pages, you'll find a graphic index showing examples of each Image menu operation.
Following the index are descriptions of each operation.
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Graphic Index of Image Menu Operations

ORIGINAL IMAGE:

INVERT IMAGE FLip IMAGE

i »

MIRROR IMAGE
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RoTaTE

90 degrees: 27 degrees:

FramE/CAPTION

Frame: Frame with Caption:
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TiLE

Tile (2 x 3):
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Tile (2 x 3 with mirroring):
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Invert Image

Use this menu item to invert the colors in your image. Invert Image takes each of the original image
colors, computes their opposite in the color spectrum, and changes each original color to its opposite. As
a simple example, if there is a color in your image which is composed of a lot of red, a little blue, and a
little green (which would be a light red), the inverted color would be composed of a little red, a lot of blue,
and a lot of green (which would be a dark cyan).

Flip Image

Use this menu item to flip your image along the horizontal axis.

Mirror Image

Use this menu item to flip your image along the vertical axis. This will create a mirror-image of the
original.

Crop...

Use this option to crop off portions from the sides of your image.

The Crop dialog box lets you specify portions of the image you want to cut from top, bottom, left, and/or
right. A thumbnail version of the image is included in a previewing box at left. Use this to monitor your
crop-line locations as you crop the image.

Cropping an image has no effect on its color (bits-per- pixel) configuration. In other words, if you start
with a 256-color (8-bit) image, it will be stored as an 8-bit image after it has been cropped.
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THE CROP DIALOG BOX

The Crop group in the dialog box has fields in which you can enter pixel values to crop off of the Top,
Bottom, Left, and/or Right of your image. As you enter pixel values, crop lines will appear at the specified
locations in the thumbnail previewing box.

Another way you can crop your image is to point with the mouse to a crop line in the previewing box (the
cursor will change to a double-sided arrow), hold down the left mouse button, and drag the line to the new
location. When you first open the Crop dialog, the crop lines are located at the edges of the image in the
previewing box. As you drag, the pixel values in the Top, Bottom, Left, and Right fields will change
dynamically. You can also point to a corner (a four-sided cursor appears) and drag the corner, to move
two crop lines simultaneously. To move the entire crop-line box around the image, just point anywhere
inside the box (the cursor will change to a hand), click, and drag the box to its new location.

The new dimensions (in pixels) of the image will be displayed in the Dimensions group (see below).

The Dimensions group allows you to enter new pixel dimensions for the image in the Width: and Height:
edit boxes. By default, the crop lines will be centered on your image. For example, if you enter a Width:
value that is 20 pixels less than your original image's width, crop lines will appear 10 pixels in from the left
and right edges of the image.
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The Dimensions group is quite useful if you want your final cropped image to be of a specific size. Just
enter the final dimensions in the Width: and Height: boxes. Then, if the crop lines are not where you'd
like them to be, you can use the hand cursor to move the crop box around.

The Display group allows you to choose whether or not to preview your image at its actual size.

If your image is small enough that it fits entirely within the borders of the previewing box, the Show Real
Size radio button will be permanently selected (since your image will automatically be previewed at full
size).

If the entire image does not fit in the previewing box, you may choose between Show Real Size and Fit In
Window. Fit In Window is good for an overall view of your crop-line locations. Show Real Size is useful
for examining a portion of your image up-close. If, for instance, you need to see if your crop line is
touching or just missing an object in the image, Show Real Size lets you take a closer look. Scroll bars
allow you to move around the image.

Scale...

Use this option to enlarge or reduce the overall size of your image.

The Scale Image dialog box allows you to: set a new width and/or height for the image; scale by
percentage; choose high-quality or high-speed scaling; choose different units of measurement; specify
dots-per-inch for different devices (allowing you to create predictable image sizes for particular devices,
such as printers); and correct aspect ratio and resolution problems.
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Scale Image
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THE ScALE IMAGE DIALOG BOX

You may specify a new image size by typing values into the Width: and/or Height: fields. Use the
Maintain Aspect check-box to choose whether or not to maintain the image's original aspect ratio (in this
instance, aspect ratio means the ratio of image height to image width). If you select the Maintain Aspect
check-box and then change either the Width: or the Height: value, the other value will change
automatically, to preserve the same aspect ratio. If you de-select the Maintain Aspect check- box, and
you enter Width: and Height: values that do not preserve the original aspect ratio, the result will generally
be an image that looks squashed or elongated. (For a discussion on how to correct aspect ratio
problems, see the following section, Correcting Resolution and Aspect Ratio Problems.)

The Measure: list box allows you to change the resolution by which the scaled image is measured. This
allows you to create images which are of a predictable size for a particular device. There are three
choices: Screen (X, y), Printer (x, y), and Custom. The values in parentheses represent dots-per-inch
(horizontal, vertical) for the chosen device.

Screen (X, y) represents what Windows believes is your monitor's resolution. (This may not, in fact, be
accurate. For a discussion of how to determine and enter your correct screen resolution, see the
following section, Correcting Resolution and Aspect Ratio Problems).

Printer (x, y) represents your attached printer. If you want to use a device that has a different resolution,
use Custom. After you click on Custom, you can enter values for horizontal and vertical dots-per-inch in
the boxes provided.
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Here's an example of how to use the Measure: box. Say you would like to create an image that will be 25
centimeters wide by 50 centimeters high when printed on an attached laser printer. The laser printer has
a resolution of 300 dots-per-inch. Since screens generally have resolutions of only 70-100 dots-per-inch,
any image you create on your screen at a particular size will print at only about one-third that size (or
less). So, to ensure correct printing size, choose Printer (300, 300) from the Measure: list box (the x and
y values will be set according to your attached printer's resolution.) Choose Centimeters from the Units:
list box. Now enter 25 in the Width: box and 50 in the Height: box. Click OK. Now your image will be 25
cm x 50 cm when printed on your 300 dpi printer (unless the image is scaled during the printing
operation).

The Units: list box allows you to choose the units by which the image is measured. Choose Pixels,
Percentage, Inches, or Centimeters. Pixels is useful for correcting aspect ratio problems and for dealing
with images on a device- dependent level. Percentage lets you change the size of the image relative to
its original size. Inches and Centimeters are useful for creating images of a predictable size on a chosen
device.

The Quality: list box lets you choose between High or Low quality for your scaled image. If you choose
Low quality, the scaling operation will be fast, and the resulting image will not be as good as it could be.
With Low quality, the scaled image will be created in the same color configuration (bits-per-pixel) as the
original image.

If you choose High quality, the scaling operation will take slightly longer, but will produce the best-looking

image. In a High quality scaling operation, the scaled image will be created in 24-bit color (for color
images) or in 8-bit grayscale (for gray or monochrome images).

Correcting Resolution and Aspect Ratio Problems

Resolution

As we mentioned above, there's a possibility that Windows may enter an incorrect resolution for
your screen in the Measure: list box under Screen (x, y). If it seems to you that the resolution values
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are incorrect, you can use the Custom entry in the Measure: list box to enter your monitor's actual
resolution.

To figure out your monitor's actual resolution: Measure the width of your monitor along the top or
bottom of the screen (you can just use a regular ruler). As an example, assume the width is 10
inches. Now measure the screen's height. Assume the height is 7.125 inches.

If you are running a VGA device, the resolution of your device driver is 640 x 480 pixels (width x

height). Divide your device's pixel height (640) by the physical height of your screen to get your
screen's dots-per-inch along the height dimension:

640/ 10 = 64 dpi

Divide your device's pixel width (480) by the physical width of your screen to get your screen's
dots-per-inch along the width dimension:

480/ 7.125 = 67 dpi.

Now you can plug these numbers into the Custom Height and Width fields and create
accurately-measured images for your screen.

Aspect Ratio

One common problem you may encounter when moving images from one display device to another is
the change in aspect ratio. Aspect ratio, as the term is used in this manual, is the ratio of a device's
dpi (dots-per-inch) along its height to dpi along its width. If an image is displayed on a device that
has a different dpi value along one or both axes than the device on which the image was created, its
aspect ratio will be incorrect. The image will generally appear either squashed or elongated. There
are two common operations that are often desired when working with devices that have different
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aspect ratios: converting an image to have the same absolute size on the new device, and
converting the image to have the same relative aspect ratio.

Same Absolute Size

To convert an image to the same absolute size on a new device you must know the absolute size of
both display devices as well as the devices' pixel resolutions. This allows you to compute the
device-independent dpi resolution for each device. Once the dpi is known it is a simple matter to
scale the image to the proper size.

As an example, imagine that you have a picture of dimensions 160 pixels wide by 58 pixels high. The

picture was created on a CGA device with a monitor that measures 10 inches wide by 7 inches high.
CGA pixel resolution is 640 x 200. So the CGA device's resolution (dots-per-inch) would be:

200 pixels / 7 in = 28.57 dpi along its height

640 pixels / 10 in = 64.00 dpi along its width

On this device, the picture's physical dimensions would be:
58 pixels / 28.57 dpi = 2.03 inches high

160 pixels / 64 dpi = 2.50 inches wide

If we use a Super VGA device with a pixel resolution of 640 x 480 (assuming the same-sized monitor
as the CGA display), its resolution (dpi) would be:

480 pixels / 7 in = 68.57 dpi along its height

640 pixels / 10 in = 64.00 dpi along its width
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Now, imagine that you display the CGA-created image on the Super VGA device (still assuming both
monitors are 10 x 7 inches). The picture, of course, still measures 160 pixels wide and 58 pixels
high. However, on the VGA device, its physical dimensions would be:

58 pixels / 68.57 dpi = 0.85 inches high
160 pixels / 64.00 dpi = 2.50 inches wide

So, without correcting for the different aspect ratio, the image would appear very squashed on the
VGA.

To make the image have the same absolute size on the VGA device you must start out with the
original size on the CGA device, and from there work out the new pixel size using the
device-independent dpi information. Since, in this case, both devices happen to have the same dpi
along the dimension of width, you only need to alter the image's height. To get the desired height of
2.03 inches, given the VGA's height dpi of 68.57, you would multiply dpi by inches to get the pixel
height:

68.57 dpi * 2.03 in = 139 pixels

So the image needs to be 139 pixels high on the new device to be the same size as it was on the old
device.

To perform this action on the actual image, you would go to the Scale dialog box, de-select Maintain
Aspect, and enter 139 in the Height: box. Now your image will be 2.03 x 2.5 inches and will no longer
look squashed.

Same Relative Aspect Ratio

Although there are an infinite number of ways to convert an image so that it has a particular aspect
ratio (1:2, 2:4, 3:6, etc), the most commonly-desired results are for an image to maintain either the
same height or the same width (measured in pixels). This can be accomplished by computing the dpi
resolutions of the two devices and then computing a new height or width.
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As an example, let's say you have an image created on a CGA device which has dimensions of 320
pixels wide by 200 pixels high. You want to save it as a VGA image with a height of 200 pixels (the
same pixel height as the old CGA image), and to correct its aspect ratio. So you need to find the
width, in pixels, which will produce an image with the new VGA aspect ratio, given a height of 200
pixels. Using the same CGA/VGA data as above you have aspect ratios of:

VGA: 68.57 dpi / 64.00 dpi = 1.07
CGA: 28.57 dpi / 64.00 dpi = 0.45

Now, to keep the height the same and compute a new width you would have:

0 oss [O_ 4.
320 Dﬁm—l.

To keep the width the same and compute a new height, you would have:

oz [— 4+,
200 DWD_A'?‘

To accomplish this last aspect change in Conversion Artist you would go to the Scale dialog box,
de-select Maintain Aspect, choose Pixels as the unit of measure, and enter the new height (475) in
the Height: edit box.

Rotate...

Use this menu item to rotate your image by any number of degrees, positive or negative, and to choose a
back- ground color for the rotated image.
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THE ROTATE DIALOG BOX

Choose Custom, 90, 180, or 270 for degrees of rotation. If you choose Custom, you may enter any
integer in the Amount: edit box, and your image will be rotated by that number of degrees. Rotation is to
the right (clockwise) if the integer is positive, to the left (counterclockwise) if the integer is negative.

You may use the Quality: list box to choose between High and Low quality for the final rotated image.

If you are rotating the image by 90, 180, or 270 degrees, the quality will always be High (in other words,
there will be no difference in appearance of the image or in speed of the operation, whether you choose
High or Low quality). If you choose 90, 180, or 270 for degrees of rotation, the rotated image will be
created in the same color configuration (bits-per-pixel) as the original image. For instance, if your original
image was a 4-bit (16-color) image and you rotate it by 180 degrees, the rotated image will be created as
a 4-bit (16-color) image as well.

If you are rotating the image by any other number of degrees, you will be performing a Custom rotation.
If you choose Low quality for a Custom rotation, the rotation operation will be fast, and the resulting
image will not be as good as it can be. With Low quality, the resulting image will be stored in the same
color configuration (bits-per-pixel) as the original image.

If you choose High quality for a Custom rotation, the rotation operation will be slower, but the resulting
image will look much better. In a High quality rotation, the rotated image will be created in 24-bit color
(for color images) or in 8-bit grayscale (for gray or monochrome images).
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The final quality of the rotated image is dependent on the image's resolution. One way to increase an
image's resolution is to first use the Scale... operation to enlarge your image (say to 300%, or 3 times
original size), then perform the Rotate... operation, and finally scale the image back down to its original
size. Working with the image at a higher resolution (larger size) will increase the quality of the image
when it is shrunk back to its original size.

In a Custom rotation, the rotated image's dimensions will be larger than the original image's dimensions.
(Rotate... draws a rectangle around the rotated image, with edges tangent to the rotated image's corners.
You will thus have portions of "background” showing behind the rotated image.) You may choose a
background color for the rotated image by clicking on the Color: button. The background color may be
chosen from a palette corresponding to your original image's color configuration (for monochrome
images, choose black or white; for 4-bit images, choose among 16 colors; etc.). If your original image
was in 24-bit color, you may choose any color for the background.

When you click on the Color: button, a color-chooser dialog box for the present color configuration
appears (except for monochrome, where the color toggles between black and white). For 4-bit and 8-bit
files, the color palette will have 16 colors and 256 colors to choose from, respectively. For 24-bit files, the
standard Windows color-chooser dialog box appears. Note: If you are choosing a color for a 24-bit
image, remember to check the luminance value in the color-chooser dialog (this can be adjusted with
the slider on the far right). If luminance is set to 0, your color will always come out black, and if it is set to
240 (the highest value), your color will always come out white.

Frame/Caption...

Use this menu item to create a custom frame and to add captions to the image.

In the Frame/Caption Image dialog box, you will find options for choosing a frame style; specifying a
framed image's final dimensions; specifying and previewing frame margin measurements; adding caption
text; and choosing colors for frame fill, frame outline, and text.
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THe FRaME/CAPTION DIALOG BOX

From the Style: list box, you may choose Filled or Outline as the frame style. Filled creates a frame filled
with a specified color. Outline creates a frame with a one-pixel outline of a different color from the fill
color. (Use the Color: button to name a color for frame fill and frame outlines.)

In the Einal Dimensions group, you may enter the dimensions, in pixels, of the finished image (picture
plus frame). As you enter the picture's final dimensions, the Frame Margin values (see Frame Margins
below) will change dynamically, centering the image within the frame. Please note: The Final
Dimensions width and height values cannot be smaller than the width and height of the image you wish to
frame. In other words, the frame cannot cover any part of the image but must only wrap around the
outside of the image. If you want the finished dimensions to be smaller, you should first use Crop... or
Scale... to cut down the size of the image before framing it.

In the Erame Margins group, you may specify the width of the frame, in pixels, at the Top, Bottom, Left,
and Right of the image. As you alter these values, the Final Dimensions values will change dynamically
to show you the final height and width of the framed image. A previewing box at the top right also
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changes dynamically as the Frame Margins values change. (The frame you've specified appears in
black, while the hatch-marked area represents the framed image.)

Use the Colors group to choose colors for frame fill, frame outline, and caption text. In the drop-down list
box, choose the area for which you want to pick a color (Fill Color, Outline Color, or Text Color), then
choose the color with the Color: button. Colors may be chosen from a palette corresponding to the
original image's color configuration (except for 24-bit images, for which any color may be chosen).

When you click on the Color: button, a color-chooser dialog box for the present color configuration
appears (except for monochrome, where the color toggles between black and white). For 4-bit and 8-bit
files, the color palette will have 16 colors and 256 colors to choose from, respectively. For 24-bit files, the
standard Windows color-chooser dialog box appears. Note: If you are choosing a color for a 24-bit
image, check the luminance value in this dialog (adjust with the slider on the far right). If luminance is
set to 0, your color will always be black, and if it is set to 240 (the highest value), your color will always
come out white.

In the Caption (X, y) group, you may enter any text you wish to overlay upon the image. (You are not
required to create a frame in order to place text upon your image.) The x and y values that are displayed
next to the word Caption represent the width and height (in pixels) of the caption that you create. This
allows you to create a frame in which your caption will fit. Note: If your caption text does not fit in your
frame or on your picture, the text will be truncated, not wrapped.

Click the Style: button to select your font, font style (bold, italic, etc.), size, and effects. Choose a text
color with the drop-down list box in the Colors group: click on Text Color, then pick a color with the Color:
button. (See above for information on the Color: button.)

Click the Align: button to position your text along the horizontal and vertical axes. Choose Left, Center, or
Right align in the Horizontal group, and Top, Center, or Bottom align in the Vertical group.

You should also consider the special effects you can achieve by combining various operations in the
Image menu. For instance, to run a caption diagonally across your image, first rotate the image by 45
degrees, caption it, then rotate back to its original orientation.
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SPECIAL TEXT EFFECT USING
FraME/CAPTION AND ROTATE

The final appearance and quality of the framed image and caption text is dependent on the image's
resolution. One way to increase an image's resolution is to first use the Scale... operation to enlarge
your image (say to 300%, or 3 times original size), then frame and/or caption it, and finally scale the
image back down to its original size. Working with the image at a higher resolution (larger size) will
increase the quality of the image when it is shrunk back to its original size.



PhotoMorph 1 Online Manual 85

Tile...

Use this menu item to create multiple copies (tiles) of your original image and organize them in an array
Tile Image

Width: (3

Height: |4 Cancel
E1 Mirror Tiles

(as though the images were tiles being laid).

THE TILE IMAGE DIALOG BOX

The Tile Image dialog box provides you with a Width: and a Height: field. Use these fields to specify how
many tiles of the image you want along the horizontal (Width) and vertical (Height) dimensions.

Select the Mirror Tiles option to create mirror effects. This option will mirror tiles both along the horizontal
and along the vertical axes. If you wish to mirror only along one axis, first tile along the mirrored axis with
Mirror Tiles selected; then tile along the non-mirrored axis with Mirror Tiles de-selected.

Mask...

Use this menu item to create special effects by masking out (hiding) parts of your image with the figures
and patterns provided.
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THE MAsK IMAGE DIALOG BOX

In the Mask Image dialog box, you can choose from an assortment of shapes for your mask. The
Shape: box at right will display the shape you choose from the Name: list at left. By default, the black
areas in the Shape: box will be the areas through which your original image will show, and the white
areas will be masked. If you select the Invert Mask option, however, the white areas in the preview box
will be the areas through which your image will show, and the black areas will be masked.

Use the Mask Color... button to choose a color for the masked parts of the final image. Colors may be
chosen from a palette corresponding to your image's color configuration (i.e., black or white for a
monochrome image, 256 colors for an 8-bit image, etc.). If the original image is in 24-bit color, any color
may be chosen for the mask color.

When you click on the Color: button, a color-chooser dialog box for the present color configuration
appears (except for monochrome, where the color toggles between black and white). For 4-bit and 8-bit
files, the color palette will have 16 colors and 256 colors to choose from, respectively. For 24-bit files, the
standard Windows color- chooser dialog box appears. Note: If you are choosing a color for a 24-bit
image, remember to check the luminance value in the color-chooser dialog (this can be adjusted with
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the slider on the far right). If luminance is set to 0, your color will always come out black, and if it is set to
240 (the highest value), your color will always come out white.

The final quality of the masked image is dependent on the image's resolution. One way to increase an
image's resolution is to first use the Scale... operation to enlarge your image (say to 300%, or 3 times
original size), then mask the image, and finally scale the image back down to its original size. Working

with the image at a higher resolution (larger size) will increase the quality of the image when it is shrunk
back to its original size.

Contrast/Brightness

Use these menu items to increase the contrast and brightness of the selected image. Contrast
will make dark parts of an image darker and will make light colors lighter. Brightness will make the
entire image lighter. Use the slider controls to change the contrast and brightness on the preview
image which is displayed. Then select OK to apply those changes to the image. You can use
Channel to select the specific color you which to modify or you can select RGB and change all colors
with a single operation.
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Hue/Saturation

Use the Hue and Saturation controls to change to overall Hue and Saturation of an image.
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The Filter Menu

Conversion Artist comes with 10 filter effects which can give an image additional distinction and flair. A
filter is applied to the image in the active window. This process can be repeated several times to give more of an
effect. All filters work with images having 16 or more colors. If an image is only black and white, or monochrome,
the filter menus will appear grayed out and will not be applicable. If you really need to apply a filter to a
black-and-white image you can promote the image to color using the settings in the Colors menu.

The filters appear in the FILTER menu in the following order:

Sharpen

The Sharpen filter will make a blurred image look more crisp. The opposite of Sharpen is Blur.

Sharpen Lines

The Sharpen Lines filter will accentuate lines and finer detail in an image.
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Despeckle

The Despeckle filter will remove stray points of very different colors. This has a subtle smoothing effects.

Emboss

Emboss is a very interesting effect which can make an image look like a three-dimensional relief, or
sculpture.

Blur

The Blur effect gives an image a blurry appearance. It is especially noticeable on images with a lot of fine
detail. As with all filters it can be used several times repeatedly on an image to make it very blurry or just a little
blurry.

Median
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The Median filter can be used repeatedly to create a Posterize effect where a few colors dominate an
image.

Trace Edges

The Trace Edges filter will remove all features from an image accept its edges. Because of the nature of
the filter, the colors it creates are very bright. These colors can be toned down or simply converted to gray using
the Contrast/Brightness or Hue/Saturation controls in the Image menu.

Noise

The Noise filter will add a small amount of randomly colored pixels evenly over an image. The effect is
that of adding 'visual noise' to the image. If more noise is desired, the filter can be repeatedly applied as needed.

Maximum

The Maximum filter will increase bright or light colored areas in an image. Repeatedly applying this filter
will spread the bright colors over an image much like water colors or finger paints.
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Minimum

The Minimum filter is much like the Maximum filter except that it spreads dark colors.
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The Window Menu

Use the Window menu to arrange multiple windows for ease of viewing, to tidy up window icons, or to close
all open windows.

—

ile

Tile arranges all of the open windows such that all windows are visible and none are overlapping. This is
good for an overview of several images at once.

Cascade

Cascade stacks the open windows one on top of the other, like a deck of cards. The title bar of each
window shows above the next one in the stack. This option is good for flipping through a screenful of
images one at a time.

Arrange Icons

This option arranges any iconized windows at the bottom of the screen.

Close All

Closes all open windows. Before closing them, PhotoMorph will ask the user whether to save windows
with images which have been altered since they were last saved.

Shortcut: If you hold down the Shift key while you click on "Close All," the query about saving altered
files will be overridden. All windows will close, and no changes will be saved.
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The Help Menu

Index

Index gives you a list of topics available through online Help.

Using Help

Using Help gives you a help window which gives you information about using the online Help subsystem.

System Info

System Info gives you a display with complete information about the current state of your system.
Windows

Version - Current version of Windows (3.0 or 3.1)

Path - Your Windows directory path (ex. d:\windows)

System Path - Your Windows system directory path (ex. d:\windows\system)
Mode - Current mode of Windows (enhanced or standard)

* 6 ¢ o

Memory/Resource

¢ Largest Free Block - The largest currently-existent contiguous block of memory (not necessarily the
largest possible block)

+ Free System Resources - Percentage of free system (Windows) resources. This determines how
many tasks can be going on at once; for example, how many windows can be open at once, how
many applications can be running, etc.
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+ Free Local Resources - Percentage of memory resources available for PhotoMorph to utilize for
creating windows, running operations, etc.
¢+ Free Memory - Total bytes of free memory.

Tasks

¢ Tasks Running - Number of tasks currently running. (Each application or utility generally equals one
task.) The List... button will attempt to show you the currently-active application names.
¢+ PMorph Windows - Number of windows currently open in PhotoMorph.

Keyboard

Character Translation - The alphabet supported by the keyboard.
+ Keyboard Type - The make-/type of the currently-installed keyboard. (For example, IBM Enhanced.)

DLL's

¢ Function DLL's Loaded - Number of Function DLL's loaded currently. (Function DLL's expand or in
some way change the functionality of PhotoMorph.)

¢ Format DLL's Loaded - Number of Format DLL's loaded currently. (Format DLL's add file formats to
PhotoMorph's import/export capabilities.)

Hardware

CPU - Type of central processing unit (80386, 80486, etc.)
+ Math Co-Processor - Present/Not Present

Disk

Temporary Disk Drive - Location of the disk drive in which Windows stores temporary files (i.e., d:).
¢+ _EXE Path - Location of the PhotoMorph executable file (i.e., c:\pmorph).

Display Device
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This block displays information about your monitor (screen), or your currently-active printer. Use the
radio button in the next section (Printer/Screen) to change from one to the other.

¢ Device Driver - Screen or name of active printer.
Size - Size of your device (width X height, in millimeters). These figures represent the dimensions
that Windows believes your device has. They are not necessarily the actual physical dimensions of
the device (though they might be close).
Resolution - Width X height of your device in pixels (these figures are exact).

¢ Bits Per Pixel - This number applied as an exponent of 2 gives the number of colors your display
device is capable of displaying (i.e., if bits per pixel = 8, your device is capable of showing 256 (or 2°
colors). Your system's hardware determines this capability.

¢ Color Planes - A multiplier for bits per pixel. For example, if your device has 8 bits per pixel and 3
color planes, it is a 24-bit color device.

+ Device Brushes - Number of logical device brushes. (Brushes are patterns of color. They may be

pure colors or mixed, as in halftones.)

Number of Colors - The number of entries in your device's color table.

Palette Size - Number of colors in the device's palette, if it has one.

Reserved Colors - Number of colors reserved by the system (Windows), which cannot be changed.

Color Resolution - Physical resolution of the device. For example, a 256-color VGA device uses 6 bits

per color component (of which there are three); therefore its color resolution is 18 bits.

+ Raster Capabilities - A listing of your device's support for raster images:

¢ Ras =raster-based device

Bnd = supports banding

Blt = ability to transfer bitmaps

B64 = ability to transfer bitmaps larger than 64K

DIB = supports device-independent bitmaps

Drw = supports device-independent bitmaps

Pal = palette-based device

* 6 ¢ o
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Printer/Screen

Choose Printer or Screen to change the Display Device information above.
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Mouse

Mouse - Present/Not Present
¢+ Double-Click Time - Of your mouse buttons, in milliseconds. This value may be set using the Control
Panel in the Windows Program Manager.

About PhotoMorph...

This item gives you a short message about the program and about North Coast Software.
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Chapter 3: Morphing - The Tools

Menu

The Tools menu is the heart of the PhotoMorph application. With its three main tools you can create, edit, and
view an animation project involving morphing, warping, distortion, and transition effects.

The three main tools are:
¢+ The Project Editor (which includes the Filter Editors)

¢ The Preview Window
¢ The AVI Player

These tools allow you to create and edit animation projects, save individual frames of an animation as separate
files, and to create complete animations in Microsoft's Video for Windows standard AVI format, Autodesk's FLC
(Flick) format, or as a series of 24-bit frames in any of the supported output file formats.

As you work with the tools in this menu, you can access context-sensitive help simply by pointing at any feature
with the cursor. There is also a full Windows-based Help facility, accessed through the Help icon in each menu

item's tool bar.

THE HELP ICON
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Overview of the Tools Menu

The Project Editor gives you tools for creating and editing animation projects. Filters (animation engines) are
provided for morphing, warping, distortion, and transition effects. Animation files can be created from
projects. Controls are provided for adjusting animation speed, compression, quality, and specifying output file
type and number of frames.

The Preview Window lets you browse through the animation clip (section) which is currently loaded into the
Project Editor. You have options for saving individual frames of the animation or copying frames to new
windows.

The AVI Player is an animation viewer you can use to look at a final animation in the AVI format. VCR-like
controls are provided. The AutoPlay feature lets you construct multi-animation presentations.

Note: The AVI format allows you to create animations which can be viewed by anyone who has a computer
equipped with an AVI player. (A runtime version of Microsoft's Video for Windows is included with
PhotoMorph, allowing you to play AVI animations from within PhotoMorph.) AVI animations will run on any
device (monochrome, 8-bit, 16-bit, 24-bit, etc).



PhotoMorph 1 Online Manual 101

Understanding Filters

The Filters are the engines of PhotoMorph, where the real work is done. Through a series of computations,
they use the information you enter to generate an animated series of frames which produce the specified
effect: Distort, Morph, Transition, or Warp.

Distort

This filter produces one of 18 different distortion effects over the course of the clip. It can be used with
either one (Start) or two (Start and End) images. Examples include: lens, ripple, pinch, zoom in/out, etc.
If two images are used, controls are provided to create a merge phase, during which one image segues
into the second image. Graphic examples of distortion effects are provided in the Distort Filter section.

An example of a distort project in your PhotoMorph directory is carbisT.pvP.

Morph
A filter which produces an animated change from one image into another, different image. The Morph
filter uses two images (Start and End).

An example of a morph project in your PhotoMorph directory is cars.pmp.

Transition

This filter produces various transition effects, such as those that might be used between section (clips) of
an animation, or at the end of an animation. Examples include: fade-to-black, fade-from-black, a curtain
effect, or a fade from one image to another. The Transition filter uses one or two images, depending on
which option is chosen.
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An example of a transition project in your PhotoMorph directory is TRANSIT.PMP.

Warp

A filter which produces an animated change from one image into a different, warped version of the same
image. The Warp filter uses one image.

An example of a warp project in your PhotoMorph directory is sHRINK.PMP.

What Are Clips and Animation Projects?

A clip is simply an animation defined by a beginning and an ending image. You can imagine it as a
section of film which consists of several individual cels, or frames. Just as running such a filmstrip
through a projector would produce an animation on a screen, so playing a clip creates an animated
sequence on your computer monitor.

A clip consists of:

One or more images

A filter type (Distort, Morph, Transition, or Warp)
Frames (the number can be specified)

Editing information

* 6 o o

An animation project can include one or more clips, and contains global information which will apply to
the entire animation, whether composed of one or many clips.

An animation project consists of:

One or more clips (see above)
A file compression method tag
An output file type

A quality setting

* 6 ¢ o
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Basic Steps to Creating an Animation Project

Following is a basic procedure for the creation of an animation project. For more detailed information on
particular steps, please see the relevant sections in this chapter.

1. Load Start and End images for your project's first clip.

The Project Editor opens with an empty clip. To begin creating your first clip, you need to load Start
and End images.

To load Start and End images:

Any images currently loaded in the PhotoMorph application will be listed in the Image List boxes
below the Start and End image windows. If the images you wish to use are currently loaded, simply
click on the down-arrow under the Start image window and choose the image by clicking on its name
in the list. Do the same for the End image window.

If the images you wish to use are not currently loaded, click on the Load icon next to the Image List
box below the Start window. The File dialog box opens. Use this dialog box to load the Start image.
Repeat the process using the Load icon under the End image window.

Project Edilor

THE ProJECT EDITOR WITH START AND END IMAGES LOADED
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2. Choose a filter from the Filter Type list box: Distort, Morph, Transition, or Warp.
Diztort

Transition
Warp

THE FILTER TYPE LIST
3. Use the Eilter Editor to specify what is to happen during the clip.

To access the Filter Editor, click on the Edit... button or on the right arrow between the Start and End
images.

(e b
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The Filter Editor is different depending on the chosen filter type. (See The Filter Editor section for a
complete description).

AT G

THE MorpPH/WARP FILTER EDITOR
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U
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THE TrANSITION FILTER EDITOR

4. Click on the Save Project icon in the Project Editor tool bar to save your clip to disk.

=

THE SAvE PROJECT ICON

You will be prompted for a filename. The default file extension for a PhotoMorph project is .PMP.

5. Preview the clip by choosing Preview Window from the Tools menu or clicking on
the Preview Window icon in the Project Editor tool bar.

THE PrEVIEW WINDOW ICON

The Preview Window allows you to browse through your clip and, if you wish, to save individual
frames as image files. The window's slider corresponds to percent progress through the animation.
(See The Preview Window section for a complete description.)
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6. Add another clip if desired.

Click on the New Clip icon and begin again at step 1 to append a new clip to the one you just created.

To see a display of the current clips in your animation, click on the Storyboard icon. The Storyboard
also allows you to move clips around by cutting, copying, and pasting.

W

THE NEw CLip IcoN

THE STORYBOARD ICON
7. Alter animation parameters.

The Animate parameters display may be toggled with the Animate Parameters icon.

THE ANIMATE PARAMETERS ICON
You can specify:

Speed

Compression Method
Output File Type
Animation Quality

* 6 ¢ o



PhotoMorph 1 Online Manual 108

8. Click the Create Animation button to create an animation file.

Create Animation

Depending on which output file type you select, you will be prompted for a filename with an .AVI or
.FLC extension, or you will be presented with the Frames setup dialog box. The animation output file
will contain no information about individual clips, pairs of married points, etc., but only a sequence of
animation cels. To make changes to an animation, you must use the Project Editor to make the
alterations, and then re-create the output file.

9. If you wish to play an AVI animation, click on the AVI Player icon of the Project
Editor, or choose AVI Player from the Tools menu.

THE AVI PLAYER ICON

Load your AVI animation into the AVI Player, and click the Play button. (See the AVI Player section
for a complete description.)
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The Project Editor

The Project Editor is your base of operations for creating an animation project. Context-sensitive help can be
accessed by pointing with the cursor to any icon. Context-sensitive help messages are displayed at the
bottom of the Project Editor window. Full Windows-based help can be accessed by clicking on the Help icon.

[14ha Imagen (2 [como o ==k
Filter

L — N R I

Tnggie dipliry of Amration Parsrsstars:
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THE ProJecT EDITOR
The Project Editor's main features are:

Start and End image windows
Filter Type selector
Storyboard

Animation parameters area

* 6 ¢ o

Start and End Image Windows

The Start and End images can be loaded with the Load icons beside the Image File lists below each
window. The Start and End images define the beginning and end states of a clip.
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Any image that can be loaded by PhotoMorph can be used as a Start or End image. The Start and End
images are treated differently depending on which filter Type is selected.

Filter Type Selector

The Filter Type Selector box lists the available filters: Distort, Morph, Transition, and Warp.
Distort

Transition
Warp

THE FILTER TYPE LIST

Storyboard

The Storyboard displays the clips which are included in the current animation and allows for moving and
copying clips. Click on the Storyboard icon in the Project Editor tool bar to toggle the Storyboard display.

kil

THE STORYBOARD ICON
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THE STORYBOARD

The clip which is currently loaded in the Project Editor is outlined in red. The clip which has been clicked
on (selected) in the Storyboard is outlined in blue.

Begin
The Begin button moves the selected clip (blue outline) to the beginning position in the Storyboard.
This clip will now begin the animation.

Left

The Left button moves the selected clip (blue outline) one position to the left.

Load Clip
The Load button reloads the selected clip (blue outline) back into the Project Editor. The clip will now

be outlined in red, as the currently-loaded clip.

You may also double-click on a clip to reload it into the Project Editor.

Right
The Right button moves the selected clip (blue outline) one position to the right.

End

The End button moves the selected clip (blue outline) to the ending position in the Storyboard. This
clip will now end the animation.
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Cut

The Cut button removes the selected clip (blue outline) from the sequence of clips on the Storyboard
and puts it on the Windows Clipboard. It may then be pasted into a different position in the current
animation, or into another animation.

Copy
The Copy button puts a copy of the selected clip (blue outline) on the Clipboard. This clip may now
be pasted into a different position in the current animation, or into another animation.

Paste
The Paste button inserts a clip from the Windows Clipboard. The clip will be inserted into the
currently-selected position (blue outline), and the other clips will be shifted to the right.

Animation Parameters Area

The Animate parameters area provides settings for speed, compression, output file type, and quality of
animations. Click on the Animation icon in the Project Editor tool bar to toggle the Animate parameters
display.

THE ANIMATE PARAMETERS ICON
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THE ANIMATION PARAMETERS AREA

Speed

The frames-per-second setting is a global variable, applying to the entire animation. In other words,
you cannot set one speed for one clip and another speed for another clip in the same animation.

Any number of frames per second may be entered in the Speed edit box. However, the animation's
actual speed will be limited by your computer's capabilities. Use a small frame size for smoother
animations. (See Chapter 5 for more information about optimizing the speed and appearance of
animations.)

Compression Method

Choose a compression method using the Compression drop-down list.
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For the AVI output file type, you have several compression options. Video 1 is a compression method
written by Microsoft. Indeo is a compression method written by Intel. These two methods have
comparable compression rates. (Hardware support is available for playback of Indeo-compressed
animations through Intel's ActionMedia cards.) Cinepak is a compression method written by
SuperMac. ltis slow to compress but produces fast playback results.

If a compression method is listed more than once, use the item with the highest version number for
best results. If you have any other AVI Codecs (compressor/ decompressors) installed on your
computer, PhotoMorph will load them automatically for use in compressing and decompressing your
animations. Look for them in the Compression drop-down list.

For the FLC output file type, you can choose no compression or RLE (run-length encoding)
compression.

For the Frames output file type, you may choose ON or OFF for compression. ON specifies that
compression will be used if the chosen output file format supports compression. OFF specifies that
compression will not be used, if the chosen output file format supports uncompressed files.

The compression method is a global variable. In other words, you cannot assign one compression
method to one clip and another compression method to another clip within the same animation.

Output File Type
The Output list lets you specify the output file type for your animation. Choices are:

* AVI
FLC
* Frames

Use the Setup button to alter parameters of the output file.
For the AVI format, these parameters are:

+ Data Rate
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The kilobytes-per-second rate of transfer from the hard disk to the computer. Note that
you must click on the check box to activate this parameter.

Key Frame rate

The Key Frame rate tells the chosen compression algorithm how often to select a frame
as a key frame. A key frame is a frame used as a marker in the compressed form of the
animation. The compression algorithm uses key frames as landmarks and extrapolates
the remaining frames of the animation from the key frames.

The lower the Key Frame rate, the higher the quality of the animation.
Note that you must click on the check box to activate this parameter.
Quality (0 - 100)

The Quality setting affects the compression of the output file. The higher the Quality
setting, the lower the rate of compression. Note: This setting affects the quality of the
output fiille when it is written to disk, not when the animation frames are actually created.

You must determine a setting that produces a quality sufficiently high to satisfy you
without using up all of your disk space. (An animation of dimensions 320 X 200 pixels
which is 30 frames long will take up about 5.7 megabytes of disk space.) As a general
guideline, a Quality setting of 75 will produce reasonably high quality and pretty good
compression.

For the FLC output type, parameters are:

+ Dynamic Palette Option

With the Dynamic Palette option, you can create FLC animations which contain many
more colors than the standard 256-color FLC animations. When selected, this option
instructs PhotoMorph to compute the best palette for each frame of the animation and
then use this palette. If Dynamic Palette is not selected, a standard 256-color palette is
chosen and used for all frames in the FLC file.
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NOTE: When using a dynamic palette, your animation must contain an even number of
output frames in order to loop correctly in a FLC player.

+ Dither Frames Option

With the Dither Frames option, you can instruct PhotoMorph to dither each frame of the
FLC animation, which will produce smoother-looking images. Dithering works by mixing
pixels of different colors to produce the appearance of more colors than are actually
displayed. For best results, dithered FLC files should be displayed using high-resolution
drivers for the FLC player. If dithering is turned off, the output frames will be produced
with the closest matching colors.

For the Frames output type, parameters are:

¢ Name

Specify the base name for the output files. The base name will be used to create all of
the different frame files. Example: A base name of '‘frame’ will produce file names of
frame001.BMP, frame002.bmp, etc. The name of the currently-specified first frame file is
displayed in the lower right.

+ Directory

Specify the DOS path name for the output directory. All of the frame files will be saved to
this directory. If left blank, the current directory will be used.

¢ File Format

Specify the type of output file format which will be used for each frame file. Any 24-bit file
format which is supported by PhotoMorph can be used when outputting to frames. These
formats include:

BMP - Windows Bitmap
DIB - Windows DIB
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EPS - Encapsulated PostScript
JPG - JPEG Compressed

PCX - PC Paintbrush

TGA - Targa

TIF - TIFF

¢ Start Frame

Specify the first frame number to be used when numbering the output frame files. The
frame files look like 'baseXXX', where X" is the frame number. Example: If you specified
a starting frame number of 23, a base name of 'frame’, and the TGA file format, the first
output frame file would be called 'frame023.TGA' The name of the currently-specified
start frame file is displayed in the lower right.

Quality

Choose High or Low quality for the creation of your final animation frames. This setting affects the
frame quality at the time of creation. High quality animations will have smoother action but will take
longer to create. Low quality animations will be created faster but the animation will be less accurate.
(See Chapter 5 for more information about optimizing the quality of your animations.)
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The Filter Editors

This section describes the different Filter Editors, which are used to specify the action in an animated clip.
After loading Start and End images in the Project Editor and choosing a Filter Type, click on Edit... or on the
right arrow between the Start and End images. The Filter Editor window will open. Context-sensitive help is
available by pointing at any icon or control.

The Filter Editor will be different depending on which Filter Type is selected.

The Distort Filter

To choose a Distort filter effect, click on the Edit... button or on the right-pointing arrow between the
Start and End image windows in the Project Editor. A list of 18 different distort effects is displayed. (A
graphic index of these effects is shown in the next section.)

The Distort filter can be used with either one image (load only a Start image) or two images (load Start
and End images).

The Start and End percentages control when the Distort clip will begin and end recording to the output
file.

If two images are being used, controls are provided for specifying different phases of the animation:
Source, Merge, and Destination. These controls allow sophisticated transition effects to be achieved.

Controls are also available for dictating the direction of the distortion: Forward (undistorted image =>
distorted image) or Reverse (distorted image => undistorted image).

Each of the Distort filter controls and options are described fully in the following pages. NOTE: Filter
effect names followed by a [F] are particularly computationally intensive and will be slow on machines
without a floating point coprocessor.
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Index of Distort Effects

Shear Spherize Stretch Width
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Zigzag Zoom In Zoom Out
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Start and End Percentages

Use the START percentage to specify when to start recording the animation to the output file.
For example, setting a start percentage of 20% means that the first 20% of the clip's total
animation will be skipped and only 20% through 100% will be recorded to the output file.

Use the END percentage to specify when to stop recording the animation to the output file. For
example, setting an end percentage of 80% means that 0% through 80% of the animation will be
recorded to the output file, and 80% through 100% will be skipped.
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Source/Merge/Destination Percentages

NOTE: If you are interested in creating a Distort clip in which only one image is distorted over
the course of the clip (in other words, the Distort clip is not being used as a transition between
two distorted images), then this section may be skipped. In this case, you will load only a Start
image, and the Source, Merge, and Destination fields will be disabled.

Use the SOURCE percentage to specify how much of the animation should use only the start
image, without merging in any of the destination image.

Use the MERGE percentage to specify how much of the animation should merge the start and
end images. In the MERGE portion of the animation, the frames are created by merging
information from the Start and End images, beginning with the distorted state of each of the two
images at the beginning of the merge. The result is a transformation from the distorted start
image to the distorted end image.

The amount of each image that will contribute to the final frame is set according to the
percentage through the merge phase of the rendering. At the start of the merge phase, the
source image will contribute 100% to the final frame and the destination image will contribute 0%.
Half way through the merge phase, the source image will contribute 50% andthe destination
image will contribute 50%. At the end of the merge phase, the source image will contribute 0%
and the destination image will contribute 100%.

Use the DESTINATION percentage to specify how much of the animation should include only the
end image without merging in any of the start image.

The Reverse Checkboxes

A Distort filter effect can either be run forwards or backwards. In this case, forwards means
from undistorted (unfiltered) to fully distorted (filtered), and backwards means fully distorted to
undistorted.

The Reverse Source Filter and Reverse Destination Filter boxes are used to specify the
direction of the distortion for each image over the course of the animation.
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Reverse Src Filter box unchecked: The start image will be filtered forwards (No Distort =>
Full Distort).

Reverse Src Filter box checked: The start image will be filtered backwards (Full Distort =>
No Distort).
Reverse Dst Filter box unchecked: The end image will be filtered forwards (No Distort =>

Full Distort).

Reverse Dst Filter box checked: The end image will be filtered backwards (Full Distort => No
Distort).

Phases of Rendering
The following table will clarify how the different phases of a Distort clip are created.

From => To Phase of Distort Clip
0% =>  Start % Skip this section when writing animation output file
Start % => Source % Filter only the Start image

Source % => Merge % Filter both Start and End images in specified direction (Forward or
Reverse), and merge results

Merge % => End % Filter only the End image

End % => 100 % Skip this section when writing animation output file

Examples
Following are some examples of Distort clip setups, with explanations of the results.
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Example 1:

A Start image is loaded in the Project Editor. No End image is loaded. The Distort options are
set as follows:

Start: 0%

End: 100%

(Source: 100% - This option is grayed out and set to 100% when only a Start image is loaded.)
Reverse Src Filter: FALSE

Result: 100% of clip is rendered using a forward filter on the Start image.

Why? The Start percentage is set to 0, so the clip is written to the output file from 0% (the
beginning). The End percentage is set to 100, so the output file ends when 100% of the clip is
written. The Reverse Src Filter box is not selected, so the filter runs in a forward direction.

Example 2:

Start and End images are loaded in the Project Editor. The Distort options are set as follows:

Start: 0%

End: 100%

Source: 0%

Merge: 0%

Destination: 100%
Reverse Src Filter: FALSE
Reverse Dst Filter: TRUE

Result: 100% of clip is rendered, using a Reverse filter on the End image.
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Why? The Start percentage is 0 and the End percentage is 100, so the entire clip is written to
the output file. The Source percentage is set to 0, so 0% (none) of the Start (Source) image is
used during the clip. The Merge percentage is set to 0, so none of the clip merges the two
images. The Destination percentage is set to 100, so the Destination (End) image contributes
100% of the information used in the clip. Since the Reverse Dst Filter box is selected, the
Destination image is filtered in reverse.

Example 3:

Start and End images are loaded in the Project Editor. The Distort options are set as follows:

Start: 20%

End: 95%

Source: 80%

Merge: 0%

Destination: 20%

Reverse Src Filter: FALSE
Reverse Dst Filter: TRUE

Result: The output file skips the first 20% of the clip. The first 80% of the clip is rendered using
a forward filter on the Start image, and then the final 20% of the clip is rendered using a reverse
filter on the End image. The output file skips the final 5% of the clip.

Why? The Start percentage is set to 20, so the recording of the clip to the output file will start
after 20% has gone by. The End percentage is set to 95, so the final 5% of the clip will not be
recorded to the output file. The Source percentage is set to 80, so the first 80% of the clip uses
only information from the Source (Start) image. The Merge percentage is set to 0, so none of the
clip merges the two images. The Destination percentage is set to 20, so the final 20% of the clip
uses only information from the Destination (End) image. The Source image is filtered forward,
since the Reverse Src Filter box is not selected. The Destination image is filtered in reverse,
since the Reverse Dst Filter box is selected. A diagram is shown below:
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Example 4.

Start and End images are loaded in the Project Editor. The Distort options are set as follows:

Start: 0%

End: 100%

Source: 33%

Merge: 34%

Destination: 33%

Reverse Src Filter: FALSE
Reverse Dst Filter: TRUE

Result: The entire clip is recorded to the output file. 33% of the clip is rendered using a forward
filter on the Start image; then 34% is rendered using a forward filter on the Start image merged
with a reverse filter on the End image; then 33% is rendered using a reverse filter on the End
image.

Why? Start and End percentages are set to 0 and 100 respectively, so the entire clip is written.
The Source percentage is set to 33, so the first 33% of the clip uses information from the Start
(Source) image. The Merge percentage is set to 34, so the next 34% of the clip merges
information from the Start and End (Source and Destination) images. The Destination
percentage is set to 33, so the final 33% of the clip uses only information from the End
(Destination ) image. The Reverse Src Filter box is not selected, so the Start image is filtered
forward. The Reverse Dst Filter box is selected, so the End image is filtered in reverse. A
diagram is shown below:
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The Transition Filter Editor

After clicking on Edit... or the right arrow, choose a transition effect from the list.
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THE TrRANSITION FILTER EDITOR LIST
Available effects are:

¢ Curtain (begins with Start image, then splits the image like a curtain opening to reveal the
End image)

Fade from Black (begins with black, fades to Start image)

Fade to Black (begins with Start image, fades to black)

Fade to Image (begins with Start image, fades to End image)

Reverse Curtain (begins with Start image, then brings the split End image over it like a
curtain closing)

* & ¢ o
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Slide Down (slides Start image down to reveal End image)
Slide Left (slides Start image to the left, revealing End image)
Slide Right (slides Start image to the right, revealing End image)
Slide Up (slides Start image up to reveal End image)

* & o o

The Fade from Black and Fade to Black effects require only one image to be loaded, since one end of
the animation is a black frame. Note that whether you choose Fade from Black or Fade to Black, the
Start image is the one that PhotoMorph will use to create the animation. If an End image is loaded, it
will be ignored.

The Morph and Warp Filter Editor

When you select Morph or Warp as your Filter and click on Edit... or on the right arrow, the Morph/Warp
Filter Editor appears.

Morphfe'sap Edinge

THE MorpPH/WARP FILTER EDITOR

The loaded Start and End images are displayed. Each image's window has its own tool bar. The tool
bars allow you to place married pairs of points on the two images. Each married pair of points represents
a beginning and end location for the Morph or Warp operation to use when creating the final animation.

By default, when the Filter Editor is opened, the Place Point tool is activated in the Start image and the
Move Point tool is activated in the End image.
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The tool icons are as follows:

+ Place Point
w | -

S

Allows you to place a point on a Start or End image by clicking with the left mouse button. When a
point is placed on one image, a corresponding point is automatically placed on the other image and
"married" to the first point. Over the course of the morph or warp animation, a point placed on the
Start image will migrate to its married point's location on the End image.

+ Move Point

Allows you to position the active point (red) in the active window (red outline) with the cursor or the
arrow keys. The left mouse button lets you point and drag. The right mouse button acts as a "point
magnet," grabbing the active point from its current location and moving it to the cursor's location.

+ Delete Point

Allows you to delete a pair of points. Position the cursor over the point to be deleted and click with
the left mouse button; or simply click with the right button, and the currently-active point, along with
its partner, will be deleted.
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When a point is deleted, its married point on the other image will always automatically be deleted.
Thus, there are always the same number of points on each image, and every point is one of a pair.

¢ Zoom In/Out
e

Allows you to look at fine detail or the entire image. To zoom in, click with the left mouse button. To
zoom out, hold the Shift key down and click with the left mouse button.

Placing Married Points on the Images
1. Click with the left mouse button in the Start image.

Since the Place Point tool is active, a red point will appear where you clicked. Red indicates that the
point is currently active. You'll also note that the Start image has a red outline, indicating that it is the
active image.

2. At the same time you place a point in the Start image, a corresponding red point
will appear at the same location (same x y coordinates) in the End image.

3. Move the cursor over the End image to activate it (note the red outline), and
position the married end point.

In this image, the Move Point tool is active (by default). Use the mouse to move the point on the End
image to the desired final location (where you want the Start point to end up at the close of the
animation).

4. Repeat steps 1 through 3 to place as many married point pairs as you wish.
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The more point pairs you specify, the more precise the resulting Morph or Warp animation will be.
(See Chapter 5 for discussion of advanced morphing techniques.)

IMAGES WITH MORPHING POINTS PLACED

Editing Shortcuts
+ Selecting Points

As you add more point pairs, you'll note that the inactive points are blue and the active points are red.
Use the Space bar to activate successive point pairs for ease in editing point locations.

+ Moving Points

When the Move Point tool is selected, the right mouse button acts as a "point magnet," grabbing the
active point from its current location and moving it to the current cursor location. This will save you
the trouble of positioning the cursor exactly above the point you wish to move and then dragging.
You may also use the arrow keys to move the selected point. The arrow keys will operate on the

active point in the active image. The active point is red, and the active image is marked by a red
outline around its window.

+ Deleting Points
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With the Delete Point tool activated, click with the right mouse button to delete the currently-active
(red) point and its corresponding married point. This will save you the trouble of positioning the
mouse directly above the point you wish to delete.
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The Preview Window

The Preview Window lets you browse through a clip, save individual frames to files, and copy frames to
image windows. Using the Preview Window is the fastest way to view the result of an animation project.

Context-sensitive help is available by simply pointing at any icon or control.

Previewing a Clip

To preview a clip, click on the Preview Window item in the Tools menu.

| Proviow
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THE PreviEw WiNDOW

The slider in the Preview Window is used to browse through the current animation clip. The slider
corresponds to progress through the clip over time; for example, move the slider halfway across the bar
to see a frame 50% through the clip. (Depending on the final number of frames in your clip, the frames
you can view in the Preview Window may or may not correspond to actual frames in an AVI animation
created from the clip.) Using the slider to browse can help you decide if you need to adjust or alter your
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clip. For instance, if the metamorphosis in a morph or warp clip seems unconvincing or imprecise, you
may want to refine it by using the Project Editor to add more point pairs.

Tools are provided for updating the preview image, saving a frame to a file, and copying a frame to a new
window.

Updating the Preview Image

THE UPDATE IMAGE ICON

This tool is provided for updating the image in the Preview Window after work has been done in the
Project Editor on the present clip, or if you have switched to a new clip. This option is provided since the
update process is somewhat time-consuming, as the morph movie has to be recomputed for the update
to occur.

Saving a Frame to a File

=)

SAVE IMAGE TO FILE IcON

To save any individual frame to a file, slide the slider until the desired frame is displayed in the Preview
Window. Click on the Save Image to File icon in the tool bar at the bottom of the window. A dialog box
appears. Choose the desired file format from the box and click Save.
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NOTE: The Preview Window can save files only in 24-bit color formats. Export formats which support
24-bit color are:

Windows Bitmap (BMP and DIB)
Encapsulated PostScript (EPS)
JPEG Compressed

PCX

Windows Compressed Bitmap (RLE)
Targa (TGA)

TIFF

* 6 6 6 ¢ o o

If you wish to save your file in another format or reduce its number of colors, you should either:

1. Copy the frame to an empty window from the Preview Window (see below for the procedure).

2. Use the Colors menu or File/Image/Save As... to reduce the number of colors in the image and/or to
save to another format.

OR:

1. Save the image to a file from the Preview Window. in one of the listed 24-bit color formats.

2. Open the file and reduce the number of colors using the Colors menu or File/lmage/Save As...

Copying a Frame to a New Window

THe Copy IMAGE TO NEW WINDOW ICON
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The Preview Window is equipped with a tool bar at the bottom of the window.

To save any individual frame to a file, slide the slider until the desired frame is displayed in the Preview
Window. Click on the Save Image to New Window icon in the tool bar at the bottom of the window. The
frame will be copied to a new image window.

From the new window, the image may be saved in any supported export format.
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The AVI Player

When you have finished editing an animation clip or project, create an AVI animation file by choosing AVI as
your output file type (in Animation Parameters) and clicking on Create Animation in the Project Editor. Now
you can use the AVI Player to view the final product. You can also set up multi-animation presentations with
the AVI AutoPlay feature.

To open the AVI Player, choose AVI Player from the Tools menu, or click on the AVI Player icon in the
Project Editor tool bar. Context-sensitive help is available by pointing at any icon in the window.

THE AVI PLAYER ICON

Load the AVI animation by clicking on the Load Animation icon and selecting the AVI file.

Use the controls to look at the animation. The controls provided are similar to standard VCR controls.

THE LoAD ANIMATION ICON

+ Play

4
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+ Rewind

=

+ Single-step back

N

+ Single-step forward

R

*

Fast forward

E|

Remember, the AVI file contains no project information. To alter an animation, you need to go back to the
Project Editor, make changes, and re-create the AVI file. If your animation's action is jerky or abrupt, you
might want to smooth it by increasing the number of frames in the animation or by decreasing the frame size.
If the metamorphosis seems unconvincing or imprecise, you might want to add more married point pairs to
refine the changes.
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The AutoPlay Feature

AutoPlay is used to play a sequence of AVI files in any order, looping each AVI file as many times as
desired, and looping the entire presentation. To bring up the AutoPlay Dialog Box, click on the
AutoPlay icon.

AUTO |

THE AuTOPLAY IcoN
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AutoPlay Dialog Box
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The AutoPlay dialog box lets you set up a multi-animation presentation.

Directory
Use the Directory section to move around your disk. Double-click to change directories and
drives.

The Change Directory button is provided as an alternative to double-clicking with the mouse to
change directories.

Files
Use the Files section to set up your AVI AutoPlay sequence.
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All AVI files in the current directory will be listed in the Files section.

An X to the left of the filename means that the file will be included in the AutoPlay sequence.
Click on the filename in the list to remove it from the AutoPlay sequence (the X disappears).

The number to the right of the AVI filename is the loop count for that file. It specifies how many
times to play that particular AVI file before going on to the next one in the AutoPlay queue.

Use the + and - keys to increment and decrement an AVI file's loop count.

Use the arrow buttons at the right of the AVI file list to change the order of the AVI files in the
AutoPlay queue. From top to bottom, the arrow buttons:

1) Move the selected file to the beginning of the AutoPlay queue.
2) Move the selected file one position up in the AutoPlay queue.

3) Move the selected file one position down in the AutoPlay queue.
4) Move the selected file to the bottom of the AutoPlay queue.

Select the Continuous Looping option if you wish the entire AutoPlay sequence to repeat until it
is cancelled.

The Global Select/Deselect key at bottom right sets the default for the entire AVI file list when it
is first displayed. If you usually use only one or two AVI files in your AutoPlay sequence, you
should set the default to Deselect All Files. If you usually use most of a directory's AVI files in
your AutoPlay sequence, set the default to Select All Files.
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Chapter 4: Creating Clips and

Animations

In this chapter we bring together all the information and the tools you have been given and discuss creating clips
and full-scale animations.

Creating a Morph Clip

The Morph Filter Type creates an animation in which the Start image undergoes a metamorphosis into the
End image.

1. Load Start and End images into the Project Editor.
2. Choose Morph from the Filter Type list box.

3. Click on the Edit... button or on the right arrow between the Start and End images to
access the Morph Eilter Editor.

4. Use the tools in the tool bars next to the Start and End images to place point pairs on
the images. The point pairs will control the metamorphosis which takes place in the
Morph clip.

5. Use the Preview Window to browse through the clip, and make any needed changes
with the Filter Editor.
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6. Create an output animation file from your Morph clip by clicking on Create Animation
in the Project Editor.

Tips on Positioning Maorph Point Pairs

In general, it's best to place points on features in the images when creating a morph clip.

As a simple example, imagine a morph clip in which one person's face changes into another person's
face.

= Morphf¥¥arp Editor

Zoom In (Hold Shift to zoom out) |

PosiTioNING POINTS IN THE MoRrRPH/WARP FILTER EDITOR
You would want to place point pairs on:

¢+ Edges/outline of eyes
+ Edges/outline of mouth
¢ Along the hairline
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+ Edges of nose
¢+ Edges of ears
+ Along the outside edge of the head

... and on any other specific features which you want to make sure change in a specific way over the
course of the morph.

It's less desirable to place points on relatively homgeneous areas such as cheeks or foreheads.

For more suggestions on making your morph clips look as convincing, realistic, fast, and smooth as
possible, see Chapter 5.

Creating a Distort Clip

The Distort Filter Type provides 18 different distortion effects, which can be used to distort one image, or to
create a segue from one distorted image to another. (A graphic index of the different distortion effects is
shown in Chapter 3.) NOTE: Those effects followed by an [F] are particularly computationally intensive, and
will be slow on a machine lacking a floating-point coprocessor.

Lens [F]
Pinch

Ripple [F]
Rotate

Rotate & Shear
Rotate Center
Shear
Spherize [F]
Stretch Height
Stretch Width
Swirl [F]

Tear

® 6 6 6 6 6 6 0 0 0 0 0
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Tumble [F]
Twirl [F]
Wave
ZigZag
Zoom In
Zoom Out

* 6 6 O o o

1. Load an image into the Start image window, or into both the Start and End image
windows.

2. Choose Distort from the Filter Type list box.

3. Click on the Edit... button or on the right arrow between the Start and End images to
access the Distort Filter Editor.

4. Choose the desired effect from the Distort effect list by clicking with the mouse.

5. Use the Start % to specify when the animation is to begin recording to the output file.
Use End % to specify when the animation is to end recording to the output file. If using
Start and End images, use Source, Merge, and Destination percentages to specify
how to blend the two images.

6. Use the Preview Window to browse through the clip, and make any needed changes
with the Filter Editor.

7. Create an output animation file from your Distort clip by clicking on Create Animation
in the Project Editor.

Creating a Transition Clip
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The Transition Filter Type provides effects which are commonly used to begin an animation, end an
animation, or segue from one animation section to another.

Some transition effects require only one image to be loaded, whereas others need two, a Start and an End.
One-Image Effects:

These effects need only one image to be loaded, since a black frame is used for one end of the clip. Load
the image into the Start image window.

+ Fade from Black (begins with black, fades to Start image)
¢+ Fade to Black (begins with Start image, fades to black)

Two-Image Effects:

¢ Curtain (begins with Start image, then splits the image like a curtain opening to reveal the
End image)

¢+ Fade to Image (begins with Start image, fades to End image)

Reverse Curtain (begins with Start image, then brings the split End image over it like a

curtain closing)

Slide Down (slides Start image down to reveal End image)

Slide Left (slides Start image to the left, revealing End image)

Slide Right (slides Start image to the right, revealing End image)

Slide Up (slides Start image up to reveal End image)

* & ¢ o

1. Load your image into the Start image window.
2. Choose Transition from the Filter Type list box.

3. Click on the Edit... button or on the right arrow between the Start and End images to
access the Transition FEilter Editor.

4. Choose the desired effect from the Transition list by clicking with the mouse.
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5.

Use the Preview Window to browse through the clip, and make any needed changes
with the Filter Editor.

Create an output animation file from your Transition clip by clicking on Create
Animation in the Project Editor.

Creating a Warp Clip

The Warp Filter Type creates an animation in which the Start image undergoes a metamorphosis into an
altered version of itself. Examples would be stretching a mouth or shrinking a head.

Since the Warp Filter Type begins and ends with different version of the same image, only the Start image
need be loaded. However, an End image may be loaded for use as a reference image (see below, Tips on
Positioning Warp Point Pairs).

1.
2.
3.

Load Start and/or End images for your Warp clip.
Choose Warp from the Filter Type list box.

Click on the Edit... button or on the right arrow between the Start and End images to
access the Warp Eilter Editor.

Use the tools in the tool bars next to the Start and End images to place point pairs on
the images. The point pairs will control the metamorphosis which takes place in the
Warp clip.

Use the Preview Window to browse through the clip, and make any needed changes
with the Filter Editor.

Create an output animation file from your Warp clip by clicking on Create Animation in
the Project Editor.
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Tips on Positioning Warp Point Pairs

As in creating morph clips, a good rule of thumb to follow for a warp clip is to place points on features in
the image or images.

As mentioned above, the Warp Filter Type begins and ends with different version of the same image, so
only a Start image need be loaded. However, an End image may be loaded for use as a reference
image.

A reference image can be used to reference end point locations.

As an example, imagine that you wanted to warp an image of your face into another version which has
the geometry of Arnold Schwarzenegger's face. You would load the image of your face as the Start
image, and load Arnold's face into the End image window. Then you would use the Warp Filter Editor to
place points on the features of the faces, such as:

Edges/outline of eyes
Edges/outline of mouth

Along the hairline

Edges of nose

Edges of ears

Along the outside edge of the head

* 6 ¢ & o o

... and any other specific features which you want to make sure change in a specific way over the course
of the warp.

When you create the warp animation, your original face will warp into another version which has the
same configuration as Arnold's face. Note, though, that Arnold's face (since it was loaded in the End
image window) never actually appears in the warp clip.

For suggestions on making your warp clips look as convincing, realistic, fast, and smooth as possible,
see Chapter 5.
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Creating a Multi-Clip Animation

This section discusses the construction of an animation which contains more than one clip.

The Storyboard

The Storyboard portion of the Project Editor serves as the clip manager. The Storyboard keeps track of
where each clip is positioned in the animation. Tools are provided for moving clips around, either by
using arrow buttons or by cutting, copying, and pasting.

Each clip in an animation project is displayed in a cell of the Storyboard. The cell includes a thumbnail
version of the Start and End images of the clip. If a clip uses only one image, as in a Warp or a Fade
to/from Black, only that image will be displayed.

The clip which is currently loaded into the Project Editor is outlined in red in the Storyboard. The
currently- selected clip (the clip most recently clicked on with the mouse) is outlined in blue. To reload a
previous clip back into the Project Editor, double-click on it, or click on the Edit button of the Storyboard.

Storyboard Toaols

The Storyboard tools operate on the currently-selected (blue outline) clip. To select a clip, simply click on
it with the left mouse button.

Beqgin
BEGIH

I4

The Begin button moves the selected clip to the beginning position in the Storyboard. This clip will
now begin the animation.
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Left

LEF

14

The Left button moves the selected clip one position to the left.

—

Load Clip

LOAD
'

The Load Clip button reloads the selected clip back into the Project Editor. The clip will now be
outlined in red, as the currently-loaded clip.

You may also double-click on a clip to reload it into the Project Editor.

Right
RIGHT

rr
The Right button moves the selected clip one position to the right.

End
EHD

4

The End button moves the selected clip to the ending position in the Storyboard. This clip will now
end the animation.
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Cut

CUT

=%H

The Cut button removes the selected clip from the sequence of clips on the Storyboard and puts it on
the Windows Clipboard. It may then be pasted into a different position in the current animation, or
into another animation.

The Paste button inserts a clip from the Windows Clipboard. The clip will be inserted into the
currently-selected position, and the other clips will be shifted to the right.

Generating a Multi-Clip Animation

The procedure for generating a multi-clip animation is simple. After planning, building, previewing, and
arranging the clips with the Filter Editors, the Preview Window, and the Storyboard, you need only to set
global animation parameters and create a final animation.

Animation Parameters
Click on the Animation Parameters icon to toggle the display of parameters.
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Speed

Speed is entered in frames-per-second. Since this is a global variable, the speed will apply to the
animation as a whole. In other words, you cannot set one speed for one clip and another speed
for another clip within the same animation.

Any number of frames per second may be entered in the Speed edit box. However, the
animation's actual speed will be limited by your computer's capabilities. Though increasing the
speed of the animation will make it appear smoother, you can also use a smaller frame size for
smoother animations. (See Chapter 5 for more information about optimizing the speed and
appearance of animations.)

Compression Method

Choose a compression method using the Compression drop-down list.

Video 1 is a compression method written by Microsoft. Indeo is a compression method by Intel.
These two methods have comparable compression rates. (Hardware support is available for
playback of Indeo-compressed animations through Intel's ActionMedia cards.) Cinepak is a
method written by SuperMac. It is slow to compress but produces fast playback results. You
should create and view animations using each compression method to see which is best for your
applications.

If you have any other AVI Codecs (compressor/ decompressors) installed on your computer,
PhotoMorph will load them automatically for use in compressing and decompressing your
animations. Look for them in the Compression drop-down list.

Since the compression method is a global variable, you cannot assign one compression method
to one clip and another compression method to another clip within the same animation.

Output File Type
The Output list lets you specify the output file type for your animation: AVI, FLC, or Frames.

Use the Setup button to alter parameters of the output file.
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For the AVI format, these parameters include:

+ Data Rate
Key Frame rate
¢ Quality (0- 50)

For the FLC format, these parameters include:

¢+ Dynamic Palette
+ Dither Frames

For the Frames option, these parameters include:

Name (base name for each frame in the sequence)
Directory

File Format

*
*
*
* Start Frame

Quality

Choose High, Medium, or Low quality for your final animation. This setting affects how your
animation frames are created. High quality animations will have smoother action but will take
longer to create. Lower quality animations will be created faster but the animation will be less
accurate. (See Chapter 5 for more information about optimizing the quality of your animations.)
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Chapter 5: More About PhotoMorph

This chapter includes in-depth and reference information about morphing, image conversion, and related issues.

Advanced techniques for animation creation with PhotoMorph are discussed, with attention to creating the most
convincing, realistic, fast, and smooth animations possible.

Special image conversion topics such as color reduction, display devices, device dependency, file compression,
and anti-aliasing are covered.

Getting the Most out of Morphing/Warping

This section discusses methods for creating top-notch animations with PhotoMorph. Topics include:

Point Placement
Image Characteristics
Speed

Compression

Quality Settings
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Point Placement in the Morph/ Warp Filter Editor

The importance of the placement of point pairs when creating morphs cannot be overemphasized. The
strategic placement of point pairs is what lets PhotoMorph create the illusion of something inherently
unbelievable actually happening before your eyes.
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Features/Boundaries
The most basic rule for point placement is to attend to features and boundaries in the two images.

Think about each salient feature and boundary in the Start image. Where on the End image should it
migrate over the course of the animation?

Imagine morphing a face into another face. Features you would need to bear in mind would include:

Edges/outline of eyes
Edges/outline of mouth
Edges of nose
Eyebrows

Edge of hairline

Ears

Outside edge of head
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Don't hesitate to place a lot of point pairs. In general, the more specific you are in showing
PhotoMorph what is to happen in the animation, the more convincing it will be; and the speed of
animation creation is affected negligibly by each additional pair of points.

Negative Space

Another consideration for making a morph look especially convincing is to add points to the negative
space, or background, in the images.

If the background actually has features in it, you should attend to those especially carefully. Make
sure they don't simply disappear and reappear (see Ghosting below). Ensure that the background's
transformation is smooth and convincing, so that it does not detract from the foreground.

Ghosting

A tip-off that you need to work further on point placement in a morph is an effect called ghosting.
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Ghosting is when a part of one object becomes transparent over the course of the animation. In
ghosting, an area or feature disappears slowly and then reappears in the end image, instead of
seeming to actually change into the new area or feature.

If you notice ghosting in your animation, you should add more points or position your points more
carefully in the area where the ghosting occurs. Think about exactly where that area should migrate
during the animation, and be very specific about placing points to define that migration.

Image Characteristics

Though any pair of images can be used to create a morph, some image characteristics tend to produce
better or more convincing animations.

Object Placement in the Frame
The placement of the image within the frame is an important consideration. Be sure that the object

you want to morph does not extend past the edge of the frame. If it does, you will never be able to
control how that edge transforms.

However, if you do have an object that hangs off the edge that you want to use in a morph, you
should use the Image menu to add a border to that edge of the image. Click on Image/Frame, and
specify a frame along only that edge. Try to match the frame's color to the image's background color.

Same Image Size
A simple measure you should take to ensure good-looking morphs is to make the images used in

your animations the same size.

When PhotoMorph creates an animation, it uses the largest frame size in the entire animation (all
clips included) and scales all images in the animation to that size, no matter what their original size.
This may produce unexpected effects and in some way lower the quality of the animation's
appearance.
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Though PhotoMorph does not require you to make the images the same size, in many instances
you can improve the appearance of the animation by changing the images yourself before using
them.

Use the Image menu to change the size of your images. There are various ways to change the size:

Scale the image
Add a frame of a certain width around the image to make it larger overall
¢+ Crop the image

Object and Background Colors

The more similar the colors of the related objects or areas in the Start and End images of a clip, the
more realistic-looking the change should look. If the colors are not the same shade, it helps if they
are at least similar in luminance (both light, like yellow, pink, or sky blue, or both dark, like black,
indigo, or brown).

Background color can be instrumental in making the morph look good. Similar background colors
help. If they are not similar, it is best to have a dark background color. That way, if there is any
ghosting or imprecision, it will tend to be less visible against the background.

Topology

Once again, similarity of object topology (general configuration) will help make the transformation
look real. However, if the topology of the objects differs significantly, you will need to carefully plan
how the dissimilar features will be dealt with.

Imagine morphing a frog into a chick.
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You would have to consider dissimilarities like:

Four legs vs two legs and two vestigial wings

Nose vs beak

Overall flat horizontal shape vs overall upright and round shape
Large muscular legs vs small skinny legs

* 6 ¢ o

Possible solutions include:

Place points so that the frog's front legs "atrophy" into the chick's body
Shrink the edges of the frog's nose into the edges of the beak
Carefully place a large number of points around the perimeter of the frog's flat body and
the chick’s round body to make sure the frog shape changes smoothly into the chick
shape

+ Place points around the edges of the frog's legs and make sure both sides migrate toward
the center of the leg to form the chick’s thin leg

Speed

The speed of your animation can contribute greatly to its believability. In general, an animation looks
much better if it moves along fairly swiftly. Speed can be affected in a number of different ways. Some
are more controllable than others.
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The Speed (Frames-per- second) setting

You can enter any number you wish in the Speed edit box of the Animate parameters area of the
Project Editor. However, the actual speed of the animation will be limited by the capabilities of your
hardware (see Hardware below).

Frame Size

Using a smaller frame size will speed up your animation. Remember, PhotoMorph chooses the
largest image frame size in the entire animation (all clips included) and scales the animation to that
size. Therefore, you should make sure that you don't mistakenly include a large image in the
animation, or else all your images will be scaled to that size.

AVI File Creation

PhotoMorph always creates AVI files in 24-bit color. You can use Video for Windows to create an
8-bit AVI file from a 24-bit file. The quality of the AVI animation will be affected, since colors will be
lost, but the animation file will be smaller and will run three times faster.

Hardware
Your hardware can be the single most limiting factor in determining how fast your animations can run.
Components affecting speed include:

Speed of machine (MHz)

Amount of memory (RAM)

Size of disk cache

386/486 processor

Speed of hard disk

Speed of video card

ISA, local bus, VESA, EISA

Type of AVI compression (some types support hardware decompression, such as Intel
Indeo)

* 6 6 6 6 ¢ o o
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Special hardware that can speed up animations includes:

Graphics accelerators
¢ High-speed disk drive
+ Video accelerators

Compression

Since animation files can be huge, you should always choose some type of animation file compression.

As an example, imagine you have an animation in which the frames are 320 X 200 pixels and the length
of the animation is 30 frames (a modest length for an animation). The final size of that animation would
be about 5.7 megabytes.

¢+ Use the Compression list box in the Animate parameters area of the Project Editor to choose a
compression technique for your selected output file type.

+ For AVl files, use the Quality setting in the Output File Type/ Setup dialog box of the Animate
parameters area in the Project Editor. As a guideline, a quality setting of 75 usually produces a
reasonably high-quality animation with good compression.

The higher the compression rate, the more blurry or chunky (pixellated) the frames will appear. You will
have to determine the compression rate that still preserves sufficient quality to satisfy you but produces
manageable file sizes for your system.

If you plan to merge animations at a later date (with an animation editor such as Microsoft's VidEdit), it is
best to preserve as much quality as possible.
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uality Settings

AVI Files: Output File Type Quality

The Quality setting in the Output File Type/Setup dialog box (in the Animate parameters area of the
Project Editor) affects the compression rate of AVI output files. This influences the quality of the
animation at the time of compression.

The higher the compression rate, the lower the quality of the animation. As the compression rate is
set higher, the frames will become progressively more blurry or chunky (pixellated). In general, a
Quality setting of 75 will preserve a reasonably high animation quality and will produce pretty good
compression.

Animation Quality setting
The Quality setting in the Animate parameters area affects the appearance of the animation and its
frames. This setting influences the quality of the animation frames at the time of creation.

Depending on the images used in the particular animation, choosing High Quality may change the
way your animation is created by using such techniques as anti-aliasing or a more sophisticated
image processing algorithm.

Video for Windows "Skip video frames..."
If the action in an AVI animation looks jerky, check to make sure that the Video for Windows "Skip
frames..." option is turned OFF.

¢+ Go to the Windows Main window. Select Control Panel.
Choose Drivers, and select (MCI) Microsoft Video for Windows from the list.
Click on the Setup button. Check to see if the "Skip video frames if behind" option is selected. If
it is, de-select it.
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Image and Conversion Topics

Colors and Color Reduction

This section offers discussions about several aspects of colors and color information, including color
reduction, dithering, palettes, display devices, and storing color information. This information will help
you when you are working with the image conversion facilities in PhotoMorph.

Methods of Color Reduction

Reducing the number of colors in an image can be valuable for many reasons. High-color images
require a lot of disk space, so reducing the number of colors is one way of saving space. Also, many
output devices have a rather limited number of colors available for display, and using color reduction
with dithering can vastly improve the appearance of high-color images on these types of boards.

PhotoMorph has two methods available to reduce the number of colors in an image: Flat Cut and
Optimized Cut. Note: It is important to realize that when a color reduction is performed on a
high-color image, color information is lost (discarded) at that point.

Flat Cut can be used to reduce colors to 16-bit color (32,767 colors), 256 colors, 16 colors or
monochrome. It uses a simple algorithm for color reduction, creating a uniform distribution of colors
across the visible spectrum. It then uses this set of colors and matches them as closely as possible
to the image's original colors.

Optimized Cut can be used to reduce to 256 or 16 colors. The Optimized Cut algorithm may produce
results far superior to the Flat Cut algorithm (depending on the image). Optimized Cut is a method to
determine the most important colors in the particular image you're working with. It creates a custom
palette which will optimize the appearance of that certain image.
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Dithering
Dithering is an extremely useful tool for color management. It can be used with both the Flat Cut and
Optimized Cut methods of color reduction.

In a nutshell, dithering increases the apparent number of colors in an image by reducing the
apparent resolution of the video screen. How does this work? Dithering uses patterns of
different-colored pixels which cause you to perceive a blended color. For example, an area filled with
an alternating pattern of red and blue pixels will be perceived as being purple. Therefore, the image
appears to have more colors than it actually contains. The flip side of using this technique is that the
"purple" area will appear slightly more blurry or grainy to you than if it were composed of truly purple
pixels.

Palettes
A palette is an assortment of colors that can be used to draw an image. There is an important
distinction between a device palette and an image which has a palette included in its information.

A device palette is a palette of colors that a particular device has available for use in displaying
images. If the device's palette is fixed, the colors must be chosen from the same palette for any
image displayed. If the device's palette can be set, then there is more flexibility in choosing colors.

An image may have a palette included in its information. This means that the palette of colors used
in the image is actually encoded into the image's data.

The distinction between the device palette and an image's palette may be illustrated in this example.
Suppose you have an image which is drawn in sixteen shades of blue. The image's palette, which is
included in the data, consists of these sixteen different blues. Now imagine you have a device which
has a fixed 16-color palette, which includes colors distributed over the range of the visible spectrum.
When you display the image on this system, the device can only use the shades of blue in its fixed
palette (in a standard 16-color palette, there would be two shades of blue to choose from). It will
display the image using only its palette's two blues. Obviously, the image's appearance will have
deteriorated. (However, no color information has been lost, since the information was encoded in the
image itself. It is only the display device's limitations that have affected the image's appearance.)
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Now, imagine that you display the same image using a device with a 16-color custom palette. Since
the colors in a custom palette can be set, the device can accommodate this image by setting its own
palette to the sixteen blues in the image's palette. In this case, the display device can take full
advantage of the image's palette information and can show the original colors accurately.

It should be mentioned here that Windows does not support a custom palette for 16-color devices.
However, there are non-Windows applications that do support 16-color custom palettes.

PhotoMorph can create custom palettes for images using the Optimized Cut color reduction
algorithm. Optimized Cut and the other color reduction algorithm, Flat Cut, are described in the
Methods of Color Reduction section.

How Color Configurations of Display Devices Affect Color Reduction

In this discussion, we emphasize the impact that your device's color configuration has on your choice
of color reduction methods.

Monochrome
Monochrome is otherwise known as black-and-white.

Since monochrome displays have only two colors available, there's a very limited amount of
subtlety you can achieve in displaying images. The Flat Cut color reduction algorithm is sufficient
for any reduction to monochrome.

16 Colors

If you're running Windows and have a 16-color board, the palette is fixed. However, some
non-Windows programs have custom 16-color palettes. You can take advantage of that
capability by using Optimized Cut and then transferring the color-reduced image into the other
program.
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If you want to use Windows and display an image that originally had more than 16 colors, you will
get the best possible results if you use Flat Cut and dither the image to 16 colors.

256 Colors

When you are running PhotoMorph with a 256-color video board and Windows driver, 256 colors
are available for any and all images being displayed at any one time. With the Optimized Cut
color reduction algorithm, PhotoMorph can custom-set the 256 palette colors to conform to a
particular image's original colors, so as to produce the best-looking image possible. Dithering will
also improve the image's appearance.

If you use Flat Cut color reduction, the new palette will be composed of 256 colors evenly spaced
throughout the visible spectrum. Depending on what you intend to use your image for, this may
be the option you want (though generally a custom palette will produce better-looking images).
You may also use dithering with Flat Cut to improve the image's appearance.

If you use the Optimized Cut algorithm to reduce an image's colors, it may look slightly different if
you display it under Windows than if you display it with a non-Windows application. This is
because Windows reserves 20 colors of the 256-color palette for its own use. Since these 20
fixed colors will likely not be included in the custom 256-color palette of the image, they will
"bump" some of the custom colors, and your image will look a little different.

16-Bit Color ("High Color")

If you're using a 16-bit board (sometimes known as "high color"), you have over 32,000 colors
available for display. 16-bit images do not have palettes; therefore, only the Flat Cut option is
available. PhotoMorph supports two 16-bit formats: Targa (TGA) and TIFF.

24-Bit Color ("True Color")

"True Color" 24-bit boards can display 16.7 million colors. The human eye can only distinguish
about 9 million colors, so these boards essentially have all perceivable colors available for
display. PhotoMorph supports 8 True Color formats. They are: Targa (TGA), TIFF, Video
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Toaster IFF, JPEG Compressed, PCX, Windows DIB/BMP, Color PostScript (EPS), and
Macintosh PCT.

32-Bit Color

32-bit images include an extra 8 bits of information which involves alpha channels. Alpha
channeling is a sophisticated image generating technique which essentially makes portions of an
image “clear,"” so that another image or a background can show through. When a 32-bit image is
loaded into PhotoMorph, these 8 bits are nullified; therefore, a 32-bit image in PhotoMorph
actually contains no more information than a 24-bit image. PhotoMorph supports two 32-bit
formats: Targa (TGA) and TIFF.

Device Dependency: Issues and Information

Differences among devices and media become important issues to deal with when you're working with
graphics. You need to be aware of these issues if you plan to transfer images among devices that vary in
their color support or resolution, or if you plan to print graphic images.

Clipboard Files

You may run into a problem with device dependency if you use Clipboard files (.CLP files) to transfer
images between devices. Some formats create device-dependent bitmaps (DDBs). As the name
implies, this type of bitmap includes information that is only compatible with a particular type of
device. If you are importing a .CLP file from a different type of device, you may not be able to load it
in PhotoMorph.

Color Support
One parameter that varies greatly among display devices is color support. Display devices can

support anywhere from two (monochrome) to 16.7 million (24-bit) colors. You can imagine that
transferring files between devices that support different numbers of colors can create problems. As
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one example, if a picture created with a device that supports 256 colors is viewed on a 16-color video
board, it will likely contain inaccurate colors and banding.

Differences in Resolution and Aspect Ratio

Another issue to consider is differences in resolution among devices. An image which takes up the
entire screen on a video monitor with a resolution of 70 dots per inch may be only three inches wide
when printed on a laser printer at 300 dots per inch. A related issue is differences in aspect ratio (the
ratio of pixel height to pixel width). Pixels can appear somewhat rectangular on some devices; a
square drawn on such a device may not look like a square, though the number of pixels on each side
is actually the same.

Color Creation: Light vs. Ink

When printing images, more problems may surface because of the different mechanisms for creating
colors between video monitors (using light) and printing on paper (using ink). The same image may
look very different on a video screen than when it's printed on paper. Video monitors use an additive
method of color creation, using red, green, and blue light to create all of the other colors in the visible
spectrum. Printing uses a subtractive method of color creation, with layers of cyan, magenta, yellow,
and black ink mixing to create all other colors. On an more elementary level, it's clear that if the red
of one device looks different from the red of another device, then all the different saturations (shades)
of that color will look different as well.

Image File Compression

PhotoMorph supports several different kinds of graphics file compression. In most cases, an image's
specific file format dictates which compression algorithm PhotoMorph must use when saving the file in
compressed form.

The one exception to this rule is the TIFF format. You have an option to set the default compression
algorithm that will be used when you save a TIFF file in compressed format (use the Settings dialog box
under the File menu to change the default TIFF compression algorithm). You may find this handy if you
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will be using the compressed images with another program that recognizes only certain types of
compressed files, or if your disk space is of paramount concern and you need to be sure you're using the
most efficient algorithm.

All standard PhotoMorph image compression formats are "loss-less.” This means that no information is
lost when the image is compressed, and therefore when it is decompressed, it will be exactly the same as
before. However, PhotoMorph can also save images in the special JPEG compression format. JPEG is
a "lossy" compression format. Information can be lost when an image is compressed using JPEG. The
user should review the information on JPEG Compression in the Import/Export File Formats section of
this manual before using JPEG.

The compression algorithms used by PhotoMorph can be discussed in terms of three basic types:

¢ LZW (Lempel, Ziv & Welch)
RLE/PackBits (Run-Length Encoding)
¢ JPEG **

*See Import/Export File Formats before using JPEG compression on your image files.

LZW - Lempel, Ziv & Welch

LZW encoding is a very efficient compression technique. It requires more computation time than
RLE, but generally produces better compression results.

LZW works by constructing a tree of color patterns that are used in the image. Thus, if a pattern
recurs, no matter how complex, it can be encoded in an extremely simple form. For example, if the
image has a color that's created by using a pattern of different-colored pixels (such as alternating red
and yellow pixels for an orange area), LZW would produce good compression results.

LZW may be specified for TIFF files by using the TIFF Compression group in the Settings dialog box
under the File menu.
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RLE/PackBits (Run-Length Encoding)

This type of encoding is very quick and produces good compression results when your image has a
lot of runs of same-color pixels and not much detail. For instance, say you have an image which has
a run of 100 red pixels on one of its lines. In raw form, it would take 100 memory locations to store
the information in those pixels. In RLE, the pixels would be stored as (essentially) "100 red," taking
up only two memory locations, resulting in an enormous reduction in data size.

RLE compression is used for Targa and DIB files. RLE (PackBits) compression may be specified for
TIFF files by using the TIFF Compression group in the Settings dialog box under the File menu.

Aliasing & Anti-aliasing

A pervasive problem with computer graphics files is the appearance of objects that include curves or
diagonals. The jagged appearance of such objects is caused by too-low resolution of screens or printers,
which results in step-like approximations where there are supposed to be smooth curves or diagonals.
This phenomenon is known as aliasing. Colloquially, the small step-like areas are called jaggies.

To improve the appearance of curves and diagonals, a technique has been developed which is known as
anti-aliasing. Anti-aliasing causes the apparent smoothing of curves by capitalizing on a particular
characteristic of the human perceptual system. The human eye tends to blend colors that are in close
spatial proximity, especially if the colors are also close to each other on the visible spectrum. This
causes a slight blurring of the edges between the two colors, resulting in the appearance of a smooth,
continuous blend. So, if the pixels that are near to an object's jaggies are colored a slightly different
shade of the object's color, the eye will blur the jaggies and you will perceive a much smoother curve.
The improvement can be quite striking, since the nearby pixels are not actually perceived to be a different
color when viewed by the human eye, but the curve seems magically to become much more smooth and
continuous.
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Import/Export File Formats

Following are the file formats currently supported by PhotoMorph for import and/or export.

Note: Though PhotoMorph can import images of many different color configurations, the Preview Window's
Save feature can write only 24-bit images. Therefore, if you want to save a frame created by PhotoMorph in
a reduced color format, you must either:

1. Copy the frame to an empty window from the Preview Window.

2. Use the Colors menu or File/Image/Save As... to reduce the number of colors in the image.
OR:

1. Save the image to a file from the Preview Window. Only those formats supporting 24-bit color will be
available.

2. Open the file and reduce the number of colors using the Colors menu or File/lmage/Save As...

BMP - Windows

IMPORTING:

The Windows bitmap format supports monochrome, 16 colors, 256 colors, and 24-bit color.
ExPoRTING FROM FiLE MENU:

PhotoMorph exports monochrome, 16-color, 256-color, and 24-bit Windows bitmaps. Windows BMP
files are always uncompressed.
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ExpPorTING FROM PREVIEW WINDOW:

Frames can be saved as 24-bit BMP files from the Preview Window.

CLP - Windows Clipboard files

IMPORTING:

Windows Clipboard files can contain many different types of Clipboard information. PhotoMorph
supports loading Clipboard files which contain device-dependent bitmaps or device- independent bitmaps.

PhotoMorph can only load device-dependent bitmaps that are compatible with the current device. For
example, if you created a .CLP bitmap with a 16-color VGA device, you would not be able to load this file
using a 256-color VGA device.

If you are using a 256-color device, please see the section, "Clipboard Files" under Device Dependency:
Issues and Information in this chapter for more information about using Clipboard files.

DIB - Windows

IMPORTING:

The Windows DIB (device-independent bitmap) format supports monochrome, 16 colors, 256 colors, and
24-hit color.

ExPoRrTING FROM FILE MENU:

PhotoMorph exports monochrome, 16-color, 256-color, and 24-bit color Windows DIB files. The user
can set the compression state for monochrome, 16-color and 256-color DIBs. 24-bit DIBs cannot be
compressed.
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ExpPorTING FROM PREVIEW WINDOW:

Frames can be saved as 24-bit color Windows DIB files from the Preview Window.

EPS - Encapsulated PostScript

ExPoRTING FROM FiLE MENU:
EPS is the only file format the PhotoMorph exports but does not import.

EPS is a format used by certain printing devices and desktop publishing programs. If you are printing to
a black-and-white PostScript printer, you should convert your image to grayscale before printing. If you
are printing on a color PostScript printer, you should convert your image to color before printing. You can
use the Colors menu to convert to color or to grayscale.

Five color configurations are possible when writing PostScript images: monochrome, 16-color, 256-color
(color-mapped), 256-color (grayscale), and 24-bit color.

EPS files cannot be compressed.
ExpPorTING FROM PREVIEW WINDOW:

Frames can be saved as 24-bit color EPS files from the Preview Window.

GIF - Graphics Interchange Format

IMPORTING:

The GIF format supports monochrome, 16 colors, and 256 colors. GIF files can be interlaced or
non-interlaced (Conversion Artist loads both types).
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IFF - Amiga/Video Toaster

IMPORTING:

Subformats supported are: standard IFF with color map, HAM, and 24-bit color. The 24-bit color
subformat is compatible with NewTek's Video Toaster.

JPG - JPEG Compressed Format

What is JPEG?

JPEG is a new high-compression technique for color and grayscale images. JPEG can be used to
compress images from one-third to one-thirtieth of their original size. It is especially useful for images
with a lot of color and detail. JPEG provides good compression where non-lossy compression
techniques (such as Run-Length Encoding or LZW) do not perform well.

This JPEG software is based in part on the work of the Independent JPEG Group.

Compressing a file with PhotoMorph's JPEG Option
PLEASE NOTE: JPEG is a "lossy" compression technique. If you are not familiar with JPEG

compression, you are advised to read the following sections, What is lossy compression? and
Using JPEG Compression before performing JPEG compression on any of your files.

To use JPEG compression in PhotoMorph:

1. Choose File/Image/Open. Load (open) the file you wish to save as JPEG-compressed.
2. Choose File/Image/Save As...

3. Look in the file formats list (click on the down-arrow button at right for a complete listing of file
formats) and click on the item JPG - JPEG Compression.
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4. A dialog box will appear. Use this box to set the JPEG Quality setting.

The JPEG Quality setting can be any number from 1 to 100. (In general, the higher the quality
setting (100 being highest quality), the lower the compression rate, and as the quality setting number
is lowered, the compression rate will rise. Please read the sections What is lossy compression?
and Using JPEG Compression before performing JPEG compression on your files!)

Enter JPEG Quality [0 - 100];

L] [ 1]
0 50 100

100 = Best quality, low compression
h0 = Good quality, good compression
0 = Low quality, best compression

1] .4 Cancel

THe JPEG QUALITY SETTING DIALOG BOX

What is lossy compression?

When an image is compressed with JPEG, it is changed slightly. This means that when the file is
decompressed, the image's appearance will also have changed. This is known as "lossy"
compression, since some information is lost in the course of the compression operation.

The amount of change, or image loss, depends on the JPEG Quality setting used when compressing
the file. If the JPEG quality setting is high (highest setting = 100), these changes will probably not be
noticeable to the human eye. If the quality setting is lower, these changes become more noticeable.
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With a quality setting of 50, for example, JPEG losses would be noticeable as small dots and a slight
fuzziness near edges within an image. With a lower quality setting, the losses will become very
noticeable and will appear as fuzziness and small blocks.

Using JPEG Compression

Because JPEG may change an image, you should investigate its effects before deleting the original
image. If you require high quality (very little loss but low compression rate), you should use a quality
setting of 100. Save the image in the JPEG format (see the section above, Compressing a file with
PhotoMorph's JPEG Option, for the procedure), reload it, and examine the effects of JPEG
compression. If the losses are too noticeable, you should not use JPEG for compression, but rather
save the file in the TIFF format with LZW compression. This compression technique is not lossy and
therefore will not change the image.

For typical use, a JPEG quality setting of 80 will give you a good balance between high quality and
high compression rate. Very high compression rates can be achieved by choosing a low quality
setting.

Actual compression rates will depend on the character of the image being compressed. As an
example, scanned photographs will typically compress to between one-third and one-fifteenth of their
original size with a JPEG quality setting of 100.

JPEG Performance

The JPEG algorithm requires computation and will take three to four times longer than a compression
technique like LZW. JPEG does not require a math co-processor but may run slightly faster with one.
If you are working with large images and notice a lot of activity on your hard disk, this may indicate
that you need more system RAM.

There are specialized hardware accelerators which can greatly speed up JPEG. The PhotoMorph
JPEG option does not require any such specialized hardware but will read and write JPEG images
which are compatible with most of these accelerators.
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Problems you may encounter when using JPEG

Out of memor
Large, high-color images require lots of memory. To decompress a JPEG image, you must have

enough memory to hold the original image. The upper limit for the file size that PhotoMorph can
handle is 16 megabytes.

Out of disk space

If you run out of disk space while saving a JPEG image, you must use DOS or the File Manager
to delete files or otherwise create space for your JPEG image.

Cannot read a JPEG image
PhotoMorph JPEG uses the industry standard JFIF JPEG file format. Although this format is

widely used, not all software products have made the change to this standard. If PhotoMorph
fails to read a JPEG image which was created by another product, you should make a copy of
the image on a floppy disk, include information on how to contact the product's manufacturer, and
send the floppy disk to:

North Coast Software, Inc.
Technical Support

P.O. Box 459

Barrington, NH 03825

Images can only be accepted on floppy disks.

Macintosh QuickTime JPEG

JPEG images created on a Macintosh contain a 128-byte header. This header cannot be read by
this version of PhotoMorph.
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PCC - PC Paintbrush Clipboard files

IMPORTING:

For information on PC Paintbrush files, see file format PCX below.

PCT - Macintosh Color Bitmap

IMPORTING:

PhotoMorph supports loading of PICT 2 raster files in monochrome, 16 colors, 256 colors, and 24-bit
color.

PCX - ZSoft PC Paintbrush

IMPORTING:

PCX supports monochrome, 16 colors, 256 colors with implicit gray palette, 256 colors with palette, and
24-hit color.

ExPoRrTING FROM FILE MENU:

PhotoMorph exports monochrome, 16 colors, 256 color, and 24-bit color PCX files. PCX files are
always compressed.

ExpPorTING FROM PREVIEW WINDOW:

Frames can be saved as 24-bit color PCX files from the Preview Window.
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RLE - Compressed Windows Bitmap

IMPORTING:
The Windows RLE format supports monochrome, 16 colors, and 256 colors.
ExPoRTING FROM FiLE MENU:

PhotoMorph exports monochrome, 16-color, and 256-color RLE files. Windows bitmap files with the
RLE extension are always compressed.

ExpPorTING FROM PREVIEW WINDOW:

Frames can be saved as 24-bit color RLE files from the Preview Window.

TGA - Targa

IMPORTING:
TGA supports 256 colors with implicit gray palette, 256 colors with palette, 16-bit, 24-bit, and 32-bit color.
ExPoRTING FROM FiLE MENU:

PhotoMorph exports 256-color, 16-bit, 24-bit, and 32-bit TGA files. The user can set the compression
state for Targa files.

ExpPorTING FROM PREVIEW WINDOW:

Frames can be saved as 24-bit color TGA files from the Preview Window.
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TIF - Tagged Image File Format

IMPORTING:

The TIFF format is a very complex format with many different components. You may find that some
applications will not accept TIFF images created from other sources. This is because many applications
will read or write only a few TIFF subformats.

PhotoMorph can read a large majority of TIFF files. It follows the TIFF 5.0 specifications but is
compatible with most earlier versions as well. PhotoMorph is equipped to deal with certain common
deviations from TIFF 5.0 specifications in an effort to load as many TIFF images as possible.

TIFF supports monochrome, 16 colors, 256 colors, 16-bit, 24-bit, and 32-bit color. PhotoMorph supports
TIFF files with palettes or no palettes; Motorola or Intel-style TIFFs; planar and non-planar color
configurations; multiple samples per pixel; and multiple bits per sample.

ExPORTING FROM THE FILE MENU:

PhotoMorph writes TIFFs according to the TIFF 5.0 standard. Monochrome, 16-color, 256-color, 16-bit,
24-bit, and 32-bit color are all exported.

The user can set the compression state for TIFF files. In fact, the user can set a different compression
algorithm for each color configuration under TIFF by using the "TIFF Compression” group in the Settings
dialog box under the File menu. Compression for 32-bit TIFFs will be set to be the same compression
format as that of 24-bit TIFFs.

Several different file compression algorithms are supported: LZW and RLE (PackBits) for all color types;
Group 3 (CCITT Fax 3) and Group 4 (CCITT Fax 4) are also available for monochrome.

ExpPorTING FROM PREVIEW WINDOW:

Frames can be saved as 24-bit color TIFF files from the Preview Window.
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Troubleshooting

Cannot load image file

This message occurs when PhotoMorph tries to load an animation project's Start and End images. It
indicates that there is a problem with the image file specified in the title bar of the message box.

Possibilities to investigate:

The file was renamed or moved to a defferent location on the disk.
The file was deleted from the disk.
¢+ The project (.PMP) file was somehow corrupted.

Project file was damaged, cannot load

This message appears if the .PMP file you try to load was corrputed. This is caused by a disk error.

Old PhotoMorph project

You will receive a message if your project was created by an earlier version of PhotoMorph and is
incompatible with the present version.
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Need to load additional images

You will receive a message if:

* You load only one image for a Morph project or a Transition project that requires two images
* You have not loaded an image for a Warp or a Transition project

Clip #is incomplete, cannot be rendered

This message indicates that one of the images associated with the named clip cannot be loaded or located.

Insufficient Memory

This message occurs when your computer does not have enough memory free for PhotoMorph to load or
display an image or project.

This can also occur when PhotoMorph is creating new animations or images (AVI files, screen captures,
etc.)

Possible solutions:

Close images not being used at present
Increase virtual memory

Smaller images

Buy more memory

* 6 ¢ o
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If your animation looks jerky...

If you are running an AVI animation, be sure that the "Skip video frames..." option in your Video for Windows
Setup is turned OFF.

Go to the Windows Main window. Select Control Panel.

Choose Drivers, and select (MCI) Microsoft Video for Windows from the list.

Click on the Setup button. Check to see if the "Skip video frames if behind" option is selected. If itis,
de-select it.
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animation parameters, 110, 150

animation projects, 21, 100, 101, 107, 148, 154, 159

animation quality, 115, 142, 147, 152, 154, 155, 156, 157, 158, 159, 160, 161
anti-aliasing, 169

aspect ratio, 65, 74, 167

AVI AutoPlay, 136

AVl files, 112, 135, 151, 159

AVI Player, 98, 135
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Blur filter, 88
brightness, adjusting, 85

C

captioning images, 67, 80

Capture menu, 54

capturing windows, 54, 55, 56, 57, 58

clips, 43, 100, 141, 144, 146, 154

color reduction, 41, 47, 59, 60, 61, 162, 163, 164
Colors menu, 59

compression, animations, 111, 115, 151, 160, 161
compression, images, 167, 173
context-sensitive help, 48

contrast, adjusting, 85

converting imagefiles, 162, 163

copying aclip, 150

copying an image, 53
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creating amovie, 19, 21, 101, 148, 154
cropping images, 65, 70

cutting aclip, 150

cutting an image, 52

D

deleting an image, 53

Despecklefilter, 88

distort clips, 99, 100, 102, 108, 120

Distort Filter Editor, 99, 116, 118, 119, 120
distortion effects, 117

dithering, 47, 50, 59, 163

E

Edit menu, 52
editing aclip, 149
Emboss filter, 88
export formats, 170

F

file compression, 41, 47, 49, 160, 167, 173
File menu, 37

file operations, settings for, 47

file saving, setting options, 47

Filter Editor, 116, 128

Filter menu, 87

filter type, 108

flat cut color reduction, 59, 162, 165
FLCfiles, 112, 113

flip image, 63, 70

Frames output, 112, 114
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framing images, 67, 80
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G
ghosting, 155

H

help, 48, 92
Help menu, 92
hue, adjusting, 86

Image menu, 62
import formats, 170
installation, 16
invert image, 63, 70

L

loading afile, 38
loading a project, 44

M

masking images, 69, 83

Maximum filter, 89

Median filter, 88

Minimum filter, 90

mirror image, 63, 70

morph clips, 99, 100, 126, 141, 142
Morph Filter Editor, 126, 128

movies, creating, 19, 21, 101, 141, 148, 154
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N

Noisefilter, 89

O

online help, 92
optimized cut color reduction, 59, 162, 165
Output File Type, 112

P

pasting aclip, 150

pasting an image, 53

placing pointsin Filter Editor, 154, 155
points, placing, 154, 155

posterize effect using Median filter, 83
Preview Window, 98, 131

Printer Setup, 46

printing, 45

Project Editor, 98, 107

projects (PMP files), 43, 148

Q

quality, animation, 142, 147, 152, 155, 156, 157, 158, 160, 161
quality, animations, 115

R

Requirements, 15
requirements, 15
rotating images, 67, 78
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S

saturation, adjusting, 86

saving a project, 45

saving an image, 40, 41, 47, 51
scaling images, 65, 72

screen captures, 54, 55, 56, 57, 58
Sharpen filter, 87

Sharpen Linesfilter, 87

speed, 111, 151, 158, 159

status bars, 48

storyboard, 108, 110, 148

T

tiling images, 68, 83

Tools menu, 97, 98

Trace Edges filter, 89
transition clips, 99, 100, 144
Transition Filter Editor, 125
troubleshooting, 180

U

undoing an operation (images), 50, 52

W

warp clips, 100, 126, 146
Warp Filter Editor, 126, 128, 146
Window menu, 91



