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Switching from Lotus 1-2-3
Microsoft Excel Help provides information on how to perform Lotus 1-2-3 tasks in Microsoft 
Excel.    When you select a Lotus topic from the list below, you will get information about the
Microsoft Excel equivalent or an index with more specific topics.
Access System Menu
Alternate Navigation Keys
Commands
File Formats
Frequently Used Lotus 1-2-3 Commands
Functions
Help for Lotus 1-2-3 Users
Keyboard
Macro Interpreter for Lotus 1-2-3 Users
Macro Translation Assistant



Switching from Multiplan
Microsoft Excel Help provides information on how to perform Multiplan tasks in Microsoft 
Excel.    When you select one of the Multiplan topics from the list below, you will get 
information about the Microsoft Excel equivalent of that topic.
Commands
Files
Keyboard
Macro Translation Assistant



Worksheets
For more information, see About Worksheets.
Creating a Worksheet

Creating a new worksheet
Entering a formula
Entering text or numbers into a cell 
Selecting a cell, row, column, or worksheet
Selecting a range of cells
Selecting nonadjacent cells 

Editing a Worksheet
Adding a text box or an arrow to a worksheet 
Canceling a command
Changing the decimal separator
Checking spelling
Choosing a command
Clearing data from cells
Closing panes in a window
Combining copied formulas or values with those in the paste area 
Combining values on different worksheets
Consolidating data
Converting a formula or a portion of a formula to its displayed value
Copying cells to multiple locations
Copying data and formats to all sheets in a group
Copying data and saving it in a separate file
Copying data
Copying to a range of adjacent cells
Copying visible cells
Copying within the formula bar
Creating a report
Creating a view of a worksheet
Creating or deleting a button on a worksheet or macro sheet
Deleting a graphic object
Deleting cells, rows, or columns
Editing a group of worksheets in a workbook
Editing a report
Editing cell contents
Editing worksheets as a group
Entering and editing an array formula 
Extending a series of numbers or dates
Finding cells referred to by formulas in selected cells (precedents) 
Finding cells with formulas that refer to selected cells (dependents) 
Finding characters
Inserting cells, rows, or columns
Making corrections while typing



Moving cells and data
Pasting functions
Pasting names 
Protecting worksheet cells
Redefining a style
Redefining the Normal style
Renaming a document
Renaming a stand-alone or a dependent worksheet
Replacing characters
Replacing references in formulas with names
Scrolling to and selecting specified cells or a named range
Selecting a graphic object
Selecting all graphic objects
Selecting multiple graphic objects and removing graphic objects from a multiple selection
Sorting a range of cells
Switching to a different pane within a window
Transposing ranges from columns to rows or from rows to columns
Turning AutoFill on or off
Turning drag and drop on or off

Formatting a Worksheet
Adding borders
Adding shading to cells
Adjusting row height
Aligning text and numbers within cells
Aligning text box or button text
Applying a style
Centering text over columns
Changing screen colors
Changing the layout of a printed page
Changing the thickness of window borders
Changing the width of columns
Changing worksheet dimensions on the screen
Copying styles from another document
Creating international currency formats
Creating or deleting a custom number format
Creating or deleting a style
Customizing colors in the color palette
Formatting a table using AutoFormat
Formatting cells
Freezing and unfreezing panes
Freezing and unfreezing worksheet titles
Grouping or ungrouping graphic objects
Hiding a column
Hiding a row



Justifying text right and left within a cell
Justifying text to fill a selected range
Moving and sizing a graphic object along with cells
Moving or sizing an arrow
Preventing display of zero values
Setting a format for the entire worksheet
Setting or removing a manual page break
Setting the default font for worksheets
Splitting a window into panes
Zooming in or out on your worksheet

Organizing and Documenting a Worksheet
Assigning an outline level to a row or column
Clearing an outline from a worksheet
Collapsing an outline level
Copying a text or sound note to another cell
Creating a sound note
Creating an outline from an existing worksheet
Creating names
Creating or editing a note
Defining a name
Deleting a note
Displaying an outline level
Displaying or hiding cell note indicators
Displaying or hiding outline symbols
Expanding an outline level
Playing a sound note           
Viewing text notes

Analyzing and Calculating a Worksheet
Filling in a one-input data table
Filling in a two-input data table
Setting calculation options for open documents
Solving equations using goal seeking



Databases
For more detailed information on databases, see About Databases.
Creating a Database

Defining a criteria range
Defining a database (input) range
Defining an extract range

Editing and Formatting a Database
Canceling the database, criteria, or extract range
Creating a trend series
Deleting records from a database
Editing records using a data form 
Extracting data from a database
Finding records in a database
Finding records using a data form
Setting up a criteria range with comparison criteria

Sorting a Database
Sorting a range of cells
Sorting with more than three keys



Charts
For more detailed information on charts, see About Charts.

Creating a Chart
Creating a chart
Creating a new chart series
Creating or clearing a picture chart
Protecting a chart

Editing a Chart
Adding data and formats to a chart from a worksheet or another chart
Adding or deleting an overlay chart
Adding or deleting unattached chart text
Adding or editing series
Adjusting a data value by dragging a data marker
Canceling a command
Choosing a command
Clearing a data marker picture
Copying a chart to a worksheet or another application
Copying a chart's series or formats
Deleting a chart document or an embedded chart
Deleting a data series
Disabling updating of all links to other applications on a worksheet
Editing chart text
Linking chart text to a worksheet cell
Saving a chart
Selecting items in a chart
Setting the preferred chart type

Formatting a Chart
Adding or deleting a chart arrow
Adding or deleting a chart title, an axis title, or a data marker label
Adding or deleting a legend
Adding or deleting gridlines 
Adjusting the 3-D chart view
Changing the chart type and format
Changing whether a picture marker is stacked or stretched
Displaying or hiding chart axes
Drawing a line, oval, arc, or rectangle
Formatting a chart arrow
Formatting a chart embedded in a worksheet
Formatting a legend
Formatting an axis scale
Formatting axis patterns and tick mark and label location
Formatting chart text alignment and orientation
Formatting data markers in a chart



Formatting gridlines
Formatting text box borders and fill patterns
Formatting the chart text font
Formatting the data marker layout
Formatting the plot area, 3-D walls, or 3-D floor
Formatting tick-mark label orientation
Moving a legend
Moving or sizing an arrow
Replacing a data marker with a picture



Macros and Customizing
Macros
For more detailed information on macros, see Macros.

Assigning a macro to a graphic object
Creating a new macro sheet
Defining a macro name
Editing add-in macro settings
Opening an add-in macro as a regular macro sheet
Recording a macro
Running a macro
Saving a macro sheet as an add-in macro
Stepping through a macro

Buttons 
For more detailed information on buttons, see Buttons.

Creating or deleting a button on a worksheet or macro sheet
Templates    
For more detailed information on templates, see Templates.

Creating a new template
Editing a template
Saving a document as a template
Using a template



Importing and Exporting
For more detailed information on importing and exporting, see About Importing and 
Exporting.

Combining values on different worksheets
Consolidating data
Copying to another worksheet or application
Exporting documents
Importing documents
Opening a text file in Microsoft Excel worksheet format
Parsing data from another application



Linking and Embedding
For more detailed information on linking and embedding, see About Linking and Embedding.

Controlling remote requests
Creating links
Editing a Microsoft Excel object embedded in another document
Editing an object embedded in a Microsoft Excel document
Embedding information in a Microsoft Excel document
Recalculating linked worksheets
Redirecting links for source documents you rename or move
Replacing a source worksheet with another worksheet
Saving an embedded Microsoft Excel object as a separate document
Updating linked information
Viewing a list of source documents for a dependent worksheet
Viewing the source data for a link



Printing
Canceling print titles
Changing headers and footers
Changing the layout of a printed page
Previewing a document before printing
Printing a report
Printing a chart
Printing a document without previewing
Printing a section of a worksheet
Printing text notes
Resetting the print area
Selecting a printer
Setting or removing a manual page break
Setting print titles for rows and columns
Setting up a printer



Managing Files
Adding or removing open documents from a group
Changing the default directory for opening files
Changing the drive
Closing the active document
Copying color palettes between documents
Copying data and formats to all sheets in a group
Creating an additional window for the active document
Deleting a file from a disk
Editing a group of worksheets in a workbook
Editing worksheets as a group
Opening a file from a disk
Opening source documents for the active worksheet
Opening the Clipboard
Protecting a document with a password
Protecting windows
Quitting Microsoft Excel
Renaming a document
Replacing a source worksheet with another worksheet  
Saving a document for the first time
Saving a file for use by another application
Saving new unnamed linked documents
Sizing document and application windows
Starting or ending a group editing session
Switching to or closing a document window
Viewing a list of files in a directory
Using workbooks



Commands
This index lists the command menus available on the menu bar.    Choose a menu to view a 
list of the specific commands on each menu.

Chart Menu Commands
Control Menu Commands
Data Menu Commands
Edit Menu Commands
File Menu Commands
Format Menu Commands
Formula Menu Commands
Gallery Menu Commands
Help Menu Commands
Info Menu Commands
Macro Menu Commands
Options Menu Commands
Window Menu Commands



Keyboard Guide
In some keyboard topics, you will see F11 and F12 keys.    For keyboards with only 10 function
keys, use:

ALT+F1 for F11
ALT+F2 for F12

Command Keys
Dialog Box Keys
Formula Bar Keys
Function Keys
Keys for Selecting Chart Items
Keys for Switching Windows
Menu Keys
Outlining Keys
Worksheet Keys



Parts of the Microsoft Excel Screen
Buttons
Chart
Clipboard
Control-Menu Box
Drawn Objects
Embedded Charts
Formula Bar
Grouped Objects
Info Window
Macro Sheet
Maximize Button
Minimize Button
Outlining Symbols
Pictures
Print Preview Window
Restore Button
Scroll Bars
Split Bar
Status Bar
Text Boxes
Title Bar
Window Sizing Border
Worksheet



Tools
Microsoft Excel provides tools that allow you to do your work quickly and more easily.    The 
tools are grouped in categories that correspond to tasks you can perform in Microsoft Excel, 
such as charting and formatting.    
There are 10 categories of tools: 

Charting Tools Category
Drawing Tools Category
Edit Tools Category
File Tools Category
Formatting Tools Category
Macro Tools Category
Formula Tools Category
Text Formatting Tools Category
Custom Tools Category
Utility Tools Category

Microsoft Excel also has certain related tools grouped on toolbars for your convenience.    
You can change any toolbar or create new toolbars by adding, deleting, and rearranging 
tools.    Additional tools are available in the Toolbars dialog box.    
There are nine toolbars:

Chart Toolbar
Drawing Toolbar
Formatting Toolbar
Macro Paused Toolbar
Macro Recording Toolbar
Macro Toolbar
Microsoft    Excel 3.0 Toolbar
Standard Toolbar
Utility Toolbar

See Also
Help
Using Tools
About Tools
About Toolbars



Using Workbooks
For more detailed information on workbooks, see Workbooks.

Creating a workbook
Adding or removing a document from a workbook
Copying a document from one workbook to another
Editing a group of worksheets in a workbook
Binding or unbinding workbook documents
Giving a bound workbook document an extended name
Opening a new window of a document in a workbook
Reordering documents in a workbook
Moving between workbook documents
Saving a workbook



Using Tools
Adding and deleting a tool from a toolbar
Assigning or recording a macro to a tool
Changing the action that a tool performs
Changing the shape of a floating toolbar
Creating a custom tool
Creating a new toolbar
Customizing the appearance of a tool
Deleting a custom toolbar
Displaying and hiding a toolbar
Grouping and ungrouping tools
Moving a toolbar
Moving and copying tools
Resetting a built-in toolbar



Microsoft Excel Product Support
When You Have a Question
Types of Product Support
Answers to Common Questions
Microsoft Product Support Phone Numbers in the United States
Microsoft Product Support Services Worldwide



Add-in Functions
Contains five functions in addition to those built into Microsoft Excel.    Use the Add-Ins 
command on the Options menu to install the add-in functions.
Open the ADDINFNS.XLA file after choosing the Add button.
BASE(number,target_base,precision)

Converts a number from base-10 to another base.
Number is a base-10 number.
Target_base is an integer between 2 and 36 representing the base to convert the 
number into.    If target_base is omitted, BASE will return a base-16 number.
Precision is a positive integer that specifies the number of digits you want after the 
decimal place in the returned base representation.

DEGREES(angle_in_radians)
Converts radians into degrees.
Angle_in_radians is an angle in radians.

FASTMATCH(lookup_value,lookup_array,type_of_match)
Returns the relative position of an element in an array that matches the specified 
value.    The elements in the array must be sorted in ascending or descending order.    
Similar to the built-in function MATCH.
Lookup_value is the value you're searching for in lookup_array.
Lookup_array is an array or a contiguous range of cells containing possible lookup 
values.
Type_of_match is either 1 or -1.    Specifies how FASTMATCH matches lookup_value 
with values in lookup_array.
For more information, see MATCH in the Microsoft Excel Function Reference.

RADIANS(angle_in_degrees)
Converts degrees into radians.
Angle_in_degrees is an angle in degrees.

RANDBETWEEN(bottom,top)
Returns a random integer within a given range.
Bottom is the smallest integer RANDBETWEEN returns.
Top is the largest integer RANDBETWEEN returns.



Alternate Startup Directory
Allows you to specify an alternate startup directory for Microsoft Excel.    Documents you 
place in the alternate startup directory open automatically when you start Microsoft Excel.
To specify an alternate startup directory

1 In the LIBRARY directory, open the ALTSTART.XLA add-in macro.
2 Type the full path of the alternate startup directory you want to use.

For example, if the directory you want to specify as the alternate startup directory is on
your C drive and is called ACCOUNTING, type c:\accounting
The next time you start Microsoft Excel, all the files in the startup directory will open 
automatically.    The names of templates in the startup directory will appear when you 
choose New from the File menu.



Auto Save Macro
Automatically saves your documents at a specified interval to prevent data loss.    Use the 
Add-Ins command on the Options menu to install the Auto Save macro.    
Open the AUTOSAVE.XLA file after choosing the Add button.
The following options are available:
High

Saves your documents every three minutes.
Medium

Saves your documents every nine minutes.
Low

Saves your documents every 30 minutes.
Never

Turns off automatic saving.
Prompt Before Saving

Displays a message asking if you want to save before Auto Save saves a file.
Save All Files

Saves all open documents each time Auto Save saves your files.    If cleared, saves only 
the active document.

To save your work automatically
1 From the Options menu, choose AutoSave.
2 Select an option for saving your files.

If you select High, Medium, or Low, a check mark is displayed next to the AutoSave 
command on the Options menu.

3 If you want Auto Save to notify you before saving a document, select the Prompt Before
Saving check box.

4 If you want Auto Save to save all open Microsoft Excel documents at each automatic 
save, select the Save All Files check box.

5 Choose the OK button.



Macro Debugger
Creates an environment within Microsoft Excel in which you can easily debug and run 
macros.    Use the Add-Ins command on the Options menu to install the Macro Debugger.
Open the DEBUG.XLA file after choosing the Add button.
You can set tracepoints and breakpoints at key cells of the macro you're debugging.

The debugger pauses the macro at tracepoints and enters single-step mode.    You 
can trace the macro, continue running it, or stop it.

The debugger pauses the macro at all breakpoints and displays the values of a group 
of cells and names you specify in advance.    You can continue running the macro, enter 
single-step mode, or stop the macro.

Collectively, tracepoints and breakpoints are known as debug points.
Document protection must be off before you enter the debugging environment.

To enter the debugging environment
1 Switch to the macro sheet you want to debug.
2 From the Macro menu, choose Debug.

The debug menu bar is displayed.
Setting a debug point at a cell on your macro sheet temporarily changes the formula in
that cell, but does not change the value when you calculate the formula.    When you 
leave the debugging environment, all debug points are removed and your formulas are 
restored.

In the debugging environment, you can't change the formula in a cell containing a debug 
point.    Before you run a macro in the debugging session, you should set debug points.
To set a tracepoint in the debugging environment

1 Select the cell where you want to set a tracepoint.
2 From the Debug menu, choose Set Trace Point.

To set a breakpoint in the debugging environment
1 Select the cell before which you want to set a breakpoint.
2 From the Debug menu, choose Set Breakpoint.
3 If you want, you can type a message in the Alert String box to be displayed whenever 

the breakpoint is found.
4 Choose the OK button.

To remove debug points
1 Select a cell or range of cells containing tracepoints or breakpoints.
2 From the Debug menu, choose Erase Debug Point.

To specify variables to be displayed at breakpoints
When you set breakpoints in your macro, you need to specify the cells and names you want 
the Macro Debugger to display at each breakpoint.

1 From the Debug menu, choose Breakpoint Output.
2 To add a variable, type the reference or name, or switch to the sheet and click the cell.
3 Choose the Add button.
4 Choose the OK button.

To remove a variable, select the variable from the list and then choose the Delete 
button.
After you set the debug points and specify the variables to be displayed at the 
breakpoints, you are ready to run the macro.



To run a macro
1 From the Debug menu, choose Run Macro.
2 In the Run box, select the name of the macro from the list

--or--
In the Reference box, type the name or reference of the macro.

3 Choose the OK button.
The macro runs normally, except that it carries out special commands at debug points. 
These commands do not affect the result of the macro.
When a breakpoint is found, the breakpoint dialog box appears.    Choose the Continue 
button to continue running the macro, the Step button to enter single-step mode, or 
the Halt button to stop the macro.
When a tracepoint is found, the macro switches to single-step mode.

To exit the debugging environment
From the Debug menu, choose Exit Debug.

The macro restores the previous menu bar and removes all debug points.
Other Macro Debugger Commands

Hidden Names command (Formula menu) displays the definitions of any hidden names on
the active document.
Select Debug Points command (Formula menu) selects all the cells on your macro 
sheet with breakpoints or tracepoints.
Select Errors command (Formula menu) selects cells (within the active selection) 
that have formulas that result in errors.
Formulas/Values command (Display menu) switches between displaying formulas 
and displaying values on the macro sheet.
Arrange All command (Display menu) displays all open, displayed windows on your 
screen at once.    Windows are arranged and sized to show as much of each as possible.
Show Info command (Display menu) is the same as the Show Info check box in the 
Workspace dialog box that you open from the Options menu.



Document Summary Macro
Records information about a worksheet, such as the title, author, and creation date, and 
stores it with the worksheet.    Using this macro, you can easily record and view any changes
made to the worksheet.
Use the Add-Ins command on the Options menu to install the Document Summary macro.
Open the SUMMARY.XLA file after choosing the Add button.
To record and view summary information

1 From the Edit menu, choose Summary Info.
A dialog box is displayed containing current summary information about the active 
worksheet.

2 Make the changes you want to the summary information.
You cannot change the date the document was created.

3 Choose the OK button.
The summary information is saved automatically with the worksheet.

See Also
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



Flat File Macro
Imports or exports data between "flat" text files -- files in which data is separated by 
spaces, not tabs -- and cell ranges on a worksheet.    The flat file macro creates a text file 
that contains the data in the selected cells. 
Use the Add-Ins command on the Options menu to install the flat file macro.
Open the FLATFILE.XLA file after choosing the Add button.
The flat file macro has two commands:
Export Command (Data Menu)

Exports a group of selected cells to a text file.
Smart Parse Command (Data Menu)

Distributes text values that are in a single column so that they fill several columns.    
Treats each row independently, placing each logical word into its own cell.

To export cells to a text file
1 Select the range of cells containing the data you want to export.
2 From the Data menu, choose Export.
3 In the Name box, type the name of the text file you are creating.
4 If you want the exported text file to reflect the alignment and number formats of the 

selected cells, select the Retain Cell Formats check box.
If you want the exported text file to reflect General alignment and number formats, 
clear the Retain Cell Formats check box.

5 Choose the Export button.
To parse text values

1 Select the cells you want to parse.
The selection must be only one column wide, but it can be as many rows high as you 
want.

2 From the Data menu, choose Smart Parse.
For the selected cells that contain text, the macro places each group of characters 
separated by one or more spaces into a separate cell.

3 Select the option button for the column delimiter you want.
4 To include extra blank spaces, clear the Remove Extra Blank Spaces check box.
5 Choose the OK button.



File Functions
Contains six additional macro functions to create and delete directories, get information 
about directories, and display the standard Open and Save dialog boxes.
Use the Add-Ins command on the Options menu to install the file functions.
Open the FILEFNS.XLA file after choosing the Add button.
CREATE.DIRECTORY(path_text)

Creates a directory.
Path_text is the name of the directory you want to create.    If path_text is a full path 
statement, CREATE.DIRECTORY creates a directory at the specified path location.    
Otherwise, a new subdirectory named path_text is created in the current directory.

DELETE.DIRECTORY(path_text)
Deletes an empty directory.    If the specified directory is not empty, DELETE.DIRECTORY 
returns FALSE.
Path_text is the name of the subdirectory in the current directory or the path of the 
directory you want to delete.

DIRECTORIES(path_text)
Returns a horizontal array of all the subdirectories in the current directory or specified 
path.
Path_text is the directory from which you want to return a list of subdirectories.    If 
path_text is omitted, DIRECTORIES returns a list of the subdirectories inside the current 
directory.

FILE.EXISTS(path_text)
Tests for the existence of a file or directory.    Returns TRUE if the file or directory exists; 
returns FALSE otherwise.
Path_text is the name of the file or directory you want to find.    If the file or directory is 
not in the current directory, you must enter the full path.

OPEN.DIALOG(file_filter,button_text,title,filter_index)
Displays a dialog box for opening files.    This is the same dialog box that appears when 
you choose Open from the File menu.    Returns the name of the file that is chosen by the 
user.
File_filter is a string that determines what type of files will be displayed in the dialog 
box.    List the filters you want to display as a string, separated by commas.    All files will 
be displayed if file_filter is omitted.
Button_text does not function in Microsoft Excel for Windows.    The button always 
displays OK.
Title displays a name in the title bar of the dialog box.    If the argument is omitted, the 
title bar displays Open.
Filter_index is a number corresponding to a file_filter.    The corresponding file_filter 
will initially appear in the File Name box.

SAVE.DIALOG(init_filename,title,button_text,file_filter,filter_index)
Displays a dialog box for saving files.    This is the same dialog box that appears when you
choose Save from the File menu.    Returns the filename entered by the user.
Init_filename is the proposed name that appears in the File Name box.
Button_text does not function in Microsoft Excel for Windows.    The button always 
displays OK.
Title displays a name in the title bar of the dialog box.    If the argument is omitted, the 
title bar displays File Save As.



File_filter is a string that determines what type of files will be displayed in the dialog 
box.    List the filters you want to display as a string, separated by commas.    All files will 
be displayed if file_filter is omitted.
Filter_index is a number corresponding to a file_filter.    The corresponding file_filter 
will initially appear in the File Name box.



Glossary Macro
Saves commonly used formulas and cell contents as glossary entries that you can paste 
onto worksheets or macro sheets.    The glossary entries are stored in the glossary for 
further use until you delete them.
Use the Add-Ins command on the Options menu to install the Glossary macro.
Open the GLOSSARY.XLA file after choosing the Add button.
To add a glossary entry

1 Select the cell or cells whose contents you want to include in the glossary entry.
2 From the Edit menu, choose Glossary.
3 In the Name box, type a name for the new entry.
4 Choose the Define button.

The macro creates a new glossary entry with the specified name.
5 Repeat steps 1 through 4 to add any more entries.

To paste a glossary entry onto a worksheet or macro sheet
1 Select the cell or cells in which you want to insert the glossary entry.

If your selection is not the same size as the glossary entry, the active cell is the upper-
left corner of the area in which the glossary entry is inserted.

2 From the Edit menu, choose Glossary.
3 Select the glossary entry you want to paste onto the worksheet or macro sheet.
4 Choose the Insert button.

To delete a glossary entry
1 From the Edit menu, choose Glossary.
2 Select the glossary entry you want to delete.
3 Choose the Delete button.
4 Choose the OK button to confirm the deletion.
5 Repeat steps 2 through 4 for each glossary entry you want to delete.
6 Choose the Cancel button to save your changes and close the dialog box.



Name Changer Macro
Deletes a name of a cell on a worksheet or macro sheet, or changes the name and then 
searches the document and replaces each occurrence of the old name with the new one.

Changes the name in the Go To and Define dialog boxes, not the text in cells on the 
worksheet. 
Use the Add-Ins command on the Options menu to install the Name Changer macro.
Open the CHANGER.XLA file after choosing the Add button.
To delete a name

1 From the Formula menu, choose Change Name.
2 In the From box, select the name you want to delete.
3 Choose the Delete button.

If the name you have selected is referred to on the worksheet, Name Changer asks you
to confirm the deletion.    Choose the OK button.

4 Repeat steps 2 and 3 for every name you want to delete.
5 When you have finished deleting names, choose the Close button to save your changes

and close the dialog box.
To change a name

1 From the Formula menu, choose Change Name.
2 In the From box, select the name you want to change.
3 In the To box, type the new name.
4 Choose the Rename button.

Name Changer automatically changes every occurrence of the old name to the new 
one.

5 Repeat steps 2 through 4 for every name you want to change.
6 Choose the Close button to save your changes and close the dialog box.



What If Macro
Cycles a worksheet model through several scenarios by supplying a succession of input 
values to one or more input cells.    For example, in a model that depends on three input 
cells, each of which can have one of four values, or independent variables, the What If 
macro allows you to quickly cycle through the 64 possible scenarios.
Use the Add-Ins command on the Options menu to install the What If macro.
Open the WHATIF.XLA file after choosing the Add button.
To use the What If macro, you must specify a data sheet to be used with the model 
worksheet.    The data sheet stores the sets of values to be entered into each input cell.    
You can either specify a new data sheet or an existing one.
To specify a new data sheet

1 Switch to the model worksheet.
2 From the Formula menu, choose What If.
3 Choose the New button.
4 Type the name or reference of the first independent variable, and then choose the OK 

button.
5 Type an input value and choose the OK button.
6 Repeat step 5 for each possible value for the first variable.
7 Choose the Done button.
8 Repeat steps 4 through 7 for each additional independent variable.
9 Choose the Done button.

To specify an existing data sheet
1 Open the existing data sheet.
2 Switch to the model worksheet.
3 From the Formula menu, choose What If.
4 Select the data sheet from the list.
5 Choose the OK button.

To calculate all possible input values at once
1 Switch to the model worksheet.
2 Press CTRL+SHIFT+T.

The What If macro cycles the worksheet through all the possible scenarios.
The cycling of variables is similar to that of a counter.    When a new input value has 
been calculated, the next input value will be supplied to the first variable until all input 
values for the first variable have been calculated.    Then the first variable will go back 
to its first value and the second variable will get its next value, and the process will 
begin for the second variable.

To advance one variable at a time
1 Switch to the model worksheet.
2 Select the input cell to be calculated.
3 Press CTRL+T.

The What If macro calculates the next input value for the selected variable in the input 
cell and recalculates the worksheet.



Worksheet Auditor Macro
Provides four tools to help you check the structure and analyze the layout and formulas of 
your worksheets.    Use the Add-Ins command on the Options menu to install the Worksheet 
Auditor macro.
Open the AUDIT.XLA file after choosing the Add button.
Audit 

Generates a report of potential errors on your worksheet.
Errors includes cells with error values.
References To Blanks includes formulas that refer to blank cells.
References To Text includes formulas that refer to cells containing text.
Circular References includes all cells that are part of circular references.
Names includes questionable or potentially unused worksheet names.

Map
Creates a map of your worksheet to help you see its contents.

Interactive Trace
Displays the cell dependencies on your worksheet to help you understand the data flow.
Find Dependents jumps to the dependents of the active cell.
Find Precedents jumps to the precedents of the active cell.
Reset Active Cell changes the active cell.
Retrace Move Backward and Retrace Move Forward retrace your steps.
Go To Sibling Previous moves to other dependents of those found by the most recent 
Find Dependent.
Go To Sibling Next moves to other precedents of those found by the most recent Find 
Precedents.
Exit Trace quits Interactive Trace.

Worksheet Info
Displays detailed information about your worksheet.

To generate an audit report
1 From the Formula menu, choose Worksheet Auditor.
2 Select Generate Audit Report.
3 Choose the OK button.
4 In the Audit Report dialog box, clear the check boxes for the types of auditing you don't

want included in the report:
Errors includes cells with error values.
References To Blanks includes formulas that refer to blank cells.
References To Text includes formulas that refer to cells containing text.
Circular Reference includes all cells that are part of circular references.
Names includes questionable or potentially unused worksheet names.

5 Choose the OK button.
To map a worksheet

1 From the Formula menu, choose Worksheet Auditor.
2 Select Map Worksheet.
3 Choose the OK button.

Worksheet Auditor creates a map of the cells on your worksheet.



To trace cell dependencies
1 From the Formula menu, choose Worksheet Auditor.
2 Select Interactive Trace.
3 Choose the OK button.

Worksheet Auditor displays your worksheet on the right side of your screen and the 
Info Window and the Interactive Trace control panel on the left side.

4 In the Interactive Trace control panel, choose the command buttons for the cell 
dependencies you want to trace:
To select all the dependents or precedents of the active cell, choose the Find 
Dependents button or the Find Precedents button.
To change the active cell, choose the Reset Active Cell button.
To retrace the steps you've already made, choose the Retrace Move Back button or the 
Retrace Move Forward button.
To move to other dependents of those found by the most recent Find Dependents, 
choose the Go To Sibling Previous button.    To move to other precedents of those found 
by the most recent Find Precedents, choose the Go To Sibling Next button.
To quit the interactive trace, choose the Exit Trace button.

To get information about a worksheet
1 From the Formula menu, choose Worksheet Auditor.
2 Select Worksheet Info.
3 Choose the OK button.

The Worksheet Auditor macro displays a report containing information about your 
worksheet.



Worksheet Comparison Macro
Compares the active worksheet to another worksheet and generates a report listing the 
differences.    Use this macro when you have two different versions of a worksheet and you 
want to find out what has changed in the newer one.
Use the Add-Ins command on the Options menu to install the add-in functions.
Open the COMPARE.XLA file after choosing the Add button.
To compare two worksheets

1 Open the two worksheets you want to compare.
2 Switch to one of the worksheets.
3 From the Formula menu, choose Compare.
4 In the Compare To Sheet box, select the name of the second worksheet.
5 Choose the OK button.

Worksheet Comparison performs the comparison and generates a report listing the 
differences.



Macro Library Overview
The macro library is a collection of Microsoft Excel macros you can use to assist you in a 
number of common spreadsheet tasks.    These files are located in the LIBRARY directory, a 
subdirectory of the directory in which you installed Microsoft Excel.    In addition, more add-
in macros are installed in subdirectories of the LIBRARY directory.

You must select the Macro Library option during Setup to install the macro library on 
your hard disk.    The Checkup, Custom Color Palettes, and Slide Show files are located in 
subdirectories of the LIBRARY directory.    Use the Add-Ins command on the Options menu to 
make add-in macros automatically available whenever you start Microsoft Excel.

The Checkup, Crosstabs, View Manager, Report Manager, Scenario Manager, Add-in 
Manager, and Slide Show add-in macros are automatically installed when you choose the 
Microsoft Excel option during Setup.    You must choose the Analysis ToolPak option during 
Setup if you want to use these statistical, financial, and engineering functions and tools.    
You must choose the Solver option during Setup if you want to use Solver for calculating 
what-if scenarios with several variables.    The Crosstabs, Solver, and Analysis ToolPak files 
are located in subdirectories of the LIBRARY directory.
Files in the LIBRARY directory
ADDINFNS.XLA Add-in Functions    Adds five worksheet functions: BASE, DEGREES, 

FASTMATCH, RADIANS, and RANDBETWEEN.
*ADDINMGR.XLA Add-In Manager    Controls the Add-ins command on the Options menu.
ALTSTART.XLA Alternate Startup Directory    Lets you designate or change the alternate 

startup directory.
AUDIT.XLA Worksheet Auditor    Generates reports that help you track down errors or

other problems in your worksheets.
AUTOSAVE.XLA Auto Save    Saves documents automatically as you work.
CHANGER.XLA Name Changer    Changes or deletes names.
COMPARE.XLA Worksheet Comparison    Generates a report that shows the cells that 

differ between two worksheets.
DEBUG.XLA Macro Debugger    Tracks down bugs in your macros.
FILEFNS.XLA File Functions    Adds six macro functions: CREATE.DIRECTORY, 

DELETE.DIRECTORY, FILE.EXISTS, DIRECTORIES, OPEN.DIALOG, and 
SAVE.DIALOG.

FLATFILE.XLA Flat File    Parses imported text files with variable-length fields and 
exports data from a worksheet to a space-delimited text file.

GLOSSARY.XLA Glossary    Saves frequently used formulas or data for pasting into a 
worksheet or macro sheet.

*REPORTS.XLA Report Manager    Prints reports that consist of a view and a scenario.
*SCENARIO.XLA Scenario Manager    Tests "what-if" scenarios by using a set of values in 

the input cells you select.
SUMMARY.XLA Document Summary    Stores the author, title, comments, and creation 

date with a worksheet or macro sheet.
SWITCH.XLA Switch    Adds toolbar tools that you can click to switch to another 

application, such as Microsoft Word.
*VIEWS.XLA View Manager    Saves the current window display as a view and lets you 

apply your saved views to see your worksheet data in different formats.
WHATIF.XLA What-If    Cycles a worksheet model through different scenarios.



*These add-in macros open automatically, if installed.
LIBRARY subdirectories
ANALYSIS Analysis ToolPak    Adds financial and engineering functions as well as 

providing tools for performing statistical and engineering analysis 
procedures.

CHECKUP Checkup    Displays technical information about Microsoft Excel and the 
environment in which it is running.    This information may be needed 
when requesting assistance from Microsoft Product Support.

COLOR Custom Color Palettes    Changes the color palette for the active 
document or chart.

*CROSSTAB Crosstabs    Starts the Crosstab ReportWizard so that you can aggregate 
and compare related data in a database.

*SLIDES Slide Show    Works with the Slide Show template document to create a 
slide show from Microsoft Excel worksheets and charts.

*SOLVER Solver    Calculates solutions to what-if scenarios based on adjustable 
cells, constraint cells and, optionally, cells that must be maximized or 
minimized.    

* These add-in macros open automatically, if installed.
See Also

Help
Add-Ins Command (Options Menu)
Add-In Functions
Add-In Macros
Alternate Startup Directory
Analysis ToolPak
Auto Save Macro
Checkup
Crosstab
Custom Color Palettes
Document Summary Macro
File Functions
Flat File Macro
Glossary Macro
Macro Debugger
Name Changer Macro
Q+E
Report Manager
Scenario Manager
Slide Show
Switch
Using Solver
View Manager
What If Macro
Worksheet Auditor Macro
Worksheet Comparison Macro



User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



To assign a macro to an application switching tool
To use one of the application switching tools, you must assign a macro to it. This procedure 
assigns a macro to the tool and allows you to switch from Microsoft Excel to one of the 
following applications:

Microsoft Word
Microsoft Project
Microsoft PowerPoint

If the application is open, running this macro is like choosing the Switch To command from 
the Application Control menu and then selecting the application.
To do this procedure, the LIBRARY directory must be installed.

1 From the File menu, choose Open.    In the LIBRARY directory, open the SWITCH.XLA 
add-in macro.

2 To use the tool, it must be on a toolbar.    In the list box, select the toolbar where you 
want to place the tool.
The tool will be added as the first tool on the toolbar.    You can reposition it after you 
have added the tools you want.

3 Choose the Add button to add the current tool and move to the next tool.
4 Choose the Skip button to move to the next tool without adding the current tool.
5 When you have finished choosing the toolbar for each tool you want to add, choose the

OK button.
When you choose the OK button, SWITCH.XLA will save the toolbars in the toolbar file 
and place a macro called SWITCHTO.XLA in the XLSTART directory.
If you delete an application switching tool from a toolbar, you will need to repeat this 
process again to make the tool work.

See Also
Help

Microsoft PowerPoint Tool
Microsoft Project Tool
Microsoft Word Tool

Adding and deleting a tool from a toolbar
Adding or removing an add-in macro
Displaying and hiding a toolbar
Macro Library Overview
Moving and copying tools
Switch To Command (Control Menu)
Toolbars
Tools

User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



Custom Palettes Command (Chart or Options Menu)
Allows you to change the color palette on the active document or chart to the one you 
select from the Palettes box.
Palettes

Displays a list of the available custom color palettes.
Apply

Applies the selected custom palette to your document or chart.    Choose OK to save this 
palette.



Checkup
Displays configuration information about Microsoft Excel and your operating environment.

To display checkup information, open CHECKUP.XLM in the CHECKUP subdirectory of 
the LIBRARY directory.

Checkup information can be helpful when requesting assistance from Microsoft 
Product Support.    

To print Checkup information, choose the Print button in the Checkup dialog box.



Crosstab Command (Data Menu)
Opens the Crosstab ReportWizard to assist you in creating, recalculating, or modifying a 
cross tabulation table.    A cross tabulation table is a report that groups data from a 
database into categories and tallies, analyzes, or compares the data in ways you specify.    
The Crosstab ReportWizard steps you through the process of selecting the fields from your 
database to include in the crosstab table and the method or methods of aggregating that 
data in the cells.

The Crosstab ReportWizard does not modify your original database.    It creates a 
separate cross tabulation table based on data in the database.

If this command does not appear on the Data menu, you need to install the Crosstab 
ReportWizard add-in macro.    For more information, see the Help topic on the Add-ins 
command, or see Chapter 4, "Customizing Microsoft Excel," in Book 2 of the Microsoft Excel 
User's Guide.

Instructions for using the Crosstab ReportWizard appear on the screen.
This button Does this

Displays more information about the current step in the left side of the dialog 
box.    Choosing Explain again returns the left side of the dialog box to its previous contents.

Closes the Crosstab ReportWizard without creating a cross tabulation table.

Goes back to the beginning of the Crosstab ReportWizard.
Goes back to the previous step.
Goes on to the next step.

Goes to the end of the Crosstab ReportWizard using the selections you have made so 
far.
See Also

Help
CROSSTAB
User's Guide (Book 1)
Chapter 10, "Analyzing and Reporting Database Information"
Function Reference
CROSSTAB
CROSSTAB.RECALC
CROSSTAB.CREATE
CROSSTAB.CREATE?
CROSSTAB.DRILLDOWN



Activate QE Command (Data Menu)
Switches from Microsoft Excel to the Q+E application.    If Q+E is not open, Microsoft Excel 
opens the application and then switches to it.

This command is available on the Data menu only when the QE.XLA data access add-
in macro sheet is open.



Delete Command (Data Menu)
Deletes all records that meet the criteria you have defined with the Set Criteria command 
on the Data menu.

When the QE.XLA data access add-in macro sheet is open, this command deletes 
records in external databases as well as those in the current selection in a Microsoft Excel 
database.

Asks for verification.
Other records in the database are shifted to fill in space.
Can't be undone. 
Make sure you don't include any blank rows in the criteria range.    If you do, every 

record in the database will be deleted.



Extract Command (Data Menu)
Finds database records that match the criteria defined in the criteria range and copies them
into the extract range in your worksheet.

When the QE.XLA data-access add-in macro sheet is open, this command can extract 
data from external databases as well as from Microsoft Excel worksheet databases.

Before using this command to extract data from an external database, use the Set 
Database command on the Data menu to connect to an external database source; use the 
Set Criteria command on the Data menu to specify what to extract; and use the Set Extract 
command on the Data menu to define the extract range in your worksheet.

The extract range must be a range defined in your Microsoft Excel spreadsheet.    It 
can be either a range containing only field names or a range containing both field names 
and references to cells that will contain the extracted data.

You can enter the field names and select them before choosing Extract on the Data 
menu, or you can define the extract range using Set Extract on the Data menu.    Then you 
can use the name Extract as a named reference with the Formula Goto command or with 
database functions.    

If you are extracting records from an external database, use Paste Fieldnames on the 
Data menu to transfer the field names from the external database to your Microsoft Excel 
worksheet, so that you can define the Criteria and Extract ranges.

If the extract range contains only field names, the extracted records are copied into 
cells below them.    All cells below the field names are cleared even if no extracted 
information is copied into them.

If the extract range contains both field names and references to cells below them, all 
cells in the range are cleared and as many extracted records as will fit are copied into the 
cells.

The Extract command on the Data menu cannot be undone.
When you choose this command and are connected to an external database, a dialog box
is displayed to indicate how many records were retrieved as a result of the extract and to 
enable you to specify how to paste the records into your worksheet.

Paste
Pastes the records from the external database according to other options you choose in 
the dialog box.

Paste Options
Provides the option for a linked or unlinked extract.    

If you choose the Linked option, the records you paste in your worksheet are 
dynamically linked, via DDE, with the records in the external database.    

If you choose the Unlinked option, the records are merely pasted into your worksheet 
as text.
Save As

Displays a dialog box where you can specify a filename under which to save the records 
extracted from the external database.    The records are saved as a text file.



Find Command (Data Menu)
This command is not available from Microsoft Excel when you are using an external 
database.    Choose Activate Q+E and use the Find command on the Search menu in Q+E for
Microsoft Excel.



Form Command (Data Menu)
This command is not available from Microsoft Excel when you are using an external 
database.    Choose Activate Q+E and use the Form command on the Edit menu in Q+E for 
Microsoft Excel.



Paste Fieldnames (Data Menu)
Copies field names from an internal or external database into a Microsoft Excel worksheet.    
Use these field names to set up your criteria and extract ranges when extracting data from 
a database.

This command is available on the Data menu only when the QE.XLA add-in macro 
sheet is open.

If the database is a Microsoft Excel worksheet, the field names are copied from the 
first row of the database.

If the database is an external database, Microsoft Excel queries Q+E for the field 
names.

If you are connected to more than one database, Microsoft Excel uses the name of 
the database file containing the field and an extension which is the name of the field as the 
field name.

You can paste all the field names in the order they appear in the database, or choose 
which field names to paste and rearrange them prior to pasting using the Order Fields option
button.
Fields

Displays the field names from the internal or external database.    Select the ones you 
want from the list, or choose Paste All to paste all the fields in the order they appear.

Paste
Transfers the currently selected field names into your Microsoft Excel worksheet.

Close
Closes the dialog box without pasting field names.

Paste All
Pastes all the field names from the database into your worksheet in the order given in the
Fields box.

Order Fields
Displays additional options that allow you to select what field names to paste and what 
sequence to place them in:
Available Fields

Displays all the field names in the database.    Select a field name, then choose the Add
button.    Each field name is then added to the Selected Fields box.    Select the field 
names in the order in which you want them to appear in your worksheet.

Selected Fields
Displays the field names you have selected from the Available Fields box.

Add
Adds the field names currently selected in the Available Fields box to the list in the 
Selected Fields box.

Remove 
Removes the selected field name from the Selected Fields box.

Clear All
Removes all field names from the Selected Fields box.



Set Criteria (Data Menu)
Defines the selected range of cells as the criteria range--the range of cells that contain the 
criteria used to find, extract, or delete matching database records.

When the QE.XLA add-in macro sheet is open, this command sets the criteria for 
searching both external database files and Microsoft Excel databases.

You can specify two types of criteria:    comparison or computed.
Use comparison criteria when you want to find records whose data matches or falls 

within certain limits of specified criteria.
Use computed criteria if you want to test the database against the result of a formula

that refers to one or more fields in one or more records.
Use SQL-like commands when using computed criteria to query an external database.

You cannot use Microsoft Excel computed criteria as they are specific to Microsoft Excel and 
cannot be translated into SQL-equivalent functions.

The criteria range can be any area on the worksheet outside your database range, or 
it can be on another worksheet.    You must set the criteria range before using the Extract, 
Delete, or Data Find commands on the Data menu.

This command assigns the name Criteria to the selection.
The first row of the criteria range must contain one or more field names    from the 

database; one or more rows below that must contain the criteria.
If the criteria range includes a blank row, all database records are matched.
Once you define a criteria range, you can change the criteria as often as you like.    
A worksheet can have only one criteria range defined at a time.

See Also
Q+E for Microsoft Excel User's Guide
Chapter 10, "Using Dynamic Data Exchange to Communicate with Q+E"
User's Guide (Book 1)
Chapter 10, "Analyzing and Reporting Database Information"



Set Database (Data Menu)
Sets the current worksheet selection as a database, or connects you to one or more 
external databases; selects one or more external database files from which to extract data; 
switches back and forth between an internal Microsoft Excel database range and the current
external database file or files.    

This command is a special version of the Set Database command on the Data menu.   
This command is available only when the QE.XLA add-in macro sheet is open.

When no external database is currently selected, this command displays a dialog box 
where you can set a database in your Microsoft Excel worksheet, or set an external 
database.
Current Selection

Assigns the name Database to the current selection in the Microsoft Excel worksheet.
External Database

Displays a dialog box where you specify the external database file to use.    
File name

The name of the external database file to open.
Source

Lists the database systems for which drivers have been installed.
Sources

Leads to another dialog box where you can select sources for logging in and logging 
off.    Selecting an available source and clicking Logon leads to the Logon dialog box for 
that particular source.    Selecting a source in the Current Connection's box and 
choosing Logoff closes the connection for that source.

File List
Lists available files in the current directory.    (Depending on the source, this box may 
have a different name).

Directory List
Changes current drive or directory.    (Depending on the source, this box may have a 
different name.)

Options
The options available depend on the type of file selected under Source.    For more 
information, see the appendix in the Q+E for Microsoft Excel User's Guide that covers 
the type of source you are connecting to.

If you choose Set Database from the Data Menu when an external database is already 
active, a dialog box is displayed, allowing you to change or add external database 
sources.

Current Selection
Assigns the name Database to the current selection in the Microsoft Excel worksheet.

External Database
Specifies that subsequent Data menu commands will work on the currently defined 
external database file.    The current source and files are displayed in the dialog box.

Change
Changes the current database selection.    Displays the Set External Database dialog box 
described above.

Add



Allows you to connect to additional databases on the same source by displaying a dialog 
box similar to the Set External Database dialog box described above.    You cannot change
sources or log on to or log off from a source in the Add dialog box:    Use the Change 
option to change sources.
Note    If you are extracting information from more than one database, you should specify
a join to set up a relationship between the database files.    For example, if you want to 
search for records in both EMP.DBF and DEPT.DBF, you could set up a join based on the 
department ID fields that the database files have in common.    To do this, you would 
enter

EMP.DEPT_ID = DEPT.DEPT_ID
anywhere within the criteria range in your spreadsheet before choosing Set Database 
from the Data menu.
For more information about joins, see Chapter 2, "Sorting and Selecting Records," in the 
Q+E for Microsoft Excel User's Guide.



Set Extract (Data Menu)
Defines the selected range of cells as an extract range for extracting records from a 
database.

The extract range must be outside your database and can be either a range 
containing only field names or a range containing field names and references to the cells 
that will contain the extracted data.

Microsoft Excel names the range Extract.    You can use the name as you would any 
other named reference.

If the extract range contains only the field names, all cells below the field names to 
the bottom of the worksheet are cleared when you extract data, whether or not information 
is extracted into them.    You cannot reverse the Extract command on the Data menu with 
the Undo command on the Edit menu.

You do not have to define an extract range to extract database records; you can 
simply select the extract range before choosing Extract on the Data menu.    However, if you 
define the extract range using Set Extract on the Data menu, you can use the name Extract 
as a named reference with the Goto command on the Formula Menu or database functions.



SQL Query (Data Menu)
Extracts external database records that result from an QL SELECT statement you enter or a 
Q+E query file that you specify.    Retrieves the results of the query into the current 
worksheet.

This command is available on Microsoft Excel's Data menu only when the QE.XLA 
add-in macro sheet is open.

This command works only for querying an external database; it does not work on 
Microsoft Excel internal database ranges.

If you want to send the query to a database other than the current default source in 
Q+E, be sure to preface the database name with the source name in the FROM clause.

For example:    SELECT FIRST_NAME, LAST_NAME FROM Microsoft ExcelFile|C:\qe\
emp.xls
If you send an SQL Query statement that includes an extract command and there are 

matching records in the database, then another dialog box is displayed which indicates the 
number of records received and gives you the option to make the extract linked or unlinked.
SQL Query

Type your SQL Query statement here.
Run

Executes the SQL Query statement you have entered.
Save

Saves the current SQL Query statement as a text file with extension .QEF.
Open

Opens an existing text file that contains an SQL Query statement.
New

Clears the SQL Query box.    If your current query has not been saved, displays a dialog 
box prompting you to save it before it is cleared.

Close
Closes the dialog box without executing the query.



Scenario Manager Command (Formula Menu)
Creates and saves different sets of data as separate scenarios.    You can use these 
scenarios to view multiple outcomes based on different assumptions.    You can also create a
separate summary report that shows the changing cell values and the resulting cell values 
for each scenario.

If the Scenario Manager command does not appear on the Formula menu, run the 
Setup program to install it.

You can use any cell with data as a changing cell for a scenario, but if you name the 
changing cells using the Define Name or Create Names command on the Formula menu, the 
names will appear in the Add Scenario dialog box next to the data contained in the cell.

You can include the scenario in a report, and then print the scenario as part of the 
report, using the Print Report command on the File menu.
Scenarios

Lists any existing scenarios.
Changing Cells

Select the cells containing the data that will change in each scenario, or type the cell 
references.    If you include nonadjacent cells, select them by holding down CTRL and 
then clicking each cell, or separate the cell references with a comma.
If you later specify different cells as your changing cells, existing scenarios will be 
changed to reflect the data in the new cells.    If you specify all new changing cells, 
existing scenarios are deleted.    Before scenarios are changed or deleted, Microsoft 
Excel displays a message asking you to confirm the change or deletion.

Show
Displays on the worksheet the changing cell values for the scenario selected in the 
Scenarios box.    The worksheet is recalculated to reflect the new values.

Add
Displays the Add Scenario dialog box, where you can specify the values for each 
changing cell.    The current values on your worksheet are suggested.

Name
Type a name for the scenario.

OK
Adds the scenario to the list in the Scenarios box in the Scenario Manager dialog box,
and closes the Add Scenario dialog box.

Add
Adds the scenario to the list in the Scenarios box in the Scenario Manager dialog box,
leaving the Add Scenario dialog box open.

Delete
Deletes the scenario you have selected in the Scenarios box.

Edit
Displays the Edit Scenario dialog box, which lists the scenario's changing cell values 
next to each cell reference or name.    Type new values to change the scenario.

Name
Use the original name if you want to change the numbers for a scenario, or a new 
name if you want to create a different scenario.

OK
Accepts the changes and closes the Edit Scenario dialog box.



Add
Accepts the changes, leaving the Edit Scenario dialog box open.

Summary
Creates a summary table of your scenarios on a separate worksheet.

Changing Cells
Lists the cells that will change for each scenario.

Result Cells
If you want to include cells containing formulas that depend on the changing cells, 
you can select those cells or type the cell references or names.    The table will then 
include the results of the formulas for each scenario.

See Also
Help
Adding a scenario to the Scenario list
Create Names Command (Formula Menu)
Define Name Command (Formula Menu)
Deleting a scenario
Displaying data from a scenario on the active worksheet
Editing a scenario
Generating a summary report of your scenarios
Print Report Command (File Menu)
View Command (Window Menu)
User's Guide (Book 1)
Chapter 1, "Getting Started With Microsoft Excel"
User's Guide (Book 2)
Chapter 2, "Performing What-if Analysis on a Worksheet Model"



To add a scenario to the Scenario list
1 From the Formula menu, choose Scenario Manager.

If the Scenario Manager command does not appear on the Formula menu, run the 
Setup program to install it.

2 If you have not already specified the cells you want to change, or if you want to specify
new cells, select the cells or type the cell references in the Changing Cells box.

3 Choose the Add button.
4 In the Name box, type the name of your scenario.
5 Edit the values for each changing cell.

The current values on the sheet are suggested.
If you have more than nine changing cells, only the values of the first nine can be 
edited in the Add Scenario dialog box.    The current sheet values are used for the 
others.

6 If you want to add the scenario to the list, and then create additional scenarios, choose 
the Add button.
If you want to add the scenario to the list and return to the Scenario Manager dialog 
box, choose the OK button.
If you want to return to the Scenario Manager dialog box without adding the current 
scenario, choose the Close button.

See Also
Help
Deleting a scenario
Displaying data from a scenario on the active worksheet
Editing a scenario
Scenario Manager Command (Formula Menu)
User's Guide (Book 1)
Chapter 1, "Getting Started With Microsoft Excel"
User's Guide (Book 2)
Chapter 2, "Performing What-if Analysis on a Worksheet Model"



To edit a scenario
1 From the Formula menu, choose Scenario Manager.
2 In the Scenarios box, select the scenario you want to edit.
3 Choose the Edit button.
4 In the Name box, type a name for the new scenario.

If you use the scenario's original name, the new changing cell values will replace those 
in the original scenario.

5 Edit the values for each changing cell.
6 If you want to add the edited scenario to the list, and then create additional scenarios, 

choose the Add button.
If you want to add the edited scenario to the list and return to the Scenario Manager 
dialog box, choose the OK button.
If you want to return to the Scenario Manager dialog box without adding the current 
scenario, choose the Close button.

See Also
Help
Adding a scenario to the Scenario list
Deleting a scenario
Displaying data from a scenario on the active worksheet
Generating a summary report of your scenarios
Scenario Manager Command (Formula Menu)
User's Guide (Book 2)
Chapter 2, "Performing What-if Analysis on a Worksheet Model"



To delete a scenario
1 From the Formula menu, choose Scenario Manager.
2 In the Scenarios box, select the scenario that you want to delete.
3 Choose the Delete button.
4 To delete additional scenarios, repeat steps 2 and 3.
5 Choose the Close button.

See Also
Help
Adding a scenario to the Scenario list
Editing a scenario
Scenario Manager Command (Formula Menu)
User's Guide (Book 2)
Chapter 2, "Performing What-if Analysis on a Worksheet Model"



To display data from a scenario on the active worksheet
1 From the Formula menu, choose Scenario Manager.
2 In the Scenarios box, select the scenario that you want to show.
3 Choose the Show button.

The changing cell values for the scenario that you selected will appear in the changing 
cells on the worksheet.    The worksheet is recalculated to reflect the new values.

4 Repeat steps 2 and 3 to display other scenarios.
5 Choose the Close button.

See Also
Help
Adding a scenario to the Scenario list
Deleting a scenario
Editing a scenario
Generating a summary report of your scenarios
Scenario Manager Command (Formula Menu)
User's Guide (Book 2)
Chapter 2, "Performing What-if Analysis on a Worksheet Model"



To generate a summary report of your scenarios
1 From the Formula menu, choose Scenario Manager.
2 Choose the Summary button.
3 In the Results Cells box, specify the cells that contain the significant results of each 

scenario by selecting the cells or typing the cell references.    These cells should have 
formulas that refer to changing cells.
If you include nonadjacent cells, select them by holding down CTRL and then clicking 
each cell, or separate the cell references with a comma.
You do not have to include result cells in your summary report.

4 Choose the OK button.
Microsoft Excel creates a summary table of your scenarios on a separate worksheet.

See Also
Help
Adding a scenario to the Scenario list
Deleting a scenario
Displaying data from a scenario on the active worksheet
Editing a scenario
Scenario Manager Command (Formula Menu)
User's Guide (Book 2)
Chapter 2, "Performing What-if Analysis on a Worksheet Model"



Slide Show
Opens a slide show template with which you can create a slide show. You can include a 
variety of graphics in a slide show and apply video and audio transition effects between 
slides.

To create and display slide shows, you must have installed the Slide Show add-in. If it 
is not installed, run Setup again to install the Slide Show add-in.

Slide shows can only be displayed on your computer screen. They cannot be printed.
Graphics that you've created in Microsoft Excel, such as worksheet objects and 

charts, should not be saved on the slide show template. Save them on another worksheet.
Paste Slide

Pastes the current contents of the Clipboard onto the slide show template as a slide and 
then displays the Edit Slide dialog box.

Edit Slide
Allows you to change the display settings of the current slide.

Start Show
Allows you to choose to repeat a slide show and to specify the slide at which the show 
should begin.

Set Defaults
Allows you to change the default settings that are used each time you create a new slide.

Cut Row
Cuts the current row or rows and places them on the Clipboard.

Copy Row
Copies the current row or rows onto the Clipboard.

Paste Row
Pastes the row or rows from the Clipboard into a blank row or rows created above the 
currently selected row.

Delete Row
Deletes the currently selected row or rows.

See Also
Help
Creating a slide
Editing a slide
Moving and copying a slide
Deleting a slide
Running or interrupting a slide show



Edit Slide Dialog Box
Allows you to change the display settings of the current slide. When you choose the Set 
Defaults button on the Slide Show template, the Edit Slide dialog box allows you to change 
the defaults for all subsequent slides you paste into the template.
Effect

Allows you to choose the effect you want applied to the transition between the previous 
slide and the current slide.

Speed
Allows you to choose the speed of the transition effect.

Advance
Allows you to specify a method for advancing between slides. Choose Manual to advance 
slides by clicking the mouse button or pressing the SPACEBAR.    Choose Timed and specify an
interval in seconds to advance slides automatically.

Sound
If you are using Microsoft Windows with MultiMedia Extensions, Microsoft Windows 3.1 or 
later, you can import and record sounds to be played during the transition between 
slides. 



Start Show Dialog Box
Allows you to choose to repeat a slide show and to specify the slide at which the slide 
show should begin.



Slide Show Options Dialog Box 
Allows you to stop the current slide show, continue running the slide show, or go to a 
specific slide.



To create a slide
1 Select the range of worksheet cells that contain the data you want in the slide.

If you want to use a graphic on a worksheet in a slide, select the cells underneath the 
graphic.
If you want to use a graphic from another application, select the object you want to 
use, choose Copy from the Edit menu, and then switch to Microsoft Excel.

2 From the Edit menu or the shortcut menu, choose Copy.
3 Open or switch to the slide show template.
4 Choose the Paste Slide button.

A picture of the range of cells you've selected is pasted into column A as a slide, and 
the Edit Slide dialog box is displayed.

5 Select the options you want.
6 Choose the OK button.

See Also
Help
SlideShow



To edit a slide
1 On the slide show template, select any cell in the row or rows containing the slide or 

slides you want to edit.
2 Choose the Edit Slide button.

The Edit Slide dialog box is displayed.
3 Select the options you want.
4 Choose the OK button.

See Also
Help
SlideShow



To move or copy a slide
1 On the slide show template, select any cell in the row or rows containing the slide or 

slides you want to copy or move.
2 Choose the Cut Row button or the Copy Row button.
3 Select a cell in the row below which you want to insert the slide or slides.
4 Choose the Paste Row button.

The row or rows are pasted to the new location.
See Also

Help
SlideShow



To delete a slide
1 On the slide show template, select any cell in the row or rows containing the slide or 

slides you want to delete.
2 Choose the Delete Row button.

The slide is deleted.
See Also

Help
SlideShow



To run or interrupt a slide show
To run a slide show

1 On the slide show template, choose the Start Show button.
The Start Show dialog box is displayed.

2 Select the Repeat option button and the slide you want to start with.
3 Choose the OK button.

To interrupt a slide show
Press ESC.

The slide show is paused and the Slide Show Options dialog box is displayed. You can 
choose to stop the slide show, continue running the slide show, or go to a specific slide.

See Also
Help
SlideShow



This is not a valid slide show document.    Switch to a slide show 
document and try again.
You tried to use a command or run a macro that requires a slide show document to be 
active, when a slide show document was not active.    Switch to the slide show that you want
to operate on and try the command again.



Out of memory or system resources.    Quit Microsoft Excel and any 
unnecessary applications, and try again.
Microsoft Excel was unable to perform a command because there was not enough available 
memory.    Try closing other documents or quitting applications that you are not using, or 
quitting and restarting Microsoft Excel.



The slide show sheet is full.
The active slide show document is full.    If you want to add more slides, delete some 
existing slides or create a new slide show sheet.



The contents of the Clipboard cannot be pasted as a slide.
The data that you have copied to the Clipboard cannot be used as a slide in Microsoft Excel. 
Note that Microsoft Excel graphic objects cannot be used directly as slides.    Try selecting 
the cells underneath the object, copying those cells, and then pasting them as a slide.



Cannot locate the slide show add-in code.    Run Setup again and 
install the Library option.
Microsoft Excel cannot locate a file which is required to run the slide show add-in.    To fix 
this problem, run Setup again and specify the Library option only.



This slide contains an invalid parameter.
The slide show you are working with contains an invalid parameter.    Choose the Edit Slide 
button to select new properties.



Cannot paste a slide because the Clipboard is empty.    Select the 
data you want as a slide, copy it, and then choose the Paste Slide 
button.
Microsoft Excel cannot paste a slide before data has been copied to the Clipboard.    To 
create a slide, select the cells you want to paste as a slide, switch to the slide show sheet, 
and choose the Paste Slide button.



Cannot do that command when a graphic object is selected.    Select 
the underlying sheet row.
Microsoft Excel cannot perform the desired action when a graphic object is selected.    Select
a cell in the same row as the graphic object you want to operate on, and try the command 
again.



Cannot unprotect the slide show sheet.
Microsoft Excel was unable to unprotect the active slide show sheet.    To edit a slide show, 
first use the Unprotect Document command on the Options menu to remove password 
protection.    Then, edit your slide show.    You can then turn on password protection.



The slide show image cannot be displayed because the image 
source link has been misplaced or deleted.    Try deleting the 
selected slide show row and pasting the slide again.
Either the slide show picture or the picture's formula has been corrupted.    Select the row 
and use the Delete Row button to remove the slide.    Then create the slide again.



Select a single row to mark where the slide rows should be 
inserted.
You chose the Paste Row button when more than one row was selected.    Choose a single 
row in front of which you want Microsoft Excel to paste the slides.



There is no slide information on the selected row.
The currently selected row does not contain any slide information, or the entire slide show 
sheet is empty.    Select a cell on a row with slide information, and try again.



There are no slides to paste.    Choose the Cut Row button or Copy 
Row button to select the rows to paste.
You chose the Paste Row button when there was no slide information on the Clipboard to 
paste.    Choose the Cut Row or Copy Row button first to select the rows to paste, and then 
choose the Paste Row button.



Solver Command (Formula Menu)
Displays the Solver Parameters dialog box, in which you define the problem you want to 
solve.    
With Microsoft Excel Solver, you can solve complex problems by creating a worksheet model
with multiple adjustable cells.    You can set constraints on your problem that must be 
satisfied before a solution is reached.
Set Cell

Specifies the cell whose value must reach a certain value, be maximized, or be 
minimized.

Equal To
Specifies whether you want the cell value identified in the Set Cell box to be maximized, 
minimized, or reach a certain value.

By Changing Cells
Specifies the adjustable cells.    An adjustable cell is one that can be changed by Solver 
until the constraints in the problem are satisfied and the cell in the Set Cell box reaches 
its target.

Guess
Guesses all non-formula cells referred to by the formula in the Set Cell box and places 
their references in the By Changing Cells box.

Subject To The Constraints
Lists the current constraints on the problem.    A constraint is a condition that needs to be 
satisfied by the solution; for example, Sales > 0.    A constraint is listed as a cell or cell 
range, usually containing a formula that depends on one or more adjustable cells, whose 
value is required to fall within certain bounds or satisfy a target.

Add
Displays the Add dialog box, where you can add constraints to the current problem.

Change
Displays the Change dialog box, where you can modify the existing constraints.

Delete
Removes the selected constraint.

Solve
Starts the problem-solving process for a problem you've defined.

Close
Closes the dialog box without solving the problem.    Retains only those changes made 
with the Options, Add, Change, or Delete button.    Does not retain any setting changes 
you may have made since using any of these buttons.

Options
Displays the Options dialog box, where you can control advanced features of the solution 
process and load or save the specifications, such as cell selections and constraints, for a 
particular problem on the worksheet.

Reset All
Clears the current Solver problem settings and resets all options to their defaults.

See Also
Help



Using Solver
User's Guide (Book 2)
Chapter 2, "Performing What-if Analysis on a Worksheet Model"



Add Constraint Dialog Box
Allows you to add constraints to the problem currently defined in the Solver Parameters 
dialog box.
Cell Reference

Specifies the cell or range of cells whose values you want to constrain.
Relationship

The unnamed list box between the Cell Reference box and the Constraint box, which 
specifies the relationship you want between the referenced cell or cell range and the 
constraint.    You can select <=, =, >=, or int.    If you choose int to specify that a variable 
must be an integer, the Constraint box is unavailable.

Constraint
Specifies a restriction you want placed on the contents of the Cell Reference box.    The 
constraint can be a number, a cell reference, a range reference, or a formula.    If you 
specify a range of cells, the range must be the same size as the range of cells in the Cell 
Reference box.

Add
Allows you to add another constraint without returning to the Solver Parameters dialog 
box.

See Also
Help
Using Solver
User's Guide (Book 2)
Chapter 2, "Performing What-if Analysis on a Worksheet Model"



Change Constraint Dialog Box
Allows you to change or modify a constraint to the problem currently defined in the Solver 
Parameters dialog box.
Cell Reference

Specifies the cell or range of cells whose values you want to constrain.
Relationship

The unnamed list box between the Cell Reference box and the Constraint box, which 
specifies the relationship you want between the referenced cell or cell range and the 
constraint.    You can select <=, =, >=, or int.    If you choose int to specify that a variable 
must be an integer, the Constraint box is unavailable.

Constraint
Specifies a restriction you want placed on the contents of the Cell Reference box.    The 
constraint can be a number, a cell reference, a range reference, or a formula.    If you 
specify a range of cells, the range must be the same size as the range of cells in the Cell 
Reference box.

See Also
Help
Using Solver
User's Guide (Book 2)
Chapter 2, "Performing What-if Analysis on a Worksheet Model"



Solver Options Dialog Box
Allows you to control advanced features of the solution process and load or save the 
specifications, such as the cell reference and constraints, for a particular problem on the 
worksheet.    You can define parameters for both linear and nonlinear problems.
Each of the options in this dialog box has a default setting that is appropriate for most 
problems.
Max Time

Specifies the maximum amount of time in seconds that you want Solver to spend on a 
problem.    Solver will only spend as much time on a problem as needed.

Iterations
Specifies the maximum number of trial solutions Solver is permitted.

Precision
Specifies how close the Cell Reference and Constraint formula must be to satisfy a 
constraint.

Tolerance
The maximum percentage of error allowed for integer solutions.    Only used if there is an 
integer constraint.

Assume Linear Model
Speeds the solution process.    Can be used only if all the relationships in the model are 
linear.

Show Iteration Results
Interrupts Solver and shows the results after each iteration.

Use Automatic Scaling
Turns on automatic scaling.    This is useful when the inputs (By Changing Cells) and 
outputs (Set Cell and Constraints) have large differences in magnitude; for example, 
maximizing percent profit based on million-dollar investments. 

Estimates
Specifies the approach used to obtain initial estimates of the basic variables in each one-
dimensional search.
Tangent

Uses linear extrapolation from a tangent vector.
Quadratic

Uses quadratic extrapolation; this may improve the results on highly nonlinear 
problems.

Derivatives
Specifies forward differencing or central differencing for estimates of partial derivatives.
Forward

The default method.
Central

Requires more worksheet recalculations, but may help on problems when you get a 
message saying that Solver could not improve the solution.

Search
Specifies either a quasi-Newton or Conjugate gradient method of searching.
Newton



The default method.
Conjugate

Useful if stepping through the iterations reveals slow progress between successive trial 
points.

Load Model
Displays the Load Model dialog box, where you can specify the reference for the model 
you want to load.

Save Model
Displays the Save Model dialog box, where you can specify the reference of the model 
you want to save.
Choose the Save Model button only when you want to save more than one Solver model 
with your worksheet.    The first Solver model is automatically saved with your worksheet.

See Also
Help
Using Solver
User's Guide (Book 2)
Chapter 2, "Performing What-if Analysis on a Worksheet Model"



Solution Dialog Box
Displays the results of the last calculation, using the adjustable cell values that are closest 
to the solution you want.    One of the following completion messages is displayed:

Solver found a solution.    All constraints and optimality conditions are satisfied.
All constraints are satisfied within the Precision setting and, if appropriate, a maximum 
or minimum value has been found for the cell in the Set Cell box.

Solver has converged to the current solution.    All constraints are satisfied.
The value in the cell specified in the Set Cell box is virtually unchanged for the last five 
trial solutions.    A solution may have been found, but it is also possible that the 
iterative solution process is making very slow progress.

Unsuccessful completion messages.
For details on any unsuccessful completion messages, see Chapter 2, "Performing 
What-if Analysis on a Worksheet Model," in Book 2 of the Microsoft Excel User's Guide.

Keep Solver Solution
Accepts the solution Solver found and puts these values in the adjustable cells.

Restore Original Values
Restores the original values in the adjustable cells.

Reports
Creates the type of report you specify.    Each report appears in its own worksheet window.
Answer

Lists the cell named in the Set Cell box and the adjustable cells, with both their original
and final values.    Also shows the constraints and information about the constraints.

Limit
Lists the cell named in the Set Cell box, and the adjustable cells with their respective 
values, upper and lower limits, and target results.    The lower limit is the smallest value
that the adjustable cell can take while holding all other adjustable cells fixed and still 
satisfying the constraints.    The upper limit is the greatest such value.    The target 
result is the value of the cell in the Set Cell box when the adjustable cell is at its lower 
or upper limit.

Sensitivity
Provides information about how sensitive the solution is to small changes in the Set 
Cell formula or the constraints.    For non-linear models, the report provides dual values 
(reduced gradients and Lagrange multipliers).    For linear models, the report includes 
dual values (reduced costs and shadow prices) and objective coefficient and constraint 
right-hand side ranges.

OK
Sets the adjustable cells as specified and generates any requested reports.

Cancel
Closes the Solution dialog box and restores the original values to the adjustable cells.

See Also
Help
Using Solver
User's Guide (Book 2)
Chapter 2, "Performing What-if Analysis on a Worksheet Model"



Using Solver
By using Solver, you can get better answers to questions such as: "What product price or 
promotion mix will maximize profit?    How can I live within the budget? How fast can we 
grow without running out of cash?"    Instead of guessing over and over, you can use Solver 
to find the best answer. 
Once you install Solver, you can use it whenever you run Microsoft Excel.    If the Solver 
command does not appear on the Formula menu, see Chapter 1, "Getting Started with 
Microsoft Excel," in Book 1 of the Microsoft Excel User's Guide for information on how to 
install Solver.    After you choose the Solver command from the Formula menu, follow these 
four steps to a solution:    

Specify a cell (such as net profit) whose value is to be maximized, minimized, or 
made to reach a certain value.

Specify the adjustable cells whose values are to be adjusted until a solution is found.
Specify constraint cells, which must fall within certain limits or satisfy target values.
Choose the Solve button.

Solver goes to work and the solution values appear in the adjustable cells.    You can then 
create three types of reports that summarize the results of a successful solution process.
About Solver. . .
See Also
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Save Scenario Dialog Box
This box allows you to save your problem for use with the Microsoft Excel Scenario Manager.
If you have not previously defined a scenario, the reference in Solver's By Changing Cells 
box is used in Scenario Manager's Changing Cells box.
Scenario Name

Allows you to enter a name for the scenario.
See Also

Help
Scenario Manager Command (Formula Menu)
Using Solver
User's Guide (Book 2)
Chapter 2, "Performing What-if Analysis on a Worksheet Model"



Show Trial Solution Dialog Box
If you select the Show Iteration Results check box in the Options dialog box and then choose
the Solve button, Solver stops and displays each iteration's results.
Save Scenario

Allows you to save your problem for use with the Microsoft Excel Scenario Manager.    If 
you have not previously defined a scenario, the reference in Solver's By Changing Cells 
box is used in Scenario Manager's Changing Cells box.    The Save Scenario dialog box 
appears and you are asked to enter a scenario name.

Continue
Continues the solution process.

Stop
Displays the Solution dialog box without completing the solution.

See Also
Help
Scenario Manager Command (Formula Menu)
Using Solver
User's Guide (Book 2)
Chapter 2, "Performing What-if Analysis on a Worksheet Model"



Load Model Dialog Box
The last model you worked with on the active worksheet is automatically opened by default 
when you choose the Solver command.
Select Model Area

To open an alternate model you've previously saved, type its reference in this box or 
select the range containing the model.

See Also
Help
Using Solver
User's Guide (Book 2)
Chapter 2, "Performing What-if Analysis on a Worksheet Model"



Save Model Dialog Box
Use this dialog box only when you want to save more than one Solver model with your 
worksheet.    The current Solver model is automatically saved with your worksheet.
Select Model Area

Specify a range where you want to save the current model, or accept the range Solver 
proposes, which begins with the active cell.

See Also
Help
Using Solver
User's Guide (Book 2)
Chapter 2, "Performing What-if Analysis on a Worksheet Model"



About Solver
The Microsoft Excel Solver program code is copyright 1990, 1991, 1992 by Frontline 
Systems, Inc.    Portions copyright 1989 by Optimal Methods, Inc.
The Microsoft Excel Solver uses the GRG2 nonlinear optimization code developed by Leon 
Lasdon, University of Texas at Austin and Allan Waren, Cleveland State University.
Linear and integer problems use the simplex method with bounds on the variables and the 
branch and bound method, implemented by John Watson and Dan Fylstra, Frontline 
Systems, Inc.
For more information, contact:

Frontline Systems, Inc.
P.O. Box 4288
Incline Village, Nevada    89450-4288
(702) 831-0300



Anova: Single-Factor
Performs simple analysis of variance, which tests the hypothesis that means from several 
samples are equal. Generally, analysis of variance, or anova, is a statistical procedure that 
you use to determine whether means from two or more samples are drawn from populations
with the same mean. This technique expands on the tests for two means, such as the t-test.
Input Range

Type the reference for the range of worksheet data you want to analyze. The input range 
should contain two or more blocks of data arranged in columns or rows. If your input 
range includes row or column labels, you must select the Labels In First Column or Labels 
In First Row check box, or Microsoft Excel will display a message.

Output Range
Type the reference for the upper-left cell of the range where you want the output table to 
appear. If existing data is about to be overwritten in the output range, Microsoft Excel 
displays a message.

Grouped By
Select either the Rows or Columns option button to indicate whether the data in the input
range is arranged in rows or by columns.

Labels In First Row/Labels In First Column
If you selected the Columns option button under Grouped By, and the first row of your 
input range contains labels, select the Labels In First Row check box.
If you selected the Rows options button under Grouped By, and the first column of your 
input range contains labels, select the Labels In First Columns check box.
If your input range does not include labels, clear the Labels In First Row or Labels In First 
Column check box.    Microsoft Excel will then generate the appropriate data labels for the 
output table (Row 1, Row 2, Row 3, and so on; or Column 1, Column 2, Column 3, and so 
on).

Alpha
Type the significance level at which you want to evaluate critical values for the F statistic.
The default alpha value is 0.05. This critical value appears in the output table.

See Also
Help
Using an Analysis ToolPak tool
Function Reference
ANOVA1
User's Guide (Book 2)
Chapter 1, "Analyzing and Calculating Data"



Anova: Two-Factor With Replication
Performs an extension of the single-factor anova that includes more than one sample for 
each group of data. Analysis of variance, or anova, is a statistical procedure that you use to 
determine whether means from two or more samples are drawn from populations with the 
same mean. This technique expands on the tests for two means, such as the t-test.
Input Range

Type the reference for the range of worksheet data you want to analyze. The input range 
should contain two or more blocks of data arranged in columns. Type column labels in the
first row, and one row label in the first column for each group of data in the input range; 
Microsoft Excel assumes that the first row and column of the input range contain labels.

Output Range
Type the reference for the upper-left cell of the range where you want the output table to 
appear.

Rows Per Sample
Type the number of rows contained in each sample.    Each now represents a replication of
the data. Each sample must contain the same number of rows.

Alpha
Type the significance level at which you want to evaluate critical values for the F statistic.
The default alpha value is 0.05. This critical value appears in the output table.

See Also
Help
Using an Analysis ToolPak tool
Function Reference
ANOVA2
User's Guide (Book 2)
Chapter 1, "Analyzing and Calculating Data"



Anova: Two-Factor Without Replication
Performs simple anova that does not include more than one sampling per group. In general, 
analysis of variance, or anova, is a statistical procedure you use to determine whether 
means from two or more samples are drawn from populations with the same mean. This 
technique expands on the tests for two means, such as the t-test.
Input Range

Type the reference for the range of worksheet data you want to analyze. The input range 
should contain two or more blocks of data arranged in columns or rows. If your input 
range includes row or column labels, you must select the Labels check box, or Microsoft 
Excel will display a message.

Output Range
Type the reference for the upper-left cell of the range where you want the output table to 
appear. 

Labels
If the first row and column of your input range contain labels, select the Labels check box.
If your input range does not contain labels, clear the Labels check box.    Microsoft Excel 
will then generate the appropriate data labels for the output table.

Alpha
Type the significance level at which you want to evaluate critical values for the F statistic.
The default alpha value is 0.05. This critical value appears in the output table.

See Also
Help
Using an Analysis ToolPak tool
Function Reference
ANOVA3
User's Guide (Book 2)
Chapter 1, "Analyzing and Calculating Data"



Correlation
Measures the relationship between two data sets that are scaled to be independent of the 
unit of measurement. The population correlation calculation returns the covariance of two 
data sets divided by the product of their standard deviations.
You can use Correlation to determine whether two data sets move together; that is, whether
large values of one set are associated with large values of the other (positive correlation), 
whether small values of one set are associated with large values of the other (negative 
correlation), or whether values in both sets are unrelated (correlation near zero).
Input Range

Type the reference for the range of worksheet data you want to analyze. The input range 
should contain two or more blocks of data arranged in columns or rows. If your input 
range includes row or column labels, you must select the Labels In First Column or Labels 
In First Row check box, or Microsoft Excel will display a message.

Output Range
Type the reference for the upper-left cell of the output table. Only half of the table is 
complete because correlation between two data sets is independent of the order in which
the data sets are processed. Cells in the output table with matching row and column 
coordinates contain the value 1 because each data set correlates perfectly with itself. The
output table is a square whose width and height are one larger than the number of cell 
ranges of data. If existing data is about to be overwritten in the output range, Microsoft 
Excel displays a message.

Grouped By
Select either the Rows or Columns option button to indicate whether the data in the input
range is arranged in rows or by columns.

Labels In First Row/Labels In First Column
If you selected the Columns option button under Grouped By, and the first row of your 
input range contains labels, select the Labels In First Row check box.
If you selected the Rows options button under Grouped By, and the first column of your 
input range contains labels, select the Labels In First Columns check box.
If your input range does not include labels, clear the Labels In First Row or Labels In First 
Column check box.    Microsoft Excel will then generate the appropriate data labels for the 
output table (Row 1, Row 2, Row 3, and so on; or Column 1, Column 2, Column 3, and so 
on).

See Also
Help
CORREL
COVAR
Using an Analysis ToolPak tool
Function Reference
MCORREL
MCOVAR
User's Guide (Book 2)
Chapter 1, "Analyzing and Calculating Data"



Covariance
Returns the average of the product of deviations of data points from their respective means.
Covariance is a measure of the relationship between two ranges of data. Covariance is 
sensitive to the unit of measure for X and Y. Two pairs of similarly related ranges of data will 
yield different covariance values if the magnitude of the data points vary. 
Use the Covariance tool to determine whether two ranges of data move together; that is, 
whether large values of one set are associated with large values of the other (positive 
covariance), whether small values of one set are associated with large values of the other 
(negative covariance), or whether values in both sets are unrelated (covariance near zero).
Input Range

Type the reference for the range of worksheet data you want to analyze. The input range 
should contain two or more blocks of data arranged in columns or rows. If your input 
range includes row or column labels, you must select the Labels In First Column or Labels 
In First Row check box, or Microsoft Excel will display a message.

Output Range
Type the reference for the upper-left cell of the range where you want the output to 
appear. Microsoft Excel populates only half of the table because covariance between two 
ranges of data is independent of the order in which the ranges of data are processed. The
output table is a square whose width and height are one larger than the number of cell 
ranges of data. The table's diagonal contains the variance of each range

Grouped By
Select either the Row or Column option button to indicate whether the data in the input 
range is arranged in rows or by columns.

Labels In First Row/Labels In First Column
If you selected the Columns option button under Grouped By, and the first row of your 
input range contains labels, select the Labels In First Row check box.
If you selected the Rows options button under Grouped By, and the first column of your 
input range contains labels, select the Labels In First Columns check box.
If your input range does not include labels, clear the Labels In First Row or Labels In First 
Column check box.    Microsoft Excel will then generate the appropriate data labels for the 
output table (Row 1, Row 2, Row 3, and so on; or Column 1, Column 2, Column 3, and so 
on).
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Descriptive Statistics
Generates a report of univariate statistics for data in the input range. This procedure 
provides information about the central tendency and variability of your data. The statistics 
in this table are a common starting point for further analysis and can indicate which tests 
are appropriate to explore next.
Input Range

Type the reference for the range of worksheet data you want to analyze. If your input 
range includes labels, you must select the Labels In First Column or Labels In First Row 
check box, or Microsoft Excel will display a message.

Output Range
Type the reference for the upper-left cell of the range where you want the output to 
appear. The Descriptive Statistics tool produces two columns of information for each data 
set. The left column contains the statistics labels (see the Summary Statistics option 
below); the right column contains the statistics.

If the Columns option button is selected under Grouped By, Microsoft Excel writes a 
two-column table of statistics for each column in the input range.

If the Rows option button is selected under Grouped By, Microsoft Excel writes a two-
column table of statistics for each row in the input range.
Grouped By

Select either the Rows or Columns option button to indicate whether the data in the input
range is arranged in rows or columns.

Labels In First Row/Labels In First Column
If you selected the Columns option button under Grouped By, and the first row of your 
input range contains labels, select the Labels In First Row check box.
If you selected the Rows options button under Grouped By, and the first column of your 
input range contains labels, select the Labels In First Columns check box.
If your input range does not include labels, clear the Labels In First Row or Labels In First 
Column check box.    Microsoft Excel will then generate the appropriate data labels for the 
output table (Row 1, Row 2, Row 3, and so on; or Column 1, Column 2, Column 3, and so 
on).

Summary Statistics
Select the Summary Statistics check box if you want Microsoft Excel to produce one field 
for each of the following statistics in the output table:
Mean
Standard Error (of the mean)
Median
Mode
Standard Deviation
Variance
Kurtosis
Skewness
Range
Minimum
Maximum
Sum
Count
Largest (#)
Smallest (#)
Confidence Level

Kth Largest



Select the Kth Largest check box if you want to include a row in the output table for the 
kth largest value for each range of data. In the Kth Largest box, type the number to use 
for k. If k is 1, this row contains the maximum of the data set.

Kth Smallest
Select the Kth Smallest check box if you want to include a row in the output table for the 
kth smallest value for each range of data. In the Kth Smallest box, type the number to 
use for k. If k is 1, this row contains the minimum of the data set.

Confidence Level For Mean
Select the Confidence Level For Mean check box if you want to include a row for the 
confidence level of the mean in the output table. In the Confidence Level For Mean box, 
type the confidence level that you want. For example, a value of 95% calculates the 
confidence level of the mean at a significance of 0.05.

See Also
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Exponential Smoothing
Predicts a value based on the forecast for the prior period, adjusted for the error in that 
prior forecast. Uses a smoothing constant, a, the magnitude of which determines how 
strongly forecasts respond to errors in the prior forecast. 
You can use exponential smoothing to forecast sales, inventory, or other trends. Another 
method, Regression, also predicts values based on relationships in existing data.
Input Range

Type the reference for the range of worksheet data you want to analyze. The input range 
must consist of a single column or row containing four or more cells of data. If data in the 
Input Range is nonnumeric, Microsoft Excel displays a message.

Output Range
Type the reference for the upper-left cell of the range where you want the output table to 
appear. The input range and output range must be on the same worksheet.

If the Standard Errors check box is selected, Microsoft Excel generates a two-column 
output table with standard error values in the right column.

If there are insufficient historical values to project a fore cast or calculate a standard 
error, Microsoft Excel returns the #N/A error value.
Damping Factor

Type the Damping Factor that you want to use as the exponential smoothing constant. 
Microsoft Excel uses 0.3 as the default value for the damping factor. 

Standard Errors
Select the Standard Errors check box if you want to include a column that contains 
standard error values in the output table. 

If the Standard Errors check box is selected, Microsoft Excel generates a two-column 
output table with standard error values in the right column.

If the Standard Errors check box is cleared, Microsoft Excel generates a single-column
output table without standard error values.
Chart Output

Select the Chart Output check box if you want Microsoft Excel to automatically generate a
chart for the actual and forecast values with the output table. If you save the original 
chart with the filename EXPSMTH.XLC, subsequent charts will automatically update this 
file. Each time you use Exponential Smoothing and select the Chart Output check box, 
Microsoft Excel searches for the file EXPSMTH.XLC. If this chart is active, Microsoft Excel 
modifies the chart for the current data. If the chart is in a default directory but inactive, 
Microsoft Excel opens the chart and modifies it to reflect current data. In either of these 
cases, legends and titles are unaffected. If EXPSMTH.XLC cannot be found, a new chart is 
opened with the next available default chart name. In this case, legend and title 
information are added to the chart.
If the Chart Output check box is cleared, Microsoft Excel does not generate the chart.

See Also
Help
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F-Test: Two-Sample for Variances
Performs a two sample F-test. An F-test is a method for comparing two population 
variances. For example, you can use an F test to determine whether the time scores in a 
swimming meet have a difference in variance for samples from two teams.
Variable 1 Input Range

Type the reference for the first column or row of data you want analyzed. If any data point
in the range of data is nonnumeric, Microsoft Excel displays a message.

Variable 2 Input Range
Type the reference for the second column or row of data you want analyzed. If any data 
point in the range of data is nonnumeric, Microsoft Excel displays a message.

Output Range
Type the reference for the upper-left cell of the range where you want the output table to 
appear.

Labels
If the first row or column of your input range contains labels, select the Labels check box. 
If your input range does not contain labels, clear the Labels check box.    Microsoft Excel 
will then generate the appropriate data labels for the output table (Variable 1 and 
Variable 2).

See Also
Help
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Histogram
Calculates individual and cumulative frequencies for a cell range of data and data bins. 
Generates data for the number of occurrences of a value in a data set. For example, in a 
class of 20 students, you may be interested in the distribution of scores in letter grade 
categories. A histogram table presents the letter grade boundaries and the number of 
scores between the lowest bound and the current bound. The single most frequent score is 
the mode of the cell range of data.
Input Range

Type the reference for the range of worksheet data that you want to analyze. You can 
type either a column, a row, or a block of numeric data for frequency generation. Data 
must be numeric or Microsoft Excel will display a message.

Bin Range (optional)
Type a cell range with an optional set of boundary values that define bin ranges. These 
values should be in ascending order. 

Microsoft Excel counts the number of data points between the current bin number 
and the adjoining higher bin, if any. Microsoft Excel includes values at the lower bin 
boundary and excludes the values at the upper bin boundary. For example, bins might equal 
2 to 2.9999, 3 to 3.9999, 4 to 4.9999, and so on.

If you omit the Bin Range, Microsoft Excel will create a set of evenly distributed bins 
between the data's minimum and maximum values.
Output Range

Type the reference for the upper-left cell of the output table. If existing data is about to be
overwritten in the output range, Microsoft Excel displays a message.

Pareto
Select the Pareto check box to present the data in order of descending frequency.

If the Pareto check box is selected, Microsoft Excel presents data in descending 
frequency order in the output table.

 If the Pareto check box is cleared, Microsoft Excel presents data in ascending bin 
order in the output table and omits the three rightmost columns containing the sorted data.
Cumulative Percentage

Select the Cumulative Percentage check box to generate cumulative percentages. 
If the Cumulative Percentage check box is selected, Microsoft Excel generates an 

output table column for cumulative percentages and includes a cumulative percentage line 
in the histogram chart.    For more information about generating a histogram chart, see the 
Chart Output option, which follows.

If the Cumulative Percentage check box is cleared, Microsoft Excel omits the 
cumulative percentage column in the output table and the cumulative percentage line in the
charts.
Chart Output

Select the Chart Output check box if you want Microsoft Excel to automatically generate a
histogram chart with the output table. If the Chart Output check box is selected, Microsoft
Excel generates a chart in addition to the output table. If you save the original chart with 
the filename HISTOGRM.XLC, subsequent charts will automatically update this file. Each 
time you use Histogram and select the Chart Output check box, Microsoft Excel searches 
for the file HISTOGRM.XLC. If this chart is active, Microsoft Excel modifies the chart for the
current data. If the chart is in a default directory but inactive, Microsoft Excel opens the 
chart and modifies it to reflect current data. In either of these cases, legends and titles 
are unaffected. If HISTOGRM.XLC cannot be found, a new chart is opened with the next 
available default chart name.    In this case, legend and title information are added to the 
chart.



See Also
Help
Creating a chart
MODE
Using an Analysis ToolPak tool
Function Reference
HISTOGRAM
User's Guide (Book 2)
Chapter 1, "Analyzing and Calculating Data"



Moving Average
Projects values in the forecast period, based on the average value of the variable over a 
specific number of preceding periods. You can use this procedure to forecast sales, 
inventory, or other trends.
Input Range

Type the reference for the range of worksheet data that you want to analyze. The input 
range must consist of a single column or row containing four or more cells of data.    If any
data in the input range is nonnumeric, Microsoft Excel displays a message. 

Output Range
Type the reference for the upper-left cell of the range where you want the output table to 
appear. If there are insufficient historical values to project a forecast, Microsoft Excel 
returns the #NUM! error value.

Interval
Type the number of values you want to include in the moving average. The default 
interval is 3.    If interval is nonnumeric, Microsoft Excel displays a message.

Standard Errors
Select the Standard Errors check box if you want to include a column that contains 
standard errors in the output table. 

If the Standard Errors check box is selected, Microsoft Excel generates a two-column 
output table, with standard error values in the right column.

If the Standard Errors check box is cleared, Microsoft Excel generates a single-column
output table without standard error values.
Chart Output

Select the Chart Output check box if you want Microsoft Excel to automatically generate a
chart of the forecast values with the output table. If the Chart Output check box is 
selected, Microsoft Excel generates a chart in addition to the output table. If you save the
original chart with the filename MOVEAVG.XLC, subsequent charts will automatically 
update this file. 
Each time you use Moving Average and select the Chart Output check box, Microsoft 
Excel searches for the file MOVEAVG.XLC. If this chart is active, Microsoft Excel modifies 
the chart for the current data. If the chart is in a default directory but inactive, Microsoft 
Excel opens the chart and modifies it to reflect current data. In either of these cases, 
legends and titles are unaffected. If MOVEAVG.XLC cannot be found, a new chart is 
opened with the next available default chart name. In this case, legend and title 
information are added to the chart.

If the Chart Output check box is cleared, Microsoft Excel does not generate a chart.
See Also
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Random Number Generation
Fills a range with independent random numbers drawn from one of several distributions. 
Random variables have a variety of applications in statistical simulations. One application of
this procedure characterizes subjects in a population with a probability distribution. For 
example, you might use a normal distribution to characterize the population of individuals’ 
heights, or a Bernoulli distribution of two possible outcomes to characterize the population 
of coin flip results.
Output Range

Type the reference for the upper-left cell of the range where you want output table to 
appear. 

Number Of Variables
Type the number of columns of values you want Microsoft Excel to place in the output 
table. If you do not type the number of variables, Microsoft Excel fills all output table 
columns.

Number Of Random Numbers
Type the number of data points you want generated for each variable. Each data point is 
placed in a row of the output table. If this item is blank, Microsoft Excel fills all output 
table rows.

Distribution
Select the distribution you want to use to create random variables. 

Parameters
Type the parameters you want to use to characterize a distribution.
Uniform 

Characterized by lower and upper bounds. Variables are drawn with equal probability 
from all values in the range. A common application uses a uniform distribution in the 
range 0...1.

Normal
Characterized by a mean and standard deviation. A common application uses a mean 
of zero and a standard deviation of one for the standard normal distribution.

Bernoulli 
Characterized by a probability of success on a given trial. Bernoulli random variables 
will have the value zero or one. For example, you can draw a uniform random variable 
in the range 0...1. If the variable is less than or equal to the probability of success, the 
Bernoulli random variable is assigned the value of one; otherwise, it is assigned the 
value of zero.

Binomial
Characterized by a probability of success for a number of trials. For example, you can 
generate number_of_trials Bernoulli random variables, the sum of which is a binomial 
random variable.

Poisson
Characterized by a value lambda, equal to 1/mean. The Poisson distribution is often 
used to characterize the number of events that occur per unit of time; for example, the
average rate at which cars arrive at a toll plaza.

Patterned
Characterized by a lower and upper bound, a step, repetition rate for values, and a 
repetition rate for the sequence.



Discrete
Characterized by a value and the associated probability range. The range must contain 
two columns: the left column must contain values and the right column must contain 
probabilities associated with the value in that row. The sum of the probabilities must be
one.

Random Seed
Type an optional value from which to generate random numbers. You can reuse this value
to produce the same random numbers at a later time.

See Also
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Rank and Percentile
Produces a table that contains the ordinal and percent rank of each value in a data set. You 
can use this procedure to analyze the relative standing of values in a data set.
Input Range

Type the reference for the range of worksheet data that you want to analyze. If your input
range includes row or column labels, you must select the Labels In First Row or Labels In 
First Column check box, or Microsoft Excel will display a message.

Output Range
Type the reference for the upper-left cell of the range where you want the output table to 
appear. Microsoft Excel generates one output table for each data set in the input range. 
Each output table contains four columns: the data point number, the data point value, the
data point's rank, and the data point's percent rank. Microsoft Excel sorts each output 
table in ascending rank order.

Grouped By
Select either the Rows or Columns option button to indicate whether the data in the input
range is arranged in rows or columns.

Labels In First Row/Labels In First Column
If you selected the Columns option button under Grouped By, and the first row of your 
input range contains labels, select the Labels In First Row check box.
If you selected the Rows option button under Grouped By, and the first column of your 
input range contains labels, select the Labels In First Column check box.
If your input range does not include labels, clear the Labels In First Row or Labels In First 
Column check box.    Microsoft Excel will then generate the appropriate row and column 
labels for the output table (Column 1, Column 2, Column 3, and so on; or Row 1, Row 2, 
Row 3, and so on).

See Also
Help
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Regression
Performs linear regression analysis. Regression fits a line through a set of observations 
using the "least squares" method. Regression is used in a wide variety of applications that 
seek to analyze how a single dependent variable is affected by the values of one or more 
independent variables. For example, several factors affect an athlete’s performance 
including age, sex, height, and weight. Regression apportions shares in the performance 
measure to each of these four factors based on a set of performance data. You can then use
the regression results to predict the performance of a new, untested athlete.
Input Y Range

Type the reference for the range of dependent data that you want to analyze. The 
dependent data should be typed in a single column. 
If you include a report label in the first row of the input y range, you must select the 
Labels check box, or Microsoft Excel will display a message.

Input X Range
Type the reference for the range of independent data that you want to analyze. 
Microsoft Excel orders independent variables in ascending order from left to right, and 
uses 1, 2, 3, and so on for the variable names in the summary output table.

Constant Is Zero
Select the Constant Is Zero check box to force the regression line to pass through the 
origin.

Labels
If the first row in the input range includes report labels, select the Labels check box.
If your input range does not contain labels, clear the labels check box.    Microsoft Excel 
will then generate the appropriate data labels for the summary output table.

Confidence Level
Select the Confidence Level check box if you want an additional level included in the 
summary output table.    In the Confidence Level box, type an additional confidence level 
that you want Microsoft Excel to apply to the regression in addition to the default 95% 
confidence level.

Summary Output Range
Type the reference for the upper-left cell of the range where you want the summary 
output table to appear.    Allow at least seven columns for the summary output table.
The summary output table includes the following:
Anova table
Coefficients
Standard error of y estimate
r2 values
Number of observations
Standard error of coefficients

Residuals
Select the Residuals check box if you want to include residuals in the residuals output 
table.    
If you select the Residuals check box, you must type a cell reference in the Residuals 
Output Range box.

Standardized Residuals
Select the Standardized Residuals check box if you want to include standardized residuals



in the output table.
If you select the Standardized Residuals check box, you must type a cell reference in the 
Residuals Output Range box.

Residual Plots
Select the Residual Plots check box if you want Microsoft Excel to generate a chart for 
each independent variable versus the residual.
If you select the Residual Plots check box, you must type a cell reference in the Residuals 
Output Range box.

Line Fit Plot
Select the Line Fit Plot check box if you want Microsoft Excel to generate a chart for 
predicted values versus the observed values.
If you select the Line Fit Plot check box, you must type a cell reference in the Residuals 
Output Range box.

Residuals Output Range
Type the reference for the upper-left cell of the range where you want the residuals 
output table to appear.    The residuals output table can include residuals, standardized 
residuals, and predicted values.
Allow at least four columns for the residuals output table.

Normal Probability Plot
Select the Normal Probability Plot check box if you want Microsoft Excel to generate a 
chart plotting normal probability plots.
If you select the Normal Probability Plot check box, you must type a cell reference in the 
Probability Data Output Range box.

Probability Data Output Range
Type the reference for the upper-left cell of the range where you want the probability data
output table to appear.    The probability data output table displays the dependent 
variable values and percentiles used to generate the normal probability plot.
Allow al least two columns for the probability data output table.
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t-Test: Paired Two-Sample for Means
Performs a two-sample paired student’s t-Test. This form of the t-test tests whether a 
samples' means are distinct, and does not assume the variances of both populations from 
which the data sets are drawn are equal. A paired test is appropriate whenever there is a 
natural pairing of observations in the samples, such as when a sample group is tested twice,
before and after an experiment. 
The two input ranges of data must contain the same number of data points.
Variable 1 Input Range

Type the reference for the first range of data you want analyzed. The data must occupy a 
single column or row on the worksheet. If any data points in the range of data are 
nonnumeric, Microsoft Excel displays a message.

Variable 2 Input Range
Type the reference for the second range of data you want analyzed. The data must 
occupy a single column or row on the worksheet. If any data points in the range of data 
are nonnumeric, Microsoft Excel displays a message.

Output Range
Type the reference for the upper-left cell of the range where you want the output table to 
appear.

Labels
If the first row or column of your input range contains labels, select the Labels check box.
If your input range does not contain labels, clear the Labels check box.    Microsoft Excel 
will then generate the appropriate data labels for the output table (Variable 1 and 
Variable 2).

Alpha
Type the confidence level for the test. The default alpha value is 0.05. If alpha is 
nonnumeric or outside the range 0...1, Microsoft Excel displays a message.

Hypothesized Mean Difference
Type the number that you want for the shift in sample means. A value of 0 indicates that 
the sample means are hypothesized to be equal.

See Also
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t-Test: Two-Sample Assuming Equal Variances
Performs a two-sample student’s t-Test. This form of the t-test assumes that the means of 
both data sets are equal and is referred to as a homoscedastic t-test. You use t-tests to 
determine whether the two samples' means are equal.
Variable 1 Input Range

Type the reference for the first range of data you want analyzed. The data must occupy a 
single column or row on the worksheet. If any data point in the range of data is 
nonnumeric, Microsoft Excel displays a message.

Variable 2 Input Range
Type the reference for the second range of data you want analyzed. The data must 
occupy a single column or row on the worksheet. If any data point in the range of data is 
nonnumeric, Microsoft Excel displays a message.

Output Range
Type the reference for the upper-left cell of the range where you want the output table to 
appear. 

Labels
If the first row or column of your input range contains labels, select the Labels check box.
If your input range does not contain labels, clear the Labels check box.    Microsoft Excel 
will then generate the appropriate data labels for the output table (Variable 1 and 
Variable 2).

Alpha
Type the confidence level for the test. The default alpha value is 0.05. If alpha is 
nonnumeric or outside the range 0...1, Microsoft Excel displays a message.

Hypothesized Mean Difference
Type the number that you want for the shift in sample means. A value of 0 indicates that 
the sample means are hypothesized to be equal.

See Also
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t-Test: Two-Sample Assuming Unequal Variances
Performs a two-sample student’s t-Test. This form of the test assumes that the variances of 
both ranges of data are equal and is referred to as a heteroscedastic t-test. Use t-tests to 
determine whether two sample means are equal. Use this test when the groups under study
are distinct. Use a paired test when there is one group before and after a treatment.
Variable 1 Input Range

Type the reference for the first range of data you want to analyzed. The data must occupy
a single column or row on the worksheet. If any data point in the range of data is 
nonnumeric, Microsoft Excel displays a message.

Variable 2 Input Range
Type the reference for the second range of data you want to analyzed. The data must 
occupy a single column or row on the worksheet. If any data point in the range of data is 
nonnumeric, Microsoft Excel displays a message.

Output Range
Type the reference for the upper-left cell of the range where you want the output table to 
appear. 

Labels
If the first row or column of your input range contains labels, select the Labels check box.
If your input range does not contain labels, clear the Labels check box.    Microsoft Excel 
will then generate the appropriate data labels for the output table (Variable 1 and 
Variable 2).

Alpha
Type the confidence level for the test. The default alpha value is 0.05. If alpha is 
nonnumeric or outside the range 0...1, inclusive, Microsoft Excel displays a message.
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z-Test: Two-Sample for Means
Performs a two-sample z-test for means with known variances. This procedure is commonly 
used to test hypotheses about the difference between two population means. For example, 
you can use this test for differences between the performance of two car models.
Variable 1 Input Range

Type the reference for the first range of data you want to analyzed. The data must occupy
a single column or row on the worksheet. If any data point in the range of data is 
nonnumeric, Microsoft Excel displays a message.

Variable 2 Input Range
Type the reference for the second range of data you want to analyzed. The data must 
occupy a single column or row on the worksheet. If any data point in the range of data is 
nonnumeric, Microsoft Excel displays a message.

Output Range
Type the reference for the upper-left cell of the range where you want the output table to 
appear.

Labels
If the first row or column of your input range contains labels, select the Labels check box.
If your input range does not contain labels, clear the Labels check box.    Microsoft Excel 
will then generate the appropriate data labels for the output table (Variable 1 and 
Variable 2).

Alpha
Type the confidence level for the test. The default alpha value is 0.05. If alpha is 
nonnumeric or outside the range 0...1, inclusive, Microsoft Excel displays a message.

Variable 1 Variance (Known)
Type the known population variance for the Variable 1 input range. If the variance is 
nonnumeric, Microsoft Excel displays a message.

Variable 2 Variance (Known)
Type the known population variance for the Variable 2 input range. If the variance is 
nonnumeric, Microsoft Excel displays a message.
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Fourier Analysis
Fourier analysis is a technique for solving problems in linear systems and analyzing periodic
data. The Fourier Analysis tool transforms data using the Fast Fourier Transform (FFT) 
method. The procedure also supports inverse transformations, where the inverse of 
transformed data returns the original data.
Input Range

Type the reference for the range of real or complex data you want to transform. Complex 
data must be in either the x+yi or x+yj format. The number of input range values must 
be an even power of two.    If x is a negative number, it must be preceded by an 
apostrophe ( ' ), or Microsoft Excel will display a message.

Output Range
Type the reference for the upper-left cell of the range where you want the output table to 
appear. 

Inverse
Clear or select the Inverse check box to perform or undo a transform. If the Inverse check
box is selected, the data in the input range is considered transformed and is returned to 
its original state in the output table. If the Inverse check box is cleared, the data in the 
input range is transformed in the output table.

See Also
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Sampling
Creates a sample from a population by treating the input range as a population. When the 
population is too large to process or chart, you can use a representative sample of your 
population. In addition, if you believe the input data is periodic, you can create a sample 
that contains only values from a particular part of a cycle. For example, if the input range 
contains quarterly sales figures, sampling with a periodic rate of four places values from the
same quarter in the output range.
Input Range

Type the references for the block of data on the worksheet that contains the population of
values from which you want Microsoft Excel to draw a sample.    Microsoft Excel draws 
samples from the first column, then the second column, and so on.

Output Range
Type the reference for the upper-left cell of the range where you want the output table to 
appear. Data is written in a single column below the output range.

If you select the Periodic option button, the number of values in the output table is 
equal to the number of values in the input range divided by period, the sampling rate.

 If you select the Random option button, the number of values in the output table is 
equal to the number of samples.
Sampling

Select either the Periodic or Random option button for the interval at which to sample 
values from the input range. 

If you select the Periodic option button, type a number in the Period box.
If you select the Random option button, type a number in the Number of Samples 

box.
Period

Type the periodic interval at which you want sampling to take place.    The period-th value 
in the input range and every period-th value thereafter is copied to the output column.    
Sampling stops when the end of the input range is reached.    When you select the 
Periodic option button, if period is not numeric, is less than or equal to zero, or is greater 
than the number of values in the input range, Microsoft Excel displays a message.

Number Of Samples
Type the number of random values that you want Microsoft Excel to place in the output 
column. Each value is drawn from a random position in the input range. Values are drawn 
with replacement; that is, the sample position may be selected more than once. If you 
select the Random option button under Period, and the number of the sample is 
nonnumeric or less than or equal to zero, Microsoft Excel displays a message.

See Also
Help
Using an Analysis ToolPak tool
Function Reference
SAMPLE
User's Guide (Book 2)
Chapter 1, "Analyzing and Calculating Data"



To use an Analysis ToolPak tool
Before you use an analysis tool, you must organize the data you want analyzed into 
columns or rows on your worksheet.    This is your input range.    You can also include a text 
label in the first cell of a row or column to identify your variables.
When you use an analysis tool to analyze data in an input range, Microsoft Excel creates an 
output table of the results.    The contents of the output table depend on the analysis tool 
that you are using.    If you included labels in the input range, Microsoft Excel uses them to 
label data in the output table.    If you did not include labels in the input range, Microsoft 
Excel automatically generates data labels for the results in the output table

1 From the Options menu, choose Analysis Tools.
If the Analysis Tools command does not appear on the Options menu, run the Setup 
program to install the Analysis ToolPak.

2 In the Analysis Tools box, select the tool that you want to use.
3 Choose the OK button.
4 Type the input range, the output range, and any other options you want.

You can type cell ranges in the Input Range and Output Range boxes by typing a cell 
reference in the box or by selecting the contents of each box and then selecting the 
cell range on the worksheet.
You can also type references to other worksheets in the Input Range and Output Range 
boxes.

5 Choose the OK button.
The results of the analysis will appear in the cell range that you designated as the 
output range.

See Also
Help
Macro Library Overview
Using an Analysis ToolPak tool
User's Guide (Book1)
Chapter 11, "Working with Multiple Microsoft Excel Documents"
User's Guide (Book 2)
Chapter 1, "Analyzing and Calculating Data"
Chapter 4, "Customizing Microsoft Excel"



Analysis Tools Command (Options Menu)
Displays the Analysis Tools dialog box with a list of the statistical and engineering Analysis 
ToolPak tools.    The Microsoft Excel Analysis ToolPak was developed by GreyMatter 
International, Inc., 173 Otis Street, P.O. Box 388, Cambridge, MA 02141.

If the Analysis Tools command does not appear on the Options menu, run the Setup 
program to install the Analysis ToolPak. 
Analysis Tools

Lists the available Analysis ToolPak tools.
See Also

Help
Using an Analysis ToolPak tool
Anova: Single-Factor
Anova: Two Factor With Replication
Anova: Two Factor Without Replication
Correlation
Covariance
Descriptive Statistics
Exponential Smoothing
F-Test: Two-Sample for Variances
Fourier Analysis
Histogram
Moving Average
Random Number Generation
Rank and Percentile
Regression
Sampling
t-Test: Paired Two-Sample for Means
t-Test: Two-Sample Assuming Equal Variances
t-Test: Two-Sample Assuming Unequal Variances
z-Test: Two-Sample for Means
User's Guide (Book 2)
Chapter 1, "Analyzing and Calculating Data"



Chart Menu
Attach Text 

Adds a title to a chart or attaches text to an axis or data marker.
Add Arrow 

Adds an arrow to the active chart.
Delete Arrow 

Removes an arrow from the active chart.
Add Legend 

Adds a legend to the active chart.
Delete Legend 

Removes the legend from the active chart.
Axes 

Controls whether axes are visible on the active chart.
Gridlines 

Controls whether gridlines are visible on the active chart.
Add Overlay

Creates an overlay chart on the active chart.
Delete Overlay

Removes the overlay chart from the active chart.
Edit Series

Allows you to create or edit a data series on the active chart. 
Select Chart 

Selects the entire active chart.
Select Plot Area 

Selects the plot area of the active chart.
Protect Document

Prevents changes to a chart's data series, formats, or windows.
Unprotect Document

Removes protection.
Custom Palettes

Allows you to change the color palette for the active document or chart.
Color Palette

Allows you to edit the colors in the palette for the active chart or copy the colors from 
another document.

Calculate Now
Calculates open worksheets and redraws any open charts dependent on those 
worksheets.

Spelling
Checks the spelling of all chart text not linked to a worksheet cell.



Add Arrow and Delete Arrow Commands (Chart Menu)
Inserts an arrow in the active chart.    When an arrow is selected, the command name 
changes to Delete Arrow.

You can add as many arrows to your chart as you want.
Change the size and direction of an arrow by selecting the arrow and dragging one of 

the black selection handles.    You can also use the Size command on the Format menu and 
the arrow keys.

Move an arrow by dragging its shaft with the mouse.    You can also use the Move 
command on the Format menu and the arrow keys.
Shortcut: Arrow tool (Charting toolbar)
See Also

Help

Arrow Tool
Adding or deleting a chart arrow
Moving and sizing an arrow
Size Command (Format Menu)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



Add Legend and Delete Legend Commands (Chart Menu)
Add Legend places a legend along the right side of the active chart.    

The plot area is reduced to accommodate the legend.
The command name changes to Delete Legend.
You can move and format a legend with commands from the Format menu.

Shortcut: Legend tool (Charting toolbar)
Delete Legend removes a legend from the active chart.

The plot area returns to its original size.
The command name changes to Add Legend.
If you delete a legend and then add it again, the legend returns to the default format.
The legend can be moved using the mouse or the Legend command on the Format 

menu.
Shortcut: Legend tool (Charting toolbar)

See Also
Help

Legend Tool
Adding or deleting a legend
Formatting a legend
Legend Command (Format Menu)
Moving a legend

User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



Add Overlay and Delete Overlay Commands (Chart Menu)
Add Overlay creates an overlay chart on the active chart. 

If there is an even number of data series, the first half appears on the main chart and
the second half on the overlay chart.

If there is an odd number of data series, one more series appears on the main chart 
than on the overlay chart.    For example, in a chart with five data series, the first three 
appear on the main chart and the last two on the overlay chart.

The overlay chart is initially a line chart.
You cannot add an overlay chart to a 3-D chart.
You can change the distribution of series between the main and overlay charts with 

the Edit Series command on the Chart menu and the Overlay command on the Format 
menu.
Delete Overlay removes the overlay chart.

All data series on the overlay chart are returned to the main chart.
See Also

Help
Adding or deleting an overlay chart
User's Guide (Book 1)
Chapter 12, "Creating a Chart"



Attach Text Command (Chart Menu)
Places a title on a chart or axis or attaches a label to a data point.

If you select an axis or a data point before choosing Attach Text, Microsoft Excel 
selects that option in the dialog box for you.

If an axis or a data point moves or changes size, attached text stays with it.
Change attached text by selecting the title or label and entering new text.

Shortcut: Text Box tool (Charting toolbar)
Chart Title 

Attaches "Title" above the plot area.
Value (Y) Axis (or Value (Z) Axis)

For 2-D charts, attaches a "Y" centered on the value axis (y-axis).
For 3-D charts, this option changes to Value (Z) Axis, and attaches a "Z" centered on the 
value axis (z-axis).

Category (X) Axis
Attaches an "X" centered on the category (x) axis.

Series (Y) Axis
Attaches a "Y" centered on the series axis (y-axis).
This option is not available for 2-D charts.

Series and Data Point
Attaches the value of a data point to its marker in the chart.    For all charts except area 
charts, you must specify both the series number and the data point number.
In area charts, if you specify only the series number, this option attaches the text that 
you type to the center of the series area.

Overlay Value (Y) Axis
Attaches a "Y" centered on the overlay value axis.
This option is not available for 3-D charts.

Overlay Category (X) Axis
Attaches an "X" centered on the overlay category axis.
This option is not available for 3-D charts.

See Also
Help

Text Box Tool
Editing chart text
Formatting the chart text font
Formatting chart text alignment and orientation
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



Axes Command (Chart Menu)
Controls whether axes are visible on the active chart.

You can display or hide any available axis under Main Chart.
If there is an overlay chart, separate options are included for the overlay chart axes.

See Also
Help
Adding or deleting a chart title, an axis title, or a data marker label
Formatting an axis scale
Formatting axes patterns and tick mark and label location



Calculate Now Command (Chart Menu)
Calculates open worksheets and redraws any open charts dependent on those worksheets.

Microsoft Excel calculates according to the settings in the Calculation Options dialog 
box.    To change the settings, choose Calculation from the Options menu.
Shortcuts: F9

Calculate Now tool (Utility toolbar)
See Also

Help

Calculate Now Tool
Adjusting a data value by dragging a data marker
Calculation Command (Options Menu)
User's Guide (Book 1)
Chapter 13, "Editing a Chart"



Color Palette Command (Chart Menu)
Customizes the colors on the Microsoft Excel color palette and copies color palettes 
between documents.    You can customize colors in the color palette for worksheets, macro 
sheets, and chart documents.

If you do not have a color monitor, standard color names appear in the dialog box 
rather than the actual colors.    Customized colors have the names Color 1, Color 2, and so 
on.

If you are working with a worksheet, use the Color Palette command on the Options 
menu.

You can copy an object with a custom color from one document to another.    The 
color is copied along with the object.

The Color Palette command is not available for charts embedded in a worksheet.    To 
customize colors for an embedded chart, use the Color Palette command on the Options 
menu for the worksheet.

You can change the color by choosing the Edit button to open the color editing dialog 
box.    You can use the color box and the brightness bar, or change the values in the boxes 
below.

The boxes at the bottom of the color editing dialog box provide alternative systems 
for precisely setting the color.    One system uses hue, saturation, and luminosity.    The other 
uses the three primary colors used by color monitors: red, green, and blue.    These systems 
work independently.
Color Palette

Displays the color palette.
Copy Colors From

Contains the list of open documents from which you can copy a color palette.    
Selecting a document copies its palette to the active document.

Default
Resets the color palette to its original 16 colors.

Edit
Displays the color editing dialog box.    You can edit any of the original 16 colors on the 
color palette to create custom colors.

Color box
This is the large colored box. Clicking or dragging in this box changes the current color. 
This is reflected in the Color|Solid box; in the Hue, Sat (saturation), and Lum 
(luminosity) boxes; and in the Red, Green, and Blue boxes.

Brightness bar
This is the colored bar to the right of the dialog box. Dragging the arrow along this bar 
changes the amount of white and black in the current color. This has the same effect as
changing the value in the Luminosity box.

Color|Solid
The left side of this box displays the current color. The right side shows the nearest 
solid color. To use the nearest solid color to the one you have created, double-click the 
solid color.

Hue
The basic color: red, yellow, green, blue, and so on.    You can change the hue by typing
a value from 0 to 239 or by clicking the arrows. Changing this value has the same 
effect as dragging horizontally in the color box.

Sat (saturation)



A measure of how pure the color is; in other words, how different it is from gray.    You 
can change the saturation by typing a value from 0 to 240 or by clicking the arrows.    
Changing this value has the same effect as dragging vertically in the color box.

Lum (luminosity)
The lightness (amount of white) or darkness (amount of black) in the current color. You 
can change the luminosity by typing a value from 0 to 240 or by clicking the arrows. 
Changing this value has the same effect as dragging the arrow along the brightness 
bar.

Red, Green, Blue
Changing the amounts of red, green, and blue changes the overall color. You can 
change these values by typing values from 0 to 255 for each, or by clicking the arrows. 
Changing the red, green, and blue values is an alternate method of changing the hue, 
saturation, and luminosity.

See Also
Help
Copying color palettes between documents
Customizing colors in the color palette
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



Edit Series Command (Chart Menu)
Creates or edits a data series on the active chart.

The categories (x labels/values) are determined by the first data series in the main 
chart and the first data series in the overlay chart.    Category values in other series are 
ignored unless the chart is an xy (scatter) chart.

When you select the contents of one of the option boxes, the corresponding cells on 
the worksheet are surrounded by a moving border.    Selecting a different range of cells 
changes the contents of the option box. 
Series

Lists the names of all defined data series, in plot order.
If you select a data series before you choose Edit Series from the Chart menu, that series 
is selected.
Select New Series if you want to create a new series.

Name
Displays the name of the data series selected in the Series box.    If you do not enter a 
name, Microsoft Excel names the series Series N, where N is the same as the plot order.
The name can be an external absolute reference to a single cell, a name defined to be a 
single cell. It can also be text.    This name is the series name for the legend if there is 
one.

X Labels or X Values
Displays the category label reference for the first data series in the Series box.    If the 
chart is an xy (scatter) chart, displays the x-values reference for the series you select.
The reference can be an external reference to the worksheet and cells that contain the 
categories or x-values, a reference to a named range, or an array constant.

Y Values (Y Label for 3-D Chart)
For a 2-D chart, contains the values reference for the data series selected in the Series 
box.    
The reference can be an external reference to the worksheet and cells that contain the 
values, a reference to a named range, or an array constant.
For a 3-D chart, this option contains the text "Series Name" and cannot be edited.

Z Values
For a 3-D chart, contains the values reference for the data series selected in the Series 
box.    
The reference can be an external reference to the worksheet and cells that contain the 
values, a reference to a named range, or an array constant.
This option is not displayed for a 2-D chart.

Plot Order
Contains an integer (1, 2, 3, . . .) that defines the order in which the selected data series 
is plotted in the chart.    The data labels and values associated with the series remain 
associated with the series.

Define
Creates a newly defined data series or applies your changes to an existing data series 
without closing the dialog box.

Delete
Deletes the selected data series from the chart.    The data on the worksheet is not 
affected.



See Also
Help
Adding or editing series
Adjusting a data value by dragging a data marker
Deleting a data series
User's Guide (Book 1)
Chapter 13, "Editing a Chart"
Function Reference
SERIES Function



Gridlines Command (Chart Menu)
Controls whether the major and minor gridlines are visible on the active chart.

Gridlines extend from a chart axis across the plot area.
Major gridlines are aligned with tick marks.
Minor gridlines are positioned between tick marks.
To control spacing of gridlines, use the Scale command on the Format menu.

Shortcuts: Horizontal Gridlines tool (Charting toolbar)
Vertical Gridlines tool

See Also
Help

Horizontal Gridlines Tool
Vertical Gridlines Tool

Adding and deleting a tool from a toolbar
Adding or deleting gridlines
Formatting gridlines
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



Protect Document and Unprotect Document Commands (Chart 
Menu)
Protect Document protects a chart so that its data series and formats cannot be changed or 
its window cannot be moved, sized, or hidden.    Unprotect Document returns a chart to an 
unprotected state.

Before you can protect a chart, its window must be active.
The Protect Document command is not available when an embedded chart window is 

active.
To protect an embedded chart, use the Protect Document command on the Options 

menu for the worksheet.
Password

Any combination of letters, numbers, spaces, or symbols.
Passwords are case sensitive; lower-case and upper-case letters are regarded as different.
The password is optional; you can protect a document without using one.    The password 
is not displayed when you type it.    If you forget the password, you will not be able to 
unprotect the document.

Chart
Protects all aspects of the chart except window characteristics.

Windows
Prevents the chart window from being sized or moved; prevents the chart window from 
being closed except with the Close command on the File menu.

Password
If you assigned a password when you protected the chart, you must type the same 
password to remove protection.

See Also
Help
Close Command (File Menu)
Protecting chart data
Protecting a document
Protecting windows
Protecting worksheet cells
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



Select Chart Command (Chart Menu)
Selects the entire active chart.    When selected, the chart is surrounded by white selection 
squares.
Shortcut: Click just outside the plot area.
See Also

Help
Select Plot Area Command (Chart Menu)



Select Plot Area Command (Chart Menu)
Selects the plot area of the active chart.    When selected, the plot area is surrounded by 
white selection squares.
See Also

Help
Select Chart Command (Chart Menu)



Spelling Command (Chart Menu)
Checks the spelling of all text in the chart not linked to a worksheet cell.

To check text linked to a worksheet cell, switch to the worksheet and choose Spelling 
from the Options menu.
Shortcut: Check Spelling tool (Utility toolbar)
Change To/Suggestions

Type or select a replacement for the word not found in the dictionary.    
Add Words To

Select the dictionary to which you want to add words that are correctly spelled but not 
found in the main dictionary.    The first time you use the Spelling command, the 
dictionary CUSTOM.DIC appears in the Add Words To box.    The dictionary is empty until 
you add words to it.

Ignore
Leaves the selected instance of the word unchanged.

Ignore All
Leaves the selected word unchanged throughout the document.

Change
Changes the selected word to the word in the Change To box.

Change All
Changes the selected word throughout the document to the word in the Change To box.

Add
Adds the selected word to the dictionary in the Add Words To box.

Cancel/Close
Closes the dialog box.    The Cancel button changes to Close when you change a 
misspelled word or add a new word to the dictionary.

Suggest
Displays a list of proposed suggestions.    This button is dimmed if the Always Suggest box
is selected.

Ignore Words in UPPERCASE
Does not check the spelling of words that contain only capital letters.

Always Suggest
Causes a list of suggested words to be displayed whenever Microsoft Excel encounters a 
word that is not in the dictionary.

See Also
Help

Check Spelling Tool
Checking Spelling

Spelling Command (Options Menu)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



Control Menu
Restore

Restores the active document window or Microsoft Excel window to its former size and 
location.

Move
Displays a four-headed arrow you can use to reposition the active document window, 
Microsoft Excel window, or an open dialog box.

Size
Displays a four-headed arrow you can use to change the size of the active document 
window or Microsoft Excel window.

Minimize
Shrinks the active document window or Microsoft Excel window to an icon.

Maximize
Enlarges the active document window or Microsoft Excel window to fill the available 
space.

Close
Closes the active document window or an open dialog box.    Quits Microsoft Excel.

Switch To
Lists all currently open applications and activates the one you select.
Appears only on the Microsoft Excel Control menu.

Next Window
Switches to the next Microsoft Excel document window.
Appears only on the document Control menu.

Run
Displays the Run dialog box. Select the Clipboard, Control Panel, Macro Translator, or 
Dialog Editor option button.
Appears only on the Microsoft Excel Control menu.

Split
Switches to the next Microsoft Excel document window.
Appears only on the document Control menu.



Close Command (Control Menu)
Closes the active document window, or an open dialog box.    Quits Microsoft Excel.
Double-clicking the Control-menu box is the same as choosing the Close command.

Closing the Microsoft Excel window is the same as choosing the Exit command from 
the File Menu.

To close all of a document's windows, use the Close command on the File menu.
To close all open windows for all documents, use the Close All command on the File 

menu (hold down the SHIFT key and select the File menu).
Shortcuts: CTRL+F4 (document windows)

ATL+F4 (Microsoft Excel window or open dialog box)



Maximize Command (Control Menu)
Enlarges the active document window or Microsoft Excel window to fill the available space.
Clicking the Maximize button is the same as choosing the Maximize command.

The Microsoft Excel window fills the entire screen.
A document window fills the entire Microsoft Excel workspace. 
You can restore a maximized window to its former size by using the Restore 

command on the Control menu.
Shortcut: CTRL+F10 (document windows)
See Also

Help

Maximize button 



Minimize Command (Control Menu)
Shrinks the active document window or Microsoft Excel window to an icon.
Clicking the Minimize button is the same as choosing the Minimize command.

Double-clicking a minimized window icon restores the window to its former size.    You 
can also restore a minimized window by using the Restore command on the Control menu.
Shortcut: CTRL+F9 (document windows)
See Also

Help

Minimize button 



Move Command (Control Menu)
Displays a four-headed arrow.    Use the arrow keys to move the active document window, 
Microsoft Excel window, or open dialog box.

If the window is maximized, this command is unavailable.
You can also move a window that is not maximized, or an open dialog box, by 

dragging the title bar.
Shortcut: CTRL+F7 (document windows)



Next Window Command (Control Menu for Documents)
Switches to the next document window.
Shortcut: CTRL+F6 



Restore Command (Control Menu)
Restores the active document window or Microsoft Excel window to the size and location it 
had before you maximized or minimized the window.

You can also restore the size of a window by clicking its Restore button.
To restore a minimized window, click the icon and choose the Restore command, or 

double-click the icon.
Restoring a window does not affect changes made to the window with the Move or 

Size commands on the Control menu.
Shortcut: CTRL+F5 (document windows)
See Also

Help

Restore button



Run Command (Control Menu for Microsoft Excel)
Displays a dialog box from which you can run other applications.
This command appears on the Microsoft Excel Control menu.
Clipboard

Runs the Clipboard Viewer.    Use the Clipboard Viewer to see data cut or copied using the 
Cut and Copy commands on the Edit menu.

Control Panel
Runs the Windows Control Panel.    Use the Control Panel to adjust your computer's screen
color, font, port, mouse speed, desktop, network, printer, international, keyboard, 
date/time, and sound settings.

Macro Translator
Runs the Macro Translation Assistant.    Use the Macro Translation Assistant to convert 
Lotus 1-2-3 and Multiplan macros to Microsoft Excel macros.

Dialog Editor
Runs the Dialog Editor.    Use the Dialog Editor to create custom dialog boxes.

See Also
Help
Macro Translation Assistant--Lotus 1-2-3



Size Command (Control Menu)
Displays a four-headed arrow you can use to change the size of the active document 
window or Microsoft Excel window.    Press the arrow key (RIGHT, LEFT, UP, or DOWN) of the side 
you want to size, and the mouse pointer changes to an arrow.    You can then use the arrow 
keys to make the window the size you want.

If the window is maximized, this command is unavailable.
Shortcut: CTRL+F8 (document windows)



Switch To Command (Control Menu for Microsoft Excel)
Displays the Task List dialog box of Windows Program Manager.

For more information, see your Windows documentation.
Shortcut: CTRL+ESC



Split Command (Control Menu)
Displays a four-headed arrow you can use to split the window both horizontally and 
vertically.        Press the arrow keys (RIGHT, LEFT, UP, DOWN) to position the pointer where you 
want the splits to intersect; then press ENTER.



Data Menu
Form 

Displays a database form you use to view, change, add, and delete records.
Find 

Locates records in the database that match the criteria you define.
Exit Find 

Quits Find mode.
Extract 

Copies into an extract range all records from the database that meet the criteria you 
define.

Delete 
Deletes all records from the database that meet the criteria you define.

Series 
Fills a selected range of cells with one or more series of numbers or dates.

Set Database 
Defines the selected range of cells as a database.

Set Criteria 
Defines the selected range of cells as the criteria range you use to select records for 
search or extract operations.

Set Extract 
Defines the selected range of cells as an extract range to contain records extracted from 
the database.

Sort 
Rearranges the rows or columns of a selection according to the cell contents of the rows 
or columns you specify.

Table 
Creates a data table based on input values and formulas on a worksheet.

Parse 
Redistributes the contents of a range one column wide to fill several columns.

Consolidate 
Consolidates data from multiple ranges on multiple sheets into a single range.

Crosstabs* 
Creates a special data table to examine relationships between database fields.

* If this command does not appear on the Data menu, you need to install the Crosstab 
ReportWizard add-in macro.    For more information, see the Help topic on the Add-Ins 
command on the Options menu, or see Chapter 4, "Customizing Microsoft Excel" in Book 2 
of the Microsoft Excel User's Guide.



Consolidate Command (Data Menu)
Consolidates data from multiple ranges on multiple sheets into a single range.    For 
example, you could use consolidation to combine the totals from four quarterly reports 
(source areas) and display the summary totals in one range (destination area).

This command consolidates data to the destination area you select.
If you consolidate by category using labels, you must include in your source area 

selection the labels you want to appear in the destination area.    If you consolidate by 
position using references, you should not include category labels.

This command consolidates data by category using labels when source areas contain 
similar data, but source areas are arranged differently than destination areas.

This command consolidates data by position using references when source areas 
include similar categories of data arranged identically to destination areas.

This command optionally consolidates data with links to source worksheets.
If the destination area is a single cell, the area expands down and to the right to 

accommodate all categories from the source areas.
If the destination area is a single row, the area expands down to accommodate all 

row categories from the source data.    You can consolidate only as many column categories 
as there are columns in your initial selection.

If the destination area is a single column, the area expands to the right to 
accommodate all column categories from the source areas.    You can consolidate only as 
many row categories as there are rows in your initial selection.

If the destination area is a range of cells with multiple rows and columns, this 
command consolidates as many categories as will fit within the range.    If the destination 
area is not large enough to hold all consolidated information, only as many categories as will
fit into the selection will be consolidated.

If you consolidate data using labels, you can include category labels in the 
destination range to indicate where you want the consolidated totals to appear.
Function

Specifies the function Microsoft Excel will use to consolidate data.
Reference

Specifies a source area reference to add to the consolidation.
You can specify up to 255 source areas for Microsoft Excel to consolidate.    The 
worksheets containing the source areas do not have to be open during consolidation. 
Although you can use unsaved worksheets as sources of data, it is recommended that 
you save source worksheets before consolidation.

All References
Displays the source area references you have chosen for the consolidation. 

Use Labels In
Specifies whether to consolidate by category using labels or by position using references. 
If the Top Row check box is selected, labels in the top row of the source area are used as 
category names.    If the Left Column check box is selected, labels in the left column of the
source area are used as category names.    Labels must be identical in all source 
worksheets.    If you are consolidating by position using references, cell locations of similar
data must be identical in all source worksheets. If only one check box is selected, this 
command consolidates data using labels for the check box that is selected and by 
position for the check box that is cleared.

Create Links To Source Data
Creates links from the destination area to the source areas when you consolidate data so 
that the destination area will be automatically updated whenever the source data 
changes.



Microsoft Excel creates a linking formula for every cell and inserts rows or columns into 
the destination area to hold the linking formulas for each piece of source data.    The 
destination area is then outlined with linking formulas placed in hidden rows or columns 
subordinate to positions or categories in the destination area.

Browse
Opens a dialog box where you can select a file to add to the All References list from the 
files you have saved on disk. The name and complete path of the file you select will be 
pasted into the References box. You then add the cell or range reference to the area you 
want to include in the consolidation.

Add
Adds the source area reference specified in the Reference box to the consolidation. The 
new source area appears in the All References box.

Delete
Deletes the source area reference selected in the All References box.

See Also
Help
Consolidating data
Displaying outline levels
User's Guide (Book 1)
Chapter 11, "Working with Multiple Microsoft Excel Documents"



Delete Command (Data Menu)
Deletes all records from the database that meet the criteria you defined with the Set 
Criteria command on the Data menu.

A message appears asking for verification.
Other records in the database shift to fill in space.
This command can't be undone.    To preview the records before deleting, choose the 

Find command from the Data menu.
Do not include blank rows in the criteria range.    If you do, every record in the 

database will be deleted.
See Also

Help
Canceling the database, criteria, or extract range
Deleting records from a database
Editing records using a data form
User's Guide (Book 1)
Chapter 10, "Analyzing and Reporting Database Information"



Extract Command (Data Menu)
Finds database records that match the criteria defined in the criteria range and copies them
into the extract range.

The extract range must be a range outside of your database.    It can be either a 
range containing only field names or a range containing field names and cells that will 
contain the extracted data.

You can either enter the field names and select them or define the extract range 
using the Set Extract command on the Data menu before extracting data. 

If the extract range contains only field names, the extracted records are copied into 
cells below them.    All cells below the field names are cleared even if no extracted 
information is copied into them.

If the extract range contains both field names and cells below them, all cells in the 
range are cleared and as many extracted records as will fit are copied into the cells.

The Extract command can't be undone.
Unique Records Only

Extracts only one copy of repeated records.
See Also

Help
Databases
Defining a database
Extracting data from a database
User's Guide (Book 1)
Chapter 10, "Analyzing and Reporting Database Information"



Find and Exit Find Commands (Data Menu)
The Find command on the Data menu locates records in the database that match the 
criteria you define.    

You must define both a database range and a criteria range before using the Find 
command.

If a cell outside the database range is active, the Find command selects the first 
matching record; if a cell inside the database range is active, it selects the first matching 
record below that cell.

Until you exit Find mode, scrolling can locate only matching records within the 
database range.
The Exit Find command on the Data menu exits Find mode and returns scrolling to normal.

The Exit Find command appears on the Data menu while you're using the Find 
command.

You can also exit Find mode by choosing any other command, by selecting a cell 
outside the database range, by editing a cell, or by pressing ESC.
See Also

Help
Databases
Defining a database
Finding records in a database
User's Guide (Book 1)
Chapter 9, "Creating and Using a Database on a Worksheet"
Chapter 10, "Analyzing and Reporting Database Information"



Form Command (Data Menu)
Displays a database form you use to view, change, add, search for, and delete records.

Use this command to view one complete record at a time.
A database can contain as many records as you want.    However, the data form 

displays only as many fields as will fit in the form.    You cannot scroll the data form to view 
the remaining fields.

This command provides an alternative to the database commands for working with a 
database.

In the form, the left column of text lists database field names.
The contents of corresponding fields for one record in the database appear beside 

the field names.    Fields you can edit appear in text boxes.    You can't edit computed or 
protected fields.

The scroll bar shows your position in the database.
The position indicator in the upper-right corner of the form tells you which record is 

displayed and how many records there are, for example, 1 of 3.    The indicator changes to 
New Record when you scroll beyond the last nonblank record in the database.
New

Scrolls to the first blank record at the end of the database.    Adds a blank record there if 
none exists.    You can then add data to the new record's fields.

Delete
Deletes the data in the currently displayed record; the other records shift to fill in the 
space.    Deleted records can't be restored.

Restore
Restores edited fields in the displayed record, removing your changes.    You must restore 
before pressing ENTER or scrolling to another record.

Find Prev
Displays the previous record that matches criteria you defined with the Criteria button.    If
the criteria range in the data form is blank, displays the previous record in the database.

Find Next
Displays the next record that matches criteria you defined with the Criteria button.    If the
criteria range in the data form is blank, displays the next record in the database.

Criteria
Displays a dialog box in which you can use criteria to display matching records.
Does not affect criteria specified with the Set Criteria command on the Data menu.
The Clear button removes existing criteria used in this dialog box.

Form
Returns you to the regular data form.    Available only after you choose the Criteria button.

Close
Closes the data form.

See Also
Help
Editing records using a data form
Finding records using a data form
User's Guide (Book 1)
Chapter 9, "Creating and Using a Database on a Worksheet" 



Parse Command (Data Menu)
Redistributes the contents of a range one column wide to fill several columns.    

Use the Parse command after you import data from other applications into Microsoft 
Excel if several columns of data have been condensed into a single column.

The range you parse can have any number of rows but only one column.
The parse settings you create for the first cell in the range apply to all cells in the 

range.
Parsed data fills cells to the right of the column you are parsing.    If there is data in 

those cells, that data is replaced by the parsed data.    Make sure there are enough blank 
cells to the right of the range you are parsing to accommodate the data.
Parse Line

Displays the contents of the first nonblank cell in the selected range.    Brackets you set 
here determine how the contents of all cells in the range will be distributed into separate 
columns.
Microsoft Excel saves the parse line you used last for each worksheet.

Guess
Makes a best guess at where brackets should go in data displayed in the parse line.    You 
can modify the guess by adding or deleting brackets.

Clear
Removes all brackets from the parse line.

Destination
Displays the reference of the upper-left cell of the selection. Parsed data will replace 
original data if the destination is left unchanged. You can enter any single cell reference 
as the destination for your parsed data. Range references, range names, and external 
references are not allowed.

See Also
Help
Parsing imported data
User's Guide (Book 2)
Chapter 3, "Exchanging Data with Other Applications"



Set Criteria Command (Data Menu)
Defines the selected range of cells as the criteria range -- the range of cells that contain or 
will contain the criteria used to find, extract, or delete matching database records.

You can specify two types of criteria: comparison or computed.
Use comparison criteria when you want to find records whose data matches or falls 

within certain limits of specified criteria.
Use computed criteria if you want to test the database against the result of a formula

that refers to one or more fields in one or more records.
The criteria range can be any area on the worksheet outside your database range, or 

it can be on another worksheet.    You must set the criteria range before using the Extract, 
Delete, or Find command on the Data menu.

Microsoft Excel names the selection Criteria Range, which can be used like any other 
named reference.

The first row of the criteria range must contain one or more field names from the 
database; one or more rows below that must contain the criteria.

If the criteria range you define includes a blank row, all database records will be 
matched.

Once you define a criteria range, you can change the criteria as often as you like.    
A worksheet can have only one criteria range defined at a time.

See Also
Help
Canceling the database, criteria, or extract range
Defining a criteria range
Deleting records from a database
Extracting data from a database
Finding records in a database
Setting up a criteria range with comparison criteria
Using comparison criteria
Using computed criteria
User's Guide (Book 1)
Chapter 9, "Creating and Using a Database on a Worksheet"
Chapter 10, "Analyzing and Reporting Database Information"



Series Command (Data Menu)
This command fills the selected range of cells with one or more series of numbers or dates.   
The contents of the first cell or cells in each row or each column of the selection are used as
the starting values for the series.
You can also create a series of numbers or dates directly on a worksheet using the AutoFill 
feature. 
Series In

Fills series across rows or down columns.
Type

Linear 
Adds a step value to each cell value in turn.
Growth 
Multiplies the value of each cell in turn by your entry in the Step Value box.
Date
Calculates a series of dates according to your selected option under Date Unit.
AutoFill
Fills blank cells in a selection with a series based on data included in the selection.    
Overrides any entry in the Step Value box or any selected Date Unit option.
The following table shows samples of AutoFill operations on a selected cell or cells. 
Data in selection Series created
1, 2 3, 4, 5, 6,...
1, 3 5, 7, 9, 11,...
Mon Tues, Wed, Thurs,...
Qtr1 Qtr2, Qtr3, Qtr4, Qtr1,...
text1, textA text2, textA, text3, textA,...
1-Jan, 1-Mar 1-May, 1-Jul, 1-Sept,...

Date Unit
Determines whether a series of dates will increase by days, weekdays, months, or years.   
Used only when creating a Date series.

Step Value
The amount by which a series increases or decreases.    A positive number causes the 
series to increase; a negative number causes it to decrease.

Stop Value
The value at which you want the series to end.    If the selection is filled before the series 
reaches the stop value, the series stops at that point.    Can be left blank.

Trend
Creates a linear or exponential growth trend based on the values in the selected range.    
Calculates a step value from the existing values at the top or left of the selection to 
produce a best fit line (for linear series) or exponential curve (for growth series) based on 
those values. This calculated step value overrides anything entered in the Step Value box.
Trend overwrites the original values in your selection. For example, if the selection is one 
row high, begins with the values 1, 4, 5, and you enter a step value of 2 with the Linear 
Type option selected, the resulting series will be:
Linear Resulting series
Trend cleared 1, 3, 5, 7, 9, 11,...



Trend selected 1, 3.33, 5.33, 7.33, 9.33, 11.33,...
Using the same example with the Growth Type option selected, the resulting series will 
be:
Growth Resulting series
Trend cleared 1, 2, 4, 8, 16, 32, 64,...
Trend selected 1.21, 2.71, 6.07, 13.57, 30.35, 67.86,...

See Also
Help
Creating a trend series
Extending a series of numbers or dates
Fill Commands (Edit Menu)
Turning AutoFill on or off
Using AutoFill
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



Set Database Command (Data Menu)
Defines the selected range of cells as a database.

This command names the selection Database.
Make sure you include in the selection the field names and an extra blank row below 

the last record of your database.
Your database can include text, numbers, formulas, and functions.
A worksheet can have only one database defined at a time.

See Also
Help
Databases
Defining a database
User's Guide (Book 1)
Chapter 9, "Creating and Using a Database on a Worksheet" 



Set Extract Command (Data Menu)
Defines the selected range of cells as an extract range for extracting records from a 
database.

The extract range must be outside of your database and can be either a range 
containing field names only or a range containing field names and the cells that will contain 
the extracted data. 

Microsoft Excel names the range Extract.    You can use the name as you would any 
other named reference.

If the extract range contains only the field names, all cells below the field names to 
the bottom of the worksheet will be cleared when you extract data, whether or not 
information is extracted into them.    You cannot undo the Extract command.

If the extract range contains the field names and a range of cells beneath the field 
names, only the selected range will be filled with extracted data. If there is more data to 
extract than will fit into the selected range, a message is displayed.
See Also

Help
Canceling the database, criteria or extract range
Databases
Defining an extract range
Extracting data from a database
User's Guide (Book 1)
Chapter 10, "Analyzing and Reporting Database Information"



Sort Command (Data Menu)
Rearranges the rows or columns of a selection according to the contents of a key row or 
column within the selection.    You can sort with the Sort Ascending and Sort Descending 
tools on the Utility toolbar. Use the Toolbars command on the Options menu to display the 
Utility toolbar. Additional sort options are available using the Sort command on the Data 
menu.

This command can be used in any worksheet cell range, whether in a database or 
not.

When sorting a database, don't include field names in the selection.
You can specify up to three sort keys.    A sort key identifies which column to sort by 

when sorting rows, or which row to sort by when sorting columns.
You can refer to any cell in a row or column to identify that row or column as a sort 

key.
You can refer to a named cell to identify its row or column as a sort key.
If you use more than one sort key, columns or rows with duplicates in the first key are

sorted according to the second and third keys.
If you have not identified second and third keys, rows or columns with duplicates in 

the first key are left in the order in which they are found.
To sort more than three levels, sort more than once using the least significant keys 

first.
Sort by

Specifies whether to sort by rows or columns.
1st Key

Identifies the column to sort by when sorting rows or the row to sort by when sorting 
columns.    Select a cell (or type any cell reference or name) from the column or row you 
want to sort by.    Specifies whether to sort in ascending or descending order.

2nd Key
Sorts duplicates in the first key column or row according to the additional key you specify.

3rd Key
Sorts duplicates in the second key column or row according to the additional key you 
specify.

See Also
Help

      Sort Ascending tool
      Sort Descending tool

Sorting a range of cells
Sorting with more than three keys
Toolbars Command (Options Menu)

User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"
Chapter 9, "Creating and Using a Database on a Worksheet"



Table Command (Data Menu)
Creates a data table based on input values and formulas you define on a worksheet.

Use this command to show the results of substituting different values in one or more 
formulas.

For a one-input table, enter the reference of either the row input cell or the column 
input cell; for a two-input table, enter both.

You cannot create a table on a macro sheet.
Row Input Cell

Specifies the input cell reference if the input values are in a row.
Column Input Cell

Specifies the input cell reference if the input values are in a column.
See Also

Help
Filling in a one-input data table
Filling in a two-input data table
User's Guide (Book 2)
Chapter 1, "Analyzing and Calculating Data"



Edit Menu
Undo

Reverses certain commands or actions.
Repeat 

Repeats the last command you chose.
Cut 

Removes the selection and places it onto the Clipboard.
Copy 

Copies the selection and places it onto the Clipboard.
Copy Tool Face 

Copies the picture on the selected tool onto the Clipboard.    This command appears only 
when the Customize dialog box or the Toolbars dialog box is displayed.

Copy Picture 
Copies a picture of the current selection and places it onto the Clipboard.    From the 
Clipboard, you can paste it into another application.    This command appears only when 
you hold down SHIFT and select the Edit menu.

Paste 
Pastes the contents of the Clipboard into a worksheet, chart, or group, or into the formula 
bar.

Paste Tool Face 
Pastes the picture on the Clipboard onto the selected tool.    This command appears only 
when the Customize dialog box or the Toolbars dialog box is displayed.

Clear 
Removes the selected object or the data, formats, or both from the selected worksheet 
cells.    If the active document is a chart, removes the chart data series or formats, or the 
selected item.    If a workbook window is active, removes the selected document from the 
workbook without deleting it.

Paste Special 
Pastes selected attributes of copied cells into the current selection on the active 
worksheet or group, or if the active document is a chart, pastes data series from a 
worksheet or another chart into the active chart.    

Paste Picture 
Pastes the contents of    the Clipboard as a picture into a Microsoft Excel worksheet or 
macro sheet or into another application.    This command appears only when you hold 
down SHIFT and select the Edit menu.

Paste Link 
Pastes copied data into the selection and creates a link with the source data.

Paste Picture Link 
Pastes the contents of the Clipboard as a picture into a Microsoft Excel document and 
creates a link between the picture and the source data.    This command appears only 
when you hold down SHIFT and select the Edit menu.

Delete 
Removes selected cells from a worksheet and shifts surrounding cells to fill the space.

Insert 



Inserts a range of cells equivalent in size and shape to the selection, and shifts the 
selection to accommodate new cells.    In a workbook, inserts existing, open documents 
(worksheets, charts, or macro sheets) into the workbook.

Insert Object
Inserts a new embedded object in a Microsoft Excel document.

Insert Paste 
Inserts the contents of the Clipboard between existing cells.    This command is only 
available immediately following the use of Cut or Copy.

Fill Left 
Copies the contents and formats of the cells in the right column of a selected range into 
the remaining cells in the selection.    This command appears only when you hold down 
SHIFT and select the Edit menu.

Fill Right 
Copies the contents and formats of the cells in the left column of a selected range into 
the remaining cells in the selection.

Fill Down 
Copies the contents and formats of the cells in the top row of a selected range into the 
remaining cells in the selection.

Fill Up 
Copies the contents and formats of the cells in the bottom row of a selected range into 
the remaining cells in the selection.    This command appears only when you hold down 
SHIFT and select the Edit menu.

Fill Group 
Copies the contents of the active sheet's selection to the same area on all sheets in the 
group.



Clear Command (Edit Menu)
Worksheets

Removes the selected object or the formats, formulas, notes, or all three, from the 
selected cells.    If the selection is in the formula bar, removes the selected characters.    
For detailed information, see Clear Command (Worksheet).

Charts
Removes the selected item or the data series, formats, or both from the selected chart.    
If the selection is in the formula bar, removes the selected characters.    For detailed 
information, see Clear Command (Chart).

Workbooks
Removes the active document from the workbook but does not delete it.



Clear Command (Edit Menu for Charts)
When a chart is selected, removes data series, chart formats, or both.    If the selection is in 
the formula bar, removes selected characters.    If an item (such as the chart title or the 
legend) is selected, removes the item. 
Shortcut: DEL

All
Clears all data series and chart formats.    This option appears in the dialog box when the 
entire chart is selected.

Formats
Removes formats only; the data is not affected.    This option appears in the dialog box 
when the entire chart or a data series is selected.
Shortcut: Clear Formats tool

Formulas
Removes all data series, leaving chart formats unchanged.
Removes a single data series, if you select the series and then choose Edit Clear.
This option only appears in the dialog box when the entire chart is selected.
Shortcut: Clear Formulas tool

Series
Removes data series when a series or a single point of a series is selected.    This option 
appears in the dialog box only when a data series or a single point is selected.

See Also
Help

Clear Formulas Tool
Clear Formats Tool



Clear Command (Edit Menu for Worksheets)
Removes the contents, formats, notes, or all three from selected cells in the worksheet.    If a
graphic object or embedded chart is selected, removes the object or chart.

A worksheet formula containing a reference to a cleared cell assumes that the cell 
has a value of zero.

The Delete command removes not only the contents of the selected cells, but the 
cells themselves.    A formula containing a reference to a deleted cell displays the #REF! 
error value.    
Shortcuts: DEL    (displays the Clear dialog box)

CTRL+DEL    (clears formulas from the selection)
All

Removes contents, formats, and notes from selected cells.
Formats

Removes formats only; cell formulas and notes are unchanged.    The cells return to 
General format.
Shortcut: Clear Formats tool

Formulas
Removes cell contents from selected cells without affecting formats or notes.
Shortcut: Clear Formulas tool

Notes
Removes notes from selected cells, but leaves contents and formats intact.

See Also
Help

Clear Formulas Tool
Clear Formats Tool

Clearing data from cells



Copy Command (Edit Menu)
Copies the selection onto the Clipboard. The selection can be a cell, cell range, formula bar 
selection, chart, graphic object, or document within a workbook (worksheet, chart, or macro
sheet).

To copy a picture of a cell range or chart to another Microsoft Excel document or to 
another application, use the Copy Picture command.    This command appears only when you
hold down SHIFT and select the Edit menu.
Shortcuts: Copy tool

CTRL+C

Worksheets
If the selection is a single cell, a cell range, or a nonadjacent selection and you 

choose Paste after choosing Copy, cell contents and formats are copied.    If you choose 
Paste Special, specified cell attributes are copied.    If you choose Insert Paste, cell contents 
and formats are copied and inserted between existing cells.

If your selection contains hidden rows or columns that you don't want to copy, you 
can select only the visible cells in the worksheet using the Select Special command from the 
Formula menu or the Select Visible Cells tool on the Utility toolbar.

Choosing Copy surrounds selected cells with a moving border.
Formula Bar

If the formula bar is active, choosing Copy copies selected characters onto the 
Clipboard.    You can then paste the contents of the Clipboard into another part of the same 
formula, formulas in other cells, or another application.
Charts

If an embedded chart is selected, choosing Copy copies the entire embedded chart.
If a chart within a chart document or open embedded chart is selected, choosing 

Copy copies data series and formats, which you can then paste into another Microsoft Excel 
document.

Choosing Copy surrounds the chart with a moving border.
Workbooks

After copying a worksheet in a workbook window, you can paste a copy into the same
workbook, another workbook, or a non-workbook window. The Save As dialog box appears so
you can give the copy a new name. The copy has no links to the original worksheet.
See Also

Help

Copy Tool
Copying a chart to a worksheet
Copying cells to multiple locations
Copying color palettes between documents
Copying data from a worksheet and saving it in a separate file
Copying data
Copying a cell's value, formula, formatting, or note
Copying styles from another document
Copying to a range of adjacent cells
Copying visible cells
Copying within and between worksheets
Copying within the formula bar

User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"





Copy Picture Command (Edit Menu)
Copies a picture of the selected cell, cell range, graphic object, or chart onto the Clipboard.   
From the Clipboard, you can paste the picture into another application.

Appears on the Edit menu in place of the Copy command when you hold down SHIFT 
and select the Edit menu.
Appearance

Select the As Shown On Screen option button to paste the selection into a Microsoft Excel 
worksheet.
Select the As Shown When Printed option button to paste the selection into another 
application.

Size (Charts Only)
As Shown On Screen copies the selection so it is the same size as appears on the screen.  
The picture size varies according to the size and shape of the chart window.
As Shown When Printed copies the selection so it is the same size as it would appear 
when printed.    The picture size varies according to the size and shape of the chart 
window, the capabilities of your printer, and the Size option in the Page Setup dialog box.

Format
Picture 
Copies the picture in Windows metafile format. This format can be displayed on screens 
with varying resolutions. 
Bitmap 
Copies the picture in bitmap format. The bitmap can be displayed correctly only on a 
screen of the same type and resolution as the screen from which it was copied.



Cut Command (Edit Menu)
Removes the selection from the document and places it onto the Clipboard.    The selection 
can be a cell, cell range, characters in the formula bar, embedded chart, graphic object, or a
document within a project (worksheet, chart, or macro sheet).

When you cut characters in the formula bar, the characters are deleted and placed 
on the Clipboard.    The cut characters are then available for pasting to a new location in the 
same formula or into a formula in another cell.

When you cut cells on a worksheet, Microsoft Excel surrounds the selected cell or cell 
range with a moving border.

Within a worksheet, the selection to be cut must be a single, continuous, rectangular 
area.

Within a worksheet, if Cut is followed by Paste, the cell contents and formats are 
pasted into the paste area; if Cut is followed by Insert Paste, the cell contents and formats 
are inserted between existing cells.

To completely remove selected cells and shift other cells to fill the space, use the 
Delete command.

Within a project window, use Cut and Paste to rearrange the order of worksheets or to
move a worksheet from one project to another.
Shortcuts: Cut tool

CTRL+X
SHIFT+DEL or SHIFT+DELETE

See Also
Help

Cut Tool
Moving cells and data

User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"



Delete Command (Edit Menu)
Removes selected cells, rows, or columns from a worksheet, including the contents and 
formats contained within the selection.    Surrounding cells shift to fill the space.

If you delete an entire row or column, rows or columns are shifted to fill the space.
If you select less than an entire row or column, a dialog box appears asking whether 

to shift the surrounding cells up or to the left, or to delete the entire column or row.
A worksheet formula containing a reference to a deleted cell displays the #REF! 

value.
To remove the contents, formats, or both from selected cells, but not the cells 

themselves, use the Clear command. A worksheet formula containing a reference to a 
cleared cell assumes that the cell has a value of zero.
Shortcuts: Delete tool

CTRL+MINUS SIGN

Shift Cells Left 
Shifts surrounding cells to the left.

Shift Cells Up
Shifts surrounding cells up.

Entire Row
Deletes the entire row and shifts entire rows to fill the space.

Entire Column
Deletes the entire column and shifts entire columns to fill the space.

See Also
Help

Delete Tool
Deleting cells, rows, or columns



Fill Commands (Edit Menu)
Copy the contents and formats of cells along one side of a selected range into the 
remaining cells in the selection.

Copied contents and formats replace existing contents and formats.
To display Fill Left and Fill Up, hold down SHIFT and select the Edit menu. In this case, 

they replace Fill Right and Fill Down.
Fill Right appears dimmed when the selection is only one column wide; Fill Down 

appears dimmed when the selection is only one row high.
If your selection contains hidden rows or columns that you don't want to include, you 

can select only the visible cells using the Select Special command on the Formula menu or 
the Select Visible Cells button on the Utility toolbar.
Shortcuts: Fill Down tool

Fill Right tool
CTRL+R or CTRL+> (Fill Right)
CTRL+D or CTRL+< (Fill Down)

Fill command Copies
Fill Down Top row
Fill Right Left column
Fill Up Bottom row
Fill Left Right column
Fill Group Selection to same position on all other sheets in the group

See Also
Help

Fill Down Tool
Fill Right Tool

Copying data and formats to all sheets in a group
Copying to a range of adjacent cells
Copying visible cells
Fill Group Command (Edit Menu)
Series Command (Data Menu)
Turning AutoFill on or off
Using AutoFill



Fill Group Command (Edit Menu)
Copies the contents of the range of cells selected on the active worksheet to the same 
range of cells in all the other sheets in a group.    This command is available only if a group 
is active.
All

Copies all data and formats.
Formulas

Copies all data.    Formats are unchanged.
Formats

Copies formats only.    Data is unchanged.



Insert Command (Edit Menu)
Inserts a row, column, or range of blank cells equivalent in size and shape to the selected 
cell range, or inserts a selection you defined with the Copy or Cut command.    The selected 
rows, columns, or cells are shifted to accommodate the insertion.    In a workbook, inserts 
existing, open documents (worksheets, charts, or macro sheets) into the workbook.
Shortcuts: Insert tool

CTRL+PLUS SIGN

Worksheet or Macro Sheet
After selecting a cell or range of cells, you can choose the Insert command and specify 
the kind of insertion you want.
Shift Cells Right

Shifts the existing cells to the right when inserting.
Shift Cells Down

Shifts the existing cells down when inserting.
Entire Row

Inserts an entire row above the selection.
Shortcut: Insert Row tool

Entire Column
Inserts an entire column to the left of the selection.
Shortcut: Insert Column tool

See Also
Help

Insert Tool
Insert Column Tool
Insert Row Tool

Inserting cells, rows, or columns



Paste Command (Edit Menu)
Pastes the contents of the Clipboard into a worksheet, macro sheet, or chart, into the 
formula bar, or into a workbook window.
Shortcuts: Paste tool

ENTER
CTRL+V
SHIFT+INS

Worksheet
Choosing this command pastes the contents and formats of copied or cut cells into 

the selected cells.
The paste area can be a single cell, a cell range, or a graphic object.
If the paste area is a graphic object, choosing Paste creates a new graphic object 

consisting of a picture of the copied cells.
If the paste area is a single cell, this cell is the upper-left corner of the paste area; the

rest of the copied data is pasted down and to the right.
If you choose Cut before pasting and you are pasting into a cell range, the paste area

must be the same size and shape as the cut area.
If you choose Copy before pasting, you can paste multiple copies, either 

simultaneously or sequentially.
Chart

Choosing Paste creates a data series from copied worksheet cells and pastes them 
into the active chart.

You can also copy an entire chart and paste it into another chart.    The copied chart's 
data series are added to the active chart, and its format replaces the active chart's format.

To control how data series are organized and plotted, use the Paste Special 
command.
Formula Bar

Choosing Paste inserts the contents of the Clipboard into the formula bar at the 
insertion point.

If any characters in the formula bar are selected, those characters are replaced with 
the Clipboard contents.
Workbook

Choosing Paste inserts a previously cut document above the selection in the 
workbook window.

Choosing Paste inserts a copy of a previously copied document in a workbook 
window. If the copy is being inserted into the same workbook, the Save As dialog box 
appears so you can give the copy a new name.
See Also

Help

Paste Tool
Copying a chart to a worksheet
Copying cells to multiple locations
Copying data
Copying to another worksheet or application
Copying within the formula bar
Moving cells and data

User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"
Chapter 13, "Editing a Chart"





Insert Object Command (Edit Menu)
Inserts a new embedded object in a Microsoft Excel document.    

The dialog box displays a list of objects you can embed.
The list is determined by the applications you have installed.



Insert Paste Command (Edit Menu)
Inserts the contents of the Clipboard between existing cells.    The existing cells shift to 
accommodate the inserted cells.

When you copy or cut a selection using the Copy or Cut command, the Insert 
command changes to Insert Paste.

If you cut or copy an entire row and then choose Insert Paste, the new row is inserted 
above the selected row.

If you cut or copy an entire column and then choose Insert Paste, the new column is 
inserted to the left of the selected column.

Unless you cut or copied entire rows or columns, a dialog box is displayed for you to 
specify which direction existing cells will shift to accommodate the pasted cells.
Shift Cells Right

Shifts the existing cells to the right when inserting.
Shift Cells Down

Shifts the existing cells down when inserting.



Paste Link Command (Edit Menu)
Pastes copied data into the selected cells and establishes a link with the source of the data.

When the source data changes, the pasted data reflects those changes.
The source can be another Microsoft Excel worksheet or another application.
If the source is a Microsoft Excel worksheet, the source selection must be a single cell

or a range of cells.
If the source is more than one cell, Paste Link pastes an array.
The paste area can be a single cell, a cell range, or a named range.
If the paste area is a single cell and the source is another Microsoft Excel worksheet, 

the upper-left cell of the copied area is pasted into the paste area, filling the rest of the 
range downward and to the right.

If the paste area is a range and the source is another Microsoft Excel worksheet, the 
paste area should be the exact size and shape of the copied area.
See Also

Help
Copying visible cells
Creating links between documents
User's Guide (Book 2)
Chapter 3, "Exchanging Data with Other Applications"



Paste Picture Command (Edit Menu)
Pastes a picture of the contents of the Clipboard into a Microsoft Excel document.

This command appears on the menu when you hold down SHIFT and select the Edit 
menu.

You can move or size a picture as you would any other graphic object.



Paste Picture Link Command (Edit Menu)
Pastes a picture of the contents of the Clipboard into a Microsoft Excel document and 
creates a link between the picture and the document from which it came.

This command appears on the menu when you hold down SHIFT and select the Edit 
menu.

When the source document changes, the pasted picture reflects those changes.
You can move and size a linked picture as you would any other graphic object.

Shortcut: Camera tool (Utility toolbar)
See Also

Help

Camera Tool
Displaying and hiding a toolbar
Toolbars Command (Options Menu)

User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Paste Special Command (Edit Menu)
Worksheets

Pastes values, formats, formulas, or notes of copied cells into the selected cells on the 
active sheet or group.    This command also combines copied data with data in the paste 
area, transposes data, and pastes data copied from other applications.    For detailed 
information, see Paste Special (Worksheet).

Charts
Pastes data series from a worksheet or another chart into the active chart.    For detailed 
information, see Paste Special (Chart).

See Also
Help
Adding data to a chart from a worksheet
Copying specific cell attributes



Paste Special Command (Edit Menu for Charts)
Controls how the data series are organized and plotted when pasted from a worksheet or 
another chart.

Dialog box options vary, depending on what type of chart you are pasting into and 
whether you paste from a worksheet or from another chart.
Pasting from a Worksheet

The following dialog box options appear if you start by copying worksheet cells.    The first
two check boxes in the dialog box change, depending on which options you select in the 
Values In box.
Rows

Uses the contents of each row in the copied selection to create the data series.
Columns

Uses the contents of each column in the copied selection to create the data series.
Series Names In First Column (or Row)

If Rows is selected under Values In, uses the contents of the cell in the first column of 
each row as the name of the data series in that row. 
If Columns is selected under Values In, uses the contents of the cell in the first row of 
each column as the name of the data series in that column.
If cleared, uses the contents of the first cell as the first data point in the data series.
This option changes to Series Names (Y Labels) In First Column/Row when a 3-D chart is
the active document.

Categories (X Labels) In First Row (or Column)
If Rows is selected under Values In, uses the contents of the first row of the selection as
the chart categories.    
If Columns is selected under Values In, uses the contents of the first column of the 
selection as the chart categories. 
If cleared, uses the contents of the first row or column as the first data series in the 
chart.
This option changes to Categories (X Values) In First Column/Row when an xy (scatter) 
chart is the active document.

Replace Existing Categories
Replaces the existing chart categories with the categories you are pasting.
Available only when Categories In First Column/Row is selected.

Pasting from a Chart
If you start by copying data series from another chart, the following dialog box options 
appear:
All

Pastes both the data series and their formats from the copied chart into the active 
chart.

Formats
Replaces the format of the active chart with the format of the copied chart.    Does not 
affect the data in the chart you're pasting into.

Formulas
Adds data series from the copied chart to any data series already on the active chart.    
Does not change the format of the chart you're pasting into.



See Also
Help
Adding data to a chart from a worksheet
Copying a chart's series or formats
User's Guide (Book 1)
Chapter 13, "Editing a Chart"



Paste Special Command (Edit Menu for Worksheets)
Pastes the values, formats, formulas, or notes of the copy area you defined with the Copy 
command into the cells in the current selection.    Paste Special also controls how data 
copied from an application other than Microsoft Excel is pasted.

Paste Special does not paste a selection defined with the Cut command.
The paste area can be a cell, cell range, or nonadjacent selection.    If the paste area 

is a single cell, Paste Special uses this cell as the upper-left corner of the paste area and 
pastes the rest of the copied area down and to the right.    If the paste area is a range or 
nonadjacent selection, it must be able to contain one or more rectangles the exact size and 
shape of the copied area.

If a group is active, Paste Special pastes properties of the copied area of each sheet 
into the corresponding paste area on each sheet in the group.

Paste Special can be used to combine the formulas or values in the copied cells with 
the formulas or values in the paste area cells.    You specify whether the copied formulas or 
values are added to, subtracted from, multiplied by, or divided into the contents of the paste
area cells.

Paste Special can also be used to transpose a range of values.
Dialog Box Options When Copied Data is From Microsoft Excel

All
Pastes all cell attributes.

Formulas
Pastes only formulas as entered in formula bar.

Values
Pastes only values as displayed in cells.

Formats
Pastes only cell formats.

Notes
Pastes only cell notes.

None
Completely replaces the cells in the paste area with the cells from the copy area.    

Add
Adds copied formulas or values to those of the cells in the paste area.

Subtract
Subtracts copied formulas or values from those of the cells in the paste area.

Multiply
Multiplies copied formulas or values by those of the paste area.

Divide
Divides copied formulas or values into those of the paste area.

Skip Blanks
Does not paste blank cells from the copy area to your paste area, so copying a blank 
cell will not delete the existing data in the corresponding cell in your paste area.

Transpose
Switches the orientation of data when you paste it.    Data from the top row of the 
copied area appears in the left column of the paste area; data from the left column 
appears in the top row.



Dialog Box Options When Copied Data is From Another Application
Data Type

This lists the different forms in which the data can be pasted into Microsoft Excel.    For 
example, text copied from a Microsoft Word document can be embedded into a 
Microsoft Excel worksheet as a Microsoft Word object or copied into cells as either 
formatted or unformatted text.    When copied into cells, the text can be edited and 
formatted just as text in any worksheet cell.    If you select a Microsoft Word object, the 
object can be moved and sized just like an embedded chart or a graphic object.    
Double-clicking the object opens it in Microsoft Word so that you can edit it.

Paste Button
Choosing this button pastes the information from the Clipboard into the worksheet.    No
link is established to the source document.

Paste Link Button
Choosing this button links the pasted information to its source document.    Unavailable 
if a link cannot be established.

See Also
Help
Combining copied formulas or values with those in the paste area
Combining values on different worksheets
Converting a formula to its displayed values
Copying a cell's value, formula, formatting, or note
User's Guide (Book 1)
Chapter 6 "Editing a Worksheet"



Repeat Command (Edit Menu)
Repeats the last command you chose, if possible, including any dialog box settings.

The command name reflects the command to be repeated; for example, Repeat 
Display, Repeat Alignment.

This command is useful for applying the same formats to different groups of cells or 
different chart items.

Can't Repeat appears on the Edit menu instead of Repeat if the last command you 
chose is not repeatable.
Shortcuts: Repeat tool (Utility toolbar)

ALT+ENTER
See Also

Help

Repeat Tool
Displaying and hiding a toolbar
Toolbars Command (Options Menu)



Undo Command (Edit Menu)
Reverses certain commands, or deletes the last entry you typed.

The command name reflects the command or action to be undone; for example, 
Undo Cut; Undo Typing.

Can't Undo appears on the Edit menu if you cannot undo the previous action.
Immediately after you undo an action, this command changes to Redo, allowing you 

to restore what you reversed.
Shortcuts: Undo tool (Utility toolbar)

CTRL+Z
ALT+BACKSPACE

See Also
Help

Undo Tool
Displaying and hiding a toolbar
Toolbars Command (Options Menu)



Delete Tool Command
Removes the selected tool from the toolbar.    You can only delete custom tools.

This command appears on the shortcut menu for a tool only when the Customize 
dialog box or the Toolbars dialog box is displayed.    To display either of these dialog boxes, 
choose Customize or Toolbars from the toolbar shortcut menu.

You cannot delete built-in tools.
See Also

Help
Adding and deleting a tool from a toolbar
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



Copy Tool Face Command (Edit Menu)
Copies the picture on the selected tool onto the Clipboard.    From the Clipboard, you can 
paste the picture onto another tool.

This command appears on the Edit menu and the shortcut menu for a tool only when 
the Customize dialog box or the Toolbars dialog box is displayed.    To display either of these 
dialog boxes, choose Customize or Toolbars from the toolbar shortcut menu.
See Also

Help
Customizing the appearance of a tool
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



Paste Tool Face Command (Edit Menu)
Pastes the picture on the Clipboard onto the selected tool.

This command appears on the Edit menu and the shortcut menu for a tool only when 
the Customize dialog box or the Toolbars dialog box is displayed.    To display either of these 
dialog boxes, choose Customize or Toolbars from the toolbar shortcut menu.

The picture can be copied from another tool, or it can be an object drawn in Microsoft
Excel or another application.
See Also

Help
Customizing the appearance of a tool
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



Reset Tool Face Command
Restores the original appearance of a tool.

This command appears on the shortcut menu for a tool only when the Customize 
dialog box or the Toolbars dialog box is displayed.    To display either of these dialog boxes, 
choose Customize or Toolbars from the toolbar shortcut menu.
See Also

Help
Customizing the appearance of a tool
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



File Menu
New

Creates a new worksheet, chart, macro sheet, workbook, slideshow, or a document based
on one of the templates you have created.

Open
Opens an existing document or lets you import information from a different application.    
Also used for changing directories and drives.

Close
Closes all windows of the active document.

Close All
Closes all windows of all open Microsoft Excel documents.

Close Workbook
Closes the active workbook and all bound and unbound workbook documents.

Links
Opens documents linked to the active document, or changes those links.

Save
Saves changes made to the active document.

Save As
Saves a new document or a new version of an existing document in the file format and 
with the filename you specify.    Also used for saving a file in a different directory or drive.

Update
Updates information in an application containing a Microsoft Excel object.

Save Workbook
Saves all changes made to all documents in the workbook.

Delete
Removes from a disk the document you specify.

Record Macro**
Creates a new macro sheet and starts recording your actions as a macro.

Unhide**
Makes a hidden window visible.

Print Preview
Displays the document's pages so you can see how they will look when printed.

Page Setup
Controls the appearance of items such as headers, footers, and margins on the 
document's printed pages.

Print
Prints the active document according to the selections you make in the Print dialog box.

Print Report*
Prints a sequence of views and scenarios.

1,2,3,4
Lists the last four files you opened.



Exit
Ends your Microsoft Excel work session.

Send Mail***
Sends Microsoft Excel files to other users through Microsoft Mail or other mail clients that 
suppport the Windows simple mail interface (SMI).

* If this command does not appear on the File menu, run the Setup program to install it.    
For more information, see Chapter 4, "Customizing Microsoft Excel," in Book 2 of the 
Microsoft Excel User's Guide.
** These commands appear only when all windows are closed or hidden.
*** Available only with Microsoft Mail version 2.0 or later.



1,2,3,4 Commands (File Menu)
Refers to the files listed at the bottom of the File menu.    The names on the list are the last 
four files you opened.    To open one of these files, select the filename you want from the 
list.    You do not need to choose the Open command from the File menu to open one of 
these files.



Close and Close All Commands (File Menu)
Close Command
Closes the active document and all of its windows.    If you have made any changes to the 
document, you will be asked if you want to save those changes.

If you have several windows open for the same document and only want to close one 
of them, switch to the window you want to close, and then use the Close command on the 
Control menu.
Shortcut: CTRL+F4

Close All Command
Closes all windows of all open Microsoft Excel documents.

To display the Close All command, hold down SHIFT and select the File menu.
If you have made changes to any of the open documents, you will be asked if you 

want to save those changes.
The Close All command does not close add-in macros.

Shortcut: SHIFT+F4

See Also
Help
Close Command (Control Menu)
Closing the active document
Quitting Microsoft Excel
Switching to or closing a document window



Delete Command (File Menu)
Permanently removes selected documents from the disk.

After you choose the OK button, Microsoft Excel asks you to verify the deletion.
This command can be undone only if the deleted document is still displayed on your 

screen.    If it is displayed, you can save it again with the Save As command on the File 
menu.
File Name

Displays *.* as the default until you type the name of the file you want to delete, or select
the file you want from the File Name box.

Directories
Lists the current directory and any subdirectories.

List Files Of Type
Lists the available file formats.

Drives
Lists the available drives.

See Also
Help
Deleting a file from a disk
Deleting a chart document or an embedded chart



Exit Command (File Menu)
Ends your Microsoft Excel work session.

If you have made changes to any open document, you are asked if you want to save 
those changes.

The contents of the Clipboard are also saved when you quit.    If a cut or copied 
selection is surrounded with a moving border when you quit, Microsoft Excel copies the 
selection to the Clipboard.
Shortcut: ALT+F4
See Also

Help
Quitting Microsoft Excel



Links Command (File Menu)
Lists the source documents for the active dependent worksheet.    Provides options you can 
use to change the links in linked documents.    The available options vary, depending on the 
type of link specified in the Link Type box.
Link Type

Select the type of link you want to display in the Links box.
Links

Lists the names of source documents of the type specified in the Link Type box.
Open

Opens the selected source document.
Close

Cancels the command and closes the Links dialog box.
Read Only

Opens the selected source document as read-only.
Change

Displays the Change Links dialog box, which you can use to redirect links to the 
dependent worksheet.
Type the name of the document to which you want to redirect links, or select the 
document's name from the File Name box.    The filenames displayed in the File Name box
are contained in the current directory.    If the document you want is in a different 
directory, select the directory you want from the Directories box.

Update
Updates the active dependent document with information from the selected source 
documents.

Options
Displays the DDE/OLE Options dialog box.    The Options button is unavailable if Excel 
Links is specified in the Link Type box.
Automatic

Select the check box if you want the linked data to be updated automatically.
See Also

Help
Creating links between documents
Disabling updating of all links on a worksheet
Linking and Embedding
Opening source documents for the active worksheet
Recalculating linked worksheets
Redirecting links to source documents
Replacing a source worksheet with another worksheet
Saving new unnamed linked worksheets
Updating information in linked documents
Viewing a list of source documents for a dependent worksheet

User's Guide (Book 1)
Chapter 11, "Working with Multiple Microsoft Excel Documents"



User's Guide (Book 2)
Chapter 3, "Exchanging Data with Other Applications"



New Command (File Menu)
Creates a new document in the form you specify:    worksheet, chart, macro sheet, or 
workbook; slides; or based on one of the templates you have created.

Any templates saved in the XLSTART directory or alternate startup directory appear in
the list automatically.
Worksheet

Creates a new worksheet.
Shortcuts: New Worksheet tool

SHIFT+F11
ALT+SHIFT+F1

Chart
Using selected data, creates a new chart in the default chart type and format.    Initially, 
Microsoft Excel uses the simple column chart.    You can change the default chart format 
by choosing the chart format you want, and then choosing the Set Preferred command 
from the Gallery menu.    The preferred chart format you select remains in effect for the 
current work session only.
If the selection to be plotted contains more than one row or column and does not contain 
text labels or dates in both the first row and the first column, the New Chart dialog box is 
displayed.    Select an option button to specify how the data in the first row or column 
should be plotted.
Shortcuts: New Chart tool (File Tools category)

ChartWizard tool
F11
ALT+F1

Macro Sheet
Creates a new macro sheet.
Shortcuts: New Macro Sheet tool (Macro toolbar)

CTRL+F11
ALT+CTRL+F1

Workbook
Creates a new workbook.
Shortcut: New Workbook tool (File Tools category)

Slides
Creates a new slideshow.

See Also
Help

ChartWizard Tool
New Chart Tool
New Macro Sheet Tool
New Workbook Tool
New Worksheet Tool

Changing the chart type and format
Creating a chart
Creating a new macro sheet
Creating a new template



Creating a new worksheet
Preferred Command (Gallery Menu)
Set Preferred Command (Gallery Menu)
User's Guide (Book 1)
Chapter 4, "Managing Document Files"
Chapter 6, "Editing a Worksheet"
Chapter 12, "Creating a Chart"
Chapter 13, "Editing a Chart"
Chapter 15, "Working with Graphic Objects"



Open Command (File Menu)
Opens an existing document and displays it on the screen.    You can have more than one 
document open at a time.

In addition to opening Microsoft Excel documents, you can also use this command to 
import files in different file formats from other applications, such as Lotus 1-2-3 file formats.

If the document you want to open was assigned a password when it was saved with 
the Save As command on the File menu, you will be asked to type that password before you 
can open the document.    Be sure to type the password with correct capitalization and 
punctuation.

If the document you want to open was saved with a Write Reservation Password using
the Save As command on the File menu, and you do not select the Read Only check box, you
will be asked to type a password to open the document as read-write.

To reopen one of the last four documents you opened, select that document's name 
from the list of recently opened documents on the File menu.

You can open any template using the Open command on the File menu.    You can 
open templates saved in the XLSTART directory or an alternate startup directory with the 
New command on the File menu.
Shortcuts: File Open tool

CTRL+F12
ALT+CTRL+F2

File Name
Displays the default file specification *.XL*, and a list of the Microsoft Excel files in the 
current directory.    Type the name of the file you want to open, or select it from the list.

Directories
Lists the current directory and any subdirectories.

List Files Of Type
Lists the available file formats.

Drives
Lists the available drives.

Read Only
Select this check box if you want to view the document, but don't want to save changes 
to it.

Text
Displays additional options.    When you open a text file, you can choose the character 
used to separate fields or columns of text.    Microsoft Excel places the text following each
delimiter character in a separate cell.    You can also specify the original source of the text 
file you're opening:    Macintosh, Windows (ANSI), and DOS or OS/2 (PC-8).

See Also
Help

Open File Tool
Changing the drive or directory
Changing the default directory for opening files
Opening a file from a disk



Page Setup Command (File Menu)
Controls the appearance of the printed worksheet, chart, macro sheet, or Info window 
contents.

When you save a document, its specific printer settings are also saved.
When you are working with a group of worksheets, any changes you make in the 

Page Setup dialog box change the settings for all documents in the group.
If an embedded chart is selected, the specifications in the Page Setup dialog box 

refer to the chart only.
Current Printer

Lists the printer selected in the Printer Setup dialog box.
Orientation

Specify the orientation for the printed image:    Portrait prints the document down the 
length of the paper; Landscape prints the document across the width of the paper.

Paper
Specify letter, legal, or other paper size and source options.

Margins
Specify the amount of space you want to appear between the edge of the paper and the 
printed document, and whether the document is centered horizontally or vertically.    
Available for sheets and charts only.

Row and Column Headings
Select to print row and column headings, and cell references when printing notes.    
Available for sheets only.

Cell Gridlines
Select to print the cell gridlines.    Clear to print cell contents without gridlines.    Available 
for sheets only.

Black & White Cells
Select to print cells in black and white.    Available for sheets only.

Start Page No.'s At
Type the number you want page numbering to start with.    Available for sheets and charts
only.

Page Order
To print pages from top to bottom, and then right, select the Down, Then Over option 
button.    To print pages from left to right, and then down, select the Over, Then Down 
option button.    Available for sheets only.

Scaling
Select the Reduce/Enlarge To option button to specify the percentage of reduction or 
enlargement for a document.
Select the Fit To option button to compress the document or selection during the printing 
process so that it can be printed on the specified page layout.

Chart Size
Select the Size On Screen option button to print the chart the same size as it appears on 
the screen.    Select the Scale To Fit Page option button to print the chart as large as 
possible while retaining the chart's height-to-width ratio as shown on the screen.    Select 
the Full Page option button to print the chart to fit the page, adjusting the height-to-width
ratio as necessary.    Available for charts only.

Header, Footer



Displays the Header Edit and Footer Edit Windows, in which you can specify text, page 
numbers, and formatting for headers and footers.
Default header and footer margins are 0.5 inch from the top or bottom of the page and 
0.75 inch from the side of the page.

Print
Displays the Print dialog box.

Printer Setup
Displays the Printer Setup dialog box, listing the printers that are installed for your 
system.

See Also
Help
Header and Footer Code
Changing the layout of a printed page
Set Page Break and Remove Page Break Commands (Options Menu)



Print Command (File Menu)
Prints the active document according to the settings in the Page Setup dialog box.

If the active document is a worksheet or a macro sheet, it is printed according to 
settings you have specified using the Set Print Area, Set Print Titles, and Set Page Break 
commands on the Options menu.

If you want to print an embedded chart only, without the surrounding worksheet, you 
must first double-click the chart to display it in a chart window.    You can specify the printed 
size of such a chart using the Page Setup command on the File menu.

If the Info window is active, information about the selected cells in the worksheet is 
printed.
Shortcuts: Print tool

CTRL+SHIFT+F12
ALT+CTRL+SHIFT+F2

Printer
Displays the name of the printer you selected in the Printer Setup dialog box.

Print Range
Select the All option button to print all the pages in the document or the Pages option 
button to specify in the From and To boxes a range of pages to print.

Print Quality
Displays the resolution levels offered by the current printer.

Copies
Type the number of copies you want to print.

Print
Select the Sheet option button to print only the active document, the Notes option button
to print only the notes, or the Both option button to print the document and notes on 
separate pages.

Preview
Displays the Print Preview window when you choose the OK button.

Fast, But No Graphics
Select to print the document without graphics, and therefore more quickly.

Page Setup
Displays the Page Setup dialog box.

See Also
Help

Print Tool
Changing the layout of the printed page
Page Setup Command (File Menu)
Previewing a document before printing
Print Preview Command (File Menu)
Print Preview Window
Print Report Command (File Menu)
Printing a chart
Printing a section of a worksheet
Printing reports



Resetting the print area
Selecting a printer
Setting up a printer
User's Guide (Book 1)
Chapter 16, "Printing"



Print Preview Command (File Menu)
Displays each page as it will look when you print the document.

If an embedded chart is active in a chart window, Print Preview displays the chart 
only.

To preview specific pages, choose the Print command from the File menu, specify a 
print range in the From and To boxes, select the Preview check box, and then choose the OK 
button.
Shortcut: Print Preview tool (File Tools category)
Next

Displays the next page of the document.
Previous

Displays the previous page of the document.
Zoom

Switches between full page view and actual size view of document pages.
Print

Displays the Print dialog box.
Setup

Displays the Page Setup dialog box.
Margins

Displays the current margin and column width settings.    You can adjust these by 
dragging the margins or column markers.    Choose the Margins button again to turn the 
margins and column markers off.

Close
Closes the Print Preview window and displays the active document.

See Also
Help

Print Preview Tool
Adding and deleting a tool from a toolbar
Page Setup Command (File Menu)
Previewing a document before printing
Print Command (File Menu)
Print Preview Window
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 16, "Printing"



Record Macro Command (File Menu)
Opens a macro sheet and records your subsequent actions as macro functions.

This command appears on the File menu when all windows are closed or hidden.
This command is the same as the Record command on the Macro menu.

Shortcut: Record Macro tool (Macro toolbar)
Name

Displays a name for the macro.    Accept the proposed name or type a new one that will 
remind you what the macro does.

Key
Defines a shortcut key you can use later to quickly run the macro.    Accept the proposed 
letter or type another one.    Shortcut keys are case sensitive and must be letters; 
numbers are not allowed.

Store Macro In
Specify whether to record the macro on the global macro sheet or on a new macro sheet.

See Also
Help

Record Macro Tool
Macro Toolbar
Creating a new macro sheet
Defining a macro name
Record Command (Macro Menu)
Recording a macro
Toolbars Command (Options Menu)

User's Guide (Book 2)
Chapter 6, "Automating Tasks with Command Macros"



Save Command (File Menu)
Saves changes made to the active document.

This command replaces the previous version of the document with the current 
version.

The newly saved document is still displayed in the window.
If the document hasn't been saved yet, or if it was last saved in a file format other 

than Normal, the Save As dialog box is displayed.
When the active document is in a group, choosing Save from the File menu saves all 

the documents in the group, one at a time.
Shortcuts: Save File tool

SHIFT+F12
ALT+SHIFT+F2

See Also
Help

Save File Tool
Save As Command (File Menu)
Saving a chart
Saving a document as a template
Saving a document for the first time
Saving a file for use by another application



Save As Command (File Menu)
Saves a new document or a new version of an existing document.    The saved document 
remains displayed in the window.

You can also use this command to export files to other applications, such as Lotus 1-
2-3.

When an embedded chart is active in a chart window, choosing this command saves 
a copy of the chart as a separate document.
Shortcuts: F12

ALT+F2
File Name

Saves the document in the current directory unless you type a full path for the document 
or select a different directory from the directory listing.
Type a name for the document, or accept the proposed name.    A file name cannot 
contain a left bracket ( [ ) or a right bracket ( ] ).

Directories
Lists the current directory and any subdirectories.

Save File As Type
Lists the available file formats.    The formats available depend on whether you're saving a
worksheet, macro sheet, chart, workbook, or template.

Drives
Lists the available drives.

Options
Create Backup File

Creates a backup copy of a document every time you save it.
The backup copy is the previous version of the document, renamed with a .BAK 
extension.

Protection Password
Type text as the password that is required to open the file.
A password can contain up to 15 characters and can include spaces, symbols, and 
numbers, as well as letters.
As you type the password, Microsoft Excel displays an asterisk (*) for each character 
entered.
If you assign a password, you must use the same password to open the document after
you close it, typing uppercase and lowercase letters exactly.
You can assign passwords to documents saved in template and add-in macro file 
formats, in addition to those saved in the Normal Microsoft Excel file format.

Write Reservation Password
Type text as the password required to save changes to the file.

Read Only Recommended
Select this check box to display a message requesting that readers access the file as 
read only.
This message is displayed before the document is opened only if readers have cleared 
the Read Only check box in the Open dialog box.
The file remains read only even when it is saved under another name using the Save 
As command on the File menu.



See Also
Help
Exporting documents to other applications
Saving a chart
Saving a document as a template
Saving a document for the first time
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



Unhide Command (File Menu)
Makes a hidden window visible.

This command appears on the File menu only when all open windows are hidden.    
When at least one window is visible, the Unhide command appears on the Window menu.
Unhide

Lists all hidden windows.    Select the one you want and choose the OK button.
If the window is protected with a password, Microsoft Excel asks for the password before 
displaying the window.

See Also
Help
Protecting windows



Send Mail Command (File Menu)
Sends copies of Microsoft Excel documents to other users through Microsoft Mail.

This command is only available with mail clients that support the Windows simple 
mail interface (SMI).

For more information, see your Microsoft Mail User's Guide or other mail client's 
documentation.



Save Workbook Command (File Menu)
Saves all changes made to all documents in the workbook.

When you save a new workbook, the Save Workbook command displays the File Save
As dialog box, described below.
File Name

Type a name for the workbook, or accept the proposed name.
Saves the workbook in the current directory unless you type the full path of the workbook
or select a different directory from the list.

Directories
Lists the current directory and any subdirectories.

Save File As Type
Lists the available file formats.

Drives
Lists the available drives.

Options
Create Backup File

Creates a backup copy of the workbook every time you save it.
The backup copy is the previous version of the workbook renamed with a .BAK 
extension.

Protection Password
Enter text for the password that is required to open the workbook.
A password can contain up to 15 characters and include spaces, symbols, and 
numbers, as well as letters.
As you type the password, Microsoft Excel displays an asterisk for each character 
typed.
If you assign a password, you must use the same password to open the workbook after 
you close it, typing uppercase and lowercase letters exactly.

Write Reservation Password
Type text for the password that is required to save changes to the workbook.

Read Only Recommended
Select this check box to display a message requesting that readers access the 
workbook as read only.
This message is displayed before the workbook is opened only if readers have cleared 
the Read Only check box in the Open dialog box.
The workbook remains read only even when it is saved under another name using the 
Save As command on the File menu.

See Also
Help
Saving a workbook
Workbooks
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



Update Command (File Menu)
Updates information in a document containing a Microsoft Excel object.

This command replaces the Save command on the File menu when you are editing a 
Microsoft Excel object that has been embedded in another document.

If you want to update the object and return to the other application, choose the Exit 
command from the File menu.
See Also

Help
About Linking and Embedding
User's Guide (Book 2)
Chapter 3, "Exchanging Data with Other Applications"



Print Report Command (File Menu)
Prints a set sequence of views and scenarios.

If the Print Report command does not appear on the File menu, run the Setup 
program to install it.
Reports

Select a report to print, edit, or delete.
Print

Prints the document.
Copies

Type the number of copies you want to print.
Add, Edit

Report Name
Type a name for the report.

Report Section
In the View box, select the view that you want in the section.
In the Scenario box, select the scenario, if any, that you want for the view in this 
section.

Current Sections
Lists the current sections.

Add
Choose the Add button to add the selected section to the Current Sections list.

Continuous Page Numbers
Select this check box if you want pages to be numbered consecutively.

Move Up, Move Down
Select the section you want to move and choose these buttons to change the section's 
order in the Current Sections list.

Delete
Deletes the current selection.

Delete
Deletes the selected report.

See Also
Help
Creating a view of a worksheet
Formula Menu
Printing a report
View Command (Window Menu)
User's Guide (Book 1)
Chapter 1, "Getting Started With Microsoft Excel"
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



Close Workbook Command (File Menu)
Closes the active workbook and all of its documents.    If you have made changes to any 
workbook documents, you will be asked if you want to save those changes.

If you have several windows open for a document, the Close Workbook command 
closes all the document windows.
See Also

Help
Quitting Microsoft Excel
Saving a workbook
Workbooks
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



Format Menu for Charts
The Format menu changes depending on whether the active document is a worksheet or a 
chart.
Patterns

Changes the appearance of the selected chart item.
Font

Changes the font of the selected chart text.
Text

Changes the alignment of the selected chart text.
Scale

Changes characteristics of a chart's axes, tick marks, and labels.
Legend

Repositions a chart's legend.
Main Chart

Changes the main chart's type and formats.
Overlay

Changes the overlay chart's type and formats.
3-D View

Changes the view of a 3-D chart.
Move

Moves a selected chart item.
Size 

Resizes arrows and unattached text in a chart.



Format Menu for Worksheets
The Format menu changes depending on whether the active document is a worksheet or a 
chart.    Commands for formatting worksheets also apply to macro sheets.
Number

Determines how numbers, currency, dates, and times are displayed in selected cells.
Alignment

Aligns the contents of selected cells and allows you to wrap text.
Text

Changes the alignment of text in a selected text box or button.    The Alignment command
is replaced by the Text command when a text box or button is selected.

Font
Changes the font for text in the selected cells or text boxes. 

Border
Adds or removes solid border lines, shading, or both in selected cells.

Patterns
Changes the appearance of the selected cells or objects.

Cell Protection
Determines whether cells will be locked or their formulas hidden when you protect the 
document.    Changes to Object Protection when an object is selected.

Object Protection
Determines whether objects or selected text in a text box are locked when you protect 
the document.    Changes to Cell Protection when a cell is selected.

Style
Defines cell styles.

AutoFormat
Automatically formats a range of cells using one of several built-in table formats.

Row Height
Changes the height of selected rows.

Column Width
Changes the width of selected columns.

Justify
Distributes the text contained in the left column evenly throughout the selected range.

Bring To Front
Places the selected objects in front of all other objects.

Send To Back
Places the selected objects behind all other objects.

Group
Groups several objects into a single object.

Ungroup
Ungroups previously grouped objects into individual objects.    Ungroup replaces Group on 
the Format menu when a group of objects is selected.

Object Properties



Specifies whether an object is attached to its underlying cells and whether it is 
repositioned with them if they move or change size.    Also defines whether the object will 
be printed.



3-D View Command (Format Menu for Charts)
Controls the angles at which you view the data in a three-dimensional chart.

A sample chart in the dialog box shows the current settings.
Elevation

Controls the height at which you view the data. The elevation is measured in degrees.    
For all charts except pie charts and 3-D bar charts, ranges from -90 (view from directly 
below the plot area) to 90 degrees (view from directly above the plot area).    For pie 
charts, ranges from 10 to 80 degrees.    For 3-D bar charts, ranges from 0 to 44 degrees.

Perspective
Controls the amount of perspective for 3-D charts.    A greater degree of perspective 
provides a greater sense of depth when viewing the chart.    The perspective value 
specifies the ratio of the front of the chart to the back of the chart and can range from 0 
to 100.    Unavailable when the Right Angle Axes check box is selected, and for 3-D bar 
charts.

Rotation
Controls the rotation of the plot area around the z-axis (vertical axis).    The rotation is 
measured in degrees from 0 to 360.    For 3-D bar charts, the rotation ranges from 0 to 44 
degrees.

Right Angle Axes
Sets the axes at right angles independent of chart rotation or elevation.    Clear this check 
box to show axes in perspective.    For 3-D bar charts, this check box is always selected.

Auto Scaling
Available only if the Right Angle Axes check box is selected.    When you change a 2-D 
chart into a 3-D chart, it is sometimes drawn smaller.    For charts with right-angle axes 
and a rotation of less than 45 degrees, this option scales the 3-D chart so that it is closer 
in size to the 2-D version.

Height % of Base
Controls the height of the z-axis and walls relative to the length of the x-axis or the width 
of the base of the chart.    The height is measured as a percentage of the x-axis length.    
For example, a value of 200% makes the chart height twice the x-axis length.

Apply
Applies the current settings to the active chart without closing the dialog box so that you 
can see the effects of your changes.

Default
Resets all the settings in the dialog box to the default values.    If you change the chart 
type using a Gallery menu command, the 3-D view formats are not reset to their original 
values.    Choosing the Default button is the only way to restore the original settings.

See Also
Help
Adjusting the 3-D chart view
Formatting the plot area on a chart
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



Alignment Command (Format Menu for Worksheets)
Aligns the contents of selected cells.    Only affects the appearance of cells, not the actual 
values within them.
Horizontal

General
Aligns text to the left and numbers to the right; centers logical and error values.    This 
is the default alignment.    Alignment is set to General if the Left Align, Right Align, and 
Center Align tools are not selected.

Left
Aligns all selected cell entries to the left.

Center
Centers all selected cell entries.

Right
Aligns all selected cell entries to the right.

Fill
Repeats the contents of the selected cell until the cell is full.    If blank cells to the right 
also have the Fill format, they are filled as well.

Justify
Aligns text within a cell to the right and left.

Center Across Selection
Centers a cell entry across the selected cells.

Wrap Text
Displays long strings of text on multiple lines within a cell.    Wrapped text may be left-
aligned, right-aligned, centered, or justified in a cell.    If you change the length of the 
text, double-click the lower border of the row heading or use the Row Height command on
the Format menu to reset the row height.

Vertical
Aligns cell entries with the top, center, or bottom of a cell.

Orientation
Rotates selected cell entries.    You must adjust the height of the row to the length of the 
rotated text.

See Also
Help

Center Across Columns Tool
Center Align Tool
Justify Align Tool
Left Align Tool
Right Align Tool

Aligning text and numbers within cells
Toolbars Command (Options Menu)
User's Guide (Book 1)



Chapter 7, "Formatting a Worksheet"



Border Command (Format Menu for Worksheets)
Adds or removes border lines and shading in selected cells.
Border

Outline
Puts a border around the outer edges of the selection.
Shortcuts: CONTROL+SHIFT+ &

CTRL+SHIFT+ MINUS SIGN (removes all borders)
Left, Right, Top, Bottom

Puts a border along the specified edges of each cell in the selection.
Style

Sets the line style to apply to a border:    hairline, thin, medium, thick, double, dotted, 
or dashed lines, or no border.

Color
Sets the border color to one of 16 colors.    The Automatic option applies the default 
border color and style.

Shade
Applies or removes shading in selected cells.    Use the Patterns command on the 
Format menu to adjust the applied shading.

See Also
Help

Bottom Border Tool
Drop Shadow Tool
Left Border Tool
Outline Border Tool
Right Border Tool
Top Border Tool

Adding borders
Adding shading
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Bring To Front Command (Format Menu for Worksheets)
Places selected objects in front of all other objects.

This command has no effect if the selected object is already in front.
See Also

Help

Bring To Front Tool
Selecting a graphic object
Send To Back Command (Format Menu for Worksheets)
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Cell Protection Command (Format Menu for Worksheets)
Determines whether cells will be locked or their formulas hidden when you choose the 
Protect Document command from the Options menu.

Locked cells can't be edited if the document is protected.
Hidden cells display their values, but no formula appears in the formula bar.
All cells in a new worksheet are initially locked but not hidden.

Locked
Prevents selected cells from being changed when a document is protected.    All cells in a 
new worksheet are locked by default.    

Hidden
Prevents a cell's formula from being displayed in the formula bar when a document is 
protected.

See Also
Help

Lock Cell Tool
Object Protection Command (Format Menu for Worksheets)
Protecting a chart
Protecting a document with a password
Protecting an object
Protecting windows
Protecting worksheet cells
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



Column Width Command (Format Menu for Worksheets)
Changes the width of selected columns.

Only one cell in a column needs to be selected to change the width for the entire 
column.

To change the width of all columns in a worksheet, select the entire worksheet or one 
entire row.

To change the width of columns in several worksheets at once, use the Group Edit 
command on the Option menu.

To select Best Fit, double-click the right border of the column heading.
Choosing the Hide, Unhide, or Best Fit button overrides the Use Standard Width check

box or an entry in the Column Width box.
Column Width

Changes the width of the selected column or columns.    You can enter an integer or 
decimal fraction from 0 through 255.    This number represents the number of characters 
that can be displayed in a cell for the current font and size.

Use Standard Width
Returns the selected columns to standard width.

Hide
Hides the selected columns.
Shortcut: CTRL+0 (zero)

Unhide
Unhides hidden columns within the selection.    To select hidden columns, select cells in 
the columns immediately to the left and right of the hidden one.
Shortcut: CTRL+SHIFT+ )

Best Fit
Sets the column to the minimum width necessary to display the contents of the selected 
cells.    If you change the cell contents later, you must choose the Best Fit button again. 

Standard Width
Changes the width of all columns in the active worksheet that have not been individually 
changed.    You can enter an integer or decimal fraction from 0 through 255.    This number
represents the number of characters that can be displayed in a cell for the current font 
and size.

See Also
Help
Changing the width of columns
Group Edit Command (Options Menu)
Hiding and unhiding a column
Row Height Command (Format Menu for Worksheets)



Font Command (Format Menu for Charts)
Changes the font, font style, size, and color of the selected chart text.

To change the font of all chart text, you must first select the entire chart using the 
Select Chart command on the Chart menu.    You can also select the entire chart using the 
mouse or the keyboard.
Font

Lists available fonts.    
You can select a font or type the name of the font you want in the box above the list of 
fonts.

Font Style
Lists the available font styles.    You can select one of the styles in the list.
Shortcuts: CTRL+B (Bold)

CTRL+I (Italic)
Bold tool (Standard or Formatting toolbar)
Italic tool (Standard or Formatting toolbar)

Size
Lists the available sizes for the font selected in the Font box.    
You can select a font size or type the size you want in the box above the list of sizes.

Effects
Strikeout

Formats selected text with a line through the middle.
Shortcut: CTRL+5

Underline
Formats selected text with an underline.
Shortcut: CTRL+U 

Color
Controls the text color.    Select a color from the list or select Automatic to set the color 
to the window text color defined in the Windows Control Panel.    Unless you have 
changed the window text color, selecting Automatic sets the text color to black.

Sample
Shows a sample of text with the current font formatting choices applied.

Background
Automatic

Applies the default background.
Transparent

Leaves the area behind the text transparent.
Opaque

Removes any pattern but leaves the foreground color behind the text.
Patterns

Applies the font changes you've made and displays the Patterns dialog box so you can 
format the selected chart item.

Text
Applies the font changes you've made and displays the Text dialog box so you can choose
text alignment and orientation.



Scale
Applies the font changes you've made and displays the Scale dialog box so you can 
format the selected axis.

See Also
Help

Font Name Box
Font Size Box
Style Box

Formatting a chart embedded in a worksheet
Formatting a legend
Formatting chart text alignment and orientation
Formatting the chart text font
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



Font Command (Format Menu for Worksheets)
Changes the font, style, size, and color of the text in selected cells, buttons, or text boxes. 
Font

Lists available screen and printer fonts. 
You can select a font or type the name of the font you want in the box above the list of 
fonts.

Font Style
Lists the available font styles.    You can select one of the styles in the list.
Shortcuts: CTRL+B (Bold)

CTRL+I (Italic)
Bold tool (Standard or Formatting toolbar)
Italic tool (Standard or Formatting toolbar)

Size
Lists the available sizes for the font selected in Font box. 
You can select a font size or type the size you want in the box above the list of sizes.

Effects
Strikeout

Formats selected text with a line through the middle.
Shortcut: CTRL+5

Underline
Formats selected text with an underline.
Shortcut: CTRL+U 

Color
Controls the text color.    Select a color from the list or select Automatic to set the color 
to the window text color defined in the Windows Control Panel.    Unless you have 
changed the window text color, selecting Automatic sets the text color to black.

Sample
Shows a sample of text with the current font formatting choices applied.

Normal Font
Sets the font, font style, size, and effects to the normal style.
Shortcut: CTRL+1

See Also
Help

Font Name Box
Font Size Box
Style Box

Setting the default font for worksheets
Setting a format for the entire worksheet
Formatting cells
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"





Group and Ungroup Commands (Format Menu for Worksheets)
Group Command

Creates a single graphic object from several selected graphic objects.    The grouped 
objects can be moved and sized as one object or ungrouped and handled as individual 
objects. 

The Group command is available only when two or more objects are selected.
You can group and ungroup objects that are already grouped, creating multiple layers

of groupings.
Ungroup Command

Separates grouped objects into individual objects.
The Ungroup command is available only when a grouped object is selected.

See Also
Help

Group Tool
Ungroup Tool

Grouping graphic objects
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Justify Command (Format Menu for Worksheets)
Redistributes text within a range of cells into even lines.    Each line of text is as close as 
possible to the maximum width of the range.    Use this command if you have several entries
in consecutive rows and you want to move the text into a selected range.    

This command can only be used for ranges that contain text or blank cells.    If you 
select a range that contains numeric values, an error message is displayed.

Blank cells in the left column divide text into paragraphs, separated by a blank cell, 
that are justified separately.    Except for the left column, cells in the range should be blank 
or they will interfere with the display of text.
See Also

Help
Justifying text to fill a selected range
Switching from Lotus 1-2-3
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Legend Command (Format Menu for Charts)
Repositions the selected legend on a chart.

You can move a legend using the mouse or the Legend command.
Top, Bottom

Centers the legend above or below the chart.
Corner

Places the legend in the upper-right corner of the chart.
Right, Left

Centers the legend vertically to the right or left of the chart.
Patterns

Applies the legend changes and displays the Patterns dialog box.
Font

Applies the legend changes and displays the Font dialog box.
See Also

Help
Adding or deleting a legend
Formatting a legend
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



Main Chart Command (Format Menu for Charts)
Controls the main chart's type and formats.

Use this command instead of a Gallery command to change the chart type or other 
options when you want to preserve the chart's custom formats.

Only options that are relevant to the selected chart type are available.
To change an overlay chart's type and formats, choose the Overlay command from 

the Format menu.
Main Chart Type

Changes the main chart to the type selected in the box.
Data View

Shows the available marker arrangements for the selected chart type.    Select the marker
arrangement you want.

Bar/Column
Overlap 

Determines how much the markers within a cluster overlap each other in a bar or 
column chart.    The number in the box is a percentage of the bar or column width.    A 
negative value sets a gap between markers.

Gap Width 
Determines the width of the space between clusters in a bar or column chart.    The 
number in the box is a percentage of the bar or column width.

Series Lines
Connects the tops of the data markers for each series with lines. Available for stacked 
bar and stacked column charts only.

Format
Vary By Categories

If a chart contains only one data series, assigns a different color or pattern to each data
marker.    Does not apply to a chart with more than one series.

Drop Lines
Extends drop lines from each marker to the x-axis.    Applies only to line or area charts.

Hi-Lo Lines
Extends hi-lo lines from the highest to the lowest value in each category.    Applies only 
to 2-D line charts.

Up/Down Bars
This option is for open-high-low-close charts which track stock prices. An up/down bar 
is a rectangle extending from the opening price to the closing price on a given day. 
Available for line charts only.

Radar Axis Labels
Displays labels for category axes on radar charts.

Angle Of First Pie Slice
Determines the angle at which the first pie slice starts.    The angle is measured in 
degrees clockwise from vertical.

3-D
Gap Depth

Determines the distance between the data series in a 3-D chart.    The number in the 



box is a percentage of the marker width.
Chart Depth

Determines the depth of a 3-D chart relative to its width.    The number in the box is a 
percentage of the chart width. 

See Also
Help

Horizontal Gridlines Tool
Vertical Gridlines Tool

Changing the chart type and format
Chart Toolbar
Formatting the data marker layout
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



Move Command (Format Menu for Charts)
Lets you move chart arrows, unattached text, slices of pie charts, and chart legends using 
the arrow keys.

To position a chart legend, use the Legend command on the Format menu.
Shortcut: Use the mouse to move selected chart items.
See Also

Help
Adding or deleting unattached chart text
Moving a legend
Moving or sizing an arrow



Number Command (Format Menu for Worksheets)
Determines how information is displayed in the selected cells.    You can use one of the built-
in number formats, or you can create your own custom formats.
Category

Lists a variety of number, date, and time formats.    When you select a category, the built-
in and custom formats for that category are displayed in the Format Codes box.

Format Codes
Lists all available formats for a selected category.    
All cells in a new worksheet are formatted with the General format.    When you type a 
number in a cell formatted as General, Microsoft Excel assigns the number a built-in 
format based on what you typed.
Shortcuts: CTRL+SHIFT+~ (General format)

CTRL+SHIFT+ ! (0.00)
CTRL+SHIFT+ @ (h:mm)
CTRL+SHIFT+ # (d-mmm-yy)
CTRL+SHIFT+ $ [$#,##0.00);($#,##.00)]
CTRL+SHIFT+ % (0%)
CTRL+SHIFT+ ^ (0.00E+00)

Code
Displays the format selected in the Format Codes box.
To add a custom format, edit the format shown in the Format box or type a new one.    The
custom format is added to the current category.

Sample
Displays a sample of the format selected in the Format Codes box.

Delete
Deletes a selected custom format displayed in the Code box.
You cannot delete built-in number formats.

See Also
Help

Comma Style Tool
Currency Style Tool
Percent Style Tool

Creating or deleting a custom number format
Preventing the display of zero values
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Object Properties Command (Format Menu for Worksheets)
Determines how graphic objects are attached to cells.    Lets you position graphic objects by 
attaching them to cells and specifying how they move and size relative to the underlying 
cells.    Also determines whether the object prints or not.

Graphic objects are initially formatted to move and size with the underlying cells.
Pictures are initially formatted to move but not size with underlying cells.
Graphic objects that are not attached to cells stay in the same position regardless of 

changes to the underlying cells.
Unattached graphic objects must be repositioned manually if cells move or change 

size.
Buttons do not print by default; other objects do.

Move And Size With Cells
The object changes its position and size along with the cells under its upper-left and 
lower-right corners.

Move But Don't Size With Cells
The object moves with the cells under its upper-left corner, but does not change size.

Don't Move Or Size With Cells
The object is detached from the cell grid so that it maintains its position and size 
regardless of changes to the underlying cells.

Print Object
Prints the object when you print the worksheet.

See Also
Help
Moving and sizing a graphic object along with cells
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Object Protection Command (Format Menu for Worksheets)
Specifies whether objects are locked when you use the Protect Document command on the 
Options menu.    Use the Object Protection command when you want to lock a graphic object
or the text in a text box.

This command is available only when the active document is a worksheet or macro 
sheet.
Locked

Locks the selected object so that it can't be deleted, formatted, moved, or sized when the
document is protected.    If only the Locked check box is selected and the selected object 
is a text box, the text in the text box can be edited or formatted, but the text box itself 
cannot be deleted, formatted, moved, or sized.

Lock Text
Locks the text in the selected text box so that it can't be edited when the document is 
protected.    If only the Lock Text check box is selected, the text box can be formatted, 
moved, or sized, but the text within the text box cannot be edited or formatted.

See Also
Help

Lock Cell Tool
Cell Protection Command (Format Menu for Worksheets)
Protecting a chart
Protecting a document with a password
Protecting an object
Protecting windows
Protecting worksheet cells
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



Overlay Command (Format Menu for Charts)
Controls the overlay chart's type and formats.

This command is available only when you have created an overlay chart with the Add
Overlay command on the Chart menu or by choosing a combination chart from the Gallery 
menu.

Only the dialog box options relevant to the selected chart type are available.
To change the main chart's type and formats, choose the Main Chart command from 

the Format menu.
Overlay Chart Type

Changes the overlay chart to the type selected in the box:    Area, Bar, Column, Line, Pie, 
XY (Scatter), or Radar.

Data View
Shows the available marker arrangements for the selected chart type.    Select the marker
arrangement you want.

Bar/Column
Overlap

Determines how much the markers within a cluster overlap each other in a bar or 
column chart. The number in the box is a percentage of the bar or column width.    A 
negative value sets a gap between markers.

Gap Width
Determines the width of the space between clusters in a bar or column chart.    The 
number in the box is a percentage of the bar or column width.

Series Lines
Connects the tops of the data markers for each series with lines. Available for stacked 
bar and stacked column charts only.

Format
Vary By Categories

If a chart contains only one data series, assigns a different color or pattern to each data
marker.    Does not apply to a chart with more than one series.

Drop Lines
Extends drop lines from the highest value in each category to the category axis.    
Applies only to line and area charts.

Hi-Lo Lines
Extends hi-lo lines from the highest to the lowest value in each category.    Applies only 
to line charts.

Up/Down Bars
This option is for open-high-low-close charts which track stock prices. An up/down bar 
is a rectangle extending from the opening price to the closing price on a given day. 
Available for line charts only.

Radar Axis Labels
Displays labels for category axes on radar charts.

Angle Of First Pie Slice
Determines the angle at which the first pie slice starts.    The angle is measured in 
degrees clockwise from vertical.

Series Distribution



Automatic
Instructs Microsoft Excel to automatically divide the data series between the main 
chart and the overlay chart.
If there is an odd number of series, one more series appears on the main chart than on 
the overlay chart.    For example, in a chart with five data series, the first three appear 
on the main chart, and the last two on the overlay chart.

First Overlay Series
Controls which data series are in the overlay chart.
Type the plot number of the first series you want in the overlay chart.    That series, and
any with higher plot order numbers, is put in the overlay chart.
You can use the Edit Series command on the Chart menu to reorder the series.

See Also
Help

Horizontal Gridlines Tool
Vertical Gridlines Tool

Add Overlay and Delete Overlay Commands (Chart Menu)
Chart Toolbar
Edit Series Command (Chart Menu)
Main Chart Command (Format Menu for Charts)
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



Patterns Command (Format Menu for Charts)
Controls the appearance of the selected item in a chart.

The options available depend on the item selected. 
Automatic

Applies the default patterns to the selection.
None

Makes the selected item or part of the chart item invisible.
Axes, tick mark labels, and gridlines can't be made invisible.    Use the Axes command on 
the Chart menu, the Scale command on the Format Menu for Charts, and the Gridlines 
command on the Chart menu to turn off axes, labels, and gridlines.

Custom
Indicates whether custom formatting has been selected for the item.

Style
Controls the line style of an axis, line, marker, or item border or the marker style in a line 
chart. 

Color
Controls the color of an axis, line, or item border.

Weight
Controls the weight of an axis, line, or item border.

Shadow
Adds a shadow to the bottom and right side of a text box, legend, or the entire chart.

Pattern, Foreground, Background 
Controls the fill pattern, foreground color, and background color for the selected text box, 
arrow, plot area, or chart background; or controls the foreground and background colors 
for a data series marker in a chart.    A solid pattern is the foreground color.    A pattern 
other than solid is a combination of the foreground and background colors. 

Invert If Negative
Reverses the foreground and background colors for the data series marker in a bar, 
column, area, or pie chart when the value it represents is negative.

Apply To All
Applies the choices you make to all data points in the chart.
Available only when a data point, data series, or text attached to a data point is selected.

Tick Mark Type
Displays major or minor tick marks on the chart side of axes, on the other side of axes, 
across the axes, or not at all.

Tick Labels
Displays tick mark labels at the low end of the axis, high end of the axis, next to the axis, 
or not at all.

Arrow Head
Controls the style, width, and length of the arrowhead for a line.

Sample
Shows the current line or pattern format.

Font, Scale, Text



Carries out pattern changes you've made and displays the Font, Scale, or Text dialog box.
Legend

Carries out pattern changes you've made and displays the Legend dialog box, which 
offers options for positioning the legend and formatting the legend pattern and text font.

Picture Chart Format Options
Stretch

Stretches the picture.
Stack

Stacks a picture at normal size.
Stack And Scale

Stacks a scaled picture.
Units/Picture

Indicates the number of value units per picture.
See Also

Help

Color Tool
Dark Shading Tool
Light Shading Tool

Formatting axis patterns and tick mark and label location
Formatting gridlines
Formatting text box borders and fill patterns
Selecting items in a chart
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



Patterns Command (Format Menu for Worksheets)
Controls the shading of selected cells or the appearance of the selected graphic object.    
You can format text boxes, ovals, arcs, rectangles, picture borders, and lines.    

The options available depend on the object selected. 
If you select multiple objects and choose the Patterns command, the options selected

apply only to the objects that have those characteristics.    For example, if a line and a 
rectangle are selected, the Fill option applies only to the rectangle.

Double-clicking an object displays the Patterns dialog box unless the object is a chart 
or a linked picture.
Automatic

Applies the default patterns for an object border or fill or a line style.    Does not apply to 
cells.

None
Makes the entire selected object or part of the selected object invisible.    Does not apply 
to cells.

Custom
Removes default settings so you can customize the style, color, and weight of a selected 
object border or line, or the fill pattern and background and foreground color of an object.

Style
Controls the style of a line or object border.    

Color
Controls the color of a line or object border.

Weight
Controls the weight of a line or object border.

Pattern
Controls the fill pattern for the selected cells or objects.    Select None if you don't want 
any pattern in selected cells.

Foreground
Controls the foreground color of the fill pattern.    A solid pattern is the foreground color.    
A pattern other than solid is a combination of the foreground and background colors.

Background
Controls the background color of the fill pattern.    A solid pattern is the foreground color.    
A pattern other than solid is a combination of the foreground and background colors.

Shadow
Adds a shadow to the bottom and right side of a rectangle, oval, chart, or text box.

Round Corners
Rounds the corners of a rectangle, chart, or text box.

Arrow Head
Controls the style, width, and length of the arrowhead for a line.    An arrowhead style 
must be selected for the width and length options to apply.

Sample
Displays the formats selected for the line or object.

See Also
Help



Bottom Border Tool
Color Tool
Dark Shading Tool
Drop Shadow Tool
Left Border Tool
Light Shading Tool
Outline Border Tool
Right Border Tool
Top Border Tool

Adding shading to cells
Formatting text box borders and fill patterns
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"
Chapter 15, "Working with Graphic Objects"



Row Height Command (Format Menu for Worksheets)
Changes the height of selected rows.

You need to select only one cell in a row to change the height for the entire row.
To change the height of all rows in a worksheet, select the entire worksheet or one 

entire column.
This command is unavailable if the document is protected.

Row Height
An integer or decimal fraction, representing the row height in points.    If set to 0, the row 
is hidden.

Standard Height
Varies according to font size.
Returns each row in the selection to the standard height for the font within the row.    If a 
row contains more than one font, standard height is adjusted for the largest font.

Hide
Hides rows.
Shortcut: CTRL+9

Unhide
Unhides rows.
Shortcut: CTRL+SHIFT+ (

See Also
Help
Adjusting row height
Changing the width of columns
Hiding and unhiding a row



Scale Command (Format Menu for Charts)
Controls the scale settings (tick marks, labels, and gridline spacing) used for each of the 
chart axes.

The scale command is available only when a chart axis is selected.
Different options are available depending on which axis is selected: a category (x) 

axis, value (y or z) axis, or series (y) axis.
Category Axis Scale Options

Value (Y) Axis Crosses At Category Number
Specifies the number of the category at which the value axis will cross the category 
axis. 
This option is not available for 3-D charts.

Number Of Categories Between Tick Labels
Specifies which categories are labeled.
Type 1 to label every category, 2 to label every other category, 3 to label every third 
category, and so on.

Number Of Categories Between Tick Marks
Specifies the number of categories between each pair of tick marks. 

Value (Y) Axis Crosses Between Categories (or Value (Z) Axis Crosses Between 
Categories)

For a 2-D chart, displays the value axis at the edge of the category indicated in the 
Value (Y) Axis Crosses At Category Number box; otherwise, the value axis crosses 
through the center of the category.
This option changes to Value (Z) Axis Crosses Between Categories for a 3-D chart 
plotted with three axes.
For 2-D charts, controls whether data is plotted between tick marks or at tick marks.    If
selected, data points are plotted between tick marks; if cleared, they are plotted at the 
tick mark positions.    For 3-D charts, applies only to line and area charts.

Categories In Reverse Order
Reverses the displayed order of the categories and the data within a category.    This 
does not reverse the plot order of the data or categories.

Value (Y) Axis Crosses at Maximum Category
Displays the value axis at the last plotted category.    This option overrides the Value (Y)
Axis Crosses At Category Number value and is not available on a 3-D chart.

Patterns
Displays the Patterns dialog box so you can format the axis, tick mark type, and tick 
labels.

Font
Displays the Font dialog box so you can format the axis font, size, style, color, and 
background.

Text
Displays the Text dialog box so you can select the axis text orientation.

Value Axis Scale Options
Minimum

Specifies the smallest data value to appear on the value axis.    If the Auto check box is 
selected, displays the lowest value (rounded) from all data series.



Maximum
Specifies the highest data value to appear on the value axis.    If the Auto check box is 
selected, displays the highest value (rounded) from all data series.

Major Unit
Specifies the increment between major tick marks and major gridlines on the value 
axis.    If the Auto check box is selected, automatically calculates the increment.

Minor Unit
Specifies the increment between minor tick marks and minor gridlines on the value 
axis.    If the Auto check box is selected, automatically calculates the increment.

Category (X) Axis Crosses At (or Value (Y) Axis Crosses At)
Specifies the value at which the category axis crosses the value axis.    If the Auto 
check box is selected, the category axis crosses at zero or at the number in the value 
axis range closest to zero.
This option changes to Value (Y) Axis Crosses At for the x-axis of an xy (scatter) chart 
and specifies the value at which the y-axis crosses the x-axis.
For 3-D charts plotted with three axes, this option changes to the Floor (XY Plane) 
Crosses At option.    This option is not available for radar charts.

Floor (XY Plane) Crosses At
Specifies the value at which the floor of a 3-D plotted chart crosses the value axis (z-
axis).    If the Auto check box is selected, the floor crosses at zero or at the number 
closest to zero in the value axis range.

Logarithmic Scale
Recalculates the Minimum, Maximum, Major Unit, and Minor Unit values as powers of 
10, based on the range of data plotted in the chart.    No zero or negative data values 
are permitted on logarithmic charts.    The Major Unit and Minor Unit must both be at 
least 10.    If you type a value that is not a power of 10 in the Maximum or Minimum 
box, it will be rounded up or down to the next power of 10.

Values In Reverse Order (or Categories In Reverse Order)
Inverts the chart and displays the lowest scale value at the chart top and the highest 
scale value at the chart bottom. 
This option changes to Categories In Reverse Order for the x-axis of an xy (scatter) 
chart and reverses the x-axis scale.    This option is not available for radar charts.

Category (X) Axis Crosses At Maximum Value (or Value (Y) Axis Crosses At 
Maximum Category)

Makes the category axis cross the value axis at the highest value.    This option 
overrides the Category (X) Axis Crosses At value.
This option changes to Value (Y) Axis Crosses At Maximum Category for the x-axis on 
an xy (scatter) chart, and displays the y-axis at the highest x-axis value.
For 3-D charts plotted with three axes, this option changes to the Floor (XY Plane) 
Crosses At Minimum Value option.    This option is not available for radar charts.

Floor (XY Plane) Crosses At Minimum Value
Displays the floor of a 3-D plotted chart at the lowest value on the chart.    This option 
overrides the Floor (XY Plane) Crosses At value.

Patterns
Displays the Patterns dialog box so you can format the axis, tick mark type, and tick 
labels.

Font



Displays the Font dialog box so you can format the axis font, size, style, color, and 
background.

Text
Displays the Text dialog box so you can select the axis text orientation.

Series Axis Scale Options
Number Of Series Between Tick Labels

Specifies which data series are labeled.
Type 1 to label every series, 2 to label every other series, 3 to label every third series, 
and so on.

Number Of Series Between Tick Marks
Specifies the number of data series between each pair of tick marks. 

Series In Reverse Order
Reverses the displayed order of the data series.    This does not reverse the plot order 
of the series.

Patterns
Displays the Patterns dialog box so you can format the axis, tick mark type, and tick 
labels.

Font
Displays the Font dialog box so you can format the axis font, size, style, color, and 
background.

Text
Displays the Text dialog box so you can select the axis text orientation.

See Also
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



Send To Back Command (Format Menu for Worksheets)
Places selected objects behind all other objects.

This command has no effect if the selected object is already in back.
See Also

Help

Send To Back Tool
Bring To Front Command (Format Menu for Worksheets)
Selecting a graphic object
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Size Command (Format Menu for Charts)
Lets you size arrows and text boxes in a chart using the arrow keys.
Shortcut: Use the mouse to size chart arrows and unattached text.
See Also

Help
Moving or sizing an arrow
Adding or deleting unattached chart text



Style Command (Format Menu for Worksheets)
Lets you define a cell style by choosing the combination of formats you want and assigning 
them a name.    You can apply the defined style to various worksheets and copy it for use in 
other files.

You can create styles in three ways:    by definition, by example, or by copying styles 
from another file.

You can change a style by redefining the style name.    Cells formatted with the style 
are automatically updated to reflect the new formats.

You can also select a style from the Style box on the toolbar.
Style Name

Displays the name of the style applied to the selected cells and lists the existing styles.
Description

Describes the format of the selected style.    You can accept this definition as the style or 
choose the Define button to change the style definition.

Define
Displays attributes you can choose from to define a new style or redefine existing styles.

Style Includes
Lists the cell attributes you can choose to have included in a style:    Number, Font, 
Alignment, Border, Patterns, and Protection.    Select an attribute check box to change the
format of that attribute when the style is applied; clear an attribute check box to retain 
the current selection's formatting when the style is applied.

Number, Font, Alignment, Border, Patterns, and Protection
Buttons that allow you to change the format of these attributes when you define a style.

Add
After defining a style, choose the Add button to add the style.

Delete
After selecting a style name, choose the Delete button to delete the style.

Merge
Choose the Merge button to copy styles from one document to another.

See Also
Help

Comma Style Tool
Currency Style Tool
Percent Style Tool
Style Box

Applying a style
Copying styles from another document
Creating or deleting a style
Redefining a style
Redefining the Normal style
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"





Text Command (Format Menu for Charts)
Controls the alignment and orientation of selected text.

You can format a chart title, axis label, data series or data point label, unattached 
text, title, or tick labels.

The options available depend on the type of text that is selected.
Text Alignment

Controls the horizontal and vertical alignment of selected chart text within its text border. 
This option is not available for tick labels.

Orientation
Controls the orientation of selected chart text.    If there is too much text to format into a 
single line, Microsoft Excel wraps the text into lines. 
If a chart axis is selected, controls orientation of the tick-mark labels.    If the orientation 
of the labels has been changed, the Automatic option button restores the original 
orientation.

Automatic Text
If you created text with the Attach Text command on the Chart menu and later edited it, 
this option restores the original text.

Automatic Size
Sizes the border to fit exactly around the text.    The border changes automatically if the 
text is changed.

Show Value
If a data point or series label is selected, this option replaces the label with the value of 
the data point.

Show Key
If a data point or series label is selected, this option displays the pattern used by the data
point or series label next to the label.

Patterns
Applies the text changes you've made and displays the Patterns dialog box.

Font
Applies the text changes you've made and displays the Font dialog box.

Scale
Applies the text changes you've made and displays the Scale dialog box.    Available only 
when an axis is selected.

See Also
Help

Rotate Text Down Tool
Rotate Text Up Tool
Vertical Text Tool

Formatting chart text alignment and orientation
Formatting tick-mark label orientation
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



Text Command (Format Menu for Worksheets)
Controls the alignment and orientation of selected text.
Text Alignment

Controls the horizontal and vertical alignment of selected text within its text border.
Orientation

Controls the orientation of selected text.    If there is too much text to format into a single 
column, Microsoft Excel wraps the text into additional columns. 

Automatic Size
Sizes the border to fit exactly around the text.    The border changes automatically if the 
text is changed.

Font
Applies the text changes you've made and displays the Font dialog box.

Patterns
Applies the text changes you've made and displays the Patterns dialog box.

See Also
Help

Rotate Text Down Tool
Rotate Text Up Tool
Vertical Text Tool

Aligning text box or button text
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Format Menu
The Format menu changes depending on whether the active document is a worksheet or a 
chart.    For more information, see the Format Menu for Charts or the Format Menu for 
Worksheets.



AutoFormat Command (Format Menu for Worksheets)
Allows you to automatically apply a built-in format to a range of cells or a table on a 
worksheet.    Microsoft Excel provides a variety of automatic formats that apply combined 
formats for numbers, alignments, fonts, borders, patterns and shading, column width, and 
row height.

You can clear an automatic format immediately after choosing it, by choosing Undo 
AutoFormat from the Edit menu.

You can retain any formatting you have already applied to a worksheet by choosing 
the Options button and then clearing the appropriate check box.
Shortcut: AutoFormat tool (Standard or Formatting toolbar)    Applies the last AutoFormat 

used.
Table Format

Lists the available built-in formats.    
Sample

Displays an example of the format selected in the Table Format list.
Options

Displays a list of formats to apply.    
Formats To Apply

Lists the format categories.    Clear the check boxes for the types of formatting you 
don't want to change.    Changes are reflected in the Sample box.

See Also
Help

AutoFormat Tool
Formatting a table using AutoFormat
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Formula Menu
Paste Name

Inserts the selected name into the formula bar.
Paste Function

Inserts the selected function into the formula bar.
Reference

Converts the selected references in the formula bar from relative to absolute, absolute to 
mixed, and mixed to relative.

Define Name
Creates a name for a cell, range, value, or formula.

Create Names
Uses text in the top or bottom row, the left or right column, or any combination of a 
selected range to name the rows and columns in the range.

Apply Names
Searches through formulas in the selected cells and replaces cell references with names 
defined for them.

Note
Allows you to add, delete, edit, or view notes for specific cells on the active worksheet.

Goto
Selects a cell or a named area you specify.

Find
Searches for specified characters and selects the first cell containing those characters.

Replace
Finds specified characters and replaces them with other specified characters.

Select Special
Selects cells that have the characteristics you specify, or selects all objects.

Show Active Cell
Scrolls the worksheet until the active cell is visible.

Outline
Creates an outline from an existing worksheet or range.

Goal Seek
Changes the value in a specified cell until a formula dependent on that cell reaches the 
value you specify.

Solver *
Allows you to define the parameters of a problem you want to solve.

Scenario Manager **
Allows you to maintain multiple variations of a what-if analysis model.

* If this command does not appear on the Formula menu, you need to install the Solver add-
in application.    For more information, see Chapter 2, "Performing What-if Analysis on a 
Worksheet Model," in Book 2 of the Microsoft Excel User's Guide.
** If this command does not appear on the Formula menu, you need to install the Scenario 
Manager add-in macro.    For more information, see the Help topic on the Add-Ins command 
on the Options menu, or see Chapter 4, "Customizing Microsoft Excel," in Book 2 of the 



Microsoft Excel User's Guide.



Apply Names Command (Formula Menu)
Searches formulas in the selected cells and replaces references with names defined for 
them, if they exist.    You can name cells and ranges using the Define Name and the Create 
Names commands on the Formula menu.
Apply Names

Lists all names defined on a worksheet.    Select the name or names you want to use in 
place of references.

To select more than one name, hold down CTRL while you press the UP ARROW or DOWN 
ARROW key.    Then press the SPACEBAR to add the item to the selection.

Ignore Relative/Absolute
Replaces references with names regardless of the reference types of either the names or 
references.

If you clear this check box, replaces absolute references only with absolute names, 
relative references only with relative names, and mixed references only with mixed 
names.

Use Row And Column Names
Uses the names of row and column ranges containing the cells referred to if names for 
the exact cells referred to can't be found.

Options
Displays the following additional options.
Omit Column Name If Same Column

If the referenced cell is in the same column as the formula and within a row-oriented 
named range, replaces the reference with the row-oriented name without including a 
column-oriented name.

Omit Row Name If Same Row
If the referenced cell is in the same row as the formula within a column-oriented named
range, replaces reference with the column-oriented name without including a row-
oriented name.

Name Order
Determines which range name is listed first when a cell reference is replaced by both a 
row-oriented and a column-oriented range name.

See Also
Help
Create Names Command (Formula Menu)
Define Name Command (Formula Menu)
Defining a name
Replacing references in formulas with names
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



Create Names Command (Formula Menu)
Creates names using labels in a selected range.

Uses text in the top or bottom row, the left or right column, or any combination of a 
selected range to name the other cells in the range.

Text in Names cells in
Top row Rows below
Left column Columns to the right
Bottom row Rows above
Right column Columns to the left

If the cell at the edge of the selection contains a number formatted as a date, 
Microsoft Excel converts the date to text to create a name.    For example, a date formatted 
as "February 1, 1987" becomes "February_1_1987".

If a name is already defined on the worksheet, Microsoft Excel asks if you want to 
replace the existing definition of the name. 

From the Formula menu, choose Define Name to see a list of the names you've 
created and their references.
Shortcut: CTRL+SHIFT+F3

See Also
Help
Apply Names Command (Formula Menu)
Creating names
Define Name Command (Formula Menu)
Defining a name
Replacing references in formulas with names
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



Outline Command (Formula Menu)
Allows you to make an outline from an existing worksheet or range.    You can create one 
outline at a time on a worksheet and assign up to eight levels of information.    Microsoft 
Excel automatically outlines your worksheet or the range based on the formulas and 
direction of references.

References in your formulas must point in a consistent direction; for example, 
summary formulas that are always located below or to the right of detail data, referring to 
cells above or to the left.

Outline symbols are automatically displayed on worksheets that contain outlines.
You can hide or display individual rows or columns within levels. From the Format 

menu, choose the Row Height or Column Width command, and in the dialog box choose the 
Hide or Unhide button.
Shortcuts: ALT+SHIFT+LEFT ARROW (Promote a row or column)

ALT+SHIFT+RIGHT ARROW(Demote a row or column)
CTRL+8 (Show or hide outline symbols)
Show Outline Symbols tool (Utility toolbar)
Promote tool (Utility toolbar)
Demote tool (Utility toolbar)

Automatic Styles
Applies built-in cell styles for the summary rows and columns of an outline. Styles are 
applied to entire rows and columns.

Summary Rows Below Detail
Specifies the location of summary rows in the outline.

Summary Columns To Right Of Detail
Specifies the location of summary columns in the outline.

Create
Automatically assigns outline levels based on the formulas in your worksheet.    If the 
Automatic Styles check box is selected, Microsoft Excel applies the built-in cell styles as 
well.

Apply Styles
Applies row and column level styles to the selected outline, or the part of an outline, that 
does not currently have them.

Outline
Creates a new outline based on the options specified.

See Also
Help

       Demote Tool  
       Promote Tool  
       Show Outline Symbols Tool  
       Select Visible Cells Tool  

Assigning an outline level to a row or column
Collapsing an outline level
Creating an outline from a existing worksheet
Clearing an outline from a worksheet



Displaying an outline level
Displaying or hiding outline symbols
Expanding an outline level
Style Command (Format Menu)
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



Define Name Command (Formula Menu)
Creates a name for a cell, range, or constant or computed value.    You can then use this 
name to refer to the cell, range, or value.    Names make formulas easier to read, 
understand and maintain. You can change or delete names that have already been defined, 
and define constant or computed values that you intend to use later.    Names appear in the 
reference area of the formula bar when a named cell or an entire named range is selected.
Shortcut: CTRL+F3

Names In Sheet
Lists all names currently defined on the worksheet or macro sheet.
When you select a name from the list, the name appears in the Name text box and its 
reference appears in the Refers To box.

Name
If the active cell contains text, proposes that text as the name.    Otherwise, proposes text
in the cell to the left or above the active cell as the name.
You can accept or edit the proposed name, type a new name, or select a name from the 
Names In Sheet box.
The first character must be a letter, an underline character (_), or a backslash character 
(\).
The name can be as long as 255 characters, and can contain letters, numerals, 
underlines (_), backslashes (\), periods (.), and question marks (?).
Names that resemble numbers or cell references are not allowed.
If you use a name you have already defined, the new definition replaces the old 
definition.

Refers To
Displays the reference for the selected cell or range. Can be a cell range, a constant 
value, or a formula.
If you select a previously defined name in the list, proposes the range, value, or formula 
that name currently refers to.    If you type the previously defined name, the range, value, 
or formula is not displayed.
You can edit the reference.    While doing so, you can make worksheet selections, choose 
formula editing commands, and switch to and move windows.

Category
Appears in the dialog box only when a macro sheet is active.    The Category list is 
available only when the Command or Function option is selected in the Macro box.    
A list of available categories is displayed for command or function macros that you 
create.    You can assign a macro to an existing category, or you can create your own 
category.    The default category proposed is User Defined.    After you assign a macro to a 
category, the macro will appear in the Paste Function dialog box under that category.

Macro
Appears in the dialog box only when a macro sheet is active.
The Function and Command options indicate which type of macro you are naming.
If you're defining a command macro, you can also assign any letter as a shortcut key. 
Type any letter in the Key: Ctrl+ box.

OK
Adds the current entry in the Name and Refers To boxes to the list of names defined for 
the worksheet, and then closes the Define Name dialog box.

Close



Closes the Define Name dialog box without adding the current entry in the Name and 
Refers To boxes to the list of names defined for the worksheet.    However, any names 
already entered using the Add button remain.

Add
Adds the current entry in the Name and Refers To boxes to the list of names defined for 
the worksheet, without closing the Define Name dialog box, allowing you to define more 
names.

Delete
Deletes the name selected in the Names in Sheet box.    

See Also
Help
Create Names Command (Formula Menu)
Creating names
Defining a macro name
Defining a name
Deleting a name
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



Find Command (Formula Menu)
Searches selected cells or the entire worksheet for specified characters, and selects the first
cell containing those characters.

Unless you select a range of cells, Find searches the entire worksheet.
The Find command displays a message if no matching characters are found.

Shortcuts: SHIFT+F5
F7 (next)
SHIFT+F7 (previous)

Find What
Specifies what to search for.    Can include any letter, number, punctuation mark, or 
wildcard character.    Can include uppercase and lowercase characters and any letter, 
number, punctuation mark, or wildcard.    Does not distinguish between uppercase and 
lowercase characters.    To search for an actual wildcard character (* or ?), precede it with 
a tilde (~).
Proposes the last text or value you searched for, which you can accept or change.

Look In
Searches in cell formulas, cell values, or cell notes.

Look At
The Whole option searches for an exact and complete match of characters specified in 
the Find What box.    The Part option searches for any occurrence of those characters 
within cells.

Look By
Determines the direction of the search: across rows or down columns.    To reverse the 
search direction, hold down SHIFT while choosing the OK button.

Match Case
Distinguishes between uppercase and lowercase characters in the search text specified in
the Find What box.

See Also
Help
Finding characters
Replacing characters
User's Guide (Book 1)
Chapter 5,    "Creating a Worksheet"
Chapter 6,    "Editing a Worksheet"



Goal Seek Command (Formula Menu)
Adjusts the value in a specified cell until a formula dependent on that cell reaches the value
you specify.
Set Cell

Specifies the cell containing the formula for which you want to find a solution.    You can 
enter a cell reference or a name in this box.

To Value
Specifies the new value you want to reach.

By Changing Cell
Specifies the cell whose value you want Microsoft Excel to change to achieve the desired 
result.    You can enter a cell reference or a name in this box.

OK
Displays the Goal Seek Status dialog box.
OK

Replaces the value in the cell specified in the By Changing Cell box with the new value.
Cancel

Stops the calculation and preserves the original value.
Step

Proceeds through the goal-seeking calculation one step at a time.
Pause

Interrupts the calculation.    When you choose the Pause button, it changes to the 
Continue button.

Continue
Continues the calculation after a pause.    When you choose the Continue button, it 
changes back to the Pause button.

See Also
Help
Solving equations using goal seeking
Adjusting a data value by dragging a data marker
User's Guide (Book 2)
Chapter 2,    "Performing What-if Analysis on a Worksheet Model"



Goto Command (Formula Menu)
Scrolls the worksheet and selects the cell or range you specify.

The Reference entry in the Goto dialog box can be an intersection, a union, or a 
range of cell references or names.

You can go to a reference or a named area in another open worksheet by typing an 
external reference containing the sheet name, an exclamation point, and the desired 
reference or name.    For example, BUDGET.XLS!B3.

Named cells or ranges defined with the Define Name command on the Formula menu
appear in the Goto box.

The Goto dialog box stores the last four references from which you chose the Goto 
command.    These appear at the top of the Goto box, with the latest reference at the top of 
the list.

You can extend the selection from the current cell or range to the reference you enter
in the Goto dialog box by pressing SHIFT while you choose the OK button.

You can move back and forth between two parts of a worksheet by repeating the 
command.

When Goto is used while the formula bar is active, you can insert a reference that is 
listed in the Goto box into the formula.
Shortcut: F5

Goto
Lists all names defined on the active worksheet.    Also lists the last four references from 
which you chose the Goto command at the top of the list, with the latest one first.

Reference
Specifies the desired reference or named area.    If a name in the Goto list is selected, 
displays that name.

See Also
Help
Scrolling to and selecting specified cells or a named range
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



Note Command (Formula Menu)
Attaches comments to a cell.    You can add, edit, view, or delete notes on the active 
worksheet.

A cell note indicator appears in the upper right corner of the cell when a note is 
attached.

If a note already exists, double-click the cell to edit, view, or delete the note.    If a 
sound note is attached and your system is capable of playing it, the sound note will play 
automatically after you double-click.

A note does not appear in the cell, but you can view it by using the Note command 
on the Formula menu or by choosing the Workspace command on the Options menu and 
selecting the Show Info check box.

You can print notes using the Page Setup and Print commands on the File menu while 
the worksheet or the Show Info window is active.
Shortcut: SHIFT+F2

Cell
Displays the reference of the active cell or the cell selected in the Notes In Sheet box.

Notes In Sheet
Lists the cell reference and partial note text for each note on the worksheet. If a cell 
contains a sound note, an asterisk (*) appears next to the cell reference.

Text Note
Shows the text of the note selected in the Notes In Sheet box.    Enter, edit, or view text 
notes here.    
Pressing CTRL+ENTER starts a new line.

Add
Attaches the current text note and sound note to the cell in the Cell box.    The Cell Note 
dialog box remains open so you can continue adding, editing, or deleting other notes.

Delete
Deletes the note selected in the Notes In Sheet box and removes the cell note indicator.    
Does not otherwise affect the cell to which the note was attached.

OK
Attaches the new or changed text or sound note to the cell in the Cell box, and then 
closes the Cell Note dialog box.

Close
Closes the Cell Note dialog box, but does not cancel your actions; any notes you have 
added, edited, or deleted remain as you changed them.

Sound Note
Allows you to attach sounds to the cell in the Cell box. This feature is available only if you 
have the necessary hardware and software to record and/or play sounds.
If a cell has only a sound note attached without a text note, double-clicking the cell 
causes the sound note to be played immediately; otherwise, the Cell Note dialog box 
appears first, and then the sound note plays.
Record/Erase

Displays the Record dialog box containing Record, Stop, Pause, and Play buttons, as 
well as a time scale showing elapsed recording time relative to the total amount 
available.
If a selected cell has a sound note attached, the Record button in the Cell Note dialog 
box changes to an Erase button, allowing you to remove the sound note from the cell.



Play
Allows you to play a sound note in a selected cell. 

Import
Displays the Open dialog box listing available sound files.

See Also
Help
Copying a text or sound note to another cell
Creating or editing a note
Creating a sound note
Deleting a note
Displaying or hiding cell note indicators
Playing a sound note
Removing a sound note
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



Paste Function Command (Formula Menu)
Inserts the selected function into the formula bar.

If the formula bar is active and you began the formula by typing an equal sign (=), 
Paste Function pastes the selected function at the insertion point.

If the formula bar is not active, Paste Function activates it and pastes an equal sign 
(=) followed by the selected function.
Shortcuts: Paste Function tool (Utility toolbar)

SHIFT+F3

Function Category
Allows you to select subsets of all available functions.    If All is selected in the Function 
Category box, all available functions are listed.    If any other category is selected, lists 
only those functions that belong to that category.    Custom functions that you define are 
listed under their assigned categories, or in the User Defined category if no other 
categories are assigned.    Macro function categories are available only when a macro 
sheet is active.

Function
Lists all built-in and custom functions that are available in the selected category.    Also 
lists built-in and custom macro functions if a macro sheet is active. The display area 
below the Function Category list box shows the selected function with its argument 
names. If there is more than one form of the selected function, an ellipsis (...) is displayed
in place of the arguments.

Paste Arguments
Pastes a function's argument names into the formula bar along with the function's name.  
For example, Paste Function pastes DATE(year,month,day) when Paste Arguments is 
selected; otherwise, it pastes DATE().    You must then replace these argument names with
the actual arguments you want to use.
Select Arguments

This dialog box appears when the Paste Arguments box is selected and you select a 
function that has more than one form.    The Select Arguments box lists the different 
sets of arguments available for all the forms of the selected function.

See Also
Help

Paste Function Tool
Pasting functions

Toolbars Command (Options Menu)
Worksheet functions
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



Paste Name Command (Formula Menu)
Inserts the selected name into the formula bar.    

If the formula bar is active and you began a formula by typing an equal sign (=), 
Paste Name pastes the selected name at the insertion point. 

If the formula bar is not active, Paste Name activates it and pastes an equal sign (=) 
followed by the selected name.
Shortcuts: Paste Names tool (Utility toolbar)

F3

Paste Name
Lists all names defined on the active worksheet or macro sheet.    

Paste List
Pastes all names defined on your worksheet or macro sheet, starting at the active cell. On
a worksheet, the list of names is an area two columns wide. The left column lists names; 
the right column lists cell references that the names refer to.    On a macro sheet, the list 
of names is five columns wide and includes a name column, a reference column, a 
column for the type of macro (0=none, 1=function, 2=command), a column for assigned 
shortcut keys, and a column for the category.

See Also
Help

Paste Names Tool
Defining a name
Pasting names

Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



Reference Command (Formula Menu)
Changes the reference type of selected references in the formula bar from relative to 
absolute, from absolute to mixed, and from mixed back to relative.

Reference Changes to Description
A1 $A$1 Relative to absolute
$A$1 A$1 Absolute to mixed
A$1 $A1 Mixed to mixed
$A1 A1 Mixed to relative

This command is available only when you are editing a formula in the formula bar.
A reference is selected when it or the formula containing it is highlighted in the 

formula bar, when the insertion point is within the reference, or when the insertion point is 
to the immediate right or left of the reference.    If more than one reference is selected, the 
Reference command changes the type of all selected references simultaneously. If there are 
different reference types in the selection, the Reference command changes each reference 
to the next type according to the table above.
Shortcut: F4

See Also
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



Replace Command (Formula Menu)
Finds and replaces characters in selected cells or on the entire worksheet.

Unless you select a range of cells, Replace searches the entire worksheet.
Replace displays a message if nothing matches.
Searched characters and replacement characters can include text, numbers, 

formulas, or parts of formulas.
Find What

Specifies what to search for.    Can include any letter, number, punctuation mark, or 
wildcard character.    Can include uppercase and lowercase characters.    Does not 
distinguish between uppercase and lowercase characters.    To search for an actual 
wildcard character (* or ?), precede it with a tilde (~).
Proposes the last text or value you searched for, which you can accept or change.

Replace With
Identifies the characters that will replace the characters searched for.    Proposes the 
characters last used for replacement.

Look At
The Whole option searches for an exact and complete match of the characters specified 
in the Find What box. The Part option searches for any occurrence of those characters 
within cells.

Look By
Determines the direction of the search: across rows or down columns.

Match Case
Distinguishes between uppercase and lowercase characters in the search text specified in
the Find What box.

Replace All
Finds and replaces every occurrence of the characters in the Find What box with the 
characters in the Replace With box.

Close
Closes the dialog box but does not affect replacements already made.

Find Next
Finds the next occurrence of the characters specified in the Find What box.
To find the previous occurrence, press SHIFT while you choose the Find Next button.

Replace
Replaces the searched characters in the active cell with the new characters and then 
finds the next occurrence of the searched characters.    To find and replace the previous 
occurrence, press SHIFT while you choose Replace.    To replace without finding the next 
cell, press CTRL while you choose Replace.

See Also
Help
Finding characters
Replacing characters
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



Select Special Command (Formula Menu)
Selects cells that have the characteristics specified in the dialog box, or selects all objects.

The resulting selection can contain many cells and ranges.
To search the entire worksheet, select a single cell before choosing the Select Special 

command; to search only a specific range, select that range.
When searching for precedents or dependents, Microsoft Excel always searches the 

entire worksheet.    The selection determines the cells whose precedents or dependents are 
searched for.
Notes

Selects all cells that contain a note.
Shortcut: CTRL+SHIFT+?

Constants
Selects all cells that contain constants, based on the check boxes you select.
Numbers

Selects constant numbers.
Text

Selects constant text.
Logicals

Selects cells containing the logical values TRUE and FALSE that were entered as 
constants.

Errors
Selects cells containing error values that were entered as constants.

Formulas
Selects all cells that contain formulas, based on the check boxes you select.

Numbers
Selects cells with formulas that produce numbers.

Text
Selects cells with formulas that produce text.

Logicals
Selects cells with formulas that produce the logical values TRUE and FALSE.

Errors
Selects cells with formulas that produce error values.

Blanks
Selects all blank cells.

Current Region
Selects a rectangular range of cells around the active cell.    The range selected is an area 
bounded by any combination of blank rows and blank columns.
Shortcuts: Select Current Region tool (Utility Tools category)

CTRL+* (asterisk on keypad)
Current Array

Selects the entire array to which the active cell belongs, if any.
Shortcut: CTRL+/

Row Differences



Selects cells whose contents are different from the comparison cell in each row.    For each
row, the comparison cell is in the same column as the active cell.
Shortcut: CTRL+\

Column Differences
Selects cells whose contents are different from the comparison cell in each column.    For 
each column, the comparison cell is in the same row as the active cell.
Shortcut: CTRL+SHIFT+|

Precedents
Selects cells to which the formulas in the selected cells refer.
Direct Only 

Selects only cells directly referred to by formulas in the selection.
Shortcut: CTRL+[

All Levels
Selects all cells directly or indirectly referred to by cells in the selection.
Useful for selecting the entire network of cells that affect a particular cell in a complex 
worksheet.
Useful for tracking the logic of a model one step at a time.
Shortcut: CTRL+SHIFT+{ 

Dependents
Selects cells with formulas that refer to the cells in the current selection.
Direct Only 

Selects only cells with formulas that refer directly to the cells in the selection.
Shortcut: CTRL+] 

All Levels 
Selects all cells that directly or indirectly refer to cells in the selection.
Useful for selecting the entire network of cells that depend on a particular cell in a 
complex worksheet.
Useful for tracking the logic of a model one step at a time.
Shortcut: CTRL+SHIFT+}

Last Cell
Selects the last cell that contains data or formatting in the worksheet or macro sheet.

Visible Cells
Selects the visible cells on a worksheet so that changes you make affect only the visible 
cells and not the hidden rows or columns.
Shortcut: Select Visible Cells tool (Utility toolbar)

Objects
Selects all graphic objects, including buttons and text boxes.

See Also
Help

Select Current Region Tool
Select Visible Cells Tool

Finding cells referred to by formulas in selected cells (precedents)



Finding cells with formulas that refer to selected cells (dependents)
Utility Tools Category
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"
Chapter 8, "Organizing and Documenting a Worksheet"



Show Active Cell Command (Formula Menu)
Scrolls the worksheet until the active cell is visible.
See Also

User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"
Chapter 8, "Organizing and Documenting a Worksheet"



Gallery Menu
Area 

Changes the format of the active chart to the area chart format you specify.
Bar 

Changes the format of the active chart to the bar chart format you specify.
Column

Changes the format of the active chart to the column chart format you specify.
Line

Changes the format of the active chart to the line chart format you specify.
Pie 

Changes the format of the active chart to the pie chart format you specify.
Radar

Changes the format of the active chart to the radar chart format you specify.
XY (Scatter) 

Changes the format of the active chart to the xy (scatter) chart format you specify.
Combination 

Changes the active chart into a combination of main and overlay charts.
3-D Area 

Changes the format of the active chart to the three-dimensional (3-D) area chart format 
you specify.

3-D Bar 
Changes the format of the active chart to the 3-D bar chart format you specify.

3-D Column 
Changes the format of the active chart to the 3-D column chart format you specify.

3-D Line 
Changes the format of the active chart to the 3-D line chart format you specify.

3-D Pie 
Changes the format of the active chart to the 3-D pie chart format you specify.

3-D Surface
Changes the format of the active chart to the 3-D surface chart format you specify.

Preferred 
Changes the format of the active chart to the format you define as preferred.

Set Preferred 
Makes the format of the active chart the preferred format which is the default format for 
new charts.



3-D Area Command (Gallery Menu)
Changes the format of the active chart to the 3-D area chart format you specify.    A 3-D area
chart emphasizes the sum of plotted values and separates series into distinct rows to show 
differences between the series.

If the chart has an overlay, choosing this command deletes the overlay.
3-D area chart formats

1 Stacked area chart with 3-D markers
2 Stacked 3-D areas and labels
3 Stacked 3-D areas and drop lines
4 Stacked 3-D areas and gridlines
5 3-D areas, each series plotted separately

Shortcut: 3-D Area Chart tool
6 3-D areas plotted separately with gridlines
7 3-D areas plotted separately with x-axis and y-axis gridlines only

Next
Displays the gallery for the next chart type on the Gallery menu.

Previous
Displays the gallery for the previous chart type on the Gallery menu.

See Also
Help

3-D Area Chart Tool
Creating a chart
User's Guide (Book 1)
Chapter 12, "Creating a Chart"



3-D Bar Command (Gallery Menu)
Changes the format of the active chart to the 3-D bar chart format you specify.    A 3-D bar 
chart emphasizes the values of individual figures at a specific time or draws comparisons 
among items.    It is similar to a 3-D column chart, but the vertical ordering of the bars 
places less emphasis on the flow of time and more on the comparisons.    The stacked and 
100% options show relationships to the whole.

If the chart has an overlay, choosing this command deletes the overlay.
3-D bar chart formats

1 Simple bar chart with 3-D markers
Shortcut: 3-D Bar Chart tool

2 Stacked 3-D bars
3 Stacked 100% 3-D bars
4 3-D bars with value axis (z-axis) gridlines

Next
Displays the gallery for the next chart type on the Gallery menu.

Previous
Displays the gallery for the previous chart type on the Gallery menu.

See Also
Help

3-D Bar Chart Tool
Creating a chart
User's Guide (Book 1)
Chapter 12, "Creating a Chart"



3-D Column Command (Gallery Menu)
Changes the format of the active chart to the 3-D column chart format you specify.    A 3-D 
column chart emphasizes the comparison of data points along two axes--a category axis 
and a series axis--so you can compare data points within a series more easily, yet still view 
data by category.

If the chart has an overlay, choosing this command deletes the overlay.
3-D column chart formats

1 Simple column chart with 3-D markers
Shortcut: 3-D Column Chart tool

2 Stacked 3-D columns
3 Stacked 100% 3-D columns
4 3-D columns with value axis (z-axis) gridlines
5 3-D columns, each series plotted separately

Shortcut: Perspective 3-D Column Chart tool
6 3-D columns plotted separately with gridlines
7 3-D columns plotted separately with x-axis and y-axis gridlines only

Next
Displays the gallery for the next chart type on the Gallery menu.

Previous
Displays the gallery for the previous chart type on the Gallery menu.

See Also
Help

3-D Column Chart Tool
Perspective 3-D Column Chart Tool

Creating a chart
User's Guide (Book 1)
Chapter 12, "Creating a Chart"



3-D Line Command (Gallery Menu)
Changes the format of the active chart to the 3-D line chart format you specify.    Shows 
lines in a line chart as 3-D ribbons.    This makes individual lines easier to view, particularly 
when they cross, while still showing all series in one chart for comparison.

If the chart has an overlay, choosing this command deletes the overlay.
3-D line chart formats

1 3-D line chart
Shortcut: 3-D Line Chart tool

2 3-D line chart with gridlines
3 3-D line chart with x-axis and y-axis gridlines only
4 3-D line chart with logarithmic value (z) axis and gridlines

Next
Displays the gallery for the next chart type on the Gallery menu.

Previous
Displays the gallery for the previous chart type on the Gallery menu.

See Also
Help

3-D Line Chart Tool
Creating a chart
User's Guide (Book 1)
Chapter 12, "Creating a Chart"



3-D Pie Command (Gallery Menu)
Changes the format of the active chart to the 3-D pie chart format you specify.    Shows a pie
chart with 3-D slices. 

If the chart has an overlay, choosing this command deletes the overlay.
3-D pie chart formats

1 Each slice patterned or colored differently
2 All slices patterned and colored the same and labeled with categories
3 First slice exploded
4 All slices exploded
5 With category labels
6 With value labels expressed as percentages

Shortcut: 3-D Pie Chart tool
7 With category labels and value labels expressed as percentages

Next
Displays the gallery for the next chart type on the Gallery menu.

Previous
Displays the gallery for the previous chart type on the Gallery menu.

See Also
Help

3-D Pie Chart Tool
Creating a chart
User's Guide (Book 1)
Chapter 12, "Creating a Chart"



3-D Surface Command (Gallery Menu)
Changes the format of the active chart to the surface chart format you specify.    Creating a 
surface chart is like stretching a rubber sheet over a regular 3-D column chart.    Color is 
used in a surface chart not to mark data series, but to indicate areas that are at the same 
height, as in a 3-D topographic map.    A wireframe chart is the same as a surface chart but 
without color.    The third and fourth chart formats provide 2-D views of these charts from 
above, like 2-D topographic maps.

If the chart has an overlay, this command deletes the overlay.
Colors cannot be edited directly.    To change colors in a surface chart, you must 

change the colors in the color palette.
If the chart is a separate chart document, you can change the colors in the color 

palette for that document.
If the chart is embedded in a worksheet, you can change the colors in the color 

palette for that worksheet.
3-D surface chart formats

1 3-D surface chart
Shortcut: 3-D Surface Chart tool

2 3-D wireframe chart
3 Contour chart (surface chart viewed from above)
4 Contour chart (wireframe chart viewed from above)

Next
Displays the gallery for the next chart type on the Gallery menu.

Previous
Displays the gallery for the previous chart type on the Gallery menu.

See Also
Help

3-D Surface Chart Tool
Creating a chart
User's Guide (Book 1)
Chapter 12, "Creating a Chart"



Area Command (Gallery Menu)
Changes the format of the active chart to the area chart format you specify.    An area chart 
shows how values change in proportion to the total over a period of time. It is similar to a 
line chart, but emphasizes magnitude of values rather than flow of time and rate of change. 
The 100% option shows relationships to the whole.

If the chart has an overlay, choosing this command deletes the overlay.
Area chart formats

1 Simple area chart
Shortcut: Area Chart tool

2 100% area chart
3 Area chart with drop lines 
4 Area chart with gridlines 
5 Area chart with areas labeled

Next
Displays the gallery for the next chart type on the Gallery menu.

Previous
Displays the gallery for the previous chart type on the Gallery menu.

See Also
Help

Area Chart Tool
Creating a chart
User's Guide (Book 1)
Chapter 12, "Creating a Chart"



Bar Command (Gallery Menu)
Changes the format of the active chart to the bar chart format you specify.    A bar chart 
shows individual figures at a specific time or draws comparisons among items.    It is similar 
to a column chart, but the vertical ordering of bars places less emphasis on the flow of time 
and more on the comparisons.    The stacked and 100% options show relationships to the 
whole.

If the chart has an overlay, choosing this command deletes the overlay.
Bar chart formats

1 Simple bar chart
Shortcut: Bar Chart tool

2 Bar chart for one series with varied patterns or colors
3 Stacked bar chart
4 Overlapped bar chart
5 Stacked 100% bar chart
6 Bar chart with vertical gridlines
7 Bar chart with value labels
8 Step chart (no space between categories)
9 Stacked bar chart with series lines

10 Stacked 100% bar chart with series lines
Next

Displays the gallery for the next chart type on the Gallery menu.
Previous

Displays the gallery for the previous chart type on the Gallery menu.
See Also

Help

Bar Chart Tool
Creating a chart
User's Guide (Book 1)
Chapter 12, "Creating a Chart"



Column Command (Gallery Menu)
Changes the format of the active chart to the column chart format you specify.    A column 
chart shows variations over a period of time or draws comparisons among items.    The 
stacked and 100% options show relationships to the whole.

If the chart has an overlay, choosing this command deletes the overlay.
Column chart formats

1 Simple column chart
Shortcut: Column Chart tool

2 Column chart for one series with varied patterns
3 Stacked column chart

Shortcut: Stacked Column Chart tool
4 Overlapped column chart
5 Stacked 100% column chart
6 Column chart with horizontal gridlines
7 Column chart with value labels
8 Step chart (no space between categories)
9 Stacked column chart with series lines

10 Stacked 100% column chart with series lines
Next

Displays the gallery for the next chart type on the Gallery menu.
Previous

Displays the gallery for the previous chart type on the Gallery menu.
See Also

Help

Column Chart Tool
Stacked Column Chart Tool

Creating a chart
User's Guide (Book 1)
Chapter 12, "Creating a Chart"



Combination Command (Gallery Menu)
Changes the active chart into the combination of two chart types you specify.    A 
combination chart consists of two charts: a main chart with an overlay chart above.    It 
shows data that may be related but measured in different units.    Combination charts are 
useful for comparing two different kinds of data or juxtaposing series to show correlations 
that might not otherwise be recognized.

If there is an even number of data series, the first half appear on the main chart and 
the second half on the overlay chart. 

If there is an odd number of data series, the main chart will have one series more 
than the overlay chart.    For example, in a chart with five data series, the first three appear 
on the main chart and the last two on the overlay chart.

You can change the order in which the series are plotted with the Edit Series 
command on the Chart menu and the Overlay command on the Format menu.
Combination chart formats

1 Column chart overlaid by a line chart
Shortcut: Line/Column Chart tool

2 Column chart overlaid by a line chart with an independent y-axis scale
3 Line chart overlaid by a line chart with an independent y-axis scale
4 Area chart overlaid by a column chart
5 Column chart overlaid by a line chart containing three data series (for showing stock 

volumes related to high, low, and closing prices)
Shortcut: Volume/Hi-Lo-Close Chart tool

6 Column chart overlaid with open-high-low-close chart (for showing stock volumes 
related to opening, high, low, and closing prices)

Next
Displays the gallery for the next chart type on the Gallery menu.

Previous
Displays the gallery for the previous chart type on the Gallery menu.

See Also
Help

Line/Column Chart Tool
Volume/Hi-Lo-Close Chart Tool

Creating a chart
User's Guide (Book 1)
Chapter 12, "Creating a Chart"



Line Command (Gallery Menu)
Changes the format of the active chart to the line chart format you specify.    A line chart 
shows trends or changes in data over a period of time. It is similar to an area chart, but 
emphasizes the flow of time and rate of change rather than the magnitude of values. This 
type is often used for stock quotes.

If the chart has an overlay, choosing this command deletes the overlay.
Line chart formats

1 Simple line chart with lines and markers
Shortcut: Line Chart tool

2 Line chart with lines only
3 Line chart with markers only
4 Line chart with lines and markers with horizontal gridlines
5 Line chart with lines and markers with horizontal and vertical gridlines
6 Line chart with lines and markers with logarithmic scale and gridlines
7 Hi-lo chart with markers and hi-lo lines
8 Hi-lo-close chart (for stock quotes)
9 Open-hi-lo-close chart (for stock quotes)

Next
Displays the gallery for the next chart type on the Gallery menu.

Previous
Displays the gallery for the previous chart type on the Gallery menu.

See Also
Help

Line Chart Tool
Creating a chart
User's Guide (Book 1)
Chapter 12, "Creating a Chart"



Pie Command (Gallery Menu)
Changes the format of the active chart to the pie chart format you specify.    A pie chart 
shows the relationship of parts to the whole.    It can contain only one series.

If the chart has an overlay, choosing this command deletes the overlay.
Pie chart formats

1 Each slice patterned or colored differently
2 All slices patterned and colored the same and labeled with categories
3 First slice exploded
4 All slices exploded
5 With category labels
6 With value labels expressed as percentages

Shortcut: Pie Chart tool
7 With category labels and value labels expressed as percentages

Next
Displays the gallery for the next chart type on the Gallery menu.

Previous
Displays the gallery for the previous chart type on the Gallery menu.

See Also
Help

Pie Chart Tool
Creating a chart
User's Guide (Book 1)
Chapter 12, "Creating a Chart"



Radar Command (Gallery Menu)
Changes the format of the active chart to the radar chart format you specify.    Each 
category in a radar chart has its own axis radiating from the center point.    The data points 
belonging to the same series are connected by lines.

If the chart has an overlay, choosing this command deletes the overlay.
Radar chart formats

1 Radar chart with lines and markers
Shortcut: Radar Chart tool

2 Radar chart with lines only
3 Radar chart with lines and without axes
4 Radar chart with lines, axes, and gridlines
5 Radar chart with logarithmic scale

Next
Displays the gallery for the next chart type on the Gallery menu.

Previous
Displays the gallery for the previous chart type on the Gallery menu.

See Also
Help

Radar Chart Tool
Creating a chart
User's Guide (Book 1)
Chapter 12, "Creating a Chart"



Preferred Command (Gallery Menu)
Changes the format of the active chart to the previously defined "preferred" chart format.

Use the Set Preferred command on the Gallery menu to define your preferred chart 
format.

If you haven't specified a preferred format, Microsoft Excel uses the simple column 
chart (the first option in the gallery for the column chart type).

You can retrieve a preferred chart from a workbook if you saved it with the Save 
Workbook command on the File menu.    Loading the workbook sets the preferred format to 
the one saved with the workbook.
Shortcut: Preferred Chart tool (Chart Toolbar)
See Also

Help

Preferred Chart Tool
Creating a chart
Set Preferred Command (Gallery Menu)
Save Workbook
User's Guide (Book 1)
Chapter 12, "Creating a Chart"



Set Preferred Command (Gallery Menu)
Changes the default format Microsoft Excel uses when you create a new chart with the New 
command from the File menu, or when you change the format of an existing chart using the 
Preferred command on the Gallery menu.

Until you use this command to specify a preferred format, Microsoft Excel uses the 
simple column chart (the first option in the gallery for the column chart type) as the default 
format.

The new preferred chart setting remains in effect for the current work session only.    
When you quit Microsoft Excel and start it again, the preferred chart setting will be the 
Microsoft Excel default, the simple column chart.

You can save your preferred format in a workbook file with the Save Workbook 
command on the File menu, or use a chart template.
See Also

Help

Preferred Chart Tool
Creating a chart
Creating a new template
New Command (File Menu)
Preferred Command (Gallery Menu)
Save Workbook Command (File Menu)

User's Guide (Book 1)
Chapter 12, "Creating a Chart"
Chapter 13, "Editing a Chart"



XY (Scatter) Command (Gallery Menu)
Changes the format of the active chart to the xy (scatter) chart format you specify.    An xy 
(scatter) chart shows the relationship or degree of relationship between numeric values in 
different groups of data. It is useful for finding patterns or trends and for determining 
whether variables are dependent on or affect one another.

If the chart has an overlay, choosing this command deletes the overlay.
XY (scatter) chart formats

1 XY chart with data point markers only
Shortcut: XY (Scatter) Chart tool

2 XY chart with markers from the same series connected by lines
3 XY chart with markers with horizontal and vertical gridlines
4 XY chart with markers with logarithmic y axis and gridlines
5 XY chart with markers with log-log axes and gridlines

Next
Displays the gallery for the next chart type on the Gallery menu.

Previous
Displays the gallery for the previous chart type on the Gallery menu.

See Also
Help

XY (Scatter) Chart Tool
Creating a chart
User's Guide (Book 1)
Chapter 12, "Creating a Chart"



Help Menu
Contents

Displays the Help table of contents.
Search

Displays the Search dialog box, which allows you to search for Help topics by typing or 
selecting a keyword.

Product Support
Gives details on all the product support services for Microsoft Excel.

Introducing Microsoft Excel
Starts an introductory tutorial.    The lessons include a basic lesson that teaches you the 
fundamental features of Microsoft Excel, a lesson describing what's new in Microsoft Excel
version 4.0, and a lesson for Lotus 1-2-3 users.

Learning Microsoft Excel
Starts a tutorial on using Microsoft Excel.    The lessons cover worksheets, charts, 
databases, macros, and toolbars.

Lotus 1-2-3
Displays a dialog box that shows the Microsoft Excel equivalent to a Lotus 1-2-3 menu 
item.

Multiplan
Displays a dialog box that shows the Microsoft Excel equivalent to a Multiplan command.

About Microsoft Excel
Displays the version number of Microsoft Excel you are using and how much memory is 
available.



About Microsoft Excel Command (Help Menu)
Displays the version number of Microsoft Excel you are using, how much memory is 
available, and whether a math co-processor is installed.    Also shows the user name, 
organization name, and software serial number.
See Also

User's Guide (Book 1)
Chapter 1, "Getting Started with Microsoft Excel"



Contents Command (Help Menu)
Displays the Microsoft Excel Help table of contents.

With the mouse, click the name of the topic you want.
--Or--

Press TAB to move to the topic you want, and then press ENTER.
See Also

Tutorial
"Learning Microsoft Excel"
User's Guide (Book 1)
Chapter 2, "Learning Microsoft Excel"



Search Command (Help Menu)
Displays the Search dialog box, which allows you to search for Help topics by typing or 
selecting a keyword.
Keyword

Type an entry or select one from the list, and then choose the Show Topics button.
Topics

Select a Help topic from the list and then choose the Go To button.
Shortcut: Double-click a Help topic in the list.
Microsoft Excel displays the selected Help topic.

See Also
Tutorial
"Learning Microsoft Excel"
User's Guide (Book 1)
Chapter 2, "Learning Microsoft Excel"



Lotus 1-2-3 Command (Help Menu)
Displays a dialog box that helps you learn Microsoft Excel equivalents to Lotus 1-2-3 menu 
items.    You can display the instructions for the equivalent command on your worksheet, or 
you can view a demonstration showing the Microsoft Excel steps.
See Also

Help
Help for Lotus 1-2-3 Users
Microsoft Excel Equivalents for Frequently Used Lotus 1-2-3 Commands
Switching from Lotus 1-2-3
Tutorial
"Introducing Microsoft Excel"
Switching to Microsoft Excel from Lotus 1-2-3



Multiplan Command (Help Menu)
Displays a dialog box that provides online Help about equivalents to Multiplan commands.

Command
Specify the Multiplan command for which you want the Microsoft Excel equivalent.

See Also
Help
Switching from Multiplan



Introducing Microsoft Excel Command (Help Menu)
Starts online interactive lessons that introduce Microsoft Excel version 4.0.

Microsoft Excel closes all open documents (other than workbooks) before starting the 
tutorial.    A message appears asking whether you want to save any changes.    At the end of 
the tutorial, your documents are reopened.

If you have any workbooks open, you must close them yourself using the Close 
command on the File menu before starting the tutorial.
The online tutorial includes the following lessons:
The Basics

Teaches the basic skills you need to start using Microsoft Excel right away.
What's New?

Shows the exciting new features of Microsoft Excel version 4.0.
For Lotus 1-2-3 Users

Shows how you can use your Lotus 1-2-3 skills and files immediately in Microsoft Excel.



Learning Microsoft Excel Command (Help Menu)
Starts online interactive lessons that introduce the fundamental skills and concepts you 
need to work with worksheets, charts, databases, macros, and toolbars.

Microsoft Excel closes all open documents (other than workbooks) before starting the 
tutorial.    A message appears asking whether you want to save any changes.    At the end of 
the tutorial, your documents are reopened.

If you have any workbooks open, you must close them yourself using the Close 
command on the File menu before starting the tutorial.
The online tutorial includes the following sections:
Introduction 

Provides an overview of Microsoft Excel, and shows you how to use Microsoft Excel online 
Help.

Worksheets 
Introduces worksheet basics, such as how to create worksheets, choose commands, 
change formats, and print.

Charts 
Introduces chart basics, such as how to create, change, and print a chart.

Databases 
Introduces databases.    You will learn how to create a database and use it to organize and
retrieve data.

Macros
Introduces macros.    You will learn how to create, run, and edit macros.

Toolbars
Explains how to use Microsoft Excel tools and toolbars.



Product Support Command (Help Menu)
Gives details on all the product support services for Microsoft Excel available to you from 
Microsoft, including how to contact Microsoft Product Support worldwide.



Info Menu
The Info menu appears on the menu bar when you select the Info Window check box in the 
Workspace dialog box.    To open the dialog box, choose Workspace from the Options menu.   
The Info menu controls which information about the active cell is displayed in the Info 
window.    Each option corresponds to a unique item of information.
Cell

Displays the cell's reference.
Formula

Displays the contents of the cell.
Value

Displays the value in the cell in General format.
Format

Displays the number format, alignment, font, borders, and shading of the cell.
Protection

Displays the protection status of the cell.
Names

Displays the names that include references to the cell.
Precedents

Displays a dialog box containing two options.    Direct Only displays only the direct 
precedents that the cell refers to.    All Levels displays both direct and indirect precedents 
that the cell refers to.

Dependents
Displays a dialog box containing two options.    Direct Only displays only the direct 
dependents that refer to the cell.    All Levels displays both direct and indirect dependents 
that refer to the cell.

Note
Displays the cell note, or indicates if a sound note has been added to a cell.



Macro Menu
Run 

Runs a command macro from the global macro sheet or an open macro sheet.
Record 

Records your subsequent actions as macro functions.
Start Recorder 

Records your actions as macro functions.    You must first define the recorder range on the
macro sheet with the Set Recorder command.

Stop Recorder 
Ends macro recording.    This command is available only during the recording of a macro.

Resume
Continues macro operation after you choose the Pause button in the Single Step dialog 
box or after a PAUSE macro function.

The following commands appear on the Macro menu for worksheets and macro 
sheets only:
Set Recorder 

Defines the selection on your macro sheet as the recorder range.
Relative Record 

Changes recording of references from absolute to relative, so that the macro operates on 
cells a fixed distance from the active cell when run.    This command is available only 
when the Absolute Record command is active.

Absolute Record 
Changes recording of references from relative to absolute, so that the macro operates on 
a fixed range of cells each time it is run.    This command is available only when the 
Relative Record command is active.

Assign to Object 
Assigns a macro to an object on a worksheet or macro sheet.    When you click the object, 
the macro runs.

Assign to Tool
Assigns a macro to a tool on a toolbar.    When you click the tool, the macro runs.    This 
command only appears on the menu when you are customizing tools.



Assign To Object Command (Macro Menu)
Assigns a macro to an object on a worksheet or macro sheet.    When you click the object, 
the macro runs.

Macros can be assigned to any object, including buttons, lines, arcs, ovals, 
rectangles, embedded charts, and pictures.

The mouse pointer changes to a hand when it is over an object that has a macro 
assigned to it.    The hand indicates that the macro will run when you click the object.
Assign Macro

Lists the command macros from the global macro sheet and any other open macro 
sheets.

Reference
Displays the name of the macro selected in the Assign Macro box.    If the macro you want
to assign to an object is not listed in the Assign Macro box, you can type its cell reference 
or name (name of the macro sheet, exclamation point, macro name) in the Reference 
box.    For example,    Macro1!Record1    would appear in the Reference box if you had 
created a macro using Microsoft Excel's default names.

Record
Equivalent to the Record command (Macro menu), which allows you to record your 
subsequent actions as a macro assigned to the graphic object.

See Also
Help
Assign To Tool Command (Macro Menu)
Assigning a macro to a graphic object
Creating or deleting a button on a worksheet or macro sheet
User's Guide (Book 2)
Chapter 6, "Automating Tasks with Command Macros"



Resume Command (Macro Menu)
Resumes macro operation after choosing the Pause button in the Single Step dialog box or 
after a PAUSE macro function.
You can resume macro operation in three ways:

Click the Resume Macro tool, which automatically appears whenever you pause a 
macro.

Choose Resume from the Macro menu.
Use the RESUME macro function.

See Also
Help

Resume Macro Tool
User's Guide (Book 2)
Chapter 6, "Automating Tasks with Command Macros"
Function Reference
PAUSE
RESUME



Record and Stop Recorder Commands (Macro Menu)
Record Command

Records your subsequent actions as macro functions so that you can repeat those actions
later using the Run command on the Macro menu.

The dialog box proposes a macro name and shortcut key combination.    You can 
record to the global macro sheet, a new macro sheet, or an existing macro sheet (if opened).

This command starts recording in the first cell of the recorder range, or if the first cell
is occupied, in the first completely blank column of the macro sheet.

If all documents are closed, Record appears on the File menu as the Record Macro 
command.

Name
The macro name.    Accept the proposed name or type one that will remind you what 
the macro does.    This name will appear in the Run box when you choose the Run 
command from the Macro menu.

Key
Defines a shortcut key you can use later to quickly run the macro.    Accept the 
proposed letter or type another one.    Shortcut keys are case sensitive and must be 
letters; numbers aren't allowed.

Store Macro In
Global Macro Sheet

Records macros on a hidden macro sheet automatically managed by Microsoft Excel. 
Macros recorded in the global macro sheet are available every time you start the 
program.

New Macro Sheet or Macro Sheet (Name)
Records macros on a new or existing macro sheet.    If you haven't already opened a 
macro sheet, Microsoft Excel automatically opens a new macro sheet for you.
If you want to add macros to an existing macro sheet, you must first open the macro 
sheet and set a recorder range.

Stop Recorder Command
Ends macro recording.

See Also
Help

Record Macro Tool
Stop Recording Macro Tool

Macro Toolbar
Recording a macro
Toolbars Command (Options Menu)
User's Guide (Book 2)
Chapter 6, "Automating Tasks with Command Macros"



Relative Record and Absolute Record Commands (Macro Menu)
Relative Record Command records cell references as relative, so that the macro operates
on cells a fixed distance from the active cell at the time the macro is run.
Absolute Record Command records cell references as absolute, so that the macro 
operates on a fixed range of cells each time the macro is run, regardless of where the active
cell is.

Initially, references are recorded as absolute.
You can switch between Relative Record and Absolute Record at any time.    When the

Relative Record command is displayed on the Macro menu, you are currently recording cell 
references as absolute.    When the Absolute Record command is displayed, you are 
recording the cell references as relative.
See Also

User's Guide (Book 2)
Chapter 7, "Designing and Writing a Command Macro"



Run Command (Macro Menu)
Runs a command macro from the global macro sheet or an open macro sheet.

You open a macro sheet the same way you open a worksheet, using the Open 
command on the File menu.

A macro name is preceded by the name of the macro sheet containing the macro and
an exclamation point; for example, Macro1!Record1.    Microsoft Excel labels macro sheets 
with the default filename extension .XLM.
Run

Lists all global command macros and all named command macros on open macro sheets, 
preceded by their shortcut keys, if any.

Reference
Displays the name of the command macro selected in the Run box.    If the active sheet is 
a macro sheet, the reference of the active cell is displayed in the Reference box.

Step
Displays the Single Step dialog box, which allows you to step through the macro one cell 
at a time.

See Also
Help

Run Macro Tool
Step Macro Tool

Macro Toolbar
Running a macro
Stepping through a macro
Toolbars Command (Options Menu)
User's Guide (Book 2)
Chapter 6, "Automating Tasks with Command Macros"
Chapter 7, "Designing and Writing a Command Macro"



Set Recorder Command (Macro Menu)
Defines the selection on your macro sheet as the recorder range.    Before you can use this 
command, a macro sheet must be active.

Use this command when you want to record a macro on an existing macro sheet or 
specific part of a macro sheet.

If the selection is a single cell, all the cells below it in the same column become the 
recorder range.    Recording starts in the selected cell and continues downward.    For 
recording to proceed without interruption, all cells below the selected cell must be blank.

If the selection is a range of cells, recording starts in the upper-left corner of the 
range and proceeds down its leftmost column.    When recording reaches the last selected 
cell in a column, it is redirected to the first selected cell in the next column and continues 
down from there.    All cells within the selected range should be blank.
See Also

Help
Recording a macro
User's Guide (Book 2)
Chapter 6, "Automating Tasks with Command Macros"



Start Recorder Command (Macro Menu)
Records your subsequent actions and commands as macro functions until you choose the 
Stop Recorder command from the Macro menu.

Before recording, you must set a recorder range on your macro sheet by selecting a 
cell or range of cells and choosing the Set Recorder command from the Macro menu.

If Microsoft Excel encounters a nonblank cell while recording or reaches the bottom of
the recorder range, it stops recording and displays a message telling you that the recorder 
range is full.
See Also

Help
Macro Toolbar
Recording a macro



Assign To Tool Command (Macro Menu)
Assigns a macro to a tool on a toolbar.    When you click the tool, the macro runs.
Assign Macro

Lists the command macros on the global macro sheet and any other open macro sheets.
Reference

Displays the name of the macro selected in the Assign Macro box.    If the macro you want
to assign to a tool is not listed in the Assign Macro box, you can type its cell reference or 
name (name of the macro sheet, exclamation point, macro name) in the Reference box.    
For example,    Macro1!Record1    would appear in the Reference box if you had created a 
macro using Microsoft Excel's default names.

Record
Equivalent to the Record command on the Macro menu, which allows you to record your 
subsequent actions as a macro assigned to the graphic object.

See Also
Help
Assigning or recording a macro to a tool
Creating a custom tool
Changing the action that a tool performs
User's Guide (Book 2)
Chapter 6, "Automating Tasks with Command Macros"



Add-Ins Command (Options Menu)
The Add-Ins command allows you to specify a working set of add-in macros that are 
automatically opened and ready to run when you open Microsoft Excel.    With the Add-Ins 
command, you can add to or delete from this working set of macros any of the add-in 
macros that come with Microsoft Excel or that you have created yourself and then saved as 
add-in macros.    
Add

Displays the Open dialog box where you can choose add-in macro files to be added to the
working set.

Edit
Allows you to edit add-in macro settings.    You can specify the path for your add-in macro.

Remove
Removes from the working set the add-in macro selected in the Add-Ins Installed dialog 
box.

See Also
Help
Add-In Macros
Adding or removing an add-in macro from the working set
Editing add-in macro settings
Macro Library Overview
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



Options Menu
Set Print Area

Defines the area of a worksheet that you want to print.
Remove Print Area

Removes the previously defined print area so the entire worksheet can be printed.
Set Print Titles

Defines text in selected rows and columns of a worksheet as titles in the printed 
document.

Remove Print Titles
Cancels previously selected print titles.

Set Page Break
Sets a manual page break for printing a worksheet.

Remove Page Break
Removes a manual page break.

Display
Controls the screen display of formulas, gridlines, headings, zero values, and objects in 
the active worksheet.    Also controls the color of gridlines and row and column headings.

Toolbars
Allows you to add, create, edit, hide, and customize the toolbars.

Custom Palettes
Allows you to change the color palette for the active worksheet or chart.

Color Palette
Controls the shade and intensity of each color in the color palette for a document and 
copies the color palette from one document to another.

Protect Document
Prevents changes to a document's data, formats, or windows.

Unprotect Document
Removes protection.

Calculation
Controls when and how formulas in open documents are calculated.

Workspace
Controls option settings that apply to the current Microsoft Excel work session.

Analysis Tools*
Allows you to select from a list of analysis tools for special statistical and engineering 
applications.

Add-Ins
Allows you to specify a working set of add-in macros that are automatically opened and 
ready to run when you start Microsoft Excel.

Group Edit
Groups multiple sheets so you can choose a command once and have it apply to every 
sheet in the group.    Only available for worksheets and macro sheets.

Spelling



Checks the spelling of text in worksheets, macro sheets, embedded charts, graphic 
objects, or the formula bar.

* If this command does not appear on the Options menu, run the Setup program to install 
the Analysis ToolPak.    For more information about adding or removing add-in macros, see 
Chapter 4, "Customizing Microsoft Excel," in Book 2 of the Microsoft Excel User's Guide.



Calculation Command (Options Menu)
Controls when and how formulas in open documents are calculated.
Automatic

Calculates all dependent formulas every time you make a change to a value, formula, or 
name.
The default calculation setting for all new worksheets.

Automatic Except Tables
Calculates all dependent formulas except data tables.    You can calculate tables by 
choosing the Calc Now button in this dialog box.

Manual
Calculates open documents only when you choose the Calc Now button.
When you choose Manual calculation, the Recalculate Before Save check box is 
automatically selected.

Iteration
Limits iteration for goal seeking, or for resolving circular references.    Unless you specify 
otherwise, stops after 100 iterations or when all values change by less than 0.001.    You 
can limit iteration by changing Maximum Iterations, Maximum Change, or both.

Calc Now
Calculates all open worksheets, including data tables, and updates all open chart 
documents.
Shortcuts: Calculate Now tool (Utility toolbar)

CTRL+EQUAL SIGN ( = )
F9

Calc Document
Calculates only the active worksheet and updates only the charts on the worksheet and 
open charts linked to the worksheet.
Shortcut: SHIFT+F9

Update Remote References
Calculates formulas that include references to other applications.    When cleared, 
formulas use the last value received from the other application.

Precision As Displayed
Changes stored values in cells from full precision (15 digits) to whatever format is 
displayed.    The displayed values are then used for calculations.

1904 Date System
Changes the starting date from which all dates are calculated from January 1, 1900 to 
January 2, 1904.    Choose this option when creating models that you plan to use with 
Microsoft Excel for the Macintosh.

Save External Link Values
Saves copies of values contained in an external document linked to your Microsoft Excel 
worksheet.    If a worksheet with links to large ranges on an external document requires 
an unusually large amount of disk space, or takes a very long time to open, clearing this 
check box can reduce the disk space and time needed to open the worksheet.

Alternate Expression Evaluation
Evaluates text strings to 0, Boolean expressions to 0 or 1, and database criteria according
to the rules used in Lotus 1-2-3.    This allows you to open Lotus 1-2-3 files without losing 



or changing information.
Alternate Formula Entry

Converts formulas entered with Lotus 1-2-3 syntax into Microsoft Excel syntax.
See Also

Help
Calculate Now Tool

Setting calculation options for open documents
Calculate Now Command (Chart Menu)
Goal Seek Command (Formula Menu)
Recalculating linked worksheets
Solving equations using goal seeking
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"
User's Guide (Book 2)
Chapter 1, "Analyzing and Calculating Data"



Color Palette Command (Options Menu)
Customizes the colors on the Microsoft Excel color palette and copies color palettes 
between documents.    You can customize colors in the color palette for worksheets, macro 
sheets, and chart documents.

If you do not have a color monitor, standard color names rather than the actual colors
appear in the dialog box.    Customized colors have the names Color 1, Color 2, and so on.

If you are working with a chart document, choose the Color Palette command from 
the Chart menu.

You can copy an object with a custom color from one document to another.    The 
color is copied along with the object.

The Color Palette command is not available for charts embedded in worksheets.    To 
customize colors for an embedded chart, use this command for the worksheet.

You can change the color by choosing the Edit button to open the color editing dialog 
box.    You can use the color box and the brightness bar, or change the values in the boxes 
below.

The boxes at the bottom of the color editing dialog box provide alternative systems 
for precisely setting the color.    One system uses hue, saturation, and luminosity.    The other 
uses the three primary colors used by color monitors: red, green, and blue.    These systems 
work independently.
Color Palette

Displays the color palette.
Copy Colors From

Contains the list of open documents from which you can copy a color palette.    
Selecting a document copies its palette to the active document.

Default
Resets the color palette to its original 16 colors.

Edit
Displays the color editing dialog box.    You can edit any of the original 16 colors on the 
color palette to create custom colors.

Color box
The large colored box where you can click or drag to change the current color. The 
current color is reflected in the Color|Solid box; in the Hue, Sat (saturation), and Lum 
(luminosity) boxes; and in the Red, Green, and Blue boxes.

Brightness bar
The colored bar to the right of the color box. Dragging the arrow along this bar changes
the amount of white and black in the current color. This has the same effect as 
changing the value in the Lum (luminosity) box.

Color|Solid
The left side of this box displays the current color. The right side shows the nearest 
solid color. To use the nearest solid color to the one you have created, double-click the 
solid color.

Hue
Displays the number of the current color.    You can change the hue by typing a value 
from 0 to 239 or by clicking the arrows. Changing this value has the same effect as 
dragging horizontally in the color box.

Sat (saturation)
Indicates how pure the color is; in other words, how different it is from gray.    You can 
change the saturation by typing a value from 0 to 240 or by clicking the arrows.    



Changing this value has the same effect as dragging vertically in the color box.
Lum (luminosity)

Indicates the lightness (amount of white) or darkness (amount of black) in the current 
color. You can change the luminosity by typing a value from 0 to 240 or by clicking the 
arrows. Changing this value has the same effect as dragging the arrow along the 
brightness bar.

Red, Green, Blue
Changes the overall color by changing the amounts of red, green, and blue . You can 
change these values by typing values from 0 to 255 for each, or by clicking the arrows. 
Changing the red, green, and blue values is an alternate method to changing the hue, 
saturation, and luminosity.

See Also
Help

Color Tool
Text Color Tool

Copying color palettes between documents
Customizing colors in the color palette
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



Display Command (Options Menu)
Controls how cells and graphic objects are displayed on the screen.    Also controls the color 
of gridlines and row and column headings.

These settings affect only the active worksheet window.
Shortcut: CTRL+6 (Switches among displaying all objects, displaying placeholders, and 

hiding all objects.)
Formulas

Displays the formulas in cells instead of the values produced.    Also doubles the width of 
all columns and left-aligns cell contents.
Shortcut: CTRL+` (left single quotation mark)

Gridlines
Displays gridlines.

Row & Column Headings
Displays row and column headings.

Zero Values
Displays all zero values.    If cleared, displays cells that have zero values as blank cells.
Does not affect cells you've formatted to display zeros by using the Number command 
from the Format menu.

Outline Symbols
Displays outlining symbols.
Shortcuts: Show Outline Symbols tool (Utility toolbar)

CTRL+8

Automatic Page Breaks 
Displays page breaks that have been set automatically by Microsoft Excel.

Show All
Displays all graphic objects, buttons, text boxes, drawn objects, and pictures.

Show Placeholders
Displays selected pictures and charts as gray rectangles.    Other graphic objects, buttons,
and text boxes are displayed normally.

Hide All
Hides all graphic objects, buttons, text boxes, drawn objects, and pictures.

Gridline & Heading Color
Sets the color for gridlines and column and row headings.
If Automatic is selected, the color is based on the text color defined in the Control Panel.

See Also
Help

Show Outline Symbols Tool
Converting a formula or a portion of a formula to its displayed values
Displaying or hiding outline symbols
Preventing display of zero values
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"
Chapter 8, "Organizing and Documenting a Worksheet"





Protect Document and Unprotect Document Commands (Options 
Menu)
Protect Document Command

Prevents changes to a document's data and formats.    You can also use this command to 
protect document windows so that they cannot be moved, resized, hidden, or closed 
using the Close command on the Control menu.

Caution:    If you forget the password of a document that was previously protected with a 
password, you cannot unprotect the document.

The Cell Protection command on the Format menu determines the type of cell 
protection.

The Object Protection command on the Format menu turns protection on or off for 
selected objects.

The Protect Document command on the Chart menu turns protection on or off for the 
active chart.

Password
Can be any combination of letters, numbers, or symbols, up to 255 characters long.
Passwords are case-sensitive and optional.    You can protect a document without using 
one.

Cells
Protects the contents of locked cells from being changed.    This option appears only for 
worksheets or macro sheets.

Contents
Protects the contents of all documents in a workbook.    This option appears only if a 
workbook's Contents window is active.

Windows
Prevents a document's windows from being moved, sized, hidden, or closed with the 
Close command on the Control menu.    You can close a protected window using the 
Close command on the File menu.

Objects
Locks graphic objects so they cannot be selected, moved, resized, or reformatted.    
When the Move And Size With Cells option is selected in the Object Properties dialog 
box, the object will move when surrounding cells are moved, but retain its locked and 
protected status.
This option appears only for worksheets and macro sheets.

Unprotect Document Command
Removes protection for the active document.
Password

If you assigned a password when you protected the worksheet, you must type the 
same password to remove protection.

See Also
Help
Protecting a document with a password
Protecting an object
Protecting windows
Protecting worksheet cells



User's Guide (Book 1)
Chapter 4, "Managing Document Files"
Chapter 15, "Working with Graphic Objects"



Set Page Break and Remove Page Break Commands (Options Menu)
Set Page Break 

Sets a manual page break.    Manual page breaks you set override the page breaks that 
Microsoft Excel automatically sets.

Manual page breaks appear on the screen as bold dashed lines and are darker than 
automatic page breaks.
Remove Page Break 

Removes manual page breaks.
This command is available on the Options menu when the active cell is directly below

or to the right of a manual page break.
To remove all manual page breaks, select the entire worksheet before choosing this 

command.
You cannot remove automatic page breaks.

See Also
Help
Setting or removing a manual page break
User's Guide (Book 1)
Chapter 16, "Printing"



Workspace Command (Options Menu)
Controls Microsoft Excel settings for the current session.
Fixed Decimal

Determines where Microsoft Excel will automatically put the decimal point in the numbers
you enter as constants on a worksheet.    A positive number moves the decimal to the left;
a negative number moves the decimal to the right.    If the option is left blank or set at 0 
(zero), the decimal point must be entered manually.    To override this option when 
entering a number, type a decimal point as you enter the number.

R1C1
Changes the reference style of row and column headings and cell references from A1 to 
R1C1.

Status Bar
Displays the status bar in the Microsoft Excel window.

Info Window
Displays the Info window for the active worksheet or macro sheet.

Scroll Bars
Displays the scroll bars in the document window.

Formula Bar
Displays the formula bar.    When you edit a cell, its contents are visible in the formula bar.

Note Indicator
Displays a small dot in the upper-right corner of cells with notes attached.

Alternate Menu Or Help Key
Displays the key you press to activate the Microsoft Excel menu bar or Help for Lotus 1-2-
3 Users.    Accept the default key or type a new key symbol in the box.
If you select Microsoft Excel Menus, pressing the Alternate Menu or Help key activates the
Microsoft Excel menu bar.    If you select Lotus 1-2-3 Help, pressing the Alternate Menu or 
Help key activates Help for Lotus 1-2-3 Users.

Alternate Navigation Keys
Provides an alternate set of keys for worksheet navigation, formula entry, label entry, and
other actions.    

Ignore Remote Requests
Ignores remote requests to Microsoft Excel made by other applications.

Move Selection After Enter
Automatically moves the active cell down one row after you press ENTER to enter a 
formula or value in a cell.

Cell Drag And Drop
Allows you to move and copy cells and data by dragging.

See Also
Help
Alternate Navigation Keys
Controlling remote requests
Displaying or hiding cell note indicators
Turning AutoFill on or off



Turning drag and drop on or off
User's Guide (Book 2)
Chapter 3, "Exchanging Data with Other Applications"
Chapter 4, "Customizing Microsoft Excel"



Toolbars Command (Options Menu)
Allows you to add, create, edit, hide, and customize the toolbars.
Show Toolbars

Lists built-in toolbars in the order you've added them followed by custom toolbars in 
alphabetic order.

Toolbar Name
Displays the name of the selected toolbar.    Typing a new name creates a new toolbar.    
You cannot rename a customized or built-in toolbar.

Show
Shows the toolbar selected in the Show Toolbars box.    Changes to Hide if the selected 
toolbar is already displayed.
Shortcut: CTRL+7 (Standard toolbar only)

Hide 
Hides the toolbar selected in the Show Toolbars box.    Changes to Show if the selected 
toolbar is already hidden.
Shortcut: CTRL+7 (Standard toolbar only)

Close
Closes the dialog box and automatically saves any changes. 

Customize
Displays the Customize dialog box so that you can add tools to toolbars and customize 
both tools and toolbars.
Categories

Lists all of the tool categories.
Tools

Shows the tools that are in the selected tool category.
Tool Description

Describes the selected tool.
Reset

Returns to the built-in version of the selected toolbar.    Changes to Delete if you select a 
custom toolbar.

Delete
Deletes the selected custom toolbar.    Changes to Reset if you select a built-in toolbar.

See Also
Help
Adding and deleting a tool from a toolbar
Creating a new toolbar
Deleting a custom toolbar
Displaying and hiding a toolbar
Resetting a built-in toolbar
Toolbars
Tools
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"





Set Print Area and Remove Print Area Commands (Options Menu)
Set Print Area Command

Defines the selection as the area of the worksheet that will be printed when you choose 
the Print command from the File menu.

Names the selected cells Print_Area.
The default print area of a worksheet is the portion that includes all entered data.

Shortcut: Set Print Area tool (Utility toolbar)
Remove Print Area Command

Removes the previously defined print area so the entire worksheet can be printed.
Available on the Options menu only when the entire worksheet has been selected.

Shortcut: Set Print Area tool (Utility toolbar)
See Also

Help

Set Print Area Tool
Resetting the print area
User's Guide (Book 1)
Chapter 16, "Printing"



Set Print Titles and Remove Print Titles Commands (Options Menu)
Set Print Titles Command

Defines text in selected rows and columns of your worksheet as titles.    When you print 
the worksheet with the Print command on the File menu, the titles appear on every page.

The text selected can include any number of adjacent rows, adjacent columns, or a 
combination.

This command names the selection Print_Titles.
If the print area is smaller than the area with the assigned titles, only those titles 

within the print area are printed.
Titles For Rows

Identifies the column or columns to be used for row titles.    You can change the 
selected range by entering new text, or by selecting the columns you want to use.    If 
you don't want row titles, leave this blank.

Titles For Columns
Identifies the row or rows to be used for column titles.    You can change the selected 
range by entering new text, or by selecting the rows you want to use.    If you don't 
want column titles, leave this blank.

Remove Print Titles Command
Cancels previously selected print titles.

Available on the Options menu only when the entire worksheet has been selected.

See Also
Help
Canceling print titles
Setting print titles for rows and columns
User's Guide (Book 1)
Chapter 16, "Printing"



Group Edit Command (Options Menu)
Lets you edit designated worksheets and macro sheets as a group.    Once you've created a 
group, you can apply many of the Microsoft Excel editing, file management, and formatting 
commands to the active sheet in the group and have those commands automatically 
applied to the other sheets.    For example, by changing column width in one sheet, you 
cause the column width in all other sheets in the group to be changed as well.

A document must be open to be included in a group.
You cannot include charts in a group; however, you can include a worksheet that 

contains embedded charts.
To copy data and formats from the selection on the active sheet to the same area on 

the other sheets in a group, choose the Fill Group command from the Edit menu.
To display all the sheets in a group, choose the Arrange command from the Window 

menu; then select the Documents Of Active Group check box.
Drawing operations are not available when you are editing a group.

See Also
Help
Adding or removing open documents from a group
Copying data and formats to all sheets in a group
Editing worksheets as a group
Starting or ending a group editing session
User's Guide (Book 1)
Chapter 11, "Working with Multiple Microsoft Excel Documents"



Spelling Command (Options Menu)
Checks the spelling of text in worksheets, macro sheets, graphic objects, or the formula bar. 
When Microsoft Excel encounters a word that is not in its dictionary, a dialog box appears to
help you correct the possible misspelling.

If the formula bar is active, this command checks the spelling of selected words; if no 
words are selected, it checks the spelling of the entire contents of the formula bar.

If a single cell of a worksheet or macro sheet is selected, then the headers and 
footers, all cells, cell notes, and objects in the document are checked for spelling errors.

If more than one cell is selected, or if one or more objects are selected, then only the 
contents of the selection are checked for spelling errors.

Hidden cells and all cells in collapsed outlines are also checked for spelling errors.
Cells containing formulas are not checked for spelling errors.
For graphic objects, only the text in text boxes and buttons is checked for spelling 

errors.
If a chart window is active, you can check spelling by choosing the Spelling command

from the Chart menu.
Shortcut: Check Spelling tool (Utility toolbar)
Change To/Suggestions

Type or select a replacement for the word not found in the dictionary.    
Add Words To

Select the dictionary to which you want to add words that are correctly spelled but not 
found in the main dictionary.    The first time you use the Spelling command, the 
dictionary CUSTOM.DIC appears in the Add Words To list.    The dictionary is empty until 
you add words to it.

Ignore
Leaves the selected word unchanged.

Ignore All
Leaves the selected word unchanged throughout the document.

Change
Changes the selected word to the word in the Change To box.

Change All
Changes the selected word throughout the document to the word in the Change To box.

Add
Adds the selected word to the dictionary in the Add Words To box.

Cancel/Close
Closes the dialog box.    The Cancel button changes to Close when you change a 
misspelled word or add a new word to the dictionary.

Suggest
Displays a list of proposed suggestions.    This button is dimmed if the Always Suggest box
is selected.

Ignore Words in UPPERCASE
Skips words that contain only capital letters.

Always Suggest
Displays a list of proposed suggestions whenever Microsoft Excel encounters a word that 
is not in the dictionary.



See Also
Help

Check Spelling Tool
Checking spelling
Spelling Command (Chart Menu)
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Window Menu
Show Document*

Opens the worksheet or macro sheet containing the information on shown in the Info 
window, while keeping the Info window open.

New Window 
Opens an additional window for the active document.    Only available for worksheets and 
macro sheets.

Arrange
Arranges all open windows so that they can be viewed at the same time.

Arrange Icons
Arranges the icons if all the windows have been minimized.

Hide 
Hides the active window from view.

Unhide 
Unhides a hidden window.

Split 
Splits a window into two or four panes so that different areas of a large worksheet can be 
viewed simultaneously.

Remove Split
Removes the splits from a window.

Freeze Panes
Freezes the top pane, the left pane, or both, on the active worksheet.
Creates panes if your window is not split yet.

Unfreeze Panes
Unfreezes frozen panes on your worksheet.

Zoom
Allows you to view your sheet at different scales.    This is useful for navigating, arranging 
the placement of data and objects, print setup, and getting an overview of the structure 
of the information.

View**
Creates different views of a worksheet.    You can display and print the views without 
saving them as separate documents.

1,2,3,...9
Lists the names of open windows and switches to the one you choose.

More Windows
Displays a list of the open and unhidden windows that do not appear on the Window 
menu and switches to the one you choose.    Available only when there are more than nine
windows open.    

*This command appears only after you select the Info Window check box from the 
Workspace Options dialog box, accessed from the Options menu.
** If this command does not appear on the Window menu, you need to install the View 
command.    For more information, see the Help topics on the Add-Ins command on the 
Options menu, or see Chapter 4, "Customizing Microsoft Excel" in Book 2 of the Microsoft 
Excel User's Guide.





1,2,3,...9 Commands (Window Menu)
List the currently open windows at the bottom of the Window menu.    Choosing a window 
switches to it.

A check mark is displayed beside the active window.
If more than nine windows are open, the More Windows command appears at the end

of the list.    Choose it to see a list of all open windows.



Arrange and Arrange Icons Commands (Window Menu)
The Arrange command provides ways to arrange windows and synchronize scrolling.

You can arrange individual windows in your workspace by dragging them with the 
mouse.

You can also arrange individual windows in your workspace using the Move and Size 
commands on the Control menu.

If the active window is in a group, you can arrange all the windows in the group.
If the active window is in a workbook, you can arrange all the windows in the 

workbook.
You can arrange windows in the following ways:
Tiled

Arranges open windows in small sizes to fit on the screen.
Horizontal

Arranges windows to be stacked evenly from top to bottom.
Vertical

Arranges windows evenly from left to right.
None

Allows you to change the synchronization without arranging the windows.
Windows Of Active Document

If selected, arranges only the windows of the active document.
If cleared, arranges all unhidden windows.
Sync Horizontal

Synchronizes horizontal scrolling in all windows of the active document.
Available only if the Windows Of Active Document check box is selected.

Sync Vertical
Synchronizes vertical scrolling in all windows of the active document.
Available only if the Windows Of Active Document check box is selected.

The Arrange Icons command arranges all the minimized windows.    Available only when a 
minimized window is active.

All icons will be arranged horizontally from left to right at the bottom of the 
application window.



Hide Command (Window Menu)
Hides the active window from view.

Even though you cannot see a hidden window, it is still open.
You can hide source documents that need to be open but do not need to be seen.
You can hide windows before choosing Arrange from the Window menu to exclude 

certain windows from being rearranged.
If you have protected the document's window with a password, you will be asked for 

the password when hiding the window.
Use the Unhide command on the Window menu to make a hidden window visible 

again.
See Also

Help
Protecting windows



More Windows Command (Window Menu)
Displays a list of open windows and switches to the window you choose.

This command appears on the Window menu only when you have more than nine 
windows open.



New Window Command (Window Menu)
Creates an additional window for the active worksheet or macro sheet so you can view 
different parts of your worksheet simultaneously.

You can open more than one new window for a given document; the maximum 
number is limited only by the available memory.

The title bar shows the original document name followed by a colon and the number 
of the new window.    For example, the second window of your BUDGET.XLS worksheet would 
be named BUDGET.XLS:2.
See Also

Help
Creating an additional window for the active document



Unhide Command (Window Menu)
Makes a hidden window visible.

This command lists all hidden windows and unhides the one you choose.
If you have protected the document's window with a password, you will be asked for 

the password before the window is displayed.
Add-in macros cannot be made visible with this command.
If all the windows have been hidden, this command moves from the Window menu to 

the File menu.
See Also

Help
Protecting windows



Split and Remove Split Commands (Window Menu)
The Split command splits the active window into two or four panes.

This command allows you to scroll multiple panes simultaneously.    Two top-to-bottom
stacked panes always have the same column headings; two side-by-side panes always have 
the same row headings.

This command is available when a worksheet or macro sheet is the active document.
Use the Freeze Panes command to prevent the top pane, left pane, or both, from 

scrolling.
The Remove Split command removes the split from the active window.

This command is available only when the active window has been split.
Double-clicking the split bar also removes the split.

See Also
Help
Splitting a window into panes
Closing panes in a window
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet" 



Freeze Panes and Unfreeze Panes Commands (Window Menu)
The Freeze Panes command freezes the top pane, the left pane, or both, on the active 
worksheet.

This command is useful for keeping row or column titles on the screen while you 
scroll to other parts of the worksheet.

This command prevents panes to the left of a vertical split from scrolling horizontally 
and prevents panes above a horizontal split from scrolling vertically.

The panes that are not frozen do not scroll into the frozen part of the worksheet.
You can also use the Freeze Panes tool to freeze or unfreeze panes in your worksheet. 

Use the Toolbars command on the Options menu to put the Freeze Panes tool onto a toolbar.
If the window is not divided into panes, this command will split the window at the 

location of the active cell.
The Unfreeze Panes command unfreezes frozen panes on your worksheet.

This command appears on the Window menu only when you have frozen panes with 
the Freeze Panes command.
See Also

Help

Freeze Panes tool
Splitting a window into panes
Freezing and unfreezing panes
Freezing and unfreezing worksheet titles
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



View Command (Window Menu)
Creates different views of a worksheet.    A view provides an easy and powerful way to see 
your data in a different format.    You can display and print the views without saving them as 
separate documents.

The View dialog box appears when you choose the View command.    You can choose 
to save a view with different print settings, hidden rows and columns, display settings, 
selected cells, and window size.

You can choose the View command to show a view you created earlier, to add a new 
view, or to delete a view.

When you create a view, you name the view and choose the settings as part of the 
view.

A view you create always includes window size, position, frozen panes, selection, the 
active cell, and the settings in the Display dialog box, which you open from the Options 
menu.
See Also

Help
Creating a view of a worksheet
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Zoom Command (Window Menu)
Displays a worksheet at different scales for navigating, arranging and placing objects and 
data, setting print options, and getting an overview of the information presented.

This command allows you to see a worksheet in detail or view more of a worksheet.
You can select a zoom factor between 10% and 400% in addition to the five built-in 

zoom factors in the Zoom dialog box.
When you select the Fit Selection option button in the Zoom dialog box, Microsoft 

Excel calculates a zoom factor so that all the selected cells fit in the current window size.
You can also use the Zoom In tool and the Zoom Out tool on the Utility toolbar.    Use 

the Toolbars command on the Options menu to display the Utility toolbar.
See Also

Help

Zoom In Tool
Zoom Out Tool

Zooming in or out on your worksheet
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Show Document (Window Menu)
Displays the worksheet or macro sheet containing the information shown in the Info 
window, while keeping the Info window open.

This command appears only when you select the Info Window check box in the 
Workspace Options dialog box, accessed from the Options menu.

To switch between the worksheet or macro sheet and the Info window, press CTRL+F2.

See Also
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



Basic Concepts
For introductory information on basic spreadsheet concepts and Microsoft Excel features, 
choose one of the underlined topic titles in the table below.    To return to this topic once you
have selected another topic, choose the Back button at the top of the Help window until this
topic reappears.
You may also want to complete the Microsoft Excel tutorials, "Introducing Microsoft Excel" 
and "Learning Microsoft Excel," available on the Help menu.    These tutorials provide 
additional information on these topics.
Worksheets

Primary documents for recording, calculating, and analyzing data.
Charts

Graphic presentations of worksheet data.
Databases

Parts of a worksheet used for organizing, managing, and retrieving information.
Tools

Buttons on a toolbar that help you perform selected actions faster and more easily.
Toolbars

Bars containing tools to help you to work faster and more easily.
Graphic objects

Graphic shapes and pictures that enhance a worksheet's appearance.
Macros

Instructions that you create to automate repetitive tasks and create customized functions
and applications.

Add-in macros
Macros integrated with Microsoft Excel, which work as if they were built into the 
application.

Importing and exporting
Data exchange between Microsoft Excel documents and documents created in other 
applications.

Linking and embedding
Dynamic data exchange between Microsoft Excel documents and documents created in 
other applications (linking).    Inserting data as an updatable object from another 
application (embedding).

Templates
Documents created for use as basic patterns or forms for other similar documents.

AutoFill
Allows you to create a series of incremental or repeating values on a worksheet by 
dragging the fill handle of the selection border with the mouse. 

Drag and Drop
Allows you to copy, move, or delete cell contents, notes, and formats on a worksheet by 
dragging with the mouse.



About Worksheets
A worksheet, also called a spreadsheet, is the main document used in Microsoft Excel to 
store and work with data.    A worksheet is a rectangular grid of 256 columns and 16,384 
rows.    The basic unit of a worksheet is a cell, the intersection of a column and a row, in 
which you store data.    Columns are labeled from left to right, beginning with A through Z.    
After Z, labeling continues with AA through AZ, then BA through BZ, and so on through 
column IV for a total of 256.    Rows are numbered down from 1 to 16,384.
You fill in a worksheet by entering text, numbers, and formulas in the cells.    Microsoft Excel 
automatically recalculates any mathematical formulas in your worksheet when you add or 
change data.

You can change the way information is displayed in your worksheet by changing the 
size, style, and color of data within cells.

You can also add graphic objects to enhance your worksheet's appearance.
With Microsoft Excel, you can link worksheets.    For example, you can link several 
worksheets that calculate monthly financial data to one worksheet that calculates quarterly 
data.    When worksheets are linked, changes you make in one worksheet produce 
corresponding changes in dependent worksheets.
See Also

Help
Copying data
Creating a new worksheet
Editing cell contents
Formatting cells
Linking and embedding
Selecting a range of cells
Selecting cells, rows, or columns
Learning Microsoft Excel (Online Tutorial)
What Is a Worksheet?
Using a Worksheet
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"
Chapter 6, "Editing a Worksheet"
Chapter 7, "Formatting a Worksheet"



    



About Databases
A database is an area on a worksheet used for organizing, managing, and retrieving 
information.    You create a database on a portion of a worksheet and use it to store and 
manipulate large or complex bodies of data.
You can use a Microsoft Excel database to:

Search or query using defined criteria to find specific data.
Sort all or part of a worksheet alphabetically and numerically.
Extract subsets of data based on criteria you define.
Simplify adding, changing, and deleting worksheet data.
Print data organized for specific purposes.

You create a database by using the Set Database command on the Data menu to define a 
range of worksheet cells as a database .    Each row of the range contains a database record 
and each column contains a field, or category of data.    The first row of the database 
contains the field names.    For example, if you are tracking sales orders, the fields might 
include the date, the client's name, address, and phone number, the quantity and price of 
each item ordered, and the order total, each in its own column.    Each sales order 
transaction will be a record, or row, containing this information.
See Also

Help
Data Menu Commands
Defining a database
Extracting data from a database
Finding records in a database
Sorting a range of cells
Learning Microsoft Excel (Online Tutorial)
What Is a Database?
Using a Database
User's Guide (Book 1)
Chapter 9, "Creating and Using a Database on a Worksheet"
Chapter 10, "Analyzing and Reporting Database Information"



About Macros
A macro is a set of instructions, like a script, that Microsoft Excel carries out when you press 
a special key combination or click an object, tool, or button to which the macro has been 
assigned.    A macro may be very simple, carrying out two or three commands, or very 
complex, carrying out hundreds of commands.    You record macros and design custom 
functions on macro sheets.
You can use macros to:

Create custom functions.
Automate routine tasks.
Create menus and dialog boxes for custom applications.
Automatically run other applications.

You can write a macro by entering formulas in the cells of a macro sheet, or you can use the
macro recorder.    The macro recorder works like a tape recorder:    it records your actions so 
you can play them back on request.    
See Also

Help
Creating a new macro sheet
Macro Menu Commands
Recording a macro
Running a macro
Stepping through a macro
Learning Microsoft Excel (Online Tutorial)
What Is a Macro?
Using a Macro
User's Guide (Book 2)
Chapter 5, "Creating and Using Custom Worksheet Functions"
Chapter 6, "Automating Tasks with Command Macros"
Chapter 7, "Designing and Writing a Command Macro"
Chapter 8, "Creating a Custom Application"



About Graphic Objects
Using the tools on the Microsoft Excel toolbars, you can draw graphic objects on worksheets
and macro sheets.    You can also import graphics, as pictures, from other applications to 
enhance the appearance of your worksheets and macro sheets.
With the tools on the Drawing toolbar, you can draw lines, arcs, and transparent or filled 
ovals, rectangles, and polygons.    Once you have added a graphic object, you can change 
its position, shape, or size; group it with other graphic objects; make copies of it; and format
its color, border, or pattern.
You can assign a macro to a graphic object so that the macro will run whenever you click 
the object.
With the Camera tool on the Utility toolbar, you can create pictures of Microsoft Excel 
charts, worksheet cells, or macro sheet cells.    You can then place the pictures on other 
parts of the sheet, on another sheet, or in another application.
See Also

Help
Assigning a macro to a graphic object
Drawing a line, oval, arc, or rectangle with tools from the toolbar
Showing and hiding toolbars
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



About Templates
A template is a document you create as the basic pattern to use for other similar 
documents.    When you create a new document from a template, you get an exact copy.    
For instance, you can create a tax form, a quarterly report, or an annual budget; save it as a
template; and then use the template to insert data that varies every month, quarter, or 
year.
You can create templates from worksheets, charts, macro sheets, and workbooks by using 
the Save As command on the File menu to save them in the Template file format.    
Templates can contain text, such as row and column labels on a worksheet; formats, such as
colors or column widths; macros, such as printing macros; formulas, such as the SUM 
formula and other mathematical formulas; or your own custom cell styles.

Chart templates use the preferred chart type to generate the chart.    To change the 
chart type for the current session, use the Set Preferred command on the Gallery menu.

When you save a template in the XLSTART directory, Microsoft Excel automatically 
adds the template name to the list of available choices when you choose the New command 
from the File menu.
See Also

Help
Creating a new template
Editing a template
Saving a document as a template
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



About Add-In Macros
Add-in macros are macro sheets that are integrated with Microsoft Excel and appear to be 
part of the application.    You can create an add-in macro by using the Save As command on 
the File menu to save a macro sheet in the add-in file format.    The add-in file format is 
available only when a macro sheet is active.    You can create your own add-in macros or use
the many third-party products created for Microsoft Excel as add-in macros.

Add-in macros are given the filename extension .XLA.
To open an add-in macro every time you start Microsoft Excel, place it in the XLSTART 

directory.    
Add-in macros located in other directories can be opened using the Open command 

on the File menu.
Add-in macros are hidden from the user and cannot be unhidden using the Unhide 

command on the Window or File menu.
Add-in command macro names do not appear in the Run or Assign To Object dialog 

boxes when you choose the Run or Assign to Object command from the Macro menu.
Custom functions in the add-in macros are listed in alphabetic order, without the 

name of the preceding add-in macro, in the Paste Function dialog box when you choose the 
Paste Function command from the Formula menu.

The Close All command on the File menu does not close add-in macros.
See Also

Help
Opening an add-in macro as a regular macro sheet
Saving a macro sheet as an add-in macro
User's Guide (Book 2)
Chapter 8, "Creating a Custom Application"



About Importing and Exporting
Because Microsoft Excel automatically recognizes the file formats of many other 
applications, there are several ways to exchange data between Microsoft Excel documents 
and documents created in other applications.
You can import documents from other applications, such as spreadsheets and databases, by
opening them in Microsoft Excel with the Open command on the File menu.    You can format 
Microsoft Excel documents for other applications using the Save As command on the File 
menu.

If you import data into Microsoft Excel from another application, especially a text or 
database file, several columns of data may be condensed into a single column during the 
transfer.    You can separate the fields of each record into columns with the Parse command 
on the Data menu.
See Also

Help
Exporting a document to another application
Importing a document from another application
User's Guide (Book 2)
Chapter 3, "Exchanging Data with Other Applications"



About Toolbars
The toolbars contain tools to help you to work faster and more easily.    The Standard toolbar
contains tools for some of the most frequently used commands.      By choosing the Toolbars 
command from the Options menu, you can hide the toolbar at any time to allow more space
for your work.
Microsoft Excel has nine toolbars.    They are:

Chart toolbar
Drawing toolbar
Formatting toolbar
Macro Paused toolbar
Macro Recording toolbar
Macro toolbar
Microsoft Excel 3.0 toolbar
Standard toolbar
Utility toolbar

You can display any of these toolbars by choosing the Toolbars command from the Options 
menu. 
You can change the toolbars or create new toolbars to suit the way you work or the way you
have developed your Microsoft Excel documents.    You can add as many toolbars as you 
like.
See Also

Help
Adding and deleting a tool from a toolbar
Assigning or recording a macro to a tool
Changing the action that a tool performs
Changing the shape of a floating toolbar
Creating a new toolbar
Customizing the appearance of a tool
Deleting a custom toolbar
Displaying and hiding a toolbar
Grouping and ungrouping tools
Moving a toolbar
Moving tools
Resetting a built-in toolbar
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel" 



About Tools
Tools are buttons located on the toolbar that allow you to perform selected actions quickly 
and more easily.    In addition to the Standard toolbar, Microsoft Excel has eight toolbars, 
each containing a related group of tools.    You can change any toolbar or create new 
toolbars by adding, deleting, and rearranging tools.    Additional tools are available in the 
Toolbars dialog box.
Microsoft Excel has 10 categories of tools.    They are:

Charting Tools category
Custom Tools category
Drawing Tools category
Edit Tools category
File Tools category
Formatting Tools category
Formula Tools category
Macro Tools category
Text Formatting Tools category
Utility Tools category

You can customize toolbars by:
Moving tools from a tool category or another toolbar.
Grouping and ungrouping tools so that the arrangement of tools is more compatible 

with your work style and needs.
Creating tools to carry out macros or commands that you use frequently.    You can 

add tools you create to toolbars.
See Also

Help
Adding and deleting a tool from a toolbar
Assigning or recording a macro to a tool
Changing the action that a tool performs
Creating tools
Customizing the appearance of a tool
Grouping and ungrouping tools
Moving tools
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



About Charts
A chart is a graphic presentation of worksheet data.    Microsoft Excel offers 14 types of 
charts, in 88 built-in formats.    When you create a chart, Microsoft Excel plots the chart 
based on the shape of the selected range of data and on the types of data in the row and 
columns.    
You can create a chart directly on a worksheet, to be displayed and saved as a part of the 
worksheet; this is called an embedded chart.    Or, you can create a chart as a separate 
document in its own window.    Both embedded charts and separate chart documents are 
linked to the worksheet data they were created from, and will be updated when you update 
the worksheet.
You can change the format of a chart using the commands on the Chart menu and the 
Format menu.    You can add a legend, text, or arrows to emphasize certain information, and 
change colors, patterns, axes, and gridlines.

Chart types are:    area, bar, column, line, pie, radar, xy (scatter), combination, 3-D 
area, 3-D bar, 3-D column, 3-D line, 3-D pie, and 3-D surface.

To change the chart type, use the tools on the Chart toolbar or the commands on the 
Gallery menu.
See Also

Help
Changing the chart type and format
Copying a chart
Creating a chart
Editing chart text
Formatting a chart created on a worksheet
Selecting items in a chart
Learning Microsoft Excel (Online Tutorial)
What Is a Chart?
Using a Chart
User's Guide (Book 1)
Chapter 12, "Creating a Chart"
Chapter 13, "Editing a Chart"
Chapter 14, "Formatting a Chart"
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Workbooks
A workbook is a Microsoft Excel document in which you can store other documents.    A 
workbook can include any combination of worksheets, macro sheets, and charts.    
Workbooks make it easy to keep related Microsoft Excel documents together. 

By opening and closing a single workbook document, you can open or close all of the 
documents you need for a specific task.

Workbook files have the .XLW extension.
You can save worksheets and related macro sheets in a single workbook file.    This 

ensures that when you are using a worksheet, the macro sheets you need are open.
Workbooks can be used to keep linked or dependent worksheets, macro sheets, and 

charts together.
Workbooks make it easy to manage files and maintain security.    For example, you 

can set up password protection once for a workbook containing several financial worksheets.
The size and position of all open windows in the workbook are saved with the 

workbook, and appear just as you saved them the next time you open the workbook.
You can quickly display any document in a workbook by clicking one of the paging 

buttons or by selecting it from the Workbook Contents window.
With workbooks you can ensure that several people will use the same documents 

across a network.    For example, you can create a single macro sheet to be used by many 
people.    Save the macro sheet as read-only and store it on your network.    If you distribute 
a workbook file that includes that macro sheet as an unbound document, when you update 
the macro sheet all your users will automatically use the latest version.

Bound workbook documents can be given extended names up to 31 characters long.  
You can use this feature to describe the document in more detail than the normal filename 
allows.
Workbook Contents

When you open a workbook, the documents in the workbook are listed in the Workbook 
Contents window.
From the Workbook Contents window, you can add or remove documents from your 
workbook, give the document a descriptive name, and specify whether you want the 
documents saved as part of the workbook or as separate files.

Bound and Unbound Documents
Documents may be bound in the workbook or unbound as separate files.    A document 
bound in a workbook can appear in only that workbook, but unbound documents can be 
part of several workbooks.    You can tell by the icon in the Workbook Contents window 
whether a document is:

Bound
or

Unbound.
Paging

Every workbook document has a set of paging buttons in the lower-right corner of the 
window.

Displays the next document in the workbook.
Displays the previous document in the workbook.
Displays the Workbook Contents window.

Clicking any of these buttons with the right mouse button displays a shortcut menu listing
all workbook documents and the Group Edit and New commands.

See Also
Help



New Workbook Tool
Adding or removing a document from a workbook
Binding and unbinding workbook documents
Copying a document from one workbook to another workbook
Creating a workbook
Editing a group of worksheets in a workbook
Giving a bound workbook document an extended name
Moving between workbook documents
Opening a new window of a document in a workbook
Reordering documents in a workbook
Saving a workbook
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



Using AutoFill
Allows you to create a series of incremental or fixed values on a worksheet by dragging the 
fill handle of the selection border with the mouse. 
For example, if you want to copy the value from one cell into the five cells below it, you can 
use AutoFill.    In this instance, AutoFill works in the same way as the Fill commands on the 
Edit menu. 
Or, you can extend a series in the same way you use the Series command on the Data 
menu.    For example, if you type Monday and Tuesday in consecutive columns, then drag 
the fill handle to the right, Microsoft Excel fills Wednesday, Thursday and so on into the 
selected cells.

Series are useful when creating table row or column headings on a worksheet, and 
then extending linear projections, or any time you need a series of incremental numbers, 
time periods, or other entries that include incremental values.

AutoFill works well for creating or extending a small series, while the Series command
on the Data menu is better for creating very large series or for specifying a stop value.

Just as you can create a series that incrementally increases in value in one direction, 
you can create a series that decreases in value in the reverse direction. You do this by 
dragging the fill handle up or to the left.

You can clear data within a selection by dragging the fill handle up or to the left of the
selection and stopping within the selected cells, without going past the column or the row 
border. The data to be cleared appears in gray as you drag the fill handle.

For example, if you want to clear Saturday and Sunday from a series of the days of the 
week, drag the fill handle to the left until Saturday and Sunday appear in gray; then 
release the mouse button.    Saturday and Sunday will be cleared from the cell.

If you select an entire column or row, the fill handle appears at the lower right of the 
row or column heading and not at the end of the selection.

If you hold down SHIFT while dragging the fill handle into the selection, the cursor 
changes to a horizontal I-beam for rows or a vertical I-beam for columns, the data in those 
rows or columns over which you drag turns gray, and the cells are deleted when you release 
the mouse button.

If you hold down SHIFT while dragging the fill handle out of the selection, the cursor 
changes to the I-beam, and the number of rows or columns over which you drag are 
inserted.    The surrounding rows or columns shift when you release the mouse button.
See Also

Help
Copying to a range of adjacent cells
Creating a trend series
Extending a series of numbers or dates
Turning AutoFill on and off
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"
Chapter 6, "Editing a Worksheet"



Using Drag and Drop
With Microsoft Excel, you can copy, move, or delete cell contents, notes, and formats on a 
worksheet by dragging with the mouse.

When moving or copying cells, you cannot drag the entire selection into hidden 
columns or rows. 

The border that appears skips the hidden rows or columns and moves to the next 
visible column or row.

You can, however, partially move or copy a selection into hidden rows or columns.    
Copying cells by dragging

You can copy formulas or values and all the attributes of the cell to a new location by 
holding down CTRL and dragging the border surrounding the cells.

When working with values that would otherwise increment, you can use this method 
to create a series or to copy a single cell or range of cells to adjacent cells.

When you move a cell by holding down CTRL and dragging, Microsoft Excel adjusts all 
references to the moved cells to reflect their new location.
Moving cells by dragging

You can move cells to another area of the worksheet by dragging the border surrounding 
the cells. 

When you select and drag any group of cells that is not an entire row or column, the 
contents move to the new location and the cells in the old location are cleared. 

When you hold down SHIFT while dragging the fill handle out of the selection, the 
cursor changes to an I-beam, and the number of rows or columns over which you dragged 
are inserted.    The surrounding rows or columns shift when you release the mouse button.

When you select and drag an entire row or column, the contents of the row or column
are moved, and the row or column is deleted.
To delete a row, column, or range of cells by dragging

1 Select the row, column, or range.
2 Position the mouse pointer on the fill handle.    Press SHIFT while dragging the fill handle 

up for rows or left for columns, selecting the number of rows or columns you want to 
delete.

3 Release the mouse button.
To move or copy a selection into hidden rows or columns

1 Select the row, column, or range you want to move or copy.
2 Drag the border of a selection to the gridline of the hidden row or column. 

Part of the border you are dragging vanishes and part remains visible. This indicates 
that part of the data will be pasted into the hidden rows or columns and part will be 
pasted into the visible rows or columns.    
You cannot paste an entire selection into hidden rows or columns.

3 Release the mouse button.
See Also

Help
Copying data
Moving cells and data
Deleting cells, rows, or columns
Turning drag and drop on and off
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"
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About Linking and Embedding
Linking and embedding are two different ways to exchange data between Microsoft Excel 
documents, and between Microsoft Excel documents and documents created in other 
applications.    Use linking when you want the data updated dynamically as the data in the 
source document changes.    Use embedding when you want to be able to edit or format the 
data within another document.
Linking data between Microsoft Excel documents

You can link a Microsoft Excel worksheet to source data in another Microsoft Excel 
worksheet.    Any changes you make in the source worksheet are immediately reflected in 
the dependent worksheet.    You can also link macro sheets.    When you create a chart, 
the data in the chart is automatically linked to the worksheet containing the data from 
which the chart was created.

Linking data between a Microsoft Excel document and a document in another 
application

You can link data from a document in another application to a Microsoft Excel document, 
or from a Microsoft Excel document to a document in another application.
For example, you can link a Microsoft Excel chart to a Microsoft Word document.    
Whenever you edit the chart in Microsoft Excel, your changes are displayed in the chart in
the Microsoft Word document, if it is open.    If the Microsoft Word document is not open, 
the chart is updated the next time you open it.
To create a link between a Microsoft Excel document and a document in another 
application, that application must be running with Windows, and it must support dynamic 
data exchange (DDE) or object linking and embedding (OLE).
Use the Links command on the File menu to edit or change existing links, and to open 
source documents.

Embedding data from one document into another document
You can embed a Microsoft Excel cell, cell range, or chart into another document.    You 
can also embed information from another document, such as text, a table, a chart, or a 
graphic, in Microsoft Excel.    Information that you embed is called an embedded object.
For example, you can embed a Microsoft Excel chart as an object in a report created in 
another application.    All the information that was used to create the object, in this case a
chart, is encapsulated in the embedded object in the report.    If you want to change the 
chart while you're working in the report, double-click the embedded object.    This opens 
the object in Microsoft Excel so that you can make the editing and formatting changes 
you want.    When you close the object, the report is displayed again, and the embedded 
object is updated with the changes you made.
To use embedding with Microsoft Excel and another application, both applications must be
running with Microsoft Windows and must support object linking and embedding (OLE).

See Also
Help
Creating links between documents
Disabling updating of all links on a worksheet
Editing a Microsoft Excel object embedded in another document
Editing an object embedded in a Microsoft Excel document
Embedding a Microsoft Excel object in another document
Embedding an object in a Microsoft Excel document
Insert Object Command (Edit Menu)
Links Command (File Menu)



Paste Link Command (Edit Menu)
Paste Special Command (Edit Menu)
Redirecting links to source documents
Saving an embedded Microsoft Excel object as a separate document
Updating linked information
Viewing the source data for a link
User's Guide (Book 1)
Chapter 1, "Getting Started With Microsoft Excel"
Chapter 11, "Working with Multiple Microsoft Excel Documents"
User's Guide (Book 2)
Chapter 3, "Exchanging Data with Other Applications"



Argument
Information you supply to a Microsoft Excel function for calculation.



Array
Used to build formulas that produce multiple results or that operate on a group of 
arguments arranged into rows and columns.    There are two types of arrays in Microsoft 
Excel: array ranges and array constants.    An array range is a rectangular area of cells 
sharing one common formula; an array constant is a specially arranged group of constants 
used as an argument in a formula.



ASCII Character
A standard code for representing characters as numbers.    Used on most microcomputers, 
computer terminals, and printers.    Includes not only printable characters but also 
nonprintable characters, such as control codes that indicate carriage return and backspace.



Axes
Lines bordering the plot area providing a frame of reference for measurement or 
comparison on a chart.    A two-dimensional (2-D) chart has two axes.    A three-dimensional 
(3-D) plotted chart has two or three axes depending on the data view selected.



Breakpoint
A location that you set on a macro sheet where the macro pauses and displays a dialog box 
containing three options:    step through each formula, continue running the macro, or stop 
the macro.    Set a breakpoint to stop the macro and look at the value of the variables you 
specified.



Chart
A graphic presentation of data from a worksheet.    You can create a chart in a separate 
document or embedded as a graphic object on a worksheet.    An embedded chart can be 
linked to data on other worksheets.



Chart Data Series
A group of related data points to be plotted on a chart.    Each data point consists of a 
category and a value.    You can plot one or more data series on a chart.



Clipboard
The holding place for information you cut or copy with the Cut, Copy, and Copy Picture 
commands.
If you cut or copy worksheet cells, the Clipboard does not display the actual cells.    Instead, 
it displays the action you are taking and the location of the cells you are cutting or copying, 
for example, "Copy 2R x 3C" or "Cut 2R x 3C".



Comparison Operators
There are six standard comparison (logical) operators you can use in Microsoft Excel 
formulas:

Operator Meaning
= Equal to
> Greater than
< Less than
>= Greater than or equal to
<= Less than or equal to
<> Not equal to



Consolidation by Category
Consolidates worksheet cells based on their category name.    The worksheet cells you want 
to consolidate must have identical category labels, but the position of the categories within 
each worksheet may vary.    



Consolidation by Position
Consolidates worksheet cells based on their position.    The worksheets that contain the cells
you want to consolidate must have identical layouts so that similar categories of data 
occupy exactly the same location in each source area.    



Constant
A number, text, logical, or error value that does not start with an equal sign (=).



Criteria
Information you enter in a worksheet range that determines which records will be affected 
when you choose either the Find, Extract, or Delete command from the Data menu.



Data Table
A range of cells summarizing the results of substituting different values in one or more 
formulas on your worksheet.    In Microsoft Excel, there are one-input tables and two-input 
tables.



Database
A range of cells on a worksheet.    The first row of the database contains the field names.    
Each additional row of the database is one record; each column in the record is one field.



Dependent Worksheet
A worksheet that contains an external reference formula or a remote reference formula.    
When you link two Microsoft Excel worksheets, the dependent worksheet relies on another 
worksheet for the value in the external reference formula.    When you link a Microsoft Excel 
worksheet to a document in a different application, the worksheet is dependent on that 
document for the value in the remote reference formula.



Embedding
The process by which an object is copied into another document.    Embedding can take 
place between documents within the same application or between documents in different 
applications, as long as both applications support the embedding process.
Because an embedded object maintains "ties" with its original application, you can open 
that application and edit the object simply by double-clicking the embedded object.



External Reference
A reference to another Microsoft Excel worksheet.    An external reference can designate a 
single cell, a cell range, or a named cell or range.



External Reference Formula
A formula in a worksheet that contains a reference to a single cell, cell range, or named cell 
or range in another worksheet.    An external reference formula creates the actual link 
between Microsoft Excel worksheets.



Extract Range
A separate area on a worksheet set aside for data retrieved and copied from the database.



Field
A column or a cell in a database.    Each column in a database contains a different category 
of data, and each cell in a database shares a common characteristic with other cells in the 
same column.



Field Name Row
The first row of a database.    Each cell in the row contains a name describing the contents 
of the cells beneath it.



File Format
The way information in a document is stored in a file.    Different programs use different file 
formats.    You can save documents in a variety of file formats using the Save As command 
on the File menu.



Formula
A sequence of values, cell references, names, functions, or operators that is contained in a 
cell and produces a new value from existing values.    A formula always begins with an equal
sign (=).



Formula Bar
A bar at the top of your Microsoft Excel window used to enter or edit values and formulas in 
cells or charts.    Displays the constant value or formula contained in the active cell.



Function
A built-in formula that takes a series of values, uses them to perform an operation, and 
returns the result of the operation.    Functions can be entered in the formula bar as part of 
cell formulas.



Global Macro Sheet
A hidden macro sheet automatically managed by Microsoft Excel.    Macros recorded in the 
global macro sheet are available every time you start the program.



Graphic Object
A line or shape (button, text box, oval, rectangle, arc, picture) you draw using the tools on 
the toolbar, or a picture you paste into Microsoft Excel.



Input Cell
The cell into which values from a data table are substituted.



International File Format
Saves a worksheet or macro sheet in an international format so that you can open the file in
any other language version of Microsoft Excel.



Legend
A key that identifies the series markers in a chart.    Includes each pattern or symbol used as
a marker, followed by the corresponding data series or category name.



Linked Documents
Separate documents that are dynamically connected so that a formula in one document 
refers to a value in another document.    Since the link enables Microsoft Excel to update the
value when it changes, the changes made in one document are immediately reflected in the
other.
Any time you build a formula or define a name in one worksheet by entering a reference to 
a cell, cell range, or name in another worksheet, Microsoft Excel links the two worksheets.



Logarithm
The exponent that indicates the power to which a number is raised to produce a given 
number.
For example, LOG(100) = 2, since 100 = 10 squared.



Logical Value
The result of a formula that contains a logical function or equation, such as 1=1, that is 
either true or false.    Microsoft Excel recognizes both TRUE and FALSE and one and zero 
(1,0) as logical values. 



Macro Sheet
A document similar to a worksheet that contains sets of instructions (macros) for 
accomplishing specific tasks.



Macro Translation Assistant
A utility that helps translate Lotus 1-2-3 and Multiplan macros into Microsoft Excel macros.



Moving Border
A moving dotted line that surrounds a cell or range of cells.    A moving border appears 
around a cell or range that has been cut or copied, or around a cell or range you are 
inserting in a formula while in Point mode.



Menu Key
The menu key activates the menu bar.    In Microsoft Excel the ALT key and F10 both function 
as menu keys.    In addition, you can specify an alternate menu key in the Workspace dialog 
box.



Nonadjacent Selection
A selection of noncontiguous cells and/or objects.



Name
An identifier you create to refer to a cell, a group of cells, a constant value, an array of 
values, or a formula.    When you use names in a formula, the formula is easier to read and 
remember than a formula containing cell references 



Normal Style
The style automatically applied to documents until you apply your own style.



Pause
A macro function that suspends macro operation allowing you to perform other tasks.



Parsing
Distributing the contents of a single cell to fill several cells, or a single column to fill several 
columns.



Paste Area
The target destination for data you cut with the Cut command or copied with the Copy 
command from the Edit menu.



Plot Area
The area of a chart in which Microsoft Excel plots data.    On a 2-D chart, it is bounded by the
axes and includes all markers that represent data points.    On a 3-D chart, the plot area is 
defined by the walls and floor of the chart.    The walls and floor can be formatted 
independently.



Range
A rectangular section of a worksheet containing two or more cells.



Record
One row in a database.    The first row of the database contains the field name.    Each 
additional row of the database is one record.    Each record contains the same categories of 
data as every other record in the database.



Reference
The location of a cell or group of cells on a worksheet, indicated by column letter and row 
number.    Examples: "C5"; "A1:D3"; "R1C1"; and "R[1]C[3]".    If the cell or cells are on a 
different worksheet, the cell location is preceded by the name of the worksheet and an 
exclamation point (!).    Example:    "Sales!$A$1:$H$1".



Reference Style
A method of identifying cells in a worksheet.    In the A1 reference style, columns are labeled
with letters and rows with numbers.    In the R1C1 reference style, R indicates row, C 
indicates column; both columns and rows are labeled with numbers.



Reference Type
A relative reference (A1) in a formula indicates the location of another cell in relationship to 
the cell containing the formula.
An absolute reference ($A$1) always refers to the exact location of a specific cell.
A mixed reference ($A2; A$2) is half relative and half absolute.



Remote Reference
A reference to a document in a different application.    A remote reference can designate a 
single cell, cell range, value, or field of data in the other document.



Remote Reference Formula
A formula in a Microsoft Excel worksheet that contains a reference to a cell, cell range, 
value, or field of data in a document from a different application.    A remote reference 
formula creates the actual link between a Microsoft Excel worksheet and the other 
document.



Scroll Bars
Bars along the right and bottom sides of your worksheet or macro sheet that allow you to 
scroll through the document vertically and horizontally, using a mouse.    Clicking an arrow 
moves one column or row at a time.    Clicking a shaded area moves one window at a time.
The length of the scroll bar represents the entire document.    Dragging the scroll box to a 
different position on the scroll bar and releasing the mouse button displays the part of the 
document that is in that position.



Series Formula
A formula that contains the data used to plot a data series on a chart.    When you create a 
new chart, Microsoft Excel automatically builds a series formula for each data series. The 
formula consists of the SERIES function followed by four arguments, each of which defines 
one aspect of the data series.



Startup Directory
The startup directory is an optional directory named XLSTART which is located in the same 
directory as EXCEL.EXE.    If you have an XLSTART directory, any documents placed in it are 
automatically opened when you start Microsoft Excel.
Templates placed in the startup directory are not automatically opened, but are listed as 
options in the New dialog box when you choose the New command from the File menu.
Documents in startup subdirectories are not automatically opened.



Status Bar
The bar at the bottom of the screen that displays information about the currently selected 
command, the active dialog box, standard keys on the keyboard, and the current state of 
the program and the keyboard.



Source Document
A Microsoft Excel worksheet referred to by an external reference formula or a remote 
reference formula.    The source document is the source of the value contained in the 
external reference formula or remote reference formula and therefore provides "supporting 
data" to the dependent worksheet.



Destination Macro Sheet
A Microsoft Excel macro sheet on which the Macro Translation Assistant enters a translated 
macro.



Templates
Templates are worksheets, charts, or macro sheets created as patterns for subsequent 
documents.
Since templates keep all the formatting, styles, and formulas--including row and column 
headings--of the original documents, they offer a quick way of creating similar documents 
with variable data in them, such as quarterly reports or annual budgets.



Topic
An article in Microsoft Excel Help that explains how to use Microsoft Excel.



Tracepoint
A location that you set on a macro sheet where the macro pauses so that you can step 
through the formulas one at a time.    Set a tracepoint so that you can debug a section of a 
macro without having to step through every formula in the macro.



Unattached Text
Text that is not linked to a chart object and can be moved anywhere on the chart.



Wildcard
A character (? or *) that stands for one or more characters.    Used for finding data in a 
worksheet or as part of database criteria.    Use the asterisk (*) to represent any number of 
characters.    Use the question mark (?) to represent any single character in the same 
position as the question mark.



Group
A temporary grouping of worksheets and macro sheets.    Any changes you make in data or 
formatting on the active sheet is reflected in all sheets in the group.



Worksheet
Also called a spreadsheet.    The worksheet is the primary document you use in Microsoft 
Excel to store and manipulate data.    A worksheet consists of cells organized into columns 
and rows.



XY (Scatter) Chart
A 2-D chart that has numeric values plotted along both axes rather than values along the 
vertical axis and categories along the horizontal axis.    This kind of chart type is typically 
used to analyze scientific data to see if one set of values is dependent on or affects another 
set of values.



Command Macro
A sequence of commands that you record on a macro sheet.    Later, you can run the 
recorded commands to automate your work.    A command macro can be assigned to a 
shortcut key, a button, an object, or a tool, for easy use.



One-Input Data Table
A table you produce using the Table command on the Data menu.    Using a formula 
containing one variable and a series of values to be substituted for that variable, you can 
generate a one-row or one-column series of results based on the series of values you 
entered.



Two-Input Data Table
A table you produce using the Table command on the Data menu.    Using a formula 
containing two variables and two series of values to be substituted for those variables, you 
can generate a two-dimensional matrix of results based on the series of values you entered.



External Absolute Reference
An external absolute reference consists of the name of the source worksheet, followed by 
an exclamation point (!) and the absolute reference to the cell range.    Example: "Sales!
$A$1:$H$1".



Shortcut Menu
With the mouse pointer pointing to a selection on a chart, worksheet, or macro sheet, click 
the right mouse button to display a menu of useful commands.    You can display shortcut 
menus from cells, columns, rows, text boxes, objects, buttons, charts, chart items, toolbars, 
tools, or workbooks.



Frequency Distribution
For a given set of values and a given set of intervals (or bins), counts how many of the 
values occur in each interval.



Workbook
A Microsoft Excel document in which you can store other documents.    A workbook can 
include worksheets, macro sheets, and charts.



Tick Mark
A small line that intersects an axis like a division on a ruler. Tick marks are considered parts 
of an axis. Double-clicking an axis displays the Patterns dialog box, in which you can specify
what kind of tick marks you want.



Toolbar Dock
The region above the formula bar and below the menu bar, or the regions on the left, right, 
and bottom sides of the application window, where toolbars can reside.



Floating Toolbar
A toolbar that is in a window with a title bar, stays on top of the other windows, and is not 
docked.



Bound
When a document is bound to a workbook, it can only appear in that workbook.    A bound 
document is saved in the workbook file.



Unbound
An unbound document can be a part of several workbooks and is saved as a separate file.



Handles
Small black squares located in the lower-right corner of selected cells or around selected 
graphic objects, chart items, or text.    By dragging the handles you can perform actions 
such as moving, copying, filling, sizing, or formatting, on the selected cells, object, chart 
item, or text.



Using comparison criteria
There are three types of comparison criteria:

A series of characters you want matched
A quantity you want compared
A wildcard character

To find all records in your database that contain a field or fields with specific series of 
characters or exact quantities, you can simply type the characters or quantities into the 
corresponding field or fields in your criteria range.    
To find all records that contain a field or fields that fall within a range, or that match 
certain inexact criteria, you can use comparison operators. An equal sign (=) with nothing
after it will find only blank fields, while a not-equal sign (<>) with nothing after it will find 
only nonblank fields.
To find all records that contain a field or fields with certain combinations of known and 
unknown characters, use wildcard characters. Microsoft Excel assumes that any text 
entries you use in your criteria are followed by the asterisk (*) wildcard. For example, 
entering BAT is the same as entering BAT*. Either will return BAT, BATS, BATH, or any 
other series of characters starting with BAT. To match BAT exactly, the form ="=BAT" will 
find only those records without returning BATS, BATH, and so on.

See Also
Help
Defining a criteria range
Defining a database
Setting up a criteria range with comparison criteria
The Set Criteria Command (Data Menu)
Using Computed Criteria
User's Guide (Book 1)
Chapter 10, "Analyzing and Reporting Database Information"



Using computed criteria
When you use computed criteria, you use formulas as your comparison criteria. Your 
formula must refer to one or more fields in the database. The database fields must be 
named ranges if you use names in your formulas, or your criteria formulas must use 
relative references to refer to the first cell in the field below the corresponding field name.
The computed criteria must reside in a separate column in your criteria range, which 
must either remain unnamed by leaving the first row of the column blank, or be labeled 
with a unique name.
For example, the computed criteria =Jan_sales<Feb_sales would find any records in which
the field Feb_sales contains a larger value that of Jan_sales.
You can also use other constants in computed criteria that are not part of the database, 
as long as you refer to at least one database field in your formula.

See Also
Help
Defining a criteria range
Defining a database
Setting up a criteria range with comparison criteria
The Set Criteria Command (Data Menu)
Using Comparison Criteria
User's Guide (Book 1)
Chapter 10, "Analyzing and Reporting Database Information"



File Formats
File formats determine the way information in a document is stored in a file.    Different 
programs use different file formats.    Microsoft Excel allows you to save a file in the 
following formats, using the Save As command on the File menu.

Normal*    **    ***
Saves documents in the standard Microsoft Excel file format.    Unless you type your 
own extension, worksheets are saved in this file format with the .XLS extension, charts 
with the .XLC extension, macro sheets with the .XLM extension, and workbook files with
the .XLW extension.

Template*    **
Saves documents in Template format.    By default, templates are saved with the .XLT 
extension.

Excel 3.0* **
Saves documents in the Microsoft Excel version 3.0 format.

Excel 2.1*    **
Saves documents in the Microsoft Excel version 2.1 format.

SYLK**
Saves documents in the Symbolic Link format.

Text**
Saves documents in the Text (tab delimited) format.

CSV**
Saves documents in the Comma Separated Values format.

Add-In**
Saves a macro or custom function in the Add-In format.    By default, add-ins are saved 
with the .XLA extension.    This option is only available when a macro sheet is active.

Int'l Macro**
Saves a macro sheet in the International Macro format.

Int'l Add-In**
Saves a macro sheet in the International Add-In format.    This option is only available 
when using a non-English (American) version of Microsoft Excel.

WKS
Saves documents in Lotus 1-2-3 Release 1.x format.

WK1
Saves documents in Lotus 1-2-3 Release 2.x format.

WK3***
Saves documents in Lotus 1-2-3 Release 3.x format.

DIF**
Saves documents in Data Interchange Format (VisiCalc).

DBF 2
Saves documents in dBASE II format.

DBF 3
Saves documents in dBASE III format.

DBF 4



Saves documents in dBASE IV format.
Text (Macintosh)**

Saves documents in the Macintosh Text (tab delimited) format.
Text (OS/2 or DOS)**

Saves documents in the OS/2 or MS-DOS Text (tab delimited) format.
CSV (Macintosh)**

Saves documents in the Macintosh Comma Separated Values format.
CSV (Windows)**
CSV (OS/2 or DOS)**

Saves documents in the OS/2 or MS-DOS Comma Separated Values format.

* These formats are available when a chart is the active document.
** These formats are available when a macro sheet is the active document.
*** These formats are available when a workbook is the active document.



Header and Footer Codes
You can customize headers and footers for printed documents in the Header and Footer Edit
Windows.    To display the Header or Footer Edit Window, choose the Page Setup command 
from the File menu, and then choose the Header button or the Footer button.    You can type 
text in the three text boxes (left, center, or right), and enter any of the codes listed below.
Click the following buttons to enter the codes in the text boxes:

Button Button name Code Action

Font button --- Displays the Font dialog box

Page Number button &P Inserts the page number

Total Pages button &N Inserts the total number of pages

Date button &D Inserts the current date

Time button &T Inserts the current time

Filename button &F Inserts the filename of the active document
See Also

Help
Changing headers and footers
Page Setup Command (File Menu)
User's Guide (Book 1)
Chapter 16, "Printing"



Serial Number
Microsoft Excel uses serial numbers to represent time.
The numbers to the left of the decimal point represent the date.    The numbers to the right 
of the decimal point represent the time.
To the left of the decimal point, each integer from 1 to 65380 represents a different day.

1 represents January 1, 1900.
2 represents January 2, 1900.
65380 represents December 31, 2078.

To the right of the decimal point, the numbers .0 to .99999 represent a different time.
.0 represents the time 0:00:00 (12:00:00 midnight).
.5 represents the time 12:00:00 (12:00:00 noon).
.99999 represents the time 23:59:59 (11:59:59 PM).

The date system used here is the 1900 date system.    You can also use the1904 date 
system, which has a serial number range of 0 to 63918, where 0 represents January 1, 1904
and 63918 represents December 31, 2078.
To change to the 1904 date system, choose Calculation from the Options menu, and then 
select the 1904 Date System check box.



Error Values
Microsoft Excel displays an error value in a cell when it cannot properly calculate the 
formula for that cell.    For more detailed information on the causes and corrections for error 
values, see Chapter 5, "Creating a Worksheet," in Book 1 of the Microsoft Excel User's 
Guide.
If a formula includes a reference to a cell that contains an error value, that formula also 
produces an error value (unless you are using the special worksheet functions ISERR, 
ISERROR, or ISNA, which look for error values).    You may have to trace the references back 
through a series of cells to discover the source of the error.

Error value Meaning
#DIV/0! The formula is trying to divide by zero.
#N/A! No value is available.    Usually, you enter this value directly into worksheet

cells that will eventually contain data that is not yet available.    Formulas 
referring to those cells will return #N/A! instead of calculating a value.

#NAME? Microsoft Excel does not recognize a name used in the formula.
#NULL! You specified an intersection of two areas that do not intersect.
#NUM! There is a problem with a number.
#REF! The formula refers to a cell that is not valid.
#VALUE! An argument or operand is of the wrong type.



Database Function Arguments
Each database function uses three arguments:
database

Range of cells that make up the database.
Can be entered as a cell range or as a name assigned to a range.
If you use the Set Database command on the Data menu to define a range as a 

database, Microsoft Excel names that range Database.
field

Indicates which field to use in the function.
Can be given as text or a number.

criteria
Range of cells that contain database criteria.
Can be entered as a cell range or as a name assigned to a range.
If you use the Set Criteria command on the Data menu on a selected range of cells, 

Microsoft Excel names the range Criteria.
When you use a name as an argument, do not enclose the name in quotation marks.
If you want to perform an operation on an entire column in a database, enter a blank line 
or lines below the field names in the criteria range.

See Also
Help
List of Database Functions



DAVERAGE(database,field,criteria)
Averages the values in field column of database records that satisfy the criteria.
Example

For an example of this function, see DATABASE FUNCTIONS in the Microsoft Excel Function
Reference.

See Also
Help
AVERAGE Returns average of arguments.
DSUM Returns sum of values in a database field.
Database Function Arguments
List of Database Functions



DCOUNT(database,field,criteria)
Returns the number of database values that are numbers in the field whose records 
satisfy the criteria.

Field is optional.
If field omitted, returns the number of records in the database that satisfy the 

criteria.
Example

For an example of this function, see DATABASE FUNCTIONS in the Microsoft Excel Function
Reference.

See Also
Help
DCOUNTA Counts nonblank cells.
Database Function Arguments
List of Database Functions



DCOUNTA(database,field,criteria)
Returns the number of database values that are nonblank in the field whose records 
satisfy the criteria.
Example

For an example of this function, see DATABASE FUNCTIONS in the Microsoft Excel Function
Reference.

See Also
Help
COUNTA Counts how many values are in the list of arguments.
DCOUNT Counts cells containing numbers from selected database entries.
Database Function Arguments
List of Database Functions



DGET(database,field,criteria)
Extracts single values from a database.    Returns the value of a field in the database 
record that satisfies the criteria.

Returns #VALUE! if no records satisfy the criteria.
Returns #NUM! if more than one record satisfies the criteria.

Example
For an example of this function, see DATABASE FUNCTIONS in the Microsoft Excel Function
Reference.

See Also
Help
Database Function Arguments
List of Database Functions



DMAX(database,field,criteria)
Returns the largest number from the specified field in a group of database records that 
satisfy the criteria.
Example

For an example of this function, see DATABASE FUNCTIONS in the Microsoft Excel Function
Reference.

See Also
Help
DMIN Returns smallest value in a field of records that satisfy criteria.
MAX Returns largest number in list of arguments.
MIN Returns smallest number in list of arguments.
Database Function Arguments
List of Database Functions



DMIN(database,field,criteria)
Returns the smallest number from the specified field in a group of database records that 
satisfy the criteria.
Example

For an example of this function, see DATABASE FUNCTIONS in the Microsoft Excel Function
Reference.

See Also
Help
DMAX Returns largest value in a database field.
MAX Returns largest number in list of arguments.
MIN Returns smallest number in list of arguments.
Database Function Arguments
List of Database Functions



DPRODUCT(database,field,criteria)
Multiplies the values in the column field of database records that satisfy the criteria.
Example

For an example of this function, see DATABASE FUNCTIONS in the Microsoft Excel Function
Reference.

See Also
Help
DSUM Adds all numbers in a database field.
PRODUCT Multiplies its arguments.
Database Function Arguments
List of Database Functions



DSTDEV(database,field,criteria)
Estimates the standard deviation of a population based on a sample.    Uses the numbers in 
the column field of database records that satisfy the criteria.
Example

For an example of this function, see DATABASE FUNCTIONS in the Microsoft Excel Function
Reference.

See Also
Help
DSTDEVP Returns the standard deviation of a population using numbers from a 

database.
STDEV Estimates the standard deviation of a population based on a sample.
Database Function Arguments
List of Database Functions



DSTDEVP(database,field,criteria)
Calculates the standard deviation of a population based on the entire population.    Uses the 
numbers in the column field of database records that satisfy the criteria.
Example

For an example of this function, see DATABASE FUNCTIONS in the Microsoft Excel Function
Reference.

See Also
Help
STDEVP Returns the standard deviation for a population based on the entire 

population.
DSTDEV Estimates the standard deviation of a population based on a sample from a

database.
Database Function Arguments
List of Database Functions



DSUM(database,field,criteria)
Adds the numbers in the column field of database records that satisfy the criteria.
Example

For an example of this function, see DATABASE FUNCTIONS in the Microsoft Excel Function
Reference.

See Also
Help
DAVERAGE Returns average of values in a database field.
DPRODUCT Multiplies values in a database field.
SUM Adds all numbers given as arguments.
Database Function Arguments
List of Database Functions



DVAR(database,field,criteria)
Estimates the variance of a population based on a sample.    Uses database values in field 
whose records satisfy the criteria.
Example

For an example of this function, see DATABASE FUNCTIONS in the Microsoft Excel Function
Reference.

See Also
Help
DVARP Returns the variance of an entire population based on values from a 

database.
VAR Returns variance of a population based on a sample.
Database Function Arguments
List of Database Functions



DVARP(database,field,criteria)
Calculates the variance of a population based on the entire population.    Uses database 
values in field whose records satisfy the criteria.
Example

For an example of this function, see DATABASE FUNCTIONS in the Microsoft Excel Function
Reference.

See Also
Help
DVAR Estimates variance of an entire population based on a sample from a 

database.
VARP Calculates the variance of a population based on the entire population.
Database Function Arguments
List of Database Functions



CROSSTAB()
Defines the structure and content of a cross-tabulation table. It is generally easier to use the
Crosstab Wizard to create the cross-tabulation table and to enter the necessary CROSSTAB 
formulas. Once the table is created, you can modify it by editing the CROSSTAB formulas. 
For more information, see "Viewing Data Using Crosstab Tables" in Chapter 10 in Book 1 of 
the Microsoft Excel User's Guide.
If this function is not available, you must install the Crosstab add-in macro. For more 
information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 of the 
Microsoft Excel User's Guide.
For an example of this function and a description of arguments, see CROSSTAB in the 
Microsoft Excel Function Reference.



DATE(year,month,day)
Returns the serial number of the date corresponding to year, month, and day.

Year is a number between 1900 and 2078.    To specify a year in the range 1920 to 
2019, you can give the last two digits of the year.    To specify a year before 1920 or after 
2019, give all four digits of the year.

Month is a number representing the month of the year.    If the month value is 
greater than 12, month adds the number of months to the first month in the year specified 
and adjusts the year accordingly.

Day is a number representing the day of the month.    If the day value is greater than
the number of days in the specified month, day adds the number of days to the first day in 
the month specified and adjusts both the month and year accordingly.

You can use negative numbers as arguments, if the resulting serial number is 
positive.
Example

DATE(91,1,1) = 33239, the serial number corresponding to January 1. 1991 in the 1900 
Date System.

See Also
Help
DATEVALUE Is like DATE, but takes a text argument.
TODAY Returns serial number of the current date.
List of Date & Time Functions



DATEVALUE(date_text)
 Returns the serial number of date_text.    Use DATEVALUE to convert a date represented by
text to a serial number.

Date_text must represent a date from January 1, 1900, to December 31, 2078.
Can be in any of the built-in Microsoft Excel date formats.
If the year is omitted, DATEVALUE uses the current year from your computer's built-in

clock.
Time information in date_text is ignored.

Examples
DATEVALUE("8/22/55") = 20323
VALUE("22-Aug-55") = 20323

See Also
Help
DAY Converts a serial number to a day of the month.
NOW Returns serial number of current date and time.
TIMEVALUE Converts a time in the form of text to a serial number.
TODAY Returns serial number of current date.
List of Date & Time Functions



DAY(serial_number)
Returns the day of the month corresponding to serial_number.    The day is given as an 
integer from 1 to 31.

Serial_number is the date-time code used by Microsoft Excel for date and time 
calculations.

If given as text, the text is automatically converted to a serial number.
Examples

DAY("4-Jan") = 4
DAY("15-Apr-1991") = 15
DAY("8/11/91") = 11

See Also
Help
HOUR Returns hour (0-23).
MINUTE Converts serial numbers to minutes.
MONTH Converts serial numbers to months.
NOW Returns serial number of current date and time.
SECOND Converts serial numbers into seconds.
TODAY Returns serial number of current date.
WEEKDAY Converts serial numbers into weekdays.
YEAR Converts serial numbers into years.
List of Date & Time Functions



HOUR(serial_number)
Returns the hour corresponding to serial_number.    The hour is given as an integer, 
ranging from 0 (12:00 AM) to 23 (11:00 PM).

Serial_number is the date-time code used by Microsoft Excel for date and time 
calculations.

If given as text, the text is automatically converted to a serial number.
Examples

HOUR(0.7) = 16
HOUR(29747.7) = 16
HOUR("3:30:30 PM") = 15

See Also
Help
DAY Converts a serial number to a day of the month.
MINUTE Converts serial numbers to minutes.
MONTH Converts serial numbers to months.
NOW Returns serial number of current date and time.
SECOND Converts serial numbers to seconds.
WEEKDAY Converts serial numbers to weekdays.
YEAR Converts serial numbers to years.
List of Date & Time Functions



MINUTE(serial_number)
Returns the minute corresponding to serial_number.    The minute is given as an integer 
ranging from 0 to 59.

Serial_number is the date-time code used by Microsoft Excel for date and time 
calculations.

If given as text, the text is automatically converted to a serial number.
Examples

MINUTE("4:48:00 PM") = 48
MINUTE(.01) = 14
MINUTE(4.02) = 28

See Also
Help
HOUR Returns hour (0-23).
SECOND Returns second (0-59).
TIME Returns serial number of specified time.
List of Date & Time Functions



MONTH(serial_number)
Returns the month corresponding to serial_number.    The month is given as an integer 
from 1 to 12.

Serial_number is the date-time code used by Microsoft Excel for date and time 
calculations.

If given as text, the text is automatically converted to a serial number.
Examples

MONTH("6-May") = 5 
MONTH(366) = 12
MONTH(367) = 1

See Also
Help
DAY Converts a serial number to a day of the month.
TODAY Returns serial number of current date.
YEAR Returns year (1900-2078).
List of Date & Time Functions



NOW()
Returns the serial number of the current date and time, according to your computer's clock.
You must include empty parentheses with NOW, otherwise Microsoft Excel will not recognize
it as a function.
Examples

If your computer's built-in clock is set to 12:30:00 PM, 1-Jan-1991:
NOW() =33239.52
Ten minutes later:
NOW() =33239.53

See Also
Help
DATE Returns the serial number of a particular date.
TIME Returns serial number of specified time.
TODAY Returns serial number of current date.
List of Date & Time Functions



SECOND(serial_number)
Returns the second corresponding to serial_number.    The second is given as an integer, 
ranging from 0 to 59.

Serial_number is the date-time code used by Microsoft Excel for date and time 
calculations.

If given as text, the text is automatically converted to a serial number.
Examples

SECOND("4:48:18 PM") = 18
SECOND(0.01) = 24
SECOND(4.02) = 48

See Also
Help
HOUR Returns the hour (0-23).
MINUTE Returns the minute (0-59).
List of Date & Time Functions



TIME(hour,minute,second)
Returns the serial number of the time specified by hour, minute, and second.
Examples

TIME(12,0,0) = 0.5 (which is 12:00:00)
TIME(16,48,0) - TIME(12,0,0) = 0.2 (which is 4:48:00)

See Also
Help
DATE Returns the serial number of a particular date.
NOW Returns serial number of current date and time.
TIMEVALUE Returns serial number of time specified by text.
List of Date & Time Functions



TIMEVALUE(time_text)
Returns the serial number of the time specified by time_text.

Time_text is a quoted text string that gives a time in any one of Microsoft Excel's 
time formats.

The Number dialog box which appears when you choose Number from the Format 
menu lists all built-in time formats.
Example

TIMEVALUE("2:24 AM") = 0.1
See Also

Help
DATEVALUE Returns serial number of date specified by text.
NOW Returns serial number of current date and time.
TIME Returns serial number of specified time.
List of Date & Time Functions



TODAY()
Returns the serial number of the current date according to your computer's clock.    Even 
though TODAY does not have an argument, you must include the empty parentheses so that
Microsoft Excel recognizes it as a function.
See Also

Help
DAY Converts a serial number to a day of the month.
MONTH Converts serial number to month.
NOW Returns serial number of current date and time.
YEAR Converts serial number to year.
List of Date & Time Functions



WEEKDAY(serial_number)
Returns the day of the week corresponding to a specified serial_number.    The day is given
as an integer from 1 to 7, where 1 equals Sunday.

Serial_number is the date-time code used by Microsoft Excel for date and time 
calculations.

If given as text, the text is automatically converted to a serial number.
Examples

WEEKDAY(29747.007) = 4 (Wednesday)
WEEKDAY("2/14/90") = 4 (Wednesday)

See Also
Help
DAY Converts a serial number to a day of the month.
NOW Returns serial number of current date and time.
TEXT Formats a number and converts it to text.
TODAY Returns serial number of current date.
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YEAR(serial_number)
Returns the year corresponding to a specified serial_number.    The year is given as an 
integer from 1900 to 2078.

Serial_number is the date-time code used by Microsoft Excel for date and time 
calculations.

If given as text, the text must be enclosed in quotes and is automatically converted 
to a serial number.
Examples

YEAR(0.007) = 1900
YEAR(29747.007) = 1981

See Also
Help
DATE Returns the serial number of a particular date.
DAY Converts a serial number to a day of the month.
MONTH Returns the month (1-12).
List of Date & Time Functions



DAYS360(start_date,end_date)
Returns the number of days between two dates based on a 360-day year (12 months, each 
with 30 days).    To calculate the difference between two dates based on a 365-day year, use
normal subtraction ("12/31/91"-"1/1/91" = 364).
If the start_date is after the end_date, DAYS360() returns a negative number.
Examples

DAYS360("1/30/91","2/1/91") = 1
DAYS360("1/1/91","12/31/91") = 360

See Also
Help
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BESSELI(x,n)
Returns the modified Bessel function In(x), which is equivalent to the Bessel function Jn 
evaluated for purely imaginary arguments.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

X is the value at which to evaluate the function.
N is the order of the Bessel function. If n is not an integer, it is truncated.

Example
BESSELI(1.5,1) = 0.981666

See Also
Help
BESSELJ Returns the Bessel function Jn(x).
BESSELK Returns the modified Bessel function Kn(x).
BESSELY Returns the Bessel function Yn(x).
List of Engineering Functions



BESSELJ(x,n)
Returns the Bessel function Jn(x).
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

X is the value at which to evaluate the function.
N is the order of the Bessel function. If n is not an integer, it is truncated.

Example
BESSELJ(1.9,2) = 0.329926

See Also
Help
BESSELI Returns the modified Bessel function In(x).
BESSELK Returns the modified Bessel function Kn(x).
BESSELY Returns the Bessel function Yn(x).
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BESSELK(x,n)
Returns the modified Bessel function Kn(x), which is equivalent to the Bessel functions Jn 
and Yn evaluated for purely imaginary arguments.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

X is the value at which to evaluate the function.
N is the order of the function. If n is not an integer, it is truncated.

Example
BESSELK(1.5,1) = 0.277388

See Also
Help
BESSELJ Returns the Bessel function Jn(x).
BESSELY Returns the Bessel function Yn(x).
BESSELI Returns the modified Bessel function In(x).
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BESSELY(x,n)
Returns the Bessel function Yn(x), which is also called the Weber function or the Neumann 
function.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

X is the value at which to evaluate the function.
N is the order of the function. If n is not an integer, it is truncated.

Example
BESSELY(2.5,1) = 0.145918

See Also
Help
BESSELJ Returns the Bessel function Jn(x).
BESSELK Returns the modified Bessel function Kn(x).
BESSELI Returns the modified Bessel function In(x).
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COMPLEX(real_num,i_num,suffix)
Converts real and imaginary coefficients into a complex number of the form x+yi or x+yj.    
The result is text.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Real_num is the real coefficient of the complex number.
I_num is the imaginary coefficient of the complex number.
Suffix is the suffix, as quoted text, for the imaginary component of the complex 

number.    If omitted, suffix is assumed to be i.
Examples

COMPLEX(3,4) = 3+4i
COMPLEX(3,4,"j") = 3+4j
COMPLEX(0,1) = i
COMPLEX(1,0) = 1

See Also
Help
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CONVERT(number,from_unit,to_unit)
Converts a number from one measurement system to another.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Number is the value in from_units to convert. 
From_unit is the unit for number.
To_unit is the units for the result.

Weight and mass From_unit or to_unit
Gram g
Slug sg
Pound mass (avoirdupois) lbm
U u
Ounce mass (avoirdupois) ozm

Distance From_unit or to_unit
Meter m
Statute mile mi
Nautical mile nmi
Inch in
Foot ft
Yard yd
Angstrom ang

Temperature From_unit or to_unit
Degree Celsius cel
Degree Fahrenheit fah
Degree Kelvin kel

For a complete list of values for from_unit and to_unit, see CONVERT in the Microsoft Excel
Function Reference.

Examples
CONVERT(1.0,"lbm","kg") = 0.453592
CONVERT(68,"fah","cel") = 20
CONVERT(2.5,"ft","cel") = #N/A!

See Also
Help
BIN2DEC Converts a binary number to decimal.
DEC2BIN Converts a decimal number to binary.
HEX2DEC Converts a hexadecimal number to decimal.
OCT2DEC Converts an octal number to decimal.
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DELTA(number1,number2)
Tests whether two values are equal. Returns 1 if number1 = number2; returns 0 
otherwise.    Use this function to filter a set of values.    This function is also known as the 
Kronecker Delta function.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Number1 is the first number.
Number2 is the second number. If omitted, number2 is assumed to be zero.

Examples
DELTA(5,4) = 0
DELTA(5,5) = 1
DELTA(0.5,0) = 0

See Also
Help
GESTEP Tests whether a number is greater than a threshold value.
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ERF(lower_limit,upper_limit)
Returns the error function integrated between lower_limit and upper_limit.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Lower_limit is the lower bound for integrating ERF.
Upper_limit is the upper bound for integrating ERF. If omitted, ERF integrates 

between zero and lower_limit.
Examples

ERF(0.74500) = 0.70793
ERF(1) = 0.84270

See Also
Help
ERFC Returns the complementary error function.
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FACTDOUBLE(number)
Returns the double factorial of a number.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Number is the value for which to return the double factorial. If number is not an 
integer, it is truncated.
Examples

FACTDOUBLE(6) = 6*4*2 = 48
FACTDOUBLE(7) = 7*5*3 = 105

See Also
Help
FACT Returns the factorial of a number.
MULTINOMIAL Returns the multinomial of a set of numbers.
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GCD(number1,number2,number3,...)
Returns the greatest common divisor of two or more integers.    The greatest common 
divisor is the largest integer that divides both number1 and number2 without a remainder.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Number1,number2,... are 1 to 29 values. If any value is not an integer, it is 
truncated.
Examples

GCD(5,2) = 1
GCD(24,36) = 12
GCD(7,1) = 1
GCD(5,0) = 5

See Also
Help
LCM Returns the least common multiple.
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GESTEP(number,step)
Returns 1 if number is greater than or equal to step; returns 0 otherwise.    Use this 
function to filter a set of values. 
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Number is the value to test against step.
Step is the threshold value. If you omit a value for step, GESTEP uses zero. 

Examples
GESTEP(5,4) = 1
GESTEP(5,5) = 1
GESTEP(-4,-5) = 1
GESTEP(-1,0) = 0

See Also
Help
DELTA Test whether two numbers are equal.
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IMABS(inumber)
Returns the absolute value (modulus) of a complex number in x+yi or x+yj text format.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Inumber    is a complex number for which you want the absolute value.
Example

IMABS("5+12i") = 13
See Also

Help
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IMAGINARY(inumber)
Returns the imaginary coefficient of a complex number in x+yi or x+yj text format.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Inumber is a complex number for which you want the imaginary coefficient.
Examples

IMAGINARY("3+4i") = 4
IMAGINARY("0-j") = -1
IMAGINARY(4) = 0

See Also
Help
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IMARGUMENT(inumber)
Returns the argument q, an angle expressed in radians.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Inumber is a complex number for which you want the argument q.
Example

IMARGUMENT(3+4i) = 0.927295
Related Functions      
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IMCONJUGATE(inumber)
Returns the complex conjugate of a complex number in x+yi or x+yj text format.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Inumber is a complex number for which you want the conjugate.
Example

IMCONJUGATE("3+4i") = 3-4i
See Also

Help
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IMCOS(inumber)
Returns the cosine of a complex number in x+yi or x+yj text format.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Inumber is a complex number for which you want the cosine.
Example

IMCOS("1+i") = 0.83373-0.988898i
See Also

Help
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IMEXP(inumber)
Returns the exponential of a complex number in x+yi or x+yj text format.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Inumber is a complex number for which you want the exponential.
Example

IMEXP("1+i") = 1.468694+2.287355i
See Also

Help
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IMLN(inumber)
Returns the natural logarithm of a complex number in x+yi or x+yj text format.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Inumber is a complex number for which you want the natural logarithm.
Example

IMLN("3+4i") = 1.609438+0.927295i
See Also

Help
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IMLOG10(inumber)
Returns the common logarithm (base 10) of a complex number in x+yi or x+yj text format.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Inumber is a complex number for which you want the common logarithm.
Example

IMLOG10("3+4i") = 0.69897+0.402719i
See Also

Help
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IMLOG2(inumber)
Returns the base-2 logarithm of a complex number in x+yi or x+yj text format.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Inumber is a complex number for which you want the base-2 logarithm.
Example

IMLOG2("3+4i") = 2.321928+1.337804i
See Also

Help
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IMPOWER(inumber,number)
Returns a complex number in x+yi or x+yj text format raised to an integer power.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Inumber is a complex number you want to raise to a power.
Number is the power to which you want to raise the complex number.

Example
IMPOWER("2+3i",3) = -46+9i

See Also
Help
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IMPRODUCT(inumber1,inumber2)
Returns the product of two complex numbers in x+yi or x+yj text format.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Inumber1 is the complex number multiplicand.
Inumber2 is the complex number multiplier.

Examples
IMPRODUCT("3+4i","5-3i") = 27+11i
IMPRODUCT("1+2i",30) = 30+60i

See Also
Help
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IMSIN(inumber)
Returns the sine of a complex number in x+yi or x+yj text format .
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Inumber is a complex number for which you want the sine.
Example

IMSIN("3+4i") = 3.853738-27.016813i
See Also

Help
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IMSQRT(inumber)
Returns the square root of a complex number in x+yi or x+yj text format.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Inumber is a complex number for which you want the square root.
Example

IMSQRT(1+i) = 1.098684+0.45509i
See Also

Help
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IMSUM(inumber1,inumber2,inumber3,...)
Returns the sum of two or more complex numbers in x+yi or x+yj text format.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Inumber1,inumber2,inumber3,... are from 1 to 12 complex numbers to add.
Example

IMSUM("3+4i","5-3i") = 8+i
See Also

Help
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ERFC(x)
Returns the complementary error function integrated between x and infinity.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

X is the lower bound for integrating ERF.
Example

ERFC(1) = 0.1573
See Also

Help
ERF Returns the error function. 
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IMDIV(inumber1,inumber2)
Returns the quotient of two complex numbers in x+yi or x+yj text format.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Inumber1 is the complex numerator or dividend.
Inumber2 is the complex denominator or divisor.

Example
IMDIV("-238+240i","10+24i") = 5+12i

See Also
Help
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IMREAL(inumber)
Returns the real coefficient of a complex number in x+yi or x+yj text format.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Inumber is a complex number for which you want the real coefficient.
Example

IMREAL("6-9i") = 6
See Also

Help
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IMSUB(inumber1,inumber2)
Returns the difference of two complex numbers in x+yi or x+yj text format.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Inumber1 is the complex number from which to subtract inumber2.
Inumber2 is the complex number to subtract from inumber1.

Example
IMSUB("13+4i","5+3i") = 8+i

See Also
Help
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ISEVEN(number)
Returns TRUE if number is even, or FALSE if number is odd.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Number is the value to test. If number is not an integer, it is truncated.
Examples

ISEVEN(-1) = FALSE
ISEVEN(2.5) = TRUE
ISEVEN(5) = FALSE

See Also
Help
ISODD Tests whether a number is odd.
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ISODD(number)
Returns TRUE if number is odd, or FALSE if number is even.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Number is the value to test. If number is not an integer, it is truncated.
Examples

ISODD(-1) = TRUE
ISODD(2.5) = FALSE
ISODD(5) = TRUE

See Also
Help
ISEVEN Tests whether a number is even.
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BIN2DEC(number)
Converts a binary number to decimal.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Number is the binary number you want to convert. Number can contain a maximum
of 10 characters (10 bits). The most significant bit of number is the sign bit. The remaining 
9 bits are magnitude bits. Negative numbers are represented using two's-complement 
notation.
Examples

BIN2DEC(1100100) = 100
BIN2DEC(1111111111) = -1

See Also
Help
DEC2BIN Converts a decimal number to binary.
HEX2BIN Converts a hexadecimal number to binary.
OCT2BIN Converts an octal number to binary.
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BIN2HEX(number,places)
Converts a binary number to hexadecimal.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Number is the binary number you want to convert. Number can contain a maximum
of 10 characters (10 bits).    The most significant bit of number is the sign bit. The remaining
9 bits are magnitude bits.    Negative numbers are represented using two's-complement 
notation.

Places is the number of characters to use. If places is omitted, BIN2HEX uses the 
minimum number of characters necessary.    Places is useful for padding the return value 
with leading zeros.
Examples

BIN2HEX(11111011,4) = 00FB
BIN2HEX(1110) = E
BIN2HEX(1111111111) = FFFFFFFFFF

See Also
Help
DEC2BIN Converts a decimal number to binary.
HEX2BIN Converts a hexadecimal number to binary.
OCT2BIN Converts an octal number to binary.
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BIN2OCT(number,places)
Converts a binary number to octal.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Number is the binary number you want to convert. Number can contain a maximum
of 10 characters (10 bits). The most significant bit of number is the sign bit. The remaining 
9 bits are magnitude bits. Negative numbers are represented using two's-complement 
notation.

Places is the number of characters to use. If places is omitted, BIN2OCT uses the 
minimum number of characters necessary. Places is useful for padding the return value with
leading zeros.
Examples

BIN2OCT(1001,3) = 011
BIN2OCT(01100100) = 144
BIN2OCT(1111111111) = 7777777777

See Also
Help
DEC2BIN Converts a decimal number to binary.
HEX2BIN Converts a hexadecimal number to binary.
OCT2BIN Converts an octal number to binary.
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DEC2BIN(number,places)
Converts a decimal integer to binary.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Number is the decimal integer you want to convert. If number is negative, places is
ignored and DEC2BIN returns a 10-character (10-bit) binary number in which the most 
significant bit is the sign bit.    The remaining 9 bits are magnitude bits. Negative numbers 
are represented using two's-complement notation.

Places is the number of characters to use. If places is omitted, DEC2BIN uses the 
minimum number of characters necessary.    Places is useful for padding the return value 
with leading zeros.
Examples

DEC2BIN(9,4) = 1001
DEC2BIN(-100) = 1110011100

See Also
Help
BIN2DEC Converts a binary number to decimal.
HEX2DEC Converts a hexadecimal number to decimal.
OCT2DEC Converts an octal number to decimal.
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DEC2HEX(number,places)
Converts a decimal integer to hexadecimal.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Number is the decimal integer you want to convert. If number is negative, places is
ignored and DEC2HEX returns a 10-character (40-bit) hexadecimal number in which the 
most significant bit is the sign bit.    The remaining 39 bits are magnitude bits. Negative 
numbers are represented using two's-complement notation.

Places is the number of characters to use.    If places is omitted, DEC2HEX uses the 
minimum number of characters necessary.    Places is useful for padding the return value 
with leading zeros.
Examples

DEC2HEX(100,4) = 0064
DEC2HEX(-54) = FFFFFFFFCA

See Also
Help
BIN2DEC Converts a binary number to decimal.
HEX2DEC Converts a hexadecimal number to decimal.
OCT2DEC Converts an octal number to decimal.
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DEC2OCT(number,places)
Converts a decimal integer to octal.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Number is the decimal integer you want to convert. If number is negative, places is
ignored and DEC2OCT returns a 10-character (30-bit) octal number in which the most 
significant bit is the sign bit.    The remaining 29 bits are magnitude bits. Negative numbers 
are represented using two's-complement notation.

Places is the number of characters to use. If places is omitted, DEC2OCT uses the 
minimum number of characters necessary.    Places is useful for padding the return value 
with leading zeros.
Examples

DEC2OCT(58,3) = 072
DEC2OCT(-100) = 7777777634

See Also
Help
BIN2DEC Converts a binary number to decimal.
HEX2DEC Converts a hexadecimal number to decimal.
OCT2DEC Converts an octal number to decimal.
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ERROR.TYPE(error_val)
Returns a number corresponding to a Microsoft Excel error value.    Use ERROR.TYPE to 
determine what type of error occurred so that your macro can run an appropriate error-
handling subroutine. ERROR.TYPE can also be used on a worksheet.

Error_val is the error value whose identifying number you want to find. Although 
error_val can be the actual error value, it will usually be a reference to a cell containing a 
formula that    you want to test.

If error_val is ERROR.TYPE returns
#NULL! 1
#DIV/0! 2
#VALUE! 3
#REF! 4
#NAME? 5
#NUM! 6
#N/A 7
Anything else #N/A

Example
The following macro formula checks the cell named Ratio to see if it contains a #DIV/0! 
error.    If it does, a subroutine named DivisionByZero is run.
IF(ERROR.TYPE(Ratio)=2,DivisionByZero())

See Also
Help
ISERR Returns TRUE if its argument refers to any error except #N/A.
ISERROR Returns TRUE if its argument refers to any error value.
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HEX2BIN(number,places)
Converts a hexadecimal number to binary.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Number is the hexadecimal number you want to convert.    Number can contain no 
more than 10 characters.    The most significant bit of number is the sign bit.    The 
remaining 9 bits are magnitude bits.    Negative numbers are represented using two's-
complement notation. 

A negative number cannot be less than FFFFFFFE0. A positive number cannot be 
more than 1FF.

Places is the number of characters to use. If places is omitted, HEX2BIN uses the 
minimum number of characters necessary.    Places is useful for padding the return value 
with leading zeros.
Examples

HEX2BIN("F",8) = 00001111
HEX2BIN("B7") = 10110111
HEX2BIN("FFFFFFFFFF") = 1111111111

See Also
Help
BIN2HEX Converts a binary number to hexadecimal.
DEC2HEX Converts a decimal number to hexadecimal.
OCT2HEX Converts an octal number to hexadecimal.
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HEX2DEC(number)
Converts a hexadecimal number to decimal.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Number is the hexadecimal number you want to convert.    Number can contain a 
maximum of 10 hexadecimal characters (40 bits).    The most significant bit of number is 
the sign bit.    The remaining 39 bits are magnitude bits.    Negative numbers are represented
using two's-complement notation.
Examples

HEX2DEC("A5") = 165
HEX2DEC("FFFFFFFF5B") = -165
HEX2DEC("3DA408B9") = 1034160313

See Also
Help
BIN2HEX Converts a binary number to hexadecimal.
DEC2HEX Converts a decimal number to hexadecimal.
OCT2HEX Converts an octal number to hexadecimal.
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HEX2OCT(number,places)
Converts a hexadecimal number to octal.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Number is the hexadecimal number you want to convert.    Number can contain a 
maximum of 10 characters.    The most significant bit of number is the sign bit. The 
remaining 39 bits are magnitude bits.    Negative numbers are represented using two's-
complement notation. 

A negative number cannot be less than FFE0000000. A positive number cannot be 
more than 1FFFFFFF.

Places is the number of characters to use.    If places is omitted, HEX2OCT uses the 
minimum number of characters necessary.    Places is useful for padding the return value 
with leading zeros.
Examples

HEX2OCT("F",3) = 017
HEX2OCT("3B4E") = 35516
HEX2OCT("FFFFFFFF00") = 7777777400

See Also
Help
BIN2HEX Converts a binary number to hexadecimal.
DEC2HEX Converts a decimal number to hexadecimal.
OCT2HEX Converts an octal number to hexadecimal.
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LCM(number1,number2,...)
Returns the least common multiple of integers.    The least common multiple is the smallest 
positive integer that is a multiple of all integer arguments number1, number2, and so on.  
Use LCM to add fractions with different denominators.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Number1,number2,... are 1 to 29 values for which you want the least common 
multiple. If a value is not an integer, it is truncated.
Examples

LCM(5,2) = 10
LCM(24,36) = 72

See Also
Help
GCD Returns the greatest common divisor.
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MROUND(number,multiple)
Returns a number rounded to the desired multiple.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Number is the value to round.
Multiple is the multiple to which you want to round number.

Examples
MROUND(10,3) = 9
MROUND(-10,-3) = -9
MROUND(1.3,0.2) = 1.4
MROUND(5,-2) = 6

See Also
Help
CEILING Rounds a number up to the nearest integral value.
EVEN Rounds a number up to the nearest even value.
FLOOR Rounds a number down to the nearest integral value.
ODD Rounds a number up to the nearest odd value.
ROUND Rounds a number to a specified number of digits.
TRUNC Truncates a number to an integer.
List of Math & Trig Functions



MULTINOMIAL(number1,number2,...)
Returns the ratio of the factorial of a sum of values to the product of factorials.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Number1,number2,... are 1 to 29 values for which you want the multinomial.
Example

MULTINOMIAL(2,3,4) = (2+3+4)!/(2!*3!*4!) = 1260
See Also

Help
FACT Returns the factorial of a number.
FACTDOUBLE Returns the double factorial of a number.
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OCT2BIN(number,places)
Converts an octal number to binary.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Number is the octal number you want to convert.    Number can contain a maximum
of 10 characters.    The most significant bit of number is the sign bit.    The remaining 29 bits
are magnitude bits.    Negative numbers are represented using two's-complement notation.

A negative number cannot be less than 7777777000. A positive number cannot be 
more than 777.

Places is the number of characters to use.    If places is omitted, OCT2BIN uses the 
minimum number of characters necessary.    Places is useful for padding the return value 
with leading zeros.
Examples

OCT2BIN(3,3) = 011
OCT2BIN(7777777000) = 1000000000

See Also
Help
BIN2OCT Converts a binary number to octal.
DEC2OCT Converts a decimal number to octal.
HEX2OCT Converts a hexadecimal number to octal.
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OCT2DEC(number)
Converts an octal number to decimal.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Number is the octal number you want to convert.    Number can contain a maximum
of 10 octal characters (30 bits).    The most significant bit of number is the sign bit. The 
remaining 29 bits are magnitude bits.    Negative numbers are represented using two's-
complement notation.
Examples

OCT2DEC(54) = 44
OCT2DEC(7777777533) = -165

See Also
Help
BIN2OCT Converts a binary number to octal.
DEC2OCT Converts a decimal number to octal.
HEX2OCT Converts a hexadecimal number to octal.
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OCT2HEX(number,places)
Converts an octal number to hexadecimal.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Number is the octal number you want to convert.    Number can contain a maximum
of 10 octal characters (30 bits).    The most significant bit of number is the sign bit. The 
remaining 29 bits are magnitude bits.    Negative numbers are represented using two's-
complement notation.

Places is the number of characters to use.    If places is omitted, OCT2HEX uses the 
minimum number of characters necessary.    Places is useful for padding the return value 
with leading zeros.
Examples

OCT2HEX(100,4) = 0040
OCT2HEX(7777777533) = FFFFFFFF5B

See Also
Help
BIN2OCT Converts a binary number to octal.
DEC2OCT Converts a decimal number to octal.
HEX2OCT Converts a hexadecimal number to octal.
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QUOTIENT(numerator,denominator)
Returns the integer portion of a division.    Use this function when you want to discard the 
remainder of a division.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Numerator is the dividend.
Denominator is the divisor.

Examples
QUOTIENT(5,2) = 2
QUOTIENT(4.5,3.1) = 1
QUOTIENT(-10,3) = -3

See Also
Help
MOD Returns the remainder from a division.
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SERIESSUM(x,n,m,coefficients)
Returns the sum of a power series.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

X is the input value to the power series.
N is the initial power to which you want to raise x. 
M is the step by which to increase n for each term in the series.
Coefficients is a set of coefficients by which each successive power of x is 

multiplied.    The number of values in coefficients determines the number of terms in the 
power series.    For example, if there are three values in coefficients, then there will be 
three terms in the power series.
Example

For an example of this function, see SERIESSUM in the Microsoft Excel Function Reference.
See Also

Help
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SQRTPI(number)
Returns the square root of (number * pi).
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Number is the number by which pi is multiplied.
Examples

SQRTPI(1) = 1.772454
SQRTPI(2) = 2.506628

See Also
Help
PI Returns the value pi.
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DDB(cost,salvage,life,period,factor)
Returns the depreciation of an asset for a specific period using the double-declining 
balance method based on the asset's initial cost, its salvage value at the end of its life, 
and the rate at which the balance is to be declined (factor).

All arguments must be positive numbers.
The default value for factor is two, indicating that the balance is double-declined.

Example
You just purchased a new machine for $2400.    It has a lifetime of 10 years and a salvage 
value of $300.
DDB(2400,300,10,1) = $480.00, the depreciation for the first year.
DDB(2400,300,10,2,1.5) = $306.00, the depreciation for the second year using a factor 
or 1.5 instead of the double-declining balance method.
DDB(2400,300,10,10) = $22.12, the depreciation for the tenth year.

See Also
Help
SLN Returns straight-line depreciation.
SYD Returns sum-of-the-years' digits depreciation.
VDB Returns depreciation of an asset for a partial period.
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SLN(cost,salvage,life)
Returns straight-line depreciation of an asset for a single period.    All arguments must be 
positive numbers.

Argument Description
cost Initial cost of the asset
salvage Value at end of depreciation (also called salvage value of the asset)
life Number of periods over which the asset is being depreciated (also called 

useful life of the asset)
Example

For an example of this function, see SLN in the Microsoft Excel Function Reference.
See Also

Help
DDB Returns the depreciation of an asset using the double-declining balance 

method.
SYD Returns the depreciation of an asset using the sum-of-years' digits method.
VDB Returns the depreciation of an asset for a partial period.
List of Financial Functions



SYD(cost,salvage,life,per)
Returns sum-of-years' digits depreciation of an asset for a specified period.

Argument Description
cost Initial cost of the asset
salvage Value at end of depreciation (also called salvage value of the asset)
life Number of periods over which the asset is being depreciated (also called 

useful life of the asset)
per Period

Example
For an example of this function, see "SYD" in the Microsoft Excel Function Reference.

See Also
Help
DDB Returns depreciation of an asset using the double-declining balance 

method.
SLN Returns straight-line depreciation of an asset for one period.
VDB Returns depreciation of an asset for a partial period.
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VDB(cost,salvage,life,start_period,end_period,factor,no_switch)
Returns the depreciation of an asset for a length of time specified by start_period and 
end_period.    If factor is not supplied, uses the double-declining balance method based on
the asset's initial cost and its salvage value at the end of its life. 

Arguments must be positive numbers or references to positive numbers, except 
no_switch which can be TRUE or FALSE.    

VDB uses the formula, "cost minus the total depreciation from prior periods," to 
calculate bookvalue and the formula, "(Bookvalue*2)/life", to calculate depreciation for a 
period.

Factor is the rate at which you can depreciate an asset relative to straight-line 
depreciation.

If omitted, factor is assumed to be 2 (double-declining balance).
If no_switch is FALSE or omitted, VDB will switch to straight-line depreciation when 

that depreciation is greater than the declining-balance calculation.
If no_switch is TRUE, VDB will not switch to straight-line depreciation, even if 

depreciation is greater than the declining-balance calculation.
Example

You purchased a new machine for $2400 in the middle of the first quarter of the fiscal 
year.    It has a lifetime of 5 years and a salvage value of $300.    You want to determine 
the amount of depreciation for the first fiscal year that you own the asset, assuming tax 
laws limit you to 150% depreciation of the declining balance.

VDB(2400,300,5,0,.875,1.5) = $630.00
See Also

Help
DDB Returns depreciation for an asset using the double-declining balance 

method.
SLN Returns straight-line depreciation.
SYD Returns sum-of-years' digits depreciation.
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FV(rate,nper,pmt,pv,type)
Returns the future value of an investment based on a number (nper) of periodic constant 
payments (pmt) and a constant interest rate (rate).    The pv and type arguments are 
optional; if they are omitted, FV uses the value 0.
Examples

FV(0.5%,10,-200,-500,1) = $2,581.40
FV(1%,12,-1000) = $12,682.50
FV(11%/12,35,-2000,,1) = $82,846.25

See Also
Help
FVSCHEDULE Returns the future value of an initial principal after applying a series of 

compound interest rates.
PV Returns the present value of an investment based on even cash flows.
Financial Function Arguments
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IPMT(rate,per,nper,pv,fv,type)
Returns the interest payment for a given period (per) for an investment based on periodic, 
constant payments and a constant interest rate (rate).    Fv and type are optional; if 
omitted, IPMT uses 0.
Examples

The following function finds the interest due in the first month of a 3-year $8,000 loan at 
10% annual interest, where payments are made monthly:
IPMT(0.1/12,1,36,8000) = -$66.67
The following function finds the interest due in the last year of a 3-year $8,000 loan at 
10% annual interest:
IPMT(0.1,3,3,8000) = -$292.45

See Also
Help
CUMIPMT Returns the cumulative interest paid between start_period and end_period.
FV Returns the future value of an investment. 
PV Returns the present value of an investment based on even cash flows.
Financial Function Arguments
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IRR(values,guess)
Returns the internal rate of return for a series of periodic cash flows represented by the 
numbers in values.    The internal rate of return is the interest rate received for an 
investment consisting of payments (negative values) and incomes (positive values) that 
occur at regular periods.
IRR is closely related to the net present value function, NPV.    The rate of return calculated 
by IRR is the interest rate corresponding to a net present value of zero.

Values must be an array or a reference to cells that contain numbers.    There must 
be at least one positive value and one negative value.    Otherwise the internal rate of return 
would be infinite.

In cases where values reflects payments (negative cash flows) and incomes (positive
cash flows) for the same period, the payments and incomes should be totaled and the net 
positive or negative cash flow should be used for that period.

IRR uses the order of values to interpret the order of cash flows.    Be sure to enter 
your payment and income values in the correct sequence.

Text, logical, and blank values are ignored.    However, if no cash flow or net cash 
flow occurs for a particular period, you must enter 0 (zero) as the value for that period (not 
leave it blank) to signify that a period has gone by in which no cash flow occurred.
Starting with the value of guess, IRR uses an iterative technique to cycle through the 
calculation until the value is accurate within .00001%.    If after 20 tries it can't find a value 
that works, IRR returns the error value #NUM!
In most cases you don't need to provide guess.    If you omit it, IRR guesses in the 
range .1% to 10%.    However, if IRR returns the error value #NUM!, try again with different 
values of guess.
Example

For an example of this function, see IRR in the Microsoft Excel Function Reference.

See Also
Help
MIRR Returns the internal rate of return including cost of investment.
NPV Returns the net present value of an investment based on a series of 

periodic cash flows and a discount rate.
PV Returns the present value of an investment based on even cash flows.
RATE Returns the interest rate per period of an annuity.
Financial Function Arguments
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MIRR(values,finance_rate,reinvest_rate)
Returns modified internal rate of return for a series of periodic cash flows represented by 
the numbers in values.    Considers both cost of the investment, finance_rate, and interest
received on reinvestment of cash, reinvest_rate.

Values must be an array or a reference to cells that contain numbers.    These 
numbers represent a series of payments (negative values) and income (positive values) 
occurring at regular periods.

In cases where values reflects payments (negative cash flows) and incomes (positive
cash flows) for the same period, the payments and incomes should be totaled and the net 
positive or negative cash flow should be used for that period.

There must be at least one positive value and one negative value; otherwise, MIRR 
returns #DIV/0!.

MIRR uses the order of values to interpret order of cash flows.    It ignores text, 
logical, and blank values.    However, if no cash flow occurs for a particular period, you must
enter 0 (zero) as the value for that period (not leave it blank) to signify that a period has 
gone by in which no cash flow occurred.
Example

For an example of this function, see MIRR in the Microsoft Excel Function Reference.

See Also
Help
IRR Returns internal rate of return for a series of cash flows.
RATE Returns the interest rate per period of an annuity.
Financial Function Arguments
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NPER(rate,pmt,pv,fv,type)
Returns the number of periods for an investment based on periodic, constant payments and
a constant interest rate.

NPER, rate, and pmt refer to the same period of time.    If rate is per year then 
NPER returns the number of years and pmt is yearly.

The fv and type arguments are optional; if omitted, NPER uses 0.
Examples

NPER(12%/12,-100,-1000,10000,1) =60
NPER(1%,-100,-1000,10000) =60
NPER(1%,-100,1000) =11

See Also
Help
IPMT Returns interest payment for an investment for a given period.
PPMT Returns principal payment for an investment for a given period.
Financial Function Arguments
List of Financial Functions



NPV(rate,value1,value2,...)
Returns the net present value of an investment based on a series of periodic cash flows, 
value1, value2,... and a discount rate equal to rate.

Rate is the rate of discount over the length of one period.
Value1,value2,... must be equally spaced in time and occur at the end of each 

period.    
NPV uses the order of value1,value2,... to interpret the order of cash flows.
The list of values can contain up to 29 arguments representing the payments and 

income.
The individual arguments must be numbers, empty cells, logical values, or text 

representations of logical values.
If the argument is an array or a reference, only numbers in that array or reference are

counted.
Error values or text that cannot be converted into numbers are ignored.

The NPV investment begins one period before the date of the value1 cash flow, and ends 
with the last cash flow in the list.    If your first cash flow occurs at the beginning of the first 
period, the first value must be added to the NPV result, not included in the values 
arguments.
Example

For an example of this function, see NPV in the Microsoft Excel Function Reference.

See Also
Help
FV Returns future value of an investment based on constant cash flows.
IRR Returns internal rate of return for a series of cash flows.
PV Returns present value of an investment based on constant cash flows.
Financial Function Arguments
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PMT(rate,nper,pv,fv,type)
Returns payment for an investment based on periodic, constant payments and a constant 
interest rate.

Make sure that you are consistent about the units you use for specifying rate and 
nper.    If rate is per year then PMT returns the number of payments per year and nper is 
the number of years.

Fv and type are optional; if omitted, PMT uses 0.
Examples

PMT(8%/12,10,0,10000,1) =-$963.94
PMT(8%/12,10,0,10000) =-$970.37
PMT(12%/12,5,-5000) =$1,030.20

See Also
Help
IPMT Returns interest payment for an investment for a given period.
PPMT Returns principal payment for an investment for a given period.
Financial Function Arguments
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PPMT(rate,per,nper,pv,fv,type)
Returns the payment on the principal for a given period for an investment based on 
periodic, constant payments and a constant interest rate.

The fv and type arguments are optional; if omitted, PPMT uses 0.
Per specifies the period and must be in the range 1 to nper.

Example
For an example of this function, see PPMT in the Microsoft Excel Function Reference.

See Also
Help
IPMT Returns interest payment for an investment for a given period.
PMT Returns periodic total payment for an investment.
Financial Function Arguments
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PV(rate,nper,pmt,fv,type)
Returns the present value of an investment based on periodic, constant payments and a 
constant interest rate.

The fv and type arguments are optional; if omitted, PV uses 0.
Example

For an example of this function, see PV in the Microsoft Excel Function Reference.

See Also
Help
IPMT Returns interest payment for an investment for a given period.
PPMT Returns principal payment for an investment for a given period.
Financial Function Arguments
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RATE(nper,pmt,pv,fv,type,guess)
Returns the interest rate per period for an annuity.

Calculated by iteration; can have zero or more solutions.    If the successive results of 
RATE do not converge to within 0.0000001 after 20 iterations, RATE returns #NUM!.

Guess is your guess for what the rate will be.
If you omit guess, RATE uses 10%.
If RATE does not converge, try different values for guess.    RATE usually converges if 
given a guess between 0 and 1.

The fv and type arguments are optional; if omitted, RATE uses 0.
Example

For an example of this function, see RATE in the Microsoft Excel Function Reference.

See Also
Help
IPMT Returns interest payment for an investment for a given period.
PPMT Returns principal payment for an investment for a given period.
Financial Function Arguments
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DB(cost,salvage,life,period,month)
Returns the real depreciation of an asset for a specific period using the fixed-declining 
balance method.

Cost is the initial cost of the asset.
Salvage is the value at the end of the depreciation (sometimes called the salvage 

value of the asset).
Life is the number of periods over which the asset is being depreciated (sometimes 

called the useful life of the asset).
Period is the period for which you want to calculate the depreciation. Period must 

use the same units as life.
Month is the number of months in the first year. If month is omitted, it is assumed 

to be 12.
Examples

Suppose a factory purchases a new machine.    The machine costs $1,000,000 and has a 
lifetime of six years.    The salvage value of the machine is $100,000.    The following 
examples show depreciation over the life of the machine.    The results are rounded to 
whole numbers.
DB(1000000,100000,6,1,7) = $186,083
DB(1000000,100000,6,2,7) = $259,639
DB(1000000,100000,6,3,7) = $176,814
DB(1000000,100000,6,4,7) = $120,411
DB(1000000,100000,6,5,7) = $82,000
DB(1000000,100000,6,6,7) = $55,842
DB(1000000,100000,6,7,7) = $15,845

See Also
Help
DDB Returns the depreciation of an asset using the double-declining balance 

method.
SLN Returns the straight-line depreciation of an asset for one period.
SYD Returns the sum-of-years' digits depreciation of an asset for a specified 

period.
VDB Returns the depreciation of an asset for a partial period.
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ACCRINTM(issue,settlement,rate,par,basis)
Returns the accrued interest for a security that pays interest at maturity.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

A note has the following terms:
April 1, 1991 issue date
June 15, 1991 maturity date
10.0% coupon
$1,000 par value
Actual/365 basis

The accrued interest (in the 1900 date system) is:
ACCRINTM(33329,33404,0.1,1000,3) = 20.54795

See Also
Help
ACCRINT Returns the accrued interest for a security.
DATE Returns the serial number of a particular date.
Financial Function Arguments
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COUPDAYBS(settlement,maturity,frequency,basis)
Returns the number of days from the beginning of the coupon period to the settlement 
date.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

A bond has the following terms:
January 25, 1991 settlement date
November 15, 1992 maturity date
Semiannual coupon
Actual/actual basis

The number of days from the beginning of the coupon period to the settlement date (in 
the 1900 date system) is:
COUPDAYBS(33263,33923,2,1) = 71

See Also
Help
COUPDAYS Returns the number of days in coupon period that contains settlement 

date.
COUPDAYSNC Returns the number of days from settlement to next coupon date.
COUPNCD Returns the next coupon date after settlement date.
COUPNUM Returns the number of coupons payable between settlement date and 

maturity date.
COUPPCD Returns the previous coupon date before settlement date.
NOW Returns the serial number of the current date and time.
Financial Function Arguments
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COUPDAYS(settlement,maturity,frequency,basis)
Returns the number of days in the coupon period that contains the settlement date.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

A bond has the following terms:
January 25, 1991 settlement date
November 15, 1992 maturity date
Semiannual coupon
Actual/actual basis

The number of days in the coupon period that contains the settlement date (in the 1900 
date system) is:
COUPDAYS(33262,33923,2,1) = 181

See Also
Help
COUPDAYBS Returns the number of days from beginning of coupon period to settlement

date.
COUPDAYSNC Returns the number of days from settlement to next coupon date.
COUPNCD Returns the next coupon date after settlement date.
COUPNUM Returns the number of coupons payable between settlement date and 

maturity date.
COUPPCD Returns the previous coupon date before settlement date.
NOW Returns the serial number of the current date and time.
Financial Function Arguments
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COUPDAYSNC(settlement,maturity,frequency,basis)
Returns the number of days from the settlement date to the next coupon date.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

A bond has the following terms:
January 25, 1991 settlement date
November 15, 1992 maturity date
Semiannual coupon
Actual/actual basis

The number of days from the beginning of the coupon period to the settlement date (in 
the 1900 date system) is:
COUPDAYSNC(33263,33923,2,1) = 110

See Also
Help
COUPDAYBS Returns the number of days from beginning of coupon period to settlement

date.
COUPDAYS Returns the number of days in coupon period that contains settlement 

date.
COUPNCD Returns the next coupon date after settlement date.
COUPNUM Returns the number of coupons payable between settlement date and 

maturity date.
COUPPCD Returns the previous coupon date before settlement date.
NOW Returns the serial number of the current date and time.
Financial Function Arguments
List of Financial Functions



COUPNCD(settlement,maturity,frequency,basis)
Returns the next coupon date after the settlement date.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

A bond has the following terms:
January 25, 1991 settlement date
November 15, 1992 maturity date
Semiannual coupon
Actual/actual basis

The next coupon date after the settlement date (in the 1900 date system) is:
COUPNCD(33263,33923,2,1) = 33373 or May 15, 1991

See Also
Help
COUPDAYBS Returns the number of days from beginning of coupon period to settlement

date.
COUPDAYS Returns the number of days in coupon period that contains settlement 

date.
COUPDAYSNC Returns the number of days from settlement to next coupon date.
COUPNUM Returns the number of coupons payable between settlement date and 

maturity date.
COUPPCD Returns the previous coupon date before settlement date.
NOW Returns the serial number of the current date and time.
Financial Function Arguments
List of Financial Functions



COUPNUM(settlement,maturity,frequency,basis)
Returns the number of coupons payable between the settlement date and the maturity 
date, rounded to the nearest whole coupon.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

A bond has the following terms:
January 25, 1991 settlement date
November 15, 1992 maturity date
Semiannual coupon
Actual/actual basis

The number of coupon payments (in the 1900 date system) is:
COUPNUM(33263,33923,2,1) = 4

See Also
Help
COUPDAYBS Returns the number of days from beginning of coupon period to settlement

date.
COUPDAYS Returns the number of days in coupon period that contains settlement 

date.
COUPDAYSNC Returns the number of days from settlement to next coupon date.
COUPNCD Returns the next coupon date after settlement date.
COUPPCD Returns the previous coupon date before settlement date.
NOW Returns the serial number of the current date and time.
Financial Function Arguments
List of Financial Functions



COUPPCD(settlement,maturity,frequency,basis)
Returns the previous coupon date before the settlement date.
If this function is not available, you must install the Analysis ToolPak add-in macro. For more 
information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 of the 
Microsoft Excel User's Guide.
Example

A bond has the following terms:
January 25, 1991 settlement date
November 15, 1992 maturity date
Semiannual coupon
Actual/actual basis

The previous coupon date before the settlement date (in the 1900 date system) is:
COUPPCD(33263,33923,2,1) = 33192 or November 15, 1990

See Also
Help
COUPDAYBS Returns the number of days from beginning of coupon period to settlement

date.
COUPDAYS Returns the number of days in coupon period that contains settlement 

date.
COUPDAYSNC Returns the number of days from settlement to next coupon date.
COUPNCD Returns the next coupon date after settlement date.
COUPNUM Returns the number of coupons payable between settlement date and 

maturity date.
NOW Returns the serial number of the current date and time.
Financial Function Arguments
List of Financial Functions



CUMIPMT(rate,nper,pv,start_period,end_period,type)
Returns the cumulative interest paid on a loan between start_period and end_period.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Examples

A home mortgage loan has the following terms:
Interest rate, 9.00% per annum (rate = 9.00%    divided by 12 = 0.0075)
Term, 30 years (nper = 30 x 12 = 360)
Present value, $125,000

The total interest paid in the second year of payments (periods 13 through 24) is:
CUMIPMT(0.0075,360,125000,13,24,0) = -11135.23
The interest paid in a single payment, in the first month, is:
CUMIPMT(0.0075,360,125000,1,1,0) = -937.50

See Also
Help
CUMPRINC Returns the cumulative principal paid on a loan between two periods.
Financial Function Arguments
List of Financial Functions



CUMPRINC(rate,nper,pv,start_period,end_period,type)
Returns the cumulative principal paid on a loan between start_period and end_period.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Examples

A home mortgage loan has the following terms:
Interest rate, 9.00% per annum (rate = 9.00% divided by 12 = 0.0075)
Term, 30 years (nper = 30 x 12 = 360)
Present value, $125,000

The total principal paid in the second year of payments (periods 13 through 24) is:
CUMPRINC(0.0075,360,125000,13,24,0) = -934.1071
The principal paid in a single payment, in the first month, is:
CUMPRINC(0.0075,360,125000,1,1,0) = -68.27827

See Also
Help
CUMIPMT Returns the cumulative interest between two periods.
Financial Function Arguments
List of Financial Functions



DISC(settlement,maturity,pr,redemption,basis)
Returns the discount rate for a security.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

A bond has the following terms:
February 15, 1991 settlement date
June 10, 1991 maturity date
97.975 price
$100 redemption value
Actual/360 basis

The bond discount rate (in the 1900 date system) is:
DISC(33284,33399,97.975,100,2) = 0.063391 or 6.3391%

See Also
Help
NOW Returns the serial number of the current date and time.
PRICEDISC Returns the price per $100 face value for a discounted security.
YIELDDISC Returns the annual yield for a discounted security.
Financial Function Arguments
List of Financial Functions



DOLLARDE(fractional_dollar,fraction)
Converts a dollar price expressed as a fraction into a dollar price expressed as a decimal 
number. Use DOLLARDE to convert fractional dollar numbers, such as securities prices, to 
decimal numbers.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Examples

DOLLARDE(1.02,16) = 1.125
DOLLARDE(1.1,8) = 1.125

See Also
Help
DOLLAR Converts a number to text, using currency format.
DOLLARFR Converts a dollar price expressed as a decimal number to a dollar price 

expressed as a fraction.
Financial Function Arguments
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DOLLARFR(decimal_dollar,fraction)
Converts a dollar price expressed as a decimal number to a dollar price expressed as a 
fraction. Use DOLLARFR to convert decimal numbers to fractional dollar numbers, such as 
securities prices.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Examples

DOLLARFR(1.125,16) = 1.02
DOLLARFR(1.125,8) = 1.1

See Also
Help
DOLLAR Converts a number to text, using currency format.
DOLLARDE Converts a dollar price expressed as a fraction to a dollar price expressed 

as a decimal number.
Financial Function Arguments
List of Financial Functions



DURATION(settlement,maturity,coupon,yld,frequency,basis)
Returns the Macauley duration for an assumed par value of $100.    Duration is defined as 
the weighted average of the present value of the cash flows, and is used as a measure of a 
bond price's response to changes in yield.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

A bond has the following terms:
January 1, 1986 settlement date
January 1, 1994 maturity date
8.0% semiannual coupon
9.0% yield
Actual/actual basis

The duration (in the 1900 date system) is:
DURATION(31413,34335,0.08,0.09,2,1) = 5.993775

See Also
Help
MDURATION Returns the modified Macauley duration.
NOW Returns the serial number of the current date and time.
Financial Function Arguments
List of Financial Functions



EFFECT(nominal_rate,npery)
Returns the effective annual interest rate, given the nominal annual interest rate and the 
number of compounding periods per year.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

EFFECT(5.25%,4) = 0.053543 or 5.3543%
See Also

Help
NOMINAL Returns the nominal annual interest rate.
Financial Function Arguments
List of Financial Functions



EOMONTH(start_date,months)
Returns the serial number date for the last day of the month that is the indicated number of
months before or after start_date. Use EOMONTH to calculate maturity dates or due dates 
that fall on the last day of the month. 
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Examples

In the 1900 date system:
EOMONTH(DATEVALUE("01/01/91"),1) = 33297 or 02/28/91
EOMONTH(DATEVALUE("01/01/91"),-1) = 33238 or 12/31/90

See Also
Help
EDATE Returns the date before or after a specified number of months.
NETWORKDAYS Returns the number of whole workdays between two dates.
NOW Returns the serial number of the current date and time.
WORKDAY Returns the date before or after a specified number of workdays.
List of Date & Time Functions



FVSCHEDULE(principal,schedule)
Returns the future value of an initial principal after applying a series of compound interest 
rates. Use FVSCHEDULE to calculate the future value of an investment with a variable or 
adjustable rate.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

FVSCHEDULE(1.0,{0.09,0.11,0.1}) = 1.33089
See Also

Help
FV Returns the future value of an investment.
Financial Function Arguments
List of Financial Functions



INTRATE(settlement,maturity,investment,redemption,basis)
Returns the interest rate for a fully invested security.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

A bond has the following terms:
February 15, 1991 settlement (issue) date
May 15, 1991 maturity date
$1,000,000 investment
$1,014,420 redemption value
Actual/360 basis

The bond discount rate (in the 1900 date system) is:
INTRATE(33284,33373,1000000,1014420,2) = 0.058328 or 5.8328%

See Also
Help
NOW Returns the serial number of the current date and time.
RECEIVED Returns the amount received at maturity for a fully invested security.
Financial Function Arguments
List of Financial Functions



MDURATION(settlement,maturity,coupon,yld,frequency,basis)
Returns the modified Macauley duration for a security with an assumed par value of $100.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

A bond has the following terms:
January 1, 1986 settlement date
January 1, 1994 maturity date
8.0% semiannual coupon
9.0% yield
Actual/actual basis

The modified duration (in the 1900 date system) is:
MDURATION(31413,34335,0.08,0.09,2,1) = 5.73567

See Also
Help
DURATION Returns the Macauley duration.
NOW Returns the serial number of the current date and time.
Financial Function Arguments
List of Financial Functions



NETWORKDAYS(start_date,end_date,holidays)
Returns the number of whole working days between start_date and end_date.    Working 
days exclude weekends and any dates identified in holidays.    Use NETWORKDAYS to 
calculate employee benefits that accrue based on the number of days worked during a 
specific term.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

NETWORKDAYS(DATEVALUE("10/01/91"),DATEVALUE("12/01/91"),DATEVALUE("11/28/91"))
= 43 

See Also
Help
EDATE Returns the date before or after a specified number of months.
EOMONTH Returns the serial number last day of the month before or after a specified 

number of months.
NOW Returns the serial number of the current date and time.
WORKDAY Returns the date before or after a specified number of workdays.
List of Date & Time Functions



NOMINAL(effect_rate,npery)
Returns the nominal annual interest rate, given the effective rate and the number of 
compounding periods per year.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

NOMINAL(5.3543%,4) = 0.0525 or 5.25%
See Also

Help
EFFECT Returns the effective annual interest rate.
Financial Function Arguments
List of Financial Functions



ODDFPRICE(settlement,maturity,issue,first_coupon,rate,yld, 
redemption,frequency,basis)
Returns the price per $100 face value for a security having an odd (short or long) first 
period.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
See Also

Help
NOW Returns the serial number of the current date and time.
ODDFYIELD Returns the yield for a security with an odd first period.
ODDLPRICE Returns the price per $100 face value for a security with an odd last 

period.
ODDLYIELD Returns the yield for a security with an odd last period.
Financial Function Arguments
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ODDFYIELD(settlement,maturity,issue,first_coupon,rate, 
pr,redemption,frequency,basis)
Returns the yield of a security that has an odd (short or long) first period.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
See Also

Help
NOW Returns the serial number of the current date and time.
ODDFPRICE Returns the price per $100 face value for a security with an odd first 

period.
ODDLPRICE Returns the price per $100 face value for a security with an odd last 

period.
ODDLYIELD Returns the yield for a security with an odd last period.
Financial Function Arguments
List of Financial Functions



ODDLPRICE(settlement,maturity,last_coupon,rate,yld, 
redemption,frequency,basis)
Returns the price per $100 face value of a security having an odd (short or long) last coupon
period.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
See Also

Help
NOW Returns the serial number of the current date and time.
ODDFPRICE Returns the price per $100 face value for a security with an odd first 

period.
ODDFYIELD Returns the yield for a security with an odd first period.
ODDLYIELD Returns the yield for a security with an odd last period.
Financial Function Arguments
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ODDLYIELD(settlement,maturity,last_coupon,rate,pr, 
redemption,frequency,basis)
Returns the yield of a security that has an odd (short or long) last period.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
See Also

Help
NOW Returns the serial number of the current date and time.
ODDFPRICE Returns the price per $100 face value for a security with an odd first 

period.
ODDLPRICE Returns the price per $100 face value for a security with an odd last 

period.
ODDFYIELD Returns the yield for a security with an odd first period.
Financial Function Arguments
List of Financial Functions



PRICE(settlement,maturity,rate,yld,redemption,frequency,basis)
Returns the price per $100 face value of a security that pays periodic interest.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

A bond has the following terms:
February 15, 1991 settlement date
November 15, 1999 maturity date
5.75% semiannual coupon
6.50% yield
$100 redemption value
30/360 basis

The bond price (in the 1900 date system) is:
PRICE(33284,36479,0.0575,0.065,100,2,0) = 95.04287

See Also
Help
NOW Returns the serial number of the current date and time.
YIELD Returns the yield for a security with periodic interest payments.
Financial Function Arguments
List of Financial Functions



PRICEDISC(settlement,maturity,discount,redemption,basis)
Returns the price per $100 face value of a discounted security.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

A bond has the following terms:
February 15, 1991 settlement date
March 1, 1991 maturity date
5.25% yield
$100 redemption value
Actual/360 basis

The bond price (in the 1900 date system) is:
PRICEDISC(33284,33298,0.0525,100,2) = 99.79583

See Also
Help
DISC Returns the discount rate for a security.
NOW Returns the serial number of the current date and time.
YIELDDISC Returns the yield for a discounted security.
Financial Function Arguments
List of Financial Functions



PRICEMAT(settlement,maturity,issue,rate,yld,basis)
Returns the price per $100 face value of a security that pays interest at maturity.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

A bond has the following terms:
February 15, 1991 settlement date
April 13, 1991 maturity date
November 11, 1990 issue date
6.1% semiannual coupon
6.1% yield
30/360 basis

The price (in the 1900 date system) is:
PRICEMAT(33284,33341,33188,0.061,0.061,0) = 99.984499

See Also
Help
NOW Returns the serial number of the current date and time.
YIELDMAT Returns the yield for a security that pays interest at maturity .
Financial Function Arguments
List of Financial Functions



RECEIVED(settlement,maturity,investment,discount,basis)
Returns the amount received at maturity for a fully invested security.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

A bond has the following terms:
February 15, 1991 settlement (issue) date
May 15, 1991 maturity date
$1,000,000 investment
5.75% discount rate
Actual/360 basis

The bond discount rate (in the 1900 date system) is:
RECEIVED(33284,33373,1000000,0.0575,2) = 1,014,420.266

See Also
Help
INTRATE Returns the interest rate for a fully invested security.
NOW Returns the serial number of the current date and time.
Financial Function Arguments
List of Financial Functions



TBILLEQ(settlement,maturity,discount)
Returns the bond-equivalent yield for a Treasury bill.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

A Treasury bill has the following terms:
March 31, 1991 settlement date
June 1, 1991 maturity date
9.14% discount rate

The Treasury bill price (in the 1900 date system) is:
TBILLEQ(33328,33390,0.0914) = 0.094151 or 9.4151%

See Also
Help
NOW Returns the serial number of the current date and time.
TBILLPRICE Returns the price per $100 face value for a Treasury bill.
TBILLYIELD Returns the yield for a Treasury bill.
Financial Function Arguments
List of Financial Functions



TBILLPRICE(settlement,maturity,discount)
Returns the price per $100 face value for a Treasury bill.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

A Treasury bill has the following terms:
March 31, 1991 settlement date
June 1, 1991 maturity date
9% discount rate

The Treasury bill price (in the 1900 date system) is:
TBILLPRICE(33328,33390,0.09) = 98.43

See Also
Help
DATE Returns the serial number of a particular date.
TBILLEQ Returns the bond-equivalent yield for a Treasury bill.
TBILLYIELD Returns the yield for a Treasury bill.
Financial Function Arguments
List of Financial Functions



TBILLYIELD(settlement,maturity,pr)
Returns the yield for a Treasury bill.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

A Treasury bill has the following terms:
March 31, 1991 settlement date
June 1, 1991 maturity date
98.45 price per $100 face value

The Treasury bill price (in the 1900 date system) is:
TBILLYIELD(33328,33390,98.45) = 9.1417

See Also
Help
DATE Returns the serial number of a particular date.
TBILLEQ Returns the bond-equivalent yield for a Treasury bill.
TBILLPRICE Returns the price per $100 face value for a Treasury bill.
Financial Function Arguments
List of Financial Functions



WORKDAY(start_date,days,holidays)
Returns the serial number date that is the indicated number of working days before or after 
start_date. Working days exclude weekends and any dates identified in holidays.    Use 
WORKDAY to exclude weekends or holidays when you calculate invoice due dates, expected 
delivery times, or the number of days of work performed.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Examples

In the 1900 date system:
WORKDAY(DATEVALUE("01/03/91"),5) = 33248 or 01/10/91
If January 7, 1991 and January 8, 1991 are holidays, then
WORKDAY(DATEVALUE("01/03/91"),5,{33245,33246}) = 33252 or 01/14/91

See Also
Help
EDATE Returns the date before or after a specified number of months.
EOMONTH Returns the serial number last day of the month before or after a 

specified number of months.
NETWORKDAYS Returns the number of whole workdays between two dates.
NOW Returns the serial number of the current date and time.
List of Date & Time Functions



XIRR(values,dates,guess)
Returns the internal rate of return for a schedule of cash flows that is not necessarily 
periodic.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

Consider an investment that requires a $10,000 cash payment on January 1, 1991, and 
returns $2,750 on March 1, 1991, $4,250 on October 30, 1991, $3,250 on February 15, 
1992, and $2,750 on April 1, 1992.    The internal rate of return (in the 1900 date system) 
is:
XIRR({-10000,2750,4250,3250,2750},{33239,33298,33541,33649,33695},0.1) = 
0.374581 or 37.4581%

See Also
Help
IRR Returns the internal rate of return for a series of periodic cash flows.
MIRR Returns the internal rate of return where positive and negative cash flows 

are financed at different rates.
NPV Returns the net present value of investment.
RATE Returns the interest rate per period of an annuity.
XNPV Returns the net present value for a schedule of cash flows that is not 

necessarily periodic.
Financial Function Arguments
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XNPV(rate,values,dates)
Returns the net present value for a schedule of cash flows that is not necessarily periodic.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

Consider an investment that requires a $10,000 cash payment on January 1, 1991, and 
returns $2,750 on March 1, 1991, $4,250 on October 30, 1991, $3,250 on February 15, 
1992, and $2,750 on April 1, 1992.    Assume that the cash flows are discounted at 9%.    
The net present value (in the 1900 date system) is:
XNPV(0.09,{-10000,2750,4250,3250,2750},{33239,33298,33541,33649,33695}) = 
2088.918556

See Also
Help
IRR Returns the internal rate of return for a series of periodic cash flows.
MIRR Returns the internal rate of return where positive and negative cash flows 

are financed at different rates.
NPV Returns the net present value of an investment.
RATE Returns the interest rate per period for an annuity.
XIRR Returns the internal rate of return for a schedule of cash flows that is not 

necessarily periodic.
Financial Function Arguments
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YEARFRAC(start_date,end_date,basis)
Returns the year fraction representing the number of whole days between start_date and 
end_date.    Use YEARFRAC to identify the proportion of a whole year's benefits or 
obligations to assign to a specific term.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Examples

In the 1900 date system:
YEARFRAC(DATEVALUE("01/01/91"),DATEVALUE("06/30/91"),0) = 0.5
YEARFRAC(DATEVALUE("01/01/91"),DATEVALUE("07/01/91"),3) = 0.49589

See Also
Help
EDATE Returns the date before or after a specified number of months.
EOMONTH Returns the serial number last day of the month before or after a 

specified number of months.
NETWORKDAYS Returns the number of whole workdays between two dates.
NOW Returns the serial number of the current date and time.
WORKDAY Returns the date before or after a specified number of workdays.
List of Date & Time Functions



YIELD(settlement,maturity,rate,pr,redemption,frequency,basis)
Returns the yield for a security that pays periodic interest. Use YIELD to calculate bond 
yield.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

A bond has the following terms:
February 15, 1991 settlement date
November 15, 1999 maturity date
5.75% semiannual coupon
95.04287 price
$100 redemption value
30/360 basis

The bond yield (in the 1900 date system) is:
YIELD(33284,36479,0.0575,95.04287,100,2,0) = 0.065 or 6.5%

See Also
Help
NOW Returns the serial number of the current date and time.
PRICE Returns the price per $100 face value for a security with periodic interest 

payments.
Financial Function Arguments
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YIELDDISC(settlement,maturity,pr,redemption,basis)
Returns the annual yield for a discounted security.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

A bond has the following terms:
February 15, 1991 settlement date
June 10, 1991 maturity date
99.795 price
$100 redemption value
Actual/360 basis

The bond yield (in the 1900 date system) is:
YIELDDISC(33284,33298,97.975,100,2) = 0.052823 or 5.2823%

See Also
Help
DISC Returns the discount rate for a security.
NOW Returns the serial number of the current date and time.
PRICEDISC Returns the price per $100 face value for a discounted security.
Financial Function Arguments
List of Financial Functions



YIELDMAT(settlement,maturity,issue,rate,pr,basis)
Returns the annual yield for a security that pays interest at maturity.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

A bond has the following terms:
March 15, 1991 settlement date
November 3, 1991 maturity date
November 8, 1990 issue date
6.25% semiannual coupon
100.0123 price
30/360 basis

The yield (in the 1900 date system) is:
YIELDMAT(33312,33545,33185,0.0625,100.0123,0) = 0.060954 or 6.0954%

See Also
Help
NOW Returns the serial number of the current date and time.
PRICEMAT Returns price per $100 face value for a security that pays interest at 

maturity.
Financial Function Arguments
List of Financial Functions



ACCRINT(issue,first_interest,settlement,coupon,par,frequency,basis)
Returns the accrued interest for a security that pays periodic interest.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

A Treasury bond has the following terms:
February 28, 1991 issue date
May 1, 1991 settlement date
August 31, 1991 first interest date
10.0% semiannual coupon
$1,000 par value
30/360 basis

The accrued interest (in the 1900 date system) is:
ACCRINT(33297,33481,33359,0.1,1000,2,0,) = 16.94444

See Also
Help
ACCRINTM Returns the accrued interest for a security that pays interest at maturity.
DATE Returns the serial number of a particular date.
Financial Function Arguments
List of Financial Functions



Financial Function Arguments
Basis An optional value that indicates the type of calendar to use.    If 

Basis is 0 or omitted, the calendar is 30/360; if 1, actual/actual; if 2,
actual/360; if 3, actual/365.

Coupon The security's annual coupon rate.
Dates A schedule of payment dates that corresponds to the cash flow 

payments.    The first payment date indicates the beginning of the 
schedule of payments.    All other dates must be later than this date, 
but they may occur in any order.

Days The number of non-weekend and non-holiday days before or after 
start_date.    A positive value for days yields a future date; a 
negative value yields a past date.

Decimal_dollar A decimal dollar.
Discount The security's discount rate.
Effect_rate The effective interest rate.
End_date A serial date number that represents the end date.
End_period The last period in the calculation.
First_coupon The security's first coupon date, expressed as a serial date number.
First_interest The security's first interest date, expressed as a serial date number.
Fraction The number in the denominator of the fraction.
Fractional_dollar A number expressed as a fraction.
Frequency The number of coupon payments per year.    For annual payments, 

frequency =1; for semiannual, frequency = 2; for quarterly, 
frequency = 4.

Fv Future value, cash balance attained sometime in the future after the
last payment is made.

Guess A number that you guess is close to the result.
Holidays An set of one or more serial date numbers to exclude from the 

working calendar.
Investment The amount invested in the security.
Issue The security's issue date expressed as a serial date number.
Last_coupon The security's last coupon date, expressed as a serial number date.
Maturity The security's maturity date, expressed as a serial date number.
Months The number of months before or after start_date.    A positive value 

for months yields a future date; a negative value yields a past date.
Nominal_rate The nominal interest rate.
Nper Number of periods (payments) in a loan.
Npery The number of compounding periods per year.
Par A security's par value. If omitted, the function uses $1,000.
Per Period for which payment is calculated. 
Pmt The security's payment.
Pr The security's price per $100 face value.
Principal The present value.
Pv Present value, the lump sum value of a series of future payments.
Rate Interest rate for one period.
Redemption The security's redemption value per $100 face value.
Schedule An array of interest rates to apply.



Settlement The security's settlement date, expressed as a serial date number.
Start_date A serial date number that represents the start date.
Start_period The first period in the calculation.    Payment periods are numbered 

beginning with 1.
Type Indicates when payments are due. 0 (zero) means payments are due

at the end of the period; 1 means they are due at the beginning.
Values A series of cash flows that correspond to a schedule of payments in 

dates.    The first payment is options, and corresponds to a cost or 
payment that occurs at the beginning of the investment.    All 
succeeding payments are discounted based on a 365-day year.

Yld The security's annual yield.
See Also

Help
List of Financial Functions



EDATE(start_date,months)
Returns the serial number date that is the indicated number of months before or after 
start_date.    Use EDATE to calculate maturity dates or due dates that fall on the same day 
of the month as the date of issue.
If this function is not available, you must install the Analysis ToolPak add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Examples

In the 1900 date system:
EDATE(DATEVALUE("01/15/91"),1) = 33284 or "02/15/91"
EDATE(DATEVALUE("03/31/91"),-1) = 33297 or "02/28/91"

See Also
Help
EOMONTH Returns the serial number last day of the month before or after a 

specified number of months.
NETWORKDAYS Returns the number of whole workdays between two dates.
NOW Returns the serial number of the current date and time.
WORKDAY Returns the date before or after a specified number of workdays.
List of Date & Time Functions



Worksheet Functions
All Worksheet Functions (alphabetical list)
Financial Functions
Date & Time Functions
Math & Trig Functions
Statistical Functions
Lookup & Reference Functions
Database Functions
Text Functions
Logical Functions
Information Functions
Engineering Functions



All Worksheet Functions (alphabetical list)
ABS()
ACCRINT()
ACCRINTM()
ACOS()
ACOSH()
ADDRESS()
AND()
AREAS()
ASIN()
ASINH()
ATAN()
ATAN2()
ATANH()
AVEDEV()
AVERAGE()
BASE()
BESSELI()
BESSELJ()
BESSELK()
BESSELY()
BETADIST()
BETAINV()
BIN2DEC()
BIN2HEX()
BIN2OCT()
BINOMDIST()
CEILING()
CELL()
CHAR()
CHIDIST()
CHIINV()
CHITEST()
CHOOSE()
CLEAN()
CODE()
COLUMN()
COLUMNS()
COMBIN()
COMPLEX()
CONFIDENCE()
CONVERT()
CORREL()
COS()



COSH()
COUNT()
COUNTA()
COUPDAYBS()
COUPDAYS()
COUPDAYSNC()
COUPNCD()
COUPNUM()
COUPPCD()
COVAR()
CRITBINOM()
CROSSTAB()
CUMIPMT()
CUMPRINC()
DATE()
DATEVALUE()
DAVERAGE()
DAY()
DAYS360()
DB()
DCOUNT()
DCOUNTA()
DDB()
DEC2BIN()
DEC2HEX()
DEC2OCT()
DEGREES()
DELTA()
DEVSQ()
DGET()
DISC()
DMAX()
DMIN()
DOLLAR()
DOLLARDE()
DOLLARFR()
DPRODUCT()
DSTDEV()
DSTDEVP()
DSUM()
DURATION()
DVAR()
DVARP()
EDATE()
EFFECT()



EOMONTH()
ERF()
ERFC()
ERROR.TYPE()
EVEN()
EXACT()
EXP()
EXPONDIST()
FACT()
FACTDOUBLE()
FALSE()
FASTMATCH()
FDIST()
FIND()
FINV()
FISHER()
FISHERINV()
FIXED()
FLOOR()
FORECAST()
FREQUENCY()
FTEST()
FV()
FVSCHEDULE()
GAMMADIST()
GAMMAINV()
GAMMALN()
GCD()
GEOMEAN()
GESTEP()
GROWTH()
HARMEAN()
HEX2BIN()
HEX2DEC()
HEX2OCT()
HLOOKUP()
HOUR()
HYPGEOMDIST()
IF()
IMABS()
IMAGINARY()
IMARGUMENT()
IMCONJUGATE()
IMCOS()
IMDIV()



IMEXP()
IMLN()
IMLOG10()
IMLOG2()
IMPOWER()
IMPRODUCT()
IMREAL()
IMSIN()
IMSQRT()
IMSUB()
IMSUM()
INDEX() 
INDIRECT()
INFO()
INT()
INTERCEPT()
INTRATE()
IPMT()
IRR()
ISBLANK()
ISERR()
ISERROR()
ISEVEN()
ISLOGICAL()
ISNA()
ISNONTEXT()
ISNUMBER()
ISODD()
ISREF()
ISTEXT()
KURT()
LARGE()
LCM()
LEFT()
LEN()
LINEST()
LN()
LOG()
LOG10()
LOGEST()
LOGINV()
LOGNORMDIST()
LOOKUP() 
LOWER()
MATCH()



MAX()
MDETERM()
MDURATION()
MEDIAN()
MID()
MIN()
MINUTE()
MINVERSE()
MIRR()
MMULT()
MOD()
MODE()
MONTH()
MROUND()
MULTINOMIAL()
N()
NA()
NEGBINOMDIST()
NETWORKDAYS()
NOMINAL()
NORMDIST()
NORMINV()
NORMSDIST()
NORMSINV()
NOT()
NOW()
NPER()
NPV()
OCT2BIN()
OCT2DEC()
OCT2HEX()
ODD()
ODDFPRICE()
ODDFYIELD()
ODDLPRICE()
ODDLYIELD()
OFFSET()
OR()
PEARSON()
PERCENTILE()
PERCENTRANK()
PERMUT()
PI()
PMT()
POISSON()



PPMT()
PRICE()
PRICEDISC()
PRICEMAT()
PROB()
PRODUCT()
PROPER()
PV()
QUARTILE ()
QUOTIENT()
RADIANS()
RAND()
RANDBETWEEN()
RANK()
RATE()
RECEIVED()
REPLACE()
REPT()
RIGHT()
ROUND()
ROW()
ROWS()
RSQ()
SEARCH()
SECOND()
SERIESSUM()
SIGN()
SIN()
SINH()
SKEW()
SLN()
SLOPE()
SMALL()
SQRT() 
SQRTPI()
STANDARDIZE()
STDEV()
STDEVP()
STEYX()
SUBSTITUTE()
SUM()
SUMPRODUCT()
SUMSQ()
SUMX2MY2()
SUMX2PY2()



SUMXMY2()
SYD()
T()
TAN()
TANH()
TBILLEQ()
TBILLPRICE()
TBILLYIELD()
TDIST()
TEXT()
TIME()
TIMEVALUE()
TINV()
TODAY()
TRANSPOSE()
TREND()
TRIM()
TRIMMEAN()
TRUE()
TRUNC()
TTEST()
TYPE()
UPPER()
VALUE()
VAR()
VARP()
VDB()
VLOOKUP()
WEEKDAY()
WEIBULL()
WORKDAY()
XIRR()
XNPV()
YEAR()
YEARFRAC()
YIELD()
YIELDDISC()
YIELDMAT()
ZTEST()



Financial Functions
Function Returns
ACCRINT() Accrued interest for a security that pays periodic interest
ACCRINTM() Accrued interest for a security that pays interest at maturity
COUPDAYBS() Number of days from the beginning of the coupon period to the 

settlement date
COUPDAYS() Number of days in the coupon period that contains the settlement date
COUPDAYSNC() Number of days from the settlement date to the next coupon date
COUPNCD() Next coupon date after the settlement date
COUPNUM() Number of coupons payable between the settlement date and maturity

date
COUPPCD() Previous coupon date before the settlement date
CUMIPMT() Cumulative interest paid between start_period and end_period
CUMPRINC() Cumulative principal paid on a loan between start_period and 

end_period
DB() Real depreciation of an asset for a specific period using the fixed-

declining balance method
DDB() Depreciation of an asset using the double-declining balance method
DISC() Discount rate for a security
DOLLARDE() Converts a dollar price, expressed as a fraction, into a dollar price, 

expressed as a decimal number
DOLLARFR() Converts a dollar price, expressed as a decimal number, into a dollar 

price, expressed as a fraction
DURATION() Annual duration for a security with periodic interest payments
EFFECT() Effective annual interest rate
FV() Future value of an investment
FVSCHEDULE() Future value of an initial principal after applying a series of compound 

interest rates
INTRATE() Interest rate for a fully invested security
IPMT() Interest payment for an investment for a given period
IRR() Internal rate of return for a series of cash flows
MDURATION() Macauley modified duration for a security with an assumed par value 

of $100
MIRR() Modified internal rate of return for a list of values
NOMINAL() Annual nominal interest rate
NPER() Number of periods (payments) for an investment
NPV() Net present value of an investment based on a series of periodic cash 

flows and a discount rate
ODDFPRICE() Price per $100 face value of a security with an odd first period
ODDFYIELD() Yield of a security with an odd first period
ODDLPRICE() Price per $100 face value of a security with an odd last coupon period
ODDLYIELD() Yield of a security with an odd last period
PMT() Periodic payment for an annuity
PPMT() Payment on the principal for a given period
PRICE() Price per $100 face value of a security that pays periodic interest
PRICEDISC() Price per $100 face value of a discounted security



PRICEMAT() Price per $100 face value of a security that pays interest at maturity
PV() Present value of an investment
RATE() Interest rate per period of an annuity
RECEIVED() Amount received at maturity for a fully invested security
SLN() Straight-line depreciation for an asset
SYD() Sum-of-years' digits depreciation for an asset
TBILLEQ() Bond-equivalent yield for a treasury bill
TBILLPRICE() Price per $100 face value for a treasury bill
TBILLYIELD() Yield for a treasury bill
VDB() Depreciation of an asset for a specified or partial period using a 

declining balance method
XIRR() Internal rate of return of a schedule of cash flows, amounts, and dates
XNPV() Net present value of a schedule of cash flows
YIELD() Yield on a security that pays periodic interest
YIELDDISC() Annual yield for a discounted security
YIELDMAT() Annual yield of a security that pays interest at maturity

See Also
Help
Financial Function Arguments



Date & Time Functions
Microsoft Excel stores dates as serial numbers.    The Date and Time functions either 
translate a serial number into a recognized unit of time or the reverse.

Function Returns
DAYS360() Number of days between two dates based on a 360-day year
NETWORKDAYS() Number of whole work days between start_date and end_date
YEARFRAC() Year fraction representing the number of whole days between 

start_date and end_date
Function Returns serial number of
DATE() Specified date
DATEVALUE() date_text
EDATE() Date that is the indicated number of months before or after start_date
EOMONTH() Last day of the month before or after a specified number of months
NOW() Current date and time
TIME() Specified time
TIMEVALUE() time_text
TODAY() Current date
WORKDAY() Date    a specified number of workdays before or after start_date
Function Converts serial_number to
DAY() Day of the month
HOUR() Hour of the day
MINUTE() Minute
MONTH() Month
SECOND() Second
WEEKDAY() Day of the week
YEAR() Year



Mathematical & Trigonometric Functions
Function Returns
ABS() Absolute value of number
ACOS() Arccosine of a number
ACOSH() Inverse hyperbolic cosine of number
ASIN() Arcsine of a number
ASINH() Inverse hyperbolic sine of number
ATAN() Arctangent of a number
ATAN2() Arctangent, given the x- and y-coordinates
ATANH() Inverse hyperbolic tangent of number
BASE() Equivalent of a base-10 number in another base
CEILING() Number rounded up to the nearest integer
COMBIN() Number of combinations for a given number of objects
COS() Cosine of an angle
COSH() Hyperbolic cosine of number
EVEN() Rounds a number up to the nearest even integer
EXP() e raised to the power of a given number
FACT() Factorial of number
FACTDOUBLE() Double factorial of a number
FLOOR() Number rounded down toward zero
GCD() Greatest common divisor
INT() Number rounded down to the nearest integer
LCM() Least common multiple
LN() Natural logarithm of a number
LOG() Logarithm of a number to a specified base
LOG10() Base-10 logarithm of a number
MDETERM() Matrix determinant of array
MINVERSE() Matrix inverse of array
MMULT() Matrix product of two arrays
MOD() Remainder of number from division
MROUND() Number rounded to the desired multiple
MULTINOMIAL() Multinomial of a set of numbers
ODD() Number rounded up to the nearest odd integer
PI() Value of pi
PRODUCT() Product of numbers
QUOTIENT() Integer portion of a division
RAND() Random number between 0 and 1
RANDBETWEEN() Random number between two specified numbers
ROUND() Number rounded to a specified number of digits
SERIESSUM() Sum of a power series
SIGN() Sign of number
SIN() Sine of an angle
SINH() Hyperbolic sine of number
SQRT() Positive square root of number



SQRTPI() Square root of number multiplied by pi
SUM() Total of arguments
SUMPRODUCT() Sum of the products of corresponding array components
SUMSQ() Sum of the squares of all the arguments
SUMX2MY2() Sum of the difference of squares of corresponding values in two arrays
SUMX2PY2() Sum of the sum of squares of corresponding values in two arrays
SUMXMY2() Sum of squares of differences of corresponding values in two arrays
TAN() Tangent of an angle
TANH() Hyperbolic tangent of number
TRUNC() Number truncated to an integer



Text Functions
Function Returns
CHAR() ANSI character corresponding to given numeric code
CLEAN() Text without nonprintable characters
CODE() Numeric ANSI code of the first character
DOLLAR() Number    converted to text, in currency format
EXACT() TRUE or FALSE depending on likeness of two text strings
FIND() Position of matching text, case sensitive
FIXED() Formats a number as text with a fixed number of decimals
LEFT() Leftmost characters from a text value
LEN() Number of characters in a text string
LOWER() Text in noncapital letters
MID() Returns a specific number of characters from a text string starting at the 

position you specify
PROPER() Text with the first letter in each word capitalized
REPLACE() Text with selected character positions replaced
REPT() Text repeated specified number of times
RIGHT() Rightmost characters from a text value
SEARCH() Finds one text value within another (not case sensitive)
SUBSTITUTE() Substitutes new text for old text in a text string
T() Argument converted to text
TEXT() Number as a formatted text value
TRIM() Text minus excess spaces
UPPER() Text in capital letters
VALUE() Numeric text as number



Logical Functions
Function Returns
AND() True if every argument is TRUE
FALSE() Logical value FALSE
IF() Returns a specified value depending on the outcome of a test
NOT() Returns True if its argument is FALSE; false if its argument is TRUE
OR() True if any argument is TRUE
TRUE() Logical value TRUE



Lookup & Reference Functions
Function Returns
ADDRESS() A reference as text for a single cell specified by row_num and 

column_num
AREAS() Number of areas in a reference
CHOOSE() Value selected from values using index_num
COLUMN() Column number of a reference
COLUMNS() Number of columns in a reference or array
FASTMATCH() Index of a value selected by lookup_value (sorted arrays only)
HLOOKUP() Looks in the top row of an array and returns the value of the indicated 

cell
INDEX() Uses an index to choose a value from a reference or array
INDIRECT() The contents of a reference in the form of text
LOOKUP() Looks up values in a vector or array
MATCH() Index of a value selected by lookup_value
OFFSET() Reference offset by a specified number of rows and columns
ROW() An array of row numbers from a reference
ROWS() Number of rows in a reference or array
TRANSPOSE() Transpose of array
VLOOKUP() Looks in the first column of an array and moves across the row to 

return the value of a cell



Database Functions
Function Returns
CROSSTAB() Structure and content of a cross-tabulation table
DAVERAGE() Average of numbers
DCOUNT() Count of numbers
DCOUNTA() Count of nonblank cells
DGET() Single record that matches the specified criteria
DMAX() Largest of numbers
DMIN() Smallest of numbers
DPRODUCT() Product of numbers
DSTDEV() Estimated standard deviation of a population based on a sample
DSTDEVP() Standard deviation of a population based on the entire population
DSUM() Sum of numbers
DVAR() Estimated variance of a population based on a sample
DVARP() Variance of a population based on the entire population

See Also
Help
Database Function Arguments 
AVERAGE
COUNT
COUNTA
MAX
MIN
STDEV
STDEVP
SUM
VAR
VARP



Statistical Functions
Function Returns
AVEDEV() Average of absolute deviations of data points from their mean
AVERAGE() Average of arguments
BETADIST() Cumulative beta probability density function
BETAINV() Inverse of the cumulative beta probability density function
BINOMDIST() Individual term binomial distribution
CHIDIST() One-tailed probability of the chi-squared (c2) distribution
CHIINV() Inverse of the chi-squared (c2) distribution
CHITEST() Test for independence
CONFIDENCE() Confidence interval for a population
CORREL() Correlation coefficient between two data sets
COUNT() Tally of the arguments that are numbers
COUNTA() Tally of the nonblank values in the list of arguments
COVAR() Covariance, the average of the products of paired deviations
CRITBINOM() Smallest value for which the cumulative binomial distribution is less 

than or equal to a criterion value
DEVSQ() Sum of squares of deviations
EXPONDIST() Exponential distribution
FDIST() F probability distribution
FINV() Inverse of the F probability distribution
FISHER() Fisher transformation
FISHERINV() Inverse of the Fisher transformation
FORECAST() Returns values along a linear trend
FREQUENCY() Frequency distribution as a vertical array
FTEST() Result of an F-test
GAMMADIST() Gamma distribution
GAMMAINV() Inverse of the gamma cumulative distribution
GAMMALN() Natural logarithm of the gamma function, G(x)
GEOMEAN() Geometric mean
GROWTH() Values along an exponential trend
HARMEAN() Harmonic mean
HYPGEOMDIST() Hypergeometric distribution
INTERCEPT() Intercept of the linear regression line
KURT() Kurtosis of a data set
LARGE() k-th largest value in a data set
LINEST() Parameters of a linear trend
LOGEST() Parameters of an exponential trend
LOGINV() Inverse of the lognormal distribution
LOGNORMDIST() Lognormal distribution
MAX() Maximum value in a data set
MEDIAN() Middle value in a data set
MIN() Minimum value in a data set
MODE() Most common value in a data set



NEGBINOMDIST() Negative binomial distribution
NORMDIST() Normal cumulative distribution
NORMINV() Inverse of the normal cumulative distribution
NORMSDIST() Standard normal cumulative distribution
NORMSINV() Inverse of the standard normal cumulative distribution
PEARSON() Pearson product moment correlation coefficient
PERCENTILE() Value from a range at the k-th percentile
PERCENTRANK() Percentage rank of x among the values in a data set
PERMUT() Number of permutations for a given number objects
POISSON() Poisson probability distribution
PROB() Probability that values in a range are between two limits
QUARTILE () Quartile from a data set
RANK() The rank of a number in a list of numbers
RSQ() r2 value of the linear regression line
SKEW() Skewness of a distribution
SLOPE() Slope of the linear regression line
SMALL() k-th smallest value in a data set
STANDARDIZE() Normalized value
STDEV() Estimate of standard deviation based on a sample
STDEVP() Standard deviation for a population based on the entire population
STEYX() Standard error of the predicted y value for each x in the regression
TDIST() Student's t-distribution
TINV() Inverse of the Student's t-distribution
TREND() Values along a linear trend
TRIMMEAN() Mean of the interior of a data set
TTEST() Probability associated with a Student's t-test
VAR() Estimates variance based on a sample
VARP() Calculates variance based on the entire population
WEIBULL() Weibull distribution 
ZTEST() Two-tailed P-value of a z-test



Information Functions
Function Returns
CELL() Information about formatting, location, or contents of a cell
INFO() Information about the current operating system
Function TRUE if value is
ISBLANK() Blank
ISERR() Any error value except #N/A
ISERROR() Any error value
ISEVEN() Even
ISLOGICAL() Logical value
ISNA() Error value #N/A
ISNONTEXT() Not text
ISNUMBER() Number
ISODD() Odd
ISREF() Reference
ISTEXT() Text
Function Returns
ERROR.TYPE() A number corresponding to an error type
N() Argument converted to a number
NA() The error value #N/A
TYPE() A number indicating the data type of a value



Engineering Functions
Function Result
BESSELI() Modified Bessel function In(x)
BESSELJ() Bessel function Jn(x)
BESSELK() Modified Bessel function Kn(x)
BESSELY() Bessel function Yn(x)
BIN2DEC() Converts a binary number to decimal
BIN2HEX() Converts a binary number to hexadecimal
BIN2OCT() Converts a binary number to octal
COMPLEX() Converts real and imaginary coefficients into a complex number
CONVERT() Converts a number from one measurement system to another
DEC2BIN() Converts a decimal number to binary
DEC2HEX() Converts a decimal number to hexadecimal
DEC2OCT() Converts a decimal number to octal
DEGREES() Converts radians into degrees
DELTA() Tests whether two numbers are equal
ERF() Error function
ERFC() Complementary error function
GESTEP() Tests whether a number is greater than a threshold value
HEX2BIN() Converts a hexadecimal number to binary
HEX2DEC() Converts a hexadecimal number to decimal
HEX2OCT() Converts a hexadecimal number to octal
IMABS() Absolute value (modulus) of a complex number
IMAGINARY() Imaginary coefficient of a complex number
IMARGUMENT() The angle theta, expressed in radians
IMCONJUGATE() Complex conjugate of a complex number
IMCOS() Cosine of a complex number
IMDIV() Quotient of two complex numbers
IMEXP() Exponential of a complex number
IMLN() Natural logarithm of a complex number
IMLOG2() Base-2 logarithm of a complex number
IMLOG10() Common logarithm (base 10) of a complex number
IMPOWER() Complex number raised to an integer power
IMPRODUCT() Product of two complex numbers
IMREAL() Real coefficient of a complex number
IMSIN() Sine of a complex number
IMSQRT() Square root of a complex number
IMSUB() Difference of two complex numbers
IMSUM() Sum of complex numbers
OCT2BIN() Converts an octal number to binary
OCT2DEC() Converts an octal number to decimal
OCT2HEX() Converts an octal number to hexidecimal
RADIANS() Converts degrees into radians



AREAS(reference)
Returns the number of areas in reference.    An area is a single cell or a range of cells.    
Reference can be a reference to multiple areas.
Example

AREAS(B2:D4) = 1
If the name "Prices" refers to the areas B1:D4, B2, and E1:E10, then AREAS(Prices) = 3.

See Also
Help
ADDRESS Returns a reference as text to a single cell in a worksheet.
CELL Returns information about the formatting, location, or contents of a cell.
COLUMN Returns the column number of a reference.
COLUMNS Returns the number of columns in a reference.
INDEX Reference in reference or value in array selected by index values.
ROW Returns the row number of a reference.
ROWS Returns the number of rows in a reference.
List of Lookup & Reference Functions



CELL(info_type,reference)
Returns information about the formatting, location, or contents of the upper-left cell in 
reference.

If reference is omitted, the active cell is used.
If reference is a nonadjacent selection, returns the error value #VALUE!.
Info_type specifies the kind of cell information you want.

Info_type Result
"address" Reference of the first cell in reference, as text.
"col" Column number of cell in reference.
"color" 0 (zero) if the cell font is not formatted for color for negative values; 1 if it 

is.
"contents" Contents of the upper-left cell in reference.
"filename" The name of the file that contains the cell, including full path.    Returns 

empty text ("") if the worksheet that contains reference has not yet been 
saved to a file.

"format" Text value corresponding to format of the cell.    In addition, returns "-" if 
the cell is formatted for color for negative values and "()" if the cell is 
formatted for parentheses for negative values.

"parentheses" 0 (zero) if the cell is not formatted for parentheses for positive values; 1 if 
it is.

"prefix" Symbol corresponding to the alignment of the cell:
' Left-aligned text
" Right-aligned text
^ Centered text
\ Fill-aligned text
"" All other values

"protect" 0 (zero) if the cell is not locked; 1 if the cell is locked.
"row" Row number of cell in reference.
"type" Text corresponding to the type of data in the cell:

b Blank
l Label(text constant)
v Value(anything else)

"width" Column width of cell.    (Units for column width are the width of one 
character in the currently selected font.)

Examples
CELL("row",A20) = 20
If B12 has format "d-mmm", CELL("format",B12) = "D2"

See Also
Help
COLUMN Returns the column number of a reference.
ROW Returns the row number of a reference.
List of Information Functions



COLUMN(reference)
Returns the column number of reference.

If reference is a range of cells and it is entered as an array formula, COLUMN returns
the column numbers of reference as a horizontal array.

Reference cannot be a reference to multiple areas.
If reference is omitted, COLUMN refers to its own cell.

Examples
COLUMN(A3) = 1
COLUMN(A3:C5) = {1,2,3}

See Also
Help
COLUMNS Returns the number of columns in a reference.
ROW Returns the row numbers in a reference.
ROWS Returns the number of rows in a reference.
List of Lookup & Reference Functions



COLUMNS(array)
Returns the number of columns in array.
Examples

COLUMNS(A1:C4) = 3
COLUMNS({1,2,3;4,5,6}) = 3

See Also
Help
COLUMN Returns the column numbers in a reference.
ROW Returns the row numbers in a reference.
ROWS Returns the number of rows in a reference.
List of Lookup & Reference Functions



INDIRECT(ref_text,a1)
Returns the contents of a cell or reference specified by ref_text.

Ref_text must indicate a cell containing an A1 reference, an R1C1 reference, or a 
name assigned to a cell.    If the cell indicated by ref_text is not a valid cell reference, it 
returns error value #REF!.

A1 is optional, but must be a logical value when included.    If you enter FALSE, 
INDIRECT interprets the contents of the ref_text cell as the R1C1 reference style.    If a1 is 
TRUE or omitted, INDIRECT interprets the contents of the ref_text cell as the A1 reference 
style.

The a1 argument refers to the style of the cell referenced by ref_text and not by the
style of ref_text itself.
Examples

If cell B2 contains the value 1.33 and cell A1 contains the text B2, INDIRECT(A1) = 1.33
If cell B2 contains "Jones" and A1 contains R2C2, INDIRECT(A1,FALSE) = "Jones".
If the name Customer refers to a cell containing the text "Jones", INDIRECT("Customer") =
"Jones".

See Also
Help
CELL Returns information about formatting, location, or contents of a cell.
TYPE Returns a number indicating the data type of a value.
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INFO(type_text)
Returns information about the current operating environment.    Type_text is text specifying
what type of information you want returned.

Type_text Returns
"directory" The path of the current directory.
"memavail" The amount of memory available, in bytes.
"memused" Amount of memory being used for data
"numfile" The number of active worksheets.
"origin" Absolute A1-style reference, as text, prepended with "$A:" for Lotus 1-2-3 

release 3.x compatibility.
"osversion" The current operating system version, as text.
"recalc" The current recalculation mode; returns "Automatic" or "Manual".
"release" The version of Microsoft Excel, as text.
"system" The name of the operating system, for example:

Windows = "pcdos"
"totmem" Total memory available, including that already in use, in bytes.

Example
If two worksheets are currently open:
INFO("numfile") = 2

See Also
Help
CELL Returns information about formatting, location, or contents of a cell.
List of Information Functions



N(value)
If value is a number, returns that number; if value is a date, returns the serial number of 
that date; if value is TRUE, returns 1; otherwise, returns zero.    Provided for compatibility 
with other worksheet programs.
Example

For an example of this function, see N in the Microsoft Excel Function Reference.
See Also

Help
CELL Returns information about the formatting, location, or contents of a cell.
T Converts its argument into text.
List of Information Functions



NA()
Returns #N/A, which indicates "No value is available."    Provided for compatibility with other
worksheet programs.    You can also enter #N/A directly into a cell.

You must include empty parentheses with NA, otherwise Microsoft Excel will not 
recognize it as a function.

Used primarily for marking blank cells.    By entering #N/A or =NA() in cells where you
are missing information, you can avoid the problem of unintentionally including blank cells in
your calculations.

If you use a formula with calculations involving a cell containing the value #N/A, the 
formula returns the value #N/A.

#N/A values are skipped in line charts without breaking the line.
See Also

Help
List of Information Functions



OFFSET(reference,rows,cols,height,width)
Returns a reference of a specified height and width, offset from reference by a specified 
number of rows and cols.

Reference is the cell reference from which you want to base the offset.
Rows is the number of rows, up or down, to which you want the upper-left cell in the 

result to refer.
Cols is the number of columns, to the left or right, to which you want the upper-left 

cell of the result to refer.
If rows and cols offset the reference over the edge of the worksheet, returns the 

#REF! error value.
Rows and cols can be positive or negative numbers.
Height is the height, in number of rows, that you want the returned reference to be.
Width is the width, in number of columns, that you want the returned reference to 

be.
If height or width is omitted, assumed to be same height and width as reference.

Examples
OFFSET(C3,2,3,1,1) = F5
OFFSET(C3:E5,-1,0,3,3) =C2:E4

See Also
Help
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ROW(reference)
Returns the row number of reference, if reference is the reference of a single cell.    If 
reference includes more than one row and if ROW is entered as an array, ROW returns the 
row numbers as a vertical array.

If reference is omitted, it is assumed to be the reference of the cells in which the 
ROW function appears.

Reference cannot be a reference to multiple areas.
Examples

ROW(A3) =3
ROW(A3:B5) ={3;4;5}

See Also
Help
COLUMN Returns column number or array of column numbers in a reference.
COLUMNS Returns number of columns in an array.
ROWS Returns the number of rows in a reference.
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ROWS(array)
Returns the number of rows in array.
Examples

ROWS(A1:C4) =4
ROWS({1,2,3;4,5,6}) =2

See Also
Help
COLUMN Returns column number or array of column numbers in a reference.
COLUMNS Returns number of columns in an array.
ROW Returns row number or array of row numbers in a reference.
List of Lookup & Reference Functions



T(value)
Returns the text referred to by value.    If value does not refer to text, T returns "" (empty 
text).
It is not necessary to use the T function in a formula since Microsoft Excel automatically 
converts values as necessary.    This function is provided for compatibility with other 
worksheet programs.
Example

For an example of this function, see T in the Microsoft Excel Function Reference.
See Also

Help
CELL Returns information about the formatting, location, or contents of a cell.
N Converts its arguments to a number.
VALUE Converts a text argument to a number.
List of Information Functions
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TYPE(value)
Returns a number indicating the type of value.

If value is Returns
A number 1
Text 2
A logical value 4
An error value 16
An array 64

Examples
TYPE({1,2;3,4}) = 64
If A1 contains the text "Smith", then:

TYPE(A1) = TYPE("Smith") = 2
TYPE("Mr."&A1) = 2
TYPE(2+A1) = TYPE(#VALUE!) = 16

See Also
Help
List of Information Functions



ADDRESS(row_num,column_num,abs_num,a1,sheet_text)
Returns a reference as text for a single cell specified by row_num and column_num.

Abs_num specifies the type of cell reference to return, according to the following:
1 Absolute reference (default)
2 Absolute row, relative column
3 Relative row, absolute column
4 Relative reference

If a1 is true or omitted, references are given in A1 reference style.
If a1 is false, references are given in R1C1 reference style.
Sheet_text specifies the name of the worksheet or macro to be used as an external 

reference.    If omitted, no sheet name is used.
Examples

ADDRESS(2,3) = $C$2
ADDRESS(2,3,2) = $C$2
ADDRESS(13,5,4,TRUE) = E13
ADDRESS(13,5,4,FALSE,"Sheet1.XLS") = Sheet1!R[13]C[5]

See Also
Help
CELL Returns information about the formatting, location, or contents of a cell.
COLUMN Returns the column number of a reference.
OFFSET Returns a reference offset from a given reference.
ROW Returns the row number of a reference.
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ISBLANK(value)
Returns TRUE if value refers to an empty cell; otherwise returns FALSE.
Example

For an example of this function, see ISBLANK in the Microsoft Excel Function Reference.

See Also
Help
CELL Returns information about the formatting, location, or contents of a cell.
TYPE Returns a number indicating the data type of a value.
List of Information Functions



ISERR(value)
Returns TRUE if value is any error value except #N/A; otherwise returns FALSE.
Example

For an example of this function, see ISERR in the Microsoft Excel Function Reference.

See Also
Help
CELL Returns information about the formatting, location, or contents of a cell.
ISERROR Returns TRUE, if value is any error value.
ISNA Returns TRUE, if value is #N/A.
TYPE Returns a number indicating the data type of a value.
List of Information Functions



ISERROR(value)
Returns TRUE if value is any error value: #N/A, #VALUE!, #REF!, #DIV/0!, #NUM!, #NAME?,
or #NULL!; otherwise returns FALSE.
Example

For an example of this function, see ISERROR in the Microsoft Excel Function Reference.

See Also
Help
CELL Returns information about the formatting, location, or contents of a cell.
ISERR Returns TRUE, if value is any error value except #N/A.
ISNA Returns TRUE, if value is #N/A.
TYPE Returns a number indicating the data type of a value.
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ISLOGICAL(value)
Returns TRUE if value is a logical value; otherwise returns FALSE.
See Also

Help
CELL Returns information about the formatting, location, or contents of a cell.
TYPE Returns a number indicating the data type of a value.
List of Information Functions



ISNA(value)
Returns TRUE if value is the error value #NA (no value available); otherwise returns FALSE.
Example

For an example of this function, see ISNA in the Microsoft Excel Function Reference.

See Also
Help
CELL Returns information about the formatting, location, or contents of a cell.
ISERROR Returns TRUE, if value is any error value.
ISERR Returns TRUE, if value is any error value except #N/A.
TYPE Returns a number indicating the data type of a value.
List of Information Functions



ISNONTEXT(value)
Returns TRUE if value is not text; otherwise returns FALSE.
See Also

Help
CELL Returns information about the formatting, location, or contents of a cell.
TYPE Returns a number indicating the data type of a value.
List of Information Functions



ISNUMBER(value)
Returns TRUE if value is a number; otherwise returns FALSE.
Example

For an example of this function, see ISNUMBER in the Microsoft Excel Function Reference.

See Also
Help
CELL Returns information about the formatting, location, or contents of a cell.
TYPE Returns a number indicating the data type of a value.
List of Information Functions



ISREF(value)
Returns TRUE if value is a reference; otherwise returns FALSE.
Example

For an example of this function, see ISREF in the Microsoft Excel Function Reference.

See Also
Help
CELL Returns information about the formatting, location, or contents of a cell.
TYPE Returns a number indicating the data type of a value.
List of Information Functions



ISTEXT(value)
Returns TRUE if value is text; otherwise returns FALSE.
Example

For an example of this function, see ISTEXT in the Microsoft Excel Function Reference.

See Also
Help
CELL Returns information about the formatting, location, or contents of a cell.
TYPE Returns a number indicating the data type of a value.
List of Information Functions



AND(logical1,logical2,...)
Returns the logical value TRUE if all arguments are true.    If any argument is false, returns 
FALSE.

Can have 1 to 30 arguments.
Arguments should be either logical values, or arrays or references that contain logical

values.
Ignores any values other than logical values in arrays and references.
If there are no logical values in the range specified, returns the error value #VALUE!.

Examples
AND(TRUE,TRUE) = TRUE
AND(FALSE,TRUE) = FALSE
AND(2+2=4,2+3=5) = TRUE
If B1:B3 contains the values TRUE, FALSE, and TRUE, then AND(B1:B3) = FALSE.

See Also
Help
NOT Reverses the logic of its argument.
OR Returns TRUE if any argument is TRUE.
List of Logical Functions



FALSE()
Returns the logical value FALSE.

Usually used as an argument within another formula.
You can also generate the value FALSE by typing it as a constant with no 

parentheses.
Example

FALSE() = FALSE
See Also

Help
IF Returns specified value depending on outcome of a test.
TRUE Returns the logical value TRUE.
List of Logical Functions



IF(logical_test,value_if_true,value_if_false)
Returns value_if_true if logical_test is TRUE.    Returns value_if_false if logical_test is 
FALSE.    Use IF to make conditional tests of cell values and formulas.

If omitted, value_if_false is assumed to be FALSE.
The outcome of the logical_test determines the value given by the IF function.
The value_if_true and value_if_false arguments can be any value.
Up to seven IF functions can be nested as value_if_true and value_if_false 

arguments to construct more elaborate tests.
Examples

IF(TRUE,1,2) = 1
IF(FALSE,1,2) = 2

See Also
Help
AND Returns TRUE, if all arguments are true.
NOT Reverses the logic of its argument.
OR Returns TRUE, if at least one argument is TRUE.
List of Logical Functions



TRUE()
Returns the logical value TRUE.    Usually used as an argument within another formula.
You can also generate the value TRUE by typing it as a constant without parentheses.
Example

TRUE() = TRUE
See Also

Help
FALSE Returns the logical value FALSE.
IF Returns a specified value depending on the outcome of a test.
List of Logical Functions



NOT(logical)
Changes the value of logical.

If logical is FALSE, returns TRUE.
If logical is TRUE, returns FALSE.

Examples
NOT(FALSE) =TRUE
NOT(1+1=2) =FALSE

See Also
Help
AND Is TRUE if all its arguments are true.
OR Is TRUE if one or more arguments are true.
List of Logical Functions



OR(logical1,logical2,...)
Returns logical value TRUE if any argument is true.    Returns FALSE if all arguments are 
false.

Can have from 1 to 30 arguments.
Arguments should be logical values, or arrays or references that contain logical 

values.
Ignores text, numbers, and empty cells in arrays and references.
If there are no logical values in the range specified, returns the error value #VALUE!.

Examples
OR(TRUE) =TRUE
OR(1+1=1,2+2=5) =FALSE
If A1:A3 contains the values TRUE, FALSE, and TRUE, then:
OR(A1:A3) =TRUE

See Also
Help
AND Returns TRUE if all arguments are true.
NOT Reverses the logic of its argument.
List of Logical Functions



CHOOSE(index_num,value1,value2,...)
Uses index_num to select a value from the list of value arguments.

Index_num is a number indicating the placement of a value in the list of arguments.
If 1, returns value1; if 2, returns value2; and so on.
If less than 1 or greater than the number of the last value in the list, returns the 

#VALUE! error value.
Value1,value2,... are 1 to 29 value arguments from which CHOOSE selects.

Can be numbers, cell references, or text.
Must be a list, not a range.    To choose from a range, use INDEX.

Examples
CHOOSE(2,"apple","orange","banana") = "orange"
CHOOSE(1,3.5,14.2,2.5) = 3.5
CHOOSE(-2,4,6,7) = #VALUE!
If cell D5 contains the value 3, CHOOSE(D5,"xx","yy","zz") equals "zz"
SUM(A1:CHOOSE(3,A10,A20,A30)) equals the sum of the range A1:A30

See Also
Help
INDEX Uses an index to choose a value from a reference or array.
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HLOOKUP(lookup_value,table_array,row_index_num)
Looks in table_array for a column whose first row contains lookup_value and then moves 
down the column according to row_index_num and returns the value of the cell.
The values in the first row of table_array can be text, numbers, or logical values.    They 
must be placed in ascending order:    0, 1, 2, ...; A-Z; FALSE, TRUE.

A row_index_num of 1 returns the first row value in the table_array, a 
row_index_num of 2 returns the second row value, and so on.

Returns error value #REF! if row_index_num is greater than the number of rows in 
table_array and #VALUE! if row_index_num is less than 1.

If HLOOKUP can't find lookup_value, it uses the largest value that is less than 
lookup_value.

Returns error value #N/A if lookup_value is smaller than smallest value in first row 
of array.
Example

For an example of this function, see HLOOKUP in the Microsoft Excel Function Reference.
See Also

Help
INDEX Uses an index to choose a value from a reference or array.
LOOKUP Looks up values in a vector or array.
MATCH Returns the relative position of an element in an array that matches a 

specified value.
VLOOKUP Looks in the first column of an array and moves across the row to return 

the value of a cell.
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INDEX()
There are two forms of the INDEX() function: reference and array.    The reference form 
always returns a reference; the array form always returns a value or an array of values.

INDEX(reference,row_num,column_num,area_num) returns a reference to a 
specified cell or cells within reference.

INDEX(array,row_num,column_num) returns the value of a specified cell or array of 
cells within array.
See Also

Help
INDEX (array)
INDEX (reference)



INDEX(array,row_num,column_num)
Returns the value of a specified cell within array or a specified array of values from within 
array.
Formulas that give arrays must be entered as array formulas.

Array is a range of cells entered as an array.
Row_num and column_num select the row number and column number of the 

desired cell within array.    Row 1 is the first row in the array; column 1 is the first column in 
the array.

If row_num is 0, returns array of values for entire row.
If column_num is 0, returns array of values for entire column.
For a single row array, use INDEX(array,column_num).
For a single column array, use INDEX(array,row_num).
If row and column point to a cell outside array, returns error value #REF!.

You can enter a formula by:
Pressing CONTROL+SHIFT+ENTER
Pressing CONTROL+SHIFT and clicking the enter box in the formula bar

Example
INDEX(A1:A5,3) = the value in A3

See Also
Help
HLOOKUP Looks in the top row of an array and returns the value of the indicated 

cell.
INDEX(reference) Returns a reference to a cell or range of cells within a reference.
LOOKUP Looks up values in a vector or array.
MATCH Returns the relative position of an element in an array that matches a 

specified value.
VLOOKUP Looks in the first column of an array and moves across the row to 

return the value of a cell.
List of Lookup & Reference Functions



INDEX(reference,row_num,column_num,area_num)
Returns a reference to a cell or range of cells within reference.

Reference is a reference to one or more cell ranges.    May be a complex reference 
to more than one nonadjacent range; for example, A1:B4,D1:E4,G1:H4.

If reference includes more than one rectangular area, area_num specifies which of 
those rectangles or ranges contains the desired result.    For example, for the reference 
A1:B4,D1:E4,G1:H4, area 1 is A1:B4, area 2 is D1:E4, and area 3 is G1:H4.

If you are entering a multiple selection for reference, enclose it in parentheses.
If area_num is omitted, uses area 1.
Row_num and column_num indicate the row number and column number of the 

desired cell within the specified range.    Row 1 is the first row in the range; column 1 is the 
first column in the range.

If row_num is 0 or omitted, returns reference for entire row.
If column_num is 0 or omitted, returns reference for entire column.
If row_num, column_num, or area_num point to a cell outside reference, returns 

error value #REF!.
Example

INDEX(A1:A5,3) = the value in A3
See Also

Help
HLOOKUP Looks in the top row of an array and returns the value of the indicated cell.
INDEX(array) Returns value of a cell or array of cells within array.
LOOKUP Looks up values in a vector or array.
MATCH Returns the relative position of an element in an array that matches a 

specified value.
OFFSET Returns a reference offset by a specified number of rows and columns.
VLOOKUP Looks in the first column of an array and moves across the row to return 

the value of a cell.
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LOOKUP()
Has two forms, vector and array.

LOOKUP(lookup_value, lookup_vector, result_vector)    A vector is an array that 
contains only one row or one column.    Looks in lookup_vector for lookup_value, moves to
the corresponding position in result_vector, and then returns this value.

LOOKUP(lookup_value,array)    This form is provided for compatibility with other 
worksheet programs.    Looks in the first row or column of array for lookup_value, moves 
down or across to the last cell and returns the value of the cell.
See Also

Help
LOOKUP (array)
LOOKUP (vector)



LOOKUP(lookup_value,lookup_vector,result_vector)
A vector is an array that contains only one row or one column.    LOOKUP looks in 
lookup_vector for lookup_value and then moves to the corresponding position in 
result_vector and returns this value.

If LOOKUP can't find lookup_value, it uses the largest value less than or equal to 
lookup_value.

If lookup_value is smaller than the smallest value in lookup_vector, LOOKUP 
returns the error value #N/A.

Values in lookup_vector can be text, numbers, or equal to logical values; these 
values must be placed in ascending order: ...-1, 0, 1,..., A-Z, FALSE, TRUE.

Uppercase and lowercase text are equivalent.
Example

For an example of this function, see LOOKUP in the Microsoft Excel Function Reference.
See Also

Help
HLOOKUP Looks in the top row of an array and returns the value of the indicated cell.
MATCH Returns the relative position of an element in an array that matches a 

specified value.
VLOOKUP Looks in the first column of an array and moves across the row to return 

the value of a cell.
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LOOKUP(lookup_value,array)
Provided for compatibility with other worksheet programs.    Looks in the first row or column 
of array for lookup_value, moves down or across to the last cell, and returns the value of 
the cell.

If array is square, or an area with more columns than rows, LOOKUP searches for 
lookup_value in the first row; if array has more rows than columns, LOOKUP searches in 
the first column.

If LOOKUP can't find the lookup_value, it uses the largest value less than or equal to
lookup_value.

If lookup_value is smaller than the smallest value in the first row or column 
(depending on the array dimensions), LOOKUP returns the error value #N/A.

The LOOKUP search range (first row or column) must contain text, numbers, or logical
values in ascending order: ...-1,0,1,..., A-Z, FALSE, TRUE.
Examples

LOOKUP("C",{"a","b","c","d";1,2,3,4}) = 3
LOOKUP("bump",{"a",1;"b",2;"c",3}) = 2

See Also
Help
HLOOKUP Looks in the top row of an array and returns the value of the indicated cell.
INDEX Uses an index to choose a value from a reference or array.
MATCH Returns the relative position of an element in an array that matches a 

specified value.
VLOOKUP Looks in the first column of an array and moves across the row to return 

the value of a cell.
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MATCH(lookup_value,lookup_array,match_type)
Returns the relative position of the element in lookup_array that matches the 
lookup_value, according to the match_type.    The three types of matching you can 
choose are listed in following table.

Match_type MATCH
1 or omitted Finds the largest value less than or equal to lookup_value; lookup_array

must be in ascending order:    ...-1, 0, 1..., A-Z, FALSE, TRUE.
-1 Finds the smallest value greater than or equal to lookup_value; 

lookup_array must be in descending order:    TRUE, FALSE, Z-A, ...1, 0, -
1....

0 Finds the first value equal to lookup_value; lookup_array can be in any 
order.

If match_type is omitted, it is assumed to be 1. 
 If no match is found, MATCH returns error value #N/A.    
Uppercase and lowercase letters are equivalent.
If match_type is 0 and lookup_value is text, lookup_value can contain the 

wildcards    *    and    ?.    MATCH will look for text with any single character in the    ?    position 
and any string of characters in the    *    position.

MATCH returns the position of the matched value, not the value itself.
Example

For an example of this function, see MATCH in the Microsoft Excel Function Reference.
See Also

Help
HLOOKUP Looks in the top row of an array and returns the value of the indicated cell.
INDEX Uses an index to choose a value from a reference or array.
LOOKUP Looks up values in a vector or array.
VLOOKUP Looks in the first column of an array and moves across the row to return 

the value of a cell.
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VLOOKUP(lookup_value,table_array,col_index_num)
Looks in table_array for a row whose first column contains lookup_value, and then moves
across the row according to col_index_num and returns the value of the cell.    A 
col_index_num of 1 returns the first column value in table_array, a col_index_num of 2 
returns the second column value in table_array, and so on.

Values in the first column of table_array can be text, numbers, or logical values.
Values must be placed in ascending order:    ...-2, -1, 0, 1, 2,..., A-Z, FALSE, TRUE.
Uppercase and lowercase text are equivalent.

If VLOOKUP can't find lookup_value, it uses the largest value that is less than or 
equal to lookup_value.    If lookup_value is smaller than the smallest value in the first 
column of table_array, VLOOKUP returns the error value #N/A.

Returns the error value #VALUE! if col_index_num is less than 1.
Returns the error value #REF! if col_index_num is greater than the number of 

columns in table_array.
Example

For an example of this function, see VLOOKUP in the Microsoft Excel Function Reference.
See Also

Help
HLOOKUP Looks in the top row of an array and returns the value of the indicated cell.
INDEX Uses an index to choose a value from a reference or array.
LOOKUP Looks up values in a vector or array.
MATCH Returns the relative position of an element in an array that matches a 

specified value.
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FASTMATCH(lookup_value,lookup_array,type_of_match)
Returns the relative position of the element in lookup_array that matches the 
lookup_value, according to the type_of_match.    If this function is not available, you must
install the Add-in Functions add-in macro.    For more information, see "Managing Add-in 
Commands and Functions" in Chapter 4 in Book 2 of the Microsoft Excel User's Guide.    The 
two types of matching you can choose are listed in following table.

Type_of_match FASTMATCH
1 or omitted Finds the largest value less than or equal to lookup_value; lookup_array

must be in ascending order:    ...-1, 0, 1..., A-Z, FALSE, TRUE.
-1 Finds the smallest value greater than or equal to lookup_value; 

lookup_array must be in descending order:    TRUE, FALSE, Z-A, ...1, 0, -
1....

If type_of_match is omitted, assumed to be 1. 
If no match is found, FASTMATCH returns error value #N/A.    
Uppercase and lowercase letters are equivalent.
FASTMATCH returns the position of the matched value, not the value itself.
Unlike MATCH, FASTMATCH requires the values in lookup_array to be in sorted order. 

Use FASTMATCH instead of MATCH when you need to search large sorted arrays.
Example

For an example of how to use FASTMATCH, see MATCH in the Microsoft Excel Function 
Reference.

See Also
Help
HLOOKUP Looks in the top row of an array and returns the value of the indicated cell.
INDEX Uses an index to choose a value from a reference or an array.
LOOKUP Looks up values in a vector or array.
MATCH Index of    a value selected by lookup_value.
VLOOKUP Looks in the first column of an array and moves across the row to return 

the value of a cell.
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FACT(number)
Returns the factorial of number.

The factorial of a number is the product of all positive integers from 1 to number.
If number is not an integer, FACT truncates it.
If number is negative, returns the error value #NUM!.

Examples
FACT(5) = 5*4*3*2*1, and returns 120
FACT(3.9) = FACT(3), and returns 6
FACT(1) = 1
FACT(0) = 1
FACT(-1) = #NUM!

See Also
Help
PRODUCT Returns the product of its arguments.
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MOD(number,divisor)
Returns the remainder (modulus) after number is divided by divisor.

Result has same sign as divisor.
If divisor is 0, returns the error value #DIV/0!.
MOD(n,d) is equivalent to n - d*INT(n/d).

Examples
MOD(3,2) = 1
MOD(-3,2) = 1
MOD(3,-2) = -1
MOD(-3,-2) = -1

See Also
Help
INT Returns number rounded down to nearest integer.
ROUND Returns number rounded to specified number of digits.
TRUNC Rounds a number down to an integer or to specified decimal place.
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PI()
Returns the number 3.14159..., the mathematical constant pi, accurate to 15 decimal 
places.
You must include empty parentheses with PI(); otherwise Microsoft Excel will not recognize it
as a function.
Examples

PI()/2 =1.57079
SIN(PI()/2) =1

See Also
Help
COS Returns the cosine of a number.
SIN Returns the sine of a number.
TAN Returns the tangent of a number.
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PRODUCT(number1,number2,...)
Returns the product of all the numbers given as arguments.      Can have from 1 to 30 
arguments.    All text, logical, or blank arguments are ignored.

Arguments that are numbers, logical values, or text representations of numbers are 
counted.

Errors result from arguments that are error values or text that cannot be converted to
numbers.

If an argument is an array or reference, only numbers are counted.
Example

For an example of this function, see PRODUCT in the Microsoft Excel Function Reference.
See Also

Help
FACT Returns the factorial of a number.
SUM Adds its arguments.
SUMPRODUCT Returns sum of the products of corresponding array elements.
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SIGN(number)
Returns a value representing the sign of number.

If number is Returns
Positive 1
Zero 0
Negative -1

Examples
SIGN(10) = 1
SIGN(4-4) = 0
SIGN(-0.00001) = -1
If cell B5 contains the number 20.9,    SIGN(B5) = 1

See Also
Help
ABS Returns the absolute value of a number.
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SQRT(number)
Returns the positive square root of number.    If number is negative, returns the error value
#NUM!
Examples

SQRT(16) = 4
SQRT(-16) = #NUM!

See Also
Help
PRODUCT Returns the product of its arguments.
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ABS(number)
Returns the absolute value of number.    The absolute value of a number is the number 
without its sign.
Examples

ABS(-2) = 2
ABS(2) = 2

See Also
Help
IMABS Returns the absolute value (modulus) of a complex number.
SIGN Returns the sign of a number.
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EXP(number)
Returns e raised to the power of number.    The constant e equals 2.71828182845904, the 
base of the natural logarithm.

EXP is the inverse of the LN function.
To calculate powers of other bases, use the exponential operator (^).

Examples
EXP(1) = 2.71828 (the approximate value of e)
EXP(LN(3)) = 3

See Also
Help
IMEXP Returns the exponential of a complex number.
LN Returns natural logarithm (inverse of the EXP function).
LOG Returns logarithm of a number to a specified base.
LOG10 Returns base 10 logarithm of a number.
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INT(number)
Rounds number down to nearest integer.    Negative numbers are rounded away from zero.
Examples

INT(8.9) = 8
INT(-8.9) = -9

See Also
Help
CEILING Returns a number rounded up to the nearest integer.
FLOOR Returns a number rounded down, towards zero.
MOD Returns the remainder from division.
MROUND Returns number rounded to the nearest multiple.
ROUND Returns number rounded to specified decimal place.
TRUNC Truncates a number to an integer.
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LN(number)
Returns the natural logarithm of number.    Natural logarithms are based on the constant e 
(2.71828182845904).    LN is the inverse of the EXP function.
Number must be positive.
Examples

LN(86) = 4.45
LN(2.7182818) = 1
LN(EXP(3)) = 3

See Also
Help
EXP Returns e raised to the power of a given number.
IMLN Returns the natural logarithm of a complex number.
IMLOG2 Returns the logarithm base 2 of a complex number.
IMLOG10 Returns the logarithm base 10 of a complex number.
LOG Returns logarithm of a number to a specified base.
LOG10 Returns base 10 logarithm of number.
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LOG(number,base)
Returns the logarithm of number to base.
Number must be positive.    If base is omitted, it is assumed to be 10.
Examples

LOG(10) = 1
LOG(8,2) = 3
LOG(86,2.7182818) = 4.45

See Also
Help
EXP Returns e raised to the power of a given number.
IMLN Returns the natural logarithm of a complex number.
IMLOG2 Returns the logarithm base 2 of a complex number.
IMLOG10 Returns the logarithm base 10 of a complex number.
LN Returns the natural logarithm of a number.
LOG10 Returns base 10 logarithm of a number.
List of Math & Trig Functions



LOG10(number)
Returns the base 10 logarithm of number.
Number must be positive.
Examples

LOG10(86) = 1.93
LOG10(10) = 1
LOG10(1E5) = 5
LOG10(10^5) = 5

See Also
Help
EXP Returns e raised to the power of a given number.
IMLN Returns the natural logarithm of a complex number.
IMLOG2 Returns the logarithm base 2 of a complex number.
IMLOG10 Returns the logarithm base 10 of a complex number.
LN Returns the natural logarithm of a number.
LOG Returns the logarithm of a number to the specified base.
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RAND()
Returns an evenly distributed random number greater than or equal to 0 but less than 1.

You must include empty parentheses with RAND, otherwise Microsoft Excel will not 
recognize it as a function.

To generate a random integer, use the RANDBETWEEN function.
If you don't want the random number to change every time the cell is recalculated, 

you can enter =RAND() in the formula bar and choose the Calc Now button in the Calculation
dialog box on the Options menu to change the formula to a random number.
Example

To generate a number greater than or equal to 0 but less than 100:
RAND()*100

See Also
Help
RANDBETWEEN Returns a random number between two specified numbers.

 List of Math & Trig Functions



ROUND(number,num_digits)
Rounds number to num_digits.

If num_digits greater than zero, rounds number to specified decimal places.
If num_digits equals zero, rounds number to nearest integer.
If num_digits is less than zero, rounds number to the left of the decimal point.

Examples
ROUND(2.15,1) = 2.2
ROUND(2.149,1) = 2.1
ROUND(-1.475,2) = -1.48
ROUND(21.5,-1) = 20
ROUND(5.7,0) = 6

See Also
Help
CEILING Returns a number rounded up to the nearest integer.
FLOOR Returns a number rounded down, towards zero.
INT Returns a number rounded down to nearest integer.
MOD Returns the remainder from division.
MROUND Returns number rounded to the nearest multiple.
TRUNC Truncates a number to an integer.
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SUM(number1,number2,...)
Returns total of all numbers included as arguments.

1 to 30 arguments are allowed.
Arguments should be either numbers, or arrays or references that contain numbers.
To automatically insert the SUM function, press Alt+= (equal sign) or, if the toolbar is 

displayed, choose the AutoSum button.
Example

If A1:A3 contains the numbers 5, 8, and 2, then:
SUM(A1:A3) = 15
SUM(A1:A3,15,5) = 35

See Also
Help
AVERAGE Returns the average of the arguments.
COUNT Returns tally of the arguments that are numbers.
COUNTA Returns tally of the non-blank values in the list of arguments.
DSUM Returns the sum of the numbers in a particular field of a database.
PRODUCT Multiplies all arguments together.
SUMPRODUCT Returns the sum of the products of corresponding array elements.
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TRUNC(number,num_digits)
Rounds number down to nearest integer or nearest specified num_digits decimal places.

Num_digits argument is optional.    If omitted, it is assumed to be zero.
Examples

TRUNC(8.975,0) = 8
TRUNC(8.975,1) = 8.9
TRUNC(8.975,2) = 8.97
TRUNC(-8.975,2) = -8.97

See Also
Help
CEILING Returns a number rounded up to the nearest integer.
FLOOR Returns a number rounded down, towards zero.
INT Returns a number rounded down to nearest integer.
MOD Returns the remainder from division.
ROUND Returns a number rounded to a specified number of digits.
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BASE(number,target_base,precision)
Returns the equivalent of a base 10 number in another base.
If this function is not available, you must install the Add-in Functions add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Number is a base-10 number.
Target_base is the base you want to convert number into and must be between 2 

and 36.    If omitted, it is assumed to be 16.
Precision is the number of digits you want after the decimal point in the result.    If 

omitted, precision is assumed to be 0.
Example

BASE(256,8) = 400
BASE(299.875,7,5) = 605.6061

See Also
Help
AVERAGE Returns the average of the arguments.
COUNT Returns tally of the arguments that are numbers.
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DEGREES(angle_in_radians)
Converts angle_in_radians into degrees.
If this function is not available, you must install the Add-in Functions add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

DEGREES(PI()) = 180
See Also

Help
RADIANS Converts degrees into radians.
List of Engineering Functions
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RADIANS(angle_in_degrees)
Converts angle_in_degrees into radians.
If this function is not available, you must install the Add-in Functions add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.
Example

RADIANS(270) = 4.712389 (3*pi/2 radians)
See Also

Help
DEGREES Converts radians into degrees.
List of Engineering Functions
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RANDBETWEEN(bottom,top)
Returns an evenly distributed random integer within a given range of numbers.    A new 
random number is returned every time the worksheet is calculated.
If this function is not available, you must install the Add-in Functions add-in macro.    For 
more information, see "Managing Add-in Commands and Functions" in Chapter 4 in Book 2 
of the Microsoft Excel User's Guide.

Bottom is the smallest integer RANDBETWEEN will return.
Top is the largest integer RANDBETWEEN will return.

See Also
Help
RAND Returns a random number between 0 and 1.
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MDETERM(array)
Returns the matrix determinant value of array, where array must be a numeric array with 
an equal number of rows and columns.    Generally used for solving systems of 
mathematical equations that involve several variables.

Array can be given as a cell range (for example, A1:C3), or as an array constant 
(such as {1,2,3;4,5,6;7,8,9}).

If array is blank or contains nonnumeric values or if array is not a square array, 
MDETERM returns the #VALUE! error value.
Example

For an example of this function, see MDETERM in the Microsoft Excel Function Reference.
See Also

Help
MINVERSE Returns matrix inverse of an array.
MMULT Returns matrix product of two arrays.
TRANSPOSE Returns transpose of an array.
List of Lookup & Reference Functions
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MINVERSE(array)
Returns the inverse matrix for the matrix stored in array, where array must be a square 
array containing numbers.    Generally used for solving systems of mathematical equations 
that involve several variables.    The product of a matrix and its inverse is the identity 
matrix, the square array in which the diagonal values equal 1 and all other values equal 0.

Array can be given as a cell range (for example, A1:C3), an array constant (such as 
{1,2,3;4,5,6;7,8,9}), or as a reference.

If array contains blank cells or nonnumeric values, or if array is not a square array, 
returns the error value #VALUE!.
Example

For an example of this function, see MINVERSE in the Microsoft Excel Function Reference.
See Also

Help
MDETERM Returns matrix determinant of an array.
MMULT Returns the matrix product of two arrays.
TRANSPOSE Returns transpose of an array.
List of Lookup & Reference Functions
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MMULT(array1,array2)
Returns the matrix product of array1 and array2.    Result is array with same number of 
rows as array1 and same number of columns as array2.
Number of columns in array1 must be the same as number of rows in array2; both arrays 
must contain only numbers.

They can be given as cell ranges, array constants, or as references.
If any cells are blank or contain text, or if number of columns in array1 is different 

than the number of rows in array2, MMULT returns the error value #VALUE!.
Example

For an example of this function, see MMULT in the Microsoft Excel Function Reference.
See Also

Help
MDETERM Returns matrix determinant of an array.
MINVERSE Returns matrix inverse of an array.
TRANSPOSE Returns transpose of an array.
List of Lookup & Reference Functions
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SUMPRODUCT(array1,array2,array 3...)
Multiplies corresponding components in the given arrays and returns the sum of those 
products.

All arrays must have the same dimensions.    If they do not, returns the #VALUE! 
error value.

SUMPRODUCT can have from 2 to 30 arguments.
Array can be a cell range (for example, A1:C3), or an array constant (such as 

{1,2,3;4,5,6;7,8,9}).
Blank cells and text are interpreted as zero.

Example
SUMPRODUCT({1,2,3},{1,2,3}) = 14
For an example of this function using cell ranges, see SUMPRODUCT in the Microsoft Excel
Function Reference.

See Also
Help
MMULT Returns the matrix product of two arrays.
PRODUCT Multiplies its arguments.
SUM Adds all numbers given as arguments.
List of Lookup & Reference Functions
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TRANSPOSE(array)
Returns the transpose of array.    To form the transpose of an array, Microsoft Excel uses the
first row of the array as the first column of the new array, uses the second row of the array 
as the second column of the new array, and so on.
Example

For an example of this function, see TRANSPOSE in the Microsoft Excel Function 
Reference.

See Also
Help
MDETERM Returns matrix determinant of an array.
MINVERSE Returns matrix inverse of an array.
MMULT Returns matrix product of two arrays.
List of Lookup & Reference Functions
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COUNT(value1,value2,...)
Counts how many numbers are in the list of arguments.

Can have 1 to 30 arguments.
Arguments should be logical values, empty cells, text representation of numbers, 

numbers, or arrays or references that contain numbers.
Example

If all cells in A1:A10 contain data except cell A3, then:
COUNT(A1:A10) = 9

See Also
Help
AVERAGE Averages arguments.
COUNTA Counts values.
DCOUNT Counts cells containing numbers from selected database entries.
DCOUNTA Counts nonblank cells.
PRODUCT Multiplies arguments.
SUM Adds arguments.
List of Statistical Functions



COUNTA(value1,value2,...)
Counts the number of nonblank values in the list of arguments.

Can have 1 to 30 arguments.
Arguments should be either numbers, or arrays or references that contain numbers.

Example
If all cells in A1:A10 contain data except cell A3, then:
COUNTA(A1:A10) = 9

See Also
Help
AVERAGE Averages arguments.
COUNT Counts numbers.
DCOUNT Counts cells containing numbers from selected database entries.
DCOUNTA Counts cells containing values from selected database entries.
PRODUCT Multiplies arguments.
SUM Adds arguments.
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MAX(number1,number2,...)
Returns the largest number in the list of arguments.

Can have up to 30 arguments.
Arguments should be either numbers, or arrays or references that contain numbers.
Arguments that are numbers, empty cells, logical values, or text representations of 

numbers are used.
Arguments that are error values or text that cannot be translated into numbers cause

errors.
If an argument is an array or reference, only numbers in that array or reference are 

used.
Examples

If A1:A5 contains the numbers 10, 7, 9, 27, and 2, then:
MAX(A1:A5) = 27
MAX(A1:A5,30) = 30

See Also
Help
DMAX Returns largest value from selected database entries.
MIN Returns smallest number in list of arguments.
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MIN(number1,number2,...)
Returns the smallest number in the list of arguments.

Can have up to 30 arguments.
Arguments should be either numbers, or arrays or references that contain numbers.

Examples
If A1:A5 contains the numbers 10, 7, 9, 27, and 2, then:
MIN(A1:A5) = 2
MIN(A1:A5,0) = 0

See Also
Help
DMIN Returns smallest value from selected database entries.
MAX Returns largest number in list of arguments.
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AVERAGE(number1,number2,...)
Returns the average (arithmetic mean) of the arguments.

Can have 1 to 30 arguments.
Arguments should be either numbers, or arrays or references that contain numbers. 

Example
For an example of this function, see AVERAGE in the Microsoft Excel Function Reference.

See Also
Help
DAVERAGE Returns the average of selected database entries.
GEOMEAN Returns the geometric mean.
HARMEAN Returns the harmonic mean.
MEDIAN Returns the middle value in a data set.
MODE Returns the most common value in a data set.
SUM Adds its arguments.
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GROWTH(known_y's,known_x's,new_x's,const)
Fits an exponential curve to known_y's and known_x's.    Returns y-values along that curve
for the new_x's.    
If any number in known_y's is negative, returns error value #NUM!.
The known_x's, new_x's, and const arguments are optional.

If known_x's includes only one variable, then known_x's and known_y's can be 
ranges of any shape, as long as they have the same dimensions.

If known_x's include more than one variable, known_y's must be in a single row or 
column.

If known_y's are in a single column, known_x's and new_x's should have the same 
number of columns; GROWTH interprets each column of known_x's as a separate variable.

If known_y's are in a single row, known_x's and new_x's should have the same 
number of rows; GROWTH interprets each row of known_x's as a separate variable.

If both known_x's and new_x's are omitted, they are assumed to be the array 
{1,2,3,...} of the same size as known_y's.

If any of the numbers in known_y's are negative, GROWTH returns the error value 
#NUM!.

One dimension of new_x's must be the same as known_x's.
If const is FALSE, the constant term b equals 1.
If const is TRUE or omitted, the constant term will be estimated.

Example
For an example of this function, see GROWTH in the Microsoft Excel Function Reference.

See Also
Help
LINEST Returns the parameters of a linear trend.
LOGEST Returns the parameters of an exponential trend.
TREND Returns values along a linear trend.
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LINEST(known_y's,known_x's,const,stats)
Fits a straight line to your data and returns an array that describes that line.    The accuracy 
of the line depends on the degree of scattering in the data you provide.    The more linear 
the data, the more accurate the LINEST model.    LINEST uses the method of least squares 
for determining the best fit for the data.
The known_x's, const, and stats arguments are optional.

If the array known_y's is in a single row, then each row of known_x's is interpreted 
as a separate variable.

If the array known_y's is in a single column, then each column of known_x's is 
interpreted as a separate variable.

The array known_x's can include one or more sets of variables.
If you use only one variable, known_y's and known_x's can be shaped differently.
If you use more than one variable, known_y's must be a vector (a range with a height 
or width of 1).

If you omit known_x's, LINEST uses the values {1,2,3,...} in an array the same size 
as known_y's.

If const is FALSE, the constant term b equals zero.
If const is TRUE or omitted, the constant term will be estimated.
If stats is FALSE or omitted, LINEST returns only the slope and y-intercept.
If stats is TRUE, LINEST returns the additional values:
Standard error for each coefficient
Standard error for the constant b
Coefficient of determination (r-squared)
Standard error for the y-estimate
F-statistic
Degrees of freedom
Regression sum of squares
Residual sum of squares

Example
For an example of this function, see LINEST in the Microsoft Excel Function Reference.

See Also
Help
GROWTH Returns values along an exponential trend.
LOGEST Returns the parameters of an exponential trend.
TREND Returns values along a linear trend.
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LOGEST(known_y's,known_x's,const,stats)
Fits an exponential curve to the arrays known_y's and known_x's.    Returns a horizontal 
array that describes that curve.    The closer your data resembles an exponential curve, the 
better the calculated line will fit your data.
The known_x's, const, and stats arguments are optional.

If the array known_y's is in a single row, then each row of known_x's is interpreted 
as a separate variable.

If the array known_y's is in a single column, then each column of known_x's is 
interpreted as a separate variable.

The array known_x's can include one or more sets of variables.
If you use only one variable, known_y's and known_x's can be shaped differently 
as long as they have equal dimensions.
If you use more than one variable, known_y's must be a vector (a range with a 
height or width of 1).
If you omit known_x's, LOGEST uses the values {1,2,3,...} in an array the same size 

as known_y's.
If const is FALSE, the constant term b equals 1.
If const is TRUE or omitted, returns the estimated constant term.    
If stats is FALSE or omitted, LOGEST returns only the slope and y-intercept.
If stats is TRUE, LOGEST returns the additional values:
Standard error for each coefficient
Standard error for the constant b
Coefficient of determination (r-squared)
Standard error for the y-estimate
F-statistic
Degrees of freedom
Regression sum of squares
Residual sum of squares

Example
For an example of this function, see LOGEST in the Microsoft Excel Function Reference.

See Also
Help
GROWTH Returns values along an exponential trend.
INDEX Reference in reference or value in array selected by index values.
LINEST Returns the parameters of a linear trend.
TREND Returns values along a linear trend.
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MEDIAN(number1,number2,...)
Returns the middle value of the arguments.

If there is an even number of arguments, MEDIAN() returns the average of the two 
middle values.
Examples

MEDIAN(9,5,3,1,7,2,8) = 5
MEDIAN(3,1,9,5) = 4

See Also
Help
AVERAGE Returns average of arguments.
DAVERAGE Returns the average of selected database entries.
GEOMEAN Returns the geometric mean.
HARMEAN Returns the harmonic mean.
MODE Returns the most common value in a data set.
SUM Adds its arguments.
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STDEV(number1,number2,...)
Returns an estimate for the standard deviation of a population based on the population 
sample provided in the list of arguments.    Use when you have data for a sample of the 
population.    If you have data for the whole population, use STDEVP.

Can have 1 to 30 arguments.
Arguments should be either numbers, or arrays or references that contain numbers.

Example
For an example of this function, see STDEV in the Microsoft Excel Function Reference.

See Also
Help
DSTDEV Estimates the standard deviation of a population based on a sample from a

database.
DVARP Calculates the variance of an entire population based on the entire 

population in a database.
STDEVP Calculates the standard deviation for a population based on the entire 

population.
VAR Estimates the variance for a population based on a sample.
VARP Calculates the variance of a population based on the entire population.
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STDEVP(number1,number2,...)
Returns the standard deviation of an entire population based on a list of arguments.    Use 
when you have data for the entire population.    If you have data for a sample, use STDEV.

Can have 1 to 30 arguments.
Arguments should be either numbers, or arrays or references that contain numbers.

Example
For an example of this function, see STDEVP in the Microsoft Excel Function Reference.

See Also
Help
DSTDEVP Calculates the standard deviation for a population based on the entire 

population in a database.
DVARP Calculates the variance of an entire population based on the entire 

population in a database.
STDEV Estimates the standard deviation for a population based on a sample.
VAR Estimates the variance for a population based on a sample.
VARP Calculates the variance for a population based on the entire population.
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TREND(known_y's,known_x's,new_x's,const)
Fits a straight line (using the method of least squares) to arrays known_y's and 
known_x's.    Returns y-values along that line for the array of new_x's.
The const argument is optional.

If array known_y's is in a single column, then each column of known_x's is 
interpreted as a separate variable.    If array known_y's is in a single row, then each row of 
known_x's is interpreted as a separate variable.

The array known_x's can include one or more sets of variables.
If only one variable is used, known_y's and known_x's can be shaped differently but must 
have the same dimensions.
If more than one variable is used, known_y's must be a vector (a range with a height or 
width of 1).

If new_x's is included, one dimension of that array must be the same as known_x's. 
If you omit new_x's, it is assumed to be the same as known_x's.

If you omit both known_x's and new_x's, they are assumed to be the array 
{1,2,3,...} of the same size as known_y's.

If const is FALSE, the constant term b equals zero.
If const is TRUE or omitted, the constant term will be estimated.    

You can also use TREND for curve-fitting by regressing against the same variable raised to 
different powers.
Example

For an example of this function, see TREND in the Microsoft Excel Function Reference.

See Also
Help
GROWTH Returns values along an exponential trend.
LINEST Returns the parameters of a linear trend.
LOGEST Returns the parameters of an exponential trend.
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VAR(number1,number2,...)
Returns an estimate for the variance of a population based on the population sample 
provided in the list of arguments.    Use when you have data for a sample of the population.   
If you have data for the entire population, use VARP.

Can have 1 to 30 arguments.
Arguments should be either numbers, or arrays or references that contain numbers.

Example 
For an example of this function, see VAR in the Microsoft Excel Function Reference.

See Also
Help
DSTDEV Estimates the standard deviation of a population based on a sample in a 

database.
DVARP Calculates the variance of an entire population based on the entire 

population in a database.
VARP Calculates the variance of a population based on the entire population.
STDEV Returns the standard deviation of a population based on a sample.
STDEVP Returns the standard deviation of a population based on the entire 

population.
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VARP(number1,number2,...)
Returns the variance for an entire population, based on the list of arguments.    Use when 
you have data for the entire population.    If you have data for a sample, use VAR.

Can have 1 to 30 arguments.
Arguments should be either numbers, or arrays or references that contain numbers.

Example 
For an example of this function, see VARP in the Microsoft Excel Function Reference.

See Also
Help
DSTDEV Estimates the standard deviation of a population based on a sample in a 

database.
DVARP Calculates the variance of an entire population based on values from the 

database.
STDEV Estimates the standard deviation for a population based on a sample.
STDEVP Calculates the standard deviation for a population based on the entire 

population.
VAR Estimates the variance for a population based on a sample.
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FREQUENCY(data_array,bins_array)
Returns a frequency distribution as a vertical array.

Data_array is an array of, or reference to, a set of values for which you want to 
count frequencies.    If data_array is empty, returns an array of zeros.

Bins_array is an array of, or reference to, intervals into which you want to group the 
values in data_array.    If bins_array is empty, returns the number of elements in 
data_array.

FREQUENCY ignores blank cells and text.
Example

When entered as an array:
FREQUENCY({79;85;78;85;83;81;95;88;97},{70;79;89}) = {0;2;5;2}

See Also
Help
COUNT Counts numbers.
DCOUNT Counts cells containing numbers from a specified database.
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AVEDEV(number1,number2,...)
Returns the average of the absolute deviations of data points from their mean.    AVEDEV is 
a measure of the variability in a data set.

Number1, number2, ... are 1 to 30 arguments for which you want the average of 
the absolute deviations.    You can also use a single array or a reference to an array instead 
of arguments separated by commas.

The arguments should be number, or names, arrays, or references that contain 
numbers.

If an array or reference argument contains text, logical values, or empty cells, those 
values are ignored; however, cells with the value zero are included.
Example

AVEDEV(4,5,6,7,5,4,3) = 1.020408
See Also

Help
DEVSQ Returns the sum of squares of deviations.
STDEV Estimates standard deviation based on a sample.
STDEVP Calculates standard deviation based on the entire population.
VAR Estimates variance based on a sample.
VARP Calculates variance based on the entire population.
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BETADIST(x,alpha,beta,A,B)
Returns the cumulative beta probability density function.    The cumulative beta probability 
density function is commonly used to study variation in the percentage of something across
samples, such as the fraction of the day people spend watching television.

X is the value at which to evaluate the function over the interval A<x<B.
Alpha is a parameter to the distribution. 
Beta is a parameter to the distribution.
A is an optional lower bound to the interval of x.
B is an optional upper bound to the interval of x.
If you omit A and B, a standard cumulative beta distribution is used, so that A=0 and

B=1.
Example

BETADIST(2,8,10,1,3) = 0.685471
See Also

Help
BETAINV Returns the inverse of the cumulative beta probability density.
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BETAINV(probability,alpha,beta,A,B)
Returns the inverse of the cumulative beta probability density function.    That is, if 
probability = BETADIST(x,...), then BETAINV(probability,...) = x.    The cumulative beta 
distribution can be used in project planning to model probable completion times given an 
expected completion time and variability.    For example, a project might take three days to 
complete, plus or minus a day, and you want to know the probability that it will take less 
than three days.

Probability is a probability associated with the beta distribution.
Alpha is a parameter to the distribution. 
Beta is a parameter to the distribution.
A is an optional lower bound to the interval of x.
B is an optional upper bound to the interval of x.
If you omit A and B, a standard cumulative beta distribution is used, so that A=0 and

B=1.
Example

BETAINV(0.685471,8,10,1,3) = 2
See Also

Help
BETADIST Returns the cumulative beta probability density.
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BINOMDIST(number_s,trials,probability_s,cumulative)
Returns the individual term binomial distribution probability. Use BINOMDIST in problems 
with a fixed number of tests or trials, when the outcomes of any trial are only success or 
failure, when trials are independent, and when the probability of success is constant 
throughout the experiment.    BINOMDIST can calculate the probability that two of the next 
three babies born are male.

Number_s is the number of successes in trials.
Trials is the number of independent trials.
Probability_s is the probability of success on each trial.
Cumulative is a logical value that determines the form of the function.    If 

cumulative is TRUE, then BINOMDIST returns the cumulative distribution function, which is 
the probability that there are at most number_s successes; if FALSE, it returns the 
probability mass function, which is the probability that there are number_s successes.
Example

The flip of a coin can only result in heads or tails.    The probability that the first flip is 
heads is 0.5, and the probability that exactly 6 of 10 flips are heads is:
BINOMDIST(6,10,0.5,FALSE) = 0.205078

See Also
Help
COMBIN Returns the number of combinations for a given number of objects.
CRITBINOM Returns the smallest value for which the cumulative binomial distribution

is less than or equal to a criterion value.
FACT Returns the factorial of a number.
HYPGEOMDIST Returns the hypergeometric distribution.
NEGBINOMDIST Returns the negative binomial distribution.
PERMUT Returns the number of permutations for a given number of objects.
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CEILING(number,significance)
Returns number rounded up to the nearest multiple of significance.    For example, if you 
want to avoid using pennies in your prices and your product is priced at $4.42, use the 
formula =CEILING(4.42,0.05) to round prices up to the nearest nickel.

Number is the value you want to round.
Significance is the multiple to which you want to round.

Examples
CEILING(2.5,1) = 3
CEILING(-2.5,-2) = -4
CEILING(-2.5,2) = #NUM!
CEILING(1.5,0.1) = 1.5
CEILING(0.234,0.01) = 0.24

See Also
Help
EVEN Rounds a number up to the nearest even integer.
FLOOR Rounds a number down, towards zero.
INT Rounds a number down to the nearest integer.
ODD Rounds a number up to the nearest odd integer.
ROUND Rounds a number to a specified number of digits.
TRUNC Truncates a number to an integer.
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CHIDIST(x,degrees_freedom)
Returns the one-tailed probability of the chi-squared (c2) distribution.    The chi-squared 
distribution is associated with a chi-squared test.    Use the chi-squared test to compare 
observed and expected values.    For example, a genetic experiment might hypothesize that 
the next generation of plants will exhibit a certain set of colors.    By comparing the 
observed results with the expected ones, you can decide if your original hypothesis is valid.

X is the value at which you want to evaluate the distribution.
Degrees_freedom is the number of degrees of freedom.

Example
CHIDIST(18.307,10) = 0.050001

See Also
Help
CHIINV Returns the inverse of the chi-squared distribution.
CHITEST Returns the test for independence.
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CHIINV(probability,degrees_freedom)
Returns the inverse of the chi-squared (c2) distribution.    Use the chi-squared distribution to 
compare observed results with expected ones to decide if your original hypothesis is valid.

Probability is a probability associated with the chi-squared distribution.
Degrees_freedom is the number of degrees of freedom.

Example
CHIINV(0.05,10) = 18.30703

See Also
Help
CHIDIST Returns the one-tailed probability of the chi-squared distribution. 
CHITEST Returns the test for independence.
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CHITEST(actual_range,expected_range)
Returns the test for independence. CHITEST returns the value from the chi-squared (c2) 
distribution for the statistic and the appropriate degrees of freedom.    You can use chi-
squared tests to determine if hypothesized results are verified by an experiment.

Actual_range is the range of data that contains observations to test against 
expected values.

Expected_range is the range of data that contains the ratio of the product of row 
totals and column totals to the grand total.
Example

For an example of this function, see CHITEST in the Microsoft Excel Function Reference.
See Also

Help
CHIDIST Returns the one-tailed probability of the chi-squared distribution. 
CHIINV Returns the inverse of the chi-squared distribution function.
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COMBIN(number,number_chosen)
Returns the number of ways that number_chosen objects can be selected from number 
objects, without regard for order.    Use COMBIN to determine the total possible number of 
groups for a given number of objects.

Number is the number of objects.
Number_chosen is the number of objects in each combination.

Example
Suppose you want to form a two-person team from 8 candidates and you want to know 
how many possible teams can be formed. COMBIN(8,2) = 28 teams.

See Also
Help
BINOMDIST Returns the individual term binomial distribution.
CRITBINOM Returns the smallest value for which the cumulative binomial distribution 

is less than or equal to a criterion value.
FACT Returns the factorial of a number.
HYPGEOMDIST Returns the hypergeometric distribution.
NEGBINOMDIST Returns the negative binomial distribution.
PERMUT Returns the number of permutations for a given number of objects.
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CONFIDENCE(alpha,standard_dev,size)
Returns the confidence interval for a population mean.    The confidence interval is a range 
on either side of a sample mean.    For example, if you order a product through the mail, you
can determine, with a particular level of confidence, the earliest and latest dates the 
product should arrive.

Alpha is the significance level used to compute the confidence level. The confidence 
level equals 100(1 - alpha)%.

Standard_dev is the population standard deviation for the data range, and is 
assumed to be known.

Size is the sample size.
Example

For an example of this function, see CONFIDENCE in the Microsoft Excel Function 
Reference.

See Also
Help
ZTEST Returns the two-tailed P-value of a z test.
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CORREL(array1,array2)
Returns the correlation coefficient of the given arrays.    Use the correlation coefficient to 
determine the relationship between two properties.    For example, you can examine the 
relationship between a location’s average temperature and the use of air conditioners.

Array1 is an array or a cell range of values.
Array2 is a second array or cell range of values.

Example
CORREL({3,2,4,5,6},{9,7,12,15,17}) = 0.997054

See Also
Help
COVAR Returns covariance, the average of the products of paired deviations.
FISHER Returns the Fisher transformation.
FISHERINV Returns the inverse of the Fisher transformation.
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COVAR(array1,array2)
Returns covariance, the average of the products of deviations for each data point pair.    Use 
covariance to determine the relationship between two data sets.    For example, you can 
examine whether greater income accompanies higher levels of education.

Array1 is the first array or cell range of integers. 
Array2 is a second array or cell range of integers.

Example
COVAR({3,2,4,5,6},{9,7,12,15,17}) = 5.2

See Also
Help
CORREL Returns the correlation coefficient between two data sets.
FISHER Returns the Fisher transformation.
FISHERINV Returns the inverse of the Fisher transformation.
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CRITBINOM(trials,probability_s,alpha)
Returns the smallest integer k for which the cumulative binomial distribution function is 
greater than or equal to the criterion value alpha.    Use this function for quality assurance 
applications. 

Trials is the number of Bernoulli trials.
Probability_s is the probability of a success on each trial.
Alpha is the criterion value.

Example
CRITBINOM(6,0.5,0.75) = 4

See Also
Help
BINOMDIST Returns the individual term binomial distribution.
COMBIN Returns the number of combinations for a given number of objects.
FACT Returns the factorial of a number.
HYPGEOMDIST Returns the hypergeometric distribution.
NEGBINOMDIST Returns the negative binomial distribution.
PERMUT Returns the number of permutations for a given number of objects.
PROB Returns the probability that values in a range are between two limits.
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DEVSQ(number1,number2,...)
Returns the sum of squares of deviations of data points from their sample mean.

Number1, number2, ... are 1 to 30 arguments for which you want to calculate the 
sum of squared deviations.    You can also use a single array or a reference to an array 
instead of arguments separated by commas.

The arguments should be number, or names, arrays, or references that contain 
numbers.

If an array or reference argument contains text, logical values, or empty cells, those 
values are ignored; however, cells with the value zero are included.
Example

DEVSQ(4,5,8,7,11,4,3) = 48
See Also

Help
AVEDEV Returns the average of absolute deviations of data points from their mean.
STDEV Estimates standard deviation based on a sample.
STDEVP Calculates standard deviation based on the entire population.
VAR Estimates variance based on a sample.
VARP Calculates variance based on the entire population.
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EVEN(number)
Returns number rounded up to the nearest even integer.

Number is the value to round. Regardless of the sign of number, EVEN rounds 
number away from zero.
Examples

EVEN(1.5) = 2
EVEN(3) = 4
EVEN(2) = 2
EVEN(-1) = -2

See Also
Help
CEILING Rounds a number up, away from zero.
FLOOR Rounds a number down, towards zero.
INT Rounds a number down to the nearest integer.
ODD Rounds a number up to the nearest odd integer.
ROUND Rounds a number to a specified number of digits.
TRUNC Truncates a number to an integer.
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EXPONDIST(x,lambda,cumulative)
Returns the exponential distribution function. Use EXPONDIST to model the time between 
events, such as how long an automated bank teller takes to deliver cash.    You can use 
EXPONDIST to determine the probability that the process takes at most one minute.

X is the value of the function.
Lambda is the parameter value. 
Cumulative is a logical value that indicates which form of the exponential function 

to provide.    If cumulative is TRUE, EXPONDIST returns the cumulative distribution function;
if FALSE, it returns the probability density function.
Examples

EXPONDIST(0.2,10,TRUE) = 0.864665
EXPONDIST(0.2,10,FALSE) = 1.353353

See Also
Help
GAMMADIST Returns the gamma distribution.
POISSON Returns the Poisson probability distribution.
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FDIST(x,degrees_freedom1,degrees_freedom2)
Returns the F probability distribution. You can use this function to determine whether two 
data sets have different degrees of diversity.    For example, you can examine test scores 
given to men and women entering high school and determine if the variability in the 
females is different from that found in the males.

X is the value at which to evaluate the function.
Degrees_freedom1 is the numerator degrees of freedom.
Degrees_freedom2 is the denominator degrees of freedom.

Example
FDIST(15.20704,6,4) = 0.01

See Also
Help
FINV Returns the inverse of the F probability distribution.
FTEST Returns the results of an F-test.
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FINV(probability,degrees_freedom1,degrees_freedom2)
Returns the inverse of the F probability distribution. The F distribution can be used in an F-
test which compares the degree of variability in two data sets.

Probability is a probability associated with the F cumulative distribution.
Degrees_freedom1 is the numerator degrees of freedom.
Degrees_freedom2 is the denominator degrees of freedom.

Example
FINV(0.01,6,4) = 15.207

See Also
Help
FDIST Returns the F probability distribution.
FTEST Returns the result of an F-test.
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FISHER(x)
Returns the Fisher transformation at x.    This transformation produces a function that is 
approximately normally distributed rather than skewed.    Use this function to perform 
hypothesis testing on the correlation coefficient.

X is a numeric value strictly between -1 and 1 for which you want the transformation.
Example

FISHER(0.75) = 0.972955
See Also

Help
CORREL Returns the correlation coefficient between two data sets.
COVAR Returns covariance, the average of the products of paired deviations.
FISHERINV Returns the inverse of the Fisher transformation.
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FISHERINV(y)
Returns the inverse of the Fisher transformation.    Use this transformation when analyzing 
correlations between ranges or arrays of data. 

Y is the value for which you want to perform the inverse of the transformation.
Example

FISHERINV(0.972955) = 0.75
See Also

Help
CORREL Returns the correlation coefficient between two data sets.
COVAR Returns covariance, the average of the products of paired deviations.
FISHER Returns the Fisher transformation.
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FLOOR(number,significance)
Rounds number down to the nearest multiple of significance.

Number is the numeric value you want to round. Regardless of the sign of number, 
FLOOR rounds number toward zero.

Significance is the multiple to which you want to round.
Examples

FLOOR(2.5,1) = 2
FLOOR(-2.5,-2) = -2
FLOOR(-2.5,2) = #NUM!
FLOOR(1.5,0.1) = 1.5
FLOOR(0.234,0.01) = 0.23

See Also
Help
CEILING Returns a number rounded up, away from zero.
EVEN Rounds a number up to the nearest even integer.
INT Rounds a number down to the nearest integer.
ODD Rounds a number up to the nearest odd integer.
ROUND Rounds a number to a specified number of digits.
TRUNC Truncates a number to an integer.
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FORECAST(x,known_y's,known_x's)
Returns a predicted value for x based on a linear regression of known x- and y-arrays or 
ranges of data.    You can use this function to predict future sales, inventory requirements, or
consumer trends.

X is the data point for which you want to predict a value.
Known_y's is the dependent array or range of data. 
Known_x's is the independent array or range of data. 

Example
FORECAST(30,{6,7,9,15,21},{20,28,31,38,40}) = 10.60725

See Also
Help
GROWTH Returns values along an exponential trend.
LINEST Returns parameters of a linear trend.
LOGEST Returns parameters of an exponential trend.
TREND Returns values along a linear trend.
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FTEST(array1,array2)
Returns the results of an F-test.    An F-test returns the one-tailed probability that the 
variances in array1 and array2 are not significantly different.    Use this function to 
determine if two samples have different variances. 

Array1 is the first array or range of data.
Array2 is the second array or range of data.

Example
FTEST({6,7,9,15,21},{20,28,31,38,40}) = 0.648318

See Also
Help
FDIST Returns the F probability distribution.
FINV Returns the inverse of the F probability distribution.
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GAMMADIST(x,alpha,beta,cumulative)
Returns the gamma distribution function.    You can use this function to study variables that 
may have a skewed distribution.    The gamma distribution is commonly used in queuing 
analysis.

X is the value at which you want to evaluate the distribution.
Alpha is a parameter to the distribution.
Beta is a parameter to the distribution. If beta = 1, GAMMADIST returns the 

standard gamma distribution.
Cumulative is a logical value that determines the form of the function.    If 

cumulative is TRUE, GAMMADIST returns the cumulative distribution function; if FALSE, it 
returns the probability mass function.
Examples

GAMMADIST(10,9,2,FALSE) = 0.032639
GAMMADIST(10,9,2,TRUE) = 0.068094

See Also
Help
CHIDIST Returns the chi-squared distribution function.
EXPONDIST Returns the exponential distribution.
GAMMAINV Returns the inverse of the gamma cumulative distribution.
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GAMMAINV(probability,alpha,beta)
Returns the inverse of the gamma cumulative distribution function.    You can use this 
function to study a variable whose distribution may be skewed.

Probability is the probability associated with the gamma distribution.
Alpha is a parameter to the distribution.
Beta is a parameter to the distribution. If beta = 1, GAMMAINV returns the standard 

gamma distribution.
Example

GAMMAINV(0.068094,9,2) = 10
See Also

Help
GAMMADIST Returns the gamma distribution.
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GAMMALN(x)
Returns the natural logarithm of the gamma function.

X is the value for which you want to calculate GAMMALN.
If e, the base of the natural logarithm, is raised to the GAMMALN(i) power, where i is 

an integer, the result is the same as FACT(i-1).
Examples

GAMMALN(4) = 1.791759
EXP(GAMMALN(4)) = 6 or FACT(4-1)

See Also
Help
FACT Returns the factorial of a number.
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GEOMEAN(number1,number2,...)
Returns the geometric mean of an array or range of positive data.    For example, you can 
use GEOMEAN to calculate average growth rate given compound interest with variable 
rates.

number1,number2,... are 1 to 30 arguments for which you want to calculate the 
mean.    You can also use a single array or a reference to an array instead of arguments 
separated by commas.
Example

GEOMEAN(4,5,8,7,11,4,3) = 5.476987
See Also

Help
AVERAGE Returns the arithmetic mean.
HARMEAN Returns the harmonic mean.
MEDIAN Returns the middle value in a data set.
MODE Returns the most common value in a data set.
TRIMMEAN Returns the mean of the interior of a data set.
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HARMEAN(number1,number2,...)
Returns the harmonic mean of a data set. The harmonic mean is the reciprocal of the 
arithmetic mean of reciprocals.

number1,number2,... are 1 to 30 arguments for which you want to calculate the 
mean. You can also use a single array or a reference to an array instead of arguments 
separated by commas.
Example

HARMEAN(4,5,8,7,11,4,3) = 5.028376
See Also

Help
AVERAGE Returns the arithmetic mean.
GEOMEAN Returns the geometric mean.
MEDIAN Returns the middle value in a data set.
MODE Returns the most common value in a data set.
TRIMMEAN Returns the mean of the interior of a data set.
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HYPGEOMDIST(sample_s,number_sample,population_s, 
number_population)
Returns the hypergeometric distribution. HYPGEOMDIST returns the probability of a given 
number of sample successes, given the sample size, population successes, and population 
size.    Use HYPGEOMDIST for problems with a finite population, where each observation is 
either a success or a failure, and where each subset of a given size is chosen with equal 
likelihood.

Sample_s is the number of successes in the sample. 
Number_sample is the size of the sample. 
Population_s is the number of successes in the population. 
Number_population is the population size.

Example
A sampler of chocolates contains 20 pieces. Eight pieces are caramels and the remaining 
twelve are nuts.    If a person selects 4 chocolates at random, the following function 
returns the probability that exactly one piece is a caramel.
HYPGEOMDIST(1,4,8,20) = 0.363261

See Also
Help
BINOMDIST Returns the binomial distribution.
COMBIN Returns the number of combinations for a given number of objects.
FACT Returns the factorial of a number.
NEGBINOMDIST Returns the negative binomial distribution.
PERMUT Returns the number of permutations for a given number of objects.
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INTERCEPT(known_y's,known_x's)
Returns the intercept of the linear regression line through data points in known_x's and 
known_y's.    The intercept is the point at which the regression line through the values in 
known_x's and known_y's intersects the y-axis.    Use the intercept when you want to 
determine the value of the dependent variable when the independent variable is zero.

Known_y's is the dependent set of observations or data.
Known_x's is the independent set of observations or data.

Example
INTERCEPT({2,3,9,1,8},{6,5,11,7,5}) = 0.0483871

See Also
Help
FORECAST Returns values along a regression line.
GROWTH Returns values along an exponential trend.
LINEST Returns parameters of a linear trend.
LOGEST Returns parameters of an exponential trend.
PEARSON Returns the Pearson product moment correlation coefficient.
RSQ Returns the r2 value of the linear regression line.
SLOPE Returns the slope of the linear regression line.
STEYX Returns the standard error of the predicted y value for each x in the 

regression.
TREND Returns values along a linear trend.
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KURT(Number1,number2,...)
Returns the kurtosis of a data set. Kurtosis characterizes the relative peakedness or flatness
of a distribution compared to the normal distribution.    Positive kurtosis indicates a relatively
peaked distribution. Negative kurtosis indicates a relatively flat distribution.

Number1,number2,... are 1 to 30 arguments for which you want to calculate 
kurtosis.
Example

KURT(3,4,5,2,3,4,5,6,4,7) = -0.1518
See Also

Help
SKEW Returns the skewedness of a distribution.
STDEV Estimates standard deviation based on a sample.
STDEVP Calculates standard deviation based on the entire population.
VAR Estimates variance based on a sample.
VARP Calculates variance based on the entire population.
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LARGE(array,k)
Returns the k-th largest value in a data set. You can use this function to select a value based
on its relative standing.    For example, you can use LARGE to return the highest, runner-up, 
or third-place score.

Array is the array or range of data for which you want to determine the k-th largest 
value. 

K is the position (from the largest) in the array or cell range of data to return.
Examples

LARGE({3,4,5,2,3,4,5,6,4,7},3) = 5
LARGE({3,4,5,2,3,4,5,6,4,7},7) = 4

See Also
Help
PERCENTILE Returns the k-th percentile of values in a range.
PERCENTRANK Returns the percentage rank of a value in a data set.
QUARTILE Returns the a quartile of a data set.
SMALL Returns the k-th smallest value in a data set.
List of Statistical Functions



LOGINV(probability,mean,standard_dev)
Returns the inverse of the lognormal cumulative distribution function of x.    Use the 
lognormal distribution to analyze logarithmically transformed data.

Probability is a probability associated with the lognormal distribution.
Mean is the mean of x.
Standard_dev is the standard deviation of x.

Example
LOGINV(0.039084,3.5,1.2) = 4.000014

See Also
Help
EXP Returns e raised to a given number.
LN Returns the natural logarithm of a number.
LOG Returns the logarithm of a number to a specified base.
LOG10 Returns the base-10 logarithm of a number.
LOGNORMDIST Returns the lognormal distribution.
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LOGNORMDIST(x,mean,standard_dev)
Returns the lognormal cumulative distribution function of x, where ln(x) is normally 
distributed with parameters mean and standard_dev.    Use this function to analyze data 
that has been logarithmically transformed.

X is the value at which to evaluate the function.
Mean is the mean of x.
Standard_dev is the standard deviation of x.

Example
LOGNORMDIST(4,3.5,1.2) = 0.039084

See Also
Help
EXP Returns e raised to a given number.
LN Returns the natural logarithm of a number.
LOG Returns the logarithm of a number to a specified base.
LOG10 Returns the base-10 logarithm of a number.
LOGINV Returns the inverse of the lognormal distribution.
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MODE(Number1,number2,...)
Returns the most frequently occurring value in an array or range of data.    Like MEAN and 
MEDIAN, MODE is a location measure.

Number1,number2,... are 1 to 30 arguments for which you want to calculate the 
mode.    You can also use a single array or a reference to an array instead of arguments 
separated by commas.
Example

MODE({5.6,4,4,3,2,4}) = 4
See Also

Help
AVERAGE Returns the arithmetic mean.
GEOMEAN Returns the geometric mean.
HARMEAN Returns the harmonic mean.
MEDIAN Returns the middle value in a data set.
TRIMMEAN Returns the mean of the interior of a data set.
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NEGBINOMDIST(number_f,number_s,probability_s)
Returns the negative binomial distribution. NEGBINOMDIST returns the probability that there
will be number_f failures before the success numbered number_s, when the constant 
probability of a success is probability_s.    This function is similar to the binomial 
distribution, except that the number of successes is fixed and the number of trials is 
variable.    Like the binomial, trials are assumed to be independent.

Number_f is the number of failures.
Number_s is the threshold number of successes.
Probability_s is the probability of a success. 

Example
NEGBINOMDIST(10,5,0.25) = 0.055049

See Also
Help
BINOMDIST Returns the individual term binomial distribution.
COMBIN Returns the number of combinations for a given number of objects.
FACT Returns the factorial of a number.
HYPGEOMDIST Returns the hypergeometric distribution.
PERMUT Returns the number of permutations for a given number of objects.
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NORMDIST(x,mean,standard_dev,cumulative)
Returns the normal cumulative distribution function for the specified mean and standard 
deviation.    This function has a very wide range of applications in statistics, including 
hypothesis testing.

X is the value for which you want the distribution. 
Mean is the arithmetic mean of the distribution. 
Standard_dev is the standard deviation of the distribution.
Cumulative is a logical value that determines the form of the function.    If 

cumulative is TRUE, NORMDIST returns the cumulative distribution function; if FALSE, it 
returns the probability mass function.
Example

NORMDIST(42,40,1.5) = 0.908789
See Also

Help
NORMINV Returns the inverse of the normal cumulative distribution.
NORMSDIST Returns the standard normal cumulative distribution.
NORMSINV Returns the inverse of the standard normal cumulative distribution.
STANDARDIZE Returns a normalized value.
ZTEST Returns the P-value of a z test.
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NORMSDIST(z)
Returns the standard normal cumulative distribution function.    The distribution has a mean 
of zero and a standard deviation of one.    Use this function in place of a table of standard 
normal curve areas.

Z is the value for which you want the distribution. 
Example

NORMSDIST(1.333333) = 0.908789
See Also

Help
NORMDIST Returns the normal cumulative distribution.
NORMINV Returns the inverse of the normal cumulative distribution.
STANDARDIZE Returns a normalized value.
NORMSINV Returns the inverse of the standard normal cumulative distribution 

function.
ZTEST Returns the P-value of a z test.
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NORMINV(probability,mean,standard_dev)
Returns the inverse of the normal cumulative distribution for the specified mean and 
standard deviation.

Probability is a probability corresponding to the normal distribution.
Mean is the arithmetic mean of the distribution.
Standard_dev is the standard deviation of the distribution.

Example
NORMINV(0.908789,40,1.5) = 42

See Also
Help
NORMDIST Returns the normal cumulative distribution.
NORMSDIST Returns the standard normal cumulative distribution.
NORMSINV Returns the inverse of the standard normal cumulative distribution.
STANDARDIZE Returns a normalized value.
ZTEST Returns the P-value of a z-test.
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NORMSINV(probability)
Returns the inverse of the standard normal cumulative distribution.    The distribution has a 
mean of zero and a standard deviation of one.

Probability is a probability corresponding to the normal distribution.
Example

NORMSINV(0.908789) = 1.333333
See Also

Help
NORMDIST Returns the normal cumulative distribution.
NORMINV Returns the inverse of the normal cumulative distribution.
NORMSDIST Returns the standard normal cumulative distribution.
STANDARDIZE Returns a normalized value.
ZTEST Returns the P-value of a z-test.
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ODD(number)
Returns number rounded up to the nearest odd integer.

Number is the value to round. Regardless of the sign of number, ODD rounds 
number away from zero.
Examples

ODD(1.5) = 3
ODD(3) = 3
ODD(2) = 3
ODD(-1) = -1
ODD(-2) = -3

See Also
Help
CEILING Rounds a number up, away from zero.
EVEN Rounds a number up to the nearest even integer.
FLOOR Rounds a number down, towards zero.
INT Rounds a number down to the nearest integer.
ROUND Rounds a number to a specified number of digits.
TRUNC Truncates a number to an integer.
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PEARSON(array1,array2)
Returns the Pearson product moment correlation coefficient, r, a dimensionless index that 
ranges from -1.0 to 1.0 inclusive, and reflects the extent of a linear relationship between 
two data sets.

Array1 is an array or range of independent values.
Array2 is an array or range of dependent values.

Example
PEARSON({9,7,5,3,1},{10,6,1,5,3}) = 0.699379

See Also
Help
INTERCEPT Returns the intercept of the linear regression line.
LINEST Returns parameters of a linear trend.
RSQ Returns the r2 value of the linear regression line.
SLOPE Returns the slope of the linear regression line.
STEYX Returns the standard error of the predicted y-value for each x in the 

regression.
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PERCENTILE(array,k)
Returns the value from array at the k-th percentile.    You can use this function to establish 
a threshold of acceptance.    For example, you can decide to examine candidates that score 
above the 90th percentile.

Array is the array or range of data which defines relative standing. 
K is the percentile value in the range 0...1, inclusive.

Example
PERCENTILE({1,2,3,4},0.3) = 1.2

See Also
Help
LARGE Returns the k-th largest value from a data set.
MAX Returns the maximum value in a data set.
MEDIAN Returns the middle value in a data set.
MIN Returns the minimum value in a data set.
PERCENTRANK Returns the percentage rank of a value in a data set.
QUARTILE Returns a quartile of a data set.
SMALL Returns the k-th smallest value from a data set.
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PERCENTRANK(array,x,significance)
Returns the percentage rank of x among the values in array.    This function can be used to 
evaluate the relative standing of an observation in a data set.

Array is the array or range of data with numeric values that defines relative 
standing.

X is the value for which you want to know the rank.
Significance is an optional value that identifies the number of significant digits for 

the returned percentage value.    If omitted, PERCENTRANK uses three digits (0.xxx%).
Example

For an example of this function, see PERCENTRANK in the Microsoft Excel Function 
Reference.

See Also
Help
LARGE Returns the k-th largest value from a data set.
MAX Returns the maximum value in a data set.
MEDIAN Returns the middle value in a data set.
MIN Returns the minimum value in a data set.
PERCENTILE Returns the k-th percentile of values in a range.
QUARTILE Returns the quartile of a data set.
SMALL Returns the k-th smallest value from a data set.
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PERMUT(number,number_chosen)
Returns the number of permutations of groups of number_chosen objects that can be 
selected from number objects.    A permutation is any set or subset of objects or events 
where internal order is significant.    Permutations are different than combinations, for which 
the internal order is not significant. Use this function for lottery-style probability 
calculations.

Number is an integer that describes the number of objects.
Number_chosen is an integer that describes the number of objects in each 

permutation.
Example

Suppose you want to calculate the odds of selecting a winning lottery number.    Each 
lottery number contains three numbers, each of which can be between 0 and 99, 
inclusive.    The following function calculates the number of possible permutations.
PERMUT(100,3) = 970,200

See Also
Help
BINOMDIST Returns the binomial distribution.
COMBIN Returns the number of combinations for a given number of objects.
CRITBINOM Returns the smallest value for which the cumulative binomial distribution

is less than or equal to a criterion value.
FACT Returns the factorial of a number.
HYPGEOMDIST Returns the hypergeometric distribution.
NEGBINOMDIST Returns the negative binomial distribution.
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POISSON(x,mean,cumulative)
Returns the Poisson probability distribution.    A common application of the Poisson 
distribution is predicting the number of events over a specific time, such as the number of 
cars arriving at a toll plaza in one minute.

X is the number of events.
Mean is the expected numeric value.
Cumulative is a logical value that determines the form of the probability distribution 

returned.    If cumulative is TRUE, POISSON returns the cumulative Poisson probability that 
the number of random events occurring will be between 0 and x inclusive; if FALSE, it 
returns the Poisson probability mass function that the number of events occurring will be 
exactly x.
Examples

POISSON(2,5,FALSE) = 0.084224
POISSON(2,5,TRUE) = 0.124652

Related Functions      
EXPONDIST Returns the exponential distribution.
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PROB(x_range,prob_range,lower_limit,upper_limit)
Returns the probability that values in x_range are between the lower_limit and 
upper_limit.    If upper_limit is not supplied, returns the probability that values in x_range
are equal to lower_limit.

X_range is the range of numeric values of x with which there are associated 
probabilities.

Prob_range is a set of probabilities associated with values in x_range.
Lower_limit is the lower bound on the value for which you want a probability.
Upper_limit    is the optional upper bound on the value for which you want a 

probability.
Examples

PROB({0,1,2,3},{0.2,0.3,0.1,0.4},2) = 0.1
PROB({0,1,2,3},{0.2,0.3,0.1,0.4},1,3) = 0.8

See Also
Help
BINOMDIST Returns the individual term binomial distribution.
CRITBINOM Returns the smallest value for which the cumulative binomial distribution 

is less than or equal to a criterion value.
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QUARTILE (array,quart)
Returns a quartile from the data points in array. Quartiles often are used in sales and 
survey data to divide populations into groups.    For example, you can use QUARTILE to find 
the top 25% of incomes in a population.

Array is the array or cell range of numeric values for which you want the quartile 
value.

Quart indicates which value to return.
If quart equals QUARTILE returns
0 Minimum value
1 First quartile (25th percentile)
2 Median value (50th percentile)
3 Third quartile (75th percentile)
4 Maximum value

Example
QUARTILE({1,2,4,7,8,9,10,12},1) = 3.5

See Also
Help
LARGE Returns the k-th largest value from a data set.
MAX Returns the maximum value in a data set.
MEDIAN Returns the middle value in a data set.
MIN Returns the minimum value in a data set.
PERCENTRANK Returns the percentage rank of a value in a data set.
PERCENTILE Returns the k-th percentile of values in a range.
SMALL Returns the k-th smallest value from a data set.
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RSQ(known_y's,known_x's)
Returns the r2 value of the linear regression line through data points in known_y's and 
known_x's.    The r2 value is the square of the Pearson product moment correlation 
coefficient.    The r2 value can be interpreted as the proportion of the variance in y 
attributable to the variance in x. 

Known_y's is an array or range of data points.
Known_x's is an array or range of data points.

Example
RSQ({2,3,9,1,8,7,5},{6,5,11,7,5,4,4}) = 0.05795

See Also
Help
CORREL Returns the correlation coefficient of two data sets.
COVAR Returns covariance, the average of the products of paired deviations.
INTERCEPT Returns the intercept of the linear regression line.
LINEST Returns parameters of a linear trend.
LOGEST Returns parameters of an exponential trend.
PEARSON Returns the Pearson product moment correlation coefficient.
SLOPE Returns the slope of the linear regression line.
STEYX Returns the standard error of the predicted y value for each x in the 

regression.
TREND Returns values along a linear trend.
List of Statistical Functions



SKEW(number1,number2,...)
Returns the skewness of a distribution.    Skewness characterizes the degree of asymmetry 
of a distribution around its mean.    Positive skewness indicates a distribution with an 
asymmetric tail extending towards more positive values.    Negative skewness indicates a 
distribution with an asymmetric tail extending towards more negative values.

Number1,number2,... are 1 to 30 arguments for which you want to calculate 
skewness.
Example

SKEW(3,4,5,2,3,4,5,6,4,7) = 0.359543
See Also

Help
KURT Returns the kurtosis of a data set.
STDEV Estimates standard deviation based on a sample.
STDEVP Calculates standard deviation based on the entire population.
VAR Estimates variance based on a sample.
VARP Calculates variance based on the entire population.
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SLOPE(known_y's,known_x's)
Returns the slope of the linear regression line through data points in known_y's and 
known_x's.    The slope is the vertical distance divided by the horizontal distance between 
any two points on the line, which is the rate of change along the regression line.

Known_y's is an array or cell range of numeric dependent data points.
Known_x's is the set of independent data points.

Example
SLOPE({2,3,9,1,8,7,5},{6,5,11,7,5,4,4}) = 0.305556

See Also
Help
INTERCEPT Returns the intercept of the linear regression line.
LINEST Returns parameters of a linear trend.
LOGEST Returns parameters of an exponential trend.
PEARSON Returns the Pearson product moment correlation coefficient.
RSQ Returns the r2 value of the linear regression line.
STEYX Returns the standard error of the predicted y value for each x in the 

regression.
TREND Returns values along a linear trend.
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SMALL(array,k)
Returns the k-th smallest value in a data set.    Use this function to return values with a 
particular relative standing in a data set.

Array is an array or range of numerical data for which you want to determine the k-
th smallest value.

K is the position (from the smallest) in array or range of data to return.
Examples

SMALL({3,4,5,2,3,4,5,6,4,7},4) = 4
SMALL({1,4,8,3,7,12,54,8,23},2) = 3

See Also
Help
LARGE Returns the k-th largest value from a data set.
MAX Returns the maximum value in a data set.
MEDIAN Returns the middle value in a data set.
MIN Returns the minimum value in a data set.
PERCENTILE Returns the k-th percentile of values in a range.
PERCENTRANK Returns the percentage rank of a value in a data set.
QUARTILE Returns the quartile of a data set.
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STEYX(known_y's,known_x's)
Returns the standard error of the regression.    The standard error is a measure of the 
amount of error in the prediction of y for an individual x.

Known_y's is an array or range of dependent data points.
Known_x's is an array or range of independent data points.

Example
STEYX({2,3,9,1,8,7,5},{6,5,11,7,5,4,4}) = 3.305719

See Also
Help
INTERCEPT Returns the intercept of the linear regression line.
LINEST Returns parameters of a linear trend.
LOGEST Returns parameters of an exponential trend.
PEARSON Returns the Pearson product moment correlation coefficient.
RSQ Returns the r2 value of the linear regression line.
SLOPE Returns the slope of the linear regression line.
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SUMX2MY2(array_x,array_y)
Returns the sum of the difference of squares of corresponding values in two arrays. 

Array_x is the first array or range of values.
Array_y is the second array or range of values.

Example
SUMX2MY2({2,3,9,1,8,7,5},{6,5,11,7,5,4,4}) = -55

See Also
Help
SUMPRODUCT Returns the sum of the product of corresponding values in two arrays.
SUMX2PY2 Returns the sum of the sum of squares of corresponding values in two 

arrays.
SUMXMY2 Returns the sum of squares of differences of corresponding values in two 

arrays.
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SUMX2PY2(array_x,array_y)
Returns the sum of the sum of squares of corresponding values in two arrays.    The sum of 
the sum of squares is a common term in many statistical calculations.

Array_x is the first array or range of values.
Array_y is the second array or range of values.

Example
SUMX2PY2({2,3,9,1,8,7,5},{6,5,11,7,5,4,4}) = 521

See Also
Help
SUMPRODUCT Returns the sum of the product of corresponding values in two arrays.
SUMX2MY2 Returns the sum of the difference of squares of corresponding values in 

two arrays.
SUMXMY2 Returns the sum of squares of differences of corresponding values in two 

arrays.
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SUMXMY2(array_x,array_y)
Returns the sum of squares of differences of corresponding values in two arrays.

Array_x is the first array or range of values.
Array_y is the second array or range of values.

Example
SUMXMY2({2,3,9,1,8,7,5},{6,5,11,7,5,4,4}) = 79

See Also
Help
SUMPRODUCT Returns the sum of the product of corresponding values in two array.
SUMX2MY2 Returns the sum of the difference of squares of corresponding values in 

two arrays. 
SUMX2PY2 Returns the sum of the sum of squares of corresponding values in two 

arrays.
List of Math & Trig Functions



TDIST(x,degrees_freedom,tails)
Returns the Student's t-distribution.    The t-distribution is used in the hypothesis testing of 
small sample data sets.    Use this function in place of a table of critical values for the t-
distribution.

X is the numeric value at which to evaluate the distribution.
Degrees_freedom is an integer indicating the number of degrees of freedom.
Tails specifies the number of distribution tails to return.    If tails = 1, TDIST returns 

the one-tailed distribution.    If tails = 2, TDIST returns the two-tailed distribution.
Example

TDIST(1.96,60,2) = 0.054645
See Also

Help
TINV Returns the inverse of the Student's t distribution.
TTEST Returns the probability associated with a Student's t-Test.
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TRIMMEAN(array,percent)
Returns the mean taken by excluding a percentage of data points from the top and bottom 
tails of a data set.    You can use this function when you wish to exclude outlying data from 
your analysis.

Array is the array or range of values to trim and average.
Percent is the fractional number of data points to exclude from the calculation. For 

example, if a data set has 20 points and percent = 0.2, 4 points are trimmed from the data 
set (20 x 0.2), two from the top and two from the bottom.
Example

TRIMMEAN({4,5,6,7,2,3,4,5,1,2,3},0.2) = 3.777778
See Also

Help
AVERAGE Returns the arithmetic mean.
HARMEAN Returns the harmonic mean.
GEOMEAN Returns the geometric mean.
MEDIAN Returns the middle value in a data set.
MODE Returns the most common value in a data set.
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TTEST(array1,array2,tails,type)
Returns the probability associated with a Student's t-Test. Use TTEST to determine whether 
two samples are likely to have come from the same two underlying populations that have 
the same mean.

Array1 is an array or range containing the first data set.
Array2 is an array or range containing the second data set.
Tails specifies the number of distribution tails. If tails = 1, TTEST uses the one-tailed 

distribution. If tails = 2, TTEST uses the two-tailed distribution.
Type is the kind of t test to perform.

If type equals This test is performed
1 Paired
2 Two-sample equal variance (homoscedastic)
3 Two-sample unequal variance (heteroscedastic)

Example
TTEST({3,4,5,8,9,1,2,4,5},{6,19,3,2,14,4,5,17,1},2,1) = 0.191996

See Also
Help
TDIST Returns the Student's t-distribution.
TINV Returns the inverse of the Student's t-distribution.
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WEIBULL(x,alpha,beta,cumulative)
Returns the Weibull distribution. Use this distribution in reliability analysis, such as 
calculating a device's mean time to failure.

X is the value at which to evaluate the function.
Alpha is a parameter to the distribution.
Beta is a parameter to the distribution.
Cumulative determines the form of the function. If cumulative is TRUE, WEIBULL 

returns the cumulative distribution function; if FALSE, it returns the probability density 
function.
Examples

WEIBULL(105,20,100,TRUE) = 0.929581
WEIBULL(105,20,100,FALSE) = 0.035589

See Also
Help
EXPONDIST Returns the exponential distribution.
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ZTEST(array,x,sigma)
Returns the two-tailed P-value of a z-test.    The z-test generates a standard score for x with 
respect to the data set, array, and returns the two-tailed probability for the normal 
distribution.    You can use this function to assess the likelihood that a particular observation 
is drawn from a particular population.

Array is the array or range of data against which to test x.
X is the value to test.
Sigma is the population (known) standard deviation. If omitted, the sample standard 

deviation is used.
Example

ZTEST({3,6,7,8,6,5,4,2,1,9},4) = 0.090574
See Also

Help
CONFIDENCE Returns a confidence interval for a population.
NORMDIST Returns the normal cumulative distribution.
NORMINV Returns the inverse of the normal cumulative distribution.
NORMSDIST Returns the standard normal cumulative distribution.
NORMSINV Returns the inverse of the standard normal cumulative distribution.
STANDARDIZE Returns a normalized value.
List of Statistical Functions



STANDARDIZE(x,mean,standard_dev)
Returns a normalized value from a distribution characterized by mean and standard_dev.

X is the value you want to normalize.
Mean is the arithmetic mean of the distribution. 
Standard_dev is the standard deviation of the distribution.

Example
STANDARDIZE(42,40,1.5) = 1.333333

See Also
Help
NORMDIST Returns the normal cumulative distribution.
NORMINV Returns the inverse of the normal cumulative distribution.
NORMSDIST Returns the standard normal cumulative distribution.
NORMSINV Returns the inverse of the standard normal cumulative distribution.
ZTEST Returns the P-value of a z-test.
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TINV(probability,degrees_freedom)
Returns the inverse of the Student's t-distribution for the specified degrees of freedom.

Probability is the probability associated with the Student's t-distribution.
Degrees_freedom is the number of degrees of freedom to characterize the 

distribution.
Example

TINV(0.054645,60) = 1.96
See Also

Help
TDIST Returns the Student's t-distribution.
TTEST Returns the probability associated with a Student's t-Test.
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SUMSQ(number1,number2,...)
Returns the sum of the squares of the arguments.

Number1, number2,... are 1 to 30 arguments for which you want the sum of the 
squares.    You can also use a single array or a reference to an array instead of arguments 
separated by commas.
Example

SUMSQ(3,4) = 25
See Also

Help
SUM Returns the sum of its arguments.
SUMPRODUCT Returns the sum of the products of corresponding array elements.
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RANK(number,ref,order)
Returns the rank of a number in a list of numbers.    The rank of a number is its size relative 
to other values in a list.    (If you were to sort the list, the rank of the number would be its 
position.)

Number is the number whose rank you want to find.
Ref is an array of, or a reference to, a list of numbers. Non-numeric values in ref are 

ignored.
Order is a number specifying how to rank number.    If order is 0 or omitted, 

number is ranked as if ref were a list sorted in descending order; if any non-zero value, 
number is ranked as if ref were a list sorted in ascending order.

Duplicate numbers receive the same rank.
Examples

If A1:A5 contain the numbers 7, 3.5, 3.5, 1, and 2, respectively, then:
RANK(A2,A1:A5,1) = 3
RANK(A1,A1:A5,1) = 5 

See Also
Help
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CHAR(number)
Returns the ANSI character corresponding to the code number.
Number can be any number between 1 and 255.
Examples

CHAR(65) = "A"
CHAR(33) = "!"

See Also
Help
CODE Returns the ANSI code for a character.
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CLEAN(text)
Removes all nonprintable characters from text.
Examples

CHAR(7) = a nonprintable character, therefore:
CLEAN(CHAR(7)&"text"&CHAR(7)) = "text"

See Also
Help
CODE Returns the ANSI code for a character.
TRIM Removes spaces from text.
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CODE(text)
Returns the numeric ANSI code of the first character in text.
Example

CODE("Alphabet") = 97
See Also

Help
CHAR Returns character corresponding to an ANSI code.
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DOLLAR(number,decimals)
Rounds number to decimals, formats it in currency format, and returns the result as text.   
The format used is $#,##0.00_);($#,##0.00).
The DOLLAR function converts its result to text.    A number formatted with the Number 
command on the Format menu is not converted to text; it remains a number.

Decimals is the number of digits to the right of the decimal point.
If negative, number is rounded to the left of the decimal point.
If omitted, number is assumed to be 2.

Examples
DOLLAR(1234.567,2) = $1,234.57
DOLLAR(1234.567,-2) = $1,200
DOLLAR(-1234.567,-2) = ($1,200)
DOLLAR(-0.123,4) = ($0.1230)
DOLLAR(99.888) = $99.89

See Also
Help
FIXED Formats a number as text with a fixed number of decimals.
TEXT Formats a number and converts it to text.
VALUE Converts a text argument into a number.
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EXACT(text1,text2)
Returns the logical value TRUE if text1 and text2 are exactly the same; otherwise, returns 
FALSE.    EXACT is case-sensitive but ignores formatting differences.
Examples

EXACT("word","word") = TRUE
EXACT("Word","word") = FALSE
EXACT("w ord","word") = FALSE

See Also
Help
LEN Returns the number of characters in a text string.
SEARCH Finds one text value within another (not case sensitive).
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FIND(find_text,within_text,start_at_num)
Finds find_text within within_text, starting the search at character specified by 
start_at_num.    Returns the number of the character at which find_text first occurs.

If find_text does not appear within within_text, if start_at_num is not greater than
zero, or if start_at_num is greater than the length of within_text, FIND returns the error 
value #VALUE!.

If find_text is "", FIND matches the first character in the search string (the character 
numbered start_at_num or 1).

Find_text cannot contain wildcards.
Within_text is the text or reference to the cell containing the text you want to find.
Start_at_num is optional.    If omitted, it is assumed to be 1.

Examples
FIND("A","Average VanGun") = 1
FIND("a","Average VanGun") = 5
FIND("V","Average VanGun") = 9
FIND("v","Average VanGun") = 2

See Also
Help
EXACT Checks two text values to see if they are identical.
LEN Returns the number of characters in a text string.
SEARCH Finds one text value within another (not case sensitive).
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LEFT(text,num_chars)
Returns text consisting of the first num_chars characters in text.

The first character in text has position 1.
Letters, spaces, punctuation marks, and numbers are counted as characters.
Text must be text enclosed in quotation marks or a reference to a cell containing 

text.
Num_chars must be greater than zero.
If num_chars is greater than length of text, returns entire text.
If num_chars is omitted, it is assumed to be 1.

Examples
LEFT("two three four",3) = "two"
LEFT("abalone") = "a"
If cell C12 contains the text "Paul Irving", then LEFT(C12,4) = "Paul"

See Also
Help
MID Returns a specific number of characters from a text string starting at the 

position you specify.
RIGHT Returns the rightmost characters from a text value.
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LEN(text)
Returns the number of characters in text.    Letters, spaces, punctuation marks, and 
numbers are counted as characters. 
Examples

LEN("fox") = 3
LEN("Phoenix, AZ") = 11
LEN("") = 0
If cell A3 contains the text "Michigan":
LEN(A3) = 8

See Also
Help
EXACT Checks to see if two text values are identical.
SEARCH Finds one text value within another (not case sensitive).
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LOWER(text)
Returns text in lowercase letters.    Characters in text that are not letters are unchanged.
Examples

LOWER("E.E. Cummings") = "e.e. cummings"
LOWER("Apt. 2B") = "apt. 2b"

See Also
Help
PROPER Returns text with the first letter in each word capitalized.
UPPER Returns text in capital letters.
List of Text Functions



MID(text,start_num,num_chars)
Returns text string from within text, starting with the character at start_num and having a 
length of num_chars.

The first character in text has position 1, and so on.
Letters, spaces, punctuation marks, and numbers are characters. 
If start_num is less than 1, returns #VALUE!.
If start_num is greater than the length of text, returns "" (the empty text).
If num_chars is negative, returns #VALUE!.
If num_chars plus start_num exceeds the length of text, returns characters from 

start_num to the end of text.
Examples

MID("Hello there",1,5) = "Hello"
MID("Hello there",7,20) = "there"
MID("cat",4,4) = "" (empty text)

See Also
Help
LEFT Returns the leftmost characters from a text value.
RIGHT Returns the rightmost characters from a text value.
TRIM Removes excess spaces from text.
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PROPER(text)
Capitalizes the first letter of each word in text and any other letters in text that follow any 
character other than a letter.    Converts all other letters to lowercase.    Characters in text 
that are not letters are unchanged.
Examples

PROPER("this is a TITLE") ="This Is A Title"
PROPER("2-cent's worth") ="2-Cent'S Worth"
PROPER("76tromBones") ="76Trombones"

See Also
Help
LOWER Converts uppercase text to lowercase.
UPPER Converts lowercase text to uppercase.
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REPLACE(old_text,start_num,num_chars,new_text)
Removes num_chars characters from old_text starting at start_num, and then replaces 
them with new_text.

First character in the text is numbered 1.
Examples

REPLACE("abcde",1,1,"*") ="*bcde"
REPLACE("abcde",3,2,"*") ="ab*e"
REPLACE("1991",3,2,"92") = "1992"

See Also
Help
MID Returns a specific number of characters from a text string starting at the 

position you specify.
SEARCH Finds one text value within another (not case sensitive).
SUBSTITUTE Substitutes new text for old text in a text string.
TRIM Removes spaces from text.
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REPT(text,number_times)
Repeats text a specified number_times to make a new text value.    The result cannot be 
longer than 255 characters.

Number_times must be greater than or equal to 0.
If 0, REPT returns "" (empty text).
If number_times is not an integer, it is truncated.

Examples
REPT("*-",3) ="*-*-*-"
REPT("Louie ",2.9) ="Louie Louie "

See Also
Help
List of Text Functions



RIGHT(text,num_chars)
Returns the last num_chars characters in text.

Num_chars must be greater than zero.
If num_chars is greater than the length of text, returns entire text.
If num_chars is omitted, it is assumed to be 1.

Examples
RIGHT("Paul Irving",6) ="Irving"
RIGHT("Hedgehog?") ="?"

See Also
Help
LEFT Returns the leftmost characters from a text value.
MID Returns a specific number of characters from a text string starting at the 

position you specify.
List of Text Functions



SEARCH(find_text,within_text,start_num)
Searches for find_text within within_text.    Ignores case distinctions.    Starts search at 
character specified by start_num.    First character in within_text is character number 1.    
SEARCH returns the number of the character at which find_text first occurs.

Returns the error value #VALUE! if:
find_text does not appear within within_text,
start_num is not greater than zero, or
start_num is greater than the length of within_text.

If you omit start_num, it is assumed to be 1.
If find_text is "", it will match the first character that is searched (character 

numbered start_num).
Find_text may contain the following wildcard characters:

?    Indicates that any single character can occupy that position.
*    Indicates that any sequence of characters can occupy that position.

Examples
SEARCH("e","Beautiful Noise") = 2
SEARCH("e","Beautiful Noise",2) = 2
SEARCH("","Beautiful Noise",7) = 7
SEARCH("u*i","Beautiful Noise",1) = 4
SEARCH("u*i","Beautiful Noise",5) = 8

See Also
Help
EXACT Checks to see if two text values are identical.
FIND Finds one text value within another (case-sensitive).
LEN Returns the number of characters in a text string.
List of Text Functions



SUBSTITUTE(text,old_text,new_text,instance_num)
Substitutes new_text for old_text in text.    If you specify instance_num, only that 
instance of old_text is replaced.    Otherwise, every old_text in text is changed to 
new_text.
Examples

SUBSTITUTE("waffles","f","d") = "waddles"
SUBSTITUTE("Ann And Nick","An","Da",1) = "Dan And Nick"
SUBSTITUTE("Ann And Nick","An","Da",2) = "Ann Dad Nick"
SUBSTITUTE("Ann And Nick","An","Da") = "Dan Dad Nick"
SUBSTITUTE("hi de hi","hi","Ho",2) = "hi de Ho"

See Also
Help
REPLACE Removes and replaces specified characters within text.
TRIM Removes spaces from text.
List of Text Functions



TEXT(value,format_text)
Formats value as specified by format_text; returns result as text.
Format_text must be formatted as text, as described in Chapter 7 in Book 2 of the 
Microsoft Excel User's Guide, however, format_text cannot contain an asterisk (*) and the 
format cannot be "General".    
Examples

TEXT(2.715, "$0.00") = "$2.72"
TEXT("4/15/1991","mmmm d, yyyy") = "April 15, 1991"

See Also
Help
DOLLAR Converts a number to text, using currency format.
FIXED Formats a number as text with a fixed number of decimals.
T Converts its arguments to text.
VALUE Converts a text argument to a number.
List of Text Functions



TRIM(text)
Removes all spaces from text, except for one space between words.
Examples

TRIM("      the        final      frontier...      ") = "the final frontier..."
TRIM("    4 score and 7 years ago ,") = "4 score and 7 years ago,"

See Also
Help
CLEAN Removes all nonprintable characters from text.
REPLACE Replaces characters within text.
SUBSTITUTE Substitutes new text for old text in a text string.
List of Text Functions



UPPER(text)
Returns text in uppercase letters.    Characters in text that are not letters are unchanged.
Examples

UPPER("How are you?") = "HOW ARE YOU?"
UPPER("45 cats") = "45 CATS"

See Also
Help
LOWER Returns text in lowercase letters.
PROPER Returns text with the first letter of each word capitalized.
List of Text Functions



VALUE(text)
Converts text to a number.
Text can be in any of the constant number, date, or time formats recognized by Microsoft 
Excel.    If it is not in one of those formats, VALUE returns the error value #VALUE!.
It is not necessary to use the VALUE function in a formula; Microsoft Excel automatically 
converts text to numbers as necessary.    This function is provided for compatibility with 
other worksheet programs.
Examples 

VALUE("$1,000") = 1000
VALUE("16:48:00")-VALUE("12:00:00") = 0.2 (the serial number equivalent to 4 hours and 
48 minutes)

See Also
Help
DOLLAR Converts a number to text, using currency format.
FIXED Formats a number as text with a fixed number of decimals.
TEXT Formats a number and converts it to text.
List of Text Functions



FIXED(number,decimals,no_commas)
Rounds number to decimals in decimal format using a period and commas, and returns 
the result as text.
FIXED converts its result to text.    A number formatted with the Number command on the 
Format menu, however, is not converted to text but remains a number.

Number is the number you want to round and convert to text.
Decimals is the number of digits to the right of the decimal point.
No_commas is a logical value that, if TRUE, prevents fixed from including commas 

in the returned text.    If no_commas is FALSE or omitted, then the returned text includes 
commas as usual.

If decimals is negative, number is rounded to the left of the decimal point.
If decimals is omitted, it is assumed to be 2.
Decimals can be as large as 127, but numbers in Microsoft Excel never have more 

than 15 significant digits.
Examples

FIXED(1234.567,1) = "1,234.6"
FIXED(1234.567,-1) = "1,230"
FIXED(-1234.567,-1) = "-1,230"
FIXED(44.332) = "44.33"

See Also
Help
DOLLAR Converts a number to text, using currency format.
ROUND Rounds a number to a specified number of digits.
TEXT Formats a number and converts it to text.
VALUE Converts a text argument to a number.
List of Text Functions



ACOS(number)
Returns the arccosine of number in radians from 0 to pi.    The arccosine is the angle whose 
cosine is number.

Number must be in the range -1 to 1.
To express the arccosine in degrees, multiply the result by 180/PI().

Examples
ACOS(-0.5) = 2.094 ((2*pi) /3 radians)
ACOS(-0.5)*180/PI() = 120 degrees

See Also
Help
COS Returns the cosine of a number.
PI Returns the value pi.
List of Math & Trig Functions



ACOSH(number)
Returns the inverse hyperbolic cosine of number.    Number must be greater than or equal 
to 1.
Examples

ACOSH(3) = 1.762747
ACOSH(3.25) = 1.847246

See Also
Help
ACOS Returns the arccosine of a number.
COS Returns the cosine of a number.
COSH Returns the hyperbolic cosine of a number.
List of Math & Trig Functions



ASIN(number)
Returns the arcsine of number in radians from -pi/2 to pi/2.    The arcsine is the angle whose 
sine is number.

Number must be in the range -1 to 1.
To express the arcsine in degrees, multiply the result by 180/PI().

Examples
ASIN(-0.5) = -0.52 (-pi/6 radians)
ASIN(-0.5)*180/PI() = -30 degrees

See Also
Help
PI Returns the value pi.
SIN Returns the sine of a number.
List of Math & Trig Functions



ASINH(number)
Returns the inverse hyperbolic sine of number.
Examples

ASINH(-2.5) = -1.64723
ASINH(10) = 2.998223

See Also
Help
ACOSH Returns the inverse hyperbolic cosine of a number.
ATANH Returns the inverse hyperbolic tangent of a number.
SINH Returns the hyperbolic sine of a number.
List of Math & Trig Functions



ATAN(number)
Returns the arctangent of number in radians from -pi/2 to pi/2.

The arctangent is the angle whose tangent is number.
To express the arctangent in degrees, multiply the result by 180/PI().

Examples
ATAN(1) = 0.785 (pi/4 radians)
ATAN(1)*180/PI() = 45 degrees

See Also
Help
ATAN2 Returns the arctangent from x and y coordinates.
PI Returns the value pi.
TAN Returns the tangent of a number.
List of Math & Trig Functions



ATAN2(x_num,y_num)
Returns the arctangent of the x and y coordinates represented by x_num and y_num.    The 
angle is given in radians from -pi to pi, excluding -pi.

The arctangent is the angle from the x-axis to the coordinates x_num, y_num.
A positive result represents a counterclockwise angle from the x-axis; a negative 

result represents a clockwise angle.
To express the result in degrees, multiply it by 180/PI().
If both x_num and y_num are 0, returns the error value #DIV/0!

Examples
ATAN2(1,1) = 0.785398 (pi /4 radians)
ATAN2(-1,-1) = -2.35619 (-3*pi/4 radians)
ATAN2(-1,-1)*180/PI() = -135 (degrees)

See Also
Help
ATAN Returns the arctangent of a number.
ATANH Returns the inverse hyperbolic tangent of a number.
PI Returns the value pi.
TAN Returns the tangent of a number.
List of Math & Trig Functions



ATANH(number)
Returns the inverse hyperbolic tangent of number.    Number must be greater than -1 and 
less than 1.
Examples

ATANH(0.25) = 0.255413
ATANH(0.50) = 0.549306

See Also
Help
ATAN Returns the arctangent of a number.
ATAN2 Returns the arctangent from x and y coordinates.
TAN Returns the tangent of a number.
TANH Returns the hyperbolic tangent of a number.
List of Math & Trig Functions



COS(number)
Returns the cosine of the given angle.    Number is the angle in radians for which you want 
the cosine.
If argument is in degrees, multiply the argument by PI()/180 to convert to radians.
Examples

COS(PI()/2) = 0
COS(1.047) = 0.5
COS(60*PI()/180) = 0.5

See Also
Help
ACOS Returns the arccosine of a number.
PI Returns the value pi.
List of Math & Trig Functions



COSH(number)
Returns the hyperbolic cosine of number.
Example

COSH(4) = 27.30823
See Also

Help
ACOSH Returns the inverse hyperbolic cosine of a number.
SINH Returns the hyperbolic sine of a number.
TANH Returns the hyperbolic tangent of a number.
List of Math & Trig Functions



SIN(number)
Returns the sine of number, where number is the angle given in radians.
If argument is in degrees instead of radians, multiply number by PI()/180.
Examples

SIN(PI()/2) = 1
SIN(30*PI() /180) = 0.5

See Also
Help
ASIN Returns the arcsine of a number.
PI Returns the value pi.
List of Math & Trig Functions



SINH(number)
Returns the hyperbolic sine of number.
Examples

SINH(3) = 10.01787
SINH(3.25) = 12.87578

See Also
Help
ASIN Returns the arcsine of a number.
ASINH Returns the inverse hyperbolic sine of a number.
SIN Returns the sine of a number.
List of Math & Trig Functions



TAN(number)
Returns the tangent of a given angle.    Number is the angle in radians for which you want 
the tangent.
If argument is in degrees instead of radians, multiply the argument by PI()/180.
Examples

TAN(0.785) = 0.99204
TAN(45*PI()/180) = 1

See Also
Help
ATAN Returns the arctangent of a number.
ATAN2 Returns the arctangent, given the x- and y-coordinates.
PI Returns the value pi.
List of Math & Trig Functions



TANH(number)
Returns the hyperbolic tangent of number.
Examples

TANH(-2) = -0.96403
TANH(0) = 0
TANH(0.5) = 0.462117

See Also
Help
ATANH Returns the inverse hyperbolic tangent of a number.
COSH Returns the hyperbolic cosine of a number.
SINH Returns the hyperbolic sine of a number.
List of Math & Trig Functions



Printing Dialog Box
You used the Print command on the File menu to print a document.    This dialog box 
indicates that the printing process has begun. 
If you want to cancel printing, choose the Cancel button.



Change Links Dialog Box
Allows you to redirect links to the dependent worksheet.
File Name

Lists the files of the specified type in the current directory.
Select or type the name of the file you want.

Directories
Lists the available directories.
To change directories, double-click one of the directories on the list, or select a directory 
from the list and choose the OK button.

List Files Of Type
Lists the available file formats.

Drives
Lists the available drives.
To change drives, double-click one of the drives on the list, or select a drive from the list 
and choose the OK button.

See Also
Help
Links Command (File Menu)
Creating links between documents
Linking and Embedding
Recalculating linked worksheets
Redirecting links for source documents



DDE Dialog Box
More than one application has responded to your DDE request.
Select the application from which you want to receive data, and then choose the OK button.



Document Password Dialog Box
You are trying to do one of the following things:

Open a document that was protected with a password.
Remove protection from a document that was protected with a password.
Hide a window that was protected with a password.
Display a hidden window that was protected with a password.

To continue, type the correct password in this dialog box.
See Also

Help
Protecting a document
Protecting windows



Promote or Demote Dialog Box
You are trying to do one of the following things:

Promote selected rows or columns to a higher level in an outline.
Demote selected rows or columns to a lower level in an outline.    

You can create an outline manually by demoting rows or columns.
Rows

Promotes or demotes rows to outline information horizontally.
Columns

Promotes or demotes columns to outline information vertically.



Macro Input Dialog Box
You are running a macro that contains the INPUT function.    Use this dialog box to enter a 
single value, an array, or a formula into the macro.

Enter the type of data requested by the dialog box prompt.
You can move the dialog box by dragging its title bar.
Depending on how the macro was written, one or more of the following data types 

may be accepted:
Formula
Number
Text
Logical value
Reference
Array
Error value



Macro Interrupt/Error Dialog Box
You have interrupted a macro while it was running, or an error has occurred in the macro.    
This dialog box allows you to step through the macro one function at a time, stop the 
macro, or continue running the macro.
Halt

Stops the macro.
Step

Starts the single-stepping process.
Continue

Carries out the rest of the macro as if the error or interruption had not occurred.
Goto

Goes to the cell where the error or interruption occurred.
See Also

Help
Cannot add another menu bar.    Macro error at cell: [reference]
Cannot delete built-in or active menu bars.    Macro error at cell: [reference]
Cannot enable built-in commands.    Macro error at cell: [reference]
Command not available at cell [reference]
Command or menu does not exist.    Macro error at cell: [reference]
Illegal reference argument at: [reference]
Missing an END.IF function.    Macro error at cell: [reference]
Missing IF.    Macro error at cell: [reference]
Missing loop.    Macro error at cell: [reference]
Missing NEXT for loop.    Macro error at cell: [reference]
Names cannot look like references.    Macro error at cell: [reference]



Custom Dialog Box
This is a custom dialog box.    A Help topic can be written to go with it, but none has been 
provided for this dialog box.    Please contact the provider of this Microsoft Excel custom 
application.



Custom Menu
This is a custom menu.    A Help topic can be written to go with it, but none has been 
provided for this menu.    Please contact the provider of this Microsoft Excel custom 
application.



New Chart Dialog Box
Appears when you are creating a new chart and:

The selection contains more than one row or column of values.
The selection does not contain text or dates as category labels.
The preferred chart type is not xy (scatter).

First Data Series
Creates a preferred chart using the data in the first row or column as the first data series. 
The categories are numbered consecutively (1, 2, 3, and so on).

Category (X) Axis Labels
Creates a preferred chart using the data in the first row or column as labels for the 
categories rather than as a data series. 

X-Values for XY Chart
Creates an xy (scatter) chart using the data in the first row or column as the x-coordinate 
for each point in the chart.

The preferred chart type is the first option in the Column gallery unless you changed it using
the Set Preferred command on the Gallery menu.



Custom Alert Message
This is a custom alert message.    A Help topic can be written to go with it, but none has 
been provided for this alert message.    Please contact the provider of this Microsoft Excel 
custom application.



File Not Found Dialog Box
Allows you to find the file you want to link to the dependent worksheet.
File Name

Lists the files of the specified type in the current directory.
Select or type the name of the file you want.

Directories
Lists the available directories.
To change directories, double-click one of the directories in the list, or select a directory 
from the list and choose the OK button.

List Files Of Type
Lists the available file formats.

Drives
Lists the available drives.
To change drives, double-click one of the drives in the list, or select a drive from the list 
and choose the OK button.

See Also
Help
About Linking and Embedding
Creating links between documents



Workbook Contents Window
When you open a workbook, the documents in the workbook are listed in the Workbook 
Contents window.    From this window, you can add documents to or remove documents from
your workbook, give a document a descriptive name, and specify whether you want the 
documents saved as part of the workbook or as separate files.
Document Icons

Documents that are part of the workbook are listed in the Workbook Contents window.    
The document name and a document icon (for worksheet, chart, or macro sheet) are 
listed on the left.    You can double-click the document name or icon to display that 
document.
The icon on the right side of the window indicates whether the workbook document is 
bound or unbound.    You can click this icon to change the document status from bound to 
unbound.

Add
Allows you to add, open, or create new documents in a workbook.
Shortcut: ALT+SHIFT+A

Options
Allows you to give a bound document an extended name or to bind or unbind a document
to the workbook.
Shortcut: ALT+SHIFT+O

Remove
Removes the selected document from the workbook.
Shortcut: ALT+SHIFT+R

Paging Buttons
You can use the three buttons in the lower-right corner of the window to page through a 
workbook.    Clicking the left button displays the Workbook Contents window.    Clicking the
middle button pages to the previous document in the workbook.    Clicking the right 
button pages to the next document in the workbook.    
Clicking any of these buttons with the right mouse button displays a shortcut menu listing
all workbook documents and the Group Edit and New commands.

See Also
Help
Adding or removing a document from a workbook
Binding and unbinding workbook documents
Creating a workbook
Editing a group of worksheets in a workbook
Giving a bound workbook document an extended name
Group Edit Command (Options Menu)
Moving between workbook documents
Reordering documents in a workbook
Workbooks
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



Workbook Options Dialog Box
From this dialog box, you can give a document an extended name and specify whether you 
want the documents saved as part of the workbook or as separate files.
Document Name

Type a document name up to 31 characters long.    This name can include any 
combination of characters, including spaces.

Store Document In
Workbook File

Select this option button when you want a document bound to the workbook.    Bound 
documents can only be included in one workbook.

Separate File
Select this option button to include a document in a workbook, but have it saved as a 
separate file.    Unbound documents can be included in several workbooks.

See Also
Help
Binding and unbinding workbook documents
Giving a bound workbook document an extended name
Workbooks



Add to Workbook Dialog Box
From this dialog box, you can add open documents to a workbook.
Select Documents To Add

Lists all open documents that are not already part of the active workbook.
OK

Choosing the OK button adds the selected documents to the active workbook and closes 
the dialog box.

Close
Closes the dialog box.

Add
Adds any selected documents from the Select Documents To Add list to the active 
workbook.

New
Displays the New dialog box so that you can create a new worksheet, chart, or macro 
sheet.

Open
Displays the File Open dialog box so that you can open an existing document to add to 
your workbook.

See Also
Help
Adding or removing a document from a workbook



Confirm Password Dialog Box
Asks you to confirm the spelling of the password you just entered.    Type the password 
again and choose the OK button.    If the password you type does not match the first entry 
exactly, Microsoft Excel asks you to type the password again.    Choose the Cancel button to 
return to the dialog box.



Name Conflict Dialog Box
While changing from R1C1 to A1 reference style, Microsoft Excel encountered a name that 
looks like a reference.    Although names can resemble references when you're using the 
R1C1 reference style, they cannot do so when you're using the A1 reference style. 
You must either cancel the command or type a valid name in place of the invalid one.
OK

Accepts the new name you type in the New Name box, if it's valid.    All formulas using the
old name are changed to include the new name.

Cancel
Cancels both the dialog box and the command.



Bound File Dialog Box
You can only establish links between bound documents.    Choose the bound document you 
want to link to, or cancel the command.



Bound Save As Dialog Box
Type a name for the new version of the document and choose the OK button.



Messages
[Copy or cut] and paste areas are different shapes.
[Document] contains incomplete calculation.    Continue reporting each error?
[Document] contains incomplete calculation.
[Document] is being modified by [user].    Open as Read-Only?
[Document] is currently in use.    Open as Read-Only?
[Document] is Read-Only.
[Document] should be opened as Read-Only unless changes to it need to be saved. Open 
as Read-Only?
[Entry] is too long.
[External Copy or SYLK]: file format is not valid.
[Filename] was created in a previous version of Microsoft Excel.    Do you want to update it
to Microsoft Excel 4.0 format?
[Incorrect number of] arguments.
[Name] is not a valid name.
[Name] on [document] is not defined or is too complex.
[Range] is not defined.
A document with that name is a supporting document. Charts cannot be supporting 
documents.
A document with that name is a supporting document. Workbook table of contents cannot
be supporting documents.
A document with the name [name] is already open.
A group must contain two or more sheets.
A high-low-close stock chart must contain three series.
A surface chart must contain at least two series.
A volume-high-low-close stock chart must contain four series.
A volume-open-high-low-close stock chart must contain five series.
An open-high-low-close stock chart must contain four series.
AutoFormat could not detect a table around the active cell.
Bound filename is invalid.
Calculation is incomplete. Recalculate before saving?
Can't find that sheet in workbook file.
Cannot access [document].
Cannot access [document].
Cannot access directory.
Cannot access file.
Cannot access read-only document.
Cannot add another menu bar.
Cannot add any more custom formats.
Cannot add duplicate source reference.
Cannot bind a document with the same name as another bound document.
Cannot change linked data--[message].
Cannot change part of a table.
Cannot change part of an array.
Cannot change this cell while a macro is paused.



Cannot change to that name.
Cannot convert 3-D reference: [reference].
Cannot copy a document when the copy's name would result in a document name 
conflict.
Cannot create an outline.
Cannot create backup file.
Cannot create data form for a database in which all columns are hidden.
Cannot create Global Macro Sheet.
Cannot create links to consolidation sheet.
Cannot delete [document].
Cannot delete built-in format.
Cannot delete built-in or active menu bars.
Cannot demo with custom menus.
Cannot do that command on a multiple selection.
Cannot empty the Clipboard.
Cannot enable built-in commands.
Cannot end macro in a menu.
Cannot enter a formula in a Data Form.
Cannot enter an array formula into a range of cells which are not all locked or all 
unlocked.
Cannot enter an external reference to a chart.
Cannot enter an external reference to a workbook.
Cannot execute [program].    The program or one of its components is damaged or 
missing.
Cannot extend database.
Cannot extract to an open file.
Cannot find [document].
Cannot find [linked document].
Cannot find [macro] which has been assigned to run each time [document] is opened.    
Continuing could lead to erroneous results.    Cancel Open?
Cannot find [macro] which has been assigned to run each time [document] is closed.    
Continuing could lead to erroneous results.    Cancel Close?
Cannot find [name].
Cannot find data source.
Cannot find macro [name].
Cannot import from an open file.
Cannot include this type of document in a workbook.
Cannot insert object.
Cannot justify cells containing numbers or formulas.
Cannot link to a chart.
Cannot load the send mail service.
Cannot open a copy since the template [document] is already open.Cannot open a 
dependent document that contains references to different sheets with the same name.
Cannot open consolidation source file [filename].
Cannot open FM? files directly. Open the corresponding WK? file.
Cannot open Macintosh Excel 1.X chart.



Cannot open normal Macintosh Excel document.
Cannot open normal Multiplan document.
Cannot open or save any more documents.
Cannot open printer driver.
Cannot open protected file.
Cannot open the Clipboard.
Cannot open waveform input device.
Cannot open waveform output device.
Cannot paste a table onto a macro sheet.
Cannot paste data.
Cannot paste that macro formula onto a worksheet.
Cannot post instructions because a worksheet is not active.
Cannot post instructions because worksheet is protected.
Cannot post instructions because worksheet objects are currently hidden or protected.
Cannot print chart in draft quality.
Cannot print chart with the current scale and paper size; select a larger scale percentage 
or a smaller paper size.
Cannot promote. To start an outline, select the detail rows or columns and demote them.
Cannot quit Microsoft Excel.
Cannot read record [reference].    Continue reporting each error?
Cannot read this binary file. If the file was created in a version of Microsoft Excel greater 
than 4.0, use that version to save it as an Excel 4.0 file. Open file as text?
Cannot rename a document to the same name as another document.
Cannot resolve circular references.
Cannot revert to a saved WK3 file.    Close the file and then open it.
Cannot run tutorial. There may be another instance of tutorial active.
Cannot save [filename] because the volume is locked.
Cannot save a document that belongs to a workbook in that format.
Cannot save Global Macro Sheet in the startup directory. You may save it elsewhere now 
and move to the startup directory later.
Cannot save to an open document.
Cannot save to that name. Document was opened as Read-Only.
Cannot save to that name.
Cannot save workbook with macro sheets as a WK3 file.
Cannot save workbook with no worksheet as a WK3 file.
Cannot save workbook with unbound sheets as a WK3 file.
Cannot shift nonblank cells off sheet.
Cannot shift objects off sheet.
Cannot show outline symbols.
Cannot split when the document has more than one window.
Cannot split when windows are locked.
Cannot unbind a document that would result in an invalid file name.
Cannot unbind a document with the same name as another open document.
Cannot use a workbook reference to documents not in a workbook.
Cannot use name that is a reference to nonadjacent cells.



Cannot use that command on a protected document.
Cannot use that command while in Data Entry mode.
Cannot use this command with a workbook or WK3 file open.
Cannot write record [reference].    Continue reporting each error?
Category range contains nonnumeric data.
Cell in supporting worksheet contains nonnumeric data.
Cell in supporting worksheet is locked.
Cell must contain a formula.
Cell must contain a value.
Cell with block IF function should not contain anything else.
Cell with looping function should not contain anything else.
Change DDE link failed.
Chart is protected and cannot be changed.
Column width must be between 0 and 255.
Command not available at cell:
Command or menu does not exist.
Confirmation password is not identical.
Consolidate_Area reference is not valid.
Consolidation Reference is not valid.
Continue checking at beginning of sheet?
Could not create [dictionary name].
Could not find main dictionary.
Could not find matching data to delete.
Could not find matching data to replace.
Could not find matching data.
Could not initialize spell checker.
Could not open [dictionary name].
Could not read [dictionary name].
Could not share [dictionary name].
Could not write [dictionary name].
Create Graphs?
Create Works graphs?
Criteria range is not defined.
Criteria range is not valid.
Current printer is either missing or bad.
Custom dictionary [name] does not exist.    Create?
Custom dictionary is full.
Data may be lost saving to an old file format.
Data on the Clipboard is not the same size and shape as the selected area.
Data point corresponds to a formula on a hidden worksheet.
Data point corresponds to a formula on a macro sheet.
Data type is not valid.
Data will permanently lose accuracy.
Data_Form is not correct.
Database is hidden.



Database is not defined.
Database range is not defined.
Database range is not valid.
Delete file [filename]?
Delete the [name] toolbar?
Destination Reference is not valid.
Dialog box contains too many items.
Dictionary is too large.
Did not encounter RETURN() or HALT() on macro sheet.
Directory does not exist.
Disk is full.
Displayed record will be deleted permanently.
Document already open.
Document in more than one workbook.
Document is already protected.
Document is not completely saved.
Document not saved. Any previously saved copy has been deleted.
Document not saved.
Error in dialog box at [cell].    [Message]
Error in formula.
Error in Formula: Missing operand.
Error in parse line.
Error printing on [printer].
EXCELCBT directory not found.
EXCELCBT.CBT not found. Cannot run tutorial.
EXCELCBT.LIB not found. Cannot run tutorial.
Existing categories will be permanently deleted.
Existing remote links will be terminated.
External Reference is not valid.
Extract range is full.
Extract range is not defined.
Extract range is not valid.
File error: data may have been lost.
File error: some number formats may have been lost.
File format is not valid.
File is not a valid wave file.
File may contain nondisplayable text and formats from the Far East.
Filename is not valid.
Finished spell checking [document].
First document in the workbook must be a worksheet.
Fixed objects will move.
Font name is too long.
Font size must be between 1 and 409 points.
Formula in cell must result in a number.
Formula is not valid.



Formula is too complex to be assigned to object.
Formula is too long.
Formula must refer to a single cell or result in a text string.
Function is not valid.
Global Macro Sheet in the startup directory must stay open for recording.
Help for Lotus 1-2-3 Users is not available in workgroup mode.
Help reference is not valid.
Illegal reference argument at:
Incompatible version of spell checker.
Incorrect password.
Input and output ranges overlap.
Input cell reference is not valid.
Insert new page into printer.
Integer is not valid.
Invalid [dictionary name].
Invalid document for consolidation.
Invalid register id, or function not registered yet.
Lesson file(s) not found. Cannot run tutorial.
Linked or combination list box requires a preceding edit item.
Locked cells cannot be changed.
Lotus 1-2-3 Help demonstrations cannot be recorded.
Macro error at cell:
Macro error at cell:
Macro interrupted at cell:
Macro interrupted at cell:
Macro with name [name] already exists.    Overwrite?
Margins do not fit page size.
Matching records will be deleted permanently.
Matrices are incompatible for multiplication.
Matrix must be square.
Maximum axis value must be greater than minimum axis value.
Maximum number of data points in a data series is 4000.
Maximum number of data series per chart is 255.
Merge styles that have the same names?
Minor unit must be less than major unit.
Missing an END.IF function.
Missing IF.
Missing loop.
Missing NEXT for loop.
Modify existing outline?
Multiple selection usage is not valid.
Name already exists on destination sheet.
Name cannot be the same as built in name.
Name cannot resemble a reference.
Name conflict.



Name in formula is unclear.
Name is not defined.
Names cannot look like references.
Names in complex reference are not allowed.
Need to specify sheet to copy from workbook file.
Negative or zero values cannot be plotted correctly on log charts.
No cells found.
No data was consolidated.
No link to paste.
No match in current cell.
No match.
No objects found.
No point number is specified.
No references found.
No series number is specified.
No source references specified for consolidation.
Not a workbook file.
Not enough data for Graph demonstration.
Not enough memory. Continue without Undo?
Not enough system resources to display completely.
Note will be permanently deleted.
Number format is not valid.
Number Format is too long.
Number is not valid.
Number must be between [number] and [number].
Number must be greater than or equal to zero.
Operation failed. [Document] is reserved by [user].
Operation failed. [Document] is write reserved.
Option button group without option buttons.
Option buttons must belong to an option button group.
Output range extends beyond edge of worksheet.
Overwrite nonblank cells in destination?
Parentheses do not match.
Password contains accented characters or certain punctuation marks which will not 
transfer correctly to Microsoft Excel for the Macintosh or Microsoft Excel for OS/2.
Re-establish remote links?
Recorder is not defined.
Recorder is not valid.
Recorder range is full.
Recording failed.
Redefine [stylename] based on selected cells?
Reference cannot be to a closed sheet.
Reference is not valid.    Cannot enter a multiple cell reference for the Series Title.
Reference is not valid.    Reference for Categories and Values must be a row or column.
Reference is not valid.    Reference must be a simple external reference to a worksheet.



Reference is not valid.    Reference must be to an open worksheet.
Reference is not valid.
Reference is too complex.
Reference must be on the active sheet.
Reference must be to a macro sheet.
Reference must be to a single cell on the active sheet.
Reference must be to a single cell.
References in series formulas must be external references to worksheets.
Remote data not accessible. Start application [name]?
Remote data not accessible.
Remote links to document exist. Close anyway?
Replace existing [document]?
Replace existing definition of [name]?
Revert to saved [document]?
Revert to saved secondary sheets?
Row height must be between 0 and 409.
Save [document] with references to unsaved documents?
Save [workbook] and all bound sheets?
Save changes in [document]?
Save changes to current series?
Save changes to Global Macro Sheet?
Save large Clipboard from [filename]?
Select cells in one column only.
Select entire row and/or columns before choosing Options Set Print Titles.
Selection is not valid.
Selection too large. Continue without Undo?
Selection too large.
Series definition must include a [Y or Z] reference.
Series formula is too long.
Series must contain at least one value.
Series order must be an integer between 0 and 255.
Sheet is protected with password and formulas are displayed.
Sheet is protected with password.
Shortcut key must be a letter.
Some custom formats will not fit on the destination sheet.
Sort key is not valid.
Source reference overlaps destination area.
Stack overflow.    Note conditions and report to your DLL provider.
Stationery document is not saved in Normal Excel format.
Style [name] not found.
Style name is not valid.
Supporting worksheet is closed.
Text extends beyond worksheet.
Text in your macro may need to be translated by hand.
Text is too long.



Text will extend below range.
That gallery option does not exist.
That name already exists.
That name is not valid.
The [selected text] is spelled correctly.
The current selection already contains only visible cells.
The date and time separators specified by the system are identical.
The header or footer cannot be longer than 255 characters.    Please delete some text, or 
make the formatting less complex.
The list and decimal separators specified by the system are identical.
There are no printers installed.    Please use the Printers Control Panel to install a printer.
There is nothing to print in the specified pages.
This chart graphs constant data.
This chart graphs data from an unopen worksheet.
This chart graphs data from more than one worksheet.
This command controls default printer settings for all documents and all applications.
This document belongs to more than one open workbook.    Create a copy of it to bind in 
this workbook?
Tick mark intervals must be greater than 0.
Too complex to record.
Too many different cell formats.
Too many external references.
Too many fields in the data form.
Too many files to mail.
Total number of file errors: [number]
Unable to activate the source application for this embedded object.
Unable to combine file.
Unable to extract file.
Unable to import file.
Unable to locate the source application for this embedded object.
Unable to paste link.
Unable to read file.
Unable to save external link values.
Unit of log scale must be at least 10.
Update embedded objects?
Update object [name] in [document]?
Update references to unopened documents?
Use existing definition of [name]?
Useful only in Windows for Pen Computing environment.
Value is too large.
Value is too small.
Value must be a number.
Workbook has no bound sheets.
Workbook is protected and cannot be changed.





Definitions
Argument
Array
ASCII Character
Axes
Bound
Breakpoint
Chart
Chart Data Series
Clipboard
Command Macro
Comparison Operators
Consolidation by Category
Consolidation by Position
Constant
Criteria
Data Table
Database
Dependent Worksheet
Destination Macro Sheet
Embedding
External Absolute Reference
External Reference Formula
External Reference
Extract Range
Field Name Row
Field
File Format
Floating Toolbar
Formula Bar
Formula
Frequency Distribution
Function
Global Macro Sheet
Graphic Object
Group
Handles
Input Cell
International File Format
Legend
Linked Documents
Logarithm
Logical Value
Macro Sheet             



Macro Translation Assistant
Menu Key
Moving Border
Name
Nonadjacent Selection
Normal Style             
One-Input Data Table
Parsing
Paste Area
Pause
Plot Area
Range
Record
Reference Style
Reference Type
Reference
Remote Reference
Remote Reference Formula
Scroll Bars
Serial Number
Series Formula
Shortcut Menu
Source Document
Startup Directory
Status Bar
Templates
Tick Mark
Toolbar Dock
Topic
Tracepoint
Two-Input Data Table
Unattached Text
Unbound
Wildcard
Workbook
Worksheet
XY (Scatter) Chart



Worksheet Keys
Accountant's Keypad
Alternate Navigation Keys
Keys for Deleting, Copying, and Moving Data
Keys for Inserting Cell or Range References in a Formula
Keys for Moving and Selecting in a Worksheet
Keys for Moving and Selecting Within the Formula Bar
Keys for Moving Within a Selection
Keys for Scrolling in a Worksheet Window



Accountant's Keypad
When you enter monetary figures on a worksheet, you usually have to type decimal points 
to indicate dollars and cents.    In Fix mode, Microsoft Excel automatically enters the decimal
places for you.
For example, if you have specified two decimal places and you type 732 into the formula 
bar,    Microsoft Excel enters the number as 7.32.    You can override the automatic decimal 
by including a decimal point when you type a number.
To turn on Fix mode, choose the Workspace command from the options menu and select the
Fixed Decimal check box.    The word "FIX" appears in the status bar.



Switching Windows
For applications
ALT+ESC Next application 
ALT+SHIFT+ESC Previous application
ALT+TAB Next Windows application
ALT+SHIFT+TAB Previous Windows application
CTRL+ESC Task List
For documents
CTRL+F4 Close command (Control menu)
CTRL+F5 Restore command (Control menu)
CTRL+F6 Next Window command (Control menu)
CTRL+SHIFT+F6 Previous window
CTRL+F7 Move command (Control menu)
CTRL+F8 Size command (Control menu)
CTRL+F9 Minimize command (Control menu)
CTRL+F10 Maximize command (Control menu)



Command Keys
Edit Command Keys
File Command Keys
Format Command Keys
Formula Command Keys
Help Command Keys
Options Command Keys
Toolbar Command Keys
Window Command Keys



Deleting, Copying, and Moving Data
DELETE Clears formulas, formats, notes, or all three from selected cells.    

Cells remain in their locations.
CTRL+DEL Clears formulas in cells.
CTRL+X    or Cut command (Edit menu)
SHIFT+DEL
CTRL+SHIFT+DEL Cuts text to the end of the line in the formula bar.
BACKSPACE Activates and clears the formula bar when a cell is selected, or 

clears one character to the left when the formula bar is active.
CTRL+V    or Pastes the cut or copied data into the paste area.
SHIFT+INS
CTRL+C    or Copies data to the Clipboard.
CTRL+INS
CTRL+SHIFT+PLUS SIGN Inserts a block of cells the same size as the current selection.
CTRL+MINUS SIGN Deletes the selected cells and shifts remaining cells to fill the 

space.
CTRL+Z    or Undo command (Edit menu)
ALT+BACKSPACE
ALT+SHIFT+A Adds a document to a workbook.
ALT+SHIFT+R Removes a document from a workbook.
ALT+SHIFT+O Opens the Document Options dialog box so that you can set 

options for a document in a workbook.



Dialog Box Keys
TAB Moves to the next list box, text box, check box, command button, or 

group of option buttons.
SHIFT+TAB Moves to the previous list box, text box, check box, command button, 

or group of option buttons.
Arrow keys Move and select within the active list box or group of option buttons.
SPACEBAR Selects the active check box or chooses the active command button.
Letter key Moves to the next item beginning with that letter in an active list box.
ALT+Letter key Selects the item with that underlined letter.
ENTER Chooses the default command button.
ESC Cancels the command and closes the dialog box.



Formula Bar Keys
= Starts a formula.
F2 Activates the formula bar; then switches between Edit mode and Enter 

mode.
ESC Cancels an entry in the formula bar.
ENTER Completes the cell entry.
ALT+ENTER Inserts the carriage return
TAB Completes the cell entry and moves to the next cell in the row or 

range.
SHIFT+TAB Completes the cell entry and moves to the previous cell in the row or 

range.
CTRL+TAB Inserts a tab.
Arrow keys Complete the cell entry and move to the next cell corresponding to the 

direction of the arrow.
See Also

Edit Command Keys
Inserting Cell or Range References in a Formula
Moving and Selecting Within the Formula Bar



Function Keys
F1 Help
SHIFT+F1 Context-sensitive Help
F2 Activates the formula bar
SHIFT+F2 Note command (Formula menu)
CTRL+F2 Workspace command (Options menu); displays an Info window.
F3 Paste Name command (Formula menu)
SHIFT+F3 Paste Function command (Formula menu)
CTRL+F3 Define Name command (Formula menu)
CTRL+SHIFT+F3 Create Names command (Formula menu)
F4 Reference command (Formula menu)
CTRL+F4 Close command (Document Control menu)
ALT+F4 Exit command (File menu)
F5 Goto command (Formula menu)
SHIFT+F5 Find command (Formula menu)
CTRL+F5 Restore command (Document Control menu)
F6 Next pane
SHIFT+F6 Previous pane
CTRL+F6 Next Window command (Control menu)
CTRL+SHIFT+F6 Previous document window
F7 Find command (Formula menu); finds next occurrence.
SHIFT+F7 Find command (Formula menu); finds previous occurrence.
CTRL+F7 Move command (Document Control menu)
F8 Turns Extend mode on or off.
SHIFT+F8 Turns Add mode on or off.
CTRL+F8 Size command (Document Control menu)
F9 Calc Now button, Calculation command (Options menu)
SHIFT+F9 Calc Document button, Calculation command (Options menu)
CTRL+F9 Minimize command (Document Control menu)
F10* Activates the menu bar.
SHIFT+F10 Activates the shortcut menu
CTRL+F10 Maximize command (Document Control menu)
F11 New command (File menu); Chart
SHIFT+F11 New command (File menu); Worksheet
CTRL+F11 New command (File menu); Macro sheet
F12 Save As command (File menu)
SHIFT+F12 Save command (File menu)
CTRL+F12 Open command (File menu)
CTRL+SHIFT+F12 Print command (File menu)

* Unavailable when you have selected the Alternate Navigation Keys check box in the 
Workspace Options dialog box, which you access by choosing the Workspace command 
from the Options menu.



Inserting Cell or Range References in a Formula
When you enter a formula on a worksheet, you can enter cell or range references by typing 
them in Enter mode or by selecting the cells in Point mode.    In Point mode, you can click 
cells or select ranges, or use the arrow keys and shifted arrow keys to select the cells.    The 
reference for the selection is displayed in the formula bar.    Press F2 to switch between Enter
mode and Point mode.
For example, to insert a reference to cell A6 in a formula while editing in the formula bar, 
use the arrow keys to move to cell A6.    The reference for the active cell is displayed in the 
formula bar.

To insert the reference for the active cell into the formula, type the next operator, 
comma, or parenthesis, or complete the formula by pressing ENTER.
See Also

Help
Entering text or numbers into a cell



Menu Keys
ALT    or Activates the menu bar.
F10
SHIFT+F10 Activates the shortcut menu
ALT+BACKSPACE    or Undoes the last command.
CTRL+Z
ALT+ENTER Repeats the last command if applicable.
When menu bar is active
ESC Cancels the menu.
SPACEBAR Displays the Microsoft Excel Control menu.
HYPHEN Displays the document Control menu.
Letter key Displays the menu with that letter underlined.
LEFT or RIGHT ARROW Selects the menu to the left or right.
DOWN or UP ARROW Selects the next or previous command.
With menu displayed
Letter key Chooses the command with that letter underlined.
ENTER Chooses the selected command.
ESC Cancels the menu.
UP ARROW Selects the previous command.
DOWN ARROW Selects the next command.
LEFT or RIGHT ARROW Displays the menu to the left or right.



Moving and Selecting in a Worksheet
Arrow keys Move by one cell in the direction of the arrow.
CTRL+UP ARROW    or Moves by one block of data within a column.
CTRL+DOWN ARROW
CTRL+LEFT ARROW*    or Moves by one block of data within a row.
CTRL+RIGHT ARROW*
CTRL+SHIFT+ARROW KEY Extends the selection to the end of the block in the direction of 

the arrow.
SHIFT+ARROW KEY Extends the selection by one cell.
HOME Moves to the beginning of the row.
CTRL+HOME Moves to the beginning of the worksheet.
CTRL+SHIFT+HOME Extends the selection to the beginning of the worksheet.
SHIFT+HOME Extends the selection to the beginning of the row.
CTRL+END Moves to the lower-right corner of the worksheet.
CTRL+SHIFT+END Extends the selection to the end of the data.
CTRL+SPACEBAR Selects the entire column.
CTRL+SHIFT+SPACEBAR Selects the entire worksheet.
SHIFT+SPACEBAR Selects the entire row.
SHIFT+BACKSPACE Collapses the selection to the active cell.
PAGE DOWN Moves down one window.
CTRL+PAGE DOWN* Moves right one window.
PAGE UP Moves up one window.
CTRL+PAGE UP* Moves left one window.
CTRL+SHIFT+PAGE DOWN* Extends the selection right one window.
SHIFT+PAGE DOWN Extends the selection down one window.
CTRL+SHIFT+PAGE UP* Extends the selection left one window.
SHIFT+PAGE UP Extends the selection up one window.
SCROLL LOCK Turns Scroll Lock on or off.

* Unavailable when you have selected the Alternate Navigation Keys check box in the 
Workspace Options dialog box, which you access by choosing the Workspace command 
from the Options menu.

End Mode
END Turns End mode on or off.
END, ARROW KEY Moves by one block of data within a row or column.
END, SHIFT+ARROW KEY Extends the selection to the end of the data block in the 

direction of the arrow.
END, HOME Moves to the end of the worksheet.
END, SHIFT+HOME Extends the selection to the end of the worksheet.
END, SHIFT+ENTER* Extends the selection to the last cell in the current row.
END, ENTER* Moves to the last cell in the current row.

* Unavailable when you have selected the Alternate Navigation Keys check box in the 
Workspace Options dialog box, which you access by choosing the Workspace command 
from the Options menu.

With Scroll Lock on
HOME Moves to the upper-left cell in the window.



SHIFT+HOME Extends the selection to the upper-left cell in the window.
END Moves to the lower-right cell in the window.
SHIFT+END Extends the selection to the right cell in the window.



Moving and Selecting Within the Formula Bar
HOME Moves to the beginning of the line.
CTRL+HOME Moves to the beginning of the data.
CTRL+SHIFT+HOME Extends the selection to the beginning of the data.
SHIFT+HOME Extends the selection to the beginning of the line.
END Moves to the end of the line.
CTRL+END Moves to the end of the data.
CTRL+SHIFT+END Extends the selection to the end of the data.
SHIFT+END Extends the selection to the end of the line.
Arrow keys Move by a character or a line.
CTRL+ARROW KEY Moves by a word or a line.
CTRL+SHIFT+ARROW KEY Extends the selection by a word or a line.
SHIFT+ARROW KEY Extends the selection by a character or a line.
CTRL+A Pastes the arguments to the function that you have typed.    Only 

works following an open left parenthesis.



Moving Within a Selection
ENTER* Down one cell
SHIFT+ENTER* Up one cell
TAB** Right one cell
SHIFT+TAB** Left one cell
CTRL+PERIOD To the next corner of the selection (clockwise).
CTRL+TAB To the next area in a nonadjacent selection.
CTRL+SHIFT+TAB To the previous area in a nonadjacent selection.

*If the selection consists of a single row, then pressing ENTER or SHIFT+ENTER moves the 
active cell right one cell or left one cell, respectively.
**If the selection consists of a single column, then pressing TAB or SHIFT+TAB moves the 
active cell down one cell or up one cell, respectively.



Outlining Keys
ALT+SHIFT+LEFT ARROW Promotes a row or a column.
ALT+SHIFT+RIGHT ARROW Demotes a row or a column.
CTRL+8 Display command (Options menu); displays or hides outline 

symbols.



Scrolling in a Worksheet Window
SCROLL LOCK Turns Scroll Lock on or off.
With Scroll Lock on
PAGE UP or PAGE DOWN Moves up or down one window.
CTRL+PAGE UP Moves left one window.
CTRL+PAGE DOWN Moves right one window.
UP or DOWN ARROW Moves up or down one row.
LEFT or RIGHT ARROW Moves left or right one column.
CTRL+HOME Moves to the beginning of the sheet.
CTRL+END Moves to the end of the sheet.
HOME Selects the cell in the upper-left corner of the window.
END Selects the cell in the lower-right corner of the window.
CTRL+BACKSPACE Scrolls to display the active cell indicated in the formula bar.



Selecting Chart Items
RIGHT ARROW Selects the next item.
LEFT ARROW Selects the previous item.
DOWN ARROW Selects the previous class of items.
UP ARROW Selects the next class of items.

See Also
User's Guide (Book 1)
Chapter 13, "Editing a Chart"



Edit Command Keys
LEFT ARROW Moves left one cell.
RIGHT ARROW Moves right one cell.
SHIFT+LEFT ARROW Extends the selection one cell to the left.
SHIFT+RIGHT ARROW Extends the selection one cell to the right.
HOME Moves to the beginning of the line.
SHIFT+HOME Extends the selection to the beginning of the line.
END Turns End mode on or off.
CTRL+MINUS SIGN Delete command (Edit menu)
CTRL+R    or Fill Right command (Edit menu)
CTRL+SHIFT+>
CTRL+D    or Fill Down command (Edit menu)
CTRL+SHIFT+<
CTRL+SHIFT+PLUS SIGN Insert command (Edit menu)
CTRL+V    or Paste command (Edit menu)
SHIFT+INS
ENTER Paste command (Edit menu).    Only works immediately after 

choosing the Cut or Copy command.
ALT+ENTER Repeat command (Edit menu)
CTRL+Z Undo command (Edit menu)
With no selection in the Formula bar
DEL Deletes the character to the right of the insertion point.
CTRL+DEL Deletes to the end of the line.
CTRL+SHIFT+DEL Cuts to the end of the line.
BACKSPACE Deletes the character to the left of the insertion point.
INS Turns Overtype mode on or off.
With characters selected in the Formula bar
DEL Deletes the selection.
CTRL+DEL Deletes from the beginning of the selection to end of the line.
CTRL+SHIFT+DEL Cuts from the beginning of the selection to the end of the line.
CTRL+X    or Cuts the selection to the Clipboard.
SHIFT+DEL
BACKSPACE Deletes the selection.
INS Turns Overtype mode on or off.
CTRL+INS    or Copies the selection to the Clipboard.
CTRL+C
SHIFT+INS    or Replaces the selection with Clipboard data.
CTRL+V
Formula bar shortcuts
BACKSPACE Activates and clears the formula bar.
ALT+= AutoSum tool.
CTRL+; Inserts the current date.
CTRL+SHIFT+: Inserts the current time.
CTRL+' Copies the formula from the cell above.
CTRL+SHIFT+" Copies the value from the cell above.



Arrow keys Switch from Edit mode to Point mode, allowing cell selection with 
the arrow keys when the last character is an operator such as + - *  
or /.

CTRL+A Pastes the arguments to the function that you have typed.    Only 
works following an open left parenthesis.



File Command Keys
F11    or New command (File menu); chart
ALT+F1
CTRL+F11    or New command (File menu); macro sheet
ALT+CTRL+F1
SHIFT+F11    or New command (File menu); worksheet
ALT+SHIFT+F1
CTRL+F12    or Open command (File menu)
ALT+CTRL+F2
ALT+SHIFT+F2    or Save command (File menu)
SHIFT+F12
ALT+F2    or Save As command (File menu)
F12
ALT+CTRL+SHIFT+F2    or Print command (File menu)
CTRL+SHIFT+F12
ALT+F4 Exit command (File menu)



Format Command Keys
Number Command (Format Menu)
CTRL+SHIFT+~ Applies General number format.
CTRL+SHIFT+! Applies #,##0.00 number format.
CTRL+SHIFT+$ Applies $#,##0.00_) number format.
CTRL+SHIFT+% Applies 0% number format.
CTRL+SHIFT+^ Applies 0.00E+00 number format.
CTRL+SHIFT+# Applies d-mmm-yy number format.
CTRL+SHIFT+@ Applies h:mm AM/PM number format.
Font Command (Format Menu)
CTRL+1 Applies Normal font.
CTRL+B Applies or removes bold.
CTRL+I Applies or removes italic.
CTRL+U Applies or removes underline.
CTRL+5 Applies or removes strikeout.
CTRL+S Displays the Style list.
CTRL+P Displays the Font Size list.
CTRL+F Displays the Font Name list.
Row Height Command (Format Menu)
CTRL+9 Hides the selected rows.
CTRL+SHIFT+( Unhides the selected rows.
Column Width Command (Format Menu)
CTRL+0 (zero) Hides the selected columns.
CTRL+SHIFT+) Unhides selected columns.
Border Command (Format Menu)
CTRL+SHIFT+& Adds an outline border.
CTRL+SHIFT+_ Removes all borders.



Formula Command Keys
CTRL+A Pastes the arguments to    the function that you have typed.

Only works following an open left parenthesis in the formula bar.
CTRL+SHIFT+F3 Create Names command (Formula menu)
CTRL+F3 Define Name command (Formula menu)
SHIFT+F5 Find command (Formula menu)
F7 Find Next command (Formula menu)
SHIFT+F7 Find Previous command (Formula menu)
F5 Goto command (Formula menu)
SHIFT+F2 Note command (Formula menu)
SHIFT+F3 Paste Function command (Formula menu)
F3 Paste Name command (Formula menu)
F4 Reference command (Formula menu)
CTRL+SHIFT+| Selects column differences.
CTRL+/ Selects the current array.
CTRL+SHIFT+* Selects the current region.
CTRL+SHIFT+} Selects all dependents.
CTRL+] Selects direct dependents only.
CTRL+SHIFT+? Selects notes.
CTRL+SHIFT+{ Selects all precedents.
CTRL+[ Selects direct precedents only.
CTRL+\ Selects row differences.
ALT+; Selects visible cells.
CTRL+TAB Inserts a tab in the formula bar.
ALT+ENTER Inserts a carriage return in the formula bar.



Help Command Keys
F1 Help
SHIFT+F1 Context-sensitive Help



Options Command Keys
SHIFT+F9 Calculates the active document.
F9    or Calculates all open documents.
CTRL+=
CTRL+6 Switches between displaying all objects, displaying placeholders, and 

hiding all objects.
CTRL+8 Shows or hides outline symbols.
CTRL+` Displays formulas or values.
CTRL+7 Hides or shows the Standard toolbar.
CTRL+F2 Displays the Info Window.



Toolbar Keys
ALT+= AutoSum tool.
ALT+' Displays the Style box.
CTRL+S Displays the Style list.
CTRL+P Displays the Font Size list.
CTRL+F Displays the Font Name list.
CTRL+7 Hides or shows the Standard toolbar.



Window Command Keys
ALT+PAGE UP In a workbook, switches to the previous document.
ALT+PAGE DOWN In a workbook, switches to the next document.
SHIFT+F10 Opens the shortcut menu for the current selection.



Alternate Navigation Keys
When you choose the Workspace command from the Options menu and select the Alternate
Navigation Keys check box, the following keyboard shortcuts are put into effect. 

Navigation Keys
CTRL+LEFT ARROW Left one page.
CTRL+RIGHT ARROW Right one page.
CTRL+PAGE UP In a workbook, next worksheet.
CTRL+PAGE DOWN In a workbook, previous worksheet.
TAB Right one page.
SHIFT+TAB Left one page.
HOME Upper-left corner of the sheet.
Function Keys
F5 Positions the entered cell or range in the upper-left corner of the 

window.
F6 Next window of the same document.
SHIFT+F6 Previous pane of the same window
In Data Find Mode
LEFT ARROW Moves to the previous field of the current record.
RIGHT ARROW Moves to the next field of the current record.
HOME Moves to the first record.
END Moves to the last record.
Text Alignment Prefix Characters
When the Alternate Navigation Keys check box is selected, you can use the following text-
alignment prefix characters to assign alignment formats as you enter data into cells.
' (single quotation mark) Aligns data in the cell to the left.
" (double quotation mark) Aligns data in the cell to the right.
^ (caret) Centers data in the cell.
\ (backslash) Repeats characters across the cell.

When in Point mode, hidden columns will unhide themselves temporarily.



Lotus 1-2-3 Access System Menu
1-2-3
Printgraph
Translate
Install



To start Microsoft Excel
For information about starting Microsoft Excel, see Chapter 1, "Getting Started with 
Microsoft Excel," in Book 1 of the Microsoft Excel User's Guide.



To print a chart
1 Switch to the chart you want to print.
2 From the File menu, choose Print.
3 Select the print options you want.
4 Choose the OK button.

See Also
Help
Open Command (File Menu) 
Print Command (File Menu)
User's Guide (Book 1)
Chapter 16, "Printing"



To save files so they can be read by other programs
 Microsoft Excel can open documents created with Lotus 1-2-3 Releases 1, 1A, 2, 2.01, 2.2, 
2.3, 3.0, 3.1, and 3.1+, as well as Lotus 1-2-3/W, Symphony, Microsoft Multiplan (SYLK), 
Microsoft Excel for the Macintosh, VisiCalc, and dBASE II, III, and IV.    Microsoft Excel can 
also read and write 2-D and 3-D sheets in the WK3 format. 

1 From the File menu, choose Save As.
2 In the Save File As Type box, select the file format that you want.
3 Choose the OK button.

See Also
Help
Save As Command (File Menu)
User's Guide (Book 1)
Chapter 5 , "Creating a Worksheet"
Switching to Microsoft Excel from Lotus 1-2-3



Lotus 1-2-3 Commands
Worksheet
Range
Copy
Move
File
Print
Graph
Data
System
Quit



Lotus 1-2-3 Worksheet Commands
Global
Insert
Delete
Column
Erase
Titles
Window
Status
Page



Lotus 1-2-3 Worksheet Global Commands
Format
Label-Prefix
Column-Width
Recalculation
Protection
Default
Zero



To format cell contents
1 Select the cells you want to format.

To select the entire worksheet, click the square on the worksheet directly above the 
row numbers, or press CTRL+SHIFT+SPACEBAR.

2 From the Format menu, choose Number.
3 Select a format.    

Refer to the table below for Microsoft Excel equivalents to Lotus 1-2-3 formats.
You can create other fixed decimal number formats by editing the displayed format in 
the Code box or by typing an entirely new one.

4 Choose the OK button.
Lotus 1-2-3 Microsoft Excel
Fixed 0.00
Scientific 0.00E+00
Currency $#,##0_);($#,##0)
Comma #,##0.00    or    #,##0
General General
+/- No equivalent
Percent 0.00%
Date dd-mm-yy
Time h:mm:ss AM/PM
Text Microsoft Excel allows you to choose between displaying formulas or 

values in the entire worksheet, but not in selected ranges. To display 
formulas or values, choose Display from the Options menu.

Hidden In the Code box, type ;;; to hide the contents of a cell or range.    Use the 
Row Height and Column Width commands on the Format menu to hide 
entire rows or columns.    

Reset General
See Also

Help
Number Command (Format Menu)
Cell Protection Command (Format Menu)
Protect Document Command (Options Menu)
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"
Switching to Microsoft Excel from Lotus 1-2-3



Lotus 1-2-3 Worksheet Global Default Commands
Printer
Directory
Status
Update
Other
Quit



Lotus 1-2-3 Worksheet Global Default Printer Commands

Lotus 1-2-3 Microsoft Excel
Interface Setting up a printer and port
Auto-LF Not necessary; handled by printer driver
Left Page Setup command (File menu)
Right Page Setup command (File menu)
Top Page Setup command (File menu)
Bottom Page Setup command (File menu)
Pg-Length Page Setup command (File menu)
Wait Page Setup command (File menu)
Setup Not necessary; handled by printer driver
Name Page Setup command (File menu)
Quit ESC key



Lotus 1-2-3 Worksheet Global Default Directory Command
There is no direct equivalent in Microsoft Excel for the Lotus 1-2-3 Worksheet Global Default 
Directory command.
You can also create an autoexec macro that changes the current directory to a specified 
directory every time you open a macro sheet.    Name the macro sheet STARTDIR.XLM, for 
example, and save the macro in the XLSTART subdirectory, located in the same directory as 
the Microsoft Excel program.    
See Also

User's Guide (Book 2)
Chapter 8, "Creating a Custom Application"
Switching to Microsoft Excel from Lotus 1-2-3



Lotus 1-2-3 Worksheet Global Default Status Command
Microsoft Excel displays status information in the dialog boxes you use to carry out 
commands, not in one single display.
Printer

From the File menu, choose Page Setup.    The dialog box displays printer status 
information such as the current port, margins, and name.    Microsoft Excel does not 
display auto-linefeed and setup string status because they are handled automatically by 
the printer driver.

Add-In
You can view a list of the working set of add-in macros by using the Add-ins command on 
the Options menu.    The Add-ins command will appear on the Options menu only if the 
Add-in Manager option was selected when you installed Microsoft Excel.

File extensions and path
From the File menu, choose the Open command.    The dialog box displays filenames and 
extensions as well as current directory information.

International, Currency, Date, and Time Formats
1 From the Microsoft Excel Control menu, choose Run.

Shortcut: ALT, SPACEBAR, U
2 Select the Control Panel option button.
3 Choose the OK button.
4 From the Settings menu, choose International, or double-click the International icon.
5 In the Country list box, select the country whose settings you want to view or 

change. 
6 Change any settings you want.
7 Choose the OK button.
8 From the Settings menu, choose the Exit command to close the Control Panel 

window.
Help access method

Help remains in memory until you use the Close command from the Help window Control 
menu to close it.

Clock display
Not available in Microsoft Excel.

Undo
From the Edit menu, choose Undo.    If it is available, Undo will appear black.    If it is not 
available, Can't Undo will appear dimmed.

Warning Beep
1 From the Microsoft Excel Control menu, choose Run.

Shortcut: ALT, SPACEBAR, U
2 Select the Control Panel option.
3 Choose the OK button.
4 From the Settings menu, choose Sound, or double-click the Sound icon.
5 To turn on the warning beep, select the Warning Beep check box.
6 Choose the OK button.
7 From the Settings menu, choose the Exit command to close the Control Panel.



See Also
Help
Add-ins Command (Options Menu)
Control Menu
Number Command (Format Menu)
Open Command (File Menu)
Page Setup Command (File Menu)
Undo Command (Edit Menu)
User's Guide (Book 1)
Chapter 16, "Printing"
User's Guide (Book 2)
Chapter 8, "Creating a Custom Application"
Switching to Microsoft Excel from Lotus 1-2-3



Lotus 1-2-3 Worksheet Global Default Update Command
There is no direct equivalent in Microsoft Excel for the Lotus 1-2-3 Worksheet Global Default 
Update command.
Settings affecting the document, such as margins, are stored with the document.    The 
dialog box settings reflect the setting for the active document.
Settings affecting how Microsoft Excel is configured to work with the hardware and software 
environment, such as printer settings and preferences, are not specific to a document, and 
are retained as defaults until you change them.
See Also

Switching to Microsoft Excel from Lotus 1-2-3



Lotus 1-2-3 Worksheet Global Default Other Commands
International

Except for the argument separator in functions (comma), you can change punctuation, 
currency, date, and time formats, and other country-specific settings with the Control 
Panel.

To change country-specific settings
1 From the Microsoft Excel Control menu, choose Run.

Shortcut: ALT, SPACEBAR, U
2 Select the Control Panel option.    
3 From the Settings menu, choose International, or double-click the International icon.
4 In the Country box, select the name of the country you want.
5 Make any other changes you want.
6 Choose the OK button.

These settings remain in effect for all Windows applications until you change them.
Help

Not applicable.
Clock
Not applicable.

See Also
Help
Control Menu
Switching to Microsoft Excel from Lotus 1-2-3



To erase the active worksheet and start a new one
In Microsoft Excel, you can have more than one worksheet open at once, allowing you to 
keep the active worksheet open while starting a new one. The following procedure 
corresponds to the Lotus 1-2-3 Worksheet Erase command, which removes the active 
worksheet from memory (but not from your disk), allowing you to start a new one. 

1 From the File menu, choose Close.
If you have made unsaved changes to the active worksheet, a dialog box will appear 
asking if you want to save your changes.

2 To erase the active worksheet, choose the No button.
3 From the File menu, choose New to open a new worksheet.
4 Choose the OK button.

See Also
Help
Close Command (File Menu)
New Command (File Menu)
Switching to Microsoft Excel from Lotus 1-2-3



Lotus 1-2-3 Worksheet Status Command
Lotus 1-2-3 Microsoft Excel
Memory used From the Help menu, choose About Microsoft Excel.
Coprocessor From the Help menu, choose About Microsoft Excel.
Recalculation From the Options menu, choose Calculation.
Circular Reference Microsoft Excel displays a message after each recalculation if any 

formulas contain circular references.
Cell Display

Format Select the cell and choose a command from the Format menu.
Label Prefix From the Format menu, choose Alignment.
Column Width From the Format menu, choose Column Width.

Zero Suppression From the Options menu, choose Display.
See Also

Help
Alignment Command (Format Menu)
Column Width Command (Format Menu)
Display Command (Options Menu)
Calculation Command (Options Menu)
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"
Switching to Microsoft Excel from Lotus 1-2-3



Lotus 1-2-3 Range Commands
Format
Label-Prefix
Erase
Name
Justify
Protect
Unprotect
Input
Value
Transpose



Lotus 1-2-3 Range Name Commands
Create
Delete
Labels
Reset
Table



To delete one or more names in a worksheet
When you delete a name, any references to the name in formulas are replaced by the 
#NAME! error value.    If you want to avoid this, replace all occurrences of the name with its 
definition by using the Replace command on the Formula menu before deleting the name 
from the list.

1 From the Formula menu, choose Define Name.
2 Select a name from the list.
3 Choose the Delete button.
4 Repeat steps 2 and 3 for each name you want to delete.

See Also
Help
Define Name Command (Formula Menu)
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"
Switching to Microsoft Excel from Lotus 1-2-3



To paste a list of names in a worksheet into a range
1 Select the upper-left cell of the range.
2 From the Formula menu, choose Paste Name.

Shortcuts: Paste Names tool (Utility toolbar)
F3

3 Choose the Paste List button.
See Also

Help
Paste Names Tool

Paste Name Command (Formula Menu)
Pasting names
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"
Switching to Microsoft Excel from Lotus 1-2-3



Lotus 1-2-3 Range Input Command
There is no command in Microsoft Excel that is directly equivalent to the Lotus 1-2-3 Range 
Input command, but you can use the following features to achieve similar functionality.
The Cell Protection and Protect Document commands
Using the Cell Protection command on the Format menu, you can unlock the cells that you 
want to use as input cells so they can be altered when the worksheet is protected using the 
Protect Document command on the Options menu. By default, all cells on a sheet have the 
locked format, but they remain unlocked until you choose the Protect Document command 
on the Options menu. Then, when document protection is on, pressing the TAB key allows 
you to move among only unlocked cells.
The ENTER.DATA macro function
The ENTER.DATA macro function temporarily provides the same functionality as the Protect 
Document command. When the ENTER.DATA function is encountered in a macro, Enter Data
mode is activated. Any cells that have been not been formatted as unlocked with the Cell 
Protection command become locked. You can then use the TAB key to move among only 
unlocked cells.
The ENTER.DATA function is a toggle and needs no arguments, although you can use TRUE 
or FALSE to turn Enter mode on and off. When Enter mode is turned on, the unlocked cell 
nearest the upper-left corner of the selection becomes the active cell. Pressing the TAB key 
selects the next unlocked cell. You can turn Enter mode off by running a macro containing 
the ENTER.DATA function again. This function can only be used on macro sheets.
See Also

Help
Cell Protection Command (Format Menu)
Protecting worksheet cells
Protect Document Command (Options Menu)
User's Guide (Book 1)
Chapter 4, "Managing Document Files"
Switching to Microsoft Excel from Lotus 1-2-3
Microsoft Excel Function Reference
ENTER.DATA



Lotus 1-2-3 File Commands
Retrieve
Save
Combine
Xtract
Erase
List
Import
Directory
Translate



Lotus 1-2-3 Print Commands
Printer
File



Lotus 1-2-3 Print Printer Commands
Lotus 1-2-3 Microsoft Excel 
Range From the Options menu, choose Set Print Area.
Line Use the LINE.PRINT macro function.
Page Not applicable in Microsoft Excel.
Options

Header From the File menu, choose Page Setup.
Footer From the File menu, choose Page Setup.
Margins From the File menu, choose Page Setup.
Borders From the Options menu, choose Set Print Titles.
Setup Select cells and choose the Font command from the Format menu.
Pg-Length From the File menu, choose Page Setup.
Other Worksheet is printed as displayed. To display values or formulas, choose 

Display from the Options menu. To add or remove headers and footers, 
choose Page Setup from the File menu. To add or remove page breaks, 
choose Set Page Break or Remove Page Break from the Options menu.

Quit Press ESC.
Clear

All Reset individual settings.
Range From the Formula menu, choose Define Name and delete Print_Area.
Borders From the Formula menu, choose Define Name and delete Print_Titles.
Format From the File menu, choose Page Setup to reset margins.    Page Length 

and Setup String are handled by the printer driver.
Align Not applicable in Microsoft Excel.
Go From the File menu, choose Print.
Quit Press ESC.

See Also
Help
Define Name Command (Formula Menu)
Display Command (Options Menu)
Lotus 1-2-3 Line Print Command
Page Setup Command (File Menu)
Set Page Break and Remove Page Break Commands (Options Menu) 
Set Print Area Command (Options Menu)
Set Print Titles Command (Options Menu)
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"
Chapter 7, "Formatting a Worksheet"
Chapter 16, "Printing"
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"
Switching to Microsoft Excel from Lotus 1-2-3



Lotus 1-2-3 Print File Command
There is no direct equivalent in Microsoft Excel to the Lotus 1-2-3 Print to File command.
See Also

Help
Lotus 1-2-3 Line Print Command
Lotus 1-2-3 Print Printer Commands
Switching to Microsoft Excel from Lotus 1-2-3



Lotus 1-2-3 File Combine Commands
Copy
Add
Subtract



Lotus 1-2-3 Graph Commands
Type
X A B C D E F
Reset
View
Save
Options
Name
Quit
See Also

User's Guide (Book 1)
Chapter 14, "Formatting a Chart"
Switching to Microsoft Excel from Lotus 1-2-3



Lotus 1-2-3 Graph Type Commands
In Microsoft Excel, you change the chart (graph) type after you have created the chart 
(graph).

Lotus 1-2-3 Microsoft Excel 
Line From the Gallery menu, choose Line.
Bar From the Gallery menu, choose Column.
XY From the Gallery menu, choose XY (Scatter).
Stacked bar From the Gallery menu, choose Column and then select type 5.
Pie From the Gallery menu, choose Pie.
The Gallery menu appears when a chart window is active.    The gallery also offers 
additional chart types such as 3-D charts.

See Also
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"
Switching to Microsoft Excel from Lotus 1-2-3



Lotus 1-2-3 Graph View Command
When you create a chart (graph), it appears in a new, active window.    If at any time another
window covers all or part of the chart and you want to see it, choose the name of the chart 
from the list at the bottom of the Window menu.
See Also

Help
Switching to or closing a document window
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"
Switching to Microsoft Excel from Lotus 1-2-3



Lotus 1-2-3 Graph Options Commands
Legend
Format
Titles
Grid
Scale
Color
B&W
Data-Labels
Quit
See Also

User's Guide (Book 1)
Chapter 12, "Creating a Chart"
Chapter 13, "Editing a Chart"
Chapter 14, "Formatting a Chart"
Switching to Microsoft Excel from Lotus 1-2-3



Lotus 1-2-3 Graph Options Format Commands
Microsoft Excel and Lotus 1-2-3 take different approaches to formatting charts.    The Lotus 
1-2-3 Graph Options Format commands apply to line and xy (scatter) charts only. 
To format a line or xy (scatter) chart

1 Select a data series.
2 From the Format menu, choose Patterns.
3 Under Line, select the line style, color, and weight you want.    

If you don't want any lines, select the None option button.
4 Under Marker, select the marker style, foreground color, and background color you 

want.
If you don't want any markers, select the None option button.
If you want to apply the same format to all data series in the chart, select the Apply To 
All check box.

5 Choose the OK button.
See Also

Help
Patterns Command (Format Menu for Charts)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart" 
Switching to Microsoft Excel from Lotus 1-2-3



Lotus 1-2-3 Graph Options Titles Commands
For a complete guide to using text in charts for titles, labels, and descriptions, see Chapter 
14, "Formatting a Chart," in Book 1 of the Microsoft Excel User's Guide.
See Also

Help
Format Menu for Charts
Edit Series Command (Chart Menu)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"
Switching to Microsoft Excel from Lotus 1-2-3



Lotus 1-2-3 Graph Options Grid Commands
To add and delete gridlines in a chart

1 From the Chart menu, choose Gridlines.
2 Select the options for the types of gridlines you want.
3 Choose the OK button.

See Also
Help
Gridlines Command (Chart Menu)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart" 
Switching to Microsoft Excel from Lotus 1-2-3



Lotus 1-2-3 Graph Options Scale Commands
X-Scale
Y-Scale
Skip



Lotus 1-2-3 X Scale and Y Scale Commands
Automatic

Microsoft Excel creates the scale automatically.    If you have designated any aspect of the
scale as manual, you can return it to automatic by doing the following procedure.
1 Select the x (category) or y (value) axis.
2 From the Format menu, choose Scale.    

The options will be different for the x and y axes.
3 Select the Auto check box for any option you want to return to automatic.
4 Choose the OK button.

Manual, Lower, Upper
To control the scale manually:
1 Select the x (category) or y (value) axis.
2 From the Format menu, choose Scale.    

The options will be different for the x and y axes.
3 Change any options you want.
4 Choose the OK button.

Format
To change the number format on the scale:
1 On the source worksheet, select the numbers you want to format.
2 From the Format menu, choose Number.

Select the number format you want to use in the chart.
3 Choose the OK button.

Indicator
To select or clear scale indicators:
1 Select the chart.
2 From the Chart menu, choose Axes.
3 Select the Category (X) Axis or Value (Y) Axis check box.
4 Choose the OK button.

Quit
Press ESC.

See Also
Help
Axes Command (Chart Menu)
Number Command (Format Menu)
Scale Command (Format Menu)
User's Guide (Book 1)
Chapter 13, "Editing a Chart"
Chapter 14, "Formatting a Chart"
Switching to Microsoft Excel from Lotus 1-2-3



To change how Microsoft Excel displays labels on the x-axis
1 Select the x-axis.
2 From the Format menu, choose Scale.
3 Change the number in the Number Of Categories Between Tick Labels box.
4 Choose the OK button.

See Also
Help
Scale Command (Format Menu)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"
Switching to Microsoft Excel from Lotus 1-2-3



Lotus 1-2-3 Graph Options Color Command
There is no direct equivalent in Microsoft Excel for the Lotus 1-2-3 Graph Options Color 
command.    However, you can change the color of individual chart items using the Patterns 
command on the Format menu.
See Also

Help
Patterns Command (Format Menu for Charts)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"
Switching to Microsoft Excel from Lotus 1-2-3



To create data labels
1 From the Chart menu, choose Attach Text.
2 Select the Series And Data Point option button.
3 In the Series Number box, type the number of the series containing the point you want 

to label.
4 In the Point Number box, type the number of the point you want to label.
5 Choose the OK button.    

Microsoft Excel suggests the value of that point for a data label in the formula bar and 
displays the value in the chart.

6 Type the label if you want to use something other than the suggested point value.
7 Click the enter box or press ENTER.

See Also
Help
Attach Text Command (Chart Menu)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart" 
Switching to Microsoft Excel from Lotus 1-2-3



To name a graph and save it on a disk
You can save Microsoft Excel charts (graphs) as separate files on disk. If you are working 
with a chart that is embedded in your worksheet, you must first open it as a chart document
by double-clicking it. The chart is displayed in a window with a title bar at the top.

1 From the File menu, choose Save As.
2 Type a name for the file.
3 Choose the OK button.

To open a chart (graph)
1 From the File menu, choose Open.
2 Select the name of the chart (graph).
3 Choose the OK button.

To delete a chart (graph)
1 From the File menu, choose Delete.
2 Select the name of the chart (graph).
3 Choose the OK button.

You cannot delete all charts at once.    You must repeat this procedure for each chart 
you want to delete.

See Also
Help
Delete Command (File Menu)
Open Command (File Menu)
Save As Command (File Menu)
User's Guide (Book 1)
Chapter 12, "Creating a Chart"
Chapter 13, "Editing a Chart"
Chapter 14, "Formatting a Chart"
Switching to Microsoft Excel from Lotus 1-2-3



Lotus 1-2-3 Data Commands
Fill
Table
Sort
Query
Distribution
Matrix
Regression
Parse



Lotus 1-2-3 Data Query Commands
Input
Criterion
Output
Find
Extract
Unique
Delete
Reset
Quit



Lotus 1-2-3 Data Distribution Command
There is no equivalent command in Microsoft Excel for the Lotus 1-2-3 Data Distribution 
command. Instead, Microsoft Excel provides the FREQUENCY function, which provides 
similar functionality. 
See Also

Help
FREQUENCY function
Microsoft Excel Function Reference
FREQUENCY



Lotus 1-2-3 Data Matrix Commands
The Microsoft Excel equivalents to the Data Matrix commands are array functions, rather 
than commands.

Lotus 1-2-3 Microsoft Excel function
Invert MINVERSE
Multiply MMULT

See Also
Help
MINVERSE function
MMULT function
Switching to Microsoft Excel from Lotus 1-2-3
Microsoft Excel Function Reference
MINVERSE
MMULT



Lotus 1-2-3 Data Regression Commands
The Microsoft Excel equivalents to the Data Regression commands are array functions 
rather than commands and do not translate directly.    
See Also

Help
Regression
GROWTH function
LINEST function
LOGEST function
TREND function
Switching to Microsoft Excel from Lotus 1-2-3
Microsoft Excel Function Reference
GROWTH
LINEST
LOGEST
TREND



Lotus 1-2-3 System Command
There is no direct equivalent for the Lotus 1-2-3 System command in Microsoft Excel, but 
you can switch to MS-DOS using the Microsoft Windows Program Manager.
To switch to MS-DOS

1 Press CTRL+ESC.
2 From the Task List, select Program Manager and press ENTER.
3 From the File menu, choose Run.
4 Type command
5 Choose the OK button.

To return to Microsoft Excel
1 At the MS-DOS prompt, type exit
2 Press CTRL+ESC to switch to the Task List.
3 From the Task List, select Microsoft Excel and press ENTER.



Lotus 1-2-3 Line Print Command
There is no command in Microsoft Excel that is equivalent to the Lotus 1-2-3 Line Print 
command. To add the same functionality, Microsoft Excel includes a LINE.PRINT macro 
function that provides compatibility with Lotus 1-2-3. 
The LINE.PRINT macro function has three forms:

LINE.PRINT (command, file, append)
LINE.PRINT (command, setup_text, leftmarg, rightmarg, topmarg, botmarg, pglen, 
formatted)
LINE.PRINT (command, setup_text, leftmarg, rightmarg, topmarg, botmarg, pglen, wait, 
autolf, port, update)
Arguments Defined
command 1=Go, 2=Line, 3=Page, 4=Align, 5=Document settings (form 2 only), 

6=Global settings (form 3 only), 7=Clear (revert document settings to 
global settings)

file Output file
Default=currently defined port

append TRUE to append the file, FALSE to rewrite the file
Default=FALSE 

setup_text Setup string
leftmarg Number of characters from the left side of page

Default=4
rightmarg Number of characters from the right side of page

Deault=76
topmarg Number of characters from the top of page

Default=2
botmarg Number of characters from the bottom of page

Default=2
pglen Number of lines per page

Default=66
formatted TRUE=formatted

Default =TRUE 
wait TRUE=wait

Default=FALSE 
autolf TRUE if printer auto-linefeeds

Default=FALSE 
port 1 through 8 only. See the Microsoft Excel Function Reference

Default=1
update TRUE to update global settings to Microsoft Excel

Default=FALSE 
See Also

Help
Lotus 1-2-3 Print Printer Commands
Switching to Microsoft Excel from Lotus 1-2-3
Microsoft Excel Function Reference
LINE.PRINT



Macro Interpreter for Lotus 1-2-3 Users
You can run the macros contained on your Lotus 1-2-3 worksheet by holding down CTRL and 
pressing the letter of the macro name.    While your macro is running, the status bar displays
"MI" (macro interpreter).    If your macro contains a {?} command, the status bar displays 
"MI Pause" until you press ENTER.
Microsoft Excel recognizes all 1-2-3 file formats, but only fully runs macros that contain 
menu commands, @ functions, keywords, and advanced macro commands that are 
supported by Lotus 1-2-3 Release 2.01.    Lotus 1-2-3 add-ins are not supported; remove any 
keystrokes or command names that attach or start a Lotus 1-2-3 add-in.    Also, macros 
cannot end in a menu.
See Also

Switching to Microsoft Excel from Lotus 1-2-3
"Running Existing 1-2-3 Macros in Microsoft Excel"



Lotus 1-2-3 Prompt Dialog Box
The Lotus 1-2-3 macro you are running requires more information.

To continue
1 Type the information in the box or boxes.
2 Press ENTER.
If more than one box appears, you can move back through the boxes by pressing ESC.    
You cannot backtrack into the menu from which the prompt dialog box was displayed.
To stop the macro now

Press CTRL+BREAK.
You can move the dialog box by dragging its title bar with the mouse.



Lotus 1-2-3 Menu Dialog Box
The Lotus 1-2-3 macro you are running requires you to choose a menu item.

To choose a menu item
Double-click the item you want.

-or-
Press the first letter of the item you want.

To stop the macro now
Press CTRL+BREAK.

You can move the dialog box by dragging its title bar with the mouse.
Clicking the Cancel button has the same effect as pressing ESC.



Macro Translation Assistant--Lotus 1-2-3 
For an introduction to the Macro Translation Assistant, select Overview.
Overview
Alert Messages
Translation Comments
Problematic Lotus 1-2-3 Macros
Translate Lotus 1-2-3 Command
Translating Lotus 1-2-3 Macros
Lotus 1-2-3 Commands That Require Editing to Translate



Overview of Macro Translation Assistant--Lotus 1-2-3
To translate a Lotus 1-2-3 macro, you start Microsoft Excel and open the Lotus 1-2-3 file 
containing the macros to translate.    Then, start the Macro Translation Assistant by choosing
the Translate Lotus 1-2-3 command, and specifying which macros you want to translate.
The Macro Translation Assistant translates the Lotus 1-2-3 macro into a Microsoft Excel 
macro, and writes the translated macro on a new macro sheet.    The original Lotus 1-2-3 
macros are displayed on the new macro sheet with the translated macro, unless you clear 
the Verbose check box.
See Also

Help
Differences Between Lotus 1-2-3 and Microsoft Excel Macros
Lotus 1-2-3 Commands
Lotus 1-2-3 Commands That Require Editing to Translate
Problematic Lotus 1-2-3 Macros
Translating Lotus 1-2-3 Macros



Lotus 1-2-3 Messages
These messages appear in boxes while your macro is being translated.    You must select a 
button in the box before translation can continue.
Comments that are displayed on the destination macro sheet after translation is complete 
are called translation comments.
The messages, listed alphabetically, include:

<Document> no longer open.
<Document> not translatable.
Can't communicate with Microsoft Excel.
Can't find Microsoft Excel.
Disk operation failed.
Formula in source cell <cell> too long.
Out of columns on target macro sheet.
Translation still in progress.



Translation Comments
These comments are displayed on the destination macro sheet after translation is complete.
They give information about translations that may not be exact, warn you about 
adjustments you may want to make yourself, and so on.    Each comment is adjacent to the 
cell containing the macro instruction it describes.
Messages appear in alert boxes.
Following are the translation comments listed in alphabetical order, under headings 
corresponding to the part of the translation comment that precedes the colon (:).    
For example, to find the comment "Not translated: All printing is formatted", look up "All 
printing is formatted" under the heading "Not Translated".
Errors

BRANCH or subroutine call to undefined name.
Branch through undefined menu name.
Expected reference to be a reference.
Expected type to be an argument type.
Formula is too long to translate.
Return in multiple states.
String too long.

Inexact translation
Aligns all labels.
Always translated into data find.
Displays formulas on entire document.
Formats whole document.
International date format not available.
International time format not available.
Movement not limited to input range.
Names and global settings not saved.
Password ignored.
Recalculates whole document.
Sets all column widths.
Unhidden columns given default width.

Not translated
+/- format not available.
All printing is formatted.
All recalculation is natural.
Can't translate ABS key.
Can't translate complex self-modifying macros.
Charts are separate files.
Configuration file not available.
Default status not available.
{DISPATCH} destination could change.
File listing not available.
Formatting scale numbers not available.
Intercept is always computed.
International currency format not available.



International date format not available.
International punctuation format not available.
International time format not available.
{LOOK} not available.
Lotus 1-2-3 clock not available.
Lotus 1-2-3 help type not available.
Lotus 1-2-3 worksheet status not available.
Microsoft Excel handles file replacement.
Printer connections are not numbered.
Printer driver handles auto-linefeed.
Printer driver handles page length selection.
Printer driver handles print wait.
Printer driver handles printer alignment.
Printer driver handles printer movement.
Printer driver handles printer setup.
Printer names are not numbered.
Range reset not available.
Skipping data points not available.
Split windows are always synchronized.
System call not available.

Warning
Assuming char is cancel/replace character.
Assuming interactive cancel/replace.
Assuming interactive password.
Assuming no cancel/replace character.
Assuming no password.
Assuming password to be password.
Assuming self-modified cell begins label.
Axis scaling not applied to empty charts.
Axis title not attached to pie charts.
Edited formula may be incorrect.
Edited name may be incorrect.
Edited range may be incorrect.
Gridlines not applied to pie charts or empty charts.
Line formatting not applied to empty charts.
Line formatting only applied if series exists.
Line formatting only applied to line and scatter charts.
No type given; assumed to be formula.
Selection depends on window size.
Shading, coloring, and exploded wedges not translated.
Title not attached to empty charts.
X axis scaling only applied to scatter charts.



Problematic Lotus 1-2-3 Macros
The following types of Lotus 1-2-3 macros may require editing to be correctly translated:

Macros that edit formulas will not always translate correctly.
Self-modifying macros can only be translated under certain conditions.
Some Lotus 1-2-3 commands may not translate precisely into equivalent Microsoft 

Excel macro functions.    For a list, see Lotus 1-2-3 Commands That Require Editing to 
Translate.

Some general differences between Lotus 1-2-3 and Microsoft Excel macros may cause
problems when a macro is translated.

Extremely large Lotus 1-2-3 macros may be difficult and time-consuming to translate. 
You may want to break them into smaller parts before translation.



Lotus 1-2-3 Commands That Require Editing to Translate
This is an alphabetical list of Lotus 1-2-3 commands that do not have direct equivalents in 
Microsoft Excel, or that require editing to translate.

{?}
{BIGLEFT}
{BIGRIGHT}
{DISPATCH}
/DRIC
/DRIZ
/FL
/FX
/GND
/GNR
/GOF
/GOFA
/GOFB
/GOFC
/GOFD
/GOFE
/GOFF
/GOFG
/GOG
/GOS
/GOSS
/GOSX
/GOSXF
/GOSYF
/GOTF
/GOTS
/GOTX
/GOTY
{LET}
{LOOK}
{MENUBRANCH}
{MENUCALL}
/PFA
/PFL
/PFOOF
/PFOOU
/PFOP
/PFOS
/PFP
{PGDN}
{PGUP}
/PPA



/PPL
/PPOOF
/PPOOU
/PPOP
/PPOS
/PPP
{PUT}
{QUERY}
{RECALC}
{RECALCOL}
/RF+
/RFD4
/RFD5
/RFDT3
/RFDT4
/RFT
/RI
/RNR
/S
/WCD
/WGC
/WGDOC
/WGDOH
/WGDOIC
/WGDOID
/WGDOIP
/WGDOIT
/WGDPA
/WGDPI
/WGDPN
/WGDPP
/WGDPS
/WGDPW
/WGDS
/WGDU
/WGF
/WGF+
/WGFD4
/WGFD5
/WGFDT3
/WGFDT4
/WGL
/WGRC
/WGRR
/WS



/WWU
/XM



Translate Lotus 1-2-3 Command
Translates Lotus 1-2-3 macros into Microsoft Excel macros.
Select Source Sheet

Lists open documents.    Select the document containing the macros you want to 
translate.

Select Macro(s) To Translate
Lists macros on the document you selected.    Select the macros you want to translate.

Verbose
Selecting the Verbose check box tells the Macro Translation Assistant to enter the Lotus 1-
2-3 macro commands being translated above the Microsoft Excel result on the destination
macro sheet.    The original Lotus 1-2-3 macro commands are printed in italic.
For more information about the Translate Lotus 1-2-3 Command, see Translating Lotus 1-
2-3 Macros.



Translating Lotus 1-2-3 Macros
1 Start Microsoft Excel.
2 Open the Lotus 1-2-3 file containing the macros you want to translate.

By default, only files whose extensions begin with XL are listed in the dialog box which 
is displayed when you choose Open from the File menu.    Lotus 1-2-3 files typically 
have extensions that start with WK.    To list those files, type *.WK* in the File Name 
box.

3 From the Microsoft Excel Control menu, choose Run.
4 Select Macro Translator and choose the OK button.
5  In the Macro Translation Assistant window, choose the Translate Lotus 1-2-3 command.
6 In the dialog box, select the document containing the macros you want to translate and

choose the OK button.
7 In the dialog box, select the macros to translate.

You can select multiple macros.
If you don't want to list the original Lotus 1-2-3 macros in the translated macro, clear 
the Verbose check box.

8 Choose the OK button.
The Macro Translation Assistant opens a new macro sheet (the destination macro 
sheet) and begins translating.    While it translates, it displays messages in the Macro 
Translation Assistant window.    If an error occurs, a message is displayed in a box.

To stop translation at any time
Press ESC.

The destination macro sheet is hidden during translation.    After translation is complete, or if
you stop translation by pressing ESC, the destination macro sheet is unhidden.
If the Macro Translation Assistant finds something that it cannot translate, or can only 
translate roughly, it enters a translation comment in bold characters directly above or below
the problem on the destination macro sheet.
After the macro is translated, the Macro Translation Assistant tells you that translation is 
complete and asks if you want to close the Macro Translation Assistant.    Choose the Yes 
button if you have finished translating; choose the No button if you would like to translate 
more macros.    If you choose the Yes button, another message asks if you want to open 
TRANS123.XLM (unless TRANS123.XLM is already open).    If you plan to run the translated 
macro now, choose the Yes button to open TRANS123.XLM.



{?} as Command Argument
Translated by displaying a dialog box in which you can enter a specific argument.    If the 
argument is a range, you can either type it in or select the range on the document.



{?} during Data Find
Translated by displaying a dialog box.    The dialog box contains a text box in which you can 
edit the contents of the active cell, plus the following:
Enter Button

Enters the edited contents in the cell.
Previous and Next Buttons

Moves the active cell to the previous or next database entry that matches the criteria.
Left and Right Buttons

Moves one cell in the specified direction so you can edit other cells.
Done Button

Closes the dialog box and continues to execute the macro.



Differences Between Lotus 1-2-3 and Microsoft Excel Macros
Running a macro

Run command macros in Microsoft Excel by pressing CTRL and the shortcut key instead of 
ALT and the macro name.

Values of cells containing strings
Cells containing strings (text) are not equivalent to 0 in Microsoft Excel, as they are in 
Lotus 1-2-3.    However, for operations that expect ranges as arguments, such as SUM and
AVERAGE, text is equivalent to 0.

Incomplete commands
Lotus 1-2-3 macros that begin a command but don't complete it (such as a single-cell 
macro containing /WGFF) can't be translated.    To allow for interactive input, use the {?} 
command.    For example, change a single-cell macro from:

'Name:
to:
'Name: {?}~

Formulas
Graphs
Names
Names in extracted ranges

When a range is extracted to a separate worksheet from within Lotus 1-2-3, the upper-left
corner of the extracted range becomes cell A1 on the new worksheet.    Names within the 
extracted range are updated to reflect the new location of the range.
If, for example, the range C3:E5 is extracted, that range becomes A1:C3.    If the cell D4 
within that range was named Profit, Profit now becomes cell B2.
When Microsoft Excel reads this worksheet, the name is not modified.    Profit, for 
example, would still refer to D4, not B2.    Macros that use the name may have 
unpredictable results.



{?} for Data Entry
Pauses for data entry are translated by displaying a dialog box.    The dialog box has a text 
box, containing the contents of the active cell, and the following buttons:
Enter Button

Enters the edited contents in the cell.
Up, Down, Left, and Right Buttons

Moves one cell in the specified direction, so you can edit other cells.
Done Button

Closes the dialog box and continues executing the macro.



Differences in Formulas
The differences in formulas are translated correctly by the Macro Translation Assistant for 
macros that enter formulas directly into a cell.    Macros that edit formulas may need to be 
edited before translation.
Range syntax

Corners of a range are separated by a colon (:) instead of by one or more periods.    R1C1-
style references are often used instead of A1-style references.

Worksheet functions
Function names are not preceded by @ signs.    Some functions have different names and 
arguments in Microsoft Excel than in Lotus 1-2-3.    

Logical operations
Worksheet functions are used (for example, AND(A,B)) instead of operators (for example, 
A#AND#B).

Names
The first character must be a letter.    Other characters can be letters, numbers, periods, 
and underscores.    Names can be up to 255 characters long.    The name can't be in the 
form of a reference (such as A1 or R[2]C[2]).



Differences in Graphs
Chart files

Charts are separate files, not just associated with a specific spreadsheet.    When you load
a Lotus 1-2-3 spreadsheet, Microsoft Excel asks whether charts should be converted into 
Microsoft Excel charts.    If a translated macro acts on these charts, the charts must be 
converted, and must be in the current directory when the translated macro is run.
Since charts are separate files, saving a worksheet does not save related charts.    You 
must save charts independently.

Display
Charts are always displayed when they are being acted on, not just in Graph View.

Series order
Series are numbered in the order in which they are entered.    If Lotus 1-2-3 series are 
numbered in a different order than they are entered, they may be operated on incorrectly
by a translated macro.



Self-modifying Macros
The Macro Translation Assistant can translate self-modifying macros that do the following:

Enter a simple string or value into a cell using {LET}, {GETNUMBER} and /SN, or 
{GETLABEL} and /XL.

Use that cell as part of a label, formula entry, or cell edit, or as an argument.
Not translatable are more involved self-modifying macros that perform the following tasks:

Substituting one command for another (for example, changing {READ} to {READLN} 
or /WIC to /WIR).

Changing a branch location (for example, changing {BRANCH E3 to BRANCH F3} or 
/XCsub1~ to /XCsub2~).

Modifying a macro by entering a value or label into a cell, or by editing a cell.
To translate a macro that performs an untranslatable self-modification, edit it to eliminate 
the self-modifying instructions or to perform the simple self-modifications described here 
(using {LET}, {GETNUMBER}, or {GETLABEL}).    If you use Lotus 1-2-3 version 1A, you can 
use the {LET} command even though Lotus 1-2-3 version 1A will not understand it -- the 
Macro Translation Assistant understands the command and will translate it.



Translating Multiple Macros
You can translate as many macros as you like at one time, as long as all the macros are on 
the same source document.

1 Choose Translate Lotus 1-2-3.
2 Select the document containing the macros you want to translate and then choose the 

OK button.
3 In the next dialog box, select all the macros you want to translate:

To select one macro, press an arrow key.
To select several macros that are together, press SHIFT+ARROW KEY.
To select several macros that are not together, press CTRL+ARROW KEY and SPACEBAR.
Mouse users can select macros by clicking the macro or holding down the SHIFT key 

and clicking several macros.
4 Choose the OK button.

If you select a macro that calls a subroutine, the Macro Translation Assistant automatically 
translates that subroutine with the calling macro.    You don't need to select the subroutine 
macro.



Differences in Names
Macro Names

A named macro may be reached in more than one state.    Since a name can only be 
defined once, the Macro Translation Assistant chooses an instance of the macro that is in 
READY mode.    The first cell of the macro is defined as the name, and is labelled in the 
column to the left of the macro.    If a macro is not in READY mode, the name is not 
defined, but is shown in parentheses in the column to the left of the first cell of the 
macro.

Named Ranges
Names in Microsoft Excel are more powerful than in Lotus 1-2-3.    In Lotus 1-2-3, names 
are simply used as substitutes for ranges.    For example, when displaying the formula 
1+B1, Lotus 1-2-3 checks to see if a name is defined as B1.    If a name is defined, for 
example,"top", the formula is displayed using that name (1+top).
In Microsoft Excel, names convey more meaning.    This can cause problems when 
translating.    For example, suppose you translated a macro that entered the formula 
1+B1 in a cell, then copied it down into the row below.    The Lotus 1-2-3 macro would 
enter the formula 1+B2 in the next row.    The Microsoft Excel translation, however, uses 
the name and enters the formula 1+top in the row below.
Be careful when using macros with named ranges.    If you are confused about whether 
names are being translated correctly, you can edit your original Lotus 1-2-3 macro to 
remove questionable names.



TRANS123.XLM
A macro sheet that contains subroutines that the Macro Translation Assistant sometimes 
uses in translated macros.    All translated macros automatically open TRANS123.XLM when 
they are opened.    
If you want to run a macro immediately after you translate it, make sure TRANS123.XLM is 
open.    Otherwise, the translated macro may try to call subroutines on TRANS123.XLM and 
won't be able to access them.    If this happens, Microsoft Excel tells you that there was a 
macro error in the cell containing the formula that tried to call the subroutine.
After a macro is translated, a dialog box asks if you want to close the Macro Translation 
Assistant.    If you choose the Yes button, another message asks if you want to open 
TRANS123.XLM.    If you choose Yes, make sure TRANS123.XLM is in the current working 
directory.    If it is not, the Microsoft Excel title bar blinks.    To continue:

1 Switch to the Microsoft Excel window.
Microsoft Excel says that TRANS123.XLM is not available.

2 Choose the OK button.
The Macro Translation Assistant then closes itself.    If you still want to run the macro, 
you can open TRANS123.XLM yourself by using the Open command from the File menu.



Out of columns on target macro sheet.
When the Macro Translation Assistant translates subroutines and branching macros, it 
enters sections of the translated macro in separate columns.    Lotus 1-2-3 macros that 
contain many subroutines and use extensive branching may use all the open columns on 
the destination macro sheet.
Break your macro into smaller pieces and try translating them separately.



Can't communicate with Microsoft Excel.
The Macro Translation Assistant may either be unable to open a destination macro sheet or 
be unable to read from or write to it.
This also occurs when Microsoft Excel runs out of memory.
Close unnecessary documents and applications and try translating again.



Can't find Microsoft Excel.
The Macro Translation Assistant can't establish a connection to Microsoft Excel.
Make sure that:

Microsoft Excel is running before you choose the Translate Lotus 1-2-3 command.
The Ignore Remote Requests check box in the Workspace Options dialog box has 

been cleared.



Document not translatable.
The document that you selected is not a valid worksheet.    Microsoft Excel charts, for 
example, cannot be translated.



Translation still in progress.
Microsoft Windows is being shut down before translation is complete.
Start Microsoft Excel and translate the macro again.



Document no longer open.
Either the original Lotus 1-2-3 worksheet or the destination macro sheet has been closed 
during translation.    If you did not close the document, it was probably closed by another 
application using dynamic data exchange (DDE).
Open the document and start translation again.



Disk operation failed.
Your disk may be full, or there may have been a hardware failure.
You can make room on your disk by deleting files you don't need any more.



Formula in source cell too long.
The cell contains a formula that is too long to be translated.
Edit the Lotus 1-2-3 macro to shorten the formula.



Not translated: Can't translate ABS key.
Pressing the ABS key changes a reference through a cycle of absolute, relative, and mixed 
references.    The Macro Translation Assistant does not support this.



Not translated: Printer driver handles auto-linefeed.
/WGDPA is not translated.
You don't need to specify whether linefeeds are sent after carriage returns.



Warning: Assuming char is cancel/replace character.
This command is writing to a file.    If the file already exists, the macro needs to specify 
whether to cancel the save or replace the existing file.    The Macro Translation Assistant 
assumes that char specifies Cancel or Replace.
If char is not specifying Cancel or Replace, add a tilde (~) before it in the Lotus 1-2-3 macro.



Not translated: Lotus 1-2-3 clock not available.
/Worksheet Global Default Other Clock affects the on-screen clock in Lotus 1-2-3.    Microsoft 
Excel has no on-screen clock, so there is no equivalent command.



Not translated: Configuration file not available.
/Worksheet Global Default Update saves Lotus 1-2-3 default settings in a configuration file.   
This has no equivalent in Microsoft Excel.



Not translated: Default status not available.
/WGDS is not translated.
Most of the default status information provided by the /WGDS command (such as clock 
display, printer setup strings, and help access method) does not apply in Microsoft Excel.
You can get pertinent status information by using macro functions:

The formula =DIRECTORY() returns the name of the current directory, as text.
Margins are defined on the destination macro sheet using the names _LeftMrgn, 

_RightMrgn, _TopMrgn, and _BottomMrgn.    Within a macro, you can use the GET.NAME 
function to learn the definition of a specific name.    For example, =GET.NAME("_LeftMrgn") 
returns the left margin.



Not translated: {DISPATCH} destination could change.
{DISPATCH} is not translated.
Since the contents of the dispatch cell could be changed before the {DISPATCH} command 
is executed, the Macro Translation Assistant does not know where the macro should 
continue executing.    Therefore, the translator does not know what cells to translate after 
the {DISPATCH} command.
To correct this problem, edit the Lotus 1-2-3 macro so that the dispatch is performed 
explicitly.    For example:

{IF DISPATCH = 1}{BRANCH branch1}
{IF DISPATCH = 2}{BRANCH branch2}
{IF DISPATCH = 3}{BRANCH branch3}
etc....



Error: BRANCH or subroutine call to undefined name.
There is a BRANCH command or subroutine call to a name that was not defined on the Lotus
1-2-3 spreadsheet.



Error: Expected reference to be a reference.
The reference is not a cell or range reference.



Error: Expected type to be an argument type.
The type is not one of the Lotus 1-2-3 argument types "value" or "label."



Inexact translation: Names and global settings not saved.
/File Xtract copies names, charts (graphs), defaults, and references in labels from the 
original spreadsheet to the new spreadsheet.
In Microsoft Excel, charts are available to the new document, since charts are separate files. 
Names, defaults, and references in labels, however, are not copied from the original 
document to the new document.



Not translated: File listing not available.
/File List lists all files of a certain type on a separate screen.
To get a list of files in a specific directory, use the FILES macro function.



Not translated: Intercept is always computed.
/DRIC and /DRIZ determine whether an intercept should be calculated or forced to zero 
during regression.



Not translated: Formatting scale numbers not available.
/GOSXF and /GOSYF are not translated.
To format scale values in Microsoft Excel, format the values on the worksheet used to create
the chart.



Not translated: Lotus 1-2-3 help type not available.
/Worksheet Global Default Other Help determines whether the current help file remains 
open after use.    This has no equivalent in Microsoft Excel.



Warning: Assuming interactive cancel/replace.
This command is writing to a file.    If the file already exists, the macro needs to specify 
whether to cancel the save or replace the existing file.    The Macro Translation Assistant 
assumes that the {?} command is provided to let the user specify Cancel or Replace.
If the {?} command is not provided for that purpose, add a tilde (~) before it in the Lotus 1-
2-3 macro and it will be interpreted correctly.



Inexact translation: Always translated into data find.
{QUERY} from READY mode repeats the last /Data Query command executed.    The Macro 
Translation Assistant can't predict what command will be executed last, so it always 
translates {QUERY} into the DATA.FIND(TRUE) macro function.



Not translated: Printer connections are not numbered.
/WGDPI is not translated.
To choose a printer, use the PRINTER.SETUP macro function.



Inexact translation: Displays formulas on entire document.
/Range Format Text displays formulas in a given range.
In Microsoft Excel, values or formulas are displayed for the entire document.



Inexact translation: Sets all column widths.
/Worksheet Global Column-Width changes only the default width of columns.
To avoid changing column widths that have already been set, position this command in the 
Lotus 1-2-3 macro before all commands that explicitly change column width.



Not translated: International currency format not available.
/WGDOIC changes the currency symbol.    This has no equivalent in Microsoft Excel.



Inexact translation: International date format not available.
/WGFD4, /WGFD5, /RFD4, and /RFD5 use the international date format set with the 
/WGDOID command.    Microsoft Excel has no equivalent to the /WGDOID command, so the 
Macro Translation Assistant translates /WGFD4 and /RFD4 into formatting with the format 
MM/DD/YY and translates /WGFD5 and /RFD5 into formatting with the format MM/DD.



Inexact translation: Formats whole document.
/Worksheet Global Format changes only the default format of cells.
To avoid reformatting ranges, position this command in the Lotus 1-2-3 macro before all 
commands that explicitly format ranges.



Inexact translation: Aligns all labels.
/Worksheet Global Label-Prefix changes only the default alignment of labels.    The 
translated macro will change the alignment of all cells in the worksheet.
To avoid realigning labels, position this command in your Lotus 1-2-3 macro before all 
commands that explicitly align labels.



Not translated: International punctuation format not available.
/WGDOIP changes the punctuation used for decimal points, thousands separators, and 
argument separators.    This has no equivalent in Microsoft Excel.



Inexact translation: International time format not available.
/WGFDT3, /WGFDT4, /RFDT3, and /RFDT4 use the international time format set with the 
/WGDOIT command.    Microsoft Excel has no equivalent to the /WGDOIT command, so the 
Macro Translation Assistant translates /WGFDT3 and /RFDT3 into formatting with the format 
hh:mm:ss and translates /WGFDT4 and /RFDT4 into formatting with the format hh:mm.



Error: Formula is too long to translate.
A Lotus 1-2-3 or Multiplan formula was translated into a Microsoft Excel formula that is too 
long for the Macro Translation Assistant to translate (more than 255 characters).    The 
formula will be truncated.



Not translated: {LOOK} not available.
{LOOK} puts the next character typed into a cell.    This has no equivalent in Microsoft Excel.



Not translated: Can't predict arguments chosen from a menu.
The Macro Translation Assistant does not know what names will be defined when the macro 
is run, so it cannot guess what arguments would be selected from the menu.
To correct the problem, edit your Lotus 1-2-3 macro so the command uses an explicit 
argument (for example, a filename) instead of choosing that argument from a menu.



Error: Branch through undefined menu name.
/XM, {MENUBRANCH}, or {MENUCALL} referred to a location that is undefined.



Not translated: Can't translate complex self-modifying macros.
The Macro Translation Assistant can translate self-modifying macros only under certain 
conditions.



Not translated: All recalculation is natural.
/WGRC and /WGRR are not translated.
Microsoft Excel always recalculates in natural order.    This means that a cell is recalculated 
after cells on which it is dependent have been changed.



Warning: Assuming no cancel/replace character.
This command is writing to a file.    If the file already exists, the macro needs to specify 
whether to cancel the save or replace the existing file.    The Macro Translation Assistant did 
not find a C or R to specify Cancel or Replace.    It also did not find a {?} to allow you to 
specify a Cancel or Replace character.
To specify a Cancel or Replace character, enter C or R in the same cell as the filename.



Warning: No type given; assumed to be formula.
{LET} or {PUT} entered an expression into a cell without specifying whether the expression
should be treated as a value or a label.    The Macro Translation Assistant treats the 
expression as a formula.
If the expression was supposed to be a label, it is generally easiest to add the :label suffix in
your original Lotus 1-2-3 macro and translate it again.    Or, you can add double quotation 
marks around the expression in the FORMULA macro function, remove the equal sign, and 
correct any changes the Macro Translation Assistant made when translating the label into a 
formula.



Not translated: International date format not available.
/WGDOID changes the date formats D4 and D5.    This has no equivalent in Microsoft Excel.



Not translated: International time format not available.
/WGDOIT changes the time formats D8 and D9.    This has no equivalent in Microsoft Excel.



Not translated: Printer driver handles printer alignment.
/PPA and /PFA tell Lotus 1-2-3 that the printer has been aligned at the top of a page.



The {?} Command
The Macro Translation Assistant translates most pauses by displaying a dialog box to accept 
input from the user.    Microsoft Excel accepts pauses that have the following purposes:

Entering data.
Entering an argument.
Editing during Data Find.
Entering passwords.
Specifying cancellation or replacement characters.

When you are writing to a file and that file already exists, you may have a pause to allow 
the user to specify whether the file should be replaced or whether the operation should be 
canceled.
If your macro uses a pause for another purpose, you must edit the macro.



Not translated: Printer driver handles page length selection.
/WGDPP, /PFOP and /PPOP are not translated.
With some printer drivers you can select an approximate page length (such as letter size or 
legal size) by choosing the Printer Setup command from the File menu.    To control this from
a macro, use the PRINTER.SETUP? and SEND.KEYS macro functions.



Not translated: /- format not available.
/WGF+ and /RF+ are not translated.
You can duplicate the appearance of the +/- format in another range on your worksheet:

1 Select a range the same size as the range containing the data.    The active cell should 
be the upper-left cell in that range.

2 Type the following formula, where ref is the reference of the upper-left cell in the range 
containing the data:

=REPT(IF(ref>=0,"+","-"),ABS(ref))
3 Press CTRL+ENTER to fill the formula into the selected range.



Not translated: Printer driver handles printer movement.
/PFL, /PFP, /PPL and /PPP are not translated.
To indicate where to start a new page, use the SET.PAGE.BREAK macro function.



Not translated: Printer names are not numbered.
/WGDPN is not translated.
To choose a printer, use the PRINTER.SETUP macro function.



Warning: Assuming password to be password.
The string password is in the same cell as a filename and is followed by a tilde (~).    The 
Macro Translation Assistant assumes that password is the password to be used in opening 
the file.
If password is supposed to be a label instead of a password, insert a tilde (~) between the 
filename and the password in the Lotus 1-2-3 macro.



Inexact translation: Password ignored.
Passwords must be entered when a password-protected file is opened -- they cannot be 
included in a macro.    You can, however, change the OPEN macro function to the OPEN? 
macro function.    OPEN? displays a dialog box so that you can enter a password.
If a {?} command is provided in your Lotus 1-2-3 macro for entering a password, that 
command is automatically translated into the OPEN? macro function.



Warning: Assuming interactive password.
A {?} was found in the same cell as the name of a file being opened.    The Macro 
Translation Assistant assumes that the pause was provided to allow a password to be 
entered.    It translates the action of opening the file using the OPEN? macro function.



Warning: Assuming no password.
If the file being opened is protected by a password, edit the Lotus 1-2-3 macro so that the 
password is in the same cell as the filename and is immediately followed by a tilde (~).



Not translated: Printer driver handles printer setup.
/WGDPS, /PPOS, and /PFOS send setup strings or control codes to a printer.



Not translated: Printer driver handles print wait.
/WGDPW is not translated.
If single-sheet printing is available, it is controlled by the driver for your printer.    To control 
this from a macro, use the PRINTER.SETUP? and SEND.KEYS macro functions.



Inexact translation: Movement not limited to input range.
/Range Input limits movement of the highlight to a specific range.    This has no equivalent in
Microsoft Excel.    The translated macro selects the upper-left cell of the range.
Movement within the input range may not translate correctly.    For example, {HOME} 
after /RI selects the upper-left cell of the input range, but upon translation selects the upper-
left cell of the worksheet.



Inexact translation: Recalculates whole document.
{RECALC} and {RECALCOL} recalculate a specified range.    Microsoft Excel always 
recalculates an entire document (with the possible exception of tables).    Also, recalculation 
is always in natural order, not by row or by column as in these commands.    The optional 
condition and iteration arguments to these commands are ignored.



Not translated: Microsoft Excel handles file replacement.
This command is writing to a file.    If the file already exists, the Lotus 1-2-3 or Multiplan 
macro needs to specify whether to cancel the save or replace the existing file.    In Microsoft 
Excel, a message is displayed asking if you want to replace the existing file.
You can use the formula =SAVE.AS(,0) to mark the active file as saved without writing it to 
your disk.    This can be useful if you want to close a document without saving changes, and 
don't want the replace/save message to be displayed.
If the existing file should always be replaced, you can disable all messages by using the 
ERROR macro function.    If you use ERROR, make sure that you don't need any other error 
handling.



Not translated: Range reset not available.
/Range Name Reset deletes all defined names.    In Microsoft Excel, names must be deleted 
individually with the DELETE.NAME macro function.



Not translated: System call not available.
/S accesses the operating system.



Not translated: Charts are separate files.
/Graph Name Delete and /Graph Name Reset clear graphs from a Lotus 1-2-3 spreadsheet.    
In Microsoft Excel, charts are separate documents.    
To delete a chart, you use the FILE.DELETE macro function.



Not translated: Skipping data points not available.
/Graph Options Scale Skip skips data points in a series.    This has no equivalent in Microsoft 
Excel.
You can use a macro to enter every nth point of the series in another range on the 
worksheet.



Error: Return in multiple states.
There is more than one possible return from a subroutine or from branches of a 
{MENUCALL} command, and the different returns occur in different states.
A state consists of:

Location in the Lotus 1-2-3 menu tree, and menu item currently highlighted.
Current stage of processing, if an argument to a command is being processed.
Other global settings (for example, whether the END key is activated).

Before the Macro Translation Assistant can translate this macro, you need to edit the 
subroutine or {MENUCALL} branches so that returns occur in the same state, such as 
READY mode.



Error: String too long.
A string being used by the Macro Translation Assistant was too long.    Check for cells 
containing very long strings, or ranges with very long names.    
This problem can also occur when arguments are being substituted into the argument list of
a macro function.    You can try editing the original macro to shorten any values or names 
that will be used as arguments in the translated macro.



Not translated: All printing is formatted.
/PPOOU, /PFOOU, /PPOOF, and /PFOOF enable and disable headers, footers, and page 
breaks.    This has no equivalent in Microsoft Excel.



Inexact Translation: Unhidden columns given default width.
/Worksheet Column Display restores an unhidden column to the width it had when it was 
hidden.    The Macro Translation Assistant displays unhidden columns using the default 
column width (8 characters).



Not translated: Split windows are always synchronized.
/WWU is not translated.
To scroll through windows on a document independently, open a new window using the 
NEW.WINDOW macro function.



Warning: Axis title not attached to pie charts.
/Graph Options Titles X-Axis and /Graph Options Titles Y-Axis add titles by the X or Y axis.    
This does not apply to pie charts.    If the chart is a pie chart /GOTX and /GOTY are not 
translated.



Warning: Shading, coloring, and exploded wedges not translated.
Pie charts in Microsoft Excel have no equivalent to the second graph series range in Lotus 1-
2-3.    
To shade or change the color of a pie slice

1 Select the slice with the SELECT macro function.
2 Change the shading or color with the PATTERNS macro function.

To explode a pie slice
1 Select it with SELECT.
2 Get its current position with GET.CHART.ITEM.
3 Move it with FORMAT.MOVE.

You can record these actions with the macro recorder.



Warning: Edited formula may be incorrect.
The Macro Translation Assistant translates Lotus 1-2-3 and Multiplan formulas into Microsoft 
Excel formulas.    When a formula is edited during macro execution, the equivalent Microsoft 
Excel formula is being edited.    You should check the resulting formula.



Warning: Gridlines not applied to pie charts or empty charts.
/Graph Options Grid adds gridlines to a graph.    This does not apply to pie charts, so if the 
chart is a pie chart /GOG is not translated.
Also, series in Microsoft Excel must be defined before they can be formatted.    If the 
translated macro does not add gridlines, edit the original Lotus 1-2-3 macro so that a series 
is defined before gridlines are added.



Not translated: Lotus 1-2-3 worksheet status not available.
/WS is not translated.
Microsoft Excel has no command equivalent to the /Worksheet Status command.    However, 
most of the same information is available through the Microsoft Excel macro functions 
GET.CELL, GET.DOCUMENT, GET.WINDOW, and GET.WORKSPACE.



Warning: Line formatting not applied to empty charts.
/Graph Options Format Graph specifies whether data points in all ranges of a graph are 
shown as symbols and/or connected by lines.    Series in Microsoft Excel must be defined 
before they can be formatted.    If the translated macro does not format your series, edit the 
original Lotus 1-2-3 macro so that the series is defined before it is formatted.



Warning: Line formatting only applied to line and scatter charts.
/Graph Options Format specifies whether data points are shown as symbols and/or 
connected with a line.    This only applies to line and xy (scatter) charts, so if the chart is not
a line or xy (scatter) chart /GOF is not translated.



Warning: Line formatting only applied if series exists.
/GOFA, /GOFB, /GOFC, /GOFD, /GOFE, and /GOFF specify whether data points in the data 
range specified (A through F) are shown as symbols and/or connected by lines.    Series in 
Microsoft Excel must be defined before they can be formatted.    If the translated macro 
does not format your series, edit the original Lotus 1-2-3 macro so that the series is defined 
before it is formatted.



Warning: Assuming self-modified cell begins label.
The Macro Translation Assistant can't determine whether a self-modified cell will contain a 
label or a formula and so uses label as a default.
If the cell begins a formula, add an equal sign in the FORMULA function.    For example, 
change =FORMULA("A+B") to =FORMULA("=A+B").



Warning: Edited name may be incorrect.
A range name entered interactively or by using self-modification may be incorrect.    The 
Macro Translation Assistant checks names for characters that are illegal in Microsoft Excel 
names and replaces them with underscores.    However, it cannot check a name that is 
entered interactively.



Warning: Edited range may be incorrect.
A named range entered interactively or by using self-modification may be incorrect:

The Macro Translation Assistant checks names for characters that are illegal in 
Microsoft Excel names and replaces then with underscores.    However, it cannot check the 
name of a range that is entered interactively.

If a Lotus 1-2-3 range name contains one or more periods, these are interpreted 
incorrectly as defining a range, and the periods will be converted to colons.



Warning: Axis scaling not applied to empty charts.
/Graph Options Scale lets you adjust the scale and formatting of axes.    Series in Microsoft 
Excel must be defined before they can be formatted.    If the translated macro does not 
format your axes, edit the original Lotus 1-2-3 macro so that a series is defined before the 
axes are adjusted.



Warning: Title not attached to empty charts.
/Graph Options Titles First and /Graph Options Titles Second add titles to a graph.    Series in 
Microsoft Excel must be defined before they can be formatted.    If the translated macro 
does not add titles, edit the original Lotus 1-2-3 macro so that a series is defined before 
titles are added.



Warning: Selection depends on window size.
{BIGLEFT}, {BIGRIGHT}, {PGUP}, and {PGDN} scroll by window.    The range selected by 
these commands in the translated macro depends on the number of columns or rows 
displayed in the Microsoft Excel window when the command is executed.    The number of 
columns or rows in a window depends on the size of the window as well as the width of 
columns and height of rows.
If, for example, your Microsoft Excel window is displaying 16 columns, the {BIGLEFT} 
command that would have scrolled through a Lotus 1-2-3 spreadsheet (using the default 
column width) 8 columns to the left, scrolls through your Microsoft Excel worksheet 16 
columns to the left.
If you adjust your Microsoft Excel window and Lotus 1-2-3 screen to display the same 
number of rows and columns, the translated macro selects the same range as the original 
Lotus 1-2-3 macro.



Warning: X axis scaling only applied to scatter charts.
/Graph Options Scale X-Scale adjusts the formatting and scale of the x-axis.    This only 
applies to xy (scatter) charts (XY graphs), so if the chart is not an xy (scatter) chart /GOSX is
not translated.



File Formats for Lotus 1-2-3
You can open Lotus 1-2-3 files in Microsoft Excel, and you can save Microsoft Excel files as 
Lotus 1-2-3 files.    Microsoft Excel can read files in the following Lotus 1-2-3 file formats:    
WKS (releases 1 and 1A), WK1 and associated FMT files (release 2.0 or later), and WK3 with 
associated FMT files (releases 3.0,    3.1+, and 1-2-3/W).    In WK3 format, Microsoft Excel can
read and write both 2-D and 3-D worksheets. Lotus 1-2-3 3-D worksheets are converted to 
Microsoft Excel workbook files and formulas are converted to their Microsoft Excel linked 
equivalents.
See Also

Help
Switching to Microsoft Excel from Lotus 1-2-3
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Microsoft Excel Equivalents for Frequently Used Lotus 1-2-3 
Commands

Lotus 1-2-3 command Microsoft Excel command
/c Copy and Paste (Edit menu)
/fd Open (File menu)
/few Delete (File menu)
/fr Open (File menu)
/fs Save As (File menu)
/gv Open (File menu)      Used when chart is in a separate file.
/m Cut and Paste (Edit menu)
/ppg Print (File menu)
/ppr Set Print Area (Options menu)
/qy Exit (File menu)
/re Clear (Edit menu)
/rf, Number    (Format menu)
/rfc Number (Format menu)
/rfp Number (Format menu)
/rnl Create Names (Formula menu)
/rnc Define Name (Formula menu)
/wcs Column Width (Format menu)
/wdr Delete (Edit menu)
/wey Close and New (File menu)
/wic Insert (Edit menu)
/wir Insert (Edit menu)
/wtc Unfreeze Panes (Options menu)
/wth Freeze Panes (Options menu)
/wtv Freeze Panes (Options menu)

See Also
Switching to Microsoft Excel from Lotus 1-2-3



Lotus 1-2-3 Functions
This is an alphabetic list of Lotus 1-2-3 functions that have Microsoft Excel equivalents.    
There are also a number of Microsoft Excel functions without 1-2-3 equivalents.
When Alternate Formula Entry is activated, you can type most of these functions directly 
into the formula bar, and they are automatically converted into their Microsoft Excel 
equivalents. To activate Alternate Formula Entry, choose the Calculation command from the 
Options menu. The functions that you cannot enter in this way are specific to Lotus 1-2-3 
Release 3 and later.
Microsoft Excel uses different rules than Lotus 1-2-3 does when evaluating text in formulas, 
certain database criteria, and the value of certain logical operators.    When Alternate 
Expression Evaluation is activated, some of the following functions will be interpreted as 
they would be in Lotus 1-2-3. To activate Alternate Expression Evaluation, choose the 
Calculation command from the Options menu. The affected functions are noted in the 
following list.    See also Entering Lotus 1-2-3 Formulas.

Lotus function Microsoft Excel equivalent
@@ INDIRECT
@ABS ABS
@ACOS ACOS
@ASIN ASIN
@ATAN ATAN
@ATAN2 ATAN2
@AVG AVERAGE
@CELL CELL
@CELLPOINTER CELL When used without a second argument, returns 

information about the current selection.
@CHAR CHAR
@CHOOSE CHOOSE
@CLEAN CLEAN
@CODE CODE
@COLS COLUMNS
@COS COS
@COUNT COUNTA
@CTERM NPER Requires periodic payment instead of future value.
@DATE DATE
@DATEVALUE DATEVALUE
@DAVG DAVERAGE
@DAY DAY
@D360 DAYS360 Lotus 1-2-3 Release 3 and later.
@DCOUNT DCOUNTA
@DDB DDB
@DGET DGET
@DMAX DMAX
@DMIN DMIN
@DSTD DSTDEVP
@DSTDS DSTDEV Lotus 1-2-3 Release 3 and later.
@DSUM DSUM
@DVAR DVARP



@DVARS DVAR Lotus 1-2-3 release 3 and later.
@ERR No equivalent is necessary, because Microsoft Excel lets 

you type error values directly into cells and formulas.
@EXACT EXACT
@EXP EXP
@FALSE FALSE
@FIND FIND
@FV FV
@HLOOKUP HLOOKUP Activate Alternate Expression Evaluation to use Lotus 1-

2-3's evaluation rules.
@HOUR HOUR
@IF IF Last two arguments can be any value, not just numbers 

or strings, as in @IF.
@INDEX INDEX Also has form for selecting values from an array.
@INT TRUNC
@IRR IRR Arguments are given in reverse order.
@ISERR ISERR Detects any of six Microsoft Excel error values.
@ISNA ISNA
@ISNUMBER ISNONTEXT
@ISRANGE ISREF Lotus 1-2-3 Release 3 and later.
@ISSTRING ISTEXT
@LEFT LEFT
@LENGTH LEN
@LN LN
@LOWER LOWER
@LOG LOG
@MAX MAX
@MID MID
@MIN MIN
@MINUTE MINUTE
@MOD MOD Activate Alternate Expression Evaluation to use Lotus 1-

2-3's evaluation rules.
@MONTH MONTH
@N N
@NA NA
@NOW NOW
@NPV NPV
@PI PI
@PMT PMT Arguments are in different order than in @PMT.
@PROPER PROPER
@PV PV Arguments are in different order than in @PV.
@RAND RAND Calculates values randomly each time it is recalculated 

(@RAND calculates the same values in each work 
session).

@RATE RATE Arguments are in different order than in @RATE.
@REPEAT REPT



@REPLACE REPLACE
@RIGHT RIGHT
@ROUND ROUND
@ROWS ROWS
@S T
@SECOND SECOND
@SIN SIN
@SLN SLN
@SQRT SQRT
@STD STDEVP
@STDS STDEV Lotus 1-2-3 Release 3 and later.
@STRING FIXED
@SUM SUM
@SYD SYD
@TAN TAN
@TERM NPER Arguments are in different order than in @TERM.
@TIME TIME
@TIMEVALUE TIMEVALUE
@TODAY TODAY
@TRIM TRIM
@TRUE TRUE
@UPPER UPPER
@VALUE VALUE
@VAR VARP
@VARS VAR Lotus 1-2-3 Release 3 and later.
@VDB VDB
@VLOOKUP VLOOKUP Activate Alternate Expression Evaluation to use Lotus 1-

2-3's evaluation rules.
@YEAR YEAR



Functions Without Lotus 1-2-3 Equivalents
Many Microsoft Excel functions have equivalents to Lotus 1-2-3 functions.    The following 
Microsoft Excel functions, however, have no equivalents in Lotus 1-2-3 Release 3.1 or 
earlier, or Lotus 1-2-3/W Release 1.0.    Microsoft Excel also provides many    add-in functions
and statistical functions that do not have Lotus 1-2-3 equivalents; these are    not included in
this list. 

AREAS
DOLLAR
DPRODUCT
FACT
FREQUENCY
GROWTH
INT
IPMT
ISBLANK
ISERROR
ISLOGICAL
LINEST
LOGEST
LOOKUP
MATCH
MDETERM
MINVERSE
MIRR
MMULT
PPMT
PRODUCT
SEARCH
SUBSTITUTE
TEXT
TRANSPOSE
TREND
TYPE
WEEKDAY

See Also
Help
Add-in Functions 
Statistical Functions 
Microsoft Excel Function Reference
Switching to Microsoft Excel from Lotus 1-2-3



Help for Lotus 1-2-3 Users
With Help for Lotus 1-2-3 Users, you can type Lotus 1-2-3 compatible keystrokes and then 
choose to display instructions for completing the same task in Microsoft Excel, or watch as 
Microsoft Excel demonstrates equivalents to familiar Lotus 1-2-3 commands.    There are two
ways to open the Help For Lotus 1-2-3 Users dialog box:

From the Help menu, choose Lotus 1-2-3.    
From the Options menu, choose Workspace. In the Alternate Menu Or Help Key box, 

type / (slash), and select the Lotus 1-2-3 Help option button.    With these settings, pressing / 
displays the Help For Lotus 1-2-3 Users dialog box.
Help for Lotus 1-2-3 Users dialog box options
Menu

Displays a list of Lotus 1-2-3 menu items.    Type the Lotus 1-2-3 keystrokes you would use
to choose a command.    The result depends on the type of help you select in Help 
Options, as described below.
For multilevel Lotus 1-2-3 menus, Microsoft Excel displays the next submenu on a status 
line at the bottom of the dialog box.    To move down to a lower menu level, select the 
menu item and press ENTER or type the first letter of the menu item.

Using 1-2-3 Help/To perform command in Microsoft Excel
Initially displays instructions for using Help for Lotus 1-2-3 Users.    If you select a Lotus 1-
2-3 command, this box displays instructions for performing the equivalent command in 
Microsoft Excel.    The title of this box changes depending on the menu item currently 
selected.
If you select the Instructions option under Help Options and then press ENTER when the 
command is selected and the procedure is visible, the dialog box disappears but the 
procedure remains posted on your sheet for reference as you carry out the command.    To
remove the text box, press ESC.

Help Options
Allows you to choose to display the Microsoft Excel equivalent procedure for carrying out 
a Lotus 1-2-3 command or to watch Microsoft Excel demonstrate the equivalent steps.
If you select Instructions, Microsoft Excel displays the procedure that is equivalent to the 
selected Lotus 1-2-3 command.    To select this option with the mouse, click the 
Instructions option button.    To select this option with the keyboard, press ALT+I.
If you select Demo, Microsoft Excel demonstrates how to carry out the equivalent 
Microsoft Excel command step by step.    To select this option with the mouse, click the 
Demo button.    To select this option with the keyboard, press ALT+D.
For commands requiring additional information, such as cell references, you will be 
prompted for the necessary information at the top of your Microsoft Excel window before 
the demonstration starts.
The Faster and Slower buttons allow you to choose from among five demonstration 
speeds, with 5 being the fastest and 1 being the slowest.    The current speed is displayed 
in the box to the right of the two buttons.    To select faster speeds, press ALT+F.    To select 
slower speeds, press ALT+S.

More Help
Displays a Help topic for the Lotus 1-2-3 command selected under Menu.

OK
Carries out the selected options. If the Demo option is selected, begins performing the 
equivalent Microsoft Excel actions on the screen. If the Instructions option is selected, 
places a text box on the worksheet containing the equivalent Microsoft Excel procedure.



Close
Closes the dialog box without applying the selected options.

See Also
Switching to Microsoft Excel from Lotus 1-2-3



Help for Lotus 1-2-3 Users
When a Help for Lotus 1-2-3 Users demonstration requires additional information, such as 
ranges, number of decimal places, or filenames, a new dialog box is displayed at the top of 
the window.    The dialog box prompts you for the necessary information.    

In most cases, you enter data into one or more text boxes, depending on the type of 
data required to carry out the command.    A default value may be displayed in the text box.

After making an entry, press ENTER to move to the next entry field.    On the last field, 
pressing ENTER causes the demonstration to proceed.

To back up to a previous entry field, press ESC.    From the first field, pressing ESC 
displays the main Help For Lotus 1-2-3 Users dialog box.

You can use the arrow keys to highlight and select a range.    You can use the PERIOD 
key to anchor a range to be selected.

A text box may include a list box that displays one or more alternatives.    You can 
enter the required data or select from the list.
Esc

Displays the previous Help for Lotus 1-2-3 Users dialog box or step.
Cancel

Closes Help for Lotus 1-2-3 Users.
OK

Applies selected options and performs the demonstration.
See Also

Switching to Microsoft Excel from Lotus 1-2-3



Lotus 1-2-3 Keyboard Equivalents
Microsoft Excel default keyboard equivalents to Lotus 1-2-3 keys are listed in the following 
tables.    If you have not activated the alternate navigation keys option, these equivalents 
will be in effect. 

Function Keys
Lotus 1-2-3 Microsoft Meaning

Excel
F1 F1 Help
F2 F2 Edit
F3 F3 Name
F4 F4 Absolute/Relative
F5 F5 Goto
F6 F6 Next window
F7 ALT, D, F Query (first time)

DOWN ARROW Query (thereafter)
F8 Automatic Table
F9 F9 Calculate
F10 F11 or ALT+F1 Graph
Navigation Keys
The default Microsoft Excel navigation keys are listed below. You can also activate 
Microsoft Excel's alternate navigation keys, which are equivalent to many of the Lotus 1-
2-3 navigation keys.
Lotus 1-2-3 Microsoft Excel
Up, Down UP ARROW , DOWN ARROW
Left, Right LEFT ARROW, RIGHT ARROW
End, Up CTRL+UP    or    END+UP
End, Down CTRL+DOWN  or    END+DOWN
End, Left CTRL+LEFT  or    END+LEFT
End, Right CTRL+RIGHT    or    END+RIGHT
Home CTRL+HOME
Tab CTRL+PAGE DOWN
Shift+Tab CTRL+PAGE UP
PgUp, PgDn PAGE UP, PAGE DOWN

See Also
Help
Alternate Navigation Keys
Keyboard Guide 
Switching to Microsoft Excel from Lotus 1-2-3



Lotus 1-2-3
Displays a dialog box in which you type Lotus 1-2-3 keystrokes to display instructions for 
completing the same operation in Microsoft Excel.    
See Also

Help
Help for Lotus 1-2-3 Users
Switching to Microsoft Excel from Lotus 1-2-3



What you typed was not a Lotus 1-2-3 command sequence. 
Choose the topic below or choose the Lotus 123 command from the Microsoft Excel Help 
menu and try again.
See Also

Help
Switching to Microsoft Excel from Lotus 1-2-3
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To enter Lotus 1-2-3 formulas
You can enter any formula or function exactly as you would in Lotus 1-2-3 by selecting the 
Alternate Formula Entry option. 

1 From the Options menu, choose Calculation. 
2 In the Sheet Options box, select the Alternate Formula Entry check box.

For example, you might use the following formula in Lotus 1-2-3:
@AVG(A1..A5)

With the Alternate Formula Entry option selected, the preceding formula is translated into 
the equivalent Microsoft Excel formula:

=AVERAGE(A1:A5)
See Also

Help
Lotus 1-2-3 Functions
Help for Lotus 1-2-3 Users
Alternate Navigation Keys
Keyboard Guide
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Multiplan Commands
Alpha
Blank
Copy
Delete
Edit
Format
Goto
Help
Insert
Lock
Move
Name
Options
Print
Quit
Run
Sort
Transfer
Value
Window
Xternal
See Also

Help
Help Multiplan.



Multiplan Copy Commands
Right
Down
From
Transpose



Multiplan Delete Commands
Row
Column



Multiplan Format Commands
Cells
Default Cells
Default Width
Default Height
Options
Width
Units Currency*
Time-Date Cells*
Time-Date Replace*
Replace**
Style**
Font**
*These commands appear only in Multiplan version 3.04 and earlier.
**These commands appear only in Multiplan version 4.0 and later.



Multiplan Format Options Command
Multiplan Option Microsoft Excel Equivalent
Commas* Number (Format menu)
Decimal separator** Changing the decimal separator
Error messages** No equivalent
Formulas Display (Options menu)

*This command appears only in Multiplan version 3.04 and earlier.
**These commands appear only in Multiplan version 4.0 and later.



Multiplan Format Time-Date Replace Command
There is no direct equivalent to the Multiplan Format Time-Date Replace command in 
Microsoft Excel.    You can use one of the 23 built-in time or date formats or create your own 
custom formats.



Multiplan Goto Commands
Macro
Name
Row-col
Window



Multiplan Insert Commands
Row
Column



Multiplan Lock Commands
Cells
Formula



Multiplan Move Commands
Row
Column



Multiplan Options Command
Multiplan Option Microsoft Excel Command or Action
Recalc Calculation (Options menu)
Iteration Calculation (Options menu)
Test at Calculation (Options menu)
Alpha/value You don't need to specify alpha or value; Microsoft Excel will accept any

type of valid data in the selected cell.
Learn Select all the cells in which you want to enter data.    The ENTER, TAB, 

and arrow keys move the active cell within the selection.
Mute 1 From the Excel Control menu, choose Run (ALT+SPACEBAR+U). 

2 Select Control Panel.
3 Choose the OK button.
4 Choose the Options button.

If the warning beep is selected, a check mark is displayed next to 
Warning beep on the Options menu.    To turn off the warning beep, 
choose Warning beep.

5 From the Options menu, choose Exit to close the Control Panel.
Old menus* No equivalent
Hold Alpha* You don't need to hold the Alpha command; Microsoft Excel is always 

ready to accept data in the selected cell.
*These commands appear only in Multiplan version 4.0 and later.



Multiplan Print Commands
Printer
File
Margins
Options
Heading*
*This command appears only in Multiplan version 3.0 and later.



Multiplan Print File Command
There is no procedure in Microsoft Excel Help for the Multiplan Print File command.    For 
information about printing to a text file, see your Windows documentation.



Multiplan Print Options Command
Multiplan Option Microsoft Excel Command
Area Set Print Area (Options menu)
Setup* Page Setup (File menu)
Formulas Display (Options menu)
Row-col numbers Page Setup (File menu)
Printer** Page Setup (File menu)
Model** Page Setup (File menu)
Draft** Print (File menu)
Number of copies*** Print (File menu)

*This command appears only in Multiplan version 3.04 and earlier.
**These commands appear only in Multiplan version 4.0 and earlier.
***This command appears only in Multiplan version 4.2.



Multiplan Run Commands
Command
Audit Formulas
Audit Cells
Report Print
Report File
Database Forward-Search**
Database Backward-Search**
Database Extract**
Database Delete**
DOS*
*This command appears only in Multiplan version 3.04 and earlier.
**These commands appear only in Multiplan version 4.0 and later.



Multiplan Run Command Command
There is no direct equivalent to the Multiplan Run Command command in Microsoft Excel, 
but you can switch to DOS by using the Microsoft Windows Program Manager.

To switch to DOS
1 Press CTRL+ESC to switch to the Task List.
2 From the Task List, select Program Manager and press ENTER.
3 From the File menu, choose Run.
4 Type command, and choose the OK button.
To return to Microsoft Excel
1 Type exit.
2 Press CTRL+ESC to switch to the Task List.
3 From the Task List, select Microsoft Excel and press ENTER.



Multiplan Run Report Print Command
Option Microsoft Excel Equivalent
Cross-ref No direct equivalent.    This command prints a report of all the cells that 

refer to another cell.    Use the Worksheet Auditor macro in the Macro 
Library.    
To track cell dependencies
1 From the Options menu, choose Workspace.
2 Under Display, select the Info Window box.
3 Choose the OK button.
4 From the Info menu, choose Precedents or Dependents.
5 In the Precedents or Dependents dialog box, select Direct Only or All 

Levels.
6 Choose the OK button.

You can also use the Select Special command on the Formula menu to 
track cell precedents and dependents.

Names No direct equivalent.    This command prints a report of all the names in a 
worksheet.    
To get a list of the names in a worksheet
1 Find an area in the worksheet that has a lot of empty cells.
2 Select the upper-left cell of the area.
3 From the Formula menu, choose Paste Name.
4 Choose Paste List.

Summary No direct equivalent.    This command prints a report of the conditions in a 
worksheet that are likely to cause errors.    Use the Worksheet Auditor 
Macro in the Macro Library to generate a report of the potential errors of 
your worksheet.



Multiplan Run Report File Command
Option Microsoft Excel Equivalent
Cross-ref No direct equivalent.    Use the Worksheet Auditor Macro in the Macro 

Library.    This command prints a report of all the cells that refer to another 
cell.
To track cell dependencies
1 From the Options menu, choose Workspace.
2 Under Display, select Info Window.
3 Choose the OK button.
4 From the Info menu, choose Precedents or Dependents.
5 In the Precedents or Dependents dialog box, select Direct Only or All 

Levels.
6 Choose the OK button.

You can also use the Select Special command on the Formula menu to 
track cell precedents and dependents.

Names No direct equivalent.    This command prints a report of all the names in a 
worksheet.
To get a list of the names in a worksheet
1 Find an area in the worksheet that has a lot of empty cells.
2 Select the upper-left cell of the area.
3 From the Formula menu, choose Paste Name.
4 Choose Paste List.

Summary No direct equivalent.    This command prints a report on the conditions in a 
worksheet that are likely to cause errors.    Use the Worksheet Auditor 
Macro in the Macro Library to generate a report of the potential errors of 
your worksheet.



Multiplan Sort Commands
Rows
Columns



Multiplan Transfer Commands
Load
Save
Clear All
Clear Window
Delete
Options Mode
Options Setup
Rename
Import*
*This command appears only in Multiplan version 4.0 and earlier.



To clear your work and start a new document
1 From the File menu, choose Close or Close All to close the active documents and their 

windows.
2 From the File menu, choose New to start a new document.



Multiplan Transfer Clear Window Command
There is no direct equivalent to the Multiplan Transfer Clear Window command in Microsoft 
Excel.

To create a new document, choose New from the File menu.
To close the active document, choose Close from the File menu.
To clear the contents of cells from a document, see Clearing data from cells.



Multiplan Window Commands
Split Horizontal
Split Vertical
Split Titles
Border
Close
Link



Multiplan Xternal Commands
Copy
List
Total
Use
Renew



Macro Translation Assistant--Multiplan
For an introduction to the Macro Translation Assistant, select Overview.
Overview
Alert Messages
Problematic Multiplan Macros
Translate Multiplan Command
Translating Multiplan Macros
Translation Comments



Overview of Macro Translation Assistant--Multiplan
To translate a Multiplan macro, you start Microsoft Excel and open the Multiplan file 
containing the macros you want to translate.    Then, you start the Macro Translation 
Assistant by choosing the Translate Multiplan command, and specifying which macros you 
want to translate.
The Macro Translation Assistant translates the Multiplan macro into a Microsoft Excel macro,
and writes the translated macro on a new macro sheet.    The original Multiplan commands 
are displayed on the new macro sheet with the translated macro, unless you clear the 
Verbose check box.
See Also

Alert Messages
Multiplan Commands
Problematic Multiplan Macros
Translating Multiplan Macros
Translating Multiple Macros
Translation Comments



Multiplan Alert Messages
These messages appear in alert boxes while your macro is being translated.    You must 
select a button in the alert box before translation can continue.
Comments that are displayed on the target macro sheet after translation is complete are 
called translation comments.
The alert messages, listed alphabetically, include:

Can't find Microsoft Excel.
Document no longer open.
Error: Subroutine call to undefined name.
Formula in source cell too long.
Not translated: Alpha/Value Mode not available.
Not translated: Branch through undefined menu name.
Not translated: Change in window link status not available.
Not translated: Multiplan Auditing/Reports not available.
Not translated: Multiplan Help not available.
Out of columns on target macro sheet.



Problematic Multiplan Macros
The following Multiplan macros may require editing to be correctly translated:

Macros that edit formulas.
Macros containing Multiplan commands that do not have equivalent macro functions 

in Microsoft Excel.
Macros that are extremely large.
Macros that contain locked cells.
Macros that have been assigned names or accelerator keys.
Macros that save files for Multiplan use.
Macros that enter formulas containing R1C1-style cell references. 
Macros that contain arrow key movements.
Macros that contain edited range references.
Macros that contain unsupported worksheet functions.
Macros that use multiple windows.
Macros that contain Multiplan Help commands.
Macros that contain Multiplan Run Audit and Run Report Commands.
Macros that run in Alpha/Value mode.
Macros that run in Learn mode.
Macros that use Multiplan Time and Date Formats.



Translate Multiplan Command
Translates Multiplan macros into Microsoft Excel macros.

Select Source Sheet:
Lists open documents.    Select the document containing the macros you want to 
translate.

Select Macro(s) To Translate:
Lists macros on the document you selected.    Select the macros you want to translate.

Verbose
Selecting the Verbose check box tells the Macro Translation Assistant to enter the 
Multiplan macro commands being translated above the Microsoft Excel result on the 
target macro sheet.    The original Multiplan macro commands are printed in italic.

See Also
Help
Translating Multiplan Macros.



Translating Multiplan Macros
To translate Multiplan macros
1 Start Microsoft Excel.
2 Open the Multiplan file containing the macros you want to translate.

To open Multiplan worksheets in Microsoft Excel, you must save those worksheets in 
the SYLK format.    To list those files, type *.SLK in the File Name box.

3 From the Microsoft Excel Control menu, choose Run (ALT+SPACEBAR+U).
4 Select Macro Translator and choose the OK button.
5 In the Macro Translation Assistant window, choose Translate Multiplan.
6 In the dialog box, select the document containing the macros you want to translate and

choose the OK button.
7 In the dialog box, select the macros to translate.

You can select multiple macros.
If you don't want to list the original Multiplan commands in the translated macro, clear 
the Verbose check box.

8 Choose the OK button.
The Macro Translation Assistant opens a new macro sheet (the target macro sheet) and
begins translating.    While it translates, it displays messages in the Macro Translation 
Assistant window.    If an error occurs, an alert message is displayed in an alert box.

To stop translation at any time
Press ESC.

The target macro sheet is hidden during translation.    After translation is complete, or if
you stop translation by pressing ESC, the target macro sheet is unhidden.
If the Macro Translation Assistant finds something that it cannot translate, or can only 
translate roughly, it enters a translation comment in bold characters directly above or 
below the problem on the target macro sheet.
After the macro is translated, the Macro Translation Assistant tells you that translation 
is complete and asks if you want to close the Macro Translation Assistant.    Choose the 
Yes button if you have finished translating; choose the No button if you would like to 
translate more macros.    If you choose Yes, another message asks if you want to open 
TRANSMP.XLM (unless TRANSMP.XLM is already open).    If you plan to run the translated
macro now, choose Yes to open TRANSMP.XLM.



Self-modifying Macros
The Macro Translation Assistant translates self-modifying macros that do the following:

1 Enter a simple string or value into a cell.
2 Use that cell as part of a label, formula entry, or cell edit, or as an argument.

Self-modifying macros that perform the following tasks are not translatable:
Substitute one command for another.
Change a branch location.
Modify a macro by entering a value or label into a cell, or by editing a cell.

To translate a macro that performs an untranslatable self-modification, edit the macro to 
eliminate the self-modifying instructions or so it performs the simple self-modification 
described here.    



Translating Multiple Macros
You can translate as many macros as you like at one time, as long as all the macros are on 
the same source document.

1 Choose Translate Multiplan.
2 Select the document containing the macros to translate and choose the OK button.
3 In the next dialog box, select all the macros to translate:

To select one macro, use an arrow key.
To select several macros that are together, use SHIFT+ARROW key.
To select several macros that are not together, use CONTROL+ARROW key+SPACEBAR.    
Using the mouse, click the macro or hold down SHIFT and select several macros.

4 Choose the OK button.
If you select a macro that calls a subroutine, the Macro Translation Assistant 
automatically translates that subroutine with the calling macro.    You don't need to 
select the subroutine macro.



TRANSMP.XLM
A macro sheet that contains subroutines that the Macro Translation Assistant sometimes 
uses in translated macros.    All translated macros automatically open TRANSMP.XLM when 
they are opened.
If you want to run a macro immediately after you translate it, make sure TRANSMP.XLM is 
open.    Otherwise, the translated macro may try to call subroutines on TRANSMP.XLM and 
won't be able to access them.    If this happens, Microsoft Excel tells you that there was a 
macro error in the cell containing the formula that tried to call the subroutine.
After a macro is translated, a dialog box asks if you want to close the Macro Translation 
Assistant.    If you choose the Yes button, another message asks if you want to open 
TRANSMP.XLM.    If you choose Yes, make sure TRANSMP.XLM is in the current working 
directory.    If it is not, the Microsoft Excel title bar blinks.    To continue:

1 Switch to the Microsoft Excel window.
Microsoft Excel says that TRANSMP.XLM is not available.

2 Choose the OK button.
The Macro Translation Assistant then closes itself.    If you still want to run the macro, 
you can open TRANSMP.XLM yourself by using the Open command on the File menu.



Translation Comments
These comments are displayed on the target macro sheet after translation is complete.    
They give information about translations that may not be exact, warn you about 
adjustments you may want to make yourself, and so on.    Each comment is adjacent to the 
cell containing the macro instruction it describes.
Messages that appear in alert boxes while your macro is being translated are called alert 
messages.
The translation comments are listed alphabetically below, under headings corresponding to 
the part of the translation comment that precedes the colon (:).    For example, to find the 
comment "Not translated: All printing is formatted." look up "All printing is formatted." 
under the heading "Not Translated:".
Error:

Can't define macro names
Expected reference to be a reference
Formula is too long to translate
Return in multiple states
String too long
Subroutine call to undefined name

Inexact translation:
Complex reference in command truncated
Formats whole document
Headers are text constants
Only totals numbers
Password ignored
Sets all column widths

Not translated:
Alpha/Value mode not available
Branch through undefined menu name
Can't translate complex self-modifying macros
Change in window link status not available
Command arguments chosen by menu are untranslatable
Completion test cell not available
Delimiters can't be specified
Display driver handles screen height.
File import query mode not available
Follow Mouse not available
International currency format not available
Learn mode not available
Links automatically updated
Microsoft Excel handles file replacement
Mouse button not available
Multiplan auditing/reports not available
Multiplan Help not available
Mute not available
Next/Previous unlocked cell not available



Numeric data always interpreted to be values
Page number adjustment ignored
Printer driver handles currency symbol
Printer driver handles page length selection
Printer driver handles printer setup
Printer name needed for printer selection
Region Recalc not available
Time-Date format replacement not available

Warning:
Assuming char is cancel/replace character.
Assuming interactive cancel/replace.
Assuming interactive password.
Assuming no cancel/replace character.
Assuming no password.
Assuming password to be password.
Edited formula may be incorrect.
Edited name may be incorrect.
Edited range may be incorrect.



Not translated: Alpha/Value Mode not available.
Multiplan uses an alpha/value option, returning to data entry mode after every command 
instead of returning to the main menu.    Macros that rely on running in Alpha/Value mode 
may not translate correctly.



Not translated: Multiplan Auditing/Reports not available.
Multiplan's Run Audit and Run Report commands are not emulated in Microsoft Excel.
Use the SELECT.SPECIAL() command to examine a cell's precedents and dependents and to 
find error values.
Use the NAMES() macro function to retrieve all names defined on the worksheet or macro 
sheet.



Not translated: Branch through undefined menu name.
An undefined menu has been referenced by an 'MC or 'MN command.



Not translated: Change in window link status not available.
Multiplan allows adjacent windows to be linked to and unlinked from each other at any time. 
Translated macros do not support this.



Out of columns on target macro sheet.
When the Macro Translation Assistant translates subroutines and branching macros, it 
enters sections of the translated macro in separate columns.    Macros that contain many 
subroutines and use extensive branching may use all the open columns on the target macro
sheet.
Break your macro into smaller pieces and try translating them separately.



Can't find Microsoft Excel.
The Macro Translation Assistant can't establish a connection to Microsoft Excel.
Make sure that:

Microsoft Excel is running before you choose the Translate Lotus 1-2-3 or the 
Translate Multiplan command.

The Ignore Remote Requests check box, which appears when you choose the 
Workspace command on the Options menu, has been cleared.



Document no longer open.
Either the original Lotus 1-2-3 or Multiplan worksheet or the target macro sheet has been 
closed during translation.    If you did not close the document, it was probably closed by 
another application using dynamic data exchange (DDE).
Open the document and start translation again.



Not translated: Multiplan Help not available.
Multiplan Help commands are not translated.



Formula in source cell too long.
The cell contains a formula that is too long to be translated.    
Edit the Lotus 1-2-3 or Multiplan macro to shorten the formula.



Error: Subroutine call to undefined name.
The translator encountered a subroutine call to a name that was not defined on the source 
worksheet.



Alpha/Value Mode
Multiplan uses an alpha/value option, returning to data entry mode after every command 
instead of returning to the main menu.    Macros that rely on running in Alpha/Value mode 
may not translate correctly.



Arrow Key Movements
The translator translates arrow key movements into relative selections. For example, 'DK -> 
=SELECT(R[1]C).    Multiplan arrow keys move the highlight only to the edge of the 
worksheet.    Translated macros do not check this, so they can erroneously cause the 
highlight to wrap around to the far side of the spreadsheet.



Multiplan Run Audit and Run Report Commands
The Multiplan Run Audit and Run Report commands are not emulated in Microsoft Excel.    
Use the SELECT.SPECIAL() command to examine a cell's precedents and dependents and to 
find error values.    Use the NAMES() macro function to retrieve all names defined on the 
worksheet or macro sheet.



Warning: Assuming char is cancel/replace character.
This command is writing to a file.    If the file already exists, the macro needs to specify 
whether to cancel the save or replace the existing file.    The Macro Translation Assistant 
assumes that char specifies Cancel or Replace.



Not translated: Command arguments chosen by menu are 
untranslatable.
The translator is unable to translate macros that select arguments, such as filenames and 
range names, from a menu.    The translator doesn't know what names will be defined when 
the macro is run, so it cannot guess what names are being selected by moving through a 
menu. 
Change the instruction to use regular arguments (for example, if reading a file name, type 
the name).



Not translated: Completion test cell not available.
Multiplan allows you to specify a cell containing a complex completion test used to 
determine when to terminate iteration.    Microsoft Excel iteration does not allow the user to 
do this;    you need to use Microsoft Excel's system of iteration.    
See Also

User's Guide (Book 2)
Chapter 1,    "Analyzing and Calculating Data" 



Not translated: International currency format not available.
Multiplan allows you to set the international currency symbol and the decimal separator.    
The Macro Translation Assistant does not support this.    



Not translated: Delimiters can't be specified.
The Multiplan text file import command lets you specify which characters are to delimit data
fields.    Microsoft Excel does not support this.



Not translated: Display driver handles screen height.
This command adjusts the standard screen height of the Multiplan display.    In Microsoft 
Windows screen height is automatically set by the display driver.



Not translated: Follow Mouse not available.
The Multiplan special mouse tracking command codes have no direct translation in 
Microsoft Excel.



Inexact translation: Formats whole document.
In Multiplan, a default format can be set without affecting previously formatted cells.      The 
translated command resets the format for the whole worksheet, including previously 
formatted cells.    If you don't want cells to lose previous formats, use this command before 
formatting any cells.



Inexact translation: Headers are text constants.
Multiplan takes a cell address for printing headers and footers, and uses the cell contents 
when printing.    Microsoft Excel takes string constants.    Macros that change the contents of 
these header cells after you specify them using the Print Heading command will not 
translate correctly; the contents of the cells at the time that the Print Heading command is 
chosen will be used instead of the new contents.



Multiplan Help
Multiplan Help commands are not translated.



Warning: Assuming interactive cancel/replace.
This command is writing to a file.    If the file already exists, the macro needs to specify 
whether to cancel the save or replace the existing file.    The Macro Translation Assistant 
assumes that the '? command is provided to let you specify Cancel or Replace.



Not translated: File import query mode not available.
The Multiplan Text File Import command has a query option that prompts the user before a 
cell is overwritten.    Translated macros do not support this.



Interactive Macros
The Translation of Multiplan pause macro command suffers the same limitations as the 
Lotus 1-2-3 pause command.    For more information about the {?} command, see the {?} 
command in Problematic Lotus 1-2-3 Macros.
When the Multiplan pause macro is encountered while processing a command field, only the
currently selected field may be interactively edited.    Since Multiplan allows you to "tab" 
between fields until the pause command is terminated by a return, Multiplan allows several 
fields to be interactively edited.    The translator allows editing of the current field only.    
Modify the Multiplan macro to explicitly tab to and pause at each field to be edited.



Not translated: Links automatically updated.
Multiplan links to source worksheets must be explicitly renewed using the External Renew 
command.    In Microsoft Excel, these links become external references and are renewed 
automatically.    The Multiplan External Renew command does not require translation.



Not translated: Learn mode not available.
The Multiplan "Learn" option moves the selection in a learned direction after each data 
entry.    The translator does not support this option.    Macros relying on learn mode may be 
translated incorrectly.



Learn Mode
The Multiplan"Learn" option, which automatically moves the selection in a learned direction 
after each data entry, is not supported by the translator.    Macros relying on learn mode 
may translate incorrectly.



Not translated: Can't translate complex self-modifying macros.
The Macro Translation Assistant can translate only certain self-modifying macros.



Not translated: Mouse button not available.
Multiplan's special mouse tracking command codes have no direct translation in Microsoft 
Excel.



Multiple Windows
The Multiplan linked and unlinked window splits are not directly supported by Microsoft 
Excel.    Linked window splits are implemented with multiple panes, and unlinked window 
splits are implemented with separate windows.    
Please note the following limitations:

1 The translator uses the Arrange All command to simulate the appearance of Multiplan's
split windows.    Windows split by Multiplan, however, might not appear in the same 
positions on the screen when you use Microsoft Excel .    Also, if other documents are 
loaded, they appear within the arrangement.    Use the HIDE, SIZE, and MOVE Microsoft 
Excel macro functions to create the window arrangements you want.

2 The active cell in the current window may not be visible in scrolling macro commands.
3 Microsoft Excel supports only a single split in each direction.    Multiple linked window 

splits in the same direction will not translate.



Not translated: Mute not available.
Multiplan supports a mute option, which turns off the sound.    This option is not available in 
Microsoft Excel. 
You can turn off the sound manually using the Control Panel.



Macro Names and Accelerator keys
Macro names and accelerator key sequences can be assigned to Multiplan macros.    Macro 
name and accelerator key information is lost when Multiplan SYLK files are loaded into 
Microsoft Excel.    
To assign accelerator keys to Multiplan macros in Microsoft Excel, name the macros using 
the Define Name command on the Formula menu.



Warning: Assuming no cancel/replace character.
This command is writing to a file.    If the file already exists, the macro needs to specify 
whether to cancel the save or replace the existing file.    The Macro Translation Assistant did 
not find a Y or N to specify Replace or Cancel.    It also did not find a '? to allow you to 
specify a Cancel or Replace character.
To specify a Cancel or Replace, type Y or N in the same cell as the filename.



Error: Can't define macro names.
Multiplan defines macro names on worksheets.    Microsoft Excel defines macro names only 
on macro sheets.    If you translate a Multiplan macro that attempts to define a macro name 
on a worksheet, that function will return an error.



Not translated: Numeric data always interpreted to be values.
The Multiplan Text File Import command allows you to specify whether numbers are 
interpreted as values or as text.    In Microsoft Excel, numbers are always interpreted as 
values.



Not translated: Next/Previous unlocked cell not available.
Microsoft Excel does not support Multiplan commands that select the next and previous 
unlocked cell.



Inexact translation: Only totals numbers.
The Multiplan Xternal Transfer command translates into the Microsoft Excel PASTE.SPECIAL()
command macro, with the appropriate arguments.    The resulting PASTE.SPECIAL() 
command ignores cells containing text.    The Xternal Transfer command copies them.



Inexact Translation: Password ignored.
The Macro Translation Assistant does not automatically translate a password.    Multiplan 
macros that open password-protected files cannot automatically provide the passwords.    
Interactive passwords (using the pause command), however, cause the Microsoft Excel 
Open command on the File menu to become interactive.    You can then manually edit the 
translated macro command to include the password or supply the password in the Open 
dialog box.



Not translated: Page number adjustment ignored.
The Macro Translation Assistant does not automatically translate a page number 
adjustment.    Multiplan allows you to specify the first page number to be used in numbering 
pages to be printed and the format of the page numbers (for example, 1, i), or to manually 
edit the header and footer codes.



Not translated: Printer driver handles currency symbol.
Multiplan allows you to specify the character sequence used to print a currency symbol.    In 
Microsoft Excel, the printer driver generates the currency symbol.



Not Translated: Print to file not available.
Multiplan allows printing to a print file instead of directly to the printer.    Microsoft Excel 
does not allow this.



Not translated: Printer driver handles page length selection.
Multiplan allows the user to set the page length.    In Microsoft Excel, the selected printer 
driver controls page length.    The printer setup for the selected printer may allow you to 
select an approximate page length (for example, letter size), depending on the printer 
driver.



Not translated: Printer driver handles printer setup.
This Multiplan command specifies setup information to be sent to the printer.    In Microsoft 
Excel this is done for you by the selected printer driver.



Worksheet Protection
Translated Multiplan macros run only on unprotected worksheets.    Multiplan SYLK sheets 
containing locked cells are loaded into Microsoft Excel with protection enabled.    Protection 
must be disabled for translated macros to run correctly.
For translated Multiplan Lock commands to have effect, enable protection on your Microsoft 
Excel worksheet or macro sheet.    Multiplan Lock commands are translated into the 
Microsoft Excel Cell Protection command, which does not lock cells until worksheet 
protection is enabled.



Not translated: Printer name needed for printer selection.
The "adaptor" Multiplan print option selects a printer for a specified device name (for 
example, LPT1).    The Microsoft Excel PRINTER.SETUP() macro function can select a printer, 
but you must specify the name of the printer, as well as the device name (for example, 
PRINTER.SETUP("HP Laserjet+ on COM1")).    You must add this specification to the 
translated macro.



Warning: Assuming password to be password.
The string password is in the same cell as a filename and is followed by an 'RT.    The Macro 
Translation Assistant assumes that password is the password to be used in opening the file.



Warning: Assuming interactive password.
A '? was found in the same cell as the name of a file being opened.    The Macro Translation 
Assistant assumes that the pause was provided to allow a password to be entered.    It 
translates the action of opening the file using the OPEN? macro function.



Warning: Assuming no password.
If the file being opened is protected by a password, edit the Multiplan macro so that the 
password is in the same cell as the filename, and it is immediately followed by an 'RT.



Edited Range References
Multiplan supports range references consisting of a range of row numbers followed by a 
range of column numbers.    Simple references of this type are translated.    Edited 
references of this type, however, are not converted by the Macro Translation Assistant, and 
macros containing them may fail.



R1C1-Style Cell References
Translated Multiplan macros are meant to run with Microsoft Excel in the R1C1 mode.    
Attempts to enter a formula containing the R1C1 reference style while Microsoft Excel is in 
A1 mode will cause an error.



Not translated: Region recalc not available in Microsoft Excel.
This macro command code recalculates a specified region.    Microsoft Excel does not 
support this feature.



Not translated: Microsoft Excel handles file replacement.
If a Multiplan file cancel/replace character is detected, it is not translated. The Microsoft 
Excel macro language offers no control over whether or not a file is replaced;    the "Replace 
existing file..." message box always appears.    If the existing version of a file should always 
be replaced, you can disable this box by disabling error messages with the ERROR() 
command.



Error: Return in multiple states.
If there is more than one return from a subroutine, or if there is an 'MC (with each branch 
returning after the call), the different returns must all be in the same state for the Macro 
Translation Assistant to continue properly.    "State" consists of the menu tree location and 
the argument being processed, the status of processing this argument (for example, is it a 
string constant or is there editing, self-modification, or interactive input; is the range 
anchored or not), and other global settings.
Change the subroutine or 'MC branches so that returns are all in the same state.



Saving Microsoft Excel files for use with Multiplan
Microsoft Excel macros normally save files in the Normal Microsoft Excel file format.    To 
save files for use with Microsoft Excel using macros in Multiplan, your macros must use the 
SYLK format.
To create a Multiplan macro that saves files in the SYLK format, add a Transfer Options 
command that switches to symbolic mode (SYLK) before saving the file for the first time.    
To save files when working in Microsoft Excel for use with Multiplan, edit the Microsoft Excel 
SAVE.AS() command to specify SYLK in the type_num field.



Inexact translation: Sets all column widths.
In Multiplan, a default column width can be set without affecting columns whose widths 
have previously been set.    The translated command resets the column width for all 
columns in the document.    If you don't want to lose previously set column widths, use this 
command before setting any column widths.



Not translated: Time-Date format replacement not available.
This command globally substitutes one time-date format for another.    Microsoft Excel does 
not support this substitution.



Time and Date Formats
In Multiplan, a cell's time-date format is maintained independent of its number format; time 
values are displayed in the time-date format, nontime values in the number format.    
Microsoft Excel makes no such distinction; choosing a time-date format replaces a cell's 
number format.
Multiplan allows time and date formats to be chosen from a list.    The Macro Translation 
Assistant supports only formats entered as text.
Multiplan allows global replacement of one time-date with another.    Microsoft Excel does 
not support this substitution.



Translating Large Multiplan Macros
Extremely large Multiplan macros may be difficult and time-consuming to translate.    You 
may want to break them into smaller parts before translation.



Inexact translation: Complex reference in command truncated.
Multiplan allows complex reference expressions within commands.    For example, with a 
macro Multiplan can clear a noncontiguous selection such as R1C1:R3C3,R5C1:R5C3.    
Microsoft Excel's macro commands cannot operate on complex references such as this.    
The translator displays the above message, and then shortens the reference, keeping only 
everything up to the first ',' or ' '(intersection).



Unsupported Worksheet Functions
The Multiplan worksheet functions NAME(), DELTA(), and ITERCNT() have no equivalents in 
Microsoft Excel.



Not translated: Window borders automatic under Windows.
Multiplan allows you to specify whether windows are to have borders.    This is not an option 
with Windows.



Not translated: Windows controls window color.
Multiplan allows each window to have its own foreground, background, and border color.    
Microsoft Windows does not support this; all windows receive the same colors, which are 
selected in the Control Panel.



Multiplan Files and Microsoft Excel
Multiplan version 4.0 and later can open and save files in a Microsoft Excel file format.

To open a worksheet in Microsoft Excel that was created with Multiplan version 
3.04 and earlier
1 From the File menu, choose Open.
2 In the File Name box, type *.*
3 Choose the OK button.
4 In the list box, select the Multiplan worksheet.
5 Choose the OK button.
To save a Microsoft Excel worksheet so you can open it in Multiplan version 
3.04 and earlier
1 From the File menu, choose Save As.
2 Choose the Options button.
3 In the File Format box, select SYLK.
4 Choose the OK button.
5 In the Save Worksheet As box, type a name for the Multiplan worksheet.
6 Choose the OK button.
To save a Microsoft Excel worksheet so you can open it in Multiplan version 4.0 
and later
1 From the File menu, choose Save As.
2 Choose the Options button.
3 In the File Format box, select Excel 2.2.
4 Choose the OK button.
5 In the Save Worksheet As box, type a name for the Multiplan worksheet.
6 Choose the OK button.



Multiplan Function and Special Keys
Selecting and Carrying Out Commands
Multiplan key Microsoft Excel command or action
F1 or SEMICOLON (;) or CTRL+W 1,2,3,...9 (Window menu)
F2 or CTRL+F Find next unlocked cell
SHIFT+F2 or CTRL+R, CTRL+F Find previous unlocked cell
F4 or EXCLAMATION MARK (!) F9 or Calc Now button in the Calculation (Options menu) 

dialog box
F6 or COLON (:) Extend the selection
ALT+H or QUESTION MARK (?) Help
Editing Cells and Commands
Multiplan key Microsoft Excel command or action
F3 or AT SIGN (@) Reference (Formula menu)
F5 or CTRL+V Edit cells on macro sheet
SHIFT+F1, SHIFT+F6 1,2,3,...9 (Windows menu)
SHIFT+F3, arrow key or 
AT SIGN (@), AT SIGN (@), 
arrow key Paste Function (Formula menu)
F3, arrow key or @, arrow key Paste Name (Formula menu)
SHIFT+F5 or CTRL+T Step through macro
SHIFT+F6 or CTRL+R, CTRL+U Recalculate links
SHIFT+F8 or CTRL+R, CTRL+O Edit home
SHIFT+F9 or SHIFT+F7
or CTRL+R, CTRL+R Record and Stop Recorder (Macro menu)
SHIFT+F10 or CTRL+R, CTRL+PEdit end
F7 or CTRL+O Word left
F8 or CTRL+P Word right
F9 or CTRL+K Character left
F10 or CTRL+L Character right



Locked cells cannot be changed.
When a document is protected (with the Protect Document command on the Options menu),
you cannot change a locked cell.    You generally cannot modify the document if it has been 
protected.    
If you want to edit designated cells of a protected document while still protecting other 
parts of the document:

1 From the Options menu, choose Unprotect Document.
2 Type the password and choose the OK button.
3 Select the cells you want to change.
4 From the Format menu, choose Cell Protection.
5 Clear the Locked check box.
6 Choose the OK button.
7 From the Options menu, choose Protect Document.

You may now change the contents of the cells you unlocked.
See Also

Help
Cell Protection Command (Format Menu)



Data type is not valid.
Either the data you entered in the dialog box could not be converted to the data type 
specified by the type argument of the INPUT macro function, or the data type specified for 
the INPUT macro function is not valid.
The type-num argument of the INPUT macro function must be one of the following numbers 
or the sum of a combination of two or more of the following numbers:

Type-num Data Type
0 Formula
1 Number
2 Text
4 Logical
8 Reference
16 Error
64 Array

When you specify the type as a sum of data types, the input box accepts data of more than 
one type. For example, =INPUT("Enter text or a number.",3) allows input of text or numbers.



[Entry] is too long.
Formula is too long.

The formula you are entering is too long or complex.    Try breaking the formula into two 
or more parts and entering each into a different cell.

Text is too long.
The text you are entering is too long. You can enter a maximum of 255 characters in the 
formula bar or in a dialog box.    Reduce the number of characters used in the text string 
or cancel the entry.



Formula is not valid.
Entering a formula
The formula you have entered is not a valid Microsoft Excel formula.    For information on the
correct syntax for the formula you've entered, see the Microsoft Excel Function Reference.
Either enter a valid formula or press ESC to cancel the current invalid formula.
Choosing a user-defined command
The formula associated with the command does not result in a valid macro sheet reference.  
Either the macro sheet associated with that command is not open, or you specified an 
invalid menu descriptor in an ADD.COMMAND or ADD.MENU function.    
Make sure the macro references in the menu descriptor are external references entered as 
text.



Name in formula is unclear.
Microsoft Excel could not understand the text in the formula bar.    One of the following has 
happened:

You want text to appear on the chart as the name of a series, but you forgot to put 
quotation marks around the series' title argument in the SERIES function. For example, 
=SERIES("Total Income",Budget!B13:G13,Budget!B14:G14,1)

You want to link a text label or data series to a name on a worksheet, but you forgot 
to specify the worksheet in the formula. For example, for the SERIES function:
=SERIES(,,Revenue!Sales,1), for a linked text formula:    =Revenue!ChartTitle

You want a text label on your chart to begin with an equal sign (=), but you did not 
enter the formula correctly. For example, ="=Total"
Determine the problem in the formula, correct it, and try again.



Error in formula.
The formula you tried to enter contains an error.    Microsoft Excel attempts to highlight the 
error.
If you are entering a mathematical formula, correct the formula or cancel it.    If you cannot 
correct the formula now and don't want to cancel it, delete the equal sign from the formula.  
Microsoft Excel will enter the data as text.    Remember to fix the error and reinsert the equal
sign later.
To correct the formula

1 Choose the OK button to close the message.
2 Edit the formula in the formula bar.
3 Press ENTER.

To cancel the formula
1 Choose the OK button to close the message.
2 Press ESC.

Some common formula issues include:
Unmatched parenthesis.
Too few or too many arguments in a function.
Invalid character where an operator was expected.    For example:    =5@7
Worksheet name enclosed in quotation marks but not followed by an exclamation 

point.    For example:    ='budget.xls'5
External reference without a worksheet name (on a worksheet other than a macro 

sheet).    For example:    =!$A$5
Incorrectly constructed number.    For example:    =5c3
External reference referring to something other than a name or a reference.    For 

example:    =budget.xls!5
Missing operand.    For example:    =5+
Missing closing bracket for array constants.    For example:    ={1, 2, 3,
Nonrectangular array constant.    For example:    ={1, 2, 3; 4, 5}
Reference number out of range.    For example:    A16385, R5C258    (a worksheet is 

16384 rows by 256 columns).
Nested external references.
Alternate Formula Entry is on.    Clear the Alternate Formula Entry check box in the 

Calculation Options dialog box and try again.



Function is not valid.
The function you are using is either not valid in Microsoft Excel or is not valid in this type of 
document.    For example, the SERIES function is valid in a chart but invalid in a worksheet 
or macro sheet.
If you are creating a macro and using a function with a ? (question mark) attached, make 
sure the function corresponds to a command that has a dialog box.
Check the function, and then try again.



That name is not valid.
The name you entered to define a name for a formula or an area of the worksheet is not 
valid.
To enter a valid name

1 Choose the OK button to close the message box.
2 In the Name box, type a valid name.
3 Choose the OK button to define the name.



Cannot enter an external reference to a chart.
You tried to enter an external reference in a chart.
If you want to use an external reference to the data presented in a chart, you must use a 
reference to the worksheet cells included in the chart series formula; otherwise, you cannot 
enter an external reference to a chart.



Name is not defined.
The name you typed is not defined on this worksheet.
Choose the Define Name command from the Formula menu to see a list of the names 
defined on this worksheet and their correct spelling.



Number format is not valid.
Microsoft Excel cannot accept the number format you typed.
Correct the format or choose one of the built-in formats.
See Also

Help
Number Command (Format Menu)



Selection too large.
Too many cells are selected for the operation you are performing.    A selection may be too 
large because:

You have nonadjacent selections comprising more than 2048 separate cell ranges.
You are creating an array formula and the selection exceeds 1636 cells.    If possible, 

enter two or more separate array formulas.
Choosing the Select Special command from the Formula menu starts to build a 

selection that is too complex.
Reduce the number of cells selected and try the operation again.    To complete the 
operation on the entire area, you may need to perform the operation on two or more 
smaller areas.



Cannot paste that macro formula onto a worksheet.
You're attempting to paste onto a worksheet a formula that is allowed only on a macro 
sheet.
Either paste the formula onto a macro sheet or choose a valid worksheet formula to paste 
onto the worksheet.



Cannot resolve circular references.
There is a circular reference and the Iteration option is not selected in the Options menu's 
Calculation dialog box.    Circular references can be resolved only when Iteration is selected.

If you want to use iteration to resolve a circular reference, choose Calculation from 
the Options menu and select Iteration.

If you did not intend to create a circular reference, locate the cells involved and 
correct the formulas.
To locate circular references

1 Look at the status bar at the bottom of the Microsoft Excel window. There will be a 
reference to one of the cells in the circular reference after the word "Circular."

2 Select the referenced cell.
3 From the Formula menu, choose Select Special.
4 Select Precedents or Dependents, and All Levels.    This selects all cells involved in the 

circular reference.    If just one cell is selected, that cell contains a formula that refers to
itself.

5 Edit the formulas to resolve the circular reference.
See Also

Help
Select Special Command (Formula Menu)



Series order must be an integer between 0 and 255.
In the series formula, the series order is the order in which the series will be plotted in the 
chart.    Series order 1 indicates the series that will be plotted first, series order 2, the series 
that will be plotted second, and so on.
You must either specify an integer for the series order or leave it blank. If you leave the 
series order blank, Microsoft Excel plots the series last and enters the series order for you.



Series must contain at least one value.
A series formula requires at least one value to display on the chart.
Enter at least one value for the series formula and try the operation again.    If you are 
creating a template, either specify a dummy value in the series formula or do not enter a 
series formula at all.



Formula must refer to a single cell or result in a text string.
In the series formula, the argument used to generate the title of the series must result in 
text.    You must use one of the following:

Text enclosed in quotation marks.
A reference to a cell containing text.
A reference to a name that results in text.

A formula that results in an array cannot be converted to text even if each component of 
the array contains text.
You cannot enter an array constant.    If you use a name in the argument that refers to an 
array or multiple cells, this message will appear whenever the chart is updated.



External Reference is not valid.
An external reference to a worksheet in a chart formula can be invalid for several reasons:
Entering a formula on a chart

The worksheet containing the cells you're referring to is not open.    Open the 
worksheet and then enter the reference.
Updating a chart

A text label formula, or a formula for a series title, refers to a name on a worksheet 
that doesn't result in text.    Check the name and make sure the name is defined as text or 
that it refers to a cell or formula that returns text.

An external reference in the SERIES formula for the chart's categories or values refers
to a name on the worksheet and that name defines something other than a rectangular 
reference or array.    Check the name and make sure it refers to a rectangular range of cells 
or to an array.



Cannot do that command on nonadjacent selections.
The current task cannot be performed when there are nonadjacent selections.    
To complete your task, select only one area at a time and repeat the action.



Cannot access [document].
You are trying to save, open, or link to a document that currently cannot be accessed.    
Some possible reasons for this include:

The document name or path you specified in a dialog box does not exist.
Check the spelling of the name or path, and try to access the document again.

The document you are trying to open is being used by another application.
When the document is no longer being used, try to open it again.

The name of the document you are trying to save is the same as the name of another
document that is read-only or that is being used by another application.

Save your document with a different name.    If you want your document to have the 
same name, save the read-only document as a normal read/write document, or wait 
until the in-use document is no longer being used.

You are trying to save a document to a read-only network directory or disk or a 
network drive that has run out of disk space.

Save the document to a different network directory or disk.
You are trying to reopen the last-saved version of an open document, but the saved 

version has been deleted.
Save the open document with another name, and then open the backup version of the 
deleted document if one exists.

The buttons that appear in the message box vary depending on the cause of the error.    To 
continue:
OK

Closes the message box.
Retry

Tries to access the document again.
Cancel

Cancels the command.



Cannot open or save any more documents.
There is not enough memory to open or save any more documents.
To open more documents or save a currently open document with read and write access:

Close documents you no longer need.
Close and then reopen some of your documents as read-only.    Read-only documents 

require less memory than documents with read and write access.



Disk is full.
The disk to which you are saving your document is full, or you are trying to save your 
document on a write-protected floppy disk. 
Either delete some files from the disk and try again, or save your document on another disk.
If you are trying to save your document on a floppy disk, make sure the disk is not write-
protected.
If you have saved the document on the disk before, don't assume the previous copy of your 
document is still on the disk.    Microsoft Excel may have erased it to make room for the new 
version of the document.



Unable to read file.
Microsoft Excel cannot read the file due to an unrecoverable error.    The file is probably 
corrupted.
Try using the backup copy of the file.



Filename is not valid.
Microsoft Excel tried to save a file and failed. The filename is not valid, the specified 
directory does not exist, or the directory is read-only.
If you are trying to save a global macro sheet, Microsoft Excel could not find the XLSTART 
directory.
A valid filename is

Made up of two parts separated by a period.    The first part, called a name, can be up
to eight characters long.    The second part, called an extension, can be up to three 
characters long.    For example:    SALES.XLS

A valid filename is made up of the following characters:
a-z A-Z 0-9 period
$ % ' -
@ { } ~
! # & _



Cannot access read-only document.
You are trying save, open, or link to a document that currently cannot be accessed.    Some 
possible reasons for this include:

The document you are trying to open is being used by another application. When the 
document is no longer being used, try to open it again.

The name of the document you are trying to save is the same as the name of another
document that is read-only or that is being used by another application. Save your 
document with a different name.    If you want your document to have the same name, 
change the read-only document's attributes to read/write, or wait until the in-use document 
is no longer being used.

You are trying to save a document to a read-only network directory or disk. Save the 
document to a different network directory or disk.

You are trying to revert to the saved version of an open document, but the saved 
version has been deleted. Save the open document with another name, and then open the 
backup version of the deleted document if one exists.
The buttons that appear in the message box vary depending on the cause of the error.
OK

Closes the message box.
Retry

Tries to access the document again.
Cancel

Cancels the command.



[External Copy or SYLK]: file format is not valid.
External Copy
The file to which you are trying to establish an external reference is not a valid Microsoft 
Excel worksheet.    Three reasons may be:

You did not save the document in Normal format.    Load and save it now; then try 
entering the external reference again.

You misspelled the name of the worksheet to which you are trying to establish a link.  
Correct the spelling; then try entering the external reference again.

You may be attempting to open a Lotus 1-2-3 file which has a damaged or 
invalid .FMT or .FM3 file.
SYLK
The file you are trying to open appears to be in SYLK (Symbolic Link) file format, but the 
format is not correct.
If the file was created with Multiplan or with Microsoft Excel for the Apple Macintosh and you
saved the original file in Normal format, try opening the document with the original 
application and saving it again in SYLK.



Replace existing [document]?
There is already a document on the disk with the specified name.
OK

Saves the active document and replaces the document on the disk.
Cancel

Cancels the command.



Cannot save to an open document.
There is already an open document with the name you specified.    
Choose a different name for your document or close the open document before saving.



Revert to saved [document]?
You have made changes to a document and have tried to open it again.
OK

Opens the document as it was before you made the changes.
Cancel

Cancels the command.



Revert to saved secondary sheets?
You have made changes to one or more of the worksheets in a 3-D Lotus 1-2-3 WK3 file.    
Microsoft Excel converted the 3-D file into separate documents, and you are trying to open 
it again.
OK

Opens the main and secondary sheets as they were before you made the changes.
Cancel

Cancels the command.



Document is not completely saved.
The save process was terminated.    There is probably not enough room on your disk for your
entire document; however, some of the document may have been saved. 
Make some room on your disk and save the document again, or save the document on 
another disk.



Delete file [filename]?
Microsoft Excel is asking if you really want to delete this file from the disk.
Yes

Permanently deletes the file from the disk.
No

The file is not deleted from the disk.



Maximum number of data series per chart is 255.
Microsoft Excel allows you to use up to 255 data series in a chart (the main chart and its 
overlay). If you want to plot more than 255 data series, you have to create two or more 
charts.



Maximum number of data points in a data series is 4000.
Microsoft Excel allows you to use up to 4000 data points per series.    
If you want to plot more than 4000 data points, you have to create two or more series. 



Negative or zero values cannot be plotted correctly on log charts.
Only positive values can be interpreted on a logarithmic scale.    Therefore, only values 
greater than zero can be plotted correctly on a log chart.
Select only positive values for the chart or choose another chart type.



Did not encounter RETURN() or HALT() on macro sheet.
While running a macro, Microsoft Excel reached the end of a column without encountering
the RETURN or HALT function.    
To stop a macro, you need to enter either a RETURN or HALT function.    If it appears that 
you have entered RETURN or HALT correctly, try using the STEP function to step through 
the macro and determine why Microsoft Excel did not encounter the RETURN or HALT 
function.



Reference must be to a macro sheet.
In the Macro menu's Run Macro dialog box, you can run a macro by choosing one listed in 
the Run box or by typing a reference to the first cell of a macro in the Reference box.
If the macro you want to run is on the active macro sheet, the reference you type in the 
Reference box should be either a single cell reference or a name defined on the macro 
sheet that refers to the first cell in a macro.    If the macro you want to run is on another 
macro sheet, you must include the name of the macro sheet as part of the reference.
Examples

A1 Runs the macro starting in cell A1 on the active macro sheet.
Macros!A1 Runs the macro starting in cell A1 on the Macros macro sheet.
Macros!Sort Runs the macro starting in the cell with the name Sort on the Macros 

macro sheet.
Note that the Run command cannot be used to run a Lotus 1-2-3 macro. Instead, use the 
CTRL+[letter] key combination.



Error printing on [printer].
Microsoft Excel is unable to print. There are several possible reasons for this:

Not enough memory.    Try closing other documents and applications (such as Help), 
and then try printing again.

If you use a network for printing, the network connection may have been cancelled or
your computer or printer may not be connected to the network.

There may be loose cables or bad connections between your computer and printer.
There may be a problem with the printer driver.    Try installing it again.



No point number is specified.
For all chart types except area charts, you must specify both series number and data point 
number to attach text (the value of the data point) to a data point marker.    In area charts, 
you only need to specify the series number; the text you type is then attached to the center
of the series area.
If you do not know the series and data point numbers, select the point before you choose 
the Attach Text command from the Chart menu.    Microsoft Excel will provide the number of 
the series and data point you have selected.



No series number is specified.
For all chart types except area charts, you must specify both series number and data point 
number to attach text (the value of the data point) to a data point marker.    In area charts, 
you only need to specify the series number; the text you type is then attached to the center
of the series area.
If you do not know the series and point numbers, select the point before you choose the 
Attach Text command from the Chart menu.    Microsoft Excel will provide the numbers of 
the series and data point you have selected.
If you are reformatting an overlay chart, you must specify which series is first in the overlay 
chart.    You can delete the overlay chart by choosing Delete Overlay from the Chart menu.



Tick mark intervals must be greater than 0.
In the Format menu's Scale dialog box, Major Unit and Minor Unit refer to subdivisions of the
axis.    The length of a subdivision must be a positive number.
Either select the Auto check boxes for the Major Unit and Minor Unit options, or specify a 
number greater than zero for both.



That gallery option does not exist.
One of the Gallery macro functions calls for a chart type that is not available from that 
Gallery command.
Change the number to correspond to an existing type of chart.



Cannot print chart in draft quality.
Draft quality does not work for graphics.    You must print charts in standard graphics mode 
or better.
To print the chart

1 From the File menu, choose Print.
2 Clear the Draft Quality check box.
3 Choose the OK button.

See Also
Help
Print Command (File Menu)
To print a chart



Cannot add any more custom formats.
You can only have a total of 256 built-in and custom formats.    
Before creating another format, you must delete one of the custom formats. 
To delete a custom format

1 From the Format menu, choose Number.
2 Select the custom format to delete.
3 Choose the Delete button.
4 Choose the OK button.

See Also
Help
Number Command (Format Menu)



[Document] is Read-Only.
You are either trying to open a read-only document or trying to save changes to a read-only 
document using the current filename. To save changes to this document, choose the Save 
As command from the File menu and specify a new filename.



[Document] is currently in use.    Open as Read-Only?
The document you want to open is being used by another application. You can open the 
document, but you cannot change it.
OK

Opens the document as read-only.
Cancel

Does not open the document.
If you need to open and change the document, wait until it is no longer being used and try 
to open it again, or open it now as read-only and save it with a new name.



Sort key is not valid.
The sort key you specified cannot be used.    The sort key specifies the row or column by 
which Microsoft Excel sorts.
If sorting by rows, you must specify which column Microsoft Excel should look at when 
determining how to sort the rows.    A sort key must refer to a cell in one of the selected 
columns.    The cell referred to doesn't need to be within the selected area.    For example, 
suppose you are sorting $A$1:$D$10 by rows.    The sort key can refer to any cell in columns
A, B, C, or D.
If sorting by columns, you must specify which row Microsoft Excel should look at.    For 
example, suppose you are sorting $A$1:$D$10 by columns.    The sort key can refer to any 
cell in rows 1 through 10.



Cannot change part of an array.
Microsoft Excel treats an array as a single unit; therefore, you cannot change part of an 
array and you cannot sort it using the Sort command on the Data menu.    
To continue

1 Choose the OK button.
2 If necessary, press ESC to cancel the current action.

To change the individual values in an array, you must replace the array with its values.
To replace an array with its values

1 Select the entire array by pressing CTRL+/ (slash).
2 From the Edit menu, choose Copy.
3 From the Edit menu, choose Paste Special.
4 In the Paste box, select the Values option.

The array no longer exists; only its values remain.    You can change these values if you 
want.
See Also

Help
Copy Command (Edit Menu)
Paste Special Command (Edit Menu)



Cannot change part of a table.
Microsoft Excel treats a data table as a single unit; therefore, you cannot change part of a 
table and you cannot sort it using the Sort command on the Data menu.
To continue

1 Choose the OK button.
2 If necessary, press ESC to cancel the current action.

To change the individual values in a table, you must replace the table with its values. 
To replace a table with its values

1 Select the entire table by pressing CTRL+/ (slash).
2 From the Edit menu, choose Copy.
3 From the Edit menu, choose Paste Special.
4 In the Paste box, select the Values option.

The table no longer exists; only its values remain.    You can change these values if you 
want.
See Also

Help
Copy Command (Edit Menu)
Paste Special Command (Edit Menu)



Cannot delete built-in format.
You cannot delete the selected format because it is a built-in format; you can delete only 
custom formats.
See Also

Help
Number Command (Format Menu)



Cannot save to that name.    Another document is linked to a 
document with that name.
An open document has links to both the file you are trying to rename and a file that has the 
name you typed.
Type a unique name for the file you want to rename.    Or, open the file with the name you 
want to use and resave it with a different name.    You can then rename the first file as you 
intended.



Value must be a number.
When you chose the Scale command on the Format menu, you cleared one or more Auto 
check boxes in the dialog box, but forgot to specify a number in the edit box associated with
it.
Either enter a number or select the Auto check box you want.



Minor unit must be less than major unit.
Major and minor units are subdivisions of the axis.    Major units specify major subdivisions; 
minor units specify more refined or minor subdivisions of the axis.    In the Format menu's 
Scale dialog box, the number you specify for the minor unit increment must be less than the
number you specify for the major unit increment.
If you don't know what values to specify, select the Auto check box next to Major Unit and 
Minor Unit in the Scale dialog box. Microsoft Excel will determine a correct set of values.    
Specify major unit and minor unit increments only if you want to customize your chart.



Maximum axis value must be greater than minimum axis value.
The minimum value is the smallest number on the axis and the maximum value is the 
largest number on the axis.    Numbers labeled on the axis are scaled between the minimum
and the maximum.    In the Format menu's Scale dialog box, the number you specify for the 
minimum value must be less than the number you specify for the maximum value.
If you don't know what values to specify, select the Auto check box next to Minimum and 
Maximum in the Scale dialog box. Microsoft Excel will determine a correct set of values.    
Specify numbers only if you want to customize your chart.    Make sure that the maximum 
axis value you have specified is greater than the minimum axis value. Use the Values in 
Reverse Order check box to plot data from the largest to the smallest number.



Unit of log scale must be at least 10.
A log scale axis is based on powers of 10.
When specifying major and minor unit increments, you must specify a value of at least 10, 
and the value must be a multiple of 10.



[Name] is not a valid name.
One of the names in the selected range is not valid.
OK

Skips the invalid name and continues to create all remaining valid names.
Cancel

Cancels the Create Names command so it creates no more names.
To create a valid name to replace the invalid name

1 Choose the Cancel button.
2 Correct the invalid name.
3 Select the range again.
4 From the Formula menu, choose Create Names again.



Replace existing definition of [name]?
Using the Create Names command on the Formula menu, you tried to create a name that 
already exists on this worksheet.    Microsoft Excel needs to know if you want the existing 
definition of the name to be replaced with the new definition you're giving it.
Yes

Replaces the existing definition of the name with the new definition.
No

Leaves the existing definition of the name as it is and continues creating names.
Cancel

Cancels the command.    No additional names are created.    Names created up to the 
point of canceling remain in effect.



Number is not valid.
Depending on the command you've chosen, you must enter either an integer or a decimal 
number in the box.    
If it appears you have entered a valid number, try deleting the number completely and then
reentering it.



Integer is not valid.
You typed a noninteger value in a dialog box that accepts only integers.
Type an integer in the dialog box.



That name already exists.
In the last dialog box, you typed a new name for the formula to use.    However, the name 
you typed exists on this worksheet.
Choose OK, and then type another name for the formula to use.



No match.
Microsoft Excel could not find what you are searching for.
If you used the Find or Replace command on the Formula menu, no cell in the selection 
contains what you typed.
If you used the Form, Find, or Delete command on the Data menu, no more records match 
the criteria.    This means that all records matching the criteria have been found, or that 
there are no other records that match the criteria.
If you think there should be a match, check your typing and then try the search operation 
again.



Shortcut key must be a letter.
A number, punctuation mark, or other symbol, instead of a letter, was typed as a shortcut 
key.
Type any letter of the alphabet as the shortcut key.



Column width must be between 0 and 255.
Microsoft Excel sets column width based on the width of unformatted numeric characters.    
A column with a width of zero is hidden; negative values are not valid.    The maximum 
column width is 255 unformatted numeric characters.    The number of characters actually 
displayed in a cell may vary depending on the font and format.
In the Format menu's Column Width dialog box, change the column width to a value 
between 0 and 255.



Row height must be between 0 and 409.
Row height is measured in points. A row with a height of 0 points is hidden. Type a number 
between 0 and 409.    



[Range] is not defined.
Criteria range is not defined.
Before you choose the Find, Extract, or Delete command from the Data menu, you must 
define a criteria range using the Set Criteria command.
To define a criteria range

1 Select the criteria range.
2 From the Data menu, choose Set Criteria.

Database range is not defined.
Before you choose the Find, Delete, Extract, or Form command from the Data menu, you 
must define a database range using the Set Database command.    Also, when you save a 
document in dBASE II, dBASE III, or dBASE IV format, Microsoft Excel saves only the 
database portion of a document, so you must define a database range for this operation as 
well. 
To define a database range

1 Select the database range.
2 From the Data menu, choose Set Database.

Recorder range is not defined.
Before you can record a macro in the recorder range, an area named Recorder must be 
defined on your macro sheet.    You can designate the recorder range yourself with the Set 
Recorder command on the Macro menu or have Microsoft Excel determine the recorder 
range automatically when you choose the Record command from the Macro menu.    Once 
the recorder range has been defined, do not delete or alter the name Recorder until you 
have recorded the macro.    Otherwise, you will have to choose the Set Recorder or Record 
command to define the recorder range again before you begin recording.



Recording failed.
The recording of your macro failed due to some interference with the recorder area -- the 
area named Recorder on the macro sheet that is defined when you choose the Set Recorder 
command from the Macro menu.    It's also possible that Microsoft Excel ran out of memory 
while recording.
You cannot redefine the recorder area while you are recording a macro.    To continue with 
your work, the macro must be recorded again starting at the point the recording failed.    
To resume recording

1 Select the area on the macro sheet where you want to record.
2 From the Macro menu, choose Set Recorder.
3 From the Macro menu, choose Start Recorder.
4 Resume recording.



Recorder range is full.
There are no more cells available in the selected area of the macro sheet for recording 
actions.    
If you do not want to limit the area in which you can record actions, select a single cell 
before you choose the Record or Set Recorder command from the Macro menu.



Cannot open the Clipboard.
You are trying to do a procedure that requires the Clipboard, but Microsoft Excel is unable to
open the Clipboard. Some possible reasons for this:

Another application may be using the Clipboard for copying or pasting.    Wait for the 
operation to finish and try again.

There may not be enough memory to use the Clipboard.    After closing other 
documents and applications (such as Help), try again.



Cannot empty the Clipboard.
You are doing a procedure that requires using the Clipboard, but the Clipboard is full and 
Microsoft Excel is unable to empty it. There are several possible reasons for this:

Another application is using the Clipboard while Microsoft Excel is trying to cut or 
copy data onto the Clipboard.    Try performing the current operation again.

Another application used the Clipboard but did not close it properly, preventing other 
applications from using it.    Quit Microsoft Excel, restart Microsoft Excel, and then try again.

There is not enough memory to use the Clipboard.    After closing other documents 
and applications (such as Help), try again.



Too complex to record.
The action you are attempting to record is too complex or long.
Reduce the complex or long formulas, names, or text to two or more simpler or shorter 
formulas, names, or text, and then try recording again.



Cannot shift nonblank cells off sheet.
To prevent possible loss of data, Microsoft Excel will not allow you to use the Insert 
command on the Edit menu to shift cells containing data or borders beyond the edges of the
worksheet.
Delete or clear the cells, or move the data to a new location and try again.



Cannot shift objects off sheet.
To prevent possible loss of data, Microsoft Excel will not allow you to use the Insert 
command on the Edit menu to shift objects beyond the edges of the worksheet.
To shift an object on your worksheet, move the object to a new location, and try again.



Fixed objects will move.
You changed the dimensions of your worksheet.    Microsoft Excel moves the fixed objects 
you placed near the boundaries of your worksheet so that the objects remain visible.



Cannot link to a chart.
You chose the Links command from the File menu and attempted to create or change links 
to a chart.    Microsoft Excel cannot establish or change a link from a chart to another 
document.    You can create links from either a worksheet or a macro sheet.
If you want to create a link to the information in a chart, you must open the worksheet 
containing the chart's source data.



Change DDE/OLE link failed.
You are changing a dynamic data exchange (DDE) link, or an object linking and embedding 
(OLE) link, and you typed a name that does not match the required syntax or a name that 
conflicts with one already being used in another context.
The correct DDE/OLE syntax is:    application|topic!item
Check the syntax of the name you typed, and correct it if necessary.    If the syntax is 
correct, type a unique name.



Number must be greater than or equal to zero.
If the Iteration check box in the Calculation dialog box is selected, calculation stops when all
cells change by less than the number specified in the Maximum Change box.    This number 
is used to limit the number of iterations and can't be less than zero. Change the number to 
be greater than or equal to zero.
See Also

Help
Calculation Command (Options Menu)



Cannot paste data.
This error is usually caused by conditions beyond the control of Microsoft Excel.    The 
Clipboard may not contain information suitable for pasting into a Microsoft Excel document, 
or another application may be using the Clipboard.



Cannot insert object.
You attempted to insert an object and either memory was insufficient to complete the 
operation, or the object specified by a macro containing an INSERT.OBJECT macro function 
was not a supported object type. Close any unneeded open documents and applications, or 
check the argument in the INSERT.OBJECT macro function and try again.
See Also

Help
Insert Object Command (Edit Menu)
Microsoft Excel Function Reference



Cannot open printer driver.
The printer driver that is needed to print your document cannot be opened. Some possible 
reasons for this:

Not enough memory.    After closing other documents and applications (such as Help),
try again.

There may be some problem with the printer driver.    Try installing it again with the 
Control Panel.



File error: data may have been lost.
An error occurred while opening a Microsoft Excel binary file.    Some of the data in the file 
may not be in memory.    The problem may have been caused by another application 
creating a Microsoft Excel binary file incorrectly.
Resave the file and try opening it again.



A document with the name [name] is already open.
You cannot open two documents with the same name.    Even if you have documents with 
the same name in different directories, they must have different names if you want to open 
both of them at once. 
To open the second document, either close the document that is now open or rename one of
the documents.



Update references to unopened documents?
The document you are opening has references to cells on a worksheet or macro sheet not 
currently open.
Yes

Checks the unopened documents and updates simple references to them.    This will 
update the document you are opening with the latest values from the unopened 
documents.

No
Does not check unopened documents for changes in data.

In either case, the error value #REF! appears in all cells containing complex external 
references to unopened documents.    To recalculate these formulas, you must open the 
referenced documents.



[Copy or cut] and paste areas are different shapes.
The paste area you selected is either too large, too small, or the wrong shape.    If you chose
Copy before choosing Paste or Insert Paste from the Edit menu, the paste area must be one 
of the following:

A single cell.
A rectangle the exact size and shape of the copied area.
A rectangle able to contain two or more rectangles the exact shape of the copied 

area.
If you chose Cut from the Edit menu before Paste, the paste area must be one of the 
following:

A single cell.
A rectangle the exact size and shape of the cut area.

Check the paste area and try again.



Cannot paste a table onto a macro sheet.
The area you cut includes a table created with the Table command on the Data menu.    
Microsoft Excel does not allow this type of table on a macro sheet.
To copy data from the table to a macro sheet, use the Copy command on the Edit menu.



Some custom formats will not fit on the destination sheet.
When you're cutting and pasting between worksheets or extracting database records to a 
different worksheet, all custom number formats used in the database are copied to the 
destination sheet.    The total number of formats on the destination sheet plus the number of
custom formats needed for extracted records cannot be more than 64.    Extracted records 
using the custom formats that will not fit revert to General format.
To regain formatting, you must use the Number command on the Format menu to delete 
some custom formats from the destination sheet.    This makes room for the new formats.    
Then, do one of the following:

Add the custom formats you want to use and reformat the transferred data.
From the Data menu, choose the Extract command again.



Cannot find [document].
Microsoft Excel cannot find the document you are trying to open.    Either the document 
does not exist, you specified the wrong directory or disk, or you made a spelling error.    
Choose OK, and then choose the Open command again.    In the Open dialog box, find the 
correct name and location of the file you want to open, and try again.    If you are using a 
macro to open a document, you will probably need to include the path name as part of the 
document name.



Cannot access [document].
You are trying save, open, or link to a document that currently cannot be accessed.    Some 
possible reasons for this include:

The document name or path you specified in a dialog box does not exist. Check the 
spelling of the name or path, and try to access the document again.

The document you are trying to open is being used by another application. When the 
document is no longer being used, try to open it again.

The name of the document you are trying to save is the same as the name of another
document that is read-only or that is being used by another application. Save your 
document with a different name.    If you want your document to have the same name, 
change the read-only document's attributes to read/write, or wait until the other document 
is no longer being used.

You are trying to save a document to a read-only network directory or disk or a 
network drive that has run out of disk space. Save the document to a different network 
directory or disk.

You are trying to revert to the saved version of an open document, but the saved 
version has been deleted. Save the open document with another name, and then open the 
backup version of the deleted document if one exists.
The buttons that appear in the message box vary depending on the cause of the error.    
OK

Closes the message box.
Retry

Tries to access the document again.
Cancel

Cancels the command.



Not enough system resources to display completely.
The percentage of system resources available is not sufficient for Microsoft Excel to update 
what is displayed on the screen.    Any command you've just chosen was completed 
successfully, but the screen does not completely reflect the update.    
To check system resources, switch to the Microsoft Windows Program Manager and choose 
the About Program Manager command from the Help menu.    The percentage of free system
resources is displayed in the dialog box.
To free more system resources, try closing other applications or worksheet windows.    Then, 
to have the data on the screen updated, move the window off the screen and back again, 
minimize and restore the window, or close and reopen the window.



Matching records will be permanently deleted.
You are about to permanently delete all records that match the criteria from the database.
The only way to retrieve deleted records is to reopen the original document.    When you 
reopen the document, you discard any changes you have made since the last time you 
saved it.



Incorrect password.
You attempted to turn off document protection or open a protected document without the 
correct password.    The document was protected and the password assigned using either 
the Protect Document command on the Options menu or Save As command on the File 
menu. You cannot turn off document protection or open a protected document without 
typing the correct password.
Check the password you typed and try again.



Cannot open a dependent document that contains references to 
different sheets with the same name.
Formulas in the dependent document contain external references to sheets with the same 
name in different directories.    Some of the formulas were entered without a pathname, and
some were entered with a full pathname.
Example

Formula A: =SHEET1.XLS!A1
(no pathname)
Formula B: =C:\BUDGET\SHEET1.XLS!A1
(full pathname)

Microsoft Excel assumes that Formulas A and B were entered this way to differentiate 
between two sheets named SHEET1.XLS located in different directories.    It looks for 
SHEET1.XLS in Formula A in the same directory as the dependent document and uses the 
specified pathname to look in the BUDGET directory on Drive C to find the SHEET1.XLS in 
Formula B.
You are now trying to open the dependent document from the directory you specified in 
Formula B, but Microsoft Excel cannot distinguish between the two documents named 
SHEET1.XLS.
To open the document, switch to the directory in which it was created or include the entire 
pathname in the formula.



Use existing definition of [name]?
The formula you are pasting contains a name that already exists on the destination 
worksheet.    Microsoft Excel needs to know whether to use the existing definition of the 
name, or redefine the name to refer to the same area on the destination worksheet as it 
does on the original.
Yes 

The name in the formula you are pasting will refer to the existing definition of the name 
on the destination sheet.

No
The name in the formula you are pasting will refer to the same area on the destination 
sheet it does on the original sheet.    You will be asked to type a new name for these cells. 
The name you type will be defined on the destination worksheet and the name in the 
formula will change to the new name.

Cancel
Cancels the Paste command.



Name cannot resemble a reference.
While changing from R1C1 to A1 reference style, Microsoft Excel encountered a name that 
looks like a reference.    Although names can resemble references when you're using the 
R1C1 reference style, they cannot do so when you're using the A1 reference style. 
You must either cancel this command or type a valid name in place of the invalid one.
OK

Accepts the new name you type, if it's valid.    All formulas using the old name are 
changed to include the new name.

Cancel
Cancels the command.



Name cannot be the same as built-in name.
You are opening a spreadsheet saved by a Microsoft Excel version that was produced for 
another country, and a defined name on the spreadsheet matches a name that is reserved 
as a special name for your version of Microsoft Excel.
Type a different defined name.



Name already exists on destination sheet.
The formula you are pasting contains a name that already exists on the destination 
worksheet.    You chose No in the preceding message box to indicate that the name in the 
formula should not refer to the destination worksheet's existing definition of the name.    
You now need to specify a new name for the formula to use.    The name you type will be 
defined on the destination worksheet and the name in the formula will change to the new 
name.    Choose OK and then type the name you want to use.



Data on the Clipboard is not the same size and shape as the 
selected area. Paste anyway?
The size and shape of the area selected do not match the size and shape of the data on the 
Clipboard.
OK

Pastes the data from the Clipboard, starting at the upper-left corner of the selected area 
until it fills the selected area.

Cancel
Cancels the command, leaving the data on the Clipboard.

If you choose Cancel, you can reselect the area and try again.



No link to paste.
The information necessary to create a link is not available.
If you are trying to create a link between two Microsoft Excel worksheets:
The worksheet you copied from is no longer open. Reopen the worksheet and repeat the 
copy and paste sequence.
If you are trying to create a link between a Microsoft Excel worksheet and a 
document created with another application:
The document is no longer open, the application is no longer running, or the application 
does not support links with other applications.
Make certain that the other application is running, the document is open, and the 
application supports links to other applications.    Then repeat the copy and paste sequence.



Unable to paste link.
This error is generally caused by conditions beyond the control of Microsoft Excel.    Microsoft
Excel was not able to create the link because the Clipboard does not contain information 
suitable for pasting into a Microsoft Excel document.    
Try the complete operation again.



No match in current cell.
The text you are looking for with the Formula menu's Replace command is not in the current
cell.
If you think the text should be there, check the spelling and try again.



Cell with looping function should not contain anything else.
The FOR, FOR.CELL, WHILE, and NEXT functions are used to control loops in a macro.    
Because these functions control how other macro functions are carried out, you cannot 
enter anything else in a cell containing one of these functions.
Examples

=FOR("I",1,10) is legal.
=NEXT()5 is not legal.

Remove the extraneous information from the cell and enter the function again.



Save changes in [document]?
You have made changes to a document since the last time you saved it and you chose the 
Close or Exit command from the File menu, or the Close command from the Windows 
Control menu.
Yes

Saves the changes you've made in the document before closing it or quitting.
No

Does not save the changes you've made since the last time you saved the document.
Cancel

Cancels the command.



Reference must be to a single cell.
The reference in the Cell box of the Note dialog box refers to more than one cell.
From the Formula menu, choose the Note command and type a reference to a single cell in 
the Cell box.



Select cells in one column only.
The range you want to parse can have any number of rows; however, it can only be one 
column wide. Select cells in one column.
See Also

Help
Parse Command (Data Menu)



Error in parse line.
The parse line contains an error.    A right bracket ( ] ) may be missing following a left 
bracket.
Check to see that every left bracket has a matching right bracket.    Also check that there 
are no nested brackets.
See Also

Help
Parse Command (Data Menu)



Cannot find data source.
You entered a reference to a document created with another application, but you did not 
include either the application name or the document name.    No document matching the 
description you provided is available.
If your reference specifies:

The application but not the document, make sure the application is running, has open
documents, and supports DDE (Dynamic Data Exchange).

The document but not the application, make sure at least one application is running 
with the specified document open, and supports DDE (Dynamic Data Exchange).

Neither the document nor the application, make sure at least one application is 
running, has open documents, and supports DDE (Dynamic Data Exchange).

If you cannot remedy the problem by opening the document with the application that
created it, remove the reference from your formula.
You can enter a reference to a document created with another application even if the 
document or the application is not available.    To do this, you must specify both the 
application and the document name, for example, =WinWord|'C:\SALES\NEWSALES.DOC'!
DDE_LINK.



Reference is not valid.
The reference you specified is not a valid reference or is not valid for the particular 
command you chose; or, you did not enter a reference where one was required.
Microsoft Excel could not recognize what you typed as a reference.    To enter references 
with the keyboard, first make sure that the status bar displays "Enter," click the cell, or drag
through the cell range you want to select. Using the arrow keys, first select a cell, and then 
press SHIFT+ARROW to extend the selection.
These techniques work when referring to cells on the same worksheet and when referring to
cells on different worksheets. A reference to another Microsoft Excel worksheet is an 
external reference; to create external references, both worksheets must be open.



Data will permanently lose accuracy.
When you use the Number command on the Format menu to select a number format, data 
is normally stored as entered and displayed according to the selected format. 
When you choose the Calculation command from the Options menu, and select the 
Precision as Displayed check box, all stored values are replaced.
For example, if you format a cell containing the number 1.11601 to be displayed with two 
decimal places, it appears as 1.12 on your worksheet.    If you select the Precision as 
Displayed check box, the stored value changes to 1.12; the displayed number remains the 
same.
OK

Stores values with the precision as displayed.
Cancel

Cancels the action.



Document is already protected.
The active document is already protected.    You cannot protect a document a second time 
without first removing the original protection. 
If you are using a macro to change how a document is protected, you must first unprotect 
the document using the Unprotect Document command on the Options menu, and then 
protect it again. 



Data_Form is not correct.
The name Data_Form is defined on the worksheet, but does not refer to a properly defined 
custom data form. A custom data form description follows the same description rules as a 
custom dialog box description.
Some common custom data form issues include:

Numbers in cells for item numbers, field coordinates, height, or width are invalid.
The custom data form description has more than 32 fields.
The data form area is less than seven columns wide.
The cell range containing the custom dialog box description in the Refers To box is 

incorrect.
Check the areas mentioned above and try the operation again.



Cannot justify cells containing numbers or formulas.
Only empty cells or cells containing text can be justified. 
Change the selection to include only empty cells or cells containing text, and then try again.



Text will extend below range.
There is more text to justify than will fit in the area you selected.    
OK

Justifies text into cells below the area you selected, overwriting existing data, if 
necessary.

Cancel
Cancels the action.



Error in dialog box at [cell].    [Message]
The custom dialog box you created contains an error at the cell indicated. 
Some common custom dialog box issues include:

Invalid numbers in any of the cells for item numbers, field coordinates, height, or 
width.

More than 64 rows used in the description.
Too much text.
More than 32 items that accept and return values.
Dialog box area less than seven columns wide.
Cell reference containing the custom dialog box description in the Refers To box is 

incorrect.
See Also

Help
Linked or combination list box requires a preceding edit item.
Option buttons must belong to an option button group.
Option button group without option buttons.



Existing categories will be permanently deleted.
You are using the Paste Special command to paste a new data series onto a chart, and you 
chose to replace the existing categories.
OK

Permanently replaces existing categories with the new categories.
Cancel

Adds the new series to the chart and retains the existing categories for the chart's 
original series.



Displayed record will be deleted permanently.
The single record displayed in the data form will be removed from the database 
permanently.    Once the record is removed, the only way to retrieve it is to reopen the last 
saved version of the document without saving the changes in the current document, or save
the current document under another name. 
OK

Deletes the record.
Cancel

Cancels the action.



Cannot extend database.
Either extending the database would overwrite cells containing information, or there are no 
more rows available at the bottom of the worksheet.
Close the data form and insert rows or move information to make room at the bottom of the
database.



Chart is protected and cannot be changed.
You cannot change a protected chart.
To change the chart, choose the Unprotect Document command from the Chart menu when 
the chart window is active, and then clear the Chart check box.



No cells found.
While carrying out the Select Special command, Microsoft Excel found no cells of the type 
you were looking for.    
Try selecting a larger or different area of the worksheet and then, from the Formula menu, 
choose the Select Special command again.



Cannot open normal Multiplan document.
This is a normal Multiplan document.    
To open it in Microsoft Excel:

1 Open the file in Multiplan.
2 Choose the Transfer Options command.
3 Choose Symbolic.
4 Save the file.
5 In Microsoft Excel, open the file using the Open command on the File menu.



Total number of file errors: [number]
When opening or saving a WKS, WK1, WK3, or SYLK file, or while saving a document in a file
format for a previous version of Microsoft Excel, Microsoft Excel could not translate some of 
the cells.    This message indicates the total number of errors found.



Cannot read record [reference].    Continue reporting each error?
While opening a WKS, WK1, WK3, or SYLK document, Microsoft Excel found an error in the 
cell or name indicated.    Microsoft Excel is asking if you want additional errors to be 
reported as they occur, or if you want the total number displayed once the file is completely
opened.

An error occurs while loading a WKS, WK1, or WK3 file if Microsoft Excel interprets 
two names as the same name.    For example, Microsoft Excel interprets TOTAL$ and TOTAL#
as the same name ( TOTAL_ ).    In this instance, change one of the names and try the 
procedure again.
Yes

Reports each error as it occurs.
No

Does not report each error as it occurs.
Cancel

Cancels the Open command.
Whether you choose Yes or No, the total number of errors will be displayed once the file is 
completely opened.    It's usually best to have each reported as it occurs so you can 
determine where problems are.



Cannot write record [reference].    Continue reporting each error?
While saving a WKS, WK1, WK3, or SYLK document, or while saving a document in a file 
format for a previous version of Microsoft Excel, Microsoft Excel found an error in the cell or 
name indicated.    Microsoft Excel is asking if you want additional errors to be reported as 
they occur, or if you want the total number displayed once the file is saved.
Yes

Reports each error as it occurs.
No

Does not report each error as it occurs.
Cancel

Cancels the Save command.
Whether you choose Yes or No, the total number of errors will be displayed once the file is 
completely saved.    It's usually best to have each reported as it occurs so you can 
determine where problems are.



Cannot convert 3-D reference: [reference].
Microsoft Excel cannot convert some Lotus 1-2-3    3-D references. In a multiple worksheet 
file, a Lotus 1-2-3 function might use an argument that does not refer to the same 
worksheet in which the function appears.    (This limitation applies only to a few functions 
with specific worksheet arguments, such as @COORD.)



A high-low-close stock chart must contain three series.
This type of chart is intended to compare a stock's high price, low price, and closing price 
for each day.    The chart must contain exactly three series in this order:

High prices
Low prices
Closing prices

The chart categories should be the days that the various prices occurred.



A volume-high-low-close stock chart must contain four series.
This type of chart is intended to show the daily volumes of stock traded and to compare a 
stock's high price, low price, and closing price for each day.    The chart must contain exactly
four series in this order:

Volume traded
High prices 
Low prices
Closing prices

The first series is plotted on the main chart; the remaining series are plotted on the overlay 
chart. The chart categories should be the days the various prices occurred.



An open-high-low-close stock chart must contain four series.
This type of chart is intended to compare a stock's opening price, high price, low price, and 
closing price for each day.    The chart must contain exactly four series in this order:

Opening prices
High prices 
Low prices
Closing prices

The first series is plotted on the main chart; the remaining series are plotted on the overlay 
chart. The chart categories should be the days the various prices occurred.



A volume-open-high-low-close stock chart must contain five series.
This type of chart is intended to show the daily volumes of stock traded and to compare a 
stock's opening price, high price, low price, and closing price for each day.    The chart must 
contain exactly five series in this order:

Volume traded
Opening prices
High prices 
Low prices
Closing prices

The first series is plotted on the main chart; the remaining series are plotted on the overlay 
chart. The chart categories should be the days the various prices occurred.



References in series formulas must be external references to 
worksheets.
The references you entered for your chart in either the Edit Series dialog box or the series 
formula are not external references to the worksheet containing the data for your chart.
External references take the following form:

worksheet name!cell or range reference. Example: Sheet1!A1:B2
Change the references to external references either using the Edit Series command on the 
Chart menu, or editing the series formula in the formula bar.    You can type the changes to 
the references or select the cells on the underlying worksheet, and Microsoft Excel will enter
them as external references automatically.



Redefine [stylename] based on selected cells?
The style you just selected is already applied to the selected cell.    Since then, additional 
formatting has been added to the cell using the toolbar or the Format menu commands.
Yes

Redefines the current style name to include the new formatting.
No

Reapplies the original style name and removes any new formatting.
Cancel

Cancels the command.    The cell retains all existing formatting.



Macro with name [name] already exists.    Overwrite?
You attempted to name a macro using a name that already is defined on the current macro 
sheet. 
Yes

The name will be assigned to the new macro, replacing the definition of the existing 
macro name. 

No
You must provide a unique name for the macro.

Cancel
Cancels the command.



Cannot create Global Macro Sheet.
You have tried to create a global macro sheet but either there is not enough memory 
available, or there is already a nonmacro sheet open that has been named GLOBAL.XLM. 
If not enough memory was available to create the global macro sheet, close windows, save 
unsaved documents, or quit other open applications as necessary to make more memory 
available. 
If a nonmacro sheet with the name GLOBAL.XLM is open, close it or rename it using the 
Save As command on the File menu.



Save changes to Global Macro Sheet?
You have made changes to the global macro sheet during this Microsoft Excel session. The 
global macro sheet is hidden, and must be saved now to preserve the changes made to it.
Yes

Saves the hidden global macro sheet, and then quits Microsoft Excel.
No

Does not save the hidden global macro sheet, and then quits Microsoft Excel.
Cancel

Cancels the command.



Cannot change this cell while a macro is paused.
You attempted to make a change to a cell that is necessary for running the currently paused
macro. If you need to make changes to the paused macro or one of its subroutines, you 
must first stop the macro and then edit the cell.



Stack overflow. Note conditions and report to your DLL provider.
This message indicates an unrecoverable error condition that exists between a Dynamic 
Link Library (DLL) and Microsoft Excel. Make note of the conditions that led to this error and 
forward this information to the developer of the DLL.



Too many fields in the data form.
You have entered too many fields in your default or custom data form.    Either type of data 
form can display a maximum of 32 fields.    If you are using the default data form, you can 
work around this limitation by using one of these options:

Define a smaller database.
Hide columns in your database so that your data form displays 32 or fewer fields.
Define a custom data form that uses 32 or fewer of the fields in your database.

See Also
Help
Form Command (Data Menu)



Cannot create data form for a database in which all columns are 
hidden.
You are trying to create a data form for a database, but all of the columns in the database 
are hidden (have a width of zero). The widths of the fields in the data form correspond to 
the widths of the columns in the database. If all field widths are zero, nothing will appear in 
the data form.
To create the data form, you must unhide one or more columns in the database.
See Also

Help
Form Command (Data Menu)



Extract range is full.
There is no more room available in the selected area of the worksheet to put extracted 
records.
If you want to extract all records that match the criteria, select only the data field names 
before you choose the Extract command from the Data menu.    Existing data below the field
names will be overwritten by the extracted records, if necessary.



Too many different cell formats.
For any cell, you can apply any combination of number formatting, font, alignment, borders,
patterns, and protection, but Microsoft Excel can store only 4050 unique combinations of 
these attributes.    It's possible that you have applied the maximum number of cell formats, 
and no more can be added.
First, try saving the sheet, closing it, and reopening it to make more memory available, and 
then try to format the selection again.    If the message reappears, you must either format 
the selection with the same combination of attributes as another cell on the worksheet, or 
apply a cell style to it.
See Also

Help
Creating or deleting a style



Note will be permanently deleted.
You are about to permanently delete a note.    Once the note is deleted, there is no way to 
retrieve it.
OK

Permanently deletes the selected note.
Cancel

Cancels the command.



Create Works graphs?
Choose the OK button to tell Microsoft Excel to create accompanying graphs for the 
Microsoft Works worksheet you want to open.



Save large Clipboard from [filename]?
You chose the Close or Exit command on the File menu after performing a large (greater 
than 50 cells) copy operation.    When you're copying a large amount of data, it is placed on 
the Clipboard and uses a significant amount of memory.    Microsoft Excel asks if you want to
save the data on the Clipboard.
Yes

Saves the data on the Clipboard.
No

Does not save the data on the Clipboard.
Cancel

Cancels the Close command.



Save [document] with references to unsaved documents?
The document you are saving contains external references to documents that have never 
been saved.    If you choose the OK button to save the worksheet and then close it before 
saving the source documents, the external references to those documents may not be valid 
because the names of unsaved documents usually change when you save them.
To save source documents

1 Choose the Cancel button.
2 Save the unsaved source documents.
3 Save the dependent document.

Choose the OK button only if you are sure you will save the unsaved source documents 
before closing the dependent document.



Remote data not accessible.    Start application [application]?
You initiated a dynamic data exchange (DDE) link to an application that is not running.    
Yes

Microsoft Excel starts the application to access the data.
No

Microsoft Excel does not start the application. The procedure is canceled, and the data is 
not accessed.



Cannot quit Microsoft Excel.
You tried to quit Microsoft Excel before it was ready to quit.
To return to Microsoft Excel, choose the OK button to close the message box, and then:

If a dialog box is still displayed, close it.
If a macro is still running or a long calculation is in progress, wait until Microsoft Excel

is finished with the task, or press ESC to cancel the task.
If the formula bar is active, press ENTER or ESC to deactivate it.

Try to quit Microsoft Excel again.



Too many external references.
On one worksheet, you have defined external references to more than 255 other 
worksheets.    On any given worksheet, Microsoft Excel lets you define references to a 
maximum of 255 other worksheets.
Remove some of the external references on the worksheet.



Help reference is not valid.
One of the following actions occurred:

Online Help was requested for a custom menu, custom dialog box, or custom 
database form that does not have a custom Help topic.

A macro containing the HELP macro function was run. The Help reference is not in the
form FILE.HLP!N, where FILE.HLP is the name of the custom Help file, and N is an integer 
specifying a topic in the custom Help file. Correct the Help reference so it is in the proper 
form.



Cannot delete [document].
Microsoft Excel cannot find the document you are trying to delete.    The document does not 
exist, you specified the wrong directory or disk, or you made a typing error.
Choose the OK button, and then choose the Open command from the File menu.    Use the 
Open dialog box to find the correct name and location of the file you want to delete, and try 
again. 
If you are using a macro to delete a document, you will probably need to include the path as
part of the document name.



Margins do not fit page size.
The margins you specified don't leave any room for printing on this paper size; for example, 
a left margin of 4 inches and a right margin of 6 inches on paper that is 8.5 inches wide. 
Choose the Page Setup command from the File menu and adjust the margins.



Number must be between [number] and [number].
Numbers outside of the range given in the message are not valid.
Enter a number within the specified range and try again.



[Name] on [document] is not defined or is too complex.
The name you specified is either not defined on the specified document, or it is defined as 
something other than a rectangular cell reference; for example, another name or 
intersection of named ranges, a formula or a constant, or an array.
Check the name and then try again.



Merge styles that have the same names?
When you merge styles from one document to another and two or more styles have the 
same name, Microsoft Excel warns you that the document you are copying to contains 
styles with the same names. 
You receive this message only once, regardless of the number of conflicting style names.
Yes

Changes the existing styles in the active document.
No

Keeps the existing styles in the active document.
Cancel

Cancels the procedure.    No styles are merged.



Database is hidden.
The database you are using is on another worksheet and all of its windows are hidden.    You 
cannot use the Find, Form, and Delete commands on the Data menu in this situation.
Use the Unhide command on the Window menu to make one or more of the hidden windows
visible.    Then choose the Find, Form, or Delete command again.



Cannot enter a formula in a Data Form.
You tried to enter a formula in the data form.    Only numbers or text are allowed.
Change the formula to a number or text.



Cannot save to that name. Document was opened as Read-Only.
The document you are trying to save was named and opened in a read-only format.    In a 
read-only format, you cannot make changes to a document or save it.    To save the 
document now, you must give it a new name. 



Save changes to current series?
You changed a series in the Edit Series dialog box and selected another series without 
choosing the OK or Define button. 
Yes

Saves the changes you made to the selected series and selects the other series.
No

Removes the changes you made to the selected series and selects the other series.
Cancel

Saves the changes you made to the selected series and cancels the new selection.



Name conflict.    Rename the document you want to open.
This document has been given two different external references.
Rename the document and try again.



Dialog box contains too many items.
There are too many items in the custom dialog box. 
A custom dialog box can contain no more than 64 items, 32 of which can be items that 
take or return arguments, and 4 of which can be list boxes. You can add no more than 
1024 characters of text to a custom dialog box.
Remove some items from the custom dialog box and try again.



Cannot open protected file.
You are trying to open a file that is password-protected. Remove the password before 
opening the file in Microsoft Excel.



Font name is too long.
The font name you typed in the Font dialog box is too long.    The maximum number of 
characters you can enter is 32.
Check the length of the font name you typed and try again.



Text extends beyond worksheet.    Some text will be lost.
There is not enough room on the worksheet to justify the text you have selected.    If you 
choose the OK button some text will be lost.    
To prevent the text from being lost, choose the Cancel button and select an area on the 
worksheet that is large enough to accommodate your selection.



Command not available at cell [reference].
The macro you are running has a function that corresponds to a command that is not 
supported in this version of Microsoft Excel.
Edit the cell by replacing the unsupported function with one that is supported.



There is nothing to print in the specified pages.
There is no data on the pages that you have specified to print.    Check to see if you have 
specified an incorrect range of page numbers or selected Notes in the Print dialog box when
there are no notes.



Cannot create backup file.    Save [file] without backup?
Microsoft Excel cannot create a current backup file.    You may have locked or protected the 
previous backup file.    
In order to create a current backup file, the previous backup file must be unlocked or 
unprotected.    Check the file and try again.    
OK

Continues to save without creating a backup.
Cancel

Cancels the action.
See Also

Help
Protect Document and Unprotect Document Commands (Options Menu)



File format is not valid.
External Copy
You are trying to establish an external reference to a file that is not a valid Microsoft Excel 
worksheet.    Three reasons may be:

You did not save the document in Normal format.    Open and save it now; then try to 
enter the external reference again.

You misspelled the name of the worksheet to which you are trying to link.    Correct 
the spelling and then try to enter the external reference again.

You may be attempting to open a Lotus 1-2-3 file which has a damaged or 
invalid .FMT or .FM3 file.
SYLK
The file you are trying to open appears to be in SYLK (Symbolic Link) file format, but the 
format is not correct.
If the file was created with Multiplan or with Microsoft Excel for the Apple Macintosh and you
have the original, Normal format file, try opening the document with the original application
and saving it again in SYLK format.



Cell must contain a value.
To use goal seeking, you must enter in the By Changing Cell box a reference to a cell that 
contains a number.
Make sure that the referenced cell contains a number, and try again.



Reference must be on the active sheet.
You entered a reference to a sheet that is not the active sheet.
If you are using Goal Seek, switch to the sheet on which you want to use goal seeking and 
repeat the procedure.



Cell must contain a formula.
To use goal seeking, you must enter in the Set Cell box a reference to a cell that contains a 
formula.
Make sure the referenced cell contains a formula and try again.



Formula in cell must result in a number.
To use goal seeking, you must enter in the Set Cell box a reference to a cell that contains a 
formula that results in a number.
Check the formula you are using and try again.



Calculation is incomplete. Recalculate before saving?
The document you are trying to save is set to recalculate before saving, but you pressed Esc
before Microsoft Excel finished recalculating. 
Yes

Recalculates the document and then saves it.
No

Saves the document without recalculating it first.
Cancel

Cancels the Save command.
See Also

Help
Calculation Command (Options Menu)



[Document] contains incomplete calculation.
Microsoft Excel is unable to complete the calculation operation for several possible reasons:

The document you are trying to open is linked to one or more documents that were 
not recalculated before they were last saved.

The formula you typed in the formula bar contains a reference to an external 
document that was not recalculated before it was last saved.
OK

Opens the document or enters the formula but does not recalculate the source data.
Cancel

Does not open the document or cancels the formula.
Before continuing, you may want to cancel the current operation, open the documents that 
were not recalculated, and recalculate them.



[Document] contains incomplete calculation.    Continue reporting 
each error?
One of the documents you are consolidating was not recalculated before it was saved.
Before continuing, you may want to cancel the Consolidate command, open the documents 
that were not recalculated, and recalculate them.
Yes

Continues to display this message for each occurrence of a document that was not 
recalculated.

No
Does not display the message if other documents were not recalculated.

Cancel
Cancels the Consolidate command.



Operation failed. [Document] is reserved by [user].
You entered the name of a document that was saved with a write-reservation password. You 
cannot save changes to this document name. 
You can save the document with a different name, or open the document with permission to
save changes by providing the write-reservation password. 
See Also

Help
Save As Command (File Menu)



Operation failed. [Document] is write reserved.
You entered the name of a document that was saved as a write-reserved document in an 
application other than Microsoft Excel. You cannot save changes to this document name. 
Save the document with a different name.
See Also

Help
Save As Command (File Menu)



Confirmation password is not identical.
The text you typed in the Reenter [password type] Password box does not match your 
password.    
Type the password and the confirmation password and try again.



Password contains accented characters or certain punctuation 
marks which will not transfer correctly to Microsoft Excel for the 
Macintosh or Microsoft Excel for OS/2.
The password you typed in the Save As options dialog box or the Protect Document dialog 
box can be interpreted only by Microsoft Excel for Windows.    If you want to export this 
document to Microsoft Excel for the Macintosh or Microsoft Excel for OS/2, your password 
should not contain accented characters or punctuation marks not used in English.
OK

Accepts the password you typed and carries out the command.
Cancel

Returns you to the dialog box so you can type another password.



[Document] is being modified by [user].    Open as Read-Only?
The document you want to open is being used by another user on the network. You can 
open the document, but you cannot change it.
OK

Opens the document as read-only.
Cancel

Does not open the document.
If you need to open and change the document, wait until it is no longer being used and 
open it again, or open it now as read-only and save it with a new name.



[Document] should be opened as Read-Only unless changes to it 
need to be saved. Open as Read-Only?
The document you want to open was saved as read-only recommended. This is useful if the 
document is intended for several users on a network, because only one user at a time can 
open the file and change it; other users must open the file as read-only. If you do not intend 
to change the file, open it as read-only.
Yes

Opens the document as read-only.
No

Opens the document with write access.
Cancel

Does not open the document.



Cell with block IF function should not contain anything else.
The cell containing the block IF function can only contain the IF function.    Any nested or 
combined information in the cell will not be accepted.    
Remove the extraneous information from the cell and enter the function again.



Reference is too complex.
You created nonadjacent selections on a worksheet and did one or both of the following:

You started with a selection on a sheet and then selected Visible Cells in the Select 
Special dialog box, which created nonadjacent selections too complex for Microsoft Excel to 
handle.

You exceeded the maximum number of references allowed for nonadjacent 
selections.    The maximum number of references is 2048.
Choose the OK button and create nonadjacent selections with fewer references.



Cannot use that command on a protected document.
The outlining tools, Bold and Italic tools, text alignment tools, and drawing tools cannot be 
used on a locked or read-only document.
To use these tools, remove the protection from the document by choosing Unprotect 
Document from the Options menu, and then try again.



Reference must be to a single cell on the active sheet.
The reference in the Cell box in the Note dialog box refers to more than one cell or to a cell 
on a different sheet.
Change the reference in the Cell box to refer to a single cell on the active sheet.



Cannot find macro [name].
Microsoft Excel cannot find the macro you assigned to a custom command or object, or the 
macro named in an ON function.    
Make sure the path you specified is correct and that the name of the macro sheet and the 
reference to the macro are correct.    Then try the operation again.



Series definition must include a [Y or Z] reference.
After you entered a name for the series, you chose the OK or Define button before supplying
the external reference for the y axis for 2-D charts or the z axis for 3-D charts. Before 
Microsoft Excel can create the series, you must enter the y or z values you want to plot.
Type the external reference containing the values you want to plot, or select the reference 
on the worksheet, and then choose the OK or Define button again.



Data may be lost saving to an old file format.
The document you saved contains features that are not supported by the old Microsoft Excel
file format that you selected.    
To avoid losing data and formatting, save the document in the Normal file format for 
Microsoft Excel version 4.0.



Cannot find [macro] which has been assigned to run each time 
[document] is opened.    Continuing could lead to erroneous results. 
Cancel Open?
Microsoft Excel cannot find the macro that is assigned to run each time this document is 
opened.    
Make sure the path you have specified is correct and that the name of the macro sheet and 
the reference to the macro are correct, and try again. 
Yes

Cancels opening the document.
No

Opens the document.



Cannot find [macro] which has been assigned to run each time 
[document] is closed.    Continuing could lead to erroneous results.    
Cancel Close?
Microsoft Excel cannot find the macro that is assigned to run each time this document is 
closed.    
Make sure the path you specified is correct and that the name of the macro sheet and the 
reference to the macro are correct, and then try again. 
Yes

Cancels closing the document.
No

Closes the document.



Cannot find [name].
You tried to activate or deactivate a sheet containing a macro assigned to run whenever the
sheet is activated or deactivated. However, the macro could not be found.
If you used an Auto_activate or Auto_deactivate name that runs a macro that is on a sheet 
in a different location, be sure to include the full pathname in the name definition, and 
verify that the pathname is still correct.



Unable to activate the source application for this embedded object.
Microsoft Excel is unable to activate the source application for the embedded object you are
trying to edit.    There may not be enough memory, or the application may have stopped 
due to an unrecoverable error.
Quit all unneeded applications, close all unneeded windows, and then try to edit the 
embedded object again.



Unable to locate the source application for this embedded object.
Microsoft Excel cannot find the source application for the embedded object you are trying to
edit.    There are several possible reasons for this:

The application may not be installed on your computer.
If the source application is installed on a network, you may not be connected to the 

correct network disk.
Make sure the source application is installed or that you are connected to the correct 
network disk, and then try to edit the embedded object again.



Database is not defined.    File format cannot be used.
You tried to save your file in a DBF 2, DBF 3, or DBF 4 file format.    To use these file formats, 
you must have a database defined on your worksheet.    
To continue, define a database on your worksheet or select another file format.



Sheet is protected with password.    File format cannot be used.
This document has been protected with the Protect Document command on the Options 
menu and cannot be saved in any spreadsheet file format, including Excel 2.x, SYLK, WKS, 
WK1, WK3, or DBx.
If you want to save the file, you can do one of the following:

Remove the document protection using the Unprotect Document command.
Save the file in the Normal file format or as a template.



Sheet is protected with password and formulas are displayed.    File 
format cannot be used.
This document has been protected with the Protect Document command on the Options 
menu and cannot be saved in the Text, CSV, or DIF file format while formulas are displayed.
If you want to save the file, you can do one of the following:

Display values and save in a Text, CSV, or DIF file format.
Remove the document protection using the Unprotect Document command.
Save the file in the Normal file format or as a template.



Value is too large.
The value you specified while running a demonstration in Help for Lotus 1-2-3 Users is too 
large. The valid range varies depending on the specific action.
Run the command again and enter a smaller value.



Value is too small.
The value you specified while running a demonstration in Help for Lotus 1-2-3 Users is too 
small. The valid range varies depending on the specific action.
Run the demonstration again and enter a larger value.



Unable to import file
The Lotus 1-2-3 command /File Import was not able to import the specified file.    Check to 
make sure that the filename and pathname are accurate.



Unable to combine file
The Lotus 1-2-3 command /File Combine was not able to combine the specified file.    Check 
to make sure that the filename and pathname are accurate.



Unable to extract file
The Lotus 1-2-3 command /File Xtract was not able to extract the specified file.    This could 
be caused by insufficient disk space or insufficient memory to complete the operation. Try 
deleting unnecessary documents from your disk, using a different disk, or closing other 
open applications to make more memory available.



Cannot import from an open file
In Help for Lotus 1-2-3 Users, Microsoft Excel cannot run the File Import Text or File Import 
Numbers demonstration using a file that is already open.    Close the file containing the text 
or numbers you want to import, and run the demonstration again.



Cannot extract to an open file
The Lotus 1-2-3 command /File Xtract was not able to extract the specified file.    Check to 
make sure that the file to which you are extracting is not open. Close the file and try again.



Directory does not exist.
The directory you specified for the File Directory demonstration in Help for Lotus 1-2-3 Users
does not exist.
Check the drive letter and the spelling of the path, and then run the demonstration again.



Matrix must be square.
Only square matrices can be inverted.
Make sure the range you want to invert is a square matrix containing values, and then try 
again.



Matrices are incompatible for multiplication.
You specified two incompatible matrices while running the Data Matrix Multiply command.    
When you multiply two matrices, the number of columns in the first matrix must be the 
same as the number of rows in the second.    The matrices can contain only values.
Check the contents, size, and shape of each matrix, and then run the demonstration again.



Output range extends beyond edge of worksheet.
The output cell or range you specified while running a demonstration in Help for Lotus 1-2-3 
Users is too close to the edge of the worksheet to accommodate the result.
Specify a cell or range that is further from the edge of the worksheet, and then run the 
demonstration again.



Cannot split when the document has more than one window.
The Lotus 1-2-3 command /Worksheet Window Horizontal (or Vertical) was not able to split 
the active window because the window is already split into two panes.    In Microsoft Excel, 
you cannot split a window into more than two panes, but you can open multiple windows for
the same document by choosing the New Window command from the Window menu.



Cannot split when windows are locked.
The Lotus 1-2-3 command /Worksheet Window Horizontal (or Vertical) was not able to split 
the active window because the worksheet is locked.    Unlock the worksheet using the 
Unprotect Document command on the Options menu, and try again.



Reference cannot be to a closed sheet.
The reference you specified while running a demonstration in Help for Lotus 1-2-3 Users 
does not refer to an open document.
Open the document and run the demonstration again.



Lotus 1-2-3 Help demonstrations cannot be recorded.    Stop 
recording and continue?
You tried to start Help for Lotus 1-2-3 Users while recording a macro, but Microsoft Excel 
does not record Lotus 1-2-3 Help demonstrations.
OK

Stops recording your macro and starts Help for Lotus 1-2-3 Users.
Cancel

Cancels Help for Lotus 1-2-3 Users and continues recording your macro.



Cannot post instructions because a worksheet is not active.
You opened Help for Lotus 1-2-3 Users with the Instructions option selected, but there is no 
worksheet on which to place the Instructions text box. Open a new or existing worksheet 
and try again.



Cannot post instructions because worksheet objects are currently 
hidden or protected.
In Help for Lotus 1-2-3 Users, Microsoft Excel cannot post instructions to a worksheet with 
hidden or protected objects.
To post the instructions, you must either unhide or unprotect worksheet objects. You can 
also post the instructions to another worksheet.
To unhide worksheet objects

1 From the Options menu, choose Display.
2 Under Objects, select the Show All option button.
3 Choose the OK button.

To unprotect worksheet objects
From the Options menu, choose Unprotect Document.



Cannot post instructions because worksheet is protected.
You opened Help for Lotus 1-2-3 Users with the Instructions option selected, but the active 
worksheet is protected. Unprotect the worksheet using the Unprotect Document command 
on the Options menu, and try again.



Not enough data for Graph demonstration.
Microsoft Excel cannot run the Graph View demonstration in Help for Lotus 1-2-3 Users 
because you have not specified an x-axis range, one or more series ranges, or both.
To specify the x-axis and series ranges and to see the graph demonstration

1 In Help for Lotus 1-2-3 Users, run the Graph X demonstration.
2 Enter the x-axis range.
3 Run the Graph A demonstration.
4 Enter the first series range.
5 To continue entering ranges for other series, run the demonstrations for Graph B, 

Graph C, and so on.
6 Run the Graph View demonstration.

For a pie chart, you only need to specify one series range by running the Graph A 
demonstration.    No x-axis range is required.



Cannot demo with custom menus.
In Help for Lotus 1-2-3 Users, Microsoft Excel cannot complete the demonstration because 
you have modified one or more of the menus it needs.
You should avoid using custom menus when running demonstrations with Help for Lotus 1-
2-3 Users.



Help for Lotus 1-2-3 Users is not available in group edit mode.
You cannot use Help for Lotus 1-2-3 Users when you are editing multiple worksheets as a 
group.
To continue

1 Choose the OK button to close the message box.
2 From the Options menu, choose Group Edit.
3 Select only one worksheet in the Select Group list.
4 Choose the OK button.
5 Start Help for Lotus 1-2-3 Users again.



Missing NEXT for loop. Macro error at cell [reference].
There is a FOR or WHILE statement in the macro without a NEXT statement to go with it. 
Halt

Stops the macro.
Step

Starts the "single-step" process to step through the macro one function at a time.
Continue

Continues running the macro.
Goto

Switches to the macro sheet and selects the cell where the error occurred.



Missing loop. Macro error at cell:
There is a NEXT statement in the macro without a FOR or WHILE statement to go with it. 
Halt

Stops the macro.
Step

Starts the "single-step" process to step through the macro one function at a time.
Continue

Continues running the macro.
Goto

Switches to the macro sheet and selects the cell where the error occurred.



Missing IF. Macro error at cell: [reference].
There is an ELSE, ELSE.IF, or END.IF statement in the macro without an IF statement to go 
with it. 
Halt

Stops the macro.
Step

Starts the "single-step" process to step through the macro one function at a time.
Continue

Continues running the macro.
Goto

Switches to the macro sheet and selects the cell where the error occurred.



Missing an END.IF function. Macro error at cell: [reference].
For every block form of the IF function (IF-THEN-ELSE), there must be one END.IF function to 
complete the block. Check the number of block form IF functions.    Make sure you have an 
equal number of END.IF functions and that they are properly placed to complete each 
logical block of macro functions.



Cannot add another menu bar. Macro error at cell: [reference].
You have already added the maximum number of menu bars.    The maximum number of 
menu bars is 15. Use the DELETE.BAR macro function to delete any menu bars you are not 
using before adding the new menu bar.    Make sure you do not use the numbers of any 
deleted menu bars as arguments to other functions.



Command or menu does not exist. Macro error at cell: [reference].
You are attempting to display a command or menu that doesn't exist. 
If you are displaying a built-in command or menu, make sure you are using the correct 
identifying name or number. If you are displaying a custom command or menu, make sure it
is correctly defined on the macro sheet.



Cannot delete built-in or active menu bars. Macro error at cell: 
[reference].
You cannot delete built-in Microsoft Excel menu bars or the active custom menu bar.
To delete the displayed custom menu bar, use the SHOW.BAR macro function to display 
another menu bar, and then try the delete operation again.



Cannot enable built-in commands. Macro error at cell: [reference].
You can neither enable nor disable built-in Microsoft Excel commands using a macro. You 
can enable and disable custom menu commands only by using the ENABLE.COMMAND 
macro function.



Names cannot look like references. Macro error at cell: [reference].
A name in your macro resembles a reference. Names cannot resemble an A1-style reference
when you are using that style. If you are using the R1C1 reference style, however, names 
can resemble the A1 reference style. 
Type a valid name in place of the invalid one.



Option buttons must belong to an option button group.
In the area where you are defining your custom dialog box, Microsoft Excel does not know 
with what group to associate a particular option button.
In your custom dialog box, make sure an option button group box is defined (item type 11) 
before the individual buttons are defined (item type 12).



Option button group without option buttons.
In the area where you are defining an option button group (item type 11) for your custom 
dialog box, there are no option buttons (item type 12).
Make sure you define at least two option buttons for each option button group.



Linked or combination list box requires a preceding edit item.
You are trying to display a custom dialog box containing one of the following items:

Linked list box (item type 16)
Linked file list box (item type 18)
Linked drive and directory list box (item type 19)
Drop-down combination edit/list box (item type 22)

However, there is no preceding edit box (item types 6 through 10) in your dialog box 
definition table. Check the dialog box definition table and make sure an edit box is defined 
above the cell defining the list box.    Linked file and linked drive and directory list boxes 
require a preceding text edit box (item type 6).



Cannot use name that is a reference to nonadjacent cells.
The selected object or chart contains a formula that refers to a name that is a reference to 
nonadjacent cells.
Use the Define Name command on the Formula menu to redefine the name as a simple 
reference, or use another named reference.



Nonadjacent selections are not valid.
You are creating a complex reference for a series in the Edit Series dialog box or the formula
bar that violates one or both of the following rules:

All references in a complex reference must refer to the same sheet.
All references in a complex reference must refer to rectangles of similar size.    For 

example, in a single complex reference, some of the references should not be to ranges of 1 
by 8 cells while others are to ranges of 10 by 10 cells.



Cannot change linked data--[message].
Category range contains nonnumeric data.
You are trying to change a data point on an xy (scatter) chart by dragging it in the x-axis 
direction, but the category range for this chart contains nonnumeric data.    You cannot drag 
points in the x-axis direction in this situation. 
To change a data point on an xy (scatter) chart, edit the cells in the category range so that 
they contain only numeric values, and then try making the change again.
Cell in source worksheet contains nonnumeric data.
The cell in the source worksheet that corresponds to the data point you are trying to change
contains nonnumeric data.    Before you can change the data point, you must edit the cell so
that it contains a number, a formula that returns a number, nothing, or the #N/A error 
value.
Cell in source worksheet is locked.
The cell in the source worksheet that corresponds to the data point you are trying to change
is locked.
To unlock all cells, switch to the source worksheet and choose the Unprotect Document 
command from the Options menu.
Data point is linked to a formula on a macro sheet.
The cell in the source worksheet that corresponds to the data point you are trying to change
is on a macro sheet.    To change the data in that cell, you must switch to the macro sheet 
and edit the cell directly.
Source worksheet is closed.
You cannot change a data point on a chart when the source worksheet is closed.
Open the source worksheet and try again.



Source worksheet is closed.
You cannot change a data point on a chart when the source worksheet is closed.
Open the source worksheet and try again.



Data point corresponds to a formula on a hidden worksheet.
You attempted to drag a chart data point to perform a graphical goal-seek operation, but 
the source worksheet is hidden. You cannot change data on a hidden worksheet. Unhide the
worksheet using the Unhide command on the Window menu, and try again.



Data point corresponds to a formula on a macro sheet.
You attempted to drag a chart data point to perform a graphical goal-seek operation, but 
the source sheet is a macro sheet. You cannot perform goal-seeking on a macro sheet. 



Cell in supporting worksheet is locked.
You tried to drag a point on a chart for which the corresponding cell in the linked worksheet 
is protected.    
To drag the point, remove the protection from the supporting worksheet using the Unprotect
Document command on the Options menu.



Category range contains nonnumeric data.
You manually entered a chart SERIES formula using constants for the category names 
argument, and these constants included nonnumeric data.    You are now trying to change a 
data point on an xy (scatter) chart by dragging it in the x-axis direction, but the data point 
uses the category argument that contains the nonnumeric data.    You cannot drag points in 
the x-axis direction in this situation. 
Edit the SERIES formula, specifying numeric data for the category names argument, and 
then try to change the data point again.



Stationery document is not saved in Normal Excel format.    Opening
as a nonstationery file.
You created a stationery document from the Apple desktop that was not saved in Microsoft 
Excel Normal file format. Microsoft Excel will open the file as a nonstationery file.

You can save the document as a template in Microsoft Excel. The template will 
function in the same way as a stationery document. 

You can also save the document in Microsoft Excel Normal format, and then make it a
stationery document from the Apple desktop.



Names in complex reference are not allowed.
You are creating a complex reference for a series in the Edit Series dialog box or the formula
bar that contains a name.    Only cell or range references are allowed in complex references.
Use the Define Name command on the Formula menu to check the cell or range reference 
the name refers to and enter the reference into the complex reference for the series.



Series formula is too long.
You have entered too many references for a single series in the Edit Series dialog box or the 
series formula in the formula bar.
The maximum number of references in a series is 17. For example, in a single series you 
cannot have 1 name reference, 9 category or x references, and 9 value or y references (or z
references for 3-D charts).
Use fewer references in your series or create more than one chart.



The list and decimal separators specified by the system are 
identical.    Substituting [punctuation mark] for the list separator.
The list and decimal separators specified in the International settings of the Control Panel 
are identical.    Microsoft Excel will substitute an appropriate punctuation mark for the list 
separator. To manually change the International settings, see your system documentation.



The date and time separators specified by the system are identical. 
Substituting ':' for the time separator.
The date and time separators specified in the Country settings of the Control Panel are 
identical.    Microsoft Excel will substitute a colon for the time separator. 
To manually change the Country settings, see your system documentation.



Text in your macro may need to be translated by hand.
You are either saving a macro in the International format or saving a macro in a non-
International format that was previously saved in the International format.    This may cause 
problems if your macro was written or recorded when United States was not the country 
selected in the Control Panel's International dialog box, or when other Control Panel settings
were not standard for an International macro.
If you decide to save your macro in the specified format, run your macro later and make 
sure it works correctly.    You may have to modify the macro to run correctly under the 
current Control Panel settings.
OK

Saves the macro in specified format.
Cancel

Cancels the command.



No objects found.
You chose the Select Special command from the Formula menu and tried to select all 
objects in the document, but the document contains no objects, or all the objects are 
hidden.
To unhide objects

1 From the Options menu, choose Display.
2 Under Objects, select the Show All option button.
3 Choose the OK button.



Unable to save external link values.
You are saving a document with external links, but there is not enough free memory to save 
the link values.    The document will be saved as if you had chosen the Calculation command
from the Options menu and cleared the Save External Link Values check box.    Only the links
to the external documents are saved, not the actual values. You can update the values the 
next time you open the document, provided that there is enough memory available.



Cannot print chart with the current scale and paper size; select a 
larger scale percentage or a smaller paper size.
You can print charts on most standard paper sizes, but Microsoft Excel cannot print on paper
that is longer than approximately 22 inches on any side. Some plotter paper sizes may be 
too large. 
If you are using a PostScript printer and have selected Size On Screen in the Page Setup 
dialog box, the number you entered in the Reduce/Enlarge To box, also in the Page Setup 
dialog box, is too small.    There are three ways to get the chart to print at the size you want:

In the Page Setup dialog box, select a smaller Paper Size.
Under Scaling in the Page Setup dialog box, enter a higher number.    Then, manually 

adjust the size of the chart window on the screen to the size you want.
Embed the chart on a worksheet.



Cannot change to that name.    Another document is linked to a 
document with that name.
You tried to use the Save As command on the File menu to change the name of the active 
document to a name that is already used for a file that is saved on disk. In addition, another
open document contains links to both the file you are trying to save and the file on disk. 
Save the document with a different name, or redirect the links of one of the other 
documents.
See Also

Help
Links Command (File Menu)
Redirecting links for source documents you rename or move.



Not enough memory. Continue without Undo?
There is not enough memory for the operation you want to perform.    You may be able to 
complete the operation, but you won't be able to choose the Undo command from the Edit 
menu after the operation has been performed.
OK

Proceeds with the operation; you will not be able to undo it.
Cancel

Cancels the operation, leaving the document as it was before the operation began.



Selection too large. Continue without Undo?
Microsoft Excel will not be able to undo changes made to that many cells.    You may be able 
to complete the operation, but you will not be able to undo it with the Undo command on 
the Edit menu.
OK

Proceeds with the operation; you will not be able to undo it.
Cancel

Cancels the operation, leaving the document as it was before the operation began.



Document not saved.
The save process was terminated.    Some possible reasons for this include:

You pressed ESC to cancel the save operation.
A disk read or write error occurred.
The disk does not have enough space to hold the document.

Insert another disk, save on a disk in a different drive, or delete unnecessary files with the 
Delete command on the File menu, and then try saving again.



Document not saved. Any previously saved copy has been deleted.
The save process was terminated.    Microsoft Excel deleted the original document from the 
disk to save the version in memory but has not saved the new version successfully.
Insert another disk, save on a disk in a different drive, or delete unnecessary files with the 
Delete command on the File menu, and then try saving again.



No source references specified for consolidation.
The All References box in the Data menu's Consolidate dialog box is empty.    You must 
specify at least one reference as a source for data consolidation.
To specify a source reference

1 Choose the OK button.
2 From the Data menu, choose Consolidate again.
3 In the Reference box, specify a source reference.
4 Choose the Add button to add the reference to the list of source references.



Cannot open consolidation source file [filename].
Microsoft Excel is unable to open the consolidation source file and therefore cannot perform 
the consolidation. There are several possible reasons for this:

Check to be sure that you have specified either Microsoft Excel or Lotus 1-2-3 files as 
the source files for your consolidation.

The file doesn't exist in the current directory. Change to the correct directory or copy 
the file to the current directory.

The spelling is incorrect.    Check it and try again.
You have used an incomplete or incorrect pathname.    Type a full pathname and try 

again.
The source refers to a protected file and you entered the wrong password.    Check 

the password and try again.



No data was consolidated.
Microsoft Excel was not able to consolidate any data. There are several possible reasons for 
this:

The categories used in the destination don't match those found in the source 
references. 

All of the cells in the destination area contain formulas.    Microsoft Excel will not 
replace formulas with consolidated data. 

An error occurred during the opening of one or more of the source references.
Check the source references for missing data and the destination area for formulas, and 
then try again.



Cannot add duplicate source reference.
The source reference you are trying to add already exists in the All References list box in the
Consolidate dialog box.
See Also

Help
Consolidate Command (Data Menu)



Consolidate_Area reference is not valid.
The Consolidate_Area must refer to a single rectangular reference on the current worksheet.
Check the Define Name command on the Formula menu to verify that the reference is 
correct.



Source reference overlaps destination area.
The source reference and the destination reference are overlapping.    Microsoft Excel will 
not consolidate data if these references overlap.
Check the references you have typed and try again.
See Also

Help
Consolidate Command (Data Menu)



Cannot create links to consolidation sheet.
In the Consolidate dialog box, the current worksheet is specified as a source reference, and 
the Create Links To Source Data check box is selected.    A consolidation worksheet cannot 
create a link to itself.
Either consolidate your data onto another worksheet, or delete any references to the 
current worksheet in the All References list.
See Also

Help
Consolidate Command (Data Menu)



Cannot show outline symbols.    No outline exists on the current 
worksheet.    Create one?
Outline symbols are displayed only when you have an outline on the active worksheet.    If a 
range is selected on your worksheet, Microsoft Excel creates an outline using that data.    If 
there is no selection, Microsoft Excel creates an outline using all the data below and to the 
right of the active cell.
OK

Creates an outline.
Cancel

Cancels the action.
See Also

Help
Outline Command (Formula Menu)



Cannot promote.    To start an outline, select the detail rows or 
columns and demote them.
You tried to promote a row or column without first creating an outline on your worksheet. To 
create an outline, either select the detail rows or columns and demote them, or choose the 
Outline command from the Formula menu.



Modify existing outline?
You chose the Create button in the Outline dialog box on a worksheet that already contains 
an outline.
OK

Ignores the existing outline and creates a new one.
Cancel

Cancels the procedure.
See Also

Help
Outline Command (Formula Menu)



Cannot create an outline.
Microsoft Excel is unable to create an outline because it can't determine a relationship 
between any formulas on which to base the outline.    There are several possible reasons for 
this:

The worksheet is blank or contains only constant values or text.
None of the formulas in the worksheet depend on cells in the same row or column.
The relationship between the formulas in the worksheet is ambiguous, and the 

resulting outline summaries point in conflicting directions.
Examples

Cell A5 contains =A3+A4+A6.    All references are in the same column (as required), but 
no outline direction is apparent, so the outline could not be created.
Cell A5 contains =A2+A3+A4.    In this example, an outline can be created in which row 5 
is a summary row for the three preceding subordinate rows.

Make sure your formulas depend on cells in the same rows or columns and that their 
relationships are in one direction, and then try to create the outline again.
See Also

Help
Outline Command (Formula Menu)



Style name is not valid.
The style name you selected consists of only blank spaces or other invalid characters.
Check the style name you entered in the Style list box on the toolbar, and try the operation 
again.

See Also
Help
Creating or deleting a style



Style [name] not found.
You tried to apply a style that does not exist, using the APPLY.STYLE macro function. Check 
to see that the style name is spelled correctly in the macro, and that the desired style exists
on the sheet on which you are applying it. You might need to first define the style on the 
sheet using the DEFINE.STYLE macro function.
See Also

Microsoft Excel Function Reference



A group must contain two or more sheets.
To edit several worksheets and macro sheets as a single group, you must specify at least 
two sheets in the Select Group box in the Group Edit dialog box.
To continue

1 Choose the OK button.
2 From the Options menu, choose Group Edit.
3 In the Select Group box, hold down CTRL and select the sheets you want to add to the 

group.
4 Choose the OK button.



Input and output ranges overlap.
The input range and output range you specified for the Data Matrix Multiply or Data Matrix 
Invert command contain one or more of the same cells.
Specify an output range that does not include any cells in the input range, and then run the 
command again.



The current selection already contains only visible cells.
You clicked the Select Visible Cells button on the tool bar, but there are no hidden cells in 
the current selection.
Choose the OK button to close the message box.



Cannot use that command while in Data Entry mode.
You tried to issue a command that is not allowed while in Data Entry mode, which was 
activated by the ENTER.DATA macro function. You can use the ENTER.DATA macro function 
again to exit Data Entry mode, or you can press the ESC key to exit Data Entry mode.
See Also

Help
Lotus 1-2-3 Range Input Command
Microsoft Excel Function Reference



Insert new page into printer
You are using the LINE.PRINT macro function with the wait argument set to TRUE or you are
running a Lotus 1-2-3 macro that has the /wgdpw (Wait) feature on. Insert a new page into 
the printer.
See Also

Help
LINE.PRINT



AutoFormat could not detect a table around the active cell. Select 
the desired range and choose the command again.
You tried to perform an AutoFormat operation with only one cell selected that has no 
adjacent nonblank cells. If you select one cell in a range of adjacent nonblank cells, 
AutoFormat selects the entire range, called the current region, and applies the selected 
table format. If you select a cell with no adjacent nonblank cells, AutoFormat cannot 
determine which cells are part of a table. 
Select the range you want to format; then choose the AutoFormat command again.
See Also

Help
AutoFormat Command (Format Menu for Worksheets)
Select Special Command (Formula Menu)



Continue checking at beginning of sheet?
Microsoft Excel has checked the worksheet from the active cell to the last cell. Spell 
checking continues from the active cell to the right and down the worksheet. 
OK

Continue checking from the beginning of the worksheet to the active cell.
Cancel

Cancels the operation. Any corrections that have already been made will remain.



Could not find main dictionary.
Microsoft Excel could not find the main dictionary. If the main dictionary file does not exist 
on your hard drive, run the Microsoft Excel Setup program again to reinstall Microsoft Excel.



Finished spell checking [document].
Microsoft Excel has completed the spelling check. 



Could not initialize spell checker.
Microsoft Excel could not run the spell checker. Make sure that the file named MSSPELL.DLL 
is in your WINDOWS\MSAPPS\PROOF directory.
If the spelling file does not exist on your hard drive, run the Microsoft Excel Setup program 
again to reinstall Microsoft Excel.



Incompatible version of spell checker.
Microsoft Excel cannot find a compatible version of the spell checker on your machine. Run 
the Microsoft Excel Setup program again to reinstall Microsoft Excel.



Custom dictionary [name] does not exist.    Create?
Microsoft Excel could not find the indicated custom dictionary. Make sure that the file is in 
your WINDOWS\MSAPPS\PROOF directory. 
If the indicated file does not exist on your hard drive, choose Yes to create it. 



Selection is not valid.
If you chose the Copy or Paste command from the Edit menu, the copy and paste areas 
cannot overlap unless they are exactly the same.
If you chose the Cut or Paste command from the Edit menu, and the paste area you select is
a single cell, the pasted data must not extend beyond the edges of the worksheet.
If you chose the Create Names command from the Formula menu, the row or column 
containing the proposed names will not be included in the definitions of the names.

If the names you are creating are listed in a row, you must select more than one row.
If the names you are creating are listed in a column, you must select more than one 

column.
If you chose the Table command from the Data menu, you must select a single rectangle 
that is more than one row high and more than one column wide.



Recorder is not valid.
Before you can record a macro in the recorder range, you must define an area on your 
macro sheet with the name Recorder.    You can designate the recorder range yourself with 
the Set Recorder command on the Macro menu or have Microsoft Excel determine the 
recorder range automatically when you choose the Record command from the Macro menu. 
Once the recorder range has been defined, do not delete or alter the name Recorder until 
you have recorded the macro.    Otherwise, you will have to choose Set Recorder or Record 
to set the recorder range again before you begin recording.
To resume recording, choose Set Recorder, then choose Record from the Macro menu.



Recorder is not defined.
Before you can record a macro in the recorder range, you must define an area on your 
macro sheet with the name Recorder.    You can designate the recorder range yourself with 
the Set Recorder command on the Macro menu or have Microsoft Excel determine the 
recorder range automatically when you choose the Record command from the Macro menu. 
Once the recorder range has been defined, do not delete or alter the name Recorder until 
you have recorded the macro.    Otherwise, you will have to choose Set Recorder or Record 
to set the recorder range again before you begin recording.
To resume recording, choose Set Recorder, then choose Record from the Macro menu.



Formula is too long.
The formula you are entering is too long or complex.    Try breaking the formula into two or 
more parts and entering each into a different cell.



Text is too long.
The text you are entering is too long. You can enter a maximum of 255 characters in the 
formula bar or in a dialog box.    Reduce the number of characters used in the text string or 
cancel the entry. 
If you are running a spell check, the maximum allowed length of a word is 40 characters. 
Please click the Ignore button to bypass words over 40 characters in length.



Number format is too long.
In the Number dialog box, you typed a custom format that is invalid. Check the type and 
number of placeholders and format codes, and try again.
See Also

Help
Number Command (Format Menu)



Parentheses do not match.
You have entered a formula in the formula bar with incorrect or missing parentheses. 
Although Microsoft Excel can add missing parentheses to simple formulas automatically, the
formula you entered has more than one possible location for additional parentheses. Check 
the formula and add the parentheses in the appropriate place in the formula. 



[Incorrect number of] arguments.
You have added either too few or too many arguments to the function you just entered. 
Check the proper syntax of the function, and reenter it. 
See Also

Help
Functions
Paste Function Command (Formula Menu)
Microsoft Excel Function Reference



Error in Formula: Missing operand.
You have typed an incomplete formula. You must include an operand following each 
operator. For example, =A1+A2+ is an incomplete formula with a missing operand following
the second plus sign. Add the missing operand to the formula or delete the extra operator.



Cannot access file.
You are trying to save, open, or link to a document that currently cannot be accessed.    
Some possible reasons for this include:

The document name or path you specified in a dialog box does not exist.
Check the spelling of the name or path, and try to access the document again.
The document you are trying to open is being used by another application.
When the document is no longer being used, try to open it again.
The name of the document you are trying to save is the same as the name of another

document that is read-only or that is being used by another application.
Save your document with a different name.    If you want your document to have the 

same name, change the read-only document's attributes to read/write, or wait until the in-
use document is no longer being used.

You are trying to save a document to a read-only network directory or disk.
Save the document to a different network directory or disk.

You are trying to revert to the saved version of an open document, but the saved 
version has been deleted.

Save the open document with another name, and then open the backup version of 
the deleted document if one exists.
The buttons that appear in the message box vary depending on the cause of the error.    
OK

Closes the message box.
Retry

Tries to access the document again.
Cancel

Cancels the command.



Invalid register id, or function not registered yet.
You have used a dynamic link library (DLL) function or command that has not been 
registered in the current session. DLL functions and commands that you want to use must 
be registered each time Microsoft Excel is started. 



No references found.
You tried to use the Apply Names command to replace references in formulas with their 
equivalent names. Microsoft Excel could not find any references that match the definitions 
of the selected names. 



Input cell reference is not valid.
When you are constructing a data table, references for the row and column input cells must 
refer to single cells.    The cell referenced for each cannot be within the table itself.
For a one-input table, you will have either a row input cell or a column input cell, but not 
both.
See Also

Help
Table Command (Data Menu)



First document in the workbook must be a worksheet.
You tried to save a workbook as a WK3 file without a worksheet as the first document. Move 
any other types of documents from the beginning of the list of documents in the Workbook 
Contents window.
See Also

Help
Save Workbook Command (File Menu)
To add or remove a document from a workbook
To move between workbook documents
To reorder documents in a workbook
Workbooks



Cannot save workbook with no worksheet as a WK3 file.
You have not designated a worksheet as the first document in a workbook, or no worksheet 
file was included in your list of workbook documents. Move any other types of documents 
from the beginning of the list of documents in the Workbook Contents window, or add a 
worksheet to your workbook.
See Also

Help
Save Workbook Command (File Menu)
To add or remove a document from a workbook
To move between workbook documents
To reorder documents in a workbook
Workbooks



Cannot save unbound workbook as a WK3 file.
You have designated one or more worksheets in the workbook to be saved as separate files.
To save your workbook as a WK3 file, all documents must be bound as a workbook file.
See Also

Help
Save Workbook Command (File Menu)
To add or remove a document from a workbook
To move between workbook documents
To reorder documents in a workbook
Workbooks



Cannot save workbook with macro sheets as a WK3 file.
You have included one or more macro sheets in a workbook that you want to save as a WK3 
file. Macro sheets have no equivalent in WK3 files, so you must remove any documents that 
are not macro sheets from the list of documents in the Workbook Contents window.
See Also

Help
Save Workbook Command (File Menu)
To add or remove a document from a workbook
To move between workbook documents
To reorder documents in a workbook
Workbooks



Update embedded objects?
You chose the Save or Save As command from the Edit menu while a worksheet containing 
open embedded objects was active. You can choose to save or discard the newly edited 
versions of the embedded objects.
Yes

Updates the embedded objects and saves the worksheet.
No

Does not update the embedded objects and saves the worksheet.
Cancel

Cancels the command.



Cannot bind a document with the same name as another bound 
document.
Microsoft Excel cannot bind two documents with the same name into the same workbook. 
Either save the unbound document with a new name, or change the name of the bound 
document by using the Options button in the Workbook Contents window.
See Also

Help
Save Workbook Command (File Menu)
To add or remove a document from a workbook
To move between workbook documents
To reorder documents in a workbook
Workbooks



Cannot unbind a document with the same name as another open 
document
You cannot have two documents with the same name open at the same time. Change the 
name of the bound document so that it does not conflict with the name of another open 
document, then unbind it.
See Also

Help
Save Workbook Command (File Menu)
To add or remove a document from a workbook
To move between workbook documents
To reorder documents in a workbook
Workbooks



Workbook is protected and cannot be changed.
You cannot make changes to protected workbooks. You must go to the contents page of the 
workbook and use the Unprotect Document command on the Options menu before you can 
make changes.
See Also

Help
Protect and Unprotect Document Commands (Options Menu)
Save Workbook Command (File Menu)
To add or remove a document from a workbook
To move between workbook documents
To reorder documents in a workbook
Workbooks



Cannot use this command with a workbook or WK3 file open.
You must close all open workbooks and WK3 files before you can choose the Introducing 
Microsoft Excel or Learning Microsoft Excel command from the Help menu. 



Document in more than one workbook. Activate workbook contents 
and try again.
You have chosen the Save Workbook command from the File menu while an unbound 
document is active that is included in more than one open workbook.
If you want to save the document itself, choose the Save command from the File menu. The 
updated version of the document will be opened when you open any workbooks with which 
it is associated. 
If you want to save a new version of one of the workbooks associated with the active 
document , save the workbook while the Workbook Contents window is active.
See Also

Help
Save Workbook Command (File Menu)
To add or remove a document from a workbook
To move between workbook documents
To reorder documents in a workbook
Workbooks



This chart graphs data from more than one worksheet.    Use the 
Chart Edit Series command to change its plot data.
You have chosen the ChartWizard tool while a chart that uses data from multiple worksheets
is active. The ChartWizard can only be used to adjust the data series of a chart that has a 
single source worksheet. The active chart has references to more than one worksheet in its 
data series formulas. You must use the Edit Series command on the Chart menu to make 
changes to this chart.
See Also

Help
ChartWizard tool
Edit Series Command (Chart Menu)



This chart graphs constant data.    Use the Chart Edit Series 
command to change its plot data.
You have chosen the ChartWizard tool while an unlinked chart is active. The ChartWizard 
uses external references to another worksheet to adjust the data series of a selected chart. 
The active chart has no external references in its data series formulas. You must use the 
Edit Series command on the Chart menu to make changes to this chart.
See Also

Help
ChartWizard tool
Edit Series Command (Chart Menu)



This chart graphs data from an unopen worksheet.    Use the File 
Links command to open the supporting document.
You have chosen the ChartWizard tool while a chart whose source worksheet is not open is 
active. The ChartWizard uses references to the source worksheet to adjust the data series of
a selected chart. Use the Links command on the File menu to open the source worksheet.
See Also

Help
ChartWizard tool
Links Command (File Menu)



Update object [name] in [document]?
You chose the Exit command from the File menu while editing an Excel document that will 
become an embedded object in another document. You can choose to send the Microsoft 
Excel object to the destination document, or discard it.
Yes

Sends the embedded object to the destination document and quits Microsoft Excel.
No

Does not send the embedded object to the destination document and quits Microsoft 
Excel.

Cancel
Cancels the command.



Cannot execute [program].    The program or one of its components 
is damaged or missing.
You ran a macro that includes the EXEC macro function, but the EXEC function could not 
open the indicated program. Check to make sure that all the files necessary for the program
to run are available, and that the syntax of the EXEC function is correct. You may need to 
include the path along with the name of the program you need to run. The EXEC function 
uses the form:

=EXEC(program_text, window_num)
Make sure that the name of the program matches the argument program_text exactly, and 
that it is surrounded by quotation marks in the formula.
For example:

=EXEC("C:\WINWORD.EXE", 1)
See Also

Microsoft Excel Function Reference



A surface chart must contain at least two series.
You attempted to create a surface chart with only one data series selected on the 
worksheet. Either select two or more data series before creating the surface chart, or select 
another chart type.



Criteria range is not valid.
The criteria range must be a single rectangle more than one row high.

For comparison criteria, the first row of the criteria range must contain one or more 
field names from the database.

For computed criteria, the first row of the criteria range must either be blank or 
contain a criteria name different from any database field name.
Redefine the criteria range using the Set Criteria command on the Data menu.    
See Also

Help
Set Criteria Command (Data Menu)



Database range is not valid.
The database range must be a single rectangle more than one row high.    The first row of 
the database range must contain the database field names.
When defining a database range, make sure you include in the selection the field names 
and an extra blank row below the last record of your database. A worksheet can have only 
one database defined at a time.
Redefine the database range using the Set Database command on the Data menu. 
See Also

Help
Set Database Command (Data Menu)



Extract range is not valid.
The extract range must be a single rectangle containing either field names or field names 
with empty cells beneath them that will contain the extracted data.    The field names must 
match field names in the database.    Either one or more field names in the extract range is 
not from the database, or the extract range contains a blank cell in the field name row.
Try copying the field names from the first row of the database and pasting them into the first
row of the extract range.    Select the extract range and choose the Extract command again.  
Or, redefine the extract range using the Set Extract command, and then choose Extract.
See Also

Help
Extract Command (Data Menu)
Set Extract Command (Data Menu)



Global Macro Sheet in the startup directory must stay open for 
recording.
You attempted to record a global macro while a global macro sheet exists in the startup 
directory but is not currently open. Either the global macro sheet was closed and it must be 
reopened, or the file is corrupted or empty. 
To open the global macro sheet

1 From the File menu, choose Open.
2 Select GLOBAL.XLM in the XLSTART directory.
3 Choose the OK button.

If you cannot open the global macro sheet
1 From the File menu, choose Delete.
2 Select GLOBAL.XLM in the XLSTART directory.
3 Choose the OK button.
4 Try recording your global macro again.

Any global macros previously recorded will be lost if you delete the global macro sheet. Now
you can record your new global macros. Remember that when you open the global macro 
sheet, it will probably not appear in a window because it is normally a hidden sheet. If it is 
visible when you open it, choose the Hide command from the Window menu.



Cannot save Global Macro Sheet in the startup directory. You may 
save it elsewhere now and move it to the startup directory later.
You tried to save a global macro sheet, but the XLSTART directory does not exist, the disk on
which the XLSTART directory resides is full, or you do not have write privileges for the 
GLOBAL.XLM macro sheet.
See Also

Help
Alternate Startup Directory



Invalid [dictionary name].
You attempted to check spelling, but Microsoft Excel could not open the specified dictionary.
If the main dictionary was specified, you must rerun the Microsoft Excel Setup program. If a 
custom dictionary was specified, you will need to first delete the existing custom dictionary 
file on disk and then re-create it.
See Also

Help
Spelling Command (Options Menu)



Could not read [dictionary name].
You attempted to check spelling, but Microsoft Excel could not read the specified dictionary. 
If the main dictionary was specified, rerun the Microsoft Excel Setup program. If a custom 
dictionary was specified, either specify another dictionary, or delete the existing custom 
dictionary file on disk and then re-create it.
See Also

Help
Spelling Command (Options Menu)



Could not write [dictionary name].
You attempted to check spelling, but Microsoft Excel could not write to the specified 
dictionary file. Check to make sure that the specified dictionary file is not read-only. 
Otherwise, if the main dictionary was specified, you must rerun the Microsoft Excel Setup 
program. If a custom dictionary was specified, you will need to first delete the existing 
custom dictionary file on disk and then re-create it.
See Also

Help
Spelling Command (Options Menu)



Could not create [dictionary name].
You attempted to create a new custom dictionary, but Microsoft Excel could not create the 
file. Possible causes are:

The filename you used for the custom dictionary is invalid. 
There is not enough room on your disk for the custom dictionary file.
You tried to save the custom dictionary to a read-only disk.

See Also
Help
Spelling Command (Options Menu)



Could not share [dictionary name].
You attempted to check spelling, but the specified dictionary file was in use by another 
application. If you are running another application that is using the dictionary file, quit the 
other application and try running the spelling checker again. If you are using Microsoft Excel
on a network, another person may be using the dictionary file. Wait and try to check 
spelling again later.



Custom dictionary is full.
The specified custom dictionary is full. Create a new custom dictionary with a different 
name, or delete some entries in the current custom dictionary to make room for the new 
entries you want to include.
See Also

Help
Spelling Command (Options Menu)



Could not open [dictionary name].
You attempted to check spelling, but Microsoft Excel could not open the specified dictionary.
If the main dictionary was specified, you must rerun the Microsoft Excel Setup program. If a 
custom dictionary was specified, make sure the filename refers to an actual dictionary file.
See Also

Help
Spelling Command (Options Menu)



Dictionary is too large.
The specified custom dictionary is too large. Create a new custom dictionary with a different
name, or delete some entries in the current custom dictionary to make room for the new 
entries you want to include.
See Also

Help
Spelling Command (Options Menu)



The [selected text] is spelled correctly.
You selected text in the formula bar, on the worksheet, or in a text box and then chose the 
Spelling Command from the Options menu. Microsoft Excel determined that the selected 
text is spelled correctly.
See Also

Help
Spelling Command (Options Menu)



Font size must be between 1 and 409 points.
Font size is measured in points.    Negative values and decimal values are not valid.    The 
maximum size you can enter is 409 points.    The Font command on the Format menu 
displays a dialog box that lists sizes available for display or for printing.    If you type a size 
that differs from one of those in the box, Microsoft Excel attempts to produce that size as 
closely as possible.    Depending on your screen display and your printer driver, the results 
may appear ragged. 
Check the font size you specified and try the operation again.



Cannot find [linked document].
The document to which you have established a link has been moved, renamed, or deleted, 
or was never created.    
You can copy the linked values from a different document, or from the same document if it 
was moved or renamed.
OK

Copies values from the alternate document you have selected.    Select documents the 
same way you select them using the Open command on the File menu.

Cancel
Cancels the dialog box and does not update the linked values.

Selecting a document in this dialog box and choosing the OK button is only a temporary 
solution.    
To redirect links permanently

1 From the File menu, choose Links.
2 Select the correct source file in the Links list.
3 Choose the Change button.

See Also
Help
Links Command (File Menu)



Cannot open Macintosh Excel 1.X chart.
This chart, created in Microsoft Excel for the Macintosh version 1.5 or earlier, cannot be 
opened.
You must open the Macintosh worksheet from which you got the data for the chart and then 
recreate the chart using a newer version of Microsoft Excel.



Cannot open normal Macintosh Excel document.
This is a normal document created in Microsoft Excel for the Macintosh version 1.5 or earlier.
To open the document with Microsoft Excel for Windows

1 Open the file in Microsoft Excel for the Macintosh.
2 Save it in SYLK format.
3 Transfer the file to an IBM PC or compatible computer.
4 Open the file in Microsoft Excel for Windows by choosing the Open command from the 

File menu.



Remote data not accessible. Start application [name]?
You initiated a dynamic data exchange (DDE) link to an application that is not running.    
Yes

Microsoft Excel starts the application to access the data.
No

Microsoft Excel does not start the application. The procedure is canceled, and the data 
is not accessed.



Re-establish remote links?
When you open a document that contains a remote external reference (a DDE formula), 
Microsoft Excel asks if you want to reestablish the link to the remote data.
Yes

Microsoft Excel attempts to reestablish the remote link.
No

The remote link is not established.    Microsoft Excel will use the existing values.



Existing remote links will be terminated.
You chose the Workspace command from the Options menu and instructed Microsoft Excel 
to ignore all remote requests from other applications.    This terminates existing remote 
links.
OK

Remote requests will be ignored and existing remote links will be terminated.
Cancel

Cancels the command.



Remote links to document exist. Close anyway?
Another application is linked to some data on the document you are trying to close.    If you 
close the document, the remote link to the document you are closing will be terminated, 
and the application using the data on the worksheet will no longer be able to access the 
data.
OK

Closes the document and terminates the remote link.
Cancel

Cancels the command.



This command controls default printer settings for all documents 
and all applications.    Use Page Setup to set Orientation, Paper Size,
and Scaling for individual documents.
Your printer driver supports document-specific settings for orientation, paper size, and 
scaling.    Document-specific settings override system-wide default settings--the settings 
Microsoft Excel uses unless you specify otherwise--and do not affect other documents.    If 
you continue, you will change the default value for the printer settings, but you may not 
change the settings for this document. 
Choose the Page Setup command from the File menu to change settings for a specific 
document.
Choose the Printer Setup button in the Page Setup dialog box to display the Printer Setup 
dialog box, which allows you to change the default settings for all documents and 
applications.    This default value will be used for any new documents that you create.
OK

Continues the Printer Setup command. 
Cancel

Cancels the operation.



EXCELCBT.LIB not found. Cannot run tutorial.
Microsoft Excel cannot find the file EXCELCBT.LIB, which is required to run the tutorial.
Locate the file and copy it to the EXCELCBT subdirectory in the directory in which you 
installed Microsoft Excel, or run the Microsoft Excel Setup program to install all of the 
tutorial (CBT) files.



EXCELCBT.CBT not found. Cannot run tutorial.
Microsoft Excel cannot find the file EXCELCBT.CBT, which is required to run the tutorial.
Locate the file and copy it to the EXCELCBT subdirectory in the directory in which you 
installed Microsoft Excel, or run the Microsoft Excel Setup program to install all of the 
tutorial (CBT) files.



Lesson file(s) not found. Cannot run tutorial.
Microsoft Excel cannot find the file or files corresponding to the tutorial lesson you are trying
to run. 
Locate the files and copy them to the EXCELCBT subdirectory in the directory in which you 
installed Microsoft Excel, or run the Microsoft Excel Setup program to install all of the 
tutorial (CBT) files.



EXCELCBT directory not found.
Microsoft Excel cannot find the EXCELCBT subdirectory, which is normally in the directory in 
which you installed Microsoft Excel.    The subdirectory was either deleted or was never 
installed.
Run the Microsoft Excel Setup program to create the directory and install all of the tutorial 
(CBT) files.



Macro interrupted at cell:
You pressed CTRL+BREAK while running a Lotus 1-2-3 macro.
Click the OK button or press ENTER to return to Ready mode.



Macro error at cell:
This cell contains one of the following:

A misspelled or invalid command, keyword, or argument.
A macro statement that is not compatible with Lotus 1-2-3 Release 2.01.    You can 

open any 1-2-3 file in Microsoft Excel, but you can run only macros that are compatible with 
Lotus 1-2-3 Release 2.01.    The Macro Interpreter for Lotus 1-2-3 Users does provide some 1-
2-3 Release 2.2 macro compatibility.    See Switching to Microsoft Excel from Lotus 1-2-3 for 
details.

A command that attaches or starts a Lotus 1-2-3 add-in.    Lotus 1-2-3 add-ins are not 
supported.

The macro code /a was used to attach or invoke an add-in. 
Remove all occurrences of this keystroke, as well as any add-in commands such as 
{app1}.

The macro was invoked from a frozen pane. 
You must start a macro from an unfrozen pane.

The {let} command was used to insert a file linking formula.
You can use the syntax '+<<file.wk1>>A1~ instead.

The macro code /fr or /fs was used on a worksheet located in a workbook. 
To retrieve or save files in a macro, the worksheet must not be in a workbook.

The code {getlabel} or {getnumber} was called from Edit mode.
A macro statement that leaves the macro in menu mode.
A macro statement that calls a subroutine on another sheet.

This is Lotus 1-2-3 3.0 or greater functionality and is not supported.



Cannot end macro in a menu.
When you run a Lotus 1-2-3 macro in Microsoft Excel, the macro cannot end with a menu 
activated.    Edit the macro so that it does not end with keystrokes that leave the macro with
a menu activated.
Click the OK button or press ENTER to return to Ready mode.



Too many files to mail.
You attempted to mail too many files as a group. Either send smaller groups of files, or bind 
the files in a workbook, and try again.
See Also

Help
Group Edit Command (Options Menu)
Save Workbook Command (File Menu)



Cannot start the Send Mail service. Please check your Microsoft 
Mail installation.
You attempted to send mail, but a necessary mail resource was missing or damaged. 
Reinstall Microsoft Mail and try again.



Cannot open FM? files directly. Open the corresponding WK? file.
You tried to open a Lotus 1-2-3 FMT or FM3 format file created by the Impress add-in. 
Microsoft Excel uses these files for formatting information, but cannot open them directly. 
Instead, open the WK1 or WK3 file associated with the FMT or FM3 file you    want. The 
corresponding FMT or FM3 file information will be incorporated when the file is opened in 
Microsoft Excel.



Cannot use a workbook reference to documents not in a workbook.
You entered a reference to a workbook document, but the document you specified is not 
part of the specified workbook. 
Regular Microsoft Excel references take the form:

file_name!range_reference
Workbook references take the form:

[workbook_name]file_name!range_reference
The name of the workbook, which is enclosed in square brackets, precedes the regular 
Microsoft Excel reference form only if the document specified by file_name is bound into the
workbook. This reference form cannot be used unless the document to which you refer is a 
bound workbook file. Unbound documents use the regular Microsoft Excel reference form, 
even if they are used in the workbook.
Check the specified document, and try again.
See Also

Help
Save Workbook Command (File Menu)



Reference is not valid. Cannot enter a multiple cell reference for the
Series Title.
The title of the selected series refers to more than one cell. The series title must refer to a 
single cell containing the title text. Enter the correct cell reference.



Reference is not valid. Reference for Categories and Values must be
a row or column.
The reference for the selected category or value axis comprises an incorrect range of cells. 
Category or value references must be to a range of cells in either a single column or a 
single row. References that refer to cells in more than one row and column are not valid. 
Enter a reference that indicates a valid category or value range.



Reference is not valid. Reference must be a simple external 
reference to a worksheet.
The selected reference either refers to a document other than a worksheet, or is a complex 
external reference. A simple reference is an absolute reference to a cell, range, named cell, 
or named range. A complex reference is anything that is not a simple reference. For 
example, =Sheet1!$A$1 is a simple reference, while =Sheet1!$A$1+Sheet2!$A$1 is a 
complex reference.



Reference is not valid. Reference must be to an open worksheet.
You are trying to edit a reference to a worksheet that is not open. When you are editing a 
series, the source worksheet must be open. Open the source worksheet and try again.



Cannot run tutorial. There may be another tutorial active.
The tutorial cannot run for one of the following reasons:

The tutorial may be already running.
Your system may not have enough memory available.

Make sure the tutorial is not running, check the available memory, and try again.



Document is already open. Select it from the list box instead.
You tried to add a document to a workbook using the Open button in the Add To Workbook 
dialog box when the document was already open.    To add the document, select it from the 
Select Documents To Add list box instead.



Cannot enter an array formula into a range of cells which are not all
locked or unlocked.
You tried to enter an array formula into a range of cells in which some of the cells are locked
and others are unlocked.    To enter the array formula in this range of cells, use the Cell 
Protection command on the Format menu to either lock or unlock all of the cells in the 
range.



Cannot read this binary file... 
...If the file was created in a version of Microsoft Excel later than 4.0, use that 
version to save it as a Microsoft Excel 4.0 file. Open file as text?
You tried to open a binary file that was in a format that Microsoft Excel could not read.    This
file could be:

A file from a version of Microsoft Excel that is later than the version you are running.   
In this case, quit this version of Microsoft Excel, run the later version of Microsoft Excel, open
the file, and use the Save As command on the File menu to change the File Type to Excel 4.0.

A file from another program in a format that Microsoft Excel does not read.    Try 
copying the data from the other application and pasting it into Microsoft Excel.

A file, such as a program, that is not intended to be opened in a spreadsheet.    
Try opening another file.



Formula too complex to be assigned to object.
You tried to assign to a worksheet object an expression that cannot be used here. Try using 
a reference or a name. If you need to use a register_id number or a more complicated 
expression, assign it to a name, and then assign the name to the object.



File may contain nondisplayable text and formats from the Far East.
A Microsoft Excel document that was created by a Chinese, Japanese, or Korean version of 
Microsoft Excel has been loaded into a Western version of Microsoft Excel.    Only ASCII 
characters are transferred in a readable form.    The character sets are significantly different 
and have only ASCII characters in common. Kanji, Hiragana, Katakana, Chinese, Hangeul, 
and Hanja characters and number formats using these are not displayed properly in 
Western versions of    Microsoft Excel.
This message can be ignored if the file contains only ASCII text and uses no Far Eastern 
number formats.    To preserve and read the text properly, one must reload the file using the 
proper Far Eastern version of Microsoft Excel that was used to create the file originally. 
Resaving a Far Eastern file once from a Western version will not corrupt the Far Eastern text 
in the file.    But the text may be corrupted by Microsoft Excel's built-in code page 
conversion, if it is subjected to multiple open and save sequences in more than one 
environment (Macintosh, Windows, or OS/2).



Cannot save [filename] because the volume is locked.
You tried to save a file on a disk that is locked, or on a disk for which you do not have write 
privileges.    Try saving the document on a different disk.



Database range not defined.
You tried to perform an operation that requires a defined database range. 
To define a database range

1 On the worksheet, select the range that you want to define as a database.
2 From the Data menu, choose Set Database.

See Also
Help
Set Database Command (Data Menu)
Defining a criteria range
Defining a database
Defining an extract range



Criteria range not defined.
You tried to perform an operation that requires a defined criteria range. 
To define a criteria range

1 On the worksheet, select the range that you want to define as the criteria range.
2 From the Data menu, choose Set Criteria.

See Also
Help
Set Criteria Command (Data Menu)
Defining a criteria range
Defining a database
Defining an extract range



Extract range not defined.
You tried to perform an operation that requires a defined extract range. 
To define a extract range

1 On the worksheet, select the range that you want to define as an extract range.
2 From the Data menu, choose Set Extract.

See Also
Help
Set Extract Command (Data Menu)
Defining a criteria range
Defining a database
Defining an extract range



Cannot revert to a saved WK3 file.    Close the file and then open it.
You have opened a WK3 file, made some changes, and then tried to open the file again.    If 
you want to revert to the previous version of the WK3 file, first close the file without saving 
changes, and then open the file again.



Cannot copy a document when the copy's name would result in a 
document name conflict.
You tried to make a copy of a document that belongs to a workbook when both the source 
and destination workbook are the same.    If you need to create another copy of the 
document in the same workbook, use the Save As command on the File menu to save it 
under a different name. You can then add the newly named document to the workbook.



A document with that name is a supporting document. Workbook 
tables of contents cannot be supporting documents.
You tried to open or save a workbook that is referred to by a formula on a worksheet. You 
cannot open or save a workbook with the specified name because:

An open document contains an external reference to a document with that name.
External references to workbooks are not permitted.
A workbook might have been saved with the same name as an existing worksheet, 

thus overwriting the worksheet.    Any external references to this worksheet are now invalid.
Save the workbook under a different name, or remove the illegal reference.



Save [workbook] and all bound sheets?
You tried to close a modified workbook or save a worksheet that is bound into a workbook 
that has been changed. 
When you have modified the workbook table of contents window, and then you try to save 
one of its bound worksheets, you must save the entire workbook. 
Choose Yes to save the workbook; chose No to continue the requested operation without 
saving or choose Cancel to cancel the operation.



Cannot enter an external reference to a workbook.
You entered a reference to a workbook document, rather than a document that is included 
in a workbook. You cannot refer directly to workbook table-of-contents documents in 
formulas. 
The proper syntax for a workbook reference is

[workbook_name]sheet_name!cell_ref



Cannot include this type of document in a workbook.
You tried to add to a workbook a document that is not allowed, or you tried to load a 
Microsoft Excel 3.0 workspace that contains a document that is not allowed.
Document types that are not allowed in workbooks are: 

Add-in macro sheets
Templates
Other workbooks
A Microsoft Excel toolbar file
Lotus 1-2-3    WK3 worksheets.



This document belongs to more than one open workbook.    Create a 
copy of it to bind in this workbook?
You are trying to bind into a workbook a document that is currently in more than one 
workbook. While unbound documents can be in more than one workbook, bound documents
can only be in one workbook at a time. If you want to make a copy of the document to 
include in the new workbook, choose OK; otherwise, choose Cancel.



Cannot unbind a document that would result in an invalid file name
You tried to unbind a document from a workbook, but doing so would result in an invalid file 
name. Possible reasons for this are:

The document was renamed in the workbook with a name that exceeds the 8-
character plus 3-character MS-DOS filename syntax.

The bound document has the same name as another open document.
The document was transferred from Microsoft Excel for the Macintosh and the 

filename contains a backslash (\).
Rename the bound document with a valid or unique filename and try again.



Need to specify sheet to copy from workbook file.
You tried to perform a consolidate operation, but a reference to a workbook was entered 
incorrectly. The proper syntax for a workbook reference is

[workbook_name]sheet_name!cell_ref
Be sure that you refer to worksheets or macro sheets, and include the workbook name as 
part of the reference. Do not refer to workbook documents directly.



Not a workbook file.
You entered an invalid reference to a workbook file. 
The proper syntax for a workbook reference is:

[workbook_name]sheet_name!cell_ref
Be sure that you entered the name of a valid workbook document, and that you used the 
proper syntax.



Cannot save a document that belongs to a workbook in that format.
You tried to save a document that belongs to a workbook in a file format that is not allowed.
Document types that are not allowed in workbooks are: 

Add-in macro sheets
Templates
Other workbooks



Cell in supporting worksheet contains nonnumeric data.
You created a chart whose category range contains nonnumeric data. You are now trying to 
change a data point on a chart by dragging it in the x-axis direction, but the data point uses
the category argument that contains the nonnumeric data.    You cannot drag points in the 
x-axis direction in this situation. 
Edit the SERIES formula, specifying numeric data for the category names argument, and 
then try to change the data point again.



Useful only in Windows for Pen Computing environment
You clicked the Constrain Numeric tool, but Microsoft Windows is the active environment. 
This tool can be used only with Microsoft Windows for Pen Computing.



Could not find matching data.
Microsoft Excel could not find what you are searching for.
If you used the Find command on the Formula menu, no cell in the selection contains what 
you typed.
If you used the Find command on the Data menu, no more records match the criteria.    This 
means that all records matching the criteria have been found, or that no records match the 
criteria.
If you think there should be a match, check your typing and try again.



Could not find matching data to delete.
Microsoft Excel could not delete what you are searching for; no more records match the 
criteria.    This means that all records matching the criteria have been deleted, or that no 
records match the criteria.
If you think there should be a match, check your typing and try again.



Could not find matching data to replace.
Microsoft Excel could not find what you are searching for; no cell in the selection contains 
what you typed. This means that all records matching the criteria have been found, or that 
no records match the criteria.
If you think there should be a match, check your typing and try again.



Consolidation reference is not valid.
You entered an invalid reference for a consolidation. To enter a valid reference, use the form

sheet_name!cell_ref
Check the form of your references in the Consolidate dialog box, and try again.



Invalid document for consolidation.
You entered an invalid reference for a consolidation. You cannot use chart documents or 
workbook documents in a consolidation.
Check your references in the Consolidate dialog box, and try again.



A document with that name is a supporting document.    Charts 
cannot be supporting documents.
You cannot save a chart with the specified name because:

An open document contains an external reference to a document with that name.
External references to charts are not permitted.
The chart might have been saved with the same name as an existing worksheet, thus

overwriting the worksheet.    Any external references to this worksheet are now invalid. 
Save the chart under a different name.



Overwrite nonblank cells in destination?
You tried to move cells by selecting them and dragging them to a new location, but the 
destination area is not empty. Choosing OK replaces the existing cells with the cells you are 
moving; choosing Cancel cancels the operation.



Cannot access directory.
You are trying to save, open, or link to a document in a directory that currently cannot be 
accessed.    Possible reasons for this include:

The path you specified in a dialog box does not exist.
Check the spelling of the path, and try to access the directory again.

You are trying to save a document to a read-only network directory or disk.
Save the document to a different network directory or disk.

To continue:
OK Closes the message box.
Retry Tries to access the directory again.
Cancel Cancels the operation.



Workbook has no bound sheets.
You tried to change links or enter an external reference formula to a workbook file that has 
no bound documents in it.    Try selecting another file or another workbook that does have 
bound documents in it.



Bound filename is invalid.
You tried to rename a bound document in a workbook, but doing so would result in an 
invalid filename. Possible reasons for this are:

The name exceeds the 31-character limit for bound workbook documents.
The bound document has the same name as another open document.
The filename contains a colon (:).
The filename contains a slash (/).
The filename contains a backslash (\).
The filename is 0 characters in length.
The filename begins with an opening square bracket ( [ ), followed by 0 or more 

characters and a closing square bracket ( ] ).
Rename the bound document with a valid filename and try again.



Delete the [name] toolbar?
You chose the Delete button in the Toolbars dialog box with the name of a custom toolbar 
selected in the Show Toolbars list.

OK Permanently deletes the indicated custom toolbar.
Cancel Cancels the operation.



Can't find that sheet in workbook file.
You tried to open a bound workbook document using the Links command on the File menu, 
but the specified document does not exist in the workbook. Check to make sure that you're 
using the correct workbook and document names.



Destination reference is not valid.
The reference you have entered in the Destination box of the dialog box for the Parse 
command is not valid.    The Parse command cannot parse data into a nonadjacent selection 
or into cells on another worksheet.    Enter a reference to a single cell or to a rectangular 
range of cells and try again.
See Also

Help
Parse Command (Data Menu)



Current printer is either missing or bad. Please select a new printer.
The printer you specified to print your document cannot be found. Make sure the printer is 
properly connected and try again, or use the Control Menu to select a different printer using
the Printers Control Panel.
See Also

Help
Control Menu



There are no printers installed. Please use the Printers Control 
Panel to install a printer.
There are no printers currently installed. Use the application Control Menu to select a printer
using the Printers Control Panel.
See Also

Help
Control Menu



The header or footer cannot be longer than 255 characters.    Please
delete some text, or make the formatting less complex.
The combination of text and formatting you entered in the    Header or Footer dialog box is 
longer than 255 characters.    If you have entered less than 255 characters, but this dialog 
box appears, it is probably due to the formatting.    For example, changing the font to MS 
Sans Serif takes sixteen characters, even though no new characters actually appear in the 
dialog box.
Either delete some text, simplify the formatting, or both to achieve a length of fewer than 
255 characters.



[Filename] was created in a previous version of Microsoft Excel.    Do
you want to update it to Microsoft Excel 4.0 format?
You tried to save a file from a previous version of Microsoft Excel. To replace the existing file 
format with the Microsoft Excel 4.0 format, choose the Yes button. To retain the existing file 
format, choose the No button.



Cannot rename a document to the same name as another 
document.
You tried to change the name of a document in a workbook to a name that is already being 
used by another workbook document. Specify a unique name for the document and try 
again.



Cannot run tutorial with Microsoft Windows for Pen Computing
You chose either the Introducing Microsoft Excel or the Learning Microsoft Excel command 
from the Help menu.    These tutorials do not run under Microsoft Windows for Pen 
Computing.    To view the tutorials, you must run Microsoft Excel on a machine with standard
Microsoft Windows.



File is not a valid wave file.
You specified a file that does not contain sound data that Microsoft Excel accepts.    Try 
specifying another file instead.    Typically, sound files used with Microsoft Windows have 
a .wav file extension.



Recording buffer is full.
You tried recording a sound that was longer than two minutes, which is the maximum length
that Microsoft Excel allows.    You can accept the first two minutes of recorded sound, or you 
can record a shorter sound.    To monitor the length of a recording, watch the recording 
status bar.



Cannot load wave file.
Microsoft Excel encountered an error while opening the specified sound file.    Your file may 
be corrupted, or it may be in use by another application.



Cannot open waveform output device.
Microsoft Excel could not play the requested sound because the output device was 
unavailable.    Make sure that no other applications you are running are currently trying to 
play sounds.    Then try again.



Cannot open waveform input device.
Microsoft Excel could not record any sounds because the input device was unavailable.    
Make sure that no other applications you are running are currently trying to record sounds.   
Then try again.



Cannot play Macintosh sounds under Windows.
While using Microsoft Excel for Windows, you tried to play a sound that was recorded using 
Microsoft Excel for Macintosh.    Microsoft Excel for Windows can only play sounds that were 
recorded using Windows applications.    Try playing another sound, or play the sound using 
Microsoft Excel for Macintosh.



Select entire rows and/or columns before choosing Options Set 
Print Titles.
The area named Print_Title must consist of entire rows that are adjacent, entire columns 
that are adjacent, or a combination of entire rows and columns that are adjacent.    Partial 
rows and/or columns are not accepted.
Define the print titles again using the Set Print Titles command from the Options menu.



File error: some number formats may have been lost.
The Microsoft Excel document you are loading contains some number format errors.    These 
number formats have been changed to General.    No data has been lost.



The word [] is not in the dictionary.    Change anyway?
The word that you typed in the Change To box is not in a dictionary.

Yes Changes the word and continues the spelling check.
No Continues the spelling check without replacing the word.



Using the Pen with Microsoft Excel
To use a pen with Microsoft Excel, you must be running Microsoft Windows for Pen 
Computing.    This topic contains information on some specific ways you can use the pen 
with Microsoft Excel.    For basic information on using the pen, see Microsoft Windows for Pen
Computing Help.
If you are running Microsoft Windows for Pen Computing, the Microsoft Excel formula bar will
be larger than normal to make entering text and numbers with the pen easier.
To display a shortcut menu

Press the Barrel button and tap the item for which you want to see a shortcut menu.
To copy objects or cells

Press the Barrel button; then tap and drag the object or the border of the selection.
Without the Barrel button, this moves the objects or cells.

To copy data to a range of adjacent cells
Press the Barrel button; then tap and drag the fill handle.

Without the Barrel button, this extends a series of numbers or dates.
See Also

Help
Constrain Numeric Tool
Copying data
Copying to a range of adjacent cells
Creating a trend series
Extending a series of numbers or dates
Microsoft Excel Function Reference
CONSTRAIN.NUMERIC



To assign a macro to a graphic object
1 Open the macro sheet containing the macro you want to assign.    Skip this step if you 

are using a macro from the global macro sheet.
2 Select the graphic object.

To select a graphic object with a macro assigned to it, hold down the CTRL key while 
clicking the object.    This selects the object without running the macro.

3 From the Macro menu or the shortcut menu, choose Assign To Object.
4 In the Assign Macro box, select the macro you want to assign, or type the macro name 

(name of the macro sheet, exclamation point, macro name) in the Reference box; for 
example, Macro1!Record1.

5 Choose the OK button.
The mouse pointer changes to a hand when it is over a graphic object with a macro 
assigned to it.    The hand indicates that the macro will run when you click the object.

See Also
Help

Selection Tool
Assigning or recording a macro to a tool
Assign To Object Command (Macro Menu)
Assign To Tool Command (Macro Menu)
Toolbars Command (Options Menu)
User's Guide (Book 2)
Chapter 6, "Automating Tasks with Command Macros"



To add or remove an add-in macro from the working set
To add an add-in macro to the working set

1 From the Options menu, choose Add-Ins.
The Add-in Manager displays a dialog box listing all the add-in macros in the working 
set.

2 Choose the Add button.
3 In the Files box, select the add-in macro you want to add.
4 Choose the OK button.
5 Repeat steps 2 through 4 to add another add-in macro.
6 Choose the Close button to save your changes and close the dialog box.
The add-in macros you add to the working set are opened every time you start Microsoft 
Excel.

To remove an add-in macro from the working set
1 From the Options menu, choose Add-Ins.

The Add-in Manager displays a dialog box listing all the add-in macros in the working 
set.

2 In the Add-ins Installed box, select the add-in macro you want to remove.
3 Choose the Remove button.
4 Choose the OK button.
5 Repeat steps 2 through 4 to remove another add-in macro.
6 Choose the Close button to save your changes and close the dialog box.

See Also
Help
Add-Ins Command (Options Menu)
Add-In Macros
Macro Library Overview
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



To add a text box or an arrow to a worksheet
To add a text box to a worksheet
Before you do this procedure, you must have the Text Box tool on the Utility toolbar 
available.    Use the Toolbars command on the Options menu to display toolbars.

1 Click the Text Box tool.
The mouse pointer becomes a cross hair.

2 Position the cross hair where you want one corner of the text box.
3 Drag until the box is the size and shape you want.
4 Type the text you want in the box.

The text will wrap inside the box. If you want to start a new line, press ENTER.
To draw an arrow from a text box to the cell or range of cells it describes
Before you do this procedure, you must have the Arrow tool on the Drawing toolbar 
displayed.    Use the Toolbars command on the Options menu to display toolbars.

1 Click the Arrow tool.
The mouse pointer becomes a cross hair when the Arrow tool is selected.

2 Position the cross hair where you want one end of your arrow.
3 Drag to where you want the other end of your arrow.

You can change the style, color, and weight of the arrow shaft and the arrowhead style, 
width, and length with the Patterns command on the Format menu.
See Also

Help
Arrow Tool
Text Box Tool

Displaying and hiding a toolbar
Patterns Command (Format Menu)
Toolbars Command (Options Menu)



To add borders
1 Select the cells you want to format.
2 From the Format menu or shortcut menu, choose the Border command.

Shortcuts: Border tools
3 Select the border options you want and then choose the OK button.

See Also
Help

Outline Border Tool
Bottom Border Tool
Left Border Tool
Right Border Tool
Top Border Tool
Bottom Double Border Tool

Adding and deleting a tool from a toolbar
Border Command (Format Menu)



To add shading to cells
1 Select the cells you want to format.
2 From the Format menu or the shortcut menu, choose Patterns.

Shortcuts: Dark Shading tool
Light Shading tool (Formatting toolbar)

3 If you chose the Patterns command, select the pattern and colors you want.
If you do not want a pattern, select the None option.

4 Choose the OK button.
See Also

Help
Dark Shading Tool
Light Shading Tool

Adding and deleting a tool from a toolbar
Displaying and hiding a toolbar
Patterns Command (Format Menu)
Toolbars Command (Options Menu)



To apply a style
To apply a style using the menu

1 Select the cells you want to format.
2 From the Format menu, choose Style.
3 Select or type the name of the style you want.
4 Choose the OK button.

To apply a style using the Style box
1 Select the cells you want to format.
2 In the Style box, select or type the name of the style.

To apply a style using tools
To do this procedure, you must have the Formatting toolbar displayed.    Use the Toolbars 
command on the Options menu to display toolbars.

1 Select the cells you want to format.
2 Click the Comma Style, Currency Style, or Percent Style tool, to apply the currently 

defined style.
See Also

Help
Comma Style Tool
Currency Style Tool
Percent Style Tool
Style Box

Creating or deleting a style
Formatting Toolbar
Style Command (Format Menu)
Toolbars Command (Options Menu)



To assign an outline level to a row or column
1 Select the entire row or column you want to assign.

If you don't select an entire row or column, Microsoft Excel displays a dialog box asking 
whether you want to assign a level to rows or columns.

2 If the selection is not currently part of the outline, press ALT+SHIFT+RIGHT ARROW to 
demote it to detail.

3 To promote the selection one level, press ALT+SHIFT+LEFT ARROW.
4 To demote the selection one level, press ALT+SHIFT+RIGHT ARROW.

Shortcuts: Promote tool (Utility toolbar)
Demote tool (Utility toolbar)

See Also
Help

            Demote Tool  
            Promote Tool  
            Show Outline Symbols Tool  

Clearing an outline from a worksheet
Collapsing an outline level
Creating an outline from a existing worksheet
Displaying an outline level
Displaying or hiding outline symbols
Expanding an outline level
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



To adjust row height
Microsoft Excel worksheets are initially set to the Standard row height, which changes 
automatically to accommodate the largest font in each row.

1 Select the row or rows you want to change by clicking the row heading.    If you are 
adjusting row height from the Format menu, you only need to select one cell in the row.
You can add adjacent or nonadjacent rows to the selection by pressing CTRL and clicking
the row heading.

2 To adjust the row height, use one of the following procedures:
Drag the line below the row heading to adjust row height.    If more than one row is 
selected, dragging the row heading line for one row changes all the selected rows.
To quickly adjust the row height to accommodate the largest font in the row, or to 
adjust row height for cells containing wrapped text, double-click the line below the row 
heading.
From the Format menu or the row shortcut menu, choose Row Height and type a 
number in the Row Height box.    Selecting the Standard Height check box changes the 
row height automatically to accommodate the largest font.

See Also
Help
Row Height Command (Format Menu for Worksheets)



To align text and numbers within cells
1 Select the cells you want to format.
2 From the Format menu or the shortcut menu, choose Alignment. 
3 Select the alignment options you want.

If you have a long cell entry that you want displayed on multiple lines in a single cell, 
select the Wrap Text check box.    Microsoft Excel automatically increases the row 
height to accommodate all of the text in your cell entry.

4 Choose the OK button.
You can also align cell contents by clicking one of the alignment tools on the toolbar.

See Also
Help

Center Across Columns Tool
Center Align Tool
Justify Align Tool
Left Align Tool
Right Align Tool

Alignment Command (Format Menu)
Formatting Toolbar
Standard Toolbar
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



To align text box or button text
1 Select the text box or button.

To select a graphic object with a macro assigned to it, hold down CTRL while clicking the
object.

2 From the Format menu or the shortcut menu, choose Text.
3 Select the text alignment options you want.

The Automatic Size check box sizes the border to fit exactly around the text.    If the 
text is changed, the border will adjust automatically.

4 Choose the OK button to apply your changes.
See Also

Help
Rotate Text Down Tool
Rotate Text Up Tool
Vertical Text Tool

Text Command (Format Menu for Worksheets)



To add data and formats to a chart from a worksheet or another 
chart
To add data series to a chart with the ChartWizard

1 Switch to the chart window or select the embedded chart.
2 Click the ChartWizard tool.
3 Select the data you want to include in the chart.    Include both the data now in the 

chart and the data you want to add.
4 Choose the button labeled >>.

To add data series to a chart by copying and pasting
1 Open the chart and the worksheet containing the data you want to add.
2 Select the worksheet data.
3 From the Edit menu or the shortcut menu, choose Copy.
4 Switch to the chart window.

If the chart is embedded in a worksheet, double-click the chart to display it in a chart 
window.

5 If you want Microsoft Excel to control plotting, choose Paste from the Edit menu.
If you want to control plotting, choose Paste Special from the Edit menu, select the 
options you want, and then choose the OK button.

To add data series and formats to a chart from another chart
1 Open both charts.
2 Switch to the chart that contains the data series you want to add.

If the chart is embedded in a worksheet, double-click the chart to display it in a chart 
window.

3 Choose Select Chart from the Chart menu.
4 From the Edit menu or the shortcut menu, choose Copy.
5 Switch to the chart that you want to change.
6 If you want to add all data series and their formats, choose Paste from the Edit menu.

If you want to selectively add data series or their formats, choose Paste Special from 
the Edit menu, select the options you want, and then choose the OK button.

See Also
Help

ChartWizard Tool
Adding or editing series
Copy Command (Edit Menu)
Paste Command (Edit Menu)
Paste Special Command (Edit Menu)
Select Chart Command (Chart Menu)
User's Guide (Book 1)
Chapter 13, "Editing a Chart"



To add or delete a legend
Once you add a legend, the Add Legend command on the Chart menu changes to Delete 
Legend.
To add a legend

1 Switch to the chart window if it is not already active.
If the chart is embedded in a worksheet, double-click the chart to display it in a chart 
window.

2 From the Chart menu, choose Add Legend.
Shortcut: Legend tool (Chart toolbar)

Microsoft Excel inserts a legend at the right of the plot area and resizes the plot area to 
accommodate the legend.    Microsoft Excel automatically selects the legend so you can 
format it.

To delete a legend
1 Switch to the chart window containing the legend, if it is not already active.

If the chart is embedded in a worksheet, double-click the chart to display it in a chart 
window.

2 From the Chart menu, choose Delete Legend.    
Shortcut: Legend tool (Chart toolbar)

You can also select the legend and choose Clear from the Edit menu or the shortcut 
menu.

See Also
Help

Legend Tool
Add Legend and Delete Legend Commands (Chart Menu)
Clear Command (Edit Menu)
Moving a legend
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



To add or delete a chart arrow
To add a chart arrow

1 Switch to the chart window.
If the chart is embedded in a worksheet, double-click the chart to display it in a chart 
window.

2 From the Chart menu, choose Add Arrow.
Shortcut:    Arrow tool (Chart toolbar)

If the Add Arrow command is not on the Chart menu, but the Delete Arrow command is, 
this means an arrow is selected.    To add another arrow, select any item in the chart other
than a chart arrow and then choose Add Arrow from the Chart menu.

To delete a chart arrow
1 Select the arrow you want to delete.
2 From the Chart menu, choose Delete Arrow.
You can also select the arrow and choose Clear from the Edit menu or the shortcut menu.

See Also
Help

Arrow Tool
Add Arrow and Delete Arrow Commands (Chart Menu)
Clear Command (Edit Menu)
Moving or sizing a chart arrow
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



To add or delete a chart title, an axis title, or a data marker label
To add a chart title or axis title

1 Switch to the chart window.
If the chart is embedded in a worksheet, double-click the chart to display it in a chart 
window.

2 From the Chart menu, or the axis, chart, or plot area shortcut menu, choose Attach 
Text.

3 Select the item to which you want to attach text.
4 Choose the OK button.

Microsoft Excel adds default text in the appropriate chart location and surrounds the 
text with white selection squares.

5 Type the text you want.    The text appears in the formula bar.    You can edit the text in 
the formula bar, just as you would for a worksheet cell.
To insert a line break in the text, press CTRL+ENTER.

6 Click the enter box or press ENTER.

To add a data marker label
1 Switch to the chart window.
2 Select the data marker by holding down CTRL and clicking the marker.
3 From the Chart menu or the shortcut menu, choose Attach Text.

Microsoft Excel automatically selects the Series And Data Point option button and 
displays the numbers for the selected data marker in the Series Number and Point 
Number boxes.    For an area chart, enter only the data series number to label the 
entire series.

4 Choose the OK button.
Microsoft Excel adds default text in the appropriate chart location and surrounds the 
text with white selection squares.

5 Type the text you want.    The text appears in the formula bar.    You can edit the text in 
the formula bar, just as you would for a worksheet cell.
To insert a line break in the text, press CTRL+ENTER.

6 Click the enter box or press ENTER.

To delete chart text
1 Select the text.
2 From the Edit menu or the shortcut menu, choose Clear.

Shortcut: DEL or DELETE

See Also
Help
Attach Text Command (Chart Menu)
Clear Command (Edit Menu)
Adding or deleting unattached chart text
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



To add or delete unattached chart text
To add unattached chart text

1 With no other text selected, type the text you want.    The text appears in the formula 
bar.    You can edit the text in the formula bar, just as you would for a worksheet cell.
Shortcut: Text Box tool (Chart toolbar)
To insert a line break in the text, press CTRL+ENTER.

2 Click the enter box or press ENTER.
Microsoft Excel places the text on the chart and surrounds the text with black selection 
handles indicating that you can move and size the text.

To delete chart text
1 Select the text.
2 From the Edit menu or the shortcut menu, choose Clear.

Shortcut: DEL or DELETE
See Also

Help
Text Box Tool

Clear Command (Edit Menu)
Formatting chart text alignment and orientation
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



To add or delete gridlines
1 Switch to the chart window.

If the chart is embedded in a worksheet, double-click the chart to display it in a chart 
window.

2 From the Chart menu, or the axis or plot area shortcut menu, choose Gridlines.
3 For each axis, select the check boxes for the gridlines you want displayed.    Clear the 

check boxes for the gridlines you don't want displayed.
Shortcut: Horizontal Gridlines tool (Chart toolbar)

Vertical Gridlines tool
4 Choose the OK button.
You can also delete gridlines by selecting a gridline and choosing Clear from the Edit 
menu or the shortcut menu.    If you select a major gridline, you clear all major gridlines 
for that axis.    If you select a minor gridline, you clear all minor gridlines for that axis.

See Also
Help

Horizontal Gridlines Tool
Vertical Gridlines Tool

Adding and deleting a tool from a toolbar
Clear Command (Edit Menu for Charts)
Formatting gridlines
Gridlines Command (Chart Menu)
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



To add or edit series
To add or edit series with the ChartWizard tool

1 Switch to or select the chart you want to edit.
You can select an embedded chart in a worksheet, double-click the embedded chart to 
open it in its own window, or open an existing chart document.    Make sure the 
worksheet that contains the source data for the chart is open.

2 Click the ChartWizard tool.
Microsoft Excel selects the data on the worksheet that is plotted in the chart and 
displays the ChartWizard.

3 Follow the instructions on the screen.
The chart is updated to reflect the new data.

To add or edit series or data points with the Edit Series command
1 Switch to the chart to which you want to add the series, or edit the existing series.

If you want to start with a new blank chart, select a blank cell on the worksheet, choose
New from the File menu, select Chart from the list, and choose the OK button.

2 If you want to edit an existing data series, select the series.
3 From the Chart menu or the chart or series shortcut menu, choose Edit Series.
4 If you are creating a new data series, select New Series in the Series box.

If you are editing an existing data series, the name of the series is selected in the 
Series box.    Microsoft Excel lists unnamed series as "Series n," where n is the same as 
the series' plot order number.

5 Type the name of the data series in the Name box, select the cell on the worksheet that
contains the name you want used for the data series, or type an external absolute 
reference to the cell containing the data series name in the Name box.

6 In the X Labels box, type an external absolute reference for the cells containing the 
labels for the x-axis tick labels, or select the labels on the worksheet.
If the chart is an xy (scatter) chart, this option appears as the X Values box.    Type an 
external absolute reference for the x-coordinates, or select the x-coordinates on the 
worksheet.

7 In the Y Values box, type an external absolute reference for the values of the data 
series, or select the values on the worksheet.
If the chart is a two-dimensional xy (scatter) chart, type the reference for the y-
coordinates of the series, or select the y-coordinates on the worksheet.
This option is not available for 3-D charts.    Instead, the text "Series Name" is 
displayed.

8 If the chart is a 3-D chart, type an external absolute reference for the data series 
values in the Z Values box, or select the values on the worksheet.

9 In the Plot Order box, type the order in which you want the series to be plotted.
You can plot up to 255 series.

10 To complete the series formula and close the dialog box, choose the OK button.
To complete the series formula and keep the dialog box open so you can add or edit 
another series, choose the Define button.

If your worksheet contains hidden rows or columns that you don't want included in the data 
series, you can select only the data you want using the procedure for copying visible cells.
You can also add and edit series by typing and editing series formulas in the formula bar.
See Also

Help



ChartWizard Tool
Copying visible cells
Edit Series Command (Chart Menu)
User's Guide (Book 1)
Chapter 13, "Editing a Chart"



To adjust a data value by dragging a data marker
You can drag the data markers on two-dimensional line charts, bar charts, column charts 
and xy (scatter) charts.    When you drag a data marker, the data value on the worksheet 
changes to match the new value on the chart.

1 Switch to the chart window.
If the chart is embedded in a worksheet, double-click the chart to display it in a chart 
window.

2 Hold down CTRL and click the data point on the chart.
3 Drag the black selection square in the direction you want to adjust the value.

While you drag, a line appears on the y-axis to show the adjusted value of the data 
marker and the changing value is displayed at the left of the formula bar.    You can 
drag only within the scale on the value axis.
If the chart is an xy (scatter) chart, lines appear on both axes.    You can drag with the 
scales on both axes.

If the value of a data point you move is generated by a formula, Microsoft Excel switches 
to the worksheet (which must be open) and displays the Goal Seek dialog box.    Use the 
dialog box to have Microsoft Excel change the variables in the formula until it returns the 
value designated by the data point's new position.

See Also
Help
Goal Seek Command (Formula Menu)
User's Guide (Book 1)
Chapter 13, "Editing a Chart"
User's Guide (Book 2)
Chapter 2, "Performing What-if Analysis on a Worksheet Model"



To adjust the 3-D chart view
To adjust the 3-D chart view by dragging

1 Switch to the chart window.
If the chart is embedded in a worksheet, double-click the chart to display it in a chart 
window.

2 Click the intersection of any two axes to select the corners of the chart.
Black selection handles will appear at all the corners.

3 Drag any of the corners to adjust the elevation and rotation of the chart.
To see an outline of the data plotted in the chart while you drag, hold down the CTRL 
key as you drag.

This procedure adjusts only the elevation and rotation of the chart.    To adjust other 
aspects of the 3-D view, use the following procedure.

To adjust the 3-D chart view with the 3-D View command
1 Switch to the chart window.

If the chart is embedded in a worksheet, double-click the chart to display it in a chart 
window.

2 From the Format menu, choose 3-D View.
3 Type the values you want in the Elevation and Rotation boxes.    You can also click the 

arrow buttons to increase or decrease these values.
4 To show axes at right angles to each other, select the Right Angle Axes check box.

To show the axes in perspective, clear the Right Angle Axes check box.
5 If you selected the Right Angle Axes check box, select the Auto Scaling check box to fill

the chart window with the chart.    However, you must clear the Auto Scaling check box 
if you want to specify a height in the Height box.
If you cleared the Right Angle Axes check box, enter a value from 0 to 100 in the 
Perspective box.    The perspective value specifies the ratio of the width of the front of 
the chart to the back of the chart:    the higher the number, the greater the perspective.

6 In the Height box, type the height of the chart.
The height is measured as a percentage of the length of the x-axis.
The Height box does not appear if both the Auto Scaling and the Right Angle Axes 
check boxes are selected.    If you want to specify the height of a chart with Right Angle 
Axes selected, clear the Auto Scaling check box.

7 To apply your changes and close the dialog box, choose the OK button.
To apply your changes to the chart but leave the dialog box open so you can continue 
to adjust the chart, choose the Apply button.
If you close the dialog box after applying the changes, the changes will replace the 
formats in the chart.
To reset the view options to the defaults, choose the Default button.

If you change the chart type using a Gallery menu command, the 3-D view formats are not 
reset to their original values.    You can retrieve the original settings by choosing the Default 
button in the 3-D View dialog box.
Note    The Perspective option is not available for 3-D bar charts; 3-D bar charts always 
have the Right Angle Axes check box selected.
See Also

Help
Gallery Menu



3-D View Command (Format Menu)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



To add or remove a document from a workbook
To add a new document to a workbook

1 Switch to the Workbook Contents window of the workbook to which you want to add 
the document.

2 Choose the Add button.
Shortcut: ALT+SHIFT+A

3 In the Add to Workbook dialog box, choose the New button.
4 Select the type of document you want to create.

Microsoft Excel creates a document and adds it to the workbook.    Documents are 
initially added as bound to the workbook.    
To change a document to an unbound document, click the icon to the right of the 
document name in the Workbook Contents window.

To add an unopened document to a workbook
1 Switch to the Workbook Contents window.
2 Choose the Add button.

Shortcut: ALT+SHIFT+A
3 In the Add to Workbook dialog box, choose the Open button.

Microsoft Excel displays a list of all documents in the current directory.
4 Select the document you want to add to the workbook.

Microsoft Excel adds the document to the workbook.    Documents are initially added as 
bound to the workbook.
To change a document to an unbound document, click the icon to the right of the 
document name in the Workbook Contents window.

To add an opened document to a workbook
1 Switch to the Workbook Contents window.
2 Choose the Add button.

Shortcut: ALT+SHIFT+A
Microsoft Excel displays a list of all open, unbound documents.

3 Select the document you want to add to the workbook.
4 Choose the OK button.

Microsoft Excel adds the document to the workbook.    Documents are initially added as 
bound to the workbook.
To change a document to an unbound document, click the icon to the right of the 
document name in the Workbook Contents window.

To remove a document from a workbook by dragging
1 In the Workbook Contents window, select the document you want to remove.
2 Drag the document out of the workbook window and release the mouse button.

The document is removed from the workbook.
To remove a document from a workbook

1 In the Workbook Contents window, select the document you want to remove.
To select multiple documents, press CTRL while clicking the document names.

2 Choose the Remove button.
Shortcut: ALT+SHIFT+R
The document is removed from the workbook.



See Also
Help
Workbooks
Creating a workbook
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



To bind or unbind workbook documents
Workbook documents can be either bound or unbound.    You should bind your documents to
a workbook when:

You want to keep related documents in one file.
You want others to have access to a group of documents.    For example, you may 

want to distribute a template with a worksheet.
You want to give your documents extended names.

You should keep a workbook document unbound when:
You want to include a document in two or more workbooks.
You want some people to use the document as a single document.    For example, you

want sales sheets to be completed by salespersons, but viewed in a workbook by managers.
To bind a document in a workbook
1 In the Workbook Contents window, select the document you want to bind to the 

workbook.
2 Choose the Options button.

Shortcut: ALT+SHIFT+O
3 Select the Workbook File option button.
4 Choose the OK button.

Shortcut: Click the icon to the right to change the document status from unbound to
bound.

To unbind a document in a workbook
1 In the Workbook Contents window, select the document you want to unbind in the 

workbook.
2 Choose the Options button.

Shortcut: ALT+SHIFT+O
3 Select the Separate File option button.
4 Choose the OK button.

Shortcut: Click the icon to the right to change the document status from bound to 
unbound.

See Also
Help
Creating a workbook
Giving a bound workbook document an extended name
Workbooks
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



To add or remove open documents from a group
1 From the Options menu, choose Group Edit.

The Group Edit dialog box lists all open, unhidden worksheets and macro sheets.    The 
sheets that are part of the current group are selected.

2 To add or delete a sheet, hold down CTRL and click the sheet name.
--or--
Hold down CTRL while using the arrow keys to select the sheet name, and then press 
CTRL+SPACEBAR.
Only sheets that remain selected will be included in the group.

3 Choose the OK button.
See Also

Help
Editing worksheets as a group
Starting or ending a group editing session
User's Guide (Book 1)
Chapter 11, "Working with Multiple Microsoft Excel Documents"



To create or delete a button on a worksheet or macro sheet
Before you do this procedure, you must have the Utility toolbar displayed.    Use the Toolbars
command on the Options menu to display toolbars.
To create a button

1 Click the Button tool on the toolbar.
The mouse pointer changes to a cross hair.

2 Drag the mouse to create a button on the worksheet or macro sheet.
Microsoft Excel displays the Assign To Object dialog box.

3 If you don't want to assign a macro to the button, choose the Cancel button to close 
the dialog box.
If you want to assign a macro to the new button, select a macro from the Assign Macro 
box or type a reference in the Reference box.    Choose the OK button.
To record your subsequent actions as a macro assigned to the new button, choose the 
Record button.    To stop recording, click the Stop Recording Macro tool, which pops up 
when you begin recording, or choose Stop Recorder from the Macro menu.

To assign a macro to a button
1 Select the button.

If a macro is already assigned to the button, hold down CTRL while clicking the button.    
This prevents the macro from running.
Shortcut: Selection tool (Drawing toolbar)

2 From the Macro menu, choose Assign To Object or from the shortcut menu, choose 
Assign Macro to Button.

3 If you want to assign a macro to the button, select a macro from the Assign Macro box 
or type a reference in the Reference box.    Choose the OK button.
If you want to record your subsequent actions as a macro assigned to the button, 
choose the Record button.    To stop recording, click the Stop Recording Macro tool, 
which appears when you begin recording, or choose Stop Recorder from the Macro 
menu.
The mouse pointer changes to a hand when it is over a button with a macro assigned 
to it.    The hand indicates that the macro will run when you click the button.
You can also assign a macro to graphic objects, including objects on charts, and toolbar
tools.

To delete a button on a worksheet or macro sheet
1 Select the button you want to delete.

If a macro is already assigned to the button, hold down CTRL while clicking the button.    
This prevents the macro from running.
Shortcut: Selection tool (Drawing toolbar)

2 Press DELETE or choose Clear from the Edit menu.
See Also

Help

Button Tool
Selection Tool
Stop Recording Macro Tool

Assign To Object (Macro Menu)



Assign To Tool (Macro Menu)
Stop Recording Toolbar
Drawing Toolbar
Toolbars Command (Options Menu)



To create a new macro sheet
1 From the File menu, choose New.

Shortcuts: New Macro Sheet tool (Macro toolbar)
CTRL+F11
ALT+CTRL+F1

2 Select Macro Sheet.
3 Choose the OK button.

See Also
Help

New Macro Sheet Tool
Macro Toolbar
New Command (File Menu)
Toolbars Command (Options Menu)



To cancel the database, criteria, or extract range 
1 From the Formula menu, choose Define Name.
2 In the Names In Sheet box, select Database, Criteria, or Extract.

--or--
In the Name box, type the name of the range you want to cancel.

3 Choose the Delete button.
4 Choose the OK button. 

See Also
User's Guide (Book 1)
Chapter 10, "Analyzing and Reporting Database Information"



To consolidate data
1 Select the destination area you want to contain the consolidated data.
2 From the Data menu, choose Consolidate.
3 In the Reference box, enter a reference to the source area you want to consolidate.    

You can also select the source area with the mouse on open worksheets to enter the 
reference.    Alternatively, you can use the Window menu to activate any open 
worksheets you need.    If you need to move the dialog box out of the way, click and 
drag the title bar. 
You can also include references to any unopened worksheets using the Browse button. 
Choosing Browse will display a dialog box from which you can locate the file you want. 
Its full path and filename will then be entered into the Reference box. You must then 
add a cell or range reference, or a name, to complete the consolidation reference.

4 Choose the Add button.
5 Repeat steps 3 and 4 for all the source areas you want to consolidate.
6 Select the function you want to use to consolidate the source areas.

The SUM function is the default.
7 Under Use Labels In, select one or both check boxes if you want to consolidate by 

categories using labels.    Microsoft Excel consolidates by position using references for 
the cleared check boxes.

8 Select the Create Links To Source Data check box if you want to create links to the 
source data used in the consolidation.    
If you create links to source data, the Undo command on the Edit menu will not be 
available. 

9 Choose the OK button.
To undo consolidation

From the Edit menu, choose Undo immediately after you consolidate data.
This option is not available if you have selected the Create Links To Source Data check 
box.

To remove a source area from a consolidation
1 From the Data menu, choose Consolidate.
2 In the All References box, select the source area reference you want to remove.
3 Choose the Delete button.
4 Choose the OK button.

To create links to source data used in consolidation
1 Set up your source and destination areas for consolidation using labels or by position.
2 From the Data menu, choose Consolidate.
3 Select the Create Links To Source Data check box.
4 Choose the OK button.

Microsoft Excel consolidates data from the source areas and adds outline rows and 
columns as necessary to accommodate the linking formulas for the source data for 
each position or category.    Be sure the rows and columns added to your destination 
areas will not disrupt other parts of your worksheet.

See Also
Help
Consolidate Command (Data Menu)



Displaying outline levels
User's Guide (Book 1)
Chapter 11, "Working with Data from Multiple Documents"



To create a trend series
The Series command on the Data menu includes a Trend option. With it you can create a 
linear or exponential growth trend based on existing selected values.    A trend created using
the Series command will replace the values in your original selection.
To create a trend series using the Series command

1 Select the cell range containing the values on which you want to base your trend.
2 From the Data menu, choose Series.
3 Under Series In, select the Rows option button or the Columns option button, 

depending on your selection.
4 Under Type, select the Linear option button to produce a linear growth trend, or select 

the Growth option button to create an exponential growth trend.
5 Select the Trend check box.
6 Choose the OK button.

With the AutoFill feature, you can also create a linear trend by using the fill handle.    The fill 
handle is the small black square at the lower right of the selection.    A trend created using 
the AutoFill feature does not alter the values in your original selection. AutoFill creates a 
trend if you select three or more cells containing values that do not fall in a straight line.
To create a trend series using the AutoFill feature

1 Select three or more cells containing your starting values.
2 Drag the fill handle in the direction you want to fill. 

See Also
Help
Extending a series of numbers or dates
Series Command (Data Menu)
Turning AutoFill on or off
Using AutoFill
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



To change screen colors
1 From the Microsoft Excel Control menu, choose Run.
2 Select the Control Panel option button.
3 Choose the OK button.
4 With the mouse, double-click the Color icon, or choose Color from the Control Panel 

Settings menu.
5 In the Color Schemes list, select the color combination you want.
6 If you want to change a color in the color scheme you selected, choose Color Palette.

In the Screen Element list, select the screen element whose color you want to change, 
and choose one of the colors from the Basic Colors selection.

7 If you want to create a custom color, choose the Define Custom Colors button.
Use the Custom Color Selector to find the color you want.    Choose the Add Color 
button to add that color to the Custom Colors palette.    Repeat to add additional colors 
to the Custom Colors palette.    Choose the Close button when you are finished adding 
colors.

8 Choose the OK button to apply the changes.
9 From the Control menu, choose Close to close the Control Panel.



To change the decimal separator
1 From the Microsoft Excel Control menu, choose Run.
2 Select the Control Panel option button.
3 Choose the OK button.
4 Double-click the International icon or choose International from the Control Panel 

Settings menu.
5 In the Number Format box, choose the Change button.
6 In the Decimal Separator box, type the decimal separator you want.
7 Choose the OK button.
8 Choose the OK button to close the International dialog box.
9 From the Control menu, choose Close to close the Control Panel.



To clear data from cells
To clear data from cells by dragging

1 Select the cells you want to clear.
2 To clear only data, drag the fill handle (black square in lower-right corner of selection) 

up until the entire selection is gray, and then release the mouse button.
To clear both data and formats, press CTRL and drag the fill handle (black square in 
lower-right corner of selection) up until the entire selection is gray, and then release 
the mouse button.

To clear data from cells using the Clear command
1 Select the cells you want to clear.
2 From the Edit menu or the shortcut menu, choose Clear.

Shortcut: Clear Formats tool
Clear Formulas tool
DEL

3 Select the option for the cell attributes you want to clear.
4 Choose the OK button.

See Also
Help

Clear Formats Tool
Clear Formulas Tool

Adding and deleting a tool from a toolbar
Clear Command (Edit Menu)
Displaying and hiding a toolbar
Toolbars Command (Options Menu)



To close panes in a window
1 Switch to the worksheet window from which you want to remove the panes.
2 Double-click the split bar, or choose Remove Split from the Window menu.



To combine copied formulas or values with those in the paste area
1 Select the cells you want to copy.
2 From the Edit menu or the shortcut menu, choose Copy.

Shortcuts: Copy tool (Utility toolbar)
CTRL+C

3 Select the paste area.
4 From the Edit menu, choose Paste Special.
5 Under Paste, select the Formulas option to combine formulas from the copied cells with

formulas from the paste area cells, or select the Values option to combine values from 
the copied cells with formulas from the paste area cells.

6 Under Operation, select the operation you want used to combine each copied cell and 
its corresponding paste area cell.
The arithmetic operator you select specifies whether the copied formula or value is 
added to, subtracted from, multiplied by, or divided into the contents of the destination
cells.

7 Choose the OK button.
8 To cancel the moving border, press ESC or choose another command.

See Also
Help

Copy Tool
Paste Values Tool
Paste Formats Tool

Adding and deleting a tool from a toolbar
Copy Command (Edit Menu)
Displaying and hiding a toolbar
Paste Special Command (Edit Menu)
Toolbars Command (Options Menu)



To combine values on different worksheets
1 On the source worksheet, select the cell or range of cells you want to copy.
2 From the Edit menu or the shortcut menu, choose Copy.

Shortcuts: Copy tool (Utility toolbar)
CTRL+C

3 On the destination worksheet, select the paste area.
4 From the Edit menu, choose Paste Special.
5 Under Paste, select the Values option.
6 Under Operation, select the operation you want used to combine each copied cell and 

its corresponding paste area cell.
The arithmetic operator you select specifies whether the copied formula or value is 
added to, subtracted from, multiplied by, or divided into the contents of the destination
cell.

7 Choose the OK button.
8 To cancel the moving border, press ESC or choose another command.

You do not have to switch to the source worksheet to cancel the moving border.
See Also

Help
Copy Tool

Adding and deleting a tool from a toolbar
Copy Command (Edit Menu)
Displaying and hiding a toolbar
Paste Special Command (Edit Menu)
Toolbars Command (Options Menu)



To convert a formula or a portion of a formula to its displayed 
values
To convert a formula to its displayed values

1 Select the cells you want to convert.
2 From the Edit menu or the shortcut menu, choose Copy.

Shortcuts: Copy tool (Utility toolbar)
CTRL+C

3 From the Edit menu, choose Paste Special.
Shortcut: Paste Values tool (Utility toolbar)

4 Under Paste, select the Values option button.
5 Choose the OK button.

The cells now contain the results of the formulas as constant values, not the formulas.
6 To cancel the moving border, press ESC or choose another command.

To convert a portion of a formula to its displayed value
Use this procedure if you want to change only part of a formula to a value.
1 Select the cell containing the formula you want to change.
2 In the formula bar, select the part of the formula you want to change.
3 Press F9 or click the Calculate Now tool on the Utility toolbar.
4 Click the enter box or press ENTER.

See Also
Help

Calculate Now Tool
Copy Tool
Paste Values Tool

Adding and deleting a tool from a toolbar
Calculate Now Command (Options Menu)
Copy Command (Edit Menu)
Displaying and hiding a toolbar
Paste Special Command (Edit Menu)
Toolbars Command (Options Menu)



To copy data
To copy data by dragging

1 Select the cell or cells you want to copy.
2 Position the mouse pointer over the border of the selection.
3 Press CTRL while dragging the selection to where you want to paste it.

While you drag, a border appears to indicate the size and position of the selection.
If the paste area is located beyond the visible portion of the worksheet, drag the 
selection to the edge of the window to scroll the worksheet.

4 To copy the data to existing cells, position the border so that it surrounds the paste 
area, and then release the mouse button.    Any existing data in the paste area is 
replaced.
To insert the copied data between existing cells, press CTRL+SHIFT while dragging the 
selection to where you want to insert it.    Existing cells and data shift to make room for 
the new data.

To copy data with the Copy command
1 Select the cells containing the data you want to copy.
2 From the Edit menu or the shortcut menu, choose Copy.

Shortcuts: Copy tool (Utility toolbar)
CTRL+C

3 Select the paste area.    
Any values or formulas in the paste area will be replaced.

4 To copy the data to existing cells, choose Paste from the Edit menu or the shortcut 
menu.
Shortcuts: Paste tool

ENTER
CTRL+V

If you choose Paste from the Edit menu instead of pressing ENTER, you can then repeat 
steps 3 and 4 to paste the data in additional locations.
To insert the copied cells and shift the existing cells to accommodate the inserted cells,
choose Insert Paste from the Edit menu.

5 If the moving border is still visible, cancel it by pressing ESC or choosing another 
command.

You can also copy a picture of the data and paste it on a macro sheet or worksheet using 
the Camera tool or the Copy Picture command on the Edit menu.    This command appears
only when you hold down SHIFT and select the Edit menu.

See Also
Help

Camera Tool
Copy Tool
Paste Tool

Adding and deleting a tool from a toolbar
Copy Command (Edit Menu)
Copy Picture Command (Edit Menu)
Displaying and hiding a toolbar
Insert Paste Command (Edit Menu)
Paste Command (Edit Menu)
Toolbars Command (Options Menu)
Turning drag and drop on or off



Using Drag and DropUsing the pen with Microsoft Excel
User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"
Chapter 15, "Working with Graphic Objects"



To copy data and save it in a separate file
1 Switch to the document from which you want to copy data.
2 Select the data you want to copy.
3 From the Edit menu or the shortcut menu, choose Copy.

Shortcuts: Copy tool (Utility toolbar)
CTRL+C

4 Switch to the document to which you want to copy the data or choose New    from the 
File menu to create a new document.

5 Select the upper-left cell of the area to which you want to copy the data.
6 Choose Paste from the Edit menu or the shortcut menu.

Shortcuts: Paste tool
CTRL+V

7 Choose the OK button.
You can now save the new document.

See Also
Help

Copy Tool
Paste Tool

Adding and deleting a tool from a toolbar
Copy Command (Edit Menu)
Displaying and hiding a toolbar
New Command (File Menu)
Paste Command (Edit Menu)
Saving a document for the first time
Toolbars Command (Options Menu)



To copy cells to multiple locations
1 Select the cells you want to copy.
2 From the Edit menu or the shortcut menu, choose Copy.

Shortcuts: Copy tool (Utility toolbar)
CTRL+C

3 Select multiple nonadjacent paste areas the same size and shape as the copied cells, 
or select the upper-left cell of each paste area.    

4 From the Edit menu, choose Paste.
Shortcuts: Paste tool

ENTER
CTRL+V

The data in the copied cells replaces any existing data already in the paste areas.
5 To paste the same copy area again, leave the moving border active and repeat steps 3 

and 4.
6 To cancel the moving border, press ESC or choose another command.
You can also copy a picture of the data and paste it on a worksheet or macro sheet using 
the Camera tool or the Copy Picture command on the Edit menu.    This command appears
only when you hold down SHIFT and select the Edit menu.

See Also
Help

Camera Tool
Copy Tool
Paste Tool

Adding and deleting a tool from a toolbar
Copy Command (Edit Menu)
Copy Picture Command (Edit Menu)
Displaying and hiding a toolbar
Paste Command (Edit Menu)
Selecting nonadjacent cells
Toolbars Command (Options Menu)

User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"
Chapter 15, "Working with Graphic Objects"



To copy a cell's value, formula, formatting, or note
1 Select the cells you want to copy.
2 From the Edit menu or from the shortcut menu, choose Copy.

Shortcuts: Copy tool (Utility toolbar)
CTRL+C

3 Select the paste area.
4 From the Edit menu, choose Paste Special.
5 Under Paste, select the option for the attributes of the cells that you want to paste.
6 Choose the OK button.
7 Cancel the moving border by pressing ESC, choosing another command, or activating 

the formula bar.
See Also

Help
Copy Tool
Paste Values Tool
Paste Formats Tool

Copy Command (Edit Menu)
Displaying and hiding a toolbar
Paste Special (Edit Menu, Worksheet)
Toolbars Command (Options Menu)

User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"



To copy a chart's series or formats
1 From the Chart menu, choose Select Chart.
2 From the Edit menu or the shortcut menu, choose Copy.

Shortcuts: Copy tool (Utility toolbar)
CTRL+C

3 Select the chart you want to copy to, or choose New from the File menu to create a 
new chart.
If the chart you want to copy to is embedded in a worksheet, double-click it to open it.

4 From the Edit menu, choose Paste Special.
5 Under Paste, select the option for the attributes of the chart that you want to paste.
6 Choose the OK button.
7 Cancel the moving border by pressing ESC, choosing another command, or activating 

the formula bar.
See Also

Help
Copy Tool

Copy Command (Edit Menu)
Displaying and hiding a toolbar
Paste Special (Edit Menu, Chart)
Toolbars Command (Options Menu)

User's Guide (Book 1)
Chapter 13, "Editing a Chart"



To copy to a range of adjacent cells
To copy using the AutoFill feature

1 Select the cells containing the data you want to copy.
2 Press CTRL and drag the fill handle (black square in lower-right corner of selection) to 

extend the selection across the cells you want to fill, and then release the mouse 
button.
Any existing values or formulas in the cells you fill will be replaced.
Note    If you drag a fill handle up or to the left of a selection and stop in the selected 
cells without going past the first column or the top row, you will erase your data within 
the selection.

To copy using the Fill Right and Fill Down commands
1 Select the cell or cells you want to copy and the adjacent cells you want to fill.

You can make a nonadjacent selection; in this case, each range in the selection is filled 
from the cells in the same range.

2 To copy the selection's first column into the adjacent cells to the right, choose Fill Right 
from the Edit menu.
Shortcuts: Fill Right tool

CTRL+R
To copy the selection's first row into the adjacent cells below, choose Fill Down from the
Edit menu.
Shortcuts: Fill Down tool

CTRL+D
To copy the selection's last column into the adjacent cells to the left, hold down SHIFT 
and choose Fill Left from the Edit menu.    
Shortcut: SHIFT+Fill Right tool.
To copy the selection's last row into the adjacent cells above, hold down SHIFT and 
choose Fill Up from the Edit menu.    
Shortcut: SHIFT+Fill Down tool.
Any existing values or formulas in the cells you fill will be replaced.

See Also
Help

Fill Down Tool
Fill Right Tool

Fill Commands (Edit Menu)
Turning AutoFill on or off
Using AutoFill
Using the pen with Microsoft Excel

User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"



To copy visible cells
1 Select the cells you want to copy.
2 Choose Select Special from the Formula menu, select the Visible Cells option, and 

choose the OK button.
Shortcut: Select Visible Cells tool (Utility toolbar)

3 From the Edit menu or the shortcut menu, choose Copy.
Shortcuts: Copy tool (Utility toolbar)

CTRL+C
4 Select the paste area.
5 From the Edit menu, choose Paste.

Shortcut: Paste tool
CTRL+V

The data in the copied cells replaces any existing data in the paste area.
To create a link to the copied cells, choose Paste Link instead of Paste from the Edit 
menu.

6 To cancel the moving border after you finish copying, press ESC or choose another 
command.

Note    If the paste area contains hidden rows or columns, Microsoft Excel pastes the copy
area in consecutive rows or columns even if they are not visible.    You may need to 
expand the paste area to see all of the copied cells.

See Also
Help

Copy Tool
Paste Tool
Select Visible Cells Tool

Adding and deleting a tool from a toolbar
Copy Command (Edit Menu)
Displaying and hiding a toolbar
Paste Command (Edit Menu)
Paste Link Command (Edit Menu)
Select Special Command (Formula Menu)
Toolbars Command (Options Menu)

User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"
Chapter 11, "Working with Multiple Microsoft Excel Documents"



To copy within the formula bar
1 In the formula bar, select the characters you want to copy.
2 From the Edit menu, choose Copy.

Shortcut: CTRL+C
3 Move the insertion point in the formula bar where you want to paste the copied 

characters.
4 From the Edit menu, choose Paste.

Shortcut: CTRL+V

To copy all or part of a cell entry into the formula bar of another cell
1 Select the cell containing the data you want to copy.
2 In the formula bar, select the characters you want to copy.
3 From the Edit menu, choose Copy.

Shortcut: CTRL+C
4 Press ESC or ENTER to deactivate the formula bar.
5 Select the cell that you want to copy to.
6 In the formula bar, select the characters you want to replace, or position the insertion 

point where you want to paste the data.
7 From the Edit menu, choose Paste.

Shortcut: CTRL+V

See Also
Help
Copy Command (Edit Menu)
Paste Command (Edit Menu)
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



To copy to another worksheet or application
1 Select the cells you want to copy.
2 From the Edit menu or the shortcut menu, choose Copy.

Shortcuts: Copy tool (Utility toolbar)
CTRL+C

3 To copy the cells to another worksheet, switch to the other worksheet.
4 Select the paste area.
5 From the Edit menu, choose Paste.

Shortcut: Paste tool
CTRL+V

The data in the copied cells replaces any existing data in the paste area.
To insert the copied cells and shift the other cells to accommodate the inserted cells 
instead of replacing existing data, choose Insert Paste from the Edit menu.

6 To copy cells again, repeat steps 4 and 5.
7 To cancel the moving border after you finish copying, press ESC or choose another 

command.
To paste the copied cells and cancel the moving border in one step, press ENTER instead
of choosing the Paste command.

You can also copy a picture of the data and paste it to a worksheet or macro sheet by 
using the Camera tool or by choosing Copy Picture from the Edit menu.    This command 
appears only when you hold down SHIFT and select the Edit menu.

To copy data to another application
1 Select the cells you want to copy.
2 From the Edit menu or the shortcut menu, choose Copy.

Shortcuts: Copy tool (Utility toolbar)
CTRL+C

3 Switch to the application for the document you want to paste the data into, and then 
open the document.

4 Select the paste area.
5 Paste the information, using the procedure for pasting data in the active application.
6 Return to Microsoft Excel and cancel the moving border by pressing ESC or choosing 

another command.
To copy a picture of a range of cells to another application

1 Select the range of cells you want to copy.
2 Hold down SHIFT and choose Copy Picture from the Edit menu.

Copy Picture appears on the Edit menu in place of Copy when you hold down SHIFT 
while selecting the Edit menu.

3 Select the As Shown On Screen option button or the As Shown When Printed option 
button.

4 Choose the OK button.
5 Switch to the application containing the document you want to paste the picture into, 

and then open the document.
6 Select the paste area.
7 Paste the information, using the procedure for pasting data in the application you are 

copying to.
8 Return to Microsoft Excel and cancel the moving border by pressing ESC or choosing 



another command.
See Also

Help
Copy Tool
Paste Tool

Adding and deleting a tool from a toolbar
Copy Command (Edit Menu)
Copy Picture Command (Edit Menu)
Displaying and hiding a toolbar
Insert Paste Command (Edit Menu)
Paste Command (Edit Menu)
Toolbars Command (Options Menu)

User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"
Chapter 15, "Working with Graphic Objects"



To create links between documents
You can create a link between Microsoft Excel documents, between a Microsoft Excel 
worksheet and a document from another application, or between a Microsoft Excel chart 
and another application.
To create a link between Microsoft Excel documents

1 Open the two documents you want to link.
To make it easy to move between documents, choose Arrange from the Window menu 
to display both windows in the workspace at the same time.

2 Switch to the source document window.    This is the document that contains the 
information to be linked.

3 Select the cell or cell range containing the information to be linked.
4 From the Edit menu or the shortcut menu, choose Copy.

Shortcuts: Copy tool (Utility toolbar)
CTRL+C

A moving border appears around the selected cell or range.
5 Switch to the dependent worksheet window.    This is the document that will contain the

linked data.
6 Select the cell or the upper-left corner of the range that will contain the link.
7 From the Edit menu, choose Paste Link.

Microsoft Excel creates the external reference formula that links the worksheets.
To create a link between a source Microsoft Excel worksheet and a dependent 
document from another application

To do this procedure, both applications must be Microsoft Windows applications. 
1 Open the source worksheet in Microsoft Excel and the dependent document in the 

other application.
2 Switch to the source worksheet in Microsoft Excel.
3 Select the worksheet data or embedded chart you want to copy into the dependent 

document in the other application.
4 From the Edit menu or the shortcut menu, choose Copy.

Shortcuts: Copy tool (Utility toolbar)
CTRL+C

5 Switch to the dependent document window in the other application.
6 Place the insertion point where you want to insert the worksheet data or chart.
7 Follow the procedure for pasting linked data in the other application.

To create a link between a dependent Microsoft Excel worksheet and a source 
document from another application

To do this procedure, both applications must be Microsoft Windows applications. 
1 Open the dependent worksheet in Microsoft Excel document and the source document 

in the other application.
2 Switch to the source document window in the other application.
3 Follow the other application's procedure for selecting and copying data.
4 Switch to the dependent Microsoft Excel worksheet.
5 Select the cell or the upper-left corner of the range that will contain the linked data.
6 From the Edit menu, choose Paste Link.

Microsoft Excel creates the remote reference formula that links the documents.
If the Paste Link command is unavailable when you select the Edit menu, the other 



application does not support linking or cannot supply the data in a format that 
Microsoft Excel can use.

To create a link between a source Microsoft Excel chart and a dependent 
document in another application

To do this procedure, both applications must be Microsoft Windows applications. 
1 If you want to create a link from an embedded chart, select the chart.

If you want to create a link to a separate chart document, switch to the chart and then 
choose Select Chart from the Chart menu.

2 From the Chart menu, choose Select Chart.
3 From the Edit menu or the shortcut menu, choose Copy.

Shortcuts: Copy tool (Utility toolbar)
CTRL+C

A moving border appears around the selected chart.
4 Switch to the document in the other application.
5 Position the insertion point where you want to insert the chart.
6 Follow the procedure for linking data in the other application.

See Also
Help
Arrange Command (Window Menu)
Copy Command (Edit Menu)
Displaying and hiding a toolbar
Paste Link Command (Edit Menu)
Select Chart Command (Chart Menu)
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 11, "Working with Data from Multiple Documents"
User's Guide (Book 2)
 Chapter 3, "Exchanging Data with Other Applications"



To create a view of a worksheet
1 From the Window menu, choose View.
2 In the View dialog box, choose the Add button.
3 In the Name box, type a name for the view.
4 Under View Includes, select the options you want to include in the view.
5 Choose the OK button.

To display a view of a worksheet
1 From the Window menu, choose View.
2 Select the name of the view you want to see.
3 Choose the Show button.

To delete a view of a worksheet
1 From the Window menu, choose View.
2 Select the name of the view you want to delete.
3 Choose the Delete button.
4 If you want to delete other views you no longer need, repeat steps 2 and 3. 
5 Choose the Close button.

See Also
Help
View Command (Window Menu)
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



To create an additional window for the active document
From the Window menu, choose New Window.

Microsoft Excel opens a new window that contains the same information as the active 
window.    The new window scrolls separately.

See Also
Help
New Window Command (Window Menu)



To collapse an outline level
This procedure requires a mouse.

Click the collapse button.    
Click the outline level button.    

A minus sign button next to a row or column indicates that outline levels subordinate to that
row or column are currently displayed.    You can collapse any outline level that has a minus 
sign next to it. Click the numbered outline level button in the upper-left corner of the 
window to display only up to that outline level.
See Also

Help
            Show Outline Symbols Tool  

Assigning an outline level to a row or column
Creating an outline from a existing worksheet
Clearing an outline from a worksheet
Displaying an outline level
Displaying or hiding outline symbols
Expanding an outline level
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



To create or edit a note
1 Select the cell you want to annotate.
2 From the Formula menu, choose Note, or if the cell already has a note, double-click the 

cell.
3 In the Text Note box, type the text of the new note or edit the text of the existing note.  

The text you type automatically wraps to the next line.    To insert a line or paragraph 
break, press CTRL+ENTER.

4 Choose the OK button.
Microsoft Excel attaches the note to the cell.

To create multiple notes quickly
1 Select the first cell you want to annotate.
2 From the Formula menu, choose Note, or if the cell already has a note, double-click the 

cell.
3 In the Text Note box, type the text of the new note or edit the text of the existing note.

The text you type automatically wraps to the next line.    To insert a line or paragraph 
break, press CTRL+ENTER.

4 Choose the Add button.
5 Select the next cell you want to annotate, or type the reference in the Cell box.
6 In the Text Note box, delete the text from the previous note and type the text of the 

next note.
7 Choose the Add button.
8 Repeat steps 5 through 7 for each additional note you want to create.
9 Choose the OK button when you are finished adding notes.

See Also
Help
Copying a text or sound note to another cell
Creating a sound note
Deleting a note
Displaying or hiding note indicators
Note Command (Formula Menu)
Playing a sound note
Removing a sound note
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



To create an outline from an existing worksheet
You can create a new outline on a worksheet using the Outline dialog box. You can use the 
Create button to automatically determine the location of the summary rows and columns 
relative to the detail data in your worksheet. 

1 Select the range you want to outline.
If you select a single cell, the entire worksheet will be outlined.

2 From the Formula menu, choose Outline.
3 Select the Automatic Styles check box if you want Microsoft Excel to apply built-in cell 

styles to summary rows and columns.
4 Specify the direction you want the levels to flow in the outline.

Both the Summary Rows Below Detail check box and the Summary Columns To The 
Right Of Detail check box are normally selected.    If your worksheet is not set up in this 
fashion, as is normally the case, clear one or both check boxes.
Your worksheet must be consistent in the way summary rows and columns are 
positioned relative to source data.

5 Choose the Create button.
See Also

Help
            Demote Tool  
            Promote Tool  

Assigning an outline level to a row or column
Clearing a outline from a worksheet
Collapsing an outline level
Displaying or hiding outline symbols
Expanding an outline level
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



To create names
1 Select the range of cells with which you want to create names.

The selected range should include text labels at the top, bottom, left, or right of the 
selection. These labels will become the range names.    Date labels will automatically 
be converted to text values.

2 From the Formula menu, choose Create Names.
Shortcut: SHIFT+CTRL+F3

3 Under Create Names In, select Top Row, Left Column, Bottom Row, or Right Column, 
depending on the location of the labels from which you want to create names. 

4 Choose the OK button.
See Also

Help
Apply Names Command (Formula Menu)
Create Names Command (Formula Menu)
Define Name Command (Formula Menu)
Defining a name
Replacing references in formulas with names
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



To clear an outline from a worksheet
1 Select the entire outline.
2 Press ALT+SHIFT+LEFT ARROW until all rows and columns are at level 1.

When the Promote dialog box appears, choose the Rows or Columns option and click 
the OK button.
--or--
With the mouse, click the Promote tool on the Utility toolbar until all rows and columns 
are at level 1. 
When the Promote dialog box appears, choose the Rows or Columns option and click 
the OK button.

The outline symbols disappear and your worksheet no longer contains an outline.
See Also

Help
            Demote Tool  
            Promote Tool  

Assigning an outline level to a row or column
Collapsing an outline level
Creating an outline from a existing worksheet
Displaying or hiding outline symbols
Expanding an outline level
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



To create a sound note
You must have the proper hardware and software installed to use the Sound Note features. 
See Chapter 8, "Organizing and Documenting a Worksheet," in Book 1 of the Microsoft Excel
User's Guide.
To record a new sound note

1 Select the cell you want to annotate.
2 From the Formula menu, choose Note, or if the cell already has a note attached, 

double-click the cell.
3 Under Sound Note, choose the Record button.

If the cell already has a sound note attached, the Record button is not available. 
4 In the Record/Play dialog box, choose the Record button and begin recording your note. 

The time scale below the Record, Stop, Pause, and Play buttons shows elapsed 
recording time relative to the total amount available.

5 Choose the Stop button when you are finished recording.    
Choose the Pause button to suspend and then resume recording.

6 Choose the Play button to review your recording.    
7 To rerecord your sound note, repeat steps 4 and 5.
8 When you are satisfied with your recording, choose the OK button.
9 In the Cell Note dialog box, choose the Add button if you want to add more notes, and 

repeat steps 1 through 8.
--or--
Choose the OK button to add your note and close the dialog box.

To import a prerecorded sound file
1 Select the cell you want to annotate.
2 From the Formula menu, choose Note, or if the cell already has a note attached, 

double-click the cell.
3 Under Sound Note, choose the Import button to select a previously recorded sound file 

to attach to the cell.
4 From the list, select the sound file you want to import.
5 Choose the OK button.
6 In the Cell Note dialog box, choose the Add button if you want to add more notes, and 

repeat steps 1 through 4.
--or--
Choose the OK button to add your note and close the dialog box.

See Also
Help
Creating or editing a note
Deleting a note
Note Command (Formula Menu)
Removing a sound note
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



To copy a text or sound note to another cell
1 Select the cell containing the note you want to copy.

If the selected cell contains a text note as well as a sound note, both will be copied.
2 From the Edit menu, choose Copy.

Shortcuts: Copy tool (Utility toolbar)
CTRL+INSERT
CTRL+C

3 Select the cell to which you want to copy the note.
4 From the Edit menu, choose Paste Special.
5 Under Paste, select the Notes option button.
6 Choose the OK button.

The copied note replaces any existing notes in the destination cell.
See Also

Help
Copy Tool (Utility Toolbar)

Creating a note
Creating a sound note
Deleting a note
Displaying or hiding cell note indicators
Playing a sound note
Removing a sound note
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



To change the thickness of window borders
1 From the Control menu, choose Run.

Shortcut: ALT+SPACEBAR+U
2 Select the Control Panel option button.
3 Choose the OK button.
4 Double-click the Desktop icon.
5 Adjust the Border Width by clicking the up or down arrow or by typing a number in the 

Border Width box.
6 Choose the OK button.
7 From the Control menu in the Windows Control Panel, choose Close.

Shortcut: ALT+SPACEBAR+C



To change worksheet dimensions on the screen
Change the size of the window, the height of the individual rows, or both.    You can 

also zoom in or out of your worksheet.
See Also

Help

Zoom In Tool
Zoom Out Tool

Utility Toolbar
Toolbars Command (Options Menu)



To change the width of columns
To change a column's width

Drag the line to the right of the column heading until the column is the desired width.
--Or--

1 Select the column or any cell in the column.
2 From the Format menu or the column shortcut menu, choose Column Width.
3 Change the number in the Column Width box.    This number represents the number of 

characters that can be displayed in a cell for the current font and size.
To adjust a column's width for the best fit

Double-click the line to the right of the column heading.
--Or--

1 Select the column or any cell in the column.
2 From the Format menu or the column shortcut menu, choose Column Width.
3 Choose the Best Fit button.

The column width adjusts to accommodate the longest cell entry in the column.
To change the standard column width

1 Select a range of cells or the entire worksheet.
2 From the Format menu, choose Column Width.
3 In the Standard Width box, type a new number.

Only columns within the selection that have not been manually set will change to the 
standard width.

4 If you want all columns within the selection to have the standard width, choose the Use
Standard Width check box.

5 Choose the OK button.
To change column widths on more than one worksheet

1 Start a group editing session.
2 Use any of the above procedures.

See Also
Help
Column Width Command (Format Menu for Worksheets)
Copying data and formats to all sheets in a group
Starting or ending a group editing session
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



To create or delete a custom number format
To create a custom number format

1 Select the cells you want to format.
2 From the Format menu or the shortcut menu, choose Number.

To create a custom format, you can edit a built-in format or type a new format.
3 To edit a built-in format, select the format from the list.
4 In the Code box, edit the built-in format or type a new format.
5 Choose the OK button.

Your custom format now appears at the end of the Format Codes list and is available 
every time you open the worksheet.

To delete a custom number format
1 From the Format menu or the shortcut menu, choose Number.
2 Select the number format you want to delete.

You cannot delete built-in formats.
3 Choose the Delete button.
4 Choose the OK button.

See Also
Help
Creating international currency formats
Number Command (Format Menu for Worksheets)
User's Guide (Book 1)
Chapter 7 "Formatting a Worksheet"



To center text over columns
1 Select a range of cells, including the cell that contains your text entry.
2 From the Format menu or the shortcut menu, choose Alignment.
3 Select the Center Across Selection option button.
4 Choose the OK button.

The text is centered across all the selected blank columns to the right and will change 
with any column width adjustments.

Shortcut: Center Across Columns tool
See Also

Help
Center Across Columns Tool

Alignment Command (Format Menu for Worksheets)
Standard Toolbar



To create or delete a style
You can create a style by example by using either the Style command on the Format menu 
or the Style box on the toolbar.
To create a style by example using the Style box

1 Select a cell that has the combination of formats you want.
2 In the Style box on the toolbar, type a name for the new style.
3 Press ENTER.

To create a style by example using the Style command
1 Select a cell that has the combination of formats you want to include in your style.
2 From the Format menu, choose Style.
3 In the Style Name box, type a name for the new style.

A description of the new style appears in the Description box.
4 Choose the OK button.

To create a style by definition
1 From the Format menu, choose Style.
2 In the Style Name box, type a name for the style.
3 Choose the Define button.

The Style dialog box expands.
4 In the Style Includes box, select the check boxes for the attributes you want the style 

to have.    Clear the check boxes for the attributes you do not want affected.
When you clear the check box for an attribute, the corresponding button for that 
attribute becomes unavailable and the description for this attribute is omitted.

5 Choose the button in the Change box for the attribute you want to add or change.
The appropriate dialog box is displayed.

6 Select the formats you want for the attribute.
7 Choose the OK button to confirm your selections and return to the Style dialog box.
8 Repeat steps 5 through 7 until you have selected all the formats you want for your 

style.
9 To define and apply the style, choose the OK button.

To define the style without applying it, choose the Add button and then choose the 
Close button.

To delete a style
1 From the Format menu, choose Style.
2 In the Style Name box, select the style you want to delete.

You cannot delete the Normal style.
3 Choose the Define button.
4 Choose the Delete button.
5 Choose the OK button.

See Also
Help

Comma Style Tool
Currency Style Tool
Percent Style Tool
Style Box



Applying a style
Copying styles from another document
Redefining a style
Redefining the Normal style
Style Command (Format Menu for Worksheets)
Toolbars Command (Options Menu)



To copy styles from another document
To do this procedure, you must have both documents open: the document you are copying 
to and the document you are copying from.

1 Switch to the document you want to copy the styles to.
2 From the Format menu, choose Style.
3 Choose the Define button.
4 Choose the Merge button.

Microsoft Excel displays a list of the documents that are open.
5 In the Merge Styles From box, select the name of the document that contains the styles

you want to copy.
6 Choose the OK button to copy the styles and style names from the document you 

selected to the active document.
7 Choose the Close button to close the Style dialog box.

See Also
Help
Applying a style
Creating or deleting a style
Redefining a style
Redefining the Normal style
Style Command (Format Menu for Worksheets)



To create international currency formats
1 Select the cells you want to format.
2 From the Format menu or the shortcut menu, choose Number.
3 In the Format Codes list, select any format.

The format you select is displayed in the Code box.
4 In the Code box, edit the existing format or type a new one.

Enter special characters to display currency symbols by pressing NUM LOCK and holding 
down ALT while typing the ANSI character for the currency symbol on the numeric 
keypad.
For example, if you want to insert a yen symbol, hold down ALT while typing 0165 on 
the numeric keypad.

5 Choose the OK button.
The new format is applied to the selected cells, and appears at the end of the Format 
Codes list.    Your custom currency format is available every time you open the 
worksheet.

For more information, see ANSI character set in your Microsoft Windows documentation.
See Also

User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



To cancel print titles
1 Select the entire worksheet.
2 From the Options menu, choose Remove Print Titles.

Remove Print Titles is available on the Options menu only when you have selected the 
entire worksheet.

See Also
Help
Selecting a cell, row, column, or worksheet
Set Print Titles and Remove Print Titles Commands (Options Menu)
Setting print titles for rows and columns
User's Guide (Book 1)
Chapter 16, "Printing"



To add or delete an overlay chart
You can add an overlay chart by changing the chart type with the Combination command on
the Gallery menu.    You can delete an overlay chart by changing the chart type with any 
other command on the Gallery menu.    These commands completely replace any custom 
formatting you have applied to the chart.    The following procedure adds an overlay chart 
while retaining any custom formatting you have applied.
To add an overlay chart to a customized chart

1 Switch to the chart window.
If the chart is embedded in a worksheet, double-click the chart to display it in a chart 
window.

2 From the Chart menu, choose Add Overlay.
Microsoft Excel overlays a line chart.

3 To change the overlay chart type, choose Overlay from the Format menu.
4 In the Overlay Chart Type box, select the overlay chart type you want.

If more than one format is available for the chart type you want, select a format under 
Data View.

5 Choose the OK button.
To delete an overlay chart

From the Chart menu, choose Delete Overlay.
See Also

Help
Add Overlay and Delete Overlay Commands (Chart Menu)
Combination Command (Gallery Menu)
Gallery Menu
Overlay Command (Format Menu for Charts)
User's Guide (Book 1)
Chapter 12, "Creating a Chart"



To change the chart type and format
To change the chart type and format with the Chart toolbar

This procedure overrides some custom formatting applied to the chart.
1 If the chart is embedded on a worksheet, select it.

If the chart is a separate document, switch to the chart window.
2 Click the tool for the chart type you want.

To change the chart type and format with commands
This procedure overrides some custom formatting applied to the chart.
1 Switch to the chart window.

If the chart is embedded in a worksheet, double-click the chart to display it in a chart 
window.

2 From the Gallery menu, choose the chart type you want.
3 In the Chart Gallery dialog box, select the chart format you want.    

Click the Next or Previous button to display the Chart Gallery dialog box for the next or 
previous chart type.

4 Choose the OK button.
To change the chart type of a customized chart without changing other 
formatting 

1 Switch to the chart window.
If the chart is embedded in a worksheet, double-click the chart to display it in a chart 
window.

2 From the Format menu, choose Main Chart.
To change the overlay chart type, choose Overlay from the Format menu.

3 In the Main Chart Type box or the Overly Chart Type box, select the chart type you 
want.
If more than one format is available for the type of chart you want, select a format 
under Data View.

4 Choose the OK button.
The chart retains any custom formatting that is appropriate for the new chart type.

To change the chart back to the preferred chart type
From the Gallery menu, choose Preferred.

Shortcut: Preferred Chart tool (Chart toolbar)
See Also

Help
Preferred Chart Tool

Chart Toolbar
Gallery Menu
Main Chart Command (Format Menu for Charts)
Overlay Command (Format Menu for Charts)
Preferred Command (Gallery Menu)
3-D View Command (Format Menu for Charts)
User's Guide (Book 1)
Chapter 12, "Creating a Chart"



To set calculation options for open documents
1 From the Options menu, choose Calculation.
2 Select the options you want.
3 Choose the OK button.

You cannot change the calculation order.
See Also

Help
Calculate Now Tool

Calculation Command (Options Menu)
Calculate Now Command (Chart menu)
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"
User's Guide (Book 2)
Chapter 1, "Analyzing and Calculating Data"



To control remote requests
When Microsoft Excel is running, it responds to dynamic data exchange (DDE) requests, and
object linking and embedding (OLE) requests from any other application unless you have 
disabled remote requests.

1 From the Options menu, choose Workspace.
2 To disable remote requests, select the Ignore Remote Requests check box.

To enable remote requests, clear the Ignore Remote Requests check box.
3 Choose the OK button.

See Also
Help
Updating linked information
Workspace Command (Options Menu)
User's Guide (Book 2)
Chapter 3, "Exchanging Data with Other Applications"



To copy a chart to a worksheet or another application
To copy a chart to a worksheet

1 Switch to the chart window.
If the chart is embedded in a worksheet, click the chart to select it.

2 From the Chart menu, choose Select Chart.
3 From the Edit menu or the shortcut menu, choose Copy.

Shortcuts: Copy tool
CTRL+C

4 Switch to the worksheet you want to paste the chart onto.
5 Select the cell in the upper-left corner of the paste area.
6 From the Edit menu or the shortcut menu, choose Paste.

Shortcuts: Paste tool
ENTER
CTRL+V

To copy a chart to another application
1 Switch to the chart window.

If the chart is embedded in a worksheet, click the chart to select it.
2 From the Chart menu, choose Select Chart.
3 From the Edit menu or the shortcut menu, choose Copy.

Shortcuts: Copy tool
CTRL+C

4 Switch to the application you want to paste the chart into.
5 Paste the chart, using the procedure for pasting in the application you are copying to.
If you want to control the size and appearance of the copied chart and treat it as a 
graphic object rather than as an embedded chart, use the Copy Picture command on the 
Edit menu instead of the Copy command.    Copy Picture appears on the Edit menu in 
place of Copy when you hold down SHIFT and select the Edit menu. 

See Also
Help

Copy Tool
Paste Tool

Copy Command (Edit Menu)
Copy Picture (Edit Menu)
Paste Command (Edit Menu)
Select Chart Command (Chart Menu)

User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



To copy color palettes between documents
1 Open the document that has the color palette you want to copy.
2 Switch to the document to which you want to copy the color palette.
3 From the Options menu, choose Color Palette.

If you are working with a chart, choose Color Palette from the Chart menu.
4 In the Copy Colors From box, select the document that has the color palette you want 

to copy.
5 Choose the OK button.

See Also
Help
Color Palette Command (Chart Menu)
Color Palette Command (Options Menu)
Customizing colors in the color palette
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



To create or clear a picture chart
You can replace data markers with a picture created in another application or a picture 
created using the drawing tools on the Drawing toolbar.    You can use picture markers in 
line, bar, and column charts.    You cannot use picture markers in 3-D charts.
To create a picture chart

1 Switch to the application and the document containing the picture.
2 Copy the picture using that application's procedure for copying.

If you are copying a picture from a Microsoft Excel document, choose Copy from the 
Edit menu.

3 Switch to the window containing the Microsoft Excel chart in which you want to use the 
picture.
If the chart is embedded in a worksheet, double-click the chart to display it in a chart 
window.

4 Select the data series whose markers you want to replace with the picture.
If the chart has only one data series, select the single data marker you want to replace 
with the picture.    To select a single data marker, press CTRL and click the marker.

5 From the Edit menu, choose Paste.
To clear a data marker picture

1 Select the data series whose markers you want to clear.
If the chart has only one data series, select the single data marker you want to replace 
with the picture.    To select a single data marker, press CTRL and click the marker.

2 From the Edit menu or the shortcut menu, choose Clear.
Shortcut: DEL

3 Select the Formats option button.
4 Choose the OK button.

See Also
Help
Changing whether a picture marker is stacked or stretched
Clear Command (Edit Menu for Charts)
Clearing a data marker picture
Drawing Toolbar
Replacing a data marker with a picture
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



To create a chart
To create a chart embedded in a worksheet with the ChartWizard

1 Select the data you want to plot.    Include cells containing labels for rows or columns 
that you want used in the chart.

2 Click the ChartWizard tool.
3 Position the cross-hair pointer where you want one corner of the chart.
4 Drag until the outline is the size you want the chart to be.
5 Follow the instructions on the screen.

To create a chart embedded in a worksheet with the Preferred Chart tool
1 Select the data you want to plot.    Include cells containing labels for rows or columns 

that you want used in the chart.
2 Click the Preferred Chart tool.    
3 Position the cross-hair pointer where you want one corner of the chart.
4 Drag until the outline is the size you want the chart.

If the selection contains more than one row or column and does not contain text labels 
or dates in both the first row and first column, the New Chart dialog box appears.    
Select the option you want, and then choose the OK button.

To create a chart embedded in a worksheet with the chart tools
To do this procedure, the Charting toolbar must be displayed.    Use the Toolbars command
on the Options menu to display toolbars.
1 Select the data you want to plot.    Include cells containing labels for rows or columns 

that you want used in the chart.
2 Click the tool you want.    

There are tools for some of the more common chart types.
3 Position the cross-hair pointer where you want one corner of the chart.
4 Drag until the outline is the size you want the chart.

If the selection contains more than one row or column and does not contain text labels 
or dates in both the first row and first column, the New Chart dialog box appears.    
Select the option you want, and then choose the OK button.

To create a chart as a separate document
1 Select the data you want to plot.    Include cells containing labels for rows or columns 

that you want used in the chart.
2 From the File menu, choose New.

Shortcut: F11
3 In the New box, select Chart.
4 Choose the OK button.

If the selection contains more than one row or column and does not contain text labels 
or dates in both the first row and first column, the New Chart dialog box appears.    
Select the option you want, and then choose the OK button.

See Also
Help

ChartWizard Tool
Preferred Chart Tool
Area Chart Tool
Bar Chart Tool



Column Chart Tool
Line Chart Tool
Pie Chart Tool
Radar Chart Tool
Line/Column Chart Tool
Stacked Column Chart Tool
Volume/Hi-Lo-Close Chart Tool
XY (Scatter) Chart Tool
3-D Area Chart Tool
3-D Bar Chart Tool
3-D Column Chart Tool
3-D Line Chart Tool
3-D Perspective Column Chart Tool
3-D Pie Chart Tool
3-D Surface Chart Tool

Changing the chart type and format
Creating or clearing a picture chart
Displaying and hiding a toolbar
New Chart Dialog Box
New Command (File Menu)
Protecting chart data
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 12, "Creating a Chart"



To customize colors in the color palette
Each document you create with Microsoft Excel has a palette, or set, of 16 colors that you 
can use to format cells, fonts, gridlines, graphic objects, and items in a chart. If you have a 
color monitor, you can customize any or all of the colors.
To customize colors

1 Switch to the window of the document for which you want to change the color palette.
Charts that are embedded in a worksheet use the worksheet's color palette; charts that
are separate documents have their own color palette.

2 If the active document is a worksheet, choose Color Palette from the Options menu.
If the active document is a chart, choose Color Palette from the Chart menu.

3 Double-click the color you want to customize, or select the color and then choose the 
Edit button.
The Color Picker dialog box appears.

4 Change the color by clicking in the color box and by adjusting the brightness bar.
-- or --
Change the color by changing the numbers in the Red, Green, and Blue boxes, or in the
Hue, Sat (saturation), and Lum (luminosity) boxes.
The customized color appears in the left side of the Color|Solid box. If you want to use 
the solid color nearest the color you have created, double-click the right side of the 
box.

5 Choose the OK button.
The Color Picker dialog box closes and the custom color appears in the palette.

6 Repeat steps 3 through 5 to customize additional colors. 
7 When you are finished customizing colors, click the OK button or press Enter. 

To restore the default palette
1 Switch to the window of the document for which you want to change the color palette.

Charts that are embedded in a worksheet use the worksheet's color palette; charts that
are separate documents have their own color palette.

2 If the active document is a worksheet, choose Color Palette from the Options menu.
If the active document is a chart, choose Color Palette from the Chart menu.

3 Choose the Default button.
4 Choose the OK button.

See Also
Help
Color Palette Command (Chart Menu)
Color Palette Command (Options Menu)
Copying color palettes between documents
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



To check spelling
1 Select the items for which you want to check spelling.

If you are checking spelling in a worksheet or a macro sheet, and you select only a 
single cell, the entire sheet including headers, footers, embedded charts, text boxes, 
cell notes, and buttons will be checked for spelling errors.

2 To check spelling in a worksheet or a macro sheet, choose Spelling from the Options 
menu.
To check spelling in a chart, choose Spelling from the Chart menu.
Shortcut: Check Spelling tool (Utility toolbar)

3 When Microsoft Excel selects an unknown word, select the options you want in the 
Spelling dialog box to make or ignore the suggested corrections.
If no correction is suggested, you can add the currently selected word to the dictionary 
by choosing the Add button.

4 When Microsoft Excel displays a message stating that it has checked all of the items 
you have selected, choose the OK button to close the dialog box.

See Also
Help

Check Spelling Tool
Spelling Command (Chart Menu)
Spelling Command (Options Menu)
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



To change the layout of a printed page
1 From the File menu, choose Page Setup.

You can also choose the Setup button in the Print dialog box.
2 Under Orientation, select the Portrait option button to print the image vertically on the 

page, or the Landscape option button to print the image horizontally on the page.
3 Under Paper, select a paper size in the Size box.
4 Under Margins, type the margin sizes you want in the Left, Right, Top, and Bottom 

boxes.
5 If you want to center the document, select the Horizontally or Vertically check box, or 

both.
You can also choose the Margins button in the Print Preview window to display margins 
and column widths, and then drag them to the size you want.

6 Select any other options you want.
7 To change headers or footers, choose the Header button or the Footer button.
8 To print the document, choose the Print button.
9 To select another printer or to change printer settings, choose the Printer Setup button.

10 Choose the OK button.
11 To preview the page layout before printing, choose Print Preview from the File menu.

Shortcut: Print Preview tool
See Also

Help
Print Preview Tool

Changing headers and footers
Page Setup Command (File Menu)
Print Preview Command (File Menu)
Printing a document without previewing
Setting up a printer
User's Guide (Book 1)
Chapter 16, "Printing"



To change the default directory for opening files
1 From the File menu, choose Open.
2 In the Directories box, select a directory, or in the File Name box, type the directory 

path.
3 Choose the OK button.

Microsoft Excel displays the files in the current directory that match the criteria entered
in the File Name box.    To see all the files in a directory, type *.*

4 In the File Name box, type the name of the file you want to open or select it from the 
list.

5 Choose the OK button to open the file.
See Also

Help
Open Command (File Menu)



To change the drive or directory
1 From the File menu, choose Open.
2 In the Drives box, select the drive from the list, or in the File Name box, type the name 

of the drive, directory, or both, followed by *.*
3 Choose the OK button.
4 To close the dialog box, choose the Cancel button.

To change to a subdirectory of the current directory
1 From the File menu, choose Open.
2 In the Directories box, select a subdirectory.
3 Choose the OK button.
4 To close the dialog box, choose the Cancel button.

To change to the parent directory of the current directory
1 From the File menu, choose Open.
2 In the Directories box, select the parent directory of the current directory.
3 Choose the OK button.
4 To close the dialog box, choose the Cancel button.

See Also
Help
Open Command (File Menu)



To close the active document
1 From the File menu, choose Close.

If there are no changes, the document is closed immediately.
If there are unsaved changes, Microsoft Excel asks if you want to save changes.

2 Choose the Yes button to save changes, the No button to discard changes, or the 
Cancel button to cancel the command.
If the document hasn't been saved in Normal format before, the Save As dialog box is 
displayed.

3 In the File Name box, type a name for the file or accept the proposed name.
4 Choose the OK button.

If you selected the Recalculate Before Save check box in the Calculation Options dialog 
box, Microsoft Excel recalculates your worksheet if necessary.
Press ESC to interrupt recalculation.
When you press ESC, you will be asked if you want to continue with recalculating before 
saving.
Choose Yes to continue, No to save without recalculating, or Cancel to cancel the 
command and return to the document.

See Also
Help
Calculation Command (Options Menu)
Setting calculation options for open documents



To create a new template
1 Create a worksheet, chart, or macro sheet with all the styles, formats, text, formulas, 

and macros you want in your template.    You can also open a document that you want 
to use as a template.

2 From the File menu, choose Save As.
3 Type the name you want for the template.    
4 In the Save File As Type box, select Template.

Microsoft Excel adds the extension .XLT to the name.
5 Choose the OK button.

See Also
Help
Editing a template 
Using a template
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



To create a new worksheet
1 From the File menu, choose New.
2 Select Worksheet.
3 Choose the OK button.

Shortcuts: New Worksheet tool
SHIFT+F11

See Also
Help

New Worksheet Tool
New Command (File Menu)



To change headers and footers
1 From the File menu, choose Page Setup.
2 Choose the Header button or the Footer button.
3 Move to the edit box you want (left, center, or right).    For example, text entered in the 

left text box will appear left-aligned on the printed page.
4 In the box, enter the text you want as a header or footer.

If you want to insert the page number, total number of pages, date, time, or filename 
in the header or footer, click the appropriate tool in the dialog box to enter the code.    
For example, if you want to include the page number in a footer, click the page number
tool.    The code &P appears in the selected text box.
For more information about header and footer tools and codes, see the Header and 
footer codes Help topic.

5 If you want to format the text, select the text, click the Font tool in the dialog box, 
select the formatting you want, and choose the OK button.

6 Choose the OK button.
7 Choose the OK button to close the Page Setup dialog box.
8 To preview the header or footer before printing, choose Print Preview from the File 

menu.
Shortcut: Print Preview tool

See Also
Help

Print Preview Tool
Changing the layout of a printed page
Header and Footer Codes
Page Setup Command (File Menu)
Print Preview Command (File Menu)
Standard Toolbar
Formatting Toolbar
User's Guide (Book 1)
Chapter 16, "Printing"



To copy data and formats to all sheets in a group
1 Start a group editing session.
2 In the active sheet, select the cells you want to copy.
3 From the Edit menu, choose Fill Group.
4 To copy cell contents, formulas, and formatting, select the All option button.

To copy only the formulas, select the Formulas option button.
To copy only the formatting, select the Formats option button.

5 Choose the OK button.
Microsoft Excel copies the specified attributes of the selected cells to the same location
in all the sheets in the group.

See Also
Help
Editing worksheets as a group
Starting or ending a group editing session
User's Guide (Book 1)
Chapter 11, "Working with Multiple Microsoft Excel Documents"



To create a workbook
1 From the File menu, choose New.

Shortcut: New Workbook tool (File Tools category)
2 Select Workbook.
3 Choose the OK button.

Microsoft Excel displays a blank Workbook Contents window.
See Also

Help
New Workbook Tool

Adding or removing a document from a workbook
Toolbars Command (Options Menu)
Workbooks
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



To copy a document from one workbook to another workbook
To copy a document by dragging

1 In the Workbook Contents window, select the document you want to copy.
2 Hold down CTRL and drag the document to another Workbook Contents window or icon.

If the destination workbook is a Workbook Contents window, drag the document to the 
position you want in the list of documents.    If the destination workbook is minimized to
an icon, the document is added to the end of the list of documents in the workbook.

To copy a document using the Copy and Paste commands
1 In the Workbook Contents window, select the document you want to copy.
2 From the Edit menu, choose Copy.

Shortcuts: Copy tool (Utility toolbar)
CTRL + C

Microsoft Excel surrounds the selected document name with a moving border.
3 Select the workbook where you want to place a copy of the document.
4 From the Edit menu, choose Paste.

Shortcut: CTRL + V
Microsoft Excel makes a copy of the document and places it in the selected workbook.   
The new document appears directly above the currently selected document in the 
workbook.

See Also
Help

Copy Tool
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



To cancel a command
Press ESC.



To choose a command
To choose a command using the mouse

1 In the menu bar, click the menu name to display the menu.
2 Click the command you want to choose.

To choose a command using the keyboard
1 Press ALT to select the menu bar.
2 Press the key for the underlined letter in the name of the menu you want to display.

Use the RIGHT ARROW and LEFT ARROW keys to browse through the menus.    When you 
have selected the menu you want, press ENTER to display it.

3 Press the key for the underlined letter in the command name you want to choose.
If the command name ends with an ellipsis (...), a dialog box is displayed which 
contains options associated with this command.

To select a button, check box, list box, or text box in a dialog box
Click the option you want.

--Or--
Hold down ALT and press the underlined letter in the option name.

To select an item from a list box
Click the item you want.

--Or--
1 Hold down ALT and press the key for the underlined letter in the list box name.
2 Press the key for the first letter of the list item you want to select.    If more than one 

item starts with the same letter, press the letter key until you reach the item you want.
To carry out the command after you have selected options

Click the OK button or press ENTER.

To cancel a command
Press ESC.



To create a report
1 From the File menu, choose Print Report.

If the Print Report command does not appear on the File menu, run the Setup program 
to install it.

2 Choose the Add button.
3 In the Report Name box, type a name for the report.
4 In the View box, select the view that you want in the section.
5 In the Scenario box, select the scenario, if any, that you want for the view in this 

section.
6 Choose the Add button to add the section to the Current Sections list.
7 Repeat steps 4 through 6 until all of the views and scenarios are selected.
8 If you want a section to appear in a different order in the list, select the section that 

you want to move, and choose the Move Up or Move Down button to move the section.
9 If you want to remove a section, select the section that you want to remove, and 

choose the Delete button to remove the section.
10 If you want the pages to be numbered consecutively, select the Continuous Page 

Numbers check box.
11 Choose the OK button to close the Add Report dialog box.
12 Choose the Print button to print the selected report.

--or--
Choose the Close button to close the dialog box without printing.

See Also
Help
Creating a view of a worksheet
Editing a report
Print Report Command (File Menu)
Printing a report
Scenario Manager Command (Formula Menu)
View Command (Window Menu)
User's Guide (Book 1)
Chapter 1, "Getting Started With Microsoft Excel"
Chapter 16, "Printing"



To edit add-in macro settings
1 From the Options menu, choose Add-Ins.

The Add-in Manager displays a dialog box listing all the add-in macros that are 
automatically opened and ready to run when you open Microsoft Excel.

2 In the Add-ins Installed box, select the add-in macro you want to edit.
3 Choose the Edit button.
4 To open an add-in macro from a different directory, type the complete path in the Path 

box.
5 Choose the OK button.



To define a database
1 Enter the field names in the first row of the area that will become the database range.
2 Enter the data in the rows below the field names.
3 Select all the cells in the database range, including the field names, the records you 

want in the database, and an extra blank row below the last record for additional 
records.

4 From the Data menu, choose Set Database.
Microsoft Excel names the selected range Database.

See Also
Help
Databases
Defining a criteria range
Defining an extract range
Set Criteria Command (Data Menu)
Set Database Command (Data Menu)
Set Extract Command (Data Menu)
Setting up a criteria range with comparison criteria
User's Guide (Book 1)
Chapter 9, "Creating and Using a Database on a Worksheet"



To delete records from a database
Be sure to save your worksheet before deleting records from a database. You cannot use the
Undo command on the Edit menu to restore deleted database records.

1 Define a criteria range that contains the criteria for selecting the records you want to 
delete.
Be sure not to include any blank rows in your criteria range; this will select all records 
in the database and all records will be deleted.

2 From the Data menu, choose Delete.
A message warns you that matching records will be deleted permanently from the 
database.

3 Choose the OK button.
Microsoft Excel deletes all records that match the criteria.

See Also 
Help
Set Criteria Command (Data Menu)
Delete Command (Data Menu)
Defining a criteria range
Setting up a criteria range with comparison criteria
Editing records using a data form
User's Guide (Book 1)
Chapter 9, "Creating and Using a Database on a Worksheet"
Chapter 10, "Analyzing and Reporting Database Information"



To edit records using a data form
1 Switch to the worksheet containing the database.
2 From the Data menu, choose Form.
3 To move between records, use the scroll bar, press the UP ARROW or DOWN ARROW key, or 

choose the Find Prev or Find Next button.
4 Edit each record you want to change.

Press TAB to move between fields.
To cancel changes to a record, choose the Restore button.
Changes to a record are permanently saved when you move to another record.

5 Choose the Close button when you finish working in the data form.
To add a record

1 Switch to the worksheet containing the database.
2 From the Data menu, choose Form.
3 Choose the New button.
4 Enter data in the new record's fields.

Press TAB to move between fields.
5 Press ENTER.

Microsoft Excel adds the new record to the database and displays another blank record.
6 Repeat steps 4 and 5 to add as many records as you want.
7 Choose the Close button when you finish adding records.

To delete a record
Deleted data cannot be restored with either the Restore button or the Undo command on 
the Edit menu.
1 Switch to the worksheet containing the database.
2 From the Data menu, choose Form.
3 Display the record you want to delete.
4 Choose the Delete button.

A message asking for confirmation is displayed.
5 Choose the OK button to confirm the deletion.

See Also
Help
Form Command (Data Menu)
Finding records using a data form
User's Guide (Book 1)
Chapter 9, "Creating and Using a Database on a Worksheet" 



To find records using a data form
1 Switch to the worksheet containing the database.
2 From the Data menu, choose Form.
3 Choose the Criteria button. 

The Criteria button changes to the Form button, which you can choose to return to the 
data form.

4 In the field name boxes, type the criteria you want to use for your search.
Criteria can include text you want to match, a quantity you want to compare using a 
comparison operator, and wildcard characters.

5 Press ENTER.
Microsoft Excel displays the first matching record.

6 Choose the Find Next button to display the next matching record.
Choose the Find Prev button to display the previous matching record.
The criteria you use in a data form do not replace the criteria you define with the Set 
Criteria command.

See Also
Help
Editing records using a data form
Find and Exit Find Commands (Data Menu)
Finding records in a database
Form Command (Data Menu)
User's Guide (Book 1)
Chapter 9, "Creating and Using a Database on a Worksheet" 



To extract data from a database
1 Switch to the worksheet containing the database.
2 Make sure the criteria range is defined, and that it contains the criteria you need for 

the records you want to extract.
3 To set up the extract range, copy the field names for the fields you want to extract to 

another row on the worksheet.
When you extract data, only the fields you specify will be copied into the extract range.
Be sure to locate your extract range away from other worksheet areas, because 
extracted data will erase data below the extract range.

4 Select the area that contains, or will contain, your extract field names and extracted 
records.

5 From the Data menu, choose Set Extract.
If the extract range contains only field names, all cells between the field names and the
bottom of the worksheet are cleared whether or not information is extracted into them. 
If the extract range contains additional rows under the field names, records are 
extracted only until the selected range is full.    If there are more records than will fit in 
the selected range, a message is displayed.

6 From the Data menu, choose Extract.
7 To extract only one copy of duplicate records, select the Unique Records Only check 

box.
8 Choose the OK button.

Microsoft Excel copies the matching database records into the extract range.
You cannot reverse the Extract command with the Undo command on the Edit menu.

See Also
Help
Set Database Command (Data Menu)
Set Criteria Command (Data Menu)
Set Extract Command (Data Menu)
Extract Command (Data Menu)
Defining a database
Defining a criteria range
Defining an extract range
Setting up a criteria range with comparison criteria
User's Guide (Book 1)
Chapter 10, "Analyzing and Reporting Database Information"



To fill in a one-input data table
This procedure produces a data table that displays results produced by substituting different
values for one variable in a formula.    You can use either a column-oriented table or a row-
oriented table.
To fill in a column-oriented table

1 In a single column, enter a list of values you want Microsoft Excel to substitute into the 
input cell.    The input cell can be any single cell in your worksheet.    

2 In the row above the first value and one cell to the right of the column of values, enter 
the formula that refers to the input cell.
Enter additional formulas to the right of the first formula in the same row.

3 Select the rectangular range containing the formula or formulas and the list of values 
to substitute.

4 From the Data menu, choose Table.
5 In the Column Input Cell box, enter the cell reference of the input cell.    

You can click the input cell to enter the reference into the Column Input Cell box.    If the
Data Table dialog box obscures the input cell, click on the title bar and drag it out of the
way.

6 Choose the OK button.
Microsoft Excel substitutes each value in the input cell and displays the result to the 
right of each input value.

To fill in a row-oriented table
1 In a single row, enter a list of values you want Microsoft Excel to substitute into the 

input cell.    
The input cell can be any single cell in your worksheet.    

2 In the column to the left of the first value and one cell below the row of values, enter 
the formula that refers to the input cell.
Enter additional formulas below the first formula in the same column.

3 Select the rectangular range containing the formula or formulas and the values to 
substitute.

4 From the Data menu, choose Table.
5 In the Row Input Cell box, enter the cell reference of the input cell.    

You can click the input cell to enter the reference into the Row Input Cell box.    If the 
Data Table dialog box obscures the input cell, click on the title bar and drag it out of the
way.

6 Choose the OK button.
Microsoft Excel substitutes each value in the input cell and displays the result beneath 
each input value. 

To reset values
Substitute new values for those you originally entered in a row or column on the 

worksheet.    The table will recalculate using the new values.
See Also

Help
Table Command (Data Menu)
User's Guide (Book 2)
Chapter 1, "Analyzing and Calculating Data"





To fill in a two-input data table
This procedure produces a data table that displays results produced by substituting different
values for two variables in a formula.    

1 In a cell, enter the formula that will refer to the substituted values.
The formula should refer to two input cells, either directly or by referring to other cells 
that refer to the input cells.    The input cells are the cells for which values will be 
substituted.

2 Starting in the cell below the formula, enter the values that you want substituted into 
one input cell.    Enter these values in the same column as the formula.

3 Starting in the cell to the right of the formula, enter the values that you want 
substituted into the other input cell.    Enter these values in the same row as the 
formula.

4 Select the range of cells containing the formula and the row and column of values.
5 From the Data menu, choose Table.
6 In the Row Input Cell box, enter the reference to the input cell for which you want the 

row of values to be substituted.
7 In the Column Input Cell box, enter the reference to the input cell for which you want 

the column of values to be substituted.
You can click the input cell to enter the reference in either box.    If the Data Table dialog
box obscures the input cell, click on the title bar and drag it out of the way.

8 Choose the OK button.
Microsoft Excel substitutes the values and displays the results in the corresponding 
row/column intersections.

To reset values
Substitute new values for those you originally entered in a row and column on the 

worksheet.    The table will recalculate using the new values.
See Also

Help
Table Command (Data Menu)
User's Guide (Book 2)
Chapter 1, "Analyzing and Calculating Data"



To find records in a database
1 Switch to the worksheet containing the database.
2 Enter the criteria you want to match in the criteria range.
3 From the Data menu, choose Find.

Microsoft Excel selects the first database record that matches the criteria.
To scroll in Find mode
The scroll bars change from a solid color to a striped pattern when Find mode is active.

Using the mouse
Click the down scroll arrow or the up scroll arrow to find the next or previous record 

matching your criteria in the database.
Click below or above the scroll box to find the next or previous matching record at 

least one window away.
Drag the scroll box to find a matching record in a particular area of the database.

Using the keyboard
Press the UP ARROW key to find the previous record, or the DOWN ARROW key to find the 

next record matching your criteria in the database.
Press the PAGE DOWN key to find the next matching record at least one window down 

from the selection.
Press the PAGE UP key to find the previous matching record at least one window up 

from the selection.
To exit Find mode

Press ESC or choose Exit Find from the Data menu.
See Also

Help
Databases
Defining a criteria range
Defining a database
Finding records using a data form
Setting up a criteria range with comparison criteria
The Find Command (Data Menu)
The Set Criteria Command (Data Menu)
The Set Database Command (Data Menu)
User's Guide (Book 1)
Chapter 9, "Creating and Using a Database on a Worksheet"
Chapter 10, "Analyzing and Reporting Database Information"



To define a criteria range
1 Switch to the worksheet containing the database.
2 Type or copy to another area of the worksheet the field names from your database that

you want to include in the criteria range. 
3 Select the entire cell range that will contain your criteria names and comparison 

criteria.
The criteria range must be at least two rows deep and one column wide, but it can be 
as large as you want. Typically this range will be two rows deep by as many columns as
the number of field names you want to include. If you include blank rows in your 
criteria range, all records will be matched.

4 From the Data menu, choose Set Criteria.
See Also

Help
Copy Command (Edit Menu)
Defining a database
Set Criteria Command (Data Menu)
Setting up a criteria range with comparison criteria
Using comparison criteria
Using computed criteria
User's Guide (Book 1)
Chapter 10, "Analyzing and Reporting Database Information."



To define an extract range
1 Switch to the worksheet containing the database.
2 Type or copy to another area of the worksheet the field names from your database that

you want to include in the extract range. 
When you extract data, only the fields you specify will be copied into the extract range.
You can specify any number of database fields as your extract range.    Be sure to 
locate your extract range away from other worksheet areas, because extracted records
will erase data below the extract range.

3 Select the extract range.
If the extract range contains only field names, all cells between the field names and the
bottom of the worksheet are cleared whether or not information is extracted into them. 
If the extract range contains additional rows under the field names, records are 
extracted only until the selected range is full.    If there are more records than will fit in 
the selected range, a message is displayed.

4 From the Data menu, choose the Set Extract command.
See Also

Help
Defining a database
Set Extract Command (Data Menu)
Extracting data from a database
User's Guide (Book 1)
Chapter 10, "Analyzing and Reporting Database Information"



To extend a series of numbers or dates
You can extend a series by using the Series command on the Data menu, or by dragging the
fill handle. The fill handle is the small black square at the bottom right of the selection.
Using the Series command on the Data menu

1 Select the first cell you want in your series.
2 Enter the starting value of the series.
3 Starting with the cell containing the starting value, select the cells in the row or column

that you want to fill.
4 From the Data menu, choose Series.
5 Under Series In, select the option you want.
6 Under Type, select the type of series.
7 If you selected the Date option under Type, select a unit under Date Unit.

If you choose the AutoFill option, the Date Unit will be ignored.
8 In the Step Value box, enter a value by which you want to increment the series.

If you choose the AutoFill option, the Step Value will be ignored.
9 To stop the series at a specific value or date, enter the value or date in the Stop Value 

box.
10 Choose the OK button.

Using the AutoFill feature
1 Select the first cell you want in your series and enter the starting value, or select two 

cells and enter the first two starting values.
2 With the cell or cells selected, drag the fill handle in the direction you want to fill. 

Microsoft Excel guesses at the type of series you want to create by the data type and 
incremental changes between cells, and fills in the rest of the selection accordingly.

See Also
Help
Creating a trend series
Series Command (Data Menu)
Turning AutoFill on or off
Using AutoFill
Using the pen with Microsoft Excel
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



To delete a graphic object
1 Select the graphic object you want to delete.

If a macro is assigned to the object you want to delete, use the Selection tool or hold 
down CTRL while clicking the object to prevent the macro from running.

2 To delete the object and place it on the Clipboard, choose Cut from the Edit menu or 
the shortcut menu.
Shortcut: CTRL+X
To delete the object without placing it on the Clipboard, choose Clear from the Edit 
menu or the shortcut menu, or press BACKSPACE or DEL.

To undo a deletion
From the Edit menu, choose Undo immediately after deleting.

See Also
Help

Selection Tool
Clear Command (Edit Menu)
Cut Command (Edit Menu)
Undo Command (Edit Menu)
Displaying and hiding a toolbar
Toolbars Command (Options Menu)



To delete cells, rows, or columns
To delete cells, rows, or columns by dragging

1 Select the range of cells you want to delete.
2 Press SHIFT and drag the fill handle (the small black square at the lower right of the 

selection) up or to the left.
To delete cells, rows, or columns with the Delete command

1 Select the cells, rows, or columns you want to delete.
2 From the Edit menu or the shortcut menu, choose Delete.

Shortcuts: Delete tool
Delete Column tool
Delete Row tool

3 If you did not select entire rows or columns, a dialog box appears allowing you to shift 
cells left or up to fill the space occupied by the deleted cells, or to delete entire rows or
columns.    Select the option you want and choose the OK button.

See Also
Help

Delete Column Tool
Delete Row Tool
Delete Tool

Adding and deleting a tool from a toolbar
Delete Command
Displaying and hiding a toolbar
Inserting a column or row
Selecting cells, rows, or columns
Toolbars Command (Options Menu)
Turning drag and drop on or off
Using drag and drop



To edit cell contents
1 Click the cell containing the data you want to edit.

You can also use the arrow keys to select the cell.
2 Click to position the insertion point in the formula bar.

You can also press F2 to activate the formula bar, and then use the arrow keys to 
position the insertion point in the formula bar.

3 Edit the cell contents.
4 To enter your changes into the cell, click the enter box or press ENTER.
5 To cancel edits, click the cancel box or press ESC.

To edit in the formula bar
To delete Press
The character to the right DEL
To the end of the line CTRL+DEL
The character to the left BACKSPACE



To enter and edit an array formula
Array formulas can take the place of several single-value formulas, reducing the amount of 
time you spend entering repetitive formulas.    You can use array formulas to perform an 
operation that produces multiple results or to operate on a group of arguments arranged in 
rows and columns.
To enter an array formula

1 Select the cell or range of cells in which you want to enter the formula.
2 Enter the formula.

Make sure that each argument or operand includes the entire cell, range, or set of 
values you want used for the operation or function.    Microsoft Excel adds the braces 
when you enter the formula as an array formula; do not type the braces around the 
formula.    If you type the braces, Microsoft Excel interprets the entry as text.    

3 Press CTRL+SHIFT+RETURN.
You must hold down both CTRL and SHIFT when you press ENTER.    If you hold down only 
SHIFT, the formula is entered as an ordinary formula in the active cell.    If you hold down
only CTRL, the formula is entered as an ordinary formula in all the selected cells.

To edit an array formula
1 Select any cell in the array range.
2 Activate the formula bar.

The array formula braces disappear when the formula bar is active.
3 Edit the formula.
4 Press CTRL+SHIFT+RETURN.

See Also
Help
Selecting a range of cells
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



To freeze and unfreeze panes
1 Switch to the window on which you want to freeze the panes.
2 If the window is not split, select a cell where you want to split the window.
3 From the Window menu, choose Freeze Panes.

Shortcut: Freeze Panes tool
To unfreeze panes

1 Switch to the window in which you want to unfreeze the frozen panes.
2 From the Window menu, choose Unfreeze Panes.

Shortcut: Freeze Panes tool
See Also

Help

Freeze Panes Tool
Freeze Panes and Unfreeze Panes Commands (Window Menu)
Freezing and unfreezing worksheet titles

User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



To freeze and unfreeze worksheet titles
You do not have to split the window into panes before freezing worksheet titles.
To freeze both column and row titles and automatically split the window

1 Switch to the window on which you want to freeze the titles.
2 Select a cell where you want to split the window.
3 From the Window menu, choose Freeze Panes.

The window is automatically split above and to the left of the active cell, and the titles 
are frozen.
If you split the window before freezing panes, the panes are frozen at their current 
location, not at the active cell.
Shortcut: Freeze Panes tool

To freeze horizontal or vertical titles only
1 Select a row (to freeze the horizontal pane) or column (to freeze the vertical pane).
2 From the Window menu, choose Freeze Panes.

Shortcut: Freeze Panes tool
To unfreeze titles
When a worksheet window that has frozen titles is active, the Freeze Panes command 
changes to the Unfreeze Panes command.

1 Switch to the window with frozen titles or frozen panes.
2 From the Window menu, choose Unfreeze Panes.

Shortcut: Freeze Panes tool
If you split the window before choosing the Freeze Panes command, the split panes 
remain.    
If you split the window with the Freeze Panes command, all panes are removed.

See Also
Help

Freeze Panes Tool
Freeze Panes and Unfreeze Panes Commands (Window Menu)
Freezing and unfreezing panes 

User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



To define a name
1 Select the cell, range, or nonadjacent selection for which you want to define a name.
2 From the Formula menu, choose Define Name.

Shortcut: CTRL+F3
3 In the Name box, type a name or accept the proposed name.

If the active cell, or a cell immediately above or to the left of the active cell contains 
text, Microsoft Excel proposes that text as the name.

4 In the Refers To box, type the cell reference or accept the proposed reference.
Microsoft Excel proposes the selected cell or range as the cell reference.    If you type a 
reference, it must begin with an equal sign (=), just like a formula.

5 If you want to define more names, choose the Add button to add the name and repeat 
steps 3 through 4.
--or--
Choose the OK button to add the name and close the dialog box.

See Also
Help
Creating names
Define Name Command (Formula Menu)
Defining a macro name
Deleting a name
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



To delete a note
1 Select the cell containing the note you want to delete.
2 From the Edit or shortcut menu, choose Clear.

Shortcut: DELETE
3 Select the Notes option.
4 Choose the OK button.
--Or--
1 From the Formula menu, choose Note.
2 In the Notes In Sheet box, select the note you want to delete.
3 Choose the Delete button.    

Microsoft Excel displays a message warning you that the note will be permanently 
deleted.

4 To confirm the deletion, choose the OK button.    
To cancel the deletion and return to the Cell Note dialog box, choose the Cancel button.

5 Repeat steps 2 through 4 for each note you want to delete.
6 When you are finished deleting notes, choose the Close button to close the dialog box.

See Also
Help
Creating or editing a note
Creating a sound note
Note Command (Formula Menu)
Removing a sound note
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



To display an outline level
This procedure requires a mouse. 

To display up to a specific level of rows or columns, click the row or column level 
button representing that level.

To display all levels, click the button for the outline's lowest level (the highest 
number).
    Outline level 1

    Outline level 2
    Outline level 3
    Outline level 4
    Outline level 5
    Outline level 6
    Outline level 7
    Outline level 8

See Also
Help

            Show Outline Symbols Tool  
Assigning an outline level to a row or column
Clearing an outline from a worksheet
Collapsing an outline level
Creating an outline from a existing worksheet
Displaying or hiding outline symbols
Expanding an outline level
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



To display or hide outline symbols
Outline symbols are displayed by default when your worksheet contains an outline.

1 From the Options menu, choose Display.
2 To display outline symbols, select the Outline Symbols check box.

To hide outline symbols, clear the Outline Symbols check box.
3 Choose the OK button.

Shortcuts: CTRL+8 
Show Outline Symbols tool (Utility toolbar)

See Also
Help

            Show Outline Symbols Tool  
Assigning an outline level to a row or column
Clearing an outline from a worksheet
Collapsing an outline level
Creating an outline from a existing worksheet
Displaying an outline level
Expanding an outline level
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



To expand an outline level
This procedure requires a mouse. 

Click the expand button.    
Click the outline level button.    

A plus sign next to a row or column indicates that there are hidden outline levels 
subordinate to that row or column.    You can display the hidden levels by expanding any 
outline level that has a plus sign next to it. Click the numbered outline level button in the 
upper-right corner of the window to display only up to that outline level.
See Also

Help
            Show Outline Symbols Tool  

Assigning an outline level to a row or column
Collapsing an outline level
Creating an outline from an existing worksheet
Displaying an outline level
Displaying or hiding outline symbols
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



To find cells referred to by formulas in selected cells (precedents)
1 Select the cell or cells containing formulas whose precedents you want to find.

If you select more than one cell, Microsoft Excel selects all cells in the worksheet that 
are precedents for any of the selected cells.

2 From the Formula menu, choose Select Special.
Shortcuts: CTRL+[    (direct precedents)

CTRL+SHIFT+{    (all levels of precedents)
3 Select the Precedents option button.
4 Select the Direct Only option button to find only cells that are specifically referred to by

formulas in the selected cells.
Select the All Levels option button to find all cells that are either directly or indirectly 
referred to by formulas in the selected cells, including precedents of precedents.

5 Choose the OK button.
See Also

Help
Select Special Command (Formula Menu)
Finding cells with formulas that refer to selected cells (dependents)
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"
Chapter 8, "Organizing and Documenting a Worksheet"



To find cells with formulas that refer to selected cells (dependents)
1 Select the cell or cells whose dependents you want to find.

If you select more than one cell, Microsoft Excel selects all cells in the worksheet that 
are dependents of any of the selected cells. 

2 From the Formula menu, choose Select Special.
Shortcuts: CTRL+]    (direct dependents)

CTRL+SHIFT+}    (all levels of dependents)
3 Select the Dependents option button.
4 Select the Direct Only option button to find only cells containing formulas that 

specifically refer to the selected cells.
Select the All Levels option button to find all cells containing formulas that either 
directly or indirectly refer to selected cells, including dependents of dependents.

5 Choose the OK button.
See Also

Help
Select Special Command (Formula Menu)
Finding cells referred to by formulas in selected cells (precedents)
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"
Chapter 8, "Organizing and Documenting a Worksheet"



To delete a name
You cannot undo deleting a name.

1 From the Formula menu, choose Define Name.
Shortcut: CTRL+F3

2 In the Names In Sheet box, select the name you want to delete.
3 Choose the Delete button.

Repeat steps 2 and 3 for each name you want to delete.
4 Choose the Close button.

See Also
Help
Define Name Command (Formula Menu)
Defining a name
Defining a macro name
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



To define a macro name
1 Select the cells in the macro sheet containing the macro you want to name.
2 From the Formula menu, choose Define Name.

Shortcut: CTRL+F3
3 In the Name box, type the macro name or accept the proposed name.

If the active cell, or a cell immediately above or to the left of the active cell contains 
text, Microsoft Excel proposes that text as the name.

4 In the Refers To box, type the cell reference or accept the proposed reference.
Microsoft Excel proposes the selected cell or range as the cell reference.    If you type a 
reference, it must begin with an equal sign (=), just like a formula.

5 In the Macro box, select the Command option button, the Function option button, or 
accept the default None option button.

6 If you want to specify a shortcut key for running the macro, type a letter or a number in
the Key: Ctrl+ box.
If you chose the Function or None option, shortcut keys are not available.

7 In the Category box, select a category appropriate for the macro you are defining, or 
accept the default category, User Defined.
Your macro must be defined as either a command macro or a custom function to assign
it a category.    After you assign a category, your macro appears in the Paste Function 
dialog box under that category when a macro sheet is active. If you defined a custom 
function, it also appears in the Paste Function dialog box while a worksheet is active.

8 If you want to define more names, choose the Add button and repeat steps 1 through 
7.
--or--
Choose the OK button to add the macro name and close the dialog box.

See Also
Help
Define Name Command (Formula Menu)
Defining a name
Deleting a name
Running a macro
Macros
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



To find characters
1 Select the area of the worksheet or macro sheet you want to search.

If only one cell is selected, Microsoft Excel searches the entire worksheet.
2 From the Formula menu, choose Find.

Shortcut: SHIFT+F5
3 In the Find What box, type the characters you want to search for.

You can include any letter, number, punctuation mark, or wildcard character in your 
search. To search for an actual wildcard character (* or ?), precede it with a tilde (~).

4 Under Look In, select Formulas, Values, or Notes.
Microsoft Excel searches for the characters you type in only the location you specify.

5 Under Look At, select Whole or Part.
If you select the Whole option, Microsoft Excel finds only exact and complete matches 
of the specified characters. If you select the Part option, Microsoft Excel finds any 
occurrences of the specified characters, including partial occurrences within other 
strings of characters.

6 Under Look By, select the direction in which you want Microsoft Excel to search, either 
across rows or down columns.
If you hold down SHIFT while choosing the OK button, Microsoft Excel reverses the 
direction, searching right to left across rows or up columns.

7 Select the Match Case check box if you want Microsoft Excel to use the exact 
combination of uppercase and lowercase characters you entered in the Find What box.

8 Choose the OK button.
9 To find the next occurrence of the characters, choose the Find command again, or 

choose Repeat Find from the Edit menu.
Shortcuts: F7 (next occurrence)

SHIFT+F7 (previous occurrence)
See Also

Help
Find Command (Formula Menu)
Replacing characters
User's Guide (Book 1)
Chapter 5,    "Creating a Worksheet"
Chapter 6,    "Editing a Worksheet"



To display or hide note indicators
Note indicators appear in the upper-right corner of cells with attached notes.

1 From the Options menu, choose Workspace.
2 Under Display, select the Note Indicator check box to display note indicators.

To hide note indicators, clear the Note Indicator check box.
3 Choose the OK button.

See Also
Help
Copying a text or sound note to another cell
Creating or editing a note
Creating a sound note
Deleting a note
Note Command (Formula Menu)
Playing a sound note
Removing a sound note
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



To format cells
Using menu commands

1 Select the cells you want to format.
2 From the Format menu or the shortcut menu, choose the appropriate command.
3 Select the options you want.
4 Choose the OK button.

Using AutoFormat
Use AutoFormat when you want to format cells that make up a table.

1 Select the cells you want to format.
2 From the Format menu, choose AutoFormat.

Shortcut: AutoFormat tool (Standard or Formatting toolbar).    Applies the last 
AutoFormat used.

3 Select the type of format you want from the Table Format box.
The Sample box displays an example of what the selected format looks like.

4 Choose the OK button.
Using a tool
To do this procedure, you must have a toolbar that contains the formatting tool displayed.

1 Select the cells you want to format.
2 Click the appropriate tool for the formatting change you want to make.

See Also
Help

AutoFormat Tool
Format Menu for Worksheets
Formatting Toolbar
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



To format text box borders and fill patterns
1 Select the text box.

To select a graphic object with a macro assigned to it, hold down CTRL while clicking the
object.

2 From the Format menu or the shortcut menu, choose Patterns.
3 Select the border and fill pattern options you want.

If you want Microsoft Excel to select the options for you, select the Automatic option 
button.

4 Choose the OK button to apply your changes.
To apply your changes and specify additional formatting, choose the Font or Text 
button.



To format a table using AutoFormat
1 Select the range on the worksheet you want to format.

If you select a single cell, Microsoft Excel will guess the range for you.    You cannot 
automatically format a nonadjacent selection.

2 From the Format menu, choose AutoFormat.
3 In the Table Format box, select the type of format you want.

The Sample box displays an example of what the selected format looks like.
4 Choose the OK button.

Shortcut: AutoFormat tool (Standard or Formatting toolbar).    Applies the last 
AutoFormat used.

See Also
Help

AutoFormat Tool
AutoFormat Command (Format Menu for Worksheets)
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



To delete a chart document or an embedded chart
To delete a chart document

1 From the File menu, choose Delete.
2 In the Files box, select the chart you want to delete.

To list only charts in the Files box, type *.xlc in the File Name box and choose the OK 
button.
If the chart you want to delete is not listed in the Files box, switch to the drive or 
directory containing the chart by selecting the drive or directory in the Directories box 
and choosing the OK button.    For more information about working with directories, see 
"Opening an Existing Chart" in Chapter 13 of Book 1 of the Microsoft Excel User's 
Guide.

3 Choose the OK button.
Microsoft Excel asks for confirmation before deleting the chart.    After you delete a 
chart, the Delete dialog box remains on the screen so you can select and delete other 
charts.

4 To close the dialog box, choose the Close button.
To delete an embedded chart from a worksheet

1 Open the worksheet containing the embedded chart.
2 Select the embedded chart.
3 From the Edit menu or the shortcut menu, choose Clear.

Microsoft Excel removes the embedded chart from the worksheet.
Shortcut: DEL

To clear chart data or formats
1 Switch to the chart window.

If the chart is embedded on a worksheet, double-click the chart to display it in a chart 
window.

2 Select the entire chart.
3 From the Edit menu or the shortcut menu, choose Clear.

Shortcuts: DEL
4 To clear both the chart data and its formats, select the All option button.

To clear the formats and keep the chart data, select the Formats option button.
To clear the chart data and keep the formats, select the Formulas option button.

5 Choose the OK button.
See Also

Help
Delete Command (File Menu)
Clear Command (Edit Menu)
User's Guide (Book 1)
Chapter 13, "Editing a Chart"



To delete a data series
Deleting a data series from a chart does not delete the source data from the worksheet.
To delete a data series using the Clear command on the Edit menu

1 Select the data series you want to delete.
2 From the Edit menu or the shortcut menu, choose Clear.

Shortcuts: DELETE
DEL

3 Select the Series option button.
4 Choose the OK button.

Microsoft Excel deletes the data series and redraws the chart.
To delete a data series using the Edit Series command on the Chart menu

1 Select the data series you want to delete.
2 From the Chart menu or the shortcut menu, choose Edit series.
3 Choose the Delete button.

Microsoft Excel deletes the data series and redraws the chart.
4 To delete additional data series, select the series you want to delete in the Series box 

and choose the Delete button.
To close the dialog box, choose the Close button.

See Also
Help
Clear Command (Edit Menu)
Edit Series Command (Chart Menu)
User's Guide (Book 1)
Chapter 13, "Editing a Chart"



To disable updating of all links to other applications on a worksheet
This procedure affects the active dependent worksheet only.

1 Switch to the dependent worksheet containing the remote references.
2 From the Options menu, choose Calculation.
3 Clear the Update Remote References check box.
4 Choose the OK button.

When the Update Remote References check box is cleared, Microsoft Excel uses the 
last value from the source documents for the remote references.

To disable updating on a single link
This procedure affects the active dependent worksheet only.

1 Switch to the dependent worksheet containing the remote reference.
2 From the File menu, choose Links.
3 In the Link Type box, select DDE Links.
4 In the Links box, select the link you want to disable.
5 Choose the Options button.
6 Clear the Automatic check box.
7 Choose the OK button.

See Also
Help
Controlling remote requests
Creating links between documents
Opening source documents for the active worksheet
Recalculating linked worksheets
Redirecting links for source documents
Updating linked information
Viewing a list of source documents for a dependent worksheet
User's Guide (Book 1)
Chapter 11, "Working with Multiple Microsoft Excel Documents"
User's Guide (Book 2)
Chapter 3, "Exchanging Data with Other Applications"



To display or hide chart axes
1 From the Chart menu, or the axis or plot area shortcut menu, choose Axes.

If the chart is embedded in a worksheet, double-click the chart to display it in a chart 
window.

2 Under Main Chart, select the check boxes for the axes you want to display.    Clear the 
check boxes for the axes you don't want to display.
If there is an overlay chart, select or clear the check boxes under Overlay.

3 Choose the OK button.
You can also delete an axis by selecting it and choosing Clear from the Edit menu or the 
shortcut menu.

See Also
Help
Axes Command (Chart Menu)
Clear Command (Edit Menu for Charts)



To draw lines, ovals, arcs, or rectangles
To do these procedures, you must have the Line tool, the Oval tool, the Arc tool or the 
Rectangle tool displayed.    These tools are on the Drawing toolbar, or you can add them to a
toolbar of your choice.
To draw a line, oval, arc, or rectangle

1 Click the drawing tool you want.
The mouse pointer changes to a cross hair.

2 Position the cross-hair pointer where you want to start drawing.
3 To restrict lines to horizontal, vertical, or 45-degree angles; the ovals and arcs to 

circles; or    the rectangles to squares, hold down SHIFT while you draw.
4 Drag until the object is the size and shape you want.

When you release the mouse button, the graphic object is displayed and automatically 
selected.
If you want the graphic object that you are drawing to adjust automatically to fit the 
nearest row and column, hold down the ALT key while dragging.

To draw multiple lines, ovals, arcs, or rectangles
1 Double-click the drawing tool you want.
2 Draw the first graphic object.

When you release the mouse button, the drawing tool stays selected and the pointer 
remains a cross hair.

3 Repeat step 2 to draw additional objects of the same kind.
4 When you finish drawing the last object, cancel the drawing tool selection by clicking 

the same tool again, clicking another tool, pressing ESC, or clicking another part of the 
worksheet without dragging.
The drawing tool is no longer selected.    The last object you drew is selected and the 
regular mouse pointer reappears.

See Also
Help

Line Tool
Oval Tool
Arc Tool
Rectangle Tool

Adding and deleting a tool from a toolbar
Displaying and hiding a toolbar
Drawing Toolbar
Toolbars Command (Options Menu)
Tools
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



To edit chart text
1 Select the text you want to edit.

If the text is linked to a worksheet cell, switch to the worksheet and then select the cell
the text is linked to.

2 Click the formula bar or press F2 to activate it.
If you don't activate the formula bar, all the existing text is replaced with the new text 
you type.

3 Edit the text in the formula bar, using the same techniques you use for editing 
worksheet cell contents.

4 Click the enter box or press ENTER.
See Also

Help
Editing cell contents
User's Guide (Book 1)
Chapter 13, "Editing a Chart"



To format a chart embedded in a worksheet
1 Double-click the embedded chart.

Microsoft Excel opens a window for the embedded chart.
2 Change the chart type or format the chart using the commands on the Chart and 

Format menus or the tools on the Chart toolbar.
In the chart window, you can also save the embedded chart as a separate document.    
If you close the chart window without saving, the embedded chart remains in the 
worksheet and changes you made to the chart will be saved when you save the 
worksheet.    If you delete the embedded chart from the worksheet, the chart window is
closed automatically.

See Also
Help
Chart Menu
Format Menu for Charts
Chart Toolbar
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



To format a legend
1 Switch to the chart window.

If the chart is embedded on a worksheet, double-click the chart to display it in a chart 
window.

2 Double-click the legend to display the Patterns dialog box.
You can also click the legend to select it, and then choose Patterns from the Format 
menu or the shortcut menu.

3 Select the border and area options you want.
If you want Microsoft Excel to select the options for you, select the Automatic option 
button under Border or Area.

4 Choose the OK button.
You can also choose the Font button to apply your changes and open the Font dialog 
box to format the font of the legend, or you can choose the Legend button to apply 
your changes and open the Legend dialog box to reposition the legend.

See Also
Help
Adding or deleting a legend
Font Command (Format Menu for Charts)
Legend Command (Format Menu for Charts)
Patterns Command (Format Menu for Charts)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



To format axis patterns and tick mark and label location
1 Switch to the chart window.

If the chart is embedded in a worksheet, double-click the chart to display it in a chart 
window.

2 Double-click the axis to display the Patterns dialog box.
You can also select the axis and then choose the Patterns command from the Format 
menu or the shortcut menu.

3 Under Axis, select the style, color, and weight you want for the axis line.
If you want Microsoft Excel to select the options for you, select the Automatic option 
button.

4 Under Tick Mark Type, select the alignment (relative to the axis line) you want for major
and minor tick marks.

5 Under Tick Labels, select the position on the chart where you want the tick-mark labels 
to appear.

6 Choose the OK button.
You can control the number and position of tick marks with the Scale command from 
the Format menu.

See Also
Help
Formatting an axis scale
Formatting the chart text font
Patterns Command (Format Menu for Charts)
Scale Command (Format Menu for Charts)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



To format a chart arrow
1 Switch to the chart window.

If the chart is embedded in a worksheet, double-click the chart to display it in a chart 
window.

2 Double-click the arrow to display the Patterns dialog box.
You can also click the arrow to select it, and then choose Patterns from the Format 
menu or the shortcut menu.

3 Under Line, select the style, color, and weight options you want for the arrow shaft.
If you want Microsoft Excel to select the options for you, select the Automatic option 
button.

4 Under Arrow Head, select the style, width, and length options you want for the 
arrowhead.

5 Choose the OK button.
See Also

Help
Patterns Command (Format Menu for Charts)
Adding or deleting a chart arrow
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



To format data markers in a chart
To format data markers

1 Double-click any marker in the data series to display the Patterns dialog box.
You can also click a marker to select it and then choose Patterns from the Format 
menu.
To format a single marker, hold down CTRL and double-click the marker.

2 Select the options you want.
If you want Microsoft Excel to select the options for you, select the Automatic option 
button.

3 To apply your selected formats to all markers in the chart, select the Apply To All check 
box.

4 Choose the OK button.
To clear the data marker formats

1 Select the marker or data series you want to clear.
2 From the Edit menu or the shortcut menu, choose Clear.

Shortcut: DEL
3 Select the Formats option button.
4 Choose the OK button.

If you selected a data series, the formatting for the series returns to the original 
formatting.
If you selected a single data marker with formatting different from the other markers in
its series, Microsoft Excel formats that marker the same as the other markers in the 
series.

See Also
Help
Clear Command (Edit Menu)
Patterns Command (Format Menu for Charts)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



To format chart text alignment and orientation
1 Click the text to select it.
2 From the Format menu or the shortcut menu, choose Text.
3 Select the Text Alignment options and the Orientation option you want.

Shortcuts: Center Align tool
Left Align tool
Right Align tool

4 Choose the OK button.
See Also

Help
Center Align Tool
Left Align Tool
Right Align Tool

Text Command (Format Menu for Charts)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



To format tick-mark label orientation
1 Double-click the axis you want to format.    In the Patterns dialog box, choose the Text 

button.
You can also select the axis and then choose Text from the Format menu or the shortcut
menu.

2 Choose the Text button.
3 Under Orientation, select the text orientation you want.

If you want Microsoft Excel to select the orientation for you based on the current size 
and orientation of the plot area, leave the Automatic option button selected.

4 Choose the OK button.

See Also
Help
Formatting an axis scale
Formatting axis patterns and tick mark and label location
Text Command (Format Menu)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



To format the chart text font
1 To format all text in the chart, choose Select Chart from the Chart menu.

To format a single piece of attached or unattached text, select the text.
To format tick-mark labels for an axis, select the axis.
To format text that appears in a legend, select the legend.

2 From the Format menu or the shortcut menu, choose Font.
3 Under Font, select the font you want.

Printer fonts are indicated by a printer graphic next to the font name.      TrueType fonts 
are indicated by a TrueType logo next to the font name.
If the font you want is not listed, type the font name in the Font box.

4 Under Size, select the font size you want.
If the font size you want is not listed, type the size in the Size box.    If the size you want
is not available on the printer, another size may be substituted when you print the 
document.

5 Select the other style or color effects you want.
6 Choose the OK button.
Note    You can also use the Bold, Italic, Increase Font, and Decrease Font tools to change 
the size and style of the selected text.

See Also
Help

Bold Tool
Decrease Font Size Tool
Increase Font Size Tool
Italic Tool

Font Command (Format Menu for Charts)
Select Chart Command (Chart Menu)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



To format the data marker layout
1 To format the data markers on the main chart, choose Main Chart from the Format 

menu.
To format the data markers on the overlay chart, choose Overlay from the Format 
menu.

2 Select the options you want.    Only those options that apply to the selected chart type 
are available in the dialog box.

3 Choose the OK button.
Some of the more common options are included in this table.    See the Main Chart and 
Overlay Chart topics for more information.
Option Effect
Overlap Amount that columns overlap
Gap Width Thickness of columns (the larger the gap, the thinner the columns)
Gap Depth Spacing between 3-D columns
Chart Depth Shape of the base of a 3-D chart
Drop Lines Add droplines to a line or area chart
Hi-Lo Lines Add hi-lo lines to a line chart

See Also
Help
Main Chart Command (Format Menu)
Overlay Chart Command (Format Menu)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



To format gridlines
1 Switch to the chart window.

If the chart is embedded in a worksheet, double-click the chart to display it in a chart 
window.

2 To format all major gridlines for an axis, double-click one of the major gridlines for the 
axis to display the Patterns dialog box. To format all minor gridlines, double-click a 
minor gridline.    You can also select the gridline and choose Patterns from the Format 
menu or the shortcut menu.

3 Under Custom, select the style, color, and weight options you want.
If you want Microsoft Excel to select the options for you, select the Automatic option 
button.

4 Choose the OK button.
See Also

Help
Adding or deleting gridlines
Patterns Command (Format Menu for Charts)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



To format an axis scale
1 Switch to the chart window.

If the chart is embedded in a worksheet, double-click the chart to display it in a chart 
window.

2 Double-click the axis you want to format to display the Patterns dialog box.    In the 
Patterns dialog box, click the Scale button.
You can also select the axis and then choose Scale from the Format menu or the 
shortcut menu.
The options available in the dialog box vary depending on the type of axis you have 
selected.

3 Type values, or select or clear check boxes, to achieve the format you want.
4 Choose the OK button.

See Also
Help
Scale Command (Format Menu)
Formatting axis patterns and tick mark and label location
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



To format the plot area, 3-D walls, or 3-D floor
1 Double-click the plot area, walls, or floor to display the Patterns dialog box.

You can also select the plot area, 3-D walls, or 3-D floor and then choose Patterns from 
the Format menu or the shortcut menu.

2 Select the border and area options you want.
If you want Microsoft Excel to select the options for you, select the Automatic option 
button under Border or Area.

3 Choose the OK button.
See Also

Help
Patterns Command (Format Menu for Charts)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



To delete a file from a disk
1 From the File menu, choose Delete.
2 In the File Name box, type the name of the file you want to delete or select it from the 

list.
3 Choose the OK button.
4 To confirm the deletion, choose the Yes button.
5 To close the dialog box, choose the Close button.

See Also
Help
Delete Command (File Menu)



To edit a template
1 From the File menu, choose Open.
2 Select the template you want to change.
3 Hold down SHIFT and choose the OK button.

Microsoft Excel opens the original template for editing.
4 Edit the template.
5 From the File menu, choose Save.

Microsoft Excel saves the changes to the template.
See Also

Help
Creating a new template
Saving a document as a template
Using a template
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



To edit worksheets as a group
When you edit worksheets and macro sheets as a group, you can use many of the Microsoft 
Excel editing, file management, and formatting commands to complete your work more 
quickly.    All your changes in the active sheet are duplicated in the rest of the sheets in the 
group.
For a complete list of commands that you can use in a group editing session, see Chapter 
11, "Working with Multiple Microsoft Excel Documents," in Book 1 of the Microsoft Excel 
User's Guide.
To edit worksheets or macro sheets as a group

1 Start a group editing session.
2 In the active worksheet, select the cells in which you want to enter, change, delete, or 

format data.
Microsoft Excel selects the cells in the same location on all sheets in the group, though 
you only see the selection in the active sheet.

3 Enter, change, delete, or format data in the active worksheet or macro sheet.
The changes you make in the active sheet are made in the same location in all sheets 
in group.

See Also
Help
Copying data and formats to all sheets in a group
Starting or ending a group editing session
User's Guide (Book 1)
Chapter 11, "Working with Multiple Microsoft Excel Documents"



To export a document to another application
1 From the File menu, choose Save As.
2 In the File Name box, type a name for the document or accept the proposed name.
3 In the Save File As Type box, select the file format of the other application.
4 Choose the OK button to save the document in the format you specified.

You can now open the Microsoft Excel document in the other application.
To export data from Microsoft Excel to other applications using the Clipboard

1 Switch to the Microsoft Excel window that contains the information you want to export.
2 Select the data, chart, or object you want to copy.
3 From the Edit menu, choose Cut or Copy.

To copy a picture of data, hold down SHIFT and choose Copy Picture from the Edit menu.
4 Switch to the document or application to which you want to export.
5 Paste the information using the procedure for pasting in the application you are pasting

to.
See Also

Help
Clipboard
Copy Picture Command (Edit Menu)
Importing and Exporting
Linking and Embedding
Save As Command (File Menu)
Saving a file for use by another application
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



To edit a group of worksheets in a workbook
1 In the lower-right corner of the workbook document window or Workbook Contents 

window, click any of the buttons with the right mouse button.    A menu appears.
2 From this menu, choose Group Edit.

Instead of doing steps 1 and 2, you can also choose the Group Edit command from the 
Options menu while a workbook is active.
The Group Edit dialog box appears.    All worksheets in the workbook are selected.

3 To add or delete a worksheet from the selection, hold down CTRL and click the 
worksheet name.

4 Choose the OK button.
5 Edit the active worksheet.

Any changes you make will also be made in the other selected worksheets.
6 To end group editing, move to another document in the workbook by clicking one of the

paging buttons in the lower-right corner of the window.
See Also

Help
Workbooks
Group Edit Command (Options Menu)
Moving between workbook documents



To embed a Microsoft Excel object in another document
1 Open the document in which you want the object embedded, and the Microsoft Excel 

document containing the object you want to embed.
If you are embedding a Microsoft Excel object in another application, you must be 
running that application with Windows and the application must support embedding.

2 Switch to the Microsoft Excel document containing the object you want to embed.
3 Select the cell, cell range, chart, or entire worksheet you want to embed.
4 From the Edit menu or the shortcut menu, choose Copy.

Shortcuts: Copy tool (Utility toolbar)
CTRL+C

A moving border appears around the selection.
5 Switch to the document in which you want the object embedded.
6 Position the insertion point where you want to embed the Microsoft Excel object.
7 Follow the application's procedure for embedding an object.

See Also
Help

Copy Tool
Copy Command (Edit Menu)
Editing a Microsoft Excel object embedded in another document
Linking and Embedding

User's Guide (Book 2)
Chapter 3, "Exchanging Data with Other Applications"



To enter a formula
1 Select the cell in which you want to enter the formula.
2 Type an equal sign (=) to activate the formula bar.

If you begin a formula by pasting a name or function, Microsoft Excel automatically 
inserts the equal sign.

3 Type the formula or use any of the following pasting techniques to enter a formula into 
the formula bar:
Insert references into your formula by selecting cells on your worksheet.    When you 
select cells, Microsoft Excel inserts relative references in your formula.
From the Edit menu, choose Paste to paste characters that you previously copied from 
another formula or application.
From the Formula menu, choose Paste Function.    In the Paste Function list box, select 
the worksheet function you want, and then choose OK.
From the Formula menu, choose Paste Name.    In the Paste Name list box, select the 
name you want to paste, and then choose OK.

4 After you have completed the formula, press ENTER.
Note    If you type the name of the function up to the left parenthesis, you can then press 
CTRL+A and Microsoft Excel will paste the names of the arguments for that function into 
the formula bar.
Note    To enter a formula as text, type a single quotation mark before the entry.

See Also
Help
Editing cell contents
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



To enter text or numbers into a cell
1 Select the cell in which you want to enter text or numbers.
2 Type the text or numbers.

The data you type appears in the formula bar and in the active cell.
3 Click the enter box or press ENTER.

Click the cancel box or press ESC to clear the data from the formula bar and the cell.
Note    To enter a number, string, or formula as text, type a single quotation mark before 
the entry.

See Also
Help
Editing cell contents
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



To edit a report
1 From the File menu, choose Print Report.

If the Print Report command does not appear on the File menu, run the Setup program 
to install it.

2 In the Reports box, select the report you want to edit.
3 Choose the Edit button.
4 In the Current Sections box, select the section you want to edit.
5 Under Report Section, edit the report by selecting the views and the scenarios that you 

want.
6 Choose the Add button to add the edited section to the Current Sections list.
7 Repeat steps 4 through 6 to edit any additional sections.
8 If you want a section to appear in a different order in the list, select the section that 

you want to move and use the Move Up or Move Down button to move the section.
You can also choose the Delete button to delete a section.

9 If you want pages to be numbered consecutively, select the Continuous Page Numbers 
check box.

10 Choose the OK button to close the Edit Report dialog box.
11 Choose the Print button to print the selected report.

--or--
Choose the Close button to close the dialog box without printing.

See Also
Help
Creating a report
Creating a view of a worksheet
Print Report Command (File Menu)
Printing a report
Scenario Manager Command (Formula Menu)
View Command (Window Menu)
User's Guide (Book 1)
Chapter 1, "Getting Started With Microsoft Excel"
Chapter 16, "Printing"



To embed an object in a Microsoft Excel document
To embed a new object

1 In Microsoft Excel, choose Insert Object from the Edit menu.
Microsoft Excel displays a list of objects you can embed. This list depends on the 
applications you have installed.

2 Select the type of object you want to embed.
3 Choose the OK button.

Microsoft Excel starts the other application and opens a blank object.
4 Format the object to look the way you want.
5 In the application in which you are editing the object, choose Close or Exit from the File 

menu.
Embedding and updating commands may vary between applications.    Check the 
application's documentation for additional information about embedding.

To embed an existing object
1 Open the document containing the object you want to embed.

If you are embedding an object from another application, you must be running that 
application with Windows and the application must support embedding.

2 Follow the application's procedure for selecting and copying the object.
3 Switch to the Microsoft Excel document in which you want to embed the object.
4 Select a cell or a graphic object that is located where you want to embed the object.
5 From the Edit menu, choose Paste Special.
6 In the Data Type box, select the object data type.
7 Choose the Paste button.

See Also
Help
Editing an object embedded in a Microsoft Excel document
Insert Object Command (Edit Menu)
Linking and Embedding
Links Command (File Menu)
Paste Special Command (Edit Menu)
User's Guide (Book 2)
Chapter 3, "Exchanging Data with Other Applications"



To edit a Microsoft Excel object embedded in another document
1 Follow the application's procedure for opening an embedded object for editing.

For example, in Microsoft Word, double-click the object, or select the object and choose
Microsoft Excel Object from the Edit menu.
Microsoft Excel starts and displays the data in a Microsoft Excel document.

2 Edit the document using Microsoft Excel commands.
To edit chart data or update it from the source worksheet, choose Links from the File 
menu and choose the Open button or the Update button.    The chart data is 
automatically updated from the source worksheet as long as the source worksheet is 
open.

3 If you want to close the Microsoft Excel document and update the object in the other 
application, choose Close from the File menu.
If you want to quit Microsoft Excel, choose Exit from the File menu.    Microsoft Excel 
asks if you want to update the object in the other application.
If you want to update the object in the other application, but leave the Microsoft Excel 
document on the screen, choose Update from the File menu.

See Also
Help
Close Command (File Menu)
Editing an object embedded in Microsoft Excel
Embedding a Microsoft Excel object in another document
Exit Command (File Menu)
Linking and Embedding
Links Command (File Menu)
Update Command (File Menu)
User's Guide (Book 2)
Chapter 3, "Exchanging Data with Other Applications"



To edit an object embedded in a Microsoft Excel document
1 Double-click the embedded object, or choose Edit Object from the shortcut menu.

Microsoft Excel starts the application used to create the object and the object is 
displayed in that application.

2 Use the commands in the other application to edit or format the object.
3 Follow the procedure in the other application for updating the object in Microsoft Excel.

For example, in Microsoft Word, choose Close or Exit from the File menu.
To delete an object embedded in Microsoft Excel

1 Select the embedded object.
2 From the Edit menu or the shortcut menu, choose Clear or press the DEL key.

See Also
Help
Clear Command (Edit Menu)
Embedding an object in a Microsoft Excel document
Linking and Embedding
User's Guide (Book 2)
Chapter 3, "Exchanging Data with Other Applications"



To open an add-in macro as a regular macro sheet
1 From the File menu, choose Open.

Add-in macros have .XLA, .XLL, or .DLL extensions.    Only add-in macros with .XLA 
extensions can be opened as regular macro sheets.

2 Select    the name of the add-in macro.
3 Hold down SHIFT and choose the OK button.

Open an add-in macro as a regular macro sheet when you need to read or edit the 
macro in the macro sheet.    When you open an add-in macro as a regular macro sheet, 
it may be hidden.    To display a hidden macro sheet, choose the Unhide command from
the Window menu.
When you open an add-in macro as a regular macro sheet, any macro that normally 
runs automatically when the add-in macro opens will not run.

See Also
Help
Add-In Macros
Open Command (File Menu)
User's Guide (Book 2)
Chapter 8, "Creating a Custom Application"



To hide a column
Drag the right border of the column heading beyond the left border of the column 

heading.
--Or--
1 Select the column you want to hide.
2 From the Format menu or the shortcut menu, choose Column Width.
3 Choose the Hide button.

To unhide a hidden column
A thick column heading border indicates that there are hidden columns.

1 Position the mouse pointer just to the right of a thick column heading border.
2 Drag to the right.
--Or--
1 Select the columns on both sides of the hidden column.
2 From the Format menu or the shortcut menu, choose Column Width.
3 Choose the Unhide button.

See Also
Help
Column Width Command (Format Menu)



To hide a row
Drag the bottom border of the row heading above the top border of the row heading.

--Or--
1 Select the row you want to hide.
2 From the Format menu or the shortcut menu, choose Row Height.
3 Choose the Hide button.

To unhide a hidden row
A thick row heading border indicates that there are hidden rows.

1 Position the mouse pointer just below a thick row heading border.
2 Drag down.
--Or--
1 Select the rows on either side of the hidden row.
2 From the Format menu or the shortcut menu, choose Row Height.
3 Choose the Unhide button.

See Also
Help
Row Height Command (Format Menu)



To insert cells, rows, or columns
To insert cells, rows, or columns by dragging

1 Select a range of cells above or to the left of where you want to insert the new cells, 
rows, or columns.

2 Press SHIFT and drag the fill handle (the small black square at the lower right of the 
selection) down or to the right.

To insert cells, rows, or columns with the Insert command
1 Select a range of cells below or to the right of where you want to insert the new cells, 

rows, or columns.
2 From the Edit menu or the shortcut menu, choose Insert.

Shortcuts: Insert tool
Insert Column tool
Insert Row tool

3 If you did not select entire rows or columns, a dialog box appears allowing you to shift 
cells right or down to make space for the inserted cells, or to insert entire rows or 
columns.    Select the option you want and choose the OK button.

See Also
Help

Insert Tool
Insert Column Tool
Insert Row Tool

Deleting cells, rows, or columns
Insert Command (Edit Menu)
Selecting cells, rows, or columns



To make corrections while typing
When you select a cell and begin typing, the entry is displayed in both the cell and the 
formula bar.

Press BACKSPACE to delete the character to the left, or select the text in the formula 
bar that you want to delete, and then press DEL or BACKSPACE.

You can also select the text you want to change and type the correct data.



To move cells and data
To move cells and data by dragging

1 Select the cell or cells you want to move.
2 Position the mouse pointer over the border of the selection.

The mouse pointer changes to an arrow.
3 Drag the selection to the paste area where you want to move the data.

While you drag, a border appears to indicate the size and position of the selection.
If the paste area is located beyond the visible portion of the worksheet, drag the 
selection to the edge of the window to scroll the worksheet.

4 To move the data to existing cells, position the border so that it surrounds the paste 
area, and then release the mouse button.    Any existing data in the paste area is 
replaced.
To insert cells containing the moved data between existing cells, hold down SHIFT as you
position the mouse pointer over a gridline.    When the border collapses, release the 
mouse button.    Existing cells and data are shifted to make room for the new cells.

To move cells and data by cutting and pasting
1 Select the cell or cells you want to move.
2 From the Edit menu or the shortcut menu, choose Cut.

Shortcuts: Cut tool
CTRL+X

If you want to move the cells to another worksheet, switch to the other worksheet.
3 Select the upper-left cell of the paste area or select the entire paste area.

The cut area and paste area can overlap.
4 To move the data to existing cells, choose Paste from the Edit menu or the shortcut 

menu.    Any existing data in the paste area is replaced.
Shortcuts: Paste tool

ENTER
CTRL+V

To insert cells containing the moved data between existing cells, choose Insert Paste 
from the Edit menu.    Existing cells and data are shifted to make room for the new 
cells.

See Also
Help

Cut Tool
Paste Tool

Adding and deleting a tool from a toolbar
Copying data
Cut Command (Edit Menu)
Displaying and hiding a toolbar
Insert Paste Command (Edit Menu)
Paste Command (Edit Menu)
Selecting cells, rows, or columns
Toolbars Command (Options Menu)
Turning drag and drop on or off
Using drag and drop
Using the pen with Microsoft Excel

User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"





To move and size a graphic object along with cells
1 Select the graphic object you want to reposition.
2 From the Format menu or the shortcut menu, choose Object Properties.
3 Select Move And Size With Cells to format the object so it moves and changes size 

along with the cells under its upper-left and lower-right corners.
Select Move But Don't Size With Cells to format the object so it moves with the cell 
under its upper-left corner, but doesn't change size.
Select Don't Move Or Size With Cells to detach the object from the cell grid.

4 Choose the OK button.
See Also

Help
Object Properties Command (Format Menu)
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



To group or ungroup graphic objects
To group graphic objects

1 Select the graphic objects you want to group together.
To select multiple graphic objects, hold down SHIFT while clicking the objects.
Shortcut: Selection tool (Drawing toolbar)

2 From the Format menu or the shortcut menu, choose Group.
Shortcut: Group tool (Drawing toolbar)

To ungroup graphic objects
1 Select the graphic objects you want to separate.
2 From the Format menu or the shortcut menu, choose Ungroup.

Shortcut: Ungroup tool (Drawing toolbar)
See Also

Help
Group Tool
Selection Tool
Ungroup Tool

Drawing Toolbar
Selecting multiple graphic objects
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



To justify text to fill a selected range
1 Select the cells containing the text you want to justify.    Include the entire range in 

which you want the justified text to appear.
The selected cells can contain only text.    If the cells contain numeric values, an error 
message is displayed.

2 From the Format menu, choose Justify.
If the selected range is not large enough, Microsoft Excel displays a message telling 
you the text will extend below the range.    If you choose the OK button, justified text 
will replace the contents in cells extending beyond the selected range.

See Also
Help
Justify Command (Format Menu for Worksheets)
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



To justify text right and left within a cell
1 Select the cell or cells you want to justify.
2 From the Format menu or the shortcut menu, choose Alignment.
3 Select the Wrap Text check box.
4 Select the Justify option button.
5 Choose the OK button.

If you adjust the column width, the text will always be aligned to the right and left.    To 
quickly adjust the row height after adjusting the column width, double-click the line 
below the row heading.
Shortcut: Justify Align tool (Formatting toolbar)

See Also
Help

Justify Align Tool
Adjusting row height
Changing the width of columns
Toolbars Command (Options Menu)



To link chart text to a worksheet cell
1 Select the text on the chart.
2 Type an equal sign (=).

Microsoft Excel clears any existing text from the formula bar.
3 Switch to the worksheet window and select the cell that contains the data or text you 

want shown in your chart.
You can also type a complete external reference to the worksheet cell. 

4 Click the enter box or press ENTER.

See Also
Help
Adding or deleting a chart title, an axis title, or a data marker label
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



To move a legend
To move the legend to a standard position

Drag the legend to one edge of the chart window.
When you drag the legend close enough to the edge, Microsoft Excel displays a vertical
or horizontal bar along the edge of the window to show that the legend will be placed 
in a standard position.

- Or -
1 Select the legend.
2 From the Format menu or the shortcut menu, choose Legend.
3 Under Type, select the legend position you want.
4 Choose the OK button.
Microsoft Excel redraws the chart to make room for the legend.    Microsoft Excel also 
changes the horizontal or vertical arrangement of the elements in the legend, if needed, 
to make the legend fit better in the chart window.    For example, if you move the legend 
to the bottom of the chart, Microsoft Excel arranges the legend elements horizontally.

To move the legend wherever you want
Drag the legend to the position you want.

When you drag the legend to a position other than the edge of the chart window, 
Microsoft Excel may not be able to move the rest of the chart out of the way, so the 
legend may overlap other parts of the chart.

See Also
Help
Legend Command (Format Menu)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



To move or size an arrow
To move an arrow

Drag the arrow shaft to the position you want.
You can also choose the Move command from the Format menu and use the arrow keys
to move the arrow.

To size an arrow and change its direction
1 Click the arrow to select it.
2 Drag the selection handles until the arrow is the size you want and pointing in the 

direction you want.
You can also choose the Size command from the Format menu and use the arrow keys   
to size the arrow.

See Also
Help
Adding or deleting a chart arrow
Formatting a chart arrow
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



To import a document from another application
1 From the File menu, choose Open.
2 In the File Name box, type the name of the file you want to open or select it from the 

list.
If you want to import a table from a text-based program, choose the Text button.    In 
the Text File Options dialog box, select the character that separates the data.
Later, you can arrange the imported data into columns and rows using the Parse 
command on the Data menu.
You can also specify the original source of the text file.    Under File Origins, select the 
source:    Macintosh, Windows (ANSI), and DOS or OS/2 (PC-8).

3 Choose the OK button.
4 Choose the OK button.

To import data from another application using the Clipboard
1 Switch to the document or application that contains the information you want to 

import.
2 Cut or copy the data using the appropriate procedure in the application you are 

exporting from.
3 Switch to the Microsoft Excel document to which you want to import data.
4 Select the cells into which you want to paste the data.
5 From the Edit menu, choose Paste.

To paste a picture of data, hold down SHIFT and choose Paste Picture from the Edit 
menu.
To link the data, choose Paste Link from the Edit menu.

See Also
Help
Clipboard
Importing and Exporting
Linking and Embedding
Open Command (File Menu)
Opening a text file in Microsoft Excel worksheet format
Paste Link Command (Edit Menu)
Paste Picture Command (Edit Menu)



To open a file from a disk
1 From the File menu, choose Open.

Shortcut: Open File tool
The File Name box displays a list of the Microsoft Excel files in the current directory.
To see a list of Microsoft Excel files in another directory, select the directory from the 
Directories box, or type the name of the directory in the File Name box.    Then select 
MS Excel Files (*.XL*) from the List Files Of Type box.
To see a list of all the files in a directory, including Microsoft Excel files, select All Files 
(*.*) from the List Files Of Type box.

2 In the File Name box, type the name of the file you want to open, or select it from the 
list.

3 Choose the OK button.
See Also

Help
Open Command (File Menu)
Open File Tool



To open the Clipboard
1 From the Microsoft Excel Control menu, choose Run.
2 Select the Clipboard option button.
3 Choose the OK button.

To close the Clipboard
From the Clipboard Control menu, choose Close.

See Also
Help
Run Command (Control Menu)
Clipboard



To move between workbook documents
To page through workbook documents in sequence

1 Switch to any workbook document or the Workbook Contents window.
2 To display the document before the active window, click the left paging button in the 

lower-right corner of the window.
3 To display the document after the active window, click the right paging button.

The Workbook Contents window is displayed after the last and before the first 
workbook document.    Documents are displayed in the same window size and location 
as the Workbook Contents window.

To move between workbook documents in any order
1 With the right mouse button, click any of the buttons in the lower-right corner of the 

document window.
A menu appears that lists the documents in the workbook.

2 From this menu, choose the name of the document you want to display.
The document is displayed in the same window size and location as the Workbook 
Contents window.



To give a bound workbook document an extended name
1 In the Workbook Contents window, select the bound document to which you want to 

give an extended name.
2 Choose the Options button.

Shortcut: ALT+SHIFT+O
3 In the Document Name box, type a name up to 31 characters long.

This name can include any combination of characters, including spaces.
4 Choose the OK button.

If you later unbind the document, Microsoft Excel will prompt you to give the document
an MS-DOS 11-character filename.

See Also
Help
Binding and unbinding workbook documents
Workbooks



To open a new window of a document in a workbook
1 In the Workbook Contents window, select the document for which you want to open a 

new window.
2 From the Window menu, choose New Window.

Microsoft Excel opens another window of the document.
Shortcut: Hold down CTRL while you double-click the document in the Workbook 

Contents window.
See Also

Help
New Window Command (Window Menu)



To view the source data for a link
Double-click the cell containing the link reference.

If a cell contains multiple references, Microsoft Excel uses the one that appears first in 
the formula bar.
Microsoft Excel switches to the source document and displays the source data.    If the 
source document or application is not open, Microsoft Excel opens it.
When you finish viewing the source data, you can quickly return to where you were in 
the dependent worksheet by choosing the Goto command from the Formula menu.    
Your previous location is stored in the Reference box of the Goto dialog box.
If you double-click a cell that contains both a note and a reference, Microsoft Excel 
displays the Note dialog box, instead of the source data.

See Also
Help
Goto Command (Formula Menu)
Linking and Embedding
Note Command (Formula Menu)
Opening source documents for the active worksheet
Replacing a source worksheet with another worksheet
Viewing a list of source documents for a dependent worksheet



To open source documents for the active worksheet
1 Switch to the dependent worksheet.
2 From the File menu, choose Links.
3 In the Link Type box, select the type of link you want to display.

In the Links box, Microsoft Excel displays a list of all the source documents for the 
dependent worksheet, with the link type you specified.

4 In the Links box, select the name of the source document you want to open.
To select several documents at once, hold down CTRL and click each document you 
want to open.
When using the keyboard, hold down CTRL as you press the UP or DOWN ARROW key to 
move to each document.    To add a document to the selection, press the SPACEBAR.

5 To open the documents, choose the Open button.
See Also

Help
Links Command (File Menu)
Linking and Embedding
Replacing a source worksheet with another worksheet
Viewing a list of source documents for a dependent worksheet
Viewing the source data for a link



To record a macro
To record a macro on a new or global macro sheet

1 From the Macro menu, choose Record.
Shortcut: Record Macro tool (Macro toolbar)

2 In the Name box, type a name or accept the proposed name.
3 In the Key box, type a shortcut key or accept the proposed key.
4 Select Global Macro Sheet if you want Microsoft Excel to automatically manage your 

macros, or select New Macro Sheet to create a new macro sheet.
If you have already recorded to a new macro sheet, your macro sheet name replaces 
the New Macro Sheet option button.

5 Choose the OK button.
6 Carry out the actions you want to record.
7 To stop recording, choose Stop Recorder from the Macro menu.

Shortcut: Record Macro tool (Macro toolbar)
To record a macro on an existing macro sheet

1 Open a new or existing macro sheet.
2 Select the cell or range on the macro sheet where you want to begin recording.
3 From the Macro menu, choose Set Recorder.
4 Switch to the document on which you will carry out the actions.
5 From the Macro menu, choose Record.
6 In the Name box, type a name or accept the proposed name.
7 In the Key box, type a shortcut key or accept the proposed key.
8 The name of your macro sheet will appear as the chosen option under Store Macro In.
9 Choose the OK button.

10 Carry out the actions you want to record.
11 To stop recording, choose Stop Recorder from the Macro menu.

Shortcut: Record Macro tool (Macro toolbar)
See Also

Help
Record Macro Tool

Macro Toolbar
Record and Stop Recorder Commands (Macro Menu)
Set Recorder Command (Macro Menu)
Start Recorder Command (Macro Menu)
Toolbars Command (Options Menu)
User's Guide (Book 2)
Chapter 6, "Automating Tasks with Command Macros"



To run a macro
1 From the Macro menu, choose Run.

Shortcut: CTRL+shortcut key
2 In the Run box, select the macro you want to run.
3 Choose the OK button.

You can also use the Run Macro tool on the Macro toolbar to run a macro.    Use the Toolbars 
command on the Options menu to display toolbars.    Before you click the Run Macro tool, a 
macro sheet must be active.    The macro runs from the active cell without displaying the 
Run dialog box.
See Also

Help
Run Macro Tool

Macro Toolbar
Run Command (Macro Menu)
User's Guide (Book 2)
Chapter 6, "Automating Tasks with Command Macros"



To parse data from another application
If you copy data into Microsoft Excel from another application, several columns of data can 
be condensed into a single column.    You can use the Parse command to distribute the fields
of each record into separate columns.    The range you parse can be any number of rows 
long, but only one column wide.

1 Select the range of cells you want to parse.
The range you are parsing must be no more than one column wide.

2 From the Data menu, choose Parse.
The Parse Line box displays the contents of the first cell in the range.    The settings you
select for the first cell apply to all cells in the range.
Microsoft Excel guesses at where to add brackets to the parse line.    Each set of 
brackets shows where a field will be separated into a different column.

3 If necessary, change the guess by adding or deleting brackets in the parse line.
4 In the Destination box, enter a reference to a single cell. 

The default reference displayed is the upper-left cell in the selected range; parsed data 
will overwrite existing data using the default destination.

5 Choose the OK button.
The Parse command fills cells to the right of the column you are parsing.    If there is 
data in those cells, that data is lost when the parsed data overwrites it.    Make sure you
have enough blank cells to the right of the range you are parsing to accommodate the 
data.
If you need to parse dissimilar cells, refer to the PARSE function in the Microsoft Excel 
Function Reference for a macro that parses based on a delimiting character.

See Also
Help
Parse Command (Data Menu)
User's Guide (Book 2)
Chapter 3, "Exchanging Data with Other Applications"



To redefine a style
To redefine a style by example

1 Select a cell that has been assigned the style you want to change.
2 Format the cell with the new formatting that you want the style to have.
3 Click the Style box on the toolbar, and then press ENTER.

Microsoft Excel asks if you want to redefine the style based on the current selection.
4 To redefine the existing style, choose the Yes button.

To reapply the old style and eliminate any new formatting you added to the cell, choose
the No button.
To keep the old style along with the new formatting you added to the cell, choose the 
Cancel button.

To redefine a style by definition
1 From the Format menu, choose Style.
2 Choose the Define button.

The Style dialog box expands.
3 In the Style Name box, select or type the name of the existing style you want to 

change.
If you select the existing style name, the formats of the style are displayed as the 
description and serve as your starting point for making changes to the style.
If you type an existing style name, the formats of the active cell are displayed as the 
description and serve as your starting point for the style.

4 Select any check boxes for any attributes you want added to the style.
Clear the check boxes for any attributes you want removed from the style.
When you clear a check box, the corresponding button becomes unavailable, and the 
description for this attribute is removed.

5 Choose the button that corresponds to the attribute you want to change.
6 Select the new format or formats you want for that attribute.
7 Choose the OK button to accept the formats and return to the Style dialog box.
8 Repeat steps 4 through 7 until you have selected all the formats you want for the style.
9 Choose the OK button to accept the changes, apply the new style to the selected cells, 

and close the dialog box.
To accept the changes and keep the Style dialog box open so you can create or 
redefine other styles, choose the Add button.    When you are finished, choose the OK 
button to apply the currently selected style, or choose the Close button to close the 
dialog box without applying any of the styles.

See Also
Help

Style Box
Style Command (Format Menu)

User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



To redefine the Normal style
Redefine the Normal style when you want to change the default style for an entire 
worksheet; for example, when you change the default font.

1 From the Format menu, choose Style.
2 Choose the Define button.

The Style dialog box expands.
3 In the Style Name box, select or type the style name Normal.

If you select the name Normal, the current definition of the Normal style serves as the 
starting point for making changes to the style.
If you type the style name Normal, the formats of the active cell are displayed as the 
description and serve as your starting point for making changes to the style.

4 Clear the check boxes for any attributes you want removed from the style.
Select any check boxes for any attributes you want added to the style.
When you clear a check box, the corresponding button becomes unavailable, and the 
description for this attribute is removed.

5 Choose the button that corresponds to the attribute you want to change.
6 Select a new format or formats you want for that attribute.
7 Choose the OK button to accept the formats and return to the Style dialog box.
8 Repeat steps 4 through 7 until you have selected the combination of formats you want 

in the Normal style.
9 Choose the OK button to accept the changes, apply the new standard style to the 

selected cells, and close the dialog box.
To accept the changes and keep the Style dialog box open so you can create or 
redefine other styles, choose the Add button.    When you are finished, choose the OK 
button to apply the currently selected style, or choose the Close button to close the 
dialog box without applying any of the styles.

See Also
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



To rename a document
1 From the File menu, choose Save As.
2 In the File Name box, type a new name for the document.
3 Choose the OK button.

The previous version of the document still remains under its earlier name.
To delete the previous version of the document

1 From the File menu, choose Delete.
2 In the File Name box, type the name of the document you want to delete, or select the 

name of the document you want to delete in the Files box.
3 Choose the OK button.
4 Choose the Yes button to confirm the deletion.

See Also
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



To rename a stand-alone or a dependent worksheet
1 Switch to the worksheet to be renamed.
2 From the File menu, choose Save As.
3 In the File Name box, type the new filename.
4 Choose the OK button.

The previous version of the worksheet still remains under its earlier name.
To delete the previous version of the worksheet

1 From the File menu, choose Delete.
2 In the File Name box, type the name of the worksheet you want to delete, or select the 

name of the worksheet you want to delete in the Files box.
3 Choose the OK button.
4 Choose the Yes button to confirm the deletion.

To rename a source worksheet
1 Open all the dependent documents.
2 Switch to the source worksheet.
3 From the File menu, choose Save As.
4 In the File Name box, type the new filename.
5 Choose the OK button.

A version of the worksheet still remains under its earlier name.    To delete that version 
of the worksheet, follow the preceding procedure.

See Also
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



To replace references in formulas with names
You should have defined names on your worksheet before following this procedure.

1 Select the range of cells to which you want to apply names.
If a single cell is selected, Microsoft Excel will replace references in the entire 
worksheet.

2 From the Formula menu, choose Apply Names.
3 In the Apply Names box, select the name or names with which you want to replace 

references.
To select more than one name, hold down CTRL while you press the UP ARROW or DOWN 
ARROW key to move the selection cursor.    Then press the SPACEBAR to add the item to 
the selection.

4 If you want to replace absolute or relative references with names whose definitions are 
identically absolute or relative, clear the Ignore Relative/Absolute check box.

5 If you do not want to replace references of cells located in named rows and columns 
with the names of those rows and columns, clear the Use Row And Column Names 
check box.

6 For more options regarding the replacement of row and column references, choose the 
Options button.
If you cleared the Use Row And Column Names check box, the additional options 
displayed are unavailable.

7 If you do not want to omit the column name when the formula is in the same column as
the referenced cell, clear the Omit Column Name If Same Column check box.

8 If you do not want to omit the row name when the formula is in the same row as the 
referenced cell, clear the Omit Row Name If Same Row check box.

9 Under Name Order, select the Row Column or Column Row option button to determine 
the order in which compound names will replace applicable references.

10 Choose the OK button.
See Also

Help
Apply Names Command (Formula Menu)
Define Name Command (Formula Menu)
Create Names Command (Formula Menu)
Defining a name
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



To remove a sound note
1 Select the cell from which you want to remove an attached sound note.
2 From the Formula menu, choose Note.
3 In the Sound Note box, choose the Erase button to remove the sound note from the 

cell.
After the sound note is erased, the Erase button changes to the Record button.

4 Choose the OK button.
See Also

Help
Creating or editing a note
Creating a sound note
Deleting a note
Note Command (Formula Menu)
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



To paste names
You can paste names into cells or formulas using the Paste Name command on the Formula 
menu.    You can also paste a list of all names defined on the active worksheet or macro 
sheet into a range beginning at the active cell. You should have defined names on your 
worksheet before following this procedure.

1 Select the cell where you want to insert a name.
2 Place the insertion point where you want to insert the name.

If the formula bar is not currently active, Paste Name will place the name, preceded by 
an equal sign, in the selected cell. Any existing cell contents will be replaced.

3 From the Formula menu, choose Paste Name.
Shortcuts: Paste Names tool (Macro toolbar)

F3
4 In the Paste Name box, select the name you want to paste.
5 Choose the OK button.

To paste a list of all defined names
1 Select a cell that will become the upper-left corner of the list.

Because the pasted list will overwrite any existing data, be sure to allow enough room 
for the list on your worksheet or macro sheet.

2 From the Formula menu, choose Paste Name.
3 Choose the Paste List button.

All names defined on your worksheet or macro sheet are pasted, starting at the active 
cell.    On a worksheet, the list of names is two columns wide. The left column lists 
names; the right column lists cell references that the names refer to.    On a macro 
sheet, the list of names is five columns wide and includes columns for names and cell 
references, a column for the type of macro (0=none, 1=function, 2=command), a 
column for assigned shortcut keys, and a column for Category. 

See Also
Help

Paste Names Tool
Apply Names Command (Formula Menu)
Create Names Command (Formula Menu)
Define Names Command (Formula Menu)
Defining a name
Displaying and hiding a toolbar
Paste Name Command (Formula Menu)
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



To paste functions
1 Select the cell where you want to insert a function in a formula.
2 Place the insertion point where you want to insert the function.

If the formula bar is not currently active, Paste Function will place the function, 
preceded by an equal sign, in the selected cell. Any existing cell contents will be 
replaced.

3 From the Formula menu, choose Paste Function.
Shortcuts: Paste Function tool (Macro toolbar)

SHIFT+F3
4 In the Function Category box, select the category that describes the type of function 

you want to use. Select All to view all available functions.
5 In the Paste Function box, select the function you want to paste.
6 If you want to include the function's arguments along with the pasted function, select 

the Paste Arguments check box.
If there is more than one form of the selected function, another dialog box will appear, 
allowing you to select the form you want to use.

7 Choose the OK button.
If you selected a function with more than one form, choose the OK button again to 
close the Paste Function dialog box and insert the selected function.

See Also
Help

Paste Function Tool
Displaying and hiding a toolbar
Paste Function Command (Formula Menu)
Toolbars Command (Options Menu)
Worksheet Functions
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



To replace characters
1 Select the area of the worksheet or macro sheet in which you want to replace 

characters.
If only one cell is selected, Replace searches the entire worksheet.

2 From the Formula menu, choose Replace.
3 In the Find What box, type the characters you want to search for.

You can include any letter, number, punctuation mark, or wildcard character in your 
search. To search for an actual wildcard character (* or ?), precede it with a tilde (~).

4 In the Replace With box, type the characters you want to use instead.
5 Under Look At, select Whole or Part.

If you select the Whole option, Microsoft Excel finds only exact and complete matches 
of the specified characters. If you select the Part option, Microsoft Excel finds any 
occurrences of the specified characters, including partial occurrences within other 
strings of characters.

6 Under Look By, select the direction in which you want Microsoft Excel to search, either 
across rows or down columns.

7 Select the Match Case check box if you want Microsoft Excel to use the exact 
combination of uppercase and lowercase characters you entered in the Find What box.

8 Choose the Replace All button if you want Microsoft Excel to automatically find and 
replace all occurrences.
--or--
Choose the Find Next button if you want to find the next occurrence of the characters; 
then choose the Replace button to replace the specified characters. 
After you choose the Replace button, Microsoft Excel automatically finds the next 
occurrence.

9 When you are finished, choose the Close button.
See Also

Help
Finding characters
Replace Command (Formula Menu)
User's Guide (Book 1)
Chapter 5,    "Creating a Worksheet"
Chapter 6,    "Editing a Worksheet"



To play a sound note
1 Double-click the cell containing the sound note.

If the selected cell contains a text note as well as a sound note, the Cell Note dialog 
box opens first, and then the sound note plays.

2 To play other sound notes on the same worksheet, select the note from the Notes In 
Sheet box, and choose the Play button.
Cells with attached sound notes are marked with an asterisk (*) in the Notes In Sheet 
box.

See Also
Help
Copying a text or sound note to another cell
Creating or editing a note
Creating a sound note
Deleting a note
Displaying or hiding cell note indicators
Removing a sound note
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



To prevent the display of zero values
1 From the Options menu, choose Display.
2 Clear the Zero Values check box.
3 Choose the OK button.

See Also
Help
Number Command (Format Menu for Worksheets)



To protect worksheet cells
1 Select the cells you want to protect.
2 From the Format menu, choose Cell Protection.
3 Set the protection you want by selecting the Locked or Hidden check box or both.

Locked cells cannot be edited if the document is protected.    Hidden cells display their 
values, but no formula appears in the formula bar.

4 Choose the OK button.
5 From the Options menu, choose Protect Document.
6 Select the Cells check box.
7 In the Password box, type a password if you want to prevent others from turning off 

document protection.
8 Choose the OK button.
9 In the Reenter Protection Password box, type your password to confirm it.

10 Choose the OK button.
To turn off worksheet cell protection

1 From the Options menu, choose Unprotect Document.
2 If the worksheet is protected with a password, type the password in the Password box.
3 Choose the OK button.

See Also
Help

Lock Cell Tool
Cell Protection Command (Format Menu for Worksheets)
Protecting a chart
Protecting a document with a password
Protecting an object
Protecting windows
Protecting worksheet cells
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



To print a chart
The Print tool prints with the current settings.    If you want to change the settings, use the 
Print command.

1 Switch to the chart window.
If the chart is embedded in a worksheet, double-click the chart to display it in a chart 
window.

2 From the File menu, choose Print.
Shortcut: Print tool

3 Select the print options you want.
4 Choose the OK button.

Microsoft Excel displays a message that printing is in progress.
To cancel printing, choose the Cancel button.

See Also
Help

Print Tool
Print Command (File Menu)
User's Guide (Book 1)
Chapter 16, "Printing"



To protect a chart
To protect a chart saved as a separate document

1 Switch to the chart window.
2 From the Chart menu, choose Protect Document.
3 Select the Chart check box.
4 If you want to prevent others from turning off document protection, type a password in 

the Password box.
5 Choose the OK button.
6 If you typed a password, the Confirm Password dialog box appears.    Type the password

again, and then choose the OK button. 
To protect a chart embedded in a worksheet

1 From the Options menu, choose Protect Document.
2 To protect the chart formats, select the Objects check box.

To protect the data on which the chart is based, select the Cells check box.
3 If you want to prevent others from turning off document protection, type a password in 

the Password box.
4 Choose the OK button.
5 If you typed a password, the Confirm Password dialog box appears.    Type the password

again, and then choose the OK button. 
To unprotect a chart

1 Switch to the chart document or to the worksheet in which the chart is embedded.
2 From the Chart menu or the Options menu, choose Unprotect Document.
3 If the chart is protected with a password, type the password in the Password box.
4 Choose the OK button.

See Also
Help
Protect Document Command (Chart Menu)
Protect Document Command (Options Menu)
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



To protect a document with a password
Caution:    If you forget the password of a document that was previously protected with a 
password, you cannot open or unprotect the document.

1 From the File menu, choose Save As.
2 In the File Name box, type a new name for the document or accept the default name.
3 Choose the Options button.
4 In the Protection Password box, type a password.

The characters are displayed as asterisks (*).
5 Choose the OK button.
6 In the Reenter Protection Password box, type the same password again to confirm it.
7 Choose the OK button.
8 In the Save As dialog box, choose the OK button to save the protected document.

To remove password protection
1 Open the document.
2 Type the password you gave the document.
3 Choose the OK button.
4 From the File menu, choose Save As.
5 Choose the Options button.
6 In the Protection Password box, select the password, which is displayed as asterisks (*).
7 Press the DEL key to remove the password.
8 Choose the OK button.
9 In the Save As dialog box, choose the OK button to save the unprotected document.

10 Choose the OK button to confirm replacement of the protected version of the document
with an unprotected version.

See Also
Help
Protect Document and Unprotect Document Commands (Options Menu)
Save As Command (File Menu)
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



To protect windows
1 Move and size the window or windows within your workspace the way you want them.
2 If the active document is a worksheet, a macro sheet, or a workbook, choose Protect 

Document from the Options menu.
If the active document is a chart, choose Protect Document from the Chart menu.

3 Select the Windows check box.
In the Password box, type a password if you want to protect the window with a 
password.

4 Choose the OK button.
To turn off window protection

1 If the active document is a worksheet, a macro sheet, or a workbook, choose Unprotect
Document from the Options menu.
If the active document is a chart, choose Unprotect Document from the Chart menu.

2 If the document is protected with a password, type the password in the Password box 
and then choose the OK button.

See Also
Help
Protect Document and Unprotect Document Commands (Options Menu)
Protect Document and Unprotect Document Commands (Chart Menu)
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



To recalculate linked worksheets
When the Manual calculation option is specified in the Calculation Options dialog box, use 
the following procedure to recalculate links.

1 Open the source and dependent worksheets.
2 From the Options menu, choose Calculation.
3 Choose the Calc Now button.

Shortcuts: Calculate Now tool (Utility toolbar)
CTRL+EQUAL SIGN ( = )
F9

4 Choose the OK button.
See Also

Help
Calculate Now Tool

Calculation Command (Options Menu)
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"
User's Guide (Book 2)
Chapter 1, "Analyzing and Calculating Data"



To reset the print area
If you have set a print area and later want to set another that is less than the entire 
worksheet, use the following procedure.

Select the new area you want to print; then, from the Options menu, choose Set Print 
Area.

Shortcut: Set Print Area tool (Utility toolbar)
To reset the print area to the entire worksheet
If you have set a print area and later want to print the entire worksheet, you must first 
remove the previous print area.

1 Select the entire worksheet.
2 From the Options menu, choose Remove Print Area.

Remove Print Area is available on the Options menu only when you have selected the 
entire worksheet.
Shortcut: Set Print Area tool (Utility toolbar)

See Also
Help

Set Print Area Tool
Set Print Area and Remove Print Area Commands (Options Menu)
User's Guide (Book 1)
Chapter 16, "Printing"



To replace a data marker with a picture
You can replace data markers with a picture created in another application or a picture 
created using the drawing tools on the Drawing toolbar.    You can use picture markers in 
line, bar, and column charts.    You cannot use picture markers in 3-D charts.

1 Switch to the application and the document containing the picture you want to use as a
data series marker.

2 Copy the picture using the application's procedure for copying.
If you are copying a graphic object from another Microsoft Excel document, select the 
object and choose Copy from the Edit menu or the shortcut menu.

3 Switch to the Microsoft Excel chart in which you want to use the picture.
4 Select the marker or data series you want to replace with the picture.
5 From the Edit menu, choose Paste.

See Also
Help
Creating or clearing a picture chart
Copy Command (Edit Menu)
Paste Command (Edit Menu)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



To change whether a picture marker is stacked or stretched
When picture markers are stacked, all the pictures for the series are the same size.    As 
many pictures as are necessary to indicate the value are stacked on top of each other or 
side by side.    When picture markers are stretched, only one picture is used for each value.   
It is stretched or shrunk to indicate the value.

1 Double-click the picture marker or data series to display the Format Picture dialog box.
You can also click the marker or series to select it and then choose Patterns from the 
Format menu or the shortcut menu.

2 Select the option you want.
3 To apply the formatting to all data markers in the chart, select the Apply To All check 

box.
4 Choose the OK button.

See Also
Help
Patterns Command (Format Menu for Charts)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



To clear a data marker picture
1 Select the marker or data series whose picture you want to clear.
2 From the Edit menu or the shortcut menu, choose Clear.
3 Select the Formats option button.
4 Choose the OK button.
If you selected a data series, Microsoft Excel removes the picture, and the formatting for 
the series returns to the automatic formatting it originally had.
If you selected a single data marker with a picture different from the other markers in the 
series, Microsoft Excel formats that marker like the other markers in the series.

See Also
Help
Clear Command (Edit Menu)
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



To preview a document before printing
From the File menu, choose Print Preview.    Or, choose the Print command from the 

File menu, select the Preview check box, and then choose the OK button.
Shortcut: Print Preview tool (File Tools category)
Microsoft Excel displays a full page view of the active document in the Print Preview 
window.

To display the active document in actual size in the Print Preview window (enlarged, 
with only a portion of the page showing), choose the Zoom button, or click the area of the 
document you want to see.

To print from the Print Preview window, choose the Print button.
To close the Print Preview window without printing, choose the Close button.

See Also
Help

Print Preview Tool
Adding and deleting a tool from a toolbar
Print Preview Command (File Menu)
Print Preview Window
Print Command (File Menu)
Toolbars Command (Options Menu)
User's Guide (Book 1)
Chapter 16, "Printing"



To print a document without previewing
The Print tool prints the active document using the current settings.    If you want to change 
the print settings, use the Print command.

1 From the File menu, choose Print.
2 Select the options you want.

To specify printers and printing settings, choose the Page Setup button.
3 If necessary, clear the Preview check box.
4 Choose the OK button.

Microsoft Excel displays a message saying that printing is in progress.
To cancel printing, choose the Cancel button.

See Also
Help

Print Tool
Page Setup Command (File Menu)
Print Command (File Menu)
User's Guide (Book 1)
Chapter 16, "Printing"



To print a section of a worksheet
The Print tool prints the active document using the current settings.    If you want to change 
the print settings, use the Print command.

1 Select the range or ranges you want to print.    Make nonadjacent selections if you want
non-contiguous areas of the worksheet to be printed.

2 From the Options menu, choose Set Print Area.
3 From the File menu, choose Print.

Shortcut: Print tool
4 Select the options you want.
5 Choose the OK button.

Microsoft Excel displays a message saying that printing is in progress.
To cancel printing, choose the Cancel button.

See Also
Help

Print Tool
Print Command (File Menu)
Set Print Area Command (Options Menu)

User's Guide (Book 1)
Chapter 16, "Printing"



To quit Microsoft Excel
1 From the File menu, choose Exit.

If you have made changes to any open documents and not saved them, Microsoft Excel
asks you if you want to save the changes before closing.

2 Choose the Yes button to save changes, the No button to discard changes, or the 
Cancel button to cancel the command.
If you selected the Recalculate Before Save check box in the Calculation Options dialog 
box, Microsoft Excel recalculates your worksheet if necessary.
Press ESC to interrupt recalculation.
When you press ESC, you will be asked if you want to continue recalculating and saving.
Choose Yes to continue, No to save without recalculating, or Cancel to cancel the 
command and return to the document.

See Also
Help
Calculation Command (Options Menu)
Exit Command (File Menu)
Setting calculation options for open documents



To open a text file in Microsoft Excel worksheet format
1 From the File menu, choose Open.
2 In the File Name box, type the name of the file you want to open or select it from the 

list.
The File Name list displays only the files that have the same extension as the one 
shown in the File Name box.    To see all the files in a directory, select All Files (*.*) from 
the List Files Of Type box.

3 Choose the Text button.
4 Under Column Delimiter, select the character used to separate columns:    Tab, Comma,

Space, Semicolon, None, or Custom.
5 Under File Origin, select the original source of the text file:    Macintosh, Windows 

(ANSI), or DOS or OS/2 (PC-8).
6 Choose the OK button to confirm your selections.
7 Choose the OK button to open the file.

See Also
Help
Open Command (File Menu)
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



To reorder documents in a workbook
1 Switch to the Workbook Contents window.
2 Drag the document to a new location.

When you release the mouse button, Microsoft Excel moves the document to the new 
location.

--Or--
1 Switch to the Workbook Contents window.
2 From the Edit menu or shortcut menu, choose Cut.

The document name is surrounded by a moving border.
3 Select the document in the location you want the cut document moved to.
4 From the Edit menu or shortcut menu, choose Paste.

Microsoft Excel moves the document to the new location.
See Also

Help
Moving between workbook documents



To print a report
1 From the File menu, choose Print Report.

If the Print Report command does not appear on the File menu, run the Setup program 
to install it.

2 In the Reports box, select the report you want to print.
3 Choose the Print button.
4 In the Copies box, type the number of copies you want to print.
5 Choose the OK button.

See Also
Help
Print Report Command (File Menu)
Creating a report
Editing a report
User's Guide (Book 1)
Chapter 1, "Getting Started With Microsoft Excel"
Chapter 16, "Printing"



To protect an object
Before you can do this procedure, the active document must be a worksheet or macro 
sheet.
To protect an object

1 Select the object you want to protect.
2 From the Format menu, choose Object Protection.
3 Select the Locked check box.

If a text box is selected and you want to protect the text in the text box, select the Lock
Text check box.

4 Choose the OK button.
Once you have set protection status for the object, you must turn on document 
protection for those settings to take effect.

5 From the Options menu, choose Protect Document.
6 If you want to prevent others from turning off document protection, type a password in 

the Password box.
7 Select the Objects check box.
8 Choose the OK button.
9 If you typed a password in the Password box, the Confirm Password dialog box will 

appear.    Type the password again to confirm it.
        10 Choose the OK button.
To remove document protection

1 From the Options menu, choose Unprotect Document.
2 If the object is protected with a password, type the password in the Password box.
3 Choose the OK button.

See Also
Help
Object Protection Command (Format Menu for Worksheets)
Protect Document and Unprotect Document Commands (Options Menu)
Protecting a chart
Protecting worksheet cells
User's Guide (Book 1)
Chapter 4, "Managing Document Files"
Chapter 15, "Working with Graphic Objects"



To redirect links to source documents
If you change the name of a source document or move the source document to a different 
directory, you must redirect the links in the dependent document to include the new name 
or path of the source document.

1 Switch to the dependent worksheet.
2 From the File menu, choose Links.
3 In the Link Type box, select the type of link you want to display.

In the Links box, Microsoft Excel displays a list of all the source documents for the 
dependent worksheet with the link type you specified.

4 In the Links box, select the name of the source document for which you want to 
redirect links.
To select several documents at once, hold down CTRL and click each document you 
want to change. You can also hold down CTRL as you press the UP ARROW or DOWN ARROW 
key to move to each document, and then press the SPACEBAR to add a document to the 
selection.

5 Choose the Change button.
Microsoft Excel displays a dialog box for each document you selected.

6 In the File Name box, type the complete new name of the source document, including 
its path, or select the name of the new source document from the list.
The File Name box displays the documents in the current directory.    If the new source 
document is not in the current directory, select the appropriate directory in the 
Directories box.

7 Choose the OK button.
8 Repeat steps 6 and 7 for each document you selected.

See Also
Help
Replacing a source worksheet with another worksheet
Linking and Embedding
Links Command (File Menu)
User's Guide (Book 1)
Chapter 11, "Working with Multiple Microsoft Excel Documents"
User's Guide (Book 2)
Chapter 3, "Exchanging Data with Other Applications"



To print text notes
1 From the File menu, choose Page Setup.
2 Select the Row & Column Headings check box to print notes with the cell reference 

before each note.
Clear the Row & Column Headings check box to print notes without the cell reference 
before each note.

3 Choose the OK button.
4 From the File menu, choose Print.
5 To print only the notes, select the Notes option button under Print.

To print the worksheet and its notes, select the Both option button.
6 Choose the OK button.

See Also
Help
Note Command (Formula Menu)
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



To save a macro sheet as an add-in macro
1 Switch to the macro sheet you want to save as an add-in macro.
2 From the File menu, choose Save As.
3 If you want, type a new name for the macro sheet.

Microsoft Excel will automatically add the .XLA extension.
4 In the Save File As Type box, select the Add-In option.
5 Choose the OK button.

See Also
Help
Add-In Macros
Save As Command (File Menu)
User's Guide (Book 2)
Chapter 8, "Creating a Custom Application"



To step through a macro
1 From the Macro menu, choose Run.
2 In the Run box, select the macro you want to run or type the name or reference of the 

macro in the Reference box.
3 Choose the Step button.

The first formula in the macro appears in the Single Step dialog box.
4 Choose the Step Into or Step Over button to continue stepping through the macro.    

Step Into steps through user-defined functions.    Step Over carries out, but does not 
step through user-defined functions.

5 Choose the Evaluate button to see how Microsoft Excel calculates the formula.
The formula is calculated one expression at a time.

6 Choose the Halt button to close the dialog box and stop the macro.
7 Choose the Goto button to close the dialog box and stop the macro at the cell currently

being evaluated.
8 Choose the Pause button to close the dialog box and pause the macro.    To return to the

Single Step dialog box, click the Resume Macro tool on the Macro Paused toolbar, which
automatically appears whenever you pause a macro, or choose Resume from the Macro
menu.

9 Choose the Continue button to close the dialog box and continue running the macro 
without stepping.

You can use the Step Macro tool on the Macro toolbar to step through a macro.    Use the 
Toolbars command on the Options menu to display toolbars.    You must have a macro 
sheet active before clicking the Step Macro tool.    The macro begins stepping from the 
active cell on the macro sheet.    
You can also step through a macro by pressing ESC while the macro is running or by using 
the STEP macro function.

See Also
Help

Resume Macro Tool
Run Macro Tool
Step Macro Tool

Macro Paused Toolbar
Macro Toolbar
Run Command (Macro Menu)
Single Step Dialog Box
Toolbars Command (Options Menu)
Microsoft Excel Function Reference
PAUSE
RESUME
STEP
HALT



To set up a criteria range with comparison criteria
1 Copy the field names for the database fields you want to compare to a row outside the 

database range.
2 In the cells beneath the field names, enter the comparison values for each field.

You can enter values or text as comparison criteria.
You can also use comparison operators and wildcard characters.

3 Select the field names and the rows beneath them that contain the criteria.
4 From the Data menu, choose Set Criteria.

See Also
Help
Defining a criteria range
Finding records in a database
Finding records using a data form
Set Criteria Command (Data Menu)
Using comparison criteria
Using computed criteria
User's Guide (Book 1)
Chapter 9, "Creating and Using a Database on a Worksheet"
Chapter 10, "Analyzing and Reporting Database Information"



To sort a range of cells
In Microsoft Excel, you can sort a selected range of cells independently from unselected 
cells in rows or columns. Before you sort, make sure you have selected all the cells you 
want to include. Any adjacent unselected cells will not be sorted.

1 Select the range you want to sort.    
If you are sorting a database, exclude the field names.

2 From the Data menu, choose Sort.
Shortcuts: Sort Ascending tool (Utility toolbar)

Sort Descending tool (Utility toolbar)
3 Under Sort By, select the Rows option button to sort by rows or the Columns option 

button to sort by columns.
4 In the 1st Key box, enter the reference of your first sort key.    

You can do this by typing the reference or using the arrow keys or the mouse to select 
the first key cell. You can move the dialog box out of the way by dragging the title bar.

5 To sort by more than one key, enter references in the 2nd Key and 3rd Key boxes.
6 Select the Ascending or Descending option button for each key you specify.
7 Choose the OK button.

Microsoft Excel resets the settings in the Sort dialog box after each sort.    
To undo a sort

From the Edit menu, choose Undo Sort immediately after you sort.
See Also

Help
Sort Ascending Tool
Sort Descending Tool

Sort Command (Data Menu)
Sorting with more than three keys

Toolbars Command (Options Menu)
Utility Toolbar
User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"
Chapter 9, "Creating and Using a Database on a Worksheet"



To sort with more than three keys
Although the Sort command on the Data menu allows only three sort keys, you can sort by 
more than three keys by using more than one sort operation.    First you sort by the least 
significant sort keys, ending with the three most significant keys in the final sort.

1 Select the range you want to sort.    
If you are sorting a database, exclude the field names.

2 From the Data menu, choose Sort.
3 Under Sort By, select the Rows option button to sort by rows or the Columns option 

button to sort by columns.
4 In the 3rd Key box, enter the reference of your least significant sort key.    
5 In the 2nd Key box, enter the reference of the second-least significant sort key.
6 In the 1st Key box, enter the reference of the third-least significant sort key.
7 Select the Ascending or Descending option button for each key you specify.
8 Choose the OK button.
9 Repeat steps 2 through 7 for the rest of the keys on which you want to sort.    Always 

enter keys of greater significance into higher-numbered Key boxes. 
Microsoft Excel resets the settings in the Sort dialog box after each sort operation.

To undo a sort
From the Edit menu, choose Undo Sort immediately after you sort.

See Also
Help
Sorting a range of cells
User's Guide (Book 1)
Chapter 9, "Creating and Using a Database on a Worksheet"



To split a window into panes
Drag the horizontal or vertical split box to the desired position.

To display the split box, choose Workspace from the Options menu and select the Scroll
Bars check box.    When you position the mouse pointer on a split box, the pointer 
changes to a two-headed arrow. 

To split a window into four panes
1 Switch to the worksheet window you want to split.
2 From the Window menu, choose Split.

The window is split above and to the left of the active cell.
To adjust the split panes, drag each split bar in the direction you want.

To split a window into vertical or horizontal panes
1 Switch to the worksheet window you want to split.
2 For vertical panes, select a column.

For horizontal panes, select a row.
3 From the Window menu, choose Split.
4 To adjust the split panes, drag the split bar or the split box to the desired position.

To remove splits from a window
1 Switch to the worksheet window you want to remove the split from.
2 Double-click any part of the split bar, or choose Remove Split from the Window menu.

See Also
Help
Split and Remove Split Commands (Window Menu)
Split Bar
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



To switch to a different pane within a window
Select a cell in the pane you want to switch to.

Using the keyboard, press F6 to select the pane you want to switch to.



To switch to or close a document window
To switch to another open document window

From the Window menu, choose the name of the document.
Shortcut: CTRL+F6

To close a document window
1 Switch to the window you want to close.
2 From the File menu, choose Close.

Shortcut: CTRL+F4



To size document and application windows
To size a window with the mouse

Drag the window sizing border until the window is the size you want.
To size a window with the keyboard

1 From the Control menu, choose Size.
The mouse pointer changes to a four-headed arrow.

2 Use the arrow keys to move the border until the window is the size you want.
3 Press ENTER.



To scroll to and select specified cells or a named range
1 From the Formula menu, choose Goto.
2 In the Goto box, select a name.

--or--
In the Reference box, type a name or reference.

3 Choose the OK button.
4 To return to the location from which you last issued the Goto command, choose the 

Goto command again.    The previous location is already selected in the Reference box.
The last four Goto destinations are listed at the top of the Goto box, with the latest one 
first.

See Also
Help
Goto Command (Formula Menu)
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



To select a graphic object
Point to the graphic object and click.

Microsoft Excel displays selection handles around the graphic object.
To select a graphic object with a macro assigned to it

1 If any object is already selected, select any cell to cancel the selection.
2 Hold down the CTRL key and click the graphic object.

--or--
Use the Selection tool on the Drawing toolbar to select the object by drawing a 
selection rectangle around it.

Microsoft Excel selects the object without running the macro.
See Also

Help
Selection Tool (Drawing Toolbar)

Graphic Objects
Selecting all graphic objects
Selecting multiple graphic objects and removing graphic objects from a multiple selection
Displaying and hiding toolbars
Toolbars Command (Options Menu)

User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



To solve equations using goal seeking
1 Select the cell containing the formula for which you want to find a specific solution.
2 From the Formula menu, choose Goal Seek.
3 In the To Value box, enter the target value you want the formula to arrive at.
4 In the By Changing Cell box, enter the reference of the cell whose value you want 

Microsoft Excel to change to achieve the desired result.
The cell you enter must be one that the formula referred to in the Set Cell box depends
on, either directly or indirectly, and it must contain a value, not a formula.

5 Choose the OK button.
You can interrupt or stop calculation during goal seeking by choosing either the Pause 
button or the Cancel button. 

6 If Microsoft Excel reaches the solution you want for your formula, choose the OK button
to replace the value used in goal seeking with the new value.
Choose the Cancel button to keep the old value.

See Also
Help
Goal Seek Command (Formula Menu)
Adjusting a data value by dragging a data marker
User's Guide (Book 2)
Chapter 2,    "Performing What-if Analysis on a Worksheet Model"



To select multiple graphic objects and remove graphic objects from 
a multiple selection

1 Click the first graphic object.
2 Hold down SHIFT and click another object.
3 Repeat step 2 until you have selected all the objects you want.

To remove an object from the selection, hold down SHIFT and click the object you want 
to remove.

To select multiple graphic objects with the Selection tool (Drawing toolbar)
1 Click the Selection tool on the Drawing toolbar.
2 Point to one corner of the area you want to select and drag until the selection rectangle

fully encloses all the objects you want to select.
When you release the mouse button, all objects that are entirely within the selection 
rectangle are selected.

3 To add more objects to the selection, hold down SHIFT and drag again.
To remove a group of graphic objects from a multiple selection

1 Click the Selection tool on the Drawing toolbar.
2 Hold down SHIFT and drag until the selection rectangle encloses the objects you want to

remove from the selection.
See Also

Help
Selection Tool

Graphic Objects
Selecting a graphic object
Selecting all graphic objects
Showing and hiding toolbars
Toolbars Command (Options Menu)

User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



To select all graphic objects
1 From the Formula menu, choose Select Special.
2 Select the Objects option.
3 Choose the OK button.
All graphic objects on the worksheet are selected, including drawn objects, buttons, and 
text boxes.

See Also
Help
Graphic Objects
Select Special Command (Formula Menu)
Selecting a graphic object
Selecting multiple graphic objects and removing graphic objects from a multiple selection
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"
Chapter 8, "Organizing and Documenting a Worksheet"
Chapter 15, "Working with Graphic Objects"



To set a format for the entire worksheet
1 From the Format menu, choose Style.
2 In the Style Name box, select Normal.
3 Choose the Define button.
4 Under Change, choose the button for the attribute you want to change.    In the dialog 

box that appears, select the options you want.
5 Choose the OK button.
6 Repeat steps 4 and 5 for any attributes you want changed.
7 In the Style dialog box, choose the Add button.
8 Choose the Close button.

See Also
Help
Format Menu for Worksheets
Redefining the Normal style
Setting the default font for worksheets



To set the default font for worksheets
To set the default font for a worksheet

1 From the Format menu, choose Style.
2 In the Style Name box, select Normal.
3 Choose the Define button.
4 Under Change, choose the Font button.

The Font dialog box is displayed.
5 Select the font, font style, size, and effects you want.

A sample of the font appears in the Sample box.
6 Choose the OK button.
7 In the Style dialog box, choose the Add button.
8 Choose the Close button.

To set the default font for all new worksheets
1 From the File menu, choose New.

Shortcut: New Worksheet tool (Standard    toolbar)
2 Select Worksheet and choose the OK button.
3 Set the default font for the worksheet using the procedure above.
4 From the File menu, choose Save As.
5 In the Save File As Type box, select Template.
6 In the File Name box, type sheet.xlt
7 In the Directories box, select the XLSTART directory.
8 Choose the OK button.

The next time you start Microsoft Excel, the new font will be the default for all new 
worksheets.

See Also
Help

New Worksheet Tool
About Templates
New Command (File Menu)
Save As Command (File Menu)
Style Command (Format Menu for Worksheets)



To set or remove a manual page break
1 Select the cell below and to the right of the gridline where you want the page to end.
2 From the Options menu, choose Set Page Break.

To set a horizontal page break only
1 Select the row below the gridline where you want the page to end.    
2 From the Options menu, choose Set Page Break.

To set a vertical page break only
1 Select the column to the right of the gridline where you want the page to end.
2 From the Options menu, choose Set Page Break.

To remove a manual page break
1 Select any cell directly below or to the right of the manual page break.

Set Page Break changes to Remove Page Break on the Options menu.
2 From the Options menu, choose Remove Page Break.

To remove all page breaks
1 Select the entire worksheet by clicking the Select All button (the rectangle above the 

row headings and to the left of the column headings).
Shortcut: CTRL+SHIFT+SPACEBAR

2 From the Options menu, choose Remove Page Break.



To save a chart 
1 Switch to the chart document or the worksheet containing the embedded chart.
2 From the File menu, choose Save As.

Shortcut: Save File tool
3 In the File Name box, type a name for the chart or worksheet.
4 Choose the OK button.

See Also
Help

Save File Tool
Save As Command (File Menu)
Saving an embedded Microsoft Excel document as a separate document
User's Guide (Book 1)
Chapter 4, "Managing Documents"



To select items in a chart
To select chart items with the mouse

To select Do this
An item Click the item.
A single data point Hold down the CTRL key and click the data marker.
The plot area Click part of the plot area not occupied by any other item, including 

gridlines.    Or choose Select Plot Area from the Chart menu.
The entire chart Click outside of the plot area where there is no other item.    Or 

choose Select Chart from the Chart menu.
To select chart items with the keyboard

1 Use the UP ARROW and DOWN ARROW keys to select the class of items you want to select 
(chart, plot area, 3-D floor, 3-D walls, 3-D corners, legend, axes, text, arrows, gridlines, 
data series, drop lines, hi-lo lines, up/down bars, series lines, radar axis labels).

2 Use the RIGHT ARROW and LEFT ARROW keys to select the particular item within that class.
To change an item, you first select it and then choose an appropriate command. When an 
item is selected, it is surrounded with white or black selection squares. Black squares mean 
that you can drag to move and resize the item; white squares mean that you cannot change
the size or position of the item directly because it is dependent on some other aspect of the 
chart.
If chart text is selected, it appears in the formula bar so you can edit it.    If series markers 
are selected, the series formula that Microsoft Excel uses to plot the data is displayed in the 
formula bar.    You can edit this formula to control how data is plotted.    For information 
about editing a series formula, see Adding or editing series.
When a chart is the active document, the reference area at the far left of the formula bar 
tells you what is selected.    If the legend is selected, for example, the area displays the word
"Legend."    If this area displays the code "S1P3," it means the third point of the first series is
selected.    For more information about what codes are used for the different parts of a chart,
see the SELECT function in the Microsoft Excel Function Reference.
Note    If you are working with a chart that was embedded in a worksheet or macro sheet 
with one of the chart tools, you must open the chart before you can select an item within 
the chart.    To open an embedded chart, double-click it.
See Also

Help
Select Chart Command (Chart Menu)
Select Plot Area Command (Chart Menu)
User's Guide (Book 1)
Chapter 13, "Editing a Chart"



To set the preferred chart type
Microsoft Excel uses the preferred chart type when you create a new chart with the New 
command on the File menu, when you change the format of an existing chart using the 
Preferred command on the Gallery menu, or when you use the Preferred Chart tool.

1 Create a chart that is formatted with the chart type and formats you want used for all 
new charts.

2 From the Gallery menu, choose Set Preferred.
The preferred chart type and format you set remains in effect for the current work 
session only.

See Also
Help

Preferred Chart Tool (Chart Toolbar)
New Command (File Menu)
Preferred Command (Gallery Menu)
Set Preferred Command (Gallery Menu)
User's Guide (Book 1)
Chapter 12, "Creating a Chart"



To set print titles for rows and columns
1 From the Options menu, choose Set Print Titles.
2 To set titles for columns, select the Titles For Columns box, and then select cells in the 

rows you want to use for column titles.
If you leave the Titles For Columns box blank, Microsoft Excel will not set print titles for 
columns.

3 To set titles for rows, select the Titles For Rows box, and then select cells in the 
columns you want to use for row titles.
If you leave the Titles For Rows box blank, Microsoft Excel will not set print titles for 
rows.

4 Choose the OK button.
To remove print titles

1 Select the entire worksheet.
2 From the Options menu, choose Remove Print Titles.

Remove Print Titles is available on the Options menu only when you have selected the 
entire worksheet.

See Also
Help
Canceling print titles
Set Print Titles and Remove Print Titles Commands (Options Menu)
User's Guide (Book 1)
Chapter 16,    "Printing"



To save a document for the first time
1 From the File menu, choose Save As.

Shortcuts: Save File tool
F12

2 In the File Name box, type a name for the document or accept the proposed name.
The Microsoft Excel Normal file format is automatically displayed in the Save File As 
Type box.    If you want to save the file in a format other than the Normal file format, 
select that format in the Save File As Type box.

3 Choose the OK button.
To save changes made to an existing document

From the File menu, choose Save.
If you selected the Recalculate Before Save check box in the Calculation Options dialog 
box, Microsoft Excel recalculates your worksheet if necessary.
Press ESC to interrupt recalculation.
When you press ESC, you will be asked if you want to continue recalculating and saving.
Choose Yes to continue, No to save without recalculating, or Cancel to cancel the 
command and return to the document.

See Also
Help

Save File Tool
Calculation Command (Options Menu)
Save As Command (File Menu)
Setting calculation options for open documents
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



To save a file for use by another application
1 From the File menu, choose Save As.
2 In the File Name box, type a name for the document or accept the proposed name.
3 In the Save File As Type box, select the file format of the other application.
4 Choose the OK button to save the file.

See Also
Help
Save As Command (File Menu)
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



To save a document as a template
1 From the File menu, choose Save As.
2 Type the name you want for the template.    

If you don't type an extension, Microsoft Excel adds the extension .XLT after you save 
the template.

3 In the Save File As Type box, select Template.
4 Choose the OK button.

See Also
Help
Creating a new template
Editing a template 
Using a template
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



To select a printer
1 From the File menu, choose Page Setup.
2 Choose the Printer Setup button.
3 In the Printer box, select the printer you want.

If the printer you want is not listed, choose the Setup button and select it from the list 
in the Printer box.    Then choose the OK button.

4 Choose the OK button to save your selection and close the Page Setup dialog box.
See Also

Help
Page Setup Command (File Menu)
Setting up a printer



To set up a printer
This procedure controls default printer settings, which apply to all documents and 
applications until you change them.

1 From the File menu, choose Page Setup.
2 Choose the Printer Setup button.
3 In the Printer box, select the printer you want.
4 If you want to change printer settings or add a printer, choose the Setup button.
5 Select the printer you want to add or select the options you want to change for the 

current printer.
6 Choose the OK button until all the dialog boxes are closed.
For more information, see your Microsoft Windows documentation.

See Also
Help
Page Setup Command (File Menu)
User's Guide (Book 1)
Chapter 16, "Printing"



To replace a source worksheet with another worksheet
1 Switch to the dependent worksheet.
2 From the File menu, choose Links.
3 In the Link Type box, select the type of link you want to change.

In the Links box, Microsoft Excel displays a list of all the source documents for the 
dependent worksheet with the link type you specified.

4 In the Links box, select the name of the source document you want to replace.
To select several documents at once, hold down CTRL and click each document you 
want to replace.
When using the keyboard, hold down CTRL as you press the UP or DOWN ARROW key to 
move to each document.    To add a document to the selection, press the SPACEBAR.

5 Choose the Change button.
Microsoft Excel displays a dialog box for each document you selected.

6 In the File Name box, type the new source document name or select the new source 
document name from the list.
The File Name box displays the documents in the current directory.    If the new source 
document is not in the current directory, you can use the Directories box to change to 
the appropriate directory.

7 Choose the OK button.
8 Repeat steps 6 and 7 for each document you selected.

See Also
Help
Change Links Dialog Box
Linking and Embedding
Links Command (File Menu)
User's Guide (Book 1)
Chapter 11, "Working with Multiple Microsoft Excel Documents"
User's Guide (Book 2)
Chapter 3, "Exchanging Data with Other Applications"



To save an embedded Microsoft Excel object as a separate 
document

1 Double-click the embedded object.
Microsoft Excel starts and displays the data or chart in a worksheet or chart window.

2 From the File menu, choose Save As.
3 In the File Name box, type a name for the new document, or accept the proposed 

name.
4 Choose the OK button.

See Also
Help
Save As Command (File Menu)
Linking and Embedding



To save a workbook
1 From the File menu, choose Save Workbook.
2 In the File Name box, type a name for the workbook or accept the proposed name.

The Microsoft Excel Normal file format is automatically displayed in the Save File As 
Type box.    If you want to save the file in a format other than the Normal file format, 
select that format in the Save File As Type box.

3 Choose the OK button.
See Also

Help
Save Workbook Command (File Menu)



To start or end a group editing session
To start a group editing session

1 Open the worksheets and macro sheets you want to work with as a group.
2 Switch to the sheet in which you want to enter text and make changes.
3 From the Options menu, choose Group Edit.

Microsoft Excel displays a list of all open, unhidden worksheets and macro sheets.
4 To add or delete a sheet, hold down CTRL and click the sheet name.

--or--
Hold down CTRL while using the arrow keys to select the sheet name, and then press 
CTRL+SPACEBAR.
Only the sheets that remain selected will be included in the group.

5 Repeat step 4 until all the sheets you want to include in the group are selected.
6 Choose the OK button.

To end a group editing session and return to single sheet editing
Switch to another sheet by clicking it or by choosing its name from the Window 

menu.
See Also

Help
Editing worksheets as a group
User's Guide (Book 1)
Chapter 11, "Working with Multiple Microsoft Excel Documents"



To save new unnamed linked documents
1 Switch to the source document.
2 From the File menu, choose Save As.
3 In the File Name box, type a name for the document or accept the proposed name.
4 Choose the OK button.
5 Repeat steps 1 through 4 for each additional source document.
6 Switch to the dependent document.
7 Repeat steps 2 through 4 for each dependent document.

To save changes in existing linked documents
1 Switch to the source document.
2 From the File menu, choose Save.
3 Repeat steps 1 and 2 for each additional source document.
4 Switch to the dependent document.
5 From the File menu, choose Save.
6 Repeat steps 4 and 5 for each dependent document.

If you save linked worksheets in different directories, make sure that you use the Save 
As command on the File menu to save all source documents before you save the 
dependent documents, so that the link references in the dependent documents are 
correct.

See Also
Help
Save As Command (File Menu)



To select a cell, row, column, or worksheet
To select a single cell

Click the cell you want, or press the arrow keys to move to the cell you want.
To select an entire row or column

Click the row or column heading.
--Or--

1 Select a cell in the row or column.
2 To select an entire row, press SHIFT+SPACEBAR.

To select an entire column, press CTRL+SPACEBAR.
To select the entire worksheet

Click the Select All button (the square on the worksheet directly above the row 
headings and to the left of the column headings), or press CTRL+SHIFT+SPACEBAR.
See Also

Help
Selecting a range of cells
Selecting nonadjacent cells



To select a range of cells
Drag from the first cell of the range to the last.

--Or--
1 Select the first cell of the range.
2 Hold down SHIFT or press F8 to turn on Extend mode.
3 Press the arrow keys to extend the selection in the direction you want.
4 Release SHIFT or press F8 again to turn off Extend mode.

To select a named range
1 From the Formula menu, choose Goto.

Shortcut: F5
2 In the Goto box, select the name you want or, in the Reference box, type a range 

name.
3 Choose the OK button.

To reduce a selection to the active cell
Press SHIFT+BACKSPACE.

To select an array range
1 Select any cell in the array range.
2 From the Formula menu, choose Select Special.
3 Select the Current Array option button.
4 Choose the OK button.

Shortcut: CTRL+SLASH

To select a rectangular block of data
1 Select any cell in the rectangular block of data you want to select.
2 Press CTRL+SHIFT+ASTERISK (*).

To move to the edge of a rectangular block of data
Press CTRL+ARROW or END+ARROW.

See Also
Help
Copying visible cells
Selecting a cell, row, column, or worksheet
Selecting nonadjacent cells



To select nonadjacent cells
1 Select the first cell or range.
2 Hold down CTRL and select the next cell or range.
3 Repeat step 2 to continue adding selections.
--Or--
1 Select the first cell or range.
2 Press SHIFT+F8 to turn on Add mode.
3 Move to the first cell of the next selection.
4 Press F8 to turn on Extend mode and select the second cell or range.
5 Repeat steps 2 through 4 to continue adding selections.
6 Press F8 to turn off Extend mode.

See Also
Help
Selecting a range of cells
Selecting a cell, row, column, or worksheet



To delete a custom toolbar
1 From the Options menu or the toolbar shortcut menu, choose Toolbars.
2 In the Show Toolbars box, select the custom toolbar you want to delete.

You cannot delete built-in toolbars.
3 Choose the Delete button.

If the Delete button changes to the Reset button, you have selected a built-in toolbar, 
which you cannot delete.

4 Choose the Close button to close the dialog box.
See Also

Help
Toolbars Command (Options Menu)
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



To group and ungroup tools
You can add spaces between tools to organize them into groups and make them easier to 
find.
To group tools

1 From the Options menu or the toolbar shortcut menu, choose Toolbars.
You can also choose Customize from the toolbar shortcut menu.
If the dialog box covers up the toolbar, you can move it out of the way by dragging the 
title bar of the dialog box.

2 On the toolbar, drag the tool that you want to group with another tool toward that tool, 
but not past it. 

3 Release the mouse button and the tool will move with its border adjacent to the next 
tool.
Microsoft Excel removes the space between the two tools.

To ungroup tools
1 From the Options menu or the toolbar shortcut menu, choose Toolbars.

You can also choose Customize from the toolbar shortcut menu.
If the dialog box covers up the toolbar, you can move it out of the way by dragging the 
title bar of the dialog box.

2 Drag the tool before which you want to insert the space to the right, or down on a 
vertical toolbar, but not past the next tool.
Microsoft Excel inserts a space preceding, on the left or above, the tool you dragged.

To insert a space before a tool that is followed by a space
Drag the tool just past its original position, but not past the middle of the next tool.

See Also
Help
Toolbars Command (Options Menu)
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



To move and copy tools
To move a tool

1 From the Options menu or the toolbar shortcut menu, choose Toolbars.
You can also choose Customize from the toolbar shortcut menu.
If the dialog box covers up the toolbar, you can move it out of the way by dragging the 
title bar of the dialog box.

2 Drag the tool to a new location on the same toolbar or another displayed toolbar.
Microsoft Excel closes up the space where the tool was and shifts tools to 
accommodate the new location of the tool.

To copy a tool
1 From the Options menu or the toolbar shortcut menu, choose Toolbars.

You can also choose Customize from the toolbar shortcut menu.
If the dialog box covers up the toolbar, you can move it out of the way by dragging the 
title bar of the dialog box.

2 Hold down CTRL and drag the tool to the new location on the same toolbar or another 
displayed toolbar.
Microsoft Excel shifts tools to accommodate the copy of the tool.

See Also
Help
Toolbars Command (Options Menu)
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



To change the shape of a floating toolbar
You change the shape of a floating toolbar in the same way that you change the size of a 
document window.

Drag any of the toolbar window borders.
If you change the toolbar height and width, Microsoft Excel automatically wraps the 
tools to fit in the new toolbar shape.
If you move the toolbar back to the toolbar dock, Microsoft Excel aligns the tools to fit 
in the horizontal or vertical toolbar dock.
Toolbars with drop-down lists, such as the style box, cannot be docked in a vertical 
position.

See Also
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



To create a new toolbar
To create a new toolbar using menu commands

1 From the Options menu or the toolbar shortcut menu, choose Toolbars.
2 In the Toolbar Name box, type the name of the new toolbar.

Once you have created a toolbar, you cannot rename it.
3 Choose the Add button or the Customize button.

Microsoft Excel displays a new blank toolbar in its own toolbar window and displays the 
Customize dialog box so that you can add tools to the toolbar.

4 In the Categories box, select the category of tools from which you want to add tools to 
the new toolbar.
Microsoft Excel displays the tools for that category in the Tools box.    
To display a description of the tool, click the tool in the Tools box.

5 Drag the tool from the Tools box to the position on the new toolbar where you want to 
add the tool.
You can also drag tools from a displayed toolbar to the new toolbar.    This moves the 
tool from the original toolbar to the new toolbar. 
Hold down CTRL while you drag the tool to place a copy of the tool on the new toolbar 
without affecting the original toolbar.

6 Repeat steps 4 and 5 until you have added all the tools you want.
Microsoft Excel resizes the toolbar to accommodate the added tools.
If you change your mind, you can remove the tool from the toolbar by dragging it off 
the toolbar and placing it anywhere there is no toolbar.

7 Choose the Close button.
To create a new toolbar by dragging

1 From the Options menu or the toolbar shortcut menu, choose Toolbars.
You can also choose Customize from the toolbar shortcut menu.

2 Choose the Customize button.
3 In the Categories box, select the category of tools from which you want to add tools to 

the new toolbar.
Microsoft Excel displays the tools for that category in the Tools box.    
To display a description of the tool, click the tool in the Tools box.

4 Drag a tool from the Tools box out of the dialog box and place it where there is no 
toolbar, or hold down CTRL and drag a tool from a displayed toolbar.
Microsoft Excel creates a toolbar for the tool and names it Toolbar 1.    If Toolbar 1 
already exists, Microsoft Excel names it Toolbar 2, and so on.    You will not be able to 
rename this toolbar.

See Also
Help
Moving and copying tools
Toolbars Command (Options Menu)
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



To display and hide toolbars
To display a toolbar with the Toolbars command

1 From the Options menu, choose Toolbars.
Shortcut: CTRL+7 (Standard toolbar only)

2 In the Show Toolbars box, select the toolbar you want to display.
3 Choose the Show button.

The Show button changes to the Hide button if the selected toolbar is already 
displayed.

To hide a toolbar
1 From the Options menu, choose Toolbars.

Shortcut: CTRL+7 (Standard toolbar only)
2 In the Show Toolbars box, select the toolbar you want to hide.
3 Choose the Hide button.

The Hide button changes to the Show button if the selected toolbar is not already 
displayed.
If the toolbar is displayed in a separate toolbar window with a window border, you can 
hide the toolbar by clicking the Control-menu box.

To display or hide a toolbar from the toolbar shortcut menu
From the toolbar shortcut menu, choose the name of the toolbar you want to display 

or hide.    
Microsoft Excel places a check mark next to the name of each displayed toolbar.
If you create additional toolbars and not all of the toolbar names can fit on the toolbar 
shortcut menu, choose the More Toolbars command on the toolbar shortcut menu to 
see the names of additional toolbars that you can display.

See Also
Help
Control-Menu Box
Toolbars Command (Options Menu)
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



To add or delete a tool from a toolbar
To add a tool to a toolbar

1 From the Options menu or toolbar shortcut menu, choose Toolbars.
You can also choose Customize from the toolbar shortcut menu.

2 Choose the Customize button.
3  In the Categories box, select the category of tools from which you want to add a tool.

Microsoft Excel displays the tools for that category in the Tools box.
To display a description of a tool, click the tool in the Tools box.

4 Drag the tool from the Tools box to the position on a displayed toolbar where you want 
to add the tool.
Microsoft Excel resizes the toolbar to accommodate the added tool.

To delete a tool from a toolbar by dragging it
1 From the Options menu or the toolbar shortcut menu, choose Toolbars.

You can also choose Customize from the toolbar shortcut menu.
Built-in tools are not deleted from Microsoft Excel when you remove them from the 
toolbars.
A tool that you customized is permanently deleted once you delete it from the toolbar.
If you want to delete a custom tool from a toolbar but save it for later use, create a 
toolbar for storing unused tools, and then move the tool that you want to delete to this 
storage toolbar.

2 To delete a tool, drag the tool off the toolbar and place it anywhere where there is no 
toolbar, including on the dialog box.

To delete a tool from the toolbar using a menu command
1 From the Options menu or the toolbar shortcut menu, choose Toolbars.

You can also choose Customize from the toolbar shortcut menu.
2 Select the tool that you want to delete.
3 From the toolbar shortcut menu, choose Delete Tool.

See Also
Help
Delete Tool Command
Toolbars Command (Options Menu)
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



To customize the appearance of a tool
To change the appearance of a tool
You can copy a picture from a graphics application and paste it onto a tool.    You should 
copy a picture that is the same size as the built-in tool images (16 by 15 pixels or bits) so 
that the picture will be clear when it appears in the tool. The best way to make sure that 
your tool picture is the correct size is to copy the image of any tool provided with Microsoft 
Excel into your graphics application and then draw the picture inside the boundaries of the 
tool.

1 Copy the picture that you want on the tool to the Clipboard.    
If the application you are copying from lets you select the format stored on the 
Clipboard, you can select either bitmap or picture format.

2 Switch to Microsoft Excel.
3 From the Options menu or the toolbar shortcut menu, choose Toolbars.

You can also choose Customize from the toolbar shortcut menu.
4 Click the tool that you want to change.
5 From the Edit menu or the tool shortcut menu, choose Paste Tool Face.

If the image is larger than the tool (16 x 15 pixels or bits), Microsoft Excel scales it to fit
the tool.

To copy a tool face to another tool
Use this procedure if you want to use the image from a built-in tool or a custom tool as the 
picture on a new tool.

1 From the Options menu or toolbar shortcut menu, choose Toolbars.
You can also choose Customize from the toolbar shortcut menu.

2 Select the tool whose image you want to copy to another tool by clicking the tool on 
the toolbar or in the Customize dialog box.

3 From the Edit menu, choose Copy Tool Face.
If you selected a tool on a displayed toolbar, you can also choose Copy Tool Face from 
the tool shortcut menu.

4 On the toolbar, click the tool on which you want to paste the copied image.
5 From the Edit menu or the tool shortcut menu, choose Paste Tool Face.

To restore the original appearance of a tool
1 From the Options menu or the toolbar shortcut menu, choose Toolbars.

You can also choose Customize from the toolbar shortcut menu.
2 Click the tool whose appearance you want to restore.
3 From the tool shortcut menu, choose Reset Tool Face.

See Also
Help
Copy Tool Face Command (Edit Menu)
Paste Tool Face Command (Edit Menu)
Reset Tool Face Command
Toolbars Command (Options Menu)
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



To assign or record a macro to a tool
To assign an existing macro to a custom tool

1 From the Options menu or the toolbar shortcut menu, choose Toolbars.
You can also choose Customize from the toolbar shortcut menu.

2 Choose the Customize button.
3 In the Categories box, select Custom.

Microsoft Excel provides custom tools with a variety of tool faces as well as a blank 
tool.

4 Drag the tool you want from the Tools box to the position on the toolbar where you 
want to add the tool.    
Microsoft Excel displays the Assign To Tool dialog box.

5 In the Assign Macro box, select the name of the command macro you want to assign to 
the tool, or type a macro name or cell reference in the Reference box.
Only command macros on the global macro sheet or other open macro sheets are 
listed in the Assign Macro box.
If the command macro you want to assign is not listed, type the full reference to the 
macro in the Reference box.

6 Choose the OK button.
7 Choose the Close button.

To record a new macro to a custom tool
1 From the Options menu or the toolbar shortcut menu, choose Toolbars.

You can also choose Customize from the toolbar shortcut menu.
2 Choose the Customize button.
3 In the Categories box, select Custom.

Microsoft Excel provides custom tools with a variety of tool faces as well as a blank 
tool.

4 Drag the tool you want from the Tools box to the position on the toolbar where you 
want to add the tool.    
Microsoft Excel displays the Assign To Tool dialog box.

5 Choose the Record button.
Microsoft Excel displays the Record Macro dialog box.

6 Type the name for the macro and a shortcut key.
7 Choose the OK button.

Microsoft Excel enters the macro name in the global macro sheet or in the new macro 
sheet, and then starts recording.
The Stop Recording Macro tool appears.

8 Carry out the actions you want recorded in the command macro.
9 When you are finished, click the Stop Recording Macro tool or choose Stop Recorder 

from the Macro menu.
See Also

Help
Stop Recording Macro Tool

Assign To Tool Command (Macro Menu)
Creating a custom tool
Customizing the appearance of a tool



Record and Stop Recorder Commands (Macro Menu)
Stop Recording Toolbar
Toolbars Command (Options Menu)
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



To change the action that a tool performs
You can assign a macro to a built-in tool to change what the tool does, or you can change 
the macro assigned to a custom tool.

1 From the Options menu or the toolbar shortcut menu, choose Toolbars.
You can also choose Customize from the toolbar shortcut menu.

2 Choose the Customize button.
3 On the toolbar, click the tool that you want to change.
4 From the Macro menu, choose Assign To Tool. 

Microsoft Excel displays the Assign To Tool dialog box.
Shortcut: From the tool shortcut menu, choose Assign Macro To Tool.

5 In the Assign Macro box, select the name of the command macro you want to assign to 
the tool, or type a macro name or cell reference in the Reference box.
Only command macros on the global macro sheet or other open macro sheets are 
listed in the Assign Macro box.
If the command macro you want to assign is not listed, type the full reference to the 
macro in the Reference box.
You can also record a new macro by choosing the Record button.

6 Choose the OK button.
If you are recording a macro and assigning it to the tool, stop here.

7 If you are assigning a previously recorded macro, choose the Close Button.
See Also

Help
Assign To Tool Command (Macro Menu)
Creating a custom tool
Toolbars Command (Options Menu)
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



To create a custom tool
You can create custom tools by:

Assigning or recording a macro to a tool
Changing the action that a tool performs
Customizing the appearance of a tool

See Also
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



To move a toolbar
To move a toolbar 

1 Position the mouse pointer in a blank area in the toolbar, or on the toolbar title bar if it 
is a floating toolbar.

2 Drag the toolbar to a new location in the toolbar dock, or anywhere else in the 
workspace.
If you place the toolbar in the toolbar dock, Microsoft Excel automatically shifts the 
other toolbars to accommodate the moved toolbar.
If the    moved toolbar would shift an entire toolbar off the screen, Microsoft Excel wraps
the shifted toolbar to the next row of a horizontal toolbar dock or to the next column of 
a vertical toolbar dock.

To move a toolbar to a new row or column in a toolbar dock
Use this procedure if you have two or more toolbars displayed in a toolbar dock and you 
want to move one of the toolbars into its own row or column.

1 Position the mouse pointer in a blank area of the toolbar.
2 Drag the toolbar toward the center of the screen but not completely beyond the toolbar

dock.
As you drag the toolbar, Microsoft Excel displays a dotted border the same size as the 
toolbar to show the new position of the toolbar.
The toolbar border changes to a thick border if you drag the toolbar completely beyond
the toolbar dock and release the mouse button.    This indicates a floating toolbar.

To quickly move toolbars on and off the toolbar dock
Position the mouse pointer in a blank area of the toolbar or in the title bar of a 

floating toolbar, and double-click.
If the toolbar is in a toolbar dock, Microsoft Excel moves the toolbar to its previous 
floating position outside of a toolbar dock.
If the toolbar is a floating toolbar, Microsoft Excel moves the toolbar to the last toolbar 
dock on which it was placed.

See Also
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



To reset a built-in toolbar
If you have customized a built-in toolbar, you can restore it to its original configuration.

1 From the Options menu or the toolbar shortcut menu, choose Toolbars.
2 In the Show Toolbars box, select the toolbar you want to restore.
3 Choose the Reset button.

If the Reset button has changed to a Delete button, you have selected a custom toolbar
and not a built-in toolbar.    You cannot reset a custom toolbar.

4 Choose the Close button.
See Also

Help
Toolbars Command (Options Menu)
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



To transpose ranges from columns to rows or from rows to columns
1 Select the cells you want to transpose.
2 From the Edit menu or the shortcut menu, choose Copy.

Shortcuts: Copy tool (Utility toolbar)
CTRL+C

3 Select the upper-left cell of the paste area.
4 From the Edit menu, choose Paste Special.
5 Select    the Transpose check box.
6 Choose the OK button.
7 Cancel the moving border by pressing ESC or choosing another command.

See Also
Help
Copy Command (Edit Menu)
Displaying and hiding a toolbar
Paste Special Command (Edit Menu)
Toolbars Command (Options Menu)



To zoom in or out on your worksheet
1 From the Window menu, choose Zoom.

Shortcuts: Zoom In tool (Utility toolbar)
Zoom Out tool (Utility toolbar)

2 Under Magnification, select an option or type a size in the Custom box.
For a description of the options, choose the Help button.

3 Choose the OK button.
To zoom an area of your worksheet to fit the current window size

1 Select the rows, columns, or range you want to fit in the window.
2 From the Window menu, choose Zoom
3 Under Magnification, select the Fit Selection option button.
4 Choose the OK button.

See Also
Help
Zoom Command (Window Menu)
Toolbars Command (Options Menu)
Utility Toolbar

Zoom In Tool
Zoom Out Tool

User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



To update linked information
1 Switch to the dependent worksheet.
2 From the File menu, choose Links.
3 In the Link Type box, select the type of link you want to update.

Microsoft Excel displays a list of all the source worksheets for the dependent worksheet
with the link type you specified.

4 In the Links box, select the name of the document you want to update.
To select several documents at once, hold down SHIFT and click the name of each 
document you want to update.
When using the keyboard, hold down CTRL as you press the UP or DOWN ARROW key to 
move to each document.    To add a document to the selection, press the SPACEBAR.

5 Choose the Update button to update values in the selected documents.
To update information in a Microsoft Excel document linked to another 
application

When you open a worksheet containing links to other applications, Microsoft Excel 
displays a message asking if you want to reestablish those links.

Choose the OK button to reestablish the links and update the references.
Choose the Cancel button to freeze the linked references and use the worksheet's 

existing values.
See Also

Help
Linking and Embedding
Links Command (File Menu)



To use a template
When you create a new chart from a chart template, the    data series that were used to 
create the chart on the template are not used for the new chart.    Instead, the selection on 
the active worksheet is used to supply the data series for the new chart.    Only the 
formatting characteristics of the template chart are used to create the new chart.

1 To open a template in the startup directory, choose New from the File menu.
To open a template in any other directory, choose Open from the File menu.

2 Select the template on which you want to base a new document.
In the Open dialog box you can also select a different drive and directory.    You can list 
only templates by selecting Microsoft Excel Templates (*.XLT) in the List Files Of Type 
box.    You can also type the complete path and filename in the File Name box.

3 Choose the OK button.
Microsoft Excel opens a copy of the template for you to use, and gives it a temporary 
name.

See Also
Help
Creating a new template
Editing a template 
Saving a document as a template
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



To view a list of files in a directory
1 From the File menu, choose Open.
2 In the File Name box, type a file specification and choose the OK button, or select a file 

specification from the List Files Of Type box.
The file specification can include the filename, the drive, and the directory.    It can also 
include the wildcard characters ? (question mark) to match a single character, and * 
(asterisk) to match any number of characters.
The Files box displays the names of all files matching the file specification you typed.

3 When you have finished viewing the list, choose the Cancel button to close the dialog 
box.

To view all Microsoft Excel files in a directory
1 From the File menu, choose Open.
2 In the List Files Of Type box, select MS Excel Files (*.XL*).
3 Choose the OK button.
4 When you have finished viewing the list, choose the Cancel button.

To view all files in a directory
1 From the File menu, choose Open.
2 In the List Files Of Type box, select All Files (*.*).
3 Choose the OK button.
4 When you have finished viewing the list, choose the Cancel button.

See Also
Help
Open Command (File Menu)



To view a list of source documents for a dependent worksheet
1 Switch to the dependent worksheet.
2 From the File menu, choose Links.
3 In the Link Type box, select the type of link you want to view.

Microsoft Excel displays a list of all the source documents for the dependent worksheet 
with the link type you specified.

4 When you have finished viewing the list, choose the Cancel button.
See Also

Help
Linking and Embedding
Links Command (File Menu)



To view text notes
1 Select any cell in the worksheet.
2 From the Formula menu, choose Note.

A list of all notes in the worksheet appears in the Notes In Sheet box.    To scroll through
the list, use the scroll bar.

3 Select the note you want to view.
4 The text of the note is displayed in the Text Note box.
5 When you are finished viewing the notes, choose the Close button.

See Also
Help
Note Command (Formula Menu)
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



To turn drag and drop on or off
1 From the Options menu, choose Workspace.
2 Select the Cell Drag and Drop check box.
3 Choose the OK button.

Turning off the drag and drop option also turns off the AutoFill option.
You can still use the Cut and Paste commands on the Edit menu with this check box 
selected.

See Also
Help
Cut Command (Edit Menu)
Paste Command (Edit Menu)
Using Drag and Drop
Workspace Command (Options Menu)



To turn AutoFill on or off
1 From the Options menu, choose Workspace.
2 Select the Cell Drag And Drop check box.
3 Choose the OK button.

Turning off the AutoFill option also turns off the drag and drop option.
You can still use the Cut and Paste commands on the Edit menu with this check box 
selected.

See Also
Help
Cut Command (Edit Menu)
Paste Command (Edit Menu)
Using AutoFill
Workspace Command (Options Menu)



To arrange workbook documents in separate windows
1 Switch to the Workbook Contents window.
2 Select the name of a workbook document you want to display.
3 From the Window menu, choose New Window.

The workbook document now appears in its own window.
4 To display the Workbook Contents window again, choose the workbook name from the 

bottom of the Window menu.
Do not use the paging buttons to display the Workbook Contents window, or your 
document window will disappear.

5 Repeat steps 1 through 4 for each workbook document you want to display.
6 From the Window menu, choose Arrange.
7 Select the type of screen arrangement you want: Tiled, Horizontal, or Vertical.

The Documents Of Active Workbook check box will be selected.
8 Choose the OK button.

To save your workbook with this window arrangement, choose Save Workbook from the
File menu.

See Also
Help
Arrange Command (Window Menu)
Moving between workbook documents
Opening a new window of a document in a workbook



Buttons
Created on worksheets or macro sheets with the Button tool.    You can assign a macro to a 
button, format the text in a button, and move or size a button.

Clicking the Button tool on the toolbar and dragging across the active worksheet or 
macro sheet creates a button on the sheet and displays the Assign To Object dialog box.

You can type the text you want on a button, and then format it with the Text and Font 
commands on the Format menu.

Double-clicking a word in a button selects it.
Point to the border of the button and drag to move it to another location on the 

worksheet or macro sheet.
To resize a button, select the button, click one of the handles, and drag until it is the 

size you want.
Once a macro is assigned to a button, you can hold down the CTRL key and click the 

button to select it.
See Also

Help
Assigning a macro to a graphic object
Creating a button on a worksheet or macro sheet
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Chart
A chart is a graphic presentation of worksheet data.    Microsoft Excel offers 14 types of 
charts, in 88 built-in formats.

Chart types are:    area, bar, column, line, pie, radar, xy (scatter), combination, 3-D 
area, 3-D bar, 3-D column, 3-D line, 3-D pie, and 3-D surface.

To change the chart type, you use the commands on the Gallery menu.
To customize a chart, you use the commands on the Chart menu and the Format 

menu.



Embedded Charts
Created on worksheets with any chart tools on the Chart toolbar, or with the ChartWizard on
the Standard toolbar.    Embedded charts are objects created on a worksheet, based on 
selected cells from that worksheet or another worksheet.    An embedded chart is linked to 
its source data, but unlike a chart document, an embedded chart is saved as part of the 
worksheet in which it was created.    You can format, move, and size an embedded chart, or 
open the embedded chart in a chart window and then edit, format, and save it as a chart 
document.

Double-clicking an embedded chart opens the chart in its own window.    You can then
edit and format the chart just as you do any Microsoft Excel chart.    Double-click the chart 
again to display the Patterns dialog box, which allows you to format the chart.    Once you 
have opened the chart in a chart window, you can save the chart as a separate document.

To move an embedded chart, drag the chart to another location on the worksheet.
To resize an embedded chart, select the chart, point to one of the handles, and drag 

until it is the size you want.
See Also 

Help
ChartWizard Tool
Preferred Chart Tool

Chart Toolbar
Chart Tools Category
Creating a new chart
Formatting a chart on a worksheet
Standard Toolbar
User's Guide (Book 1)
Chapter 12, "Creating a Chart"



Clipboard
The Clipboard is a temporary holding area for the information you cut or copy with the Cut, 
Copy, or Copy Picture command.    If you cut or copy worksheet cells, the Clipboard shows 
the size of the area you cut or copied.    The information remains on the Clipboard until you 
cut or copy other information or quit Microsoft Excel.    From the Clipboard, you can paste cut
or copied data to another location on a worksheet, to a different Microsoft Excel document, 
or to a document in another application.



Control-Menu Box
With the mouse, you can click the Control-menu box to display the Control menu, which 
contains commands that control the size and position of the Microsoft Excel window.

    Controls document window
    Controls Microsoft Excel window

The Control-menu box is located at the left end of the title bar.



Drawn Objects
Graphic objects such as lines, arcs, ovals, and rectangles that you draw on a worksheet or 
macro sheet using the tools on the Drawing toolbar.    You can format, move, and size drawn
objects.

To display the Patterns dialog box so you can change formatting, double-click an 
object.    You can also select an object and choose Patterns from the Format menu.

To move a drawn object to another location on the worksheet or macro sheet, drag 
the object.

To resize a drawn object, select the object, point to one of the handles, and drag until 
it is the size you want.
See Also

Help
Drawing lines and shapes with the tool bar
Grouping and ungrouping graphic objects
Moving and sizing a graphic object along with cells
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Formula Bar 
The formula bar is used to enter or edit data in worksheet cells or in charts.    The formula 
bar also displays the reference of the active cell, or selected objects and the size of a 
selection.
    To enter data, select a cell, type the data, and click the enter box on the formula bar 

 or press ENTER.    The data appears in the formula bar as you type.
To edit data, click the formula bar with the mouse or press F2.    Then type your 

changes and click the enter box or press ENTER.
To cancel your changes, click the cancel box on the formula bar    

 or press ESC.



Grouped Objects
You can select two or more objects (buttons, embedded charts, drawn objects, pictures, and
text boxes), group them together, and format, move, or size them as you would an 
individual object.

To group several objects, use the Selection tool on the Drawing tool bar to enclose 
the objects you want to include in the group.    You can also select the objects you want to 
group and click the Group tool on the Drawing toolbar or choose the Group command from 
the Format menu. 

You can format a selected group of objects using the Patterns command on the 
Format menu.    The options you choose in the Patterns dialog box affect all the objects in the
group, if applicable.    For example, if you select an arrow, a button, a circle, and a text box, 
and you choose Patterns from the Format menu and select the Shadow check box, only the 
button, circle, and text box are formatted with a shadow.

You can resize a selected group of objects.    When the mouse pointer is over one of 
the selection handles, it changes to a cross hair.    Drag the selection handle to resize the 
objects.

To move a group of objects to a different location on a worksheet, select the group 
and drag it to the new location.    You can also use the Cut and Paste commands on the Edit 
menu.
See Also

Help
Creating a button on a worksheet or macro sheet
Drawing lines and shapes with the toolbar
Grouping and ungrouping graphic objects
Selecting a graphic object
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Info Window
The Info window displays information about the active cell when you choose the Workspace 
command from the Options menu and select the Info Window check box.

When the Info window is active, Info window menus are displayed.
The first time you open the Info window, it automatically displays the active cell's 

reference, formula, and note.
Each item currently displayed in the Info window is indicated by a check mark next to

its corresponding command name on the Info menu.    To display additional information in the
Info window, choose a command without a check mark.    To stop displaying an item of 
information, choose a command with a check mark.

You can save the Info window's display settings with the Save Workbook command on
the File menu.

To close the Info window, double-click the Control-menu box or click the worksheet.
Shortcut: CTRL+F2



Macro Sheet
A document much like a worksheet except that it contains sets of instructions (macros) for 
accomplishing specific tasks.

You can use the same functions in a macro sheet that you use in a worksheet.
When a macro sheet is open, its macros are listed in the Run dialog box.
When a macro sheet is the active document, macro functions are listed alphabetically

in the Paste Function dialog box.
Because macro sheets normally display formulas instead of values, the default 

column width is wider than it is for worksheets.
See Also

User's Guide (Book 2)
Chapter 6, "Automating Tasks with Command Macros"



Outlining Symbols
The outlining symbols are displayed on a worksheet that contains an outline.    They include 
the expand button, the collapse button, the outline level buttons, and the outline level bars.
    The expand button indicates a summary row or column with hidden detail.    Click the 

expand button to display collapsed levels.
    The collapse button indicates a summary row or column with detail rows or columns 
displayed.    Click the collapse button to hide the rows or columns indicated by the column or
row level bar.

Row and column level buttons indicate the number of row and column levels in an 
outline.    Click these buttons to display specific levels of data in an outline.
    Outline level 1

    Outline level 2
    Outline level 3
    Outline level 4
    Outline level 5
    Outline level 6
    Outline level 7
    Outline level 8

Row and column level bars indicate that all the detail rows and columns are 
displayed.    Click the collapse button or click anywhere on the level bar to hide the detail 
rows or columns.
See Also

Help
Clearing an outline from a worksheet
Collapsing an outline level
Creating an outline from an existing worksheet
Displaying an outline level
Expanding an outline level



Single Step Dialog Box
You can display the Single Step dialog box when you want to run a macro one step at a 
time.    This technique is often used for debugging a macro.

This dialog box shows which cell in the macro is about to be calculated and what 
formula is in that cell.
Step Into

Carries out the next instruction in the macro, including user-defined function calls.
Step Over

Carries out the next instruction in the macro.    Carries out, but does not step through, 
user-defined function calls.

Evaluate
Evaluates each part of the formula in the active cell.    If chosen repeatedly, this button 
will Step Into the macro, not Step Over.

Pause
Closes the dialog box and suspends the macro, allowing you to perform other tasks.    
To return to the Single Step dialog box, click the Resume Macro tool on the Macro 
Paused toolbar, which appears whenever you pause a macro, or choose Resume from 
the Macro menu.

Halt
Stops the macro.

Continue
Runs the rest of the macro without single-stepping.

Goto
Stops the macro and selects the cell currently being evaluated on the macro sheet.

See Also
Help

Resume Macro Tool
Run Macro Tool
Step Macro Tool

Macro Paused Toolbar
Macro Toolbar
Stepping through a macro
Toolbars Command (Options Menu)



Maximize Button          
    Click the Maximize button with the mouse to enlarge a window to its maximum size.

A maximized document window fills as much of the Microsoft Excel window as 
possible and has no borders.

You can maximize the Microsoft Excel window only if it does not fill the screen, or if it 
has been minimized to an icon.

Clicking the Maximize button has the same effect as choosing the Maximize 
command from the Control menu.

To restore a maximized window to its former size, click the Restore button or choose 
Restore from the Control menu.



Minimize Button          
    Click the Minimize button with the mouse to shrink the Microsoft Excel window to an icon.

As an icon, Microsoft Excel remains in memory but does not take up room on your 
desktop.

When you minimize the Microsoft Excel window, any open documents are minimized 
with it.

Clicking the Minimize button has the same effect as choosing the Minimize command 
from the Control menu.

To restore the Microsoft Excel window and any documents that were open when you 
minimized it, you can double-click the icon, or click the icon and choose Restore from the 
Control menu.



Pictures
Charts or cells that are copied as pictures and pasted to a different part of the worksheet or 
another worksheet or macro sheet.    Pictures can also be graphics copied into Excel from a 
graphics program, or created with Excel's drawing tools.    Pictures can be formatted, moved,
or sized just as other graphic objects are.

You can create pictures of charts and cells with the Copy Picture command on the 
Edit menu.    These pictures are not linked to their source data.

You can link pictures of cells to their source data using the Camera tool on the Utility 
toolbar, but you cannot link pictures of charts to their source data.

To switch to the source document, double-click a linked picture.    Linked pictures are 
updated automatically when you update the formats, data, or gridlines in the source 
document.
See Also

Help
Creating links 
Selecting graphic objects
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Print Preview Window
In the print preview window, you can preview pages and adjust margins and column widths 
on the screen before printing.

To scroll through the document, choose the Next or Previous button.
To switch between actual-size view and full-page view of the document, choose the 

Zoom button.
To print the document, choose the Print button.
To display the Page Setup dialog box, choose the Setup button.
To adjust margins and column widths, choose the Margins button.

There are three ways to display the Print Preview window:
Click the Print Preview tool on the Standard toolbar.
From the File menu, choose Print Preview.
From the File menu, choose Print.    Select the Preview check box, and then choose 

the OK button.
See Also

Help
Print Preview tool
User's Guide (Book 1)
Chapter 16, "Printing"



Restore Button
Click the Restore button with the mouse to return a window to its previous size and 

location.
Clicking the Restore button has the same effect as choosing the Restore command 

from the Control menu.
The Restore button does not affect changes made to a window with the Move or Size 

command on the Control menu.
See Also

Help
Control Menu



Scroll Bars
The shaded bars along the right and bottom sides of a window.

With the scroll bars, you can move through a long document or Help topic.
The position of the scroll box in the scroll bar indicates the part of the document or 

topic currently displayed in the window.    To scroll quickly to another part of the document or
topic, drag the box.

To scroll one row or column in a given direction, click the arrow at that end of the bar. 
To scroll one window in a given direction, click the bar on that side of the scroll box.
To quickly scroll to the last row used in your worksheet, hold down SHIFT while you 

drag the scroll box to the bottom of the scroll bar.



Split Bar
The split bar divides a window into separate panes.

Panes on either side of a vertical split scroll together vertically.    Panes above and 
below a horizontal split scroll together horizontally.

You can split a window by using the Split command on the Window menu.
To remove a split, double-click the split bar or choose Remove Split from the Window 

menu.
See Also

Help
Splitting a window into panes



Status Bar
Displays information about the current activity or mode.

When a command is selected, the left side of the status bar briefly describes the 
command.

The left side of the status bar also indicates operations in progress, such as copying 
cells or recording a macro.

The right side of the status bar shows whether keys such as CAPS LOCK or NUM LOCK are 
turned on.

You can hide the status bar with the Workspace command on the Options menu.



Text Boxes
Created on worksheets and macro sheets with the Text Box tool on the Utility toolbar.    You 
can move and size the text box, or format the text, border and background pattern.

Text typed in a text box wraps automatically.
To select a word in a text box, double-click the word.
To select the entire text box when text inside a text box is selected, click the border 

of the text box.
To display the Patterns dialog box, double-click the border of the text box.
To move a text box on the worksheet or macro sheet, point to the text box border and

drag it to the location you want.
To resize a text box, select the text box, point to one of the handles, and drag until it 

is the size you want.
See Also

Help
Adding a text box to a worksheet
Formatting text box borders and fill patterns
Moving and sizing a graphic object along with cells
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Title Bar
The bar across the top of a window that contains the window's name.

You can move the active window by dragging the title bar with the mouse.
You can also move a window by choosing the Move command from the Control menu 

of the document window.
A dialog box can also be moved by dragging its title bar.



Window Sizing Border
The border around a window.    You can drag a border with the mouse to change the 
window's shape and size.

Drag the top, bottom, or side border to size in one direction only.
Drag a corner of the border to size in two directions at once.
You can also size a window by using the Size command on the Control menu.



Worksheet
The main document for storing and manipulating data.

To enter data, select a cell, type the data, and click the enter box or press ENTER.
To edit data, use commands on the Edit menu.
To format the worksheet, use commands on the Format menu.

See Also
Help
Worksheets
Entering text or numbers into a cell
Editing cell contents
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"
Chapter 6, "Editing a Worksheet"
Chapter 7, "Formatting a Worksheet"



Bold Tool
Applies bold formatting to selected text in text boxes and buttons, or to the text in a 

selected cell.    
This tool is available when a chart window is active.
This tool is unavailable when a drawn object or picture is selected.

Shortcut: CTRL+B

See Also
Help
Font Command (Format Menu for Charts)
Font Command (Format Menu for Worksheets)
Formatting the chart text font
Formatting Toolbar
Standard Toolbar
Text Formatting Tools Category
Toolbar
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"
Chapter 14, "Formatting a Chart"



Italic Tool
Applies italic formatting to selected text in text boxes and buttons, or to the text in a 

selected cell.    
This tool is available when a chart window is active.
This tool is unavailable when a drawn object or picture is selected.

Shortcut: CTRL+I

See Also
Help
Font Command (Format Menu for Charts)
Font Command (Format Menu for Worksheets)
Formatting the chart text font
Formatting Toolbar
Standard Toolbar
Text Formatting Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"
Chapter 14, "Formatting a Chart"



Underline Tool
Underlines selected text in text boxes and buttons, or the text in a selected cell.    
This tool is available when a chart window is active.
This tool is unavailable when a drawn object or picture is selected.

Shortcut: CTRL+U

See Also
Help
Font Command (Format Menu for Charts)
Font Command (Format Menu for Worksheets)
Formatting Toolbar
Text Formatting Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"
Chapter 14, "Formatting a Chart"



Strikeout Tool
Draws a line through the selected text in text boxes and buttons, or the text in a 

selected cell.
This tool is available when a chart window is active.
This tool is unavailable when a drawn object or picture is selected.

Shortcut: CTRL+5

See Also
Help
Font Command (Format Menu for Charts)
Font Command (Format Menu for Worksheets)
Formatting Toolbar
Text Formatting Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"
Chapter 14, "Formatting a Chart"



Left Align Tool
Aligns the contents of a selected text box, button, or cell to the left. 
This tool is available when a chart window is active.
This tool is unavailable when a drawn object or picture is selected.
If no alignment tool is selected, General alignment is applied.

See Also
Help
Aligning text and numbers within cells
Formatting chart text alignment and orientation
Standard Toolbar
Text Formatting Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"
Chapter 14, "Formatting a Chart"



Right Align Tool
Aligns the contents of a selected text box, button, or cell to the right.    
This tool is available when a chart window is active.
This tool is unavailable when a drawn object or picture is selected.
If no alignment tool is selected, General alignment is applied.

See Also
Help
Aligning text and numbers within cells
Formatting chart text alignment and orientation
Standard Toolbar
Text Formatting Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"
Chapter 14, "Formatting a Chart"



Center Align Tool
Centers the contents of a selected text box, button, or cell.
This tool is available when a chart window is active.
This tool is unavailable when a drawn object or picture is selected.
If no alignment tool is selected, General alignment is applied.

See Also
Help
Aligning text and numbers within cells
Formatting chart text alignment and orientation
Standard Toolbar
Text Formatting Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"
Chapter 14, "Formatting a Chart"



Line Tool
Draws a straight line.
When you select the Line tool, the mouse pointer changes to a cross hair.    
To draw multiple lines, double-click the Line tool.    The Line tool remains selected 

until you click it again, click another tool, press ESC, or click another part of the worksheet 
without dragging.

To draw horizontal, vertical, or 45-degree diagonal lines, hold down the SHIFT key 
while dragging.

If you want the line that you are drawing to automatically line up with the nearest 
gridline, hold down the ALT key while drawing the line.
See Also

Help
Arrow Tool
Drawing lines, ovals, arcs, or rectangles
Drawing Toolbar
Drawing Tools Category
Drawn Objects
Toolbars
Tools
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Rectangle Tool
Draws a rectangle or square.
When you select the Rectangle tool, the mouse pointer changes to a cross hair.    
To draw a square, hold down the SHIFT key while dragging.
To draw multiple rectangles or squares, double-click the Rectangle tool.    The 

Rectangle tool remains selected until you click it again, click another tool, press ESC, or click 
another part of the worksheet without dragging.

If you hold down SHIFT while clicking this tool, it functions like the Filled Rectangle 
tool.

If you want the rectangle or square that you are drawing to adjust automatically to fit
the nearest row and column, hold down the ALT key while drawing the rectangle or square.
See Also

Help
Drawing lines, ovals, arcs, or rectangles
Drawing Toolbar
Drawing Tools Category
Drawn Objects
Toolbars
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Oval Tool
Draws an oval or circle.    
When you select the Oval tool, the mouse pointer changes to a cross hair.    
To draw a circle, hold down the SHIFT key while dragging.
To draw multiple ovals or circles, double-click the Oval tool.    The Oval tool remains 

selected until you click it again, click another tool, press ESC, or click another part of the 
worksheet without dragging.

If you hold down SHIFT while clicking this tool, it functions like the Filled Oval tool.
If you want the oval or circle that you are drawing to adjust automatically to fit the 

nearest row and column, hold down the ALT key while drawing the oval or circle.
See Also

Help
Drawing lines, ovals, arcs, or rectangles
Drawing Toolbar
Drawing Tools Category
Drawn Objects
Toolbars
Tools
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Arc Tool
Draws an arc or circle segment.
The circle segment is one quarter of a full circle.
When you click the Arc tool, the mouse pointer changes to a cross hair.    
To draw a circle segment, hold down the SHIFT key while dragging.
To draw multiple arcs, double-click the Arc tool.    The Arc tool remains selected until 

you click it again, click another tool, press ESC, or click another part of the worksheet without
dragging.

If you hold down SHIFT while clicking this tool, it functions like the Filled Arc tool.
If you want the arc that you are drawing to adjust automatically to fit the nearest row 

and column, hold down the ALT key while drawing the arc.
See Also

Help
Drawing lines, ovals, arcs, or rectangles
Drawing Toolbar
Drawing Tools Category
Drawn Objects
Toolbars
Tools
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Selection Tool
Selects one or more graphic objects.    
A selection rectangle with a dotted border appears.    Drag the mouse to expand the 

rectangle and enclose the objects you want to select.
When you release the mouse button, Microsoft Excel selects all the objects completely 
enclosed by the selection rectangle and displays handles around each of the objects.

To add another area to the selection, hold down CTRL while selecting the new area.    
The Selection tool remains selected until you click it again.
See Also

Help
Assigning a macro to a graphic object
Creating or deleting a button on a worksheet or macro sheet
Deleting a graphic object
Drawing Toolbar
Drawing Tools Category
Grouping or ungrouping graphic objects
Selecting a graphic object
Selecting multiple graphic objects and removing graphic objects from a multiple selection
Toolbars
Tools
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Group Tool
Creates a single group of graphic objects from multiple objects.
This tool is available when the active document is a worksheet or macro sheet.
This tool is available when more than one object is selected.
If you hold down SHIFT while clicking this tool, it functions like the Ungroup tool.
If only one object is selected, clicking this tool causes a beep, indicating that the tool 

is not available.
See Also

Help
Drawing Toolbar
Drawing Tools Category
Group and Ungroup Commands (Format Menu)
Grouped Objects
Grouping or ungrouping graphic objects
Selecting graphic objects
Toolbars
Tools
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Bring To Front Tool
Places one or more selected objects in front of all other objects.
This tool has no effect if the selected object is already in front.
If you hold down SHIFT while clicking this tool, it functions like the Send To Back tool.

See Also
Help
Bring To Front Command (Format Menu)
Drawing Toolbar
Drawing Tools Category
Selecting a graphic object
Toolbars
Tools
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Send To Back Tool
Places one or more selected objects behind all other objects.
This tool has no effect if the selected object is already in back.
If you hold down SHIFT while clicking this tool, it functions like the Bring To Front tool.

See Also
Help
Drawing Toolbar
Drawing Tools Category
Selecting a graphic object
Send To Back Command (Format Menu)
Toolbars
Tools
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Open File Tool
Displays the Open dialog box so that you can open an existing document.
This tool opens the same dialog box that you get when you choose the Open 

command from the File menu.
You can also use this tool to change directories.

Shortcut: CTRL+F12

See Also
Help
File Tools Category
Opening a file from a disk
Standard Toolbar
Toolbars
Tools
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



Print Preview Tool
Displays each page as it will look when you print the document.
If an embedded chart window is active, Print Preview previews the chart only.
If you hold down SHIFT while clicking this tool, it functions like the Print tool.
This tool is available when a chart window is active.

See Also
Help
Changing the layout of a printed page
File Tools Category
Previewing a document before printing
Print Preview Command (File Menu)
Toolbars
Tools
User's Guide (Book 1)
Chapter 16, "Printing"



Print Tool
Prints the active document according to the options you previously specified in the 

Print dialog box.
Before you print a chart that is embedded in a worksheet, you must display the chart 

in a chart window.
If the Info window is active, information is printed about the selected cells in the 

worksheet.
If you hold down SHIFT while clicking this tool, it functions like the Print Preview tool.

Shortcut: CTRL+SHIFT+F12

See Also
Help
File Tools Category
Print Command (File Menu)
Printing a chart
Printing a document without previewing
Printing a section of a worksheet
Standard Toolbar
Toolbars
Tools
User's Guide (Book 1)
Chapter 16, "Printing"



New Macro Sheet Tool
Creates a new macro sheet.    Clicking this tool is the same as choosing the New 

command from the File menu and selecting Macro Sheet.
This tool is available when a chart window is active.

Shortcut: CTRL+F11

See Also
Help 
Creating a new macro sheet
File Tools Category
Macro Toolbar
New Command (File Menu)
Toolbars
Tools
User's Guide (Book 2)
Chapter 5, "Creating and Using Custom Worksheet Functions"



New Worksheet Tool
Creates a new worksheet.    Clicking this tool is the same as choosing the New 

command from the File menu and selecting Worksheet.
This tool is available when a chart window is active.

Shortcut: SHIFT+F11

See Also
Help 
Changing headers and footers
Creating a new worksheet
File Tools Category
New Command (File Menu)
Standard Toolbar
Toolbars
Tools
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



New Chart Tool
Creates a new chart document in the default chart type or the chart type and format 

that are selected by the Set Preferred command on the Gallery menu.    
Clicking this tool is the same as choosing the New command from the File menu and 

selecting Chart.
Shortcut: F11

See Also
Help
File Tools Category
New Command (File Menu)
Toolbars
Tools
User's Guide (Book 1)
Chapter 12, "Creating a Chart"



AutoSum Tool
Inserts into the active cell a formula with the SUM function and a proposed sum 

range.    The proposed range is based on the data above or to the left of the active cell.
To view the sum, click the AutoSum tool again, click the enter box, or press ENTER.

See Also
Help
Formula Tools Category
Standard Toolbar
SUM()
Toolbars
Tools
Utility Tools Category



Text Box Tool
Draws a text box where you can type text on a worksheet; lets you add unattached 

text to an active chart.
Worksheets

After you draw the text box to the size and shape you want, you can type text in the 
box.    

To start a new line, press ENTER.
Charts

Type the text that you want.    
The text appears in the formula bar, where you can edit it in the same way you would 
edit text in a worksheet cell.

To insert a line break in the text, press ALT+ENTER.
When you finish typing, click the enter box or press ENTER.
The text that appears on the chart will not have a border around it.

See Also
Help
Adding a text box or an arrow to a worksheet
Adding or deleting unattached chart text
Chart Toolbar
Charting Tools Category
Drawing Toolbar
Drawing Tools Category
Text Boxes
Toolbars
Tools
Utility Toolbar
Utility Tools Category
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"
Chapter 14, "Formatting a Chart"



Button Tool
Draws a button to which you can assign a macro.    When you click the button, the 

macro runs.
To draw multiple buttons, double-click the Button tool.    The Button tool remains 

selected until you click it again, click another tool, press ESC, or click another part of the 
worksheet without dragging.
See Also

Help
Assign To Object Command (Macro Menu)
Assigning a macro to a graphic object
Buttons
Creating a button on a worksheet or macro sheet
Drawing Tools Category
Toolbars
Tools
Utility Toolbar
Utility Tools Category
User's Guide (Book 2)
Chapter 6, "Automating Tasks with Command Macros"



Camera Tool
Creates a picture of a selected range of cells and pastes the picture as an object onto

a worksheet.
The picture is linked to the source selection.    If the source selection changes, the 

picture is updated automatically.
To create multiple pictures, double-click the Camera tool.    The Camera tool remains 

selected until you click it again, click another tool, press ESC, or click another part of the 
worksheet without dragging.
See Also

Help
Copying cells to multiple locations
Copying data
Copying to another worksheet or application
Paste Picture Link Command (Edit Menu)
Pictures
Toolbars
Tools
Utility Toolbar
Utility Tools Category
User's Guide (Book 1)
Chapter 11, "Working with Multiple Microsoft Excel Documents"



Zoom In Tool
Allows you to see more detail by changing the scale of the document to the next 

higher magnification.
When the document is displayed at the maximum magnification, clicking the Zoom In

tool produces a beep.
The available magnifications range from 400% to 10%.
Actual page size is 100%.
If you hold down SHIFT while clicking this tool, it functions like the Zoom Out tool.

See Also
Help
Changing worksheet dimensions on the screen
Toolbars
Tools
Utility Toolbar
Utility Tools Category
Zoom Command (Window Menu)
Zooming in or out on your worksheet



Zoom Out Tool
Allows you to see more of the document by changing the scale to the next lower 

magnification.
When the document is displayed at the minimum magnification, clicking the Zoom 

Out tool produces a beep.
The available magnifications range from 400% to 10%.
Actual page size is 100%.
If you hold down SHIFT while clicking this tool, it functions like the Zoom In Tool.

See Also
Help
Changing worksheet dimensions on the screen
Toolbars
Tools
Utility Toolbar
Utility Tools Category
Zoom Command (Window Menu)
Zooming in or out on your worksheet



Paste Names Tool
Displays the Paste Name dialog box so that you can insert a selected name into the 

formula bar.
This tool opens the same dialog box that you get if you choose the Paste Name 

command from the Formula menu.
If the formula bar is active, and you have begun a formula by typing an equal sign 

(=), the name is pasted at the insertion point.
If the formula bar is not active, this tool activates it and pastes an equal sign followed

by the name.
Shortcut: F3

See Also
Help
Formula Tools Category
Macro Tools Category
Paste Name Command (Formula Menu)
Pasting names
Toolbars
Tools
Utility Tools Category
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"
User's Guide (Book 2)
Chapter 7, "Designing and Writing a Command Macro"



Fill Right Tool
Copies the values, formulas, and formats of cells in the left column of a selected 

range into the remaining selected cells to the right.
Copied contents and formats replace existing contents and formats.
If you hold down SHIFT while clicking this tool, it fills cells to the left instead of to the 

right.
Shortcut: CTRL+R

See Also
Help
Copying to a range of adjacent cells
Edit Tools Category
Fill Commands (Edit Menu)
Toolbar
Tools
User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"



Fill Down Tool
Copies the values, formulas, and formats of cells in the top row of a selected range 

into the remaining selected cells below.
Copied contents and formats replace existing contents and formats.
If you hold down SHIFT while clicking the tool, it fills up instead of down in the 

selection.
Shortcut: CTRL+D

See Also
Help
Copying to a range of adjacent cells
Edit Tools Category
Fill Commands (Edit Menu)
Toolbar
Tools
User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"



Currency Style Tool
Applies the currently defined dollar currency style to selected cells.
May appear instead of the dollar sign symbol, depending on the country selected in 

the International dialog box, accessed from the Windows Control Panel prior to starting 
Microsoft Excel.

This tool applies the default currency style unless you change it. 
To change the currency style to another built-in style, you can use the Style 

command on the Format menu.
To redefine a style, click the Style box on the Standard toolbar.

For information about changing the International settings, see your Windows 
documentation.
See Also

Help
Applying a style
Creating or deleting a style
Formatting Toolbar
Formatting Tools Category
Redefining a style by example or definition
Redefining the Normal style
Style Box
Style Command (Format Menu)
Toolbar
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Percent Style Tool
Applies the currently defined percent style to selected cells.
This tool applies the default percent style unless you change it. 
To change the percent style to another built-in style, you can use the Style command 

on the Format menu.
To redefine a style, click the Style box on the Standard toolbar.

See Also
Help
Applying a style
Creating or deleting a style
Formatting Toolbar
Formatting Tools Category
Redefining a style by example or definition
Redefining the Normal style
Style Box
Style Command (Format Menu)
Toolbar
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Comma Style Tool
Applies the currently defined comma style to selected cells.
This tool applies the default comma style unless you change it. 
To change the comma style to another built-in style, you can use the Style command 

on the Format menu.
To redefine a style, click the Style box on the Standard toolbar.

See Also
Help
Applying a style
Creating or deleting a style
Formatting Toolbar
Formatting Tools Category
Redefining a style
Redefining the Normal style
Style Box
Style Command (Format Menu)
Toolbar
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Style Box
Applies a cell style to the selection, or lets you define a style based on the current 

selection.
You can change the style by selecting the style you want from the list in the Style 

Name box.
You can also use this tool to define a new style by typing a new name in the Style 

box.
Shortcuts: ALT+APOSTROPHE ( ' )

CTRL+S

See Also
Help
Applying a style
Creating or deleting a style
Formatting Toolbar
Formatting Tools Category
Redefining a style
Standard Toolbar
Text Formatting Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Promote Tool
Raises selected rows or columns one level higher in an outline.
This tool is available only when the active document is outlined.

Shortcut: ALT+SHIFT+LEFT ARROW

See Also
Help
Assigning an outline level to a row or column
Clearing an outline from a worksheet
Creating an outline from an existing worksheet
Outline Command (Formula Menu)
Toolbars
Tools
Utility Toolbar
Utility Tools Category
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



Increase Font Size Tool
Increases the font size of the selected text to the next larger size in the Font Size list 

box each time you click the tool.
When the largest available font size is applied to the text, clicking this tool causes a 

beep, indicating that the tool is no longer available.
If you hold down SHIFT while clicking this tool, it functions like the Decrease Font Size 

tool.
See Also

Help
Font Command (Format Menu for Charts)
Font Command (Format Menu for Worksheets)
Formatting the chart text font
Standard Toolbar
Text Formatting Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"
Chapter 14, "Formatting a Chart"



Decrease Font Size Tool
Decreases the font size of the selected text to the next smaller size in the Font Size 

list box each time you click the tool.
When the smallest available font size is applied to the text, clicking this tool causes a

beep, indicating that the tool is no longer available.
If you hold down SHIFT while clicking this tool, it functions like the Increase Font Size 

tool.
See Also

Help
Font Command (Format Menu for Charts)
Font Command (Format Menu for Worksheets)
Formatting the chart text font
Standard Toolbar
Text Formatting Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"
Chapter 14, "Formatting a Chart"



Preferred Chart Tool
Creates an embedded chart on a worksheet, based on the selected cells, in the area 

you defined by dragging the mouse, and in the format you set using the Set Preferred 
command on the Gallery menu.    

The chart:
Is linked to its source data.
Is saved as part of the worksheet on which it was created.
Can be formatted, moved, and sized.
Can be saved as a separate chart document.

You can also use this tool to change an active chart or selected embedded chart to 
the preferred chart format.

The default format is the simple column chart.
To create a chart using the Preferred Chart tool

1 Select the worksheet data that you want to plot.
2 On the Microsoft Excel 3.0 toolbar, click the Preferred Chart tool.
3 Point to a corner of the area where you want to create the chart, and drag.
4 When you release the mouse button, the chart is created.

See Also
Help
Changing the chart type and format
Chart Toolbar
Charting Tools Category
Creating a chart
Embedded Charts
Microsoft Excel 3.0 Toolbar
Formatting a chart embedded in a worksheet
Set Preferred Command (Gallery Menu)
Setting the preferred chart type
Toolbars
Tools
User's Guide (Book 1)
Chapter 12, "Creating a Chart"



Ungroup Tool
Separates grouped objects into individual objects.
This tool causes a beep or is unavailable when you select an object that is not part of 

a group.
If you hold down SHIFT while clicking this tool, it functions like the Group tool.

See Also
Help
Drawing Toolbar
Drawing Tools Category
Group and Ungroup Commands (Format Menu)
Grouped Objects
Grouping or ungrouping graphic objects
Selecting graphic objects
Toolbars
Tools
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Help Tool
Adds a question mark (?) to the mouse pointer. When you place the new pointer over 

a command name or screen region and click the mouse button, you get information about 
that command or screen region.

As you drag the mouse pointer over the toolbar buttons, the function of each tool 
appears in the status bar.    Only the name of the chart appears for the charting tools.

The Help tool remains selected until you choose a command, click a screen region, or
press ESC.

If you double-click the Help tool, the Search dialog box appears.
Shortcut: SHIFT+F1

See Also
Help
Standard Toolbar
Toolbars
Tools
Utility Tools Category
User's Guide (Book 1)
Chapter 2, "Learning Microsoft Excel"



Save File Tool
Saves changes made to the active document.
The newly saved document remains displayed.
The previous version of the document is replaced with the current version.
If the document has not been saved yet or if it was last saved in a file format other 

than Normal, clicking this tool displays the Save As dialog box instead of saving the file.
This tool is available when a chart window is active.

Shortcut: SHIFT+F12

See Also
Help
File Tools Category
Save Command (File Menu)
Saving a document for the first time
Standard Toolbar
Toolbars
Tools
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



Outline Border Tool
Adds a border around the outermost edges of the selected cells.
To remove the border, select the cells and choose the Border command from the 

Format menu.
Shortcuts: CTRL+AMPERSAND (&) (Outlines cell)

CTRL+UNDERLINE ( _ ) (Removes cell outline)
CTRL+SHIFT+MINUS (-) (Removes cell outline)

See Also
Help
Adding borders
Border Command (Format Menu)
Formatting Tools Category
Standard Toolbar
Toolbars
Tools



Font Name Box
Lists available fonts.
You can change the font name by selecting the name you want from the list or by 

typing the name of the font in the Font Name box.    This is equivalent to choosing the Font 
command from the Format menu and specifying a font in the Font box.

You can have as many as 256 different fonts on one worksheet.
Shortcut: CTRL+F

See Also
Help
Font Command (Format Menu for Charts)
Font Command (Format Menu for Worksheets)
Formatting Toolbar
Text Formatting Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Font Size Box
Lists available sizes for the font selected in the Font Name box.
You can change the font size by selecting the size you want from the list or by typing 

it in the Font Size box.    This is equivalent to choosing the Font command from the Format 
menu and specifying a size in the Size box.
Shortcut: CTRL+P

See Also
Help
Font Command (Format Menu for Charts)
Font Command (Format Menu for Worksheets)
Formatting Toolbar
Text Formatting Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Center Across Columns Tool
Centers the text from one cell horizontally across selected columns.
This tool centers text only.
This tool centers the text from one cell across all selected blank cells to the right.    

For example, if you have text in cell A1 and have selected columns A through E, the 
text in cell A1 will be centered across cells A1 through E1.    However, if you then add 
text to cell C1, the original text will be centered across cells A1 and B1 and the new 
text will be centered across cells C1 through E1. 

See Also
Help
Aligning text and numbers within cells
Alignment Command (Format Menu)
Centering text over columns
Standard Toolbar
Text Formatting Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet "



Filled Rectangle Tool
Draws a rectangle or square that is filled with the window background pattern and 

color.
When you select the Filled Rectangle tool, the mouse pointer changes to a cross hair.  

Drag to draw a rectangle.
To draw a square, hold down the SHIFT key while dragging.
To draw multiple filled rectangles or squares, double-click the Filled Rectangle tool.    

The Filled Rectangle tool remains selected until you click it again, click another tool, press 
ESC, or click another part of the worksheet without dragging.

If you hold down SHIFT while clicking this tool, it functions like the Rectangle Tool.
If you want the filled rectangle or square that you are drawing to adjust automatically

to fit the nearest row and column, hold down the ALT key while dragging.
See Also

Help
Drawing lines and shapes with the toolbar
Drawing Toolbar
Drawing Tools Category
Drawn Objects
Toolbars
Tools
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Filled Oval Tool
Draws an oval or circle that is filled with the window background pattern and color.
The mouse pointer changes to a cross hair.    Drag to draw an oval.
To draw a filled circle, hold down the SHIFT key while dragging.
To draw multiple filled ovals or circles, double-click the Filled Oval tool.    The Filled 

Oval tool remains selected until you click it again, click another tool, press ESC, or click 
another part of the worksheet without dragging.

If you hold down SHIFT while clicking this tool, it functions like the Oval tool.
If you want the filled oval or circle that you are drawing to adjust automatically to fit 

the nearest row and column, hold down the ALT key while dragging.
See Also

Help
Drawing lines and shapes with the toolbar
Drawing Toolbar
Drawing Tools Category
Drawn Objects
Toolbars
Tools
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Arrow Tool
Creates an arrow on an active worksheet or macro sheet, or adds an arrow on an 

active chart.
Worksheets

The mouse pointer changes to a cross hair.    Drag to create an arrow.
To draw multiple arrows, double-click the Arrow tool.    The Arrow tool remains 

selected until you click it again, click another tool, press ESC, or click another part of the 
worksheet without dragging.

To draw horizontal, vertical, or 45-degree diagonal arrows, hold down the SHIFT key 
while dragging.

If you want the arrow that you are drawing to automatically line up with the nearest 
gridline, hold down the ALT key while dragging.

When you release the mouse button, the arrow is automatically selected and an 
arrowhead is displayed.
Charts

When you click the Arrow tool, an arrow is automatically added to your chart.
You can add as many arrows to your chart as you want.
You can resize an arrow using the keyboard or the mouse.
If a chart on a worksheet is selected but not active, the Arrow tool functions as it 

does on a worksheet.
See Also

Help
Add and Delete Arrow Commands (Chart Menu)
Adding a text box or an arrow to a worksheet
Adding or deleting a chart arrow
Charting Toolbar
Charting Tools Category
Drawing Toolbar
Drawing Tools Category
Formatting a chart arrow
Moving and sizing an arrow
Tools
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"
Chapter 14, "Formatting a Chart"
Chapter 15, "Working with Graphic Objects"



Increase Decimal Tool
Adds one decimal place to a number each time you click the tool.
You can add decimal places until the maximum number of 253 for Microsoft Excel is 

reached; then you will hear a beep and you will not be able to add any more.
If you hold down SHIFT while clicking this tool, it functions like the Decrease Decimal 

tool.
See Also

Help
Formatting Toolbar
Formatting Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Decrease Decimal Tool
Removes one decimal place from the number each time you click the tool.
You can continue to remove decimal places until the integer is reached.
If you hold down SHIFT while clicking this tool, it functions like the Increase Decimal 

tool.
See Also

Help
Formatting Toolbar
Formatting Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Drop Shadow Tool
Adds a shadowed rectangular object around a selected cell or cells.
The Drop Shadow tool remains selected until you click it again, click another tool, 

press ESC, or click another part of the worksheet.
The shadowed rectangular object remains selected until you press ESC, or click 

another part of the worksheet.
To remove the rectangular object, select it by its border and press DEL or DELETE.
This tool is available for both worksheets and macro sheets.

See Also
Help
Drawing Toolbar
Drawing Tools Category
Patterns Command (Format Menu for Worksheets)
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Light Shading Tool
Applies a light shading pattern to selected cells and graphic objects.
This tool applies the pattern to cells and graphic objects, not to their borders.

See Also
Help
Adding shading to cells
Drawing Tools Category
Formatting Toolbar
Formatting Tools Category
Patterns Command (Format Menu for Worksheets)
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"
Chapter 15, "Working with Graphic Objects"



AutoFormat Tool
Automatically formats a range of cells by recognizing header rows and columns, 

summary rows and columns, and other elements of a table.
The AutoFormat tool uses the last table format and any modifications that you made 

with the AutoFormat command on the Format menu.
By holding down SHIFT while clicking the tool, you can apply the next table format 

until you return to your initial table format.
If you have a single cell selected, Microsoft Excel automatically selects the range 

bounded by blank cells, and applies the formatting to that range.
See Also

Help
AutoFormat Command (Format Menu for Worksheets)
Formatting a table using AutoFormat
Formatting cells
Formatting Toolbar
Formatting Tools Category
Standard Toolbar
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Reshape Tool
Allows you to change the shape of a polygon.
The vertices remain selected until you click the Reshape tool again.
Handles appear along the freehand line and at the beginning and end of each 

straight line.    You can add or move vertices by dragging the handles.
The mouse pointer changes to a cross hair when you position it over a handle.
To add a vertex, press SHIFT, position the mouse pointer on a line of the polygon, and 

drag the pointer to where you want the new vertex.
To move a vertex, drag the handle to where you want the vertex to be placed.
To delete a vertex, press SHIFT and click the handle of the selected object.

See Also
Help
Drawing Toolbar
Drawing Tools Category
Drawn Objects
Toolbars
Tools
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Freehand Tool
Draws freehand lines.
The mouse pointer changes to a cross hair.    To draw freehand lines, hold down the 

mouse button and drag.
When you release the mouse button, the graphic object is automatically selected.    

The Freehand tool remains selected until you click it again, click another tool, press ESC, or 
click another part of the worksheet without dragging.
See Also

Help
Drawing lines and shapes with the toolbar
Drawing Toolbar
Drawing Tools Category
Drawn Objects
Toolbars
Tools
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Freehand Polygon Tool
Draws a shape that is a combination of freehand and straight lines.
The mouse pointer changes to a cross hair.
To draw a freehand line, drag the mouse.    
To draw a straight line, click the mouse button.    Without pressing the mouse button, 

point to the place where you want the line to end.    Then click the mouse button.
The Freehand Polygon tool remains selected until you close the shape or double-click 

the end point of the line.
If you hold down SHIFT while clicking this tool, it functions like the Filled Freehand 

Polygon tool.
To draw multiple polygon shapes, double-click the Freehand Polygon    tool.    The 

Freehand Polygon tool remains selected until you click it again, click another tool, press ESC, 
or click another part of the worksheet without dragging.

If you want the object that you are drawing to adjust automatically to fit the nearest 
row and column, hold down the ALT key while drawing it.
See Also

Help
Drawing lines and shapes with the toolbar
Drawing Toolbar
Drawing Tools Category
Drawn Objects
Toolbars
Tools
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Demote Tool
Moves selected rows or columns one level lower in an outline.
If you have not created an outline, this tool will create one.

Shortcut: ALT+SHIFT+RIGHT ARROW

See Also
Help
Assigning an outline level to a row or column
Clearing an outline from a worksheet
Creating an outline from an existing worksheet
Outline Command (Formula Menu)
Toolbars
Tools
Utility Toolbar
Utility Tools Category
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



Color Tool
Changes the foreground color of a selected cell or object.
The foreground color of the cell or object changes each time you click the tool.

If you have chosen no pattern for cell shading or the object fill pattern, this tool assigns
a solid pattern.

By holding down SHIFT while clicking the tool, you can reverse the direction of the 
color changes.
See Also

Help
Drawing Toolbar
Drawing Tools Category
Formatting Tools Category
Patterns Command (Format Menu)
Toolbars
Tools
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Filled Freehand Polygon Tool

Draws a freehand polygon shape that is filled with the window background pattern 
and color.

The mouse pointer changes to a cross hair.
To draw a freehand line, drag the mouse.    
To draw a straight line, click the mouse button.    Without pressing the mouse button, 

point to the place where you want the line to end.    Then click the mouse button.
The Filled Freehand Polygon tool remains selected until you close the shape or 

double-click the end point of the line.
If you hold down SHIFT while clicking this tool, it functions like the Freehand Polygon 

tool.
To draw multiple polygon shapes, double-click the Filled Freehand Polygon    tool.    The

tool remains selected until you click it again, click another tool, press ESC, or click another 
part of the worksheet without dragging.

If you want the object that you are drawing to adjust automatically to fit the nearest 
row and column, hold down the ALT key while drawing it.
See Also

Help
Drawing lines and shapes with the toolbar
Drawing Tools Category
Drawing Toolbar
Drawn Objects
Toolbars
Tools
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Filled Arc Tool
Draws a circle segment that is one quarter of a full circle and is filled with the window

background pattern and color.
When you select the Filled Arc tool, the mouse pointer changes to a cross hair.    Drag 

to draw an arc.
To draw multiple filled arcs, double-click the Filled Arc tool.    The Filled Arc tool 

remains selected until you click it again, click another tool, press ESC, or click another part of 
the worksheet without dragging.

If you hold down SHIFT while clicking this tool, it functions like the Arc tool.
If you want the filled arc that you are drawing to adjust automatically to fit the 

nearest row and column, hold down the ALT key while dragging.
See Also

Help
Drawing lines and shapes with the toolbar
Drawing Tool Category
Drawing Toolbar
Drawn Objects
Toolbars
Tools
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Paste Function Tool
Displays the Paste Function dialog box so that you can insert a selected function into 

the formula bar. 
If a worksheet is active, the Paste Function dialog box lists all worksheet and custom 

worksheet functions.    If a macro sheet is active, it lists all macro functions and custom 
macro functions. 

If the formula bar is active, and you have begun entering a formula by typing an 
equal sign (=), the function is pasted at the insertion point.

If the formula bar is not active, this tool activates it and pastes an equal sign (=) 
followed by the function.
Shortcut: SHIFT+F3

See Also
Help
Formula Tools Category
Macro Toolbar
Macro Tools Category
Paste Function (Formula Menu)
Pasting functions
Toolbars
Tools
Utility Tools Category
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"
User's Guide (Book 2)
Chapter 7, "Designing and Writing a Command Macro"



Plus Sign Tool
Adds a plus sign (+) at the location of the insertion point in the formula bar.
If the formula bar is not active, clicking this tool activates it and replaces the contents

with a plus sign.
See Also

Help
Entering a formula
Formula Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



Minus Sign Tool
Adds a minus sign ( - ) at the location of the insertion point in the formula bar.
If the formula bar is not active, clicking this tool activates it and replaces the contents

with a minus sign.
See Also

Help
Entering a formula
Formula Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



Multiplication Sign Tool
Adds an asterisk ( * ) at the location of the insertion point in the formula bar.
If the formula bar is not active, clicking this tool activates it and replaces the contents

with an asterisk.
See Also

Help
Entering a formula
Formula Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



Division Sign Tool
Adds a division sign ( / ) at the location of the insertion point in the formula bar.
If the formula bar is not active, clicking this tool activates it and replaces the contents

with a division sign.
See Also

Help
Entering a formula
Formula Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



Left Parenthesis Tool
Adds an opening parenthesis [ ( ] at the location of the insertion point in the formula 

bar.
If the formula bar is not active, clicking this tool activates it and replaces the contents

with an opening parenthesis.
See Also

Help
Entering a formula
Formula Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



Right Parenthesis Tool
Adds a closing parenthesis [ ) ] at the location of the insertion point in the formula 

bar.
If the formula bar is not active, clicking this tool activates it and replaces the contents

with a closing parenthesis.
See Also

Help
Entering a formula
Formula Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



Exponentiation Sign Tool
Adds a caret ( ^ ) at the location of the insertion point in the formula bar.
If the formula bar is not active, clicking this tool activates it and replaces the contents

with a caret.
See Also

Help
Entering a formula
Formula Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



Equal Sign Tool
Adds an equal sign ( = ) at the location of the insertion point in the formula bar.
If the formula bar is not active, clicking this tool activates it and replaces the contents

with an equal sign.
See Also

Help
Entering a formula
Formula Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



Resume Macro Tool
Resumes a macro operation after the macro has been paused.
This tool is available only when a macro has been paused.
When you are running a macro and Microsoft Excel encounters the PAUSE function, 

the Macro Paused toolbar with the Resume Macro tool is automatically displayed.
This tool is also available on the Macro toolbar and from the Macro Tools category in 

the Customize dialog box.
See Also

Help
Macro Paused Toolbar
Macro Toolbar 
Macro Tools Category
Resume Command (Macro Menu)
Stepping through a macro
Toolbars
Tools
User's Guide (Book 2)
Chapter 6, "Automating Tasks with Command Macros"
Microsoft Excel Function Reference
PAUSE
RESUME



Record Macro Tool
Records your actions and commands to create a macro.
The Record Macro dialog box is displayed unless you hold down SHIFT while clicking 

the tool.
The Record Macro dialog box is displayed if no recorder range has been defined. 
Recording begins in the first cell of the recorder range, or if the first cell is occupied, 

in the first completely blank column of the macro sheet.
Recording continues until you choose the Stop Record command from the Macro 

menu or click the Record Macro tool again.
If you have stopped recording, holding down SHIFT while clicking this tool will resume 

recording where you stopped.
If Microsoft Excel encounters a nonblank cell while recording or reaches the bottom of

the recorder range, it stops recording and displays a message telling you that the recorder 
range is full.

You can repeat the actions you've recorded later using the Run command on the 
Macro menu, or the Run tool if the macro toolbar is displayed.
See Also

Help
Macro Toolbar
Macro Tools Category
Record and Stop Recorder Commands (Macro Menu)
Recording a macro
Toolbars
Tools
User's Guide (Book 2)
Chapter 6, "Automating Tasks with Command Macros"



Justify Align Tool
Evenly redistributes the contents of a selected text box, button, or cell.
This tool is unavailable when a drawn object or picture is selected.
If no alignment tool is selected, General alignment is applied.
This tool is also available when a chart window is active.

See Also
Help
Aligning text and numbers within cells
Formatting Toolbar
Justifying text right and left within a cell
Text Formatting Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"
Chapter 14, "Formatting a Chart"



Dark Shading Tool
Applies a dark shading pattern to selected cells and graphic objects.
This tool applies the pattern to cells and graphic objects, not to their borders.

See Also
Help
Adding shading to cells
Drawing Tools Category
Formatting Tools Category
Patterns Command (Format Menu for Worksheets)
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"
Chapter 15, "Working with Graphic Objects"



Percent Sign Tool
Adds a percent sign ( % ) at the location of the insertion point in the formula bar.
If the formula bar is not active, clicking this tool activates it and replaces the contents

with a percent sign.
See Also

Help
Entering a formula
Formula Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



Right Border Tool
Adds or removes a border along the right edge of each selected cell.
To remove the border, select the cells and choose the Border command from the 

Format menu or click the Right Border tool again.
This tool is available only on worksheets and macro sheets.

See Also
Help
Adding borders
Border Command (Format Menu)
Formatting Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Run Macro Tool
Runs the currently selected macro, starting at the active cell.
If you hold down SHIFT while clicking this tool, it functions like the Step Macro tool.

See Also
Help
Macro Toolbar
Macro Tools Category
Run Command (Macro Menu)
Running a macro
Stepping through a macro
Toolbars
Tools
User's Guide (Book 2)
Chapter 6, "Automating Tasks with Command Macros"
Chapter 7, "Designing and Writing a Command Macro"
Microsoft Excel Function Reference
RESUME



Stop Recording Macro Tool
Stops recording of a macro.    
When you click the Record button in the Assign To Object or Assign To Tool dialog box,

the Stop Recording toolbar with the Stop Recording Macro tool is automatically displayed.
See Also

Help
Adding and deleting a tool from a toolbar
Assign To Object Command (Macro Menu)
Assign To Tool Command (Macro Menu)
Assigning or recording a macro to a tool
Assigning a macro to a graphic object
Creating or deleting a button on a worksheet or macro sheet
Stop Recording Toolbar
Macro Tools Category
Toolbars
Tools
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"
Chapter 6, "Automating Tasks with Command Macros"



Top Border Tool
Adds or removes a border along the upper edge of each selected cell.
To remove the border, select the cells and choose the Border command from the 

Format menu or click the Top Border tool again.
This tool is available only on worksheets and macro sheets.

See Also
Help
Adding borders
Border Command (Format Menu)
Formatting Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Bottom Border Tool
Adds or removes a border along the lower edge of each selected cell.
To remove the border, select the cells and choose the Border command from the 

Format menu or click the Bottom Border tool again.
This tool is available only on worksheets and macro sheets.

See Also
Help
Adding borders
Border Command (Format Menu)
Formatting Tools Category
Standard Toolbar
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Colon Tool
Adds a colon ( : ) at the location of the insertion point in the formula bar.
If the formula bar is not active, clicking this tool activates it and replaces the contents

with a colon.
See Also

Help
Entering a formula
Formula Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



Left Border Tool
Adds or removes a border along the left edge of each selected cell.
To remove the border, select the cells and choose the Border command from the 

Format menu or click the Left Border tool again.
This tool is available only on worksheets and macro sheets.

See Also
Help
Adding borders
Border Command (Format Menu)
Formatting Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Step Macro Tool
Displays the Single Step dialog box so that you can step through the currently 

selected command macro one cell at a time, starting at the active cell.
If you hold down SHIFT while clicking this tool, it functions like the Run Macro tool.

See Also
Help
Macro Toolbar
Macro Tools Category
Run Command (Macro Menu)
Stepping through a macro
Toolbars
Tools
User's Guide (Book 2)
Chapter 6, "Automating Tasks with Command Macros"
Chapter 7, "Designing and Writing a Command Macro"



Lock Cell Tool
Prevents selected cells and objects from being changed when the document is 

protected.
All cells in a new worksheet are locked.
If a cell or object is locked, this tool appears selected.    To unlock a cell or object, click

the Lock Cell tool.
This tool is also available on macro sheets.

See Also
Help
Cell Protection Command (Format Menu for Worksheets)
Protecting worksheet cells
Toolbars
Tools
Utility Toolbar
Utility Tools Category
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



Sort Ascending Tool
Rearranges the rows of a selection in sorted ascending order.
The active cell identifies which column to sort by when sorting rows, or which row to 

sort by when sorting columns.
This tool is available for worksheets and macro sheets only.
If you hold down SHIFT while clicking this tool, it functions like the Sort Descending 

tool.
See Also

Help
Sort Command (Data Menu)
Sorting a range of cells
Toolbars
Tools
Utility Toolbar
Utility Tools Category
User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"
Chapter 9, "Creating and Using a Database on a Worksheet"



Sort Descending Tool
Rearranges the rows of a selection in sorted descending order.
The active cell identifies which column to sort by when sorting rows, or which row to 

sort by when sorting columns.
This tool is available for worksheets and macro sheets only.
If you hold down SHIFT while clicking this tool, it functions like the Sort Ascending tool.

See Also
Help
Sort Command (Data Menu)
Sorting a range of cells
Toolbars
Tools
Utility Tools Category
Utility Toolbar
User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"
Chapter 9, "Creating and Using a Database on a Worksheet"



Copy Tool
Copies the selected cells, characters, or objects onto the Clipboard.    Clicking this tool

is the same as choosing the Copy command from the Edit menu.
The selection can be a cell; cell range; nonadjacent section; characters in the formula

bar, text box, or button; a chart; a document within a workbook (worksheet, macro sheet, or 
chart); a graphic object; or a series.

Characters that are copied from the formula bar are placed on the Clipboard.    The 
characters can then be pasted into a new location in the same formula or into a formula in 
another cell.

When you copy cells on a worksheet or macro sheet, Microsoft Excel outlines the 
selected cell or cell range with a moving border.    

To paste the copied selection to another location, you can use the
Paste command (Edit menu) or the Paste tool.

To insert and paste the copied selection to another location, you can use the Insert 
Paste command (Edit menu).

Within a workbook window, you can use the Copy tool and the Paste command or the 
Paste tool to rearrange the order of worksheets or to move a worksheet to another 
workbook.

You can copy an individual object or several objects together. 
If you copy more than one object at a time, the objects maintain the same relative 
positions when pasted into a new location.

Shortcut: CTRL+C

See Also
Help
Combining copied formulas or values with those in the paste area
Combining values on different worksheets
Converting a formula or a portion of a formula to its displayed values
Copy Command (Edit Menu)
Copying a cell's value, formula, formatting, or note
Copying a chart's series and formats
Copying a chart
Copying a document from one workbook to another workbook
Copying a text or sound note to another cell
Copying cells to multiple locations
Copying data and saving it in a separate file
Copying data
Copying to another worksheet or application
Copying visible cells
Copying within the formula bar
Creating links between documents
Edit Tools Category
Editing a Microsoft Excel object embedded in another document
Standard Toolbar
Toolbars
Transposing ranges from columns to rows or from rows to columns
Tools
User's Guide (Book 1)



Chapter 5, "Creating a Worksheet"
Chapter 6, "Editing a Worksheet"
Chapter 8, "Organizing and Documenting a Worksheet"
Chapter 11, "Working with Multiple Microsoft Excel Documents"
Chapter 15, "Working with Graphic Objects"
User's Guide (Book 2)
Chapter 3, "Exchanging Data with Other Applications"



Undo Tool
Undoes certain commands or, if possible, deletes the last entry you typed into a 

blank cell.
Shortcut: CTRL+Z

See Also
Help
Edit Tools Category
Toolbars
Tools
Undo Command (Edit Menu)
Utility Toolbar
User's Guide (Book 1)
Chapter 2, "Learning Microsoft Excel"
Chapter 15, "Working with Graphic Objects"



Repeat Tool
Repeats the last command you chose, if possible, including any dialog-box option 

settings.
This tool is useful for applying the same formats to different groups of cells or 

different chart items.
Shortcut: ALT+ENTER

See Also
Help
Edit Tools Category
Repeat Command (Edit Menu)
Toolbars
Tools
Utility Toolbar
User's Guide (Book 1)
Chapter 2, "Learning Microsoft Excel"
Chapter 5, "Creating a Worksheet"



Check Spelling Tool
Checks the spelling of the text in worksheets, macro sheets, charts, graphic objects, 

or the formula bar.
Checking begins as soon you click the Check Spelling tool.    The spelling dialog box 

does not open until a misspelled word is found.
If you have a worksheet or macro sheet active, this tool is the same as the Spelling 

command on the Options menu.
If you have a chart active, this tool is the same as the Spelling command on the Chart

menu.
Worksheets and Macro Sheets

If the selection is a single cell, then all cells, objects, headers, footers, notes, and 
buttons in the entire document are checked for spelling errors.

Checking begins at the first object.    If there are no objects, headers, or footers, 
spelling begins at the active cell and continues across each row until the end of the 
document is reached.    If you do not start at the beginning of the document, Microsoft 
Excel asks if you want to continue checking at the beginning.

If the selection is more than one cell, only the selected cells and their notes are 
checked.

Hidden cells and cells in a collapsed outline are also checked.
Cells with values and cell notes are checked but cells with formulas are not.

Graphic Objects
Only the text in text boxes and buttons is checked for spelling.
You can check the spelling of one or more selected objects.

Charts
You can check the spelling of both chart documents and embedded charts.
Headers, footers, the chart title, regular and overlay values, category axis labels, 

series and data point text, series names, and unattached text are checked for spelling, 
regardless of the selection.

Text strings that are defined by references to the worksheet are treated like formulas 
and are not checked.
Formula Bar

If you have selected one or more words in the formula bar, they are checked.    If the 
formula bar is active but you have no words selected, the entire formula bar is checked, 
beginning with the first word.
See Also

Help
Checking spelling
Collapsing an outline level
Selecting a graphic object
Selecting a range of cells
Selecting cells, rows, or columns
Selecting items in a chart
Selecting nonadjacent cells
Spelling Command (Chart Menu)
Spelling Command (Options Menu)
Toolbars
Tools
Utility Toolbar



Utility Tools Category
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"
Chapter 8, "Organizing and Documenting a Worksheet"
Chapter 14, "Formatting a Chart"



Paste Values Tool
Pastes only the values from the cells that you have copied onto the Clipboard.
The paste area can be a cell, cell range, or nonadjacent selection.

If the paste area is a single cell, the Paste Values tool uses this cell as the upper-left 
corner of the paste area and pastes the rest of the copied area down and to the right.
If the paste area is a range or nonadjacent selection, it must be able to contain one or 
more rectangles the exact size and shape of the copied area.

This tool is available only on worksheets and macro sheets.
If you hold down SHIFT while clicking this tool, it functions like the Paste Formats tool.

See Also
Help
Combining copied formulas or values with those in the paste area
Combining values on different worksheets
Converting a formula or a portion of a formula to its displayed values
Copying a cell's values, formula, formatting or note
Edit Tools Category
Paste Special Command (Edit Menu for Chart)
Paste Special Command (Edit Menu for Worksheet)
Toolbars
Tools
Utility Toolbar
User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"



Paste Formats Tool
Pastes into the selection only the cell formats from the cells that you have copied 

onto the Clipboard.
The paste area can be a cell, cell range, or nonadjacent selection.

If the paste area is a single cell, the Paste Formats tool uses this cell as the upper-left 
corner of the paste area and pastes the rest of the copied area down and to the right.
If the paste area is a range or nonadjacent selection, it must be able to contain one or 
more rectangles the exact size and shape of the copied area.

This tool is useful when you want to paste the same format multiple times onto 
different areas of a spreadsheet.

This tool is available for worksheets and macro sheets only.
If you hold down SHIFT while clicking this tool, it functions like the Paste Values tool.

See Also
Help
Combining copied formulas or values with those in the paste area
Copying a cell's value, formula, formatting, or note
Edit Tools Category
Paste Special Command (Edit Menu for Worksheet)
Standard Toolbar
Toolbars
Tools
User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"



Select Visible Cells Tool
Selects the visible cells within the current selection that crosses hidden rows or 

columns; changes you make affect only the visible cells and not the hidden rows or columns. 
This tool also allows you to copy and paste only the visible cells.
You can use this tool with the following commands:

Edit Series (Chart menu)
Copy (Edit menu)
Fill Down (Edit menu)
Fill Right (Edit menu)
All commands on the Format menu except AutoFormat and Justify.

You can paste a single cell into nonadjacent cells but you cannot paste a range of 
cells into nonadjacent cells.

This tool is useful when you have collapsed an outline and you want to copy only the 
collapsed version of it.    The hidden rows or columns will not be copied.
See Also

Help
Copying visible cells
Outline Command (Formula Menu)
Select Special Command (Formula Menu)
Toolbars
Tools
Utility Toolbar
Utility Tools Category
User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"
Chapter 8, "Organizing and Documenting a Worksheet"



Show Outline Symbols Tool
Creates an outline, if one does not exist, and displays or hides the outline symbols on

your worksheet.
If you do not have an outline created, the Show Outline Symbols tool offers to create 

one and then displays the outline symbols.
If the outline symbols are displayed, the Show Outline Symbols tool hides them.

Shortcut: CRTL+8

See Also
Help
Assigning an outline level to a row or column
Collapsing an outline level
Displaying an outline level
Displaying or hiding outline symbols
Expanding an outline level
Outline Command (Formula Menu)
Toolbars
Tools
Utility Toolbar
Utility Tools Category
User's Guide (Book 1)
Chapter 8, "Organizing and Documenting a Worksheet"



Custom Tool
An unassigned tool to which you can assign a macro.

By assigning a macro to this tool, you can use it to carry out commands that you use 
frequently.

You can either assign a previously recorded macro or record a new macro when you 
create the tool.

Only built-in tools can be in the Tools box in the Customize dialog box.    After you 
customize a tool, you cannot save it to the Tools box in the Customize dialog box.    

If you drag a customizable tool into the tools box in the Customize dialog box, you 
delete it.

You can customize the appearance of the tool by adding or changing the bitmap.
See Also

Help
Adding and deleting a tool from a toolbar
Assigning or recording a macro to a tool
Changing the action that a tool performs
Creating a custom tool
Custom Tools Category
Customizing the appearance of a tool
Toolbars
Toolbars Command (Options Menu)
Tools
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



Comma Tool
Adds a comma ( , ) at the location of the insertion point in the formula bar.
If the formula bar is not active, clicking this tool activates it and replaces the contents

with a comma.
See Also

Help
Entering a formula
Formula Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



Bottom Double Border Tool
Adds or removes a double border along the lower edge of each of the selected cells.
To remove the border, select the cells and click the Bottom Double Border tool again 

or choose the Border command from the Format menu.
This tool is available only on worksheets and macro sheets.

See Also
Help
Adding borders
Border Command (Format Menu)
Formatting Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Dollar Sign Tool
Adds a dollar sign ( $ ) at the location of the insertion point in the formula bar.
If the formula bar is not active, clicking this tool activates it and replaces the contents

with a dollar sign.
See Also

Help
Entering a formula
Formula Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"



Text Color Tool
Changes the color of the selected text in a cell, text box, or button.
The text color changes each time you click the tool.
Holding down SHIFT while clicking the tool reverses the direction of the color changes.

See Also
Help
Text Command (Format Menu for Worksheets)
Text Formatting Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 16, "Printing"



Vertical Text Tool
Aligns selected text in cells, chart text, buttons, and text boxes vertically, with each 

letter below the previous one so that you read from top to bottom.
You must adjust the height of the row or the dimensions of the button or text box to 

accommodate the length of the vertical text.
Clicking this tool again changes the text alignment to horizontal.
Using the Vertical Text tool affects only the appearance of cells, not the actual values 

within them.
See Also

Help
Aligning text box and button text
Alignment Command (Format Menu for Worksheets)
Text Command (Format Menu for Charts)
Text Formatting Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Rotate Text Down Tool
Rotates the alignment of selected text in cells, chart text, buttons, and text boxes so 

that you read it from top to bottom.
You must adjust the height of the row or the dimensions of the button or text box to 

accommodate the length of the rotated text.
Clicking this tool again changes the text alignment to horizontal.

Cells
Using the Rotate Text Down tool affects only the appearance of cells, not the actual 

values within them.
You can either rotate the text or wrap the text in a cell, but you cannot do both at the

same time.
Text Boxes

You can rotate and wrap text at the same time in a text box.
See Also

Help
Aligning text box and button text
Alignment Command (Format Menu for Worksheets)
Text Command (Format Menu for Charts)
Text Formatting Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Rotate Text Up Tool
Rotates the alignment of selected text in cells, chart text, buttons, and text boxes so 

that you read it from bottom to top.
You must adjust the height of the row or the dimensions of the button or text box to 

accommodate the length of the rotated text.
Clicking this tool again changes the text alignment to horizontal.

Cells
Using the Rotate Text Up tool affects only the appearance of cells, not the actual 

values within them.
You can either rotate the text or wrap the text in a cell, but you cannot do both at the

same time.
Text Boxes

You can rotate and wrap text at the same time in a text box.
See Also

Help
Aligning text box and button text
Alignment Command (Format Menu for Worksheets)
Text Command (Format Menu for Charts)
Text Formatting Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Freeze Panes Tool
Freezes panes above and to the left of the active cell.
This tool prevents panes to the left of a vertical split from scrolling horizontally and 

prevents panes above a horizontal split from scrolling vertically.
To unfreeze the panes, click this tool again.

See Also
Help
Freeze and Unfreeze Panes Commands (Window Menu)
Freezing and unfreezing panes
Freezing and unfreezing worksheet titles
Toolbars
Tools
Utility Tools Category
User's Guide (Book 1)
Chapter 7, "Formatting a Worksheet"



Delete Tool
Removes the selected cells from a worksheet or macro sheet and shifts the 

surrounding cells to fill the space. 
To remove the contents, formats, or both from selected cells, but not the cells 

themselves, use the Clear command, the Clear Formats tool, or the Clear Formulas tool.
If you hold down SHIFT while clicking this tool, it functions like the Insert tool.

Shortcut: CTRL+MINUS SIGN ( -- )

See Also
Help
Clear Formats Tool
Clear Formulas Tool
Delete Command (Edit Menu)
Deleting cells, rows, or columns
Edit Tools Category
Insert Tool
Toolbars
Tools
User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"



Insert Row Tool
Inserts a row or rows equivalent in size and shape to the selected cell range and 

shifts the surrounding rows to accommodate the insertion. 
If you hold down SHIFT while clicking this tool, it functions like the Delete Row tool.

See Also
Help
Edit Tools Category
Inserting cells, rows, or columns
Toolbars
Tools
User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"



Insert Column Tool
Inserts a column or columns equivalent in size and shape to the selected cell range 

and shifts the surrounding columns to the right to accommodate the insertion.    
If you hold down SHIFT while clicking this tool, it functions like the Delete Column tool.

See Also
Help
Delete Column Tool
Edit Tools Category
Inserting cells, rows, or columns
Toolbars
Tools
User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"



Delete Row Tool
Removes the selected rows from a worksheet or macro sheet and shifts the 

surrounding rows up to fill in the space.
Both contents and formats contained within the selection are deleted.
If you hold down SHIFT while clicking this tool, it functions like the Insert Row tool.

See Also
Help
Deleting cells, rows, or columns
Edit Tools Category
Insert Row Tool
Toolbars
Tools
User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"



Delete Column Tool
Removes the selected columns from a worksheet or macro sheet and shifts the 

surrounding columns to the right or the left to fill in the space.
Both contents and formats contained within the selection are deleted.
If you hold down SHIFT while clicking this tool, it functions like the Insert Column tool.

See Also
Help
Deleting cells, rows, or columns
Edit Tools Category
Insert Column Tool
Toolbars
Tools
User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"



Clear Formulas Tool
Removes selected objects or data, or the formulas, from selected cells.
If a chart is active, clicking this tool removes a selected data series or formats, or 

selected objects.
Clicking this tool also removes a document from an active workbook without deleting 

it.
Clicking this tool is the same as choosing the Clear command from the Edit menu for 

both worksheets and charts.
Shortcuts: CTRL+DEL

See Also
Help
Clear Command (Edit Menu for Charts)
Clear Command (Edit Menu for Worksheets)
Clearing data from cells
Edit Tools Category
Toolbars
Tools

User's Guide (Book 1)
Chapter 4, "Managing Document Files"
Chapter 6, "Editing a Worksheet"
Chapter 13, "Editing a Chart"



Cut Tool
Removes the selection from the document and places it onto the Clipboard.    Clicking 

this tool is the same as choosing the Cut command from the Edit menu.
The selection can be a cell, cell range, characters in the formula bar, a chart, a 

document within a workbook (worksheet, macro sheet, or chart), or a graphic object.
Characters that are cut from the formula bar are deleted and placed on the Clipboard.

The characters can then be pasted into a new location in the same formula or into a formula 
in another cell.

When you cut cells on a worksheet or macro sheet, Microsoft Excel surrounds the 
selected cell or cell range with a moving border.    

To paste the cut selection to another location, you can use the Paste command on the
Edit menu or the Paste tool.

To paste the cut selection and insert new cells to contain the selection, you can use 
the Insert Paste command on the Edit menu.

Within a workbook window, you can use the Cut tool and the Paste command or the 
Paste tool to rearrange the order of worksheets or to move a worksheet from one workbook 
to another.

You can cut an individual object or several objects together. 
If you cut more than one object at a time, the objects maintain the same relative 
positions when pasted into a new location.

Shortcut: CTRL+X
SHIFT+DEL

See Also
Help
Cut Command (Edit Menu)
Deleting a graphic object
Edit Tools Category
Inserting cells, rows, or columns
Moving cells and data
Toolbars
Tools
User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"
Chapter 15, "Working with Graphic Objects"



Paste Tool
Pastes the contents of the Clipboard onto a worksheet, chart, group, or into the 

formula bar.    Clicking this tool is the same as choosing the Paste command from the Edit 
menu.

The selection can be a cell, a cell range, a nonadjacent section, characters in the 
formula bar, a chart, a document within a workbook (worksheet, macro sheet, or chart), or a 
graphic object.

Characters that are cut from the formula bar are available for pasting to a new 
location in the same formula or into a formula in another cell.

Within a workbook window, you can use the Paste tool to rearrange the order of 
worksheets or to move a worksheet from one workbook to another.

You can paste an individual object or several objects together. 
The objects maintain the same relative positions when pasted in a new location as they
had when they were cut or copied.

Shortcuts: CTRL+V
SHIFT+INS

See Also
Help
Copying a chart to a worksheet or another application
Copying cells to multiple locations
Copying data and saving it in a separate file
Copying data
Copying to another worksheet or application
Copying visible cells
Copying within the formula bar
Edit Tools Category
Moving cells and data
Paste Command (Edit Menu)
Toolbars
Tools
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"
Chapter 6, "Editing a Worksheet"
Chapter 8, "Organizing and Documenting a Worksheet"
Chapter 11, "Working with Multiple Microsoft Excel Documents"
Chapter 15, "Working with Graphic Objects"



Calculate Now Tool
Calculates all open worksheets, macro sheets, and charts, or a formula in the formula

bar.
The calculations are made according to the settings in the Calculation Options dialog 

box.
If the formula bar is active, the whole formula or the selected part is replaced with 

the results of the calculation.
Shortcut: F9

See Also
Help
Calculation Command (Options Menu)
Setting calculation options for open documents
Recalculating linked worksheets
Toolbars
Tools
Utility Toolbar
Utility Tools Category
User's Guide (Book 1)
Chapter 5, "Creating a Worksheet"
User's Guide (Book 2)
Chapter 1, "Analyzing and Calculating Data"



Clear Formats Tool
Removes the formats from selected cells in worksheets and macro sheets and 

selected items in charts.
Worksheets and Macro Sheets

Cell formulas and notes are unchanged.    
The cells return to General format.

Charts
The data is not affected. 

See Also
Help
Clear Command (Edit Menu for Charts)
Clear Command (Edit Menu for Worksheet)
Clearing data from cells
Edit Tools Category
Toolbars
Tools

User's Guide (Book 1)
Chapter 6, "Editing a Worksheet"
Chapter 14, "Formatting a Chart"



Insert Tool
Inserts a cell or range of cells and shifts the surrounding cells to accommodate the 

insertion.
If you hold down SHIFT while clicking this tool, it functions like the Delete tool.

Shortcut: CTRL+PLUS SIGN ( + )

See Also
Help
Delete Tool
Edit Tools Category
Inserting cells, rows, or columns
Toolbars
Tools
User's Guide (Book 1)
Chapter 6, "Editing a Worksheet "



Microsoft Word Tool
Switches to Microsoft Word.
Before using this tool, you must open the add-in macro SWITCH.XLA, and specify 

which toolbar you want this tool added to.
This tool will then function similarly to the Switch To command on the Microsoft Excel 

Control menu.
See Also

Help
Assigning a macro to the application switching tools
Custom Tools Category
Toolbars
Tools
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



Set Print Area Tool
Defines the area of the active worksheet that you want to print.
After setting the print area, you can print it by using the Print tool or the Print 

command on the File menu.
See Also

Help
File Tools Category
Print Command (File Menu)
Print Tool
Resetting the print area
Set Print Area Command (Options Menu)
Toolbars
Tools
Utility Toolbar
User's Guide (Book 1)
Chapter 16, "Printing"



Filled Polygon Tool
Draws a polygon that is filled with the window background pattern and color.
When you click the Filled Polygon tool, the mouse pointer changes to a cross hair.
To draw a polygon, click where you want to start drawing.    Without dragging, move 

to where you want the next line to begin.    Click to form a vertex.    Repeat these actions 
until you have drawn the polygon.    

To end the drawing, double-click the mouse button or close the polygon by clicking on 
the same point where you began drawing.

When you double-click the mouse button, the graphic object is automatically 
selected.

To draw multiple filled polygons, double-click the Filled Polygon tool.    The Filled 
Polygon tool remains selected until you click it again, click another tool, press ESC, or click 
another part of the worksheet without dragging.

If you hold down SHIFT while clicking this tool, it functions like the Polygon tool.
If you want the filled polygon that you are drawing to adjust automatically to fit the 

nearest row and column, hold down ALT while clicking.
See Also

Help
Drawing lines and shapes with the toolbar
Drawn Objects
Drawing Tools Category
Toolbars
Tools
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Polygon Tool
Draws a polygon.    
When you click the Polygon tool, the mouse pointer changes to a cross hair. 
To draw a polygon, click where you want to start drawing.    Without dragging, move 

to where you want the next line to begin.    Click to form a vertex.    Repeat these actions 
until you have drawn the polygon.    

To end the drawing, double-click the mouse button or close the polygon by clicking on 
the same point where you began drawing.

When you double-click the mouse button, the graphic object is automatically 
selected.

To draw multiple polygons, double-click the Polygon tool.    The Polygon tool remains 
selected until you click it again, click another tool, press ESC, or click another part of the 
worksheet without dragging.

If you hold down SHIFT while clicking this tool, it functions like the Filled Polygon tool.
If you want the polygon that you are drawing to adjust automatically to fit the nearest

row and column, hold down ALT while drawing the polygon.
See Also

Help
Drawing lines and shapes with the toolbar
Drawing Tools Category
Drawn Objects
Toolbars
Tools
User's Guide (Book 1)
Chapter 15, "Working with Graphic Objects"



Vertical Gridlines Tool
Adds or removes major category axis gridlines visible on the active chart.
The gridlines extend vertically from the category axis through the plot area for most 

charts.
On bar charts, the gridlines extend horizontally from the category axis across the plot

area.
The gridlines are aligned with the major tick marks.
If the chart already has major category gridlines, clicking the Vertical Gridlines tool 

removes them.
See Also

Help
Adding or deleting gridlines
Charting Tools Category
Gridlines Command (Chart Menu)
Toolbars
Tools
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



3-D Surface Chart Tool
Creates an embedded chart, or changes the format of an active or selected 

embedded chart to the 3-D surface chart format.
Creating a surface chart is like stretching a rubber sheet over a regular 3-D column 

chart.
Color is used in a surface chart not to mark data series, but to indicate areas that are 

at the same height, as in a topographic map. 
Colors cannot be edited directly.    To change colors in a surface chart, you must 

change the colors in the color palette.
If the chart is a separate chart document, you can change the colors in the color 
palette for that document.
If the chart is embedded on a worksheet, you can change the colors in the color palette
for that worksheet.

If the chart has an overlay, using the 3-D Surface Chart tool deletes the overlay.
If you have a range of cells selected on a worksheet, this tool creates a new 3-D 

surface chart on the worksheet.
See Also

Help
3-D Surface Command (Gallery Menu)
Chart Toolbar
Charting Tools Category
Creating a chart
Customizing colors in the color palette
Toolbars
Tools
User's Guide (Book 1)
Chapter 12, "Creating a Chart"
Chapter 13, "Editing a Chart"



3-D Bar Chart Tool
Creates an embedded chart, or changes the format of an active or selected 

embedded chart to a simple bar chart with 3-D markers.    
A 3-D bar chart emphasizes the values of individual figures at a specific time or 

draws comparisons among items.
If the chart has an overlay, using the 3-D Bar Chart tool deletes the overlay.
If you have a range of cells selected on a worksheet, this tool creates a new 3-D bar 

chart on the worksheet.
See Also

Help
3-D Bar Command (Gallery Menu)
Chart Toolbar
Charting Tools Category
Creating a chart
Toolbars
Tools
User's Guide (Book 1)
Chapter 12, "Creating a Chart"
Chapter 13, "Editing a Chart"



3-D Column Chart Tool
Creates an embedded chart, or changes the format of an active or selected 

embedded chart to a simple column chart with 3-D markers.    
A 3-D column chart emphasizes the comparison of data points along two axes--a 

category axis and a series axis--so you can compare data points within a series more easily, 
yet still view data by category.

If the chart has an overlay, using the 3-D Column Chart tool deletes the overlay.
If you have a range of cells selected on a worksheet, this tool creates a new 3-D 

column chart on the worksheet.
See Also

Help
3-D Column Command (Gallery Menu)
Chart Toolbar
Charting Tools Category
Creating a chart
Toolbars
Tools
User's Guide (Book 1)
Chapter 12, "Creating a Chart"
Chapter 13, "Editing a Chart"



3-D Line Chart Tool
Creates an embedded chart, or changes the format of an active or selected 

embedded chart to a line chart with the lines shown as 3-D ribbons.    
A 3-D line chart has individual lines that are easier to view, particularly when they 

cross, while still showing all series in one chart for comparison.
If the chart has an overlay, using the 3-D Line Chart tool deletes the overlay.
If you have a range of cells selected on a worksheet, this tool creates a new 3-D line 

chart on the worksheet.
See Also

Help
3-D Line Command (Gallery Menu)
Chart Toolbar
Charting Tools Category
Creating a chart
Toolbars
Tools
User's Guide (Book 1)
Chapter 12, "Creating a Chart"
Chapter 13, "Editing a Chart"



3-D Pie Chart Tool
Creates an embedded chart, or changes the format of an active or selected 

embedded chart to a 3-D pie chart with the value labels expressed as percentages.    
A 3-D pie chart shows a pie chart with 3-D slices.    
If the chart has an overlay, using the 3-D Pie Chart tool deletes the overlay.
If you have a range of cells selected on a worksheet, this tool creates a new 3-D pie 

chart on the worksheet.
See Also

Help
3-D Pie Command (Gallery Menu)
Chart Toolbar
Charting Tools Category
Creating a chart
Toolbars
Tools
User's Guide (Book 1)
Chapter 12, "Creating a Chart"
Chapter 13, "Editing a Chart"



3-D Perspective Column Chart Tool
Creates an embedded chart, or changes the format of an active or selected 

embedded chart to a 3-D column chart with each series plotted separately.    
A 3-D perspective column chart emphasizes the comparison of data points along two 

axes--a category axis and a series axis--so you can compare data points within a series more
easily, yet still view data by category.

If the chart has an overlay, using the 3-D Perspective Column Chart tool deletes the 
overlay.

If you have a range of cells selected on a worksheet, this tool creates a new 3-D 
perspective column chart on the worksheet.
See Also

Help
3-D Column Command (Gallery Menu)
Chart Toolbar
Charting Tools Category
Creating a chart
Toolbars
Tools
User's Guide (Book 1)
Chapter 12, "Creating a Chart"
Chapter 13, "Editing a Chart"



Area Chart Tool
Creates an embedded chart, or changes the format of an active or selected 

embedded chart to the simple area chart format.
An area chart shows how values change in proportion to the total over a period of 

time.    It is similar to a line chart, but emphasizes the magnitude of values rather than the 
flow of time and the rate of change.

If the chart has an overlay, using the Area Chart tool deletes the overlay.
If you have a range of cells selected on a worksheet, this tool creates a new area 

chart on the worksheet.
See Also

Help
Area Command (Gallery Menu)
Chart Toolbar
Charting Tools Category
Creating a chart
Toolbars
Tools
User's Guide (Book 1)
Chapter 12, "Creating a Chart"
Chapter 13, "Editing a Chart"



Bar Chart Tool
Creates an embedded chart, or changes the format of an active or selected 

embedded chart to the simple bar chart format.
A bar chart shows individual figures at a specific time or draws comparisons among 

items.    It is similar to a column chart, but places less emphasis on the flow of time and more
on the comparisons.

If the chart has an overlay, using the Bar Chart tool deletes the overlay.
If you have a range of cells selected on a worksheet, this tool creates a new bar chart

on the worksheet.
See Also

Help
Bar Command (Gallery Menu)
Chart Toolbar
Charting Tools Category
Creating a chart
Toolbars
Tools
User's Guide (Book 1)
Chapter 12, "Creating a Chart"
Chapter 13, "Editing a Chart"



ChartWizard Tool
Starts the ChartWizard so that you can edit an embedded chart or chart document or 

create a chart as an embedded object on a worksheet.
The ChartWizard helps you to create or edit a chart by asking you questions and then

creating or modifying the chart based on your answers.
Creating a chart

After you click the ChartWizard tool, you must define the size and shape of your chart
by dragging the mouse.

When you release the mouse button, the ChartWizard appears. You can either answer
the questions or click    
    and let Microsoft Excel create the chart using the default settings.
Editing a chart

If you want to edit an embedded chart, select it, click the ChartWizard tool, and 
answer the questions.

If you want to edit a chart document, open it, click the ChartWizard tool, and answer 
the questions.

You can make changes to the chart, but you cannot change the chart type.    To 
change the chart type, select the chart and then click the appropriate chart tool on the Chart
toolbar or choose one of the chart commands from the Gallery menu.
See Also

Help
Adding data and formats to a chart from a worksheet or another chart
Adding or editing series
Changing the chart type and format
Chart Toolbar
Charting Tools Category
Creating a chart
Displaying and hiding toolbars
Standard Toolbar
Toolbars Command (Options Menu)
Toolbars
Tools
User's Guide (Book 1)
Chapter 12, "Creating a Chart"
Chapter 13, "Editing a Chart "



Column Chart Tool
Creates an embedded chart, or changes the format of an active or selected 

embedded chart to the simple column chart format.
A column chart shows variations over a period of time or draws comparisons among 

items.
If the chart has an overlay, using the Column Chart tool deletes the overlay.
If you have a range of cells selected on a worksheet, this tool creates a new column 

chart on the worksheet.
See Also

Help
Chart Toolbar
Charting Tools Category
Column Command (Gallery Menu)
Creating a chart
Toolbars
Tools
User's Guide (Book 1)
Chapter 12, "Creating a Chart"
Chapter 13, "Editing a Chart"



Constrain Numeric Tool
Constrains handwriting recognition to numbers and punctuation only.

 The Constrain Numeric tool is only available when using Microsoft Excel with Microsoft 
Windows for Pen Computing.

You can use this tool to improve recognition when entering a series of numbers or 
numeric formulas.

This tool is automatically activated in dialog box fields that only accept numbers.
 When the Constrain Numeric tool is active, only the following characters are 

recognized:
0 1 2 3 4 5 6 7 8 9 $ # @ % ( ) - + = { } : < > . , ? / |

You can still use all of the Microsoft Windows for Pen Computing gestures when this 
tool is active.

To remove the numeric constraint, click the Constrain Numeric tool again.
See Also

Help
Formula Tools Category
Using the Pen with Microsoft Excel
Toolbars
Tools
Microsoft Excel Function Reference
CONSTRAIN.NUMERIC



Horizontal Gridlines Tool
Adds or removes major value axis gridlines visible on an active chart or selected 

embedded chart.
The gridlines extend horizontally from the value axis across the plot area for most 

charts.
On bar charts, the gridlines extend vertically from the value axis across the plot area.
The gridlines are aligned with the major tick marks.
If the chart already has major value axis gridlines, clicking the Horizontal Gridlines 

tool removes them.
See Also

Help
Adding or deleting gridlines
Chart Toolbar
Charting Tools Category
Gridlines Command (Chart Menu)
Toolbars
Tools
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



Legend Tool
Adds or removes a legend along the right side of an active chart or selected 

embedded chart.
Microsoft Excel inserts the legend to the right of the plot area and resizes the plot 

area to accommodate it.
If the chart already has a legend, clicking the Legend tool removes it.

See Also
Help
Add Legend and Delete Legend Commands (Chart Menu)
Adding or deleting a legend
Chart Toolbar
Charting Tools Category
Formatting a legend
Legend Command (Format Menu for Charts)
Moving a legend
Toolbars
Tools
User's Guide (Book 1)
Chapter 14, "Formatting a Chart"



Line Chart Tool
Creates an embedded chart, or changes the format of an active or selected 

embedded chart to the simple line chart format.
A line chart shows trends or changes in data over a period of time. It is similar to an 

area chart, but emphasizes the flow of time and rate of change more than the magnitude of 
values. 

If the chart has an overlay, using the Line Chart tool deletes the overlay.
If you have a range of cells selected on a worksheet, this tool creates a new line chart

on the worksheet.
See Also

Help
Chart Toolbar
Charting Tools Category
Creating a chart
Line Command (Gallery Menu)
Toolbars
Tools
User's Guide (Book 1)
Chapter 12, "Creating a Chart"
Chapter 13, "Editing a Chart"



Line/Column Chart Tool
Creates an embedded chart, or changes the format of an active or selected 

embedded chart to a combination chart with a column chart overlaid by a line chart.
A line/column chart shows data that may be related but measured in different units.    

It is useful for comparing two different kinds of data or juxtaposing series to show 
correlations that otherwise might not be recognized.

If there is an even number of data series, the first half appears on the main chart and
the second half appears on the overlay chart. 

If there is an odd number of data series, the main chart has one series more than the 
overlay chart.    For example, in a chart with five data series, the first three appear on the 
main chart and the last two on the overlay chart.

If the chart has an overlay, using the Line/Column Chart tool replaces the overlay 
with this line chart.

If you have a range of cells selected on a worksheet, this tool creates a new 
line/column chart on the worksheet.
See Also

Help
Chart Toolbar
Charting Tools Category
Combination Command (Gallery Menu)
Creating a chart
Toolbars
Tools
User's Guide (Book 1)
Chapter 12, "Creating a Chart"
Chapter 13, "Editing a Chart"



Pie Chart Tool
Creates an embedded chart, or changes the format of an active or selected 

embedded chart to a pie chart with the value labels expressed as percentages.
A pie chart can contain only one series.
A pie chart shows the relationship of the parts to the whole.    
If the chart has an overlay, using the Pie Chart tool deletes the overlay.
If you have a range of cells selected on a worksheet, this tool creates a new pie chart 

on the worksheet.
See Also

Help
Chart Toolbar
Charting Tools Category
Creating a chart
Pie Command (Gallery Menu)
Toolbars
Tools
User's Guide (Book 1)
Chapter 12, "Creating a Chart"
Chapter 13, "Editing a Chart"



Radar Chart Tool
Creates an embedded chart, or changes the format of an active or selected 

embedded chart to a radar chart with lines and markers.
Each category in a radar chart has its own axis radiating from the center point.    The 

data points belonging to the same series are connected by lines.
If the chart has an overlay, using the Radar Chart tool deletes the overlay.
If you have a range of cells selected on a worksheet, this tool creates a new radar 

chart on the worksheet.
See Also

Help
Chart Toolbar
Charting Tools Category
Creating a chart
Radar Command (Gallery Menu)
Toolbars
Tools
User's Guide (Book 1)
Chapter 12, "Creating a Chart"
Chapter 13, "Editing a Chart"



Stacked Column Chart Tool
Creates an embedded chart, or changes the format of an active or selected 

embedded chart to a stacked column chart.
A stacked column chart shows variations over a period of time or draws comparisons 

with the whole.
If the chart has an overlay, using the Stacked Column Chart tool deletes the overlay.
If you have a range of cells selected on a worksheet, this tool creates a new stacked 

column chart on the worksheet.
See Also

Help
Chart Toolbar
Charting Tools Category
Column Command (Gallery Menu)
Creating a chart
Toolbars
Tools
User's Guide (Book 1)
Chapter 12, "Creating a Chart"
Chapter 13, "Editing a Chart"



Volume/Hi-Lo-Close Chart Tool
Creates an embedded chart, or changes the format of an active or selected 

embedded chart to a column chart overlaid by a line chart with high, low, and close markers.
A volume/hi-lo-close chart is useful for showing stock volumes related to high, low, 

and closing prices.
If the chart has an overlay, using the Volume/Hi-Lo-Close Chart tool deletes the 

overlay.
If you have a range of cells selected on a worksheet, this tool creates a new 

volume/hi-lo-close chart on the worksheet.
See Also

Help
Chart Toolbar
Charting Tools Category
Combination Command (Gallery Menu)
Creating a chart
Toolbars
Tools
User's Guide (Book 1)
Chapter 12, "Creating a Chart"
Chapter 13, "Editing a Chart"



XY (Scatter) Chart Tool
Creates an embedded chart, or changes the format of an active or selected 

embedded chart, to an xy (scatter) chart with data point markers only.
An xy chart shows the relationship or degree of relationship between numeric values 

in different groups of data.    It is useful for finding patterns or trends and for determining 
whether variables depend on or affect one another.

If the chart has an overlay, using the XY (Scatter) Chart tool deletes the overlay.
If you have a range of cells selected on a worksheet, this tool creates a new xy chart 

on the worksheet.
See Also

Help
Chart Toolbar
Charting Tools Category
Creating a chart
Toolbars
Tools
XY (Scatter) Command (Gallery Menu)
User's Guide (Book 1)
Chapter 12, "Creating a Chart"
Chapter 13, "Editing a Chart"



Microsoft Project Tool
Switches to Microsoft Project.
Before using this tool, you must open the add-in macro SWITCH.XLA, and specify 

which toolbar you want this tool added to.    
This tool will then function similarly to the Switch To command on the Microsoft Excel 

Control menu.
See Also

Help
Assigning a macro to the application switching tools
Custom Tools Category
Toolbars
Tools
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



Microsoft PowerPoint Tool
Switches to Microsoft PowerPoint.
Before using this tool, you must open the add-in macro SWITCH.XLA, and specify 

which toolbar you want this tool added to. 
This tool will then function similarly to the Switch To command on the Microsoft Excel 

Control menu.
See Also

Help
Assigning a macro to the application switching tools
Custom Tools Category
Toolbars
Tools
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



Microsoft Mail Tool
An unassigned tool to which you can assign a macro.
By assigning a macro to this tool, you can use it to carry out commands that you use 

frequently.
You can either assign a previously recorded macro or record a new macro when you 
create the tool.

Only built-in tools can be in the Tools box in the Customize dialog box.    After you 
customize a tool, you cannot save it to the Tools box in the Customize dialog box.    

If you drag a customizable tool into the tools box in the Customize dialog box, you 
delete it.

You can customize the appearance of the tool by adding or changing the bitmap.
See Also

Help
Adding and deleting a tool from a toolbar
Assigning or recording a macro to a tool
Changing the action that a tool performs
Creating a custom tool
Custom Tools Category
Customizing the appearance of a tool
Toolbars Command (Options Menu)
Toolbars
Tools
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



New Workbook Tool
Creates a new workbook.    Clicking this tool is the same as choosing the New 

command from the File menu and selecting Workbook.
See Also

Help 
Creating a workbook
File Tools Category
New Command (File Menu)
Toolbars
Tools
User's Guide (Book 1)
Chapter 4, "Managing Document Files"



3-D Area Chart Tool
Creates an embedded chart, or changes the format of an active or selected 

embedded chart to a stacked area chart with 3-D markers.
A 3-D area chart emphasizes the sum of the plotted values and separates the series 

into distinct rows to show differences between them.
If the chart has an overlay, using the 3-D Area Chart tool deletes the overlay.
If you have a range of cells selected on a worksheet, this tool creates a new 3-D area 

chart on the worksheet.
See Also

Help
3-D Area Command (Gallery Menu)
Chart Toolbar
Charting Tools Category
Creating a chart
Toolbars
Tools
User's Guide (Book 1)
Chapter 12, "Creating a Chart"
Chapter 13, "Editing a Chart"



Select Current Region Tool
Selects a rectangular range of cells around the active cell.    
The range selected is an area bounded by any combination of blank rows or blank 

columns.
Shortcut: CTRL+ASTERISK (*)

See Also
Help
Select Special Command (Formula Menu)
Toolbars
Tools
Utility Tools Category



Text Formatting Tools Category
Bold Tool

Applies bold formatting to selected text in text boxes and buttons, or to the text in a 
selected cell.

Italic Tool
Applies italic formatting to selected text in text boxes and buttons, or to the text in a 
selected cell.

Underline Tool
Underlines selected text in text boxes and buttons, or the text in a selected cell.    

Strikeout Tool
Draws a line through the selected text in text boxes and buttons, or the text in a selected 
cell.

Text Color Tool
Changes the color of the selected text in a cell, text box, or button.

Left Align Tool
Aligns the contents of a selected text box, button, or cell to the left.

Center Align Tool
Centers the contents of a selected text box, button, or cell.

Right Align Tool
Aligns the contents of a selected text box, button, or cell to the right. 

Justify Align Tool
Evenly redistributes the contents of a selected text box, button, or cell.

Center Across Columns Tool
Centers the text from one cell horizontally across selected columns.

Font Name Box
Lists available fonts.

Font Size Box
Lists available sizes for the font selected in the Font Name box.

Style Box
Applies a cell style to the selection, or lets you define a style based on the current 
selection.

Increase Font Size Tool
Increases the font size of the selected text to the next larger size in the Font Size list box 
each time you click the tool.

Decrease Font Size Tool
Decreases the font size of the selected text to the next smaller size in the Font Size list 
box each time you click the tool.

Vertical Text Tool
Aligns selected text in cells, chart text, buttons, and text boxes vertically, with each letter
below the previous one so that you read from top to bottom.

Rotate Text Up Tool
Rotates the alignment of selected text in cells, chart text, buttons, and text boxes so that 
you read it from bottom to top.

Rotate Text Down Tool
Rotates the alignment of selected text in cells, chart text, buttons, and text boxes so that 
you read it from top to bottom.

See Also
Help
Adding and deleting a tool from a toolbar



Creating a new toolbar
Moving and copying tools
Tools
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



Drawing Tools Category
Line Tool

Draws a straight line.
Arrow Tool

Creates an arrow on an active worksheet or macro sheet, or adds an arrow on an active 
chart.

Freehand Tool
Draws freehand lines.

Text Box Tool
Draws a text box where you can type text on a worksheet; lets you add unattached text 
to an active chart.

Button Tool
Draws a button to which you can assign a macro.    When you click the button, the macro 
runs.

Selection Tool
Selects one or more graphic objects.    

Reshape Tool
Allows you to change the shape of a polygon.

Rectangle Tool
Draws a rectangle or square.

Oval Tool
Draws an oval or circle.    

Arc Tool
Draws an arc or circle segment.

Polygon Tool
Draws a polygon.    

Freehand Polygon Tool
Draws a shape that is a combination of freehand and straight lines.

Filled Rectangle Tool
Draws a rectangle or square that is filled with the window background pattern and color.

Filled Oval Tool
Draws an oval or circle that is filled with the window background pattern and color.

Filled Arc Tool
Draws a circle segment that is one quarter of a full circle and is filled with the window 
background pattern and color.

Filled Polygon Tool
Draws a polygon that is filled with the window background pattern and color.

Filled Freehand Polygon Tool
Draws a freehand polygon shape that is filled with the window background pattern and 
color.

Group Tool
Creates a single group of graphic objects from multiple objects.

Ungroup Tool
Separates grouped objects into individual objects.



Bring To Front Tool
Places one or more selected objects in front of all other objects.

Send To Back Tool
Places one or more selected objects behind all other objects.

Color Tool
Changes the foreground color of a selected cell or object.

Dark Shading Tool
Applies a dark shading pattern to selected cells and graphic objects.

Light Shading Tool
Applies a light shading pattern to selected cells and graphic objects.

Drop Shadow Tool
Adds a shadow to the bottom and the right side of a selected cell.

See Also
Help
Adding and deleting a tool from a toolbar
Creating a new toolbar
Moving and copying tools
Tools
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



File Tools Category
Open File Tool

Displays the Open dialog box so that you can open an existing document.
Save File Tool

Saves changes made to the active document.
Print Tool

Prints the active document according to the options you previously specified in the Print 
dialog box.

Print Preview Tool
Displays each page as it will look when you print the document.

Set Print Area Tool
Defines the area of the active worksheet that you want to print.

New Worksheet Tool
Creates a new worksheet.    Clicking this tool is the same as choosing the New command 
from the File menu and selecting Worksheet.

New Chart Tool
Creates a new chart document in the default chart type or the chart type and format that 
are selected by the Set Preferred command on the Gallery menu.    

New Macro Sheet Tool
Creates a new macro sheet.    Clicking this tool is the same as choosing the New 
command from the File menu and selecting Macro Sheet.

New Workbook Tool
Creates a new workbook.    Clicking this tool is the same as choosing the New command 
from the File menu and selecting Workbook.

See Also
Help
Adding and deleting a tool from a toolbar
Creating a new toolbar
Moving and copying tools
Tools
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



Utility Tools Category
AutoSum Tool

Inserts into the active cell a formula with the SUM function and a proposed sum range.    
The proposed range is based on the data above or to the left of the active cell.

Text Box Tool
Draws a text box where you can type text on a worksheet; lets you add unattached text 
to an active chart.

Button Tool
Draws a button to which you can assign a macro.    When you click the button, the macro 
runs.

Camera Tool
Creates a picture of a selected range of cells and pastes the picture as an object onto a 
worksheet.

Calculate Now Tool
Calculates all open worksheets, macro sheets, and charts, or a formula in the formula bar.

Check Spelling Tool
Checks the spelling of the text in worksheets, macro sheets, charts, graphic objects, or 
the formula bar.

Help Tool
Adds a question mark (?) to the mouse pointer. When you place the new pointer over a 
command name or screen region and click the mouse button, you get information about 
that command or screen region.

Promote Tool
Raises selected rows or columns one level higher in an outline.

Demote Tool
Moves selected rows or columns one level lower in an outline.

Show Outline Symbols Tool
Creates an outline, if one does not exist, and displays or hides the outline symbols on 
your worksheet.

Select Visible Cells Tool
Selects the visible cells within the current selection that crosses hidden rows or columns 
so that changes you make affect only the visible cells and not the hidden rows or 
columns.    

Select Current Region Tool
Selects a rectangular range of cells around the active cell.    

Sort Ascending Tool
Rearranges the rows of a selection in sorted ascending order.

Sort Descending Tool
Rearranges the rows of a selection in sorted descending order.

Lock Cell Tool
Prevents selected cells and objects from being changed when the document is protected.

Freeze Panes Tool
Freezes panes above and to the left of the active cell.

Zoom In Tool
Allows you to see more detail by changing the scale of the document to the next higher 
magnification.

Zoom Out Tool
Allows you to see more of the documents by changing the scale to the next lower 
magnification.



Paste Names Tool
Displays the Paste Names dialog box so that you can insert a selected name into the 
formula bar.

Paste Function Tool
Displays the Paste Function dialog box so that you can insert a selected function into the 
formula bar. 

See Also
Help
Adding and deleting a tool from a toolbar
Creating a new toolbar
Moving and copying tools
Tools
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



Edit Tools Category
Undo Tool

Undoes certain commands or, if possible, deletes the last entry you typed into a blank 
cell.

Repeat Tool
Repeats the last command you chose, if possible, including any dialog-box option 
settings.

Cut Tool
Removes the selection from the document and places it onto the Clipboard.    Clicking this 
tool is the same as choosing the Cut command from the Edit menu.

Copy Tool
Copies the selected cells, characters, or objects onto the Clipboard.    Clicking this tool is 
the same as choosing the Copy command from the Edit menu.

Paste Tool
Pastes the contents of the Clipboard onto a worksheet, chart, group, or into the formula 
bar.    Clicking this tool is the same as choosing the Paste command from the Edit menu.

Clear Formulas Tool
Removes selected objects or data, or the formulas, from selected cells.

Clear Formats Tool
Removes the formats from selected cells in worksheets and macro sheets and selected 
items in charts.

Paste Formats Tool
Pastes into the selection only the cell formats from the cells that you have copied onto 
the Clipboard.

Paste Values Tool
Pastes only the values from the cells that you have copied onto the Clipboard.

Delete Tool
Removes the selected cells from a worksheet or macro sheet and shifts the surrounding 
cells to fill the space. 

Delete Row Tool
Removes the selected rows from a worksheet or macro sheet and shifts the rows up to fill 
in the space.

Delete Column Tool
Removes the selected columns from a worksheet or macro sheet and shifts the columns 
to the right or to the left to fill in the space.

Insert Tool
Inserts a cell or range of cells and shifts the surrounding cells to accommodate the 
insertion.

Insert Row Tool
Inserts a row or rows equivalent in size and shape to the selected cell range and shifts the
surrounding rows to accommodate the insertion.    

Insert Column Tool
Inserts a column or columns equivalent in size and shape to the selected cell range and 
shifts the surrounding columns to the right to accommodate the insertion.

Fill Right Tool
Copies the values, formulas, and formats of cells in the left column of a selected range 
into the remaining selected cells to the right.

Fill Down Tool
Copies the values, formulas, and formats of cells in the top row of a selected range into 
the remaining selected cells below.



See Also
Help
Adding and deleting a tool from a toolbar
Creating a new toolbar
Moving and copying tools
Tools
User's Guide (Book 2)
Chapter 4, "Customizing Microsoft Excel"



Formula Tools Category
Equal Sign Tool

Adds an equal sign ( = ) at the location of the insertion point in the formula bar.

Plus Sign Tool
Adds a plus sign (+) at the location of the insertion point in the formula bar.

Minus Sign Tool
Adds a minus sign ( - ) at the location of the insertion point in the formula bar.

Multiplication Sign Tool
Adds an asterisk ( * ) at the location of the insertion point in the formula bar.

Division Sign Tool
Adds a division sign ( / ) at the location of the insertion point in the formula bar.

Exponentiation Sign Tool
Adds a caret ( ^ ) at the location of the insertion point in the formula bar.

Left Parenthesis Tool
Adds an opening parenthesis [ ( ] at the location of the insertion point in the formula bar.

Right Parenthesis Tool
Adds a closing parenthesis [ ) ] at the location of the insertion point in the formula bar.

Colon Tool
Adds a colon ( : ) at the location of the insertion point in the formula bar.

Comma Tool
Adds a comma ( , ) at the location of the insertion point in the formula bar.

Percent Sign Tool
Adds a percent sign ( % ) at the location of the insertion point in the formula bar.

Dollar Sign Tool
Adds a dollar sign ( $ ) at the location of the insertion point in the formula bar.

AutoSum Tool
Inserts into the active cell a formula with the SUM function and a proposed sum range.    
The proposed range is based on the data above or to the left of the active cell.

Paste Function Tool
Displays the Paste Function dialog box so that you can insert a selected function into the 
formula bar. 

Paste Names Tool
Displays the Paste Names dialog box so that you can insert a selected name into the 
formula bar.

Constrain Numeric Tool
Constrains handwriting recognition to numbers and punctuation only.

See Also
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Macro Tools Category
Record Macro Tool

Records your actions and commands to create a macro.
Stop Recording Macro Tool

Stops recording of a macro.    
Run Macro Tool

Runs the currently selected macro, starting at the active cell.
Step Macro Tool

Displays the Single Step dialog box so that you can step through the currently selected 
command macro one cell at a time, starting at the active cell.

Resume Macro Tool
Resumes a macro operation after the macro has been paused.

Paste Function Tool
Displays the Paste Function dialog box so that you can insert a selected function into the 
formula bar. 

Paste Names Tool
Displays the Paste Names dialog box so that you can insert a selected name into the 
formula bar.
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Help
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Moving and copying tools
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Charting Tools Category
Area Chart Tool

Creates an embedded chart, or changes the format of an active or selected embedded 
chart to the simple area chart format.

Bar Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to the simple bar chart format.

Column Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to the simple column chart format.

Stacked Column Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to a stacked column chart.

Line Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to the simple line chart format.

Pie Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to a pie chart with the value labels expressed as percentages.

3-D Area Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart    to a stacked area chart with 3-D markers.

3-D Bar Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to a simple bar chart with 3-D markers. 

3-D Column Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to a simple column chart with 3-D markers.    

3-D Perspective Column Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to a 3-D column chart with each series plotted separately.    

3-D Line Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to a line chart with the lines shown as 3-D ribbons.    

3-D Pie Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to a 3-D Pie chart with the value labels expressed as percentages.    

XY (Scatter) Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart, to an xy (scatter) chart with data point markers only.

3-D Surface Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to the 3-D surface chart format.

Radar Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to a radar chart with lines and markers.

Line/Column Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to a combination chart with a column chart overlaid by a line chart.

Volume/Hi-Lo-Close Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 



chart to a column chart overlaid by a line chart with high, low, and close markers.
Preferred Chart Tool

Creates an embedded chart on a worksheet, based on the selected cells, in the area you 
defined by dragging the mouse, and in the format you set using the Set Preferred 
command on the Gallery menu.

ChartWizard Tool
Starts the ChartWizard so that you can edit an embedded chart or chart document or 
create a chart as an embedded object on a worksheet.

Horizontal Gridlines Tool
Adds or removes major value axis gridlines visible on an active chart or selected 
embedded chart.

Vertical Gridlines Tool
Adds or removes major category axis gridlines visible on the active chart.

Legend Tool
Adds or removes a legend along the right side of an active chart or selected embedded 
chart.

Arrow Tool
Creates an arrow on an active worksheet or macro sheet, or adds an arrow on an active 
chart.

Text Box Tool
Draws a text box where you can type text on a worksheet; lets you add unattached text 
to an active chart.
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Creating a new toolbar
Moving and copying tools
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Formatting Tools Category
Outline Border Tool

Adds a border around the outermost edges of the selected cells.
Left Border Tool

Adds or removes a border along the left edge of each selected cell.
Right Border Tool

Adds or removes a border along the right edge of each selected cell.
Top Border Tool

Adds or removes a border along the upper edge of each selected cell.
Bottom Border Tool

Adds or removes a border along the lower edge of the each selected cell.
Bottom Double Border Tool

Adds or removes a double border along the lower edge of each of the selected cells.
Dark Shading Tool

Applies a dark shading pattern to selected cells and graphic objects.
Light Shading Tool

Applies a light shading pattern to selected cells and graphic objects.
AutoFormat Tool

Automatically formats a range of cells by recognizing header rows and columns, summary
rows and columns, and other elements of a table.

Currency Style Tool
Applies the currently defined currency style to selected cells.

Percent Style Tool
Applies the currently defined percent style to selected cells.

Comma Style Tool
Applies the currently defined comma style to selected cells.

Increase Decimal Tool
Adds one decimal place to a number each time you click the tool.

Decrease Decimal Tool
Removes one decimal place from the number each time you click the tool.

Style Box
Applies a cell style to the selection, or lets you define a style based on the current 
selection.
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Custom Tools Category
This category contains unassigned tools with a variety of tool faces.    You can use these 
tools to change the appearance of tools or to make custom tools.    To customize a tool, you 
assign a macro to it.
See Also
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Microsoft Excel 3.0 Toolbar
Contains the same tools as the Microsoft Excel version 3.0 toolbar.

Style Box
Applies a cell style to the selection, or lets you define a style based on the current 
selection.

Promote Tool
Raises selected rows or columns one level higher in an outline.

Demote Tool
Moves selected rows or columns one level lower in an outline.

Show Outline Symbols Tool
Creates an outline, if one does not exist, and displays or hides the outline symbols on 
your worksheet.

Select Visible Cells Tool
Selects the visible cells on a worksheet so that changes you make affect only the visible 
cells and not the hidden rows or columns.

AutoSum Tool
Inserts into the active cell a formula with the SUM function and a proposed sum range.    
The proposed range is based on the data above or to the left of the active cell.

Bold Tool
Applies bold formatting to selected text in text boxes and buttons, or to the text in a 
selected cell.

Italic Tool
Applies italic formatting to selected text in text boxes and buttons, or to the text in a 
selected cell. 

Left Align Tool
Aligns the contents of a selected text box, button, or cell to the left.    

Center Align Tool
Centers the contents of a selected text box, button, or cell.    

Right Align Tool
Aligns the contents of a selected text box, button, or cell to the right.    

Selection Tool
Selects one or more graphic objects. 

Line Tool 
Draws a straight line.

Filled Rectangle Tool 
Draws a rectangle or square that is filled with the window background pattern and color.

Filled Oval Tool
Draws an oval or circle that is filled with the window background pattern and color.

Arc Tool
Draws an arc or circle segment.

Preferred Chart Tool
Creates an embedded chart on a worksheet, based on the selected cells, in the area you 
defined by dragging the mouse, and in the format you set using the Set Preferred 
command on the Gallery menu. 

Text Box Tool
Draws a text box where you can type text on a worksheet; lets you add unattached text 
to an active chart.

Button Tool
Draws a button to which you can assign a macro.    When you click the button, the macro 
runs.



Camera Tool
Creates a picture of a selected range of cells on a chart and pastes the picture as an 
object on a worksheet or chart.    The picture is linked to the source selection.
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Formatting Toolbar
Style Box

Applies a cell style to the selection, or lets you define a style based on the current 
selection.

Font Name Box 
Lists available fonts.

Font Size Box
Lists available sizes for the font selected in the Font Name box.

Bold Tool
Applies bold formatting to selected text in text boxes and buttons, or to the text in a 
selected cell. 

Italic Tool
Applies italic formatting to selected text in text boxes and buttons, or to the text in a 
selected cell.    

Underline Tool
Underlines selected text in text boxes and buttons, or the text in a selected cell.    

Strikeout Tool
Draws a line through the selected text in text boxes and buttons, or the text in a selected 
cell.

Justify Alignment Tool
Evenly redistributes the contents of a selected text box, button, or cell.

Currency Style Tool
Applies the currently defined currency style to selected cells.

Percent Style Tool
Applies the currently defined percent style to selected cells.

Comma Style Tool
Applies the currently defined comma style to selected cells.

Increase Decimal Tool
Adds one decimal place to a number format each time you click the tool.

Decrease Decimal Tool
Removes one decimal place from the number format each time you click the tool.

Light Shading Tool
Applies a light shading pattern to selected cells and graphic objects.

AutoFormat Tool
Automatically formats a range of cells by recognizing header rows and columns, summary
rows and columns, and other elements of a table.
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Drawing Toolbar
Line Tool

Draws a straight line.
Arrow Tool

Creates an arrow on an active worksheet or macro sheet, or adds an arrow on an active 
chart.

Freehand Tool
Draws freehand lines.

Rectangle Tool
Draws a rectangle or square.

Oval Tool
Draws an oval or circle.

Arc Tool
Draws an arc or circle segment.

Freehand Polygon Tool
Draws a shape that is a combination of freehand and straight lines.

Filled Rectangle Tool
Draws a rectangle or square that is filled with the window background pattern and color.

Filled Oval Tool
Draws an oval or circle that is filled with the window background pattern and color.

Filled Arc Tool
Draws a circle segment that is one quarter of a full circle and is filled with the window 
background pattern and color.

Filled Freehand Polygon Tool
Draws a freehand polygon shape that is filled with the window background pattern and 
color.

    Text Box Tool
Draws a text box where you can type text on a worksheet; lets you add unattached text 
to an active chart.

Selection Tool
Selects one or more graphic objects.

Reshape Tool
Allows you to change the shape of a polygon.

Group Tool
Creates a single group of graphic objects from multiple objects.

Ungroup Tool
Separates grouped objects into individual objects.

Bring to Front Tool
Places one or more selected objects in front of all other objects.

Send to Back Tool
Places one or more selected objects behind all other objects.

Color Tool
Changes the foreground color of a selected cell or object. 

Drop Shadow Tool
Adds a shadowed rectangular object around a selected cell or cells.
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Macro Toolbar
New Macro Sheet Tool

Creates a new macro sheet.    Clicking this tool is the same as choosing the New 
command from the File menu and selecting Macro Sheet.

Paste Function Tool
Displays the Paste Function dialog box so that you can insert a selected function into the 
formula bar. 

Paste Names Tool
Displays the Paste Names dialog box so that you can insert a selected name into the 
formula bar.

Run Macro Tool
Runs the currently selected macro, starting at the active cell.

Step Macro Tool
Displays the Single Step dialog box so that you can step through the currently selected 
command macro one cell at a time, starting at the active cell.

Record Macro Tool
Records your actions and commands to create a macro.

Resume Macro Tool
Resumes a macro operation after the macro has been paused.
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Stop Recording Toolbar
This toolbar is automatically displayed when you begin recording a macro by choosing the 
Record button in the Assign To Object or Assign To Tool dialog box. 

The Stop Recording toolbar contains the    
    Stop Recording tool.

When you click the Stop Recording tool, the tool and toolbar disappear; they will be 
displayed automatically the next time you record a macro.

If you close the toolbar using the Control-menu box, the toolbar will not appear again,
until you display it.

You can show the Stop Recording toolbar by choosing the Toolbars command from the 
Options menu or the toolbar shortcut menu.

You can move the Stop Recording toolbar to a more convenient location in your 
application window by dragging its title bar.
See Also
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Macro Paused Toolbar
This toolbar is automatically displayed when a running macro encounters the PAUSE 
function.

The Macro Paused toolbar contains the    
    Resume tool.

When you click the Resume tool, the tool and toolbar disappear; they will be 
displayed automatically the next time you pause a macro.

If you close the toolbar using the Control-menu box, the toolbar will not appear again,
until you display it.

You can show the Macro Paused toolbar by choosing the Toolbars command on the 
Options menu or the toolbar shortcut menu.

You can move the Macro Paused toolbar to a more convenient location in your 
application window by dragging its title bar.
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Standard Toolbar
Appears when Microsoft Excel starts.

New Worksheet Tool
Creates a new worksheet.    Clicking this tool is the same as choosing the New command 
from the File menu and selecting Worksheet.

Open File Tool
Displays the Open dialog box so that you can open an existing document.

Save File Tool
Saves changes made to the active document.

Print Tool
Prints the active document according to the options you previously specified in the Print 
dialog box.

Style Box
Applies a cell style to the selection, or lets you define a style based on the current 
selection.

AutoSum Tool
Inserts into the active cell a formula with the SUM function and a proposed sum range.    
The proposed range is based on the data above or to the left of the active cell.

Bold Tool
Applies bold formatting to selected text in text boxes and buttons, or to the text in a 
selected cell.

Italic Tool
Applies italic formatting to selected text in text boxes and buttons, or to the text in a 
selected cell.    

Increase Font Size Tool
Increases the font size of the selected text to the next larger size in the Font Size list box 
each time you click the tool.

Decrease Font Size Tool
Decreases the font size of the selected text to the next smaller size in the Font Size list 
box each time you click the tool.

Left Align Tool
Aligns the contents of a selected text box, button, or cell to the left.    

Center Align Tool
Centers the contents of a selected text box, button, or cell.    

Right Align Tool
Aligns the contents of a selected text box, button, or cell to the right.      

Center Across Columns Tool
Centers the text from one cell horizontally across selected columns.

AutoFormat Tool
Automatically formats a range of cells by recognizing header rows and columns, summary
rows and columns, and other elements of a table.

Outline Border Tool
Adds a border around the outermost edges of the selected cells.

Bottom Border Tool
Adds a bottom border to the selected cell.

Paste Formats Tool
Pastes into the selection only the cell formats from the cells that you have copied onto 
the Clipboard.

Copy Tool
Copies the selected cells, characters, or objects onto the Clipboard.    Clicking this tool is 



the same as choosing the Copy command from the Edit menu.
ChartWizard Tool

Starts the ChartWizard so that you can edit an embedded chart or chart document or 
create a new chart as an embedded object on a worksheet.

Help Tool
Adds a question mark (?) to the mouse pointer. When you place the new pointer over a 
command name or screen region and click the mouse button, you get information about 
that command or screen region.
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Utility Toolbar
Undo Tool

Undoes certain commands, or deletes the last entry you typed.
Repeat Tool

Repeats the last command you chose, if possible, including any dialog-box option 
settings.

Copy Tool
Copies the selected cells, characters, or objects onto the Clipboard.

Paste Values Tool
Pastes into the current selection only the values from the cells that you have copied to 
the Clipboard.

Paste Formats Tool
Pastes into the current selection only the cell formats from the cells that you have copied 
to the Clipboard.

Zoom In Tool
Allows you to see more detail by changing the scale of the document to the next higher 
magnification.

Zoom Out Tool
Allows you to see more of the document by changing the scale to the next lower 
magnification.

Sort Ascending Tool
Rearranges the rows of a selection in sorted ascending order.

Sort Descending Tool
Rearranges the rows of a selection in sorted descending order.

Lock Cell Tool
Prevents selected cells and objects from being changed when the document is protected.

Promote Tool
Raises selected rows or columns one level higher in an outline.

Demote Tool
Moves selected rows or columns one level lower in an outline.

Show Outline Symbols Tool
Creates an outline, if one does not exist, and displays or hides the outline symbols on 
your worksheet.

Select Visible Cells Tool
Selects the visible cells within the current selection that crosses hidden rows or columns 
so that changes you make affect only the visible cells and not the hidden rows or 
columns.    

Button Tool
Draws a button to which you can assign a macro.    When you click the button, the macro 
runs.

Text Box Tool
Draws a text box where you can type text on a worksheet; lets you add unattached text 
to an active chart.

Camera Tool 
Creates a picture of a selected range of cells as an object on a worksheet. The picture is 
linked to the source selection.

Check Spelling Tool
Checks the spelling of the text in worksheets, macro sheets, charts, graphic objects, or 
the formula bar.

Set Print Area Tool



Defines the area of the active worksheet that you want to print.
Calculate Now Tool

Calculates all open worksheets, macro sheets, and charts, or a formula in the active 
formula bar.
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Chart Toolbar
Area Chart Tool

Creates an embedded chart, or changes the format of an active or selected embedded 
chart to the simple area chart format.

Bar Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to the simple bar chart format.

Column Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to the simple column chart format.

Stacked Column Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to a stacked column chart.

Line Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to the simple line chart format.

Pie Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to a pie chart with the value labels expressed as percentages.

XY (Scatter) Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart, to an xy (scatter) chart with data point makers only.

3-D Area Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart    to a stacked area chart with 3-D markers.

3-D Bar Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to a simple bar chart with 3-D markers. 

3-D Column Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to a simple column chart with 3-D markers.    

           3-D Perspective Column Chart Tool  
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to a 3-D column chart with each series plotted separately. 

3D Line Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to a line chart with the lines shown as 3-D ribbons. 

3-D Pie Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to a 3-D Pie chart with the value labels expressed as percentages.

3-D Surface Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to the 3-D surface chart format.

Radar Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to a radar chart with lines and markers.

Line/Column Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 
chart to a combination chart with a column chart overlaid by a line chart.

Volume/Hi-Lo-Close Chart Tool
Creates an embedded chart, or changes the format of an active or selected embedded 



chart to a column chart overlaid by a line chart with high, low, and close markers.
Preferred Chart Tool

Creates an embedded chart on a worksheet, based on the selected cells, in the area you 
defined by dragging the mouse, and in the format you set using the Set Preferred 
command on the Gallery menu.    

ChartWizard Tool
Starts the ChartWizard so that you can create a chart as an embedded object on a 
worksheet or edit either an embedded chart or chart document.

Horizontal Gridlines Tool
Adds or removes major value axis gridlines visible on an active chart or selected 
embedded chart.

Legend Tool
Adds or removes a legend along the right side of an active chart or selected embedded 
chart.

Arrow Tool
Creates an arrow on an active worksheet or macro sheet, or adds an arrow on an active 
chart.

Text Box Tool
Draws a text box where you can type text on a worksheet; lets you add unattached text 
to an active chart.
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ChartWizard 
Assists you in creating a chart from data on the worksheet.    The chart is not drawn on the 
worksheet until you complete the ChartWizard.

If the ChartWizard hides a part of the worksheet you want to see, move the 
ChartWizard by dragging its title bar.

If you are creating a new chart, the second step of the ChartWizard shows examples 
of all 14 chart types available.    Each of these corresponds to a command on the Gallery 
menu.

This button Does this

Displays information about the current step in the Help window.    Choosing 
this button is the same as pressing F1.

Closes the ChartWizard without drawing a chart.
Goes back to the beginning of the ChartWizard.
Goes back to the previous step.
Goes on to the next step.
Completes the ChartWizard using the selections you have made so far.    If you choose

this button on the first step, the ChartWizard creates a chart of the type determined by the 
Set Preferred command.



ChartWizard
The sample chart is based on the actual data you have selected.    As you select options in 
this dialog box, the sample chart is redrawn to reflect your selections.    You can experiment 
with various options--no changes are made in the actual chart until you complete the 
ChartWizard.
Data Series In 

Rows Each selected row of data on the worksheet will appear as a data series on
the chart.

Columns Each selected column of data on the worksheet will appear as a data 
series on the chart.

Use First Row/Column For
The options available depend on the chart type you selected.

Category (X) Axis Labels
The contents of the first row or column will appear as labels along the x-axis.

First Data Series
The contents of the first row or column will appear as a data series on the chart.    Any 
cell in the first row or column that contains text will be plotted as zero.

Pie Slice Labels
The contents of the cells in the first row or column will appear as labels for the pie 
slices.

First Data Series
The values of the cells in the first row or column will determine the size of the slices.

X Data
The values in the first column or row will be used to calculate the scale for the x-axis of
an xy (scatter) chart.

First Data Series
The contents of the cells in the first row or column will appear as a data series on the 
chart.    Any cell in the first row or column that contains text will be plotted as zero.

Use First Column/Row For
The options available depend on the chart type you selected.

Legend Text
The contents in the first column or row will appear in the legend as labels for the data 
series.

First Data Point
The values in the first column or row will appear as the first category on the chart.    
Any cell in the first column or row that contains text will be plotted as zero.

Chart Title
The value in the first column or row will appear as the title for the chart.

First Data Point
The value in the first column or row will be the value of the first pie slice.

Series (Y) Axis Labels



The values in the first column or row will be labels along the y-axis.
First Data Point

The values in the first column or row will be the first category on the chart.    Any cell in 
the first column or row that contains text will be plotted as zero.



ChartWizard 
This step allows you to add or delete a legend and type chart and axis titles if you want.
The sample chart reflects the changes you make as you make them.    You can experiment 
with various options--no changes are made in the actual chart until you complete the 
ChartWizard by pressing ENTER or choosing the OK button.




