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About Icon Editor
Icon Editor provides the tools you need to create new icons and modify existing ones. You can also 
establish your own icon libraries for storing and organizing multiple icons. 
You can edit 32x32 pixel icons in monochrome, VGA, and EGA format, as well as 64x64 pixel icons in 
Windows 2.x and 3.1 Hi Resolution format.
With Icon Editor, you can:

Create icon libraries
Import icons into libraries from existing .ICL, .ICO, .EXE, or .GRP files
Export icons from icon libraries to new .ICO files
Rearrange and organize icons within icon libraries
Save icons in executable or .GRP files
Create and color individual icons using the editor's painting tools and 16-color palette



File Menu
Use commands on this menu to create, open, save, import, and export icons.
New Creates an icon library (.ICL) file.

Open Opens an existing icon, executable, group, or icon library file.

Save Saves changes from the current file to disk.

Save As Saves an icon library file.

Import Icon Imports an icon from an existing icon, executable, group, or icon library file.

Export Icon Exports an icon from the workspace and creates a new icon (.ICO) file.

Exit Exits from the Icon Editor application.



File Menu
New Import Icon
Open Export Icon
Save Exit
Save As



    New 
Creates a new icon library.
The workspace and Icon Selector are cleared.
If you have not saved changes to your work in progress, an alert dialog box asks if you want to save the 
changes. 

_________
See Also

Creating Icon Libraries



    Open
Opens an existing icon or icon library file.
If you have not saved changes to your work in progress, an alert dialog box asks if you want to save the 
changes. 

Dialog Box Options
File Name The name of the file you want to open.

Directories The name of the current directory. To change directories, double-click the 
directory where the file you want to open is located.

Drives The current drive. To display a different drive, select a new entry from the list.

List Files of Type The type of file you want displayed in the scrolling file list. You can then select the
file you want from this list.

Viewer button Choose Viewer>> to view an file before you open it in Icon Editor. Choose 
<<Viewer to close the view pane.

_________
See Also

Modifying Existing Icons
Modifying Icon Libraries



    Save As
Saves an icon library file or an individual icon file.

Dialog Box Options
File Name The name of the icon library file you want to save. If you provide the .ICO 

extension, you can use Save As to save an individual icon file.

Directories The name of the current directory. To change directories, double-click the 
directory where the file you want to open is located.

Drives The current drive. To display a different drive, select a new entry from the list.

List Files of Type The type of file you want displayed in the scrolling file list. You can then select the
file you want from this list. To display all existing .ICL files in the selected 
directory, select Icon Libraries from the drop-down list.

_________
See Also

Creating Icon Libraries



    Import Icon
Imports icons.
Importing allows you to convert icons to different icon types for VGA, EGA, Monochrome, High 
Resolution, and Windows 2 displays. You can import single icons, icons from libraries, group files, and 
icons from executable files such as .EXE, .DLL, .RSL, .BIN, .DRV, and .SCR. 

Dialog Box Options
File Name The name of the file from which you want to import icons.

Directories The name of the current directory. To change directories, double-click the 
directory where the file you want to open is located.

Drives The current drive. To display a different drive, select a new entry from the list.

List Files of Type The type of file you want displayed in the scrolling file list. You can then select the
file you want from this list. To display all existing .ICL files in the selected 
directory, select "Icon Libraries" from the drop-down list.

Icons Displays the icon or icons in the file you selected to import. If there are more than
12 icons in the file (8 for EGA displays), you need to use the scroll bar to see the 
remaining icons.

Icon Type The display type of the selected icon in the selector.

_________
See Also

Importing Icons



    Export Icon Dialog Box
Creates an individual icon (.ICO) file.

Dialog Box Options
File Name The name of the file you want to export the icon to.

Directories The name of the current directory. To change directories, double-click the 
directory where the file you want to open is located.

Drives The current drive. To display a different drive, select a new entry from the list.

List Files of Type The type of file you want displayed in the scrolling file list. You can then select the
file you want from this list. To display all existing .ICO files in the selected 
directory, select Icons from the drop-down list.

________
See Also

Change Icons Used by Applications



    Exit 
Closes the Icon Editor application. 
If you have not saved your work, a dialog box asks if you want to save changes you have made.



Edit Menu
Commands on this menu cut, copy, and paste selected regions, undo recent changes, and clear the 
workspace.
Undo Reverses the most recent editing action.

Cut Removes the selection and places it on the Clipboard.

Copy Copies the selection to the Clipboard.

Paste Copies the selection on the Clipboard to a new location.

Delete Removes the selection without copying it to the Clipboard.

Clear Clears the workspace area.



Edit Menu
Undo Paste
Cut Delete
Copy Clear



    Undo
Reverses the most recent cut, copy, or paste command.
You cannot undo the Clear command.



    Cut 
Removes the selection and places it on the Clipboard.

_________
See Also

Pasting



    Copy 
Copies the selection to the Clipboard.

_________
See Also

Pasting



    Paste 
Copies the selection on the Clipboard to the upper-left corner of the workspace.

_________
See Also

Cutting



    Delete
Removes the selection without copying it to the Clipboard.

_________
See Also

Cutting



    Clear 
Clears the workspace.
If you have not saved changes, you are prompted to specify whether to save them, ignore all changes, or 
cancel the Clear command and return to the workspace.



Icon Menu
Edit Copies the selected icon from the Icon Selector to the workspace.

Replace Replaces the selected icon in the Icon Selector with the icon from the workspace.

Append Adds the icon in the workspace to the bottom of the Icon Selector panel.

Insert Inserts the icon from the workspace at the current position in the Icon Selector.

Remove Removes the selected icon in the Icon Selector. 



Icon Menu
Edit
Replace
Append
Insert
Remove



    Edit
Replaces the icon in the workspace with the selected icon in the Icon Selector.
If you have not saved changes, you are prompted to specify whether to save them, ignore all changes, or 
cancel the Clear command and return to the workspace.



    Replace
Replaces the selected icon in the Icon Selector with the icon from the workspace.



    Append
Adds the icon in the workspace to the first available position in the Icon Selector.



    Insert
Inserts the icon from the workspace to the current position in the Icon Selector.



    Remove
Removes the selected icon in the Icon Selector. 



Tools Menu
Corresponds to the Toolbox.
Use commands on this menu to select the icon editing tools. 

_________
See Also

Using the Toolbox



Tools Menu
Brush
Replacer
Square
Filled Square
Circle
Filled Circle
Line
Filler
Selector
Move



Brushes Menu

 Corresponds to the Brush Selector. 
Sets the size of the brush in use.
1x1 A brush that colors only one pixel when you click the mouse in the workspace.

2X2 A brush that colors a square of 4 pixels when you click the mouse.

3x3 A brush that colors a square of 9 pixels when you click the mouse.

4x4 A brush that colors a square of 16 pixels when you click the mouse.



Brushes Menu
1. 1x1
2. 2x2
3. 3x3
4. 4x4



Options Menu
Use commands on this menu to customize various aspects of Icon Editor.
Customize Displays the Customize Icon Editor dialog boxes that you use to change the Toolbar, 

shortcut keys, and menus, and create custom commands that start other programs. If
you run PC Tools for Windows from a network, this dialog box series might be 
password-protected. 

When checked, the following options are on:
Long Menu The long version of the pull-down menus, which contain all of the available 

commands. This is the default menu scheme.

Short Menu The short version of the pull-down menus, which do not contain commands for the 
tools in the main application window.

Toolbar The Toolbar appears in the application window.

Status Bar A description of the selected command appears on a status line at the bottom of the 
application window. If you are using the workspace, the status bar shows the grid 
position of the mouse cursor, including the upper left and lower right position if the 
selected brush size is larger than one pixel, and the brush size.

VGA VGA icons appear in the Icon Selector.

EGA EGA icons appear in the Icon Selector.

Monochrome Monochrome icons appear in the Icon Selector.

HiRes High Resolution icons appear in the Icon Selector.

Windows 2 Windows 2 icons appear in the Icon Selector.



Options Menu
Customize

Toggle Commands
Long Menu EGA
Short Menu Monochrome
Toolbar HiRes
Status Bar Windows 2
VGA



    Help Menu
Use commands on this menu to get help on Icon Editor and access help for the Microsoft Windows help 
system.
Contents Opens the table of contents for this help file.

Search for Help on Displays a list of index terms for this help file. Follow the instructions in the dialog box
to search for a help topic.

How to Use Help Provides information about using the Microsoft Windows help system.

About Icon Editor Displays the version number of this application, a copyright notice, and user and 
Windows environment information, including the amount of free memory and 
resources in Windows.



Using the Tools
The Icon Editor main window contains a palette, a drawing and coloring toolbox, image manipulation 
tools, and a panel that displays selected icons or an icon library.

Workspace 

 A 32x32 grid, or 64x64 for HiRes icons. Each square represents a single pixel or pel. The icon appears in
its actual size in the icon viewer and is updated as you work.

Toolbox 

Ten coloring and drawing tools. Choose
Brush Replacer
Square Filled Square
Circle Filled Circle
Line Filler
Selector Move 

Brush Size Selector 

Four buttons for selecting the current brush size, from one to four pixels square. The brush size applies to
the Brush, Replacer, Line, Square, and Circle tools. Only one brush size can be selected at a time. 

Shift and Flip Selector

Six buttons for shifting the selected block of pixels in the workspace one pixel in the indicated direction, or
rotating it on its horizontal or vertical axis. If no block is selected, the entire workspace is shifted or 
rotated.

Color Palette

20 buttons, 16 for selecting fast colors, two for selecting the screen and inverse colors, and two for cycling
through screen and inverse colors. 



Eyedropper 

Assigns colors to the right and left mouse buttons. Used especially for editing 256-color icons that contain
colors not in the palette. Select the Eyedropper and click a color in the workspace with either the right or 
left mouse button to assign the color to that button

Icon Selector Panel
Displays the icons in the open library. If there are more than 12 icons in the file (8 for EGA displays), use 
the scroll bar to see the remaining icons. Double-click an icon to edit it in the workspace.

________
See Also

Using the Toolbox



Assigning Colors to the Mouse Buttons
The mouse icon in the lower -left corner of the application window shows the colors that are currently 
assigned to the mouse buttons. If one of the assigned colors is a screen or inverse color, a small s or i 
appears next to the mouse button in the icon.
You assign colors to mouse buttons in two ways:

To assign a color from the color palette, click the color with the mouse button. If you click the s or 
i squares, the assigned color in the created icon will change if the monitor screen color changes.

To assign a color directly from the icon, use the Eyedropper.
1. Click the Eyedropper tool. The mouse cursor changes to an eyedropper.
2. Position the tip of the eyedropper cursor on the pixel that contains the color you want to use, and 

click the mouse button.
The Eyedropper lets you use colors that are not shown in the color palette when you are editing 256-
color icons.



Using the Toolbox to Draw and Color
The Toolbox contains 10 basic tools for drawing and coloring in the icon workspace.

    Brush Colors individual pixels. The number of pixels colored with each mouse click depends on 
the brush size you have selected.

    Replacer Replaces pixels of only one color with pixels of a second color, preventing you from 
changing other pixels in case your hand slips or you are using a large brush size. When the Replacer tool 
is in effect, pixels of the color on the mouse button you click replace only pixels of the color on the other 
mouse button.

    Square Draws rectangular outlines. The cursor changes to two cross hairs. Position the cross 
hairs in one corner of the rectangle and drag them to the diagonally opposite corner. The release the 
mouse button. The width of the outline depends on the selected brush size.

    Filled Square Draws filled rectangles. Draw filled squares as you draw outlined squares.

    Circle Draws circular and oval outlines. The cursor changes to two cross hairs. Draw circles and
ovals as you draw squares.

    Filled Circle Draws filled circles and ovals. The cursor changes to two cross hairs. Draw filled 
circles and ovals as you draw filled squares.

    Line Draws a straight line in any direction. The cursor changes to two cross hairs. Position the 
cross hairs where you want the line to begin and drag it to where you want it to end. The width of the line 
is determined by the selected brush size.

    Filler Fills a region of the workspace with a selected color. Click one pixel in the region you 
want to fill. All adjacent pixels of the same original color are filled with the new color. The entire area is 
filled with the new color, regardless of the selected brush size.

    Selector Selects an area of the workspace to edit. The cursor changes to two cross hairs. Position 
the cross hairs where you want one corner of your selection to start. Drag the cursor to the diagonally 
opposite corner and release the mouse button.

    Move Moves the selected region of the icon in the workspace. If no region is selected, the 
entire workspace is moved. Note that the space originally occupied by a moved region is filled with the 
default background color, which is the color assigned to the right mouse button.

________
See Also

Editing Workspace Regions 



Mouse Shortcuts
You can import icons by dragging a file containing icons from File Manager to the workspace, or to the 
Icon Viewer in the upper-right corner of the application window. Dragging an icon file to the Icon Selector 
or minimized Icon Editor opens the file. In addition, you can drag desktop items to the workspace or Icon 
Selector. 
Drag-and-Drop
Pop-Up Menus

Go to 



Using Drag-and-Drop

Go to Click 

 to print this page
To Drag and Drop
Open an icon file The file from File Manager, or the item from the desktop, to the Icon Selector or 

minimized Icon Editor icon.

Import icons The file from File Manager to the workspace or Icon Viewer.



Using the Pop-Up Menu
Click the right mouse button over the Toolbar to pop up a menu containing commands that you can use to
change the style or placement of buttons, select a different configuration scheme, or display the 
Customize dialog box. 

Go to 



Keyboard Shortcuts

Go to Click 

 to print this page.
Key Action
Tab Moves to the next command button, list box, text box, or group of option buttons.

Shift+Tab Moves to the previous command button, list box, text box, or group of option 
buttons.

Arrow keys Moves down the file list or within a group of option or command buttons.

Spacebar Selects a color for the left mouse button.

Shift+Spacebar Selects a color for the right mouse button.

F1 Displays context-sensitive help.

F10 or Alt Activates the menu bar.

Alt + underlined letter Activates the menu or command.

Alt+F4 Closes Icon Editor.

Enter Chooses the active command button.

Esc Cancels the command and closes the dialog box.



Modifying Existing Icons
Follow these steps to change an existing icon:
1. Choose Open from the File menu or Toolbar.
2. Double-click a file in the file list to open it for editing.
3. Choose Replace from the Icon menu when you finish modifying the icon.
4. Choose Save from the File menu.
5. Choose OK.

________
See Also

Modifying Icon Libraries



Creating Icon Libraries
An icon library is a single file that contains many icons. 
Use Icon Editor to create new icon libraries, and import icons to and export icons from existing libraries. 
You can select icons from the libraries that you create and associate them with items in Desktop.
Follow these steps to create an icon library:
1. Choose New from the File menu. The workspace and Icon Selector are cleared.
2. Create an icon in the workspace with the editing tools or import an existing icon.
3. Choose Insert from the Icon menu or Toolbar.

The icon in the workspace is added to the Icon Selector panel at the right of the workspace. Choose 
Replace to replace the selected icon in the Icon Selector with the icon in the workspace, or choose 
Append to insert the icon in the workspace in the next available position.
Continue to create or import icons and add them to the Icon Selector panel.

4. Choose Save As from the File menu when you finish creating the icons that you want in the new 
library.

5. Type the file name of the new icon library you want to create in the File Name text box and choose OK 
to save the library. 

________
See Also

PC Tools for Windows Icon Libraries 
Modifying Icon Libraries
Save As Dialog Box



Modifying Icon Libraries
You can edit icons in an existing icon library or add icons to it. 
Follow these steps to change an existing icon library:
1. Choose Open from the File menu or Toolbar and select the icon library from the file list. Icon libraries 

have the extension .ICL.
The Icon Selector panel displays the icons in the library file. If there are more than 12 icons in the 
library, or 8 for EGA displays, use the scroll bar to see the remaining icons. 

2. In the Icon Selector, double-click the icon you want change. The icon is displayed in the workspace for 
you to edit.

3. After you have made your changes, choose Insert from the Icon menu or Toolbar. The icon in the 
workspace is inserted in the Icon Selector. 
Choose Replace to switch the selected icon in the Icon Selector with the icon in the workspace, or 
choose Append to insert the icon in the workspace in the next available position.
Choose Remove from the Icon menu to remove a selected icon in the Icon Selector. 

4. Continue to edit, create, or import icons and add them to the Icon Selector panel.
5. Choose Save from the File menu when you have finished modifying the icons in the library.

________
See Also

Modifying Existing Icons
Open Dialog Box



Importing Icons
Import icons to convert them to different icon types for VGA, EGA, Monochrome, Hi Resolution, and 
Windows 2 displays. You can import single icon files, icons from libraries, group files, and icons from 
executable files with extensions such as .EXE, .DLL, .RSL, .BIN, .DRV, and .SCR. 
1. Choose Import Icon from the File menu or Import from the Toolbar. The Import Icon dialog box 

appears.
2. Select a file type to display in the list from the List Files of Type drop-down list box. 
3. Double-click a file in the file list to import the icon. The Icon Type drop-down list box indicates the 

display format of the selected icon. The icons appear in the Icons panel.
4. In the Icons panel, double-click the icon you want to select.

The Icon Editor main window reappears with the selected icon in the workspace. This icon is displayed
according to the current display format setting on the Options menu. 

5. Choose a new display format from the Options menu. You might have to edit the icon to make it appear
correctly in the new format.

6. Choose Export from the File menu to save the imported icon in the new display format. 

_________
See Also

Import Icon Dialog Box



Changing Icons in Executable Files
Most programs have two similar icons, one for monochrome and one for VGA displays. If you modify and 
replace these icons, you see the changes when you run the program and minimize it. 
To change the icons that mark a minimized executable file, such as NOTEPAD.EXE, follow these steps:
1. Choose the File menu Open command to open the executable file in the Icon Editor.

Its icons appear in the Icon Selector panel. 
2. Double-click an icon in the selector panel to edit it. You can also use the File menu Import command to

put a completely different icon in the workspace, and substitute it for one of the icons in the executable 
file. 

3. When you have made changes or imported a different icon, use the Replace command to substitute 
the new icon for the old one.

4. Choose the File menu Save command to save the executable file with the modified icons. The changed
icon appears when you minimize the application.

Note
You cannot add icons to an executable file or delete icons from it. Even if icons could be added to the file, 
the application would not be able to use them. If any icons were deleted from the file, the application 
would fail when it tried to display a missing icon.
Always make a backup copy of any executable file whose icons you want to edit. When you finish editing, 
copy the modified file to the original file name. If the results are not what you expect, copy the backup to 
the original file.

Warning
Do not change an executable file that Windows is using. For example, if you replace an icon in 
WNDTL.RSL (a file used by Desktop) and then save the .RSL, your system will crash the next time you 
start Desktop. If Desktop is your shell, you will not be able to run Windows. You can avoid this problem by
making changes to a backup copy, then renaming the file to the original name when the original file is not 
in use.



Editing a Selected Workspace Region
The following information about the Move tool and Shift and Flip indicators applies to a region you have 
created with the Selector tool. If no region is selected, the entire workspace is affected.

To select a region, click the Selector tool. The workspace cursor changes to a crosshair. Click the 
crosshair on one corner of the region you want to select, drag the cursor to the diagonally opposite 
corner, and then release the mouse button.
The selected region is outlined with a dotted line. You can select only a rectangular area. A selected 
region remains selected until you click the Selector tool again.

 Move
Choose the Move tool to move a selected region in the workspace. When Move is active, click in the 
selected region and drag it to a new position. 
The pixels that originally occupied the moved region are colored automatically with the default 
background color, which is the color assigned to the right mouse button.

Shift and Flip
Use the Shift and Flip indicators to reverse the orientation of a region or move it one pixel at a time in the 
indicated direction. 

 To move a selected region one pixel in any direction, choose one of the direction arrows. 

 To flip a selected region so that its right/left orientation is reversed, select this indicator.

 To flip a selected region so that its up/down orientation is reversed, select this indicator.

________
See Also

Working with Colors



PC Tools for Windows Icon Libraries
PC Tools for Windows provides the following icon libraries:

Icon Library Name Contains
APPLCTNS.ICL PC Tools for Windows application icons.

DRIVES.ICL A variety of drive icons.

FILEITMS.ICL An assortment of file icons.

FOLDERS.ICL Desktop folder icons.

HARDWARE.ICL A variety of hardware icons.



Working with Colors
Icons are created with two different kinds of colors: 
Screen and Inverse Colors

These colors do not have a constant value. They are related to each other and 
change when the monitor screen background color changes. 

Fast Colors These colors never change on the screen. When you draw with a fast color, it 
remains the same in the icon, even when the color of the monitor screen changes. 

To assign any kind of color to a mouse button, click the button on the color or the s or i symbol in 
the color palette.
When the icon appears on the monitor screen, pixels colored with the screen color change to match the 
background screen color. The inverse colored pixels contrast with the screen color, and change when it 
does. 
Pixels colored with the screen color will appear to show the background through the icon when it is 
displayed on the screen. Pixels colored with the inverse color will always contrast with the monitor screen.
When it is marked by the s or i symbols, the mouse icon in the lower-left corner of the window shows that 
a mouse button is being used for screen and inverse colors. The color palette displays the current screen 
and inverse colors marked by s and i symbols. 
Screen and inverse colors are black and white by default.

To display different combinations of screen and inverse colors, click the up and down arrows 
beside the s and i symbols at the right end of the color palette to see how the icon looks against different 
backgrounds. The actual colors used for the screen and inverse colors are not important in any other way,
since they change when the icon appears on the monitor screen.

________
See Also

Using the Toolbox 
Assigning Colors to Mouse Buttons 



Fast Colors
These colors never change on the screen. When you draw with a fast color, it remains the same, even 
when the color of the background screen changes. 



Screen and Inverse Colors
These colors do not have a constant value. They are related to each other and change when the monitor 
screen background color changes. When the icon appears on the monitor screen, pixels colored with the 
screen color change to match the background screen color. The inverse colored pixels contrast with the 
screen color, and change when it does. 
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    Customize
Customizes the toolbar, menus, or keyboard shortcuts in your Central Point application. If you choose All 
from the Customize submenu, all available tabs appear in the Customize dialog box. If the application 
does not have a toolbar or menus, those tabs are not available.
Select a tab from the top of the Customize dialog box to customize the following:
Toolbar Commands on the toolbar.

Menu Commands on the menus.

Keyboard Shortcut keys for commands.

Commands Custom commands that start other applications.

The dialog box may contain any of the following buttons:

Buttons Save Default Copy



Toolbar
Creates a new series of toolbar commands or changes an existing one.

To change the appearance of the buttons on the bar, choose the Style button and select a style 
from the choices that appear.

To add a command to the toolbar, select the command from the Commands drop-down list box 
and choose Insert.

Dialog Box Options
Toolbar Click the arrow to the right of the list box to see the toolbar schemes you have saved.

The name of the current scheme appears by default. Scheme names are case-
sensitive. For example, you can have a scheme named Projects and another named 
PROJECTS.

(Toolbar Display) A representation of the current toolbar.

Commands This drop-down list box displays the names of commands you can add to the toolbar. 
The list includes any custom commands you have set up.

Buttons Copy Remove
Insert Delete

 
      

Default Style

Note
Use the toolbar only for commands that perform tasks. Some commands shown in the list box do not 
perform actions, but display information. These commands are not appropriate for the toolbar. 



Toolbar Style
Displays tool buttons in different styles and locations in the window.

Dialog Box Options
Button Style Select a style. You can display large or small icons, with or without text, or text 

only. When you select a style, the sample command button shows you what it 
looks like.

Placement You can display the toolbar at the top of the window (the default position), the 
bottom, or the left or right side. In applications where you want a long screen 
window rather than a wide one, you might prefer to display the buttons on the 
side.

Show Toolbar Balloons Displays on-screen balloons that identify a toolbar button when the mouse 
pointer pauses over it. Toolbar balloons appear only if the button style does not 
include text.

Note
In some Central Point applications, the Placement options are not available.



Button Style
Select one of five tool button styles.
Large Icon and Text Shows both the large command icon and the name.

Large Icon Only Shows only the large command icon.

Small Icon and Text Shows both the small command icon and the name.

Small Icon Only Shows only the small command icon. 

Text Only Shows only the command name.

ShowToolbar Balloons Displays on-screen descriptions of a toolbar button when the mouse pointer 
pauses over it. Toolbar Balloons only display if the button style does not include 
text.



Toolbar Position
In many Central Point applications, you can display the toolbar in one of four locations in the window.
Top Horizontally, across the top of the window, under the menu bar.

Bottom Horizontally, across the bottom of the window, above the status line.

Left Vertically, at the extreme left of the window.

Right Vertically, at the extreme right of the window.



Keyboard
Adds or removes keyboard shortcut keys for commands.

To change the shortcut key associated with a command, select the command, type a new 
shortcut key, and choose Insert or Replace. (Replace appears if the shortcut key is already assigned to 
another command.)

Dialog Box Options
Shortcut Keys Click the arrow to the right of the drop-down list box to see the keyboard schemes 

you have set up. Scheme names are case-sensitive. For example, you can have a a 
scheme named Lisa and another named LISA.

(Command List) A list of commands and associated shortcut keys.

Shortcut Key Key names are entered automatically in the box when you press the keys. If you 
enter a shortcut key already in use, you replace the command currently assigned to 
the key.

Commands This list box displays the names of commands you can assign shortcut keys to. The 
list includes any custom commands you have set up.

Buttons Replace or Insert Delete
Default



Shortcut Key Schemes
You can create named keyboard schemes (that is, sets of shortcut keys) for special purposes.
If you choose Default, you reset the named scheme to the default keyboard settings.



Menu
Lets you add, delete, rename, or reorder pull-down menu commands.

To add a command to the menu at the level of the selected menu item:
1. Scroll through the Commands list box.
2. Select the command you want to add.
3. Choose Insert.

Dialog Box Options
Menu Click the arrow to the right of the list box to see the menu schemes that are set up. 

Scheme names are case-sensitive. For example, you can have a scheme named 
Maria and another named MARIA.

(Menu Display) The Menu window shows the selected menu scheme. You can delete existing 
commands and add new commands at any level. Choose the Separator command to 
insert a separator bar. 

Commands This drop-down list box displays the names of commands you can add to the menu. 
The list includes any custom commands you have set up.

Buttons Copy Remove Insert 
Delete Default

 

      
      

Note
Choose the Default button only if you want to change the selected menus to match the default menu 
scheme. 

________
See Also

Editing Command Names 
About Editing Menus 



About Editing Menu Schemes
In several Central Point applications, you can select a Long Menu scheme or a Short Menu scheme.
You can modify a menu scheme in the following ways:

Delete commands you do not use.

Add a new menu category.

Add custom commands you have created.

Change the order of commands on a menu.

Move commands from one menu to another.

Add separator bars.



Editing Menu Command Names
You are most likely to edit the names of commands that you have created yourself. For example, you 
might edit a menu level header you have added, and give it a unique name.

To change the name of any command on the menu, select the command, then press F2 to edit 
the name. Type the name you want to assign to the command, and press Enter.

To create an underline character for use as a keyboard shortcut, insert an ampersand (&) before 
the letter you want to use. Make sure that the shortcut key you create does not conflict with another 
shortcut key. If you want to include a literal ampersand character in the command name, insert two 
ampersands.

For example, 
My&Command produces MyCommand. 
My&&Command produces My&Command.



Default Menu Schemes
Each Central Point application with menus has a default menu scheme. When you choose the Default 
button in the Menus tab of the Customize dialog box, the selected menu is reset to match the default.



Menu Schemes
Available menu schemes (sets of menus and commands) appear on the Options menu. Several Central 
Point applications offer default long and short menus.
If you have created custom menu schemes, they are available from the Options menu in the application.

To switch to another menu scheme, choose a scheme from the Options menu.



Separator
To add a line that divides one group of commands in a menu or toolbar from another group, select the 
Separator command from the commands shown in the list box, or click the Separator icon.
The line appears above the selected command (in a menu) or before the selected button (in a toolbar) 
when you choose Insert.



Toolbar Schemes
The list of toolbar schemes (sets of toolbar buttons) appears on the pop-up menu for the toolbar.
If you have created custom toolbar schemes, the names of these schemes appear in the list.

To change to another toolbar scheme, choose it from the pop-up menu.



Custom Commands
You can add your own custom commands to Central Point applications.
Custom commands do not have online help at the menu level. If the command is a Windows program, 
you can use the Microsoft Windows help after you choose the command to start the program.
If the command is a DOS application or a macro from another application, help is probably not available.



Creating Custom Commands
Adds commands to the list available for the menu and toolbar. A custom command may be any of the 
following programs or documents:

Another Windows application, such as Word for Windows or Central Point Backup.

A macro, such as a Central Point ScriptTools .RUN program.

A DOS application you run in a DOS window.

A document associated with an application.
To use a custom command after you create it, you need to assign it to a menu, the toolbar, or a keyboard 
shortcut.

Dialog Box Options
Commands The Commands box shows a list of custom commands that you have added.

Command Name The name you assign to the command.

Command Line The full path of the command document or application program. Use the Browse 
button to look for the file and insert its name.

Working Directory The directory where the command looks for data files and other documents. This 
information is optional. If you leave the working directory box blank when you first 
create a new command, the default is the program directory. If you delete the working
directory information, the default is the Windows directory.

Description A descriptive comment that appears on the status bar.

Show Style The size of the window where the command runs: normal, minimized, or maximized.

Button Text A very short title to appear on a button for this command.

Menu Text A short title to appear in a menu listing for this command.

Buttons New Copy
Browse Icon
Password Delete



Select Icon Dialog Box
Selects an icon for a command or item.
You can select an icon from any file that contains icons in the standard format, such as MORICONS.DLL. 
You can also select an icon that you have created yourself in an application such as Central Point Icon 
Editor (in PC Tools for Windows).

To use a different icon file, choose Browse and use the directory tree and file list to select an icon 
file. Then choose OK to apply it to the custom command.

To select a new icon, select the icon in the selection box and choose OK.

Dialog Box Options
Current File The name of the file containing the current icon. A file can contain multiple icons.

Total Icons The number of icons in the current icon file. Icons are shown in the selection box. 
Use the scroll bar at the bottom of the selection box to see all available icons.

Available if you choose the Browse button:
File Name The names of files in the current directory that might contain icons.

Directories The directory tree on the current drive.

List Files of Type The file types displayed in the file list. Select from the drop-down list a file type that 
contain icons.

Drives The list of drives available to your computer. The current drive is displayed.



Icon Files
Files that contain icons have the following file types: DLL, EXE, ICO, RSL, and ICL.



Save
Saves all new or changed configurations for this part of the Customize dialog box.



Copy
Makes a copy of the named scheme so that you can modify it and create a new scheme.



Copy
Makes a copy of the selected custom command. 
You can modify the copy by editing the command line or other options in the text boxes to create a 
different version of the command.



Default
Returns the named scheme to the default, even if it has been saved. All changes are lost.
If more than one menu scheme is shipped with the application, the scheme used to reset menus to the 
default is the menu scheme in use when you first installed the application.



Password
Enter a password for this command. After you assign a password to a command, you are prompted to 
enter it when you choose the command. You must also enter the password to change any of the 
command attributes in the Commands tab of the Customize dialog box.



Insert
Inserts the command that appears in the Commands box into the toolbar, menu, or keyboard shortcut key
list into the named scheme. The command is positioned either to the left of the selected item or above it.
In the Keyboard tab, the Insert button is inactive until you specify the shortcut key.



Delete
Deletes the selected item on the toolbar, menu, or keyboard shortcut key list.



Delete
Deletes the selected custom command.



New
Adds a new named configuration scheme.
When you select New, a default name appears selected in the Scheme box. To enter a different name, 
type over the default.



New
Displays the generic command template.
You can enter all necessary information yourself, or choose Browse to select a .PIF, .RUN, .EXE, or other 
executable file. When you select the file, the Command Name, Command Line, Description, Button Text, 
and Menu Text boxes are automatically filled in with defaults for the executable file. You can edit these 
defaults to make them more descriptive.



Replace or Insert
This button is labeled Insert if the shortcut key you have typed is not assigned to another command.
The button is labeled Replace if the shortcut key you have typed is already assigned to another 
command. No confirmation message appears.



Remove 
Deletes the entire named configuration shown in the Scheme text box.



New Menu
Adds a new menu at the level of the selected box. 
The default name for the new menu is Custom Menu. 
Immediately after you create the new menu item, you can enter a descriptive name to replace Custom 
Menu. If you want to change the name later, select the menu name, then press F2 to edit the name.
If a menu name is selected, a new menu is inserted above it. If a menu command is selected, a 
cascading submenu, accessed through the command, is inserted.



Arrows
Click the arrow keys to move the selected item to the right or left in the toolbar, and up or down in the 
menu list hierarchy.



Icon
The icon appears on the button if you put the command on your toolbar.
You can select any icon file available on your drive. Choose Browse in the Icon dialog box to find icon 
files and apply them to the new command.



 Password for Customizing
If you are using a Central Point application from a network, the network administrator might have 
password-protected the Customize command to prevent individual users from changing the toolbar, 
menus, shortcut keys, or custom command list.
If you find that you cannot use the Customize dialog box because it is password-protected, see your 
network administrator.



Browse

Selects a drive, directory, and file from the Browse dialog box.



Browse Dialog Box
Selects a custom command program file from the directory tree and file list.

To select a file, highlight the file name in the file list box. Then choose OK.

Dialog Box Options
File Name Enter the file-name pattern you are looking for. If you enter the full path of the files 

you want to select from, the drive and directory name change automatically.

For example, if the current directory is C:\WINDOWS, you can enter D:\LETTERS in 
the box. Files in D:\LETTERS appear when you press Enter. The drive and directory 
names shown in the Drive and Directory lists also change.

File List Files that match the file-name pattern appear here. Select a file name and choose 
OK to select it.

Directory Change the selected directory by clicking the directory folders.

Drive Change the selected drive by clicking the arrow at the right of the box and selecting 
another drive from the list that appears.

List Files of Type Click the arrow at the right of the box to select a different file category. You can 
override the category that appears here by typing another category specification in 
the File Name text box.



File Companions
File Companions can manage files (for example, copy a file or create a directory) from the Browse, Open,
or Save dialog box in any application--even non-Central Point applications--without switching to File 
Manager. For example, suppose you're about to save a newly-created file but need a new directory for it. 
From the Save dialog box you can create the directory and save the file--without leaving the dialog box.
File Companions are available when Desktop, rather than Program Manager, is your shell application. (To
use Desktop as the Windows shell, open the Configure icon in the PC Tools for Windows group.)

To use File Companions from any Browse, Open, or Save dialog box:
1. Click the  icon (next to the Control-menu icon) to open the File Companions menu and choose 
a file management command.
2. Use the Copy, Rename, or other dialog box to perform the chosen function.

You can choose the Help button for information about the active file management dialog box.
You can also display the File Companions menu by clicking the right mouse button on the background of 
the Browse, Open, or Save dialog box.






