Taakplanner

Met Taakplanner kunt u ervoor zorgen dat opdrachten, programma's of scripts op bepaalde tijden worden uitgevoerd:

  • Raadpleeg Mogelijkheden van Taakplanner voordat u met Taakplanner gaat werken.
  • Raadpleeg Procedures voor informatie over specifieke taken.
  • Raadpleeg Basisprincipes voor algemene achtergrondinformatie.
  • Raadpleeg Probleemoplossing voor informatie over het oplossen van problemen.


Mogelijkheden van Taakplanner

De onderstaande tabel geeft een overzicht van de bewerkingen die in Taakplanner het vaakst worden uitgevoerd. Zie Procedures voor een volledige lijst met Taakplanner-instructies.

Bewerking | Zie
Voordat u een taak kunt plannen, moet u een taak toevoegen. | Nieuwe taken plannen
Nadat u een geplande taak hebt gemaakt, kunt u een ander programma aan de taak koppelen of het schema of de instellingen van de taak wijzigen. | Geplande taken wijzigen
U kunt geplande taken volledig verwijderen als u deze niet meer nodig hebt. | Geplande taken verwijderen
Als een geplande taak wordt uitgevoerd terwijl u op dat moment de computer gebruikt, kunt u de taak desgewenst beëindigen en later opnieuw uitvoeren. | Het uitvoeren van geplande taken beëindigen
U kunt alle geplande taken tijdelijk onderbreken en op een later tijdstip verder laten uitvoeren. | Alle geplande taken tijdelijk onderbreken


Procedures

  • Taken plannen
  • Taakplanner beheren


Taken plannen
  • Taakplanner starten
  • Nieuwe taken plannen
  • Geplande taken wijzigen
  • Geplande taken verwijderen
  • Het uitvoeren van geplande taken beëindigen
  • Taken onmiddellijk uitvoeren


Taakplanner starten

  • Dubbelklik op Deze computer en vervolgens op Geplande taken.
  • Dubbelklik op Een geplande taak toevoegen. Hiermee opent u de wizard Nieuwe taak plannen die u helpt bij het plannen van een taak.


Nieuwe taken plannen
  1. Start Taakplanner.
  2. Dubbelklik op Een geplande taak toevoegen.
  3. Volg de instructies in de wizard Nieuwe taak plannen.

Opmerkingen

  • Als u geavanceerde instellingen voor de taak wilt opgeven, schakelt u in het laatste scherm van de wizard het selectievakje Geavanceerde eigenschappen voor deze taak openen wanneer ik op Voltooien klik in.
  • Als u een nieuwe taak herhaald wilt laten uitvoeren, schakelt u in het laatste scherm van de wizard het selectievakje Geavanceerde eigenschappen voor deze taak openen wanneer ik op Voltooien klik in. Vervolgens klikt u op het tabblad Schema en klikt u op Geavanceerd.
  • Als het taakprogramma parameters vereist, schakelt u in het laatste scherm van de wizard het selectievakje Geavanceerde eigenschappen voor deze taak openen wanneer ik op Voltooien klik in. Vervolgens klikt u op het tabblad Taak en typt u de parameters in het vak Uitvoeren achter het pad voor de taak.
  • Controleer of de systeemdatum en -tijd van de computer goed zijn ingesteld. Aan de hand van deze gegevens wordt bepaald wanneer geplande taken moeten worden uitgevoerd. U kunt de datum en tijd controleren of wijzigen door te dubbelklikken op de klok op de Taakbalk.


Geplande taken wijzigen
  1. Start Taakplanner.
  2. Klik met de rechtermuisknop op de taak die u wilt wijzigen en klik vervolgens op Eigenschappen.
  3. Voer een of meer van de volgende bewerkingen uit:
    • Als u een ander programma wilt uitvoeren, typt u in het vak Uitvoeren het pad voor het nieuwe programma.
    • Als u het schema voor de taak wilt wijzigen, klikt u op het tabblad Schema.
    • Als u de instellingen voor de taak wilt wijzigen, klikt u op het tabblad Instellingen.

Opmerkingen

  • Als u de gebruikersaccount wijzigt van het programma dat wordt uitgevoerd, moet u aangeven wat het wachtwoord is voor deze gebruikersaccount.
  • Als het taakprogramma parameters vereist, typt u deze in het vak Uitvoeren achter het pad voor de taak.
  • Als het pad naar het taakprogramma spaties bevat, plaatst u het volledige pad tussen dubbele aanhalingstekens ("").
  • Controleer of de systeemdatum en -tijd van de computer goed zijn ingesteld. Aan de hand van deze gegevens wordt bepaald wanneer geplande taken moeten worden uitgevoerd. U kunt de datum en tijd controleren of wijzigen door te dubbelklikken op de klok op de Taakbalk.


Geplande taken verwijderen
  1. Start Taakplanner.
  2. Klik met de rechtermuisknop op de taak die u wilt verwijderen en klik vervolgens op Verwijderen.

Opmerkingen

  • Als u een geplande taak verwijdert, wordt alleen het schema uit de lijst met schema's verwijderd. Het programmabestand wordt niet van de vaste schijf verwijderd.
  • U kunt een geplande taak ook verwijderen door op de toets DEL te drukken.


Het uitvoeren van geplande taken beëindigen
  1. Start Taakplanner.
  2. Klik met de rechtermuisknop op de taak die u wilt beëindigen en klik vervolgens op Taak beëindigen.

Opmerkingen

  • Als door het uitvoeren van een geplande taak een ander programma wordt gestart, wordt met deze opdracht alleen de oorspronkelijke geplande taak beëindigd en niet de tweede taak.
  • Als u een taak opnieuw wilt uitvoeren, klikt u met de rechtermuisknop op de taak en klikt u vervolgens op Uitvoeren.


Taken onmiddellijk uitvoeren
  1. Start Taakplanner.
  2. Klik met de rechtermuisknop op de taak die u wilt uitvoeren en klik vervolgens op Uitvoeren.

Opmerkingen

  • U kunt de taak beëindigen door te klikken op Taak beëindigen in het menu Bestand.
  • Als een taak niet op het geplande tijdstip is uitgevoerd, kijkt u in het logboek wat de oorzaak is: klik op Logboek weergeven in het menu Geavanceerd.


Taakplanner beheren
  • Logboek met reeds uitgevoerde taken weergeven
  • Taken weergeven die zijn gepland op een externe computer
  • Alle geplande taken tijdeljk onderbreken
  • Taakplanner uitschakelen
  • AT-serviceaccount instellen


Logboek met reeds uitgevoerde taken weergeven
  1. Start Taakplanner.
  2. Klik op Logboek weergeven in het menu Geavanceerd.


Taken weergeven die zijn gepland op een externe computer
  1. Dubbelklik op Netwerkomgeving op het Bureaublad.
  2. Dubbelklik op de computer waarvan u de geplande taken wilt weergeven.
  3. Klik op Geplande taken.

Opmerkingen

  • U kunt de taken van een externe computer waarop Windows wordt uitgevoerd, alleen weergeven als u beheerder van die externe computer bent.
  • U kunt de taken van een externe computer waarop Windows wordt uitgevoerd alleen bewerken als op die externe computer software voor externe registers is geïnstalleerd en de share x$ gedeeld is, waarbij x de vaste schijf is waarop de map Geplande taken staat. Tevens moet door deze computer aan uw gebruikersaccount specifieke toegang tot het externe register worden verleend. In Windows kunt u opgeven welke gebruikers toegang hebben tot het externe register van de computer door te dubbelklikken op het pictogram Beveiliging in het Configuratiescherm.


Alle geplande taken tijdelijk onderbreken
  1. Start Taakplanner.

  2. Klik op Taakplanner onderbreken in het menu Geavanceerd.

Opmerkingen

  • Deze opdracht is handig als u een ander programma (zoals een spelletje) uitvoert of software installeert en op dat moment geen geplande taken wilt laten uitvoeren.
  • Taken die zouden zijn uitgevoerd als Taakplanner niet onderbroken was, worden pas uitgevoerd op het volgende geplande tijdstip voor die taken.
  • Als u alle taken weer volgens planning wilt laten uitvoeren, klikt u op Doorgaan met Taakplanner in het menu Geavanceerd.


Taakplanner uitschakelen
  1. Start Taakplanner.
  2. Klik op Taakplanner uitschakelen in het menu Geavanceerd.

Opmerking

  • Als u Taakplanner uitschakelt, worden de geplande taken niet uitgevoerd en wordt Taakplanner niet automatisch gestart als u Windows opstart.


AT-serviceaccount instellen
  1. Start Taakplanner.
  2. Klik op AT-serviceaccount in het menu Geavanceerd.
  3. Klik op Deze account en typ vervolgens de gebruikersaccount waarmee taken moeten worden uitgevoerd die zijn gepland met de opdracht at.
  4. Typ het juiste wachtwoord voor de account in de vakken Wachtwoord en Wachtwoord bevestigen.

Opmerkingen

  • De AT-service is alleen beschikbaar onder Windows NT.
  • U kunt ook op Systeemaccount klikken. In dat geval worden de taken van de opdracht at uitgevoerd met de LocalSystem-account waaraan beheerdersrechten zijn toegekend.

  • U moet een account opgeven waaraan voldoende rechten zijn toegekend om alle taken die gepland zijn met de opdracht at uit te kunnen voeren. Als u bijvoorbeeld een taak wilt plannen voor een programma dat alleen door een beheerder kan worden uitgevoerd, moet u een beheerdersaccount opgeven.


Basisprincipes van Taakplanner

Basisprincipes

In dit gedeelte vindt u algemene achtergrondinformatie over Taakplanner:

  • Overzicht van Taakplanner
  • Taakplanner gebruiken
  • Taakplanner en de opdracht at
  • Taakplanner en beveiliging
  • Probleemoplossing


Overzicht van Taakplanner

Met Taakplanner kunt u taken (bijvoorbeeld Defragmentatie) regelmatig laten uitvoeren op het voor u meest geschikte tijdstip. Taakplanner wordt gestart zodra u Windows start en wordt op de achtergrond uitgevoerd.

Taakplanner biedt de volgende mogelijkheden:

  • U kunt instellen dat een taak dagelijks, wekelijks, maandelijks of op een bepaald tijdstip wordt uitgevoerd, bijvoorbeeld wanneer de computer wordt opgestart.
  • U kunt het schema voor een taak wijzigen.
  • U kunt de uitvoering van een geplande taak afbreken.
  • U kunt instellen hoe een taak op het geplande tijdstip wordt uitgevoerd.


Taakplanner gebruiken

Taakplanner wordt automatisch geïnstalleerd bij het Windows-besturingssysteem. U kunt deze planningsservice starten door te dubbelklikken op de map Geplande taken in Deze computer.

U kunt taken toevoegen door te dubbelklikken op Een geplande taak toevoegen waarna de wizard Nieuwe taak plannen verschijnt. U kunt ook taken toevoegen door scripts, programma's of documenten vanuit Windows Verkenner of vanaf het Bureaublad naar het venster met geplande taken te slepen.

Daarnaast kunt u met Taakplanner geplande taken wijzigen, verwijderen, onderbreken of beëindigen, een logboek met reeds geplande taken weergeven of taken weergeven die op een externe computer zijn gepland.

Zie Procedures voor meer informatie over het gebruik van Taakplanner.

Optimaal gebruikmaken van Taakplanner

In het Windows-besturingssysteem kunt u met Taakplanner elke toepassing automatisch laten uitvoeren. Om optimaal gebruik te kunnen maken van Taakplanner moet u, voordat u een taak toevoegt, controleren of de systeemdatum en -tijd van de computer goed zijn ingesteld.


Taakplanner en de opdracht at

Naast Taakplanner kunt u ook de opdracht at gebruiken voor het automatisch uitvoeren van taken.

Taakplanner is niet hetzelfde als de opdracht at, maar u kunt ze wel naast elkaar gebruiken. Als u een taak plant met de opdracht at, wordt de taak opgenomen in de takenlijst van Taakplanner.

Met Taakplanner kunt u de eigenschappen wijzigen van een taak die u met de opdracht at hebt gepland. Daarna kunt u voor deze taak echter alleen nog Taakplanner gebruiken. De opdracht at is niet langer beschikbaar voor deze taak.

Als u de gebruikersaccount wilt opgeven waarmee taken moeten worden uitgevoerd die met de opdracht at zijn gepland, klikt u op Geplande taken in Deze computer en klikt u vervolgens op AT-serviceaccount in het menu Geavanceerd.

Opmerking

  • De AT-service is alleen beschikbaar onder Windows NT.


Taakplanner en beveiliging

In Taakplanner kunt u beveiliging instellen door een gebruikersnaam en een wachtwoord aan een bepaalde taak toe te wijzen. De taak kan dan niet door een andere gebruiker worden beëindigd of verwijderd.

Opmerkingen

  • Deze beveiligingsfunctie is alleen beschikbaar onder Windows NT.
  • U moet een gebruikersnaam opgeven in de wizard Nieuwe taak plannen voordat u een taak kunt plannen. Wachtwoorden zijn niet vereist.
  • Als u een wachtwoord wilt instellen of wijzigen, schakelt u in het laatste scherm van de wizard het selectievakje Geavanceerde eigenschappen voor deze taak openen wanneer ik op Voltooien klik in.


Probleemoplossing

Als de geplande taak niet op het verwachte tijdstip wordt uitgevoerd, klikt u met de rechtermuisknop op de taak en klikt u vervolgens op Eigenschappen. Controleer op het tabblad Taak of het selectievakje Ingeschakeld is ingeschakeld. Controleer op het tabblad Schema of de planning klopt.

Als een taakprogramma niet goed wordt uitgevoerd, moet u misschien parameters voor het programma opgeven. Als u meer wilt weten over een programma en de bijbehorende parameters, voert u een van de volgende handelingen uit:

  • Als het programma over on line Help beschikt, raadpleegt u deze Help.

  • Typ het volgende achter de MS-DOS-prompt, waarbij programma de naam van het programma is.

    • programma /?


Component van Windows NT niet geïnstalleerd

Dit programma kan niet worden uitgevoerd.

Mogelijke oorzaken:

    • Het programma is door een systeembeheerder verwijderd.
    • De systeembeheerder heeft de toegangsrechten voor het bestand gewijzigd.
    • Het programma is niet op uw computer geïnstalleerd.
    • Het programma is per ongeluk verwijderd.
    • Het bestand is beschadigd.

Als uw computer wordt beheerd door een systeembeheerder, vraagt u deze waarom het programma niet kan worden uitgevoerd.