
Microsoft System Info

Microsoft System Info is a basic tool for gathering system configuration information.    It is intended 
primarily to help Product Support Services (PSS) engineers determine information that could indicate 
problems with your system.



File menu commands

The File menu offers the following commands:

Save Saves a listing with the information for each 
category.

Print Prints a listing with the information for each 
category.

Run Invokes a dialog for specifying an application to 
run.

Exit Exits Microsoft System Info.



Edit menu commands

The Edit menu offers the following commands:

Copy Copies data from the list view to the clipboard.
Select All Selects all of the items in the list.



View menu commands

The View menu offers the following commands:

Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.
Refresh Refreshes the list of items for the current 

category.
Always on Top Toggles the option to keep MSInfo the 

topmost window.

Help menu commands

The Help menu offers the following commands, which provide you assistance with this application: 

Help Topics Offers you an index to topics on which you 
can get help.

About Displays the copyright and version 
information for Microsoft System Info.



Save command (File menu)

Use this command to save a listing of all the information for the categories.



Run command (File menu)

Use this command to start another application.    This will invoke a dialog displaying a list of common 
utilities to choose from.    You can also type in the file specification or browse for the application using the 
standard file-open dialog.



Exit command (File menu)

Use this command to quit this application.    You can also use the Close command on the application 
Control menu. 



Copy command (Edit menu)

Use this command to copy selected data onto the clipboard.    This command is unavailable if there is no 
data currently selected.

Copying data to the clipboard replaces the contents previously stored there.



Toolbar command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the most common 
commands, such as File Save.    A check mark appears next to the menu item when the Toolbar is 
displayed.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The toolbar 
provides quick mouse access to many tools used in Microsoft System Info.

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).



Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be executed by the 
selected menu item or depressed toolbar button.    A check mark appears next to the menu item when the 
Status Bar is displayed.



Status Bar

The status bar is displayed at the bottom of the main window.    To display or hide the status bar, use the 
Status Bar command in the View menu.

This area describes actions of menu items as you use the arrow keys to navigate through menus.    This 
area similarly shows messages that describe the actions of toolbar buttons as you depress them, before 
releasing them.    If after viewing the description of the toolbar button command you wish not to execute 
the command, then release the mouse button while the pointer is off the toolbar button.



Help Topics command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can jump to 
step-by-step instructions for using Microsoft System Info and various types of reference information.    

Once you open Help, you can click the Contents button whenever you want to return to the opening 
screen.



About command (Help menu)

Use this command to display the copyright notice and version number of your copy of Microsoft System 
Info.



Context Help command 

Use the Context Help command to obtain help on some portion of Microsoft System Info.    When you 
choose the Toolbar's Context Help button, the mouse pointer will change to an arrow and question mark.   
Then click somewhere in the application window, such as another Toolbar button.    The Help topic will be 
shown for the item you clicked.



No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.



Print command (File menu)

Use this command to print a listing of all the information for the categories.

Note: If your system is configured for VoiceView modem support, you will have the option of sending the 
information over the modem.



Select All command (Edit menu)

Use this command to select all of the items displayed in the list view.



Refresh command (View menu)

Use this command to refresh the list of items for the current category.    For instance, if the System 
category is shown, this command can be used to update some of the statistics shown, such as available 
memory.



Always on Top command (View menu)

Use this command to force Microsoft System Info’s window frame to always remain visible, even if 
another application’s window has the input focus.



System Info

Generates a report of data about your computer.    This information is useful when attempting to 
troubleshoot system problems.

To view information on a specific category, highlight the category in the left pane.    You can sort a column 
by clicking on the column's heading.

You can copy the data from selected rows in the right pane.    Click in the first column of the row(s) you 
want to copy and choose Edit, Copy (or ctrl-C).    The data is tab delimited, so you can easily paste it into 
Excel worksheets.



System

Lists information about your computer's hardware. 



Items for System Category

Operating System:    The software controlling file and disk access on your computer.

Windows version:  The currently active Windows version number.

Processor:    The type of CPU (central processing unit).

Total physical memory:    The total amount of installed RAM (random access memory).

Available physical memory:    The amount of free physical RAM in kilobytes.

USER memory available:    The percent of free resources in the Windows User component.

GDI memory available:    The percent of free resources in the Windows Graphic Design Interface (GDI).

Swap file size:    The size of the system file used to implement virtual memory. 

Swap file usage:    The percentage of the Windows swap file that is in use.

Swap file setting:    The swap file configuration (e.g, dynamic vs. fixed limit).

Available space on drive <x:>:  The free disk space (in kilobytes) on a specific drive.
. . .

Windows directory:    The fully qualified path to the main Windows directory.

TEMP directory:    The fully qualified path to the system’s temporary directory.



Virtual Memory

A memory management technique to allow more programs to be active at the same time.    Since physical
memory is expensive, disk space is used to extend the amount of logical memory that programs can 
access.    When a new program is run, infrequently used components or data of other programs can be 
moved out of physical memory to a special swap file on disk.



Kilobyte (KB)

A measurement of memory or disk space.    1 kilobyte (KB) equals 1024 bytes or characters.



Printing

Displays information about installed printer drivers.



Items for Printing Category

Default printer:    Currently active printer.

Using print manager spooling?:    Indicates if the printer output is buffered through the printer manager 
instead of directly going to the printer port.

Unidriver (UNIDRV.DLL):    File information for universal printer driver.

Gen drv (GENDRV.DLL):    File information for generic library driver.

<specific printer>:    Name and file information for each printer that has been installed.
. . . 



System DLL’s

Lists the filename, version number, date stamp, file size, and build number of each DLL in the Windows’ 
system directory (e.g., c:\windows\system) and determines whether it's loaded in memory. 



Items for System DLL’s category

Each item represents a Dynamic Link Library file in the windows system directory (typically, c:\windows\
system or c:\winnt\system32).    The columns displayed are as follows:

Files:    The DLL’s filename.

Version:    The numeric version code (e.g., 4.0.0.500).
Often given as <major>.<minor>.<revision>.<build>. 

Date:    The date that the DLL was produced (“build” date).

Size:    Size of the file in bytes.

Loaded:    Indicates if the DLL is active (loaded in memory).

Build No.:    Version code including build identification.



Font

Shows information about your system's font engine. 



Font Substitutions

Displays the font substitutions for common fonts that are not installed.



Font Managers

Lists the current application that controls font size, format, design, and layout.



Proofing

Displays information about your thesaurus, spelling, and grammar checkers.



Registry Settings

Displays proofing tool information found in the Windows registry.



INI Settings

Displays proofing tool information found in the Win.ini file.



File Info

Lists the filename, version number, file date, file size, build number, and fully qualified path of each file 
associated with your proofing tools.    This category also determines whether the file is currently loaded in 
memory.



Graphic Filters

Lists data about your graphic import and export capability.



Registry Settings

Displays graphic filter information found in the Windows registry.



INI Settings

Displays graphic filter information found in the Win.ini file.



File Info

Lists the filename, version number, file date, file size, build number, and fully qualified path of each file 
associated with your graphic filters.    This category also determines whether the file is currently loaded in 
memory.



Text Converters

Lists data about your text import and export capability.



Registry Settings

Displays text converter information found in the Windows registry.



INI Settings

Displays text converter information found in the Win.ini file.



File Info

Lists the filename, version number, file date, file size, build number, and fully qualified path of each file 
associated with your text converters.    This category also determines whether the file is currently loaded 
in memory.



Display

Shows the file name, version date, and size of the current video driver.



Items for Display Category

<Optional Driver Description>

<Driver Filename>:  version, date, and size in bytes.



Applications Running

Displays the Module name, Process ID number, and bitness of all active programs (EXE or COM files).



Items for Applications Running Category

Each item represents a Windows application that is active.    The columns displayed are as follows:

Module Name:    The application’s filename including its directory path.

Process ID:    The identifier that the operating system uses for the application

16-bit:    Usually indicates if the application was designed for previous versions of Windows.
Note: some new utilities are 16-bit for compatibility reasons.



OLE Registration

Lists all the OLE server entries in the Windows registry and Win.ini file.



Registry Settings

Lists all the OLE server entries from the registry.



INI Settings

Lists all the OLE server entries from the Win.ini file.



Active Modules

Displays the Module Name, version number, file date, file size, bitness, and fully qualified path to all 
modules (drivers, fonts, dynamic link libraries, and executable files) in memory.



Items for Active Modules category

Each item represents an application extension or a system resource that is currently loaded in memory.    
The columns displayed are as follows:

Module Name:    The module’s filename.

Version:    The numeric version code (e.g., 3.51.0.1057).
Often given as <major>.<minor>.<revision>.<build>.

Date:    The date that the DLL was produced (“build” date).

Size:    Size of the file in bytes.

16-bit:    Usually indicates if the module was designed for previous versions of Windows.
Note: some new module are 16-bit for compatibility reasons.

Path:    The filename including the full specification of its location.



Custom DLL’s

Lists the filename, version number, date stamp, file size, and build number of each DLL in a user-
specified directory and determines whether it's loaded in memory.    This category is activated by the /C 
command-line option, for example “msinfo32 /c [My DLL’s] c:\mydir”.



How to Copy Data

Activate the right pane, click in the first column of the row(s) you want to copy and choose Edit, Copy (or 
ctrl-C).



How to Sort data

Activate the right pane and click on the column heading you want to sort.    A second click toggles the sort 
order.



How to Save a report

Choose File, Save (or ctrl-S).



How to Print a report

Choose File, Print (or ctrl-P).



How to Show available space on Network Drives

Select the System category while holding the shift key down.    If you are already in this category, select 
the refresh command while holding the shift key down.

To enable the display of network drives throughout the session, invoke Microsoft System Info with the /N 
command-line switch: “MSInfo32 /n”.

Note:    Network drive space is not shown by default to avoid network delays.




