Fejl i Microsoft Jet og dataadgangsfejl, der kan opfanges.

Fejl, der kan opfanges fra Microsoft® Jet-databasemotoren, kan opstå, mens et program kører, enten i udviklingsmiljøet eller som enkeltstående eksekverbar fil. Du kan undersøge og svare på fejl, der kan opfanges ved hjælp af objektet Error.

Kode Meddelelse

2420 Der er en syntaksfejl i tallet.

2421 Der er en syntaksfejl i datoen.

2422 Der er en syntaksfejl i strengen.

2423 Der er gjort ugyldig brug af '.', '!' eller '()'.

2424 Navnet er ukendt.

2425 Funktionsnavn er ukendt.

2426 Funktionen er ikke tilgængelig i udtrykkene

2427 Objektet har ingen værdi.

2428 Der er brugt ugyldige argumenter i domænefunktionen.

2429 Operatoren In er brugt uden ().

2430 Between-operatoren er brugt uden And.

2431 Der er en syntaksfejl, fordi der mangler en operator.

2432 Der er en syntaksfejl, fordi der mangler et komma.

2433 Der er en syntaksfejl.

2434 Der er en syntaksfejl, fordi der mangler en operator.

2435 Der er en ekstra højreparentes:).

2436 Der mangler en ), ] eller et element.

2437 Der er gjort ugyldig brug af lodrette streger.

2438 Der er en syntaksfejl.

2439 Antallet af argumenter til funktionen er forkert.

2440 Funktionen IIF er brugt uden ().

2442 Der er gjort ugyldig brug af parenteser.

2443 Is-operatoren er ugyldig.

2445 Udtrykket er for komplekst.

2446 Der er ikke mere hukommelse til at fuldføre beregningen.

2447 Der er gjort ugyldig brug af '.', '!' eller '()'.

2448 Værdien kan ikke indstilles.

3000 Reserveret fejl <element>. Der er ingen meddelelse til denne fejl.

3001 Argumentet er ugyldigt.

3002 Sessionen kunne ikke startes.

3003 Transaktionen kunne ikke startes. For mange transaktioner er allerede indlejret.

3005 <Databasenavn> er ikke et gyldigt databasenavn.

3006 Databasen <navn> er låst med udelt adgang.

3007 Biblioteksdatabasen <navn> kan ikke åbnes.

3008 Tabellen <navn> er allerede åbnet med udelt adgang af en anden bruger, eller den er allerede åbnet i en anden brugerflade og kan ikke manipuleres ved hjælp af programkode.

3009 Du har forsøgt at låse tabellen <tabel> under åbning, men tabellen kan ikke låses, fordi den i øjeblikket er i brug. Vent et øjeblik, og forsøg derefter at udføre handlingen igen.

3010 Tabellen <navn> findes allerede.

3011 Microsoft Jet-databasemotoren kan ikke finde objektet <navn>. Kontroller, at objektet findes, og at du har stavet navnet og stien korrekt.

3012 Objektet <navn> findes allerede.

3013 Den installerbare ISAM-fil kunne ikke omdøbes.

3014 Der kan ikke åbnes flere tabeller.

3015 Indeksfilen blev ikke fundet.

3016 Feltet passer ikke til posten.

3017 Størrelsen af et felt er for stor.

3018 Feltet kunne ikke findes.

3019 Handlingen er ugyldig uden et aktuelt indeks.

3020 Update eller CancelUpdate uden AddNew eller Edit.

3021 Der er ingen aktuel post.

3022 De ønskede ændringer til tabellen blev ikke gennemført, fordi de vil oprette dublerede værdier i indekset, den primære nøgle eller relationen. Rediger dataene i det eller de felter, der indeholder dublerede data, fjern indekset, eller omdefiner indekset, så dublerede indtastninger tillades, og forsøg igen.

3023 Metoden AddNew eller Edit er allerede brugt.

3024 Det er ikke finde filen <navn>.

3025 Der kan ikke åbnes flere filer.

3026 Der er ikke tilstrækkelig plads på disken.

3027 Det er ikke muligt at opdatere. Databasen eller objektet er skrivebeskyttet.

3028 Programmet kan ikke startes. Arbejdsgruppeoplysningsfilen mangler eller er åbnet med udelt adgang af en anden bruger.

3029 Det er ikke et gyldigt kontonavn eller en gyldig adgangskode.

3030 <Databasenavn> er ikke et gyldigt databasenavn.

3031 Det er ikke en gyldig adgangskode.

3032 Denne handling kan ikke udføres.

3033 Du har ikke de nødvendige tilladelser til at bruge objektet <navn>. Få systemadministratoren eller den person, der oprettede dette objekt, til at give dig de nødvendige tilladelser.

3034 Du forsøgte at bekræfte eller annullere en transaktion uden først at starte en transaktion.

3036 Databasen har nået den maksimale størrelse.

3037 Der kan ikke åbnes flere tabeller eller forespørgsler.

3039 Indekset kunne ikke oprettes. Der er allerede defineret for mange indeks.

3040 Der opstod en disk I/O-fejl under læsning.

3041 En database, der er oprettet i en tidligere version af programmet, kan ikke åbnes.

3042 Der er ikke flere MS-DOS-filhandles.

3043 Der opstod en disk- eller netværksfejl.

3044 <Sti> er ikke en gyldig sti. Kontroller, at stinavnet er stavet korrekt, og at du er tilsluttet den server, hvor filen findes.

3045 Filen <navn> kunne ikke bruges, fordi den allerede er i brug.

3046 Posten kan ikke læses, fordi den er låst af en anden bruger.

3047 Posten er for stor.

3048 Der kan ikke åbnes flere databaser.

3049 Biblioteksdatabasen <navn> kan ikke åbnes. Det er måske ikke en database, som programmet genkender, eller filen kan være beskadiget.

3050 Filen kunne ikke låses.

3051 Microsoft Jet-databasemotoren kan ikke åbne filen <navn>. Den er allerede åbnet med udelt adgang af en anden bruger, eller du skal have tilladelse til at vise dataene.

3052 Antallet af MS-DOS-fildelingslåse er overskredet. Forøg registreringsnøglen MaxLocksPerFile.

3053 Der er for mange klientopgaver.

3054 Der er for mange felter af typen Memo, OLE Object eller Hyperlink Object.

3055 Det er ikke et gyldigt filnavn.

3056 Denne database kunne ikke repareres.

3057 Handlingen understøttes ikke i sammenkædede tabeller.

3058 Et indeks eller en primær nøgle kan ikke indeholde en Null-værdi.

3059 Handlingen blev annulleret af brugeren.

3060 Det er en forkert datatype til parameteren <parameter>.

3061 Der er for få parametre. Der var ventet <tal>.

3062 Outputaliaset <navn> er dubleret.

3063 Outputdestinationen <navn> er dubleret.

3064 Handlingsforespørgslen <navn> kan ikke åbnes.

3065 En udvælgelsesforespørgsel kan ikke udføres.

3066 Forespørgslen skal have mindst ét destinationsfelt.

3067 Forespørgselsinputtet skal indeholde mindst én tabel eller forespørgsel.

3068 Det er ikke et gyldigt aliasnavn.

3069 Handlingsforespørgslen <navn> kan ikke bruges som rækkekilde.

3070 Microsoft Jet-databasemotoren genkender ikke <navn> som et gyldigt feltnavn eller udtryk.

3071 Dette udtryk er stavet forkert, eller det er for komplekst til at blive evalueret. Et numerisk udtryk kan f.eks. indeholde for mange komplicerede elementer. Prøv at forenkle udtrykket ved at tildele variabler til dele af udtrykket.

3072 Der var en typeuoverensstemmelse under oprettelse af en tabelvalideringsregel, eller der var en CHECK-konstant i en kolonne.

3073 Handlingen skal bruge en opdaterbar forespørgsel.

3074 Tabelnavnet <navn> kan ikke gentages i FROM-delsætningen.

3075 <Meddelelse> i forespørgselsudtrykket <udtryk>.

3076 <Navn> i et kriterieudtryk.

3077 <Meddelelse> i et udtryk.

3078 Microsoft Jet-databasemotoren kan ikke finde inputtabellen eller forespørgslen <navn>. Kontroller, at den findes, og at navnet er stavet korrekt.

3079 Det angivne felt <felt> kan referere til mere end en tabel, der er vist i FROM-delsætningen i SQL-sætningen.

3080 Den joinforbundne tabel <navn> er ikke medtaget i FROM-delsætningen.

3081 Der kan ikke joinforbindes mere end en tabel med samme navn <navn>.

3082 JOIN-handlingen <handling> refererer til et felt, der ikke er i en af de joinforbundne tabeller.

3083 En intern rapportforespørgsel kan ikke bruges.

3084 Data kan ikke indsættes med en handlingsforespørgsel.

3085 Der er en ikke-defineret funktion <navn> i udtrykket.

3086 Der kunne ikke slettes fra de angivne tabeller.

3087 Der er for mange udtryk i GROUP BY-delsætningen.

3088 Der er for mange udtryk i ORDER BY-delsætningen.

3089 Der er for mange udtryk i DISTINCT-outputtet.

3090 Det er ikke tilladt for den fremkomne tabel at have mere end ét felt af typen AutoNumber.

3091 Der er en HAVING-delsætning <navn> uden gruppering eller aggregering.

3092 En HAVING-delsætning kan ikke bruges i en TRANSFORM-sætning.

3093 ORDER BY-delsætningen <delsætning> er i konflikt med DISTINCT.

3094 ORDER BY-delsætningen <delsætning> er i konflikt med GROUP BY-delsætningen.

3095 En aggregatfunktion kan ikke bruges i udtrykket <udtryk>.

3096 En aggregatfunktion kan ikke bruges i WHERE-delsætningen <delsætning>.

3097 En aggregatfunktion kan ikke bruges i ORDER BY-delsætningen <delsætning>.

3098 En aggregatfunktion kan ikke bruges i GROUP BY-delsætningen <delsætning>.

3099 En aggregatfunktion kan ikke bruges i JOIN-handlingen <handling>.

3100 Feltet <navn> kan ikke angives i en joinnøgle til Null.

3101 Microsoft Jet-databasemotoren kan ikke finde en post i tabellen <navn>, hvor nøglen svarer til feltet/felterne <navn>.

3102 En cirkulær reference blev forårsaget af <forespørgselsreference>.

3103 En cirkulær reference blev forårsaget af aliaset <navn> på forespørgselsdefinitionens SELECT-liste.

3104 Den faste kolonneoverskrift <værdi> kan ikke angives i en krydstabuleringsforespørgsel mere end én gang.

3105 Der mangler et destinationsfeltnavn i SELECT INTO-sætningen <sætning>.

3106 Der mangler et destinationsfeltnavn i UPDATE-sætningen <sætning>.

3107 Der kan ikke tilføjes poster, fordi der ikke er tilladelse til at indsætte i <navn>.

3108 Der kan ikke rediges poster, fordi der ikke er tilladelse til at opdatere i <navn>.

3109 Der kan ikke slettes poster, fordi der ikke er tilladelse til at slette i <navn>.

3110 Definitioner kan ikke læses, fordi der ikke er tilladelse til at læse definitioner i tabellen eller forespørgslen <navn>.

3111 Der kunne ikke oprettes, fordi der ikke er tilladelse til at redigere design i tabellen eller forespørgslen <navn>.

3112 Poster kan ikke læses, fordi der ikke er tilladelse til at læse i <navn>.

3113 <Feltnavn> kan ikke opdateres, fordi feltet ikke er opdaterbart.

3114 Der kan ikke medtages et felt af typen Memo, OLE eller Hyperlink Object, når du markerer unikke værdier <sætning>.

3115 Der kan ikke være felter af typen Memo, OLE eller Hyperlink Object i aggregatargumentet <sætning>.

3116 Der kan ikke være et felt af typen Memo, OLE eller Hyperlink Object i kriteriet <kriterium> for en aggregatfunktion.

3117 Der kan ikke sorteres på Memo, OLE eller Hyperlink Object <delsætning>.

3118 Der kan ikke sorteres på Memo, OLE eller Hyperlink Object <navn>.

3119 Der kan ikke sorteres på Memo, OLE eller Hyperlink Object <delsætning>.

3120 Der kan ikke grupperes efter felter, der er markeret med '*' <tabelnavn>.

3121 Der kan ikke grupperes efter felter, der er markeret med '*'.

3122 Du har forsøgt at køre en forespørsel, der ikke medtager det angivne udtryk <navn> som en del af en aggregatfunktion.

3123 '*' kan ikke bruges i en krydstabuleringsforespørgsel.

3124 Input kan ikke modtages fra den interne rapportforespørgsel <navn>.

3125 <Navn> er ikke er gyldigt navn. Sørg for, at det ikke indeholder ugyldige tegn eller tegnsætning, og at navnet ikke er for langt.

3126 Der er brugt ugyldige kantede parenteser omkring navnet <navn>.

3127 INSERT INTO-sætningen indeholder følgende ukendte feltnavn: <feltnavn>. Kontroller, at du har skrevet navnet korrekt, og forsøg derefter at udføre handlingen igen.

3128 Du skal angive den tabel, der indeholder de poster, du vil slette.

3129 Det er en ugyldig SQL-sætning. 'DELETE', 'INSERT', 'PROCEDURE', 'SELECT' eller 'UPDATE' var ventet.

3130 Der er en syntaksfejl i DELETE-sætningen.

3131 Der er en syntaksfejl i FROM-delsætningen.

3132 Der er en syntaksfejl i GROUP BY-delsætningen.

3133 Der er en syntaksfejl i HAVING-delsætningen.

3134 Der er en syntaksfejl i INSERT INTO-sætningen.

3135 Der er en syntaksfejl i JOIN-handlingen.

3136 LEVEL-sætningen indeholder et reserveret ord eller et argument, der er stavet forkert eller mangler, eller tegnsætningen er ikke korrekt.

3137 Der mangler et semikolon (;) i slutningen af SQL-sætningen.

3138 Der er en syntaksfejl i ORDER BY-delsætningen.

3139 Der er en syntaksfejl i PARAMETER-delsætningen.

3140 Der er en syntaksfejl i PROCEDURE-delsætningen.

3141 SELECT-sætningen indeholder et reserveret ord eller argument, der er stavet forkert eller mangler, eller tegnsætningen er ikke korrekt.

3142 Der blev fundet tegn efter slutningen af SQL-sætningen.

3143 Der er en syntaksfejl i TRANSFORM-sætningen.

3144 Der er en syntaksfejl i UPDATE-sætningen.

3145 Der er en syntaksfejl i WHERE-delsætningen.

3146 ODBC: Kaldet lykkedes ikke.

3151 ODBC: Tilslutningen til <navn> lykkedes ikke.

3154 ODBC: DLL'en <navn> blev ikke fundet.

3155 ODBC: Indsættelse lykkedes ikke i den sammenkædede tabel <tabel>.

3156 ODBC: Sletningen lykkedes ikke i den sammenkædede tabel <tabel>.

3157 ODBC: Opdateringen lykkedes ikke i den sammenkædede tabel <tabel>.

3158 Posten kan ikke gemmes, fordi den er låst af en anden bruger.

3159 Det er ikke et gyldigt bogmærke.

3160 Tabellen er ikke åben.

3161 Filen kunne ikke dekrypteres.

3162 Du har forsøgt at tildele Null-værdien til en variabel, der ikke er af datatypen Variant.

3163 Feltet er for kort til den mængde data, du forsøger at tilføje. Prøv at indsætte færre data.

3164 Feltet kan ikke opdateres.

3165 .inf-filen kunne ikke åbnes.

3166 Den ønskede Xbase memo-fil kan findes.

3167 Posten er slettet.

3168 .inf-filen er ugyldig.

3169 Microsoft Jet-databasemotoren kan ikke udføre SQL-sætningen, da den indeholder et felt med en ugyldig datatype.

3170 Den installerbare ISAM blev ikke fundet.

3171 Netværksstien eller brugernavnet blev ikke fundet.

3172 Paradox.net kunne ikke åbnes.

3173 Tabellen 'MSysAccounts' i arbejdsgruppeoplysningsfilen kan ikke åbnes.

3174 Tabellen 'MSysGroups' i arbejdsgruppeoplysningsfilen kan ikke åbnes.

3175 Datoen er uden for området eller har et ugyldigt format.

3176 Filen <navn> kunne ikke åbnes.

3177 Det er ikke et gyldigt tabelnavn.

3179 Fandt en uventet slutning på fil.

3180 Der kunne ikke skrives til filen <navn>.

3181 Området er ugyldigt.

3182 Filformatet er ugyldigt.

3183 Der er ikke tilstrækkelig plads på den midlertidige disk.

3184 Forespørgslen kunne ikke køres. Den sammenkædede tabel blev ikke fundet.

3185 Sætningen SELECT INTO i en fjerndatabase prøvede at frembringe for mange felter.

3186 Der kan ikke gemmes, fordi den er låst af brugeren <navn> på maskinen <navn>.

3187 Der kan ikke gemmes, fordi den er låst af brugeren <navn> på maskinen <navn>.

3188 Der kan ikke opdateres, fordi den er låst af en anden session på denne maskine.

3189 Tabellen <navn> er låst med udelt adgang af brugeren <navn> på maskinen <navn>.

3190 Der er defineret for mange felter.

3191 Feltet kan ikke defineres mere end en gang.

3192 Outputtabellen <navn> blev ikke fundet.

3196 Databasen <databasenavn> bruges allerede af en anden person eller proces. Når databasen er tilgængelig, kan du forsøge at udføre handlingen igen.

3197 Microsoft Jet-databasemotoren har standset processen, fordi du og en anden bruger forsøger at ændre de samme data samtidigt.

3198 Sessionen kunne ikke startes. Der er allerede for mange aktive sessioner.

3199 Referencen blev ikke fundet.

3200 Posten kan ikke slettes eller ændres, fordi tabellen <navn> indeholder relaterede poster.

3201 Du kan ikke tilføje eller ændre en post, fordi der kræves en relateret post i tabellen <navn>.

3202 Der kunne ikke gemmes, fordi den er låst af en anden bruger.

3203 Underforespørgsler kan ikke bruges i udtrykket <udtryk>.

3204 Databasen findes allerede.

3205 Der er for mange krydstabuleringskolonneoverskrifter <værdi>.

3206 En relation kan ikke oprettes mellem et felt og feltet selv.

3207 Handlingen understøttes ikke i en Paradox-tabel, der ikke har en primær nøgle.

3208 Der er en ugyldig Deleted-indstilling i Xbase-nøglen i Windows-registreringsdatabasen.

3210 Tilslutningsstrengen er for lang.

3211 Databasemotoren kunne ikke låse tabellen <navn>, fordi den allerede er låst af en anden person eller proces.

3212 Tabellen <navn> kan ikke låses, fordi den anvendes af brugeren <navn> på maskinen <navn>.

3213 Der er en ugyldig Date-indstilling i Xbase-nøglen i Windows-registreringsdatabasen.

3214 Der er en ugyldig Mark-indstilling i Xbase-nøglen i Windows-registreringsdatabasen.

3216 Parameteren <navn> er angivet, hvor der kræves et tabelnavn.

3217 Parameteren <navn> er angivet, hvor der kræves et databasenavn.

3218 Der kunne ikke opdateres, fordi siden er låst.

3219 Handlingen er ugyldig.

3220 Det er en forkert sorteringsrækkefølge.

3222 Forespørgslen kan ikke indeholde en Database-parameter.

3223 <Parameternavn> er ugyldigt, fordi det er for langt eller indeholder ugyldige tegn.

3227 Der er en ugyldig Century-indstilling i Xbase-nøglen i Windows-registreringsdatabasen.

3228 Den valgte CollatingSequence-indstilling understøttes ikke af operativsystemet.

3230 Paradox-låsefilen er forældet.

3231 ODBC: Dataene er blevet afkortet, fordi feltet ville blive for langt.

3232 ODBC: Tabellen kunne ikke oprettes.

3234 ODBC: Timeout for fjernforespørgslen er udløbet.

3235 ODBC: Datatypen understøttes ikke på serveren.

3238 ODBC: Dataene er uden for området.

3239 Der er for mange aktive brugere.

3242 Der er en ugyldig reference i SELECT-sætningen.

3243 Ingen af importfeltnavnene passer til felterne i den tilføjede tabel.

3244 Regneark, der er beskyttet med adgangskode, kan ikke importeres.

3245 Feltnavnene fra den første række i importtabellen kan ikke opdeles.

3246 Handlingen understøttes ikke i transaktioner.

3247 ODBC: Definitionen på den sammenkædede tabel er blevet ændret.

3248 Der er en ugyldig NetworkAccess-indstilling i Windows-registreringsdatabasen.

3249 Der er en ugyldig PageTimeout-indstilling i Windows-registreringsdatabasen.

3250 Der kunne ikke genereres en nøgle.

3251 Handlingen understøttes ikke for denne objekttype.

3252 Det er ikke muligt at åbne en formular, hvis underliggende forespørgsel indeholder en brugerdefineret funktion, der prøver på at angive eller hente formularens RecordsetClone-egenskab.

3254 ODBC: Ikke alle posterne kan låses.

3256 Indeksfilen blev ikke fundet.

3257 Der er en syntaksfejl i WITH OWNERACCESS OPTION-erklæringen.

3258 SQL-sætningen kan ikke udføres, fordi den indeholder tvetydige ydre joinforbindelser. Du kan gennemtvinge, at en af joinforbindelserne bliver udført først ved at oprette en separat forespørgsel, der udfører den første joinforbindelse, og derefter medtage forespørgslen i SQL-sætningen.

3259 Feltdatatypen er ugyldig.

3260 Der kan ikke opdateres, fordi den er låst af brugeren <navn> på maskinen <navn>.

3261 Tabellen <navn> er låst med udelt adgang af brugeren <navn> på maskinen <navn>.

3262 Filen kunne ikke låses.

3263 Databaseobjektet er ugyldigt.

3264 TableDef eller Index kan ikke tilføjes, fordi der ikke er defineret nogen felter.

3265 Elementet blev ikke fundet i denne samling.

3266 Et Field-objekt, der allerede er en del af en Fields-samling, kan ikke tilføjes.

3267 Egenskaben kan kun angives, når feltet er en del af et Recordset-objekts Fields-samling.

3268 Denne egenskab kan ikke angives, når først objektet er en del af en samling.

3269 Et Index-objekt, der allerede er en del af en Indexes-samling, kan ikke tilføjes.

3270 Egenskaben blev ikke fundet.

3271 Egenskabsværdien er ugyldig.

3272 Objektet er ikke en samling.

3273 Metoden kan ikke anvendes på dette objekt.

3274 En ekstern tabel er ikke i det ventede format.

3275 Der opstod en uventet fejl i den eksterne databasedriver <fejlnummer>.

3276 Databaseobjektreferencen er ugyldig.

3277 Et indeks kan ikke have mere end ti felter.

3278 Microsoft Jet-databasemotoren er ikke blevet initialiseret.

3279 Microsoft Jet-databasemotoren er allerede blevet initialiseret.

3280 Et felt, der indgår i et indeks eller er krævet af systemet, kan ikke slettes.

3281 Dette indeks eller denne tabel kan ikke slettes. Det er enten det aktuelle indeks, eller det bruges i en relation.

3282 Handlingen understøttes ikke i en tabel, der indeholder data.

3283 Den primære nøgle findes allerede.

3284 Indekset findes allerede.

3285 Indeksdefinitionen er ugyldig.

3286 Formatet af memo-filen stemmer ikke overens med det angivne eksterne databaseformat.

3287 Et indeks kan ikke oprettes i det givne felt.

3288 Paradox-indekset er ikke det primære.

3289 Der er en syntaksfejl i CONSTRAINT-delsætningen.

3290 Der er en syntaksfejl i CREATE TABLE-sætningen.

3291 Der er en syntaksfejl i CREATE INDEX-sætningen.

3292 Der er en syntaksfejl i feltdefinitionen.

3293 Der er en syntaksfejl i ALTER TABLE-sætningen.

3294 Der er en syntaksfejl i DROP INDEX-sætningen.

3295 Der er en syntaksfejl i DROP TABLE- eller DROP INDEX-sætningen.

3296 Joinudtrykket understøttes ikke.

3297 Tabellen eller forespørgslen kunne ikke importeres. Der blev ikke fundet poster, eller alle posterne indeholder fejl.

3298 Der er flere tabeller med det navn. Du skal angive ejeren med formatet 'ejer.tabel'.

3299 ODBC Specification Conformance-fejl <meddelelse>. Du skal rapportere denne fejl til udvikleren af programmet.

3300 Relationen kan ikke oprettes.

3301 Denne handling kan ikke udføres, fordi funktioner i denne version ikke er tilgængelige i databaser, der har et ældre format.

3302 En regel kan ikke ændres, så længe reglerne for denne tabel er i brug.

3303 Dette felt kan ikke slettes. Det er en del af en eller flere relationer.

3304 Du skal indtaste et personligt id (PID), der består af mindst fire og højst 20 tegn og cifre.

3305 Tilslutningsstrengen i videregivelsesforespørgslen er ugyldig.

3306 Du har skrevet en underforespørgsel, der kan returnere mere end et felt uden at bruge det reserverede ord EXISTS i hovedforespørgslens FROM-delsætning. Du kan redigere sætningen SELECT i underforespørgslen for kun at anmode om én post.

3307 Antallet af kolonner i de to markerede tabeller eller forespørgsler i en foreningsforespørgsel stemmer ikke overens.

3308 Argumentet TOP i en udvælgelsesforespørgsel er ugyldigt.

3309 Egenskabsværdien er for stor.

3310 Denne egenskab understøttes ikke i forbindelse med eksterne datakilder eller databaser, der er oprettet med en tidligere version af Microsoft Jet.

3311 Den angivne egenskab findes allerede.

3312 Valideringsregler og standardværdier kan ikke bruges på systemtabeller eller sammenkædede tabeller.

3313 Valideringsudtrykket kan ikke bruges på dette felt.

3314 Feltet <navn> kan ikke indeholde en Null-værdi, fordi egenskaben Required til dette felt er angivet til True. Indtast en værdi i dette felt.

3315 Feltet <navn> kan ikke indeholde en streng af længden nul.

3316 <Valideringsmeddelelse på tabelniveau>.

3317 En eller flere indtastede værdier tillades ikke af valideringsreglen <regel>, der er angivet for <navn>. Skriv en værdi, som udtrykket for dette felt kan acceptere.

3318 Værdier, der er angivet i en Top-delsætning, er ikke tilladt i sletteforespørgsler eller rapporter.

3319 Der er en syntaksfejl i foreningsforespørgslen.

3320 <Fejl> i et valideringsudtryk på tabelniveau.

3321 Der er ikke angivet en database i tilslutningsstrengen eller IN-delsætningen.

3322 Krydstabuleringsforespørgslen indeholder en eller flere ugyldige faste kolonneoverskrifter.

3323 Forespørgslen kan ikke bruges som rækkekilde.

3324 Denne forespørgsel er en DDL-forespørgsel og kan ikke bruges som rækkekilde.

3325 En videregivelsesforespørgsel med egenskaben ReturnsRecords angivet til True returnerede ingen poster.

3326 Dette resultatsæt kan ikke opdateres.

3327 Feltet <navn> er baseret på et udtryk og kan ikke redigeres.

3328 Tabellen <navn> er skrivebeskyttet.

3329 Post i tabellen <navn> blev slettet af en anden bruger.

3330 Post i tabellen <navn> er låst af en anden bruger.

3331 Hvis du vil foretage ændringer i dette felt, skal du først gemme posten.

3332 Der kan ikke indtastes en værdi i et tomt felt på en-siden af en ydre joinforbindelse.

3333 Poster i tabellen <navn> vil ikke have poster på en-siden.

3334 Kan kun vises i version 1.0-formatet.

3337 Der er en ugyldig DataCodePage-indstilling under initialiseringsindstillingen.

3340 Forespørgslen <navn> er beskadiget.

3341 Det aktuelle felt skal være svare til joinnøglen <navn> i den tabel, der fungerer som en-siden af en en-til-mange-relation. Indtast en post i en-sidetabellen med den ønskede nøgleværdi, og foretag derefter indtastningen med det ønskede joinnøgle i mange-tabellen.

3342 Der er et ugyldigt felt af typen Memo, OLE eller Hyperlink Object i underforespørgslen <navn>.

3343 Databaseformatet <filnavn> kan ikke genkendes.

3344 Databasemotoren genkender hverken feltet <navn> i valideringsudtrykket eller standardværdien i tabellen <navn>.

3345 Feltreferencen <navn> er ukendt eller ugyldig.

3346 Antallet af forespørgselsværdier og destinationsfelter er ikke det samme.

3347 Der kan ikke tilføjes poster. Den primære nøgle til tabellen <navn> er ikke i resultatsættet.

3348 Der kan ikke tilføjes poster. Joinnøglen til tabellen <navn> er ikke i resultatsættet.

3349 Der opstod et numerisk feltoverløb.

3350 Objektet er ugyldigt til handlingen.

3351 ORDER BY-udtrykket <udtryk> indeholder felter, der ikke er udvalgt af forespørgslen. Kun de felter, der forespørges på i den første forespørgsel, kan medtages i et ORDER BY-udtryk.

3352 Der er intet destinationsfeltnavn i INSERT INTO-sætningen <sætning>.

3354 Denne underforespørgsel returnerer maksimalt én post.

3355 Der er en syntaksfejl i standardværdien.

3356 Du har forsøgt at åbne en database, der allerede er åbnet med udelt adgang af brugeren <navn> på maskinen <navn>. Prøv igen, når databasen er tilgængelig.

3357 Denne forespørgsel er ikke en korrekt udformet datadefinitionsforespørgsel.

3358 Microsoft Jet-arbejdsgruppeoplysningsfilen i databasemotoren kan ikke åbnes.

3359 Videregivelsesforespørgslen skal indeholde mindst ét tegn.

3360 Forespørgslen er for kompleks.

3361 Foreningsforespørgsler er ikke tilladt i underforespørgsler.

3362 Opdatering/sletning af en enkelt række påvirkede mere end en række i en sammenkædet tabel. Indekset, der er angivet som unikt, indeholder dublerede værdier.

3363 Der kan ikke tilføjes poster. Der er ingen tilsvarende post på en-siden.

3364 Feltet <navn> af typen Memo, OLE eller Hyperlink Object kan ikke bruges i en SELECT-delsætning i en foreningsforespørgsel.

3365 Denne egenskab kan ikke angives for fjernobjekter.

3366 En relation, hvor der ikke er defineret felter, kan ikke tilføjes.

3367 Der kan ikke tilføjes. Et objekt med samme navn findes allerede i samlingen.

3368 Relationer skal bestå af det samme antal felter med de samme datatyper.

3370 Udformningen af tabellen <navn> kan ikke ændres. Det er en skrivebeskyttet database.

3371 Tabellen eller begrænsningen kan ikke findes.

3372 Indekset <navn> findes ikke i tabellen <navn>.

3373 Relationen kan ikke oprettes. Tabellen <navn>, der refereres til, indeholder ikke en primær nøgle.

3374 De angivne felter er ikke unikt indekserede i tabellen <navn>.

3375 Tabellen <navn> har allerede et indeks, der hedder <navn>.

3376 Tabellen <navn> findes ikke.

3377 Relationen <navn> findes ikke i tabellen <navn>.

3378 Der er allerede en relation med navnet <navn> i den aktuelle database.

3379 Relationer, der gennemtvinger referentiel integritet, kan ikke oprettes. Eksisterende data i tabellen <navn> overholder ikke de referentielle integritetsregler, der er defineret i tabellen <navn>.

3380 Feltet <navn> findes allerede i tabellen <navn>.

3381 Feltet <navn> findes ikke i tabellen <navn>.

3382 Feltet <navn> er for stort.

3383 Feltet <navn> kan ikke slettes. Det er en del af en eller flere relationer.

3384 En indbygget egenskab kan ikke slettes.

3385 Brugerdefinerede egenskaber understøtter ikke en Null-værdi.

3386 Egenskaben <navn> skal angives, før du bruger denne metode.

3388 Der er en ukendt funktion <navn> i valideringsudtrykket eller standardværdien i <navn>.

3389 Forespørgselsunderstøttelse er ikke tilgængelig.

3390 Kontonavnet findes allerede.

3393 Joinforbindelsen, grupperingen, sorteringen eller den indekserede begrænsning kan ikke udføres. En værdi, der søges eller sorteres efter, er for lang.

3394 Egenskaben kan ikke gemmes, fordi den er en skemaegenskab.

3396 Den kaskadevise handling kan ikke udføres. Da der findes relaterede poster i tabellen <navn>, vil de referentielle integritetsregler blive overtrådt.

3397 Den kaskadevise handling kan ikke udføres. Der skal være en relateret post i tabellen <navn>.

3398 Den kaskadevise handling kan ikke udføres. Det ville resultere i en nøgle med Null i tabellen <navn>.

3399 Den kaskadevise handling kan ikke udføres. Det ville resultere i en dubleret nøgle i tabellen <navn>.

3400 Den kaskadevise handling kan ikke udføres. Det ville resultere i to opdateringer af feltet <navn> i tabellen <navn>.

3401 Den kaskadevise handling kan ikke udføres. Det ville medføre, at feltet <navn> blev angivet til Null, hvilket ikke er tilladt.

3402 Den kaskadevise handling kan ikke udføres. Det ville medføre, at feltet <navn> blev angivet til en streng af længden nul, hvilket ikke er tilladt.

3403 Den kaskadevise handling kan ikke udføres. <Valideringstekst>.

3404 Den kaskadevise handling kan ikke udføres. Den indtastede værdi tillades ikke af valideringsreglen <regel>, der er angivet for <navn>.

3405 Fejl <fejltekst> i valideringsregel.

3406 Det udtryk, du forsøger at bruge på egenskaben DefaultValue, er ugyldigt, fordi <fejltekst>. Brug et gyldigt udtryk til at angive egenskaben.

3407 Serverens MSysConf-tabel findes, men den har et forkert format. Kontakt systemadministratoren.

3408 Der er kaldt for mange FastFind-sessioner.

3409 Feltnavnet <navn> er ugyldigt i definitionen af et indeks eller en relation.

3411 Indtastningen er ugyldig. Den kaskadevise handling, der er angivet i tabellen <navn>, kan ikke udføres, fordi den indtastede værdi er for stor til feltet <navn>.

3412 Den kaskadevise opdatering af tabellen kan ikke udføres, fordi den bruges af en anden bruger.

3413 Den kaskadevise opdatering af tabellen <navn> kan ikke udføres, fordi den er i brug af brugeren <navn> på maskinen <navn>.

3414 Den kaskadevise handling på tabellen <navn> kan ikke udføres, fordi den er i brug.

3415 Strenge af længden nul er kun gyldige i et felt af typen Text eller Memo.

3416 <Reserveret fejladvarsel>

3417 En handlingsforespørgsel kan ikke bruges som en rækkekilde.

3418 <Tabelnavn> kan ikke åbnes. En anden bruger har åbnet tabellen med en anden netværksstyrefil eller låseteknik.

3419 Denne Paradox 4.x- eller 5.x-tabel kan ikke åbnes, fordi ParadoxNetStyle er angivet til 3.x i Windows-registreringsdatabasen.

3420 Objektet er ugyldigt eller er ikke længere angivet.

3421 Der opstod en datatypekonverteringsfejl.

3422 Tabelstrukturen kan ikke ændres. En anden bruger har åbnet tabellen.

3423 Du kan ikke bruge ODBC til at importere fra, eksportere til eller sammenkæde en ekstern Microsoft Jet- eller ISAM-databasetabel med databasen.

3424 Databasen kan ikke oprettes, fordi landestandarden er ugyldig.

3428 Der opstod et problem i databasen. Løs problemet ved at reparere og komprimere databasen.

3429 Den installerbare ISAM-version er ikke kompatibel.

3430 OLE kunne ikke initialiseres under indlæsning af den installerbare ISAM til Microsoft Excel.

3431 Dette er ikke en Microsoft Excel 5.0-fil.

3432 Der opstod en fejl under åbning af en Microsoft Excel 5.0-fil.

3433 Der er en ugyldig indstilling i Excel-nøglen i sektionen Engines i Windows-registreringsdatabasen.

3434 Det navngivne område kan ikke udvides.

3435 Regnearkceller kan ikke slettes.

3436 Det lykkedes ikke at oprette filen.

3437 Regnearket er fuldt.

3438 De data, der eksporteres, passer ikke til det format, der er beskrevet i filen Schema.ini.

3439 Du har forsøgt at sammenkæde eller importere en Microsoft Word-brevfletningsfil. Selvom du kan eksportere sådanne filer, kan du ikke sammenkæde eller importere dem.

3440 Der er gjort forsøg på at importere eller sammenkæde en tom tekstfil. Hvis du vil importere eller sammenkæde en tekstfil, skal filen indeholde data.

3441 Tekstfilspecifikationens feltseparator er magen til decimalseparatoren eller tekstafgrænseren.

3442 Indstillingen <navn> i tekstfilspecifikationen <navn> er ugyldig.

3443 Fast bredde-specifikationen <navn> indeholder ingen kolonnebredder.

3444 Kolonnen <kolonne> angiver ikke en bredde i fast bredde-specifikationen <navn>.

3445 Der blev fundet en forkert version af DLL-filen <navn>.

3446 Jet VBA-filen (Vbajet.dll til 16-bit versioner eller Vbajet.dll til 32-bit versioner) mangler. Prøv at geninstallere det program, der returnerede fejlen.

3447 JET VBA-filen (Vbajet.dll til 16-bit versioner eller Vbajet32.dll til 32-bit versioner) kunne ikke initialiseres, da den blev kaldt. Prøv at geninstallere det program, der returnerede fejlen.

3448 Et kald til en OLE-systemfunktion lykkedes ikke. Prøv at geninstallere det program, der returnerede fejlen.

3449 Der blev ikke fundet en landekode i tilslutningsstrengen.

3450 Der er en syntaksfejl i forespørgslen. Forespørgslens delsætning er ikke komplet.

3451 Der er en ugyldig reference i forespørgslen.

3452 Du kan ikke foretage ændringer til databasedesignet i denne replika.

3453 Du kan ikke etablere eller vedligeholde en gennemtvunget relation mellem en replikeret tabel og en lokal tabel.

3455 Databasen kan ikke gøres replikerbar.

3456 <Navn>-objektet i <navn>-objektbeholderen kan ikke gøres replikerbart.

3457 Du kan ikke angive egenskaben KeepLocal for et objekt, der allerede er replikeret.

3458 Egenskaben KeepLocal kan ikke angives for en database. Den kan kun angives for objekter i en database.

3459 Når en database er replikeret, kan du ikke fjerne replikeringsfunktionerne fra databasen.

3460 Den handling, du forsøgte at udføre, er i konflikt med en eksisterende handling, der involverer dette medlem i replikasættet.

3461 Den replikeringsegenskab, du prøver at angive eller slette, er skrivebeskyttet og kan ikke ændres.

3462 Det lykkedes ikke at indlæse et DLL-bibliotek.

3463 DLL-biblioteket <navn> kunne ikke findes.

3464 Datatyperne stemmer ikke overens i kriterieudtrykket.

3465 Det diskdrev, du prøver at få adgang til, kan ikke læses.

3468 Adgang blev nægtet under forsøg på at få adgang til mappen med rullelisten <navn>.

3469 Disken til mappen med rullelisten <navn> er fuld.

3470 Der opstod en diskfejl under forsøg på at få adgang til mappen med rullelisten <navn>.

3471 Det lykkedes ikke at skrive til Synchronizer-logfilen.

3472 Disken er fuld for stien <navn>.

3473 Der opstod en diskfejl under forsøg på at få adgang til logfilen <navn>.

3474 Logfilen <navn> kan ikke åbnes med skriveadgang.

3475 Der opstod en delingsfejl under forsøg på at åbne logfilen <navn> i nægt skrivning-tilstand.

3476 Stien <navn> til rullelisten er ugyldig.

3477 Adressen <navn> på rullelisten har en ugyldig syntaks.

3478 Replikaen er ikke en delvis replika.

3479 En delvis replika kan ikke gøres til masterdesign for et replikasæt.

3480 Relationen <navn> i det delvise filterudtryk er ugyldig.

3481 Tabelnavnet <navn> i det delvise filterudtryk er ugyldigt.

3482 Filterudtrykket til den delvise replika er ugyldigt.

3483 Den angivne adgangskode til mappen med rullelisten <navn> er ugyldig.

3484 Den adgangskode, der bruges af Synchronizer til at skrive til en mappe med en destinationsrulleliste, er ugyldig.

3485 Objektet kan ikke replikeres, fordi databasen ikke er replikeret.

3486 Du kan ikke føje et andet ReplicationID-felt af typen Autonumber til en tabel.

3487 Den database, du prøver at replikere, kan ikke konverteres.

3488 Den værdi, der er angivet, er ikke et ReplicaID for noget medlem i replikasættet.

3489 Det angivne objekt kan ikke replikeres, fordi objektet mangler en nødvendig ressource.

3490 En ny replika kan ikke oprettes, fordi <navn>-objektet i objektbeholderen <navn> ikke kan replikeres.

3491 Databasen skal åbnes med udelt adgang, før den kan replikeres.

3492 Synkroniseringen lykkedes ikke, fordi en designændring ikke kan anvendes på en af replikaerne.

3493 Det er ikke muligt at angive den angivne registreringsdatabaseparameter for Synchronizer.

3494 Det er ikke muligt at hente den angivne registreringsdatabaseparameter for Synchronizer.

3495 Der er ingen planlagte synkroniseringer mellem de to Synchronizer-programmer.

3496 Replikastyring kan ikke finde ExchangeID i tabellen MSysExchangeLog.

3497 Det er ikke muligt at angive en tidsplan for Synchronizer.

3499 Oplysningerne om den fulde sti til et medlem af replikasættet kan ikke hentes.

3500 Det er ikke muligt at angive en udveksling med det samme Synchronizer-program.

3502 Masterdesign eller replikaen styres ikke af et Synchronizer-program.

3503 Registreringsdatabasen til Synchronizer har ingen værdi angivet for den anmodede nøgle.

3504 Synchronizer-id'et passer ikke til et eksisterende id i tabellen MSysTranspAddress.

3505 Du har forsøgt at slette eller hente oplysninger om et delvist filter, der ikke findes i MsysFilters.

3506 Synchronizer kan ikke åbne logfilen til Synchronizer.

3507 Det lykkedes ikke at skrive til Synchronizer-logfilen.

3508 Der findes ingen aktiv transport til Synchronizer.

3509 En gyldig transport til Synchronizer kunne ikke findes.

3510 Medlemmet af det replikasæt, du forsøger at synkronisere, bruges aktuelt i en anden synkronisering.

3512 Det lykkedes ikke at læse i mappen med rullelisten.

3513 Det lykkedes ikke at skrive til mappen med rullelisten.

3514 Synchronizer kunne ikke finde planlagte eller anmodede synkroniseringer, der skal behandles.

3515 Microsoft Jet-databasemotoren kunne ikke læse systemuret på computeren.

3516 Destinationssynchronizer er ikke konfigureret til at understøtte indirekte synkronisering, og destinationsreplikaen er ikke tilgængelig for direkte synkronisering.

3517 Synchronizer kunne ikke finde meddelelser, der skal behandles.

3518 Synchronizer i tabellen MSysTranspAddress kunne ikke findes.

3519 Det lykkedes ikke at sende en meddelelse.

3520 Replikanavnet eller id'et passer ikke til et aktuelt vedligeholdt medlem af replikasættet.

3521 To medlemmer af replikasættet kan ikke synkroniseres, fordi der ikke findes et fælles udgangspunkt til start af synkroniseringen.

3522 Synchronizer kan ikke finde posten til en bestemt synkronisering i tabellen MSysExchangeLog.

3523 Synchronizer kan ikke finde et bestemt versionsnummer i tabellen MSysSchChange.

3524 Oversigten over designændringer i replikaen svarer ikke til oversigten i masterdesign.

3525 Synchronizer kunne ikke åbne meddelelsesdatabasen.

3526 Det valgte navn til systemobjektet er allerede i brug.

3527 Synchronizer eller Replikastyring kunne ikke finde systemobjektet.

3528 Der er ingen nye data at læse for Synchronizer eller Replikastyring i den delte hukommelse.

3529 Synchronizer eller Replikastyring fandt ulæste data i den delte hukommelse. De eksisterende data bliver overskrevet.

3530 Synchronizer betjener allerede en klient.

3531 Ventetiden for en hændelse er udløbet.

3532 Synchronizer kunne ikke initialiseres.

3533 Det systemobjekt, der bruges af en proces, findes stadig efter processen er ophørt.

3534 Synchronizer har søgt efter en systemhændelse, men fandt ingen at rapportere til klienten.

3535 Klientprogrammet har anmodet Synchronizer om at afslutte handlingen.

3536 Synchronizer modtog en ugyldig meddelelse til et medlem af det replikasæt, som det vedligeholder.

3537 Klientprogrammet til Synchronizer er ikke længere tilgængeligt og kan ikke underrettes.

3538 Synchronizer kan ikke initialiseres, fordi der kører for mange programmer.

3539 Der er opstået en systemfejl, eller swapfilen har nået grænsen.

3540 Swapfilen har nået grænsen eller er beskadiget.

3541 Synchronizer kunne ikke lukkes korrekt ned og er stadig aktiv.

3542 Processen stoppede, da der blev gjort forsøg på at afslutte Synchronizer-klientprogrammet.

3543 Synchronizer er ikke installeret.

3544 Synchronizer kører allerede.

3545 De to replikaer, du forsøger at synkronisere, kommer fra forskellige replikasæt.

3546 Den type synkronisering, der er forsøgt udført, er ugyldig.

3547 Synchronizer kunne ikke finde en replika fra det korrekte sæt til at afslutte synkroniseringen.

3548 GUID'erne passer ikke sammen, eller den GUID, der blev anmodet om, kunne ikke findes.

3549 Det angivne filnavn er for langt.

3550 Der er ikke et indeks i GUID-kolonnen.

3551 Den angivne registreringsdatabaseparameter for Synchronizer kan ikke slettes.

3552 Størrelsen af registreringsdatabaseparameteren overskrider den tilladte maksimale størrelse.

3553 GUID'en kan ikke oprettes.

3555 Alle gyldige kælenavne for replikaer er allerede i brug.

3556 Stien til mappen til destinationsrullelisten er ugyldig.

3557 Adressen for mappen med destinationsrullelisten er ugyldig.

3558 Der er en disk I/O-fejl i mappen med destinationsrullelisteboksen.

3559 Der kan ikke skrives, da destinationsdisken er fuld.

3560 De to medlemmer af replikasættet, du forsøger at synkronisere, har samme replika-id.

3561 De to medlemmer af replikasættet, du forsøger at synkronisere, er begge masterdesign.

3562 Adgang til mappen med destinationsrullelisten blev nægtet.

3563 Der opstod en alvorlig fejl under adgang til en lokal mappe til rullelisten.

3564 Synchronizer kan ikke finde kildefilen til meddelelserne.

3565 Der er en delingsfejl i mappen til kilderullelisten, fordi meddelelsesdatabasen er åben i et andet program.

3566 Der opstod en I/O-fejl på netværket.

3567 Meddelelsen i mappen til rullelisten tilhører den forkerte Synchronizer.

3568 Synchronizer kan ikke slette en fil.

3569 Dette medlem af replikasættet er blevet logisk fjernet fra replikasættet og er ikke længere tilgængeligt.

3570 De filtre, der definerer en delvis replika, er ikke synkroniseret i forhold til hinanden.

3571 Forsøget på at angive en kolonne i en delvis replika krænker en regel for delvise replikaer.

3572 Der opstod en disk I/O-fejl under læsning eller skrivning til Temp-biblioteket.

3573 Det bibliotek, hvor du har forespurgt efter en liste over replikaer, er ikke et styret bibliotek.

3574 Replika-id'et for dette medlem af replikasættet blev gentildelt under en flytte- eller kopieringsprocedure.

3575 Det diskdrev, du forsøger at skrive til, er fuldt.

3576 Den database, du prøver at åbne, bruges allerede af et andet program.

3577 Systemkolonnen til replikering kan ikke opdateres.

3578 Det lykkedes ikke at replikere databasen. Det kan ikke afgøres, om databasen er åben med udelt adgang.

3579 De systemtabeller til replikering, der er nødvendige for at gøre databasen replikerbar, kunne ikke oprettes.

3580 De rækker, der er nødvendige for at gøre databasen replikerbar, kunne ikke tilføjes.

3581 Systemtabellen <navn> til replikering kan ikke åbnes, fordi tabellen allerede er i brug.

3582 En ny replika kan ikke oprettes, fordi <navn>-objektet i objektbeholderen <navn> ikke kunne gøres replikerbar.

3583 <Navn>-objektet i <navn>-objektbeholderen kan ikke gøres replikerbart.

3584 Der er ikke tilstrækkelig hukommelse til at udføre handlingen.

3585 Tabellen kan ikke replikeres. Antallet af kolonner overskrider det maksimale tilladte antal.

3586 Der er en syntaksfejl i et delvist filterudtryk i tabellen <navn>.

3587 Der er et ugyldigt udtryk i egenskaben ReplicaFilter.

3588 Der opstod en fejl under evalueringen af det delvise filterudtryk.

3589 Der er en ukendt funktion i det delvise filterudtryk.

3590 Overtræder reglerne for delvise replikaer.

3591 Stien til logfilen <stinavn> er ugyldig.

3592 Du kan ikke replikere en database, der er beskyttet med adgangskode, eller angive en adgangskodebeskyttelse i en replikeret database.

3593 Du kan ikke ændre replikasættets datamasterattribut.

3594 Du kan ikke ændre replikasættets datamasterattribut. Det tillader kun dataændringer i masterdesign.

3595 Systemtabellerne i replikaen er ikke længere pålidelige, og replikaen bør ikke bruges.

3600 Aggregeringsudtryk kan ikke anvende GUID'er.

3605 Synkronisering med en ikke-replikeret database er ikke tilladt. Databasen <navn> er ikke et masterdesign eller en replika.

3607 Den replikeringsegenskab, du prøver at slette, er skrivebeskyttet og kan ikke fjernes.

3608 Postlængden er for lang til en indekseret Paradox-tabel.

3609 Der blev ikke fundet et entydigt indeks for det felt, der refereres til, i den primære tabel.

3610 Der refereres til den samme tabel <tabel> som både kilde og destination i tabeloprettelsesforespørgslen.

3611 Datadefinitionssætninger kan ikke udføres på sammenkædede datakilder.

3612 GROUP BY-delsætninger i flere niveauer er ikke tilladt i en underforespørgsel.

3613 Til sammenkædede ODBC-tabeller kan der ikke oprettes en relation.

3614 GUID er ikke tilladt i kriterieudtrykket til metoden Find.

3615 Datatyper i JOIN-udtrykket stemmer ikke overens.

3616 Opdatering af data i en sammenkædet tabel understøttes ikke af denne ISAM.

3617 Sletning af data i en sammenkædet tabel understøttes ikke af denne ISAM.

3618 Undtagelsestabellen kan ikke oprettes ved import/eksport.

3619 Poster kan ikke føjes til undtagelsestabellen.

3620 Tilslutningen for visning af det sammenkædede Microsoft Excel-regneark er gået tabt.

3621 Adgangskoden kan ikke ændres for en delt, åben database.

3622 Du skal bruge indstillingen dbSeeChanges med OpenDatabase ved adgang til en SQLServer-tabel, der har en IDENTITY-kolonne.

3623 Den bundne FoxPro 3.0-DBF-fil <filnavn> kan ikke åbnes.

3624 Posten kan ikke gemmes, fordi den er låst af en anden bruger.

3625 Tekstfilspecifikationen <navn> findes ikke. Du kan ikke importere, eksportere eller sammenkæde med denne specifikation.

3626 Handlingen lykkedes ikke. Der er for mange indeks til tabellen <navn>. Slet nogle af indeksene til tabellen, og prøv at udføre handlingen igen.

3627 Synchronizers eksekverbare fil kan ikke findes (Mstran40.exe).

3628 Partnerreplikaen vedligeholdes ikke af Synchronizer.

3629 Synchronizer-programmet <navn> har samme filsystemrulleliste <navn>.

3630 Synchronizer-programmet <navn> har samme filsystemrulleliste <navn>.

3631 Tabelnavnet i filteret er ugyldigt.

3632 Internet Transport er ikke aktiveret på Synchronizer-fjernprogrammet.

3633 DLL-biblioteket <navn> kan ikke indlæses.

3634 Replikaen kan ikke oprettes ved brug af en delvis replika.

3635 En delvis replika af en systemdatabase kan ikke oprettes.

3636 Replikaen kan ikke udfyldes, eller replikafilteret kan ikke ændres, fordi replikaen indeholder konflikter eller datafejl.

3637 Krydstabuleringsforespørgslen i en ikke-fast kolonne kan ikke bruges som underforespørgsel.

3638 En kildestyret database kan ikke gøres replikerbar.

3639 En replika af en systemdatabase kan ikke oprettes.

3640 Hentebufferen var for lille til antallet af ønskede data.

3641 Der er færre poster tilbage i postsættet, end du anmodede om.

3642 Der er udført en annullering i handlingen.

3643 En af posterne i postsættet er slettet af en anden proces.

3645 En af bindingsparametrene er ugyldig.

3646 Den angivne rækkelængde er kortere end summen af kolonnelængderne.

3647 Den ønskede kolonne returneres ikke til postsættet.

3648 En delvis replika kan ikke synkroniseres med en anden delvis replika.

3649 Den sprogspecifikke tegntabel var ikke angivet eller blev ikke fundet.

3650 Enten er Internettet for langsomt, eller der er et problem i opsætningen af replikeringstyring på Internet-servercomputeren.

3651 Internet-adressen er ugyldig.

3652 Der opstod en fejl ved logon til Internettet.

3653 Internet er ikke konfigureret.

3656 Der opstod en fejl under evaluering af et delvist udtryk.

3657 Der opstod en fejl under evaluering af det booleske filterudtryk i tabellen <navn>.

3658 Den binære kolonne <navn> kan ikke bruges i et boolesk filter.

3659 Relationen <navn> er ikke-gennemtvunget. En relation i et delvist filterudtryk skal være gennemtvunget.

3660 Der opstod en fejl ved den anmodede udveksling, fordi <beskrivelse>.

3661 Der opstod en fejl ved den anmodede udveksling, fordi <beskrivelse>.

3663 Denne handling kræver et andet markørbibliotek.

3664 Et asynkront OpenConnection-kald er endnu ikke udført. Du kan ikke refererere til det returnerede tilslutningsobjekt, før kaldet er udført.

3665 Du kan ikke ændre systemobjektet til replikeringen <navn>.

3666 Du kan ikke ændre systemobjektet til replikeringen <navn>.

3667 En anden handling forhindrer, at denne handling udføres.

3668 Denne handling kan ikke udføres, fordi der ikke er en aktiv forbindelse.

3672 Det lykkedes ikke at indlæse et RDOCURS.dll.

3673 Denne tabel indeholder celler, der er uden for det celleområde, der er defineret i dette regneark.

3674 Internet-dll-filen (wininet.dll) blev ikke fundet eller indlæst.

3675 Det lykkedes ikke at læse fra en Internet-handle. Prøv at udføre handlingen igen.

3676 Det lykkedes ikke at skrive til en Internet-handle. Prøv at udføre handlingen igen.

3677 Det lykkedes ikke at udføre HTTP-anmodningen om at starte Internet Synchronizer eller Internet-serveren. Brug Replikeringsstyring til at konfigurere Internet Synchronizer på Internet-serveren.

3678 Det lykkedes ikke at tilslutte til FTP-serviceprogrammet. Sørg for, at FTP-serviceprogrammet kører korrekt på serveren og understøtter anonyme forbindelser.

3679 Det lykkedes ikke at åbne filen ved hjælp af FTP-serviceprogrammet. Sørg for, at FTP-rullelisten har læsetilladelser.

3680 Det lykkedes ikke at hente en fil ved hjælp af FTP. Sørg for, at FTP-rullelisten har læsetilladelser.

3681 Det lykkedes ikke at placere en fil ved hjælp af FTP. Sørg for, at FTP-rullelisten har skrivetilladelser.

3682 Det lykkedes ikke at slette en fil ved hjælp af FTP. Sørg for, at FTP-rullelisten har læse- og skrivetilladelser.

3683 Internet Synchronizer afsluttede uventet. Se på udvekslingsoversigten over partnerreplikaen på Internet-serveren for at løse problemet.

3684 Der er ingen passende replika at udveksle med.

3685 HTTP-adressen er ugyldig.

3686 Replikastien eller -navnet er ugyldigt.

3689 SQL-syntaksen er ugyldig – forventet token: Privileges.

3700 Præcisionen for decimal datatypen er ugyldig.

3701 Skalaen for decimal datatypen er ugyldig.

3702 Bredden på en Unicode-tekstkolonne skal være et lige antal byte..

3703 Handlingen understøttes ikke på replikerbare databaser, der ikke er konverteret til den aktuelle version.

3704 Du har forsøgt at åbne en database, der allerede er åbnet af brugeren <navn> på maskinen <navn>. Prøv igen, når databasen er tilgængelig.

3705 Tabellen <navn> kan ikke replikeres på grund af for mange kolonner.

3706 Tabellen <navn> kan ikke replikeres på grund af for mange indeks.

3707 De kaskadevise indstillinger for den nye reference er i konflikt med den eksisterende reference <navn>.

3708 Der er en syntaksfejl i TRANSACTION-sætningen. TRANSACTION, WORK eller intet var ventet.

3709 Søgenøglen blev ikke fundet i posterne.

3710 MAPI-mappen eller -adressekartoteket blev ikke fundet.

3711 Gendannede replikerbare data. Denne række blev gendannet fra en beskadiget replikerbar database. Bekræft, at postens indhold er korrekt, og genindsæt derefter posten, eller slet konfliktposten.

3713 Opdater/opdater-konflikt. En anden replika har også opdateret denne post. Denne post tabte konflikten. Send enten opdateringen igen, eller slet denne konfliktpost.

3714 Tabellen er låst. Denne post kunne ikke anvendes under synkroniseringen, da tabellen var låst af en anden bruger. Send denne konfliktpost igen.

3715 Der er opstået en entydig nøglefejl. Denne post har samme nøgleværdi som en anden post. Kun entydige værdier er tilladte. Du skal enten ændre nøgleværdien i denne konfliktpost eller i den vindende post og derefter sende denne post igen, eller slette konfliktposten.

3716 TLV-fejl. Denne post indeholder en feltværdi, der ikke overholder valideringsbegrænsningen på tabelniveau. Opdater enten den feltværdi, der overtræder valideringsreglen, og send derefter denne konfliktpost igen, eller slet den.

3717 Delete/RI-konflikt. Den primære nøglepost er blevet slettet af en anden replika. Derfor er denne referencepost blevet afvist. Opret enten en ny primær nøgle, der opfylder den referentielle integritetsbegrænsning, og send derefter opdateringen igen, eller slet denne konfliktpost.

3718 Update/RI-konflikt. Den primære nøglepost er blevet opdateret af en anden replika. Derfor er denne referencepost blevet afvist. Opret enten en ny primær nøglepost, der opfylder den referentielle integritetsbegrænsning, rediger den fremmede nøgleværdi i denne konflikt, så den svarer til en gyldig, primær nøgleværdi, og send opdateringen igen, eller slet denne konfliktpost.

3719 Fejl i den fremmede nøgle på grund af en ugyldig, primær nøglepost, der var part i en replikeringskonflikt. Opret enten en ny primær nøglepost, der opfylder den referentielle integritetsbegrænsning, rediger den fremmede nøgleværdi i denne konflikt, så den svarer til en gyldig, primær nøgleværdi, og send derefter denne konfliktpost igen, eller slet den.

3720 Feltet <navn> kan ikke ændres. Det er en del af én eller flere relationer

3721 Det er en ugyldig SQL-syntaks – forventede CONSTRAINT-navn.

3722 Det er en ugyldig SQL-syntaks – forventede token: DEFAULT.

3723 Det er en ugyldig SQL-syntaks – forventede token: COMPRESSION efter WITH.

3724 Det er en ugyldig SQL-syntaks – forventede token: UPDATE eller DELETE.

3725 Det er en ugyldig SQL-syntaks – forventede token: CASCADE, SET NULL eller NO ACTION.

3726 Det er en ugyldig SQL-syntaks – forventede token: NULL.

3727 Det er en ugyldig SQL-syntaks. Kun én opdateringsregel og/eller sletteregel er tilladt.

3728 Det er en ugyldig SQL-syntaks – forventede token: AS.

3729 Det er en ugyldig SQL-syntaks – forventede token: SELECT.

3730 VIEW kan ikke indeholde en parameter.

3731 Antallet af angivne aliaser skal være det samme som antallet af outputkolonner.

3732 Forespørgselsnavn var ventet efter EXECUTE.

3733 Databasen er indstillet i en tilstand af en ukendt bruger. Dette forhindrer, at databasen kan åbnes eller låses.

3734 Databasen er indstillet i en tilstand af brugeren <navn> på maskinen <navn>. Dette forhindrer, at databasen kan åbnes eller låses.

3736 Update/Delete-konflikt. Den opdaterede post blev slettet ved en anden replika. Du skal enten genindsætte eller slette konfliktposten.

3737 Denne type replika kan ikke oprettes fra den givne kildereplika.

3738 Lokale og anonyme replikaer skal kun synkronisere til deres angivne hub-replika.

3740 Der kan ikke tilføjes en ny kolonne til konflikttabellen <navn>. Slet forældede kolonner, og komprimer databasen.

3741 Det er en ugyldig synkroniseringspartner. En lokal eller anonym replika skal synkronisere med den angivne hub-replika.

3742 En Internet-funktion blev afbrudt.

3743 Ingen replika blev synkroniseret inden for opbevaringsfristen for replikasæt.

3745 Den kombinerede længde af Internet-servernavn, HTTP-sharenavn og FTP-aliasnavn må ikke overstige 252 tegn.

3746 Der er en syntaksfejl i forespørgslen. Parameterværdi.

3747 Parameteren har ingen standardværdi.

3748 Parameteren <navn> har ingen standardværdi.

3749 Objektet er ikke en lagret procedure.

3750 Objektet <navn> er ikke en lagret procedure.

3751 Den anmodede rækkelåsning kan ikke udføres, fordi DB er i sidelåsningstilstand.

3752 Den anmodede sidelåsning kan ikke udføres, fordi DB er i rækkelåsningstilstand.

3753 Replika af en Jet SQL-replika kan ikke oprettes.

3754 Der kan ikke slettes fra en Prevent Deletes-replika.

3755 CHECK-begrænsningen <navn> findes ikke.

3756 CHECK-begrænsningen <navn> findes allerede.

3757 JET sorterings-DLL’er kunne ikke indlæses korrekt.

3758 Skalering af decimalværdi medførte afkortelse af data.

3759 Skalering af decimalværdi medførte afkortelse af data.

3760 Skalering af decimalværdi medførte overløb af data.

3761 Præcisionen af decimalfeltet er for lav til at godkende det tal, du forsøgte at tilføje.

3762 Det er en ugyldig SQL-syntaks – forventede token: ACTION.

3763 Samtidige skemaændringer medførte, at oprettelsen af replika mislykkedes. Forsøg igen.

3765 Der er en syntaksfejl i CHECK CONSTRAINT-delsætningen.

3766 Kun simple SELECT-forespørgsler er tilladt i VIEWS

3767 Tabellen <navn> kunne ikke gøres replikerbar, fordi den ikke kan åbnes med udelt adgang.

3768 FastFind kan ikke søge på referencer, der ikke er kolonner.

3769 Konflikttabeller kan ikke omdøbes.

3770 Tællerdefinitionen er ikke i et gyldigt område.

3771 Lokale og anonyme replikaer kan ikke gøres til masterdesign.

3772 Uden Administrere-tilladelse, skal prioriteten af replika ligge i området 0 - <tal>.

3773 Det er ikke muligt at slette et eller flere objekter: <Navn>.

3775 Jet SQL Server Reconciler - MSRPJT40.dll, kunne ikke indlæses.

3777 Der blev forsøgt en ulovlig handling på en Jet SQL Server-replika.

3778 Jet-databasen er forkert eller mangler for dette SQL/Jet-replikasæt.

3779 Egenskaben for sporing af kolonneniveau kunne ikke ændres på de objekter, der allerede er replikerbare.

3780 Det er en ugyldig SQL-syntaks – forventede et visningsnavn.

3781 Det er en ugyldig SQL-syntaks – forventede et procedurenavn.

3784 Databasen er allerede replikerbar.

3785 Det er en ugyldig SQL-syntaks – forventede token: Database.

3786 Det er en ugyldig SQL-syntaks – forventede et databaseprivilegium, f.eks. CREATEDB eller CONNECT.

3787 Denne handling er ikke tilladt i underforespørgsler.

3788 Et indeks kunne ikke oprettes på denne MAPI-mappe/adressebog.

3789 Det er en ulovlig begrænsning på kolonneniveau.

3798 CHECK-begrænsninger er ikke tilladt på replikerbare databaser.

3799 Det er ikke finde feltet <navn>.

3800 <Navn> er ikke et indeks i denne tabel.

3801 Forespørgslen <navn> kan ikke bruges i en CHECK CONSTRAINT-delsætning.

3802 Der opstod en fejl under bedømmelse af CHECK-begrænsningen <navn>. <Yderligere oplysninger>.

3803 DLL kan ikke udføres på denne tabel, fordi der refereres til det af begrænsningen <navn> på tabellen <navn>.

3804 Der er ingen MAPI-klienter installeret på denne maskine. Installer en MAPI-klient, f.eks. Outlook, på maskinen.

3805 CHECK-begrænsninger på tabellen <navn> overføres ikke til denne tabel. CHECK-begrænsninger kan kun oprettes via SQL DLL-sætninger.

3806 Flere NULL, NOT NULL-attributter kan ikke indstilles.

3807 Forespørgslen <navn> indeholder et tvetydigt kolonnenavn, der er i konflikt med korrelationsnavnet (aliaset) <navn>. Gør kolonnenavnet fuldstændigt, eller rediger korrelationsnavnet (aliaset).

3808 Databasesystemformatet skal være version 4.x eller senere for at kunne udføre denne handling.


handlingsforespørgsel <Jet-definition>

handlingsforespørgsel

En forespørgsel, der flytter eller ændrer data. Handlingsforespørgsler omfatter tilføjelses-, slette-, tabeloprettelses- og opdateringsforespørgsler. Slette- og opdateringsforespørgsler ændrer eksisterende data. I SQL henvises til disse som DML-forespørgsler, og de består af nøgleordene DELETE, INSERT og UPDATE. Microsoft® Jet understøtter nøgleordet SELECT INTO, der også betragtes som en DDL-forespørgsel. Tilføjelses- og tabeloprettelsesforespørgsler flytter eksisterende data. Derimod returnerer udvælgelsesforespørgsler dataposter. En SQL-videregivelsesforespørgsel kan også være en handlingsforespørgsel.


ADO (Active Data Objects) <Jet-definition>

ADO (Active Data Objects)

En programmeringsmæssig brugerflade til at åbne og manipulere databaseobjekter.


aggregatfunktion <Jet-definition>

aggregatfunktion

En funktion, f.eks. Sum, Antal, Gennemsnit og Maks, der benyttes ved beregning af totaler. Når du indtaster udtryk og programmerer, kan du bruge SQL-aggregatfunktioner (herunder de fire ovennævnte) og domæneaggregatfunktioner til at bestemme forskellige statistikoplysninger.


alias <Jet-definition>

alias

Visual Basic: Et alternativt navn, som du giver til en ekstern procedure for at undgå konflikter med et Microsoft® Visual Basic®-nøgleord, en global variabel, en konstant eller et navn, der ikke er tilladt ifølge navngivningskonventionerne i Visual Basic.

SQL (Structured Query Language): Et alternativt navn, som gives til et felt eller et udtryk i en SELECT-sætning ved hjælp af den valgfri AS-delsætning. ANSI kalder dette et korrelationsnavn.


ANSI-tegnsæt <Jet-definition>

ANSI-tegnsæt

Et 8 bit tegnsæt, der benyttes af Microsoft® Windows®. Du kan anvende tegnsættet til at angive op til 256 tegn (0-255) ved hjælp af tastaturet. ASCII-tegnsættet er en delmængde af ANSI-tegnsættet.


ANSI SQL 92-tilstand <Jet-definition>

ANSI SQL 92-tilstand

Denne tilstand tillader en udvidet SQL-syntaks, der er mere kompatibel med SQL-92 og Microsoft® SQL Server™. Denne tilstand er kun tilgængelig, når du går via Microsoft OLE DB Provider til Jet. Den kan ikke indstilles, når du går via dataadgangsobjekter. Nye funktioner er primært i DDL. Understøttelse af ANSI-jokertegn, dvs. procenttegnet (%) og understregningstegnet (_), er også en del af ANSI SQL-92-tilstanden.


tilføjelsesforespørgsel <Jet-definition>

tilføjelsesforespørgsel

En handlingsforespørgsel, der tilføjer nye poster til slutningen af en eksisterende tabel eller forespørgsel. Tilføjelsesforespørgsler returnerer ikke poster (rækker). SQL-syntaks indeholder nøgleordet INSERT.


argument <Jet-definition>

argument

En konstant, en variabel eller et udtryk, der giver yderligere oplysninger til en handling, procedure eller metode. Du kan anvende et argument med en operand i et udtryk for at give de ekstra oplysninger, der kræves i forbindelse med visse handlinger.


matrix <Jet-definition>

matrix

En variabel, der indeholder et endeligt antal elementer, som har et almindeligt navn eller en almindelig datatype. Hvert element i en matrix identificeres af et unikt indeksnummer. Ændringer, der er foretaget i ét element i en matrix, påvirker ikke de andre elementer.


ASCII-tegnsæt <Jet-definition>

ASCII-tegnsæt

ASCII (American Standard Code for Information Interchange) er et 7 bit-tegnsæt, som i vid udstrækning bruges til at repræsentere de bogstaver og symboler, der findes på et almindeligt dansk tastatur. ASCII-tegnsættet er identisk med de første 128 tegn (0 – 127) i ANSI-tegnsættet.


stjerne <Jet-definition>

stjerne

Et tegn (*), der bruges som et jokertegn i SQL-udtryk til at acceptere enhver tegnstreng. Udtrykket LIKE "*by*" vil f.eks. returnere alle de poster, der indeholder strengen "by" efterfulgt af ingen eller flere tegn.

Når du opretter en forespørgsel eller skriver en SQL-sætning, skal du anvende stjernen til at medtage alle de felter, der aktuelt findes i den underliggende tabel eller forespørgsel. For eksempel vil SELECT * FROM MinTabel returnere alle felter (kolonner) fra tabellen.

Når der udstedes en forespørgsel via Microsoft® OLE DB Provider til Jet, bruges stjernen ikke længere som et jokertegn. I stedet bruges procenttegnet (%) som ANSI-jokertegn. Lagrede forespørgsler påvirkes ikke, men nye forespørgsler (VIEWS), der oprettes via Microsoft OLE DB Provider til Jet, skal bruge ANSI-jokertegnene, procenttegnet (%) og understregningstegnet (_) for at opnå den samme resultat som med stjernen (*) og spørgsmålsregnet (?). Microsoft OLE DB Provider til Jet tolker stjernen og spørgsmålstegnet som bogstavelige tegn, og det resultat, der returneres, afviger fra det resultat, der opnås via Microsoft Access UI eller DAO.


asynkron forespørgsel <Jet-definition>

asynkron forespørgsel

En type forespørgsel, hvor SQL-forespørgslens resultater returneres med det samme, selvom de endelige resultater stadig er forestående. Herved kan et program fortsætte med andre processer, mens forespørgslen venter på at blive udført.


felt af typen AutoNumber <Jet-definition>

Felt af typen AutoNumber

En feltdatatype, der automatisk gemmer et unikt tal for hver post, når den føjes til en tabel. Et felt af typen AutoNumber bruger altid datatypen Long. Tal, der genereres af et felt af typen AutoNumber, kan ikke redigeres, medmindre der er givet en speciel tilladelse til tabellen enten via GRANT- eller REVOKE-sætningerne i SQL DDL-syntaks. Feltet af typen AutoNumber kaldes også en Counter- eller Identify-datatype. Ved brug af SQL DDL understøtter denne datatype nu også forskellige basis- eller stigningsværdier. Dette er forskellig fra tidligere versioner, hvor basisværdien var 1 og stigningsværdien var 1.

Se også

attributten Identity

basis

stigning


basistabel <Jet-definition>

basistabel

En tabel i en Microsoft® Jet-database. En tabel definerer en relationsdatabases struktur, og den er et objekt, som gemmer data i poster og felter. Du kan manipulere med tabellens struktur ved hjælp af dataadgangsobjekter eller SQL-datadefinitionssætninger (DDL), og du kan redigere i en basistabel ved hjælp af Recordset-objekter eller handlingsforespørgsler.


datatypen Big Integer <Jet-definition>

datatypen Big Integer

En datatype, der lagrer en nøjagtig numerisk værdi med fortegn med præcision 19 (med fortegn) eller 20 (uden fortegn), skala 0 (med fortegn: -263 ≤ n ≤ 263-1; uden fortegn: 0 ≤ n ≤ 264-1).


datatypen Binary <Jet-definition>

datatypen Binary

En datatype, der lagrer binære data med fast længde. Maksimumlængden er 255 byte.


bookmark <Jet-definition>

bookmark

En egenskab i Recordset-objektet, der indeholder en binær streng, som identificerer den aktuelle post. Hvis du tildeler en variabel Bookmark-værdien og derefter går til en anden post, kan du aktivere den tidligere post igen ved at indstille Bookmark til den pågældende strengvariabel.


Boolesk udtryk <Jet-definition>

Boolesk udtryk

Et udtryk, der kan udregnes til enten True eller False.


datatypen Boolean <Jet-definition>

Datatypen Boolean

En værdi af typen True/False eller ja/nej. Booleske værdier gemmes som regel i Bit-felter i en Microsoft® Jet-database, men visse databaser understøtter ikke denne datatype direkte.


datatypen Byte <Jet-definition>

Datatypen Byte

En grundlæggende datatype, der bruges til at opbevare små, positive heltal fra 0 til 255.


Kartesisk produkt <Jet-definition>

Kartesisk produkt

Det resultat, der opstår, når to relationelle tabeller forbindes, og der fremkommer alle mulige ordnede kombinationer af rækker fra den første tabel med alle rækker fra den anden tabel.

Et kartesisk produkt er almindeligvis et resultat af udførelsen af en SQL SELECT-sætning, der henviser til to eller flere tabeller i delsætningen FROM, og som udelukker en delsætning af typen WHERE eller JOIN, der angiver, hvordan tabellerne skal forbindes.


kaskadevis <Jet-definition>

kaskadevis

Den proces, hvor én handling udløser en anden handling. Når f.eks. en kaskadevis opdatering af relationer er defineret for to (eller flere) tabeller, vil en opdatering af den primære nøgle i den primære tabel automatisk udløse (kaskadevise) ændringer i den fremmede tabel.

Kan nu også defineres fra SQL DDL.


kaskadevis sletning <Jet-definition>

kaskadevis sletning

Kaskadevis sletning er en indstilling i forbindelse med relationer, der gennemtvinger referentiel integritet mellem tabeller, og medfører, at en sletning af en post fra den primære tabel automatisk vil omfatte en sletning af alle relaterede poster i den eller de relaterede, fremmede tabeller.

Hvis du f.eks. etablerer en relation mellem en kundetabel (primær) og en ordretabel (fremmed), og kaskadevis sletning er aktiveret, når en post i kundetabellen slettes, slettes også alle de ordrer, der er knyttet til denne kunde, i den fremmede ordretabel.

Kan nu også defineres fra SQL DDL.


kaskadevis opdatering <Jet-definition>

kaskadevis opdatering

Kaskadevis opdatering er en indstilling i forbindelse med relationer, der gennemtvinger referentiel integritet mellem tabeller, der får en ændring af den primære nøgle i en post i den primære tabel til automatisk, at opdatere den fremmede nøgle i alle relaterede poster i den eller de relaterede, fremmede tabeller.

Hvis du f.eks. etablerer en relation mellem en kundetabel (primær) og en ordretabel (fremmed), og kaskadevis opdatering er aktiveret, når en post i kundetabellen ændres, ændres også alle de ordrer, der er knyttet til denne kunde, i ordretabellen.

Kan nu også defineres fra SQL DDL.


kaskadevis NULL <Jet-definition>

kaskadevis NULL

Kaskadevis NULL er en indstilling i forbindelse med relationer, der gennemtvinger referentiel integritet mellem tabeller, der får en slettet række i den primære tabel til automatisk at opdatere den fremmede nøgle i alle relaterede poster i den eller de relaterede, fremmede tabeller med en NULL-værdi.

Kan nu også defineres fra SQL DDL.

Hvis du f.eks. etablerer en relation mellem tabellen Kunder (primær) og tabellen Ordrer (fremmed), og kaskadevis NULL er aktiveret, når den primære nøgle i en post i kundetabellen slettes, ændres også alle de ordrer, der er knyttet til denne kunde, i ordretabellen til at have en NULL-værdi.


skelner mellem store og små bogstaver <Jet-definition>

skelner mellem store og små bogstaver

Skelner mellem store og små bogstaver. En søgning, hvor der skelnes mellem store og små bogstaver, finder kun tekst, der svarer nøjagtigt til de store og små bogstaver. Med en sådan søgning vil f.eks. "ZeroLengthStr" og "zerolengthstr" blive behandlet forskelligt. Handlinger i Microsoft® Jet-databasen skelner ikke mellem store og små bogstaver. Skelnen mellem store og små bogstaver findes dog i andre databasesystemer.


datatypen Char <Jet-definition>

datatypen Char

En datatype, der lagrer en tegnstreng med fast længde. Længden angives af egenskaben Size.


begrænsningen CHECK <Jet-definition>

bekrænsningen CHECK

Et ANSI SQL-92-begreb, der gør det muligt at oprette forretningsregler, der strækker sig over en hel tabel eller flere andre tabeller. Et eksempel herpå kunne være at oprette en kundetabel eller en ordretabel. Ordretabellen kunne have begrænsningen CHECK for at forhindre en kundes ordrer i at overskride den kreditgrænse, der er defineret for kunden i kundetabellen.


klasse <Jet-definition>

klasse

Den formelle definition på et objekt. Klassen fungerer som den skabelon, der bruges til at oprette en forekomst af et objekt under kørsel. Klassen definerer objektets egenskaber og de metoder, der bruges til at kontrollere objektets virkemåde.


batchmarkørbibliotek i klientprogrammet <Jet-definition>

batchmarkørbibliotek i klientprogrammet

Et bibliotek, der understøtter markøren på client-siden i forbindelse med ODBCDirect-databaseprogrammer. Dette bibliotek understøtter alle fire typer markører (nøglesætmarkør, statisk markør, dynamisk markør og fremadrullende markør) og giver et antal andre faciliteter, herunder muligheden for at afbryde forbindelser og udføre begrænsede batchopdateringer.


klynget indeks <Jet-definition>

klynget indeks

Den fysiske rækkefølge af rækker er den samme som den indekserede rækkefølge af rækker.


samling <Jet-definition>

samling

Et objekt, der indeholder et sæt relaterede objekter. Et objekts placering i samlingen kan ændre sig, når der sker en ændring i samlingen. Placeringen af et bestemt objekt i samlingen kan derfor variere.


kollision <Jet definition>

kollision

En konflikt, der opstår under en batchopdatering.

Der opstår en kollisionskonflikt, hvis en klient læser data fra serveren og forsøger at redigere dataene ved hjælp af en batchopdatering, og en anden klient redigerer de oprindelige serverdata, før opdateringen faktisk udføres. I dette tilfælde forsøger den første klient at redigere serverdataene uden at vide, hvilke data der faktisk findes på serveren.


kolonne <Jet-definition>

kolonne

Den visuelle gengivelse af et felt i et net. En kolonne definerer datatypen og størrelsen samt andre attributter i et felt i en række (post) af data. Alle de kolonner, der opfattes som et sæt, definerer en række (post) i databasen. En individuel kolonne indeholder data, der er relateret med hensyn til type og formål gennem hele tabellen. En kolonnes definition ændrer sig således ikke fra række til række.


sporing på kolonneniveau <Jet-definition>

sporing på kolonneniveau

Sporing på kolonneniveau er en mekanisme, hvor hele rækken deltager i definition og løsning af konflikter. Hvis flere end én replika ændrer den samme række, men hver replika ændrer en entydig kolonne, opstår der ikke konflikt, og alle ændringerne sammenflettes.


bekræfte <Jet-definition>

bekræfte

For at acceptere en forestående transaktion. Hvis du benytter transaktionsbehandling og starter en transaktion ved hjælp af DAO, ADO eller SQL, vil ingen af de ændringer, der er foretaget i transaktionen, blive skrevet i databasen, før du bekræfter eller accepterer transaktionen.


sammensat forespørgsel <Jet-definition>

sammensat forespørgsel

En forespørgsel, der er sammensat af mindst én handlingsforespørgsel (en forespørgsel, der kopierer eller ændrer data) og mindst én udvælgelsesforespørgsel (en forespørgsel, der returnerer et Recordset-objekt uden at ændre data). I DAO oprettes en sammensat forespørgsel ved at placere to eller flere SQL-sætninger (adskilt med semikolon (;)) i egenskaben SQL til et QueryDef-objekt.


tilslutningsstreng <Jet-definition>

tilslutningsstreng

En streng, der bruges til at definere datakilden til en ekstern database. I et objekt af typen QueryDef, TableDef, Connection eller Database tildeles tilslutningsstrengen som regel egenskaben Connect, eller den tildeles metoden OpenDatabase som et argument.


konsekvent <Jet-definition>

konsekvent

Den tilstand for et Recordset-objekt med flere tabeller, der giver mulighed for kun at udføre opdateringer, der resulterer i en konsekvent visning af data. I for eksempel et Recordset, der består af en forbindelse mellem to eller flere tabeller (en en-til-mange-relation), vil en konsekvent forespørgsel ikke give dig mulighed for at angive nøglen på mange-siden til en værdi, der ikke findes i tabellen på en-siden.


konstant <Jet-definition>

konstant

Et navngivet element, der bibeholder et konstantværdi igennem hele udførelsen af et program i modsætning til en variabel, hvis værdi kan ændres under udførelsen. Alle værtsprogrammer kan definere egne sæt konstanter. Ekstra konstanter kan defineres af brugeren med Const-sætningen. Konstanter kan bruges over alt i programkode i stedet for faktiske værdier. En konstant kan være en streng eller et numerisk konstanttegn, en anden konstant eller en anden kombination, der omfatter aritmetiske eller logiske operatorer undtagen Is-sætningen og potensopløftning , f.eks.:

Const strdb = "c:\Programfiler \Microsoft Office\Access\Eksmpler\Northwind.mdb"


begrænsning <Jet-definition>

begrænsning

En begrænsning af mulige værdier, brugeren kan indtaste i et felt. Begrænsningen ANSI SQL DDL CHECK er føjet til Microsoft® Jet version 4.X, når der arbejdes via Microsoft OLE DB Provider til Jet. CHECK-brgrænsningen tillader oprettelsen af forretningsregler, der strækker sig over en hel tabel eller flere andre tabeller.


kopieringsbuffer <Jet-definition>

kopieringsbuffer

Et sted, der er oprettet af Microsoft® Jet-databasemotoren, som skal indeholde en post, der er åben for redigering. Metoden Edit kopierer den aktuelle post til kopieringsbufferen, metoden AddNew rydder bufferen til en ny post og angiver standardværdierne, og metoden Update gemmer dataene fra kopieringsbufferen i databasen og erstatter den aktuelle post eller indsætter den nye post. Sætninger, der nulstiller eller flytter den aktuelle postpointer, kasserer kopieringsbufferen. Når du f.eks. bruger metoden MoveNext eller ændrer egenskaben Index i en tabel, kasserer du indholdet i kopieringsbufferen.


korrelationsnavn <Jet-definition>

korrelationsnavn

ANSI-definitionen af et navn, der refererer til en kolonne i en tabel eller en visning (lagret forespørgsel). Også kaldet et aliasnavn.


datatypen AutoNumber <Jet-definition>

datatypen AutoNumber

En feltattribut, der automatisk gemmer et unikt tal for hver post, når den føjes til en tabel. Et Autonummerering-felt anvender datatypen Long, og egenskaben for feltets Attributer er indstillet til dbAutoIncrement. Tal, der genereres af et felt af typen AutoNumber, kan ikke redigeres, medmindre der er givet en speciel tilladelse til tabellen enten via GRANT- eller REVOKE-sætninger i SQL DDL-syntaks. Feltet af typen AutoNumber kaldes også en Counter- eller Identify-datatype.

Bemærk! I forbindelse med replikerede tabeller i replikerede databaser stiger et Autonummerering-felt ikke med 1. Det tildeles derimod en tilfældig værdi mellem -2.000.000.000 og 2.000.000.000.

Se også

Identificere attribut


kriterier <Jet-definition>

kriterier

En række begrænsende betingelser, såsom = "Danmark" (dvs. er lig med Danmark) eller >30000, der bruges til at oprette en forespørgsel eller et filter for at vise et bestemt sæt poster.


krydstabuleringsforespørgsel <Jet-definition>

krydstabuleringsforespørgsel

En forespørgsel, der beregner en sum, et gennemsnit, en sammentælling eller en anden form for opgørelse af poster, og dernæst grupperer resultatet under to typer oplysninger – den ene ned langs venstre side af et net (rækkeoverskrifter) og den anden hen over den øverste del (kolonneoverskrifter). Ordrer efter produkt pr. kvartal i eksempeldatabasen Northwind er f.eks. en krydstabuleringsforespørgsel.


styretegn <Jet-definition>

styretegn

En tastkombination, der starter med CTRL eller ESC.


datatypen Currency <Jet-definition>

datatypen Currency

En datatype, der er nyttig i forbindelse med valutaberegninger, som involverer penge, eller i forbindelse med beregninger med fast komma, hvor det er vigtigt at være meget nøjagtig. Denne datatype anvendes til at gemme tal med op til 15 cifre til venstre for decimalseparatoren og 4 cifre til højre. Da datatypen Currency bruger diskrete værdier for alle beløb, er den binære afrunding ikke en faktor, når du beregner totaler.


aktuel database <Jet-definition>

aktuel database

Objektet Database, der returneres af funktionen CurrentDB( ). En reference for DBEngine.Workspaces(0).Databases(0) returnerer den første database, som blev åbnet. Dette begreb gælder kun for Microsoft® Access.


aktuelt indeks <Jet-definition>

aktuelt indeks

Det indeks i forbindelse med et indekseret Recordset-objekt af typen tabel, der sidst er angivet med egenskaben Index. Dette indeks er grundlaget for sortering af poster i Recordset af typen tabel og bruges af metoden Seek til at finde poster. Et Recordset-objekt kan have mere end ét indeks, men kan kun benytte et indeks ad gangen (selvom der kan være defineret flere indeks i forbindelse med et TableDef-objekt). Microsoft Jet-databasemotoren skal i nogle tilfælde bruge mere end ét indeks for at behandle en forespørgsel.


aktuel post <Jet-definition>

aktuel post

Den post i et Recordset-objekt, som du kan bruge til at redigere eller undersøge data. Du kan bruge Move-metoderne til at anbringe den aktuelle post i et postsæt igen. Du kan bruge Find-metoderne (sammen med et Recordset-objekt af typen dynamisk udvalg eller snapshot) eller metoden Seek (sammen med et Recordset-objekt af typen tabel) til at ændre den aktuelle posts placering i forhold til bestemte kriterier.

Kun én post i et Recordset kan være den aktuelle post, men et Recordset har ikke nødvendigvis en aktuel post. Når f.eks. en Recordset-post af typen dynamisk udvalg er blevet slettet, eller når et Recordset ingen poster har, er den aktuelle post udefineret. I dette tilfælde vil handlinger, der henviser til den aktuelle post, resultere i en fejl, der kan opfanges.


aktuel transaktion <Jet-definition>

aktuel transaktion

Alle de ændringer, der er foretaget i Recordset-objektet, efter at du har brugt den sidste BeginTrans-metode, og før du bruger Rollback- eller CommitTrans-metoden.


DAO (dataadgangsobjekter) <Jet-definition>

DAO (dataadgangsobjekter)

En programmeringsmæssig brugerflade til at åbne og manipulere databaseobjekter.


dataadgangsobjekt <Jet-definition>

dataadgangsobjekt

Et objekt, der defineres af dataadgangsobjektbiblioteket. Du kan bruge dataadgangsobjekter, såsom Database-, TableDef-, Recordset- og QueryDef-objekter, til at repræsentere objekter, der bruges til at organisere og manipulere data, f.eks. tabeller og forespørgsler, i kode.


databasemotor <Jet-definition>

databasemotor

Den del af databasesystemet, der henter data fra og gemmer data i bruger- og systemdatabaser.


DDL (Data Definition Language) <Jet-definition>

DDL (Data Definition Language)

Det sprog, der bruges til at beskrive attributter i en database, især tabeller, felter, indeks og lagerstrategi. ANSI definerer disse til at have tokenerne CREATE, DROP og ALTER.


datadefinitionsforespørgsel <Jet-definition>

datadefinitionsforespørgsel

En SQL-specifik forespørgsel, der kan oprette, ændre eller slette en tabel eller oprette eller slette et indeks i en database. ANSI definerer disse som DDL-forespørgsler og bruger tokenerne CREATE, DROP og ALTER.

Se også

DDL (Data Definition Language)


datakilde <Jet-definition>

datakilde

En navngivet ODBC-ressource (ODBC - Open DataBase Connectivity), der angiver placeringen, drivertypen og andre parametre, der er nødvendige, for at en ODBC-driver kan åbne en ODBC-database. En datakilde kan være en hvilken som helst kilde med databaseoplysninger.


datatype <Jet-definition>

datatype

De karakteristika for en variabel, der bestemmer, hvilken slags data variablen kan indeholde. Datatyper omfatter Big Integer, Binary, Byte, Boolean, Char, Currency, Date, Decimal, Double, Float, GUID, Integer, Long, Long Binary (OLE Objekt), Memo, Numeric, Single, String, Text, Time, TimeStamp, VarBinary, Variant (standard), brugerdefinerede typer (oprettet med Type-sætningen) og objektdatatyper, der omfatter objektdatatyper og dataadgangsobjekttyper, der er defineret af værten.


datokonstant <Jet-definition>

datokonstant

Enhver sekvens af tegn med et gyldigt format, der er omgivet af nummertegn (#). Gyldige formater omfatter det datoformat, der er angivet i landeindstillingerne for koden eller det universelle datoformat.

Datokonstanten #31/12/92# angiver f.eks. datoen den 31. december 1992, hvis landeindstillingen i programmet er angivet til dansk. Datokonstanter bruges, hvis man ønsker de bedste muligheder for at overføre datoformatet til flere sprog.


datoer og klokkeslæt <Jet-definition>

datoer og klokkeslæt

Datoer og klokkeslæt lagres internt som forskellige dele af et reelt tal.

Værdien til venstre for decimalen repræsenterer en dato fra og med 30. december 1899 til og med 31. december 9999. Negative værdier angiver datoer før den 30. december 1899.

Værdien til højre for decimalen angiver et tidspunkt fra og med 0:00:00 til og med 23:59:59. Middag gengives af .5.


datatypen Decimal <Jet-definition>

datatypen Decimal

En datatype, der lagrer en eksakt numerisk værdi med fortegn med præcision p og skala s (1 ≤ p ≤15; 0 ≤ s ≤ p).


standardarbejdsområde <Jet-definition>

standardarbejdsområde

Det Workspace-objekt, som DAO automatisk opretter, når programmet første gang henviser til et dataadgangsobjekt. Der henvises til dette Workspace med DBEngine.Workspaces(0) eller bare Workspaces(0).


sletteforespørgsel <Jet-definition>

sletteforespørgsel

En handlingsforespørgsel, der sletter et sæt rækker, der opfylder de kriterier, du angiver. En sletteforespørgsel returnerer ikke rækker.


under design <Jet-definition>

under design

Den tid, du bruger på at bygge et program i udviklingsmiljøet, ved at tilføje kontrolelementer, angive kontrolelement- eller formularegenskaber osv. Under kørsel bruger du derimod programmet, som en bruger ville gøre det.


destinationsfelt <Jet-definition>

destinationsfelt

Et felt i en forespørgsel, der indeholder resultaterne af forespørgslen.


direkte synkronisering <Jet-definition>

direkte synkronisering

En type synkronisering, der finder sted, når de to replikaer kan åbnes på samme tid under synkroniseringen.


DLL (dynamic-link library) <Jet-definition>

DLL (dynamic-link library)

Et bibliotek med procedurer, som kan kaldes fra procedurer, og som indlæses i og sammenkædes med programmer under kørsel.


datatypen Double <Jet-definition>

datatypen Double

En grundlæggende datatype, der indeholder reelle tal med dobbelt præcision i IEEE-format. En Double-variabel lagres som et 64 bit-tal (8-byte), der strækker sig i værdi fra -1.79769313486231E308 til -4.94065645841247E-324 for negative værdier, og fra 4.94065645841247E-324 til 1.79769313486231E308 for positive værdier og 0.


dynamisk markør <Jet-definition>

dynamisk markør

Et dynamisk sæt rækker, du kan bruge til at tilføje, ændre eller slette rækker i en eller flere underliggende databasetabeller. En dynamisk markør kan indeholde kolonner fra en eller flere tabeller i en database. Medlemskab er ikke fast.


dynamisk udvalg <Jet-definition>

dynamisk udvalg

En type Recordset-objekt, der returnerer et dynamisk sæt pointere til "rigtige" databasedata. Ligesom et Recordset af typen tabel eller snapshot vil et dynamisk udvalg returnere data i poster (rækker) og felter (kolonner). Til forskel fra et Recordset af typen tabel kan et Recordset af typen dynamisk udvalg være resultatet af en forespørgsel, der forbinder to eller flere tabeller. Posterne i Recordset-objekter af typen dynamisk udvalg kan opdateres, hvis Recordset-egenskaben Updatable er True, hvis det Field, der ændres, kan opdateres, og hvis den dataside, der indeholder den aktuelle post, ikke er låst. Datasiden er låst, hvis Update-metoden bruges (når egenskaben for LockEdits er False), eller Edit-metoden bruges (når egenskaben for LockEdits er True).


lighedsjoinforbindelse <Jet-definition>

lighedsjoinforbindelse

En joinforbindelse, hvor poster fra to tabeller forbindes og kun tilføjes til Recordset-objektet, når de joinforbundne felter indeholder de samme værdier. Kaldes også en indre joinforbindelse.


udelt adgang <Jet-definition>

udelt adgang

En adgangstype, som beskytter data i en database, der deles i et netværk. Hvis du åbner en database i udelt tilstand, forhindrer du andre i at åbne databasen.


udtryk <Jet-definition>

udtryk

Alle de kombinationer af operatorer, konstanter, konstanttegnværdier, funktioner og navne på felter, kontrolelementer og egenskaber, der udregnes til en enkelt værdi. Du kan bruge udtryk, som indstillinger for mange egenskaber og handlingsargumenter, til at angive kriterier eller definere beregnede felter i forespørgsler.


ekstern database <Jet-definition>

ekstern database

Enten en ODBC-database, såsom en Microsoft® SQL Server™, der ligger på en fjernserver, eller en af de eksterne databaser, såsom Paradox, dBASE, Microsoft FoxPro®,Microsoft Excel, Microsoft Access, Lotus 1-2-3, HTML og Text.


ekstern tabel <Jet-definition>

ekstern tabel

En tabel i en database uden for den åbne Microsoft® Jet-database. En ekstern tabel kan have samme form som en anden fil, eller den kan være en tabel i en anden relationsdatabase.


felt <Jet-definition>

felt

En kategori af oplysninger, der gemmes i en tabel i en database – en kolonne med data. Et element i en databasetabel, der indeholder en bestemt oplysning, såsom efternavn.


feltegenskaber <Jet-definition>

feltegenskaber

Attributter til et felt, der bestemmer, hvilken slags data feltet indeholder. Eksempler på dette er Størrelse og Type.


filter <Jet-definition>

filter

En række kriterier, der anvendes på poster for at oprette et delsæt af posterne.


datatypen Float <Jet-definition>

datatypen Float

En datatype, der lagrer en gennemsnitslig numerisk værdi med fortegn med mantissepræcision 15 (nul eller en absolut værdi fra 10-308 til 10308).


fremmed nøgle <Jet-definition>

fremmed nøgle

Et eller flere tabelfelter, der henviser til det eller de primære nøglefelter i en anden tabel. En fremmed nøgle viser, hvordan tabellerne er relaterede – data i fremmede nøglefelter og primære nøglefelter skal stemme overens. En liste over gyldige varenumre vil f.eks. indeholde en fremmed nøgle til en lagerbeholdningstabel, der indeholder referencer til gyldige varenumre. Anvendes til at etablere referentiel integritet for en database.


fremmed tabel <Jet-definition>

fremmed tabel

En tabel, der stiller en fremmed nøgle til rådighed for en anden tabel i databasen. Du kan generelt bruge en fremmed tabel til at etablere eller gennemtvinge referentiel integritet. Den fremmede tabel er som regel på mange-siden i en en-til-mange-relation. Et eksempel på en fremmed tabel er en tabel over kundeordrer.


formular <Jet-definition>

formular

Et vindue eller en dialogboks. Formularer er objektbeholdere for kontrolelementer. En MDI-formular (MDI - multiple-document interface) kan også fungere som en beholder for underordnede formularer og visse kontrolelementer.


fremadrullende markør <Jet-definition>

fremadrullende markør

Et resultatsæt, hvor den aktuelle position kun kan flyttes frem et angivet antal poster eller til den sidste post. Den aktuelle postion kan ikke flyttes tilbage til begyndelsen af resultatsættet eller til tidligere poster. Markørmedlemskab, -orden og -værdier fastlægges normalt, når markøren åbnes. Hvis andre brugere opdaterer, sletter eller indsætter rækker, afspejler markøren ikke disse ændringer, før du lukker og åbner den igen.


rulle fremad <Jet-definition>

rulle fremad

Flytter hen til slutningen (EOF) af Recordset-objektet.


fremadrullende snapshot <Jet-definition>

fremadrullende snapshot

Et Recordset-objekt af typen snapshot, hvor du kun kan søge efter poster fra begyndelsen til slutningen. Den aktuelle postplacering kan ikke flyttes tilbage til den første post. Fremadrullende snapshop reducerer behandlingstiden i fjerndatabaser. Du kan f.eks. bruge et fremadrullende snapshot i en tilknyttet fjerntabel til hurtigt at behandle data i en handling, f.eks. når du opretter en brugerdefineret rapport.


FTP <Jet-definition>

FTP

File Transfer Protocol. En protokol, der gør det muligt for en bruger at overføre filer fra et sted til et andet via Internet. URL-adresser til filer på FTP-servere starter med ftp://.


proceduren Function <Jet-definition>

proceduren Function

En procedure, der udfører en bestemt opgave i et Microsoft® Visuel Basic®-baseret program og returnerer en værdi. En Function-procedure begynder med en Function-sætning og slutter med en End Function-sætning.


gruppe <Jet-definition>

gruppe

En samling af brugerkonti i Workgroup-objektet, der identificeres med gruppenavn og et personligt ID (PID). Tilladelser, der tildeles en gruppe, gælder for alle brugerne i en gruppe.


datatypen GUID <Jet-definition>

datatypen GUID

Globally Unique Identifier/Universally Unique Identifier. En unik identifikationsstreng, der bruges i forbindelse med fjerne procedurekald. Hver grænseflade og objektklasse bruger en GUID som identifikation. En GUID er en 128-bitværdi. 12345678-1234-1234-1234-123456789ABC er f.eks. en syntaktisk korrekt GUID. GUID'erne i klienten og serveren skal passe sammen, for at klienten og serveren kan forbindes. Forhandlere af OLE-objekter kan anmode om, at Microsoft udleverer et eller flere sæt 256-GUID, som de alene må bruge. Hvis du har et netværkskort, kan du køre en funktion, der kaldes Uuidgen.exe, som giver et sæt 256 GUID, der er baseret på det tidspunkt af dagen, den dato og det unikke tal, som er indeholdt i netværkskortet.


HTTP <Jet-definition>

HTTP

Hypertext Transfer Protocol. Den bagvedliggende protokol til Internet, der leverer oplysninger via World Wide Web. Protokollen gør det muligt for en bruger at anvende et klientprogram til at indtaste en URL-adresse (eller klikke på en hyperlink) og hente tekst, grafik, lyd og andre digitale oplysninger fra en Web-server. URL-adresser til filer på Web-servere starter med http://.


datatypen Hyperlink <Jet-definition>

datatypen Hyperlink

En feltdatatype, du bruger til felter, der lagrer hyperlinks. Hyperlink-felter indeholder tekst og kombinationer af tekst og tal lagret som tekst, der bruges som en hyperlink-adresse. En hyperlink-adresse kan indeholde op til tre dele (hver del kan indeholde op til 2.048 tegn og bruger følgende syntaks:

vistekst#adresse#underadresse


attributten Identity <Jet-definition>

attributten Identity

Tilføjes for at tillade ækvivalent syntaks i forhold til SQL-server. Er kun tilgængelig, når du bruger SQL DDL fra Microsoft® OLE DB Provider til Jet. Denne datatype har samme funktioner som datatyperne Counter og AutoNumber. Det er et synonym og har ingen andre funktioner.

Se også

feltet AutoNumber


inkonsekvent <Jet-definition>

inkonsekvent

Den tilstand i et Recordset-objekt med flere tabeller, som gør det muligt at opdatere alle felter (kolonner). I et Recordset, der er oprettet ved at joinforbinde to tabeller i en en-til-mange-joinforbindelse (som i tabellen Kunder eller Ordrer), kan du f.eks. opdatere Ordrer.Kunde-ID, så den ikke svarer til Kunder.Kunde-ID, medmindre referentiel integritet slår opdateringen fra.


stigning <Jet-definition>

stigning

Valgfri parameter, der bruges sammen med datatyperne Counter eller Identity. Er kun tilgængelig i SQL DDL, når du bruger Microsoft® OLE DB Provider til Jet. Dette er den værdi, der bruges til at tildele den næste værdi til en ny række i en tabel, der indeholder en Counter- eller Identity-datatype. Stigning er den anden af de to valgfri parametre til datatyperne Counter eller Identity.

Se også

basis


indeks <Jet-definition>

indeks

En dynamisk krydsreference på et eller flere tabeldatafelter (kolonner), der giver mulighed for hurtigt at hente bestemte poster fra en tabel. Efterhånden som poster tilføjes, ændres eller slettes, vil databasestyringssystemet automatisk opdatere indekset, så det afspejler ændringerne.

Når det aktuelle indeks anvendes sammen med et Recordset-objekt af typen tabel, bestemmer det den rækkefølge, som dataposter returneres i til Recordset. En tabel kan indeholde flere indeks til de tilhørende data.

Et DAO-Indeks-object repræsenterer et indeks for et TableDef-objekt.


indirekte synkronisering <Jet-definition>

indirekte synkronisering

En type synkronisering, der finder sted, når et Synchronizer-program efterlader ændringer i en mappe til en rulleliste, som et andet Synchronizer-program kan hente og anvende på den replika, som den styrer.


indre joinforbindelse <Jet-definition>

indre joinforbindelse

En joinforbindelse, hvor poster fra to tabeller kun er forbundet og føjet til et Recordset, hvis værdien i de joinforbundne felter opfylder en bestemt betingelse. En lighedsjoinforbindelse er f.eks. en indre joinforbindelse, hvor værdierne i de joinforbundne felter skal være ens.


installerbar ISAM <Jet-definition>

installerbar ISAM

En driver, du kan angive, og som giver dig adgang til eksterne databaseformater, såsom dBASE, Microsoft® Excel og Paradox. ISAM er akronym for Indexed Sequential Access Method. Microsoft Jet-databasemotoren installerer (indlæser) disse ISAM-drivere, når programmet henviser til dem. Placeringen af disse drivere vedligeholdes i Microsoft Windows®-registreringsdatabasen.


forekomst <Jet-definition>

forekomst

Hvert enkelt sæt objekter, der befinder sig i samme klasse. Flere forekomster af en Form-klasse har f.eks. samme kode og indlæses med samme kontrolelementer, som Form-klasse er udformet med. Under kørsel, kan de enkelte egenskaber til kontrolelementer i hver forekomst angives til forskellige værdier.


datatypen Integer <Jet-definition>

datatypen Integer

En grundlæggende datatype, der indeholder heltal. En Integer-variabel gemmes som et 16-bit tal (2-byte), der i værdi strækker sig fra -32.768 til 32.767.


Internet <Jet-definition>

Internet

Et verdensomspændende netværk med tusinder af mindre computernetværk og millioner af computere, der bruges i erhvervslivet, inden for uddannelsessektoren, i offentlige institutioner og privat. Internet er ligesom en elektronisk by med virtuelle biblioteker, udstillingsvinduer, firmakontorer, kunstgallerier osv.


Internet-synkronisering <Jet-definition>

Internet-synkronisering

En type synkronisering, der er baseret på en række meddelelsesudvekslinger mellem replikaer, der placeres i en mappe til en rulleliste. Kun de replikaer, der styres af Synchronizer-programmet på Internet Server, har en rulleliste. Du får adgang til denne rulleliste med en HTTP- eller FTP-forbindelse.


intranet <Jet-definition>

intranet

Et netværk i et firma, der bruger funktioner i Internet (såsom HTTP- eller FTP-protokollerne). Du kan bruge et intranet til at styre mellem objekter, dokumenter, Web-sider og andre destinationer ved hjælp af hyperlinks.


indbygget konstant <Jet-definition>

indbygget konstant

En konstant, der foreligger i et program. Konstanter til dataadgangsobjekter er f.eks. anført i biblioteket til dataadgangsobjekter og kan vises med Objektoversigt.


Microsoft Jet-tilsluttet ODBC-datakilde <Jet-definition>

Microsoft Jet-tilsluttet ODBC-datakilde

En ODBC-datakilde, der åbnes ved hjælp af DAO (dataadgangsobjekter) og Microsoft® Jet-databasemotoren.


joinforbindelse <Jet-definition>

joinforbindelse

En databasehandling, der kombinerer nogle eller alle poster fra to eller flere tabeller, såsom en lighedsjoinforbindelse, en indre joinforbindelse, en ydre joinforbindelse eller en selvjoinforbindelse. En joinforbindelse henviser som regel til en forbindelse mellem et felt i én tabel og et felt af samme datatype i en anden tabel. Du opretter en joinforbindelse ved hjælp af en SQL-sætning.

Når du definerer en relation mellem to tabeller, kan du oprette en joinforbindelse ved at angive de primære og fremmede tabel-felter. Når du tilføjer en tabel til en forespørgsel, skal du oprette en joinforbindelse mellem de rette felter i den SQL-sætning, der definerer forespørgslen.


nøglesætmarkør <Jet-definition>

nøglesætmarkør

Et sæt rækker, du kan bruge til at tilføje, ændre eller slette rækker i en eller flere underliggende databasetabel eller -tabeller. Flytning i nøglersættene er ubegrænset. En nøglesætmarkør kan indeholde kolonner fra en eller flere tabeller i en database. Medlemskab er fast.


venstre joinforbindelse <Jet-definition>

venstre joinforbindelse

En venstre ydre joinforbindelse medtager alle posterne fra den første (venstre) af to tabeller, selvom der ikke findes værdier for poster i den anden (højre) tabel.


venstre ydre joinforbindelse <Jet-definition>

venstre ydre joinforbindelse

En ydre joinforbindelse, hvor alle posterne fra den venstre side af handlingen LEFT JOIN i forespørgslens SQL-sætning tilføjes til Recordset-objektet, selvom der ikke findes nogen tilsvarende værdier i det joinforbundne felt fra tabellen til højre. Poster fra tabellen til højre forbindes kun med posterne fra tabellen til venstre, når der findes tilsvarende værdier i de joinforbundne felter. Når en post til venstre ikke har nogen tilsvarende værdi, joinforbindes en række nulværdier i højre side.


sammenkædet tabel <Jet-definition>

sammenkædet tabel

En tabel i en anden database, der er sammenkædet med en Microsoft® Jet-database. Data for tilknyttede tabeller bliver i den eksterne database, hvor andre programmer kan arbejde med dem. Tidligere kendt som tilknyttede tabeller.


låst <Jet-definition>

låst

Betingelsen for en dataside, et Recordset-objekt eller et Database-objekt, der skrivebeskytter dem over for alle brugere med undtagelse af den bruger, der aktuelt indtaster data.


datatypen Long Binary <Jet-definition>

datatypen Long Binary

En felttype, der kan indeholde 2,14 GB data. Felter af typen Long Binary kan indeholde enhver binær datatype. Også kendt som datatypen OLE-Object i Microsoft® Access.


datatypen Long <Jet-definition>

datatypen Long

En grundlæggende datatype, der indeholder dobbelte heltal. Long -variablen gemmes som et 32 bit-tal (4-byte), der strækker sig i værdi fra -2.147.483.648 til 2.147.483.647.


tabeloprettelsesforespørgsel <Jet-definition>

tabeloprettelsesforespørgsel

En handlingsforespørgsel, der opretter en ny tabel fra et Recordset-objekt i en eksisterende forespørgsel.


kun-mange-tabel <Jet-definition>

kun-mange-tabel

En tabel, der ikke fremstår som en-siden i en joinforbindelse i en forespørgsel.


datatypen Memo <Jet-definition>

datatypen Memo

En feltdatatype. Sådanne felter kan indeholde op til 2,14 GB data.


meddelelse <Jet-definition>

meddelelse

En række oplysninger, der overføres fra et program til et andet.


metode <Jet-definition>

metode

En procedure, som svarer til en funktion, der fungerer i bestemte objekter.


Microsoft Jet-database <Jet-definition>

Microsoft Jet-database

En database, der er oprettet med Microsoft® Jet-databasemotoren. Filtypenavnet til en Microsoft Jet-database er .mdb.


Microsoft Jet-arbejdsområde <Jet-definition>

Microsoft Jet-arbejdsområde

Et arbejdsområde, der bruger Microsoft® Jet-databasemotoren til at åbne en datakilde. Datakilden kan være en Microsoft Jet-databasefil (.mdb), en ODBC-database, såsom en Paradox-database eller en ISAM-database.


feltdatatyper <Jet-definition>

feltdatatyper

Følgende tabel viser feltdatatyperne.

DAO-feltdatatype | Konstant
Big Integer | DbBigInt
Binary | DbBinary
Boolean | DbBoolean
Byte | DbByte
Char | DbChar
Currency | DbCurrency
Date/Time | DbDate
Decimal | DbDecimal
Double | DbDouble
Float | DbFloat
GUID | DbGUID
Integer | DbInteger
Long | DbLong
Long Binary (OLE-objekt) | DbLongBinary
Memo | DbMemo
Numeric | DbNumeric
Single | DbSingle
Text | DbText
Time | DbTime
TimeStamp | DbTimeStamp
VarBinary | DbVarBinary


Microsoft Jet-databasemotor <Jet-definition>

Microsoft Jet-databasemotor

Et databasestyringssystem, der henter data fra og gemmer dem i bruger- og systemdatabaser. Microsoft® Jet-databasemotoren kan opfattes som et datastyringselement, som andre dataadgangssystemer, såsom Microsoft Access og Visual Basic®, kan opbygges sammen med.


flerbrugerdatabase <Jet-definition>

flerbrugerdatabase

En database, der giver mere end én bruger mulighed for adgang til og redigering af samme sæt data samtidig. I nogle tilfælde kan den anden bruger være en anden del af programmet eller et andet program, der kører i systemet, og som har adgang til de samme data som et andet program.


normalisere <Jet-definition>

normalisere

At minimere dublerede oplysninger i en relationsdatabase ved hjælp af et effektivt tabeldesign.


Null <Jet-definition>

Null

En værdi, der angiver manglende eller ukendte data. Null-værdier kan indtastes i felter, du ikke har oplysningerne om, samt i udtryk og forespørgsler. I Visual Basic angiver det reserverede ord Null en Null-værdi. Nogle felter, såsom dem, der indeholder den primære nøgle, kan ikke indeholde Null-værdier.


nulværdifelt <Jet-definition>

nulværdifelt

Et felt, der ikke indeholder tegn eller værdier. Et nulværdifelt er ikke det samme som en streng af længden nul ("") eller et felt med værdien 0. Et felt angives til nul, når indholdet af feltet er ukendt. Feltet Dato afsluttet i en opgavetabel indeholder f.eks. en nulværdi, indtil en opgave er udført.


datatypen Numeric <Jet-definition>

datatypen Numeric

En datatype, der lagrer en eksakt numerisk værdi med fortegn med præcision p og skala s (1 ≤ p ≤15; 0 ≤ s ≤ p).


numerisk udtryk <Jet-definition>

numerisk udtryk

Ethvert udtryk, der kan udregnes som et tal. Numeriske udtryk kan omfatte alle kombinationer af variabler, konstanter, funktioner og operatorer, der evalueres til et tal.


Objektoversigt <Jet-definition>

Objektoversigt

En dialogboks, du kan anvende til at undersøge indholdet af et objektbibliotek for at få oplysninger om de leverede objekter.


objektudtryk <Jet-definition>

objektudtryk

Et udtryk, der angiver et bestemt objekt. Dette udtryk kan omfatte alle objektbeholderne. Hvis programmet f.eks. har et Application-objekt, der indeholder et Document-objekt, som indeholder et Text-objekt, er følgende udtryk gyldige objektudtryk:

Application.Document.Text

Application.Text

Document.Text

Text


objektbibliotek <Jet-definition>

objektbibliotek

Et DLL-bibliotek (DLL – Dynamic Link Library) med en eller flere typer biblioteksressourcer, der typisk har filtypenavnet .olb. Du kan bruge Objektoversigt til at undersøge indholdet af et objektbibliotek for at få oplysninger om de tilgængelige objekter.


objektvariabel <Jet-definition>

objektvariabel

En variabel, der indeholder en reference til et objekt.


ODBC (Open Database Connectivity) <Jet-definition>

ODBC (Open Database Connectivity)

En standardprotokol, der giver programmer mulighed for at få forbindelse til adskillige eksterne databaseservere eller filer. ODBC-drivere, der bruges af Microsoft® Jet-databasemotoren, giver adgang til Microsoft SQL Server™ og flere andre eksterne databaser.

Med API (Application Programming Interface) i ODBC kan du også få adgang til ODBC-drev og de databaser, de er forbundet til, uden brug af Microsoft Jet-databasemotoren.


ODBC-datakilde <Jet-definition>

ODBC-datakilde

En betegnelse, som bruges til at referere til en database eller databaseserver, der er brugt som datakilde. Der refereres til ODBC-datakilder ved datakildenavnene (DSN). Du kan oprette datakilder ved hjælp af Microsoft® Windows® Kontrolpanel eller RegisterDatabase-metoden.


ODBC-drivere <Jet-definition>

ODBC-drivere

Et DLL-bibliotek (DLL – Dynamic Link Library), der bruges til at forbinde en bestemt ODBC-datakilde med et andet klientprogram.


ODBC-driverstyring <Jet-definition>

ODBC-driverstyring

Et program, der styrer forbindelserne mellem ODBC-aktiverede datakilder og de drivere, der bruges for at få adgang til dem.


OLE (Object Linking and Embedding) <Jet-definition>

OLE (Object Linking and Embedding)

Objektsammenkædning og -integrering i Microsoft-programmer. Den teknologi, der giver dig mulighed for at oprette programmer, som indeholder komponenter fra diverse andre programmer.


ActiveX-objekt <Jet-definition>

ActiveX-objekt

Et objekt, der benyttes af andre programmer eller programmeringsværktøjer via Automation-grænseflader (tidligere OLE Automation-grænseflader). I Microsoft® Access kan du f.eks. oprette og manipulere Microsoft ActiveX®-objekter fra Microsoft Word eller Microsoft Excel.


datatypen OLE Object <Jet-definition>

datatypen OLE Object

En feltdatatype, du bruger i forbindelse med objekter, der er oprettet i andre programmer, som kan sammenkædes med eller integreres i en Microsoft® Jet-database. Du kan f.eks. bruge et felt af typen OLE Object for at lagre en samling billeder.


en-til-mange-relation <Jet-definition>

en-til-mange-relation

En forbindelse mellem to tabeller, hvor:

  • Den primære nøgle-værdi i hver post i den primære tabel svarer til værdien i det eller de tilsvarende felter i mange poster i den relaterede tabel.
  • Den primære nøgle-værdi i hver post i den relaterede tabel svarer til værdien i det eller de tilsvarende felter med én og kun en post i den primære tabel.


en-til-en-relation <Jet-definition>

en-til-en-relation

En forbindelse mellem to tabeller, hvor:

  • Den primære nøgle-værdi i hver post i den primære tabel svarer til værdien i det eller de tilsvarende felter med én og kun én post i den relaterede tabel.
  • Den primære nøgle-værdi i hver post i den relaterede tabel svarer til værdien i det eller de tilsvarende felter med én og kun en post i den primære tabel.


begrænset <Jet-definition>

begrænset

En type låsning, hvor den dataside, der indeholder en eller flere poster, herunder den post, der aktuelt redigeres, kun er utilgængelig for andre brugere, mens posten opdateres af metoden Update, men er tilgængelig mellem metoderne Edit og Update. Begrænset låsning anvendes, når du åbner ODBC-databaser, eller når egenskaben LockEdits i Recordset-objektet er angivet til False.


ydre joinforbindelse <Jet-definition>

ydre joinforbindelse

En joinforbindelse, hvor alle posterne fra en tabel tilføjes Recordset-objektet, selvom der ikke findes nogen tilsvarende værdier i det joinforbundne felt fra den anden tabel. Poster fra den anden tabel kombineres kun med dem fra den første tabel, når der er tilsvarende værdier i de joinforbundne felter. Null-poster joinforbindes, når der ikke findes tilsvarende værdier.


side <Jet-definition>

side

En del af databasen, hvor postdata gemmes. Alt afhængigt af posternes størrelse kan en side indeholde mere end én post. I Microsoft® Jet-databaser (.mdb) er længden på en side 2.048 byte (2 KB). Jet 4.X-filformater har en 4 KB-side (4096 byte).


parameter <Jet-definition>

parameter

Et element, der indeholder en værdi, du kan ændre, så den påvirker resultatet i en forespørgsel. En forespørgsel, der returnerer data om en medarbejder, kan f.eks. indeholde en parameter for medarbejderens navn. Du kan derefter bruge ét QueryDef-objekt til at finde data om hver medarbejder ved at angive parameteren til et bestemt navn, før du kører forespørgslen.

Med Microsoft® OLE DB Provider til Jet i Microsoft Jet version 4.X kan parametre vises med procedurer ved hjælp af ANSI-spørgsmålstegnets (?) parametermærker. Med SQL-syntaks kan du oprette ækvivalenten til en QueryDef.


parameterforespørgsel <Jet-definition>

parameterforespørgsel

En forespørgsel, der beder dig om en eller flere kriterieværdier, såsom Århus for Bynavn, før forespørgslen køres. En parameterforespørgsel er egentlig ikke en separat type forespørgsel. Den udvider snarere andre forespørgslers fleksibilitet.

Med Microsoft® OLE DB Provider til Jet i Microsoft Jet version 4.X kan parametre vises med procedurer ved hjælp af ANSI-spørgsmålstegnets (?) parametermærker. Med SQL-syntaks kan du oprette ækvivalenten til en QueryDef.


parse <Jet-definition>

parse

At identificere delene i en sætning eller i et udtryk og derefter validere disse dele i forhold til de rette sproglige regler.


delvis replika <Jet-definition>

delvis replika

En database, der kun indeholder et delsæt af posterne i en fuldstændig replika. Med en delvis replika kan du angive filtre og identificere relationer, der definerer, hvilket delsæt af posterne i den fuldstændige replika der bør være i databasen.


videregivelsesforespørgsel <Jet-definition>

videregivelsesforespørgsel

En SQL-specifik forespørgsel, du anvender til at sende kommandoer direkte til en SQL-databaseserver (såsom Microsoft® SQL Server™). Med videregivelsesforespørgsler arbejder du med tabellerne på serveren i stedet for at sammenkæde dem. Videregivelsesforespørgsler bruges til at udføre SQL-forespørgsler og system-specifikke kommandoer, der er skrevet ved hjælp af SQL-sprogbrug, som kun kendes af serveren.

En videregivelsesforespørgsel kan enten returnere poster eller ej. Hvis den gør det, returneres posterne altid i snapshot.


tilladelse <Jet-definition>

tilladelse

Et eller flere attributter, der angiver, hvilken slags adgang brugeren har til data eller objekter i en database. Hvis en bruger har en Læse data-tilladelse til en tabel eller forespørgsel, kan brugeren f.eks. læse eller hente, men ikke redigere data i tabellen eller forespørgslen.


fast objekt <Jet-definition>

fast objekt

Et objekt, der er lagret i databasen, f.eks. en databasetabel eller et QueryDef-objekt. Recordset-objekter af typen dynamisk udvalg eller snapshot opfattes ikke som faste objekter, fordi de oprettes i hukommelsen efter behov.


fuldstændig <Jet-definition>

fuldstændig

En type låsning, hvor den dataside, der indeholder en eller flere poster, herunder den post, som aktuelt redigeres, er ikke tilgængelig for andre brugere, når du anvender metoden Edit og forbliver ikke-tilgængelig, indtil du anvender metoden Update. Fuldstændig låsning aktiveres, når egenskaben LockEdits i Recordset-objektet er angivet til True.


personligt ID (PID) <Jet-definition>

personligt ID (PID)

En alfanumerisk streng, der skelner mellem store og små bogstaver. Strengen indeholder 4-20 tegn, og Microsoft® Jet-databasemotoren anvender den i forbindelse med kontonavnet for at identificere en bruger eller gruppe i et Workgroup-objekt. Du angiver PID'et og kontonavnet, når du opretter en ny bruger eller gruppe.


primær nøgle <Jet-definition>

primær nøgle

Et eller flere felter, hvis værdi eller værdier unikt identificerer hver post i en tabel. I en relation bruges en primær nøgle til at referere til bestemte poster i én tabel fra en anden tabel. En primær nøgle kaldes en fremmed nøgle, når den refereres til fra en anden tabel. Du kan kun have én primær nøgle. I en Medarbejder-tabel kan den primære nøgle f.eks. være CPR-nummeret.


primær tabel <Jet-definition>

primær tabel

En-siden af to relaterede tabeller i en en-til-mange-relation med en fremmed tabel. En primær nøgle-tabel bruges som regel til at etablere eller gennemtvinge referentiel integritet.


prioritet <Jet-definition>

prioritet

En lang værdi, der angiver replikaens prioritet, til brug under konfliktløsninger. En gyldig prioriteringsværdi for en global replika ligger mellem fra og med 0 og til og med 100. Lokale og anonyme replikaer har altid prioriteten 0. Hvis en konflikt opstår under synkronisering, vinder replikaen med den højeste prioritet. De data, der tabte, logges i konflikttabellen.


procedure <Jet-definition>

procedure

Ligner en visning, bortset fra at SQL-syntaksen tillader SELECT-sætninger (forespørgsler, der returnerer en række) at sende parametre og DML (forespørgsler, der ikke returnerer rækker) UPDATE, INSERT, DELETE og SELECT INTO. Stort set det samme som en forespørgselsdefinition, bortset fra at den kan oprettes med SQL-syntaks uden brug af DAO-objektmodellen.


procedural forespørgsel <Jet-definition>

procedural forespørgsel

En SQL-sætning, der udfører en lagret procedure.


egenskab <Jet-definition>

egenskab

Et navngivet attribut i et objekt. Egenskaber definerer objektkarakteristika, såsom størrelse, farve og skærmplacering, eller et objekts tilstand, såsom aktiveret eller deaktiveret.


pseudoindeks <Jet-definition>

pseudoindeks

En dynamisk krydsreference til en eller flere tabeldatafelter (kolonner), der gør det muligt at redigere en ODBC-tabel (servertabel) uden et unikt indeks. Et pseudoindeks er ikke et egentligt indeks i servertabellen, men en krydsreference, som Microsoft® Jet-databasemotoren kan anvende til at understøtte tabelopdateringer. Et pseudoindeks er kun nødvendigt, hvis en ODBC-tabel ikke indeholder et unikt indeks, der gør det muligt at opdatere tabellen. Et pseudoindeks er ikke nødvendigt, hvis tabellen allerede har et unikt indeks, eller hvis der ikke er behov for at opdatere tabellen. Tabeller kan ikke indeholde et unikt indeks, hvis de skulle have været skrivebeskyttede. I tidligere versioner blev pseudoindekser kaldt indeksspecifikationer.


forespørgsel <Jet-definition>

forespørgsel

En formaliseret instruktion til en database til enten at returnere et sæt poster eller udføre en angivet handling i et sæt poster, som angivet i forespørgslen. Følgende SQL-forespørgselssætning returnerer f.eks. poster:

SELECT Firmanavn FROM Udgivere WHERE Område = 'NY'

Du kan oprette og køre udvælgelses-, handlings-, krydstabulerings- og parameterforespørgsler samt SQL-specifikke forespørgsler.


skrivebeskyttet <Jet-definition>

skrivebeskyttet

En form for adgang til data, hvor oplysninger kan hentes, men ikke redigeres.


post <Jet-definition>

post

Et sæt af relaterede data om en person, et sted, en begivenhed eller andre oplysninger. Tabeldata lagres i poster (rækker) i databasen. Hver post består af et sæt relaterede felter (kolonner). Hvert felt definerer én oplysningsattribut for posten. Alt i alt definerer en post en bestemt del af oplysninger i en database, der kan hentes.

En post kaldes også en række.

Se også

række


referentiel integritet <Jet-definition>

referentiel integritet

Regler, du fastsætter for at etablere og bevare relationer mellem tabeller, når du tilføjer, ændrer eller sletter poster. Hvis du gennemtvinger referentiel integritet, forhindrer du, at brugere tilføjer poster til en joinforbundet tabel, som ikke indeholder en primær nøgle, ændrer værdier i en primær tabel, der ville resultere i poster, der ikke længere har en relation til en tabel, og sletter poster fra en primær tabel, når der er tilsvarende relaterede poster.

Hvis du vælger dbRelationDeleteCascade eller dbRelationCascade for en relation, giver Microsoft® Jet-databasemotoren mulighed for ændringer eller sletninger, men ændrer eller sletter relaterede poster for at sikre sig, at reglerne stadig er i kraft.

Microsoft Jet version 4.X viser via Microsoft OLE DB Provider til Jet et meget rigere ANSI SQL-sæt, og viser også den referentielle ANSI kaskadevise NULL-handling.


relation <Jet-definition>

relation

En forbindelse, der er oprettet mellem fælles felter (kolonner) i to tabeller. En relation kan være en-til-en, mange-til-mange eller en-til-mange.


genforespørge <Jet-definition>

genforespørge

At køre en forespørgsel igen for at afspejle ændringer i posterne, hente nyligt tilføjede poster og fjerne slettede poster.


reserveret ord <Jet-definition>

reserveret ord

Et ord, som er en del af et sprog, såsom SQL-sproget i Microsoft® Jet-databasemotoren. Reserverede ord omfatter navnene på sætninger, foruddefinerede funktioner og datatyper samt metoder, operatorer og objekter. Eksempler herpå er: SELECT, UPDATE, BETWEEN, SET og INSERT. Brug ikke reserverede ord i forbindelse med variabler eller objektnavne.

Når Microsoft OLE DB Provider til Jet bruges, er den reserverede ordliste for Microsoft jet version 4.X blevet forøget, så den er kompatibel med ANSI SQL-92.


højre joinforbindelse <Jet-definition>

højre joinforbindelse

En højre ydre joinforbindelse omfatter alle poster fra den anden (højre) af to tabeller, selvom der ikke findes tilsvarende værdier for posterne i den første (venstre) tabel.

Du kan f.eks. bruge LEFT JOIN sammen med tabellerne Afdelinger (venstre) og Medarbejdere (højre) til at markere alle afdelinger, herunder dem, der ingen medarbejdere har. Hvis du vil markere alle medarbejdere, herunder dem, der ikke har tilknytning til en afdeling, skal du bruge RIGHT JOIN.


højre ydre joinforbindelse <Jet-definition>

højre ydre joinforbindelse

En ydre joinforbindelse, hvor alle posterne fra højre side af handlingen RIGHT JOIN i forespørgslens SQL-sætning tilføjes til Recordset-objektet, selvom der ikke er tilsvarende værdier i det joinforbundne felt fra venstre tabel. Poster fra venstre tabel kombineres kun med de poster fra højre tabel, hvor der er tilsvarende værdier i de joinforbundne felter.


tilbagerulning <Jet-definition>

tilbagerulning

Hvis du bruger Microsoft® OLE DB Provider til Jet, kan du starte (BeginTrans), bekræfte (CommitTrans) eller rulle en transaktion tilbage (RollBack) uden at gå via objektmodellen DAO eller ADO. Med tilbagerulning (RollBack) kan en transaktion, der blev startet (BeginTrans), afsluttes eller fjernes.


række <Jet-definition>

række

Et sæt relaterede kolonner eller felter, der bruges til at opbevare data. En række er det samme som en post i Microsoft® Jet-databasemotoren. En tabel består af ingen eller flere rækker data.


låsning på rækkeniveau <Jet-definition>

låsning på rækkeniveau

En ny funktion i Microsoft® Jet version 4.X, hvormed en bruger kan låse en række i stedet for at låse en side, når en række opdateres eller slettes. Låsning på rækkeniveau er ikke implementeret på de kolonner, der er indekserede eller LV (lang værdi)-datatyperne (Memo).


sporing på rækkeniveau <Jet-definition>

sporing på rækkeniveau

Sporing på rækkeniveau er en mekanisme, hvor hele rækken deltager i definition og løsning af konflikter. Der opstår en konflikt, hvis flere end én replika ændrer samme række, også selvom de ændrede data findes i forskellige kolonner i den pågældende række.


kørselsfejl <Jet-definition>

kørselsfejl

En fejl, der opstår, når programkode kører. Der opstår en kørselsfejl, når en sætning forsøger at udføre en ugyldig handling.


kørselstid <Jet-definition>

kørselstid

Den tid, hvor programkode kører. Under kørselstiden arbejder du med programkode på samme måde, som en bruger ville gøre.


virkefelt <Jet-definition>

virkefelt

Attributtet af en variabel eller procedure, der bestemmer, hvilke sektioner i hvilke moduler der genkender det. Der findes tre niveauer af virkefelt: offentlige, modul og procedure. De variabler, du erklærer med Public, kan åbnes i alle moduler, mens de variabler, du erklærer i et specielt modul, kun kan bruges i dette modul. Variabler, du erklærer i proceduren Sub eller Function, kan ligeledes kun bruges i denne bestemte procedure.


sikret arbejdsgruppe <Jet-definition

sikret arbejdsgruppe

Et Workgroup-objekt i Microsoft® Jet-databasen, som brugere logger på med et brugernavn og en adgangskode, og hvor adgangen til databaseobjektet er begrænset i overensstemmelse med tilladelser, der er angivet for brugerkonti og -grupper.


sikkerhed <Jet-definition>

sikkerhed

Et sæt funktioner, der anvendes til at angive eller begrænse den adgang, som brugere eller brugergrupper har til data og objekter i en database.


basis <Jet-definition>

basis

Valgfri parameter, der bruges sammen med datatyperne Counter eller Identity. Er kun tilgængelig i SQL DDL, når du bruger Microsoft® OLE DB Provider til Jet. Kan også betegnes startværdien. Basis er den første af de to valgfri parametre til datatyperne Counter eller Identity.

Følgende SQL-sætning er et eksempel med parametrene:

CREATE TABLE Customers (CustId IDENTITY (100, 10) CONSTRAINT pkCustomers PRIMARY KEY, CFrstNm VARCHAR(10), CLstNm VARCHAR(15));

Kolonnen CustId i første række har værdien 100. Anden række har værdien 110.

Når de valgfrie parametre bruges og ikke indeholder værdier på (1,1), nulstiller Jet ikke basis til maksimumværdien i tabellen. Denne virkemåde er forskellig fra tidligere versioner af Jet. Hvis de valgfrie parametre ikke overskrides, eller der ikke bruges en værdi på (1,1), når databasen komprimeres, nulstilles basis til maksimumværdien for tabellens Counter- eller Identity-kolonne.

Se også

stigning


udvælgelsesforespørgsler <Jet-definition>

udvælgelsesforespørgsler

En forespørgsel, der stiller spørgsmål om de data, som er lagret i tabellen, og som returnerer et Recordset-objekt uden at ændre dataene. Når du har hentet dataene fra Recordset, kan du undersøge og foretage ændringer i dataene i de underliggende tabeller. Handlingsforespørgsler kan derimod ændre dataene men ikke returnere dataposter.


selvjoinforbindelse <Jet-definition>

selvjoinforbindelse

En joinforbindelse, hvor poster fra en tabel er kombineret med andre poster fra samme tabel, hvor der er tilsvarende værdier i de joinforbundne felter. En selvjoinforbindelse kan være en indre joinforbindelse eller en ydre joinforbindelse. Du kan med fordel benytte en selvjoinforbindelse, når du stiller hierarkiske spørgsmål, såsom en forespørgsel, der viser alle chefer og de medarbejdere, der rapporterer til dem.


server <Jet-definition>

server

Det databasestyringssystem, der er udformet til at dele data med client-programmer. Servere og clientprogrammer er ofte forbundet over et netværk. En databaseserver indeholder og styrer som regel et centralt lager til data, som eksterne clientprogrammer kan hente og manipulere.


markør på server-side <Jet-definition>

markør på server-side

Markører, der findes på serveren i modsætning til at være placeret på clientcomputeren. Mens markører på client-siden kopierer markøren til arbejdsstationen, bruger markører på server-siden ressourcerne på databaseserveren til at vedligeholde markørerne.


session <Jet-definition>

session

En session viser en sekvens af handlinger, der er udført af Microsoft® Jet-databasemotoren. En session starter, når en bruger logger på, og slutter, når en bruger logger af. Alle de handlinger, der udføres under en session, udgør ét transaktionsvirkefelt og er underkastet de tilladelser, der bestemmes af logonbrugernavnet og -adgangskoden. Sessioner implementeres som Workspace-objekter af DAO.


datatypen Short <Jet-definition>

datatypen Short

En grundlæggende datatype i Microsoft® Jet-databasemotoren, der svarer til datatypen Integer, som er defineret i Microsoft Visual Basic® for Applications. Variablen Short lagres som et 16-bit tal (2 byte), som strækker sig i værdi fra -32.768 til 32.767.


datatypen Single <Jet-definition>

datatypen Single

En grundlæggende datatype, der indeholder reelle tal med enkelt præcision i IEEE-formatet. Variablen Single lagres som et 32-bit tal (4 byte), der strækker sig i værdi fra -3,402823E38 til -1,401298E-45 for negative værdier, fra 1,401298E-45 til 3,402823E38 for positive værdier og 0.


snapshot <Jet-definition>

snapshot

En statisk kopi af et sæt af poster, der er hentet fra databasen og kopieret i hukommelsen. Et snapshot, der er afledt af en Microsoft® Jet-tilsluttet datakilde kan ikke opdateres. Recordset-objekter af typen snapshot kan oprettes fra en basistabel, en forespørgsel eller et andet Recordset-objekt. Alle SQL-videregivelsesforespørgsler returnerer snapshots.


sorteringsrækkefølge <Jet-definition>

sorteringsrækkefølge

Et princip, der bruges til at sortere data i alfabetisk eller numerisk rækkefølge. Sorteringsrækkefølgen kan enten være stigende eller faldende.


SQL-specifik forespørgsel <Jet-definition>

SQL-specifik forespørgsel

En forespørgsel, der kun kan oprettes ved at skrive en SQL-sætning. Underforespørgsler og videregivelses-, forenings- og datadefinitionsforespørgsler er SQL-specifikke forespørgsler.


SQL-sætning/-streng <Jet-definition>

SQL-sætning/-streng

Et udtryk, der definerer en SQL-kommando (SQL - Structured Query Language), såsom SELECT, UPDATE eller DELETE, og som omfatter delsætninger, såsom WHERE og ORDER BY. SQL-strenge og -sætninger bruges som regel i forespørgsler, Recordset-objekter og aggregatfunktioner, men kan også bruges til at oprette eller redigere en databasestruktur.


standardafvigelse <Jet-definition>

standardafvigelse

En parameter, der angiver den måde, hvorpå en sandsynlighedsfunktion centreres omkring gennemsnittet, og det svarer til kvadratroden af det element, hvor afvigelsen fra gennemsnittet kvadreres. Bruges til at beskrive sæt af værdier for at bestemme, hvor meget værdien varierer fra det aritmetiske gennemsnit.


standardnavngivningskonventioner <Jet-definition>

standardnavngivningskonventioner

Et sæt af særlige regler til navngivning af DAO-objekter. Navne kan indeholde op til 64 tegn og kan omfatte alle kombinationer af bogstaver, tal, mellemrum og specielle tegn undtagen punktum (.), udråbstegn (!), accent grave (`) og kantede parenteser ([ ]). Du må heller ikke bruge foranstillede mellemrum eller kontroltegn (ASCII-værdierne 0-31).


statisk markør <Jet-definition>

statisk markør

Et resultatsæt, hvor medlemskabet, rækkefølgen og værdierne som regel er faste, når markøren åbnes. Hvis andre brugere opdaterer, sletter eller indsætter rækker, afspejler markøren ikke disse ændringer, før du lukker og åbner den igen.


strengsammenligning <Jet-definition>

strengsammenligning

Brugen af en operator, der bestemmer, om én streng er større end eller på størrelse med en anden streng. Hvis du bruger Option Compare Text i sektionen Erklæringer i et modul, skelnes der i strengsammenligninger ikke mellem store og små bogstaver. Hvis du anvender Option Compare Binary, skelnes der i sammenligningerne mellem store og små bogstaver. Hvis du bruger Option Compare Database, er sammenligningsmetoden angivet i den aktuelle database.


datatypen String <Jet-definition>

datatypen String

En grundlæggende datatype, der indeholder tegnoplysninger. Variablen String er enten en streng af fast eller variabel længde og indeholder et tegn pr. byte. Strenge af fast længde er erklæret til at have en bestemt længde og kan indeholde ca. 1-64 KB (2^16) tegn. Strenge af variabel længde kan indeholde op til 2 mia. (2^31) tegn (ca. 64 KB [2^16] tegn i forbindelse med Microsoft® Windows® version 3.1 og tidligere versioner) minus et lille fast lager.


strengudtryk <Jet-definition>

strengudtryk

Ethvert udtryk, der evalueres til en sekvens af ikke-sammenhængende tegn. Elementer i udtrykket kan medtage en funktion, der returnerer en streng, et strengkonstanttegn, en strengkonstant, en strengvariabel, en streng af typen Variant eller en funktion, der returnerer en streng af typen Variant (VarType 8).


SQL (Structured Query Language) <Jet-definition>

SQL (Structured Query Language)

Et sprog, der bruges i forbindelse med forespørgsel, opdatering og håndtering af relationsdatabaser. SQL kan bruges til at hente, sortere og filtrere specifikke data, der skal hentes fra databasen.

Du kan benytte SQL SELECT-sætninger, hvor et tabel-, forespørgsels- eller feltnavn accepteres. Du kan f.eks. anvende en SQL-sætning i stedet for et tabelnavn i metoden OpenRecordset.


underforespørgsel <Jet-definition>

underforespørgsel

En underforespørgsel er en SELECT-sætning, der er indlejret i en SELECT-, SELECT...INTO-, INSERT...INTO-, DELETE- eller UPDATE-sætning eller i en anden underforespørgsel.


syntaksfejl <Jet-definition>

syntaksfejl

En fejl, der opstår, når du skriver en linje med programkode, som Microsoft® Visual Basic® ikke genkender.

Bemærk! Syntaksregler for de enkelte nøgleord defineres i sektionen Syntaks i det relaterede Hjælp-emne. Hjælp til et reserveret ord inde fra udviklingsmiljøet finder du ved at markere det reserverede ord og klikke på F1.


systemobjekt <Jet-definition>

systemobjekt

Et databaseobjekt, der defineres i Microsoft® Jet-databasemotoren, såsom tabellen MSysIndexes.


tabel <Jet-definition>

tabel

Den grundlæggende enhed af datalagring i en relationsdatabase. En tabel lagrer data i poster (rækker) og felter (kolonner) og drejer sig som regel om en bestemt kategori, såsom medarbejdere eller andet. Det kaldes også en basistabel.

Recordset af typen tabel er en logisk repræsentation af en basistabel i en database.


TEMP <Jet-definition>

TEMP

Miljøvariablen TEMP angives i filen Autoexec.bat, når du starter systemet. TEMP peger som regel på et område i harddisken, der bruges af Microsoft® Windows® og andre programmer, såsom Microsoft Jet-databasemotoren, til at lagre oplysninger, der ikke behøver at blive gemt, efter at du har lukket systemet. I følgende linje i Autoexec.bat-filen peger miljøvariablen TEMP f.eks. på mappen D:\TempArea.

SET TEMP=D:\TempArea


midlertidig diskette <Jet-definition>

midlertidig diskette

Den diskette eller det bibliotek, der identificeres af miljøvariablen TEMP i operativsystemet, hvor Microsoft® Jet-databasemotoren lagrer midlertidige filer og resultatsæt. Kaldes også et midlertidigt drev. Selvom miljøvariablen TEMP kan pege på en RAM-diskette, anbefales det ikke.


datatypen Text(n) med længdespecifikation <Jet-definition>

datatypen Text(n) (med længdespecifikation)

En feltdatatype. Tekstfelter kan indeholde op til 255 tegn eller det antal tegn, der er angivet af egenskaben Size i objektet Field, alt efter hvad der er lavest. Hvis egenskaben Size i tekstfeltet er angivet til 0, kan tekstfeltet indeholde op til 255 datategn.


datatypen Text uden længdespecifikation <Jet-definition>

datatypen Text (uden længdespecifikation)

En feltdatatype. Tekstfelter, der er defineret uden en bestemt længde, er de samme som Memo-felter og kan indeholde op til 2,15 GB tegndata.


datatypen Time <Jet-definition>

datatypen Time

En datatype, der lagrer en klokkeslætsværdi. Værdien afhænger af indstillingen af uret i datakilden.


transaktion <Jet-definition>

transaktion

En række ændringer, der er foretaget i databasens data og skema. Marker begyndelsen af en transaktion med sætningen BeginTrans, bekræft transaktionen ved hjælp af sætningen CommitTrans, og fortryd alle de ændringer, der er foretaget siden BeginTrans, ved hjælp af sætningen Rollback.

Transaktioner er valgfrie og kan indlejres i op til fem niveauer. Transaktioner øger hastigheden for handlinger, der ændrer data, og gør det let at fortryde ændringer.

Transaktioner er globale i forbindelse med det databaseobjekts Workspace, der refereres til.


repræsentationsformatet Unicode <Jet-definition>

repræsentationsformatet Unicode

Et 16-bit tegnsæt, der administreres af Unicode Consortium, og som indeholder alle de tegn, der er nødvendige for at vise alle verdens sprog. Unicode bruges i stigende grad for at lette håndteringen af software på flere sprog.


foreningsforespørgsel <Jet-definition>

foreningsforespørgsel

En SQL-specifik udvælgelsesforespørgsel, der opretter et Recordset-objekt af typen snapshot, som indeholder data fra alle angivne poster i to eller flere tabeller, hvor alle dublerede poster fjernes. Hvis du vil medtage dubletter, skal du tilføje det reserverede ord ALL.

En foreningsforespørgsel i tabellen Kunder og tabellen Leverandører resulterer f.eks. i et Recordset af typen snapshot, der indeholder alle de leverandører, som også er kunder.


Ikke-vedligeholdt replika <Jet-definition>

ikke-vedligholdt replika

En replika, der ikke vedligeholdes af et Synchronizer-program. Ikke-vedligeholdte replikaer vises i vinduet Synkronisering med et specielt ikon. Du kan ikke angive tidsindstillinger fra en ikke-vedligeholdt replika, selvom de kan synkroniseres med et andet Synchronizer-program eller ved hjælp af programkode til dataadgangsobjekter.


opdatering <Jet-definition>

opdatering

Den proces, der gemmer ændringer i data i en post. Indtil posten gemmes, lagres ændringerne i en midlertidig post, der kaldes kopieringsbufferen. Delsætningen UPDATE i en SQL-sætning ændrer dataværdier i en eller flere poster (rækker) i en databasetabel.


opdateringsforespørgsel <Jet-definition>

opdateringsforespørgsel

En handlingsforespørgsel, der ændrer et sæt poster efter de angivne kriterier. En opdateringsforespørgsel returnerer ingen poster.


brugerkonto <Jet-definition>

brugerkonto

En konto, der er identificeret af et brugernavn og et personligt ID (PID), som er oprettet til at styre adgangen til databaseobjekter i et Workgroup-objekt i Microsoft® Jet-databasen.


validering <Jet-definition>

validering

Den proces, hvor du undersøger, om de indtastede data opfylder visse betingelser eller begrænsninger.


valideringsegenskaber <Jet-definition>

valideringsegenskaber

Egenskaber, der bruges til at angive betingelser i tabelfelter og -poster. Valideringsegenskaber omfatter ValidationRule, Required og AllowZeroLength.


valideringsregel <Jet-definition>

valideringsregel

En regel, der angiver begrænsninger eller betingelser for, hvad der kan indtastes i et eller flere felter. Valideringsregler kan angives for et Field- eller TableDef-objekt. Valideringsregler undersøges, når du opdaterer en post, der indeholder felter, som kræver validering. Hvis reglen ikke overholdes, opstår der en fejl, der kan opfanges.


datatypen VarBinary <Jet-definition>

datatypen VarBinary

En datatype, der lagrer binære data med variabel længde. Maksimumlængden er 255 byte.


variabel <Jet-definition>

variabel

En navngivet lagerplacering, der kan indeholde data, som kan redigeres, mens programmet kører. Hver variabel har et navn, der unikt identificerer den inden for virkefeltsniveauet. En datatype kan enten angives eller ej.

Navne på variabler:

  • Skal begynde med et alfabetisk tegn.
  • Kan ikke indeholde en integreret periode eller et typeerklæringstegn.
  • Skal være unikt inden for samme virkefelt.
  • Må ikke være længere en 255 tegn.


varians <Jet-definition>

varians

Kvadratroden af standardafvigelsen. Den angiver en størrelse på den mængde, hvor alle værdier i en gruppe afviger fra gruppens gennemsnitsværdi.


datatypen Variant <Jet-definition>

datatypen Variant

En særlig datatype, der kan indeholde numeriske data, streng- eller datodata samt de særlige værdier Empty og Null. Funktionen VarType definerer, hvordan dataene i Variant behandles. Alle variabler bliver varianttyper, hvis de ikke udtrykkeligt erklæres som en anden type.


variantudtryk <Jet-definition>

variantudtryk

Alle udtryk, der kan evalueres til numeriske data, streng- eller datodata samt de særlige værdier Empty og Null.


visning <Jet-definition>

visning

En visning er ANSI-definitionen af en virtuel tabel. En visning er synonymt med en lagret forespørgsel i Access, der består af en SELECT-sætning uden parametre. En visning er en lagret definition, der materialiserer sig ved udførelse. Den afviger fra en tabel, idet den ikke lagrer data fysisk. Den returnerer kun data.

En visning kan oprettes ud fra den nye ANSI SQL CREAT VIEW-syntaks, som du finder i Microsoft® OLE DB Provider til Jet. Alternativt kan der oprettes en procedure, der tillader SQL DML-sætninger og SELECT-sætninger, der har parametre. Dette kan gøres med den nye CREATE PROCEDURE-syntaks, som du finder i Microsoft® OLE DB Provider til Jet.


jokertegn <Jet-definition>

jokertegn

Stjernen (*), procenttegnet (%), spørgsmålstegnet (?), understregningstegnet (_), nummertegnet (#), udråbstegnet (!), bindestregen (-) og de kantede parenteser ([ ]) er jokertegn. Du kan bruge disse tegn i forespørgsler og udtryk til at medtage alle poster, filnavne eller andre elementer, der begynder med særlige tegn eller passer til et bestemt mønster. Du kan også bruge jokertegn og tilsvarende tegn til yderligere at forbedre en søgning, når du bruger en SQL-sætning.

Bemærk! Procenttegnet (%) og understregningstegnet (_) bruges kun som jokertegn med Microsoft® OLE DB Provider til Jet. De vises ikke via DAO eller Microsoft Access UI. De behandles som bogstavelige værdier i DAO eller Access UI.

Symbol | Eksempel | Brug
* or % | hv* finder hvad, hvid og hvorfor *at finder kat, rabat og skat | Finder et vilkårligt antal tegn og kan bruges overalt i tegnstrengen.
? or _ | m?l finder mal, mel og mil | Finder et enkelt tegn.
# | 1#3 finder 103, 113 og 123 | Finder et enkelt ciffer.
[ ] | m[ae]l finder mal og mel, men ikke mil | Finder et af tegnene i de kantede parenteser.
! | m[!ae]l finder mil, men ikke mal og mel | Finder et tegn, der ikke er vist.
- | b[a-c]d finder bad, bbd og bcd | Finder et tegn i tegnområdet.

Bemærk! Jokertegnene * (stjerne), ? (spørgsmålstegn), # (nummertegn) og [ (åben kantet parentes) kan kun have sammenfald med sig selv, hvis de omsluttes af kantede parenteser.


arbejdsgruppe <Jet-definition

arbejdsgruppe

En brugergruppe i et flerbrugermiljø, der deler data og den samme arbejdsgruppeoplysningsfil (som regel filen System.mdw).


arbejdsgruppeadministrator <Jet-definition

arbejdsgruppeadministrator

Et medlem af gruppen Administratorer i et Workgroup-objekt i Microsoft® Jet-databasen. En arbejdsgruppeadministrator kan altid opnå fuld tilladelse til ethvert databaseobjekt, der er oprettet i objektet Workgroup.


streng af længden nul <Jet-definition>

streng af længden nul

En streng, der ikke indeholder tegn (""). Funktionen Len med en streng af længden nul returnerer 0.


Initialisering af dBASE-databasedriveren

Når du installerer dBASE-databasedriveren, skriver installationsprogrammet et sæt standardværdier til Microsoft® Windows®-registreringsdatabasen i undernøglerne Engines og ISAM Formats. Du skal ikke redigere disse indstillinger direkte. Brug installationsprogrammet til programmet til at tilføje, fjerne eller ændre disse indstillinger. I de følgende afsnit beskrives initialisering og ISAM-format-indstillinger for dBASE-databasedriveren.

Paradox-databasedriveren fungerer i en af to tilstande, afhængigt af om Borland Database Engine (BDE) er installeret. Paradox-data kan kun opdateres med BDE. Uden BDE kan Paradox-data være Read, Exported eller Linked to read-only.

dBASE-initialiseringsindstillinger

I mappen Jet\4.0\Engines\Xbase findes initialiseringsindstillinger til driveren msxbde40.dll, der bruges til at få adgang til eksterne dBASE-datakilder. Typiske indstillinger af indtastningerne i denne mappe vises i følgende eksempel.

win32=<sti>\msxbde40.dll

NetworkAccess=On

PageTimeout=600

INFPath=C:\Dbase\System

CollatingSequence=ASCII

DataCodePage=OEM

Deleted=On

DbcsStr=On

Century=Off

Date=MDY

Mark=47

Exact=Off

Microsoft Jet-databasemotoren bruger Xbase-mappeindtastningerne på følgende måde.

Indtastning | Beskrivelse
win32 | Placeringen af Msxbse35.dll. Den fulde sti bestemmes på installationstidspunktet. Værdierne er af typen Streng i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.
NetworkAccess | En binær indikator til indstilling af fillåsning. Hvis NetworkAccess angives til 00, åbnes tabeller med udelt adgang, uanset indstillingerne af argumentet udelt til metoderne OpenDatabase og OpenRecordset. Standardværdien er 01. Værdierne er af typen Binær i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_BINARY i forbindelse med Windows NT 3.51.
PageTimeout | Den tid, der går, fra data placeres i en intern cache, til de bliver gjort ugyldige. Værdien angives i enheder på 100 millisekunder. Standard er 600 enheder eller 60 sekunder. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
INFPath Den fuldstændige sti til .inf-filbiblioteket. Microsoft Jet-databasemotoren søger først efter en .inf-fil i det bibliotek, der indeholder tabellen. Hvis .inf-filen ikke findes i databasebiblioteket, søges der i INFPath-stien. Hvis der ikke findes en INFPath-sti, bruges de indeksfiler (.cdx eller .mdx), databasemotoren finder i databasebiblioteket. Værdierne er af typen Streng i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.

Denne indtastning skrives ikke af installationsproceduren.
CollatingSequence Denne indstilling bruges kun, hvis BDE ikke findes på maskinen.

Sorteringsrækkefølgen for alle de dBASE-tabeller, der er oprettet eller åbnet ved hjælp af Microsoft Jet-databasemotoren. Mulige værdier er ASCII og International. Standard er ASCII. Værdierne er af typen Streng i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.
DataCodePage Denne indstilling bruges kun, hvis BDE ikke findes på maskinen.

En indikator for, hvordan tekstsider lagres. Mulige indstillinger er:

  • OEM – OemToAnsi- og AnsiToOem-konverteringer er afsluttet.
  • ANSI – OemToAnsi- og AnsiToOem-konverteringer er ikke afsluttet.

Standard er OEM. Værdierne er af typen Streng i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.
Deleted | En binær indikator, der bestemmer, hvordan poster, der er markeret til sletning, behandles af Microsoft Jet-databasemotoren. Værdien 01 svarer til dBASE-kommandoen SET DELETED ON og angiver, at en slettet post aldrig må hentes, eller at der aldrig må placeres på en slettet post. Værdien 00 svarer til dBASEkommandoen SET DELETED OFF og angiver, at en slettet post skal behandles som enhver anden post. Standard er 00. Værdierne er af typen Binær i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_BINARY i forbindelse med Windows NT 3.51.
DbcsStr | En binær indikator, der bestemmer, hvordan strengfunktioner behandler data for tegnsæt fra Fjernøsten. Værdien 01 svarer til dBASE-kommandoen SET KANJISTRING ON og angiver, at en streng skal behandles som en dbcs-tegnstrøm. Værdien 00 angiver, at en streng skal behandles som en simpel bytestrøm.
Century | En binær indikator til formatering af århundrededelen i datoer i de tilfælde, hvor der bruges dato-til-streng-funktioner i indeksudtryk. Værdien 01 svarer til dBASE-kommandoen SET CENTURY ON, og værdien 00 svarer til dBASE-kommandoen SET CENTURY OFF. Standard er 00. Værdierne er af typen Binær i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_BINARY i forbindelse med Windows NT 3.51.
Date | Den datoformateringstypografi, der skal anvendes i de tilfælde, hvor der anvendes dato-til-streng-funktioner i indeksudtryk. De mulige indstillinger af denne indtastning, der svarer til dBASE-kommandoen SET DATE, er Amerikansk, ANSI, Engelsk, Fransk, DMY, Tysk, Italiensk, Japansk, MDY, USA og YMD. Standard er MDY. Værdierne er af typen Streng i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.
Mark Decimalværdien af det ASCII-tegn, der bruges til at adskille datodele. Standarden afhænger af datoindstillingen som følger:
  • "/" (Amerikansk, MDY (MDÅ))
  • "." (ANSI)
  • "/" (Engelsk, Fransk, DMY (DMÅ))
  • "." (Tysk)
  • "-" (Italiensk)
  • "/" (Japansk, YMD (ÅMD))
  • "-" (USA)

Værdien 0 angiver, at systemet skal bruge det separatortegn, der som regel er tilknyttet det markerede dataformat.

Standard er 0. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
Exact | En binær indikator til strengsammenligninger. Værdien 01 svarer til dBASE-kommandoen SET EXACT ON. Værdien 00 svarer til dBASE-kommandoen SET EXACT OFF. Standard er 00. Værdierne er af typen Binær i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_BINARY i forbindelse med Windows NT 3.51.

dBASE ISAM Formats

Mappen Jet\4.0\ISAM Formats\dBASE III indeholder følgende indtastninger.

Indtastningsnavn | Windows NT 3.51-type | Windows 95- og Windows NT 4.0-type | Værdi
Engine | REG_SZ | Streng | Xbase
ExportFilter | REG_SZ | Streng | dBASE III (*.dbf)
ImportFilter | REG_SZ | Streng | dBASE III (*.dbf)
CanLink | REG_BINARY | Binær | 01
OneTablePerFile | REG_BINARY | Binær | 01
IsamType | REG_DWORD | DWORD | 0
IndexDialog | REG_BINARY | Binær | 01
IndexFilter | REG_SZ | Streng | dBASE-indeks (*.ndx)
CreateDBOnExport | REG_BINARY | Binær | 00
ResultTextImport | REG_SZ | Streng | Importerer data fra den eksterne fil til den aktuelle database. Ændring af data i den aktuelle database ændrer ikke dataene i den eksterne fil.
ResultTextLink | REG_SZ | Streng | Opretter en tabel i den aktuelle database, der er sammenkædet med den eksterne fil. Ændring af data i den aktuelle database vil ændre dataene i den eksterne fil.
ResultTextExport | REG_SZ | Streng | Eksporterer data fra den aktuelle database til en dBASE III-fil. Denne proces overskriver dataene, hvis de eksporteres til en eksisterende fil.
SupportsLongNames | REG_BINARY | Binær | 00

Mappen Jet\4.0\ISAM Formats\dBASE IV indeholder følgende indtastninger.

Indtastningsnavn | Windows NT 3.51-type | Windows 95- og Windows NT 4.0-type | Værdi
Engine | REG_SZ | Streng | Xbase
ExportFilter | REG_SZ | Streng | dBASE IV (*.dbf)
ImportFilter | REG_SZ | Streng | dBASE IV (*.dbf)
CanLink | REG_BINARY | Binær | 01
OneTablePerFile | REG_BINARY | Binær | 01
IsamType | REG_DWORD | DWORD | 0
IndexDialog | REG_BINARY | Binær | 01
IndexFilter | REG_SZ | Streng | dBASE-indeks (*.ndx og *.mdx)
CreateDBOnExport | REG_BINARY | Binær | 00
ResultTextImport | REG_SZ | Streng | Importerer data fra den eksterne fil til den aktuelle database. Ændring af data i den aktuelle database ændrer ikke dataene i den eksterne fil.
ResultTextLink | REG_SZ | Streng | Opretter en tabel i den aktuelle database, der er sammenkædet med den eksterne fil. Ændring af data i den aktuelle database vil ændre dataene i den eksterne fil.
ResultTextExport | REG_SZ | Streng | Eksporterer data fra den aktuelle database til en dBASE IV-fil. Denne proces overskriver dataene, hvis de eksporteres til en eksisterende fil.
SupportsLongNames | REG_BINARY | Binær | 00

Mappen Jet\4.0\ISAM Formats\dBASE 5.x indeholder følgende indtastninger.

Indtastningsnavn | Windows NT 3.51-type | Windows 95- og Windows NT 4.0-type | Værdi
Engine | REG_SZ | Streng | Xbase
ExportFilter | REG_SZ | Streng | dBASE 5 (*.dbf)
ImportFilter | REG_SZ | Streng | dBASE 5 (*.dbf)
CanLink | REG_BINARY | Binær | 01
OneTablePerFile | REG_BINARY | Binær | 01
IsamType | REG_DWORD | DWORD | 0
IndexDialog | REG_BINARY | Binær | 01
IndexFilter | REG_SZ | Streng | dBASE-indeks (*.ndx og *.mdx)
CreateDBOnExport | REG_BINARY | Binær | 00
ResultTextImport | REG_SZ | Streng | Importerer data fra den eksterne fil til den aktuelle database. Ændring af data i den aktuelle database ændrer ikke dataene i den eksterne fil.
ResultTextLink | REG_SZ | Streng | Opretter en tabel i den aktuelle database, der er sammenkædet med den eksterne fil. Ændring af data i den aktuelle database vil ændre dataene i den eksterne fil.
ResultTextExport | REG_SZ | Streng | Eksporterer data fra den aktuelle database til en dBASE 5-fil. Denne proces overskriver dataene, hvis de eksporteres til en eksisterende fil.
SupportsLongNames | REG_BINARY | Binær | 00

Bemærk! Når du ændrer indstillinger i Windows-registreringsdatabasen, skal du afslutte og derefter genstarte databasemotoren, for at de nye indstillinger træder i kraft.

Se også

Tilpasning af indstillinger i Windows-registreringsdatabasen til Microsoft Jet


Initialisering af Microsoft Excel-driver

Når du installerer Microsoft® Excel-driveren, skriver installationsprogrammet et sæt standardværdier til Microsoft Windows®-registreringsdatabasen i undernøglerne Engines og ISAM Formats. Du skal ikke redigere disse indstillinger direkte. Brug installationsprogrammet til programmet til at tilføje, fjerne eller ændre disse indstillinger. I de følgende afsnit beskrives initialisering og ISAM Format-indstillinger til Microsoft Excel-databasedriveren.

Microsoft Excel-initialiseringsindstillinger

I mappen Jet\4.0\Engines\Excel findes de initialiseringsindstillinger til msexcl40.dll-driveren, der bruges til at få ekstern adgang til Microsoft Excel-regneark. Typiske indstillinger af indtastningerne i denne mappe vises i følgende eksempel.

win32=<sti>\ msexcl40.dll

TypeGuessRows=8

ImportMixedTypes=Text

AppendBlankRows=1

FirstRowHasNames=Yes

Microsoft Jet-databasemotoren bruger Excel-mappeindtastningerne på følgende måde:

Indtastning | Beskrivelse
win32 | Placeringen af msexcl40.dll. Den fulde sti bestemmes på installationstidspunktet. Værdierne er af typen Streng i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.
TypeGuessRows | Det antal rækker, der skal kontrolleres i forbindelse med datatypen. Datatypen bestemmes ud fra det maksimale antal datatyper, der bliver fundet. Hvis der er en begrænsning, bestemmes datatypen i følgende rækkefølge: Number, Currency, Date, Text, Boolean. Hvis der er data, som ikke passer til den datatype, der er anslået til kolonnen, returneres de som en Null-værdi. Hvis en kolonne har blandede datatyper i forbindelse med import, omformes hele kolonnen i overensstemmelse med indstillingen ImportMixedTypes. Det antal rækker, der som standard skal kontrolleres, er otte. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
ImportMixedTypes | Kan angives til MajorityType eller Text. Hvis MajorityType er angivet, bliver kolonner med blandede datatyper omformet til den fremherskende datatype ved import. Hvis Text er angivet, bliver kolonner med blandede datatyper omformet til Text ved import. Standard er Text. Værdierne er af typen Streng i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.
AppendBlankRows | Det antal tomme rækker, der skal tilføjes i slutningen af et version 3.5- eller version 4.0-regneark, før nye data tilføjes. Hvis AppendBlankRows f.eks. er angivet til fire, vil Microsoft Jet tilføje fire tomme rækker i slutningen af regnearket, før der tilføjes rækker, der indeholder data. Heltalsværdierne til denne indstilling kan ligge i intervallet 0 til 16. Standard er 01 (en ekstra tilføjet række). Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
FirstRowHasNames | En binær værdi, der angiver, om den første række i tabellen indeholder kolonnenavne. Værdien 01 angiver, at kolonnenavne under import hentes fra den første række. Værdien 00 angiver, at der ingen kolonnenavne er i den første række. Kolonnenavne vises som F1, F2, F3 osv. Standard er 01. Værdierne er af typen Binær i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_BINARY i forbindelse med Windows NT 3.51.

Microsoft Excel ISAM Formats

Mappen Jet\4.0\ISAM Formats\Excel 3.0 indeholder følgende indtastninger:

Indtastningsnavn | Windows NT- type | Windows 95- og Windows NT 4.0-type | Værdi
Engine | REG_SZ | Streng | Excel
ExportFilter | REG_SZ | Streng | Microsoft Excel 3 (*.xls)
CanLink | REG_BINARY | Binær | 01
OneTablePerFile | REG_BINARY | Binær | 00
IsamType | REG_DWORD | DWORD | 1
IndexDialog | REG_BINARY | Binær | 00
CreateDBOnExport | REG_BINARY | Binær | 01
ResultTextExport | REG_SZ | Streng | Eksporterer data fra den aktuelle database til en Microsoft Excel 3.0-fil. Denne proces overskriver dataene, hvis de eksporteres til en eksisterende fil.
SupportsLongNames | REG_BINARY | Binær | 01

Mappen Jet\4.0\ISAM Formats\Excel 4.0 indeholder følgende indtastninger:

Indtastningsnavn | Windows NT 3.51-type | Windows 95- og Windows NT 4.0-type | Værdi
Engine | REG_SZ | Streng | Excel
ExportFilter | REG_SZ | Streng | Microsoft Excel 4 (*.xls)
CanLink | REG_BINARY | Binær | 01
OneTablePerFile | REG_BINARY | Binær | 00
IsamType | REG_DWORD | DWORD | 1
IndexDialog | REG_BINARY | Binær | 00
CreateDBOnExport | REG_BINARY | Binær | 01
ResultTextExport | REG_SZ | Streng | Eksporterer data fra den aktuelle database til en Microsoft Excel 4.0-fil. Denne proces overskriver dataene, hvis de eksporteres til en eksisterende fil.
SupportsLongNames | REG_BINARY | Binær | 01

Mappen Jet\4.0\ISAM Formats\Excel 5.0 indeholder følgende indtastninger, der anvendes til Microsoft Excel version 5.0 og 7.0:

Indtastningsnavn | Windows NT 3.51-type | Windows 95- og Windows NT 4.0-type | Værdi
Engine | REG_SZ | Streng | Excel
ExportFilter | REG_SZ | Streng | Microsoft Excel 5-7 (*.xls)
ImportFilter | REG_SZ | Streng | Microsoft Excel (*.xls)
CanLink | REG_BINARY | Binær | 01
OneTablePerFile | REG_BINARY | Binær | 00
IsamType | REG_DWORD | DWORD | 1
IndexDialog | REG_BINARY | Binær | 00
CreateDBOnExport | REG_BINARY | Binær | 01
ResultTextImport | REG_SZ | Streng | Importerer data fra den eksterne fil til den aktuelle database. Ændring af data i den aktuelle database ændrer ikke dataene i den eksterne fil.
ResultTextLink | REG_SZ | Streng | Opretter en tabel i den aktuelle database, der er sammenkædet med den eksterne fil. Ændring af data i den aktuelle database vil ændre dataene i den eksterne fil.
ResultTextExport | REG_SZ | Streng | Eksporterer data fra den aktuelle database til en Microsoft Excel 5.0-fil. Denne proces overskriver dataene, hvis de eksporteres til en eksisterende fil.
SupportsLongNames | REG_BINARY | Binær | 01

Mappen Jet\4.0\ISAM Formats\Excel 8.0 indeholder følgende indtastninger, der anvendes til Microsoft Excel 97:

Indtastningsnavn | Windows NT 3.51-type | Windows 95- og Windows NT 4.0-type | Værdi
Engine | REG_SZ | Streng | Excel
ExportFilter | REG_SZ | Streng | Microsoft Excel 97-2000 (*.xls)
CanLink | REG_BINARY | Binær | 01
OneTablePerFile | REG_BINARY | Binær | 00
IsamType | REG_DWORD | DWORD | 1
IndexDialog | REG_BINARY | Binær | 00
CreateDBOnExport | REG_BINARY | Binær | 01
ResultTextExport | REG_SZ | Streng | Eksporterer data fra den aktuelle database til en Microsoft Excel 97-fil. Denne proces overskriver dataene, hvis de eksporteres til en eksisterende fil.
SupportsLongNames | REG_BINARY | Binær | 01

Bemærk! Når du ændrer indstillinger i Windows-registreringsdatabasen, skal du afslutte og derefter genstarte databasemotoren, for at de nye indstillinger træder i kraft.

Se også

Tilpasning af indstillinger i Windows-registreringsdatabasen til Microsoft Jet


*Initialisering af Microsoft Jet 3.5-databasemotordriveren

Når du installerer Microsoft® Jet version 3.5-databasemotordriveren, skriver installationsprogrammet et sæt standardværdier til Microsoft Windows®-registreringsdatabasen i undernøglerne Engines og ISAM Formats. Du skal bruge Registreringseditor til at tilføje, fjerne eller ændre disse indstillinger. I de følgende afsnit beskrives initialisering og ISAM Format-indstillinger til Microsoft Jet Engine-databasedriveren.

Initialiseringsindstillinger til Microsoft Jet Engine

I mappen Jet\4.0\Engines\Jet 3.x findes de initialiseringsindstillinger til msrd3x40.dll-driveren, der bruges til at få ekstern adgang til Microsoft Access 97-regneark. Typiske initialiseringsindstillinger af indtastningerne i denne mappe vises i følgende eksempel:

win32=<sti>\ msrd3x40.dll

FlushTransactionTimeout=500

LockDelay=100

LockRetry=20

MaxBufferSize= 0

MaxLocksPerFile= 9500

PageTimeout=5000

Threads=3

UserCommitSync=Yes

ImplicitCommitSync=No

ExclusiveAsyncDelay=2000

SharedAsyncDelay=0

RecycleLV'er=0

SortMemorySource=0

Microsoft Jet-databasemotoren bruger følgende indstillinger:

Indtastning | Beskrivelse
win32 | Placering af databasemotordriveren (.dll). Stien bestemmes på installationstidspunktet. Værdierne er af typen Streng i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.
PageTimeout | Den tid, der går, fra at data, som ikke er læselåst, placeres i en intern cache, til de bliver gjort ugyldige, udtrykt i millisekunder. Standard er 5000 millisekunder eller 5 sekunder. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
FlushTransactionTimeout | Denne indtastning deaktiverer de to registreringsindtastninger ExclusiveAsyncDelay og SharedAsyncDelay. Hvis disse indtastninger skal aktiveres, skal der indtastes en værdi på nul. FlushTransactionTimeout ændrer den måde, hvorpå Microsoft Jet-databasemotoren foretager asynkrone skrivninger til en databasefil. Tidligere ville Microsoft Jet-databasemotoren bruge enten ExclusiveAsyncDelay eller SharedAsyncDelay til at bestemme, hvor lang tid der skal gå, før asynkrone skrivninger gennemtvinges. FlushTransactionTimeout ændrer denne funktionsmåde ved at indeholde en værdi, der kun vil starte asynkrone skrivninger, når den angivne tid er udløbet, og når der ikke er tilføjet sider til cachen. Den eneste undtagelse er, hvis cachen overskrider MaxBufferSize. I dette tilfælde vil cachen starte asynkrone skrivninger, uanset om tiden er udløbet. Microsoft Jet 3.5-databasemotoren venter uden aktivitet i 500 millisekunder, eller indtil cachestørrelsen er overskredet, før de asynkrone skrivninger startes.
LockDelay | Denne indstilling arbejder sammen med indstillingen LockRetry, idet den medfører, at hver LockRetry skal vente 100 millisekunder, før en anden låseanmodning afgives. Indstillingen LockDelay er tilføjet for at forhindre "sprængning", der vil opstå i forbindelse med visse netværksoperativsystemer.
MaxLocksPerFile | Denne indstilling forhindrer, at transaktioner i Microsoft Jet overskrider den angivne værdi. Hvis låsene i en transaktion forsøger at overskride denne værdi, opdeles transaktionen i to eller flere dele og bekræftes delvist. Denne indstilling er tilføjet for at forhindre, at Netware 3.1-serveren går ned, når den angivne Netware-låsegrænse er overskredet, og for at forbedre ydeevnen i forbindelse med både Netware og NT.
LockRetry | Det antal gange, der bliver gjort forsøg på at få adgang til en låst side, før en låsekonfliktmeddelelse returneres. Standard er 20. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
RecycleLV'er Denne indstilling medfører, når den er aktiveret, at Microsoft Jet genbruger LV-sider (Long Value) (datatyperne Memo, Lang Binær [OLE object] og Binær). Microsoft Jet 3.0 genbruger ikke disse typer sider, før den sidste bruger har lukket databasen. Hvis indstillingen RecycleLV er aktiveret, vil Microsoft Jet 3.5 begynde at genbruge de fleste LV-sider, når databasen udvides (dvs. når grupper af sider tilføjes).

Bemærk! Når denne facilitet aktiveres, vil brugerne bemærke en forringelse af ydeevnen, når Long Value-datatyperne manipuleres. Microsoft Access 97 aktiverer og deaktiverer automatisk denne facilitet, når moduler, formularer og rapporter manipuleres, og fjerner derfor behovet for at aktivere den, når disse objekter ændres. Standardværdien er 0. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
MaxBufferSize Størrelsen på den interne cache i databasemotoren, målt i kilobyte (KB). MaxBufferSize skal være en heltalsværdi, der er større end eller lig med 512. Standard er baseret på følgende form:

((TotalRAM in MB - 12 MB) / 4) + 512 KB

I forbindelse med et system på 32 MB RAM er standardstørrelsen på bufferen f.eks. ((32 MB - 12 MB) / 4) + 512 KB or 5632 KB. Hvis værdien skal angives til standardværdien, skal registreringsnøglen angives til

MaxBufferSize=

Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
Threads | Det antal baggrundstråde, der er tilgængelige for Microsoft Jet-databasemotoren. Standard er 3. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
UserCommitSync | Angiver, om systemet venter på, at en bekræftelse skal udføres. Værdien Yes beder systemet vente, og værdien No beder systemet udføre bekræftelsen asynkront. Standard er Yes. Værdierne er af typen Streng i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.
ImplicitCommitSync | Angiver, om systemet venter på, at en bekræftelse skal udføres. Værdien No beder systemet fortsætte udførelsen uden at vente på, at bekræftelsen afsluttes. Værdien Yes beder systemet vente på, at bekræftelsen afsluttes. Standard er No. Værdierne er af typen String i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.
ExclusiveAsyncDelay | Angiver den tid i millisekunder, det tager at udskyde en asynkron tømning af en database med udelt adgang. Standardværdien er 2000 eller 2 sekunder. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
SharedAsyncDelay | Angiver den tid i millisekunder, det tager at udskyde en asynkron tømning af en delt database. Standardværdien er 0. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
SortMemorySource | Angiver, hvordan Microsoft Jet opnår den hukommelse, der bruges til sortering af nøgler. Værdien 0 angiver, at hukommelsen skal hentes fra bunken. Værdien 1 angiver, at hukommelsen skal hentes fra den globale hukommelse ved hjælp af malloc-funktionskaldet.

Microsoft Jet Engine ISAM Formats

Mappen Jet\4.0\ISAM Formats\Jet 3.x indeholder følgende indtastninger:

Indtastningsnavn | Windows NT 3.51-type | Windows 95- og Windows NT 4.0-type | Værdi
Engine | REG_SZ | Streng | Jet 3.x
OneTablePerFile | REG_BINARY | Binær | 00
IndexDialog | REG_BINARY | Binær | 00
CreateDBOnExport | REG_BINARY | Binær | 00
IsamType | REG_DWORD | DWORD | 0

Bemærk! Når du ændrer indstillinger i Windows-registreringsdatabasen, skal du afslutte og derefter genstarte databasemotoren, for at de nye indstillinger træder i kraft.

Se også

Tilpasning af indstillinger i Windows-registreringsdatabasen til Microsoft Jet


Initialisering af Microsoft Jet 4.0-databasemotordriveren

Når du installerer Microsoft® Jet version 4.0-databasemotordriveren, skriver installationsprogrammet et sæt standardværdier til Microsoft Windows®-registreringsdatabasen i undernøglerne Engines og ISAM Formats. Du skal bruge Registreringseditor til at tilføje, fjerne eller ændre disse indstillinger. I de følgende afsnit beskrives initialisering og ISAM Format-indstillinger til Microsoft Jet Engine-databasedriveren.

Initialiseringsindstillinger til Microsoft Jet Engine

I mappen Jet\4.0\Engines findes de initialiseringsindstillinger til msjet40.dll-databasemotoren, der bruges til at få ekstern adgang til Microsoft Access-databaser. Typiske initialiseringsindstillinger af indtastningerne i denne mappe vises i følgende eksempel.

SystemDB = <sti>\System.mdb

CompactBYPkey = 1

PrevFormatCompactWithUNICODECompression=1

Microsoft Jet-databasemotoren bruger følgende indstillinger:

Indtastning | Beskrivelse
SystemDB | Angiver den fulde sti og filnavnet på arbejdsgruppeoplysningsfilen. Standard er den rette sti efterfulgt af filnavnet System.mdb. Værdierne er af typen Streng i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.
CompactByPKey Angiver, at når tabeller i forbindelse med komprimering kopieres i primær nøgle-rækkefølge, hvis der findes en primær nøgle i tabellen. Hvis der ikke findes en primær nøgle i en tabel, kopieres tabellerne i basistabel-rækkefølge.

Værdien 0 angiver, at tabeller skal komprimeres i basistabel-rækkefølge. En ikke-nul værdi angiver, at tabellerne skal komprimeres i primær nøgle-rækkefølge, hvis der findes en primær nøgle. Standardværdien er ikke-nul. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.

Bemærk! Denne indstilling anvendes kun i forbindelse med komprimering af databaser, der er oprettet med Microsoft Jet-databasemotoren version 3.0 eller senere. Når du komprimerer databaser, der er oprettet med Microsoft Jet-databasemotoren version 2.x, kopieres dataene altid i rækkefølgen for basistabellen.
PrevFormatCompactWithUNICODECompression Microsoft Jet 4.0-databaser bruger Unicode-tegnsættet til at lagre tekstdata. Komprimering af Unicode-data kan forbedre databasens ydeevne markant, fordi det nødvendige antal handlinger til den efterfølgende læsning/skrivning af sider er formindsket.

Denne nøgle bestemmer, om de databaser, der er oprettet af Microsoft Jeg-databasemotoren version 3.x eller tidligere, skal oprettes med komprimeret Unicode eller ikke-komprimeret Unicode.

Bemærk! Denne indstilling kan ikke anvendes til komprimering af Microsoft Jet 4.0-databaser. Microsoft Jet 4.0-databaser bevarer som standard de komprimeringsindstillinger, som de er oprettet med.

I mappen Jet\4.0\Engines\Jet 4.0 findes de initialiseringsindstillinger til msjet40.dll-databasemotoren, der bruges til at få ekstern adgang til Microsoft Access-databaser. Typiske initialiseringsindstillinger af indtastningerne i denne mappe vises i følgende eksempel.

FlushTransactionTimeout=500

LockDelay=100

LockRetry=20

MaxBufferSize= 0

MaxLocksPerFile= 9500

PageTimeout=5000

Threads=3

UserCommitSync=Yes

ImplicitCommitSync=No

ExclusiveAsyncDelay=2000

SharedAsyncDelay=0

RecycleLV'er=0

PagesLockedToTableLock=0

Microsoft Jet-databasemotoren bruger følgende indstillinger.

Indtastning | Beskrivelse
PageTimeout | Den tid, der går, fra at data, som ikke er læselåst, placeres i en intern cache, til de bliver gjort ugyldige, udtrykt i millisekunder. Standard er 5000 millisekunder eller 5 sekunder. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
FlushTransaction
Timeout 		Denne indtastning deaktiverer de to registreringsindtastninger ExclusiveAsyncDelay og SharedAsyncDelay. Hvis disse indtastninger skal aktiveres, skal der indtastes en værdi på nul. FlushTransactionTimeout ændrer den måde, hvorpå Microsoft Jet-databasemotoren foretager asynkrone skrivninger til en databasefil. Tidligere ville Microsoft Jet-databasemotoren bruge enten ExclusiveAsyncDelay eller SharedAsyncDelay til at bestemme, hvor lang tid der skal gå, før asynkrone skrivninger gennemtvinges. FlushTransactionTimeout ændrer denne funktionsmåde ved at indeholde en værdi, der kun vil starte asynkrone skrivninger, når den angivne tid er udløbet, og når der ikke er tilføjet sider til cachen. Den eneste undtagelse er, hvis cachen overskrider MaxBufferSize. I dette tilfælde vil cachen starte asynkrone skrivninger, uanset om tiden er udløbet eller ej. Microsoft Jet 3.5-databasemotoren venter uden aktivitet i 500 millisekunder, eller indtil cachestørrelsen er overskredet, før de asynkrone skrivninger startes.
LockDelay | Denne indstilling arbejder sammen med indstillingen LockRetry, idet den medfører, at hver LockRetry skal vente 100 millisekunder, før en anden låseanmodning afgives. Indstillingen LockDelay er tilføjet for at forhindre "sprængning", der vil opstå i forbindelse med visse netværksoperativsystemer.
MaxLocksPerFile | Denne indstilling forhindrer, at transaktioner i Microsoft Jet overskrider den angivne værdi. Hvis låsene i en transaktion forsøger at overskride denne værdi, opdeles transaktionen i to eller flere dele og bekræftes delvist. Denne indstilling er tilføjet for at forhindre, at Netware 3.1-serveren går ned, når den angivne Netware-låsegrænse er overskredet, og for at forbedre ydeevnen i forbindelse med både Netware og NT.
LockRetry | Det antal gange, der bliver gjort forsøg på at få adgang til en låst side, før en låsekonfliktmeddelelse returneres. Standard er 20. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
RecycleLV'er Denne indstilling medfører, når den er aktiveret, at Microsoft Jet genbruger LV-sider (Long Value) (datatyperne Memo, Lang Binær [OLE object] og Binær). Microsoft Jet 3.0 genbruger ikke disse typer sider, før den sidste bruger har lukket databasen. Hvis indstillingen RecycleLV er aktiveret, vil Microsoft Jet 3.5 begynde at genbruge de fleste LV-sider, når databasen udvides (dvs. når grupper af sider tilføjes).

Bemærk! Når denne facilitet aktiveres, vil brugerne bemærke en forringelse af ydeevnen, når Long Value-datatyperne manipuleres. Microsoft Access 97 aktiverer og deaktiverer automatisk denne facilitet, når moduler, formularer og rapporter manipuleres, og fjerner derfor behovet for at aktivere den, når disse objekter ændres. Standardværdien er 0. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
MaxBufferSize Størrelsen på den interne cache i databasemotoren, målt i kilobyte (KB). MaxBufferSize skal være en heltalsværdi, der er større end eller lig med 512. Standard er baseret på følgende form:

((TotalRAM in MB - 12 MB) / 4) + 512 KB

I forbindelse med et system på 32 MB RAM er standardstørrelsen på bufferen f.eks. ((32 MB - 12 MB) / 4) + 512 KB or 5632 KB. Hvis værdien skal angives til standardværdien, skal registreringsnøglen angives til

MaxBufferSize=

Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
Threads | Det antal baggrundstråde, der er tilgængelige for Microsoft Jet-databasemotoren. Standard er 3. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
UserCommitSync | Angiver, om systemet venter på, at en bekræftelse skal udføres. Værdien Yes beder systemet vente, og værdien No beder systemet udføre bekræftelsen asynkront. Standard er Yes. Værdierne er af typen Streng i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.
ImplicitCommitSync | Angiver, om systemet venter på, at en bekræftelse skal udføres. Værdien No beder systemet fortsætte udførelsen uden at vente på, at bekræftelsen afsluttes. Værdien Yes beder systemet vente på, at bekræftelsen afsluttes. Standard er No. Værdierne er af typen String i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.
ExclusiveAsyncDelay | Angiver den tid i millisekunder, det tager at udskyde en asynkron tømning af en database med udelt adgang. Standardværdien er 2000 eller 2 sekunder. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
SharedAsyncDelay | Angiver den tid i millisekunder, det tager at udskyde en asynkron tømning af en delt database. Standardværdien er 0. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
PagesLockedToTableLock Ved en stor gruppe af handlinger er det ofte mere effektivt at låse en hel tabel i stedet for at låse hver enkelt side i tabellen, når du forsøger at åbne den.

Denne indstilling angiver, hvor mange sider der kan låses i en bestemt transaktion, før Microsoft Jet forsøger at benytte en udelt tabellås

Standardværdien 0 angiver, at Jet aldrig vil skifte automatisk fra sidelåsning til tabellåsning.

Bemærk! Denne indstilling skal bruges med forsigtighed. Hvis databasen skal bruges til flerbrugeradgang, vil låsning af en hel tabel skabe låsningskonflikter for andre brugere. Dette vil være særligt problematisk, hvis der bruges et lille tal i denne indstilling. Selv om der bruges et større tal, f.eks. 25 eller 50, kan handlingen for andre brugere blive uforudsigelig.

Replikeringsindstillinger til Microsoft Jet Engine

Nøglen Jet\4.0\Transporter medtager initialiseringsindstillinger til Jet Replication-synkroniseringer via Jet Synchronizer. Disse indstillinger bestemmer rækkefølgen af de specifikke transporter, som Synchronizer vil forsøge at udføre. De gyldige værdier er 0-100. En værdi på 0 betyder, at der ikke bør forsøges at udføre en transport. Alle transporttyper med ikke-nul værdier forsøges ifølge nøgleværdierne i stigende rækkefølge, indtil synkroniseringen lykkedes, eller indtil alle forsøg mislykkedes.

Typiske initialiseringsindstillinger af indtastningerne i denne mappe vises i følgende eksempel:

Priority_FS=1

Priority_Internet=2

Priority_direct=3

Microsoft Jet-databasemotoren bruger følgende prioriterede indstillinger:

Indtastning | Beskrivelse
Priority_FS | Filsystem-synkronisering (indirekte) afhænger af en række udvekslinger af meddelelser mellem replikaer. Synchronizer, der styrer hver enkelt replika, samler ændringer i meddelelsesfiler (*.msg), der kopieres til en delt mappe, kaldet mappen med rullelisten. Mappen med rullelisten bruges af Synchronizer-partneren og kan åbnes fra filsystemet.
Priority_Internet | Internet-synkronisering (indirekte) afhænger af en række udvekslinger af meddelelser mellem replikaer. Kun replikaer, der styres af Synchronizer på Internet-serveren, har en mappe med en rulleliste, der kan åbnes via en HTTP- eller FTP-forbindelse.
Priority_direct | Direkte synkronisering er den proces, hvor data udveksles og design ændres mellem to medlemmer af et replikasæt, der er direkte forbundet, enten på den samme computer eller i et netværk. Synchronizer åbner begge databaser.

Bemærk! Når du ændrer indstillinger i Windows-registreringsdatabasen, skal du afslutte og derefter genstarte databasemotoren, for at de nye indstillinger træder i kraft.

Se også

Tilpasning af indstillinger i Windows-registreringsdatabasen til Microsoft Jet


Initialisering af Microsoft Jet 2.5-databasemotordriveren

Når du installerer Microsoft® Jet version 2.5-databasemotordriveren, skriver installationsprogrammet et sæt standardværdier til Microsoft Windows®-registreringsdatabasen i undernøglerne Engines og ISAM Formats. Du skal bruge Registreringseditor til at tilføje, fjerne eller ændre disse indstillinger. I de følgende afsnit beskrives initialisering og ISAM Format-indstillinger til Microsoft Jet Engine-databasedriveren.

Initialiseringsindstillinger til Microsoft Jet Engine

I mappen Jet\4.0\Engines\Jet 2.x findes de initialiseringsindstillinger til msrd2x40.dll-driveren, der bruges til at få ekstern adgang til Microsoft Access 2.0-regneark. Typiske initialiseringsindstillinger af indtastningerne i denne mappe vises i følgende eksempel.

win32=<sti>\ msrd2x40.dll

PageTimeout=5

LockedPageTimeout=5

CursorTimeout=5

LockRetry=20

CommitLockRetry=20

MaxBufferSize=512

ReadAheadPages=16

IdleFrequency=10

ForceOsFlush = 0

Følgende indtastninger bruges til at konfigurere Microsoft Jet-databasemotoren:

Indtastning | Beskrivelse
win32 | Placering af databasemotordriveren (.dll). Stien bestemmes på installationstidspunktet. Værdierne er af typen Streng i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.
PageTimeout | Den tid, der går, fra at data, der ikke er læselåst, placeres i en intern cache, og til de bliver gjort ugyldige, udtrykt i enheder på 100 millisekunder. Standard er fem enheder (eller 0,5 sekunder). Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
LockedPageTimeout | Den tid, der går, fra at data, der er læselåst, placeres i en intern cache, og til de bliver gjort ugyldige, udtrykt i enheder på 100 millisekunder. Standard er fem enheder (eller 0,5 sekunder). Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
CursorTimeout | Den tid, en reference til en side forbliver på den pågældende side, udtrykt i enheder på 100 millisekunder. Standard er fem enheder (eller 0,5 sekunder). Denne indstilling anvendes kun på databaser, der er oprettet med version 1.x af Microsoft Jet-databasemotoren. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
LockRetry | Det antal gange, der bliver gjort forsøg på at få adgang til en låst side, før en låsekonfliktmeddelelse returneres. Standard er 20 gange. LockRetry er relateret til CommitLockRetry. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
CommitLockRetry Det antal gange, Microsoft Jet-databasemotoren forsøger at anbringe en lås på data for at bekræfte ændringer i de pågældende data. Hvis Microsoft Jet-databasemotoren ikke kan anbringe en bekræftelseslås, lykkes ændringer af dataene ikke.

Det antal forsøg, Microsoft Jet-databasemotoren gør for at hente en bekræftelseslås, er direkte relateret til værdien LockRetry. I forbindelse med hvert forsøg på at anbringe en bekræftelseslås vil Microsoft Jet-databasemotoren gøre så mange forsøg på at anbringe en lås, som der er angivet af værdien LockRetry. Hvis CommitLockRetry f.eks. er angivet til 20, og LockRetry er angivet til 20, vil Microsoft Jet-databasemotoren forsøge at anbringe en bekræftelseslås op til 20 gange. I forbindelse med hvert af disse forsøg vil Microsoft Jet-databasemotoren forsøge at anbringe en lås op til 20 gange, i alt 400 forsøg.

Standardværdien for CommitLockRetry er 20. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
MaxBufferSize | Størrelsen på den interne cache i databasemotoren, målt i kilobyte (KB). MaxBufferSize skal være en heltalsværdi mellem 9 og 4096, inklusive. Standard er 512. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
ReadAheadPages | Det antal sider, der skal læses forud, når der udføres sekventielle skanninger. Standard er 16. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
ForceOSFlush | En anden indstilling end 0 betyder, at en bekræftelse eller en skrivning vil gennemtvinge, at OS-cachen tømmes på disken. En indstilling på 0 (standardindstillingen) betyder, at der ikke opstår nogen gennemtvunget tømning. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
IdleFrequency | Det tidsrum, i enheder på 100 millisekunder, som Microsoft Jet vil vente, før en læselås udløses. Standard er 10 enheder eller ét sekund. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.

Microsoft Jet Engine ISAM Formats

Mappen Jet\4.0\ISAM Formats\Jet 2.x indeholder følgende indtastninger:

Indtastningsnavn | Windows NT 3.51-type | Windows 95- og Windows NT 4.0-type | Værdi
Engine | REG_SZ | Streng | Jet 2.x
OneTablePerFile | REG_BINARY | Binær | 00
IndexDialog | REG_BINARY | Binær | 00
CreateDBOnExport | REG_BINARY | Binær | 00
IsamType | REG_DWORD | DWORD | 0

Bemærk! Når du ændrer indstillinger i Windows-registreringsdatabasen, skal du afslutte og derefter genstarte databasemotoren, for at de nye indstillinger træder i kraft.

Se også

Tilpasning af indstillinger i Windows-registreringsdatabasen til Microsoft Jet


Initialisering af Lotus-driveren

Når du installerer Lotus-databasedriveren, skriver installationsprogrammet et sæt standardværdier til Microsoft® Windows®-registreringsdatabasen i undernøglerne Engines og ISAM Formats. Du skal ikke redigere disse indstillinger direkte. Brug installationsprogrammet til programmet til at tilføje, fjerne eller ændre disse indstillinger. I de følgende afsnit beskrives initialisering og ISAM Format-indstillinger til Lotus-databasedriveren.

Lotus-initialiseringsindstillinger

I mappen Jet\4.0\Engines\Lotus findes initialiseringsindstillinger til driveren msltus40.dll, der bruges til at få ekstern adgang til Lotus-regneark. Typiske indstillinger af indtastningerne under denne overskrift vises i følgende eksempel.

win32=<sti>\msltus40.dll

TypeGuessRows=8

ImportMixedTypes=Text

AppendBlankRows=4

FirstRowHasNames=Yes

Microsoft Jet-databasemotoren bruger Lotus-mappeindtastningerne på følgende måde:

Indtastning | Beskrivelse
win32 | Placeringen af msltus40.dll. Den fulde sti bestemmes på installationstidspunktet. Værdierne er af typen Streng i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.
TypeGuessRows | Det antal rækker, der skal kontrolleres i forbindelse med datatypen. Datatypen bestemmes på basis af den hyppigst fundne datatype i markeringen. Hvis der er en begrænsning, bestemmes datatypen i følgende rækkefølge: Number, Currency, Date, Text, Long Text. Hvis der er data, som ikke passer til den datatype, der er anslået til kolonnen, returneres de som en Null-værdi. Hvis en kolonne har blandede datatyper i forbindelse med import, bliver hele kolonnen konverteret i overensstemmelse med indstillingen ImportMixedTypes. Det antal rækker, der som standard skal kontrolleres, er otte. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
ImportMixedTypes | Kan angives til MajorityType eller Text. Hvis MajorityType er angivet, bliver kolonner med blandede datatyper omformet til den fremherskende datatype ved import. Hvis Text er angivet, bliver kolonner med blandede datatyper omformet til Text ved import. Standard er Text. Værdierne er af typen Streng i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.
AppendBlankRows | Det antal tomme rækker, der skal tilføjes i slutningen af et WK1-regneark, før ny data tilføjes. Hvis AppendBlankRows f.eks. er angivet til fire, vil Microsoft Jet tilføje fire tomme rækker i slutningen af regnearket, før der tilføjes rækker, der indeholder data. Heltalsværdierne til denne indstilling kan ligge i intervallet 0 til 16. Standard er 01 (en ekstra tilføjet række). Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
FirstRowHasNames | En binær værdi, der angiver, om den første række i tabellen indeholder kolonnenavne. Værdien 01 angiver, at kolonnenavne under import hentes fra den første række. Værdien 00 angiver, at der ingen kolonnenavne er i den første række. Kolonnenavne vises som F1, F2, F3 osv. Standard er 01. Værdierne er af typen Binær i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_BINARY i forbindelse med Windows NT 3.51.

Lotus ISAM Formats

Mappen Jet\4.0\ISAM Formats\Lotus WK1 indeholder følgende indtastninger:

Indtastningsnavn | Windows NT 3.51-type | Windows 95- og Windows NT 4.0-type | Værdi
Engine | REG_SZ | Streng | Lotus
ExportFilter | REG_SZ | Streng | Lotus 1-2-3 WK1 (*.wk1)
ImportFilter | REG_SZ | Streng | Lotus 1-2-3 (*.wk* )
CanLink | REG_BINARY | Binær | 00
OneTablePerFile | REG_BINARY | Binær | 00
IsamType | REG_DWORD | DWORD | 1
IndexDialog | REG_BINARY | Binær | 00
CreateDBOnExport | REG_BINARY | Binær | 01
ResultTextImport | REG_SZ | Streng | Importerer data fra den eksterne fil til den aktuelle database. Ændring af data i den aktuelle database ændrer ikke dataene i den eksterne fil.
ResultTextExport | REG_SZ | Streng | Eksporterer data fra den aktuelle database til en Lotus 1-2-3 version 2-fil. Denne proces overskriver dataene, hvis de eksporteres til en eksisterende fil.
SupportsLongNames | REG_BINARY | Binær | 01

Mappen Jet\4.0\ISAM Formats\Lotus WK3 indeholder følgende indtastninger:

Indtastningsnavn | Windows NT 3.51-type | Windows 95- og Windows NT 4.0-type | Værdi
Engine | REG_SZ | Streng | Lotus
ExportFilter | REG_SZ | Streng | Lotus 1-2-3 WK3 (*.wk3)
CanLink | REG_BINARY | Binær | 00
OneTablePerFile | REG_BINARY | Binær | 00
IsamType | REG_DWORD | DWORD | 1
IndexDialog | REG_BINARY | Binær | 00
CreateDBOnExport | REG_BINARY | Binær | 01
ResultTextExport | REG_SZ | Streng | Eksporterer data fra den aktuelle database til en Lotus 1-2-3 version 3-fil. Denne proces overskriver dataene, hvis de eksporteres til en eksisterende fil.
SupportsLongNames | REG_BINARY | Binær | 01

Mappen Jet\4.0\ISAM Formats\Lotus WK4 indeholder følgende indtastninger:

Indtastningsnavn | Windows NT 3.51-type | Windows 95- og Windows NT 4.0-type | Værdi
Engine | REG_SZ | Streng | Lotus
CanLink | REG_BINARY | Binær | 00
OneTablePerFile | REG_BINARY | Binær | 00
IsamType | REG_DWORD | DWORD | 1
IndexDialog | REG_BINARY | Binær | 00
CreateDBOnExport | REG_BINARY | Binær | 01
SupportsLongNames | REG_BINARY | Binær | 01

Mappen Jet\4.0\ISAM Formats\Lotus WJ2 indeholder følgende indtastninger:

Indtastningsnavn | Windows NT 3.51-type | Windows 95- og Windows NT 4.0-type | Værdi
Engine | REG_SZ | Streng | Lotus
ExportFilter | REG_SZ | Streng | Lotus 1-2-3 WJ2 (*.wj2)
ImportFilter | REG_SZ | Streng | Lotus 1-2-3/DOS (*.wj* )
CanLink | REG_BINARY | Binær | 00
OneTablePerFile | REG_BINARY | Binær | 00
IsamType | REG_DWORD | DWORD | 1
IndexDialog | REG_BINARY | Binær | 00
CreateDBOnExport | REG_BINARY | Binær | 01
ResultTextExport | REG_SZ | Streng | Eksporterer data fra den aktuelle database til en Lotus 1-2-3 version 2-fil. Denne proces overskriver dataene, hvis de eksporteres til en eksisterende fil.
SupportsLongNames | REG_BINARY | Binær | 01

Mappen Jet\4.0\ISAM Formats\Lotus WJ3 indeholder følgende indtastninger:

Indtastningsnavn | Windows NT 3.51-type | Windows 95- og Windows NT 4.0-type | Værdi
Engine | REG_SZ | Streng | Lotus
CanLink | REG_BINARY | Binær | 00
OneTablePerFile | REG_BINARY | Binær | 00
IsamType | REG_DWORD | DWORD | 1
IndexDialog | REG_BINARY | Binær | 00
CreateDBOnExport | REG_BINARY | Binær | 01
SupportsLongNames | REG_BINARY | Binær | 01

Bemærk! Når du ændrer indstillinger i Windows-registreringsdatabasen, skal du afslutte og derefter genstarte databasemotoren, for at de nye indstillinger træder i kraft.

Se også

Tilpasning af indstillinger i Windows-registreringsdatabasen til Microsoft Jet


Konfigurering af Microsoft Jet-databasemotoren til ODBC-adgang

I de følgende afsnit beskrives indstillinger i Microsoft® Windows®-registreringsdatabasen til Microsoft Jet-databasemotoren i forbindelse med tilslutning til en ODBC-database.

Initialiseringsindstillinger til Microsoft Jet-tilsluttede ODBC-databaser

Mappen \HKEY_LOCAL_MACHINE\Software\Microsoft\Jet\4.0\Engines\ODBC indeholder initialiseringsindstillinger til Microsoft Jet-databasemotoren.

Bemærk! Typiske indstillinger af indtastningerne i mappen Jet\4.0\Engines\ODBC vises i følgende eksempel.

LoginTimeout=20

QueryTimeout=60

ConnectionTimeout=600

AsyncRetryInterval=500

AttachCaseSensitive=0

AttachableObjects='TABLE','VIEW','SYSTEM TABLE','ALIAS','SYNONYM'

SnapshotOnly=0

TraceSQLMode=0

TraceODBCAPI=0

DisableAsync=1

TryJetAuth=1

PreparedInsert=0

PreparedUpdate=0

FastRequery=0

FatBlastRows=-1

FatBlastTimeout=3

ODBCISAMAttach=0

Microsoft Jet-databasemotoren bruger ODBC-indtastningerne på følgende måde:

Indtastning | Beskrivelse
LoginTimeout | Det antal sekunder, et logonforsøg kan vare, før timeout. Standard er 20 (værdierne er af typen REG_DWORD).
QueryTimeout | Det antal sekunder, en forespørgsel kan køre (total behandlingstid), før timeout. Hvis DisableAsync=0 (standard), så er QueryTimeout det antal sekunder, der skal ventes på et svar fra serveren mellem pollinger under udførelse af forespørgsler. Standard er 60 (værdierne er af typen REG_DWORD).
ConnectionTimeout | Det antal sekunder, en cachelagret tilslutning kan forblive inaktiv, før timeout. Standard er 600 (værdierne er af typen REG_DWORD).
AsyncRetryInterval | Det antal millisekunder, det tager mellem pollinger at bestemme, om serveren er færdig med at behandle en forespørgsel. Denne indtastning bruges kun i forbindelse med asynkron behandling. Standard er 500 (værdierne er af typen REG_DWORD).
AttachCaseSensitive | En angivelse af, om tabelnavne skal være i fuld overensstemmelse ved sammenkædning. Værdierne er 0 (sammenkæder den første tabel, der svarer til det angivne navn, uanset store eller små bogstaver) og 1 (sammenkæder kun en tabel, hvis navnet er i nøjagtig overensstemmelse). Standard er 0 (værdierne er af typen REG_DWORD).
AttachableObjects | En liste over de serverobjekttyper, hvor sammenkædning er mulig. Standard er: 'TABLE', 'VIEW', 'SYSTEM TABLE', 'ALIAS' og 'SYNONYM' (værdierne er af typen REG_SZ).
SnapshotOnly | En angivelse af, om Recordset-objekter gennemtvinges til at være af typen snapshot. Værdierne er 0 (tillader dynamiske udvalg) og 1 (gennemtvinger kun snapshot). Standard er 0 (værdierne er af typen REG_DWORD).
TraceSQLMode | En angivelse af, om Microsoft Jet-databasemotoren vil spore SQL-sætninger, der er sendt til en ODBC-datakilde i SQLOUT.txt. Værdierne er 0 (no) og 1 (yes). Standard er 0 (værdierne er af typen REG_DWORD). Denne indtastning kan udskiftes med SQLTraceMode.
TraceODBCAPI | En angivelse af, om der skal spores ODBC API-kald i ODBCAPI.txt. Værdierne er 0 (no) og 1 (yes). Standard er 0 (værdierne er af typen REG_DWORD).
DisableAsync | En angivelse af, om der skal gennemtvinges synkron udførelse af forespørgsler. Værdierne er 0 (brug synkron udførelse af forespørgsler, hvis det er muligt) og 1 (gennemtvinger synkron udførelse af forespørgsler). Standard er 1 (værdierne er af typen REG_DWORD).
TryJetAuth | En angivelse af, om der skal gøres forsøg på at bruge Microsoft Access-brugernavn og -adgangskode til at logge på serveren, før brugeren spørges. Værdierne er 0 (no) og 1 (yes). Standard er 1 (værdierne er af typen REG_DWORD).
PreparedInsert | En angivelse af, om der skal bruges en forberedt INSERT-sætning, der indsætter data i alle kolonner. Værdierne er 0 (bruger en brugerdefineret INSERT-sætning, der kun indsætter ikke-Null-værdier) og 1 (bruger en forberedt INSERT-sætning). Standard er 0 (værdierne er af typen REG_DWORD). Brug af forberedte INSERT-sætninger kan medføre, at Null-værdier overskriver serverstandarder, samt at udløsningsmekanismer udføres i kolonner, der ikke er indsat eksplicit.
PreparedUpdate | En angivelse af, om der skal bruges en forberedt UPDATE-sætning, der opdaterer data i alle kolonner. Værdierne er 0 (bruger en brugerdefineret UPDATE-sætning, der kun angiver kolonner, der er ændret) og 1 (bruger en forberedt UPDATE-sætning). Standard er 0 (værdierne er af typen REG_DWORD). Brug af forberedte UPDATE-sætninger kan medføre, at udløsningsmekanismer udføres i uændrede kolonner.
FastRequery | En angivelse af, om der skal bruges en forberedt SELECT-sætning til parameterforespørgsler. Værdierne er 0 (no) og 1 (yes). Standard er 0 (værdierne er af typen REG_DWORD).
FatBlastRows |
FatBlastTimeout |
ODBCISAMAttach |

Bemærk! Når du ændrer indstillinger i Windows-registreringsdatabasen, skal du afslutte og derefter genstarte databasemotoren, for at de nye indstillinger træder i kraft.

Se også

Tilpasning af indstillinger i Windows-registreringsdatabasen til Microsoft Jet


Initialisering af Paradox-databasedriveren

Når du installerer Paradox-databasedriveren, skriver installationsprogrammet et sæt standardværdier til Microsoft® Windows®-registreringsdatabasen i undernøglerne Engines og ISAM Formats. Du skal ikke redigere disse indstillinger direkte (medmindre det er nødvendigt). Brug installationsprogrammet til at tilføje, fjerne eller ændre disse indstillinger. I de følgende afsnit beskrives initialisering og ISAM Format-indstillinger til Paradox-databasedriveren.

Paradox-databasedriveren fungerer i en af to tilstande, afhængigt af om Borland Database Engine (BDE) er installeret. Paradox-data kan kun opdateres med BDE. Uden BDE kan Paradox-data være Read, Exported eller Linked to read-only.

Initialiseringsindstillinger til Paradox

Mappen Jet\4.0\Engines\Paradox indeholder de initialiseringsindstillinger til Mspdox35.dll-driveren, der bruges til at få adgang til eksterne Paradox-data. Typiske indstillinger af indtastningerne i denne mappe vises i følgende eksempel.

win32=<sti>\ mspbde40.dll

PageTimeout=600

CollatingSequence=ASCII

DataCodePage=OEM

ParadoxUserName=Kimberly

ParadoxNetPath=P:\PDOXDB

ParadoxNetStyle=4.X

Microsoft Jet-databasemotoren bruger indtastningerne i Paradox-mappen på følgende måde:

Indtastning | Beskrivelse
win32 | Placeringen af mspbde40.dll. Den fulde sti bestemmes på installationstidspunktet. Værdierne er af typen Streng i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.
PageTimeout | Den tid, der går, fra data placeres i en intern cache, til de bliver gjort ugyldige. Værdien angives i enheder på 100 millisekunder. Standard er 600 enheder eller 60 sekunder. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
CollatingSequence Denne indstilling bruges kun, hvis BDE ikke findes på maskinen.

Sorteringsrækkefølgen for alle Paradox-tabeller, der er oprettet eller åbnet ved hjælp af Microsoft Jet-databasemotoren. Mulige værdier er ASCII, International, Norsk-dansk og Svensk-finsk. Indtastningen CollatingSequence skal svare til den sorteringsrækkefølge, der blev brugt, da Paradox-tabellen blev oprettet. Standard er ASCII. Værdierne er af typen Streng i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.
DataCodePage Denne indstilling bruges kun, hvis BDE ikke findes på maskinen.

En indikator for, hvordan tekstsider lagres. Mulige indstillinger er:

  • OEM – OemToAnsi- og AnsiToOem-konverteringer er afsluttet.
  • ANSI – OemToAnsi- og AnsiToOem-konverteringer er ikke afsluttet.

Standard er OEM. Værdierne er af typen Streng i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.
ParadoxUserName Det navn, der skal vises af Paradox, hvis en tabel er låst Paradox ISAM, og hvis en interaktiv bruger med adgang til dataene i Paradox (i stedet for ISAM) forsøger at placere en inkompatibel lås. Denne indtastning tilføjes ikke af installationsprogrammet. Du skal oprette denne indtastning. Værdierne er af typen Streng i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.

Bemærk! Hvis du angiver ParadoxUserName, skal du også angive ParadoxNetPath og ParadoxNetStyle, ellers opstår der en fejl, når du forsøger at få adgang til eksterne Paradox-data. Hvis du åbner en Paradox-database i flerbrugertilstand på netværket, skal du tilføje eller redigere registreringsindtastningen manuelt.
ParadoxNetPath Den fulde sti til det bibliotek, der indeholder filen Paradox.net (til Paradox 3.x) eller filen Pdoxusrs.net (til Paradox 4.x). Denne indtastning tilføjes ikke af installationsprogrammet. Du skal oprette denne indtastning. Den fulde ParadoxNetPath (herunder drevbogstavet) skal være konsistent for alle brugere, der deler en bestemt database (bibliotek). Værdierne er af typen Streng i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.

Bemærk! Hvis du angiver ParadoxNetName, skal du også angive ParadoxUserPath og ParadoxNetStyle, ellers opstår der en fejl, når du forsøger at få adgang til eksterne Paradox-data. Hvis du åbner en Paradox-database i flerbrugertilstand på netværket, skal du tilføje eller redigere registreringsindtastningen manuelt.
ParadoxNetStyle Den netværksadgangstype, der skal bruges ved adgang til Paradox-data. Mulige værdier er:
  • 3.x
  • 4.x

Bemærk! Paradox 3.x-brugere kan ikke angive denne til 4.x ellers bruger driveren den forkerte låsemetode. Paradox 5.0-brugere skal bruge indstillingen 4.x ParadoxNetStyle for at sikre den rette låsefunktionsmåde.

Denne indtastning tilføjes ikke af installationsprogrammet. Du skal oprette denne indtastning. Indtastningen skal svare til en vilkårlig version af Paradox, som brugerne i gruppen anvender. Den skal være konsistent for alle brugere, der deler en bestemt database (bibliotek). Standard er 4.x. Værdierne er af typen Streng i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.

Bemærk! Hvis du angiver ParadoxNetStyle, skal du også angive ParadoxUserName og ParadoxNetPath, ellers opstår der en fejl, når du forsøger at få adgang til eksterne Paradox-data.

Paradox ISAM Formats

Mappen Jet\4.0\ISAM Formats\Paradox 3.x indeholder følgende indtastninger:

Indtastningsnavn | Windows NT 3.51-type | Windows 95- og Windows NT 4.0-type | Værdi
Engine | REG_SZ | Streng | Paradox
ExportFilter | REG_SZ | Streng | Paradox 3 (*.db)
ImportFilter | REG_SZ | Streng | Paradox (*.db)
CanLink | REG_BINARY | Binær | 01
OneTablePerFile | REG_BINARY | Binær | 01
IsamType | REG_DWORD | DWORD | 0
IndexDialog | REG_BINARY | Binær | 00
CreateDBOnExport | REG_BINARY | Binær | 00
ResultTextImport | REG_SZ | Streng | Importerer data fra den eksterne fil til den aktuelle database. Ændring af data i den aktuelle database ændrer ikke dataene i den eksterne fil.
ResultTextLink | REG_SZ | Streng | Opretter en tabel i den aktuelle database, der er sammenkædet med den eksterne fil. Ændring af data i den aktuelle database vil ændre dataene i den eksterne fil.
ResultTextExport | REG_SZ | Streng | Eksporterer data fra den aktuelle database til en Paradox 3-fil. Denne proces overskriver dataene, hvis de eksporteres til en eksisterende fil.
SupportsLongNames | REG_BINARY | Binær | 00

Mappen Jet\4.0\ISAM Formats\Paradox 4.x indeholder følgende indtastninger:

Indtastningsnavn | Windows NT 3.51-type | Windows 95- og Windows NT 4.0-type | Værdi
Engine | REG_SZ | Streng | Paradox
ExportFilter | REG_SZ | Streng | Paradox 4 (*.db)
CanLink | REG_BINARY | Binær | 01
OneTablePerFile | REG_BINARY | Binær | 01
IsamType | REG_DWORD | DWORD | 0
IndexDialog | REG_BINARY | Binær | 00
CreateDBOnExport | REG_BINARY | Binær | 00
ResultTextExport | REG_SZ | Streng | Eksporterer data fra den aktuelle database til en Paradox 4-fil. Denne proces overskriver dataene, hvis de eksporteres til en eksisterende fil.
SupportsLongNames | REG_BINARY | Binær | 00

Mappen Jet\4.0\ISAM Formats\Paradox 5.x indeholder følgende indtastninger:

Indtastningsnavn | Windows NT 3.51-type | Windows 95- og Windows NT 4.0-type | Værdi
Engine | REG_SZ | Streng | Paradox
ExportFilter | REG_SZ | Streng | Paradox 5 (*.db)
CanLink | REG_BINARY | Binær | 01
OneTablePerFile | REG_BINARY | Binær | 01
IsamType | REG_DWORD | DWORD | 0
IndexDialog | REG_BINARY | Binær | 00
CreateDBOnExport | REG_BINARY | Binær | 00
ResultTextExport | REG_SZ | Streng | Eksporterer data fra den aktuelle database til en Paradox 5-fil. Denne proces overskriver dataene, hvis de eksporteres til en eksisterende fil.
SupportsLongNames | REG_BINARY | Binær | 00

Mappen Jet\4.0\ISAM Formats\Paradox 7.x indeholder følgende indtastninger:

Indtastningsnavn | Windows NT 3.51-type | Windows 95- og Windows NT 4.0-type | Værdi
Engine | REG_SZ | Streng | Paradox
ExportFilter | REG_SZ | Streng | Paradox 7 (*.db)
CanLink | REG_BINARY | Binær | 01
OneTablePerFile | REG_BINARY | Binær | 01
IsamType | REG_DWORD | DWORD | 0
IndexDialog | REG_BINARY | Binær | 00
CreateDBOnExport | REG_BINARY | Binær | 00
ResultTextExport | REG_SZ | Streng | Eksporterer data fra den aktuelle database til en Paradox 7-fil. Denne proces overskriver dataene, hvis de eksporteres til en eksisterende fil.
SupportsLongNames | REG_BINARY | Binær | 00

Bemærk! Når du ændrer indstillinger i Windows-registreringsdatabasen, skal du afslutte og derefter genstarte databasemotoren, for at de nye indstillinger træder i kraft.

Se også

Tilpasning af indstillinger i Windows-registreringsdatabasen til Microsoft Jet


Initialisering af Text- og HTML-datakildedriveren

De samme databasedrivere bruges til Text- og HTML-datakilder.

Når du installerer Text-datakildedriveren, skriver installationsprogrammet et sæt standardværdier til Microsoft® Windows®-registreringsdatabasen i undernøglerne Engines og ISAM Formats. Du skal ikke redigere disse indstillinger direkte. Brug installationsprogrammet til programmet til at tilføje, fjerne eller ændre disse indstillinger. I de følgende afsnit beskrives initialisering og ISAM Format-indstillinger for databasedriveren til Text-datakilden.

Initialiseringsindstillinger til Text-datakilden

Mappen Jet\4.0\Engines\Text indeholder de initialiseringsindstillinger til Mstext35.dll-driveren, der bruges til ekstern adgang til tekstdatafiler. Typiske indstillinger af indtastningerne i denne mappe vises i følgende eksempel.

win32=<sti>\ mstext40.dll

MaxScanRows=25

FirstRowHasNames=True

CharacterSet= ANSI

Format=CSVDelimited

Extensions= txt,csv,tab,asc

ExportCurrencySymbols=Yes

Microsoft Jet-databasemotoren bruger tekstmappen på følgende måde:

Indtastning | Beskrivelse
win32 | Placeringen af mstext40.dll. Den fulde sti bestemmes på installationstidspunktet. Værdierne er af typen Streng i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.
MaxScanRows | Det antal rækker, der skal skannes, når kolonnetyperne anslås. Hvis 0 er angivet, gennemsøges hele filen. Standard er 25. Værdierne er af typen DWORD i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_DWORD i forbindelse med Windows NT 3.51.
FirstRowHasNames | En binær værdi, der angiver, om den første række i tabellen indeholder kolonnenavne. Værdien 01 angiver, at kolonnenavne under import hentes fra den første række. Værdien 00 angiver, at der ikke er nogen kolonnenavne i den første række. Standard er 01. Værdierne er af typen Binær i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_BINARY i forbindelse med Windows NT 3.51.
CharacterSet En indikator for, hvordan tekstsider lagres. Mulige indstillinger er:
  • ANSI – Maskinens ANSI-tegntabel. AnsiToUnicode- og UnicodeToAnsi-konverteringer er udført.
  • OEM – Maskinens OEM-tegntabel. OemToUnicode- og UnicodeToOem-konverteringer er udført.
  • Unicode – tegntabelkonverteringer er ikke udført.
  • <decimaltal> – Tegntabelnummeret på et bestemt tegnsæt. Konverteringer til og fra Unicode vil blive udført.

Standard er ANSI. Værdierne er af typen Streng i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.
Format | Kan være en af følgende: TabDelimited, CSVDelimited, Delimited (<enkelttegn>). Afgrænseren med enkelttegn i formatet Delimited kan være ethvert enkelttegn undtagen et dobbelt anførselstegn ("). Standard er CSVDelimited. Værdierne er af typen Streng i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.
Extensions | Filtypenavnet på de filer, der skal gennemses, når der søges efter tekstbaserede data. Standard er txt, csv, tab, asc. Værdierne er af typen Streng i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.
ExportCurrencySymbols | En binær værdi, der angiver, om det rette valutasymbol er medtaget, når valutafelter eksporteres. Værdien 01 angiver, at symbolet er medtaget. Værdien 00 angiver, at kun numeriske data eksporteres. Standard er 01. Værdierne er af typen Binær i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_BINARY i forbindelse med Windows NT 3.51.

Text-datakilde ISAM Formats

Mappen Jet\4.0\ISAM Formats\Text indeholder følgende indtastninger:

Indtastningsnavn | Windows NT 3.51-type | Windows 95- og Windows NT 4.0-type | Værdi
Engine | REG_SZ | Streng | Text
ExportFilter | REG_SZ | Streng | Tekst-filer (*.txt; *.csv; *.tab; *.asc)
ImportFilter | REG_SZ | Streng | Tekst-filer (*.txt; *.csv; *.tab; *.asc)
CanLink | REG_BINARY | Binær | 01
OneTablePerFile | REG_BINARY | Binær | 01
IsamType | REG_DWORD | DWORD | 2
IndexDialog | REG_BINARY | Binær | 00
CreateDBOnExport | REG_BINARY | Binær | 00
ResultTextImport | REG_SZ | Streng | Importerer data fra den eksterne fil til den aktuelle database. Ændring af data i den aktuelle database ændrer ikke dataene i den eksterne fil.
ResultTextLink | REG_SZ | Streng | Opretter en tabel i den aktuelle database, der er sammenkædet med den eksterne fil. Ændring af data i den aktuelle database vil ændre dataene i den eksterne fil.
ResultTextExport | REG_SZ | Streng | Eksporterer data fra den aktuelle database til en tekstfil. Denne proces overskriver dataene, hvis de eksporteres til en eksisterende fil.
SupportsLongNames | REG_BINARY | Binær | 01

Bemærk! Når du ændrer indstillinger i Windows-registreringsdatabasen, skal du afslutte og derefter genstarte databasemotoren, for at de nye indstillinger træder i kraft.

HTML Import ISAM Formats

Mappen Jet\4.0\ISAM Formats\HTML Import indeholder følgende indtastninger:

Indtastningsnavn | Windows NT 3.51-type | Windows 95- og Windows NT 4.0-type | Værdi
Engine | REG_SZ | Streng | Text
ImportFilter | REG_SZ | Streng | HTML-filer (*.ht*)
CanLink | REG_BINARY | Binær | 01
OneTablePerFile | REG_BINARY | Binær | 00
IsamType | REG_DWORD | DWORD | 2
IndexDialog | REG_BINARY | Binær | 00
CreateDBOnExport | REG_BINARY | Binær | 00
ResultTextImport | REG_SZ | Streng | Importerer data fra den eksterne fil til den aktuelle database. Ændring af data i den aktuelle database ændrer ikke dataene i den eksterne fil.
ResultTextLink | REG_SZ | Streng | Opretter en tabel i den aktuelle database, der er sammenkædet med den eksterne fil. Ændring af data i den aktuelle database vil ændre dataene i den eksterne fil.
SupportsLongNames | REG_BINARY | Binær | 01

Bemærk! Når du ændrer indstillinger i Windows-registreringsdatabasen, skal du afslutte og derefter genstarte databasemotoren, for at de nye indstillinger træder i kraft.

HTML Export ISAM Formats

Mappen Jet\4.0\ISAM Formats\HTML Export indeholder følgende indtastninger:

Indtastningsnavn | Windows NT 3.51-type | Windows 95- og Windows NT 4.0-type | Værdi
Engine | REG_SZ | Streng | Text
ExportFilter | REG_SZ | Streng | HTML-filer (*.htm)
CanLink | REG_BINARY | Binær | 00
OneTablePerFile | REG_BINARY | Binær | 01
IsamType | REG_DWORD | DWORD | 2
IndexDialog | REG_BINARY | Binær | 00
CreateDBOnExport | REG_BINARY | Binær | 00
ResultTextExport | REG_SZ | Streng | Eksporterer data fra den aktuelle database til en tekstfil. Denne proces overskriver dataene, hvis de eksporteres til en eksisterende fil.
SupportsLongNames | REG_BINARY | Binær | 01

Bemærk! Når du ændrer indstillinger i Windows-registreringsdatabasen, skal du afslutte og derefter genstarte databasemotoren, for at de nye indstillinger træder i kraft.

Tilpasning af Schema.ini-filen til Text- og HTML-data

Hvis du vil læse, importere eller eksportere Text- og HTML-data, skal du oprette en Schema.ini-fil udover at medtage Text ISAM-oplysningerne i .ini-filen. Schema.ini indeholder detaljerede oplysninger om en datakilde: Hvordan tekstfilen formateres, hvordan den læses under import, og hvilket standardformat der bruges til eksport af filer. I følgende eksempler vises layoutet for en fil med fast bredde, Filnavn.txt:

[Filnavn.txt]

ColNameHeader=False

Format=FixedLength

FixedFormat= RaggedEdge

MaxScanRows=25

CharacterSet=OEM

Col1=columnname Char Width 24

Col2=columnname2 Date Width 9

Col3=columnname7 Float Width 10

Col4=columnname8 Integer Width 10

Col5=columnname9 LongChar Width 10

På samme måde angives formatet for en afgrænset fil:

[Afgræns.txt]

ColNameHeader=True

Format=Delimited()

MaxScanRows=0

CharacterSet=OEM

Col1=username char width 50

Col2=dateofbirth Date width 9

Hvis du eksporterer data til en afgrænset tekstfil, skal du også angive formatet for den pågældende fil:

[Eksport: Min særlige eksport]

ColNameHeader=True

Format=TabDelimited

MaxScanRows=25

CharacterSet=OEM

DateTimeFormat=mm.dd.yy.hh.mm.ss

CurrencySymbol=Dm

CurrencyPosFormat=0

CurrencyDigits=2

CurrencyNegFormat=0

CurrencyThousandSymbol=,

CurrencyDecimalSymbol=.

DecimalSymbol=,

NumberDigits=2

NumberLeadingZeros=0

TextDelimeter=”

Eksemplet Min særlige eksport refererer til en særlig eksportindstilling. Du kan angive enhver variation af eksportindstillinger ved tilslutningstidspunktet. Dette sidste eksempel svarer også til et datakildenavn (DSN), der valgfrit kan overføres ved tilslutningstidspunktet. Alle tre formatafsnit kan medtages i den samme .ini-fil.

Microsoft Jet-databasemotoren bruger Schema.ini-linjer på følgende måde:

Indtastning | Beskrivelse
ColNameHeader | Kan angives til enten True (angiver, at den første post med data angiver kolonnenavnene) eller False.
Format | Kan angives til en af følgende værdier: TabDelimited, CSVDelimited, Delimited (<enkelttegn>) eller FixedLength. Den afgrænser, der er angivet for filformatet Delimited, kan være ethvert enkelttegn med undtagelse af et dobbelt anførselstegn (").
FixedFormat Bruges kun, når Format er FixedLength. Det kan angives til en af følgende værdier: RaggedEdge eller TrueFixedLength.

RaggedEdge gør det muligt at afslutte rækker med et vognreturtegn.

TrueFixedLength kræver, at hver række består af et nøjagtigt antal tegn. Et vognreturtegn, der ikke er placeret for enden af en række, antages at være integreret i et felt.

Hvis denne indstilling ikke findes, er standardværdien RaggedEdge.
MaxScanRows | Angiver det antal rækker, der skal skannes, når kolonnedatatyperne anslås. Hvis 0 er angivet, gennemsøges hele filen.
CharacterSet | Kan indstilles til OEM, ANSI, UNICODE eller decimaltallet fra en gyldig tegntabel og angiver kildefilens tegnsæt.
DateTimeFormat | Kan angives til en formatstreng, der angiver datoer og klokkeslæt. Denne linje skal være angivet, hvis alle dato-/klokkeslætsfelter under import/eksport behandles med samme format. Alle formater i Microsoft Jet-databasemotoren med undtagelse af AM og PM understøttes. I mangel af en formatstreng bruges det korte datoformat og klokkeslætsindstillingerne i Windows Kontrolpanel.
CurrencySymbol | Angiver det valutasymbol, der skal bruges for valutaværdier i tekstfilen. Eksemplerne omfatter dollartegnet ($) og Dm. Hvis denne linje mangler, bruges standardværdien i Windows Kontrolpanel.
CurrencyPosFormat Kan angives til en af følgende værdier:

Valutasymbolpræfiks uden adskillelse ($1)

Valutasymbolsuffiks uden adskillelse (1$)

Valutasymbolpræfiks med adskillelse på ét tegn ($ 1)

Valutasymbolsuffiks med adskillelse på ét tegn (1 $)

Hvis denne linje mangler, bruges standardværdien i Windows Kontrolpanel.
CurrencyDigits | Angiver det antal cifre, der skal bruges til brøkdelen i et valutabeløb. Hvis denne linje mangler, bruges standardværdien i Windows Kontrolpanel.
CurrencyNegFormat Kan være en af følgende værdier:

($1)

–$1

$–1

$1–

(1$)

–1$

1–$

1$–

–1 $

–$ 1

1 $–

$ 1–

$ –1

1– $

($ 1)

(1 $)

Dollartegnet vises i forbindelse med dette eksempel, men det skal erstattes af den rette CurrencySymbol-værdi i det faktiske program. Hvis denne linje mangler, bruges standardværdien i Windows Kontrolpanel.
CurrencyThousandSymbol | Angiver det enkelttegnsymbol, der skal bruges til at adskille valutaværdier i tusinder i tekstfilen. Hvis denne linje mangler, bruges standardværdien i Windows Kontrolpanel.
CurrencyDecimalSymbol | Kan være angivet til ethvert enkelttegn, der bruges til at adskille den hele del fra brøkdelen i et valutabeløb. Hvis denne linje mangler, bruges standardværdien i Windows Kontrolpanel.
DecimalSymbol | Kan være angivet til ethvert enkelttegn, der bruges til at adskille heltallet fra brøkdelen af et tal. Hvis denne linje mangler, bruges standardværdien i Windows Kontrolpanel.
NumberDigits | Angiver antallet af decimalcifre i brøkdelen af et tal. Hvis denne linje mangler, bruges standardværdien i Windows Kontrolpanel.
NumberLeadingZeros | Angiver, om en decimalværdi, der er mindre end 1 og større end –1, skal indeholde foranstillede nuller. Denne værdi kan være enten False (ingen foranstillede nuller) eller True.
Col1, Col2, ... Viser de kolonner i tekstfilen, der skal læses. Formatet af denne linje skal være følgende:

Coln=kolonnenavn type [Bredde #]

kolonneNavn: Kolonnenavne med integrerede mellemrum skal være omsluttet af anførselstegn.

type: Kan være Bit, Byte, Short, Long, Decimal, Currency, Single, Double, DateTime. Binary, OLE, Text eller Memo.

Derudover understøttes følgende ODBC Text-drivertyper:

Char (det samme som Text)
Float (det samme som Double)
Integer (det samme som Short)
LongChar (det samme som Memo)
Date datoformat

I tilfælde med en Memo-type kan et ekstra formatmærke bruges til at angive de kolonner, der skal være aktive URL-adresser i Microsoft Access.

I tilfælde med en Decimal-type skal det ekstra formatmærke [Scale #] Precision #] bruges.

TextDelimiter Kan være angivet til ethvert enkelttegn, der bruges til at afgrænse strenge, der indeholder et af de andre specialtegn.

F.eks. “abc”,”xyz,pqr”,”hij”

Hvis denne indstilling ikke findes, er standardafgrænseren et dobbelt anførselstegn. Hvis denne indstilling er strengen “ingen”, behandles ingen tegn som afgrænsere.

Bemærk! Når du ændrer indstillinger i Schema-ini-filen, skal du afslutte og derefter genstarte databasemotoren, for at de nye indstillinger træder i kraft.

Se også

Tilpasning af indstillinger i Windows-registreringsdatabasen til Microsoft Jet


Oprettelse af en del i træstrukturen til registreringsdatabasen i programmet for at styre indstillingerne

Oprettelse af en del i programmets træstruktur til registreringsdatabasen for at styre indstillingerne

Du kan tilpasse indstillingerne i Microsoft® Windows®-registreringsdatabasen ved at oprette en Microsoft Jet-del i programmets træstruktur til registreringsdatabasen for at styre indstillingerne til Microsoft Jet-databasemotoren. Den letteste måde at opnå dette på er ved at eksportere den eksisterende Microsoft Jet-nøgle og derefter importere den i programmets træstruktur ved hjælp af eksport- og importkommandoerne i Regedit.exe. Du kan derefter ændre værdierne i din nye træstruktur i registreringsdatabasen. Hvis du har tilføjet værdier i undermappen Engines, indlæser Microsoft Jet disse indstillinger, når programmet starter. Alle de værdier, der ikke er indsat i klientprogrammets træstruktur til registreringsdatabasen, indlæses fra skyggeindstillinger.

Hvis programmet skal indlæse den rette del af nøglen i Windows-registreringsdatabasen, skal du angive placeringen ved hjælp af DAO-egenskaben INIPath. Programmet skal angive egenskaben INIPath, før der udføres andre DAO-koder. Virkefeltet for denne indstilling er begrænset til programmet og kan ikke ændres, uden at du starter programmet igen.

Bemærk! Selvom det er lettere at oprette en Microsoft Jet-del i programmets registreringsdatabase end at overskrive Microsoft Jet-standardindtastningerne, er det nødvendigt, at du vedligeholder træstrukturen til registreringsdatabasen. Hver gang det er nødvendigt at ændre i standardindstillingerne, skal du redigere i Registreringseditor.

Se også
Brug af Regedit.exe til overskrivning af standardindstillingerne | Brug af tilslutningsegenskaberne i Microsoft OLE DB Provider til Jet
Brug af metoden SetOption fra DAO |


Tilpasning af indstillinger i Windows-registreringsdatabasen til Microsoft Jet

Hvis programmet ikke fungerer korrekt med standardfunktionaliteten i Microsoft Jet-databasemotoren, kan du ændre indstillingerne i Microsoft® Windows®-registreringsdatabasen, så de passer til dine behov. Windows-registreringsdatabasen kan også bruges til at justere funktionsmåden af den installerbare ISAM- og ODBC-driver.

Du kan tilpasse indstillingerne af Windows-registreringsdatabasen på fire forskellige måder:

Brug af Regedit.exe til overskrivning af standardindstillingerne

Oprettelse af en del i programmets træstruktur til registreringsdatabasen for at styre indstillingerne

Brug af metoden SetOption fra DAO

Brug af tilslutningsegenskaberne i Microsoft OLE DB Provider til Jet

Du kan også redigere Windows-registreringsdatabasen til at angive følgende:

  • Indstillinger, der bruges til at arbejde sammen med Microsoft Excel-, Lotus-, Paradox- og dBASE-databaser. Se under Initialisering af Paradox-databasedriveren, Initialisering af Microsoft Excel-driveren, Initialisering af Lotus-driveren og Initialisering af dBASE-databasedriveren.
  • Indstillinger, der bruges af Microsoft ODBC til at arbejde sammen med SQL-databaser. Se under Initialisering af Microsoft ODBC-databasedriveren.
  • Indstillinger, der påvirker, hvordan Microsoft Jet-databasemotoren læser og gemmer data. Se under Initialisering af Microsoft Jet 2.5-databasemotordriveren, Initialisering af Microsoft Jet 3.5-databasemotordriveren og Initialisering af Microsoft Jet 4.0-databasemotordriveren.
  • Indstillinger, der bruges til at styre, hvordan Microsoft Jet-databasemotoren arbejder sammen med Internet og Microsoft Exchange. Se under Initialisering af Text- og HTML-datakildedriveren (Internet) og Initialisering af Microsoft Exchange-datakildedriveren.
  • Indstillinger, der bruges til at styre, hvordan Microsoft Jet-databasemotoren arbejder sammen med data, der er importeret som almindelig tekst. Se under Initialisering af Text- og HTML-datakildedriveren.
Se også
Initialisering af dBase Databasedriveren | Konfigurering af Microsoft Jet-databasemotoren til ODBC-adgang
Initialisering af Lotus-driveren | Initialisering af Paradox-databasedriveren
Initialisering af Microsoft Jet 2.5-databasemotordriveren | Initialisering af Text- og HTML-datakildedriveren
Initialisering af Microsoft Jet 3.5-databasemotordriveren | Initialisering af Microsoft Exchange-datakildedriveren
Initialisering af Microsoft Jet 4.0-databasemotordriveren | Initialisering af Microsoft Excel-driver


Initialisering af Microsoft Exchange-datakildedriveren

Når du installerer Microsoft® Exchange-datakildedriveren, skriver installationsprogrammet et sæt standardværdier til Microsoft Windows®-registreringsdatabasen i undernøglerne Engines og ISAM Formats. Du skal ikke redigere disse indstillinger direkte. Brug installationsprogrammet til programmet til at tilføje, fjerne eller ændre disse indstillinger. I de følgende afsnit beskrives initialisering og ISAM Format-indstillinger til Microsoft Exchange-datakildedriveren.

Initialiseringsindstillinger til Microsoft Exchange-datakilden

I mappen Jet\4.0\Engines\Exchange findes de initialiseringsindstillinger til msexch40.dll-driveren, der bruges til at få ekstern adgang til mapperne Microsoft Outlook og Microsoft Exchange. Den eneste indtastning i denne mappe er følgende:

win32=<sti>\msexch40.dll

Microsoft Jet-databasemotoren bruger denne indstilling til at angive placeringen af msexch40.dll. Den fulde sti bestemmes på installationstidspunktet. Værdierne er af typen Streng i forbindelse med Windows 95 og Windows NT 4.0 og af typen REG_SZ i forbindelse med Windows NT 3.51.

Resultaterne ved at bruge Outlook ISAM-formatet og Exchange-klient ISAM-formatet er ens. Den eneste forskel er, at de to forskellige klienter bruger forskellige navne for de samme kolonner. De to ISAM-formater er oprettet, så Microsoft Jet kan returnere kolonnenavnene i den bestemte stil, som brugeren ønsker.

Microsoft Outlook-klient ISAM Formats

Mappen Jet\4.0\ISAM Formats\Exchange 9.0 indeholder følgende indtastninger:

Indtastningsnavn | Windows NT 3.51-type | Windows 95- og Windows NT 4.0-type | Værdi
Engine | REG_SZ | Streng | Exchange
ImportFilter | REG_SZ | Streng | Outlook()
CanLink | REG_BINARY | Binær | 01
OneTablePerFile | REG_BINARY | Binær | 00
IsamType | REG_DWORD | DWORD | 3
IndexDialog | REG_BINARY | Binær | 00
CreateDBOnExport | REG_BINARY | Binær | 00
SupportsLongNames | REG_BINARY | Binær | 01

Bemærk! Når du ændrer indstillinger i Windows-registreringsdatabasen, skal du afslutte og derefter genstarte databasemotoren, for at de nye indstillinger træder i kraft.

Microsoft Exchange-klient ISAM Formats

Mappen Jet\4.0\ISAM Formats\Exchange 4.0 indeholder følgende indtastninger:

Indtastningsnavn | Windows NT 3.51-type | Windows 95- og Windows NT 4.0-type | Værdi
Engine | REG_SZ | Streng | Exchange
ImportFilter | REG_SZ | Streng | Exchange()
CanLink | REG_BINARY | Binær | 01
OneTablePerFile | REG_BINARY | Binær | 00
IsamType | REG_DWORD | DWORD | 3
IndexDialog | REG_BINARY | Binær | 00
CreateDBOnExport | REG_BINARY | Binær | 00
SupportsLongNames | REG_BINARY | Binær | 01

Bemærk! Når du ændrer indstillinger i Windows-registreringsdatabasen, skal du afslutte og derefter genstarte databasemotoren, for at de nye indstillinger træder i kraft.

Tilpasning af Schema.ini-filen til Outlook- og Exchange-data

Schema.ini-filen bruges af Outlook og Exchange ISAM på omtrent samme måde, som den bruges af Text ISAM. Schema.ini indeholder detaljerede oplysninger om en datakilde: Hvordan data formateres, og hvordan kolonnenavnene skal åbnes.

Det er ikke nødvendigt at redigere Schema.ini-filen, før data kan læses, importeres eller eksporteres til Outlook og Exchange. Mange af indstillingerne i Schema.ini-filen til Outlook og Exchange er særegne for de interne koder, som MAPI kræver. Du skal ikke forsøge at redigere disse kodeværdier.

Se også

Tilpasning af indstillinger i Windows-registreringsdatabasen til Microsoft Jet


Brug af tilslutningsegenskaberne i Microsoft OLE DB Provider til Jet

Du kan tilpasse indstillingerne til Microsoft® Windows®-registreringsdatabasen ved at bruge tilslutningsegenskaberne i Microsoft OLE DB Provider til Jet. Dette er muligt ved at referere til en egenskab i tilslutningsobjektet og ændre værdien. Hvis du f.eks. antager, at tilslutningsobjektet har navnet ADOConnection, vil følgende give samme resultat som ved at gå via ADO:

ADOConnection.Properties("Jet OLEDB:Max Locks Per File") = 20000

Egenskabernes navne er forskellige fra DAO-konstanterne og indstillingerne i registreringsdatabasen. Egenskabernes navne er følgende:

Jet OLEDB:Max Locks Per File

Jet OLEDB:Implicit Commit Sync

Jet OLEDB:Flush Transaction Timeout

Jet OLEDB:Lock Delay

Jet OLEDB:Max Buffer Size

Jet OLEDB:User Commit Sync

Jet OLEDB:Lock Retry

Jet OLEDB:Exclusive Async Delay

Jet OLEDB:Shared Async Delay

Jet OLEDB:Page Timeout

Jet OLEDB:Recycle Long-Valued Pages

Se også
Brug af Regedit.exe til overskrivning af standardindstillingerne | Brug af metoden SetOption fra DAO
Oprettelse af en del i programmets træstruktur til registreringsdatabasen for at styre indstillingerne |


Brug af Regedit.exe til overskrivning af standardindstillingerne

Du kan tilpasse indstillingerne til Microsoft® Windows®-registreringsdatabasen ved at bruge Regedit.exe til at overskrive de standardindstillinger, der etableres, når Microsoft Jet-databasemotoren registreres. Denne redigeringsmetode er den mindst fleksible, fordi alle programmer, der ikke angiver en anden placering af registreringsdatabasen, indeholder disse nye standardindstillinger.

Se også
Oprettelse af en del i programmets træstruktur til registreringsdatabasen for at styre indstillingerne | Brug af tilslutningsegenskaberne i Microsoft OLE DB Provider til Jet
Brug af metoden SetOption fra DAO |


Brug af metoden SetOption fra DAO

I DAO version 3.6 findes en ny måde at redigere standardindstillinger på. Indstillinger til Microsoft® Windows®-registreringsdatabasen kan nu ændres under kørslen med metoden SetOption. Du kan tilpasse indstillingerne til Windows-registreringsdatabasen ved at bruge metoden SetOption fra DAO. Med denne metode kan programmet opnå den maksimale fleksibilitet og styring. Metoden gør det muligt at oprette programmer, der er lettere at vedligeholde og justeret til maksimal ydeevne.

Syntaksen for at gøre dette er dbEngine.SetOption, konstanten er NewValueSetting. F.eks. vil følgende syntaks, dbEngine.SetOption dbMaxLocksPerfFile, 20000, gøre det muligt for Microsoft Jet at spore 20.000 låse på én gang. Navnene på definerede konstanter svarer til registreringsdatabasens navn, med db tilføjet som præfiks.

Dette er den anbefalede metode at finjustere registreringsdatabaseindstillinger til programmet på. Denne metode er den mest fleksible fremgangsmåde, og den giver den bedste mulighed for at styre, hvordan registreringsdatabasen ændres. Med metoden SetOption kan du angive nye indstillinger for følgende standardindstillinger:

  • PageTimeout-nøgle
  • SharedAsyncDelay-nøgle
  • ExclusiveAsyncDelay-nøgle
  • LockRetry-nøgle
  • UserCommitSync-nøgle
  • ImplicitCommitSync-nøgle
  • MaxBufferSize-nøgle
  • MaxLocksPerFile-nøgle
  • LockDelay-nøgle
  • RecycleLV'er
  • FlushTransactionTimeout-nøgle
Se også
Brug af Regedit.exe til overskrivning af standardindstillingerne | Brug af tilslutningsegenskaberne i Microsoft OLE DB Provider til Jet
Oprettelse af en del i programmets træstruktur til registreringsdatabasen for at styre indstillingerne |


SQL-aggregatfunktioner (SQL)

SQL-aggregatfunktioner

Med SQL- aggregatfunktioner kan du bestemme forskellige statistikker på sæt af værdier. Du kan anvende i en forespørgsel eller i aggregatfunktioner i egenskaben SQL i et QueryDef-objekt, eller når du opretter et Recordset-objekt, der er baseret på en SQL-forespørgsel.

Funktionen Avg

Funktionen Count

Funktionerne First og Last

Funktionerne Min og Max

Funktionerne StDev og StDevP

Funktionen Sum

Funktionerne Var og VarP


ALL <Microsoft Jet SQL-reserveret ord>

ALL

Det reserverede ord ALL anvendes i følgende kontekster:

Prædikaterne ALL, DISTINCT, DISTINCTROW, TOP

SQL-underforespørgsler

Handlingen UNION


ALTER <Microsoft Jet SQL-reserveret ord>

ALTER

Det reserverede ord ALTER anvendes i følgende kontekster:

Sætningen ALTER TABLE

Sætningen ALTER USER eller DATABASE


ASC/DESC <Microsoft Jet SQL-reserveret ord>

ASC/DESC

De reserverede ord ASC og DESC anvendes i følgende kontekster:

Sætningen CREATE INDEX

Delsætningen ORDER BY


AS <Microsoft Jet SQL-reserveret ord>

AS

Det reserverede ord AS anvendes i følgende kontekster:

Sætningen SELECT

Sætningen CREATE VIEW

Sætningen CREATE PROCEDURE


BY <Microsoft Jet SQL-reserveret ord>

BY

Det reserverede ord BY anvendes i følgende kontekster:

Delsætningen GROUP BY

Delsætningen ORDER BY


CONTAINER <Microsoft Jet SQL-reserveret ord>

CONTAINER

Det reserverede ord CONTAINER anvendes i følgende kontekster:

Sætningen GRANT

Sætningen REVOKE


CREATE <Microsoft Jet SQL-reserveret ord>

CREATE

Det reserverede ord CREATE anvendes i følgende kontekster:

Sætningen CREATE INDEX

Sætningen CREATE TABLE

Sætningen CREATE VIEW

Sætningen CREATE PROCEDURE

Sætningen CREATE USER eller GROUP

Sætningen GRANT

Sætningen REVOKE


DELETE <Microsoft Jet SQL-reserveret ord>

DELETE

Det reserverede ord DELETE anvendes i følgende kontekster:

Sætningen DELETE

Sætningen CREATE PROCEDURE

Sætningen GRANT

Sætningen REVOKE


DROP <Microsoft Jet SQL-reserveret ord>

DROP

Det reserverede ord DROP anvendes i følgende kontekster:

Sætningen ALTER TABLE

Sætningen DROP

Sætningen DROP USER eller GROUP

Sætningen GRANT

Sætningen REVOKE


FIRST <Microsoft Jet SQL-reserveret ord>

FIRST

Det reserverede ord FIRST anvendes i følgende kontekster:

Funktionerne First og Last

Eksempel på funktionerne First og Last


FROM <Microsoft Jet SQL-reserveret ord>

FROM

Det reserverede ord FROM anvendes i følgende kontekster:

Sætningen SELECT

Sætningen DROP USER eller GROUP

Sætningen REVOKE


INDEX <Microsoft Jet SQL-reserveret ord>

INDEX

Det reserverede ord INDEX anvendes i følgende kontekster:

Sætningen CREATE INDEX

Sætningen DROP

Sætningen GRANT

Sætningen REVOKE


IN <Microsoft Jet SQL-reserveret ord>

IN

Det reserverede ord IN anvendes i følgende kontekster:

Operatoren In

Delsætningen IN

SQL-underforespørgsler

Sætningen TRANSFORM


INSERT <Microsoft Jet SQL-reserveret ord>

INSERT

Det reserverede ord INSERT anvendes i følgende kontekster:

Sætningen INSERT INTO

Sætningen CREATE PROCEDURE

Sætningen GRANT

Sætningen REVOKE


INTO <Microsoft Jet SQL-reserveret ord>

INTO

Det reserverede ord INTO anvendes i følgende kontekster:

Sætningen INSERT INTO

Sætningen SELECT ... INTO


JOIN <Microsoft Jet SQL-reserveret ord>

JOIN

Det reserverede ord JOIN anvendes i følgende kontekster:

Handlingen INNER JOIN

Handlingen LEFT JOIN og RIGHT JOIN


LAST <Microsoft Jet SQL-reserveret ord>

LAST

Det reserverede ord LAST anvendes i følgende kontekster:

Funktionerne First og Last

Eksempel på funktionerne First og Last


ON <Microsoft Jet SQL-reserveret ord>

ON

Det reserverede ord ON anvendes i følgende kontekster:

Handlingen INNER JOIN

Handlingen LEFT JOIN og RIGHT JOIN

Delsætningen CONSTRAINT

Sætningen GRANT

Sætningen REVOKE


SCHEMA <Microsoft Jet SQL-reserveret ord>

SCHEMA

Det reserverede ord SCHEMA anvendes i følgende kontekster:

Sætningen GRANT

Sætningen REVOKE


SELECT <Microsoft Jet SQL-reserveret ord>

SELECT

Det reserverede ord SELECT anvendes i følgende kontekster:

Sætningen SELECT

Sætningen SELECT ... INTO

Sætningen CREATE VIEW

Sætningen CREATE PROCEDURE

Sætningen GRANT

Sætningen REVOKE


SELECTSCHEMA <Microsoft Jet SQL-reserveret ord>

SELECTSCHEMA

Det reserverede ord SELECTSCHEMA anvendes i følgende kontekster:

Sætningen GRANT

Sætningen REVOKE


SELECTSECURITY <Microsoft Jet SQL-reserveret ord>

SELECTSECURITY

Det reserverede ord SELECTSECURITY anvendes i følgende kontekster:

Sætningen GRANT

Sætningen REVOKE


TABLE <Microsoft Jet SQL-reserveret ord>

TABLE

Det reserverede ord TABLE anvendes i følgende kontekster:

Sætningen ALTER TABLE

Sætningen CREATE INDEX

Sætningen CREATE TABLE

Sætningen DROP

Handlingen UNION

Sætningen GRANT

Sætningen REVOKE


TO <Microsoft Jet SQL-reserveret ord>

TO

Det reserverede ord TO anvendes i følgende kontekster:

Sætningen ADD USER

Sætningen GRANT


UPDATE <Microsoft Jet SQL-reserveret ord>

UPDATE

Det reserverede ord UPDATE anvendes i følgende kontekster:

Sætningen UPDATE

Sætningen CREATE PROCEDURE

Sætningen GRANT

Sætningen REVOKE


UPDATEIDENTITY <Microsoft Jet SQL-reserveret ord>

UPDATEIDENTITY

Det reserverede ord UPDATEIDENTITY anvendes i følgende kontekster:

Sætningen GRANT

Sætningen REVOKE


UPDATEOWNER <Microsoft Jet SQL-reserveret ord>

UPDATEOWNER

Det reserverede ord UPDATEOWNER anvendes i følgende kontekster:

Sætningen GRANT

Sætningen REVOKE


UPDATEIDENTITY <Microsoft Jet SQL-reserveret ord>

UPDATESECURITY

Det reserverede ord UPDATESECURITY anvendes i følgende kontekster:

Sætningen GRANT

Sætningen REVOKE


USER <Microsoft Jet SQL-reserveret ord>

USER

Det reserverede ord USER anvendes i følgende kontekster:

Sætningen CREATE USER eller GROUP

Sætningen ADD USER

Sætningen DROP USER eller GROUP

Sætningen ALTER USER eller DATABASE


VIEW <Microsoft Jet SQL-reserveret ord>

VIEW

Det reserverede ord VIEW anvendes i følgende kontekster:

Sætningen CREATE VIEW

Sætningen DROP


WITH <Microsoft Jet SQL-reserveret ord>

WITH

Det reserverede ord WITH anvendes i følgende kontekster:

Sætningen CREATE INDEX

Erklæringen WITH OWNERACCESS OPTION


Udtrykket er for komplekst. (Fejl 2445)

Dette udtryk er for komplekst for Microsoft Jet-databasemotoren. Prøv at forenkle udtrykket.


Denne Paradox 4.x- eller 5.x-tabel kan ikke åbnes, fordi ParadoxNetStyle er angivet til 3.x i Windows-registreringsdatabasen. (Fejl 3419)

Microsoft Jet-databasemotoren kan ikke åbne en ekstern Paradox-tabel på grund af uoverensstemmelse mellem tabelversionen og initialiseringsindstillingen i ParadoxNetStyle i Microsoft® Windows®-registreringsdatabasen.

Sådan løses problemet:

  1. Afslut programmet.
  2. Start Registreringseditor, flyt til nøglen \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox, og marker værdien ParadoxNetStyle.
  3. Vælg Rediger i menuen Rediger.
  4. Angiv værdien 4.x i feltet "Værdidata".
  5. Indstillingen ParadoxNetStyle skal være den samme for alle brugere, der deler en database.
  6. Genstart programmet.
  7. Forsøg at åbne tabellen igen.


Denne database kunne ikke repareres. (Fejl 3056)

Den angivne database er beskadiget, eller det er en Microsoft Jet database. Genopret den beskadigede Microsoft® Jet-database fra en sikkerhedskopi, eller opret en ny database.


Der er udført en annullering i handlingen. (Fejl 3642)

En forespørgsel er blevet afbrudt af datakilden. Nogle af de tilsvarende rækker er ikke returneret. Forsøg at sende forespørgslen igen.


Du har ikke de nødvendige tilladelser til at bruge objektet <navn>. Få systemadministratoren eller den person, der oprettede dette objekt, til at give dig de nødvendige tilladelser. (Fejl 3033)

Du har ikke de nødvendige tilladelser til det angivne objekt. Hvis du vil ændre tildelingerne af tilladelserne, skal du henvende dig til systemadministratoren eller den, der har oprettet objektet.


Det angivne kontonavn findes allerede. (Fejl 3390)

Kontonavnet findes allerede. (Fejl 3390)

Dette er et sikkerhedsproblem. Du har forsøgt at etablere en brugerkonto med et navn, der allerede findes. Undersøg samlingen Users for at se, om brugernavnet allerede findes, eller prøv igen med et andet brugernavn.


Den ønskede kolonne returneres ikke til postsættet. (Fejl 3647)

En af de ønskede kolonner er ikke tilgængelig.


De rækker, der er nødvendige for at gøre databasen replikerbar, kunne ikke tilføjes. (Fejl 3580)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


En aggregatfunktion kan ikke bruges i udtrykket <udtryk>. (Fejl 3095)

Du kan ikke bruge en aggregatfunktion i dette udtryk.


En aggregatfunktion kan ikke bruges i GROUP BY-delsætningen <delsætning>. (Fejl 3098)

Du kan ikke bruge en aggregatfunktion i delsætningen GROUP BY i en SQL-sætning.


En aggregatfunktion kan ikke bruges i JOIN-handlingen <handling>. (Fejl 3099)

Du kan ikke bruge en aggregatfunktion i JOIN-handlingen i en SQL-sætning.


En aggregatfunktion kan ikke bruges i ORDER BY-delsætningen <delsætning>. (Fejl 3097)

Du kan ikke bruge en aggregatfunktion i delsætningen ORDER BY i en SQL-sætning.


En aggregatfunktion kan ikke bruges i WHERE-delsætningen <delsætning>. (Fejl 3096)

Du kan ikke bruge en aggregatfunktion i delsætningen WHERE i en SQL-sætning.


Underforespørgsler kan ikke bruges i udtrykket <udtryk>. (Fejl 3203)

Det angivne udtryk indeholder en underforespørgsel eller et andet udtryk, der fungerer som en underforespørgsel.

Mulig årsag:

  • Du har benyttet en SELECT-sætning, der medtager en aggregatfunktion, som elvaluerer en anden aggregatfunktion. Denne fejl opstår, hvis du f.eks. udfører følgende sætning:

    TRANSFORM Sum([Ordrebeløb]) AS Sum1

    SELECT Sum([Sum1]) AS Sum2, Ordreid, Sum([Sum2]) AS Expr1

    FROM Ordrer

    GROUP BY Ordreid

    PIVOT Modtagernavn;

    Parameteren <udtryk> i advarslen vil indeholde udtrykket Sum([Sum2]) fra delsætningen SELECT, fordi dette udtryk refererer til et alias, der er benyttet i samme SELECT-sætning og fungerer som en underforespørgsel forhold til Sum([Sum1]).


Aggregeringsudtryk kan ikke anvende GUID'er. (Fejl 3600)

SQL-sætningen kan ikke indeholde en kolonne, der har en GUID-datatype i en aggregatfunktion, såsom MAX, MIN, SUM osv.


Alle gyldige kælenavne for replikaer er allerede i brug. (Fejl 3555)

Du har nået det maksimale antal replikaer (32.768), der er tilladt i et replikasæt. Start et nyt replikasæt.


Microsoft Jet-databasemotoren er allerede blevet initialiseret. (Fejl 3279)

Du har forsøgt at initialisere Microsoft Jet-databasemotoren, men den er allerede blevet initialiseret.


Metoden AddNew eller Edit er allerede brugt. (Fejl 3023)

Du har ikke gemt eller annulleret de aktuelle ændringer og forsøger at tilføje eller ændre en anden post. Benyt metoden Rollback eller Update, og brug derefter metoden AddNew eller Edit.


Tekstfilspecifikationens feltseparator er magen til decimalseparatoren eller tekstafgrænseren. (Fejl 3441)

To eller flere af følgende afgrænsningsindstillinger, der anvendes af Text ISAM, er de samme:

  • TxtDelimiter
  • NumberDecimalSymbol
  • CurrencyDecimalSymbol
  • Format


Der er syntaksfejl. (Fejl 2438)

Du har indtastet et udtryk, der indeholder en ugyldig syntaks. Der mangler f.eks. en operand eller operator, du kan have skrevet et ugyldigt tegn eller komma, eller du kan have skrevet tekst uden at sætte den i anførselstegn ("). Kontroller udtrykket for at sikre, at du har indtastet det korrekt.


Der er en syntaksfejl i datoen. (Fejl 2421)

Der er syntaksfejl i datoen. (Fejl 2421)

Syntaksen til Date er ikke korrekt. Denne fejl opstår, hvis du angiver en ugyldig dato. 9/31/94 er f.eks. ugyldig, fordi september kun har 30 dage.


Der er gjort ugyldig brug af '.', '!' eller '()'. (Fejl 2423)

Udtrykket bruger ikke afgrænsere korrekt. Hvis du skal referere til egenskaber i et DAO-objekt, anbefales det, at du benytter syntaksen .egenskabsnavn.


Funktionen IIF er brugt uden (). (Fejl 2440)

Funktionen IIf kræver, at argumenterne omsluttes af parenteser som vist i følgende eksempel:

IIf(udtryk, sanddel, falskdel )


Operatoren In er brugt uden (). (Fejl 2429)

Når du skriver programkode til en SQL-sætning, der medtager operatoren In, skal du sætte parenteser omkring den liste elementer, der skal undersøges. Hvis du f.eks. vil se, om en værdi findes i et sæt af værdier, kan du benytte følgende programkode i WHERE-delsætningen i en SQL-forespørgsel:

WHERE Område In ('TX', 'CA', 'WA')

I denne kode undersøges det, om feltet Område indeholder en af ovenstående forkortelser, som repræsenterer Texas, Californien og Washington.


Is-operatoren er ugyldig. (Fejl 2443)

Operatoren Is anvendes til at afgøre, om et udtryk er Null. Du kan kun benytte operatoren Is i et udtryk med NULL eller NOT NULL.


Serverens tabel MSysConf findes, men er ikke i det korrekt format. Kontakt systemadministratoren. (Fejl 3407)

Serverens MSysConf-tabel findes, men den har et forkert format. Kontakt systemadministratoren. (Fejl 3407)

MSysConf-tabellen, der er oprettet på serveren for at hjælpe med at styre kommunikationen mellem Microsoft Jet-databasemotoren og den sammenkædede ODBC-datakilde, kræver et helt specielt format.


Der er syntaksfejl i tallet. (Fejl 2420)

Du har skrevet en ugyldig værdi. Denne fejl opstår, hvis en ikke-numerisk værdi er angivet som del af udtrykket.


Området er ugyldigt. (Fejl 3181)

Du har forsøgt at importere et ugyldigt område af regnearksceller.


Der er en syntaksfejl i strengen. (Fejl 2422)

Der er syntaksfejl i strengen. (Fejl 2422)

Du har indtastet et udtryk, der indeholder en ugyldig streng. Kontroller udtrykket for at sikre, at du har indtastet det korrekt.


Der er gjort ugyldig brug af lodrette streger. (Fejl 2437)

Du har indtastet et udtryk, der indeholder ugyldige lodrette streger (|). Kontroller udtrykket for at sikre, at du har indtastet det korrekt.


Det er ikke et gyldigt tabelnavn. (Fejl 3177)

Det navn, du har skrevet, følger ikke standardnavngivningskonventionerne. Skriv et nyt navn, og forsøg derefter at udføre handlingen igen.


Den binære kolonne <navn> kan ikke bruges i et boolesk filter. (Fejl 3658)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Filformatet er ugyldigt. (Fejl 3182)

Mulige årsager:

  • Den fil, du har forsøgt at læse eller sammenkæde, er beskadiget. Gendan en sikkerhedskopi af filen på disken, og forsøg derefter at udføre handlingen igen.
  • Filformatet genkendes ikke. Hvis det er en Btrieve-, dBASE- eller Paradox-fil, skal du køre installationsprogrammet for at geninstallere den installerbare ISAM og derefter sammenkæde filen.


Der opstod en fejl under evaluering af det booleske filterudtryk i tabellen <navn>. (Fejl 3657)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


En delvis replika kan ikke synkroniseres med en anden delvis replika. (Fejl 3648)

Den database, du forsøger at synkronisere med, er en delvis replika. Du kan ikke synkronisere en delvis replika med en anden delvis replika, da den anden delvise replika måske ikke indeholder alle de poster, der opfylder filteret til den delvise replika.


Between-operatoren er brugt uden And. (Fejl 2430)

Når du benytter operatoren Between for at undersøge, om en værdi i et udtryk ligger inden for et bestemt værdiinterval, skal du angive øverste og nederste grænse i intervallet adskilt af det reserverede ord And. Hvis du f.eks. vil undersøge et interval fra A til C, kan du benytte følgende programkode:

WHERE fldName Between "A" And "C"


Synchronizer kunne ikke åbne meddelsesdatabasen. (Fejl 3525)

Synchronizer kunne ikke åbne meddelelsesdatabasen. (Fejl 3525)

Meddelelsesdatabasen er ikke tilgængelig til brug for Synchronizer. Databasefilen kan være i brug af et andet program eller en anden bruger (brugerne bør ikke åbne meddelelsesdatabaser til Synchronizer). Luk alle programmer, der kan bruge databasen.


Denne type replika kan ikke oprettes fra den givne kildereplika. (Fejl 3737)

Du kan ikke oprette en replika med en anden synlighed, undtagen fra en global replika. En lokal replika kan f.eks. kun oprette en lokal replika, og en anonym replika kan kun oprette en anonym replika. Globale replikaer kan oprette globale, lokale og anonyme replikaer.


En delvis replika af en systemdatabase kan ikke oprettes. (Fejl 3635)

Du forsøger at oprette en delvis replika med en arbejdsgruppeoplysningsfil som kilde. Arbejdsgruppeoplysningsfiler kan ikke replikeres.


Replikaen kan ikke oprettes ved brug af en delvis replika. (Fejl 3634)

Du forsøger at oprette en replika ved hjælp af en delvis replika som kilden. Delvise replikaer kan ikke replikeres.


DLL-biblioteket <navn> kunne ikke findes. (Fejl 3463)

Sørg for, at det angivne DLL-bibliotek findes i stien, eller geninstaller Replikastyring eller programmet.


Synchronizer kan ikke finde posten til en bestemt synkronisering i tabellen MSysExchangeLog. (Fejl 3522)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Synchronizers eksekverbare fil kan ikke findes (Mstran40.exe). (Fejl 3627)

Du forsøger at starte Synchronizer, men filen Mstran40.exe kan ikke findes i den angivne sti.


Synchronizer eller Replikastyring kunne ikke finde systemobjektet. (Fejl 3527)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Synchronizer kan ikke finde et bestemt versionsnummer i tabellen MSysSchChange. (Fejl 3523)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


<Navn>-objektet i <navn>-objektbeholderen kan ikke gøres replikerbart. (Fejl 3583)

Et objekt (tabel, formular, rapport, modul eller makro) i den angivne objektbeholder kan ikke gøres replikerbart.

Et eksempel på et objekt, der ikke kan gøres replikerbart, er en tabel med 253 eller flere felter. Da replikering skal tilføje mindst 3 ekstra felter, vil det overskride feltbegrænsningen på 255.


Du kan ikke ændre systemobjektet til replikeringen <navn>. (Fejl 3665)

Du forsøger at udføre en ugyldig handling, såsom at slette en systemtabel, omdøbe en systemtabel eller slette en systemkolonne til replikering, i et internt replikeringssystemobjekt.


Du kan ikke ændre systemobjektet til replikering <navn>. (Fejl 3666)

Du kan ikke ændre systemobjektet til replikeringen <navn>. (Fejl 3666)

Du forsøger at udføre en ugyldig handling, såsom at slette en systemtabel, omdøbe en tabel eller slette en replikeringskolonne, i et internt replikeringssystemobjekt.


Programmet kan ikke startes. Arbejdsgruppeoplysningsfilen mangler eller er åbnet med udelt adgang af en anden bruger. (Fejl 3028)

Programmet skal læse filen System.mdw i Microsoft® Jet-databasen for at sikre referentiel integritet af databaser, der er oprettet af Microsoft Jet-databasemotoren. Kontroller, at filen har den placering, der er angivet i SystemDB-værdien til nøglen \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Access\Jet\4.0\Engines\Jet i Windows-registreringsdatabase.


Den installerbare ISAM-fil kunne ikke omdøbes. (Fejl 3013)

Du har forsøgt at omdøbe en Btrieve-, dBASE- eller Paradox-tabel, men den fil, der indeholder tabellen, kunne ikke omdøbes.

Mulige årsager:

  • Filen er defineret som skrivebeskyttet i operativsystemet eller i netværket.
  • Du har ikke skriveadgang til filen i et netværksmiljø.


Paradox.net kunne ikke åbnes. (Fejl 3172)

Paradox.net kunne ikke åbnes.

Mulige årsager:

  • ParadoxNetPath-værdien i registreringsnøglen \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox er ikke gyldig. Denne fejl opstår, hvis du benytter den eksterne Paradox-database, og værdien ParadoxNetPath peger på et bibliotek, der ikke findes. Afslut programmet, ret den ugyldige angivelse, og prøv at udføre handlingen igen.
  • ParadoxNetPath-værdien i registreringsdatabasen peger på et netværksdrev, som du ikke er tilsluttet. Kontroller, at netværksdrevet er tilgængeligt, og forsøg derefter at udføre handlingen igen.


Du kan ikke føje et andet ReplicationID-felt af typen Autonumber til en tabel. (Fejl 3486)

Den tabel, du forsøger at ændre, indeholder allerede et felt, der benytter ReplicationID af datatypen AutoNumber (eller GUID). Hvis du forsøger at oprette endnu et ReplicationID-felt, der skal fungere som fremmed nøgle, skal du benytte datatypen Number i stedet for datatypen Autonumber.


Databasen har nået den maksimale størrelse. (Fejl 3036)

Hvis du vil føje data til denne database, skal du først reducere databasens størrelse ved at slette data. Den maksimale størrelse for en Microsoft® Jet-database version 3.X og lavere er 1,07 GB. Den maksimale størrelse for en Microsoft® Jet-database version 4.0 og lavere er 2,14 GB.


Synkroniseringen lykkedes ikke, fordi en designændring ikke kan anvendes på en af replikaerne. (Fejl 3492)

Microsoft Jet-databasemotoren har forsøgt at opdatere databasedesignet til en af replikaerne. Der er flere mulige årsager til, at designet ikke kunne opdateres, bl.a.:

  • Det objekt, der skal opdateres, er allerede åbent ved replikaen.
  • Du har føjet en gennemtvunget relation til en replika, der indeholder en fremmed nøgle, som refererer til en ikke-eksisterende primær nøgle.

Yderligere oplysninger om synkroniseringsfejl finder du i tabellen MSysSchemaPro, enten i masterdesignet eller den replika, der skulle synkroniseres.


Sessionen kunne ikke startes. (Fejl 3002)

Du har forsøgt at indlede en handling, der kræver en ny session, men du har nået grænsen for, hvor mange sessioner der kan være aktive samtidigt. Vent, til andre handlinger er afsluttet, eller afbryd andre handlinger, og forsøg derefter at udføre handlingen igen.


Der kunne ikke genereres en nøgle. (Fejl 3250)

Microsoft Jet-databasemotoren kunne ikke generere en primær nøgle, da den genererede et primært indeks. Kontroller, at nøglefelterne er navngivet korrekt, og at ingen dublerede poster baseres på denne nøgle.

Denne fejl kan opstå, når du benytter metoden Seek og giver den en værdi til et felt, der ikke er en del af indekset. Antag, at du f.eks. vil benytte metoden Seek til et Recordset-objekt, hvis aktuelle indeks bruger feltet Efternavn i den underliggende tabel, og skriver det på følgende måde:

rstEmployees.Seek "=", "Hansen", "Jens"

Microsoft® Jet vil forsøge at generere en primær nøgle fra to felter, men da det ene felt er indekseret, mislykkes forsøget, og denne fejl opstår.


Adgangskoden kan ikke ændres for en delt, åben database. (Fejl 3621)

Hvis du vil ændre adgangskoden, skal databasen åbnes med udelt adgang.


Du kan ikke foretage ændringer til databasedesignet i denne replika. (Fejl 3452)

Ændringer i designet til en replikeret database kan kun foretages i masterdesign. Den replika, du forsøger at ændre, er ikke masterdesign til replikasættet. Find masterdesignet, og foretag ændringerne der.


Den database, du prøver at replikere, kan ikke konverteres. (Fejl 3487)

Kun databaser, der er oprettet med version 3.0 eller senere versioner af Microsoft Jet-databasemotoren kan replikeres. Selvom du kan åbne databasen ved hjælp af en installerbar ISAM, kan du ikke konvertere den til en replikerbar tilstand. Hvis databasen er oprettet ved hjælp af en tidligere version af Microsoft® Jet, skal du konvertere formatet til den nye version ved vælge menuen Funktioner i Microsoft Access, pege på Databasefunktioner og derefter vælge Konverter database. Hvis databasen er i et andet format, skal du eksportere dataene til en ny Microsoft Jet-database og forsøge igen.


GUID'en kan ikke oprettes. (Fejl 3553)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


En replika af en systemdatabase kan ikke oprettes. (Fejl 3639)

Du forsøger at replikere en arbejdsgruppeoplysningsfil. Dette er ikke muligt.


Den angivne registreringsdatabaseparameter for Synchronizer kan ikke slettes. (Fejl 3551)

Du skal konfigurere Synchronizer på computeren.

Sådan konfigureres Synchronizer

  1. Start Replikastyring.
  2. Vælg Konfigurer Microsoft Replikastyring i menuen Funktioner.
  3. Følg instruktionerne i guiden.


Det lykkedes ikke at replikere databasen. Det kan ikke afgøres, om databasen er åben med udelt adgang. (Fejl 3578)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Du kan ikke etablere eller vedligeholde en gennemtvunget relation mellem en replikeret tabel og en lokal tabel. (Fejl 3453)

Du forsøger at etablere eller vedligeholde en gennemtvunget relation mellem en replikeret tabel og en ikke-replikeret tabel. Replikering tillader ikke en gennemtvunget relation mellem:

  • En replikeret tabel og en lokal tabel.
  • To lokale tabeller, som du gør replikerbare.
  • To tabeller med forskellige indstillinger af egenskaben KeepLocal.

Slet relationen mellem de to tabeller, før du fortsætter.


Der opstod en fejl under bedømmelse af CHECK-begrænsningen <navn>. <Yderligere oplysninger>. (Fejl 3802)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Replikastyring kan ikke finde ExchangeID i tabellen MSysExchangeLog. (Fejl 3496)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Synchronizer kan ikke finde kildefilen til meddelelserne. (Fejl 3564)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Destinationssynchronizer er ikke konfigureret. (Fejl 3516)

Destinationssynchronizer er ikke konfigureret til at understøtte indirekte synkronisering, og destinationsreplikaen er ikke tilgængelig for direkte synkronisering. (Fejl 3516)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Synchronizer i tabellen MSysTranspAddress kunne ikke findes. (Fejl 3518)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


En gyldig transport til Synchronizer kunne ikke findes. (Fejl 3509)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


DLL-biblioteket <navn> kan ikke indlæses. (Fejl 3633)

Den angivne DLL er enten ikke registreret eller er ikke i stien.


Du har forsøgt at låse tabellen <tabel> under åbning, men tabellen kan ikke låses, fordi den i øjeblikket er i brug. Vent et øjeblik, og forsøg derefter at udføre handlingen igen. (Fejl 3009)

Du har forsøgt at låse tabellen <navn> under åbning, men tabellen kan ikke låses, fordi den i øjeblikket er i brug. Vent et øjeblik, og forsøg derefter at udføre handlingen igen. (Fejl 3009)

Enten har en anden bruger en udelt lås på den tabel, som du forsøger at åbne i delt tilstand, eller en anden bruger har en delt lås på den tabel, som du forsøger at åbne med udelt adgang. Det returnerede brugernavn viser, hvem der i øjeblikket har låsen.


.inf-filen kunne ikke åbnes. (Fejl 3165)

Du har forsøgt at sammenkæde en dBASE-tabel, men den tilknyttede .inf-fil, der indeholder indeksoplysninger om den pågældende tabel, kunne ikke åbnes eller oprettes.

Mulige årsager:

  • Der er ikke nok diskplads til at oprette .inf-filen.
  • Du har ikke skriveadgang til netværksdrevet i et netværksmiljø.


Databasen kan ikke gøre replikerbar. (Fejl 3455)

Databasen kan ikke gøres replikerbar. (Fejl 3455)

Microsoft Jet-databasemotoren var i gang med at gøre objektet replikerbart. Handlingen mislykkedes, fordi der ikke var ressourcer nok. Hvis objektet er en tabel, skal du sørge for, at det totale antal felter efter replikering ikke overstiger 255, og at det totale antal byte i en post ikke overstiger 2.048.


En delvis replika kan ikke gøres til masterdesign for et replikasæt. (Fejl 3479)

Vælg en anden replika, der skal være masterdesign.


Når en database er replikeret, kan du ikke fjerne replikeringsfunktionerne fra databasen. (Fejl 3459)

Du kan ikke fjerne replikeringsfaciliteterne fra en database, der er replikeret, enten ved at angive egenskaben Replicable til "T" eller ved at konvertere den med Microsoft® Windows® Rejsetaske, Microsoft Access eller Replikastyring. Hvis du bruger DAO til at angive databasens egenskab Replicable til "F" eller en anden værdi, påvirkes den replikerede database ikke. Hvis du har brug for en kopi af databasen, der ikke har de egenskaber, felter, tabeller og andre karakteristika, der er forbundet med replikering, skal du åbne den sikkerhedskopi af databasen, der blev lavet, før databasen blev konverteret første gang.


Filen <navn> kunne ikke åbnes. (Fejl 3176)

Den angivne tekst eller regnearksfil kunne ikke åbnes. Det kan skyldes, at den angivne filspecifikation er ugyldig, at en anden bruger er ved at åbne filen, eller at du ikke har læseadgang til filen. Vent, til den anden bruger er færdig med at arbejde med filen, og forsøg derefter at udføre handlingen igen, eller kontakt system- eller netværksadministratoren.


Logfilen <navn> kan ikke åbnes med skriveadgang. (Fejl 3474)

Kontroller, at du har tilladelse til at skrive i logfilen.


Du har forsøgt at sammenkæde eller importere en Microsoft Word-brevfletningsfil. Selvom du kan eksportere sådanne filer, kan du ikke sammenkæde eller importere dem. (Fejl 3439)

Du har forsøgt at sammenkæde eller importere en Microsoft® Word-brevfletningsfil. Selvom du kan eksportere sådanne filer, kan du ikke sammenkæde eller importere dem.


Du kan ikke replikere en database, der er beskyttet med adgangskode, eller angive en adgangskodebeskyttelse i en replikeret database. (Fejl 3592)

Hvis der er angivet en databaseadgangskode til databasen, skal du fjerne adgangskoden.


Replikaen kan ikke udfyldes, eller replikafilteret kan ikke ændres, fordi replikaen indeholder konflikter eller datafejl. (Fejl 3636)

Du forsøger at ændre den delvise replikas filter eller udfylde en delvis replika, og den pågældende replika indeholder konflikter eller datafejl. Du skal løse konflikterne eller fejlene, før du fortsætter. Dette forhindrer utilsigtet tab af konfliktdata og sikrer, at fejlene løses korrekt.


Oplysningerne om den fulde sti til et medlem af replikasættet kan ikke hentes. (Fejl 3499)

Dette er en uventet advarsel. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Det er ikke muligt at hente den angivne registreringsdatabaseparameter for Synchronizer. (Fejl 3494)

Du skal konfigurere Synchronizer på computeren.

Sådan konfigureres Synchronizer

  1. Start Replikastyring.
  2. Vælg Konfigurer Microsoft Replikastyring i menuen Funktioner.
  3. Følg instruktionerne i guiden.


Værdien kan ikke indstilles. (Fejl 2448)

Du forsøger at tildele en værdi til et objekt, der er skrivebeskyttet, eller som ikke indeholder en værdi.


Du kan ikke angive egenskaben KeepLocal for et objekt, der allerede er replikeret. (Fejl 3457)

Egenskaben KeepLocal kan ikke angives for et replikeret objekt. Det påvirker ikke objektet, hvis du angiver et lokalt objekts egenskab KeepLocal, når databasen er blevet replikeret. Hvis du vil forhindre, at et objekt replikeres til de andre replikaer i sættet, skal du angive objektets egenskab Replicable til "F".


Du kan ikke ændre datamasterattributet til replikasættet. Der tillades kun dataændringer i masterdesign. (Fejl 3594)

Du kan ikke ændre replikasættets datamasterattribut. Det tillader kun dataændringer i masterdesign. (Fejl 3594)

Om en replikeret database tillader brugere at ændre data i alle replikaer eller kun i masterdesignreplikaen bestemmes, når databasen første gang konverteres til et masterdesign. Når databasen er konverteret, kan attributtet til en enkelt eller flere datamasters ikke ændres.


Du kan ikke ændre replikasættets datamasterattribut. (Fejl 3593)

Om en replikeret database tillader brugere at ændre data i alle replikaer eller kun i masterdesignreplikaen bestemmes, når databasen første gang konverteres til et masterdesign. Når databasen er konverteret, kan attributtet til en enkelt eller flere datamasters ikke ændres.


Det er ikke muligt at angive den specificerede registreringsdatabaseparameter for Synchronizer. (Fejl 3493)

Du skal konfigurere Synchronizer på computeren.

Sådan konfigureres Synchronizer

  1. Start Replikastyring.
  2. Vælg Konfigurer Microsoft Replikastyring i menuen Funktioner.
  3. Følg instruktionerne i guiden.


Systemkolonnen til replikering kan ikke opdateres. (Fejl 3577)

Den kolonne, du forsøger at opdatere, er en systemkolonne, der er skrivebeskyttet.


Handlingen understøttes ikke i en Paradox-tabel, der ikke har en primær nøgle. (Fejl 3207)

Kør det program, der har oprettet tabellen, og tilføj en primær nøgle. Forsøg derefter at udføre handlingen igen.


Det lykkedes ikke at skrive til Synchronizer-logfilen. (Fejl 3471)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Der kunne ikke skrives til filen <navn>. (Fejl 3180)

Du har forsøgt at eksportere data til den angivne tekst- eller regnearksfil, men filen kunne ikke ændres.

Mulige årsager:

  • En anden bruger er ved at åbne filen. Vent, til den anden bruger er færdig med at arbejde med filen, og forsøg derefter at udføre handlingen igen.
  • Filen er defineret som skrivebeskyttet i operativsystemet eller i netværket. Fjern betingelsen for skrivebeskyttelse, og forsøg derefter at udføre handlingen igen.
  • Du har ikke skriveadgang til filen i et netværksmiljø.

Kontakt eventuelt system- eller netværksadministratoren.


Denne tabel indeholder celler, der er uden for det celleområde, der er defineret i dette regneark. (Fejl 3673)

Den regnearksfil, der læses, er ikke korrekt udformet. Den indeholder data, som ligger uden for det område, der er angivet i filheaderens oplysninger. Regnearksdriveren kan ikke læse dataene pålideligt, hvis de ikke er udformet korrekt.

Filen er måske ikke en regnearksfil, eller den er eventuelt blevet beskadiget. Prøv at læse filen i det oprindelige regnearksprodukt, og skriv den derefter igen til en anden fil. Regnearksproduktet kan måske rette fejlene.


Feltet <navn> kan ikke ændres. (Fejl 3720)

Feltet <navn> kan ikke ændres. Det er en del af én eller flere relationer. (Fejl 3720)

Denne fejl opstår, når du forsøger at ændre navnet på og definitionen af en primær nøgle, der refereres til af andre fremmede nøgler. Hvis du vil ændre definitionen af eller navnet på de kolonner, der indgår i den primære nøgle, skal du først fjerne alle referencer til den primære nøgle i de fremmede nøgler. Dette sker typisk, når du bruger sætningen ALTER TABLE ALTER COLUMN.


CHECK-begrænsningen <navn> findes ikke. (Fejl 3755)

Denne fejl opstår, når du bruger syntaksen ALTER TABLE ALTER COLUMN og forsøger at bruge DROP til en CHECK-begrænsning, der ikke findes. Fejlen kan også opstå, når du forsøger at bruge Microsoft® OLE DB Provider til Jet til at hente oplysninger om en CHECK-begrænsning, der ikke findes.


Der er en syntaksfejl i CHECK CONSTRAINT-delsætningen. (Fejl 3765)

Denne fejl opstår, når du bruger SQL DLL til at definere en CHECK-begrænsning. Den opstår, når søgebetingelsen (SELECT-sætning) i CHECK-delsætningen refererer til et ugyldigt tabel- eller kolonnenavn.


CHECK-begrænsningen <navn> findes allerede. (Fejl 3756)

Denne fejl opstår, når du bruger syntaksen ALTER TABLE ALTER COLUMN og forsøger at bruge et navn til en CHECK-begrænsning, der allerede er i brug i tabellen. Fejlen kan også opstå, når du bruger Microsoft® OLE DB Provider til Jet og forsøger at tilføje en CHECK-begrænsning med samme navn som en anden CHECK-begrænsning i den samme tabel.


Klientprogrammet har anmodet Synchronizer om at afslutte handlingen. (Fejl 3535)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Det er ikke tilladt for den fremkomne tabel at have mere end ét felt af typen AutoNumber. (Fejl 3090)

Du har forsøgt at køre en forespørgsel, der resulterer i en tabel med mere end ét felt, som indeholder en AutoNumber-datatype. Rediger forespørgslen, så den kun indeholder et AutoNumber-felt.


Et indeks kan ikke oprettes i det givne felt. (Fejl 3287)

Du forsøger at oprette et index i et felt af typen Memo eller OLE Object. Angiv et andet felt, og forsøg derefter at udføre handlingen igen.

Denne fejl kan også opstå, hvis du forsøger at oprette et indeks på et 1-byte felt i en Btrieve-tabel.


Antallet af kolonner i de to markerede tabeller eller forespørgsler i en foreningsforespørgsel stemmer ikke overens. (Fejl 3307)

De to tabeller eller forespørgsler, der er joinforbundet ved hjælp af UNION-handlingen, skal generere samme antal kolonner. Fjern kolonnerne fra den SELECT-sætning, der indeholder for mange kolonner, eller medtag flere kolonner i den SELECT-sætning, der indeholder for få.

Bemærk! Du kan medtage konstanter i stedet for kolonner i den SELECT-sætning, der indeholder for få kolonner. I følgende foreningsforespørgsel genereres f.eks. tre kolonner fra den første SELECT-sætning, men én kolonne og to konstanter i den anden SELECT-sætning. Forespørgslen returnerer alle lande i tabellerne Medarbejdere og Områder. Fra tabellen Medarbejdere returnerer forespørgslen også fornavnet og efternavnet på en medarbejder. Hvis landeværdien er fra tabellen Områder, returnerer forespørgslen dog Null i kolonnerne Fornavn og Efternavn.

SELECT Land, Fornavn, Efternavn FROM Medarbejdere

UNION SELECT Land, NULL, NULL FROM Områder;


Feltet passer ikke til posten. (Fejl 3016)

Du har forsøgt at importere eller indsætte et felt, der er for stort. Overvej at opdele feltet i mindre dele og dernæst importere eller indsætte dataene i flere felter eller ændre feltets datatype.

Poster er begrænset til lidt under 2 KB i størrelse, undtagen felter af typen Memo og OLE Object.


Feltet kan ikke defineres mere end en gang. (Fejl 3191)

Feltet kan ikke defineres mere end én gang. (Fejl 3191)

Du har forsøgt at oprette en tabel, hvor mere end et felt var defineret med det samme navn. Alle feltnavne i en tabel skal være unikke.


Dette felt kan ikke slettes. Det er en del af en eller flere relationer. (Fejl 3303)

Du forsøger at slette et felt, der er defineret relationer til i databasen. Hvis du vil slette dette felt, skal du først slette relationerne.


Et felt, der indgår i et indeks eller er krævet af systemet, kan ikke slettes. (Fejl 3280)

Hvis du vil slette et felt, der er en del af et indeks, skal du først slette indekset.


Egenskaben for sporing af kolonneniveau kunne ikke ændres på de objekter, der allerede er replikerbare. (Fejl 3779)

Når et objekt er gjort replikerbart, kan egenskaben for sporing af kolonneniveauet ikke ændres. Hvis du vil ændre sporingen af objektet, skal objektet gøres lokalt igen. Derefter kan du ændre egenskaben for sporing af kolonneniveauet og gøre objektet replikerbart igen.


Feltet kunne ikke findes. (Fejl 3018)

Mulige årsager:

  • Det angivne objekt findes ikke.
  • Du har stavet feltnavnet forkert. Kontroller, om der mangler understregningstegn ( _ ) eller anden tegnsætning, og kontroller, at du ikke har indtastet foranstillede mellemrum.
  • Du har indtastet et ugyldigt felt-ID. F.eks. [Min tabel]_[Mit felt] i stedet for MinTabel![Mit felt].
  • Du har ikke brugt kantede parenteser omkring et feltnavn, der indeholder mellemrum.


Feltet <navn> kunne ikke findes. (Fejl 3799)

Du har refereret til et kolonnenavn, der ikke findes.


JOIN-handlingen <handling> refererer til et felt, der ikke er i en af de joinforbundne tabeller. (Fejl 3082)

Du har forsøgt at køre en SQL-sætning, der indeholder en ugyldig joinforbindelse. Denne fejl opstår, hvis du forsøger at oprette en joinforbindelse til et felt, der ikke findes i en af de joinforbundne tabeller. I følgende eksempel opstår denne fejl:

SELECT Forfattere.Fornavn, Titler.ISBN

FROM Forfattere, Titler, ForfatterTitler,

Forfattere INNER JOIN Titler ON Forfattere.ID = ForfatterTitler.ISBN;

Fejlen opstår, fordi joinforbindelsen omfatter tabellerne Forfattere og Titler, men de joinforbundne felter findes i tabellerne Forfattere og ForfatterTitler.


Feltet kan ikke opdateres, fordi en anden bruger eller proces har låst den tilsvarende post eller tabel. (Fejl 3164)

Feltet kan ikke opdateres. (Fejl 3164)

Mulige årsager:

  • Du har forsøgt at opdatere et felt i en post eller tabel, der i øjeblikket er låst af en anden bruger. Vent, til den anden bruger er færdig med at arbejde med posten eller tabellen, og forsøg derefter at udføre handlingen igen.
  • Du har i Microsoft® Access forsøgt at ændre værdien i et kontrolelement, hvis Locked-egenskaben er angivet til Yes.


Tabellen kan ikke replikeres. Antallet af kolonner overskrider det maksimale tilladte antal. (Fejl 3585)

Tabellen har overskredet det maksimalt tilladte antal kolonner. Hvis tabellen indeholder mindre end 251 kolonner, kan du ved at komprimere databasen hente tilgængelige kolonner, der stadig tæller med til grænsen.


Størrelsen af et felt er for stort. (Fejl 3017)

Mulige årsager:

  • Du har forsøgt at definere eller oprette et felt af typen Text, der er på mere end 254 tegn. Benyt et tal fra 1 til 254 tegn, og forsøg derefter at udføre handlingen igen, eller opret et felt af typen Memo til dataene.
  • Du forsøgte at definere et forespørgselsparameter, der er længere end 255 tegn.


Bredden på en Unicode-tekstkolonne skal være et lige antal byte. (Fejl 3702)

Databasen lagrer data ved hjælp af Unicode-tegnsættet, hvor hvert tegn er en ordværdi (to byte). Kolonner til tekst skal erklæres som et lige antal byte i bredden, så kolonnerne kan indeholde et nøjagtigt antal Unicode-tegn.

  • Hvis denne fejlmeddelelse vises under databaseoprettelse, skal det program, der forsøger at oprette en ikke-korrekt database, rettes.
  • Hvis denne fejlmeddelelse vises under normal kørsel, skyldes det sandsynligvis, at databasen er beskadiget og skal komprimeres eller repareres.


Den kombinerede længde af Internet-servernavn, HTTP-sharenavn og FTP-aliasnavn må ikke overstige 252 tegn. (Fejl 3745)

De angivne indirekte værdier eller Internet-værdier overstiger den interne grænse på 252 tegn. Du skal afkorte det navn, der overstiger denne grænse.


Posten kan ikke læses, fordi den er låst af en anden bruger. (Fejl 3624)

Du har forsøgt at læse en post på en 2 KB-database- side der i øjeblikket er låst af en anden bruger. Vent, til den anden bruger er færdig med at arbejde med posten, og forsøg derefter at udføre handlingen igen.


Der kan ikke læses, fordi den er låst af brugeren <navn> på maskinen <navn>. (Fejl 3187)

Der kan ikke gemmes, fordi den er låst af brugeren <navn> på maskinen <navn>. (Fejl 3187)

Du har forsøgt at læse oplysninger på en database- side, der i øjeblikket er låst af den angivne bruger. Vent, til den anden bruger er færdig, og forsøg derefter at udføre handlingen igen.


Samtidige skemaændringer medførte, at oprettelsen af replika mislykkedes. Forsøg igen. (Fejl 3763)

Under oprettelsen af replika kan der være oprettet nye objekter i kildereplikaen, som forhindrer handlingen i at blive udført. Forsøg igen.


De kaskadevise indstillinger for den nye reference er i konflikt med den eksisterende reference <navn>. (Fejl 3707)

Denne fejl opstår, hvis en CASCADE-handling er defineret i en kolonne, der allerede har en anden type CASCADE-handling. Hvis CASCADE DELETE f.eks. allerede er defineret, forhindres brugeren i at skrive for at tilføje CASCADE UPDATE. Hvis du vil anvende den ønskede CASCADE-handling, skal den oprindelige CONSTRAINT opgives. Dette kan gøres med ALTER TABLE ALTER COLUMN-syntaksen eller med DROP CONSTRAINT-syntaksen.


Der kan ikke tilføjes en ny kolonne til konflikttabellen <navn>. Slet forældede kolonner, og komprimer databasen. (Fejl 3740)

Du har nået grænsen for antallet af kolonner i en konflikttabel. Design basistabellen med færre kolonner.


Konflikttabeller kan ikke omdøbes. (Fejl 3769)

En konflikttabel er en systemtabel, der ikke kan omdøbes. Hvis du vil fjerne konflikter fra replikaen, kan du slette indholdet i konflikttabellen. Du kan også slette selve konflikttabellen.


Tilslutningsstrengen er for lang. (Fejl 3210)

Tilslutningsstrengen i delsætningen IN i en SQL-sætning kan ikke være længere end 255 tegn. Ret indtastningen, og forsøg derefter at udføre handlingen igen.


Feltreferencen <navn> er ukendt eller ugyldig. (Error 3345)

Feltreferencen <navn> er ukendt eller ugyldig. (Fejl 3345)

Udtrykket refererer ukorrekt til et felt, eller det refererer til et felt, der ikke findes. Undersøg, om feltnavnet er korrekt.


Filen kunne ikke låses. (Fejl 3050)

Operativsystemet tillader ikke, at Microsoft® Jet opretter en låsefil (.ldb) i det samme bibliotek, hvor databasefilen (.mdb) er placeret. Du skal have skrivetilladelser til det bibliotek, der indeholder den database, du prøver at åbne. Denne fejl kan også opstå, hvis du prøver at bruge den passive luk ned/tilslutningsstyringsfunktion, mens databasen er åbnet med udelt adgang.


Der kunne ikke opdateres, fordi siden er låst. (Fejl 3218)

Du har forsøgt at opdatere data på en side, der i øjeblikket er låst.

Mulige årsager:

  • Du har forsøgt at gemme en forespørgsel, der bruges af en anden person. Hvis du vil gemme forespørgslen, skal du vente, til den anden bruger er færdig, eller skrive et andet navn, og derefter forsøge at udføre handlingen igen.
  • Du har forsøgt at benytte metoden Edit på en dataside, der indeholder en post, som allerede er åben eller låst.


Tællerdefinitionen er ikke i et gyldigt område. (Fejl 3770)

Denne fejl opstår, når du forsøger at oprette en kolonne, der er en IDENTITY- eller COUNTER-datatype, og angiver de valgfri værdier for basis og stigning. Basis- og stigningsværdierne skal være i det gyldige område for en LONG-datatype.


Det lykkedes ikke at oprette filen. (Fejl 3436)

Der er opstået en fejl, mens du har forsøgt at oprette en Microsoft® Excel-fil, en tekstfil eller en installerbar ISAM i Lotus.

Mulige årsager:

  • Utilstrækkelig diskplads
  • Netværksfejl


Denne handling kræver et andet markørbibliotek. (Fejl 3663)

Den markørtype, der blev valgt, da postsættet blev åbnet, understøtter ikke den anmodede handling. Åbn igen med den korrekte markørtype, eller brug den rette handling for den aktuelle markørtype. Denne fejl opstod ved brug af ODBCDirect.


Den database, du prøver at åbne, bruges allerede af et andet program. (Fejl 3576)

Hvis du forsøger at åbne databasen i udelt tilstand, er det muligt, at et andet program allerede har databasen åben. Hvis du forsøger at åbne databasen i delt tilstand, er det muligt, at et andet program har databasen åben i udelt tilstand. Luk de andre programmer, der benytter databasen, og prøv at foretage anmodningen igen.


Der opstod et problem i databasen. Løs problemet ved at reparere og komprimere databasen. (Fejl 3428)

Den database, du forsøger at anvende, har et ikke-angivet problem, og den markeres derfor som beskadiget.

Sådan løses problemet:

  1. Luk databasen.
  2. Reparer databasen med metoden RepairDatabase. I Microsoft® Access kan du også reparere databasen ved at gå til menuen Funktioner, pege på Databasefunktioner og derefter klikke på Reparer database.
  3. Komprimer databasen ved hjælp af metoden CompactDatabase. I Microsoft Access kan du også gøre dette ved at gå til menuen Funktioner, pege på Databasefunktioner og derefter klikke på Komprimer database.

Vigtigt! Alle trin er obligatoriske.


Databasen findes allerede. (Fejl 3204)

Du har forsøgt at oprette eller omdøbe en database og bruge et navn, som allerede findes. Skriv et andet navn, og forsøg derefter at udføre handlingen igen.


Regnearket er fuldt. (Fejl 3437)

Du har forsøgt at tilføje nye poster til en Lotus 1-2-3 eller Microsoft® Excel version 3.0- eller version 4.0-fil, men filen er fuld. Filer af disse typer kan indeholde højst 16.384 poster.


Databasen <databasenavn> er allerede i brug af en anden person eller proces. Når databasen er tilgængelig, skal du forsøge at udføre handlingen igen. (Fejl 3196)

Databasen <databasenavn> bruges allerede af en anden person eller proces. Når databasen er tilgængelig, kan du forsøge at udføre handlingen igen. (Fejl 3196)

Den angivne database anvendes i øjeblikket af en anden bruger eller session med udelt adgang. Vent, til den anden bruger eller session er færdig med at arbejde med databasen, og forsøg derefter at udføre handlingen igen.


<Databasenavn> er ikke et gyldigt databasenavn. (Fejl 3005)

Det angivne databasenavn følger ikke standardnavngivningskonventionerne for filnavne. Navnet er måske for langt til den buffer, der indeholder stien og filnavnet. Skriv et nyt navn, og forsøg derefter at udføre handlingen igen.


Databasen <navn> er låst med udelt adgang. (Fejl 3006)

Du har forsøgt at benytte en database, der i øjeblikket er åbnet med udelt adgang af en anden bruger. Vent, til den anden bruger er færdig med at arbejde med databasen, og forsøg derefter at udføre handlingen igen.


Objektet kan ikke replikeres, fordi databasen ikke er replikeret. (Fejl 3485)

Du kan ikke replikere et objekt i en database, medmindre du først replikerer den database, objektet tilhører. Du kan replikere databasen ved at:

  • Trække den til Microsoft® Windows® Rejsetaske.
  • Bruge DAO-programmering til at angive egenskaben Replicable til "T" eller egenskaben ReplicableBool til True.
  • Bruge Microsoft Access.
  • Bruge Replikastyring.

Alle objekter i databasen er replikeret, når databasen er replikeret, medmindre egenskaben KeepLocal er angivet for et objekt.


Biblioteksdatabasen <navn> kan ikke åbnes. (Fejl 3007)

Den angivne database er en intern biblioteksdatabase i Microsoft Jet-databasemotoren, som du ikke kan åbne.


Databasen er allerede replikerbar. (Fejl 3784)

Databasen er allerede replikerbar og kan ikke gøres replikerbar igen. Hvis du vil replikere lokale objekter i databasen, skal du gøre objekterne replikerbare fra masterdesignet ved at indstille den replikerbare egenskab til True.


Systemtabellerne i replikaen er ikke længere pålidelige, og replikaen bør ikke bruges. (Fejl 3595)

Replikaen på computeren er beskadiget. Da Microsoft Jet-databasemotoren reparerede replikaen, kan den have ændret en eller flere systemtabeller. Slet replikaen, og erstat den med en nye replika.


Jet-databasen er forkert eller mangler for dette SQL/Jet-replikasæt. (Fejl 3778)

Den angivne Microsoft® Jet-database er forkert eller mangler, fordi:

  • Den sti til datakilden, der er angivet i linkserveren på SQL Server, peger på en ugyldig replika til denne publikation. Replikaen kan være erstattet, beskadiget eller er ikke oprettet korrekt.
  • Hub-rækken mangler eller er ugyldig.
  • Den angivne database er ikke replikerbar.

Løsningen er at geninitialisere Jet Subscriber ved hjælp af Re-Initialize-værktøjerne på SQL Server.


Microsoft Jet-databasemotoren har standset processen, fordi du og en anden bruger forsøger at ændre de samme data samtidigt. (Fejl 3197)

Denne fejl kan opstå i et flerbrugermiljø.

En anden bruger har ændret de data, du forsøger at opdatere. Denne fejl kan opstå, hvis flere brugere åbner en tabel eller opretter et Recordset-objekt og bruger begrænset låsning. Fra det tidspunkt, hvor du benyttede metoden Edit, til du benyttede metoden Update, har en anden bruger ændret de samme data.

Hvis du vil overskrive den anden brugers ændringer med dine egne, skal du udføre metoden Update igen.


Datoen er uden for området eller har et ugyldigt format. (Fejl 3175)

Kun datoer fra 30. december 1899 til 30. december 9999 genkendes.

Mulige årsager:

  • Du har indtastet en dato, der ligger uden for det gyldige område.
  • Du har indtastet en gyldig dato, men formatet blev ikke genkendt. Kontroller, at du har skrevet datoen korrekt, og forsøg derefter at udføre handlingen igen.


Du har forsøgt at åbne en database, der allerede er åbnet af brugeren <navn> på maskinen <navn>. Prøv igen, når databasen er tilgængelig. (Fejl 3704)

Denne fejl opstår, hvis databasen åbnes med udelt adgang og ikke er delt. Denne fejl opstår, hvis en bruger opretter en ny database i DAO, ADO eller Microsoft® Access og ikke lukker databasen. Andre brugere kan åbne databasen, men de får ovenstående fejlmeddelelse.


Denne handling kan ikke udføres, fordi funktioner i denne version ikke er tilgængelige i databaser, der har et ældre format. (Fejl 3301)

Databasen blev lagret i en tidligere version af Microsoft Jet-databasemotoren, der ikke understøtter denne funktion. Du skal enten konvertere databasen til et Microsoft® Jet version 2.0- eller 3.0-format, eller korrigere denne bestemte handling for at undgå brug af den ikke-understøttede funktion.


Der er en syntaksfejl i ALTER TABLE-sætningen. (Fejl 3293)

Du har skrevet en SQL-sætning, der medtager en ugyldig ALTER TABLE-sætning.

Mulige årsager:

  • Navnet på et reserveret ord eller argument er stavet forkert eller mangler.
  • Tegnsætningen er ikke korrekt.


Der er en syntaksfejl i feltdefinitionen. (Fejl 3292)

Der er opstået en syntaksfejl i feltdefinitionen i en CREATE TABLE- eller ALTER TABLE-sætning.

Mulige årsager:

  • Navnet på et reserveret ord eller argument er stavet forkert eller mangler.
  • Tegnsætningen er ikke korrekt.


Feltet <navn> findes allerede i tabellen <navn>. (Fejl 3380)

Du har skrevet det samme felt- navn to gange. Skriv programkoden om igen, og giv hvert felt et unikt navn. Du bør også kontrollere, at feltnavnet findes i samlingen Fields.


Feltet <navn> kan ikke slettes. Det er en del af en eller flere relationer. (Fejl 3383)

Du forsøger at slette et felt, der er defineret relationer til i databasen. Hvis du vil slette dette felt, skal du først slette relationerne.


Feltet <navn> findes ikke i tabellen <navn>. (Fejl 3381)

Den angivne tabel indeholder ikke det angivne felt. Du skal undersøge, om feltnavnet indeholder stavefejl. Du bør også kontrollere, at feltnavnet findes i samlingen Fields.


De angivne felter er ikke unikt indekserede i tabellen <navn>. (Fejl 3374)

De angivne felter i den tabel, der refereres til i en CONSTRAINT-delsætning, er ikke unikt indekserede.


Feltet <navn> er for stort. (Fejl 3382)

Tekstfelter i Microsoft® FoxPro®-tabeller kan højst indeholde 254 tegn og i Microsoft Jet-tabeller 255-tegn. Du kan omdefinere størrelsen af feltet.


Der er en syntaksfejl i CONSTRAINT-delsætningen. (Fejl 3289)

Du har skrevet en SQL-sætning, der indeholder en ugyldig CONSTRAINT-delsætning.

Mulige årsager:

  • Navnet på et reserveret ord eller argument er stavet forkert eller mangler.
  • Tegnsætningen er ikke korrekt.


Der er en syntaksfejl i CREATE INDEX-sætningen. (Fejl 3291)

Du har skrevet en SQL-sætning, der medtager en ugyldig CREATE INDEX-sætning.

Mulige årsager:

  • Navnet på et reserveret ord eller argument er stavet forkert eller mangler.
  • Tegnsætningen er ikke korrekt.


Der er en syntaksfejl i CREATE TABLE-sætningen. (Fejl 3290)

Du har skrevet en SQL-sætning, der medtager en ugyldig CREATE TABLE-sætning.

Mulige årsager:

  • Navnet på et reserveret ord eller argument er stavet forkert eller mangler.
  • Tegnsætningen er ikke korrekt.


Relationer skal bestå af det samme antal felter med de samme datatyper. (Fejl 3368)

Den CONSTRAINT-delsætning, du bruger til at oprette en relation, indeholder foreskellige antal felter til hver tabel eller medtager felter med forskellige datatyper. Du skal kontrollere antallet af felter i CONSTRAINT-delsætningen, kontrollere felternes datatyper for at sikre, at de stemmer overens, og derefter prøve igen.


Der er en syntaksfejl i DROP INDEX-sætningen. (Fejl 3294)

Du har skrevet en SQL-sætning, der indeholder en ugyldig DROP INDEX-sætning.

Mulige årsager:

  • Navnet på et reserveret ord eller argument er stavet forkert eller mangler.
  • Tegnsætningen er ikke korrekt.


Der er en syntaksfejl i DROP TABLE- eller DROP INDEX-sætningen. (Fejl 3295)

Du har skrevet en SQL-sætning, der indeholder en ugyldig DROP-sætning.

Mulige årsager:

  • Navnet på et reserveret ord eller argument er stavet forkert eller mangler.
  • Tegnsætningen er ikke korrekt.


Tabellen <navn> har allerede et indeks, der hedder <navn>. (Fejl 3375)

Du forsøger at oprette et indeks, der allerede findes.


Indekset <navn> findes ikke i tabellen <navn>. (Fejl 3372)

Det angivne indeks findes ikke i den angivne tabel. Undersøg, om programkoden indeholder stavefejl eller andre fejl, eller kontroller, at samlingen Indexes indeholder det angivne indeks.


Relationer, der gennemtvinger referentiel integritet, kan ikke oprettes. Eksisterende data i tabellen <navn> overholder ikke reglerne for referentiel integritet i tabellen <navn>. (Fejl 3379)

Relationer, der gennemtvinger referentiel integritet, kan ikke oprettes. Eksisterende data i tabellen <navn> overholder ikke de referentielle integritetsregler, der er defineret i tabellen <navn>. (Fejl 3379)

Du forsøger at oprette en relation ved hjælp af CONSTRAINT-delsætningen i sætningen ALTER TABLE, men eksisterende data i de to tabeller overholder ikke begrænsningerne for referentiel integritet. Der kan f.eks. være poster, der er tilknyttet en medarbejder i den relaterede tabel, men der er ingen tilsvarende post for medarbejderen i den primære tabel.

Hvis du vil oprette relationen, skal du redigere dataene, så der findes primære poster til alle relaterede poster.


Relationen kan ikke oprettes. Tabellen <navn>, der refereres til, indeholder ikke en primær nøgle. (Fejl 3373)

Den tabel, du har refereret til i CONSTRAINT-delsætningen, indeholder ikke en primær nøgle. Hvis du vil oprette relationen, skal du enten oprette en primær nøgle i den tabel, der refereres til, eller udtrykkeligt referere til et eller flere unikt indekserede felter, der skal anvendes i relationen.


Tabellen eller begrænsningen kan ikke findes. (Fejl 3371)

Den tabel eller relation du har angivet, findes ikke. Angiv et gyldigt navn på tabellen eller begrænsningen.


Udformningen af tabellen <navn> kan ikke ændres. Det er en skrivebeskyttet database. (Fejl 3370)

Du kan ikke redigere tabeller i en skrivebeskyttet database.


Der er allerede en relation med navnet <navn> i den aktuelle database. (Fejl 3378)

Du skal angive et unikt navn for hver relation, du føjer til en database ved hjælp af data-definitionsforespørgsler. Kontroller, at det navn, du har angivet, findes i samlingen Relations.


Relationen <navn> findes ikke i tabellen <navn>. (Fejl 3377)

Den relation, du har angivet, findes ikke i denne database. Kontroller, at det navn, du har angivet, findes i samlingen Relations.


DLL kan ikke udføres på denne tabel, fordi der refereres til det af begrænsningen <navn> på tabellen <navn>.

DLL kan ikke udføres på denne tabel, fordi der refereres til det af begrænsningen <navn> på tabellen <navn>. (Fejl 3803)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Tabellen <navn> findes ikke. (Fejl 3376)

Den tabel, du har angivet, findes ikke. Kontroller, at det navn, du har angivet, findes i samlingen TableDefs.


Skalering af decimalværdi medførte overløb af data. (Fejl 3760)

Denne fejl opstår, når data opdateres eller indsættes i datatypen DECIMAL, og de er større end den definerede skala for kolonnen.


Præcisionen af decimalfeltet er for lav til at godkende det tal, du forsøgte at tilføje. (Fejl 3761)

Præcisionen af decimalfeltet er for lav til at godkende det tal, du forsøgte at tilføje.

Denne fejl opstår, når data opdateres eller indsættes i datatypen DECIMAL, og de ikke stemmer overens med den definerede præcision for kolonnen.


Skalering af decimalværdi medførte afkortelse af data. (Fejl 3758)

Denne fejl opstår, når data opdateres eller indsættes i datatypen DECIMAL, og de ikke stemmer overens med den definerede skala og præcision for kolonnen.


Filen kunne ikke dekrypteres. (Fejl 3161)

Du har forsøgt at få adgang til en krypteret Btrieve- eller Paradox-tabel, men du har angivet en forkert adgangskode. Indtast den korrekte adgangskode, og forsøg derefter at udføre handlingen igen.


Skalering af decimalværdi medførte afkortelse af data. (Fejl 3759)

Denne fejl opstår, når data opdateres eller indsættes i datatypen DECIMAL, og de ikke stemmer overens med den definerede skala og præcision for kolonnen.


Der er en syntaksfejl i standardværdien. (Fejl 3355)

Mulige årsager:

  • Der er medtaget et ukendt funktionsnavn i standardværdiudtrykket i en valideringsregel på tabelnivau.
  • Et standardværdiudtryk i en valideringsregel på tabelniveau har en forkert synktaks.


Det lykkedes ikke at slette en fil ved hjælp af FTP. (Fejl 3682)

Det lykkedes ikke at slette en fil ved hjælp af FTP. Sørg for, at FTP-rullelisten har læse- og skrivetilladelser. (Fejl 3682)

Det lykkedes ikke at slette en fil på Internet-serveren. Sørg for, at serveren kører, og at den delte mappe til FTP er konfigureret med læse- og skriveadgang.


Sletning af data i en sammenkædet tabel understøttes ikke af denne ISAM. (Fejl 3617)

Den installerbare ISAM, du anvender, giver dig ikke mulighed for at slette poster i eksterne tabeller. Du kan kun tilføje nye poster.


Det er ikke muligt at slette et eller flere objekter: <Navn>. (Fejl 3773)

Denne fejl opstår, når du bruger syntaksen DROP TABLE og angiver en tabel, der ikke findes eller er åbnet af en anden bruger.


Delete/RI-konflikt. (Fejl 3717)

Den primære nøgle er blevet slettet af en anden replika. Derfor er denne referencepost blevet afvist. Opret enten en ny primær nøgle, der opfylder den referentielle integritetsbegrænsning, og send derefter opdateringen igen, eller slet denne konfliktpost.


Lokale og anonyme replikaer kan ikke være masterdesign. (Fejl 3771)

Lokale og anonyme replikaer kan ikke gøres til masterdesign. (Fejl 3771)

Lokale eller anonyme replikaer af masterdesignet kan ikke udføres, fordi de indeholder replikasættets systemoplysninger. Kun globale replikaer af masterdesign kan udføres. Du skal kun oprette et nyt masterdesign, hvis du er sikker på, at det aktuelle masterdesign er ugyldigt og ikke længere fungerer som masterdesign, eller hvis masterdesignet skal flyttes.


Adgang til mappen med destinationsrullelisten blev nægtet. (Fejl 3562)

Kontroller, om du har adgang til det drev, hvor mappen til destinationsrullelisten ligger.


En anden handling forhindrer, at denne handling udføres. (Fejl 3667)

Denne fejl betyder normalt, at en asynkron handling allerede udføres på objektet, og at der ikke tillades en anden handling, før den asynkrone handling er udført eller annulleret.


De to replikaer, du forsøger at synkronisere, kommer fra forskellige replikasæt. (Fejl 3545)

Replikaer fra forskellige replikasæt kan ikke synkroniseres. Sørg for, at du har valgt den rette replika til synkronisering.


Det diskdrev, du forsøger at skrive til, er fuldt. (Fejl 3575)

Diskdrevet har ikke tilstrækkelig plads til at fuldføre handlingen. Slet overflødige filer fra disken for at skaffe tilstrækkelig plads til handlingen. Skaf tilstrækkelig plads på disken til den fil, du forsøger at gemme.


Det diskdrev, du prøver at få adgang til, kan ikke læses. (Fejl 3465)

Hvis du forsøger at få adgang til en diskette, skal du sørge for, at diskettedrevet er lukket. Hvis du forsøger at få adgang til en harddisk, kan disken have en beskadiget sektor.


Der opstod en disk- eller netværksfejl. (Fejl 3043)

En intern disk- eller drevfejl forhindrer læsning fra eller skrivning til disken.

Mulige årsager:

  • Du har forsøgt at benytte et netværksdrev, men netværket er midlertidigt optaget, eller du er ikke længere tilsluttet netværket. Kontroller netværkstilslutningen, og forsøg derefter at udføre handlingen igen.
  • Der er opstået en fejl ved disken eller drevet.


Der er en disk I/O-fejl i mappen med destinationsrullelisten. (Fejl 3558)

Der er en disk I/O-fejl i mappen med destinationsrullelisteboksen. (Fejl 3558)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Der opstod en diskfejl under forsøg på at få adgang til logfilen <navn>. (Fejl 3473)

Diskdrevet til logfilen kan have en beskadiget sektor.

Hvis du vil vælge et andet diskdrev til logfilen, skal du åbne Replikastyring og vælge Konfigurer Microsoft Replikastyring i menuen Funktioner. Eller kør installationsprogrammet til det program, der anvender replikering.


Der opstod en diskfejl under forsøg på at få adgang til mappen med rullelisten <navn>. (Fejl 3470)

Disken kan have en beskadiget sektor.


Der er ikke tilstrækkelig plads på disken. (Fejl 3026)

Du har forsøgt at udføre en handling, der kræver mere end den tilgængelige diskplads. Fjern ubenyttede filer fra disken, komprimer databasen, og forsøg derefter at udføre handlingen igen.


Der er opstået en systemfejl, eller swapfilen har nået grænsen. (Fejl 3539)

Synchronizer har foretaget et systemkald, der har medført et uventet problem. Luk computeren ned, sluk den, og genstart den.


Der kan ikke grupperes på felter, der er markeret med '*' <tabelnavn>. (Fejl 3120)

Der kan ikke grupperes efter felter, der er markeret med '*' <tabelnavn>. (Fejl 3120)

Du har forsøgt at køre en SELECT-sætning, der grupperer eller sammentæller alle felter i en enkelt tabel, der er markeret med en stjerne ( * ). Denne fejl opstår, hvis du f.eks. skriver følgende SQL-sætning:

SELECT Ordrer.* FROM Ordrer GROUP BY Speditionsfirma;


Adgang blev nægtet under forsøg på at få adgang til mappen med rullelisten <navn>. (Fejl 3468)

Kontroller dine tilladelser til mappen til rullelisten.


Adressen <navn> på rullelisten har en ugyldig syntaks. (Fejl 3477)

Nulstil rullelistemappen. Åbn Replikastyring, gå til menuen Funktioner, og vælg Konfigurer Microsoft Replikastyring. Eller kør installationsprogrammet til det program, der anvender replikering.


Disken til mappen med rullelisten <navn> er fuld. (Fejl 3469)

Der er ikke nok plads på rullelistemappen's diskdrev til at fuldføre handlingen. Slet overflødige filer fra disken for at skaffe tilstrækkelig plads til handlingen.


Den adgangskode, der bruges af Synchronizer til at skrive til en mappe med en destinationsrulleliste, er ugyldig. (Fejl 3484)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Fandt en uventet slutning på fil. (Fejl 3179)

Du har forsøgt at importere en fil, der indeholder et filafslutningsmærke i en uventet position.

Mulige årsager:

  • Den fil, du vil importere, er beskadiget. Gendan en sikkerhedskopi af den fil, du vil importere, og forsøg derefter at udføre handlingen igen.
  • De import-/eksportspecifikationer, du bruger, svarer ikke til dataene i importfilen. Rediger import- og eksportspecifikationerne, og forsøg derefter at udføre handlingen igen.


Den kaskadevise handling i tabellen <navn> kan ikke udføres. (Fejl 3413)

Den kaskadevise opdatering af tabellen <navn> kan ikke udføres, fordi den er i brug af brugeren <navn> på maskinen <navn>. (Fejl 3413)

Denne fejl opstår, når referentiel integritet defineres med en af følgende handlinger: CASCADE DELETE, UPDATE eller NULL. Fejlen opstår, når du foretager en ændring i en tabel, der indeholder en primær nøgle, der refereres til, og en eller flere fremmed nøgle- tabeller åbnes i en tilstand, der forhindrer, at de fremmed nøgletabeller åbnes i delt læse- og skriveadgang.


Der opstod en alvorlig fejl under adgang til en lokal mappe til rullelisten. (Fejl 3563)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Der opstod en fejl under evalueringen af det delvise filterudtryk. (Fejl 3588)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Der opstod en fejl under evaluering af et delvist udtryk. (Fejl 3656)

Du har indtastet et ugyldigt udtryk i et boolesk filter, der bruges til at bestemme, hvilke poster der skal bruges i en delvis replika. Replikafilteret kan indeholde følgende værdier:

Værdi | Beskrivelse
En streng | Et kriterium, som en post skal opfylde for at blive vist i den replikerede tabel. Strengen svarer til en SQL WHERE-delsætning, men du kan ikke angive underforespørgsler, aggregatfunktioner (såsom Count) eller brugerdefinerede funktioner i kriteriet.
True | Replikerer alle poster.
False | (Standard) Replikerer ingen poster.


(Fejl 3072)

Der var en typeuoverensstemmelse under oprettelse af en tabelvalideringsregel, eller der var en CHECK-konstant i en kolonne. (Fejl 3072)

En valideringsregel på tabelniveau, der refererer til en numerisk datatype, skal f.eks. have en numerisk valideringsdelsætning. Hvis en strengvalideringsdelsætning bruges, returneres denne fejl.


Ventetiden for en hændelse er udløbet. (Fejl 3531)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Tilslutningen for visning af det sammenkædede Microsoft Excel-regneark er gået tabt. (Fejl 3620)

Tilslutningen for visning af det sammenkædede Microsoft® Excel-regneark er gået tabt. Sessionen med Microsoft Excel blev muligvis afbrudt.


Undtagelsestabellen kan ikke oprettes ved import/eksport. (Fejl 3618)

Der opstod et problem under import eller eksport til en ekstern fil. Import/eksportdriveren kunne ikke oprette en fejltabel i Microsoft® Access-databasen til rapportering af problemet.


Poster kan ikke føjes til undtagelsestabellen. (Fejl 3619)

Der opstod et problem under import eller eksport til en ekstern fil. Import/eksportdriveren kunne ikke tilføje en række i fejltabellen i Microsoft® Access-databasen til rapportering af problemet.


Den anmodede udveksling lykkedes ikke, fordi <navn>. (Fejl 3661)

Der opstod en fejl ved den anmodede udveksling, fordi <beskrivelse>. (Fejl 3661)

Udvekslingen er annulleret.


Internet Synchronizer afsluttede uventet. (Fejl 3683)

Internet Synchronizer afsluttede uventet. Se på udvekslingsoversigten over partnerreplikaen på Internet-serveren for at løse problemet. (Fejl 3683)

Internet-serveren svarede med et ugyldigt svar. Forsøg at udføre handlingen igen.


Det er ikke muligt at angive en udveksling med det samme Synchronizer-program. (Fejl 3500)

Brug et gyldigt fjern- synkroniserings-id, når du anmoder om synkronisering.


Den type synkronisering, der er forsøgt udført, er ugyldig. (Fejl 3546)

Den anmodede synkronisering kan ikke udføres på grund af en ugyldig angivelse af argumentet udveksling i metoden Synchronize. Brug en gyldig synkroniseringstype i programmet.


Du har forsøgt at åbne en database, der allerede er åbnet med udelt adgang af brugeren <navn> på maskinen <navn>. Prøv igen, når databasen er tilgængelig. (Fejl 3356)

Mulige årsager:

  • Du forsøgte at åbne en database, der allerede er åbnet med udelt adgang af den angivne bruger <navn>. Du kan ikke åbne databasen, før den anden bruger lukker den.
  • Du forsøgte at åbne en database med udelt adgang, der allerede er åben med delt adgang af den angivne bruger <navn>. Du kan kun åbne databasen med delt adgang, indtil den anden bruger lukker den.


Synchronizer eller Replikastyring fandt ulæste data i den delte hukommelse. De eksisterende data bliver overskrevet. (Fejl 3529)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Forespørgselsnavn var ventet efter EXECUTE. (Fejl 3732)

Denne fejl opstår, når du bruger EXECUTE-sætningen. Der kræves en gyldig lagret forespørgsel (visning eller procedure) efter EXECUTE-sætningen.


Microsoft Jet-databasemotoren kan ikke udføre SQL-sætningen, da den indeholder et felt med en ugyldig datatype. (Fejl 3169)

Du har forsøgt at udføre en SQL-sætning, der indeholder et felt med en ugyldig feltdatatype.

Mulige årsager:

  • Du har medtaget et felt af typen Memo eller OLE Object i et udtryk, hvor det ikke er tilladt.
  • Du har medtaget en numerisk aggregatfunktion, såsom Sum eller StDev, der har forsøgt at udføre en beregning i et felt af typen Text. Vælg en anden aggregatfunktion.


Der er en ikke-defineret funktion <navn> i udtrykket. (Fejl 3085)

Du har angivet et SQL- udtryk, der medtager et Function-procedurenavn, der ikke genkendes. Sørg for, at funktionen findes, og at den kan anvendes i SQL-udtryk, eller kontroller udtrykket for at sikre, at du har stavet navnet korrekt.


Der er en ekstra højreparentes. (Fejl 2435)

Der en ekstra højreparentes. (Fejl 2435)

Du har indtastet et udtryk, der har for mange højreparenteser. Slet alle parenteser, der ikke har en tilhørende venstreparentes.


Det lykkedes ikke at indlæse et RDOCURS.dll. (Fejl 3672)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Det lykkedes ikke at læse i mappen med rullelisten. (Fejl 3512)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Der kan ikke skrives, da destinationsdisken er fuld. (Fejl 3559)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Det lykkedes ikke at skrive til mappen med rullelisten. (Fejl 3513)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Det lykkedes ikke at skrive til Synchronizer-logfilen. (Fejl 3507)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


FastFind kan ikke søge på referencer, der ikke er kolonner. (Fejl 3768)

DAOs metode FIND kan ikke referere til kolonner, der er baseret på en parameter eller et udtryk.


Handlingen understøttes ikke for denne objekttype. (Fejl 3251)

Du har forsøgt at udføre en metode eller tildele en værdi til en egenskab, der normalt er gyldig i forbindelse med objektet, men ikke understøttes i dette bestemte tilfælde. Metoden Edit er f.eks. generelt gyldig i forbindelse med Recordset-objekter, men ikke for Recordset af typen snapshot. Denne fejl kan også opstå, hvis handlingen ikke er tilladt pga. objektets type eller status, som når du forsøger af benytte metoden MovePrevious i et fremadrullende Recordset. Nogle handlinger understøttes heller ikke, afhængigt af om du har adgang til en Microsoft Jet- eller ODBC-datakilde.


Microsoft Jet-databasemotoren kan ikke åbne filen <navn>. Den er allerede åbnet med udelt adgang af en anden bruger, eller du skal have skrivetilladelse til at få vist de tilhørende data. (Fejl 3051)

Microsoft Jet-databasemotoren kan ikke åbne filen <navn>. Den er allerede åbnet med udelt adgang af en anden bruger, eller du skal have tilladelse til at vise dataene. (Fejl 3051)

Mulige årsager:

  • Du skal have tilladelse at læse data i den angivne fil for at kunne vise dataene. Hvis du vil ændre de tildelte tilladelser, skal du kontakte systemadministratoren eller den person, der har oprettet tabellen eller forespørgslen.
  • Du har forsøgt at åbne den angivne fil med udelt adgang, men en anden bruger har allerede åbnet filen.


Du har forsøgt at importere eller sammenkæde en tom tekstfil. Hvis du vil importere eller sammenkæde en tekstfil, skal den indeholde data. (Fejl 3440)

Der er gjort forsøg på at importere eller sammenkæde en tom tekstfil. Hvis du vil importere eller sammenkæde en tekstfil, skal filen indeholde data. (Fejl 3440)

Du har forsøgt at importere eller sammenkæde en tom tekstfil. Hvis du vil importere eller sammenkæde en tekstfil, skal filen indeholde data.


Posten kan ikke læses, fordi den er låst af en anden bruger. (Fejl 3046)

Du har forsøgt at gemme oplysninger på en databaseside, der i øjeblikket er låst af en anden bruger. Hvis du vil gemme ændringerne, skal du vente, indtil den anden bruger er færdig, og derefter forsøge at udføre handlingen igen.


Det angivne filnavn er for langt. (Fejl 3549)

Brug et kortere filnavn.


Filen <navn> kunne ikke findes. (Fejl 3024)

Mulige årsager:

  • Det angivne objekt findes ikke.
  • Du har stavet filnavnet forkert. Kontroller, om der mangler understregningstegn ( _ ) eller anden tegnsætning, og kontroller, at du ikke har indtastet foranstillede mellemrum.
  • Netværkstilslutningen lykkedes ikke eller blev ikke etableret.


<Name> kunne ikke bruges. Filen er allerede i brug. (Error 3045)

Filen <navn> kunne ikke bruges, fordi den allerede er i brug. (Fejl 3045)

Den angivne fil anvendes i øjeblikket af en anden bruger eller session. Vent, indtil den anden bruger eller session er færdig med at arbejde med filen, og forsøg derefter at udføre handlingen igen.


Indstillingen <navn> i tekstfilspecifikationen <navn> er ugyldig. (Fejl 3442)

En af indstillingerne i tekstfilspecifikationen til Tekst ISAM er ugyldig. Specifikationen kan angives på flere måder:

  • Fra Microsoft® Access angives disse værdier i guiden Sammenkæd Tekst, som du kan bruge ved at pege på Hent eksterne data i menuen Filer og derefter vælge Sammenkæd tabeller. Du kan også se dem i systemtabellerne MSysIMEXSpec og MSysIMEXColumns.
  • Fra andre værtsprogrammer i Microsoft Jet lagres disse værdier i filen Schema.ini.


En database, der er oprettet i en tidligere version af programmet, kan ikke åbnes. (Fejl 3041)

Du har forsøgt at få adgang til en database, der har et forældet format. Komprimer databasen, og forsøg derefter at udføre handlingen igen.


<Meddelelse> i et udtryk. (Fejl 3077)

Det udtryk, du har indtastet, er ikke gyldig af den grund, der angives i meddelelsen. Kontroller, at du har indtastet feltnavne og tegnsætning korrekt, og forsøg derefter at udføre handlingen igen.


Fejl i den fremmede nøgle. (Fejl 3719)

Denne fejl i den fremmede nøgle skyldes en ugyldig, primær nøgle, der var part i en replikeringskonflikt. Opret enten en ny primær nøglepost, der opfylder den referentielle integritetsbegrænsning, og send derefter opdateringen igen, eller rediger den fremmede nøgleværdi i denne konflikt, så den svarer til en gyldig, primær nøgleværdi, og send derefter denne konfliktpost igen, eller slet den.


Det lykkedes ikke at tilslutte til FTP-serviceprogrammet. (Fejl 3678)

Det lykkedes ikke at tilslutte til FTP-serviceprogrammet. Sørg for, at FTP-serviceprogrammet kører korrekt på serveren og understøtter anonyme forbindelser. (Fejl 3678)

FTP-forbindelsen kunne ikke åbnes. Sørg for, at Internet-serveren og FTP-serviceprogrammet kører, og at FTP-serviceprogrammet understøtter anonyme forbindelser.


Funktionen er ikke tilgængelig i udtrykkene. (Error 2426)

Funktionen er ikke tilgængelig i udtrykkene. (Fejl 2426)

Du har indtastet en funktion, der ikke kan bruges i dette udtryk. Funktionerne DoEvents, LBound, UBound, Spc og Tab er ikke tilgængelige i udtrykkene.


<Reserveret fejladvarsel> (Fejl 3416)

Denne fejl blev genereret af et program, der er frigivet efter denne version af Microsoft Jet-databasemotoren. Kontakt Microsoft Teknisk Support.


Det lykkedes ikke at hente en fil ved hjælp af FTP. (Fejl 3680)

Det lykkedes ikke at hente en fil ved hjælp af FTP. Sørg for, at FTP-rullelisten har læsetilladelser. (Fejl 3680)

Det lykkedes ikke at hente en fil fra Internet-serveren. Sørg for, at serveren kører, og at den delte mappe til FTP er konfigureret med læse- og skriveadgang. Den fil, du forsøger at hente, kan være slettet.


GUID'erne passer ikke sammen, eller den GUID, der blev anmodet om, kunne ikke findes. (Fejl 3548)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


En HAVING-delsætning kan ikke bruges i en TRANSFORM-sætning. (Fejl 3092)

Hvis du vil angive udvælgelseskriterier, skal du benytte en WHERE-delsætning.


En HAVING-delsætning <navn> uden gruppering eller aggregering. (Fejl 3091)

Der er en HAVING-delsætning <navn> uden gruppering eller aggregering. (Fejl 3091)

Denne fejl opstår, når forespørgslen evaluerer id'erne i SELECT-sætningen. Denne fejl opstår, fordi der ikke er angivet en GROUP BY-delsætning før HAVING-delsætningen, eller fordi den kolonne, der refereres til i HAVING-delsætningen, ikke er medtaget i en AGGREGATE-funktion. Denne fejl opstår f.eks. med SELECT kol1 FROM tabel1 HAVING kol1 > 20. Hvis sætningen er ændret til SELECT kol1 FROM tabel1 GROUP BY kol1 HAVING kol1 > 20, ville sætningen være gyldig. Alternativt ville følgende være gyldig SELECT kol1, count(kol2) FROM tabel1 GROUP BY kol1 HAVING count(kol1) > 20.


Det lykkedes ikke at udføre HTTP-anmodningen. (Fejl 3677)

Det lykkedes ikke at udføre HTTP-anmodningen om at starte Internet Synchronizer eller Internet-serveren. Brug Replikeringsstyring til at konfigurere Internet Synchronizer på Internet-serveren. (Fejl 3677)

Det lykkedes ikke at sende en anmodning til Internet-serveren. Anmodningen kunne være en af følgende:

  • Et forsøg på at åbne og læse en fil på tværs af Internettet.
  • Et forsøg på at slette en fil på tværs af Internettet.
  • Et forsøg på at starte MSTRAI40.exe-synkroniseringsprocessen på Internet-serveren.


Der er en syntaksfejl, fordi der mangler et komma. (Fejl 2432)

Der er benyttet et komma i udtrykket eller sætningen, hvor det ikke hører til, eller der mangler et komma til at adskille argumenter.


Der er brugt ugyldige argumenter i aggregatfunktionen. (Fejl 2428)

Du har angivet et ugyldigt argument i en aggregatfunktion. Oplysninger om funktionens argumenter finder du i SQL-aggregatfunktioner. Vælg derefter navnet på funktionen.


Der er en ugyldig Century-indstilling i Xbase-nøglen i Windows-registreringsdatabasen. (Fejl 3227)

Der er en ugyldig Century-indstilling i nøglen Xbase i Microsoft® Windows®-registreringsdatabasen.

Sådan retter du Century-indstillingen:

  1. Afslut programmet.
  2. Start Registreringseditor, flyt til nøglen \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase, og marker Century-værdien.
  3. Vælg Rediger i menuen Rediger.
  4. Ret Century-dataen i feltet "Værdidata".
  5. Genstart programmet, og forsøg derefter at udføre handlingen igen.


Den valgte CollatingSequence-indstilling understøttes ikke af operativsystemet. (Fejl 3228)

Der er en ugyldig CollatingSequence-indstilling i Paradox-nøglen i Microsoft® Windows®-registreringsdatabasen.

Sådan retter du CollatingSequence-indstillingen:

  1. Afslut programmet.
  2. Start Registreringseditor, flyt til nøglen \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox, og marker CollatingSequence-værdien.
  3. Vælg Rediger i menuen Rediger.
  4. Angiv enten ascii eller International i feltet "Værdidata".
  5. Genstart programmet, og forsøg derefter at udføre handlingen igen.


Det er en ulovlig begrænsning på kolonneniveau. (Fejl 3789)

Denne fejl opstår, når du bruger syntaksen CREATE TABLE eller ALTER TABLE ALTER COLUMN. Mens ANSI SQL tillader at oprette CHECK-begrænsninger som en del af tabeldefinitionen, kræver Microsoft® Jet, at brugeren opretter CHECK-begrænsningen adskilt fra COLUMN-definitionen. Dette er muligt ved at angive det reserverede ord CHECK efter et komma. Følgende synktaks vil f.eks. fungere, fordi CHECK-begrænsningen er defineret adskilt fra kolonnen og følger efter et komma:

CREATE TABLE Ordrer (Ordreid IDENTITY (100,10) CONSTRAINT pkOrdrer PRIMARY KEY, Kundeid LONG CONSTRAINT fkKunderKundeid REFERENCES Kunder (Kundeid), Balance DOUBLE, CONSTRAINT KundeOverskredetKreditGrænse CHECK (Kundeid IN (SELECT Kundeid FROM Kunder C WHERE C.Kundeid = Ordrer.Kundeid AND C.KreditGrænse >= (SELECT SUM(Balance)FROM Ordrer O WHERE O.Kundeid = Ordrer.Kundeid))));.


Der er en ugyldig DataCodePage-indstilling under initialiseringsindstillingen. (Fejl 3337)

DataCodePage-indstillingen til den eksterne datakilde, du forsøger at anvende, er ikke gyldig. Denne indstilling findes i den tilsvarende nøgle \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engine\<ekstern datakilde ISAM> i Microsoft® Windows®-registreringsdatabasen.

Følgende indstillinger er gyldige:

  • OEM – Data lagres som OEM-data. Der er foretaget OemToAnsi- og AnsiToOem-konverteringer.
  • OEM – Data lagres som ANSI-data. Der er foretages OemToAnsi- og AnsiToOem-konverteringer.


Der er en ugyldig Date-indstilling i Xbase-nøglen i Windows-registreringsdatabasen. (Fejl 3213)

Der er en ugyldig Date-indstilling i nøglen Xbase i Microsoft® Windows®-registreringsdatabasen.

Sådan retter du Date-indstillingen:

  1. Afslut programmet.
  2. Start Registreringseditor, flyt til nøglen \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase, og marker Date-værdien.
  3. Vælg Rediger i menuen Rediger.
  4. Ret Date-dataene i feltet "Værdidata".
  5. Genstart programmet, og forsøg derefter at udføre handlingen igen.


Der er en ugyldig Deleted-indstilling i Xbase-nøglen i Windows-registreringsdatabasen. (Fejl 3208)

Der er en ugyldig Deleted-indstilling i nøglen Xbase i Microsoft® Windows®-registreringsdatabasen.

Sådan retter du Deleted-indstillingen:

  1. Afslut programmet.
  2. Start Registreringseditor, flyt til nøglen \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase, og marker værdien Deleted.
  3. Vælg Rediger i menuen Rediger.
  4. Ret Deleted-dataene i feltet "Værdidata".
  5. Genstart programmet, og forsøg derefter at udføre handlingen igen.


Du har forsøgt at køre en forespørsel, der ikke medtager det angivne udtryk <navn> som en del af en aggregatfunktion. (Fejl 3122)

Du har forsøgt at køre en forespørsel, der ikke medtager det angivne udtryk som en del af en aggregatfunktion eller gruppering.

Mulig årsag:

  • Du har ikke angivet en aggregatfunktion i sætningen TRANSFORM.


Der er en ugyldig indstilling i Excel-nøglen i sektionen Engines i Windows-registreringsdatabasen. (Fejl 3433)

En af indstillingerne i nøglen \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Excel i Microsoft® Windows®-registreringsdatabasen er ugyldig. Rediger Windows Registreringseditor for at sikre, at alle parametrene er gyldige.


Der er en ugyldig Mark-indstilling i Xbase-nøglen i Windows-registreringsdatabasen. (Fejl 3214)

Der er en ugyldig Mark-indstilling i nøglen Xbase i Microsoft® Windows®-registreringsdatabasen.

Sådan retter du Mark-indstillingen:

  1. Afslut programmet.
  2. Start Registreringseditor, flyt til nøglen \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase, og marker Mark-værdien.
  3. Vælg Rediger i menuen Rediger.
  4. Ret Mark-dataene i feltet "Værdidata".
  5. Genstart programmet, og forsøg derefter at udføre handlingen igen.


Der er en ugyldig NetworkAccess-indstilling i Windows-registreringsdatabasen. (Fejl 3248)

Der er en ugyldig NetworkAccess-indstilling i Microsoft® Windows®-registreringsdatabasen.

Sådan gennemfører du denne handling:

  1. Afslut programmet.
  2. Start Registreringseditor, og flyt til NetworkAccess-værdien.

    Afhængigt af, hvilken installerbar ISAM du forsøger at anvende, er den ugyldige indtastning i nøglen \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase.

  3. Vælg Rediger i menuen Rediger.
  4. Angiv enten On eller Off i feltet "Værdidata".
  5. Genstart programmet, og forsøg derefter at udføre handlingen igen.


Handlingen er ugyldig. (Fejl 3219)

Mulige årsager:

  • Du har forsøgt at skrive til en skrivebeskyttet egenskab. Oplysninger om, hvorvidt egenskaben er med læse- og skriveadgang, finder du i Hjælp-indekset under den pågældende egenskab.
  • Du har forsøgt at benytte en metode eller egenskab til et Recordset-objekt af en type, som metoden eller egenskaben ikke gælder for. I emnet Oversigt over objektet Recordset finder du oplysninger om, hvilke metoder og egenskaber der gælder for et Recordset-objekt af en given type.
  • Du har forsøgt at tilføje en egenskab til en Properties-samling i et objekt, der ikke understøtter brugerdefinerede egenskaber.
  • Du har forsøgt at bruge metoden Update på et skrivebeskyttet Recordset-objekt.


Det er ikke muligt at åbne en formular, hvis underliggende forespørgsel indeholder en brugerdefineret funktion, der prøver på at angive eller hente formularens RecordsetClone-egenskab. (Fejl 3252)

Denne fejl kan opstå i Microsoft® Access, hvis du kører en forespørgsel, der medtager en brugerdefineret funktion i outputtet, og derefter opretter en formular på basis af den pågældende forespørgsel.


Der er en ugyldig reference i forespørgslen. (Fejl 3451)

Denne fejl opstår, når parametre defineres som ikke-genkendte datatyper.


Relationen kan ikke oprettes. (Fejl 3300)

Du forsøger at oprette en relation, der ikke er tilladt. Tabellerne kan f.eks. være i forskellige databaser.


Der blev forsøgt en ulovlig handling på en Jet SQL Server-replika. (Fejl 3777)

Mange handlinger kan ikke udføres fra Microsoft® Jet SQL-replikaer. Du kan f.eks. ikke slette eller omdøbe en tabel, tilføje, slette eller omdøbe en kolonne i en tabel, gøre en lokal tabel replikerbar, udveksle med en anden Jet Subscriber i Jet SQL-replikasættet eller udføre en udveksling med SQL Publication, hvis ikke du anvender direkte synkronisering.


Der er en ugyldig PageTimeout-indstilling i Windows-registreringsdatabasen. (Fejl 3249)

Der er en ugyldig PageTimeout -indstilling i Microsoft® Windows®-registreringsdatabasen.

Sådan gennemfører du denne handling:

  1. Afslut programmet.
  2. Start Registreringseditor, og flyt til PageTimeout-værdien.

    Afhængigt af, hvilken installerbar ISAM du forsøger at anvende, er den ugyldige indtastning i nøglen \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase.

  3. Vælg Rediger i menuen Rediger.
  4. Angiv den nye værdi i feltet "Værdidata".
  5. Genstart programmet, og forsøg derefter at udføre handlingen igen.


Den installerbare ISAM-version er ikke kompatibel. (Fejl 3429)

Du har forsøgt at anvende en ældre version af en installerbar ISAM sammen med den aktuelle version af Microsoft Jet-databasemotoren. Kør installationprogrammet igen for at installere den rette version af den installerbare ISAM.


Der er en syntaksfejl i forespørgslen. Forespørgslens delsætning er ikke komplet. (Fejl 3450)

Denne fejl opstår, når du forsøger at gemme en lagret forespørgsel (visning eller procedure).


Det aktuelle felt skal svare til joinnøglen <navn> i den tabel, der fungerer som en-siden af en en-til-mange-relation. (Fejl 3341)

Du har prøvet at indtaste en værdi i joinfeltet i mange-tabellen i forbindelse med en ydre joinforbindelse uden en tilsvarende værdi i joinfeltet i en-side-tabellen.

Meddelelsen indeholder følgende vejledning: Indtast en post i en-sidetabellen med den ønskede nøgleværdi, og foretag derefter indtastningen med det ønskede joinfelt i mange-tabellen.


Postlængden er for lang til en indekseret Paradox-tabel. (Fejl 3608)

En indekseret Paradox-tabel kan højst have en post på 1350 byte. Forsøg at reducere størrelsen på nogle felter af typen Text eller Memo.


Indekset findes allerede. (Fejl 3284)

Du kan ikke have to indeks med det samme navn i en tabel. Omdøb det ene indeks.


Paradox-indekset er ikke det primære. (Fejl 3288)

Du forsøger at oprette et indeks i en Paradox-tabel, der ikke er defineret andre indeks for. Det første indeks, du opretter i en Paradox-tabel, skal være et primæret indeks.

Mulige løsninger:

  • Omdefiner indekset til det primære indeks.
  • Hvis det indeks, du forsøger at oprette, ikke er det primære indeks, skal du oprette det primære indeks først.


Den primære nøgle findes allerede. (Fejl 3283)

Du forsøger at definere endnu en primær nøgle til denne tabel. Hver tabel kan kun have én primær nøgle. Fjern referencen til den anden primære nøgle.


Dette indeks eller denne tabel kan ikke slettes. Det er enten det aktuelle indeks, eller det bruges i en ralation. (Fejl 3281)

Dette indeks eller denne tabel kan ikke slettes. Det er enten det aktuelle indeks, eller det bruges i en relation. (Fejl 3281)

Hvis indekset eller tabellen bruges i en relation, skal du slette relationen, før du kan slette indekset eller tabellen. Hvis indekset er angivet som det aktuelle indeks ved hjælp af egenskaben Index, skal du angive egenskaben til et andet indeks, før du kan slette indekset.


Indeksdefinitionen er ugyldig. (Fejl 3285)

Mulige årsager:

Du bruger det samme felt to gange i et indeks eller i en relation, hvilket ikke er tilladt i Microsoft Jet-databasemotoren.

Du er ved at oprette en relation ved hjælp af felter med uoverensstemmende datatyper. I Microsoft® Jet-databaser kan du kun relatere felter, der indeholder identiske datatyper eller et AutoNumber-felt, der indeholder et Number-felt, der er angivet til Long Integer.


Indeksfilen blev ikke fundet. (Fejl 3015)

Du har forsøgt at benytte en værdi, der ikke er et indeks. Du kan fastslå gyldige indeksnavne ved at se i samlingen Indexes til objektet TableDef.


<Navn> er ikke et indeks i denne tabel. (Fejl 3800)

Du har brugt et ugyldigt indeksnavn, da du forsøgte at referere til et indeks.


.inf-filen er ugyldig. (Fejl 3168)

Du har forsøgt at få adgang til en dBASE-tabel, men den tilknyttede .inf-fil er ugyldig eller er blevet beskadiget. Sammenkæd tabellen igen, og kontroller, at du angiver de korrekte indeks.


Indeksfilen blev ikke fundet. (Fejl 3256)

Du har forsøgt at få adgang til en dBASE-tabel, men et af de indeks, der er anført i tabellens tilknyttede .inf-fil, kunne ikke findes. Indekset kan have fået et nyt navn, være blevet flyttet eller slettet. Du skal enten sammenkæde tabellen igen eller bruge Microsoft® Windows® Notesblok eller en anden teksteditor til at opdatere .inf-filen.


Microsoft Jet-databasemotoren kan ikke finde inputtabellen eller forespørslen <navn>. Sørg for, at den findes, og at navnet er stavet korrekt. (Fejl 3078)

Microsoft Jet-databasemotoren kan ikke finde inputtabellen eller forespørgslen <navn>. Kontroller, at den findes, og at navnet er stavet korrekt. (Fejl 3078)

Mulige årsager:

  • Den angivne tabel eller forespørgsel findes ikke.
  • Du har stavet tabel- eller forespørgselsnavnet forkert. Kontroller, om der mangler understregningstegn ( _ ) eller anden tegnsætning, og kontroller, at du ikke har indtastet foranstillede mellemrum.


Sætningen INSERT INTO indeholder følgende ukendte feltnavn: <feltnavn>. Sørg for, at du har skrevet navnet korrekt, og prøv at udføre handlingen igen.(Fejl 3127)

INSERT INTO-sætningen indeholder følgende ukendte feltnavn: <feltnavn>. Kontroller, at du har skrevet navnet korrekt, og forsøg derefter at udføre handlingen igen. (Fejl 3127)

Du har forsøgt at benytte en INSERT INTO-sætning sammen med det angivne feltnavn, men feltet findes ikke i outputtabellen. Kontroller, at du har skrevet navnet korrekt, og forsøg derefter at udføre handlingen igen.


Den installerbare ISAM blev ikke fundet. (Fejl 3170)

Der kunne ikke findes en fil med installerbar ISAM i DLL-biblioteket. Denne fil er nødvendig for at sammenkæde eksterne tabeller (andre end ODBC- eller Microsoft Jet-databasetabeller). Placeringen af alle ISAM-drivere vedligeholdes i Microsoft® Windows®-registreringsdatabasen. Disse angivelser oprettes automatisk, når du installerer programmet. Hvis du ændrer placeringen af disse drivere, skal du rette installationsprogrammet, så denne ændring afspejles, og foretage de korrekte angivelser i Registreringseditor.

Mulige årsager:

  • En indtastning i registreringsdatabasen er ikke gyldig. Denne fejl opstår f.eks., hvis du benytter en ekstern Paradox-database, og Paradox-angivelsen peger på et bibliotek eller en driver, der ikke findes. Afslut programmet, ret Registreringseditor, og prøv at udføre handlingen igen.
  • En af angivelserne i registreringsdatabasen peger på et netværksdrev, som ikke er tilsluttet netværket. Kontroller, at netværket er tilgængeligt, og forsøg derefter at udføre handlingen igen.


Der er ikke tilstrækkelig hukommelse til at fuldføre handlingen. (Fejl 3584)

Der er ikke tilstrækkelig hukommelse til at udføre handlingen. (Fejl 3584)

Computeren er løbet tør for hukommelse under forsøget på at replikere databasen. Luk andre programmer på computeren, og forsøg at udføre handlingen igen.


Posten kan ikke slettes eller ændres, fordi tabellen <navn> indeholder relaterede poster. (Fejl 3200)

Du har forsøgt at udføre en handling, der vil overtræde reglerne for referentiel integritet i forbindelse med relaterede tabeller. Denne fejl opstår, hvis du f.eks. forsøger at slette eller ændre en post i en-tabellen i en en-til-mange-relation, hvor der er relaterede poster i mange-tabellen.

Hvis du vil slette eller ændre posten, skal du først slette de relaterede poster fra mange-tabellen.


Du kan ikke tilføje eller ændre en post, fordi der kræves en relateret post i tabellen <navn>. (Fejl 3201)

Du har forsøgt at udføre en handling, der vil overtræde reglerne for referentiel integritet i forbindelse med relaterede tabeller. Denne fejl opstår, hvis du f.eks. forsøger at ændre eller indsætte en post i mange-tabellen i en en-til-mange-relation, og posten har ikke en relateret post i tabellen på en-siden.

Hvis du vil tilføje eller ændre posten, skal du først føje en post til den en-tabel, der indeholder samme værdi for det tilsvarende felt.


Reserveret fejl <element>. Der er ingen meddelelse til denne fejl. (Fejl 3000)

Der er opstået en uventet fejl. Den angivne programkode angiver de betingelser, denne fejl kan opstå under. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Internet-dll-filen (wininet.dll) blev ikke fundet eller indlæst. (Fejl 3674)

Wininet.dll blev ikke fundet i stien. Kør installationsprogrammet igen.


En Internet-funktion blev afbrudt. (Fejl 3742)

Internet-funktionen blev afbrudt, før den var udført. Forøg timeout-værdierne i registreringsdatabasen. Værdierne i registreringsdatabasen er lagret i: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Transporter.


Det lykkedes ikke at læse fra en Internet-handle. (Fejl 3675)

Det lykkedes ikke at læse fra en Internet-handle. Forsøg at udføre handlingen igen. (Fejl 3675)

Der opstod en Internet-fejl under læsning af en fil eller læsning af et svar fra en Internet-handling.


Det lykkedes ikke at skrive fra en Internet-handle. (Fejl 3676)

Det lykkedes ikke at skrive til en Internet-handle. Forsøg at udføre handlingen igen. (Fejl 3676)

Der opstod en Internet-fejl under skrivning til en fil.


Internettet er for langsomt. (Fejl 3650)

Enten er Internettet for langsomt, eller der er et problem i opsætningen af replikeringstyring på Internet-servercomputeren. (Fejl 3650)

Der er sket en fejl som følge af transmissionshastigheden på Internet.


Der opstod en fejl ved logon til Internettet. (Fejl 3652)

Serveren kan ikke genkende de logonoplysninger, du har indtastet.


Internet er ikke konfigureret. (Fejl 3653)

Der er et problem med installationen af Internet.


Fjernprogrammet Synchronizer er ikke konfigureret til fjernsynkronisering. (Fejl 3632)

Internet Transport er ikke aktiveret på Synchronizer-fjernprogrammet. (Fejl 3632)

Dette Synchronizer-fjernprogram er ikke konfigureret til at udføre fjernsynkronisering.


Handlingen understøttes ikke i transaktioner. (Fejl 3246)

Du har forsøgt at udføre en handling, der ikke er gyldig i en transaktion. En transaktion kan være en, du opretter ved hjælp af sætningen BeginTrans, eller en intern transaktion, der er oprettet af Microsoft Jet-databasemotoren, som når du sletter flere poster i en enkelt handling.


<Databasenavn> er ikke et gyldigt databasenavn. (Fejl 3030)

Det angivne kontonavn (brugernavn) er ikke gyldigt. Brugernavne kan bestå af 1-20 tegn, herunder alfabetiske tegn, tegn med accent, tal, mellemrum og symboler, med følgende undtagelser:

  • Tegnene " / \ [ ] | < > + = ; , : ? *
  • Foranstillede mellemrum
  • Kontroltegn

I brugernavne skelnes der ikke mellem store og små bogstaver.


Adressen for mappen med destinationsrullelisten er ugyldig. (Fejl 3557)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Det er ikke et gyldigt bogmærke. (Fejl 3159)

Du har forsøgt at angive et bogmærke til en ugyldig streng.

Denne fejl kan opstå, hvis du angiver egenskaben Bookmark til en streng, der er ugyldig eller ikke er gemt fra en tidligere læsning af egenskaben Bookmark. Denne fejl opstår f.eks. i følgende programkode:

Sub SetBookmark()

    Dim dbs As Database

    Dim rstEmployees As Recordset

    Dim strPlaceholder As String

    Set dbs = OpenDatabase("Northwind.mdb")

    Set rstEmployees = _

        dbs.OpenRecordset _

        ("Medarbejdere", dbOpenDynaset)

    strPlaceholder = "1"

    rstEmployees.Bookmark = strPlaceholder    ' Ikke et gyldigt bogmærke.

End Sub


Feltet er for kort til den mængde data, du forsøger at tilføje. Prøv at indsætte færre data. (Fejl 3163)

Det felt, du har forsøgt at indsætte data i, er ikke stort nok til at indeholde dataene. Forsøg at indsætte færre data.


Feltnavnet <navn> er ugyldigt i definitionen af et indeks eller en relation. (Fejl 3409)

Feltnavnet <navn> er ugyldig i definitionen af et indeks eller en relation. (Fejl 3409)

Mulige årsager:

  • Det feltnavn, du har angivet, kan være stavet forkert. Du skal undersøge, om feltnavnet indeholder stavefejl.
  • Den felttype, du anvender, er et felt af typen Memo eller et OLE-objekt, der ikke kan indekseres.


Feltdatatypen er ugyldig. (Fejl 3259)

Den datatype, der er angivet i egenskaben Type til objektet Field er ikke gyldig. Vælg en af de gyldige typer, der er vist i Hjælp-emnet til egenskaben Type.


Der blev ikke fundet en landekode i tilslutningsstrengen. (Fejl 3449)

Der blev ikke fundet en landekode i tilslutningsstrengen.


Biblioteksdatabasen <navn> kan ikke åbnes. Det er måske ikke en database, som programmet genkender, eller filen kan være beskadiget. (Fejl 3049)

Mulige årsager:

  • Du har forsøgt at åbne en ikke-Microsoft Jet-database, f.eks. en Btrieve-, dBASE- eller Paradox-database eller -tabel. Sammenkæd i stedet for databasen eller tabellen til en eksisterende Microsoft® Jet-database.
  • Du har forsøgt at importere eller sammenkæde en Paradox-database eller -tabel, og den tilknyttede .px-fil kunne ikke findes. Kontroller, at .px-filen findes i samme bibliotek som Paradox-databasen eller -tabellen, og forsøg derefter at udføre handlingen igen.
  • Hvis den angivne database er en Microsoft Jet-database, er den beskadiget. Du skal forsøge at reparere databasen. Hvis databasen ikke kan repareres, skal du gendanne den fra en sikkerhedskopi, eller oprette en ny database.


Databaseobjektreferencen er ugyldig. (Fejl 3276)

Det angivne Database-objekt er ikke resultatet af metoden OpenDatabase, eller det er blevet redigeret og er ikke længere gyldigt.


Databaseformatet <filnavn> kan ikke genkendes. (Fejl 3343)

Mulige årsager:

  • Det angivne filnavn er ikke en Microsoft Jet-database.
  • Det angivne filnavn er et navnet på en enhed, såsom en printer eller en konsol.
  • .mdb-filen indeholder ugyldige headeroplysninger eller en ukendt sorteringsrækkefølge.
  • Du venter på en bekræftelse fra en anden bruger, men låsefilen kan ikke findes.
  • Mens du foretager en bekræftelse, forsøger du at skrive en værdi af typen Long, der er større end den maksimale side- størrelse på 2KB.
  • Databasen er beskadiget. Komprimer databasen, og prøv derefter at åbne den igen.


Datadefinitionssætninger kan ikke udføres på sammenkædede datakilder. (Fejl 3611)

Microsoft Jet-databasemotoren kan ikke oprette et indeks i en sammenkædet ISAM-tabel eller i en ODBC-tabel, der allerede har et entydigt indeks.


Stien til mappen med destinationsrullelisten er ugyldig. (Fejl 3556)

Stien til mappen til destinationsrullelisten er ugyldig. (Fejl 3556)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Den angivne adgangskode til mappen med rullelisten <navn> er ugyldig. (Fejl 3483)

Hvis du vil angive adgangskoden, skal du starte Replikastyring. Vælg Konfigurer Microsoft Replikastyring i menuen Funktioner, og skriv adgangskoden til rullelistemappen igen.


Stien <navn> til rullelisten er ugyldig. (Fejl 3476)

Sørg for, at stien til rullelisten er korrekt.

Åbn Replikastyring, gå til menuen Funktioner, og vælg Konfigurer Microsoft Replikastyring. Eller kør installationsprogrammet til det program, der anvender replikering.


Det er ikke et gyldigt filnavn. (Fejl 3055)

Du har forsøgt at bruge et filnavn, der ikke følger navngivningskonventionerne til operativsystemet. Skriv filnavnet igen, og forsøg derefter at udføre handlingen igen.


Filterudtrykket til den delvise replika er ugyldigt. (Fejl 3482)

Egenskaben ReplicaFilter er angivet til en ugyldig streng.


Relationen <navn> i det delvise filterudtryk er ugyldig. (Fejl 3480)

Angiv en gyldig relation.


GUID er ikke tilladt i kriterieudtrykket til metoden Find. (Fejl 3614)

Kriterieudtrykket i en Find-metode kan ikke referere til en GUID.


HTTP-adressen er ugyldig. (Fejl 3685)

Den angivne HTTP-adresse er ikke gyldig til dette replikasæt. Den angivne HTTP-adresse svarer ikke til værdierne i feltet InternetAddress i systemtabellen MSysTranspAddress.


Forespørgslen <navn> kan ikke bruges i en CHECK CONSTRAINT-delsætning. (Fejl 3801)

Denne fejl opstår, når du bruger syntaksen CREATE TABLE eller ALTER TABLE ALTER COLUMN og bruger CHECK CONSTRAINT-delsætningen. Fejlen opstår, når en CHECK-begrænsning forsøger at referere til en tilknyttet/sammenkædet tabel, en visnings- eller procedureforespørgsel eller en lagret forespørgsel.


Internet-adressen er ugyldig. (Fejl 3651)

Du har anmodet om en Internet-adresse, der ikke er gyldig eller tilgængelig. Kontroller adressen, og forsøg igen, hvis den er gyldig.


Databasen kan ikke oprettes, fordi landestandarden er ugyldig. (Fejl 3424)

Der er angivet en ugyldig landestandard-parameter. Sørg for at anvende en gyldig DAO-konstant (Data Access Objects) til at angive parameteren landestandard.


Det er ikke et gyldigt kontonavn eller en gyldig adgangskode. (Fejl 3029)

Du har skrevet et ugyldigt kontonavn (brugernavn) eller en ugyldig adgangskode.

Brugernavne

Brugernavne kan bestå af 1-20 tegn, herunder alfabetiske tegn, tegn med accent, tal, mellemrum og symboler, med følgende undtagelser:

  • Tegnene " / \ [ ] | < > + = ; , : ? *
  • Foranstillede mellemrum
  • Kontroltegn

I brugernavne skelnes der ikke mellem store og små bogstaver.

Adgangskoder

Adgangskoder kan være en vilkårlig kombination af 14 eller færre tegn. Adgangskoder kan ikke indeholde styretegn. I adgangskoder skelnes der mellem store og små bogstaver.


Dette er ikke et gyldigt navn. Sørg for, at der ikke indeholder ugyldige tegn eller tegnsætning, og at navnet ikke er for langt. (Fejl 3125)

<Navn> er ikke er gyldigt navn. Sørg for, at det ikke indeholder ugyldige tegn eller tegnsætning, og at navnet ikke er for langt. (Fejl 3125)

Det angivne navn følger ikke standardnavngivningskonventioner, eller det er ikke et gyldigt parameter- eller alias- navn. Kontroller indtastningen for at sikre, at du ikke har medtaget ugyldige tegn eller ugyldig tegnsætning, og at navnet ikke er for langt.


Objektet er ugyldigt til handlingen. (Fejl 3350)

Du har anvendt metoden RefreshLink på et andet objekt end en sammenkædet tabel. Et objekt ophører med at eksistere, når det ødelægges, og når det tilknyttede DAO-objekt lukkes eller ikke længere defineres i det aktuelle virkefelt.


Denne handling kan ikke udføres. (Fejl 3032)

Mulige årsager:

  • Du har forsøgt at slette den eneste brugerkonto i gruppen Administrator. I gruppen Administrator skal der være mindst én brugerkonto. Hvis du vil slette denne konto, skal du oprette en ny konto og tilføje den til gruppen Administrator eller tilføje en eksisterende konto til gruppen Administrator og derefter slette kontoen.
  • Du har forsøgt at tilføje en bruger til en gruppe, som brugeren allerede tilhører, ved enten at føje et Group-objekt til et User-objekts Groups-samling, der allerede har et Group-objekt med samme navn eller et User-objekt til et Group-objekts Users-samling, der allerede har et User-objekt med samme navn.


Argumentet er ugyldigt. (Fejl 3001)

Du har forsøgt at udføre en handling, der indebærer en rutine i et DLL-bibliotek (Dynamic Link Library), og et af argumenterne til rutinen er ugyldigt. Kontroller indtastningen for at sikre dig, at du har angivet de rette argumenter, og forsøg derefter at udføre handlingen igen.

Denne fejl opstår også, hvis du i et argument til en metode forsøger at benytte konstanter, der gensidigt udelukker hinanden, f.eks. at angive både dbConsistent og dbInconsistent i argumentet indstillinger til metoden OpenRecordset.


Det er ikke en gyldig adgangskode. (Fejl 3031)

Du har indtastet en ugyldig adgangskode. Adgangskoder kan være en vilkårlig kombination af 14 eller færre tegn undtagen kontroltegn. I adgangskoder skelnes der mellem store og små bogstaver.


<Sti> er ikke en gyldig sti. Kontroller, at stinavnet er stavet korrekt, og at du er tilsluttet den server, hvor filen findes. (Fejl 3044)

Mulige årsager:

  • Du har angivet en ugyldig filspecifikation, der indeholder en ugyldig sti. Du kan f.eks. have angivet en sti, der ikke findes, eller stavet et element i stispecifikationen forkert.
  • Den angivne fil findes på et netværksdrev, men du er ikke tilsluttet netværket. Kontroller, at netværket er tilgængeligt, og forsøg derefter at udføre handlingen igen.


Du skal indtaste et personligt id (PID), der består af mindst 4 og højst 20 tegn og cifre. (Fejl 3304)

Du skal indtaste et personligt id (PID), der består af mindst fire og højst 20 tegn og cifre. (Fejl 3304)

Et personligt id (PID) skal bestå af mindst fire tegn og højst 20 tegn.


Præcisionen for decimal datatypen er ugyldig. (Fejl 3700)

Præcisionen og skalaen for en DECIMAL-datatype skal være mellem 0 og 28. Følgende SQL-sætning returnerer f.eks. denne fejl: CREATE TABLE foo (foo DECIMAL(38,0));


Replikastien eller -navnet er ugyldigt. (Fejl 3686)

Den synchronizer, der identificeres af HTTP-adressen, styrer ikke det databasenavn, der er angivet i URL-adressen.


Skalaen for decimal datatypen er ugyldig. (Fejl 3701)

Skalaen for en DECIMAL-datatype skal altid være mindre end eller lig med præcisionen. Følgende SQL-sætning returnerer f.eks. denne fejl: CREATE TABLE foo (foo DECIMAL(10,12));


Databaseobjektreferencen er ugyldig. (Fejl 3263)

Databaseobjektet er ugyldigt. (Fejl 3263)

Det angivne Database-objekt er ikke resultatet af metoden OpenDatabase, eller det er blevet redigeret og er ikke længere gyldigt.


Tabelnavnet <navn> i det delvise filterudtryk er ugyldigt. (Fejl 3481)

Sørg for at bruge det korrekte tabelnavn i udtrykket.


Tabelnavnet i filteret er ugyldigt. (Fejl 3631)

Du har refereret til en tabel i et boolesk filter, der ikke er gyldigt. Booleske filtre kan kun referere til den tabel, der filtreres.


Argumentet TOP i en udvælgelsesforespørgsel er ugyldigt. (Fejl 3308)

Der er en ugyldig parameter i TOP-delsætningen i en SELECT-sætning. Den værdi, der er placeret efter det reserverede ord TOP, skal være et positivt heltal. Hvis det reserverede ord PERCENT også anvendes, kan heltallet ikke være større end 100.


Synchronizer-id'et passer ikke til et eksisterende id i tabellen MSysTranspAddress. (Fejl 3504)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Replika af en Jet SQL-replika kan ikke oprettes. (Fejl 3753)

En Microsoft® Jet SQL-replika understøtter en hub/spoke-topologi, hvor SQL Publication er hub og Jet Subscriber er spoke. Hvis du ønsker flere Jet-replika, kan du oprette en ekstra Push/Pull Subscription fra SQL Publication.


Joinudtrykket understøttes ikke. (Fejl 3296)

Mulige årsager:

  • SQL-sætningen indeholder flere joinforbindelser, hvorved resultatet af forespørgslen kan variere afhængigt af den rækkefølge, joinforbindelserne udføres i. Du kan eventuelt oprette en separat forespørgsel, der udfører den første joinforbindelse, og derefter medtage den pågældende forespørgsel i SQL-sætningen.
  • Sætningen ON i JOIN-handlingen er ikke komplet eller indeholder for mange tabeller. Du angive udtrykket ON i en WHERE-delsætning.


Joinnøgle. (Fejl 3348)

Der kan ikke tilføjes poster. Joinnøglen til tabellen <navn> er ikke i resultatsættet. (Fejl 3348)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Den joinforbundne tabel <navn> er ikke medtaget i FROM-delsætningen. (Fejl 3080)

Føj det angivne tabelnavn til delsætningen FROM i forespørgslen, og forsøg derefter at udføre handlingen igen.


Denne egenskab understøttes ikke i forbindelse med eksterne datakilder eller databaser, der er oprettet med en tidligere version af Microsoft Jet. (Fejl 3310)

Du har forsøgt at angive eller undersøge en egenskab, der ikke er tilgængelig i forbindelse med dette objekt i en database, der er lagret i en Microsoft® Jet-database version 1.x, 2.x eller i en ekstern datakilde. Søg efter objektet i Hjælp, og vis derefter resumeemnet til objektet for at se en liste over gyldige egenskaber.


Egenskaben KeepLocal kan ikke angives for en database. Den kan kun angives for objekter i en database. (Fejl 3458)

Egenskaben KeepLocal er angivet til "T" for objekter i en database, som du ikke ønsker skal replikeres. Du kan ikke angive denne egenskab for hele databasen.


De ønskede ændringer til tabellen blev ikke gennemført, fordi de vil oprette dublerede værdier i indekset, den primære nøgle eller relationen. (Fejl 3022)

Du har forsøgt at duplikere en værdi i et felt, der er den underliggende tabels primære nøgle eller et indeks, der ikke tillader dubletter.

Meddelelsen indeholder følgende instruktion: Skift dataene i det eller de felter, der indeholder dublerede data, fjern indekset, eller omdefiner indekset, så dublerede indgange tillades, og forsøg igen.


Handlingen understøttes ikke i sammenkædede tabeller. (Fejl 3057)

Importer data fra tabellen, og forsøg derefter at udføre handlingen igen.


Lokale og anonyme replikaer skal kun synkronisere til deres angivne hub-replika. (Fejl 3738)

Kilde- replikaen er en lokal eller anonym replika. Du forsøger at udveksle til den forkerte hub-replika. Du kan kun synkronisere en lokal eller anonym replika med den globale replika, den er oprettet af.


Tabellen er låst. (Fejl 3714)

Tabellen er låst. Denne post kunne ikke anvendes under synkroniseringen, da tabellen var låst af en anden bruger. Send denne konfliktpost igen. (Fejl 3714)

Synkroniser replikaene igen, når låsen frigives på tabellen.


Disken er fuld for stien <navn>. (Fejl 3472)

Fjern filer fra diskdrevet for at frigive plads.


Stien til logfilen <stinavn> er ugyldig. (Fejl 3591)

Kontroller, at filen har den placering, der er angivet i Logfile-værdien til nøglen \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Transporter i Microsoft® Windows®-registreringsdatabasen, eller konfigurer Synchronizer-programmet på computeren igen.

Sådan konfigureres Synchronizer

  1. Start Replikastyring.
  2. Vælg Konfigurer Microsoft Replikastyring i menuen Funktioner.
  3. Følg instruktionerne i guiden.


Det bibliotek, hvor du har forespurgt efter en liste over replikaer, er ikke et styret bibliotek. (Fejl 3573)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Tabellen <navn> kan ikke replikeres på grund af for mange kolonner. (Fejl 3705)

Tabellen kan ikke replikeres, da systemkolonner til replikering ikke kan tilføjes. Hvis disse kolonner tilføjes, overskrides grænsen for kolonner. Reducer antallet af kolonner i tabellen, før du gør den replikerbar.


Tabellen <navn> kan ikke replikeres på grund af for mange indeks. (Fejl 3706)

Tabellen kan ikke replikeres, da systemindeks til replikering ikke kan tilføjes. Hvis disse indeks tilføjes, overskrides grænsen for det maksimale antal indeks.


MAPI-mappen eller -adressekartoteket blev ikke fundet. (Fejl 3710)

Microsoft® Outlook/Exchange-driveren kunne ikke finde den anmodede mappe eller det anmodede adressekartotek.

  • Kontroller, at du har adgang og tilladelser til det MAPI-lager, hvor mappen eller adressekartoteket opbevares.
  • Kontroller, at tilslutningsoplysningerne ikke er specifikke for placeringen, såsom drevtilslutninger på en anden maskine.
  • Kontroller, at navnet på mappen eller adressekartoteket er stavet korrekt.


Et indeks kunne ikke oprettes på denne MAPI-mappe/adressebog. (Fejl 3788)

Mange Microsoft® Outlook/Exchange-mapper og -adressebøger er systemkomponenter, der ikke kan redigeres på nogen måde. Denne fejlmeddelelse angiver, at du forsøgte at oprette et indeks på et objekt, f.eks. en global adresseliste eller en offentlig mappe, som du ikke har adgang til.


Der er ikke mere hukommelse til at fuldføre beregningen. (Fejl 2446)

Programmet har ikke tilstrækkelig hukommelse til at foretage beregningen. Sørg for, at der er tilstrækkelig RAM, og at der er oprettet en virtuel swapfil. Det kan være nødvendigt at afslutte andre programmer, fjerne tapetbitmaps til skrivebordet eller fjerne unødvendige enhedsdrivere for at gendanne tilstrækkelig hukommelse.


Der er en delingsfejl i mappen til kilderullelisten, fordi meddelelsesdatabasen er åben i et andet program. (Fejl 3565)

Luk meddelelsesdatabasen. Brugere må ikke åbne meddelelsesdatabasen direkte.


Meddelelsen i mappen til rullelisten tilhører den forkerte Synchronizer. (Fejl 3567)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Den ønskede Xbase memo-fil kan ikke findes. (Fejl 3166)

Den ønskede Xbase memo-fil kan findes. (Fejl 3166)

Du har forsøgt at få adgang til en dBASE-fil (.dbf), men filens tilknyttede Memo-fil (.dbt) kunne ikke findes. Kontroller, at .dbt-filen findes i det samme bibliotek som .dbf-filen, og forsøg derefter at udføre handlingen igen.


Der er en syntaksfejl, fordi der mangler en operator. (Fejl 2431)

Udtrykket eller sætningen mangler en operator.


Der er en syntaksfejl, fordi der mangler en operator. (Fejl 2434)

Udtrykket eller sætningen mangler en operator.


Der mangler en ), ] eller et element. (Fejl 2436)

Du har indtastet et udtryk, der mangler en højreparentes, en kantet parentes eller en lodret streg (|). Kontroller udtrykket for at sikre, at du har indtastet det korrekt.


Flere NULL, NOT NULL-attributter kan ikke indstilles. (Fejl 3806)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Elementet blev ikke fundet i denne samling. (Fejl 3265)

Du har forsøgt at referere til et navn i en samling, men det mislykkedes.

Mulige årsager:

  • Objektet findes ikke i denne samling. Kontroller, at objektet er føjet til en samling, før du refererer til det.
  • Der er mere end ét objekt med det samme navn i samlingen. Navnet er en tvetydig reference. Referer til objektet ud fra dets placering i rækken i samlingen, f.eks. Recordsets(3).


Databasesystemformatet skal være version 4.x eller nyere for at kunne udføre denne handling. (Fejl 3808)

Når du bruger Microsoft® OLE DB Provider til Jet med sikkerhed, skal sikkerhedsdatabasen være i et Jet version 4.x-filformat. Dette er muligt ved at komprimere den eksisterende sikkerhedsdatabase eller oprette en ny gennem Microsoft OLE DB Provider til Jet.


<Tabelnavn> kan ikke åbnes. En anden bruger har åbnet tabellen med en anden netværksstyrefil eller låseteknik. (Fejl 3418)

Microsoft Jet-databasemotoren kan ikke åbne en ekstern Paradox-tabel på grund af uoverensstemmelse mellem dine initialiseringsindstillinger og indstillingerne hos en anden bruger, der aktuelt har tabellen åben. Indstillingerne ParadoxNetPath og ParadoxNetStyle i nøglen \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox i Microsoft® Windows®-registreringsdatabasen skal være de samme for alle brugere, der deler en database. Sørg for, at dine initialiseringsindstillinger svarer til indstillingerne hos alle andre brugere, der deler databasen, og forsøg derefter at åbne tabellen igen.


Der opstod en I/O-fejl på netværket. (Fejl 3566)

Der opstod et problem i kommunikationen mellem computeren og netværket. Kontroller, at netværket fungerer korrekt, og at netværkskablet er korrekt forbundet til computeren. Luk, sluk, og genstart computeren.


En ny replika kan ikke oprettes, fordi <navn>-objektet i objektbeholderen <navn> ikke kunne gøres replikerbar. (Fejl 3582)

Databasen kunne ikke gøres replikerbar, fordi det angivne objekt ikke kunne replikeres. Hvis det maksimale antal tilladte indeks overskrides i en tabel, kan tabellen f.eks. ikke replikeres. Hvis du vil forhindre denne fejl i at opstå, skal du, før du gør databasen replikerbar, sikre, at objekterne i databasen overholder replikeringskravene.


Denne handling kan ikke udføres, fordi der ikke er en aktiv forbindelse. (Fejl 3668)

Følgende handling kunne ikke udføres uden en åben tilslutning i objektet. Åbn en tilslutning, og forsøg derefter at udføre handlingen igen.


Der findes ingen aktiv transport til Synchronizer. (Fejl 3508)

Du skal konfigurere Replikastyring igen.

Sådan konfigureres Synchronizer

  1. Start Replikastyring.
  2. Vælg Konfigurer Microsoft Replikastyring i menuen Funktioner.
  3. Følg instruktionerne i guiden.


Strenge af længden nul er kun gyldige i et felt af typen Text eller Memo. (Fejl 3415)

Du forsøger at indtaste en streng af længden nul i et felt, der har en anden datatype end Text eller Memo. Du kan måske i stedet indtaste en Null-værdi.


Netværksstien eller brugernavnet blev ikke fundet. (Fejl 3171)

En eller flere angivelser i nøglen \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox i Microsoft® Windows®-registreringsdatabasen er ugyldige. Ret de ugyldige angivelser, og forsøg derefter at udføre handlingen igen.


CHECK-begrænsninger på tabellen <navn> overføres ikke til denne tabel. CHECK-begrænsninger kan kun oprettes via SQL DLL-sætninger. (Fejl 3805)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Handlingen er ugyldig uden et aktuelt indeks. (Fejl 3019)

Angiv Index, og forsøg derefter at udføre handlingen igen.


Der er ingen aktuel post. (Fejl 3021)

Denne fejl opstår, efter at du uden held har forsøgt at benytte en af Find-metoderne eller metoden Seek, når det underliggende Recordset ikke indeholder poster, eller posten er slettet. Flyt til eller marker en anden post, og forsøg at udføre handlingen igen. Hvis Recordset er tomt, kan du ikke flytte til en aktuel post. Kontroller egenskaberne BOF og EOF.


Der er ikke angivet en database i tilslutningsstrengen eller IN-delsætningen. (Fejl 3321)

Microsoft Jet-databasemotoren kan ikke tilsluttes til en ekstern ISAM-database, da du ikke har angivet navnet på den database, den skal tilsluttes. Når du tilslutter til en ekstern datakilde, skal du angive et databasenavn.

Mulige årsager:

  • Tilslutningsstrengen i FROM-delsætningen i SELECT-sætningen mangler parameteren DATABASE=.
  • IN-delsætningen i SELECT-sætningen medtager et databasetypeargument, der angiver, hvordan data vælges fra en ekstern database, men den mangler et databasenavneargument.


Synchronizer kunne ikke finde planlagte eller anmodede synkroniseringer, der skal behandles. (Fejl 3514)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Der er ikke et indeks i GUID-kolonnen. (Fejl 3550)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Der mangler et destinationsfeltnavn i INSERT INTO-sætningen <sætning>. (Fejl 3352)

Der er intet destinationsfeltnavn i INSERT INTO-sætningen <sætning>. (Fejl 3352)

Destinationsfelt- navnet eller -navnene kan ikke bestemmes ud fra udtrykket i delsætningen SELECT i sætningen INSERT INTO.


Registreringsdatabasen til Synchronizer har ingen værdi angivet for den anmodede nøgle. (Fejl 3503)

Du skal konfigurere Synchronizer på computeren.

Sådan konfigureres Synchronizer

  1. Start Replikastyring.
  2. Vælg Konfigurer Microsoft Replikastyring i menuen Funktioner.
  3. Følg instruktionerne i guiden.


Der er ingen MAPI-klienter installeret på denne maskine. Installer en MAPI-klient, f.eks. Outlook, på maskinen. (Fejl 3804)

Microsoft® Outlook/Exchange IISAM bruger Messaging API (MAPI) til at hente mappe- eller adressebogsoplysninger. Hvis du vil have MAPI på maskinen, skal du installere en af de Microsoft e-mail-klienter, der bruger MAPI, f.eks. Outlook Client, Outlook Express eller Exchange Client. Outlook/Exchange IISAM kan ikke fungere, før du gør dette.


Ingen af importfeltnavnene passer til felterne i den tilføjede tabel. (Fejl 3243)

Mindst ét feltnavn i importtabellen og den tilføjede tabel skal stemme overens.


Synchronizer kunne ikke finde meddelelser, der skal behandles. (Fejl 3517)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Der kan ikke åbnes flere tabeller eller forespørgsler. (Fejl 3037)

Du har nået grænsen for, hvor mange tabeller og forespørgsler der kan være åbne samtidigt. Luk en eller flere tabeller eller forespørgsler, og forsøg derefter at udføre handlingen igen.


Der er ikke flere MS-DOS-filhandles. (Fejl 3042)

Du skal enten lukke nogle filer, lukke andre programmer eller forøge antallet af tilgængelige MS-DOS-filhandles.

Sådan forøges antallet af filhandles

  1. Rediger filen CONFIG.sys ved hjælp af Microsoft® Windows® Notesblok eller en anden teksteditor. Filen CONFIG.sys findes normalt i rodbiblioteket på startdrevet. Hvis du ikke har en CONFIG.sys-fil på systemet, skal du oprette én, der indeholder den linje, der et anført i trin 2.
  2. Se efter den linje, der hedder FILES = x, hvor x er et tal. Forøg det tal, der er angivet af kommandoen FILES. Det præcise antal handles, du angiver, afhænger af de programmer, du kører, og det antal filer, der er åbne på et givet tidspunkt. Hvis andre programmer åbner flere filer, kan du være nødt til at angive flere filhandles.

    Når du forøger antallet af filhandles, skal du huske på, at der ved hvert handle bruges mere hukommelse. Yderligere oplysninger finder du i håndbogen til operativsystemet.

  3. Afslut Microsoft Windows.
  4. Genstart systemet, og forsøg derefter at udføre handlingen igen.


Tabellen 'MSysAccounts' i arbejdsgruppeoplysningsfilen kan ikke åbnes. (Fejl 3173)

Til denne handling skal du bruge filen System.mdw, som indeholder sikkerheds- og indstillingsangivelser til tabeller i Microsoft Jet-databasen.

Mulige årsager:

  • SystemDB-værdien i nøglen \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Access\Jet\4.0\Engines\Jet i Microsoft® Windows®-registreringsdatabasen peger på et netværksdrev, som du ikke er tilsluttet. Kontroller, at netværksdrevet er tilgængeligt, og forsøg derefter at udføre handlingen igen.
  • Filen System.mdw er beskadiget. Hvis du har en sikkerhedskopi af System.mdw, skal du kopiere den til den placering, der er angivet i SystemDB-angivelsen i registreringsdatabasen.


Tabellen 'MSysGroups' i arbejdsgruppeoplysningsfilen kan ikke åbnes. (Fejl 3174)

Til denne handling skal du bruge filen System.mdw, som indeholder sikkerheds- og indstillingsangivelser til tabeller i Microsoft Jet-databasen.

Mulige årsager:

  • SystemDB-værdien i nøglen \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Access\Jet\4.0\Engines\Jet i Microsoft® Windows®-registreringsdatabasen peger på et netværksdrev, som du ikke er tilsluttet. Kontroller, at netværksdrevet er tilgængeligt, og forsøg derefter at udføre handlingen igen.
  • Filen System.mdw er beskadiget. Hvis du har en sikkerhedskopi af System.mdw, skal du kopiere den til den placering, der er angivet i SystemDB-angivelsen i registreringsdatabasen.


Der er ingen nye data at læse for Synchronizer eller Replikastyring i den delte hukommelse. (Fejl 3528)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Der er ingen planlagte synkroniseringer mellem de to Synchronizer-programmer. (Fejl 3495)

Tidsplanen mellem to Synchronizer-programmer er slettet, eller du forsøger at angive en tidsplan mellem Synchronizer på din computer og selve Synchronizer. Brug Replikastyring til at angive tidsplanen med den rette Synchronizer.


Der mangler et destinationsfeltnavn i SELECT INTO-sætningen <sætning>. (Fejl 3105)

Skriv et destinationsfelt- navn i den angivne sætning, og forsøg derefter at udføre handlingen igen.


Fast bredde-specifikationen <navn> indeholder ingen kolonnebredder. (Fejl 3443)

Parameteren med fast bredde, der er angivet i tekstfilspecifikationen til Tekst ISAM, er ugyldig, fordi den ikke angiver en kolonnebredde. Specifikationen kan angives på flere måder:

  • Fra Microsoft® Access angives disse værdier i guiden Sammenkæd Tekst, som du kan bruge ved at pege på Hent eksterne data i menuen Filer og derefter vælge Sammenkæd tabeller.
  • Fra andre værtsprogrammer i Microsoft Jet lagres disse værdier i filen Schema.ini.


Tekstfilspecifikationen <navn> findes ikke. Du kan ikke importere, eksportere eller sammenkæde med denne specifikation. (Fejl 3625)

Microsoft® Access forsøgte at importere/eksportere/sammenkæde til en tekstfil med et specifikationstabelnavn, der ikke findes i databasens MSysIMEXSpecs-tabel. Gendan kæden ved at bruge en gyldig specifikationstabel.


Den værdi, der er angivet, er ikke et replika-id for noget medlem i replikasættet. (Fejl 3488)

Den værdi, der er angivet, er ikke et ReplicaID for noget medlem i replikasættet. (Fejl 3488)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Synchronizer kunne ikke finde en replika fra det korrekte sæt til at afslutte synkroniseringen. (Fejl 3547)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


En ekstern tabel er ikke i det ventede format. (Fejl 3274)

Tabellens format er blevet ændret, siden den blev sammenkædet. Sammenkæd tabellen igen, og forsøg derefter at udføre handlingen igen.


Tabellen eller forespørgslen kunne ikke importeres. Der blev ikke fundet poster, eller alle posterne indeholder fejl. (Fejl 3297)

Microsoft Jet-databasemotoren kunne ikke finde den tabel eller forespørgsel, du har forsøgt at importere, eller ingen poster i den angivne kilde blev fundet, eller alle posterne indeholdt fejl. Kontroller den sti, du har angivet, og prøv igen.


Microsoft Jet-databasemotoren er ikke blevet initialiseret. (Fejl 3278)

Databasemotoren kan ikke initialiseres.

Mulige årsager:

  • Der er en konflikt med et andet program, der bruger Microsoft Jet-databasemotoren. Afslut alle andre programmer, og start derefter programmet igen.
  • Der er opstået en fejl i forbindelse med installationen. Geninstaller programmet.


Du forsøgte at bekræfte eller annullere en transaktion uden først at starte en transaktion. (Fejl 3034)

Du forsøgte at bekræfte eller annullere en transaktion, der ikke var startet med en BeginTrans-sætning.


Den bundne FoxPro 3.0-DBF-fil <filnavn> kan ikke åbnes. (Fejl 3623)

Du har forsøgt at åbne en bundet .dbf-fil i Microsoft ® FoxPro® version 3.0. Bundne filer kan kun åbnes gennem den FoxPro-databaseobjektbeholder, de er bundet til.


Der mangler et destinationsfeltnavn i UPDATE-sætningen <sætning>. (Fejl 3106)

Skriv et destinationsfelt- navn i den angivne sætning, og forsøg derefter at udføre handlingen igen.


Objektet har ingen værdi. (Fejl 2427)

Du har indtastet et udtryk, der indeholder et ID til et objekt, som ikke har nogen værdi. Objekter kan have en standardegenskab- sværdi eller returnere en standard- metode.

Kontroller udtrykket for at sikre, at du har indtastet det korrekt.


Feltet <navn> kan ikke angives i en joinnøgle til Null. (Fejl 3100)

Du har en joinforbindelse, og du har forsøgt at angive et felt på den ene eller anden side af joinforbindelsen til en Null-værdi. Du skal enten markere andre felter eller indtaste data i felterne og derefter forsøge at udføre handlingen igen.


Du har forsøgt at tildele Null-værdien til en variabel, der ikke er af datatypen Variant. (Fejl 3162)

Du har forsøgt at tildele Null-værdien til en variabel, der ikke er af datatypen Variant. Brug sætningen Dim til at erklære variablen som en Variant, og forsøg derefter at udføre handlingen igen.


Et indeks eller en primær nøgle kan ikke indeholde en Null-værdi. (Fejl 3058)

Mulige årsager:

  • Du har forsøgt at føje en Null-værdi til et primært nøgle-felt.
  • Du har forsøgt at tilføje en ny post, men ikke indtastet en værdi i det felt, der indeholder den primære nøgle.
  • Du har kørt en forespørgsel, der forsøgte at angive en Null-værdi i et primær nøgle-felt.


Antallet af angivne aliaser skal være det samme som antallet af outputkolonner. (Fejl 3731)

Denne fejl opstår, når du forsøger at oprette en visning gennem SQL DDL. Fejlen opstår, når du definerer et andet antal af korrelationsnavne eller aliaser, end der findes i SELECT-sætningen. Denne fejl genereres f.eks. med følgende syntaks: CREATE VIEW foo (kol1, kol2) AS SELECT kol1 FROM tabel1.


Der opstod et numerisk feltoverløb. (Fejl 3349)

Dataene i et Btrieve-felt er for store til at kunne optræde i programmet.


En ny replika kan ikke oprettes, fordi <navn>-objektet i objektbeholderen <navn> ikke kan replikeres. (Fejjl 3490)

En ny replika kan ikke oprettes, fordi <navn>-objektet i objektbeholderen <navn> ikke kan replikeres. (Fejl 3490)

Microsoft Jet-databasemotoren var i gang med at oprette et replika. Handlingen mislykkedes, da databasemotoren forsøgte at rette sig efter det objekt og den objektbeholder, der er angivet i fejlmeddelelsen.


Objektet <navn> findes allerede. (Fejl 3012)

Du har forsøgt at oprette et objekt med et navn, der allerede findes i databasen. Vælg et andet navn, og forsøg derefter at udføre handlingen igen.


Det angivne objekt kan ikke replikeres, fordi objektet mangler en nødvendig ressource. (Fejl 3489)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Microsoft Jet-databasemotoren kunne ikke finde objektet <navn>. Kontroller, at objektet findes, og at du har stavet navnet og stien korrekt. (Fejl 3011)

Microsoft Jet-databasemotoren kan ikke finde objektet <navn>. Kontroller, at objektet findes, og at du har stavet navnet og stien korrekt. (Fejl 3011)

Mulige årsager:

  • Det angivne objekt findes ikke.
  • Du har stavet objektnavnet forkert. Kontroller, om der mangler understregningstegn ( _ ) eller anden tegnsætning, og kontroller, at du ikke har indtastet foranstillede mellemrum.
  • Hvis du forsøger at åbne en Btrieve-tabel, kan den sti, der er angivet i datadefinitionsfilen File.ddf, være forkert. Sørg for, at datafilerne (.dat) findes i de rette biblioteker.


<Navn>-objektet i <navn>-objektbeholderen kan ikke gøres replikerbart. (Fejl 3456)

Microsoft Jet-databasemotoren var i gang med at gøre objektet replikerbart. Handlingen mislykkedes, fordi der ikke var ressourcer nok til at manipulere objektet. Hvis objektet er en tabel, skal du sørge for, at det totale antal felter efter replikering ikke overstiger 255, og at det totale antal byte i en post ikke overstiger 2.048. Hvis antallet af felter eller tegn overstiger denne grænse, skal du reducere postens størrelse.


Objektet er ikke en lagret procedure. (Fejl 3749)

Denne fejl opstår, når du bruger det reserverede ord EXECUTE og enten overfører et navn på en procedure eller en visning, der ikke findes i databasen, eller overfører navnet på en basistabel.


Der er gjort ugyldig brug af '.', '!' eller '()'. (Fejl 2447)

Udtrykket bruger ikke afgrænsere korrekt. Hvis du skal referere til egenskaber i DAO-objekter, anbefales det, at du benytter syntaksen .egenskabsnavn.


Paradox-låsefilen er forældet. (Fejl 3230)

Du har forsøgt at benytte en Paradox-tabel, men tabellens associerede låsefil (.lck) er forældet. Slet .lck-filen, og forsøg derefter at udføre handlingen igen.


ODBC Specification Conformance-fejl <meddelelse>. Du skal rapportere denne fejl til udvikleren af programmet. (Fejl 3299)

Denne fejl kan skyldes en række problemer med ODBC-driveren. Noter nummeret på den fejlmeddelelse, der er angivet i meddelelsen, og rapporter det til programudvikleren, som derefter kan rapportere det til forhandleren af driveren.


Der opstod en fejl under åbning af en Microsoft Excel 5.0-fil. (Fejl 3432)

Der opstod en OLE-fejl under åbning af en Microsoft® Excel version 5.0-fil.


OLE kunne ikke initialiseres under indlæsning af den installerbare ISAM til Microsoft Excel. (Fejl 3430)

OLE Automation kunne ikke initialiseres under indlæsning af den installerbare ISAM til Microsoft® Excel. Prøv at installere DLL-filerne til OLE igen.


Dette er ikke en Microsoft Excel 5.0-fil. (Fejl 3431)

Du har forsøgt at læse en fil som en Microsoft® Excel version 5.0-fil, men filen findes ikke i dette format.


En af bindingsparametrene er ugyldig. (Fejl 3645)

En datatype eller en bindingstype i den bindingsstruktur, der er overført til GetRows eller GetRowsEx, har en ugyldig værdi, eller den maksimale feltlængde er ugyldig for den angivne datatype.

Undersøg bindingsstrukturen.


En af posterne i postsættet er slettet af en anden proces. (Fejl 3643)

En eller flere af posterne i postsættet er blevet slettet, efter at forespørgslen er blevet udført. Du skal opdatere postsættet og forsøge at køre forespørgslen igen.


Et asynkront OpenConnection-kald er endnu ikke udført. (Fejl 3664)

Et asynkront OpenConnection-kald er endnu ikke udført. Du kan ikke refererere til det returnerede tilslutningsobjekt, før kaldet er udført. (Fejl 3664)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Databasen skal åbnes med udelt adgang, før den kan replikeres. (Fejl 3491)

Du har forsøgt at replikere en database, der er åbnet i delt tilstand. Luk databasen, åbn den igen i udelt tilstand, og repliker den derefter.


Det lykkedes ikke at åbne filen ved hjælp af FTP-serviceprogrammet. (Fejl 3679)

Det lykkedes ikke at åbne filen ved hjælp af FTP-serviceprogrammet. Sørg for, at FTP-rullelisten har læsetilladelser. (Fejl 3679)

Det lykkedes ikke at åbne en fil på Internet-serveren. Sørg for, at serveren kører, og at den delte mappe til FTP er konfigureret med læse- og skriveadgang.


Handlingen blev annulleret af brugeren. (Fejl 3059)

Du har stoppet handlingen, før den er udført. Nogle af dataændringerne er måske ikke gemt.


Den handling, du forsøgte at udføre, er i konflikt med en eksisterende handling, der involverer dette medlem af replikasættet. (Fejl 3460)

Den handling, du forsøgte at udføre, er i konflikt med en eksisterende handling, der involverer dette medlem i replikasættet. (Fejl 3460)

En anden bruger eller et andet program udfører allerede samme handling på dette medlem i replikasættet. Forsøg at udføre handlingen igen senere.


Handlingen understøttes ikke på replikerbare databaser, der ikke er konverteret til den aktuelle version. (Fejl 3703)

Denne replika er oprettet i en tidligere version af Microsoft® Jet. Hvis du vil udføre replikeringshandlinger, skal du først komprimere eller konvertere replikasættet.


Denne handling er ikke tilladt i underforespørgsler. (Fejl 3787)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


ORDER BY-delsætningen <delsætning> er i konflikt med DISTINCT. (Fejl 3093)

Du har oprettet en SQL-sætning med et ALL-, DISTINCT- eller DISTINCTROW-prædikat og en ORDER BY-delsætning, som indeholder et felt, der ikke er angivet i SELECT-sætningen. Fjern det reserverede ord DISTINCT, eller fjern det angivne felt i delsætningen ORDER BY.


ORDER BY-delsætningen <delsætning> er i konflikt med GROUP BY-delsætningen. (Fejl 3094)

Denne fejl kan opstå, hvis du opretter en udvælgelsesforespørgsel og angiver grupperede felter efter sorterede felter, der ikke er grupperede. Du har f.eks. oprettet en SQL-sætning, hvor det angivne felt ikke er med i rækkefølgen i delsætningen ORDER BY. Flyt det angivne felt til venstre for de ikke-grupperede felter, eller fjern det angivne felt i delsætningen ORDER BY.


Udtrykket ORDER BY <udtryk> indeholder felter, der ikke er udvalgt af forespørgslen. Kun de felter, der forespørges på i den første forespørgsel, kan medtages i et ORDER BY-udtryk. (Fejl 3351)

ORDER BY-udtrykket <udtryk> indeholder felter, der ikke er udvalgt af forespørgslen. Kun de felter, der forespørges på i den første forespørgsel, kan medtages i et ORDER BY-udtryk. (Fejl 3351)

I en foreningsforespørgsel har du medtaget felter i et ORDER BY-udtryk, der ikke er angivet af forespørgslen. Kun de felter, der forespørges på i den første forespørgsel, kan medtages i et ORDER BY-udtryk.


En cirkulær reference blev forårsaget af aliaset <navn> på forespørgselsdefinitionens SELECT-liste. (Fejl 3103)

Det angivne alias har oprettet en reference, der ikke kan opløses. Denne fejl kan opstå, hvis du f.eks. skriver følgende SQL-sætning, hvor A er den cirkulære reference:

SELECT A + B AS C, C + D AS E, E + F AS A
FROM MinTabel;

SELECT week1 + week2 as hours, hours + overtime as gross, gross + ytdpay as week1FROM Medarbejderløn


Outputtabellen <navn> blev ikke fundet. (Fejl 3192)

Du har forsøgt at benytte en INSERT INTO-sætning sammen med den angivne tabel, der ikke findes. Kontroller, at du har skrevet navnet korrekt, og forsøg derefter at udføre handlingen igen.

Hvis du forsøger at køre en tabeloprettelsesforespørgsel, der opretter tabellen for dig, skal du i stedet bruge syntaksen til SELECT INTO.


Swapfilen har nået grænsen eller er beskadiget. (Fejl 3540)

Synchronizer har fået et uventet systemproblem. Luk computeren ned, sluk den, og genstart den.


Den anmodede sidelåsning kan ikke udføres, fordi DB er i rækkelåsningstilstand. (Fejl 3752)

Denne fejl opstår, når en bruger angiver, at databasen skal åbnes kun i sidelåsningstilstand, men en anden bruger allerede har åbnet databasen i række/sidelåsningstilstand.


Parameteren <navn> har ingen standardværdi. (Fejl 3748)

Denne fejl opstår, når du bruger procedurer. Den opstår, når du forsøger at bruge en standardværdi, og parameteren ikke har en defineret standardværdi. Undgå denne fejlmeddelelse ved at definere en standardværdi for proceduren eller overføre en værdi til parameteren.


Parameteren har ingen standardværdi. (Fejl 3747)

Denne fejl opstår, når du bruger procedurer. Den opstår, når du forsøger at bruge en standardværdi, og parameteren ikke har en defineret standardværdi. Undgå denne fejlmeddelelse ved at definere en standardværdi for proceduren eller overføre en værdi til parameteren.


Størrelsen af registreringsdatabaseparameteren overskrider den tilladte maksimale størrelse. (Fejl 3552)

Alle parametre i Microsoft® Windows®-registreringsdatabasen har en maksimal størrelse. Den indstilling, du har forsøgt at bruge, overskrider den højst tilladte størrelse. Kontroller størrelsesbegrænsningen for den parameter, du angiver.


Der er en syntaksfejl i et delvist filterudtryk i tabellen <navn>. (Fejl 3586)

Sørg for, at du benytter den korrekte syntaks i udtrykket.


De filtre, der definerer en delvis replika, er ikke synkroniseret i forhold til hinanden. (Fejl 3570)

Du har ændret filtrene i den delvise replika siden sidste gang, du udfyldte det delvise replika. Du skal udfylde den delvise replika igen ved enten at køre guiden Delvis replika eller ved at bruge metoden PopulatePartial Method i VBA-kode.


Partnerreplikaen vedligeholdes ikke af Synchronizer. (Fejl 3628)

Du forsøger at synkronisere med en partnerreplika, der ikke vedligeholdes af Synchronizer.


Det er en ugyldig synkroniseringspartner. (Fejl 3744)

Det er en ugyldig synkroniseringspartner. En lokal eller anonym replika skal synkronisere med den angivne hub-replika. (Fejl 3741)

Den angivne Synchronizer er ikke gyldig for dette replikasæt eller er ikke hub-Synchronizer for en lokal eller anonym replika. Du kan kun synkronisere en lokal eller anonym replika med den globale hub-replika, den er oprettet af.


Regneark, der er beskyttet med adgangskode, kan ikke importeres. (Fejl 3244)

Vend tilbage til det program, der blev benyttet til at gemme regnearket, gem regnearket igen uden adgangskode, og forsøg derefter at importere regnearket igen.


Det er ikke muligt at opdatere. Databasen eller objektet er skrivebeskyttet. (Fejl 3027)

Du har forsøgt at gemme ændringer i en database, der blev åbnet med skrivebeskyttet adgang.

Databasen er skrivebeskyttet af en af følgende årsager:

  • Du har brugt metoden OpenDatabase og åbnet databasen med skrivebeskyttet adgang.
  • I Microsoft® Visual Basic® bruger du kontrolelementet Data, og du har angivet egenskaben ReadOnly til True.
  • Databasefilen er defineret som skrivebeskyttet i operativsystemet eller i netværket.
  • Databasefilen er lagret på et skrivebeskyttet medie.
  • Du har ikke skriveadgang til databasefilen i et netværksmiljø.
  • Når du arbejder med en sikret database, kan databasen eller et af dens objekter, f.eks. et felt eller en tabel, være skrivebeskyttet. Dit brugernavn og din adgangskode giver muligvis ikke adgangstilladelse til disse data.

Luk databasen, fjern betingelsen for skrivebeskyttelse, og genåbn derpå filen med læse- og skriveadgang.


Der kan ikke slettes fra en Prevent Deletes-replika. (Fejl 3754)

En Prevent Deletes-replika er en replika, der er designet til af forhindre brugere i at slette poster. Hvis du vil udføre en sletning, skal du slette fra en replika, der tillader sletning.


Primær nøgle. (Fejl 3347)

Der kan ikke tilføjes poster. Den primære nøgle til tabellen <navn> er ikke i resultatsættet. (Fejl 3347)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Det er en ugyldig SQL-syntaks - forventede et procedurenavn. (Fejl 3781)

Det er en ugyldig SQL-syntaks – forventede et procedurenavn. (Fejl 3781)

Denne fejl opstår, når du forsøger at oprette eller slette en procedure ved hjælp af SQL DDLs syntaks CREATE PROCEDURE eller DROP PROCEDURE. Den opstår, hvis der ikke angives et gyldigt navn. Fejlen genereres f.eks. med følgende sætning: DROP PROCEDURE.


Processen stoppede, da der blev gjort forsøg på at afslutte Synchronizer-klientprogrammet. (Fejl 3542)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Den angivne egenskab findes allerede. (Fejl 3311)

Du har forsøgt at tilføje et nyt Property-objekt til en samling, der indeholder en egenskab med samme navn. Du skal undersøge, om du har stavet egenskaben Name i det nye Property-objekt forkert, eller referere til Hjælp-emnet til den eksisterende egenskab med samme navn for at se, om du skal oprette et nyt Property-objekt.


Egenskabsindstilling kan ikke være større end 2 KB. (Fejl 3309)

Egenskabsværdien er for stor. (Fejl 3309)

Du forsøger at angive et objekts egenskabsværdi til en størrelse, der er større end den højst tilladte størrelse på 2 KB. Afkort længden af egenskabsværdien.


Egenskaben kan ikke gemmes, fordi den er en skemaegenskab. (Fejl 3394)

Du har forsøgt at angive eller ændre en skemaegenskab. Når du opretter en ny skemaegenskab, skal du angive True som det fjerde argument til metoden CreateProperty for at angive eller slette denne egenskab.


Det lykkedes ikke at placere en fil ved hjælp af FTP. (Fejl 3681)

Det lykkedes ikke at placere en fil ved hjælp af FTP. Sørg for, at FTP-rullelisten har skrivetilladelser. (Fejl 3681)

Det lykkedes ikke at placere en fil på Internet-serveren. Sørg for, at serveren kører, og at den delte mappe til FTP er konfigureret med læse- og skriveadgang.


<Navn> i et kriterieudtryk. (Fejl 3076)

Det udtryk, du har indtastet, er ikke gyldig af den grund, der angives i meddelelsen. Kontroller, at du har indtastet feltnavne og tegnsætning korrekt, og forsøg derefter at udføre handlingen igen.


Den faste kolonneoverskrift <værdi> kan ikke angives i en krydstabuleringsforespørgsel mere end én gang. (Fejl 3104)

Når du opretter en krydstabuleringsforespørgsel med faste kolonneoverskrifter, skal de angivne værdier være unikke. Udskift en eller flere af de dublerede kolonneoverskrifter, og forsøg derefter at udføre handlingen igen.


Forespørgslen <navn> indeholder et tvetydigt kolonnenavn, der er i konflikt med korrelationsnavnet (aliaset) <navn>. (Fejl 3807)

Gør kolonnenavnet fuldstændigt, eller rediger korrelationsnavnet (aliaset). En SQL SELECT-sætning bruger et korrelationsnavn (alias), der bruges i en af basistabellerne i sætningens FROM-delsætning. Dette gav et forkert resultatsæt i tidligere versioner af Microsoft® Jet. Denne fejlmeddelelse overføres for at forhindre ændring af resultatsæt.

Denne SQL SELECT-sætning fungerer, når du bruger Microsoft OLE DB Provider til Jet for sig selv eller gennem Active Data Objects (ADO). Hvis denne SQL SELECT-sætning bruges gennem en del af Microsoft Access uden for ADO, mens du bruger Microsoft OLE DB Provider til Jet, skal du ændre korrelationsnavnet (aliaset) til et andet navn end kolonnenavnet i basistabellen.

Følgende er et eksempel på dette: CREATE TABLE Ordrer (OrdreDato DATE, Fragtomkostninger DOUBLE);. Følgende SQL-sætning returnerer nu en fejl: SELECT OrdreDato AS A1, Fragtomkostninger + Fragtomkostninger AS OrdreDato. Løsningen er at ændre korrelationsnavnet (aliaset) OrdreDato til et andet navn eller at køre denne forespørgsel gennem ADO ved hjælp af Microsoft OLE DB Provider til Jet.


Det angivne felt <felt> kan referere til mere end en tabel, der er vist i FROM-delsætningen i SQL-sætningen. (Fejl 3079)

Det angivne felt <felt> kan referere til mere end en tabel, der er vist i FROM-delsætningen i SQL-sætningen. I følgende eksempel findes feltet Ordreid i både tabellen Ordrer og Ordrespecifikationer:

SELECT Ordreid

FROM Ordrer, [Ordrespecifikationer];

Da sætningen ikke angiver, hvilken tabel feltet Ordreid tilhører, medfører den denne fejl. Hvis du vil udføre denne handling, skal du bestemme feltreferencen fuldt ud ved at tilføje et tabelnavn. For eksempel:

SELECT Ordrer.Ordreid

FROM Ordrer, [Ordrespecifikationer];


SQL-sætningen kunne ikke udføres, fordi den indeholder tvetydige ydre joinforbindelser. Du kan gennemtvinge, at en af joinforbindelserne bliver udført først ved at oprette en separat forespørgsel, der udfører den første joinforbindelse, og derefter medtage forespørgslen i SQL-sætningen. (Fejl 3258)

SQL-sætningen kan ikke udføres, fordi den indeholder tvetydige ydre joinforbindelser. Du kan gennemtvinge, at en af joinforbindelserne bliver udført først ved at oprette en separat forespørgsel, der udfører den første joinforbindelse, og derefter medtage forespørgslen i SQL-sætningen. (Fejl 3258)

Du har forsøgt at udføre en SQL-sætning, der indeholder flere joinforbindelser. Resultatet af forespørgslen kan variere afhængigt af den rækkefølge, joinforbindelserne udføres i. Denne fejl kan f.eks. opstå, hvis du udfører følgende SQL-sætning:

SELECT * FROM Kunder, Ordrer, [Ordrespecifikationer],

Kunder LEFT JOIN Ordrer

ON Kunder.Kundeid = Ordrer.Kundeid,

Ordrer INNER JOIN [Ordrespecifikationer]

ON Ordrer.Ordreid = [Ordrespecifikationer].Ordreid;

Når du udfører denne sætning, opstår der en fejl, fordi rækkefølgen af joinforbindelserne er tvetydig. Du kan gennemtvinge, at en af joinforbindelserne bliver udført først ved at oprette en separat forespørgsel, der udfører den første joinforbindelse, og derefter medtage forespørgslen i SQL-sætningen. I følgende forespørgsler vises, hvordan du kan konstruere den foregående forespørgsel, så handlingen INNER JOIN udføres før handlingerne LEFT JOIN og RIGHT JOIN:

Forespørgsel1

SELECT * FROM Ordrer, [Ordrespecifikationer],

Ordrer INNER JOIN [Ordrespecifikationer]

ON Ordrer. Orderid = [Ordrespecifikationer].Orderid;

Forespørgsel2

SELECT * FROM Kunder, Forespørgsel1,

Kunder LEFT JOIN Forespørgsel1

ON Kunder.Kundeid = Ordrer.Kundeid;


Der er brugt ugyldige kantede parenteser omkring navnet <navn>. (Fejl 3126)

Det angivne navn kan enten ikke sættes i kantede parenteser, eller også passer parenteserne ikke sammen. Kontroller indtastningen for at sikre, at parenteserne passer sammen, og forsøg derefter at udføre handlingen igen.


Der er en ugyldig reference i SELECT-sætningen. (Fejl 3242)

Du har skrevet en ugyldig felt- eller tabelreference i sætningen SELECT. Referencen er f.eks. stavet forkert eller findes ikke.


Krydstabuleringsforespørgslen indeholder en eller flere ugyldige faste kolonneoverskrifter. (Fejl 3322)

Listen over indtastninger til en fast kolonneoverskrift i en krydstabuleringforespørgsel (PIVOT-delsætningen i en TRANSFORM-sætning) er ikke gyldig.

Mulige årsager:

  • Der er ingen indtastninger på listen. Der skal være mindst en værdi i de parenteser, der efterfølger det reserverede ord IN i PIVOT-delsætningen.
  • Der vises en tom indtastning på listen. To kommaer i en række (,,) opretter en tom indtastning.
  • Listen indeholder et feltnavn på mere end 64 tegn.

Rediger PIVOT-delsætningen, og kør forespørgslen igen.


Der kunne ikke slettes fra de angivne tabeller. (Fejl 3086)

Du har forsøgt at slette data fra en eller flere tabeller, men sletningen kunne ikke fuldføres.

Mulige årsager:

  • Du har ikke tilladelse til at ændre tabellen. Hvis du vil ændre de tildelte tilladelser, skal du kontakte systemadministratoren eller den person, der har oprettet tabellen.
  • Databasen blev åbnet med skrivebeskyttet adgang. Databasen er skrivebeskyttet af en af følgende årsager:
    • Du har brugt metoden OpenDatabase og åbnet databasen med skrivebeskyttet adgang.
    • Databasefilen er defineret som skrivebeskyttet i operativsystemet på databasens server eller på netværket.
    • Du har ikke skriveadgang til databasefilen i et netværksmiljø.
    • Du har i Microsoft® Visual Basic® brugt kontrolelementet Data og angivet egenskaben ReadOnly til True.

Hvis du vil slette dataene, skal du lukke databasen, fjerne betingelsen til skrivebeskyttelse, og derefter genåbne filen med læse- og skriveadgang.


Der kan ikke indtastes en værdi i et tomt felt på "en"-siden af en ydre joinforbindelse. (Fejl 3332)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


<Feltnavn> kan ikke opdateres, fordi feltet ikke er opdaterbart. (Fejl 3113)

Mulige årsager:

  • Det angivne felt er en del af et TableDef-objekt eller et Recordset-objekt af typen dynamisk udvalg, der ikke kan opdateres. Denne fejl opstår, hvis du f.eks. forsøger at opdatere et felt af typen AutoNumber.
  • Du har kørt en forespørgsel, der kombinerer opdaterbare og ikke-opdaterbare Tabledef-objekter, og du har forsøgt at opdatere et af felterne i forespørgslens resultater (det fremkomne Recordset af typen dynamisk udvalg).


Forespørgslen kan ikke indeholde en Database-parameter. (Fejl 3222)

Udskift parameterens feltdatatype til denne parameterforespørgsel med en gyldig feltdatatype, og forsøg derefter at udføre handlingen igen.


Outputaliaset <navn> er dubleret. (Fejl 3062)

Du har forsøgt at køre en SQL-sætning, der indeholder mere end et alias med det samme navn. Følgende sætning vil f.eks. give denne fejl:

SELECT Efternavn AS Name, Fornavn AS Name FROM Medarbejdere;

Omdøb et eller flere aliaser, og forsøg derefter at udføre handlingen igen.


Outputdestinationen <navn> er dubleret. (Fejl 3063)

Du har forsøgt at køre en forespørgsel, der indeholder mere end et destinationsfelt med det samme navn.

Mulig årsag:

  • Du har oprettet en SQL-sætning, der indeholder en INSERT INTO-, SELECT...INTO- eller UPDATE-sætning, som medtager det angivne feltnavn mere end en gang.

Fjern de dublerede felter eller aliaset til destinationsfeltnavnene, og forsøg at udføre handlingen igen.


Krydstabuleringsforespørgslen i en ikke-fast kolonne kan ikke bruges som underforespørgsel. (Fejl 3637)

Du har forsøgt at sortere på en krydstabuleringsforspørgsel med en variabel kolonne. Du skal gemme forespørgslens resultater og derefter sortere resultaterne med knappen Sorter stigende eller Sorter faldende.


Dette udtryk er ikke skrevet korrekt, eller det er for komplekst til at blive evalueret. Et numerisk udtryk kan f.eks. indeholde for mange komplicerede elementer. Prøv at forenkle udtrykket ved at tildele dele af udtrykket til variabler. (Fejl 3071)

Dette udtryk er stavet forkert, eller det er for komplekst til at blive evalueret. Et numerisk udtryk kan f.eks. indeholde for mange komplicerede elementer. Prøv at forenkle udtrykket ved at tildele variabler til dele af udtrykket. (Fejl 3071)

Mulige årsager:

  • Du har indtastet et udtryk med en ugyldig syntaks. Der mangler f.eks. en operand eller operator, eller du har måske skrevet et ugyldigt tegn eller komma eller en tekst, der ikke er omsluttet med anførselstegn ( " ). Kontroller udtrykket for at sikre dig, at du har indtastet det korrekt.
  • Du har indtastet et udtryk, der er for komplekst. Et numerisk udtryk kan f.eks. indeholde for mange komplicerede elementer. Forsøg at forenkle udtrykket ved at tildele nogle deludtryk til variabler.


Feltet <navn> er baseret på et udtryk og kan ikke redigeres. (Fejl 3327)

Hvis f.eks. en lagret forespørsel eller visning med en kolonne, der er oprettet ud fra et udtryk, blev oprettet, kunne du opdatere den pågældende kolonne. Følgende ville give denne fejl: CREATE VIEW VCustomer AS SELECT (Fornavn & Efternavn) AS Test FROM Kunde efterfulgt af UPDATE Test FROM VCustomer


<Meddelelse> i forespørgselsudtrykket <udtryk>. (Fejl 3075)

Det udtryk, du har indtastet, er ikke gyldig af den grund, der angives i meddelelsen. Kontroller, at du har indtastet feltnavne og tegnsætning korrekt, og forsøg derefter at udføre handlingen igen.


Hvis du vil foretage ændringer i dette felt, skal du først gemme posten. (Fejl 3331)

Denne fejl opstår, når brugeren prøver at redigere en række, der er baseret på en visning eller en lagret forespørgsel, som er baseret på mere end én tabel.


Data kan ikke indsættes med en handlingsforespørgsel. (Fejl 3084)

Du har forsøgt at køre en tilføjelsesforespørgsel ved at bruge en handlingsforespørgsel til inputtet. Erstat handlingsforespørgslen med en udvælgelsesforespørgsel, og forsøg derefter at udføre handlingen igen.


Det er ikke et gyldigt aliasnavn. (Fejl 3068)

Det alias, du har skrevet, følger ikke standardnavngivningskonventionerne. Skriv et nyt navn, og forsøg derefter at udføre handlingen igen.


En handlingsforespørgsel kan ikke bruges som rækkekilde. (Fejl 3417)

En handlingsforespørgsel kan ikke bruges som en rækkekilde. (Fejl 3417)

Mulig årsag:

  • Den forespørgsel, der anvendes som postkilde, er en handlingsforespørgsel eller en datadefinitionsforespørgsel.


Handlingsforespørgslen <navn> kan ikke bruges som rækkekilde. (Fejl 3069)

Du kan ikke benytte navnet på en handlingsforespørgsel her. Brug i stedet navnet på en udvælgelsesforespørgsel. Hvis du vil køre en handlingsforespørgsel, skal du bruge metoden Execute i stedet for navnet på en handlingsforespørgsel som input til delsætningen FROM.


Input kan ikke modtages fra den interne rapportforespørsel <navn>. (Fejl 3124)

Input kan ikke modtages fra den interne rapportforespørgsel <navn>. (Fejl 3124)

Du har forsøgt at bruge en SQL-sætning, der indeholder en eksplicit reference til en ikke-tilladt, intern rapportforespørgsel.


<Parameternavn> er ugyldigt, fordi det er for langt eller indeholder ugyldige tegn. (Fejl 3223)

Parameternavnet er for langt eller indeholder ugyldige tegn. Ret navnet, og forsøg derefter at udføre handlingen igen.


Handlingsforespørgslen <navn> kan ikke åbnes. (Fejl 3064)

Du har forsøgt at åbne en handlingsforespørsel ved hjælp af metoden OpenQueryDef, der er en forældet metode, som oprindeligt kun var gyldig sammen med udvælgelsesforespørgsler. Den foretrukne metode til at køre en handlingsforespørgsel er at benytte metoden Execute til objektet QueryDef.


Forespørgslen <navn> er beskadiget. (Fejl 3340)

Du har refereret til et udefineret forespørgselsnavn. Undersøg de forespørgsler, der er vist i samlingen QueryDefs for at sikre, at du har refereret til et gyldigt forespørgselsnavn.


Denne forespørgsel er en DDL-forespørgsel og kan ikke bruges som rækkekilde. (Fejl 3324)

Du har forsøgt at køre en handlingsforespørgsel eller en datadefinitionsforespørgsel uden at bruge metoden Execute.


En intern rapportforespørgsel kan ikke bruges. (Fejl 3083)

Du har forsøgt at bruge en SQL-sætning, der indeholder en eksplicit reference til en ikke-tilladt, intern rapportforespørgsel. Fjern den ugyldige reference, og forsøg derefter at udføre handlingen igen.


En udvælgelsesforespørgsel kan ikke udføres. (Fejl 3065)

Du har forsøgt at benytte metoden Execute sammen med en udvælgelsesforespørgsel. Metoden Execute er kun gyldig sammen med handlingsforespørgsler. I modsætning til handlingsforespørgsler indeholder udvælgelsesforespørgsler en SELECT-sætning og kan returnere poster.


Denne forespørgsel er ikke en korrekt udformet datadefinitionsforespørgsel. (Fejl 3357)

Denne forespørgsel er ikke en korrekt udformet datadefinitionsforespørgsel.


Forespørgslen kan ikke bruges som rækkekilde. (Fejl 3323)

Mulige årsager:

Den forespørgsel, der anvendes som postkilde, er en handlingsforespørgsel eller en datadefinitionsforespørgsel.


Dette postsæt kan ikke opdateres. (Fejl 3326)

Dette resultatsæt kan ikke opdateres. (Fejl 3326)

Du har forsøgt at redigere data i et felt, der er bundet til et Result set-objekt af typen snapshot. Felter af typen Snapshot i en Microsoft Jet-database kan ikke redigeres.


Datatyperne i JOIN-udtrykket stemmer ikke overens. (Fejl 3615)

Datatyper i JOIN-udtrykket stemmer ikke overens. (Fejl 3615)

Et JOIN-udtryk forsøger at joinforbinde to tabeller i felter med inkompatible datatyper. Denne fejl opstår f.eks., hvis du forsøger at joinforbinde et felt af typen Memo med et felt af typen Text.


Joinforbindelsen, grupperingen, sorteringen eller den indekserede begrænsning kan ikke udføres. En værdi, der søges eller sorteres efter, er for lang. (Fejl 3393)

Den kombinerede maksimumlængde på felter, der anvendes til at joinforbinde, gruppere eller sortere, er 255 byte. Du kan reducere antallet af felter i joinforbindelsen, grupperingen eller sorteringen eller anvende kortere datatyper og feltstørrelser til felterne.


Der kan ikke være felter af typen Memo eller OLE Object i aggregatargumentet <sætning>. (Fejl 3115)

Der kan ikke være felter af typen Memo, OLE eller Hyperlink Object i aggregatargumentet <sætning>. (Fejl 3115)

Du kan ikke medtage felter af typen Memo eller OLE Object i en aggregatfunktion.


Der kan ikke medtages et felt af typen Memo eller OLE Object, når du markerer unikke værdier <sætning>. (Fejl 3114)

Fjern det reserverede ord DISTINCT, eller feltet af typen Memo eller OLE Object fra sætningen.


Der kan ikke grupperes på Memo eller OLE Object <delsætning>. (Fejl 3119)

Der kan ikke sorteres på Memo eller OLE Object <delsætning>. (Fejl 3119)

Delsætningen GROUP BY i en SQL-sætning kan ikke indeholde felter af typen Memo eller OLE Object.


Der kan ikke være et felt af typen Memo eller OLE Object i kriteriet <kriterie> for en aggregatfunktion. (Fejl 3116)

Der kan ikke være et felt af typen Memo eller OLE Object i kriteriet <kriterium> for en aggregatfunktion. (Fejl 3116)

Delsætningen HAVING i en SQL-sætning kan ikke indeholde felter af typen Memo eller OLE Object.


Der kan ikke joinforbindes på Memo eller OLE Object <navn>. (Fejl 3118)

Der kan ikke sorteres på Memo eller OLE Object <delsætning>. (Fejl 3118)

Du kan ikke joinforbinde felter af typen Memo eller OLE Object. Det felt, du bruger til logisk at knytte to eller flere tabeller sammen, skal være af en anden datatype, som f.eks. Text eller Integer.


Der kan ikke sorteres på Memo eller OLE Object <delsætning>. (Fejl 3117)

Delsætningen ORDER BY i en SQL-sætning kan ikke indeholde felter af typen Memo eller OLE Object.


Feltet <navn> af typen Memo, OLE eller Hyperlink Object kan ikke bruges i en SELECT-delsætning i en foreningsforespørgsel. (Fejl 3364)

Et felt, du har angivet i SELECT-delen i en foreningsforespørgsel i SQL-sætningen til forespørgslen, har feltdatatypen Memo eller OLE object. Du kan ikke angive et felt af nogen af disse typer.


Der er et ugyldigt felt af typen Memo, OLE eller Hyperlink Object i underforespørgslen <navn>. (Fejl 3342)

En underforespørgsel kan ikke returnere et objekt af typen Memo eller OLE Object, og den kan ikke sammenlignes med et Memo eller OLE Object i et udtryk.


GROUP BY-delsætninger i flere niveauer er ikke tilladt i en underforespørgsel. (Fejl 3612)

En SQL-underforespørgsel kan ikke vise mere end et felt i en GROUP BY-delsætning.


Der er for få parametre. Der var ventet <tal>. (Fejl 3061)

Denne parameterforespørgsel kræver det angivne antal parametre, du skal indtaste. Angiv det forventede antal parametre, og kør forespørgslen igen.

I nogle tilfælde genereres denne meddelelse, når ukendte feltnavne eller udtryk fortolkes som forespørgselsparametre. Sørg for at omslutte feltnavne, der indeholder mellemrum eller tegnsætning, med kantede parenteser [ ].


Der kan ikke slettes poster, fordi der ikke er tilladelse til at slette i <navn>. (Fejl 3109)

Du skal have tilladelse til at slette data i den angivne tabel eller forespørgsel. Hvis du vil ændre de tildelte tilladelser, skal du kontakte systemadministratoren eller den person, der har oprettet tabellen eller forespørgslen.


Du skal angive den tabel, der indeholder de poster, du vil slette. (Fejl 3128)

Du har forsøgt at køre en sletteforespørgsel, men forespørgslen angiver ikke navnet på den tabel, der indeholder de poster, du vil slette.

Mulig årsag:

  • Du har ikke indtastet en stjerne for hver tabel i prædikaterne ALL, DISTINCT og DISTINCTROW. I stedet har du skrevet feltnavne (f.eks. Kunder.Adresse i stedet for Kunder.*).


Forespørselsinputtet skal indeholde mindst én tabel eller forespørgsel. (Fejl 3067)

Forespørgselsinputtet skal indeholde mindst én tabel eller forespørgsel. (Fejl 3067)

Denne fejl opstår i Microsoft Jet-databaser, hvis du ikke markerer et tabelnavn, når du opretter en forespørgsel. Marker mindst én tabel eller forespørgsel.

Denne fejl opstår i ODBCDirect-databaser, hvis du forsøger at køre en forespørgsel, der ikke indeholder en SQL-sætning. Medtag mindst én forespørgsel eller et lagret procedurekald i egenskaben SQL til objektet QueryDef.


Der kan ikke tilføjes poster, fordi der ikke er tilladelse til at indsætte i <navn>. (Fejl 3107)

Du skal have tilladelse til at indsætte data i den angivne tabel eller forespørgsel. Hvis du vil ændre de tildelte tilladelser, skal du kontakte systemadministratoren eller den person, der har oprettet tabellen eller forespørgslen.


Der kan ikke tilføjes poster. Der er ingen tilsvarende post på en-siden. (Fejl 3353)

Der kan ikke tilføjes poster. Der er ingen tilsvarende post på en-siden. (Fejl 3363)

Denne fejl opstår, når du redigerer en lagret forespørgsel eller visning, der indeholder mere end en tabel. Denne fejl kan opstå, hvis du har forsøgt at gemme en række fra en visning, der var en joinforbindelse mellem en kunde- (enkelt) og ordretabel (mange). Hvis du kun har angivet oplysninger for ordren og ikke har indtastet oplysninger, såsom den primære nøgleværdi, for kundetabellen, vil denne fejl returneres.


Forespørgslen skal have mindst ét destinationsfelt. (Fejl 3066)

Denne fejl opstår, hvis du ikke angiver destinationsfelt- navne, når du opretter en forespørgsel. Marker mindst ét destinationfelt.


Definitioner kan ikke læses, fordi der ikke er tilladelse til at læse definitioner i tabellen eller forespørgslen <navn>. (Fejl 3110)

Du skal have tilladelse til at læse definitioner i den angivne tabel eller forespørgsel. Hvis du vil ændre de tildelte tilladelser, skal du kontakte systemadministratoren eller den person, der har oprettet tabellen eller forespørgslen.


Poster kan ikke læses, fordi der ikke er tilladelse til at læse i <navn>. (Fejl 3112)

Du skal have tilladelse til at læse i den angivne tabel eller forespørgsel. Hvis du vil ændre de tildelte tilladelser, skal du kontakte systemadministratoren eller den person, der har oprettet tabellen eller forespørgslen.


Der kan ikke redigeres poster, fordi der ikke er tilladelse til at opdatere i <navn>. (Fejl 3108)

Der kan ikke rediges poster, fordi der ikke er tilladelse til at opdatere i <navn>. (Fejl 3108)

Du skal have tilladelse til at opdatere data i den angivne tabel eller forespørgsel. Hvis du vil ændre de tildelte tilladelser, skal du kontakte arbejdsgruppeadministratoren eller den person, der har oprettet tabellen eller forespørgslen.


Der kunne ikke oprettes, fordi der ikke er tilladelse til at redigere design i tabellen eller forespørgslen <navn>. (Fejl 3111)

Du har forsøgt at oprette den angivne tabel eller forespørgsel, men du har ikke den nødvendige tilladelse til at redigere design. Hvis du vil ændre de tildelte tilladelser, skal du kontakte systemadministratoren eller den person, der har oprettet forespørgslen.


Forespørgselsunderstøttelse er ikke tilgængelig. (Fejl 3389)

Du har forsøgt at skabe referentiel integritet på et Relation-objekt i et QueryDef-objekt, der ikke understøttes.

Du skal ændre indstillingen af egenskaben Attributes i Relation-objektet til dbRelationDontEnforce.


Handlingen skal bruge en opdaterbar forespørgsel. (Fejl 3073)

Du har forsøgt at køre, åbne eller ændre en forespørgsel, der kan opdateres.

Mulige årsager:

  • Du har forsøgt at køre en forespørgsel, der forsøgte at opdatere et ikke-opdaterbart felt. Du har f.eks. oprettet forespørgslen på en sådan måde, at du har forsøgt at opdatere et felt på den ene side i en en-til-mange-relation.
  • Du har forsøgt at benytte den forældede metode OpenQueryDef til en forespørgsel, der findes i en database, som er skrivebeskyttet.

Databasen er skrivebeskyttet af en af følgende årsager:

  • Du har benyttet metoden OpenDatabase eller Visual Basic-kontrolelementet Data og har åbnet databasen med skrivebeskyttet adgang.
  • Databasefilen er defineret som skrivebeskyttet i netværksoperativsystemet.
  • Du har ikke skriveadgang til databasefilen i et netværksmiljø.

Luk databasen, fjern betingelsen for skrivebeskyttelse, og genåbn den dernæst med læse- og skriveadgang.

  • Du har ikke tilladelse til at foretage ændringer i forespørgslen. Hvis du vil ændre de tildelte tilladelser, skal du kontakte systemadministratoren eller den person, der har oprettet forespørgslen.


Parameteren <navn> er angivet, hvor der kræves et databasenavn. (Fejl 3217)

Du har oprettet en parameterforespørgsel, der angiver en ugyldig parametertype. Følgende eksempel giver denne fejl:

PARAMETERS Param1 Text;

SELECT Kundeid

FROM Kunder IN Param1;

Param1 er en parameter af typen Text, men delsætningen FROM kræver en databaseparameter.

Skift parametertypen fra Text til Database, og forsøg derefter at udføre handlingen igen.


Parameteren <navn> er angivet, hvor der kræves et tabelnavn. (Fejl 3216)

Du har oprettet en parameterforespørgsel, der angiver en ugyldig parametertype. I følgende eksempel opstår denne fejl:

PARAMETERS Param1 Text;

INSERT INTO Param1

SELECT *

FROM Kunder;

Param1 er en parameter af typen Text, men sætningen INSERT INTO forventer et tabelnavn.

Skift parametertypen fra Text til TableID, og forsøg derefter at udføre handlingen igen.


Det er en forkert datatype til parameteren <parameter>. (Fejl 3060)

Du har forsøgt at benytte et argument med en datatype, som er i konflikt med den datatype, der er defineret til denne parameter. Du kan f.eks. have forsøgt at bruge et strengudtryk, der forventer et numerisk argument med en parameter. Brug et argument med den korrekte datatype, og forsøg derefter at udføre handlingen igen.


Post i tabellen <navn> blev slettet af en anden bruger. (Fejl 3329)

Den række, du forsøger at redigere, er slettet af en anden bruger. Denne funktionsmåde kan forhindres ved at lade alle brugere i databasen bruge fuldstændig låsning.


Post i tabellen <navn> er låst af en anden bruger. (Fejl 3330)

Den række eller side, du forsøger at opdatere, er i øjeblikket låst af en anden bruger. Microsoft® Jet version 4.0 tillader brugere at have databasen åben i en tilstand, der tillader låsning på rækkeniveau. Denne tilstand kan væsentligt reducere antallet af gange, denne fejl genereres.


Der refereres til den samme tabel <tabel> som både kilde og destination i tabeloprettelsesforespørgslen. (Fejl 3610)

En af kildetabellerne i en SELECT INTO-sætning har samme navn som destinationstabellen. Du kan enten fjerne tabellen fra kildetabellerne eller navngive destinationstabellen igen.


Tabellen <navn> er skrivebeskyttet. (Fejl 3328)

Denne fejl opstår, når du forsøger at opdatere en kolonne i en tabel, en anden bruger har åbnet som skrivebeskyttet.


Forespørgslen er for kompleks. (Fejl 3360)

Forespørgslen er for kompleks. Reducer antallet af felter i delsætningen SELECT eller antallet af underforespørgsler eller tabeller i join- forbindelsen.


Der er for mange udtryk i DISTINCT-outputtet. (Fejl 3089)

Du har oprettet en SQL-sætning, der indeholder et ALL-, DISTINCT- eller DISTINCTROW-prædikat med mere end 10 udtryk. Fjern det reserverede ord DISTINCT, eller fjern nogle af felterne i prædikatet DISTINCT.


Der er for mange udtryk i delsætningen GROUP BY. (Fejl 3087)

Der er for mange udtryk i GROUP BY-delsætningen. (Fejl 3087)

Du har oprettet en SQL-sætning med mere end 10 felter i delsætningen GROUP BY. Fjern nogle af felterne i delsætningen GROUP BY.


Der er for mange udtryk i delsætningen ORDER BY. (Fejl 3088)

Der er for mange udtryk i ORDER BY-delsætningen. (Fejl 3088)

Du har oprettet en SQL-sætning, der indeholder en ORDER BY-delsætning med mere end 10 udtryk. Fjern nogle af felterne i delsætningen ORDER BY.


Der er for mange krydstabuleringskolonneoverskrifter <værdi>. (Fejl 3205)

Du har udført en SQL-sætning, der har forsøgt at oprette for mange kolonner. Den angivne værdi er den kolonne, der har fremkaldt denne fejl.

Du kan reducere antallet af kolonner ved at tilføje yderligere betingelser til delsætningen WHERE eller tilføje en WHERE-delsætning, hvis der ikke er en.


Værdier, der er angivet i en Top-delsætning, er ikke tilladt i sletteforespørgsler eller rapporter. (Fejl 3318)

Top-værdier, dvs. de værdier, der er angivet i en TOP-delsætning i en SELECT-sætning, er ikke tilladt i sletteforespørgsler eller i rapporter.


En cirkulær reference blev forårsaget af <forespørgselsreference>. (Fejl 3102)

Du har forsøgt at køre en forespørgsel, der afhænger af sig selv med hensyn til data. Denne fejl opstår, hvis du f.eks. kører en af følgende forespørgsler:

Forespørgsel1

SELECT * FROM Medarbejdere, Forespørgsel2;

Forespørgsel2

SELECT * FROM Forespørgsel1;

Rediger forespørgslerne for at fjerne afhængigheden.


Microsoft Jet-databasemotoren genkender ikke <navn> som et gyldigt feltnavn eller udtryk. (Fejl 3070)

Det angivne navn genkendes ikke som et feltnavn eller et gyldigt udtryk. I en forespørgsel kan denne fejl opstå, hvis du skriver et navn, der fejlagtigt refererer til en database, en tabel eller et felt.

Mulige årsager i forbindelse med Microsoft® Access:

  • Du har en parameter i en krydstabuleringsforespørgsel eller i en forespørgsel, som en krydstabuleringsforespørgsel eller et diagram er baseret på, og parameterdatatypen er ikke eksplicit angivet i dialogboksen Forespørgselsparametre. Hvis du vil løse dette problem, skal du:
    • Angive parameteren og parameterens datatype i dialogboksen Forespørgselsparametre i den forespørgsel, der indeholder parameteren, og
    • Angive egenskaben ColumnHeadings i den forespørgsel, der indeholder parameteren.
  • I ingen af forespørgselstyperne har du refereret korrekt til en database, en tabel eller et felt. Denne fejl kan f.eks. opstå, hvis du refererer til et felt med navnet "Løn" i et udtryk, og du har stavet feltnavnet forkert, f.eks. [Løøn]*1.1.


Poster i tabellen <navn> vil ikke have poster på "en"-siden. (Fejl 3353)

Poster i tabellen <navn> vil ikke have poster på en-siden. (Fejl 3333)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Antallet af forespørgselsværdier og destinationsfelter er ikke det samme. (Fejl 3346)

Enten har forespørgslen INSERT INTO (tilføjelse) ikke nok destinationsfelter, eller den har flere felter på listerne VALUES eller SELECT, end der er felter i destinationstabellen. Marker et tilsvarende antal felter.


Der kunne ikke gemmes, fordi den er låst af en anden bruger. (Fejl 3202)

Mulig årsag:

  • Du har forsøgt at gemme en post på en databaseside på 2 KB, som en anden bruger i øjeblikket har låst. Vent, til den anden bruger er færdig med at arbejde med posten, og forsøg derefter at udføre handlingen igen.


Der opstod en disk I/O-fejl under læsning. (Fejl 3040)

Du kan ikke læse disken på grund af en intern disk- eller drevfejl.

Mulige årsager:

  • Du har forsøgt at læse fra et netværksdrev, men netværket er midlertidigt optaget, eller du er ikke længere tilsluttet netværket. Kontroller netværkstilslutningen, og forsøg derefter at udføre handlingen igen.
  • Der er opstået en fejl ved disken eller drevet.


Synchronizer modtog en ugyldig meddelelse til et medlem af det replikasæt, som det vedligeholder. (Fejl 3536)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Posten er slettet. (Fejl 3167)

Du har refereret til en post, som du har slettet, eller som en anden bruger i et flerbrugermiljø har slettet. Flyt til en anden post, og forsøg derefter at udføre handlingen igen.


Posten kan ikke gemmes, fordi den er låst af en anden bruger. (Fejl 3158)

Du har forsøgt at gemme en post, der findes på en database- side, som i øjeblikket er låst af en anden bruger. Hvis du vil gemme ændringerne, skal du vente, til den anden bruger er færdig med at arbejde med posten, og derefter forsøge at udføre handlingen igen.


Du forsøgte at kalde Update eller CancelUpdate eller at opdatere et felt i et postsæt uden først at kalde AddNew eller Edit. (Fejl 3020)

Update eller CancelUpdate uden AddNew eller Edit. (Fejl 3020)

I en Microsoft Jet-database har du kaldt metoden Update eller CancelUpdate, men ikke brugt metoden AddNew eller Edit, før du skrev data til en post.

I en ODBCDirect-database opstår denne fejl, når du forsøger at skrive data til en post uden først at kalde AddNew eller Edit.


Posten er for stor. (Fejl 3047)

Du har defineret eller importeret en tabel med poster, der er større end 2 KB. Denne fejl opstår, når du indtaster data i posten – ikke når du definerer tabelstrukturen. Omdefiner tabellen ved at gøre nogle felter mindre, ved at fjerne unødvendige felter, eller ved at flytte nogle felter til andre tabeller.


Gendannede replikerbare data. (Fejl 3711)

Gendannede replikerbare data. Denne række blev gendannet fra en beskadiget replikerbar database. Bekræft, at postens indhold er korrekt, og genindsæt derefter posten, eller slet konfliktposten. (Fejl 3711)

Når en replika gendannes, føjes nye poster, der fandtes i den beskadigede replika, til konflikttabellen med gendannede replika. Hermed sikres, at dataene kan gennemses, før de indsættes igen.


Referencen blev ikke fundet. (Fejl 3199)

Du har skrevet en fil-, tabel- eller feltreference, der ikke kunne findes. Kontroller stavningen og tegnsætningen for at sikre, at du har skrevet referencen korrekt, og forsøg derefter at udføre handlingen igen.


Relationen <navn> er ikke-gennemtvunget. (Fejl 3659)

Relationen <navn> er ikke-gennemtvunget. En relation i et delvist filterudtryk skal være gennemtvunget. (Fejl 3659)

Du har forsøgt at anvende et filter i en delvis replika i en tabel, hvor en relation, der ikke er gennemtvunget, findes. Gennemtving relationen i masterdesign, og prøv derefter igen at anvende filteret og udfylde den delvise replika.


Der blev ikke fundet et entydigt indeks for det felt, der refereres til, i den primære tabel. (Fejl 3609)

Når du opretter en relation mellem tabeller, skal det felt, der refereres til i den primære tabel, have et entydigt indeks. Yderligere oplysninger om fremgangsmåden finder du i emnerne om Index-objektet og egenskaben Primary.


CHECK-begrænsninger er ikke tilladt på replikerbare databaser. (Fejl 3798)

Fjern alle CHECK-begrænsninger, før du gør databasen eller tabellen replikerbar.


Du har forsøgt at slette eller hente oplysninger om et delvist filter, der ikke findes i MsysFilters. (Fejl 3505)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Replika-id'et for dette medlem af replikasættet blev gentildelt under en flytte- eller kopieringsprocedure. (Fejl 3574)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Den replikeringsegenskab, du prøver at angive eller slette, er skrivebeskyttet og kan ikke ændres. (Fejl 3461)

Mange egenskaber, der er forbundet med replikering, er kun til internt brug eller tilgængelige for udvikleren som skrivebeskyttet. Gennemgå programkoden igen for at sikre, at du læser egenskaben i stedet for at ændre den.


Masterdesign eller replikaen styres ikke af et Synchronizer-program. (Fejl 3502)

Der er gjort forsøg på at hente oplysninger om masterdesign eller en replika, der ikke styres af et Synchronizer-program.


Dette medlem af replikasættet er blevet logisk fjernet fra replikasættet og er ikke længere tilgængeligt. (Fejl 3569)

Det medlem af replikasættet, du forsøger at bruge, er blevet fjernet, enten fordi det ikke er blevet synkroniseret inden for det krævede antal dage (opbevaringsfrist), eller fordi det er blevet synkroniseret med en anden masterdesignreplika. Medlemmet bør slettes fra computeren.

Hvis der er data i det medlem, som ikke er blevet synkroniseret med et andet medlem i replikasættet, skal du manuelt indtaste de pågældende data i et andet medlem. Du kan fastslå, hvilke poster der indeholder ikke-synkroniserede data, ved at undersøge feltet s_Generation i alle tabeller. Værdien 0 i feltet s_Generation angiver, at posten er indsat eller opdateret og ikke synkroniseret med en anden replika i sættet. Hvis du vil se feltet s_Generation, skal du åbne Microsoft® Access, gå til menuen Funktioner, klikke på Indstillinger, vælge fanen Vis og derefter markere afkrydsningsfeltet Systemobjekter.

Hvis medlemmet er masterdesignreplikaen, skal du sammenligne replikaens struktur med en anden replika i sættet for at fastslå, om nogen af designændringerne ikke er blevet synkroniseret.


Replikanavnet eller id'et passer ikke til et aktuelt vedligeholdt medlem af replikasættet. (Fejl 3520)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Medlemmet af det replikasæt, du forsøger at synkronisere, bruges aktuelt i en anden synkronisering. (Fejl 3510)

Masterdesignet eller en replika kan kun involveres i én synkronisering ad gangen. Selvom du ikke kan begynde en anden synkronisering, mens medlemmet er låst, kan du fortsat bruge det. Vent nogle få minutter, og forsøg at synkronisere igen.


Replikaen er ikke en delvis replika. (Fejl 3478)

Du forsøger at få oplysninger om filteret eller et andet aspekt af en delvis replika. Den replika, du forespørger om, er dog ikke en delvis replika. Brug Replikastyring til at se replikaens egenskabsark, og bekræft, at replikaen ikke er delvis.


Uden Administrator-tilladelse, skal prioriteten af replika ligge i området 0 - <tal>. (Fejl 3772)

Uden Administrator-tilladelse skal prioriteten for replika ligge i området fra 0 til tallet for den prioritet, som den nye replika oprettes fra.


De to medlemmer af replikasættet, du forsøger at synkronisere, er begge masterdesign. (Fejl 3561)

Slet den ene masterdesignreplika.


De to medlemmer af replikasættet, du forsøger at synkronisere, har samme replika-id. (Fejl 3560)

Brug et andet destinationsmedlem i replikasættet til at synkronisere med.


Den replikeringsegenskab, du prøver at slette, er skrivebeskyttet og kan ikke fjernes. (Fejl 3607)

Sørg for, at du sletter den korrekte egenskab.


De systemtabeller til replikering, der er nødvendige for at gøre databasen replikerbar, kunne ikke oprettes. (Fejl 3579)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


To medlemmer af replikasættet kan ikke synkroniseres, fordi der ikke findes et fælles udgangspunkt til start af synkroniseringen. (Fejl 3521)

Der er gået for lang tid, siden disse to medlemmer af replikasættet sidst blev synkroniseret. Microsoft Jet-databasemotoren kan ikke finde et fælles referencepunkt, hvor ændringer i indholdet eller ændringer af databasestrukturen kan gælde fra.


Der opstod en fejl ved den anmodede udveksling, fordi <beskrivelse>. (Fejl 3660)

Detaljer om, hvorfor udvekslingen ikke lykkedes, finder du i udvekslingsoversigten. Hvis du bruger Replikastyring, kan du se udvekslingsoversigten ved at klikke på det replikerede objekt. Du kan også se replikeringsoversigten med kommandoen Synkroniseringsoversigt i menuen Vis.

Hvis du foretager replikering med Microsoft® Access, kan du åbne udvekslingsoversigten i dataarkvisning for at se oversigten over udvekslinger. Tabellen med udvekslingsoversigten er et skjult objekt. Du kan vise den i databasevinduet ved at markere afkrydsningsfeltet Systemobjekter under fanen Vis i dialogboksen Indstillinger, der er tilgængelig ved at vælge Indstillinger i menuen Funktioner.


Ingen replika blev synkroniseret inden for lagringsperioden for replikasæt. (Fejl 3743)

Hvis lagringsperioden udløber for en replika, kan du ikke synkronisere ændringer mellem de udløbne replika og de andre replika i replikasættet. Hvis en replika ikke synkroniserer med en anden replika i sættet inden for lagringsperioden, fjernes den fra replikasættet, næste gang du forsøger at synkronisere replikaen. Lagringsperioden fastlægges, når databasen gøres replikerbar fra start. Hvis du replikerer databasen ved hjælp af Replikastyring, Data Access Objects (DAO) eller ActiveX Data Objects (ADO), er standardlagringsperioden 60 dage. Hvis du replikerer databasen ved hjælp af Microsoft® Access eller Briefcase er standardlagringsperioden 1000 dage.


Indtastningen er ugyldig. Den kaskadevise handling, der er angivet i tabellen <navn>, kan ikke udføres, fordi den indtastede værdi er for stor til feltet <navn>. (Fejl 3411)

Du forsøger at gemme en værdi i et primær nøgle- felt, der er medtaget i en relation.

I Microsoft® Access markeres indstillingen Kaskadevis opdatering af relaterede felter for relationen. Eller i DAO-kode angives indstillingen dbRelationUpdateCascade for egenskaben Attributes til objektet Relation. Angivelse af en af disse indstillinger vil medføre, at programmet forsøger at opdatere det tilsvarende felt i den relaterede tabel.

Hvis du vil gemme ændringerne i dette felt, må den tekst, du skriver, ikke være længere end feltstørrelsen på det relaterede felt, som programmet forsøger at opdatere. I dette tilfælde har det relaterede felt en mindre feltstørrelse end det felt, du opdaterer. Hvis du vil undgå dette problem i fremtiden, skal du angive egenskaben Size for begge de tilsvarende felter til samme værdi.


Den kaskadevise handling kan ikke udføres. Det ville resultere i en nøgle med Null i tabellen <navn>. (Fejl 3399)

Den kaskadevise handling kan ikke udføres. Det ville resultere i en dubleret nøgle i tabellen <navn>. (Fejl 3399)

Den kaskadevise handling, du forsøger at udføre, vil resultere i en dubleret nøgle i den angivne tabel, der er indstillet til ikke at tillade dublerede primære nøgler. Undersøg de værdier, du forsøger at opdatere, og sørg for, at de ikke resulterer i dublerede nøgler.


Den kaskadevise handling udføres. Det ville resultere i en nøgle med Null i tabellen <navn>. (Fejl 3398)

Den kaskadevise handling kan ikke udføres. Det ville resultere i en nøgle med Null i tabellen <navn>. (Fejl 3398)

Den kaskadevise handling, du forsøger at udføre, vil resultere i en Null-værdi i et primært nøgle-felt i den angivne tabel, der er angivet til ikke at tillade Null-værdier. Undersøg de værdier, du forsøger at opdatere, og sørg for, at de ikke resulterer i Null-værdier.


Den kaskadevise opdatering af tabellen <navn> kan ikke udføres, fordi den er i brug. (Fejl 3414)

Den kaskadevise handling på tabellen <navn> kan ikke udføres, fordi den er i brug. (Fejl 3414)

Du forsøger at gemme en værdi i et primær nøgle- felt, der er medtaget i en relation.

I Microsoft® Access markeres indstillingen Kaskadevis opdatering af relaterede felter for relationen. Eller i DAO-kode angives indstillingen dbRelationUpdateCascade for egenskaben Attributes til objektet Relation. Programmet forsøger derfor at opdatere det tilsvarende felt i den relaterede tabel.

Det tilsvarende felt kan ikke opdateres, fordi du har åbnet eller låst det på computeren. Hvis du vil gemme posten, skal du først lukke den relaterede tabel.


Den kaskadevise handling kan ikke udføres. Det ville medføre, at feltet <navn> blev til en streng af længden nul, hvilket ikke er tilladt. (Fejl 3402)

Den kaskadevise handling kan ikke udføres. Det ville medføre, at feltet <navn> blev angivet til en streng af længden nul, hvilket ikke er tilladt. (Fejl 3402)

Den kaskadevise handling, du forsøger at udføre, vil resultere i en streng af længden nul i det angivne felt, der ikke tillader strenge af længden nul. Kontroller de værdier, du forsøger at opdatere, og sørg for, at de ikke resulterer i strenge af længden nul i dette felt.


Den kaskadevise handling kan ikke udføres. Det ville medføre, at feltet <navn> blev Null, hvilket ikke er tilladt. (Fejl 3401)

Den kaskadevise handling kan ikke udføres. Det ville medføre, at feltet <navn> blev angivet til Null, hvilket ikke er tilladt. (Fejl 3401)

Den kaskadevise handling, du forsøger at udføre, vil resultere i en Null-værdi i det angivne felt, der er angivet til ikke at tillade Null-værdier. Kontroller de værdier, du forsøger at opdatere, og sørg for, at de ikke resulterer i Null-værdier i dette felt.


Den kaskadevise handling kan ikke udføres. Den indtastede værdi tillades ikke af valideringsreglen <regel>, der er angivet for <navn>. (Fejl 3404)

Den kaskadevise handling, du forsøger at udføre, vil resultere i en ugyldig værdi i det angivne felt, som det fastlægges af feltets valideringsregel. Kontroller de værdier, du forsøger at opdatere, og sørg for, at de følger valideringsreglen.


Den kaskadevise handling kan ikke udføres: <Valideringstekst>. (Fejl 3403)

Den kaskadevise handling kan ikke udføres. <Valideringstekst>. (Fejl 3403)

Den kaskadevise handling, du forsøger at udføre, vil resultere i ugyldige data. Kontroller de værdier, du forsøger at opdatere, og sørg for, at de følger valideringsreglerne.


Den kaskadevise handling kan ikke udføres. Det ville resultere i to opdateringer af feltet <navn> i tabellen <navn>. (Fejl 3400)

Den kaskadevise handling, du forsøger at udføre, kan ikke udføres, da det vil resultere i to separate opdateringer af det angivne felt. Kontroller de værdier, du forsøger at opdatere, og sørg for enten at:

  • Feltet opdateres kun én gang.
  • Hvis feltet opdateres mere end én gang, er resultatet af hver opdatering af feltet det samme.


Den kaskadevise handling kan ikke udføres. Da der findes relaterede poster i tabellen <navn>, vil de referentielle integritetsregler blive overtrådt. (Fejl 3396)

Den kaskadevise handling, du forsøger at udføre, overtræder reglerne for referentiel integritet med den angivne tabel. Du skal undersøge de værdier, du forsøger at opdatere eller slette, og sørge for, at de er i overensstemmelse med reglerne for referentiel integritet.


Den kaskadevise handling udføres. Der skal være en relateret post i tabellen <navn>. (Fejl 3397)

Den kaskadevise handling kan ikke udføres. Der skal være en relateret post i tabellen <navn>. (Fejl 3397)

Den kaskadevise handling, du forsøger at udføre, overtræder reglerne for referentiel integritet, der kræver en relateret post i den angivne tabel. Undersøg de værdier, du forsøger at opdatere eller slette, og sørg for, at de er i overensstemmelse med reglen for referentiel integritet.


Den kaskadevise opdatering af tabellen kan ikke udføres, fordi den bruges af en anden bruger. (Fejl 3412)

Du forsøger at gemme en værdi i et primær nøgle- felt, der er medtaget i en relation.

I Microsoft® Access markeres indstillingen Kaskadevis opdatering af relaterede felter for relationen. Eller i DAO-kode angives indstillingen dbRelationUpdateCascade for egenskaben Attributes til objektet Relation. Programmet forsøger at opdatere det tilsvarende felt i den relaterede tabel.

Det tilsvarende felt kan ikke opdateres på grund af en låsekonflikt med en anden bruger. Hvis du vil gemme posten, skal du vente, indtil den relaterede tabel ikke længere er i brug.


Tilslutningsstrengen i videregivelsesforespørgslen er ugyldig. (Fejl 3305)

Tilslutningsstrengen til en videregivelsesforespørgsel skal begynde med "ODBC;".


ODBC: Dataene er blevet afkortet, fordi feltet ville blive for langt. (Fejl 3231)

Du har forsøgt at udføre en opgave på en ODBC-datakilde, der ville have medført et felt, der er for langt. Dataene er blevet afkortet til det maksimale tilladte længde.


ODBC: Tabellen kunne ikke oprettes. (Error 3232)

ODBC: Tabellen kunne ikke oprettes. (Fejl 3232)

Du har forsøgt at eksportere en tabel til en ODBC-database, men tabellen kunne ikke oprettes. Denne fejl kan opstå, hvis ODBC-databasen er skrivebeskyttet, eller du ikke har tilladelse til at oprette en tabel i den pågældende database. Fjern betingelsen for skrivebeskyttelse, eller kontakt systemadministratoren eller den person, der har oprettet databasen, for at få de nødvendige tilladelser.


ODBC: Sletningen lykkedes ikke i den sammenkædede tabel <tabel>. (Fejl 3156)

Du har ved hjælp af en ODBC-tilslutning forsøgt at slette data i en ODBC-database. Denne sletning kunne ikke udføres.

Mulige årsager:

  • Sletningen ville forårsage et brud på reglerne.
  • ODBC-databasen er skrivebeskyttet, eller du har ikke tilladelse til at slette data i den pågældende database. Fjern betingelsen for skrivebeskyttelse, eller kontakt systemadministratoren eller den person, der har oprettet databasen, for at få de nødvendige tilladelser.
  • ODBC-databasen findes på et netværksdrev, og netværket er ikke tilsluttet. Kontroller, at netværket er tilgængeligt, og forsøg derefter at udføre handlingen igen.


ODBC: Ikke alle posterne kan låses. (Fejl 3254)

Du har ved hjælp af en ODBC-tilslutning forsøgt at låse alle posterne i en ODBC-database.


Du kan ikke bruge ODBC til at importere fra, eksportere til eller sammenkæde en ekstern Microsoft Jet- eller ISAM-databasetabel med databasen. (Fejl 3423)

Du forsøger at sammenkæde, importere data fra eller eksportere data til enten en ekstern Microsoft Jet-tabel eller en ekstern ISAM-databasetabel (f.eks. dBASE, Microsoft® FoxPro®, Paradox eller Btrieve), men du har valgt <SQL-database> som datakilden. Du skal vælge den rette datakilde til de data, du forsøger at sammenkæde.


ODBC: Indsættelse lykkedes ikke i den sammenkædede tabel <tabel>. (Fejl 3155)

Du har ved hjælp af en ODBC-tilslutning forsøgt at indsætte data i en ODBC-database. Denne indsættelse kunne ikke udføres.

Mulige årsager:

  • Indsættelsen ville forårsage et brud på reglerne.
  • ODBC-databasen er skrivebeskyttet, eller du har ikke tilladelse til at indsætte data i den pågældende database. Fjern betingelsen for skrivebeskyttelse, eller kontakt systemadministratoren eller den person, der har oprettet databasen, for at få de nødvendige tilladelser.
  • ODBC-databasen findes på et netværksdrev, og du ikke er tilsluttet netværket. Kontroller, at netværket er tilgængeligt, og forsøg derefter at udføre handlingen igen.


ODBC: Tilslutningen til <navn> lykkedes ikke. (Fejl 3151)

Der kan ikke etableres en tilslutning til den angivne ODBC-database eller -tabel ved hjælp af ODBC. Hvis ODBC-databasen åbnes via en netværkstilslutning, skal du kontrollere, at netværket er tilgængeligt, og dernæst forsøge at udføre handlingen igen.


Forespørgslen kunne ikke køres. Den sammenkædede tabel blev ikke fundet. (Fejl 3184)

Mulige årsager:

  • Den sammenkædede tabel findes ikke længere eller er blevet omdøbt eller fjernet. Sammenkæd tabellen, og forsøg derefter at køre forespørgslen igen.
  • Den sammenkædede tabel findes på et netværksdrev, og du ikke er tilsluttet netværket. Kontroller, at netværket er tilgængeligt, og forsøg derefter at køre forespørgslen igen.


ODBC: Definitionen på den sammenkædede tabel er blevet ændret. (Fejl 3247)

Definitionen eller strukturen i en sammenkædet tabel er ændret, siden du oprettede kæden. Slet kæden, og sammenkæd tabellen igen.


ODBC: DLL'en <navn> blev ikke fundet. (Fejl 3154)

Du har ved hjælp af ODBC-tilslutning forsøgt at udføre en handling, der kræver den angivne DLL.

Mulige årsager:

  • .dll-filen findes på et netværksdrev, og netværket er ikke tilsluttet. Kontroller, at netværket er tilgængeligt, og forsøg derefter at udføre handlingen igen.
  • .dll-filen er ikke installeret korrekt. Geninstaller ODBC-driveren, og forsøg derefter at udføre handlingen igen.


Opdatering/sletning af en enkelt række påvirker mere end en række i en sammenkædet tabel. Indekset, der er angivet som unikt, indeholder dublerede værdier. (Fejl 3362)

Opdatering/sletning af en enkelt række påvirkede mere end en række i en sammenkædet tabel. Indekset, der er angivet som unikt, indeholder dublerede værdier. (Fejl 3362)

Opdaterings- eller slette -forespørgselen påvirkede mere end én post i den sammenkædede SQL-tabel. En opdaterings- eller sletteforespørgsel kan kun påvirke én post ad gangen.


Du skal bruge indstillingen dbSeeChanges med OpenRecordset ved adgang til en SQL Server-tabel, der har en IDENTITY-kolonne. (Fejl 3622)

Du skal bruge indstillingen dbSeeChanges med OpenDatabase ved adgang til en SQLServer-tabel, der har en IDENTITY-kolonne. (Fejl 3622)

De IDENTITY-værdier, der blev genereret af serveren, kan ikke afspejles på klientsiden, medmindre du bruger DAO-egenskaben dbSeeChanges.


ODBC: Timeout for fjernforespørgslen er udløbet. (Fejl 3234)

ODBC-serveren ikke er installeret korrekt, eller en obligatorisk netværkstilslutning ikke er aktiv. Prøv at forøge værdien af egenskaben QueryTimeout.


ODBC: Kaldet lykkedes ikke. (Fejl 3146)

Du har ved hjælp af ODBC-tilslutning forsøgt at udføre en handling på data i en ODBC-datakilde. Denne fejl kan opstå, når ODBC-datakilden er på et netværksdrev, og netværket ikke er tilsluttet. Kontroller, at netværket er tilgængeligt, og forsøg derefter at udføre handlingen igen.


Der er flere tabeller med dette navn. Du skal angive ejeren i formatet 'ejer.tabel'. (Fejl 3298)

Der er flere tabeller med det navn. Du skal angive ejeren med formatet 'ejer.tabel'. (Fejl 3298)

Der findes mere end én tabel med det samme navn i ODBC-fjerndatakilden. Hvis du vil fjerne tvetydigheden, skal du angive ejeren af den tabel, du vil have adgang til, ved hjælp af syntaksen ejer.tabel.


Sætningen SELECT INTO i en fjerndatabase prøvede at frembringe for mange felter. (Fejl 3185)

Microsoft Jet-databasen understøtter op til 255 felter pr. tabel, men den anden database understøtter færre felter. En SELECT...INTO-sætning har oprettet en tabel med flere felter, end fjerndatabasen kan understøtte. Reducer antallet af kolonner, der er frembragt af sætningen SELECT INTO, og forsøg derefter at udføre handlingen igen.


ODBC: Datatypen understøttes ikke på serveren. (Fejl 3235)

ODBC-serveren understøtter ikke de samme SQL-datatyper som databasemotoren eller programmet. Dataene er ikke placeret på serveren.


ODBC: Opdateringen lykkedes ikke i den sammenkædede tabel <tabel>. (Fejl 3157)

Du har ved hjælp af en ODBC-tilslutning forsøgt at opdatere data i en ODBC-database. Denne opdatering kunne ikke udføres.

Mulige årsager:

  • Opdateringen ville forårsage et brud på reglerne.
  • ODBC-databasen er skrivebeskyttet, eller du har ikke tilladelse til at opdatere data i den pågældende database. Fjern betingelsen for skrivebeskyttelse, eller kontakt systemadministratoren eller den person, der har oprettet databasen, for at få de nødvendige tilladelser.
  • ODBC-databasen findes på et netværksdrev, og netværket er ikke tilsluttet. Kontroller, at netværket er tilgængeligt, og forsøg derefter at udføre handlingen igen.


ODBC: Dataene er uden for området. (Fejl 3238)

Du har ved hjælp af en ODBC-tilslutning forsøgt at læse fra eller skrive til en ODBC-database, og dataene ligger ikke inden for de definerede grænser.


Den anmodede rækkelåsning kan ikke udføres, fordi DB er i sidelåsningstilstand. (Fejl 3751)

Denne fejl opstår, når en bruger angiver, at databasen skal åbnes i række/sidelåsningstilstand, men en anden bruger har allerede åbnet databasen kun i sidelåsningstilstand.


En regel kan ikke ændres, så længe reglerne for denne tabel er i brug. (Fejl 3302)

En post i denne tabel er blevet ændret af en anden bruger, eller den er blevet ændret af dig i en anden session i programmet, og er aktuelt låst. Du kan ikke ændre reglerne i en tabel, mens en post i den pågældende tabel er låst.

Hvis du har låst posten i en anden session, skal du gemme posten og derefter foretage ændringerne. Hvis en anden bruger har låst posten, skal du vente lidt og derefter gemme regelændringerne.


Synchronizer-programmet <navn> har samme filsystemrulleliste <navn>. (Fejl 3630)

Hver enkelt Synchronizer skal have en unik filsystemrulleliste. Hvis du bruger samme placering af rulleliste til flere Synchronizers, kan det medføre tab af meddelelser og ukomplette udvekslinger. Programmet kunne ikke oprette signalfilen, fordi den allerede er åbnet af en anden transport.


Der kan ikke gemmes, fordi den er låst af brugeren <navn> på maskinen <navn>. (Fejl 3186)

Mulige årsager:

  • Du har forsøgt at gemme en post på en databaseside på 2 KB, som en anden bruger i øjeblikket har låst. Vent, til den anden bruger er færdig med at arbejde med posten, og forsøg derefter at udføre handlingen igen.


Oversigten over designændringer i replikaen svarer ikke til oversigten i masterdesign. (Fejl 3524)

Synchronizerprogrammet kan ikke synkronisere de to medlemmer af replikasættet, fordi oversigten over design- eller skemaændringer er forskellig for hver replika. Uoverensstemmelsen i designoversigten kan være forårsaget af enten eksistensen af to masterdesign, eller fordi masterdesignet er gendannet fra en sikkerhedskopi, der er lavet for nogen tid siden.


Søgenøglen blev ikke fundet i posterne. (Fejl 3709)

Denne fejl opstår, når en ISAM SEEK udføres, og der ikke findes tilsvarende værdier i indekset.


Det valgte navn til systemobjektet er allerede i brug. (Fejl 3526)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


En relation kan ikke oprettes mellem et felt og feltet selv. (Fejl 3206)

Du har forsøgt at oprette en relation mellem et felt og feltet selv. Vælg et andet felt til den primære eller relaterede tabel, og forsøg derefter at udføre handlingen igen.


Jet SQL Server Reconciler - MSRPJT40.dll - kunne ikke indlæses. (Fejl 3775)

Jet SQL Server Reconciler - MSRPJT40.dll – kunne ikke indlæses. (Fejl 3775)

Du forsøger at udføre en handling mellem en Microsoft® Jet Subscriber og en SQL Publication. Filen msrpjt40.dll kunne ikke findes på den angivne sti eller er ikke registreret.


Der kan ikke opdateres, fordi den er låst af en anden session på denne maskine. (Fejl 3188)

Du har forsøgt at opdatere oplysninger, der i øjeblikket er låst af en anden session. Vent, til den anden session er færdig, eller luk den anden session, og forsøg derefter at udføre handlingen igen.


Foreningsforespørgsler er ikke tilladt i underforespørgsler. (Fejl 3361)

Du kan bruge en UNION-handling i en underforespørgsels udtryk. Hvis du vil bruge en foreningsforespøgsel i en underforespørgsel, skal du først oprette foreningsforespørgslen og gemme den som en navngivet forespørgsel. Du kan derefter medtage navnet på den gemte forespørgsel i underforespørgselsudtrykket.


Antallet af MS-DOS-fildelingslåse er overskredet. (Fejl 3052)

Antallet af MS-DOS-fildelingslåse er overskredet. Forøg registreringsnøglen MaxLocksPerFile. (Fejl 3052)

Du har overskredet det maksimale antal af tilladte låse på et postsæt. Denne grænse er angivet af indstillingen MaxLocksPerFile i systemets registreringsdatabase. Standardværdien er 9500, og den kan ændres enten ved at redigere registreringsdatabasen med Regedit.exe eller med metoden SetOption.

Andre faktorer, der kan bevirke, at et program når denne tærskel, kan være én af følgende:

  • Mængden af tilgængelig hukommelse.
  • Størrelsen af rækkerne i postsættet.
  • Restriktioner i netværksoperativsystemet.


Der opstod en delingsfejl under forsøg på at åbne logfilen <navn> i nægt skrivning-tilstand. (Fejl 3475)

Luk logfilen i alle andre programmer.


Kun simple SELECT-forespørgsler er tilladt i VIEWS. (Fejl 3766)

Denne fejl opstår, når du forsøger at oprette en visning fra SQL DDL. Fejlen opstår, når du forsøger at medtage parametre eller Sub Select-sætninger som del af visningsdefinitionen.


Du har skrevet en underforespørgsel, der kan returnere mere end et felt uden at bruge det reserverede ord EXISTS i hovedforespørgslens FROM-delsætning. Ret SELECT-sætningen i underforespørgslen for kun at anmode om ét felt. (Fejl 3306)

Du har skrevet en underforespørgsel, der kan returnere mere end et felt uden at bruge det reserverede ord EXISTS i hovedforespørgslens FROM-delsætning. Ret SELECT-sætningen i underforespørgslen, så den kun kræver et felt. (Fejl 3306)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Denne underforespørgsel returnerer maksimalt én post. (Fejl 3354)

En underforespørgsel af denne type kan ikke returnere mere end én post. Du kan redigere sætningen SELECT i underforespørgslen for kun at anmode om én post.


JET sorterings-DLL'er kunne ikke indlæses korrekt. (Fejl 3757)

JET sorterings-DLL’er kunne ikke indlæses korrekt. (Fejl 3757)

Microsoft® Jet bruger to sorterings-DLL’er til sammenligninger og indekseringer: MSWSTR10.DLL og MSWDAT10.DLL. Kontroller, at disse DLL’er findes i stien til indlæsning af DLL’er.

Hvis et andet program har slettet eller beskadiget DLL’erne, skal du geninstallere dem.


En kildestyret database kan ikke gøres replikerbar. (Fejl 3638)

Den database, du forsøger at replikere, styres af en database, der ikke understøtter replikering. Hvis du vil gøre databasen replikerbar, skal du sørge for, at den ikke styres af kildestyringsprogrammet.


De data, der eksporteres, passer ikke til det format, der er beskrevet i filen Schema.ini. (Fejl 3438)

Sørg for, at de data, der eksporteres, svarer til det format, der er beskrevet i Schema.ini-filen.


Tabellen <navn> kan ikke låses, fordi den anvendes af brugeren <navn> på maskinen <navn>. (Fejl 3212)

Tabellen kan ikke låses, fordi den er i brug. Vent, til den anden brugers transaktion er udført, og forsøg derefter at udføre handlingen igen.


Tabellen <navn> er låst med udelt adgang af brugeren <navn> på maskinen <navn>. (Fejl 3189)

Du kan ikke få adgang til den angivne tabel, fordi den er låst med udelt adgang af en anden bruger. Kontakt den anden bruger med udelt adgang, eller vent, til den anden bruger frigør låsen, og forsøg derefter at udføre handlingen igen.


En videregivelsesforespørgsel med egenskaben ReturnsRecords angivet til True returnerede ingen poster. (Fejl 3325)

En videregivelsesforespørgsel har ikke returneret poster, selvom egenskaben ReturnsRecords er angivet til True. Hvis en videregivelsesforespørgsel ikke returnerer poster, skal du angive egenskaben ReturnsRecords til False.


Det er en ugyldig SQL-syntaks - forventede token: ACTION. (Fejl 3762)

Det er en ugyldig SQL-syntaks – forventede token: ACTION. (Fejl 3762)

Denne fejl opstår, når du definerer referentiel integritet gennem syntaksen CREATE TABLE eller ALTER TABLE ALTER COLUMN. Den opstår, når det reserverede ord NO ikke efterfølges af det reserverede ord ACTION. Hvis du f.eks. udelader det reserverede ord BOLD ON, vil følgende syntaks generere fejlen:

CREATE TABLE Ordrespecifikationer (Ordreid LONG CONSTRAINT fkOrdrerOrdreid REFERENCES Ordrer (Ordreid) ON UPDATE CASCADE ON DELETE NO ACTION, LinjeElement LONG, Produktnr LONG CONSTRAINT fkProdukterProduktnr REFERENCES Produkter (Produktnr), Antal LONG);


Det er en ugyldig SQL-syntaks - forventede token: AS. (Fejl 3728)

Det er en ugyldig SQL-syntaks – forventede token: AS. (Fejl 3728)

Denne fejl opstår, når du definerer eller opretter en visning eller en procedure ved hjælp af SQL DDL. Fejlen genereres ved følgende syntaks: CREATE VIEW visningsnavn SELECT…. Undgå fejlen ved at ændre syntaksen til følgende: CREATE VIEW visningsnavn AS SELECT….


Der blev fundet tegn efter slutnignen af SQL-sætningen. (Fejl 3142)

Der blev fundet tegn efter slutningen af SQL-sætningen. (Fejl 3142)

Du har indtastet data efter brug af et semikolon (;) i SQL-sætningen. “SELECT * FROM tabel1; garbage” vil f.eks. generere denne fejl. Hvis du vil undgå denne fejl, skal du fjerne tegn, der følger efter semikolon (;).


Det er en ugyldig SQL-syntaks - forventede token: COMPRESSION efter WITH. (Fejl 3723)

Det er en ugyldig SQL-syntaks – forventede token: COMPRESSION efter WITH. (Fejl 3723)

Denne fejl opstår, når du bruger syntaksen CREATE TABLE eller ALTER TABLE ALTER COLUMN. Den opstår, når du refererer til en af NATIONAL CHARACTER-synonymerne for en kolonnetype, og du ikke bruger det reserverede ord COMPRESSION efter det reserverede ord WITH. Følgende er en gyldig SQL-sætning: CREATE TABLE foo (foo NCHAR WITH COMP);. Følgende SQL-sætning returnerer fejlen: CREATE TABLE foo (foo NCHAR WITH);.


Det er en ugyldig SQL-syntaks - forventede CONSTRAINT-navn. (Fejl 3721)

Det er en ugyldig SQL-syntaks – forventede CONSTRAINT-navn. (Fejl 3721)

Når du definerer referentiel integritet fra en SQL DDL-sætning, er det nødvendigt at navngive en begrænsning, når du bruger det reserverede ord CONSTRAINT. Hvis du ikke vil angive navnet på en begrænsning, kan du ikke bruge det reserverede ord CONSTRAINT. Et eksempel på denne fejl er: CREATE TABLE Kunder (CLstNm TEXT(50), CFrstNm TEXT(25), CONSTRAINT PRIMARY KEY (CFrstNm, CLstNm));.

Undgå fejlen ved at medtage et navn efter det reserverede ord CONSTRAINT:

CREATE TABLE Kunder (CLstNm TEXT(50), CFrstNm TEXT(25), CONSTRAINT pkKunder PRIMARY KEY (CFrstNm, CLstNm));.

eller ved at udelade det reserverede ord CONSTRAINT:

CREATE TABLE Kunder (CLstNm TEXT(50), CFrstNm TEXT(25), PRIMARY KEY (CFrstNm, CLstNm));.


Det er en ugyldig SQL-syntaks - forventede token: Database. (Fejl 3785)

Det er en ugyldig SQL-syntaks – forventede token: Database. (Fejl 3785)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Det er en ugyldig SQL-syntaks - forventede et databaseprivilegium, f.eks. CREATEDB eller CONNECT. (Fejl 3786)

Det er en ugyldig SQL-syntaks – forventede et databaseprivilegium, f.eks. CREATEDB eller CONNECT. (Fejl 3786)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Det er en ugyldig SQL-syntaks - forventede token: DEFAULT. (Fejl 3722)

Det er en ugyldig SQL-syntaks – forventede token: DEFAULT. (Fejl 3722)

Denne fejl opstår, når du bruger syntaksen ALTER TABLE ALTER COLUMN. Den opstår, hvis en af de følgende reserverede ord USER, NULL eller konstanttegn bruges uden at være efterfulgt af det reserverede ord DEFAULT.


Der er en syntaksfejl i DELETE-sætningen. (Fejl 3130)

Du har skrevet en SQL-sætning, der indeholder en ugyldig DELETE-sætning.

Mulige årsager:

  • Navnet på et reserveret ord eller argument er stavet forkert eller mangler.
  • Tegnsætningen er ikke korrekt.


Det er en ugyldig SQL-syntaks - forventede token: CASCADE, SET NULL eller NO ACTION. (Fejl 3725)

Det er en ugyldig SQL-syntaks – forventede token: CASCADE, SET NULL eller NO ACTION. (Fejl 3725)

Denne fejl opstår, når du definerer referentiel integritet gennem sætningen CREATE TABLE eller ALTER TABLE ALTER COLUMN. Fejlen opstår, når du bruger det reserverede ord UPDATE eller DELETE, og du ikke har angivet et af de følgende reserverede ord efter det: CASCADE, SET NULL, NO ACTION.


Det er en ugyldig SQL-syntaks - forventede token: NULL. (Fejl 3726)

Det er en ugyldig SQL-syntaks – forventede token: NULL. (Fejl 3726)

Denne fejl opstår, når du angiver en DDL-sætning, der er tilknyttet et indeks. Den kan opstå, når du ikke bruger det reserverede ord NULL efter følgende reserverede ord: CREATE INDEX, WITH PRIMARY eller IGNORE.


Der er en syntaksfejl i FROM-delsætningen. (Fejl 3131)

Du har skrevet en SQL-sætning, der indeholder en ugyldig FROM-sætning.

Mulige årsager:

  • Navnet på et reserveret ord eller argument er stavet forkert eller mangler.
  • Tegnsætningen er ikke korrekt.


Der er en syntaksfejl i GROUP BY-delsætningen. (Fejl 3132)

Du har skrevet en SQL-sætning, der indeholder en ugyldig GROUP BY-delsætning.

Mulige årsager:

  • Navnet på et reserveret ord eller argument er stavet forkert eller mangler.
  • Tegnsætningen er ikke korrekt.


Der er en syntaksfejl i HAVING-delsætningen. (Fejl 3133)

Du har skrevet en SQL-sætning, der indeholder en ugyldig HAVING-sætning.

Mulige årsager:

  • Navnet på et reserveret ord eller argument er stavet forkert eller mangler.
  • Tegnsætningen er ikke korrekt.


Der er en syntaksfejl i INSERT INTO-sætningen. (Fejl 3134)

Du har skrevet en SQL-sætning, der indeholder en ugyldig INSERT INTO-sætning.

Mulige årsager:

  • Navnet på et reserveret ord eller argument er stavet forkert eller mangler.
  • Tegnsætningen er ikke korrekt.


Videregivelsesforespørgslen skal indeholde mindst ét tegn. (Fejl 3359)

SQL-strengen i en videregivelsesforespørgsel skal indeholde mindst ét tegn.


Der er en syntaksfejl i JOIN-handlingen. (Fejl 3135)

Du har skrevet en SQL-sætning, der indeholder en ugyldig join-handling. Det kan være en indre joinforbindelse, ydre joinforbindelse eller selvjoinforbindelse.

Mulige årsager:

  • Navnet på et reserveret ord eller argument er stavet forkert eller mangler.
  • Tegnsætningen er ikke korrekt.


LEVEL-delsætningen indeholder et reserveret ord eller et argument, der er stavet forkert eller mangler, eller tegnsætningen er ikke korrekt. (Fejl 3136)

LEVEL-sætningen indeholder et reserveret ord eller et argument, der er stavet forkert eller mangler, eller tegnsætningen er ikke korrekt. (Fejl 3136)

Du har skrevet en SQL-sætning, der indeholder en ugyldig reserveret ord-delsætning.

Mulige årsager:

  • Navnet på et reserveret ord eller argument er stavet forkert eller mangler.
  • Tegnsætningen er ikke korrekt.


Der kan ikke orettes en relation til il sammenkædede ODBC-tabeller. (Fejl 3613)

Microsoft Jet-databasemotoren kan ikke oprette en relation i sammenkædede tabeller i ODBC-datakildetabeller.


Der mangler et semikolon (;) i slutningen af SQL-sætningen. (Fejl 3137)

SQL-sætningen indeholder flere ugyldige tokens efterfulgt af en SQL-sætning. “SELECT kol1 FROM tabel1 garbage” vil f.eks. returnere denne fejl. “SELECT kol1 FROM tabel1 garbage” er gyldig.


Det er en ugyldig SQL-syntaks. Kun én opdateringsregel og/eller sletteregel er tilladt. (Fejl 3727)

Denne fejl opstår, når du definerer referentiel integritet gennem SQL DDL. Den opstår, når du ikke bruger NULL eller DEFAULT efter det reserverede ord SET.


Der er en syntaksfejl i ORDER BY-delsætningen. (Fejl 3138)

Du har skrevet en SQL-sætning, der indeholder en ugyldig ORDER BY-delsætning.

Mulige årsager:

  • Navnet på et reserveret ord eller argument er stavet forkert eller mangler.
  • Tegnsætningen er ikke korrekt.


Der er en syntaksfejl i WITH OWNERACCESS OPTION-erklæringen. (Fejl 3257)

Mulige årsager:

  • Erklæringen WITH OWNERACCESS OPTION er ikke komplet eller indeholder et mellemrum mellem OWNER og ACCESS.
  • Erklæringen optræder et uventet eller ikke-tilladt sted i SQL-sætningen. For eksempel:

    SELECT * WITH OWNERACCESS OPTION FROM [Min tabel];

    Erklæringen WITH OWNERACCESS OPTION skal optræde i slutningen af SQL-sætningen, normalt efter delsætningen ORDER BY, hvis den findes:

    SELECT * FROM [Min tabel] WITH OWNERACCESS OPTION;


Der er en syntaksfejl i PARAMETER-delsætningen. (Fejl 3139)

Du har skrevet en SQL-sætning med en ugyldig PARAMETERS-erklæring.

Mulige årsager:

  • Navnet på et reserveret ord eller argument er stavet forkert eller mangler.
  • Tegnsætningen er ikke korrekt.


SQL-syntaksen er ugyldig - forventet token: Rettigheder. (Fejl 3688)

SQL-syntaksen er ugyldig – forventet token: Rettigheder. (Fejl 3689)

Denne fejl opstår, når de reserverede ord GRANT eller REVOKE bruges. En rettighed blev ikke angivet. Nogle gyldige rettigheder er SELECT, UPDATE, DELETE og INSERT.


Der er en syntaksfejl i PROCEDURE-delsætningen. (Fejl 3140)

Du har skrevet en SQL-sætning, der indeholder en ugyldig PROCEDURE-delsætning.

Mulige årsager:

  • Navnet på et reserveret ord eller argument er stavet forkert eller mangler.
  • Tegnsætningen er ikke korrekt.


Det er en ugyldig SQL-syntaks - forventede token: SELECT. (Fejl 3729)

Det er en ugyldig SQL-syntaks – forventede token: SELECT. (Fejl 3729)

Denne fejl opstår, når du forsøger at oprette en visning fra SQL DDL. Fejlen genereres ved følgende syntaks: CREATE VIEW visningsnavn AS. Undgå fejlen ved at bruge en gyldig SELECT-sætning efter det reserverede ord AS.


SELECT-sætningen indeholder et reserveret ord eller argument, der er stavet forkert eller mangler, eller tegnsætningen er ikke korrekt. (Fejl 3141)

Du har skrevet en SQL-sætning, der indeholder en ugyldig SELECT-sætning.

Mulige årsager:

  • Navnet på et reserveret ord eller argument er stavet forkert eller mangler.
  • Tegnsætningen er ikke korrekt.


Det er en ugyldig SQL-sætning. 'DELETE', 'INSERT', 'PROCEDURE', 'SELECT' eller 'UPDATE' var ventet. (Fejl 3129)

SQL-sætningen blev ikke genkendt, fordi den ikke begynder med et af de angivne reserverede ord.


Der er en syntaksfejl i TRANSFORM-sætningen. (Fejl 3143)

Du har skrevet en SQL-sætning, der indeholder en ugyldig TRANSFORM-sætning.

Mulige årsager:

  • Navnet på et reserveret ord eller argument er stavet forkert eller mangler.
  • Tegnsætningen er ikke korrekt.


Der er en syntaksfejl i foreningsforespørgslen. (Fejl 3319)

Der er en syntaksfejl i en SQL-streng i foreningsforespørgslen.

Mulige årsager:

  • Navnet på et reserveret ord eller argument er stavet forkert.
  • Der mangler et reserveret ord eller et argument.
  • Tegnsætningen er ikke korrekt.


Det er en ugyldig SQL-syntaks - forventede token: UPDATE eller DELETE. (Fejl 3724)

Det er en ugyldig SQL-syntaks – forventede token: UPDATE eller DELETE. (Fejl 3724)

Denne fejl opstår, når du definerer referentiel integritet gennem sætningen CREATE TABLE eller ALTER TABLE ALTER COLUMN. Denne fejl opstår, når du bruger det reserverede ord CASCADE, og du ikke har angivet det reserverede ord UPDATE eller DELETE foran det.


Der er en syntaksfejl i UPDATE-sætningen. (Fejl 3144)

Du har skrevet en SQL-sætning, der indeholder en ugyldig UPDATE-sætning.

Mulige årsager:

  • Navnet på et reserveret ord eller argument er stavet forkert eller mangler.
  • Tegnsætningen er ikke korrekt.


Det er en ugyldig SQL-syntaks - forventede et visningsnavn. (Fejl 3780)

Det er en ugyldig SQL-syntaks – forventede et visningsnavn. (Fejl 3780)

Denne fejl opstår, når du forsøger at oprette eller slette en visning ved hjælp af SQL DDLs syntaks CREATE VIEW eller DROP VIEW. Den opstår, hvis der ikke angives et gyldigt navn. Fejlen genereres f.eks. med følgende sætning: CREATE VIEW AS SELECT * FROM tabel1.


Der er en syntaksfejl i WHERE-delsætningen. (Fejl 3145)

Du har skrevet en SQL-sætning, der indeholder en ugyldig WHERE-delsætning.

Mulige årsager:

  • Navnet på et reserveret ord eller argument er stavet forkert eller mangler.
  • Tegnsætningen er ikke korrekt.


'*' kan ikke bruges i en krydstabuleringsforespørsel. (Fejl 3123)

'*' kan ikke bruges i en krydstabuleringsforespørgsel. (Fejl 3123)

Du har forsøgt at køre en forespørgsel, der grupperer eller sammentæller felter, der er markeret med en stjerne ( * ). Vælg bestemte felter, og forsøg derefter at udføre handlingen igen.


Der kan ikke grupperes på felter, der er markeret med '*'. (Fejl 3121)

Der kan ikke grupperes efter felter, der er markeret med '*'. (Fejl 3121)

Du har forsøgt at køre en SELECT-sætning, der grupperer eller sammentæller alle felter fra alle de tabeller, der er markeret med en stjerne ( * ).

Mulig årsag:

  • Du har oprettet en SQL-sætning, der indeholder en aggregatfunktion eller en GROUP BY-delsætning, der refererer til et felt, du har markeret med en stjerne. Denne fejl opstår, hvis du f.eks. skriver følgende SQL-sætning:

    SELECT * FROM Ordrer GROUP BY Speditionsfirma;


Databasen er indstillet i en tilstand af brugeren <navn> på maskinen <navn>. Dette forhindrer, at databasen kan åbnes eller låses. (Fejl 3734)

Denne fejl opstår, når den nye passive lukning/tilslutningsstyring er i brug. Denne fejlmeddelelse angiver, at en bruger har indstillet databasen til en tilstand, der forhindrer andre brugere i at åbne den.


Databasen er indstillet i en tilstand af en ukendt bruger. Dette forhindrer, at databasen kan åbnes eller låses. (Fejl 3733)

Denne fejl opstår, når den nye passive lukning/tilslutningsstyring er i brug. Denne fejl angiver, at en anden bruger har indstillet databasen til en tilstand, der forhindrer andre brugere i at åbne den. Den er forbundet med fejl nr. 3734 og bruges, når Microsoft® Jet ikke kan afgøre, hvilken bruger der har fremkaldt den passive lukning/tilslutningsstyring.


Objektet <navn> er ikke en lagret procedure. (Fejl 3750)

Denne fejl opstår, når du bruger det reserverede ord EXECUTE og enten overfører et navn på en procedure eller en visning, der ikke findes i databasen, eller overfører navnet på en basistabel.


Der er ingen passende replika at udveksle med. (Fejl 3684)

Der er ingen passende replikaer at synkronisere med den angivne HTTP-adresse.


Synkronisering med en ikke-replikeret database er ikke tilladt. <navn>-databasen er ikke et masterdesign eller en replika. (Fejl 3605)

Synkronisering med en ikke-replikeret database er ikke tilladt. Databasen <navn> er ikke et masterdesign eller en replika. (Fejl 3605)

Du forsøger at synkronisere en replikeret database med en ikke-replikeret database eller synkronisere to ikke-replikerede databaser. Kun replikaer, der er oprettet på basis af den samme replikerede database, kan synkroniseres.

Hvis en af databaserne allerede er replikeret, kan du bruge den til at oprette en anden databasereplika.

Hvis ingen af databaserne er replikeret, skal du markere den af databaserne, der skal bruges som masterdesign for replikasættet. Åbn den pågældende database ved hjælp af Microsoft® Access, og vælg kommandoen Opret replika i Replikering i menuen Funktioner. Hvis Microsoft Access ikke er tilgængelig, men Microsoft Windows® 95 Rejsetaske er tilgængelig, skal du trække databasen til Rejsetaske for at oprette en replika. Du skal ikke forsøge at replikere den anden af to oprindelige databaser og derefter synkronisere de to databaser. Den anden database skal være en replika, der er baseret på den første, for at synkroniseringen lykkes.


Synchronizer-programmet <navn> har samme filsystemrulleliste <navn>. (Fejl 3629)

Hver enkelt Synchronizer skal have en unik filsystemrulleliste. Hvis du bruger samme placering af rulleliste til flere Synchronizers, kan det medføre tab af meddelelser og ukomplette udvekslinger.

Signalfilen kunne ikke oprettes. Den er allerede åbnet af en anden transport.


Der er en syntaksfejl i forespørgslen. Parameterværdi. (Fejl 3746)

Denne fejl kan opstå, når:

  • Der bruges en ugyldig parameter sammen med parameterforespørgslerne/procedurerne.
  • En procedure og den navngivne parameter indledes ikke af symbolet @.
  • Der er overført en ugyldig parameter efter symbolet @.
  • Der er ikke angivet et lighedstegn (=) efter en parameter.
  • Reserverede ord bruges som parametre uden de rette escape-tegn.


Der er en syntaksfejl i TRANSACTION-sætningen. (Fejl 3708)

Der er en syntaksfejl i TRANSACTION-sætningen. TRANSACTION, WORK eller intet var ventet. (Fejl 3708)

Når du udelukkende bruger transaktioner i Microsoft® Jet (ikke i en objektmodel som DAO eller ADO), skal følgende syntaks anvendes: BEGIN/ROLLBACK TRANSACTION, WORK eller intet. Hvis der står andre tegn efter BEGIN eller ROLLBACK, opstår denne fejl.


Microsoft Jet-arbejdsgruppeoplysningsfilen i databasemotoren kan ikke åbnes. (Fejl 3358)

Du har forsøgt at udføre en sikkerhedsrelateret opgave, men den arbejdsgruppeoplysningsfil (typisk System.mdw), der kræves til opgaven, kan ikke findes.


Microsoft Jet-databasemotoren kunne ikke læse systemuret på computeren. (Fejl 3515)

Microsoft Jet-databasemotoren bruger computerens systemur til visse interne processer. Den forsøgte at læse computerens ur, men kunne ikke. Luk computeren ned, og genstart den.


Det systemobjekt, der bruges af en proces, findes stadig efter at processen er ophørt. (Fejl 3533)

Det systemobjekt, der bruges af en proces, findes stadig efter processen er ophørt. (Fejl 3533)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Systemtabellen <navn> til replikering kan ikke åbnes, fordi tabellen allerede er i brug. (Fejl 3581)

Den systemtabel, der er nødvendig for at udføre denne handling, er allerede i brug. Vent nogle få minutter, og forsøg derefter at udføre handlingen igen.


Regnearksceller kan ikke slettes. (Fejl 3435)

Regnearkceller kan ikke slettes. (Fejl 3435)

Du kan ikke slette data i det angivne celleområde i regneark. Disse celler kan indeholde formularer, eller de kan være beskyttede celler.


Tabellen <navn> findes allerede. (Fejl 3010)

Du har forsøgt at oprette eller omdøbe en tabel med et navn, der allerede findes i denne database. Vælg et andet navn, og forsøg derefter at udføre handlingen igen.

I en flerbrugerdatabase kan denne fejl også opstå, hvis du sletter en tabel, og en anden bruger opretter en tabel med det samme navn, samt du derefter forsøger at annullere sletningen af din tabel. Hvis du vil gendanne tabellen, skal den anden bruger først slette eller omdøbe den nye tabel, før du forsøger at annullere handlingen igen.


Tabellen <navn> er allerede åbnet med udelt adgang af en anden bruger, eller den er allerede åbnet i en anden brugerflade og kan ikke manipuleres ved hjælp af programkode. (Fejl 3008)

Tabellen <navn> er allerede åbnet med udelt adgang af en anden bruger, eller den er allerede åben i en anden brugerflade og kan ikke manipuleres ved hjælp af programkode. (Fejl 3008)

Du har forsøgt at bruge en tabel, der i øjeblikket er åbnet med udelt adgang af en anden bruger, eller du har via programmering forsøgt at manipulere en tabel, der er åbnet gennem brugerfladen. Angiv den ønskede betingelse, og forsøg derefter at udføre handlingen igen.


Det navngivne område kan ikke udvides. (Fejl 3434)

Du har fundet celler med værdier, mens du har forsøgt at føje rækker til et navngivet område i Microsoft® Excel version 5.0. Disse celler kan ikke overskrives ved hjælp af en tilføjelseshandling.


Tabellen <navn> kan ikke låses, fordi den anvendes af brugeren <navn> på maskinen <navn>. (Fejl 3262)

Filen kunne ikke låses. (Fejl 3262)

Du har forsøgt at låse en tabel, under åbningen af den, men tabellen kan ikke låses, fordi den i øjeblikket er i brug. Vent et øjeblik, og forsøg derefter at udføre handlingen igen.


Databasemotoren kunne ikke låse tabellen <navn>, fordi den allerede er låst af en anden person eller proces. (Fejl 3211)

Hvis du vil udføre denne handling, skal en tabel, der i øjeblikket bruges af en anden bruger, være låst. Vent, til den anden bruger er færdig med at arbejde med tabellen, og forsøg derefter at udføre handlingen igen.


Tabellen <navn> er låst med udelt adgang af brugeren <navn> på maskinen <navn>. (Fejl 3261)

Du har forsøgt at benytte en tabel, som en bestemt bruger i øjeblikket har åben med udelt adgang. Vent, til den anden bruger er færdig med at arbejde med tabellen, og forsøg derefter at udføre handlingen igen.


Handlingen understøttes ikke i en tabel, der indeholder data. (Fejl 3282)

Du kan ikke føje et felt til eller oprette et indeks i en sammenkædet tabel, der indeholder data. Når en tabel er udfyldt med data, kan du ikke ændre tabellens udformning eller indeks. Opret en ny tabel med den ændrede udformning, og overfør dataene til denne tabel ved hjælp af en handlingsforespørgsel.


Tabelstrukturen kan ikke ændres. En anden bruger har åbnet tabellen. (Fejl 3422)

Microsoft Jet-databasemotoren kan ikke redigere strukturen i en tabel, da en anden bruger I øjeblikket har tabellen åben. Vent, indtil tabellen er lukket, og forsøg derefter at foretage ændringerne igen.


Tabellen er ikke åben. (Fejl 3160)

Du har forsøgt at udføre en handling i en tabel, der ikke er åben. Åbn tabellen, og forsøg derefter at udføre handlingen igen.


Tabellen <navn> kunne ikke gøres replikerbar, fordi den ikke kan åbnes med udelt adgang. (Fejl 3767)

Luk alle åbne instanser i den tabel, som du forsøger at replikere, og forsøg derefter igen.


Tabelnavnet <navn> kan ikke gentages i FROM-delsætningen. (Fejl 3074)

Du kan ikke angive tabelnavnet mere end en gang. Fjern de ekstra forekomster af tabelnavnet, eller brug et alias. Hvis du forsøger at joinforbinde en tabel til sig selv, skal du benytte et alias for at ændre den anden reference til tabellen.


Der er for mange klientopgaver. (Fejl 3053)

Du har for mange kopier af Microsoft® Visual Basic® eller Visual Basic-programmer kørende samtidig. Luk en eller flere forekomster.


Der opstod en disk I/O-fejl under læsning af eller skrivning til Temp-biblioteket. (Fejl 3572)

Der opstod en disk I/O-fejl under læsning eller skrivning til Temp-biblioteket. (Fejl 3572)

Der opstod et problem under adgang til Temp-biblioteket på computeren. Kontroller, at stien til Temp-biblioteket et angivet korrekt.


Der er ikke tilstrækkelig plads på den midlertidige disk. (Fejl 3183)

Du har forsøgt at udføre en handling, der kræver mere plads end det, der er tilgængelig på den midlertidige disk. Placeringen af den midlertidige disk er baseret på miljøvariablen TEMP DOS, som blev angivet, da systemet blev startet.

Du forsøger f.eks. at oprette en forespørgsel, der opretter midlertidige filer, som er større end den midlertidige disk. Du skal enten gøre de midlertidige filer mindre ved at åbne et mindre antal data ad gangen eller den midlertidige disk større.

Du kan forøge den tilgængelige midlertidige diskplads på forskellige måder:

  • Vælg færre poster. Recordset-objekter af typen dynamisk udvalg og snapshot samt fremadrullende Recordset-objekter registrerer nøgler og data på den midlertidige disk.
  • Vælg et andet drev til den midlertidige disk.
  • Hvis den midlertidige disk er en RAM-disk, skal du gøre disken større eller flytte den til en fast disk.
  • Frigiv plads ved at slette data eller ved at fjerne unødvendige tabeller, forespørgsler, formularer, makroer og moduler fra databasen.
  • Frigiv plads ved at komprimere slettede poster fra databasen.
  • Hvis du har brug for mere plads, skal du overveje at fjerne andre filer, der ikke benyttes, fra disken.


Hentebufferen var for lille til antallet af ønskede data. (Fejl 3640)

Under udførelse af en GetRows- eller GetRowsEx-metode var hentebufferen for lille til at indeholde de angivne rækker.


Den sprogspecifikke tegntabel var ikke angivet eller blev ikke fundet. (Fejl 3649)

Du har forsøgt at åbne en database, der er oprettet med et sprog, der ikke er installeret på computeren. Du skal bestemme, hvilket sprog der er angivet til denne database, da den blev oprettet, og derefter sørge for, at det pågældende sprog er installeret på systemet. Hvis databasen er oprettet med DAO, er sproget angivet med argumentet for landestandarder til metoden CreateDatabase. Hvis databasen er blevet oprettet med Microsoft® Access, er sproget angivet med indstillingen "Sorteringsrækkefølge for nye databaser" under fanen Generelt i dialogboksen Indstillinger, der er tilgængelig ved at vælge Indstillinger i menuen Funktioner.

Sprog kan føjes til systemet ved hjælp af indstillingerne i International i Kontrolpanel.


Der er færre poster tilbage i postsættet, end du anmodede om. (Fejl 3641)

Slutningen af postsættet er nået.


Den angivne rækkelængde er kortere end summen af kolonnelængderne. (Fejl 3646)

Parameteren til rækkelængden angav ikke tilstrækkeligt plads til kolonnebindingen.


Databasemotoren genkender hverken feltet <navn> i valideringsudtrykket eller standardværdien i tabellen <navn>. (Fejl 3344)

Udtrykket refererer ukorrekt til et felt, eller det refererer til et felt, der ikke findes. Undersøg, om feltnavnet er gyldigt og korrekt stavet.


Det udtryk, du forsøger at bruge til egenskaben DefaultValue, er ugyldig, fordi <fejltekst>. Brug et gyldigt udtryk til at angive denne egenskab. (Fejl 3406)

Det udtryk, du forsøger at bruge på egenskaben DefaultValue, er ugyldigt, fordi <fejltekst>. Brug et gyldigt udtryk til at angive egenskaben. (Fejl 3406)

Det udtryk, du forsøger at bruge på egenskaben DefaultValue, er ugyldigt. Angiv egenskaben til et gyldigt udtryk.


Fejl <fejltekst> i valideringsregel. (Fejl 3405)

Udtrykket kan ikke udregnes korrekt af den grund, der angives i advarslen. Hvis fejlmeddelelsen f.eks. er "Typerne passer ikke sammen", svarer egenskabsindstillingen ikke til den datatype, der er defineret til feltet.


<Fejl> i et valideringsudtryk på tabelniveau. (Fejl 3320)

Der er opstået en fejl i et udtryk for en valideringsregel på tabelniveau eller i standardværdiudtrykket. Dette kan være en syntaksfejl eller en anden slags fejl.


Der er en ukendt funktion <navn> i valideringsudtrykket eller standardværdien i <navn>. (Fejl 3388)

Den funktion, du refererer til, er enten ukendt (da navnet er ugyldigt eller stavet forkert) eller en funktionstype, der ikke tillades af egenskaben ValidationRule eller DefaultValue. Blandt de funktionstyper, der ikke er tilladt, er brugerdefinerede SQL-aggregatfunktioner


Valideringsudtrykket kan ikke bruges på dette felt. (Fejl 3313)

Du forsøger at angive valideringsegenskaber på et felt (f.eks. et felt af typen AutoNumber eller OLE Object), der ikke tillader denne egenskabstype. Brug et andet felt til at validere data eller, hvis du ikke har føjet data til tabellen, definer datatypen til feltet igen.


Valideringsregler og standardværdier kan ikke bruges på systemtabeller eller sammenkædede tabeller. (Fejl 3312)

Du forsøger at angive egenskaben DefaultValue, ValidationRule, ValidationText eller Required i en tabel, et felt eller et andet objekt, der ikke tillades af programmet. Du angiver f.eks. en egenskab i et systemobjekt.


Feltet <navn> kan ikke være en streng af længden nul. (Fejl 3315)

Feltet <navn> kan ikke indeholde en streng af længden nul. (Fejl 3315)

Egenskaben AllowZeroLength til dette felt er angivet til False, hvilket ikke tillader indtastningen af en streng af længden nul i feltet. Indtast en anden værdi i feltet.


Feltet <navn> kan ikke indeholde en Null-værdi, fordi egenskaben Required til dette felt er angivet til True. Indtast en værdi i dette felt. (Fejl 3314)

Egenskaben Required til dette felt er angivet til True, hvilket ikke tillader en indtastning af Null i dette felt. Indtast en værdi i feltet.


<valideringstekst på tabelniveau>. (Fejl 3316)

<Valideringsmeddelelse på tabelniveau>. (Fejl 3316)

En valideringsregel på tabelniveau er overtrådt.


En eller flere værdier er forbudt af valideringsregelen <regel>, der er angivet for <navn>. Indtast en værdi, som udtrykket for dette felt kan acceptere. (Fejl 3317)

En eller flere indtastede værdier tillades ikke af valideringsreglen <regel>, der er angivet for <navn>. Skriv en værdi, som udtrykket for dette felt kan acceptere. (Fejl 3317)

Egenskaben ValidationRule til dette felt indeholder et udtryk, der begrænser de værdier, som kan indtastes i feltet. Du skal indtaste en værdi, der tillades af udtrykket.


TLV-fejl. (Fejl 3716)

Denne post indeholder en feltværdi, der ikke overholder valideringsbegrænsningen på tabelniveau. Opdater enten den feltværdi, der overtræder valideringsreglen, og send derefter denne konfliktpost igen, eller slet den.


Der er for mange aktive brugere. (Fejl 3239)

I et flerbrugermiljø understøtter Microsoft Jet-databaser op til 255 aktive brugere. Vent, til en eller flere af brugerne er færdige med at bruge systemet, og forsøg derefter at udføre handlingen igen.


Synchronizer kan ikke initialiseres, fordi der kører for mange programmer. (Fejl 3538)

Der er ikke nok systemressourcer tilgængelig til at køre alle de åbne programmer og til at starte Synchronizer. Luk et eller flere programmer ned, og prøv igen.


Der er defineret for mange felter. (Fejl 3190)

Du har forsøgt at udføre en handling, der medtager mere end 255 felter. Reducer antallet af felter, og forsøg derefter at udføre handlingen igen.


Der er kaldt for mange FastFind-sessioner. (Fejl 3408)

DAOs FIND-metode kan kun udføres én gang i en tabel eller et postsæt.


Indekset kunne ikke oprettes. Der er allerede defineret for mange indeks. (Fejl 3039)

Du kan ikke oprette et andet indeks til denne tabel. Overvej at slette et eksisterende indeks for at skabe plads til det nye indeks. Grænsen er 32 indeks pr. tabel.


Handlingen lykkedes ikke. Der er for mange indeks til tabellen <name>. Slet nogle af indeksene til tabellen, og prøv at udføre handlingen igen. (Fejl 3626)

Handlingen lykkedes ikke. Der er for mange indeks til tabellen <navn>. Slet nogle af indeksene til tabellen, og prøv at udføre handlingen igen. (Fejl 3626)

En tabel i en Microsoft Jet-database kan højst indeholde 32 indeks. Du kan ikke oprette ekstra indeks i en tabel med så mange indeks. Derudover kan du ikke komprimere en database, der indeholder en tabel med så mange indeks, fordi komprimering af en database omfatter oprettelse af flere nye indeks.

Slet et eller flere indeks fra den navngivne tabel, og forsøg at udføre handlingen igen.


Et indeks kan ikke have mere end ti felter. (Fejl 3277)

Du har defineret et indeks med mere end ti felter. Reducer antallet af felter til ti eller mindre.


Der er for mange felter af typen Memo eller OLE Object. (Fejl 3054)

Der er for mange felter af typen Memo, OLE Object eller Hyperlink Object. (Fejl 3054)

Du har forsøgt at udføre en Btrieve-handling, der omfatter for mange felter af typen Memo eller OLE Object. Reducer antallet af felter af typen Memo og OLE Object, og forsøg derefter at udføre handlingen igen.


Der kan ikke åbnes flere databaser. (Fejl 3048)

Der kan ikke åbnes flere tabeller. (Fejl 3048)

Du har nået grænsen for, hvor mange databaser der kan være åbne samtidigt. Luk en eller flere databaser, og forsøg derefter at udføre handlingen igen.


Der kan ikke åbnes flere filer. (Fejl 3025)

Du har nået grænsen for, hvor mange filer der kan være åbne samtidigt. Luk en eller flere filer, og forsøg derefter at udføre handlingen igen.


Der kan ikke åbnes flere tabeller. (Fejl 3014)

Du har nået grænsen for, hvor mange tabeller der kan være åbne samtidigt. Luk en eller flere tabeller, og forsøg derefter at udføre handlingen igen.


Sessionen kunne ikke startes. Der er allerede for mange aktive sessioner. (Fejl 3198)

Du har forsøgt at udføre en handling, der ville have startet en ny session, men der er allerede for mange aktive sessioner. Vent, til en eller flere sessioner er afsluttet, og forsøg derefter at udføre handlingen igen.


Det lykkedes ikke at indlæse et DLL-bibliotek. (Fejl 3462)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Synchronizer kører allerede. (Fejl 3544)

Kun én forekomst af Synchronizer kan køre ad gangen. Brug det Synchronizer-program, der aktuelt kører, i stedet for at starte et andet Synchronizer-program på denne computer.


Synchronizer kan ikke slette en fil. (Fejl 3568)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Synchronizer kan ikke åbne logfilen til Synchronizer. (Fejl 3506)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Synchronizer har søgt efter en systemhændelse, men fandt ingen at rapportere til klienten. (Fejl 3534)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Synchronizer kunne ikke initialiseres. (Fejl 3532)

Det er ikke muligt at starte Synchronizer. Luk computeren ned, og genstart den. Hvis fejlen forsat findes, skal du konfigurere Synchronizer igen.

Sådan konfigureres Synchronizer

  1. Start Replikastyring.
  2. Vælg Konfigurer Microsoft Replikastyring i menuen Funktioner.
  3. Følg instruktionerne i guiden.


Synchronizer er ikke konfigureret. (Fejl 3543)

Synchronizer er ikke konfigureret på computeren.

Sådan konfigureres Synchronizer

  1. Start Replikastyring.
  2. Vælg Konfigurer Microsoft Replikastyring i menuen Funktioner.
  3. Følg instruktionerne i guiden.

Hvis du bruger et program fra andre computerproducenter, skal du få installationsdisken til Synchronizer fra den udvikler, der understøtter programmet.


Synchronizer betjener allerede en klient. (Fejl 3530)

Du forsøger at starte et andet klientprogram til Synchronizer, men Synchronizer-programmet kan kun køre ét klientprogram ad gangen. Identificer det program eller den bruger, der allerede bruger et Synchronizer-program, og luk programmet.


Synchronizer kunne ikke lukkes korrekt ned og er stadig aktiv. (Fejl 3541)

En programmeringsmæssig anmodning om at afslutte Synchronizer er ikke udført korrekt, og Synchronizer kører stadig i baggrunden.

Sådan afsluttes Synchronizer

  1. Tryk på CTRL+ALT+DELETE for at vise dialogboksen Luk program.
  2. Marker Synchronizer.
  3. Klik på Afslut job.


Det lykkedes ikke at sende en meddelelse. (Fejl 3519)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Transaktionen kunne ikke startes. For mange transaktioner er allerede indlejret. (Fejl 3003)

Du har forsøgt at indlejre en transaktion, der er mere end fem niveauer dyb. Brug metoden CommitTrans eller Rollback til at gemme den aktuelle transaktion eller annullere den, før du starter en anden.


Datatyperne stemmer ikke overens i kriterieudtrykket. (Fejl 3464)

Kriterieudtrykket i en Find-metode forsøger at sammenligne et felt med en værdi, hvor datatyperne ikke stemmer overens med feltets datatype.


Det er ikke muligt at angive en tidsplan for Synchronizer. (Fejl 3497)

Der er opstået et internt problem i forbindelse med indstilling af tidsplanen. Forsøg igen.


Der kan ikke joinforbindes mere end en tabel med samme navn <navn>. (Fejl 3081)

Du har forsøgt at joinforbinde to eller flere tabeller med samme navn. Marker forskellige tabeller, omdøb en af tabellerne, eller brug et alias, og forsøg derefter at udføre handlingen igen. Hvis du forsøger at joinforbinde en tabel til sig selv, skal du bruge et tabelalias for at ændre den anden reference til tabellen.


Der opstod en uventet fejl i den eksterne databasedriver <fejlnummer>. (Fejl 3275)

Den angivne eksterne databasedriver har returneret en fejl. Denne fejl kan skyldes en handling, der ikke understøttes i denne type ekstern database.


Der er opstået en entydig nøglefejl. (Fejl 3715)

Denne post har samme nøgleværdi som en anden post. Kun entydige værdier er tilladte. Du skal enten ændre nøgleværdien i denne konfliktpost eller i den vindende post og derefter sende denne post igen, eller slette konfliktposten.


Navnet er ukendt. (Fejl 2424)

Du har skrevet et udtryk, der har et felt- eller et egenskabsnavn, der ikke kan genkendes. Sørg for, at objektet findes, eller kontroller udtrykket for at sikre, at du har indtastet det korrekt.


Der er en ukendt funktion i det delvise filterudtryk. (Fejl 3589)

Sørg for, at du benytter det korrekte navn på funktionen. Bemærk også, at ikke alle funktioner er gyldige i filterudtryk.


Der er et ugyldigt udtryk i egenskaben ReplicaFilter. (Fejl 3587)

Strengen ReplikaFilter indeholder et ugyldigt ord. Kontroller syntaksen for eventuelle stavefejl eller manglende ord.


Funktionsnavnet er ukendt. (Fejl 2425)

Du har indtastet et udtryk med et funktionsnavn, der ikke kan genkendes. Sørg for, at funktionen findes, eller kontroller udtrykket for at sikre, at du har indtastet det korrekt.


Der er en syntaksfejl. (Fejl 2433)

Formuleringen eller tegnsætningen i kommandoen er ikke korrekt. Der mangler måske en operator, eller du kan have angivet en operator, der ikke findes.


Feltnavnene fra den første række i importtabellen kan ikke opdeles. (Fejl 3245)

Den første række data indeholder ugyldige feltnavne, f.eks. strenge med og uden anførselstegn i det samme feltnavn. I følgende eksempel kan tredje og fjerde feltnavn ikke opdeles:

"Navn", Dato, "Id " Nummer, Telefon" Nummer"

De første to felter er gyldige, men det tredje og fjerde felt er ugyldige, fordi de indeholder tegn, der ikke er mellemrumstegn, uden for anførselstegnene.

Kontroller, at anførselstegnene i importtabellen stemmer overens, og forsøg derefter at udføre importhandlingen igen.


Opdater/opdater-konflikt. (3713)

Opdater/opdater-konflikt. En anden replika har også opdateret denne post. Denne post tabte konflikten. Send enten opdateringen igen, eller slet denne konfliktpost. (Fejl 3713)

Denne post indeholder en feltværdi, der tabte i konflikten med en anden replika. Send enten denne konfliktpost eller slet den.


Update/Delete-konflikt. Den opdaterede post blev slettet ved en anden replika. (Fejl 3736)

Update/Delete-konflikt. Den opdaterede post blev slettet ved en anden replika. Du skal enten genindsætte eller slette konfliktposten. (Fejl 3736)

Når en post slettes ved én replika, men opdateres ved en anden, vil den slettede post altid vinde i den konflikt, der opstår, når de to replika synkroniserer. Den opdaterede post logges ind i konflikttabellen. Hvis du vil fortryde den indledende løsning af konflikten, skal du genindsætte konfliktposten. Hvis du vil acceptere den aktuelle løsning, skal du slette konfliktposten.


Opdatering af data i en sammenkædet tabel understøttes ikke af denne ISAM. (Fejl 3616)

Den installerbare ISAM, du anvender, tillader ikke opdateringer af poster i eksterne tabeller. Du kan kun tilføje nye poster.


Update/RI-konflikt. (Fejl 3718)

Den primære nøglepost er blevet opdateret af en anden replika. Derfor er denne referencepost blevet afvist. Opret enten en ny primær nøgle, der opfylder den referentielle integritetsbegrænsning, og send derefter opdateringen igen, eller rediger den fremmede nøgle i denne konflikt, så den svarer til en gyldig, primær nøgleværdi, og send opdateringen igen, eller slet denne konfliktpost.


Kan kun vises i version 1.0-formatet. (Fejl 3334)

Du forsøger at anvende en funktion, der ikke længere understøttes i den aktuelle version af programmet.


Microsoft Jet-databasemotoren kan ikke finde en post i tabellen <navn>, hvor nøglen svarer til feltet/felterne <navn>. (Fejl 3101)

I en en-til-mange-relation har du indtastet data på mange-siden, der ikke har en tilsvarende post på en-siden. Denne fejl opstår, hvis du f.eks. joinforbinder tabellerne Kunder og Ordrer i feltet Kundeid og derefter tilføjer en ordre ved hjælp af et Kundeid, der ikke findes i tabellen Kunder.


VIEW kan ikke indeholde en parameter. (Fejl 3730)

Denne fejl opstår, når du forsøger at oprette en visning fra SQL DDL. Hvis sætningsargumentet SELECT i visningssætningen CREATE indeholder parametre, returneres fejlen. Løs problemet ved at bruge sætningen CREATE PROCEDURE i stedet for.


Forsøget på at angive en kolonne i en delvis replika krænkede en regel for delvise replikaer. (Fejl 3571)

Forsøget på at angive en kolonne i en delvis replika krænker en regel for delvise replikaer. (Fejl 3571)

Du kan ikke ændre en primær nøgle i en tabel i en delvis replika, medmindre nøglen ikke refererer til den.


Overtræder reglerne for delvise replikaer. (Fejl 3590)

Du kan ikke opdatere en kolonne i en tabel i en delvis replika, når en anden tabel refererer til den pågældende kolonne. Dette er højst sandsynligt et RI-tilfælde, hvor de relaterede tabeloplysniger ikke findes i den delvise replika. Sørg for, at du følger alle relationer til relaterede tabeller, når du definerer delvise filtre.


En indbygget egenskab kan ikke slettes. (Fejl 3384)

Du forsøger at slette et Property-objekt, der er defineret af Microsoft Jet-databasemotoren

Du kan kun slette brugerdefinerede (herunder programdefinerede) egenskaber, hvor du har tilladelse til at ændre design, eller egenskaber, hvor denne tilladelse ikke er obligatorisk.


Et Field-objekt, der allerede er en del af en Fields-samling, kan ikke tilføjes. (Fejl 3266).

Et Field-objekt blev angivet som et argument til en Append-handling, da det allerede var medlem af en eksisterende Fields-samling. Brug sætningen Dim og metoden CreateField til at erklære et nyt Field-objekt, angiv objektets værdier, og prøv at udføre handlingen igen med det nye Field-objekt.


Egenskabsværdien er ugyldig. (Fejl 3271)

Mulige årsager:

  • Indstillingen af egenskaben Value til objektet Parameter er for langt eller på anden måde ukorrekt.
  • Navnet på objektet Index er en streng af længden nul (" "). Du skal skrive et navn til objektet Index, når du føjer det til samlingen Indexes.
  • Navnet på objektet Workspace er en streng af længden nul. Du skal skrive et navn til objektet Workspace, når du føjer det til en Workspaces-samling.


Et Index-objekt, der allerede er en del af en Indexes-samling, kan ikke tilføjes. (Fejl 3269)

Et Index-objekt blev angivet som et argument til en Append-handling, da det allerede var medlem af en eksisterende Indexes-samling. Brug sætningen Dim og metoden CreateIndex til at erklære et nyt Index-objekt, angiv objekternes værdier, og prøv at udføre handlingen igen med det nye Index-objekt.


Denne egenskab kan ikke angives for fjernobjekter. (Fejl 3365)

Denne egenskab er ikke tilgængelig for objekter, der er associeret med ODBC-databaser.


Egenskaben <navn> skal angives, før du bruger denne metode. (Fejl 3386)

Du har forsøgt at tilføje et nyt Property-objekt til en samling uden først at angive alle det nye objekts egenskaber: Value, Type og Name.


TableDef eller Index kan ikke tilføjes, fordi der ikke er defineret nogen felter. (Fejl 3264)

Du kan ikke tilføje et TableDef, før du har defineret et eller flere felter. Brug metoden CreateField til at oprette felter, føj dem til samlingen Fields i objektet TableDef, og føj derefter objektet TableDef til samlingen TableDefs.


En relation, hvor der ikke er defineret felter, kan ikke tilføjes. (Fejl 3366)

Du forsøger at tilføje et Relation-objekt uden felter til en Relations-samling.

Sådan tilføjes et Relation-objekt korrekt

  1. Benyt metoden CreateRelation til at oprette objektet Relation.

    Angiv egenskaberne Table, ForeignTable og Attributes i Relation-objektet, hvis du ikke har angivet dem som argumenter til metoden CreateRelation.

    Benyt metoden CreateField til at oprette et nyt Field-objekt for hvert felt i relationens primære og fremmede nøgler.

  2. Angiv egenskaben Name (hvis du ikke har angivet den som argument til metoden CreateField) og egenskaben Foreign Name i objektet eller objekterne Field til den tilsvarende Name-egenskab i den primære nøgles og den fremmede nøgles Field-objekter for hvert felt i relationen.
  3. Benyt metoden Append til at gemme objektet eller objekterne Field i samlingen Fields til objektet Relation.
  4. Benyt metoden Append til at gemme objektet Relation i samlingen Relations i databasen.


Denne egenskab kan ikke angives, når først objektet er en del af en samling. (Fejl 3268)

Du har forsøgt at ændre værdien af en egenskab til et objekt (TableDef, Field osv.), der allerede er føjet til en samling.


Metoden kan ikke anvendes på dette objekt. (Fejl 3272)

Metoden kan ikke anvendes på dette objekt. (Fejl 3273)

Du har forsøgt at benytte en metode i et objekt, der ikke understøtter denne metode. En liste over gyldige metoder til objektet finder du under Resumé-emnet til objektet.


Egenskaben kan kun angives, når feltet er en del af et Recordset-objekts Fields-samling. (Fejl 3267)

Denne egenskab er kun gyldig i forbindelse med Field-objekter, der er en del af en Fields-samling til et Recordset-objekt . En liste over egenskaber, der er tilgængelige for forskellige Fields-samlinger finder du under emnet Objektet Field og samlingen Fields –Resume.


Objektet er ikke en samling. (Fejl 3272)

Du har refereret til et objekt, som om det var en samling. En sætning, såsom qrySales.Refresh eller qrySales(2), kan f.eks. medføre denne fejl.


Der kan ikke tilføjes. Et objekt med samme navn findes allerede i samlingen. (Fejl 3367)

Du har forsøgt at føje et objekt til en samling, der allerede indeholder et objekt med dette navn. Du kan benytte metoden Refresh på samlingen og kontrollere, om det objekt, du vil tilføje, allerede findes, eller forsøge at ændre indstillingen af objektets egenskab Name.


Egenskaben blev ikke fundet. (Fejl 3270)

Den angivne egenskab blev ikke fundet.

Mulige årsager:

  • Egenskaben findes ikke. Kontroller stavningen af egenskaben i programkoden.
  • Hvis egenskaben er brugerdefineret, er den måske slettet fra samlingen.


Brugerdefinerede egenskaber understøtter ikke en Null-værdi. (Fejl 3385)

Brugerdefinerede Property-objekter kan ikke angives til Null. Du kan i stedet bruge metoden Delete på egenskaben til at fjerne det fra den tilhørende samling.


Der opstod en datatypekonverteringsfejl. (Fejl 3421)

Microsoft Jet-databasemotoren kan ikke konvertere data til den type, der kræves af en metode eller egenskab. Dette problem opstår typisk, hvis du bruger én type argument, når en metode eller egenskab forventer en anden type.


Jet VBA-filen (VBAJET.dll til 16-bit versioner eller VBAJET32.dll til 32-bit versioner) mangler. Prøv at geninstallere det program, der returnerede fejlen. (Fejl 3446)

Jet VBA-filen (Vbajet.dll til 16-bit versioner eller Vbajet.dll til 32-bit versioner) mangler. Prøv at geninstallere det program, der returnerede fejlen. (Fejl 3446)

Microsoft® Jet VBA-filen (Vbajet.dll til 16-bit versioner eller Vbajet32.dll til 32-bit versioner) blev ikke fundet. Prøv at geninstallere det program, der returnerede fejlen.


Objektet er ugyldigt eller er ikke længere angivet. (Fejl 3420)

Du forsøger at referere til et objekt, der ikke længere er gyldigt eller ikke er angivet.

Mulige årsager:

  • Objektet er lukket.
  • Objektet har ikke længere en relation (det overordnede objekt er lukket eller slettet).
  • Objektet er uden for virkefeltet.
  • Objektbiblioteket registreres ikke i Microsoft® Windows®-registreringsdatabase.
  • Du forsøger at referere til en metode eller egenskab i samlingen, men du har ikke først tildelt den til en variabel. Hvis du f.eks. vil referere til egenskaben Name, skal du bruge følgende:

    Dim dbsPublish As Database

    Set dbsPublish = OpenDatabase("Biblio.mdb")

    dbname = dbsPublish.Name


Et kald til en OLE-systemfunktion lykkedes ikke. Prøv at geninstallere det program, der returnerede fejlen. (Fejl 3448)

Et kald til en OLE Automation-funktion mislykkedes. Prøv at geninstallere det program, der returnerede fejlen.


JET VBA-filen (Vbajet.dll til 16-bit versioner eller Vbajet32.dll til 32-bit versioner) kunne ikke initialiseres, da den blev kaldt. Prøv at geninstallere det program, der returnerede fejlen. (Fejl 3447)

Microsoft® Jet VBA-filen (Vbajet.dll til 16-bit versioner eller Vbajet32.dll til 32-bit versioner) blev ikke initialiseret, da den blev kaldt. Prøv at geninstallere det program, der returnerede fejlen.


Der blev fundet en forkert version af DLL-filen <navn>. (Fejl 3445)

I forbindelse med Microsoft Jet-databaser skal den installerede Microsoft® Jet-DLL (msajt200.dll til 16-bit versioner eller msjt2032 til 32-bit versioner) være version 2.5 eller nyere.

I forbindelse med ODBCDirect-databaser skal den installerede RDO (Remote Data Objects) (RDO) DLL-fil (msrdo32.dll) være version 1.0 eller nyere.

Prøv at geninstallere det program, der returnerede fejlen.


Kolonnen <kolonne> angiver ikke en bredde i fast bredde-specifikationen <navn>. (Fejl 3444)

Der er ikke angivet nogen kolonnebreddeparameter i tekstfilspecifikationen til Tekst ISAM. Specifikationen kan angives på flere måder:

  • Fra Microsoft® Access angives disse værdier i guiden Sammenkæd Tekst, som du kan bruge ved at pege på Hent eksterne data i menuen Filer og derefter vælge Sammenkæd tabeller.
  • Fra andre værtsprogrammer i Microsoft Jet lagres disse værdier i filen Schema.ini.


Der kan ikke opdateres, fordi den er låst af brugeren <navn> på maskinen <navn>. (Fejl 3260)

Du har forsøgt at opdatere data på en side, der i øjeblikket er låst.

Mulige årsager:

  • Du har forsøgt at gemme en forespørgsel, der bruges af en anden. Hvis du vil gemme forespørgslen, skal du vente, til den anden bruger er færdig, eller skrive et andet navn, og derefter forsøge at udføre handlingen igen.
  • Du har forsøgt at benytte metoden Edit på en dataside, der indeholder en post, som allerede er åben eller låst.


Klientprogrammet til Synchronizer er ikke længere tilgængeligt og kan ikke underrettes. (Fejl 3537)

Dette er en uventet fejl. Kontakt Microsoft Teknisk Support for at få yderligere oplysninger.


Antallet af argumenter til funktionen er forkert. (Fejl 2439)

Antal argumenter til funktionen er forkert. (Fejl 2439)

Du har indtastet et udtryk, der indeholder en funktion med det forkerte antal argumenter. Kontroller funktionen for at se, hvor mange argumenter den har, eller kontroller udtrykket for at sikre, at du har indtastet det korrekt.


Det er en forkert sorteringsrækkefølge. (Fejl 3220)

Du har forsøgt at sammenkæde en Paradox-tabel, der er oprettet med en international sorteringsrækkefølge, der ikke er den, du benytter.


Formatet af memo-filen stemmer ikke overens med det angivne eksterne databaseformat. (Fejl 3286)

Programmet kan ikke læse den Memo-fil, der er knyttet til den database, du forsøger at importere eller sammenkæde, og kan derfor ikke importere eller sammenkæde filen. Memo-filen kan have det forkerte format, hvis du f.eks. har valgt dBASE IV som datakilde, og Memo-filen er i et Microsoft® FoxPro®-format.


Der er gjort ugyldig brug af parenteser. (Fejl 2442)

Du har indtastet et udtryk, der indeholder ugyldige parenteser. Du forsøger måske at benytte en syntaks med parenteser til et ID i en forespørgsel. I en forespørgsel kan du kun bruge standardsyntaksen til et ID.


Sætningen ADD USER (Microsoft Jet SQL)

Sætningen ADD USER

Tilføjer en eller flere eksisterende brugere til en eksisterende gruppe.

Syntaks

ADD USER bruger[, bruger, …] TO gruppe

Sætningen ADD USER indeholder følgende argumenter:

Argument | Beskrivelse
bruger | Navnet på en bruger, der skal tilføjes til arbejdsgruppeoplysningsfilen.
gruppe | Navnet på en gruppe, der skal tilføjes til arbejdsgruppeoplysningsfilen.

Bemærkninger

Når en bruger er føjet til en gruppe, har brugeren alle de tilladelser, der er givet til gruppen.

Se også
Sætningen ALTER USER eller DATABASE | Sætningen CREATE USER eller GROUP
Sætningen ALTER TABLE | Sætningen CREATE VIEW
Delsætningen CONSTRAINT | Sætningen DROP
Sætningen CREATE INDEX | Sætningen DROP USER eller GROUP
Sætningen CREATE PROCEDURE | Sætningen GRANT
Sætningen CREATE TABLE | Sætningen REVOKE


Prædikaterne ALL, DISTINCT, DISTINCTROW og TOP

Angiver poster, der udvælges med SQL-forespørgsler.

Syntaks

SELECT [ALL | DISTINCT | DISTINCTROW | [TOP n [PERCENT]]]
FROM tabel

En SELECT-sætning, der indeholder disse prædikater, indeholder følgende:

Argument | Beskrivelse
ALL Anvendes, hvis du ikke medtager et af prædikaterne. Microsoft Jet-databasemotoren udvælger alle de poster, der opfylder betingelserne i SQL-sætningen. Følgende to eksempler svarer til hinanden, og alle poster returneres fra tabellen Medarbejdere:

SELECT ALL *
FROM Medarbejdere
ORDER BY Medarbejdernr;

SELECT *
FROM Medarbejdere
ORDER BY Medarbejdernr;
DISTINCT Udelader poster, der indeholder dublerede data i de valgte felter. Hvis de skal medtages i forespørgslens resultater, skal værdierne for hvert enkelt felt, der vises i SELECT-sætningen, være unikke. Flere medarbejdere, der vises i tabellen Medarbejdere, kan f.eks. have samme efternavn. Hvis to poster indeholder Smith i feltet Efternavn, returnerer den følgende SQL-sætning kun én post, der indeholder Smith:

SELECT DISTINCT
Efternavn
FROM Medarbejdere;

Hvis du udelader DISTINCT, returnerer denne forespørgsel begge poster med Smith.

Hvis SELECT-delsætningen indeholder mere en et felt, skal kombinationen af værdier fra alle felter være unik, for at en bestemt post medtages i resultaterne.

Outputtet fra en forespørgsel, der anvender DISTINCT, kan ikke opdateres og afspejler ikke de efterfølgende ændringer, der foretages af andre brugere.
DISTINCTROW Udelader data, der er baseret på hele dublerede poster, ikke kun dublerede felter. Du kan f.eks. oprette en forespørgsel, der joinforbinder tabellerne Kunder og Ordrer i feltet Kundeid. Tabellen Kunder indeholder ingen dublerede Kundeid-felter, men tabellen Ordrer gør, da hver enkelt kunde kan have mange ordrer. Følgende SQL-sætning viser, hvordan du kan bruge DISTINCTROW til at vise en liste over firmaer, der har mindst én ordre, uden at angive detaljer om disse ordrer:

SELECT DISTINCTROW Firmanavn
FROM Kunder INNER JOIN Ordrer
ON Kunder.Kundeid = Ordrer.Kundeid
ORDER BY Firmanavn;

Hvis du udelader DISTINCTROW, medfører denne forespørgsel flere rækker for hvert enkelt firma, der har mere end en ordre.

DISTINCTROW har kun indflydelse, når du vælger felter fra nogle, men ikke alle tabeller, der bruges i forespørgslen. DISTINCTROW ignoreres, hvis forespørgslen kun medtager én tabel, eller hvis du får felter fra alle tabeller som output.
TOP n [PERCENT] Returnerer et vist antal poster, der ligger øverst eller nederst i et område, som er angivet af en ORDER BY-delsætning. Antag, at du vil have navnene på de bedste 25 studenter fra årgang 1994:

SELECT TOP 25
Fornavn, Efternavn
FROM Studenter
WHERE Afgangsår = 1994
ORDER BY Gennemsnitskarakter DESC;

Hvis du ikke medtager en ORDER BY-delsætning, returnerer forespørgslen et tilfældigt sæt på 25 poster fra tabellen Studenter, der opfylder WHERE-delsætningen.

Prædikatet TOP vælger ikke mellem ens værdier. Hvis det 25. og 26. højeste karaktergennemsnit i det foregående eksempel er det samme, returnerer forespørgslen 26 poster.

Du kan også bruge det reserverede ord PERCENT til at returnere en vis procentdel af poster, der ligger øverst eller nederst i et område, som er angivet af en ORDER BY-delsætning. Antag, at i stedet for de bedste 25 studenter, vil du have de dårligste 10 procent af klassen:

SELECT TOP 10 PERCENT
Fornavn, Efternavn
FROM Studenter
WHERE Afgangsår = 1994
ORDER BY Gennemsnitskarakter ASC;

Prædikatet ASC angiver, at de nederste værdier returneres. Værdien, der følger efter TOP, skal være en Integer uden fortegn.

TOP har ingen betydning for, om forespørgslen kan opdateres.
tabel | Navnet på den tabel, som posterne hentes fra.

Se også
Delsætningen FROM (Microsoft Jet SQL) Sætningen SELECT (Microsoft Jet SQL)

Eksempel

Eksempel på prædikaterne ALL, DISTINCT, DISTINCTROW, TOP


Eksempel på prædikaterne ALL, DISTINCT, DISTINCTROW og TOP (DAO)

Eksempel på prædikaterne ALL, DISTINCT, DISTINCTROW og TOP

I følgende eksempel oprettes en forespørgsel, der joinforbinder tabellerne Kunder og Ordrer ved hjælp af feltet Kundeid. Tabellen Kunder indeholder ingen dublerede Kundeid-felter, men tabellen Ordrer gør, da hver enkelt kunde kan have mange ordrer. Ved hjælp af DISTINCTROW kan du få en liste over firmaer med mindst en ordre, men uden yderligere oplysninger om disse ordrer.

Sub AllDistinctX()

    Dim dbs As Database, rst As Recordset

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Joinforbind tabellerne Kunder og Ordrer ved hjælp

    ' Kundeid. Udvælg en liste over firmaer

    ' med mindst en ordre.

    Set rst = dbs.OpenRecordset("SELECT DISTINCTROW " _

        & "Firmanavn FROM Kunder " _

        & "INNER JOIN Ordrer " _

        & "ON Kunder.Kundeid = " _

        & "Ordrer.Kundeid " _

        & "ORDER BY Firmanavn;")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    ' Recordset-objektet. Overfør Recordset-objektet og

    ' den ønskede feltbredde.

    EnumFields rst, 25

    dbs.Close

End Sub


Sætningen ALTER TABLE (Microsoft Jet SQL)

Sætningen ALTER TABLE

Ændrer designet af en tabel, når den er oprettet med sætningen CREATE TABLE.

Bemærk! Microsoft Jet-databasemotoren understøtter ikke brugen af ALTER TABLE eller DDL-sætninger (data definition language) med ikke-Microsoft Jet-databaser. Du skal i stedet bruge DAO Create -metoderne.

Syntaks

ALTER TABLE tabel {ADD {COLUMN felttype[(størrelse)] [NOT NULL] [CONSTRAINT indeks] |
ALTER COLUMN felttype[(størrelse)] |
CONSTRAINT flerfeltindeks} |
DROP {COLUMN felt I CONSTRAINT indeksnavn} }

Sætningen ALTER TABLE indeholder følgende argumenter:

Argument | Beskrivelse
tabel | Navnet på den tabel, der skal ændres.
felt | Navnet på det felt, der skal tilføjes eller slettes fra tabel. Eller navnet på det felt, der skal ændres i tabel.
type | Datatypen i felt.
størrelse | Feltstørrelsen i tegn (kun tekstfelter og binære felter).
indeks | Indekset til felt. Yderligere oplysninger om, hvordan dette indeks oprettes, findes i Delsætningen CONSTRAINT.
flerfeltindeks | Definitionen på det indeks med flere felter, der skal tilføjes til tabel. Yderligere oplysninger om, hvordan dette indeks oprettes, findes i Delsætningen CONSTRAINT.
indeksnavn | Navnet på det indeks med flere felter, der skal fjernes.

Bemærkninger

Hvis du bruger sætningen ALTER TABLE, kan du ændre en eksisterende tabel på flere måder. Du kan:

  • Anvende ADD COLUMN til at tilføje et nyt felt til tabellen. Du kan angive feltnavnet, datatypen og (i forbindelse med felter af typen Text og Binary) en valgfri størrelse. Følgende sætning tilføjer f.eks. et Text-felt med 25-tegn kaldet Bemærkninger til tabellen Medarbejdere:

    ALTER TABLE Medarbejdere ADD COLUMN Bemærkninger TEXT(25)

    Du kan også definere et indeks i det pågældende felt. Yderligere oplysninger om, hvordan dette indeks oprettes, findes i Delsætningen CONSTRAINT.

    Hvis du angiver NOT NULL for et felt, kræves det, at de nye poster har gyldige data i det pågældende felt.

  • Brug ALTER COLUMN til at ændre datatypen på et eksisterende felt. Du kan angive feltnavnet, den nye datatype og en valgfri størrelse for felter af typen Text og Binary. Følgende sætning ændrer f.eks. datatypen i et felt kaldet Postnummer (oprindeligt defineret som et heltal) i tabellen Medarbejdere til et Text-felt med 10 tegn:

    ALTER TABLE Medarbejdere ALTER COLUMN Postnummer TEXT(10)

  • Bruge ADD CONSTRAINT til at tilføje et indeks med flere felter. Yderligere oplysninger om, indeks med flere felter findes i Delsætningen CONSTRAINT.
  • Anvende DROP COLUMN til at slette et felt. Du skal kun angive navnet på feltet.
  • Bruge DROP CONSTRAINT til at slette et indeks med flere felter. Du skal kun angive navnet på det indeks, der følger efter det reserverede ord CONSTRAINT.

Bemærk!

  • Du kan ikke tilføje eller slette mere end et felt eller indeks ad gangen.
  • Du kan bruge sætningen CREATE INDEX til at tilføje et indeks med et eller flere felter til en tabel, og du kan benytte sætningen ALTER TABLE eller DROP til at slette et indeks, der er oprettet med ALTER TABLE eller CREATE INDEX.
  • Du kan ikke bruge NOT NULL i et enkelt felt eller i en navngivet CONSTRAINT-delsætning, der gælder for enten et enkelt felt eller flere felter med navnet CONSTRAINT. Du kan dog kun anvende begrænsningen NOT NULL én gang i et felt. Forsøg på at anvende denne begrænsning mere end én gang medfører en kørselsfejl.
Se også
Sætningen ADD USER | Sætningen CREATE USER eller GROUP
Sætningen ALTER USER eller DATABASE | Sætningen CREATE VIEW
Delsætningen CONSTRAINT | Sætningen DROP
Sætningen CREATE INDEX | Sætningen DROP USER eller GROUP
Sætningen CREATE PROCEDURE | Sætningen GRANT
Sætningen CREATE TABLE | Sætningen REVOKE

Eksempel

Eksempel på sætningen ALTER TABLE


Sætningen ALTER USER eller DATABASE (Microsoft Jet SQL)

Sætningen ALTER USER eller DATABASE

Ændrer adgangskoden til en eksisterende bruger eller til en database.

Syntaks

ALTER DATABASE PASSWORD nyadgangskode gammeladgangskode

ALTER USER bruger PASSWORD nyadgangskode gammeladgangskode

Sætningen ALTER USER eller DATABASE indeholder følgende argumenter:

Argument | Beskrivelse
bruger | Navnet på en bruger, der skal tilføjes til arbejdsgruppeoplysningsfilen.
nyadgangskode | Den nye adgangskode, der skal tilknyttes det angivne brugernavn eller databasenavn.
gammeladgangskode | Den eksisterende adgangskode, der skal tilknyttes det angivne brugernavn eller gruppenavn.

Se også
Sætningen ADD USER | Sætningen CREATE USER eller GROUP
Sætningen ALTER TABLE | Sætningen CREATE VIEW
Delsætningen CONSTRAINT | Sætningen DROP
Sætningen CREATE INDEX | Sætningen DROP USER eller GROUP
Sætningen CREATE PROCEDURE | Sætningen GRANT
Sætningen CREATE TABLE | Sætningen REVOKE


Eksempel på sætningen ALTER TABLE (DAO)

Eksempel på sætningen ALTER TABLE

I følgende eksempel føjes feltet Løn af en datatype Money til tabellen Medarbejdere.

Sub AlterTableX1()

    Dim dbs As Database

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Tilføj feltet Løn til tabellen Medarbejdere, og

    ' angiv, at det skal være af datatypen Money.

    dbs.Execute "ALTER TABLE Medarbejdere " _

        & "ADD COLUMN Løn MONEY;"

    dbs.Close

End Sub

I følgende eksempel ændres feltet Løn fra datatypen Money til datatypen Char.

Sub AlterTableX2()

    Dim dbs As Database

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Tilføj feltet Løn til tabellen Medarbejdere, og

    ' angiv, at det skal være af datatypen Money.

    dbs.Execute "ALTER TABLE Medarbejdere " _

        & "ADD COLUMN Løn CHAR(20);"

    dbs.Close

End Sub

I følgende eksempel fjernes feltet Løn fra tabellen Medarbejdere.

Sub AlterTableX3()

    Dim dbs As Database

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Slet feltet Løn fra tabellen Medarbejdere.

    dbs.Execute "ALTER TABLE Medarbejdere " _

        & "DROP COLUMN Løn;"

    dbs.Close

End Sub

I følgende eksempel føjes en fremmed nøgle til tabellen Ordrer. Den fremmede nøgle er baseret på feltet Medarbejderid og refererer til feltet Medarbejderid i tabellen Medarbejdere. I følgende eksempel behøver du ikke at medtage feltet Medarbejderid efter tabellen Medarbejdere i delsætningen REFERENCES, fordi Medarbejderid er den primære nøgle i tabellen Medarbejdere.

Sub AlterTableX4()

    Dim dbs As Database

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Føj en fremmed nøgle til tabellen Ordrer.

    dbs.Execute "ALTER TABLE Ordrer " _

        & "ADD CONSTRAINT Ordrerelation " _

        & "FOREIGN KEY (Medarbejderid) " _

        & "REFERENCES Medarbejdere(Medarbejderid);"

    dbs.Close

End Sub

I følgende eksempel fjernes den fremmede nøgle i tabellen Ordrer.

Sub AlterTableX5()

    Dim dbs As Database

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Fjern den fremmede nøgle Ordrerelation i

    ' fra tabellen Ordrer.

    dbs.Execute "ALTER TABLE Ordrer " _

        & "DROP CONSTRAINT Ordrerelation;"

    dbs.Close

End Sub


Funktionen Avg (Microsoft Jet SQL)

Funktionen Avg

Beregner den aritmetiske gennemsnitsværdi af et sæt værdier, der er indeholdt i et angivet felt i en forespørgsel.

Syntaks

Avg(udtr)

Pladsholderen udtr repræsenterer et strengudtryk, der identificerer det felt, som indeholder de numeriske data, du vil beregne gennemsnittet af, eller et udtryk, der udfører en beregning ved hjælp af dataene i det pågældende felt. Operander i udtr kan medtage navnet på et tabelfelt, en konstant eller på en funktion, der kan være enten indbygget eller brugerdefineret, men ikke en af de andre SQL- aggregat funktioner.

Bemærkninger

Det gennemsnit, der beregnes af Avg, er den aritmetiske gennemsnitsværdi (summen af værdier divideret med antallet af værdier). Du kan f.eks. benytte Avg til at beregne gennemsnitsomkostningerne for fragt.

Funktionen Avg medtager ikke Null-felter i beregningen.

Du kan anvende Avg i en forespørgsel og i egenskaben SQL i et QueryDef-objekt, eller når du opretter et Recordset-objekt, der er baseret på en SQL-forespørgsel.

Se også
Beregning af felter i SQL-funktioner SQL-aggregatfunktioner (SQL)

Eksempel

Eksempel på funktionen Avg


Eksempel på funktionen Avg (DAO)

Eksempel på funktionen Avg

I følgende eksempel benyttes tabellen Ordrer til at beregne de gennemsnitlige fragtomkostninger for ordrer med fragtomkostninger over kr.

I følgende eksempel kaldes proceduren EnumFields, som du finder i eksemplet på sætningen SELECT.

Sub AvgX()

    Dim dbs As Database, rst As Recordset

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Beregn de gennemsnitlige fragtomkostninger for

    ' ordrer med fragtomkostninger over kr.

    Set rst = dbs.OpenRecordset("SELECT Avg(Fragtomkostninger)" _

        & " AS [Gennemsnitsfragtomkostninger]" _

        & " FROM Ordrer WHERE Fragtomkostninger > 600;")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    ' Recordset-objektet. Overfør Recordset-objektet og

    ' den ønskede feltbredde.

    EnumFields rst, 25

    dbs.Close

End Sub


Operatoren Between...And (Microsoft Jet SQL)

Operatoren Between...And

Bestemmer, om værdien af et udtryk ligger inden for et angivet værdiområde. Du kan bruge denne operator i SQL-sætninger.

Syntaks

udtr [Not] Between værdi1 And værdi2

Syntaksen til operatoren Between...And indeholder følgende argumenter:

Argument | Beskrivelse
udtr | Udtryk, der identificerer det felt, som indeholder de data, du vil evaluere.
værdi1, værdi2 | Udtryk, som du vil evaluere udtr i forhold til.

Bemærkninger

Hvis værdien af udtr er mellem værdi1 og værdi2 (inklusive), returnerer operatoren Between...And værdien True. I modsat fald returneres False. Du kan medtage den logiske operator Not til at evaluere den modsatte betingelse (dvs. om udtr ligger uden for det område, der er defineret af værdi1 og værdi2).

Du kan også benytte Between...And til at bestemme, om værdien i et felt ligger inden for et angivet numerisk område. I følgende eksempel bestemmes, om en ordre er afsendt til et sted inden for et bestemt postnummerinterval. Hvis postnummeret ligger mellem 9000 og 9220, returnerer funktionen IIf “Lokal”. Ellers returneres “Ikke-lokal”.

SELECT IIf(Postnummer Between 9000 And 9220, “Lokal”, “Ikke-lokal”)

FROM Udgivere

Hvis udtr, værdi1 eller værdi2 er Null, returnerer Between...And en Null-værdi.

Da jokertegn, såsom *, behandles som konstanter, kan du ikke bruge dem sammen med operatoren Between...And. Du kan f.eks. ikke benytte 900* og 923* til at finde alle postnumre, der begynder med 900 til 923. Det kan du i stedet gøre på to andre måder. Du kan tilføje et udtryk til forespørgslen, der tager de tre tegn til venstre i tekstfeltet og bruger Between...And på disse tegn. Eller du kan forsyne de høje og lave værdier med ekstra tegn – i dette tilfælde 9000 til 9220 eller 9000 til 9220-9333, hvis du anvender udvidede postnumre. Du skal udelade -000 fra de lave værdier, da 9000 ellers opgives, hvis nogle postnumre har udvidede sektioner og andre ikke har.

Se også
Delsætningen IN (Microsoft Jet SQL) | SQL-udtryk
Delsætningen WHERE (Microsoft Jet SQL) |

Eksempel

Eksempel på SQL-underforespørgsler


Beregning af felter i SQL-funktioner

Du kan bruge strengudtryksargumentet i en SQL-aggregatfunktion til at udføre en beregning på værdier i et felt. Du kan f.eks. beregne en procent, såsom en tillægsafgift eller moms, ved at gange en feltværdi med en brøk.

I følgende tabel vises eksempler på beregninger på felter i tabellerne Ordrer og Ordrespecifikationer i databasen Northwind.mdb.

Beregning | Eksempel
Føje et tal til et felt | Fragtomkostninger + 5
Trække et tal fra et felt | Fragtomkostninger + 5
Gange et felt med et tal | [Pris pr enhed] * 2
Dividere et felt med et tal | Fragtomkostninger / 2
Føje et felt til et andet | [Enheder på lager] + [Enheder i ordre]
Trække et felt fra et andet | [Genbestilling ved] - [Enheder på lager]

I følgende eksempel beregnes det gennemsnitlige rabatbeløb af alle ordrer i databasen Northwind.mdb. Værdierne i felterne Pris pr enhed og Rabat ganges for at bestemme rabatbeløbet for hver ordre og derefter beregnes gennemsnittet. Du kan anvende dette udtryk i en SQL-sætning i Visual Basic-kode:

SELECT Avg([Pris pr enhed] * Rabat) AS [Gennemsnitlig rabat] FROM Ordrespecifikationer;

Se også
SQL-aggregatfunktioner (SQL) SQL-udtryk


Delsætningen CONSTRAINT (Microsoft Jet SQL)

Delsætningen CONSTRAINT

En begrænsning ligner et indeks, selvom den også kan bruges til at etablere en relation med en anden tabel.

Du kan anvende delsætningen CONSTRAINT i sætningerne ALTER TABLE og CREATE TABLE til at oprette eller slette begrænsninger. Der findes to typer CONSTRAINT-delsætninger: En til oprettelse af en begrænsning med et enkelt felt og en til oprettelse af en begrænsning for mere end et felt.

Bemærk! Microsoft Jet-databasemotoren understøtter ikke brugen af CONSTRAINT eller DDL-sætninger (data definition language) med ikke-Microsoft Jet-databaser. Du skal i stedet bruge DAO Create-metoderne.

Syntaks

Begrænsning i enkelt felt:

CONSTRAINT navn {PRIMARY KEY | UNIQUE | NOT NULL |
REFERENCES fremmedtabel [(fremmedfelt1, fremmedfelt2)]
[ON UPDATE CASCADE | SET NULL]
[ON DELETE CASCADE | SET NULL]}

Begrænsning i flere felter:

CONSTRAINT navn
{PRIMARY KEY (primær1[, primær2 [, ...]]) |
UNIQUE (unik1[, unik2 [, ...]]) |
NOT NULL (ikkenul1[, ikkenul2 [, ...]]) |
FOREIGN KEY [NO INDEX] (ref1[, ref2 [, ...]]) REFERENCES fremmedtabel [(fremmedfelt1 [, fremmedfelt2 [, ...]])]}
[ON UPDATE CASCADE | SET NULL]
[ON DELETE CASCADE | SET NULL]}

CONSTRAINT-delsætningen indeholder følgende argumenter:

Argument | Beskrivelse
navn | Navnet på den begrænsning, der skal oprettes.
primær1, primær2 | Navnet på det eller de felter, der skal angives som den primære nøgle.
unik1, unik2 | Navnet på det eller de felter, der skal angives som unik nøgle.
ikkenul1, ikkenul2 | Navnet på det eller de felter, der begrænses til ikke-Nulll-værdier.
ref1, ref2 | Navnet på en fremmed nøgle med et eller flere felter, der refererer til felter i en anden tabel.
fremmedtabel | Navnet på den fremmede tabel der indeholder det eller de felter, der er angivet af fremmedfelt.
fremmedfelt1, fremmedfelt2 | Navnet på det eller de felter i fremmedtabel, der er angivet af ref1, ref2. Du kan udelade denne delsætning, hvis det felt, der refereres til, er den primære nøgle i fremmedtabel.

Bemærkninger

Du anvender syntaksen til en begrænsning med et enkelt felt i delsætningens feltdefinition i en ALTER TABLE- eller CREATE TABLE-sætning, så den følger umiddelbart efter angivelsen af feltets datatype.

Du bruger syntaksen til en begrænsning med flere felter, når du anvender det reserverede ord CONSTRAINT uden for en feltdefinitionsdelsætning i en ALTER TABLE- eller CREATE TABLE-sætning.

Hvis du anvender CONSTRAINT, kan du udforme et felt som en af følgende typer begrænsninger:

  • Du kan anvende det reserverede ord UNIQUE til at udforme et felt som en unik nøgle. Det vil sige, at to poster i tabellen ikke kan have samme værdi i dette felt. Du kan begrænse alle felter eller lister over felter til at være unikke. Hvis en begrænsning med flere felter er udformet som en unik nøgle, skal de kombinerede værdier i alle felter i indekset være unikke, selvom to eller flere poster kun har samme værdi i et enkelt af felterne.
  • Du kan bruge det reserverede ord PRIMARY KEY til at angive et felt eller et sæt felter i en tabel som en primær nøgle. Alle værdier i den primære nøgle skal være unikke og ikke Null, og der kan kun være en enkelt primær nøgle i en tabel.

    Bemærk! Du skal ikke angive begrænsningen PRIMARY KEY i en tabel, der allerede har en primær nøgle. Hvis du gør dette, opstår der en fejl.

  • Du kan bruge det reserverede ord FOREIGN KEY til at angive et felt som en fremmed nøgle. Hvis den fremmede tabels primære nøgle består af mere end et felt, skal du benytte en begrænsningsdefinition for flere felter, der viser alle de refererede felter, navnet på den fremmede tabel og navnene på de felter, der refereres til i den fremmede tabel, i samme rækkefølge, som de refererede felter vises i. Hvis det eller de felter, der refereres til, er den fremmede tabels primære nøgle, behøver du ikke at angive de felter, der refereres til. Som standard fungerer databasemotoren, som om den fremmede tabels primære nøgle er de felter, der refereres til.

    Fremmed nøglebegrænsninger definerer handlinger, der skal udføres, når en tilsvarende værdi i en primær nøgle ændres:

  • Du kan angive handlinger, der skal udformes i den fremmede tabel ud fra en tilsvarende handlinger, der udføres på en primær nøgle i den tabel, hvor CONSTRAINT er defineret. Se f.eks. følgende definition for tabellen Kunder:

    CREATE TABLE Kunder (Kundeid INTEGER PRIMARY KEY, CLstNm NCHAR VARYING (50))

    Se følgende definition i tabellen Ordrer, der definerer en fremmed nøglerelation, der refererer til den primære nøgle i tabellen Kunder:

    CREATE TABLE Ordrer (Ordreid INTEGER PRIMARY KEY, Kundeid INTEGER, OrderNotes NCHAR VARYING (255), CONSTRAINT FKOrdrerKundeid FOREIGN KEY (Kundeid) REFERENCES Kunder ON UPDATE CASCADE ON DELETE CASCADE

    Både en ON UPDATE CASCADE- og en ON DELETE CASCADE-delsætning defineres på den fremmede nøgle. Delsætningen ON UPDATE CASCADE betyder, at hvis en kundes id (Kundeid) opdateres i tabellen Kunder, vil opdateringen være kaskadevis igennem tabellen Ordrer. Hver ordre indeholder en tilsvarende kundeidværdi, der automatisk opdateres med den nye værdi. Delsætningen ON DELETE CASCADE betyder, at hvis en kunde slettes fra tabellen Kunder, slettes også alle rækker i tabellen Ordrer, der indeholder den samme kundeidværdi.

    Se følgende anden definition af tabellen Ordrer ved hjælp af handlingen SET NULL i stedet for handlingen CASCADE:

    CREATE TABLE Ordrer (Ordreid INTEGER PRIMARY KEY, Kundeid INTEGER, OrderNotes NCHAR VARYING (255), CONSTRAINT FKOrdrerKundeid FOREIGN KEY (Kundeid) REFERENCES Kunder ON UPDATE SET NULL ON DELETE SET NULL

    Delsætningen ON UPDATE SET NULL betyder, at hvis en kundes id (Kundeid) opdateres i tabellen Kunder, angives de tilsvarende fremmed nøgleværdier i tabellen Ordrer automatisk til NULL. Tilsvarende betyder delsætningen ON DELETE SET NULL, at hvis en kunde slettes fra tabellen Kunder, angives alle tilsvarende fremmede nøgler i tabellen Ordrer automatisk til NULL.

Hvis du vil forhindrer den automatiske oprettelse af indeks for fremmede nøgler, kan du bruge ændringssætningen NO INDEX. Denne form for fremmed nøgledefinition skal kun bruges i de tilfælde, hvor de sluttelige indeksværdier ofte duplikeres. De steder, hvor værdierne i et fremmed nøgleindeks ofte duplikeres, kan brugen af et indeks være mindre effektivt end blot at fortage en tabelskanning. Vedligeholdelse af denne type indeks med rækker indsat og slettet fra tabellen nedsætter ydeevnen og giver ingen fordele.

Se også
Sætningen ADD USER | Sætningen CREATE USER eller GROUP
Sætningen ALTER USER eller DATABASE | Sætningen CREATE VIEW
Sætningen ALTER TABLE | Sætningen DROP
Sætningen CREATE INDEX | Sætningen DROP USER eller GROUP
Sætningen CREATE PROCEDURE | Sætningen GRANT
Sætningen CREATE TABLE | Sætningen REVOKE

Eksempel

Sætningen CREATE TABLE, Eksempel på delsætningen CONSTRAINT


Funktionen Count (Microsoft Jet SQL)

Funktionen Count

Beregner antallet af poster, der returneres af en forespørgsel.

Syntaks

Count(udtr)

Pladsholderen udtr repræsenterer et strengudtryk, der identificerer det felt, som indeholder de data, du vil beregne gennemsnittet af, eller et udtryk, der udfører en beregning ved hjælp af dataene i det pågældende felt. Operander i udtr kan medtage navnet på et tabelfelt eller på en funktion, der kan være enten indbygget eller brugerdefineret, men ikke en af de andre SQL- aggregat funktioner. Du kan beregne alle typer data, herunder tekst.

Bemærkninger

Du kan benytte Count til at tælle antallet af poster i en underliggende forespørgsel. Du kan f.eks. bruge Count til at tælle antallet af ordrer, der er afsendt til et bestemt land.

Selv om udtr kan udføre en beregning på et felt, beregner Count blot antallet af poster. Det har ingen betydning, hvilke værdier der er lagret i posterne.

Funktionen Count tæller ikke poster, der har Null-felter, medmindre udtr er jokertegnet stjerne (*). Hvis du anvender en stjerne, beregner Count det totale antal poster, herunder dem, der indeholder Null-felter. Count(*) er betydeligt hurtigere end Count([Kolonnenavn]). Du skal ikke sætte stjernen i anførselstegn (' '). I følgende eksempel beregnes antallet af poster i tabellen Ordrer:

SELECT Count(*)

AS Ordretotal FROM Ordrer;

Hvis udtr identificerer flere felter, tæller funktionen Count kun en post, hvis mindst et af felterne ikke er Null. Hvis alle angivne felter er Null, tælles posten ikke. Du skal adskille feltnavnene med &-tegnet. I følgende eksempel vises, hvordan du kan begrænse optællingen af poster, hvor enten Afsendelsesdato eller Fragtomkostninger ikke er Null:

SELECT

Count("Afsendelsesdato & Fragtomkostninger")

AS [Ikke Null] FROM Ordrer;

Du kan benytte Count i et forespørgselsudtryk. Du kan også anvende dette udtryk i egenskaben SQL i et QueryDef-objekt, eller når du opretter et Recordset-objekt, der er baseret på en SQL-forespørgsel.

Se også
Sætningen SELECT (Microsoft Jet SQL) | Funktionen Sum (Microsoft Jet SQL)
SQL-aggregatfunktioner (SQL) |

Eksempel

Eksempel på funktionen Count


Eksempel på funktionen Count (DAO)

Eksempel på funktionen Count

I følgende eksempel benyttes tabellen Ordrer til at beregne antallet af ordrer, der er afsendt til Storbritannien.

I følgende eksempel kaldes proceduren EnumFields, som du finder i eksemplet på sætningen SELECT.

Sub CountX()

    Dim dbs As Database, rst As Recordset

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Beregn antallet af ordrer, der er afsendt til

    ' Storbritannien.

    Set rst = dbs.OpenRecordset("SELECT" _

        & " Count (Modtagerland)" _

        & " AS GB-ordrer FROM Ordrer" _

        & " WHERE Modtagerland = 'Storbritannien';")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    ' Recordset-objektet. Overfør Recordset-objektet og

    ' den ønskede feltbredde.

    EnumFields rst, 25

    dbs.Close

End Sub


Sætningen CREATE INDEX (Microsoft Jet SQL)

Sætningen CREATE INDEX

Opretter et nyt indeks i en eksisterende tabel.

Bemærk! I forbindelse med ikke-Microsoft Jet-databaser understøtter Microsoft Jet-databasemotoren ikke brugen af CREATE INDEX (undtagen for at oprette et pseudoindeks eller en ODBC sammenkædet tabel) eller en af DDL-sætningerne (data definition language). Du skal i stedet bruge DAO Create-metoderne. Yderligere oplysninger finder du i afsnittet "Bemærkninger".

Syntaks

CREATE [ UNIQUE ] INDEX indeks
ON tabel (felt [ASC|DESC][, felt [ASC|DESC], ...])
[WITH { PRIMARY | DISALLOW NULL | IGNORE NULL }]

Sætningen CREATE INDEX indeholder følgende argumenter:

Argument | Beskrivelse
indeks | Navnet på det indeks, der skal oprettes.
tabel | Navnet på den eksisterende tabel, der skal indeholde indekset.
felt | Navnet på det eller de felter, der skal indekseres. Hvis du vil oprette et indeks med et enkelt felt, skal du vise feltnavnet i parenteser efter tabelnavnet. Hvis du vil oprette et indeks med flere felter, skal du vise navnet på alle de felter, der skal medtages i indekset. Hvis du vil oprette faldende indeks, skal du bruge det reserverede ord DESC. Ellers antages det, at indeksene er stigende.

Bemærkninger

Hvis du vil forhindre dublerede værdier i de indekserede felter i forskellige poster, skal du bruge det reserverede ord UNIQUE.

I den valgfrie WITH-delsætning kan du gennemtvinge datavalideringsregler. Du kan:

  • Forhindre Null-indtastninger i det eller de indekserede felter i nye poster ved hjælp af indstillingen DISALLOW NULL.
  • Forhindre poster med Null-værdier i det eller de indekserede felter i at medtages i indekset ved hjælp af indstillingen IGNORE NULL.
  • Angive det eller de indekserede felter som den primære nøgle ved hjælp af det reserverede ord PRIMARY. Dette indebærer, at nøglen er unik, så du kan udelade det reserverede ord UNIQUE.

Du kan bruge CREATE INDEX til at oprette et pseudoindeks i en tilknyttet tabel i en ODBC-datakilde, såsom Microsoft® SQL Server™, der ikke allerede har et indeks. Du behøver ikke tilladelse eller adgang til fjernserveren for at oprette et pseudoindeks, og fjerndatabasen er uvidende om og påvirkes ikke af pseudoindekset. Du kan bruge den samme syntaks til både tilknyttede og oprindelige tabeller. Oprettelse af et pseudoindeks i en tabel, der normalt vil være skrivebeskyttet, kan være særligt nyttigt.

Du kan også bruge sætningen ALTER TABLE til at tilføje et indeks med et enkelt eller flere felter til en tabel, og du kan anvende sætningen ALTER TABLE eller sætningen DROP til at fjerne et indeks, der er oprettet med ALTER TABLE eller CREATE INDEX.

Bemærk! Du skal ikke bruge det reserverede ord PRIMARY, når du opretter et nyt indeks, der allerede indeholder en primær nøgle. Hvis du gør dette, opstår der en fejl.

Se også
Sætningen ADD USER | Sætningen CREATE USER eller GROUP
Sætningen ALTER USER eller DATABASE | Sætningen CREATE VIEW
Sætningen ALTER TABLE | Sætningen DROP
Delsætningen CONSTRAINT | Sætningen DROP USER eller GROUP
Sætningen CREATE PROCEDURE | Sætningen GRANT
Sætningen CREATE TABLE | Sætningen REVOKE

Eksempel

Eksempel på sætningen CREATE INDEX


Eksempel på sætningen CREATE INDEX (DAO)

Eksempel på sætningen CREATE INDEX

I følgende eksempel oprettes et indeks, der består af felterne Privattelefon og Lokalnummer i tabellen Medarbejdere.

Sub CreateIndexX1()

    Dim dbs As Database

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Opret indekset NytIndeks i tabellen Medarbejdere.

    dbs.Execute "CREATE INDEX NytIndeks ON Medarbejdere " _

        & "(Privattelefon, Lokalnummer);"

    dbs.Close

End Sub

I følgende eksempel oprettes et indeks i tabellen Kundeid ved hjælp af feltet Kundeid. To poster kan ikke have de samme data i feltet Kundeid og Null-værdier tillades ikke.

Sub CreateIndexX2()

    Dim dbs As Database

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Opret det unikke indeks Kundeid i feltet

    ' Kundeid.

    dbs.Execute "CREATE UNIQUE INDEX Kundeid " _

        & "ON Kunder(Kundeid) " _

        & "WITH DISALLOW NULL;"

    dbs.Close

End Sub


Sætningen CREATE PROCEDURE (Microsoft Jet SQL)

Sætningen CREATE PROCEDURE

Opretter en gemt procedure.

Bemærk! Microsoft Jet-databasemotoren understøtter ikke brugen af CREATE PROCEDURE eller DDL-sætninger med ikke-Microsoft Jet-databasemotordatabaser.

Syntaks

CREATE PROCEDURE procedure
[param1 datatype[, param2 datatype[, ...]] AS sqlstatement

Sætningen CREATE INDEX indeholder følgende argumenter:

Argument | Beskrivelse
procedure | Et navn til proceduren. Det skal følge standardnavngivningskonventioner.
param1, param2 | Fra et til 255 feltnavne eller parametre. For eksempel: CREATE PROCEDURE Salg_efter_land [Startdato] DateTime, [Slutdato] DateTime; Yderligere oplysninger om parametre finder du under PARAMETRE.
datatype | En af de primære Microsoft Jet SQL-datatyper eller de tilhørende synonymer.
sqlsætning | En SQL-sætning, såsom SELECT, UPDATE, DELETE, INSERT, CREATE TABLE, DROP TABLE osv.

Bemærkninger

En SQL-procedure består af en PROCEDURE-delsætning, der angiver navnet på proceduren, en valgfri liste over parameterdefinitioner og en enkelt SQL-sætning.

Et procedurenavn kan ikke være det samme som navnet på en eksisterende tabel.

Se også
Sætningen ADD USER | Sætningen CREATE USER eller GROUP
Sætningen ALTER USER eller DATABASE | Sætningen CREATE VIEW
Sætningen ALTER TABLE | Sætningen DROP
Delsætningen CONSTRAINT | Sætningen DROP USER eller GROUP
Sætningen CREATE INDEX | Sætningen GRANT
Sætningen CREATE TABLE | Sætningen REVOKE

Eksempel

Sætningen CREATE PROCEDURE, eksempel på delsætningen PROCEDURE


Sætningen CREATE TABLE (Microsoft Jet SQL)

Sætningen CREATE TABLE

Opretter en ny tabel.

Bemærk! Microsoft Jet-databasemotoren understøtter ikke brugen af CREATE TABLE eller DDL-sætninger med ikke-Microsoft Jet-databasemotordatabaser. Du skal i stedet bruge DAO Create-metoderne.

Syntaks

CREATE [TEMPORARY] TABLE tabel (felt1 type [(størrelse)] [NOT NULL] [WITH COMPRESSION | WITH COMP] [indeks1] [, felt2 type [(størrelse)] [NOT NULL] [indeks2] [, ...]] [, CONSTRAINT flerfeltindeks [, ...]])

Sætningen CREATE TABLE indeholder følgende argumenter:

Argument | Beskrivelse
tabel | Navnet på den tabel, der skal oprettes.
felt1, felt2 | Navnet på det eller de felter, der skal oprettes i den nye tabel. Du skal oprette mindst ét felt.
type | Datatypen i felt i den nye tabel.
størrelse | Feltstørrelsen i tegn (kun tekstfelter og binære felter).
indeks1, indeks2 | En CONSTRAINT-delsætning, der definerer et indeks med et enkelt felt. Yderligere oplysninger om, hvordan dette indeks oprettes, findes i CONSTRAINT-deltsætning.
flerfeltindeks | En CONSTRAINT-delsætning, der definerer et indeks med flere felter. Yderligere oplysninger om, hvordan dette indeks oprettes, findes i CONSTRAINT-deltsætning.

Bemærkninger

Du kan bruge sætningen CREATE TABLE til at definere en ny tabel og de tilhørende felter og feltbegrænsninger. Hvis NOT NULL er angivet for et felt, skal de nye poster indeholde gyldige data i dette felt.

En CONSTRAINT-delsætning etablerer flere begrænsninger på et felt og kan bruges til at etablere den primære nøgle. Du kan også bruge sætningen CREATE INDEX til at oprette en primær nøgle eller flere indeks på eksisterende tabeller.

Du kan ikke bruge NOT NULL i et enkelt felt eller i en navngivet CONSTRAINT-delsætning, der gælder for enten et enkelt felt eller flere felter med navnet CONSTRAINT. Du kan dog kun anvende begrænsningen NOT NULL én gang i et felt. Forsøg på at anvende denne begrænsning mere end én gang medfører en kørselsfejl.

Når en TEMPORARY-tabel oprettes, er den kun synlig i den session, hvor den blev oprettet. Den slettes automatisk, når sessionen afsluttes. Midlertidige tabeller kan åbnes af mere end én bruger.

Attributten WITH COMPRESSION kan kun bruges med datatyperne CHARACTER og MEMO (også kendt som TEXT) og deres synonymer.

Attributten WITH COMPRESSION blev tilføjet til CHARACTER-kolonner pga. ændringen i repræsentationsformatet for Unicode-tegn. Alle Unicode-tegn kræver to byte til hvert tegn. I forbindelse med eksisterende Microsoft® Jet-databaser, der indeholder fremherskende tegndata, kan dette betyde, at databasefilen næsten fordobles i størrelse, når den konverteres til Microsoft Jet version 4.0-formatet. Unicode-præsentation af mange tegnsæt, tidligere beskrevet som SBCS (Single-Byte Character Sets) kan let komprimeres til en enkelt byte. Hvis du definerer en CHARACER-kolonne med dette attribut, komprimeres data automatisk, når de lagres og dekomprimeres, når de hentes fra kolonnen.

MEMO-kolonner kan også defineres til at lagre data i et komprimeret format. Der er dog en begrænsning. Forekomster af MEMO-kolonner komprimeres kun, når de kan komprimeres til 4096 eller der under. Alle andre forekomster af MEMO-kolonner forbliver dekomprimerede. Dette betyder, at i en given tabel for en given MEMO-kolonne kan nogle data blive komprimeret og andre data ikke.

Se også
Sætningen ADD USER | Sætningen CREATE USER eller GROUP
Sætningen ALTER USER eller DATABASE | Sætningen CREATE VIEW
Sætningen ALTER TABLE | Sætningen DROP
Delsætningen CONSTRAINT | Sætningen DROP USER eller GROUP
Sætningen CREATE INDEX | Sætningen GRANT
Sætningen CREATE PROCEDURE | Sætningen REVOKE

Eksempel

Sætningen CREATE TABLE, Eksempel på delsætningen CONSTRAINT


Eksempel på sætningen CREATE TABLE og delsætningen CONSTRAINT (DAO)

Eksempel på sætningen CREATE TABLE og delsætningen CONSTRAINT

I følgende eksempel oprettes en ny tabel med navnet DenneTabel med to tekstfelter.

Sub CreateTableX1()

    Dim dbs As Database

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

' Opret en tabel med to tekstfelter.

    dbs.Execute "CREATE TABLE DenneTabel " _

        & "(Fornavn CHAR, Efternavn CHAR);"

    dbs.Close

End Sub

I følgende eksempel oprettes en ny tabel med navnet MinTabel, som har to felter af typen Text, et felt af typen Date/Time og et unikt indeks bestående af alle tre felter.

Sub CreateTableX2()

    Dim dbs As Database

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Opret en tabel med tre felter og et unikt

    ' indeks bestående af alle tre felter.

    dbs.Execute "CREATE TABLE MinTabel " _

        & "(Fornavn CHAR, Efternavn CHAR), " _

        & "Fødselsdato DATETIME, " _

        & "CONSTRAINT MinTabelBetingelse UNIQUE " _

        & "(Fornavn, Efternavn, Fødselsdato));"

    dbs.Close

End Sub

I følgende eksempel oprettes en ny tabel med to felter af typen Text og et felt af typen Integer. Feltet CPRnummer er den primære nøgle.

Sub CreateTableX3()

     Dim dbs As Database

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Opret en tabel med tre felter og en primær

    ' nøgle.

    dbs.Execute "CREATE TABLE NyTabel " _

        & "(Fornavn CHAR, Efternavn CHAR), " _

        & "CPRnr INTEGER CONSTRAINT MitFeltBetingelse " _

        & "PRIMARY KEY);"

    dbs.Close

End Sub


Sætningen CREATE USER eller GROUP (Microsoft Jet SQL)

Sætningen CREATE USER eller GROUP

Opretter en eller flere nye brugere eller grupper.

Syntaks

Opret en bruger:

CREATE USER bruger adgangskode pid [, bruger adgangskode pid, …]

Opret en gruppe:

CREATE GROUP gruppe pid[, gruppe pid, …]

Sætningen CREATE USER eller GROUP indeholder følgende argumenter:

Argument | Beskrivelse
bruger | Navnet på en bruger, der skal tilføjes til arbejdsgruppeoplysningsfilen.
gruppe | Navnet på en gruppe, der skal tilføjes til arbejdsgruppeoplysningsfilen.
Adgangskoder | Den adgangskode, der skal tilknyttes det angivne brugernavn.
pid | Det personlige id.

Bemærkninger

En bruger og en gruppe kan ikke have samme navn.

Det er nødvendigt med en adgangskode til hver bruger eller gruppe, der oprettes.

Se også
Sætningen ADD USER | Sætningen CREATE TABLE
Sætningen ALTER USER eller DATABASE | Sætningen CREATE VIEW
Sætningen ALTER TABLE | Sætningen DROP
Delsætningen CONSTRAINT | Sætningen DROP USER eller GROUP
Sætningen CREATE INDEX | Sætningen GRANT
Sætningen CREATE PROCEDURE | Sætningen REVOKE


Sætningen CREATE VIEW (Microsoft Jet SQL)

Sætningen CREATE VIEW

Opretter en ny visning.

Bemærk! Microsoft Jet-databasemotoren understøtter ikke brugen af CREATE VIEW eller DDL-sætninger med ikke-Microsoft Jet-databasemotordatabaser.

Syntaks

CREATE VIEW visning [(felt1[, felt2[, ...]])] AS selectsætning

Sætningen CREATE VIEW indeholder følgende argumenter:

Argument | Beskrivelse
visning | Navnet på den visning, der skal oprettes.
felt1, felt2 | Navnet på feltet eller felterne til de tilsvarende felter, der er angivet i selectsætning.
selectsætning | En SQL SELECT-sætning. Yderligere oplysninger findes i Sætningen SELECT.

Bemærkninger

Sætningen SELECT, der definerer visningen, kan ikke være en SELECT INTO-sætning.

Sætningen SELECT, der definerer visningen, kan ikke indeholde parametre.

Navnet på visningen kan ikke være det samme som navnet på en eksisterende tabel.

Hvis den forespørgsel, der er defineret af sætningen SELECT, kan opdateres, kan visningen derfor også opdateres. I modsat fald er visningen skrivebeskyttet.

Hvis en af forespørgslens to felter, der er defineret af SELECT-sætningen, har samme navn, skal visningsdefinitionen indeholde en feltliste, der angiver entydige navne for hvert af felterne i forspørgslen.

Se også
Sætningen ADD USER | Sætningen CREATE USER eller GROUP
Sætningen ALTER USER eller DATABASE | Sætningen CREATE TABLE
Sætningen ALTER TABLE | Sætningen DROP
Delsætningen CONSTRAINT | Sætningen DROP USER eller GROUP
Sætningen CREATE INDEX | Sætningen GRANT
Sætningen CREATE PROCEDURE | Sætningen REVOKE


Sætningen DELETE (Microsoft Jet SQL)

Sætningen DELETE

Opretter en sletteforespørgsel, der fjerner poster fra en eller flere af de tabeller, der er anført i delsætningen FROM, som opfylder delsætningen WHERE.

Syntaks

DELETE [tabel.*]
FROM tabel
WHERE kriterier

Sætningen DELETE indeholder følgende argumenter:

Argument | Beskrivelse
tabel | Det valgfrie navn på den tabel, som posterne slettes fra.
tabel | Navnet på den tabel, som posterne slettes fra.
kriterier | Et udtryk der afgør, hvilke poster der skal slettes.

Bemærkninger

DELETE er især nyttig, når du vil slette mange poster.

Hvis du vil slette en hel tabel fra databasen, kan du bruge metoden Execute sammen med en DROP-sætning. Hvis du sletter tabellen, går strukturen dog tabt. Hvis du i stedet bruger DELETE, slettes kun dataene. Tabelstrukturen og alle tabelegenskaberne, såsom feltattributter og indeks, forbliver intakte.

Du kan bruge DELETE til at fjerne poster fra de tabeller, der har en en-til-mange-relation med andre tabeller. Kaskadevise slettehandlinger medfører, at posterne i de tabeller, der er på mange-siden af relationen, slettes, når den tilsvarende post på en-siden af relationen slettes i forespørgslen. I relationen mellem tabellerne Kunder og Ordrer er tabellen Kunder f.eks. på en-siden, og tabellen Ordrer er på mange-siden af relationen. Sletning af en post fra tabellen Kunder medfører, at tilsvarende poster i Ordrer slettes, hvis indstillingen Kaskadevis sletning er angivet.

En sletteforespørgsel sletter hele poster og ikke kun data i bestemte felter. Hvis du vil slette værdier i et bestemt felt, skal du oprette en opdateringsforespørgsel, der ændrer værdierne til Null.

Vigtigt!

  • Når du har fjernet poster ved hjælp af en sletteforespørgsel, kan du ikke fortryde handlingen. Hvis du vil vide, hvilke poster der slettes, skal du først undersøge resultaterne af en udvælgelsesforespørgsel, der anvender samme kriterier, og derefter køre sletteforespørgslen.
  • Behold altid sikkerhedskopier af dataene. Hvis du sletter de forkerte poster, kan du udtrække dem fra sikkerhedskopierne.
Se også
Sætningen DROP (Microsoft Jet SQL) | Sætningen SELECT (Microsoft Jet SQL)
Delsætningen FROM (Microsoft Jet SQL) | Sætningen UPDATE (Microsoft Jet SQL)
Delsætningen IN (Microsoft Jet SQL) | Sætningen WHERE (Microsoft Jet SQL)
Handlingen INNER JOIN (Microsoft Jet SQL) |

Eksempel

Eksempel på sætningen DELETE


Eksempel på sætningen DELETE (DAO)

Eksempel på sætningen DELETE

I følgende eksempel slettes alle de poster, hvor stilling er Elev. Hvis der kun findes én tabel i delsætningen FROM, er det ikke nødvendigt at angive tabelnavnet i DELETE-sætningen.

Sub DeleteX()

    Dim dbs As Database, rst As Recordset

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Slet de medarbejderposter, hvor stillingen er Elev

    dbs.Execute "DELETE * FROM " _

        & "Medarbejdere WHERE Stilling = 'Elev';"

    dbs.Close

End Sub


Sætningen DROP (Microsoft Jet SQL)

Sætningen DROP

Slette en eksisterende tabel, procedure eller visning fra en database, eller slette et eksisterende indeks fra en tabel.

Bemærk! Microsoft Jet-databasemotoren understøtter ikke brugen af DROP eller DDL-sætninger med ikke-Microsoft Jet-databasemotordatabaser. Du skal i stedet bruge DAO Delete-metoderne.

Syntaks

DROP {TABLE tabel | INDEX indeks ON tabel | PROCEDURE procedure | VIEW visning}

Sætningen DROP indeholder følgende argumenter:

Argument | Beskrivelse
tabel | Navnet på den tabel, der skal slettes, eller den tabel, et indeks skal slettes fra.
procedure | Navnet på den procedure, der skal slettes.
visning | Navnet på den visning, der skal slettes.
indeks | Navnet på det indeks, der skal slettes fra tabel.

Bemærkninger

Du skal lukke tabellen, før du kan slette den eller fjerne et indeks fra den.

Du kan også bruge ALTER TABLE til at slette et indeks i en tabel.

Du kan bruge CREATE TABLE til at oprette en tabel og CREATE INDEX eller ALTER TABLE til at oprette et indeks. Hvis du vil ændre en tabel, skal du bruge ALTER TABLE.

Se også
Sætningen ADD USER | Sætningen CREATE USER eller GROUP
Sætningen ALTER USER eller DATABASE | Sætningen CREATE TABLE
Sætningen ALTER TABLE | Sætningen CREATE VIEW
Delsætningen CONSTRAINT | Sætningen DROP USER eller GROUP
Sætningen CREATE INDEX | Sætningen GRANT
Sætningen CREATE PROCEDURE | Sætningen REVOKE

Eksempel

Eksempel på sætningen DROP


Sætningen DROP USER eller GROUP (Microsoft Jet SQL)

Sætningen DROP USER eller GROUP

Sletter en eller flere eksisterende brugere eller grupper, eller fjerner en eller flere eksisterende brugere fra en eksisterende gruppe.

Syntaks

Sletter en eller flere eksisterende brugere, eller fjerner en eller flere brugere fra en gruppe.

DROP USER bruger[, bruger, …] [FROM gruppe]

Sletter en eller flere grupper:

DROP GROUP gruppe[, gruppe, …]

Sætningen DROP USER eller GROUP indeholder følgende argumenter:

Argument | Beskrivelse
bruger | Navnet på en bruger, der skal fjernes fra arbejdsgruppeoplysningsfilen.
gruppe | Navnet på en gruppe, der skal fjernes fra arbejdsgruppeoplysningsfilen.

Bemærkninger

Hvis det reserverede ord FROM bruges i sætningen DROP USER, fjernes hver af de brugere, der er indeholdt i sætningen fra den gruppe, der er angivet efter det reserverede ord FROM. Selve brugerne slettes dog ikke.

Sætningen DROP GROUP sletter den eller de angivne grupper. De brugere, der er medlemmer af grupperne, påvirkes ikke, men de er ikke længere medlemmer af den eller de slettede grupper.

Se også
Sætningen ADD USER | Sætningen CREATE TABLE
Sætningen ALTER USER eller DATABASE | Sætningen CREATE USER eller GROUP
Sætningen ALTER TABLE | Sætningen CREATE VIEW
Delsætningen CONSTRAINT | Sætningen DROP
Sætningen CREATE INDEX | Sætningen GRANT
Sætningen CREATE PROCEDURE | Sætningen REVOKE


Eksempel på sætningen DROP (DAO)

Eksempel på sætningen DROP

I følgende eksempler antages det, at der findes et hypotetisk indeks med navnet NytIndeks i tabellen Medarbejdere i databasen Northwind.

I følgende eksempel slettes indekset NytIndeks i tabellen Medarbejdere.

Sub DropX1()

    Dim dbs As Database

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Slet NytIndeks i tabellen Medarbejdere.

    dbs.Execute "DROP INDEX NytIndeks ON Medarbejdere;"

    dbs.Close

End Sub

I følgende eksempel slettes tabellen Medarbejdere i databasen.

Sub DropX2()

    Dim dbs As Database

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Slet tabellen Medarbejdere.

    dbs.Execute "DROP TABLE Medarbejdere;"

    dbs.Close

End Sub


Ækvivalente ANSI SQL-datatyper

I følgende tabel vises ANSI SQL-datatyper og de ækvivalente SQL-datatyper i Microsoft Jet-databasemotoren samt deres gyldige synonymer. Den viser også de ækvivalente Microsoft® SQL Server™-datatyper.

ANSI SQL- datatype | Microsoft Jet SQL-datatype | Synonym | Microsoft SQL Server-datatype
BIT, BIT VARYING | BINARY (Se "Bemærkninger") | VARBINARY, BINARY VARYING BIT VARYING | BINARY, VARBINARY
Ikke understøttet | BIT (Se " Bemærkninger") | BOOLEAN, LOGICAL, LOGICAL1, YESNO | BIT
Ikke understøttet | TINYINT | INTEGER1, BYTE | TINYINT
Ikke understøttet | BINARY (Se " Bemærkninger") | AUTOINCREMENT | (Se "Bemærkninger")
Ikke understøttet | MONEY | CURRENCY | MONEY
DATE, TIME, TIMESTAMP | DATETIME | DATE, TIME (Se " Bemærkninger") | DATETIME
Ikke understøttet | UNIQUEIDENTIFIER | GUID | UNIQUEIDENTIFIER
DECIMAL | DECIMAL | NUMERIC, DEC | DECIMAL
REAL | REAL | SINGLE, FLOAT4, IEEESINGLE | REAL
DOUBLE PRECISION, FLOAT | FLOAT | DOUBLE, FLOAT8, IEEEDOUBLE, NUMBER (Se " Bemærkninger") | FLOAT
SMALLINT | SMALLINT | SHORT, INTEGER2 | SMALLINT
INTEGER | INTEGER | LONG, INT, INTEGER4 | INTEGER
INTERVAL | Ikke understøttet |  | Ikke understøttet
Ikke understøttet | IMAGE | LONGBINARY, GENERAL, OLEOBJECT | IMAGE
Ikke understøttet | TEXT (Se " Bemærkninger") | LONGTEXT, LONGCHAR, MEMO, NOTE, NTEXT (Se " Bemærkninger") | TEXT
CHARACTER, CHARACTER VARYING, NATIONAL CHARACTER, NATIONAL CHARACTER VARYING | CHAR (Se " Bemærkninger") | TEXT(n), ALPHANUMERIC, CHARACTER, STRING, VARCHAR, CHARACTER VARYING, NCHAR, NATIONAL CHARACTER, NATIONAL CHAR, NATIONAL CHARACTER VARYING, NATIONAL CHAR VARYING (Se " Bemærkninger") | CHAR, VARCHAR, NCHAR, NVARCHAR

Bemærkninger

  • ANSI SQL BIT-datatypen svarer ikke til Microsoft Jet SQL BIT-datatypen. Den svarer i stedet til datatypen BINARY. Der findes ingen ANSI SQL-ækvivalent til Microsoft Jet SQL BIT-datatypen.
  • TIMESTAMP understøttes ikke længere som et synonym for DATETIME.
  • NUMERIC understøttes ikke længere som et synonym for FLOAT eller DOUBLE. NUMERIC bruges nu som et synonym for DECIMAL.
  • Et felt af typen LONGTEXT gemmes altid i Unicode-repræsentationsformatet.
  • Hvis datatypenavnet TEXT bruges uden angivelse af valgfri længde, f.eks.TEXT(25), oprettes et felt af typen LONGTEXT. Dette muliggør, at der kan skrives CREATE TABLE-sætninger, der vil vige for datatyper, som er konsistente med Microsoft SQL Server.
  • Et felt af typen CHAR gemmes altid i Unicode-repræsentationsformatet, der er ækvivalenten til ANSI SQL NATIONAL CHAR-datatypen.
  • Hvis datatypenavnet TEXT bruges, og den valgfrie længde er angivet, f.eks.TEXT(25), er feltets datatype ækvivalent til datatypen CHAR. Hermed bevares kompatibiliteten bagud for de fleste Microsoft Jet-programmer, mens det er muligt at justere TEXT-datatypen (uden en længdeangivelse) med Microsoft SQL Server.
Se også

SQL-datatyper i Microsoft Jet-databasemotor


Sætningen EXECUTE (Microsoft Jet SQL)

Sætningen EXECUTE

Bruges til at kalde udførelsen af en procedure.

Syntaks

EXECUTE procedure [param1[, param2[, ...]]

Sætningen EXECUTE indeholder følgende argumenter:

Argument | Beskrivelse
procedure | Navnet på den procedure, der skal udføres.
param1, param2, … | Værdier til de parametre, der er defineret af proceduren.

Se også
Erklæringen PARAMETERS (Microsoft Jet SQL) Delsætningen PROCEDURE (Microsoft Jet SQL)

Eksempel

Sætningen CREATE PROCEDURE, eksempel på delsætningen PROCEDURE


SQL-udtryk

Et SQL-udtryk er en streng, der udfører hele eller en del af en SQL-sætning. Metoden FindFirst på et Recordset-objekt bruger f.eks. et SQL-udtryk, der består af de udvælgelseskriterier, der er fundet i en SQL WHERE-delsætning.

Microsoft Jet-databasemotoren benytter den udtryksservice, der findes i Microsoft® Visual Basic for Applications (eller VBA), til at udføre simple aritmetiske udregninger og funktionsudregninger. Alle de operatorer, der bruges i SQL-udtryk i Microsoft Jet SQL (undtagen Between, In, og Like) er defineret af VBA-udtryksservice. Derudover har VBA-udtryksservice over 100 VBA-funktioner, som du kan anvende i SQL-udtryk. Du kan f.eks. bruge disse VBA-funktioner til at oprette en SQL-forespørgsel i forespørgselsdesign i Microsoft Access, og du kan også bruge disse funktioner i en SQL-forespørgsel i metoden DAO OpenRecordset i Microsoft Visual C++®, Microsoft Visual Basic og Microsoft Excel-kode.


Funktionerne First og Last (Microsoft Jet SQL)

Funktionerne First og Last

Returnerer en feltværdi fra første eller sidste post i det resultatsæt, der returneres af en forespørgsel.

Syntaks

First(udtr)

Last(udtr)

Pladsholderen udtr repræsenterer et strengudtryk, der identificerer det felt, som indeholder de data, du vil beregne gennemsnittet af, eller et udtryk, der udfører en beregning ved hjælp af dataene i det pågældende felt. Operander i udtr kan medtage navnet på et tabelfelt, en konstant eller på en funktion, der kan være enten indbygget eller brugerdefineret, men ikke en af de andre SQL- aggregat funktioner.

Bemærkninger

Funktionerne First og Last svarer til metoderne MoveFirst og MoveLast i et DAO Recordset-objekt. De returnerer blot værdien af et angivet felt i henholdsvis den første eller sidste post i det resultatsæt, der returneres af en forespørgsel. Da poster normalt ikke returneres i en bestemt rækkefølge (medmindre forespørgslen medtager en ORDER BY-delsætning), vil de poster, der returneres af disse funktioner, være tilfældige.

Se også
Beregning af felter i SQL-funktioner SQL-aggregatfunktioner (SQL)

Eksempel

Eksempel på funktionerne First og Last


Eksempel på funktionerne First og Last (DAO)

Eksempel på funktionerne First og Last

I følgende eksempel benyttes tabellen Medarbejdere til at returnere værdierne fra feltet Efternavn i første og sidste post, der returneres fra tabellen.

I følgende eksempel kaldes proceduren EnumFields, som du finder i eksemplet på sætningen SELECT.

Sub FirstLastX1()

    Dim dbs As Database, rst As Recordset

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Returner værdierne i feltet Efternavn i

    ' første og sidste post, der returneres fra tabellen.

    Set rst = dbs.OpenRecordset("SELECT " _

        & "First(Efternavn) as Første, " _

        & "Last(Efternavn) as Sidste FROM Medarbejdere;")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    ' Recordset-objektet. Overfør Recordset-objektet og

    ' den ønskede feltbredde.

    EnumFields rst, 12

    dbs.Close

End Sub

I næste eksempel sammenlignes brugen af funktionerne First og Last med brugen af Min og Max til at finde den tidligste og seneste fødselsdato for medarbejdere.

Sub FirstLastX2()

    Dim dbs As Database, rst As Recordset

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Find den tidligste og seneste fødselsdato

    ' i tabellen Medarbejdere

    Set rst = dbs.OpenRecordset("SELECT " _

        & "First(Fødselsdato) as FørsteFD, " _

        & "Last(Fødselsdato) as SidsteFD FROM Medarbejdere;")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    ' Recordset-objektet. Overfør Recordset-objektet og

    ' den ønskede feltbredde.

    EnumFields rst, 12

    Debug.Print

    ' Find den tidligste og seneste fødselsdato

    ' i tabellen Medarbejdere

    Set rst = dbs.OpenRecordset("SELECT " _
        & "Min(Fødselsdato) as MinFD," _

        & "Max(Fødselsdato) as MaksFD FROM Medarbejdere;")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    ' Recordset-objektet. Overfør Recordset-objektet og

    ' den ønskede feltbredde.

    EnumFields rst, 12

    dbs.Close

End Sub


Delsætningen FROM (Microsoft Jet SQL)

Delsætningen FROM

Angiver tabeller eller forespørgsler, der indeholder de felter, der anføres i SELECT-sætningen.

Syntaks

SELECT feltliste
FROM tabeludtryk [IN eksterndatabase]

En SELECT-sætning, der indeholder en FROM-delsætning, har følgende argumenter:

Argument | Beskrivelse
feltliste | Navnet på det eller de felter, der skal hentes sammen med eventuelle aliaser for feltnavne, SQL-aggregatfunktioner, udvælgelsesprædikater (ALL, DISTINCT, DISTINCTROW eller TOP) eller andre gyldige SELECT-sætninger.
tabeludtryk | Et udtryk, der identificerer en eller flere tabeller, som data hentes fra. Udtrykket kan være et enkelt tabelnavn, et gemt forespørgselsnavn eller et sammensat resultat fra INNER JOIN, LEFT JOIN eller RIGHT JOIN.
eksterndatabase | Den fulde sti i en ekstern database, der indeholder alle tabeller i tabeludtryk.

Bemærkninger

FROM er obligatorisk og følger efter enhver SELECT-sætning.

Rækkefølgen af tabelnavne i tabeludtryk er ikke vigtig.

Det anbefales, at du bruger en sammenkædet tabel i stedet for en IN-delsætning til at hente data i en ekstern database for at forbedre ydeevnen og lette udførelsen.

I følgende eksempel vises, hvordan du kan hente data i tabellen Medarbejdere:

SELECT Efternavn, Fornavn

FROM Medarbejdere;

Se også
Eksempel på prædikaterne ALL DISTINCT, DISTINCTROW, TOP (Microsoft Jet SQL) | Sætningen SELECT (Microsoft Jet SQL)
Delsætningen IN (Microsoft Jet SQL) | SQL-aggregatfunktioner (SQL)
Handlingerne LEFT JOIN og RIGHT JOIN (Microsoft Jet SQL) | Delsætningen WHERE (Microsoft Jet SQL)
Handlingen INNER JOIN (Microsoft Jet SQL) |

Eksempel

Eksempel på sætningen SELECT og delsætningen FROM


Sætningen GRANT (Microsoft Jet SQL)

Sætningen GRANT

Giver bestemte rettigheder til en eksisterende bruger eller gruppe.

Syntaks

GRANT {rettighed[, rettighed, …]} ON
{TABLE tabel |
OBJECT objekt|

CONTAINER objektbeholder } TO {autorisationsnavn[, autorisationsnavn, …]}

Sætningen GRANT indeholder følgende argumenter:

Argument | Beskrivelse
rettighed | Den eller de rettigheder, der gives. Rettigheder angives ved hjælp af følgende reserverede ord: SELECT, DELETE, INSERT, UPDATE, DROP, SELECTSECURITY, UPDATESECURITY, DBPASSWORD, UPDATEIDENTITY, CREATE, SELECTSCHEMA, SCHEMA og UPDATEOWNER.
tabelnavn | Et gyldigt tabelnavn.
objekt | Dette kan omfatte alle ikke-tabelobjekter. En lagret forespørgsel (visning eller procedure) er et eksempel.
objektbeholder | Navnet på en gyldig objektbeholder.
autorisationsnavn | Et bruger- eller gruppenavn.

Se også
Sætningen ADD USER | Sætningen CREATE TABLE
Sætningen ALTER USER eller DATABASE | Sætningen CREATE USER eller GROUP
Sætningen ALTER TABLE | Sætningen CREATE VIEW
Delsætningen CONSTRAINT | Sætningen DROP
Sætningen CREATE INDEX | Sætningen DROP USER eller GROUP
Sætningen CREATE PROCEDURE | Sætningen REVOKE


Delsætningen GROUP BY (Microsoft Jet SQL)

Delsætningen GROUP BY

Kombinerer poster med identiske værdier i den angivne feltliste til en enkelt post. Der oprettes en opsummeringsværdi for hver post, hvis du medtager en SQL-aggregatfunktion, såsom Sum eller Count, i SELECT-sætningen.

Syntaks

SELECT feltliste
FROM tabel
WHERE kriterier
[GROUP BY gruppefeltliste]

En SELECT-sætning, der indeholder en GROUP BY-delsætning, har følgende argumenter:

Argument | Beskrivelse
feltliste | Navnet på det eller de felter, der skal hentes sammen med eventuelle aliaser for feltnavne, SQL-aggregatfunktioner, udvælgelsesprædikater (ALL, DISTINCT, DISTINCTROW eller TOP) eller andre gyldige SELECT-sætninger.
tabel | Navnet på den tabel, som posterne hentes fra. Yderligere oplysninger finder du i emnet om FROM-delsætningen.
kriterier | Udvælgelseskriterier. Hvis sætningen medtager en WHERE-delsætning, grupperer Microsoft Jet-databasemotoren værdier, efter at WHERE-betingelserne er anvendt på posterne.
gruppefeltliste | Navnene på op til 10 felter, der anvendes til at gruppere poster. Rækkefølgen af feltnavne i gruppefeltliste bestemmer grupperingsniveauerne fra det højeste til det laveste grupperingsniveau.

Bemærkninger

GROUP BY er valgfri.

Opsummeringsværdier udelades, hvis der ikke er nogen SQL-aggregatfunktion i SELECT-sætningen.

Null-værdier i GROUP BY-felter grupperes og udelades ikke. Null-værdier evalueres dog ikke i nogen SQL-aggregatfunktioner.

Du kan bruge WHERE-delsætningen til at udelukke de rækker, du ikke vil have grupperet, og anvende HAVING-delsætningen til at filtrere poster, når de er blevet grupperet.

Medmindre et felt indeholder data af typen Memo eller OLE Object, kan det i GROUP BY-feltlisten referere til ethvert felt i en tabel, der vises i FROM-delsætningen, selv hvis feltet ikke er medtaget i SELECT-sætningen, forudsat at SELECT-sætningen medtager mindst én SQL-aggregatfunktion. Microsoft® Jet-databasemotoren kan ikke gruppere felter af typen Memo eller OLE Object.

Alle felter i SELECT-feltlisten skal medtages enten i GROUP BY-delsætningen eller som argumenter til en SQL-aggregatfunktion.

Se også
Prædikaterne ALL DISTINCT, DISTINCTROW, TOP (Microsoft Jet SQL) | Sætningen SELECT (Microsoft Jet SQL)
Delsætningen FROM (Microsoft Jet SQL) | Sætningen SELECT...INTO (Microsoft Jet SQL)
Delsætningen HAVING (Microsoft Jet SQL) | SQL-aggregatfunktioner (SQL)
Delsætningen ORDER BY (Microsoft Jet SQL) | Delsætningen WHERE (Microsoft Jet SQL)

Eksempel

Eksempel på delsætningen GROUP BY


Eksempel på delsætningen GROUP BY (DAO)

Eksempel på delsætningen GROUP BY

I følgende eksempel oprettes en liste over unikke stillinger, og for hver stilling angives antallet af medarbejdere.

I følgende eksempel kaldes proceduren EnumFields, som du finder i eksemplet på sætningen SELECT.

Sub GroupByX1()

    Dim dbs As Database, rst As Recordset

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Tæl antallet af medarbejdere for hver

    ' stilling.

    Set rst = dbs.OpenRecordset("SELECT Stilling, " _

        & "Count([Stilling]) AS Antal" _

        & "FROM Medarbejdere GROUP BY Stilling;")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    ' Recordset-objektet. Overfør Recordset-objektet og

    ' den ønskede feltbredde.

    EnumFields rst, 25

    dbs.Close

End Sub

I forbindelse med alle unikke stillinger beregnes i følgende eksempel antallet af medarbejdere i Washington, der har denne stilling.

Sub GroupByX2()

    Dim dbs As Database, rst As Recordset

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Tæl antallet af medarbejdere for hver

    ' stilling Medtag kun medarbejdere i.

    ' Washington-området.

    Set rst = dbs.OpenRecordset("SELECT Stilling, " _

        & "Count(Stilling) AS Antal " _

        & "FROM Medarbejdere WHERE Område = 'WA' " _

        & "GROUP BY Stilling;")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    ' Recordset-objektet. Overfør Recordset-objektet og

    ' den ønskede feltbredde.

    EnumFields rst, 25

    dbs.Close

End Sub


Delsætningen HAVING (Microsoft Jet SQL)

Delsætningen HAVING

Angiver, hvilke grupperede poster der vises i en SELECT-sætning med en GROUP BY-delsætning. Når posterne er kombineret med GROUP BY, viser HAVING alle de poster, der er grupperet med GROUP BY-delsætningen, som opfylder betingelserne i HAVING-delsætningen.

Syntaks

SELECT feltliste
FROM tabel
WHERE udvælgelseskriterier
GROUP BY gruppefeltliste
[HAVING gruppekriterier]

En SELECT-sætning, der indeholder en HAVING-delsætning, har følgende argumenter:

Argument | Beskrivelse
feltliste | Navnet på det eller de felter, der skal hentes sammen med eventuelle aliaser for feltnavne, SQL-aggregatfunktioner, udvælgelsesprædikater (ALL, DISTINCT, DISTINCTROW eller TOP) eller andre gyldige SELECT-sætninger.
tabel | Navnet på den tabel, som posterne hentes fra. Yderligere oplysninger finder du i emnet om FROM-delsætningen.
udvælgelseskriterier | Udvælgelseskriterier. Hvis sætningen medtager en WHERE-delsætning, grupperer Microsoft Jet-databasemotoren værdier, efter at WHERE-betingelserne er anvendt på posterne.
gruppefeltliste | Navnene på op til 10 felter, der anvendes til at gruppere poster. Rækkefølgen af feltnavne i gruppefeltliste bestemmer grupperingsniveauerne fra det højeste til det laveste grupperingsniveau.
gruppekriterier | Et udtryk, der bestemmer, hvilke grupperede poster der skal vises.

Bemærkninger

HAVING er valgfri.

HAVING svarer til WHERE, som bestemmer hvilke poster, der vælges. Når posterne er grupperet med GROUP BY, bestemmer HAVING, hvilke poster der vises:

SELECT Kategorinr,

Sum([Enheder på lager])

FROM Produkter

GROUP BY Kategorinr

HAVING Sum([Enheder på lager]) > 100 And Like "BOS*";

En HAVING-delsætning kan indeholde op til 40 udtryk, der er sammenkædet ved hjælp af logiske operatorer, såsom And og Or.

Se også
Prædikaterne ALL DISTINCT, DISTINCTROW, TOP (Microsoft Jet SQL) | Sætningen SELECT (Microsoft Jet SQL)
Delsætningen FROM (Microsoft Jet SQL) | Sætningen SELECT...INTO (Microsoft Jet SQL)
Delsætningen GROUP BY (Microsoft Jet SQL) | SQL-aggregatfunktioner (SQL)
Delsætningen ORDER BY (Microsoft Jet SQL) | Delsætningen WHERE (Microsoft Jet SQL)

Eksempel

Eksempel på delsætningen HAVING


Eksempel på delsætningen HAVING (DAO)

Eksempel på delsætningen HAVING

I følgende eksempel udvælges de stillinger, der er tildelt til mere end én medarbejder i Washington-området.

I følgende eksempel kaldes proceduren EnumFields, som du finder i eksemplet på sætningen SELECT.

Sub HavingX()

    Dim dbs As Database, rst As Recordset

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Udvælg de stillinger, der er tildelt til mere end

    ' én medarbejder i Washington-området.

    Set rst = dbs.OpenRecordset("SELECT Stilling, " _

        & "Count(Stilling) as Total FROM Medarbejdere " _

        & "WHERE Område = 'WA' " _

        & "GROUP BY Stilling HAVING Count(Stilling) > 1;")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    EnumFields rst, 25

    dbs.Close

End Sub


Delsætningen IN (Microsoft Jet SQL)

Delsætningen IN

Identificerer tabeller i alle eksterne databaser, som Microsoft Jet-databasemotoren kan tilsluttes, såsom en dBASE- eller Paradox-database eller en ekstern Microsoft® Jet-database.

Syntaks

Hvis du vil identificere en destinationstabel:

[SELECT | INSERT] INTO destination IN
{sti | ["sti" "type"] | ["" [type; DATABASE = sti]]}

Hvis du vil identificere en kildetabel:

FROM tabeludtryk IN
{sti | ["sti" "type"] | ["" [type; DATABASE = sti]]}

En SELECT-sætning, der indeholder en IN-delsætning, har følgende argumenter:

Argument | Beskrivelse
destination | Navnet på den eksterne tabel, som data indsættes i.
tabeludtryk | Navnet på den eller de tabeller, som data hentes fra. Udtrykket kan være et enkelt tabelnavn, et gemt forespørgselsnavn eller et sammensat resultat fra INNER JOIN LEFT JOIN, RIGHT JOIN.
sti | Hele stien til det bibliotek eller den fil, der indeholder tabel.
type | Navnet på den databasetype, der bruges til at oprette tabel, hvis en database ikke er en Microsoft Jet-database (f.eks. dBASE III, dBASE IV, Paradox 3.x eller Paradox 4.x).

Bemærkninger

Du kan bruge IN til kun at tilslutte til én ekstern database ad gangen.

I nogle tilfælde refererer argumentet sti til det bibliotek, der indeholder databasefilerne. Når du f.eks. arbejder med dBASE-, Microsoft FoxPro®- eller Paradox-databasetabeller, angiver argumentet sti det bibliotek, der indeholder .dbf- eller .db-filer. Tabelfilnavnet hentes fra argumentet destination eller tabeludtryk.

Hvis du vil angive en ikke-Microsoft Jet-database, skal du tilføje et semikolon (;) til navnet og omslutte det i enkelte (' ') eller dobbelte (" ") anførselstegn. Både 'dBASE IV;' og "dBASE IV;" er f.eks. acceptable.

Du kan også anvende det reserverede ord DATABASE til at angive den eksterne database. Følgende linjer angiver f.eks. samme tabel:

... FROM Tabel IN "" [dBASE IV; DATABASE=C:\DBASE\DATA\SALG;];

... FROM Tabel IN " C:\DBASE\DATA\SALG" "dBASE IV;"

Bemærk!

Hvis du vil forbedre ydeevnen og lette udførelsen skal du bruge en sammenkædet tabel i stedet for IN.

Du kan også bruge det reserverede ord IN som en sammenligningsoperator i et udtryk. Yderligere oplysninger finder du i emnet om operatoren In.

Se også
Delsætningen FROM (Microsoft Jet SQL) | Sætningen SELECT (Microsoft Jet SQL)
Handlingen INNER JOIN (Microsoft Jet SQL) | Sætningen SELECT...INTO (Microsoft Jet SQL)
Sætningen INSERT INTO (Microsoft Jet SQL) | SQL-aggregatfunktioner (SQL)
Handlingerne LEFT JOIN og RIGHT JOIN (Microsoft Jet SQL) |

Eksempel

Eksempel på delsætningen IN


Handlingen INNER JOIN (Microsoft Jet SQL)

Handlingen INNER JOIN

Kombinerer poster fra to tabeller, når der er tilsvarende værdier i et almindeligt felt.

Syntaks

FROM tabel1 INNER JOIN tabel2 ON tabel1.felt1 compopr tabel2.felt2

Handlingen INNER JOIN indeholder følgende argumenter:

Argument | Beskrivelse
tabel1, tabel2 | Navnene på de tabeller, hvorfra der skal kombineres poster.
felt1, felt2 | Navnene på de felter, der joinforbindes. Hvis de ikke er numeriske, skal felterne være af samme datatype og indeholde samme slags data, men de behøver ikke at have samme navn.
compopr | Alle relationelle sammenligningsoperatorer: "=," "<," ">," "<=," ">=," eller "<>."

Bemærkninger

Du kan bruge en INNER JOIN-handling i alle FROM-delsætninger. Dette er den mest almindelige type joinforbindelse. Indre joinforbindelser kombinerer poster fra to tabeller, når der er tilsvarende værdier i et felt, der er fælles for begge tabeller.

Du kan bruge INNER JOIN sammen med tabellerne Afdelinger og Medarbejdere til at vælge alle medarbejderne i en afdeling. Hvis du derimod vil vælge alle afdelinger (selvom nogle ikke har tilknyttet medarbejdere) eller alle medarbejdere (selvom nogle ikke er tilknyttet en afdeling), kan du benytte en LEFT JOIN eller RIGHT JOIN-handling til at oprette en ydre joinforbindelse.

Hvis du forsøger at joinforbinde felter, der indeholder data af typen Memo eller OLE Object, opstår der en fejl.

Du kan joinforbinde to numeriske felter af samme type. Du kan f.eks. joinforbinde felter af typen AutoNumber og Long, fordi de er af samme type. Du kan dog ikke kan joinforbinde felter af typen Single og Double.

I følgende eksempel vises, hvordan du kan joinforbinde tabellerne Kategorier og Produkter på feltet Kategorinr:

SELECT Kategorinavn, Produktnavn

FROM Kategorier INNER JOIN Produkter

ON Kategorier.Kategorinr = Produkter.Kategorinr;

I det foregående eksempel er Kategorinr det joinforbundne felt, men det medtages ikke i forespørgslens output, da det ikke er indeholdt i SELECT-sætningen. Hvis du vil medtage det joinforbundne felt, skal du medtage feltnavnet i SELECT-sætningen – i dette tilfælde: Kategorier.Kategorinr.

Du kan også sammenkæde flere ON-delsætninger i en JOIN-sætning ved hjælp af følgende syntaks:

SELECT felter
FROM tabel1 INNER JOIN tabel2
ON tabel1.felt1 compopr tabel2.felt1 AND
ON tabel1.felt2 compopr tabel2.felt2) OR
ON tabel1.felt3 compopr tabel2.felt3)];

Du kan også indlejre JOIN-sætninger ved hjælp af følgende syntaks:

SELECT felter
FROM tabel1 INNER JOIN
(tabel2 INNER JOIN [( ]tabel3
[INNER JOIN [( ]tabelx [INNER JOIN ...)]
ON tabel3.felt3 compopr tabelx.feltx)]
ON tabel2.felt2 compopr tabel3.felt3)
ON tabel1.felt1 compopr tabel2.felt2;

En LEFT JOIN eller en RIGHT JOIN kan være indlejret i en INNER JOIN, men en INNER JOIN kan ikke indlejres i en LEFT JOIN eller en RIGHT JOIN.

Se også
Delsætningen FROM (Microsoft Jet SQL) | Sætningen TRANSFORM (Microsoft Jet SQL)
Handlingerne LEFT JOIN og RIGHT JOIN (Microsoft Jet SQL) | Handlingen UNION (Microsoft Jet SQL)
Sætningen SELECT (Microsoft Jet SQL) |

Eksempel

Eksempel på handlingen INNER JOIN


Eksempel på handlingen INNER JOIN (DAO)

Eksempel på handlingen INNER JOIN

I følgende eksempel oprettes to lighedsjoinforbindelser: En mellem tabellerne Ordrespecifikationer og Ordrer og én mellem tabellerne Ordrer og Medarbejdere. Dette er nødvendigt, da tabellen Medarbejdere ikke indeholder salgsdata, og tabellen Ordrespecifikationer ikke indeholder medarbejderdata. Forespørgslen opretter en liste over medarbejdere og deres salgstotaler.

I følgende eksempel kaldes proceduren EnumFields, som du finder i eksemplet på sætningen SELECT.

Sub InnerJoinX()

    Dim dbs As Database, rst As Recordset

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Opret en joinforbindelse mellem tabellerne

    ' Ordrespecifikationer og Ordrer og én mellem tabellerne Ordrer og Medarbejdere.

    ' Opret en liste over medarbejdere og

    ' deres salgstotaler.

    Set rst = dbs.OpenRecordset("SELECT DISTINCTROW " _

        & "Sum([Pris pr enhed] * Antal) AS Salg, " _

        & "(Fornavn & Chr(32) & Efternavn) AS Navn " _

        & "FROM Medarbejdere INNER JOIN(Ordrer " _

        & "INNER JOIN Ordrespecifikationer " _

        & "ON Ordrespecifikationer.Ordreid = " _

        & "Ordrer.Ordreid ) " _

        & "ON Ordrer.Medarbejderid = " _

        & "Medarbejdere. Medarbejderid " _

        & "GROUP BY (Fornavn & Chr(32) & Efternavn);")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    ' Recordset-objektet. Overfør Recordset-objektet og

    ' den ønskede feltbredde.

    EnumFields rst, 20

    dbs.Close

End Sub


Operatoren In (Microsoft Jet SQL)

Operatoren In

Bestemmer, om værdien i et udtryk er lig med nogle af de forskellige værdier på en angivet liste.

Syntaks

udtr [Not] In(værdi1, værdi2, . . .)

Bemærkninger

Syntaksen til operatoren In indeholder følgende argumenter:

Argument | Beskrivelse
udtr | Udtryk, der identificerer det felt, som indeholder de data, du vil evaluere.
værdi1, værdi2 | Udtryk eller liste over udtryk, du vil evaluere udtr i forhold til.

Hvis udtr findes på listen over værdier, returnerer operatoren In værdien True. I modsat fald returneres False. Du kan medtage den logiske operator Not til at evaluere den modsatte betingelse (dvs., om udtr ikke findes på listen over værdier).

Du kan f.eks. bruge In til at bestemme, hvilke ordrer der er afsendt til angivne områder:

SELECT *

FROM Ordrer

WHERE Modtagerområde In (‘Avon’,’Glos’,’Som’)

Se også
SQL-udtryk Delsætningen WHERE (Microsoft Jet SQL)

Eksempel

Eksempel på operatoren In


Eksempel på operatoren In (DAO)

Eksempel på operatoren In

I følgende eksempel bruges tabellen Ordrer i databasen Northwind.mdb til at oprette en forespørgsel, der indeholder alle de ordrer, der er afsendt til Lancashire og Essex, samt forsendelsesdatoerne.

I følgende eksempel kaldes proceduren EnumFields, som du finder i eksemplet på sætningen SELECT.

Sub InX()

    Dim dbs As Database, rst As Recordset

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Udvælg de poster i tabellen Ordrer, hvor

    ' værdien for Havneindløb er Lancashire eller Essex.

    Set rst = dbs.OpenRecordset("SELECT " _

        & "Kundeid, Forsendelsesdato FROM Ordrer " _

        & "WHERE Modtagerområde In " _

        & "('Lancashire','Essex');")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    ' Recordset-objektet.

    EnumFields rst, 12

    dbs.Close

End Sub


Sætningen INSERT INTO (Microsoft Jet SQL)

Sætningen INSERT INTO

Tilføjer en post eller flere poster til en tabel. Dette er omtalt som en tilføjelsesforespørgsel.

Syntaks

Tilføjelsesforespørgsel med flere poster:

INSERT INTO mål [(felt1[, felt2[, ...]])] [IN eksterndatabase]
SELECT [kilde.]felt1[, felt2[, ...]
FROM tabeludtryk

Tilføjelsesforespørgsel med en enkelt post:

INSERT INTO mål [(felt1[, felt2[, ...]])]
VALUES (værdi1[, værdi2[, ...])

Sætningen INSERT INTO indeholder følgende argumenter:

Argument | Beskrivelse
mål | Navnet på den tabel eller forespørgsel, der skal føjes poster til.
felt1, felt2 | Navnene på de felter, der skal tilføjes data til, hvis de følger efter et mål-argument, eller navnene på felter, der skal hentes data fra, hvis de følger efter et kilde-argument.
eksterndatabase | Stien til en ekstern database. Du finder en beskrivelse af stien under IN-delsætningen.
kilde | Navnet på den tabel eller forespørgsel, der skal kopieres poster fra.
tabeludtryk | Navnet på den eller de tabeller, hvorfra poster indsættes. Udtrykket kan være et enkelt tabelnavn eller et sammensat resultat fra INNER JOIN, LEFT JOIN, eller RIGHT JOIN eller et gemt forespørgselsnavn.
værdi1, værdi2 | Værdierne, der skal indsættes i de bestemte felter i den nye post. Hver værdi indsættes i det felt, der svarer til værdiens placering på listen: værdi1 indsættes i felt1 i den nye post, værdi2 i felt2 osv. Du skal adskille værdier med et komma og sætte anførselstegn (' ') omkring tekstfelter.

Bemærkninger

Du kan bruge sætningen INSERT INTO til at tilføje en enkelt post i en tabel ved hjælp af syntaksen til tilføjelsesforespørgslen med en enkelt post, som vist ovenfor. I dette tilfælde angiver programkoden navnet og værdien for hvert enkelt felt i posten. Du skal angive alle felterne i posten, som skal have en værdi tildelt, og en værdi for det pågældende felt. Når du ikke angiver alle felterne, indsættes standardværdien eller Null i manglende kolonner. Poster tilføjes i slutningen af tabellen.

Du kan også anvende INSERT INTO til at tilføje et sæt poster fra en anden tabel eller forespørgsel ved hjælp af SELECT ... FROM-delsætningen som vist ovenfor i syntaksen til tilføjelsesforespørgslen med flere poster. I dette tilfælde angiver SELECT-delsætningen de felter, der skal tilføjes i den angivne mål-tabel.

kilde- eller mål-tabellen kan angive en tabel eller en forespørgsel. Hvis en forespørgsel er angivet, tilføjer Microsoft Jet-databasemotoren poster i en vilkårlig tabel og alle de tabeller, der er angivet af forespørgslen.

INSERT INTO er valgfri, men hvis den er medtaget, skal den stå foran SELECT-sætningen.

Hvis destinationstabellen indeholder en primær nøgle, skal du sørge for, at du tilføjer entydige, ikke-Null-værdier i det primære nøglefelt eller -felter. I modsat fald tilføjer Microsoft Jet-databasemotoren ikke posterne.

Hvis du føjer poster til en tabel med et AutoNumber-felt, og du vil omnummerere de tilføjede poster, skal du ikke medtage AutoNumber-feltet i forespørgslen. Du skal dog medtage AutoNumber-feltet i forespørgslen, hvis du vil bibeholde de oprindelige værdier fra feltet.

Du kan bruge IN-delsætningen til at tilføje poster i en tabel i en anden database.

Hvis du vil oprette en ny tabel, skal du i stedet bruge SELECT... INTO-sætningen til at oprette en tabeloprettelsesforespørgsel.

Når du vil se, hvilke poster der tilføjes, før du kører tilføjelsesforespørgslen, skal du først udføre og vise resultaterne af en udvælgelsesforespørgsel, der benytter de samme udvælgelseskriterier.

En tilføjelsesforespørgsel kopierer poster fra en eller flere tabeller til en anden. De tabeller, der indeholder de poster, du tilføjer, påvirkes ikke af tilføjelsesforespørgslen.

I stedet for at tilføje eksisterende poster fra en anden tabel, kan du angive værdien for hvert felt i en enkelt ny post, der benytter VALUES-delsætningen. Hvis du udelader feltlisten, skal VALUES-delsætningen medtage en værdi for hvert enkelt felt i tabellen. I modsat fald lykkes INSERT-handlingen ikke. Du skal bruge en ekstra INSERT INTO-sætning med en VALUES-delsætning for hver ekstra post, du vil oprette.

Se også
Delsætningen FROM (Microsoft Jet SQL) | Sætningen SELECT (Microsoft Jet SQL)
Delsætningen IN (Microsoft Jet SQL) | Sætningen SELECT...INTO (Microsoft Jet SQL)
Handlingen INNER JOIN (Microsoft Jet SQL) | Delsætningen WHERE (Microsoft Jet SQL)
Handlingerne LEFT JOIN og RIGHT JOIN (Microsoft Jet SQL) |

Eksempel

Eksempel på sætningen INSERT INTO


Eksempel på sætningen INSERT INTO (DAO)

Eksempel på sætningen INSERT INTO

I følgende eksempel vælges alle poster i den hypotetiske tabel Nye kunder og føjer dem til tabellen Kunder. Når de enkelte kolonner ikke er angivet, skal kolonnenavnene i SELECT-tabellen svare præcist til dem, der findes i INSERT INTO-tabellen.

Sub InsertIntoX1()

    Dim dbs As Database

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Udvælg alle poster i tabellen Nye kunder,

    ' og føj dem til tabellen Kunder.

    dbs.Execute " INSERT INTO Kunder " _

        & "SELECT * " _

        & "FROM [Nye kunder];"

    dbs.Close

End Sub

I følgende eksempel oprettes en ny post i tabellen Medarbejdere.

Sub InsertIntoX2()

    Dim dbs As Database

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Opret en ny post i tabellen Medarbejdere. Fornavnet

    ' er Harry, efternavnet er Washington,

    ' og stillingen er Elev.

    dbs.Execute " INSERT INTO Medarbejdere " _

        & "(Fornavn, Efternavn, Stilling) VALUES " _

        & "('Harry', 'Washington', 'Elev');"

    dbs.Close

End Sub


Eksempel på delsætningen IN (DAO)

Eksempel på delsætningen IN

I følgende tabel vises, hvordan du kan benytte delsætningen IN til at hente data fra en ekstern database. I hvert eksempel antages det, at den hypotetiske tabel Kunder er lagret i en ekstern database.

Ekstern database SQL-sætning
Microsoft® Jet-database SELECT Kundeid
FROM Kunder
IN AndenDB.mdb
WHERE Kundeid Like "A*";
dBASE III eller IV.
Hvis du vil hente data fra en dBASE III-tabel, skal du erstatte "dBASE IV;" med "dBASE III;". 		SELECT Kundeid
FROM Kunder
IN "C:\dBASE\Data\Salg" "dBASE IV;"
WHERE Kundeid Like "A*";
dBASE III eller IV med databasesyntaks SELECT Kundeid
FROM Kunder
IN "" [dBASE IV; Database=C:\DBASE\DATA\SALG;]
WHERE Kundeid Like "A*";
Paradox 3.x eller 4.x.
Hvis du vil hente data fra en Paradox version 3.x-tabel, skal du erstatte "Paradox 4.x;" med "Paradox 3.x;". 		SELECT Kundeid
FROM Kunder
IN "C:\Paradox\Data\Salg" "Paradox 4.x;"
WHERE Kundeid Like "A*";
Paradox 3.x eller 4.x med databasesyntaks SELECT Kundeid
FROM Kunder
IN "" [Paradox 4.x;Database=C:\Paradox\Data\Salg;]
WHERE Kundeid Like "A*";
Et regneark i Microsoft Excel SELECT Kundeid, Firmanavn
FROM Kundeområde$
IN "C:\Dokumenter\Xldata.xls" "EXCEL 5.0;"
WHERE Kundeid Like "A*"
ORDER BY Kundeid;
Et navngivet område i et regneark SELECT Kundeid, Firmanavn
FROM Kundeområde
IN "C:\Dokumenter\Xldata.xls" "EXCEL 5.0;"
WHERE Kundeid Like "A*"
ORDER BY Kundeid;


SQL-datatyper

SQL-datatyper i Microsoft Jet-databasemotoren består af 13 primære datatyper, der er defineret af Microsoft® Jet-databasemotoren, og flere synonymer, der genkendes som gyldige for disse datatyper.

I følgende tabel vises de primære datatyper. Synonymerne identificeres i SQL-reserverede ord i Microsoft Jet-databasemotor.

Datatype | Lagerstørrelse | Beskrivelse
BINARY | 1 byte pr. tegn | Enhver datatype kan lagres i et felt af denne type. Der foretages ingen oversættelse af dataene (f.eks. til tekst). Hvordan dataene indsættes i et binært felt, bestemmer, hvordan de vises som output.
BIT | 1 byte | Ja- og Nej-værdier samt felter, der kun indeholder en af de to værdier.
TINYINT | 1 byte | En heltalsværdi mellem 0 og 255.
MONEY | 8 byte | Et skaleret heltal mellem –922.337.203.685.477,5808 og 922.337.203.685.477,5807.
DATETIME (Se DOUBLE) | 8 byte | En dato- eller klokkeslætsværdi mellem årene 100 og 9999.
UNIQUEIDENTIFIER | 128 bit | Et unikt identifikationsnummer, der bruges med fjernprocedurekald.
REAL | 4 byte | Et reelt tal med enkelt præcisionsværdi i intervallet – 3,402823E38 til -1,401298E-45 for negative værdier og 1,401298E-45 til 3,402823E38 for positive værdier samt 0.
FLOAT | 8 byte | Et reelt tal med dobbelt præcisionsværdi i intervallet -1,79769313486232E308 til -4,94065645841247E-324 for negative værdier og 4,94065645841247E-324 til 1.79769313486232E30 for positive værdier samt 0.
SMALLINT | 2 byte | Et kort heltal mellem – 32.768 og 32.767 (Se "Bemærkninger")
INTEGER | 4 byte | Et langt heltal mellem – 2.147.483.648 og 2.147.483.647 (Se "Bemærkninger")
DECIMAL | 17 byte | En nøjagtigt numerisk datatype, der indeholder værdier fra 1028 - 1 til - 1028 - 1. Du kan definere både præcision (1 - 28) og skala (0 - defineret præcision). Standardpræcisionen og -skalaen er henholdsvis 18 og 0.
TEXT | 2 byte pr. tegn (Se "Bemærkninger") | Nul til et maksimum på 2,14 gigabyte.
IMAGE | Som krævet | Nul til et maksimum på 2,14 gigabyte. Bruges til OLE-objekter.
CHARACTER | 2 byte pr. tegn (Se "Bemærkninger") | Nul til 255 tegn.

Bemærkninger

  • Både basis og stigning kan ændres ved hjælp af en ALTER TABLE-sætning. De nye rækker, der indsættes i tabellen, har værdier baseret på de nye basis- og stigningsværdier, der automatisk genereres for hver kolonne. Hvis basis og stigningen kan få værdier til at vige, der svarer til værdier, som er genereret ud fra den foregående basis og stigning, oprettes dubletter. Hvis kolonnen er en primær nøgle, kan indsættelse af nye rækker medføre fejl, når dubletværdier genereres.
  • Hvis du vil finde den sidste værdi, der blev anvendt i en kolonne, som automatisk stiger, kan du bruge følgende sætning: SELECT @@IDENTITY. Du kan ikke angive et tabelnavn. Værdien returneres fra den sidste tabel, som indeholder en automatisk stigende kolonne, der blev opdateret.
  • Tegn i felter, der er defineret enten som TEXT (også kendt som MEMO) eller CHAR (også kendt som TEXT(n) med en angivet længde) lagres i Unicode-repræsentationsformat. Unicode-tegn kræver alle to byte til at lagre hvert tegn. I forbindelse med eksisterende Microsoft® Jet-databaser, der indeholder fremherskende tegndata, kan dette betyde, at databasefilen næsten fordobles i størrelse, når den konverteres til Microsoft Jet 4.0-formatet. Unicode-præsentation af mange tegnsæt, tidligere beskrevet som SBCS (Single-Byte Character Sets) kan let komprimeres til en enkelt a single byte. Yderligere oplysninger findes i CREATE TABLE. Hvis du definerer en CHARACER-kolonne med attributtet COMPRESSION, komprimeres data automatisk, når de lagres, og de dekomprimeres, når de hentes fra kolonnen.
Se også
Ækvivalente ANSI SQL-datatyper SQL-reserverede ord i Microsoft Jet-databasemotoren


SQL-reserverede ord

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

I følgende liste findes alle ord, der er reserveret af Microsoft Jet-databasemotoren til brug i SQL-sætninger. Ordene på listen, som ikke er skrevet med store bogstaver, er også reserverede ord i andre programmer. Derfor giver de enkelte Hjælp-emner til disse ord en generel beskrivelse, der ikke fokuserer på brug af SQL.

Bemærk! Ord, der efterfølges af en stjerne (*), er reserveret, men har ikke i øjeblikket nogen betydning i forbindelse med konteksten til en SQL-sætning i Microsoft® Jet (f.eks. Level og TableID). Ord, der ikke er understreget, har ingen sammenkædede forklaringer.

A

ABSOLUTE | ANY
ADD | ARE
ADMINDB | AS
ALL | ASC
Alphanumeric – Se TEXT | ASSERTION
ALTER | AUTHORIZATION
ALTER TABLE | AUTOINCREMENT – Se COUNTER
And | Avg
AS |

B-C

BEGIN | COLLATION
Between | COLUMN
BINARY | COMMIT
BIT | COMP, COMPRESSION
BIT_LENGTH | CONNECT
BOOLEAN – Se BIT | CONNECTION
BOTH | CONSTRAINT, CONSTRAINTS
BY | CONTAINER
BYTE | CONTAINS
CASCADE | CONVERT
CATALOG | Count
CHAR, CHARACTER – Se TEXT | COUNTER
CHAR_LENGTH | CREATE
CHARACTER_LENGTH | CURRENCY
CHECK | CURRENT_DATE
CLOSE | CURRENT_TIME
CLUSTERED | CURRENT_TIMESTAMP
COALESCE | CURRENT_USER
COLLATE | CURSOR

D

DATABASE | DISALLOW
DATE – Se DATETIME | DISCONNECT
DATETIME | DISTINCT
DAY | DISTINCTROW
DEC, DECIMAL | DOMAIN
DECLARE | DOUBLE
DELETE | DROP
DESC |

E-H

Eqv | FOREIGN
EXCLUSIVECONNECT | FROM
EXEC, EXECUTE | FROM-delsætning
EXISTS | GENERAL – Se LONGBINARY
EXTRACT | GRANT
FALSE | GROUP
FETCH | GUID
FIRST | HAVING
FLOAT, FLOAT8 – Se DOUBLE | HOUR
FLOAT4 – Se SINGLE |

I

IDENTITY | INPUT
IEEEDOUBLE – Se DOUBLE | INSENSITIVE
IEEESINGLE – Se SINGLE | INSERT
IGNORE | INSERT INTO
IMAGE | INT, INTEGER, INTEGER4 – Se LONG
Imp | INTEGER1 – Se BYTE
In | INTEGER2 – Se SHORT
IN | INTERVAL
INDEX | INTO
INDEXCREATEDB | Is
INNER | ISOLATION

J-M

JOIN | LONGTEXT
KEY | LOWER
LANGUAGE | MATCH
LAST | Max
LEFT | MEMO – Se LONGTEXT
Level* | Min
Like | MINUTE
LOGICAL, LOGICAL1 – Se BIT | Mod
LONG | MONEY — See CURRENCY
LONGBINARY | MONTH
LONGCHAR |

N-P

NATIONAL | Outer*
NCHAR | OUTPUT
NONCLUSTERED | OWNERACCESS
Not | PAD
NTEXT | PARAMETERS
NULL | PARTIAL
NUMBER – Se DOUBLE | PASSWORD
NUMERIC – Se DECIMAL | PERCENT
NVARCHAR | PIVOT
OCTET_LENGTH | POSITION
OLEOBJECT – Se LONGBINARY | PRECISION
ON | PREPARE
OPEN | PRIMARY
OPTION | PRIVILEGES
Or | PROC, PROCEDURE
ORDER | PUBLIC

Q-S

REAL – Se SINGLE | SMALLDATETIME
REFERENCES | SMALLINT – Se SHORT
RESTRICT | SMALLMONEY
REVOKE | SOME
RIGHT | SPACE
ROLLBACK | SQL
SCHEMA | SQLCODE, SQLERROR, SQLSTATE
SECOND | StDev
SELECT | StDevP
SELECTSCHEMA | STRING – Se TEXT
SELECTSECURITY | SUBSTRING
SET | Sum
SHORT | SYSNAME
SINGLE | SYSTEM_USER
SIZE |

T-Z

TABLE | UPDATEOWNER
TableID* | UPDATESECURITY
TEMPORARY | UPPER
TEXT | USAGE
TIME – Se DATETIME | USER
TIMESTAMP | USING
TIMEZONE_HOUR | VALUE
TIMEZONE_MINUTE | VALUES
TINYINT | Var
TO | VARBINARY – Se BINARY
TOP | VARCHAR – Se TEXT
TRAILING | VarP
TRANSACTION | VARYING
TRANSFORM | VIEW
TRANSLATE | WHEN
TRANSLATION | WHENEVER
TRIM | WHERE
TRUE | WITH
UNION | WORK
UNIQUE | Xor
UNIQUEIDENTIFIER | YEAR
UNKNOWN | YESNO – Se BIT
UPDATE | ZONE
UPDATEIDENTITY |


Sammenligning af Microsoft Jet SQL og ANSI SQL

Microsoft Jet-databasemotor SQL er normalt kompatibel med ANSI-89 Level 1. Visse ANSI SQL-faciliteter er dog ikke implementeret i Microsoft® Jet SQL. Med udgaven af Microsoft Jet version 4.X benytter Microsoft OLE DB Provider til Jet mere ANSI-92 SQL-syntaks. Microsoft Jet SQL medtager på den anden side reserverede ord og funktioner, der ikke understøttes i ANSI SQL.

Vigtigste forskelle
  • Microsoft Jet SQL og ANSI SQL har hver især forskellige reserverede ord og datatyper. Yderligere oplysninger finder du under SQL-reserverede ord i Microsoft Jet-databasemotor og Ækvivalente ANSI SQL-datatyper. Ved brug af Microsoft OLE DB Provider til Jet med Jet 4.X er der flere reserverede ord.
  • Forskellige regler anvendes til konstruktionen Between...And, der har følgende syntaks:

    udtr1 [NOT] Between værdi1 And værdi2

    I Microsoft Jet SQL kan værdi1 være større end værdi2. I ANSI SQL skal værdi1 være lig med eller mindre end værdi2.

  • Microsoft Jet SQL understøtter både ANSI SQL-jokertegn og Microsoft Jet-specifikke jokertegn, der kan bruges sammen med operatoren Like. Brugen af ANSI og Microsoft Jet-jokertegn udelukker gensidigt hinanden. Du skal bruge det ene eller det andet sæt. De kan ikke blandes. ANSI SQL-jokertegn er kun tilgængelig, når du anvender Jet 4.X og Microsoft OLE DB Provdier til Jet. Hvis du forsøger at bruge ANSI SQL-jokertegn via Microsoft Access eller DAO, fortolkes de som konstanter. Det forholder sig modsat, når du anvender Microsoft OLE DB Provdier til Jet og Jet 4.X.

    Tilsvarende tegn Microsoft Jet SQL ANSI SQL
    Et enkelt tegn ? _ (understregningstegn)
    Nul eller flere tegn * %

  • Microsoft Jet SQL er generelt mindre begrænsende. Du kan f.eks. gruppere og opstille rækkefølger for udtryk.
  • Microsoft Jet SQL understøtter mere effektive udtryk.
Forbedrede funktioner i Microsoft Jet SQL

Microsoft Jet SQL har følgende forbedrede funktioner:

· Sætningen TRANSFORM, der understøtter crosstab queries.

  • Ekstra aggregatfunktioner, såsom StDev og VarP.

· Erklæringen PARAMETERS til at definere parameterforespørgsler.

ANSI SQL-funktioner, der ikke understøttes i Microsoft Jet SQL

Microsoft Jet SQL understøtter ikke følgende ANSI SQL-funktioner:

  • Referencer til DISTINCT-aggregatfunktioner. Microsoft Jet SQL tillader f.eks. ikke SUM(DISTINCT kolonnenavn).
  • Delsætningen LIMIT TO nn ROWS anvendes til at begrænse det antal rækker, der returneres af en forespørgsel. Du kan kun bruge WHERE-delsætningen til at begrænse en forespørgsels virkefelt.
Se også
Ækvivalente ANSI SQL-datatyper | SQL-reserverede ord i Microsoft Jet-databasemotoren
Operatoren Like (Microsoft Jet SQL) | SQL-aggregatfunktioner (SQL)
SQL-datatyper i Microsoft Jet-databasemotor | Brug af jokertegn i strengsammenligninger


Handlingerne LEFT JOIN og RIGHT JOIN (Microsoft Jet SQL)

Handlingerne LEFT JOIN og RIGHT JOIN

Kombinerer poster i kildetabeller, når de bruges i alle FROM delsætninger.

Syntaks

FROM tabel1 [ LEFT | RIGHT ] JOIN tabel2
ON tabel1.felt1 compopr tabel2.felt2

Handlingerne LEFT JOIN og RIGHT JOIN indeholder følgende argumenter:

Argument | Beskrivelse
tabel1, tabel2 | Navnene på de tabeller, hvorfra der skal kombineres poster.
felt1, felt2 | Navnene på de felter, der joinforbindes. Felterne skal være af samme datatype og indeholde samme slags data, men de behøver ikke at have samme navn.
compopr | Alle relationelle sammenligningsoperatorer: "=," "<," ">," "<=," ">=," eller "<>."

Bemærkninger

Du kan bruge en LEFT JOIN-handling til at oprette en venstre ydre joinforbindelse. Venstre ydre joinforbindelser medtager alle poster fra den første (venstre) af de to tabeller, selvom der ikke findes tilsvarende værdier for poster i den anden (højre) tabel.

Du kan anvende en RIGHT JOIN-handling til at oprette en højre ydre joinforbindelse. Højre ydre joinforbindelser medtager alle posterne fra den anden (højre) af de to tabeller, selv om der ikke findes tilsvarende værdier for poster i den første (venstre) tabel.

Du kan f.eks. bruge LEFT JOIN sammen med tabellerne Afdelinger (venstre) og Medarbejdere (højre) til at markere alle afdelinger, herunder dem, der ingen medarbejdere har. Hvis du vil markere alle medarbejdere, herunder dem, der ikke har tilknytning til en afdeling, skal du bruge RIGHT JOIN.

I følgende eksempel vises, hvordan du kan joinforbinde tabellerne Kategorier og Produkter på feltet Kategorinr. Forespørgslen frembringer en liste over alle kategorier, herunder dem, der ikke indeholder produkter:

SELECT Kategorinavn,

Produktnavn

FROM Kategorier LEFT JOIN Produkter

ON Kategorier.Kategorinr = Produkter.Kategorinr;

I dette eksempel er Kategorinr det joinforbundne felt, men det medtages ikke i forespørgslens output, da det ikke er indeholdt i SELECT-sætningen. Hvis du vil medtage det joinforbundne felt, skal du indtaste feltnavnet i SELECT-sætningen – i dette tilfælde: Kategorier.Kategorinr.

Bemærk!

Hvis du vil oprette en forespørgsel, der kun indeholder poster, hvor dataene i de joinforbundne felter er de samme, skal du bruge en INNER JOIN-handling.

  • En LEFT JOIN eller en RIGHT JOIN kan indlejres i en INNER JOIN, men en INNER JOIN kan ikke indlejres i en LEFT JOIN eller en RIGHT JOIN. Oplysninger om, hvordan du indlejrer joinforbindelser i andre joinforbindelser, finder du i emnet om INNER JOIN.
  • Du kan sammenkæde flere ON-delsætninger. Yderligere oplysninger om sammenkædning af delsætninger finder du i emnet om INNER JOIN.

Hvis du forsøger at joinforbinde felter, der indeholder data af typen Memo eller OLE Object, opstår der en fejl.

Se også
Delsætningen FROM (Microsoft Jet SQL) | Handlingen UNION (Microsoft Jet SQL)
Handlingen INNER JOIN (Microsoft Jet SQL) |

Eksempel

Eksempel på handlingerne LEFT JOIN og RIGHT JOIN


Eksempel på handlingerne LEFT JOIN og RIGHT JOIN (DAO)

Eksempel på handlingerne LEFT JOIN og RIGHT JOIN

I følgende eksempl antages det, at de hypotetiske felter Afdelingsnavn og Afdelingsnr findes i tabellen Medarbejdere. Bemærk, at disse felter faktisk ikke findes i tabellen Medarbejdere i databasen Northwind.

I følgende eksempel udvælges alle afdelinger, herunder dem uden medarbejdere.

I følgende eksempel kaldes proceduren EnumFields, som du finder i eksemplet på sætningen SELECT.

Sub LeftRightJoinX()

    Dim dbs As Database, rst As Recordset

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Udvælg alle afdelinger herunder dem uden

    ' medarbejdere.

    Set rst = dbs.OpenRecordset _

        ("SELECT Afdelingsnavn, " _

        & "Fornavn & Chr(32) & Efternavn AS Navn " _

        & "FROM Afdelinger LEFT JOIN Medarbejdere " _

        & "ON Afdelinger.Afdelingsnr = " _

        & "Medarbejdere.Afdelingsnr " _

        & "ORDER BY Afdelingsnavn;")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    ' Recordset-objektet. Overfør Recordset-objektet og

    ' den ønskede feltbredde.

    EnumFields rst, 20

    dbs.Close

End Sub


Operatoren Like (Microsoft Jet SQL)

Operatoren Like

Sammenligner et strengudtryk med et mønster i et SQL-udtryk.

Syntaks

udtryk Like “mønster”

Syntaksen til operatoren Like indeholder følgende argumenter:

Argument | Beskrivelse
udtryk | SQL-udtryk, der anvendes i en WHERE-delsætning.
mønster | Streng eller strengkonstanttegn, som udtryk sammenlignes med.

Bemærkninger

Du kan bruge operatoren Like til at søge efter værdier i et felt, der svarer til det mønster, du angiver. I forbindelse med mønster kan du angive hele værdien (f.eks. Like “Smith”), eller du kan bruge jokertegn til at søge efter et værdiområde (f.eks. Like “Sm*”).

I et udtryk kan du anvende operatoren Like til at sammenligne en feltværdi med et strengudtryk. Hvis du f.eks. indtaster Like “C*” i en SQL-forespørgsel, returnerer forespørgslen alle de feltværdier, der begynder med bogstavet C. I en parameterforespørgsel kan du bede brugeren om det mønster, der skal søges efter.

I følgende eksempel returneres data, der begynder med bogstavet P efterfulgt af et vilkårligt bogstav mellem A og F og tre cifre:

Like “P[A-F]###”

I følgende tabel vises, hvordan du kan benytte Like til at afprøve, om der er forskellige mønstre i udtryk.

Type af sammenfald | Mønster | Sammenfald (returnerer True) | Intet sammenfald (returnerer False)
Flere tegn | a*a | aa, aBa, aBBBa | aBC
 | *ab* | abc, AABB, Xab | aZb, bac
Specialtegn | a[*]a | a*a | aaa
Flere tegn | ab* | abcdefg, abc | cab, aab
Enkelt tegn | a?a | aaa, a3a, aBa | aBBBa
Enkelt ciffer | a#a | a0a, a1a, a2a | aaa, a10a
Tegnområde | [a-z] | f, p, j | 2, &
Uden for et område | [!a-z] | 9, &, % | b, a
Ikke et ciffer | [!0-9] | A, a, &, ~ | 0, 1, 9
Kombineret | a[!b-m]# | An9, az0, a99 | abc, aj0

Se også
SQL-udtryk | Brug af jokertegn i strengsammenligninger
Delsætningen WHERE (Microsoft Jet SQL) |

Eksempel

Eksempel på operatoren Like


Eksempel på operatoren Like (DAO)

Eksempel på operatoren Like

I følgende eksempel vises en liste over medarbejdere, hvis navne begynder med bogstaverne A - D.

I følgende eksempel kaldes proceduren EnumFields, som du finder i eksemplet på sætningen SELECT.

Sub LikeX()

    Dim dbs As Database, rst As Recordset

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Returner en liste over medarbejdere med navne,

    ' der begynder med bogstaverne A - D.

    Set rst = dbs.OpenRecordset("SELECT Efternavn," _

        & " Fornavn FROM Medarbejdere" _

        & " WHERE Efternavn Like '[A-D]*';")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    ' Recordset-objektet. Overfør Recordset-objektet og

    ' den ønskede feltbredde.

    EnumFields rst, 15

    dbs.Close

End Sub


Funktionerne Min og Max (Microsoft Jet SQL)

Funktionerne Min og Max

Returnerer det mindste eller største sæt af værdier, der er indeholdt i et angivet felt i en forespørgsel.

Syntaks

Min(udtr)

Max(udtr)

Pladsholderen udtr repræsenterer et strengudtryk, der identificerer det felt, som indeholder de data, du vil beregne på, eller et udtryk, der udfører en beregning ved hjælp af dataene i det pågældende felt. Operander i udtr kan medtage navnet på et tabelfelt, en konstant eller på en funktion, (der kan være enten indbygget eller brugerdefineret, men ikke en af de andre SQL- aggregat funktioner).

Bemærkninger

Du kan benytte Min og Max til at bestemme de mindste og største værdier i et felt på basis af den angivne aggregering eller gruppering. Du kan f.eks. anvende disse funktioner til at returnere de laveste eller højeste fragtomkostninger. Hvis der ikke er givet en aggregering, anvendes hele tabellen.

Du kan anvende Min og Max i et forespørgselsudtryk og i egenskaben SQL i et QueryDef-objekt, eller når du opretter et Recordset-objekt, der er baseret på en SQL-forespørgsel.

Se også

SQL-aggregatfunktioner (SQL)

Eksempel

Eksempel på funktionerne Min og Max


Eksempel på funktionerne Min og Max (DAO)

Eksempel på funktionerne Min og Max

I følgende eksempel benyttes tabellen Ordrer til at returnere de laveste og højeste fragtomkostninger ved de ordrer, der er afsendt til Storbritannien.

I følgende eksempel kaldes proceduren EnumFields, som du finder i eksemplet på sætningen SELECT.

Sub MinMaxX()

    Dim dbs As Database, rst As Recordset

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Returner de laveste og højeste

    ' fragtomkostninger ved de ordrer, der er afsendt til Storbritannien.

    Set rst = dbs.OpenRecordset("SELECT " _

        & "Min(Fragtomkostninger) AS [Lave fragtomkostninger], " _

        & "Max(Fragtomkostninger)AS [Høje fragtomkostninger] " _

        & "FROM Ordrer WHERE Modtagerland = ' Storbritannien';")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    ' Recordset-objektet. Overfør Recordset-objektet og

    ' den ønskede feltbredde.

    EnumFields rst, 12

    dbs.Close

End Sub


ODBC-skalærfunktioner

Microsoft® Jet SQL understøtter brugen af den ODBC-definerede syntaks til skalærfunktioner. F.eks. ville forespørgslen:

SELECT DAILYCLOSE, DAILYCHANGE FROM DAILYQUOTE
WHERE {fn ABS(DAILYCHANGE)} > 5

returnere alle rækker, hvor den absolutte værdi i området for lagerpris var større end fem.

En delmængde af de ODBC-definerede skalærfunktioner understøttes. Følgende tabel viser de feltdatatyper, der understøttes.

En beskrivelse af argumenterne og en komplet forklaring af escape-syntaksen til at medtage funktioner i en SQL-sætning finder du i dokumentationen til ODBC.

Strengfunktioner
ASCII | LENGTH | RTRIM
CHAR | LOCATE | SPACE
CONCAT | LTRIM | SUBSTRING
LCASE | RIGHT | UCASE
LEFT |  |

Numeriske funktioner
ABS | FLOOR | SIN
ATAN | LOG | SQRT
CEILING | POWER | TAN
COS | RAND | MOD
EXP | SIGN |

Time og Date-funktioner
CURDATE | DAYOFYEAR | MONTH
CURTIME | YEAR | WEEK
NOW | HOUR | QUARTER
DAYOFMONTH | MINUTE | MONTHNAME
DAYOFWEEK | SECOND | DAYNAME

Datatypekonvertering
CONVERT Strengkonstanter kan konverteres til følgende datatyper: SQL_FLOAT, SQL_DOUBLE, SQL_NUMERIC, SQL_INTEGER, SQL_REAL, SQL_SMALLINT, SQL_VARCHAR og SQL_DATETIME.

Se også

Konfigurering af Microsoft Jet-databasemotoren til ODBC-adgang


Delsætningen ORDER BY (Microsoft Jet SQL)

Delsætningen ORDER BY

Sorterer en forespørgsels fremkomne poster i et eller flere angivne felter i stigende eller faldende rækkefølge.

Syntaks

SELECT feltliste
FROM tabel
WHERE udvælgelseskriterier
[ORDER BY felt1 [ASC | DESC ][, felt2 [ASC | DESC ]][, ...]]]

En SELECT-sætning, der indeholder en ORDER BY-delsætning, har følgende argumenter:

Argument | Beskrivelse
feltliste | Navnet på det eller de felter, der skal hentes sammen med eventuelle aliaser for feltnavne, SQL-aggregatfunktioner, udvælgelsesprædikater (ALL, DISTINCT, DISTINCTROW eller TOP) eller andre gyldige SELECT-sætninger.
tabel | Navnet på den tabel, som posterne hentes fra. Yderligere oplysninger finder du i emnet om FROM-delsætningen.
udvælgelseskriterier | Udvælgelseskriterier. Hvis sætningen medtager en WHERE-delsætning, grupperer Microsoft Jet-databasemotoren værdier, efter at WHERE-betingelserne er anvendt på posterne.
felt1, felt2 | Navnene på de felter, som posterne skal sorteres efter.

Bemærkninger

ORDER BY er valgfri. Hvis du vil vise dataene i sorteret rækkefølge, skal du dog bruge ORDER BY.

Standard rækkefølgen er stigende (A til Å, 0 til 9). I de to følgende eksempler sorteres medarbejdernavnene efter efternavn:

SELECT Efternavn, Fornavn

FROM Medarbejdere

ORDER BY Efternavn;

SELECT Efternavn, Fornavn

FROM Medarbejdere

ORDER BY Efternavn ASC;

Hvis du vil sortere i faldende rækkefølge (Å til A, 9 til 0), skal du tilføje det reserverede ord DESC til slutningen af hvert enkelt felt, du vil sortere i faldende rækkefølge. I følgende eksempel udvælges lønninger og de sorteres i faldende rækkefølge:

SELECT Efternavn, Løn

FROM Medarbejdere

ORDER BY Løn DESC, Efternavn;

Hvis du angiver et felt, der indeholder data af typen Memo eller OLE Object i delsætningen ORDER BY, opstår der en fejl. Microsoft Jet-databasemotoren sorterer ikke felter af denne type.

ORDER BY er normalt det sidste element i en SQL-sætning.

Du kan medtage ekstra felter i ORDER BY-delsætningen. Poster sorteres først efter det første felt, der vises efter ORDER BY. Poster med ens værdier i det pågældende felt sorteres derefter efter værdien i det andet felt, der vises, osv.

Se også
Prædikaterne ALL DISTINCT, DISTINCTROW, TOP (Microsoft Jet SQL) | Sætningen SELECT (Microsoft Jet SQL)
Delsætningen FROM (Microsoft Jet SQL) | Sætningen SELECT...INTO (Microsoft Jet SQL)
Delsætningen GROUP BY (Microsoft Jet SQL) | SQL-aggregatfunktioner (SQL)
Delsætningen HAVING (Microsoft Jet SQL) | Delsætningen WHERE (Microsoft Jet SQL)

Eksempel

Eksempel på delsætningen ORDER BY


Eksempel på delsætningen ORDER BY (DAO)

Eksempel på delsætningen ORDER BY

I de SQL-sætninger, der vises nedenfor, benyttes delsætningen ORDER BY til at sortere poster efter efternavn i faldende rækkefølge (Å-A).

I følgende eksempel kaldes proceduren EnumFields, som du finder i eksemplet på sætningen SELECT.

Sub OrderByX()

    Dim dbs As Database, rst As Recordset

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Vælg værdierne for Efternavn og Fornavn fra

    ' tabellen Medarbejdere, og sorter dem i faldende

    ' rækkefølge.

    Set rst = dbs.OpenRecordset("SELECT Efternavn, " _

        & "Fornavn FROM Medarbejdere " _

        & "ORDER BY Efternavn DESC;")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af.

    EnumFields rst, 12

    dbs.Close

End Sub


Erklæringen PARAMETERS (Microsoft Jet SQL)

Erklæringen PARAMETERS

Erklærer navnet og datatypen for hver enkelt parameter i en parameterforespørgsel.

Syntaks

PARAMETERS navn datatype [, navn datatype [, ...]]

Erklæringen PARAMETERS indeholder følgende argumenter:

Argument | Beskrivelse
navn | Navnet på parameteren. Tildeles til egenskaben Name til Parameter-objektet og anvendes til at identificere denne parameter i samlingen Parameters. Du kan bruge navn som en streng, der vises i en dialogboks, mens programmet kører forespørgslen. Brug kantede parenteser ([ ]) til at omslutte tekst, der indeholder mellemrum eller tegnsætning. [Lav pris] og [Begynd rapport ved hvilken måned?] er f.eks. gyldige navn-argumenter.
datatype | En af de primære Microsoft Jet SQL-datatyper eller de tilhørende synonymer.

Bemærkninger

I forbindelse med forespørgsler, som du kører regelmæssigt, kan du bruge en PARAMETERS-erklæring til at oprette en parameterforespørgsel. En parameterforespørgsel kan være en hjælp til at automatisere ændringen af forespørgselskriterier. Med en parameterforespørgsel skal programkoden angive parametrene, hver gang forespørgslen kører.

Erklæringen PARAMETERS er valgfri, men hvis den medtages, skal den stå foran alle andre sætninger, herunder SELECT.

Hvis erklæringen medtager mere end en parameter, skal du adskille dem med komma. I følgende eksempel medtages to parametre:

PARAMETERS [Lav pris] Currency, [Startdato] DateTime;

Du kan benytte navn, men ikke datatype i en WHERE- eller HAVING-delsætning. I følgende eksempel forventes, at brugeren giver to parametre og derefter anvender kriterierne på posterne i tabellen Ordrer:

PARAMETERS [Lav pris] Currency,

[Startdato] DateTime;

SELECT Ordreid, Ordrebeløb

FROM Ordrer

WHERE Ordrebeløb > [Lav pris]

AND Ordredato >= [Startdato];

Se også
Sætningen EXECUTE (Microsoft Jet SQL) | Sætningen SELECT (Microsoft Jet SQL)
Delsætningen HAVING (Microsoft Jet SQL) | Delsætningen WHERE (Microsoft Jet SQL)
SQL-datatyper i Microsoft Jet-databasemotor |

Eksempel

Eksempel på erklæringen PARAMETERS


Eksempel på erklæringen PARAMETERS (DAO)

Eksempel på erklæringen PARAMETERS

I følgende eksempel bedes brugeren angive en stilling, som så bruges som kriterium i forespørgslen.

I følgende eksempel kaldes proceduren EnumFields, som du finder i eksemplet på Sætningen SELECT.

Sub ParametersX()

    Dim dbs As Database, qdf As QueryDef

    Dim rst As Recordset

    Dim strSql As String, strParm As String

    Dim strMessage As String

    Dim intCommand As Integer

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("NorthWind.mdb")

    ' Definer delsætningen Parameters.

    strParm = "PARAMETERS [Medarbejderstilling] CHAR; "

    ' Definer en SQL-sætning med delsætningen

    ' Parameters

    strSql = strParm & "SELECT Efternavn, Fornavn, " _

        & "Medarbejderid " _

        & "FROM Medarbejdere " _

        & "WHERE Titel = [Medarbejderstilling];"

    ' Opret et QueryDef-objekt på baggrund af

    ' SQL-sætningen.

    Set qdf = dbs.CreateQueryDef _

        ("Find medarbejdere", strSql)

    Do While True

        strMessage = "Find medarbejdere ud fra job " _

            & "stilling:" & Chr(13) _

            & "  Vælg stilling:" & Chr(13) _

            & "   1 - Salgschef" & Chr(13) _

            & "   2 - Sælger" & Chr(13) _

            & "   3 - Salgskoordinator"

        intCommand = Val(InputBox(strMessage))

        Select Case intCommand

            Case 1

                qdf("Medarbejderstilling") = _

                    "Salgschef"

            Case 2

                qdf("Medarbejderstilling") = _

                    "Sælger"

            Case 3

                qdf("Medarbejderstilling") = _

                    "Salgskoordinator"

            Case Else

                Exit Do

        End Select

        ' Opret et midlertidigt Recordset-objekt af typen snapshot.

        Set rst = qdf.OpenRecordset(dbOpenSnapshot)

        ' Udfyld Recordset-objektet.

        rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    ' Recordset-objektet. Overfør Recordset-objektet og

    ' den ønskede feltbredde.

        EnumFields rst, 12

    Loop

    ' Slet QueryDef-objektet, da dette er en

    ' demonstration.

    dbs.QueryDefs.Delete "Find medarbejdere"

    dbs.Close

End Sub


Delsætningen PROCEDURE (Microsoft Jet SQL)

Delsætningen PROCEDURE

Definerer et navn og valgfrie parametre til en forespørgsel.

Bemærk! Delsætningen PROCEDURE tilsidesættes af sætningen PROCEDURE. Selvom delsætningen PROCEDURE stadig understøttes, giver sætningen PROCEDURE et underset af funktionen i delsætningen PROCEDURE og er den syntaks, der anbefales.

Syntaks

PROCEDURE navn [param1 datatype[, param2 datatype[, ...]]

Delsætningen PROCEDURE indeholder følgende argumenter:

Argument | Beskrivelse
navn | Et navn til proceduren. Det skal følge standardnavngivningskonventioner.
param1, param2 | Et eller flere feltnavne eller parametre For eksempel: PROCEDURE Salg_efter_land [Startdato] DateTime, [Slutdato] DateTime; Yderligere oplysninger om parametre finder du under parametre.
datatype | En af de primære Microsoft Jet SQL-datatyper eller de tilhørende synonymer.

Bemærkninger

En SQL-procedure består af en PROCEDURE-delsætning, der angiver navnet på proceduren, en valgfri liste over parameterdefinitioner og en enkelt SQL-sætning. Proceduren Hent_Varenummer kan f.eks. køre en forespørgsel, der udtrækker et bestemt delnummer.

Bemærk!

  • Hvis delsætningen medtager mere end en feltdefinition (dvs. param-datatype-par), skal du adskille dem med komma.
  • Delsætningen PROCEDURE skal efterfølges af en SQL-sætning (f.eks. en SELECT- eller UPDATE-sætning).
Se også
Sætningen DELETE (Microsoft Jet SQL) | Erklæringen PARAMETERS (Microsoft Jet SQL)
Sætningen EXECUTE (Microsoft Jet SQL) | Sætningen SELECT (Microsoft Jet SQL)
SQL-datatyper i Microsoft Jet-databasemotor | Sætningen UPDATE (Microsoft Jet SQL)

Eksempel

Sætningen CREATE PROCEDURE, eksempel på delsætningen PROCEDURE


Sætningen CREATE PROCEDURE og eksempel på delsætningen PROCEDURE (DAO)

Sætningen CREATE PROCEDURE og eksempel på delsætningen PROCEDURE

I følgende eksempel navngives forespørgslen Kategoriliste.

I følgende eksempel kaldes proceduren EnumFields, som du finder i eksemplet på sætningen SELECT.

Sub ProcedureX()

    Dim dbs As Database, rst As Recordset

    Dim qdf As QueryDef, strSql As String

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    strSql = "PROCEDURE Kategoriliste; " _

        & "SELECT DISTINCTROW Kategorinavn, " _

        & "Kategorinr FROM Kategorier " _

        & "ORDER BY Kategorinavn;"

    ' Opret en navngivet QueryDef på baggrund af

    ' SQL-sætningen.

    Set qdf = dbs.CreateQueryDef("NyForespørgsel", strSql)

    ' Opret et midlertidigt Recordset-objekt af typen snapshot.

    Set rst = qdf.OpenRecordset(dbOpenSnapshot)

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    ' Recordset-objektet. Overfør Recordset-objektet og

    ' den ønskede feltbredde.

    EnumFields rst, 15

    ' Slet QueryDef-objektet, da dette er en

    ' demonstration.

    dbs.QueryDefs.Delete "NyForespørgsel"

    dbs.Close

End Sub


Sætningen REVOKE (Microsoft Jet SQL)

Sætningen REVOKE

Kalder bestemte rettigheder fra en eksisterende bruger eller gruppe.

Syntaks

REVOKE {rettighed[, rettighed, …]} ON
{TABLE tabel |
OBJECT objekt|

CONTAINER objektbeholder }
FROM {autorisationsnavn[, autorisationsnavn, …]}

Sætningen UPDATE indeholder følgende argumenter:

Argument | Beskrivelse
rettighed | Den eller de rettigheder, der skal kaldes. Rettigheder angives ved hjælp af følgende reserverede ord: SELECT, DELETE, INSERT, UPDATE, DROP, SELECTSECURITY, UPDATESECURITY, DBPASSWORD, UPDATEIDENTITY, CREATE, SELECTSCHEMA, SCHEMA og UPDATEOWNER.
tabel | Et gyldigt tabelnavn.
objekt | Dette kan være alle ikke-tabelobjekter. En lagret forespørsel (visning eller procedure) er et eksempel.
objektbeholder | Navnet på en gyldig objektbeholder.
autorisationsnavn | Et bruger- eller gruppenavn.

Se også
Sætningen ADD USER | Sætningen CREATE TABLE
Sætningen ALTER USER eller DATABASE | Sætningen CREATE USER eller GROUP
Sætningen ALTER TABLE | Sætningen CREATE VIEW
Delsætningen CONSTRAINT | Sætningen DROP
Sætningen CREATE INDEX | Sætningen DROP USER eller GROUP
Sætningen CREATE PROCEDURE | Sætningen GRANT


Sætningen SELECT (Microsoft Jet SQL)

Sætningen SELECT

Instruerer Microsoft Jet-databasemotoren til at returnere oplysninger fra databasen som et sæt poster.

Syntaks

SELECT [prædikat] { * | tabel.* | [tabel.]felt1 [AS alias1] [, [tabel.]felt2 [AS alias2] [, ...]]}
FROM tabeludtryk[, ...] [IN eksterndatabase]
[WHERE... ]
[GROUP BY... ]
[HAVING... ]
[ORDER BY... ]
[WITH OWNERACCESS OPTION]

Sætningen SELECT indeholder følgende argumenter:

Argument | Beskrivelse
prædikat | En af følgende prædikater: ALL, DISTINCT, DISTINCTROW eller TOP. Du kan bruge prædikatet til at begrænse antallet af poster, der returneres. Hvis intet er angivet, er standarden ALL.
* | Angiver, at alle felter i den eller de angivne tabeller er valgt.
tabel | Navnet på den tabel, der indeholder de felter, som posterne vælges fra.
felt1, felt2 | Navnene på de felter, der indeholder de data, du vil hente. Hvis du medtager mere end et felt, hentes de i den rækkefølge, de vises i.
alias1, alias2 | De navne, der skal anvendes som kolonneoverskrifter i stedet for de oprindelige kolonnenavne i tabel.
tabeludtryk | Navnet på den eller de tabeller, der indeholder de data, du vil hente.
eksterndatabase | Navnet på den database, der indeholder tabellerne i tabeludtryk, hvis de ikke er i den aktuelle database.

Bemærkninger

Hvis du vil udføre denne handling, søger Microsoft® Jet-databasemotoren i den eller de angivne tabeller, henter de markerede kolonner, vælger rækker, der opfylder kriteriet, og sorterer eller grupperer de fremkomne rækker i den angivne rækkefølge.

SELECT-sætninger ændrer ikke data i databasen.

SELECT er normalt det første ord i en SQL-sætning De fleste SQL-sætninger er enten SELECT- eller SELECT...INTO-sætninger.

Syntaksen til en SELECT-sætning er som minimum:

SELECT felter FROM tabel

Du kan anvende en stjerne (*) til at markere alle felter i en tabel. I følgende eksempel markeres alle felterne i tabellen Medarbejdere:

SELECT * FROM Medarbejdere;

Hvis et feltnavn medtages i mere end en tabel i FROM-delsætningen, skal feltnavnet indledes med tabelnavnet og operatoren . (punktum). I følgende eksempel medtages feltet Afdeling både i tabellen Medarbejdere og tabellen Overordnede. SQL-sætningen markerer afdelinger i tabellen Medarbejdere og navne på overordnede i tabellen Overordnede:

SELECT Medarbejdere.Afdeling, Overordnede.OverordNavn

FROM Medarbejdere INNER JOIN Overordnede

WHERE Medarbejdere.Afdeling = Overordnede.Afdeling;

Når et Recordset-objekt oprettes, anvender Microsoft Jet-databasemotoren tabellens feltnavn som Field-objektnavnet i Recordset-objektet. Hvis du vil have et andet feltnavn, eller navnet ikke er underforstået i det udtryk, der bruges til at generere feltet, skal du anvende det reserverede ord AS. I følgende eksempel bruges titlen Fødsel til at navngive det returnerede Field-objekt i det fremkomne Recordset-objekt:

SELECT Fødselsdato

AS Fødsel FROM Medarbejdere;

Når du anvender aggregatfunktioner eller forespørgsler, der returnerer tvetydige eller dublerede Field-objektnavne, skal du bruge AS-delsætningen til at give Field-objektet et andet navn. I følgende eksempel bruges titlen Hovedtal til at navngive det returnerede Field-objekt i det fremkomne Recordset-objekt:

SELECT COUNT(Medarbejdernr)

AS Hovedtal FROM Medarbejdere;

Du kan anvende andre delsætninger i en SELECT-sætning til yderligere at begrænse og organisere de returnerede data. Yderligere oplysninger finder du i Hjælp-emnet, der omhandler den delsætning, du arbejder med.

Se også
Eksempel på prædikaterne ALL DISTINCT, DISTINCTROW, TOP (Microsoft Jet SQL) | Delsætningen ORDER BY (Microsoft Jet SQL)
Sætningen DELETE (Microsoft Jet SQL) | Sætningen SELECT...INTO (Microsoft Jet SQL)
Delsætningen FROM (Microsoft Jet SQL) | SQL-aggregatfunktioner (SQL)
Delsætningen GRUP BY (Microsoft Jet SQL) | Handlingen UNION (Microsoft Jet SQL)
Delsætningen HAVING (Microsoft Jet SQL) | Sætningen UPDATE (Microsoft Jet SQL)
Delsætningen IN (Microsoft Jet SQL) | Delsætningen WHERE (Microsoft Jet SQL)
Sætningen INSERT INTO (Microsoft Jet SQL) | Erklæringen WITH OWNERACCESS OPTION (Microsoft Jet SQL)

Eksempel

Eksempel på sætningen SELECT og delsætningen FROM


Sætningen SELECT...INTO (Microsoft Jet SQL)

Sætningen SELECT...INTO

Opretter en tabeloprettelsesforespørgsel.

Syntaks

SELECT felt1[, felt2[, ...]] INTO tabeludtryk [IN eksterndatabase]
FROM kilde

Sætningen SELECT...INTO indeholder følgende argumenter:

Argument | Beskrivelse
felt1, felt2 | Navnet på de felter, der skal kopieres til den nye tabel.
nytabel | Navnet på den tabel, der skal oprettes. Det skal opfylde standardnavngivningskonventioner Hvis nytabel svarer til navnet på en eksisterende tabel, vil det medføre en fejl, der kan opfanges.
eksterndatabase | Stien til en ekstern database. Du finder en beskrivelse af stien under IN-delsætningen.
kilde | Navnet på den eksisterende tabel, som poster vælges fra. Dette kan være en eller flere tabeller eller en forespørgsel.

Bemærkninger

Du kan benytte tabeloprettelsesforespørgsler til at arkivere poster, sikkerhedskopiere tabellerne eller lave kopier, der kan eksporteres til en anden database eller bruges som basis for rapporter, der skal vise data i en bestemt periode. Du kan f.eks. fremstille rapporten Månedligt salg efter område ved at køre den samme tabeloprettelsesforespørgsel hver måned.

Bemærk!

  • Du vil måske definere en primær nøgle til den nye tabel. Når du opretter tabellen, arver felterne i den nye tabel datatypen og feltstørrelsen på hvert felt i forspørgslens underliggende tabeller, men der overføres ingen andre felt- eller tabelegenskaber.
  • Hvis du vil tilføje data i en eksisterende tabel, skal du i stedet bruge sætningen INSERT INTO til at oprette en tilføjelsesforespørgsel.
  • Hvis du vil vide, hvilke poster der vælges, før du kører tabeloprettelsesforespørgslen, skal du først undersøge resultatet af en SELECT-sætning, der bruger samme udvælgelseskriterier.
Se også
Prædikaterne ALL DISTINCT, DISTINCTROW, TOP (Microsoft Jet SQL) | Sætningen SELECT (Microsoft Jet SQL)
Delsætningen FROM (Microsoft Jet SQL) | Handlingen UNION (Microsoft Jet SQL)
Delsætningen IN (Microsoft Jet SQL) | Delsætningen WHERE (Microsoft Jet SQL)
Sætningen INSERT INTO (Microsoft Jet SQL) |

Eksempel

Eksempel på sætningen SELECT...INTO


Eksempel på sætningen SELECT...INTO (DAO)

Eksempel på sætningen SELECT...INTO

I følgende eksempel udvælges alle poster i tabellen Medarbejdere, og de kopieres til en ny tabel med navnet Medarbejderkopi.

Sub SelectIntoX()

    Dim dbs As Database

    Dim qdf As QueryDef

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Udvælg alle poster i tabellen Medarbejdere,

    ' og kopier dem til en ny tabel kaldet Medarbejderkopi.

    dbs.Execute "SELECT Medarbejdere.* INTO " _

        & "[Medarbejderkopi] FROM Medarbejdere;"

    ' Slet denne tabel, da dette er en demonstration.

    dbs.Execute "DROP TABLE [Medarbejderkopi];"

    dbs.Close

End Sub


Eksempel på sætningen SELECT og delsætningen FROM (DAO)

Eksempel på sætningen SELECT og delsætningen FROM

I nogle af følgende eksempler antages det, at der findes et hypotetisk felt med navnet Løn i tabellen Medarbejdere. Bemærk, at dette felt faktisk ikke findes i tabellen Medarbejdere i databasen Northwind.

I følgende eksempel oprettes et Recordset-objekt af typen dynamisk udvalg på baggrund af en SQL-sætning, der udvælger felterne Efternavn og Fornavn i alle posterne i tabellen Medarbejdere. Der foretages et kald til proceduren EnumFields, som udskriver indholdet af et Recordset-objekt i vinduet Fejlfinding.

Sub SelectX1()

    Dim dbs As Database, rst As Recordset

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Udvælg værdierne fra felterne Efternavn og

    ' Fornavn i alle poster i tabellen Medarbejdere.

    Set rst = dbs.OpenRecordset("SELECT Efternavn, " _

        & "Fornavn FROM Medarbejdere;")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

' Kald EnumFields for at udskrive indholdet af

' Recordset-objektet.

    EnumFields rst,12

dbs.Close

End Sub

I følgende eksempel tælles antallet af poster, der har en indtastning i feltet Postnr, og det returnerede felt får navnet Antal.

Sub SelectX2()

    Dim dbs As Database, rst As Recordset

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Tæl antallet af poster med en værdi for Postnr og

    ' returner resultatet i feltet Antal.

    Set rst = dbs.OpenRecordset("SELECT Antal " _

        & "(Postnr) AS Beregning FROM Kunder;")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    ' Recordset-objektet. Angiv, at feltbredden = 12.

    EnumFields rst, 12

    dbs.Close

End Sub

I følgende eksempel vises antallet af medarbejdere, gennemsnitslønnen og maksimumlønnen.

Sub SelectX3()

    Dim dbs As Database, rst As Recordset

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

Set dbs = OpenDatabase("Northwind.mdb")

    ' Tæl antallet af medarbejdere, beregn

    ' gennemsnitslønnen, og returner den højeste løn.

    Set rst = dbs.OpenRecordset("SELECT Antal (*) " _

        & "AS AntalMedarbejdere, Avg(Løn) " _

        & "AS Gennemsnitsløn, Max(Løn) " _

        & "AS Maksimumløn FROM Medarbejdere;")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    ' Recordset-objektet. Overfør Recordset-objektet og

    ' den ønskede feltbredde.

    EnumFields rst, 17

    dbs.Close

End Sub

Den procedure, der foretager kaldet, overfører et Recordset-objekt til Sub-proceduren EnumFields. Derefter formaterer og udskriver proceduren felterne i Recordset i vinduet Fejlfinding. Variablen intFldLen er den valgte, udskrevne feltbredde. Nogle felter afkortes muligvis.

Sub EnumFields(rst As Recordset, intFldLen As Integer)

    Dim lngRecords As Long, lngFields As Long

    Dim lngRecCount As Long, lngFldCount As Long

    Dim strTitle As String, strTemp As String

    ' Angiv variablen lngRecords til antallet af poster

    ' i postsættet.

    lngRecords = rst.RecordCount

    ' Angiv variablen lngFields til antallet af felter

    ' i postsættet.

    lngFields = rst.Fields.Count

    Debug.Print "Der er " & lngRecords _

        & " poster med " & lngFields _

        & " felter i postsættet."

    Debug.Print

    ' Opret en streng til udskrivning af

    ' kolonneoverskriften. strTitle = "Post  "

    For lngFldCount = 0 To lngFields - 1

        strTitle = strTitle _

        & Left(rst.Fields(lngFldCount).Name _

        & Space(intFldLen), intFldLen)

    Next lngFldCount

    ' Udskriv kolonneoverskriften.

    Debug.Print strTitle

    Debug.Print

    ' Udfør en løkke i postsættet. Udskriv

    ' feltværdier og nummeret på posten.

    rst.MoveFirst

    For lngRecCount = 0 To lngRecords - 1

        Debug.Print Right(Space(6) & _

            Str(lngRecCount), 6) & "  ";

        For lngFldCount = 0 To lngFields - 1

            ' Undersøg, om der findes Null-værdier.

            If IsNull(rst.Fields(lngFldCount)) Then

                strTemp = "<null>"

            Else

                ' Indstil strTemp til feltindholdet.

                Select Case _

                    rst.Fields(lngFldCount).Type

                    Case 11

                        strTemp = ""

                    Case dbText, dbMemo

                        strTemp = _

                            rst.Fields(lngFldCount)

                    Case Else

                        strTemp = _

                            str(rst.Fields(lngFldCount))

                End Select

            End If

            Debug.Print Left(strTemp _

                & Space(intFldLen), intFldLen);

        Next lngFldCount

        Debug.Print

        rst.MoveNext

    Next lngRecCount

End Sub


Funktionerne StDev og StDevP Functions (Microsoft Jet SQL)

Funktionerne StDev og StDevP

Returnerer skøn over standardafvigelsen for en population eller en stikprøve af en population, der gengives som et sæt værdier, der er indeholdt i et angivet felt i en forespørgsel.

Syntaks

StDev(udtr)

StDevP(udtr)

Pladsholderen udtr repræsenterer et strengudtryk, der identificerer det felt, som indeholder de numeriske data, du vil beregne på, eller et udtryk, der udfører en beregning ved hjælp af dataene i det pågældende felt. Operander i udtr kan medtage navnet på et tabelfelt, en konstant eller på en funktion, der kan være enten indbygget eller brugerdefineret, men ikke en af de andre SQL- aggregatfunktioner.

Bemærkninger

Funktionen StDevP evaluerer en population, og funktionen StDev evaluerer en populationsstikprøve.

Hvis den underliggende forespørgsel indeholder mindre end to poster (eller ingen poster i forbindelse med funktionen StDevP), returnerer disse funktioner en Null-værdi, der angiver, at en standardafvigelse ikke kan beregnes.

Du kan benytte funktionerne StDev og StDevP i et forespørgselsudtryk. Du kan også anvende dette udtryk i egenskaben SQL i et QueryDef-objekt, eller når du opretter et Recordset-objekt, der er baseret på en SQL-forespørgsel.

Se også
Funktionen Avg (Microsoft Jet SQL) | SQL-aggregatfunktioner (SQL)
Sætningen SELECT (Microsoft Jet SQL) | Funktionen SUM (Microsoft Jet SQL)

Eksempel

Eksempel på funktionerne StDev og StDevP


Eksempel på funktionerne StDev og StDevP (DAO)

Eksempel på funktionerne StDev og StDevP

I følgende eksempel benyttes tabellen Ordrer til at anslå standardafvigelsen for fragtomkostninger ved ordrer, der er afsendt til Storbritannien.

I følgende eksempel kaldes proceduren EnumFields, som du finder i eksemplet på sætningen SELECT.

Sub StDevX()

    Dim dbs As Database, rst As Recordset

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Beregn standardafvigelsen for fragtomkostninger

    ' ved ordrer, der er afsendt til Storbritannien.

    Set rst = dbs.OpenRecordset("SELECT " _

        & "StDev(Fragtomkostninger) " _

        & "AS [Afvigelse for fragtomkostninger] FROM Ordrer " _

        & "WHERE Modtagerland = 'Storbritannien';")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    ' Recordset-objektet. Overfør Recordset-objektet og

    ' den ønskede feltbredde.

    EnumFields rst, 15

    Debug.Print

    Set rst = dbs.OpenRecordset("SELECT " _

        & "StDevP(Fragtomkostninger) " _

        & "AS [PAfvigelse for fragtomkostninger] FROM Ordrer " _

        & "WHERE Modtagerland = 'Storbritannien';")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    ' Recordset-objektet. Overfør Recordset-objektet og

    ' den ønskede feltbredde.

    EnumFields rst, 15

    dbs.Close

End Sub


SQL-underforespørgsler

En underforespørgsel er en SELECT sætning, der er indlejret i en SELECT-, SELECT...INTO, INSERT...INTO, DELETE,eller UPDATE sætning eller i en anden underforespørgsel.

Syntaks

Du kan bruge følgende tre syntaksformer til at oprette en underforespørgsel:

sammenligning [ANY | ALL | SOME] (sqlsætning)

udtryk [NOT] IN (sqlsætning)

[NOT] EXISTS (sqlsætning)

En underforespørgsel indeholder følgende argumenter:

Argument | Beskrivelse
sammenligning | Et udtryk og en sammenligningsoperator, der sammenligner udtrykket med resultatet af underforespørgslen.
udtryk | Et udtryk, der søges efter i underforespørgslens resultatsæt.
sqlsætning | En SELECT-sætning, der følger det samme format og de samme regler som alle andre SELECT-sætninger. Sætningen skal omsluttes af parenteser.

Bemærkninger

Du kan benytte en underforespørgsel i stedet for et udtryk på feltlisten i en SELECT-sætning eller til en WHERE eller HAVING delsætning. I en underforespørgsel kan du bruge en SELECT-sætning til at angive et sæt af en eller flere bestemte værdier, der skal evalueres i WHERE- eller HAVING-delsætningsudtrykket.

Du kan bruge prædikaterne ANY eller SOME, der er synonyme, til at udtrække poster i den overordnede forespørgsel, der opfylder sammenligningen med alle poster, der er hentet i underforespørgslen. I følgende eksempel returneres alle produkter, hvis pris pr. enhed er større end prisen på et produkt, der er solgt med en rabat på 25 procent eller mere:

SELECT * FROM Produkter

WHERE [Pris pr enhed] > ANY

(SELECT [Pris pr enhed] FROM Ordrespecifikationer

WHERE Rabat >= .25);

Du kan bruge prædikatet ALL til kun at udtrække de poster i den overordnede forespørgsel, der opfylder sammenligningen med alle poster, der er hentet i underforespørgslen. Hvis du har ændret ANY til ALL i det foregående eksempel, returnerer forespørgslen kun de produkter, hvis pris pr. enhed er større end prisen på alle de produkter, der er solgt med en rabat på 25 procent eller mere. Dette er langt mere begrænsende.

Du kan benytte prædikatet IN til kun at udtrække de poster i den overordnede forespørgsel, som en post i underforespørgslen indeholder en tilsvarende værdi af. I følgende eksempel returneres alle produkter med en rabat på 25 procent eller mere:

SELECT * FROM Produkter

WHERE Produktnr IN

(SELECT Produktnr FROM Ordrespecifikationer

WHERE Rabat >= .25);

Omvendt kan du bruge NOT IN til kun at hente de poster i den overordnede forespørgsel, hvor der ikke findes en post i underforespørgslen, der indeholder en tilsvarende værdi.

Du kan bruge prædikatet EXISTS (med det valgfrie reserverede ord NOT) i sand/falsk-sammenligninger til at bestemme, om underforespørgslen returnerer poster.

Du kan også benytte aliasesfor tabelnavne i en underforespørgsel til at referere til tabeller, der vises i en FROM delsætning uden for underforespørgslen. I følgende eksempel returneres navnene på medarbejdere, hvis løn svarer til eller er større end den gennemsnitsløn for alle medarbejdere, der har samme stilling. Tabellen Medarbejdere har aliaset "T1":

SELECT Efternavn,

Fornavn, Stilling, Løn

FROM Medarbejdere AS T1

WHERE Løn >=

(SELECT Avg(Løn)

FROM Medarbejdere

WHERE T1.Stilling = Medarbejdere.Stilling) [Ordre efter stilling];

I det foregående eksempel er det reserverede ord AS valgfrit.

Visse underforespørgsler er tilladte i krydstabuleringsforespørgsler – især som prædikater (i WHERE-delsætningen). Underforespørgsler som output (på SELECT-listen) er ikke tilladt i krydstabuleringsforespørgsler.

Se også
Prædikaterne ALL DISTINCT, DISTINCTROW, TOP (Microsoft Jet SQL) | Sætningen SELECT (Microsoft Jet SQL)
Sætningen DELETE (Microsoft Jet SQL) | Sætningen SELECT INTO (Microsoft Jet SQL)
Delsætningen HAVING (Microsoft Jet SQL) | Handlingen UNION (Microsoft Jet SQL)
Handlingen INNER JOIN (Microsoft Jet SQL) | Sætningen UPDATE (Microsoft Jet SQL)
Sætningen INSERT INTO (Microsoft Jet SQL) | Delsætningen WHERE (Microsoft Jet SQL)
Handlingerne LEFT JOIN og RIGHT JOIN (Microsoft Jet SQL) |

Eksempel

Eksempel på SQL-underforespørgsler


Eksempel på SQL-underforespørgsler (DAO)

Eksempel på SQL-underforespørgsler

I følgende eksempel vises en liste over navnet på og kontaktpersonen til alle de kunder, der har afgivet en ordre i andet kvartal i 1995.

I følgende eksempel kaldes proceduren EnumFields, som du finder i eksemplet på sætningen SELECT.

Sub SubQueryX()

    Dim dbs As Database, rst As Recordset

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Viser navnet og kontaktpersonen for hver kunde,

    ' der har afgivet en ordre i andet kvartal i

    ' 1995.

    Set rst = dbs.OpenRecordset("SELECT Kontaktperson," _

        & " Firmanavn, Stilling, Telefonnummer" _

        & " FROM Kunder" _

        & " WHERE Kundeid" _

        & " IN (SELECT Kundeid FROM Ordrer" _

        & " WHERE Ordredato Between #04/1/95#" _

        & " And #07/1/95#);")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    ' Recordset-objektet. Overfør Recordset-objektet og

    ' den ønskede feltbredde.

    EnumFields rst, 25

    dbs.Close

End Sub


Funktionen Sum (Microsoft Jet SQL)

Funktionen Sum

Returnerer summen af et sæt værdier, der er indeholdt i et angivet felt i en forespørgsel.

Syntaks

Sum(udtr)

Pladsholderen udtr repræsenterer et strengudtryk, der identificerer det felt, som indeholder de numeriske data, du vil tilføje, eller et udtryk, der udfører en beregning ved hjælp af dataene i det pågældende felt. Operander i udtr kan medtage navnet på et tabelfelt, en konstant eller på en funktion, der kan være enten indbygget eller brugerdefineret, men ikke en af de andre SQL- aggregat funktioner.

Bemærkninger

Funktionen Sum lægger værdierne i et felt sammen. Du kan f.eks. anvende funktionen Sum til at bestemme de samlede fragtomkostninger.

Funktionen Sum ignorerer poster, der indeholder Null-felter. I følgende eksempel vises, hvordan du kan beregne summen af produkterne i felterne Pris pr enhed og Antal:

SELECT

Sum([Pris pr enhed] * Antal)

AS [Samlede indtægt] FROM Ordrespecifikationer;

Du kan benytte funktionen Sum i et forespørgselsudtryk. Du kan også anvende dette udtryk i egenskaben SQL i et QueryDef-objekt, eller når du opretter et Recordset, der er baseret på en SQL-forespørgsel.

Se også
Funktionen Count (Microsoft Jet SQL) | SQL-aggregatfunktioner (SQL)
Sætningen SELECT (Microsoft Jet SQL) |

Eksempel

Eksempel på funktionen Sum


Eksempel på funktionerne StDev og StDevP

Eksempel på funktionen Sum

I følgende eksempel benyttes tabellen Ordrer til at beregne det samlede salg for ordrer, der er afsendt til Storbritannien.

I følgende eksempel kaldes proceduren EnumFields, som du finder i eksemplet på sætningen SELECT.

Sub SumX()

    Dim dbs As Database, rst As Recordset

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Beregn det samlede salg for ordrer, der er

    ' afsendt til Storbritannien.

    Set rst = dbs.OpenRecordset("SELECT" _

        & " Sum([Pris pr enhed]*Antal)" _

        & " AS [Samlede salg i GB] FROM Ordrer" _

        & " INNER JOIN [Ordrespecifikationer] ON" _

        & " Ordrer.Ordreid = [Ordrespecifikationer].Ordreid" _

        & " WHERE (Modtagerland = 'Storbritannien');")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    ' Recordset-objektet. Overfør Recordset-objektet og

    ' den ønskede feltbredde.

    EnumFields rst, 15

    dbs.Close

End Sub


Sætningen TRANSACTION (Microsoft Jet SQL)

Sætningen TRANSACTION

Bruges til at starte og afslutte eksplicitte transaktioner.

Syntaks

Starter en ny transaktionen.

BEGIN TRANSACTION

Afslutter en transaktion ved at bekræfte alt arbejde, der er udført under transaktionen.

COMMIT [TRANSACTION | WORK]

Afslutter en transaktion ved at alt arbejdet, der er udført, under transaktionen rulles tilbage.

ROLLBACK [TRANSACTION | WORK]

Bemærkninger

Transaktioner startes ikke automatisk. Hvis du starter en transaktion, skal du gøre det udtrykkeligt ved hjælp af BEGIN TRANSACTION.

Transaktioner kan indlejres i op til fem niveauer. Hvis du vil starte en indlejret transaktion, skal du bruge BEGIN TRANSACTION i den eksisterende transaktions kontekst.

Transaktioner understøttes ikke i sammenkædede tabeller.


Sætningen TRANSFORM (Microsoft Jet SQL)

Sætningen TRANSFORM

Opretter en krydstabuleringsforespørgsel.

Syntaks

TRANSFORM aggfunktion
selectsætning
PIVOT pivotfelt [IN (værdi1[, værdi2[, ...]])]

Sætningen TRANSFORM indeholder følgende argumenter:

Argument | Beskrivelse
aggregatfunktion | En SQL-aggregatfunktion, der arbejder på udvalgte data.
selectsætning | En SELECT-sætning.
pivotfelt | Det felt eller udtryk, du vil bruge til at oprette kolonneoverskrifter i forespørgslens resultatsæt.
værdi1, værdi2 | Faste værdier, der bruges til at oprette kolonneoverskrifter.

Bemærkninger

Når du opsummerer data ved hjælp af en krydstabuleringsforespørgsel, vælger du værdier fra angivne felter eller udtryk som kolonneoverskrifter, så du kan vise data i et mere komprimeret format end med en udvælgelsesforespørgsel.

TRANSFORM er valgfri, men er første sætning i en SQL-streng, når den medtages. Den står foran en SELECT-sætning, der angiver de felter, som benyttes som rækkeoverskrifter, og en GROUP BY-delsætning, der angiver rækkegruppering. Du kan også medtage andre delsætninger, såsom WHERE, der angiver ekstra udvælgelses- eller sorteringskriterier. Du kan også bruge underforespørgsler som prædikater – især i WHERE-delsætningen – i en krydstabuleringsforespørgsel.

De værdier, der returneres i pivotfelt, bruges som kolonneoverskrifter i forespørgslens resultatsæt. Hvis du f.eks. pivoterer salgstallene på salgsmåneden i en krydstabuleringsforespørgsel, oprettes 12 kolonner. Du kan begrænse pivotfelt til at oprette overskrifter fra faste værdier (værdi1, værdi2), der er vist i den valgfrie IN-delsætning. Du kan også medtage faste værdier, der ikke findes data for, til at oprette ekstra kolonner.

Se også
Delsætningen FROM (Microsoft Jet SQL) | Sætningen SELECT (Microsoft Jet SQL)
Delsætningen GROUP BY (Microsoft Jet SQL) | SQL-aggregatfunktioner (SQL)
Handlingen INNER JOIN (Microsoft Jet SQL) | SQL-underforespørgsler
Delsætningen ORDER BY (Microsoft Jet SQL) | Delsætningen WHERE (Microsoft Jet SQL)

Eksempel

Eksempel på sætningen TRANSFORM


Eksempel på sætningen TRANSFORM (DAO)

Eksempel på sætningen TRANSFORM

I følgende eksempel bruges delsætningen SQL TRANSFORM til at oprette en krydstabuleringsforespørgsel, der viser antallet af ordrer pr. medarbejder i alle kvartaler i 1994. Hvis du vil afspille denne procedure, skal du anvende funktionen SQLTRANSFORMOutput.

Sub TransformX1()

    Dim dbs As Database

    Dim strSQL As String

    Dim qdfTRANSFORM As QueryDef

    strSQL = "PARAMETERS prmYear SHORT; TRANSFORM " _

        & "Count(Ordreid) " _

        & "SELECT Fornavn & "" "" & Efternavn AS " _

        & "FuldeNavn FROM Medarbejdere INNER JOIN Ordrer " _

        & "ON Medarbejdere.Medarbejderid = " _

        & "Ordrer.Medarbejderid WHERE DatePart " _

        & "(""åååå"", Ordredato) = [prmYear] "

       strSQL = strSQL & "GROUP BY Fornavn & " _

        & """ "" & Efternavn " _

        & "ORDER BY Fornavn & "" "" & Efternavn " _

        & "PIVOT DatePart(""q"", Ordredato)"

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    Set qdfTRANSFORM = dbs.CreateQueryDef _

        ("", strSQL)

    SQLTRANSFORMOutput qdfTRANSFORM, 1994

    dbs.Close

End Sub

I følgende eksempel bruges SQL-delsætningen TRANSFORM til at oprette en krydstabuleringsforespørgsel, der er en smule mere kompliceret, og som viser det samlede beløb for de enkelte medarbejderes ordrer i alle kvartaler i 1994. Hvis du vil afspille denne procedure, skal du anvende funktionen SQLTRANSFORMOutput.

Sub TransformX2()

    Dim dbs As Database

    Dim strSQL As String

    Dim qdfTRANSFORM As QueryDef

    strSQL = "PARAMETERS prmYear SMALLINT; TRANSFORM " _

        & "Sum(Subtotal) SELECT Fornavn & "" """ _

        & "& Efternavn AS FuldeNavn " _

        & "FROM Medarbejdere INNER JOIN " _

        & "(Ordrer INNER JOIN Ordresubtotaler " _

        & "ON Ordrer.Ordreid = " _

        & "Ordresubtotaler.Ordreid) " _

        & "ON Medarbejdere.Medarbejderid = " _

        & "Ordrer.Medarbejderid WHERE DatePart" _

        & "(""åååå"", Ordredato) = [prmYear] "

       strSQL = strSQL & "GROUP BY Fornavn & "" """ _

        & "& Efternavn " _

        & "ORDER BY Fornavn & "" "" & Efternavn " _

        & "PIVOT DatePart(""q"",Ordredato)"

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    Set qdfTRANSFORM = dbs.CreateQueryDef _

        ("", strSQL)

    SQLTRANSFORMOutput qdfTRANSFORM, 1994

    dbs.Close

End Sub

Function SQLTRANSFORMOutput(qdfTemp As QueryDef, _

    intYear As Integer)

    Dim rstTRANSFORM As Recordset

    Dim fldLoop As Field

    Dim booFirst As Boolean

    qdfTemp.PARAMETERS!prmYear = intYear

    Set rstTRANSFORM = qdfTemp.OpenRecordset()

    Debug.Print qdfTemp.SQL

    Debug.Print

    Debug.Print , , "Kvartal"

    With rstTRANSFORM

        booFirst = True

        For Each fldLoop In .Fields

            If booFirst = True Then

                Debug.Print fldLoop.Name

                Debug.Print , ;

                booFirst = False

            Else

                Debug.Print , fldLoop.Name;

            End If

        Next fldLoop

        Debug.Print

        Do While Not .EOF

            booFirst = True

            For Each fldLoop In .Fields

                If booFirst = True Then

                    Debug.Print fldLoop

                    Debug.Print , ;

                    booFirst = False

                Else

                    Debug.Print , fldLoop;

                End If

            Next fldLoop

            Debug.Print

            .MoveNext

        Loop

    End With

End Function


Handlingen UNION (Microsoft Jet SQL)

Handlingen UNION

Opretter en foreningsforespørgsel, der kombinerer resultaterne af to eller flere uafhængige forespørgsler eller tabeller.

Syntaks

[TABLE] forespørgsel1 UNION [ALL] [TABLE] forespørgsel2 [UNION [ALL] [TABLE] forespørgseln [ ... ]]

Handlingen UNION indeholder følgende argumenter:

Argument | Beskrivelse
forespørgsel1-n | En SELECT-sætning, navnet på en lagret forespørgsel eller navnet på en lagret tabel, der indledes med det reserverede ord TABLE.

Bemærkninger

Du kan flette resultaterne af to eller flere forespørgsler, tabeller og SELECT-sætninger i en vilkårlig kombination i en enkelt UNION-handling. I følgende eksempel flettes en eksisterende tabel med navnet Nye konti og en SELECT-sætning:

TABLE [Nye konti] UNION ALL

SELECT *

FROM Kunder

WHERE Ordrebeløb > 1000;

Som standard returneres ingen dublerede poster, når du benytter en UNION-handling. Du skal dog medtage prædikatet ALL for at sikre, at alle poster returneres. Dette betyder også, at forespørgslen kører hurtigere.

Alle forespørgsler i en UNION-handling skal anmode om det samme antal felter. Felterne skal dog ikke have samme størrelse eller datatype

Brug kun aliaser i den første SELECT-sætning, da de ignoreres i alle andre. I delsætningen ORDER BY skal du referere til felter med det navn, de har i den første SELECT-sætning.

Bemærk!

  • Du kan bruge en GROUP BY- eller HAVING-delsætning i hvert forespørgsel-argument til at gruppere de returnerede data.
  • Du kan bruge en ORDER BY-delsætning i slutningen af det sidste forespørgsel-argument til at vise de returnerede data i en angivet rækkefølge.
Se også
Prædikaterne ALL DISTINCT, DISTINCTROW, TOP (Microsoft Jet SQL) | Delsætningen ORDER BY (Microsoft Jet SQL)
Delsætningen GROUP BY (Microsoft Jet SQL) | Sætningen SELECT (Microsoft Jet SQL)
Delsætningen HAVING (Microsoft Jet SQL) | SQL-underforespørgsler
Handlingen INNER JOIN (Microsoft Jet SQL) | Delsætningen WHERE (Microsoft Jet SQL)
Handlingerne LEFT JOIN og RIGHT JOIN (Microsoft Jet SQL) |

Eksempel

Eksempel på handlingen UNION


Eksempel på handlingen UNION (DAO)

Eksempel på handlingen UNION

I følgende eksempel hentes navnene på og byerne for alle leverandører og kunder i Brasilien.

I følgende eksempel kaldes proceduren EnumFields, som du finder i eksemplet på sætningen SELECT.

Sub UnionX()

    Dim dbs As Database, rst As Recordset

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Hent navnene på og byerne for alle leverandører i

    ' Brasilien.

    Set rst = dbs.OpenRecordset("SELECT Firmanavn," _

        & " Bynavn FROM Leverandører" _

        & " WHERE Land = 'Brasilien' UNION" _

        & " SELECT Firmanavn, Bynavn FROM Kunder" _

        & " WHERE Land = 'Brasilien';")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    ' Recordset-objektet. Overfør Recordset-objektet og

    ' den ønskede feltbredde.

    EnumFields rst, 12

    dbs.Close

End Sub


Sætningen UPDATE (Microsoft Jet SQL)

Sætningen UPDATE

Opretter en opdateringsforespørgsel, der ændrer værdier i felter i en angivet tabel, der er baseret på bestemte kriterier.

Syntaks

UPDATE tabel
SET nyværdi
WHERE kriterier

Sætningen UPDATE indeholder følgende argumenter:

Argument | Beskrivelse
tabel | Navnet på den tabel, der indeholder de data, du vil ændre.
nyværdi | Et udtryk, der bestemmer den værdi, der skal indsættes i et bestemt felt i de opdaterede poster.
kriterier | Et udtryk, der bestemmer, hvilke poster der skal opdateres. Kun poster, der opfylder udtrykket, opdateres.

Bemærkninger

UPDATE er særlig nyttig, når du vil ændre mange poster, eller når de poster, du vil ændre, befinder sig i flere tabeller.

Du kan ændre flere felter på samme tid. I følgende eksempel forøges værdierne i Ordrebeløb med 10 procent og værdierne i Fragtomkostninger med 3 procent for speditører i Storbritannien:

UPDATE Ordrer

SET Ordrebeløb = Ordrebeløb * 1.1,

Fragtomkostninger = Fragtomkostninger * 1.03

WHERE Modtagerland = 'GB';

Vigtigt!

  • UPDATE genererer ikke et resultatsæt. Når du har opdateret poster ved hjælp af en opdateringsforespørgsel, kan du heller ikke fortryde handlingen. Hvis du vil vide, hvilke poster der opdateres, skal du først undersøge resultaterne af en udvælgelsesforespørgsel, der anvender samme kriterier, og derefter køre opdateringsforespørgslen.
  • Behold altid sikkerhedskopier af dataene. Hvis du opdaterer de forkerte poster, kan du hente dem fra sikkerhedskopierne.
Se også
Sætningen SELECT (Microsoft Jet SQL) Delsætningen WHERE (Microsoft Jet SQL)

Eksempel

Eksempel på sætningen UPDATE


Eksempel på sætningen UPDATE (DAO)

Eksempel på sætningen UPDATE

I følgende eksempel ændres værdierne til 5 i feltet "Rapporterer til" i alle de medarbejderposter, hvor værdien i dette felt i øjeblikket er 2.

Sub UpdateX()

    Dim dbs As Database

    Dim qdf As QueryDef

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Lad værdierne i feltet "Rapporterer til" være 5 i

    ' alle de medarbejderposter, hvor værdien i dette

    ' felt i øjeblikket er 2.

    dbs.Execute "UPDATE Medarbejdere " _

        & "SET [Rapporterer til] = 5 " _

        & "WHERE [Rapporterer til] = 2;"

    dbs.Close

End Sub


Brug af jokertegn i strengsammenligninger

Indbygget mønstersammenligning er et alsidigt værktøj i forbindelse med strengsammenligninger. I følgende tabel vises de jokertegn, du kan benytte sammen med operatoren Like, og det antal cifre eller strenge, de svarer til.

Tegn i mønster | Svarer til udtryk
? eller _ (understregningstegn) | Et enkelt tegn
* eller % | Nul eller flere tegn
# | Ethvert enkelt ciffer (0 – 9)
[tegnliste] | Ethvert enkelt tegn i tegnliste
[!tegnliste] | Ethvert enkelt tegn, der ikke findes i tegnliste

Du kan benytte en gruppe på et eller flere tegn (tegnliste), der er omsluttet af kantede parenteser ([ ]), til at modsvare ethvert enkelt tegn i udtryk, og tegnliste kan medtage næsten alle tegn i ANSI-tegnsættet, herunder cifre. Du kan bruge specialtegnenes venstre kantet parentes ([ ), spørgsmålstegn (?), nummertegn (#) og stjerne (*) til at modsvare hinanden direkte, hvis de er omsluttet i kantede parenteser. Højre kantet parentes ( ]) kan ikke svare til sig selv i en gruppe, men du kan anvende den uden for en gruppe som et enkelt tegn.

Ud over en simpel liste over tegn, der er omsluttet i kantede parenteser, kan tegnliste angive et tegnområde ved hjælp af en bindestreg (-) til at adskille den øverste og nederste grænse i området. Hvis du f.eks. bruger [A-Å] i mønster, giver det et sammenfald, hvis det tilsvarende tegns placering i udtryk indeholder nogle af tegnene skrevet med store bogstaver i området A til Å. Du kan medtage flere områder i de kantede parenteser uden at begrænse områderne. [a-åA-Å0-9] svarer f.eks. til ethvert alfanumerisk tegn.

Det er vigtigt at bemærke, at ANSI SQL-jokertegn (%) og (_) kun er tilgængelig med Microsoft® Jet version 4.X og Microsoft OLE DB Provider til Jet. De fungerer som konstanter, hvis de bruges via Microsoft Access eller DAO.

Andre vigtige regler for mønstersammenligning består af følgende:

  • Et udråbstegn (!) i begyndelsen af tegnliste betyder, at der foretages en sammenligning, når programmet finder et vilkårligt tegn i udtryk, ikke i tegnliste. Når udråbstegnet anvendes uden for de kantede parenteser, modsvarer det sig selv.
  • Du kan bruge bindestregen (-) enten i begyndelsen (efter et udråbstegn, hvis der bruges et) eller i slutningen af tegnliste til at modsvare sig selv. På ethver andet sted identificerer bindestregen et område med ANSI-tegn.
  • Når du angiver et tegnområde, skal tegnene vises i stigende sorteringsrækkefølge (A-Å eller 0-100). [A-Å] er et gyldigt mønster, men [Å-A] er ikke.
  • Tegnsekvensen [ ] ignoreres. Den fortolkes som en streng af længden nul (“”).
Se også
Operatoren Like SQL-udtryk


Funktionerne Var og VarP (Microsoft Jet SQL)

Funktionerne Var og VarP

Returnerer skøn over afvigelsen for en population eller en stikprøve af en population, der gengives som et sæt værdier, der er indeholdt i et angivet felt i en forespørgsel.

Syntaks

Var(udtr)

VarP(udtr)

Pladsholderen udtr repræsenterer et strengudtryk, der identificerer det felt, som indeholder de numeriske data, du vil beregne på, eller et udtryk, der udfører en beregning ved hjælp af dataene i det pågældende felt. Operander i udtr kan medtage navnet på et tabelfelt, en konstant eller på en funktion, der kan være enten indbygget eller brugerdefineret, men ikke en af de andre SQL- aggregat funktioner.

Bemærkninger

Funktionen VarP evaluerer en population, og funktionen Var evaluerer en populationsstikprøve.

Hvis den underliggende forespørgsel indeholder mindre end to poster, returnerer funktionerne Var og VarP en Null-værdi, der angiver, at en varians ikke kan beregnes.

Du kan benytte funktionerne Var og VarP i et forespørgselsudtryk eller i en SQL-sætning.

Se også

SQL-aggregatfunktioner (SQL)

Eksempel

Eksempel på funktionerne VAR og VARP


Eksempel på funktionerne Var og VarP (DAO)

Eksempel på funktionerne Var og VarP

I følgende eksempel benyttes tabellen Ordrer til at anslå variansen for fragtomkostninger ved ordrer, der er afsendt til Storbritannien.

I følgende eksempel kaldes proceduren EnumFields, som du finder i eksemplet på sætningen SELECT.

Sub VarX()

    Dim dbs As Database, rst As Recordset

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Beregn variansen for fragtomkostninger

    ' fragtomkostninger ved de ordrer, der er afsendt ' til Storbritannien.

    Set rst = dbs.OpenRecordset("SELECT " _

        & "Var(Fragtomkostninger) " _

        & "AS [Varians for fragtomkostninger i GB] " _

        & "FROM Ordrer WHERE Modtagerland = ' Storbritannien';")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    ' Recordset-objektet. Overfør Recordset-objektet og

    ' den ønskede feltbredde.

    EnumFields rst, 20

    Debug.Print

    Set rst = dbs.OpenRecordset("SELECT " _

        & "VarP(Fragtomkostninger) " _

        & "AS [PVarians for fragtomkostninger i GB] " _

        & "FROM Ordrer WHERE Modtagerland = ' Storbritannien';")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    ' Recordset-objektet. Overfør Recordset-objektet og

    ' den ønskede feltbredde.

    EnumFields rst, 20

    dbs.Close

End Sub


Delsætningen WHERE (Microsoft Jet SQL)

Delsætningen WHERE

Angiver, hvilke poster i de tabeller der vises i delsætningen FROM, som påvirkes af en SELECT-, UPDATE- eller DELETE-sætning.

Syntaks

SELECT feltliste
FROM tabeludtryk
WHERE kriterie

En SELECT-sætning, der indeholder en WHERE-delsætning, har følgende argumenter:

Argument | Beskrivelse
feltliste | Navnet på det eller de felter, der skal hentes sammen med eventuelle aliaser for feltnavne, udvælgelsesprædikater (ALL, DISTINCT, DISTINCTROW eller TOP) eller andre gyldige SELECT-sætninger.
tabeludtryk | Navnet på den eller de tabeller, som data hentes fra.
kriterier | Et udtryk, som poster skal opfylde for at blive medtaget i forespørgselsresultaterne.

Bemærkninger

Microsoft Jet-databasemotoren udvælger de poster, der opfylder de betingelser, som anføres i WHERE-delsætningen. Hvis du ikke angiver en WHERE-delsætning, returnerer forespørgslen alle rækker i tabellen. Hvis du angiver mere end en tabel i forespørgslen, og du ikke har medtaget en WHERE-delsætning eller en JOIN-delsætning, genererer forespørgslen et kartesisk produkt i tabellerne.

WHERE er valgfri, men følger efter FROM, når den medtages. Du kan f.eks. vælge alle medarbejdere i salgsafdelingen (WHERE Afdeling = 'Salg') eller alle kunder i alderen 18 til 30 (WHERE Alder Between 18 And 30).

Hvis du ikke bruger en JOIN-delsætning til at udføre SQL-joinhandlinger i flere tabeller, vil det fremkomne Recordset-ikke opdateres.

WHERE svarer til HAVING. WHERE bestemmer, hvilke poster, der vælges. Når poster er grupperet med GROUP BY, bestemmer HAVING på samme måde, hvilke poster der vises.

Du kan bruge WHERE-delsætningen til at slette poster, du ikke vil have grupperet med en GROUP BY-delsætning.

Du kan bruge forskellige udtryk til at bestemme, hvilke poster SQL-sætningen returnerer. Følgende SQL-sætning vælger f.eks. alle de medarbejdere, hvis lønninger er større end kr 186.000:

SELECT Efternavn, Løn

FROM Medarbejdere

WHERE Løn > 186.000;

En WHERE-delsætning kan indeholde op til 40 udtryk, der er sammenkædet ved hjælp af logiske operatorer, såsom And og Or.

Når du indtaster et feltnavn, der indeholder et mellemrum eller tegnsætning, skal du omslutte navnet med kantede parenteser ([ ]). En tabel med kundeoplysninger kan f.eks. indeholde oplysninger om bestemte kunder :

SELECT [Kundes ynglingsrestaurant]

Når du angiver argumentet kriterier, skal datokonstanter anføres i amerikansk format, selvom du ikke bruger den amerikanske version af Microsoft Jet-databasemotoren. Den 10. maj 1996 skrives f.eks. 10-05-96 i Danmark og som 5/10/96 i USA. Du skal sørge for at omslutte datokonstanter med nummertegnet (#) som vist i følgende eksempler.

Hvis du vil finde poster, der er dateret 10. maj 1996 i en dansk database, skal du anvende følgende SQL-sætning:

SELECT *

FROM Ordrer

WHERE Forsendelsesdato = #5/10/96#;

Du kan også bruge funktionen DateValue, der kender de internationale indstillinger i Microsoft Windows®. Brug f.eks. denne programkode i forbindelse med USA:

SELECT *

FROM Ordrer

WHERE Forsendelsesdato = DateValue('5/10/96');

Og brug denne programkode i forbindelse med Danmark:

SELECT *

FROM Ordrer

WHERE Forsendelsesdato = DateValue('10-05-96');

Bemærk! Hvis den kolonne, der refereres til i kriteriestrengen er af typen GUID, anvender kriterieudtrykket en lidt anderledes syntaks:

WHERE Replika-ID = {GUID {12345678-90AB-CDEF-1234-567890ABCDEF}}

Sørg for at medtage de indlejrede parenteser og bindestreger som vist.

Se også
Prædikaterne ALL DISTINCT, DISTINCTROW, TOP (Microsoft Jet SQL) | Handlingerne LEFT JOIN og RIGHT JOIN (Microsoft Jet SQL)
Sætningen DELETE (Microsoft Jet SQL) | Delsætningen ORDER BY (Microsoft Jet SQL)
Delsætningen FROM (Microsoft Jet SQL) | Sætningen SELECT (Microsoft Jet SQL)
Delsætningen GROUP BY (Microsoft Jet SQL) | Sætningen SELECT...INTO (Microsoft Jet SQL)
Delsætningen HAVING (Microsoft Jet SQL) | SQL-aggregatfunktioner (SQL)
Delsætningen IN (Microsoft Jet SQL) | Sætningen UPDATE (Microsoft Jet SQL)
Handlingen INNER JOIN (Microsoft Jet SQL) |

Eksempel

Eksempel på delsætningen WHERE


Eksempel på delsætningen WHERE (DAO)

Eksempel på delsætningen WHERE

I følgende eksempler antages det, at det hypotetiske felt Løn findes i tabellen Medarbejdere. Bemærk, at dette felt faktisk ikke findes i tabellen Medarbejdere i databasen Northwind.

I følgende eksempel udvælges felterne Efternavn og Fornavn i alle de poster, hvor efternavnet er King.

I følgende eksempel kaldes proceduren EnumFields, som du finder i eksemplet på sætningen SELECT.

Sub WhereX()

    Dim dbs As Database, rst As Recordset

    ' Rediger denne linje for at angive stien til

    ' Northwind på computeren.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Udvælg de poster i tabellen Medarbejdere, hvor

    ' Efternavn er King.

    Set rst = dbs.OpenRecordset("SELECT Efternavn, " _

        & "Fornavn FROM Medarbejdere " _

        & "WHERE Efternavn = 'King';")

    ' Udfyld Recordset-objektet.

    rst.MoveLast

    ' Kald EnumFields for at udskrive indholdet af

    ' Recordset-objektet.

    EnumFields rst, 12

    dbs.Close

End Sub


Erklæringen WITH OWNERACCESS OPTION (Microsoft Jet SQL)

Erklæringen WITH OWNERACCESS OPTION

I et flerbrugermiljø med en sikret arbejdsgruppe skal du bruge denne erklæring sammen med en forespørgsel for at give brugeren, der kører forespørgslen, de samme tilladelser som forespørgslens ejer.

Syntaks

sqlsætning
[WITH OWNERACCESS OPTION]

Bemærkninger

Erklæringen WITH OWNERACCESS OPTION er valgfri.

I følgende eksempel får brugeren mulighed for at vise lønoplysninger (selv om brugeren i øvrigt ikke har tilladelse til at se tabellen Løn), forudsat at forespørgslens ejer ikke har den pågældende tilladelse:

SELECT Efternavn,

Fornavn, Løn

FROM Medarbejdere

ORDER BY Efternavn

WITH OWNERACCESS OPTION;

Hvis en bruger på anden vis er forhindret i at oprette eller tilføje i en tabel, du kan anvende WITH OWNERACCESS OPTION til at gøre det muligt for brugeren at køre en tabeloprettelses- eller tilføjelsesforespørgsel.

Hvis du vil gennemtvinge sikkerhedsindstillinger for arbejdsgrupper og brugertilladelser, skal du ikke medtage erklæringen WITH OWNERACCESS OPTION.

Denne indstilling kræver, at du har adgang til filen System.mdw, der er forbundet med databasen. Den er kun nyttig i sikrede flerbrugerimplementeringer.

Se også

Sætningen SELECT (Microsoft Jet SQL)


Nyheder i forbindelse med DLL (Data Definition Language)

Microsoft® Jet version 4.x har nye og forbedrede sætninger til DLL.

Yderligere oplysninger om disse sætninger finder du under:

Sætningen ALTER TABLE | Sætningen CREATE USER eller GROUP
Delsætningen CONSTRAINT | Sætningen ADD USER
Sætningen CREATE PROCEDURE | Sætningen DROP USER eller GROUP
Sætningen CREATE TABLE | Sætningen ALTER USER eller DATABASE
Sætningen CREATE VIEW | Sætningen GRANT
Sætningen DROP | Sætningen REVOKE

Se også
Oversigt over nyheder | Nyheder til Indstillinger i Windows-registreringsdatasen
Nyheder i forbindelse med Data Manipulation Language |


Nyheder i forbindelse med Data Manipulation Language

Microsoft® Jet version 4.x har nye og forbedrede sætninger til DLL.

Yderligere oplysninger om disse sætninger finder du under:

Sætningen EXECUTE | Sætningen TRANSACTION
Delsætningen PROCEDURE |

Se også
Oversigt over nyheder | Nyheder til Indstillinger i Windows-registreringsdatasen
Nyheder i forbindelse med DLL (Data Definition Language) |


Oversigt over Nyheder

Microsoft® Jet version 4.x har mange nye funktioner, herunder flere SQL-reserverede ord, SQL-datatyper og ODBC-skalærfunktioner. Der er nu flere oplysninger, der sammenligner SQL med ANSI SQL og flere oplysninger om ækvivalente ANSI SQL-datatyper. ANSI SQL-jokertegn, procenttegnet (%) og understregningstegnet (_) er tilgængeligt med Jet 4.x og Microsoft OLE DB Provider til Jet.

Yderligere oplysninger om disse funktioner finder du under:

SQL-reserverede ord | Sammenligning af Microsoft Jet SQL og ANSI SQL
SQL-datatyper | Ækvivalente ANSI SQL-datatyper
ODBC-skalærfunktioner | Brug af jokertegn i strengsammenligninger

Microsoft Jet 4.x har nye DDL-sætninger (Data Definition Language), nye data manipulation language-sætninger, flere metoder til tilpasning af indstillinger i Microsoft Windows®-registreringsdatabasen, og flere indstillinger til initialisering af databasemotordriveren.

Yderligere oplysninger om disse funktioner finder du under:

Nyheder i forbindelse med DLL (Data Definition Language) | Nyheder til Indstillinger i Windows-registreringsdatasen
Nyheder i forbindelse med Data Manipulation Language |


Nyheder til Indstillinger i Windows-registreringsdatabasen

Microsoft® Jet version 4.x har nu fire metoder til at ændre indstillingerne i Microsoft Windows®-registreringsdatabasen. Udover at du kan anvende Regedit.exe til at overskrive standardindstillinger eller oprette en del i programmets træstruktur til registreringsdatabasen for at styre indstillingerne, kan du også bruge metoden SetOption fra DAO eller tilslutningsegenskaberne i Microsoft OLE DB Provider til Jet.

Du kan få yderligere oplysninger og eksempler på initialiseringsindstillinger til Jet-databasemotoren. Disse indstillinger bruges til at få adgang til Microsoft Access-databaser. Du kan også få oplysninger om Microsoft Jet-replikeringsindstillinger.

Yderligere oplysninger om disse metoder og indstillinger finder du under:

Tilpasning af indstillinger i Windows-registreringsdatabasen til Microsoft Jet Initialisering af Microsoft Jet 4.0-databasemotordriveren

Se også
Oversigt over nyheder | Nyheder i forbindelse med Data Manipulation Language
Nyheder i forbindelse med DLL (Data Definition Language) |


basiscomputer <Jet-definition>

basiscomputer

En computer, der bruges i en stjerneformet topologi. En replika kopieres fra hubserveren og placeres i basiscomputeren. På grundlag af denne replika kan du lave yderligere kopier til andre computere.

Se også
hubserver stjerneformet topologi


konflikttabel <Jet-definition>

konflikttabel

En tabel, der genereres, når der opstår en synkroniseringskonflikt mellem to replikaer. Konflikttabellen vises kun i replikaen med afviste ændringer.


databasereplikering <Jet-definition>

databasereplikering

Reproduktion af en database, så to eller flere kopier (replikaer) af samme database kan forblive synkroniserede. Ændringer i dataene i en replikeret tabel i én replika sendes til og anvendes på de andre replikaer i replikasættet. Ændringer i designet af databasen i masterdesignet sendes til og anvendes i alle replikaer i sættet.


standardsynkroniseringspartner <Jet-definition>

standardsynkroniseringspartner

Et Synchronizer-program, der anvendes til automatisk at synkronisere en replika med andre replikaer i sættet. Når en replika oprettes, vil det Synchronizer-program, der styrer kildereplikaen, være standardsynkroniseringspartner for den nye replika.


standardsynkroniseringsskema <Jet-definition>

standardsynkroniseringsskema

En skabelon, der bruges af et Synchronizer-program til at definere et skema mellem en nyligt vedligeholdt replika og replikaens standardsynkroniseringspartner, når den nyligt vedligeholdte replika ikke indeholder et synkroniseringsskema. Skemaet kan ændres, når det er defineret.


masterdesign <Jet-definition>

masterdesign

En database, hvor der er blevet tilføjet systemtabeller, systemfelter og replikeringsegenskaber. Et masterdesign er første replika i et replikasæt. Du kan kun foretage ændringer i databasestrukturen med masterdesignreplikaen. Replikaer i samme replikasæt kan skiftes til at være masterdesign, men der kan kun være ét masterdesign ad gangen i hvert replikasæt.


mappe til rulleliste <Jet-definition>

mappe til rulleliste

Den delte netværksplacering, hvor et Synchronizer-program kan efterlade eller hente design- og dataændringer.


globalt unikt id (GUID) <Jet-definition>

globalt unikt ID (GUID)

Et 16-byte felt, der bruges til at etablere et unikt id til replikering. GUID'er bruges i vid udstrækning til at identificere replikaer, replikasæt, tabeller, poster og andre objekter.

Bemærk! I Microsoft® Access refereres der til GUID'er som replikerings-id'er.


hubserver <Jet-definition>

hubserver

En computer, der bruges i en stjerneformet topologi. En replika, som findes på denne computer, kan bruges som synkroniseringspartner til andre replikaer.

Se også
basiscomputer | stjerneformet topologi
satellitcomputer |


lokalt objekt <Jet-definition>

lokalt objekt

En tabel eller forespørgsel, der bliver i den replika, hvor den blev oprettet. Hverken objektet eller ændringer i objektet kopieres til andre medlemmer i replikasættet.


vedligeholdte replikaer <Jet-definition>

vedligeholdte replikaer

En replika med et tildelt Synchronizer-program. Synchronizer-programmet leverer ændringer til og modtager ændringer fra andre replikaer i sættet.

Bemærk! Hvis du ikke tildeler et Synchronizer-program til en replika, kan du stadig synkronisere replikaen i programkoden eller ved at bruge et andet Synchronizer-program. Du kan dog ikke angive synkroniseringsskemaer fra denne replika, medmindre du tildeler Synchronizer-programmet en replika.


objektreplikering <Jet-definition>

objektreplikering

Reproduktion af et objekt (en tabel eller en forespørgsel), så to eller flere kopier af samme objekt synkroniseres. Ændringer, der er foretaget i objektets design i masterdesign sendes til og anvendes på alle replikaer i sættet.


synkronisering efter anmodning <Jet-definition>

synkronisering efter anmodning

Udveksling af data mellem to replikaer, der finder sted på brugerens klare anmodning.


replika <Jet-definition>

replika

En kopi af en database, herunder tabellerne, forespørgslerne, formularerne, rapporterne, makroerne og modulerne. En replika er medlem af et replikasæt og kan synkroniseres med andre replikaer i sættet. Ændringer i dataene i en replikeret tabel i én replika sendes til og anvendes på de andre replikaer i sættet.

Bemærk! Masterdesign er også en replika.


replikeret database <Jet-definition>

replikeret database

En database, hvor der er blevet tilføjet ekstra tabeller, felter og egenskaber til at registrere oplysninger om ændringer i data og design til replikerede objekter i databasen.


replikeret objekt <Jet-definition>

replikeret objekt

En tabel eller forespørgsel, der er i alle replikaer i replikasættet. Du kan kun ændre det replikerede objekt i masterdesignet. Disse ændringer udbredes derefter til andre replikaer i replikasættet under en synkronisering.


replikasæt <Jet-definition>

replikasæt

Replikaer, der deler samme databasedesign og samme unikke replikasæt-id. Synkronisering finder sted mellem replikasætmedlemmer.


replikasætmedlem <Jet-definition>

replikasætmedlem

En replika, der tilhører et replikasæt. Replikasætmedlemmer deler samme databasedesign og kan synkroniseres med hinanden.


replikere <Jet-definition>

replikere

Laver en replika eller kopi af noget, f.eks. en database.


replikering <Jet-definition>

replikering

Oprettelse og synkronisering af replikaer på forskellige adresser. Replikering tilføjer systemfelter og -tabeller samt replikeringsegenskaber til en database, så ændringer, der udføres i dataene eller i databasedesignet, sendes til og anvendes på alle medlemmer i replikasættet.


Microsoft Replikastyring <Jet-definition>

Microsoft Replikastyring

Et program med en grafisk brugerflade, der styrer placeringen, synkroniseringsskemaet og relationen i en eller flere replikaer med andre replikaer i sættet. Replikastyring styrer Synchronizer-programmets indstillinger, der styrer replikeringen, mens Synchronizer-programmet udfører de aktuelle synkroniseringer. Replikastyring er en del af Microsoft® Office 97, udviklerversion.


tilbageholdelsesperiode <Jet-definition>

tilbageholdelsesperiode

Det antal dage, systemet tilbageholder visse replikeringssystemoplysninger om en replika. Hvis tilbageholdelsesperioden udløber, før en replika er blevet synkroniseret, mislykkes synkroniseringen.


satellitcomputer <Jet-definition>

satellitcomputer

En computer i en stjerneformet topologi, hvor der ligger en replika. Denne replika er kopieret fra basiscomputeren og synkroniseres som standard med en replika, der ligger på hubserveren.

Se også
basiscomputer | stjerneformet topologi
hubserver |


tidsindstilling <Jet-definition>

tidsindstilling

De tidspunkter, hvor Synchronizer-programmet initierer synkronisering med andre replikaer. Det mindste tidsinterval mellem planlagte synkroniseringer er 15 minutter. Du kan angive forskellige tidsindstillinger mellem to vilkårlige Synchronizer-programmer.


planlagt synkronisering <Jet-definition>

planlagt synkronisering

En udveksling af data mellem to replikaer, der finder sted på et foruddefineret tidspunkt.


delt netværksmappe <Jet-definition>

delt netværksmappe

Se mappe til rulleliste.


stjerneformet topologi <Jet-definition>

stjerneformet topologi

En type organisationskort for netværkscomputere. I forbindelse med replikering refererer den til en hubserver, en basiscomputer og fordelingen af medlemmer af replikationssættet på andre satellitcomputere. Topologien er vigtig, når man fastlægger tidsindstillinger til synkronisering.

Se også
basiscomputer | satellitcomputer
hubserver |


synkroniseringskonflikt <Jet-definition>

synkroniseringskonflikt

En situation, hvor brugerne af to replikaer har ændret den samme post. En af de opdaterede poster vælges som "vinderen", og posten i den "tabende" replika opdateres, så den indeholder disse data. Den anden opdaterede post placeres i en konflikttabel i den tabende replika.


synkroniseringsfejl <Jet-definition>

synkroniseringsfejl

Et problem, der opstår under synkronisering, som forhindrer, at ændringer i en post bliver udført. Dette er mere alvorligt end en konflikt og skal løses så hurtigt som muligt.


synkronisering <Jet-definition>

synkronisering

Opdatering af to replikaer, hvor alle opdaterede poster og objekter udveksles. Udveksling af data mellem to replikaer kan gå én vej eller begge veje og kan styres af et Synchronizer-program.


topologi for replikasæt <Jet-definition>

topologi for replikasæt

Den rækkefølge, som ændringer overføres i fra replika til replika. Topologi er af stor betydning, da den bestemmer, hvor hurtigt ændringer i en anden replika vises i din replika.


Synchronizer <Jet-definition>

Synchronizer

Et program, der overvåger ændringer i en replika og behandler den aktuelle udveksling af data mellem replikaer. Synchronizer-programmet arbejder i baggrunden og vises på proceslinien. I vinduet Synkronisering i Replikastyring kan du se, hvilke Synchronizer-programmer et replikasæt har.

Bemærk! I Den tidligere version af Replikastyring henvistes til Synchronizer-programmer som Transportører.


vinduet Synkronisering <Jet-definition>

vinduet Synkronisering

Det område i Replikastyring, hvor Synchronizer-programmerne vises. Du kan flytte Synchronizer-programmerne og zoom ind eller ud for at vise flere eller færre Synchronizer-programmer. Du kan også klikke på linien mellem to Synchronizer-programmer, hvis du vil redigere deres tidsindstillinger til synkronisering. Hvis du vil vide mere om de forskellige ikoner i vinduet Synkronisering, skal du klikke på Forklaring i menuen Vis.