
YEAR 1.1 HELP INDEX
The Index lists the Help topics available for YEAR. Use the scroll bar to see entries not 
currently visible in the Help window. To learn how to use Help, press F1 or choose Using Help 
from the Help menu.

Introduction
About YEAR 1.1 
What's New... 
Software License and Disclaimer 
How to register 
Shareware concept 
Why register? 

Procedures
Displaying an arbitrary year 
Displaying previous or next year 
Displaying current year 
Calculating Time-Span 
Displaying Day-Info 
Defining display format 
Defining print format 
Defining display fonts 
Defining printer fonts 
Choosing display preferences 
Choosing printer preferences 
Choosing display colors 
Printing calendars 
Configuring the printer 
Permanently saving configuration 
Loading configuration
Defining start-up configuration 
Exiting YEAR 

Commands
File Menu commands 
Show Menu commands 
Options Menu commands 

Keyboard
Program keys 
Windows keys 



About YEAR 1.1

YEAR is a Windows' calendar application that allows you to see the entire year at a glance. 
You can view any Gregorian calendar year from the range 1 to 32767 A.D. in a variety of 
formatting options, including display colors and fonts, which you may select according to 
your taste.

YEAR will also allow you to print hard copies of the year-at-a-glance calendars in your 
favorite selection of printer fonts and formats.

YEAR has also Day-Info and Time-Span features, that allow you to obtain useful information 
about a particular day in a year, and calculate the time-span between any two given dates. 
Simply point and click with the mouse.

See also:
What's new in YEAR 1.1
Software License and Disclaimer
How to register?



What's new in YEAR 1.1:

1. Highligting background and text color, when selecting a day with a mouse, are now user 
definable from Colors submenu under Preferences.

2. A number of cosmetic improvements to the dialog boxes have been made. The 
improvements are more apparent in lower resolutions (CGA, EGA, VGA) rather than 
higher ones.

3. Innumerable changes and improvements have been made in the program's code, not all 
of them readily visible to the user, but resulting in better overall performance and 
reliability.



Shareware Concept

Computer software is intellectual property, requiring large investments in time and money 
while it is being created, and it cannot be freely copied and distributed without 
compensating the author(s) and/or copyright owners.

User Supported Software, or SHAREWARE, is a concept in microcomputer software 
distribution based on the following principles:

1. That the individual user is entitled to judge the value or worth of a 
program by using it first, before (s)he makes the commitment and 
actually buys it.

2. That the creation and distribution of microcomputer software does not 
need to be expensive, if it is directly financially supported by the users.

Free distribution of shareware and voluntary payment for its use eliminate costs of 
advertising and copy protection schemes. Users obtain high quality software at nominal 
cost. They can try it out before buying, an do so in the comfort of their own home or office. 
Thereby, only the best programs survive, based on their quality and usefulness.

While shareware programs are distributed by the users, they are copyrighted software, and 
must be paid for if they are being used. Shareware is NOT free software.

See also:
How to register?
Why register?
Software License and Disclaimer



Software License and Disclaimer

YEAR 1.1 Copyright © 1991 Software Professional.

Users are granted a limited license to make copies of this product for trial use by others. The
limited license does not include:

1. Distributing this program in connection with any other product, unless a 
separate agreement with Software Professional has been negotiated.

2. Distributing the software in modified form.
3. Distributing only parts of this product.

This software is protected by the international copyright laws. Users must register within 14 
days after obtaining a copy of this program. Continued use of this software beyond the 14-
day trial period without registration constitutes a copyright violation.

The license to use this program is effective until terminated. You may terminate this license 
at any time by destroying all copies of this program. It will also be terminated upon failure to
comply with any of the terms or conditions of this agreement.

THIS PROGRAM IS PROVIDED ON "AS IS" BASIS, WITHOUT ANY WARRANTY, EXPRESSED OR 
IMPLIED, INCLUDING, BUT NOT LIMITED TO IMPLIED WARRANTIES OF MERCHANTABILITY AND 
FITNESS FOR ANY PARTICULAR PURPOSE.

IN NO EVENT AND UNDER NO CIRCUMSTANCES WILL SOFTWARE PROFESSIONAL, ITS AGENTS
AND THE AUTHOR OF THIS PROGRAM, BE LIABLE FOR ANY DAMAGES WHATSOEVER, 
INCLUDING WITHOUT LIMITATION DAMAGES FOR LOST PROFITS, LOST SAVINGS, BUSINESS 
INTERRUPTION, LOSS OF BUSINESS INFORMATION AND THE LIKE ARISING OUT OF THE USE 
OR THE INABILITY TO USE THIS PRODUCT, EVEN IF SOFTWARE PROFESSIONAL, OR ITS 
AGENTS, OR THE AUTHOR, HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

Some states do not allow the exclusion or limitation of incidental or consequential damages, 
so the above limitation or exclusion may not apply to you. In no case shall Software 
Professional's liability exceed the license fees paid for the right to use this product.

Any commercial products, brands and trademarks mentioned in this document belong to 
their respective owners.

This statement shall be construed, interpreted, and governed by the laws of the Province of 
Ontario, Canada.

See also:
How to register?
Why register?
Shareware concept



How to register?

YEAR is not copy protected and you are encouraged to copy, and distribute this program, 
subject to the conditions described in the Software License. Please, make sure when 
distributing this product to others, that both the program file YEAR.EXE and the help file 
YEAR.HLP are present.

If you continue to use this program after the 14-day trial period, please remit $20 along with 
the completed Registration Form to:

Software Professional
620 Jarvis St., #2312

Toronto, Ontario M4Y 2R8 Canada

A disk will be sent to you, containing a registered version (please indicate your media format
preference, 3 1/2 or 5 1/4 inch, while registering).

See also:
Why register?



YEAR 1.1 REGISTRATION FORM
Please include the following information with your registration (you may simply print this 
Help topic on a standard 8"1/2 by 11" sheet: select File/Print Topic on the Help menu). Send 
the completed form with $20 license fee (no cash, please) to Software Professional.

______________________________________________________________
Your Name

______________________________________________________________
Organization

______________________________________________________________
Street and No.:

______________________________________________________________
City

______________________________________________________________
Postal/Zip Code

______________________________________________________________
State/Province

______________________________________________________________
Country

______________________________________________________________
How did you obtain your copy of YEAR

______________________________________________________________
Media preference (3"1/2 o 5"1/4) ?

Please, include your suggestions and comments below:

______________________________________________________________

______________________________________________________________

______________________________________________________________

______________________________________________________________

______________________________________________________________

Thank you for supporting the shareware concept!



Why register?

The main reason to purchase any program is because it is ethically correct. Not registering is
an abuse of the shareware concept and in the long run will cause this method of distribution 
to disappear. YEAR, like any other software product, represents a large investment of time 
and money and therefore the author expects compensation if you use YEAR beyond the 14-
day trial period.

The unregistered version is not lacking any features. We trust you and want you to be able 
to appreciate the full value of the program, and facilitate your decision to purchase.

Registering entitles you to continued use of the program, beyond the trial 14-day period. It 
also entitles you to one free upgrade of the software , when it becomes available. Upon 
registering you will receive an upgrade voucher, which you may redeem at any time by 
requesting your free upgrade. You will not receive the upgrade automatically, after 
registering. You must use your voucher to request the upgrade.

See also:
How to register?
Registration Form
Software License and Disclaimer



Displaying a given year

When YEAR first starts, current system year is displayed. You can move to any other year 
within the allowable range 1..32767 by selecting Year from the Show menu, or simply 
pressing Enter.

A dialog box will then be displayed, prompting you to enter the number of the year you wish 
to see. Enter the number, or dial it by pressing the arrows next to the input box, then select 
OK (or press Enter). The year you selected will appear.

See also:
Displaying next/previous year
Displaying current year



Displaying previous or next year

You can easily flip back and forth, from year to year, either using menu selections: Show/Next, 
Show/Prev or keyboard shortcuts: PageDown, PageUp

See also:
Displaying an arbitrary year
Displaying current year



Displaying current year

Press either the key marked Home on your keyboard, or select Current from the Show menu.
The current year, according to your system's date setting, will be displayed. Current day will 
be highlighted.

See also:
Displaying an arbitrary year
Displaying next/previous year
Choosing color of current day highlight



Calculating Time-Span

You can calculate the number of elapsed days and the number of elapsed weeks between 
any two given dates within the range January 1, 1 A.D. and December 31, 32767 A.D.

Simply point and select a date, by clicking on it with the mouse, then move to another date 
and select it too. A dialog box will appear showing the number of days and weeks that these 
two dates span.

The order in which you select the dates is not important. The dates you select do not have to
be in the same year. You may select a date in one year, then flip the display to a different 
year and select the other date.

If you select by clicking on the same date twice (or by double-clicking on a single date) Day-
Info, instead of Time-Span will be displayed.



Displaying Day-Info

You can obtain some useful information about any given date. This information includes 
week number, day number within the year (January 1st in any year is day number 1), and 
the number of days left until the end of the year.

Simply point and double-click with the mouse on a displayed date (anywhere on the 
calendar page).

See also:
Calculating Time-Span



Defining display format

The Options menu gives you access to the color, font and preferences customization for the 
display.

Selecting display colors
Selecting display fonts
Selecting calendar preferences

See also:
Defining print format



Defining print format

The Options submenu gives you access to the font and preferences customization for the 
printer. In addition, under File submenu, there is a printer setup selection (standard Windows
setup dialog for the printer) and print selection.

Selecting printer fonts
Selecting calendar preferences
Printer setup

See also:
Printing calendars
Defining display format



Defining display fonts

Choose Font from the Options menu. "Select Display Font" dialog will apear, allowing you to 
select from a drop-down list of fonts installed on your system, as well as letting you choose 
some other attributes of the font. 

The available heights of bitmapped fonts installed on your system can be displayed by 
opening the pulldown-list under the Width entry-box. If the list is empty, reload the font 
description by deselecting that font, and then selecting it again from the Font list. The empty
list may also indicate a vector (scalable) font, such as TrueType font introduced with 
Windows 3.1, in which case you can enter any number in the Height field. 

You don't have to select a suggested height from the list: you may enter any number 
manually and Windows will scale the font or supply the closest matching one.

Enter width of 0 (or press button marked -) to select default character width for the font. If 
you enter a non-zero width, Windows will scale or supply the closest matching font.

Windows fonts belong to one of the three character sets: ANSI (default), Symbol, and OEM. 
You can choose the character set by selecting one of the radio buttons near the bottom of 
the dialog.

To switch to defining printer fonts while the Select Display Font dialog is open, press Printer 
button near the bottom of the dialog-box.

See also:
Selecting display colors



Defining printer fonts

Choose Font from the Options menu. "Select Display Font" dialog will appear. Press Printer 
button at the bottom of the dialog and the title of the dialog will change to "Select Printer 
Font". The Font entry will now contain a drop-down list of fonts available on your printer. 

The available heights of bit-mapped fonts installed by your printer can be displayed by 
opening the pulldown-list under the width entry-box. If the list is empty, reload the font 
description by deselecting that font, and then selecting it again from the Font list. The empty
list may also indicate a vector (scalable) font, such as PostScript font available if you have a 
PostScript printer, in which case you can enter any number in the Height field. 

You don't have to select a suggested height from the list: you may enter any number 
manually and Windows will scale the font or supply the closest matching one.

Enter width of 0 (or press button marked -) to select default character width for the font. If 
you enter a non-zero width, Windows will scale or supply the closest matching font.

Windows fonts belong to one of the three character sets: ANSI (default), Symbol, and OEM. 
You can choose the character set by selecting one of the radio buttons near the bottom of 
the dialog.

To switch to defining display fonts while the Select Printer Font dialog is open, press Display 
button near the bottom of the dialog-box.

See also:
Printing calendars



Choosing display colors

Select Color from the Options menu. A submenu with the following entries will appear:

Window
Month
Weekdays
Days
Today
Today's Box
HighText
High Background

Restore Default

Each of these entries, except the last one, corresponds to a display element. If you select 
one of these entries, except the last one, the color dialog box will appear, letting you adjust 
the color of the corresponding display element.



Color Dialog

The "Select Color" dialog allows you to change the color of a display element. You can adjust
colors by manually entering the RGB values for red, green, and blue component of the color 
respectively. Alternatively, you may use the slide-dials to adjust the RGB values.

Choosing colors



Window Color
The background color of the program window. In the default 
configuration, it is the window background color set with the 
Control Panel.



Month Color
The color in which the name of the month is displayed. In the 
default configuration, it is the window text color which you can 
set with the Control Panel.



Weekdays Color
The color in which the day-of-the-week labels are displayed. In 
the default configuration, it is the window text color which you 
can set with the Control Panel.



Days Color
The color in which the days of the month are displayed. In the 
default configuration, it is the window text color which you can 
set with the Control Panel.



Today Color
The color in which the today's date is displayed. In the default 
configuration, it is the highlighted text color which you can set 
with the Control Panel.



Today's Box Color
The color in which the box highlighting the current date is 
displayed. In the default configuration, it is the highlight color 
which you can set with the Control Panel.



Today's Box Color
The color in which the selected date is displayed. In the default 
configuration, this color is equivalent to the window caption's 
text color, which you can set with the Control Panel.



High Text Color
The color in which the box highlighting the selected date is 
displayed. In the default configuration, it is the window 
caption's background color which you can set with the Control 
Panel.



Restore Default Colors
Selecting Restore Default, will reset the color settings for all 
display elements to their default values. These defaults are 
related to your Windows-wide system colors, that you selected, 
for example, using Control Panel.



Printing calendars

To print a year-at-a-glance calendar, or a range of calendars, select Print from the File menu. 
A Print dialog box will appear allowing you to change the number of copies, and printing 
options.

You can print either: 

1. The currently displayed year
2. The current year, no matter which year is currently displayed
3. A range of years. You must enter the full number of the starting and ending 

year.

Press Ok to begin printing, Cancel to exit the dialog without printing anything.



Configuring the printer

This standard printer setup dialog box is the same as the one you activate from Control 
Panel. It allows you to change settings for the currently selected printer.

See also:
Printing calendars



Choosing display preferences

Select Preferences from the Options menu to open Display Preferences dialog box. This 
dialog allows you to set a number of parameters defining the appearance of the calendar on 
screen. 

The parameters you can define include:

Top Margin
Left Margin
Month-Column Gaps
Day-Column Gaps
Month Name Row Gaps
Week Row Gaps
Whole Month Row Gaps
Day Row Gaps
Number of Month-Columns
Upper Case

Press Printer button to set the Printer Preferences.



Choosing printer preferences

Select Preferences from the Options menu to open Display Preferences dialog box. Then 
press Printer button. The title of the dialog changes to Printer Preferences. This dialog allows 
you to set a number of parameters defining the appearance of the calendar when it is 
printed. 

The parameters you can define include:

Top Margin
Left Margin
Month-Column Gaps
Day-Column Gaps
Month Name Row Gaps
Week Row Gaps
Whole Month Row Gaps
Day Row Gaps
Number of Month-Columns
Upper Case

Press Display button to return to the Display Preferences dialog.



Top Margin
The distance between the top of the page (window client area) 
and the first row of data, expressed in device units (pixels).



Left Margin
The distance between the left edge of the page (window client 
area) and the calendar text, expressed in the device units 
(pixels).



Month-Column Gaps
The number of device units (pixels) between adjacent month-
columns.



Day-Column Gaps
The number of device units (pixels) between the adjacent day-
columns within a month.



Month Name Row Gaps
The number of device units (pixels) between the month names 
and the week-day labels.



Week Row Gaps
The number of device units (pixels) between the week-day 
labels and the first row of days within a month.



Whole Month Row Gaps
The number of device units (pixels) between the adjacent rows 
of entire months.



Day Row Gaps
The number of device units (pixels) between the adjacent 
weekly rows, i.e. rows of days within a month.



Number of Month-Columns
The number of columns in which the year will be displayed. 
Values may range from 1 to 12.



Upper Case
Month names and week-day labels can be displayed/printed in 
either mixed, or all-uppercase, depending on the state of the 
two check-boxes.



Permanently saving configuration

You can save the calendar configuration in a configuration file by selecting Save from the 
Options menu. A standard "Save As" file dialog box will appear allowing you to enter the 
name of the configuration file. Press OK to save the configuration, after choosing suitable file
name.

See also:
Loading configuration
Defining start-up configuration



Loading calendar configuration from disk

Select Load from Options menu to load a calendar configuration file. A "File Open" dialog will
appear allowing you to find and select a filename. Press Ok to load the configuration. The 
display and the printer settings will change according to the contents of the configuration 
file.

See also:
Saving configuration
Defining start-up configuration



Defining start-up configuration

YEAR searches for its initialization file (YEAR.INI) in the Windows directory. This file contains 
the "configuration=" entry in its [YEAR1.1] section telling the program which of the saved 
configuration files is to be used as the default. For example,

[YEAR 1.1]
configuration=c:\calendar\year1.yer

tells the program to use c:\calendar\year1.yer as its default configuration file. If there is no 
YEAR.INI, or the configuration entry in the [YEAR 1.1] section is blank, default configuration 
will be used.

YEAR will remember your last configuration file used, if any (it will automatically update the 
configuration= entry of YEAR.INI), so that it will be reloaded automatically on start-up the 
next time you invoke YEAR.

See also:
Saving configuration
Loading configuration



Configuration File
The program configuration i.e. display colors, and both display 
and printer fonts and preferences, may be permanently saved 
for later recall in a configuration file. The configuration files for 
YEAR are binary files with a default extension of *.YER.



Exiting YEAR

To exit program, choose one of the following methods:

1. Select Exit from the File menu.
2. Press Alt-X keyboard shortcut directly.



File Menu Commands

Print
Printer setup
Exit



Show Menu Commands

Prev
Next
Current
Year



Options Menu Commands

Font
Preferences
Color
Load
Save



Program Keys

PgDn Show next year
PgUp Show previous year
Home Show current year
Enter Show an arbitrary year
Esc Clear any selection

Alt+X Exit program



Windows Keys

Alt+Esc Next application 
Alt+Shift+Esc Previous application
Alt+Tab Next windowed application
Alt+Shift+Tab Previous windowed application
Ctrl+Esc Display the Task List



Gregorian Calendar

So called reformed calendar, the way we know it today, was introduced by Pope George XIII 
in 1582. It replaced the earlier Julian calendar (named after Julius Caesar), in which after 
every three years of 365 days, there was a leap year, of 366 days.

In gregorian calendar, normal year also has 365, leap year 366 days, and there is also a leap
year every four years, namely every year whose number is divisible by four. However, the 
years at the turn of a century, such as 1700, 1800, 1900, 2000, etc., even though their 
numbers are divisibl by four, are leap only every four centuries, i.e. year 1600 was leap, 
while 1700, 1800, and 1900 were not. However, year 2000 will be leap again.



Week Standards

Every week in a year has a unique sequence number designated by the international (ISO) 
standard. The first week of any year that contains at least 4 days of that new year, is week 
number 1.

According to the ISO rules, Monday is the first day of the week.




