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Introduction
AIR Mosaic™ is a sophisticated graphical Internet browsing application, allowing you to access the Internet 
World Wide Web.  World Wide Web (also referred to as WWW, W3, or the Web) is what is known as a 
hypermedia environment on the Internet.  You can browse World Wide Web information by merely pointing and 
clicking (similar to using a CD-ROM based reference tool)--you can view pictures or movies, play sounds, read 
documents, and copy files to your PC.  

AIR Mosaic is designed to be the optimal tool for browsing the World Wide Web.  Developed from NCSA's 
(National Center for Supercomputing Applications) original Mosaic application, it has been updated to 
incorporate more Windows functionality and to be easy to configure and customize.

AIR Mosaic features hotlists and advanced menu support, allowing you to incorporate your own Internet “finds” 
into Mosaic and quickly jump to the information you want to access.  Fonts, colors, and performance are easily 
configured using one integrated screen.

Features

•  Advanced Hotlist capability allowing you to add WWW documents into Hotlists with folders and 
subfolders, and easily add multiple Hotlists to your AIR Mosaic menu for quick access. (Also allows you 
to import NCSA menus).

•  Configure Mosaic preferences (colors, fonts, default home page), viewers, and options via a straight-
forward Configuration dialog.  Advanced Viewers dialog allows you to easily change viewers or add new 
ones.

•  Kiosk mode allows you to hide the Toolbar and other information.  Ideal for presentations, it also allows 
you to set up AIR Mosaic for “unattended” use.

•  Customizable caching feature: quickly access documents you've already browsed in the session.

•  Easily connect to the last World Web sites you accessed, via a drop down History list or Document 
Title/Document URL list.

•  Search for keywords in any document you are browsing.

•  Support for Proxy servers for http, WAIS, ftp, and gopher.

•  Print WWW document text and graphics.

•  Save, edit, or copy HTML document source code.

•  Support for dragging and dropping Mosaic documents to other Windows applications.

•  Support for inline GIF and JPEG graphics.

•  Control over screen redraw options.

•  News posting and threading options.

What is the World Wide Web?
The World Wide Web is an “environment” on the Internet that presents a variety of information to you that is 
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easy to browse and use.  AIR Mosaic makes it easy to access this vast and complex environment.  When you 
browse the World Wide Web, you do not have to know exactly where the information you find is located, or what 
type of information it is' because all you need to do is point and click..

When people talk about the World Wide Web, they are often referring to HTML documents located on the 
Internet.  HTML (Hypertext Markup Language) documents, also referred to as home pages, attractively display 
information (text and graphics) and allow you easy access to other documents across the Internet.

The collection of WWW home pages available on the Internet, as well as other Internet resources such as ftp, 
gopher and news is constantly growing.  The World Wide Web environment was designed to incorporate a great 
many resources, so information is interlinked (hence, a Web).  Therefore, you can click on an item on a home 
page to access an ftp server or gopher server, or another home page.

An interesting example of the power of the power and functionality of the World Wide Web is the SPRY technical 
support HTML page. This page includes jumps to information about all SPRY products, including AIR Mosaic. 
When you've found the answer to your question, you may read it in screen or request that it be sent to you via e-
mail or fax. This page represents the leading edge of Web technology, combining information and service in one 
location. 

Many home pages on the Web contain links to other locations. Because of this, the amount and scope of the 
information you can find using AIR Mosaic is quite impressive.

_____________________________________________________________________________________
Starting AIR Mosaic
Although there are thousands of Mosaic sites on the Internet that you can explore, you may not know where to 
start.  AIR Mosaic comes pre-configured with a World Wide Web home page.  This is done so that you have a 
place to start looking for other WWW resources.  

When you start AIR Mosaic, it will automatically connect you to the pre-configured home page.  From there, you 
can begin browsing the Internet and begin connecting to other home pages.  As you become an experienced 
browser, you'll be able to build a library of home pages that you like, using AIR Mosaic's “hotlist” feature.

Start AIR Mosaic by double-clicking on the AIR Mosaic icon.  AIR Mosaic will immediately start connecting 
you to the home page, by dialing up your service provider access number  (You will see the radar logo in the 
upper right hand corner of the AIR Mosaic console spinning as the home page is retrieved.)

Once you finish connecting to the default home page, you can immediately begin browsing with Mosaic by 
clicking on Mosaic hyperlinks, as described in the next section.

You can easily define your own home page to automatically connect to on startup.  Use the Configuration option in 
the Options menu to set up a default home page.  See “Configuring AIR Mosaic Options” later in this document for 
more information.

Exiting Mosaic
You can exit AIR Mosaic by choosing Exit from the File menu.  You can also double-click on the Windows 
System Menu to exit AIR Mosaic.

If you are currently retrieving a new Mosaic document, it is recommended that you wait to exit until that 
document is retrieved, or stop retrieving the document by clicking the Stop button or choosing Cancel 
Current Task from the History menu.

_____________________________________________________________________________________
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The AIR Mosaic Console
The AIR Mosaic Console is described below.

The Toolbar at the top of the Console contains buttons that serve as shortcuts for AIR Mosaic menu items.  The 
Toolbar style can be changed between Picture & Text, Picture only, and Text only by choosing Toolbar Style 
from the Options menu.  

The Status Bar at the bottom of the Console displays the locations of resources you connect to, and indicates 
when a transfer is in progress or a graphic is being loaded. 

Both the Toolbar and the Status Bar can be shown or hidden by checking or unchecking Show Status Bar or 
Show Toolbar using the Configuration option in the Options menu.

Below the Toolbar is the Document Title Bar, containing the Document Title and Document URL (Uniform 
Resource Locator) drop down lists.  The two lists contain a record of the last several documents you've accessed.  
The lists are identical, but one shows the Title of the document (such as “Wired Magazine's Rest Stop on the 
InfoBahn”) and the other shows that document's URL (http://www.wired.com).  You can go back to any of the 
displayed documents by choosing its title or URL from the lists.  You can change the number of documents that 
are displayed in these lists using the Configuration option in the Options menu.

The Document Title Bar also contains the radar retrieval icon.  This icon moves when a document is being 
loaded or a graphic is being transferred (roughly, it indicates that AIR Mosaic is busy.)  You can disable the 
animation of this icon by unchecking Animate logo using the Configuration option in the Options menu. It's 
generally a good idea to keep the icon animation functional, because this way you'll know when AIR Mosaic is 
transferring data. The icon's motion assures you that your system and AIR Mosaic are still working properly.

Using Kiosk Mode
Kiosk Mode is available with AIR Mosaic; you can hide all the Console information except the actual document 
(in other words, the Toolbar, Status Bar, and Document Title Bar and the menu items and commands will be 
hidden).  This may be useful to use when giving Mosaic presentations or when setting up Mosaic on an 
unattended workstation.

•Click the Kiosk button on the Toolbar, or choose Kiosk Mode from the Options menu.  AIR Mosaic will 
change into Kiosk Mode.

•You can move around in Mosaic as you would normally, except that the Toolbar buttons and menu options 
are not available to you.

Note that the shortcut movement keys of F (for Forward) and B (for Back) will be very helpful to you to
move when in this mode, since the Forward and Back commands are not available.

Press the Esc key or Ctrl-K to exit Kiosk mode.

______________________________________________________________________________

Browsing with AIR Mosaic
World Wide Web uses hyperlinks (also referred to as anchors or hot spots) to allow you to jump to other 
resources.  Hyperlinks are indicated by blue, underlined text, or by graphics surrounded by a blue border (you can
change the color that is used, see Configuring AIR Mosaic Options, later in this documentation, for more details).  
Another way to tell that you are on a hyperlink is to place the mouse pointer over the text.  The arrow will turn 
into a pointing hand, and information about the hyperlink URL (Uniform Resource Locator) will appear in the 
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Status Bar at the bottom of the AIR Mosaic window.  This URL information tells you where the resource you are 
highlighting is located and provides additional information about the resource.  See “Understanding URLs” for 
more information.

You can click on a hyperlink to connect to another Mosaic document.  The new document will be opened (you 
will see the radar indicator in the upper right hand corner of your AIR Mosaic Console begin to spin).  If at any 
time you need to stop loading in a document, you can click the Stop button or choose Cancel Current Task from 
the Navigate menu.

You can continue to browse through WWW documents by simply clicking on the hyperlinks you find in the 
document.  You can also travel through documents you encounter as described below.

Jumping Back and Forward
You can click on the Back button (the third button on the Toolbar) to move back to the last document you viewed.
The Forward button (the fourth button on the Toolbar) can move you forward after you have moved back.  You 
can also type B for Back or F for Forward, or choose Back or Forward from the Navigate menu.

Opening Previous Documents
The Document Title: and Document URL: drop-down lists, under the Toolbar, contain a listing of the last 
several documents you've accessed.  The lists are identical, but one shows the title of the document (such as 
“GNN Home”) and the other shows that document's URL (http://nearnet.gnn.com/gnn.html).  You can go back to 
any of the displayed documents by choosing its title or URL from the lists.

You can also click History to access the History dialog.  The History dialog allows you to access documents 
you've already accessed in this session.  This is equivalent to using the drop down lists, above.  Select the 
document you want to go back to, and click on the Load button.

At any time, you can click the Home button on the Toolbar, or choose Home from the Navigate menu to return to
the document defined as your Home Page.  When you start using Mosaic, a home page is defined as your default 
home page; you can set up a new home page (or set AIR Mosaic to start without opening a home page) using 
Configuration in the Options menu.

You can reload the current WWW document at any time by clicking the Reload button or choosing Reload from 
the Navigate menu.  You might want to do this if the document did not load properly.

Accessing HTTP /0.9 Documents
Some older WWW documents may require you to use an earlier version of the Transfer Protocol, HTTP /0.9 to 
access them.  In most cases, the hyperlinks to those documents will warn you that HTTP /0.9 is required to read 
them.  Check HTTP/0.9 in the Options menu to read these older documents.

______________________________________________________________________________

Using Hotlists
One of AIR Mosaic's strongest features is its ability to organize the information that you find on the World Wide 
Web.  There are so many documents out there with useful jumps to resources you might be interested in, that it is 
common to want to access these documents again and again.  You can save these documents and open them again 
later (see “Saving Documents in Mosaic” later in this chapter), but AIR Mosaic provides an easier way to re-
access documents.

AIR Mosaic's Hotlists can be used to remember WWW document locations, so that you can easily locate and 
access them.  You can group Hotlists by subject (Games, Sports, Weather, Fun Stuff) or by any other criteria (if 
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several people use one computer, they might each have their own hotlist).  

Hotlists you create can then be accessed two ways:  they can be accessed with a couple of mouse clicks from the 
convenient Hotlists dialog, or you can make Hotlists into drop-down menus, so that you can choose them 
directly from the AIR Mosaic menu bar.

NCSA Mosaic users:  You can convert any menus you created in NCSA Mosaic to Hotlists.  See the end of this 
section for information.

The Hotlists Dialog
You work with Hotlists in the <Hotlists> dialog, (accessed by pressing the Hotlists button or by choosing Hotlists
in the File menu).  The <Hotlists> dialog will show all the different Hotlists you have.  AIR Mosaic comes with 
several Hotlists pre-loaded.  You can remove any of the provided hotlists, or add additional Hotlists of your own.

The Hotlist icon in the <Hotlists> dialog appears as a burning document (you'll understand when you see it). 
Initially, Hotlists may be shown closed; you can open up (expand) the Hotlist by double-clicking on the Hotlist 
icon.  Each Hotlist can contain many WWW documents, or it can contain folders that contain additional 
documents (you can use folders and subfolders to organize your documents in any way you want).  You will see 
the documents and folders listed in a hierarchy similar to the Windows File Manager.

 
In the <Hotlists> dialog, you can create new Hotlists, add new Hotlist items, edit your existing items, or delete 
them.  

You can check Use Hotlist as menu item to have a Hotlist added as a menu item.  When you choose this option, 
the Hotlist icon in the <Hotlists> dialog will change to a dialog containing the letter H.  If you add a Hotlist as a 
menu item, any folders within that Hotlist will appear as menu items that have sub-menu items beneath them.

Creating a New Hotlist
Choose Hotlists from the File menu, or click the Hotlist button on the Toolbar.  The <Hotlists> dialog, described 
earlier, will appear.

Click the New/Open button.  You will see a Windows file open dialog.  (You could specify the name of an 
existing hotlist at this point, if you already have a hotlist on your hard drive, to open and load it into the 
<Hotlists> dialog.)

Choose a filename for your Hotlist, and click OK.  This must be a legal DOS filename (using up 
to 8 characters, with the extension .hot).

The next dialog asks you to specify a name for this Hotlist.  This can be any name you want (keep in mind that 
you may want to use this hotlist as a Mosaic menu, so you should keep the name short.)  Type a name, and click 
OK.

The Hotlist will be created, and you will see it appear in the Hotlists dialog (as a “flaming” document).

As mentioned earlier, you may want to create folders and subfolders to help organize your information.  To do 
this, click Add and specify Folder in the dialog that appears.  (To create a subfolder, first highlight the folder you 
want to add a subfolder to).  You will be asked to name the folder.  Give a name for the folder and click OK; the 
folder will be created.
Now that you have a Hotlist, you can begin to add documents to it.

Adding a Document to a Hotlist
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There are two ways to add documents to a Hotlist:

•Add the document to a Hotlist when you are viewing it.
•Add the document to a Hotlist manually.

The first option is easiest, since you will not have to know or remember the document's URL (the document's 
“address”, described in the next section) to add it to a Hotlist.  These two options are described below.

Add the current document to a Hotlist:
In Mosaic, display the document that you want to add to a Hotlist.  You could do this by jumping to it from 
another document, or opening it directly using its URL (as described in the section "Opening Documents Using 
URL's").

You now have two ways to add the document to a Hotlist: 

•Clicking Add Document to Hotlist in the Navigate menu will add the document to the current Hotlist--
this will be the last Hotlist you selected.  Open the <Hotlists> dialog if you are not sure which Hotlist is 
currently selected.  If no Hotlist is selected, this command may not work properly.

•Using the Hotlists screen, as described below, will allow you to specify exactly where you want to add 
the document.

Click the Hotlist button, or choose Hotlist from the File menu.  You will see the <Hotlists> dialog.

Select the Hotlist (or Hotlist subfolder) to which you want to add the current document.
Click Add.  You will be asked whether you want to add a document or folder; select Document.  You will see
the <Add Document> dialog.  This should contain the Name and URL of the document you are currently 
viewing.  If you wish, you can change the name of the document.  Do not change the URL!

Click OK.  The document will be added to the Hotlist you selected.

Adding a document to a Hotlist manually:
You would do this if you want to add a document to a Hotlist, but do not currently have the document open.  To 
do this, you need to know the URL (address) for each document; URLs are described in more detail in the next 
section.  For instance, someone may give you a list of WWW documents containing travel information.  You can 
create a Travel Hotlist, and add all the documents to it quickly--a one step process.  You would do this as follows.

Click the Hotlist button, or choose Hotlist from the File menu.  You will see the <Hotlists> dialog.

Select the Hotlist to which you want to add a document by highlighting it with the mouse pointer
.
Click Add.  You will be asked whether you want to add a document or folder; select Document.  You will see
the <Add Document> dialog.  If you currently have a document open, the information about that document 
will appear in this dialog.  To add a different document to this Hotlist, you must type in the Name and URL of
the document.  

For the Document name:, type any name you want.  It should be a name that will help you recognize this 
URL.

For the Document URL: field, type the Document's URL.  See the section "Opening Documents Using 
URL's" for more information on using URLs.

Click OK.  The document will be added to the Hotlist you selected.

8 mosaic.wri1.17.95



Exporting Hotlists
You can, if you choose, export any of your Hotlists as an HTML file (i.e. a Mosaic-format document).  This 
feature might be useful if, for example, you have compiled a hotlist with an interesting collection of Mosaic home
pages, and want to put it up on a World Wide Web server for others to access.  Or you may find it handy to use the
Hotlist as your default home page, so that you immediately have a list of your favorite resources available when 
you start Mosaic.

You export a hotlist by clicking the Export button in the <Hotlists> dialog.  This dialog prompts you for a name 
and location for the HTML file.  Select the directory you want for the file, and assign a name to the file.  The file 
will be saved with the extension .htm by default.

After you export the file, you can open the file by using the File Open command.  Your Hotlist will be displayed 
as a Mosaic document which resembles your hotlist and contains hyperlink jumps for documents in your hotlist.

Importing NCSA Menus as Hotlists
If you previously used NCSA's Mosaic (by the National Center of Supercomputing Applications), you may have 
built up extensive menus of favorite home pages and resources; AIR Mosaic allows you to convert these menus to
AIR Mosaic Hotlists so that you can use them just as you would Hotlists created in AIR Mosaic.  

To import an NCSA menu as a Hotlist:
Click Import NCSA Menu as Hotlist in the Options menu.  You will see the <Import NCSA Menu as Hotlist> 
dialog.

In the dialog's INI file to import from field, you should specify the name and location of the MOSAIC.INI file 
where your NCSA menu information is stored.  You can click the Browse button to browse the directories on your
PC and select the correct file.  Once you've selected the file, you can confirm that it is the correct file you want by
clicking the Open button.

You should then specify a Hotlist file for this menu.  Do not choose an existing Hotlist unless you want to 
overwrite the information in that file.  Again, you can use Browse to find a Hotlist file and a directory for the 
file.

Last, you should specify which menus from that NCSA MOSAIC.INI file you want to import (all of the menus 
identified in that file should appear in a list).  Click OK when you're ready to import the file.

The next time you open the <Hotlists> dialog, the menu(s) you imported should be displayed.  
You can add them as menu items, if you like, using the Put this Hotlist in the menu bar command, as described 
earlier.

_____________________________________________________________________________

Opening Local HTML Documents
You may need to open a local HTML file at some point.  A local HTML file is a file on your PC containing HTML
code.  This could be a Mosaic document that you saved using the Document Source command, or a Mosaic 
document that someone wrote and gave to you.  A Local File usually has extension .htm.  

You can open a local file by choosing Open Local File in the File menu or clicking the Open button on the 
Toolbar. A file open dialog will appear, displaying any files in the current directory with extension .htm.  Specify 
the name and path for the local file, and click OK.  AIR Mosaic will try to open the file you specified.
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______________________________________________________________________________

Opening Documents using URLs
Mosaic locates documents by using URLs, Uniform Resource Locators.  URLs are a standard notation for WWW
resources, designed to be able to identify information stored on a variety of machines, in a variety of different 
ways. A URL can point to resources such as an HTML document (a WWW home page), an ftp server, a gopher 
server, or a local document.  When you access a document in AIR Mosaic, you will see the URL for that 
document shown in the Document URL: field  displayed below the AIR Mosaic Toolbar.

If you know a document's URL (Uniform Resource Locator; a standard “address” for WWW documents), you can
access a document directly by typing the document's URL.  If someone tells you the URL of a popular WWW site
on the Internet, you can go to it directly using that URL.  You will also need to know a document's URL to set it 
up in a Hotlist or as a default home page.  Opening documents using their URLs is described below.

If you know the URL of a resource, you can access it directly, as described below.

1) Click Open URL in the File menu  You will see the <Open URL> dialog..

The most common URL you will specify in the <Open URL> dialog is the URL for an HTML home page.  
This is always preceded by http:// followed by the address of the HTML document, i.e. 

http://www.bakerstreet.com/221B.html

2) Type the URL you want to connect to and click OK.  If the URL is valid, AIR Mosaic should begin 
connecting to it.

Understanding URLs
URLs typically provide information about a resource type, location, and path.  
You might find a document called “Internet Web Text” with a URL of

http://www.rpi.edu/Internet/Guides/decemj/text.html

This URL can be deciphered as follows:

http: //www.rpi.edu /Internet/Guides/decemj/text.html

or, roughly,

Resource Type    //Resource Location    /Pathname

These three portions are described below.

Resource Type
The Resource Type tells you the type of server on which the resource resides.  The resource type is actually the 
kind of protocol will be used when retrieving the document.
WWW resource types and formats include:

http://         HTTP (HyperText Transfer Protocol) Server.  This is a site designed principally for hypertext WWW 
documents.

ftp://           FTP (File Transfer Protocol) Server.
file://          Local HTML File (also sometimes used to denote FTP Servers).
telnet://     Telnet Server. This format is not directly supported by AIR Mosaic, although AIR Mosaic can be 
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configured for it by adding a telnet application as a viewer. See the section on Viewers for more 
detail.

gopher://   Gopher Server.
wais://       WAIS Server (not directly supported in AIR Mosaic).
news:        USENET news group.

The news: URL uses a slightly different format; it takes the format news:newsgroup.name, since you already have a
news server defined in Mosaic (using the <Configuration> option).

Resource Location
This is the Internet address of the machine where the resource resides.

In the example above, www.rpi.edu is the World Wide Web server at Rensselaer Polytechnic Institute, a school in
Troy, New York.  Note that often you will not be able to figure out exactly where a resource is located.

Pathname {filename}
In most cases, the URL for a document or other resource contains a full pathname for the file.  If you're familiar 
with DOS or UNIX pathnames,  the path in a URLis very similar.  (Paths in WWW always use the forward slash
/).

In the example above, the path is /Internet/Guides/Decemj/.  If you're looking at the resource, you see that it is 
titled Internet Web Text, by John December.  You might infer that this is John December's personal directory on 
the Rensselaer Polytechnic Institute WWW server.

Some sample URLs are shown below:

http://www.rpi.edu/Internet/Guides/decemj/text.html
ftp://ftp.circe.com
file://localhost/c:/mosdocs/sample.htm
telnet://odysseus.circe.com:70
gopher://spinaltap.micro.umn.edu:70/11/fun/Movies
news:alt.tv.seinfeld

For advanced information on URLs, a URL primer is available from NCSA on the NCSA home page, at 
http://www.ncsa.uiuc.edu/demoweb/url-primer.html.

_____________________________________________________________________________________

Accessing FTP, Gopher, News, and Mail
Although you may navigate principally between HTML documents ("home pages") when 
using AIR Mosaic, you can also use it to access other Internet resources such as ftp and 
gopher sites and USENET news.  The functionality of AIR Mosaic as an ftp, gopher, or news 
browser is somewhat limited, since the World Wide Web protocols used are not very 
sophisticated.  For full-featured use of ftp, gopher, and news, more sophisticated 
applications are recommended, such as those available in Internet In A Box.  You can also 
use Mosaic to send mail.

FTP Using Mosaic
You may find hyperlinks to ftp (file transfer protocol) sites when you're using AIR Mosaic, or
you can connect to a site directly if you know its URL (address).  AIR Mosaic incorporates 
ftp functionality and can be used to browse and retrieve files.  Some background on using 
ftp may be helpful to you in understanding how ftp works.
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The ftp site will be displayed in a hierarchical folder format in the AIR Mosaic Console.  You 
will only see two types of items, folders (directories) and files.  You can navigate through 
folders by double-clicking on them to move deeper into the folders; if you want to move 
back, click on the up arrow shown at the top of the folder list.  When you double-click on 
the name of a file, AIR Mosaic will automatically download (copy) the file to your \ ... \DATA
directory, using the displayed filename.

Gopher Using Mosaic
You may find hyperlinks to gopher sites when you're using AIR Mosaic, or you can connect 
to a site directly if you know its URL (address).  AIR Mosaic incorporates gopher 
functionality and can be used to browse and use gopher links.  Some background on using 
gopher may be helpful to you in understanding how gopher works.

The gopher site will be displayed in a hierarchical file format in the AIR Mosaic Console.  
You will see folders (directories), and several different types of items: files such as image 
files, sound files, and applications; database search tools; links to telnet and 3270 sites.  
Double-clicking on a file in gopher will either download it to your \ ... \DATA directory or will
open it, depending on whether you have a Viewer for that file configured in AIR Mosaic 
(AIR Mosaic examines the gopher file extensions to decide which viewer to use).  See the 
"Configuring Viewers" section for more information.  If you click on a telnet or tn3270 link, 
AIR Mosaic will use the telnet or tn3270 application defined in the <Viewers> dialog.

News Using Mosaic
You can use AIR Mosaic as a very basic newsreader for USENET News.  A News Server 
address is provided with AIR Mosaic, so you can actually read and post to news 
immediately. The News Server address can be set up in the News Server option of the 
<Configuration> dialog, should you wish to connect to a different news server.

Often you will end up reading a USENET newsgroup in Mosaic because you clicked a 
hyperlink in a document that connected you to that newsgroup.

To connect to a USENET news newsgroup, you would specify the URL in AIR Mosaic dialogs 
(such as the <Open URL> dialog) in the following format:

news:newsgroup.name

If you want to access a list of all the available newsgroups, from which you can select 
newsgroups, you would instead type

news:*

Note: The * wildcard can also be used to show subsets of newsgroups on the news 
server; for instance, news:alt.tv.* would show all the newsgroups with 
names starting with alt.tv, (like alt.tv.seinfeld or alt.tv.northem-exp), 
news:alt.* would show all of the alt newsgroups, etc.

By default, descriptions of all the newsgroups will be displayed when reading in a list of 
newsgroups; to disable this feature, uncheck Expanded News Listing in the Options 
menu.  Note that this unchecking this option will disable threading.

Once you're connecting to News using Mosaic, you will see news articles listed as bulleted 
items on the screen.
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Reading News:
Articles whose titles are not preceded by "Re:" are original "threads" - they represent the 
initial article on a particular topic.  Articles whose titles begin with "Re:" are responses to 
an initial article.  AIR Mosaic displays hyperlinks at the top of the article; you can click on 
these hyperlinks to navigate through threads.  When you are viewing an article that is part
of a thread, you will see either "Next thread" or "Next article in thread" and "Previous 
article in thread", depending on where you are in the thread.

To view an article, simply click on its title in the article list.  You can use the Back button 
on the Toolbar to move back to the original article.

Posting News articles:
You can add a message to a newsgroup ("post" a message) in AIR Mosaic.  There are 
several ways you can post

1. When you are viewing a list of news articles in AIR Mosaic, you will see a Post to 
newsgroup hyperlink at the top of the screen.  Clicking on this hyperlink will produce an 
<AIR Mosaic News> posting dialog allowing you to post a news article.

2. When you are viewing an individual article in AIR Mosaic, you will see a Followup to 
message hyperlink.  This also produces the <AIR Mosaic News> dialog, but will 
automatically include the text of the currently displayed article in that dialog (using 
standard followup format).

3. You can also post or followup a news article directly using a URL, with the following 
syntax:

newspost: newsgroupname {,newsgroupname,newsgroupname} {/followup}

where

newsgroupname is the name of the newsgroup you want to post to (you can specify 
multiple newsgroups by separating them by commas).

/followup indicates that you want the posting to be a followup posting and include the 
currently displayed article text (if no article is displayed when you do this, no text will be 
included).

text displayed in brackets ({}) is optional.

Examples:
newspost:alt.tv.seinfeld
newspost:rec.bicycles,rec.sports.cycling
newspost:alt.suburbia/followup

The <AIR Mosaic News> posting dialog will be displayed.

News Posting Dialog
The News dialog allows you to post news messages to a News Server.

The Sender field will be filled out automatically with your e-mail address; this is obtained 
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from the Email Address option in the <Configuration> dialog.  If this value is incorrect, you
should change it; otherwise, no one will be able to reply to your posting. If you have a 
valid e-mail account with an Internet Service Provider, you could include that information 
here so that other people could respond to your messages personally.

The Newsgroup field will be filled out with the name of the newsgroup you were viewing, 
or the newsgroup you specified using the newspost: URL.  You can change this field, if 
you wish to post the article to a different newsgroup, or add additional newsgroups to post
the message to.

The Subject field is optional (but strongly recommended); fill this out with the subject of 
your message. (This will be filled out automatically if this is a follow up posting).

The Keywords field allows you to specify keywords that will appear in the header of the 
news posting; these keywords are used by some news readers when searching for 
messages.  Some sample keywords are: politics, simpsons, jobs.

Type the message body in the space provided.  All standard Windows editing keys (arrow 
keys, Home, End, Delete, etc.) are supported.

You can drag and drop text files from Windows File Manager into your news article, if you 
wish.  To do this, drag the file and drop it into the text window of the Mosaic News dialog.  
The text in the file you dragged and dropped will display in that window; you can then edit 
the text or add new text, as desired.

Note:   You can also indicate the Content (or MIME) type of the item you dragged 
and dropped.

Currently, only text files are supported; text/plain will be selected by 
default.  You can change the type to another text type, if desired.

Click Send to post your news article.

Mail Using Mosaic
You can use AIR Mosaic to send mail if you have an SMTP Gateway available (this must be 
set up in the Configuration screen.)

You can send mail by choosing Open URL in the File menu, and typing

mailto:lucy@narnia.com

where lucy@narnia.com is the e-mail address you want to send mail to.

(You can also simply type this URL in the drop down URL: list beneath the Toolbar).

An <AIR Mosaic Mail> dialog will appear allowing you to compose a mail message.

The AIR Mosaic Mail Dialog
The Mail dialog allows you to send out mail from Mosaic via an SMTP Gateway.

The Sender field will be filled out automatically with a default anonymous e-mail address; 
this is changed in the Email Address field in the <Configuration> dialog.  If you have an e-
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mail account with an Internet Service provider, you should replace this anonymous 
address with your valid e-mail address, so that people with whom you correspond know 
who you are and can reply to you more easily.

Tle Recipient field may already be filled out, depending on whether or not you typed a 
valid e-mail address when you typed mailto:.  You can change this field, if you wish to 
send the mail to other people.  This field only accepts standard e-mail addresses (such as 
lucy@namia.com). A CC field is also provided; you can type e-mail addresses of other 
people to whom you want to send a copy of the mail.

The Subject field is optional; fill this out with the subject of your message.

Type the message body in the space provided.  All standard Windows editing keys (arrow 
keys, Home, End, Delete, etc.) are supported.

You can drag and drop text files from Windows File Manager into your mail message, if you
wish.  To do this, drag the file and drop it into the text window of the Mosaic mail dialog.  
The text in the file you dragged and dropped will display in that window; you can then edit 
the text or add new text, as desired.

Note: You can also indicate the Content (or MIME) type of the item you dragged and
dropped.

Currently, only text files are supported; text/plain will be selected by 
default.  You can change the type to another text type, if desired.

_____________________________________________________________________

Saving Documents in Mosaic
You might want to save WWW documents so that you can open them later (using the Open Local File command)
or so that you can use the information in the documents (in word processing or other applications).  When you 
save documents, you will not save the text exactly as you see it on the screen; any graphics on the screen will not 
be saved, and the document will be saved with accompanying HTML codes.

There are several ways to save HTML documents: you can drag and drop the document hotlink to the File 
Manager or another application that supports drag and drop, you can use Load to Disk Mode command to save 
the document to disk, or you can save the document source code to disk directly using the Document Source 
command.  These first two methods of saving documents are described below; the last method is described in the 
“Viewing Document Source” section at the end of this chapter.

_____________________________________________________________________

Using Drag and Drop in Mosaic
You can drag and drop Mosaic documents to the Windows File Manager, or to other applications that support drag
and drop, such as Windows Notepad.  

When your mouse cursor is over a hyperlink, click and hold down the mouse button until the cursor changes from 
a pointing finger to a document icon, with the caption WWW.  Continue holding down the cursor, and drag the 
icon to the application where you want to drop the item.  If the application will not let you drop the item, the 
cursor will change into a prohibited symbol (a circle with a slash through it).

Note that not all applications will support drag and drop from Mosaic, even if they are OLE-compliant (Windows 
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Object Linking and Embedding).
______________________________________________________________________________

Load to Disk Mode
You can also save Mosaic documents when you encounter them by using Load to Disk Mode.  Load to Disk 
Mode saves a document to a file, rather than loading it.  This is very useful if you want to save the contents of a 
document to use in another application, for instance, or if you find a file or resource that you currently can't use, 
but want to save.

Usually, you will want to use Load to Disk Mode selectively; you probably do not want to save everything you 
encounter to a file.  You use [Shift] click to do this. Click on the hyperlink for the document that you want to 
save, while holding down the [Shift] key.  Instead of the document loading in, as it does normally, a standard 
Windows <File Save> dialog will appear, and you will be prompted for a name and location for the document.  
You can accept or change this name, and you can also change the directory where this document is stored.

If you prefer to have Load to Disk Mode turned on, so that Mosaic saves all of the documents that you click on, 
select Load to Disk Mode in the Options menu (a check mark will indicate that the mode is enabled).  When 
Load to Disk Mode is enabled, each time you try to access a document you will be prompted with a Windows 
<File Save> dialog as described above.  Mosaic will continue to try to save documents until you disable Load to 
Disk Mode by again selecting the Load to Disk Mode option from the menu.  

Note that whenever you use Load to Disk Mode, the documents that you click on will not be loaded; they will 
only be saved.  To load in these items, you must turn off Load to Disk Mode (if you turned Load to Disk Mode on 
using the menu, you must disable it; if you simply Shift-clicked to save the document, you only need to click on 
the item normally to get it to load).
______________________________________________________________________________

Printing in Mosaic
You can print the information in a document to your printer using the Print command in the File menu.  If you 
want to see how the output will look, you can choose Print Preview to see a preview of how the document will 
print.

The Print Setup command in the File menu allows you to specify which printer you want to print to. 

The Print Margins command in the File menu allows you to specify the margins to use when printing Mosaic 
documents to a printer; by default, no margins are used.  Set the Top, Bottom, Left and Right margins to the 
settings you prefer.
______________________________________________________________________________

Finding Information in Mosaic
You can search a WWW document for particular text using the Find command.  Click the Find option in the Edit
menu, and type the text you want to search for in the dialog that appears.  The search will occur from the top of 
the document to the bottom.  If you want to search for additional occurrences of the text, you should choose Find 
Next in the <Find> dialog.

______________________________________________________________________________

Configuring AIR Mosaic Options
You can easily configure AIR Mosaic using the <Configuration> dialog.  This dialog allows you to specify 
options for displaying elements in the AIR Mosaic Console, such as the Toolbar, Status Bar, images, hyperlinks, 
and sounds; the default servers for AIR Mosaic; AIR Mosaic's fonts and colors, and which external viewers are 
used to view graphics, and play sounds and movies.
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You can access the <Configuration> dialog by choosing Configuration from the Options menu.

The <Configuration> options are described in the sections that follow.

General Options
The General Configuration options shown at the top of the <Configuration> dialog are described below.

Show Toolbar
Show Status Bar
These options control whether or not the Toolbar and Status Bar are displayed.  You may not wish to hide the 
Status Bar as it displays the locations of resources you connect to, as well as indicating when a transfer is in 
progress or a graphic is being loaded.  By default, these options are displayed; check them again to hide them.

Show Document Title
Show URL
These options control whether or not the Document Title: drop down list with the AIR Mosaic radar indicator and 
the Document URL: drop down list are displayed.  You can show both options, hide both options, or show only 
the Document Title Bar.  You cannot display only the Document URL: list.  By default, these options are 
displayed; check them again to hide them.

Save last window position
You may want to resize the AIR Mosaic Console window during your AIR Mosaic session, in order to see more 
(or less) of a WWW document.  If you want these size changes to be saved and used during your next AIR Mosaic
session, check this option.

Autoload inline images
By default, images (such as logos, fancy titles, small photos) are automatically displayed on your system when 
you connect to a World Wide Web site.  This is done by automatically downloading the image to AIR Mosaic, 
where it is kept in your system memory.  This downloading process can be very time-consuming, depending on 
the speed of your Internet connection.

AIR Mosaic allows you to disable this feature, so that the images are not automatically downloaded/displayed.  
Uncheck this option to stop viewing graphics.  In the place of the graphics, you will see graphic placeholders.

Show URL in Status Bar
By default, when you highlight a hyperlink (by moving your mouse over it), the destination URL for that 
hyperlink will be displayed in the Status Bar.  You can uncheck this option to disable the URL display, if you 
choose.

Underline hyperlinks
Typically, hyperlinks are displayed in blue and underlined.  You may want to turn off the underlining. This is a 
personal preference; it will not affect the speed that the document is retrieved in any significant way.

Animate logo
This refers to the radar indicator on the Document Title Bar.  By default, this is turned on, as it offers you some 
useful information about whether or not a document or image is being retrieved (and gives your mind something 
to do while you wait–although you can always work in other Windows applications if a document is loading too 
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slowly).  The time you'll save by turning off the logo animation is not substantial; you will probably only want to 
turn off that option if your connection is very slow.

This option is primarily provided in case you are using a remote access program such as Symantec's PC-
Anywhere to use your PC remotely.  In these cases, the animated logo may cause problems; disable Animate logo 
by unchecking this option.

Use 8-bit sound
AIR Mosaic features internal sound support for .AU and .AIFF files, using your sound card (if you have one).  
This option assumes you have a high quality sound card.  If these file types do not play properly, or you have a 
lower quality (or 8-bit) sound card, choose this option.

When loading images, redraw every __ seconds
You can change how often the screen is redrawn by changing this option.  

When you connect to a Mosaic document, AIR Mosaic loads in the entire document, using image “placeholders” 
for any images in the document.  AIR Mosaic will then load in the images one by one, and redraw the screen 
(replacing the placeholders with images) as images are loaded in.  

Changing the redraw value will affect how the Mosaic document appears as it is loaded in.  For instance, if you 
want AIR Mosaic to load in most/all of the document's images before redrawing the screen, you would set this 
value to a high number (i.e. 5 seconds), to give AIR Mosaic time to load in all the images.  If you want AIR 
Mosaic to redraw the screen each time a new image is loaded in, set this value to a lower number (2 seconds, for
instance).

The value you will want to use is also dependent on the speed of your connection.  If you are operating over a 
slow modem connection, images may not load in very quickly, and you may want to increase the screen redraw 
value to a higher number (so that the screen only redraws when new images are loaded in).

Another reason for changing this value:  if your AIR Mosaic screen is redrawing the screen very often, you may 
find the flicker of your screen as the screen is redrawn to be annoying.  If so, increase the value of the redraw 
option until you are happy with the screen performance.

Home Page
AIR Mosaic lets you set up a default Home Page that you can quickly access using the Home button on the 
Toolbar.  Type the URL for the home page in the URL: field to set up this home page.  See “Opening Documents 
Using URLs” for more information on understanding URLs.
You can also set up AIR Mosaic to automatically load this Home Page on startup; if you want to see this home 
page whenever you start AIR Mosaic, check the Load automatically at startup option.

Email Address
SMTP Server
News Server
These options are all used by AIR Mosaic when you are using some of Mosaic's extended functionality for News 
and sending mail.  You must fill out some information about your system in order for these to work properly.  See 
“Accessing FTP, Gopher, News, and Mail” for more information.

To send mail:
You must fill out your e-mail address and SMTP Server address.
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Email address  This is the address others use to send you e-mail, i.e. jwatson@moriarty.com.  The installation 
enters a default anonymous value here for you; if you have an e-mail address, you should enter it 
here.

SMTP Server   This is the mail server you use.  A default mail server out on the Internet has been supplied for 
you. Do not change this setting.

To read news:
News Server    You must fill out the address of your news server.  This is the machine that you connect to in order

to read news.  A default News server is supplied by default.  If you have a news server you prefer 
to use to read news, type its name here.

Cached Documents
This item represents how many documents are cached, or kept active, in your PC's memory.  If this number is 10, 
for instance, 10 documents will remain “available” to you; if you go back to them, they will appear immediately, 
and will not have to be loaded.  

If you have a lot of available system memory, you may want to increase this number.  Keep in mind that a high 
number for cache may affect other applications' performance, although Mosaic performance will probably 
improve quite a bit.

Documents in Drop Down
This value indicates how many of your last-accessed documents will appear in the Document Title: and Document
URL: drop down lists (displayed beneath the Toolbar).  A value of 5 would mean that the last five documents you 
accessed would display in these lists.

The three buttons at the bottom of the dialog allow you to configure viewers, choose fonts, choose the hyperlink 
color and define proxy servers.  These features are described in the sections that follow.
______________________________________________________________________________

Viewers
You can click Viewers in the <Configuration> dialog to specify the external viewers you want to use 
for different resource types that you might find on the World Wide Web. For instance, you may find a 
multimedia movie in a WWW document, and want to set up Mosaic to use an external movie player 
application so that you can view the movie. You can also use this dialog to set up applications to support 
telnet, tn3270, and rlogin.

Understanding How Viewers Work
AIR Mosaic internally provides support for text, in-line graphics, and certain sound files (note: you must have a 
sound card or Windows sound player for sound).  However, some of the resources you encounter using AIR 
Mosaic (GIF and JPEG files, MPEG movie files, .WAV sound files) will require you to use external viewers, 
separate programs that can view graphics, play movies, or otherwise interpret Mosaic resources.

Most commonly, you will need external viewers to:

•View GIF or JPEG image files

Some GIF (Graphics Interchange Format) format graphic images you find in Mosaic documents can be retrieved; 
these images are indicated by a hyperlink.  You will also often see hyperlinks to images like “Picture of the 
Louvre” or “LOUVRE.GIF”.  GIF and JPEG are common image file formats used on the World Wide Web.
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You can retrieve these images if you have an external image viewer that allows you to view the GIF or JPEG 
images.  AIR Mosaic comes with an image viewer, ImageView, which will allow you to view GIF and JPEG 
graphic files automatically.  This Viewer is already set up in AIR Mosaic.

•View MPEG movie files

Multimedia movie files (MPEG files) are found in many places on the World Wide Web.  Usually they are not 
identified  with any symbol, but are named with an extension of .mpg (“mountains.mpg”), or otherwise identified 
as MPEG movie files.

AIR Mosaic does not include an MPEG viewer.  You can use any Windows based MPEG viewer with AIR 
Mosaic.  When you find an external MPEG viewer, you must set it up in AIR Mosaic using the Configure Viewers
feature.

An application called MPEGPLAY can be found on the SPRY ftp server, ftp.spry.com (mpegexe.zip in the /ms-
windows/viewers/mpeg/apps directory.)  Note:  this is a freely-distributable application (by Xing™ Technology 
Corporation) and is not supported by SPRY.    The SPRY FTP Server's /ms-windows/viewers directory also contains 
shareware and freeware utilities for viewing postscript, rtf, gif and jpeg files.

You can set up all of your Viewers for AIR Mosaic using the <Viewers> dialog, as described in the next section, 
“Configuring AIR Mosaic Options”.

Configuring Mosaic Viewers
When you access an item on an HTTP (World Wide Web) server, AIR Mosaic determines the MIME type for that 
item, and checks the information you've defined for that MIME type to see which viewer to use to display the 
item.

MIME is a general purpose encoding method for exchanging multimedia data over the Internet. Use of MIME 
allows Mosaic to retrieve and recognize many different types of data. MIME content types specify the format in 
which a document is stored.

There is a set of standard MIME types used by WWW servers. These standard MIME types cover most of the 
items you will find using Mosaic. They are listed below:

text
plain Plain ASCII text
html HTML formatted text

image
gif CompuServe GIF format
jpeg JPEG compressed images
tiff Tagged Image File Format
targa AT&T TARGA format
x-win-bmp Windows Bitmap
xbm X Bitmap

audio
basic Sun/DEC/NeXT audio (*.AU files)
wav MS Windows WAVE (RIFF) audio
aiff Audio Image File Format

video
mpeg MPEG video
quicktime Apple QuickTime
msvideo Microsoft Video (*.AVI files)
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application
zip PKZip compression format
postscript Adobe PostScript (*.PS) format

You specify these MIME types in AIR Mosaic by specifying first the type, a forward slash and then the sub-type, 
i.e. application/zip.

The Type: drop-down list lists only those MIME types for which you currently have viewers on your system You 
can change the viewers for those MIME types, and add new MIME types and viewers, as described below.

Changing Viewer Information
You can associate a viewer with one of the existing MIME types from the preceding table by adding the MIME 
type to that list. You can also create a new MIME type if one does not exist for the resource.

In most cases, you will want to use one of the standard MIME types, since these are recognized by most HTTP 
(WWW) servers. However, when AIR Mosaic accesses an item on an FTP or Gopher server, it uses the item's file 
extensions, not the MIME type, to recognize the item. Therefore, you might want to create a special MIME type 
just for that item. The convention when adding a non-standard MIME type is to use the applicable standard 
MIME type (such as image), but prepend the sub-type name with and X (i.e., image/X-TIF, for files with a .tif 
or .tiff extension). Also, you might be accessing an HTTP (World Wide Web) server which contains a non-
standard MIME type, and you want to define that new type so that you can specify viewers for it. If you are doing 
this, you must be sure to use the exact same syntax for the MIME type that is used on the server.

1) Click New in the <Viewers> dialog to add a new MIME type and viewer.
2) Type the name of the MIME type that you want to use in the Type drop-down list. Again note that in 

most cases, you should use one of the standard MIME types in the previous table.
3) Type any file extensions that map to that MIME type in the Extensions field. Multiple entries should 

be separated by a comma. (For example, .MGP, .MPEG). You do not have to fill out this field; 
extensions will only be used when accessing items on an FRP or Gopher server.

4) Type the pathname to the viewer for this type in the Viewer: field, or click the Browse button to look 
for it with a standard Windows file dialog. (You might, for example, specify C:\VIEWERS\MPEG\
MPEGPLAY.EXE).

5) Click Close to close the <New Document Type> dialog. The new document/MIME type information 
will be saved.

Defining telnet, rlogin, and tn3270 Applications
You can also define the applications used by Mosaic for telnet, rlogin, and tn3270. To do this, type the application 
you want to use in the appropriate field (click Browse to search your disk for the correct file and directory name. 
When you Close the dialog, the changes you made will be saved.

Color
The Hyperlink color is the color that is used to highlight Mosaic hyperlinks (jumps to other 
documents or document areas, or jumps to resources).  Text hyperlinks are entirely 
highlighted, and graphics hyperlinks are surrounded by a highlight.  The standard 
Hyperlink color is blue.
To change the Hyperlink color, click Color.  The <Color> dialog will appear.

Select the color you would like to use for Hyperlinks, or click Define Custom Colors to 
select a color.  Click OK; the Hyperlink color will be changed immediately.
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Fonts
You can change the fonts that AIR Mosaic uses to display documents.  You can change the 
font that is used for a particular item, or the font size.  You might want to do this to make 
documents easier to read, or to fit more information onto your screen.  

Different items in documents use different font styles (similar to styles in word 
processors). Most regular text is displayed in Normal style, and headers are displayed in a 
Header style, such as Header 1, Header 2, Header 3, etc.

You can change these font styles clicking the Fonts button.  You will see the <Fonts> 
dialog.

If you want to change just one style, you can choose the style that you want to change 
from the drop down menu, and define a Font for that style by clicking the Change Font 
button.
Specify the font type and style you want, and click OK.  The style will be changed until you
change it again.

If you are not sure what style it is you want to change, you will have to do some 
experimenting.  AIR Mosaic cannot tell you what styles are being used in a particular WWW 
document.

If you want to change all the styles in a document, you can choose Enlarge All or 
Reduce All to enlarge or reduce the styles.  You can choose this option as many times as 
you like.
Click OK when you are finished changing styles.
______________________________________________________________________________
Proxy Servers
Proxy Servers are machines, usually doubling as Internet gateways, that allow you to send 
and receive information even though your network is protected with an Internet firewall.  
Requests for information are sent from your PC to the Proxy Server, and the requested 
information is sent back to the Proxy Server, which then sends it to your PC.  If your 
network is protected by an Internet firewall, you will not be able to use AIR Mosaic to 
access URLs outside your network unless your network uses Proxy Servers or the 
appropriate ports are enabled on your firewall.

AIR Mosaic offers support for HTTP, ftp, WAIS, and Gopher Proxy Servers; currently only 
Proxy Servers based on the CERN specification are supported.

To set up AIR Mosaic to use Proxy Servers, click the Proxy Servers button in the 
<Configuration> dialog. You will see the <Proxy Servers> dialog.

Specify the URLs (with ports, where applicable) of Proxy Servers that you want to use. AIR 
Mosaic will then transfer information through those servers.

When retrieving HTML documents, AIR Mosaic will go through an HTTP Proxy Server; when 
retrieving files via ftp, AIR Mosaic will go through an ftp Proxy Server, etc. These "servers" 
are usually on the same machine; therefore, all of the entries may be the same.

For example, for your HTTP Proxy Server, you might specify
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http://proxy.circe.com:8001

where proxy.circe is the name of your proxy server, and 8001 is the port used for the proxy service.

Using the Exclude Domain option
When you provide Proxy Server address information, AIR Mosaic will always try to access information through 
those Proxy Servers. However, there may be times when you do not want AIR Mosaic to use Proxy Servers; the 
Exclude Domain option in the <Proxy Servers> dialog allows you to do this.

For instance, if you are accessing information from your own network (such as ftp'ing files from another machine 
within your network), you will not want to go through the Proxy Server to retrieve the information. Also, if you 
have another domain within your organization that is also behind your Internet firewall, you may want to 
communicate directly with machines in that domain, rather than go through the proxy server.

When you specify a domain in the Exclude Domain field, AIR Mosaic will automatically try to connect to any 
URLs in that domain directly, not through the Proxy Server.

You can specify multiple domains in this field, separating them by commas.

______________________________________________________________________________
Viewing Document Source
A Document Source command is provided in the File menu to enable you to view, and 
save HTML document source code.  Click Document Source to view the current 
document's source code.  

You can now choose Save from the File menu to save the source code to a file.  
Remember that all the HTML codes will also be saved.  You will be prompted for a name for
this file.
You can also choose Copy from the Edit menu to copy some or all of the HTML text to the 
Windows Clipboard, so that it can be used in other applications.  (Use the Select All 
command to select the entire document.)
______________________________________________________________________________
Mosaic Command Line Options
AIR Mosaic supports three command line options:  opening a URL (Uniform Resource 
Locator) or local HTML file, starting Mosaic in Kiosk mode, and specifying the INI file for 
Mosaic to use for configuration.  

You can, if you want, change the Properties setting for the AIR Mosaic icon to have the 
command line options take place every time you click on the icon.  (This is not 
recommended when using the options to open a URL or local HTML file; see the note 
below).

Command Line Options
You can configure AIR Mosaic to start up under various set ups. For instance, you can start AIR Mosaic in Kiosk 
mode or with a different configuration, by adding a specific command to the AIR Mosaic command line. The 
command line can be found by clicking once on the AIR Mosaic Program Icon, choosing Properties from the 
File menu in Windows Program Manager. In the <Program Item Properties> dialog, enter the AIR Mosaic 
command line option after the AIRMOS.EXE entry on the Command Line. The command line options are 
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described below:

Opening a URL or HTML file upon startup:
You can configure AIR Mosaic to connect to a specific HTML document on start up. You do this by replacing the 
command line information with the following information:

AIRMOS.EXE {URL}
where {URL} contains the location of the HTML document:

AIRMOS.EXE http://www.wired.com)

or

AIRMOS {local HTML file pathname}

AIRMOS.EXE c:\wwwdemo\mydemo.htm)

This option will automatically open AIR Mosaic and connect to the URL or local HTML file 
that you specify.

If you want to connect to the same URL or HTML every time you start AIR Mosaic, it is  much 
easier to specify a default home page in Mosaic than to use the command line option.  See 
“Configuring AIR Mosaic Options”  for more information on specifying a default home page.

Running AIR Mosaic in Kiosk mode:
By entering the following information, you can indicate to AIR Mosaic to start in Kiosk mode:

AIRMOS.EXE -K

This will start AIR Mosaic in Kiosk mode, hiding the Menu Bar, Toolbar, Document Title Bar, 
and Status Bar, and displaying only the World Wide Web document you are currently 
viewing. See “Using Kiosk Mode” for more information on using Kiosk Mode.

Specifying the AIRMOS.INI file to use:
By entering the following information, you can specify to AIR Mosaic which AIRMOS.INI file to use on startup:

AIRMOS.EXE -I {full path to INI file}   

Example:  AIRMOS.INI -I C:\MOSAIC\AIRMOS.INI

This allows you to specify the location of the AIRMOS.INI file you want to use.  By default, 
Mosaic uses the AIRMOS.INI file found in your Windows directory.  Although it is easy to 
make changes to the AIR Mosaic configuration, there may be some reason you want to 
have multiple configurations of Mosaic available; you can use this option to do so.  To 
create another configuration of AIR Mosaic, configure AIR Mosaic the way you want it, and 
then copy the AIRMOS.INI file to a directory other than your Windows directory.  Any 
further configuration you make will affect the AIRMOS.INI file in the Windows directory; you
can then switch to the other configuration by using the command line option, above.
______________________________________________________________________________
Special Mouseclick Features
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AIR Mosaic supports the following modifiers when accessing hyperlinks using the mouse.

Shift-Click
If you hold down the [Shift] key while clicking on a hyperlink, AIR Mosaic will automatically 
try to save the indicated resource to disk (this is equivalent to having Load to Disk 
checked on before accessing the resource).

Ctrl-Click
If you hold down the [Ctrl] key while clicking on a hyperlink, AIR Mosaic will retrieve 
header information for the indicated resource; i.e. the resource type, size, full pathname, 
etc.  This is a good way to decide whether you will want to load in a resource (and whether
you have the appropriate viewers for it), before actually loading it.

Right Click
If Autoload Image is off, clicking the right mouse button when the cursor is over an 
unloaded image will display the “hidden” image.

Ctrl-Right Click
If you hold down the [Ctrl] button while clicking the right mouse button when the cursor is 
over an unloaded image, the header information for the indicated resource will be 
displayed; i.e. the image type, size, full pathname. As with Ctrl-Click, above, this is a good 
way to decide whether you want to load in an image before actually loading it.
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