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Starting SPRY Mosaic
Although there are thousands of Mosaic sites on the Internet that you can explore, you may 
not know where to start.    SPRY Mosaic comes pre-configured with a home page.    This is 
done so that you have a place to start looking for other WWW resources.    
When you start SPRY Mosaic, it will automatically connect you to the pre-configured home 
page.    From there, you can begin browsing the Internet and begin connecting to other home
pages.    As you become an experienced browser, you'll be able to build a library of home 
pages that you like, using SPRY Mosaic's "hotlist" feature.
You can start SPRY Mosaic by clicking on the SPRY Mosaic icon.    SPRY Mosaic will 
immediately start connecting you to a home page.    (You will see the radar logo in the upper 
right hand corner of the SPRY Mosaic console spinning as the home page is retrieved.)
Once you finish connecting to a home page, you can immediately begin browsing with 
Mosaic.
Note: You can easily define your own home page to automatically connect to on startup.    Use the Configuration 

option in the Options menu to set up a default home page. 

____
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Browsing with Mosaic
World Wide Web uses hyperlinks (also referred to as anchors or hot spots) to allow you to
jump to other resources.    Hyperlinks are indicated by blue, underlined text, or by graphics 
surrounded by a blue border (you can change the color that is used).    Another way to tell 
that you are on a hyperlink is to highlight the text or graphic with your mouse.    The mouse 
will turn into a pointing hand.
You can then click on a hyperlink to connect to another Mosaic document.    The new 
document will be opened (you will see the radar indicator in the upper right hand corner of 
your SPRY Mosaic Console begin to spin).    If at any time you need to stop loading in a 
document, you can click the Stop button or choose Cancel Current Task from the 
Navigate menu.
You can continue to browse through Mosaic documents by simply clicking on the hyperlinks 
you find in the document.    You can also travel through Mosaic documents you encounter 
using the methods listed below.
____
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Back/Forward
You can click on the Back button (the third button on the Toolbar) to move back to the last 
document you viewed.    The Forward button (the fourth button on the Toolbar) can move 
you forward after you have moved back.    You can also type B for Back or F for Forward, or 
choose Back and Forward choose Back from the Navigate menu.



Document Title/Document URL
The Document Title: and Document URL: drop-down lists, under the Toolbar, contain a 
listing of the last several documents you've accessed in this session.    The lists are identical, 
but one shows the title of the document and the other shows that document's URL 
(http://www.bakerstreet.com).    You can go back to any of the displayed documents by 
choosing its title or URL from the lists.



History
You can also click History to access the History dialog.    The History dialog allows you to 
access documents you've already accessed in this session.    This is equivalent to using the 
drop down lists, above.    Select the document you want to go back to, and click on the Load 
button.



Home
At any time, you can click the Home button on the Toolbar, or choose Home from the 
Navigate menu to return to the document defined as your Home Page.    When you start 
using Mosaic, a home page is already defined as your home page; you can set up a new 
home page (or set SPRY Mosaic to start without opening a home page) using Configuration 
in the Options menu.



Reload
You can reload the current SPRY Mosaic document at any time by clicking the Reload button
or choosing Reload from the Navigate menu.    You might want to do this if the document 
did not load properly.



Cancel Current Task
If at any time you need to stop loading in a document, you can click the Stop button or 
choose Cancel Current Task from the Navigate menu.



The SPRY Mosaic Console
The SPRY Mosaic Console is described below.
The Toolbar at the top of the Console contains buttons that serve as shortcuts for SPRY 
Mosaic menu items.    The Toolbar style can be changed between Picture & Text, Picture only,
and Text only by choosing Toolbar Style from the Options menu.    
The Status Bar at the bottom of the Console displays the locations of resources you 
connect to, as well as indicating when a transfer is in progress or a graphic is being loaded. 
Both the Toolbar and the Status Bar can be shown or hidden by checking or unchecking 
Show Status Bar or Show Toolbar using the Configuration option in the Options menu.
Below the Toolbar is the Document Title Bar, containing the Document Title and 
Document URL drop down lists.    The two lists contain a listing of the last several 
documents you've accessed.    The lists are identical, but one shows the Title of the 
document (such as "Wired Magazine's Rest Stop on the InfoBahn") and the other shows that 
document's URL (http://www.wired.com).    You can go back to any of the displayed 
documents by choosing its title or URL from the lists.    You can change the number of 
documents that are displayed in these lists using the Configuration option in the Options 
menu.
The Document Title Bar also contains the radar retrieval icon.    This icon moves when a 
document is being loaded or a graphic is being transferred (roughly, it indicates that SPRY 
Mosaic is busy.)    You can disable the animation of this icon by unchecking Animate logo 
using the Configuration option in the Options menu.
You can temporarily hide the Toolbar and Document Title Bar using Kiosk Mode.



Using Kiosk Mode
Kiosk Mode is available with SPRY Mosaic; you can hide all the Console information except 
the actual document (in other words, the Toolbar, Status Bar, and Document Title Bar and 
the menu items and commands will be hidden).    This may be a useful mode to use when 
giving Mosaic presentations (it shows a lot of the screen) or when setting up Mosaic on an 
unattended workstation.

Click the Kiosk button on the Toolbar, or choose Kiosk Mode from the Options menu.    
SPRY Mosaic will change into Kiosk Mode.

You can move around in Mosaic as you would normally, except that the Toolbar buttons and 
menu options are not available to you.    Note that the shortcut movement keys of F 
(for Forward) and B (for Back) will be very helpful to you to move when in this 
mode, since the Forward and Back commands are not available.

Click the Esc key or Ctrl-K to exit Kiosk mode.



Using Hotlists
One of SPRY Mosaic's strongest features is its ability to organize the information that you 
find on the World Wide Web.    There are so many documents out there with useful jumps to 
resources you might be interested in, that it is common to want to access these documents 
again and again.    You can save these documents and open them again later, but SPRY 
Mosaic provides an easier way to re-access documents.
SPRY Mosaic's Hotlists can be used to remember WWW document locations, so that you 
can easily locate and access them.    You can group Hotlists by subject (Games, Sports, 
Weather, Fun Stuff) or by any other criteria (if several people use one computer, they 
might each have their own hotlist).    
Hotlists you create can then be accessed two ways:    they can be accessed with a couple of 
mouse clicks from the convenient Hotlists dialog, or you can make Hotlists into drop-down
menus, so that you can choose them directly from the SPRY Mosaic menu bar.
Note: NCSA Mosaic users:    You can convert any menus you created in NCSA Mosaic to Hotlists.

____
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The Hotlists Dialog
You work with Hotlists in the <Hotlists> dialog, accessed by pressing the Hotlists button or 
by choosing Hotlists in the File menu.    The <Hotlists> screen initially will show all the 
different Hotlists you have.    SPRY Mosaic comes with several Hotlists pre-loaded.    You can 
remove any of the provided Hotlists, or add additional Hotlists of your own.
The Hotlist itself is shown as a flaming document in the <Hotlists> dialog.    Initially, Hotlists 
may be shown closed; you can open up (expand) the Hotlist by doubleclicking on the Hotlist 
icon.    Each Hotlist can contain many WWW documents, or it can contain folders that 
contain additional documents (you can use folders and subfolders to organize your 
documents any way you want).    You will see the documents and folders listed in a hierarchy 
similar to the Windows File Manager.
In the <Hotlists> dialog, you can create new Hotlists, add new Hotlist items, edit your 
existing items, or delete them.    
At any time, you can check Use Hotlist as menu item to have a Hotlist added as a menu 
item.    You can add as many menu items as can fit in your SPRY Mosaic menu bar.    When 
you choose this option, the Hotlist icon in the <Hotlists> dialog will change to a dialog 
containing the letter H.    If you add a Hotlist as a menu item, any folders within that Hotlist 
will appear as menu items that have sub-menu items beneath them.



Creating a New Hotlist
Choose Hotlists from the File menu, or click the Hotlist button on the Toolbar.    The 
<Hotlists> dialog will appear, containing any hotlists already created.
Click the New/Open button.    You will see a Windows file open dialog.    (You could specify 
the name of an existing hotlist at this point, to open and load it into the <Hotlists> dialog.)
Choose a filename for your Hotlist, and click OK.    This must be a legal DOS filename (using 
up to 8 characters, with the extension .hot).
The next dialog asks you to specify a name for this Hotlist.    This can be any name you want 
(keep in mind that you may want to use this hotlist as a Mosaic menu, so you might want to 
keep the name short.)    Type a name, and click OK.
The Hotlist will be created, and you will see it appear in the <Hotlists> dialog (as a "flaming"
document).
As mentioned earlier, you may want to create folders or subfolders to help organize your 
information.    To do this, click Add with the Hotlist highlighted (or with a folder highlighted to
create a subfolder), and specify Folder in the dialog that appears.    You will be asked to 
name the folder. Give it a name and click OK; the folder or subfolder will be created.
Now that you have a Hotlist, you can begin to add documents to it.
___
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New/Open Hotlist
The <New/Open Hotlist> dialog can be used to open an existing Hotlist, or create a new 
Hotlist.
In this dialog, specify the name of an existing Hotlist, to open and load it into the <Hotlists> 
dialog.
or
Specify the name of a new Hotlist to have SPRY Mosaic create a new Hotlist.    Choose a 
filename for your Hotlist, and click OK.    This must be a legal DOS filename (using up to 8 
characters, with the extension .hot).



Adding a Document to a Hotlist
There are two ways to add documents to a Hotlist:

> Add the document to a Hotlist when you are viewing it.
> Add the document to a Hotlist manually.

The first option is easiest, since you will not have to know or remember the document's URL 
(the document's "address") to add it to a Hotlist.    These two options are described below.

Add the current document to a Hotlist:

In Mosaic, display the document that you want to add to a Hotlist.    You could do this by 
jumping to it from another document, or opening it directly using its URL.
You now have two ways to add the document to a Hotlist: 

> Clicking Add Document to Hotlist in the Navigate menu will add the document
to the Hotlist you are currently using.    This will be the last Hotlist you selected.    
Open the <Hotlists> dialog if you are not sure which Hotlist is currently selected.   
If no Hotlist is selected, this command may not work properly.

> Using the <Hotlists> dialog, as described below, will allow you to specify exactly 
where you want to add the document.

Click the Hotlist button, or choose Hotlist from the File menu.    You will see the <Hotlists>
dialog.
Select the Hotlist (or subfolder) to which you want to add the current document.
Click Add.    You will be asked whether you want to add a document or folder; select 
Document.    You will see the <Add Document> dialog.    This should contain the Title and 
URL of the document you are currently viewing.    If you wish, you can change the name of 
the document.    Do not change the URL!
Click OK.    The document you specified will be added to the Hotlist you selected.

Adding a document to a Hotlist manually:

You would do this if you want to add a document to a Hotlist, but do not currently have the 
document open.    To do this, you need to know the URL (address) for each document.    For 
instance, someone may give you a list of WWW documents containing travel information.    
You can create a Travel Hotlist, and add all the documents to it quickly-a one step process.   
You would do this as follows.

Click the Hotlist button, or choose Hotlist from the File menu.    You will see the 
<Hotlists> dialog.
Select the Hotlist to which you want to add a document by highlighting it using your 
mouse.
Click Add.    You will be asked whether you want to add a document or folder; select 
Document.    You will see the <Add Document> dialog.    If you currently have a 
document open, the information about that document will appear in this dialog.    To add 
a different document to this Hotlist, you must type in the Name and URL of the 
document.    
For the Document Title:, type any name you want.    It should be a name that will help 
you recognize this file.
For the Document URL: field, type the Document's URL.    



Click OK.    The document you specified will be added to the Hotlist you selected.



Export Hotlist
You can, if you choose, export any of your Hotlists as an HTML file (i.e. a Mosaic-format 
document).    This feature might be useful, if, for instance, you have compiled a hotlist with 
an interesting collection of Mosaic home pages, and want to put it up on a World Wide Web 
server for others to access.    Or you may find it handy to use the Hotlist as your default 
home page, so that you immediately have a list of your favorite resources available when 
you start Mosaic.
You export a hotlist by clicking the Export button in the <Hotlists> dialog.    This dialog 
prompts you for a name and location for the HTML file.    Select the directory you want for 
the file, and assign a name to the file.    The file will be saved with the extension .htm by 
default.
After you export the file, you can open the file by using the File Open command.    Your 
Hotlist will be displayed as a Mosaic document which resembles your hotlist and contains 
hyperlink jumps for documents in your hotlist.



Import NCSA Menu as Hotlist
If you previously used NCSA Mosaic (from the National Center for Supercomputing 
Applications), you may have built up extensive menus of favorite home pages and 
resources; SPRY Mosaic allows you to convert these menus to SPRY Mosaic Hotlists so that 
you can use them just as you would Hotlists created in SPRY Mosaic.    

To import an NCSA menu as a Hotlist:

Click Import NCSA Menu as Hotlist in the Options menu.    You will see the <Import NCSA
Menu as Hotlist> dialog.
In the dialog's INI file to import from field, you should specify the name and location of the 
MOSAIC.INI file where your NCSA menu information is stored.    You can click the Browse 
button to browse the directories on your PC and select the correct file.    Once you've 
selected the file, you can confirm that it is the correct file you want by clicking the Open 
button.
You should then specify a Hotlist file for this menu.    Do not choose an existing Hotlist 
unless you want to overwrite the information in that file.     Again, you can use 
Browse to find a Hotlist file and a directory for the file.
Last, you should specify which menus from that NCSA MOSAIC.INI file you want to import (all
of the menus identified in that file should appear in a list).    Click OK when you're ready to 
import the file.
The next time you open the <Hotlists> dialog, the menu(s) you imported should be 
displayed.    You can add them as menu items, if you like, using the Put this Hotlist in the 
menu bar command.



Opening Documents Directly
There are two ways to open a WWW document directly.    If you know the document's URL 
(Uniform Resource Locator; a standard "address" for Mosaic documents), you can access the 
document by typing the document's URL.    If someone tells you the URL of a popular WWW 
site on the Internet, you can go to it directly using that URL.    You will also need to know a 
document's URL to set it up in a Hotlist or as a default home page.
You can also create or save an HTML file directly to your PC, and open it in SPRY Mosaic.    
This is known as a Local File.    
These two methods of opening Mosaic documents are listed below.
____
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Opening Documents using URLs
Mosaic locates documents by using URLs, Uniform Resource Locators.    URLs are a standard
notation for WWW resources, designed to be able to identify information stored on a variety 
of machines, in a variety of different ways. A URL can point to resources such as an HTML 
document (a WWW home page), an ftp server, a gopher server, or a local document.    When 
you access a document in SPRY Mosaic, you will see the URL for that document shown in the
Document URL: field    displayed below the SPRY Mosaic Toolbar.
URLs are used to    indicate the type of the resource and where it is located, as well as the 
resource name.
If you know the URL of a resource, you can access it directly, as described below.

Click Open URL in the File menu.
The most common URL you will specify in the <Open URL> dialog is the URL for an HTML 
home page.    This is always preceded by http:// followed by the address of the HTML 
document. 
e.g. 
http://www.bakerstreet.com/221B.html

Type the URL you want to connect to and click OK.    If the URL is valid, SPRY Mosaic 
should begin connecting to it.

____
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URL Description
URLs typically provide information about a resource type, location, and path.    
You might find a document called "Internet Web Text" with a URL of
http://www.rpi.edu/Internet/Guides/decemj/text.html
This URL can be deciphered as follows:
http:           //www.rpi.edu       /Internet/Guides/decemj/text.html
or, roughly,
Resource Type         //Resource Location         /Pathname
These three portions are described below.
Resource Type
The Resource Type tells you the type of server on which the resource resides.    The resource 
type is actually the kind of protocol will be used when retrieving the document.
URL resource types and formats include:
http:// HTTP (HyperText Transfer Protocol) Server.    This is a site designed principally 

for hypertext WWW documents.
ftp:// FTP (File Transfer Protocol) Server.
file:// Local HTML File (also sometimes used to denote FTP Servers).
telnet:// Telnet Server.
gopher:// Gopher Server.
wais:// WAIS Server (not directly supported in SPRY Mosaic)
news: USENET news site
Note: The news: URL uses a slightly different format; it takes the format news:newsgroup.name, since you 

already have a news server pre-defined in Mosaic (using the <Configuration> option).    To find out how to 
configure your news server, click here.

Resource Location
This is the Internet address of the machine where the resource resides.
In the example above, www.rpi.edu is the World Wide Web server at Rensselaer 
Polytechnic Institute, a school in Troy, New York.    Note that often you will not be able to 
figure out exactly where a resource is located.
Pathname {filename}
In most cases, the URL for a document or other resource contains a full pathname for the 
file.    If you're familiar with DOS or UNIX pathnames,    the path in a URLis very similar.    
(Paths in WWW always use the forward slash /).
In the example above, the path is /Internet/Guides/Decemj/.    If you're looking at the 
resource, you see that it is titled Internet Web Text, by John December.    You might intuit that
this is John December's personal directory on the Rensselaer Polytechnic Institute WWW 
server.
Some sample URLs are shown below:
http://www.rpi.edu/Internet/Guides/decemj/text.html
ftp://ftp.circe.com
file://localhost/c:\mosdocs\sample.htm
telnet://odysseus.circe.com:70



gopher://spinaltap.micro.umn.edu:70/11/fun/Movies
news:alt.tv.seinfeld
Note: For advanced information on URLs, a URL primer is available from NCSA on the NCSA home page, at 

http://www.ncsa.uiuc.edu/demoweb/url-primer.html.



Opening a Local File
You can create an HTML file or save an HTML file directly to your PC, and open it in SPRY 
Mosaic.    This is known as a Local File.    A Local File should have extension .htm.    
You can open a Local File using the <Open Local File> dialog.    Specify the name and path 
for this file, and click OK.    SPRY Mosaic will try to open the file you specified.



Using Mosaic for FTP, Gopher, and More...
Although you may navigate principally between HTML documents ("home pages") when 
using SPRY Mosaic, you can also use it to access other Internet resources such as ftp and 
gopher sites and USENET news.    The functionality of SPRY Mosaic as an ftp, gopher, or news
browser is somewhat limited, since the World Wide Web protocols used are not very 
sophisticated.    For full-featured use of ftp, gopher, and news, more sophisticated 
applications are recommended.    You can also use Mosaic to send mail.
Mosaic's functionality accessing FTP, Gopher, News, and Mail is described below.
Accessing FTP and Gopher Sites
Accessing ftp and gopher sites is very easy with SPRY Mosaic.    Since SPRY Mosaic 
incorporates both ftp and gopher functionality, no additional tools are needed to retrieve 
files from these types of sites.    Some background on ftp and gopher resources may be 
helpful.
You might find an ftp or gopher site when you're using SPRY Mosaic, or you could connect to 
one directly if you know its URL (address).
The ftp or gopher site will be displayed in a hierarchical folder format in the SPRY Mosaic 
Console.    Using ftp and gopher is very similar.
On an ftp site, you will only see two types of items, folders (directories) and files.    You can 
navigate through folders by doubleclicking on them to move deeper into the folders; if you 
want to move back, click on the up arrow shown at the top of the folder list.
When you doubleclick on the name of a file on an ftp screen, SPRY Mosaic will automatically 
download (copy) the file to your \...\DATA directory, using the displayed filename.
On a gopher site, aside from folders and files, there are several other items displayed on 
the screen: image files, sound files, search tools and other gopher resources.
Doubleclicking on a gopher resource will either download it to your \...\DATA directory or will 
open it, depending on whether you have a Viewer for that resource configured on your PC.
Accessing News
You can use SPRY Mosaic as a very basic newsreader for USENET News.    

Accessing a News Server:

You have to access a News Server to read News with SPRY Mosaic.    A News Server address 
is provided with SPRY Mosaic, so you can actually read news immediately, but you will only 
be able to see a limited amount of newsgroups when accessing this Server.    You will need to
find out the address of a News Server to use; your Internet Service Provider may have one 
that you can access, or you may already have been using one that you can connect to.    The
News Server address can be set up using the Configuration option in the Options menu.
Often you will end up reading a USENET newsgroup in Mosaic because you clicked a 
hyperlink in a WWW document that connected you to that newsgroup.    
To connect to a USENET news newsgroup, you would specify the URL in SPRY Mosaic dialogs 
(such as the Open URL dialog) in the following format:
news:newsgroup.name
If you want to access a list of all the available newsgroups, from which you can select 
newsgroups, you would instead type
news:*



Note: The * wildcard can also be used to show subsets of newsgroups on the news server; for instance, 
news:alt.tv.* would show all the newsgroups with names starting with alt.tv, (like alt.tv.seinfeld or 
alt.tv.northern_exp), news:alt.* would show all of the alt newsgroups, etc.

By default, descriptions of all the newsgroups will be displayed when reading in a list of 
newsgroups; to disable this feature, uncheck Expanded News Listing in the Options 
menu.    Note that this unchecking this option will disable threading.
Once you're connecting to News using Mosaic, you will see news articles listed as bulleted 
items on the screen.

Reading News:

Mosaic will display only the last 20 of the articles in a newsgroup.    To see earlier articles, 
click on the "Earlier articles..." text.    Mosaic will display the preceding 20 articles.    You can 
move back to the last 20 messages again by clicking on the "Later articles..." text (you can 
also use the Forward and Back buttons on the Toolbar to achieve this).
Articles whose titles are not preceded by "Re:" are original "threads"    they represent the 
initial article on a particular topic.    Articles whose titles begin with "Re:" are responses to an
initial article.
SPRY Mosaic displays hyperlinks at the top of the screen to help you navigate through 
threads.    When you are viewing an article that is part of a thread, you will see either Next 
thread or Next article in thread and Previous article in thread, depending on where you are in
the thread.
To view an article, simply click on its title.    You will see hyperlink text in the references 
section, as well as in the beginning of the article itself.    Selecting this hyperlink text allows 
you to move to related articles in the news thread.    You can then use the Back button on 
the Toolbar to move back to the original article.

Posting/Following Up to News:

SPRY Mosaic now supports posting (and following up to) news articles.
When you are viewing a list of news articles in SPRY Mosaic, you will now see a Post to 
newsgroup hyperlink at the top of the screen.    Clicking on this hyperlink will produce a 
separate news posting dialog allowing you to post a news article.
Fill out a subject in this screen and type your news article.    You can drag and drop text files 
from Windows File Manager into your news article, if you wish.    To do this, drag the file and 
drop it into the text window of the Mosaic news dialog.    The text in the file you dragged and 
dropped will display in that window; you can then edit the text or add new text, as desired.    
Note: You can also indicate the MIME type of the item you dragged and dropped.    Currently, only text files are 

supported; text/plain will be selected by default.    You can change the MIME type to another text type, if 
desired.

When you are viewing an individual article in SPRY Mosaic, you will now see a Followup to 
message hyperlink.    This also allows you to post a news article, but will automatically 
include the text of the currently displayed article in your posting (using standard followup 
format).
You can also post a news article directly using a URL, with the following syntax:
newspost:newsgroupname{,newsgroupname,newsgroupname}{/followup}
where
newsgroupname is the name of the newsgroup you want to post to (you can specify multiple
newsgroups by separating them by commas)



/followup indicates that you want the posting to be a followup posting and include the 
currently displayed article text (if no article is displayed when you do this, no text will be 
included).
Examples:
newspost:alt.tv.seinfeld
newspost:rec.bicycles,rec.sports.cycling
newspost:alt.suburbia/followup
Sending Mail
You can use SPRY Mosaic to send mail if you have an SMTP Gateway available (this must be 
set up in the Configuration screen.)
You can send mail by choosing Open URL in the File menu, and typing
mailto:lucy@narnia.com
where lucy@narnia.com is the e-mail address you want to send mail to.
(You can also simply type this URL in the drop down URL list).
A screen will appear allowing you to compose a mail message.    Fill out a subject in this 
screen and type your mail message.    You can drag and drop text files from Windows File 
Manager into your mail message, if you wish.    To do this, drag the file and drop it into the 
text window of the Mosaic mail dialog.    The text in the file you dragged and dropped will 
display in that window; you can then edit the text or add new text, as desired.    
Note: You can also indicate the MIME type of the item you dragged and dropped.    Currently, only text files are 

supported; text/plain will be selected by default.    You can change the MIME type to another text type, if 
desired.



HTTP/0.9
Some older WWW documents may require you to use an earlier version of the Transfer 
Protocol, HTTP /0.9 to access them.    In most cases, the hyperlinks to those documents will 
warn you that HTTP /0.9 is required to read them.    SPRY Mosaic allows you to use this option
in order to read these earlier documents.



Saving Mosaic Documents
You might want to save WWW documents so that you could open them later (using the 
Open Local File command) or so that you can use the information in the documents (in 
word processing or other applications).    When you save documents, you will not save the 
text exactly as you see it on the screen; any graphics on the screen will not be saved, and 
the document will be saved with accompanying HTML codes.
There are several ways to save documents: you can drag and drop the document to the File 
Manager or another application that supports drag and drop, you can use Load to Disk Mode 
command to save the document to disk, or you can save the document source code to disk 
directly using the Document Source command.    These first two methods of saving 
documents are described below; the last method is described in the "Viewing Document 
Source" section.
____
See
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Using Drag and Drop in Mosaic
You can drag and drop Mosaic documents to the Windows File Manager, or to other 
applications that support drag and drop, such as Windows Notepad.
When your mouse cursor is over a hyperlink, click and hold down the mouse button until the 
cursor changes from a pointing finger to a document icon, with the caption WWW.    Continue
holding down the cursor, and drag the icon to the application where you want to drop the 
item. (If the application will not let you drop the item, the cursor will change into a 
prohibited symbol (a circle with a slash through it).
Note that not all applications will support drag and drop from Mosaic, even if they are OLE-
compliant (Windows Object Linking and Embedding).



Load to Disk Mode
You can also save Mosaic documents when you encounter them by using Load to Disk 
Mode.    Load to Disk Mode saves a document to a file, rather than loading it.    This is very 
useful if you want to save the contents of a document to use in another application, for 
instance, or if you find a file or resource that you currently can't use, but want to save.
Usually, you will want to use Load to Disk Mode selectively; you probably do not want to 
save everything you encounter to a file.    You use [Shift] click to do this. Click on the 
hyperlink for the document that you want to save, while holding down the [Shift] key.    
Instead of the document loading in, as it does normally, a standard Windows <File Save> 
dialog will appear, and you will be prompted for a name and location for the document.    You
can accept or change this name, and you can also change the directory where this 
document is stored.
If you prefer to have Load to Disk Mode turned on, so that Mosaic tries to save all of the 
documents that you click on, select Load to Disk Mode in the Options menu (a check 
mark will indicate that the mode is enabled).    When Load to Disk Mode is enabled, each 
time you try to access a document you will be prompted with a Windows <File Save> dialog 
as described above.
Mosaic will continue to try to save documents until you disable Load to Disk Mode by again 
selecting the Load to Disk Mode option from the menu. Note that whenever you use Load 
to Disk Mode, the documents that you click on will not be loaded; they will only be saved.    
To load in these items, you must turn off Load to Disk Mode (if you turned Load to Disk Mode 
on using the menu, you must disable it; if you simply Shift-clicked to save the document, you
only need to click on the item normally to get it to load).



Printing in Mosaic
You can print the information in a document to your printer using the Print command in the 
File menu.    If you want to see how the output will look, you can choose Print Preview to 
see a preview of how the document will print.
____
See
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Copy
The Copy command allows you to copy text from the Document Title: or Document URL: 
drop down lists.    It cannot be used to copy from the document you are currently viewing 
(you can, however, view the document using the Document Source command in the File 
menu, and use the Copy command in that window).
Once you have copied text, you can paste it in another Windows application using the Paste
command or shortcut in that application.
Likewise, you can also paste information into Mosaic dialogs (although there is no Paste 
command in the Edit menu).    After using the Copy command in Mosaic or another Windows 
application, you can use Windows shortcut keys, Ctrl-V or Shift-Insert, to paste text into 
any Mosaic dialog (a likely use would be to paste a URL from a mail message, for instance 
into the <Open URL> dialog).



Finding Text in a Mosaic Document
You can search a WWW document for particular text using the Find command.    Click the 
Find option in the Edit menu, and type the text you want to search for in the dialog that 
appears.    The search will occur from the top of the document to the bottom.    If you want to 
search for additional occurrences of the text, you should choose Find Next in the <Find> 
dialog after the first find.    .



SPRY Mosaic Menu Commands
File Menu 
Edit Menu 
Options Menu 
Navigate Menu 



File Menu
Open URL 
Open Local File 
Hotlists 
Print 
Print Margins
Print Preview 
Print Setup 
Document Source 
Exit 



Print Margins
This option allows you to specify the margins to use when printing Mosaic documents to a 
printer; by default, no margins are used.    Set the Top, Bottom, Left and Right margins to the
settings you prefer.



Print Setup
The Print Setup command allows you to specify which printer you want to print to. The 
standard Windows Print Setup dialog is displayed; see your Windows documentation for 
information on using this dialog.



Exiting Mosaic
You can exit SPRY Mosaic by choosing Exit from the File menu.    You can also double-click on the 
Windows System Menu to exit SPRY Mosaic.

Note: If you are currently retrieving a new Mosaic document, it is recommended that you wait until that document 
is retrieved, or stop retrieving the document by clicking the Stop button, before exiting Mosaic. 



Edit Menu
Copy
Find



Options Menu
Load to Disk Mode 
Autoload Inline Images 
Expanded News Listing
Kiosk Mode 
HTTP /0.9 
Configuration 
Toolbar Style 
Import NCSA Menu as Hotlist 



Expanded News Listing
This option affects how News is displayed in Mosaic.    When this option is checked, threading
will be enabled in News.    This option will also cause a full description of each newsgroup to 
be shown when you are viewing a list of newsgroups.
This option is enabled by default.



Navigate Menu
Back 
Forward 
Home 
Reload 
History 
Cancel Current Task 
Add Document to Hotlist 



Configuring SPRY Mosaic Options
You can easily configure SPRY Mosaic using the <Configuration> dialog.    This dialog allows 
you to specify options for displaying elements in the SPRY Mosaic Console, such as the 
Toolbar, Status Bar, images, hyperlinks, and sounds; the default servers for SPRY Mosaic; 
SPRY Mosaic's fonts and colors, and which external viewers are used to view graphics, and 
play sounds and movies.
The <Configuration> options are listed below.    Click the option for which you want help.
General Configuration Options 
Home Page
Email Address
SMTP Server
News Server
Viewers
Color
Fonts
Proxy Servers



General Configuration Options
The General Configuration options shown at the top of the <Configuration> dialog are 
described below.
Show Toolbar
Show Status Bar
Show Document Title
Show URL
Save last window position
Autoload inline images
Show URL in Status Bar
Underline hyperlinks
Animate logo
Use 8-bit sound 
When loading images, redraw after __ seconds 



Show Toolbar/Status Bar
These options control whether or not the Toolbar and Status Bar are displayed.    You may not
wish to hide the Status Bar as it displays the locations of resources you connect to, as well 
as indicating when a transfer is in progress or a graphic is being loaded.    By default, these 
options are displayed; check them again to hide them.
You can also hide most of the Console options by using Kiosk Mode.



Show Document Title/URL
These options control whether or not the Document Title: drop down list with the SPRY Mosaic radar 
indicator, and the Document URL: drop down list are displayed.    You can show both options, hide both 
options, or show only the Document Title Bar.    You cannot display only the Document URL: list.    By 
default, these options are displayed; check them again to hide them.



Save last window position
You may want to resize the SPRY Mosaic Console window during your SPRY Mosaic session, in order to 
see more (or less) of a WWW document.    If you want these size changes to be saved and used during 
your next SPRY Mosaic session, check this option.



Autoload inline images
By default, images (such as logos, fancy titles, small photos) are automatically displayed on your system 
when you connect to a World Wide Web site.    This is done by automatically downloading the image to 
SPRY Mosaic, where it is kept in your system memory.    This downloading process can be very time-
consuming, depending on the speed of your Internet connection.

SPRY Mosaic allows you to disable this feature, so that the images are not automatically 
downloaded/displayed.    Uncheck this option to stop viewing graphics.    In the place of the 
graphics, you will see graphic placeholders.



Show URL in Status Bar
By default, when you highlight a hyperlink (by moving your mouse over it), the destination URL for that 
hyperlink will be displayed in the Status Bar.

You can uncheck this option, if you choose.



Underline hyperlinks
Typically, hyperlinks are displayed in blue and underlined.    You may want to turn off the 
underlining. This is a personal preference; it will not affect the speed that the document is 
retrieved in any significant way.



Animate logo
This refers to the radar indicator on the Document Title Bar.    By default, this is turned on, as it offers you 
some useful information about whether or not a document or image is being retrieved (and gives your 
mind something to do while you waitalthough you can always work in other Windows applications if a 
document is loading too slowly).    The time you'll save by turning off the logo animation is not substantial; 
you will probably only want to turn off that option if your connection is very slow.

This option is primarily provided in case you are using a remote access program such as Symantec's PC-
Anywhere to use your PC remotely.    In these cases, the animated logo may cause problems; disable 
Animate logo by unchecking this option.



Use 8-bit sound
SPRY Mosaic features internal sound support for .AU and .AIFF files, using your sound card (if
you have one).    SPRY Mosaic assumes you have a high quality sound card.    If these file 
types do not play properly, or you have a lower quality (or 8-bit) sound card, choose this 
option.



When loading images, redraw every __ seconds
You can change how often the screen is redrawn by selecting Configuration in the Options
menu, and changing the When loading images, redraw every __ seconds option.    
When you connect to a Mosaic document, SPRY Mosaic loads in the entire document, using 
image placeholders for any images in the document.    SPRY Mosaic will then load in the 
images one by one, and redraw the screen (replacing the placeholders with images) as 
images are loaded in.    
Changing the redraw value will affect how the Mosaic document appears as it is loaded in.    
For instance, if you want SPRY Mosaic to load in most/all of the documents images before 
redrawing the screen, you would set this value to a high number (i.e. 5 seconds), to give 
SPRY Mosaic time to load in all the images.    If you want SPRY Mosaic to redraw the screen 
each time a new image is loaded in, set this value to a lower number (2 seconds, for 
instance).
The value you will want to use is also dependent on the speed of your connection.    If you 
are operating over a slow modem connection, images may not load in very quickly, and you 
may want to increase the screen redraw value to a higher number (so that the screen only 
redraws when new images are loaded in).
Another reason for changing this value:    if your SPRY Mosaic screen is redrawing the screen 
very often, you may find the flicker of your screen as the screen is redrawn to be annoying.   
If so, increase the value of the redraw option until you are happy with the screen 
performance.



Home Page
SPRY Mosaic lets you set up a default Home Page that you can quickly access using the Home button 
on the Toolbar.    Type the URL for the home page in the URL: field to set up this home page.    

You can also set up SPRY Mosaic to automatically load this Home Page on startup; if you 
want to see this home page whenever you start SPRY Mosaic, check the Load automatically 
at startup option.



Email Address/SMTP Server/News Server
These options are all used by SPRY Mosaic when you are using some of Mosaic's extended functionality. 
Mosaic can be used to read News (as well as view Gopher sites) and send mail messages.    

You must fill out some information about your system in order for these to work properly.

To send mail:

You must fill out your e-mail address and SMTP Server address.

Email address This is the address others use to send you e-mail, i.e. 
jwatson@moriarty.com.

SMTP ServerThis is the mail server you use.    A default mail server on the Internet has 
been supplied for you.    For optimum use, it is suggested that you use your 
own SMTP server.    Specify the address for the server.    This would be an 
address such as mailserv.oz.com.

To read news:

News ServerYou must fill out the address of your news server.    This is the machine that 
you connect to in order to read news.    A News server address is supplied by 
default.    This news server has a limited amount of newsgroups available.    If 
you have a news server you prefer to use to read news, type its name here.



Cached Documents
This item represents how many documents are cached, or kept active, in your PC's memory.    If this 
number is 10, for instance, 10 documents will remain "available" to you; if you go back to them, they will 
appear immediately, and will not have to be loaded.    

If you have a lot of available system memory, you may want to increase this number.    Keep 
in mind that a high number for cache may affect other applications' performance, although 
Mosaic performance will probably improve quite a bit.



Documents in Drop Down
This value indicates how many of your last-accessed documents will appear in the Document Title: and 
Document URL: drop down lists (displayed beneath the Toolbar).    A value of 5 would mean that the last 
five documents you accessed would display in these lists.



Configure Viewers
The <Configure Viewers> feature lets you specify the external viewers you want to use for different 
resource types that you might find on the World Wide Web.    For instance, you may find a multimedia 
movie in a WWW document, and want to set up Mosaic to use an external movie player application so 
that you can view the movie.    You can also use this dialog to set up applications to support telnet, 
tn3270, and rlogin.

Click on a topic below for more information.

____

See

Viewing Files in Mosaic 

Adding and Configuring Mosaic Viewers 



Viewing Files in Mosaic
SPRY Mosaic internally provides support for text, in-line graphics, and certain sound files 
(note: you must have a sound card or Windows sound player for sound).    However, some of 
the resources you encounter using SPRY Mosaic (GIF and JPEG files, MPEG movie files, .WAV 
sound files) will require you to use external viewers, separate programs that can view 
graphics, play movies, or otherwise interpret Mosaic resources.
Most commonly, you will need external viewers to:

> View GIF or JPEG image files
Some GIF (Graphics Interchange Format) format graphic images you find in Mosaic 
documents can be retrieved; these images are indicated by a hyperlink.    You will also often 
see hyperlinks to images like "Picture of the Louvre" or "LOUVRE.GIF".    GIF and JPEG are 
common image file formats used on the World Wide Web.
You can retrieve these images if you have an external image viewer that allows you to view 
the GIF or JPEG images.    SPRY Mosaic comes with an image viewer, ImageView, which 
will allow you to view GIF and JPEG graphic files automatically.    This Viewer is already set up
in SPRY Mosaic.

> Play .WAV sound files
If you have a sound card or Windows sound player application, you can play sounds that you
find on the World Wide Web.    SPRY Mosaic natively supports .AU and .AIFF sounds that are 
commonly found on World Wide Web home pages; this means that you do not need an 
external application to play them.
However, you will also find .WAV and MIDI files on FTP and Gopher sites on the World Wide 
Web.    You will have to use an external application to play these types of sound.    Microsoft 
Windows 3.1 and Windows for Workgroups 3.X include an application called Media Player 
that can play sounds if the necessary device drivers are installed; SPRY Mosaic is set up to 
automatically use this application to play sounds.

> View MPEG movie files
Multimedia movie files (MPEG files) are found in many places on the World Wide Web.    
Usually they are not identified    with any symbol, but are named with an extension of .mpg 
("mountains.mpg"), or otherwise identified as MPEG movie files.
SPRY Mosaic does not include an MPEG viewer.    You can use any Windows based MPEG 
viewer with SPRY Mosaic.    When you find an external MPEG viewer, you must set it up in 
SPRY Mosaic using the Configure Viewers feature.
____
See
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Adding and Configuring Viewers in Mosaic
SPRY Mosaic is set up to automatically use ImageView (included with SPRY Mosaic) to view 
GIF and JPEG files and to use Microsoft's Media Player application (which is included in 
Windows 3.1 and Windows for Workgroups in your Accessories Program Group) to play .WAV 
and MIDI sound files.    You can add and configure viewers for other resources that are 
recognized by Mosaic.
When you click on the Viewers button in the <Configuration> dialog, the <Configure 
Viewers> dialog will appear. This dialog allows you to change the viewers and tools that are 
used to access SPRY Mosaic resources.
When SPRY Mosaic is retrieving a World Wide Web document, it uses MIME (Multipurpose 
Internet Mail Extensions) information returned by World Wide Web servers to determine the 
format in which a document is stored and determine how to treat the document.    There are 
several standard MIME types recognized by Mosaic.
When a document is retrieved from an ftp server, gopher server, or local file system, on the 
other hand, the file extension (found in the hyperlink to the resource) is used to determine 
the proper MIME type for documents.

Adding a new viewer

In general, you should use the standard MIME types when you are configuring a new viewer 
for Mosaic.    SPRY Mosaic allows you to create your own MIME types, tell Mosaic what file 
extensions map to that type, and associate viewers with them, but if the document is being 
retrieved from an HTTP server, the file extension is ignored... so be careful when selecting 
MIME types to use the same types as the HTTP server.
For instance, if you have an MPEG movie viewer, you might want to set up that viewer in 
SPRY Mosaic so that Mosaic will automatically load MPEG resources into that viewer when 
you doubleclick on them.    The standard MIME type used for MPEG viewers is video/mpeg.
You would do this as described below.

Click the Add New Type... button.    A <Document Type> dialog will appear; type the 
standard MIME type that you want to use (in this case, video/mpeg).    The type you 
specify will now appear in the Type drop down list.
Now type any file extensions that map to that MIME type in the Extensions field (multiple
entries should be separated by a comma; e.g., ".MPG,.MPEG").
Now, enter the pathname to the viewer for this type in the Viewer: field, or click the 
Browse button to look for it with a standard Windows file search dialog.    (You might, for 
this example, specify "C:\VIEWERS\MPEG\MPEGPLAY".)
When you click Close to close the Viewer Configuration dialog, the new viewer 
information will be saved.    

Configuring an existing viewer

If the MIME type that you need a viewer for already exists, you can change the extensions 
for that viewer and the path and filename of the viewer, as described below.

Choose the MIME type for the document type from the drop down list.
Type the full path and filename of the viewer you want to use in the Viewer field, or click 
Browse to more easily find the viewer on your PC (when you locate the viewer, and click
OK, the Viewer field will be filled in automatically).
Add or edit any extensions for the MIME type, separating them with commas 
(i.e. .AU, .AIFF)



Click Close when you are done configuring viewers.    The changes will take place 
immediately.

You can also define the applications used by Mosaic for telnet, rlogin, and tn3270.    To do 
this, type the application you want to use in the appropriate field (click Browse to search 
your disk for the correct file and directory name).    When you Close the dialog, the changes 
you made will be saved.



MIME (Multipurpose Internet Mail Extensions)
MIME is a a general purpose encoding method for exchanging multimedia data over the 
Internet.    Use of MIME allows Mosaic to retrieve and recognize many different types of data. 
The most visible part of this MIME usage to you, the user, is the "Content-type".    MIME 
content types specify the format in which a document is stored.
MIME content types consist of both a type and a subtype; for example "image/gif" is a valid 
MIME content type.    "image" is the type, and "gif" is the subtype.    Valid types are:

· text Specifies textual information (may be formatted text, such as HTML.)
· image Specifies still image data.
· audio Specifies audio or voice data.
· video Specifies video or moving image data, possibly with audio (e.g. AVI 

files.)
· application Specifies application data (i.e., application-specific data.)

"multipart" & "message" are also valid MIME types, but these types are for internal use by 
the MIME parser and are not used or supported by SPRY Mosaic in this release.
The subtypes for any given type may also have some defined values. MIME types in common
use today and supported by SPRY Mosaic include:
text

plain Plain ASCII text
html HTML formatted text

image
gif CompuServe GIF format
jpeg JPEG compressed images
tiff Tagged Image File Format
targa AT&T TARGA format
x-win-bmp Windows Bitmap
xbm X Bitmap

audio
basic Sun/DEC/NeXT audio (*.AU files)
wav MS Windows WAVE (RIFF) audio
aiff Audio Image File Format

video
mpeg MPEG video
quicktimeApple QuickTime
msvideo Microsoft Video (*.AVI files)

application
zip PKZip compression format
postscriptAdobe PostScript (*.PS) format

You specify these MIME types in the Configure Viewers dialog in Mosaic by specifying first 



the type, a forward slash and then the sub-type, i.e. application/zip.
Non-standard types which do not fit under these defined subtypes can also be added by pre-
pending "X-" to the desired subtype name - e.g., "image/X-my-new-image-format" - but be 
careful!    If you are retrieving documents from an HTTP server, the server must be returning
this type to you, so adding a new type requires configuration on both the client (Mosaic) side
and the server. (This is not a concern for items you retrieve from ftp or gopher sites, since 
SPRY Mosaic then uses the extension to recognize the item; therefore you could create a 
new type without concern.    For example, you could create a type called image/X-TIF, for files
with a .TIF or .TIFF extension.)
When retrieving documents from a World Wide Web server (i.e., via HTTP),    SPRY Mosaic 
uses the MIME (Multipurpose Internet Mail Extensions) content type returned by the server 
to determine in what format a particular file is stored.
Note: More information about MIME can be be found in the Internet Request For Comments document RFC 1341 

(Using SPRY Mosaic, enter this URL: "ftp://DS.INTERNIC.NET/rfc/rfc1341.txt".).



Color
The Hyperlink color is the color that is used to highlight Mosaic hyperlinks (jumps to other documents or 
document areas, or jumps to resources).    Text hyperlinks are entirely highlighted, and graphics 
hyperlinks are surrounded by a highlight.    The standard Hyperlink color is blue.

To change the Hyperlink color, click Color.    The <Color> dialog will appear.
Select the color you would like to use for Hyperlinks, and click OK.    The Hyperlink color will be changed 
immediately.



Fonts
You can change the fonts that SPRY Mosaic uses to display documents.    You can change the 
font that is used for a particular item, or the font size.    You might want to do this to make 
documents easier to read, or to fit more information onto your screen.    
Different items in documents use different font styles (similar to styles in word processors).  
Most regular text is displayed in Normal style, and headers are displayed in a Header style, 
such as Header 1, Header 2, Header 3, etc.
You can change these font styles clicking the Fonts button.    You will see the <Fonts> 
dialog.
If you want to change just one style, you can choose the style that you want to change from 
the drop down menu, and define a Font for that style by clicking the Change Font button.
Specify the font type and style you want, and click OK.    The style will be changed until you 
change it again.
If you are not sure what style it is you want to change, you will have to do some 
experimenting.    SPRY Mosaic cannot tell you what styles are being used in a particular 
WWW document.
If you want to change all the styles in a document, you can choose Enlarge All or Reduce 
All to enlarge or reduce the styles.    You can choose this option as many times as you like.
Click OK when you are finished changing styles.



Proxy Servers
Proxy Servers are machines, usually doubling as Internet gateways, that allow you to send 
and receive information even though your network is protected with an Internet firewall.    
Requests for information are sent from your PC to the Proxy Server, and the requested 
information is sent back to the Proxy Server, which then sends it to your PC.    If your network
is protected by an Internet firewall, you will not be able to use SPRY Mosaic to access URLs 
outside your network unless your network uses Proxy Servers or the appropriate ports are 
enabled on your firewall.
SPRY Mosaic offers support for HTTP, ftp, WAIS, and Gopher Proxy Servers; currently only 
Proxy Servers based on the CERN specification are supported.
To set up SPRY Mosaic to use Proxy Servers, click the Proxy Servers button in the 
Configuration dialog.    You will see the <Proxy Servers> dialog.    Specify the URLs (with 
ports, where applicable) of Proxy Servers that you want to use.    SPRY Mosaic will then 
transfer information through those servers.
When retrieving HTML documents, SPRY Mosaic will go through an HTTP Proxy Server; when 
retrieving files via ftp, SPRY Mosaic will go through an ftp Proxy Server, etc.    These "servers"
are usually all on the same machine; therefore, all of the entries may be the same. 
For example, for your HTTP Proxy Server, you might specify http://proxy.circe.com:8001/
where proxy.circe.com is the name of your proxy server, and 8001 is the port used for the 
proxy service.

Using the Exclude Domain option

When you provide Proxy Server address information, SPRY Mosaic will always try to access 
information through those Proxy Servers.    However, there may be times you do not want 
SPRY Mosaic to use Proxy Servers; the Exclude Domain option in the <Proxy Servers> dialog 
allows you to do this.
For instance, if you are accessing information from your own network (such as ftp'ing files 
from another machine within your network), you will not want to go through the Proxy Server
to retrieve the information.    Also, if you have another domain within your organization that 
is also behind your Internet firewall, you may want to communicate directly with machines in
that domain, rather than going through the proxy server.
When you specify a domain in the Exclude Domain field, SPRY Mosaic will automatically try 
to connect to any URLs in that domain directly, not going through the Proxy Server.    
You can specify multiple domains in this field, separating them by commas.



Viewing Mosaic Document Source
A Document Source command is provided in the File menu to enable you to view, and 
save HTML document source code.    Click Document Source to view the current 
documents source code.    
You can now choose Save from the File menu to save the source code to a file.    Remember
that all the HTML codes will also be saved.    You will be prompted for a name for this file.
You can also choose Copy from the Edit menu to copy some or all of the HTML text to the 
Windows Clipboard, so that it can be used in other applications.    (Use the Select All 
command to select the entire document.)



Mosaic Command Line Options
SPRY Mosaic supports three command line options:    opening a URL (Uniform Resource 
Locator) or local HTML file, starting Mosaic in Kiosk mode, and specifying the INI file for 
Mosaic to use for configuration.    
You can, if you want, change the Properties setting for the SPRY Mosaic icon to have the 
command line options take place every time you click on the icon.    (This is not 
recommended when using the options to open a URL or local HTML file; see the note below).
Command Line Options

Opening a URL or HTML file upon startup:
AIRMOS.EXE {URL}
(example:  AIRMOS.EXE http://www.wired.com)
or
AIRMOS.EXE {local HTML file pathname}
(example:  AIRMOS.EXE c:\wwwdemo\mydemo.htm)
This option will automatically open SPRY Mosaic and connect to the URL or local HTML file 
that you specify.
Note: If you want to connect to the same URL or HTML every time you start SPRY Mosaic, it is    much easier to 

specify a default home page in Mosaic than to use the command line option.    See Configuring SPRY 
Mosaic Options    for more information on specifying a default home page.

Running SPRY Mosaic in Kiosk mode:
AIRMOS.EXE -K
This will start SPRY Mosaic in Kiosk mode, hiding the Menu Bar, Toolbar, Document Title Bar, 
and Status Bar, and displaying only the World Wide Web document you are currently 
viewing.  See Using Kiosk Mode for more information on using Kiosk Mode.

Specifying the AIRMOS.INI file to use:
AIRMOS.EXE -I {full path to INI file}   
Example:  AIRMOS.EXE -I C:\MOSAIC\AIRMOS.INI
This allows you to specify the location of the AIRMOS.INI file you want to use.    By default, 
Mosaic uses the AIRMOS.INI file found in your Windows directory.    Although it is easy to 
make changes to the SPRY Mosaic configuration, there may be some reason you want to 
have multiple configurations of Mosaic available; you you can use this option to do so.    To 
create another configuration of SPRY Mosaic, configure SPRY Mosaic the way you want it, 
and then copy the AIRMOS.INI file to a directory other than your Windows directory.    Any 
further configuration you make will affect the AIRMOS.INI file in the Windows directory; you 
can then switch to the other configuration by using the command line option, above.



Special Mouseclick Features
SPRY Mosaic supports the following modifiers when accessing hyperlinks using the mouse.
Shift-Click
If you hold down the [Shift] key while clicking on a hyperlink, SPRY Mosaic will automatically 
try to save the indicated resource to disk (this is equivalent to having Load to Disk checked
on before accessing the resource).
Ctrl-Click
If you hold down the [Ctrl] key while clicking on a hyperlink, SPRY Mosaic will retrieve header
information for the indicated resource; i.e. the resource type, size, full pathname, etc.    This 
is a good way to decide whether you will want to load in a resource (and whether you have 
the appropriate viewers for it), before actually loading it.
Right Click
If Autoload Image is off, clicking the right mouse button when the cursor is over an 
unloaded image will display the "hidden" image.
Ctrl-Right Click
If you hold down the [Ctrl] button while clicking the right mouse button when the cursor is 
over an unloaded image, the header information for the indicated resource will be displayed;
i.e. the image type, size, full pathname. As with Ctrl-Click, above, this is a good way to 
decide whether you want to load in an image before actually loading it.
 




