
Reviewer’s Guide
VMware 2.0 for Windows NT
and Windows 2000

™

RG20W 20000424



Reviewer’s Guide
VMware 2.0 for Windows NT and  Windows  2000 1

Copyright © 2000 VMware, Inc. All rights reserved.

Reviewer’s Guide
VMware 2.0 for Windows NT and Windows 2000
Welcome to the reviewer’s guide for VMware™ 2.0 for Windows NT® and Windows® 2000. On the 
following pages you will fi nd several exercises to assist you with the installation, confi guration, and 
evaluation of our new product. We thank you for your time and hope you enjoy reviewing and using 
VMware 2.0 for Windows NT and Windows 2000.

Most of the exercises in this guide are designed so you can work through them on a stand-alone 
computer. The fi nal exercise, which simulates a tech support environment, assumes that you have a 
network connection to a computer where you can store one or more large fi les — about 500MB each. 

You can fi nd extensive product documentation in the support section of the VMware Web site at 
http://www.vmware.com/support/.

If you encounter any issues in using the product, please contact pr@vmware.com.
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About VMware
VMware is an application that gives you a fully functional PC in a window. Each of these fully functional 
PCs is a virtual machine, running directly on your host computer. With these virtual machines, VMware 
delivers fl exible computing. That means

• Support organizations can save money by reproducing multiple end-user environments on a 
single PC.

• Developers and QA departments can test across a wide range of operating systems and PC 
confi gurations with much less investment in hardware and setup time.

• Linux users can run Windows applications on Linux.

Multiple virtual machines can run side-by-side. For example, users can simultaneously run Microsoft® 
Windows 95, Windows 2000, and Linux®.

With VMware, sharing fi les is easy — it works just as it does on any PC. VMware also lets you cut and 
paste from one virtual machine to another and between virtual machines and the host computer.

Instant Restore brings back the state of a running virtual machine in seconds. You can pop in and out of 
applications in a virtual machine as you need them — without going through a full boot cycle.

VMware’s virtual disks allow new operating systems to be added without repartitioning. Virtual disks 
can be shared from a repository on a network fi le server — saving administration costs and storage 
overhead.

VMware supports full-screen, full-color graphics. Users are not limited to 256 colors. When running 
virtual machines, users can switch between full-screen mode and windowed mode with a hot key.

Each virtual machine is independent from the host computer — operations done in the virtual machine 
will not affect the host. A “blue screen of death” in a virtual machine won’t affect the host computer 
at all.

VMware delivers all of these features in an easy to install and manage package. It’s powerful stuff.

What’s New in Version 2.0?

With this new release, VMware improves the performance of virtual machines and adds a number of 
features to provide greater power and fl exibility to users.

• Suspend to disk and Instant Restore let you put your virtual machine to sleep, then wake it 
quickly when you need to use it again. Your virtual machine picks up right where you left 
off, with the same applications and documents opening, and there’s no wait for the virtual 
machine to boot up.

• Bidirectional parallel port support lets you use devices ranging from scanners and digital 
cameras to dongles with suitable programs running in a virtual machine.

• SCSI support allows you to defi ne virtual disks and CD-ROM devices as either SCSI or IDE, 
providing added fl exibility for users who need to test software in a variety of confi gurations.

• Removable devices may be disconnected while the virtual machine is running. You can also 
disconnect the device and edit its properties, then reconnect it.  

• VMware Tools for Linux and VMware Tools for Windows are installed from fl oppy image fi les 
that are included in the product.

• Shrink disk lets you reclaim space that’s not being used in a virtual disk fi le.

• Direct serial connections are supported.

• Sound input is supported and sound output is improved.

• Raw disk support is improved.
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Why use VMware?

The list of very practical uses of VMware is long, but here is a sample of users who may want to run 
multiple operating systems: 

• Software developers who write software for different kernels or operating systems.

• Software developers and quality assurance staff who need to run different service pack levels 
for software testing.

• Web developers who want to install different Microsoft Internet Explorer versions in each 
virtual machine for Web site testing. Different Internet Explorer versions cannot be installed on 
a Windows operating system because of system registry confl icts. 

• Technical and customer support staff who want to maintain multiple virtual machines, each 
confi gured to match different end-user operating systems and applications confi gurations. They 
can then quickly switch to whatever environment they need to try to reproduce a problem or 
work with a customer. 

• Corporate IT organizations that insist users run the corporate “standard desktop” yet also allow 
users to install their own applications in a virtual machine “secure sandbox” without affecting 
the standard desktop. 

Who Uses VMware?

• Over 300,000 users worldwide.

• Users at IBM, HP, Rational, and Lucent access Windows applications from Linux.

• Network Associates, LinuxCare, and Excel.Net use VMware to improve technical support and 
help desk operations.

• Over 600 universities and research institutions use VMware.

The VMware product line

VMware, Inc. currently produces two products. VMware 2.0 for Windows NT and Windows 2000 
runs on Windows NT and Windows 2000 host computers. Users with Linux host machines can take 
advantage of this breakthrough virtual machine technology in VMware 2.0 for Linux. 
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Exercise I
Installing and Getting Started with VMware 
Total estimated time to complete : about 85-90 minutes 

Introduction 

This exercise starts with installing VMware and follows through to completing the installation of a guest 
operating system. . This is the longest of all the exercises, and most of that time is taken in installing 
a guest operating system inside a virtual machine. You’ll need just a little longer to install a guest 
operating system in a VMware virtual machine than on a native host computer. 

To get a jump-start, you can skip the installation steps and instead use a VMware Ready to Run 
virtual machine. Ready to Run virtual machines featuring several Linux distributions are available on 
CD-ROM. It takes about fi ve minutes to set up a Ready to Run virtual machine.

Exercise I follows through the steps needed to get a VMware virtual machine and guest operating system 
installed, confi gured, and running. This exercise is divided into fi ve parts: 

• Installing VMware
Time needed: about 10 minutes

• Confi guring a Virtual Machine Using the VMware Confi guration Wizard
Time needed: about 5 minutes

• Installing a Windows 2000 Guest Operating System
Time needed: about 60 minutes

• Installing VMware Tools for Windows
Time needed: about 10-15 minutes

• Using the Virtual Machine  

We recommend that reviewers complete at least this fi rst exercise. 

A very quick way to install a guest operating system in a virtual machine is covered in Exercise IV, which 
simulates a tech support environment. In Exercise  IV, you will use the virtual disk you create in Exercise 
I to conduct an almost-instant installation of a guest operating system over a network connection. 

VMware for Windows NT and Windows 2000 can be installed on computers running Microsoft® 
Windows NT 4.0 SP3 or later or on Windows 2000 RC3 or later. To make things easier to follow, 
we assume that you are working on a system running Windows NT 4.0. It is also possible for a 
technical reviewer to work on a Windows 2000 host system and use this document as a general guide, 
referring also to the Windows 2000 host installation instructions at http://www.vmware.com/support/
win/doc/quickstart_w2k/.

Note: The VMware installer currently cannot automatically install support for host-only networking 
on Windows 2000 hosts. VMware is working with Microsoft to resolve this problem. Exercise 
III on virtual networking assumes you have support for host-only networking confi gured. If you 
want to conduct Exercise III and are running on a Windows 2000 host, follow the instructions at 
http://www.vmware.com/support/reference/win/hostonly_w2k.html to manually install support for host-
only networking. 

Exercise I (B) steps through installing Windows 2000 as a guest operating system inside a virtual 
machine. You will need a Microsoft Windows 2000 (RC3 or later) installation CD-ROM to work 
through this exercise. 

Note: If you attempt to install a guest operating system from an OEM distribution or recovery CD-ROM 
that came with your computer, you should be aware that a few of these OEM CD-ROMs have device 
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drivers specifi c to the hardware they came with and may fail to install within a virtual machine. Even 
though the CD-ROM may be compatible with the actual host hardware, it may not be compatible 
with the generic PC environment within the virtual machine. If the installation process fails with 
errors about incompatible hardware, you should try installing from a genuine Microsoft retail Windows 
2000 CD-ROM or installing another operating system such as Windows NT 4.0 or Windows 98. In 
that case, follow along with the instructions in the exercises as a general guide to what steps to take, 
even if the details are different. Also refer to the detailed guest operating system installation notes at 
http://www.vmware.com/support/win/doc/guest_os_win.html. 

System Requirements

VMware for Windows NT and Windows 2000 requires a host computer that meets the following system 
requirements:

• Standard uniprocessor or MPS (multiprocessor system) compliant PC, including laptop com-
puters 

• Intel® Pentium® II, 266 MHz or faster, or compatible processor

• 96MB or more memory recommended

• A graphics display capable of displaying more than 256 colors (greater than 8-bit display depth) 

• Microsoft Windows NT 4.0 SP3 or higher operating system or Windows 2000 RC3 or RTM

• 10MB of available disk space for installing VMware

• At least 500MB of free disk space for installing a guest operating system and applications

• Optional: Microsoft Internet Explorer 4.0 or higher required for online help. VMware will 
install and work on a PC without Internet Explorer 4.0 or higher, but the context-sensitive 
HTML-based help will not be available. 

The exact amount of memory required by VMware is really dictated by the guest operating system and 
applications that the user will run within a virtual machine. For most desktop applications 128MB is a 
good starting point if you are running one virtual machine and have applications active in the virtual 
machine and on the host. 

Typical personal computers today — especially those used by power users, software developers, and 
similar users — exceed the minimum recommended requirements for VMware. Pentium III based PCs 
running at 600 MHz are common among power users, and Celeron™ PCs running at 400 MHz or faster 
power many sub-US$1,000 PCs. Please be sure that the computer you are using to review VMware meets 
the minimum requirements. VMware does not run on non-x86 architecture computers such as Apple 
Power Macintosh or Sun Microsystems workstations. 

Note: Some Cyrix processors such as the Cyrix 5x86 are not strictly compatible with the Pentium proces-
sor and do not include a Pentium processor instruction required by VMware. Later Cyrix processors 
do work with VMware. 

Exercise I (A)
Installing VMware 

Estimated time to complete: about 10 minutes 

Prerequisites: You will need both the VMware installer and a license key for this version of the product. 
(Licenses for VMware 1.x for Windows NT and Windows 2000 will not work with VMware 2.0 for 
Windows NT and Windows 2000. Also, licenses for VMware for Linux do not work with any version of 
VMware forWindows NT and Windows 2000.) You will fi nd links to download the software and register 
for the evaluation license key at http://www.vmware.com/download/download_win_pre.html.

Note: If you are currently using VMware 1.x for Windows NT and Windows 2000 on your test 

If you upgrade
If you’re already using 
VMware on your test 
computer, be sure to 
read the downgrade 
information on the 
VMware Web site before 
installing VMware 2.0.
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computer and think you may wish to return to that version after testing VMware 2.0 for Windows 
NT and Windows 2000, review the downgrade instructions at http://www.vmware.com/support/win/doc/
beta_win/downgrade_win_beta.html before you install the new version. 

Installing VMware is simple — much like installing any other application on your computer. The follow-
ing assumes that you are installing VMware 2.0 for Windows NT and Windows 2000 on a Windows NT 
4.0 host computer. The process is the same whether you are using an installer fi le downloaded from the 
VMware Web site or one from the CD in the packaged distribution of the product. 

1. Log on to Microsoft Windows NT as an administrator or equivalent. 

2. From the Start menu, select Run and browse to where the VMware installer is stored. 

3. Select and open the fi le, then click OK at the Run dialog. 

4. You are presented with the Welcome screen. 

5. Click Next. 

6. Acknowledge the end user license agreement (EULA). 

7. Choose the directory in which to install VMware. If you prefer to install it in a directory other 
than the default, you may click the Browse button and change to your directory of choice. If the 
directory does not exist, it will be created for you. 

8. Type the name of the Start menu program folder or choose an existing one. The default is 
VMware.  

 
 Figure 1 - 1 

9. Select the type of networking support that you wish to provide to your virtual machines: 

• Connect directly to a local network via an Ethernet network adapter card. 

 Choose this option if you have an Ethernet card in your PC and wish to connect your 
virtual machines to the local area network that your Ethernet card is connected to. This 
option is also referred to as “bridged networking.” 

 Note: If your PC has more than one Ethernet card or has been confi gured for Dial-Up 
Networking, you will be prompted later to select which network card to use to connect the 
virtual machines to the network. 

• Connect the guest operating system to the host computer internally. 

 This option allows your virtual machines to communicate with each other and with the 
host even if you do not have an Ethernet card in your PC. 

 You may also use this option if your network adapter is something other than an Ethernet 
card. 

 This option is ideal for standalone PCs in a home offi ce or a lab environment. This option 
is also referred to as “host-only networking.” 

• If you do not select any options, network connectivity will not be available to your virtual 
machines. This is also referred to as “no network.” 

10. You are prompted with the option to disable the CD-ROM autorun feature. Doing so will 
prevent undesirable interactions with the virtual machines. 

11. You are given the option to have a shortcut created for you on your desktop. Answer Yes so you 
will have easy access to VMware directly from the desktop in later exercises.  

Networking note
For most of the exer-
cises in this guide, you 
do not need a connection 
to an external network. 
Some do not involve any 
network activity. Others 
can use a virtual net-
work running entirely on 
the host computer.
The fi nal exercise calls 
for a connection to an 
external network.
In the installation and 
confi guration instruc-
tions we suggest that 
you install all the 
VMware networking 
capabilities and initially 
confi gure your virtual 
machine for host-only 
networking.
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 Figure 1 - 2 

12. Finally, you are prompted to reboot your PC.It is important that you do so to allow VMware 
to complete the installation correctly. 

Installing the VMware License

After restarting your computer, you will need to install the VMware license. 

The license you received is in the format of a registry fi le. Save it to a directory of your choice on 
your host computer. To install it, simply use Windows NT Explorer to browse to the directory where 
you saved the license fi le, then double-click it. This will merge the content of the license fi le into your 
Windows NT 4.0 registry. 

Exercise I (B)
Confi guring a Virtual Machine 

Estimated time to complete: about 5 minutes 

You may start VMware by double-clicking the VMware shortcut on your desktop. 

1. Start the confi guration wizard. 

 When VMware is executed, the startup screen has three options: 

• Run the Confi guration Wizard. 

• Run the Confi guration Editor.

• Open an existing confi guration.  

 
 Figure 1 - 3 

 The default selection is Run the Confi guration Wizard. Clicking the OK button starts the 
Confi guration Wizard. The Confi guration Wizard can also be started from the File menu 
(select File > Confi guration Wizard). 

 Clicking the Help button will open a pop-up window with context-sensitive help. That text will 
also include links to relevant help topics (text in blue — clicking on it will take you to the 
corresponding help topic). 

2. Select an operating system. 

 The fi rst screen asks which operating system will be installed in the virtual machine. The 
confi guration wizard uses this information to select appropriate default values, such as the 
amount of memory needed. The wizard also uses this information when naming associated 

Defaults
The default settings will 
give good results for a 
general-purpose confi g-
uration. For purposes of 
these exercises, there 
are a few places where 
you should select dif-
ferent settings. We will 
highlight those special 
cases.
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virtual machine fi les. 

 If the operating system you are using is not listed, select Other. 

 For the purposes of this exercise, select Windows 2000. 

 Selecting a Directory for the Virtual Machine

 Each virtual machine should have its own directory. All associated fi les, such as the confi gura-
tion fi le and the disk fi le, are placed in this directory. This screen lets you select the virtual 
machine’s directory. 

 The default location for this exercise is the directory 
C:\Program Files\VMware\VMs\Win2000. 

 Virtual machine performance may be slower if your virtual hard disk is on a network drive. For 
best performance, be sure that the virtual machine’s directory is on a local drive. 

3. Select the disk type. 

 For this exercise select Virtual Disk. 

4. Select the size of the virtual disk. 

 Fill in the size of the virtual disk that you wish to create. For this exercise, use the default of 
2000 (megabytes). 

 
 Figure 1 - 4 

 Windows 2000 requires the use of a CD-ROM for installation. 
For the purposes of this exercise, select the “CD-ROM Enabled Using Drive” option. 
Leave this option set to auto detect.
Also leave the option to “Start the virtual machine with the CD-ROM connected” checked. 

 If you have more than one CD-ROM installed on your machine, you may select which drive 
letter to use. Otherwise, you may leave the option set to auto detect. 

 Even if the virtual machine has CD-ROM access enabled, you can disable access to the 
CD-ROM device later during the operation of the virtual machine by using the Devices menu. 
This is useful if you wish to control which of several running virtual machines is allowed to 
access the CD-ROM.  

6. Enable the fl oppy disk drive.  

Set disk size 2000
The size you set in this 
step limits the maxi-
mum size of the virtual 
disk. The actual fi le on 
your host machine will 
initially be quite small. 
It will grow as needed 
to hold the operating 
system, applications, 
and data fi les. Once this 
size is set, it cannot be 
changed.
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 Figure 1 - 5 

 Select the “Floppy Enabled” option and choose the drive letter that corresponds to your physical 
fl oppy drive. 

 Note that some operating systems may require the use of a fl oppy drive during installation. 

 Even if the virtual machine has fl oppy disk access enabled, you can disable access to the fl oppy 
disk device later during the operation of the virtual machine by using the Devices menu. This 
is useful if you wish to control which of several running virtual machines is allowed to access 
the fl oppy disk. 

7. Confi gure the networking capabilities of the virtual machine.  

 
 Figure 1 - 6 

 For this exercise, select Host-only Networking.

 This screen lets you select the option that applies to this virtual machine. See Exercise III for 
more details about VMware networking options. 

8. Review and fi nish the confi guration:  

 
 Figure 1 - 7 

 This fi nal screen presents you with all the options that you have selected. Review it for accuracy 
and click Finish to complete the virtual machine confi guration. 

 If you want to change any of these settings, the Back button will take you to the earlier screens, 
where you can make the changes. 

 Note that most confi guration settings can be viewed and modifi ed using the Confi guration 
Editor, which you can fi nd on the Settings menu (Settings > Confi guration Editor). 

Self-contained 
virtual network
For most uses, connect-
ing directly to the exter-
nal network (bridged 
networking) is the sim-
plest choice. However, 
selecting host-only net-
working in this step pre-
pares you for Exercise 
III, which lets you 
explore VMware net-
working without a con-
nection to a physical net-
work.
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Exercise I (C)
Installing a Windows 2000 Guest Operating System 

Estimated time to complete: about 60 minutes 

To install the operating system on your virtual machine, you may follow this procedure: 

1. Insert the Windows 2000 CD in your CD-ROM drive.  

 
 Figure 1 - 8 

2. Power on the virtual machine (by clicking the Power On button). You will see the VMware 
BIOS identifi cation, and the virtual machine will run the power on self test.  

 
 Figure 1 - 9 

3. The virtual machine will boot from the Windows 2000 CD-ROM and Windows 2000 Setup 
will start. 

4. Click anywhere inside the virtual machine window and continue installing Windows 2000 
on the virtual machine in the same manner you would on a physical PC, with the following 
considerations: 

a. During this session, the keyboard and the mouse are grabbed by the virtual machine. 
If you need to release the cursor, you may do so by selecting the Ctrl-Alt-Esc keyboard 
combination.  

b. Note that Windows 2000 Setup will detect the virtual devices rather than the physical 
devices installed in your computer.  
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  Figure 1 - 11 

c. When fdisk displays your hard disk information, it is actually referring to the virtual disk 
rather than your physical hard disk. Partitioning and formatting the virtual disk will NOT 
affect your physical hard disk partitions.   

Exercise I (D)
VMware Tools for Windows 

Estimated time to complete: about 5 minutes 

Prerequisites: complete Exercises I (A) through I (C) 

Introduction to VMware Tools 

With the VMware Tools SVGA driver installed, VMware supports up to 32-bit displays and high display 
resolution, limited by the capabilities of the host computer’s display adapter. The VMware SVGA driver 
will also make use of 2-D hardware acceleration, signifi cantly speeding up overall graphics performance 
within a virtual machine. 

In addition to the SVGA driver, the VMware Tools package includes a small background VMware Tools 
utility that implements the following features: 

• Text buffer for cut and paste between virtual machines and the host operating system and 
among virtual machines 

• Control of the VMware mouse cursor behavior, allowing you to move the mouse cursor freely 
from the virtual machine window to the host machine’s display and back 

• The ability to connect VMware removable devices (such as fl oppy and CD-ROM drives) to the 
virtual machine — and disconnect them — from within the guest operating system 

• The ability to shrink the virtual disk fi le to reclaim unused space

• Time synchronization between guest and host

These enhancements are available only when VMware Tools is running. 

Installation fi les for VMware Tools for Linux and VMware tools for Windows are built into VMware 
(Settings > VMware Tools Install). 

Installing VMware Tools for Windows 

The following instructions assume that this is the fi rst time you have installed and confi gured VMware 
on the computer you are using for these exercises. If you previously installed an earlier version of 
VMware and wish to use a virtual machine you defi ned at that time, be sure that VMware Tools is not 
running when you install the upgrade.

Tools needed for 
best performance
It is very important that 
you install VMware 
Tools in the guest oper-
ating system. 
Although VMware will 
run a guest operating 
system even if you do 
not install VMware 
Tools, the graphics envi-
ronment within the vir-
tual machine will be 
limited to VGA mode 
(640x480, 16 color). The 
graphics within the vir-
tual machine will also 
be slow and make no use 
of any hardware accel-
eration. This graphics 
slowdown can make the 
virtual machine annoy-
ingly slow. 
VMware Tools are 
available for:
• Windows (Windows 95, 
   Windows 98, Windows
   NT 4.0, and Windows
   2000 all use the
   same VMware Tools)
• Linux
• FreeBSD

Fdisk, format
You need to run fdisk 
and format during the 
installation, as if you 
were preparing a new, 
unformatted hard drive. 
These steps affect only 
your virtual disk, which 
is contained in a fi le 
on your host computer’s 
fi le system. They do not 
repartition or reformat 
the physical hard disk on 
your host computer.
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To install VMware Tools in a Windows guest operating system: 

1. Power on the virtual machine. 

2. Prepare your virtual machine to install the VMware Tools.
Choose Settings > VMware Tools Install

3. Answer Yes when asked if you want to view the instructions.

4. Double-click the My Computer icon on your desktop. 

5. Double-click the A: drive. 

 
 Figure 1 - 11

6. Double-click VMwareTools.exe and follow the instructions. 

 
 Figure 1 - 12 

Instructions for confi guring the video driver will open automatically in Notepad at the end of 
the installation process. If the Notepad window is hidden, bring it to the front by clicking the 
Notepad button on the Windows 2000 taskbar.

7. The VMware Tools background application will be launched automatically when you reboot 
the virtual machine.

8. After restarting the Windows 2000 virtual machine, open the device manager and verify that 
the display adapter is VMware SVGA.

 You should notice the presence of a Standard PCI Graphics Adapter too.
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Confi guring VMware Tools

VMware Toolbox is loaded on startup and its icon appears in the system tray. 

To confi gure VMware tools: 

1. Right-click the VMware Tools icon in the system tray.  

 
 Figure 1 - 13 

2. Click Options ... . (The above two steps can be achieved by double-clicking the icon in the 
system tray.) 

 
 Figure 1 - 14 

3. The VMware Toolbox cursor options are: 

• Release input focus when the mouse leaves the virtual machine

• Capture input focus when the mouse enters the virtual machine 

• Scroll when mouse nears edge of the virtual machine 

• Hide cursor when the virtual machine loses input focus 

• Bring the virtual machine to top when it gets input focus

 The VMware Miscellaneous Options are:

• Allow copy and paste to and from the virtual machine

• Time synchronization between the virtual machine and the host operating system (new 
feature in this release) 
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 Figure 1-15

4. The Devices tab of the VMware Toolbox options allows you to enable or disable removable 
devices. (You can also set these options by right-clicking the VMware Tools icon in the system 
tray, then clicking Devices, or navigate to them from the Devicess menu of the VMware 
application.) 

 
 Figure 1-16

5. The Shrink tab gives you access to the settings you need if you wish to reclaim 
unused space in a virtual disk.
Note: Shrinking a virtual disk may be a time-consuming operation.

Exercise I (E)
Using the Virtual Machine

Shutting Down a Virtual Machine 

To shut down a virtual machine, you may follow this procedure: 

1. Select Shut Down from the Start menu of the guest operating system (inside the virtual 
machine). 

2. Select “Shut down the computer.”  
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 Figure 1 - 17 

3. When you see the dialog saying it is safe to turn off your computer, click the VMware Power 
Off button. 

4. Now it is safe to exit the VMware application. 

Starting a Virtual Machine 

To start the virtual machine that you confi gured above: 

1. Start VMware by double-clicking the shortcut on your desktop.  

 
 Figure 1 - 18

2. Highlight the virtual machine confi guration fi le listed under “Or select a fi le from the most 
recently used fi les list” (in our exercise this fi le is called Win2000.vmx), then click OK.  

 
 Figure 1 - 19 

3. Click the Power On button to power the virtual machine on. 

Another method to start the virtual machine: 

1. Start the Windows NT Explorer and browse to the directory c:\Program Files\VMware\
VMs\Win2000.  
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 Figure 1 - 20

2. Double-click on the Win2000.vmx icon or fi le name. 

• Optionally, you may create a shortcut for the VMX confi guration fi le on the desktop or 
in a folder of your choice. 

3. Click the Power On button to power the virtual machine on. 

Using Suspend and Instant Restore

In VMware 2.0 for Windows NT and Windows 2000, you can now save the current state of your virtual 
machine to disk. Then the new Instant Restore feature lets you quickly pick up work right where you 
stopped — with all the applications and documents you were working on open and at the ready.

The speed of the suspend and restore operations depends on how much has changed during your 
working session. In general, the fi rst suspend will take a bit longer than later suspends do. 

To suspend a virtual machine:

1. When the virtual machine you started in the last section is running, open WordPad.
Start > Run 
WordPad

2. Type in a few words.

 
 Figure 1 - 21

3. If your virtual machine is running in full-screen mode, return to window mode by pressing 
the Ctrl-Alt-Esc key combination.

4. Click Suspend on the VMware button bar.

Quick switch
If you have several vir-
tual machine confi gura-
tions suspended to disk,  
you can move quickly 
from one to another.
Click Suspend to save 
the state of the current 
virtual machine. Then 
use File > Instant 
Restore VMs to display a 
list of quickly available 
virtual machines.
Or if you want to have 
both virtual machines 
running at the same 
time, just launch a new 
instance of VMware.
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 Figure 1 - 22

5. Quit VMware.
File > Exit

To restore a virtual machine that you have suspended:

 
 Figure 1 - 23

1. Start VMware and choose the virtual machine you just suspended. The process is the same as 
that described in steps 1–3 of Starting a Virtual Machine above.

2. Click Resume on the VMware button bar.

 
 Figure 1 - 24

3. Note that WordPad is running and the text you typed before suspending the virtual machine 
is displayed.
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Exercise II
VMware Virtual Machine Sharing and Isolation 
Estimated time to complete: about 15 minutes 

Introduction to VMware Virtual Machine Isolation 

VMware virtual machines provide a high degree of isolation from other virtual machines and from 
the host operating system. Installing software in the virtual machine, accidentally infecting a virtual 
machine with a computer virus or even having a virtual machine crash will not affect other virtual 
machines or the host operating system. 

Although it provides a high level of isolation, VMware still allows convenient sharing when a user 
desires, including cutting and pasting, networking, and fi le sharing between virtual machines and the 
host operating system or between two or more virtual machines. 

Exercise II (A) demonstrates simple sharing using cutting and pasting between virtual environments. 
In a later exercise you can see other forms of sharing between environments with VMware virtual 
networking and fi le sharing. 

Exercise II (B) demonstrates the robust isolation provided by VMware by deliberately crashing the 
Windows 2000 guest operating system without affecting the operation of the host operating system. 

Prerequisites 

• Exercises I (A) through I (D) completed 

• A fl oppy disk drive in your computer and a blank, formatted fl oppy disk 

• Access to the Web to download the VMware bluescreen software 

Exercise II (A)
Cutting and Pasting 

The VMware Tools installed in Exercise I (D) provide the capability to cut and paste between one virtual 
machine and another or between a virtual machine and the host operating system. In this exercise we 
will use a very simple example of copying and pasting between Microsoft WordPad and Notepad on the 
host and guest operating systems. 

VMware’s copy and paste functions allow a user to use the native copy and paste methods for a 
particular operating system. Because we are using Windows operating systems in both the guest and 
host operating system environments, the same method is used in both environments. If the guest 
operating system were Linux, then X window-style cut and paste using the mouse buttons would work 
within the virtual machine. 

1. Start VMware and power on the Windows NT 2000 guest operating system if it is not already 
running. 

2. Log in to Windows 2000 running inside the virtual machine as any user. 
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 Figure 2 - 1

3. Check to be sure VMware Tools is running in the guest operating system. There will be a 
tools icon in the system tray (the default position is the right end of the taskbar) in the guest 
operating system. 

4. On the guest operating system select Start > Run and enter WordPad. 

5. Start typing any text into WordPad. 

 
 Figure 2 - 2

6. Select a range of the text you have entered and copy the text using Ctrl-C or the Edit > Copy 
menu item. 

7. On the host computer select Start > Run and enter Notepad. 

 
 Figure 2 - 3

8. Click inside the Notepad window and paste the contents of the clipboard into Notepad using 
Ctrl-V or the Edit > Paste menu item. 

9. You can repeat this exercise going in the reverse direction by typing more text, copying this, 
then pasting it back into WordPad running inside the virtual machine. 
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Exercise II (B)
The Blue Screen Application – Crashing a Guest Operating System 

To demonstrate the isolation of the virtual machines, VMware has created a special software package 
called bluescreen. This consists of a program and small device driver that deliberately crash a Windows 
NT 4.0 or Windows 2000 system. To avoid accidents the installer only allows the program to be installed 
in a virtual machine. The operation of this application is not based on a weakness in Windows NT 4.0 
and Windows 2000; typically, any errant device driver can crash an operating system. 

The purpose of this exercise is to demonstrate the protection provided if you are installing untrusted 
software or taking other actions that may crash your computer. With VMware you can use a virtual 
machine for testing without risking the stability of the host operating system. 

1. Download bluescreen2.exe (1.3MB) from http://www4.vmware.com/software/
bluescreen2.exe. 

2. Copy the bluescreen2.exe fi le to fl oppy diskette. 

3. Start VMware and power on the Windows 2000 guest operating system if it is not already 
running. 

4. Log in to Windows 2000 running inside the virtual machine as Administrator or as a user who 
is a member of the Administrators group. 

5. Inside the virtual machine browse to fl oppy disk A: and double-click the bluescreen.exe 
installer program.  

 
 Figure 2 - 4 

6. The installation will start. At the Welcome dialog, press Next. 

7. Accept the default installation path by clicking Next. 

8. Accept the default program folder by clicking Next. 

9. Click Finish to restart your virtual machine. 
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Running the VMware Blue Screen Application  

 
 Figure 2 - 5

1. Once the virtual machine has been restarted, select Start > Programs > VMware > VMware 
Bluescreen. 

 
 Figure 2 - 6

2. Click OK at the VMware Bluescreen Utility dialog.  

 
 Figure 2 - 7 

3. The guest operating system will crash with a blue screen. That felt good, didn’t it!
Windows 2000 will recover from the crash by initiating a soft restart.
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4. The host operating system and any applications running on it remain running and usable even 
though the guest operating system has crashed. On the host operating system you can try 
running some applications and confi rm that the computer is working normally. 
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Exercise III
Virtual Networking in VMware 
Estimated time to complete: about 10-15 minutes 

Each virtual machine can have its own distinct network confi guration. There are four choices for 
confi guring networking: 

• No networking 

• Bridged networking 

• Host-only networking

• Custom networking 

No networking 

• The virtual machine is run in isolation. 

• It will not be able to communicate with the host operating system. 

• It will not be able to communicate with any other virtual machine running on the host. 

• This option is useful if you desire complete isolation for testing or security purposes. 

• To set up your virtual machine in this way, simply do not install a network interface adapter 
when confi guring the virtual machine. 

Bridged networking 

• The virtual machine runs on a virtual network that is connected to an existing physical 
network. 

• It permits the virtual machine to appear as a full-fl edged host on an existing physical network. 

• The virtual machine may transparently use any of the services available on the network that it is 
bridged to: printers, fi le servers, gateways, etc. 

• Any physical host, or other virtual machine confi gured with bridged networking, can use 
resources on that virtual machine. 

• This is the most commonly used networking confi guration. 

Host-only networking 

• The virtual machine can communicate with the host operating system. 

• It can also communicate with other virtual machines set up to use host-only networking. 

• The virtual machine cannot communicate with any systems beyond the host machine without 
the use of a proxy server or network address translation. 

• It utilizes VMware’s DHCP service, installed on the host during VMware installation. 

This networking type is most useful when: 

• You want to isolate your virtual machines from systems outside the host computer. 

• The host is not connected to any physical network. 

• No Ethernet network adapter is installed on the host. 

• The network adapter is something other than Ethernet (for example, Token Ring). 

• A modem is installed and Dial-Up Networking is confi gured to dial to an Internet service 
provider. 
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Custom networking

Refers to any network confi guration other than those described above. This is outside the scope of 
this exercise. 

Confi guring Host-Only Networking 

To confi gure host-only networking you may follow this procedure: 

1. Start VMware by double-clicking the shortcut on your desktop. 

2. Choose the Win2000 confi guration fi le from the recently used fi les and click OK. 

3. Choose the Settings > Confi guration Editor menu item.  

 
 Figure 3 - 1 

4. Expand the Ethernet Adapters by clicking the + next to it. 

5. Highlight Ethernet and select the radio button beside Host-only if is not already selected. 

6. Click OK. 

7. Choose the File > Save menu option to save the changes to the confi guration fi le. 

8. Power on the virtual machine (by clicking the Power On button). 

9. After the Windows 2000 guest operating system is started and you have logged in, view the 
network interface card information by opening the Network and Dial-Up Connections control 
panel from Start > Settings > Network and Dial-Up Connections, then open the Local Area 
Connection. Double-click the Local Area Conection and choose the Properties button.

 
 Figure 3 - 2 

10. Select Internet Protocol (TCP/IP). 

11. Click Properties.  
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 Figure 3 - 3 

12. Verify that “Obtain an IP address automatically” is selected. 

13. If you did not need to make any changes, click Cancel, then Cancel again. If you made any 
changes, click on OK, then OK again and restart Windows 2000 if prompted.  

 
 Figure 3 - 4 

14. Open a command prompt and type: ipconfi g /all 

15. Verify that an IP address lease has been assigned (in our example it is 172.16.13.130). 

16. Switch to the host operating system and repeat step 14 above.  

 
 Figure 3 - 5 

17. Notice that the host has been confi gured with a virtual Ethernet adapter named Vmnet1 (the 
number may vary in your installation). 

18. Also notice that the host’s IP address is the fi rst in the subnet (in our example the IP address is 
172.16.13.1 and the network number is 172.16.13.0 based on subnet mask of 255.255.255.0). 

19. Another important item to notice is that the guest operating system is acquiring its IP lease 
from a DHCP server whose IP address is the last in the above subnet (in our example it is 
172.16.13.254).  
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 Figure 3 - 6 

20. While still at the host’s command prompt, ping the virtual machine’s IP address. It should 
respond successfully. 

21. Repeat the above step using the virtual machine’s host name instead of the IP address. It should 
respond successfully. 

22. Exit the command prompt.  

 
 Figure 3 - 7 

23. Switch back to the guest’s command prompt and ping the host’s IP address. It should respond 
successfully. 

24. Repeat the above step using the host machine’s host name instead of the IP address. It should 
respond successfully. (It may take a little longer to respond, compared to step 23.) 

25. Exit the command prompt. 

26. On your virtual machine do the following: 

a. Start the Windows 2000 Explorer and browse to the C: drive. 

b. Create a new folder off the root of the C: drive and set up sharing for this folder.  

 
 Figure 3 - 8 

27. Switch to the host’s desktop and browse My Network Places. Expand the Entire Network tree, 
then expand the guest’s Workgroup tree (if it is different from the host’s workgroup). You 
should be able to see the guest’s virtual machine listed. 

28. Select the guest’s virtual machine. Notice that the newly created share is listed. 

29. Switch to the guest’s desktop and repeat steps 26 through 28, reversing the guest and host roles.  
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 Figure 3 - 9 

30. You should be able to see the host’s newly created share listed. 
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Exercise IV
Sharing VMware Virtual Disks on a Network
Estimated time to complete: about ?? minutes 

Introduction to VMware Disk Capabilities 

VMware supports two disk types: existing disk partitions (also known as raw disks) and virtual disks. 

Virtual disks are particularly convenient for many users — for example, technical support representa-
tives or quality assurance groups — because they encapsulate a virtual machine in a fi le on the host 
computer’s fi le system. This fi le can then be stored on a fi le server or CD-ROM for later use and can be 
shared with other users. A variety of operating systems and system confi gurations can be maintained as 
virtual disk fi les for quick access by anyone in the group.

A virtual disk fi le created under VMware for Windows NT and Windows 2000 can be used under 
VMware for Linux and vice versa.

A VMware virtual machine can use disks in three modes: persistent, nonpersistent, and undoable. 
The default mode is persistent. Persistent disks behave as conventional disks do, with changes made 
permanently. With nonpersistent disks, changes are discarded at the end of each session. Undoable disks 
allow users to choose whether to keep or discard changes.

In this exercise you will see how to change disk modes, then set up client and server computers for 
easy sharing of virtual disks.

Exercise IV (A)
Confi guring an Undoable Disk 

To confi gure a virtual machine to use undoable disk mode, you may follow this procedure: 

1. Start VMware by double-clicking the shortcut on your desktop.  

 
 Figure 4 - 1 

2. Choose the Windows 2000 confi guration fi le from the most recently used fi les and click OK. 

3. Choose the Settings > Confi guration Editor menu item.  

Protect your work
Many VMware users 
routinely use undoable 
disk mode as an easy 
way to protect their 
system confi gurations.
When you have your vir-
tual machine set up in 
a way you like, commit 
all changes as outlined 
in this section.
You should also click the 
Commit button any time 
you shut down a session 
where everything 
worked as you wanted it 
to.
Or if you’re not sure 
about changes you 
made, click Keep. This 
lets you decide later 
whether to commit or 
discard the changes.
But if something goes 
wrong — errors while 
installing a program, 
document changes you 
wish you hadn’t made, 
even a system crash —  
shut down the virtual 
machine and click 
Discard instead. Next 
time you start your vir-
tual machine, you’ll be 
back were you were 
before the session that 
spelled disaster.
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 Figure 4 - 2 

4. Expand the IDE Drives tree by clicking the + next to it.  

 
 Figure 4 - 3 

5. Choose the drive IDE 0:0 and select the radio button beside Undoable. 

6. Click Save to save the changes to the confi guration fi le. 

7. Power on the virtual machine (by clicking the Power On button).  

 
 Figure 4 - 4 

8. After the Windows 2000 guest operating system is started and you have logged in, use the 
Windows NT Explorer on the host operating system to browse to the Win2000 virtual machine 
directory. Notice the presence of a new fi le called Win2000.dsk.REDO. This is the redo log 
mentioned in the previous section. 

9. Install an application of your choice on the virtual machine. Use something that doesn’t take 
long to install, because you will discard this application in one of the following steps. 

10. Shut down Windows 2000 on the virtual machine and click the Power Off button.  

 
 Figure 4 - 5 

11. You are prompted with three possible actions for the redo log:

• Commit 

• Discard 

• Keep 

12. Click Keep. 
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13. Power on the virtual machine.  

 
 Figure 4 - 6 

14. You are prompted with four options for the redo log: 

• Commit: to commit the contents of the redo log to the virtual disk 

• Discard: to discard the contents of the redo log and start with a new log 

• Append: to append new changes in this session to the existing log

• Cancel: to cancel the redo operation, after which you will have an option to cancel the 
session or continue with the disk disabled 

15. Click Append 

16. After Windows 2000 has started and you are logged in, check for the application you installed in 
step 9 above. Notice that it is still installed. 

17. Shut down Windows 2000 and power off the virtual machine. 

18. You are again presented with the same dialog as in step 11 above. 

19. Click Keep. 

20. Power on the virtual machine. 

21. The dialog listed in step 14 above is displayed again. Click Discard. 

22. After Windows 2000 has started and you are logged in, check for the application you installed in 
step 9 above. Notice that it is no longer there. 

23. Now install an application that you want to keep. 

24. Shut down Windows 2000 and power off the virtual machine. 

25. Click Commit. A progress bar will appear while the changes are committed to the virtual disk. 

26. Power on the virtual machine. 

27. Notice that you no longer see the dialog listed in step 14. 

28. After Windows 2000 has started and you are logged in, check for the application you installed in 
step 23 above. Notice that it is still installed. 

29. Shut down Windows 2000 and power off the virtual machine. 

30. Click Commit. To change the disk mode back to persistent, follow Steps 1 through 6, but this 
time select the radio button beside Persistent (instead of Undoable) in step 5. 

Exercise IV (B)
Sharing Virtual Disks from a Network Drive

In this exercise you will go through the basic steps needed to set up virtual disks so they can be 
shared from a network drive. Shared virtual disks are important time-savers for VMware customers like 
Internet service provider Excel.Net.

“VMware lets us quickly fi re up a virtual machine to match the customer’s confi guration,” says Excel.Net  
President Larry Weidig. “It’s great for customer support.”



Reviewer’s Guide
VMware 2.0 for Windows NT and  Windows  2000 31

Copyright © 2000 VMware, Inc. All rights reserved.

Figure 4 - 7

In this exercise, you will store virtual disk fi les on a network drive and set up a client computer to use 
that virtual disk without changing the shared fi les. You willl need to copy some fi les to the network 
server and modify your VMware confi guration to run the virtual machine from the server.

1. Locate the virtual machine directory you created in Exercise I (in our example it was 
C:\Program fi les\VMware\VMs\Win2000). 

2. Map a drive to the network share on which you will store the fi les. 

3. Copy the .vmx and .dsk fi les from the directory identifi ed in step 1 to the network drive. 

4. Start the Windows NT Explorer and browse to the above network drive. 

5. Double-click the .vmx fi le; this will launch VMware using this fi le. 

6. Start the confi guration editor (Settings > Confi guration Editor).  

 
 Figure 4 - 8 

7. Expand the IDE Drives tree, then highlight IDE 0:0. 

8. Notice that the virtual disk name fi eld is still pointing to the original path. 

9. Edit the above path to refl ect the new location on the network. You may use a mapped drive or 
simply use a UNC (in our example \\home\disks\win2000 where home is the server name 
and disks is the share name on which the virtual disks are stored).  

10. Change the virtual disk mode to Nonpersistent. 

Reference library
The customer support 
group at Excel.Net has 
a shared fi le server that 
contains virtual disks 
with the many operating 
system and browser 
combinations their cus-
tomers use. Each cus-
tomer support repre-
sentative has VMware 
installed and can use 
any of the virtual disks 
to replicate the custom-
ers’ environments. 
For example, one user 
may call and have 
Windows 95 running 
Microsoft Internet 
Explorer 4, while the 
next customer will have 
Windows NT and 
Internet Explorer 5. It 
is invaluable to be able 
to step through exactly 
what the user sees, 
since the network con-
fi guration dialogs are 
different on each oper-
ating system.
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 Figure 4 - 9

11. To improve disk I/O performance, set the redo log directory to a local drive. To do so: 

a. Click the Misc item in the window on the left. 

b. In the panel on the right, type in the path to a directory on the local drive. In our example, 
the directory is on c:\local\win2000 

 Note: You MUST set the disk mode to nonpersistent since multiple users will be modifying it at 
the same time.  You want to prevent their modifi cations from being committed to the disk. This 
is the safest method for sharing the same virtual disk. 

 If you want to allow users to keep their changes between sessions (but not commit the changes 
to the shared virtual disk), you can do the following: 

a. Set the disk mode to undoable. You can do that by selecting Undoable instead of Nonpersis-
tent in step 10 above. 

b. Change the fi le attribute of the shared .dsk fi le to read only.This will allow 
the users to keep their changes but not commit them to the virtual disk. 
Note: If you use undoable disk mode, only one user at a time will have access to a given 
virtual disk fi le. 

From the user’s workstation, do the following: 

1. Install VMware as outlined in Exercise I. 

2. Create a directory on the local drive named c:\local\win2000. 

3. Temporarily map a network drive to the share where you stored the virtual machine fi les. 

4. Copy the .vmx fi le to the c:\local\win2000 directory. 

5. Open the Windows NT Explorer and browse to the above directory. 

6. Double-click the .vmx fi le. This will launch VMware using this confi guration fi le. 

7. Now, power the virtual machine on. 

8. If you are using nonpersistent mode, you should receive the following dialog:  

 
 Figure 4 - 10

9. This is a reminder that when you are using the nonpersistent mode, all changes will be 
discarded when you reset the virtual machine. 

10. If you are using undoable disk mode (fl agged read only), you should receive this dialog instead:  
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 Figure 4 - 11

11. Click OK. 

12. Verify that Windows 2000 boots successfully. 

13. Shut down the guest operating system. 

14. If you are using undoable disk mode, you will receive this dialog:  

 
 Figure 4 - 12

15. Click Keep. You will not be allowed to commit the contents of the redo log since the DSK fi le 
has already been fl agged read only. Otherwise, click Discard and your virtual disk will revert to 
its original form the next time you start this virtual machine. 

16. The next time this virtual machine is restarted, you will receive the following dialog if you 
did not discard the redo log.  

 
 Figure 4 - 13

17. Click Append to allow the new session to add the changes to this redo log. Otherwise, click 
Discard to start the virtual disk in its original form (as if this were the fi rst time you were 
using it). 
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