


Print command (File menu)

Use this command to print a document.      This command presents a Print dialog box, where you may specify the 
range of pages to be printed, the number of copies, the destination printer, and other printer setup options.

Shortcuts

Toolbar:
Keys: CTRL+P



Print dialog box

The following options allow you to specify how the document should be printed:
Printer

This is the active printer and printer connection.    Choose the Setup option to change the printer and printer 
connection.

Setup
Displays a Print Setup dialog box, so    you can select a printer and printer connection.

Print Range
Specify the pages you want to print:

All Prints the entire document.
Selectio
n

Prints the currently selected text.

Pages Prints the range of pages you specify in the From and To boxes.
Copies

Specify the number of copies you want to print for the above page range.
Collate Copies

Prints copies in page number order, instead of separated multiple copies of each page.
Print Quality

Select the quality of the printing.    Generally, lower quality printing takes less time to produce.



Print Progress Dialog

The Printing dialog box is shown during the time that True3D is sending output to the printer.    The page number 
indicates the progress of the printing.

To abort printing, choose Cancel.



Print Preview command (File menu)

Use this command to display the active document as it would appear when printed.    When you choose this 
command, the main window will be replaced with a print preview window in which one or two pages will be 
displayed in their printed format.    The print preview toolbar offers you options to view either one or two pages 
at a time; move back and forth through the document; zoom in and out of pages; and initiate a print job.



Print Preview toolbar

The print preview toolbar offers you the following options:
Print

Bring up the print dialog box, to start a print job.
Next Page

Preview the next printed page.
Prev Page

Preview the previous printed page.
One Page / Two Page

Preview one or two printed pages at a time.
Zoom In

Take a closer look at the printed page.
Zoom Out

Take a larger look at the printed page.
Close

Return from print preview to the editing window.



Print Setup command (File menu)

Use this command to select a printer and a printer connection.    This command presents a Print Setup dialog 
box, where you specify the printer and its connection.



Print Setup dialog box

The following options allow you to select the destination printer and its connection.
Printer

Select the printer you want to use.    Choose the Default Printer; or choose the Specific Printer option and 
select one of the current installed printers shown in the box.    You install printers and configure ports using 
the Windows Control Panel. 

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the document is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources.    Specify the tray here.

Options
Displays a dialog box where you can make additional choices about printing, specific to the type of printer you
have selected.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.



Page Setup command (File menu)

<< Write application-specific help here. >>
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The File Menu

The File menu offers the following commands:

New Creates a new document.
Open Opens an existing document.
Close Closes an opened document.
Save Saves an opened document using the same file name.
Save As Saves an opened document to a specified file name.
Print Prints a document.
Print 
Preview

Displays the document on the screen as it would appear printed.

Print Setup Selects a printer and printer connection.
Send... Sends the active document through electronic mail.
Exit Exits True3D.



The Edit Menu

The Edit menu offers the following commands:

Undo Reverse previous editing operation.
Cut Deletes data from the document and moves it to the clipboard.
Copy Copies data from the document to the clipboard.
Paste Pastes data from the clipboard into the document.
Paste Link Pastes from the clipboard a link to data in another application.
Insert New 
Object

Inserts and embeds an object, such as a chart or an equation in a document.

Links List and edit links to embedded documents.



The View Menu

The View menu offers the following commands:

Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.

The Window Menu

The Window menu offers the following commands, which enable you to arrange multiple views of multiple 
documents in the application window:

New Window Creates a new window that views the same document.
Cascade Arranges windows in an overlapped fashion.
Tile Arranges windows in non-overlapped tiles.
Arrange Icons Arranges icons of closed windows.
Split Split the active window into panes.
Window 1, 
2, ...

Goes to specified window.



The Help Menu

The Help menu offers the following commands, which provide you assistance with this application: 

Help 
Topics

Offers you an index to topics on which you can get help.

About Displays the version number of this application.



New command (File menu)

Use this command to create a new document in True3D 

You can open an existing document with the Open command.

Shortcuts

Toolbar:
Keys: CTRL+N



File New dialog box

<< Delete this help topic if your application supports only one document type. >>

Specify the type of document you wish to create:
<< List your application's document types here >>



Open command (File menu)

Use this command to open an existing document in a new window.    You can open multiple documents at once.    
Use the Window menu to switch among the multiple open documents.    See Window 1, 2, ... command.

You can create new documents with the New command.

Shortcuts

Toolbar:
Keys: CTRL+O



File Open dialog box

The following options allow you to specify which file to open:
File Name

Type or select the filename you want to open.    This box lists files with the extension you select in the List 
Files of Type box. 

List Files of Type
Select the type of file you want to open:
<< List your application's file types here. >>

Drives
Select the drive in which True3D stores the file that you want to open. 

Directories
Select the directory in which True3D stores the file that you want to open.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



Close command (File menu)

Use this command to close all windows containing the active document.    True3D suggests that you save 
changes to your document before you close it.    If you close a document without saving, you lose all changes 
made since the last time you saved it.    Before closing an untitled document, True3D displays the Save As dialog 
box and suggests that you name and save the document.

You can also close a document by using the Close icon on the document's window, as shown below:



Save command (File menu)

Use this command to save the active document to its current name and directory.    When you save a document 
for the first time, True3D displays the Save As dialog box so you can name your document.    If you want to 
change the name and directory of an existing document before you save it, choose the Save As command.

Shortcuts

Toolbar:
Keys: CTRL+S



Save As command (File menu)

Use this command to save and name the active document.    True3D displays the Save As dialog box so you can 
name your document.    

To save a document with its existing name and directory, use the Save command.



Send command (File menu)

Use this command to send the active document through electronic mail.    This command presents a mail window
with the active document attached to it.    You may then fill out the To: field, Subject: field, etc., and add text to 
the body of the message if you wish.    When you are finished you may click the "Send" button to send the 
message.



File Save As dialog box

The following options allow you to specify the name and location of the file you're about to save:
File Name

Type a new filename to save a document with a different name.    A filename can contain up to eight 
characters and an extension of up to three characters.    True3D adds the extension you specify in the Save 
File As Type box.

Drives
Select the drive in which you want to store the document.

Directories
Select the directory in which you want to store the document.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 

<< Add other File Save As dialog box options depending on which ones your application chooses via the OFN_ 
flags of the OPENFILENAME structure used by the CFileDialog. >>



1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last six documents you closed.  
Choose the number that corresponds with the document you want to open.



Exit command (File menu)

Use this command to end your True3D session.    You can also use the Close command on the application Control 
menu.    True3D prompts you to save documents with unsaved changes.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



Undo/Can't Undo command (Edit menu)

<< Your application's user interface for Undo may differ from the one described below.    Modify this help text 
accordingly. >>

Use this command to reverse the last editing action, if possible.      The name of the command changes, 
depending on what the last action was.    The Undo command changes to Can't Undo on the menu if you cannot 
reverse your last action.

Shortcuts

Toolbar:
Keys: CTRL+Z or

ALT-BACKSPACE



Redo command (Edit menu)

<< Write application-specific help here. >>



Cut command (Edit menu)

Use this command to remove the currently selected data from the document and put it on the clipboard.    This 
command is unavailable if there is no data currently selected.

Cutting data to the clipboard replaces the contents previously stored there.

Shortcuts

Toolbar:
Keys: CTRL+X



Copy command (Edit menu)

Use this command to copy selected data onto the clipboard.    This command is unavailable if there is no data 
currently selected.

Copying data to the clipboard replaces the contents previously stored there.

Shortcuts

Toolbar:
Keys: CTRL+C



Paste command (Edit menu)

Use this command to insert a copy of the clipboard contents at the insertion point.    This command is unavailable
if the clipboard is empty.

Shortcuts

Toolbar:
Keys: CTRL+V



Toolbar command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the most common 
commands in True3D, such as File Open.    A check mark appears next to the menu item when the Toolbar is 
displayed.

See Toolbar for help on using the toolbar.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The toolbar provides 
quick mouse access to many tools used in True3D,

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).

<< Add or remove toolbar buttons from the list below according to which ones your application offers. >>

Click To

Open a new document.

Open an existing document.    True3D displays the Open dialog box, in which you can locate and open the 
desired file.

Save the active document or template with its current name.    If you have not named the document, 
True3D displays the Save As dialog box.

Print the active document.

Remove selected data from the document and stores it on the clipboard.

Copy the selection to the clipboard.

Insert the contents of the clipboard at the insertion point.

Reverse the last editing.    Note:    You cannot undo some actions.

Go to the first record in the current selection.

Go to the previous record in the current selection.

Go to the next record in the current selection.

Go to the last record in the current selection.



Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be executed by the selected 
menu item or depressed toolbar button, and keyboard latch state. A check mark appears next to the menu item 
when the Status Bar is displayed.

See Status Bar for help on using the status bar.



Status Bar

The status bar is displayed at the bottom of the True3D window.    To display or hide the status bar, use the Status
Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to navigate through 
menus.    This area similarly shows messages that describe the actions of toolbar buttons as you depress them, 
before releasing them.    If after viewing the description of the toolbar button command you wish not to execute 
the command, then release the mouse button while the pointer is off the toolbar button.

The right areas of the status bar indicate which of the following keys are latched down:

Indicator Description
CAP The Caps Lock key is latched down.

NUM The Num Lock key is latched down.

SCRL The Scroll Lock key is latched down.



New command (Window menu)

Use this command to open a new window with the same contents as the active window.    You can open multiple 
document windows to display different parts or views of a document at the same time.    If you change the 
contents in one window, all other windows containing the same document reflect those changes.    When you 
open a new window, it becomes the active window and is displayed on top of all other open windows.



Cascade command (Window menu)

Use this command to arrange multiple opened windows in an overlapped fashion. 



Tile command (Window menu)

Use this command to arrange multiple opened windows in a non-overlapped fashion.



Tile Horizontal command (Window menu)

Use this command to vertically arrange multiple opened windows in a non-overlapped fashion.



Tile Vertical command (Window menu)

Use this command to arrange multiple opened windows side by side.



Window Arrange Icons Command

Use this command to arrange the icons for minimized windows at the bottom of the main window.    If there is an 
open document window at the bottom of the main window, then some or all of the icons may not be visible 
because they will be underneath this document window.



Split Command (Window menu)

Use this command to split the active window into panes.    You may then use the mouse or the keyboard arrows 
to move the splitter bars.    When you are finished, press the mouse button or enter to leave the splitter bars in 
their new location.    Pressing escape keeps the splitter bars in their original location.    << In a single document 
interface application, this command will appear on the View menu. >>



1, 2, ... command (Window menu)

True3D displays a list of currently open document windows at the bottom of the Window menu.    A check mark 
appears in front of the document name of the active window.    Choose a document from this list to make its 
window active.    



Index command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can jump to step-by-
step instructions for using True3D and various types of reference information.    

Once you open Help, you can click the Contents button whenever you want to return to the opening screen.



Using Help command (Help menu)

Use this command for instructions about using Help.



About command (Help menu)

Use this command to display the copyright notice and version number of your copy of True3D.



Context Help command 

Use the Context Help command to obtain help on some portion of True3D.    When you choose the Toolbar's 
Context Help button, the mouse pointer will change to an arrow and question mark.    Then click somewhere in 
the True3D window, such as another Toolbar button.    The Help topic will be shown for the item you clicked.

Shortcut
Keys: SHIFT+F1



Title Bar

<< Show your application's title bar here. >>

The title bar is located along the top of a window.    It contains the name of the application and document.

To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging their title bars.

A title bar may contain the following elements:
Application Control-menu button
Document Control-menu button
Maximize button
Minimize button
Name of the application
Name of the document
Restore button



Scroll bars

Displayed at the right and bottom edges of the document window.    The scroll boxes inside the scroll bars 
indicate your vertical and horizontal location in the document.    You can use the mouse to scroll to other parts of 
the document.

<< Describe the actions of the various parts of the scrollbar, according to how they behave in your application. 
>>



Size command (System menu)

Use this command to display a four-headed arrow so you can size the active window with the arrow keys.

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer to the border you 

want to move.    
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or dialog box with the 
arrow keys.

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



Minimize command (application Control menu)

Use this command to reduce the True3D window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9



Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title bar.
Keys: CTRL+F10 enlarges a document window.



Next Window command (document Control menu)

Use this command to switch to the next open document window.    True3D determines which window is next 
according to the order in which you opened the windows.

Shortcut
Keys: CTRL+F6



Previous Window command (document Control menu)

Use this command to switch to the previous open document window.    True3D determines which window is 
previous according to the order in which you opened the windows.

Shortcut
Keys: SHIFT+CTRL+F6



Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Note:    If you have multiple windows open for a single document, the Close command on the document Control 
menu closes only one window at a time.    You can close all windows at once with the Close command on the File 
menu.

Shortcuts
Keys: CTRL+F4 closes a document window

ALT+F4 closes the <<YourType>> window or dialog box



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the Maximize or 
Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to or close an 
application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the following options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap and you can see each title bar.    This option does not affect 
applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not affect applications 
reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



Ruler command (View menu)

<< Write application-specific help here. >>



Choose Font dialog box

<< Write application-specific help here. >>



Choose Color dialog box

<< Write application-specific help here. >>



Find command (Edit menu)

<< Write application-specific help here. >>



Find dialog box

<< Write application-specific help here. >>



Replace command (Edit menu)

<< Write application-specific help here. >>



Replace dialog box

<< Write application-specific help here. >>



Repeat command (Edit menu)

Use this command to repeat the last editing command carried out.    The Repeat menu item changes to Can't 
Repeat if you cannot repeat your last action.

Shortcut
Key: F4



Clear command (Edit menu)

<< Write application-specific help here. >>



Clear All command (Edit menu)

<< Write application-specific help here. >>



Next Pane

<< Write application-specific help here. >>



Prev Pane

<< Write application-specific help here. >>
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No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.

<< If you wish to author help specific to each message box prompt, then remove the AFX_HIDP_xxx values from 
the [ALIAS] section of your .HPJ file, and author a topic for each AFX_HIDP_xxx value.    For example, 
AFX_HIDP_INVALID_FILENAME is the help topic for the Invalid Filename message box. >>



Disclaimer

True3D

The True Hidden 3D Design Software

Version 1.0 for Windows® 95 and Windows NT

Tel.: (613) 723-7680

E-mail: info_true3d@yahoo.com
dzfeng@phy.ulaval.ca

Copyright © 1998 Dazeng Feng
All rights reserved. 

Disclaimer
I make no representation or warranty with respect to the adequacy of this documentation or the programs that it describes for 
any particular purpose or with respect to its adequacy to produce any particular result.

Microsoft, MS, Windows and Windows NT are trademarks of Microsoft Corporation.



Welcome

Welcome to True3D – a powerful and user-friendly design software for creating true hidden 3D graphics. 

The true hidden 3D images are also known as Single Image Random Dot Stereograms (SIRDS), or Single Image Stereograms 
(SIS). By focusing your eyes behind the image, you can see true 3D image without the need for special glasses or equipment.

The true hidden 3D image design can be greatly facilitated by the use of the appropriate computer software: True3D. The 
True3D uses advanced algorithms and offers different options and tools for design hidden 3D images. By using the True3D 
software, you can build your own stereogram gallery, create unique postcards for your friends and so on.



Installing True3D

Before installing True3D, make sure that you have the system requirements described below.

Hardware and Software Requirement

True3D requires the following system configuration:

· Microsoft Windows 95 or Windows NT 4.0
· 16MB memory
· 10 MB free hard disk space 

True3D Directory

By default, the Installer will create a True3D directory on your hard disk. The True3D directory will contain the following 
subdirectories:

\TUTORIAL – contain examples
\DEPTH – contains depth image files
\BKG – contains background image files
\DOC – contains True3D Manual



How to Learn True3D

You can quickly become an efficient True3D user by reading carefully the Technical Background, doing the Tutorial lessons, 
referring to the User Guide, and consulting the On line Help.



Technical Support

Technical support is provided only for registered users. 
· Technical support by E-mail
info_true3d@yahoo.com
dzfeng@phy.ulaval.ca



Register

True3D is a shareware. You can use it for free. If you found it useful and wish to have a full functional software, you need to 
registration your copy. 

Limitation for Unregistered True3D Software

· True3D image is limited to the size 1024X1024 pixels
· Signature on the final True3D image
· No upgraded
· No Technical support

The Advantage for Registered True3D Software

· Full functional software
· Free upgraded to all minor release
· Unlimited technical support
· Discounts on new releases

Finally, by registering the software, you provide us with the resources and incentive to support the software with updates and to 
develop additional quality shareware products in the future.

How to register

Just send a email to the following address
Dzfeng@phy.ulaval.ca
Info_true3d@yahoo.com



what is true Hidden 3D, SIS and SIRDS?
The true hidden 3D pictures are also known as Single Image Random Dot Stereograms (SIRDS), or Single Image Stereograms 
(SIS). By focusing your eyes behind the image, you can see true 3D image without the need for special glasses or equipment. 
For details, please refer to:
http://www.cs.waikato.ac.nz/~singlis/sirds/general.thml



How to See Hidden 3D?
http://www.cs.waikato.ac.nz/~singlis/sirds/general.thml



How to Create Hidden 3D?
http://www.cs.waikato.ac.nz/~singlis/sirds/general.thml

You can create Hidden 3D by using our True3D software
In True3D, some advanced algorithms are used to create high quality 3D images. They are listed as following:

· Rigorous approach
· Hidden surfaces are removed in both horizontal and vertical directions. No geometric distortion for 3D object.
· Enhanced resolution method for low resolution devices
· Support random dot and single image sterograms
· Support 256 gray level and 16 colors depth image
· Tools for modifying depth image
· Tool for adding real images with transparency background



How to Create Depth image?

The simplest way to create depth image is using 2D graphics software, such as windows paintbrush. Simple 3D or text depth 
image can be drawn manually in different colors or shades of gray.

You can create depth image for more complicated 3D object by using 3D graphics software. You need figure out how to get 
depth information from 3D object for different kind of software.

Finally, by using 3D-measurement equipment, the depth image for real model scene can be created.



Tutorial

The best way to learn how to work with True3D is to do the Tutorial lessons. By following the step by step instructions, you will 
see how quickly you can become a highly efficient True3D user.

Lesson 1: Design Simple Hidden 3D 

Lesson 2: Design SIS Hidden 3D 

Lesson 3: Design Advanced Hidden 3D 



Lesson 1: Design Simple Hidden 3D

In this lesson, you will learn how to create simple True3D image. Also you will learn how to create depth image by using Color 
Mapping tool. 

Step 1
From the File menu , click New . 
You will see two windows. One is a Depth image window, the other is a True3D image window.

Step 2
Click the right hand mouse button on Depth image window. Select Open. Read the bitmap file located on True3D\Tutorial\
T1depth.bmp. This kind of bitmap can be easily created by windows paintbrush.

Step 3
Click the right mouse button on Depth image window. Select Color Mapping . Put the following value in the color mapping dialog 
box and press OK

You will see the color bitmap image changes to gray level bitmap image. 

Step 4
From Setting menu, click Input. Put the following values in the Input Parameters dialog box and press OK



Step 5
From Execute Menu , click Run. You will see the True3D image in the True3D image window.

Here, The True3D image’s background is a random color dots. This kind of True3D image is known as Single Image Random 
Dot Stereograms (SIRDS)

Step 6
Go back to the Input Parameter dialog box, Select Template Pattern. Click on Load. Open the background bitmap file located on \
True3D\Tutorial\T1Bkg.bmp. Press OK to close the Input Parameters dialog box.

Step 7
From Execute Menu , Click Run. Now you have create True3D image with a background image. This kind of True3D image is also 
known as Single Image Stereograms (SIS)





Lesson 2: Design SIS Hidden 3D

In this lesson, you will know how to create more complicated True3D image.

Assume you already have depth image. By following the step by step, you can create True3D image from depth image.

Step 1
From the File menu , click New . 
You will see two windows. One is a Depth image window, the other is a True3D image window.

Step 2
Click the right hand mouse button on Depth image window. Select Open . Read the bitmap file located on True3D\Tutorial\
T2depth.bmp

Step 3
Click the right hand mouse button on Modify Depth Data Put the following data in the dialog box. Press OK

Step 4
From Setting menu , click Input. Put 180 to the True3D image Width. Select Template Pattern. Click on Load. Open the background 
bitmap file located on \True3D\Tutorial\T2Bkg.bmp.

Step 5
From Execute Menu , Click Run. Now you have create another True3D image. By changing the background template pattern and 
modifying the Depth data, you can change the True3D image. 



Step 6 
Click the right hand mouse button on Depth image window. Select Inset Depth Image. Read the bitmap file located on True3D\
Tutorial\T2Insert.bmp. Drag and drop the inserted bitmap to the up center. 

Step 7
Click the right hand mouse button on Depth image window. Select Color Mapping Put the following data in the dialog box and press 
OK

Step 8
From Execute Menu , Click Run. Now you have create a new True3D image. You will see a title has been added 





Lesson 3: Design Advanced Hidden 3D Image

In this Lesson, you will learn how to edit true3D image. By using Import Image tool, you can add real images with different 
depths. Also, you can add title, frame and merge the depth image with the true3D image.    

Step 1
Open Tutorial2.t3d project. Then, from Execute Menu , Click Run.

Step 2
Click the right hand mouse button on True3D image window. Select Import Image. Read the bitmap file located on True3D\
Tutorial\face.bmp. You will see a face bitmap inside the True3D image.

Step 3
Click the right hand mouse button on True3D image window. Select Clone. Put the following parameters in the dialog box.

Press Apply and then Join Image

Step 4
Click the right hand mouse button on True3D image window. Select Import Image. Read the bitmap file located on True3D\Tutorial\
banana.bmp. You will see a banana bitmap inside the True3D image.

Step 5
Click the right hand mouse button on True3D image window. Select Clone. Put the following parameters in the dialog box.

Press Apply and then Join Image

Step 6
Click the right hand mouse button on True3D image window. Select Edit True3D Image. Put the following parameters to the dialog 
box



Step 7
Now you have create the True3D image with title, frame, depth image and different depth true images

That is the end of tutorial.



The Depth Image Menu

The Depth Image menu offers the following commands

Open Opens an existing Depth Image (Bitmap format)
Save Saves an opened Depth Image (Bitmap format) using the same file name
Save AsSaves an opened Depth Image (Bitmap format) to a specified file name



The True3D Image Menu

The True3D Image menu offers the following commands:

Open Opens an existing True3D Image (Bitmap format)
Save Saves an opened True3D Image (Bitmap format) using the same file name
Save AsSaves an opened True3D Image (Bitmap format) to a specified file name



The Tools Menu

The Tools Menu offers the following commands:

Color->Gray Convert color image to gray level image
Import Depth Image Import depth image (only support 16 colors bitmap)
Color Mapping mapping the bitmap color to 3d object’s depth
Input True3D Image Import True3D image
Clone Clone image on True3D image
Modify Depth Data Tool for modify the depth data
Edit True3D Image Tool for Edit (add Title, Border…) True3D Image



The Setting Menu

The Setting menu offers the following commands:

Input setting the input parameters for true3D project



Input

Define the most parameters in this dialog box

Eye Position X: Eye position in horizontal direction
Eye Position Y: Eye position in vertical direction
(The central point (X=0, Y=0) is in the central point of true3D image)
Paper to Eyes: The Distance from your eyes to the paper
Paper to Object: The distance from paper to object reference plane. If the object surface is just on the reference plane, the object 
depth at this point is zero.
Same as Display (check box): If it is selected, using the display’s resolution to create true3D image.

DPIX: Resolution in horizontal direction (dots per inch). If ‘Same as Display’ is selected, it displays the resolution of your monitor.
DPIY: Resolution in vertical direction (dots per inch). If ‘Same as Display’ is selected, it displays the resolution of your monitor.

Over Sample
X: Over sampling ratio in X direction
Y: Over sampling ratio in Y direction
These two parameters are very useful when the resolution of your output device is low 

Ransom Pattern: If this radio button is selected, the True3D image will be filled by random pattern.
Pixel_X: This slider controls the points in X direction for one pixel of True3D image. Maximum is in the right hand side.
Pixel_Y: This slider controls the points in Y direction for one pixel of True3D image. Maximum is in the right hand side.

R, G, B: These sliders controls the RGB color region that are used to generate random background
Template Pattern: If this radio button is selected, the True3D image will be filled by Template pattern stored in a file 
Load: Press this button to load the template pattern in bitmap format.

OK: If this button is pressed, the input data in this dialog box will be updated. 
Cancel: If this button is pressed, the input data in this dialog box will not be updated.    
Help: Display helps information for this dialog box



Clone
Using this dialog box to add images on the True3D image

Transparent color
Red: Enter Red value for the transparent color 
Green: Enter Green value for the transparent color
Blue: Enter Blue value for the transparent color
The color same as the entered transparent color on Add on image will be transparent for the True3D image
You can also double click on the Add on image to choose the transparent color

Depth Info
Object Depth: Enter depth value here. The Add on images will be duplicated based on the depth value
Duplicate Number: Enter the number that controls how many Add on images will be cloned

Apply: Clone the add on images, you can still remove it by press Remove button
Remove: Remove images from the True3D image. You can’t remove images after you pressed Join Image button
Join Image: Merge the add on images with True3D image
Close: Close the dialog box
Help: Display the help information of this dialog box



Modify Depth Data

Using this dialog to modify the depth data of the 3D object

Original 3D Properties
Max: Displays the maximum depth value before modification
Min: Displays the minimum depth value before modification

Modification
Max: Enter the new maximum depth value to be modified
Min: Enter the new minimum depth value to be modified

OK: modify the depth data with the new maximum and minimum values.
Cancel: does nothing
Help: Display the help information of this dialog box



Edit True3D Image
Using this dialog box to add title, footnote and border to the True3D image

Title: Type the title here 
Choose Font: Choose font for the Title

Title: Type the Footnote here 
Choose Font: Choose font for the Footnote

Border: Type the width (in mm) of the Border here 
Choose Color: Choose color for the Border

OK: Draw title, Footnote, border and merge the depth image with the True3D image 
Cancel: Remove the Title, Footnote, border and the depth image from the True3D image
Help: Display help information of this dialog box



The Execute Menu

The Execute menu offers the following commands:

Run Starts to build true3D image



Color Mapping
Using this dialog box to mapping 16 color image to depth image

Enter the depth value after each color bar. 16 colors bitmap image will be converted to depth image based on depth value you 
entered after each color bar.

OK: Convert the 16 colors bitmap to depth image
Cancel: Does nothing
Help: Display the help information of this dialog box



New Depth Image Window

Create a new depth image window 



New True3D Image Window

Create a new true3D window



Closes this dialog and saves any changes you have made.



Closes this dialog and saves any changes you have made.



Closes this dialog without saving any changes you have made.



Enter your input in this field.



Enter your input in this field.



Enter your input in this field.



Enter your input in this field.



Select your preferred option.



Select your preferred option.



Click this button to make your choice.



Click this button to make your choice.



Drag the slider to select your preferred value



Drag the slider to select your preferred value



Drag the slider to select your preferred value



Drag the slider to select your preferred value



Drag the slider to select your preferred value



Drag the slider to select your preferred value



Drag the slider to select your preferred value



Drag the slider to select your preferred value



Enter your input in this field.



Enter your input in this field.



Enter your input in this field.



Enter your input in this field.



Enter your input in this field.



Check your desired options.



Closes this dialog and saves any changes you have made.



Closes this dialog without saving any changes you have made.



Enter your input in this field.



Enter your input in this field.



Click this button to make your choice.



Enter your input in this field.



Enter your input in this field.



Closes this dialog without saving any changes you have made.



Enter your input in this field.



Enter your input in this field.



Enter your input in this field.



Enter your input in this field.



Enter your input in this field.



Enter your input in this field.



Enter your input in this field.



Enter your input in this field.



Enter your input in this field.



Enter your input in this field.



Enter your input in this field.



Enter your input in this field.



Enter your input in this field.



Enter your input in this field.



Enter your input in this field.



Enter your input in this field.



Click this button to make your choice.



Closes this dialog and saves any changes you have made.



Closes this dialog without saving any changes you have made.



Closes this dialog and saves any changes you have made.



Closes this dialog without saving any changes you have made.



Enter your input in this field.



Click this button to make your choice.



Enter your input in this field.



Click this button to make your choice.



Click this button to make your choice.



Enter your input in this field.



Click this button to make your choice.



Check your desired options.



Closes this dialog and saves any changes you have made.



Enter your input in this field.



Enter your input in this field.



Enter your input in this field.



Enter your input in this field.



Click this button to make your choice.



Enter your input in this field.



Click this button to make your choice.



Click this button to make your choice.



Click this button to make your choice.



Closes this dialog and saves any changes you have made.



Click this button to make your choice.




