
WhatsUp Gold Help Contents

Welcome to WhatsUp Gold 
 
Creating a network map 
      Creating a New Map     
      Loading a hosts file    
      Scanning a Windows network  
      Scanning a range of IP addresses
      Importing a WhatsUp Version 2.x (.db) file 
   Creating a Subnet Map

Setting a network element's properties
      Main properties 
      Monitor properties 
      Services properties 
      Alerts properties 
      Adding/Editing notifications 
      Host Menu Property 
      Notes properties
      Status properties 
      Chart properties 
      Log properties 
      RTT 
      History properties 
 
Defining Notifications
      System Notifications
      Pager Notifications 
      Beeper Notifications 
      Pager/Beeper communications setup 
      Notification message variables 
      Mail Notifications 
      Program Notifications 
      Voice Notifications 
      Setting up a voice modem 

 Monitoring the network map display 
      Initiating polling
      Turning off an alarm
      WhatsUp Gold Windows
            Map Window 
            Tree Window 
            List Window 
            Notifications Window 
            Status Window 
            Mini Status Window 
        Monitoring from a Web Browser

Using the Map Editor 
      Editing toolbar 
      Drawing toolbar 
      Color toolbar 
      Align toolbar 



      Hide/Display toolbars 
      Position toolbars 

Setting Properties for Drawing Objects 
      Line Properties 
      Rectangle Properties 
      Oval Properties 
      Text Properties 

Setting Program Properties 
      Startup Properties 
      Reports Properties 
      Web Properties 
      Web Access Properties 
      Logging on to the Web server
      WhatsUp Gold Web pages 

Setting Map Properties 
      Map Properties 
      Map Color Properties
      Map Alerts Properties 

Using Network Tools 
      Ping 
      Trace Route 
      Lookup 
      Finger 
      Whois 
      Misc Tools 
      Scan 
      SNMP 

About Box 

Monitoring SNMP Devices

Reference: Menu commands

Print commands



Welcome to WhatsUp Gold
Do you need to know the status of a system on your network? Do you need instant notification when the 
status of your Web, SMTP, POP3, FTP, or News servers changes? For most network administrators, the 
answer is yes. As computer networks proliferate you need a tool to easily monitor the status of networked 
components and the services that they provide. If you are the person responsible for installing, 
configuring, monitoring, and correcting problems with an organization's network and computer assets, 
WhatsUp Gold can make your job easier. WhatsUp Gold helps you monitor the status of network 
resources.    

What is WhatsUp Gold?

WhatsUp Gold builds on the success of Ipswitch's WhatsUp, an easy-to-use tool for monitoring TCP/IP 
and NetBEUI networks. WhatsUp Gold initiates both visible and audible alarms when monitored network 
elements do not respond to polling. WhatsUp Gold will even notify you by digital beeper, alphanumeric 
pager, e-mail, or voice message. 

Designed for PCs operating with Windows 95 or Windows NT, WhatsUp Gold can be installed wherever 
needed and does not require expensive, dedicated hardware. It will run in the background on your PC. 
WhatsUp Gold will work with any 32-bit TCP/IP stack, such as those bundled with Windows NT and 
Windows 95 and you can configure WhatsUp Gold and start monitoring your network without any special 
training. 

WhatsUp Gold monitors vital network elements and system services and generates an alarm when there 
is a problem. It also facilitates remote support and diagnosis by allowing users to easily view the status of 
all network elements.

See also:

How WhatsUp Gold Works
WhatsUp Gold Features



How WhatsUp Gold Works
WhatsUp Gold lets you quickly map your network, initiate monitoring, and receive notification if a network 
element or a service is down. The following screen shows a network map:

 

Mapping your Network

WhatsUp Gold provides several methods for creating a map of your network, including an automatic load 
capability that can scan files and scan the Windows network to create a network database. The network 
map contains an icon for each network element. Network elements can be workstations, servers, hosts, 
bridges, routers, LAN boxes, hubs, or printers. Each network element is associated with a specific IP 
address. 

Monitoring the Network

Once you have created or loaded a network map, you can set WhatsUp Gold to continuously monitor the 
network elements, or you can initiate a single check of the network. 

WhatsUp Gold monitors each of the network elements defined in a particular map/database by sending a 
set number of ICMP echo requests to the specified IP address and then tracking the responses. 

You can also scan a network element for the services it is running (such as HTTP, SMTP, POP3, DNS) 
and select the services you want to monitor. WhatsUp Gold monitors the service by checking the port that
the service is running on.

Receiving Notification 

During monitoring operations, WhatsUp Gold makes effective use of colors to indicate the status of the 
various network elements. By convention, those that respond to polling are displayed in green, those that 
have missed one polling request are displayed in light green, those that have missed two polling requests 
are displayed in yellow, and those that are not accessible or have not responded to four consecutive 
polling requests are displayed in red. You can easily change these default color selections to fit your 
preferences.



While monitoring, you can display up-to-the-minute status information about a particular network element 
by simply pointing to it and double-clicking the left mouse button to display a status window.

In addition, WhatsUp Gold lets you define specific notification actions (such as sending a message to a 
pager or e-mail account, or sending a voice message) for a network element or a range of network 
elements.

See also:

Welcome to WhatsUp Gold
WhatsUp Gold Features



WhatsUp Gold Features
WhatsUp Gold provides the following capabilities for mapping your network, monitoring network elements,
and receiving notification when a network element or service is down.

Mapping capabilities: 

· Automatic network scan and mapping
· Sophisticated, object-oriented drawing tools for organizing your network map
· Linked subnet mapping and monitoring

Monitoring capabilities:

· Graphical display of components being monitored and their status
· Monitoring of a wide range of network elements, including hosts, servers, workstations, bridges, 

routers, hubs, LAN concentrators, and printers
· Monitoring of the availability of one or more predefined services (e.g., SMTP, POP3, FTP, Telnet, 

WWW, or News) on a host 
· Monitoring of non-standard services on a host (e.g., an alternate Web server on a non-standard port) 
· Display and polling of multiple databases simultaneously
· Web access to live network maps from any browser
· Multiple monitoring views of core network database (Map, Status, List, and Tree Windows) 
· Hierarchical tree view that shows user-defined up/down dependencies and polling sequence
· On-going confirmation of network connections
· Scalable from small flat networks to large hierarchical, subnetted networks
· Ability to save different configurations of WhatsUp Gold windows to provide different views 
· Ability to Telnet from WhatsUp Gold to a monitored host using your favorite Telnet program
· Monitoring of unmanageable as well as manageable network devices
· Requires no additional agent technology on monitored network elements

Notification capabilities:

· Initiation of visible and audible alarms when any network element does not respond to polling 
· Remote notification by digital beeper, alphanumeric pager, e-mail, and voice message
· Notification via the WinPopup window (on Windows NT systems only)
· Notification can trigger an executable program
· Notifications can be applied globally

In addition, WhatsUp Gold includes a versatile set of integrated tools that let you search for and display 
information about organizations, networks, computers, or people on a network. WhatsUp Gold tools 
include Lookup, Ping, Traceroute, Whois, and Finger.

You can also configure WhatsUp Gold to use your favorite FTP and Telnet programs (such as WS_FTP 
Professional or VT320 Telnet Terminal Emulator from Ipswitch) to connect to networked hosts from within 
WhatsUp Gold.

See also:

Welcome to WhatsUp Gold
How WhatsUp Gold Works



    WhatsUp Gold Windows
 
The Map Window is designed to be the primary view of the WhatsUp Gold database.    Most of the editing 
actions in WhatsUp Gold are only available in the Map Window.
 

Map Window 
Tree Window 
List Window 
Notification Window 
Status Window 

 
 



 Map Window
 
The Map Window is the primary view of WhatsUp Gold. It shows a graphical display of the monitored 
components and their status. The Map Window has two modes: 

Monitor mode - used for polling network elements and reporting status. Status of a network element is 
indicated by color. 

Edit mode - used for creating and moving network elements (hosts, servers, routers, etc.) and drawing 
objects (lines, rectangles, ellipses, text). You can use the drawing capabilities to show network 
connections or group related components together. To modify the network map, click on the  icon on the
tool bar or select View -> Edit View.

Any network element can be changed by right clicking on the element and selecting Properties from the 
pop-up menu or by double clicking on the item. Most of the editing actions in WhatsUp Gold are only 
available in the Map Window.

The Status line at the bottom of the Map Window displays the polling status and a timer that counts down 
the time between polls.

You can have multiple Map Windows (representing multiple network databases) open and actively 
monitoring.
    
Other View Windows 
 



 Tree Window
 
The Tree Window uses a hierarchical tree view of the network database to show the polling sequence and
user-defined up and down dependencies. In the Tree Window, you can view and change the polling 
sequence and a network element's dependency on other elements.    

You can drag and drop network elements in each of the sub-trees to change their poll order or you can 
select an element and use the Arrange menu options. (The menu options are also available by right 
clicking on an element and using the pop-up menu.) You can also set an up or down dependency in a 
network element's Monitor properties.
 
In WhatsUp Gold, network elements can have dependencies on other network elements.    
 
If item A is "up dependent" on item B, then item A is only checked if item B is reachable.    If item B is not 
reachable, then item A will automatically be assumed to be down, will not be checked and will take on the 
same down count as item B.
 
If item A is "down dependent" on item B then item A is only check if item B is not reachable.    If item B is 
reachable, then item A will automatically be assumed to be up. If item B is not reachable, then item A will 
be checked. This is useful when you want to poll intervening routers only if the end point is not reachable. 
An easy way to set this up is to use the TraceRoute tool to automatically map a path to an address and 
tell it to Set Dependencies.    Look at the result in the Tree Window after doing this.
 
The "tree" consists of three primary branches.
 
Poll Sequence and Up Dependencies
Network elements are listed in this branch in the order they are polled.    If a network element is "up 
dependent" on the element above it, it is indented one level. You can drag a network element within the 
branch to change the polling order of element. The first element in the list is the first polled and the last 
element in the list is the last to be polled. 
 
Down Dependencies
Network Elements are listed in this branch in the order they are polled. If a network element is "down 
dependent" on the element above it, it is indented one level.
 
Invalid Dependencies
Network elements are listed in this branch when they have an invalid dependency,    i.e, a network 
element is dependent on an element that occurs later in the list.
 
The value in the parenthesis after the name is the item identifier for the item. This is used to resolve any 
ambiguity in host naming.
 
Other View Windows 
 



 List Window
 
The list view provides a tabular view into the map where you can sort the information by clicking on the 
column header buttons.
 
The database file lists all of the network elements in the network map and shows the following polling 
statistics for each element:
 
Name - the network element's hostname
 
Address - the network element's TCP/IP address
 
Count - the number of times the network element has been polled
 
Status - the network element's last read status
 
RTT -    round trip time (RTT) of the last poll 
 
Down Count - current count of lost polls, if the element is down 
 
Total Down Count - total count of lost polls since the map was      loaded 
 
Service Down Count - current count of lost service polls, if a service is down
 
Total Service Down Count - total count of lost service polls since the map was loaded
 
You can click on any of the column headings to sort the information based on the selected column. The 
initial sort will be in ascending order. Click the column heading a second time to reverse the sort to 
descending order.
 
Other View Windows 
 



 Notifications Window
 
You can view the notification actions that are enabled for a network map by using the Notifications 
Window. 

The notifications are grouped by network element. You can click on any of the column headings to sort 
the information based on the selected column. The initial sort will be in ascending order. Click the column 
heading a second time to reverse the sort to descending order.
 
Other View Windows 
 



 Status Window
 
The Status Window shows a list of all the network elements in the currently active map and displays the 
status using the same colors used on the network map. The Status Window also shows the status of any 
services that are being monitored on a network element. 

From the Windows menu, select Status Window. The Status Window appears.

Note: You may need to resize the Status Window in order to read the service status information. To resize
the window, click on the window border and drag it, or click on the Maximize button in the upper right 
corner of the window.

Click the     button to initiate a single check of each network element. Click the    

    button to initiate automatic polling of each network element. Click the Exit button to close the 
Status Window.

You can double click on a network element to display its properties.
 
Other View Windows 
 



Mini Status view

The Mini Status view provides a small profile window that you can use to monitor network status in place 
of the Map Window and the other view windows. The Mini Status view lists all network elements in the 
currently active map databases and displays status using the same colors used in the Map Window. 

From the View menu, select Mini Status or click the  button. The WhatsUp Gold main window is 
closed and the Mini Status window appears. 

Each map database is listed in a separate column. Any services being monitored on a network element 
are shown. 

Click on the Mini Status    view to silence an alarm. Double click on the Mini Status view to expand back 
to the Map Window. 



    About Box (Help menu)
 
Displays information about this program.



Monitoring the Network Map Display 

By convention, the following colors are used to indicate a network element's status:      

· Green - network elements that respond to polling
 
· Light green - network elements that have missed at least one polling request
 
· Yellow - network elements that have missed two polling requests
 
· Red - network elements that are not accessible or have not responded to four consecutive polling 

requests
 
· Purple - A service on the network element is down.

You can change the default colors in the Map Colors options.    

You can quickly display a brief status message by moving the cursor on to a network element. In the 
status line, a message displays the network element's hostname, IP address, and current status or 
service status. 

WhatsUp Gold displays a count-down timer in the status line of the Map window. The timer is set to the 
Map Poll Frequency (in File ->Map Properties) and counts down to one between each poll. WhatsUp Gold
resets this timer after each polling. 

Alarms

An alarm will sound when the network element fails to respond to four (the default) consecutive polling 
requests, provided sound alerts are enabled (in the Alerts properties for the network element). To hear the
alarm, you must have a sound card installed on your system. You can set the number of failed poll 
requests that triggers an alarm.

To turn off an alarm, click the  button in the main window's toolbar, or select Stop Alarm from the 
Tools menu.

Notifications

Any notifications that you have enabled (in the Alerts properties) will be sent when the network element 
fails to respond to four (the default) consecutive polling requests. You can set the number of failed poll 
requests that triggers the notification.

To view the active notifications for a network map, select Notifications Window from the Windows menu. 

Status Information

To display status information associated with any of the displayed network elements (active or inactive), 
double click on the network element. The Properties dialog box appears. Click the Status tab to display 
current status information.



Using the Map Editor

You use the Map Editor to create, move, and delete individual network elements (such as workstations, 
routers, and bridges), drawing objects (which include rectangles, ellipses, and text), and "attached" and 
"free" lines. Network elements represent devices on your network. Drawing objects let you organize your 
map to best represent your network. Attached lines show a connection between elements and move with 
the network element. Free lines can show connections but are not attached to any element and do not 
move when you move the element.

To access the Map Editor, first select the map that you want to edit, then click the Edit Mode  button in 
the main window's Toolbar. The Map Editor toolbars appear. 

The toolbars provide the map edit functions. Many of these functions are also available from the right 
mouse pop-up menu.

Editing Toolbar
Drawing Toolbar
Color Toolbar
Alignment Toolbar
Hiding/Displaying the Toolbars
Positioning the Toolbars



Editing Toolbar

You can use the Editing Toolbar to create network elements and select, move, cut, copy and paste 
network elements and drawing objects.    

Position the mouse pointer over a toolbar button to display a description of the button in the status line. 
Click on a tool button to make it the currently active tool.

Note: By default, when you click a tool button it is active for one operation. If you want the tool to remain 
the active tool, make sure the Keep Buttons Down item in the options menu is checked. 

Cut, Copy, Paste, and Undo tools
Select tool
Display tool
Add Icons tools
Add Line tool



Cut, Copy, Paste, and Undo tools

Select a map element, then click the Cut tool (scissors icon) to delete the element.

Select a map element, then click the Copy tool to copy it to the Windows clipboard.

Select the Paste tool to paste an element that has been copied or cut.

Click the Undo tool to undo the last change that you made. 



Select tool

When the Select tool is active, you can click and drag any map element to a new location on the map, or 
you can click and drag the end point of a line to a new location. The Select tool is the default active tool.

You can press Shift+mouse button to select multiple elements, and then click on one of the selected items
and drag them together to a new location.



Display tool

When the Display tool is active, you can click on a network element to view and modify its properties. 



Add Icons tools

The Editing Toolbar provides icons for nine types of network elements: Workstation, Host, Server, Router, 
LAN box, Bridge, Hub, Printer, and Subnet. When you click on one of these icons, it becomes the active 
Add tool. Click on the icon type (for example Add Workstation), and then click on the map to add the icon.



Add line tool

When the Add Line tool is active, you can click and hold the mouse button on the map, and then drag the 
cursor to create a line. To change the line width and color, select the line, and then click the right mouse 
button and select Properties from the pop-up menu. You can enter changes in the Properties dialog box.



Drawing toolbar

You can use the Drawing Toolbar to create rectangles, filled rectangles, ellipses, filled ellipses, and lines 
on your map. These drawing objects can be used to group and visually organize the segments of your 
network.

Position the mouse pointer over a toolbar button to display a description of the button in the status line. 
Click on a tool button to make it the currently active tool.

Note: The Color Toolbar to assign a color to be used for lines and borders and to set the fill color. You can
always change color settings by selecting the element's properties from the right mouse pop-up menu.

Add Line tool
Rectangle tool
Filled Rectangle tool
Ellipse tool
Filled Ellipse tool
Text tool



Rectangle tool

When the Rectangle tool is active, you can press and hold the mouse button on the map, and then drag 
the cursor to create a rectangle. The rectangle uses the active border color (shown in the Color toolbar). 
To change the border width and color, select the rectangle, and then click the right mouse button and 
select Item Properties from the pop-up menu. You can enter changes in the Properties dialog box.



Filled Rectangle tool

When the Filled Rectangle tool is active, you can press and hold the mouse button on the map, and then 
drag the cursor to create a filled rectangle. The filled rectangle uses the active border color and the active 
fill color (both shown in the top left corner of the Color toolbar). To change the border width and color and 
the fill color, select the filled rectangle, and then click the right mouse button and select Item Properties 
from the pop-up menu. You can enter changes in the Properties dialog box.



Ellipse tool

When the Ellipse tool is active, you can press and hold the mouse button on the map, and then drag the 
cursor to create an ellipse. The ellipse uses the active border color (shown in the top left corner of the 
Color toolbar). To change the border width and color, select the ellipse, and then click the right mouse 
button and select Properties from the popup menu. You can enter changes in the Properties dialog box.



Filled Ellipse tool

When the Filled Ellipse tool is active, you can press and hold the mouse button on the map, and then 
drag the cursor to create a filled ellipse. The filled ellipse uses the active border color and the active fill 
color (both shown in the top left corner of the Color toolbar). To change the border width and color and the
fill color, select the filled ellipse, and then click the right mouse button and select Item Properties from the 
popup menu. You can enter changes in the Properties dialog box.



Text tool

When the Text tool is active, you can click on any area of the map to add the sample text. The sample text
properties appear. In the Properties dialog box, change the text in the Text box. You can also set color, 
width, font, and rotation properties. 



Color toolbar

You can use the Color Toolbar to assign colors to the drawing objects that you create. Click on a tool 
button to make it the currently active tool. 

To change the Border color, click the left-mouse button on any color square. The Border color will change 
in the toolbar. Any new lines, rectangles, ellipses, or text that you create will have this border color.

To change the Fill color, click the right mouse button on any color square. The Fill color will change in the 
toolbar. Any new filled rectangles or filled ellipses that you create will have this fill color.



Alignment toolbar

You can use the Alignment Toolbar to help you align multiple network elements and/or drawing objects.

Position the mouse pointer over a toolbar button to display a description of the button in the status bar.

First select the elements you want to align, then click one of the alignment buttons. To select contiguous 
elements, press and hold the mouse button, drag the selection box around all elements to be selected, 
and then release the mouse button. The selected elements are highlighted. You can also select elements 
individually by clicking on your first selection, and then using Ctrl+mouse button to select any other 
elements.

Align Left
Aligns the selected elements with the left-most element.

Align Right
Aligns the selected elements with the right-most element.

Align Top
Aligns the selected elements with the top-most element.

Align Bottom
Aligns the selected elements with the bottom-most element.



Hiding/Displaying Toolbars

By default, all of the toolbars are displayed when you are in Edit mode. You can turn display of a toolbar 
on or off by selecting its name from the View menu. For example, to hide the Color Toolbar, select Color 
Toolbar from the View menu. To redisplay the toolbar, select Color Toolbar again.



Positioning the Toolbars

To move any of the Map Editor toolbars to a different location:

1. Point the cursor at the border of the toolbar.

2. Press and hold the mouse button.

3. Drag the toolbar to a new location by moving the mouse.

4. Release the mouse button.



    Program Properties
 

Startup properties 
Reports properties 
Web properties 
Web Access properties 

 
 



 Startup Properties (View->Program Options->Startup)
 
You can view or change the following default startup options:

· When WhatsUp Gold starts up it will open the network map named whatsup.wept that it finds in the 
whatsup directory. 

· Any subnets of the specified map will automatically be loaded (Auto load subnets is enabled).

· The Stack Supports Raw Sockets option is enabled if you use a 32-bit stack that supports raw 
sockets. In most cases, it is disabled if you use a Microsoft stack. 

 
To change the default settings:

Use these settings on startup
To change the default startup network map, enable this option and select a Map Name from the drop-
down list. If necessary, enter the Directory where the map can be found.

If the map has subnets that you also want to load, check the Auto load subnets option (this option is 
enabled by default). 

Mini Status
To open the network map in Mini Status mode, check this option. Mini Status mode provides a simple 
listing of the network elements (in place of the main window) and is designed to save screen space. 

Open the specified context on startup
To specify a context to open on startup, select this option and select a context from the drop-down list.

Stack Supports Raw Sockets
This option should be enabled if you are using a 32-bit network stack that supports raw sockets, such as 
the Acadia stack from Ipswitch, Inc. This is normally disabled when using Microsoft network stacks. 
However, if you are using Windows NT 4.0 and have administrator access, you should enable this option. 
Note that the Traceroute tool will not work correctly on NT 4.0 with raw sockets enabled.

Click Apply to save your changes.
 
Other Program Properties 
 



 Reports Properties (View->Program Options->Reports)
 
The Reports options let you send a network status report as a pager or e-mail message at a specified 
time interval. You can set up these options so that you receive up-to-date status reports at a remote site, 
so you can be assured the network is running smoothly, or so you can be quickly apprised of any 
problems.    

To set up the status report notification:

1. From the View menu, select Program Options. The Options dialog box appears.

2. Select the Reports tab to display the Reports options.

3. Select the Enable Reports option (make sure it is checked).

4. Click the Add button. The Add/Edit WhatsUp Reports dialog box appears.

Select a notification action from the drop-down list.

For example, if you created a notification action that sends e-mail to the network administrator, you can
select that action from the drop-down list. 

6. Enter how often (in minutes) you want to send the report.

7. Select the Time Period when you would like to receive the report. Click Change to change the default 
setting of 7 days a week, 24 hours a day.

Note: To receive a WhatsUp Report at a specific time every day, enter that time in both boxes. For 
example, enter 0600 in both boxes of the No notify between option.

8. Check any other options you want to use. 

9. Click the OK button to apply the new notification and close the Add/Edit WhatsUp Reports dialog box.

The new notification appears in the Notifications list in the Reports options.

10. In the Reports options, click on OK to save the changes and close the dialog box.

 
Other Program Properties 
 



 Web Properties (View->Program Options->Web)
 
WhatsUp Gold provides a Web server that lets you view the status of your network from any Web 
browser. You can enable/disable the Web server and set access to this server through the Web 
properties. 

To set up the Web server:

1. From the View menu, select Program Options. The Options dialog box appears.

2. Select the Web tab to display the setup properties.

3. Make sure the Enable Web Server option is checked.

4. Enter or change any of the setup information.

Main Title

The title displayed on the main Web page for the WhatsUp Gold web site. You can enter any text for the 
title.

Refresh Frequency

The number of seconds between updates to the WhatsUp Gold display on the Web site.
This sets the distributed HTML pages to cause the browser to automatically refresh the display. 
 
TCP Port
The default is port 80, which is the standard TCP/IP port for a Web (HTTP) server. If you already have a 
Web server running on this system, set the port number in this box to another port number (for example, 
8000).

HTML Files Directory

This is the directory that holds the HTML files for the WhatsUp Gold web server. You can add any HTML 
files to this directory to create a WhatsUp Gold Web site. Subdirectories to this directory are also 
supported.    

Note that you should avoid placing a default.htm file in this directory because WhatsUp Gold will open the
default.htm page if you go to the "http://ip_addr/" address. 

Main Page Prefix

Enter a message to be displayed at the top of the main Web page. You can enter up to 100 characters of 
plain text and/or raw HTML code in this edit box. HTML code must start with <HTML> and end with 
</HTML>.

Click the right mouse button in this edit box to access the standard Windows cut, copy, paste, and delete 
functions.

Main Page Suffix

Enter a message to be displayed at the bottom of the main Web page. You can enter up to 100 characters
of plain text and/or raw HTML code in this edit box. HTML code must start with <HTML> and end with 
</HTML>.

Click the right mouse button in this edit box to access the standard Windows cut, copy, paste, and delete 



functions.

Click OK to apply your changes. The changes take effect immediately.

See also:

Setting WhatsUp Gold web access
Logging on the web server
Using the Web display
Other Program Properties 
 



 Web Access Properties (View->Program Options->Web Access)
 
There are two ways that you can restrict access to the Web server. You can use either one or both 
together. 

· Require a userid and password to view data on the WhatsUp Gold Web site. 
 

· Specify an IP address or set of IP addresses that are either granted access to the Web site or are 
denied access.

To set up a userid and password for the Web server:

1. From the View menu, select Program Options. The Options dialog box appears.

2. Select the Web Access tab to display the access properties.
 
3. Select the Access Password option (make sure it is checked).

4. Set a userid and password for logon.

The default userid is test30 and the password is 30test.

5. Select the Web pages for which you want to require logon.

You can select from the Web page options - Summary Page, Map Pages, Item Pages, and Activity 
Log. 

6. Click Apply to save your changes.

When a user opens the WhatsUp Gold web pages, they will be prompted to enter the logon userid and
password before they can view the specified pages.

You can specify a list of IP addresses to be granted or denied access to the WhatsUp Gold web pages.

To deny access to a specific computer or group of computers:

1. In the Web Access properties, select the Granted Access option.

2. Click the Add button. The Deny Access On dialog box is displayed.

3. In the IP Address box, enter the IP address of the computer to be denied access to the WhatsUp Gold 
site.

To deny access to a group of computers, select the Group of Computers option. In the IP Address and 
Subnet Mask boxes, enter the IP address and subnet mask for the group to be denied access.

4. Click OK to add the IP address(es) to the list.

Access will be granted to all computers except those listed.

5. In the Web Access properties, click Apply to save the changes.

To grant access to a specific computer or group of computers:

1. In the Web Access properties, select the Deny Access option.



2. Click the Add button. The Grant Access On dialog box is displayed.

3. In the IP Address box, enter the IP address of the computer to be denied access to the WhatsUp Gold 
site.

To deny access to a group of computers, select the Group of Computers option. In the IP Address and 
Subnet Mask boxes, enter the IP address and subnet mask for the group to be denied access.

4. Click OK to add the IP address(es) to the list.

Access will be denied to all computers except those listed.

5. In the Web Access properties, click Apply to save the changes.

If you also have the Active Password option enabled, when a user logs on from a valid IP address, 
they will be prompted to enter the logon userid and password before they can view the specified 
pages.

See also:

Setting up the WhatsUp Gold web server
Logging on the Web Server
Other Program Properties 
 



Logging on the Web Server

The Web server is assigned a Web address that can be used to open the WhatsUp Gold Web page from 
any browser. This Web address consists of the hostname of the WhatsUp Gold host and the Web server 
port number. The default port number is 80. For example, if your WhatsUp Gold host is named 
monitor1.ipswitch.com, then the Web address will be: http://monitor1.ipswitch.com:80

To log on to the Web server, open any browser on your network and enter your WhatsUp Gold Web 
address in the Address (or URL:) box.

See also:

Setting WhatsUp Gold web access
Setting up the WhatsUp Gold web server
Using the web display



WhatsUp Gold Web Display

After logging on to the WhatsUp Gold Web site, you have access to the following Web pages: Summary 
Page, Map Pages, Item Pages, and Activity Log (depending on how Web Access is set up).

The first page displayed is the Summary page, which lists each active network map by Map Title (the title 
is set in File->Map Properties). You can click on a map title to display the Map page for that network map. 

The Map page view of the network map is similar to the Status Window. It lists each network element in 
the map and shows status using the same colors used in the Map Window. Any services being monitored 
on a network element are shown. 

You can click on any network element in the list to show its Item page. The Item page lists the hostname, 
IP address, and polling statistics for the network element.

You can click the Log item to view the Activity Log page. The Activity Log page shows all events that have
been logged for the elements in a network map.

See also:

Logging on to the Web Server
Setting up the WhatsUp Gold web server
Setting WhatsUp Gold web access



    Map Properties
 

Map properties
Color properties 
Alerts properties 

 
 



 Map Properties (File->Map Properties->Map)
 
You can set the polling and display properties for each network map and subnet map. 

Select the Map Window for which you want to set map properties, then select Map Properties from the 
File menu. The Map Properties dialog box appears.
 
Map Title
This title is used to identify the network map when accessed from a Web browser and when printing the 
Status, Tree, List, and Notifications Windows.
 
Map Poll Frequency
This is the number of seconds between the start of polls. The status line of each Map Window displays a 
timer that counts down from this number to zero before starting each poll. Note that this timer continues to
count down during polls. If the previous poll is not complete when the timer reaches zero, a new poll is not
started. 

Default timeout
This is the number of seconds to wait for a response from a polled network element. This default value is 
used for new network elements that are added to the map.
    
Auto Resize
When this option is checked, the map will shrink to fit the display window, if necessary. If the window is 
larger than required to display all of the network elements, the map is not resized. (This option applies to 
the Map Window in monitor mode only, it does not affect the Edit mode.)
 
Clip Names
When this option is checked, the display names for network elements are terminated at the first space or 
period in the name, thus shortening the display name.
 
Wrap Names
When this option is checked, long display names are wrapped at every space or period in the name.
 
Label Font
Specifies the font used for the network element's display name. Click the Change button to open the 
standard Windows font selection dialog box. Select the font properties you want to use and click OK. The 
"Sample Label" shows the new font selection.
 
Map width/height in pixels
Specifies the maximum map size and the size of the internal display buffers. These should be set to the 
same size as the display screen. The default setting is 800 by 600. In Edit mode, these settings will 
appear as a dotted line in the Map Window.
 
Background Bitmap and Position
Allows you to specify a bitmap image file to be used as a background for the WhatsUp Gold map. This 
could be a floor plan, a geographical map (city, state, or country), or any bitmap image that you want. You 
can position the bitmap to completely fill the map background (Stretch), or place it within the map using 
the TopLeft, Center, or Tile settings. Note that the color depth of the bitmap must be equal to or less than
the color depth of the screen.
 
Other Map Properties 
 



 Program/SNMP Properties (View->Program Options->Program/SNMP)

Set options for applications used with WhatsUp Gold and set SNMP trap handling options.

Sound Recorder
Program that is executed when you select a .wav file.

BMP Editor
Program that is executed when you select a bitmap (.bmp) file. 

Telnet program
Program that is executed when you select Connect from a network element's pop-up menu. 

SNMP options
Set the SNMP options to allow monitoring of SNMP information for network elements.
Enable the SNMP Trap Handler if you want WhatsUp Gold to log SNMP traps in the system log file and 
in individual network element's Log properties.

Enable the Add Registry Entries option to add the six standard SNMP traps to the Windows registry. 
WhatsUp Gold adds entries from the mib.txt file (located in the directory where you installed WhatsUp 
Gold) to the registry key:

      HKEY_CURRENT_USER\Software\Ipswitch\WhatsUp\SNMP\Traps

See Monitoring SNMP for more information on the SNMP options.



 Map Color Properties (File->Map Properties->Color)
 
For each network map, you can set the default colors used for the various alerts and the colors used in 
the map display (such as the background, free lines, attached lines, and other drawing objects). 

To change the color for an item, select the item name in the list box and click the color patch that you 
want. The current setting for a name is displayed to the right of the list box, above the color patches. 
Colors that can be modified include:

Responding

This is the color used to paint the icon or text background of a network element that is responding to 
active checks. The default is solid green.

Lost 1 pkt

This is the color used to paint the icon or text background of a network element that has timed out on one 
active check. The default is solid light green.

Lost 2 pkts

This is the color used to paint the icon or text background of a network element that has timed out on two 
consecutive active checks. The default is solid yellow.

Lost 3 pkts

This is the color used to paint the icon or text background of a network element that has timed out on 
three consecutive active checks. The default is solid yellow.

Lost 4-7 pkts

This is the color used to paint the icon or text background of a network element that has timed out on four 
to seven consecutive active checks. The default is solid light red.

Lost 8+ pkts

This is the color used to paint the icon or text background of a network element that has timed out on 
eight or more consecutive active checks and for elements that have a network error such as network 
unreachable. The default is solid dark red.

Service down

This is the color used to paint the icon or text background of a network element that has a predefined 
service that is down. The default is solid purple. 

Inactive

This is the color used to paint the icon or text background of a network element that is not being 
monitored (the Monitor option in the Define properties is disabled). The default is solid dark grey.

Background

This is the color used to paint main window background. The default is solid light grey.

Text



This is the color used to paint the text used in labels in the main window. The default is solid black.

Attach lines

This is the color used to paint lines created in the network map using the Attach to item from the pop-up 
menu. The default is solid yellow.

Free lines

This is the color used to paint lines created in the network map using the Add Line button on the Tools 
window. The default is solid yellow.
 
Other Map Properties 
 



Map Alerts Properties (File->Map Properties->Alerts)

You can set up alerts and notifications globally, rather than setting them for each network element. You 
can specify alerts and notifications to apply to selected network elements or to apply to all network 
elements in the map. You set up global alerts and notifications in Map Properties->Alerts.

Note: Alerts and notifications set in Map Properties->Alerts will replace any alerts and notifications set up 
through a network element's Alerts properties. Because of this, you should set up any global alerts and 
notifications before you set alerts and notifications for individual network elements. 

To set properties for all network elements:

1. From the File menu, select Map Properties. In the Map Properties dialog box, select the Alerts tab.

2. Set the Alerts and Notifications you want to apply. See Alerts properties for information on setting the 
alerts properties. See Defining Notifications for information on defining the notification actions.

3. Select the Apply to all option.

4. Click Apply to apply your changes. Click OK to apply your changes and exit the Properties dialog box.

To set properties for selected network elements:

1. In the network map, select the network elements to which you want to apply the alerts.

2. From the File menu, select Map Properties. In the Map Properties dialog box, select the Alerts tab.

3. Set the Alerts and Notifications you want to apply. See Alerts properties for information on setting the 
alerts properties. See Defining Notifications for information on defining the notification actions.

4. Select the Apply to selected option. 

5. Click Apply to apply your changes. Click OK to apply your changes and exit the Properties dialog box.

Note: When deleting notifications, make sure you select the Apply to all or Apply to selected option before
clicking Apply.



    Network Element Properties
After creating your network map, you can further define each network element and set how you want to 
monitor an element and how you will be notified it its status changes.

Note: You can begin monitoring immediately based on the default settings for the network element's 
properties, provided each network element has a valid IP address.
 
Network element properties are available by right clicking on a host and selecting Item Properties from 
the popup menu, or by double clicking on a network element.
 

Main properties
Monitor properties 
Alerts properties 
Services properties
Notes properties 
Menu properties 

 
The following properties do not show up when in Edit mode and are informational only:
 

Status properties
History properties 
Up-Time properties 

 Log properties
 



 Host Main Properties (Host Popup Menu->Item Properties->Main)
 
The Main properties define the display name, hostname, IP address, and type of network protocol to use 
for polling. When you create a network element, you need to specify its hostname and IP address before 
WhatsUp Gold can monitor it. 

Note: When you create a map using any of the automatic scan or load methods (from the Tools->Import 
menu), the network element's display name, hostname, and IP address are already entered. 
 
Display Name
Used in most views to identify the network element. If the Display Name is long, you can set options (in 
Map Properties) to clip the name at the first period or space or to wrap the name in map displays.

Host Name 
This should be the official host name (or the IP address) of the network element if the polling method is 
ICMP or TCP/IP. If the polling method is NetBIOS, this must be the NetBIOS name.
 
Address
WhatsUp Gold will use the value in the Host Name box to look up the IP address, if the polling type is 
ICMP or TCP/IP. If the polling type is NetBIOS, this box is not editable and will contain the hardware 
ethernet address of the network element, after WhatsUp Gold completes a successful poll of the element.

Check the box next to the Address text box if you want WhatsUp Gold to look up the IP address (by using 
the value in the Host Name box) whenever it polls this network element. This is useful if you use DHCP to
assign IP addresses, but note that if you use this feature for many network elements, the name lookups 
will put a heavy load on the DNS server
 
Type
Select the desired type from the drop-down list. This option is used to select the icon to display. The 
subnet icon is a special type that is used to link a subnet map to a map. 

Info Line 1 and Info Line 2
In these text boxes, enter any information you want to associate with the network element. For example, 
you can enter a name that is the "point of contact" for a system or location. This information can be 
included in notification messages.

Network protocol used for polling
Supported protocols are: ICMP (the default polling method), NetBIOS (used for Windows networks), and 
TCP/IP. 

TCP/IP is used to monitor systems outside of a firewall when the firewall will not pass ICMP packets but 
will pass TCP/IP packets. If TCP/IP monitoring is enabled, you must select at least one service to be 
monitored on this network element (in the Services properties) or it will revert to ICMP.
 
If NetBIOS monitoring is enabled, you cannot monitor any services on this network element and the Host 
Name box must contain a valid NetBIOS name.
 

Other Host Properties 
 



Host Monitor Properties (Host Popup Menu->Item Properties->Monitor)

You can use the Monitor properties to turn monitoring on or off for a network element (the default is on), to
specify how often to poll the element, the number of seconds to wait for a response, and any up or down 
dependencies. 
 
Monitor this item
When enabled, this network element will be polled when polling is active. If this option is disabled, the 
network element is "greyed out" on the network map.
 
Poll Frequency
The default value of 1 indicates this network element should be checked on every poll.    You can increase
this value and cause the network element to be checked every 2nd, 3rd, 4th, etc… poll.
 
Timeout
Enter the number of seconds to wait for a response from a polled network element. Because some 
network elements may be at a different site or may take longer to respond, you can change this timeout. 
You can enter a value from 1 to 20 seconds.
 
Time period
Specifies when you want to monitor this network element. Click the Change button to change the default 
setting of 7 days a week, 24 hours a day.

Connected to item
Optionally, to draw an attached line from this network element to another element, select an element from
the Connected to item drop-down list. 

WhatsUp Gold will draw an attached line between the two network elements. This attached line will be the
primary connection (shown as a line width of two pixels) if it is the only connection from the network 
element or it is the last connection made from that network element. In these cases, any other attached 
lines from this network element will be secondary connections (shown as a line width of one pixel).

(You can also draw attached lines between elements by right clicking on an element and selecting 
Connect to from the popup menu (in Edit mode), and then clicking on another network element.)    
 
Check only if up item
If item A is "up dependent" on item B, then item A is only polled if item B is reachable. If item B is not 
reachable, then item A will automatically be assumed to be down, will not be polled, and will take on the 
same down count as item B.
 
Check only if down item
If item A is "down dependent" on item B, then item A is only polled if item B is not reachable. If item B is 
reachable, then item A will automatically be assumed to be up. If item B is not reachable, then item A will 
be polled. For example, you can set down dependencies so that WhatsUp Gold will poll intervening 
routers only if the end point is not reachable. To set this up, you can use the TraceRoute tool to 
automatically map a path to an address and tell it to Set Dependencies. Look at the result in the Tree 
Window (which shows dependencies) after creating the traceroute map.
 
 
Other Host Properties 



Host Services Properties (Host Popup Menu->Item Properties->Services)
 
WhatsUp Gold lets you monitor a service (such as SMTP, POP3, or HTTP) on a network element and 
notifies you if it goes down.

Check each of the services that you need to monitor on the network element. We recommend that you 
ONLY monitor those services that are critical to your operation as each service that you monitor adds to 
network load and to host load. Note that you can watch the protocol conversation by opening the View-
>Debug Log.
 
You can click the Scan button on the Services page to scan the network element and determine if any of 
the standard services are running on that host. Services found on the machine are marked with a check. 
Note that you cannot cancel a scan for services in this dialog once you press the Scan button.

You can click on a User Define service to display a dialog box that lets you define a specific service to 
monitor. This is useful if a service does not appear in the list of Services, or if it uses a nonstandard port 
number. When you enable one of the user defined services, a dialog will be presented that will allow you 
to define/edit a special service check. See User Defined Services.
 
Note: By default, WhatsUp Gold monitors services using the ICMP network protocol. If you are monitoring
a service that is outside of a firewall and the firewall will not pass ICMP packets, you need to set the 
network type to TCP. (Click the Main tab and set the Network Type to TCP/IP). 

WhatsUp Gold will check that the selected services are running whenever it polls the network item. If a 
service is down, the network element will change color to purple. If a user-defined service is down, the 
regular color codes are used (green = up, red = down).

You can also double click on a network element and select Status properties to show the status of polled 
services: green = up, red = down. 
 
Other Host Properties 



User Defined Services
 
You can also monitor for a specific service that does not appear in the list of standard services. You can 
define up to three user-defined services to be monitored on the network element. For example, you may 
want to monitor an IRC (Internet Relay Chat) service or a RADIUS (Remote Authentication and Dial-In 
User Service) server.

Name
Enter a display name for this service. 
 
Port
Enter the TCP/IP or UDP port number that you want to monitor. (For example: 6667=IRC, 
1645=RADIUS). Select the Port type: TCP or UDP. (For example, TCP for IRC, UDP for RADIUS).
 
Timeout Seconds
Since some network elements may be at a different site or may take longer to respond, you can change 
the amount of time that WhatsUp Gold will wait for a response from the element.    This can be from 1 to 
20 seconds.
 
Expect on connect
Optionally, enter the exact string that is expected to be returned by the remote service when you connect. 
For example, a logon prompt from FTP expects "220 " (rest of line is discarded). It is considered to be an 
error if the service does not match this string exactly (unless no string is specified here).
 
Send command on connect
Optionally, enter a string to send to the remote network element. (For example, for IRC, the send the 
command is: "Version\r\n"). 
 
Expected command response
Optionally, enter the exact string that is expected to be returned by the remote service after you send the 
command above. (For example, for IRC, this is ":irc") It is considered to be an error if the service does not
match this string exactly (unless no string is specified here).
 
Send to disconnect
Every good net citizen says goodbye when they are done. This would be "QUIT\r\n" for a service like FTP.
 
The \r (carriage return) and \n (line feed) are the conventions for sending these control characters to 
terminate a string.

You can use \r = 0x0a, \n = 0x0d, \t = 0x09 or %nnn where nnn is any value from 0 to 255. It is up to the 
user to determine the proper strings to expect and send in a user defined service.



 Host Alerts Properties (Host Popup Menu->Item Properties->Alerts)
 
Use the Alerts properties to configure alerts/notifications and logging for a network element. 

When a network element does not respond to polling, WhatsUp Gold will display the element in a different
color. In addition to this visual alert, you can specify the following types of alerts: sound alarms and 
notification via a beeper, pager, e-mail, or voice message.
 
Note: You can set up alerts for all network elements or for selected network elements by using the global 
alerts properties in Map Properties->Alerts. Alerts and notifications set in Map Properties->Alerts will 
replace any alerts/notifications set up in the network element's Alerts properties. Because of this, you 
should set any global alerts/notifications before you set them for individual network elements.

Activate alerts for this item 
This must be enabled for either sound or notifications to be enabled. (This setting has no impact on 
logging.)

Log Activity 
When enabled, a log entry is written when a host is initially unreachable (has missed 4 polls) or returns to 
a reachable state. The log entry is made in the mapname.LOG file in the same directory as the map and 
can also be viewed in the network element's Log properties. 
 
Sound Alerts
You can use the Sound properties to set or change the sound alarm. 

Enable Sound
Select this option to sound an alarm (play a selected .wav file) when the network 

          element fails.

Trigger
Enter the number of missed polls after which the alarm will be sounded. The default value is 4.

Continuous
Select this option to sound the alarm until it is manually turned off (by clicking the Quiet button in the 
main window's toolbar).

Filename
In this text box, enter or select the sound (.wav) file that will be played when the network element goes 
down. WhatsUp Gold provides three .wav files: alarm1.wav, alarm2.wav, alarm3.wav. 

Click the Browse button to browse the directories and select a .wav file. Click the Sound button to 
open the .wav file in the Sound Recorder. You can play the sound file or edit it to create a different 
sound. For information on recording and editing sound files, select an item from the Sound Recorder's 
Help menu.
 

Notifications
Add any notifications that you want to occur when this network element goes down or comes back up. 
You can have up to 10 notifications for each network element. Any notifications shown in the list box will 
be activated when Enable Notifications is checked.

Any of the system defined notification types can be specified for each network element. In addition, you 
can use multiple notifications of the same type with different trigger values. 

To add a notification click Add (see Add/Edit Notification); to edit a notification, select it and click Edit (or 
double click the notification in the list box); to delete a notification, select it and click Delete. 



 
Note: Before you can add a notification to a network element's alerts, you need to define the notification 
by using the Notifications Editor.

Defining Notifications 
Other Host Properties 
Other Map Properties 



Add/Edit Notification
 
Add or modify a notification to be sent if the network element goes down or comes up (or a service 
changes state).
 
This dialog box changes depending on the type of notification that is selected. Some of the fields are only 
valid for beeper notifications, some are only valid for program notifications and some are only valid for 
voice notifications.
 
Note:    You can send an Up alert if you set the trigger value to 0. It will only honor that notification if at 
least one other notification was processed.
 
Any notification except sound notifications can be sent when the host comes back up after sending the 
down notification by enabling the Auto send UP alert after sending DOWN alert option.

Drop-down list
All notification actions that have been defined are available from the drop-down list. Select an action, such
as Default Beeper or Default Pager, from this list.

Trigger
After this number of failures on system checks, send notification. This is an exact match of the down 
count for when the notification should be activated. We recommend that this number be at least 4.

Auto send UP alert after sending DOWN alert
When checked, performs notification action when the system comes back up after a down notification. 
(This property is valid for all notifications except Sound notifications.)

Send alert even if console response
When checked, any active notifications for the network element will be sent even if the alarm has been 
turned off on the WhatsUp Gold console (by clicking the Quiet Alarm button in the main window's toolbar).

Time Period 
Set the Time Period options to specify when you want to receive notifications from this network element. 
Click Change to change the default setting of 7 days a week, 24 hours a day. 
 
If you are adding a beeper notification, the Item digital code option appears. If you are adding a voice 
notification, the Wave file option appears.

The Item digital code is a unique numeric code that identifies the network element (for example, the IP 
address). This code is sent to the beeper following an "Up" or "Down" code. It is only valid for beeper 
notifications. (Note: The period (.) character is not accepted in this box; you can use the asterisk (*) 
character to separate numbers in an IP address.

For voice notifications, the Wave file option accepts a .wav file entry. You can use this option to specify a
.wav file that identifies the network element. To do this, record a .wav file for the network element; for 
example, the recording could say "Gyro". When the network element goes down, the voice message will 
be "Gyro is down." The default in this box ([auto]) will play the file ahost.wav, which says "a host," as in 'a 
host is down.
 



 Host Menu Properties (Host Popup Menu->Item Properties->Menu)
 
Defines additional menu options that appear on the right mouse button pop-up menu for 
a network element.
 
Four internal values can be used as the command line. These include:
[telnet] calls telnet.exe
[ping] calls internal ping routines
[trace] calls internal traceroute routines
[browse] calls ShellExecute with an automatic URL.
 
The command line can contain the following special characters:
%1 returns Info Line 1 in place of %1
%2 returns Info Line 2 in place of %2
%l returns Display Name in place of %l (lower case L)
%n returns Hostname in place of %n
%a returns IP Address in place of %a
 
Info Line 1, Info Line 2, Display Name, Hostname, and IP Address are set in the network element's Main 
properties.

Example lines that can be used:
ftp95pro.exe ftp://%a/
ftp://%a/
http://%n/
 
Other Host Properties 
 



 Host Status Properties (Host Popup Menu->Item Properties->Status)
 
Displays the current status of a network element.
 
Status
Current status of the host.    Numeric status above 10000 is a WinSock error response.
 
Count
Total number of times that this host was polled.
 
RTT
Last round trip time.
 
Down Count
Count of how many polls have passed since the host last responded to the specified type.
 
Total
Total count of how many polls occurred where the host did not respond to the specified type since 
WhatsUp started or since the host was added to the map.
 
Last Response Time
Time of the last response of this type.
 
Other Host Properties 
 



 Host Up-Time Properties (Host Popup Menu->Item Properties->Up-Time)
 
Shows the percentage of successful polls for the total poll count for the network element.
 
Other Host Properties 
 



Host Log Properties (Host Popup Menu->Item Properties->Log)
 
Displays any log entries for this network element. You must select the Log Activities option in the Alerts 
properties to enable logging for the network element. An entry is made in the log when the network 
element misses one or more polls and when it comes back up after being down.

If SNMP trapping is enabled, the events trapped for this network element are displayed in 
this log.
 
Other Host Properties 



Round Trip Time (RTT)

The time (in milliseconds) that it took the last packet sent to arrive at the network element and return.



 Host History Properties (Host Popup Menu->Item Properties->History)
 
Displays graph of round trip time (RTT) for host for the last 30 polls. Red vertical bars indicate the network
element not responding.
 
Other Host Properties 
 



 Host Notes Properties (Host Popup Menu->Item Properties->Notes)
 
Display or modify notes for a network element. 

The edit window supports use of the standard Windows edit functions. Click the right mouse button in the 
edit window to display the editing pop-up menu.
 
Other Host Properties 



    Net Tools
 

Ping 
TraceRoute 
Lookup 
Whois 
Finger 
Misc 
Scan 

 SNMP
 



 Ping (Tools->Net Tools->Ping)
 
The Ping tool is a network diagnostic tool used to verify connectivity to a particular system on your 
network. Ping sends an ICMP "echo request" in the form of a data packet to a remote host and displays 
the results for each "echo reply". This exchange is referred to as "pinging." The Ping command also 
displays the time for a response to arrive in milliseconds (this will vary depending on network load) and 
debugging information about the network interface. You can have multiple instances of the Ping 
application active simultaneously.

To Ping a Host:

1. From the View menu, select Net Tools. The Network Tools dialog box appears.

2. Select the Ping tab to display Ping options.

3.In the Hostname or IP Address box, type a hostname or IP Address (for example, internic.net).

4. Set any of the options you want to use:

Count
The number of data packets sent by the ping command.

Delay (sec)
Number of seconds to wait between sending a ping.

Size
The length in bytes of each packet sent by the ping command.

Timeout
The ping will fail if the host does not respond after this number of milliseconds.

5. Click the Start button.

The Ping application sends an echo request and waits for the echo reply.    If the Ping was successful, 
summary lines are displayed in the Ping window, indicating the result of the Ping.

If the reply is not received within the timeout value, the Ping fails. This means there has been a failure at 
one of several points from your PC to the remote host.    The host may not be functioning and therefore is 
unable to respond, a network or gateway in the path from the user may not be working, or the host may 
not implement the service you are requesting.

Other Net Tools 
 



 Traceroute (Tools->Net Tools->TraceRoute)
 
Traceroute will show you the network path used to reach a specified TCP/IP address. (Note that this will 
NOT show the return path, only the path used to reach the address.)

To initiate a Traceroute search, do the following:

1. From the View menu, select Net Tools. The Network Tools dialog box appears.

2. Select the Traceroute tab to display the Traceroute options.

3. In the Host Name or IP Address text box, enter a host name or IP address for the remote host - this is 
the host to which you want to trace the route.

The drop-down list shows the previous host names or IP addresses for which you've done a 
traceroute.

4. Set any of the options you want to use. 
 

Maximum Hopcount 
Used to limit the trace (normally 32 hops will reach anywhere in the world). When an IP packet passes 
from one host to another, it is referred to as one hop. This can be useful if a router loop occurs or 
devices do not respond.

Resolve Addresses 
When enabled, the hostnames of each router along the route will be displayed along with the IP 
addresses. When disabled, only the IP addresses are shown. Showing the hostnames will add time to 
the traceroute as it requires that the IP addresses be resolved. For maximum tracing speed, disable 
the Resolve Addresses option.
 
Map Results 
When this option is enabled, the intervening routers are added to the current map (with connecting 
lines). If Set Dependencies is also enabled, the intervening devices are marked as "Down 
Dependent" on the next further device. (See the discussion of dependencies in the Tree Window 
section.)
 

 5. Click the Start button.

The results of the Traceroute search are displayed in the Results window.
If the Map Results option is enabled, WhatsUp Gold draws a map of the route. It adds icons for any 
network elements (such as routers) that are not already in the map. 

Other Net Tools 
 



 Lookup (Tools->Net Tools->Lookup)
 
The Lookup tool lets you query Internet domain name servers for information about hosts and name 
servers. You can use Lookup to print just the name and Internet address of a host or domain, query the 
name server for information about various hosts and domains, or print a list of hosts in the domain. You 
can use Lookup to find the IP address from a name or a name from an IP address.

To initiate a Lookup query:

1. From the View menu, select Net Tools. The Network Tools dialog box appears.

2. Select the Lookup tab to display Lookup options.

3. In the Name or IP Address text box, enter a hostname or IP address of the network element or domain
name server you want to look up.

4. Set any of the options you want to use. 

DNS Server
Enter the IP address of the domain name server you want to use or select "{stack}" from the drop-
down list to use the network stack in your operating system.

Query Type
Select a type from the drop-down list. 
 
Note that you can only do name-to-IP-address lookups (A) or IP-address-to-name lookups (PTR) if you
use the network stack. You can look up additional information if you specify a DNS server and use the 
internal lookup system in WhatsUp Gold.
 
The Verbose option is useful only when you specify a DNS server. When enabled, you can see a 
decode of the information that comes back from the DNS server.

5. Click the Start button. 

The information returned by the lookup query is displayed in the Results window.
 

Other Net Tools 
 



 Finger (Tools->Net Tools->Finger)
 
The Finger tool lets you identify and display information about all users on a network host. This 
information includes a display of current users on the host (their userids and usernames). Also displayed 
for each user are the home directory, login time, idle times, office location, last time they received mail, 
and last time they read mail. 

A Finger request will also display any information contained in the file .plan or the file .project in the user's
home directory. These files are often used as a simple way to distribute information. 

If the specified host does not have a Finger server, the Finger client displays the message:    Connection 
not made.

To initiate a Finger query, do the following:

1. From the View menu, select Net Tools. The Network Tools dialog box appears.

2. Select the Finger tab to display Finger options.

3. In the Finger String text box, enter a hostname or IP address.

The drop-down list shows the previous host names or IP addresses for which you sent a Finger 
request.

4. Click the Start button.

The Finger client contacts the host's Finger server. The results of the query appear in the window.
 
Other Net Tools 
 



 Whois (Tools->Net Tools->Whois)
 
The Whois tool, like Finger, is an Internet directory service. Whois provides information about who owns 
an Internet host or domain and who you can contact regarding that host or domain. A Whois request 
displays a contact name, mailing address, telephone number, and network mailbox for all users and 
organizations who are registered with the Network Information Center (NIC) database. 

Note: The current host server for Network Information Center (NIC) is RS.INTERNIC.NET. You can send 
a Whois query to this host to display information on using the services that the NIC provides.
 
To initiate a Whois search, do the following:

1. From the View menu, select Net Tools.    The Network Tools dialog box appears.

2. Select the Whois tab to display the Whois options.

3. In the Search String text box, enter a search string.

If you know the name or handle of an organization, enter it here.

4. In the WAIS Host text box, enter a hostname or username.

5. Click the Start button.

The Whois client contacts that host's Whois server. The results of the query appear in the window.

Other Net Tools 
 



 Misc (Tools->Net Tools->Misc)
 
This tool lets you view the names of all the domains, hosts or shares visible to WINNET on your network 
segment. The drop-down combo box allows you to specify your choice. In addition, you can enter the 
NETBUEI name of a workstation or server on your network and view information about that workstation or
server.
 
1. From the View menu, select Net Tools. The Network Tools dialog box appears.

2. Select the Misc tab to display the Miscellaneous options.

3. In the Network Items text box, select the type of network items that you want to display from the drop-
down list. You can select from the following item types:

networks - show all networks (groups of domains)

domains - show all domains (groups of servers)

servers - show all servers

shares - show all shared devices, such as printers

all - show all the above types of items

4. Click the Start button.

WhatsUp Gold scans your local network and displays the name and IP address of the specified items.

Other Net Tools 
 



 Scan (Tools->Import->Scan IP or Tools->Net Tools->Scan)
 
If you want to map a range of systems in a network, you can use the Scan IP tool. Using the Scan IP tool, 
you specify a range of IP addresses to be scanned, and WhatsUp Gold polls each address. If WhatsUp 
Gold finds an active host, it creates an icon for it on the map. By default, WhatsUp Gold creates a 
workstation icon type to represent each system it scans. 

A scan can also identify the network services (such as FTP, HTTP, SMTP) that are available on each 
system so that you can also monitor the services. 

To start a Scan IP:

1.    Select an existing map or create a new map window.

To select an existing map, select Open from the File menu and enter the map file name.

To create a new map window, select New from the File menu, or click the New button in the main 
window's Toolbar. Select the Create empty map option, and then click Finish.

2.    From the Tools menu, select Import->Scan IP, or from the Tools menu select Net Tools->Scan. The 
Scan dialog box appears. 

3.    Enter a range of network addresses to scan.

Specify the starting address in the top four boxes (defaults to your current network) and the ending 
address in the lower two boxes. The scan is consecutive from the number in the upper box to the 
number in the lower box in EACH position. Thus, if you put 245.245.1.50 in the upper boxes and put 
10.60 in the lower boxes, it will only scan from 50 to 60 in each of the nets 245.245.1 through 
245.245.10.

 
4.    Set any of the options you want to use.

Map results
When this option is checked, WhatsUp Gold will create an icon for each host that it finds. This option is
checked by default.
 
Resolve Names
When this option is checked, WhatsUp Gold will resolve the hostname for each active IP address and 
display the name in the Scan IP dialog box and in the map (if Map results is checked.)
 
Timeout
Enter the timeout in milliseconds (ms). If a network element does not respond to the scan within this 
time, the Scan IP continues on to the next IP address. The Timeout should be set to 300 ms or greater.
For maximum scanning speed, set the Timeout to 300 ms and disable the Resolve Names option.
 
Server Options (DNS, FTP, POP3, SMTP, IMap4, HTTP, NNTP, SNMP, Echo, Gopher, Telnet, Time)
Check any of the types of services for which you want to scan. WhatsUp Gold will scan each active 
host (IP address) that it finds for the selected services. This allows you to then monitor whether the 
services on a host are up or down. 

Note: If you are scanning for services and the found host already exists on the map, the service will be
added to that host.

 
Note: Scanning hosts for these services can significantly increase the time it takes to complete a scan.



All IP devices
When this option is checked, the Scan IP will find all the devices in the specified range of IP 
addresses. If the option is not checked, the Scan IP finds only those devices that are running one of 
the services (specified in the Server options).

5. Click Start. (The Start button toggles to Cancel. You can click Cancel at any time to stop the scan. 
Wait at least three seconds for the system to respond to a Cancel request.)

WhatsUp Gold scans the range of IP addresses. For each active IP address it finds, it lists the IP 
address and also the hostname if the Resolve Names option is selected. The Scan dialog box shows 
the current address being scanned and displays the message "The scan is completed" after scanning 
the end address. If the Map results option is selected, WhatsUp Gold creates an icon for each system 
it finds on the network. 

6.    Click Close to close the Scan IP dialog box.

Changing any option after a scan has started does not affect the current scan.

7. Use the Map Editor to organize network elements, change icon types, and add connecting lines and 
drawing objects.

To change a network element's icon, double-click on it to display the Properties, select the Main tab, 
then select a new Type from the drop-down list. 

8. Enter or modify the network elements' properties.

9. From the File menu, select Save or Save As to save the map.

 
Other Net Tools 
 



Receiving SNMP Traps

WhatsUp has an internal SNMP trap handler (if enabled) that listens for and accepts SNMP traps that are 
addressed to it. (You must set the trap manager addresses on each physical SNMP device. This is 
outside the scope of WhatsUp Gold). When a trap arrives from a device, WhatsUp Gold inverts the 
network element's label to show a status change and records the trap information in the element's Log 
properties..

To enable the SNMP trap handler: from the View menu, select Program Options. In the Options dialog 
box, click the Program/SNMP tab. Check the Enable SNMP Trap Handler option, and then click Apply.

To view trap information, select the network element's Item Properties and click the Log tab. 

WhatsUp Gold converts the numeric identifiers in traps to text according to the entries in the Windows 
Registry key:

HKEY_CURRENT_USER\Software\Ipswitch\WhatsUp\SNMP\Traps

The six standard SNMP traps are added to this list as follows: from the View menu, select Program 
Options. In the Options dialog box, click the Program/SNMP tab. Check the Add registry entries option, 
and then click Apply. WhatsUp Gold adds the entries from the mib.txt file (located in the directory where 
you installed WhatsUp Gold).



Monitoring SNMP Service

To monitor whether SNMP is running on a network element:

1.    Double click on the network element. The Item Properties dialog box appears.

2.    Click the Services tab to display services properties.

3.    Check the SNMP service. Use the default (public) in the Community box unless your system 
administrator has set a different community.

4.    Click Apply to apply your changes Click OK to apply the changes and exit the dialog box.

If SNMP service is being monitored on a network element, an asterisk (*) is displayed next to the 
element's icon in the map.



SNMP Tool (Tools->Net Tools->SNMP)

The SNMP tool lets you view information from a remote host that supports SNMP. To view SNMP 
information:

1.    From the View menu, select Net Tools. The Network Tools dialog box appears. 

2.    Select the SNMP tab to display the SNMP options.

3.    In the Address box, enter the IP address of the network element for which you want to view SNMP 
information, or select one from the drop-down list.

4. If necessary, change the string in the Community box. The default string is: "public"

SNMP (Version 1) as a protocol does not support security. Security is implemented within the manager
itself by stating what IP addresses it will accept requests from. However, simple security can be 
implemented by use of the Community string. The default (public) will work for most SNMP hosts 
unless the administrator has specifically removed public and replaced it with a string of their own. If 
you know a device is manageable via SNMP and public doesn't work, you will have to talk to the owner
of that device to get a community name that will work.

If you use Get Next the SNMP manager (on the remote host) will increment the numbers until it gets a 
valid item and will return that. You can determine the values to use in the What box according to what 
is returned using Get Next.

5. In the What box, enter an SNMP object name or number to retrieve, or select one from the drop-down 
list.

SNMP objects have names like 1.3.6.1.2.1.1. If you know the    actual object for which you want to get 
information, you can enter the name/number in the What box and use Get option. 

If it is a wrong name or number you will not get any information back. You should use Get Next with 
most of the items that are in the drop-down list. "*sysInfo" returns most of the "system" identification 
objects. You can also add numbers to the end of items in the drop-down list to get information about a 
specific instance of the object. (A Get request for ifPhysAddress.2 will return the network adapter 
address of an NT system.) Get All Subitems will return any subitems of the named item.

Clicking the button next to the What box displays a tree view of the SNMP object entries in the 
Windows registry. When you select an object in the tree view, the object identifier is entered in the 
What box. 

6. Click Start to retrieve the object you entered in the What box.

Any information found for the object is shown in the edit window.

WhatsUp decodes text names according to entries in the Windows Registry key:

HKEY_CURRENT_USER\Software\Ipswitch\WhatsUp\SNMP\ObjiD    

WhatsUp converts numeric object identifiers in returned messages according to entries in the Windows
Registry key:

HKEY_CURRENT_USER\Software\Ipswitch\WhatsUp\SNMP\Obj

The default information is added to those keys as follows: from the View menu, select Program 
Options. In the Options dialog box, click the Program/SNMP tab. Check the Add registry entries option,



and then click Apply. WhatsUp Gold adds the entries from the mib.txt file (located in the directory 
where you installed WhatsUp Gold). The mib.txt file contains the entries as specified in MIB 2.

You can add your own information under those keys by editing mib.txt and using the Add registry 
entries option as described above. (You need to run this procedure each time you update the mib.txt 
file.) The mib.txt file is an ASCII file that can be edited with any text editor. The format is one line per 
object, with the object's name, followed by a comma, and then the mib number. For example:

sysObjectID,1.3.6.1.2.1.1.2
sysUpTime,1.3.6.1.2.1.1.3
sysContact,1.3.6.1.2.1.1.4
sysName,1.3.6.1.2.1.1.5

Other Net Tools



Monitoring SNMP Devices

WhatsUp Gold provides limited monitoring of devices that support the Simple Network Management 
Protocol (SNMP). WhatsUp Gold supports SNMP Version 1 and MIB 2. You can make custom extensions 
to MIB 2.

WhatsUp Gold provides the following SNMP monitoring capabilities:

· Ability to receive traps from SNMP devices.

A trap is sent when the status of a network element changes. Traps are unsolicited messages, such as
a router indicating one of its interfaces went down or a printer indicating that it is out of paper.

WhatsUp Gold records traps in the network element's log file and in the system log. Traps do not 
trigger alarms or notifications. When a trap is recorded for a network element, that element's label will 
be inverted (as happens with any change in status). You can then check the element's properties (Item
Properties->Log) for the trap information.

· Ability to view SNMP information on a device.

· Monitoring of whether SNMP is running on device.

You can select SNMP in a network element's Service properties (Item Properties-> Services) and 
monitor it just as you can monitor any TCP service. This checks if SNMP is running on the network 
element; no SNMP management is involved.



 Drawing Object Properties
 
You can set properties for each drawing object that determines the display of the object in the Map 
Window.
 

Line Properties 
Rectangle Properties 
Oval Properties 
Text Properties 

 
 



 Line Properties
 
To change a line's properties:

1. Click the right mouse button on the element and then select Item Properties from the pop-up menu.

2.    Change the appropriate properties.

Line Width
Enter a number from one to ten pixels. One is the smallest line width.

Line Color
Click the Change Color button to select another color. The Color dialog box appears. Select a basic 
color or a custom color and click OK to apply the change.

You can create custom colors in the Color dialog box and assign them to elements. Click the Define 
Custom Colors button to access the color selector.

3. Click OK to apply your changes and close the dialog box.

To resize an object:

1.    Click on the object to select it. 

The object outline appears and shows the square anchor points.

2.    Press and hold the mouse button on an anchor point, drag the mouse to resize the object, and then 
release the mouse button.

 
Other Properties
 



 Rectangle Properties
 
To change a rectangle's properties:

1. Click the right mouse button on the element and then select Item Properties from the pop-up menu.

2.    Change the appropriate properties.

Line Width
Enter a number from one to ten pixels. One is the smallest line width.

Line Color
Click the Change Color button to select another color. The Color dialog box appears. Select a basic 
color or a custom color and click OK to apply the change.

You can create custom colors in the Color dialog box and assign them to elements. Click the Define 
Custom Colors button to access the color selector.

Filled
Click this check box to make the element a "filled" element. The Fill Color will be used.

Rounded
Click this check box to make the corners of a rectangle rounded.

3D Effect
Click this check box to give the element a 3-dimensional effect.

Fill Color
Click the Change Color button to select another color. The Color dialog box appears. Select a basic 
color or a custom color and click OK to apply the change.

You can create custom colors in the Color dialog box and assign them to elements. Click the Define 
Custom Colors button to access the color selector.

3. Click OK to apply your changes and close the dialog box.

To resize an object:

1.    Click on the object to select it. 

The object outline appears and shows the square anchor points.

2.    Press and hold the mouse button on an anchor point, drag the mouse to resize the object, and then 
release the mouse button.

 
Other Properties 



 Oval Properties

To change an oval's properties:

1. Click the right mouse button on the element and then select Item Properties from the pop-up menu.

2.    Change the appropriate properties.

Line Width
Enter a number from one to ten pixels. One is the smallest line width.

Line Color
Click the Change Color button to select another color. The Color dialog box appears. Select a basic 
color or a custom color and click OK to apply the change.

You can create custom colors in the Color dialog box and assign them to elements. Click the Define 
Custom Colors button to access the color selector.

Filled
Click this check box to make the element a "filled" element. The Fill Color will be used.

Rounded
Click this check box to make the corners of a rectangle rounded.

3D Effect
Click this check box to give the element a 3-dimensional effect.

Fill Color
Click the Change Color button to select another color. The Color dialog box appears. Select a basic 
color or a custom color and click OK to apply the change.

You can create custom colors in the Color dialog box and assign them to elements. Click the Define 
Custom Colors button to access the color selector.

3. Click OK to apply your changes and close the dialog box.

To resize an object:

1.    Click on the object to select it. 

The object outline appears and shows the square anchor points.

2.    Press and hold the mouse button on an anchor point, drag the mouse to resize the object, and then 
release the mouse button.

 
Other Properties    



 Text Properties
 
To change text properties:

1. Click the right mouse button on the element and then select Item Properties from the pop-up menu.

2.    Change the appropriate properties.
 

Foreground
Click the Change Color button to select another color. The Color dialog box appears. Select a basic 
color or a custom color and click OK to apply the change.

Opaque
Check this box if you want to set the text against a selected background color.

Background
If the Opaque option is checked, the Background color is used. You can click the Change Color button 
to select another color. The Color dialog box appears. Select a basic color or a custom color and click 
OK to apply the change.

Change Font
Click the Change Font button to change the font of the text. A standard Windows font dialog box 
appears. You can set the font, font style, and size. You can also set strikeout, underline, and color 
effects.

Rotation
Enter a number from 0 to 360 to represent the degrees to rotate the text. You must be using one of the 
TrueType fonts in order to rotate text. The hit points (where you have to click to select it or move it) 
remains at the original location of the text. Rotation is specified as clockwise in degrees. (A negative 
value will rotate clockwise.)

3. Click OK to apply your changes and close the dialog box.

To resize an object:

1.    Click on the object to select it. 

The object outline appears and shows the square anchor points.

2.    Press and hold the mouse button on an anchor point, drag the mouse to resize the object, and then 
release the mouse button.

Other Properties 
 



Creating a New Map
 
This wizard helps you create a new map. You can:

· Create a blank map, and add network elements using any of the create map functions or by cutting 
and pasting from an existing map.

· Use the Auto Load option to create a map from information contained in a local hosts file, the Windows
registry, Internet Explorer and Netscape entries in the registry, and Windows Network information. You 
can specify which of these sources you want to use.

To create a blank map: 

1. From the File menu, select New, or click the New button in the Toolbar. The New Map dialog box 
appears.

2. Select Create a blank map and press Finish.
 

You can use the Map Editor to add network elements and drawing objects, or cut and paste elements 
from an existing map. You can also use any of the create map functions (Tools->Import) to map your 
network.

To have WhatsUp Gold create a map of your network:

1. From the File menu, select New, or click the New button in the Toolbar. The New Map dialog box 
appears.

2. Select Auto load map and then click the Next button. The Auto Load Parameters screen appears.



Auto Load Parameters
 
Select Import hosts from registry if you want hosts that are referenced in the TCP/IP, Microsoft Internet 
Explorer or Netscape Navigator configurations to be automatically added to the map.
 
Select Import hosts from hosts file if you want to import hosts from the systems HOSTS file. (Note this 
may be empty unless you have specifically added hosts to the HOSTS file.)
 
Select Import hosts from MSNet if you want to import hosts that WhatsUp Gold can find via the 
Microsoft network. (These are the same hosts that are listed when you browse the network.)
 
Press Next to continue after making your selections.
 



Finish
 
Click Finish if you want to continue with the options that you selected. Note that it may take several 
minutes before the auto load process completes (you will be at the map window) if you selected Import 
hosts from MSNet in the previous screen (accessible by pressing Back).

When the map is completed, you can use the Map Editor to organize network elements, change icon 
types, and add connecting lines and drawing objects. 

To change a network element's icon, double click on it to display the Properties, select the Main tab, then 
select a new Type from the drop-down list. Enter or modify any other network element properties.

To save the map, select Save or Save As from the File menu.



Save Context (File->Save Context)
 
Saves the current layout of the screen and the various windows that may be open so that you can restore 
this same layout with File->Load Context (or set it to be the default startup context in View->Program 
Options->Startup).
 



Load Context (File->Load Context)
 
Restores a previously saved context.
 
 



Add Report
 
1. Select a notification action from the drop-down list.

For example, if you created a notification action that sends e-mail to the network administrator, you can
select that action from the drop-down list. 

2. Enter how often (in minutes) you want to send the report.

3. Select the Time Period when you would like to receive the report. Click Change to change the default 
setting of 7 days a week, 24 hours a day.

Note: To receive a WhatsUp Report at a specific time every day, enter that time in both boxes. For 
example, enter 0600 in both boxes of the No notify between option.

4. Check any other options you want to use. 

5. Click the OK button to apply the new notification and close the Add/Edit WhatsUp Reports dialog box.

The new notification appears in the Notifications list in the Reports options.
 



Defining Notifications

When a network element does not respond to polling, WhatsUp Gold can notify you in several ways: 

· Changing the color of the network element and sounding an alarm. 
· Activating a beeper. 
· Sending a message to a pager or an e-mail account.
· Sending a voice message to a telephone or answering machine (if you have a voice modem installed).

You can also set up a notification to send a network status report at a specified time interval. 

Setting up notification for a network element involves two steps:

1. You first need to define the notification actions that you will want to use, such as activating a network 
administrator's beeper or sending e-mail to an individual. You define the different types of notifications 
using the Notifications Editor. 

To access the Notifications Editor, open the network element's Properties dialog box and click Alerts, 
select the Enable Notifications option (make sure it is checked), and then click the Notifications 
Editor button; or, from the View menu, select Notifications.

You can define the following types of notifications:

System Notifications
Pager Notifications
Beeper Notifications
E-mail Notifications
Program Notifications
Voice Notifications

2. Then, you can enable a notification action for a particular network element, selected elements, or all 
elements.

See Setting the Alerts for information on enabling notification actions for a network element. See 
Setting Alerts and Notifications Globally for information on enabling notification actions for all network 
elements or for selected elements.

Use the Notifications Window to view all active notifications.



System Notifications
 
You can define a Sound notification to sound an alarm when a network element goes down or comes 
back up. This sound notification is in addition to the default sound alarm (set in the Alerts properties). You 
can also define WinPopup notifications to display a message in the WinPopup window (on Windows NT 
systems only). You can specify the hosts to which the WinPopup notifications are broadcast. 

In the Notification System dialog box, click the System tab to display the System properties.

To define a Sound notification:

1. Click New and enter a unique name for the notification.

The new notification name appears in the listbox.

2. In the Filename text box, enter the name of the .wav file to be played when this notification is triggered.

Click the Browse button to browse the directories and select a .wav file. Click the Sound button to 
open the .wav file in the Sound Recorder. You can play the sound file or edit it to create a different 
sound. For information on recording and editing sound files, select an item from the Sound Recorder's 
Help menu.

3. Optionally, select the Repeat option to play the sound continuously until it is manually turned off (by 
clicking the Quiet button on the main window's toolbar).

4. Click Save to save the new notification.

To edit a notification, select it in the listbox, and then enter your changes to the properties. Click Save to 
save your changes.

To delete a notification, select it in the listbox and click Delete.

To define a WinPopup notification:

1. Click New and enter a unique name for the notification.

The new notification name appears in the listbox.

2. In the Select Destination text box, specify the Windows NT hosts or domain that you want to receive 
this notification. Note that domains are marked with an asterisk (*).

3. In the Message text box, enter a text message plus any of the notification variables (see the 
Notification Message Variables at the end of this section). You can use these variables to add status 
information to the notification.

4. Click Save to save the new notification. 



Communications Setup

Enter the information in the appropriate (Pager, Beeper) section of the dialog box.

Pager setup:

Modem Initialization String (ATEO)
The default string is ATEO. What is expected in this string are the modem commands for "Command 
Echo Off" (EO).

Baud Rate
Select the speed (measured in bits per second) at which the serial port will communicate with the modem.

COM Port
Select the port to which your modem is attached. 

8N1
The TAP protocol requires the 7E1 setting for communications, but if your pager uses 8N1, you can 
enable this option. By default, this option is disabled.
 

Beeper setup:

Dial String
This is the default dial string used for beeper notifications.

Baud Rate
Select the speed (measured in bits per second) at which the serial port will communicate with the modem.

COM Port
Select the port to which your modem is attached. 

Modem Init String
The default string is ATEOQOV1X4. What is expected in this string are the modem commands for 
"Command Echo Off" (EO), "Result Codes On" (QO), "Verbal Results" (V1), and "Extended Status" (X4). 

Timeout
The timeout value determines how long the system waits after sending the last character before it hangs 
up the phone, if a transition is not recognized.

E-mail setup:



Beeper Notifications
 
You can define beeper notifications to activate a beeper when the network element does not respond to 
polling. 

In the Notification System dialog box, click the Beeper tab to display the Beeper properties.
 
1. Click New and enter a unique name to identify the beeper notification, for example
 "Beep Bob." The new notification name appears in the listbox.

2. In the Beeper Number box, enter the phone number to dial.

You can use parenthesis to delimit the area code and a dash to separate the exchange from the 
extension numbers, for example: (617) 555-xxxx.

3. In the Dial String box, the default is:    ATDT%s,,,,%s#    
WhatsUp replaces the first %s with the phone number and the second %s with the beeper code. Most 
modems and beepers support the use of `#' to terminate the message and `*' to print out a dash. You 
may find a need to increase the number of commas in the dial string if it dials the code too soon or 
decrease the number of commas if it waits too long. 

4. In the "Common to all" section, the Up code specifies the characters sent to the beeper to indicate that 
the network element has come back up after being down (the default value is 0*). The Down code 
specifies the code sent to indicate the element is down (the default value is 9*). (You can use the 
asterisk (*) character to separate the code from a subsequent message.

When sent to the beeper, the Up or Down code will be followed by the Item digital code that tells you 
which network element the notification is for. (The Item digital code is specified in the Add/Edit 
Notifications dialog box.)

5.    Click Comm Setup to set the beeper communications.

6.    In the Beeper properties, click Save to save the new notification. 

To test a notification, select it and click the Test button. WhatsUp Gold will run a test and respond with a 
Success or Fail message.

To edit a notification, select it in the listbox, and then enter your changes to the properties. Click Save to 
save your changes.

To delete a notification, select it in the listbox and click Delete.



Pager Notifications
 
You can define pager notification to send a message to a pager when the network element does not 
respond to polling. WhatsUp Gold supports PageNet and other TAP (Telocator Alphanumeric Protocol) 
pagers.

In the Notification System dialog box, click the Pager tab to display the Pager properties.

To define a pager notification action:

1. Click New and enter a unique name to identify the pager notification, for example "Page Bob."

The new notification name appears in the listbox.

2. In the Terminal Phone Number box, enter the phone number to dial. If required, enter the pager 
password in the Terminal Password box.

You can use parenthesis to delimit the area code and a dash to separate the exchange from the 
extension numbers, for example: (617) 555-xxxx.

3. In the Pager ID box, enter the pager identification number.

4. In the Message String text box, enter a text message plus any of the notification variables (see the 
Notification Message Variables). You can use these variables to add status information to the 
notification.

5. Click Comm Setup to set the pager communications.

6. In the Pager properties, click the Save button to save the new notification. 

To test a notification, select it and click the Test button. WhatsUp Gold will run a test and respond with a 
Success or Fail message.

To edit a notification, select it in the listbox, and then enter your changes to the properties. Click Save to 
save your changes.

To delete a notification, select it in the listbox and click Delete.



Notification Message Variables

In pager and e-mail notification messages, you can use the following variables to encode information 
about a network element from WhatsUp Gold.

      %a = IP Address

      %C = Item digital code

      %c = System Type

      %d = date (yy.mm.dd)

      %h = Address/Name

      %L = log file (or %Lnn where nn=last nn lines of the log file)    
                      (This variable can be used in e-mail messages only.)

      %N = notes

      %n = Display Name

      %S = status (such as "timed out", "did not respond")

      %s = integer status (these are Winsock error codes)

      %t = time (hh:mm:ss)

      %u = "UP" or "DOWN"

      %v = down services

      %V = down services with "services" printed

      %1 = Info line 1

      %2 = Info line 2



Mail Notifications
 
You can define e-mail notification to send a message to an e-mail address when a network element does 
not respond to polling. 

In the Notification System dialog box, click the Mail tab to display the Mail properties.
 
1. Click New and enter a unique name to identify the e-mail notification, for example "Mail to Netadmin." 

The new notification name appears in the listbox.

2. In the IP Address of SMTP Host box, enter the IP address of your SMTP mail host. 

3. In the To: box, enter one or more e-mail addresses that are accepted by the SMTP server. (This can be
a simple name.) Separate each address with a comma. The addresses should not contain brackets, 
braces, quotes, or parentheses.

4. The From address defines the sender of an e-mail notification as: <whatsup@%s>, where %s is 
converted by WhatsUp Gold to the local hostname. In most cases, you will not need to change this 
address. If you do change the address, be sure to keep the angle brackets (<    >) in place.

5.    In the Subject box, enter a text message or any of the notification variables (see the Notification 
Message Variables). You can use these variables to add status information to the notification.

6. In the Message String box, enter a text message plus any of the notification variables (see the 
Notification Message Variables). You can use these variables to add status information to the 
notification.

7. Click Save to save the new notification. 

To test a notification, select it and click the Test button. WhatsUp Gold will run a test and respond with a 
Success or Fail message.

To edit a notification, select it in the listbox, and then enter your changes to the properties. Click Save to 
save your changes.

To delete a notification, select it in the listbox and click Delete.



Program Notifications
 
You can define Program notifications to launch an application when a network element goes down or 
comes back up.

In the Notification System dialog box, click the Program tab to display the Program properties.
 
1. Click New and enter a unique name to identify the program notification. The new notification name 

appears in the listbox.

2. In the Program Filename box, enter the executable name of the application you want to launch. 

You can select a filename from the drop-down list. You can also use the Browse button to browse 
directories and locate a file.

3. In the Working Directory, specify a directory where the working files for the application are stored.

4. In the Command Line Arguments box, enter any of the notification variables. The default variables 
are the hostname (%h), IP address (%a), and up or down status (%u) for the network element. See 
Notification Message Variables for a description of each variable.

5. Click Save to save the new notification. 

To edit a notification, select it in the listbox, and then enter your changes to the properties. Click Save to 
save your changes.

To delete a notification, select it in the listbox and click Delete.



Voice Notifications
 
You can define Voice notifications to send a voice message to a telephone or answering machine when a 
network element goes down or comes back up. You can use the default .wav files included with WhatsUp 
Gold to send a message, or you can record your own .wav files. 
 
Note: The Voice tab in the Item Properties dialog box is displayed only if the system has a voice modem 
and the Unimodem/V driver installed, as described in the Setting up a Voice Modem.

When a voice notification is triggered (by a host or service down), WhatsUp calls the specified telephone 
number and plays the initial message. The default initial message (pressone.wav) is "WhatsUp has a 
message for you. Press 1 for the message." When you press 1 on the phone, one of the up or down 
messages will play, such as "A host is down." If you want to include the hostname in the message (for 
example, "Gyro is down"), you can record a .wav file for a particular host and enter the file name in the 
Add Notifications dialog box when you add the voice notification to that network element.

In the Notification System dialog box, click the Voice tab to display the Program properties.

1. Click New and enter a unique name to identify the voice notification, for example "Phone Fred."

The new notification name appears in the listbox.

2. In the Phone number box, enter the phone number to dial.

You can use parentheses to delimit the area code and a dash to separate the exchange from the 
extension numbers, for example: (617) 555-xxxx.

3. In the Repeat Msg box, enter or select the sound (.wav) file that will be played as the initial voice 
message to tell the recipient that they have received a message from WhatsUp. 

The default message (pressone.wav) is "WhatsUp has a message for you. Press 1 for the message." 
When the recipient presses 1 on the phone, one of the status messages will be played.

Click the Browse button to browse the directories and select a .wav file. Click the Sound button to 
open the .wav file in the Sound Recorder. You can play the sound file or edit it to create a different 
sound. For information on recording and editing sound files, select an item from the Sound Recorder's 
Help menu.

4. In the Count box, enter the number of times to play the initial message (specified in the Repeat Msg 
box) before timing out (if the message is not acknowledged).

5. In the Button box, enter the number on the telephone that the recipient presses to get the status 
message. 

The default message (specified in the Repeat Message box) tells the recipient to press 1 to receive the
status message. You can set this number to 99 to make it accept any number pressed on the 
telephone.

 
Note: If voice mail or an answering machine answers the phone, the voice notification will not get 
beyond the initial .wav file (specified in the Repeat Msg box).

6. Optionally, enter or select the sound (.wav) file that will be played for any of the status messages. The 
default status messages are:

 
Property Default .wav file Message
Item Down isdown.wav "... is down"



Item Up isup.wav "... is now reachable."
Svc Down svcdown.wav "a service is down on ..."
Svc Up svcup.wav "the service is now up on ..."
Wave file    ahost.wav "a host"
 (in Alerts)

Click the Browse button to browse the directories and select a .wav file. Click the Sound button to 
open the .wav file in the Sound Recorder. You can play the sound file or edit it to create a different 
sound. For information on recording and editing sound files, select an item from the Sound Recorder's 
Help menu.

7. Click Save to save the new notification. 

To edit a notification, select it in the listbox, and then enter your changes to the properties. Click Save 
to save your changes.

To delete a notification, select it in the listbox and click Delete.



Setting Up a Voice Modem

To use the Voice Notifications, you must install a supported voice modem and the Unimodem/V drivers on
the system on which you run WhatsUp Gold. WhatsUp Gold has been tested with the "US Robotics 
Sportster Voice 33.6 Faxmodem with Personal Voice Mail" and with the "Diamond 3500" voice modem.

To install the driver and voice modem:

1. Install the Unimodem/V drivers on your system.

You can download the driver from Microsoft. Go to www.microsoft.com/kb and search for: 
"unimodemv"

http://www.microsoft.com/kb/softlib/mslfiles/unimodv.exe

Copy unimodv.exe into an empty directory and run it. It will extract several files. Read the readme.txt 
for installation instructions.

2. If your voice modem is not directly supported by Unimodem/V, go to the web site of your modem's 
manufacturer (www.usr.com for US Robotics) and locate the Unimodem/V support files and wave 
driver. 

For Sportster Voice, go to http://www.usr.com/home/online /files/d107.htm and get usrwave.inf and 
mdmusrvi.inf). After copying the proper .inf files into your \windows\inf directory, open the Windows 
Explorer to the directory, click the right mouse button on the files and select Install from the pop-up 
menu (or read the instructions that come with the vendor's .inf files).

3. If the .wav files that are included with WhatsUp Gold are compatible with your voice modem, you can 
use them. If they are not compatible or you want to change the message, you can record new files. 
The suggested default setting for recording is:

          PCM 8,000 Hz, 16 bit, Mono.

Wave files needed for voice notifications are:

Default .wav file Message
isdown.wav "... is down"
isup.wav "... is now reachable."
svcdown.wav "a service is down on ..."
svcup.wav "the service is now up on ..."
ahost.wav "a host"
 (in Alerts)

4. Set the wave files in the Voice properties to point to the wave files that you create. See the Defining 
Voice Notifications.

5. Make sure your serial port has a COM driver. You can check this in the Control Panel by selecting 
System->Device Manager->Ports->(modem's Com port).

If you do not have all of the above installed (voice modem, Unimodem/V drivers, and a COM driver), 
you will not see the Voice tab in the Notifications Editor dialog box.



Subnets
Subnets are a different breed of devices. When a map is loaded, WhatsUp will search for a file with the 
same name as the subnet with a .wup extension. If it finds such a file, WhatsUp will load that map and 
start monitoring it. If such a file is not found or the map window for the subnet is subsequently closed, 
then WhatsUp will use the hostname or IP address that is specified in the definition of the subnet icon and
check that device.    

The subnet icon in the map window will then be colored according to the worst device on that subnet 
map.

Subnets have an additional item on the popup menu of either Load Subnet (if it is not loaded and such a 
file exists) or View Subnet (if a map window exists for the subnet).

To create a subnet map:

You create a network map and link it to another map by using the subnet feature. Subnets allow you to 
create separate maps for different segments of your network, yet maintain a connection between the 
maps. WhatsUp Gold can simultaneously monitor the network map and any subnet maps.      

1. Create a new map and add the network elements for the subnet.

You can use any of the methods for creating a network map. You can also use the Map Editor to cut 
and paste network elements from an existing map.

2. Create a subnet icon in the main network map to link it to the subnet map.

Select the main network map and click the  button in the main window's toolbar to enter Edit mode. 
Click the right mouse button in the map and select New->Subnet from the popup menu. A subnet icon 
appears.

Double click the subnet icon to display the Properties dialog and click the Main tab. In the Main 
properties, in the Display Name box, enter the name of the subnet map. Click Apply to save your 
changes. In the Monitor properties, make sure Monitor this item is enabled.

When you open a network map, WhatsUp Gold can also open any associated subnet maps and start 
monitoring them (from the View menu, select Program Options->Startup, and then enable the Auto Load 
Subnets option.) 

The subnet icon in the main network map will have the color of the highest priority alarm that occurs in the
subnet map. For example, if a network element in the subnet does not respond to four polls, the subnet 
icon will be red.

If a subnet map window is not opened, you can click the right mouse button on the subnet icon and select
Load Subnet from the popup menu to open it. 

If a subnet map is opened but is hidden behind other windows, you can click the right mouse button on 
the subnet icon and select View Subnet from the popup menu to move it to the top. 



Time Period options

Select the Day of Week options: Every day means the function (monitoring, notifying) is active every day 
of the week. You can uncheck the Every day option and then select the specific days of the week that you
want to the function to be active.

Select one of the three Time of Day options: 24 hours a day means that the function (monitoring, 
notifying) will be active at any time of day. Between lets you specify the hours between which the function 
will be active for this network element. No between lets you specify the hours that function will not be 
active. 

Because the first value must be less than the second value, use the No between option to enable the 
function between an afternoon time and a morning time.



Creating a Network Map

The network map is a graphical representation of the elements in your network that you want to monitor. 
Network elements can be workstations, hosts, servers, routers, bridges, hubs, LAN boxes, printers, or 
subnetworks (subnets). 

There are several ways to create a map for your network and to add network elements to an existing 
map:

· Use the Auto Load wizard to have WhatsUp Gold create a map from information contained on your 
computer or on the network to which your computer is connected. WhatsUp Gold creates a map by 
reading the network files on your local host and identifying systems listed in the files. Select File->New 
to use the Auto Load wizard. 
 

· Load a hosts file and WhatsUp Gold will create an icon for each host found in the file. 
 

· Use Scan IP to automatically detect and list the network elements within a specified range of IP 
addresses. The Scan IP can also scan each network element for services (such as FTP or HTTP).
 

· Use Scan WinNet to have WhatsUp Gold scan a Windows Network (to which your computer is 
connected) and create a map of the systems it finds.
 

· Map the route from your local host to a remote host using the Traceroute tool.
 

· Manually create an icon for each network element and enter information about the element. Use File-
>New to create a blank map, and then use the Map Editor to create network elements in the map.

· Importing a map from WhatsUp Version 2.x.

The following sections describe how to use each of the methods for creating a map.

In all cases, after creating the network elements, you can organize them to best represent your network 
by using the Map Editor. The Map Editor lets you draw connecting lines between network elements and 
add rectangles, ellipses, and text. You can use these drawing objects to group network elements on the 
map and provide visual cues for identifying the different parts of your network.      



Loading a Hosts File

You can load a hosts file (which lists hostnames and their associated IP addresses) and WhatsUp Gold 
will create icons for each system listed in the file.

1. Select an existing map or create a new map window.

To select an existing map, select Open from the File menu and enter the map file name. 

To create a new map window, select New from the File menu, or click the New button in the main 
window's Toolbar. Select the Create empty map option, and then click Finish.

2. From the Tools menu, select Import->Hosts File.

The Browse dialog box appears.    

3. Locate the hosts file and click OK.

WhatsUp Gold reads the hosts file and creates an icon for each network element it finds in the hosts 
file. 

4. Use the Map Editor to organize network elements, change icon types, and add connecting lines and 
drawing objects.

To change a network element's icon, double-click on it to display the Properties, select the Main tab, 
then select a new Type from the drop-down list. 

5. Enter or modify the network elements' properties.

6. From the File menu, select Save or Save As to save the map.



Scan WinNet

The Scan WinNet tool creates a map by scanning the Windows network to which your computer is 
connected and finding the other systems on the network. It creates an icon for each host that it finds on 
the network.

To start a Scan WinNet:

1. Select an existing map or create a new map window.

To select an existing map, select Open from the File menu and enter the map file name.

To create a new map window, select New from the File menu, or click the New button in the main 
window's Toolbar. Select the Create empty map option, and then click Finish.

2. From the Tools menu, select Import->Scan WinNet. 

WhatsUp Gold scans your Windows network and creates an icon on the map for each system that it 
finds. Note that this scan can take a few minutes to complete depending on the size of your network. 

Note: The Scan WinNet will also find NetWare devices, but you will not be able to monitor these 
devices.

3. Use the Map Editor to organize network elements, change icon types, and add connecting lines and 
drawing objects.

To change a network element's icon, double-click on it to display the Properties, select the Main tab, 
then select a new Type from the drop-down list. 

4. Enter or modify the network elements' properties.

5. From the File menu, select Save or Save As to save the map.



Importing a Map from WhatsUp Version

If you have existing maps in the WhatsUp Version 2.0 format (files with the extension .db), you can open 
them in WhatsUp Gold and they will automatically be converted to the new format (which uses the file 
extension .wup).

To import a Whatsup Version 2.0 map:

1. From the File menu, select Open. The Browse dialog box appears.    

2. Locate the .db file and click OK.

WhatsUp Gold converts the file to the .wup format and opens it.

3. From the File menu, select Save or Save As to save the map.



Initiating Polling

WhatsUp Gold makes a single pass through the elements in the network map, polling each element. You 
can also initiate automatic polling, in which case WhatsUp Gold polls the network elements continuously, 
starting each new pass after a specified time interval.

When you open a network map, Whatsup Gold immediately starts automatic polling. WhatsUp Gold can 
also open any subnet maps associated with the network database and start automatic polling on those 
maps (if you enabled the Auto Load Subnets option in    View->Program Options).

To Start/Stop a Single Check
To Start/Stop Automatic Polling



Start/Stop a Single Check

To start a single check

When you are ready to begin monitoring your network, you can initiate a single check or polling of 

currently active network elements by clicking the  button on the main window's toolbar or by choosing
Check from the Tools menu. These two actions are equivalent and result in WhatsUp Gold sending a set 
number of ICMP echo requests to the specified IP address for each active network element and tracking 
the responses. 

If WhatsUp Gold is in automatic polling mode, initiating a single check will interrupt the automatic polling, 
do an immediate poll of each network element in the map, and then restart automatic polling.

To stop a single check

To stop a single check or polling of currently active network elements, simply click the  button on the 
main window's toolbar. 



Start/Stop Automatic Polling

To initiate automatic polling:

When you open a network map, Whatsup Gold immediately starts automatic polling on the map and any 
associated submaps.

To change the default settings for automatic polling, choose Map Properties from the File menu. The 
Properties dialog box will appear. In the Map options, set up the number of seconds you want between 
checks (Map Poll Frequency), the number of seconds to wait before time-out (Default Timeout), and any 
other options you may want to change. 

If polling is stopped, you can initiate automatic polling of currently active network elements by clicking the

 button in the main window's toolbar. WhatsUp Gold will poll each network element and track the 
responses. After waiting the time set in the Map Poll Frequency, it will make a second polling pass 
through the elements and will continue polling until you stop polling by clicking on the Timer button again 
or by closing the Map Window.

WhatsUp Gold polls the network elements in the order in which they were created in the network map. To 
view or change the polling sequence, select Tree Window from the Windows menu. 

To Stop Automatic Polling

To temporarily stop polling of currently active network elements, click on the  button. 

To resume polling, click the  button again.

Note: If you exit WhatsUp Gold during a poll, it may take up to 30 seconds for WhatsUp Gold to remove 
itself from memory. Until it is removed from memory, WhatsUp Gold will appear in the task list when you 
press Ctrl+Alt+Del.



Turning off an alarm

To turn off an alarm, click the  button in the main window's toolbar, or select Stop Alarm from the 
Tools menu.



Activity Log

Each time a network element goes down, or comes back up after going down, the event is recorded in the
Activity Log file (if the Log Activity option is enabled in the Alerts menu for the network element). The 
Activity Log provides a history of all such actions for a particular network map. 

The Activity Log file shows the following information: the date and time the event occurred, the hostname 
and TCP/IP address of the network element, whether the event was the element going down or coming 
up (down/up), and the reason for the failure, such as "timed out," or "not responding."



Debug Log

All actions, such as poll requests and service checks performed by WhatsUp Gold are recorded in the 
Debug log. The Debug log is a real-time log that displays WhatsUp Gold events as they occur.



Reference: Menu Commands
 
File menu commands 
Edit menu commands
View menu commands
Tools menu commands
Window menu commands
Help menu commands

 



 File menu commands
 
The File menu offers the following commands:
 
New Creates a new document.
Open Opens an existing document.
Close Closes an opened document.
Save Saves an opened document using the same file name.
Save As Saves an opened document to a specified file name.
Print Prints a document.
Print Preview Displays the document on the screen as it would appear printed.
Print Setup Selects a printer and printer connection.
Map Properties    Displays the Map Properties dialog.
 Exit Exits WhatsUp Gold
 
 



Edit menu commands
 
The Edit menu offers the following commands:
 
Undo Reverse previous editing operation.
Cut Deletes data from the document and moves it to the internal clipboard.
Copy Copies data from the document to the internal clipboard.
Paste Pastes data from the internal clipboard into the document.
 



View menu commands
 
The View menu offers the following commands:
 
Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.
Notifications Displays the Notifications dialog box.
Activity Log Displays the Activity Log.
Debug Log Displays the Debug Log.
Edit View Switches a Map view to Edit view.
Program Options Displays the Program Properties dialog.
 
 



Tools menu commands
 
The Tools menu offers the following commands:
 
Poll Decrements the counter in the current view to 0, thereby initiating a poll.
Stop Check Stops the current check.
Stop Alarm Quiets the current sound alarm.
Import Import items from another source.
Net Tools Displays the Net Tools.

 
 



Poll button

 Click this button to initiate a single check or polling of currently active network elements (or choose 
Check from the Tools menu). These two actions are equivalent and result in WhatsUp Gold sending a set 
number of ICMP echo requests to the specified IP address for each active network element and tracking 
the responses. 

If WhatsUp Gold is in automatic polling mode, initiating a single check will interrupt the automatic polling, 
do an immediate poll of each network element in the map, and then restart automatic polling.



Stop Check

 Click this button to stop a single check or polling of currently active network elements (or select Stop 
Check from the Tools menu).



Stop Alarm

 Quiets the current sound alarm.



Window menu commands
 
The Window menu offers the following commands, which enable you to arrange multiple views of multiple
documents in the application window:
 
Map Window Creates a window that displays the map of the current WhatsUp database.
Tree Window Creates a tree window that views the polling sequence and dependencies in 

the current WhatsUp database.
List Window Creates a list window that views the raw data in the current WhatsUp database.
Notifications Window Creates a list window that views the Notifications in the current WhatsUp 

database.
Status Window      Creates a window that displays the Status of the current WhatsUp 

database.
Cascade  Arranges windows in an overlapped fashion.
Tile Horizontally    Arranges windows in non-overlapped tiles.
Tile Vertically  Arranges windows in non-overlapped tiles.
Arrange Icons  Arranges icons of closed windows or arranges the icons in the current Map window.
Window 1, 2, ...  Goes to specified window.
 
 
 



Help menu commands
 
The Help menu offers the following commands, which provide you assistance with this application: 
 
Help Topics Offers you an index to topics on which you can get help.
About Displays the version number of this application.
 
 
 



 New command (File menu)
 
Use this command to create a new Map Window in WhatsUp Gold.    
 
You can open an existing Map Window with the Open command.
 
Shortcuts

Toolbar:  
Keys: CTRL+N
 
 



 Open command (File menu)
 
Use this command to open an existing Map Window.    You can open multiple network maps at once.    
Use the Window menu to switch among the multiple open documents.    See Window 1, 2, ... command.
 
You can create new documents with the New command.
 
Shortcuts

Toolbar:  
Keys: CTRL+O
 
 



File Open dialog box
 
The following options allow you to specify which file to open:

File Name
Type or select the filename you want to open.    This box lists files with the extension you select in the List 
Files of Type box. 

List Files of Type
Select the type of file you want to open:    WhatsUp Gold database files have the .wup extension. If you 
have a file from a pervious version of WhatsUp (.db file), you can open it and WhatsUp Gold will 
automatically convert the file to the .wup format and display the Map Window.

Drives
Select the drive in which WhatsUp Gold stores the file that you want to open. 

Directories
Select the directory in which WhatsUp Gold stores the file that you want to open.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 
 
 



 Close command (File menu)
 
Use this command to close the active window. WhatsUp Gold suggests that you save changes to your 
network map before you close it. If you close a map without saving, you lose all changes made since the 
last time you saved it. Before closing an untitled map, WhatsUp Gold displays the Save As dialog box and
suggests that you name and save the map.
 
You can also close a map by using the Close icon on the Map Window, as shown below:

 
 



 Save command (File menu)
 
Use this command to save the active network map to its current name and directory. When you save a 
map for the first time, WhatsUp Gold displays the Save As dialog box so you can name your map. If you 
want to change the name and directory of an existing map before you save it, choose the Save As 
command.
 
Shortcuts

Toolbar:  
Keys: CTRL+S
 
 
 



 Save As command (File menu)
 
Use this command to save and name the active map. WhatsUp Gold displays the Save As dialog box so 
you can name your map.    
 
To save a map with its existing name and directory, use the Save command.
 
 



File Save As dialog box
 
The following options allow you to specify the name and location of the file you're about to save:

File Name
Type a new filename to save a document with a different name. A filename can contain up to eight 
characters and an extension of up to three characters. WhatsUp Gold adds the extension you specify in 
the Save File As Type box.

Drives
Select the drive in which you want to store the document.

Directories
Select the directory in which you want to store the document.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 
 
 



    1, 2, 3, 4 command (File menu)
 
Use the numbers and filenames listed at the bottom of the File menu to open the last four network maps 
you closed. Choose the number that corresponds with the map you want to open.
 



 Exit command (File menu)
 
Use this command to end your WhatsUp Gold session. You can also use the Close command on the 
application Control menu. WhatsUp Gold prompts you to save maps with unsaved changes.
 
Shortcuts
Mouse: Double-click the application's Control menu button.

 
Keys: ALT+F4
 



Undo/Can't Undo command (Edit menu)
 
Use this command to reverse the last editing action, if possible. The name of the command changes, 
depending on what the last action was. The Undo command changes to Can't Undo on the menu if you 
cannot reverse your last action.
 
Shortcuts

Toolbar:  
Keys: CTRL+Z or

ALT-BACKSPACE
 
 



Cut command (Edit menu)
 
Use this command to remove the currently selected data from the network map and put it on the 
clipboard. This command is unavailable if there is no data currently selected.
 
Cutting data to the clipboard replaces the contents previously stored there.
 
Shortcuts

Toolbar:  
Keys: CTRL+X
 
 



Copy command (Edit menu)
 
Use this command to copy selected data onto the clipboard. This command is unavailable if there is no 
data currently selected.
 
Copying data to the clipboard replaces the contents previously stored there.
 
Shortcuts

Toolbar:  
Keys: CTRL+C
 
 



Paste command (Edit menu)
 
Use this command to insert a copy of the clipboard contents at the insertion point. This command is 
unavailable if the clipboard is empty.
 
Shortcuts

Toolbar:  
Keys: CTRL+V
 
 



 Toolbar command (View menu)
 
Use this command to display and hide the Toolbar, which includes buttons for some of the most common 
commands in WhatsUp Gold, such as File Open. A check mark appears next to the menu item when the 
Toolbar is displayed.
 
See Toolbar for help on using the toolbar.
 



 Toolbar

 
 
The toolbar is displayed across the top of the application window, below the menu bar. The toolbar 
provides quick mouse access to many tools used in WhatsUp Gold,
 
To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).

 
Click To

 Open a new document. 
 

 Open an existing document.    WhatsUp Gold displays the Open dialog box, in which you can 
locate and open the desired file. 
 

 Save the active document or template with its current name.    If you have not named the 
document, WhatsUp Gold displays the Save As dialog box. 

 Switches the current Map Window between Edit mode (where you can create or move network 
elements and drawing objects) and Monitor mode (in which polling can occur).
 

    Closes the main window and displays a small profile window that you can use to monitor network 
status in place of the Map Window and the other view windows. The Mini Status view lists all network 
elements in the currently active map databases and displays status using the same colors used in the 
Map Window. Close the Mini Status window to redisplay the main window.      

    If polling is stopped, click this button to initiate automatic polling of currently active network 
elements. WhatsUp Gold will poll each network element and track the responses. After waiting the time 
set in the Map Poll Frequency, it will make a second polling pass through the elements and will continue 
polling until you stop polling by clicking on this button again or by closing the Map Window.

 Click this button to initiate a single check or polling of currently active network elements. 

    Click this button to stop a single check or polling of currently active network elements (or select 
Stop Check from the Tools menu).

 Quiets the current sound alarm.

 Print the active document. 



 Displays the Help contents page.

 

 
 



Status Bar command (View menu)
 
Use this command to display and hide the Status Bar, which describes the action to be executed by the 
selected menu item or depressed toolbar button, and keyboard latch state. A check mark appears next to 
the menu item when the Status Bar is displayed.
 
See Status Bar for help on using the status bar.
 



Status Bar

 
 
The status bar is displayed at the bottom of the WhatsUp Gold window.    To display or hide the status bar,
use the Status Bar command in the View menu.
 
The left area of the status bar describes actions of menu items as you use the arrow keys to navigate 
through menus.    This area similarly shows messages that describe the actions of toolbar buttons as you 
depress them, before releasing them.    If after viewing the description of the toolbar button command you 
wish not to execute the command, then release the mouse button while the pointer is off the toolbar 
button.
 
The right areas of the status bar indicate which of the following keys are latched down:
 
Indicator Description

CAP The Caps Lock key is latched down.
NUM The Num Lock key is latched down.
SCRL The Scroll Lock key is latched down.
 



Cascade command (Window menu)
 
Use this command to arrange multiple opened windows in an overlapped fashion. 
 
 



Tile command (Window menu)
 
Use this command to arrange multiple opened windows in a non-overlapped fashion.
 
 
 



Tile Horizontal command (Window menu)
 
Use this command to vertically arrange multiple opened windows in a non-overlapped fashion.
 



Tile Vertical command (Window menu)
 
Use this command to arrange multiple opened windows side by side.
 



Window Arrange Icons Command
 
Use this command to arrange the icons for minimized windows at the bottom of the main window. If there 
is an open document window at the bottom of the main window, then some or all of the icons may not be 
visible because they will be underneath this document window.



1, 2, ... command (Window menu)
 
WhatsUp Gold displays a list of currently open document windows at the bottom of the Window menu. A 
check mark appears in front of the document name of the active window.    Choose a document from this 
list to make its window active.    
 



Help topics (Help menu)
 
Use this command to display the opening screen of Help. From the opening screen, you can jump to step-
by-step instructions for using WhatsUp Gold and various types of reference information.    
 
Once you open Help, you can click the Contents button whenever you want to return to the opening 
screen.
 
 



About command (Help menu)
 
Use this command to display the copyright notice and version number of your copy of WhatsUp Gold.
 



Title Bar
 
 The title bar is located along the top of a window.    It contains the name of the application 
and document.
 
To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging 
their title bars.
 
A title bar may contain the following elements:

          Application Control-menu button 
 Document Control-menu button 
 Maximize button 
 Minimize button 
 Name of the application 
 Name of the document 

 Restore button 
 



Scroll bars
 
Displayed at the right and bottom edges of the document window. The scroll boxes inside the scroll bars 
indicate your vertical and horizontal location in the document. You can use the mouse to scroll to other 
parts of the document.
 

 



Size command (System menu)
 
Use this command to display a four-headed arrow so you can size the active window with the arrow keys.

 
 
After the pointer changes to the four-headed arrow:

1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer to the border 
you want to move.    

2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.
 
Note:    This command is unavailable if you maximize the window.
 
Shortcut
Mouse: Drag the size bars at the corners or edges of the window.
 
 



Move command (Control menu)
 
Use this command to display a four-headed arrow so you can move the active window or dialog box with 
the arrow keys.

 
 
Note:    This command is unavailable if you maximize the window.
 
Shortcut
Keys: CTRL+F7
 
 



Minimize command (application Control menu)
 
Use this command to reduce the WhatsUp Gold window to an icon.
 
Shortcut

Mouse: Click the minimize icon  on the title bar. 

Keys: ALT+F9
 
 



Maximize command (System menu)
 
Use this command to enlarge the active window to fill the available space.
 
Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title bar. 

Keys: CTRL+F10 enlarges a document window.
 
 



Next Window command (document Control menu)
 
Use this command to switch to the next open document window.    WhatsUp Gold determines which 
window is next according to the order in which you opened the windows.
 
Shortcut
Keys: CTRL+F6
 
 



Previous Window command (document Control menu)
 
Use this command to switch to the previous open document window. WhatsUp Gold determines which 
window is previous according to the order in which you opened the windows.
 
Shortcut
Keys: SHIFT+CTRL+F6
 
 



Close command (Control menus)
 
Use this command to close the active window or dialog box.
 
Double-clicking a Control-menu box is the same as choosing the Close command.

 
 
Note:    If you have multiple windows open for a single document, the Close command on the document 
Control menu closes only one window at a time.    You can close all windows at once with the Close 
command on the File menu.
 
Shortcuts
Keys: CTRL+F4 closes a document window

ALT+F4 closes the <<YourType>> window or dialog box



Restore command (Control menu)
 
Use this command to return the active window to its size and position before you chose the Maximize or 
Minimize command.
 



Switch to command (application Control menu)
 
Use this command to display a list of all open applications.    Use this "Task List" to switch to or close an 
application on the list.
 
Shortcut
Keys: CTRL+ESC
 
Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the following 
options:

Task List
Select the application you want to switch to or close.

Switch To
Makes the selected application active.

End Task
Closes the selected application.

Cancel
Closes the Task List box.

Cascade
Arranges open applications so they overlap and you can see each title bar.    This option does not affect 
applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not affect applications 
reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.
 



No Help Available
 
No help is available for this area of the window.
 



No Help Available
 
No help is available for this message box.
 

 





Print Commands

File Print command 
File Print Preview command 
Print Preview toolbar 
File Print Setup command 



 Print command (File menu)
 
Use this command to print a document. This command presents a Print dialog box, where you may 
specify the range of pages to be printed, the number of copies, the destination printer, and other printer 
setup options.
 
Shortcuts

Toolbar:  
Keys: CTRL+P
 
 



Print dialog box
 
The following options allow you to specify how the document should be printed:

Printer
This is the active printer and printer connection.    Choose the Setup option to change the printer and 
printer connection.

Setup
Displays a Print Setup dialog box, so    you can select a printer and printer connection.

Print Range Specify the pages you want to print:

All Prints the entire document.

Selection Prints the currently selected text.

Pages Prints the range of pages you specify in the From and To boxes.

Copies
Specify the number of copies you want to print for the above page range.

Collate Copies
Prints copies in page number order, instead of separated multiple copies of each page.

Print Quality
Select the quality of the printing. Generally, lower quality printing takes less time to produce.
 



Print Progress Dialog
 
The Printing dialog box is shown during the time that WhatsUp Gold is sending output to the printer. The 
page number indicates the progress of the printing.
 
To abort printing, choose Cancel.
 
 



 Print Preview command (File menu)
 
Use this command to display the active document as it would appear when printed.    When you choose 
this command, the main window will be replaced with a print preview window in which one or two pages 
will be displayed in their printed format. The print preview toolbar offers you options to view either one or 
two pages at a time; move back and forth through the document; zoom in and out of pages; and initiate a 
print job.
 



 Print Preview toolbar
 
The print preview toolbar offers you the following options:

Print Bring up the print dialog box, to start a print job.

Next Page Preview the next printed page.

Prev Page Preview the previous printed page.

One Page / Two Page
Preview one or two printed pages at a time.

Zoom In Take a closer look at the printed page.

Zoom Out Take a larger look at the printed page.

Close Return from print preview to the editing window.
 
 



 Print Setup command (File menu)
 
Use this command to select a printer and a printer connection. This command presents a Print Setup 
dialog box, where you specify the printer and its connection.
 



Print Setup dialog box
 
The following options allow you to select the destination printer and its connection.

Printer
Select the printer you want to use. Choose the Default Printer; or choose the Specific Printer option and 
select one of the current installed printers shown in the box. You install printers and configure ports using 
the Windows Control Panel. 

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the document is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources. Specify the tray here.

Options
Displays a dialog box where you can make additional choices about printing, specific to the type of printer
you have selected.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.
 




