
Introduction
Welcome to KeyCAD 3D

Welcome to KeyCAD 3D, a powerful program that lets you draw 3-
dimensional models, or objects, using your computer.  KeyCAD 3D
shows you an outline, or wireframe representation of the object you're
drawing as you make changes to it.  You can also shade your drawing.
Shading is the process where KeyCAD 3D shines one or more lights on
the object you've drawn and colors each surface, making the object
appear solid.  Wireframe or shaded versions of your drawing can be
displayed, printed, or written to the Windows clipboard as a Metafile, so
you can use it in other Windows graphics programs.

KeyCAD 3D supports Constructive Solid Geometry (CSG) Solid Add,
Solid Subtract, and Solid Intersection commands.  These let you add,
subtract, or take the intersection of two enclosed surfaces, or solids.  This
powerful feature lets you make complex objects out of a combination of
simpler objects.

The animation features in KeyCAD 3D bring your drawings to life!
Using the powerful concept of key frames, you specify the exact viewing
angle, zoom factor, and focal point at key points in the animation.  Using
this information, KeyCAD 3D automatically draws each frame in the
animation and saves the resulting bitmaps to disk.  You can then play
these animations using the Run Animation command.  These features are
fully integrated into KeyCAD 3D, so you can create and animate your
drawings all from the same program.

Before you start using KeyCAD 3D, be sure to read the next few pages.
They tell you what equipment you need to use the program and how to
go about installing it.
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Registration

After installation, take a few minutes to fill out the enclosed registration
card to register your product. You will then be entitled to free technical
support and you will receive the latest information about upgrades, new
products, and special offers as they become available.

System Requirements

To use KeyCAD 3D, you'll need the following hardware and software:

• Windows® 95 or 3.1

• 4MB RAM for Windows 3.1 (8MB recommended)

• 8MB RAM for Windows 95

• CD-ROM drive

• 10MB available hard disk space

• SVGA monitor and compatible graphics card

• Mouse

To print your drawings you’ll also need a Windows compatible graphics
printer.

Installing the KeyCAD 3D Application

To install KeyCAD 3D:

1. Insert the KeyCAD 3D disk #1 into drive A: (or B: if applicable),
or insert the CD-ROM into your CD-ROM drive.

2. If you are using Windows 3.1, choose Run from the File menu in
the Windows Program Manager; if you are using Windows 95 or
higher, click Start, then choose Run from the popup menu.

3. Type a:\setup (or substitute the letter of the drive you are
installing from drive for a:), then press Enter.

Running KeyCAD 3D

To run KeyCAD 3D, double-click on the KeyCAD 3D icon located in the
THE LEARNING COMPANY program group or Windows 95 folder.



Getting Started
Basics and Tutorial

If you are new to KeyCAD 3D, use this chapter to learn the basic concepts
and skills you'll need to use the program successfully.  You should read
this chapter first to help you get started.  At the end of the chapter are
several tutorials which teach you how to draw, edit, print, and animate 3-
dimensional objects.

This guide assumes that you already know how to use a mouse and are
familiar with Microsoft Windows® 3.0, 3.1 or Windows95.  Please refer to
your Microsoft documentation or Windows' online help for any questions
about Windows.

This chapter assumes that you've already installed KeyCAD 3D onto your
computer's hard disk.  For installation instructions, please refer to the
previous section.

Happy drawing!
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Screen Layout
To start KeyCAD 3D, double-click on its icon.  Once started, the following
screen appears:

Tool Bar Alt. View 1 Alt. View 2 Main View

Command Cursor Position Prompt Current Layer

Current Color

Keyboard Mode

No. of points set

Selected Primitive

Figure 1-1.  KeyCAD 3D Screen layout.

The title bar contains the name of the file being edited.  In the case of a
new file, the default file name is "untitled.mdl", where ".mdl" stands for
model.  As with most Windows programs, the program window can be
resized, minimized, and maximized.  Regardless of the window size,
however, drawings will maintain their aspect ratio, although they may not
fully fit on the screen.  In other words, a circle will not distort to an ellipse
when you reduce the window width.

Tool Bars
The tool bar lets you select commonly used commands just by pressing a
button.  You can use the menus instead of the tool bars, but the tool bars let
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you activate commands more quickly and easily.  (You can hide the tool
bar if desired.)

One of three tool bars will appear, depending on what you're doing:

Drawing Tools
The drawing tools let you quickly select the next object you want to draw.
Drawing tools appear until you either select an object or start a command,
after which either the editing or point-setting tool bar appears.

Line

Polygon

Box

Arc

Curve

Circle
(radius)

Circle
(diameter)

Ellipse

Cone

Sphere

Hemi-
sphere

Cylinder

Fixed
Text

Paste

Undo

Redo

Pan

Zoom

Figure 1-2.  The Drawing Tools tool bar.

Note:  Using the menus, you can still draw objects even when the
drawing tools do not appear.  See “Drawing Objects” on page 75 for
a complete list of drawing commands.

Point-Setting Tools
Whenever KeyCAD 3D prompts you to enter one or more points, the
Point-Setting tool bar appears.  It helps you position the cursor at the
desired location.  The big red X is identical to pressing the <Esc>> key
and erases the last point, if any are set, or cancels the command if no
points are set.  The big green check mark is identical to pressing the
<Enter> key, and tells KeyCAD 3D you are through setting points.  See
“Setting Points” on page 65 for a complete description of each point-
setting command.

Absolute Polar Snap to
line

Midpoint Zoom Enter

Relative Snap to point Snap to plan Pan Erase last
point

Figure 1-3.  The Point-Setting Tools tool bar.
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Editing Tools
Once you select one or more objects, the tool bar displays some common
editing and surface-generation commands that you can use.  See “Drawing
Surfaces” on page 95 for a description of the available surfacing com-
mands.  Also see “Making Changes” on page 107 for a description of each
editing command.

Extrude

Sweep

Spiral

Surface
patch

Circular
repeat

Linear 
repeat

Fillet

Chamfer

Move to
Clipboard

Copy  to
Clipboard

Paste from
Clipboard

Set color

Move to
current
layer

Group
objects

Ungroup
objects

Scale,
Rotate,

Move

Undo

Redo

Figure 1-4.  The Editing Tools tool bar.

Main and Alternate Views
KeyCAD 3D supports up to three simultaneous views, or viewports.  The
large window on the right of the screen is called the main view.  The two
smaller windows on the left are called alternate views and are numbered 1
and 2 from top to bottom, respectively.  These views are your "windows"
into the 3-dimensional world where you create and modify objects.  You
can adjust the apparent size of the object (zoom), location (pan), and
viewing angle of each view separately.

These features let you, for example, view the top, front, and side of an
object while you're creating it.  Whenever you make changes to an object
in the main view, KeyCAD 3D automatically shows you the changes in
each of the alternate views.  When you want to focus in on a part for
greater detail, you can zoom in and make the part as large as the screen, all
without affecting the size or scale of the drawing.  When you complete the
changes, you can zoom out and view the entire object again.

The main view is different from the alternate views because it lets you
easily select and move 3D objects using techniques common in popular
2D paint programs.  For example, you can select an object by moving the
cursor over it and clicking the left mouse button.  You can disable one or
both of the alternate views.  The main view cannot be disabled and is
always active.

As with all other options, KeyCAD 3D automatically saves the viewing
options with each drawing.  Below is a list of the default viewing options
that are active when you first start the program:
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View Horizontal Vertical
Angle Angle Zoom Description

Main 0 0 1.0 Front view
Alternate 1 0 90 .25 Top (plan) view
Alternate 2 90 0 .25 Side view

See “Changing Viewpoints” on page 165 for more information about
changing the viewpoint and setting viewing options.

Prompt Bar
The prompt bar (near the bottom of the window) contains the following
fields:

Command   The currently active command displays here.  For example,
when you draw a line the command field reads "LINE."

Prompt  This field is where KeyCAD 3D prompts you to enter one or
more points.  For example, when drawing a line this field contains "Set
line start point."  Various status messages also display here as well.

Points  This field shows you how many points you've set so far.  Some
commands allow you to enter the maximum number of points allowed
(100).  Other commands limit the number of points that you can enter.

Selected  This field tells you what objects are currently selected.  It's
important because some commands, such as Surface Patch, require you to
select specific objects.  The Selected field can contain one of the follow-
ing:

Field Selected
(blank) nothing
TEXT Text primitive
LINE Line primitive
POLYGON Polygon primitive
CURVE Curve primitive
MULTIPLE Multiple primitives
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Position Bar
The position bar contains the following fields:

X, Y, Z  These fields show you the current cursor position in the XYZ
coordinate system.  The units of measurement that these values represent
are entirely up to you, and can be changed using the Set Drawing Units
command.

Layer  This field shows you the current layer number.  KeyCAD 3D will
assign the next object drawn to this layer. See “Organizing Your Drawing
into Layers” on page 183 for more information about layers.

Color  This field contains the current color -- the color that will be given
to the next object drawn.  The Edit Colors command can be invoked
simply by clicking once on the color portion of this field.  See “Working
with Color” on page 143 for more information about setting and changing
colors.

Moving the Cursor
KeyCAD 3D supports the XYZ coordinate system.  When the viewing
angles are set to 0, X moves  left and right, Y moves up and down, and Z
moves in and out:

Figure 1-5.  Movement of cursor using X, Y, and Z coordinates
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The XYZ coordinate system is fixed, even when you change the viewing
angles.  For example, when viewing the right side of an object (with a
horizontal angle of 90 degrees), the cursor will move in and out of the Z
axis as you move the mouse left and right.  In other words, moving the
mouse left and right on the screen will always move the cursor left and
right in the drawing, and KeyCAD 3D will automatically map that
movement to the XYZ coordinate system.

The units of measurement that the cursor position represents are entirely
up to you, and are determined using the Set Drawing Units command.

You can move the cursor left, right, up, and down using the mouse and/or
keyboard arrow keys.  You can also move the cursor using one of the point
setting commands, even when the point setting tools are not displayed.
The cursor is snapped to each point you set.  If the point is off the screen
then the cursor will be moved to the edge of the screen.  This prevents the
cursor from getting "lost."

The distance the cursor moves when using the keyboard is determined by
the current Cursor Step Size.  To set the cursor step size, select Cursor
Step from the View menu and enter the number of units you want the
cursor to move with each key press.  These units are in the units of
measurement you define with the Set Drawing Units command.  To move
10 times the cursor step size, press and hold the <Shift> key while
moving.

To move in and out, simply hold down the <Ctrl> key while moving up
and down (on the keyboard, use the up and down arrow keys).  This works
with both the mouse and keyboard, although with the mouse will also
move the cursor up and down.

You can move the cursor beyond the edge of the screen using the key-
board.  However, when you move the cursor with the mouse, it is restricted
to the edge of the main window.

To make it easier to set points at precise locations, KeyCAD 3D lets you
enable a snap grid.  The cursor is snapped to this grid whenever you set a
point or move an object.  You can change the grid size with the Grid Size
command in the View menu.  You can toggle the snap grid on and off with
the Snap Grid command in the View menu.  The snap grid is only used
when the cursor is moved with the mouse, not the keyboard.

Setting Points
Nearly all KeyCAD 3D commands allow (and often require) you to set
one or more points.  Points are used for a number of reasons, such as
determining where a curve is to be drawn, setting an axis of rotation,
specifying a point to zoom into, and so forth.  Whenever KeyCAD 3D is
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waiting for you to enter a point, it prompts you for the point at the bottom
of the screen and displays the point-setting tools.  Some commands, such
as Cut and Paste, don't require any points, so you can just press <Enter> or
click on the green check mark button.

To set a point, move the cursor to the desired location and click the left
mouse button or press the <Ins> key.  You can also use one of the point-
setting commands to set a point.

If you set a point mistakenly, you can erase it by either clicking on the red
X button or by pressing <Esc>.  If you do this while KeyCAD 3D is
prompting you for the first point of the command, you will cancel the
command.

You can set up to 100 points in a single command, although many
commands have a much smaller limit.  If you've reached the maximum
number of points you can set for the current command, KeyCAD 3D
prompts you with the message, "Maximum  points set.  Press <Enter>."

When you're through setting points, press <Enter>.  You can also push the
green check mark or press the right mouse button (whichever method you
prefer).

You can have KeyCAD 3D display the distance between the last point you
set and the current cursor position by selecting the Show Distance
Between Points option from the View menu.  This helps you set points an
exact distance apart.  When this option is enabled, the position bar changes
to show the distance along the X, Y, and Z axes.  It also shows the total
distance between the two points.

Distance along X Distance along ZDisance along Y Total distance

Figure 1-6.  Setting points with the "Show Distance Between Points" option.

TIP:  You can use the "Show Distance Between Points" option to
determine the distance between any two points in the drawing.  To
do this, first select a command that prompts you for two or more
points, such as Line, and set the start point.  Then, move the cursor
to the second point -- the distance between the points is displayed
at the bottom of the screen.  (Don't set the second point, however,
or the distance will be set to 0.)  You can then cancel the Line
command.
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You can immediately cancel a command when it is prompting for a point
simply by selecting another command.  For example, if you start drawing a
line and then decide that you want a curve instead, you can simply choose
Curve from the Draw menu.  This works regardless of the number of
points you have set.

Warning:  You have to be careful not to accidentally cancel a
command by prematurely selecting a new command before the
previous one has finished.  This is especially important when using
the Cut, Copy, and Paste commands.  In other words, remember to
press <Enter> when through setting points!

Setting the Drawing Units
You determine the unit of measurement that makes sense for the drawing
you're working on.  For example, if you're designing a house then you may
want to work in inches, in which case 1.0 represents one inch, 12
represents one foot, 0.5 represents 1/2 inch, and so forth.  You should
determine what these units are before starting a drawing.

To set the drawing units:

1 Select Set Drawing Units from the View menu.

2 Set two points a known distance apart, such as from the left side of
the main view to the right.

3 Press <Enter>.

4 Enter the distance between the two points.

5 Press OK.

You can easily change drawing units at any point in your drawing simply
by performing the above steps.  KeyCAD 3D will automatically scale your
model as needed.
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Drawing Objects
To draw objects in KeyCAD 3D, you first select the object you want to
draw (such as a line, circle, or sphere) by either pressing the corresponding
button on the tool bar or by selecting the object from the Draw menu.
KeyCAD 3D then prompts you for one or more points to define the object.
The following drawing commands are supported:

Command Points
Line 1 through 100 - Points to draw line through

Polygon 1 through 100 - Points to draw polygon through

Box 1 - Corner 1

2 - Corner 2

Arc 1 - Center

2 - Start

3 - Plane (optional)

Curve 1 through 100 - Points to draw curve through

Circle 1 - Center

2 - Radius

3 - Plane (optional)

Circle 1,2 - Diameter

3 - Plane (optional)

Ellipse 1 - Center

2 - Height

3 - Width (and plane)

Cone 1 - Center

2 - Width

3 - Height and direction

Sphere 1 - Center

2 - Radius

3 - Plane (optional)

Hemisphere 1 - Center

2 - Radius

3 - Plane (optional)

Cylinder 1 - Center

2 - Radius

3 - Height and direction

Text 1 - Start point

2 - End point (optional)

3 - Plane (optional)
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Selecting Objects
KeyCAD 3D automatically selects objects as soon as you draw them.
Each selected object is surrounded by a black rectangle in each of the
three views.  All of the KeyCAD 3D editing commands require that you
select at least one object; many of the commands only work with certain
types of objects.  There are several ways to select an object:

To select using a rectangle:

1. Move the cursor up and to the left of the object(s) that you want to
select (in the main view).

2. Press and hold down the left mouse button.

3. Drag the selection box that appears down and to the right of the
object(s) you want selected.  The box must completely surround
the object(s) as they appear in the main view.

4. Release the left mouse button.  A black rectangle will then appear
around the selected object(s).

To select by clicking:

1. Move the cursor over the object to be selected (as it appears in the
main view).

2. Click the left mouse button.  A black rectangle will then appear
around the selected object.

Normally, previously selected objects are automatically de-selected when
new objects are selected.  To prevent this, press and hold the <Shift> key
while selecting using either of the above methods.

Sometimes multiple objects overlap, making it difficult or impossible to
select the desired one.  In cases like this, press and hold the ALT key while
clicking on the object.  KeyCAD 3D cycles through the overlapping
objects each time you click.

You can also select objects using a 3-dimensional boundary box.

1. Move cursor to upper left hand corner of boundary box.

2. Press and hold the left mouse button.

3. Move cursor to lower right hand corner of boundary box, using the
<Ctrl> key to move in the Z direction.

4. Release mouse button.  All objects entirely enclosed by the
boundary box will be selected.

You can select all objects in the drawing by using the Select All command
from the Edit menu.  To de-select all objects, click on an empty part of the
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drawing (in the main view) or select the Deselect All command from the
Edit menu.

TIP:  When a drawing gets really dense and you find it difficult to
select an object, move some of the objects to another layer
temporarily. See “Organizing Your Drawing into Layers” on page 183
for more information.

Moving Objects
KeyCAD 3D lets you move selected objects quickly and easily.

1. Move the cursor over the selected objects and press and hold the
left mouse button.

2. Move the object to the desired location, using the <Ctrl> key if
needed to move in or out.  A rectangle appears around the objects
as you move them.

3. Release the left mouse button.

If you make a mistake, simply press Undo from the Edit menu.

TIP:  You can precisely move, scale, and rotate an object, all in a
single step, using the Copy, Cut, and Paste commands from the
Edit menu.  You can also interactively move, scale, and rotate and
object using the Virtual Trackball.  See “Making Changes” on page
107 for more information.

Grouping and Ungrouping Objects
KeyCAD 3D lets you group multiple objects together and manipulate
them as a single object.  This powerful feature lets you take a collection of
objects and combine them into a single object that you can easily select
and modify.  For example, a wheel group could consist of the rim, hubcap,
and tire.  The wheel, in turn, could itself be part of a group, such as a car.
The car could then be part of yet another group, such as a parking lot, and
so forth.

To group multiple objects into a single group:

1. Select the objects you want to group.

2. Select Make Group from the Edit menu or press the GROUP
button on the tool bar.
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To break a group into multiple objects:

1. Select object(s) you want to ungroup.

2. Select Break Group from the Edit menu or press the UNGRP
button on the tool bar.

The Break Group command only breaks top-level groups.  To continue
breaking groups when more than one level are present, just continue
selecting Break Group (since all ungrouped objects are automatically
selected).

Some of the drawing commands automatically group the objects they
create to make them easier for you to manipulate.  For example, the
Sphere command creates a sphere which is composed of a group of
polygons.  You can break this group and manipulate each individual
polygon, if desired.

Editing Objects
The following is a list of the KeyCAD 3D editing commands:

Command Description
Undo Reverses last action.

Redo Restores last action.

Cut Moves the selected objects to the clipboard file.

Copy Copies the selected objects to the clipboard file.

Paste Pastes objects from the clipboard file into the drawing.

Copy To Copies the selected objects to the specified file.

Paste From Pastes objects from the specified file into the drawing.

Delete Deletes the selected objects.

Slice Slices the selected objects along a cutting plane,
optionally deleting either side.  Useful for making
cross sections.

Make Group Combines one or more objects into a group that can be
easily selected.

Break Group Breaks selected groups into their associated objects.

Join Points Joins points of the selected objects and moves to a
specified location.  Used when several points must
connect but do not due to entry error.

Move Points Moves points of the selected objects to a new location.

Rotate/Move/Scale Interactively rotates, moves, and/or scales the selected
objects using a Virtual Trackball.

Fillet Rounds off the corner of two connected lines.

Chamfer Cuts off the corner of two connected lines with a
straight line.
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Break Lines Breaks a single line into multiple segments.  Also
breaks polygons into multiple single-line segments.

Combine Lines Combines multiple connected lines into a single line.

Convert Polygon to Line Converts a polygon into a single line.

Convert Line to Polygon Converts a single line into a polygon.

Edit Text Changes the selected text.

Convert Fixed Text to Lines Converts the selected text into lines that can be
individually edited.

Saving Your Drawing
To save your drawing to a disk file:

• Select Save or Save As from the File menu.

KeyCAD 3D will then prompt you for a filename if needed.  Once you
enter a valid file name and press OK, the file will be written to disk.

Note: KeyCAD 3D prompts you for verification before writing over a
file that already exists.

Figure 1-7.  Save File dialog box.
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Dialog Box Fields

Filename  You enter your drawing's file name in this field.  You can also
enter a directory name, in which case a list of files with the “.mdl”
extension will appear in the list of files shown.

Directory  This field contains the current directory.  To change the
current directory, either type the directory name in the Filename field or
double click on one of the directories listed in the Directories field.

Files  This field lists all files with the “.mdl” extension that are in the
current directory.

Directories  This field contains a list of directories that are in the current
directory.

Saving DXF Files

You can also save your drawings in the AutoCAD® DXF (Drawing
Interchange File) format.  This lets you transfer your drawings to any other
3D CAD program that supports DXF files.

To save your drawing in the DXF file format:

1. Select Export to DXF from the File menu.

2. Enter the name of the file you wish to save to.  If you do not supply
an extension then “.DXF” will be used.

3. Press OK.

Loading Your Drawing
To load a drawing from a disk file:

1. Select Open from the File menu to load a new drawing.  Or, select
Merge to merge a drawing with an existing drawing.

2. KeyCAD 3D will then prompt you for a filename.  Once you enter
a valid file name and press OK, the drawing will be loaded from
disk.
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Figure 1-8.  Load File dialog box.

Dialog Box Fields

Filename  You enter the file name of the drawing you want to load in this
field.  You can also enter a directory name, in which case a list of files with
the “.mdl” extension will appear in the list of files shown.

Directory  This field contains the current directory.  To change the
current directory, either type the directory name in the Filename field or
double click on one of the directories listed in the Directories field.

Files  This field lists all files with the “.mdl” extension that are in the
current directory.

Directories  This field contains a list of directories that are in the current
directory.

Note:  When you load a drawing using the Open command, all
options that were active when the drawing was last saved are
restored.  If you want to load a drawing but want to keep the current
options the way they are, use the Merge command instead.
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Loading DXF Files

You can also load drawings which are in the AutoCAD® DXF file format.
This lets you transfer drawings created in other CAD programs into
KeyCAD 3D where you can further modify and refine them.

To load a drawing in the DXF file format:

1. Select Import from DXF from the File menu.

2. Enter the name of the file you want to load.  If you do not supply
an extension then “.DXF” will be used.

3. Press OK.

After the drawing is loaded, the viewing parameters are automatically
adjusted to make the drawing fit into each of the active viewports.  When
you later save the drawing (using the Save command), the drawing will be
saved in the KeyCAD 3D file format with the “.mdl” filename extension.

Using Reference Points
When you cut or copy an object to the clipboard file, you can specify up to
three reference points.  The first point specifies the location of the
drawing.  The second point specifies the size.  The third point specifies a
reference plane.  KeyCAD 3D prompts you for these reference points
when you later paste the object and automatically scales, rotates, and
positions the object so that the reference points are aligned.  For example,
suppose you have drawn the following phone and have copied it (using the
Copy command) with the indicated reference points.
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Figure 1-9.  Reference points in a sample object.

• Reference point #1 specifies the phone's location in the XYZ
coordinate system.

• Reference point #2 specifies the size of the phone as the distance
between points 1 and 2.

• Reference point #3 specifies, along with points 1 and 2,  a
reference plane (flat surface) on which the phone is aligned.  Note
that we could've chosen any point along the bottom of the phone,
as long as it's different from the first two points.

When you later paste the object, KeyCAD 3D will prompt you to enter up
to three reference points.  If you enter just one point, then the drawing will
be positioned so that reference point 1 is aligned with the point you enter.
If you enter two points, then the object will be rotated, scaled, and
positioned so that reference points 1 and 2 are aligned with the points you
enter.  To make sure the object is aligned with the desired plane, you can
enter a third point anywhere on the plane.  (A plane is a flat surface, such
as a table top.)
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The following drawing shows how the phone can be placed onto a table
top using reference points.

Figure 1-10.  Pasted object with different reference points.

When you paste an object, KeyCAD 3D ignores any reference points that
were not originally entered.  That is, if you do not specify any reference
points when you copy the object then any reference points you set when
subsequently pasting the object will be ignored.  Likewise, if you only set
one reference point when copying the object then only one reference point
will be used when you later paste the object.

See page 110 for more information on the Cut, Copy, Copy To, Paste, and
Paste From commands.
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Printing Your Drawing
KeyCAD 3D makes it easy to print your drawing because it lets you print
exactly what you see in one of the viewports.  You simply specify which
view you want to print and whether you want to print with wireframe or
with shaded surfaces.  You can also print to the Windows clipboard or to a
Windows Metafile.

To select which printer to use and configure its options:

1. Select Printer Setup from the File menu.

2. Select the printer you want to print to.

3. Press SETUP to set up the printer-specific options.

4. Press OK.

To print your drawing on the selected printer:

1. Select Print from the File menu.  The Print dialog box appears
(described below).

2. Select the above options and press OK.  The drawing will then be
printed.  If you selected the “Windows Metafile” option (described
on the next page), then you will be prompted for the name of the
metafile.  You can cancel printing by pressing <Cancel>.
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Figure 1-11.  Print dialog box.

Dialog Box Fields

Main View  Check this box to print the drawing as it appears in the main
viewport.

Alternate View 1  Check this box to print the drawing as it appears in the
first alternate viewport.

Alternate View 2   Check this box to print the drawing as it appears in the
second alternate viewport.

Printer   Check this box to print on the currently-selected printer.

Clipboard  Check this box to print to the Windows clipboard (as a
metafile).  Use this option to export your drawing to other Microsoft
Windows programs such as Microsoft Word that support metafiles from
the clipboard.
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Windows Metafile  Check this box to print to a Windows Metafile.
(KeyCAD 3D will prompt you for the file name.)  Use this option to
export your drawing to other Microsoft Windows programs that do not
support metafiles in the clipboard (such as Adobe Illustrator).

Shaded  Check this box for a shaded representation of your drawing.
When this option is selected, the quality of the shaded surfaces depends on
the “Shading Quality” option in the Preferences dialog box, described on
the next page.

Wireframe  Check this box for a wireframe representation of your
drawing.

NOTE: Your printer must be properly configured for Windows and

support graphics for proper operation.

Setting Preferences
There are several miscellaneous options to help you customize KeyCAD
3D.  These are located in the Preferences dialog box.

Figure 1-12.  Preferences dialog box.
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To set the options:

1. Select Preferences from the File menu.

2. Set the options as desired.

3. Press OK when done.  To cancel any changes, press CANCEL.

Dialog Box Fields

Undo levels  Enter the number of Undo levels, up to a maximum of 10.
Enter 0 to disable Undo support.

No. of circle segments  Enter the number of lines that you want
KeyCAD 3D to use when generating circular shapes.  This applies to
Circles, Arcs, Cones, Spheres, Hemispheres, and Fillets.  The number you
enter is adjusted to a multiple of 4.  That is, 17 is rounded down to 16.
(This is done so that spheres and hemispheres can be properly generated.)
The minimum is 4 and the maximum is 96.

Shading quality  When Draft is selected, KeyCAD 3D uses Windows
polygon fill routines.  While this method is faster (especially when
printing), it's also less accurate and may leave gaps in the resulting image.
When Final is selected, KeyCAD 3D uses its own high-precision (floating
point) polygon fill routine, which takes longer but produces a superior
image.

Background bitmap (.BMP)  This option lets you specify the name of
a Windows-compatible bitmap which will be used as the background
during full screen shading and animation.  Pressing “Load Bitmap” brings
up a standard file-open dialog box which you can use to load the desired
bitmap.  Then select the “Stretch to fit”, “Original size”, or “Tile” options.
Select “Stretch to fit” when you want the bitmap stretched (or compressed)
to fit inside the window.  Select “Original size” to keep the bitmap its
original size.  Select “Tile” to tile (repeat) the bitmap across and down
until it fills the window.

Tool bar  Select this option to display the tool bar.

Position bar  Select this option to display the position bar.

Prompt bar  Select this option to display the prompt bar.

Alt. view 1  Select this option to display alternate view 1.

Alt. view 2  Select this option to display alternate view 2.

Keyboard moves cursor along:  This option controls how the cursor
moves when moved using the keyboard arrow keys.  When Screen is
selected, the cursor moves consistent with the screen (just like the mouse).
When Axes is selected, the cursor moves along the X, Y, or Z axis in the
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world coordinate system.  These options are illustrated in the following
diagram:

Figure 1-13.  Keyboard movement options.
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Saving and Loading the Drawing Options
KeyCAD 3D saves all of the current options with your drawing when you
save it using the Save or Save As commands from the File menu.  Since
KeyCAD 3D does not use a global options file, changes made to one
drawing will not affect any other drawings.  The following lists the options
saved with each drawing:

Options

All layer settings

All light settings

All viewing options

Color palette and shading information

Current color

Current font file name

Current layer

Current working plane (if active)

Cursor step size

Default text angle and size

Drawing units

All options in the Preferences dialog box

Snap grid size and enabled/disabled status

All animation key frames

TIP:  When you are starting a new drawing but want to use the
options from an existing drawing, first load the existing drawing,
delete all objects, and then save as a new drawing using the Save
As command.  The new drawing will then have the same options as
the original.
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Drawing an Office Chair
This section contains a tutorial to help you get started with KeyCAD 3D.
We'll first show you how to use KeyCAD 3D's drawing and editing
features to draw an office chair.  We'll then explain how to shade and print
your drawings.  Finally, we'll show you how to bring your drawings to life
with KeyCAD 3D’s powerful animation features.

This tutorial assumes you've already read the beginning of this chapter.  It
also assumes that you're reasonably familiar with Microsoft Windows.
While you don't have to be an expert with Windows, you should be
familiar with Windows features—using a mouse and keyboard, selecting
menu commands, using dialog boxes, and so forth.

Here's the chair that we'll be drawing:

Figure 1-14.  Drawing of an office chair

We'll draw the chair using the following steps:

1. Setup the drawing environment

2. Draw the center post
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3. Draw the legs

4. Draw the seat and back

5. Draw the back support

Step 1 - Setup the drawing environment
The first step when beginning any new drawing is to setup the drawing
environment.  This includes the viewing angles, zoom factors, drawing
units, and so forth.  To do this, perform the following steps:

1. Select Preferences from the File menu.  The following dialog box
appears.

Figure 1-15.  Preferences dialog box

2. Set the “No. of circle segments” field to 8.  This specifies that we
want 8 lines to make up the circles that we draw.  (We'll be
increasing this number later on.)

3. Enable both alternate viewports by making sure the “Alt. view 1"
and “Alt. view 2" options are checked.

4. Set the “Keyboard moves cursor along:” option to “Axes”.  With
this option set, the cursor will move along the X, Y, or Z axis when
moved using the keyboard, regardless of the viewing angles.
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5. Press OK to save the changes.

Next, we'll setup our three viewports so that the Main viewport is looking
at the front of the chair, Alternate view #1 is looking at the top, and
Alternate view #2 is looking at the right side.  This is the most common
orientation for new drawings.

1. Select Adjust Main View from the View menu.

2. Enter 0 for the horizontal and vertical angles; 0 for the X, Y, and Z
viewpoint position; and 1.0 for the zoom factor.

3. Press OK.

4. Select Adjust Alt. View 1 from the View menu.

5. Enter 0 for the horizontal angle, 90 for the vertical angle; 0 for the
X, Y, and Z viewpoint position; and 1.0 for the zoom factor.

6. Press OK.

7. Select Adjust Alt. View 2 from the View menu.

8. Enter 90 for the horizontal angle, 0 for the vertical angle; 0 for the
X, Y, and Z viewpoint position; and 1.0 for the zoom factor.

9. Press OK.

The viewports are now oriented like this:
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Figure 1-16.  Setting up the viewing angles

We now need to establish the drawing units we want to use.  For the chair,
we'll draw using inches.  We'll make our drawing area 50 inches wide to
give us plenty of room to work in.

1. Select Set Drawing Units from the View menu.

2. Set a point all the way to the left of the main view.  (To set a point
using the mouse, click the left mouse button.  To set a point using
the keyboard, press the <Ins> key.  If you set a point mistakenly,
press <Esc> to erase it.)

3. Set a point all the way to the right of the Main view.

4. Press <Enter>.  The following dialog box appears:
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Figure 1-17.  Set Units dialog box

5. Enter 50 and press OK.  The drawing area will now be 50 units
wide.

Next, we'll enable the Snap Grid.  The Snap Grid “snaps” the cursor to
points on an imaginary grid, making it easier to set points at predictable
locations.  We'll use a grid size of 1.0 so the cursor will move in 1 inch
increments.  We'll also set the Cursor Step to 1.0.  Then, when we move
the cursor using the keyboard arrow keys, the cursor will also move 1 inch
at a time.

1. Select Grid Size from the View menu.  The following dialog box
appears:

Figure 1-18.  Snap Grid Size dialog box

2. Enter a grid size of 1.0 and press OK.  (The Snap Grid option is
automatically enabled whenever you set the grid size and the Snap
Grid option in the View menu is preceded by a check mark.)

3. Select Cursor Step from the View menu.  The following dialog box
appears:
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Figure 1-19.  Cursor Step dialog box

4. Enter a cursor step of 1.0 and press OK.  Now, whenever the cursor
is moved using the keyboard arrow keys, it will move 1 inch at a
time.  (To move 10 times that amount, or 10 inches, hold down the
SHIFT key while moving.)

Now that you've done all that work setting up your drawing environment,
let's save it for use in future drawings.

1. Select Save As from the File menu.  The following dialog box
appears:



1-32 KeyCAD 3D

Figure 1-20.  Save File dialog box

2. Enter the filename NEWFILE.MDL and press OK.

3. Select Save As from the File menu (again).

4. Enter the filename MYCHAIR.MDL and press OK.  All future
saves will then be to MYCHAIR.MDL.

KeyCAD 3D saves not only the drawing but also all of the drawing
options in the file.  This way, whenever you load a drawing, everything is
exactly as you saved it.  (The one exception is the floating color palette,
which is initially disabled.)  Now, whenever you start a new drawing,
simply open NEWFILE.MDL, save as a new name, and start drawing.

Step 2 - Draw the center post
We're now ready to start drawing our chair.  Before we do, however, we'll
briefly explain how to set colors in KeyCAD 3D.

KeyCAD 3D comes with a default color palette that has already been set
up for you.  You just need to select which color you want to draw with.
The color you select determines the color of the wireframe version of the
object.  During shading, however, the entire range of colors is used.  For
example, if you select bright red and then draw a sphere, the wireframe
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version of the sphere will be bright red.  When you shade the sphere, its
surface will consist of several different shades of red, depending on each
surface's orientation to the light source(s).  Selecting a different shade of
red will only affect the wireframe version.

The currently selected color appears at the bottom of the screen.

Figure 1-21.  Current drawing color indicator

The color of an object is determined by the color that is selected at the
time the object is drawn.  Selecting a different color using the Color
Palette does not change the color of any objects in the drawing.  To change
the color of an object to the currently-selected color, select the object and
press the COLOR button on the tool bar.

We want the center post to appear black when viewing its wireframe and
as shades of gray when it's shaded.  To set the color and draw the post:

1. If it's not already on the screen, select Color Palette from the View
menu to enable the floating color palette.

2. Select the indicated color by clicking on it:

Click on this
color

Figure 1-22.  Floating color palette
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3. Move the color palette off the screen until you need it again later.
(You can move the palette like any other Windows dialog box -- by
dragging its caption bar.)

4. Select Cylinder from the Draw menu.

5. Set a point at (0,3,0) for the center of the cylinder.  This places it 3
inches above the floor (along the Y axis, which points up).  To set
points in KeyCAD 3D, move the cursor to the specified coordi-
nates and click the left mouse button or press the INS key.  Or, if
you already know the coordinates (as you do here), an easier way
is to use the Point Absolute command.  To use this command,
simply press “a”.  The following dialog box appears:

Figure 1-23.  Point Absolute dialog box

6. Set a point for the radius at (2,3,0).  This will make the cylinder 4
inches wide.  (The radius of a circle is 1/2 of its width.)

7. Set a point for the height at (2,18,0) and press ENTER.  This
makes the cylinder 15 inches tall.  The cylinder is then drawn on
the screen.  (If you make a mistake, select Undo from the Edit
menu to undo the last change you made.)

Tip:   You'll notice that the brightest colors are all the way to the right
of the palette.  This lets you move the palette off the left side of the
screen, leaving just the right column exposed and available for
selecting colors.  Normally, you would select the brightest shade of
the desired color for drawing, so this setup works fine.  (Of course,
don't draw using the background color since it won't be visible.)
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Step 3 - Draw the legs
Next, we'll draw the chair legs.  To do this, we'll draw an arc at the end of
one of the legs and extrude, or “stretch”, it toward the center post while
increasing its size at the same time.  We'll then add a caster (sphere) and
use the Circular Repeat command to make a total of 5 legs.

1. Select red as the current drawing color (using the color palette).

2. Select Arc from the Draw menu.

3. Set points at (0,3,-17) and (1,3,-17) for the arc center and radius,
respectively, and press <Enter>.  (Note: You can also click the right
mouse button to tell KeyCAD 3D you're through setting points.)

4. When prompted, enter 180 degrees for the arc angle and press OK.

5. Select Convert Line to Polygon from the Lines menu.  This
converts the arc into a polygon that will show up during shading.
(Shading only shades surfaces, not lines or text.)

6. Select Extrude from the Surfaces menu.

7. Set points at (0,3,-17) and (0,3,-1) for the extrusion origin and
offset, respectively, and press <Enter>.

8. When prompted, enter 1.5 for the scale factor and press OK.  This
causes the arc to increase in size as it's extruded.  (The ending size
will be 1.5 times larger than the starting size.)

9. We'll now draw the caster.  Set the color to bright blue (by clicking
on the color palette) and select Sphere from the Draw menu.

10. Set points at (0,2,-16) and (1.5,2,-16) for the sphere center and
radius, respectively, and press <Enter>.  When prompted, enter 8
for the polygon density.  (This number, in conjunction with the
“Number of Circle Segments” option in the Preferences dialog
box, controls how many polygons are used to draw the sphere.  If
you want a smoother sphere, enter 16 instead.)
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Your screen should now look like this:

Figure 1-24. Screen after drawing the post, caster and leg.

1. The next step is to use the Circular Repeat command to make the
remaining 4 legs. Select the leg and caster by drawing a rectangle
around them in the main view.  Using the mouse, move the cursor
to the upper left of the leg and press and hold the left mouse
button.  Then drag the selection box to the lower right of the caster
and release the mouse button.  (An object must be fully enclosed
by the selection box in order for it to be selected.)  The selection
box then disappears and smaller boxes appear around the selected
objects.

2. Select Circular Repeat from the Surfaces menu.  (If the Circular
Repeat command is dimmed then you don't have anything selected
and you'll have to repeat step 1.)

3. Set points at (0,3,0) and (0,10,0) to define the axis of rotation and
press <Enter>.  (An axis of rotation is an imaginary line which you
want the selected objects to be rotated around.  The direction of the
line is what counts, not its length.  Setting points at (0,3,0) and
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(0,4,0) would work just as well.) The following dialog box
appears:

Figure 1-25.  Circular Repeat dialog box

4. There are several options in this dialog box, but for our purposes
the defaults are fine.  Enter 5 for the number of copies and press
OK.  (Note:  KeyCAD 3D knows not to duplicate the last copy
over the original when copying in a full circle (360 degrees).
That's why we get a total of 5 legs, instead of 6 like you might
expect.)

Our work so far is shown on the next page:
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Figure 1-26. Result of the Circular Repeat command

Notice how the four legs are surrounded by a black rectangle.  This tells
you they are currently selected.  It also illustrates a powerful feature in
KeyCAD 3D -- Object Grouping -- where multiple objects can be grouped
together and manipulated as a single object.  To learn more about the
Group and Ungroup commands, see Chapter 5, “Making Changes.”

It's a good idea to periodically save your work.  Let's do that now.

• Select Save from the File menu.

Step 4 - Draw seat and back
To draw the seat, we'll draw a polygon and then use the Fillet command to
round the corners.  We'll then use the Extrude command to make it two
inches thick.  Next, we'll use the Copy and Paste commands to make the
chair back.

First, let's use the Pan command to “look up” a bit so we can see what
we're working on.

1. Select Pan from the View menu.

2. Set points at (0,0,0) and (0,-10,0) and press <Enter>.
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3. When prompted, select the “Main View” and “Alt. View 2" options
and press OK.

We'll draw the chair seat as a single polygon.

1. Select bright cyan from the color palette.

2. Select Polygon from the Draw menu.

3. Set points at (-12,18,12), (12,18,12), (12,18,-12), and (-12,18,-12),
in that order.  Then press <Enter>.

A square seat is pretty boring.  We'll round each corner using the Fillet
command.  Before we do, however, we'll tell KeyCAD 3D to use more
lines when creating circular shapes.  This will make the corners smoother.

1. Select Preferences from the File menu.

2. Set the “Number of Circle Segments” to 16 and press OK.

3. Select Fillet from the Lines menu.

4. Set a point at (-12,18,12) and press <Enter>.  This is the corner we
want to fillet.

5. When prompted, enter 5 for the fillet radius and press OK.

6. Repeat steps 3 through 5 for the points (12,18,12), (12,18,-12), and
(-12,18,-12), except use a fillet radius of 7 for the last two points.
This makes the front a bit more rounded.

If a square seat is boring, a flat one is even worse.  Lets give it some
thickness using the Extrude command.

1. Select Extrude from the Surfaces menu.

2. Set points at (0,18,0) and (0,20,0) for the extrusion origin and
offset, respectively, and press <Enter>.  (Notice the 2 inch
difference between the Y coordinates.  We're making the seat two
inches thick.)

3. When prompted, enter 1.0 for the scaling factor and press OK.

Let's adjust the viewing angle to get a better look at the seat.

1. Select Adjust Main View from the View menu.

2. Enter 30 for the horizontal and vertical angles and press OK.

3. Here's what you should see in the main view.  (Although not shown
here, your seat should have a black rectangle around it to show that
it's currently selected.)
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Figure 1-27.  The completed chair seat

The next step is to add the chair back.  Instead of drawing it from scratch,
we'll make a copy of the seat.

1. Make sure the chair seat is selected.  If it isn't, simply click on it.

2. Select Copy from the Edit menu.

3. Set points at (-12,18,12), (12,18,12), and (12,18,0).  Then press
<Enter>.  These points are called reference points and were
described earlier in this chapter.

4. Select Paste from the Edit menu.

5. Set points at (-12,22,14), (12,22,14), and (12,23,14).  Then press
<Enter>.  Notice how KeyCAD 3D aligns the reference points,
causing the back to be rotated into position.

Let's use the Zoom command to bring the chair fully into view.

1. Select Zoom from the View menu.

2. When prompted to set a point, just press <Enter>.

3. Select all viewports and the “Fit model entirely within viewport”
option.

4. Press OK.
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Figure 1-28: After the chair back has been added.

Step 5 - Draw back support
The chair back is floating in space without anything holding it up.  While
this is fine on screen, someone responsible for actually building the chair
would have a hard time.  To fix this, we'll connect the chair back to the
seat with a bent piece of metal. We'll use the Zoom command to magnify
the area we'll be working in.

1. Select Zoom from the View menu.

2. Set a point at (0,20,15) and press <Enter>.  This is the point to
zoom into.

3. Select all viewports and enter a zoom factor of 3.

4. Press OK.

Now we'll draw the back support as two straight pieces and a 45 degree
elbow.

1. Select bright blue as the current color.

2. Select Box from the Draw menu.

3. Set points at (-2,30,16) and (2,20,17) and press <Enter>.

4. Select Box from the Draw menu.

5. Set points at (-2,18,14) and (2,17,4) and press <Enter>.
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We'll draw the elbow by drawing a rectangle and sweeping it 90 degrees.

1. Select Box from the Draw menu.

2. Set points at (-2,18,14) and (2,17,14) and press <Enter>.

3. Select Sweep from the Surfaces menu.

4. Set points at (2,20,14) and (-2,20,14) for the rotation axis.  Then
press <Enter>.

5. When prompted, enter 5 for the number of copies and 90 for
degrees.

6. Press OK.

Now use the Zoom command to bring the chair into full view, then save.

1. Select Zoom from the View menu.

2. When prompted to set a point, just press <Enter>.

3. Select all viewports and the “Fit model entirely within viewport”
option.

4. Press OK.

5. Select Save from the File Menu to save the drawing.

That's it!  The completed chair is shown below:

Figure 1-29. After the chair back has been added
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Tilting the Chair Back
This section shows you how to use the Virtual Trackball to tilt the chair
back into a more comfortable position.  It is not necessary to complete this
section before moving on -- you can always come back to it later if
desired.

You use the Virtual Trackball to interactively rotate, scale, and/or move
objects.  To use it, you first need to select the object(s) that you want to
modify.  Next, you set one or two reference points.  The first point defines
the “origin” when scaling and moving.  The second point, along with the
first, defines the axis of rotation for rotating the object(s).  When you only
specify one point, all rotations will be about the Z axis.

If you haven't do so already, load MYCHAIR.MDL (or CHAIR.MDL if
you didn't do the tutorial).  Next, you need to make the chair back and
support bar into a group.  To do this:

1. Select the chair back and support bar pieces by drawing a 2D
selection box around them as shown:

Figure 1-30.  Selection box surrounding chair back and support
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When you release the mouse button, boxes will appear around all of the
selected objects:

Figure 1-31.  Chair back and support selection boxes

2. Select Make Group from the Edit menu.  This places all of the
selected objects into a group that will be easier to manipulate.  The
multiple selection boxes are then replaced with a single selection
box which surrounds the entire group.

3. Select Rotate/Move/Scale from the Edit menu.

4. Set points at (-2,17,4) and (2,17,4) and press <Enter>.  These
define the axis that we want to rotate around.  The following dialog
box appears:
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Figure 1-32.  Dialog box with Virtual Trackball

5. Drag the dialog box to the lower center of the screen so you can
fully see the chair back and support in all three viewports.

6. Position the mouse cursor over the center of the trackball and press
and hold the left mouse button.

7. Drag the mouse in any direction and notice how the boundary box
rotates forward and backwards around the axis of rotation.  You can
also rotate by pressing <Shift> and pressing the keyboard arrow
keys.

8. Release the mouse button, enter 15 in the “Rotation angle” field,
and press <Tab>.  (The entry isn't recognized until you move the
cursor out of the entry field.)  The chair back and support are now
rotated exactly 15 degrees.

9. Toggle the “Boundary box” option off by clicking on it.  This
replaces the boundary box with a multicolor image of the chair
back and support.

10. Again use the trackball to rotate the object.  Notice that while you
can see the actual chair back and support being rotated, it's slower
than the boundary box because of all the extra lines that must be
drawn.  (In fact, if the object is too complex then this option won't
be available.)

11. Set the rotation angle to 15 and press <Enter>.
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Alternate view 2 should now look like this:

Figure 1-33.  Office chair after back has been rotated

Shading the Office Chair
Shading is the process of shining one or more lights onto a drawing and
then determining what color each surface should be based its orientation to
the light source.  The more a surface faces the light source the brighter the
surface will be.  You can aim lights at different parts of the drawing to get
different effects.  While you can adjust the number, intensity, and
placement of these light sources, the default settings in KeyCAD 3D are
usually fine.

To shade our drawing of the office chair:

1. Select Open from the File menu.

2. Select MYCHAIR.MDL from the File menu.  (If you haven't draw
the chair yet, select CHAIR.MDL.)

3. Press OK.

4. Select Shade All Views from the Shade menu.
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The shaded chair looks like this:

Figure 1-34.  Office chair after shading

There's an important option in the Preferences dialog box that controls
shading quality.  Draft shading uses Windows' polygon fill routine to shade
surfaces.  While this is okay for most drawings, it can leave gaps in the
surface.  Final shading using a higher-precision (floating point) shading
routine which never leaves gaps.  The disadvantage of using Final shading
is that it takes longer, especially when printing.

Using Background Bitmaps
Tired of the same, boring white background?  Use a bitmap instead!
KeyCAD 3D lets you specify a background bitmap in the Preferences
dialog box for use during full screen shading.  Any bitmap will work,
regardless of the size!  Just select the “Tile” option and the bitmap will be
repeated as many times as needed to fill the screen.  Or, use the “Stretch to
fit” option to make the bitmap fit on the screen, stretching or compressing
as required.

1. Select Preferences from the File menu.

2. Press the “Load Bitmap” button.

3. Select any bitmap (.BMP) file and press OK.  (There are usually
several bitmaps in the Windows directory.)

4. Select the “Tile” option.
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5. Press OK.

6. Select Shade Full Screen from the Shade menu.

7. Press any key or click a mouse button to restore the screen.

Tip:  To copy the resulting picture to the clipboard, press the
PrintScreen key after shading is complete.  You can then paste the
picture into any other Windows drawing program where you can
make changes and/or print it.

Printing the Office Chair
We'll now show you how to print both shaded and wireframe versions of
the office chair.  KeyCAD 3D prints your drawing as it appears in one of
the viewports.  The first step is to use the Adjust View command and orient
the drawing the way you want it to be printed.

1. Select Adjust Main View from the View menu.

2. Rotate, Scale, and Move the viewpoint as desired.

3. Press OK.

If you have multiple printers, the next step is to select which one you want
to use.

1. Select Printer Setup from the File menu.  The following dialog box
appears:

Figure 1-35.  Printer Selection dialog box

2. Select the printer you want to use and press “Setup Printer” to set
its options, if needed.

3. Press OK.
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You're now ready to print.

1. Select Print from the File menu.  The following dialog box
appears:

Figure 1-36.  Print dialog box

2. Select the Main View, Printer, and Wireframe options.

3. Press OK.  Once the printing completes, repeat the above steps and
select the Shaded option to print a shaded version of the chair.

Important:   Before you print with the Shaded option, you should
first check and make sure the Shading Quality (in the Preferences
dialog box) is set the way you want it -- Draft or Final.  This is
important because Final shading takes much longer to print and
may not look any better than Draft shading, depending on your
printer.

Animating the Office Chair
The animation features in KeyCAD 3D bring your drawings to life!  Using
the powerful concept of key frames, you specify the exact viewing angle,
zoom factor, and focal point at key points in the animation.  Using this
information, KeyCAD 3D automatically draws each frame in the anima-
tion and saves the resulting bitmaps to disk.  You can then play these
animations using the Run Animation command.  These features are fully
integrated into KeyCAD 3D, so you can create and animate your drawings
all from the same program.

In this tutorial we'll show you how to generate an animation of the office
chair.  We'll make the chair appear to do the following:
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• Roll forward

• Spin around 1 1/2 times

• Do a flip

• Roll back

(Notice we said “appear” to do these things.  We won't actually be moving
the chair, just our viewpoint.)

We'll generate the animation using the following steps:

1. Load the drawing.

2. Save key frames

3. Preview the animation

4. Generate the animation

5. Run the animation

Step 1 - Load the drawing
First, load the drawing you want to animate.  In this tutorial we'll use the
chair you drew earlier, MYCHAIR.MDL.  (If you don't have it, you can
use CHAIR.MDL which comes with the software.)

1. Select Open from the File menu.

2. Select MYCHAIR.MDL and press OK.

Step 2 - Save key frames
Next, you'll save a series of  key frames.  A frame is a single frame, or
picture, in an animation sequence.  Key frames are where you specify the
viewing parameters (viewing angle, zoom factor, and focal point) at key
points in the animation.  KeyCAD 3D automatically calculates the viewing
parameters for each intermediate frame, making animations much easier to
create.

Before saving the key frames, we'll first clear out any old ones.  You'll
want to do this whenever you start defining a new animation.

1. Select Edit Key Frames from the File|Animation menu.
(File|Animation refers to the Animation popup menu that is located
in the File menu.)

2. Press the “Delete all frames” button.

3. Press OK.
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Next we'll setup the viewing parameters so the chair is centered in the
screen but appears to be way off in the distance.

1 Select Zoom from the View menu.

2 Press <Enter> when prompted to set a point.

3 Select the “Main view” and “Fit model entirely within viewport”
options.

4 Press OK.  The chair should now fit inside the viewport.

5 Select Adjust Main View from the View menu.

6 Enter the following values: Horizontal angle=0, Vertical angle=20,
Zoom=0.10.  Then press OK.  (While you could use the trackball
to set the angles, it's easier to simply type in the desired values
whenever you know what they are.)

The chair should now be centered in the main view and appear to be way
off in the distance.  This is how the animation will begin.  Let's review
what we want our energetic chair to do:

• Roll forward

• Spin around 1 1/2 times

• Do a flip

• Roll back

We're now ready to save the first key frame:

1. Select Save Key Frame from the File|Animation menu.

2. When prompted to set a point, just press <Enter>.

Now, to make the chair appear to move forward, we'll simply increase the
zoom factor and save another key frame.  Note that for each key frame
we're just adjusting the viewing parameters and not actually moving the
chair.

1. Select Adjust Main View from the View menu.

2. Enter 0.7 for the zoom factor and press OK.

3. Select Save Key Frame from the File|Animation menu.

4. When you're prompted to set a point, just press <Enter>.  The
following dialog box then appears:
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Figure 1-37.  Save Key Frame dialog box

5. Select the “Calculate change in viewpoint” option (the default) and
enter 10 for the number of intermediate frames.

6. Press OK.

Whenever you save a key frame, KeyCAD 3D needs to know if you want
the animation to smoothly change from the previous key frame to the one
being saved.  If so, you also need to specify how many intermediate
frames you want generated.  Specifying more frames will make the
transition smoother, but will also take longer to generate and use up more
disk space.

You use the second option, “Reset to current viewpoint”, whenever you
want the animation to jump to the key frame being saved, without regard
to the previous key frame.  This is useful when, for example, you are
walking through a building and immediately want to jump to an outside
view.  Key frame 0 always defines the beginning of the animation, and
therefore the initial viewpoint.  Therefore, when you save key frame 0, the
“Reset to current viewpoint” option is automatically selected and the
dialog box does not appear.

For the remaining key frames, perform the above steps using the following
viewing parameters.  Be sure to enter 10 for the number of intermediate
frames.  Also, don't change any parameters other than the ones listed.

1. To spin around 1 1/2 times, set the horizontal angle to 540 (360
degrees for a full circle plus 180 degrees for another half circle)
and save a key frame.

2. To do the flip, set the vertical angle to 380 and save a key frame.

3. To roll away, set the zoom factor to 0.10 and save a key frame.
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Step 3 - Preview the animation
Generating a complex animation can take some time to complete since
each frame must be individually rendered and saved to disk.  To speed up
the animation design and test cycle, KeyCAD 3D supports an “Animation
Preview” mode.  This mode, when combined with the “Wireframe” option,
lets you quickly preview the animation and determine if any changes are
needed.

To preview the animation:

1. Select Generate Animation from the File|Animation menu.  The
following dialog box appears:

Figure 1-38.  Generate Animation dialog box

2. Select a frame size of 1/5 and set the Wireframe and Preview
options.

3. Press OK.  Note that when the Preview option is set you do not
have to specify a filename (since none of the frames will be saved).

Once you press OK, a small window appears in the center of your screen
and a wireframe version of the animation is generated.  We chose a small
frame size so the animation would run quickly, but you can select any size.
You can also preview shaded animations, but they take longer.

To cancel the animation preview, press any key or click anywhere inside
the animation window.
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Step 4 - Generate the animation
Now let's generate the animation and actually save each frame to disk.
(You should make sure you have at least 1 megabyte of available hard disk
space before continuing.)

1. Select Generate Animation from the File|Animation menu.

2. Set the frame size to 1/4, select the Shaded option, and enter the
file name “C:\CHAIR”.

3. Press OK.

This animation will generate 45 files with the names CHAIR.000 through
CHAIR.044.  The size of each file will depend on the frame size and the
type of video adapter you're using.  For a frame size of 1/4 on a standard
16 color VGA adapter, each file will be 9582 bytes, making the total size
of the animation 431,190 bytes (45 * 9582).  You will receive an error
message if your hard disk fills up while generating the animation; even so,
you can still view the portion of the animation that completed successfully.

Normally each frame of the animation is displayed on top of a white
background.  You can use a bitmap as the background instead, if desired.
Although using a bitmap slows down animation generation by a small bit,
it does not have any affect on the speed of the animation when you later
run it.

1. Select Preferences from the File menu.  The following dialog box
appears:

Figure 1-39.  Preferences dialog box
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2. Enter the name of the bitmap in the Background bitmap field.  (Or,
press the Load Bitmap button if you don't know the exact file
name.)

3. Select the “Stretch to fit”, “Original size”, or “Tile” options.  Select
“Stretch to fit” when you want the bitmap stretched (or com-
pressed) to fit inside the animation window.  Select “Original size”
to keep the bitmap its original size.  Select “Tile” to tile (repeat)
the bitmap across and down until it fills the animation window.

4. Press OK and regenerate the animation.

Step 5 - Run the animation
Finally, on to the fun part!  Let's run the animation we just generated:

1. Select Run Animation from the File|Animation menu.  The
following dialog box appears:

Figure 1-40.  Run Animation dialog box
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2. Enter the file name C:\CHAIR and press OK.

KeyCAD 3D then displays each frame in the animation one right after
another (CHAIR.000 to CHAIR.044).  To stop the animation, press any
key or click in the animation window.

Note:  To free up the hard disk space used by the animation, delete
the files C:\CHAIR.000 through C:\CHAIR.044.

Note that each file is a standard Windows bitmap that you can edit with
any Windows graphics editor (such as Microsoft Paintbrush).  You could,
for example, add your company logo to each frame of the animation.

As you may have guessed, we have only touched on the animation
capabilities of KeyCAD 3D.  With some practice and imagination, you can
create some really spectacular animations.  Have fun and experiment!
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Setting Points

Points Menu and Tool Bars

Nearly all KeyCAD 3D commands require you to set one or more points.
Points are used for a number of reasons, such as determining where a
curve is to be drawn, setting an axis of rotation, specifying a point to zoom
into, and so forth.  Whenever KeyCAD 3D is waiting for you to set a
point, it will prompt you for the point at the bottom of the screen and will
display the point-setting tools.

Figure 2-1.  Setting Points tool bar

Points are always set at a location in the XYZ coordinate system.  The
coordinate (0,0,0) is called the origin.  X increases as it moves to the right
of the origin and decreases as it moves to the left.  Y increases as it moves
above the origin and decreases as it moves below.  Z increases at it moves
outward from the origin and decreases as it moves inward.  The origin is at
the center of the main and alternate views before you use the Pan or Zoom
commands.
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Figure 2-2.  X, Y, Z coordinate system

You decide which unit of measurement to use.  For example, if you decide
to use inches as your unit of measurement, then 1.0 would represent one
inch, 12 would represent one foot, 0.5 would represent 1/2 inch, and so
forth.  You do not actually configure KeyCAD 3D to use inches; you
simply decide what each unit stands for and then it them consistently.  You
use the Set Drawing Units command to tell KeyCAD 3D how to map your
units to the main view.

KeyCAD 3D uses points to describe each object.  The number of points in
the object and the location of each point is determined by the type of
object.  Although these points are not visible on the screen, they are
usually easy to find.

Line   There is one point at the start and end of the line.  When a line has
multiple segments, there is also one point at each vertex (corner).  When
you draw a line you are setting the line start, end, and vertex points.



Setting Points   2-3

Figure 2-3.  Line vertices

Polygon   There is one point at each vertex of the polygon.  When you
draw a polygon you are setting the polygon vertices.

Figure 2-4.  Polygon vertices

Curve   Curves are defined by control points; that is, points through
which the curve is drawn.  When you set the points for a curve you are
setting the control points.

Figure 2-5.  Curves are defined by control points
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NOTE:  When you cut a curve using the Slice command, KeyCAD 3D
converts the curves into a line with multiple segments.

Text   KeyCAD 3D uses three control points to define text location, size,
and orientation.  The first point determines the text location.  The second
point, along with the first, determines the text size and angle.  The third
point, along with the first two points, determines the plane.  When you
draw text, you can enter one, two, or all three of these points.  If you enter
less than three points then KeyCAD 3D will automatically calculate the
remaining points using the default text size and angle.

TEXT 21
size

Figure 2-6.  Control points used for text

Everything you draw in KeyCAD 3D uses one or more of the above
objects (also called primitives).  For example, a circle is really a polygon,
a sphere is a group of polygons, and so forth.

To set a point, move the cursor to the desired location and click the left
mouse button or press the <Ins> key.  You can also set a point using one of
the point-setting commands described in this chapter.

If you set a point mistakenly, you can erase it by either clicking on the red
X button, or by pressing <Esc>.  If you do this while KeyCAD 3D is
prompting you for the first point of the command, you will cancel the
command.

You can set up to 100 points in a single command, although many
commands have a much smaller limit.  If you have reached the maximum
number of points you can set for the current command, KeyCAD 3D
prompts you with the message, “Maximum  points set.  Press <Enter>.”

When you are through setting points, press <Enter>.  You can also push
the green check mark or press the right mouse button -- whichever method
you prefer.

You can have KeyCAD 3D display the distance between the last point you
set and the current cursor position by selecting the Show Distance
Between Points option from the View menu.  This helps you set points an
exact distance apart.  When this option is enabled, the position bar changes
to show the distance along the X, Y, and Z axes.  It also shows the total
distance between the two points.  (You can toggle this option on and off by
pressing the “d” key.)



Setting Points   2-5

Figure 2-7.  Setting points with the “Show Distance Between Points” option

The point-setting commands can also be accessed by pressing the
corresponding keyboard key.

Absolute
Menu: Points|Absolute Hotkey: <a>

You use the Point Absolute command to set a point at the specified XYZ
coordinate.  This is useful when you know exactly where you want the
point to be set.  You can even set points outside the viewport, although you
won't be able to see them.

1. Select the Point Absolute command.

2. Enter the desired XYZ coordinates.

3. Press OK.  KeyCAD 3D will then set a point at the specified
coordinates.

Figure 2-8.  Point Absolute dialog box
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Dialog Box Fields

X Y Z   You enter the coordinates of the point you want to set in these
fields.  By default, these fields contain the coordinates of the last point you
set.

For example, to set a point at coordinates (10, 100, -20.05), you would
enter 10 for X, 100 for Y, and -20.05 for Z.

Relative
Menu: Points|Relative Hotkey: <r>

This command lets you set a point a specified distance along the X, Y, and
Z axes from the last point that you set.

1. Select the Point Relative command.

2. Enter the desired distance to move from the last point that was set,
as shown in the dialog box.

3. Press OK.  KeyCAD 3D will then calculate the new coordinates
(by adding the values you enter to those of the last point that was
set) and set a point there.
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Figure 2-9.  Point Relative dialog box

Dialog Box Fields

X Y Z  You enter the new coordinates relative to the last point that was set
in these fields.  You can leave a field blank if you do not want to “move” in
that direction.

Last point was set at X Y Z   These fields show you where the last point
was set.

For example, if the last point was set at (10, 15, 20) and you want to set a
point 50 units below that point, you would enter -50 for Y and leave the X
and Z fields blank.
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Polar
Menu: Points|Polar Hotkey: <o>

This command lets you set a point that is rotated around the X, Y, or Z
axis, using the last point as a reference.  This is useful when you want to
set points in a circular fashion.  KeyCAD 3D takes the distance you enter,
adds it to either the X, Y, or Z coordinate of the last point that was set,
rotates the point by the specified number of degrees, and sets a point at
that location.

Figure 2-10.  Rotation about the various axes

1. Select the Point Polar command.

2. Set the rotation axis (X, Y, or Z).

3. Enter the distance from the last point that you want the new point
to be located.  (The coordinates of the last point are shown in the
dialog box.)

4. Enter the number of degrees to rotate.  A positive value will cause
the point to be rotated counter-clockwise; a negative value will
cause the point to be rotated clockwise.

5. Press OK.  KeyCAD 3D will then calculate a point using the
values you entered and set a point there.



Setting Points   2-9

Figure 2-11.  Point Polar dialog box

Dialog Box Fields

Rotation Axis   Axis of rotation.  KeyCAD 3D uses the last point as the
center of rotation.

Distance from Last Point   You enter the distance from the last point
set to establish the position of the new point.

# of degrees   Number of degrees the point is to be rotated around the
specified axis of rotation.

For example, say the last point was set at the origin (0, 0, 0) and you want
to set a point 10 units to the right of the origin and have it rotated about the
Y axis by 45 degrees.  You would select Y as the axis of rotation, enter a
distance of 10, and enter 45 for the degrees.  KeyCAD 3D will then set a
point at (7.071, 0, 7.071).

TIP:  Visualize yourself looking down the axis of rotation, with your
eye positioned at the negative end and looking toward the positive
end.  A positive rotation angle will then rotate the point counter-
clockwise around the axis; a negative rotation angle will rotate the
point clockwise.
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Figure 2-12.  Visualizing the view down the axis of rotation

Closest Point
Menu: Points|Closest Point Hotkey:  <p>

This command takes the last point you set and moves it to the closest point
in the drawing.  You should use this command whenever you want a point
to coincide precisely with another point in the drawing.  Just because two
points appear to coincide on the screen does not necessarily mean they are
at exactly the same coordinates.  While this may look okay initially, it
could result in discontinuities (gaps between lines) when the drawing is
zoomed or printed.  This command is also important because some
KeyCAD 3D commands, such as Fillet, Chamfer, and Surface Patch,
require that lines and other objects connect at a common point.

1. Set a point near the point you want to snap to.

2. Select the Closest Point command.  The point you set will be
moved to the closest point in the drawing, even if that point is off
the screen.

NOTE:   If you happen to discover discontinuities in your drawing,
they can be easily corrected using the Join Points command.  See
“Joining Points” on page 117.
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TIP:   The snap grid makes it easier to set points at more predictable
locations. See  page 12 for more information.

Closest Line
Menu: Points|Closest Line Hotkey:  <l>

This command takes the last point you set and moves it to the closest line
in the drawing.  This makes it easy to set a point exactly on a line and
prevents gaps from appearing when you zoom or print the drawing.

1. Set a point near the line you want to set a point on.

2. Select the Closest Line command.  The point you set will be
moved to the closest line in the drawing, even if the line is off the
screen.

Closest Plane
Menu: Points|Closest Plane Hotkey:  <n>

This command moves the last point you set to the closest plane (polygon)
in the drawing.  This makes it easy to set a point exactly on the surface of
a polygon.

1. Set a point near the polygon you want to set a point on.

2. Select the Closest Plane command.  The point you set will be
moved to the surface of the closest polygon in the drawing, even if
the polygon is off the screen.

Line Midpoint
Menu: Points|Line Midpoint Hotkey: <i>

This command takes the last point you set and moves it to the middle of
the closest line in the drawing.  This makes it easy to set a point exactly in
the middle of a line and prevents gaps from appearing when you zoom or
print the drawing.

1. Set a point near the line you want to set a point on.

2. Select the Line Midpoint command.  The point you set will be
moved to the middle of the closest line in the drawing, even if the
line is off the screen.
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Drawing Objects

Draw Menu and Tools

You design things with KeyCAD 3D by drawing and editing various
shapes, or objects.  These basic shapes provide the building blocks you
need to design complicated drawings, such as cars, airplanes, buildings,
and so forth.  You can even design your own objects and save them in a
disk file for later use using the Copy To and Paste From commands.

Figure 3-1.  Building drawn using multiple objects
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To draw objects in KeyCAD 3D, you first select the object you want to
draw (such as a line, circle, or sphere) by either pressing the corresponding
button on the tool bar or by selecting the object from the menu.  You will
then be asked to set one or more points to define the object.  All new
objects are assigned the current color and layer settings.  KeyCAD 3D
automatically selects each object after you draw it so you can quickly
proceed to make changes to it, if desired.

The following drawing commands are supported:

Command Points
Arc 1 - Center

2 - Start
3 - Plane (optional)

Box 1 - Corner 1
2 - Corner 2

Circle 1 - Center
2 - Radius
3 - Plane (optional)

Circle 1,2 - Diameter
3 - Plane (optional)

Cone 1 - Center
2 - Width
3 - Height and direction

Curve 1 through 100 - Points to draw curve through
Cylinder 1 - Center

2 - Radius
3 - Height and direction

Ellipse 1 - Center
2 - Height
3 - Width (and plane)

Hemisphere 1 - Center
2 - Radius
3 - Plane (optional)

Line 1 through 100 - Points to draw line through
Polygon 1 through 100 - Points to draw polygon through
Sphere 1 - Center

2 - Radius
3 - Plane (optional)
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NOTE:  You can control how many line segments KeyCAD 3D uses to
construct the circles used in arcs, circles, ellipses, cones, cylinders,
spheres, and hemispheres with the “Number of Circle Segments”
option in the Preferences dialog box.  Increasing this value in-
creases the quality of the object but also adds more points to the
drawing.  Changing this value only affects new objects that you
draw—existing objects are not affected.

Drawing an Arc

Menu: Draw|Arc

Point 1: Arc center
Point 2: Start point
Point 3: Plane (optional)

This command lets you draw an arc; that is, a portion of a circle.

To draw an arc:

1. Select the Draw Arc command.

2. Set a point at the center of the imaginary circle that you want the
arc drawn on.

3. Set a point at the location where you want the arc to start.

4. If you want the arc to lie on a plane other than the XY plane, set a
third point anywhere on the desired plane.  (The plane is defined
by all three points.)

5. Press <Enter>.

6. KeyCAD 3D will then prompt you for the arc angle in degrees.
Enter a positive value to sweep the arc counter-clockwise.  Enter a
negative value to sweep the arc clockwise.

7. Press OK.  KeyCAD 3D will then draw an arc (as a polyline) and
automatically select it.

TIP:  Depending on what you're working on, it may be easier to draw
a circle of the desired size and then cut off an arc using the Slice
command.  See “Slicing Objects” on page 114.
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Figure 3-2. Example of the Arc command
(This arc was drawn using an angle of 270 degrees.)

Drawing a Box

Menu: Draw|Box

Point 1: Corner 1
Point 2: Corner 2

This command lets you draw a box.  The two points you set are the
opposite corners of the box.  KeyCAD 3D draws the box using six
polygons, one for each side, and then makes the polygons into a group.  If
the points you set have the same Z coordinate (meaning the box has no
depth), then KeyCAD 3D will draw a single polygon.
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When you draw using different Z coordinates (that is, when the box has
depth), the box is a solid object that can be used with the Solid Add, Solid
Subtract, and Solid Intersection commands without modification.

To draw a box:

1. Select the Draw Box command.

2. Set a point at one corner of the box.

3. Set a point at the opposite corner of the box.

4. Press <Enter>.  KeyCAD 3D will then draw the box and automati-
cally select it.

Figure 3-3. Example of the Box command
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Drawing a Circle (Center & Radius)

Menu: Draw|Circle (center & radius)

Point 1: Center
Point 2: Radius
Point 3: Plane (optional)

KeyCAD 3D supports two circle-drawing commands.  The first command
lets you specify a circle by its center and radius points.  The second
command lets you specify a circle by its diameter.  Both commands draw a
circle using a single polygon.

To draw a circle using center and radius points:

1. Select the Draw Circle (center & radius) command.

2. Set a point at the center of the circle.

3. Set a point anywhere on the edge of the circle.  The distance from
the second point to the first point determines the radius of the
circle.

4. If you want the circle to lie on a plane other than the XY plane, set
a third point anywhere on the desired plane.  (The plane is defined
by all three points.)

5. Press <Enter>.  KeyCAD 3D will then draw the circle and
automatically select it.
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Figure 3-4.  Example of a circle drawn using the Circle (center & radius) command

Drawing a Circle (Diameter)

Menu: Circle (diameter)

Point 1: Diameter 1
Point 2: Diameter 2
Point 3: Plane (optional)

To draw a circle using two diameter points:

1. Select the Draw Circle (diameter) command.

2. Set a point on the edge of the circle.

3. Set a point on the opposite edge of the circle.  The distance from
the second point to the first point determines the diameter of the
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circle.

4. If you want the circle to lie on a plane other than the XY plane, set
a point anywhere on the desired plane.  (The plane is defined by all
three points.)

5. Press <Enter>. KeyCAD 3D will then draw the circle and select it.

Figure 3-5. Example of a circle drawn using the Circle (diameter) command

Drawing a Cone

Menu: Cone

Point 1: Center
Point 2: Width of base
Point 3: Height and direction

This command lets you draw a cone.  You specify three points: one for the
center of the base circle, one for the width of the base circle, and one to
specify the height and direction.  The distance from the second point to the
first point determines the radius of the base circle.  KeyCAD 3D draws the
cone as a series of polygons and then automatically makes the polygons
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into a group.

The cone is a solid object that can be used with the Solid Add, Solid
Subtract, and Solid Intersection commands without modification.

To draw a cone:

1. Select the Draw Cone command.

2. Set a point at the center of the cone base.

3. Set a point at the width (radius) of the cone base.

4. Set a point for the cone height and direction.

5. Press <Enter>.  KeyCAD 3D will then draw the cone and select it.

Point 3 - Height and Directions

Point 1 - Center
Point 2 - Width

Figure 3-6. Example of the Cone command

Drawing a Curve

Menu: Draw|Curve

Point 1–100: Points to draw curve through

This command lets you draw a smooth curve.  You set three or more
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points, called control points, through which you want a curve to be drawn.
Like all other KeyCAD 3D drawing commands, you can draw the curve
anywhere in 3D space; that is, you are not limited to drawing on a flat
surface.  The curve will pass through each of the points that you set.  The
more points you set, the more control you have over the curve.  KeyCAD
3D stores only the control points in memory, not each point on the curve.
This not only saves memory, but also lets you move the control points at a
later time, thus letting you change the shape of the curve without forcing
you to re-draw it.

To draw a curve:

1. Select the Draw Curve command.

2. Set three or more control points.

3. Press <Enter>.  KeyCAD 3D will then draw the curve and
automatically select it.

NOTE:  KeyCAD 3D automatically converts curves to lines when split
with the Slice command.  See “Slicing Objects” on page 114.

Points 1 - 100 Control Points

Figure 3-7. Example of the Curve command
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Drawing a Cylinder

Menu: Cylinder

Point 1: Center
Point 2: Radius
Point 3: Height and direction

This command lets you draw a cylinder.  You specify three points: one for
the center, one for the radius, and one to specify the height and direction.
The distance from the second point to the first point determines the radius
of the cylinder.  KeyCAD 3D draws the cylinder as a series of polygons
and then automatically makes the polygons into a group.

The cylinder is a solid object that can be used with the Solid Add, Solid
Subtract, and Solid Intersection commands without modification.

To draw a cylinder:

1. Select the Draw Cylinder command.

2. Set a point at the center of the base circle.  (The base circle is at the
starting end of the cylinder.)

3. Set a point at the radius of the base circle.

4. Set a point for the cylinder height and direction.

5. Press <Enter>.  KeyCAD 3D will then draw the cylinder and
automatically select it.
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Figure 3-8. Example of the Cylinder command

Drawing an Ellipse

Menu: Draw|Ellipse

Point 1: Center
Point 2: Width
Point 3: Height and plane

KeyCAD 3D lets you draw an ellipse (oval) anywhere you want and at any
orientation.  Unlike circles, you always enter three points for an ellipse.
The first point determines the center of the ellipse.  The second point
defines the radius (width), and the third point defines the height.  The
radius is determined by the distance between the first and second points.
The height is determined by the distance between the first and last points.
The plane is determined by all three points.

To draw an ellipse:

1. Select the Draw Ellipse command.

2. Set a point at the center of the ellipse.



Drawing Objects   3-13

3. Set a point for the width of the ellipse.

4. Set a point for the height and plane of the ellipse.

5. Press <Enter>.  KeyCAD 3D will then draw the ellipse and
automatically select it.

CenterPoint 1 -

Point 2 - Width

Point 3 - Height

Figure 3-9. Example of the Ellipse command

Drawing a Hemisphere

Menu: Hemisphere

Point 1: Center
Point 2: Radius
Point 3: Direction (optional)

You use this command to draw a hemisphere (half a sphere).  You specify
two or three points.  The first two points define the center and radius.  The
third point defines the direction of the top.  KeyCAD 3D draws the
hemisphere as a series of polygons and then automatically makes the
polygons into a group.
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To draw a hemisphere:

1. Select the Draw Hemisphere command.

2. Set a point at the center of the hemisphere base.

3. Set a point for the hemisphere radius.

4. Set a point for the direction (optional).

5. Press <Enter>.  KeyCAD 3D then prompts you for the polygon
density.  The number you enter determines how many polygons
will be generated around the hemisphere, and therefore how dense
the resulting surface will be.

6. Press OK.  KeyCAD 3D will then draw the hemisphere and
automatically select it.

NOTE:  The hemisphere is not a solid object since it is drawn without
a bottom.  To make it into a valid solid, simply add a circle to the
base.

Point 3 - Direction (optional)

Point 2 - Radius

Point 1 - Center

Figure 3-10. Example of the Hemisphere command
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Drawing a Line

Menu: Draw|Line

Points 1–100: Line points

This command lets you draw a line with one or more segments (also called
a polyline).  When you draw the line you set a point at each position you
want a line drawn through.  KeyCAD 3D stores only the endpoints you
enter, not each point on the line.  This not only saves memory, but also lets
you change the shape of the line without forcing you to re-draw it.

While the wireframe representation of lines and polygons may look
identical on the screen, there is an important difference.  Lines are
infinitely thin, while polygons represent surfaces.  Lines therefore do not
appear when you shade the drawing.  For this reason, you should use lines
only when building surfaces with commands such as Extrude and Sweep.
See page 95 for more information.

KeyCAD 3D considers each line drawn using this command as a single
line, even when the line has multiple segments.  To break each segment of
the line into a separate line, use the Break Lines command.  To combine
several connected line segments into a single line, use the Combine Lines
command.  See page 132 and 133 for more information on these com-
mands.

To draw a line:

1. Select the Draw Line command.

2. Set two or more points on the line.

3. Press <Enter>.  KeyCAD 3D will then draw the line and automati-
cally select it.

NOTE:  The Convert Polygons into Lines command can be used to
convert polygons into lines.  Conversely, the Convert Lines into
Polygons command can be used to convert lines into polygons.
See “Converting Polygons into Lines” on page 135.
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Points 1 - 100: Line Endpoints

Figure 3-11. Two lines drawn using the Line command

Drawing a Polygon

Menu: Draw|Polygon

Points 1–100: Polygon vertices

This command lets you draw a polygon; that is, a many sided figure.  A
polygon can have up to 99 sides (100 vertices).  When you draw a polygon
you specify each vertex.  Polygons are always closed—KeyCAD 3D will
automatically close the polygon by connecting the last vertex to the first, if
needed.  Although polygons look identical to lines when viewing their
wireframe representation, they are different from lines in that they can be
shaded, while lines cannot.  That is, polygons represent flat surfaces, while
lines are infinitely thin.  Polygons should be as flat (planar) as possible, in
order for them to be properly rendered during shading.

To draw a polygon:

1. Select the Draw Polygon command.

2. Set a point at each polygon vertex.  (A minimum of three points is
required.)

3. Press <Enter>.  KeyCAD 3D will then draw the polygon and
automatically select it.
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During shading, polygons are not drawn if they are completely on edge
with respect to the viewport.  This is because polygons represent infinitely
flat surfaces and therefore have no “thickness.”  However, you can extrude
polygons to the desired thickness with the Extrude command.  See
“Drawing an Extruded Surface” on page 96.

NOTE:  The Convert Polygons into Lines command can be used to
convert polygons into lines.  Conversely,  the Convert Lines into
Polygons command can be used to convert lines into polygons.
See “Converting Polygons into Lines” on page 135.

Points 1 -100: Polygon Vertices

Figure 3-12. Example of the Polygon command

Drawing a Sphere

Menu: Draw|Sphere

Point 1: Center
Point 2: Radius
Point 3: Direction

You use this command to draw a sphere (ball).  You specify two or three
points: one for the center, one for the radius, and one for the direction.
The distance from the first point to the second determines the radius of the
sphere.  The third point determines the direction of the top.  KeyCAD 3D
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draws the sphere as a series of polygons and then automatically makes the
polygons into a group.

The sphere is a solid object that can be used with the Solid Add, Solid
Subtract, and Solid Intersection commands without modification.

To draw a sphere:

1. Select the Draw Sphere command.

2. Set a point at the center of the sphere.

3. Set a point for the sphere radius (width).

4. Set a point for the sphere direction (optional).

5. Press <Enter>.  KeyCAD 3D then prompts you for the polygon
density.  The number you enter determines how many polygons
will be generated around the sphere, and therefore how dense the
resulting surface will be.

6. Press OK.  KeyCAD 3D will then draw the sphere and automati-
cally select it.

NOTE:  The sphere is a complex object and may take some time to
draw and shade, especially on slower systems.

Point 1 - Center

Point 2 - Radius

Point 3 - Direction (optional)

Figure 3-13. Example of the Sphere command
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Drawing Surfaces

Surfaces Menu and Tools

KeyCAD 3D provides several commands that let you make complex
surfaces out of simple objects.

The Extrude command takes simple objects, such as lines and polygons,
and expands them out into a 3-dimensional surface.  For example, you can
take a rectangle with rounded corners and stretch it into a chair seat.  The
Extrude command also lets you define multiple extrusion offsets and scale
factors.  This lets you design complex objects such as gears and pulleys
that might otherwise be difficult to draw.

The Sweep command sweeps objects around an arbitrary axis and
connects each part with a surface.  This lets you take the 2-dimensional
profile of a glass, for example, and turn it into a full 3-dimensional object,
all in one easy step!  The surfaces formed by this command are also called
surfaces of revolution.

The Spiral command is similar to the Sweep command, except that it lets
you specify the distance to move along the axis of rotation.  This lets you
draw complex objects like springs and screws.

The Surface Patch command lets you connect a true 3-dimensional surface
patch between any four boundary lines or curves.  This lets you draw
complex surfaces such as airplane wings and car fenders.

To use these commands, you first select one or more objects that you want
turned into a surface.  These objects can be lines, curves, and/or polygons.
It doesn't matter if the objects are grouped or ungrouped.  KeyCAD 3D
will prompt you for any additional information and then draw the surface.
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If you make a mistake and want to try again, simply select Undo from the
Edit menu.  Feel free to experiment with these commands, they're fun!
(Due to the complex calculations performed by these commands and the
number of data points that they can generate, you'll find that a math
coprocessor will speed things up considerably.)

NOTE:  Before you can use these commands with fixed text, you
must convert the text into lines using the Convert Fixed Text to
Lines command.  (This restriction does not apply if you added your
text as lines.)  See “Converting Text to Lines” on page 155.

Drawing an Extruded Surface
Menu: Surfaces|Extrude

Point 1: Origin
Point 2–100: Extrusion offsets

This command lets you extrude (stretch) lines, polygons, and/or curves
into a 3-dimensional surface.  You can enter multiple extrusion offsets,
each with their own scale factor, to control the shape and direction of the
extruded surface.

To use the Extrude command:

1. Select one or more objects that you want to extrude.

2. Select the Extrude command.

3. Set a point at the object's origin.  KeyCAD 3D will scale the
selected object around this point and use it to determine the
distance to the first extrusion offset.

4. Set a point at each extrusion offset.  These are the locations where
you want KeyCAD 3D to place a copy of the selected object.

5. Once you press <Enter>, KeyCAD 3D will prompt you for a
scaling factor for each extrusion offset that you specified in the
previous step.  A scale factor of less than 1.0 will cause the object
to shrink.  A scale factor of greater than 1.0 will cause the object to
grow.  For example, enter 0.5 for an object 1/2 size of the original;
or enter 2.0 for an object twice the size of the original.  Enter 1.0
for an object that is the same size as the original.
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Figure 4-1. Example of the Extrude command

Drawing a Spiraled Surface
Menu: Surfaces|Spiral

Point 1: Start of axis of rotation
Point 2: End of axis of rotation

This command lets you sweep lines, polygons, and/or curves in a circle
around an axis of rotation (an imaginary line) to form a surface.  It is very
useful for making things like springs and screws.  You enter an offset and
scale factor which controls how far down the axis of rotation the surface is
generated and what its ending size will be.  You also enter the total number
of degrees to sweep and the number of copies you want generated.  These
parameters control how the surface will look and how dense the resulting
surface will be.

This command prompts you to enter two points for the axis of rotation.
These two points will form an imaginary line in 3-dimensional space
around which the surface will be generated.  The placement of this line
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and its distance from the object to be swept controls how the surface will
look.  While the length of the line is not important (although it cannot be
zero), the direction is important because it controls which direction the
surface will sweep.  When looking down the line with your eye placed at
its start point, a positive rotation angle will cause the surface to sweep
counter-clockwise; a negative rotation angle will cause the surface to
sweep clockwise.

Start

Axis of Rotation

End

Eye

Figure 4-2. Viewing the Axis of Rotation

To draw a spiraled surface:

1. Select one or more objects that you want to spiral.

2. Select the Spiral command.

3. Set the start point of the axis of rotation.

4. Set the end point of the axis of rotation.

5. Press <Enter>.  KeyCAD 3D will then prompt you for the number
of copies, total # of degrees, total offset, and total scale factor and
generate the surface.
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Figure 4-3. 

Spiral dialog box

Dialog Box Fields

Number of copies  Enter the number of copies to make of the selected
objects.  KeyCAD 3D will place each copy around the axis of rotation at
the calculated position, rotation angle, and scale factor.  A surface will
then be generated between each copy.

Total # of degrees  Enter the total number of degrees around the axis of
rotation that you want the objects to be swept.  KeyCAD 3D divides the
number you enter here by the number of copies in order to determine how
far around the axis of rotation to rotate each copy.  Enter 360 degrees to
loop once around the axis of rotation, 720 degrees to loop twice, 540
degrees for 1 1/2 loops, and so forth.  Enter a positive number to sweep in
the counter-clockwise direction, or a negative number to sweep in the
clockwise direction.

Total offset   Enter the total distance down the axis of rotation that you
want the surface to be generated.  KeyCAD 3D divides this number by the
number of copies to determine the distance between each copy.

Total scale factor  Enter the total amount you want the surface scaled
from beginning to end.  KeyCAD 3D divides this number by the number
of copies to determine the scale factor for each copy.  If you enter a value
greater than 1 then the surface will increase in size.  If you enter a value of
less than 1 (but greater than 0) then the surface will decrease in size.  If
you enter a value of 0 then the surface will decrease to a point.  Enter 1.0
to disable scaling.
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Figure 4-4. Example of the Spiral command

Drawing a Swept Surface
Menu: Surfaces|Sweep

Point 1: Start of axis of rotation
Point 2: End of axis of rotation

This command lets you sweep lines, polygons, and/or curves in a circle
around an axis of rotation (an imaginary line) to form a surface, or surface
of revolution.  It is very useful for making all kinds of things such as
glasses, lamp vases, and doughnuts.  You specify the axis of rotation, scale
factor, and number of copies.  These parameters control how the surface
will look and how dense the resulting surface will be.

This command prompts you to enter two points for the axis of rotation.
These two points will form an imaginary line in 3-dimensional space
around which the surface will be generated.  The placement of this line
and its distance from the object to be swept controls how the surface will
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look.  While the length of the line is not important (although it cannot be
zero), the direction is important because it controls which direction the
surface will sweep.  When looking down the line with your eye placed at
its start point, a positive rotation angle will cause the surface to sweep
counter-clockwise; a negative rotation angle will cause the surface to
sweep clockwise.

Eye

Start

End

Axis of Rotation

Figure 4-5. Axis of Rotation used in Sweep command

To draw a swept surface:

1. Select one or more objects that you want to sweep.

2. Select the Sweep command.

3. Set the start point of the axis of rotation.

4. Set the end point of the axis of rotation.

5. Press <Enter>.  KeyCAD 3D will then prompt you for the number
of copies and total # of degrees.  Once you enter these values and
press OK, KeyCAD 3D will generate the surface.
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Figure 4-6. Sweep dialog box

Dialog Box Fields

Number of copies  Enter the number of copies to make of the selected
objects.  KeyCAD 3D will place each copy around the axis of rotation at
the calculated rotation angle and scale factor.  A surface will then be
generated between each copy.

Total # of degrees  Enter the total number of degrees that you want the
object to be swept around the axis of rotation.  KeyCAD 3D divides the
number you enter here by the number of copies to determine how far
around the axis of rotation to rotate each copy.  Enter 360 degrees to form
a full circle, 180 degrees for half a circle, 90 degrees for one quarter of a
circle, and so forth.

TIP:  Use the Spiral command if you want to sweep a surface and
control its scale factor.  Be sure to specify an offset of zero to
indicate that you don't want the surface to move down the axis of
rotation.
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Figure 4-7. Example of the Sweep command

Drawing a Surface Patch
Menu: Surfaces|Patch

This command forms a surface out of four boundary lines or curves.  It is
very useful in drawing non-geometric shapes such as car fenders, airplane
wings, and tablecloths.  The boundary lines or curves can exist anywhere
in 3-dimensional space.  In other words, the surface patch doesn't have to
be flat.  You can control the density of the surface patch and therefore how
smooth it will be.

You must select exactly four lines or curves with this command, and the
lines or curves must be connected.  KeyCAD 3D provides several
commands to help you meet these requirements:

• Use the Join Points command to join points that aren't quite
connected.

• Use the Combine Lines command to combine one or more
connected lines or curves into a single line.
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• Use the Break Lines command to break a single line, curve, or
polygon into multiple lines.

• Use the Slice command to cut lines, curves, or polygons.

See “Making Changes” on page 107 for more information about each of
the above commands.

The surface patch is generated using formulas developed by the late
Steven A. Coons.  It is also referred to as a Coons Surface Patch.

To draw a surface patch:

1. Select exactly four connected lines or curves.

2. Select the Surface Patch command.

3. KeyCAD 3D will then prompt you to enter the polygon density.
This number determines how many polygons will be used in the
surface patch, and therefore how dense the patch will be.  (The
total number of polygons that this command will generate is
[Polygon Density - 1]2.)

Four Boundary Lines

Surface Patch
(Polygon Density - 30)

Figure 4-8. Example of the Patch command
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Making Changes

Edit Menu and Tools

KeyCAD 3D features many powerful editing commands to help you make
objects exactly as you want them.  To make changes to an object, first
select the object(s) you want the changes applied to and then select one of
the editing commands from the tool bar or menu.

Figure 5-1.  Editing tools
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Editing Command Description

Undo Reverses last action.
Redo Restores last action.
Cut Moves the selected objects to the clipboard file.
Copy Copies the selected objects to the clipboard

file.
Paste Pastes objects from the clipboard file into the

drawing.
Copy To Copies the selected objects to the specified

file.
Paste From Pastes objects from the specified file into the

drawing.
Delete Deletes the selected objects.
Slice Slices the selected objects along a cutting

plane, optionally deleting either side.  Also
useful for making cross sections.

Make Group Combines one or more objects into a group for
easy selection.

Break Group Breaks selected groups into their associated
objects.

Join Points Joins points of the selected objects and moves
them to the specified location.  Used when
several points must connect but do not due to
inaccurate entry.

Move Points Moves points of the selected objects to a new
location.

Rotate/Move/Scale Rotates, scales, and/or moves selected objects
using the Virtual Trackball.

Fillet Rounds off the corner of two connected lines.
Chamfer Cuts off the corner of two connected lines with

a straight line.
Break Lines Breaks a single line into multiple segments.

Also breaks polygons into multiple single-line
segments.

Combine Lines Combines multiple connected lines into a
single line.

Convert Polygon to Line Converts a polygon into a single line.
Convert Line to Polygon Converts a single line into a polygon.
Edit Text Changes the selected text.
Convert Fixed Text to Lines Converts selected text into lines that can be

individually edited.
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Undoing and Redoing Changes
Menu: Edit|Undo

Menu: Edit|Redo

To undo the last change you made, either to the model or to the drawing
options, select the Undo command.  If you want to redo the changes, select
the Redo command.  You can continue undoing and redoing changes as
desired.

KeyCAD 3D's Undo command takes a snapshot of the entire drawing and
all drawing options after each command.  This lets you undo changes to
both drawing options as well as the drawing itself.  However, this method
does have its drawbacks.  If the combined memory space of the drawing
and options exceeds 64K bytes of memory, then KeyCAD 3D writes the
undo information to a disk file.  If you are working on a large drawing,
your system is low on memory, or your computer has a slow (or frag-
mented) hard disk, then you may want to disable Undo support.

You can specify the number of Undo levels you want KeyCAD 3D to
support with the Preferences command from the File menu.  The maxi-
mum number of levels allowed is 10.  You can enter 0 to disable Undo
support, in which case you should save your drawing before making any
major changes.  You cannot undo changes made prior to changing the
number of undo levels.

If you make any changes after selecting Undo, then the changes you made
cannot be redone.  For example, if you draw a polygon, select Undo to
remove it, and then draw a box, you will not be able to redo the polygon.

Cutting, Copying,
and Pasting Objects
Menu: Edit|Cut Hotkey: <Shift>+<X>

Menu: Edit|Copy Hotkey: <Ctrl>+<C>

Menu: Edit|Paste Hotkey: <Ctrl>+<V>

Menu: Edit|Copy To

Menu: Edit|Paste From

These commands let you copy portions of your drawing to a disk file for
later use.  They are useful in setting up libraries of symbols (objects).
They are also useful because they let you quickly and easily rotate, scale,
and move one or more selected objects around in the drawing.
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The Cut command copies the selected objects to the disk file
“_clipbrd.mdl” and deletes the objects from the drawing.

The Copy command also copies the selected objects to the disk file
“_clipbrd.mdl” but leaves the objects in the drawing.

The Copy To  command is similar to the Copy command except that you
can specify which file you want the objects copied to.

The Paste command copies objects in the disk file “_clipbrd.mdl” into
the drawing.

The Paste From command is similar to the Paste command except that
you can specify the file you want the objects pasted from.

Each of these commands prompts you to enter one or more reference
points.  The first point specifies the location of the object.  The second
point specifies the relative size and orientation of the object.  The third
point, along with the first two, specifies a reference plane.  When you use
the Paste or Paste From commands, KeyCAD 3D uses these reference
points to automatically scale, rotate, and position the object being pasted
so that the reference points are aligned.  Using the example from Chapter
1, suppose you have drawn the following chair and have copied it with the
indicated reference points.

Figure 5-2. Using reference points
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• Reference point #1 specifies the chair's location in the XYZ
coordinate system.

• Reference point #2 specifies the size of the chair as the distance
between point 1 and point 2.

• Reference point #3 specifies, along with points 1 and 2,  a
reference plane (flat surface) on which the chair is aligned.  In this
case the reference plane is the floor.

When you later paste the chair into your drawing, KeyCAD 3D prompts
you to enter up to three reference points.  If you enter just one point, then
the object will be positioned so that reference point 1 is aligned with the
point you enter.  If you enter two points, then the object will be rotated,
scaled, and positioned so that reference points 1 and 2 are aligned with the
points you enter.  To make sure the object is aligned with the desired
plane, you can enter a third point anywhere on the plane.

Now let’s add a table to the drawing and paste four copies of the chair
around it.  Notice where the reference points are placed and how they
control the position and orientation of each chair.

Figure 5-3. Copying and pasting objects

Here’s the same drawing after you shade it:
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Figure 5-4. Figure 5-3 after shading has been applied

The Cut, Copy, Copy To, Paste, and Paste From commands work with
standard KeyCAD 3D model files (with the “.mdl” extension).  When you
use the Copy To command, for example, KeyCAD 3D writes the selected
objects to a model file just as if you were to save them using the File Save
command.  In other words, KeyCAD 3D doesn't have two different file
formats, one for clipboard objects and one for drawings -- the two are
exactly the same.  In fact, objects saved using the Copy To command can
be loaded using the Open File command just like any other drawing.
Since the drawing options are also saved, the drawing options would also
be loaded.  (When you use the Merge, Paste or Paste From commands,
however, the drawing options in the file are ignored.)

These commands do not use Windows' clipboard facility to store objects.
To write objects to the Windows clipboard, select the Print command and
specify the clipboard as the destination.  KeyCAD 3D will then write
whatever is in the specified viewport to the Windows clipboard as a
Windows Meta File (WMF).  The drawing can then be pasted into any
other Windows program that supports metafiles, such as Microsoft Word.
(All 3-dimensional drawings in this document were produced in this
manner.)
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IMPORTANT:  When you paste an object, KeyCAD 3D ignores any
reference points that were not originally entered.  That is, if you do
not specify any reference points when you cut, copy, or save the
object then any reference points you set when subsequently loading
or pasting the object will be ignored.  Likewise, if you only set one
reference point when saving the object then only one reference
point will be used when you later load the drawing, and so forth.

Deleting Objects
Menu: Edit|Delete Hotkey: <Del>

The Delete command removes the selected objects from the drawing and
frees up all associated memory.

To use the Delete command:

1. Select the object(s) to delete.

2. Select the Delete command.

Slicing Objects
Menu: Edit|Slice

Points 1 - 3: Cutting plane (3rd point optional)
Point 4: Side of cutting plane to delete (optional)

The Slice command lets you slice through one or more objects with a
cutting plane.  You can think of the cutting plane as a knife you align with
a flat surface that only cuts the selected objects.  If desired, you can
specify that you want one side of the cutting plane to be deleted.  This is
useful for making a cross section of your drawing.

To use the Slice command:

1. Select one or more objects to slice.

2. Select the Slice command.

3. Set two or three points to define the cutting plane.

4. If you entered three points in the previous step, you can also set a
fourth point on the side of the plane you want erased.  If you do not
set a fourth point (or only set two points in the previous step), then
neither side will be erased.

5. Press <Enter>.  The selected objects will then be sliced.
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This command prompts you to set two or three points to define the cutting
plane.  If you only enter two points then KeyCAD 3D orients the cutting
plane in the +/- Z direction.  In other words, if you have the viewing
angles set to zero, then the cutting plane will extend in front and behind
you.  (This is the same as setting two points and then setting the third point
directly in front or back of either point.)

The following diagram shows a star that has been sliced in half.  (We
moved the top half up a bit so you can see where it was cut.)  The viewing
angles were set to zero and the cutting plane was specified using only two
points.

Original Object After Slice Command

Figure 5-5. Example of the Slice command where two points are specified

The following diagram shows a 3-dimensional example of the Slice
command where all four points have been specified:



Making Changes   5-9

Figure 5-6. Example of the Slice command where 4 points are specified

KeyCAD 3D converts curves into lines when they are cut by this com-
mand.  Therefore, you will not be able to change the shape of a curve
(without redrawing it) after it is sliced.

NOTE:  Fixed text must first be converted to lines before it will be
affected by this command.  (It's okay to have text selected while
using the Slice command, but the text won't be sliced.)  See
“Converting Text to Lines” on page 155.
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Making and Breaking Groups
Menu: Edit|Make Group Hotkey: <m>

Menu: Edit|Break Group Hotkey: <b>

KeyCAD 3D lets you group multiple objects together and manipulate
them as a single object.  This powerful feature lets you take a collection of
objects and combine them into a single object that you can easily select
and modify.

To group multiple objects into a single group:

1. Select objects to be grouped.

2. Select the Make Group command.

To break a group into multiple objects:

1. Select groups to be ungrouped.

2. Select the Break Group command.

The Break Group command only breaks top-level groups.  To continue
breaking groups when more than one level is present, just continue
selecting Break Group (since all ungrouped objects are automatically
selected).

Many of KeyCAD 3D's commands automatically group objects.  For
example, the Sphere command builds a sphere out of polygons and then
groups the result.  You can ungroup these objects using the Break Group
command just like any other object, letting you manipulate each individual
polygon or line.  The following chart lists each KeyCAD 3D command
that automatically groups objects:
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Command Description
Slice Groups objects on each side of the cutting

plane.  If a side is erased then only one side is
grouped.

Break Lines Breaks groups of all selected objects.
Convert Polygon to Line Breaks groups of all selected objects.
Convert Line to Polygon Breaks groups of all selected objects.
Box, Cone, Cylinder,
Sphere, Hemisphere,
Surface Patch, Extrude,
Sweep, Spiral, Solid Add,
Solid Subtract, Solid
Intersection Builds object out of polygons and groups the

result.
Linear/Circular Repeat Copies objects and groups the result.  If the

original objects are themselves part of a group,
then those groups are preserved.

Joining Points
Menu: Edit|Join Points

Point 1: First corner of boundary box
Point 2: Opposite corner of boundary box
Point 3: Destination

You use this command to move multiple points to a single location.  This
command is useful when points that must connect do not because of an
entry or rounding error (or errors caused when converting corners to
fillets).  Just because points appear to connect on the screen does not
guarantee they actually share the same coordinates in the drawing.  While
this may look okay initially, it could cause gaps to appear when you shade
or print the drawing.

Also, several KeyCAD 3D commands require that certain points are
connected.  For example, all four lines used with the Surface Patch
command must connect at their endpoints.  If for some reason they do not,
you could use the Join Points command to make them connect.

This command prompts you for three points.  The first two points define a
boundary box around the points you want joined.  The third point specifies
where you want the points to be joined.  Only the points of the selected
objects that fall inside the boundary box will be moved.  In other words, it



5-12 KeyCAD 3D

is okay for the points of unselected objects to fall inside the boundary box
since they will be ignored.

To use the Join Points command:

1. Select the objects containing the points you want to join.

2. Select the Join Points command.

3. Set two points to define a 3D boundary box around the points you
want joined.

4. Set a point for the destination.

5. Press <Enter>.  KeyCAD 3D will then move all points that are
within the boundary box to the destination point.

Figure 5-7. Example of the Join Points command
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Moving Points
Menu: Edit|Move Points

Point 1: Point(s) to move
Point 2: Destination

You use this command to move one or more points from one place in the
drawing to another.  This lets you quickly and easily make minor changes
to an object without redrawing it.  For example, you can adjust the shape
of a curve by moving one or more of its control points.  Likewise, you can
change the orientation, size, and plane of fixed text simply by adjusting its
control points.  This command works equally well with lines and poly-
gons.  (See “Setting Points” on page 65 for more information about where
control points are located for each type of object.)

This command prompts you for two points.  You set the first point on the
point(s) to move.  You then set a second point at the location where you
want the points to be moved.  Only the points belonging to the selected
objects will be moved.

The first point must be set precisely on the point(s) to move.  You might
want to use the Closest Point command to make sure.

NOTE:  If the points you want to move aren't at the same location,

use the Join Points command to move them to the same location
before using this command.

To use the Move Points command:

1. Select the objects containing the points you want to move.

2. Select the Move Points command.

3. Set a point directly on the point(s) to move.  (Use the Closest Point
command to make sure.)

4. Set a point at the location where you want the points to be moved.

5. Press <Enter>.  KeyCAD 3D will then move the selected points to
the new location.
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Point 1 - Point  to Move

Point 2 - Destination

Original Object After Move Points Command

Figure 5-8. Example of the Move Points command

Rotating, Moving, and Scaling Objects
Menu: Edit|Rotate/Move/Scale

Point 1: Reference point
Point 2: Axis of rotation (optional)

This command lets you rotate, move, and/or scale the selected objects
either by entering the desired values or interactively using a Virtual
Trackball.  When you select this command, you'll be asked to set up to two
points.  These points have slightly different meanings, depending on
whether you want to rotate, move, or scale.  When rotating, the first and
second point define the axis of rotation, an imaginary line around which
the selected objects are rotated.  When moving, the first point serves as a
reference point to help you move the object to the desired coordinates.
When scaling, the first point serves as an anchor point and determines
which direction the object is scaled.

The Virtual Trackball lets you interactively rotate, scale, and/or move the
selected objects quickly and easily.  To use it, position the cursor over the
center of the ball and press and hold the left mouse button.  Then drag the
mouse in any direction, watching the object on the screen as well as the
numbers in the dialog box.  If you reach the edge of the screen, release the
mouse button and repeat the process.  When the object has been rotated,
moved, and/or scaled appropriately, press OK.  You are never required to
use the trackball; you can simply enter the desired values directly into the
appropriate fields in the dialog box.
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Figure 5-9. Rotate/Move/Scale dialog box with the Virtual Trackball

Dialog Box Fields

Rotate  Select this option to rotate the object.

Move  Select this option to move the object.

Scale  Select this option to scale the object.

Rotation angle  This field contains the rotation angle, in degrees.

Boundary box  Select this option to surround the object with a 3D
boundary box.  The sides of the box are labeled for use as a reference:

Label Meaning Direction
F Front -Z axis
B Back +Z axis
L Left -X axis
R Right +X axis
T Top +Y axis
(blank) Bottom -Y axis

For simpler objects, you can deselect this option to display a rubber-band
image of the object.  For more complicated objects, the rubber-band image
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will not be available due to the excessive screen-redraw time that would be
required.

Axes  Select the axes you want to scale and/or move about.  (These
options aren't used when rotating.)

X, Y, Z  When rotating and moving, these fields contain the coordinates of
the reference point (point #1).  When scaling, these fields contain the scale
factor, which is initially 1.0.

Rotating Objects

To rotate objects:

Select the object(s) you want to rotate.

Select Rotate/Move/Scale from the Edit menu.

Set one or two points for the axis of rotation.  If you only set one point
then the Z axis is used as the axis of rotation.

Press <Enter>.  KeyCAD 3D then displays the Rotate/Move/Scale
dialog box.

Select the Rotate option.

If you know the exact rotation angle, enter it in the Rotation Angle field
and press OK.  Otherwise, use the trackball to interactively rotate
the object around the axis of rotation.

Press OK.

You can think of the axis of rotation as a line that extents infinitely in each
direction.  The two points you set can be anywhere on this line.  While the
location of points and the distance between them are not important, the
order in which you set them is.  Visualize yourself looking down the axis
of rotation, with your eye positioned at the first point you enter and
looking toward the second point.  A positive rotation angle will then rotate
the object counter-clockwise around the axis; a negative rotation angle will
rotate the object clockwise.
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Figure 5-10. Point of view as you look down the axis of rotation

The distance between the object and the axis of rotation is also important.
The further the object is from the axis of rotation, the further it will move
when rotated.  In other words, the object is rotated around the axis of
rotation as if it was connected to it by a string.  The length of the string,
and therefore the distance between the object and axis of rotation, remains
the same.

TIP:  If you just want to look at your drawing from different angles,

just change the viewing angles instead of using the Rotate/Move/
Scale command.  The Rotate command changes the objects in your
drawing, while changing the viewing angles does not -- it merely
changes your view of the object.  See “Changing Viewpoints” on
page 165 for more information.

TIP:  Consider using the Set Working Plane command to rotate

objects temporarily to the XY plane.  That way you can work on your
drawing and then use the Reset Working Plane command when
done.  For example, if you wanted to lay out dinnerware on a table
top, you could rotate the table surface toward you, lay out the
dinnerware, and then rotate everything back.  Or, you could use the
Set Working Plane command to rotate the table top toward you, lay
out the dinnerware, and then use the Reset Working Plane com-
mand to rotate everything back.  The advantage is that the Set/
Reset Working Plane commands calculate the exact rotation angles
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for you.

Figure 5-11. Example of the Rotate command

Scaling Objects

Scaling lets you shrink or expand the size of objects along the X, Y, and/or
Z axis.  This is very useful because it lets you modify the size of an object
without redrawing it.  It also lets you take stock objects such as spheres
and cylinders and deform them to make shapes that would otherwise be
difficult to draw.  For example, you can take a sphere and compress it into
a tire; turn a cylinder into a helicopter blade, or take a hemisphere and
expand it into the nose cone for a rocket.  The only limit is your imagina-
tion!

To scale objects:

Select the object(s) you want to scale.

Select the Rotate/Move/Scale command.

Set a point to scale about.

Press <Enter>.  KeyCAD 3D then displays the Rotate/Move/Scale
dialog box.
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Select the Scale option.

If you know the exact scaling factors, enter those and press OK.
Otherwise, select which axes you want to scale about (X, Y, and/or
Z).

Using the trackball, adjust the scaling factors as desired.  Rolling the
ball left and right adjusts the X scale factor.  Rolling the ball up
and down adjusts the Y scale factor.  Rolling the ball up and down
while holding down the <Ctrl> key adjusts the Z scale factor.  To
expand the object along an axis, use a scale factor of greater than
1.0.  To shrink the object along an axis, use a scale factor of less
than 1.0 (but greater than 0).  To maintain the current size of the
object along an axis, use a scale factor of 1.0.

When the object is the desired size, press OK.

The point to scale about is very important because it controls the direction
of scaling for each axis (X, Y, and Z).  You can think of this point as an
anchor point; that is, a point that won't move during scaling.  For example,
if you double the size of a square (by setting the scale factors to 2.0) and
set a point in the middle of the square, then each corner of the square will
grow outward.  However, if you scale the square using the same scale
factors but set a point on the lower left-hand corner of the square, then the
square will grow upward and to the right.
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Figure 5-12.  Example of scaling about different points



Making Changes   5-21

Figure 5-13.  Example of the Scale command

Moving Objects

To move objects:

Select the object(s) you want to move.

Select the Rotate/Move/Scale command.

Set a point to use as a reference.  That is, if there is a point on the object
that you know needs to be moved to some specific coordinates, set
a point there.  Otherwise, set a point anywhere near or on the
object.

Press <Enter>.  KeyCAD 3D then displays the Rotate/Move/Scale
dialog box.

Select the Move option.
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If you know exactly where you want to move the object to, enter the
coordinates and press OK.

Using the trackball, adjust the X, Y, and/or Z coordinates as required to
move the object to the desired location.  Rolling the ball left and
right moves along the X axis.  Rolling the ball up and down moves
along the Y axis.  Rolling the ball up and down while holding
down the <Ctrl> key moves along the Z axis.  To move using the
keyboard, press and hold down the <Shift> key while moving.  To
move in the Z direction, press and hold down the <Ctrl> key (as
well as the <Shift> key) while moving.

Press OK.

You can also move the selected objects by simply dragging them with the
mouse.  See “Getting Started” on page 5 for more information.

Figure 5-14.  Blast off into the third dimension with KeyCAD 3D!
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Using Fillet to Round Corners
Menu: Edit|Fillet

Point 1: Corner of two joined lines

The Fillet command lets you round off the corner of any two lines that
meet at a common point.

To fillet a corner:

1. Select one of the following:

• One line with two or more segments (polyline)

• Two lines connected at a single point

• One polygon

2. Select the Fillet command.

3. Set a point on the corner you want rounded.  This point must be set
exactly on the point where the two lines are joined.  Or, in the case
of a polygon or polyline, you must set the point precisely on the
corner that you want rounded.  (The Closest Point command is
really useful in cases like this.)

4. Press <Enter>.  KeyCAD 3D will then prompt you for the radius
(described below).

5. Enter the radius and press OK.  KeyCAD 3D will then round off
the corner with an arc of the specified radius.

The radius you enter in Step 5 is the radius of an imaginary circle that
KeyCAD 3D will use to round off the corner and create the fillet.  In other
words, it's the size of the arc that will replace the corner, as shown on the
next page.
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Figure 5-15.  Example of the Fillet command

The fillet radius was set to 5 in the above diagram.  As you can see, the
radius determines how big of an arc KeyCAD 3D should use to replace the
corner.  So, if you were to draw a circle with a radius of 5 and then move it
so that its sides touch both lines, then you would see how much the corner
would be rounded.  However, unless you need a corner that is mathemati-
cally exact, you may find that determining the radius by trial and error is
the easiest approach.
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Figure 5-16.  Text rounded using the Fillet command

Using Chamfer to Cut off Corners
Menu: Edit|Chamfer

Point 1: Corner of two joined lines

The Chamfer command lets you cut off the corner of any two lines that
meet at a common point.  It is similar to the Fillet command except that it
replaces the corner with a straight line instead of an arc.

To chamfer a corner:

1. Select one of the following:

• One line with two or more segments (polyline)
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• Two lines connected at a single point

• One polygon

2. Select the Chamfer command.

3. Set a point on the corner you want to cut off.  This point must be
set exactly on the point where the two lines are joined.  Or, in the
case of a polygon or polyline, you must set the point precisely on
the corner that you want rounded.  (The Closest Point command is
really useful in cases like this.)

4. Press <Enter>.  KeyCAD 3D will then prompt you for the chamfer
radius (described below).

5. Enter the radius and press OK.  KeyCAD 3D will then cut off the
corner with a line.

The radius you enter in Step 5 is the radius of an imaginary circle that
KeyCAD 3D will use to cut off the corner.  The corner will be cut off
where the circle touches each line, as shown below:

Figure 5-17.  Example of the Chamfer command
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The chamfer radius was set to 5 in the above diagram.  If you were to draw
a circle with a radius of 5 and then move it so that its sides touch both
lines, then you would see how much the corner would be cut off.  How-
ever, unless you need a corner that is mathematically exact, you may find
that determining the radius by trial and error is the easiest approach.

Figure 5-18.  More examples of the Chamfer command

Breaking Lines and Polygons
Menu: Edit|Combine Lines

The Break Lines command breaks, or separates lines, curves, and
polygons into individual line segments.  This command is usually used in
conjunction with the Combine Lines command to add or remove lines
from an object.

To use the Break Lines command:

1. Select the objects containing the lines you want to break.

2. Select the Break Lines command.
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IMPORTANT:  Use this command with caution because it breaks
polygons into lines, and lines don't appear when shaded.  It will also
be difficult to convert the lines back into polygons if they share
common edges (since each edge will consist of two identical lines).
In addition, when you break curves into lines you can no longer
control the shape of the curve simply by moving the control points.

The Break Lines command is especially useful when building the four
boundary lines for a surface patch.  For example, suppose you want to use
a circle as one of the boundary lines.  However, a circle cannot be used as
a boundary line because it doesn't have unique start and end points.  To
work around this restriction, you could break the circle into lines, remove
a small portion of the line, and then combine the lines back into a (partial)
circle using the Combine Lines command.  This technique was used in the
following diagram.

Figure 5-19.  Using the Break Lines command to modify a circle
so it can be used with the Patch command
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Combining Multiple Lines into a
Single Line
Menu: Edit|Combine Lines

The Combine Lines command combines multiple line segments into a
single line with multiple segments, called a polyline.  This command is
often used in conjunction with the Break Lines command to add or remove
lines from an object.

To use the Combine Lines command:

1. Select the lines you want to combine.  The lines must all be
connected.

2. Select the Combine Lines command.  KeyCAD 3D will then
combine the lines into a single line with multiple segments.

This command is useful when you have multiple lines that you want to
convert into a polygon.  You first make sure the lines are connected to each
other and then combine them into a single line using the Combine Lines
command.  You then select the Convert Line into Polygon command to
convert the line into a polygon.  (The Combine Line into Polygon
command requires that the selected object is a single line.)

This command is also useful when working with surface patches because
it helps you to meet the four-line requirement.  You simply draw the
boundary lines using whatever tools you want without worrying about how
many lines you end up with.  Once you have drawn the boundary lines,
you can combine them into four separate lines (using the Combine Lines
command four separate times) and then use the Patch command.  The
following object was drawn in this manner:
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Figure 5-20.  Using the Combine Lines command to meet the four-line
restriction of surface patches

Converting Polygons into Lines
Menu: Edit|Convert Polygon to Line

This command converts each selected polygon into a line with multiple
segments (that is, a polyline). This command is useful when working with
the Extrude, Sweep, and Spiral commands because if you extrude, sweep,
or spiral a polygon, then the polygon will be copied to each end of the
resulting surface.  However, if you first convert the polygon into a line
then each end of the resulting surface will be open.

To convert a polygon into a line:

1. Select one or more polygons.  (It's okay to select non-polygons
since KeyCAD 3D will ignore them.)

2. Select the Convert Polygon to Line command.
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IMPORTANT:  Use this command with caution because it breaks
polygons into lines, and lines don't appear when shaded.

Figure 5-21.  Results of extruding with polygons (left) and lines (right)

Converting Lines into Polygons
Menu:  Edit|Convert Line to Polygon

This command converts each selected polyline into a polygon.  It is useful
when working with surfaces because lines are not shaded, while polygons
are.  This command only works with polylines -- that is, single lines with
multiple segments.  If needed, you can use the Combine Lines command
to combine multiple lines into a single line for use with this command.

To convert a line into a polygon:

1. Select one or more polylines.  (It's okay to select non-polylines
since KeyCAD 3D will ignore them.)

2. Select the Convert Line to Polygon command.
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NOTE:  Although not enforced by KeyCAD 3D, you should try to keep
your polygons as flat, or planar, as possible.  In other words, if you
placed the polygon on a flat surface, then all the edges would touch
the surface.  This is important because non-planar polygons may
not shade properly and could cause improper results when used
with the Closest Plane and Solid Modeling commands.

Copying Objects in a Straight Line
Menu: Edit|Linear Repeat

Point 1: Start point of reference axis
Point 2: End point of reference axis

This command lets you copy objects in a straight line.  This is useful
whenever you want to make evenly-spaced copies of an object, such as
steps, columns in a building, cars in a parking lot, windows in an airplane,
and so forth.  You can also specify a scale factor to evenly enlarge or
decrease the size of the copies.

This command prompts you to set two points on a line called the reference
axis.  The distance between these points determines the distance between
each copy.  The direction of these points (that is, the direction of the line
formed by the start and end points), determines the direction of the copies.

To copy objects in a straight line:

1. Select the object(s) you want to copy.

2. Select the Linear Repeat command.

3. Set a point at the start of the reference axis.

4. Set a point at the end of the reference axis.

5. Press <Enter>.  KeyCAD 3D will then prompt you for the number
of copies and a total scale factor.

6. Enter these values and press OK.  KeyCAD 3D will then make and
automatically group the copies.
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Figure 5-22.  Linear Repeat dialog box

Dialog Box Fields

Number of copies  Enter the number of copies of the selected objects
that you want to make.

Total scale factor  Enter the scale factor of the last copy.  KeyCAD 3D
evenly scales each copy up (or down) starting at 1.0 to the total scale
factor you enter here.  Enter a number greater than 1.0 if you want the
copies to progressively increase in size.  Enter a number less than 1.0 (but
not 0) if you want the copies to progressively decrease in size.  Enter 1.0 if
you want all the copies to be the same size as the original.
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Figure 5-23.  Example results of using the Linear Repeat command without scaling

Original Object

Reference Axis

1 2

Number of Copies -3
Total Scale Factor - 0.25

Result of Linear Repeat C ommand

Figure 5-24.  Example of the Linear Repeat command with scaling
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Copying Objects in a Circle
Menu: Edit|Circular Repeat

Point 1: Start point of Axis in Rotation
Point 2: End point of Axis in Rotation

This command lets you copy objects in a circle, helping you make objects
like gear teeth and helicopter blades.  You can specify a scale factor to
evenly enlarge or decrease the size of the copies.  You can also specify an
offset which causes the copies to move down the axis of rotation.  This
helps you quickly and easily make circular staircases and other objects
that would otherwise be difficult to draw.

This command prompts you to set two points for an axis of rotation.  (For
a description of what an axis of rotation is, see the section “Rotating
Objects” in this chapter.)  This command also prompts you to enter the
number of copies, total # of degrees, total offset, and total scale factor.
The “total” means that the value is distributed evenly amongst all the
copies.  If you specify a scale factor of 2.0, for example, then KeyCAD 3D
will scale each copy evenly starting with 1.0 and ending with 2.0.  For two
copies that would mean the scale factor for the first copy would be 1.5 and
the scale factor for the second copy would be 2.0.  For three copies, the
scale factor for the first copy would be 1.3333, 1.6666 for the second, and
2.0 for the third.

To copy objects in a circle:

1. Select the object(s) you want to copy.

2. Select the Circular Repeat command.

3. Set two points for the axis of rotation.

4. Press <Enter>.  KeyCAD 3D will then prompt you for the number
of copies, total # of degrees, total offset, and total scale factor
(described below).

5. Enter these values and press OK.  KeyCAD 3D will then make and
automatically group the copies.  (The original objects will not be
included in the group, however.)
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Figure 5-25.  Circular Repeat dialog box

Dialog Box Fields

Number of copies  Enter the number of copies of the selected objects
that you want to make.

Total # of degrees  Enter the # of degrees in which to rotate the copies.
KeyCAD 3D divides the number of copies by the total number of degrees
to determine how much each copy needs to be rotated.  The last copy is
always rotated by the total number of degrees.  If you specify a total offset
of other than 0, then you can enter more than 360 degrees to make more
than one revolution around the axis of rotation.

Total offset  This field specifies how far down the axis of rotation you
want the copies moved.  KeyCAD 3D divides the number of copies by the
total offset to determine how far to move each copy.  The total offset
determines the distance between the last copy and the original.  All other
copies are evenly spaced in-between.

Total scale factor  Enter the scale factor of the last copy.  KeyCAD 3D
evenly scales each copy up (or down) starting at 1.0 to the total scale
factor you enter here.  Enter a number greater than 1.0 if you want the
copies to progressively increase in size.  Enter a number less than 1.0 (but
not 0) if you want the copies to progressively decrease in size.  Enter 1.0 if
you want all the copies to be the same size as the original.
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Figure 5-26.  These gears were made using the Circular Repeat command
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6
Working with Color

Shade Menu

KeyCAD 3D gives you complete control over the wireframe and shaded
color of each object.  This is done using an innovative approach that lets
you specify a base color and a range of shades.  KeyCAD 3D uses the base
color when drawing the wireframe representation of an object.  During
shading, KeyCAD 3D selects the shade to use based on each polygon's
orientation to the light source.  The more the polygon faces the light
source, the brighter the surface will be.

KeyCAD 3D supports up to 256 simultaneous colors.  If your video
adapter is capable of supporting 256 colors or more, then most or all of the
colors will appear solid.  Otherwise, KeyCAD 3D uses dithering to
simulate the actual colors.  (A dithered color is a color displayed as a
patterned mixture of two colors.)  Dithered colors look somewhat grainy
compared to solid colors, but extend the range of colors that can be used.
Since lines cannot be dithered, KeyCAD 3D uses the closest solid color
when drawing the wireframe representation of each object.

Setting the Current Color
Menu: Shade|Edit Colors

Menu: Shade|Color Palette

KeyCAD 3D colors each object you draw using the current color.  The
current color appears in a small box at the bottom of the screen.
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Current Color

Figure 6-1.  Color box at the bottom of the screen

When you draw an object, the current color becomes the object's base
color.  KeyCAD 3D uses the base color (or the closest solid color if the
base color is dithered) whenever it draws a wireframe representation of the
object.  When you later shade the object, KeyCAD 3D uses the base color
to determine which range of shades to use, if any have been defined.

To make color selection easy, KeyCAD 3D provides a floating color
palette with all 256 colors.  (Floating means you can move it around by
dragging its caption bar.)  To hide or show the floating palette, select Color
Palette from the View menu.

Figure 6-2.  Floating color palette

To set the current color, simply click once on the desired color in the color
palette.  To edit a color, double click on it.  If you've hidden the color
palette, you can also set the current color by selecting Edit Colors from the
View menu.
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Changing Colors
Menu: Shade|Set Color

Setting the current color does not by itself change the color of any objects
in your drawing.  You must also use the Set Color command.

To change an object's color:

Set the current color using the floating palette or Edit Colors command.

Select the objects whose color you want to change.

Select the Set Color command from the View menu or press the
COLOR button on the tool bar.

Editing Colors and Shades
Menu: Shade|Edit Colors

KeyCAD 3D gives you complete control over each color and shade in your
drawing.  To edit these colors and shades, select the Edit Colors command
from the View menu.  You can also select this command by clicking once
on the color box at the bottom of the screen, or by double-clicking on any
color in the floating palette.  Once you do this the following dialog box
appears:
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Figure 6-3.  Dialog box to edit colors

Dialog Box Fields

OK  Press this button to exit the color editor and save any changes.

Cancel  Press this button if you want to cancel any changes.

Help  Press this button for on-line help.

Base Color  This box shows the currently selected color.  The currently
selected color is also surrounded by a black rectangle.

Shades  This box shows the range of shades that are defined for the base
color currently selected.  If there are no shades defined, then this box will
be empty.

Red, Green, Blue  These sliders let you control how much of each
primary color to use in the base color.  You can also enter the exact amount
in the entry boxes to the right of the sliders.  These values range from 0 to
255, with 0 the darkest and 255 the brightest.

Save...  This button lets you save the palette to a disk file.

Load  This button lets you load a previously saved palette from a disk
file.
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Shade  This button lets you associate a range of shades with a base color.

Spread  This button lets you make a range of shades between two colors.

Each option is described in the following sections.

Editing Colors
You can change the red, green, and blue components of each color to make
it look the way you want.  All objects using the old color will be automati-
cally redrawn using the new one.  When you assign a color to an object,
you're really assigning a position in the color palette.  When KeyCAD 3D
draws the object, it uses whatever color is in the specified palette position.
For example, if the first color position in the palette contains green, then
all objects drawn using that palette position will appear green.  If you
change the color in that position to blue, then the objects will be subse-
quently drawn as blue.  Likewise, if you load a new palette from disk then
all objects will be drawn using the new palette.  This lets you make global
changes to any color without forcing you to re-select and change the color
of each object individually.

To edit a color:

1. Select the color you want to edit by clicking on one of the small
color boxes.  KeyCAD 3D will confirm your selection by drawing
a black rectangle around it.  The Base Color box will also be
updated with the selected color and any shades associated with it
will be drawn in the Shades box.

2. Change the red, green, and/or blue components of the color by
dragging the sliders or by entering a value in the adjacent entry
field.  KeyCAD 3D automatically updates the Base Colors box as
you edit the color.  (When changing the color components using an
entry field, the changes will not be updated until you move the
cursor out of the entry field.)

3. Repeat steps 1 and 2 for each color you want to edit.  When you
are satisfied with the changes, press OK.  To cancel the changes,
press Cancel.

TIP:  To quickly select the current color and edit it in one step, simply
double click on the desired color in the floating color palette.
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Setting Shades
KeyCAD 3D uses the object's base color when drawing a wireframe
representation of the object.  Additionally, you can associate a range of
shades with the base color for use during shading.  When KeyCAD 3D
shades each surface (polygon), it first checks if there are any shades
associated with the polygon's base color.  If there are, then KeyCAD 3D
calculates which shade to use based on the polygon's orientation to the
light source.  The more the polygon faces the light source, the brighter the
shade.  Likewise, the less the polygon faces the light source, the darker the
shade.  More concisely, the more the polygon faces the light source, the
higher the shading index will be.  When you associate shades with a base
color you usually select a range of colors that progressively increase in
brightness.  KeyCAD 3D will use the first color in the range when it
determines that little or no light from the light source is falling on the
polygon. Likewise, KeyCAD 3D will use the last color in the range when
it determines that the polygon is facing the light source directly.

To spread colors:

1. Position the cursor over the starting (darkest) color.

2. Press and hold the left mouse button.

3. Drag the cursor down to the ending (brightest) color.  KeyCAD 3D
will surround each color in the range with a black rectangle as you
drag the cursor.  (The starting color must appear before the ending
color.)

4. Release the left mouse button.

5. Press Spread.  KeyCAD 3D will then evenly spread the colors.

To set a range of shades:

1. Position the cursor over the first color in the range.

2. Press and hold the left mouse button.

3. Drag the cursor down to the ending color.  KeyCAD 3D will
surround each color in the range with a black rectangle as you drag
the cursor.  (The first color must appear before the last color.)

4. Release the left mouse button.

5. Press Shade.  KeyCAD 3D will then update the Shades box with
the range of shades you just selected.

If you no longer want shades to be associated with a particular base color,
you can remove the association:

1. Click on the base color that you no longer want any shades
associated with.



Working with Color   6-7

2. Press Shade.  KeyCAD 3D will then clear the Shades box,
indicating that there are no longer shades associated with the
selected base color.  When you subsequently shade surfaces using
this base color, the surfaces will always have the same color
regardless of their orientation to the light source.

The more colors in a range, the smoother the surface will appear when
shaded.  You can create some interesting effects by spreading two totally
different colors.  For example, try spreading from red to green and shade a
hemisphere with the result.  Have fun and experiment!

Saving and Loading Palettes
You can save and load color palettes for use in other drawings using the
Save and Load buttons.  KeyCAD 3D automatically saves the current color
palette along with the other drawing options when the drawing is cut,
copied, or saved.  These commands let you work with color palettes as
separate files.

To save the color palette:

1. Press Save.

2. Enter the name of a file you want to save the color palette to.

3. Press OK.

To load a color palette:

1. Press Load.

2. Enter the file name of the color palette you want to load.

3. Press OK.

When KeyCAD 3D starts, it loads the default palette from the file
“default.pcx”.  You can change the default palette simply by copying the
new one over “default.pcx”.  When KeyCAD 3D loads a drawing,
however, the default palette is replaced with the one from the drawing.

KeyCAD 3D saves color palettes in the PCX format, hence the “.pcx” file
name extension.  The PCX format is supported by nearly all popular
drawing programs as a means of storing pictures and color palette
information in a disk file.  This means you can load a color palette from
any other PCX file and use it in KeyCAD 3D.  (KeyCAD 3D supports
both 16 and 256 color formats.)  As another option, you could shade your
drawing using KeyCAD 3D, take a screen shot of the resulting image
(using any one of several popular screen capture programs), and save it as
a PCX file.  You could then use your favorite drawing program to enhance
the image, add a background, and so forth, all using the same color palette.
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Using Text

Text Menu

KeyCAD 3D lets you add text to your drawing at any location, in any size,
and at any orientation.  This lets you annotate your drawing, add numbers
to race cars, do special effects for use in presentations, and so forth.  You
can modify KeyCAD 3D's default font and even design your own.

Figure 7-1.  KeyCAD 3D’s default font
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Drawing Text
Menu: Text|Text

Menu: Text|Text (as lines)

When you select the Text command, KeyCAD 3D prompts you for one or
more points, called control points.  The first point determines where the
text will start.  The second point, which is optional, specifies the text size
and angle.  The third point (also optional) defines, along with the first two
points, the plane on which the text lies flat.

When you set two or three points, KeyCAD 3D scales and rotates the text
so that it fits exactly in-between the first two points.  This is important
when you know exactly how big you want the entire block of text to be.

KeyCAD 3D uses the default text size and angle whenever you set only
one point.  For example, if you want each character to be 100 units wide,
you would set the default text size to 100.  If you want the text to be
oriented straight up and down, you would set the default text angle to 90
degrees.  These defaults can be changed with the Options command and
only apply when you set one point.

You can only draw one line of text at a time.  To draw multiple lines, draw
each line separately and then move them to the desired position.

The following diagram shows text entered with one, two, and three points.

Figure 7-2.  Sample text drawn using the Text command
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When you add text, you have the choice of adding it as either text
primitives (called fixed text) or lines.  Fixed text uses a lot less memory
and disk space because only the characters representing the text are stored.
Only when KeyCAD 3D draws the fixed text does it convert it to lines
(using the current font).  Other advantages of fixed text include the
following:

• Fixed text can be edited, while text as lines cannot.

• Fixed text can be re-oriented by moving the control points, while
text as lines must be re-oriented using the Cut and Paste com-
mands.

• When you load a different font all fixed text will automatically use
the new font, while text as lines will not.

In other words, when you draw text as lines, the text becomes just that --
more lines in the drawing.  Fixed text, however, is a specially-supported
graphics primitive in KeyCAD 3D and is treated differently.

Fixed text has some disadvantages, however:

• Fixed text cannot be extruded, swept, spiraled, or sliced.

• The lines making up the fixed text cannot be edited directly.

• You cannot use the point snap or line snap commands to set a point
on the text itself.  (The points will snap to the control points
instead.)

• When you load a different font, all fixed text will automatically use
the new font.  This is listed as a disadvantage because you may not
want that to happen.

You can convert fixed text to lines any time you want to.  You cannot,
however, convert lines back into fixed text.

To draw fixed text:

1. Select the Text command from the Text menu or press the Text
button on the tool bar.

2. Set one, two, or three control points.

3. Press <Enter>.

4. KeyCAD 3D will then prompt you to enter the text.  Type up to
300 characters and press OK.  KeyCAD 3D will then draw the text
and automatically select it.
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To draw text as lines:

1. Select the Text (as lines) command from the Text menu.

2. Set one, two, or three control points.

3. Press <Enter>.

4. KeyCAD 3D will then prompt you to enter the text.  Type up to
300 characters and press OK.  KeyCAD 3D will then draw the text
as lines and automatically select it.

Editing Text
Menu: Text|Edit Text

This command lets you edit fixed text.  This command only works with
text primitives.  Text added as lines are just that, lines in the drawing, and
therefore cannot be edited as text using this command.

To edit fixed text:

1. Select the text that you want to edit.  (The word “Text” will appear
in the Selected box on the lower right-hand corner of the screen
when you select a text primitive.  If the text is part of a group then
you'll need to break the group and select just the text you want to
edit.)

2. Select the Edit Text command from the Text menu.

3. Using the keyboard arrow keys, position the cursor at the start of
the text you want to delete and press the Del key to delete each
character.  Then type in the new text.  To replace all the text,
simply start typing as soon as the dialog box appears.

4. Press OK.

KeyCAD 3D then replaces the old text with the new text using the current
control points.  If the new text has more characters than the old, then each
character in the new text will be smaller than the original.  Likewise, if the
new text has fewer characters than the old, then each character in the new
text will be larger than the original.  In other words, the new text is scaled
so that it continues to fit inside the control points you set when you
originally added the text.
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Converting Text to Lines
Menu: Text|Convert Fixed Text to Lines

You must convert fixed text to lines before using it with the Extrude,
Sweep, Spiral, or Slice commands.  When you convert fixed text to lines
you lose the ability to edit the text using the Edit Text command.  How-
ever, once you convert the text to lines you can manipulate the text using
all of KeyCAD 3D's editing commands.

This command replaces the selected text primitives with the line, curve,
and/or polygon primitives that were used when the text was originally
created.  (The text is not really limited to just lines.)  See “Customizing
Fonts” at the end of this chapter for more information.

To convert fixed text to lines:

1. Select the text you want to convert to lines.

2. Select the Convert Fixed Text to Lines command from the Text
menu.  KeyCAD 3D will then replace the text primitive with the
line, curve, and/or polygon primitives from the currently-loaded
font.

Setting Text Options
Menu: Text|Options

This command lets you set the default text size and angle.  These values
are only used when you draw text using only one point.  (When you draw
text using two or three points the scale factor and angle are calculated
automatically.)  The default size controls how big each character will be.
The size you enter is relative to the unit of measurement you're using in
the drawing.  For example, if you've decided that 1 unit represent one inch,
then a default size of 5 would make each character 5 inches wide (includ-
ing the small gap between characters).  The default angle is used whenever
you want the text to be rotated about the starting point.  For example, you
would specify an angle of 90 degrees to make the text extend straight up.

To set the default text size and angle:

1. Select Options from the Text menu.  The following dialog box will
then appear:
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Figure 7-3.  Text Options dialog box

2. Enter the default text size and angle.

3. Press OK.

NOTE:  Whenever you draw text using just one or two points,
KeyCAD 3D orients the text with the XY plane.  This is true
regardless of the current viewing angles.  Therefore, to avoid
confusion, we recommend that you place text using one or two
points with the main viewing angles set to 0.
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Figure 7-4.  Text at various sizes and angles

Customizing Fonts
You can modify the default font that comes with KeyCAD 3D and even
design your own.  A font in KeyCAD 3D is a standard model (.mdl) file
that you can edit like any other model.  The difference is that you place
each character in a different layer, where the layer number corresponds to
the character's ASCII code.  This lets you define fonts that have up to 255
characters.  When you design or modify a font file, you simply open the
file, enable the layer that corresponds to the character you want to work
on, and make the desired changes.  Each layer, and therefore each
character, can look any way you want and consists of polygons, lines,
curves, extruded or swept surfaces, surface patches -- anything except text
primitives themselves.

The following table shows each character’s corresponding ASCII codes:
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Character ASCII Character ASCII Character ASCII
Space 32 @ 64 a 97
! 33 A 65 b 98
` 34 B 66 c 99
# 35 C 67 d 100
$ 36 D 68 e 101
% 37 E 69 f 102
& 38 F 70 g 103
' 39 G 71 h 104
( 40 H 72 i 105
) 41 I 73 j 106
* 42 J 74 k 107
+ 43 K 75 l 108
' 44 L 76 m 109
- 45 M 77 n 110
. 46 N 78 o 111
/ 47 O 79 p 112
0 48 P 80 q 113
1 49 Q 81 r 114
2 50 R 82 s 115
3 51 S 83 t 116
4 52 T 84 u 117
5 53 U 85 v 118
6 54 V 86 w 119
7 55 W 87 x 120
8 56 X 88 y 121
9 57 Y 89 z 122
: 58 Z 90 { 123
; 59 [ 91 | 124
< 60 \ 92 } 125
= 61 ] 93 ~ 126
> 62 ^ 94
? 63 _ 95

Due to the way KeyCAD 3D calculates scaling factors, upper case
characters should be about 0.70 units wide and all other characters should
be about 0.55 units wide.  KeyCAD 3D automatically handles inter-
character spacing (the gap between characters) by adding 0.15 units after
each upper case character and 0.30 units after all other characters.  (The
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space is added to the X coordinate before the text is rotated.)  We
recommend that you use the following guidelines when modifying or
creating fonts:

• You should use the Set Drawing Units command to make the
entire screen about 3 units wide.

• You should disable the alternate viewports and leave the Z
coordinate at 0.

• For proper operation, the lower left corner of the text should be
located at the origin (0,0,0).

KeyCAD 3D's default font comes with a template in layer 0 that you can
use as a drawing aid.  This template shows you what size to make upper
case and other characters.  It also shows you where to place the descenders
used in lower case characters.  (The template is part of the drawing so
you'll have to be careful not to select it when making changes to the font.)

Descenders go here Lowercase
width (0.55,0,0)

width (0.7,0,0)
Uppercase

Origin (0,0,0)

Figure 7-5.  Using the template with upper case characters
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Origin (0,0,0)

Descenders go here

Uppercase
width (0.7,0,0)

Lowercase
width (0.55,0,0)

Figure 7-6.  Using the template with lower case characters

The easiest way to go about designing your own fonts is to start off by
loading the one included with KeyCAD 3D, “default.fnt”.  Once you've
loaded it (using the Open command from the File menu), you can use the
Save As command to save it as a new file.  This way the drawing units are
set up properly and you can use the template in layer 0 to get started.

You work on one character at a time by enabling the layer that corresponds
to the character's ASCII code.  For example, to work on the letter A you
would enable layer 65.  (See Chapter 9, “Organizing Your Drawing into
Layers,” for instructions on how to use layers.)  When you are done,
disable the layer you're working on before selecting a new one.  Otherwise
you'll see both characters on the screen at once.  Remember to set the
current layer number to the layer number of the character you're working
on, or the message “Current layer must always be active” will be dis-
played.

You can do some really neat things with custom fonts.  For example, you
could create a set of extruded characters that can be shaded, as shown
below:
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Figure 7-7.  Example of an extruded font

Loading Fonts
Menu: Text|Load Font

When you're ready to try out your new font, you'll need to load it using the
Load Font command from the Text menu.  This command prompts you for
the name of the file containing the font and then loads it into memory.  You
can have only one font loaded at a time -- the previous font, if any, will be
replaced by the new one.  When you load a new font, KeyCAD 3D will
regenerate your drawing and update the display.  All fixed text primitives
will be redrawn using the new font.  Any text you either converted to lines
or originally added as lines will remain the same.

During program start up, KeyCAD 3D attempts to load the font
“default.fnt”.  If the file cannot be loaded, then an error message will be
displayed and you will be prompted to enter the name of another font file,
if desired.  (If your system is low on memory and you don't want to use
fonts in your drawing, you can rename “default.fnt” to something else and
then press Cancel when prompted for a file name.)  If you want KeyCAD
3D to use your font as the default, first make a backup copy of
“default.fnt” and copy your file over it.  KeyCAD 3D will then use your
font the next time you run it.
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KeyCAD 3D saves the file name of the last font you loaded with your
drawing when you save it.  When you later load the drawing, KeyCAD 3D
will attempt to load the corresponding font file.  If it cannot find it, then an
error message will be displayed and you will be given the opportunity to
load a different font.

When KeyCAD 3D updates the display, any characters that are not defined
in the currently loaded font will be displayed as spaces.  If you do not have
a font loaded then KeyCAD 3D won't display any text, although the text
primitives themselves won't be affected (they'll just be invisible).  As soon
as you load a font, KeyCAD 3D will update the display and draw the text.

Dimensioning
Menu: Text|Dimension Line

Point 1: Start point
Point 2: End point
Point 3: Plane (optional)

KeyCAD 3D allows you to create dimension lines in your drawing that
indicate the size of objects or distances. KeyCAD 3D uses drawing units
to determine the numeric part of the dimension; see page 33 for informa-
tion on how to set the drawing units in your drawing.

To create a dimension line:

1. Choose the Dimension line command from the Text menu.

2. Set two points that define the distance the dimension line will
measure.

3. Set a third point to define a plane to place the line and text on, or
press Return to place the line and text in the current plane.

4. Set the Dimension Line options and press OK.

Dialog Box Options

Label  The text that will appear in the dimension line is display here. You
can edit this text to create custom labels, or to manually adjust the
measurement.

Measurement system  The measurement system selected here tells
KeyCAD 3D how to interpret the drawing units. As you change the
measurement system, the label text will change to reflect the new
interpretation.
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Line end options  Select one of these options to define how the end of
dimension lines will appear.

Precision  For most measurement systems, you can make a choice from
the Decimal Precision pop-up to set the number of decimals places of
accuracy you want represented in the numerical part of dimension.
KeyCAD 3D will automatically round the value to the selected number of
decimal places. As you change the precision, the label text will be updated.

For the Feet, Inches and Feet/inches measurement systems, you can also
choose to use a fractional representation of the measured value. In these
cases, select a value for denominator from the Fractional pop-up menu.
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8
Changing Viewpoints

View Menu

KeyCAD 3D gives you several different ways of changing how your
drawing appears on the screen without actually modifying the drawing
itself.

The Adjust Viewpoint commands let you set the viewing angles, zoom
factor, and focal point so you can look at your drawing from any point of
view.  The Virtual Trackball feature helps you to do this quickly and easily.

The Zoom command makes your drawing appear as large or as small as
you want.  You can zoom all viewports at once or each one individually.
This command also has an option to automatically zoom and pan the
drawing so it fits entirely within the specified viewport(s).

The Pan command moves your drawing across the screen so you can work
on different parts of it.  You can pan all viewports at once or each one
individually.

The Set Working Plane command temporarily rotates the drawing to align
a surface with the XY plane, making it easier to work on.

The Reset Working Plane command undoes the rotation caused by the Set
Working Plane command.
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Adjusting Viewpoints
Menu: View|Adjust Main View

Menu: View|Adjust Alt. View 1

Menu: View|Adjust Alt. View 2

This command gives you direct control over a viewport's viewing angles,
zoom factor, and focal point.  Use these commands whenever you want to:

• Look at your drawing from a different point of view.

• Set the zoom factor to make the drawing appear larger or smaller.

• Set the focal point to adjust the location of the drawing on the
screen.

To use these commands:

1. Select Adjust Main View from the View menu.  (Or, select Adjust
Alt. View 1 or 2 to adjust one of the alternate viewports.)  KeyCAD
3D then displays the Adjust Viewpoint dialog box and draws a
rotation box in the middle of the viewport.

2. Adjust the viewing angles, focal point, and/or zoom factor as
desired.

3. Press OK.

Figure 8-1.  Adjust Viewpoint dialog box with a Virtual Trackball
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Dialog Box Fields

Rotate  Select this option to use the trackball to adjust the viewing
angles.

Move  Select this option to use the trackball to move the focal point.

Horizontal  This field contains the horizontal viewing angle, in degrees.

Vertical  This field contains the vertical viewing angle, in degrees.

Zoom  This field contains the zoom factor.  Increasing the zoom factor
increases the apparent size of the drawing so you can make detailed
changed.  Decreasing the zoom factor decreases the apparent size of the
drawing.  The zoom factor must be greater than 0.

Fit box around model  Normally, changes to the focal point and zoom
factor do not affect the location or size of the rotation box.  When viewing
the entire drawing, however, select this option to fit the rotation box
around the drawing.  Changes to the focal point and zoom factor will then
be illustrated by the rotation box.

X, Y, Z  These fields contain the coordinates of the viewing position, or
focal point.  The focal point controls which part of the drawing is centered
in the viewport.

The rotation box helps you visualize changes to the viewing angles.  You
can also use it to help you visualize changes to the focal point and zoom
factor by selecting the “Fit box around model” option (as described
above).

Figure 8-2.  3D Rotation Box
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The sides of the rotation box are labeled for use as a reference:

Label Meaning Direction
F Front -Z axis
B Back +Z axis
L Left -X axis
R Right +X axis
T Top +Y axis
(blank) Bottom -Y axis

The Virtual Trackball lets you interactively adjust the viewing angles and/
or focal point quickly and easily.  To use it, position the cursor over the
center of the ball and press and hold the left mouse button.  Then drag the
mouse in any direction, watching the rotation box as well as the numbers
in the dialog box.  If you reach the edge of the screen, release the mouse
button and repeat the process (called rolling the ball).  When you are
through, press OK to update the viewport.

The horizontal and vertical angles control how the drawing is oriented in
the viewport.  You can enter the desired values directly or use the trackball.
To use the trackball, first select “Rotate”.  Then, roll the ball left or right to
adjust the horizontal angle; roll the ball up or down to adjust the vertical
angle.  To adjust the angles using the keyboard, hold down the <Shift> key
while pressing the cursor movement keys.

The focal point controls which part of the drawing is placed in the center
of the viewport.  You can enter the desired values directly or use the
trackball.  To use the trackball, first select “Move”.  Then, roll the ball left
or right to move along the X axis; roll the ball up and down to move along
the Y axis.  To move along the Z axis, roll the ball up and down while
holding down the <Ctrl> key.  To adjust the focal point using the key-
board, hold down the <Shift> key while pressing the cursor movement
keys.

To understand how to set the viewing angles, it helps if you imagine
yourself setting the object you're drawing on a transparent table.  When
you walk around to the right you increase the horizontal viewing angle.
When you walk around to the left, you decrease the horizontal viewing
angle.  When you lean over the object, you increase the vertical viewing
angle.  Likewise, when you bend down and look at the bottom of the
object, you decrease the vertical viewing angle.  See the following
diagram:
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Figure 8-3.  The viewing angles control which part of the object is viewed

Following is a drawing of a table and chair as seen from different
viewpoints:

Figure 8-4.  Front (horizontal angle=0, vertical angle=0)
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Figure 8-5.  Right (horizontal angle=90, vertical angle=0)

Figure 8-6.  Left (horizontal angle=-90, vertical angle=0)
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Figure 8-7.  Upper right (horizontal angle=30, vertical angle=30)

Figure 8-8.  Upper left (Horizontal angle=-30, vertical angle=30)
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Zooming In and Out
Menu: View|Zoom

Point 1: Point to zoom into (optional)

This command lets you make your drawing appear larger or smaller
without changing it.  You can magnify your drawing, making it easier to
make detailed changes.  You can also reduce the size of the drawing,
making it as small as you want.  This command also has an option to
automatically zoom and pan as required to fit the entire drawing in the
viewport.

This command prompts you for a point to zoom into.  This lets you
specify exactly which part of the drawing you want to zoom into or out of.
That is, the location of the drawing where you set the point will be
centered in the viewport after zooming.

To use the Zoom command:

1. Select Zoom from the View menu.

2. Set a point to zoom into.  This point is optional; if you do not set it
then KeyCAD 3D will zoom into the origin (0,0,0).

3. Press <Enter>.  The Zoom dialog box will appear (described
below)

4. Set the zoom options and press OK.  KeyCAD 3D will then
redisplay the drawing using the new options.
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Figure 8-9.  Zoom dialog box

Dialog Box Fields

Alternate View 1  Apply zoom to alternate viewport #1.

Alternate View 2  Apply zoom to alternate viewport #2.

Main View  Apply zoom to main viewport.

Return to origin  Reset viewpoint to (0,0,0) and zoom to 1.0 in the
selected viewports.

Fit model entirely within viewport  Pan and zoom as needed to fit the
drawing entirely within the selected viewports.

Zoom factor  Amount to zoom.  Use 2.0 to double current size, 0.5 to
decrease current size by 1/2, etc.  This value is not used when the “Return
to origin” or “Fit model entirely within viewport” options are specified.

Unless the “Return to origin” or “Fit model entirely within viewport”
options are set, this command performs a relative zoom.  In other words it
modifies, not replaces, the current zoom factor.  For example, if you
specify a zoom factor of 0.5, then the current zoom factor will be reduced
by one half.  Likewise, if you specify a zoom factor of 2.0, then the current
zoom factor will be doubled.  (You can set the current zoom factor using
one of the Adjust Viewport commands.)
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Below are some examples to help clarify the operation of the Zoom
command:

Figure 8-10.  Original size

Figure 8-11.  Zoom into origin (zoom factor = 2.0)
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Figure 8-12.  Zoom into period of exclamation mark (zoom factor = 5)

Figure 8-13.  Zoom with “Fit model entirely within viewport” option set
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Figure 8-14.  Zoom with “Return to origin” option set

Panning the Drawing
Menu: View|Pan

Point 1: Source
Point 2: Destination

This command lets you change your viewpoint in the X, Y, and/or Z
direction without modifying the drawing.  You can therefore draw objects
that are larger than the viewport and then move the viewport as necessary
to work on different parts of it.

This command prompts you for two points, one for the source and one for
the destination.  The Pan command will move the viewpoint in the
direction of the first point to the second.  The distance between the two
points determines the distance the viewpoint will be moved.

To use the Pan command:

1. Select the Pan command from the View menu.

2. Set a point at the source.

3. Set a point at the destination.
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4. Press <Enter>. KeyCAD 3D will then ask you which viewports
you want to pan:

Figure 8-15.  Pan dialog box prompts you for the viewports you want to Pan

Check each viewport you want the Pan command applied to and press OK.
KeyCAD 3D will then calculate the new viewing position and update the
display.

NOTE:  To return the viewpoint back to the origin, use the Zoom
command and check the “Return to origin” option.
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Figure 8-16.  Before Pan command

Figure 8-17.  After Pan command
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Setting the Working Plane
Menu: View|Set Working Plane

Points 1 - 3: Working Plane
Point 4: Side to View (optional)

Menu: Reset Working Plane

This command temporarily rotates your drawing so that the specified
surface is aligned with the XY plane, making it easier to work on.  To add
text to a flat surface, for example, you would use this command and set
three points anywhere on the surface.  KeyCAD 3D will then rotate the
surface to the XY plane, making it easy to add the text using just one or
two points.  When you are done, you can select the Reset Working Plane
to undo the rotation.

This command prompts for up to four points.  The first three points define
the plane.  These points do not actually have to lie on the surface you want
to work on.  The fourth point is optional and defines which side of the
plane you want to face the viewport.  KeyCAD 3D rotates and moves the
drawing so that the first point you set is at the center of the screen and the
second point is aligned with the X axis.  In other words, the points you set
not only determine how the drawing is rotated, but also where it is
positioned.

To set the working plane:

1. Select the Set Working Plane command from the View menu.

2. Set three points anywhere on the surface you want to work on.

3. Set a point on the side of the plane that you want to face the
viewport (optional).

4. Press <Enter>.  Your entire drawing will then be rotated so that the
surface is oriented with the XY plane.

To reset the working plane:

• Select the Reset Working Plane command from the View menu.
The rotation caused by the previous Set Working Plane command
will then be undone.  Any other changes, such as rotations done
using the Rotate command, moves, pans, etc. will not be undone.

You must select Reset Working Plane before using Set Working Plane a
second time.  That is, there can only be one active working plane at a time.

You do not have to reset the working plane before saving the drawing.
KeyCAD 3D saves the status of the working plane along with the drawing.
If you save the drawing while a working plane is active, then it will be
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active the next time you load it.  The following diagrams show how the Set
Working Plane command was used to add some extruded text and a star to
the side of a pyramid.

Figure 8-18.  Setting points for the Working Plane command

Figure 8-19.  Adding detail to the surface
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Figure 8-20.  Result after Reset Working Plane and Shade commands
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9
Organizing Your
Drawing into Layers

KeyCAD 3D lets you organize your drawing into layers.  A layer is simply
a portion of the drawing that can be temporarily disabled, or “hidden.”
Working in 3D can be confusing, especially when the drawing becomes
complicated.  Using layers, you can determine which parts of your
drawing you want to work on and disable all the rest.  This also reduces
processing time because KeyCAD 3D ignores disabled layers while
processing all commands (except saving and loading).

KeyCAD 3D supports up to 256 layers, each of which can be enabled or
disabled.  You can assign a name to each layer to help you remember what
it contains.

When you use the Save command, KeyCAD 3D saves the entire drawing,
even if one or more layers are disabled.  The layer information is also
saved.  When you load a drawing using the Open command, the layer
settings are restored to the way they were when the file was saved.
Therefore, you may not see all of the drawing because some layers may
have been disabled when the drawing was saved.

When you shade the drawing, only the enabled layers are shaded.  This
lets you quickly test light settings by shading a small portion of your
drawing.  Likewise, when you print the drawing, only the enabled layers
are printed.  To shade or print the entire drawing, you must first enable all
layers that are used.

When you use the Select All command, only objects in the enabled layers
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are selected.  If you want to use a command and have it affect the entire
drawing, you must first enable each layer that is used.  For example, to
rotate the entire drawing you would first enable all layers used by the
drawing, select all objects using the Select All command, rotate the
objects, and then disable the layers you don't want to work on.

At least one layer must be enabled at all times.  You must also specify that
a layer is the current layer.  All objects you draw are placed into the
current layer.  The current layer is displayed at the bottom of the screen:

Current Layer Number

Figure 9-1.  Status bar indicating current layer number

Changing Layer Settings
Menu: Change Layer Settings

This command lets you change the layer settings.  You can enable and
disable layers, change the current layer, and change the name of each
layer.  We recommend that you separate large drawings into layers because
it makes them easier to work on.  You can enable just the layers you want
to work on and disable the rest.

To change the layer settings:

1. Select Change Layer Settings from the View menu.  The Change
Layer Settings dialog box then appears, described on the next page.

2. Select the layer you want to change either by entering the layer
number in the Layer field or by using the scroll bars.  Valid layer
numbers are 0 through 255.

3. Change the layer settings as desired.

4. Continue selecting and changing layers as desired.  When done,
press OK.  If the current layer is not enabled then KeyCAD 3D
will display the message “Current layer must always be active.”
You will then need to either enable the layer or enter a different
one.
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Figure 9-2.  Dialog box for editing layers

Dialog Box Fields

Current Layer  This field contains the number of the current layer.  All
new objects drawn are placed into the current layer.  The Set Layer
command moves the selected objects into the current layer.  The current
layer must always be enabled.

Layer  Number of the layer currently being edited.

Name  Name of the layer currently being edited.  You can name each
layer to help you remember what you placed into it.  You can change the
name at any time.

Enable  Check this option to enable the layer.

Disable  Check this option to disable the layer.

Enable All  Press this button to enable all layers.

Disable All  Press this button to disable all layers.
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Moving an Object into the Current Layer
Menu: Set Layer

You can move objects from one layer to another at any time:

1. Select the Change Layer Settings command from the View menu.

2. Change the Current Layer field to the desired layer.  (Make sure
the layer is enabled or the “Current layer must always be enabled”
message will appear.)

3. Press OK.

4. Select the objects you want to move to the current layer.

5. Select the Set Layer command from the View menu.

NOTE:  You must enable all layers if you want a command to modify
the entire drawing.  This applies to moves, rotates, scales -- any
command you want applied to the entire drawing and not just to the
enabled layers.  Also remember that the Select All command only
selects the objects in the enabled layers.

Following is a drawing where each part is placed into a different layer.

Figure 9-3.  All layers enabled
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Figure 9-4.  Layer containing columns enabled

Figure 9-5.  Layer containing dome supports enabled
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Figure 9-6.  Shading with all layers enabled except those containing
the columns and dome supports
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Shading Surfaces

Shade Menu

The Shade command shades the surfaces (polygons) in your drawing with
light from up to 8 simulated light sources.  This process, called hidden
surface removal, calculates which polygons are visible based on the
current viewpoint and shades them accordingly.  Lines and curves,
however, cannot be shaded.

When KeyCAD 3D shades each polygon, it first checks if there are any
shades associated with the polygon's base color.  If there are, then
KeyCAD 3D calculates which shade to use based on the polygon's
orientation to the light sources.  The more the polygon faces the light
sources, the brighter the shade.  Likewise, the less the polygon faces the
light sources, the darker the shade.  More concisely, the more the polygon
faces the light sources, the higher the shading index will be.  When you
associate shades with a base color you usually select a range of colors that
progressively increase in brightness.  KeyCAD 3D will use the first color
in the range when it determines that little or no light is falling on the
polygon.  Likewise, KeyCAD 3D will use the last color in the range when
it determines that the polygon is facing one or more light sources directly.

For more information about colors and shading, see  “Working with
Color” on page 143.
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Shading Views
Menu: View|Shade All Views

Menu: View|Shade Main View

Menu: View|Shade Alt. View 1

Menu: View|Shade Alt. View 2

Menu: View|Shade Full Screen

These commands let you shade one or all viewports.  When you select one
of these commands, or when you print with the “Shaded” option enabled,
KeyCAD 3D shades the polygons using the following steps:

A Sort polygons.  This step sorts the polygons so they can be shaded
in the proper order.  This step is only performed once even when
all three viewports are being shaded.

B Calculate shades.  This step calculates the amount of light hitting
each polygon.

C Display background bitmap (full screen shading only).  The
background bitmap is defined in the Preferences dialog box.

D Shade polygons.  KeyCAD 3D draws each polygon in the proper
order and colors it with the calculated shade.

Step A requires a lot of complex operations and may therefore take a while
to complete.  Sorting the polygons in a complicated drawing may take
anywhere from a couple of minutes to an hour or more depending on the
size of the drawing and the speed of your computer.  (A math coprocessor
will speed things up considerably.)  KeyCAD 3D displays a status box
during this step so you can monitor its progress and cancel if desired:
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Figure 10-1.  This is the status box you see when you shade views

Dialog Box Fields

Sorted  Total number of polygons sorted so far.

Splits  Number of splits caused by the hidden surface algorithm.  (The
algorithm resolves ambiguities by dividing, or “splitting” polygons into
two or more pieces.)

Total  Total number of polygons produced during sorting.

IMPORTANT:  KeyCAD 3D does not automatically redraw the display

after shading.  This is done to give you the opportunity to view the
image and capture the screen if desired.  This can be confusing,
however, because lines are not shaded and therefore the screen
may appear to “blank out” if you do not have any polygons defined.
To redraw the display after shading, select the Select All command
followed by the Deselect All command.

Setting the Shading Quality
Menu:  View|Preferences

When KeyCAD 3D fills each polygon with color, it can either use its own
high-precision fill routine or the low-precision one included with Win-
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dows.  Windows' fill routine is faster but tends to produce gaps in the final
image.  This is not really a problem with Windows, but more of a side
effect of the hidden surface algorithm used by KeyCAD 3D.  (Windows
uses integers to represent polygon vertices while KeyCAD 3D uses
floating point.)

You can select which fill routine to use with the Preferences command
from the File menu:

Draft  When this option is set, KeyCAD 3D will use Windows' polygon
fill routine to fill each polygon.  Selecting this option will speed up
shading at the expense of quality.  The increase in speed is especially
noticeable when printing.

Final  Set this option when you want the shading quality to be as high as
possible.  (The quality, of course, will depend on the resolution and
number of colors supported by your display or printer.)  KeyCAD 3D will
then use its own high precision polygon fill routine to fill each polygon.
This process is slower, especially when printing, but produces a higher-
quality image.

NOTE:  KeyCAD 3D uses Draft mode when printing to the clipboard
or to a Windows Meta File.  This is required because graphics
applications that import data from the clipboard or metafile use
Windows' fill routine, not KeyCAD 3D'.  However, you can always
press the Print Screen key on your keyboard to write a copy of the
display to the clipboard as a bitmap, even when you shade the
image with the Final option set.

Changing the Light Settings
Menu:  View|Change Light Settings

You can aim up to 8 lights at your drawing for use during shading.  You
aim each light by specifying a horizontal and vertical viewing angle and
by setting the intensity (0-100).  You can also set the background, or
ambient, light to control the overall brightness of the shaded image.

To change the light settings:

1. Select Change Light Settings from the Shade menu.  The Edit
Lights dialog box then appears, described below.

2. Change the light settings as desired.

3. Press OK.
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Figure 10-2.  Edit Lights dialog box

Dialog Box Fields

On  Click on this box to toggle the corresponding light source on and off.

Horizontal  Horizontal angle of the light with respect to the viewport.

Vertical  Vertical angle of the light with respect to the viewport.

Intensity  This number determines how bright the light is.  Think of it as
a "dimmer" control for the light -- 0 is all the way off and 100 is all the
way on.  50 is half way in-between.

Background Light  This number controls the overall brightness of the
shaded image.  It controls how much light is used to shade polygons that
don't directly face one of the lights.  Enter a lower number for a darker
image or a higher number for a brighter one.  If you enter 0 then the
polygons will only be shaded using the light from the enabled light
sources.  If you enter 100 then each polygon will be shaded as brightly as
possible.  (More specifically, each polygon will be shaded using the last
shade in the range that is associated with the polygon's base color.)

You aim lights the same way you set the viewing angles.  The horizontal
angle determines the position of the light around the drawing.  The vertical
angle determines the angle of the light above and below the drawing.  To
understand how to set these angles, it helps if you imagine yourself setting
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the object you're shading on a transparent table and aiming a flashlight at
it.  When you walk around to the right you increase the horizontal viewing
angle.  When you walk around to the left you decrease the horizontal
viewing angle.  When you lean over the object, you increase the vertical
viewing angle.  Likewise, when you bend down and look at the bottom of
the object, you decrease the vertical viewing angle.

Figure 10-3.  Aiming light sources for shading

You can think of the light sources as being attached to each viewport.  For
example, if you define a forward-facing light (with the horizontal and
vertical angles set to 0), then whichever part of your drawing faces
forward will receive the most light.  In other words, the drawing is shaded
after it is rotated by the viewing angles, not before.

On the following pages are some examples of a sphere that was shaded
using different light settings:
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Figure 10-4.  Front (light #1: horiz=0, vert=0, intensity=100)

Figure 10-5.  Top (light #1: horiz=0, vert=90, intensity=100)
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Figure 10-6.  Upper right (light #1: horiz=30, vert=30, intensity=100)

Figure 10-7.  Upper right and lower left (light #1: horiz=30, vert=30, intensity=100;
light #2: horiz=-30, vert=-30, intensity=60)
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Using Solids

Solids Menu

KeyCAD 3D supports Constructive Solid Geometry (CSG) commands
Add (union), Subtract (difference), and Intersection.  These powerful
commands let you create complex objects by combining simpler objects
like cubes, spheres and cylinders.  The resulting solids can then be used to
construct even more complex objects.

The Solid Add command combines two solids.  The resulting solid will
consist of the original solid minus the part that resides in the area where
the two solids overlap.  This command is especially useful when working
with large drawings because it removes the background portion of objects
that will never be seen (and are therefore unnecessary).

The Solid Subtract command subtracts one solid from another.  For
example, you can punch a bolt hole through a bracket by subtracting a
cylinder from it.

The Solid Intersection command returns the solid that corresponds to the
intersection (overlapping area) of the two original solids.

A “solid” object is an object that is completely enclosed by polygons.
This means that there should not be any gaps in the surface.  It is up to you
to make sure the objects you select are valid solids.  If you use these
commands with invalid solids then the resulting object may be incorrect.
A solid should only consist of polygons -- any other primitives (text,
curves, and lines) are not used and will be deleted.

The Box, Cylinder, Cone, and Sphere commands automatically form valid
solids.  The Extrude, Sweep, and Spiral commands, however, do not
necessarily form valid solids.  For example, if you sweep a single line 360
degrees then the resulting object will not have a bottom or top.



11-2 KeyCAD 3D

Figure 11-1.  Objects A, B, and C are not valid solids; objects D, E, and F are

In the above figure, objects A, B, and C are examples of objects that are
not valid solids.  Object A is missing a front.  Object B has been sliced
using the Slice command and is therefore missing a top.  Object C is a
result of the Sweep command and is missing a bottom and top.

Objects D, E, and F are examples of valid solids.  Object D is a result of
the Box command.  Object E is an extruded ellipse.  (It's valid because the
Ellipse is a polygon.)  Object F is the result of the Sweep command.
Notice how the extra line at the bottom and top are used to form the
bottom and top of the object.

To use these commands, you first select exactly two groups, one for each
solid.  These objects should consist only of polygons—any other primi-
tives will be deleted from the resulting object.  In addition, the Solid
Subtract command lets you specify which solid you want to subtract.

During processing, KeyCAD 3D displays a status box and gives you the
opportunity to cancel.  You can also switch to other Windows programs
during this time (using ALT-ESC), but you'll notice that your system will
operate more slowly than before.  While it is not necessary that you
understand these status messages, it is helpful to know what they are so
you can better judge how far the operation has progressed.
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Figure 11-2.  Status box displayed during processing

Setting normals  The surface normals in the solid are being calculated
and set.

Determining boundaries  The boundaries of each solid are being
calculated and stored.

Classifying polygons  Each polygon is being classified as to whether it
is inside, outside, or on the boundary of the other solid.

Combining polygons  Polygons that were split are now being recom-
bined.

The last step reduces the number of polygons in the resulting solid.  While
most polygons can be recombined, some cannot.  This means that the
resulting object may appear to have one or more “out of place” lines.
These only affect the wireframe representation of the object and do not
affect shading.

NOTE:  Solid Modeling uses some very complex mathematics and
can be time consuming, especially on slower systems.  You'll find
that a math coprocessor will speed things up considerably.
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Solid Add
Menu: Solids|Solid Add

This command adds together two solids.  The resulting solid consists of
the original solids minus the part that resides in the overlapping area
(shared volume).  While the shaded result will look the same, this
command is especially useful when working with large drawings because
unnecessary objects are deleted.

This command requires that you select exactly two groups, one for each
solid.  Each solid must be valid or the resulting object will be incorrect.
See the beginning of this chapter for more information.

To use the Solid Add command:

1. Select exactly two groups.

2. Select the Solid Add command.  KeyCAD 3D will then process the
solids.

Figure 11-3.  Example of the Solid Add command
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Solid Subtract
Menu: Solids|Solid Subtract

This command subtracts one solid from another.  Select the solid you want
to subtract by setting a point on it.  You can think of the solid being
subtracted as a “drill,” where any part of it that overlaps the other solid
will be removed.  For example, you could use this command to subtract a
cylinder from a bracket, making a hole.

Select exactly two groups, one for each solid.  Each solid must be valid or
the resulting object will be incorrect.  See the beginning of this chapter for
more information.

To use the Solid Subtract command:

1. Select exactly two groups.

2. Select the Solid Subtract command.

3. Set a point on the solid you want to subtract.  This point must be
unique to the solid being subtracted (it shouldn't be shared by both
solids).  Use the Closest Point command to make sure the point is
set exactly.

4. Press <Enter>.  KeyCAD 3D will then process the solids.

Figure 11-4.  Example of the Solid Subtract command



11-6 KeyCAD 3D

Solid Intersection
Menu: Solids|Solid Intersection

This command returns a solid which is the intersection of two solids.  That
is, the resulting solid consists of the portion of the original solids that
overlap.  You can make some pretty interesting things with this command.

This command is also useful in determining if two solids overlap.  If they
do, then the resulting solid will show you where.  (Be sure to save your
drawing first because the original solids will be deleted.)

You must select exactly two groups, one for each solid.  Each solid must
be valid or the resulting object will be incorrect.  See the beginning of this
chapter for more information.

To use the Solid Intersection command:

1. Select exactly two groups.

2. Select the Solid Intersection command. and the intersection will be
processed.

Figure 11-5.  Example of the Solid Intersection command
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Figure 11-6.  This part was made using the Solid Subtract
and Solid Add commands
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12
Generating
Animations

The animation features in KeyCAD 3D bring your drawings to life!  Using
the powerful concept of key frames, you specify the exact viewing angle,
zoom factor, and focal point at key points in the animation.  Using this
information, KeyCAD 3D automatically draws each frame in the anima-
tion and saves the resulting bitmaps to disk.  You can then play these
animations using the Run Animation command.  These features are fully
integrated into KeyCAD 3D, so you can create and animate your drawings
all from the same program.

Generating an animation consists of the following steps:

• Save two or more key frames

• Edit the key frames

• Generate the animation

• Run the animation

Each of these steps are described below.  Also see “Animating the Office
Chair” on page 56 for a tutorial on how use KeyCAD 3D’s animation
features.
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Saving Key Frames
Menu: File|Animation|Save Key Frame

KeyCAD 3D uses two or more key frames to control the animation
sequence.  A frame is a single frame, or picture, in the animation.  Key
frames are where you specify the viewing parameters (viewing angle,
zoom factor, and focal point) at key points in the animation.  KeyCAD 3D
automatically calculates the viewing parameters for each intermediate
frame, making animations much easier to create.

To save a key frame:

1. Select the Save Key Frame command from the File|Animation
menu.

2. Set a point for the focal point and press ENTER.  When generating
the animation, KeyCAD 3D places this point of the drawing in the
center of the screen and uses it as the origin for all rotations and
zooms.  If you want to use the center of the screen as it currently
appears in the main view, just press <Enter> without setting a
point.

3. Unless you’re saving the very first key frame, the following dialog
box appears:

Figure 12-1.  Save Key Frame dialog box

Select “Calculate change in viewpoint” if you want the animation to
smoothly change from the previous key frame to the key frame being
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saved.  If you select this option, you also need to enter how many
intermediate frames you want KeyCAD 3D to use to make the transition.
Specifying more frames will make the transition smoother, but will also
take longer to generate and use up more disk space.

Select “Reset to current viewpoint” if you want KeyCAD 3D to reset the
viewpoint without regard to the last key frame.  This is necessary, for
example, if you are walking around a building and want to quickly switch
to an aerial view.  When you select this option the “Number of intermedi-
ate frames” field is ignored.

When saving the first key frame (#0), the above dialog box does not
appear and the “Reset to current viewpoint” option is automatically
selected.

4. Press OK.  You can save a maximum of 100 key frames (numbered
0-99).

You can edit all of the parameters associated with each key frame using
the Edit Key Frames option, described below.

Editing Key Frames
Menu: File|Animation|Edit Key Frames

KeyCAD 3D gives you complete control over the key frames that you
save.  You are not limited to just the key frames you save using the Save
Key Frame command.  The Edit Key Frames command gives you direct
control over each key frame parameter so you can fine tune the animation
sequence.  You can add key frames, delete key frames, and even save your
key frames to disk.

To edit key frames:

1. Select Edit Key Frames from the File|Animation menu.

2. Edit key frames.

3. Press OK to save the changes.  Or, press CANCEL to cancel any
changes you may have made.
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Figure 12-2.  Edit Key Frame dialog box

Dialog Box Fields

Key Frame No.  This field contains the number of the key frame that
you’re currently editing.  To edit a particular key frame, enter the number
here or select it from the list box.  (As with all entry fields, you need to
press TAB or click in another entry field before the entry will be recog-
nized.)

Number of intermediate frames  This field contains the number of
intermediate frames that you want KeyCAD 3D to generate between the
current and previous key frames.  This field does not apply to key frames
where the “Reset to these values” option is checked.

Insert new frame  Pressing this button inserts a new key frame after the
key frame currently being edited.

Delete current frame  Pressing this button deletes the key frame
currently being edited.

Delete all frames  Pressing this button deletes all key frames.

Save  This button lets you save your key frames to a file.  Note that all
key frames are automatically saved when you save your drawing.  Use this
option to explicitly save the key frames to a different file so you can use
them in another drawing.  It’s also useful when you want to define
multiple animations for the same drawing.
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Load  This button lets you load a set of key frames from disk.  Any
existing key frames will be erased.

Change in Viewing Angles   These fields specify how much the
viewing angles will change from the previous key frame to the key frame
being edited.  The horizontal and vertical angles correspond to the viewing
angles as set with the Adjust Main View command.  The bank angle lets
you bank, or “spin” the viewing angle to the left or right.  These fields take
on a different meaning when the “Reset to these values” option is set
(described below).

Change in Focal Point  These fields specify how much the focal point
will change from the previous key frame to the key frame being edited.
These fields take on a different meaning when the “Reset to these values”
option is set (described below).

Change in Zoom Factor  This field specifies how much the zoom
factor will change from the previous key frame to the key frame being
edited.  Use a positive value to increase the zoom factor (making objects
appear closer), or a negative zoom factor to decrease the zoom factor
(making objects appear farther away).  This field takes on a different
meaning when the “Reset to these values” option is set (described below).

Reset to these values  This option specifies that the viewing angles,
focal point, and zoom factor are to be reset to the specified values.  This is
useful when you want to reset the viewing parameters in the middle of an
animation.  For example, when walking through a building, you may at
some point want to jump to an exterior view and then continue walking.

Generating Animations
Menu: File|Animation|Generate Animation

KeyCAD 3D generates animations by calculating and drawing each frame
in the animation and optionally saving the resulting pictures to disk.  An
animation preview mode is provided so you can preview animations before
actually saving them.

To generate an animation:

1. Select Generate Animation from the File|Animation menu.

2. Set the animation options and press OK.

3. KeyCAD 3D then generates the animation one frame at a time.
Press any key to abort.
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Figure 12-3.  Generate Animation dialog box

Dialog Box Fields

Filename  Enter the file (and optionally the directory name) here.  It is
not necessary to enter the file extension.  KeyCAD 3D save each frame
with the extension “.nnn”, where “nnn” is the frame number (starting at
000).  For example, entering “C:\CHAIR” would result in the files
“C:\CHAIR.000” for frame 0, “C:\CHAIR.001” for frame 1, and so forth.

Frame size  Select the frame (window) size using these radio buttons.
The smaller the frame the faster the animation, but the less detail you’ll be
able to see.

Options  Select either Wireframe or Shaded.  Wireframe drawings are
faster to generate but are not nearly as realistic as shaded drawings.
However, lines and text do not show up in shaded drawings (unless the text
has been extruded).

Use the Preview option to preview the animation without saving it.  When
you select this option any file name you enter, if any, is ignored.

Once you press OK, KeyCAD 3D draws each frame in the animation and
saves the resulting picture to disk as a Windows Device Independent
Bitmap (.BMP) file.  You can edit these bitmaps using any Windows
drawing program, such as Microsoft Paintbrush.
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Normally each frame of the animation is displayed on top of a white
background.  You can use a bitmap as the background instead, if desired.
Although using a bitmap slows down animation generation by a small bit,
it does not have any affect on the speed of the animation when you later
run it.

To define which bitmap you want to use:

1. Select Preferences from the File menu.  The following dialog box
appears:

Figure 12-4.  Preferences dialog box

2. Enter the name of the bitmap in the Background bitmap field.  (Or,
press the Load Bitmap button if you don’t know the exact file
name.)

3. Select the “Stretch to fit”, “Original size”, or “Tile” options.  Select
“Stretch to fit” when you want the bitmap stretched (or com-
pressed) to fit inside the animation window.  Select “Original size”
to keep the bitmap its original size.  Select “Tile” to tile (repeat)
the bitmap across and down until it fills the animation window.

4. Press OK and then generate the animation.
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Running Animations
Menu: File|Animation|Run Animation

Each frame in an animation sequence is saved in a separate file by the
Generate Animation command.  The file’s extension indicates the frame
number (starting with “.000”).  To run the animation, KeyCAD 3D loads
and displays each frame, one right after another.

To run an animation:

1. Select Run Animation from the File|Animation menu.

2. Enter the name of the animation you want to run, the number of
seconds to delay between frames, and the total number of itera-
tions.

3. Press OK.

Figure 12-5.  Run Animation dialog box
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Dialog Box Fields

Filename  Enter the filename (and optionally the directory) of the
animation you want to run.  For example, type “C:\CHAIR” to run the
animation CHAIR starting with frame “C:\CHAIR.000”.

Delay between frames  This option lets you specify the delay between
frames.  Select “None” for no delay, “Key” to wait for a keypress, or
“Seconds” to wait the specified number of seconds.

Use the “Key” option to wait for one of the following keys after each
frame.  This is useful when you want to display a slide show.

•  Press <Enter> to show the next frame.

•  Press <Backspace> to show the previous frame.

•  Press any other key to end the animation.

Number of iterations  Select “Continuous” to run the animation
continuously.  Or, enter the number of times you want to run the animation
and select “Specified”.  Regardless of which option you select, the
animation stops when you press a key or click a mouse button.

Since each frame is a standard Windows bitmap file, you could replace
one or more frames with your own pictures.  For example, in a slide show
you might want to replace certain frames with information about your
company, introductions, statistics, and so forth; all of which could be
drawn using any Windows drawing program.  The only restriction is that
you keep all frames consecutively numbered (chair.000, chair.001,
chair.002) since the first missing frame signals the end of the animation.

NOTE:  To delete an animation from your hard disk, delete the files
filename.000 through filename.999, where filename is the name of
the animation.
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Ray Tracing

Ray tracing is a way of turning the models you create in KeyCAD 3D into
realistic images you can use for presentations, documentation or simply
artistic enjoyment. It takes a fair amount of time to ray trace an image,
however ray tracing produces images that far exceed the quality of simple
shading techniques. Ray tracing will accurately handle transparency,
refraction, mirrored surfaces and textured surfaces, giving your drawing
the potential for photo-realism.

Ray tracing uses a sophisticated set of mathematical equations to follow a
ray of light through a drawing to determine the color of each dot in the
image. In the real world, rays of light start at a source (such as the sun)
and eventually find their way to the viewer’s eye. In ray tracing, the
algorithm starts with dots on the screen and works its way back to the light
source. As it does this, the ray tracing routines watch the light wave
bounce off or pass through objects. This is how the color and intensity of
each dot are determined.

As the light waves hit each object in a drawing, the algorithm needs to
know the color of the object at that point, how reflective the object is, how
transparent the object is, etc. All of these properties are defined by the
material the object is “made” of. You can define materials in KeyCAD 3D
and apply those materials to objects in the same way you apply color.

This section tells you how to use KeyCAD 3D to create materials, assign
them to objects and then use ray tracing to create a final image in one of
several popular graphics file formats.
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Create Materials
Menu: View|Edit Color/Material

You create a material by picking a bitmap or algorithm that defines the
color of the material, as well as a set of surface attributes describing how
light behaves when it strikes the material. The materials that you create
can be viewed by applying them to objects and then ray tracing.

To create material:

1. Choose Edit Color/Material from the View menu.

2. Select a color from the color palette.

3. Select a material to edit from the pop-up menu.

4. Click Edit to change the material name and attributes.

5. Enter values for the surface attributes.

6. Choose the type of texture mapping an select options.

7. Click OK to save the material.
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Surface Attributes
When you define a material, keep in mind that there are very few objects
in the real world that are at the extremes of these properties. For example,
a mirror most of the light that falls on it, but not all of it. A glass allows
light to pass through it, but some of it shines on the surface or reflects onto
other objects. By experimenting with these different characteristics, you
can achieve some very realistic effects in your drawings.

Diffuse  Diffuse reflection is the amount of light that reflects off the
material in many directions scattering. This diffused light then illuminates
other objects. In the real world, diffused light is everywhere. You can see
what’s in the shadow of a tree because there is some amount of light that
gets diffused by other objects. Similarly, you might point a light at the
ceiling in your home to illuminate the room using indirect lighting. Light
is usually diffused from comparatively rough surfaces, or from surfaces
that are lightly colored such as walls or buildings.

Specular  Specular reflection is the amount of light that is directly
reflected off of a material. When light is specularly reflected, it bounces
directly off the material in exactly one direction instead of diffusing. An
example of a highly specular surface would be a mirror or a piece of
polished metal.

Shine  You can control how glossy a material appears, or how much glare
a particular surface has, by changing the shininess of the material. A small
amount of glare on curved objects lends realism to the drawing, but too
much glare can hide detail on the surface of the object. A value of zero in
this field indicates that the object is not at all shiny (no glare); larger
values in this field make the object increasingly shiny.

Transparency  Transparency describes the amount of light that passes
through a material. Specifying a value of 1 in this field indicates that the
material is completely transparent (the object becomes invisible); a value
of zero indicates that no light passes through the material.

Index of Refraction  When light rays pass through different materials
they are bent, or refracted. This property of a material is what causes
objects to look distorted when you look through a drinking glass. You can
tell KeyCAD 3D how to refract light through a material by entering a
value in the Index of Refraction field.

The index of refraction describes the way light waves bend as they pass
from one material into another. This value is defined as the ratio of the
trigonometric sine of the angle of a light ray falling on a surface, to the
trigonometric sine of the angle the same light ray makes after it passes into
the material. An index of refraction of 1 means the light is not bent at all;
values greater than one correspond to progressively more bending. The
index of refraction for a few common materials is listed below.
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water 1.330
glass 1.550
quartz crystal 1.575
amber 1.546
Jell-O 1.530
obsidian 1.485
diamond 2.417

Texture Mapping
The texture of the material defines the color of different points of the
object during ray tracing. These colors can come from any Windows
bitmap, or you can choose one of three algorithmically generated textures.
When you use a bitmap texture, the bitmap is stretched across the objects
surface. Algorithmic textures permeate the body of the object, which
makes them good for creating realistic wood grains or other materials that
don’t look them same on each edge.

None  Specifying no texture at all is equivalent to the shading that gets
performed when KeyCAD 3D creates a shaded preview. If you were
simply creating colored spheres, like Christmas tree ornaments, this would
be the appropriate texture selection.
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Bitmap

KeyCAD 3D will allow you to use any Windows bitmap file (.bmp) as a
texture for a material. This bitmap is stretched across the surface of the
object to define the color of different points during ray tracing. Ideally, the
bitmap should be “tileable” so that they can be repeatedly placed next to
each other to make a continuous image. Windows desktop patterns are
tileable bitmaps that can be used as textures.

You will probably use bitmaps more often than any other type of texture.
Several textures are included with KeyCAD 3D that allow you to create
materials such as brick, wall paper and other common surfaces. Third
parties sell texture libraries, or you can create your own using a draw or
paint program. You can view bitmap files by choosing View Bitmap File
from the File menu.

Select a bitmap file to use as a texture by pressing the Options button on
the Edit materials dialog box.

Dialog Box Fields

File Name  The options dialog displays the name and path of the bitmap
file used for this texture. To change the path, press Load bitmap.

Number in “up” and “across” direction  You can control the scale of
the texture as it is stretched across the object surface by specifying
different values in these fields.
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Checker

The checker texture is an algorithmic texture used to create materials like
tile floors by alternating cubes of two different colors throughout an
object.

Scale  You can control the scale of the texture by specifying a different
value in this fields.

Alternate Color  The checker texture alternates between the material
color and the alternate color selected here to create a pattern of  color for
the material.

Turbulence  You can roughen up the edges of the squares by specifying a
value in the turbulence field. A small amount of turbulence will remove
the sharp edges that make objects in your drawing look “too perfect.” A lot
of turbulence can give you an effect anywhere from splatter paint to a
mottled mess.

Axes  When the checker texture is used on a curved surface, you may
notice “banding” when the object passes through successive layers of the
texture. You can force the checker texture to extend through any two
dimensions by turning off one of the axes.
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Circular

The checker texture is an algorithmic texture used to create materials like
wood grain by alternating cylinders of two different colors throughout an
object.

Scale  You can control the scale of the texture by specifying a different
value in this fields.

Turbulence  You can roughen up the edges of the circles by specifying a
value in the turbulence field. A small amount of turbulence will remove
the sharp edges that make objects in your drawing look “too perfect.” A lot
of turbulence can give you an effect anywhere from splatter paint to a
mottled mess.

Color  The circular texture alternates between the material color and the
color selected here to create a pattern of color for the material.

Center  These coordinates define the center from which the circular
pattern spreads out.

Axis  Click the desire axis for the pattern to spread on.
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Water

The water texture is an algorithmic texture used to create by creating a
wavy surface across an object.

Number of Wave Centers  The number of wave centers sets how many
patterns of waves there are in the texture. A single wave center produces a
texture similar to the circular texture; more than one wave center will
create more complex, interfering wave patterns.

Wave Height  The wave height field defines how “thick” the waves are
as they move through the material.

Wave Frequency  The wave frequency controls how closely waves are
spaced together.

Assigning a Material to an Object
Menu: View|Edit Color|Material

Before an object can be ray traced, you must assign it a material. When
you assign a material, you won’t actually see how the material affects the
object until ray tracing. When in wire frame and shade views, the object
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will appear without textures. This is because ray tracing is the only way
KeyCAD 3D can accurately display the effects of light on the material.

You assign a material by selecting a material from the pop-up list in the
Edit Color/Material dialog and then choosing the Set Color/Material
command from the View menu.

To assign an object a material:

1. Select Edit Color/Material from the View menu or click on the
color box on the status line.

2. Click on the desired color.

3. Select a material from the pop-up list.

4. Click OK to close the Edit Color/Material dialog.

5. Select one or more objects in the drawing view.

6. Choose Set color/Material from the View menu to apply the current
color/material to the selected objects.

If you want to view the object with the texture, go through the steps in the
next section to create a ray traced image.

Ray Tracing
Menu: Shade|Ray Trace

This command takes the completed model, with the assigned materials,
and creates a ray traced image in a one of several graphics file formats.

To use the Ray Trace command:

1. Choose Ray Trace from the Shade menu.

2. Set a point to be the center of focus. Selecting an alternate center
of focus has the effect of panning the ray traced image so that the
center of focus is in the middle of the image. This point is optional;
KeyCAD 3D will use the current view if you don’t set a point.

3. Set the Ray Trace options and press OK.

4. Enter a file name for the final ray traced bit map, choose a file
format to save the image in and press OK.

5. KeyCAD 3D will ray trace the drawing, save the image in the file
you specified, and display the final image on the screen. Click the
mouse button when you’re done viewing the final image.
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IMPORTANT:  For faster operation, select a File Type which corre-
sponds to the video mode you’re currently running in For example:

Video Mode Recommended File Type
16 color BMP 4-bit
256 color BMP 8-bit
True color BMP 24-bit

Figure 13-1.  Ray Trace options

Dialog Box Fields

Size  Select the size of the final image by clicking on of the Image size
buttons. The amount of time it takes to ray trace the drawing is directly
related to the number of dots in final image. All things the same, ray
tracing a full screen image takes four times as long as ray tracing a half
screen image since a full screen contains four times as many dots and as a
half screen. When previewing, you should preview the smallest size that
will let you preview at the level of detail required.

Shadows, Reflections and Textures  When you are proofing a ray
traced image, you may want to turn off shadows, reflections or textures.
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This will save a significant amount of work as each one of these features
requires a reasonable amount of processing power, but the final image will
lack the corresponding element of realism.

Quality  The ray tracing algorithms approximate the reflections of light
off curved objects. Higher quality images make better approximations, just
as drawing a sphere with a higher polygon density makes for a smoother
surface. You can adjust the quality of the ray traced image depending on
whether you are proofing an image or creating a finished product.

Background Color  Press the Background Color button to select a
background color for the image.
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Error Messages
This appendix describes each error message that could be displayed by
KeyCAD 3D.  You can quickly view a description of the error by pressing
the F1 key while the message is being displayed (before closing the
message box).  Only KeyCAD 3D's messages are listed, not Windows'.
Please refer to your Windows documentation for information about error
messages generated by Windows.

Animation generation canceled

This is an informational message telling you that animation generation
was canceled either due to an error (which would have been previously
displayed), or by a key press or mouse click.

Animation not found

The specified animation was not found.  Animation files have the
extension “.000” for the first frame, “.001” for the second frame, and so
forth.  This message indicates that the first frame could not be opened.
Verify the file exists and try again.  Also make sure that the file is not
already in use by another application.

Animation preview canceled

The animation preview was canceled either due to an error (which would
have been previously displayed), or by a key press or mouse click.

Cannot continue Undo support due to a disk write error

An error occurred while attempting to write Undo information to a disk
file, usually because the disk is full.  The number of Undo levels is
automatically set to 0 when this happens.  See “Undoing and Redoing
Changes” on page 109 for information about resetting the number of undo
levels.
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Cannot continue Undo support due to a disk read error

An error occurred while attempting to read Undo information from a disk
file.  The number of Undo levels is automatically set to 0 when this
happens.  See “Undoing and Redoing Changes” on page 109 for informa-
tion about resetting the number of undo levels.

Cannot use fixed-text

You cannot use this command with fixed text. You will first need to
convert the text to lines using the Convert Fixed Text to Lines command.

Current layer must always be active

You attempted to close the Change Layer Settings dialog box but the
current layer is not active.  Either activate the layer (by checking "En-
abled") or by selecting a different (and enabled) Current Layer.

Error creating file

The file could not be created, usually due to an invalid directory name.
Verify the directory name and try again.  Also make sure the destination
drive has enough available storage and that the file is not in use by another
application.

Error loading file—invalid file format

The file is not in a format recognized by KeyCAD 3D.  Specify a valid file
and try again.

Error opening file

The file could not be opened for the specified reason, usually because it
wasn't found.  Verify the file exists and try again.  Also make sure that the
file is not already in use by another application.

Error writing file

The file could not be written, usually because the disk is full.  Free up
some disk space and try saving the file again. Also make sure the file isn't
being used by another application.
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File does not contain a valid palette

You attempted to load a .PCX file that does not contain a valid 16 or 256
color palette.

File already exists—Overwrite?

You selected a file that already exists.  KeyCAD 3D wants to know if you
want to overwrite the existing file with the file you are saving.  Press YES
to erase the existing file, or NO to select another file name.  Press
CANCEL to cancel the command.

File has changed—save changes?

You selected a command (such as Exit, New, or Open) that will cause
changes to the current drawing to be lost.  KeyCAD 3D wants to know if
you want to save the drawing first.  Press YES to save the drawing, NO to
discard changes, or CANCEL to cancel the command.

Font files cannot contain text primitives

The font you attempted to load contains fixed-text primitives, which is not
allowed.  See “Loading Fonts” on page 162 for information on how to
create font files.

Input out of range

You entered a number that was either too large or too small.  Enter a
number that is within the displayed range.

Invalid input

You entered a number that was either out of range or contains one or more
invalid characters.  The number entered must be greater than -99999999.0
and less than 99999999.0.  There may be other restrictions on the value as
well. Refer to the command's documentation for more information.

Key frame not defined

You attempted to edit a key frame that has not yet been defined.

Layer # must be 0-255

KeyCAD 3D supports up to 256 layers, numbered 0 through 255.
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Lines must be connected

You attempted to combine lines that are not connected.  Use the Zoom
command  to closely examine each connection.  You can also use the Join
Points command (see page 117) to connect the endpoints.

Maximum of 16000 polygons exceeded -- rest ignored

You attempted to shade a drawing that contains over 16,000 polygons. To
work around this restriction:

Save the drawing to a temporary file (using the Save As
command).

1. Set the viewing angles so that the drawing is oriented as desired for
shading.

2. Delete “hidden” polygons—that is, those polygons that will be
covered up during shading.  For example, slice off the back half of
all spheres.

3. Shade the drawing.  If you still get this error then repeat step 3 and
try again.

Maximum of 200 points exceeded

The command you selected attempted to build a primitive (such as a line
or polygon) that contained over 200 points.  Simplify the primitive(s) and
try again.

No. circle segments out of range

The number of circle segments must be no less than 4 and no more than
196.

Not enough memory

There was not enough memory to complete the requested command.  You
can do the following to increase available memory:

Close other applications.

1. Disable Undo support by setting the number of undo levels to 0
using the Preferences dialog box.

2. Add additional memory to your computer.
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Not enough memory to fully update display

There was not enough memory to fully update the display.  You should
save your drawing and exit KeyCAD 3D.  Increase available memory
(either by closing other applications or by adding additional memory to
your computer) before running KeyCAD 3D again.

Not enough memory to print to clipboard

There was not enough memory to print the drawing to the clipboard.  This
could also occur if the drawing is too large to fit in the clipboard.  Try
printing to a Metafile instead.

Out of memory!

There was not enough memory to perform a critical function inside
KeyCAD 3D. You must free up some memory before continuing.
KeyCAD 3D has already flushed Undo information to disk and freed the
safety pool, but enough memory is still not available.  You need to do the
following:

1. Close all other applications (except, of course, the Program
Manager).  To switch between applications, press ALT-ESC.

2. Switch back to KeyCAD 3D.

3. Press RETRY to retry the memory allocation.

IMPORTANT:  Pressing CANCEL will exit KeyCAD 3D and all changes
to your drawing will be lost.

Please define two or more key frames

You need to define at least two key frames in order to generate an
animation.  To add a key frame, select Add Key Frame from the
File|Animation menu.

Please select at least two connected lines

You need to select at least two connected lines with the Fillet and Chamfer
commands.  You can also select a single polygon or a single line with
multiple segments.

Please select one or more viewports

You need to specify which viewport(s) you want the pan or zoom
command applied to.
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Please specify a smaller radius

You entered a radius that would create an arc that would be too large for
the selected lines.  Try again using a smaller radius.

Patch requires exactly 4 connected lines or curves

You must select exactly 4 connected lines or curves for use with the Patch
command.  See “Drawing a Surface Patch” on page 103 for more
information.

Printer initialization error

An error occurred while attempting to initialize the printer.  Verify the
printer is configured properly and that Windows has the correct printer
driver loaded.

Points must all be unique

The command you selected requires that you set each point at a different
location.

The Copy command is currently active.  Do you want to
cancel it?

You attempted another drawing or editing command before completing the
last Cut, Copy, Copy To, Paste, or Paste From command.  Press YES if you
want to cancel the previous command.  Press NO if you want to finish it
first.

The point you set is not used by one of the selected
objects

This message is displayed when the point you set for the Solid Subtract
command does not match a point used by one of the selected solids.  Try
the command again and use the Closest Point command to make sure the
point is set precisely.  It doesn’t matter which point you use, as long as the
point is unique to the solid you want to subtract.  See “Closest Point” on
page 73 for more information about setting points and where they are
located.
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Working plane is already active

You selected the Set Working Plane command but the working plane is
already active.

Working Plane is not active

You selected the Reset Working Plane command but the working plane is
not active.

You cannot add any more key frames

You cannot add any more key frames because the maximum number (100)
has already been reached.

You must select exactly two groups for this command

You must select exactly two groups for use with the solid modeling
commands.  Each solid must be a single group.  See Chapter 1, “Getting
Started,” for information on making and breaking groups.  Also see
“Making and Breaking Groups” on page 116.
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