
DOCUMENT TEMPLATES

Creating a document in Word for Windows can be simplified by using document templates.  Instead of defining 
margins, styles or header or footer text with each new document, these items can be stored in document 
templates.  Included with Word for Windows, is a set of predefined document templates that can be used as is or 
altered to better suit your needs.  These "templates" can store standard aspects of your documents such as a 
letterhead or other formatting.  Using templates will shorten the time it takes to produce great looking  
documents.  The first few pages of this application note will introduce you to the concept of templates, and the 
final pages will step you through the creation of a custom template.

WHAT IS A TEMPLATE?

A template is a specialized file that functions as a skeleton for documents.  In the template file you can store the 
basic structure for your document files.  This might be in the form of glossaries, macros, styles, header or footer 
text, a letterhead (graphic images), or menu and key assignments.  A template file has a .DOT extension to 
indicate a "Document Template", versus a .DOC extension which is commonly used for document files.   
Template files that are listed in the File New dialog, are normally stored in the Word for Windows program 
directory.  There is a however a WIN.INI setting that allows you to move the template files (.DOT files) to 
another directory.  

[Microsoft Word 2.0]
DOT-PATH="Drive letter:\directory location for template files"
DOT-PATH=C:\WINWORD

This application note will describe the function and application of document templates.  After reading through 
this information you should have an understanding of how to use document templates as well as the items that are
stored within templates.  
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WHAT THINGS ARE STORED IN A TEMPLATE?

Item Example

Styles Text Formatting that can be applied to 
paragraphs.  Example: Italic, Bold, Paragraph 
Indents.

Menu Assignments Menu items are those items that appear below
Word's menu bar (File Edit View Insert 
Format Tools Table Window Help). Example:
In the LETTER template you could choose to 
remove the Insert Table of Contents 
command from the Insert menu and add 
Hanging Indent to the Format menu.

Toolbar Icons The appearance of the icon buttons on the 
Toolbar and the command or macro behind 
the button can be saved with the template.  
Example: Add a new icon to the Toolbar for a
macro or command that you commonly use.

Keyboard Assignments Keyboard combinations for Word for 
Windows commands.  Example: Templates 
store the keyboard combinations for 
commands such as CTRL+B for Bold 
formatting.

Macros A set of commands that automate tasks within
Word for Windows.  Example: Create a 
macro to automate a search and replace for 
carriage returns (paragraph returns).

Glossary Items Text or graphic items that can be assigned a 
name and retrieved by a single keystroke. 
Example: Enter commonly used names and 
addresses as glossary items.

Boilerplate Text A company letterhead and address or the 
{date} field in order to insert the current date 
in all new documents based on the template 
file.
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WHAT IS THE NORMAL.DOT?

Word for Windows bases new documents on the NORMAL.DOT template unless otherwise specified.  When 
selecting New from the File menu to create a new document, the Normal template is selected by default.  If OK is
clicked or the Enter key is pressed, then the new document will have settings based on the NORMAL.DOT 
template settings.  All features that are saved as global or defined in the global context will be stored and saved to
NORMAL.DOT.  Items such as the default font and point size, paragraph indents, positioning, line spacing, tab 
settings, and margins will all be preset to the settings found in the NORMAL.DOT template.  Having all of these 
settings preset will save you time from having to set them each time.  
CONTEXT:  GLOBAL VS TEMPLATE

Context is a term that is used to describe where features will be stored.   Templates are stored in two contexts: 
Global and Template.  If a user decides to store an item as global, than the item will be available to all documents
that are based on the NORMAL as well as documents based on other templates.

Global:  Global context is a option that will result in the template item being stored in the NORMAL.DOT file.  
Items stored in the NORMAL.DOT file are global in that they can be accessed from any template.  For example, 
if you place your name and address into a glossary and the context is Global, then you will be able to access the 
address information regardless of the document template in use.  Global context also means that the template 
item (whether it be a style, macro or glossary item) will be available to all documents and templates that are 
based upon NORMAL.  For example, if a macro is created while in a document created from NORMAL.DOT, 
the macro context will be stored as global.  If you are later in a document based on a template named LETTER, 
you will still be able to access the macro because the context is global.

Template:  The template context is a option that will result in the template item being stored in the active 
template only.  This means that the change will only affect documents based on the current template in use.  For 
example, if the current document is based on the MEMO2 template and you place your name and address into a 
glossary with the context being Template, then the name and address will only be accessible when a document is 
based on the MEMO2 template.  The glossary item will not be listed in the Edit Glossary dialog when a 
document based on NORMAL or any other template other than MEMO2.

INDICATING THE LOCATION OR CONTEXT

In order to indicate the location or context for new macros and glossary items, choose Template from the File 
menu.  The default for Word for Windows is "Prompt For Each New".  This means that Word will prompt you 
for the context when a new macro or glossary item is created in a template other than NORMAL.  For example, if
you are in a template other than NORMAL, the following prompt will appear when defining a glossary entry:

Store Glossary entry:
as Global (NORMAL.DOT)
in Template (TEMPLATE.DOT)  

If you do not wish to be prompted for the context with each new macro or glossary item, select one of the 
other options in the File Template dialog:

 

Choose Global to make new glossary items or macros global or "available" to all documents (regardless of the 
template in use).  Choose With Document Template to store the new macros and glossary items in the current 
template.  Macros or glossary items that are stored in a template file other than NORMAL are not available in 
other template files. 
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WHAT THINGS ARE STORED IN NORMAL.DOT?

Styles:

Styles are used to control the appearance of the text within a paragraph.  When opening  a new document, Word 
for Windows automatically begins using the formatting stored in the Normal style when a new document is 
opened.

To change formatting for the Normal style, such as a default font:

1. Select Style from the Format menu and choose the Define>> button.

2. Choose the Style named Normal from the drop down list box of style names.

3. Choose the Character button to change the font specified for the Normal style (the default font).
(Buttons: Character, Paragraph, Tabs, Border, Frame , Language)

4. Choose a Font name and Point size and click on the OK button.  

5. In order for the Style change to be recorded in the template file and not just the document file, place and X in 
the Add to Template box at the bottom of the Style dialog.

6. Finally choose the Apply button.  The following prompt will appear:
 
7. Choose Yes to change the definition of the Normal style.  

8. Choose Save All from the File menu to save the changes to the template file.  The following prompt will 
appear if a change has been made to the NORMAL.DOT file (same prompt may appear when exiting the 
program if changes were made to NORMAL):

Save global glossary and command changes?

9. To record changes made to the NORMAL.DOT file, choose Yes to this prompt.  Note: If the active document 
is based on a template other than NORMAL.DOT, then the prompt will differ slightly to refer to the template 
file:

Do you want to save changes to TEMPLATE.DOT?

STANDARD STYLES:

"Normal" is one of the standard Word for Windows styles.  To view a listing of other standard styles, such as 
Header or Line Number, do the following:

1. Choose Style from the Format menu.
2. Press CTRL+Y.

3. Click on the down arrow beside the Style name text to drop down a listing of standard styles.  Normally only 
the following standard styles are listed unless others standard styles are in use.  For example, the Header style 
is added to the listing of styles once a Header is used in the Word for Windows document.
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Standard Styles Standard Styles listed after adding a header to a document

Heading 1 Header

Heading 2 Heading 1

Heading 3 Heading 2

Normal Heading 3

Normal

CREATING A USER DEFINED STYLE

If you have already formatted a section of text with specific formatting and you need to apply this formatting to 
other sections of text, you can create a style to quicken the process of formatting text.  To create a user defined 
style based on manual or direct formatting, do one of the following:

Using the Ribbon

1. Select the text with the formatting that is to be assigned a style name.

2. Press CTRL+S.

3. Type the name for the new style.  The new style will be defined with the formatting of the selected text in 
Step 1 above.

Using the Format Style Command

1. Select the text with the formatting that is to be assigned a style name.

2. Choose Style... from the Format menu.

3. Type a new style name in the edit box labeled Style Name.

4. The description box will list the attributes of the selected text.  To accept the style description and assign the 
style to the specified name, choose the Apply button.

SAVING STYLES TO A TEMPLATE VERSUS SAVING STYLES WITH THE DOCUMENT ONLY

After defining styles you can save them for use in the document only, or to the active template file.  To save them
for the current document only, save the document file as you normally would with the File Save command.  To 
save the styles to the current template so that they can be used in other documents, do the following:

1. Select Style... from the Format menu.

2. Choose the Define>> button.
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3. Place an X in the box labeled "Add to Template" and choose the OK button.

4. Choose Save All from the File menu and when prompted to save changes to the template file, choose Yes.  
Note: If the current template is the NORMAL template, than the prompt will ask you to save global glossary 
and command changes.  Any time this prompt appears Word is referring to the NORMAL template where 
global items are stored.

CREATING A TEMPLATE FILE

While there are several templates included with Word for Windows, it is also possible to create your own 
template (see page 7 for more information on creating a custom template file).  To create a template, do the 
following:

1. Choose New from the File menu.

2. The default selection for the box labeled New is "document".  To create a new template, choose Template 
from the box labeled New.

3. By default the new template will be based upon the Normal template.  However, you can select any of the 
templates listed in the list box of templates.

4. Press OK to open a new template file.  The title bar at the top of the Word screen will read "Microsoft Word - 
Template 1".  This is similar to after opening a new document.  To save the newly created template file, 
choose Save from the File menu.  Type a filename with a maximum of 8 characters.  Word will automatically 
assign a extension of .DOT and place the file in the WinWord program directory unless otherwise specified in 
the WIN.INI file with the DOT-Path parameter.

EDITING A TEMPLATE FILE

The templates that are included with Word for Windows may need some modification to fit your individual 
needs.  For example, you might want to add your company letterhead to the LETMODBK template or delete text 
from the LETMODBK template.  To do this, you will need to open the template file (LETMODBK.DOT).

1. Choose Open from the File menu.

2. Click on the down arrow beside "List Files of Type:" and choose Document Templates (*.dot).

3. Change the directory if necessary to the Word for Windows program directory, or the directory where your 
template files are located.

4. Select the template (LETMODBK.DOT) file to edit and choose OK.

The selected template file will now be open for editing purposes.  You can delete text or add text/graphics to the 
template.  You can also add styles, glossary items, macros, or customize the menus, keys, and Toolbar.  After 
making changes to the template choose Save from the File menu to save the changes to the template file.  

A PRIMER ON FIELDS

Fields are special codes that instruct Word for Windows to insert material automatically.  Fields such as {Date}, 
{Time}, and {Fillin} fields to prompt for information, are commonly used in templates.  Fields do not have a 
context as do glossaries, styles and macros, but rather can be inserted into documents and templates alike.  The 
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advantage of placing fields into templates is one of saving time.  For example, if there are certain items that you 
would like on each memo or note that you write, you can insert fields and text in your template for creating 
memos.  Then when you base a new document on the template, the fields and the text from the template are 
already inserted.

INSERTING FIELDS

Keyboard:

1. To insert a field from the keyboard, press CTRL+F9 to insert the field characters {}.

2. Type the name of the field between the field characters.  An example field might be {Date} or {Time}.

3. Press the F9 key to update the inserted field.

4. Press the right arrow to move the cursor outside of the field characters.

To view the result of the field code, deselect Field Codes from the View menu.

Mouse:

1. Choose Field... from the Insert menu.

2. Select the name of the field to insert.  An example field name might be date or time.

To view the result of the field code, uncheck Field Codes from the View menu (if selected).  
Field Codes Checked: Field Codes Not Checked:

{date} 11/11/91

UPDATING FIELDS

With your cursor between the field brackets, press F9 to update the field.  Most fields, as in the case of the Date 
field, are updated when the document is printed.  To update the field prior to printing press F9 within the field 
brackets.  To update all of the fields in a document or template, choose Select All from the Edit menu prior to 
pressing F9.

CREATING YOUR OWN CUSTOM TEMPLATE

In this section you will have an opportunity to put into practice some of the ideas previously discussed in this 
application note.  We will begin by creating a template called MYTEMP.DOT.  Then we will enter boilerplate 
text along with the appropriate fields to prompt for information.  Finally, we will create an AutoNew macro to 
update the fields when a new document is based on our template, MYTEMP.DOT. 

1. Choose New from the File menu.  Click on the Template button to create a new Template instead of a 
document file.  Choose OK or press Enter to open a new Template based on the NORMAL template.

2. The title bar at the top of the Word screen now indicates that the active file is a template:
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Microsoft Word - Template 1

Type the text that is outlined below at the beginning of the new template file:

TO:
FROM:
SUBJECT:
DATE:

3. Once the above text has been typed, we are now ready to insert a field code called {fillin}.  Position the cursor
one space over from the TO: text. 

4. Type CTRL+F9 to insert the field brackets.  Type the following text between the field brackets:

fillin "Type who to send the memo to"

so that the field appears as follows:

TO:  {Fillin "Type who to send the memo to"}

Repeat Step 4 for the following three items:

FROM:  {author}
SUBJECT:  {Fillin "Type the subject of the memo"}
DATE:  {Date}

Note that the Date entry and Author entry are using fields other than Fillin fields.  The code to insert the date into
a document is named {Date}.  Choose Field from the Insert menu and select date on the left and the specific 
format on the right.  The code to insert the author as listed in the Summary Info dialog from the File menu, is 
{author}.

Once the fields are inserted, we will need to record a macro to update the fields when a new document is opened 
based on this template.  This macro will be called AutoNew.  
 
5. Select Record Macro from the Tools Menu.  You will be presented with a dialog box that asks for a name for 

your macro.  Type in Autonew as the macro name.  Also lets give the macro a description to describe its 
function; something like "macro to update field codes in a new document".  Once this description and name 
are in the record macro dialog box, choose OK.  You will now be prompted to save the macro as Global or in 
the Template.  Since this macro is specific to this template, choose Template and select OK.

After pressing OK, all keystrokes that are pressed will be recorded.  It is important to use the keyboard 
commands when recording macros in order for the macro to be recorded properly.  

6. Select the whole document by holding down the CTRL key and pressing 5 on the Numeric keypad (or 
ALT+E, A).  Now that the whole document template is selected, press the F9 function key.  You will be 
prompted to type in a name and subject for the memo.  For each of the prompts just press the Enter key and do
not type any text.  

7. After the two prompts, press ALT+O to drop down the Tools menu and then press R for Stop Recorder.

You have now successfully recorded a macro to update all field codes in a new document.  
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8. Choose Save from the File menu and type a name for the template.  For our example type MYTEMP.  

9. From the File menu choose Close to close the template file.

Now to use this template file, choose New from the File menu.  Select the Document option button 
and select Mytemp from the list box of available templates (under the title Use Template).  When the
new document is opened you will be prompted to "Type who to send the memo to".  Each prompt 
can be filled in accordingly.  The date field will update to reflect today's date.  Complete the memo 
and save the document as you normally would with the File Save command.
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