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The File Menu
Commands in this menu let you create, open, and print document files and provide menu access to other 
file-related functions.

New Alt+F,N Create a new document file.
Open Alt+F,O Open an existing document file.
Close Alt+F,C Close active document window.
Save Alt+F,S Save file in active window.

Save As Alt+F,A Save file in active window using different name.
Save All Alt+F,L Save all open files.

Insert Alt+F,I Insert contents of a file at cursor.
Revert Alt+F,V Undo all changes since last save.

Write Block Alt+F,W Write selected block to a file.
Printer Setup Alt+F,R Select printer and printer options.

Page Setup Alt+F,G Set headers, footers, margins, etc.
Print Alt+F,P Print current document file.

Mail Document Alt+F,M Send current document file to another user.
Compare Alt+F,E Compare contents of two documents.

(list of files) Alt+F,n Open or activate recently used file.
Exit Alt+F,X Close Desktop Editor windows and exit.



File New Command
Function name: new_file

Default keys: Alt+F,N
This command opens a new untitled window. Use the Save or Save As... command to assign a name to 
the file.



File Open Command
Function name: open_file

Default keys: F3
This command displays a Standard Browse... dialog box. Use it to select a file to edit.



File Close Command
Function name: close_window

Default keys: Alt+F,C
This command closes the active window.
If you have modified the file since the last time you saved it (and it is not open in any other document 
window), then Desktop Editor prompts you to save your changes before it closes the file.



File Save Command
Function name: save_file

Default keys: F2
This command immediately saves the file in the active window.
If the file does not yet have a name, a Standard Browse... dialog box appears and prompts you for a path 
and filename.



File Save As Command
Function name: (none)

Default keys: Alt+F,A
This command displays a Standard Browse... dialog box. Use it to select a new path and filename for the 
file displayed in the active window.
You can use this command to save the file with a new name; for example, make a "backup" of your file by 
saving it under a different name.



File Save All Command
Function name: save_all

Default keys: Alt+F,L
This command saves all open files.
If any windows are untitled, a Standard Browse... dialog box appears. Use this to specify a path and 
filename for any open, untitled files.



File Insert Command
Function name: (none)

Default keys: Alt+F,I
Use this command to insert the contents of one file into another. The file is inserted at the current cursor 
location.
A Standard Browse... dialog box appears and prompts you for the name of the file to insert.



File Revert Command
Function name: revert

Default keys: Alt+F,V
This command undoes all editing changes since the file was last saved. Before reading the file from disk, 
Desktop Editor displays a confirmation box, allowing you to cancel the operation.



File Write Block Command
Function name: (none)

Default keys: Alt+F,W
This command copies the currently selected text to a file. It is enabled only when text is selected.
Use the Standard Browse... dialog box which appears to specify a path and filename under which to save 
the text.



File Printer Setup Command
Function name: (none)

Default keys: Alt+F,U
This command displays a Printer Setup dialog box which lets you select a default printer and specify print 
options.
You can also use the Page Setup... commands to select page header, footer, and margin settings before 
printing a document.
Use the File Print command to print the document.



File Page Setup Command
Function name: (none)

Default keys: Alt+F,G
This command displays a Page Setup dialog box which lets you select a font, margins, and header and 
footer text to be used when files are printed.
You can also use the Printer Setup... command to select a printer and specify print options before 
printing a document.
Use the File Print command to print the document.



File Print Command
Function name: print

Default keys: Alt+P or Alt+F,P
If text is selected in the active window, this command sends the selected text to the default printer.
If no text is selected, the entire file is printed.
Use the Page Setup... and Printer Setup... commands to select a printer and specify print options before
using this command.



File Mail Document Command
Function name: (none)

Default keys: Alt+F,M
This command lets you use Microsoft Mail to send the document to another user. 



File Compare Command
Function name: compare

Default keys: Alt+F,E
This command displays a Compare dialog box which lets you select two files to compare.
If either file is currently open, Desktop Editor uses the version which is in memory, rather than reading the
file from the disk. If you want to pinpoint recent changes, first save the open file under a different name 
(use the Save As... command), then compare it to the file on disk.
Desktop Editor performs the comparison on a line-by-line basis. Both files are displayed and the first 
mismatch is highlighted.



File Exit Command
Function name: exit

Default keys: Alt+F4 or Alt+F,X
This command closes all Desktop Editor windows and exits.
Desktop Editor prompts you to save changes you have made to any open file.



File (list of files) Command
Function name: (none)

Default keys: Alt+F,1...4
This command lets you quickly open a recently edited file. The last four files edited appear at the bottom 
of the File menu. To open one of these files, press Alt+F then 1, 2, 3, or 4.
If the selected file is currently in memory, its window is brought to the front. You can also activate any 
open or minimized window by selecting it from the Window menu. 



The Edit Menu
Commands in this menu provide text editing tools,access to the clipboard, and keyboard macro control.

Undo Alt+E,U (Alt+BkSp) Undo the most recent text-editing change.
Cut Alt+E,T (Shift+Del) Copy the current selection to the clipboard and then delete 

that text.
Copy Alt+E,C (Ctrl+Ins) Copy selected text to the clipboard.
Paste Alt+E,P (Shift+Ins) Paste clipboard contents to the cursor position.

Delete Alt+E,D (Del) Delete current selection.
Select     All  Alt+E,A Select all text in the active file.
Time  /  Date  Alt+E,D Insert the current date and time at the cursor.

Wrap     Paragraph  Alt+E,R Reformat the paragraph at the cursor, wrapping at the current margin 
settings.

Word     Wrap  Alt+E,W Toggle automatic paragraph wrapping on or off.
Record     Macro  Alt+E,R (toggles to Stop Recording Macro) Record subsequent keystrokes for

automatic recall.
Playback     Macro  Alt+E,P Replay the keystrokes saved during the most recent Record Macro 

command.
By default, Desktop Editor uses standard keystrokes for text selection and clipboard operations. However,
you can assign different (perhaps more convenient) keystrokes to these functions. See Customizing 
Editor Keystrokes for details.



Edit Undo Command
Function name: undo

Default keys: Alt+BkSp or Gray *
Reverses the effects of a previous editing operation. Each Undo reverses the effects of one editor 
function or keystroke. The number of operations that can be undone is specified in the Editor Preferences
dialog box (from the Options Menu).
Only changes made since a document was last saved can be undone.



Edit Cut Command
Function name: cut

Default keys: Shift+Del or Gray -
Deletes the selected text from the active window and moves it to the clipboard.
If no text is selected, and if the Cut/Copy Current Line if No Text is Selected check box in the Editor 
Preferences dialog box is checked, the current line is cut.
Use the Edit Copy command if you want to copy the selection to the clipboard without deleting it. Use 
Delete if you want to discard the line without changing the contents of the clipboard.



Edit Copy Command
Function name: copy

Default keys: Ctrl+Insert or Gray +
Copies the selected text from the active window into the clipboard.
If no text is selected, and if the Cut/Copy Current Line if No Text is Selected check box in the Editor 
Preferences dialog box is checked, the current line is copied.



Edit Paste Command
Function name: paste

Default key: Shift+Insert
Inserts the contents of the clipboard at the current cursor position.



Edit Delete Command
Function name: delete

Default key: Del
Deletes the currently selected text. If no text is selected, deletes the character to the right of the cursor.
Use the Edit Cut command if you want to copy the selection to the clipboard and simultaneously delete it 
from your document.



Edit Select All Command
Function name: select_all

Default key: Alt+E,A
Selects all text in the active window. The cursor is moved to the end of the file.
This is the same as pressing Ctrl+Home and then Shift+Ctrl+End.



Edit Time/Date Command
Function name: stamp

Default key: Shift+F2
Inserts the date and time at the cursor location.



Edit Word Wrap Command
Function name: toggle_wordwrap

Default key: Ctrl+W
Enables or disables word wrap in the active window. Word wrap is used when writing narrative 
paragraphs; turn this feature off when writing program source code or creating formatted tables.
When word wrap is enabled, typing beyond the right margin causes the current word to be moved down 
to the next line. The word WRAP appears on the status line.
The right margin setting can be changed from the Document Preferences dialog box dialog box on the 
Options menu.
Use the Wrap Paragraph command on the Edit menu to reformat a paragraph and wrap all lines at the 
margin.
Note: Desktop Editor displays in a monospaced font, so word wrapping is based on a uniform character 

width. If you use a proportional-spaced font when you print the document, the right edge will 
appear more ragged in the printout than it does on the screen.



Edit Wrap Paragraph Command
Function name: wrap_para

Default key: F12
Reformats the current paragraph (or the previous paragraph, if the cursor is between paragraphs) so that 
all the words fit within the margins. The cursor moves to the end of the paragraph.
This command does nothing if word wrap is turned off. Use the Edit Word Wrap command to enable this 
feature.
Word wrap is used when writing narrative paragraphs. Don't use this feature when writing program source
code or creating formatted tables.
Change the margin setting from the Document Preferences dialog box. Choose Document Preferences 
from the Options menu.



Edit Record Macro Command
Function name: record_macro

Default key: F7
Begins or ends a keyboard macro definition. While recording a macro, REC appears on the status line, 
and the menu command toggles to Stop Recording Macro. All keystrokes and functions are recorded 
until you choose Stop Recording Macro from the Edit menu.
You can use the Playback Macro command to replay the recorded sequence.
See Using Keyboard Macros for related details.
Note: The Desktop Editor internal macros have certain limitations. If you want to record multiple, 

named macros, or if you want a macro to work within dialog boxes, use Macro Builder on 
the Norton Desktop Tools menu.



Edit Play Back Macro Command
Function name: play_macro

Default key: F8
Replays the sequence of keystrokes and functions saved by the Record Macro command.
See Using Keyboard Macros for related details.
Note: The Desktop Editor internal macros have certain limitations. If you want to record multiple, 

named macros, or if you want a macro to work within dialog boxes, use Macro Builder on 
the Norton Desktop Tools menu.



The Search Menu
Commands in this menu let you search for text in the current file or in a set of files on disk. They also 
provide a quick way to move to a line given its line number.

Find Alt+S,F Search for text or a regular expression.
Find Again Alt+S,A Continue search started with the Find command.

Replace Alt+S,R Search for and replace text or regular expression.
Find Files Containing Alt+S,C Generate a list of files which contain specified text or regular 

expression.
List Found Files Alt+S,L See a list of files found; choose one to edit.

Goto Line Alt+S,G Move the cursor to a line specified by its line number.



Search Find Command
Function name: find

Default key: Ctrl+S
This command searches the active document for specified text or a regular expression. It displays a Find 
dialog box which lets you specify search criteria such as what text to find and which direction to search.

Hint: If you select text before choosing this command, the selected text appears as the default search 
string in the dialog box.

The search commences at the current cursor location of the active document. If the search is successful, 
the matcing text is highlighted. If it fails, the status line displays the message "Pattern not found."

Note: Desktop Editor cannot find text that spans two lines.



Search Find Again Command
Function name: find_again

Default key: Ctrl+A
This command continues the search begun by the Search Find command. The search resumes from the 
current cursor position in the active document and proceeds in the direction previously specified.
If the search is successful, the matching text is highlighted. If it fails, the status line displays the message 
"Pattern not found."



Search Replace Command
Function name: replace

Default key: Ctrl+R
This command displays a Replace dialog box which lets you find and replace occurrences of text with 
different text. You can also perform a search and replace on a regular expression.
Hint: If you select some text before using this command, that text appears as the default search string in

the dialog box.
The search commences at the current cursor location of the active document. If the search succeeds (and
if you checked the "Confirm Changes" check box), the matching text is highlighted and you can choose to
replace or skip each occurrence. The status line reports how many changes were made.
If the search fails, the status line displays the message "Pattern not found."

Note: Desktop Editor cannot find text that spans two lines.



Search Find Files Containing Command
Function name: find_files_containing

Default key: Ctrl+F
This command displays the Find Files Containing dialog box, which lets you search the disk for files which
contain specified text or a regular expression. Specify the text to search for, the types of files to search 
and a directory.
If one or more files are found to contain the search string, the List Found Files dialog box appears. You 
can open any of the files from here and edit it.
Hint: After opening a found file, the first occurrence of the search text is scrolled into view and 

highlighted. Use Ctrl+A to find other occurrences.
Another way to locate files that match certain criteria is to use SuperFind (on the Norton Desktop's Tools 
menu). Besides finding files that contain a specific string, you can further narrow your search by 
specifying size, date or attribute filters. To edit the found files, select the files and drag them into the editor
window.



Search List Found Files Command
Function name: list_files_containing

Default key: Ctrl+L
This command displays a List Found Files dialog box containing the the files located using the Search 
Find Files Containing command. Use it to examine each file.
As you open each file from this dialog box, it is removed from the list. This makes it easy to process the 
files one-by-one, examining and/or making changes to each file.
Hint: After opening a found file, the first occurrence of the search text is scrolled into view and 

automatically highlighted. Use Ctrl+A to find other occurrences.



Search Goto Line Command
Function name: goto_line

Default key: Ctrl+G
This command displays a Goto Line dialog box which lets you enter the number of the line to jump to.
The active document is scrolled to the requested line. If any text is currently selected, the selection is 
extended to include that line.
Hint: This command is particularly useful to programmers. When a compiler reports an error, you can 

get to the problem line quickly.



The Options Menu
Commands in this menu set editor and document preferences.

Document Preferences Alt+O,D Set margin, tabs, indent, etc. for current document only or 
defaults for all documents.

Editor Preferences Alt+O,E Set screen font, cursor, backup, autosave.
Key Assignments Alt+O,K Customize keystrokes for fast access to editor functions.



Options Document Preferences Command
Function name: document_preferences

Default key: F4
This command displays a Document Preferences dialog box which lets you select options for the current 
active document.
Note: Document preference settings are used for the current document for the current editing session. 

They are not saved with the document. However, you can specify default settings, to be used in all 
session, from the Editor Preferences dialog box.

Related Topics:
Customizing the Desktop Editor
Document Preferences Dialog Box
The Editor Preferences Command
The Key Assignments Command



Options Editor Preferences Command
Function name: (none)

Default key: Alt+O,E
This command displays an Editor Preferences dialog box which lets you select options to be used by the 
editor for all documents. These include the display font, cursor style, backup, autosave, and undo level 
preferences.
Note: Editor preference settings are saved and used in the current editing session and remembered for 

use in future sessions.
Related Topics:

Customizing Desktop Editor
Editor Preferences Dialog Box
The Page Setup Command
The Editor Preferences Command
The Key Assignments Command



Options Key Assignments Command
Function name: (none)

Default key: Alt+O,K
This command displays a Key Assignments dialog box which lets you customize the way the editor 
interprets and acts on keystrokes. You can assign your own favorite shortcut keys to any editor function.
You can also use this command to see what keystrokes are currently mapped to the editor functions.
See Editor Functions Alphabetically
or Editor Functions by Functional Groups
for summaries of available editor functions.
Note: Be sure to use the Save button in the dialog box if you want your key assignments to be 

remembered in future editing sessions.
Related Topics:

Customizing Desktop Editor
Key Assignments Dialog Box
The Document Preferences Command
The Editor Preferences Command



The Window Menu
This menu lets you select, create, and manipulate Desktop Editor's document windows. 

New Window Alt+W,N Creates an additional window on the document in the active window.
Cascade Alt+W,C Rearranges windows in a cascading pattern.

Tile Alt+W,T Rearranges windows in a non-overlapping pattern.
Arrange     Icons  Alt+W,A Tidies up any minimized document windows.

1 to n Alt+W,n Activates one of the document windows, restoring it to its standard size if it 
is an icon.

Related Topics:
Managing Multiple Windows
Window Control Functions



Window New Window command
Function name: new_window

Default key: Alt+W,C
Creates a new document window and activates the new window.
If the same document is open in two or more document windows, editing the document in any of the 
windows affects the contents of the document. Also, any file-related commands, such as changing the 
name via the Save As... command, affect all windows. However, the current cursor position, selection, 
and similar attributes are tracked separately for each window.
Related Topics:

Managing Multiple Windows
Window Control Functions



Window Cascade command
Function name: cascade

Default key: Alt+W,C
Reorganizes all open document windows in a cascading pattern. This usually makes it possible to see the
titles of all the open windows, while making one entire window visible.
Any minimized windows remain as icons.
Related Topics:

Managing Multiple Windows
Window Control Functions



Window Tile command
Function name: tile

Default key: Alt+W,T
Reorganizes all open document windows in a tiled (non-overlapping) pattern. This makes it possible to 
see at least a small part of all of the open windows.
Any minimized windows remain as icons.
Related Topics:

Managing Multiple Windows
Window Control Functions



Window Arrange Icons command
Function name: (none)

Default key: Alt+W,A
Aligns all minimized document windows along the bottom of the Desktop Editor application window.
Related Topics:

Managing Multiple Windows
Window Control Functions



The Help Menu
Commands in this menu provide help on using Desktop Editor and access to the standard Windows help-
for-help information. 

Index Alt+H,I Get to the index for the help for this program.
Keyboard Alt+H,K Quick reference to keystrokes for this program.

Commands Alt+H,C Menu commands. You can also get help on a particular menu item by selecting it 
and then pressing F1.

Procedures Alt+H,P Common procedures and general topics.
Using Help Alt+H,U How to use the Windows help system. You can press F1 now if you want to see 

this help file.
About... Alt+H,A Product name, copyright, credits, version of this program, and useful system 

statistics.



Find Dialog Box
This dialog box appears when you choose the Search Find command. Use it to specify the text you want 
to find and which direction to search.
Pattern

Enter the text you want to find. Or, click the prompt button (or press Alt+ ) to choose from a list of 
previously-used search strings. 
Note: By default, Desktop Editor uses any currently selected text as the search string.
If you check the Regular Expression box, you can include regular expression wildcards in the text.
Note: Desktop Editor cannot find text that spans two lines.

Match Upper/Lowercase
When this check box is checked, Desktop Editor checks the case of the text in the Pattern box and 
returns only exact matches.
When cleared, the editor considers text a match even when the case is not the same. For example, 
goto matches GOTO and Goto.

Regular Expression
Check this if you want to enable the powerful and flexible regular expression pattern matching. Leave 
this unchecked (for speed) if you simply want to locate a string.

Next
Click this or press Enter to confirm the settings and begin searching forward from the cursor location. If 
a match is found, the found text is highlighted.

Previous
Confirms the settings and begins searching backward from the cursor location.

Related Topics:
Searching with Regular Expressions
Finding Files that Contain Specified Text
Search Functions



Replace Dialog Box
This dialog box appears when you use the Search Replace command. Use it to specify the text you want
to find and the text which replaces it. The replacement search always proceeds forward from the current 
cursor location in the active document.
Search For

Enter the text you want to find. Or, click the prompt button (or press Alt+ ) to choose from a list of 
previously-used search strings. 
Note: By default, Desktop Editor uses any currently selected text as the search string.
If you check the Regular Expression box, you can include regular expression wildcards in the text.
Note: Desktop Editor cannot find text that spans two lines.

Replace With
Enter the text you want to use as the replacement string. Or, click the prompt button (or press Alt+ ) to 
choose from a list of previously-used replacement strings. You cannot use a text wildcards in this text 
box.
If you leave this field blank, each occurrence of the search string is deleted (that is, replaced with 
nothing).

Match Upper/Lowercase
When this check box is checked, Desktop Editor checks the case of the text in the Pattern box and 
returns only exact matches.
When cleared, the editor considers text a match even when the case is not the same. For example, 
goto matches GOTO and Goto.

Regular Expression
Check this if you want to enable the powerful and flexible regular expression pattern matching. Leave 
this unchecked (for speed) if you simply want to locate a string.

Confirm Changes
Check this if you want to be prompted before a change is performed. When unchecked, the editor 
replaces all occurrences of the Search For text, starting at the cursor location and proceeding to the 
end of the file, without prompting you.
Hints: It is wise to leave this checked and confirm the first one or two changes. When satisfied that all 

is well, you can uncheck this checkbox let the editor quickly finish the job.
Repeated use of the Undo command on the Edit menu can repair the effects of undesired 
changes.

OK
Click this or press Enter to confirm the settings and begin searching forward from the cursor location.
If Confirm Changes is checked, you are prompted to accept or skip each occurrence of the found text. 
Otherwise, the editor automatically replaces all occurrences from the cursor location onward.
The number of changes made appears on the status line.

Related Topics:
Searching with Regular Expressions
Finding Files that Contain Specific Text
Search Functions



Goto Line Dialog Box
This dialog box appears when you use the Search Goto Line command. Use it to specify the line number
at which to position the cursor.
Line Number

Enter a number between 0 and 32,365.
The active document is scrolled to the requested line. If any text is currently selected, the selection is 
extended to include that line.
Related Topics:

The Goto Line Command
Cursor Motion Functions
Search Functions



Page Setup Dialog Box
This dialog box appears when you use the Page Setup command on the File menu. It sets page 
formatting options that take effect the next time you use the Print command.
Header and Footer

Enter one line of text to be centered at the top (a header) and/or bottom (a footer) of each page. Or, 
click the prompt button (or press Alt+ ) to choose from a list of previously-used settings.
You can embed the following special-purpose codes in the text:

%f Full path and filename of active document
%d Current date and time
%p Current page number

To omit a header or footer, leave its text box empty.
Margins

Set the print margins. The units of measure are the standard units used in your country (inches or 
centimeters), as set in the Windows Control Panel.

Font...
Click this to display a Printer Font dialog box which lets you choose a typeface and size for the printed 
output. The entire document, including headers and footers, uses the selected font. The specified 
settings are used for the current session and all subsequent sessions, until changed.

OK
Click this to confirm your settings. Use the File Print command to start printing.

Related Topics:
Printing a Document
Printing a Block of Text
The File Printer Setup Command
The File Print Command
Printer Font Dialog Box



Printer Font Dialog Box
This dialog box appears when you click the Font... button from the Page Setup dialog box. Use this dialog
box to choose a typeface and size for your printed output.
Font

Choose from the list of available fonts. Only fonts available for the current printer are shown (use the 
File Printer Setup command to choose a different printer and the Windows Control Panel to install 
additional fonts).

Size
Select from the list of available sizes for the currently-selected font.

OK
Click this to confirm you settings. Desktop Editor remembers your settings and uses them in 
subsequent print jobs.

Related Topics:
Printing a Document
The Page Setup Command
The File Printer Setup Command
The File Print Command



Compare Dialog Box
This dialog box appears when you use the Compare command from the File menu. Use it to choose the 
two files to compare, their starting line numbers, and how to display the ouput.
File 1 and File 2

Enter the names of the files to compare.
Or, click the prompt button (or press Alt+ ) to choose from a list of previously-used files.

Or, click Browse... to locate the desired files.
Line

To compare all lines in both files, use the default setting of 1. Otherwise, specify a starting line number 
for each file.

Display
* Horizontal: The files are displayed one above the other.
* Vertical: The files are displayed side-by-side.

Browse...
Click this button to display a Standard Browse... dialog box which lets you choose a file to compare. 
The selected file is displayed in the File text box which is active.

Related Topics:
Comparing Two Files
The File Compare Command



Find Files Containing Dialog Box
This dialog box appears when you use the Find Files Containing command from the Search menu. It 
lets you choose what type(s) of files to scan and specify the text you want to find.
Pattern

Enter the text you want to find. Or, click the prompt button (or press Alt+ ) to choose from a list of 
previously-used search strings.
If you check the Regular Expression check box, you can include regular expression wildcards in the 
text.
Note: Desktop Editor cannot find text that spans two lines.

Files
Enter one or more wildcard filespecs separated by spaces. Or, click the prompt button (or press Alt+ ) 
to choose from a list of previously-used file specifications.
You can include a drive ID and path in any filespec. If omitted, only files in the current default directory 
are searched. Use the Directory... button to select a default directory. Examples:

*.c *.h *.asm find a variable or function name in several types of program source code 
files

c:\wp\ltrs\*.doc c:\wp\old\*.* look at files in two directories
Match Upper/Lowercase

When this check box is checked, Desktop Editor checks the case of the text in the Pattern box and 
returns only exact matches.
When cleared, the editor considers text a match even when the case is not the same. For example, 
goto matches GOTO and Goto.

Regular Expression
Check this if you want to enable the powerful and flexible regular expression pattern matching. Leave 
this unchecked (for speed) if you simply want to locate a string.

Directory...
Click this to display a Select Search Directory dialog box which lets you select a default directory to 
search. If you enter a filespec without a path in the Files text box, it is assumed to be in this directory.

OK
Confirms the settings and begins searching. If any files match the search criteria, the List Found Files 
dialog box appears, displaying the path and name of each file. Double-click on the file to open it for 
editing. Choose List Found Files again to select additional files.

Related Topics:
Finding Files that Contain Specified Text
Searching with Regular Expressions
The List Found Files Command
Search Functions



Directory Browse Dialog Box
This dialog box appears when you click the Directory... button from the Find Files Containing dialog box. 
Use it to choose a directory to search.
Drive

Choose a drive from the drop-down list box or type its drive ID letter.
Directory

Select the desired directory from the tree.
OK

Confirms the settings, closes the dialog box, and returns the result.
Related Topics:

Finding Files that Contain Specified Text
Searching with Regular Expressions
The List Found Files Command
Search Functions



List Found Files Dialog Box
This dialog box appears when a search started by the Search Find Files Containing command locates 
one or more files. Thereafter, you can use the List Found Files command to view the list and choose 
files to open.
Pattern and Filter

These are displayed to remind you of the search criteria used to obtain the files in this list.
Files

This lists the files found by the most recent use of the Search Find Files Containing command, less 
any files that have already been opened for editing.
Scroll through the list to select a file. Click Open to open the file and remove it from the list.

Open
This opens the selected file for editing. On future uses of the Search List Found Files command, the 
opened file does not appear in the list.

Related Topics:
Finding Files that Contain Specified Text
Searching with Regular Expressions
The List Found Files Command
Search Functions



Editor Preferences Dialog Box
This dialog box appears when you use the Editor Preferences command from the Options menu. It lets 
you customize some Desktop Editor features.
Changes made here are saved automatically and used each time the editor starts.
Font

Select one of the radio buttons. The font and size that is displayed depends on settings in your 
SYSTEM.INI file in the [boot] section:
* System Fixed Font depends on fixedfon.fon=
* ANSI Fixed Font depends on fonts.fon=
* OEM Fixed Font depends on oemfonts.fon=
The OEM font contains the IBM text-mode box-and-line drawing characters.

Cursor
Select a radio button specifying how you want the text cursor to be displayed. Check the Blinking check
box to enable a blinking cursor.
* Block  Covers the current character.
* Underline  Underlines the current character.
* Vertical Bar  Standard "insertion point" caret, displayed between characters.
* Blinking  The cursor blinks when this is checked. You can set the blink rate from the Windows 

Control Panel.
Autosave

If you want the editor to automatically save open files, put non-zero values in either or both of the text 
boxes.

Undo Levels
Sets how many edit changes are remembered for the undo function. A large number tends to use up 
memory. Setting this to 0 disables the undo function.

(other options)
Check or clear any of these checkboxes:
Restore Session

When checked, each file that was open last time you exited the editor is opened automatically next 
time you start the editor.

Typing Replaces Selection
When checked, the editor follows the Windows standard convention of replacing any selected text 
with the first character typed or pasted. When unchecked, typing or pasting inserts the text to the left 
of the current selection.

Make Backup Files
When checked, each time you save a file, the editor makes a copy of the original, giving it the same 
name, but with an extension of .BAK.

File Locking
When checked, the editor locks each file when you open it and unlocks it only when you close its 
window. When a file is locked, no other program can delete or modify it. It only has an effect if a 
network is active and/or the program SHARE.EXE has been executed.

Cut/Copy Current Line if No Text is Selected
When checked, you can quickly cut or copy the current line using the standard cut or copy 
keystrokes (without having to first select the line). When unchecked, you can cut or copy a line by 
using the keys assigned to the cut_line or copy_line functions.

Remove Trailing Spaces
When checked, the editor discards spaces and tabs characters that are at the end of each line.

OK
Confirms your settings and remembers them for the current and future editing sessions.

Related Topics:
Customizing Desktop Editor
The Editor Preferences Command



The Document Preferences Command
The Key Assignments Command



Document Preferences Dialog Box
This dialog box appears when you choose the Document Preferences command from the Options 
menu. It lets you customize settings for the current active document.
Note: These settings are used for the current document during the current editing session. They are not 

saved with the document. However, you can set default preferences using the Options Editor 
Preferences command.

Tab Spacing
Sets your desired tab-stops for the current document. When you press the Tab key, the cursor 
advances this many character-widths.

Right Margin
Sets the wrapping-point to be used when word wrap is in effect. Enter a number of columns. The right 
margin is ignored unless the Word Wrap checkbox is checked (see below).
Note: To set the margins for printing, use the File Page Setup command.

(other options)
Check or clear any of these checkboxes:
Word Wrap

Check this to enable word-wrap in the current document for the current editing session. You can 
toggle this setting by using the Word Wrap command on the Edit menu.
*When checked, typing beyond the right margin causes the current word to be moved down to the 
next lower line. Also, this enables the Wrap Paragraph command of the Edit menu.
*When cleared, the Right Margin setting is ignored and you can type lines as long as your fingers 
hold out.

Auto Indent
When checked, and you press Enter, the editor positions the cursor directly below the first non-blank 
character in the previous line. This is handy for programmers.

Expand Tabs with Spaces
When checked, the editor replaces TAB characters (0x09) with a series of spaces (0x20) as it reads 
a file. It uses the tab settings set above. When it saves the file, all TAB characters are gone.

Save as Default Settings
When checked, the above settings are used as the defaults for documents opened in the future. 
Otherwise, the settings are used only for the current document during the current session.

OK
Confirms your settings and resumes editing the active document with the new settings.

Related Topics:
Customizing Desktop Editor
The Editor Preferences Command
The Document Preferences Command
The Key Assignments Command



Key Assignments Dialog Box
This dialog box appears when you use the Key Assignments command from the Options menu. It lets 
you associate custom keystrokes with editor functions. This dialog is also handy for looking up the 
currently-assigned keystroke for an editor function.
Note: In order to make a permanent keystroke assignment, you must select a function and a key, click 

Assign, then click Save.
Function

Select a function from the scrolling list. Type a function name or press  to move the focus into the list. 
As you move the cursor, the current keystroke for that function is displayed in the Current Keys box 
below.
See Editor Functions Alphabetically
or Editor Functions by Functional Groups
for summaries.

Key
Select a keystroke from the scrolling list. Only the listed keystrokes are accepted.

Assign and Unassign
When a name is in both the Function and Key text boxes, you can click these buttons to associate a 
keystroke with a function or dissolve the association. You can continue assigning and unassigning until 
you click OK.
Hint: You can assign more than one keystroke to a function. For instance, you can add Alt+C to the 

keys for the copy function while retaining the standard Ctrl+Insert for compatibility.
Enable Menu Accelerators

When this is checked, the standard menu accelerator keys such as Alt+F (to drop-down the File menu) 
take precedence over individual keystroke assignments. In general, this is the normal situation in 
Windows applications.
If you prefer to be able to use the normally preempted keystrokes for editing functions (for instance, if 
you want Alt+F to immediately save a file), you can clear this checkbox. You can still access the menus
with the mouse, or by pressing and releasing Alt.

Keyboard Configuration File
Load and Save

When Desktop Editor starts, it reads a file named DEFAULT.KEY from its home directory to map 
keystrokes to functions. If you want to maintain more than one set of keystroke assignments, you can 
input a new name in this text box and click Save. Then, to load that set later, input its name in this box 
and click Load.

OK
Confirms your settings and resumes editing the active document with the new settings. The changes 
are in effect only for the current session unless you use the Save button to save the assignments.

Related Topics:
Customizing Desktop Editor
The Key Assignments Command
The Editor Preferences Command
The Document Preferences Command
Editor Functions



Desktop Editor Keys
The Desktop Editor lets you assign your own favorite keystrokes to any of its over 100 editing functions. 
See Customizing Editor Keystrokes for details.
For information on default keystroke assignments, review the topics below:

Cursor Movement
Selecting Text
Function Keys

Other Keys
 
Related Topics:

The Key Assignments Command
Editor Functions
Using Editor Macros



Expandable/Collapsible Tree

This method of displaying your directory structure lets you expand and collapse branches of the directory 
tree in the tree pane. To expand a branch, double-click a  folder. To collapse, double-click a 

 folder.
When using expandable/collapsible trees, you may experience short delays as Norton Desktop reads the 
disk for directory information. To switch to a faster method of tree display, uncheck the Use Collapsible 
Tree menu item on the Tree menu.



Using Expandable Tree Displays
Norton Desktop features two methods of displaying and utilizing directory tree displays. To toggle 
between the two methods, choose Use Collapsible Tree from the Tree menu. When this menu item has 
a check mark to its left, expandable/collapsible trees are enabled in all drive windows and Standard 
Browse... dialog boxes.

When using expandable/collapsible trees, you never need to refresh the tree display, but you may have to
wait for short periods as Norton Desktop reads your disk for directory information.

Initially, the tree is mostly collapsed, displaying only directories that are at the same level as the current 
directory.
To expand a branch:
* Double-click the  icon.
* Or, select the branch and press + (plus) on the numeric keypad.
* Or, choose the Tree Expand One Level command.
To expand all branches:
* Press Ctrl+* (asterisk)
* Or, choose the Tree Expand All command.

To collapse a branch:
* Double-click the  icon.
* Or, select the branch and press - (minus) on the numeric keypad.
* Or, choose the Tree Collapse Branch command.





word
For the purposes of word-wrap:

An unbroken sequence of non-blank characters.
As defined for cursor motion, selection, and deletion:

A sequence of characters unbroken by space, tab, or any common programing text 
delimiters such as ; , { } ( ), etc.



paragraph
A sequence of lines of text, containing no blank lines.
When determining how to wrap a paragraph, the editor looks backward from the cursor 
location until it finds a blank line, then assumes that the paragraph includes all lines after 
that, down to, but not including, the first blank line.



status line

The Desktop Editor status line, at the bottom of its application window, displays 
information about the current active edit window.
Information, including error messages and search-and-replace status is displayed 
momentarily on the left side of the status line, until the next keystroke or mouse click.



delimiter
When using editor functions to advance or select by "words," the following characters are 
considered as word-ending delimiters:
tab (0x09)
space (0x20)
end-of-line
_ ( ) " ' , # $ @ ! % ^ & * { } [ ] \ ? / | < > ; . + - = ~ :



regular expression "wildcard" codes
? any single character or space
* zero or more characters or spaces
[chars] any one of the characters between [ and ]
[~chars] any one character except those after the ~
[c1-c2] any one of the range of characters c1 to c2
@ zero or more of the previous character
% or < the beginning of a line
$ or > the end of a line
\t a tab character (0x08)
\f a formfeed character (0x0c)
\c the literal character c; e.g. \\ means \



wildcard file specification
You can use wildcard characters to specify a set of files which share similar names.    The 
wildcard characters are:
* any 1-to-8 character filename (or 0-to-3 character file extension)
? any single character

Examples:
*.* any filename and any extension
*.bak any filename with an extension of .BAK
*.? any file that has a 1-character extension
*. any file that has no extension
*.WK? any filename that has an extension that starts with .WK and then any other single

character
rpt??jul.* any filename starting with RPT, then any two characters, then JUL, and having 

any extension





Cursor Motion Key Defaults
Key Default Editor Function

 cursor_left
    Ctrl+

 word_left

 cursor_right
    Ctrl+

 word_right

 cursor_up
    Ctrl+

 window_down

 cursor_down
    Ctrl+

 window_up
PgUp  page_up
    Ctrl+PgUp  top_of_window
PgDn  page_down
    Ctrl+PgDn  bottom_of_window
Home  beginning_of_line
    Ctrl+Home  beginning_of_buffer
End  end_of_line
    Ctrl+End  end_of_buffer
Tab  tab_right
Enter  enter
Ctrl+G  goto_line





Text Selection Key Defaults
Key Default Editor Function
Shift+

 select_line_up
Shift+

 select_line_down
Shift+

 select_char_left
    Shift+Ctrl+

 select_word_left
Shift+

 select_char_right
    Shift+Ctrl+

 select_word_right
Shift+PgUp  select_page_up
Shift+PgDn  select_page_down
Shift+Home  select_to_bol
    Shift+Ctrl+Home  select_to_top
Shift+End  select_to_eol
    Shift+Ctrl+End  select_to_end
Esc  unmark_block
Note: The default keys are assigned so that pressing Shift along with a cursor motion key 

selects text as the cursor moves.





F1...F12 Function Key Defaults
Key Default Editor Function
F1  editor_help
F2  save_file
F3  open_file
F4  document_preferences
    Ctrl+F4  close_window
F5 (none)
    Ctrl+F5  restore_window
F6 (none)
    Ctrl+F6  next_window
F7  record_macro
F8  play_macro
F9 (none)
F10 (none)
    Ctrl+F10  zoom_window
F12  wrap_para





Other Key Defaults
Key Default Editor Function
BkSp  backspace
    Alt+BkSp  undo
    Ctrl+BkSp  delete_word_left
Del  delete
    Ctrl+Del  delete_word_right
    Shift+Del  cut
Ins  toggle_insert
    Ctrl+Ins  copy
    Shift+Ins  paste
Enter  enter
numpad *  undo
numpad +  copy
numpad -  cut
Tab  tab_right
Alt+ -  close_window
Alt+D  delete_line
Alt+K  delete_to_eol
Alt+N  next_window
Alt+P  print
Alt+R  batch_help
Alt+V  about
Alt+X  save_all_exit





Desktop Editor Procedures
Using Desktop Editor
Customizing Desktop Editor
Customizing Editor Keystrokes
Comparing Two Files
Finding Which Key Performs an Editor Function
Printing All of or Part of a Document
Searching for Files that Contain Specific Text
Searching for Specified Text in an Open Document
Searching with Regular Expressions
Using Editor Macros
Using Multiple Edit Windows





Using Desktop Editor
Desktop Editor is the default text editor supplied with Norton Desktop for Windows. It is 
used automatically when you select the Edit command on the Norton Desktop's File menu 
and it is the editor for the Batch Builder and Macro Builder applications.
Features of Desktop Editor include:
* Customizable keyboard; assign keystrokes to over 100 editing functions.
* Employs MDI; you can open many edit windows, tile, cascade, and iconize windows. You 

can open more than one window on a document.
* Uses as much memory as it needs for fast editing of large files.
* Flexible find and replace, including use of "regular expression" text wildcards; 

remembers recently-used search strings.
* Search for files containing specified word or phrase and easily open them for inspection 

or editing.
* Customizable auto-save and automatic backup options.
* Compare two files.
* Auto-indent (handy for programmers).
* Supports word wrapping and paragraph reformatting for simple word processing tasks.
* Remembers recently-edited files; can reopen the set of files used in last edit session.

Ways to start Desktop Editor:
* Select Desktop Editor from the Norton Desktop Tools menu. Then choose File Open 

on the editor's menu to select a file to edit. 
Desktop Editor is automatically started when you use the Batch Builder or Macro 
Builder commands on the Tools menu.

* Or, double-click its icon in a Quick Access or Program Manager group window.
* Or, select one or more files in a desktop drive window and choose the Edit command 

from the desktop's File menu.
* Or, if the .TXT file extension is associated with Desktop Editor, just double-click any .TXT 

file from a drive window or File Manager.
Opening files when Desktop Editor is running:
* Choose the editor's File Open command.
* Or, you can drag files from a drive window into the editor application window or into its 

minimized application icon.
* Or, to open a file that you recently edited, choose it from the list at the bottom of the 

editor's File menu.
* Or, after using the editor's Find Files Containing command, use the List Found Files 

command to open any of the found files.
To automatically reload a set of files next time you start:

1 Use the Options Editor Preferences command and check the "Restore Session" check 
box.

2 Open the files you want to load the next time you start the editor.
3 Use the File Exit command to quit the editor (Note: don't close the files individually).
4 Next time you start the editor, it automatically opens the same files, arranging the 

windows in a cascading pattern.





Using Desktop Editor Macros
The Desktop Editor allows you to record and play back a single keyboard macro. You can use
this to automate simple, repetitititive tasks.
To record an editor macro:

1 Press F7 (Alt+E,R) to start recording. The status line displays the word REC to indicate it
is recording.

2 Type text and use menu commands and keystroke functions to accomplish the desired 
task.

3 Press F7 again (Alt+E,S) to stop recording. The status line displays "Keyboard macro 
defined."

To play back the editor macro:
1 Make sure the desired window is active and the cursor is positioned correctly.
2 Press F8 (Alt+E,P) to begin replaying the macro.

Notes: Events that take place in dialog boxes are NOT recorded.
Up to 256 editing events can be recorded. 
The current macro is not saved between editing sessions.

Hint: The Macro Builder utility, found of the Norton Desktop Tools menu, is far more 
flexible than this editor-internal feature. It provides a full-blown programming 
language, including looping constructs, custom dialog boxes, variables, and more. In 
addition, you can add "named macros" to the editor's Control Menu.





Using Multiple Edit Windows
Desktop Editor conforms to the Multiple Document Interface (MDI) standard to display and 
interact with document files. This interface lets you see more than one document at a time 
and provides standard ways to access the documents.
To activate a window (bring it to the front):

Click any part of it, select it from the window list under the Window menu, or press 
Ctrl+F6 until it moves to the front.

To enlarge a window to see more text:
First maximize the application window (click the maximize button or press 
Alt+spacebar,X), then maximize the individual document window (click the maximize 
button or press Alt+hyphen, X).

To see two parts of a document simultaneously:
Activate the desired window. Use the Open Window command of the Window menu. 
You can scroll the windows independently.

To see as much as possible of two documents:
First maximize the application window, then choose the Window Tile command 
(Alt+W,T).

To see the title bars of all windows:
Choose the Window Cascade command (Alt+W,C).

To iconize a window:
Minimize the window into an icon (click the minimize button or press Alt+hyphen,N). It 
is now displayed at the bottom of the application window.

To restore an icon to a normal-size window:
Double-click the icon, or press Ctrl+F6 until it is highlighted, then press Alt+Hyphen,X 
to maximize it. You can also select it from the Window menu.

To tidy up window icons:
Use the Window Arrange Icons command (Alt+W,A).





Searching with Regular Expressions
The Find, Replace, and Find Files Containing commands of the Search menu provide a 
powerful text wildcard search capability called "regular expression" searching.
Although not the full-blown "grep" utility known to UNIX programmers, this feature can be 
useful in many situations. For instance, it can be used for locating:
* Text in formatted layouts, such as phone numbers, zip codes, text in parentheses, quoted 

strings, etc.
* Programming elements and idioms; for instance, locating the start of any procedure.
* Proper names or the start of a sentence (i.e., first letter capitalized).
* Blank lines.
* A sequence of digits.
* Lines beginning or ending with some specified text.
* Alternate spellings of a word or name (e.g., Kathy or Cathy).
* Leading or trailing blanks in a line.

One of the powers of this feature over simple text-matching is that you can use it to select 
entire words or lines that contain a match. For instance,

goto selects just that single word when found
<*goto*> selects the entire line that contains the word

You can use this feature in editor macros to automate some operations. For instance, you 
can easily copy the matching line or word to the clipboard and paste it to a second file.

Examples
(click  for special code definitions)
[KC]athy  Kathy or Cathy
[KC]athy [A-Z][~ ]@  Kathy or Cathy and her last name
[A-Z][a-z]@ [A-Z][~ ]@ any two-word proper name
[2-9]??-[0-9]??? any phone number
<*[2-9]??-[0-9]???*> a line that contains any phone number
<* [A-Za-z]@(*){> a line that defines a C function; e.g., int DoIt(x,y){
<{ finds "{" when at the start of a line
<[ \t][ \t]> any line containing only blanks or tabs
\\[nrt] finds "\n" or "\r" or "\t"

(for special code definitions, click  )





Printing
The Desktop Editor provides printing capabilities that will more than satisfy your needs when
you are working with text files, including font selection, and generation of page headers and 
footers. For more complex formatting, you may need to open the file using a full-featured 
word processor.
To print an entire document:

1 Activate the document you want to print by clicking its window title.
2 Deselect any selected text by pressing Esc.
3 Choose the File Printer Setup command to specify a printer.
4 Choose the File Page Setup command to select printing options. You can type text to 

be displayed at the bottom and/or top of each page, as well as select a font for the 
printout.

5 Choose the File Print command to send the file to the printer.
To print a partial document

1 Select the portion of the document you want to print.
2 Follow the steps above. You can modify the header or footer to indicate that this is a 

partial printout. All lines having any text selected are printed.





Comparing Two Files
Desktop Editor provides a handy file-comparison feature. This is especially useful for 
programmers who wish to check for differences between versions of program source code.
To compare two files:
* (optional) Maximize the editor window and minimize all open documents. This provides 

screen space to show larger document windows when displayed.
1 Choose the Compare command of the File menu to bring up the Compare dialog box.
2 Select the two files you wish to compare.
3 Leave the "Line" input box set at "1" for both files.
4 Choose the "Horizontal" option if you wish the files to be displayed one-above-the other, 

or choose "Vertical" for a side-by-side display.
5 Click OK. The editor displays both files, highlighting the first difference it finds. If no 

differences are found, it displays a message on the status line.
6 The editor displays a small dialog box. Click Find Next... to advance through the files, or

click Cancel when satisfied.





Finding Text in an Open Document
Desktop Editor can search for simple text strings or for special text wildcards. See Searching 
with Regular Expressions for a description of the latter capability. See Searching for Files for 
a way to locate all files which contain a specified text string.
To search an entire document:

1 Open and activate the document you want to search.
2 Press Ctrl+Home to get to the top of the document (the search always starts at the 

current cursor location).
3 Press Ctrl+S or use the Find command of the Search menu to bring up the Find dialog 

box.
4 Enter the text you want to find into the Pattern text box.

Or, press Alt+{bmp symDnAro.Bmp} to choose from a list of recently-used search 
strings.
Or, you can select text before opening the dialog and the selected text is placed into the
text box automatically.

5 Uncheck the Match Upper/Lowercase check box to provide the best chance of finding a 
similar match. Leave the Regular Expressions check box unchecked to speed up the 
search.

6 Click Next to start searching. If any match is found, it is displayed and highlighted. 
Otherwise, "Pattern not found" is displayed in the status line.

To continue a search:
* Press Ctrl+A or use the Find Again command on the Search menu. If another match is

found, it is displayed and highlighted. Otherwise, "Pattern not found" is displayed in the 
status line.

To search backward through a document:
1 Position the cursor where you want the search to start.
2 Press Ctrl+S, and follow the steps described above, except use the Previous button in 

the dialog box to begin the search.
3 Pressing Ctrl+A continues the search backward through the document until it hits the 

top of the file.





Finding Files that Contain Specified Text
Desktop Editor can search the disk for files containing a specified string of text. This is 
particularly useful for programmers wishing to inspect or modify all source code files that 
use a particular function or variable.
To find files containing a search string:

1 Use the Find Files Containing command on the Search menu to bring up the Find 
Files Containing dialog box.

2 In the Pattern text box, enter the search string (it can contain regular expression 
wildcard characters). 
Or, select from the list of previously-used search strings.

3 In the Files text box, enter one or more wildcard file specifications separated by spaces.
Or, select from the list of previously-used filespecs.
Or, click Directory... and select the directory from the tree display.

4 Clear the Match Upper/Lowercase check box, unless you want the search to be case-
sensitive. 

5 Check the Regular Expression check box only if you have used text wildcards in the 
Pattern text box.

6 Click OK to start the search.
7 If any files containing the specified string are found, a list of filenames appears. Just 

double-click a filename to open it. The first occurrence of the found text is displayed.
To inspect or edit other files that contain the found string:

1 Use the List Found Files command on the Search menu to display the List Found Files 
dialog box.

2 Select a file from the scrolling list and click Open.
3 As you open files from this dialog, they are removed from the list.





Customizing Editor Keystrokes
Desktop Editor lets you customize the keyboard; you can assign any keystroke to any of over
100 editor functions.
Most users are satisfied with the default key assignments. However, when you are 
accustomed to another editor, you may find it convenient to change some Desktop Editor 
keystrokes to match your old habits (so your fingers can do the thinking...).
To add a keystroke to a function:

1 Peruse the Editor Functions by Groups help topic to familiarize yourself with the available
functions.

2 Use the Key Assignments command on the Options menu to display the Key 
Assignments dialog box.

3 Press  and scroll through the Functions list box until you highlight the function you want
to access; its name appears in the box on top.

The Current Keys box at the bottom displays what key or keys are currently assigned 
to the function. You are about to add another keystroke to those assigned to the function.
4 Press Tab and scroll through the Keys list box until you find the keystroke you want to
use to access that function.

The Current Function box at the bottom of the dialog box displays what function (if any) 
is currently assigned to that keystroke. If you proceed, you lose that assignment, since a 
key can be assigned to only one function.

5 Click Assign.
6 Click Save to save the changes to the file, DEFAULT.KEY.
7 Click OK.

To change a keystroke assignment:
1 Use the Key Assignments command on the Options menu to display the Key 

Assignments dialog box.
2 Press Tab and  and scroll through the Keys list box until you find the keystroke you 

want to change.
The Current Function box at the bottom displays what function (if any) is currently 

assigned to that keystroke. If you proceed, you lose that assignment, since a key can be 
assigned to only one function.
3 Press Shift+Tab and  and scroll through the Functions list box until you find the 
editor function you want to map to the selected keystroke.

4 Click Assign.
5 Click Save to make the assignment permanent.
6 Click OK.





Finding Which Key Performs an Editor Function
Desktop Editor features over one hundred editing functions. You can use this on-line help to 
learn the default keystroke assignments. Just peruse either of the topics:

Editor Functions Alphabetically
Editor Functions by Group

Since some keystrokes may have been reassigned (or if you wish avoid this help system), 
you can find the current key assignments as follows:
To see what key performs a function:

1 Use the Key Assignments command on the Options menu to bring up the Key 
Assignments dialog box.

2 Press  and scroll through the Functions list box until you highlight the function you want
to access; its name appears in the box on top.

The Current Keys box at the bottom displays what key or keys are currently assigned 
to the function.
3 Click Cancel to avoid changing any settings.





Customizing Desktop Editor
Desktop Editor lets you customize many of its features. If you are already familiar with 
another text editor, you can modify Desktop Editor to conform to your editing habits. And, as
you become comfortable with Desktop Editor, you can make minor adjustments to speed up 
common operations.
Some customization is automatic. For instance, Desktop Editor automatically remembers:
* Files that you have recently edited (they are placed on the File menu).
* Search strings you have previously used.
* File types recently used when finding files.
* Files that you have recently compared.
* Page printing settings, including margins, font face and size, headers, and footers.

Here are some other features and the menu commands that let you customize them:
Feature Menu command
Automatic file backups Options Editor Preferences
Automatic file saving Options Editor Preferences
Automatic line indenting Options Document Preferences
Automatic file loadingOptions Editor Preferences
Convert tabs to spaces Options Document Preferences
Cursor shape Options Editor Preferences
Features not on menus Options Key Assignments
File locking Options Editor Preferences
Header/Footer text Options Document Preferences
Keyboard macro Edit Record Macro (see Using Macros)
Keystroke assignments Options Key Assignments
Line indenting Options Document Preferences
Printer Font Options Document Preferences
Printer Margins Options Document Preferences
Programmer's indenting Options Document Preferences
Reload recent files Options Editor Preferences
Remove trailing spaces Options Editor Preferences
Screen Font Options Editor Preferences
Screen margin settings Options Document Preferences
Tab settings Options Document Preferences
Typing replaces selected text Options Editor Preferences
Undo levels Options Editor Preferences
Word wrapping Options Document Preferences

Although Desktop Editor does not remember keystroke macros between sessions, it is 
possible to use the Norton Desktop's Macro Builder to create any number of complex and 
sophisticated keyboard macros which you can access via the application Control-Menu or by 
using a single custom keystroke.
You can even use Norton Desktop's Batch Builder to display and choose from a list of your 
custom editor macros.



Editor Functions: Alphabetical List
A  about
B  backspace

 batch_help
 beginning_of_buffer

 beginning_of_line
 bottom_of_window

C  cascade
 change_case

 close_window
 compare

 copy
 copy_block

 copy_line
 cursor_down

 cursor_left
 cursor_right

 cursor_up
 cut

 cut_block
 cut_line

D  delete
 delete_line

 delete_to_eol
 delete_word_left

 delete_word_right
 document_preferences

E  editor_help
 end_of_buffer

 end_of_line
 enter

 exit
 exit_windows

F  find
 find_again

 find_files_containing
G  goto_line
H,I,J
L  list_files_containing

 lowercase
M
N  new_file

 new_window
 next_window

O  open_file
P  page_down

 page_up



 paste
 play_macro

 prev_window
 print

Q
R  record_macro

 replace
 restore_window

 revert
S  save_all

 save_all_exit
 save_all_exit_windows

 save_file
 save_file_close_window

 select_all
 select_char_left

 select_char_right
 select_line

 select_line_down
 select_line_up

 select_page_down
 select_page_up

 select_to_bol
 select_to_end

 select_to_eol
 select_to_top

 select_word
 select_word_left

 select_word_right
 split_line

 stamp
T  tab_right

 test_batch
 tile

 to_bottom
 to_center

 to_top
 toggle_backup

 toggle_insert
 toggle_wordwrap

 top_of_window
U  undo

 unmark_block
 uppercase

V
W  window_down

 window_up
 word_left

 word_right
 wrap_para



X,Y
Z  zoom_window



Editor Functions: Functional Groups
Cursor Motion
Cut, Copy, and Paste
Deleting Text
File Control
Lines
Paragraphs and Word Wrap
Searching and Replacing
Selecting Text
Window Control
Miscellaneous



Cursor Motion Functions
 beginning_of_buffer
 end_of_buffer
 top_of_window
 bottom_of_window
 beginning_of_line
 end_of_line
 page_up
 page_down
 cursor_up
 cursor_down
 word_left
 word_right
 cursor_left
 cursor_right
 window_up
 window_down
 to_top
 to_bottom
 to_center
 goto_line
 tab_right
 enter
 split_line



Cut, Copy, and Paste Functions
 copy
 copy_block
 copy_line
 cut
 cut_block
 cut_line
 paste
 undo



Delete Functions
 backspace
 delete
 delete_word_left
 delete_word_right
 delete_line
 delete_to_eol
 cut
 cut_line
 replace
 undo



File Functions
 new_file
 open_file
 save_file
 close_window
 save_file_close_window
 save_all
 save_all_exit
 save_all_exit_windows
 compare
 find_files_containing
 list_files_containing
 revert
 toggle_backup



Line Functions
 cursor_down
 cursor_up
 goto_line
 beginning_of_line
 end_of_line
 select_line
 select_line_down
 select_line_up
 select_to_bol
 select_to_eol
 copy_line
 cut_line
 copy
 cut
 delete_line
 delete_to_eol
 to_bottom
 to_center
 to_top
 window_down
 window_up
 enter
 split_line



Miscellaneous Functions
 about
 editor_help
 test_batch
 batch_help
 record_macro
 play_macro
 print
 stamp
 tab_right
 enter
 split_line
 undo
 change_case
 lowercase
 uppercase
 document_preferences
 toggle_backup
 toggle_insert
 toggle_wordwrap
 exit
 exit_windows
 save_all_exit_windows



Paragraph Functions
 wrap_para
 toggle_wordwrap
 enter
 split_line
 document_preferences



Text Selecting Functions
 select_all
 select_line
 select_word
 select_char_left
 select_char_right
 select_word_left
 select_word_right
 select_line_up
 select_line_down
 select_page_up
 select_page_down
 select_to_bol
 select_to_eol
 select_to_top
 select_to_end
 unmark_block

Note: The default keys are assigned so that pressing Shift along with a cursor motion key will
select text as the cursor moves.



Search and Replace Functions
 find
 find_again
 replace
 find_files_containing
 list_files_containing



Window Functions
 cascade
 tile
 restore_window
 zoom_window
 new_window
 new_file
 close_window
 prev_window
 next_window
 window_up
 window_down
 to_top
 to_bottom
 to_center

Related Topics:
Managing Multiple Windows



about
Displays the editor's version number, copyright notice and miscellaneous system 
information.
Default keystroke: Alt+V



backspace
If text is selected, deletes it; otherwise, deletes the character to the left of the cursor.
If the cursor is at the beginning of the line, appends the current line to the previous line.
Default keystroke: BkSp or Shift+BkSp



batch_help
Displays help text on each Batch Runner command and lets you select commands to enter 
into your current file.
Used when Desktop Editor is running as Batch Builder or Macro Builder; same as the 
Reference command under the Tools menu.
Default keystroke: Alt+R or Alt+T,R



beginning_of_buffer
Moves the cursor to the beginning of the document in the active window.
Default keystroke: Ctrl+Home



beginning_of_line
Moves the cursor to the beginning of the current line.
Default keystroke: Home



bottom_of_window
Moves the cursor to the bottom line of the window.
Default keystroke: Ctrl+PgDn



cascade
Resizes and rearranges all open windows in an overlapping pattern.    Same as the Cascade 
command on the Window menu.
Default keystroke: Alt+W,C



change_case
Within the selected block, changes the case of all letters; makes uppercase letters into 
lowercase, and lowercase into uppercase.
Default keystroke: (none)



close_window
Closes the active window (you get a chance to save the file if it has changed).
Same as the Close command on the File menu.    You may also close a window by double-
clicking its Document Control menu button.
Default keystroke: Ctrl+F4, or Alt+hyphen,C



compare
Prompts for two filenames, then compares them line-by-line.
Same as the Compare command on the File menu.
Default keystroke: Alt+F,E



copy
Copies the selected text to the Clipboard.
If no text is selected, but the Editor Preferences dialog option "Cut/Copy line if no text is 
selected" is checked, then this copies the entire line to the Clipboard.
Same as the Copy command on the Edit menu.
Default keystroke: Ctrl+Ins, or numpad +



copy_block
Copies the selected text to the Clipboard.
This variation of the copy command has no effect if no text is selected.
Default keystroke: (none)



copy_line
Copies the current line to the Clipboard.
Default keystroke: (none)



cursor_down
Moves the cursor down one line.
Default keystroke: DownArrow



cursor_left
Moves the cursor one character to the left or, if in the leftmost column, to the end of the line
above.
Default keystroke: LeftArrow



cursor_right
Moves the cursor one character to the right or, if at the end of the line, to the beginning of 
the line below.
Default keystroke: RightArrow



cursor_up
Moves the cursor up one line.
Default keystroke: UpArrow



cut
Removes the selected text, placing it in the Clipboard.
If no text is selected, but the editor's Preferences dialog option "Cut/Copy Line if No Text is 
Selected" is checked, then this cuts the entire line from the document and copies it to the 
Clipboard.
Same as the Cut command on the Edit menu.
Default keystroke: Shift+Del, or numpad -



cut_block
Removes the selected text, placing it in the Clipboard.
This variation of the cut command has no effect if no text is selected.
Default keystroke: (none)



cut_line
Removes the current line, placing it in the Clipboard.
Default keystroke: (none)



delete
Deletes the selected text.    If no text is selected, deletes the character at the cursor.
The text may be recovered via the undo function.
Default keystroke: Del



delete_line
Deletes the current line.
The line is NOT copied to the clipboard, but may be recovered via the undo function.
Default keystroke: Alt+D



delete_to_eol
Deletes all text from the cursor to the end of the current line.
The text may be recovered via the undo function.
Default keystroke: Alt+K



delete_word_left
If the cursor is in a word, deletes the text from the cursor to the beginning of the word.
If the character to the left of the cursor is a space or tab, deletes the text from the cursor to 
the previous non-blank character.
If the character to the left of the cursor is a delimiter other than space or tab, deletes that 
delimiter.
Default keystroke: Ctrl+BkSp



delete_word_right
If the cursor is in a word, deletes the text from the cursor to the end of the word.
If the character to the right of the cursor is a space or tab, deletes the text from the cursor 
to the next non-blank character.
If the character to the right of the cursor is a delimiter other than space or tab, deletes that 
delimiter.
Default keystroke: Ctrl+Del



document_preferences
Displays the Document Preferences dialog box to let you select options for the file in the 
active window.
Same as the Document Preferences command on the Options menu.
Default keystroke: F4



editor_help
Accesses the editor's help system.
Default keystroke: F1



end_of_buffer
Moves the cursor to the end of the document in the active window.
Default keystroke: Ctrl+End



end_of_line
Moves the cursor to the end of the current line.
Default keystroke: End



enter
In insert mode, inserts a carriage return and line feed, then moves the cursor to the 
beginning of the next line (or positions the cursor below the first non-blank character in the 
previous line if "Auto Indent" is checked in the Document Preferences dialog).
In overwrite mode, simply moves the cursor to the beginning of the next line.
Default keystroke: Enter



exit
Prompts you to save any modified files, then closes all windows and exits from the editor.
Same as the Exit command on the File menu.
Default keystroke: Alt+F4



exit_windows
Prompts you to save any modified files, then issues an ExitWindows call to end the current 
Windows session.    The session is not terminated unless all applications agree to terminate.
Default keystroke: (none)



find
Displays the Find dialog box to set search criteria for the active document and begins 
searching.
Same as the Find command on the Search menu.
Default keystroke: Ctrl+S



find_again
Continues a search begin via the find function.
Same as to the Find Again command on the Search menu.
Default keystroke: Ctrl+A



find_files_containing
Displays the Find Files Containing dialog box to set search criteria and begins searching for 
files.    Use the list_files_containing function to see and open the found files.
Same as the Find Files Containing command on the Search menu.
Default keystroke: Ctrl+F



goto_line
Prompts for input of a line number, then moves the cursor to the specified line in the active 
document.
If any text is selected, the selection is extended to include the requested line.
Same as the Goto Line command on the Search menu.
Default keystroke: Ctrl+G



list_files_containing
Use after using the find_files_containing function.    Displays a list of found files.    From there,
double click a file to open it and remove it from the list.
Same as the List Found Files command on the Search menu.
Default keystroke: Ctrl+L



lowercase
Converts all uppercase characters in the marked block to lowercase.
If no block is marked, acts on the character at the cursor.
Default keystroke: (none)



new_file
Opens a blank untitled document window.    Use Save or Save As... on the File menu to 
give it a name and save the contents to disk.
Same as the New command on the File menu.
Default keystroke: Alt+F,N



new_window
Opens an additional window on the current active document.
Changes made to either window will affect the same document.    If you want two different 
versions, first, use the Save As... command of the File menu to make a duplicate, then 
open both files.
Same as the New Window command on the Window menu.
Default keystroke: Alt+W,N



next_window
Activates the next window in the editor's circular list.
Same as the Next Window command on the Document     Control   menu.
Default keystroke: Ctrl+F6, or Alt+N



open_file
Prompts for a directory and filename and opens a window on that file.
Same as the Open command on the File menu.
Default keystroke: F3



page_down
Moves the cursor down one page; that is, the number of lines visible in the window.
Default keystroke: PgDn



page_up
Moves the cursor up one page; that is, the number of lines visible in the window.
Default keystroke: PgUp



paste
Inserts the contents of the Clipboard at the cursor location.
Same as the Paste command on the Edit menu.
Default keystroke: Shift+Ins



play_macro
Replays the keystrokes and functions recorded by the most recent use of the record_macro 
function.
If no macro has been recorded, that is indicated on the status line.
Same as the Play Back Macro command on the Edit menu.
Default keystroke: F8



prev_window
Activates the previous window on the editor's circular list.
Default keystroke: (none)



print
Prints the active document, using settings set via the Page Setup and Printer Setup 
commands under the File menu.
Same as the Print command on the File menu.
Default keystroke: Alt+P



record_macro
Starts recording keystrokes and editor functions.    Recording continues until the next use of 
this function.
Same as the Record Macro/Stop Recording Macro commands on the Edit menu.
Default keystroke: F7



replace
Prompts for search and replace criteria and then replaces specified text in the active 
document, starting at the cursor location.
Same as the Replace command on the Search menu.
Default keystroke: Ctrl+R



restore_window
Resizes the active window to its user-settable "intermediate" size.
Same as the Restore command on the Document     Control   menu.
Default keystroke: Ctrl+F5, or Alt+hyphen,R



revert
Prompts for verification, then undoes all changes to the contents of the active document 
since the file was last saved.
Same as the Revert command on the File menu.
Default keystroke: Alt+F,V



save_all
Saves the contents of all modified document to disk.    For untitled windows, prompts for 
filenames.
Same as the Save All command on the File menu.
Default keystroke: Alt+F,L



save_all_exit
Saves the contents of all modified document to disk, then ends the editor session.
Default keystroke: Alt+X



save_all_exit_windows
Saves the current contents of all modified documents to disk, then issues an Exit Windows 
call to end the current Windows session.    The Windows session is not terminated unless all 
applications agree to terminate.
Default keystroke: (none)



save_file
Saves the document in the current active window to disk.    If the window is untitled, you are 
prompted for a filename.
Same as the Save command on the File menu.
Default keystroke: F2



save_file_close_window
Saves the contents of the current active document to disk, then closes the active window.    If
the window is untitled, you are prompted for a filename.
Default keystroke: (none)



select_all
Selects (highlights) the entire contents of the active document.
Same as the Select All command on the Edit menu.
Default keystroke: Alt+E,A



select_char_left
Selects the character to the left of the cursor, or cancels the selection if that character is 
already selected.
If the cursor is at the beginning of a line, it moves to the end of the previous line.
Default keystroke: Shift+LeftArrow



select_char_right
Selects the character to the right of the cursor, or cancels the selection if that character is 
already selected.
If the cursor is at the end of a line, it moves to the beginning of the next line.
Default keystroke: Shift+RightArrow



select_line
Selects the current line.
Default keystroke: (none)



select_line_down
Extends the current selection down one line, or cancels the selection if that line is already 
selected.
Default keystroke: Shift+DownArrow



select_line_up
Extends the current selection up one line, or cancels the selection if that line is already 
selected.
Default keystroke: Shift+UpArrow



select_page_down
Extends the current selection down one page and scrolls the window.
Default keystroke: Shift+PgDn



select_page_up
Extends the current selection up one page and scrolls the window.
Default keystroke: Shift+PgUp



select_to_bol
Selects the text from the cursor to the beginning of the current line, or cancels the selection 
if the text is already selected.
Default keystroke: Shift+Home



select_to_end
Selects the text from the cursor to the end of the document in the active window.
Default keystroke: Ctrl+Shift+End



select_to_eol
Selects the text from the cursor to the end of the current line, or cancels the selection if the 
text is already selected.
Default keystroke: Shift+End



select_to_top
Selects the text from the cursor to the beginning of the document in the active window.
Default keystroke: Ctrl+Shift+Home



select_word
Selects the word containing the cursor.    (You can do this with the mouse by double-clicking 
the word.)
Default keystroke: (none)



select_word_left
Extends the current selection to the beginning of the word to the left of the cursor, or 
cancels the selection if the text is already selected.
Default keystroke: Ctrl+Shift+LeftArrow



select_word_right
Extends the current selection to the beginning of the word to the right of the cursor, or 
cancels the selection if the text is already selected.
Default keystroke: Ctrl+Shift+RightArrow



split_line
Inserts a line break at the cursor without advancing the cursor.
Default keystroke: Ctrl+N



stamp
Inserts the current date and time at the cursor location.
Same as the Time/Date command on the Edit menu.
Default keystroke: (none)



tab_right
In insert mode, inserts a tab character at the cursor (or inserts spaces, if "Expand Tabs with 
Spaces" in the Document Preferences dialog box is checked).
In overwrite mode, moves the cursor to the next tab position, as set in that same dialog.
Default keystroke: Tab



test_batch
Executes the commands in the active document as a Batch Runner script.
Available when Desktop Editor is running as Batch Builder or Macro Builder; same as the 
Test command under the Tools menu.
Default keystroke: (none)



tile
Resizes and rearranges all open windows to fit within the editor main window with no 
overlap.
Same as the Tile command on the Window menu.
Default keystroke: Alt+W,T



to_bottom
Scrolls the active window to place the current line at the bottom of the window.
Default keystroke: Ctrl+B



to_center
Scrolls the active window to place the current line to the center of the window.
Default keystroke: Ctrl+C



to_top
Scrolls the active window to place the current line to the top of the window.
Default keystroke: Ctrl+T



toggle_backup
Toggles the "Make Backup Files" option in the Editor Preferences dialog box.
When the backup option is on and you save a file, the original file is retained, but with an 
extension of .BAK.
Default keystroke: (none)



toggle_insert
Toggles between insert mode and overwrite mode.    The current mode is displayed on the 
status line.
Default keystroke: Ins



toggle_wordwrap
Toggles into and out of word wrap mode.    The current mode is displayed on the status line.
When word wrap is on, typing past the right margin causes the current word to be moved to 
the next lower line.
Same as the Word Wrap option on the Edit menu.
Default keystroke: Ctrl+W



top_of_window
Moves the cursor to the top visible line of the window.
Default keystroke: Ctrl+PgUp



undo
Reverses the effects of the a previous editing operation.    Repeated use will undo up to 300 
edit operations.
Same as the Undo command on the Edit menu.
Default keystroke: Alt+BkSp, or numpad *



unmark_block
Deselects the selected text and returns the cursor to its location before the text was 
selected.
Default keystroke: Esc



uppercase
Converts all lowercase characters in the marked block to uppercase.    If no block is marked, 
converts the character at the cursor.
Default keystroke: (none)



window_down
Moves the cursor up one line and at the same time moves the text in the window down one 
line.
Default keystroke: Ctrl+UpArrow



window_up
Moves the cursor down one line and at the same time moves the text in the window up one 
line.
Default keystroke: Ctrl+DownArrow



word_left
Moves the cursor to the beginning of the previous word or to the end of the previous line, 
whichever comes first.
Default keystroke: Ctrl+LeftArrow



word_right
Moves the cursor to the beginning of the next word or to the end of the line, whichever 
comes first.
Default keystroke: Ctrl+RightArrow



wrap_para
Reformats the current paragraph within the margins of the active document.    Margins are 
set via the Document Preferences command of the Options menu.
Same as the Wrap Paragraph command on the Edit menu.
Default keystroke: F12



zoom_window
Resizes the active document window to its maximum possible size within the editor's 
window.
Same as the Maximize command on the Document     Control   menu. You may also maximize
and restore a window by double-clicking its title bar.
Default keystroke: Ctrl+F1 or Alt+hyphen,X





Batch Builder Help Index
Editor Help

Desktop Editor Help Index
Desktop Editor Procedures

Batch Language Reference
Statements by Functional Groups
SendKey Key Codes
Variables and Parameters
Predefined Constants
Math and Relational Operators
Dialog Templates

Keyboard
Editor Keys

Commands
File
Edit
Search
Options
Tools
Window
Help

Procedures
Using Batch Builder Using Desktop Editor
Batch Language Capabilities
Running a Batch File
Record-and-Paste for Fast Development
Batch Language Statements by Functional Groups



Batch Builder Commands
File   Commands  
Edit   Commands  

Search   Commands  
Options   Commands  

Tools   Commands  
Window   Commands  

Help   Commands  
Related Topics:

Using Batch Builder
Using Desktop Editor
Batch Language Statements by Functional Groups



The Tools Menu
Commands in this menu provide access to tools useful when building batch files and Macro 
Builder macros.

Test Alt+T,TExecute the batch file in the active window.
Reference Alt+T,TSee the reference window which containing info on all Batch 

Runner statements.
Macro Builder Alt+T,M Start recording a Macro Builder macro.



Tools Test Command
Function name: test_batch 

Default key: Alt+T,T
This command executes the current active document as a Batch Runner batch file. Use it to 
test and work the bugs out of a batch file.



Tools Reference Command
Function name: batch_help 

Default key: Alt+R
This command displays the Batch Builder Reference dialog box, which provides an 
alphabetically ordered scrolling list of Batch Builder statements and a description, syntax 
summary, and example of each statement.
You can keep the Reference box open as you create or edit the batch file. Use Alt+F6 to 
toggle back and forth between the Reference box and the text-editing screen.
Related Topics:

Batch Statements by Functional Groups
SendKey Key Codes
Variables and Parameters
Predefined Constants
Math and Relational Operators
Dialog Templates (  .WBD   files)  



Tools Macro Builder Command
Function name: (none)

Default key: Alt+T,M
This command starts Macro Builder which lets you record a batch file. It displays a Standard 
Browse... dialog box to let you choose a filename for the macro.
After choosing a filename, the Macro Builder icon appears at the bottom of your screen and 
begins blinking. All subsequent actions (such as selecting application windows, menu 
commands, and text input) are recorded into the batch file.
To stop recording:
1 Click the Macro Builder icon once to bring up its control menu.
2 Choose the Close command.

Batch Builder will open the newly-recorded batch file automatically.
Tip: This simplifies creation of complex batch files. Rather than writing a long series of 

statements, just record a series of events to some temporary file (e.g., TEMP.WBT). 
Then edit that file to clean up any superfluous actions.

Related Topics:
Record-and-Paste for Fast Development



Batch Builder Reference Dialog Box
This dialog box appears when you use the Reference command on the Batch Builder Tools 
menu. It provides a quick reference for the over 150 functions and commands available in 
the Batch Runner language.
Additional Batch Runner language reference information is available in this help file. See 
Batch Builder Index to get to a discussion of variables, parameters, use of dialog boxes, and 
so forth.
Commands
* Use  and 
 to scroll though this list.

* Or, press the first letter of any Batch Runner statement to scroll quickly to that part 
of the list.
Description

As you scroll through the Commands list, this area displays a short description, syntax 
and example of each statement.

Close
Click this button to close the Reference dialog box.

Add
This inserts the currently highlighted statement from the Commands list into the text-
editing screen at the current cursor position. This handy feature will help you avoid 
misspelling command names.

Related Topics:
Statements by Functional Groups
SendKey Key Codes
Variables and Parameters
Predefined Constants
Math and Relational Operators
Dialog Templates (  .WBD   Files)  



Batch Builder Procedures
Using Batch Builder Using Desktop Editor
Batch Language Capabilities Desktop Editor Procedures
Running a Batch File
Record-and-Paste for Fast Development
Statements by Functional Groups
Dialog Templates
Math and Relational Operators
Predefined Constants
SendKey Key Codes
Variables and Parameters



Batch Language Capabilities
The Batch Runner batch files that you can create with either Batch Builder or Macro 
Builder provide excellent control over your Windows computing environment. The Batch 
Runner language is a little bit like the familiar DOS batch file language, but with far greater 
power and flexibility (over 150 functions and commands).
With Batch Runner batch files, you can:
* Create and display dialog boxes for user interaction; you can create buttons, check boxes 

and other controls--just like a Windows application.
* Start any program as a full-size, iconized, or even a hidden window. You can automatically 

minimize or maximize any application's window.
* Feed keystrokes to any program. Since batch files can be launched by a shortcut key and 

run in the background, you can effectively add new commands to any program.
* Control window size and position of any application and modify any window title, including 

the labels below some minimized application icons.
* Perform powerful file and directory manipulation, such as deleting and copying files, 

presenting a scrolling list of files for user selection, and much more.
* Perform network operations, such as connecting to and logging-on to the network.
* Perform Dynamic Data Exchange (DDE) operations, such as obtaining current data from a 

spreadsheet.
* Interact with the clipboard to automate cut-and-paste operations.
* Access multimedia capabilities, such as splaying waveform sounds, running a video disk, 

and so forth (assuming the hardware and drivers are attached).
* Read, write, and display .INI files to examine or change Windows global or program local 

configuration options.
* A programmer's "MAKE-like" capability. You can take action depending upon file 

modification date and time. For example, if one file is out-of-date with respect to another, 
you can run a program to force an update.

* Perform miscellaneous Windows environment-control commands such as changing the 
desktop "wallpaper."

The Batch Runner language provides program variables, numeric and string operations, and 
looping and other execution control functions and commands. In brief, it is a complete 
programming language.
Related Topics:

Batch Commands in Functional Groups



Using Batch Builder
Batch Builder is a text editor based on the Desktop Editor that comes with the Norton 
Desktop. It (or any other text editor) can be used to create Batch Runner batch files. The 
Batch Runner language is a little bit like the familiar DOS batch file language, but with far 
greater power and flexibility.
See Batch Language Capabilities
and Batch Commands in Functional Groups
for an overview of features.
To create a batch file automatically:
1 Use the Macro Builder command on the Tools menu. Choose a filename for the batch 

file.
The Macro Builder icon will appear on the bottom of the screen and will blink to show that
it is recording.

2 Perform a series of actions, such as starting a program, using menu commands, typing 
text, and so forth.

3 Click the Macro Builder icon once to bring up its control menu.
4 Select Stop Recording.

The recorded batch file is automatically opened as an additional document in the editor.
5 Choose the Test command in the Tools menu to try it out. You can edit the batch file and 

save changes, if desired.
To create a batch file manually:
1 Start Batch Builder by selecting it from the Norton Desktop Tools menu, or double-

clicking its icon in a Quick Access group window.
2 Type some commands in the editing window.
3 For a quick reference to statement syntax, use the Reference command on the Tools 

menu, or press Alt+R.
4 Use the File Save command and choose a directory and filename for the batch file.

Note: Batch files should have a filename extension of .WBT (think Windows BaTch).
To run a batch file:
* While in the Batch Builder editor, you can launch a batch file by selecting it at the active 

document, then choosing the Test command on the Tools menu.
* Start a batch file using any of the normal methods for launching programs and 

documents. See Running a Batch Builder Batch File for some useful ideas.
Note: One of the handiest ways is by adding a batch file to your Launch List.

To halt a running batch file:
* Click the minimized Batch Runner icon (which appears at the bottom of your desktop 

when you launch any batch file) and select Close from its pop-up Control menu.
* Press Esc or click Cancel in any Batch Runner dialog box.

Related Topics:
Batch Language Capabilities
Batch Commands in Functional Groups
Running a Batch Builder Batch File 



Running a Batch Builder Batch File
To test a batch file as you create it:
1 Make sure that the desired batch file document is active. You can bring it to the front by 

choosing it from the Window menu.
2 Use the Test command on the Tools menu (Alt+T,T).

To run a batch file at any time:
After creating and testing a batch file, you can start it by using any of the normal methods 
for launching programs and documents:
* Double-click the batch file in a drive window.
* Create a Quick Access group item that has the batch file filename in the "Command Line."

Then double-click its icon.
* Use the File Run command from the Norton Desktop or Quick Access menu. Specify the 

name of the batch file (including the .WBT extension) in the command line.
* Add the batch file filename to your Launch List. This is especially convenient, since you 

can then start the batch without leaving the current application. You can even set up a 
shortcut key to run the batch file instantly.

* Make the batch file into a command in the Norton Desktop menu. Use the Configure 
Edit Custom Menu command and add a "custom" item to the menu.

Tip: If you want to pass parameters to a batch file from a Run command, you may need to 
use a fully-qualified command line; that is launch BATCHRUN.EXE (rather than just 
launching the .WBT file). For example:

BATCHRUN myBat.wbt param1 param2 ...



Record-and-Paste Technique
It is often handy to start with a batch file recorded by Macro Builder (see Using Batch 
Builder). Likewise, when you are writing a complex batch file, it is often easier to record a 
sequence of operations (especially SendKey commands) than it would be to enter and test 
them by trial and error.
To record a command sequence:
1 Use the Macro Builder command on the Tools menu (Alt+T,R).
2 At the prompt, enter a filename. You can use a throw-away name such as "TEMP.WBT". 

The Macro Builder icon will blink on your desktop to show that it is recording.
3 Perform the series of actions you want to record. It's OK to make a few false starts, since 

you can edit the recorded commands later.
4 Click the Macro Builder icon once to display its control menu. Choose the Close 

command.
Batch Builder will open the newly-recorded batch file automatically.

To use the recorded sequence in a batch file:
1 You can tile the two batch file windows (Alt+W,T).
2 Activate the recorded batch file and select the line or lines you want to use. 
3 Copy them to the clipboard (Alt+E,C).
4 Activate the base batch file document.
5 Scroll to the desired place in the file, and paste the recorded sequence into the document

(Alt+E,P).



SendKey Key Codes
The SendKey command types keystrokes into the currently active window, as if they had 
been entered from the keyboard.
Tips: To send keys to a particular window, use the WinActivate command first.

You may find it easiest to record SendKey sequences. See Record-and-Paste Technique 
for a description.

To send letters and numbers, just type them into the SendKey string. The following special 
sequences are available for sending function keys and other keystrokes:
To send... Use the text...

{LEFT}
{RIGHT}
{UP}
{DOWN}

Backspace {BACKSPACE} or {BS}
Break {BREAK}
Delete {DELETE} or {DEL}
End {END}
Enter {ENTER} or ~
Esc {ESC}
F1 through F16 {F1} through {F16}
Home {HOME}
Insert {INSERT}
PageDown {PGDN}
PageUp {PGUP}
spacebar {SPACE} or {SP}
Tab {TAB}
~ {~}
! {!}
^ {^}
+ {+}

To send a Ctrl-, Alt-, or Shift-modified keystroke, you can place these characters directly 
before the character or keystroke to be sent:
For modifier      Use  
Alt !
Ctrl ^
Shift +

For example, SendKey( "!FP" ) sends Alt+F, then P.
And, SendKey( "^+{F4}" ) sends Ctrl+Shift+F4.
To send a repeated sequence of keystrokes, you can place, inside curly braces, a keystroke 
followed by a space and the number of times to send it:
{keyCode nn} Sends keyCode, repeating nn times.

For example, SendKey( "{RIGHT 10}" ) sends  ten times.



Batch Statements by Functional Groups
User Input and Screen Output
Running Programs
Window Manipulation
Batch Execution Control
Clipboard Operations
Dynamic Data Exchange
File, Directory, and Disk
.INI File Operations
List Operations
Miscellaneous
Network Access
Sound and Multimedia
Utility and Batch Debugging
Numeric Operations
String Operations
Dialog Templates
Operators
Predefined Constants
Variables



User Input and Screen Output

AskLine Prompts the user for one line of input.
AskYesNo Prompts the user to choose Yes, No or Cancel.
AskPassword Prompts for password (shows *s for output).
Beep Beeps once.
DialogBox Opens the dialog box defined by the WBD template file.
Display Displays text in a message box for the specified time period.
IgnoreInput Turns off and on hardware input to Windows.
IsKeyDown Determines whether Shift, Alt, or Ctrl key is down.
WaitForKey Waits for a keystroke.
ItemSelect Lets the user choose an item from a list box.
Message Displays text in a message box until the user selects OK.
Pause Displays text in a message box until the user selects OK or Cancel.
TextBox Displays a file in a list box and lets the user choose a line.
Tip: To display line breaks in the output, create a "new line" variable; for example:

nl=StrCat( Num2Char(13), Num2Char(10) )
Then in your output, embed that string where you want a line to break. For example:

Message("title", "line1%nl%line2")



Batch Execution Control

Execution Flow Control
If ... Then Conditionally executes a statement.
Goto Changes the flow of control in a batch file (goes to line starting with a label).
:label The destination of a Goto.
:CANCEL Special label. When present, gets control after user clicks Cancel button in a 

dialog box.
;comment Text on a line following a semicolon is not executed.
WinWaitClose Suspends batch execution until a specified window is closed.
Delay Pauses batch file execution for a specified time period.
Exit Terminates the current batch file's processing.

Executing Files as Subroutines
Call Calls another WBT file as a subroutine.
CallExt Calls another WBT file as a separate subprogram.

Note: Upon entry, batch parameters will be found in predefined variables 
param1, param2, etc. The number of parameters will be in param0.

Return Returns from a Call or a CallExt to the calling program.



Batch Debugging and Utility Operations

Debug Turns Debug mode on or off.
ErrorMode Controls what happens in the event of an error.
Execute Executes a batch statement in a protected environment; any errors are 

recoverable.
LastError Returns the last error encountered during the current batch file.
SKDebug Sets SendKey's debug mode.



Network Access Operations

NetAddCon Connects network resource to local device.
NetAttach Creates a connection between a workstation and a Novell Netware file 

server.
NetBrowse Displays the network browse box.
NetCancelCon Cancels a network connection.
NetDetach Detaches a workstation from a Novell Netware file server.
NetDialog Displays the network driver's dialog box.
NetGetCaps Get network capabilities.
NetGetCon Returns the name of the network resource.
NetGetUser Returns the name of the currently logged-in user.
NetLogin Log in to network.
NetLogout Log off of network.
NetMapRoot Redirect drive letter to be root of specified path.
NetMemberGet See if current user is a member of specified group.
NetMemberSet Assign current user to a group.
NetMsgAll Broadcast a message to all network users.
NetMsgSend Send a message to a network user.



Sound and Multimedia Operations

Beep Beeps once.
PlayMedia Plays Multimedia command.
PlayMidi Plays Multimedia MIDI sound extension.
PlayWaveForm Plays Multimedia sound extension.
Sounds Turns Multimedia sounds ON or OFF.



File, Directory, and Disk Operations

Disk
DiskFree Returns the amount of space available on a set of drives.
DiskScan Returns a list of drives.
LogDisk Logs a disk drive (makes it the DOS default drive).

Directory
DirChange Changes the current directory; can also log a new drive.
DirGet Returns the current directory path.
DirHome Returns the directory path containing the Batch Runner program.
DirItemize Returns a space-delimited list of directories.
DirMake Creates a new directory.
DirRemove Removes a space-delimited list of directories.
DirRename Renames a directory.
DirWindows Returns the Windows directory or system directory.

File Information
FileAppend Appends one or more files to another file.
FileAttrGet Returns the file attributes.
FileAttrSet Sets (and clears) file attributes.
FileCopy Copies files, with or without first displaying a warning.
FileDelete Deletes files; parameter can include wildcards.
FileExist Tests for the existence of a file.
FileExtension Returns the extension of a file.
FileItemize Returns a space-delimited list of files.
FileLocate Finds file in current directory or along DOS PATH.
FileMove Moves files, with or without first displaying a warning.
FilePath Returns the path of a file.
FileRename Renames files.
FileRoot Parses a filename and returns the root part.
FileSize Finds the total size of a group of files.
FileTimeGet Returns the file's time and date.
FileTimeTouch Sets a file's date and time.

File Reading and Writing
FileOpen Opens a file for either reading or writing (ASCII files only).
FileRead Reads data from a file, using the fileHandle returned by FileOpen.
FileWrite Writes data to a file, using the fileHandle returned by FileOpen.
FileClose Closes a file, using the fileHandle returned by FileOpen.



.Ini File Operations

IniDelete Remove lines from the WIN.INI file.
IniDeletePvt Removes lines from specified INI file.
IniItemize Itemizes sections or keywords in the WIN.INI file.
IniItemizePvt Itemizes sections or keywords in specified INI file.
IniRead Reads a string from the WIN.INI file.
IniReadPvt Reads a string from a specified .INI file.
IniWrite Writes a string to the WIN.INI file.
IniWritePvt Writes a string to a private .INI file.



List Operations

ItemCount Returns the number of items in a list.
ItemExtract Returns the selected item from a list.
ItemSelect Lets the user choose an item from a list box.
DirItemize Returns a space-delimited list of directories.
FileItemize Returns a space-delimited list of files.
IniItemize Itemizes sections or keywords in the WIN.INI file.
IniItemizePvt Itemizes sections or keywords in specified INI file.
WinItemize Returns a tab-delimited list of all open windows.
DiskScan Returns a list of drives.



Numeric Operations

Operators Many unary and binary operators are supported.
Abs Returns the absolute value of a number.
Average Returns the average of a list of integers.
Char2Num Returns the ANSI code of a string's first character; for example., Char2Num("A" )

returns 65.
IsNumber Determines whether a variable contains a valid number.
Max Returns the highest number in a list of integers.
Min Returns the lowest number in a list of integers.
Num2Char Returns the ASCII equivalent of a number; for example, Num2Char(65) returns 

"A".
Random Computes a pseudo-random number.
Drop Removes variables from memory.
IsDefined Determines if a variable is currently defined.
Tip:There is no "Num2String" function because a numeric variable can be used anywhere a 

string is used. You can also use %var% substitution to insert a number into a string; for 
example:

n=DiskFree("c")
Message ("Warning", "You have only %n% bytes of free space left!")



String Operations

%var% When embedded in a quoted string, this text is replaces with the current value 
of the numeric or string variable, var.

ParseData Parses the passed string into individual "words."    Count of items gets placed in
predefined variable param0; individual elements turn up in param1, param2, 
etc. 

StrCat Concatenates two or more strings.
StrCmp Compares two strings; case-sensitive.
StrFill Builds a string of a specified length by repeating a substring.
StrFix Pads or truncates a string to a specified length.
StrICmp Compares two strings, ignoring their case.
StrIndex Returns the position of a substring within a string.
StrLen Returns the length of a string.
StrLower Converts a string to all lower-case characters.
StrReplace Replaces all occurrences of a substring with another.
StrScan Searches a string for a delimiter; returns the delimiter's position.
StrSub Extracts a substring from an existing string.
StrTrim Trims leading and trailing blanks from a string.
StrUpper Converts a string to uppercase.
EnvironmentReturns the value of a DOS environment variable.
Drop Removes variables from memory.
IsDefined Determines if a variable is currently defined.



Running Programs

EndSession Ends the current Windows session.
Run Runs a program in a normal window.
RunHide Runs a program in a hidden window.
RunIcon Runs a program as an icon.
RunZoom Runs a program in a maximized window.
WinWaitClose Suspends batch file execution until specified window is closed.
SendKey Sends keystrokes to the active application. See SendKey Key Codes.
Exclusive Controls whether other Windows programs will get any time to perform tasks.
Yield Provides time for other windows to do processing.



Window Manipulation

IconArrange Rearranges icons at the bottom of the screen.
WinActivate Activates (brings to the front) a previously running window.
WinArrange Arranges all open windows on the desktop.
WinClose Closes an open window or icon.
WinCloseNot Closes all windows and icons except those specified.
WinExist Tests for the existence of a specified window or icon.
WinExeName Returns the EXE file that owns the matched window name.
WinGetActive Returns the title of the active window or icon.
WinHide Hides a window or icon.
WinIconize Iconizes a window.
WinItemize Returns a tab-delimited list of all open windows.
WinPlace Changes the size and position of a (non-maximized) window.
WinPlaceGet Returns coordinates of specified window.
WinPlaceSet Sets the window state and coordinates.
WinPosition Returns the coordinates of a window.
WinShow Shows a window in its "normal" state; makes a hidden window visible.
WinState Returns current state of the window specified.
WinTitle Changes the title of a window or icon.
WinZoom Maximizes a window or icon.
WinWaitClose Suspends batch file execution until specified window is closed.



Clipboard Operations

ClipAppend Appends a string to the end of the Clipboard.
ClipGet Returns the Clipboard contents into a string.
ClipPut Replaces the Clipboard contents with a string.
SnapShot Takes a snapshot of the entire screen and puts it on the clipboard.



Dynamic Data Exchange

DDEExecute Executes a DDE command to a conversation
DDEInitiate Initiates a DDE conversation
DDEPoke Changes an item's value in a conversation
DDERequest Requests an item's value from a conversation
DDETerminate Terminates a DDE conversation
DDETimeOut Sets the DDE timeout value in milliseconds



Miscellaneous Batch

DateTime Returns the current date and time.
DOSVersion Returns the major or minor version number of the DOS version currently in 

use.
Version Returns the version of Batch Runner currently running.
WallPaper Changes the desktop wallpaper, optionally tiling the graphic.
Environment Returns the value of a DOS environment variable.
IsDefined Determines if a variable is currently defined.
Drop Removes variables from memory.

Window Environment Information
DirWindows Returns the Windows directory or system directory.
WinConfig Returns the Windows configuration as bit flags.
WinResources Returns information on available resources.
WinVersion Provides the version number of the current Windows system.



Math, Relational, and Bitwise Operators

Mathematical
* multiply
/ divide
mod modulo (gives remainder)
- subtract
+ add numbers

(to add strings, use StrCat or "%var2%%var2%")
Relational (use in If...Then statements)

( ... ) parenthetical grouping
&& logical AND
|| logical OR
! logical NOT
> greater than
>= greater than or equal
< less than
<= less than or equal
== equal
!= not equal
<> not equal

(to compare strings, use StrCmp or StrICmp)
Bit Manipulation

<< bitwise shift left
>> bitwise shift right
& bitwise AND
| bitwise OR
^ bitwise XOR
~ bitwise NOT (toggle all bits)



Predefined Constants

Logical Conditions
@TRUE
@YES
@FALSE
@NO

Window Arrangement (use in WinArrange)
@STACK
@TILE
@ROWS
@COLUMNS

Window Placement (use in WinPlace)
@NORESIZE
@ABOVEICONS

Window State (use in WinState, WinPlaceGet, WinPlaceSet)
@ICON
@NORMAL
@ZOOMED

String Search Direction (use in StrIndex and StrScan)
@FWDSCAN
@BACKSCAN

Version Request (use in DOSVersion or WinVersion)
@MAJOR
@MINOR

Error Handling (use in ErrorMode)
@CANCEL
@NOTIFY
@OFF

Debugging Mode (use in Debug and SKDebug)
@ON
@OFF
@PARSEONLY

Shift Key Codes (use in IsKeyDown)
@ALT
@CTRL
@SHIFT



Variables and Parameters

var Up to 30 letters and digits; must start with a letter; case insensitive.
number Signed long integer (up to ten digits); positive or negative.
var=number Assign a number to a variable.
var="string" (or 'string' or `string`) Assign a string of text to a variable.
%var% Text of the variable is substituted (OK in commands, parameters, and quoted 

strings).
;comment Text following a semicolon on a line is not executed.
param0 The number of parameters that were passed to this batch (Call and CallExt) or the 

number of substrings in the specified string (ParseData).
param1 The first parameter.
param2 The second parameter.
(etc...) You can use IsDefined(paramn) to see if it exists.
Tips: To pass parameters to an initial batch file, you must use a fully qualified command line

to start Batch Runner; for example:
BatchRun myBat.wbt param1 param2...

rather then just using the .wbt batch file name.
If you pass a quoted string, it counts as one parameter:

Call myBat.wbt param1 "this whole thing is param 2"



Dialog Templates (.WBD Files)
Elements: These elements, plus any other static text, can be saved in a .WBD file. Then 
use DialogBox(title, WbdFilename) to start the dialog box.
[cbVar+1lbl_txt]Check box; use a different variable in each. Set set cbVar to a non-zero value in

advance if you want the boxed to be checked by default. Afterwards, cbVar will 
contain 1 (or whatever is after the + character) if the box has been checked. 
Otherwise it will be 0.

[rbVar^1lbl1_txt] Option buttons; use the same variable in each,
[rbVar^2lbl2_txt] but assign a unique number after the caret (^).
[rbVar^3lbl3_txt] When a button gets selected, its unique number will be assigned to the

variable. To make an option button selected by default, precede the 
DialogBox statement with a line setting the option button variable (for 
example, rbVar) equal to the desired option button's value (for exampe, 3, to 
set the third button as the default).

[var$ ] This var will be displayed in a box this wide.
[tbVar# ] Text input box. To preset default, set tbVar in advance.
Scrolling file lists: To get a scrolling list of files, use fVar\ as below, and use the same 
variable name in the fVar# and fVar$ elements.
[fVar\ ] Defines file list box.
[fVar\ ] Set width by spacing between \ and the ].
[fVar\ ] Set height by repeating the line.
[fVar$ ] Directory name will be displayed here.
[fVar# ] The file mask box. User can input wildcards here. Set fVar in advance to preset 

the initial wildcard.
DialogBox Tip: You may find it convenient to create the .WBD file on-the-fly (as below) 
rather than saving it in advance, where it might get separated from the batch file.
;---- create dialog box on the fly.
;---- use it in DialogBox command.
;---- delete it when done.
tDir=Environment("TEMP") ; a place for temporary files.
dlgFilename="%tDir%temp.wbd" 
dlg=FileOpen(dlgFilename,"WRITE")
FileWrite(dlg,"Type text and choose options:")
FileWrite(dlg,"Text: [t# ]")
FileWrite(dlg," [cbA+1 Bold ]" )
FileWrite(dlg," [cbB+1 Italics ]" )
FileWrite(dlg,"[rb^1 6pt] [rb^2 9pt] [rb^3 12pt]" )
FileClose(dlg)
DialogBox( "Dialog Tester", dlgFilename )
FileDelete(dlgFilename) ; don't need file anymore.
If cbA==@TRUE Then...; chose "Bold"?
If cbB==@TRUE Then... ; chose "Italic" ?
If rb==1 Then... ; ...chose "6pt"
If rb==2 Then... ; ...chose "9pt"
If rb==3 Then... ; ...chose "12pt"

DialogBox Tip: By default, when the user clicks Cancel in any dialog box, the entire batch 
terminates. However, if you have a line labeled :CANCEL, then control will go to that line 
when the user cancels a dialog.



Launch List

Launch Manager is active whenever Norton Desktop is running. It provides an easy way to 
launch programs or documents and to switch tasks without leaving your current application. 
Launch Manager commands are found in the application Control-menu of all applications. 
Just click that button or press Alt+spacebar.
The programs and documents in the Launch List sub-menu can be launched by using menu-
accelerator keystrokes (for example, Alt+spacebar,L,K to start KeyFinder) or by pressing a 
shortcut key. Use the Launch Manager... command on this menu to add items to the 
launch list or change an item's shortcut key.





Standard Browse Dialog Box
Whenever a Norton Desktop application prompts you to enter a filename, you can click 
Browse and use the handy dialog box which appears to find the file (and avoid typing a long
pathname).
Directory

This line displays the current default or currently-selected directory. This text changes 
automatically when you select from the Drives and Tree list boxes.

File
* Type the filename and press Enter.
* Or, select a file from the Files list box.
* Or, type a wildcard file specification and press Enter to see only files matching that 

wildcard. You can type multiple wildcards, separating them with a comma (for example, 
*.WK?,*.XLS).

* Or, select from the List Files of Type drop-down list box to display only files matching a 
listed wildcard.

When you click OK, the selected filename is appended to the text in the Directory line 
and the result is returned to the parent dialog box.

Files
This list shows the names of files in the current directory, in alphabetical order.
* You can type the first few characters of a filename to quickly scroll to that part of the list.

Press  to find other matches.
* Or, use the scroll bar to look through this list. You can double-click a filename to 
select it and automatically confirm the dialog box.
Tree
* You can type the first few characters of a directory name to quickly scroll to that part of 

the list. Press  to find other matches.
* Or, use the scrollbar to look through this list. When you click a directory, its files are 
shown in the Files list.

Note: If the Tree display is expandable/collapsible, some directories may not be 
listed. To expand or collapse a directory, double-click its folder icon. See Using the 
Expandable/Collapsible Tree Display for related information.

Drives
* You can type a drive letter.
* Or, click the prompt button (or press Alt+ ) and use the scrollbar to look through this 

list. When you select a drive, its directories will be listed in the Tree list.
Refresh

Use this button to refresh the listings in the Tree and File lists. This is needed when you 
change diskettes in a floppy-disk drive, or after you've created a directory or file from a 
DOS window or another application.

OK
Click this button, or double-click a filename, or press Enter to confirm your selection of 
drive, directory, and filename. The combined full file specification will be used as input for 
the dialog box from which this Browse dialog box originated.

Cancel
Exits the dialog box without selecting a file.



Standard Directory Browse Dialog Box
Whenever a Norton Desktop application prompts you for a directory name, you can click the 
Directory button, and use this handy dialog box to locate the directory.
Drive

Enter a drive letter. Or, click the prompt button (or use Alt+  to display the drop-down list 
box containing available drives and select a drive from the list. The Tree list box is 
refreshed and displays all of the directories on the selected drive.

Tree
* Type the first few characters of a directory name to quickly move to that part of the list 

box. Press  to find other matches.
* Or, use the scroll bar to look through this list box. When you select a directory, its 
files are shown in the Files list box.

Note: If the Tree display is expandable/collapsible, some directories may not be 
listed. To expand or collapse a directory, double-click its folder icon. See Using the 
Expandable/Collapsible Tree Display for related information.

OK
Click this button, or press Enter to confirm your selection of drive and directory. The result
is used as input for the dialog box from which this Browse dialog box originated.

Cancel
Exits the dialog box without selecting a directory.





Printer Setup Dialog Box
Use this dialog box to select from the printers you have installed under Windows and to 
select the various options provided by a printer.
Notes: Some system-level printer configuration commands, such as installing new printers 

and selecting printer ports, are available through the Windows Control Panel.
This dialog box sets the selected printer as the Windows default printer; other 
applications use this printer unless you change it back (usually through the 
application's own Printer Setup command).

Printer
Use  and 
 to move through the items in the list box. When the desired printer is selected, click OK or 

press Enter to confirm your choice.
Setup...

Click this button to display a Printer Driver dialog box which displays setup options for the 
selected printer. For example, on some printers you can specify landscape printing 
(printing sideways on the page), various printer resolutions and other options. That dialog 
box, and any help provided in it, is part of the printer driver, and not a part of Norton 
Desktop for Windows.

OK
Click this button, or double-click a printer name or press Enter to confirm your selection 
and close the dialog box.

Cancel
Exits from the dialog box without making any printer setup changes.





Control-Menu Box

This button opens a menu which provides general control for the active window.
Double-click it to close the window.
Click it once to drop-down the application Control Menu which lets you close, resize or 
move the window. While Norton Desktop is running, this menu can contain additional 
selections, including the Launch Manager and Task List, making it easy to launch and 
switch between applications.
Keyboard users may press Alt+spacebar to access the Control menu.
For programs which support multiple documents, press Alt+hyphen to drop-down the 
document Control Menu for the window.



Control Menu

Click  the Control-menu box (Alt+spacebar) to drop-down the Control menu. This menu 
provides a way for keyboard users to move and resize the window. With Norton Desktop 
active, the Control menu can contain additional commands:
* The Launch List is a cascading menu containing frequently used programs, Batch Runner 

batch files and documents. You can assign shortcut keys to any of these applications, 
allowing them to be launched from anywhere in Windows.

* The Launch Manager lets you add or edit items in the Launch List.
* The Task List is a cascading menu of currently running programs; it lets you switch to 

another application using menu commands, rather than the standard Switch To dialog 
box.

* Run displays a dialog box which lets you launch any application or document by name.
The Norton Desktop Configure Preferences command determines whether these items are
on the application Control menu.





Batch Runner Batch File
A standard ASCII text file containing statements of the Batch Runner Windows-oriented 
batch programming language. Batch files have a file extension of .WBT.
You can create batch files using Batch Builder (located on the Norton Desktop Tools menu)
or by using any standard text editor.
To execute a batch file, use its name (including the .WBT extension) in a Run command or 
any place you would normally use a program name.





Clipboard
A temporary storage area for cut or copied text or graphics. The clipboard can be used as a 
holding pen for information you want to pass between Windows programs.
You can place data in the clipboard by using the Cut or Copy command of the Edit menu. 
Insert data from the clipboard into a document by using the Edit Paste command.
The Windows application named Clipboard Viewer displays the current contents of this 
system-wide resource.





Minimize and Maximize
When you click  the Minimize button (Alt+Spacebar,N) located near the top-right corner 
of a window, that window shrinks into an icon and appears at the bottom of your desktop.
You can double-click the icon to restore it to its previous size.
When you click  the Maximize button (Alt+Spacebar,X) located at the top-right corner of 
a window, that window instantly expands to fill the screen.
You can click  the Restore button to restore the window to its previous size.
Tip: You can also maximize or restore a window by double-clicking its title bar.


