
Accounts Receivable Overview and Help Index

Overview
Accounts Receivable is a state-of-the-art program that doggedly tracks receivables.    The 
program prints invoices and statements on standard 8 1/2 x 11 inch letterhead stock for use 
with window envelopes.    Accounts Receivable has a short learning curve, on-line help plus 
point-and-click capability.    Features include customer templates, undo command, selective 
invoice display and single-key account and aging summaries.    This version of Accounts 
Receivable is distributed as shareware and is entirely supported by registration fees.
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General
              
Accounts Receivable operation is similar to that used by other Windows applications.    Use 
Print Topic, from the Help Menu and obtain printouts of Sample Problem 1,    Sample Problem 
2, File Maintenance and Registration.    Each sample problem can normally be completed in 
less than thirty minutes.    The sample problems walk the user through Accounts Receivable.  
Two sample files are provided.    File Maintenance covers creating working AR files and 
customizing the AR.INI file.    Invoices are stored in files with an AR extension while customer 
templates are stored in AR.TEM.    File Maintenance should not be accomplished until the 
sample problems have been completed.    Note that Accounts Receivable treats credit 
memos as an invoice with a negative balance.    Accounts Receivable invoices serve a dual 
purpose; that is, they are used as invoices and credit memos. 

The instructions assume that the user has some experience using Windows applications.    
Two files (TUTOR1.AR and TUTOR2.AR) have been constructed for use with the sample 
problems.    Either a mouse or the keyboard may be used.    After you complete the sample 
problems and are "up-to-speed" you can create additional AR files.    As many AR files as the 
hardware can support may be created. 

Although TUTOR1.AR is displayed at start-up, any AR file can be selected as the start-up file. 
Invoice files can have any valid filename but are assigned an AR extension.    AR files that 
are no longer required can be deleted from Windows or the DOS prompt.    



Sample Problem 1

1.    From Windows, start Accounts Receivable.    Note that the name of start-up file 
(TUTOR1.AR) is displayed in the Lower Window and a company name is displayed in the 
window frame border.    After File Maintenance is accomplished, your company name will 
appear in the frame border.

2.    After the display appears, entries are displayed in columnar fashion.    The Lower Window
contains the number of invoices (COUNT), number overdue (ODUE) and the filename 
(FILE) of the active file.    

3.    Press D or click on Date.    Hold the key or mouse button down.    The day of the week, 
date and time are displayed in the Lower Window until the key or mouse button is 
released.

4.    Press C or click on Cal.    After the perpetual calendar appears, note that todays date is 
surrounded by a frame.    The calendar can page from 1899 through 2090 by month or 
year.    Experiment with all the selections.    When through, press C or click on Cancel to 
restore the previous display.

5.    Press A or click on Acct.    All active file invoices that have the same Account ID are 
displayed.    The number of invoices, overdue invoices and the Account ID are displayed in
the Lower Window.    Note that the account total is displayed in the Lower Window frame 
border.    When through, press R or click on Restore to return to the previous display.

6.    Press V or click on Overdue.    All active file overdue invoices are displayed.    The number
of invoices, overdue invoices and the name of the active file are displayed in the Lower 
Window.    Note that the Lower Window is captioned Overdue.    When through, press R or 
click on Restore to restore the previous display.

7.    Press U or click on Summary.    Carefully review the active file summary.    Note that 
debits, credits, file total, overdue debits, percent of debits overdue, average days overdue
and the number and amount of overdue invoices are shown for varying periods.    The 
number/amount overdue display excludes credit memos (invoices with a negative 
balance).    When through, select OK to restore the previous display.

8.    Press L or click on List.    Note that the display shows todays date and projects ahead one
year.    Experiment by adjusting the From and To dates then select OK.    All active file 
invoices whose due dates fall within the selected range will be displayed.    The Lower 
Window contains the number of invoices, overdue invoices and the active filename.    The 
selected range is displayed in the Lower Window frame border.    If the keyboard is used, it
will be necessary to TAB to the From and To dates then use the Page Up and Page Down 
keys to change the month and the arrow keys to change the day.    When through, press R 
or click on Restore to return to the previous display.

9.    Press Alt and S or click on Sort to access the Sort Menu.    Sorts can be performed by 
invoice number, invoice amount, order date, due date, number of days overdue and bill to
field.    While order and due dates are normally in the same sort sequence, if differing 
options (10, 20, 30 day etc.) are used this may not be the case.    Experiment with the 
various sort options.    

10. Press ALT and O or click on Options to access the Options Menu.    When Auto Order Date 
is enabled (checked), the order date is entered as todays date.    When Auto Due Date is 
enabled, the number of days entered in the AR.INI file will be added to todays date to 
calculate the due date.    File Maintenance covers editing AR.INI to change the number of 
days to add.    As shipped, the AR.INI entry is thirty days.    When Auto Number is enabled, 
invoice numbers are incremented as each invoice is entered.    In normal use, a check 
should appear by each auto option.

11. From the Options Menu, press C or click on Change Number.    Enter a new invoice 
number then select OK.    Up to seven digits can be accommodated.    The invoice 
numbering sequence can be changed anytime via Change Number.    While different 
invoice numbering sequences may be used for each file, if a number is duplicated in the 
same file the entry will be rejected.



12. To edit an invoice, highlight the invoice then press F2 or select Edit from the Edit Menu.    
Double clicking on an invoice will produce the same result and is preferred.    Use one of 
the methods and select an invoice to edit.    After the invoice appears, observe the various
fields but do not change any data.    Field descriptors enclosed in braces ([ ]) denote 
customer template fields.    Experiment with Next and Prev and page through the invoices.
Select Pg 2 and note that the last page appears.    Observe the various fields but do not 
change any data.    When through, select Cancel.    After the first page appears, select 
Cancel again.        

13. Press ALT and E or click on Edit to access the Edit Menu.    After the menu appears, press 
A or click on Add.    When the first page of the invoice appears, retrieve a template from 
the drop-down menu.    Note that templates are listed in alphabetical order.    Templates 
are created by entering data in the fields surrounded by braces ([ ]) then selecting TSave. 
Line 1 of Bill To is a required entry, other template fields are optional.    Templates are 
normally generated when an invoice is entered but can be created independently.    It is 
not advisable to create templates for other than repeat customers.    Templates are 
deleted by retrieving the template then selecting TDel.    When through, select Cancel to 
restore the previous display.

14. To delete an invoice, highlight the invoice then select Delete from the Edit Menu.    Check
that the correct invoice number is displayed in the dialog box then respond to the caution
and warning prompts.    Experiment by deleting three or four invoices and note the result. 

15. Press ALT and E or click on Edit to access the Edit Menu.    After the menu appears, press 
U or click on Undo and respond OK to the prompts.    Undo will restore the AR file to the 
last "saved" condition.    If the Save command was not used, the file will be restored to the
"as loaded" condition.    It should be noted that Undo restores the AR file and has no effect
on templates as they are stored in AR.TEM.    After a file is restored with Undo, the invoice 
number is adjusted to the previous value.    It is a good idea to check (via Change 
Number) that the previous value is satisfactory.

16. Press ALT and E or click on Edit to access the Edit Menu then select Copy and respond to 
the prompt.    The Copy command copies the list of invoices from the display to the 
Clipboard.    Before using the Copy command, invoices should be sorted as required.    The 
shortcut key F3 may be used in lieu of the Copy command.

17. Press ALT and F or click on File to access the File Menu.    When the menu appears, press 
O or click on Open.    After the Save File prompt appears, select No.    Use the arrow keys 
to highlight or click on TUTOR2.AR.    To change the start-up file, select the Start-up File 
button.    After the new start-up filename appears, select OK.    If all has gone well, 
TUTOR2.AR should be displayed.

18. Press ALT and F or click on File to access the File Menu.    After the menu appears, press X
or click on Exit.    When the Save File prompt appears, select Yes.    

19. Take a five or ten minute break then proceed to Sample Problem 2.



Sample Problem 2

1.      From Windows, start Accounts Receivable.    At the end of Sample Problem 1, the start-
up file was changed to TUTOR2.AR.    Check that the new start-up file is displayed.

2.      Press ALT and O or click on Options to access the Options Menu.    Ensure that Auto 
Order Date, Auto Due Date and Auto Number are enabled (checked).

3.      Press Alt and S or click on Sort to access the Sort Menu.    When the Sort Menu appears, 
press A or click on Amount.    Note that negative values (credit memos) precede positive 
values.

4.      Press ALT and F or click on File to access the File Menu.    When the menu appears, press
S or click on Save.    Respond Yes to the Save File prompt.    

5. To create a template and add an invoice, press ALT and E or click on Edit to access the 
Edit Menu.    After the menu appears, press A or click on Add.    An invoice number, order 
date, due date, bill to entry and one page 2 description are required to add an invoice.    
All other fields are optional.    Note that the invoice number, order and due date have 
been entered.    Type any four line Bill To address.    Press the ENTER key four times in lieu 
of typing a Ship To entry.    Note that if the Bill To and Ship To addresses are the same, 
pressing ENTER will duplicate the Bill To address.    If a different Ship To address is 
required, use the TAB key.    Type an entry for each Page 1 field then select TSave and 
save the template.    Templates are normally generated when an invoice is entered but 
can be created independently.    It is not advisable to create templates for other than 
repeat customers.    After the template is saved, select Pg 2.    Type several Page 2 entries 
then select OK.    After Page 1 appears, select Cancel.    When invoices are added, dates 
should be entered in tab sequence (i.e. order, due then ship date).    Each line entry can 
accommodate four digit quantities and a total of plus or minus $999,999.99.

6.    Add another invoice, using the template created in the previous step.    Check that the 
template contains an Account ID.    To link invoices to the same account, they must have 
the same Account ID.    An Account ID can consist of up to ten alphanumeric characters 
and is not case sensitive.    The Account ID is an optional field.    Some invoices generated 
to document a sale may not require a statement; if so, an Account ID is not required.    
Keep in mind that if an invoice does not have an Account ID, a statement cannot be 
printed nor will Acct be enabled.    When through return to the previous display.

7.    To delete the template created in step 5, press ALT and E or click on Edit to access the 
Edit Menu.    After the menu appears, press A or click on Add.    After Page 1 of the blank 
invoice appears, note that the number of templates and invoices is displayed in the upper
left corner of the form.    Retrieve the template (created in step 5) from the pull-down 
menu then select TDel.    If all has gone well, the number of templates should decrease.    
When through, select Cancel.

8.    To edit an invoice, double click on (or otherwise retrieve) one of the invoices created 
above.    Experiment by editing several Page 1 fields.    To capture an edit, the OK button 
on Page 2 must be selected.    Select Pg 2 and experiment by editing several fields.    
When through, select OK.    After Page 1 appears, select Cancel.

9.    To print an invoice, highlight the invoice then press ALT and F or click on File to access 
the File Menu.    After the menu appears, press P or click on Print Invoice and respond to 
the prompt.

10. To print a statement, highlight any invoice in the account then press Alt and F or click on 
File to access the File Menu.    After the menu appears, press R or click on Print Statement 
and respond to the prompt.    Note that accounts can be previewed before printing.    To 
preview an account, highlight any invoice in the account then press A or click on Acct.

11. Press ALT and E or click on Edit to access the Edit Menu.    After the menu appears, press 
U or click on Undo and respond OK to the prompts.    After a file is restored with Undo, the 
invoice number is adjusted to the previous value.    It is a good idea to check (with Change
Number from the Options Menu) that the previous value is satisfactory.

12. Press ALT and F or click on File to access the File Menu.    When the menu appears, press 



O or click on Open.    When the Save File prompt appears, select No.    After the Open 
dialog box appears, use the arrow keys to highlight or click on TUTOR1.AR.    To change 
the start-up file back to TUTOR1.AR, select the Start-up File button.    After the new start-
up filename appears, select OK.    If all has gone well, TUTOR1.AR should be displayed.

13. Press ALT and F or click on File to access the File Menu.    After the menu appears, press X
or click on Exit.    When the Save File prompt appears, select Yes.

14. If you are satisfied with your progress, move ahead to File Maintenance and create your 
actual AR files.    If you need more practice, repeat the sample problems. 



Display

Main Window
The Main Window displays the invoice number, amount, due date, days overdue and the bill 
to name.    Access to the File, Edit, Sort, Options and Help menus is available from the 
horizontal menu bar.    

Lower Window
The Lower Window contains the number of invoices (COUNT), number of overdue invoices 
(ODUE) and the active AR filename (FILE).    The Lower Window caption changes according to
the command selected.    A row of command buttons is located to the right of the Lower 
Window frame.    

Date Button
Pressing D or clicking on Date will display the day of the week, date and time.    The display 
appears inside the Lower Window frame as long as the key or mouse button is depressed.    
Releasing the key or mouse button restores the previous display.

Cal Button
Pressing C or clicking on Cal will display the perpetual calendar.    After the calendar is 
displayed, it can be scrolled by month or year.    The calendar displays the years from 1899 
through 2090.    Pressing C or clicking on Cancel will restore the previous display.

Acct Button
Pressing A or clicking on Acct (Account ID) will display all invoices in the active file that have 
the same Account ID.    The number of invoices, overdue invoices and the Account ID will be 
displayed in the Lower Window.    The account total will be displayed in the Lower Window 
frame border.    Selecting Restore will cancel the selection.

List Button
Pressing L or clicking on List displays two scroll bar operated date controls.    After a From 
and To date entry, selecting OK will display all invoices, in the active file, whose due dates 
fall within the selected range.    The selected range is displayed in the Lower Window frame 
border.    Selecting Restore will cancel the selection.

Summary Button
Pressing U or clicking on Summary will display a summary of the active file.    Active file 
debits, credits, file total, overdue debits, percent debits overdue, average days overdue and 
the number and amount of overdue invoices for varying periods are displayed.    Selecting 
OK will restore the previous display.

Overdue Button
Pressing V or clicking on Overdue will display all overdue invoices in the active file.    After 
Overdue is selected, the Lower Window is captioned Overdue.    Selecting Restore will cancel 
the selection.

Restore Button
After Acct, Overdue or List is selected, the Restore button is displayed.    Pressing R or 
clicking on Restore will terminate an Acct, Overdue or List selection.



File Menu Commands

Open 
After Open is selected, all files with an AR extension are listed alphabetically.    To open a file,
make a selection from the list box then choose OK.    Any AR file can be selected as the start-
up file.    To change the start-up file, highlight the filename then select the Start-up File 
button.    After the start-up filename is displayed, select OK.    Note that AR files must be 
located in the directory that contains the Accounts Receivable files.    

Save 
The Save command saves the active file shown in the Lower Window.            

Print Invoice
To print an invoice, first highlight the invoice then select Print Invoice.    Check that the 
printer is on-line and has an adequate supply of letterhead stock then respond to the 
prompt.    As many copies as required may be printed.    It is advisable to print via Print 
Manager.    Check that the Control Panel Printer dialog box has an X in the Use Print Manager 
check box.

Print Statement
To print a statement, highlight an invoice in the account then select Print Statement.    Check
that the printer is on-line and has an adequate supply of letterhead stock then respond to 
the prompt.    The statement will list overdue invoices that have the same Account ID.    Note 
that invoices with negative or zero days overdue are not included.    As many copies as 
required may be printed.    It is advisable to print via Print Manager.    Check that the Control 
Panel Printer dialog box has an X in the Use Print Manager check box.

New 
To add a new AR file, select New.    After the text box appears type the name of the file to be 
added.    Do not type the extension as it is appended to the filename.    If an attempt is made 
to enter a duplicate filename, the entry will be rejected.      Note that all AR files must be 
located in the directory that contains the Accounts Receivable files.    

Exit
Selecting Exit will end the Accounts Receivable session.



Edit Menu Commands

Edit
To edit an invoice, highlight the invoice then select Edit from the Edit Menu.    The shortcut 
key F2 may be used in lieu of the Edit command.    Alternatively, double clicking the invoice 
will produce the same result.    After Page 1 of the invoice appears, entries may be edited.    
To record any changes Pg 2 (Page 2) must be selected.    The OK button (Page 2) must be 
selected to record any changes.    If additional invoices have to be edited Next and Prev can 
be used to page through the file.    After OK has been selected, select Cancel from Page 1 to 
return to the previous display.

Add
To add an invoice and/or customer template, select Add from the Edit Menu.    After Add is 
selected, the first page of a blank invoice is displayed.    If a template is available, use the 
drop-down menu and select a template then enter the Page 1 data.    Field descriptors 
surrounded by braces ([ ]) denote template fields.    If a new template is required, select 
TSave to save the template.    If an invoice is not required select Cancel otherwise select the 
Pg 2 button and complete the entries.    Each invoice can accommodate up to five entries.    
The OK button, (Page 2) must be selected to record the new invoice.    If additional invoices 
are not required, select Cancel from Page 1 to return to the previous display.    To delete a 
template, select the template from the drop-down menu then choose TDel and respond to 
the prompts.

Delete
To delete an invoice, highlight the invoice then select Delete from the Edit Menu.    Check 
that the correct invoice number is displayed in the dialog box then respond to the caution 
prompt.    After the warning prompt appears, select OK to delete the invoice or Cancel to 
abort.

Copy
The Copy command copies the list of invoices from the display to the Clipboard.    Before 
using the Copy command, a sort should be performed to group the invoices in the desired 
order.    After Copy is selected, respond to the prompt.    Note that the shortcut key F3 may be
used in lieu of the Copy command.

Undo
The Undo command will restore the active file to the previous "saved" condition.    If the Save
command was not used, the file will be restored to the "as loaded" condition.    To undo 
changes to the active AR file, select Undo from the Edit Menu and respond to the prompts.



Sort Menu Commands

Invoice
Sorts invoices by invoice number.

Amount
Sorts invoices by amount.    Invoices with a negative balance (credit memos) are displayed 
with a minus sign preceding the amount.

Order Date
Sorts invoices by order date.    Normally order and due dates are in the same sort sequence.  
In cases where differing payment options (10, 20, 30 day etc.) are offered, an order date sort
may be required.    Note that two digit years from 90 to 99 are treated as 19XX.    Years from 
00 to 89 are treated as 20XX.

Due Date
Sorts invoices by due date.    Note that two digit years from 90 to 99 are treated as 19XX.    
Years from 00 to 89 are treated as 20XX.

Days Odue
Sorts invoices by the number of days overdue.    Invoices that are not overdue will be 
displayed with a zero or minus sign preceding the number of days overdue.

Bill To
Sorts invoices by the bill to field.    The sort is not case sensitive.



Options Menu Commands

Auto Order Date
If Auto Order Date is enabled (checked), todays date will be entered as the order date.    
Even though Auto Order Date is enabled, the order date can be overwritten.    

Auto Due Date 
If Auto Due Date is enabled, the number of days in the AR.INI file is added to todays date to 
obtain the due date.    As shipped, the AR.INI entry is thirty days.    File Maintenance covers 
editing AR.INI to increase or decrease the number of days added to todays date.    Even 
though Auto Due Date is enabled, the due date can be overwritten.

Auto Number
If Auto Number is enabled, invoice numbers are incremented as each invoice is entered.    
Even though Auto Number is enabled, the invoice number can be overwritten.

Change Number
Change Number changes the next invoice number.    If Auto Number is enabled, the invoice 
number will be incremented as each invoice is entered.    Up to seven digit numbers can be 
accommodated.    The invoice numbering sequence can be changed anytime via Change 
Number.    While different invoice numbering sequences may be used for each file, if a 
number is duplicated in the same file the entry will be rejected.



File Maintenance

Creating Working AR Files
Invoice files can have any valid filename but are assigned an AR extension.    Any AR file can 
be designated as the start-up file.    AR files that are no longer required can be deleted from 
Windows or the DOS prompt.    As many AR files as the hardware can support may be 
created.    Note that all Accounts Receivable files must reside in the same directory.    Each AR
file and statement can accommodate up to two hundred invoices.    Templates are stored in 
AR.TEM.    Up to one hundred templates can be stored in AR.TEM.    If more are required, 
multiple instances may be used.    In the example that follows, your filename may be 
substituted for 93OCT.    To create a working AR file, proceed as shown:

1.    Select New from the Accounts Receivable File Menu. 
2.    Enter the new filename, type: 93OCT then select OK.
3.    Select Open from the File Menu and respond to the Save File prompt as required.
4.    Highlight 93OCT.AR then select OK.
5.    Select Add from the Edit Menu.
6.    Type the Page 1 entries.    If a customer template is required, select TSave before 

selecting the Pg 2 button.    Note that field descriptors surrounded by braces ([ ]) denote 
template fields.    It is not advisable to create templates for other than repeat customers.

7.    Type the Page 2 entries then select OK.    The OK button must be selected to record the 
invoice.

8.    Enter the remaining invoices (select a template from the drop-down menu if one is 
available) in the manner described above.    

9.    After all invoices have been entered, select the Page 1 Cancel button.

Customizing AR.INI
AR.INI contains eight entries, each on a separate line, in the order shown:

                  Line 1. Company name.
                  Line 2. Start-up filename.
                  Line 3. Auto Order Date (enabled/disabled).
                  Line 4. Auto Due Date (enabled/disabled).
                  Line 5. Auto Number (enabled/disabled).
                  Line 6. Days to add to the Due Date entry.
                  Line 7. Next invoice number.
                  Line 8. Invoice/statement spacing (lines from top of form).

It is necessary to edit AR.INI to add your company name (Line 1) to the Lower Window frame
border, to change the number of days to add to the order date (Line 6) or to adjust the 
spacing (Line 8) to accommodate your letterhead stock.    In any event, editing should be 
limited to lines 1, 6 and 8.    It is not necessary to edit other entries.    To edit AR.INI with 
Notepad, proceed as shown:

1.    From the Windows Program Manager open the Accessories window then select Notepad. 
2.    From the Notepad File Menu, select OPEN.
3.    If the Accounts Receivable files are in the AR directory on drive C type: C:\AR\AR.INI then 

select OK.    If a directory or drive designator other than that shown is used, substitute the
correct directory name and/or drive designator. 

4.    Overwrite the existing name (Line 1) with your company name.    Use upper and lower 
case characters; up to 35 characters may be used.    If your payment option is other than 
30 days, edit Line 6.    For example if payment is due in 15 days, overwrite 30 with 15.    If 
your letterhead requires a different top of form spacing, edit Line 8.    To print closer to the
top of form, decrease the setting.    To print further down, increase the setting.



5.    After editing is complete, press CTRL and END.    Check that the cursor is in the home 
position beneath the last line of text.

6.    Select SAVE AS from the Notepad File Menu.    Save the file as C:\AR\AR.INI.    If a 
directory or drive designator other than that shown is used, substitute the correct 
directory name and/or drive designator.

7.    When through, select EXIT From the Notepad File Menu.



Registration

This version of Accounts Receivable is distributed 'as is' without warranty as user supported 
shareware.    Accounts Receivable may be uploaded to bulletin boards and/or distributed by 
shareware dealers.    When distributed as shareware, reasonable charges may be applied.    
Accounts Receivable is entirely supported by registration fees.    The user is granted a non-
exclusive license to copy and freely share the program with others.    Should the software be 
used beyond a 30 day trial period, registration is required.    As a registered user, you receive
free updates for a period of one year from the registration date.    When you register, if you 
do not have the latest version, we will ship you the current version.    To register, complete 
the registration form, enclose the registration fee (CA residents please add state tax) and 
mail to the address shown below.

==============================================
=================
Cribsheet Software Accounts Receivable Ver 1.1 Registration Form
==============================================
=================
Name __________________________________________ Date ___________
Address Line 1 ___________________________________________________
Address Line 2 ___________________________________________________
City/State/Province ____________________ Phone (day) _________________
Country/Postal Code ___________________ Media Size (3 1/2 or 5 1/4) _____
Type Computer _________________ Type Network/Nodes _______________

Registration/Site License Fees
1 - 5 copies    $20 US per CPU/node              Number Copies _______________
6 or more            $19 US per CPU/node      Amount Enclosed _______________

Form of Payment (Visa/MasterCard/Cash/Check/Other) __________________
Card Number ___________________________ Expiration Date ____________
Print Name on Card _______________________________________________
Signature _______________________________________________________

Comments/Suggestions ___________________________________________
_______________________________________________________________
_______________________________________________________________
==============================================
=================
Cribsheet Software, 4455 Torrance Blvd., Ste 273, Torrance, Ca 
90503
==============================================
=================



Clipboard                                
                                
The Clipboard is a temporary storage area.    You can paste Accounts Receivable entries into 
a Windows application from the Clipboard.


