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Section 1 - Solaris

1.0 Overview 
These installation and release notes provide new information relevant to this version 
TEAM 6000 software product. This updates the information supplied by the TEAM 6
Operation Manual. If you require additional details please refer to that manual.

Team 6000 is now supported on the following Solaris platforms: Solaris 2.7 with HPO
6.1 and Solaris 2.8 with HPOV 6.1. For the latest product information, check the GD
website at http://www.gdc.com  or contact your GDC field representative.

2.0 Software Reference
Throughout this manual, short forms of the software product names will be used. Th
following tables provide detailed reference information for all software modules relev
to TEAM 6000 for Solaris installation. 

Table 1:  Software Reference for Solaris 

Item Part Number/Description Version / Release

TEAM 6000 Software Product 058U638-C01A Ver 3.0.0

TEAM 6000 Operation Manual 058R608-V300 Latest issue

Solaris Software Product S-058U019-C01 Ver 2.7 / Nov 1999 

S-058U020-000 Ver 2.8 / Feb 2000 Ver A

HPOV for Solaris Software Prod-
uct

Full: 759-065S002 (Enterprise)
Entry 759-065S003 (250 Node)

Ver 6.1

Solaris/HPOV Patch Clusters Ref: Sun / HP websites

HPOV Network Node Manager 
Installation Guide

HP J1136-9000

Table 2: TEAM 6000 Software Packages

Package Name Description Version

GDCTeam GDC TEAM Utilities Ver 3.0

GDCSelf6 GDC Shelf 6000 Ver 3.0

GDCMp6360 GDC Metroplex 6360 Ver 3-0

GDCMp6441 GDC Metroplex 6441 Ver 3-0

GDCMp6520 GDC Metroplex 6520 Ver 3-0

GDCMp6380 GDC Metroplex 6380 Ver 3-0

GDCMp6521 GDC Metroplex 6521 Ver 3-0
e Notes for GDC Part No. 058U638-C01A and 058U738-C01A Page 5
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2.1 TEAM 6000 Verification
The TEAM 6000 CD contains the software packages listed in the table above. After 
installation is completed, these packages should be present on the system at the ve
indicated in the table or greater. To verify the presence of the TEAM 6000 packages
currently installed type the following command:

/usr/bin/pkginfo -1 <PackageName>

3.0 Improvements Since Last Release
This is the initial release of TEAM 6000 software. This software has been tested to be
2000 compliant in accordance to GDC ENG-STD-003. Check GDC's web site at 
http://www.gdc.com for the latest Year 2000 information. Note the following new 
information concerning this software:

• The application is approved for operation on SUN Solaris 2.7, Solaris 2.8, HP 
OpenView 6.1 and HPUX 11.0 upgrades. 

4.0 Corrected Issues
None.

5.0 HP OpenView for Solaris
The following sections describe the current requirements and procedures concernin
HP OpenView for Solaris version of TEAM 6000 software.

5.1 Hardware Requirements
• SUN ULTRA 5 or greater with a minimum of 96 megabytes of RAM

• 2 gigabytes of hard disk space with 350 megabytes free disk space and 192 meg
of swap space

• Minimum disk space requirements:

/opt 75 megabytes

• The graphics card should support a resolution of 1152x900.

• CD ROM drive

Note: 96 megabytes of RAM is sufficient to support 1 or 2 users logged into the workstatio
running individual OpenView Windows sessions. Reduced performance can occur w
additional users accessing the workstation for remote login. To avoid problems, incr
RAM based on the expected number of simultaneous users and on the number of T
applications in use. Allow 25 megabytes of RAM for each additional user, and 3 
megabytes for each TEAM application. You should also adjust swap space to be 
approximately twice the size of the RAM. 
Release Notes for GDC Part No. 058U638-C01A and 058U738-C01A
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Note: For information on hardware requirements for HP OpenView Network Node Manage
products, refer to the HP OpenView Network Node Manager Products Installation G

5.2 Software Requirements
Before installing this version of TEAM 6000, the following software must be installed
Refer to Table 1: Software Reference for Solaris, for detailed identification of all softw
products discussed below. 

• Solaris Software

• HP OpenView for Solaris, Entry or HP OpenView for Solaris, Full

• TEAM 6000 software packages

Note: IMPORTANT - It is highly recommended that the customer download and install the l
SOLARIS PATCH CLUSTER from the following Sun web site: http://sunsolve.sun.co
This will ensure that you have updated the Operating System along with any current
to reported problems.

Note: IMPORTANT - It is highly recommended that the customer download and install the l
HP OPENVIEW CONSOLIDATED PATCH CLUSTER from the following HP web sit
http://ovweb.external.hp.com/cpe/patches. This will ensure that you have updated H
OpenView along with any current fixes to reported problems.

5.3 First Time Installation
To install the current TEAM 6000 software, perform the following steps. If you are 
installing the TEAM 6000 software in a Distributed Environment, perform the speciali
procedures in the next later sections of this document.

1. Make sure that all users exit HP OpenView for Solaris.

2. Insert the TEAM 6000 Compact Disk into the CD ROM drive.

3. At a shell prompt become super-user by entering the following command:

su root

4. To stop HP Open View daemons, type:

opt/OV/bin/ovstop

5. Start the installation process by entering the following commands:

cd /cdrom/cdrom0/solaris

6. If a version of the TEAM 6000 is already resident on the workstation, or if you a
not sure if it is resident, enter the following command before attempting to instal
new version:

./remove.sh

Ignore any error messages that may appear and answer y  for the questions.
e Notes for GDC Part No. 058U638-C01A and 058U738-C01A Page 7
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file:
7. Continue the installation process by entering the following command:

./install.sh

Answer y  for the questions. The loading of software will take a few minutes.

8. Start HP Open View daemons by typing: /opt/OV/bin/ovstart  

9. Type cd /

10. Type eject /

11. Exit super-user (type exit ).

12. Remove the CD from the CD ROM drive.

13. Update each HP Open View user’s environment by changing your environment 
scripts (with textedit or your favorite editor) as follows:

C (csh) Shell users - add the following lines to #HOME/.cshrc:

source /opt/OV/bin/ov.envvars.csh

set path=($path $OV_BIN)

Bourne (sh) and Korn (ksh) Shell users - add the following lines to #HOME/.pro

. /opt/OV/bin/ov.envvars.sh

PATH=$PATH:$OV_BIN;export PATH

These updates do not take effect until you log out and log back in. 

14. Start HP Openview by typing:

/opt/OV/bin/ovw &

5.3.1 De-Installation
To remove TEAM 6000 software:

1. Make sure that all users exit HP OpenView for Solaris.

2. Insert the TEAM 6000 Compact Disk into the CD ROM drive.

3. At a shell prompt, become super-user.

4. To stop HPOpen View, type:

/opt/OV/bin/ovstop 

5. Start the removal process by entering the following command:

cd /cdrom/cdrom0/solaris

./remove.sh

6. To start all HP Open View, type

/opt/OV/bin/ovstart

7. Exit super-user (type exit ).

8. Remove the CD from the CD ROM drive.
Release Notes for GDC Part No. 058U638-C01A and 058U738-C01A
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5.3.2 Re-Installation
To re-install TEAM 6000 software, it is necessary to first perform all the steps in the 
installation procedure. This removes all TEAM 6000 packages. You can then repeat
steps of the Installation Procedure described earlier in this chapter. You will not nee
repeat the user environment update procedure.

5.4 Installation in a Distributed Environment
The OpenView distributed operating environment uses three categories of workstati
Management Station, Collection Stations, and Management Consoles. No special se
required for Management Stations and Management Consoles. The following proced
are required for workstations that serve as Collection Stations.

Note: If additional information on distributed environment installations is desired, refer to th
following documents: 
HP OpenView: A Guide to Scalability and Distribution for Network Node Manager
GDC TEAM Core Release Notes

1. Become a super user by typing su  and supplying the super user password.

2. Setting up environment variables by typing the following commands:

/usr/bin/sh

. /opt/OV/bin/ov.envvars.sh

3. Insert the TEAM 6000 CD into the CDROM drive. If not already present, create 
/cdrom  directory now.

4. Type the following command:

mount /dev/dsk/ct0t2d0 /cdrom

5. Register GDC Trap format by typing the following:

$OV_BIN/xnmevents -merge 

/cdrom/cdrom0/solaris/shelf6000trapd.conf

6. Start the Event system configurator GUI by typing:

$OV_BIN/xnmtrap
e Notes for GDC Part No. 058U638-C01A and 058U738-C01A Page 9
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7. Set up Event Forwarding to the management station, using the GDC and HPOV
reference documents listed above to forward the events listed in the table below

A. From the Enterprise Identification pane, select an Enterprise Name

for example: gdc_6001

B. From the Event Identification pane, select an Event Name

for example: mp6001Diversity

C. From the Event Configuration window menu bar, select Edit->Modify 
Event . The Event Configurator/Modify Event dialog box appears.

D. Click on the Forward Event check box to expand the dialog box. The Forward
Event Destinations pane displays.

E. Type the hostname or IP Address for destination. Destinations are the mana
ments stations to which events will be forwarded. 

F. Repeat steps 5A through 5E for each of the events listed in the Event Forwa
table above.

8. When all events are forwarded, click OK in the Event Configurator/Modify Event 
dialog box.

9. At the Event Configuration window, click File->Save  to save the changes.

10. To cause Openview processes to re-read the trapd.conf file, generate Event by t

$OV_BIN/xnmtrap -event

11. Unmount the CDROM by typing:

cd /

umount /cdrom

5.4.1 Updating Distributed Environments
Following the first time installation procedure, you will need to update each HP Open V
user’s environment by changing your environment scripts (with textedit or your favorite 
editor). The procedures vary depending on the type of window manager being used.
following instructions apply to the Common Desktop Environment, sometimes referre
as the DT desktop window manager.

Use your favorite editor to change environment scripts described in the procedure b
After changes are made, you must logout and login for the changes to take effect.

Enterprise Name (ID) Event Name (Identifier)

gdc_6001(.1.3.6.1.4.1.498.15.2) mp6001Diversity(.1.3.6.1.4.1.498.15.2.0.1)

gdc_6001(.1.3.6.1.4.1.498.15.2) mp6001ColdStart(.1.3.6.1.6.3.1.1.5.1)

gdc_6001(.1.3.6.1.4.1.498.15.2) mp6001WarmStart(.1.3.6.1.6.3.1.1.5.2)

gdc_6001(.1.3.6.1.4.1.498.15.2) mp6001LinkDown(.1.3.6.1.6.3.1.1.5.3)

gdc_6001(.1.3.6.1.4.1.498.15.2) mp6001LinkUp(.1.3.6.1.6.3.1.1.5.4)

gdc_6001(.1.3.6.1.4.1.498.15.2) mp6001Authentication(.1.3.6.1.6.3.1.1.5.5)
0 Release Notes for GDC Part No. 058U638-C01A and 058U738-C01A
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Common Desktop Environments

1. In order to use the CDE you need to make a change in the $HOME/.dtprofile  
file. First, open and read the $HOME/.dtprofile  document with your editor

Note: The lengthy dtprofile document provides information on using the C (csh), Bourne (s
and Korn (ksh) shells in the CDE. 
It also cautions against the use of certain terminal commands which can prevent log
in. Commands are generally present in .login  and .cshrc  files when using the csh 
shell, or in .login  and .profile files  when using the sh or ksh shells.

2. After reviewing the dtprofile comments, edit the $HOME/.dtprofile  file to 
remove the leading pound sign(s) in the line that contains:

### DTSOURCEPROFILE=true

3. If you are using C (csh) Shell you must add the following lines to $HOME/.cshrc

source /opt/OV/bin/ov.envvars.csh

set path=($path $OV_BIN)

4. If you are using Bourne(sh) shell or Korn(ksh) shell you must add the following li
to $HOME/.profile

. /opt/OV/bin/ov.envvars.sh

PATH=$PATH:$OV_BIN; export PATH

5. Log out and then log back in for these updates to take effect.

Sun Open Windows

1. If you are using C (csh) Shell you must add the following lines to $HOME/.cshrc

source /opt/OV/bin/ov.envvars.csh

set path=($path $OV_BIN)

2. If you are using Bourne(sh) shell or Korn(ksh) shell you must add the following li
to $HOME/.profile:

. /opt/OV/bin/ov.envvars.sh

PATH=$PATH:$OV_BIN; export PATH

3. Log out and then log back in for these updates to take effect.

These updates do not take effect until you log out and log back in. 

5.4.2 De-Installation in a Distributed Environment
1. Become a superuser by typing su  and supplying the superuser password.

2. Setting up environment variables by typing the following commands:

/usr/bin/sh

. /opt/OV/bin/ov.envvars.sh

3. Start the Event system configurator GUI by typing:

$OV_BIN/xnmtrap
e Notes for GDC Part No. 058U638-C01A and 058U738-C01A Page 11
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4. Undo Event Forwarding according to the list below. 

A. Use Edit->Delete->Event  to select each event and delete it.

B. Use Event->Delete->Enterprise Identifier  to delete the enterprise

C. At the Event Configuration window, save the changes by clicking File->Save.

5.5 Post-Installation Procedure For All Solaris Environments
Once the TEAM 6000 software has been installed in the desired environment, the follo
procedure must be performed to enable IP Discovery.

1. After completing installation and environment setup, open the root map.

2. At the options pulldown menu, select Network Polling Configuration: 
IP .

3. At the Configuration Area, select IP Discovery . 

4. Enable the Discover New IP Nodes  option by selecting its checkbox.

5. Click OK. Discovery will begin at once and the Universe map will start to show th
discovered shelves.

6.0 Known Issues
• The keyboard Num Lock or Caps Lock  key, if pressed ON will make the mouse

buttons and the scroll bars inoperable.

• A general SNMP error may occur if certain configuration changes are attempted w
a diagnostic test is in progress. For example, an attempted reconfiguration of a ch
card’s assigned timeslot is not allowed while the channel is in test, a general SN
error will result.

• An out of focus problem may exist on a Configuration application when editing th
System Name, System Location or System Contact fields. Usually, when change
entered in these fields, a File->Save selection will cause the new entry to turn wh
indicating a pending edit before a Save operation is initiated. If an out of focus ev
occurs on these fields, the File-Save selection will not mark the field for edit (whi
and will send the change to the unit. You need to perform the Save operation to 
the field marked for edit (white) and then perform a second Save operation to co
the change to the unit.

Enterprise Name (ID) Event Name (Identifier)

gdc_6001(.1.3.6.1.4.1.498.15.2) mp6001Diversity(.1.3.6.1.4.1.498.15.2.0.1)

gdc_6001(.1.3.6.1.4.1.498.15.2) mp6001ColdStart(.1.3.6.1.6.3.1.1.5.1)

gdc_6001(.1.3.6.1.4.1.498.15.2) mp6001WarmStart(.1.3.6.1.6.3.1.1.5.2)

gdc_6001(.1.3.6.1.4.1.498.15.2) mp6001LinkDown(.1.3.6.1.6.3.1.1.5.3)

gdc_6001(.1.3.6.1.4.1.498.15.2) mp6001LinkUp(.1.3.6.1.6.3.1.1.5.4)

gdc_6001(.1.3.6.1.4.1.498.15.2) mp6001Authentication(.1.3.6.1.6.3.1.1.5.5)
2 Release Notes for GDC Part No. 058U638-C01A and 058U738-C01A
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• The configuration application may erroneously allow the same time slot to be assi
to two channels. The following sequence allows this to occur:

A. Two channels are assigned the same time slot on different LIUs.

B. The LIU is changed on one of the channels, making it the same as the other 
nel.

C. Performing a Refresh may then indicate that one of the time slots is OFF.

• On the Metroplex 6001 Error Reports application, changing the interface type res
in the Totals screen, after resizing, to contain gray areas. To prevent extra gray ar
the screen, close the Totals screen before changing interface type.

• Some TEAM applications may display meaningless characters in the application
window headings. This is due to a font conflict which can be resolved by typing t
following on the command line before running ovw:

xrdb -merge /opt/OV/bin/gdc_load_resources

• In some TEAM application windows, slight text misalignments may appear. Thes
not affect the usability or operation of the application.

• On the Front Panel display, some LED labels may appear out of alignment over 
associated LEDs. This does not affect the operation of the application.

• In the Configuration application, in order to save changes made to any of the fou
Alarm masks, you must use the telnet or craft interface. Otherwise, changes will n
saved to the system. 

7.0 Operating Guidelines
• Because the read-only maps are not automatically updated, use Map -> Refresh M

update the maps.

• After an installation of the TEAM software or a reboot of the system, TEAM 
applications may take up to one minute to start up, due to the loading of the shar
libraries.

• After an installation of TEAM software, the user must enable Discover New IP 
Nodes  from the root map Options menu in order for shelf discovery to occur. 

• In some TEAM applications, the text label associated with the Help link does not
display. This does not affect the operation of the Help link.
e Notes for GDC Part No. 058U638-C01A and 058U738-C01A Page 13



Publication No. 086R902-V300 TEAM 6000 Version 3.0.0
Issue 3 - March 2001

Page 1
4 Release Notes for GDC Part No. 058U638-C01A and 058U738-C01A



TEAM 6000 Version 3.0.0 Publication No. 086R902-V300
Issue 3 - March 2001

Releas

of the 

e 
ant 
Section 2 -HPUX

1.0 Overview 
These installation and release notes provide new information relevant to this version 
TEAM 6000 software product. This updates the information supplied by the TEAM 6000 
Operation Manual. If you require additional details please refer to that manual.

Team 6000 is now supported on HPUX 11.0 with HPOV 6.1. For the latest product 
information, check the GDC website at http://www.gdc.com  or contact your GDC 
field representative.

2.0 Software Reference
Throughout this manual, short forms of the software product names will be used. Th
following tables provide detailed reference information for all software modules relev
to TEAM 6000 for HPUX installation. 

Table 1:  Software Reference for HPUX 

Item Part Number Version / Release

TEAM 6000 Software Product 058U738-C01A Ver 2.1.0

TEAM 6000 Operation Manual 058R694-V210 Issue 1

HPOV NNM Software Product Rev 6.1

HPUX Ver 11.0 / November 1999

HPUX and HPOV Patches Ref: HP website

HPOV Network Node Manager 
Installation Guide

HP J1136-9000 Latest Release

Table 2: TEAM 6000 Software Packages

Package Name Description Version

GDCTeam GDC TEAM Utilities Ver 3.0

GDCSelf6 GDC Shelf 6000 Ver 3.0

GDCMp6360 GDC Metroplex 6360 Ver 3-0

GDCMp6441 GDC Metroplex 6441 Ver 3-0

GDCMp6520 GDC Metroplex 6520 Ver 3-0

GDCMp6380 GDC Metroplex 6380 Ver 3-0

GDCMp521 GDC Metroplex 6521 Ver 3-0
e Notes for GDC Part No. 058U638-C01A and 058U738-C01A Page 15
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2.1 TEAM 6000 Verification
The TEAM 6000 CD contains the software packages listed in the table above. After 
installation is completed, these packages should be present on the system at the ve
indicated in the table or greater. To verify the presence of the TEAM 6000 packages
currently installed type the following command:

/usr/sbin/swlist -1 fileset TEAM6000 <PackageName>

3.0 Improvements Since Last Release
This is the initial release of TEAM 6000. This software has been tested to be Year 2
compliant in accordance to GDC ENG-STD-003. Check GDC's web site at 
http://www.gdc.com for the latest Year 2000 information. Note the following new 
information concerning this software:

• The application is approved for operation on SUN Solaris 2.7, Solaris 2.8, HP 
OpenView 6.1 and HPUX 11.0 upgrades. 

• Alarm Severity support

• T1 HDSL support

4.0 Corrected Issues
None.

5.0 Hardware Requirements
• HP 9000 series model 700 or greater

• Minimum of 96 Megabytes of RAM and 2 Gigabytes of hard disk space with 350
megabytes free disk space and 500 megabytes of swap space

• Minimum disk space requirements:

/opt 60 megabytes

• CD ROM drive

Note: For information on hardware requirements for HP OpenView Network Node Manage
products, refer to the HP OpenView Network Node Manager Products Installation G
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6.0 Software Requirements
Before installing this version of TEAM 6000, the following software must be installed
Refer to Table 1: Software Reference for HPUX, for detailed identification of all softw
products discussed below.

System Software Requirements

• HP OpenView NNM 

• HPUX

• The most recent HPUX and HP OpenView patches for these versions

• TEAM 6000 Software Packages

Note: IMPORTANT - It is highly recommended that the customer download and install the
latest HP OPENVIEW CONSOLIDATED PATCH CLUSTER from the following HP w
site: http://ovweb.external.hp.com/cpe/patches. This will ensure that you have update
OpenView along with any current fixes to reported problems. 
Refer to the HPUX web site for updates to the HPUX 11.0 Operating System.

Note: It is the customer’s responsibility to install the listed HP software and patches, and to
ensure they are fully operational before loading the General DataComm TEAM 
applications.
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Publication No. 086R902-V300 TEAM 6000 Version 3.0.0
Issue 3 - March 2001

Page 1

 
, 

l - 

ities 
 being 
 the 
 SD 

ow 

 

6.1 First Time Installation
1. Close all HP OpenView and TEAM application windows (if applicable). 

2. Make sure that all users exit HP OpenView.

3. Insert the TEAM 6000 Compact Disk into the CD ROM drive.

4. At a shell prompt become super-user by entering the following command:

su

5. Verify that there is a /cdrom  directory already present. If not, create it. 

6. Enter the following commands: 

csh

mount /dev/dsk/c0t2d0 /cdrom

cd /cdrom/hpux

./INSTALL*

The install script will automatically stop HP OpenView background processes by
running /opt/OV/bin/ovstop . Files will then be extracted from CD to hard disk
an operation that will take a few minutes.

The script then automatically runs swinstall , which displays a graphical user 
interface for installing the TEAM 6000 software. The window will have “SD Instal
Software Selection” in its title bar. 

7. Select GDC_APPS from the window’s scroll-down list and double click on it. 

Note: The displayed version number for GDC_APPS is always OV3.0.0.

8. In the resulting list, highlight the TEAM 6000 applications to be installed.

9. Select Actions->Mark for Install .

10. Select Actions ->Install (analysis) .

11. Select OK in the “Install Analysis” dialog box to proceed.

12. Select Yes in the “Confirmation” popup to continue with the installation.

Note: If the installation stops, displaying an error message, it may be that a GDCTeam util
application package has been detected on the host that is more recent than the one
installed. To resolve the conflict, consult the first entry in the Log File (as prompted in
error message), then click the Cancel button in the Install Analysis window. From the
Install window menu bar, select Options ->Change Options. When the Options wind
appears, scroll to “Autoselect dependencies when marking software” and click the 
selection box (deselects the option). Then, click OK. You can now install software 
packages selectively. Resume the installation from Step 8 - this time, not selecting 
GDCTeam. When a Dependency Message Dialog window appears, click OK.

13. When the installation is complete, the Done button in the Install window is no longer
grayed out. Select Done now.

14. At the end, select File->Exit  in the main “SD Install” window.
8 Release Notes for GDC Part No. 058U638-C01A and 058U738-C01A
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The script will automatically run /opt/OV/bin/ovstart  to start HP OpenView 
background processes.

15. Exit super-user (type exit ).

16. Update each HP Open View user’s environment by changing your environment 
scripts (with textedit or your favorite editor) as follows:

C (csh) Shell users - add the following lines to #HOME/.cshrc:

source /opt/OV/bin/ov.envvars.csh

set path=($path $OV_BIN)
xhost + HostName

Bourne (sh) and Korn (ksh) Shell users - add the following lines to #HOME/.pro

. /opt/OV/bin/ov.envvars.sh

PATH=$PATH:$OV_BIN;export PATH

These updates do not take effect until you log out and log back in. 

17. Unmount the CD ROM by typing:

cd /

umount /cdrom

exit

18. Remove the CD from the drive, then confirm HP Openview and TEAM processe
running by typing:

/opt/OV/bin/ovstatus

19. If all processes are running, log out from root by typing exit

20. Exit super-user (type exit ).

21. Start HP Openview by typing:

/opt/OV/bin/ovw &

6.2 Post-Installation Procedure For All HPUX Environments
Once the TEAM 6000 software has been installed in the desired environment, the follo
procedure must be performed to enable IP Discovery.

1. After completing installation and environment setup, open the root map.

2. At the Options menu, select Network Polling Configuration: IP .

3. At the Configuration Area, select IP Discovery . 

4. Enable the Discover New IP Nodes  option by selecting its checkbox.

5. Click OK. Discovery will begin at once and the Universe map will start to show th
discovered shelves.
e Notes for GDC Part No. 058U638-C01A and 058U738-C01A Page 19
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6.3 De-installation

Note: TEAM 6000 shares the GDCTEAM utilities packages in common with other TEAM 
applications. Therefore, do not remove GDCTEAM utilities package unless you are 
certain that there are no other applications installed on the workstation that require i

1. Make sure that all users exit HP OpenView.

2. Insert the TEAM 6000 Compact Disk into the CD ROM drive.

3. At a shell prompt, become super-user by typing 

su

4. Start the removal process by entering the following commands:

csh

mount /dev/dsk/c0t2d0  /cdrom

cd /cdrom/hpux

./REMOVE*

The remove script will automatically stop HP OpenView background processes 
running /opt/OV/bin/ovstop . The script then automatically runs swremove , 
which opens a window “SD Remove - Software Selection” for removing existing
TEAM6000 software. 

5. Select GDC_APPS from the window’s scroll-down list and double click on it.

6. Select Actions->Mark for Remove .

7. Select Actions ->Remove (analysis) .

8. Select OK in the “Remove Analysis” dialog box to proceed.

9. Select Yes in the “Confirmation” popup to continue with the removal.

10. Select Done in the “Remove Window” dialog box. 

11. At the end select File->Exit  in the main “SD Remove” window.
The script will automatically run /opt/OV/bin/ovstart  to start HP OpenView 
background processes.

12. Unmount the CD ROM by typing the commands

cd /

umount /cdrom

exit

13. Remove the Compact Disk from the CD drive.

14. Exit as super-user (type exit ).

15. To start HP Openview, type:

/opt/OV/bin/ovw &
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6.4 Installation in a Distributed Environment
The OpenView distributed operating environment uses three categories of workstati
Management Station, Collection Stations, and Management Consoles. No special se
required for Management Stations and Management Consoles. The following proced
are required for workstations that serve as Collection Stations.

Note: If additional information on distributed environment installations is desired, refer to th
following documents: 
HP OpenView: A Guide to Scalability and Distribution for Network Node Manager
GDC TEAM Core Release Notes

1. Become a superuser by typing su  and supplying the superuser password.

2. Set up environment variables by typing the following commands:

/usr/bin/sh

. /opt/OV/bin/ov.envvars.sh

3. Insert the TEAM 6000 CD into the CDROM drive. If not already present, create 
/cdrom  directory now.

4. Type the following command:

mount /dev/dsk/ct0t2d0 /cdrom

5. Register GDC Trap format by typing the following:

$OV_BIN/xnmevents -merge 
/cdrom/HPUX/”SHELF6000TRAPD.CONF;”/

6. Start the Event system configurator GUI by typing:

$OV_BIN/xnmtrap

7. Set up Event Forwarding to the management station, using the GDC and HPOV
reference documents in Table 1 to forward the events listed in the table below.

Enterprise Name (ID) Event Name (Identifier)

gdc_6001(.1.3.6.1.4.1.498.15.2) mp6001Diversity(.1.3.6.1.4.1.498.15.2.0.2)

gdc_6001(.1.3.6.1.4.1.498.15.2) mp6001ColdStart(.1.3.6.1.6.3.1.1.5.1)

gdc_6001(.1.3.6.1.4.1.498.15.2) mp6001WarmStart(.1.3.6.1.6.3.1.1.5.2)

gdc_6001(.1.3.6.1.4.1.498.15.2) mp6001LinkDown(.1.3.6.1.6.3.1.1.5.3)

gdc_6001(.1.3.6.1.4.1.498.15.2) mp6001LinkUp(.1.3.6.1.6.3.1.1.5.4)

gdc_6001(.1.3.6.1.4.1.498.15.2) mp6001Authentication(.1.3.6.1.6.3.1.1.5.5)
e Notes for GDC Part No. 058U638-C01A and 058U738-C01A Page 21



Publication No. 086R902-V300 TEAM 6000 Version 3.0.0
Issue 3 - March 2001

Page 2

ed 

ge-

rding 

yping: 

iew 

 

elow. 

h), 

ging 
A. From the Enterprise Identification pane, select an Enterprise Name

for example: gdc_cmnAlarm

B. From the Event Identification pane, select an Event Name

for example: mp6000AlarmTrap

C. From the Event Configuration window menu bar, select Edit->Modify 
Event . The Event Configurator/Modify Event dialog box appears.

D. Click on the Forward Event check box to expand the dialog box. The Forward
Event Destinations pane displays.

E. Type the hostname or IP Address for destination. Destinations are the mana
ments stations to which events will be forwarded. 

F. Repeat steps 5A through 5E for each of the events listed in the Event Forwa
table above.

8. When all events are forwarded, click OK in the Event Configurator/Modify Event 
dialog box.

9. At the Event Configuration window, click File->Save  to save the changes.

10. To cause Openview processes to re-read the trapd.conf file, generate Event by t

$OV_BIN/xnmtrap -event

11. Unmount the CDROM by typing:

cd /

umount /cdrom

6.4.1 Updating Distributed Environments
Following the first time installation procedure, you will need to update each HP Open V
user’s environment by changing your environment scripts (with textedit or your favorite 
editor). The procedures vary depending on the type of window manager being used.

Use your favorite editor to change environment scripts described in the procedure b
After changes are made, you must logout and login for the changes to take effect.

Common Desktop Environments (DT desktop manager)

1. In order to use the CDE you need to make a change in the $HOME/.dtprofile  
file. First, open and read the $HOME/.dtprofile  document with your editor

Note: The lengthy dtprofile document provides information on using the C (csh), Bourne (s
and Korn (ksh) shells in the CDE. 
It also cautions against the use of certain terminal commands which can prevent log
in. Commands are generally present in .login  and .cshrc  files when using the csh 
shell, or in .login  and .profile files  when using the sh or ksh shells.

2. After reviewing the dtprofile comments, edit the $HOME/.dtprofile  file to 
remove the leading pound sign(s) in the line that contains:

### DTSOURCEPROFILE=true
2 Release Notes for GDC Part No. 058U638-C01A and 058U738-C01A
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3. If you are using C (csh) Shell you must add the following lines to $HOME/.cshrc

source /opt/OV/bin/ov.envvars.csh

set path=($path $OV_BIN)

xhost + HostName

4. If you are using Bourne(sh) shell or Korn(ksh) shell you must add the following li
to $HOME/.profile

. /opt/OV/bin/ov.envvars.sh

PATH=$PATH:$OV_BIN; export PATH

5. Log out and then log back in for these updates to take effect.

HP Visual User Environment (VUE)

1. In order to use the VUE you need to make a change in the $HOME/.dtprofile  
file. First, open and read the $HOME/.dtprofile  document with your editor.

Note: The lengthy dtprofile document provides information on using the C (csh), Bourne (s
Korn (ksh) shells in the VUE. 
It also cautions against the use of certain terminal commands which can prevent log
in. Commands are generally present in .login  and .cshrc  files when using the csh 
shell, or in .login  and .profile files  when using the sh shells.

2. After reviewing the dtprofile comments, edit the $HOME/.dtprofile  file to 
remove the leading pound sign(s) in the line that contains:

### VUESOURCEPROFILE=true

3. If you are using C (csh) Shell you must add the following lines to $HOME/.cshrc

source /opt/OV/bin/ov.envvars.csh

set path=($path $OV_BIN)

xhost + HostName

4. If you are using Bourne(sh) shell or Korn(ksh) shell you must add the following li
to $HOME/.profile

. /opt/OV/bin/ov.envvars.sh

PATH=$PATH:$OV_BIN; export PATH

5. Type the following commands and verifications:

A. Type vrdb -merge /opt/OV/bin/gdc_load_resources

B. Verify successful command execution by typing:

xrdb -query | grep “OI\*FontSet”

C. In response, the following line should display:

*OI*FontSet: -misc-fixed-medium-r-semicondensed--13-120-75-c-60-iso8859-1

6. Log out and then log back in for these updates to take effect.

Note: If, due to window resources changes, this X resource is lost at any time, repeat this 
procedure.
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6.4.2 Post-Installation Procedure For All HPUX Environments
Once the TEAM 6000 software has been installed in the desired environment, the follo
procedure must be performed to enable IP Discovery.

1. After completing installation and environment setup, open the root map.

2. At the Options menu, select Network Polling Configuration: IP .

3. At the Configuration Area, select IP Discovery . 

4. Enable the Discover New IP Nodes  option by selecting its checkbox.

5. Click OK. Discovery will begin at once and the Universe map will start to show th
discovered shelves.

6.4.3 De-Installation in a Distributed Environment
1. Become a superuser by typing su  and supplying the superuser password.

2. Setting up environment variables by typing the following commands:

/usr/bin/sh

. /opt/OV/bin/ov.envvars.sh

3. Start the Event system configurator GUI by typing:

$OV_BIN/xnmtrap

4. Undo Event Forwarding according to the list below. 

A. Use Edit->Delete->Event  to select each event and delete it.

B. Use Event->Delete->Enterprise Identifier  to delete the enterprise

C. At the Event Configuration window, save the changes by clicking File->Save.

7.0 Re-Installation
To re-install TEAM 6000 software, it is necessary to first perform all the steps in the 
installation procedure. This removes all TEAM 6000 packages. You can then repeat
steps of the Installation Procedure described earlier in this chapter.

Enterprise Name (ID) Event Name (Identifier)

gdc_6001(.1.3.6.1.4.1.498.15.2) mp6001Diversity(.1.3.6.1.4.1.498.15.2.0.1)

gdc_6001(.1.3.6.1.4.1.498.15.2) mp6001ColdStart(.1.3.6.1.6.3.1.1.5.1)

gdc_6001(.1.3.6.1.4.1.498.15.2) mp6001WarmStart(.1.3.6.1.6.3.1.1.5.2)

gdc_6001(.1.3.6.1.4.1.498.15.2) mp6001LinkDown(.1.3.6.1.6.3.1.1.5.3)

gdc_6001(.1.3.6.1.4.1.498.15.2) mp6001LinkUp(.1.3.6.1.6.3.1.1.5.4)

gdc_6001(.1.3.6.1.4.1.498.15.2) mp6001Authentication(.1.3.6.1.6.3.1.1.5.5)
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8.0 Known Issues
• A general SNMP error may occur if certain configuration changes are attempted w

a diagnostic test is in progress. For example, an attempted reconfiguration of a ch
card’s assigned timeslot is not allowed while the channel is in test, a general SN
error will result.

• An HP OpenView error can occur intermittently when a user double-clicks on the s
icon, displaying the following error message: 

Background graphic file “/usr/tmp/ShelfName.gif” cannot 
be loaded for submap ShelfName.

This causes a fully functional shelfmap to open, but without its background image
restore the image, close and then re-open the shelf submap. 

• An out of focus problem may exist on a Configuration application when editing th
System Name, System Location or System Contact fields. Usually, when change
entered in these fields, a File->Save selection will cause the new entry to turn wh
indicating a pending edit before a Save operation is initiated. If an out of focus ev
occurs on these fields, after a File-Save the field will not be marked for edit (white)
will not be sent to the unit as a change. Perform the Save operation to show the 
marked for edit (white) and then perform a second Save operation to commit the ch
to the unit.

• A Window Manager problem exists when the application screens create submenu
hide the main screen from view. The main screen cannot be brought forward wit
simple mouse-click in the title bar. You will need to drag the submenus out of the m
screen’s area of focus to view it. 

• The configuration application may erroneously allow the same time slot to be assi
to two channels. The following sequence allows this to occur:

A. Two channels are assigned the same time slot on different LIUs.

B. The LIU is changed on one of the channels, making it the same as the other 
nel.

C. Performing a Refresh may then indicate that one of the time slots is OFF.

• On the Metroplex 6001 Error Reports application, changing the interface type res
in the Totals screen, after resizing, to contain gray areas. To prevent extra gray ar
the screen, close the Totals screen before changing interface type.

• Some TEAM applications may display meaningless characters in the application
window headings. This is due to a font conflict which can be resolved by typing t
following on the command line before running ovw:

xrdb -merge /opt/OV/bin/gdc_load_resources

• In some TEAM application windows, slight text misalignments may appear. Thes
not affect the usability or operation of the application.

• On the Front Panel display, some LED labels may appear out of alignment over 
associated LEDs. This does not affect the operation of the application.

• In the Configuration application, in order to save changes made to any of the fou
Alarm masks, you must use the telnet or craft interface. Otherwise, changes will n
saved to the system. 
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9.0 Operating Guidelines
• Your HPUX workstation should contain the file: /etc/rc.config.d/ov500 with the 

following information:

SHLIB_PATH=/lib:/usr/lib:/opt/OV/lib/teamcore
export SHLIB_PATH

If this information is not present, the GDC background daemons will not start afte
reboot.

• Because the read-only maps are not automatically updated, use Map -> Refresh M
update the maps.

• Make sure that the HPUX system application font size is set to 10 pt. This is 
accomplished via the Font button in the Style Manager via the VUE workspace ar
the font is set larger that 10 pt, some TEAM application windows will not be able
display the entire textual information they contain.

• Due to the loading of shared libraries, TEAM applications may take up to one mi
to start up after an install of TEAM software or a reboot of the system. 

• For the TEAM 6000 software to function, you must set the values for Timeout an
Retries at the SNMP Configuration screen, as shown below:

Timeouts should be set to 20s (Default = 0.8s) 
Retries should be set to 3(Default = 3)  

• After an installation of TEAM software, the user must enable Discover New IP 
Nodes  from the root map Options menu in order for shelf discovery to occur. 

• On the Front Panel display for all applications, the Help link text is not visible. Th
Help link itself is operational and can be accessed by clicking the lower right corn
the Front Panel displays.

• During installation of the TEAM software, the following error pop-up may appear
The xterm environment has not been set.  This error will prevent any 
windows from launching. To correct this, add the following the following comman
should be added to the $HOME/.cshrc  file:

xhost + HostName
6 Release Notes for GDC Part No. 058U638-C01A and 058U738-C01A
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Section 3 - TEAM Applications and HP OpenView NNM
Scalable and Distributed Environments

1.0 Overview
This section briefly discusses the Scalability and Distribution features in NNM and ho
integrate/install TEAM applications in a Scalable and Distributed environment. Refer t
HP OpenView Manual, “A Guide to Scalability and Distribution for NNM” for more 
detailed understanding and concepts.

1.1 Features and Advantages
The Scalable and Distribution features of the HP OpenView NNM provide robust 
performance over a wide range of network sizes and degrees of complexity. 

The Scalable feature gives NNM the potential for handling networks of different size
both LAN and WAN environments. To make NNM scalable, the network manageme
work load must be distributed to multiple systems. Then, the Distribution feature impr
performance of NNM in large networks by reducing the amount of management traffic
network resources.

Some of the advantages of these NNM features are:

• The Scalable feature of NNM makes it easier to adapt network management for 
handling new networking landscapes.

• The Distribution feature minimizes the amount of network management traffic. 
Without this capability, it would be impractical to monitor thousands of nodes from
single workstation.

• Faster response times and better performance as work load is distributed to mul
workstations.

• Shared responsibilities reduces the risk of losing network management data in the
of an unexpected shutdown of the management station.

• One Common network management database (in most cases) for all users, so th
modifications of managed nodes would be reflected across the board.

Some drawbacks/trade-offs are:

• Distribution of tasks requires an increased number of computing resources.

• Scalable and distributed environment requires added complexity in setup.
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1.2 Theory of Operation
In a Stand-alone environment, all network management tasks are done on a single 
workstation. In a Distributed environment tasks are handled by multiple workstations
Collection Station (CS), Management Station (MS), Management Console (MC). 
Depending on network size, structure, geography and trends, one of four deploymen
models should be chosen: Fully centralized, Centralized hierarchical, Hierarchical, o
operative independent.

• Figure 1 demonstrates a Centralized hierarchical model. Refer to the HP OpenV
manual for examples of other models and for choosing the model for your needs

• Figure 2 demonstrates the HP OpenView and TEAM processes and applications
run on the collection station, the management station, and the management con

1.2.1 The Collection Station
A collection station discovers nodes and forwards this information to the manageme
station. The collection station also monitors (the netmon process) the nodes in its do
and forwards any traps it receives from the managed node (IP device) to the manag
station. Depending on the number of managed nodes and network structure, there co
more than one collection station. The collection and management stations periodica
synchronize node and topology information. Figure 1 shows two collection stations fee
node and topology information to the management station. 

1.2.2 The Management Station
The management station processes the node and topology information it receives fro
collection stations and stores the information (via ovwdb) in a database. The manag
station also receives from collection stations the trap information for various manage
nodes (ovtrapd process) and stores it. There should only be one management statio
distributed setup so that the node information can be shared by all the users on vari
management consoles. 

1.2.3 The Management Console
The management console is where all the user processes are executed. User interfa
(application) processes like ovw, xnmevents, xnmsnmpconf are executed here in ord
manage the nodes in the management station’s database. The Management Console
be connected to the Management Station using an Ethernet LAN or a high speed ne
matching the speeds of LAN. Management Station and the Management Consoles w
share the same database by mounting the database over the Network Filing System 

1.2.4 Permissions
The first network operator to run ovw and launch OpenView screens will have read/w
permissions to the database. The rest of the operators will get read-only permissions
that read-only screens do not synchronize automatically with changes in network top
or with the addition or deletion of devices to the database. To resynchronize the enti
network map, network operators on the management console must manually perform 
Map -> Refresh Map  command. All network operators will be able to perform oth
TEAM Network Management operations, such as Configuration, Provisioning, 
Diagnostics. Operators must manage a unit in the shelf from only one workstation at a
8 Release Notes for GDC Part No. 058U704-C01A
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Figure 1: Example of the Centralized Hierarchical Model
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1.3 The Distribution of Processes and Applications
The sequence of events that occur end-to-end from the IP node to the management c
(Figures 1 and 2) is as follows:

Collection Station(s)

1. netmon  process begins IP discovery, and populates the local topology 
database(ovtopmdb ) with the help of ovtopmd  process.

2. After the completion of discovery, the topology information is accessible by the 
management station.

Management Station

3. The management station requests the collection station(s) for topology informatio
ovrepld  process.

4. Upon obtaining the topology information (from all collection stations), the 
management station merges the data into its topology database. 

5. Using the data in the topology database, the processes in the management sta
communicate with each node to update other information necessary to manage
node.

6. Periodically, the ovrepld processes on the collection station(s) and managemen
station synchronize the topology data. Once synchronization is complete, only 
changes in status and topology get sent to the management station.

Management Console and Management Console X Term Server

7. After the management station is ready with node information, the ovw process c
run.

8. Once ovw is up and running, network management on various nodes can be do

Note: When one of the management consoles is also designated as a X-Term Server, 
X-Terminals (such as Tektronics Graphics terminal) could be setup to display ovw 
sessions on these terminals. The ovw sessions are actually executed on the manag
console but displayed on the X-Terminals.
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Figure 2: HP OpenView and Team Processes and Applications
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Collection Station
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ovtopmd

netmon*

snmpcollect
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pmd

ovwdb

ovwdbovtrapd

ovw

xnmevents

xnmsnmpconf

ipmap

etc...

ovspmd

ovtrapd

OVLicenseMgr

ovtopmd

netmon

ovrepld
pmd

Line Statistics Collector
Shelf Download
SCM Apps(Config, Front Panel, etc.)

SC 521 Apps (Config, Diag, etc.)
SC 553 Apps (Config, Diag, etc.)

Shelf Discovery

Event Configuration for TEAM events

Shelf Map

Management Station

GDC TEAM Processes

ovtopmdb

ovtopmdb

* Note:
netmon is optional. It should be
started only if local nodes need
to be discovered.
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2.0 Integrating the TEAM Application in a Distributed Environment
Due to distribution of tasks in a distributed environment, TEAM software products mus
installed on the collection station, the management station and the management con
the precise order as described in Sections 2 and 3 of the TEAM Core Release Notes
following sections describe the dependency tree, discovery, and event handling of G
devices for TEAM software products.

2.1 TEAM Software Product Dependency
To manage any GDC product using TEAM software, multiple software products are 
required. Figure 3 shows the dependencies among various products. In the example
SC521 and SC553 cards along with their associated packages are being managed b
TEAM521 and TEAM553. Both TEAM products are dependent upon TEAM Core. 
Because of this product dependency, TEAM Core must be installed on the workstati
before installing TEAMSC521, etc. 

. 

Figure 3: TEAM Software Product Dependencies

TEAMCORE

GDCSC553

TEAM553 TEAM521

GDCSC521
GDCNMS520
GDCNMS510

GDCTeam
GDCShelf5
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2.2 Discovery in an HP OpenView Distributed Environment
Once TEAM software is installed and configured in an HP OpenView NNM distribute
environment, the system is ready for network management of GDC devices. This be
with the discovery of a GDC device on the management console where it is managed.
of the typical applications that are executed on the management console are shown
Figure 2. The sequence of events that occur end-to-end is as follows:

1. A GDC device is discovered by a collection station and gets stored in its topolog
database. 

2. This discovery information is requested by the management station in a 
synchronization cycle of ovrepld  process.

3. The management station adds the device into its database as a new node.

4. Once a new node gets added on the management station, the shelf_discovery  
gets notified of the change. 

5. The Shelf_discovery  process communicates with the SCM to get the shelf 
contents and other relevant information and stores the information.

6. After a GDC shelf is discovered, a new shelf gets added to the TEAM universe 
submap.

7. From this submap various GDC devices can be managed.

2.3 Event Handling
A trap generated from a GDC device arrives at the management console where it is up
The sequence of events that occur end-to-end is as follows:

A. When SCM is set up to do so, a GDC device sends a trap to the collection sta

B. The collection station then forwards the trap to the management station, whe
gets processed by shelf_discovery  process and notifies the shelfmap pro-
cess on the management console.

C. The shelfmap process updates the status of the device associated with the e
Note that one process runs for every ovw session.
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