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Section 1 - HP Open View on HPUX 11.0

1.0 Overview 
These installation and release notes provide new information relevant to the T1/E1 
(TEAM) V1.2.0 software product. This updates the information supplied by the T1/E1 
Operating and Installation Manual. If you require additional details please refer to tha
manual.

TEAM V1.2.0 is now supported on HPUX 11.0 with HPOV 6.1. For the latest produc
information, check the GDC website at http://www.gdc.com  or contact your GDC 
field representative.

2.0 Software Reference
Throughout this manual, short forms of the software product names will be used. Th
following table provides reference information for all software modules relevant to TE
V1.2.0 for HPUX installation. 

Table 1:  Software Reference for HPUX

Item Part Number Version / Release

T1/E1 (TEAM) Software Product 058U707-C01A Ver 1.2.0

T1/E1 Operation/Installation 
Manual

058R693-V111 Latest Issue

HPOV NNM Software Product Release 6.1

HPUX Operating System Ref: HP website Ver 11.0 /November 1999

HPUX and HPOV Patches Ref: HP website

HPOV Network Node Manager 
Performance and Configuration 
Guide

HP J1170-99002 Latest Release
e Notes for GDC Part No. 058U707-C01A Page 5
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3.0 Improvements Since Last Release
This is the initial release of TEAM V1.2.0 software. This software has been tested to
Year 2000 compliant in accordance to GDC ENG-STD-003. Check GDC's web site a
http://www.gdc.com for the latest Year 2000 information. Note the following new 
information concerning this software:

• The application is approved for operation on HP OpenView 6.1 and HPUX 11.0 
upgrades. 

TEAM V1.1.1-PATCH

• The TEAM map application now checks to see if the TEAM alarm generator 
application is running. A pop-up is displayed if the TEAM alarm generator is not 
running.

TEAM V1.2.0 RELEASE

• In TEAM Functions->Configure Network, Configure Network now supports up to 
nodes.

Note: Firmware revision “F” or greater must be installed in the DMA-200 if you require mor
than 20 nodes.

• In TEAM Functions->Configure Network, some window field labels have been 
changed as follows:

• In TEAM Functions->Network Access, the Status Bar displays proper Terminal 
Synchronization (TSY) status. When synchronized, the status LED is dark green

4.0 HP OpenView for HPUX
The following sections describe the current requirements and procedures concernin
HP OpenView for HPUX version of TEAM V1.2.0 software.

4.1 Hardware Requirements
The current hardware requirements for TEAM V1.2.0 software is as follows:

• HP 9000 series model 700 or 800

• Minimum requirements of 96 megabytes of RAM, 2 gigabytes of hard disk space,
megabytes of free space and 500 megabytes of swap space.

• The graphics card should support a resolution of 1152x900

• CD ROM Drive

OLD LABEL NEW LABEL

Node Ckt/Node

Telephone Number Identifier/Phone
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Note: For information on hardware requirements for HP OpenView Network Node Manage
products, refer to the HP OpenView Network Node Manager Products Installation G

4.2 Software Requirements
Before installing this version of TEAM V1.2.0, the following software must be installe
Refer to Table 1, Software Reference for HPUX, for detailed identification of all softw
products discussed below.

System Software Requirements

• HP OpenView NNM 

• HPUX

• The most recent HPUX and HP OpenView patches for these versions

• TEAM V1.2.0 Software Package

Note: IMPORTANT - It is highly recommended that the customer download and install the
latest HP OPENVIEW CONSOLIDATED PATCH CLUSTER from the following HP w
site: http://ovweb.external.hp.com/cpe/patches. This will ensure that you have update
OpenView along with any current fixes to reported problems. 
Refer to the HPUX web site for updates to the HPUX 11.0 Operating System.

Note: It is the customer’s responsibility to install the listed HP software and patches, and to
ensure they are fully operational before loading the General DataComm TEAM 
applications.
e Notes for GDC Part No. 058U707-C01A Page 7
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5.0 Installation
1. Close all HP OpenView and TEAM application windows (if applicable). 

2. Make sure that all users exit HP OpenView.

3. Insert the TEAM V1.2.0 Compact Disk into the CD ROM drive.

4. At a shell prompt become super-user by entering the following command:

su

5. Verify that there is a /cdrom  directory already present. If not, create it. 

6. Enter the following commands: 

csh

mount /dev/dsk/c0t2d0 /cdrom

cd /cdrom

./INSTALL*

7. The install script will automatically stop HP OpenView background processes by
running /opt/OV/bin/ovstop.  Files will then be extracted from CD to hard 
disk, an operation that will take a few minutes.

8. The script then automatically runs swremove, which displays a graphical user 
interface that you use to remove existing TEAM software. The window title bar w
display SD Remove - Software Selection  in its title bar. If this is a first 
time installation of TEAM, select File->Exit  to dismiss the GUI. If there is 
existing TEAM software to remove, use the following procedure:

A. Select TEAM from the window scroll-down list box.

B. Select Actions->Mark  for Remove.

C. Select Actions -> Remove (analysis) .

D. Select OK in the Remove Analysis dialog box to proceed.

E. Select Yes in the Confirmation popup to continue with the removal.

9. The script now automatically runs swinstall , which displays a graphical user 
interface for installing the TEAM V1.2.0 software. The window will display SD 
Install - Software Selection  in its title bar. 

10. Select TEAM from the window’s scroll-down list and double click on it. 

11. Select Actions->Mark for Install .

12. Select Actions ->Install (analysis) .

13. Select OK in the “Install Analysis” dialog box to proceed.

14. Select Yes in the “Confirmation” popup to continue with the installation.
Release Notes for GDC Part No. 058U707-C01A
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Note: If the installation stops, displaying an error message, it may be that a GDCTeam util
application package has been detected on the host that is more recent than the one
installed. To resolve the conflict, consult the first entry in the Log File (as prompted in
error message), then click the Cancel button in the Install Analysis window. From the
Install window menu bar, select Options ->Change Options. When the Options wind
appears, scroll to “Enforce dependency analysis errors in agent” and click the select
box (deselects the option). Then, click OK. You can now install software packages 
selectively. Resume the installation from Step 9 - this time, not selecting GDCTeam. 
a Dependency Message Dialog window appears, click OK.

15. When the installation is complete, the Done button in the Install window is no longer
grayed out. Select Done now.

16. At the end, select File->Exit  in the main “SD Install” window.

The script will automatically run /opt/OV/bin/ovstart  to start HP OpenView 
background processes.

17. Unmount the CD ROM by typing:

cd /

umount /cdrom

exit

18. Remove the CD from the drive, then confirm HP Openview and TEAM processe
running by typing:

/opt/OV/bin/ovstatus

19. If all processes are running, exit super-user (type exit ).

20. Edit the $HOME/.dtprofile  file to remove the leading pound signs(s) in the lin
that contains

###DTSOURCEPROFILE=true

21. Update each HP Open View user’s environment by changing your environment 
scripts (with textedit or your favorite editor) as follows:

C (csh) Shell users - add the following lines to #HOME/.cshrc:

source /opt/OV/bin/ov.envvars.csh

set path=($path $OV_BIN)

source $OV_CONF/cshrc.TEAM
xhost + HostName

22. Create a symbolic link to /opt/OV/lib/team/libOI.sl  by typing the 
following command: 

ln -s /opt/OV/lib/team/libOI.sl /opt/OV/lib/libOI.sl
e Notes for GDC Part No. 058U707-C01A Page 9
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23. Bourne (sh) and Korn (ksh) Shell users - add the following lines to #HOME/.pro

. /opt/OV/bin/ov.envvars.sh

PATH=$PATH:$OV_BIN;export PATH)

. $OV_CONF/profile.TEAM
SHLIB_PATH=/lib:/usr/lib:/opt/OV/lib/team

export SHLIB_PATH

These updates do not take effect until you log out and log back in (below).

24. Start HP Openview by typing:

/opt/OV/bin/ovw &

5.1 Symbolic Links for Dynamic Libraries
The TEAM application requires the HPUX dynamic libraries listed in the table below
Perform the following procedures to ensure the integrity of the symbolic links to thes
libraries.

1. Create the following directory:

/HP-PA/ParcPlace/lib/

2. Copy the file libOI.sl  

from /opt/OV/lib/team

directory to /HP-PA/ParcPlace/lib

.

3. Although the TEAM Application script creates a symbolic link of libOI.sl  if 
needed, the user must create symbolic links to reference any other dynamic libr
which are not already present on your system. 

If libOI.sl  is not already present, type the following:

ln -s /opt/OV/lib/team/libOI.sl /opt/OV/lib/libOI.sl 

Table 2: Dynamic Libraries

Library Directory TEAM Library

libc.sl /lib /opt/OV/lib/team/libc.sl

libcl.sl /usr/lib /opt/OV/lib/team/libcl.sl

libndbm.sl /usr/lib /opt/OV/lib/team/libdbm.sl

libX11.sl /usr/lib/X11R5 /opt/OV/lib/team/libX11.sl

libC.sl /usr/lib /opt/OV/lib/team/libC.sl

libOI.sl /usr/lib /opt/OV/lib/team/libOI.sl
0 Release Notes for GDC Part No. 058U707-C01A
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5.2 File Permissions
Be sure to use an umask setting of 022 when editing TEAM V1.2.0 for HPUX11.0/HPOV
6.1 application configuration files. This will allow normal users to read application lice
files, configuration files, etc., while using TEAM.

5.3 Licensing TEAM 
1. Before using the TEAM V1.2.0 you must obtain a software license key from Gen

DataComm. The following information must be provided to obtain a license key:

Host ID: an 8-character hexadecimal value
Product: TEAM 
Version: 1
Release: 2
Revision: 0
Expiration: none

2. You will need to supply a host identifier (Host ID) to obtain a license key. At the s
prompt, type the following command to display the workstation Host ID:

/opt/OV/bin/GDC_hostid

3. Once you have obtained the software license key, you must install the key. Beco
super-user, then type the following commands at a shell prompt to install the ke

/opt/OV/bin/GDC_setkey -s <HostID> TEAM 1 2 0 <Expiration> <License Key>

Examples:

/opt/OV/bin/GDC_setkey -s 02bb3fa8 TEAM 1 2 0 none ZFAUVQML

5.4 Installing in an HPUX Distributed Environment
A distributed environment consists of three types of workstations. Not all workstation
require installation of all software, but the workstations must be set up in the followin
order: 

A. Collection Station (N/A for TEAM V.1.2.0 product)

B. Management Station

C. Management Console

The procedures for TEAM V1.2.0 vary depending on the type of workstation. Perform
installation and set up procedures for each workstation in your distributed environme

5.4.1 Installing TEAM Applications on the Management Station
To install TEAM V1.2.0 on the Management Station, perform the following steps:

1. Make sure all users exit HP OpenView for HPUX.

2. Close all HP OpenView and TEAM application windows (if applicable). 

3. Insert the TEAM V1.2.0 CD into the CD ROM drive.

4. At a shell prompt become super user by entering the following command:

su

5. Check /  to make sure there is a /cdrom  directory already present. If not, create it.
e Notes for GDC Part No. 058U707-C01A Page 11
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6. Start the installation process by entering the following commands:

csh

mount /dev/dsk/c0t2d0 /cdrom

cd /cdrom

./INSTALL*

7. The install script will automatically stop HP OpenView background processes b
running /opt/OV/bin/ovstop.  Files will then be extracted from CD to hard 
disk, an operation that will take a few minutes.

8. The script then automatically runs swremove, which displays a graphical user 
interface that you use to remove existing TEAM software. The window title bar w
display SD Remove - Software Selection  in its title bar. If this is a first time 
installation of TEAM, select File->Exit  to dismiss the GUI. If there is existing 
TEAM software to remove, use the following procedure:

A. Select TEAM from the window scroll-down list box.

B. Select Actions->Mark  for Remove.

C. Select Actions -> Remove (analysis) .

D. Select OK in the Remove Analysis dialog box to proceed.

E. Select Yes in the Confirmation popup to continue with the removal.

9. The script now automatically runs swinstall , which displays a graphical user 
interface for installing the TEAM V1.2.0 software. The window will display SD 
Install - Software Selection  in its title bar. 

10. Highlight the TEAM package to be installed: 

TEAM

11. Select Actions ->Mark for Install .

12. Select Actions ->Install (analysis) .

13. In the Install Analysis dialog box, click OK to proceed.

14. In the Confirmation window, click Yes to continue with the installation.

15. Click OK. TEAM V1.2.0 software installation will now begin. 

16. When the process is complete, the Done button in the Install Window dialog box 
becomes “un-grayed”. Click Done. 

17. From the main SD Install window, select File->Exit  .

18. The install script then starts HP OpenView background processes by running 
/opt/OV/bin/ovstart  .

19. Confirm that the correct versions of software have been installed by typing:

/usr/sbin/swlist

20. All GDC software packages installed on the workstation will be displayed along 
their version numbers. 

21. Unmount the CD ROM by typing:

cd /

umount /cdrom
2 Release Notes for GDC Part No. 058U707-C01A
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exit

22. Remove the CD from the CD ROM drive.

23. Confirm HP OpenView and TEAM V1.2.0 processes are running by typing:

/opt/OV/bin/ovstatus

5.4.2 Setting Up the Management Station
1. At the shell prompt, become a super user by typing:

su

2. Type the following commands:

/opt/OV/bin/ovstop

/sbin/init.d/nfs.client stop

/sbin/init.d/nfs.server start

3. To ensure the NFS server daemon process nfsd  is running, type the following 
command and verify the results:

ps -ef | grep nfsd

Note: If the nsf is not running, edit the etc/rc.config.d/nfsconf file and change 
NFS_SERVER=0 to NFS_SERVER=1. Save the file, then repeat steps 1 through 3.

4. To add all Management Consoles to the Management Station, edit the /etc/hosts 
file by typing each Console’s specific IP address and Hostname on a separate li
shown in the example:

###.###.###.### Console_Hostname

###.###.###.### Console_Hostname
5. Save and close the /etc/hosts file . 

Note: If using vi editor, use wq!  to save and close the file.

6. To allow a single Management Console to share the Management Station direc
over NFS, edit the /etc/exports file as follows:

/etc/opt/OV/share -root= Console_Hostname 

/var/opt/OV/share -root= Console_Hostname 

/usr/tmp -root= Console_Hostname 

Note: If the exports file does not exist, create one.

7. Save and close the /etc/exports  file.

8. To share the Management Station directories with the Consoles over NFS, type

usr/sbin/exportfs -au 

usr/sbin/exportfs -av
e Notes for GDC Part No. 058U707-C01A Page 13
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9. Edit the file /etc/opt/OV/share/conf/ovwdb.auth file as shown below to 
add an entry for the Console, as shown in the example: 

Console_Hostname +

10. Edit the file /etc/opt/OV/share/conf/ovw.auth file as shown below to 
add an entry for the Console, as shown in the example: 

Console_Hostname +

11. Type the following commands to restart nfs server:

/etc/init.d/nfs.server stop

/etc/init.d/nfs/server start

12. To start HP Openview processes, type:

/opt/OV/bin/ovstart

13. Exit super user by typing exit .

14. Complete the setup by typing:

/opt/OV/bin/ovw &

5.4.3 Installing TEAM Applications on the Management Console

Note: If the HPUX distributed environment has been set up, it must be disabled temporaril
before loading any TEAM software to avoid sharing conflicts with the server. Additio
steps for this are provided below.

1. Make sure all users exit HP OpenView for HPUX.

2. Close all HP OpenView and TEAM application windows (if applicable). 

3. On the Management Console, become super user by typing:

su

If the HPUX distributed environment has been set up, perform steps 4 - 9. 
Otherwise, skip to step 10.

4. Disconnect as a HP OpenView client by typing:

/opt/OV/bin/ovwsetupclient -u

5. Open the file /etc/fstab and type a # in the beginning of each line to commen
out each line with a Console hostname. 

6. Save and close the file.

7. On the Management Station, become a super user and open the file /etc/exports . 
Comment out each line with a Console hostname by typing a # in the beginning of 
each line. 

8. Save and close the file.

9. On the Management Console, become a super user and enter the following com

/etc/umount Station_Hostname:/etc/opt/OV/share

/etc/umount Station_Hostname:/var/opt/OV/share

/etc/umount Station_Hostname:/usr/tmp
4 Release Notes for GDC Part No. 058U707-C01A
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10. Insert the TEAM V1.2.0 into the CD ROM drive.

11. At a shell prompt become super user by entering the following command:

su

12. Check /  to make sure there is a /cdrom  directory already present. If not, create it.

13. Start the installation process by entering the following commands:

csh

mount /dev/dsk/c0t2d0 /cdrom

cd /cdrom

./INSTALL*

14. The install script will automatically stop HP OpenView background processes b
running /opt/OV/bin/ovstop.  Files will then be extracted from CD to hard 
disk, an operation that will take a few minutes.

15. The script then automatically runs swremove, which displays a graphical user 
interface that you use to remove existing TEAM software. The window title bar w
display SD Remove - Software Selection  in its title bar. If this is a first time 
installation of TEAM, select File->Exit  to dismiss the GUI. If there is existing 
TEAM software to remove, use the following procedure:

A. Select TEAM from the window scroll-down list box.

B. Select Actions->Mark  for Remove.

C. Select Actions -> Remove (analysis) .

D. Select OK in the Remove Analysis dialog box to proceed.

E. Select Yes in the Confirmation popup to continue with the removal.

16. The script now automatically runs swinstall , which displays a graphical user 
interface for installing the TEAM V1.2.0 software. The window will display SD 
Install - Software Selection  in its title bar. 

17. Highlight TEAM package to be installed: 

TEAM

18. Select Actions ->Mark for Install .

19. Select Actions ->Install (analysis) .

20. In the Install Analysis dialog box, click OK to proceed.

21. In the Confirmation window, click Yes to continue with the installation.

22. Click OK. TEAM V1.2.0 software installation will now begin. 

23. When the process is complete, the Done button in the Install Window dialog box 
becomes “un-grayed”. Click Done. 

24. From the main SD Install window, select File->Exit  .

25. The install script then starts HP OpenView background processes by running 
/opt/OV/bin/ovstart  .

26. Confirm that the correct versions of software have been installed by typing:

/usr/sbin/swlist 
e Notes for GDC Part No. 058U707-C01A Page 15
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27. All GDC software packages installed on the workstation will be displayed along 
their version numbers. 

28. Unmount the CD ROM by typing:

cd /

umount /cdrom

exit

29. Remove the CD from the CD ROM drive.

30. Confirm that HP OpenView and TEAM V1.2.0 processes are running by typing:

/opt/OV/bin/ovstatus

Perform steps 31 - 38 only if the HPUX distributed environment has been set 
Otherwise, skip to step 39.

31. On the Management Station, become a super user by typing:

su

32. Open the file /etc/exports . Restore the Console hostnames by removing the# 
from the beginning of each line containing the Console hostname. 

33. Save and close the file /etc/exports . 

34. Type the following commands:

/usr/sbin/exportfs -au

/usr/sbin/exportfs -av

35. On the Management Console, become a super user by typing:

su

36. Open the file /etc/fstab and restore each line by deleting the # in the beginning 
of each line. 

37. Save and close the file.

38. Type the following commands: 

/etc/mount Station_Hostname:/etc/opt/OV/share

/etc/mount Station_Hostname:/var/opt/OV/share

/etc/mount Station_Hostname:/usr/tmp

/opt/OV/bin/ovwsetupclient /opt/OV/nfs/ Station_Hostname

Note: The path many be different if automounter was used.

39. Exit super user and become a normal user. On the Management Console, bring
OpenView windows using the server database by typing:

/opt/OV/bin/ovw &

5.4.4 Setting Up the Management Console
1. At the shell prompt, become a super user by typing:

su
6 Release Notes for GDC Part No. 058U707-C01A
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2. Type the following commands:

/opt/OV/bin/ovstop

/sbin/init.d/nfs.server stop

/sbin/init.d/nfs.client start

3. To ensure the NFS client daemon process biod is running, type the following 
command and verify the results:

ps -ef | grep biod

Note: If the biod is not running, edit the /etc/rc.config.d/nfsconf file and change 
NFS_CLIENT=0 to NFS_CLIENT=1. Save the file, then repeat steps 2 and 3.

4. To add the Management Station to the Management Console, edit the /etc/hosts 
file by typing the specific Management Station IP address and Hostname, as sho
the example:

###.###.###.### Station_Hostname

###.###.###.### Station_Hostname
5. Save and close the /etc/hosts file. 

Note: If using vi editor, use wq!  to save and close the file.

6. Type the following commands:

mkdir -p /opt/OV/nfs/ Station_Hostname/etc/opt/OV/share

mkdir -p /opt/OV/nfs/ Station_Hostname/var/opt/OV/share

rmdir /usr/tmp

mkdir -p /usr/tmp

chmod 777 /usr/tmp

7. To mount the Management Station directories on this Console over NFS, edit th 
/etc/fstab file as shown in the example:

Station_Hostname:/etc/opt/OV/share /opt/OV/nfs/ Station_Hostname/etc/opt/OV/share nfs rw 0 0
Station_Hostname:/var/opt/OV/share /opt/OV/nfs/ Station_Hostname/var/opt/OV/share nfs rw 0 0
Station_Hostname:/usr/tmp /usr/tmp nfs rw 0 0

8. Save and close the /etc/fstab file.

Note: If using vi editor, use wq!  to save and close the file.

9. To mount the Management Station directories on this Console over NFS, type t
following commands:

/etc/mount Station_Hostname:/etc/opt/OV/share

/etc/mount Station_Hostname:/var/opt/OV/share

/etc/mount Station_Hostname:/usr/tmp
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10. Type the following commands to restart nfs client:

/etc/init.d/nfs.client stop

/etc/init.d/nfs.client start

11. Set up the Management Console by typing:

/opt/OV/bin/ovwsetupclient /opt/OV/nfs/ Station_Hostname
12. Exit Super User by typing exit .

13. Complete the setup by typing:

/opt/OV/bin/ovw &

Note: It is not necessary to start HP OpenView daemons using /opt/OV/bin/ovstart on the 
Management Console because the Console shares the same HP OpenView databa
present on the Management Station over NFS.

Note: If the Console OpenView windows does not start up properly, reboot the Manageme
Station and wait until it is UP completely. Then, reboot the Console.

5.4.5 Adding/Updating User Accounts in Distributed Environments
1. Type sam

2. Select Users and Groups .

3. Select Users .

4. Under the Actions menu, select Add. 

5. Enter Login name and select the shell you desire (prefer cshell)

6. Enter Password if desired

7. Exit sam

8. Log off and log back in under a user account. 

5.5 De-installation
1. Make sure that all users exit HP OpenView.

2. Insert the TEAM V1.2.0 Compact Disk into the CD ROM drive.

3. At a shell prompt, become super-user by typing 

su

4. Start the removal process by entering the following commands:

csh

mount /dev/dsk/c0t2d0  /cdrom

cd /cdrom

./REMOVE*
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The remove script will automatically stop HP OpenView background processes 
running /opt/OV/bin/ovstop . The script then automatically runs swremove , 
which opens a window “SD Remove - Software Selection” for removing existing
TEAM V1.2.0 software. 

5. Select TEAMV1.2.0  from the window’s scroll-down list and double click on it.

6. Select Actions->Mark for Remove .

7. Select Actions ->Remove (analysis) .

8. Select OK in the “Remove Analysis” dialog box to proceed.

9. Select Yes in the “Confirmation” popup to continue with the removal.

10. Select Done in the “Remove Window” dialog box. 

11. At the end select File->Exit  in the main “SD Remove” window.
The script will automatically run /opt/OV/bin/ovstart  to start HP OpenView 
background processes.

12. Unmount the CD ROM by typing the commands

cd /

umount /cdrom

exit

13. Remove the Compact Disk from the CD drive.

14. Exit as super-user (type exit ).

15. To start HP Openview, type:

/opt/OV/bin/ovw &

5.6 Distributed Environment De-Installation
De-installation of TEAM software in a distributed HPUX environment should be 
performed in the following order: 

A. Collection Station (N/A)

B. Management Station

C. Management Console

Procedures vary, depending on the type of environment. Refer to the appropriate 
procedures below. Additional information about distributed environments is provided
Section 2.

5.6.1 De-Installing TEAM Applications from the Management Station
1. In the OpenView Root map, click on the Standalone universe icon.

2. From the Edit menu of the Root map menu bar, select Delete , then select From 
All Submaps  to remove the Standalone icon from the Root map. 

3. Make sure that all users exit HP OpenView for HPUX.

4. Insert the TEAM V1.2.0 CD into the CD ROM drive.
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5. At the shell prompt, become super user by typing:

su

6. Start the removal process by entering the following commands:

csh

mount /dev/dsk/c0t2d0 /cdrom

cd /cdrom/HPUX

./REMOVE*

7. The remove script will first run /opt/OV/bin/ovstop  to stop HP OpenView 
background processes. Then, the SD Remove - Software Selection window app
indicating swremove  has begun.

8. Highlight TEAM package to be removed: 

TEAM

9. Select Actions->Mark for Remove .

10. Select Actions ->Remove (analysis) .

11. In the Remove Analysis dialog box, click OK to proceed.

12. Click OK. TEAM V1.2.0 software removal will now begin. 

13. When the process is complete, the Done button in the Remove Window dialog box 
becomes “un-grayed”. Click Done. 

14. From the main SD Remove window, select File->Exit .

15. The remove script then starts HP OpenView background processes by typing

/opt/OV/bin/ovstart 

16. Unmount the CD ROM by typing:

cd /

umount /cdrom

exit

17. Remove the CD from the CD ROM drive.

18. Confirm HP OpenView processes are running by typing the command:

/opt/OV/bin/ovstatus

5.6.2 De-Installing TEAM V1.2.0 from the Management Consoles

Note: If the HPUX distributed environment has been set up, it must be disabled temporaril
avoid sharing conflicts with the server. Additional steps for this are provided below.

1. Make sure all users exit HP OpenView for HPUX.

2. Close all HP OpenView and TEAM application windows (if applicable). 

3. On the Management Console, become super user by entering:

su
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If the HPUX distributed environment has been set up, perform steps 4 - 8. 
Otherwise, skip to step 9.

4. Disconnect as a HP OpenView client by running:

/opt/OV/bin/ovwsetupclient -u

5. Open the /etc/fstab file and type a # in the beginning of each line which contain
the Console hostname. Save and close the /etc/fstab file.

6. On the Management Station, become a super user and open the file /etc/exports . 
Type a # in the beginning of each line which contains this Console hostname.

7. Save and close the /etc/exports file.

8. On the Management Console, become a super user and type the following comm

/etc/umount Station_Hostname:/etc/opt/OV/share

/etc/umount Station_Hostname:/var/opt/OV/share

/etc/umount Station_Hostname:/usr/tmp

9. Insert the TEAM V1.2.0 CD into the CD ROM drive.

10. Start the removal process by entering the following commands:

csh

mount /dev/dsk/c0t2d0 /cdrom

cd /cdrom

./REMOVE*

11. The remove script will first run /opt/OV/bin/ovstop  to stop HP OpenView 
background processes. Then, the SD Remove - Software Selection window app
indicating swremove  has begun.

12. Highlight TEAM package to be removed: 

TEAM

13. Select Actions ->Mark for Remove .

14. Select Actions ->Remove (analysis) .

15. In the Remove Analysis dialog box, click OK to proceed.

16. In the Confirmation window, click Yes to continue with the removal.

17. Click OK. TEAM V1.2.0 software removal will now begin. 

18. When the process is complete, the Done button in the Remove Window dialog box 
becomes “un-grayed”. Click Done. 

19. From the main SD Remove window, select File->Exit  .

20. The remove script then starts HP OpenView background processes by running

/opt/OV/bin/ovstart

21. Unmount the CD ROM by typing:

cd /

umount /cdrom

exit

22. Remove the CD from the CD ROM drive.
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Perform steps 234 - 29 only if the HPUX distributed environment has been set 
Otherwise, skip to step 30.

23. On the Management Station, become a super user by typing

su

24. Open the file /etc/exports . Remove the # from the beginning of each line which
contains the Console hostname. The file should contain the following lines:

/etc/opt/OV/share -root=First_System: Console_Hostname

/var/opt/OV/share -root=First_System: Console_Hostname

/usr/tmp -root=First_System: Console_Hostname
25. Save and close the file /etc/exports . 

26. Run the following commands:

/usr/sbin/exportfs -au

/usr/sbin/exportfs -av

27. On the Management Console, become a super user by typing:

su

28. Open the file /etc/fstab and restore each line by deleting the # in the beginning 
of each line. Save and close the file.

29. Type the following commands:

/etc/mount Station_Hostname:/etc/opt/OV/share

/etc/mount Station_Hostname:/var/opt/OV/share

/etc/mount Station_Hostname:/usr/tmp

/opt/OV/bin/ovwsetupclient /opt/OV/nfs/ Station_Hostname

Note: The path many be different if automounter was used.

30. Exit super user and become a normal user. On the Management Console, bring
OpenView windows using the server database by typing:

/opt/OV/bin/ovw &

5.7 Re-Installation
To re-install TEAM V1.2.0 software, it is necessary to first perform all the steps in the
installation procedure. This removes all TEAM V1.2.0 packages. You can then repea
steps of the Installation Procedure described earlier in this chapter.

5.8 Errata and Document Changes
This section describes differences between this software release and the Operating 
Installation Instructions for T1/E1 Access Manager (TEAM) Manual - GDC Publicatio
No. 058R693-V111.

• Point-to-Point Protocol (PPP) Functions described in Section 9 are not present in
HP OpenView on HP-UX version 10.x and higher.
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• Some descriptions of TEAM on HP OpenView are relevant to the OpenView for 
SunOS version only and not to the HP OpenView on version 10.x and higher.

6.0 Known Issues
• TEAM Functions->Network Access->Performance->1&24 Hour Reports

Remote Network Reports are not supported.

• TEAM Functions->Network Access->Performance->DS0 Diagnostics
Thirty second time-out parameter is too short for diagnostic test. The current sys
has application timers for all of the diagnostic tests. The default timers are too sh
causing the application to retry the command prior to the DMAs first response. T
parameters can be modified in the /opt/OV/app-defaults/team/team.ini  
or /opt/OV/app-defaults/C/team/team.ini file. (1000080)

• TEAM Functions->Network Access->Performance->DS1/T1 Diagnostics
Test Pattern options for User Defined  and User Pattern  are not supported.

• TEAM Functions->Network Access->Performance->Channel Diagnostics
Although Self Test may be selected while in a Digital Loopback test, this operatio
not recommended and the results are indeterminate. 

• TEAM Functions->Network Access->Performance DS0/DS1/Channel 
Diagnostics
On the pop up message for a “No response”, clicking on the Help  button functions the 
same as clicking on the OK button. In either case, the command is retried. 

• A Communications Error may occur when changing from alternate DS0’s to 
consecutive DS0’s. To avoid this, set the new channel rate by selecting consecu
DS0’s and saving to unit. Then select the desired bandwidth and download to the

• TEAM Functions: Restore Node
Attempting to dial with a blank telephone number causes the screen to stay in a 
“working” mode until a time out occurs. 

The displayed phone number may not match the selected phone number in the s
list. When the window is first opened the first node in the list is highlighted, howe
the phone number displayed at the bottom is the last phone number dialed, not t
phone number of the highlighted node. 

If the dial backup attempt fails when restoring a node, the user will not be warne
the failure. 

• TEAM Functions: Master DMAs Configure->Modem Configuration:

Intermittently, the Master DMAs Configure window may disappear when the user e
an AT Modem Configuration sub-window in “edit” mode. 

• PPP Functions->Restore Network

If the user has a PPP session established and wants to dial another PPP sessio
system drops the first PPP session off-line then dials both of the PPP sessions.

• TEAM Icon
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In order to manage TEAM functions, the LAN segment map must display the TE
icon. However, when a node is discovered for the first time at a management stat
generic sysbol is displayed instead of the TEAM icon and TEAM functions appea
grayed-out at the Administer menu. To remedy this, perform the following steps:

A. Click on the generic icon to highlight it.

B. Right-click on the highlighted icon to open the symbol menu, then click on th
Change Symbol Type  option.

C. At the Change Symbol Type window, select the TEAM icon for the symbol su
class.

D. Click OK.

• Miscellaneous

DMA alarms are not passed from TEAM to Megaview or Data Set Manager after
reboot. In order for alarms to be passed from TEAM to Megaview or Data Set Man
it is necessary to stop and restart ENmacs via the Network Management Utilities

TEAM error messages are not logged to the console window on a stand-alone sy
Error messages will appear in the window from which HP Openview was started

Disabling the Supervisory terminal from the control software is not supported. 

Help windows do not exit upon termination of the application. Explicitly exit all he
window prior to exiting any TEAM application. 

During installation “Duplicate value in database for Agent” is reported. This is nor
warning message on system upgrading or reinstallation the TEAM product.

• On the Front Panel display, some LED labels may appear out of alignment over 
associated LEDs. This does not affect the operation of the application.

• In some TEAM application windows, slight text misalignments may appear. Thes
not affect the usability or operation of the application.

• Some TEAM applications may display meaningless characters in the application
window headings. This is due to a font conflict which can be resolved by typing t
following on the command line before running ovw:

xrdb -merge /opt/OV/bin/gdc_load_resources

7.0 Operating Guidelines
• Read Only Maps will not be automatically updated. Use Map->Refresh Map to up

the map. 

• Make sure that the HPUX system application is set to 10PT. This is done throug
Font button within the Style manager in the VUE workspace area. If set larger tha
PT, some TEAM application windows will not display all of the textual information
they contain. 

• TEAM applications may take up to one minute to start up after an install of TEAM
software or a reboot of the system. This is due to the loading of shared libraries.
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• For the TEAM V1.2.0 software to function, you must set the values for Timeout a
Retries at the SNMP Configuration screen, as shown below:

Timeouts should be set to 20s (Default = 0.8s) 
Retries should be set to 3(Default = 3)  

• After an installation of TEAM software, the user must enable Discover New IP 
Nodes  from the shelf map Options menu in order for IP discovery to occur. 

• In some TEAM applications, the text label associated with the Help link does not
display. This does not affect the operation of the Help link.

• During installation of the TEAM software, the following error pop-up may appear
The xterm environment has not been set.  This error will prevent any 
windows from launching. To correct this, add the following the following comman
should be added to the $HOME/.cshrc  file:

xhost + HostName
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Section 2 - TEAM Applications and HP OpenView NNM
Scalable and Distributed Environments

1.0 Overview
This section briefly discusses the Scalability and Distribution features in NNM and ho
integrate/install TEAM applications in a Scalable and Distributed environment. Refer t
HP OpenView Manual, “A Guide to Scalability and Distribution for NNM” for more 
detailed understanding and concepts.

1.1 Features and Advantages
The Scalable and Distribution features of the HP OpenView NNM provide robust 
performance over a wide range of network sizes and degrees of complexity. 

The Scalable feature gives NNM the potential for handling networks of different size
both LAN and WAN environments. To make NNM scalable, the network manageme
work load must be distributed to multiple systems. Then, the Distribution feature impr
performance of NNM in large networks by reducing the amount of management traffic
network resources.

Some of the advantages of these NNM features are:

• The Scalable feature of NNM makes it easier to adapt network management for 
handling new networking landscapes.

• The Distribution feature minimizes the amount of network management traffic. 
Without this capability, it would be impractical to monitor thousands of nodes from
single workstation.

• Faster response times and better performance as work load is distributed to mul
workstations.

• Shared responsibilities reduces the risk of losing network management data in the
of an unexpected shutdown of the management station.

• One Common network management database (in most cases) for all users, so th
modifications of managed nodes would be reflected across the board.

Some drawbacks/trade-offs are:

• Distribution of tasks requires an increased number of computing resources.

• Scalable and distributed environment requires added complexity in setup.
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1.2 Theory of Operation
In a Stand-alone environment, all network management tasks are done on a single 
workstation. In a Distributed environment tasks are handled by multiple workstations
Collection Station (CS), Management Station (MS), Management Console (MC). 
Depending on network size, structure, geography and trends, one of four deploymen
models should be chosen: Fully centralized, Centralized hierarchical, Hierarchical, o
operative independent.

• Figure 1 demonstrates a Centralized hierarchical model. Refer to the HP OpenV
manual for examples of other models and for choosing the model for your needs

• Figure 2 demonstrates the HP OpenView and TEAM processes and applications
run on the collection station, the management station, and the management con

1.2.1 The Collection Station
A collection station discovers nodes and forwards this information to the manageme
station. The collection station also monitors (the netmon process) the nodes in its do
and forwards any traps it receives from the managed node (IP device) to the manag
station. Depending on the number of managed nodes and network structure, there co
more than one collection station. The collection and management stations periodica
synchronize node and topology information. Figure 1 shows two collection stations fee
node and topology information to the management station. 

1.2.2 The Management Station
The management station processes the node and topology information it receives fro
collection stations and stores the information (via ovwdb) in a database. The manag
station also receives from collection stations the trap information for various manage
nodes (ovtrapd process) and stores it. There should only be one management statio
distributed setup so that the node information can be shared by all the users on vari
management consoles. 

1.2.3 The Management Console
The management console is where all the user processes are executed. User interfa
(application) processes like ovw, xnmevents, xnmsnmpconf are executed here in ord
manage the nodes in the management station’s database. The Management Console
be connected to the Management Station using an Ethernet LAN or a high speed ne
matching the speeds of LAN. Management Station and the Management Consoles w
share the same database by mounting the database over the Network Filing System 

1.2.4 Permissions
The first network operator to run ovw and launch OpenView screens will have read/w
permissions to the database. The rest of the operators will get read-only permissions
that read-only screens do not synchronize automatically with changes in network top
or with the addition or deletion of devices to the database. To resynchronize the enti
network map, network operators on the management console must manually perform 
Map -> Refresh Map  command. All network operators will be able to perform oth
TEAM Network Management operations, such as Configuration, Provisioning, 
Diagnostics. Operators must manage a unit in the shelf from only one workstation at a
8 Release Notes for GDC Part No. 058U704-C01A
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Figure 1: Example of the Centralized Hierarchical Model
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1.3 The Distribution of Processes and Applications
The sequence of events that occur end-to-end from the IP node to the management c
(Figures 1 and 2) is as follows:

Collection Station(s)

1. netmon  process begins IP discovery, and populates the local topology 
database(ovtopmdb ) with the help of ovtopmd  process.

2. After the completion of discovery, the topology information is accessible by the 
management station.

Management Station

3. The management station requests the collection station(s) for topology informatio
ovrepld  process.

4. Upon obtaining the topology information (from all collection stations), the 
management station merges the data into its topology database. 

5. Using the data in the topology database, the processes in the management sta
communicate with each node to update other information necessary to manage
node.

6. Periodically, the ovrepld processes on the collection station(s) and managemen
station synchronize the topology data. Once synchronization is complete, only 
changes in status and topology get sent to the management station.

Management Console and Management Console X Term Server

7. After the management station is ready with node information, the ovw process c
run.

8. Once ovw is up and running, network management on various nodes can be do

Note: When one of the management consoles is also designated as a X-Term Server, 
X-Terminals (such as Tektronics Graphics terminal) could be setup to display ovw 
sessions on these terminals. The ovw sessions are actually executed on the manag
console but displayed on the X-Terminals.
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Figure 2: HP OpenView and Team Processes and Applications
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2.0 Integrating the TEAM Application in a Distributed Environment
Due to distribution of tasks in a distributed environment, TEAM software products mus
installed on the collection station, the management station and the management con
the precise order as described in Sections 2 and 3 of the TEAM Core Release Notes
following sections describe the dependency tree, discovery, and event handling of G
devices for TEAM software products.

2.1 TEAM Software Product Dependency
To manage any GDC product using TEAM software, multiple software products are 
required. Figure 3 shows the dependencies among various products. In the example
SC521 and SC553 cards along with their associated packages are being managed b
TEAM521 and TEAM553. Both TEAM products are dependent upon TEAM Core. 
Because of this product dependency, TEAM Core must be installed on the workstati
before installing TEAMSC521, etc. 

. 

Figure 3: TEAM Software Product Dependencies
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TEAM553 TEAM521
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2.2 Discovery in an HP OpenView Distributed Environment
Once TEAM software is installed and configured in an HP OpenView NNM distribute
environment, the system is ready for network management of GDC devices. This be
with the discovery of a GDC device on the management console where it is managed.
of the typical applications that are executed on the management console are shown
Figure 2. The sequence of events that occur end-to-end is as follows:

1. A GDC device is discovered by a collection station and gets stored in its topolog
database. 

2. This discovery information is requested by the management station in a 
synchronization cycle of ovrepld  process.

3. The management station adds the device into its database as a new node.

4. Once a new node gets added on the management station, the shelf_discovery  
gets notified of the change. 

5. The Shelf_discovery  process communicates with the SCM to get the shelf 
contents and other relevant information and stores the information.

6. After a GDC shelf is discovered, a new shelf gets added to the TEAM universe 
submap.

7. From this submap various GDC devices can be managed.

2.3 Event Handling
A trap generated from a GDC device arrives at the management console where it is up
The sequence of events that occur end-to-end is as follows:

A. When SCM is set up to do so, a GDC device sends a trap to the collection sta

B. The collection station then forwards the trap to the management station, whe
gets processed by shelf_discovery  process and notifies the shelfmap pro-
cess on the management console.

C. The shelfmap process updates the status of the device associated with the e
Note that one process runs for every ovw session.
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