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Section 1-HPUX

1.0 Overview 
These installation and release notes provide new information relevant to this version 
TEAM 540 software product. This updates the information supplied by the TEAM 540 
Operation Manual. For detailed product information, refer to that manual. 

Team 540 is now supported on HPUX 11.0 with HPOV 6.1. For additional product 
information and the latest updates, check the GDC website at http://www.gdc.com  
or contact your GDC field representative. 

2.0 Software Reference
Throughout this manual, short forms of the software product names will be used. Th
following table provides detailed reference information for all software modules relev
to TEAM 540 for HPUX installation. 

2.1 TEAM 540 Verification
The TEAM 540 CD contains the software packages listed in the table above. After 
installation is completed, these packages should be present on the system at the ve
indicated in the table or greater. To verify the presence of the TEAM 540 packages 
currently installed type the following command:

/usr/sbin/swlist -1 fileset TEAM540 <PackageName>

Table 1:  Software Reference for HPUX 

Item Part Number Version / Release

TEAM 540 Software Product 058U705-C01A Ver 2.1.0

TEAM 540 Operation Manual 058R694-V210 Issue 1

HPOV NNM Software Product Rev 6.1

HPUX Ver 11.0 / November 1999

HPUX and HPOV Patches Ref: HP website

HPOV Network Node Manager 
Installation Guide

HP J1136-9000 Latest Release

Table 2: TEAM 540 Software Packages

Package Name Description Version

GDCTeam GDC TEAM Utilities Ver 1.1 or higher

GDCTeamSA GDC Standalone Utilities Ver 1.0 or higher

GDCa540 GDC Standalone TEAM 540 Ver 2.1 or higher
e Notes for GDC Part No. 058U704-C01A Page 5
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3.0 Improvements Since Last Release
This is the initial release of TEAM 540 software. This software has been tested to be
2000 compliant in accordance to GDC ENG-STD-003. Check GDC's web site at 
http://www.gdc.com  for the latest Year 2000 information. Note the following new
information concerning this software:

• The application is approved for operation on SUN Solaris 2.7, Solaris 2.8, HP 
OpenView 6.1 and HPUX 11.0 upgrades. 

4.0 Corrected Issues
None.

5.0 HP OpenView for HPUX
The following sections describe the current requirements and procedures concernin
HP OpenView for HPUX version of TEAM 540 software.

5.1 Hardware Requirements
The current hardware requirements for TEAM 540 software is as follows:

• HP 9000 series model 700 or greater with a minimum of 96 megabytes of RAM, 
2 gigabytes of hard disk space, 350 megabytes of free space and 500megabytes o
space.

• Minimum disk space requirements:

/opt 60 megabytes

• CD ROM Drive

Note: For information on hardware requirements for HP OpenView Network Node Manage
products, refer to the HP OpenView Network Node Manager Products Installation G

5.2 Software Requirements
Before installing this version of TEAM 540, the following software must be installed. Re
to Table 1, Software Reference for HPUX, for detailed identification of all software 
products discussed below.

System Software Requirements

• HP OpenView NNM 

• HPUX

• The most recent HPUX and HP OpenView patches for these versions

• TEAM 540 Software Packages
Release Notes for GDC Part No. 058U704-C01A
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Note: IMPORTANT - It is highly recommended that the customer download and install the
latest HP OPENVIEW CONSOLIDATED PATCH CLUSTER from the following HP w
site: http://ovweb.external.hp.com/cpe/patches. This will ensure that you have update
OpenView along with any current fixes to reported problems. 

Refer to the HPUX web site for updates to the HPUX 11.x Operating System.

Note: It is the customer’s responsibility to install the listed HP software and patches, and to
ensure they are fully operational before loading the General DataComm TEAM 
applications.

5.3 First Time Installation
1. Close all HP OpenView and TEAM application windows (if applicable). 

2. Make sure that all users exit HP OpenView.

3. Insert the TEAM 540 Compact Disk into the CD ROM drive.

4. At a shell prompt become super-user by entering the following command:

su

5. Verify that there is a /cdrom  directory already present. If not, create it. 

6. Enter the following commands: 

csh

mount /dev/dsk/c0t2d0 /cdrom

cd /cdrom

./INSTALL*

7. The install script will automatically stop HP OpenView background processes by
running /opt/OV/bin/ovstop.  Files will then be extracted from CD to hard 
disk, an operation that will take a few minutes.

8. The script then automatically runs swremove, which displays a graphical user 
interface that you use to remove existing TEAM software. The window title bar w
display SD Remove - Software Selection  in its title bar. If this is a first 
time installation of TEAM, select File->Exit  to dismiss the GUI. If there is 
existing TEAM software to remove, use the following procedure:

A. Select TEAM540 from the window’s scroll-down list box.

B. Select Actions->Mark  for Remove.

C. Select Actions -> Remove (analysis) .

D. Select OK in the Remove Analysis dialog box to proceed.

E. Select Yes in the Confirmation popup to continue with the removal.

F. Select Done in the “Remove Window” dialog box when the process is comple
The Done field will become ungrayed.

G. Select File->Edit  in the main “SD Remove” window.
e Notes for GDC Part No. 058U704-C01A Page 7
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9. The script then automatically runs swinstall , which displays a graphical user 
interface for installing the TEAM 540 software. The window will have “SD Install
Software Selection” in its title bar. 

10. Select TEAM540 from the window’s scroll-down list and double click on it. 

11. Select Actions->Mark for Install .

12. Select Actions ->Install (analysis) .

13. Select OK in the “Install Analysis” dialog box to proceed.

14. Select Yes in the “Confirmation” popup to continue with the installation.

Note: If the installation stops, displaying an error message, it may be that a GDCTeam util
application package has been detected on the host that is more recent than the one
installed. To resolve the conflict, consult the first entry in the Log File (as prompted in
error message), then click the Cancel button in the Install Analysis window. From the
Install window menu bar, select Options ->Change Options. When the Options wind
appears, scroll to “Enforce dependency analysis errors in agent” and click the select
box (deselects the option). Then, click OK. You can now install software packages 
selectively. Resume the installation from Step 9 - this time, not selecting GDCTeam. 
a Dependency Message Dialog window appears, click OK.

15. When the installation is complete, the Done button in the Install window is no longer
grayed out. Select Done now.

16. At the end, select File->Exit  in the main “SD Install” window.

The script will automatically run /opt/OV/bin/ovstart  to start HP OpenView 
background processes.

17. Exit super-user (type exit ).

18. Update each HP Open View user’s environment by changing your environment 
scripts (with textedit or your favorite editor) as follows:

C (csh) Shell users - add the following lines to #HOME/.cshrc:

source /opt/OV/bin/ov.envvars.csh

set path=($path $OV_BIN)
xhost + HostName

Bourne (sh) and Korn (ksh) Shell users - add the following lines to #HOME/.pro

. /opt/OV/bin/ov.envvars.sh

PATH=$PATH:$OV_BIN;export PATH

These updates do not take effect until you log out and log back in. 

19. Unmount the CD ROM by typing:

cd /

umount /cdrom

exit
Release Notes for GDC Part No. 058U704-C01A
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20. Remove the CD from the drive, then confirm HP Openview and TEAM processe
running by typing:

/opt/OV/bin/ovstatus

21. If all processes are running, log out from root by typing exit

22. Exit super-user (type exit ).

23. Start HP Openview by typing:

ovw &

5.4 Installing in an HPUX Distributed Environment
A distributed environment consists of three types of workstations. Not all workstation
require installation of all software, but the workstations must be set up in the followin
order: 

A. Collection Station

B. Management Station

C. Management Console

The procedures for TEAM Core and product software installation vary depending on
type of workstation. Perform the installation and set up procedures for each workstat
your distributed environment. 

5.4.1 Setting Up Collection Stations
On workstations that serve as collection stations, you must install the TEAM software
then configure events so that traps are forwarded to the management station. Refer
event data in Table 3 during this installation process. 

1. From the Enterprise Identification pane, select an Enterprise Name

for example: gdc_cmnAlarm

2. From the Event Identification pane, select an Event Name

for example: dmscmnAlarmTrap

3. From the Event Configuration window menu bar, select Edit->Modify Event . 
The Event Configurator/Modify Event dialog box appears.

4. Click on the Forward Event check box to expand the dialog box. 
The Forwarded Event Destinations pane displays.

Table 3: Event Forwarding Data

Enterprise Name (Enterprise ID) Event Name (Enterprise Identifier)

gdc_540(.1.3.6.1.4.1.498.8.4) snmp540ColdStart(.1.3.6.1.6.3.1.1.5.1)

gdc_540(.1.3.6.1.4.1.498.8.4) snmp540WarmStart(.1.3.6.1.6.3.1.1.5.2)

gdc_540(.1.3.6.1.4.1.498.8.4) snmpLinkDown(.1.3.6.1.6.3.1.1.5.3)

gdc_540(.1.3.6.1.4.1.498.8.4) snmpLinkUp(.1.3.6.1.6.3.1.1.5.4)

gdc_540(.1.3.6.1.4.1.498.8.4) snmp540Authentication(.1.3.6.1.6.4.1.1.5.5)
e Notes for GDC Part No. 058U704-C01A Page 9
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5. Type the hostname or IP Address for destination. Click Add, then click OK.
Destinations are the managements stations to which events will be forwarded. 

6. Repeat steps 1 through 5 for each of the events listed in Table 3. When all even
forwarded, click OK in the Event Configurator/Modify Event dialog box.

7. At the Event Configuration window, click File->Save  to save the changes.

8. To cause Openview processes to re-read the trapd.conf file, generate Event by t

$OV_BIN/xnmtrap -event

9. Unmount the cdrom by typing:

umount /cdrom

5.4.2 Installing TEAM Applications on the Management Station
To install TEAM 540 on the Management Station, perform the following steps:

1. Make sure all users exit HP OpenView for HPUX.

2. Close all HP OpenView and TEAM application windows (if applicable). 

3. Insert the TEAM 540 CD into the CD ROM drive.

4. At a shell prompt become super user by entering the following command:

su

5. Check /  to make sure there is a /cdrom  directory already present. If not, create it.

6. Start the installation process by entering the following commands:

csh

mount /dev/dsk/c0t2d0 /cdrom

cd /cdrom

./INSTALL*

7. The install script will first run /opt/OV/bin/ovstop  to stop HP OpenView 
background processes. Then, the SD Install - Software Selection window appea
indicating swinstall  has begun.

8. Highlight the TEAM 540 to be installed: 

TEAM540

9. Select Actions ->Mark for Install .

10. Select Actions ->Install (analysis) .

11. In the Install Analysis dialog box, click OK to proceed.

12. In the Confirmation window, click Yes to continue with the installation.

13. The following error message will appear: 

$HOME..sw/sessions/swinstall.last 

14. Click OK. TEAM 540 software installation will now begin. 

15. When the process is complete, the Done button in the Install Window dialog box 
becomes “un-grayed”. Click Done. 

16. From the main SD Install window, select File->Exit  .
0 Release Notes for GDC Part No. 058U704-C01A
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17. The install script then starts HP OpenView background processes by running 
/opt/OV/bin/ovstart  .

18. Confirm that the correct versions of software have been installed by typing:

/usr/sbin/swlist TEAM540

19. All GDC TEAM 540 software packages installed on the workstation will be displa
along with their version numbers. 

20. Unmount the CD ROM by typing:

cd /

umount /cdrom

exit

21. Remove the CD from the CD ROM drive.

22. Confirm HP OpenView and TEAM 540 processes are running by typing:

/opt/OV/bin/ovstatus

5.4.3 Setting Up the Management Station
1. At the shell prompt, become a super user by typing:

su

2. Type the following commands:

/opt/OV/bin/ovstop

/sbin/init.d/nfs.client stop

/sbin/init.d/nfs.server start

3. To ensure the NFS server daemon process nfsd  is running, type the following 
command and verify the results:

ps -ef | grep nfsd

Note: If the nsf is not running, edit the etc/rc.config.d/nfsconf file and change 
NFS_SERVER=0 to NFS_SERVER=1. Save the file, then repeat steps 1 through 3.

4. To add all Management Consoles to the Management Station, edit the /etc/hosts 
file by typing each Console’s specific IP address and Hostname on a separate li
shown in the example:

###.###.###.### Console_Hostname

###.###.###.### Console_Hostname
5. Save and close the /etc/hosts file . 

Note: If using vi editor, use wq!  to save and close the file.
e Notes for GDC Part No. 058U704-C01A Page 11
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6. To allow a single Management Console to share the Management Station direc
over NFS, edit the /etc/exports file as follows:

/etc/opt/OV/share -root= Console_Hostname 

/var/opt/OV/share -root= Console_Hostname 

/usr/tmp -root= Console_Hostname 

Note: If the exports file does not exist, create one.

7. Save and close the /etc/exports  file.

8. To share the Management Station directories with the Consoles over NFS, type

usr/sbin/exportfs -au 

usr/sbin/exportfs -av

9. Edit the file /etc/opt/OV/share/conf/ovwdb.auth file as shown below to 
add an entry for the Console, as shown in the example: 

Console_Hostname +

10. Edit the file /etc/opt/OV/share/conf/ovw.auth file as shown below to 
add an entry for the Console, as shown in the example: 

Console_Hostname +

11. Type the following commands to restart nfs server:

/etc/init.d/nfs.server stop

/etc/init.d/nfs/server start

12. To start HP Openview processes, type:

/opt/OV/bin/ovstart

13. Exit super user by typing exit .

14. Complete the setup by typing:

/opt/OV/bin/ovw &

5.4.4 Installing TEAM 540 on the Management Console

Note: If the HPUX distributed environment has been set up, it must be disabled temporaril
before loading any TEAM software to avoid sharing conflicts with the server. Additio
steps for this are provided below.

1. Make sure all users exit HP OpenView for HPUX.

2. Close all HP OpenView and TEAM application windows (if applicable). 

3. On the Management Console, become super user by typing:

su
2 Release Notes for GDC Part No. 058U704-C01A
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If the HPUX distributed environment has been set up, perform steps 4 - 9. 
Otherwise, skip to step 10.

4. Disconnect as a HP OpenView client by typing:

/opt/OV/bin/ovwsetupclient -u

5. Open the file /etc/fstab and type a # in the beginning of each line to commen
out each line with a Console hostname. 

6. Save and close the file.

7. On the Management Station, become a super user and open the file /etc/exports . 
Comment out each line with a Console hostname by typing a # in the beginning of 
each line. 

8. Save and close the file.

9. On the Management Console, become a super user and enter the following com

/etc/umount Station_Hostname:/etc/opt/OV/share

/etc/umount Station_Hostname:/var/opt/OV/share

/etc/umount Station_Hostname:/usr/tmp

10. Insert the TEAM 540 CD into the CD ROM drive.

11. At a shell prompt become super user by entering the following command:

su

12. Check /  to make sure there is a /cdrom  directory already present. If not, create it.

13. Start the installation process by entering the following commands:

csh

mount /dev/dsk/c0t2d0 /cdrom

cd /cdrom

./INSTALL*

14. The install script will first run /opt/OV/bin/ovstop  to stop HP OpenView 
background processes. Then, the SD Install - Software Selection window appea
indicating swinstall  has begun.

15. Highlight the TEAM 540 to be installed: 

TEAM540

16. Select Actions ->Mark for Install .

17. Select Actions ->Install (analysis) .

18. In the Install Analysis dialog box, click OK to proceed.

19. In the Confirmation window, click Yes to continue with the installation.

20. The following error message will appear: 

$HOME..sw/sessions/swinstall.last 

21. Click OK. TEAM 540 software installation will now begin. 

22. When the process is complete, the Done button in the Install Window dialog box 
becomes “un-grayed”. Click Done. 

23. From the main SD Install window, select File->Exit  .
e Notes for GDC Part No. 058U704-C01A Page 13
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24. The install script then starts HP OpenView background processes by running 
/opt/OV/bin/ovstart  .

25. Confirm that the correct versions of software have been installed by typing:

/usr/sbin/swlist TEAM540

26. All GDC software packages installed on the workstation will be displayed along 
their version numbers. 

27. Unmount the CD ROM by typing:

cd /

umount /cdrom

exit

28. Remove the CD from the CD ROM drive.

29. Confirm that HP OpenView and TEAM Core processes are running by typing:

/opt/OV/bin/ovstatus

Perform steps 30 - 37 only if the HPUX distributed environment has been set 
Otherwise, skip to step 38.

30. On the Management Station, become a super user by typing:

su

31. Open the file /etc/exports . Restore the Console hostnames by removing the# 
from the beginning of each line containing the Console hostname. 

32. Save and close the file /etc/exports . 

33. Type the following commands:

/usr/sbin/exportfs -au

/usr/sbin/exportfs -av

34. On the Management Console, become a super user by typing:

su

35. Open the file /etc/fstab and restore each line by deleting the # in the beginning 
of each line. 

36. Save and close the file.

37. Type the following commands: 

/etc/mount Station_Hostname:/etc/opt/OV/share

/etc/mount Station_Hostname:/var/opt/OV/share

/etc/mount Station_Hostname:/usr/tmp

/opt/OV/bin/ovwsetupclient /opt/OV/nfs/ Station_Hostname

Note: The path many be different if automounter was used.
4 Release Notes for GDC Part No. 058U704-C01A
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38. Exit super user and become a normal user. On the Management Console, bring
OpenView windows using the server database by typing:

/opt/OV/bin/ovw &

5.4.5 Setting Up the Management Console
1. At the shell prompt, become a super user by typing:

su

2. Type the following commands:

/opt/OV/bin/ovstop

/sbin/init.d/nfs.server stop

/sbin/init.d/nfs.client start

3. To ensure the NFS client daemon process biod is running, type the following 
command and verify the results:

ps -ef | grep biod

Note: If the biod is not running, edit the /etc/rc.config.d/nfsconf file and change 
NFS_CLIENT=0 to NFS_CLIENT=1. Save the file, then repeat steps 2 and 3.

4. To add the Management Station to the Management Console, edit the /etc/hosts 
file by typing the specific Management Station IP address and Hostname, as sho
the example:

###.###.###.### Station_Hostname

###.###.###.### Station_Hostname
5. Save and close the /etc/hosts file. 

Note: If using vi editor, use wq!  to save and close the file.

6. Type the following commands:

mkdir -p /opt/OV/nfs/ Station_Hostname/etc/opt/OV/share

mkdir -p /opt/OV/nfs/ Station_Hostname/var/opt/OV/share

rmdir /usr/tmp

mkdir -p /usr/tmp

chmod 777 /usr/tmp

7. To mount the Management Station directories on this Console over NFS, edit th 
/etc/fstab file as shown in the example:

Station_Hostname:/etc/opt/OV/share /opt/OV/nfs/ Station_Hostname/etc/opt/OV/share nfs rw 0 0
Station_Hostname:/var/opt/OV/share /opt/OV/nfs/ Station_Hostname/var/opt/OV/share nfs rw 0 0
Station_Hostname:/usr/tmp /usr/tmp nfs rw 0 0

8. Save and close the /etc/fstab file.

Note: If using vi editor, use wq!  to save and close the file.
e Notes for GDC Part No. 058U704-C01A Page 15
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9. To mount the Management Station directories on this Console over NFS, type t
following commands:

/etc/mount Station_Hostname:/etc/opt/OV/share

/etc/mount Station_Hostname:/var/opt/OV/share

/etc/mount Station_Hostname:/usr/tmp

10. Type the following commands to restart nfs client:

/etc/init.d/nfs.client stop

/etc/init.d/nfs.client start

11. Set up the Management Console by typing:

/opt/OV/bin/ovwsetupclient /opt/OV/nfs/ Station_Hostname
12. Exit Super User by typing exit .

13. Complete the setup by typing:

/opt/OV/bin/ovw &

Note: It is not necessary to start HP OpenView daemons using /opt/OV/bin/ovstart on the 
Management Console because the Console shares the same HP OpenView databa
present on the Management Station over NFS.

Note: If the Console OpenView windows does not start up properly, reboot the Manageme
Station and wait until it is UP completely. Then, reboot the Console.

5.4.6 Adding/Updating User Accounts in Distributed Environments
1. Type sam

2. Select Users and Groups .

3. Select Users .

4. Under the Actions menu, select Add. 

5. Enter Login name and select the shell you desire (prefer cshell)

6. Enter Password if desired

7. Exit sam

8. Log off and log back in under a user account. 

5.5 De-installation
1. Make sure that all users exit HP OpenView.

2. Insert the TEAM 540 Compact Disk into the CD ROM drive.

3. At a shell prompt, become super-user by typing 

su 

4. Start the removal process by entering the following commands:

csh
6 Release Notes for GDC Part No. 058U704-C01A
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mount /dev/dsk/c0t2d0  /cdrom

cd /cdrom/hpux

./REMOVE*

The remove script will automatically stop HP OpenView background processes 
running /opt/OV/bin/ovstop . The script then automatically runs swremove , 
which opens a window “SD Remove - Software Selection” for removing existing
TEAM540 software. 

5. Select TEAM540 from the window’s scroll-down list and double click on it.

6. Select Actions->Mark for Remove .

7. Select Actions ->Remove (analysis) .

8. Select OK in the “Remove Analysis” dialog box to proceed.

9. Select Yes in the “Confirmation” popup to continue with the removal.

10. Select Done in the “Remove Window” dialog box. 

11. At the end select File->Exit  in the main “SD Remove” window.
The script will automatically run /opt/OV/bin/ovstart  to start HP OpenView 
background processes.

12. Unmount the CD ROM by typing the commands

cd /

umount /cdrom

exit

13. Remove the Compact Disk from the CD drive.

14. Exit as super-user (type exit ).

15. To start HP Openview, type:

/opt/OV/bin/ovw &

6.0 TEAM 540 De-Installation in HPUX Environments
1. In the OpenView Root map, click on the Standalone universe icon.

2. From the Edit menu of the Root map menu bar, select Delete , then select From 
All Submaps  to remove the Standalone icon from the Root map. 

3. Make sure that all users exit HP OpenView for HPUX.

4. Insert the TEAM 540 CD into the CD ROM drive.

5. At the shell prompt, become super user by typing:

su

6. Start the removal process by entering the following commands:

csh

mount /dev/dsk/c0t2d0 /cdrom

cd /cdrom

./REMOVE*
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7. The remove script will first run /opt/OV/bin/ovstop  to stop HP OpenView 
background processes. Then, the SD Remove - Software Selection window app
indicating swremove  has begun.

8. Highlight one or both of the TEAM 540 to be removed: 

TEAM540

9. Select Actions->Mark for Remove .

10. Select Actions ->Remove (analysis) .

11. In the Remove Analysis dialog box, click OK to proceed.

12. Click OK. TEAM 540 software removal will now begin. 

13. When the process is complete, the Done button in the Remove Window dialog box 
becomes “un-grayed”. Click Done. 

14. From the main SD Remove window, select File->Exit  .

15. The remove script then starts HP OpenView background processes by typing:

/opt/OV/bin/ovstart 

16. Unmount the CD ROM by typing:

cd /

umount /cdrom

exit

17. Remove the CD from the CD ROM drive.

18. Confirm HP OpenView processes are running by typing the command:

/opt/OV/bin/ovstatus

6.1 Distributed Environment De-Installation
De-installation of TEAM software in a distributed HPUX environment should be 
performed in the following order: 

A. Collection Station

B. Management Station

C. Management Console

Procedures vary, depending on the type of environment. Refer to the appropriate 
procedures below. Additional information about distributed environments is provided
Section 2.

6.1.1 De-Installing TEAM 540 from the Collection Stations
1. Become a super user by typing su  and then supplying the super user password.

2. Setting up environment variables by typing:

/usr/bin/sh

.  /opt/OV/bin/ov.envvars.sh

3. Start the Event system configurator GUI by typing:

$OV_BIN/xnmtrap
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4. Select an event and delete it by selecting Edit->Delete->Event . 
Refer to Table 3 for a listing of all events to be deleted.

5. Delete the enterprise by selecting: 

Edit->Delete->Enterprise Identifier

6. From the Event Configuration window, click File->Save  to save the changes.

6.1.2 De-Installing TEAM 540 from the Management Station
1. In the OpenView Root map, click on the Standalone universe icon.

2. From the Edit menu of the Root map menu bar, select Delete , then select From 
All Submaps  to remove the Standalone icon from the Root map. 

3. Make sure that all users exit HP OpenView for HPUX.

4. Insert the TEAM 540 CD into the CD ROM drive.

5. At the shell prompt, become super user by typing:

su

6. Start the removal process by entering the following commands:

csh

mount /dev/dsk/c0t2d0 /cdrom

cd /cdrom

./REMOVE*

7. The remove script will first run /opt/OV/bin/ovstop  to stop HP OpenView 
background processes. Then, the SD Remove - Software Selection window app
indicating swremove  has begun.

8. Highlight the TEAM 540 to be removed: 

TEAM540

9. Select Actions->Mark for Remove .

10. Select Actions ->Remove (analysis) .

11. In the Remove Analysis dialog box, click OK to proceed.

12. Click OK. TEAM 540 software removal will now begin. 

13. When the process is complete, the Done button in the Remove Window dialog box 
becomes “un-grayed”. Click Done. 

14. From the main SD Remove window, select File->Exit .

15. The remove script then starts HP OpenView background processes by typing

/opt/OV/bin/ovstart 

16. Unmount the CD ROM by typing:

cd /

umount /cdrom

exit

17. Remove the CD from the CD ROM drive.
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18. Confirm HP OpenView processes are running by typing the command:

/opt/OV/bin/ovstatus

6.1.3 De-Installing TEAM 540 from the Management Consoles

Note: If the HPUX distributed environment has been set up, it must be disabled temporaril
avoid sharing conflicts with the server. Additional steps for this are provided below.

1. Make sure all users exit HP OpenView for HPUX.

2. Close all HP OpenView and TEAM application windows (if applicable). 

3. On the Management Console, become super user by entering:

su

If the HPUX distributed environment has been set up, perform steps 4 - 8. 
Otherwise, skip to step 9.

4. Disconnect as a HP OpenView client by running:

/opt/OV/bin/ovwsetupclient -u

5. Open the /etc/fstab file and type a # in the beginning of each line which contain
the Console hostname. Save and close the /etc/fstab file.

6. On the Management Station, become a super user and open the file /etc/exports . 
Type a # in the beginning of each line which contains this Console hostname.

7. Save and close the /etc/exports file.

8. On the Management Console, become a super user and type the following comm

/etc/umount Station_Hostname:/etc/opt/OV/share

/etc/umount Station_Hostname:/var/opt/OV/share

/etc/umount Station_Hostname:/usr/tmp

9. Insert the TEAM 540 CD into the CD ROM drive.

10. Start the removal process by entering the following commands:

csh

mount /dev/dsk/c0t2d0 /cdrom

cd /cdrom

./REMOVE*

11. The remove script will first run /opt/OV/bin/ovstop  to stop HP OpenView 
background processes. Then, the SD Remove - Software Selection window app
indicating swremove  has begun.

12. Highlight the TEAM 540 to be removed: 

TEAM540

13. Select Actions ->Mark for Remove .

14. Select Actions ->Remove (analysis) .

15. In the Remove Analysis dialog box, click OK to proceed.
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16. In the Confirmation window, click Yes to continue with the removal.

17. When the process is complete, the Done button in the Remove Window dialog box 
becomes “un-grayed”. Click Done. 

18. From the main SD Remove window, select File->Exit  .

19. The remove script then starts HP OpenView background processes by running

/opt/OV/bin/ovstart

20. Unmount the CD ROM by typing:

cd /

umount /cdrom

exit

21. Remove the CD from the CD ROM drive.

Perform steps 22 -28 only if the HPUX distributed environment has been set 
Otherwise, skip to step 29.

22. On the Management Station, become a super user by typing

su

23. Open the file /etc/exports . Remove the # from the beginning of each line which
contains the Console hostname. The file should contain the following lines:

/etc/opt/OV/share -root=First_System: Console_Hostname

/var/opt/OV/share -root=First_System: Console_Hostname

/usr/tmp -root=First_System: Console_Hostname
24. Save and close the file /etc/exports . 

25. Run the following commands:

/usr/sbin/exportfs -au

/usr/sbin/exportfs -av

26. On the Management Console, become a super user by typing:

su

27. Open the file /etc/fstab and restore each line by deleting the # in the beginning 
of each line. Save and close the file.

28. Type the following commands:

/etc/mount Station_Hostname:/etc/opt/OV/share

/etc/mount Station_Hostname:/var/opt/OV/share

/etc/mount Station_Hostname:/usr/tmp

/opt/OV/bin/ovwsetupclient /opt/OV/nfs/ Station_Hostname

Note: The path many be different if automounter was used.
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29. Exit super user and become a normal user. On the Management Console, bring
OpenView windows using the server database by typing:

/opt/OV/bin/ovw &

6.2 Re-Installation
To re-install TEAM 540 software, it is necessary to first perform all the steps in the D
installation procedure. This removes all TEAM 540 packages. You can then repeat the
of the Installation Procedure described earlier in this chapter.

7.0 Known Issues
• The keyboard “Num Lock” or “Caps Lock” key if pressed (On) will make the mou

buttons and scroll bars inoperable.

• An out of focus problem may exist on a Configuration application when editing th
System Name, System Location or System Contact fields. Usually, when change
entered in these fields, a File->Save selection will cause the new entry to turn wh
indicating a pending edit before a Save operation is initiated. If an out of focus ev
occurs on these fields, after a File-Save the field will not be marked for edit (white)
will not be sent to the unit as a change. Perform the Save operation to show the 
marked for edit (white) and then perform a second Save operation to commit the ch
to the unit.

• A Window Manager problem exists when the application screens create submenu
hide the main screen from view. The main screen cannot be brought forward wit
simple mouse-click in the title bar. You will need to drag the submenus out of the m
screen’s area of focus to view it. 

• On the Front Panel display, some LED labels may appear out of alignment over 
associated LEDs. This does not affect the operation of the application.

• When TEAM 540 software is installed with HPOV Network Node manager, disreg
the following message if it occurs. TEAM 540 software installs successfully despite
error message:

ovstart: ovspmd failed to start and no managers are running
ovw: Cannot open object database: Cannot connect to database
The ovwdb daemon is not running on the server <Hostname>.

Ask the administrator of this server to run "ovstart ovwdb".

ovstop: ovspmd is not running

• In some TEAM application windows, slight text misalignments may appear. Thes
not affect the usability or operation of the application.

• Some TEAM applications may display meaningless characters in the application
window headings. This is due to a font conflict which can be resolved by typing t
following on the command line before running ovw:

xrdb -merge /opt/OV/bin/gdc_load_resources
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8.0 Operating Guidelines
• Read-only maps will not be automatically updated. Use Map->Refresh Map to up

the maps.

• Your HPUX workstation should contain the file etc/rc.config.d/ov500  with 
the following information:

SHLIB_PATH=/lib:/usr/lib:opt/OV/lib/teamcore

export SHLIB_PATH

If this information is not present, the GDC background daemons will not s
after a reboot.

• Make sure that the HPUX system application font size is set to 10 pt. This is 
accomplished via the Font button in the Style Manager via the VUE workspace ar
the font is set larger that 10 pt, some TEAM application windows will not be able
display the entire textual information they contain.

• After installation of TEAM software or a reboot of the system, TEAM applications m
take up to one minute to start due to the loading of the shared libraries.

• For the TEAM 540 software to function, you must set the values for Timeout and
Retries at the SNMP Configuration screen, as shown below:

Timeouts should be set to 10s (Default = 0.8s) 
Retries should be set to 3(Default = 3)  

• After an installation of TEAM software, the user must enable Discover New IP 
Nodes  from the root map Options menu in order for shelf discovery to occur. 

• On the Front Panel display for all applications, the Help link text is not visible. Th
Help link itself is operational and can be accessed by clicking the lower right corn
the Front Panel displays.

• During installation of the TEAM software, the following error pop-up may appear
The xterm environment has not been set.  This error will prevent any 
windows from launching. To correct this, add the following the following comman
should be added to the $HOME/.cshrc  file:

xhost + HostName
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Section 2 - TEAM Applications and HP OpenView NNM
Scalable and Distributed Environments

1.0 Overview
This section briefly discusses the Scalability and Distribution features in NNM and ho
integrate/install TEAM applications in a Scalable and Distributed environment. Refer t
HP OpenView Manual, “A Guide to Scalability and Distribution for NNM” for more 
detailed understanding and concepts.

1.1 Features and Advantages
The Scalable and Distribution features of the HP OpenView NNM provide robust 
performance over a wide range of network sizes and degrees of complexity. 

The Scalable feature gives NNM the potential for handling networks of different size
both LAN and WAN environments. To make NNM scalable, the network manageme
work load must be distributed to multiple systems. Then, the Distribution feature impr
performance of NNM in large networks by reducing the amount of management traffic
network resources.

Some of the advantages of these NNM features are:

• The Scalable feature of NNM makes it easier to adapt network management for 
handling new networking landscapes.

• The Distribution feature minimizes the amount of network management traffic. 
Without this capability, it would be impractical to monitor thousands of nodes from
single workstation.

• Faster response times and better performance as work load is distributed to mul
workstations.

• Shared responsibilities reduces the risk of losing network management data in the
of an unexpected shutdown of the management station.

• One Common network management database (in most cases) for all users, so th
modifications of managed nodes would be reflected across the board.

Some drawbacks/trade-offs are:

• Distribution of tasks requires an increased number of computing resources.

• Scalable and distributed environment requires added complexity in setup.
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1.2 Theory of Operation
In a Stand-alone environment, all network management tasks are done on a single 
workstation. In a Distributed environment tasks are handled by multiple workstations
Collection Station (CS), Management Station (MS), Management Console (MC). 
Depending on network size, structure, geography and trends, one of four deploymen
models should be chosen: Fully centralized, Centralized hierarchical, Hierarchical, o
operative independent.

• Figure 1 demonstrates a Centralized hierarchical model. Refer to the HP OpenV
manual for examples of other models and for choosing the model for your needs

• Figure 2 demonstrates the HP OpenView and TEAM processes and applications
run on the collection station, the management station, and the management con

1.2.1 The Collection Station
A collection station discovers nodes and forwards this information to the manageme
station. The collection station also monitors (the netmon process) the nodes in its do
and forwards any traps it receives from the managed node (IP device) to the manag
station. Depending on the number of managed nodes and network structure, there co
more than one collection station. The collection and management stations periodica
synchronize node and topology information. Figure 1 shows two collection stations fee
node and topology information to the management station. 

1.2.2 The Management Station
The management station processes the node and topology information it receives fro
collection stations and stores the information (via ovwdb) in a database. The manag
station also receives from collection stations the trap information for various manage
nodes (ovtrapd process) and stores it. There should only be one management statio
distributed setup so that the node information can be shared by all the users on vari
management consoles. 

1.2.3 The Management Console
The management console is where all the user processes are executed. User interfa
(application) processes like ovw, xnmevents, xnmsnmpconf are executed here in ord
manage the nodes in the management station’s database. The Management Console
be connected to the Management Station using an Ethernet LAN or a high speed ne
matching the speeds of LAN. Management Station and the Management Consoles w
share the same database by mounting the database over the Network Filing System 

1.2.4 Permissions
The first network operator to run ovw and launch OpenView screens will have read/w
permissions to the database. The rest of the operators will get read-only permissions
that read-only screens do not synchronize automatically with changes in network top
or with the addition or deletion of devices to the database. To resynchronize the enti
network map, network operators on the management console must manually perform 
Map -> Refresh Map  command. All network operators will be able to perform oth
TEAM Network Management operations, such as Configuration, Provisioning, 
Diagnostics. Operators must manage a unit in the shelf from only one workstation at a
6 Release Notes for GDC Part No. 058U704-C01A
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Figure 1: Example of the Centralized Hierarchical Model
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1.3 The Distribution of Processes and Applications
The sequence of events that occur end-to-end from the IP node to the management c
(Figures 1 and 2) is as follows:

Collection Station(s)

1. netmon  process begins IP discovery, and populates the local topology 
database(ovtopmdb ) with the help of ovtopmd  process.

2. After the completion of discovery, the topology information is accessible by the 
management station.

Management Station

3. The management station requests the collection station(s) for topology informatio
ovrepld  process.

4. Upon obtaining the topology information (from all collection stations), the 
management station merges the data into its topology database. 

5. Using the data in the topology database, the processes in the management sta
communicate with each node to update other information necessary to manage
node.

6. Periodically, the ovrepld processes on the collection station(s) and managemen
station synchronize the topology data. Once synchronization is complete, only 
changes in status and topology get sent to the management station.

Management Console and Management Console X Term Server

7. After the management station is ready with node information, the ovw process c
run.

8. Once ovw is up and running, network management on various nodes can be do

Note: When one of the management consoles is also designated as a X-Term Server, 
X-Terminals (such as Tektronics Graphics terminal) could be setup to display ovw 
sessions on these terminals. The ovw sessions are actually executed on the manag
console but displayed on the X-Terminals.
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Figure 2: HP OpenView and Team Processes and Applications
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2.0 Integrating the TEAM Application in a Distributed Environment
Due to distribution of tasks in a  distributed environment, TEAM software products m
be installed on the collection station, the management station and the management c
in the precise order as described in Sections 2 and 3 of these TEAM Core Release N
The following sections describe the dependency tree, discovery, and event handling
GDC devices for TEAM software products.

2.1 TEAM Software Product Dependency
To manage any GDC product using TEAM software, multiple software products are 
required. Figure 3 shows the dependencies among various products. In the example
SC521 and SC553 cards along with their associated packages are being managed b
TEAM521 and TEAM553. Both TEAM products are dependent upon TEAM Core. 
Because of this product dependency, TEAM Core must be installed on the workstati
before installing TEAMSC521, etc. 

. 

Figure 3: TEAM Software Product Dependencies
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2.2 Discovery in an HP OpenView Distributed Environment
Once TEAM software is installed and configured in an HP OpenView NNM distribute
environment, the system is ready for network management of GDC devices. This be
with the discovery of a GDC device on the management console where it is managed.
of the typical applications that are executed on the management console are shown
Figure 2. The sequence of events that occur end-to-end is as follows:

1. A GDC device is discovered by a collection station and gets stored in its topolog
database. 

2. This discovery information is requested by the management station in a 
synchronization cycle of ovrepld  process.

3. The management station adds the device into its database as a new node.

4. Once a new node gets added on the management station, the shelf_discovery  
gets notified of the change. 

5. The Shelf_discovery  process communicates with the SCM to get the shelf 
contents and other relevant information and stores the information.

6. After a GDC shelf is discovered, a new shelf gets added to the TEAM universe 
submap.

7. From this submap various GDC devices can be managed.

2.3 Event Handling
A trap generated from a GDC device arrives at the management console where it is up
The sequence of events that occur end-to-end is as follows:

A. When SCM is set up to do so, a GDC device sends a trap to the collection sta

B. The collection station then forwards the trap to the management station, whe
gets processed by shelf_discovery  process and notifies the shelfmap pro-
cess on the management console.

C. The shelfmap process updates the status of the device associated with the e
Note that one process runs for every ovw session.
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