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This document provides an overview of the Dashcode development environment. It describes how to use
Dashcode to create two types of projects:

 ■ Dashboard widgets—simple, lightweight applications that perform a single task in the Mac OS X
Dashboard environment. Widgets are actually packaged webpages powered by standard web technologies
such as Hypertext Markup Language (HTML), Cascading Style Sheets (CSS), and JavaScript.

 ■ Web applications—webpages that provide discrete functionality to users. Web applications also make
use of web technologies such as HTML, CSS, and JavaScript. Dashcode helps you create mobile Safari
web applications, which are also known as iPhone web applications (that is, web applications optimized
to run in Safari on iPhone), and Safari web applications (that is, web applications optimized to run in
Safari).

Dashcode’s integrated environment allows you to lay out, code, and even test widgets and web applications
without opening any other applications. Its layout tools, composers, and editors simplify the process of
creating all the resources these projects need. Dashcode also includes handy coding and debugging tools
that help you manage and test the code you write.

Who Should Read This Document?

Read Dashcode User Guide to learn how to use Dashcode to create web applications and Dashboard widgets.
Developers who are new to either widget or web application creation learn how to build simple projects and
find out more about Dashcode’s capabilities. Experienced developers learn how to speed up development
using Dashcode.

Organization of This Document

This document contains the following chapters:

 ■ “Dashboard Widget Tutorial” (page 13) walks you through creating your first Dashboard widget with
Dashcode.

 ■ “Mobile Safari Web Application Tutorial” (page 19) shows you how to create a simple mobile Safari web
application with Dashcode.

 ■ “Dual-Product Web Application Tutorial” (page 27) shows you how to create a project that produces
both a mobile Safari web application and a Safari web application.

 ■ “Starting a Project” (page 45) discusses the different starting points when working with Dashcode.

 ■ “Designing the User Interface of a Widget or Web Application” (page 51) shows you the tools Dashcode
provides for designing the user interface of a widget or web application.

Who Should Read This Document? 9
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 ■ “Adding Source Code and Creating Bindings” (page 59) details the source code editing tools included
with Dashcode.

 ■ “Testing and Sharing” (page 71) includes information on testing, debugging, and distributing a widget
or web application.

 ■ “Advanced Topics for Widgets” (page 77) talks about localizing a widget using Dashcode and including
a widget plug-in.

Dashcode User Guide also includes these appendixes:

 ■ “Dashcode Templates” (page 79) describes the project templates included with Dashcode.

 ■ “Dashcode Parts” (page 85) includes information on Dashcode-originated elements, called parts, and
how to customize them.

Getting and Running Dashcode

Apple provides a comprehensive suite of developer tools (including Dashcode) for creating Mac OS X software
on a Mac. The Xcode tools include applications to help you design, create, debug, and optimize your software.
This tools suite also includes header files, sample code, and documentation for Apple technologies. You can
download the Xcode tools from the Apple Developer Connection (ADC) website (http://developer.apple.com).
Registration is required, but free.

After you download the Xcode tools, use the Xcode tools installer to install Dashcode on your Mac. After
installation, you’ll find Dashcode in /Developer/Applications/.

Reporting Bugs

If you encounter bugs in Apple software or documentation, you are encouraged to report them to Apple.
You can also file enhancement requests to describe features you would like to see in future revisions of a
product or document. To file bugs or enhancement requests, go to the Bug Reporting page of the ADC
website, which is at the following URL:

http://developer.apple.com/bugreporter/

You must have a valid ADC login name and password to file bugs. You can obtain a login name for free by
following the instructions found on the Bug Reporting page. To file a bug for Dashcode, use the Dashcode
component, version X.

See Also

For in-depth information on how to create web applications that work well on iPhone and iPod touch, see
SafariWebContent Guide. For guidance on how to design the user interface of such an application, see iPhone
Human Interface Guidelines for Web Applications.

10 Getting and Running Dashcode
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Read Dashboard Programming Topics for information on the technologies available to you when creating a
Dashboard widget. All of the Dashboard-specific information discussed in this document is covered in more
depth in Dashboard Reference. Additional Dashboard documents and sample code can be found on the ADC
topic page for Dashcode.

The Safari Dev Center contains useful information on WebKit, the technology that powers Dashboard widgets,
and other Safari-related topics. For more information on the HTML, CSS, and JavaScript capabilities found in
WebKit, consult:

 ■ Safari HTML Reference

 ■ Safari CSS Reference

 ■ Safari DOM Additions Reference

The XMLHttpRequest object allows you to parse XML in JavaScript and use the results. Read the ADC article
Dynamic HTML and XML: The XMLHttpRequest Object for more information.

See Also 11
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This tutorial walks you through using Dashcode to create a Dashboard widget. As you follow the steps, you
learn how to choose a widget template, customize your widget’s appearance and code, and share your
widget with others. Completing this tutorial is a quick and easy way to get started building Dashboard widgets
in Dashcode.

This document includes two additional tutorials, “Mobile Safari Web Application Tutorial” (page 19) and
“Dual-Product Web Application Tutorial” (page 27), which follow this one. The remainder of the document
delves more deeply into the Dashcode development environment, describing how it supports both widget
and web application development. If you don’t want to learn how to create a web application, you can
continue learning more about Dashcode by reading “Starting a Project” (page 45).

Before You Begin

In this tutorial, you build a Dashboard widget that counts down to your birthday, similar to the widget shown
in Figure 1-1.

Figure 1-1 The Birthday widget

Before continuing, make sure that you have Dashcode installed on your Mac (the location is
/Developer/Applications/). If you don’t have Dashcode installed, read “Getting and Running
Dashcode” (page 10) to learn how to get and install Dashcode.

Choose a Template

To start, double-click the Dashcode icon to open it. A new project window opens and displays a dialog in
which you first select the type of project you’re interested in—in this case, Dashboard—and then, the kind
of widget you want to create from an assortment of templates. Templates are handy starting points for
creating common types of widgets. Select a template’s icon to show a short description of what that template
does.

To make the Birthday widget, this tutorial uses the Countdown template. Select its icon and click Choose. A
project window opens with a new widget based on the Countdown template, as shown in Figure 1-2.

Before You Begin 13
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Figure 1-2 A project window showing a new Dashboard widget

Along the left side of the project window is the navigator, which you use to switch between the various
tools available when you’re designing a widget. The main portion of the window is the canvas, which you
use to design your widget’s interface.

At the bottom of the navigator in Figure 1-2 you can see the Workflow Steps list, which guides you through
the widget development process. Each step is a milestone in creating a widget, telling you what to do and
where to do it. When you complete a step, mark it as done and move on to the next step.

14 Choose a Template
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Note:  If you don’t want to see the Workflow Steps list, you can hide it by choosing View > Steps or by clicking
the button that looks like a checkbox at the bottom edge of the project window (this button is highlighted
in Figure 1-2).

Alternatively, you can view a list of the widget’s files in place of the Workflow Steps list. If you want to see
the Files list, choose View > Files or click the list button in the bottom edge of the project window (it’s the
button that looks like a bulleted list).

Set the Target Date

The Countdown template gives you a Dashboard widget with all the elements and code needed to count
down to an event. All you need to do is tell the widget the target date. To set the target date, select Widget
Attributes in the navigator. The canvas is replaced by the widget attributes pane, in which you specify
important values that your widget needs.

In the Properties section of the widget attributes pane, choose Date and Time in the Target Kind pop-up
menu and enter the date of your next birthday, as shown in Figure 1-3.

Figure 1-3 The Countdown template’s properties

Test the Countdown

Your new Dashboard widget is already fully functional. To prove this, choose Debug > Run to run the widget.
Dashcode can run a widget without opening it in Dashboard, making it a handy place to test your widget
and fix any problems you encounter. After the widget loads, it starts counting down towards your next
birthday.

When you’re satisfied that your widget is working as you expect, choose Debug > Stop to stop it.

Now is a good time to save your widget project. Choose File > Save to save the project. Give your project a
name and select a location to save it in. Your widget is saved in a widget project that encapsulates the widget
and information Dashcode needs to create the widget for you.

Set the Target Date 15
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Customize the Widget’s Appearance

Although you now have a fully functioning Dashboard widget that’s ready to share, you might want to
personalize it to make it unique. Dashcode’s design tools make it easy to customize your widget’s interface.
Select the widget item in the navigator (it should display the name you gave it when you saved the project).
The widget attributes pane is replaced with the canvas.

First, change your widget’s body color. Select the widget body (also called the front image or frontImg) on
the canvas and then choose Window > Show Inspector. The inspector window allows you to modify a
selected element’s properties, such as its appearance and behavior. Click the Fill & Stroke button at the top
of the inspector window (it’s the second from the left). If it’s not already selected, click the Style tab to reveal
fill, stroke, corner roundness, and opacity values. Click the color well and choose a new color in the Colors
window that appears. Try different fill styles until you find a combination that you like. If you want to try
changing other effects, such as the glass appearance, click the Effects tab to reveal these values, as shown
in Figure 1-4.

Figure 1-4 Tweaking the front image using the Fill & Stroke inspector

When you’re finished customizing your widget’s body, add a photo of yourself from iPhoto to the widget.
Your iPhoto library is available from the Library window. To show your iPhoto library, choose Window >
Show Library; then click the Photos button. Find a photo and drag it to your widget on the canvas. Resize it
by dragging any of the resize handles on the photo.

Finally, change the Event Label text to something like “...days until my birthday.“ You can do this by selecting
the Event Label text, clicking the Attributes button in the inspector window (it’s the leftmost button), and
entering the text in the Value field, or by double-clicking the text in the widget body itself and entering the
new text.

16 Customize the Widget’s Appearance
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Add Functionality Using Parts

Now that you have a personalized Dashboard widget that counts down to your birthday, add a button that,
when clicked, shows the Apple Store (so your friends and family can buy you a birthday present!). To add a
button to your widget, use a button part. Parts are controls and views used on a widget’s interface.

To find a button part, choose Window > Show Library and click Parts. You can use the search field at the
bottom of the window to help you find a particular part or type of part. From the list of parts, drag the
Lozenge Button part from the Library window to your widget’s body. Double-click the button to select its
label text, enter the text “Buy me a gift” and press Return. You'll probably need to resize the button to fit the
new label.

Write Code to Show the Apple Store

To make the button take the user to the Apple Store when it’s clicked, you need to add a behavior to the
button. In the inspector window, click the Behaviors button (it’s the rightmost button). This shows the
Behaviors pane, in which you assign handler functions to events on an object. Select the button on the canvas
and double-click in the Handlers column next to the onclick event name. Enter the name of a new function,
such as showAppleStore, and press Return. Click the arrow next to the function name you entered to reveal
the source code editor below the canvas. Here you write code to add functionality to your widget. Clicking
the arrow reveals the showAppleStore function Dashcode inserted in your widget’s code. Between the
braces ({ .. }) enter the following line of code:

widget.openURL("http://store.apple.com/");

The code in the source code editor should look like that in Figure 1-5.

Figure 1-5 A function in the source code editor

Add Functionality Using Parts 17
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Test your widget again by choosing Debug > Run. Click the button you added and make sure a new Safari
window opens with the Apple Store website displayed. Be sure you save your project often to preserve the
changes you make.

Deploy Your Widget

Congratulations! You’ve created your first complete Dashboard widget using Dashcode.

To open your widget in Dashboard, choose File > Deploy Widget. Click Install in the dialog that appears to
view your widget in Dashboard.

To share your widget with the world, select Run & Share in the navigator. The pane that appears displays the
widget project name you chose in “Test the Countdown” (page 15), but you can replace this with a different
name if you want. You can also set the minimum version of Mac OS X your widget should run in. Click Save
to Disk to save your widget. You can now email it to friends or post it on your webpage. You can use the File
> Compress command in the Finder to archive it.

18 Deploy Your Widget
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This tutorial walks you through using Dashcode to create project that produces a mobile Safari web application.
A mobile Safari web application (also known as an iPhone web application) is web content that is optimized
for Safari on iPhone and that offers users an application-like experience. As you follow the steps, you learn
how to choose a template, customize your code, and share your application with others. Completing this
tutorial is a quick and easy way to get started building mobile Safari web applications in Dashcode.

This is the second of three tutorials in this document. If you’re interested in learning how to start developing
Dashboard widgets, be sure to read “Dashboard Widget Tutorial” (page 13). If you want to learn how to
create a project that produces both a mobile Safari web application and a Safari web application, read
“Dual-Product Web Application Tutorial” (page 27). The remainder of the document, beginning with “Starting
a Project” (page 45), delves more deeply into the Dashcode development environment, describing how it
supports both widget and web application development.

Before You Begin

In this tutorial, you build a mobile Safari web application that displays information about national parks. This
project is based on the browser type of web application, and supports navigation through multiple levels of
content.

Before continuing, make sure that you have Dashcode version 3.0 or later installed on your Mac (the install
location is /Developer/Applications/). If you don’t have Dashcode installed, read “Getting and Running
Dashcode” (page 10) to learn how to get and install Dashcode.

Choose a Template

To start, double-click the Dashcode icon to open it. A new project window opens and displays a dialog that
displays two types of projects—Safari and Dashboard—and an assortment of templates for each project
type. Templates are handy starting points for creating common types of web applications and widgets. (To
find out what a template does, select it to show a short description of its capabilities.)

For this tutorial, select the Safari project type. Then, to create a browser-type web application that’s optimized
to run in Safari on iPhone:

1. Select the Browser template.

2. Click the “Develop for: Safari” checkbox to deselect it. (Make sure the “Develop for: Mobile Safari” checkbox
is still selected.)

3. Click Choose.

Before You Begin 19
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A project window opens, displaying the first page of a new mobile Safari web application based on the
Browser template, as shown in Figure 2-1.

Figure 2-1 A new mobile Safari web application project based on the Browser template

Along the left side of the project window is the navigator, which you use to switch between the various
tools available when you’re designing a web application. The main portion of the window is the canvas,
which you use to design your web application’s interface.

At the bottom of the navigator in Figure 2-1 you can see the Workflow Steps list, which guides you through
the web application development process. Each step is a milestone in creating a web application, telling you
what to do and where to do it. When you complete a step, mark it as done and move on to the next step.

20 Choose a Template
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Note:  If you don’t want to see the Workflow Steps list, you can hide it by choosing View > Steps or by clicking
the button that looks like a checkbox at the bottom edge of the project window (this button is highlighted
in Figure 2-1).

Alternatively, you can view a list of the web application’s files in place of the Workflow Steps list. If you want
to see the Files list, choose View > Files or click the list button in the bottom edge of the project window (it’s
the button that looks like a bulleted list).

Learn About the Template

The Browser template gives you a mobile Safari web application that displays some built-in information and
supports navigating from one page to the next. You don’t need to customize the application at all to see
how it works, but you should specify a title to display.

In the canvas, double-click Browser and type in a new title, such as Parks. You’ll see this title in the header
of the first page.

You should also give a name to the webpage itself. When you begin a project, this name is Untitled. To specify
a name, double-click Untitled at the top of the navigator and type the name you want, say, National Parks.

Now is also a good time to save your project. Choose File > Save to save the project. Give your project a
name and select a location to save it in. The project encapsulates the web application and all the information
Dashcode needs to create it for you.

Test the Default Product

Your new mobile Safari web application is already functional, even though it only displays placeholder data.
To prove this, click the green Run button in the Dashcode toolbar (alternatively, you can choose Debug >
Run).

Dashcode opens your web application in a simulator application.

Note:  If you've installed the iPhone SDK on your computer, Dashcode opens the mobile Safari web application
in the iPhone Simulator application provided by the SDK. If you do not have the iPhone SDK installed on
your computer, Dashcode opens the mobile Safari web application in its own simulator application.

Take a few moments to use the application. You should see Parks (or a different title you typed in) displayed
in the header of the first page and you should see National Parks (or a different title you gave the webpage)
in the title bar area, if this area is visible.

Notice that when you click a row item in the first page, a new page appears that gives details about the item.
There are a few other things you should notice about the second page:

 ■ The title of the second page is the same as the name of the row item you selected in the first page.

 ■ A back button has appeared to the left of the title and its label is Parks, which is the title of the first page.
You can click this button to return to the first page.
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 ■ The text in the middle of the second page includes the name of the row item you selected.

The two pages of your web application should look similar to those shown in Figure 2-2.

Figure 2-2 The default Browser-based mobile Safari web application contains a top-level page (left) and
a detail page (right)

Although the information about national parks is just placeholder information provided by the Browser
template, it helps you see some of the connections between the pages. You’ll learn a bit more about these
connections in the next step, “Explore the Views in the Stack Layout” (page 22).

Before you continue, quit the simulation by choosing Quit from the simulation application menu or pressing
Command-Q. Or, in Dashcode, you can click the red Stop button.

Explore the Views in the Stack Layout

A browser-style mobile Safari web application allows users to navigate from one page to the next. As you
found out when you tested it, your web application already supports the ability to select an item in the
top-level list and reveal information about it in a detail view. One of the keys to this structure is the stack
layout.

If you can’t already see it in the navigator, reveal the stack layout by clicking the disclosure triangles next to
National Parks and, below that, next to browser. When you click the disclosure triangle next to stackLayout,
you see two items: listLevel and detailLevel. In this application, the list level view contains the list of
parks, and the detail level view contains the text that describes a selected park.

You can change the way the detail page is revealed when you select a row in the top-level list. To do this,
follow these steps:
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1. Make sure the inspector is open. If it isn’t, click the blue Info button in Dashcode’s toolbar.

2. Select stackLayout in the navigator.

3. Click the Attributes toolbar item in the inspector (it’s the one on the left). This should change the
inspector’s title to Attributes (stackLayout).

At the bottom of the inspector is a section titled Subview Transition. The values in this section control the
transitions between pages. You can choose to have pages slide in from right to left (this is the default) or
other ways, such as from top to bottom. Note that you may not be able to see the effect of changing the
transition type in the simulator application, but you will see the effect when you view your application on
an actual device.

Note:  The transitions described in this step are based on CSS transitions and animations. In the stack layout
Attributes inspector, Dashcode gives you a way to specify attributes of the transitions you want to use, but
does not provide a user interface for manipulating them directly. After you complete this tutorial, you might
want to access the code for these transitions to make finer-grained adjustments. Before you do this, you
should read Safari CSS Visual Effects Guide for more information.

Add Functionality Using Parts

As you’ve seen, the mobile Safari web application you created using the Browser template is already functional
even though all its data is static. To make it more useful, you can add functionality that gets current information
from the web. In this step, you use Dashcode’s design tools to add a button to the detail page that performs
a Google search on the featured park (you’ll add the code to support this action in the next step).

To add a button to your web application, use a button part. Parts are controls and views used in a web
application’s user interface. Dashcode lists the available parts in the Library.

To find the appropriate button part, choose Window > Show Library and click Parts. Scroll through the list
of parts until you find the Push Button part, and drag this part into your detail page on the canvas.

Double-click the button on your detail page and give it a label (you can also do this by typing the label in
the Label field of the Attributes inspector for the button). You may need to resize the button to fit the label
you choose. Figure 2-3 shows the new button in the detail view, before it receives a new label.
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Figure 2-3 Adding a part to the mobile Safari web application’s user interface

Write Code to Perform a Search

To make the button perform a search on the featured park, you need to add behavior to the button. In the
Inspector, click Behaviors (it’s the rightmost button). This shows the Behaviors pane, in which you assign
handler functions to events on an object.

On the canvas, select the button you added to the detail page. In the Behaviors inspector, double-click in
the Handlers column next to the onclick event name. Enter the name of a new function, such as
detailButtonHandler, and press Return. If you don’t already see it, click the arrow next to the function
name you entered to reveal the source code editor below the canvas. Clicking the arrow reveals the
detailButtonHandler function Dashcode inserted in your web application’s code (specifically, in the
main.js file).

Between the braces ({...}), enter the following three lines of code:

var dsource = dashcode.getDataSource("list");
var name = dsource.selection().valueForKey("name");
document.location = ("http://www.google.com/search?client=googlet&q=" + name);

These lines of code do the following:

 ■ The first line of code creates a local variable named dsource, and gives it the value of the data source
named list.

In the Browser template, the list data source supplies the detail page with the static information about
the selected park.

24 Write Code to Perform a Search
2009-07-24   |   © 2009 Apple Inc. All Rights Reserved.

CHAPTER 2

Mobile Safari Web Application Tutorial



 ■ The second line of code creates a local variable named name, and gives it the value of the name property
of the currently selected park.

In a data source, each category of data is represented by a different property. In the list data source,
the name property contains the name of the selected park.

 ■ The third line of code tells the web application to display the search results for the park specified in
name.

Note:  You don’t need to understand anything about data sources or properties to complete this tutorial.
Later, you can begin learning about them in “Viewing a Project’s Data Sources and Bindings” (page 60).

After you add the code for the button’s event handler, the source code editor should look similar to Figure
2-4.

Figure 2-4 Adding code to handle the button’s click event

Test your web application again by clicking Run (or by choosing Debug > Run). In the detail page for a park,
click the button you added and make sure it displays the results of a Google search on the featured park (be
sure you’re connected to the Internet before you try this).

Deploy Your Mobile Safari Web Application

Congratulations! You’ve created your first mobile Safari web application using Dashcode.

To use your application on an iPhone or iPod touch, you need to deploy the application and make it available
on a web server. To learn how to do this, see “Deploying a Web Application” (page 75).
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This tutorial walks you through using Dashcode version 3.0 or later to create a project that produces two
products: a Safari web application and a mobile Safari web application. A Safari web application is a dedicated
part of a website that provides Safari users with interactivity and discrete functionality. A mobile Safari web
application (also known as an iPhone web application) is web content optimized for Safari on iPhone that
provides users of iOS-based devices with interactivity and discrete functionality.

As you follow the steps in this tutorial, you learn:

 ■ How to set up and work with a dual-product project

 ■ How to customize the user interface of both products

 ■ How to specify a data source

 ■ How to use bindings to automatically update each product’s user interface with data from a server

This is the third of three tutorials in this document. If you’re interested in learning how to develop a Dashboard
widget, read the first tutorial, “Dashboard Widget Tutorial” (page 13). If you want to learn how to create a
mobile Safari web application only and not a Safari web application, read the second tutorial, “Mobile Safari
Web Application Tutorial” (page 19).

Before You Begin

In this tutorial, you create a single Dashcode project that contains two products: a Safari web application
and a mobile Safari web application. A product is a set of files and resources that defines a web application
optimized to run in either Safari or Safari on iPhone.

The project you create in this tutorial is based on the browser style of web application and displays current
movie trailers available on Apple’s website. When you’re finished, the products will look similar to those
shown in Figure 3-1.

Before You Begin 27
2009-07-24   |   © 2009 Apple Inc. All Rights Reserved.

CHAPTER 3

Dual-Product Web Application Tutorial



Figure 3-1 The finished products: Safari web application (top) and mobile Safari web application (bottom)
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Important:  Although you can see current movie trailer information when you test your new products in
Dashcode, you cannot deploy such web applications unless you do additional work that is beyond the scope
of this document. This is because your web applications cannot request information from a domain other
than the one they’re running on unless you make changes to your server configuration and to your code.

Before continuing, make sure that you have Dashcode version 3.0 or later installed on your Mac (the install
location is /Developer/Applications/). If you don’t have Dashcode installed, read “Getting and Running
Dashcode” (page 10) to learn how to get and install Dashcode.

Choose a Template

To start, double-click the Dashcode icon to open it. A new project window opens and a dialog appears that
displays two types of projects—Safari and Dashboard—and an assortment of templates for each project
type. Templates are handy starting points for creating common types of web applications and widgets. (To
find out what a template does, select its icon to show a short description of its capabilities.)

For this tutorial, select the Safari project type. Then, to create a browser-type, dual-product web application
project:

1. Select the Browser template.

2. Make sure both “Develop for:” checkboxes are selected (they are selected by default).

3. Click Choose.

The dialog disappears and the project window displays the first page of a new web application based on the
Browser template, as shown in Figure 3-2.
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Figure 3-2 A new dual-product project

The main portion of the window is the canvas, which you use to design your web application’s interface.
The bar between the canvas and the toolbar is the product bar, which contains buttons you use to switch
between the products of a dual-product project. As shown in Figure 3-2 (page 30), the user interface of the
Safari web application is displayed on the canvas by default (note that the Safari button is selected). To see
the user interface of the mobile Safari web application, click the Mobile Safari button in the product bar.

Along the left side of the project window is the navigator, which you use to switch between the various
tools available when you’re designing a web application. When you switch between products in a dual-product
project, the contents of the navigator changes appropriately.

At the bottom of the navigator in Figure 3-2 you can see the Workflow Steps list, which guides you through
the development process. If you don’t want to see the Workflow Steps list, you can hide it by choosing View
> Steps or by clicking the button that looks like a box with a checkmark in it at the bottom edge of the project
window (this button is highlighted in Figure 3-2).

Alternatively, you can view a list of the current product’s data sources or code files in place of the Workflow
Steps list. If you want to see the Data Sources list, click the data source button in the bottom edge of the
project window (it’s to the left of the workflow steps button and it looks like a circle with a square inside it).
If you want to see the Files list, choose View > Files or click the list button in the bottom edge of the project
window (it’s the button to the left of the data sources button and it looks like a bulleted list).
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Save and Test the Default Web Applications

You don’t need to customize your project at all to see how the default web applications work, but it’s good
practice to save your project before you begin to make changes. Choose File > Save to save the project. Give
your project a name, such as MyMovieTrailersProject, and select a location to save it in. The project encapsulates
both web application products and the information that Dashcode needs to create them for you. If you quit
Dashcode at any time, you can double-click your saved project to reopen it.

Your new web applications are already functional, even though they display only placeholder data. To prove
this, start by testing the Safari web application:

1. Make sure the Safari button is selected in the product bar.

2. Click the green Run button in the Dashcode toolbar (alternatively, you can choose Debug > Run).

When you do this, Dashcode opens the Safari web application in a simulator application.

Take a few moments to use the web application. Notice that when you click the name of a park in the list
along the left edge of the window, the area to the right displays information about that park. The list on the
left is known as the master list, because it contains the complete list of items you can view. The right portion
of the window is known as the detail area or detail view, because it shows details about the item selected in
the master list. Figure 3-3 shows the default Safari web application running in the Dashcode simulator (the
simulator displays the saved project name, in this case MyMovieTrailersProject, in the title bar).

Figure 3-3 The default Safari web application running in the Dashcode simulator application
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After you’ve tested the Safari web application, stop the simulation and test the mobile Safari web application.
To stop the simulation, you can choose Quit from the simulation application menu, press Command-Q, or
click the red close button in the upper-left corner of the simulator window. Alternatively, in Dashcode, you
can click the red Stop button in the toolbar.

To test the mobile Safari web application:

1. Select the Mobile Safari button in the product bar.

2. Click the green Run button in the Dashcode toolbar or choose Debug > Run.

Note:  If you've installed the iPhone SDK on your computer, Dashcode opens the mobile Safari web application
in the iPhone Simulator the SDK provides. If you do not have the iPhone SDK installed on your computer,
Dashcode opens the mobile Safari web application in its own simulator application. (Dashcode always opens
a Safari web application in its own simulator application.)

As you use the mobile Safari web application, you see that the master list of parks takes up the entire first
page. When you click a park name, a new page slides in that displays details about that park.

Notice that a back button appears near the upper-left corner of the detail page and that its label is the same
as the title of the first page. You click this button to return to the previous page. The two pages of the default
mobile Safari web application should look similar to those shown in Figure 3-4.

Figure 3-4 The default mobile Safari web application running in the iPhone Simulator

Now that you’ve seen the default appearance and behavior of both of your products, it’s time to customize
them to display the movie trailer data similar to the data shown in Figure 3-1 (page 28). Before you do this,
be sure to quit the simulation of the mobile Safari web application. As you did after testing the Safari web
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application, quit the simulation by choosing Quit from the simulation application menu, pressing Command-Q,
or clicking the red close button in the upper-left corner of the simulator window. Or, in Dashcode, you can
click the red Stop button in the toolbar.

Customize the User Interface of the Safari Web Application

As you can see when you compare the finished Safari web application shown in Figure 3-1 (page 28) with
the default product shown in Figure 3-3 (page 31), there are a few differences in the detail area. Specifically,
the finished Safari web application displays the following details about the selected movie:

 ■ Title

 ■ Rating

 ■ Poster

 ■ Description

 ■ Trailer

This section shows you how to change the default user interface to resemble the user interface of the finished
product. Before you begin, make sure the Safari button is selected in the product bar.

To make enough room to display the poster of the selected movie trailer to the left of the description, you
need to move the description element to the right. Follow these steps to do this:

1. Click the word “Description” on the canvas. This displays a rectangular outline around the
detailDescription element. Look closely at this rectangle and notice the small, circular resize handles
that Dashcode displays at intervals along the perimeter.

2. Using the resize handle on the left edge of the outlined detailDescription element, drag to the right
until the word “Description” is centered horizontally in the detail area on the canvas.

Now you need to add two new parts to the canvas. If the Library isn’t open already, open it by clicking the
Library button in the Dashcode toolbar or by choosing Window > Show Library. Click the Parts tab in the
Library window to see the Dashcode parts you can use.

You need to add the Image part to display the selected movie’s poster in your web application. To find the
Image part, you can scroll through the list of parts in the Library until you find it or you can type image in
the search field at the bottom of the Library window.

Drag the Image part onto the canvas and place it to the left of the description element you moved earlier.
Use the resize handles on the perimeter of the image to adjust its size until you think it looks good.

Before you can align the top edge of the image with the top edge of the description, you need to change
the way Dashcode displays the Image part in relation to the other parts on the canvas. To do this, follow
these steps:

1. If the inspector isn’t open already, click the blue Info button in the Dashcode toolbar, or choose Window
> Show Inspector. Open the Metrics inspector by clicking the button that looks like a ruler in the inspector’s
toolbar.

2. Select the Image part on the canvas. The title of the inspector changes to “Metrics (image).”
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3. In the Layout section of the Metrics inspector, choose Absolute from the pop-up menu.

After you’ve done this, you can move the Image part so that its top edge aligns with the top edge of the
description element. To do this, drag from the center of the Image part (don’t use the resize handles).

Go back to the Library and find the Video part. This part displays the selected movie’s trailer and includes
playback controls. Drag the Video part onto the bottom half of the canvas, into the area below the Image
part you added and below the word “Description.” Using its resize handles, adjust the size of the Video part
until you think it fits well in the lower half of the canvas.

In the navigator, make sure both the image and the video elements that you added are inside the detailBox
element. To do this, follow these steps:

1. In the navigator, slowly drag the image element straight upwards until the detailBox element is
highlighted and a blue line appears below the detailDescription element, as shown in Figure 3-5.

Figure 3-5 In the navigator, drag the image element into the detailBox element

2. Release the mouse button. In the navigator, the image element is now directly below the
detailDescription element.

3. Similarly, slowly drag the video element straight upwards until the detailBox element is highlighted
and a blue line appears below the image element.

4. Release the mouse button. In the navigator, the video element is now directly below the image element.

After you’ve placed the new parts appropriately, the project window should look similar to the project window
shown in Figure 3-6. (Note the placement of the image and video elements in the navigator.)
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Figure 3-6 The canvas of the Safari web application after the new parts are added

You do not need to add any more parts to your web application, so you might want to close the Library
window. However, you’ll need to open it again when you customize the user interface of the mobile Safari
web application.

Specify a Data Source and Examine the Data Model

Now that you’ve completed the user interface of the Safari web application, it’s time to specify a data source
that supplies actual data in place of the default placeholder data the template provides.

As described in “Before You Begin” (page 27), your finished products display movie-trailer information from
Apple’s website. To make this happen, you need to give Dashcode the correct URL. To do this, follow these
steps:

1. Show the Data Sources list in the navigator. To do this, click the data sources button in the lower-left
corner of the project window (it’s the one that looks like a circle with a square inside it). After you do
this, you should see two data sources in the Data Sources list, one named dataSource and one named
itemsList.

2. Select dataSource in the Data Sources list. This reveals a view below the canvas, which contains the
layout of data in the data source. This layout is called the data model.

3. Paste the following URL into the URL field at the top of the data model view:
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http://www.apple.com/trailers/home/xml/current.xml

4. Click the Reload button to the right of the URL field or press Return.

If you’ve entered the URL correctly, Dashcode refreshes the data model view to display the layout of the new
data source and some current movie-trailer data from Apple’s website.

Take some time to look at the data model. Notice that it is a hierarchy with each member, called a property,
displayed on a separate line. A property that contains other properties has a disclosure triangle to the left of
it.

The data model also displays bindings and binding controls. As you can see in Figure 3-7, a gray capsule that
contains the text itemsList.dataArray is displayed to the right of the top-level content property. This
capsule represents a completed binding that Dashcode provides by default in the Browser template. This
binding means that the itemsList element on the canvas can get its information from the content property
in the data source.

Figure 3-7 Completed bindings and binding controls are visible in the data model

If a property in the data model does not already have a binding, moving the mouse pointer over the property
reveals a circular binding control to the right of the property. For example, in Figure 3-7 you can see a binding
control revealed next to the poster property.

36 Specify a Data Source and Examine the Data Model
2009-07-24   |   © 2009 Apple Inc. All Rights Reserved.

CHAPTER 3

Dual-Product Web Application Tutorial



Because the data source you’ve specified is available to both products your project creates, you do not have
to perform the steps in this section again when you switch to the mobile Safari product. However, you must
create a separate set of bindings in each product. This is because bindings connect properties in the data
source with elements in the user interface, and each product can have a different set of elements in its user
interface.

Create Bindings for the Safari Web Application

Note:  Although the bindings you create in this section do not apply to the mobile Safari web application,
the actions you take to create them are the same.

As mentioned in “Specify a Data Source and Examine the Data Model” (page 35), there is already a binding
in the data model view of the data source named dataSource. In this tutorial, you do not change this existing
binding between the content property and the itemsList element, but you do create a few new bindings.

Create the First Binding

The first binding you create identifies which data source property should supply the movie titles to display
in the web application’s master list. To do this, make sure you can still see the data model for dataSource
and that the disclosure triangle next to the content property is pointing down (you should see something
similar to the data model shown in Figure 3-7 (page 36)). Then, follow these steps:

1. If it’s not already pointing down, click the disclosure triangle next to the movieinfo property to open
it. Then, click the disclosure triangle next to the info property (it’s inside the movieinfo property).

2. Press and hold the mouse button on the binding control next to the title property (it’s the first property
inside the info property).

3. Without releasing the mouse button, drag from the binding control to the item title element on the
canvas (it’s the first occurrence of the word “Title” in the master list on the canvas).
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When you do this, you should see a blue connection line extend from the binding control to the item
title element and a little gray box that contains the element’s name, itemTitle, as shown in Figure 3-8.

Figure 3-8 Dashcode displays a blue connection line between a data source property and an element
on the canvas

4. Release the mouse button while the item title element is highlighted. Immediately, Dashcode displays
a contextual menu that lists the bindable properties for this element.

In this case, you should see a contextual menu that contains: text, editable, visible, enabled, html, and
class.

5. In this contextual menu, choose text.

Note that if you click outside the contextual menu, the binding does not complete and you must start
over from step 2.

After you finish these steps, you should see a new gray capsule in the data model. This capsule should be
next to the title property and should contain the text itemTitle.text.
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Note:  If you see different text inside the gray capsule next to the title property, erase the binding (by
clicking the delete control inside the left end of the capsule) and try the steps again. (The delete control looks
like an X.)

You can be sure that you’re binding to the correct element when you see the element’s name in the little
gray box that Dashcode displays as you drag over the canvas.

Create the Remaining Bindings

Now you need to create bindings to parts in the detail area of your Safari web application. Even though these
new bindings are between different data source properties and parts, the actions you take to create each
one are very similar to the actions described in steps 2 through 5 in “Create the First Binding” (page 37).

The new bindings you need to create are from properties in the itemsList data source. To reveal the data
model for this data source, click itemsList in the Data Sources list.

The four new bindings you need to create are described below. You do not have to create these bindings in
the order given, but you must create each one using the precise properties and elements described. Before
you begin, make sure the disclosure triangle next to the selection property is pointing down, because all
the properties you need to use are inside this property.

1. Bind the title of the selected movie to the title in the detail header.

a. In the data model, find the title property inside the info property.

b. Drag from the title property’s binding control to the detailTitle element on the canvas. (On
the canvas, the detailTitle element displays the word “Title” in a large font, and appears above
the word “Location.”)

c. Choose text from the contextual menu that appears when you release the mouse button.

2. Bind the description of the selected movie to the description that appears above the video.

a. In the data model, find the description property inside the info property.

b. Drag from the description property’s binding control to the detailDescription element on
the canvas. (The detailDescription element is the one you moved to the right to make room
for the Image part in “Customize the User Interface of the Safari Web Application” (page 33)).

c. Choose text from the contextual menu that appears when you release the mouse button.

3. Bind the poster of the selected movie to the Image part.

a. In the data model, find the xlarge property inside the poster property.

b. Drag from the xlarge property’s binding control to the image element on the canvas (this is the
Image part you added in “Customize the User Interface of the Safari Web Application” (page 33)).

c. Choose src from the contextual menu that appears when you release the mouse button.

4. Bind the trailer of the selected movie to the Video part.

Create Bindings for the Safari Web Application 39
2009-07-24   |   © 2009 Apple Inc. All Rights Reserved.

CHAPTER 3

Dual-Product Web Application Tutorial



a. In the data model, find the large property inside the preview property.

b. Drag from the large property’s binding control to the video element on the canvas (this is the
Video part you added in “Customize the User Interface of the Safari Web Application” (page 33))

c. Choose src from the contextual menu that appears when you release the mouse button.

After you’ve finished creating these bindings, you’ve completed all the steps necessary to produce a Safari
web application that looks similar to the one shown in Figure 3-1 (page 28).

Test the Safari Web Application

If you haven’t saved your project recently, save it now. Make sure the Safari button is still selected in the
product bar and click Run to test your product. If this is the first time you’ve run your web application since
you specified Apple’s website for the dataSource data source in “Specify a Data Source and Examine the
Data Model” (page 35), Dashcode displays a dialog that asks you if you want to simulate running on the
domain that hosts that website. Click Simulate in this dialog so you can see the data from the website.

You should see something similar to the Safari web application shown in Figure 3-1 (page 28). Note that
you will probably see a different list of movies, depending on which movie trailers are available.

Scroll the master list and select a movie title. Click the Video part’s playback control to see the trailer for the
movie you selected.

Customize the User Interface of the Mobile Safari Web Application

Now that your Safari web application is in good shape, it’s time to turn your attention to your mobile Safari
web application. Although you don’t need to make any changes to the master list displayed on the first page,
you do want to display the poster for the selected movie on the detail page, as shown in Figure 3-1 (page
28). Before you begin, be sure to select the Mobile Safari button in the product bar.

To show the detail page on the canvas, click detailLevel in the navigator. If you don’t see detailLevel
listed in the navigator, open the disclosure triangles next to browser and next to stackLayout to reveal
it.

As you did with the Safari web application, you need to add the Image part to your page. If the Library is not
already open, open it by clicking the Library button in the Dashcode toolbar or choose Window > Show
Library. Click the Parts tab in the Library window to see the available parts. Find the Image part by scrolling
through the list of parts or by typing image in the search field at the bottom of the Library window.

Place the Image part inside the white box on the detail page, below the title, location, and description
elements. To do this, drag the Image part onto the canvas and, without releasing the mouse button, drag it
towards the bottom edge of the white box until the title, location, and description elements jump above the
Image part. If you happen to release the mouse button before you finish placing the Image part, delete the
Image part, drag in a new one, and try again.
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Adjust the size of the Image part by using its resize handles until you think it fits well into the space inside
the white box. After you do this, your project window should look something like the project window shown
in Figure 3-9:

Figure 3-9 The canvas of the mobile Safari web application after the Image part is added to the detail
page

Create Bindings for the Mobile Safari Web Application

Note:  The bindings you created for your Safari web application do not apply to your mobile Safari web
application, so you must follow the steps in this section to create separate bindings for it. However, the data
source you specified in “Specify a Data Source and Examine the Data Model” (page 35) is available to both
products, so you do not have to specify it again.

In this section, you’ll create five bindings: one to an element on the master list page and four to elements
on the detail page. Before you begin, make sure the Mobile Safari button is selected in the product bar.
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Create a Binding to an Element on the Master List Page

The first binding you create identifies which data source property should supply the movie titles to your web
application’s master list. (If you don’t remember the meaning of terms such as data source and property, see
“Specify a Data Source and Examine the Data Model” (page 35).) To show the master list on the canvas, click
the listLevel element in the navigator. If you don’t see listLevel listed in the navigator, open the
disclosure triangles next to browser and stackLayout.

If the Data Sources list isn’t already visible in the navigator, show it by clicking the data sources button in
the lower-left corner of the project window (it’s the one that looks like a circle with a square inside it). Select
dataSource in the Data Sources list to reveal its data model. Notice that the URL you entered for your Safari
web application is already in the URL field.

To bind the movie titles to the master list’s row titles, open the disclosure triangle next to the content
property and do the following:

1. In the data model, find the title property inside the info property.

2. Drag from the title property’s binding control to the rowTitle element on the canvas. (The rowTitle
element contains the first occurrence of the word “Item” in the list.)

3. Choose text from the contextual menu that appears when you release the mouse button.

Create Four Bindings to Elements on the Detail Page

Now create the four bindings you need on the detail page. In the navigator, select the detailLevel element
to show the detail page on the canvas. In the Data Sources list, select the list data source to reveal its data
model. In the data model, make sure the disclosure triangle next to the selection property is pointing
down, because all the properties you need to use are inside this property.

1. Bind the title of the selected movie to the title in the white box.

a. In the data model, find the title property inside the info property.

b. Drag from the title property’s binding control to the detailTitle element on the canvas. (The
detailTitle element contains the word “Title” on the canvas.)

c. Choose text from the contextual menu that appears when you release the mouse button.

2. Bind the rating of the selected movie to the subtitle in the white box.

a. In the data model, find the rating property inside the info property.

b. Drag from the rating property’s binding control to the detailSubtitle element on the canvas.
(The detailSubtitle element contains the word “Location” on the canvas.)

c. Choose text from the contextual menu that appears when you release the mouse button.

3. Bind the description of the selected movie to the description in the white box.

a. In the data model, find the description property inside the info property.
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b. Drag from the description property’s binding control to the detailDescription element on
the canvas. (The detailDescription element contains the word “Description" on the canvas.)

c. Choose text from the contextual menu that appears when you release the mouse button.

4. Bind the poster of the selected movie to the Image part.

a. In the data model, find the xlarge property inside the poster property.

b. Drag from the xlarge property’s binding control to the image element on the canvas (this is the
Image part that you added in “Customize the User Interface of the Mobile Safari Web
Application” (page 40)).

c. Choose src from the contextual menu that appears when you release the mouse button.

After you’ve finished creating these bindings, you’ve completed all the steps necessary to produce a mobile
Safari web application that looks similar to the one shown in Figure 3-1 (page 28).

Test the Mobile Safari Web Application

If you haven’t saved your project recently, save it now. Make sure the Mobile Safari button is still selected in
the product bar and click Run to test your product. You do not see the dialog that asks you if you want to
simulate running on the www.apple.com domain, because Dashcode continues to simulate running on the
remote domain you specify until you change it.

On the first page you should see a long list of current movie titles. Click a title and you should see the rating,
description, and poster for that movie.

Next Steps

Congratulations! You’ve learned how to use Dashcode to create a dual-product project that produces two
web application products.

To learn about deploying your products, see “Deploying a Web Application” (page 75).
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When you start a new project, you base it on a Dashcode template or, in the case of Dashboard widgets, you
can also base it on an existing widget. A project encapsulates all the files and resources that Dashcode uses
to build a widget or web application for you.

This chapter discusses the options you have when you start a project. It also discusses opening a Dashboard
widget in Dashcode, a feature that allows you to forgo Dashcode’s design tools to code, test, and debug an
existing widget.

Creating a Project from a Template

Dashcode creates new projects based on templates. Templates are preconfigured widgets or web applications
that include code and graphics that perform common tasks. When you open Dashcode or choose File > New
Project after you open it, a dialog appears that offers you a choice of project types. When you choose one
of these, the dialog offers you a choice of templates appropriate for the project type. Click a template icon
to see a short description of the template’s abilities. If the template matches the task you’re trying to perform,
select its icon and click Choose. For more on the templates included with Dashcode, read “Dashcode
Templates” (page 79).

In Dashcode version 3.0 and later, you can choose to create a Safari web application or a mobile Safari web
application or both. By default, Dashcode creates a single project that produces both products. This allows
you to use the same data and much of the same code, but design a different user interface for each product.
If you want to create only one type of web application in a project, make sure you deselect the “Develop
for:” checkbox for the type of product that you don’t want to develop. The “Develop for:” checkboxes appear
between the template icons and their descriptions.

After you choose a template, you may need to provide required values for the widget or web application to
work properly. For widgets in particular, make sure to provide the Identity and Properties values, as discussed
in “Providing Attributes for a Dashboard Widget” (page 46).

Creating a Project from an Existing Dashboard Widget

Dashcode can create a new project from an existing widget. If you want to continue work on an existing
widget in Dashcode, you should import it. Importing a widget copies it into a new widget project and enables
the code generator. When the code generator is active, all of Dashcode’s design and management tools are
enabled.

To import a widget, choose File > Import Widget or choose Import from the template chooser dialog.
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Note:  If your widget uses objects created at runtime (such as those created from an Apple Button or an
Apple Scroll Area, both Apple classes that Apple provides widget developers), they do not appear on the
canvas since their constructors are not executed when the widget is shown.

Once you import your widget into a Dashcode project, use the widget attributes pane, as discussed in
“Providing Attributes for a Dashboard Widget” (page 46), to edit your widget’s Identity values.

Providing Attributes for a Dashboard Widget

Each widget project has required values you need to provide for the widget to work properly. You set these
values in the widget attributes pane, available when you select Widget Attributes in the navigator. Make
sure to provide values in the following sections of the editor, if available:

Identity
The values in this section are used to identify a widget.

You need to provide a widget identifier, used by Dashboard to differentiate your widget from others.
Widget identifiers are commonly formatted in reverse domain notation, starting with a top-level
domain (such as com), followed by a company or creator name (such as apple), and then a unique
product name (such as my-fabulous-widget, yielding a name such as
com.apple.my-fabulous-widget).

Additionally, you need to provide a unique version number. This number is used by Dashboard to
differentiate between versions of a widget, so that it’s always running the most recent version.

Note:  The widget identifier and version fields correspond to the CFBundleIdentifier and
CFBundleVersion information property list values, as discussed in Dashboard Info.plist Keys.

Properties
Template-specific options are in this section. If you’re using an imported or opened widget or the
Custom template, this section is absent. For each template’s specific properties, read “Dashcode
Templates” (page 79).

Providing Attributes for a Web Application

Each web application project has values you need to provide for the products to work properly. You set these
values in the application attributes pane, available when you select Application Attributes in the navigator.
Although only the page title is required, it’s a good idea to set the other values so your web application
behaves as you intend.

Some templates include a Properties section in the application attributes pane, in which you set
template-specific options. For more information about the options you can set for a template, see the template
descriptions in “Web Application Templates” (page 82).

In Dashcode version 3.0 and later, some application attributes are different, depending on whether you’re
developing a Safari web application or a mobile Safari web application. If you’re developing both types of
web application, you see a product bar below the toolbar that contains a Safari button and a Mobile Safari

46 Providing Attributes for a Dashboard Widget
2009-07-24   |   © 2009 Apple Inc. All Rights Reserved.

CHAPTER 4

Starting a Project



button. Click these buttons to switch between the attributes you need to set for each product. If you’re
developing only one type of web application (or if you’re using an earlier version of Dashcode to develop a
mobile Safari web application), you do not need to switch between attributes for different products, so you
do not see the product bar.

Application Attributes for Safari Web Applications

To set the application attributes for the Safari web application product of your dual-product project in
Dashcode version 3.0 and later, be sure to select the Safari button in the product bar. If you’re using Dashcode
version 3.0 and later to develop a Safari web application only, you do not need to do this. If you’re using an
earlier version of Dashcode to develop a mobile Safari web application, see “Application Attributes for Mobile
Safari Web Applications” (page 47) for information about the attributes you can set.

Provide values in the following section of the application attributes pane:

General
The Page Title value in this section is used to identify the Safari web application. In the Page Title
field, title your web application by giving it an appropriate, human-readable name. The title you
supply is the <title> element in your webpage and is displayed in the title bar of the browser.

The Offline Viewing value in this section controls whether users can still use your web application if
they lose their network connection. If you select this checkbox, be sure to read “Supporting Offline
Usage of a Web Application” (page 65) to find out what you need to do to handle offline viewing of
your web application.

Application Attributes for Mobile Safari Web Applications

To set application attributes for the mobile Safari web application product of your dual-product project in
Dashcode version 3.0 and later, be sure to select the Mobile Safari button in the product bar. If you’re using
Dashcode version 3.0 and later to develop a mobile Safari web application only (or if you’re using an earlier
version of Dashcode), you do not need to do this.

Provide values in the following sections of the application attributes pane, if available:

General
The Page Title value in this section is used to identify the mobile Safari web application. In the Page
Title field, title your web application by giving it an appropriate, human-readable name. The title you
supply is the <title> element in your webpage and is displayed in the title bar of Safari on iPhone.

Viewport
The values in this section control how users can view your mobile Safari web application when they
use it on iPhone or iPod touch. When users change the device orientation from portrait to landscape,
webpages can get scaled to fit the new screen orientation.

The two options for the Orientation value are:

 ■ “Adjust page width to fit.” When you choose this option, your web application resizes (that is,
increases or decreases in width) when the device orientation changes. This option is generally
recommended for mobile Safari web applications, because it enhances the user’s perception of
the web application as a standalone application and not a webpage.
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 ■ "Zoom page to fit.” When you choose this option, the width of your mobile Safari web application
does not change when the device orientation changes, but the scale does. In other words, the
content of your web application will appear a bit bigger. You might want to choose this option
if your web application has a complicated layout that you don’t want to change in width when
the device orientation changes.

The Page Zooming value in this section controls whether users can zoom your web application when
they view it on iPhone or iPod touch. In general, because you want iPhone and iPod touch users to
view your web application as a standalone application and not as a webpage, it’s recommended that
you turn off Page Zooming (that is, deselect “Allow users to adjust page zoom”).

Web Clip
The values in this section control how your web application can be displayed on iPhone and iPod
touch and how your Web Clip icon is created and displayed.

In iOS 2.0 and later you can choose to make your mobile Safari web application available in a full-screen
mode, which hides the Safari toolbar and navigation bar. If you want to do this, you must also provide
a Web Clip icon, because tapping a Web Clip icon is the only way users can open a web application
in full-screen mode (navigating to the application in Safari on iPhone does not open it in full-screen
mode). If you choose not to support full-screen mode, you should still consider providing a Web Clip
icon so users have a convenient way to open your web application.

To make your mobile Safari web application available in full-screen mode, select the “Show as full
screen application (hide Safari toolbar and navigation bar)” checkbox. This allows users to open your
web application in full-screen mode when they tap the Web Clip icon. Note that users press the Home
button to leave a web application that is running in full-screen mode.

If you selected the “Show as full screen application (hide Safari toolbar and navigation bar)” checkbox,
you can also specify one of the following three styles for the status bar:

 ■ Gray

 ■ Black

 ■ Black (Translucent)

Use the pop-up menu to choose the status bar style that best coordinates with the appearance of
your web application. You can specify a status bar style only if you selected the “Show as full screen
application (hide Safari toolbar and navigation bar)” checkbox. This is because the status bar appearance
automatically matches the appearance of the Safari navigation bar when it is visible.

The two options for the Icon value are:

 ■ "Use custom icon.” Choose this option if you want to design your own Web Clip icon to represent
your mobile Safari web application. See “Designing a Web Clip Icon for an iPhone Web
Application” (page 56) for more information on how to do this.

If you choose this option, you can also specify whether you want the shiny glass overlay effect
to be added automatically by selecting the “Add glass visual effect” checkbox. Note that you do
not have control over a Web Clip icon’s rounded corners and drop shadow; these are always
added automatically.

 ■ "Use Safari generated icon.” Choose this option if you want to allow users to create their own
Web Clip icon to represent your mobile Safari web application.
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Opening an Existing Dashboard Widget

If you want to forgo Dashcode’s project management and design tools, you can open an existing widget in
Dashcode without importing it into a new project. When Dashcode opens a widget, you have access to its
code and all of Dashcode’s debugging tools, but not its design tools.

To open a widget in Dashcode, choose File > Open and select a widget in the Open dialog, or choose File >
New Project and click the Open Existing button at the bottom of the template chooser dialog. When you
open a widget with Dashcode, the canvas is locked. This means that Dashcode’s design tools, responsible
for generating HTML, CSS, and images for a widget, are turned off. When you open an existing widget instead
of importing it into a new project, Dashcode displays a lock over the bottom of the canvas.
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After you’ve started a project as discussed in “Starting a Project” (page 45), use Dashcode’s design tools to
design the interface of the widget or web application. This chapter describes the canvas, the interface design
area in Dashcode, and how to begin laying out an interface. It also discusses how to add Dashcode parts to
your project and how to use the inspector window to adjust the appearance or behavior of a part.

Read this chapter to learn how to use Dashcode’s design tools to create, modify, and preview the appearance
of your widget or web application.

Laying Out the Interface

Dashcode includes a workspace where you lay out the elements that comprise the user interface of a web
application or a widget. This workspace, called the canvas, is visible in the main portion of the project window
when you select your widget or web application in the navigator. You can freely move and resize any element
in an interface when the canvas is visible. To move an element, drag it to where you want it to be. To resize
an element, drag one of its resize handles. If you hold down the Shift key while resizing an element, the
original proportions are maintained.

Dashcode also provides commands you can use to arrange and align elements in a widget or web application
interface. For more on how to do this, see “Arranging and Locking Elements” (page 53).

You can drag any item from the Finder to the canvas to add it to a your widget or web application. This
means that you can design the user interface in an application such as Adobe Illustrator or Photoshop, save
the images, and drag them into your Dashcode project from the Finder. Dashcode, however, offers its own
design elements. Learn about them in “Adding Parts to an Interface” (page 51).

Showing a Widget’s Sides

By default, all new widgets created from a Dashcode template have two sides: a front and a back. The canvas
shows you only one of these sides at a time. To switch between the sides, click front or back in the navigator.
(If you don’t see front and back in the navigator, click the disclosure triangle next to the widget’s name.)

When a side is visible on the canvas, you can add and arrange elements on it. To work on the other side, click
the corresponding name in the navigator.

Adding Parts to an Interface

Dashcode includes a set of controls, shapes, and views called parts. Choose Window > Show Library and
click the Parts button to see the parts included with Dashcode.
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Some parts are appropriate only for specific products. The Library displays only those parts that can be used
in the product that is selected in the currently active project. For example, in Dashcode 3.0, you see a different
set of parts when you switch between the Safari and mobile Safari products of your dual-product web
application project. Similarly, the Library shows a different set of parts when you switch between a web
application project and a widget project.

To add a part to a widget’s or web application’s interface, drag it from the Parts Library to the widget body
or web application page on the canvas. Once a part is on the canvas, you can change its properties, as
discussed in “Changing an Element’s Properties” (page 52). If you want to know more about laying out parts
in your project’s user interface, read “Arranging and Locking Elements” (page 53).

A number of Dashcode parts can be manipulated programmatically. Read “Dashcode Parts” (page 85) to
learn more about using these parts.

Using Photos from iPhoto

You can drag any photo in your iPhoto library to the canvas to include it in a widget or web application. To
show your iPhoto library, choose Window > Show Library and click the Photos button. Once the photo is on
the canvas, you can arrange it as described in “Arranging and Locking Elements” (page 53) and adjust its
properties as discussed in “Changing an Element’s Properties” (page 52).

Note:  The iPhoto library requires iPhoto 6 or later.

Changing an Element’s Properties

The inspector window reveals information about the selected element on the canvas. In this window, you
can view and edit the element’s properties based on the inspector type you choose. Choose an inspector by
clicking its button at the top of the window. The inspector window includes the following inspectors, from
left to right:

 ■ The Attributes inspector allows you to modify the selected element’s ID (used in JavaScript to reference
the element), its CSS class, whether it’s shown in the widget or web application and in the default image,
and any parameters that are unique to the element.

 ■ If it’s appropriate for the selected element, the Fill & Stroke inspector allows you to adjust its style and
add effects. Style adjustments you can make include:

 ❏ Fill, such as solid, gradient, or image

 ❏ Corner roundness, opacity, and reflection

 ❏ Stroke color and width

Effects you can add include:

 ❏ Glass, including control over shine, tone, horizon, and curvature

 ❏ Recess, including control over depth, shadow, and highlights
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 ■ The Metrics inspector allows you to modify the selected element’s size and position, as well as its behavior
if the widget or webpage is resized. The Layout pop-up menu allows you to select whether the element
should be positioned using absolute or document-flow positioning (learn about these positioning styles
in “Absolute versus Document-Flow Positioning” (page 54)). The Autoresize settings affect how an
element behaves when the widget or webpage is resized on the canvas. Note that the values in the Size
section reflect the actual dimensions of the selected element, including borders.

 ■ If the selected element displays text, you can adjust the text’s font, style, color, size, shadow, alignment,
and spacing in the Text inspector. You can also set whether text wraps or not and how to handle text
overflow. Setting the text overflow to Clip cuts any string in the selected element at its bounds, allowing
for no overflow, whereas setting the text overflow to Ellipsis appends an ellipsis character (…) to the
selected element’s text when it reaches the element’s bounds.

Note:  If you plan to share a widget or deploy a web application, be careful to use fonts that are standard
in Mac OS X, such as Helvetica Neue, Times, and Monaco.

 ■ The Bindings inspector allows you to set and adjust bindings between a data source and specific properties
of the selected element. For each bindable property of the element, you can specify the data source to
bind to, the key path of the item in the data source, a value transformer, and placeholder values. (To
learn about value transformers, see “Adding a Value Transformer” (page 64).)

You do not have to use the Bindings inspector to create bindings. Instead, you can drag connections
from items in the data model view to elements on the canvas or listed in the navigator. (To learn how
to show the data model view, see “Viewing a Project’s Data Sources and Bindings” (page 60); to learn
how to create bindings, see “Creating Bindings” (page 63).) However, you must use the Bindings inspector
to specify a value transformer or supply placeholder values.

 ■ The Behaviors inspector allows you to assign to the selected element JavaScript handlers for various
events. For each event, you can assign an existing JavaScript function as its handler or create an empty
function that’s automatically added to the project’s JavaScript code. After you assign a handler to an
event, click the arrow next to the handler’s name to reveal the function in the source code editor.

Working with code is discussed in “Adding Source Code and Creating Bindings” (page 59).

Arranging and Locking Elements

Dashcode offers helpful options for arranging elements on the canvas. If an element is obscured by other
elements, select it and choose Arrange > Bring Forward or Arrange > Bring to Front to move it in front of
any elements currently obscuring it. Similarly, if you want to move an element behind another, select it and
choose Arrange > Send Backward or Arrange > Send to Back.

Dashcode offers alignment and distribution options for arranging multiple elements with respect to each
other. If you want to align a few items on their left edges, you select them on the canvas and choose Arrange
> Align > Left. Similar options are available to align elements by center, right, top, middle, and bottom. If
you want an equal amount of vertical space between multiple elements, choose Arrange > Distribute >
Vertically. A similar option exists to distribute elements horizontally.

If you want to lock an element so that you can no longer move it, select the element and choose Arrange >
Lock. If you change your mind and want to move it again, select it and choose Arrange > Unlock. Note that
locking an element only locks its placement on the canvas—you can still adjust its attributes in the inspector.
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Absolute versus Document-Flow Positioning

Dashcode allows you to position elements in your widget or web application using either absolute or
document-flow (that is, relative) positioning. You can change the positioning of a selected element by
switching between Absolute and Document Flow in the Layout section of the Metrics inspector.

Briefly, absolute positioning means that an element’s position within its containing element is always the
same, regardless of the positions of its sibling elements. In other words, an absolutely positioned element
retains its position within the containing element, even if the sibling elements around it expand or shrink.
Absolute positioning allows you to have precise control over complicated layouts, but does not support
dynamic resizing very well.

In contrast, document-flow positioning means that an element’s position is defined in terms of the positions
of its document-flow sibling elements. In document-flow positioning sibling elements are displayed in order,
vertically, so the position of an individual element depends on its location in the series of elements. If one
element expands downward, it pushes down all the sibling elements that come after it by the same amount,
without changing their sizes or their relative positions. Although document-flow positioning provides great
flexibility to support dynamic resizing, it does not give you fine-grained control over layouts.

Because widgets tend to stay the same size (or switch among a small number of predefined sizes), Dashcode
widget projects use absolute positioning by default. Conversely, because web applications need more
flexibility in sizing, Dashcode web application projects use document-flow positioning for most elements by
default.

The default positioning style used in a project does not mean that there are no variations, however. In the
Browser template web application project, for example, the elements in the list row (the row title and the
row arrow) are absolutely positioned to ensure a consistent layout.

When you customize a project, you should be aware of the positioning style of the element you’re changing.
This is because dragging a part into an existing container element on the canvas causes the part to adopt
the prevailing positioning style of its new siblings. If you want the new part to adopt the alternate positioning
style, hold down the Shift key while you drag the part onto the canvas.

Searching for Elements

Use the search field in the toolbar to find elements in your project’s interface and code. This particular type
of search works when you’re designing and coding a widget or web application. When Dashcode is running
a widget, the toolbar’s search field narrows results from either the run log or the Stackframe & Variables table,
depending on which is visible. This is discussed further in “The Run Log and Tracing Execution” (page 73)
and “Checking Values in Memory” (page 74).

To search for an element, type part of the element’s name in the search field. When the search results are
returned, the navigator is replaced with search results. Selecting an item in the search results either highlights
it on the canvas or shows the source code file that contains the implementation of the element.
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Rulers and Guides

By default, the canvas displays rulers along its top and left sides. Rulers, when used with guides, help you
align elements relative to one another. To add a guide, position the pointer anywhere in a ruler and drag
towards the canvas. As you drag away from the ruler, a guide appears—it remains wherever you stop dragging.
To remove a guide, drag it back to a ruler. To hide the rulers, choose View > Hide Rulers.

Placing a Widget’s Close Box

Users click a widget’s close box to close it (web applications do not have a close box). By default, a widget’s
close box appears over the top left of a widget’s body. If necessary, move the close box so that it overlaps
the top left corner of your widget’s body. To hide the close box on the canvas, choose View > Hide Invisible
Items.

Disabling the Canvas

Because the canvas generates HTML and CSS automatically for you, you may want to turn its code generation
off if you’re tweaking elements by hand. To turn off the automatic code generator, choose View > Stop Code
Generator. When you’re finished tweaking values by hand, you can turn the code generator back on by
choosing View > Start Code Generator.

Previewing a Widget’s Default Image

The default image preview shows you a widget’s default image, which is displayed while it loads in Dashboard.
To see your widget’s default image, select Default Image in the navigator.

By default, all the elements on the front of a widget except the text parts (Text, Text area, and Text field) are
included in a widget’s default image. Other parts that display text, such as pop-up menus, are also included.
You are discouraged from leaving text in your widget’s default image because any text on your interface
may change when the widget is localized. Therefore, you should remove parts that display text from your
widget’s default image. To remove any element from your widget’s default image, follow these steps:

1. Select the widget item in the navigator to show the canvas.

2. Select the element on the canvas that you want removed from the default image.

3. Show the Attributes inspector (as discussed in “Changing an Element’s Properties” (page 52)).

4. Deselect Show in Default Image.

The toolbar below the default image preview offers additional configuration options for default images:

Rulers and Guides 55
2009-07-24   |   © 2009 Apple Inc. All Rights Reserved.

CHAPTER 5

Designing the User Interface of a Widget or Web Application



Start Sync / Stop Sync
By default, Dashcode updates a widget’s default image whenever the widget’s interface changes. To
turn this behavior off, click Stop Sync. To enable this behavior if it’s been turned off, click Start Sync.

Import
If you already have an image that you want to use as a widget’s default image, click the Import button
and select it in the dialog that appears.

Open in External Editor
If you want to tweak your default image in an application other than Dashcode, click the Open in
External Editor button. When you do, the default image as shown in Dashcode is opened in your
default PNG-handling application.

Designing a Widget Icon

You can use the widget icon editor to design a widget’s icon. The widget icon represents a widget in the
Dashboard widget bar and in the widget manager. To show the widget icon editor, select Widget Icon in the
navigator.

To modify the appearance of the body of the widget icon, show the Fill & Stroke inspector and change the
fill style, corner roundness, opacity, and stroke style. The toolbar at the bottom of the widget icon editor
offers additional configuration options for widget icons:

Start Sync / Stop Sync
By default, Dashcode syncs the style of a widget’s front image with its widget icon. To turn this
behavior off, click Stop Sync. To enable this behavior if it’s been turned off, click Start Sync.

Place
To put an image, such as a logo, on a widget’s icon, click the Place button and select the image file.
Once the image is placed, you can move and resize it.

Import
If you already have an image that you want to use as a widget’s icon, click the Import button and
select it in the dialog that appears.

Open in External Editor
If you want to customize a widget icon in an application other than Dashcode, click the Open in
External Editor button. When you do this, the icon is opened in your default PNG-handling application.

Designing a Web Clip Icon

A mobile Safari web application can provide a Web Clip icon for users to place on their Home screens and
use as a type of bookmark for the application. When a user taps a Web Clip icon the web application opens
automatically, without requiring the user to navigate to it. Web Clip icons should be simple, attractive, and
easy for users to recognize.

Providing a Web Clip icon is a good idea for most mobile Safari web applications, but for those that can run
in full-screen mode, it's essential. This is because the only way users can experience a web application's
full-screen mode is by tapping its Web Clip icon to open it. For more information on specifying the mode
your web application can run in, see “Application Attributes for Mobile Safari Web Applications” (page 47).
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Note:  Because iPhone and iPod touch add the appropriate corner radius and drop shadow to the icon you
provide, you should not add these effects yourself. However, you can control whether the shiny glass overlay
effect is added automatically by specifying a value in the application attributes pane (for more information
about this, see “Application Attributes for Mobile Safari Web Applications” (page 47)).

You can use the Web Clip Icon composer to design your application’s icon. To show the Web Clip Icon
composer, select Web Clip Icon in the navigator.

To modify the appearance of the body of the icon, show the Fill & Stroke inspector and change the fill style,
opacity, and stroke style. The toolbar at the bottom of the Web Clip Icon composer offers additional
configuration options for these icons:

Place
To put an image, such as a logo, on a web application’s icon, click the Place button and select the
image file. Once the image is placed, you can move and resize it.

Import
If you already have an image that you want to use as a web application’s icon, click the Import button
and select it in the dialog that appears.

Open in External Editor
If you want to customize a web application icon in an application other than Dashcode, click the Open
in External Editor button. When you do this, the icon is opened in your default PNG-handling
application.

Designing a Favicon

A Safari web application should include a favicon (an abbreviation of the term “favorites icon”), which visually
identifies the web application in the browser. Typically, a browser that supports favicons displays them in
the address field and in bookmarks or history lists. A browser that supports tabbed browsing may also display
a favicon next to the web application’s title in a tab.

Providing a distinctive favicon is a good idea because it helps users recognize your web application. You can
specify your favicon in Dashcode’s Favicon composer. To show the Favicon composer, select Favicon in the
navigator.

You can create your favicon in two sizes: 32 x 32 pixels and 16 x 16 pixels. The smaller size can be used by
all browsers that support favicons. Creating a 32 x 32 pixel version of your favicon is optional, because some
browsers ignore it or merely scale it down before displaying it.

The toolbar at the bottom of the Favicon composer offers the following options for designing a favicon:

Import
If you have an image that you want to use as a favicon, click the Import button and select it in the
dialog that appears.

Open in External Editor
If you want to customize a favicon in an application other than Dashcode, click the “Open in External
Editor” button. When you do this, the favicon is opened in your default ICO-handling application.

Dashcode updates the favicon in your project when you save the changes you made in an external
editing application.
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After you’ve started a project and designed the user interface, you may need to customize the implementation
by adding code, data sources, or bindings to your widget or web application. This chapter describes how to:

 ■ View the files and data sources that make up your project

 ■ Write custom code to perform tasks that aren’t automatically provided by the template

 ■ Add data sources and bind them to elements in the user interface

 ■ Write a value transformer that converts the value of a property to a version that’s appropriate for display

This chapter also shows you how to turn on access to resources, such as files outside of the project and the
network. Finally, it covers the application preferences that affect your code editing experience in Dashcode.

Viewing a Project’s Source Code

Dashcode includes all the HTML, CSS, and JavaScript files that constitute a widget or web application. When
you want to add functionality beyond what a template provides, you need to view and edit these
implementation files. To show your project’s implementation files, choose View > Files. This reveals the Files
list under the navigator. In the Files list, you can add, duplicate, and rename files and folders, as discussed
in “Adding and Moving Files and Folders” (page 67).

Note:  When you edit a file’s name, make sure that you make the change in all references to that file. File
references are usually in the HTML files and, for widgets, in the Info.plist file. Be sure to review these files
and, if there are references to old filenames, update them to the new name.

When you select an HTML, CSS, JavaScript, or property list file in the Files list, the source code editor appears
below the canvas showing the selected file’s contents. In the code editor you can edit the actual HTML, CSS,
and JavaScript files that implement your widget or web application. For more on coding using HTML, CSS,
and JavaScript, read “Using HTML, CSS, and JavaScript Programming Interfaces” (page 61).

Above the text view portion of the source code editor are two pop-up menus, a file history menu on the left
and, in some cases, a function menu to the right of that. The file history menu lists the text files and data
sources that you've recently edited or viewed in the source code editor. When you select a file or data source
in the file history menu, it’s displayed in the source code editor. When you first open a project, the file history
menu contains the files you’re most likely to open, such as main.js, main.css, and index.html or
main.html. Depending on the file you’re currently viewing in the source code editor, the function menu
lists the names of all the functions in a JavaScript file or all the rules in a CSS file. Note that the function menu
is not available when viewing HTML files, property list files, or data sources.
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One common way to add code is to add an event handler to an element in the user interface. You do this
using the Behaviors inspector, as discussed in “Adding a Handler for an Event” (page 65). If you’re using
Dashcode version 3.0 and later, a common reason to add code is when you need a value transformer to
provide an appropriate value to display, based on other information in your project. You do this using the
Bindings inspector, as discussed in “Adding a Value Transformer” (page 64).

When working with resources originating outside a widget or web application—XMLHttpRequest,
command-line tools, Java applets, and such—you need to explicitly turn on access to these items. To learn
more about resource access and what elements need activation, read “Resource Access” (page 68).

You can also modify how the source code editor looks and behaves, as described in “Code Editing
Preferences” (page 69).

Viewing a Project’s Data Sources and Bindings

Dashcode supports the use of data sources and bindings to give you an easy, efficient way to get source
data into the user interface and keep the display in sync with the data. A data source represents data from
a source that can be remote, such as an RSS feed, or a local object, such as a list. A binding is a connection
between a specific property or attribute in the data source and a property of an element on the canvas.

To show the data sources in your project click the data source button at the bottom of the navigator (the
button looks like a circle with a square inside it). This reveals the Data Sources list in the navigator. In this list
you can add, remove, and rename data sources, as described in “Adding or Changing a Data Source” (page
62).

Select a data source in the Data Sources list to see a graphical representation of its layout in the source code
editor below the canvas. This representation is called the data model and it shows you the structure of the
data source, the data types of the properties in it, and, when possible, a preview of the data. You can use the
data model view to create bindings and to see at a glance which user interface elements have bindings to
properties in the data source. To learn how to create bindings, see “Creating Bindings” (page 63). To see
which elements have bindings to properties in the selected data source, move the pointer over an existing
binding in the data model: Dashcode flashes the connected element on the canvas.

In the data model view, Dashcode displays the hierarchical organization of the data source, using disclosure
triangles to indicate properties that contain children. Open a disclosure triangle to reveal a box containing
a list of child properties. When you move the pointer over a child property, Dashcode highlights all its ancestor
properties.

Each property is accompanied by an icon that indicates its data type:

 ■
(Attribute)

 ■
(Boolean)

 ■
(Number)

 ■
(Object)

 ■
(String)
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When a data source contains an array of properties of the same type, the array is represented by an icon that

looks like a stack of data type icons. For example, an array of strings is represented by this icon:

If a data source has access to actual data (when, for example, you’ve specified a feed URL or you supply static
data), data is displayed to the right of a property’s name. When the property value is an array, Dashcode
displays the total number of array members and provides arrow controls you can use to step through the
array. One array member at a time is displayed in a box revealed by a disclosure triangle.

When you hover over a property name, Dashcode displays a help tag that provides the key path of the
property and its data type. The key path represents the property’s position in the hierarchy. A key path for
a property named property_n is of the form property_1.property_2.[...].property_n, where
property_1 is the root-level ancestor. For example, the Podcast template contains a data source that
represents podcast data. The key path that locates the podcast title property in the data hierarchy is
content.channel.title.

Dashcode displays all existing bindings to the far right of a data source property. When no binding yet exists,
Dashcode displays a binding control (a small circle) when you move the pointer over a property’s row. When
you position the pointer over the binding control itself, it displays a plus symbol (+).

Existing bindings are displayed in a capsule to the right of a property; the capsule is visible until you remove
the binding. Usually, the binding capsule contains a delete control on the left (it looks like an X), the property
of the user interface element to which the item is bound, and a binding control on the right. However, if a
single data source property has multiple bindings the capsule displays a disclosure triangle on the left and
the word “Multiple” in place of the user interface property. Open the disclosure triangle in the capsule to
reveal the set of bindings for that data source property.

A good example of a property with multiple bindings is the queryInProgress property of the feed data
source in the RSS template for web applications. This data source property is bound to both the visible and
animating properties of the activity indicator part on the canvas. This ensures that when the application runs,
the activity indicator is visible only while a query is in progress and that it spins until the query is finished.

As mentioned in “Changing an Element’s Properties” (page 52), you can also view and change bindings in
the Bindings inspector. Whereas the data model view gives you a bindings-centric perspective on these
connections, the Bindings inspector gives you an element-centric perspective. The Bindings inspector displays
the bindable properties of the currently selected element and provides controls to create and change bindings.
If a binding already exists on a property, the Bindings inspector displays the data source name and the
complete key path of the bound property in the data source.

Using HTML, CSS, and JavaScript Programming Interfaces

After you’ve revealed a project’s source code, you can modify its HTML, CSS, and JavaScript files, as discussed
in “Viewing a Project’s Source Code” (page 59). Any HTML, CSS, or JavaScript code that works in Safari and
its WebKit engine can be used in a widget or web application. To learn more about HTML, CSS, and JavaScript,
read these documents:

 ■ Safari FAQ

 ■ WebKit DOM Programming Topics

 ■ Safari HTML Reference

 ■ Safari Web Content Guide
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 ■ WebKit DOM Reference

To learn more about creating a webpage or web application optimized to run in Safari on iPhone, see Safari
Web Content Guide.

In addition to WebKit’s HTML, CSS, and JavaScript programming interfaces, Apple offers Dashboard-specific
programming interfaces for use in widgets. For more on these programming interfaces, read Dashboard
Programming Topics and Dashboard Reference.

Adding a Data Source

All Dashcode templates support data sources to represent the data provided to the widget or web application.
Data sources and bindings work together to dispense data to user interface elements and allow them to stay
in sync when the data changes. (See “Creating Bindings” (page 63) to learn how to create bindings.)

For your convenience, all project templates include at least one data source, even if the data source does
not represent any actual data. For example, the Browser template includes a data source that represents
static data from a JavaScript file included in the default project. The RSS template includes a data source that
can represent data from an RSS feed; you see actual data when you supply a specific feed URL.

To add a new data source, reveal the Data Sources list in the navigator (as described in “Viewing a Project’s
Data Sources and Bindings” (page 60)) and select New Data Source in the action menu below the list. Or,
select File > New > Data Source. When you do this, the new data source appears in the list. (If you have a
dual-product project, the new data source is automatically available in both products.)

Note:  If you add a list or grid part to the canvas and you bind to it an array in an existing data source, the
list or grid itself becomes a data source. This is because Dashcode implements list and grid parts using data
sources and bindings, instead of controllers. This means that you can bind the selection property of a list or
grid data source (which represents the object selected in a row or cell) to another element on the canvas,
such as a part in a detail view.

To specify the location of a data source, you supply a URL for a JSON or XML feed. Note that you can also
supply the local path of a file of static data to serve as the data source. You do not need to specify a location
for a data source that represents a list or grid part.

There are two ways to supply the location of a data source, depending on the template your project uses.
For all projects, you can enter a URL in the data model view of the new data source (you reveal the data
model view when you select the data source in the Data Sources list). For projects based on RSS, Podcast,
Maps, Photocast, Video Podcast, or Daily Feed templates, you can also enter a URL in the Properties section
of the widget attributes or application attributes pane.

If you’ve entered a valid URL, Dashcode updates the data model view to display the available properties and
attributes of the data, along with some actual data when possible.
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Creating Bindings

All Dashcode templates support bindings, which allow a user interface element to get specific items of data
from a data source and automatically update its display when that data changes.

Dashcode offers an easy way to create bindings in the data model view. To find out how to reveal this view
and for a description of its contents, see “Viewing a Project’s Data Sources and Bindings” (page 60).

To create a binding between a data source property and an element on the canvas:

1. Press and hold the mouse button on the circular binding control next to the data source property, and
drag the pointer to the element on the canvas that you want to bind to.

As you drag, a connection line extends from the binding control, and each element on the canvas
highlights as you pass the pointer over it. (You can see an example of how this looks in Figure 3-8 (page
38).)

2. Release the mouse button when the element you want to bind to is highlighted.

As soon as you stop dragging, Dashcode displays a contextual menu that lists the bindable properties
of the selected element.

3. Choose the appropriate property to complete the binding.

If you choose not to complete the binding after you stop dragging, simply click outside of the contextual
menu and the binding is not created.

Note:  You can also create a binding by dragging from a binding control in the data model view to an element
in the navigator. You might need to do this if the element you want to bind to is difficult to see on the canvas.
When you create a binding to an element in the navigator, you complete the binding as described in steps
2 and 3 above.

If the Bindings inspector wasn’t visible before, it opens when you complete a binding, allowing you to specify
a value transformer and placeholder text or values.

You can also create bindings in the Bindings inspector, without dragging from the data model view. To do
this, follow these steps:

1. Select the element you want to bind to on the canvas or in the navigator.

When you do this, the Bindings inspector displays the bindable properties of the element.

2. In the Bindings inspector, open the disclosure triangle to the left of the element property you want to
bind to.

3. Select the “Bind to” checkbox and choose a data source from the pop-up menu.

4. Open the Key Path pop-down menu to reveal the top-level properties of the selected data source.

5. Choose a data source property in the Key Path menu.
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If the data source property you’re interested in is a child of a top-level property, click the pop-down
control again to see a list of the current property’s children. Continue choosing child properties until
you reach the one you want.

Because bindings are tightly integrated with user interface objects, you must create bindings separately in
both products of a dual-product project. This is because each product uses different parts to display data,
even though they can share a single data source.

Note:  If you copy a part from one product of a dual-product project to the other, any bindings you made
are not included in the copy of the part.

Adding a Value Transformer

A value transformer is a function that takes a data source value and returns an appropriate display value,
based on other information in the data source or contextual information in your code. For example, you
might want to transform a temperature value from Fahrenheit to Celsius, or format a numerical value as a
currency value.

Because a value transformer may need to interpret the data model and make decisions based on context,
you must usually write it yourself. That said, Dashcode includes a few generic value transformers you can
use, such as a reverse-value function. To specify a value transformer open the Bindings inspector and:

1. Select the user interface element that is bound to the data source item you want to transform.

2. Click the Value Transformer text field.

Dashcode displays the generic value transformers, along with any value transformers you’ve already
included in your project, in a pop-down list.

3. Select an existing function or type the name of the function you plan to write and press Return.

If you select an existing value transformer, Dashcode displays an arrow control that you can click to see
the function in the source code editor.

If you supply the name of a new value transformer, Dashcode inserts the new function in your project’s
JavaScript file and displays it in the source code editor. You can then add custom code that performs
the transformation.

Dashcode includes several built-in value transformers in the transformers.js file. You can customize some
of these transformers by changing the default parameters. For example, the truncation value transformer
(DC.transformer.Truncated) automatically truncates the passed-in string to 10 characters, but you can
change this by editing the transformer function. The transformers.js file contains the following value
transformers:

 ■ DC.transformer.Boolean returns the Boolean value TRUE if the passed-in value is equal to a value
you supply as the “true value.” For example, you might designate the string “red” as the true value.
Changing the Boolean value transformer to use this string, this value transformer returns TRUE when
the passed-in value is “red.”
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You can also specify a reverse transformation for this function. If you want to do this, you also need to
supply a “false value” that the function can use to test the passed-in value against. In this case, the
transformer returns either the true or false value that you supplied, depending on which one the passed-in
value matches.

 ■ DC.transformer.FirstObject returns the first object in an array.

 ■ DC.transformer.Matches returns the Boolean value TRUE if the passed-in value matches a regular
expression you define.

 ■ DC.transformer.Not returns the opposite Boolean value of the passed-in value (that is, it returns
TRUE for a value whose Boolean value is FALSE).

 ■ DC.transformer.StringToObjects creates a JavaScript object from a passed-in array, or, in reverse,
creates a string from a passed-in object.

 ■ DC.transformer.Truncated truncates the passed-in string to a number of characters that you define
(or 10, by default), and adds an ellipsis.

Adding a Handler for an Event

When you add a handler using the Behaviors inspector (as discussed in “Changing an Element’s
Properties” (page 52)), the new handler function is inserted in the project’s JavaScript file. When you click
the arrow in the Behaviors inspector next to the handler function’s name, the source code editor appears
under the canvas with the function selected. You can then add your custom code to handle the event.

For more on using the source code editor, read “Viewing a Project’s Source Code” (page 59). To learn about
JavaScript and the Dashboard programming interfaces, read “Using HTML, CSS, and JavaScript Programming
Interfaces” (page 61).

Supporting Offline Usage of a Web Application

You might want to allow users to run your web application even if they lose their network connection. You
can do this by taking advantage of the manifest attribute available in the HTML 5 specification. The value
of the manifest attribute is the URL of a file that contains the resources your web application needs to have
cached in order to run offline.

Note:  Dashcode automatically includes in the manifest all files your project needs. If necessary, you can
modify the manifest after you deploy your project or save it to disk. By default, Dashcode names the manifest
file OfflineApp.manifest and includes it in the appropriate product folder (Safari or Mobile) in your saved
project and deployed project folders.

To enable offline usage of your web application, select the Offline Viewing checkbox in the General section
of the application attributes pane. Dashcode adds the manifest attribute to the HTML element in the
index.html file.
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Dashcode helps you support offline usage of your web application by providing some code snippets you
can use to query and respond to changes in online status. You can elect to receive these events when the
user goes online or offline, and you can write code to update the user interface or access different resources,
as necessary.

Adding or Removing a Web Application Product

By default, Dashcode creates two products in a web application project: a mobile Safari web application (a
web application optimized to run in Safari on iPhone) and a Safari web application. As described in “Creating
a Project from a Template” (page 45), after you select a template to start your project, you choose whether
you want to create both products, or only one.

Before you add or remove a product from your existing project, it’s important to understand how Dashcode
organizes the files in your project. In a dual-product project, you see the following files and folders at the
root level of the Files list (among other, optional files and folders):

 ■ The safari folder contains all the files and parts that are unique to the Safari web application.

 ■ The Images folder contains all the images that are common to both products.

 ■ The index.html file is the main HTML file for the project.

 ■ The mobile folder contains all the files and parts that are unique to the mobile Safari web application.

 ■ The Parts folder contains Dashcode parts and other code files that are common to both products.

As you can imagine, a project that creates only a mobile Safari web application does not contain a safari
folder, and a project that creates only a Safari web application does not contain a mobile folder.

Important:  The root-level index.html file is considered the main HTML file for the project. In a dual-product
or Safari-only project, the main index.html file contains a base tag whose href attribute references the
safari/ location on your server. In a mobile Safari–only project, the base tag in the main index.html file
references the mobile/ location on your server.

Dashcode includes this default location so your application’s URL can be, for example,
http://myserver.com/ instead of http://myserver.com/safari/. Be sure to take this into account
when you refer to resources on your server.

If you have a dual-product project, you can remove a product by choosing File > Delete Current Product,
where Current is “Safari” or “Mobile Safari,” depending on which product is currently selected.

If you want to add a product to a single-destination project, choose File > Add Other Product, where Other
is “Safari” or “Mobile Safari,” and represents the product you want to add.

Adding Code for Custom Controllers

If you want to modify a web application by changing or adding a view, such as a detail view, it’s recommended
that you add code to control it. Each view in a web application is controlled by a JavaScript controller object.
The controller object is in charge of configuring the interface within a view so that it displays properly, and
so that the view can handle all activity that occurs within it.
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If you add a list or grid part, you can write a controller for it that supplies data dynamically or you can bind
the list to an array property in a data source. Or, you can combine these approaches and use bindings to get
the number of rows and the data for each row, and a controller to configure each row.

For more information on some of the parts you can add to your web application, see “Dashcode Parts” (page
85). To learn about JavaScript and the Dashboard programming interfaces, read “Using HTML, CSS, and
JavaScript Programming Interfaces” (page 61).

Code Completion Using Code Sense

Dashcode’s source code editor includes a code completion feature that suggests possible variable and
function names based on partially entered text. When Code Sense has a suggestion, it underlines the text
you’re typing. To see the list of suggestions, press the Option and Escape keys. Use the Up and Down Arrow
keys to select the symbol you want. To add the symbol, press the Tab key. To dismiss the suggestion list,
press the Escape key.

See “Code Editing Preferences” (page 69) for more information on how to set Code Sense preferences.

Code Snippets

Dashcode includes a set of reusable code snippets. Each code snippet provides a bit of functionality that
you can use to enhance your widget or web application. To show the code snippets, choose Window > Show
Library and click the Code button. To add a code snippet to your project, drag it from the Code Library to
the source code editor.

In addition to the code snippets included with Dashcode, you can save your own snippets for later use by
dragging them from the source code editor to a group you create in the Code Library. To create a new group,
choose New Group from the action menu under the listings in the Code Library.

Adding and Moving Files and Folders

You can add additional files and folders to a widget or web application in Dashcode. Although this is rarely
necessary, it can be helpful when organizing numerous files or areas of functionality. To add a new file, show
the files list, choose File > New and choose either JavaScript File, CSS File, or File. After you create a new file,
you can view and edit its contents as described in “Viewing a Project’s Source Code” (page 59).

To add a folder to your project, choose File > New > Folder. To add items to the folder, drag them on to its
icon.

In the Files list, you can rename, duplicate, move, and delete files and folders. To rename an item, select it
in the Files list and choose Rename from the action menu (the gear icon beneath the Files list). To duplicate
an item, choose Duplicate from the action menu. To remove an item, choose Move to Trash from the action
menu. To move an item, drag its icon to another folder’s icon.
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Note:  Dashcode does not manage references to files and folders in a widget or web application. If you
remove, rename, or move a file or folder, you need to remove, rename, or update the reference to the file or
folder in the project’s main HTML file. Failure to update a reference to a removed, renamed, or moved file or
folder may result in unexpected behavior.

When you add a new JavaScript or CSS file, you need to include a reference to the file for it to be used by
your widget or web application. Add a reference to the new file at the top of the project’s main HTML file.
In a widget, the main HTML file is the file paired with the MainHTML key in the widget’s Info.plist file. In
a web application, the main HTML file is the index.html file at the root level of the Files list.

In your project’s main HTML file, add a reference to a new CSS file using the @import directive using the
<style> tags. Add a reference to a new JavaScript file using the <script> tag.

Resource Access for Widgets

If you intend to use any of the following resources in your widget, you need to turn on access to them first:

 ■ Network resources (including XMLHttpRequest)

 ■ External files

 ■ Internet plug-ins, such as QuickTime and Quartz Composer

 ■ Java applets

 ■ Command-line applications

Important:  In general, Safari on iPhone does not support any third-party plug-ins or features that require
access to the file system, so most of these resources are not appropriate for mobile Safari web applications.

However, Safari on iPhone does support XMLHttpRequest. To learn more about unsupported technologies
in a mobile Safari web application, see Safari Web Content Guide.

Turn on access to these resources, select Widget Attributes in the navigator. Then select the option for the
resource you want to use. Options include:

Network / Disk Access
If your widget requires access to network resources or files on disk, select the appropriate item. Unless
your template already needs access to network resources (such as XMLHttpRequest) and files on
disk outside of your widget bundle, these resources are turned off.

Extensions
If your widget uses content provided through an Internet plug-in or a Java applet, or uses a
command-line utility via widget.system, select the appropriate option. Unless your template already
needs access to plug-ins (such as QuickTime), Java, and command-line utilities, these resources are
turned off.

68 Resource Access for Widgets
2009-07-24   |   © 2009 Apple Inc. All Rights Reserved.

CHAPTER 6

Adding Source Code and Creating Bindings



Code Editing Preferences

The source code editor has a number of preferences you can set to change its behavior to better suit your
tastes. To show these preferences, choose Dashcode > Preferences. The Preferences window includes the
following items:

 ■ General preferences include an option for opening source code files in Dashcode or in a helper application.

 ■ The source code editor has various visibility and behavior preferences, including the visibility of the
gutter and line number next to your source code, the source code editor’s line wrapping, and the Tab
key’s indentation behavior. You can set these preferences in Editing preferences.

 ■ Your source code can be colored based on the code’s syntax. You can adjust text font, size, and color in
Formatting preferences.

 ■ Dashcode offers a code completion feature called Code Sense (as described in “Code Completion Using
Code Sense” (page 67)). At the top of the source code editor, a pop-up menu shows the symbols in a
file. Code Sense preferences include a setting for how these symbols are organized. This pane also
includes settings for code completion.
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After you’ve written code for your widget or web application, test it to ensure that it works as you expect.
Dashcode includes its own Dashboard environment so you can run and test a widget in Dashcode without
having to open it in Dashboard. Similarly, Dashcode includes a simulator application that simulates Safari
and Safari on iPhone, so you can easily test both products of a dual-product web application project.

Note:  If you’ve installed the iPhone SDK on the same computer on which you use Dashcode, Dashcode
opens the iPhone Simulator application in the SDK when you run a mobile Safari web application. If you
don’t have the SDK installed, your mobile Safari web application is opened in the Dashcode simulator
application.

In addition to running widgets and web applications, Dashcode also includes tools that help you debug and
fix problems that may arise. This chapter includes information on how to trace events and inspect variable
values while a widget or web application executes. It also includes information on sharing a widget and
deploying a web application.

Testing a Widget or a Web Application

To run a widget or a web application in Dashcode, choose Debug > Run or click Run in the toolbar. Depending
on your project type, this has a different effect:

 ■ For widgets, this runs the widget in Dashcode without having to open it in Dashboard. The widget
behaves here as it would in Dashboard.

 ■ For web applications, this runs the web application in the appropriate simulator application without
having to deploy it and run it in a device. The simulator allows your web application to behave as it
would in Safari on iPhone or in Safari.

If you’ve installed the iPhone SDK on your computer, you have two display options when testing a mobile
Safari web application in Dashcode version 3.0 and later:

 ■ Run with the Safari interface visible (that is, with the Safari toolbar and navigation bar visible). This
simulates what users can see when they use Safari on iPhone to navigate to your web application.

 ■ Run with the Safari interface hidden (that is, in full-screen mode). This simulates what users can see when
they tap a Web Clip icon to open a mobile Safari web application that can run in full-screen mode.

You can access these options by clicking and holding the Run button in the Dashcode project window. From
the menu that appears, choose “Run” or “Run Full-screen.” After you make your choice, clicking Run or
choosing Debug > Run runs your web application in that mode until you change it.
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In Dashcode version 3.0 and later you can simulate running a web application on the same server that hosts
the application’s data sources. This allows the application to bypass the “same source” restriction imposed
by web browsers and fetch data from an external server (see “Deploying a Web Application” (page 75) for
more information on this restriction). When you run the application in Dashcode for the first time, Dashcode
displays a dialog that asks whether you want to simulate running on a remote server or on your local computer.

 ■ Click Simulate to simulate running on the remote server you identified in the application attributes pane
or in the URL field of a data source.

Dashcode uses this remote server for simulation until you specify a different one, or until you deselect
the Simulation checkbox in the Running section of the Run & Share pane. If you do either of these things,
Dashcode displays a dialog asking for confirmation of your simulation choice the next time you run your
web application.

 ■ Click Continue to run the application on your local computer. Note that this can prevent the application
from loading external resources.

Note:  When you run a web application in the Dashcode simulator application, you have access to the Web
Inspector that is also available in Safari. In the Dashcode simulator, choose View > Show Web Inspector to
open the Web Inspector. To learn more about this tool, see Using the Web Inspector.

When your widget or web application loads, test it out to see if it functions as you expect. When an error
occurs, an exception is thrown and, by default, execution pauses. When this happens, there are a number
of tools at your disposal that help you see where the problem is and inspect variable values:

 ■ The run log lists errors and other useful information. If you enable tracing, the run log notes the invocation
of functions as well. See “The Run Log and Tracing Execution” (page 73) for details.

 ■ The Stackframe & Variables table shows you the value of any variable a widget or web application uses.
See “Checking Values in Memory” (page 74) for details.

 ■ Step-by-step execution enables walking through the execution line-by-line so you can see the effects
of the code. See “Pausing and Step-by-Step Execution” (page 73) for details.

 ■ The Evaluator is a console where you enter individual lines of code to be executed immediately. See
“The Code Evaluator” (page 74) for details.

To continue a paused widget or web application, choose Debug > Continue or click Continue in the toolbar.
To turn off pausing when an exception occurs, deselect Debug > Break on Exceptions.

To pause a widget or web application at any time, choose Debug > Pause or click the pause button in the
toolbar. While a widget or web application is paused, you can step through its code line-by-line as discussed
in “Pausing and Step-by-Step Execution” (page 73). You can also pause a widget or web application when
execution reaches a specific line of code using a breakpoint, as discussed in “Breakpoints” (page 74).

To stop running a widget or web application in its testing environment, choose Debug > Stop or click Stop
in the toolbar.
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The Run Log and Tracing Execution

When you run a widget or web application in Dashcode, the canvas is replaced by the run log. Any errors
that Dashcode encounters while running the widget or web application are reported here. For example, a
call to a function that doesn’t exist appears in the run log as an “object that doesn’t allow calls.“

If the run log is replaced by another view, choose View > Run Log to show it. When possible, selecting a row
in the run log reveals the associated line of code in the source code editor.

In addition to reporting errors, the run log can be used to trace execution of a widget or web application.
Tracing means that an entry in the run log is made whenever a function starts and finishes. This is useful
when you’re watching the flow of execution in a widget or web application.

When the run log is visible, you can filter the contents of the run log by typing a term into the search field
in the toolbar.

Pausing and Step-by-Step Execution

At any time, you can pause the execution of a widget or web application. Pausing execution is useful if you
want to inspect the values of variables. To pause, choose Debug > Pause or click Pause in the toolbar. When
the widget or web application is paused, the run log is replaced with the Stackframe & Variables table.

When the execution of a widget or web application is paused, you can inspect the values of the variables
within the scope of the current function and the global scope. Also, the line of code that is paused is
highlighted in the source code editor. In the shortcuts under the source code editor, you can see a hierarchy
of functions that leads to the currently executing function. If you click another function name in the shortcuts,
the function’s variables are shown in the Stackframes & Variables table and its code is shown in the code
editor. You can also search for a specific variable by typing its name into the search field in the toolbar.

When you’re finished examining variables, you can continue executing the widget or web application in a
few different ways:

Continue
Choose Debug > Continue or click Continue in the toolbar to continue execution with no interruption.

Step Into
Choose Debug > Step Into or click Step Into in the toolbar to execute the next line of code and step
into function calls so you can see the effect that line of code has.

Step Over
Choose Debug > Step Over or click Step Over in the toolbar to execute the next line of code so you
can see the effects that line of code has.

Step to End
Choose Debug > Step to End or click Step to End in the toolbar to execute the rest of the current
function; execution pauses when the function is finished so that you can inspect its variables before
they are relinquished.

Also, execution pauses whenever an exception occurs. When an exception occurs, the execution of a web
application or widget is paused and an entry in the run log explains what the problem is. If you click the
entry, the line of code in which the exception occurred is highlighted. By default, this option is enabled. You
can control this option by choosing Debug > Break on Exceptions.
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Checking Values in Memory

The Stackframe & Variables table shows the value of the variables used in a widget or web application. When
the widget or web application is running, its global variables are available for inspection. When you pause
a widget or web application, as described in “Pausing and Step-by-Step Execution” (page 73), the current
function gets its own heading in the table with its variables listed underneath. If the function was called by
another function, the second function’s variables are listed under the first, and so on.

Double-clicking a variable in the table adds the variable name to the code evaluator, as discussed in “The
Code Evaluator” (page 74).

Breakpoints

In addition to pausing the execution of a widget or web application using the Pause option, you can set
places in your code for execution to pause, called breakpoints. You can add a breakpoint in two ways. One
way is to click in the gutter of the source code editor. If the gutter is not showing, go to Editing preferences
and select the Show Gutter option.

A blue arrow in the gutter means that before that line of code is executed, execution will halt. To temporarily
disable the breakpoint, click it; it turns from blue to gray to indicate that it’s disabled. To remove the breakpoint,
drag it outside of the gutter.

The other way to set a breakpoint is to use the Breakpoints window. To show the Breakpoints window choose
Debug > Show Breakpoints Window or double-click in the gutter. In the Breakpoints window, click the plus
(+) button and specify either a filename and line number or a function name to break on. For instance, if you
wanted to break in Untitled.js on line 42, you enter Untitled.js:42. Alternatively, you can supply the
name of the function you want to break on (for instance, showFront in a widget).

In addition to the breakpoint, you can set a condition for the breakpoint. A condition is a JavaScript statement
that evaluates to either true or false. If the condition evaluates to true when execution passes the
breakpoint, execution pauses.

In the Breakpoints Window, you can remove a breakpoint by selecting a breakpoint from the table and
clicking the minus (-) button or you can disable it by deselecting the checkbox next to a breakpoint’s item
in the table.

The Code Evaluator

While you run a widget or a web application, it can be useful to execute just one line of code. The code
evaluator lets you do this. To show the code evaluator, choose View > Evaluator or choose Evaluator from
the View menu in the toolbar. In the evaluator, you enter arbitrary code and press the Return key to execute
the code immediately.

If you double-click a value in the Stackframes & Variables table, its name is automatically entered into the
code evaluator. Also, if your cursor is at the prompt and you press the up arrow key, you cycle through the
history of entries in the code evaluator.
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Sharing a Widget

When you’re finished developing a widget, you can share it with others. There are two commands for deploying
a widget, and both export the widget from the project as a .wdgt bundle, ready to run in Dashboard. Click
Run & Share in the navigator to see a pane that gives you the choice of deploying the widget for use in Mac
OS X v10.4.3 or later or for use in all versions of Mac OS X v10.4. In most cases, deploying a widget for use in
Mac OS X v10.4.3 or later is advisable, because it results in a smaller widget.

If you want to share your widget by, for example, sending it in an email, click Save to Disk in the Run & Share
pane and choose a convenient save location. If you want to make sure the widget project is automatically
saved to disk before deploying, select the “Save project to disk before deploying” checkbox. Note that this
checkbox is available after you’ve saved the widget project for the first time.

If the widget is for your use only, choose File > Deploy Widget to install it on your computer.

Deploying a Web Application

When you’re ready to deploy your web application, you choose where you want Dashcode to place your
application’s code and resource files and how they should be saved. These files include the HTML, CSS, and
JavaScript files, image files, and your application’s Web Clip icon or favicon. (Note that, during deployment,
Dashcode removes some Dashcode-specific content from the HTML file.)

By default Dashcode deploys these files to a folder in your ~/Sites folder. You can modify this behavior by
making choices in the Run & Share pane (click Run & Share in the navigator to open this pane).

Dashcode gives you three deployment options:

 ■ Deploy to a local destination. Dashcode places your web application files in a folder you specify for the
default local destination or a local destination you create.

 ■ Deploy to a remote server. Dashcode uses WebDAV, FTP, or MobileMe to upload your web application
files to a server you specify.

 ■ Save to disk. Dashcode saves your web application files in a folder whose name and location you supply.

If you want to save a copy of your web application files in a folder on disk, click Save to Disk at the bottom
of the Run & Share pane and supply a folder name and location. If you want to deploy the application to a
local or remote server, you can customize the deployment behavior in the Deploy section of the Run & Share
pane:

 ■ Use the Destination pop-up menu if you want to select a destination other than the default. (Unless
you’ve already changed the default destination, this is the localhost account.)

To add a new destination, select “Add destination” in the pop-up menu to open Dashcode’s Destinations
preferences and set up a new destination.

In Destinations preferences, you can specify an additional local destination or a WebDAV, FTP, or MobileMe
destination. You can also set whether Dashcode should use the new destination as the default destination
for new projects.
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 ■ Use the Application Path field to supply a name for the application folder (otherwise, Dashcode creates
a folder called Untitled). Dashcode creates this folder in the path specified by the currently selected
destination.

In the Options section of the Run & Share pane, you can determine the save behavior and the deployment
notification:

 ■ Select the “Save behavior” checkbox if you want your web application project to be saved before every
deployment (this checkbox is available after you’ve saved the project for the first time).

 ■ Select the Compression checkbox if you want Dashcode to compress the JavaScript code in the parts
files. This can reduce network latency during multiple file requests. Note that selecting this checkbox
does not compress main.js or any JavaScript code you supply.

 ■ Select the Notification checkbox if you want Dashcode to send an email message containing a link to
your application every time you deploy it. Use the field below the Notification checkbox to supply the
recipient’s email address (or multiple email addresses, separated by commas).

After you finish making your selections, click Deploy at the bottom of the Run & Share pane, or choose File
> Deploy, to deploy your web application. To view your web application, navigate to the index.html file
on the designated server (for example, http://myserver.com/myapp/index.html). Your web application
automatically detects the identity of the browser and opens a mobile Safari web application in Safari on
iPhone and a Safari web application in Safari.

Note:  As mentioned above, Dashcode uses WebDAV, FTP, or MobileMe to upload your application files to
a remote server. Dashcode does not support SSH or SFTP.

Warning: Web browsers, including Safari on iPhone, implement a security model known as “same
source.” This means that webpages are not allowed to request information from Internet domains other
than the one from which they came. If you have built a web application that fetches information from
other websites to display, be sure to tell Dashcode to simulate running on that server, as described in
“Testing a Widget or a Web Application” (page 71).

There are ways to configure your web server and alter your web application to make it possible to fetch
information from other websites, but these techniques are beyond the scope of this document. Contact
the administrator of your web server for advice.
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In addition to the core tasks of designing, coding, and testing a widget, Dashcode offers additional, advanced
features that help you develop a widget that fits your users’ needs. This chapter covers localization techniques
and how to include a plug-in written in Objective-C.

Localization

You supply localized strings for your widget in the Localization section of the widget attributes pane. To
show the widget attributes pane, click Widget Attributes in the navigator.

To localize your widget for other languages, click the plus (+) button and choose the language. Next to the
language name in the first table, you provide a localized name for your widget. This name is used for your
widget in the Finder and in the widget bar in Dashboard.

The table on the right shows all the strings used in your widget. In this table, you double-click a term in the
Value column and provide localized versions of your widget’s strings. You add key-value combinations for
localization by clicking the plus button, providing a unique key name, and entering the localized version of
the string next to its key.

When you add a language for localization, a language project folder is added to the widget. In addition to
the strings, you can place any localized resources, such as style sheets or images, in a language project folder.
To show the language project folder, choose View > Files and look for the folders that end with the .lproj
extension. For more information on widget localization, read Localizing Widgets in Dashboard Programming
Topics.

To make it easy to test your widget’s localization, choose View > Customize Toolbar. In the dialog, drag the
Language pop-up menu to the project window’s toolbar, then click Done. Now you can choose a language
from the Language pop-up menu to see your widget in that language. If you click Run in the toolbar, your
widget runs in the selected language.

Widget Plug-ins

Dashcode offers a place to associate a widget plug-in with your widget. If you’ve built a custom widget
plug-in with Xcode and want to include it with your widget, select Widget Attributes from the navigator and,
in the Widget Plugin section, click the Choose button and select a built widget plug-in.

For more information about widget plug-ins, read Creating a Widget Plug-in in Dashboard Programming
Topics.
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Apple provides a number of templates with Dashcode. Read this appendix to learn more about the features
of each of the Dashcode templates.

Widget Templates

All widget templates allow you to set values that identify the widget in the widget attributes pane. To learn
about these, see “Providing Widget Attributes” (page 46). Some widget templates include template-specific
attributes you can set in the Properties section of widget attributes; these are described below.

The Custom Widget Template

The Custom template for widgets creates a blank widget that contains the basic files and images needed to
make a widget. A widget made from this template contains no other preconfigured abilities.

The Countdown Template

The Countdown template creates a widget with a preconfigured digital-style countdown timer. To customize
this template, add a picture or other artwork and set the target event for the countdown. To set the target
event for the countdown, click Widget Attributes in the navigator and modify the options available under
Properties.

Options that you can set include:

Target Kind
Set a specific date and time or a shared iCal calendar as the target for your widget. If you associate
your widget with a shared iCal calendar, it counts down towards the next event on the calendar. After
that event, the widget counts down to the next event on the calendar, and so forth. For more
information on iCal and calendar publishing, read Mac 101, Lesson 10: iCal.

When Reached
When the target event is reached, your widget can stop counting or start counting upwards from the
event. Also, if you choose Do Action and provide a handler, it can trigger a JavaScript function, allowing
your widget to respond to the event programmatically.

Display
Select whether the separator colons between the units of time flash and whether leading zero
characters for each single-digit unit of time are shown.
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The Maps Template

The Maps template creates a widget that displays locations and location-specific information on a map. To
customize this template, change its appearance on the canvas and provide the URL of a map you publish.
Also, you can change how your widget displays location information.

The Maps template works with KML files and GeoRSS feeds. To set the target map for your widget, click
Widget Attributes in the navigator and modify the options available under Properties.

Options you can set include:

Maps API Key
Supply your Maps API key here. For more information on signing up for the Maps API, see Google
Maps API on the Google developer website.

Initial Address
Supply the starting address you want to display in your widget here.

Mashup URL
Paste the URL for your map feed here. For more information on publishing personalized maps, see
How to Create a Map on the Google developer website.

Note:  You may find that you get the best results when you limit the number of points in your KML file to
about 60 and limit the file’s uncompressed size to about 1 MB.

The RSS Widget Template

The RSS template creates a widget that displays headlines from an RSS source. It is suited for RSS feeds that
update very frequently because it shows a number of headlines at once. To customize this template, change
its appearance on the canvas and provide an RSS feed URL for the widget to display. To set the target RSS
feed for your widget, click Widget Attributes in the navigator and modify the options available under Properties.

Options that you can set include:

Feed URL
Paste the URL for an RSS feed here.

Show Articles
Adjust how many articles your widget shows and within what period of time the articles originate.

Display
Select whether date and time and whether a new content badge is shown with articles.

The Podcast Widget Template

The Podcast template creates a widget that displays and plays episodes from a podcast. To customize this
template, change its appearance on the canvas and provide a podcast URL for the widget to play back. To
set the target podcast feed for your widget, click Widget Attributes in the navigator and modify the options
available under Properties.

Options that you can set include:
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Podcast URL
Paste the URL for a podcast here.

Check for updates
Set how often the widget should check for new episodes.

The Photocast Template

The Photocast template creates a widget that displays a slideshow of pictures obtained from an iPhoto
Photocast. To customize this template, change its appearance on the canvas and provide a Photocast URL
for the widget to display. To set the target Photocast for your widget, click Widget Attributes in the navigator
and modify the options available under Properties.

Options that you can set include:

Photocast URL
Paste the URL for a Photocast here.

Change Picture
Adjust how often pictures should change.

Transition and Direction
Set the transition used when pictures change and, if available, the direction the transition should
occur.

Show Title
Set the conditions under which the title of the Photocast should display.

The Quartz Composer Template

The Quartz Composer template creates a widget that displays a Quartz Composer composition. Quartz
Composer compositions can be used in widgets to process and display graphical data. To customize this
template, show the Files list and open Default.qtz in Quartz Composer. Quartz Composer is installed as
part of the Developer Tools for Mac OS X v10.5.

For more information on using Quartz Composer, read Quartz Composer Programming Guide. For more
information on the Quartz Composer WebKit plug-in (the plug-in that powers the Quartz Composer template)
read Quartz Composer WebKit Plug-in JavaScript Reference.

Note:  Widgets created using the Quartz Composer template are compatible with Mac OS X v10.4.7 and later.

The Video Podcast Template

The Video Podcast template creates a widget that displays and plays episodes from a video podcast. To
customize this template, change its appearance on the canvas and provide a video podcast URL for the
widget to play back. To set the target video podcast feed for your widget, click Widget Attributes in the
navigator and modify the options available under Properties.

Options that you can set include:
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Podcast URL
Paste the URL for a video podcast here.

Check for updates
Set how often the widget should check for new episodes.

The Gauge Template

The Gauge template creates a widget with gauges and indicators useful for monitoring activities. To change
the sources of data for the gauges and indicators, choose CommandMonitor.js from the Files list and write
code to interpret your source data and feed results to the gauges and indicators.

The Daily Feed Template

The Daily Feed template creates a widget that displays individual articles or images from an RSS source. It is
suited for RSS feeds that don’t update frequently since it shows one article at a time. To customize this
template, change its appearance on the canvas and provide an RSS feed URL for the widget to display. To
set the target RSS feed for your widget, click Widget Attributes in the navigator and modify the options
available under Properties.

Options that you can set include:

Feed URL
Paste the URL for an RSS feed here.

Feed Type
Specify what kind of information the feed provides. If it provides HTML content, choose HTML. If your
feed provides an image (such as a comic strip or daily photo), choose Image.

Web Application Templates

All Dashcode web application templates are available for both dual-product and single-product projects. See
“Creating a Project from a Template” (page 45) for more information about these two project types.

All web application templates allow you to set some options in the application attributes pane. To learn
about these, see “Providing Attributes for a Web Application” (page 46). If you’re developing a mobile Safari
web application, be sure to set these options appropriately because they affect how users view and interact
with your application on an iOS-based device. Some templates include template-specific attributes that you
can set in the Properties section of application attributes; these template-specific attributes are described in
the sections below.
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Note:  In Dashcode version 3.0 and later, web application templates use data sources and bindings in place
of most custom JavaScript controllers. To learn more about data sources and bindings, start by reading
“Viewing a Project’s Data Sources and Bindings” (page 60). Then, take a look at the code in the templates
to learn how to set them up and use them. For example, you can see how to use data sources and bindings
to implement a detail view that gets its content from the selected item in a top-level (or master) list.

The Custom Web Application Template

The Custom template for web applications creates a blank web application that contains the basic files and
images to make a web application. A web application made from this template contains no other preconfigured
abilities.

The Browser Template

The Browser template creates a web application that supports navigation through multiple levels of content.
A web application developed with the Browser template is well-suited to displaying hierarchical information
through which users can drill down.

The default web application provided by the Browser template contains a list view for the top level of the
content and a detail view for the second level of the content. Selecting an item in the top-level list
automatically reveals the detail view associated with that item. You can add additional list levels and you
can add content to the detail views.

The Podcast Web Application Template

The Podcast template creates a web application that displays and plays episodes of a podcast that you
publish. The template is set up to display a list of episodes that are played when when users select them.

To customize this template, provide the URL of a podcast that you publish. One way to do this is to put the
URL in the URL field of the data model view for the podcast data source (see “Viewing a Project’s Data Sources
and Bindings” (page 60) to learn how to reveal this view). Alternatively, you can click Application Attributes
in the navigator and modify the option under Properties.

The option you can set is:

Podcast URL
Paste the URL for the podcast you publish here.

The RSS Web Application Template

The RSS template creates a web application that displays headlines and articles from an RSS source. A web
application developed with this template can handle RSS feeds that update very frequently because the
template allows you to show numerous headlines at once.
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To customize this template, provide an RSS feed URL that you publish. You can also adjust how many articles
are displayed and for how long. To customize these attributes, click Application Attributes in the navigator
and modify the options under Properties.

Options that you can set include:

Feed URL
Paste the URL for the feed you publish here.

Show Articles
Adjust how many articles to display in your web application, within what time period the articles
originate, and how many “top stories” to display.

You can also specify the feed URL in the URL field of the data model view for the feed data source. See
“Viewing a Project’s Data Sources and Bindings” (page 60) to learn how to reveal this view.

The Utility Template

The Utility template creates a web application that displays a text entry area. In the Safari product it displays
a toolbar that contains editing controls; in the mobile Safari product it includes a reverse side you can use
to display configuration options or a different view.

To customize this template for a mobile Safari product, place your content in the front view and the
configuration options or alternative view you want to offer in the settings view. Be sure to leave the Info
button in place (the template provides this button in the lower-right corner of the front view), because users
know they can tap this control to see the reverse side of a mobile Safari web application.
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Dashcode includes a number of unique elements that you use on your widget’s or web application’s interface
to display information. Some of these elements, called Dashcode parts, can be modified programmatically.
For those that can be modified programmatically, this appendix describes some of the methods you can use
to do so. To look at the code that implements these parts, choose the Files view in the navigator and select
the appropriate file.

Note:  In Dashcode version 3.0 and later, you can often avoid making programmatic changes to modify a
part by using data sources and bindings instead. See “Adding a Data Source” (page 62) and “Creating
Bindings” (page 63) for more information on how to do this.

Some parts listed in this appendix are specifically designed to work with web applications, not widgets, and
are described as such.

After you add a part to the canvas, you can change its attributes using the Attributes inspector, create bindings
to it using the Bindings inspector, and assign to it event handlers using the Behaviors inspector. For more
information about the inspector window, read “Changing an Element’s Properties” (page 52).

Activity Indicator

The Activity Indicator part is designed for use in a web application. An activity indicator shows the user that
a task or process is progressing, but does not indicate when it will finish.

The Activity Indicator part includes JavaScript code that starts and stops the spinning action. You can use
the startAnimation and stopAnimationmethods to coordinate the spinning of an activity indicator with
the progress of a task or process.

Back Button

The Back button part is designed for use in a mobile Safari web application. In a mobile Safari web application
that displays multiple levels of information, a back button gives users a convenient way to retrace their steps
within the application. This allows an application to present its own navigational hierarchy within a single
URL.

The Back button part is automatically included in the code for a mobile Safari project based on the Browser
template. It is set up to appear on all levels except the first.
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Box

The Box part is an area that is optionally wrapped with scroll bars, meant for showing content larger than a
widget’s or web application’s interface. You can customize a box’s appearance using the Attributes inspector.
Options you can set include whether the box automatically hides when its contents fit in its bounds and the
dimensions of its bounds and margins.

To change the contents of a box, use the content property from the box’s object, as shown here:

var content = document.getElementById("box").object.content;
content.innerText = someText;

Once you obtain the box’s content property, you have access to the <div> element that is inside the box.
From there, you can use the innerText or innerHTML properties to change the box’s contents.

Browser

The Browser part is designed for use in a web application. A browser provides an area for grouping elements
and browsing back and forth. When you select the Browser web application template, a Browser part is
included automatically.

The Browser part includes JavaScript code to perform some standard actions. In particular, a browser supplies
a method you can use to reveal the next level in a hierarchy of information. Typically, you call the goForward
method in the controller code for a list part, assigning it to handle the onclick event associated with a list
row. The Browser part handles the analogous “go back” functionality automatically.

Canvas

The Canvas part is a custom drawing region you can add to your widget. “Using the Canvas” in WebKit DOM
Programming Topics discusses how to draw on a canvas using JavaScript.

Call Button

The Call button part is designed for use in a web application. A call button gives users a convenient way to
initiate a phone call. In the Attributes inspector, you can specify a default phone number to dial when users
tap the button.

The Call button part includes JavaScript code to perform some standard actions, such as methods to get and
set the phone number. If the button is enabled, the default action is to initiate a phone call to the currently
set phone number when the user taps it. You can use the setPhoneNumbermethod to allow users to change
the phone number dynamically.
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Column Layout

The Column Layout part is an area you can use for laying out content side by side. This part is especially
useful for web applications because each column can be set to position its content absolutely or relatively.

If, for example, you wanted to provide one column to display fixed-size images and another column to display
variably sized descriptions about the images, you could specify the first column to use absolute positioning
and the second column to use relative positioning. The Column Layout part handles much of this for you.

Edge-to-Edge List

The Edge-to-Edge List part provides a list format in which each row stretches from one side of its container
to the other. An edge-to-edge list contains a customizable row template that is used to create new rows in
the list.

You can specify static data to display in each row, or you can set up your web application to provide data
dynamically at runtime. If you’re using Dashcode version 3.0 and later, you can provide data dynamically
using data sources and bindings. To learn how to do this, see “Adding a Data Source” (page 62) and “Creating
Bindings” (page 63).

Alternatively, you can customize the list’s controller code to provide data dynamically at runtime. You can
set this in the Attributes inspector. The remainder of this section describes how to customize a list’s controller
code.

An edge-to-edge list that receives data dynamically needs a controller object (a static edge-to-edge list does
not need a controller object). The list controller object must implement two required data source methods:
numberOfRows and prepareRow. The numberOfRows callback method returns the total number of rows
in the list. The prepareRow method is called once for each row as it is being prepared and it uses the values
it is passed to populate the row. Specifically, the prepareRowmethod requires the following three arguments:

 ■ rowElement. This is the enclosing element for the entire row. You can use this element to install click
handlers for each row in the list.

 ■ rowIndex. This is the zero-based index of the row. You can use this value to find the appropriate row
data in application-specific data structures.

 ■ templateElements. This is a dictionary that contains an entry for each element in the template row
that has an ID. Each key in the dictionary is an ID and the associated value is the element within
rowElement that corresponds to the original template elements, such as rowTitle. You can use the
values associated with these elements to fill in the appropriate places in the row.

An edge-to-edge list also contains the public rows property, which gives you access to each row element in
the list. If the list is dynamic, you can use the rows property to view currently filled rows in your prepareRow
callback method while the list is filling, but you won’t be able to see all the rows until the list is completely
filled. For both static and dynamic lists, the rows property is most useful for getting access to specific rows
after the list is filled.

If your edge-to-edge list receives data dynamically, be sure to call the reloadData function to force the list
to reload and display the updated content. (Note that reloadData is called automatically when the list part
is initialized.) To do this, add this line of code to your list controller:
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document.getElementById("myList").object.reloadData();

Forward Button

The Forward button part is designed for use in web applications. A forward button gives users a convenient
way to move forward through the multiple levels of a web application.

Gauge

The Gauge part is a dial with a pointer that indicates a value in a range of values. You can edit a gauge’s
appearance and range of values using the Attributes inspector. If you’re using a gauge as a control, select
the Track Mouse Down option in the Attributes inspector and supply your own handler function for the
onchange event in the Behaviors inspector. Your handler is called whenever the gauge’s value changes.

If you’re using a gauge to graphically represent data, you need to update its value using JavaScript. Use the
setValue method to update a gauge’s value, as shown here:

document.getElementById("gauge").object.setValue(50);

Note that the value provided to setValue should lie within the range specified in the Attributes inspector
for the gauge.

Grid

The Grid part formats data in a grid of cells. You can edit a grid’s appearance, and specify whether it receives
data statically or dynamically, in the Attributes inspector.

Image

The Image part defines an area that receives an image at runtime (or, you can provide a static image resource
by specifying the source location in the Attributes inspector). You can adjust the style and effects applied to
the image in the Fill & Stroke inspector.

Indicator

The Indicator part is a light that changes color at different values. You can edit an indicator’s appearance
and range of values using the Attributes inspector.

When using an indicator, you need to update its value using JavaScript, as shown here:

document.getElementById("indicator").object.setValue(10);
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Note that the value provided to setValue should lie within the range specified in the Attributes inspector
for the indicator.

Level Indicators

The Horizontal and Vertical Level Indicator parts are linear indicators that show a value in a range of values.
You can edit a level indicator’s appearance and range of values using the Attributes inspector. If you’re using
a level indicator as a control, select the Track Mouse Down option in the Attributes inspector and supply
your own handler function for the onchange event in the Behaviors inspector. Your handler is called whenever
the level indicator’s value changes.

If you’re using a level indicator to graphically represent data, you need to update its value using JavaScript.
Use the setValue method to update a level indicator’s value, as shown here:

document.getElementById("horizontalLevelIndicator").object.setValue(10)

Note that the value provided to setValue should lie within the range specified in the Attributes inspector
for the level indicator.

Mail Button

The Mail button part is designed for use in a web application. A mail button gives users a convenient way
to initiate an email message. In the Attributes inspector, you can specify a default recipient (email address)
and subject to use when users tap the button.

The Mail button part includes JavaScript code to perform some standard actions, such as methods to get
and set the email address and to get and set the subject. If the button is enabled, the default action is to
open a message composing view, with the To and Subject fields filled in with the currently set address and
subject. You can use the setEmailAddress and setSubject methods to allow users to change the email
address and subject dynamically.

Map Button

The Map button part is designed for use in a web application. A map button gives users a convenient way
to view a map for a location. In the Attributes inspector, you can specify a default location to display when
users tap the button.

The Map button part includes JavaScript code to perform some standard actions, such as methods to get
and set the address to display. If the button is enabled, the default action is to display a map for the currently
set location. You can use the setAddress method to allow users to change the map location dynamically.
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Quartz Composer

The Quartz Composer part is an area that contains a Quartz Composer composition. To manipulate a
composition while your widget runs, use the Quartz Composer WebKit plug-in’s JavaScript API. You can learn
more about the Quartz Composer WebKit plug-in’s JavaScript API by reading Quartz ComposerWebKit Plug-in
JavaScript Reference.

QuickTime

Note:  The QuickTime part is deprecated in Dashcode 3.0. It is still supported in existing projects, but it is not
available in the Library. See “Video” (page 94) for information about a similar part you can use instead.

The QuickTime part is an area used for playback of QuickTime media. Use the QuickTime JavaScript methods
to control the playback of the movie or change its properties. To learn more about the QuickTime plug-in’s
JavaScript methods, read JavaScript Scripting Guide for QuickTime.

Rounded-Rectangle List

The Rounded-Rectangle List part provides a list in which a group of rows is inset from the edges of its container
and is bordered by a rounded rectangle. A rounded-rectangle list part contains a customizable row template
you can use to create new rows in the list.

You can specify static data to display in each row, or you can set up your web application to provide data
dynamically at runtime. If you’re using Dashcode version 3.0 and later, you can provide data dynamically
using data sources and bindings. To learn how to do this, see “Adding a Data Source” (page 62) and “Creating
Bindings” (page 63).

Alternatively, you can customize the list’s controller code to provide data dynamically at runtime. You can
set this in the Attributes inspector. The remainder of this section describes how to customize a list’s controller
code.

A rounded-rectangle list that receives data dynamically needs a controller object (a static rounded-rectangle
list does not need a controller object). The list controller object must implement two required data source
methods: numberOfRows and prepareRow. The numberOfRows callback method returns the total number
of rows in the list. The prepareRow method is called once for each row as it is being prepared and it uses
the values it is passed to populate the row. These values are passed to the prepareRow method in the
following three arguments:

 ■ rowElement. This is the enclosing element for the entire row. You can use this element to install click
handlers for each row in the list.

 ■ rowIndex. This is the zero-based index of the row. You can use this value to find the appropriate row
data in application-specific data structures.
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 ■ templateElements. This is a dictionary that contains an entry for each element in the template row
that has an ID. Each key in the dictionary is an ID and the associated value is the element within
rowElement that corresponds to the original template elements, such as rowTitle. You can use the
values associated with these elements to fill in the appropriate places in the row.

A rounded-rectangle list also contains the public rows property, which gives you access to each row element
in the list. If the list is dynamic, you can use the rows property to view currently filled rows in your prepareRow
callback method while the list is filling, but you won’t be able to see all the rows until the list is completely
filled. For both static and dynamic lists, the rows property is most useful for getting access to specific rows
after the list is filled.

If your rounded-rectangle list receives data dynamically, be sure to call the reloadData function to force
the list to reload and display the updated content. (Note that reloadData is called automatically when the
list part is initialized.) To do this, add this line of code to your list controller:

document.getElementById("myList").object.reloadData();

Split Layout

The Split Layout part is designed for use in Safari web applications. A split layout is an area that contains two
resizable views that are separated by a splitter. You can use the Attributes inspector to adjust the orientation
of the split layout and to determine which of the two resizable views is flexible (that is, can be completely
hidden when the window is resized).

Stack Layout

The Stack Layout part is designed for use in web applications. A stack layout is an area that contains views
that can be swapped.

You can use the Attributes inspector to add and remove views in the stack layout, and you can specify
transition styles to be used while swapping. For example, you can change the transition between views from
a push (in which the new view pushes the old view from the side) to a fade (in which the new view fades in
over the top of the old view).

Note:  Although you can adjust aspects such as color, background, or text attributes, it’s not recommended
to change the layout or margins of the stack layout’s built-in views. If you need margins, add a box part to
the view and change its margins.

Stack Layout Methods

A stack layout part includes a number of methods you can use to access its subviews and set transitions
between views. In particular, you can use:

 ■ getCurrentView. This method returns the currently active view.
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 ■ getAllViews. This method returns a JavaScript array of views in the stack layout. You might want to
use the index of the array to get the “next” view.

 ■ setCurrentView. This method takes the following parameters:

 ❏ newView. The new view to display.

 ❏ isReverse. A Boolean value that specifies whether the transition should be performed in reverse
(for example, the push transition defines a reverse transition).

 ❏ makeTopVisible. A Boolean value that specifies whether the new view should be scrolled to the
top.

The setCurrentView method sets the current view to the passed-in view and sets the transition and
scroll position appropriately.

 ■ setCurrentViewWithTransition. This method is similar to setCurrentView except that it includes
a transition parameter after the newView parameter that allows you to specify a transition. (See
“Stack Layout Transitions” for more information about transition objects.)

Stack Layout Transitions

The transition object handles transitions between views in a stack layout container. By default the transition
object handles a few transition types and a number of transition properties. Transition objects are created
with the Transition constructor function, as shown here:

Transition (type, duration, timing)

The parameters of the Transition function specify the type of transition, the length of time the transition
takes, and the acceleration curve of the transition. Note that you can also set these properties in the inspector
after a transition object has been created.

The available transition types are:

 ■ Transition.NONE_TYPE. The new view simply appears in place of the old view.

 ■ Transition.PUSH_TYPE. A two-dimensional transition in which the new view pushes the old view off
one edge of the screen.

 ■ Transition.DISSOLVE_TYPE. A two-dimensional transition in which the old view dissolves into the
new view.

 ■ Transition.SLIDE_TYPE. A two-dimensional transition in which the new view slides in over the old
view from one edge of the screen.

 ■ Transition.FADE_TYPE. A two-dimensional transition in which the new view fades in over the old
view.

 ■ Transition.FLIP_TYPE. A three-dimensional transition in which the old view flips over to reveal the
new view.

 ■ Transition.CUBE_TYPE. A three-dimensional transition in which the old view and new view appear
as if they are adjacent faces of a cube, which rotates to reveal the new view.

 ■ Transition.SWAP_TYPE. A three-dimensional transition in which both views move away from each
other horizontally and then swap positions vertically, leaving the new view on top.
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 ■ Transition.REVOLVE_TYPE. A three-dimensional transition in which the old view and the new view
share an axis on one edge, about which the old view revolves out as the new view revolves in.

The duration parameter should contain the number of seconds the transition should take, from start to
finish. Finally, for the timing parameter, you can specify a timing function that controls the speed and
acceleration of the transition (the timing functions are defined in the WebKit CSS animation specification).
The available transition timing functions are:

 ■ Transition.EASE_TIMING

 ■ Transition.LINEAR_TIMING

 ■ Transition.EASE_IN_TIMING

 ■ Transition.EASE_OUT_TIMING

 ■ Transition.EASE_IN_OUT_TIMING

The timing functions determine the acceleration curve of the transition. A linear curve means constant speed
(that is, no acceleration), and “ease” means gaining or losing speed gradually. For example, the
Transition.EASE_IN_TIMING function means that the transition starts slow and gradually gets faster,
whereas the Transition.EASE_OUT_TIMING function means that the transition gradually slows down near
the end.

You can also specify a direction for the Transition.PUSH_TYPE and Transition.SLIDE_TYPE transitions.
The available directions are:

 ■ Transition.RIGHT_TO_LEFT_DIRECTION

 ■ Transition.LEFT_TO_RIGHT_DIRECTION

 ■ Transition.TOP_TO_BOTTOM_DIRECTION

 ■ Transition.BOTTOM_TO_TOP_DIRECTION

Finally, you specify a direction for the four three-dimensional transitions. The available directions for these
transitions are:

 ■ Transition.RIGHT_TO_LEFT_DIRECTION

 ■ Transition.LEFT_TO_RIGHT_DIRECTION

The transition object includes the perform method that performs the transition. You pass in the following
parameters to the perform method:

 ■ newView. The view that will be visible after the transition.

 ■ oldView. The view that is visible now (before the transition).

 ■ isReverse. A Boolean flag that specifies whether the transition should be performed in reverse. (The
push transition, for example, can be performed in reverse; the cross-fade transition is the same either
way.)

The perform method ensures that the passed-in views share a common parent container element, which
is important because the transition is constrained by the dimensions of the parent container. In particular,
the container must constrain the transitions for overflow content.
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Note that you can use transition objects to pass in for the transition parameter of the stack layout
setCurrentViewWithTransition method. For more information about the stack layout methods, see
“Stack Layout Methods” (page 91).

Video

The video part is an area that handles video playback and provides playback controls.

The Video part uses the HTML 5 video element, which means that the video is embedded in the web-view
area and does not require the QuickTime plug-in to render it. This provides greater integration with the rest
of your web content and makes possible sophisticated layouts and effects.
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This table describes the changes to Dashcode User Guide.

NotesDate

Made minor corrections.2009-07-24

Updated for Dashcode 3.0.2009-06-08

Made minor corrections.2009-03-04

Corrected the description of web application deployment.2009-01-06

Updated for Dashcode 2.0.1.2008-09-09

Added a new tutorial for web applications and descriptions for new templates
and parts introduced in Dashcode 2.0.

2008-07-11

New document that describes how to create Dashboard widgets with Dashcode.2007-08-07
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