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INTRODUCTION

Introduction

To develop iOS applications, you use Xcode, Apple’s first-class integrated development environment (IDE).
Xcode provides all the tools you need to design your application’s user interface and write the code that
brings it to life. As you develop your application, you run it on your computer, an iPhone, an iPad, or an iPod
touch.

This document describes the iOS application development process. It also provides information about
becoming a member of the iPhone Developer Program, which is required to run applications on devices for
testing.

After you finish developing your iOS application, you submit it to the App Store, the secure marketplace
where iOS users obtain their applications. However, you should test your application on a small set of users
before publishing it to cover a wide variety of usage patterns and get feedback about your product. This
document describes how to create a group of testers for your application and how to distribute it to them.

To take advantage of this document, you should be familiar with the iOS application architecture, described
in iOS Application Programming Guide. You should also be familiar with basic programming concepts.

After reading this document, you'll have a basic understanding of the iOS application development process.
To enhance that knowledge, you should read the documents listed later in this introduction.

Software requirements: This document applies to the iPhone SDK 4.0 (with Xcode 3.2.3) distribution on
Mac OS X v10.6.

If you're interested in developing iOS web applications, visit http://developer.apple.com/safari/library.

Organization of This Document

This document contains the following chapters:

m "iOS Development Quick Start" (page 11) provides an overview of the major development tasks you
follow to design, build, and run an application using Xcode.

m "Configuring Applications" (page 25) describes how to configure your application’s properties and
entitlements, and how to adapt it so that it builds correctly in the iOS simulation and device environments.

= "Running Applications" (page 31) describes each of the steps required to run or debug your iOS
applications.

m "Using iPhone Simulator" (page 43) describes the ways in which you use your computer’s input devices
to simulate the interaction between iOS users and their devices.

= "Managing Devices and Digital Identities" (page 47) shows how to configure your computer and your
device for development; how to use the Xcode Organizer to view console logs or crash information, and
take screen shots of applications running on your device; and how to safeguard the digital identifications
required to install applications in development on devices.

Organization of This Document 9
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Introduction

"Debugging Applications" (page 55) describes the Xcode debugging facilities.

"Unit Testing Applications" (page 59) introduces unit testing and describes how you can take advantage
of it in your projects.

"Tuning Applications" (page 71) describes Instruments and Shark, the tools you use to measure and
tune your application’s performance.

"Distributing Applications" (page 73) describes how to create an archive of an application using a
distribution provisioning profile, and how to send it to application testers or submit it to iTunes Connect.
It also contains testing instructions for application testers.

"iOS Development FAQ" (page 81) lists common questions developers ask about iPhone Simulator.

"Hello, World! Source Code" (page 83) contains the source code for the Hello, World! application described
in "Tutorial: Hello, World!" (page 17).

"Unit-Test Result Macro Reference" (page 85) describes the test-result macros you can use in your unit-test
methods.

Installing the iPhone SDK

See Also

10

To install the tools you need to develop iOS applications, including Xcode, iPhone Simulator, and others, visit
http://developer.apple.com/iphone.

Note: The iPhone SDK requires an Intel-based Mac.

These documents describe the essential concepts you need to know about developing iOS applications:

iOS Technology Overview introduces iOS and its technologies.

iOS Application Programming Guide describes the architecture of an iOS application and shows the key
customization points in UIKit and other key system frameworks.

Cocoa Fundamentals Guide introduces the basic concepts, terminology, architectures, and design patterns
of the Cocoa frameworks and development environment.

The Objective-C Programming Language introduces object-oriented programming and describes the main
programming language used for iOS development.

Dashcode User Guide, which describes how to create webpages optimized for Safari on iOS. These web
applications make use of web technologies such as HTML, CSS, and JavaScript.

Installing the iPhone SDK
2010-07-02 | © 2010 Apple Inc. All Rights Reserved.
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CHAPTER 1

iOS Development Quick Start

Developing iOS applications is a pleasant and rewarding endeavor. To convert your ideas into products you
use Xcode, the integrated development environment (IDE) used to develop iOS applications. With Xcode
you organize and edit your source files, view documentation, build your application, debug your code, and
optimize your application’s performance.

Note: To develop iOS applications, you must be a registered Apple developer. To run applications on a
device, you must be a member of the iPhone Developer Program. For more information, see "Managing
Devices and Digital Identities" (page 47).

This chapter provides an overview of the major development tasks you follow to design, build, and run an
application using Xcode. It also includes a quick tutorial that shows how to develop the ubiquitous Hello,
World! application for iOS.

Essential Development Tasks

The iOS-application development process is divided into these major steps:
1. Create your project.

Xcode provides several project templates that get you started. You choose the template that implements
the type of application you want to develop. See "Creating an iOS-Application Project" (page 12) for
details.

2. Design the user interface.

The Interface Builder application lets you design your application’s user interface graphically and save
those designs as resource files that you load into your application at runtime. If you do not want to use
Interface Builder, you can layout your user interface programmatically. See “User Interface Design
Considerations” in iOS Application Programming Guide for more information.

3. Write code.

Xcode provides several features that help you write code fast, including class and data modeling, code
completion, direct access to documentation, and refactoring. See "Editing Code" (page 13) for details.

4. Build and run your application.

You build your application on your computer and run it in the iPhone Simulator application or on your
device. See "Building and Running Your Application" (page 16) for more information.

5. Measure and tune application performance.

Essential Development Tasks n
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After you have a running application, you should measure its performance to ensure that it uses a device’s
resources as efficiently as possible and that it provides adequate responses to the user’s gestures. See
"Measuring Application Performance" (page 17) for more information.

The rest of this section gives more details about these steps.

Creating an iOS-Application Project

The iPhone SDK provides several project templates to get you up and running developing your application.
You can choose from these types of application:

= Navigation-based Application. An application that presents data hierarchically, using multiple screens.
The Contacts application is an example of a navigation-based application.

= OpenGL ES Application. An application that uses an OpenGL ES-based view to present images or
animation.

= Split View-based Application. An iPad application that displays more than one view onscreen at a time
to, for example, present data in a master-detail or source list-style arrangement. The iPad Mail application
is an example of a split-view-based application.

= Tab Bar Application. An application that presents a radio interface that lets the user choose from several
screens. The Clock application is an example of a tab bar application.

= Utility Application. An application that implements a main view and lets the user access a flip-side view
to perform simple customizations. The Stocks application is an example of a utility application.

m View-based Application. An application that uses a single view to implement its user interface.

= Window-based Application. This template serves as a starting point for any application, containing an
application delegate and a window. Use this template when you want to implement your own view
hierarchy.

If you need to develop a static library for use in an iOS application, you can add a static library target to your
project by choosing Project > New Target and selecting the Static Library target template in the iPhone
0OS/Cocoa Touch list.

Static libraries used in iOS applications do not need to be code signed. Therefore, you should remove the
Code Signing Identity build setting definition from the static library targets you create. To do so:

1. Open the static-library target’s Info window and display the Build pane.

2. Inthe Code Signing group, select the Any iPhone OS Device conditional definition for the Code Signing
Identity build setting.

3. Change the conditional definition’s value from iPhone Developer to Don’t Code Sign.

To learn more about the iOS application architecture, see iOS Application Programming Guide.

To develop an iOS application, you work on an Xcode project. And you do most of your work on projects
through the project window, which displays and organizes your source files and other resources needed to
build your application. This window allows you to access and edit all the pieces of your project. Figure 1-1
shows the project window.

Essential Development Tasks
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Figure 1-1 Project window
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Detail view

The project window contains the following key areas for navigating your project:

= Groups & Files list. Provides an outline view of your project’ contents. You can move files and folders
around and organize your project contents in this list. The current selection in the Groups & Files list
controls the contents displayed in the detail view.

m Detail view. Shows the item or items selected in the Groups & Files list. You can browse your project’s
contents in the detail view, search them using the search field, or sort them according to column. The
detail view helps you rapidly find and access your project’s contents.

= Toolbar. Provides quick access to the most common Xcode commands.

= Favorites bar. Lets you store and quickly return to commonly accessed locations in your project. The
favorites bar is not displayed by default. To display the favorites bar, choose View > Layout > Show
Favorites Bar.

m Status bar. Displays status messages for the project. During an operation—such as building or
indexing—Xcode displays a progress indicator in the status bar to show the progress of the current task.

To learn more about creating projects, see “Creating Projects”.

Editing Code

The main tool you use to write your code is the Xcode text editor. This advanced text editor provides several
convenient features:

= Header-file lookup. By Command-double-clicking a symbol, you can view the header file that declares
the symbol.

Essential Development Tasks 13
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= APl reference lookup. By Option-double-clicking a symbol, you get access to API reference that provides
information about the symbol’s usage.

= Code completion. As you type code, you can have the editor help out by inserting text for you that
completes the name of the symbol Xcode thinks you're going to enter. Xcode does this in an unobtrusive
and overridable manner.

= Code folding. With code folding, you can collapse code that you're not working on and display only the
code that requires your attention.

For details about these and other text editor features, see “The Text Editor”.

Using Code Completion

The text editor helps you type code faster with code completion. When code completion is active, Xcode
uses both text you have typed and the context into which you have typed it to provide suggestions for
completing the token it thinks you intend to type. Code completion is not active by default.

To activate code completion:
1. Open the Xcode Preferences window.
Choose Xcode > Preferences.

2. In the Code Completion section of the Code Sense pane, choose Immediate from the Automatically
Suggest pop-up menu.

3. Click OK.
As you type the name of a symbol, Xcode recognizes that symbol and offers a suggestion, as shown in Figure

1-2. You can accept suggestions by pressing Tab or Return. You may also display a list of completions by
pressing Escape.

Figure 1-2 Using code completion

&®HOO m MyView.m =

oA —
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B B MyView.m:25:32 3 [ -drawRect: § « " Ce ¥ B &
21 B
22
23 - (voidddrowRect:(CGRect)rect {
24 NSString *hello = @"Hello, World!"; D
25 CGPoint locotion = CGPointMake( CGFloat x, CGFloat v )
26 }
27

A

To learn more about code completion, see “Completing Code” in Xcode Workspace Guide.

14 Essential Development Tasks
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Accessing Documentation

During development, you may need fast access to reference for a particular symbol or high-level
documentation about APl usage or an iOS technology. Xcode gives you easy access to such resources through
the Research Assistant and the Documentation window.

The Research Assistant is a lightweight window, shown in Figure 1-4 (page 16), that provides a condensed
view of the API reference for the selected item, without taking your focus away from the editor in which the
item is located. This window provides an unobtrusive way to consult API reference. However, when you need
to dig deeper into the reference, the Documentation window is just a click away.

The Documentation window (Figure 1-3) lets you browse and search the developer documentation (which
includes API reference, guides, and articles about particular tools or technologies) installed on your computer.
It provides access to a wider and more detailed view of the documentation than the Research Assistant, for
the times when you need additional help.

Figure 1-3 Viewing API reference in the Documentation window
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Location | Document Title
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» Apple Xcode 3.1 | SUBSCRIEE | T UlvView Class Reference
. Apple iPhone 05 2.0 R R TS TS P S
. Apple iPhone 05 2.2 - # UlTouch Class Reference 3 <No selected symbol=> e -
. Apple iPhone 05 2.2.1 UlTouch Class Reference ['j PoF
Apple iPhone 05 3.0 {suescrize || * Table of Contents [ Jump To... 3] 4 Previous | Next »
v Apple iPhone 05 3.1 Q
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Xcode Build Settings Notes
Xcode Expert Preferences Notes Inherits from NSObject
Xcode 3.0 Release Notes . .
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Availability Available in iPhone OS5 2.0 and later.
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To display the API reference for a symbol in a source file, you select the symbol in the text editor and choose
Help > Find Selected Text in APl Reference (you can also Option-double-click the symbol name). This command
searches for the selected symbol in the API reference for your project’s SDK and displays it in the
Documentation window. For example, if you select the UTFont class name in a source file and execute the
Find Selected Text in API Reference command, Xcode opens the Documentation window and displays the
API reference for the UIFont class.

Essential Development Tasks 15
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While the Documentation window is a great tool to browse the iOS documentation library, sometimes you
may not want to take your focus away from the text editor while you write code, but need basic information
about a symbol in a condensed way. The Research Assistant provides such information in a small and
unobtrusive window.

The Research Assistant actively follows you as you move the cursor around a source file. When it recognizes
a symbol for which it finds API reference, the Research Assistant displays that reference, as shown in Figure
1-4. All you have to do is glance at the Research Assistant to get essential details about the symbol.

To display the Research Assistant, choose Help > Show Research Assistant.

Figure 1-4 Viewing API reference in the Research Assistant
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26 UIFont *font = [UIFont systemFontOfSize: (CGFloat)fontSize 2
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b ¥ Related APl 2 items
boldSystemFontOfSize
italicSystemFontOfSize:
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A

From the Research Assistant you can quickly jump to more comprehensive reference for the symbol, or even
view the header that declares it.

For more information about accessing documentation in Xcode, see Documentation Access.

Building and Running Your Application

iPhone Simulatorimplements the iOS API, providing an environment that closely resembles the environment
devices provide. It allows you to run your applications in Mac OS X, letting you quickly test application
functionality when you don't have a device available. However, running applications in iPhone Simulator is
not the same as running them in actual devices. iPhone Simulator does not emulate device performance: It
doesn't implement the memory constraints or processor performance of an actual device. First, the simulator
uses Mac OS X versions of the low-level system frameworks instead of the versions that run on the devices.
Secondly, there may be hardware-based functionality that’s unavailable on the simulator. But, in general,
the simulator is a great tool to perform initial testing of your applications.

To get an accurate idea of how your application performs on a user’s device, you must run the application
on a device and gather performance data using Instruments and other performance-measuring tools.

Essential Development Tasks
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To compile and debug your code, Xcode relies on open-source tools, such as GCC and GDB. Xcode also
supports team-based development with source control systems, such as Subversion, CVS, and Perforce.

Building your application involves the following steps:

m  Compiling your source files and generating your application binary.

m Placing the binary in iPhone Simulator or on your device.

Xcode performs these tasks for you when you execute the Build command. See "Running Applications" (page
31) for details.

Measuring Application Performance

After you have tested your application’s functionality, you must ensure that it performs well on a device. This
means that the application uses the device’s resources as efficiently as possible. For example, memory is a
scarce resource; therefore, your application should maintain a small memory footprint not to impair the
performance of iOS. Your application should also use efficient algorithms to consume as little power as
possible not to reduce battery life. Xcode provides two major tools to measure and tune application
performance: Instruments and Shark.

The Instruments application is a dynamic performance analysis tool that lets you peer into your code as it's
running and gather important metrics about what it is doing. You can view and analyze the data Instruments
collects in real time, or you can save that data and analyze it later. You can collect data about your application’s
use of the CPU, memory, the file system, and the network, among other resources.

The Shark application is another tool that helps you find performance bottlenecks in your code. It produces
profiles of hardware and software performance events and shows how your code works as a whole and its
interaction with iOS.

See "Tuning Applications" (page 71) for more information.

Further Exploration

To learn more about the Xcode development process, see A Tour of Xcode.

Tutorial: Hello, World!

This tutorial guides you through the creation of a simple project that prints text on the iPhone screen.

Create the Project

To create the Hello World project, follow these steps:

1. Launch the Xcode application, located in <Xcode>/Applications.

Tutorial: Hello, World! 17
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<{Xcode> represents the directory in which you installed the Xcode toolset. See “Xcode Installation
Details” for more information.

2. Choose File > New Project.

3. Select the Window-Based Application template, choose iPhone from the Product pop-up menu, and
click Choose.

000 New Project

Choose a template for your new project:

iPh 0s
- = o

Application v
Library
al Navigation- OpenGL ES Split View- Tab Bar
Mac Os X based Application based Application
Application Application
Application
Framework & Library
Application Plug-in [ - <
System Plug-in .
Other Utility View-based Window-based
Application Application Application
Product [ iPhone r:]

("] Use Core Data for storage

} Window-based Application

This template provides a starting point for any application. It provides just an
application delegate and a window.

( Cancel ) (Choose...)

/.

4. Name the project Hel1oWor1d and choose a location for it in your file system.
5. Add the MyView class to the project.

a. Choose File > New File.

18 Tutorial: Hello, World!
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b. Select the Cocoa Touch UlView subclass template and click Next.

AOO New Project

Choose a template for your new project:

iPh 0os
- - g L@

Application “
Library —
s Navigation- OpenGL ES Split View- Tab Bar
Mac OS X based Application based Application
Application Application
Application
Framework & Library "
Application Plug-in - =
System Plug-in | ~
Other Utility View-based Window-based
Application Application Application
Product [iPhone &

(] Use Core Data for storage

i Window-based Application

This template provides a starting point for any application. It provides just an
application delegate and a window.

( Cancel ) (Choose...)
VA

c. In the File Name text field, enter MyView.m.

d. Select the “Also create "MyView.h"” option and click Finish.

Choose the active SDK for your project and the destination for the application.

To set the active SDK:

a. Choose Project > Edit Project Settings.

Tutorial: Hello, World!
2010-07-02 | © 2010 Apple Inc. All Rights Reserved.



CHAPTER 1
iOS Development Quick Start

b. Choose the SDK from the Base SDK for All Configurations pop-up menu.

OO Project “HelloWorld” Info

[ General Build Configurations = Comments }

Base SDK for All Configurations: | iPhone Device 4.0 ﬂ

(_Rebuild Code Sense Index)

Note: If you have a development device plugged in, Xcode chooses the latest iPhone Device SDK for
you. Otherwise, Xcode chooses the latest iPhone Simulator SDK.

To use an iPhone Device SDK you must be a member of the iPhone Developer Program. For more
information, see "Becoming a Member of the iPhone Developer Program" (page 47).

The product destination specifies the type of environment for which Xcode builds your application and
where to install it. If you have a development device plugged in at the time you create the project, Xcode
sets the product destination to Device. Otherwise, it sets the destination to Simulator.

To set the product destination, choose between Device and Simulator from the Overview toolbar menu
in the project window. If you have more than one device connected, specify the device onto which to
install your application by choosing it from the Active Executable section of the Overview toolbar menu.

o006 [ Helloworld (@)
| Device - 4.0 | Debug | ... ~J - & @ ' o Q~ String Matching
_] v Device 'on Build and Run  Breakpoints Tasks Info Search
C Simulator | File Name 4 A Code o A 0O
H| MyView.h
Active ( ;ﬂ MyView.m v o
v Debug
Release
ve T
v A HelloWorld
HelloWorld - iPod_dev

v HelloWorld - Ernest_iPad

v armvéb
armv?7

» (3] Implementation Files
> (& NIB Files

20 Tutorial: Hello, World!
2010-07-02 | © 2010 Apple Inc. All Rights Reserved.



CHAPTER 1
iOS Development Quick Start

Write the Code

The Xcode text editor is where you spend most of your time. You can write code, build your application, and
debug your code. Let’s see how Xcode assists you in writing code.

To experience the Xcode source-code editing features, you should perform the following instructions to
enter the application’s source code. For your convenience, "Hello, World! Source Code" (page 83) includes
the final source code.

First, modify the He11oWor1dAppDelegate class to use the MyView class:
1. Inthe Groups & Files list, select the HelloWorld project.
2. In the detail view, double-click He1ToWorT1dAppDelegate.m.
3. IntheHelloWorldAppDelegate editor window:
a. Add the following code line below the existing #import line.
fHimport "MyView.h"

b. Add thefollowing codelinestothe application:didFinishLaunchingWithOptions: method,
below the override-point comment.

MyView *view = [[MyView alloc] initWithFrame:[window framel];

[window addSubview:view];
[view releasel;

After making these changes, the code in the HelloWor1dAppDelegate.m file should look similar to this:

#import "HelloWorldAppDelegate.h"
#import "MyView.h"

@implementation HelloWorldAppDelegate
@synthesize window;

- (BOOL)application:(UIApplication *)application
didFinishLaunchingWithOptions: (NSDictionary *)launchOptions {

// Override point for customization after application launch
MyView *view = [[MyView alloc] initWithFrame:[window framel];
[window addSubview:view];

[view release];

[window makeKeyAndVisible];
return YES;

- (void)dealloc f{
[window releasel;
[super dealloc];

@end

Tutorial: Hello, World! 21
2010-07-02 | © 2010 Apple Inc. All Rights Reserved.



22

CHAPTER 1
iOS Development Quick Start

Listing 1-1 shows the code that draws “Hello, World!” in the window. Add the highlighted code lines to the
drawRect: method in the MyView.m file.

Listing 1-1 Method to draw “Hello, World!” in a view

- (void) drawRect:(CGRect) rect f{
NSString *hello = @"Hello, World!";
CGPoint 1location = CGPointMake(10, 20);
UIFont *font [UIFont systemFont0fSize:24.0];
[[UIColor whiteColor] set];
[hello drawAtPoint:location withFont:font];

}

If you turned on code completion (as described in "Using Code Completion" (page 14)), as you type symbol
names the text editor suggests completions for the symbol names it recognizes. For example, as you type
CGPointM, the text editor suggests the completion shown in Figure 1-2 (page 14). You can take advantage
of completion here by accepting the suggested completion and jumping to the parameter placeholders:

1. Jump to the first parameter by choosing Edit > Select Next Placeholder, and type 10.

The Select Next Placeholder command moves you among the arguments in function or method calls
that the text editor suggests as completions to the text you're typing.

2. Jump to the second parameter and type 20.

3. Enter the semicolon (;) at the end of the line and press Return.

Run the Application

To build and run the Hello World application, choose Build > Build and Run (or click the Build and Run toolbar
item in the project window). If there are no build errors, Xcode installs the application in iPhone Simulator
or your device (depending on the active SDK setting).

Tutorial: Hello, World!
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Hello, World!

Troubleshooting Hello, World! Build Errors

This section contains possible build errors for the Hello, World! project and their cause.
Building ... — 2 errors
Compiling <project_directory>/Classes/HelloWorldAppDelegate.m (2 errors)
error: 'MyView' undeclared (first use in this function)
error: 'view' undeclared (first use in this function)
Fix this build error by adding the line
f#Fimport "MyView.h"
tothe HelloWorldAppDelegate.mfile.

To learn about other possible build errors, see "Solving Build Errors" (page 38).

Further Exploration

Now that you learned how to write the standard Hello, World! application for iOS, you can experiment with
HelloWorld, the Cocoa Touch version of this ubiquitous application.

For a step-by-step tutorial in developing a more complex application, see Your First iOS Application.
To learn more about Objective-C, see Learning Objective-C: A Primer.

To learn more about developing iOS applications, see iOS Application Programming Guide.
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This chapter describes how to set up your application’s properties to customize its runtime environment,
configure its entitlements to take advantage of iOS security features, and how to adapt its build process for
different SDKs and architectures.

This chapter also shows how to upgrade a target that builds an iPhone application into either a target that
builds an application optimized for iPhone and iPad, or two targets, one to build an iPhone application and
one to build an iPad application.

To learn how to set up a device for development, see "Managing Devices and Digital Identities" (page 47).

Editing Property-List Files

Property-list files are XML files that organize data into named values and lists of values using simple data
types. These data types let you create, transport, and store structured data in an accessible and efficient way.
Xcode uses two main types of property-list file to store runtime-configuration information for your application:

= Information-property list. These files, commonly referred to as info-plist files, contain essential information
used by your application and iOS. See “The Information Property List” in iOS Application Programming
Guide for information about the application properties defined in info-plist files.

= Entitlements. These files define properties that provide your application access to iOS features (such as
push notifications) and secure data (such as the user’s keychain).

To learn more about property-list files, see Property List Programming Guide.
To edit a property-list file, perform one of these actions:

= To edit it in the editor pane of the Project window, select the file in the Groups & Files list or in the detail
view.

m To edit it in a dedicated editor window, double-click the file in the Groups & Files list or in the detail
view.

For more information about the Groups & Files list, see “Project Window Components” in Xcode Workspace
Guide.

Figure 2-1 shows a property-list editor window with an info-plist file.

Editing Property-List Files 25
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Figure 2-1 Property-list editor window with an info-plist file

<4  » | MyApp-Info.plist % o o™ Cv | #v =
Key Value
¥ Information Property List (12 items)
Localization native development region English
Bundle display name ${PRODUCT _MNAME}
Executable file S{EXECUTABLE_NAME}
Icon file
Bundle identifier com.yourcompany. 5{PRODUCT_NAME:rfc1034identifier}
InfoDictionary version 6.0
Bundle name £{PRODUCT _MAME}
Bundle OS Type code APPL
Bundle creator OS Type code 7
Bundle version L0
Application requires iPhone envirenment E
Main nib file base name MainWindow

A

Each row in the file specifies a property definition (or key/value pair). Key cells specify property names (and
their data types). Value cells specify property values.

These are the property-list editing actions you can perform with the property-list editor:

= Add a sibling property. With a row selected and its disclosure triangle closed, click the Add Sibling
button (shown in Figure 2-2) or press Return to add a sibling to the property.

Figure 2-2 Adding a sibling property in the property-list editor

< | » B MyApp-info.plist 3 [ [ Co| #+ -
Key Value
w Information Property List (1 item)

InfoDictionary version

6.0 +|
L3

After adding the sibling, choose the property type from the property-type menu in the key cell, as shown
in Figure 2-3.
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Figure 2-3 Specifying a property’s type in the property-list editor

B MyApp-info.plist 3 - ] 2_|=|c |#.|® |a&

Key Value

w Infarmation Property List (2 items)

InfoDictionary version 6.0

Bundle identifier B

Localized resources can be mixed —

Main nib file base name
Renders with edge antialisasing

A
_‘ Renders with group opacity —

Required device capabilities

Status bar is initially hidden

Status bar style

Supported external accessory protocols

Upgrade other bundle identifier &
-

m Add a child property. With a row with a multi-value property—a property whose value is a list of
values—selected and its disclosure triangle open, click the Add Child button (shown in Figure 2-4) or
press Return to add a child to the property.

Figure 2-4 Adding a child property in the property-list editor

< | » | B MyApp-Info.plist 3 L ™% | Cv| #+ -
Key Value
w Information Property List (2 items)
InfoDictionary version 6.0
w URL types 2 (1 item) Ek
B ltem 1 (1 item)
A

= Delete property. With a row selected, press Delete to delete the row.

To make editing property-list files convenient and to ensure the file’s structure is correct, the property-list
editor uses property-list-file schemas to display property names in the Key column, and formatted values
(such as check boxes for Boolean values) in the Value column. However, you may want to see the properties’
key names and values in their XML (or “raw”) form. To toggle between viewing the formatted keys and values
and their raw form, toggle the Show Raw Keys/Values option of the property-list editor shortcut menu.

Managing Application Entitlements

iOS provides access to special resources and capabilities—such as whether your application can be
debugged —through properties called entitlements. To specify entitlement information in your application,
you add an entitlement property-list file containing entitlement definitions (key/value pairs) to your project.
When you build your application, Xcode copies the file to the generated application bundle.

Managing Application Entitlements 27
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To add an entitlements property-list file to your project:

1.

2.

In the Groups & Files list, select the Resources group.

Choose File > New File.

Choose the iPhone OS > Code Signing > Entitlements template.

Name the file Entitlements.plist.(You can use any name; just ensure it matches the value of the
Code Signing Entitlements build setting, as explained later in this section.)

Set the type of the property-list file to iPhone Entitlements.

With the file selected in the text editor, choose View > Property List Type > iPhone Entitlements plist.

®00

Groups & Files il

v 55 MyApp B
B| | Classes
»| | Other Sources

¥| | Resources

[] Mainwindow.xib

E| Info.plist

. Entitlements.plist ‘:
»| | Frameworks I

k| 'File Name

. Entitlements.plist

< | = [ Entitlements.plist

n

¥

-

Key Value
wiPhone Entitlements (1 item)
Can be debugged W

6. Add your entitlement entries to the file.

For each entitlement property you need to define:

a. Click the Add Child or Add Sibling buttons to the right of the selected row. The Add Child button
has three lines depicting a hierarchy, the Add Sibling button has a plus (+) sign on it.

b. Choose the entitlement property from the pop-up menu that appears.

If the entitlement you need to add doesn’t appear in the menu, choose View > Property List Type
> Default for File Type. Then enter the entitlement-key name and type.

Managing Application Entitlements
2010-07-02 | © 2010 Apple Inc. All Rights Reserved.

Enter the value for the property.



CHAPTER 2
Configuring Applications

7. Setthe Code Signing Entitlements build setting for the target to the name of the newly added entitlements
property-list file.

0 Target "MyApp" Info

r General Build Rules Properties Comments }

Configuration: [ a1 Configurations :] (Q~ Search in Build Settings

Show: [ All Settings :]

[ Setting Value
¥ Code Signing
Code Signing Entitlements Entitlements.plist
¥ Code Signing Identity v
Any iPhone OS5 Device + iPhone Developer .
Code Signing Resource Rules Path H
Other Code Signing Flags

Conditionalizing Compilation and Linking

The two iOS runtime environments are the simulation environment and the device environment. You use
the former to test your application on your Mac, and the latter to test it on a device. These environments are
fundamentally different; therefore, when using technology that’s implemented differently in the two
environments you need to tweak your code so that some of it runs in iPhone Simulator application but not
on a device.

This section shows how to target code to iPhone Simulator or a device and which frameworks (or libraries)
to link, depending on whether the active SDK belongs to the iPhone Simulator SDK family or the iPhone
Device SDK family.

Compiling Source Code Conditionally for iOS Applications

There may be times when you need to run code on the simulator but not on a device, and the other way
around. On those occasions, you can use the preprocessor macros TARGET_0S_IPHONE and
TARGET_IPHONE_SIMULATOR to conditionally compile code.

Listing 2-1 shows how to use the TARGET_IPHONE_SIMULATOR macro to determine whether code meant
for iOS is being compiled for the simulator or devices.

Listing 2-1 Determining whether you're compiling for the simulator

// Set hello to "Hello, <device or simulator>"!
##if TARGET_IPHONE_SIMULATOR
NSString *hello = @"Hello, iPhone Simulator!";

felse
NSString *hello = @"Hello, i0S device!";
ffendif
Listing 2-2 shows how to use the TARGET_OS_TPHONE macro in a source to be shared between Mac OS X
and iOS.
Conditionalizing Compilation and Linking 29
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Listing 2-2 Determining whether you're compiling for iOS

#if TARGET_OS_IPHONE
#import <UIKit/UIKit.h>
ffelse
##import <Cocoa/Cocoa.h>
ffendif

The TARGET_OS_IPHONE and TARGET_IPHONE_SIMULATOR macros are defined in the
TargetConditionals.h header file.

Linking Frameworks Conditionally for iOS Applications

There may be occasions when you need to configure your application target so that it links against one
framework to run on the simulator and a different framework to run on a device.

To link a framework only when using a particular SDK, set the Other Linker Flags build setting in all
configurations for the SDK you want the definition to apply to - framework <framework_name>.

If you need to, you can add another condition to the Other Linker Flags build setting to specify a different
SDK and framework.

See “Editing Conditional Build Settings” in Xcode Project Management Guide for details about defining build
settings for particular SDKs.

Upgrading a Target from iPhone to iPad

30

If you have an iPhone application that you want to upgrade to run on iPad devices you need to upgrade the
target that builds your iPhone application into a target that can build both an iPhone and an iPad application,
or add a target to your project for building the iPad application.

To upgrade an iPhone target for iPad development, select the target in the Groups & Files list and choose
Project > Upgrade Current Target for iPad.

For details about iPad-application development, see iPad Programming Guide.

Upgrading a Target from iPhone to iPad
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When you're ready to run or debug your application, you build it using the Xcode build system. If there are
no build errors, you can run it in iPhone Simulator or on a device.

Note: After testing your application in iPhone Simulator, you must test it on an iOS-based device to measure
and tune its performance. To be able to run your application on a device, you must be a member of the
iPhone Developer Program; see "Becoming a Member of the iPhone Developer Program" (page 47) for details.

The iPhone SDK comprises two SDK families: The iPhone Simulator SDK and the iPhone Device SDK.

= iPhone Simulator SDK: These SDKs build applications that run in iPhone Simulator.

= iPhone Device SDK: These SDKs build applications that run in a device.

These are steps you follow to build and run applications:
1. Specify the buildtime environment.

2. Specify the runtime environment.

3. Setthe Base SDK.

4. Specify where to run the application.

5. Build the application.

6. Run the application.

This chapter describes each of the steps required to run or debug your application. Start with "Running
Sample Applications" (page 31) if you're interested in seeing applications that showcase iOS features.

Running Sample Applications

The iPhone Dev Center provides several resources that help you learn about the iOS application-development
process. One of these resource types is sample code. You can download sample code to your computer and
run it in iPhone Simulator. If you're an iPhone Developer Program member, you can also run sample code
on your device. See "Becoming a Member of the iPhone Developer Program” (page 47) for details.

To run sample code:

1. Download the ZIP archive (the file with the . z1p suffix) containing the sample code you want to use.
The archive is named after the application name; for example, HelloWorld.zip.

Running Sample Applications 31
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2. If you download the sample-code projects from the Xcode Documentation window, Xcode expands the
archive and opens the project automatically. Otherwise, continue to the next step.

3. Expand the archive by double-clicking it.

4. Navigate to the sample-code project directory, also named after the example application; for example,
HelloWorld.

5. Double-click the project package, a file with the . xcodeproj suffix. For example,
HelloWorld.xcodeproj. This action opens the project in Xcode.

Troubleshooting: Xcode doesn’t launch: If Xcode doesn’t launch, you need to download it and install
it on your computer. To download Xcode, visit iPhone Dev Center.

With the sample-code project open in Xcode, follow the instructions in the following sections to build and
run the application.

Specifying the Buildtime Environment

32

When you build your application, Xcode uses a build environment made up of frameworks, libraries,
applications, command-line tools, and other resources. Each release of the iPhone SDK makes improvements
to this environment to, for example, add user-interface features or improve compilers and resource-processing
tools. In addition to these resources, you can specify whether you want to build your application to debug
it or to distribute it to customers. This section describes how to set your buildtime environment.

Setting the Base SDK

One of the main factors that determine how Xcode builds your application is the SDK used to build it. As
described earlier, iPhone SDKs come in two families: one to target devices and one to target iPhone Simulator.
Applications built using an SDK from the iPhone Device SDK family can run only on iOS-based devices.
Conversely, applications built using an SDK from the iPhone Simulator SDK family run only in iPhone Simulator.

You specify the SDK Xcode uses to build your application in your project’s Base SDK build setting, which you
can set in the General pane of the Project Info window or in the Build pane of the Project or Target Info
window. Figure 3-1 shows the Base SDK for All Configurations pop-up menu in the General pane of the
Project Info window.

Specifying the Buildtime Environment
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Figure 3-1 Base SDK for All Configurations pop-up menu in the Project Info window

Current Mac O5

Mac OS5 X S5DKs
Mac O5 X 10.5
Mac OS5 X 10.6

Phone OS Device SDKs

iPhone Device 3.2
¥ iPhone Device 4.0

05 Simulator SDKs

iPhone Simulator 3.2
iPhone Simulator 4.0

Important: In addition, applications built using a particular version of an SDK-such as iPhone SDK 3.2, which
targets iOS 3.2-may not run reliably on versions of the OS (on the iPhone Simulator or a device) that are
earlier than its corresponding SDK. That is, if you want to run your application on iOS 3.1.3, for example, you
must build it using iPhone SDK 3.1.3.

Setting Your Code Signing Identity

When you build your application to run it on a device, Xcode signs it with a development certificate (also
known as a code signing identity) stored on your keychain. To learn how to obtain and install development
certificates, see "Preparing Your Mac for iOS Development" (page 47).

The Code Signing Identity build setting specifies the code signing identity Xcode uses to sign your binary.
Xcode looks for code signing identities in your default keychain. Figure 3-2 shows an example set of options
for the Code Signing Identity build setting obtained from the login (default) keychain shown in Figure 3-3
(the name of the default keychain appears bold in the Keychains list).
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Figure 3-2 Code Signing Identity build setting options

1 General | Build @ Configurations Comments

Configuration: | All Configurations E (Qv Search in Build \
show

Setting | value

Y Architectures
Architectures Standard (armv6 armv7) &
Base SDK

~ Don't Code Sign
¥ Code Signing |
¥ Code Signing Identity Automatic Profile Selector (Recommended)
¢ iPhone Developer (currently matches 'iPhone Developer: Ernest Bruce (PMAB48EEDS)’ in "Team Provisioning Profile: *}
¥lLinking iPhone Distribution
Prebinding
YGCC 4.2 - L
C Language Dialect
¥GCC 4.2 - Warnings |
Mismatched Return Type Qiher.

Unused Variables E "_

Team Provisioning Profile: * (for Application Identifiers '*")
iPhone Developer: Ernest Bruce (PMAS4BEGDY) (current Automatic selection)

The name (*common name”) of a valid code-signing certificate in a
keychain within your keychain path. A missing or invalid
certificate will cause a build error. [CODE_SIGN_IDENTITY]

Based On: | Nothing s ®

Figure 3-3 A keychain with a developer certificate
666 Keychain Access
Q

Keychains
& login = iPhone Developer: Ernest Bruce (PMAB48EGD9)
& System abond . Issued by: Apple Worldwide Developer Relations Certification Authority
) System Roots © 4| FExpires: 2011-05-24 14:02:11 PT

@ This certificate is valid

Category
A Alliems N: 4 Kind Expires Keychain
. Passwords [Z] Apple Mac Certificate Authority certificate 2011-11-10 12:38:27 login

Secure Notes B E¥ iPhone Developer: Ernest Bruce (PMAS4BEEDI) certificate 2011-05-24 14:02:11 login
E] My Certificates » [5] iPhone Distribution: Apple Inc. - Dev Pubs Writers certificate 2011-05-24 20:22:11 login
? Keys
1= Certificates

These are the possible values for the Code Signing Identity build setting:

= Don’t Code Sign. Choose this option if you don't want to sign your binary. Note that with this value,
when you build your applications using the iPhone Device SDK the build fails.

= Automatic Profile Selectors. These choices look for an identity whose name starts with “iPhone Developer”
or “iPhone Distribution.”

= A code signing identity. A specific code signing identity. The code signing identities in your default
keychain are listed under the name of the provisioning profile under which you downloaded them from
the iPhone Provisioning Portal. Expired or otherwise invalid identities are dimmed and cannot be chosen.

34 Specifying the Buildtime Environment
2010-07-02 | © 2010 Apple Inc. All Rights Reserved.



CHAPTER 3

Running Applications

Xcode project templates are configured to use the iPhone Developer automatic selector.

Important: If need to use different code signing identities with the same name, you must use a separate
Mac OS X user account for each identity.

Setting the Architecture

An iOS device uses one of a set of architectures, which include armv6 and armv7. The Architectures build
setting identifies the architectures for which your application is built. You have two options for specifying
the value of this setting:

= Standard. Produces an application binary with a common architecture, compatible with all supported
iOS devices. This option generates the smallest application, but it may not be optimized to run at the
best possible speed for all devices.

= Optimized. Produces an application binary optimized for each supported iOS device. However, the build
time is longer than when using the Standard option, and the application is also larger because multiple
instruction sets are bundled into it.

Choose the value for the Architecture build setting in the Build pane of the Target or Project Info window.

If you need to build your application so that it contains executable code for a different set of architectures
than these predefined values offer, you can choose Other from the Architecture build-setting value list and
enter the desired iOS-device architecture names.

Setting the Active Build Configuration

A build configuration tells Xcode the purpose of the built product. Xcode project templates are configured
with Debug and Release configurations, which let you build your application for debugging or for release to
customers, respectively. Debug builds include information and features that aid in debugging your application.
Release builds produce smaller and faster binaries. During early and midlevel development, you should use
the Debug configuration because it provides the best debugging experience. You should use the Release
configuration in the last stages of development to measure and analyze your application’s performance.

When you start a build process, Xcode uses the active build configuration to build your application. There
are two places you can set the active build configuration:

= In the Set Active Build Configuration submenu in the Project menu

= In the Overview pop-up menu in the toolbar

To learn more about the Release and Debug configurations, see “Building Products”.

Setting the Device Family

The device family identifies the type of devices you want the application to run on. There are two device
families: iPhone, and iPad. The iPhone device family includes iPhone and iPod touch devices. The iPad device
family includes iPad devices.
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To specify the device families on which you want your application to be able to run:
1. Open the Project Info or Target Info window.

2. In the Build pane, locate the Targeted Device Family build setting and choose an appropriate value for
it.

.00 Project "HelloWorld” Info

| General | Build = Configurations = Comments '

Configuration: | All Configurations T] Qy Search in Build Settings

Show: | Settings Defined at Thi... T]

Setting Value

Architectures

Architectures Optimized (armv6 armv7)

Base SDK iPhone Device 3.2
Code Signing

Code Signing Identity

Any iPhone OS Device ; iPhone Developer
Deployment
| v iPhone

iPhone OS Deployment Target iPad
Linking iPhone/iPad

Prebinding L&)

Table 3-1 lists the values you can specify for the Targeted Device Family build setting. It also indicates the
device family the built application is optimized for.

Table 3-1 Values for the Targeted Device Family build setting

Value Application is optimized for
iPhone iPhone, and iPod touch
iPad iPad

iPhone/iPad | iPhone, iPod touch, and iPad (universal application)

Specifying the Runtime Environment

Each release of iOS (and its corresponding SDK) includes features and capabilities not present in earlier
releases. As new releases of the OS are published, some users may upgrade immediately while other users
may wait before moving to the latest release. You can take one of two strategies, depending on the needs
of your application and your users:

= Target the latest iOS release. Targeting the latest release allows you to take advantage of all the features
available in the latest version of iOS. However, this approach may offer a smaller set of users capable of
installing your application on their devices because your application cannot run on iOS releases that are
earlier than the target release.

= Target an earlier iOS release. Targeting an earlier release lets you publish your application to a larger
set of users (because your application runs on the target OS release and later releases), but may limit
the iOS features your application can use.
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You specify the earliest iOS release on which you want your application to run with the iPhone OS Deployment
Target build setting. By default, this build setting is set to the iOS release that corresponds to the Base SDK
build-setting value. For example, when you set Base SDK to iPhone Device 2.2.1 or iPhone Simulator 2.2.1,
the value of the iPhone Deployment Target build setting is iPhone OS 2.2.1, as shown in Figure 3-4.

Figure 3-4 Base SDK and iPhone Deployment Target build settings
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To build your application using the iPhone Device 3.0 SDK and to allow it to run on iOS 2.2.1, set Base SDK
to iPhone Device 3.0 and iPhone Deployment Target to iPhone OS 2.2.1.

When you build your application, your deployment target selection is reflected in the Minimum0OSVersion
entry in the application’s Info.p1ist file. When you publish your application to the App Store, the store
indicates the iOS release on which your application can run based on the value of this property.

iPhone Device SDK: If the iPhone Device SDK release is earlier than the application’s target iOS release (for
example, the active SDK is iPhone Device 2.2.1 and iPhone Deployment Target is iPhone OS 3.0), Xcode
displays build warnings when it detects that your application is using a feature that’s not available in the
target OS release. See "Specifying the Runtime Environment" (page 36) for more information.

You must also ensure that the symbols you use are available in the application’s runtime environment using
SDK-compatibility development techniques. These techniques are described in SDK Compatibility Guide.

iPhone Simulator SDK: When using the iPhone Simulator SDK to test your application, the iPhone Simulator
software version must be set to the iOS release that corresponds to the iPhone Simulator SDK used to build
the application. For example, if you build your application using iPhone Simulator SDK 2.2.1, you must set
the iPhone Simulator software version to iOS 2.2.1. See "Specifying Where to Place Your Application” (page
37) for details.

Specifying Where to Place Your Application

During development you may want to switch from running your application in iPhone Simulator to running
it on a device to, for example, test the device performance of your application. To switch between running
your application on a device on in the simulator use the Overview toolbar menu in the Project-window
toolbar, shown in Figure 3-5 (page 38), as described in these steps:

1. Choose whether you want to run your application on a device or in the simulation environment.

Specifying Where to Place Your Application 37
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The first two options in the Overview toolbar menu let you choose between these alternatives.
2. Choose the device or the iPhone Simulator version on which you want to run the application.

The Active Executable section of the Overview toolbar menu lets you specify a device or iPhone Simulator
version.

Figure 3-5 The Overview pop-up menu in the Project-window toolbar
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To start the build process, choose Build > Build.

The status bar in the project window indicates that the build was successful or that there are build errors or
warnings. You can view build errors and warnings in the text editor or the Project window.

Important: When building for iPhone Simulator, the generated binary runs only on the targeted iPhone
Simulator release. It doesn’t run on earlier or later releases of the simulator.

i0S-based devices support two instruction sets, ARM and Thumb. Xcode uses Thumb instructions by default
because using Thumb typically reduces code size by about 35 percent relative to ARM. Applications that
have extensive floating-point code might perform better if they use ARM instructions rather than Thumb.
You can turn off Thumb for your application by turning off the Compile for Thumb build setting.

If the build completes successfully, you can proceed to run your application as described in "Running Your
Application" (page 40).

To learn more about the build process, see "Building Products".

Solving Build Errors

This section lists build errors you may experience while building your application and provides suggestions
for solving them.

Building Your Application
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Provisioning Profile Errors

When building for a device, if Xcode has trouble installing your application onto your device due to a problem
with your provisioning profile, ensure that your provisioning profile is properly configured in the iPhone
Developer Program Portal (see "Becoming a Member of the iPhone Developer Program" (page 47)). If necessary
reinstall it on your computer and device, as described in "Preparing Your Mac for iOS Development" (page
47).

Code Signing Errors

When the code signing identity you're using to sign your binary has expired or is otherwise invalid, you may
get the following build-error message:

Code Signing Identity 'iPhone Developer' does not match any valid, non-expired,
code-signing certificate in your keychain.

To solve the error, choose a valid code signing identity, as described in "Setting Your Code Signing
Identity" (page 33).

Application ID Errors

Application ID build errors may be produced due to a conflict between the application ID set in your
provisioning profile (obtained through the Program Portal) and the application ID specified by the
CFBundleldentifier property of your application. To avoid such errors, ensure that the application ID in
the profile is set to com.<organization_name>.* and your application’s CFBundlelIdentifier property
is setto com.<organization_name>.<application_name>.That s, if the application ID in your
provisioning profile specifies a domain set, the application ID specified by the CFBundleldentifier property
of your application must not redefine the domain set, it may only reduce it. Table 3-2 and Table 3-3 identify
valid and invalid pairing of these items.

Table 3-2 Valid App ID/CFBundleldentifier property pair

Provisioning profile | App ID com.mycompany .*

Application bundle | CFBundleldentifier | com.mycompany.MyApp

Table 3-3 Invalid App ID/CFBundleldentifier property pair

Provisioning profile | App ID com.mycompany.MyApp.*

Application bundle | CFBundleldentifier | com.mycompany.MyApp

To learn about the structure of iOS application binaries, including details about the CFBundleldentifier
property, see “The Application Bundle” in iOS Application Programming Guide.

To learn about solving other build errors, use the techniques described in “Viewing Errors and Warnings” in
Xcode Project Management Guide to fix them.
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Running Your Application

When you run your application, Xcode installs it on iPhone Simulator or a device and launches it.

Once running, you can test that your application performs as you intend using all the capabilities of your
device. You should especially ensure that your application uses the device’s resources—CPU, memory, battery,
and so on—as efficiently as possible. See "Tuning Applications" (page 71) for more information.

To run your application, choose Run > Run or Run > Debug.
Troubleshooting: If you get the “Failed to start remote debug server” while trying to debug your application

on your device, your device may not be running the iOS release that corresponds to your iPhone SDK. For
more information, see "Installing iOS" (page 52).

Streamlining the Build-and-Run Workflow

In addition to the Build, Run, and Debug commands, Xcode provides convenience commands that perform
these operations as a single task. These commands are Build and Run and Build and Debug.

Managing Application Data
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As you develop your application, you might need to rely on user settings and application data to remain on
iPhone Simulator or your development device between builds. Xcode doesn’'t remove any user settings or
application data as you build your application and install it on its host. But you may need to erase that
information as part of testing your application the way users will use it. To do so, remove the application
from the Home screen. See "Uninstalling Applications" (page 45) for details.

As described in “File and Data Management” in iOS Application Programming Guide, iOS applications can
access only files that reside in the application’s local file system. You can view your application’s local file
system in your device and in iPhone Simulator.

To view your application’s iPhone Simulator-based file system, navigate to the ~/Library/Application
Support/iPhone Simulator/User/Applications directory in the Finder. Then open each directory in
the AppTlications directory to find your application’s binary file. Alongside the binary file are the directories
that make up your application’s local file system. Figure 3-6 shows the local file system for the BubbleLevel
application in iPhone Simulator.

Running Your Application
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Figure 3-6 Viewing an application’s iPhone Simulator-based local file system
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To make a copy of your application’s device-based file system to your Mac:

-

. In Xcode, choose Window > Organizer.
2. In the Organizer, select your device in the Devices list.

3. Inthe Summary pane, click the disclosure triangle next to your application.

4. Click the download button (the down-pointing arrow to the left of the Application Data package), as

shown in Figure 3-7.

5. In the dialog that appears, choose a location for the file-system copy.

Managing Application Data
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Figure 3-7 Downloading an application’s device-based local file system
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To restore your application’s file system to a backup on your Mac:
1. In Xcode, open the Organizer.
2. Inthe Finder, locate the directory containing the backup.

3. Drag the backup to your application in the Summary pane of the Organizer.

Further Exploration

To learn more about using Xcode to build and run applications, see Xcode Project Management Guide.
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The iOS simulation environment lets you build and run your iPhone or iPad application on your computer.
You use the simulation environment to:

= Find and fix major problems in your application during design and early testing.

= Learn about the Xcode development experience and the iOS development environment before becoming
a member of the iPhone Developer Program.

= Lay out and test your application’s user interface.

= Measure your application’s memory usage before carrying out detailed performance analysis on iOS-based
devices.

A major part of the iOS simulation environment is the iPhone Simulator application. This application presents
the iPhone or iPad user interface in a window on your computer. The application provides several ways of
interacting with it using your keyboard and mouse to simulate taps and device rotation, among other gestures.

Important: iOS 4.0 uses the same Objective-C runtime as Mac OS X v10.6. iOS 3.2 and earlier use the Mac
OS X v10.5 Objective-C runtime. Because of this change, binaries generated with an iPhone SDK distribution
earlier than 4.0 do not run in the simulator that’s part of the iPhone SDK 4.0 and later distributions. After
moving from iPhone SDK 3.2 and earlier distributions to a 4.0 or later distribution, you must rebuild your
iPhone Simulator binaries to run them in the simulator. If you use licensed static libraries in your application,
you must obtain versions of them generated with an iPhone SDK 4.0 or later distribution. For more information
about the Objective-C runtime, see Objective-C Runtime Reference.

The following sections describe the ways in which you use your computer’s input devices to simulate the
interaction between users and their devices. They also show how to uninstall applications from the simulator
and how to reset the contents of the simulator.

Setting the Simulation-Environment Device Family and iOS Version

iPhone Simulator can simulate two device families (iPhone and iPad) and more than one iOS release.
To specify the device family you want to simulate, choose Hardware > Device, and choose the device family.

To set the iOS release used in the simulation environment, choose Hardware > Version, and choose the
version you want to test on.

Setting the Simulation-Environment Device Family and iOS Version 43
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Manipulating the Hardware

iPhone Simulator lets you simulate most of the actions a user performs on her device. When you're running
your application in iPhone Simulator, you can carry out these hardware interactions through the Hardware
menu:

Rotate Left. Rotates the simulator to the left.
Rotate Right. Rotates the simulator the right.
Shake Gesture. Shakes the simulator.

Home. Takes the simulator to the Home screen.
Lock. Locks the simulator.

Simulate Memory Warning. Sends the frontmost application low-memory warnings. For information
on how to handle low-memory situations, see “Observing Low-Memory Warnings” in iOS Application
Programming Guide.

Toggle In-Call Status Bar. Toggles the status bar between its normal state and its in-call state. The status
bar is taller in its in-call state than in its normal state. This command shows how your application’s user
interface looks when the user launches your application while a phone call is in progress.

Simulate Hardware Keyboard. Toggles the software keyboard on iPad simulation. Turn off the software

keyboard to simulate using a keyboard dock or wireless keyboard with an iPad device.

Performing Gestures
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Table 4-1 lists gestures you can perform on the simulator (see iPhone Human Interface Guidelines for gesture

information).

Table 4-1 Performing gestures in iPhone Simulator

Gesture

Desktop action

Tap

Click.

Touch and hold

Hold down the mouse button.

Double tap Double click.
Swipe 1. Place the pointer at the start position.

2. Hold the mouse button.

3. Move the pointer in the swipe direction and release the mouse button.
Flick 1. Place the pointer at the start position.

2. Hold the mouse button.

3. Move the pointer quickly in the flick direction and release the mouse button.

Manipulating the Hardware
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Gesture Desktop action

Drag 1. Place the pointer at the start position.
2. Hold down the mouse button.

3. Move the pointer in the drag direction.

Pinch 1. Hold down the Option key.
2. Move the circles that represent finger touches to the start position.

3. Hold down the mouse button and move the circles to the end position.

Installing Applications

Xcode installs applications in iPhone Simulator automatically when you build your application using the
iPhone Simulator SDK. See "Running Applications" (page 31) for details.

In iPhone Simulator, you can install only applications that you build using the iPhone Simulator SDK. You
cannot install applications from the App Store in the simulator.

Uninstalling Applications

To uninstall applications you have installed on the simulator use the same method used to uninstall
applications from devices:

1. Place the pointer over the icon of the application you want to uninstall and hold down the mouse button
until the icon starts to wiggle.

2. Click the icon’s close button.

3. Click the Home button to stop the icon wiggling.

Resetting Content and Settings

To set the user content and settings of the simulator to their factory state and remove the applications you
have installed, choose iPhone Simulator > Reset Content and Settings.

Core Location Functionality

The relocation reported by the CoreLocation framework in the simulator is fixed at the following coordinates
(accuracy 100 meters), which correspond to 1 Infinite Loop, Cupertino, CA 95014.

= Latitude: 37.3317 North

Installing Applications 45
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= Longitude: 122.0307 West

Viewing iPhone Simulator Console Logs

To learn how to view your application’s console logs when it runs in iPhone Simulator, see "Viewing Console
and Crash Logs" (page 56).

iPhone Simulator File System on Host

iPhone Simulator stores the User domain of the iOS file system in your home directory at:
~/Library/Application Support/iPhone Simulator/User

The User domain comprises all user data iOS stores including third-party application binaries, system databases
(such as the Address Book and Calendar databases), application preferences, and so on. This location is also
known as <i0SUserDomain>.

iPhone Simulator stores system application preferences filesin <i0SUserDomain>/Library/Preferences.

Third-party-application preferences files are stored in
<i0SUserDomain>/Applications/<app_UUID>Library/Preferences.

Hardware Simulation Support

iPhone Simulator doesn’t simulate accelerometer or camera hardware.

46 Viewing iPhone Simulator Console Logs
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With iPhone Simulator you can start developing iOS applications without using iOS-based devices. This way
you can familiarize yourself with the APl and development workflows used to develop applications. However,
you must always test your applications on actual devices before publishing them to ensure that they run as
intended and to tune them for performance on actual hardware.

As a registered Apple developer you can log in to the iPhone Dev Center, which provides access to iOS
developer documentation and lets you build iOS applications that run in iPhone Simulator. (To become a
registered Apple developer, visit http://developer.apple.com/programs/register/.) Being a registered Apple
developer, however, doesn't allow you to run applications on iOS-based devices. To do so you must be a
member of the iPhone Developer Program. See "Becoming a Member of the iPhone Developer Program"” (page
47) for more information.

This chapter shows how to configure your computer and devices for iOS development. It also shows how to
view your application’s console logs or crash information, or to take screenshots of your application as it
runs. The chapter also describes how to safeguard the digital identifications required to install applications
in development in devices.

Becoming a Member of the iPhone Developer Program

The iPhone Developer Program provides the tools and resources you need to run applications on
development devices and distribute them to iOS users. To become a member of the iPhone Developer
Program, visit http://developer.apple.com/iphone/program.

After becoming an iPhone Developer Program member, you have access to the iPhone Provisioning Portal
in the iPhone Dev Center. The iPhone Provisioning Portal (or Portal) is a restricted-access area of the iPhone
Dev Center that stores information about your development devices. It also manages other resources,
including development certificates and provisioning profiles, used in the development and distribution of
iOS applications.

Important: If you are not a member of the iPhone Developer Program, you do not have access to the iPhone
Provisioning Portal.

Preparing Your Mac for iOS Development

To run applications on a device, you must configure your computer and device for iOS development. This
section presents an overview of the process, which the Xcode Organizer can manage for you.

Becoming a Member of the iPhone Developer Program 47
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Note: Configuring an iOS-based device for development does not hinder its normal operation.

In preparing your device for development, you create or obtain the following digital assets:

Certificate signing request. A certificate signing request (CSR) contains personal information used to
generate your development certificate. You submit this request to the iPhone Provisioning Portal.

Development certificate. A development certificate identifies an iOS application developer. After the
CSR is approved, you download your developer certificate from the portal and add it to your keychain.

When you build your iOS application with Xcode, it looks for your development certificate in your
keychain; if it finds the certificate, Xcode signs your application, otherwise, it reports a build error.

Provisioning profile. A provisioning profile associates one or more development certificates, devices,
and an app ID (iOS application ID).

To be able to install iOS applications signed with your development certificate on a device, you must
install at least one provisioning profile on the device. This provisioning profile must identify you (through
your development certificate) and your device (by listing its unique device identifier). If you're part of
an iOS developer team, other members of your team, with appropriately defined provisioning profiles,
may run applications you build on their devices.

Figure 5-1 illustrates the relationship between these digital assets.

Figure 5-1 Preparing computers and devices for iOS development
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To run applications on a device, you must set up the device for development. This process involves two main
tasks:

Provisioning a Device for Development
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1. Creating a provisioning profile that identifies your device on the iPhone Provisioning Portal.

2. |Installing that provisioning profile in your device.

You can have Xcode perform these tasks automatically when you designate new devices for development,
as described in "Provisioning a Device for Generic Development" (page 49). However, if your application

requires a specialized provisioning profile (if it uses push notifications or in-app purchases), you need to
follow the steps in "Provisioning a Device for Specialized Development" (page 51).

Provisioning a Device for Generic Development

To provision a new device for generic development:
1. Open the Xcode Organizer.
2. Inthe IPHONE DEVELOPMENT group, select Provisioning Profiles.

3. Select the Automatic Device Provisioning option.
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4. Plugin your device.
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5. In the DEVICES group, select your device and click Use for Development.
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6. In the dialog that appears, enter your iPhone Developer Program credentials.

Xcode logs in to the Portal and adds the new device to it. Xcode also adds a provisioning profile called
“Team Provisioning Profile: *” to your device. This provisioning profile is shared among the members of
your team who provision their devices automatically.

o606 Organizer =

¥ PROJECTS & SOURCES
Summary Device Logs Console Screenshots
¥ DEVICES
iPod_fwd iPod
Name: iPod_fwd
¥ IPHONE DEVELOPMENT Capacity: 15.72 GB
4 Archived Applications Serial Number: 9E8052H4WAT
A Developer Profile ECID: 2330424055055
- Device Logs Identifier: 65a59a020548fbff181654c8ff82a5322
Provisioning Profiles Software (3.L2@D1D 2] [__Restore
@Sc’“"‘hm‘ Xcode cannot find the software image to in
24l Software Images
Provisioning |
.

|#| Team Provisioning Profile: *

<«

1 ) Jalrl

|

+- | | M0

Provisioning a Device for Development
2010-07-02 | © 2010 Apple Inc. All Rights Reserved.



CHAPTER 5

Managing Devices and Digital Identities

7. If Xcode offers to request a development certificate in your behalf, click Submit Request.

To ensure that your device is provisioned correctly, you can download a sample project, build it using a
device SDK, and run the application it produces on your device. See, "Running Sample Applications" (page
31) for details.

Provisioning a Device for Specialized Development

When you use specialized provisioning profiles (required to run applications that use push notifications or
in-app purchases, for example), you must create those provisioning profiles in the Portal and install them on
your development device.

First, follow the steps in "Provisioning a Device for Generic Development" (page 49) to add your device to
the Portal.

To add a specialized provisioning profile to your device:
1. Inthe Portal, add your device to the specialized provisioning profile.
2. In the Xcode Organizer, select Provisioning Profiles in the IPHONE DEVELOPMENT group.

If you don't see the provisioning profile you want to add to your device in the provisioning profile list,
click Refresh.

3. Drag the specialized provisioning profile to your device in the DEVICES group.
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Installing iOS

When you develop applications using the iPhone SDK, you should test those applications on devices running
the iOS version the SDK targets. You can download the latest release of the iPhone SDK from the iPhone Dev
Center. Use iTunes to install the latest iOS release onto your device.

Note: During seed periods, you can download seed releases of the iPhone SDK and iOS from the iPhone
Dev Center.

To restore a device:

1. Launch Xcode and open the Organizer window.

2. Plug the device into your computer.

3. Select the device in the Devices list.

4. From the Software Version pop-up menu, choose the version of iOS you want to place on the device.

If you're using a seed release of the iPhone SDK and the version of iOS you want to install is not listed
in the Software Version pop-up menu:

a. Download theiOS seed that corresponds to your iPhone SDK seed from http://developer.apple.com.

Important: You must be a member of the iPhone Developer Program to be able to download iOS.

b. From the Software Version pop-up menu, choose Other Version.
¢. Navigate to the disk image containing the iOS developer software and click Open.

Xcode extracts the iOS software from the disk image. You can dispose of the disk image you
downloaded.

d. From the Software Version pop-up menu, choose the newly downloaded iOS version.

During nonseed periods, you must install iOS using iTunes.
5. Click Restore iPhone or Restore iPod, depending on your device's type.

6. Use iTunes to name your device.

Running Applications on a Device

After following the instructions in "Preparing Your Mac for iOS Development" (page 47) and "Installing
iOS" (page 52) (if necessary) you can run your application on your development device.

52 Installing iOS
2010-07-02 | © 2010 Apple Inc. All Rights Reserved.


http://developer.apple.com

CHAPTER 5

Managing Devices and Digital Identities

You tell Xcode that you want to build your application for a device and that you want to run it on a connected
device by setting the active SDK to an iPhone Device SDK. See "Building Your Application" (page 38) for
details.

Capturing Screen Shots

Screen shots help to document your application. This is also how you create your application’s default image,
which iOS displays when the user taps your application’s icon. You can capture screen shots of your device’s
screen from the Organizer or directly on your device.

To capture a screen shot from the Organizer:
1. Configure your application’s screen for the screen shot.

Depending on your application’s workflow, you may need to place breakpoint in your code and run your
application until it reaches that point.

2. Open the Organizer window, select your device, and click Screenshots.
3. Click Capture.
To make that screen shot your application’s default image, click Save As Default Image.
To get a PNG file of the screenshot, drag it to the desktop.
If you have iPhoto installed on your computer, you may capture screen shots directly on your device and
import them into your iPhoto library.

To capture a screen shot on your device, press the the Lock and Home buttons simultaneously. Your screen
shot is saved in the Saved Photos album in the Photos application.

Note: Although the default image includes the status bar as it looked when the screen shot was captured,
iOS replaces it with the current status bar when your application launches.

Managing Your Digital Identities

When you request a certificate from the iPhone Provisioning Portal, a public/private key pair is generated.
The public key is included in your certificate. The private key is stored in your keychain. With these items,
Xcode code-signs the applications you build with it. If you need to use another computer to develop iOS
applications, you must transfer these digital-identification items to the other computer. You can do this in
the Xcode Organizer.

To export your digital-identification items to a secure file, follow these steps:
1. Open the Xcode Organizer.

2. Inthe IPHONE DEVELOPMENT group, select Developer Profile.
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3.

4.

Click Export Developer Profile.

Name the file, select a location for it, enter a password to secure the file, and click Save.

Now, when you need to develop iOS applications on another computer, import your digital-identification
items into it by performing these steps:

1.

2.

Copy the developer-profile archive to the second computer.
On the second computer, launch Xcode.

Open the Organizer.

In the IPHONE DEVELOPMENT group, select Developer Profile.
Click Import Developer Profile.

Locate the archive, enter the password used to secure it, and click Open.

Managing Your Digital Identities
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Debugging Applications

This chapter describes the Xcode debugging facilities.

Part of your debugging workflow may require to view or manipulate data your application writes in its file
system. For example, you may need to edit the data the application has stored to recreate a particular
condition you want to test. See "Managing Application Data" (page 40) for details about manipulating your
application’s data.

Debugging Facilities Overview

Xcode provides several debugging environments you can use to find and squash bugs in your code:

= The text editor. The text editor allows you to debug your code right in your code. It provides most of
the debugging features you need. You can:

[—Add and set breakpoints

[_Yiew your call stack per thread

[Yiew the value of variables by hovering the mouse pointer over them
[—fxecute a single line of code

[—Step in to, out of, or over function or method calls

an0n Im| SKTLina.m (]
oo

L%J n -[SKTLine drawHandlesInView:] _:|_ Debugger Stl’ip

—-DeZierratnrorurawing 5 Tl Fy L]

[ Cur. 05 | Debug

Thread-1 3 (0 » & %+ t

MARILINE.MIL/SL 5 W

=]
- {void)drawHandlesInView: (NSView *JIview { 2
/7 A line only has two handles.
[self drowHondleInView « atPoint:[self beginPoint]]; m
[self drawHandleInView:vie :R%: SKTGraphicView *  view 0x123c40 Summary.
NSView NSView =l
¥ NSKVONotifying_SKTWin... _graphicsContainer 0x1170d0
inn NSCFString * _graphicsKeyPath Ox12ed30 {(unichar *)Xcode_CFStr
G[)B: Stopped at breakpoint 1 (hit count : 2) - '—drq #  NSArrayController * _selectionindexesContainer 0x243740
] NSCFString * _selectionindexesKeyPath Ox1e67c {{unichar *)Xcode_CFStr
L NSKVONotifying_SKTGrid * _grid 0x117510
Gutter NSRect _rulerEchoedBounds {...} x=0, y=0, width=0, hei
SKTGraphic * _creatingGraphic 0x0
SKTGraphic * _editingGraphic 0x0
NSView * _editingView 0x0
NSRect _editingViewFrame {...} =0, y=0, width=0, hei
Debugger datatip —  CGFloat _oldReservedThicknessForRuler... 0
NSRect _marqueeSelectionBounds =t x=0, y=0, width=0, hei
BOOL _isHidingHandles NO
NSTimer * _handleShowingTimer 0x0
NSInteger _pasteboardChangeCount -1
MNSInteger _pasteCascadeNumber 1]
NSPoint _pasteCascadeDelta = x=10, y=10
NSMutablelndexSet * _undoSelectionindexes 0x0
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m The Debugger window. When you need to perform more focused debugging, the Debugger window
provides all the debugging features the text editor provides using a traditional interface. This window
provides lists that allow you to see your call stack and the variables in scope at a glance.

a8 [m| SKTLine.m: Sketch - Debugger

=
Toolbar—&i@@ @@@@@ -4}-" = ma

Build and Go  Stop Deactivate  Fix Restart Continue Step Owver Step Into  Step Qut Breakpoints Breakpoints Console

Variable list ——— —
-[SKTLine drawHandlesInView:] m ¥ Arguments

= — ] Summary

o

1 -[SKTGraphicView drawRect:] b self Ox1blbe0d
2 -[NSView _drawRect:clip:] _cmd 0Ox25698
3 -[NSView _recursiveDisplayAllDirtyWithLockFocus visRect:] P view Ox16ac60
4 -[NSView _recursiveDisplayAllDirtyWithLockFocus wisRect:] b Clobals

5 -[NSView _recursiveDisplayRectlfNeededlgnoringOpacity:isVisibleRec
6

7

8

q

Thread list

-[NSView _recursiveDisplayRectlfNeededlgnoringOpacity:isVisibleRec
-[NSView _recursiveDisplayRectlfNeededlignoringOpacity:isVisibleRec
N
-[NSView _recursiveDisplayRectlfNeededlgnoringOpacity:isVisibleRec
~[NSThemeFrame recursiveDisolavRectlfMeededlancrinoOnaciheisyi
T > .
< |1 SKTLine.m:173 & [ -bezierPathForDrawing % + ™% | C | #+ ]

- (void)drawHandlesInView: (NSView *)view {
Text editor

/7 A line only has two handles. m
[ L [self drawHandleInView:view otPoint:[self beginPoint]];
[self drawHandleInView:view atPoint:[self endPoint]];

1

—— <>

- GDE: Stopped at breakpoint 1 (hit count : 2) - "-drawHandlesinView: - Line 185" A

Status bar

= The GDB console. A GDB console window is available for text-based debugging.

Important: To debug successfully on a device, you must install on your computer the iPhone SDK
corresponding to the iOS release installed on the device. That is, you cannot debug an application on a device
running iOS 2.2.1 if you do not have the iPhone 2.2.1 SDK installed on your computer.

For more information about the Xcode debugging facilities, see Xcode Debugging Guide.

Viewing Console Output and Device Logs

56

The iOS frameworks, such as UIKit, produce log entries to the console to indicate, among other things, when
an unexpected event occurs. You can produce console messages in your iOS applications, too. One way to
produce console logs is to use the NSLog function. In addition to the Xcode debugger, console logs may
help you analyze your application’s logic and track down bugs.

When running your application on iPhone Simulator, you can access its console logs in Console application
(located /Applications/Utilities). When you run the application on your development device, log
entries from your application appear in the Xcode Organizer.

To view a device’s console output:
1. Open the Organizer window.

2. Select the device whose console output you want to view.

Viewing Console Output and Device Logs
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3. Click Console.

o606 Organizer

) O

N, 4. . 49
Build  Clean Run  Action
PROJECTS & SOURCES

0

DEVICES
' Ernest_iPad (a] Tl Dec 5163 unt o + Lap PPOrt TWiSpr_ ,_Ti _async:
agent :"Capt iveNetworkSupport-94.1 wispr" url:"http://www.apple.com/library/test/success.html”
= Fri Dec 31 16:85:03 unknown configd[22] <Noticex: network configuration changed.

i iPod_dev Fri Dec 31 16:85:83 unknown configd[22] <Noticex: CaptiveNetworkSupport:CaptiveHandleRedirect:1736 No wispr
redirect detected on end (AppleWiFi)

IPHONE DEVELOPMENT Fri Dec 31 16:85:03 unknown configd[22] <Notice=: CaptiveNetworkSupport:CaptivePublishState:867 en@ - Online

+ Archived Applications Fri Dec 31 16:85:83 unknown configd[22] <Noticex: CaptiveNetworkSupport:CaptiveKnownStore:488 Added AppleWiFi/

IPv4.Router=17.244.68.1;IPv4.RouterHardwareAddress=00:1f :c9:36:84:00 to known good cache

A, Developer Profile Fri Dec 31 16:31:68 unknown mc_mobile_tunnel [64] <arnings: received request 4: <CFArray 8x1651f9 [Px38303ff4]>

Device Logs {type = immutable, count = 1, values =
8 : «LFString Bx1857c@ [Bx38303ff4]>{contents = "RequestType"}
[2] Provisioning Profiles )}, keys <LFDictionary Bx105808 [0x38303ff4]={type = nutable, count = 1, capacity = 12, pairs =
% Screenshots 8 : LFString Bx1057cl [Bx38303ff4]={contents = "RequestType"} = <LFString Bx1057eB [Ox38303ff4]-={contents =

"GetProfilelList"}
2§ Software Images b
Fri Dec 31 16:31:88 unknown mc_mobile_tunnel [64] <darnings: processing request 4: (<CFArray @x106b70 [0x383037f4]
s{type = immutable, count = 1, values = (
B : <LFString Bx1057cO [x3B33ff4]={contents = "RequestType"}

}
Fri Dec 31 16:31:88 unknown mc_mobile_tunnel [64] <darning=: Not migrating manifest
Fri Dec 31 16:31:08 unknown mc_nobile_tunnel [64] <darning=: ...completed profile migration.
Fri Dec 31 16:31:08 unknown mc_mobile_tunnel [64] <Warning=: sending reply <CFDictionary 8x18cb98 [Bx383083ff4]>
{type = immutable, count = 4, capacity = 6, pairs = {
2 : «LFString Bx552c [Bx38303ff4]={contents = "Status"} = «LFString Bx555c [Bx38303ff4]={contents =
"Acknow ledged"}
3 : «LFString Bx567c [Bx38303ff4]={contents = "Orderedldentifiers"} = <CFArray Bx1@bdc@ [Bx38303ff4]={type =
nutable-small, count = 8, values = (

by
4 : «LFString Bx566c [Bx38303ff4]={contents = "ProfileManifest"} = <LFDictionary Bx1891ed [Bx38303ff4]={type
= nutable, count = B, capacity = 3, pairs =

7 : «LFString Bx568c [Bx38303ff4]={contents = "ProfileMetadata"} = <CFDictionary Bx1@db5@ [Bx38303ff4]={type
= mutable, count = @, capacity = 3, pairs = {
i
P
Fri Dec 31 16:31:08 unknown mc_nobile_tunnel [64] <Error=: receive_message: Could not receive size of message: @
Operation not permitted
Fri Dec 31 16:31:68 unknown mc_nobile_tunnel [64] <Warning=: received request 4: (null), keys (null)
Fri Dec 31 16:31:00 unknown mc_mobile_tunnel[64] <Error=: main: Could not receive request from host.

Clear Save Console As...

A

+v | &~ | 0 I

You can save the console output to a file by clicking Save Console As.

The Device Logs pane in the Organizer contains information about application crashes. You may have to
unplug your device and plug it in again to refresh the crash list.

For more information about crash logs, see Understanding and Analyzing iPhone OS Application Crash Reports.

Finding Memory Leaks

If you fix a leak and your program starts crashing, your code is probably trying to use an already-freed object
or memory buffer. To learn more about memory leaks, see "Finding Memory Leaks".

You can use the NSZombieEnabled facility to find the code that accesses freed objects. When you turn on
NSZombieEnabled, your application logs accesses to deallocated memory, as shown here:

2008-10-03 18:10:39.933 HelloWorl1d[1026:20b] *** -[GSFont ascender]: message sent to
deallocated instance 0x126550

To activate the NSZombieEnabled facility in your application:

1. Choose Project > Edit Active Executable to open the executable Info window.

Finding Memory Leaks 57
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2. Click Arguments.

3. Click the add (+) button in the “Variables to be set in the environment” section.

4. Enter NSZombieEnabled in the Name column and YES in the Value column.

5. Make sure that the checkmark for the NSZombieEnabled entry is selected.

For more information about configuring executable environments, see “Configuring Executable Environments”
in Xcode Project Management Guide.

iPhone 3.1 SDK introduces the Leaks instrument, which you can use in the Instruments application to easily
find memory leaks. For more information, see Instruments User Guide.

58 Finding Memory Leaks
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Unit tests help you write robust and secure code. Xcode provides an easy-to-use flexible unit-testing
environment that you can use to ensure your code works as designed as it goes through changes.

Software requirements: This feature is available in iPhone SDK 3.0 and later.

This chapter introduces unit testing and describes how you can take advantage of it in your projects.
For a case study in unit-testing adoption and usage, see:

http://www.macdevcenter.com/pub/a/mac/2004/04/23/ocunit.html

Xcode is already configured for unit testing. You don't need to install additional software.

Unit Testing Overview

Unit testing lets you specify behavior that your code must exhibit to ensure that its functionality remains
unchanged as you modify it to, for example, make performance improvements or fix bugs. A test case
exercises your code in a specific way; if the results vary from the expected results, the test case fails. A test
suite is made up of a set of test cases. You can develop one or more test suites to test different aspects of
your code.

Unit tests are the basis of test-driven development, which is a style of writing code in which you write test
cases before writing the code to be tested. This development approach lets you codify requirements and
edge cases for your code before you get down to writing it. After writing the test cases, you develop your
algorithms with the aim of passing your test cases. After your code passes the test cases, you have a foundation
upon which you can make improvements to your code, with confidence that any changes to the expected
behavior (which would result in bugs in your product) are identified the next time you run the tests.

Even when not using test-driven development, unit tests can help reduce the introduction of bugs in your
code. You can incorporate unit testing in a working application to ensure that future source-code changes
don’t modify the application’s behavior. As you fix bugs, you can add test cases that confirm the bugs are
fixed. However, adding unit tests to a project that’s not designed with unit testing in mind may require
redesigning or refactoring parts of the code to make them testable.

The Xcode unit-testing environment is based on the open-source SenTestingKit framework. This framework
provides a set of classes and command-line tools that let you design test suites and run them on your code.

Xcode offers two types of unit tests: logic tests and application tests.

m Logic tests. These tests check the correct functionality of your code in a clean-room environment; that
is, your code is not run inside an application. Logic tests let you put together very specific test cases to
exercise your code at a very granular level (a single method in class) or as part of a workflow (several
methods in one or more classes). You can use logic tests to perform stress-testing of your code to ensure

Unit Testing Overview 59
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that it behaves correctly in extreme situations that are unlikely in a running application. These tests help
you produce robust code that works correctly when used in ways that you did not anticipate. Logic tests
are iPhone Simulator SDK-based; however, the application is not run in iPhone Simulator: The code being
tested is run during the corresponding target’s build phase.

= Application tests. These tests check the functionality of your code in a running application. You can use
application tests to ensure that the connections of your user-interface controls (outlets and actions)
remain in place, and that your controls and controller objects work correctly with your object model as
you work on your application. Because application tests run only on a device, you can also use these
tests to perform hardware testing, such as getting the location of the device.

Setting Up Testing

60

Logic unit tests (introduced in "Unit Testing Overview" (page 59)) allow you to perform exhaustive, highly
tailored testing of your code. To perform logic tests, you build a unit-test bundle using the iPhone Simulator
SDK. When you build the unit-test bundle, Xcode runs the test suites that are part of the bundle. You
incorporate test suites into a test bundle by adding SenTestCase subclasses to the bundle. These classes
contain test-case methods that call the API to exercise and report whether the calls produced the expected
results. Xcode reports whether the tests passed or failed in text editor windows and the Build Results window.

Application unit tests let you test your code within an application running on an iOS device, with access to
the resources available in the Cocoa Touch framework.

This section describes how to set up a project for each type of unit test.

Setting Up Logic Testing

To set up a logic—unit-test bundle in a project:

1. Add aniPhone OS unit-test bundle target to the project. Name the target LogicTests (you can use any
name you like for your unit-test bundles, but you should include the suffix Tests to identify them as such).

For details about adding targets to a project, see “Creating Targets” in Xcode Build System Guide.
2. Setthe LogicTests target as the active target.
3. Add a group called Tests to the Group & Files list, and select that group in the list.

4. Add a unit-test class to the unit-test-bundle target. Each unit-test class in the bundle makes up a test
suite.

a. Choose File > New, select the iPhone OS unit-test class template, and click Next.
b. Name the class LogicTests (you can use any name here, too0).

¢. Select the option to create the header file.

Setting Up Testing
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d. Ensure that LogicTests is the only target selected in the target list.

New Unit Test Case class

File Name: ILogicTestsLm I
M Also create "LogicTests.h”
Location: |~fdevll(irkwood.u'unit_testing!MyApp H [ Choose... )
Add to Project: | MyApp Hl!

Targets: O q.‘_ﬁvaADP
[ 'ﬁmgicTests

[:Previous) ( Finish )
A
e —

5. Change LogicTests.h so that it looks like this:

J#import <SenTestingKit/SenTestingKit.h>
f#import <UIKit/UIKit.h>

@interface LogicTests : SenTestCase {
éend
6. Change LogicTests.m so that it looks like this:
fHimport "LogicTests.h"
@implementation LogicTests
- (void) testFail f
STFail(@"Must fail to succeed.");
Ci)end
7. Set the base SDK for the project to iPhone Simulator 3.0 or later.

For more information about the Base SDK build setting, see "Setting the Base SDK" (page 32).

Setting Up Testing
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8.

Set the active target to LogicTests and choose Build > Build. If the unit-test bundle is configured correctly,
the build fails and Xcode displays an error message in the text editor.

OO0 m| @icTests.m )
<  » | [¥LogicTests.m:5 5 [ -testFail 3 — "% | Cy | #s o
#import "LogicTests.h" =

@implementation LogicTests
- {wvoid) testFail {

L=] STFail{@"Must fail to succeed.™);
1
Bend

9. Now make the test case pass by changing the highlighted lines in LogicTest.m:

fHimport "LogicTests.h"

@implementation LogicTests

- (void) testPass {
STAssertTrue(TRUE, @"");

}

@end

At this point you have a correctly configured logic—unit-test bundle. See "Writing Tests" (page 67) to learn
how to add test cases to it.

Setting Up Application Testing

To set up an application—unit-test bundle in a project:

1.

Make a copy of the target that builds the application to test by choosing Duplicate from its shortcut
menu, and name it <application_name>Testing (for example, MyAppTesting). (You can use any
name for this target, but you should include the suffix Testing to identify it as a target used to run
application unit tests.) The only purpose of this target is to run application unit tests.

Add an iPhone OS unit-test bundle target to the project. Name the target <application_name>Tests
(for example, MyAppTests).

For details about adding targets to a project, see “Creating Targets” in Xcode Build System Guide.

Setting Up Testing
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3.

Make the MyAppTesting target dependent on the MyAppTests target by dragging MyAppTests to
MyAppTesting.

600 (@)

Groups & Files 4|

» 5 MyApp =
v@ Targets
b o MyApp
¥ ;A MyAppTesting — Tesrs J
» || Copy Bundle Rzsources (2)
» [l Compile Sources (3)
» [ Link Binary With Libraries (3)
[ 3 "‘ﬁ LogicTests
T
b < Executables
» B Errors and Warnings
w |, Find Results
» [ Bookmarks
> scm
Wl Project Symbols
» (i Implementation Files
¥ [33] NIB Files

é'
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4. Embed the MyAppTests bundle into the MyAppTesting bundle by dragging the MyAppTests.octest

product to the MyAppTesting target Copy Bundle Resources build phase.

000 MyApp ()

Groups & Files
v [B MyApo =
b | Tests rr
»[ | Classes
» [ ] Other Sources
» [ Resources
» [ ] Frameworks
¥ | Products
{4 MyApp.app
» [T LogicTests.octest
{24 MyApp.app

Y@ Targets
¥ 5 MyApp
¥ oh MyAppTesting
"7 MyAppTests
( v [ Copy Bundle Resources (2) )LL
|| MainWindow.xib
@ MyAppViewController.xib
» [ | Compile Sources (3)
p [ Link Binary With Libraries (3)
> "ﬁ LogicTests
b "7 MyAppTests

& (A Fwverntahles

Ta[»

‘\

Add a group called Tests to the Groups & Files list (if it doesn't already exist), and select that group in
the list.

Add a unit-test class to the MyAppTests target. Each unit-test class in the bundle makes up a test suite.

a. Choose File > New, select the iPhone OS unit-test class template, and click Next.

b. Name the class MyAppTests (you can use any name for this class, but it should have the suffix Tests
for easy identification).

c. Select the option to create the header file.
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d. Ensure that MyAppTests is the only target selected in the target list.

o0 MNewdlle

New Unit Test Case class
File Name: MyAppTests.m
E Also create “MyAppTests.h”
Location: |n—fdevfl(irkwood,u'unit_testing!MyApp H { Choose... )
Add to Project: ( MyApp H-!
Targets: |0 i MyApp

] 5&: MyAppTesting
O [ LogicTests
o 7] MyAppTests

( Previous ) E Finish 3

P

7. Change MyAppTests.h so that it looks like this:

J#import <SenTestingKit/SenTestingKit.h>
f#import <UIKit/UIKit.h>

@interface MyAppTests : SenTestCase {
éend
8. Change MyAppTests.m so that it looks like this:
#import "MyAppTests.h"
@implementation MyAppTests
- (void) testFail f
STFail(@"Must fail to succeed.");
Ci)end
9. Set the Base SDK for the project to iPhone Device 3.0 or later.

For more information about the Base SDK build setting, see "Setting the Base SDK" (page 32).

Setting Up Testing
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10. Set the active target to MyAppTesting and choose Build > Build and Run. Xcode builds your application,
installs and launches it on your device, and runs the test suite, which fails. You can see the test results
in the console. This outcome confirms that application unit testing is set up correctly.

000 MyApp - Debugger Console D

Device - 3.0 | Debug

Test Suite started at 2009-04-30 15:06:29 -0700 r
Test Suite '/Developer/Library/Frameworks/SenTestingKit.framework(Tests)' started at 2009-04-30 15:06:29 -0700

Test Suite 'SenInterfaceTestCase' started at 2009-04-30 15:06:29 -0700

Test Suite 'SenInterfaceTestCase’ finished at 2009-04-30 15:06:29 -0700.

Executed 0 tests, with 0 failures (0 unexpected) in 0.000 (0.006) seconds

Test Suite '/Developer/Library/Frameworks/SenTestingKit.framework(Tests)' finished at 2009-04-30 15:06:29 =-0700.
Executed 0 tests, with 0 failures (0 unexpected) in 0.000 (0.020) seconds

Test Suite '/var/mobile/Applications/4340A49A-FE9E-45F8-9RBC-DBFDAT44760D/MyApp.app/MyAppTests.octest (Tests)' started at 2009-04-30
15:06:29 -0700

Test Suite 'MyAppTests' started at 2009-04-30 15:06:29 -0700

/Users/ernest/dev/Kirkwood/unit_i ing/MyApp/ m:14: error: -[MyAppTests testFail] : Must fail to succeed.

Test Case '-[MyAppTests testFail]' failed (0.004 seconds).

Test Suite 'MyAppTests' finished at 2009-04-30 15:06:29 -0700.

Executed 1 test, with 1 failure (0 unexpected) in 0.004 (0.012) seconds

Test Suite '/var/mobile/Applications/4340A49A-FE9E-45F8-9ABC-DEFDAT44760D/MyApp.app/MyAppTests.octest (Tests)' finished at 2009-04-30
15:06:29 -0700.
Executed 1 test, with 1 failure (0 unexpected) in 0.004 (0.026) seconds

Test Suite 'All tests' finished at 2009-04-30 15:06:29 -0700.
Executed 1 test, with 1 failure (0 unexpected) in 0.004 (0.074) seconds

Debugger stopped.

e
Program exited with status value:l. b4
MyApp has exited with status 1. @ Succeeded Y

11. Now make the test suite pass by changing the highlighted lines in MyAppTests.m:
fHimport "MyAppTests.h"

@implementation LogicTests
- (void) testAppDelegate {
id app_delegate = [[UIApplication sharedApplication] delegate];
STAssertNotNil(app_delegate, @"Cannot find the application delegate.");
}
@end

000 MyApp - Debugger Console —

Device - 3.0 | Debug | MyAppTesting | MyApp - () () () g

Test Suite 'All tests' started at 2009-04-30 07:29:16 -0700 [
Test Suite '/var/mobile/Applications/2BAC2621-B68C-46CD-AT67-9EEE21180B8A/MyApp.app/MyAppTests.octest (Tests)' started at
2009-04-30 07:29:16 -0700

Test Suite 'MyAppTests' started at 2009-04-30 07:29:16 -0700

Test Case '=| legate] ' passed (0.000 seconds).

Test Suite 'MyAppTests' finished at 2009-04-30 07:29:16 -0700.

Executed 1 test, with 0 failures (0 umexpected) in 0.000 (0.008) seconds

Test Suite '/var/mobile/Applications/2BAC2621-B68C-46CD-AT67-9EEE21180B8A/MyApp.app/MyAppTests.octest (Tests)' finished at
2009-04-30 07:29:16 -0700.
Executed 1 test, with 0 failures (0 unexpected) in 0.000 (0.022) seconds

Test Suite '/Developer/Library/Frameworks/SenTestingKit.framework(Tests)' started at 2009-04-30 07:29:16 -0700
Test Suite 'SenInterfaceTestCase' started at 2009-04-30 07:29:16 =-0700

Test Suite 'SenInterfaceTestCase’ finished at 2009-04-30 07:29:16 -0700.

Executed 0 tests, with 0 failures (0 unexpected) in 0.000 (0.006) seconds

Test Suite '/Developer/Library/Frameworks/SenTestingKit.framework(Tests)' finished at 2009-04-30 07:29:16 -0700.
Executed 0 tests, with 0 failures (0 unexpected) in 0.000 (0.019) seconds

Test Suite 'All tests' finished at 2009-04-30 07:29:16 -0700.
Executed 1 test, with 0 failures (0 unexpected) im 0.000 (0.071) seconds

T

Debugger stopped.

Program exited with status value:0. {
Debugging of "MyApp" ended normally. @ Succeeded

N

|
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Now that you have a correctly configured application unit-test bundle, see "Writing Tests" (page 67) to learn
how to add test cases to it.

Writing Tests

After configuring a unit-test bundle with a unit-test class (which implements a test suite), you add cases to
the suite by adding test-case methods to the class. A test-case method is an instance method of a unit-test
class that's named test. . ., with no parameters, and whose return type is void. Test-case methods call the
API they test and report whether the API performed as expected—for example, whether it returns the
anticipated return or whether it raises an exception. Test-case methods use a set of macros to check for the
expected conditions and report their findings. "Unit-Test Result Macro Reference" (page 85) describes these
macros.

For a test case to access the subject API, you may have to add the appropriate implementation files to the
unit-test bundle and import the corresponding header files into your unit-test class. For an example of a
project that uses unit tests, see the iPhoneUnitTests sample-code project.

Note: iPhone unit-test—cases are written in Objective-C.

This is the structure a test-case method:

- (void) test<test_case_name> {
// Set up, call test-case subject API.
ST... // Report pass/fail to testing framework.
// Tear down.
}

Each test-case method is invoked independently. Therefore, each method must set up and tear down any
auxiliary variables, structures, and objects it needs to interact with the subject API. Conveniently, you can
add a pair of methods to a unit-test class that are called before and after each test-case method is invoked:
setUp and tearDown. Just like test-case methods, the type of both methods is void and they take no
arguments.

This is an example of a setUp/tearDown method pair:
- (void) setUp {

test_subject = [[MyClass new] retain];
STAssertNotNil(test_subject, @"Could not create test subject.");

- (void) tearDown {
[test_subject releasel;
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Note: When there’s a reported failure in a setUp or tearDown call, the failure is ultimately reported in the
test-case method that originated the call.

Running Tests

68

To ensure that changes you make to your code don’t modify its correct behavior, you should run your test
suites periodically, especially after making significant changes. This section shows how to run logic and

application tests. It also shows how to set up an application target so that Xcode runs logic tests every time
you build it.

Running Logic Tests

To run your logic tests, all you need to do is build the appropriate logic-test target. You can build such a
target in two ways:

= Making the the target active and choosing Build > Build
= Choosing Build from the target’s shortcut menu
The Build Results window shows the results of your tests.

You can make Xcode run your logic tests every time you build your application. This way you don't have to
remember to run those tests.

Follow these steps to set up your application target so that building it runs your logic tests:

1. Drag your logic-test target into your application target. This action makes the application target depend
on the logic-test target.

OO0 MyApp —

Groups & Files [l
> 5 MyApp =
¥ (&) Targets

¥ iy MyApp
» D Copy Bundle Resources {2)
» [ ] Compile Sources (3)
» [ Link Binary With Libraries (3)
h,;ﬁq MyAppTesting
»"7 LogicTests
» 7 MyAppTests

4|k

/4
I

Running Tests
2010-07-02 | © 2010 Apple Inc. All Rights Reserved.




CHAPTER 7
Unit Testing Applications

When you build the application target, Xcode builds the logic target first, reporting test failures in the
process.

2. In the LogicTests Info window, display the build pane.
3. Choose All Configurations from the Configuration pop-up menu.
4. Choose All Settings from the Show pop-up menu.

5. In the Architectures group of the build-setting list, set Base SDK to iPhone Simulator 3.0, and deselect
Build Active Architecture Only.

- e Target "LogicTests” Info
I General Build Rules Properties Comments |
Configuration: | All Configurations :] (Q Search in Build Settings
Show: | All Settings H
[ Setting Value
Architectures

Additional SDKs

Architectures Standard (iPhone Simulator: i386)

Base SDK Simulator - iPhone 05 3.0

Build Active Architecture Only =

Walid Architectures i386

Running Application Tests

To run your application tests, you must build, and run or debug the application-testing target. Remember
that you can use such targets only to run or debug test cases; you cannot use them to run your application
on your device interactively.

The console displays the results of your application tests.

Writing Testable Code

The Xcode integrated support for unit testing makes it possible for you to build test suites to support your
development efforts in any way you want. You can use it to detect potential regressions in your code or to
validate the behavior of your application. These capabilities can add tremendous value to your projects. In

particular, they can improve the stability of your code greatly by ensuring individual APIs behave in the
expected ways.

Of course, the level of stability you receive from unit testing is highly dependent on the quality of the test
cases you write. These are some guidelines to think about as you write code to ensure that it's easily testable:

= Define API requirements. You should define requirements and outcomes for each method or function
that you add to your program. These requirements should include input and output ranges, exceptions
thrown and the conditions under which they are raised, and the type of returned values (especially if

they are objects). Specifying requirements and making sure that requirements are met in your code help
you write robust, secure code.
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See the iPhoneUnitTests sample-code project for an example of using exceptions to identify and report
incorrect APl usage by a client.

Write test cases as you write code. As you write each API, write one or more test cases that ensure the
API's requirements are met. It's harder to write unit tests for existing code than for code you haven't
written yourself or have written recently.

Check boundary conditions. If the parameter of a method expects values in a specific range, your tests
should pass values that include the lowest and highest values of the range. For example, if an integer
parameter can have values between 0 and 100, inclusive, three variants of your test may pass the values
0, 50, and 100, respectively.

Use negative tests. Negative tests ensure your code responds to error conditions appropriately. Verify
that your code behaves correctly when it receives invalid or unexpected input values. Also verify that it
returns error codes or raises exceptions when it should. For example, if an integer parameter can accept
values in the range 0 to 100, inclusive, you should create test cases that pass the values -1 and 101 to
ensure that the API raises an exception or returns an error code.

Write comprehensive test cases. Comprehensive tests combine different code modules to implement
some of the more complex behavior of your API. While simple, isolated tests provide value, stacked tests
exercise complex behaviors and tend to catch many more problems. These kinds of test mimic the
behavior of your code under more realistic conditions. For example, in addition to adding objects to an
array, you could create the array, add several objects to it, remove a few of them using different methods,
and then ensure the set and number of remaining objects is correct.

Cover your bug fixes with test cases. Whenever you fix a bug, write one or more tests cases that verify
the fix.

Writing Testable Code
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Optimizing your application’s performance is an important phase of the development process, more so in
i0S-based devices, which, although powerful computing devices, do not have the memory or CPU power
that desktop or portable computers possess. You also have to pay attention to your application’s battery
use, as it directly impacts your customer’s battery-life experience.

This chapter describes Instruments and Shark, the tools you use to measure and tune your application’s
performance.

Prerequisites: Follow the instructions in "Running Applications" (page 31) before trying the application-tuning
techniques described in this chapter on your application.

For general performance guidelines, see iOS Application Programming Guide.

The Instruments Application

The Instruments application lets you gather a variety of application performance metrics, such as memory
and network use. You can gather data from iOS applications running in iPhone Simulator or on your
development devices.

It is important that your iOS applications use the resources of iOS-based devices as efficiently as possible to
provide a satisfactory experience for you customers. For example, your application should not use resources
in a way that makes the application feel sluggish to users or drains their batteries too quickly. Applications
that use too much memory run slowly. Applications that rely on the network for their operation must use it
as sparingly as possible because powering up the radios for network communications is a significant drag
on the battery.

The Instruments application provides an advanced data gathering interface that lets you know exactly how
your application uses resources, such as the CPU, memory, file system, and so on.

Instruments uses software-based data-gathering tools, known as instruments, to collect performance data.
An instrument collects a specific type of data, such as network activity or memory usage. You find which
instruments are available for iOS in the Instruments Library.

Although most iOS applications run in iPhone Simulator and you can test most design decisions there, the
simulator does not emulate a device, in particular it doesn’t attempt to replicate a device’s performance
characteristics such as CPU speed or memory throughput. To effectively measure your application’s
performance as users may use it on their devices, you must use an iPhone or iPod touch. That’s because only
on a device can you get an accurate representation of the runtime environment (in terms of processor speed,
memory limitations, specialized hardware, and the like).

These are some limitations of iPhone Simulator:
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Maximum of two fingers. If your application’s user interface can respond to touch events involving
more than two fingers, you can test that capability only on devices.

Accelerometer. Although you can access your computer’s accelerometer (if it has one) through the UIKit
framework, its readings differ from the accelerometer readings on a device. This discrepancy stems
largely from the different positioning of the screen in relation to the rest of the hardware between
computers and iOS-based devices.

OpenGL ES. OpenGL ES uses renderers on devices that are slightly different from those it uses in iPhone
Simulator. For this reason, a scene on the simulator and the same scene on a device may not be identical
at the pixel level. See “Drawing with OpenGL ES” in iOS Application Programming Guide for details.

To measure your application’s performance on a device:

1.

2.

Build and run your application on the device as described in "Running Applications" (page 31).
Launch Instruments.

The Instruments application is located at <Xcode>/Applications. (<Xcode> refers to the installation
location of the development tools.)

Choose a template, such as Activity Monitor, to create the trace document.
A trace document contains one or more instruments that collect data about a process.

From the Default Target pop-up menu in the toolbar, select the iOS-based device containing the
application from which you want to collect performance data.

Add or remove instruments from the trace document to collect the desired data.
Use the Default Target pop-up menu, to launch or attach to the target application.

Click Record to start collecting data and use your application, exercising the areas you want to examine.

To learn more about measuring and analyzing application performance, see Instruments User Guide. This
document provides general information about using Instruments.

The Shark Application

72

To complement the performance data Instruments collects, the Shark application lets you view system-level
events, such as system calls, thread-scheduling decisions, interrupts, and virtual memory faults. You can see
how your code’s threads interact with each other and how your application interacts with iOS.

When performance problems in your code are more related to the interaction between your code, iOS, and
the hardware architecture of the device, you can use Shark to get information about those interactions and
find performance bottlenecks.

For information about using Shark with your iOS applications, see Shark User Guide.
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When you're ready to distribute your application for testing or for general distribution through the App Store,
you need to create an archive of the application using a distribution provisioning profile, and send it to
application testers or submit it to iTunes Connect. This chapter shows how to perform these tasks.

Publishing Your Application for Testing

After testing and tuning your application yourself or with the assistance of your teammates, it’s always a
good idea to perform wider testing with a representative sample of your application’s potential users. Such
testing may reveal issues that surface only with particular usage patters. Incorporating a few nondeveloper
users in your testing strategy lets you expose your application to a variety of usage styles, and, if such usage
produces crashes in your application, allows you to collect the crash reports (also known as crash logs) from
those users, to help you resolve those execution problems.

An iOS application in development can run only on devices with provisioning profiles generated by the
application developer. As iPhone Developer Program members, you and your fellow team members install
these files on your devices as part of your development process (as described in “Managing Devices and
Digital Identities”). To include users that are not of your team (also known as testers) in your testing strategy,
you must add them as part of your team in the iPhone Provisioning Portal and issue them test provisioning
profiles (also known as ad-hoc provisioning profiles), which allow them to install on their devices applications
that have not been published to the App Store.

“Publishing Your Application for Testing” illustrates the process of adding users as testers and delivering your
test application to them.
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Figure 9-1 Adding testers to your team
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Prerequisites:
m Before sending your application to testers, review the information in "Running Applications" (page 31).

m To add testers to your team you must have distribution certificate in the Portal.

To help testers obtain the information you need to add them to your testing program and to show them
how to send you crash logs, you can send them the information in "Instructions for Application Testers" (page
77).

Important: To add testers to your team, you must be a member of the iPhone Developer Program. See
"Managing Devices and Digital Identities" (page 47) for details.

The remainder of this chapter describes the steps you need to perform to add testers to your team and shows
how to import the crash logs they send you into the Organizer.

Adding Application Testers to Your Team

To add iOS users to your team as testers:

Publishing Your Application for Testing
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1. Obtain the testers’ device IDs.

The easiest way to obtain this information is through email. Have your tester follow the instructions for
sending their device ID to you in "Sending Your Device ID to a Developer" (page 77).

2. Add the testers’ device IDs to the Portal.

Tip: Use the testers’ email addresses as the device name.

3. Ifyou already have a testing provisioning profile for your application in the Portal, add the testers’ device
IDs to it. Otherwise, create the profile with these characteristics:

Distribution method | Ad Hoc

Profile name <Application_Name> Testing Profile
App ID Appropriate application ID for the application being tested
Devices Testers’ device IDs

4. Download the testing profile and install it in the Xcode Organizer.

Drag the <Profile_Name>.mobileprovision file to the Provisioning Profiles list under IPHONE
DEVELOPMENT.

Adding the iTunes Artwork to Your Application

Test versions of your application should contain artwork iTunes uses to identify your application. Otherwise,
when users add your application to their iTunes library, iTunes uses generic artwork for it, as shown in Figure
9-2.
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Figure 9-2 Generic iTunes artwork for test applications
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The iTunes artwork your testers see should be your application’s icon. This artwork must be a 512 x 512 JPEG
or PNG file named i TunesArtwork. Note that the file must not have an extension.

After generating the file of your application’s icon, follow these steps to add it to your application:

1. Open your project in Xcode.

2. In the Groups & Files list, select the Resources group.

3. Choose Project > Add to Project, navigate to your i TunesArtwork file, and click Add.

In the dialog that appears, select the "Copy items” option and click Add.

Archiving Your Application for Testing

1.

Publishing Your Application for Testing
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2. Inthe Project window Overview toolbar menu, set Active Executable to a device.

3. Choose Build > Build and Archive.

Note: To streamline this process, create a distribution configuration (by duplicating the Release configuration),
and change the Code Signing Identity build setting in that configuration. That way, you can keep your
development and distribution configurations separate. For more information about build configurations, see
"Build Configurations".

Sending Your Application to Testers

To send your application to testers:

1. In the Archived Applications list in the Organizer, select the application archive you want to send to
testers, and click Share Application.

2. Click E-Mail.

In the email message, provide your testers information they need to test your application.

Importing Crash Logs from Testers

To add tester crash logs to the Organizer to view their symbol information, drag the crash logs to the Crash
Logs group under the iPhone Development section.

Important: For Xcode to symbolize crash logs (to add information about the APl used to the crash log),
Spotlight must be indexing the volume in which your archived applications and their corresponding dSYM
files are stored.

Instructions for Application Testers

This section provides instructions to testers about the procedures to follow to test your iOS applications on
their devices. An application tester is a potential user of your application who wants to test it before it's
released through the App Store.

You may send these instructions, along with any special tasks needed to test your application, to customers
interested in testing your application.

Sending Your Device ID to a Developer

Before a developer can send you an application for testing, they must register your device with Apple under
their application-testing program.

To send your device ID to a developer for test-program registration:
1. Launch iTunes.
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Connect your device to your computer.

Select the device in the Devices list.

In the Summary pane, click the Serial Number label. It changes to Identifier.
Choose Edit > Copy.

Email your device identifier to the developer. Be sure to include your name and device name in the email.

Installing an Application for Testing

After being registered in a developer’s testing program, the developer sends you an archive of the test
application. You need to install the archive into iTunes to run the application on your device.

To install the test application on your device:

1.

In the Finder, double-click the application archive, <Application_Name>.ipa.
The application appears in the iTunes Applications list.
Sync your device.

If the version of iOS on your device is earlier than the test application can run on, you need to update
your device with the current release of iOS.

Sending Crash Reports to a Developer

When the application you're testing crashes, iOS creates a record of that event. The next time you connect
your device to iTunes, iTunes downloads those records (known as crash logs) to your computer. To help get
the problem fixed, you should send crash logs of the application you're testing to its developer.

Sending Crash Reports from Macs

To send crash logs to developers:

1.

2,

In the Finder, open a new window.

Choose Go > Go to Folder.

Enter ~/Library/Logs/CrashReporter/MobileDevice.
Open the folder named after your device’s name.

Select the crash logs named after the application you're testing.
Choose Finder > Services > Mail > Send File.

In the New Message window, enter the developer’s email address in the To field and
<application_name> crash logs from <your_name> (for example, MyTestApp crash logs
from Anna Haro) in the Subject field.

Choose Message > Send.

Publishing Your Application for Testing
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9. In the Finder, you may delete the crash logs you sent to avoid sending duplicate reports later.

Sending Crash Reports from Windows

To send crash logs to developers, enter the crash log directory (Listing 9-1 and Listing 9-2) in the Windows
search field, replacing <user_name> with your Windows user name.

Listing 9-1 Crash log storage on Windows Vista

C:\Users\<user_name>\AppData\Roaming\Apple
computer\Logs\CrashReporter/MobileDevice

Listing 9-2 Crash log storage on Windows XP

C:\Documents and Settings\<user_name>\Application Data\Apple
computer\lLogs\CrashReporter

Open the folder named after your device’s name and send the crash logs for the application you're testing
in an email message using the subject-text format <application_name> crash logs from <your_name>
(for example, MyTestApp crash logs from Anna Haro) to the application’s developer.

Publishing Your Application for App Store Distribution

When you're ready to publish your application for general distribution through the App Store, you submit
it to iTunes Connect. This section describes how to prepare your application for submission and how to
submit it to iTunes Connect.

Creating a Distribution Profile for Your Application

To create a distribution profile for your application:

1. Create a distribution provisioning profile in the Portal with these characteristics:

Distribution method | App Store

Profile name <Application_Name> Distribution Profile

App ID The appropriate application ID for your application.

2. Download the distribution profile and install it in the Xcode Organizer.

Drag the <Profile_Name>.mobileprovision file to the Provisioning Profiles list under IPHONE
DEVELOPMENT in the Organizer.
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Archiving Your Application for Submission to iTunes Connect

To create a distribution archive of your application:
1. Set the Code Signing Identity build setting to the distribution profile.
2. Inthe Overview toolbar menu in the Project window, set Active Executable to a device.

3. Choose Build > Build and Archive.

Your new application archive appears in the Archived Applications list in the Organizer. Each archive is
identified with the date and time it was created.
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Submitting Your Application to iTunes Connect

To submit your application to iTunes Connect:

1. Inthe Archived Applications list in the Organizer, select the application archive you want to submit, and
click Submit Application to iTunes Connect.

2. In the dialog that appears, enter your iTunes Connect credentials, and click Submit.
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Here are some common questions developers ask about iOS development:

How do I submit applications to iTunes Connect for distribution through the App Store.
Use the Build and Archive command. See "Distributing Applications" (page 73).

Does the iPhone Simulator application run on network home directories?

No.

Do Objective-C properties need to be backed up by instance variables or accessor methods for them to
work?

Yes.

Do static libraries need to be code-signed before being used in an iOS application?

No.

Why is my application having problems processing PNG files?

The code that is trying to use your PNG files may not understand compressed PNG files.

Turn off the Compress PNG Files build setting. For information about build settings, see “Editing Build
Settings” in Xcode Project Management Guide.

Can | develop iOS applications on Windows?
No. iOS applications can be developed only on Mac OS X.
How do | link all the Objective-C classes in a static library?

Set the Other Linker Flags build setting to -0b jC. If that doesn’'t bring in all the classes, set it to
-all_Tload.

When should | replace deprecated API?

Update as soon as you can, considering the iOS versions you want your application to run on. See SDK
Compatibility Guide for details.

Can iPhone Simulator use my computer’s camera?
No.
What are the minimum hardware requirements for iOS development?

A Mac with an Intel processor.
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Hello, World! Source Code

This appendix contains the source code for the Hello, World! application described in "Tutorial: Hello,
World!" (page 17).
Listing A-1 main.m

// main.m
fFimport <UIKit/UIKit.h>

int main(int argc, char *argv[]) {

NSAutoreleasePool * pool = [[NSAutoreleasePool alloc] init];
int retVal = UlApplicationMain(argc, argv, nil, nil);

[pool release];

return retVal;

Listing A-2 HelloWorldAppDelegate.h

// HelloWorldAppDelegate.h
fHimport <UIKit/UIKit.h>

@interface HelloWorldAppDelegate : NSObject <UIApplicationDelegate> {
UIWindow *window;
}

@property (nonatomic, retain) IBOutlet UIWindow *window;

@end

Listing A-3 HelloWorldAppDelegate.m

// HelloWorldAppDelegate.m
fHimport "HelloWorldAppDelegate.h"
#import "MyView.h"

@implementation HelloWorldAppDelegate
@synthesize window;

- (BOOL)application:(UIApplication *)application
didFinishLaunchingWithOptions: (NSDictionary *)TaunchOptions {

// Override point for customization after application launch.
MyView *view = [[MyView alloc] initWithFrame:[window framell;
[window addSubview:view];

[view release];

[window makeKeyAndVisible];

return YES;
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- (void)dealloc {
[window release];
[super dealloc];

}

@end

Listing A-4 MyView.h

// MyView.h
J#import <UIKit/UIKit.h>

@interface MyView : UIView {
}

@end

Listing A-5 MyView.m

// MyView.m
#import "MyView.h"

@implementation MyView

- (id)initWithFrame: (CGRect)frame {
if (self = [super initWithFrame:framel) {
// Initialization code
}
return self;

- (void)drawRect:(CGRect)rect {
NSString *hello = @"Hello, World!";
CGPoint Tlocation = CGPointMake(10, 20);
UIFont *font [UIFont systemFont0fSize:247];
[[UIColor whiteColor] setl];
[hello drawAtPoint:location withFont:font];

- (void)dealloc {
[super dealloc];

@end
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Unit-Test Result Macro Reference

The SenTestingKit framework defines a set of test-case result macros that allow you to report the test-case
results to the framework. When a test fails, the framework emits a test-failure message, which Xcode displays
in text-editor, Build Results, or console windows, depending on the type of unit tests being performed.

The following sections describe the test-result macros you can use in your test-case methods. These macros
are declared in SenTestCase.h.

Important: When the expressions your test cases evaluate throw exceptions, they produce unknown errors.
To test whether your code raises exceptions, create test cases that explicitly check for the presence or absence
or exceptions; see "Exception Tests" (page 89).

Unconditional Failure

STFail

Fails the test case.
STFail(failure_description, ...)
Parameters

failure_description

Format string specifying error message. Can be ni 1.

(Optional) A comma-separated list of arguments to substitute into failure_description.
Equality Tests

STAssertEqualObijects

Fails the test case when two objects are different.
STAssertEqualObjects(object_1, object_2, failure_description, ...)

Parameters
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object_1

An object.
object_2

An object.

failure_description

Format string specifying error message. Can be nil.

(Optional) A comma-separated list of arguments to substitute into failure_description.

Detail

The test fails when [object_1 isEqualTo:object_217is false.

STAssertEquals

Fails the test case when two values are different.
STAssertEquals(value_1, value_2, failure_description, ...)
Parameters
value_1

A scalar, structure, or union.
value_2

A scalar, structure, or union.
failure_description

Format string specifying error message. Can be nil.

(Optional) A comma-separated list of arguments to substitute into failure_description.

Detail

The test fails when value_1 is not equal to value_2.

STAssertEqualsWithAccuracy

Fails the test case when the difference between two values is greater than a given value.

Equality Tests
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STAssertEqualsWithAccuracy(value_1, value_2, accuracy, failure_description, ...)
Parameters
value_1
An integer or a floating-point value.
value_ 2
An integer or a floating-point value.
accuracy
An integer or a floating-point value.
failure_description

Format string specifying error message. Can be ni 1.

(Optional) A comma-separated list of arguments to substitute into failure_description.
Detail

The test fails when the difference between value_1 and value_2 is greater than accuracy.

Nil Tests

STAssertNil

Fails the test case when a given expression is not nil.
STAssertNil(expression, failure_description, ...)
Parameters
expression

Expression to test.
failure_description

Format string specifying error message. Can be ni 1.

(Optional) A comma-separated list of arguments to substitute into failure_description.
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STAssertNotNil

Fails the test case when a given expression is nil.
STAssertNotNil(expression, failure_description, ...)
Parameters
expression

Expression to test.
failure_description

Format string specifying error message. Can be ni1.

(Optional) A comma-separated list of arguments to substitute into failure_description.

Boolean Tests

88

STAssertTrue

Fails the test case when a given expression is false.
STAssertTrue(expression, failure_description, ...)
Parameters
expression

Expression to test.
failure_description

Format string specifying error message. Can be ni 1.

(Optional) A comma-separated list of arguments to substitute into failure_description.

STAssertFalse

Fails the test case when a given expression is true.
STAssertFalse(expression, failure_description, ...)

Parameters

Boolean Tests
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Unit-Test Result Macro Reference

expression

Expression to test.

failure_description

Format string specifying error message. Can be ni1.

(Optional) A comma-separated list of arguments to substitute into failure_description.
Exception Tests

STAssertThrows

Fails the test case when an expression doesn't raise an exception.
STAssertThrows(expression, failure_description, ...)
Parameters
expression

Expression to test.
failure_description

Format string specifying error message. Can be ni 1.

(Optional) A comma-separated list of arguments to substitute into failure_description.

STAssertThrowsSpecific

Fails the test case when an expression doesn't raise an exception of a particular class.
STAssertThrowsSpecific(expression, exception_class, failure_description, ...)
Parameters
expression

Expression to test.
exception_class

An exception class.

Exception Tests 89
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failure_description

Format string specifying error message. Can be nil.

(Optional) A comma-separated list of arguments to substitute into failure_description.

Detail

The test fails when expression doesn't raise an exception of the class exception_class.

STAssertThrowsSpecificNamed

Fails the test case when an expression doesn't raise an exception of a particular class with a given name.

STAssertThrowsSpecificNamed(expression, exception_class, exception_name,
failure_description, ...)

Parameters
expression
Expression to test.
exception_class
An exception class.
exception_name
A string with the name of an exception.
failure_description

Format string specifying error message. Can be ni 1.

(Optional) A comma-separated list of arguments to substitute into failure_description.

Detail

The test fails when expression doesn’t raise an exception of the class exception_class with the name
exception_name.

STAssertNoThrow

Fails the test case when an expression raises an exception.

STAssertNoThrow(expression, failure_description, ...)

Exception Tests
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Parameters
expression

Expression to test.

failure_description

Format string specifying error message. Can be nil.

(Optional) A comma-separated list of arguments to substitute into failure_description.

STAssertNoThrowSpecific

Fails the test case when an expression raises an exception of a particular class.
STAssertNoThrowSpecific(expression, exception_class, failure_description, ...)
Parameters
expression

Expression to test.
exception_class

An exception class.
failure_description

Format string specifying error message. Can be nil.

(Optional) A comma-separated list of arguments to substitute into failure_description.
Detail

The test fails expression raises an exception of the class exception_class.

STAssertNoThrowSpecificNamed

Fails the test case when an expression doesn't raise an exception of a particular class with a given name.

STAssertNoThrowSpecificNamed(expression, exception_class, exception_name,
failure_description, ...)

Parameters

expression

Exception Tests 91
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Expression to test.

exception_class

An exception class.
exception_name

A string with the name of an exception.
failure_description

Format string specifying error message. Can be nil.

(Optional) A comma-separated list of arguments to substitute into failure_description.

Detail

The test fails when the expression raises an exception of the class exception_class with the name
exception_name.

STAssertTrueNoThrow

Fails the test case when an expression is false or raises an exception.
STAssertTrueNoThrow(expression, failure_description, ...)
Parameters
expression

Expression to test.
failure_description

Format string specifying error message. Can be ni 1.

(Optional) A comma-separated list of arguments to substitute into failure_description.

STAssertFalseNoThrow

Fails the test case when an expression is true or raises an exception.
STAssertFalseNoThrow(expression, failure_description, ...)
Parameters

expression

Exception Tests
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Unit-Test Result Macro Reference

Expression to test.

failure_description

Format string specifying error message. Can be nil.

(Optional) A comma-separated list of arguments to substitute into failure_description.

Exception Tests
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Glossary

active build configuration The build configuration
used to build a product. See also build configuration.

active SDK The SDK used to build a product and the
runtime environment on which the product is to run.
See also SDK family.

application ID A string that identifies an iOS
application or a set of iOS applications from one
vendor. They are similar to bundle identifiers. This is
an example application ID:
GFWOTNXFIY.com.mycompany.MyApp.

base SDK Project setting that specifies the default
SDK to use when building the project’s targets.
Targets can override this setting with the iPhone OS
Deployment Target build setting.

build configuration A named collection of build
settings that build one or more products in a project
in different for specific purposes—for example, for
debugging or for release.

certificate signing request (CSR) File that contains
personal information used to generate a development
certificate. Certificate signing requests are created by
the Keychain Access application.

code completion A shortcut that automatically

suggests likely completions as you type an identifier
or a keyword. The suggestions are based on the text
you type and the surrounding context within the file.

development certificate File that identifies an iOS
application developer. Xcode uses development

certificates to sign application binaries.

device family Type of device in which iOS can run.
There two device families: iPhone, and iPad.

entitlement A property that allows an application
to access a protected iOS feature or capability.
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instrument A data-gathering agent developed using
the Instruments application. Instruments collect
performance information about an application or an
entire system.

Instruments application A performance analysis tool
used to gather and mine application-performance
data.

iPhone Dev Center An Apple developer center that
provides all the resources needed to develop iOS
applications. Access to this developer center requires
an ADC membership. See also Apple Developer
Connection.

iPhone Developer Program A program that allows
you to develop iOS applications, test them on devices,
and distribute them to your customers through the
App Store.

iPhone Provisioning Portal A restricted-access area
of the iPhone Dev Center that allows you to configure
devices to test your iOS applications

iPhone Simulator application An application that
simulates the iOS runtime environment and user
experience in Mac OS X for testing iOS applications
in early stages of development.

project window A window that displays and
organizes the files that make up an Xcode project.

provisioning profile A file that allows applications
in development to be installed on an iOS-based
device. It contains one or more development
certificates, an application ID, and one or more device
IDs

SDK family Group of SDK releases used to build
software products for a particular Apple platform. The
available SDK families are iPhone Device SDK, iPhone
Simulator SDK, and Mac OS X SDK.
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test case A piece of code that executes test-subject
code to verify that it behaves as expected.

test-case method An instance method of a unit-test
class named test. .. that exercises API to test and
reports whether it produced the expected results.

test provisioning profile A provisioning profile
issued to users not on an iOS application developer
team. It allows them to install and test applications
that have not been published to the App Store.

test suite A set of test cases. See also test case.

Xcode A set of tools and resources used to develop
Cocoa and Cocoa Touch applications.

Xcode application The main application of the Xcode
integrated development environment (IDE). It
manages the other applications that are part of Xcode
and provides the main user interface used to develop
software products.
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Document Revision History

This table describes the changes to iOS Development Guide.

Date Notes

2010-07-02 Changed the title from iPhone Development Guide. Updated Hello, World!
tutorial to iPhone SDK 4.0.

Updated Hello, World! tutorial and source code ("Tutorial: Hello, World!" (page
17) and "Hello, World! Source Code" (page 83)) for iPhone SDK 4.0 toolset.

2010-05-28 Added information about automatic provisioning profile management,
application archiving, and application distribution.

Updated "Running Applications" (page 31) with details about using the Base
SDK and iPhone OS Deployment Target build setting and the Overview toolbar
menu in the Project window.

Updated "Using iPhone Simulator" (page 43) with information about how the
Objective-C-runtime change in iOS 4.0 affects existing iPhone Simulator binaries.

Updated "Managing Devices and Digital Identities" (page 47) to describe
automatic provisioning-profile management and how to manage developer
profiles in the Xcode Organizer.

Updated "Distributing Applications” (page 73) with details about the use of the
Build and Archive command and recommended workflow for distributing
applications for testing.

Added hardware-simulation support information to "Using iPhone
Simulator" (page 43).

2010-03-19 Added iPad information.

Added "Setting the Device Family" (page 35) to describe how to specify the
family of devices on which you want your application to run.

Added "Upgrading a Target from iPhone to iPad" (page 30) to explain how to
upgrade an iPhone target for building iPad applications.

Updated "Using iPhone Simulator" (page 43) with iPad information.

2010-01-20 Fixed typos and addressed feedback.

2009-08-06 Added information about editing property-list files, linking static libraries, and
iPhone Simulator versions. Made minor changes.

Added "Editing Property-List Files" (page 25).
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Document Revision History

Date Notes
Added important information about debugging applications on devices to
"Debugging Facilities Overview" (page 55).

Added "Setting the Simulation-Environment Device Family and iOS
Version" (page 43).

2009-05-28 Described how to set the architecture for which an application is built.
Added "Setting the Architecture" (page 35) to describe how to choose the
architectures an application can be built for.

2009-05-14 Added unit-testing information and streamlined build workflow.

Added "Unit Testing Applications" (page 59).

Added "iPhone Simulator Frameworks and Libraries".

Updated "Running Applications" (page 31) with streamlined build workflow.
Added information about restoring application data from a backup.

2009-04-08 Added information on creating entitlement property-list files. Made minor
content reorganization.

Added "Managing Application Entitlements" (page 27).

2009-03-04 Made minor content changes.

2009-02-04 Made minor content changes.

Updated "Capturing Screen Shots" (page 53) to specify how to get PNG files of
screen shots captured in the Organizer.

Updated "Building Your Application” (page 38) with application ID build-error
information.

2009-01-06 Made minor content additions.

Explained that iPhone Simulator binaries can be used on only one release of
the simulator.

2008-11-14 Added information about new iPhone Simulator features.
Added "Adding the iTunes Artwork to Your Application" (page 75).
Added information about the Simulate Memory Warning and Toggle In-Call
Status Bar commands to "Manipulating the Hardware" (page 44).
Added "Core Location Functionality" (page 45).
Added information about using static libraries in iOS applications to "Creating
an i0S-Application Project” (page 12).

2008-10-15 New document that describes how to develop iPhone applications using Xcode.
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Date

Notes

Incorporates content previously published in iPhone OS Programming Guide and
iPhone Simulator Programming Guide.
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