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1. INSTRUCTIONS

The Microsoft DOS 5.0 Hardware Compatibility Test (HCT) is a general test  for verifying the 
compatibility between hardware environments and DOS 5.0.

The following components make up the test kit:

* The HCT Test Instructions

the desired results.

* The HCT Checklists

* The HCT Problem Report Form

the checklist, will be addressed by Microsoft. 

The following describes the steps for completing the Hardware Compatibility Test.

FOLLOW THESE STEPS:
1. Make and distribute the following to your testing staff:

* copies of the HCT Test Instructions and the HCT Floppy Disk

* copies of the HCT Checklist for every configuration you intend to test

* copies of the HCT Problem Report Form

2. For each configuration, install DOS 5.0, install the HCT tests, complete each test as 
described in the HCT Test Instructions.

3. Record the results of each test in the HCT Checklist used for that configuration:

* If the test results correspond to the output described in the HCT Test Instructions, 
record a PASS status

* If the test results do not correspond to the output described in the HCT Test, 
record a FAIL status

* If a test is not run because it did not apply on the current configuration, record a 
N/A status

4. When a test status is FAIL:

* Make a copy of the HCT Problem Report Form, and fill it in completely 
describing the test, configuration and results

* Submit a copy of the completed HCT Problem Report Form to Microsoft 
DOS Testing via fax or mail and/or submit an electronic copy of the completed 
HCT Problem Report Form as a Service Request via OnLine
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Note:  It is not necessary to further debug a problem when one is encountered while 
performing the HCT test.  It is much more efficient to promptly report the failure 
to Microsoft and continue on with the remaining HCT tests.  In many cases the 
problem may have already been reported or a Microsoft engineer may be able to 
determine the root of the problem from the bug description.  You will be notified 
of the outcome of your report.

5. When all the tests have been completed on a configuration, submit the following to 
Microsoft  DOS Testing:

* A copy of the completed HCT Checklist for the configuration

* Additional copies of all HCT Problem Report Forms referenced in the HCT 
Checklist

6. Be prepared to submit additional information and/or hardware to Microsoft DOS Testing 
for debugging purposes

All materials submitted to Microsoft DOS Testing should faxed or mailed directly to:

Microsoft DOS Testing
Microsoft Corporation
One Microsoft Way
Redmond, WA 98052-6399

Fax: (206) 883-8101
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2. OVERVIEW

DOS Hardware Testing contains two components, the DOS Installation and the DOS 
Hardware Compatibility Test.

DOS must be installed using the DOS Install program.  The installation uses FDISK to create
hard disk partitions, formats the hard disk, and copies the necessary files for the configuration 
requested.  The DOS Install must perform all of these functions to determine hardware 
compatibility.  Therefore, the hard disk must be completed erased and partitions removed.

For machines with greater than 1 megabyte of memory, parts of DOS 5.0 are moved into 
high memory during the boot sequence.  (High memory, or extended memory, is the area of 
memory above the 1 megabyte boundary.  Having DOS is high memory frees space in 
conventional memory, memory less than 640 kilobytes.)  Control whether DOS  is located in 
high or in conventional memory in the CONFIG.SYS file, reading during the boot sequence.

The CONFIG.SYS entry:

DOS=HIGH

moves DOS into high memory.  This options is automatically put into the CONFIG.SYS 
file by the DOS Install if the machine DOS is installed on has extended memory.  The 
CONFIG.SYS entry may be changed to:

DOS=LOW

in order to keep DOS in conventional memory.  The machine must be re-booted for the 
change in CONFIG.SYS to take effect.

Once the DOS Install successfully installs DOS, each of the test programs in the DOS HCT 
must be run with DOS in both high and conventional memory.

The hardware compatibility of a particular configuration with DOS 5.0 is determined by the 
success of the installation of DOS 5.0 using the DOS Install program, the results from running 
the HCT Tests with DOS in high memory,  and the results from running the HCT Tests with 
DOS in conventional memory.  Any results of tests that differ from what is expected should be 
recorded on the HCT Problem Form.

A test checklist is provided to help technicians keep track of the tests to perform and their 
results.  The HCT Checklist is located at the end of the document.  Also included is the HCT 
Problem Form which should be copied, filled out, and appended to the HCT Checklist each time 
a problem is encountered.
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2.1 Glossary of Terms

This glossary lists some terms which are used within the DOS 5.0 Hardware Compatibility 
test as well as in the DOS environment in general.  In providing these terms the goal is to enable 
the tester to better understand the tests being preformed and perhaps generate further testing 
ideas.

Enhanced Keyboard - the 101-key keyboard.  The keyboard that includes cursor keys separate 
from the keys on the numeric keypad, function keys F11 and F12, and two CTRL and two ALT 
keys.

Extended Memory - Memory in 80286 and 80386 based machines which is located above the 
1MB address boundary.

HCT - The DOS 5.0 Hardware Compatibility Test.

HIMEM.SYS - HIMEM.SYS is a extended memory manager device driver which facilitates the 
execution of code in extended memory (memory above 1 Megabyte).  HIMEM.SYS provides a 
new programming interface (XMS) which is standard in the MS-DOS environment for accessing 
extended memory.  

OEM - an acronym for Original Equipment Manufacturer.  In this document, OEM indicates a 
manufacturer of hardware that DOS 5.0 executes on.

Test Machine  - the machine that you are using to run the DOS 5.0 Hardware Compatibility 
Test.

XMS - an acronym for eXtended Memory Specification, an interface for accessing extended 
memory, memory above the 1 megabyte boundary.

XMS Manager - a memory manager that handles allocation and deallocation of extended 
memory.  HIMEM.SYS is the XMS Manager that DOS uses.
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3. HCT TEST INSTALLATION

TEST ONE:  DOS 5.0 Installation

Objective:
Test whether DOS 5.0 can be successfully installed on a OEM's test machine.

Procedure:
Erase Hard Disk
The hard disk on the test machine must be completely erased and all partitions removed.  The
HCT requires that the OEM Install program FDISK and FORMAT your hard disk.

Install DOS
Boot from the OEM Install Disk and follow the instructions on the screen to install DOS 5.0 
on your hard disk.

• At the first menu, select DISK TYPE to install DOS 5.0 to hard disk.

• At  the second menu, "Installation Options" , the Shell  and MS-Mouse must be selected 
if the test machine has a mouse installed.  The DOS Shell is used to test mouse 
operations.

•

The OEM Install uses FDISK to create partitions on your hard disk, formats your hard disk, 
and installs DOS 5.0.  When the machine reboots, DOS 5.0 automatically installs the DOS 
shell.  Exit the DOS Shell and get to a command prompt by pressing ALT-F4.

Install the DOS HCT Tests
Put the DOS HCT floppy disk in the disk drive.  Copy the DOS HCT files into the \DOSHCT
directory with the following command.

XCOPY A:\DOSHCT C:\DOSHCT 
where drive A: is the floppy drive for the DOS HCT floppy and drive C: is the hard 

disk where DOS is installed.

answer "d" to the "(F = file, D =directory)?" prompt.  Change the current directory on your 
hard disk to the newly-created \DOSHCT directory with the following command.

CD \DOSHCT

Results:
The installation program should complete successfully with the menu display:  "The 
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installation program is now complete."  The test machine should be bootable from its own 
hard disk.  The DOS HCT files should be installed at the \DOSHCT directory.
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4. HCT TEST INSTRUCTIONS

The following tests must be run with DOS running in conventional memory (DOS=low) and 
DOS running in extended memory (DOS=high).  The DOS 5.0 Installation program 
automatically installs DOS in high memory with the DOS=HIGH command in the 
CONFIG.SYS file, if the test machine has extended memory.  To test DOS in low memory, the 
CONFIG.SYS file must be changed so the above entry reads DOS=LOW and the machine must
be rebooted.

HCT Checklist Configuration Information

Use the ver command to determine the version of DOS you are running.  Use the type command 
to display the AUTOEXEC.BAT and CONFIG.SYS files.  Record this and the hardware 
configuration information on the HCT Checklist.

TEST TWO:  Floppy FORMAT Test

Objective:
Test whether FORMAT works on the vendor's floppy drives.  The FMT_TEST batch file 
provides for testing of all floppy drive types.

Estimated Time:
15 minutes.

Procedure:
Run FMT_TEST specifying drive letters for 5.25 inch drives and 3.5 inch drives.  If a disk 
size is not supported, indicate "-" for the drive letter.

FMT_TEST  [/?] 5.25drive: 3.5drive: 

/? displays help information on running this test script.
5.25drive the drive letter for a floppy drive that uses 5.25 inch disks.  Use "-" if the test 

machine does not support 5.25 inch disks.
3.5drive the drive letter for a floppy drive that uses 3.5 inch disks.  Use "-" if the test 

machine does not support 3.5 inch disks.

The test script asks whether each format configuration is supported.  For each "y" response, 
FMT_TEST will start the FORMAT program with the proper drive and type.  FORMAT then
asks you  to press ENTER when ready.  After formatting, FORMAT may ask for a drive 
label.  When FORMAT asks whether to FORMAT another disk, respond "n".  FMT_TEST 
will move on to the next disk type.
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The following FORMAT options are tested.

FORMAT /s /f:160
160KB 5.25" floppy disk
FORMAT /s /f:180
180KB 5.25" floppy disk
FORMAT /s /f:320
320KB 5.25" floppy disk
FORMAT /s /f:360
360KB 5.25" floppy disk, must be supported if 5.25" drives are used
FORMAT /s /f:1.2M
1.2MB 5.25" floppy disk
FORMAT /s /f:720
720KB 3.5" floppy disk, must be supported if 3.5" drives are used
FORMAT /s /f:1.44M
1.44MB 3.5" floppy disk
FORMAT /s /F:2.88M
2.88MB  3.5" floppy disk

Results:
FORMAT should successfully format the floppy disk types supported by the test machine.  
At minimum, 360 kilobyte floppy disks must be supported for 5.25 inch drives and 720 
kilobyte floppy disks must be supported for 3.5 inch drives.
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TEST THREE:  Disk Test

Objective:
Verify the operation of the INT 13 Disk Access Calls not used during the FORMAT process 
in the OEM install.

Estimated Time:
5 minutes.

Procedure:
The user starts the DISKTEST  program with the following command line for all physical 
drives installed.

DISKTEST  [/?] drive  [/AT]
/? displays help information on running this test  program
drive indicates the drive letter to test (specified with a colon, ex:  C:), or 

physical drive number (see below)
/AT indicates the test machine is AT-compatible or better

DISKTEST assumes the A: and B: are floppy drives and C: and drive letters thereafter are 
hard drives.  If the test machine does not support this standard, the user must specify the 
physical drive number in hex in the drive parameter.  The first floppy disk is drive 0, the 
second floppy drive is drive 1, etc..  The first hard disk is drive 80, the second hard drive is 
drive 81, etc.

When testing a floppy drive, DISKTEST prompts the user to open and close the floppy 
drive door without changing the floppy disk to test the disk change detection. 

Results:
Are displayed on the screen, or may be piped into a file or to a printer.

• Get Drive Parameters, INT 13h Function  08h, is supported on floppy drives and may or 
may not be supported on hard drives.  The number of sectors, cylinders, heads, and drives
attached to this adapter should be correct for your machine.

• Reset Disk, INT 13h Function 00h, should always return "OK".

• Read Track, INT 13h Function 02h, should read and dump the first sector of the disk 
specified.  For a hard disk, the last two bytes are 55AA.

For a bootable floppy disk, the first three bytes should be
EB xx 90
or

and the last two bytes are 55AA.
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•
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TEST FOUR:  Display Mode Test

Objective:
Test all video modes available for the display installed.  Verify all available colors and 
attributes can be displayed in each mode.

Estimated Time:
5 minutes.

Procedure:
The user starts the MODETEST  program with the following command line for the display 
installed.

MODETEST  [/?] [/cga | /ega | /vga]
/? displays help information on running this test  program
/cga indicates the display installed is a color graphics adapter (default)
/ega indicates the display installed is a enhanced graphics adapter
/vga indicates the display installed is a video graphics adapter

MODETEST describes each video mode and prompts the user to press a key before 
switching video modes.  The user must press a key to switch to the next mode.

Results:
The user should verify that each color of those available is displayed.  In text modes, the 
user should verify that the number of rows and columns is correct.
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TEST FIVE:  QBASIC Testing

Objective:
Test all video modes, screen swapping, and user interface display of QBASIC.

Estimated Time:
15 minutes.

Test 5.1 * Verify Screen Modes
Procedure:

Start the QBASIC screen mode compatibility test with the following command and 
follow the instructions on the screen.

QBASIC COMPAT

When the tests are completed, the file COMPAT1.BAS appears as the main file in the 
QBASIC editor.    Exit QBASIC by press ALT-F to select the file menu, then X to Exit.  
The file RESULTS.TXT contains a summary of the number of pages supported in each 
video mode.  Use type, edlin, or edit to examine the file and verify the results.

Results:
Each video mode used by QBASIC is displayed.  RESULTS.TXT should contain the 
proper pages for the display installed.

Test 5.2 * Verify Screen Swapping
Procedure:

Start the QBASIC screen swapping test with the following command and follow the 
instructions on the screen.  Exit QBASIC by press ALT-F to select the file menu, then X 
to Exit.

QBASIC SCREEN

Results:
QBASIC swaps screens in various display modes correctly as described.

Test 5.3 * Monochrome Menu/Help Screens
Procedure:

Start the QBASIC  monochrome test with the following command and follow the 
instructions on the screen.  Exit QBASIC by press ALT-F to select the file menu, then X 
to Exit.

QBASIC /B TESTB.BAS

Results:
QBASIC menus, help screens, and highlighted items are visible as described.
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Test 5.4 * High Resolution Menu/Help Screens
Procedure:

Start the QBASIC hi-res test with the following command and follow the instructions on 
the screen.  Exit QBASIC by press ALT-F to select the file menu, then X to Exit.

QBASIC /H TESTH.BAS

Results:
QBASIC menus, help screens, and highlighted items are visible as described.

Test 5.5 * No-Highlighting Menu/Help Screens
Procedure:

Start the QBASIC no-highlighting test with the following command and follow the 
instructions on the screen.  Exit QBASIC by press ALT-F to select the file menu, then X 
to Exit.

QBASIC /NOHI TESTNOHI.BAS

Results:
QBASIC menus, help screens, and highlighted items are visible as described.
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TEST SIX:  Printer/Serial Port Test

Objective:
Confirm that DOS can interface with the printer and serial ports of the test machine.

Test 6.1 * Printer Test - PRINTER
Procedure:

The PRINTER test program should be run for each printer port installed on the test 
machine.  The user starts the PRINTER program with the following command.

PRINTER  [/?] printer
/? displays help information on running this test  program
printer indicates the printer port to use (LPT1, LPT2, or LPT3)

Results:
Are displayed on the screen, or may be piped into a file or to a printer.

The PRINTER test attempts to initialize the printer port and write a series of characters to
it using  BIOS INT 17h.  If no printer is attached, the test program responds "printer 
timed out" during initialization.  This error is expected if a printer is not attached.  Other 
errors may occur during printer output calls if a printer is not attached.

Test 6.2 * Communications Port Test - COMTEST
Procedure:

The COMTEST test program should be run for each serial port installed on the test 
machine.  The user starts the COMTEST program with the following command.

COMTEST  [/?] port
/? displays help information on running this test  program
port indicates the serial port to use (COM1, COM2, COM3, or COM4).

Results:
Are displayed on the screen, or may be piped into a file or to a printer.

The COMTEST test initializes the COM port for all possible configuration settings, and 
attempts to send and received data using the COM port.  With no hardware attached to the
COM port, the test program responds "COM port timed out" when trying to send or 
receive.  This error is expected if a peripheral is not installed.  After a send attempt, the 
"clear-to-send signal toggled" message should appear.  After a receive attempt, the "data-
set ready toggled" and "clear-to-send signal toggled" messages should appear.
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TEST SEVEN:  System, Keyboard, and Timer BIOS Test

Objective:
Verify correct operation of commonly used calls of the machine's ROM BIOS.

Test 7.1 * Get System Information - SYSINFO
Objective:

The SYSINFO test program makes certain BIOS calls to determine information about the test
machine and displays the information for the user to verify.  

Procedure:
The user starts the SYSINFO program with the following command line.  If the test machine 
is AT-compatible or higher lever, the user should call SYSINFO with the /AT flag.

SYSINFO  [/?] [/AT]
/? displays help information on running this test program.
/AT indicates test machine is an AT-compatible or higher level machine

Results:
Are displayed on the screen, or may be piped into a file or to a printer.

• Get system environment, INT 15h Function C0h, may or may not be supported.  If this 
call is supported, then the information reflected on machine model and BIOS revision 
level should be correct.  If it is not supported, SYSINFO should indicate that the carry 
flag was set on return from this BIOS call.

• Get conventional memory size, INT 12h, should return the amount of conventional 
memory available.  The SYSINFO program uses approximately 15K during execution. 
The  amount of conventional memory available should be verified with the DOS mem 
command.

• Get extended memory size, INT 15h Function 88h, should indicate if no extended 
memory is installed.  If extended memory is installed, it may or may not be indicated 
with this call depending on whether an XMS driver such as HIMEM.SYS is installed.  
HIMEM.SYS uses all of extended memory, which causes this call to return "no extended 
memory available".  SYSINFO should indicate the presence of an XMS driver.  The 
amount of extended memory available should be verified with the DOS mem command.

• Get equipment configuration, INT 11h, should return the correct hardware information 
and default video mode for the test machine.  The number of printer ports may indicate 
three logical ports for a single printer port.

Test 7.2 * Keyboard Test - KEYBOARD
Objective:
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The KEYBOARD test program tests the mapping of the keyboard keys by asking the user to 
type each key and key-combination (control, alternate, shift) recognized by the BIOS.  
KEYBOARD also verifies control-C and control-break are captured in event handlers.  

Estimated Time:
5 minutes.

Procedure:
The user starts the KEYBOARD program with the below command line and presses the keys 
as directed by the program.  To provide for typing errors, KEYBOARD asks for a key three 
times before an error is marked as permanent.  All permanent errors should be recorded on 
the HCT Problem Form.  If an "enhanced keyboard" is used (separate cursor keys and 
numeric keypad, F11 and F12 included), the user should call KEYBOARD with the /e flag.  

KEYBOARD  [/?] [/e]
/? displays help information on running this test  program.
/e indicates test machine has an enhanced keyboard

Results:
After each key asked for is correctly pressed, KEYBOARD indicates "OK".  If a wrong key 
is pressed, KEYBOARD asks for the correct key three times before indicating a permanent 
error.  When KEYBOARD asks for control-C and control-break, it should reply that these 
keys were correctly captured in an event handler.

Test 7.3 * Time and Date Verification - TIMETEST
Objective:

The TIMETEST test program verifies that DOS can set the date and time on the test 
machine.  TIMETEST sets the date and time appropriately and confirms that minutes 
increment at the rollover of the seconds, hours increment at the rollover of the minutes, days 
increment at the rollover of the hour, and months and years increment at the proper time.

Procedure:
The user starts the TIMETEST  program with the following command line.

TIMETEST  [/?]
/? displays help information on running this test  program.

TIMETEST alters the current date and time used by DOS.  The user must reset the date and 
time after TIMETEST terminates with the DOS date and time commands.

Results:
Are displayed on the screen, or may be piped into a file or to a printer.

TIMETEST sets the date and time, waits to allow for rollover, and gets the current date and 
time to confirm rollover.  At each step, the current date and time and verification of rollover 
are displayed.  If an error is indicated by TIMETEST, the user should attempt to recreate the 
error using the DOS date and time commands.
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TEST EIGHT:  Advanced Function Tests

Objective:
Verify that advanced operations of the 80286, 80386, and 80486 processors are handled 
correctly.  Test the A20 line used for  extended memory management and confirm that DOS 
queries respond correctly.  Tests the BIOS initialization of the segment registers in real mode 
(including FS and GS) and confirms each segment register can access a full 64K of memory.

Test 8.1 * A20 line toggle test - A20TEST
Procedure:

The XMS Manager HIMEM.SYS should be installed for this test.  (The installation 
program should automatically configure your system properly with HIMEM.SYS if the 
test machine has extended memory.)  The user starts the A20TEST program with the 
following command.

A20TEST  [/?] 
/? displays help information on running this test  program

Results:
Are displayed on the screen, or may be piped into a file or to a printer.

The A20TEST program confirms that  memory addresses wrap properly when the A20 
line is disabled and do not wrap when the A20 line is enabled.

Test 8.2 * eXtended Memory Test - XMSTEST
Estimated Time:

20 minutes.

Procedure:
The XMS Manager HIMEM.SYS should be installed for this test.  (See the installation 
instructions for configuring your system.)  The user starts the XMSTEST program with 
the following command.

XMSTEST  [/?] 
/? displays help information on running this test  program

Results:
Are displayed on the screen, or may be piped into a file or to a printer.

The XMSTEST program allocates all available extended memory, attempts to move 
blocks of memory between conventional and extended memory, and confirms the correct 
moving of memory.  After each block is moved, XMSTEST responds "OK".

Test 8.3 * Protect Mode Test - PROTECT
Procedure:
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This test should be used only if the test machine is based on the 386 or 486 processor.  
The user starts the PROTECT program with the following command.

PROTECT  [/?] 
/? displays help information on running this test  program

Results:
Are displayed on the screen only.

The PROTECT program allocates a 64K block of memory and attempts to write to the 
entire 64K using the DS, ES, FS, and GS segment registers.  If an incompatibility 
problem exists with one of these registers the program may display the following error

error in register buffer writing at index offset.

where register is either DS, ES, FS, or GS and offset is a number between 0 and 65535.  
Also, an incompatibility problem may cause the program to hang after the message

program will hang here if the machine is incompatible...
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TEST NINE:  DOS Shell

Objective:
Test display and mouse operation with an application that is video-intensive and can be 
mouse driven.

Estimated Time:
15 minutes.

Procedure:
1. Start the DOS Shell with the DOSSHELL command.
2. Double-click on the File Manager icon (for this and the following commands, do not use 

the keyboard unless explicitly specified.  Clicking is performed with the left mouse 
button.)

3. Pull down the Tree menu and click on the Expand All command.
4. Verify the file structure shown in the left window is a correct representation of the current

drive.
5. Click on the \DOSHCT subdirectory so that files of that directory are shown in the right 

window.
6. Pull down the File menu and click on the Select All command.  Verify that all files of the

\DOSHCT directory are highlighted in the right window.
7. Pull down the Options menu and click on the File Options command.  Change so the File 

Manager does not "Confirm on Delete".  Click on the OK button.
8. Pull down the File menu and click on the Delete command.  Click on the OK button. The 

file list on the left window should indicate "No files in selected directory".
9. Pull down on the Arrange menu and click on the Multiple File List command.
10. Insert the DOS HCT disk into a floppy drive.  Click on the appropriate drive on one of 

the file lists so that the hard disk is displayed in one list and the DOS HCT floppy disk is 
displayed in another.

11. Click on the \DOSHCT subdirectory of the floppy drive so that files of that directory are 
shown in the right window.

12. Pull down the File menu and click on the Select All command.  Verify that all files of the
floppy DOSHCT directory are highlighted in the right window.

13. Click on the DOSHCT subdirectory of the hard drive.
14. Pull down the File menu and click on the Copy command.  Click on the OK button.  

Verify that the file list for the hard disk (left window) contains the DOS HCT files.  The 
DOS HCT files should be restored in the DOSHCT directory on the hard disk.

15. Pull down the File menu and click on the Exit command.  Pull down the Program menu 
and click on the Exit command.

16. Start the DOS Shell with the DOSSHELL /SWAP command.  (This allows for left-
handed use of the mouse by enabling the right mouse button.)

17. Double-click on the File Manager icon (for this and the following commands, do not use 
the keyboard unless explicitly specified.  Clicking is performed with the right mouse 
button.)
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18. Pull down the Tree menu and click on the Expand All command.
19. Verify the file structure shown in the left window is a correct representation of the current

drive.
20. Click on the \DOSHCT subdirectory so that files of that directory are shown in the right 

window.
21. Pull down the File menu and click on the Select All command.  Verify that all files of the

\DOSHCT directory are highlighted in the right window.
22. Pull down the Options menu and click on the File Options command.  Change so the File 

Manager does not "Confirm on Delete".  Click on the OK button.
23. Pull down the File menu and click on the Delete command.  Click on the OK button. The 

file list on the left window should indicate "No files in selected directory".
24. Pull down on the Arrange menu and click on the Multiple File List command.
25. Insert the DOS HCT disk into a floppy drive.  Click on the appropriate drive on one of 

the file lists so that the hard disk is displayed in one list and the DOS HCT floppy disk is 
displayed in another.

26. Click on the \DOSHCT subdirectory of the floppy drive so that files of that directory are 
shown in the right window.

27. Pull down the File menu and click on the Select All command.  Verify that all files of the
floppy DOSHCT directory are highlighted in the right window.

28. Click on the DOSHCT subdirectory of the hard drive.
29. Pull down the File menu and click on the Copy command.  Click on the OK button.  

Verify that the file list for the hard disk (left window) contains the DOS HCT files.  The 
DOS HCT files should be restored in the DOSHCT directory on the hard disk.

30. Pull down the File menu and click on the Exit command.  Pull down the Program menu 
and click on the Exit command.

Results:
While executing the steps noted above, the files in the \DOSHCT subdirectory should be 
deleted and then restored from the floppy disk.  If the all procedure steps specified above 
function correctly, the files used in the DOS HCT test should have been restored intact.

Microsoft DOS 5.0 Hardware Compatibility Test, revision 1.0 23



MICROSOFT CONFIDENTIAL

5.  FILES PROVIDED WITH THE HARDWARE COMPATIBILITY TEST

The following files are provided on the DOS HCT distribution disks.

A20TEST.EXE - a DOS program which tests the toggling of the A20 line, which is used to 
access extended memory.

COMPAT.BAS - a QBASIC program that switches to all video pages for the display 
installed.

COMPAT1.BAT - a chained file that is part of the COMPAT.BAS test.

COMTEST.EXE - a DOS program which writes data to and reads data from the 
communications port installed on the test machine.

DISKTEST.EXE - a DOS program used to test the BIOS interrupts for accessing the disk 
drives installed in the test machine.

FILLSCRN.EXE - a DOS program used to fill the screen with 'X's of various colors in 
conjunction with the MODETEST program.

FMT_TEST.BAT - a DOS batch file that formats a floppy disks for all formats supported by
DOS 5.0.  FMT_TEST calls the FORMAT program repeatedly using a variety of 
command line switches corresponding to disk formats.

HCTLIST.XLS - the Microsoft Excel for Windows source for the HCT Checklist.

HCTPROB.XLS - the Microsoft Excel for Windows source for the HCT Problem Report 
form.

KEYBOARD.EXE - a DOS program that prompts for various keystrokes used to test the 
DOS - keyboard interface.

MODETEST.EXE -  a DOS program that tests all of the video modes available for the 
display installed.  MODETEST uses the FILLSCRN program.

PRINTER.EXE - a DOS program that makes queries and attempts to write data to the 
printer port (and printer, if installed).

README.DOC - the Microsoft Word for Windows source for this document.

PROTECT.EXE - a DOS program for 80386 or 80486 based test machines that tests the 
initialization of the BIOS segment registers.

RESULTS.TXT - output from the QBASIC COMPAT program summarizes the display 
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modes supported and disks installed.

SCREEN.BAS - a QBASIC program that tests screen swapping.

SYSINFO.EXE - a DOS program that displays information about the test machine received 
from interrupts with the BIOS code.

TEST.BAS
TESTH.BAS
TESTNOHI.BAS - QBasic programs that verify the user interface and help screen are 

readable in various screen modes.

TIMETEST.EXE  - a DOS program that sets the current date and time and confirms the 
clock continues to run normally.

XMSTEST.EXE - a DOS program that tests the moving of blocks between extended and 
conventional memory.

YNC.EXE - a program used in the FMT_TEST batch file for user prompts.
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	6. Be prepared to submit additional information and/or hardware to Microsoft DOS Testing for debugging purposes

	All materials submitted to Microsoft DOS Testing should faxed or mailed directly to:
	Microsoft DOS Testing Microsoft Corporation One Microsoft Way Redmond, WA 98052-6399
	Fax: (206) 883-8101

	2. OVERVIEW
	2.1 Glossary of Terms

	3. HCT TEST INSTALLATION
	TEST ONE: DOS 5.0 Installation

	4. HCT TEST INSTRUCTIONS
	HCT Checklist Configuration Information
	TEST TWO: Floppy FORMAT Test
	TEST THREE: Disk Test
	TEST FOUR: Display Mode Test
	TEST FIVE: QBASIC Testing
	TEST SIX: Printer/Serial Port Test
	TEST SEVEN: System, Keyboard, and Timer BIOS Test
	TEST EIGHT: Advanced Function Tests
	TEST NINE: DOS Shell

	5. FILES PROVIDED WITH THE HARDWARE COMPATIBILITY TEST

