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1.0 - Installation

The zip file should have included the following:

winmaze.scr - The screen saver
winmaze.wri - This file
readme.txt - An overview text file
orderfrm.txt - A text order form for printing.  (Also found at the end of this document.)

To install the winmaze screen saver, simply copy winmaze.scr into your primary windows directory (the same 
directory win.com is in).  For example, if windows is installed in c:\windows and you are at a dos prompt in the
same directory as winmaze.scr, you can type:

copy winmaze.scr c:\windows

This will complete the installation.  If you run the Desktop control panel, you will see 'Maze Solver' as one of 
the screen savers.  Read the rest of this manual for instructions on configuring the screen saver.  You may 
keep winmaze.wri and readme.txt anywhere you like.

2.0 - Hardware/Software requirements

The Maze Solver screen saver should run on any 286 or higher system running Microsoft Windows version 
3.1.  There are reports that this screen saver may have difficulty under the Norton Screen Saver, but we have 
not confirmed this.  Registered users also receive a version that runs under Windows NT.

3.0 - Disclaimers

While care has been taken to ensure the quality of this product, we cannot be responsible if this product 
destroys your computer, your life, or the universe as we know it.

4.0 - Registration

If you are reading this, we are impressed.  Registration is $15.  The registration form is contained at the end 
of this document.  After registering, you will receive two disks (one PC, one Mac) which includes the most 
recent versions of the following:

- MS Windows 3.1 Maze Solver screen saver/program with password protection.

- MS Windows NT 3.1 Maze Solver screen saver/program for Intel based computers. (Password 
protection is built-into NT.)

- Macintosh Maze Solver screen saver for After Dark and Darkside of the Mac.

- Macintosh Maze Solver application program.
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5.0 - General Info

Once installed and selected as the current screen saver, Maze Solver will run with default settings without any
other configuration information.  If you choose to further configure Maze Solver, see the following sections 
describing the dialog boxes and configuration options.  Almost every facet of Maze Solver can be configured.

Maze Solver also runs correctly as an executable application.  Change the name of the file winmaze.scr to 
winmaze.exe and put it in any directory you want.  The primary item missing as an executable is that the size 
of the maze will always be the full size of the window.

The screen saver will store any needed configuration information in a .INI file that is in the same directory as 
the program.  Under WinNT, this information is stored in the screen saver portion of the current user's registry.
(Yes, each user can have their own settings).

The registered version of Maze Solver has password protection that we believe to be at least equal to the 
security provided with the built-in Windows screen savers.  Unfortunately, built-in detection of network 
passwords is not supported.  The registered version also comes with Macintosh-After Dark, Macintosh stand 
alone, and MS Windows NT versions of the screen saver.

As a final note, limits for certain values are shown in parenthesis.  For example, if an integer edit box only 
accepts numbers 1-23, the description will be followed by (1-23).

6.0 - Configuring Maze Solver

When run as a program, or in configuration mode, a menu is available which has many commands for 
configuring the display.  The following will document these commands in menu order.

6.1 - The File Menu

6.1.1 - New

This command is executed by choosing New from the File menu or pressing the letter 'N'.  There is no dialog 
box associated with this command.  This command allows a new maze to be generated.  It will restart the 
maze if it is paused.

6.1.2 - Open Dialog

This dialog is brought up by choosing Open from the File menu or pressing the letter 'O'.  From this dialog you
can load any setting you have saved, or any of the built-in settings.  Simply choose OK after making a 
selection, or double click on a selection.
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6.1.3 - Save Dialog

This dialog is brought up by choosing Save as from the File menu or pressing Control and S keys at the same
time (Control-S).  Type in a name up to 32 characters long and select OK to save the settings.  Any printable 
character is valid.  Double clicking an existing name will allow you to replace that entry.  A Yes/No 
confirmation box will pop up before overwriting an existing setting.

6.1.4 - Delete Dialog

This dialog is brought up by choosing Delete from the File menu or pressing the letter 'D'.  Select the entry to 
delete, or double click on an entry.  A Yes/No confirmation box will pop up before deleting the entry.  NOTE: If 
you are running under Windows 3.1, this will not free up any space in the .INI file.  If you are so low on disk 
space that this is an issue, load the .INI file into a text editor and remove and section that starts with '[user.' 
that does not exist in the [EntryInfo] section.  The [EntryInfo] section may also be compressed by 'squeezing 
out' the blank entries.  Keep in mind that the entries must remain sequential, so don't just yank them. Also, 
update the NumEntries field appropriately.

6.1.5 - Exit

This command is executed by choosing Exit from the File menu or pressing the letter 'Q', or by pressing Alt-
F4.  There is no dialog box associated with this command.  This command quits the program when it is 
running as a stand alone program, or in screen saver configuration mode.  Any settings will be saved and 
retrieved the next time the program is run.

6.2 - The Edit Menu

6.2.1 - Copy

This command is executed by choosing Copy from the Edit menu or pressing Control-C.  There is no dialog 
box associated with this command.  This command allows the current maze in its current state to be copied 
into the edit (cut and paste) buffer.  You can then paste the maze into any paint program.
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6.3 - The Options Menu

6.3.1 - Color Dialog

This dialog is brought up by choosing Colors from the Options menu or pressing the letter 'C'.  Choosing any 
of the color buttons will bring up the Windows standard color selector.  The color buttons have the following 
meanings:

Background Color: The color 'underneath' the maze.

Path Color: The color used to draw the current path.

Trailer Color: The color to draw where the maze has already been.

Wall Color: The color of the dividing walls.

6.3.2 - Walls Dialog

This dialog is brought up by choosing Walls from the Options menu or pressing the letter 'W'.  These settings 
change the granularity of the maze.  Many interesting things can be created by adjusting these settings since 
0 is a valid value for the wall and between width.  Each width has the following meaning:

Wall Width: Width in pixels of the dividing walls in the maze. (0-32)

Between Width: Width in pixels of the space to leave on either side of the path when traveling through the 
maze. (0-32)

Path Width: Width in pixels of the path that travels through the maze. (1-32)
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6.3.3 - Misc Dialog

This dialog is brought up by choosing Misc from the Options menu or pressing the letter 'M'.  The fields have 
the following meaning:

Pause Time:  These allow you to choose how many seconds the maze pauses after it is first created and after
it is solved respectively.  (0-60)

Maze has an Exit: Most mazes have an exit.  If you choose to remove exits, then a maze path will travel 
through the entire maze.  The maze is finished when every cell has been visited.  This is a 
good way to 'fill' the maze when the trail color is different from the background color.

Exit Blinks: This option is only available if the maze has an exit.  With this option set the exit square will blink 
every half a second.

Logo in the Maze: When the maze is large enough, the Knoware logo will pop up in a random position in the 
maze.  Disable this setting if you don't like the logo.

System Priority: This determines how much work the maze will try to do before giving time back to the system.
If the maze is moving too quickly for your tastes, lower this number.  Of course raising the 
number will increase the performance of the maze to a point (values above 250 don't seem to
change the behavior much).  If you are running the maze as a program, or if you have a 
background task going on while the screen saver is active (ie: a modem download), you may 
want to keep this number lower - under 50 should be good.  Your mileage may vary.  (0-
10000)

6.3.4 - Pause

This command is executed by choosing Pause from the Options menu or pressing the space bar.  There is no
dialog box associated with this command.  This command allows the current maze to be pause and resumed 
during creation or solving.  It is useful to pause and 'Copy' the maze.

6.3.5 - Title Bar

This command is executed by choosing Title Bar from the Options menu, pressing the letter 'T' or double 
clicking on the client region of the screen (the part where the maze is).  There is no dialog box associated with
this command.  This command removes and brings back the menu and title bar from the window.  Using this 
command will also cause the menu bar to disappear.  Remember, to bring it back, either press the letter 'T', or
double click the mouse in the client area of the window.

7



6.3.6 - Status Bar

This command is executed by choosing Status Bar from the Options menu or pressing the letter 'S'.  There is 
no dialog box associated with this command.  This command toggles a visible status bar at the bottom of the 
screen.  The status bar displays context hints on the currently highlighted menu item.  When idle, it displays 
the name of the program and the current version.  There are two small displays on the right side also.  One 
will display 'Pause' if the solver is currently paused, the other one will show a percentage complete display 
while the maze is being created.  This is very useful if the maze being created is 'invisible'.  Try loading the 
'Fractal Like Maze' as an example of this.

6.3.7 - Percent Dialog

This dialog is brought up by choosing Percent from the Options menu or pressing the '%' key.  This choice is 
not available if you are running the maze as a program.  Each of the fields has the following meaning:

Wandering Maze: If enabled, the maze will slide around on the screen as it is created and solved.  When 
enabling this button another dialog will come up requesting how many times per second to 
slide the box.  Legal values are from 1-30, although under Windows 3.1 values above 18 will
probably all execute at about the same frequency.  NOTE: To change the update frequency 
deselect the checkbox and reselect it.  If the Wandering Maze option is disabled, the maze 
will be relocated before each new creation so as to prevent burn in.  Even if the maze 
screen saver is running 'full screen', there is a small area set aside for it to bounce around 
in.

Custom Border Color:  Enable this if you wish the background of the screen to be different from the 
background of the maze.  When enabled the color button will appear below it.  Also 
choose this if the background color for the maze is not a solid color and you are seeing 
aliasing on the screen when the maze slides.  

Color Button: When Custom Border Color is enabled, this button exists.  Choose it to select a custom 
background.  Custom backgrounds must be a solid color, if you choose a 'pattern' color, you will 
be informed that the closest solid will replace it.  If you care, the reason for this is the way the 
maze is moved when it slides.  The maze is simply copied from its current location to a new 
location 1 or 2 pixels away.  A little extra is dragged along to remove leftovers from the original 
maze.  Using a pattern color tends to drag the background without preserving correct pattern 
layout.

Percentages: Set these values to select what percentage of the screen is filled in with a maze. (5-100)
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6.3.8 - Password Dialog

This dialog is brought up by choosing Password from the Options menu or pressing the letter 'P'.  This choice 
is not available if you are running the maze as a program.  Also, this choice is only available if you have the 
registered program. NOTE: All three of these text fields display a '*' for each character typed.  Also, there is a 
limit of 12 characters for each field.  Each of the fields has the following meaning:

Old Password: If a password is already set, you must type the current value here.

New Password: Your selection for the new password.

Again: Same as the 'New Password'.  Entered to verify correct typing.

6.4 - The Help Menu

6.4.1 - About

This command is executed by choosing About from the Help menu.  There is no hotkey for it.  It just brings up 
the about box.  Whee.
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7.0 - Questions and Answers (look here!)

Q: Can I make the maze slide around on the screen?
A: Yes, when configuring the screen saver, select Percent from the Option menu.  Choose the top radio 

button (Wandering Maze), and select how often the screen should update.  

Q: Will sliding the maze be too slow on my system?
A: Maybe.  It looks good on the 486 systems we tried it on.  It should be ok on 386 system with good video 

boards.  If the maze flickers or does not create/solve fast enough, try setting a lower update frequency.

Q: How do I adjust the update frequency for when the maze slides?
A: Well, it isn't obvious, we admit it.  In the Percent dialog from the Options menu, turn the 'Wandering Maze' 

option on.  If it is already on, turn it off and then on again.

Q: I get weird 'artifacts' on the screen when I select 'Wandering Maze'.  What's up with that?
A: Well, by forcing the true border/background to be solid we usually stop this from happening, however it can

be seen if either of the following are true:
- The 'Custom Border Color' option is turned off in the Percent dialog from the Option menu AND the 

maze background color is not solid.
- The maze tends to build towards a solid pattern while solving, ie: the wall width is zero, and the trail 

color is non-solid.
The reason this occurs is because the maze is not always shifted in increments that conform to the size of 
the repeating pattern that gives a patterned color its apparent color.  If this happens, simply choose a solid 
color for the offending attribute.  A solid color can always be found above the word 'Solid' in the color 
selection palette dialog.

Q: What about system priority?  Do I really care?
A: This parameter allows you to control how much work the program does before giving time back to the 

system.  You can set it to very low numbers (ie: 1) if you would like to see the maze solve slower.  Also, if 
the system will be doing 'work' while the screen saver is running (ie: a modem downloading), try keeping 
this number under 100. You may even need a lower number depending on your system.  As to the second 
question, no, you probably don't care.  Lastly, under WinNT, this number only affects speed of the 
creation/solve.  It will not significantly influence how well other programs run.

Q: Hey, in 'Wandering Maze', when I set the frequency over 18 per second it doesn't seem to make a 
difference.  What's going on?

A: You are correct, the wandering is implemented with a system timer.  Windows 3.1 does not support timers 
faster than this.  I am not sure if the NT timers have a finer resolution, but if they do, the program will take 
advantage of it.

Q: The maze does not wander.  My delay settings are being ignored.  My exit does not blink.  What's up?
A: All these things are implemented with timers.  Win3.1 only supports 32 concurrent timers.  If a timer 

request fails, the program will do without.  It should never do anything fatally wrong, the worst that should 
happen is what is described in the question.  Oh, under Win3.1 if you have the registered version, and the 
password request box comes up to terminate the screen saver, it will cancel itself and resume the saver 
after 15 seconds of no keyboard input.  It will not go away with inactivity if the timer request fails. 

Q: Just how secure is the password protection in the Win3.1 registered version?
A: Eh, not bad.  Seriously, there is only so much security that can be enforced.  The password is stored in an 

encrypted format in the .INI file.  The user cannot Ctrl-Alt-Del to terminate the screen saver.  Of course we 
cannot prevent a reboot.  The user cannot Alt-Tab or Ctrl-Esc out.  If there are unusual custom keys that 
the screen saver cannot intercept, it will attempt to steal back the focus as soon as possible (the same as 
the built-in MS screen savers).  When a correct password is entered the user will be told how many failed 
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attempts at passwords were made.  Pressing Esc will not count since the password is not checked, and of 
course if the password is entered correctly the first time, nothing is noted.
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Q: Can I run Maze Solver as an application?
A: Sure, just copy it into any directory, rename winmaze.scr to winmaze.exe and set up an icon for it in the 

program manager.  The maze will always take up 100% of the screen, and so no wandering options can be
set.  Note: For those who really really want to have these options available (why?), this is how you can do 
it.  A screen saver is nothing but a special program that look at some command line parameters.  If you 
add the parameter /c to the Program Manager entry, it will run just like the configuration mode of the actual
saver.

Q: Why is it that when Maze Solver is running as a program, or in configuration mode, the actual screen saver
never kicks in?

A: Well, in a word, Maze Solver is fooling Windows into thinking a screen saver is already running.  This will 
only happen if Maze Solver is the active application.  Windows always asks the active application if it is ok 
to run the screen saver.  Maze Solver assumes that since it is the active application, and it is pretty much a
screen saver, there is no reason to let windows run the screen saver.  This logic is not always valid for all 
users, but hey, how often is this really going to be a problem?

Q: Where can the authors be contacted for questions and comments?
A: The authors may be contacted through E-Mail at the following addresses:

CompuServe - 70004,644
Internet   - 70004.644@compuserve.com
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8.0 - Registration Form

WinMaze/MacMaze Order Form
Knoware
5696 Blinnton Place
Columbus, OH 43235

Registration for MacMaze/WinMaze is $15. After registering, you will receive two disks (one PC, one Mac) 
which includes the most recent versions of the following:

- MS Windows 3.1 Maze Solver screen saver/program with password protection.
- MS Windows NT 3.1 Maze Solver screen saver/program for Intel based computers. (Password 
protection is built into NT.)

- Macintosh Maze Solver screen saver for After Dark and Darkside of the Mac.
- Macintosh MacMaze application program.

Name ___________________________________________________________

Company ___________________________________________________________

Address ___________________________________________________________

___________________________________________________________

Where did you hear about MacMaze/WinMaze?_________________________________

Do you have a Compuserve ID?      Y    N

If you would like product upgrades or information about future Knoware products sent to your Compuserve 
account, please supply your ID number ______________________________

Do you have an Internet email address?      Y    N

If you would like information about future Knoware products sent to your Internet account, please supply your 
address _________________________________________________________

Macintosh users: Do you currently run System 7?      Y    N

Disk size (for PC disk):   ___ 3.5"     ___ 5.25"

Product Quantity Price

MacMaze and WinMaze registration, $15 _______ $ _______

Sales Tax (Ohio customers only, (5.75% currently)) $ _______

Total Enclosed $ _______
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