
 IconWorks Help Contents

The Contents lists Help topics available for IconWorks.    Use the scroll bar to see entries not 
currently visible in the Help window.

To learn how to use Help, press F1 or choose Using Help from the Help menu

Editor
Commands and Tools
Shortcut Keys
Procedures

Viewer
Commands
Shortcut Keys
Procedures

ICONWRKS.INI   File  



 Editor: Commands and Tools

Click the part of the Editor window you want to know more about.



 Editor: Shortcut Keys

Click a menu name to list the shortcut keys for menus in the IconWorks editor:

File Menu
Edit Menu
View Menu
Help Menu



File Menu Shortcut Keys
To choose Press

Save SHIFT+F12
Save As F12
Exit ALT+F4

Edit Menu Shortcut Keys
To choose Press

Undo ALT+BACKSPACE
Cut SHIFT+DEL
Copy CTRL+INS
Paste SHIFT+INS
Opaque Paste CTRL+SHIFT+INS
Delete DEL
Select All CTRL+A
Flip Horizontal CTRL+H
Flip Vertical CTRL+V
Rotate Right CTRL+L
Rotate Left CTRL+R
Invert CTRL+I

View Menu Shortcut Keys
To choose Press

Status bar CTRL+S
Tool Palette CTRL+T
Color Palette CTRL+C
Zoom Scroll bar CTRL+Z
Grid CTRL+G
Zoom In CTRL+F11
Zoom Out CTRL+F12

Help Menu Shortcut Keys
To choose Press

Help Contents F1



 Editor: File Menu

New
This command clears the editing area to start a new icon.    The new icon appears in the    
iconbox selected the Status Area.

If there are any unsaved changes in the editing area when you select the New command, 
IconWorks asks if you want to save the changes.    IconWorks then clears the editing area 
to the currently selected screen color and changes the Title bar to [Untitled].

Open
This command opens the IconWorks Viewer so you can select an icon for editing.    When 
you double-click the name of an icon in the Viewer, IconWorks opens the selected icon in 
the Editor.

Save
This command saves changes made to the icon in the editing area.    If the Title bar shows 
that the icon is untitled, the Save icon dialog box appears so you can give the icon file a 
name.

Save As
This command saves the icon in the editing area.    The Save icon dialog box appears so 
you can save the icon with a different file name.

Exit
This command closes the IconWorks Editor.    If any of the six icons in the Status Area have 
unsaved changes, IconWorks prompts you to exit any way or cancel the Exit command.    If 
the Viewer is also open, IconWorks lets you close the Viewer too if you started the Viewer 
after the Editor.    If you started the Viewer first (using the V command line argument), the 
Editor closes leaving the Viewer running.



 Editor: Edit Menu

Undo
This command removes any changes from the icon since the time you changed editing 
tools or selected another icon.    Once you select a new tool or another icon from the Status
Area, the Undo command cannot remove the changes made in the editing area.    The Undo
icon button in the Status Area displays the condition the icon will return to if you select the
Undo command.

Cut
This command copies the portion of the editing area you select to the Clipboard and clears
the selected area to the current screen color.    The Cut command does not work if you 
move the part of the icon you select before cutting it.    You must reselect the area you 
want to cut then use the Cut command.

Copy
This command copies the portion of the editing area you select to the Clipboard.    The 
editing area is not affected.    The Copy command does not work if you move the part of 
the icon you select before copying it.    You must reselect the area you want to cut then use
the Copy command.

Paste
This command inserts the contents of the Clipboard as a selected group of pixels in the 
upper-left corner of the editing area.    You can then move the selected pixels anywhere in 
the editing area before pasting them in the current icon.    To paste the selection into the 
icon, click the mouse anwhere in the editing area outside of the selection.

All pixels in the pasted bitmap that match the current screen color appear transparent and 
do not affect the icon below.    Pixels that match the inverse of the screen color replace the 
pixels in the icon.

Paste Opaque
This command inserts the contents of the Clipboard as a selected group of pixels in the 
upper-left corner of the editing area.    You can then move the selected pixels anywhere in 
the editing area before pasting them in the current icon.    To paste the selection into the 
icon, click the mouse anwhere in the editing area outside of the selection.

All pixels in the bitmap cover any pixels in the icon below.

Delete
This command deletes the selection in the editing area from the icon, replacing the 
selection with the current screen color.

Select All
This command selects the entire icon in the editing area.    You can also double-click the 
Select tool to select the entire icon.

Flip Horizontal
 This command flips the current selection in the editing area from left to right.

Flip Vertical
This command flips the current selection in the editing area from top to bottom.



Rotate Right 90 degrees
This command rotates the current selection in the editing area 90 degrees to the left.

Rotate Left 90 degrees
This command rotates the current selection in the editing area 90 degrees to the right.

Invert
This command changes all the colors in the current selection to their opposites.    The 
following picture shows the normal color palette in IconWorks and the inverted color 
palette so you can see how the colors change when using the Invert command.



 Editor: View Menu

Status Bar
This command hides or displays the Status Area.    This command is unavailable if the 
Editor window is too small to display the Status Area.

Tool Palette
This command hides or displays the Tool Palette.    This command is unavailable if the 
Editor window is too small to display the Tool Palette.

Color Palette
This command hides or displays the Color Palette.    This command is unavailable if the 
Editor window is too small to display the color palette.

Zooming Scroll bar
This command hides or displays the Zooming Scroll bar.

Show All
This command displays all hidden Editor controls: The Status Area, Tool Palette, Color 
Palette, and Zooming Scroll bar.    If the Editor window is too small to display a specific 
control, that control remains hidden.

Grid
This command turns the grid on and off.    The grid helps you tell individual pixels apart in 
the editing area.    When the grid is on you can select between a solid line grid or a dotted 
grid.

Line Grid
This command displays the grid as solid lines.    This command is unavailable when the grid
is turned off.

Dotted Grid
This command displays the grid as rows and columns of dots.    This command is 
unavailable when the grid is turned off.

Zoom In
This command magnifies the appearance of the icon in the editing area.    You can also 
zoom in on an icon with the Zooming Scroll bar.

Zoom Out
This command reduces the appearance of the icon in the editing area.    You can also zoom 
out from an icon with the Zooming Scroll bar.

Focus to Editor on Drag and Drop
When switched on this command automatically brings the Editor to the foreground any 
time an icon is dragged from the Viewer and dropped onto the Editor.    When switched off 
you can drag up to six icons from the Viewer and drop them on iconboxes in the Status 
Area without bringing the editor to the foreground each time.

Display Border on Selected Icon
This command displays or hides a narrow border showing the edge of the selected icon in 
the Status Area.



Pop-up Tools menu
When switched on this command lets you pop-up the Tools menu when you click the right 
mouse button to the left or right of the editing area.



 Editor: Tools

How to Select a Tool
You can select tools in the Editor in either of two ways:
1. Clicking on the icon for the tool in the Tool Palette
2. Selecting the name of the tool from the Tools menu

Select Tool
This tool selects a rectangular region in the editing area.
To use the Select tool, click in the editing area to anchor one corner of the area you want 
to select.    Drag the mouse until the flexible box that appears surrounds the area you want
to select.    Release the mouse button.    If you make a mistake while selecting, click outside
of the current selection and start over.

Paint Tool
This tool paints pixels in the editing area according to the selected brush size.
To use the Paint tool, click the mouse in the editing area and drag to begin painting.

 Fill Tool
This tool fills a closed area with the color selected in the Color Palette.
To use the Fill tool, click in the area to be filled.    The area will be filled with the color 
selected in the Color Palette.    The Fill tool fills adjacent pixels which are the same color as 
the starting pixel.    If you fill an area with a dithered color rather than solid color, the result
will be a checkerboard pattern.

 Line Tool
This tool draws straight lines.
To use the Line tool, click in the editing area to anchor one end of the line.    Drag the 
mouse until the mouse reaches the other end of the line you want to draw.    Release the 
mouse button to draw the line in the icon.    The width of the line corresponds to the 
current brush size.    The color of the line is the color selected in the Color Palette.
To draw a horizontal, vertical, or diagonal line, hold down the SHIFT key as you drag the 
mouse.

Square Tool
This tool draws rectangles and squares.
To use the Square tool, click in the editing area to anchor one corner of the square.    Drag 
the mouse until the square is the size and shape you want.    When the square or rectangle 
is the right size and shape, release the mouse button.    The brush size determines width of
the box's border.    The color of the outline of the square is determined by the Color Palette.
To draw a perfect square, hold down the SHIFT key as you drag the mouse.

Filled Square Tool
This tool draws filled rectangles and squares.
To use the Filled Square tool, click in the editing area to anchor one corner of the square.    
Drag the mouse until the square is the size and shape you want.    When the square or 



rectangle is the right size and shape, release the mouse button.    The brush size 
determines width of the box's border.    The color that fills in the square is determined by 
the Color Palette.
The border of the square is a line and therefore cannot be drawn using dithered colors.    If 
you select a dithered color the border of the square will appear in the nearest solid color.    
If you want the entire square to be drawn with a dithered color, first draw the square with 
a solid color then use the Fill tool to fill it in with the desired dithered color.
To draw a perfect square, hold down the SHIFT key as you drag the mouse.

Circle Tool
This tool draws circles and ellipses.
To use the Circle tool, click in the editing area to anchor one corner of a flexible box 
containing an ellipse.    The box appears while you draw to show the anchor point and 
current mouse position.      It disappears when you finish drawing.    Drag the mouse until 
the ellipse is the size and shape you want.    When the circle or ellipse is the right size and 
shape, release the mouse button.    The brush size determines the border width of the 
circle or ellipse border.    The color of the circle or ellipse border is determined by the Color 
Palette.
To draw a perfect circle, hold down the SHIFT key as you drag the mouse.

Filled Circle Tool
This tool draws filled circles and ellipses.
To use the Filled Circle tool, click in the editing area to anchor one corner of a flexible box 
containing an ellipse.    The box appears while you draw to show the anchor point and 
current mouse position.      It disappears when you finish drawing.    Drag the mouse until 
the ellipse is the size and shape you want.    When the circle or ellipse is the right size and 
shape, release the mouse button.    The brush size determines the border width of the 
circle or ellipse border.    The color that fills the circle or ellipse is determined by the Color 
Palette.
To draw a perfect circle, hold down the SHIFT key as you drag the mouse.
The border of the ellipse is a line and therefore cannot be drawn using dithered colors.    If 
you select a dithered color the border of the ellipse will appear in the nearest solid color.    
If you want the entire ellipse to be drawn with a dithered color, first draw the ellipse with a 
solid color then use the Fill tool to fill it in with the desired dithered color.



 Editor: Icons Menu

Enables you to select and display an icon from the Status Area when it is not displayed.

Choose... To select and display the icon from...
1 - [path]    Filename the upper-left iconbox
2 - [path]    Filename the upper-right iconbox
3 - [path]    Filename the middle-left iconbox
4 - [path]    Filename the middle-right iconbox
5 - [path]    Filename the lower-left iconbox
6 - [path]    Filename the lower-right iconbox

The full path and filename of the currently loaded icons appear in the appropriate menu 
item.    Selecting an icon from the Icons Menu is equivalent to clicking the corresponding 
iconbox in the Status Area.



 Editor: Color Menu

Colors
This command opens the Custom Color Palette Window, where you can define custom 
colors and assign them to the current color palette.    You can use the Custom Color Palette 
window to select colors in the same way you select colors with the Color Palette displayed 
in the Editor.    You can display your custom Color Palette as a floating palette instead of the
Color Palette in the Editor.

Default Color Palette
This command resets the Color Palette to the default colors.

INI File Color    Palette
This command sets the Color Palette to the values currently stored in the ICONWRKS.INI file. 
If this file doesn't exist, or you have never saved changes to the displayed Color Palette, 
the color palette resets to the default colors.

Solid Colors Only
This command sets the current color palette to solid colors only.    Each column of cells is 
set to the same color.    Because some tools cannot use dithered colors, this command 
ensures that any color you select can be used by any tool.

Save Color Palette to INI file
This command saves the current color palette to ICONWRKS.INI.    IconWorks creates this file 
If it doesn't exist.

Left/Right Colors
This command sets the current mouse colors to those currently displayed in the Status 
Area for the Left and Right colors.    You can also set the current mouse colors by selecting 
the corresponding option button in the Status Area.

Screen/Inverse Colors
This command sets the current mouse colors to those currently displayed in the Status 
Area for the Screen and Inverse colors.    You can also set the current mouse colors by 
selecting the corresponding option button in the Status Area.



 Editor: Brush Menu

Choose... To set drawing tool size to...
Small (1 x 1) 1 pixel wide
Medium (3 x 3) 3 pixels wide
Large (5 x 5) 5 pixels wide

The brush size does not affect the Select tool or Fill tool.



Editor: Help Menu

The commands in this menu open the help file you are now reading.



 Editor: Status Area

The Status Area is the part of the IconWorks Editor window that is to the right of the 
editing area and the Color Palette.    The Status Area displays information and provides 
controls that help as you use IconWorks.

When you resize the Editor window, IconWorks removes items from the Status Area as the 
Editor becomes too small to display them.    IconWorks displays these items again when the
Status Area becomes big enough to fit them in the window.    The entire Status Area 
disappears if the Editor window becomes too small to display the six icon boxes.    In this 
case, you must choose the Status Area command from the View menu to redisplay the 
Status Area.

The Status Area has four sections:

Icon Boxes
Mouse Position display
Undo Icon display
Mouse Button controls



Icon Boxes
The top part of the Status Area contains six icon boxes.    The icon boxes serve the 
following uses:

Displays icons open for editing.    IconWorks can edit up to six icons at one time.    You 
can open icons by dragging them from the Viewer and dropping them onto an icon box.

Indicates the currently selected icon with a square border.
Displays the actual size of the icons being edited.
Switches between any open icons by clicking on the icon box of the icon you want to 

edit.
Lets you test how icons appear when dragged.

See Also
Status Area



Mouse Position
Displays the current X and Y position of the mouse when in the editing area.

See Also
Status Area



Undo Icon
Displays the condition the icon will return to if you select the Undo command in the Edit 
menu or if you double-click on the Undo Icon.

See Also
Status Area



Mouse Buttons
Displays the colors applied by the left and right mouse buttons when editing an icon.    You 
can choose between foreground colors or screen and inverse screen colors.

See Also
Status Area



 Editor: Color Palette

The Color Palette contains solid and dithered colors you can use when editing an icon.

To select a color from the palette, click a color cell with the left or right mouse button.    
IconWorks assigns the selected color to the mouse button used to click the color cell.    You 
use this procedure to assign foreground colors as well as screen and inverse colors.

Double-clicking a mouse button assigns the selected color to that button then opens the 
Custom Color Palette Window.    You can define your own colors in this window.



 Editor: Defining Colors

You define colors using the Custom Color Palette shown below.    To open the Custom Color 
Palette, double-clicking the Color Palette in the Editor or select the Colors command form the
Color menu.    Minimizing or closing the Editor window also hides or closes the Custom Color 
Palette window.

Color Elements and Values
Custom colors are composed of red (R), green (G), and blue (B) elements.    These 
elements have values ranging from 0 to 255.    A value of 0 means none of that color 
appears in the custom color.

Setting Color Values
Use the RGB scroll bars to set the individual color elements.    You can also enter color 
values into the fields to the right of each scroll bar.    The color cell to the right of each field
displays the color matching the value chosen for each element (red, green, or blue).

The Selected Color cell displays the RGB color created by combining the individual RGB 
elements.    Since some of the tools cannot use dithered colors, the Nearest Solid Color is 
also displayed.

Adding Custom Colors to the Editor
To add a color to the Color Palette in the Editor, click the Set button.    The color cell 
currently selected in the Editor changes to display the new custom color.

Clicking the Reset button resets the RGB elements to the color values for the color cell 
currently selected in the Editor.

Defining Additional Colors
To define another color, click on a color cell in the Color Palette in the Custom Color 
window.



 Editor: Screen and Inverse Colors

Screen Color
The color you select as the Screen color controls the background of the icon.    When you 
drag the icon in Program Manager, any part of the icon colored with the Screen color is 
transparent, displaying whatever is beneath.    You can test this transparency by dragging 
an icon using the Screen color from the Status Area.

Inverse Color
The Inverse color is also transparent when you drag the icon in Program Manager, however
it inverts the colors on the screen beneath the icon.    You can test this inverted 
transparency by dragging an icon using the Inverse color from the Status Area.

Selecting Screen and Inverse Colors
The Screen and Inverse colors can only be solid colors.    The Screen and Inverse colors act 
as a pair when selecting colors.    When you select a color for either the Screen or Inverse 
color, IconWorks automatically sets the other color in the pair to the inverse of the color 
you select.    For instance, if you set the Screen color to black, IconWorks sets the Inverse 
color to white.



 Editor: Undo Icon

The Undo Icon button, which appears in the Status Area, shows the condition the icon in 
the editing area returns to if you undo your changes.    You can undo your changes by 
clicking the Undo Icon button or by choosing the Undo command from the Edit menu.

IconWorks hides the Undo Icon button if you size the Editor window too small to display the
entire Status Area.



 Editor: Procedures

Zooming In and Out
Moving a Selection
Flipping a Selection
Rotating a Selection
Testing an Icon



 Editor: Zooming In and Out

The vertical scroll bar along the left side of the editing area increases or decreases the 
magnification of the currently selected icon.

You can use this scroll bar to display the icon at actual size or magnify it to fill the editing 
area.    When you resize the Editor, the scroll bars adjusts to the new window size so that 
the icon stays at the same magnification.



 Editor: Moving a Selection

Once a region in the icon has been selected with the Select tool, there are two ways to 
move it:

Opaque Move Use the right mouse button to click and drag the selected 
pixels.    The selection is moved as is, including all 
foreground colored pixels and all screen and inverse 
screen colored pixels.

Transparent Move Use the left mouse button to click and drag the selected 
pixels.    Only the foreground colored pixels move.    This 
lets you move regions in the icon that appear to be a non-
rectangular.

Once you move a selection of pixels, the selection rectangle changes from a dotted 
rectangle to a solid rectangle.

Holding down the SHIFT key while moving a selection leaves a copy of the selected pixels 
at their original location.    Selecting another tool or selecting another icon also deposits 
the moved pixels to their current location.



 Editor: Flipping a Selection

Once you select part of the icon with the Select tool, you can flip the selected pixels either 
vertically or horizontally.    You can use the Flip Horizontal and Flip Vertical commands in 
the Edit menu.    You can also use these shortcut keys:

Flip Horizontal CTRL+H
Flip Vertical CTRL+V

The selection does not have to be square in order to be flipped.    You can also flip a 
selection while it is being moved.



 Editor: Rotating a Selection

Once you select part of the icon with the Select tool, you can rotate the selected pixels 90 
degrees to the left or right.    You can use the Rotate 90° Left and Rotate 90° Right 
commands in the Edit menu.    You can also use these shortcut keys:

Rotate Left CTRL+L 
Rotate Right CTRL+R

The selection must be square in order to be rotated.    You cannot rotate a selection that 
you are moving.



 Editor: Testing an Icon

You can test the icons you create to see what they look like when dragged.    This ability is 
especially helpful when your icon contains transparent regions.

To test an icon, drag the icon from its icon box in the Status Area.    You can test only the 
currently selected icon.    You cannot drop icons dragged from the Status Area.



 Viewer: Shortcut Keys

To... Press...
Close IconWorks Viewer ALT+F4
Open the Editor (Does not load 
icon)

F7

Show all icons CTRL+V
Open Help F1



  Viewer: Commands

File Menu
Edit Menu
Options Menu



 Viewer: File Menu

Open
This command opens the IconWorks Editor and loads the currently selected icon it for 
editing.    There are several ways to select and load an icon into the Editor.    The menu item
is active only when an icon is selected.

Exit
This command closes the IconWorks Viewer.    If the Editor is open and the Viewer was 
started first, you will be asked if you also want to close the Editor.    If the Editor was 
started first, the Viewer will be closed leaving the Editor running.



 Viewer: Edit Menu

Copy
This command copies the bitmap image of the selected icon onto the Clipboard.    The icon 
itself is not copied to the Clipboard.      The Copy command is unavailable if you haven't 
selected an icon.



 Viewer: Options Menu

Editor
This command opens the IconWorks Editor without loading an icon.    If the Editor is already
opened, this command brings it to the foreground.

Show all Icons
This command displays all of the icons listed in the Icons list box in the scrollable viewing 
window to the right.

Show all icons on DIR Change Command
This command causes IconWorks to update the scrollable viewing area whenever you 
change directories in the Viewer.



 Viewer: Procedures

Selecting an Icon to Edit
Viewing Icons



 Viewer: Viewing Icons

Viewing Individual Icons
You can view individual icons one at a time, by selecting them from the Icons list box.    The
selected icon appears beside the Selected Icon label.

Icons that aren't valid under Windows appear as solid black squares.

Viewing All Icons in a Directory
To view all the icons in a directory at the same time, choose the Show all Icons command 
from the Options menu.    Each of the icons in the current directory appears in the viewing 
area to the right of the list.    You can scroll the viewing area if not all the icons in the 
directory fit in the viewing area.    You can also resize the Viewer window to increase the 
size of the viewing area.

IconWorks clears the viewing area when you change the current directory unless you 
switch on the Show all icons on DIR Change command in the Options menu.



 Viewer: Selecting an Icon to Edit

There are several ways you can select an icon from the Viewer to open in the Editor:

 Drag the from the Viewer and drop it on the editing area or on one of the six icon 
boxes in the Status Area of the Editor.

 Double-click a filename in the file list box.

 Clicking a filename in the file list box then press ENTER.

 Enter the name directly into the FileName text box then press ENTER.

 Select an icon then choose the Open command from the File menu.



 Initialization File: ICONWRKS.INI

When you close the Editor or Viewer most settings are saved to ICONWRKS.INI in your 
Windows directory.    The only exception is the current Color Palette settings.    To save the 
Color Pallette settings, choose the Save Color palette to INI File command from the Color 
menu.

The ICONWRKS.INI flag is an ASCII text file, which should not be edited since values read from 
this file are not validated.    Items can be deleted from the file, but not modified.

The following information is saved to the ICONWRKS.INI file:

Editor:
Visibility state of the Status Area
Visibility state of the Tool Palette
Visibility state of the Color Palette
Visibility state of the Zooming Scroll bar
Visibility state of the grid
Status of the Grid type:

Line Grid
Dotted Grid

Status of the Focus to Editor flag
Status of the Display Icon Border flag
Status of the Tools Pop-up Menu flag
Current Color Palette values
Current Color Palette:

Default Colors
Solid Colors
INI File Colors

Viewer:
Status of Show Icons on DIR change flag



 Glossary

Term Definition
Color Palette Part of the IconWorks Editor window 

where you can select colors to create
an icon.

Dithered Non-solid colors created by patterns 
of solid color dots.

Editor The window in IconWorks where you 
can create, change, and test icons.

Grid A pattern of dots or lines that you 
can display in the editing area of the 
Editor to help position pixels in the 
icon.

Icon A 32 by 32 pixel bitmap used in 
Windows to represent an application 
or other window.

Icon boxes Six boxes in the Status Area that 
each displays a single icon open in 
the Editor.    You can also test icons 
by dragging them from the icon 
boxes.

Inverse color A solid color used in an icon that 
becomes transparent and inverts the
pixels beneath when you drag the 
icon.

Screen color A solid color used in an icon that 
becomes transparent when you drag
the icon.

Status Area The region on the right side of the 
Editor window containing:

Six icon boxes

Mouse position

Undo condition of the current 
icon

Foreground, Screen, and 
Inverse color controls

Tool Palette A column of tools along the left side 
of the Editor window.    You use tools 



in the Tool Palette to create and edit 
icons.

Viewer The window in IconWorks where you 
view groups of icons and select icons
to open in the Editor.

Zooming Scroll 
bar

Scroll bar along the side of the Tool 
Palette that lets you zoom in and out
of the editing area of the Editor.




