Présentation

> myCatch

Pour qui connaît spy++, myCatch ne surprendra pas. Pourtant, là ou spy++ s'arrête, myCatch continue. Outil développé à usage didactique, myCatch vous fera découvrir un mécanisme placé au coeur du fonctionnement de Windows, et de manière générale au coeur des systèmes d'exploitation graphiques : "le mécanisme des messages".

Plébiscité pour son côté "bidouille au coeur de Windows", la version 2 de myCatch fonctionnelle

sous la gamme Windows NT (NT >SP3; 2000; XP) s'est enrichie de nouvelles astuces. Ainsi, si vous pouvez toujours décoder les champs *** par un simple glisser-déplacer de la cible ; si vous pouvez toujours réactiver les boutons et menus désactivés dans les programmes extérieurs... De nouvelles possibilités "pointues" sont apparues....

------------------------------------------------------------

Depuis le début, "la sécurité par l'obscur" est le choix principal de Microsoft concernant Windows. Au compte goutte Microsoft dilue savamment (à travers les sdk notamment) quelques informations sur son système d'exploitation, lui conférant ainsi un intérêt sans cesse renouvelé. Jamais pourtant la documentation ne sera complète (même MS/DOS garde encore des parties sombres et non documentées). D'autres à travers la planète défrichent une parcelle de la galaxie Windows. Avec Internet, le puzzle est planétaire. La nouvelle version de myCatch fonctionnelle sous "NT family" (NT, 2000, XP), sorte de compilation actuelle n'est qu'un bref aperçu des possibilités du puzzle...

-------------------------------------------------------------

Le source complet documenté et détaillé à travers un tutoriel est disponible dans nos modules de formations ou dans la version commerciale de myCatch.

Retrouvez les détails de myCatch sur : http://www.artoflog.com


Première étape : sélection de la cible

L'élément de base à fournir à myCatch, est le handle (numéro d'identifiant) du contrôle (bouton, fenêtre, zone d'édition...) sur lequel on veut intervenir.

La première méthode (très peu utilisée) consiste à renseigner directement la zone handle.

La deuxième méthode (préconisée) consiste à "glisser-déplacer" la cible de myCatch vers le contrôle souhaitée (le contour du contrôle cible est surligné et la zone handle de myCatch se remplit automatiquement)


Deuxième étape : fonctionnalités

Une fois le handle renseigné, vous avez accès aux fonctionnalités de myCatch, parmi lesquelles :

- décodage des champs masqués par des *

(!! pour la famille XP, 2000 de Windows il faut glisser deux fois de suite la cible

sur le contrôle pour décoder son contenu).

- activation / désactivation des contrôles

- déplacement d'un contrôle

- envoi d'un message paramétré au contrôle

- trace des messages reçus par un contrôle

- liste des contrôles enfants

....


onglet détails

Dans cet onglet apparaissent les détails du contrôle Windows sélectionné dans la première étape. La zone texte donne le contenu du contrôle en clair. C'est ici par exemple que les champs **** sont décodés (sous windows 2000 et xp, il est parfois nécessaire de glisser-déplacer deux fois de suite la cible vers un champs **** pour le décoder).

La zone class donne la classe du contrôle ce qui peut être intéressant pour interdire l'exécution d'une applications en utilisant le nom de sa classe principale. Par exemple, le jeu pinball fourni avec windows XP a pour classe principale : 1c7c22a0-9576-11ce-bf80-444553540000.

Pour interdire son exécution, il suffit de saisir le nom de sa class dans la liste noire. Même renommé et avec un titre de fenêtre qui change selon les options de jeu choisi, le jeu est interdit.

Le zone ProcessId donne l'identifiant du process a qui appartient le contrôle.

Tandis que la zone controls donne la liste des contrôles enfants du contrôle sélectionné et permet de repartir d'un de ces contrôles enfants.


onglet action

Marquer bord permet de surligner le contour du contrôle sélectionné.

Changer d'état permet d'activer / désactiver le contrôle sélectionné.

!!! pour réactiver un contrôle windows contenu dans un panel ou une groupbox eux-même désactivés, il faut d'abord réactiver le panel ou la groupbox et les déplacer au moyen de la commande déplacer ci-dessous.

Par exemple, si une restriction est imposée sur les paramètres proxy des paramètres de connexion d'internet explorer on a :

On commence donc par réactiver la groupBox "serveur proxy", puis on la déplace pour réactiver les éléments de son contenu.

Déplacer permet de déplacer le contrôle sélectionné à l'intérieur de son contrôle parent (ex : ci-dessus)


onglet messages

Envoi messages vous permet d'envoyer un message au contrôle précédemment sélectionné. Dans l'exemple ci-dessus, le message WM_SETTEXT a été envoyé au bouton "démarrer" de windows avec le paramètre "meuh" comme nouveau texte du contrôle.

Trace message intercepte (et retransmet) tous les messages windows du contrôle précédemment sélectionné.


onglet processus

Liste des processus qui s'exécute en ce moment sur le poste windows avec possibilité de les détruire.


onglet internet

Gestion des connexions installées sur le poste, et visualisations des données sauvegardées localement dans la zone d'accès protégé.


onglet applications

Liste noire : myCatch peut maintenir une liste d'applications interdites sur un poste. Lorsque la surveillance est activée (démarrer ou démarrer avec myCatch pour un démarrage automatique), si l'application active est reconnue comme appartenant à la liste noire, celle-ci est automatiquement détruite. Une application peut être reconnue par le nom de son exécutable (ex : winmine.exe pour le solitaire), le titre de la fenètre (ex solitaire pour le solitaire), ou la classe de sa fenêtre (ex FreeWClass pour freecell).

Logs : un log de chaque nouvelle application active en avant-plan peut être généré.

Pour démarrer automatiquement la surveillance, sélectionner la case à cocher "démarrer avec myCacth". La case à cocher "démarrer myCatch automatiquement avec windows" de l'onglet propriété permettant de lancer myCatch en mode "caché" (et donc la surveillance) lors du boot de Windows.

Les fonctionnalités de surveillance et de restrictions des applications utilisés présentes dans myCatch ne sont qu'un bref aperçu didactique des possibilités offerte par la gestion de cybercafé bustleCoffee et de la gestion de salle de cours art107.


onglet shell

L'onglet shell présent dans myCatch n'est qu'un bref aperçu didactique des possibilités de "restrictions" que l'on peut mettre en place au moyen des "policies".

Ils existe dans le domaine de nombreux outils dédiés tels que tweakUI.

Le gestionnaire de stratégie de groupes de Windows (gpedit.msc) permet également de gérer ces "restrictions".

!!! Le résultat de certaines de ces restrictions n'est qu'une simple désactivation d'une zone visuelle pour un utilisateur. Dans ces cas, myCatch à travers son onglet action permet de les réactiver....

---------------------

Si les seules restrictions du shell standard Windows ne sont pas suffisantes, alors il est tout à fait possible de remplacer le shell standard par un programme de votre choix (qui doit néanmoins comporter certaines fonctionnalités, sans quoi pour revenir au shell standard il est nécessaire de complètement réinstaller Windows). myCatch vous permet d'effectuer la modification et vous propose myShell comme programme d'exemple de remplacement.

--------------------------

Le contrôle ou le remplacement du shell n'est qu'un bref aperçu des fonctions présentes dans la gestion de cybercafé "bustleCoffee" et de la gestion de salle de cours "art107"


policies

L'onglet shell présent dans myCatch n'est qu'un bref aperçu didactique des possibilités de "restrictions" que l'on peut mettre en place au moyen des "policies".

Ils existe dans le domaine de nombreux outils dédiés tels que tweakUI.

Le gestionnaire de stratégie de groupes de Windows (gpedit.msc) permet également de gérer ces "restrictions".

!!! Le résultat de certaines de ces restrictions n'est qu'une simple désactivation d'une zone visuelle pour un utilisateur. Dans ces cas, myCatch à travers son onglet action permet de les réactiver....


modification du shell

Si les seules restrictions du shell standard Windows ne sont pas suffisantes, alors il est tout à fait possible de remplacer le shell standard par un programme de votre choix (qui doit néanmoins comporter certaines fonctionnalités, sans quoi pour revenir au shell standard il est nécessaire de complètement réinstaller Windows). myCatch vous permet d'effectuer la modification et vous propose myShell comme programme d'exemple de remplacement.


onglet propriétés

Utiliser James pour les messages est un exemple didactique d'utilisations des agents microsoft à travers le personnage James de la société LaCantoche. Pour plus de détails sur la programmation des agents, reportez-vous à l'article technique sur le site d'artoflog ou au freeware d'artOfLog testAgent.

Affecter un mot de passe permet l'utilisation d'un mot passe pour accéder aux fonctionnalités (interface de myCatch)

Démarrer myCatch automatiquement avec Windows, lancera myCatch en mode "caché" lors du démarrage de Windows. L'appui simultanné sur les touches CRT+ALT+NumPAD9 permet de basculer myCatch du mode visuel au mode "caché"


A propos...

myCatch est un logiciel freeware développé par artOfLog comme support pour ses formations en développement Windows sous Delphi.

Aucune maintenance des logiciels freewares n'est assurée. myCatch est donc livré tel que.

L'utilisation non maîtrisée de myCatch peut rendre votre système d'exploitation Windows instable jusqu'au prochain redémarrage.

Vous pouvez nous faire parvenir vos remarques à : info@artoflog.com

Une version commerciale de myCatch comprenant l'intégralité de son code source ainsi qu'un tutoriel pour le réaliser pas à pas avec Delphi est disponible sur le site internet d'artOfLog.

Vous trouverez également sur ce site, d'autres logiciels freewares, des articles techniques, des ateliers et différente ressources informatiques.

Une gestion complète de cyberCafé : bustleCoffe

et une gestion complète de salle de cours informatisée : art107


darkside