
Welcome to ReNovator V1.10. It's a mod-maker for Propellerhead's Rebirth 338.

At anytime you can invoke context-sensitive help by pressing F1.

ReNovator is PostcardWare. That means that you are requested to send the Authors a (real) 
postcard of your home when you find ReNovator useful.
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Technical Reference

In Case of Error
Legal Matters
About the Authors

Check out the web-page for latest version and infos:
http://clio.unice.fr/˜fbomers/ReNovator/
if the page does not work, check here:
http://rummelplatz.uni-mannheim.de/˜boemers/



Technical Reference
Click on any of the elements in the screen-shots to get help on it. In ReNovator just click F1 to 
get context-sensitive help.



Overview

ReNovator is your tool to create new exciting "mods" (=modifications) of ReBirth 338.

Technically speaking, it lets you exchange bitmap and audio resources in a .exe or .dll 32bit file. 
Moreover, the main icon may be replaced.

A standardized file format (.rnv) lets you exchange your mods with additional information in 
an already zipped file that contains all resources.

You have preview functions for bitmaps and listen possibilities for audio files / resources.

I wrote ReNovator with the spirit that it's the best thing on earth to have good friends. So: Keep 
the spirit !

But don't waste your time with reading this, go ahead and make fantastic new ReBirths ! Once 
you've made one, send it to:
fredrik@propellerheads.se (include your Serial Number of ReBirth 1.5)



Installation

System requirements:

· Windows 95 or NT
· Full Version of ReBirth 338 (V1.5 recommended)
· All you need for ReBirth.
· Internet Explorer 3.0 or worse is recommended (for ComCtl32.dll V4.70 or higher).

Installation procedure:

1. Unzip the zip file (if not already done)
2. Copy all files in one directory, e.g. C:\ReNovator
3. Start the program by double-clicking ReNovator. You will be asked whether it shall create an 

entry in the start menu.

Uninstallation:

Click Uninstall in the options menu or select ReNovator to delete in Control Panel | Software.



File Menu

This menu provides functions that handle the executable file you want to modify - normally 
"ReBirth.exe".

Click on a menu entry to get help on it.



Resources Menu

This menu provides different functions treating the resources in your file. 

Click on a menu entry to get help on it.



Bookmarks Menu

The Bookmarks menu is made up like a Browser Bookmark menu, except that it references 
directories on your hard disk.
Like this you can jump quickly to different directories (e.g. for a sample-collection which is 
sorted by directories).
Bitmaps and sounds have separate bookmark-lists.

Click on a menu entry to get help on it.



Options Menu

The Options menu lets you change some thingies to customize some aspects of ReNovator.

Click on a menu entry to get help on it.



Help Menu

The Help menu serves to show either this help file or to display the about dialog.

Click on a menu entry to get help on it.



Toolbar

The Toolbar is a quick means for accessing the most important functions of ReNovator. You can 
hide the Toolbar by deselecting the option Show Toolbar
Click on an item to get a description of its function.

Click on a button to get help on it.



The Statusbar at the bottom of the window shows different descriptions. For example, when 
choosing a menu item, it describes the function of the function of this menu.
When selecting a resource in the Resources List, it shows the status of an assigned file: Either 
no assigned file or it displays the file path to the file which replaces the current resource.



The icon at the right side of the Toolbar shows the current file icon of the opened executable file.
Click with the right button on it to save it to disk (as .ico file) or to change the icon for this file.
Clicking on it, will show the webpage of the program; when you haven't loaded a program, it 
displays ReNovator's icon.



Choose open in the menu or click on the open button of the Toolbar in order to load an 
executable file. A file open dialog will be displayed where you select the file to be changed by 
ReNovator.
When this file (executable) doesn't contain any bitmaps or audio resources, Open fails and you 
have to restart to open another executable file.
When you have installed ReBirth on your system, just click on the Installed ReBirth item in the 
File Menu.



This is one of the key functions of ReNovator. When you have changed your executable file, for 
example you replaced the drumset, save it with this function either by clicking on the menu entry
or by clicking Save on the Toolbar.
You should consider to save the current assignment by using the Resources|Save Assignments 
function in the menu or in the pop-up menu of the Resources List. This is due to the fact that all 
assignments are lost when you save a file, then they are "hard" in there and consequently the 
original resources.

Note that you can't overwrite the currently open file; this prevents any unwanted modifications to
the original file.
When saving has completed, the new file is the currently open one.

You might want to test your modifications right away, in this case use the Run function.



The Run function is enabled, when you have loaded an executable file. It just starts the 
program.
It is available in the File menu and on the Toolbar.



Close the currently open program. The resource lists are emptied. It is of no particular use, but 
may come in handy somehow :)



This exits ReNovator.



This menu entry is displayed when you have properly installed ReBirth 338. When you click it, 
your original ReBirth is loaded as executable file and you can start with changing the 
resources !
When selecting it, you can check the path to this file by looking in the Statusbar.



The Recent File List shows the last files that you opened with ReNovator. It contains at 
maximum 6 items, latest items replacing older ones.
When selecting either one of them, it shows the path to the actual file in the Statusbar.



Load Assignments is the opposite of Save Assignments: Once you have stored assignments 
with Save Assignments, you can apply them again to the executable file. You do this by 
selecting this menu entry either in the Resources Menu or in the pop-up menu of the Resources
List.

In the appearing dialog you can select the assignment by clicking an any of them in the left list. 
The right list shows the corresponding assignment entries.

Once you've clicked OK, the file links you've made to resources, get restored. When files that 
are to be assigned cannot be found (i.e. you deleted them or put them in another directory), a 
dialog will appear and show which error(s) occured.

This function only loads references to files on your hard disk. To load a .rnv file from a good 
friend, use Import All in One.



Save Assignments lets you save the assignments (modifications) that you have currently 
applied to the open executable file. 
Important: No files are stored with this function. Only references to the "assigned" files are 
stored. 

For example, when you've replaced the "Bass Drum" (resource identifier "AIFF\1000") with a file
"C:\samples\BD\hard.wav", then this will entry is made in the Assignment.ini:
"AIFF\1000=C:\samples\BD\hard.wav".
All Assignments are stored in the Assignments.ini file in the directory of ReNovator.

This file cannot be copied and passed to good friends; they don't have the files on their hard 
disk. When you want to make an assignment available for good friends or public, use Export All 
in One in order to save a .rnv file.

When selecting Save Assignments in either the Resources Menu or the pop-up menu of the 
Resources List, a dialog appears which lets you enter a name for your Assignments. In the left 
list you'll see a list with previously made Assignments, if any. A click on these will show the 
respective Assignments in the right list.

Entering a name of an existing Assignment overwrites the existing one.

You invoke this function by the menu entry in the Resources Menu or in the pop-up menu of the 
Resources List.



Import All in One serves to load a complete set of modifications that you made to an executable 
file. These files have the extension ".rnv".

After having chosen the import file in the dialog, it will be loaded. This may take a while because
it has to be uncompressed. Meanwhile the author's informations are displayed. There you can 
click on the internet URL to launch a web browser or click on the mail address in order to start 
your mail program and write the author of this mod a mail.
For the latter 2 functions you need to have installed a web browser and/or mail program to use 
either one of them.

When loading has finished, the replaced files are invisible - they are "hard" replaced and you 
can't detach them. However, you have to save the executable file so that the modifications take 
effect.

You invoke this function by the menu entry in the Resources Menu.



Export All in One saves your current assignments to a standard exchangeable ".rnv" file. All 
replaced resources are zipped in there, so that you can share it with good friends without 
bothering to collect all files and then to zip them.

After having entered the filename, it displays a dialog where you can enter personal information 
that is displayed when importing this file.
The Web address should contain the preceding "http://".

When you check "only current assignments", it saves only these resources that are currently 
assigned (i.e. the icon has changed).

When you want to store your assignments for yourself (only references to files), use Save 
Assignments.

You invoke this function by the menu entry in the Resources Menu.



Assign All searches for each resource (either bitmaps or audio resources, depending on what 
page you've selected) a corresponding file in the right File Browser. It searches for filenames 
with either ".bmp" or ".aif" extension, having a filename that matches the original resource 
identifier. This resource identifier is displayed on the Caption of the Resources List when 
selecting a resource.

For example, when the resource identifier is "Bitmap\14500", it'll search for a file called 
"14500.bmp".

For each file that matched, it will create automatically an assignment.

When one or more resources couldn't be assigned (i.e. the corresponding file does not exist), 
an error dialog is shown which lists all the filenames that missed.

You invoke this function by the menu entry in the Resources Menu.



Call Extract All to extract all original resources of the currently open executable file. Even when 
you made assignments, it will still extract the "underlying" resource.
It creates for each resource a file with the name of the resource identifier. This resource 
identifier is displayed on the Caption of the Resources List when selecting a resource.

For example for a resource in the program with identifier "Bitmap\14500", it will create a file in 
the right file list with the name "14500.bmp". Audio resources have the extension ".aif".

To save audio resources in .wav format, drag the resources to the right file list. The format can 
be changed to aif in the Options Menu.

You invoke this function by the menu entry in the Resources Menu.



When you want that your new modified program has another program icon, select set Icon 
either in the Resources Menu or by right-clicking on the Icon.

You will be presented a dialog where you have to choose the icon file (.ico) to replace, and... 
oops...the icon changes.

Save the current icon with Extract Icon

You have to hit save in order that the program has the right icon.



Extract Icon is a means to save the icon of the current program to disk as .ico file.

For a mod, for example, you might want to save the icon to disk, change it with an icon editor, 
and then set it as actual icon of your current program by selecting Set Icon.

This function is available in the Resources Menu and the pop-up menu of the Icon itself.



Like in a web browser for web pages, this works equally for directories.

You will be displayed a dialog to enter the name of this bokmark. It will be instantly added to 
your Bookmarks menu - and the pop-up menu of the File Browser.

There exist separate bookmark lists for bimaps and sounds.

While selecting the bookmarks, the directory is displayed in the Statusbar.



Well, what could clicking on a bookmark do ? Try it !



In the Bookmarks menu, the "Delete" entry lets you choose a bookmark that you want to delete.



The Keep Exe Size option is a compatibility mode. It means that you can only assign files that 
have at maximum the same size as the original resource in the loaded program. There may be 
programs that don't support changing the length of resources - there you should use this option 
in order to keep maximum compatibility with the original executable file.

This function can be found in the Options Menu.



Toggle "Show Toolbar" to show or hide the Toolbar. But who wants to miss the beautiful 
toolbar ???

This function can be found in the Options Menu.



Use the Save Audio Resources option to set the format of audio files that are created by 
dragging audio resources into the File Browser.

Possible are the formats ".aif" and ".wav".

This function can be found in the Options Menu.



The Uninstall option deletes all entries made to the registry and deletes all installation files of 
ReNovator.

But, this is always a bad choice ;)

After a question whether you really want to uninstall, ReNovator closes and a DOS-Box appears
(a pity, but true - that's the only way I found to delete a currently executing program - a .bat file). 
Hit Return when you're really sure and then the files get deleted.

Alternatively you can uninstall ReNovator through the Control Panel|Software app.



File|Contents shows the contents of the help system. Note that you can always invoke context-
sensitive help by hitting F1.



Clicking the About menu entry will display the About box which shows not only a nice picture, 
but also version and copyright information.

It is located in the Help Menu.



Browse directory presents you a dialog to choose a new directory.
This becomes necessary when you want to change the drive, as this is not possible in the File 
Browser.

You access this function in the Toolbar or in the pop-up menu of the File Browser.



Clicking Dir Up navigates the File Browser to the parent directory. You can also click on the ".." 
item in the file list.

You access this function by the Toolbar or in the pop-up menu of the File Browser.



Selecting Refresh re-scans the current directory. Do this, when you have changed the contents 
in the directory.

You access this function by the Toolbar or in the pop-up menu of the File Browser.



The Page Selector lets you choose between audio and bitmap display.

Each page has ist own bookmarks. The Auto Assign and Extract All functions only act on the 
currently selected page.



The caption of the Resources List shows the original identifier of the selected resource. This is 
normally a quite cryptic name with numbers or any un-meaningful names.

The Resources List displays modifiable names that are stored in the ReNovator.ini file.



Resources List

This is the heart of ReNovator: After having loaded a program, it displays all bitmap or audio 
resources that are found. Along with them the file size and other informations are displayed.

The names of the resources can be modified by "click and wait" like renaming a file in Windows' 
Explorer. The caption shows you the original resource identifier.

2 types exist: A bitmap list and a audio list. To change to the other list select the page titled 
"Bitmap" or "Audio".

Drag a file on a resource to assign it with this file. Once it is succesfully assigned (you might 
have to answer a warning message before), the icon changes. For bitmaps, the icon gets 
colored, for audio resources its loudspeaker virtually starts to sound. The file path of the 
assignment is displayed in the Statusbar.

To select an item, move the mouse over it.
To display a bitmap resource (in the "Image Viewer") or to listen to the audio resource, click on 
it.
Double-clicking a resource changes the File Browser's directory to the assignment's directory (if 
you made an assignment).

To save resources to a file, drag them into the File Browser. There a file will be created with ist 
name plus the appropriate extension, ".bmp" respectively ".wav". When you want that saved 
files are stored in format ".aif", set this in the Options Menu.



The File List Caption displays the current directory of the file list.



File Browser

The File browser lets you visualize the contents of a directory. For bitmaps and audio resources 
(depending on the current page) there may be different directories. 

For each bitmap file (.bmp) it shows additional information like the file size in bytes, size of the 
bitmap in pixels ("Dimension"). The same applies to audio files - there you have information 
about the size of the file, the number of samples ("Samples") and the format.

Click on a bmp file to see it in the Image Viewer; a click on an audio file (.aif or .wav) plays it.
Directories are changed when you click on them.

Assign a file to a resource by simply dragging it on a resource in the Resources List.

A right click displays a pop-up menu with useful functions. Especially "Browse Dir" is necessary 
to change the drive. The Bookmarks provide a quick means to change the directory. Selecting 
Add Bookmark adds the current directory to the Bookmarks.

When in audio view, a blue icon means a ".aif" file, yellow is the standard wave ".wav" format.



Image Viewer
The Image Viewer is a separate window that lets you view images when you click on them. 
Images are visible in the File Browser and the Resources List when you have selected the page
"Bitmaps".

The Stay On Top button lets you stick the Image Viewer in front of all other windows on your 
screen. Like this it won't be hidden when clicking on another window.

To browse the bitmaps in your Resources List or the File Browser, use the Previous and Next 
buttons. 

Stretch is a feature to fill the Image Viewer entirely with the image - this may sometimes result in
very bizarre images as the height and width of the image is stretched to fit in the window.

You should find out for yourself which position, size and settings are most convenient for you.



 In Case of Error

I hoped you would never turn to this page...

Please try to remember exactly what lead to your error. 

Then send a description to the Author. Please include as well some information about your 
computer - such as 
· operating system (Win 95 or NT)
· processor
· RAM

When you encountered an error message include the exact contents in your mail.

Thank you very much ! That'll keep ReNovator's spirit alive !!



Legal Matters

You should carefully read the following conditions before using this software.

DISCLAIMER - AGREEMENT

Users of ReNovator must accept this disclaimer of warranty: "ReNovator is supplied as is. The 
Author disclaims all warranties, expressed or implied, including, without limitation, the 
warranties of merchantability and of fitness for any purpose.
The Author assumes no liability for damages, direct or consequential, which may result from the
use of ReNovator."

Usage of this program may violate the copyright of the modified software. It is your responsibility
to respect all legal aspects.

If not expressively granted by the respective Authors, we do not permit any release to public of 
programs that were altered using ReNovator - IT IS STRICTLY FOR YOUR PERSONAL USE !

ReNovator is a "PostcardWare program" and is provided at no charge to the user. Feel free to 
share it with your good friends, but please do not give it away altered or as part of another 
system. If you find this program useful and find that you are using ReNovator and want to 
continue to use ReNovator, you are requested to send a (real) postcard of your home to the 
Author.

Anyone distributing ReNovator for any kind of remuneration must first contact the Author for 
authorization.



About the Author of 

That was me, Florian, a few years ago. 

At the moment, I study 'MIAGE' (= Computer Science applied to business management) at the 
Fac de Sciences in Nice, France. Here I continue my studies I began in Mannheim, Germany. 
After having received my diploma here, I will return to Mannheim to complete my german 
studies (same subject). 

Coming from a 'musical' family, I soon got lessons in Cello, later I got involved in playing bass 
guitar, handling with synths, playing in bands and so on.
Having always been on an analog basis with my four-track, here in France I am stuck on my 
computer, which gives me nonetheless a new dimension of creating songs, especially with 
Rebirth 338 (and now again with ReNovator !) in conjunction with my CS1x.

I programmed ReNovator using Borland Delphi 3. My knowledge of audio programming from 
previous projects helped a lot to quickly implement it. Here's a novel about ReNovator's 
evolution.
Essential for ReNovator like we know it today was the cooperation with Rob1. He can be 
considered as the creative element - also all graphics are done by him.

Rob1.

In case of any questions, proposals, errors (also concerning this help) or what ever, contact me 
either per email:

fbomers@erato.unice.fr    
(when this address does not work, here: boemers@rumms.uni-mannheim.de)

traditional snail mail:

Florian Bömers



17, Av Desambrois
F - 06000 Nice
France
or telephone:

Tel.: +33 493 80 67 19



A bit of history of 

The idea of ReNovator was to make a joke to 2 friends, Fred Lavigne and Hugo Fiorentini. I 
wouldn't want to believe them, when they told me that there exists a 909-Version of ReBirth: I 
said "No Way !". 

Well, at home I thought, hmmm, may be resources ? With a hex editor I saw the unbelievable: 
the drums were included neatly as plain AIFF files. That was beginning of December 1997. 

Then I hode myself for days in the specifications of the PE (Portable Executable file - the normal
.exe and .dll files) and could release for christmas the first version of ReNovator (actually just 
the "small" version of the created resource editor).

Although I knew that resource sizing was possible with my program, I did not succeed in doing 
such with ReBirth - I only had the demo version.

There was very little response to this version - probably due to lack of publicity :)
After Christmas holidays I checked the page of Propellerheads and saw that they were even 
offering "mods" themselves - so I contacted them. Fredrik liked the program and came up with a
bunch of ideas. Especially resource length changing was working with the full version of ReBirth
!!
So, together with his, my own and especially Rob1's ideas I got a lot of functions to implement. 
My motivation was very high, because Fredrik was promising me the ReBirth CD.

Well, by the weekend of 18th January, it was ready for beta test and in a few days it will be 
released.



Welcome to ReNovator V1.10

With using this program, you agree to the License Agreement. 




