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Introduction
Welcome to VisLand a program that allows you to create fractal landscapes and render them either as 
still images or animation's. Visland includes it own internal 'render engine' that allows fast composing of 
the picture and can also directly produce povray script and pot heightfield files that allow the landscape 
to rendered with the povray raytracer for a more realistic image.

Visland can directly create Video For Windows AVI flyovers of the landscape with any avi codec driver 
on your system allowing memory efficient animation's to be produced. ( Video For Windows run time 
drivers are not included, they should be available for the same source as VisLand or you may find that 
they have already been installed on your system by multimedia applications such as those found on many
magazine demo CDs).  



The Menu Bar 

File
Terrain
Studio
Image
Animate
Help



The Status Bar
The Status Bar is positioned at the bottom of the main window. It displays the amount of free system 
memory available in bytes and the current key frame number.



The Terrain Window
The Terrain Window displays a contour map of the terrain. When the mouse is positioned in this window 
the pointer changes to a cross hair and the title bar of the windows displays the current position ( x , z co-
ordinates ) and the height at that position ( y co-ordinate ).

The effect of clicking the left mouse button in this window is determined by the option selected from the 
floating Tool Window.



The Image Window
This Image Window displays the rendered image. The image is rendered in 24 bit (True Colour) and may 
be saved as a True Colour TGA file or as a 256 colour gif file by using the Save Image option.



The Floating Tool Window
The floating Tool Window contains a selection of push on-off buttons that determine how a mouse click 
will function in the Terrain Window.

Position Camera
This button allows the camera to be positioned within the terrain. The cameras height will be adjusted by 
the value of the tripod height field set in the CameraDialog.

Position Camera ( Lock Height )
This button allows the camera to be positioned within the terrain window but locks the height. 
This is useful in avoiding obstructions by first positioning the camera on a high area and then using this 
button to keep the camera locked at that height.

Position Target
This button allows the target ( the point at which the camera is aimed ) to be positioned within the terrain. 

Position Target ( Lock Height )
This Button allows the target ( the point at which the camera is aimed ) to be positioned within the terrain 
but locks the height. 

Set Sea Level
This Button sets the sea level at the height shown in the terrain window upon a left mouse click.

Set Lighting
When this button is selected the terrain shrinks within the terrain window. The first left mouse click will set 
the position of the light source. The second mouse click will set the angle of the light source with respect 
to the terrain centre.

Set Tree Level
This button sets the Tree Level at the height shown in the terrain window upon a left mouse click.

Make Path
This button creates a path or ledge at the height shown in the terrain window upon a left mouse click.



The Dialog Boxes

Render
Camera 
Light 
Edit Colour    
Edit Colour Map
Edit Surface
New Terrain
Tree



The File Menu
The File Menu contains the following commands:

New
Generates a new terrain. This option selects the New Terrain Dialog dialog box.

Open
Opens a terrain file (*.fls). 

Save
Saves the current terrain file (*.fls) with the same name as it was opened , if a new name is required then 
use the Save As Option.

Save As
Saves the current terrain file and allows a name to be given.

Save Pov
Generates Script files for the Persistence of Vision Ray Tracer. A total of    3 files are saved with the 
extensions *.inc , *.pov , *.pot . The *.pov file should be used as the input file to povray in accordance with
the povray instructions. Povray is a Freeware program and should be obtainable form the same source as
this program.

System Info
Shows Information about the hardware and video set up of the computer.

Exit
Exits the Program.



The Terrain Menu
The Terrain Menu Contains the following commands:

Trees
Allows editing of the tree generator parameters by selecting the Tree Dialog Box dialog box.

Sea
Allows    editing of the sea generator parameters.

Sky
Allows editing to the sky generator parameters.

Height
Scales the relative height of the landscape as a percentage of the optimal height.

Land Colour
This enables a Edit Colour Map dialog for the landscape that determines the colour of the landscape 
according to the height.

Surface
Allows the seting of the surface characteristics of the landscape by using the Edit Surface Dialog. 



The Studio Menu
The Studio Menu has the following commands:

Camera
Allows adjustment to the camera by using the Edit Camera Dialog.

Light
Allows adjustment to the light position and intensity using the light dialog.

Ambient Light
Allows adjustment to the ambient light. The Red, Green and Blue components or Hue, Staturation and 
Luminance components are adjusted by using the Edit Colour Dialog.



The Image Menu
The Image Menu has the following commands:

Size
Set the size of the image to be rendered for still images and animation's.

Render
Renders the image , this accesses the Render Dialog

Save
Saves the image , Either as a    256 colour GIF or True Colour TGA.



The Animate Menu
Animation ability is provided by the use of key frames. Up to 64 key frames may be used. At each key 
frame the camera position and target may be specified. Upon animation these key frames are interpolated
using a bspline curve to provide a 'Path' for the camera to follow.

The Animate Menu has the following commands:

Goto Key
Selects the current key frame to work on.

Insert Key
Inserts a new key frame after the current key frame. 

Delete Key
Deletes the current key frame.

Compressor Options
This allows the selection and configuration of a chosen video for windows compression driver .This 
compression driver (codec)    will be used in the generation of avi files.

Set Frames
Sets the number of frames in the animation.

Render Animation
Starts the rendering process for the animation. First a file name and extension must be selected, the 
filename extension determines the animation type:

ani_name.avi Creates a video for windows avi file with the currently selected compressor.

ani_name.pov Creates a sequence of numbered pov scripts for each animation frame and a 
batch file ani_name.bat to 'run'. Note povray.exe must be on the path. 

ani_name.tga Creates a sequence of numbered tga image files.

View Animation
Views the last animation to be rendered.



The Help Menu
The Help menu has the following commands:

Contents
Accesses the help system.

About
Provides information about the program.



The Render Dialog
The Render Dialog allows control over the rendering process for speed and quality. It is comprised of    
four sections:

Render
This Sets quality of rendering. Flat calculates the light at the centre of a triangle only and gives a sharp , 
jaggy look. Gouard calculates the light at all 3 triangle vertices and interpolates these over the triangle 
giving a smooth look.Phong calculate the light at every pixel in the triangle to give a more accurate 
smooth look.

Palette
This selects the method that the 256 colour palette is calculated from the True Colour rendered image. 
Lock uses the last calculated palette. Optimise calculates an optimal palette for the image while Dither 
uses a fixed palette and Dithers the image to approximate the full 24 bit (16.8 millon) colour range. Both 
LOCK and DITHER avoid the time taken to calculate a palette, while optimise gives the best result. If only
small changes are made to the render, such as a minor change in camera position then LOCKing the last 
palette can also give good results in a quicker time.Note these options are only valid when using a 256 
colour dirver and are ignored when using a true colour driver. 

Divide
This sets the coarseness of the terrain grid to be sampled. Divide by 1 samples at every point in the 
terrain gird while divide by 2 samples at every 2 points etc. Use high divide factors for fast but course 
renders.    

Options
This allows the various elements Terrain, Sky, Sea, Trees to be included or excluded from the render.



The New Terrain Dialog
The New Terrain Dialog allows the creation of a new random fractal terrain map.

Size
This sets the size or resolution of the terrain map. Preset sizes can be selected via the buttons or any size
from 64 by 64 to 32767 to 32767 units may be given in accordance with the available memory.

Seed
This allows a unique seed value for the terrain to be entered or a new random seed generated by using 
the Random button

Grain
This allows the grain value to be entered. The higher the grain value the more peaks and 'spiky' the 
terrain map will be.



The Edit Colour Dialog
The Edit Colour Dialog allows a colour to be set by adjusting the RGB sliders or by adjusting the HSV 
sliders. 



The Edit Surface Dialog
The Edit Surface Dialog allow adustment of the Ambient , Diffuse and Specular components of the 
surface. The Tightness allows adjustment of the specular highlight with higher values making the specular
highlight tighter.
Increasing the ambient value will brighten the 'shadow areas' . Increasing the diffuse value will brighten 
the areas in 'direct light'.



The Edit Colour Map Dialog
The Edit Colour Map Dialog Dialog allows a colour map to be edited. The dialog Comprises of a colour 
map display which shows the spread of colours within the colour map from 0% at the far left to 100% at 
the far right. Below this display there are a selection of tags which occur at 1% intervals. Active tags are 
shown in red and the currently selected tag is shown in black while all other potential tags are shown in 
light blue. The tags at the 0% and 100% marks may not be deleted.           

Inserting a tag
A tag may be inserted by clicking with the right mouse button on any light blue tag

Selecting a tag
A tag may be selected by clicking on it with the left mouse button, only active tag (red) may be selected.

Deleting a tag
A tag may be deleted by first selecting it and then using the delete button.

Setting a tags colour
A tag colour may be changed by first selecting it and then using the RGB slider to adjust the colour.

Loading a colour map
A colour map may be loaded from disk by using the load button.

Saving a colour map
A colour map may be save to disk by using the save button.



The Tree Dialog
There tree dialog controls the generation of trees. Note the Trees check box must be selected in the 
Render Dialog for the trees to be included in the render.

Height
This sets the average height at which trees occur. Trees occur with less frequency above and bellow this 
point depending on the Spread value.

Density
This controls how sparsely or densely the trees are populated and is in percent.

Spread
This controls how far the trees will deviate in height from the Height value and is in percent.

Size
This value sets the size of the trees.

Zclip
This value ignores in the render any trees that are closer to the camera than the Zclip value.

Maximum
This determines the maximum number of trees that will be rendered.

Colour Map
This activates a Edit Colour Map dialog that allows the colour of a tree to be varied in accordance with the
trees height.



The Camera Dialog
The Camera Dialog Controls the features of the camera.

Camera
The Cameras position may be adjusted to any value , not just those positions allowable by using the 
camera options on the Tool Box.

Target
The Targets position may be adjusted to any value , not just those positions allowable by using the target 
options on the Tool Box.

Field of View
Sets the Field of View for the camera. Low values give a telephoto effect while high values give a wide 
angle effect. 

Z Rotation
Changes the cameras orientation around the z axis. 

Tripod Height
When the Tool Box is used to position the camera this value is added the height of the terrain to obtain 
the y co-ordinate simulating a tripod. This is useful to avoid small "bumps" close to the camera obscuring 
the background.    



The Light Dialog
The Light Dialog allows the scene lighting to be varied.

Position
This allows the location of the light source to be specified anywhere and is not constrained to the 
locations allowed by the Tool Box light button.

Intensity
This is allows the intensity of the Red, Green and Blue components of the lighting to be adjusted using 
the Edit Colour Dialog.



Colour Maps
Colour maps are used throughout the program to provide a colour gradient.





VisLand Licence Agreement
This licence agreement refers to and only to this unregistered trial version of VisLand.

Use of VisLand constitutes acceptance of the stated terms and conditions of this licence. All rights which 
are not expressly granted are reserved.

The VisLand Program is    fully    copyrighted,    and    is NOT FREEWARE. It is and may be distributed 
under a limited distribution agreement stated latter.

You may use VisLand in its unregistered state for 30 days before paying for and registering the product. If,
after 30 days, you    decide that VisLand performs to your expectations, you    are required    by law to pay 
for and register your copy. If the software does not meet your needs and you do not plan on registering 
VisLand after the 30 day    trial period,    you    are    required to cease the usage of the program. Continued
use of VisLand beyond the authorised evaluation period requires payment of the registration fee in full.

No responsibility is assumed for    any damages    or    other losses suffered    as a result of running 
VisLand on your    system.    The user assumes full responsibility for the proper use of this program ,    
whether damage occurs as a fault of operator error or software error. 

NO WARRANTIES ARE IMPLIED OR EXPRESSLY STATED.

Distribution Agreement

This software package and all of the related files are copyrighted and may only be distributed according to
the following conditions.

No portion of this package may be separated from the package and distributed separately. The package 
must be distributed as the original archive vislnd01.zip and may not be renamed.

The following methods are allowed for distributing this package.

Distribution by means of electronic media services such as BBS services , INTERNET etc. has no 
restrictions providing that no charge is levied other than the normal service connect charge and that 
service is not charged at a premium rate telephone tariff.

Non-commercial distribution by floppy disk (such as a user copying the software for a personal friend or 
colleague) is allowed providing that no charge or services are levied for that copy and the package is not 
provided as part of a product or a service.

No other forms of distribution are allowed without written permission of the copyright holder. These 
include distributing as part of magazine or book or distribution by shareware vendors.



Registration
VisLand is provided for a 30 day trial period after which a registered version must be purchased or the 
use of Visland must cease. The registered version of VisLand is available at the cost of £35.00 UK 
Pounds. 

To purchase VisLand print out the purchase order with the Print topic option on the Help File menu. 
Click here for purchase order



Purchase Order
VisLand costs £35.00 UK Pounds inclusive. 

Please make Cheques payable to M.J.Dimon and send to:-

Mark Dimon,
MDM Digital Media,
185 Ditchling Rise, Brighton, East Sussex, BN1 4QR.
Telephone 01273-672553.
Email mark.dimon@saxon.seuk.com.

Name: __________________________________________________

Address: __________________________________________________

__________________________________________________

__________________________________________________

__________________________________________________

Telephone: _____________________

Email: _____________________

Where did you hear about VisLand: _____________________________

_____________________________________________________________

Comments: __________________________________________________

_____________________________________________________________

_____________________________________________________________




