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INTRODUCTION

      The program Bank Investor automates the use of checking accounts.    It allows to record up to 10 
separate accounts, maintains a record of all transactions, facilitates reconciling the bank accounts, 
permits printing of the checks on any standard form that you select (inc. the standard checks supplied by 
your bank). The checks can be written in English, German, Spanish, French, or Italian. Each account can 
be individually assigned a different language and currency symbol.
      The printing of customized checks is facilitated by the setup routine in which the user may define the 
exact position of each printed line and language to be used. 
        The programs allows setting up the budget categories for your income (up to 6) and expenses (up to 
28), thus presenting an exact review of your income and expenditures over a selected time period. 
Budget reports show how much was spent/received in any user-defined budget area over any desired 
time period. It provides the function "unpaid bills/deposits" to store yearly, monthly, or one-time-only 
transactions and remind about them when they become due. The program permits naming up to 10 
bank/credit accounts.
      Registered version of the program permits setting up to three separate files (eg. for different 
individuals), each of which may contain a full selection of the various bank and credit accounts. 
            



PROGRAM CONFIGURATION

      At the first startup of the program you will be asked to select the font for check printing, password 
(optional) and to name your accounts, select the currency symbols, select the language for printing 
checks, name budget groups, and be presented with the check configuration routine which includes the 
parameters for check printing and personal password.    This routine can also be reached    by clicking 
mouse on "Program configuration" in the "Utilities" menu. The check configuration routine permits you to 
configure the program for up to five different check forms of your choice. 
      You must respond to all the questions presented on the screen, but you may leave blank the field for 
the password.    
      During the initial configuration you will also be asked to name all your accounts and budget categories.
The listing of accounts includes also a selection of the currency symbol and the check printing form (see 
above) for each individual account. Thus you have the ability to list accounts with different check forms 
and/or currencies. If you wish to keep the default selections, just press    <ENTER>,    otherwise enter the 
new name and press    <ENTER> .    
      The budget categories require an additional switch: if it is set to - 1 - this category will be counted 
towards the grand total, if it is - 0 - it will not. For instance, you might have some expenses through a 
credit card charge and then pay them back to the credit card company. Obviously the payments to the 
credit card company should not be added in calculation of the overall sum of expenses for the period. 
Thus the category "credit card payments" should get a switch of    0 . 

NOTE: If you wish to summarize expenses/income between differing accounts, these accounts 
must have identical budget categories (ie. identical names AND placed in the same order), it    can 
best be accomplished by using routine "Copy" under the "Tools" menu.



PASSWORD

The password option is active only in registered copies of the program. Please note that the password is 
case sensitive, ie. "PASSWORD" is not the same as "password", or "PassworD"!

NOTE: Make a note of your password, since once this option has been invoked, the program 
cannot be started without the correct password.    If you retained the original copy of the program 
(without the password invoked), in emergency you may recover the data by copying the former 
BANK.CFG file into your new directory and then starting the program anew.



CHECK CONFIGURATION

      The suggested parameters for check printing are displayed during the configuration dialog. You may 
change them to accommodate the particular design of your check form. The parameters required for 
check printing are row no. and column no. 
      In order to determine the settings required for your printer, insert a blank check into the printer and 
click on "Print grid for checks" from "Utilities" menu. The grid should give the exact location of various 
entries on the check form. Enter these lines during the configuration dialog. At this point, you can also 
define the language to be used with this form.
      
NOTE: This routine requires a precise placement of the printed text. Always start by placing your 
blank check in precisely the same location in the printer, eg. with the top edge just underneath the
holding bar.



BUDGET GROUPS

      You may change or add names of budget groups by selecting "Listings" - "Budget groups" and typing 
the new names in the appropriate places. The budget categories require an additional switch: if it is set to 
- 1 - this category will be counted towards the grand total, if it is - 0 - it will not. For instance, you might 
have some expenses through a credit card charge and then pay them back to the credit card company. 
Obviously the payments to the credit card company should not be added in calculation of the overall sum 
of expenses for the period. Thus the category "credit card payments" should get a switch of    0 . 



ACCOUNT NAMES

        You may change or add the names of accounts by selecting "Listings" - Accounts" and typing the new 
names in the appropriate places. For each new account you are required to state the check form #, 
currency symbol,    format for date presentation to be used, and balance limit. 'Check form #' refers to the 
forms defined during the configuration routine. The balance limit - is the lowest balance permitted for the 
account, eg.    0 - for checking account (no overdraft), or    - 3000 - for a credit card (ie. credit limit). If the 
balance drops below that number, a waerning will be flashed on the screen.



STARTING THE PROGRAM

      The initial window that appears after the user passes through the "Registration screen", contains at the
top a menu bar which presents the following options:

        File        Activities        Listings          Utilities        Tools          Help

      The inactivated menu choices will be "grayed" for easy identification. In order to start the program you 
MUST click the mouse on the "File", this will drop the menu:
          Open... 
          Print...
          Exit this program
          Exit Windows

Now click on "Open...", this will present the menu:
          File #1
          File #2
          File #3

      You MUST click on the "File #1", to activate most of the other menu options. If you wish to terminate 
the program, but remain under Windows - click on the "Exit this program". The "Exit Windows" selection 
terminates the program and the Windows operating system and brings back the DOS command line.
      The option to set up the additional two files    is available only to the registered users only. NOTE:    
Files #2 and 3 can use only the accounts that have already been selected for the File #1.

IMPORTANT NOTE:    The program uses two windows to display information. In the Main Window 
(background color - light blue) all selections are accomplished using a mouse to point the 
selections and then clicking the left mouse button to confirm it. In the Supplementary Window 
(background color - white) the mouse does not operate and all selections must be made by 
entering the appropriate number (or text) from the keyboard and pressing the    <ENTER>    key to 
complete the transmission. 



ENTERING A TRANSACTION

      To start a transaction (ie. payment or deposit), select "Transactions" from the "Activities" menu. A 
window will appear with three selection groups: disregard the first selection group, marked as "for 
automatic transactions only". The second group presents the following choice of transactions, where the 
column under "ACTION" presents your choice, while the other three columns give the result of that action:

ACTION                        ACCOUNT                      CHECK No.                        BUDGET

check                                      debited                                      increased                                debited
withdrawal                        debited                                      no change                              debited
deposit                                  credited                                    no change                              credited
unpaid bill                          N/A                                                      N/A                                                N/A
auto. deposit                    N/A                                                    N/A                                                N/A
cash purchase            no change                            no change                                debited
credit                                        no change                            no change                                credited

The use of "unpaid bill" and "auto. deposit" will be explained separately.

      The third group presents a choice of your accounts. Select one, and lastly press the "OK" button.

      The next window that will appear presents a check, or credit form to the left and a list of all the budget 
groups on the right hand side. The check form will automatically present the next check number and the 
current date. You may alter the date field directly, and check no. through the "Tools" menu. You should 
also fill the name of the payee, or payer, the amount of the transaction and select the appropriate budget 
group. The current balance on the account is indicated immediately below the check form. You are also 
given the option to print this check immediately.
        The "split entry" option allows to combine two, or more items that are charged to different budget 
groups but are paid/credited in a single transaction. Select "start split entry" for the first item, and select 
"end split entry" for the last item of such a group.



UNPAID BILLS AND AUTO. DEPOSITS

      The unpaid bills feature allows to enter a bill that needs to be paid, or a deposit that is expected to be 
received, at some future date either at regular intervals (monthly, yearly), or just once. You enter such 
bill/deposit by selecting "Transactions" from the "Activities" menu and choosing either "Unpaid bill" or 
"Auto. deposit" from the next display window. At this time you the frequency of that transaction must be 
indicated by selecting the appropriate item within the group marked "for automatic transactions only". To 
pay an "unpaid bill" simply follow the instructions as they will appear on the screen.
      Once such an item is recorded and becomes due, you will be reminded    whenever    the Bank Expert 
is started. If it is a periodic occurrence - the new date will be automatically updated after the 
payment/deposit was made.



PAYMENTS AND DEPOSITS DUE

      In order to obtain a listing of all deposits and payments due by a certain date, select "Payments & 
deposits due" from the "Activities" menu. After the listing is displayed, you may choose to pay/credit the 
individual items.



RECONCILING AN ACCOUNT

      In order to reconcile an account, ie to compare it with the bank statement, select "Reconcile account" 
from the "Activities" menu. On the first display you will be asked to select the account. Once this has been
completed, the outstanding items on that account will be presented. At this time you may correct any of 
the entries displayed and you must respond to the question whether this item was listed on the bank's 
statement.
      Once the list of outstanding items is exhausted, the program displays the current account's balance 
that should have been reported by the bank and asks if you "agree" with the result. If you agree, all the 
items that appeared on the bank statement are marked as processed and will not appear when the 
account is balanced next time.



SUMMARY OF INCOME/EXPENSES BY BUDGET GROUPS

      A summary of all income and expenses categorized by the budget groups and limited to the selected 
period of time is obtained by choosing "Summary of budget groups" from the "Listings" menu. The first 
window that will appear asks to state the time period and select all the accounts that should be 
summarized together. 

NOTE : You can only select accounts that have identical budget groups (both: named identically 
AND placed in the same order).

      The "sum of designated credits" and "sum of designated expenses" includes only the budget groups 
that have been given the switch value of 1 (for explanation see the section about configuring the 
program).



CHECK PRINTING

      Checks can be printed on any bank form, however the program must be instructed the exact position 
of the individual lines, ie. date, payee, amount of payment (numerical, and text), and any comments. Note
that the program will convert automatically the numerical amount of payment into the text.
      For consistent results, the check form must be always inserted in EXACTLY the same location in the 
printer. For instance, in matrix type printers you may align the top edge of the form with the holding bar. It 
is necessary to make a number of trial runs to determine the needed configuration for the check. The 
initial trials could be made with a plane sheet of paper, and the actual checks be used for only the final 
adjustments. Note that both row and column numbers are roughly in half units, ie for instance a third 
printing line would have a row no. of 6. The check configuration is reached by selecting "Utilities" and 
"Program configuration" next.
      You may print each check as it is recorded, by selecting "print check" on the check form (see above). 
Alternatively, select "Check printing" from the "Activities" menu. A list of checks will appear and you will be
asked for the number of the check to be printed.



CHANGE CHECK NUMBER

      A special routine is provided to change the number of the NEXT check. To access it, select "Change 
check no." from the "Tools" menu and follow instructions on the screen.



EDITING OF RECORDS

      The records in both the check register and the register of "unpaid" bills/deposits can be readily edited 
by accessing them through "Edit records" from the "Tools" menu.
      The program will list all the selected records and ask which one to change. Next, that record will be 
displayed and any of the fields on it can be altered at that time.



ACCOUNT BALANCES

      The current balances on all active accounts are obtained by selecting "Balances" from the "Listings" 
menu.



SEARCH FOR RECORDS

      To search for transactions with a selected Payee/Payer, choose "Search" from "Tools" menu and type 
in the desired search text. 

NOTE: you need not enter the full name, for instance you can enter "Soc" when looking for all 
"Social Security payments.



PRINTING OF SCREEN DISPLAY

      In order to print any of the displays, first select "Print on" from "Printing" menu item in the "File" menu. 
The selection will stay active until cancelled and will print any listings, as they are displayed on the 
screen.



ARCHIVING OF RECORDS

      It is advisable to archive all records on floppy disks at regular intervals. The procedure is very simple: 
place a floppy in drive A:    or drive B: and select "Copy" from the "Tools" menu. The program will copy 
automatically all data records (ie with    .DAT    or    .LOG) to the floppy.



EXPORTING DATA FILES

      All data can be exported in the comma delimited format by selecting "Tools" / "Copy" / "Export" from 
the menu. All data will be placed in a single file named    DATA.TXT in the following sequence: account 
no., budget group, payee/payer, amount, date, check no. Such data file can then be used in many 
"database" programs.



INTERNATIONAL EDITION

    The International Edition permits to type checks in four additional languages: French, German, Spanish,
and Italian.    The Standard Edition uses English only.



FONTS

      You may select any font that is available through the Windows interface. The name of the font must be 
exactly the same as shown in the Windows Control Panel.



RECONCILING AN ACCOUNT

      In order to reconcile an account, ie to compare it with the bank statement, select "Reconcile account" 
from the "Activities" menu. On the first display you will be asked to select the account. Once this has been
completed, the outstanding items on that account will be presented. At this time you may correct any of 
the entries displayed and you must respond to the question whether this item was listed on the bank's 
statement.
      Once the list of outstanding items is exhausted, the program displays the current account's balance 
that should have been reported by the bank and asks if you "agree" with the result. If you agree, all the 
items that appeared on the bank statement are marked as processed and will not appear when the 
account is balanced next time.



ACCOUNT NAMES

        You may change or add the names of accounts by selecting "Listings" - Accounts" and typing the new 
names in the appropriate places. For each new account you are required to state the check form #, 
currency symbol, and format for date presentation to be used. 'Check form #' refers to the forms defined 
during the configuration routine.



BUDGET GROUPS

      You may change or add names of budget groups by selecting "Listings" - "Budget groups" and typing 
the new names in the appropriate places. The budget categories require an additional switch: if it is set to 
- 1 - this category will be counted towards the grand total, if it is - 0 - it will not. For instance, you might 
have some expenses through a credit card charge and then pay them back to the credit card company. 
Obviously the payments to the credit card company should not be added in calculation of the overall sum 
of expenses for the period. Thus the category "credit card payments" should get a switch of    0 . 



FINANCIAL CALCULATIONS

Future value of an investment at compound interest :    Future value of an investment at a fixed 
interest rate, with the interest payments re-invested at the same rate.

Future value of a stream of equal payments :    Future value of periodic payments invested at a 
compound interest rate.

Repayment of amortizing loan :    Calculating the magnitude of equal, periodic payments required to pay
the entire principal and interest within a set time period. A mortgage is an example of an amortizing loan.

Present value of annuity :    Present value of a stream of payments, assuming a certain interest rate on 
the remaining balance. This calculates the amount required to finance a fixed number of peridic 
payments, eg annuity.    For the calculating the amount of annuity, insert the life expectancy for the 
number of annual payments.

Compound growth rate of investment that growth to a specified value :    Calculates the compound 
interest rate that would increase a given investment to a fixed future value within a given time period.

Single life expectancy :    based on IRS tables (published in 1991) and giving the statistically estimated 
average, remaining lifetime at any given age. 



LIFE EXPECTANCY

This is one of the "financial calculation" and is based on the IRS tables (published in 1991) and giving the 
statistically estimated average, remaining lifetime at any given age.



UNPAID BILLS AND AUTO. DEPOSITS

      The unpaid bills feature allows to enter a bill that needs to be paid, or a deposit that is expected to be 
received, at some future date either at regular intervals (monthly, yearly), or just once. You enter such 
bill/deposit by selecting "Transactions" from the "Activities" menu and choosing either "Unpaid bill" or 
"Auto. deposit" from the next display window. At this time you the frequency of that transaction must be 
indicated by selecting the appropriate item within the group marked "for automatic transactions only". To 
pay an "unpaid bill" simply follow the instructions as they will appear on the screen.
      Once such an item is recorded and becomes due, you will be reminded    whenever    the Bank Expert 
is started. If it is a periodic occurrence - the new date will be automatically updated after the 
payment/deposit was made.
      You can examine the bills/deposits that will become due by a certain date by selecting 
"Payments/deposits due by ..." from "Activities" menu.


