
Adr_Book Step by Step

The best way to learn a new program is by example.  By following the steps listed here you will 
quickly learn the operation of Adr_Book and its features. 

If you have just loaded Adr_Book the sample database file sample.adr will be loaded when you 
first run the program. This file is required for using the step by step tutorial that follows. 

NAVIGATION:  

1. Run the Adr_Book program. When first running the program the default database file 
sample.adr will be loaded.  If it is not loaded, select open from the file menu, and read this 
file. 

2. Place the mouse pointer on the black and yellow F tab and click the left mouse button. You 
should see the name Furter, Frank appear in the upper left quarter of the address book. The 
name and address will be highlighted in turquoise. Selecting any tab letter will take you to the 
first person whose last name begins with that letter. 

3. Using the mouse click single right pointer green arrow. This should cause the name, 
Gardner, Richard to be highlighted. Click the single arrow three more times and you will see 
the page turn with the name Marx, Groucho highlighted. The single green arrow keys move 
through the record names one at a time, while the double arrows move through the names 
four at a time. Play around with this for awhile.

4. Using the mouse on the list box to the right of the graphical address book,  scroll until you 
see the name Spaulding R.  click on it with the mouse. You will immediately see the name 
appear highlighted in the left hand corner of the address book. This method can be used to 
bring up any individual instantly.

5. Select the name at the top of the list box by clicking the mouse to the right of the name and 
then dragging it to the left until the entire name is highlighted. (What you are trying to do is 
erase everything in the list box title)  Type the letter M and you will see the name Main, Hugh 
appear highlighted in the upper left corner of the address book. You will also see this name 
highlighted in the list box. Now type the letter A followed by an R.  The name selected will now
be Marx, Groucho.  This is probably the fastest method to locate a name in the database.

6. Move the mouse to click on any part of the address for Ramuglia, Randy. Notice how it 
now becomes the highlighted name. This is the means for making active any name visible on 
the address book.

EDITING /ADDING /DELETING:

1. Click on the A tab letter. Aile, Ginger should appear highlighted in the upper left corner of 
the address book. Using the mouse double click in any part of the turquoise area. This should 
bring you to edit dialog box containing all attributes for this record. Change the home 
telephone number from 9833 to 9888. Now click on OK and when the address book is 
redisplayed you should see this new home phone number.

2. Select the Edit button from below the list box. This will once again bring you to the edit 
dialog box. Click Cancel to go back to the address book. Now double click on the name Chu, 
Chirk in the list box. This also gets you to the editing dialog box. Once again select  Cancel.  
Now click on Edit from the pull down menu at the top of the window and select Edit.  This is 
yet another way to get to the Edit Dialog Box. Select Cancel.



3. Click on the A tab letter. Click on the Edit button to once again enter the dialog box. Click 
on the Add / Next button. This will cause the next record to be displayed in the dialog box, 
making it available for edit changes.  In this case, you will see the record for Chirk Chu.  Click
on the Add / Next button again and you will see the record for Joe Cool appear. This is a 
good way to go through all of your records making many modifications. Click on Cancel to get 
back to the address book display.

4. To add a new entry into the database click on the Add button below the list box. This will 
bring up an empty dialog box. Enter your last name and first name and fields of interest. If this 
was the only name you wanted to add you would click OK, to get back to the address book.  If 
you wanted to add additional records you would select the Add / Next button. For our 
example, click on the Add / Next button.  Notice how the dialog box is cleared and is ready to 
receive data for the next record. Click on Cancel. You will now see the name you just entered 
highlighted in turquise.  You could also get the the dialog box for adding by selecting the Add 
option under the Edit menu option.

5. To delete a record click on the Delete button below the list box. Do this now. You will get a 
pop up box asking if you really want to delete the record.  The record to be deleted is the one 
currently highlighted in turquise. In this case it should be the name you just added. Respond  
by selecting Yes.  You could also Delete a record by selecting the Delete option under the 
Edit menu option.

DISPLAY OPTIONS:

The display options control what record information will be shown on the graphical address 
book. They also control which records will be displayed.

1. Click on the Option menu item and then select Display.  From the dialog box presented 
click on the Work Phone check box, and the Birthday check box.  Now click on the OK box. 
You should see the work phone and birthday appear in the graphical address book. 
Experiment with different data items that can be displayed.

2. Let us say you would only like to see those people who have a birthday in July. Get to the 
Options dialog as described above. If the Birthday check box does not have an X in the box 
click on it. Also make sure there is an X in the Flags field. Now in the "Display records with 
selected flags", type in the word JULY. The word needs to be typed in capital letters. Click the 
(SEQ) must be in sequence check box. Click the OK button.  You should see only five 
names displayed. Notice that the birthdays for these five all fall in July.  Notice the flags for 
these five all contain the word JULY.  The Flags field is entered in the Add / Edit dialog box.

3. Lets say now that you are interested in listing people who play either racquetball or tennis. 
Get to the Options dialog as described above. In the flags area remove the text string JULY 
and replace it with the two lower case letters rt.  Click on the OR (Containing any) check box.
Click the OK button.  You will now see all records that contained either an r or  t in the flags 
field.

4. Now you are interested in people that play both tennis and racquetball.  Enter the Options 
dialog box. Click the AND (must contain all) check box.  This indicates to display only those 
records that contain both an r and a t. Click on the OK button. There should only be two 
records displayed. Notice that it doesn't matter where the letters are placed in the Flags field 
or the order in which they come.

5. And finally you want to know who the people are who play neither tennis or racquetball. 
Enter the Options dialog box. Click on the OR (containing any) check box. Click on the NOT 
(reverse sense of selection) check box. Click on OK. You now see the people who play 



neither tennis or racquetball.

6. Enter the Options dialog box. Click on the ALL (list all records) check box. Click on OK. All
of the records are now displayed. 

REPORT OPTIONS:

The report options controls the text used for report headers, and the return addresses to be 
used when printing envelopes.

1. Click on the Option menu item and then select Report Header.  The dialog box presented 
allows for two header lines to be printed on reports and two possible return addresses that can
be used when printing envelopes. At this time you can change this entries but they will not be 
used until later when printing is described.  If you make changes select OK when you exit the 
dialog box otherwise you can select Cancel.

FILE EXPORTING / IMPORTING:

Exporting writes selected database records to a file in ASCII format. This file can then be 
Imported back into an Adr_Book database or possibly manipulated for including into some 
other database. 

1. Let's say we want to create an Export file that contains people who can play either 
racquetball or tennis. Click on the Option menu item and then select Display.  In the flags 
field enter rt. (Remember from above, these need to be entered as lower case letters)  Next 
click the OR check box and then select OK. You should now only see records for people who 
can play either Racquetball or Tennis.

2.  From the File menu select Export. You will be presented with a dialog box requesting a 
name for saving the file. Enter the name samp.dmp then click on OK.

3.  To demonstrate how this file can be Imported we will simply read it back into Adr_Book as 
a new file.  From the File menu select New.  This will clear the current database.  From the 
File menu select Import.  From the presented dialog box select the file samp.dmp and then 
click on OK.  The new database file now contains only those records of individuals that can 
play either Racquetball or Tennis. It should be noted that the samp.dmp file could have been 
Imported into an existing database file. It did not have to be a new file. (NOTE: If you have an 
unregistered version the import feature will not work)

4. The New file has not been saved.  Since we are not really interested in this New file lets 
discard it by selecting Open from the File menu.  You will be presented with a dialog box 
asking if you would like to save the New file.  Click on NO. From the Open dialog box select 
the file sample.adr.

PRINTING:

The real test of this program working for you is how well it prints name lists, the address 
booklet, labels, and envelopes.  The printing of envelopes will only work for single envelopes 
that are printed in Landscape.  Before you consider registering this program run through all of 
the printing options to see that all works well for you. Turn on your printer!

1. From the File menu select Print.  From the dialog box select Print List Two Columns. 
Then click on Print.  This report will only print individual names and and a phone number. As 
in all reports you can use the Flags as described above to print only selected records. Also as 
in all reports you can specify how many copies and a header to be printed.  The unique option 
on this report is whether to print the the home phone or work phone. Click on Print and see 



what happens.

2. From the File menu select Print.  From the dialog box select Phone List (condensed ..) 
Then click on Print. This report will print the name, address, and phone number. It will print 
both the home address and work address if present. Click on Print.

3. From the File menu select Print.  From the dialog box select Pocket Size Address Book. 
Then click on Print. This will print an address booklet with pages that are 4 1/4"  x 5 1/2 ". For 
this to work correctly you printer must be able to sheet feed since printing is two sided. Click 
on Print. For this example, one sheet will be printed and a dialog box will appear asking you 
to reload the paper to print on the reverse side. Do this and the and then click on OK.  Take 
the paper and cut it in half so you will have two sheets that are 8 1/2"  x  5 1/2".  Stack them 
so that the sheet with number 1 will be on top of the sheet with number 3. Fold it in half and 
you will have a small address book.  This address book will be created correctly for any 
number of records.

4. From the File menu select Print.  From the dialog box select either 2-UP Labels or  3-UP 
Labels. Then click on Print. You will then be presented with a dialog box permitting you to 
select whether the addresses should be home or work, in order by zip code, all capital letters. 
There is a Position ... button that will take you to a dialog box to allow positioning of labels for 
output. Click on Print.

5. From the File menu select Print.  From the dialog box select any of the three Envelope size
options. Then click on Print. Envelopes are only printed in Landscape mode. This mode will 
automatically be set on printing. At this time there are no other options.  Depending on 
response, this may change in a later release.  

The first thing you should notice in the dialog box is the Addressee contains the name that 
was highlighted in turquoise on the graphical address book.  There are a variety of options 
from this dialog box. From above, you had the opportunity to enter two return address in the 
Options  Report Header dialog box.  You can now toggle between these two preset return 
address by clicking on #1 or  #2.  You can also perform editing in the return address displayed 
to change it to any desired return address. ( You can also edit the addressee text). There are 
the usual options of fonts, point size, bold, and Italic. Have fun and create an attractive 
envelope. You can also choose to have the postnet barcode printed for the zip code.  To have 
a note text printed on the lower left of the envelope you will need to click on Note... to get to 
another dialog box for this purpose. When you are though click on Print to see the result.

Note: printing envelopes is actually a very trick business. There are several check boxes that 
allow you to specify printing on the left or right of the print tray, and whether to print in the front
or rear. Basically if you have a LaserJet the defaults of This side and Front should work fine. 
For a DeskJet select The Other Side and Rear. 

If you have stepped through this document you will have tested most of the features of Adr_Book
and should know if this program will work for you. I hope that it will. If you have any questions or 
suggestions please send to:

Internet E-mail to mikeg@ims.alaska.edu

Michael Gardner
1231 Redwood Ct.
Anchorage AK 99508

Please Register:   $15 to Michael Gardner at the above address.
June 14,  1994


