
Lyra for Windows

Introduction
Welcome to Lyra! This program is designed to be an easy way to compose music on your PC. 
Lack of music keyboard skills is not an impediment. You can easily write or transcribe music using
a mouse. The music is displayed in standard notation, just like sheet music. Or you can use the 
program to just play music.

The purpose of this document is to provide you with a file that can be printed and give you the 
essential information to get you up and running quickly. More detailed and up-to-date information 
is to be found in the on-line help. If you find a term in this document that is not completely defined
or explained, use the search button in the on-line help for additional information.

If you have suggestions for new features or notice that things don't seem to work right or are 
unnecessarily difficult to use, please let me know. If you find the program useful, please consider 
paying a $20.00 registration fee. As a registered user, you will be sent a copy of the latest version
and the opportunity to obtain updates for a small charge. Please direct all comments, 
suggestions, and inquiries to:

Lester Hands
MusicWare
Hamlet Rt. 1261
Seaside, OR 97138

Lyra is copyright 1993 by Lester Hands. Permission is given to distribute copies of this program 
and supporting files provided that no changes are made and no charge is made for the program. 
A nominal charge may be made for the distribution media. This program may not be included with
another program or product without the written permission of the author.

What you need to run Lyra
Lyra requires a computer that can run Windows 3.1 (or a later version); if you wish to play music, 
you must have a Windows compatible sound card such as a Sound Blaster or a MIDI interface 
card such as an MPU-401 and a MIDI capable synthesizer.

Windows comes with the necessary software needed to work with a Sound Blaster or MPU-401 
card. All that you have to do is to follow the directions in the Windows manual to make sure that 
the needed driver is installed and properly configured.

If you are using a different sound card or MIDI interface, then you will need to install specially 
written drivers. These drivers are usually supplied by the manufacturer on a disk. If you don't 
have such a disk, contact the manufacturer.

This version assumes that Windows is running on a VGA monitor with a resolution of 640x480 or 
higher.

Installing Lyra



All the files need by Lyra are present on the distribution disk (or ZIP file). Simply copy all files to 
an empty directory on your hard drive. Lyra will not create files outside of this directory except for 
music files when you specifically tell it to save a file to a new directory. To uninstall Lyra, delete all
the files in the directory and delete the directory.

What Lyra Can Do
Lyra is like a musician's word processor. With it, you can enter music into the computer and then 
play it back. Since you are working with standard musical notation, it is easy to work with if you 
already know how to read music; it you don't, you will find that you will learn quickly!

Lyra is a playback sequencer. That is, it will play a sequence of notes but cannot record music 
from a MIDI keyboard. The best way to think of Lyra is as an eight voice choir. Each voice in the 
choir corresponds to a track in Lyra. Just as a voice can sing only one note at a time, each track 
is limited to one note at a time. Chords are possible, but you have to split the notes up between 
the tracks. This may seem limiting, but you will find that it makes entry and editing of music very 
simple.

Lyra has provision for controling how your music will sound. You can easily vary the tempo (the 
speed at which it is played), the volume, and the instruments sounds produced by each track. 
This means that you can play music that has a good deal of expression.

Getting Help
You can get on-line help at any time by simply selecting Help from the Help menu. If you press 
F1, the help you will get depends on where the cursor is. For example, positioning the cursor over
the numbered boxes at the upper right hand corner of the window and then pressing F1 will bring 
up the Track Selection Boxes help topic. In addition, the status bar at the bottom of the window 
usually will have a message that will tell you what type of action is possible.

Loading Music
A Lyra file may be loaded from disk by selecting the Open command from the File menu. Several 
music files are supplied with the program for your enjoyment. This version of Lyra uses a 
proprietary format; the ability to import standard MIDI files is planned for a future version.

Playing Music
To play music, you must have first configured Windows correctly so that it recognizes the music 
device you have installed in your computer. This may be an internal FM synthesizer card such as 
a Sound Blaster, or a MIDI interface card such as an MPU-401 which must be connected to a 
MIDI synthesizer. Please consult the Windows manual and the instructions that came with the 
card to do this correctly.

Once this has been done, Lyra will recognize the music device(s) in your computer. If you have 
more than one music device installed, then you will need to configure Lyra so that it knows which 
one you want to play music on. This is done with the Preferences command on the Edit menu.

When you select the Play command on the Play menu, a box will pop up. As the music is played, 



the current measure number is displayed in the Goto button. You may cancel playback at any 
time by selecting the Cancel button. Selecting the Goto button will result in repositioning the 
music display to the measure number displayed.

If your synthesizer does not play correctly, you may need to set up the track parameters or you 
may want to set the Filter on the Edit menu.

Editing Music
Notes may be easily placed on the music staff by selecting the desired note or rest length from 
the toolbox and clicking on the music staff. Just as easily, you can make changes to existing 
music. 

Entering Music

To enter new music into a score, you must first select a track by clicking on one of the numbered 
boxes at the right upper corner of the window until it is black. Next select a note or rest from the 
toolbox at the bottom of the window. Select any pitch or length modifiers you wish. Now position 
the cursor on the music staff at the correct pitch and click the left mouse button (or press Enter). A
new note or rest will appear on the staff. Add as many notes as you wish. Each track is limited to 
one note at a time, so if you wish to enter chords, you will have to split the notes between the 
tracks. 

A note may be inserted between two existing notes in the same track by clicking between them at
the right pitch. If you click directly over a note, then that note will take on the attributes selected in
the toolbox. 

If you click after the last note in a track, then the new note will be added immediately after the last
note, regardless of how far to the right you click. 

Please note that new notes cannot be entered unless you have first selected a track (one of the 
numbered boxes at the right hand corner of the window is black)!

Changing notes

A note's pitch may be changed by dragging it to a new pitch. This is done by putting the cursor 
over it, pressing the left mouse button and holding it down, moving the cursor up or down to the 
new pitch, and releasing the mouse button. The cursor will change shape while a note is being 
dragged. If no track has been selected, then you must position the cursor directly over the note 
before dragging; if a track has been selected, then the note that is black directly above or below 
the cursor can be dragged. You will find that dragging is easier when a track has been selected. If
you move the cursor too far to the left or right, the pitch change will be cancelled and the cursor 
will return to its normal shape.

You can change a note's length or change the accidental by selecting the desired length or pitch 
modifier in the toolbox at the bottom of the screen and then clicking the mouse while the cursor is 
positioned directly over the note in question.

A note may be deleted by positioning the cursor over the note and pressing the Delete key or 
SHIFT+D.

Inserting a note is done by selecting a track, and positioning the cursor between two notes and 
clicking the left mouse button or pressing the Enter key.



Track Selection Boxes
The track selection boxes on the top right normally are all gray with black numbers inside.

Clicking on a box makes the colors reverse for that box and the music display changes so that 
only the selected track is black, and all the rest are grey. This can be used to simplify the display 
when you have a dense score, and it can be used to assist you in editing music.

Clicking the right mouse button on a track box will bring up a dialog box which will let you 
configure a track. This allows you to set the MIDI channel, master volume, transpose, instrument, 
and pan.

You may also select a track box by pressing the control key with the number of the desired box. 
For example CTRL+3 will select the third track. Adding the shift key will bring up the track 
configure dialog box (such as SHIFT+CTRL+3).

The Musical Staff
The musical staff is the place where notes and rests are placed. Lyra makes use of the grand 
staff, which is made up of the treble clef and the base clef. As you move the cursor up and down 
over the grand staff, watch the help bar at the bottom of the window. It will tell you the pitch name 
(such as A, B, C, D, E, F, or G) and the octave number.

The Tool Box
The tool box in the middle at the bottom of the window, contains a number of tools that will help 
you in creating and editing music. A tool may be selected by clicking on it with the mouse. Certain
combinations of tools are not allowed; see below for more information about this.

The tools are organized into several groups. The top group consists of notes and rests. Select 
one by clicking on it. Only one note or rest can be selected at a time. Pressing keys 1 through 7 
will select a note, and SHIFT+1 through SHIFT+7 select the corresponding rest.

The tools on the bottom line consist of four groups. First are the pitch modifiers, or accidentals. 
These tools (sharp, natural, and flat) will modify the pitch of a note. Selecting an accidental tool 
that has already been selected will result in its being unselected. If a rest is selected, these tools 
are not selectable. Only one of these tools may be selected at a time. Pressing keys S, N or D, 
and F will select the sharp, natural, or flat tools.

The next group is the length modifiers (triplet, dot, and tie). These will modify the length of a 
note or rest. Pressing keys , (comma), . (period), T or / (slash) will select the triplet, dot, or tie 
tools. Selecting an accidental tool that has already been selected will result in its being 
unselected. You may select any combination except that when a rest has been selected, a tie 
may not also be selected.

A special tool, whose function is not yet completely defined, is the arrow tool in the middle of the 
bottom row. When it is selected, all other tools are disabled. This tool may also be selected and 
deselected by pressing the space bar key.

The last group of tools are used to enter special symbols into the score which change the volume,



tempo, and the like. All of them can have more than one value, so the Help Bar will tell you not 
only the name of the option but also the value that you selected. When you click on the music 
score, a special symbol will be entered. Instead of playing a note, this symbol will do something 
else like changing the volume, tempo, or the sound your synthesizer makes.

The first option tool is the Volume tool. When you click on it, a pop-up menu appears, listing all of
the available volume symbols. When you release the mouse button, the volume that was 
highlighted is selected and can be entered into the music. The Help Bar will display the message 
Ready to enter Volume pp (or whatever volume you selected) while the cursor is in the music 
score area. More information about volumes in Volume Settings.

The next tool is the Tempo tool. When you click on it, a dialog box appears, asking you to enter a
new tempo. This tempo is the number of quarter notes per minute. To remind you of what tempo 
you entered, the Help Bar will display the message Ready to enter Tempo 100 (or whatever 
tempo you entered).

Next is the Octave tool. Clicking on it will pop up a menu with two choices: 8va or loco. 8va is 
used to raise or lower a track by an octave. Placing the marker above the music staff will raise the
track an octave; placing it below the music staff will lower it an octave. loco is used to cancel the 
effect of the 8va and can be placed anywhere on the staff.

The Instrument tool is supposed to look like guitar. It will let you insert instrument changes in 
your music at any point. It is very important that the Instrument Dialog (brought up by clicking the 
right mouse button on the Instrument tool) be correctly set up so that the right program change 
number is associated with each instrument name. When you click on the tool, a pop-up menu will 
appear, listing all of the available instruments. When the cursor is on the music score, the Help 
Bar will tell you what instrument you selected.

The next two tools bring up a dialog box which lets you change the key and time signatures. 
This version allows only a single key and time signature; future versions will allow changes at any
point.

The last tool, the Controller tool, is like the Instrument tool. When you click on it, a menu will pop 
up listing the available controllers. You must fill in the Controllers Dialog (brought up by clicking 
the right mouse button on the Controller tool) to define a controller.

How to change instrument sounds
You can use the Track Setup dialog box (brought up by clicking the right mouse button on one of 
the track boxes at the right upper corner of the window) to set a different instrument sound for 
each track. You will notice that an instrument assignment can be made only if the track 
assignment is not the same as another track. In other words, each track that has its own 
instrument sound must also have its own unique channel number.

If you wish to change the instrument sound for a track while music is playing, you will need to use
the Instrument tool.

Playing multiple instrument sounds
Music in Lyra is organized into eight tracks, and each of these tracks can be set up so that it has 
its own instrument sound.



First of all, the music device must be capable of playing more than one sound at the same time. 
The Sound Blaster and most recent MIDI synthesizers have this capabiltiy.

Secondly, you must determine what the program change numbers are that correspond to the 
instrument sounds you want to hear. The synthesizer manufacturer's manual should give you this 
information. This number must be entered into the Instrument box on the track setup dialog box.

Last of all, make sure that each track that has its own instrument sound has a unique channel 
number (also set up in the track setup dialog box).

Entering Lyrics
Lyrics may be added to a song by the use of the Lyrics dialog box. This version allows lyrics only 
for track one, and they are displayed above the music. Simply position the music display so that it
is at bar 1 or the first note in track 1. Call up the Lyrics dialog box (select the Lyrics command 
from the Edit menu) and type in the lyrics. Be sure to put a space between all syllables that you 
want assigned to separate notes. If you want to skip a note (no word for it), just type in an extra 
space.

Editing lyrics requires only that the words be currently displayed. If no words are displayed, move 
back in the music until words appear. The lyric editor dialog box will contain only those words that
start with what is displayed. Make any changes you want, select the OK button, and you will see 
the display changed accordingly.

Printing Music
Select the Print command from the File menu. Lyra will begin printing from the point displayed on
the screen and stop at the end of music. 

The Purpose of the _default.lyr File
_default.lyr, which is present in the same directory as wlyra.exe, is a file that is automatically 
loaded into Lyra when the program starts up. _default.lyr is a standard Lyra file and can contain 
any of the things that a Lyra file normally has. Normally, though, you will not want it to contain any
notes. You can fill the instrument table, set up the volumes, the master tempo, and the like with 
the values you usually use.

If you don't want to use the features of _default.lyr, simply delete it.

The Menus
File Menu

New: This command is used to clear the music score. It does not change the time or key 
signature, master tempo, or clear the annotation, instrument controller tables, or lyrics.

Open: Load in an existing music score from disk using this command.



Save: Save the music score as a file on disk.

Make MIDI File: Saves the music score as a standard MIDI file. This can be imported into most 
other music or multimedia programs.

Print: Print music on the default printer. Before printing, set the  Note Display mode in the 
Preferences box to a mode other than compact.

Preferences: Modify certain parameters that change the way Lyra works. See the Preferences 
topic.

Annotation: Use this command to enter any information about the music you wish, such as a 
copyright notice or directions on how the music is to be played. It will be saved with the music.

Exit: Quit Lyra and return to Windows. If the music score currently in memory has been changed, 
Lyra will first ask if you want to lose the changes.

Edit Menu

Undo: Undo a change that has been made to the music score (such as a note insertion, deletion,
or pitch change).

Unmark: Remove the block markers that define a block of music. A block is marked by selecting 
the selector tool (it looks like a cross) and clicking on the first and last notes that you want to 
mark. The block of music will now turn red.

Copy: Copy a marked block of music and place it in a holding area. You can paste these notes 
into another point in music by positioning the cursor to the right spot and pressing Ctrl-V, Shift-Ins,
or clicking the right mouse button.

Cut: Copy a marked block of music, place it in a holding area, and delete the marked notes. You 
can paste the copied notes as described for the Copy command.

Lyrics: Enter and edit lyrics for track one; more information in the Lyrics Dialog Box topic.

Goto: Adjust the music score display so that the bar number you give is the first measure 
displayed.

Filter: Prevent Lyra from displaying and playing certain types of music information. See the Filter 
topic.

Tools Menu

The Tools menu duplicates the tool box at the bottom of the screen. It provides an alternate way 
of selecting the various tools as well as listing the keyboard shortcut keys for each tool.

See the tool box topic for more information on how the individual tools work.

Play Menu

Play - see the Play Music topic.

Tempo - set the speed at which music is played as the number of quarter notes per minute.

Transpose - specify how much music will be transposed when it is played back in terms of half 



steps. For example, entering -4 will make the music be played 4 half steps lower. When the 
transpose amount is not zero, then a check mark will appear on the menu to remind you when 
you play music.

Using the Keyboard
Almost every function of the mouse has been duplicated with the computer keyboard. Here is a 
list of the valid key press commands (other than those associated with the pulldown menus):

s - select the sharp tool
d - select the natural tool (alternate for n)
n - select the natural tool
f - select the flat tool
, - select the triplet tool
. - select the dot tool
/ - select the tie tool (alternate for t)
t - select the tie tool
enter  - enter a note or rest
up arrow - move the cursor up one step on the music score; if you press the SHIFT key as well, 

you can adjust the cursor more precisely.
down arrow  - move the cursor down one step on the music score; if you press the SHIFT key as

well, you can adjust the cursor more precisely.
page up - move the cursor up one octave on the music score
page down - move the cursor down one octave on the music score
home - move the cursor to the left hand side of the window
ctrl+left arrow or ctrl+right arrow - advance or back up one screen


