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WHAT FONTBOOK DOES FOR YOU
Fontbook is a tool for those who work with type, and need the ability to quickly and 
accurately assess the quality and style of the typefaces on their system.

PRINT OUT TYPEFACE SPECIMEN SHEETS:
Use Fontbook to automatically print out clean, uncluttered, professional looking 'specimen' 
or 'sample' sheets of the typefaces on your system, whether installed or not.

Fontbook prints out a variety of specimen sheets:
full character set
alphanumeric sets in a variety of points and styles
body text samples
combined headline and body text
alphanumeric sets at 7 typefaces per page
typegauges in any font

Fontbook will do this automatically for all fonts, or any that you choose.

Specimen sheets are an essential tool in any DTP environment. Keep these on hand for 
customers to view, or for operators to assess the quality and artistic merit of a typeface. 
With Fontbook, you can (optionally) customise the specimen sheets with your own 
messages, say your company name, address and phone number.

VIEW TYPEFACES ON SCREEN:
For any typeface, view the entire 255 character set on screen    in large, clear letters.

If several typefaces have been chosen, see their alphanumeric sets together on screen, (up 
to 100 typefaces in a scrollable window) highlighting the differences between similar 
typefaces, relative character widths etc.

WORK WITH BOTH INSTALLED AND UNINSTALLED TYPEFACES:
You can use Fontbook to view or print specimens of any typeface, whether it has been 
installed or not. Uninstalled TrueType, Stroke and Raster typefaces can be used, just locate 
the file containing the typeface on either your hard or floppy disks.

LOG YOUR PRINTOUTS AND FILTER FONT TYPES:
Fontbook allows the user to record typefaces for which specimen sheets have been printed, 
saving time on large systems to which faces are regularly added or removed. This 'log' or list
of typefaces can be printed out and used as an index for the specimen book created by 
Fontbook. Further, you can filter faces according to type, if for example you wish to work 
only with TrueTypes.

SHOWS FONTS RESIDENT FOR ANY TYPEFACE:
Fontbook maintains the distinction between typefaces and fonts. For typefaces with more 
than one font on disk (i.e. roman, bold, italic or bold italic files), Fontbook makes the styles 
available. Fonts which are synthesized from the Roman are not shown. 



ABOUT TYPEFACES AND FONTS

There is confusion over typographical terminology. Although the distinction has been blurred 
in recent times, the following definitions apply.

A TYPEFACE is a set of printable characters that share a similar fundamental design.

A FONT is a single instance of that typeface, having very specific characteristics such as 
size,
weight and slant.

A TYPEFACE FAMILY is a group of typefaces that have similar appearance, stroke width 
ratios, 
and serif characteristics. 

Thus a FONT is a subset of a TYPEFACE, and a TYPEFACE is a subset of a TYPEFACE FAMILY.
For example, '18 point Bodoni Bold Condensed italic' describes a font that is

in the TYPEFACE 'Bodoni Bold Condensed'

in the FAMILY      'Bodoni' 
of which there are several, including 'Bodoni Poster' and 'Bodoni'.

a font, because we have specified the size 18 point, and the style italic.

MS Windows implements typefaces as small, uniquely named files    actually dynamic link 
libraries.

In many cases, unique files exist for the roman, bold, italic and bold italic font variants of 
any typeface. However Windows' Graphic Device Interface has the ability to synthesize the 
size, weight and style attributes of a font from a single file for the typeface, usually the 
roman. Thus, if only one file for 'Bodoni Bold Condensed' exists, Windows is able to 
synthesize an italic variant 'on the fly', a process transparent to the user.

Although it is not always the case, most operators believe that far better results are 
achieved    if the only styles used for any typeface are the ones for which a file actually exists
(not those that are synthesized from the roman). 

If a file is not found for the requested font style, whether or not this synthesis happens 
depends upon the font type, the application and the output device. A further complication 
arises because in some cases a font may be synthesised for the screen, but not for the 
printer, leading to very disappointing results when a document is printed.

Fontbook maintains the distinction between fonts and typefaces, and shows the operator 
only the fonts for which a unique disk file exists. In its default mode, for example when it is 
first started, Fontbook shows type at the level of typefaces. To view or print individual font 
styles for chosen typefaces choose 'Show Styles for Family' from the 'Styles' menu. A 
small popup window will appear, showing the font files on disk for the typeface highlighted 
in the right hand listbox of the main window.



SELECTING TYPEFACES FOR VIEWING OR PRINTING:

The main window of Fontbook has 2 large listboxes. The listbox on the left lists all faces 
installed for MS Windows (that is, MS Windows recognises for use within MS Windowshosted 
applications). 
You can add uninstalled typefaces to this listbox by using the "Load Font File" option from 
the "FontOnDisk" menu, and using the resultant dialog box to find the file on disk that you 
are interested in examining.

The listbox on the right shows faces selected for viewing or printing.

Add typefaces to the listbox on the right by:
1) highlighting the typeface or typefaces, and clicking the 'ADD' button.
2) double clicking on any typeface name.
3) clicking the 'ADD ALL' button, thus adding all faces from the left listbox.

Remove faces from the listbox on the right by:
1) highlight the typeface in the right listbox and click the 'REMOVE' button.
2) all typefaces from the right listbox by clicking the 'REMOVE ALL' button.
3) the 'CLEAR' button removes all typefaces and clears all selections.



Working with Uninstalled Typefaces:
When Fontbook starts, it shows you all of the typefaces installed on your system and 
available to MS Windows hosted applications.
You may, however, have font files which you wish to examine, but do not wish to install. 
Fontbook allows you to add these to the list of available fonts (the listbox on the left of the 
main menu), and thus make them available for viewing or printing as specimen sheets.
At present this option works only with TrueType fonts, MS Windows stroke fonts, and raster 
fonts.
 
Steps:
Insert the disk containing the font file.

From the "FontsOnDisk" menu, choose "Load Font File", and use the resultant dialog box 
to navigate the directory structure and select the file. Click the OK button and the font will 
be accessable to Fontbook, and any other program running at the time. Fontbook adds the 
font to Window's internal font table, and in the case of truetypes creates the necessary .fot 
file.

To unload the font, choose "Unload Font File" from the "FontOnDisk" menu. The font will 
be unloaded from the internal font table and the .fot file will be deleted, but only if no other 
application has used the font during this session.

When Fontbook closes, it automatically unloads all uninstalled fonts that have been loaded.



FILTERING TYPEFACES:
In its default mode, Fontbook will show (in the left hand listbox of the main window) all 
typefaces registered by MS Windows, whether TrueTypes (TTF), other vector faces (VEC), 
bitmap or raster faces (RAS), or device faces (DEV). You can add uninstalled typefaces to this
listbox by using the "Load Font File" option from the "FontOnDisk" menu, and using the 
resultant dialog box to find the file on disk that you are interested in examining.

By choosing 'Filter Fonts' from the 'File' menu, and checking the required type in the 
dialog box that appears, you can selectively work with any combination of these types. The 
dialog box is shown below.

Additionally, this menu option allows the user to filter out faces recorded in the log as 
already printed as a specimen sheet.



PRINTING SPECIMEN SHEETS:
Fontbook can print out a variety of professional quality typeface and font specimen sheets. 

You have the opportunity to add 3 lines of centered text at the bottom of most printouts. 
Most users will wish to use this for their company name, address, phone number and a short 
message. This text is stored in win.ini, and thus need not be retyped each time. If you don't 
want to include this text on a specimen sheet, choose the cancel button from the 'Company 
Name and Details' dialog box, which appears after choosing a printout from the 'Print' 
menu.

Paper size and layout:
Fontbook's printouts are optimised for US Letter size paper (8.5 x 11 inch). If you wish to use
A4, full scap or legal sizes, adjust your printer driver's margins.
Some printouts have the option of printing in A5 size, 148mm x 210 mm.

Margins:
Fontbook has been designed with the HP Laser Jet's (postscript) default margins in mind. 
If your printouts don't look right, particularly if the text is a little down and to the left, you 
may need to adjust your printer driver's margins. Most printer drivers have a 'margins' 
dialog box, sometimes quite hard to find. You may never have noticed this option because it 
is automatically overridden by most applications, but it is used by Fontbook. Most postscript 
drivers set left and top margins of approximately 1/3 inch.

The printout 'Typegauge'    is on a wide and deep measure. When printed correctly, a finely 
graded scale in 2 point increments should be visible down the extreme right hand side. If 
necessary, set the printer driver's margins to zero before printing.

Print Handling:
If multiple fonts are selected for printing, Fontbook sends each one as a separate print job. 
This allow you to cancel certain prints, or interrrupt printing specimen sheets for other more 
important jobs.

Procedure:
Add typefaces or fonts to be printed to the listbox on the right. Fontbook will sequentially 
print a specimen page for each of the typefaces chosen. From the 'Print' menu, choose the 
specimen sheet as below:

Char Set Prints the ASCII character set, one typeface per page.

Sample Page Prints alphanumerics in 6 pt, 12pt, 18 pt Roman, Bold, Italic, 
Bold Italic,and 36 pt. One typeface per page.

Page of Text 13 pt headline plus several paragraphs of body text, in a point size 
chosen by user, one typeface per page.

Sample and Text Prints 18 pt Roman, Bold, Italic, Bold Italic plus several 
paragraphs of body text in n a point size chosen by user.

Multi Face Page If more than one typeface has been chosen for printout they will
be printed at seven typefaces per page (letter size), showing the alphanumeric sets, two 
lines per typeface. The A5 printout shows 4 faces per page.

Typegauge Print typegauges for measuring printed text, in any typeface you 



choose. Photocopy onto transparent film. There are two styles of type gauge, one results if 
you choose to add the three lines of user text, the other results if you choose not to (by 
using the Cancel button).

Fonts :
From the 'View' menu choose 'Show Styles for Family' to view individual font styles, (e.g. 
roman, bold, italic, bold italic) if these exist as distinct disk files. In the case of several 
printouts, the style highlighted in the resultant popup window will be printed.



VIEWING TYPEFACES ON SCREEN:

Any typeface that has been chosen for printing or viewing    that is, has been added to the 
listbox on the right of the main window    can be viewed on screen in a popup 'View' window.

Alternatively, if 'Show Font Styles' has been chosen from the 'Styles' menu, individual 
font styles (Roman, Bold, Italic, or Bold Italic) can be viewed, provided the corresponding file 
exists on disk.

Typefaces are shown with large, clear characters, usually sufficient to allow a designer to 
choose a typeface 'on the fly'.

FULL CHAR SET:
To view a full character set of a typeface or font, highlight it in the right hand listbox, and 
from the 'View' menu choose 'Full Char Set', or double click the face name. 

To view a font style associated with that typeface, choose 'Show Font Styles' from the 
'Style' menu, highlight the desired font style in the popup window, and double click or 
choose 'Full Char Set' from the 'View' menu.

MULTIPLE TYPEFACES:
To view the alphanumeric sets of up to 100 faces at once (in a scrollable window), move the 
chosen typefaces to the right hand listbox. Then, from the 'View' menu choose 'All Faces 
Together'. Note that if you choose a large number of typefaces for viewing in this way, it 
could take a slower computer some time to make up this window.

View windows can be iconized, maximized or scrolled.



USING THE LOG:

It is possible to filter out typefaces for which specimen sheets have already been printed, so 
that they do not appear in the listbox of available faces. This can be useful on a very large 
system, that is, one with several hundred typefaces. Fontbook can be instructed to keep a 
list of faces (a 'log') for which a specimen sheet of some sort has been printed. By default, 
this option is disabled, but can be enabled by choosing 'Enable Log' from the 'File' menu, 
and the log will stay enabled through subsequent sessions until 'Disable Log' is chosen 
from the 'File' menu. Once a log is in use, a text file called 'fontbook.log' is maintained in 
the current    directory. 

When logging is enabled, several menu commands are available from the 'Log' menu, which
allow the log to be edited, sorted, kept sorted, and cleared.

By default, when the log is enabled, typefaces listed in the log are not available to Fontbook,
however this can be temporarily reversed by selecting 'Filter Fonts' from the 'File' menu, 
and in the resultant dialog box deselecting the 'Exclude Faces Already in Log' checkbox.

The log file ('fontbook.log') can be edited, using a word processor or ascii editor such as 
notepad, and used as the basis for an index to a specimen book produced by Fontbook. 

Note that the log does not distinguish exactly which type of specimen sheet has been 
printed for any typeface. It merely records that a sheet of some kind has been produced for 
each typeface listed. You are advised to decide exactly which type of specimen sheet (or 
sheets) are to be logged before using the log, and activate logging only when that type of 
sheet is about to be printed.



POSSIBLE PROBLEMS:

MY COMPUTER CRASHES:
Fontbook has been thoroughly tested, crashes are more likely to be occuring because of a 
bad font file. Bad font files are one of the most common causes of system crashes, so use 
Fontbook or Charmap to track down the bad file and remove it.

THE PRINTOUT IS NOT CENTERED ON THE PAGE:
Most printer drivers come with a preset left and top margin, and a dialog box (often rather 
well hidden) to change this setting. Because this default margin is automatically overridden 
by most applications, you have probably never needed to know it was there. Fontbook, 
however, does not override the driver's margin setting, and expects to use a very small left 
and top margin, as is the default in the HP Laser Jet Postscript driver. If necessary, adjust 
your printer driver's margin. These can also be increased to allow a left hand binding 
margin.

Fontbook is designed to print on US Letter size paper. To give satisfactory results on other 
paper sizes, adjust the printer driver's margins.

Note that the printout 'Typegauge' is on a wide and deep measure, may need margins set 
to zero. When printed correctly a finely graded ruler appears on the extreme right of the 
page. 

PRINTING IS TOO SLOW:
If you are using postscript, try turning postscript off. Printing will be faster but the 
appearance of the printed text will probably not change.

PRINTING IS UNRELIABLE, OR NOT WORKING:
Fontbook has been tested with a variety of laser, dot matrix and bubble jet printers. Most 
problems discovered during testing related to inadequate computer memory. 
If a problem exists that cannot be traced to other causes, try disabling the print manager, 
and/or printing specimen sheets one at a time.

NOT ALL MY FONTS ARE BEING SHOWN:
Check to see if logging is enabled, if so, disable it, by choosing 'Disable Logging' from the 
'File' menu, or temporarily override by choosing 'Filter Fonts' from the 'File' menu, and in 
the resultant dialog box deselecting the 'Exclude Faces Already in Log' checkbox.

Fontbook will not show .wfn fonts in Coreldraw. Fontbook will show uninstalled fonts but the 
user must select these individually.

I GET A 'text file not found' MESSAGE WHEN PRINTING 'PAGE OF TEXT' OR 'SAMPLE
AND TEXT':
When the user chooses to print either of these two specimen pages, Fontbook searches for a
small ascii file of sample text called 'text.dat', in the same directory as Fontbook. If not 
found, and error message is presented as above. Either copy the file from disk, or substitute 
any other text file renamed to 'text.dat'. The text file should be under 4096 bytes in length 
and the only line breaks should be between paragraphs (i.e., very long lines).



Payment and Registration
Fontbook is shareware. This means that you can try Fontbook for a short period, but if you 
like it and decide to use it on an ongoing basis, you should pay for it.

Payment is:
$10 for home use
$20 for business use.

As of Version 3 (this version), users who pay the $20 will recieve free upgrades, so don't 
forget to include a postal address, and make note of the fact that you are registering version
3.

Please send payment to 
Arron Davies
P.O.Box 82
West Ryde NSW 2114
Australia

Also, please let me know of any features you found particularly useful, or would like to see in
future versions.

Thanks
Arron.


