
Part IV
Tools & Options

In the third part, you learned how to create and edit complex templates including how to change
tablet properties, create regions, apply styles, work with combinations, import and export files and
print your templates.

In the next three chapters, you'll learn the tools and options for building templates and configuring
the Editor for optimum use:

n How to compile templates, trace regions and execute templates.

n How to alter the Editor's display, use tablet guides, create file backups, add comments to your
templates, change the template font and configure a custom menu.

n How to cut, copy, paste, view and undo actions using the Windows clipboard.
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Chapter 11
Using Tools

Compiling
The Editor includes an integrated compiler which translates the graphical specifications of your template into a Virtual
Tablet Interface command file executable by the Virtual Tablet Interface utilities and drivers. A key advantage of the
Virtual  Tablet  Interface is  that  these files,  once created, will run on any supported digitizer or host system without
modification or recompiling.

The process of converting your template into a command file begins when you choose Compile command from the Tools
menu. The compiler uses two passes in which the first is used for error checking and the second pass for creating the
command file. This allows you to review any errors encountered during the first pass and correct them prior to creating
the command file.

When you choose the Compile command or press the F11 key, you are asked to save any changes to the template file.
This ensures your more recent changes are saved in the event of a mishap and that the template file on disk matches the
command file should you need to reference them later. If you have not saved your template, the Compile command will
be disabled.

Compiler Errors

During the first pass, the template is scanned for logic errors which, if found, are reported in the Compile dialog box.
Otherwise, a message box will inform you the command file has been created.

At this point, you may cancel compiling or ignore the errors. If you continue compiling, a command file will be built on
disk containing the information and instructions necessary to direct the drivers and utilities on how to execute your
template. Template command files use the extension .VTT.

In general, compiler errors reported in the Compile dialog box should not be ignored. For example, if you do not specify
a pointer region, your system pointer will not work properly under Windows or DOS. Also, multiple pointer regions are
ignored after the first one is encountered and may not achieve the results you intend. Finally, if there are one or more
overlapping regions, their behavior will be unpredictable in the areas of overlap.

To locate specific regions containing errors, check the check box labeled "Debug Info" from the Display or Print dialogs.
Then, each time the Editor's window is redrawn or the template printed, regions in which an error occurred will be
marked with an "X" intersecting their four bounding corners. To remove these marks, fix the errors and recompile or
uncheck this option in the respective dialog box.

Tracing Regions
The Editor's Trace command in the Tools menu allows you to create regions by drawing or tracing them directly from a
digitizer.  In order to enter trace mode, you must have a digitizer attached to your system and the Windows library
VTABLET.DLL installed in your system directory. You do not need to specify the Windows driver as the mouse pointer
but any active templates executing under the Virtual Tablet Loader are temporary disabled.

When choosing the Trace command, the cursor changes to the Trace tool shown here. Regions created in trace mode 
inherit default attributes - their styles and template functions can be edited after you are finished tracing.
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When you are finished tracing, press the ESCAPE key. If you are in the middle of tracing a region, it will be discarded.
The Editor's Undo capabilities are fully supported should you change you mind and wish to delete the regions created
while tracing. Trace mode is automatically ended when you switch to another window or choose another command.

Note: While you are tracing,  the Windows pointer  will  be  disabled if  the Windows library VTABLET.DLL was
specified as the Windows mouse driver. If disabled, it will be restored to its previous state after you are done tracing.

Executing Templates
The Virtual Tablet Loader is used to create Virtual Tablet Information (.VTI) files which can automatically load your
Windows applications and their templates. To access the Loader from within the Editor, choose Execute from the Tools
menu or press the F12 key.

You can also start the Loader by clicking its icon in the Virtual Tablet group or on a Virtual Tablet Information file icon
created when you save a file. The Loader is displayed on the Windows desktop as shown below:

Selecting an Application

Normally, you will associate a Windows application with a template command file. To do this, click the Select button in
the Application section or choose Select from the Application menu. The cursor will change to a bomb-sight just like the
Build tool used with the Build command.

Position the cursor over the application's window or icon and press the left mouse button. The bomb-sight will disappear 
and the cursor change back to a normal pointer. If you miss the application's window, click the Select button again to 
select the right window. You may continue selecting target windows until you are satisfied the right window has been 
selected.

After you select the application's window, the Loader will update the application's name and window class in the fields
labeled Name and Class. You may clear the selected window and designate the Windows desktop by clicking the Clear
button or choosing Clear from the Application menu.

Menus

To view the menu structure of the target application, click the Menus button or choose Menus from the Application
menu. The About Windows dialog box is displayed and allows you to scroll through the windows menu structure and
accelerator keys.
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To dismiss the About Window dialog box, click the OK button or press ENTER.

Application Options

You'll notice several options in the Application section become enabled after you selected an application's window. These
include fields for controlling how the template interacts with the application under certain conditions.

Disable if Inactive This option disables the template temporarily while the target  application is inactive.  The
pointer will continue to operate normally, but template regions will not send keystrokes to the application. This option
should generally be checked unless the application can be activated by command.

Disable if No Focus This option disables the template temporarily while the target application does not have the
input  focus.  The  pointer  will  continue  to  operate  normally,  but  template  regions  will  not  send  keystrokes  to  the
application. This option should generally be checked unless the application can safely process commands without having
the keyboard focus.

Disable if Iconic This option disables the template temporarily while the target application is in an iconic state.
The pointer will continue to operate normally, but template regions will not send keystrokes to the application. This
option should always be checked unless the application can be activated and maximized by command.

Preload on Call This option instructs the Loader to load and execute the application from a Virtual Tablet
Information file specified on the command line or by double-clicking its icon. The Loader will execute the application if
not already open on the desktop and execute its associated template. The Loader will then minimize itself to an icon
before setting the input focus to the application.

Keystroke Rate The rate at which template keys are sent to the target application may be changed by entering
a new value in the Keystrokes Per Second field. The value can range from between 1 and 10 and defaults to 5 per
second. Higher rates provide faster application response time while slower rates are useful for demonstrations.

Choosing Command Files

After selecting a target window, you must specify a template command file to use with the application. This is done
through the Template section of the Loader's dialog window and is nothing more than the familiar Open dialog box
found in many Windows applications.

To choose a template command file, click on the filename in the list box under the words "Files In". The File Name edit 
box should change to reflect selected filename. If not, use the list box to change the drive or path until the file name can 
be selected. Then, click the Open button or select the Open File command from the Template menu by pulling it down or
pressing the ALT+T,P keys. If there are no file errors, the Open button should become disabled, and the Close and Info 
buttons enabled.
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If you make a mistake selecting the command file, click the Close button or choose Close from the Template menu. You
can then select another command file as described above.

File Information

Command files often contain comments by the template's creator with instructions for use or any special restrictions. To
view these comments, click the Info button or choose Info from the Template menu. The About Template dialog box is
displayed showing the file format, version number, creator's name and company, and comments, if any.

Saving the Configuration

To save the target window configuration and its template in a Virtual Tablet Information file, choose Save from the File
menu or press the CTRL+S keys. Since this is a new file, you will be presented with the Save As dialog box.

Enter the file name and click the Save button or press ENTER. The file will be saved on disk and can be used to load both
the application and its template file automatically each time you start Windows. If you change your mind, click the
Cancel button or press the ESCAPE key. Virtual Tablet Information files use the extension .VTI.

Create Icon You may also have the Virtual Tablet Loader create a Program Manager icon in the Virtual Tablet
group by checking the "Create Icon" option. Then, each time you wish to start both a template and its application,
double-click on the icon in the Virtual Tablet program group.
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Accepting the Setup

To tell the Virtual Tablet Loader to accept your changes and put them into action, click the OK button or press ENTER.
The Loader will minimize itself down to an icon and the template will become activated. To cancel your changes, click
the Cancel button or the size arrow to minimize the Loader to an icon.

Opening Existing Setups

To can open and edit saved configurations by choosing Open from the File menu or pressing the  ALT+F,O keys. This
displays the now familiar Open dialog box.

At the top of the dialog box are the words "File Name" followed by a field which allows you to type in the full path
name of the file,  or a DOS file specification including the wild cards '*' and '?'.  If you are not familiar with DOS
conventions for specifying disk, directory and filenames, consult your DOS manual or Windows User's Guide.

Another way to locate the file is to change the current drive and directory by double-clicking on the selections in the
directories list box. As you change the drive or directory, the new path is displayed in the field under "Directories:".
Once you have found the file, either double-click on its name, or single-click to place it in the File Name field and then
click the Open button or press ENTER. Virtual Tablet Information files use the extension .VTI.

You may cancel opening a file at any time by clicking the Cancel button or pressing the ESCAPE key. Canceling the Open
dialog box leaves your setup unchanged.

Exiting the Loader

To exit the Loader, choose Exit from the File menu or press the  ALT+F4 keys. Any open templates and Virtual Tablet
Information files you are working with will be closed and the mouse pointer returned to system use if originally specified
as VTABLET.DLL. If there are any changes to the current setup, you will be prompted to save them first.

Note: For information on executing Editor templates under DOS, see the Appendix titled "DOS Loader."
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Chapter 12
Changing Options

Display
The Editor's may be configured to hide imported graphics files, unsupported fonts and scroll bars. To change the Editor's
display, choose Display from the Options menu or press the F8 key. The Display dialog will be displayed.

Draft Quality Draft Quality inhibits graphics-intensive drawing operations including the display of imported graphics
files, color fills and shadow outlines, and can significantly increase the screen drawing speed. It is useful if you are
editing a large, complex template and do not need to see an exact representation of the template.

Debug Info This option enables you to display regions containing compiler errors with an "X" intersecting their
four bounding corners. To remove these marks, fix the errors and recompile or uncheck this option.

Scroll Bars Scroll bars allow you to pan the template left and right (horizontal scroll bar) or up and down (vertical
scroll bar). If you are working in one area of the screen for a period of time, you may find it useful to hide one or more
scroll bars to increase the size of the client area.

Status Bar The Status Bar appears below the Editor's window and provides short help on menu commands, the X
and Y location of cursor in the active area, the current zoom level, object (tablet, combination or region) selected, and
whether draft quality, compiler error display and metric measurements are in effect.

Tool Bar The Tool  Bar  appears  below the  Editor's  menu bar  and provides  quick  access  to  commonly used
commands. These commands from left to right on the toolbar are as follows: New, Open, Save, Cut. Copy, Paste, Undo,
Zoom In,  Zoom Out,  Zoom Template,  Zoom Special,  Properties,  Styles,  Combine,  Break  Apart,  Display,  Guides,
Backups, Compile, Build, Trace, Execute and Help.

After changing any options, click the OK button or press ENTER. To cancel changing the display options, click the Cancel
button or press the ESCAPE key. If you would like to make the display options the default each time you start the Editor,
click the Default button.

Guides
Tablet guides provide a convenient way to locate and place objects within the active area. They consist of a tablet grid
which may be displayed and to which object coordinates may be snapped. To configure the guides, choose Guides from
the Options menu or press the F9 key. The Guides dialog box is displayed.

After changing any options, click the OK button or press ENTER. To cancel changing the display options, click the Cancel
button or press the ESCAPE key. If you would like to make the guide options the default each time you start the Editor,
click the Default button.

Tools & Options   52



Grid Size To change the tablet grid, enter either a new grid size, select whether the grid is displayed on the active
area and whether the cursor is snapped to grid intersections. The grid size must be greater than the minimum region size
and less than half the minimum axis of the active area.

Show Grid If you select the Show Grid option, the grid will be displayed starting at the lower-left corner of the
active area extending right and up by the grid unit of measurement.

Snap Grid If you select the Snap Grid option, each time you begin a cursor selection, the cursor will be snapped
to the nearest grid intersection whether the grid is visible or not.

Backups
File backups can help protect your template from accidental loss of data. You should use backups to prevent over-writing
older file  versions and loss of your work in the event  your system crashes.  To change the backup options,  choose
Backups from the Options menu or press the F10 key. The Backups dialog box will be displayed.

After changing any backup options, click the OK button or press ENTER. You may cancel changing the backup options by
clicking the Cancel button or pressing the ESCAPE key. If you would like to make the backup options the default each
time you start the Editor, click the Default button. The backup options will be saved in program memory and the Editor's
configuration file.

Auto Saving Files

The auto save interval allows you to set a timer which prompts you to save your template file at specified intervals up to
60 minutes. The default value is 10 minutes. At the conclusion of each interval, you will be prompted to save the file
provided it has changed since the last interval. To disable the auto save feature, enter a time interval of zero.

Create Backups

Create Backup allows you to specify whether a backup of the file is created each time it is saved and is useful protection
against accidental writes to your file. Each time you save your template, the original disk version is renamed to the file
name plus the extension .BAK prior to saving the changes.

If  you  accidentally  save,  and  therefore  over-write,  a  valuable  template  file  which  you  did  not  wish  to  change,
immediately  exit  the  Editor  and  copy  the  file  name  plus  the  extension  .BAK to  the  original  file  name  using  the
extension .VTE. Generally, it is a good idea to keep at least one backup copy of your template on the disk at all times.

Comments
Comments are a convenient way to add text to your template and command files such as copyright notices and version
information. To add or edit comments in your command files, choose Comments from the Options menu or press the
ALT+P,C keys. The Comments dialog box is displayed.

This dialog box consists of a multi-line edit control and vertical scroll bar which you may use view text which extends
beyond the borders of the control. The total comment size is limited to 1024 characters including carriage returns and
linefeeds. For information on using edit controls, refer to the Window's User Guide.
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When you have completed editing your comments, click the OK button to accept the changes. Otherwise, click the
Cancel  button or  press  the  ESCAPE key to exit  the dialog without  changing the comment text.  You may also view
comments from compiled templates using the Virtual Tablet Loader's Info command.

Font Name
By default, style labels are displayed and printed using a proportional font. To change the font for the entire template,
choose Font Name from the Options menu or press the ALT+P,F keys. The Font Name dialog box is displayed.

This dialog box consists of a list box containing the names of the fonts installed on your system and an area where
"Sample" text is displayed for the selected font name. Each time you change the font name, the "Sample" text is redrawn
in the selected font allowing you to preview the font style.

After changing the font name, click the OK button or press  ENTER.  You may cancel changing the template font by
clicking the Cancel button or pressing the ESCAPE key. If you would like to make the font name the default for every
template (new or existing), click the Default button. The font name will be saved in program memory and the Editor's
configuration file.

Custom Menu
The Custom Menu is a convenient way to speed up access to commonly-used menu commands. The custom menu is
activated by pressing the right mouse button anywhere within the Editor's window. To create or edit your custom menu,
choose Custom Menu from the Options menu or press the ALT+P,M keys. The Custom Menu dialog box is displayed.

The Custom Menu dialog box is divided into two lists labeled Commands and Menu. On the left are the available Editor
commands and on the right are the commands currently selected into the custom menu. The buttons labeled Append and
Remove add or remove Editor commands to and from the custom menu, respectively.

To add commands to the menu, select the command from the list on the left. Then, click the Append button to add the
command to the menu. You may also add a command directly without using the Append button by double-clicking on the
command in the Command list.

To remove commands from the menu, select the command from the list on the right. Then, click the Remove button to
remove the command. You may also remove a command directly without using the Remove button by double-clicking
on the command in the Menu list.

When the custom menu contains the commands you wish, click the OK button or press ENTER. Your menu will now be
available to you each time you press the right mouse button anywhere within the Editor's window. If you change you
mind, you may cancel your changes by clicking the Cancel button or pressing the ESCAPE key. Finally, you can make the
current custom menu the default each time you start the Editor by clicking the Default button.
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Chapter 13
The Clipboard

The Windows clipboard is a temporary storage location that is always available when you want to transfer information
between  templates.  You  can  cut  or  copy  information  from  one  template  to  the  clipboard  and  then  transfer  that
information from the clipboard into another template.

The Editor uses a proprietary clipboard format which means clipboard information can only be used with the Editor itself
and cannot be pasted into other applications. If  you need to do this, use the Export command and then import  the
graphics file into the application.

Undo
The Undo command allows you to return your template to the state it  was in prior  to the last  command or action
performed. You can use Undo anytime you accidentally do something that you wish you hadn't. The following operations
can be used with the Undo command:

n All mouse commands including sizing, scaling and stretching a selection.

n Pasting and cutting with the clipboard.

n Clearing or deleting a selection.

n Formatting properties or styles.

n Combining or breaking regions.

n Alignment of regions and combinations.

n Importing all file types.

n Duplication of regions and combinations.

n Tracing regions.

n Changing comments.

n Changing fonts.

Cutting
To remove a selection of regions and combos from the template and place them on the Windows clipboard, choose Cut
from  the  Edit  menu  or  press  the  SHIFT+DELETE keys.  This  provides  a  convenient  way  of  moving  regions  and
combinations from one template to another.

Copying
To copy a selection of regions and combos from the template and to the Windows clipboard, choose Copy from the Edit
menu or press the CTRL+INSERT keys. This provides a convenient way of copying regions and combinations from one
template to another.
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Pasting
To paste a previously copied or cut selection of regions and combinations into the current template, choose Paste from
the Edit menu or press the SHIFT+INSERT keys. The Paste dialog box is displayed.

By default, the Paste command ignores the current selection of regions and combinations on the template and sets the
selection after the paste to the new ones. However, if you wish to replace the current selection with the contexts of the
clipboard, select the Replace Selection option.

Select the method by which differing active areas between the clipboard and template are resolved. For most operations,
Scale to Active Area should be used in order to guarantee the clipboard contents are fully pasted. However, if you choose
Clip to Active Area and one or more regions or combinations extend beyond the active area, they will be clipped to the
active area.

After choosing the method of pasting and whether to replace the current selection, click the Paste button or press ENTER.
To cancel pasting, click the Cancel button or press the ESCAPE key.

Viewing
To view the contents of the clipboard, choose Clipboard from the Edit menu. The CLIPBRD.EXE utility will be executed
which allows you view and save the contents of the clipboard. Note that the clipboard utility will not display imported
files. For more information on using this utility, refer to the Windows User Guide.
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