
Part III
Creating Templates

In the second part, you learned how to how to start and navigate the Virtual Tablet Editor, and create
templates for your favorite Windows applications in under one minute. In the next five chapters,
you'll learn how to create and edit more complex templates:

n How to change the digitizing tablet and system of measurement.

n Drawing, selecting, stretching and moving, aligning, duplicating and removing regions.

n How to use styles and work with region combinations.

n Importing and exporting graphics files and how to use Editor Export files.

n Printing templates including output formats and options, and printing tips.
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Chapter 6
Tablet Properties

If you installed the Virtual Tablet Interface correctly using the SETUP.EXE utility, then the active area depicted in the
Editor's  program window should reflect  the size of  your digitizer.  This chapter  describes  how to change the tablet
properties which is useful under the following circumstances:

n The tablet does not match the digitizer attached to your system.

n You need to change the tablet in order to produce a template for another system.

n The default tablet does not match your digitizer.

n You are editing a template created originally for another tablet.

Tablet Types
To change the tablet properties, choose Properties from the Format menu with no combinations or regions selected. The
Tablet Properties dialog box will be displayed.

This dialog box displays the current tablet in the list box labeled "Tablet Type" and its active area in the box labeled
"Size." If the Use Metric System check box is checked, then references to inches are in centimeters.

To change the tablet type, select the new type from the list box using either the mouse or keyboard. If you do not find a
type matching your digitizer, select the type which is nearest in both size and command format. Each time you change
the tablet, the size of the active area is displayed in the field titled Size. Check to make sure it matches your digitizer.
Pressure-sensitive tablets are marked with an asterisk (*).

When you have completed changing the tablet type, click the OK button or press ENTER. All regions, combinations and
other objects in the template will be resized based on the new active area. The template will be redrawn zoomed to fit
within the client area. You may cancel changing the tablet at any time by clicking the Cancel button or pressing the
ESCAPE key.

Each  time you begin  a  new template,  the  default  tablet  properties  are  loaded  from the  Editor's  configuration  file.
Normally, you will not need to change the default tablet. However, if you wish to set a new tablet as the default, click the
Default button.
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If the tablet type does not match the digitizer attached to your system ...

Change the tablet type from the list box to either your tablet or one that approximates it and click the OK button. You
may also make the new type the default each time you create a new template by clicking on the Default button.

If you need to change the tablet type in order to produce a template for another system ...

Change the tablet type from the list box to the tablet attached to the other system or one that approximates it and click the
OK button. Then, save the file under a different file name using the Save As command from the File menu. Do not click
the Default button unless you wish to make the new tablet type the default each time you create a new template.

If the default tablet type does not match your digitizer ...

Change the tablet to either your digitizer or one that approximates it and click the Default button. Then, each time you
start a new template, the correct tablet will be used. If you click the OK button, the tablet for the current template will be
changed as well.

If you are editing a template created originally for another tablet type ...

Change the tablet type from the list box to the tablet attached to your system, or one that approximates it, and click the
OK button. Then, save the file under a different file name using the Save As command from the File menu.

Metric System
Users who prefer using the metric system of measurement may specify that tablet locations are entered and displayed as
centimeters instead of inches. To enable the metric system, click the Use Metric System check box. The metric system
option may also be set as the application default by clicking the Default button.
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Chapter 7
Creating Regions

Regions are created in the active area by specifying their bounding rectangle. Once created, regions may be configured
as either the pen or pointer, or a template function to simulate typed-keystrokes and other command actions.

Creating large numbers of regions by hand can be tedious. The Editor is designed to automate the process and make it an
enjoyable experience. Even so, if you are creating templates for your Windows applications, you will find it easier to use
the Build command to start them and then edit them later applying styles, importing graphics files, etc.

Drawing Regions
To create a region, move the mouse pointer within the active area until the cursor shape is a cross-hair and press the left
button. Then, holding down the left button, drag the cursor across the active area.

A marquee rectangle will be drawn displaying the region's bounds. When this rectangle is the correct size, release the left
mouse button. Make sure you do not cover any other regions or your action will be construed as a selection. Don't worry
if the region size is not exact, it can be easily changed later.

Upon releasing the left mouse button, the Region Properties dialog box is displayed showing the region's bounds. This
dialog box allows you to edit the bounds before creation (or after by selecting the region and choosing the Properties
command from the Format menu).

Region Properties
To enter or change a region's properties, choose Properties from the Format menu after drawing or selecting a region.
The Region Properties dialog box will be displayed.

Region bounds are those specified when you drew or last edited the region and are in inches or centimeters relative to the
lower-left corner of the active area. If you change them, make sure they are within the active area and do not overlap, i.e.
right is less than left or bottom greater than top.
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Note: The minimum region size is 0.10 inches or 0.25 centimeters. Regions should not overlap or the compiler will
issue a warning.

Region Types

All regions, once created, must be assigned a specific template function. This not only informs the compiler how to treat
the region during the template building process, but allows it to check for errors and inconsistencies. The Virtual Tablet
Interface currently supports two region types: Pen or Pointer and Keystroke. Each of these types, and when they are
appropriate to use, are as follows:

Pen or Pointer Pen or Pointer regions are used for translating coordinate and button information into cursor movement
on the display screen. One Pen or Pointer region must be defined per template.

Keystroke Keystroke regions define a sequence of characters which are input to the host processor each time a
button is pressed. Keystrokes are entered and stored as Virtual Tablet Keystrokes described below and
listed in Appendix A.

Virtual Keystrokes

The Virtual Tablet Interface uses a host-independent keyboard encoding scheme which is designed to be compatible
across  multiple computing environments.  This  keyboard  encoding  scheme is  based on the  ASCII character  set  with
extensions for command, cursor, control and function keys.

Since many virtual keystrokes do not display or print directly from within Windows, or may be mistaken as editing
commands, they must entered as plain text sequences which are later converted to binary values at the time the template
is compiled. Each plain text  sequence must be preceded by the backslash character ('\')  and are defined as follows
(sequences are case sensitive):

\S SHIFT key modifier. The next character is shifted before the shift key state is cleared. May not be combined with
the control or alternate key.

\C CTRL key modifier. The next character is interpreted as a control key before the control key state is cleared. May
not be combined with the shift or alternate key.

\A ALT or command key modifier. The next character is interpreted as a command key before the alternate key state
is cleared. May not be combined with the shift or control key.

\Fnn Function keys 1 through 12 where nn represents a two decimal place, base ten key number. May be combined
with either the shift, control or alternate key modifiers.

\b BACKSPACE key. May be combined with the alternate key modifier.
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\t TAB key. May be combined with the shift key modifier.

\r ENTER key. May be combined with the control key modifier.

\e ESCAPE key. May be combined with either the shift, control or alternate key modifiers.

\n LINEFEED character. May not be combined with any modifier keys and produces a CTRL+ENTER key code when
compiled.

\nnn Virtual Tablet Key Code where nnn is a three decimal place, base ten number between 0 and 254 representing
the key code value.

\i INSERT key. May be combined with either the shift or control key modifiers.

\d DELETE key. May be combined with either the shift or control key modifiers.

\H HOME key. May be combined with either the shift or control key modifiers.

\E END key. May be combined with either the shift or control key modifiers.

\U UP ARROW key. May be combined with either the shift or control key modifiers.

\D DOWN ARROW key. May be combined with either the shift or control key modifiers.

\L LEFT ARROW key. May be combined with either the shift or control key modifiers.

\R RIGHT ARROW key. May be combined with either the shift or control key modifiers.

\P PAGE UP key. May be combined with either the shift or control key modifiers.

\p PAGE DOWN key. May be combined with either the shift or control key modifiers.

\f Form feed character. May not be combined with any modifier keys.

\v Vertical TAB character. May not be combined with any modifier keys.

\a Bell or alert character. May not be combined with any modifier keys.

\\ Backslash character. May be combined with the control key modifier.

Note: The Virtual Tablet Interface does not support the ALT-SPACE key combination. If you wish to access the system
menu from within Windows, use the F10 key instead.

Keystroke Examples

The following examples demonstrate several template keystrokes in which the entered text appears on the left and the
executed  characters  on  the  right.  If  you  enter  invalid  keystrokes,  an  error  message  appears  and  you will  have  an
opportunity to correct them before dismissing the dialog box.

As Entered As Executed
Hello, World!\r\n Hello, World! RETURN LINEFEED
\S\F10 SHIFT+F10
\C\P CTRL+PAGE UP
\A\b ALT+BACKSPACE
\135 ALT+Q

Accepting the Region
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After reviewing the Region Properties dialog box and making any changes, you may accept the region by clicking the
OK button or pressing  ENTER. If you change your mind, click the Cancel button or press the  ESCAPE key to cancel
creating the region.

If you accept the region, it will be displayed at its location in the active area using the default region style. Region styles
are discussed in the chapter titled Styles and Combinations. It also becomes the current selection and can edited again by
choosing Properties from the Format menu.

If you change your mind after creating the region, choose Undo command from the Edit menu or press the DELETE key to
remove the region. Removing regions are discussed later in this chapter.

Selecting Regions
Once you have created one or more regions, they must be selected in order to execute many of the Editor commands. To
select one or more regions, position the cross-hair cursor anywhere in the active area outside the regions and press the
left mouse button. Holding down the left button, drag the cursor across the active area.

A marquee rectangle will be drawn displaying the selection bounds. When this rectangle encompasses or intersects the
regions you wish to select, release the left mouse button. Regions within the selection marquee will be selected and
drawn with selection handles. Each time you begin a new selection, the previous selection is deselected first.

Extending the Selection

You may extend the current selection by using the SHIFT or CTRL key in conjunction with the mouse. Using the SHIFT key
is also called a Shift Selection and establishes the selection rectangle from the upper-left corner of the current selection
to the cursor location when the left mouse button is pressed. Regions within this new selection rectangle will be selected
and those outside deselected.

You may also use the CTRL key for multiple range selections including non-contiguous regions. To extend a selection to a
multiple range, hold down the CTRL key while making a new selection. The old selection will be preserved and the new
one added to it  (and the selection handles redrawn for the whole selection). If a region in the  CTRL-selection is not
already selected, it will be added to the previous selection. Otherwise, it will be removed from the selection. In this way,
a CTRL-selection toggles the state of any given region from selected to deselected, and visa-versa.

Stretching and Moving Regions
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Regions may stretched or moved within the active area using the selection handles. Each time the selection changes,
these handles are drawn at each corner and side of an imaginary rectangle that fully encompasses the selected regions. 

Note: This imaginary rectangle may also encompass regions that not are not selected but simply lie within the selected
area and can occur when doing multiple range selections using the CTRL key.

Each handle of the selection rectangle may be used to alter the shape of the current selection. By dragging the handle,
each region in the selection will be scaled to fit the new selection rectangle (providing the resulting size does not violate
the minimum region size).

To assist  you in  using selection handles,  the cursor  changes to  a  different  shape  each  time it  is  positioned over  a
particular handle. These cursor shapes are as follows:

Inside vertical drag handles of selection. Used for stretching selection vertically.

Inside horizontal drag handles of selection. Used for stretching selection horizontally.

Inside corner drag handles of selection. Used for stretching selection diagonally.

Inside of selection. Used for dragging selection in the active area.

To stretch or drag the current selection, position the cursor within the selection or handle until the cursor changes to the
desired shape. Then, press the left mouse button and drag the marquee rectangle to the new size or location and release
the left button. The regions are automatically scaled or moved and redrawn at their new size or positions.

Aligning Regions
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Aligning regions is useful for improving the aesthetic qualities and ease-of use of your template. There are three menu
commands for aligning regions, the choice of which depends on the type of alignment you wish. The commands and
their alignment properties are as follows:

Properties Sets one or more region bounds and leaves the others unchanged.

Grid Align Rounds each region bound to the nearest tablet grid point.

Align Moves regions leaving their size unchanged.

Regardless of alignment method, ensure that the resulting regions do not overlap or exceed the minimum region size. If
they do, the individual command will not detect these occurrences although you will get a warning when you try to
compile the template.

Properties

To align regions by property, select the region(s) and choose the Properties from the Format menu. The Format Region
dialog box will appear with the Left, Top, Right and Bottom fields blank (if multiple regions are selected). Fill in the
region bound(s) you wish to apply to the selected regions and click the OK button or press ENTER. You may change your
mind at any time and dismiss the dialog box by clicking the Cancel button or pressing the ESCAPE key.

Grid Align

You may align region bounds to the tablet grid provided one has been specified using the Guides command from the
Options menu. When you select this command, selected regions bounds (Left, Top, Right and Bottom) are rounded to the
nearest tablet grid point.

There is no dialog box or confirmation for this command. However, you may reverse the command by choosing Undo
from the Edit menu immediately before executing another command.

Align

To move regions to a common bound, select the region(s) and choose Align from the Format menu. The Align dialog box
is displayed.

Select the type of alignment you wish from the Sides, Centers or Center in Active Area options. If you choose Sides or
Centers, you may  ENTER the region bound for the alignment. The default values supplied for these fields reflect the
bounds of the current selection, i.e. the bounding rectangle which fully encompasses all selected regions.

When you have completed your choices, click the Align button or press ENTER. You may cancel at any time by clicking
the Cancel button or pressing the ESCAPE key. You may reverse this command by choosing Undo from the Edit menu
before executing another command.

Duplicating Regions
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Duplicating regions can save time when creating regions with similar properties or styles. You may freely duplicate
regions and then edit them later. Duplicated regions are automatically drawn in the active area offset by one-quarter inch.
If there is no room on active area to duplicate the region(s), you will get an error message instead.

To duplicate one or more regions, select the region(s) and choose Duplicate command from the Edit menu. Be careful
not to duplicate Pen or Pointer regions since this will generate a compiler warning.

Note: You can also duplicate regions using the Copy and Paste clipboard commands from the Edit menu. For more
information on using the clipboard, refer to the chapter titled The Clipboard.

Removing Regions
To removing regions from a template, selecting them and press the DELETE key or choose Delete from the Edit menu. If
you change your mind afterwards, select Undo from the Edit menu immediately prior to executing another command.

Instead of removing regions, you can also copy or cut them to the Windows clipboard where they can be pasted into
another template. For more information on using the clipboard, refer to the chapter titled Using the Clipboard.

Creating Templates   33



Chapter 8
Styles & Combinations

The Editor supports a variety of styles which may be applied to the active area,  regions and combinations.  (In the
remainder of this chapter, the term "object" will be used to represent any of these Editor types.) Styles also work in
conjunction with imported graphics files which are discussed in the next chapter titled Importing & Exporting.

Combinations are regions linked together solely for stylistic and selection purposes. As such, they have no properties in
and of themselves. Their size and location within the template is dependent entirely upon the regions on which they are
based. Combinations are discussed later in this chapter.

Styles
Style properties include the shape, outline, pen and fill colors; and font size, position, color and text of a label. Each time
an object is displayed or printed, the shape is drawn with the outline pen and fill color. Then, if an imported graphics file
has been defined, it is drawn clipped to the shape of the object. Finally, the label, if any, is drawn at the size and position
specified.

Styles are affected by the Draft Quality option from the Display and Print commands which inhibits color fills, outlines,
text colors and imported graphics files. Style labels are also affected by your choice of font for the template. For more
information, refer to the chapters on Changing Options and Printing.

Default Styles
The Editor supplies default styles for each type of object which may be changed from within the Style dialog by clicking
the Default button. Each time an object is created, including new templates, the default styles are applied. Default styles
for each object type are defined as follows:

Style Tablet Combination Region
Shape Rectangle Rectangle Rectangle
Hatching None None None
Fill Color White White White
Pen Type Solid Shadow Solid
Outline Color Black Black Black
Font Size Large Medium Small
Font Weight Bold Bold Bold
Horizontal Center Center Center
Vertical Bottom Top Center
Text Color Black Black Black

Applying Styles
To change the style of an object, choose Style from the Format menu. If one or more regions are selected, region styles
will  be  edited.  If  one or  more  combinations are  selected,  combination styles  will  be edited.  Finally,  if  there  is  no
selection, the tablet style will be edited. After selecting the command, the Style dialog box is displayed with the type of
object selected in its title bar.

First, choose the shape of the object by selecting one of the Shape options. This shape will be used to display and print
the object and also to which any imported graphics files will be clipped. Then, you may also specify the hatching, pen
style, outline and fill colors. Colors followed by an exclamation point are pure colors and result in the best printed output
based on today's color printer technologies.
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If you wish to assign a label to the object, type  the text for the label in the Label field up to 32 characters. Once a label is
specified, the Font,  Weight,  Horizontal,  Vertical  and Color fields become enabled allowing you to specify the size,
placement and color of the label within the object's bounds. To enter multi-line labels, use ENTER to break each line.

When you have completed your choices, click the OK button or press ENTER to apply the style changes to the object. If
you are formatting multiple regions or combinations, only the changed style elements will be applied and all others left
alone. You may cancel formatting the object's style by clicking the Cancel button or pressing the ESCAPE key.

If you wish to make the style elements the default for the object, click the Default button to store these values in program
memory and update the Editor's configuration file. You will first be prompted for confirmation before any changes are
made.

Note: If you enable Draft Quality from the Display or Print commands, hatching, fills, outlines and imported graphics
files are not drawn. This can significantly speed up drawing or printing the template.

Fonts Unlike many other graphical and word processor applications, the Editor does not specify font sizes in
points, picas or inches. Instead, five virtual font sizes are provided which are automatically scaled to the active area each
time the tablet is changed. These sizes correspond roughly to 1/100th (tiny), 1/80th (small), 1/60th (medium), 1/40th
(large) and 1/20th (huge) of the tablet's minimum X or Y axis. For example, a tablet with X an Y axis of 12" will have
fonts scaled to .12", .15", .20", .30" and .60", or approximately 9, 11, 14, 22 and 43 points, respectively.

Placement The Horizontal and Vertical fields allow you to specify the placement of the label within the object and
may be combined to yield up to nine, discrete locations. Object labels are always word-wrapped and clipped to the
object's shape and may not fully appear depending on the font position, size and object's shape. An exception to this rule
is for combinations in which the label is positioned and clipped outside the combination's bounding shape.

Style Sheets
Template styles for the tablet, combinations and regions may be saved to, and applied from, separate files called Style
Sheets. This can greatly simplify the standardization of template designs and ease the process of globally changing the
style for each type of object.

Information is stored in a Style Sheet using normal ASCII which may be edited using NotePad or any other text editor.
Objects are stored in sections delineated by square brackets including: [Tablet], [Combos], [Regions] and [Pointer]. Each
style entry appears under the appropriate section followed by an equals sign, e.g. 'Outline='. Normally, you will not need
to edit this information.

To create or use a Style Sheet, choose the Merge button from the Style dialog. You will then be presented with the Merge
Styles dialog.

This dialog box is very similar to the standard file dialog box and offers a choice of merging the current template styles
to a new or existing Style Sheet, or applying the styles from a Style Sheet to the current template. Editor Style Sheets use
the default extension .VTY.

Creating Style Sheets

To create or change an existing Style Sheet, use the file and directory list boxes to locate the file or enter a new filename.
Then, choose the Merge To button to save the current template's tablet and default combination and region styles to the
filename specified. You will be prompted before the over-writing an existing file's contents. You may cancel creating or
changing a Style Sheet by clicking the Cancel button or pressing the ESCAPE key.

Using Style Sheets

To apply styles from an existing Style Sheet to the current template, select the file using the file and directory list boxes
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and then click the Merge From button. You will be prompted before any changes are made. You may cancel using a Style
Sheet by clicking the Cancel button or pressing the ESCAPE key.

Styles from the Style Sheet are applied to the tablet, combination and region default styles; and also to each respective
object and the template redrawn. You may control which styles are updated for each object by deleting the entry under
the appropriate section in the Style Sheet. This will have the effect of using the existing style type instead of the style
from the Style Sheet.

Note: There is no Undo capability for the Merge From command. If you change your mind about the merged styles,
simply reopen the template answering No when asked to save any changes first.

Combinations
Unlike the tablet and regions, combinations have no properties other than their style and an optional imported graphics
file.  Their  position and  size  is  dependent  entirely upon the  regions  on which they  are based.  As  such,  commands
applicable to combinations are those which create them, destroy them, apply styles and import graphics files.

Combinations are useful stylistic and selection tools for enhancing the visual appeal of your template. They are not
compiled and have no effect whatsoever on the command file of your template. Instead they should be used to visually
group template regions with a common function in order to assist the user in locating specific command areas.
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Combinations versus Regions

Once regions are combined, they become a single entity for selection purposes and therefore lose their ability to be
selected or edited individually. Each time a region within a combination is selected, all other region members of the
combination become selected automatically.

Combinations inherit their bounds from the largest rectangle that fully encloses their member regions. These bounds are
updated each time the regions within the combination are moved, stretched or re-sized. In this regard, combinations are
never really selected themselves, just their member regions. Selection handles and commands applicable to a multiple
region  selection  operate  on  the  regions  themselves  and  the  combination  is  updated  simply  as  a  byproduct  of  the
command.

Note: Combinations should be created at the end of the template design process since they restrict access to their
individual member regions. To access an individual member region, the combination must first be broken, the region(s)
edited and then recombined.

Combined regions cannot be re-combined with other regions whether they are combined or not and should generally
share a common command function.

Creating Combinations
To create a combination, select the regions using the marquee method and choose Combine from the Format menu or
press the CTRL+C keys. If you have not selected any regions, or the regions selected are already combined, the Combine
command will be disabled.

When you select the Combine command, the Style dialog box is displayed in which you can change the combination's
style to that other than the default. You may cancel combining the regions at this point by clicking the Cancel button or
pressing the ESCAPE key. Otherwise, you can use the Undo command from the Edit menu or choose Break Apart from the
Format menu.

If you accept the Style dialog box by clicking the OK button or pressing ENTER, a combination will be created linking the
selected regions together. The display will be updated with the new combination and its member regions redrawn. The
combination can then be selected by selecting one or more of its member regions. You may also import graphics files
into combinations for further style enhancements. 

Breaking Combinations
To destroy one or more combinations, select their member regions using the marquee selection method and choose Break
Apart from the Format menu or press the  CTRL+B keys. If you have not selected any combinations, the Break Apart
command will be disabled.

When you select the Break Apart command, the combined regions are unlinked for selection, formatting and editing
purposes. Any combination styles defined will be lost along with imported graphics files. The display will be updated
and the uncombined regions redrawn.  There is  no confirmation for  this command but it  is  supported by the Undo
command from the Edit menu.
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Chapter 9
Importing & Exporting

The Editor provides for the exchange of graphical information with other applications through the use of imported and
exported graphics files. In addition, the Editor supports a special file format for exporting and importing Editor objects
allowing for the reuse of common template functions.

Importing graphics files is intended for enhancing the style and appearance of templates through the use of graphical
images. These images, which must be contained in separate files, may be inserted into any Editor object such the active
area, combinations or regions. Once imported, they are scaled and clipped to the object's size and shape.

Exporting graphics files is intended for exchanging a templates with desktop publishing and word processing programs.
This provides a convenient way to document template functions for users other than the template creator.

Editor Export files (VTX) can significantly reduce template development time by storing modular elements of common
template functions in disk files. These files may then be inserted into other templates, compiled and used. Editor Export
files, which are created and used from within the importing and exporting facilities of the Editor, are discussed separately
later in this chapter.

Importing Graphics Files
A variety of graphics files formats may be imported into Editor objects including the active area, combinations and
regions. Once imported, graphics files are automatically scaled and clipped to the object's size and shape even when
moved or resized. Supported import file formats include:

n Windows (Aldus) placeable metafiles (WMF);

n Windows device independent bitmaps (BMP);

n Autodesk DXF files created by AutoCAD or AutoSketch (DXF); and

n Adobe encapsulated Postscript files (EPS).

Imported files are affected by the choice of the Draft Quality option from the Display command in the Options menu and
Print dialog box. When selected, the Draft Quality option inhibits the display or printing of imported files which is useful
for saving time in proofing or testing templates.

To import a graphics file, select the regions or combinations to receive the file and choose Import from the File menu.
No selection is necessary when importing into the tablet. When you select the Import command, you will be presented
with the Import dialog box.

Choose the name of file format from the Format list box. After making your choice, the file name extension will appear
in the File Name edit field and the current directory of files matching the extension will be shown in the list box under
the File Name field. 

If the file you wish to import does not appear in the file list box, change the current drive and directory by double-
clicking on the selections in the directories list box until the file is found. As you change the drive and directory, the new
path will be displayed under the "Directories:" field. Once you have found the file, double-click on its name in the list
box or single-click to place it in the File Name field.

Note: Imported filenames (except Editor Export files) are stored with the file name only and must be in the same
directory as the template or the Windows search path to be displayed or printed. If your imported files do not appear
when displayed or printed, make sure they are in the template directory or along the Windows search path.
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When you have completed your choices, import the file by clicking the Import button or pressing ENTER. Alternatively,
you may cancel importing a file by clicking the Cancel button or pressing the ESCAPE key. Canceling the Import dialog
box leaves your template unchanged.

Resident Option By default, graphics files are loaded each time they are drawn and unloaded after use. Since
this can severely affect  screen updates each time the program window is displayed, graphics files can be locked in
memory until the file is closed. To lock a graphics file into memory, check the Resident option prior to clicking the
Import button or pressing ENTER. Imported files should be resident unless their size exceeds your system memory.

Drawing Exchange Drawing Exchange Files are imported subject to the following restrictions: ASCII entity-only
files  up  to  three  decimal  places;  fonts  are  converted  to  the  Windows  system  font;  SHAPE,  ATTDEF,  ATTRIB,
DIMENSION, 3DFACE and VPORT entities are ignored; and, polyline widths, bulges and meshes are ignored.

Encapsulated Postscript Postscript instructions are ignored when displaying, printing or exporting the image to a non-
Postscript device or file. However, if the file contains a metafile header, it will be used for non-Postscript devices or files.
Otherwise, a place holder graphic image is substituted.

Removing Imported Files

To remove an imported graphics file from an object, select the object, choose Import from the File menu and click on the
Clear button. You do not have to specify an import file type or file name in order to clear the file from the object.

Exporting Graphics Files
Exporting allows you to save your template in a file format suitable for use with other applications such as desktop
publishing and word processing. The Editor supports following export file formats:

n Windows (Aldus) placeable metafiles (WMF).

n Windows normal metafiles (WMF).

n Windows device independent bitmaps (BMP).

n Autodesk DXF files for use by AutoCAD or AutoSketch (DXF).

n Adobe Encapsulated Postscript files (EPS).

To export a template, select the regions and combinations, if any, you wish to specifically include in the export file.
Then, choose Export from the File menu or press the ALT+F,E keys. You will be presented with the Export dialog box.
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Choose the name of the export file format from the Format list box. After making your choice, the file name extension
will appear in the File Name edit field. Then, change the drive, directory and file name for the exported file. If you do
not specify a drive and directory, the current path is used.

After selecting the format and name for the file, you may choose one or more options for inclusion. These allow you to
include the active area, selected combinations and regions only (if a current selection has been made) and draft quality.
Include options are disabled when exporting Editor Export files.

When you have completed your choices, click the Export button or press  ENTER to export the file. You may cancel
exporting the file by clicking the Cancel button or pressing the ESCAPE key.

Encapsulated Postscript If you select the Encapsulated Postscript format and the Windows Postscript printer driver is
installed, the Options button will be enabled. Clicking on this button causes the Postscript Printer dialog box to appear.

Select the options you wish and click on the OK button or press  ENTER to return to the Export dialog box. To cancel
changing the Postscript options, clicking the Cancel button or press the ESCAPE key.

Note: Make sure the "Download Header Each Job" option is selected using the Options button from the Postscript 
dialog box. This header is required for exporting encapsulated Postscript files from within the Editor. However, you do 
not have to specify the encapsulated Postscript option from within the driver configuration dialog.

Windows Metafiles Exported metafiles cannot contain other metafiles.  If  your template has imported metafile
images, they will not be exported though the rest of the template should export properly. This is due to the way Windows
uses metafiles and cannot be over-ridden. If you need to export a template containing metafiles, try using another export
file format or converting the metafiles in your template to some other format and re-import them. Note also that labels
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are not wrapped unless specifically broken by a carriage return.

Drawing Exchange Drawing  Exchange  Files  are  exported  subject  to  the  following  restrictions:  ASCII  files
comprising outlines only with two decimal places; imported graphics files are ignored - including other imported DXF
files; button outlines styles are converted to Solid; labels are not wrapped unless specifically broken by a carriage return;
and, invisible objects (no outline, pen or color) are ignored.

Windows Bitmaps If you select the Windows Bitmap file format, the Options button will be enabled. Clicking on
this button causes the Export Bitmap dialog box to appear.

Choose the size of the bitmap by selecting one of the Size options and then select the number of colors from the Colors
options. If you select a bitmap size greater than 256x256, the RGB color option under Colors options will be disabled. If
you choose either 16 or 256 colors, the Compress check box will be enabled which you can select to save the bitmap file
in compressed form (RGB files are always compressed). It is recommended you use the compression option in order to
save disk space and speed file loading.

When you are done, click the OK button or press ENTER to return to the Export dialog box. Your bitmap options will be
retained in program memory until you exit the Editor. To cancel changing the export bitmap options, click the Cancel
button or press the ESCAPE key.

Editor Export Files
Editor Export files are a convenient way to save commonly-used template functions which may then be inserted into
other template designs. Editor export files must be created before they can be used. Then, each time they are inserted into
a template, they are placed in their original position where they may be moved or sized to their final location.

The information saved in Editor Export files includes all region and combination properties and styles along with the
tablet properties. This information is then used to recalculate the region's bounds when imported into another template.

Creating Export Files

To create an Editor Export file, select the specific regions and combinations you wish to export and choose the Export
command from the File menu. If you do not select any regions, then all regions in the template will be exported. When
you select the Export command, the Export dialog box is displayed.

First,  make  sure  the  Editor  Export  format  is  selected  in  the  File  Format  list  box.  The  File  Name  edit  field  will
automatically change to the path and file name of the template suffixed with the .VTX extension. If the file name or path
is not correct, you may edit the field keeping the extension .VTX.

Then, if you wish to export selected regions and combinations only, choose the Selection Only option from the Include
list. If you have not selected any regions or combinations before executing the Export command, this option will be
disabled and all regions and combinations will be exported.

Note: The Active Area and Draft Quality options are always disabled for Editor Export  files.  There are no other
options for Editor Export files (the Options button is disabled).
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When you have completed your choices, click the Export button or press ENTER. You may cancel at any time by clicking
the Cancel button or pressing the ESCAPE key.

Using Export Files

To insert the contents of an Editor Export file into your template, select the Import command from the File menu. Make
sure the Editor Export format is selected in the File Format list box. The extension .VTX will appear in the File Name
field and all matching files in the current directory will be listed in the File list box under the Files In field.

If the Editor Export file you wish to import does not appear in the File list box, change the drive, directory or both until it
is found. Select the file from the list box so that it appears in the File Name edit field. The current directory will be
shown to the right of the field titled Files In.

When importing Editor Export files, the Resident option is always disabled. Also, you cannot clear imported Editor
Export files. Use the Undo command from the Edit menu immediately after importing or delete the imported regions and
combinations.
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Chapter 10
Printing

When you have created and compiled your template, you must print the template on a hard copy device such as printer or
plotter in order to use it effectively. The printed image is placed on the digitizers surface, centered within the active area,
so that the locations of each region in the template will correspond to their locations within the actual digitizer.

The output quality of your template will vary depending on the quality your printer or plotter and the type of graphical
images you may have imported. For more information on getting the best quality in your printed output, refer to the
section below titled Printing Tips.

Selecting Printers
To print your template, make sure the printer or plotter is turned on and selected as the default printer device from within
the Control Panel. If you are not sure how to do this, refer to the Window's User's Guide in the section on using the
Control Panel. You may also access the Control Panel from the File menu or by pressing the ALT+F,C keys.

Configuring Printers
To configure the printer before printing your template, choose Print Setup from the File menu or press the ALT+F,R keys.
If your printer supports a configuration dialog box, it will be displayed and you may change its options to achieve the
correct output quality and orientation.

Printing Templates
If your printer is selected and configured, you may print your template by choosing Print from the File menu or pressing
the F7 key. The Print dialog box is displayed and allows you to select an output format and special options. Select the
format and options you wish and then click the Print button or press ENTER. To cancel printing, click the Cancel button or
press the ESCAPE key.

If you have enabled the Windows Spooler, you may invoke the Windows Print Manager by pressing the Manager button
in order to view or change the status of tasks currently printing. Selecting this option will not exit the Print dialog box
and you may continue to make your printing choices.

When you click the Print button, the Print dialog box is replaced by the Print Cancel dialog box. which informs you of
the status of the template during printing and gives you an opportunity to cancel at any time. To cancel printing, click the
Cancel button or press the ESCAPE key.

The Editor will stop printing your template and return you to the program window. If you do not cancel printing, page
numbers and objects will be displayed as they are printed and the Print Cancel dialog box closed when completed.
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Output Formats

The Editor  supports  a  variety of  output  options designed  to augment  the various  stages  of  template  design.  These
include: printing the template at actual size, fit to the printer's page size and orientation, scaled to the same level as
displayed and a tiling guide for assembling large templates printed on smaller printers.

Generally, printing the template at actual size should be reserved for the final stages of template design. Printing the
template fit  to the printer's page size or at the displayed size allows you to quickly judge the placement of regions
without wasting paper assembling large templates. The tiling guide format can be used as a road map for assembling
larger templates tiled across several pages.

Actual Size This output option prints the template at actual size tiling it to fit across multiple pages, if necessary.
Tiling refers to the practice of spreading an image across multiple pages when the image itself is larger than the page
size. If your template is fits within the printer or plotter's page size, it will be centered in the page without tiling.

Fit to Page This output option prints the template adjusting the zoom level to fit the entire template within the
page size and orientation for the printer. This option very useful for proofing your template or creating a smaller handout
for discussion purposes.

As Displayed This output option prints the template at the current zoom level tiling it to fit across multiple pages, if
necessary. If you are unsure of the zoom level, enable the Status Bar from the Display command in the Options menu. If
your template is fits within the printer or plotter's page size, it will be centered in the page without tiling.

Tiling Guide This output option prints the template fit to the page size and orientation for the printer showing tiled
pages as dashed lines. If your template is fits within the printer or plotter's page size, it will be centered in the page
without any tiling marks.

Output Options

A number of special printing options are available which are designed to save time, improve output quality and assist in
assembling large templates. While several of these options correspond to Display options, they are used for printing only.
For example, to print the template in draft quality, this option must be selected whether or not it is selected from the
Display command.

Draft Quality This print option enables you to print the template in draft quality which disables printing imported
graphics files, color fills and outlines. Choosing this option can result in significantly faster printing time and is useful
for proofing large and complex templates prior to final output.

Debug Info This print option enables you to print regions containing compiler errors with an "X" intersecting their
four bounding corners. To remove these marks, fix the errors and recompile or uncheck this option..

Crop Marks This print option enables you to include crop marks which encompass the template image on each
page. Choosing this option can assist you in assembling a large template that has been tiled across many pages or which
has no discernible marks or boundaries of its own.

Selected Only This  print  option  is  available  only  if  you  have  selected  one  or  more  combinations  and  regions.
Choosing this option prints the active areas and only the selected combinations and regions. It is useful if you are editing
a large or complex template and want to proof selected portions in order to shorten printing time.

Page Range

If you select the output format Actual Size or As displayed, you may then also select a range of pages. Pages are printed
from left-to-right and top-to-bottom. The default is to print all pages. To select a page range, chick the From radio button
and enter the starting and ending page numbers. If you do not enter a number for either value, the default page number is
one for From and the total number of pages for To. If you wish, enter only one of these fields.
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Printing Tips
Printing templates can involve enough variables that you should experiment with the best combination for your system.
However, here are some tips and tricks to get you started.

n Use the highest quality and largest printer or plotter you have access to for your final output. If you do not have
the quality and size you wish, consider printing the template to a file and finding someone who does (like a
friend, another department or even a service bureau).

n Set your page orientation to match your digitizer, i.e. portrait or landscape. This can make a big difference in the
number of pages printed and the effort needed to assemble large templates. The Editor will do this for you
automatically unless specifically disabled.

n If your printer or plotter is smaller than your digitizer, include the Crop Marks option in the Print dialog box to
assist you in assembling your template from the printed output.

n If you use a plotter or dot-matrix printer, refrain from using imported graphics or complex templates since they
will not match the quality of your output device. This is particularly true for bitmaps and other raster images.

n If you have imported many complex graphics files, use the Draft Quality option to speed up printing proofs of
your template before the final version.

n Use the Fit to Page or Tiling Guide options to proof the output before printing. This saves paper and eliminates
assembling large templates until you are ready for final output.

n Use the Windows Print Manager when printing large and complex templates in order to return to your work as
quickly as possible.
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