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Using Windows Express with a Keyboard

Use the following keyboard commands with Windows Express.    For more information about 
the Windows keyboard, press F1 to open the Windows Help file.

Menu Keys

ALT+"letter" Chooses the item on the menu bar that has the corresponding 
underlined letter.    For example, in Windows Express, ALT+S chooses the 
Special menu.

"letter" Chooses the command on the drop down menu that has the 
corresponding underlined letter.    For example, in Windows Express, P 
chooses the "Preferences..." command from the Special menu.

DIR KEYS Moves between menu items.
ENTER Chooses the selected menu item.
ESC Cancels the selected menu.    The drop down menu disappears.

Dialog Box Keys

TAB Moves to the next control.
SHIFT+TAB Moves to the previous control.
ALT+letter Moves to the control which corresponds to the underlined letter in its 

name.    For example, in the Run dialog box, ALT+M chooses the Run 
Minimized option.

DIR KEY Moves between selections within a group of options or moves through 
the items in a list box or text box.

ALT+DOWN Opens a drop-down list box
SPACEBAR Selects an item in a list box, checks or unchecks a checkbox, or chooses 

the current selection in a group of options.
SHIFT+DIR KEY Extends the selection in a list box.
ENTER Executes all the currently selected options and list items in the dialog 

box.
ESC Closes the dialog box without completing the command.

Help Keys

F1 Displays the Help window, with the Help index for the application.    If you
have chosen a command, the Help text for the command will be 
displayed instead.    If the Help window is already open, F1 opens the 
Windows Help file.

Window Keys

ALT+SPACEBAR Opens the Control menu for the active window.
ALT+F4 Closes the active window.
ALT+ESC Switches to the next application window or icon.



File Menu Commands
The File menu contains commands which allow you to work with different master folders,run 
applications not defined in your master folder, and exit Windows Express.

Note:    In some cases, the "Open..." and "Run..." commands may not appear on the File 
menu due to a control specified by the person who set up your Windows Express system.

Related Topics:
Open Command
Run Command
Outline Command
Startup Command
Exit Command
Opening a Master Folder
Running Other Applications
Viewing an outline of your Windows Express folder
Exiting Express



Open Command
The "Open..." command on the File menu allows you to open a different master folder.    
Selecting this command will display a dialog box in which you specify the filename of the 
master folder you wish to open.    Master folder filenames usually use the extension .WEM.

Note:    In some cases the "Open..." command may not appear on the File menu due to a 
control specified by the person who set up your Windows Express system.

Related Topics:
Opening a Master Folder



Run Command
The "Run..." command on the File menu allows you to access applications not defined in a 
master folder.    Selecting this command will display a dialog box in which you specify the 
applications or documents you wish to execute.

Note:    In some cases, the "Run..." command may not appear on the File menu due to a 
control specified by the person who set up your Windows Express system.

Related Topics:
Running Other Applications
Command Builder



Outline Command
The "Outline" command on the File menu allows you to view an outline of your Windows 
Express folder, and optionally print it, save it to a text file, or copy it to the clipboard.    This 
feature is particularly useful if youre working with a large folder and want to get an overview
of its structure.

Related Topics:
Viewing an outline of your Windows Express folder



Startup Command
The "Startup" command on the File menu allows you to run a certain sequence of applications when you 
start up your computer.    Selecting this command will display a dialog box in which you specify 
the applications or documents you wish to execute.

Related Topics:
Command Builder



Exit Command
The "Exit" command on the File menu allows you to leave Windows Express.    Selecting this 
command will close the Windows Express application, and return to Windows.

If you are running Windows Express as the shell, the "Exit" command is replaced by the "Exit
Windows..." command.    Selecting the "Exit Windows..." command will end your windows 
session and return you to DOS.

Note:    In some cases, the "Exit Windows..." command may not appear on the File menu due
to a control specified by the person who set up your Windows Express system.

Related Topics:
Exiting Express
Ending Windows Session



Special Menu Commands
The Special menu contains utility commands which allow you to end your Windows session, 
work with Quick Keys, customize the appearance of the Windows Express display window 
and set preferences on how you want Windows Express to work for you.

Related Topics:
End Session Command
View Quick Keys Command
Assign Quick Keys Command
Preferences Command
Edit Menu Command



End Session Command
The "End Session" command on the Special menu allows you to exit Windows and return to 
DOS.    Selecting this command will close all applications and return you to DOS after 
prompting for your confirmation.

Related Topics:
Exiting Express
Ending Windows Session



View Quick Keys Command 
The "View Quick Keys..." command on the Special menu allows you to display a window 
listing each Quick Key assignment for the current master folder.    Selecting this command 
will display the View Quick Keys window.    If there is a check mark beside the command, the 
View Quick Keys window is already displayed and selecting the command will close the View 
Quick Keys window.

Related Topics:
Using Quick Keys
Assign Quick Keys Command



Assign Quick Keys Command 
The "Assign Quick Keys..." command on the Special menu allows you to assign Quick Keys to
automatically open an application or folder item with a keystroke you've chosen.    Selecting 
this command will display the Assign Quick Keys window.    While this window is displayed, 
you can select folder and application items to be opened with a Quick Key.

Related Topics:
Using Quick Keys
View Quick Keys Command



Preferences Command
The "Preferences..." command on the Special menu allows you to customize the appearance 
of the Windows Express display and the way Windows Express works for you.    Selecting this 
command will display the Preferences dialog box in which you specify your display and 
operational preferences.

Related Topics:
Changing Preferences



Edit Menu Command
The "Edit Menu" command on the Special menu allows you to edit the current master folder. 
Selecting this command will run Windows Express Editor.



Tasks Menu
The Tasks menu allows you to access another application simultaneously with Windows Express.    You 
can switch between tasks in the same manner as clicking "Switching Tasks" within the Windows 
Command Box in the upper left corner of the main window.    For more information on tasks, read the 
Microsoft Windows User's Guide.



Help Menu
The Help menu contains commands which allow you to access this help system, view 
information about your system configuration, and view information about Windows Express.

Note: The Help window provides information about using the Windows Express application.    
Additional "Item Help" may be available that provides further information on application and 
folder items.    Item help is determined by the person who set up your Windows Express 
system.

Related Topics:
System Information Command
Getting Item Help



System Information Command
The "System Information..." command on the Help menu allows you to view information 
about your current system configuration, including Windows version, Windows mode, 
available memory, display resolution and color capabilities.

Related Topics:
System Information



About Windows Express 
Windows Express is the complete menu system for the Microsoft Windows workstation, that 
organizes your applications and documents in easy-to-use, graphical terms, using a familiar 
file folder approach. 

When you open Windows Express, your documents and applications will    already be 
organized for you within a master folder in the form of    "application items"    and "folder 
items."    When you select an application item, Windows Express starts or runs an application
and can also automatically open an existing document, or a new document.    Application 
items are stored in a master folder, or in sub-folders called "folder items."    When you select 
a folder item, Windows Express opens the folder and displays the application and folder 
items it contains.

To open a folder item or execute an application item, double-click anywhere on the item, or 
select the appropriate keyboard command.

Other special features of Windows Express:

Preferences gives you the ability to customize your Windows Express display window and 
the way it works for you.    

Quick Keys allows you to set up function key shortcuts for opening folder and application 
items with a keystroke.    

On-line Help answers your questions on how to use any of the Windows Express commands
and tells you how to perform certain tasks through context-sensitive help 
windows.

To change a master folder, or create a new master folder, you or the person who set up your 
Windows Express system can do so using Windows Express Editor.

Related topics:
Selecting Items
Changing Preferences
Using Quick Keys
Getting Item Help



Selecting Items
Before you can perform any task with an application item or folder item, you need to select 
it first using either the mouse or the keyboard.    In the instructions below, we assume that 
you are using the default Preferences setting for Execution Style, which is double-click.

To execute an application item or open a folder item:
Double-click the item or press the function key you assigned as a Quick Key to that item.

To choose another open folder
Click the folder tab that displays the name of the folder you want., or press BACKSPACE to 
choose the previous folder until you display the folder you want.

You can also run an application item minimized by pressing the SHIFT key while selecting the
application item.    

Related Topics:
Using Express with a Keyboard
Changing Preferences
Using Quick Keys
Getting Item Help
Passwords



Getting Item Help
The person who sets up your Windows Express system can write custom help text for each 
application item and folder item.    This help text gives you specific information about the 
item that you might need for your work.    

Note: Item Help provides information on application and folder items.    There is further 
information available to you about using the Windows Express application.

To display help text for an item:
Press and hold CTRL while you select the item.

Related Topics:
Using Express with a KeyboardSelecting Items
Help Menu



Opening a Master Folder
To open a master folder, open its file when you start Windows Express, or if you are already 
in Windows Express choose the "Open..." command from the File menu.    Master folder 
filenames usually use the extension .WEM.    Only one master folder can be open at a time. 
Opening a new master folder closes the currently displayed master folder.    

The master folder you select may be password protected.    If it is, you will be required to 
enter the correct password before Windows Express will open the master folder.    If you do 
not know the correct password, contact the person who set up your Windows Express 
system.

Note: In some cases, the "Open..."    command may not appear on the File menu due to a 
control specified by the person who set up your Windows Express system. 

To open a master folder:

1. Click File to display the File menu
2. Click "Open..." to display the File Open dialog box.
3. Double-click the filename of the master folder you want to open.

Related Topics:
File Menu
OpenPasswords



Running Other Applications
You can run applications that are not defined in a Windows Express folder by choosing 
"Run..." from the File menu.    This command presents the Run dialog box where you type in 
or choose the filename of the application you want to run.    You can run more than one 
application at a time by separating each command with a semi-colon.    You can also run 
applications minimized or minimize Windows Express when applications are run.

Note: In some cases, the "Run..." command may not appear on the File menu due to a 
control specified by the person who set up your Windows Express system. 

To run applications not in a folder:

1. Click the File menu.
2. Click "Run..." to display the run dialog box.
3. Type the filename, or if necessary, the pathname, in the text box.    To run multiple 

applications, type the names of the applications you want to run and separate them 
with semicolons.
-or-
If you dont know the exact location of the application or document files,    or are not 
sure of the command syntax, click the Command Builder button.    This brings up    up 
the Command Builder for you to graphically create an Enhanced Command.

4. To execute the command, click the Run button.

Related Topics:
File Menu

Run



Viewing an outline of your Windows Express folder
The "Outline" command on the File menu allows you to view an outline of your Windows 
Express folder.    This feature is particularly useful if you're working with a large folder and 
want to get an overview of its structure.    

Note: You must have Notepad to use this feature.

To view an outline of your Windows Express folder

1. Click the File menu.
2. Click "Outline."
3. An outline of your folder will appear, with an asterisk (*) used to denote folders and 

numbers (beginning with the number "1")used to label your folder hierarchy.

Related Topics:
File Menu

Outline



Saving your Windows Express folder outline
The "Save Outline" button in the Outline dialog box allows you to save an outline of your 
Windows Express folder to a text file, or copy it to the clipboard.    

To save an outline of your Windows Express folder

1. Click the File menu.
2. Click "Outline."
3. An outline of your folder will appear, with an asterisk (*) used to denote folders and 

numbers (beginning with the number "1")used to label your folder hierarchy.
4. To save an outline of your Windows Express folder as a text file, choose Save As, and 

a dialog box appears asking you to name the file and specify the location where you 
want it stored.
To copy an outline of your Windows Express folder to the Windows Clipboard, choose 
Copy.

Related Topics:
File Menu

Outline



Exiting Windows Express
When you are done working in Windows Express, you can close the Windows Express 
application and return to Windows.

To exit Windows Express:

1.    Click the File menu.
2.    Click "Exit."

or, if Windows Express is the Windows shell:
1. Click File to display the File menu.
2. Click "Exit Windows."

Note: In some cases, the "Exit WIndows..." command may not appear on the File menu due 
to a control specified by the person who set up your Windows Express system. 

Related Topics:
File Menu

Exit
Ending Windows Session



Ending Windows Session
When you are done working in Windows Express, and you no longer need to work in 
Windows, you can close all applications and exit to the DOS prompt.

To end the Windows session: 

1. Click the Special menu.
2. Click "End Session."    You will be asked if you wish to end your Windows session.
3. Choose OK.

Related Topics:
Special Menu

End Session
Exiting Windows Express



Using Quick Keys
To work more quickly and efficiently in Windows Express, you can assign a Quick Key to any 
application item or folder item.    You can then open that item by simply pressing the Quick 
Key you've defined.

To assign a Quick Key: 

1. Click the Special    menu.
2. Click "Assign Quick Keys..." to display the Assign Quick Keys window.
3. Select the item in the Windows Express window you want to assign.    If necessary, 

open another folder by double clicking the folder item you want.
4. Press the Quick Key (function keys F2 thru F9) you want to assign to that item.    To 

clear the assignment, press and hold SHIFT as you press the Quick Key.
5. Repeat 3 and 4 to make more assignments.
6. Click OK to save your assignments, or choose Cancel to close the window without 

saving    your changes.

To view Quick Key assignments: 

1. Click the Special menu.
2. Click the "View Quick Keys..."    command to display the View Quick Keys window.
3. To close the window, double click the Control menu in the upper left corner of the 

View Quick Keys window.

To use Quick Keys:

With the View Quick Keys window displayed, click the desired Quick Key in the View 
Quick Keys window, or press the Quick Key which corresponds to the desired function.

You can also run an application item minimized with Quick Keys by pressing the SHIFT key 
while selecting the desired Quick Key.

Related Topics:
Selecting Items
Special Menu

View Quick Keys
Assign Quick Keys



Changing Preferences
You can customize the appearance of your Windows Express display window, and the way 
Windows Express works for you by checking the following options in the Preferences dialog 
box.

Display Style
The Date checkbox controls the status line, which shows the day, date and time, at the top 
of the Windows Express window.    Check this box to display or hide the status line.

The checkboxes labelled Icons, Keys, Names, and Descriptions control the display of all the 
application items and folder items.    Check any or all of the display styles you prefer.

Icon Size
There are two sizes of icons to choose from.    Large icons are the same size as application 
icons when displayed in the icon area.    Small icons are half the height of large icons.    On 
low-resolution monitors, this option is always set to Large.    Check the icon size you prefer.

Text Size
There are three sizes of text to choose from.    Check Small, Medium or Large to determine 
the size of text display.

Maximize Express
Initially Maximizes the Windows Express window whenever you start Windows 

Express.    When unchecked, Windows Express opens its window the same size
as when you    last closed it.

Automatically Maximizes the Windows Express window when all other application windows 
are closed.

Minimize Express
Always Minimizes the Windows Express window whenever you execute an application 

item.
Never Leaves the Windows Express window as it is when you execute an application 

item.
Default Minimizes the Windows Express window according to the application item's 

settings which are specified by the person who set up your Windows Express 
system.

Note:    Windows Express will not minimize itself if the application item is run minimized.    To 
run an application item minimized, press SHIFT while selecting the item.

Execution Style
Single click Allows you to open items with one mouse click or one keypress (the selection 

key).
Double-click Allows you to open items with a double-click of the mouse, or with two 

keypresses (the selection key and the ENTER key).

Screen Saver
The screen saver button displays the screen saver dialog box.    It allows you to control the 
screen saver feature of Windows Express which blanks out your computer screen after a 
minute or more of inactivity.    This feature preserves the life of your monitor.

To set preferences 

1. Click the Special menu.



2. Click "Preferences" to display the preferences dialog box.
3. Click to check or uncheck each checkbox and option button you want.
4. Click This Session to save your changes for this session only, or click Permanently to 

permanently save your changes, or choose Cancel to return to Windows Express 
without saving your changes.

Related Topics:
Special Menu

Preferences



Screen Saver
The screen saver feature blanks out your computer screen if there has been no activity for a minute or 
more.    This convenient feature helps to save your monitor from having images permanently etched onto 
the screen.    To use the screen saver, click the Screen Saver icon in the preferences dialog box.    By 
default, this setting is disabled.    

Related Topics:
Special Menu

Preferences



Passwords
At some points while youre working (e.g., when you try to open a master folder, execute an 
application item, or open a folder item), Windows Express may display the Passwords 
window.    The window    is displayed according to settings made by the person who set up 
your Windows Express system.    In order to proceed, you must first enter the correct 
password.    If you don't know the correct password for an item, contact the person who set 
up your Windows Express system.

To enter a password for an item

1. Type the item's password in the text box.
2. Click OK.

-or-
Click CANCEL to abandon the operation which generated the password request.

Related Topics:
Selecting Items
Opening a Master Folder



Converting Old Files
If you try to open a master folder that was created in a previous release of Windows Express,
you will get a warning dialog box that asks you if you want to convert the file to the new 
format and give it a new name.    If you click OK, the Save File As dialog box will be 
displayed.    This dialog box allows you to name and convert the file.

To convert an older    file into the new format:

1. In the File Save As box, type the new filename, in the text box
2. In the Directories listbox, click the directory in which you want to save the file.
3. Click the Convert button to convert the file to the new format, or click Cancel to exit 

the window without converting the file.
4. If you save the converted file to the same name and location as the old file, you will 

receive a warning dialog that asks you if you want to replace the existing file.    Click 
Yes or No.    No will return you to the File Save As box to type a new name or choose a
new location.

5. If you decide not to convert the file, click CANCEL in the File Save As box to abandon 
the conversion.

Related Topics:
Opening a Master Folder



System Information
The System Information dialog box displays information on your current hardware and 
Windows configuration, including the amount of available memory, disk space, and system 
resources.    





folder item

An item in a Windows Express folder that displays another folder.



folder name

The name appearing on the folder tab of a Windows Express master folder.    Also, the name of the folder 
item.



function keys

The keyboard keys labeled F1 through F10.    Some keyboards may have more function keys.



icon

A small graphic used to depict a folder or an application item.



master folder

The first, or top-most, folder displayed on your screen, which contains all of the application and folder 
items.



selection key

The character next to the application or folder item that corresponds to a key on the keyboard.    You press
the selection key to select the item.



status line

A line near the top of the Windows Express window that displays the current date, day and time.



active window

The window that will be affected by the next keystroke or command.    When a window is active, its title 
bar changes color to differentiate it from other open windows.



application
A program used to accomplish a specific task.    For example, a word processor or spreadsheet program.



application item

An item in a Windows Express folder that runs an application.    The application may be a Windows or 
non-Windows application.    



checkbox

A small square in a dialog box that specifies whether or not the option next to it is selected.    The option is
selected if the check box is filled in.



click

To press and release the mouse button.



control menu

The drop down menu that appears in the upper left corner of the Windows Express window, and which is 
represented by an icon that looks like a small horizontal bar.    Most window, and some dialog boxes have 
their own Control menu.    Commands on the Control menu allow you to move, resize and close a window.



command

An item that appears on a drop-down menu that you choose to carry out a specific activity, such as "Exit" 
or "Preferences...".



dialog box

A window that appears when Windows Express, or any other Windows application, needs more 
information before it can carry out a command.    A dialog box may contain a list box, check box, text box, 
and option buttons, or any combination of these.



document

A file created with either a Windows or non-Windows application.



double click

To quickly press and release the mouse button twice in succession.



drop-down menu

A menu, that when selected, "drops down" on the screen displaying commands that can be chosen.



filename

The name of a document.    A filename can have up to eight alphanumeric characters, plus an extension.   
An extension begins with a period and can have up to three characters.    For example, MYFILE.DOC 
specifies the document MYFILE and a filename extension of .DOC.



keyword

An underlined term appearing in a description in the Help window for which you can display a definition.



list box

An area in a dialog box which contains a list of items for you to choose from, such as files or directories.



non-Windows application

An application that does not require Microsoft Windows in order to run.



option button

A small circle in a dialog box that specifies whether or not the option next to it is selected.    The option is 
selected if the option button is filled in.



pathname

The name and location of a file, including the filename, directory, and drive locations.    A full pathname 
includes a drive letter followed by a colon, one or more directory names separated by a backslash (\), and
a filename.    For example, C:\WINDOWS\MYFILE.DOC.



Quick Key

A function key, F2 through F9, that when pressed, automatically chooses an application or folder item.



scroll

To move the contents of a window up and down,or left and right using a scroll bar or the DIRECTION 
keys.



scroll bar

A narrow area on the right side of a window showing an arrow at each end and a small box between the 
arrows.    In Windows Express, the scroll bar appears only if the entire contents of a folder are not visible.



text box

A box within a dialog box where text is typed.



Windows application

An application that requires Microsoft Windows in order to run, such as Windows Express, Windows 
Write, and Word for Windows.



Windows shell

The Windows application which automatically appears whenever you start Windows. Unless specified 
otherwise, the Windows shell is Program Manager.



Express Command Builder

The Command Builder provides an easy way to construct Enhanced Commands without 
knowing any special command syntax.    Although you may not use the Command Builder 
every time you create a command, it simplifies the process of building complex 
commands.    The Command Builder is usually accessed by clicking the Command Builder 
button.

The Command Builder contains seven buttons, described below.

Applications & Documents    Lets you select the executable and document files you 
want to launch.    See Applications & Documents

MicroApps    Lets you select the MicroApps from Express Systems and other software 
vendors you want to launch.    See MicroApps

Scripts    Lets you select the pre-defined scripts you want to launch.    See Scripts

Replacement Variables  Lets you create dialog boxes that prompt you for a filename 
or parameter when you launch an application.    It also lets you access any of the 
environment variables currently set on your system.    See Replacement Variables

Enhanced Command Parameters    Lets you control the way an application is 
launched, including its size, position on the screen, and much more.    See Enhanced 
Command Parameters

Enhanced Command History  Displays the last 20 Enhanced Commands you've run 
using the Launch... command.    See Enhanced Command History

Macro Recorder    Lets you record macros containing keystrokes and mouse actions.    
See Macro Recorder

The Command Builder also contains two dialog boxes.

MicroApp Path dialog box
Script Library Path dialog box



 Applications & Documents
This portion of the Command Builder lets you select applications and/or documents to 
launch.    When you click the Applications & Documents button (or press ALT+A), the 
Command Builder displays the options described below.

Show box Specifies the files displayed in the Files box.    To change the 
display, type the new filename (including wildcard characters, if 
you want) and press ENTER or click the Check button.
You can also use this box to change the current path:    simply 
type the new drive or directory name, and press ENTER or click 
the Check button.

Check button Updates the Files and/or Directories boxes to reflect the 
contents of the Show: box.

Directory Displays the current drive and directory.

Files box Displays the files contained in the current directory.    Use the 
mouse to select as many files as you want.    To select files that 
aren't adjacent (for example, the third and fifth files in the list), 
hold down the CONTROL key and click the mouse.

Directories box Changes drives or directories.    To return one level toward the root
directory, click "[..]".

Use Full Path
option Builds the command using the full pathname.    Turn this option on

if you've selected an executable or document file that is not on 
your DOS search path.

Related topics
Command Builder
Syntax for launching applications and documents



 MicroApps 
This portion of the Command Builder lets you select the MicroApps you want to launch.    It 
also gives you a brief description of each MicroApp, and lets you set the MicroApp path.    
When you click the MicroApps button (or press ALT+M), the Command Builder displays the 
options described below.

MicroApps box Lists the MicroApps currently on the MicroApp Path.    Use the 
mouse to select the MicroApps you want to launch.    To select 
MicroApps that aren't adjacent (for example, the first and third 
MicroApps in the list), hold down the CONTROL key and click the 
mouse. 

Describe button Displays the version number and a brief description for the 
selected MicroApp.

MicroApp Path
button Displays the MicroApp Path dialog box.

Related topics
Command Builder
Syntax for launching applications and documents



 Scripts 
This portion of the Command Builder lets you select and launch pre-defined scripts.    When
you click the Scripts button (or press ALT+S), the Command Builder displays the options 
described below.

Scripts box Lists the scripts currently on the Script Library Path.    Use the 
mouse to select the scripts you want to launch.    To select scripts 
that aren't adjacent (for example, the third and fifth in the list), 
hold down the CONTROL key and click the mouse. 

Describe button Displays a brief description of the selected script.

Library Path button Displays the Script Library Path dialog box.

Reference By
buttons Determines how the scripts appear in the Scripts box.    Script 

lists the scripts by name;    Library and Script lists them by 
library and script name.    The Library and Script option is useful
if you've got more than one script library and want to determine 
the scripts contained in any given library.

Sort By Library
option Sorts the scripts according to the order they appear on the Script

Library Path in the Script Library Path dialog box.    This is useful 
if you've got multiple script libraries and want to see the order in 
which they will be accessed.

Related topics
Command Builder
Script synta



 Replacement Variables 
This portion of the Command Builder lets you create dialog boxes that prompt you for a 
filename or other command parameter when you launch an application.    It also lets you 
access any of the environment variables currently set on your system.    When you click the
Replacement Variables button (or press ALT+V), the Command Builder displays the options
described below.

File Prompt
edit controls Create a dialog box that prompts you for a filename when you 

launch an application.    Wildcard controls the type of files 
displayed in the dialog box.    To specify multiple wildcards, 
separate them with a semicolon.    Caption sets the text that 
appears in the dialog box's title bar.    The Check button adds the 
contents of these boxes to the Command: box.
IMPORTANT:  As with any command line parameter, you must 
leave a space after the executable filename;    make sure to 
manually insert a space before the replacement variable. 
For example, you might want to launch Write and bring up a 
prompt displaying your .WRI and .TXT files.    First type write in the
Command: box, followed by a space.    Next, type *.wri;*.txt in 
the Wildcard box and Select an INI file in the Caption box.    
Then press the Check button to update the Command: box.      
See also Replacement variable syntax: file().

Parameter Prompt
edit controls Create a dialog box that prompts you for a parameter to pass to 

the application when it is launched.    Use the Default box to 
specify the default parameter.    The Text box specifies the text 
string that appears in the dialog box.    The Check button adds the
contents of these boxes to the Command: box.
For example, you might want to launch Word for Windows and 
pass it a parameter that opens the file you last closed.    First, 
type winword in the Command: box.    Next, type /mFile1 in the 
Default box and Run this WinWord macro? in the Text box.    
Then press the Check button to update the Command: box.    See
also Replacement variable syntax: text().

Environment
Variables box Lets you select the environment variables currently defined on 

your system.    To select variables that aren't adjacent, hold down 
the CONTROL key and click the mouse.    
For example, excel: initdir={env(windir)} will set Excel's initial 
directory to the value of the WINDIR environment variable.    See 
also Replacement variable syntax: environment variables.

Other options box Returns various text strings.    {date} returns the date in 
mm/dd/yy format.    {time} returns the time in hh:mm:ss format. 
For example you could create a date and time stamp in a Write 
document with the command:
write; "Date:{date}<Enter>Time:{time}"
See also Replacement variable syntax: date, time.



{lasttext} returns the text string you last specified from a 
prompt created with the Parameter Prompt controls (described 
earlier in this topic).    In the example cited earlier, for example, 
{lasttext} would return /mFile1.  {lastfile(dpfe)} returns the 
drive, path, file, and extension of the file you last selected from a 
prompt created with the File Parameters controls (described 
earlier in this topic).    For example, you could create a command 
that inserts a header listing the name of the text file you selected
from the file prompt dialog box:
notepad {file(*.txt,dpfe,"Select a textfile")};"Filename:{lastfile}"
See also Replacement variable syntax: {lastfile}, {lasttext}.

Related topics
Command Builder
Syntax for replacement variables



 Enhanced Command Parameters 
This portion of the Command Builder lets you control the way an application or document 
is launched, including:

* How the application is displayed:    maximized, as an icon, hidden, and more.
* Where the application is launched (absolute or relative position) and the exact size of 

the application's window.
* What to do if the application is already running:    use the existing version, run a new 

version, and so on.
* What you want to display for the application's window caption and minimized icon. 

When you click the Enhanced Command Parameters button (or press ALT+P), the 
Command Builder displays the options described below.

Show Normal box This drop-down list controls the way the application is displayed 
after it's launched.    See also Enhanced Command Parameters: 
display logic.
* Show launches the application using either the Icon 

Maximize or Center parameter, depending on the application.
Most applications will use Icon Maximize, but non-sizable 
applications and applications with small windows (like Control 
Panel and PIF Editor) will use the Center parameter.

* Hidden launches the application and hides its window.    
* Icon Maximize runs the application and maximizes its window

leaving room for icons to appear at the bottom of the screen.
* Maximized runs the application and enlarges its window to fill 

the entire screen.
* Minimized launches the application and shrinks its window to 

an icon.
* Center positions the application's window in the center of the 

screen. 

Use Existing box This drop-down list controls the logic used to handle applications 
that are already running.    If you're launching an application that 
is already running, Use Existing will not run a second instance.    
For example, if you're opening a Write document while Write is 
already running, using this option loads the document in the 
existing instance of the application.    If the application you're 
launching is not running, the Use Only Existing option ignores 
the command.    If the application you're launching is already 
running, New Instance will run a new copy of the program.      
See also Enhanced Command Parameters: instance logic.

Zoom box This drop-down list controls whether or not the application's 
window "zooms" when it is launched.    Some applications may 
have problems if Zoom is on;    if so, use the No Zoom option.      
See also Enhanced Command Parameters: zoom logic.

X and Y, Width
and Height boxes These determine how an application is sized and positioned when 

it is launched.    You can specify any parameter in absolute terms 
(expressed in pixels) or relative terms (expressed in a percentage 
of the screen size).    You can specify parameters numerically by 



typing them, or graphically using the Position button.

X and Y  Control the vertical and horizontal position of the 
window.    For example, if X=0 and Y= 32, the left (or vertical) 
border of the application's window will appear on the first pixel, 
while the top (or horizontal) border will appear on the thirty-third 
pixel.    Width and Height determine the size of the window, 
expressed in number of pixels or percentage of screen size.        
See also Enhanced Command Parameters: window size and 
position.

Position button Using the Position button is probably the easiest way to size and 
position an application's window.    
Clicking the Position button brings up the Position and Size Tool 
window.    To size an application's window, point to a border or 
corner of the Position and Size Tool window and drag it until it is 
the size you like.    To position an application's window, drag the 
title bar to the location where you want the application to appear. 
Press ENTER (or choose the OK button if it's visible) to save your 
changes.

DDE Execute box Sends an initial DDE Execute string to an application.    The DDE 
topic is "system" and the application's name is the same as the 
executable filename.    For information on the DDE syntax for a 
specific application, consult the application's documentation.    For
example, excel:usee,dde=("[INSERT(1)]") sends a DDE string to 
Excel that inserts a column.    See also Enhanced Command 
Parameters: DDE.

Initial Directory box Determines the directory used to launch an application.    You 
may want to set an application's initial directory to the DOS 
directory containing the files you want to open.    For example, if 
you store all of your spreadsheet files in one directory, you could 
set the initial directory for Lotus 1-2-3 so that it defaults to that 
directory.      See also Enhanced Command Parameters: initial 
directory.

Icon box Determines the application's icon, allowing you to replace the 
default icon with one from another application.    You can use 
icons from any file that contains them, 
including .EXE, .ICO, .ICN, .IL, and .DLL files.    To specify an icon, 
type the filename (and path, if necessary) of the file whose icon 
you want to use; for example, clock:icon=bigben.ico.
If the file contains more than one icon, insert a comma and the 
number of the icon you want to use.    For example, 
pbrush:min,icon=(progman.exe, 11); launches Paintbrush and 
substitutes an icon from PROGMAN.EXE in place of Paintbrush's 
icon.    See also Enhanced Command Parameters: application icon.

Caption box Determines the caption for the application's window and the label
for the application's minimized icon.    Type the caption as you 
want it to appear.      See also Enhanced Command Parameters: 
caption.



Related topics
Command Builder
Syntax for Enhanced Command Parameters



 Enhanced Command History 
When you click the Enhanced Command History button (or press ALT+H), the Command 
Builder displays the last 20 commands you've launched from the Command Builder.    
Select as many commands as you like.

Related topics
Command Builder



 Macro Recorder 
This portion of the Command Builder lets you record macros containing keystrokes and 
mouse actions.    Macros are useful for automating repetitive tasks.    For example, you 
might create a macro that launches the Windows Control Panel, opens the Printer setup 
and sets the page orientation to landscape.    

When you click the Macro Recorder button (or pressing ALT+M), the recorder begins 
recording and displays its control panel.    The recorder's control panel "floats" over the 
active window in order to remain visible.    As you record your macro, the Enhanced 
Command will appear in the control panel.    To temporarily stop the recorder, click the 
Pause button;    when you're ready to resume recording, click the Pause button again.    To 
stop the recorder, click the Stop button.

Notes on recording macros
* As with any macro recorder, keyboard macros are generally more reliable than macros

containing mouse actions.    For that reason, as you record your macro it's best to use 
keystrokes whenever possible.

* Should you need to position a window (or configure some other portion of Windows) 
after you've begun recording, press the Pause button to temporarily stop recording;    
when you're ready to resume recording, just press the Pause button again.    

* To stop the playback of a macro, press the ESC key.    You'll receive a prompt 
confirming your decision to stop the macro.

* Keep in mind that you can easily edit your macros. For example, if you've made a 
mistake while recording a macro, just press the Pause button, move the insertion point
into the recorder's control panel and delete the error.    When you're ready start 
recording, press the Pause button again.

* To achieve the best results, you should prepare your screen before you begin 
recording a macro.    If there are windows on the screen that aren't part of the macro, 
move them out of the way or close them before you begin recording.    

* Should you need to slow down the playback of a macro, you can insert one of the 
[Pause] scripts into a macro. 

* The macro recorder does not record certain actions, such as mouse drags.    Also, it 
cannot record mouse actions involving the toolbar in some programs such as Word for 
Windows.

Related topics
Command Builder
Macro syntax



MicroApp Path dialog box

Use this dialog box to specify where your MicroApps are located;    for example, you might 
type C:\WINDOWS\MICROAPP.    If your MicroApps are stored in more than one location, 
separate each path with a semicolon.

Related topics
MicroApps



Script Library Path dialog box

Use this dialog box to specify where your scripts are located, and in what order they should
be searched.    

Filename(s) box Specifies the files displayed in the Files box.    To change the 
display, type the new filename (including wildcard characters, if 
you want) and press ENTER.    You can also use this box to change 
the current path:    simply type the new drive or directory name, 
and press ENTER.

Directory Displays the current drive and directory.

Files box Displays the files contained in the current directory.    Use the 
mouse to select as many files as you want.    

Directories box Changes drives or directories.    To return one level toward the root
directory, click "[..]".

Add button Adds the selected files to the Script Library Path.

Remove button Removes the selected files from the Script Library Path.

Script Library
Path box Displays the script libraries currently on the path.    Libraries are 

searched in the order specified in the list.      If the same script 
appears in multiple libraries, the script appearing first on the path
is used.

Arrow buttons Changes the order of the script libraries currently highlighted in 
the Script Library Path box.    Script libraries are searched in the
order in which they appear in this box.

Related topics
Scripts



Remap Key dialog box

This dialog box lets you select characters from the ANSI character set and paste them onto
the Clipboard.    You can select a character using either your mouse or the arrow keys on 
your keyboard.    To copy the character to the Clipboard, choose the Select button or press 
ENTER.



Text Prompt dialog box

This dialog box appears when you've launched a command that includes a parameter 
prompt.    To launch the application with the specified parameter, choose the OK button.    
To launch the application without a parameter, choose None.    To escape without launching
the command, choose Cancel.    

Related topics
Replacement Variables



Enhanced Command syntax

Although the Command Builder lets you create commands using buttons and other 
graphical controls, you may find that using the Enhanced Command syntax lets you work 
more quickly.    Additionally, knowing the syntax enables you to do a few things that aren't 
possible with the Command Builder, such as call a function in a Dynamic Link Library 
(.DLL) file.

Application and document syntax
DOS command syntax
Enhanced Command Parameter syntax
Dynamic Link Library (.DLL) syntax
Macro syntax
Replacement variable syntax
Script syntax
Adding comments to an Enhanced Command

TIP:    You can use the Copy command from the Edit menu in Windows Help to copy any of 
the sample commands listed in this section, and then run the command by pasting it into 
the Launch: box.

The syntax conventions are listed in the following table.

Convention Example Description
Boldface useexist Text that must be typed exactly as it appears.
Italic height A general placeholder for information that you provide.
[      ] [, arg] An optional command element.    Do not type the brackets 

themselves (except for the brackets that surround Scripts).
... [keystroke]... Indicates that the preceding element can be repeated 

several times.    You can repeat any number of keystrokes.    
Do not type the ellipsis (...) itself.

| zoom    |    nozoom Separates items in a group of mutually exclusive elements.    
Choose only one of the items from the group.    Do not type 
the pipe symbol (|) itself (except for the pipe that delineates 
a Comment).

clock:min,usee This font is used to illustrate Enhanced Command examples.  
You can copy commands from online Help, paste it directly 
into a Launch: box, and edit the example to fit your needs.



Application and document syntax

In addition to launching applications and opening documents, you can optionally pass DOS
command line parameters and send Enhanced Command Parameters to an application.    
Enhanced Command Parameters are preceded by a colon and must be separated by 
spaces or commas:

app-spec [app-parms] [: eparm] [ [,] eparm]...
Keep in mind that Enhanced Commands also accept replacement variables: parameters 
and functions that let you specify filenames, parameters, and more.

The app-spec syntax is:
[path]filename    |    replacement-var

Example
This example will launch Excel and open the document named Q1SALES.XLS.    

c:\sales92\q1sales.xls

The app-parm syntax is:
command-line-parms    |    replacement-var

Example
This example launches Word for Windows and opens the last document you closed.    

winword /mFile1

Related topics
Enhanced Command syntax



DOS command syntax

You can run several "internal" DOS commands from an Enhanced Command, without 
running a DOS session.    The DOS commands are listed below.    For complete information 
on DOS commands, see your DOS User's Guide.

Command... What it does:
copy Copies a file.
move, mv, rename, ren Moves or renames a file.
delete, del, erase Erases a file.
mkdir, md Creates a directory.
chdir, cd Changes the current directory.
rmdir, rd Deletes a directory.
ddel Deletes a directory and any files or subdirectories it contains.
dir Uses Windows File Manager to display the current directory 

contents.

Notes
* Be careful when deleting files or directories:    you will not receive a confirmation 

prompt!
* To display the current directory contents using a DOS box instead of the Windows File 

Manager, add the line DOSBOXDir=1 to the [File Manager] section of the HDC.INI file. 

Related topics
Enhanced Command syntax



Enhanced Command Parameter syntax

In addition to launching an application and specifying DOS command line parameters, you 
can also send it Enhanced Command Parameters.    These parameters are preceded by a 
colon and may be separated by spaces or commas:

app-spec [app-parms] [: eparm] [ [,] eparm]...
Enhanced Command Parameters fall into several logical groups, many of which contain 
mutually exclusive options;    for example, a window cannot be both minimized and 
maximized.    If conflicting options are specified, the parameter appearing last will override
any that precede it.    You can substiture unambiguous abbreviations (such as h for hidden
and usee for useexist) for parameters.

You can set default Enhanced Parameters--globally or for specific applications--in the 
HDC.INI file.    The global defaults are useexist, show, usee, zoom, and env=full.

Enhanced Command Parameters
caption
close
dde
env
forcesize
hidden
icon
imax
initdir
keys
max
min
newinst
nozoom
pos
show
useexist
useonlyexist
wait
zoom

Related topics
Enhanced Command syntax



Enhanced Command Parameters:    instance logic

useexist    |    useonlyexist    |    newinst
Determine what to do if you try to launch an application that is already running.    The 
useexist parameter tries to send the command to an application that is already open;    if 
the application is not open, the application is launched.    useonlyexist forces the 
Enhanced Command to use an existing instance of the application;    if none is open, the 
command does not run.    newinst launches a new instance of the application.    The 
shortest unique abbreviations are usee, useo, and ne, respectively.

Example
This example will activate the existing instance of Windows Write and change its 
caption to "Testing."    If Write is not open, it will launch the application.    

write: usee,caption="Testing"

Related topics
Enhanced Command Parameter syntax



Enhanced Command Parameters:    display logic

show    |    hidden    |    max    |    imax    |      min    |    center
Determine how the application window is displayed.    Each parameter is explained below:

Parameter... Abbreviation Displays the window:
show s Displays the window using either imax or center, 

depending on the application.    Most applications will use 
imax, but non-sizable applications and applications with 
small windows (like Control Panel) will use center.

hidden h Hidden.
max ma Maximized.
imax im Maximized with room for icons at the bottom of the 

screen.
min mi Minimized.
center ce Centered.

Examples
This example will launch Word for Windows and hide its window.      

winword:h

This example will launch CorelDRAW and maximize its window, leaving room for icons 
at the bottom of the screen. 

coreldrw: im

Related topics
Enhanced Command Parameter syntax



Enhanced Command Parameters:    zoom logic

zoom    |    nozoom
Determine whether or not the application window "zooms" when it is launched.    The 
shortest unique abbreviations are z and noz.

Example
This example will launch the Windows Control Panel and zoom its window.      

control: zoom

Related topics
Enhanced Command Parameter syntax



Enhanced Command Parameters:    closing an application

close
Closes an application.    The noclose parameter overrides close.    The shortest unique 
abbreviations are cl and noc.

Example
This example will close an existing instance of Write.      
write: useonlyexist, close;

Related topics
Enhanced Command Parameter syntax



Enhanced Command Parameters:    application caption

caption= "caption"    |    default
Sets the caption for the application's window and icon.    The caption may include 
replacement variables.    Choosing default overrides any caption setting in HDC.INI and 
allows the application to set its own caption.    The shortest unique abbreviation is ca.    

Example
This example launches Notepad and inserts the date into Notepad's caption. 

notepad:caption="Opened on {date}"

Related topics
Enhanced Command Parameter syntax



Enhanced Command Parameters:    initial directory

initdir=initial-directory
Sets the initial directory for the application and for any replacement variables.    The 
shortest unique abbreviation for initdir= is in=.

Example
The following example launches Excel and sets the initial directory to C:\BUDGET. 

excel:initdir=C:\BUDGET

Related topics
Enhanced Command Parameter syntax



Enhanced Command Parameters:    window size and position

pos= ( [x[%]], [y[%]] [, [width[%]], [height[%]] ] )    |  default
Positions and sizes the application window.    Each parameter must be an integer and can 
be expressed in absolute terms or as a relative percentage of the virtual screen size.    
Specifying parameters that are outside the boundaries of the current screen will position 
the application's window in another portion of the virtual desktop.    Choosing default 
allows the application to position and size itself.    The shortest unique abbreviation for 
pos= is p=.

Examples
The following example launches Paintbrush and positions it on the virtual desktop to 
the right of the upper left-most screen.    This command positions the window in 
absolute terms based on the display resolution.      

pbrush:pos=(640, 0) 
If you frequently change your video display driver resolution, you should position your 
application windows using the method shown in the next example.    Unlike the previous
example, this command positions the window as an absolute percentage of the virtual 
screen size.

pbrush:pos=(100%, 0)

Related topics
Enhanced Command Parameter syntax



Enhanced Command Parameters:    keystrokes

keys= "[keystroke]..."
Sends any number of keystrokes (such as a string of characters or a macro command as 
described later under key-stream) to the application.    Unlike the key-stream Enhanced 
Command used in the macro recorder--which sends keystrokes to the application currently 
active--this parameter sends keystrokes to a specific application.    In addition, it is the only
way to send keystrokes to a hidden application.    The shortest unique abbreviation for 
keys= is k=.    

Example
The following example send the text string enclosed in quotes to Word for Windows. 

winword:keys="From the desk of Jane Doe"

Related topics
Enhanced Command Parameter syntax



Enhanced Command Parameters:    application icon

icon= (ICON-filespec[.ico]    |    IL-filespec [, icon-number] )
Allows you to specify the icon you want to display for a minimized application.    "ICON-
filespec" refers to an icon file (.ICO) containing a single icon.    "IL-filespec" may be any file 
that contains an icon, such as an Icon Designer library (.IL), an application (.EXE), or a 
Dynamic Link Library (.DLL).    If "icon-number" is not specified, the first icon in the file is 
used.    The shortest unique abbreviation for icon= is ic=.

Example
The example below launches Notepad, which when minimized will display the 18th icon
from the file named PROGMAN.EXE.

notepad: icon= (progman.exe, 18 )

This example launches Solitaire, which when minimized will display the icon for 
Windows Write.

sol.exe: icon=(c:\windows\write.exe)

Related topics
Enhanced Command Parameter syntax



Enhanced Command Parameters:    environment

env= full    |    (envvar [= [value] ]    [,envvar [= [value] ] ]... )
Sets the application's environment.    The default environment is full, which provides the 
application with the complete DOS environment.

You can use the env= parameter in an Enhanced Command to minimize the launch 
environment, thus reducing the memory that is used by an application.    For example, you 
can specify an environment that contains only the certain variables from the DOS 
environment by leaving its value field empty;    for example, env=(COMSPEC, PATH=) 
specifies that COMSPEC is to be included, and that PATH is to be removed.    The specified 
environment cannot be larger than the original DOS environment.    

The shortest unique abbreviation for env= is e=.

Related topics
Enhanced Command Parameter syntax



Enhanced Command Parameters:    forcesize

forcesize 
Some applications don't allow themselves to be sized or positioned if, during their last 
session, they were closed while the window was maximized; examples include Microsoft 
Excel and Windows File Manager.    Other applications (such as Lotus 1-2-3) do not allow 
themselves to be sized or positioned at all.    The forcesize parameter allows you to size 
and position such applications.    The noforcesize parameter will override forcesize (if 
forcesize were the HDC.INI default, for example).    The shortest unique abbreviations are 
f and nof.    

Example
The following example runs Lotus 1-2-3 sized and positioned: 

123w.exe:imax,f

Related topics
Enhanced Command Parameter syntax



Enhanced Command Parameters:    wait

wait 
In an Enhanced Command that launches multiple applications, this parameter waits until 
one application is finished before processing the next part of the Enhanced Command.    
This is particularly useful when running DOS commands.    The parameter nowait runs the 
command normally.    The shortest unique abbreviations are w and now.

Example
The following example runs A.BAT, waits until it is finished, then runs B.BAT: 

A.BAT:wait;B.BAT

Related topics
Enhanced Command Parameter syntax



Enhanced Command Parameters:    DDE (Dynamic Data Exchange)

dde= ( "execute-string" [, "topic" [, "application"] ] )
Sends execute-string as a Dynamic Data Exchange execution to an application.    The DDE 
"application" name defaults to application's filename, and the topic defaults to "system."    
The shortest unique abbreviation for dde= is d=.

Example
This example sends a DDE string to Excel that inserts a column.    You could perform the
same action using Express' macro recorder, but using DDE is slightly faster and less 
obtrusive, since you don't see the menu drop down, the dialog box open, etc.

excel:s,usee,z,dde=("[INSERT(1)]")
This example takes a selected, tab-delimited table in a word processing application 
such as Write or WinWord, charts it with Excel (which remains hidden), and pastes the 
chart into the original document.    

"<Menu=Edit-Copy>"; excel: h, dde=("[PASTE()][NEW(2,2)][COPY()]
[CLOSE(0)][CLOSE(0)]"), close; "<Down><Menu=Edit-Paste>" 

Related topics
Enhanced Command Parameter syntax



Dynamic Link Library (.DLL) syntax

An Enhanced Command may call a function from a Dynamic Link Library (.DLL) file.    You 
can use the shortcut win.dll to call any Windows function contained in USER.DLL, GDI.DLL,
or KERNEL.DLL.    

dll-spec.dll procname( [ dll-arg[, dll-arg]... ] )

dll-arg
You can pass arguments to a DLL function using a decimal or hexadecimal number, or 
using a string.    The specific number and type of arguments depend upon the procedure.

[ - ]decimal-num[L]    |    0xhex-num[L]    |    "string"

The L must follow decimal-num or hex-num if and only if the function requires a long 
integer argument.    

Examples
The following example will sound a system message beep.
win.dll MessageBeep(0)

The next example calls a function in Express' Dynamic Link Library (HDCLIB.DLL) that 
displays a message box.
hdclib.dll hDCMessageBox(0,"Your message goes here","Caption",0,0L,0L) 

The last example will restart Windows.    (Calling this function ends the current Windows
session immediately without displaying a confirmation prompt.)
win.dll ExitWindows(0x42L, 0) 

Related topics
Enhanced Command syntax



Adding comments to Enhanced Commands

Each Enhanced Command may include a comment.    Comments must be preceded by a 
pipe symbol (|).    Any text between the pipe and the semicolon that terminates the 
command will be ignored.    For example:

notepad: min, newinst | starts minimized notepad;

Related topics
Enhanced Command syntax



Macro syntax

Macros use a key-stream, which is a sequence of keystrokes surround by quotation marks:

"keystroke[keystroke]..."

Each keystroke may be a printable character, a command combination, which is enclosed 
in <angle brackets>, or a replacement variable.      Listed below are the conventions used 
to translate keyboard and mouse actions into Enhanced Command syntax.

Keystroke convention Convention Example
Character

character notepad:"hello"
Non-printing keypress

<key-label> <Enter>, <F7>,<Space>
write:"Name<Enter>Address<Enter>"

Modifier + key    
<modifier - key> <Alt-a>, <Ctrl-Shift-End> control;"<Alt-S><Enter>"

Menu selection
<Menu=choice[-choice]...> <Menu=File-Open> pbrush;"<Menu=File-Open...>"
<Sysmenu=choice[-choice]...> <Sysmenu=Exit>

excel;"<Sysmenu=Restore>"
Button press

<Button=button-name> <Button=OK> charmap;"<Button=Select>"
Move window

<Move=title-xpos,ypos> <Move=Notepad-200,200> clock;"<Move=Clock-
200,200>"

Size window
<Size=title-width,height> <Size=Notepad-400,250> clock;"<Size=Clock-400,250>"

Mouse click
<Mouse[-pos]=[modifier-]click> <Mouse=Ctrl-Shift-LeftDbl>

pm4;"<Mouse=Right>"

The characters    ( ) [ ] { } < > | %    ^ - = ; :    have particular meanings within an 
Enhanced Command.    If you want to include one of these special characters within a 
keystream, precede it with a caret symbol (^).    For example, write; "Express Systems 
^"Partners in Group Productivity^"."
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Replacement variable syntax

Replacement variables let you create dialog boxes that prompt you for a filename or 
parameter when you launch an application or document.    They also lets you access any of
the environment variables currently set on your system.    Replacement variables take the 
form:

{ variable    |    function( [ arg[, arg]... ] ) }

You can use replacement variables when you launch an application, call a .DLL function, or 
send a keys=, caption=, icon=, initdir=, dde=, or env= parameter.    The replacement 
variable functions are listed below.

Replacement variables
{file()}
{text()}
{lastfile}, {lasttext}
{date}, {time}
{env()}
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Replacement variable syntax:    {file()}

This function displays a dialog that asks you to select a file.    The syntax is:

{file( wildspec [;wildspec]... [ , [d] [p] [f] [e] [, "prompt" ] ] )}

Wildspec determines which files (such as *.txt) are displayed in the Files box.    Note that 
you can specify multiple wildcards.    The caption for the dialog box's window is set by the 
prompt, which defaults to Choose document for <appname>.    The four parameters, d, 
p, f, and e, determine the portion of the pathname returned by {file()}.    A fully-qualified 
filename (dpfe) is the default.

Parameter: What it does...
d Requests the drive, including a trailing colon.
p Requests the path, including a trailing slash if used together with the f 

parameter.
f Requests the filename.
e Requests the extension, including a leading period if used in conjunction with f 

parameter.

Example
The following command will display a prompt containing the .WRI and .TXT files in the 
current directory.
Write { file( *.wri;*.txt, dpfe, "Choose a document" ) } 
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Replacement variable syntax:    {text()}

This function asks you to supply a string, which is substituted into the Enhanced 
Command.    The syntax is:

{text("default-text" [, "prompt" ] )}

It is important to note that the syntax of the string you've specified is not checked.    The 
default prompt is Parameters for <appname>.

Example
This command will bring up a text prompt specifying /mFile1 in a text box as the 
default parameter for WinWord (the parameter launches a WinWord macro that opens 
the document last opened). 
winword.exe {text("/mFile1","Run this macro?")}
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Replacement variable syntax:    {lastfile}, {lasttext}

The {lastfile} function returns the drive, path, file and/or extension of the file you've 
most recently selected using {file()}.    The syntax is:

{lastfile} [ ( [d] [p] [f] [e] ) ]

{lasttext} returns the text most recently specified via the {text()} function.    If you 
haven't called the {text()} function, no value is returned.

Example
This command inserts the name of the text file you selected from the file prompt dialog
box.
notepad {file(*.txt,dpfe)};"Filename: {lastfile}"
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Replacement variable syntax:    {date}, {time}

{date} returns the current date in mm/dd/yy format.    {time} returns the current time in 
hh:mm:ss 24 hour format.    

Example
The following command creates a date and time stamp in a Notepad document.
notepad; "DATE:{date}<Enter> TIME:{time}"

The next command launches Calendar and set its caption to the current date.
calendar:cap="{date}";

Related topics
Replacement variable syntax



Replacement variable syntax:    environment variables

You can insert environment variables into an Enhanced Command.    Percent signs surround
the variable you want to replace:

{env (ENVVAR) }

Example
This example sets Write's initial directory to the value of WINDIR . 
write: initdir={env(WINDIR)} 
The next example changes the directory to the value of WINDIR (that is, changes to the
Windows directory). 
cd {env(WINDIR)};
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Script syntax

Enhanced Commands can also execute the pre-defined scripts included with Windows 
Express.    If the library (.HSL) file containing the script is not on the Script Library Path, a 
command must explicitly reference the pathname.    The entire script reference must be 
surrounded by [ square brackets ].

[ [scriptlib!]scriptname ]

Example
The example will launch a script that minimizes all applications that are currently open.
[Minimize All] 

The next example will launch a script that cascades all currently-open applications. 
[sizing.hsl!Cascade All] 
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Enhanced Command 
A superset of the Windows command line that lets you launch 
applications, documents, MicroApps, scripts or macros.    
Enhanced Commands may also contain enhanced parameters 
or replacement variables. 



Command Builder button

Brings up the Command Builder for you to create an 
Enhanced Command using icons, buttons, and other graphical
controls.



Applications & Documents button (ALT+A)

Lets you select applications and/or documents to launch.    



MicroApps button (ALT+M)

Lets you select the MicroApps you want to launch.    It also 
gives you a brief description of each MicroApp, and lets you 
set the MicroApp path.



Scripts button (ALT+S)

Lets you select and launch pre-defined scripts.



Replacement Variables button (ALT+V)

Lets you create dialog boxes that prompt you for a filename or
parameter when you launch an application or document.    It 
also lets you access any of the environment variables 
currently set on your system.



Enhanced Command Parameters button (ALT+P)

Lets you control the way an application or document is 
launched, including its appearance (hidden, minimized, and so
forth), size and position, window caption, icon, initial 
directory, and more.



Enhanced Command History button (ALT+H)

Displays the last 20 commands you've launched from the 
Launch Command Line dialog box. 



Macro Recorder button (ALT+R)

Starts the macro recorder and brings up the recorder's control
panel.



Position button 

Appears in the Command Builder when you click the 
Enhanced Command Parameters button.    The Position button 
brings up a window for you to graphically set the size and 
position an application uses when launched.



Pause button 

Temporarily stops the macro recorder.



Stop button 

Stops the macro recorder and returns you to the Command 
Builder.



Check button 

Updates the contents of an edit control such as the Files box 
or Command: box.
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