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1.0 Introduction

Welcome to MGI's PhotoSuite, your personal photo publishing center where you can take your
favorite photos and transform them any way you want! Create anything from the simplest funny
photo cartoon, to the most impressive photo art - enhanced with dazzling new lens effects and the
Smart Magic Wand! Star in your own magazine cover. Design flyers for your garage sale, or
posters of your best friend. Did you know you can view your photos in as many different
multimedia albums as you like? Create a theme album of your wedding or family reunion, and
add music and video to create a multimedia slideshow. The possibilities are virtually limitless
with MGI PhotoSuite!

MGI PhotoSuite now includes so many tools and features that you will soon begin to think of
each photo you take as a blank canvas, just waiting to be “retouched” with your creative flair and
MGI PhotoSuite's own special magic. It's all at your fingertips. Consider the easy-to-use MGI
PhotoSuite interface as your own photo publishing console. MGI PhotoSuite makes it easy and
you make it fun.

Visit our Web Site!

Find out what's new with MGI PhotoSuite and MGI's other exciting software products! Our
website address is:

http://www.mgisoft.com

Customer Service

North America Europe

MGI Software Corp. MGI Customer Service
40 West Wilmot Street C/O Hoogoorddreef 68
Richmond Hill, Ontario  L4B 1H8 1101 BE
Canada Amsterdam Z.O.

The Netherlands

Telephone: 1-888-MGI-SOFT (644-7638) U.K.: (+44) 1 71 365 0034
Fax: (905) 764-3694 Germany: (+49) 69 9 509 6012

France: (+33) 1 41 91 38 07
Europe Fax (all): (+31) 20 430 3024
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Welcome to the World of PC Photography!

Get ready to experience photography in new and exciting ways – you and your family will be
amazed at how quickly and easily you can create amazing images and projects with MGI
PhotoSuite. Make your treasured photographs even more special. Transform or enhance the
pictures you take by altering colors, making collages, and more. Put your photos in frames, such
as posters, calendars and greeting cards. You'll see your photos in a whole new light – out of a
frame and into a screen saver, or within a school science report. Surprise yourself, impress your
friends & relatives, and create your own exciting new photo collection!

1.1 Creative Things You Can Do

There are many ways to take advantage of having your
photos on your computer. Here are some examples of
what you can do with MGI PhotoSuite.

Create personalized cards
for special occasions with
your photos in them.

Create calendars with your
photos in them

Create a
magazine
cover
with your
face on it

Create your
own rookie
card in the
sport of your
choice
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Easily apply special effects such as
crystallize.

Make a poster to find your lost cat or sell your home.

Use props
to highlight
that bright

idea

Make your photo look like an oil
painting. Viola, a masterpiece!
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Add your own
commentary with word

balloons

Turn your photo into a coloring
book. You can color it in with
MGI PhotoSuite tools or print it
and use crayons.

Create a crazy photo collage!

Move someone's head to the body of a superhero
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1.2 Getting Started

1.21 System Requirements

This is the hardware and software you need to get your MGI PhotoSuite up and running:

• 486 DX 33 or better

• Windows 3.1, Windows 3.11, Windows 95 or Windows NT

• Minimum 8 Megabytes of RAM

• Minimum 38 Megabytes of Hard Drive space

• CD-ROM drive

• Super VGA Monitor

1.22 MGI's PhotoSuite Contents

• MGI PhotoSuite software (includes program files, installer program, multimedia library, and
sample photos)

• Idea Guide & Reference manual

• Warranty Registration Card

1.23 Installation

Windows 3.x  or Windows NT 3.51

1. Insert the CD-ROM into your CD-ROM drive.
2. Open the CD-ROM drive letter using File Manager.
3. Locate and run the program “Setup.exe” by double clicking on this file. A message, “Setup

is initializing. Please wait” will appear on the screen. Follow the prompts to install MGI
PhotoSuite on your hard drive.

Windows 95 or Windows NT 4.0

1. Insert the CD-ROM into your CD-ROM drive. The MGI PhotoSuite installation dialog may
automatically appear, depending on the “Auto Insert Notification” setting in Windows 95 or
NT 4.0. If the installation dialog appears, proceed to step 3.

2. Using Explorer, locate your CD-ROM drive letter and view the files available on the CD.
Locate and run the program Setup.exe by double-clicking on this file. You should then
receive the “Setup is initializing. Please wait” message.

3. Click on the Install button, and follow the prompts to install MGI PhotoSuite on your hard
drive.
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1.24 How to Register

Don't forget to register your copy of MGI PhotoSuite. You'll find your product registration code
by loading MGI PhotoSuite, selecting “Work On Your Own” from the Activity Guide and then
choosing “About MGI PhotoSuite” from the Help menu.

Remember to record the product registration code of your MGI PhotoSuite software in a safe
place like the inside cover of this Idea Guide & Reference Manual. You will need this number
for Customer Support and to take advantage of special upgrade offers.

To register, fill in the registration card provided and send it to the appropriate address below.
You can also register by telephone (North America only), fax, e-mail, or at our web site. Find
your product code number by selecting “About MGI PhotoSuite” from the Help menu.

North America:

MGI Software Corp. MAILFAST
40 West Wilmot Street or MGI Software Corp.
Richmond Hill , Ontario YYZ / YYZ / 700248
Canada  L4B 1H8 PO Box 9018

Jericho, NY 11753-9521

Telephone: 1-888-MGI-SOFT (644-7638)
Fax: (+1) 905-707-3694
E-mail: register@mgisoft.com
Website: www.mgisoft.com/products/register

Outside North America:

TNT MAILFAST, YYZ/YYZ/700248/M01
Int. Antwoordnummer, C.C.R.I. Number 5120
3000 VB Rotterdam
The Netherlands

Fax: (+1) 905 707-3694

Why Register?

You will receive great benefits when you register your MGI PhotoSuite!

By registering, you will receive online technical support through Internet e-mail, or by fax. When
you become an MGI member, you may also get the latest information on product news, contests,
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promotional discounts, product tips and more. So there are many reasons why it's a good idea to
register your MGI PhotoSuite right away.

1.25 Technical Support

Need help? No problem. Simply consult the MGI PhotoSuite online manual by selecting
“Contents” from the Help menu. You can also obtain expert technical support from the addresses
below.

Our web site address is www.mgisoft.com for all areas.

North America
MGI Software Corp.
40 West Wilmot Street
Richmond Hill, Ontario
Canada L4B 1H8

Telephone: (905) 707-3573
Fax: (905) 707-3694
E-mail: support@mgisoft.com

Japan
Telephone: (+81) 3-3320-6821
Fax: (+81) 3-3320-2742

Europe
MGI Customer Service
C/O Hoogoorddreef 68
1101 BE
Amsterdam Z.O.
The Netherlands

Telephone: (+31) 20 430 3026
Fax: (+31) 20 430 3024
E-mail: eurosupport@mgisoft.com
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2.0 Tutorial

2.1 Taking Better Photos

There are so many impressive things you can do with your MGI PhotoSuite 8.0, but taking good
photographs is the first step. When you start with clear, well-composed photos, your MGI
PhotoSuite enhancements will be truly spectacular. It takes just a minute to set up a good shot.
Here are a few basic tips for new photographers:

Start with a Clean Lens

That may sound obvious, but surprisingly, it's the one thing many people don't consider when
they are taking pictures. Even though the lens may look clean, take an extra moment to really
make sure it is as clean as possible. Even the tiniest speck of dirt, smudge of sunscreen, or
fingerprint can ruin what might have been your most spectacular shot! So take care of your
camera with lens cleaner, lens cleaning tissue, a lens cleaning pen, or optical cleaning cloth. And
remember - never use regular cleaning tissue on your camera lens, as it may scratch the glass.

When is the Best Time to Shoot Outdoors?

The best times to take outdoor photos are in the early morning and late afternoon hours. These
are the times when the sunlight is softer, casting longer shadows, and enhancing your subjects
with a warm, rosy glow. The least effective time of day to take outdoor photos is high noon,
when the sun is at its strongest and brightest, casting harsher shadows and contrasts.

When you are composing a picture, consider the “Rule of Thirds”, particularly for showing depth
and balance in landscape photographs.
Mentally divide the view you see through the
lens into thirds, and put your primary subject
in the first or last third of your frame,
balancing the rest of your photo with the two
remaining thirds.

The Rule of Thirds. The first or third
boxes contain the primary view.
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Short Subjects? Get Down!

The next time you photograph pets, children or other small subjects, try taking the shot from a
new perspective. Keep the lens at their eye level. Crouch down to get the shot. You'll notice a big
difference.

Stay in Focus

Avoid taking blurred or out-of-focus shots by locking in (with an auto focus camera) on the part
of the shot that you want to be the sharpest. Hold the camera with both hands, squeezing the
shutter button gently. Remember, faster films allow you to freeze action (such as a swimmer's
dive) and require less light than slower film.

Going Lighter or Darker

If your photos appear too light, next time try standing further back when using a flash. If your
photos appear too dark, use a flash, and try standing closer to the subject. When shooting with a
flash, you should probably stand between 5 and 12 feet from your subject. Remember, always
wait for the “flash ready” signal before taking the next picture.

Also, make sure the film you're using is the appropriate one for the image you want to capture.
For example, for many bright outdoor shots, choose 100 ISO (ASA); for most indoor shots and
other outdoor shots, 200 ISO is best; and for indoor or outdoor shots where conditions are darker
or when you want to capture fast action (such as auto racing), a 400 ISO film might work best.

Better Indoor Pictures in a Flash!

If your subject appears too dark, it may be because you are photographing it beside a brighter
light source such as a window or lamp. Remember, the camera reacts to the brighter background,
so use your flash in such circumstances to avoid leaving the subject underexposed.

Get the Red Out

You can do something to prevent “red eye” effect when you take your photos. If there is enough
existing or natural light, try taking pictures without using a flash. Other tricks you can do include
having your subjects look off to one side instead of directly into the camera, or you can turn up
the room lights when taking flash photos to reduce the size of your subject's pupils. If you still
get “red eye”, simply remove it using MGI PhotoSuite.
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2.2 Putting Photos on Your Computer

2.21 Getting Your Photos on Disk or CD

Once your photos are on disk or CD you can load them into MGI PhotoSuite to improve the
quality of your photos. It's a snap to get your photos on disk or CD. Most photo developers have
the capability to transfer your photographs to either floppy disk or CD. Simply take your roll of
film to the photo developer and ask that the images be placed on floppy or CD. If your computer
has a CD-ROM drive, this may be the preferred medium, since CDs can hold more photographs
than floppies.

Here are some of the other ways you can get your images on your computer and into MGI
PhotoSuite:

2.22 From a Digital Camera or Scanner

MGI PhotoSuite makes it easy to open photos from any TWAIN compliant digital camera or
scanner. To do this,

1. First, install your digital camera or scanner software by following the instructions included
with your camera or scanner. Connect to your computer and turn it on, following the
instructions that came with your camera or scanner.

 
2. From MGI PhotoSuite's menu bar, select "File" then "Get Photos", then “From

Camera/Scanner...”.
 
3. MGI PhotoSuite will activate your camera or scanner and allow you to import your photos.
 
If you do not have a TWAIN compliant digital camera, follow the instructions supplied with your
camera and save your images to your hard drive. Once you have saved your photos, you can
bring your photos into MGI PhotoSuite by using the Open File button on the button bar.

For more information on accessing TWAIN devices, see section 7.3, TWAIN Support.
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2.23 From PhotoNet

Register with PhotoCenter's PhotoNet using MGI PhotoSuite's automated registering function.
PhotoNet is an on-line photo service that, in cooperation with your local photo developer,
processes your film into electronic images you can retrieve from the world wide web! Just take
your exposed film to any participating PhotoNet retailer and elect to have your processed photos
uploaded to an Online PhotoCenter home page. By accessing the Center on the Internet using a
secure code, you can view and download the photos of your choice for easy manipulation in MGI
PhotoSuite. You will also be able to send your photos via the Internet to family and friends!

Please note that this method of photo retrieval requires that you have an account with an Internet
service provider.
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2.3 Quick Tour

2.31 MGI Activity Guide

This is a fast-find visual menu of some of the more popular editing and photo enhancement
activities available to you in MGI PhotoSuite. The Activity Guide presents a menu of options for
accessing, viewing and printing your photos, and is your quick route to creating sports cards,
greeting cards, calendars, and magazine photos. As well, the Fun with your Images option at the
bottom right of the Activity Guide opens up a whole new series of activities you can do,
including special effects, lens effects, making a body switch, and adding picture frames, word
balloons, or funny props. The Activity Guide appears each time you start up MGI PhotoSuite
(unless you prefer to go directly to the MGI PhotoSuite workspace after clicking off the Show
Activity Guide at Startup checkbox at the bottom left of your screen). You can also access the
Activity Guide at any time while working in MGI PhotoSuite, either by clicking on the Activity
Guide icon (the last one on the button bar) or selecting  “Activity Guide” under the Fun menu.

The MGI Activity Guide is your window into MGI PhotoSuite's full range of creative photo
enhancement options and it is the starting point for selecting all of your photo activities. Get
ready for an amazing creative journey in which you are the artist, cartoonist, designer and photo
editor!

• Have your friend appear in a calendar and send it as a gift.

• Put your child's picture on the front of his or her birthday invitations

• Select the photo you want to work with and add a text caption, paint over it, or use any of
the amazing special effects that appear under “Fun” in the menu bar or on the button bar.

MGI PhotoSuite's Activity Guide makes it easy to have fun with your photos!
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 The activities are:

Get Photos - This allows you to transfer photos from disk or other sources such as a scanner,
digital camera or PhotoNet to your computer. See section 2.9, Get Photos.

Edit or Enhance Photos - This takes you to the MGI Photo Editor, where you have access to all
the tools you need to manipulate and enhance your photos.

View an Album - This takes you to your photo album to see your photos.

View a SlideShow - This lets you see your photo album in a slide show.

Print Your Photos - This allow you to print your photo.

Create a Sports Card - This lets you put a photo of your choice into a Sports Card.

Create a Greeting Card - This lets you put a photo into a Greeting Card.

Create a Calendar - This lets you put a photo of your choice into a Calendar.

Create a Magazine Cover - This lets you put a photo into a Magazine Cover.

Fun With Your Photos - This option calls up the dialog found below giving you more fun with
your photos:

WARNING !
Whenever you make changes to the image make sure to save it under a new filename using “Save
As” under the File menu. Otherwise you will lose the original copy of your photo.
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 2.32 MGI Photo Editor

This is your primary photo editing and enhancement desktop - the menus for all
MGI PhotoSuite functions. There is a Button Bar along the top of the screen and a Tool Bar
along the left side of the screen, where functions are represented by graphic icons for quick at-a-
glance selection (see the Quick Tour that follows for descriptions of these features). Many of the
actions you can select from the Button Bar (such as Open File) are also accessible from the word
list on the top Menu Bar.

 Button Bar Menu Bar Work Space Color Palette
 

 
 
 

 
Hide/Show Tool Palettes

You can customize the look of MGI PhotoSuite by clicking various options in the View menu. In
the example above, the “Show Color Palette” and “Show Tool Panel” options from the View
menu have been selected, giving you moveable floating palettes. You can also remove the Tool
sidebar, Color Palette sidebar and top Button Bar by clicking “Hide...” in the View menu, for
increased work space.

 Optional Floating
Color Palette view
 

 Tool
 Bar

 

 Optional Floating
Panel view

 Icon Tool Tip Help Line
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2.33 Button Bar

The Button Bar appears as a series of buttons or icons across the top of your screen and is a
handy shortcut for reaching many frequently used features. Select, manipulate and enhance your
images using the Button Bar. You can also access the same functions by selecting them from the
Menu Bar, located above the Button Bar on the top of your screen.

New Image
Provides you with a blank canvas from which you can create artwork.

Open Image
Opens the photo you want to use.

Save Image
Saves the image after you've made changes you want to keep.

Print Image
Prints the active screen image on the printer connected to your computer or network.

Cut
Cuts out a selected image or floating section to the clipboard.

Copy
Copies a selected image, area, or floating section to the clipboard.

Paste
Places selected images or areas from the clipboard to the workspace.

Mirror Image
Flips the entire photo or just a selected area horizontally.

Rotate Clockwise
Moves the entire photo or selected area 90 degrees.

Change Brightness
Alters the brightness level.

Image Enhance
Adjusts the level of contrast.

Apply Special Effect
Apply a number of adjustable special effects to your image.
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Lens Effects
Apply a camera lens filter over the image.

Picture Frame
Insert a picture frame around the current image.

Zoom
Allows you to zoom into an area you define with the mouse.

Zoom In
Brings you closer and shows more detail with each mouse click.

Zoom Out
Allows you to step back and see a bigger picture with each mouse click.

Normal View
Shows the picture in its actual size.

Virtual Camera
Allows you to take a “snapshot” of another application's screen.

Start Slide Show
Presents your album photos in sequential order.

Activity Guide
Where the fun begins! Activity Guide lets you exercise your creativity.

 
Note:  Some menus and buttons are only visible and active when a photo window is open and in
use, since they only apply to images. Similarly, some menus and buttons are only visible and
active when an album window is open and in use, as they only apply to albums.
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2.34 Tool Bar

The Tool Bar presents the range of options available to you for selecting, drawing, painting,
writing, etc. on specified areas of your photos.

Select by Ellipse*
Chooses an oval shaped area.

Select by Rectangle*
Chooses a rectangular area.

Select by Freehand (see section 2.35)
Chooses an irregularly shaped area.

Select by Magic Wand (see section 2.35)
Selects any desired area when scribbled over the area's surface.

Draw Filled Ellipse*
Draws a filled oval shaped area.

Draw Hollow Ellipse*
Draws a hollow oval shaped area.

Draw Filled Rectangle*
Draws a filled rectangle.

Draw Hollow Rectangle*
Draws a hollow rectangle.

Draw Filled Rounded Rectangle*
Draws a filled, rounded rectangle.

Draw Hollow Rounded Rectangle*
Draws a hollow, rounded rectangle.

Draw Filled Polygon
Draws a filled irregular shape with as many sides as you want.

Draw Hollow Polygon
Draws a hollow irregular shape with as many sides as you want.
 

 

 

 

 

 Holding down the left mouse
button while drawing filled
shapes fills the interior with
the current foreground color,
while the outline will be the
current background color (the
opposite is true if the right
mouse button is held down) –
see section 2.41. The line
width will be of the current
pen size.

 For hollow shapes, holding
down the left mouse button
uses the current foreground
color for the outline, while
the right button uses the
current background color.
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Draw Straight Line
Draws a straight line in the foreground color while the left mouse button is pressed, and
the background color when the right button is used. If the [Shift]
key is held down, lines will be drawn on exact 45 degree angles.

Freehand Draw
Draw whatever you wish on the screen.

Flood Fill
Fills a solid-colored area with the selected color.

 Air Brush
Performs like an air brush, emitting a steady, soft
stream of color.

 
Eraser
Click on this icon to erase. Erases the area to white.
 
 Add Text
Allows you to write your own captions, headlines, etc. onto your photo.

Eyedropper
Allows you to sample a color from your photo and use it as a primary drawing color.
Use the left mouse button for a new foreground color, and the right mouse button to
select a new background color.

Clone (see section 2.35)
Copies one area to another area on your photo.

Pen Settings
Allows you to choose the pen shape and size you prefer. Click on the
box to choose the pen shape and on the arrows to adjust the pen size.
Note: The pen size you choose will be used for all the other drawing
tools, including outlines.

Foreground/Background Colors (see section 2.41)
Shows the foreground color currently in use on the left and the background color in
use, under it, on the right.

*If the shift key is held down while the shape is drawn a circle will be created for the ellipse tools
and a square will be created for the rectangular tools.

 

 Holding down the left
mouse button assigns the
current foreground color to
the drawing tool, while the
right button assigns the
back-ground color (see
section 2.41).
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2.35 Detailed descriptions of selected icons in the Tool Bar

1. Freehand Select
Freehand Select allows you to choose an irregularly shaped area.

To draw a straight line polygon (irregular shape), simply click once on the left mouse button
for each line in the shape around the area you want. When finished drawing, click once on the
right mouse button.

To draw a curved shape freehand, click on the left mouse button and hold it down as you
move the mouse around the area you've selected. When you have outlined the shape, click on the
right mouse button to seal it.

After you have outlined your straight line or curved shape, click inside the outlined area and you
can move the image wherever you wish.

 2. Smart Magic Wand
Smart Magic Wand targets larger areas of similar color to the area sampled. You can
quickly select and copy an entire section of your photo.

Move the wand to the area of the photograph you want to select, and scribble over part of the
area with the left mouse button held down. When you release the mouse button, the entire area
will be copied, which can then be moved or resized. For example, you could select only a cloud
in a landscape photo, by scribbling with the Smart Magic Wand over part of the cloud's surface.
When the mouse button is released, the entire cloud will be selected (provided the cloud color
was fairly uniform - areas lighter or darker than the part scribbled upon may not be selected).
The Smart Magic Wand is also ideal for removing red eye from your photos! See 3.35, “How to
Remove Red Eye.”

 3. Clone Tool
This tool copies a selected color from one area of your image to another, and is
especially effective for repairing damaged photos.

First, adjust the size of the clone tool to suit the type of work you will be doing using the Pen
Settings tool, described above. Next, select the clone tool and click on the area of the image you
want to clone from. This will usually be an undamaged area of the photo (such as a background
or texture) you wish to copy over to another area. The tool appears on the image as a large “+”,
with a smaller flashing “+” remaining stationary on the first spot you clicked. Move the large “+”
to the area you wish to repair. Click and hold while you move the mouse. You are now cloning
the area under the flashing “+” to the large “+”. Use the flashing “+” as a guide to the original
area being copied. To set a new cloning source, release the mouse button, move the larger cursor
to a new source, hold the [Shift] key and press the left mouse button again. This will “drop” the
small flashing “+” on the new area. Hold the left mouse button to begin cloning.
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 2.36 Color Palette

The Color palette, appearing as a mosaic of color squares, is used to choose colors for image
editing purposes. You can choose colors to create a new image with, or to edit an existing
photograph. If you are editing a monochrome image, only two colors, black and white, are
displayed in the color palette. If you are editing a 16 color image, all sixteen available colors
appear in the color palette. When you edit a photo with 256 or more colors, 256 colors are
displayed in the color palette.

Note: If you switch between photo windows (see section 2.5), the color palette will always
display the colors of the active photo window.

 2.37 Color Palette Options (Foreground, Background Colors)

Select Foreground Drawing Color with the Left Mouse Button
Click on the desired color in the color palette. The highlighted color will display the
letter “F" (for Foreground). It now becomes the active foreground color in which
lines, circles, rectangles, rounded rectangles, polygons and freehand drawing will be
drawn. This color will remain active until it is changed.

Select Background Color (if required) with the Right Mouse Button
Some drawing activities require a specified background color for drawn shapes, such
as filled circles, filled rectangles, and filled polygons. Drawing with the left mouse
button held down assigns the foreground color to the outline and the background
color to the fill. To select the background color, click the right mouse button on the
desired color in the color palette. The letter “B" will appear over the highlighted
color you have selected. If you choose the same color for both foreground and
background, the letters “FB" will appear over the selected color.

Change Foreground Color with the Left Mouse Button
To change a foreground color, position the mouse pointer over the color in the color
palette and double-click the left mouse button. The color selector will
appear, allowing you to change the selected color (see 7.30, Color
Selection).

Change Background Color with the Right Mouse Button
To change a background color, position the mouse pointer over the
color in the color palette and double-click the right mouse button. The
color selector will appear, allowing you to change the selected color.
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 2.4 Views
 
 2.41 Full Screen

Choose “Full Screen" from the View menu to display the active photo in a full screen window.
The background color will be the one in use by the current slideshow. See  section 6, Slideshows,
for additional information.

2.42 Photo Windows

Photo windows are defined areas where you can view and edit a photo image. Each photo you
open is contained within its own photo window. The title bar of the window displays the file
name of the photo, its size in pixels, and the number of colors it contains. You can open as many
windows as system resources and memory permit, but only one photo window will be active at a
time.

2.43 Overview Window

You can use the overview window to view the active photo image at a different magnification.
This makes it easier to see the overall effect of your drawing activities. For example, you may
choose to work in the photo window at a high magnification and then use the overview window
to see the entire photo. When the overview window is open, it always displays the contents of the
active window. You can activate this feature by selecting “Show Overview” from the View
menu.

2.5 On-line Help

2.51 Using On-line Help

Windows Help is designed to offer assistance while you are using the program. It now includes
some of this reference guide as well as a complete description of each screen window. This saves
you from having to search through printed documentation to get information on program
features.

2.52 Accessing Help

The On-line Help gives you instant access to helpful information while you are working within
MGI PhotoSuite. You'll find a context sensitive help topic for each function of the application -
for every icon, tool, command, dialog and button. While you work within MGI PhotoSuite, you
can access Help quickly using any of these methods:
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• Select the Help button found in the
individual dialogs for information about the
window currently in use.

• Select an icon from any icon panel and
press [F1]. MGI PhotoSuite will display a
Help window for that topic.

• Select “Contents" from the MGI
PhotoSuite's Help menu and choose a topic.
Click on the topic you want.

• Press [F1] and choose a topic from the Help
contents. Click on the topic you want.

• Press [F1] and use the Search button in the
Help button bar to access information by
specifying a keyword or by selecting one
from a list. Using Search is like using a
book index. Each keyword directs you to
one or more Help topics.

Note:  You can display a Help window, read the
information, and then close the window. You
can also display a Help window beside the application window as you work. The two windows
can overlap when the selected one is on top. To close a Help window, choose Exit from the File
menu, or Close from the Help button bar, or click on the Help window's Close control.

2.53 Searching On-Line Help

Select “Search" in the Help button bar to find information quickly by specifying a keyword or
selecting one from a list. Each keyword will direct you to one or more Help topics. Select a
keyword in one of two ways:

• Scroll through the list box of keywords until the selection bar highlights the correct word.

• Type the keyword you want in the text area at the top of the Search window. (Note that as
you type each character, the selection bar jumps to the first keyword using that character or
sequence of characters.

List the topics associated with the selected keyword in one of two ways:

• Click on the Display button.

• Double-click on the keyword in the list box.
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If there are two or more topics related to that keyword, another window will appear. Jump to the
topic of interest in one of two ways:

• Double-click on the topic name.

• Select a topic name and click on the Display button.

The help engine closes the Search dialog and displays the help topic you selected.
After you read the information, you can:

• Click on the Search button to do another search
• Click on the Contents button to display an alphabetical list of topics
• Or exit Help by choosing Exit from the File menu, Close from the button bar, or clicking on

the Help window's Close control.

For a detailed and complete explanation of how to use the Windows On-line Help, press [F1],
then press [F1] again. This will display the “Help Topics: Windows Help" window. To return to
the MGI PhotoSuite On-line Help, you must exit the Windows Help and press [F1] again.

2.54 Help Line

The help line at the bottom of the main window displays help messages and information about
the active photo image. If the mouse is over an icon, the help line displays the function of that
icon. If a menu item is highlighted, the help line displays the function of the menu item. If the
mouse is over the main window, the help line displays the full filename of the active photo on the
left side of the help line. If you have selected an area of the image, the right side of the help line
displays the location and size of the selected area.

2.55 Icon Tool Tips

Whenever the mouse pointer pauses over an icon in the Button Bar or Tool Panel, a short “Icon
Tip" message will appear, describing what the icon does. This feature can be turned on or off by
choosing “Icon Tips" from the Help menu.

If you have questions about MGI PhotoSuite or any other MGI product, please visit our web site
at: http:\\www.mgisoft.com.
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 2.6 Files

2.61 Using the File Selector

Clicking on Open or Save from the File menu or button bar presents the
MGI PhotoSuite customized Windows file selector box to select the files to open or
save. The drive and directory are automatically set to the last path selected. All files of
the selected photo type are displayed in the file list box.

 Options:

• To see all files of a specific photo type,
click on the “Files of type" drop down list
box and select a file type from the list of
available types. The file list will be updated
to display only files of the specified type.

• To select a file, either click on the file name
in the file name box or type a file name in
the “File name" field. If you do not see the
file you want, select a new drive or
directory. In some cases you may be able to
select a different type of file by using the
“Files of type" or “Save as type" list box.
After you have specified the file you want,
click on Open (or Save).

2.62 Naming your Files

• Under Windows 95 and Windows NT, a file name can be from 1 to 260 characters long. Use
any combination of characters, except for the following: * ? \ / : | <

 
• Under Windows 3.1, a file name can be from one to eight characters long, followed by a

period and a one to three character file name extension. Use any combination of characters
except for spaces and the following: *  ? , ; [ ] + = \ / : | < . Periods can only be used to
separate the file name from the extension.

Different file types are distinguished by the file name extensions. For example, Windows bitmap
files have the extension ".BMP" while TIFF files have the extension ".TIF". To avoid confusion,
keep the default extensions when saving images.
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2.7 Get Photos

Selecting “Get Photos” from the File menu presents several sources to retrieve your photos from.

From Photo CD
Allows you to retrieve your photo from a
Photo CD. You must have a CD-ROM drive
installed or connected to your computer to
use this option.

From Floppy Disk
Access your photos from your floppy disk
drive (usually designated Drive A:).

From Camera/Scanner
Retrieve images stored in any TWAIN compatible digital camera or scanner connected to your
computer (see section 7.15, TWAIN support).

From PhotoNet
Retrieve your photos from the PhotoNet on-line photo developing service on the world wide
web. You must have an account with an Internet service provider to use this option (see section
3.86, How to Get Your Photos using PhotoNet).

Select Source
Displays a window enabling you to select from different TWAIN compatible image acquisition
sources connected to your computer. After using “Select Source” to choose an image acquisition
device, you can then get images from the device by selecting “Get Photos” and then “From
Camera/Scanner” (see section 7.14, TWAIN support).
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The “Get Photos” command can also be accessed from the Activity Guide. From the
Activity Guide, click on Get Photos, and the following dialog box will appear:

2.8 Sending Photos via Email

Provided you have an Internet account with your own email address, You can send your photos
to anyone with an email address directly from within MGI PhotoSuite!

Have the photo you want to send loaded into MGI PhotoSuite. From the File menu, select
“Send” and then “Via Email.”

Your Internet messaging application will automatically be launched, with your photo placed in
the message. You can type in a greeting to accompany the photo, if you wish.

Type in the email address of the person you want to send the photo to, and click on Send. It’s
that simple!
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3.0 How To

3.1 Some ‘How To’ Basics

3.11 How to Create a New Image

Upon loading MGI PhotoSuite, you will be greeted by the Activity Guide. The Activity Guide
presents you with a number of options, from editing photos to creating captions and applying
special effects. You are also given the option of starting an image from scratch, by clicking on
the “Work on your Own” button at the bottom right corner of the Activity Guide.

When you click “Work on your Own”, you are presented with the MGI PhotoSuite user interface,
with its Menu Bar, Button Bar, Tool Bar, Color Palette, and Work Space.

Click on the “New Image” icon. This will give you a blank canvas from which you can
create your own images. A dialog box will appear, asking for your preference in image
size and number of colors. Most home PC's are capable of
at least 640x480 pixels and 256 colors. Enter those values.

Try experimenting with the various tools provided in the Tool Bar. Use the “Draw
Filled Ellipse” tool to draw an ellipse on the page. You can change the shape's color by
clicking on a color in the “Color Palette,” then selecting the



34

“Flood Fill” tool. Click over the shape you want to fill, and it will change to the selected
color.

3.12 Add Text Captions to your Image

Next, try entering some text. First click on the color you want from the Color Palette.

Now click on the “Add Text” icon and position the cursor anywhere in the Work Space.
A dialog box will appear asking you to specify the font style and size, and paragraph
alignment.

After you have typed the text you want, click OK and the text will be placed in the upper left-
hand corner of the workspace, surrounded by an animated dashed line. At this time you can move
the text box anywhere you wish, or click on the “Add Text” icon again to edit the text. You may
also choose a different color for the text by clicking on the Color Palette. Once you are satisfied
with the text position and attributes, click anywhere outside the box to “lock” the text in place.

Note: Once the text has been set in place, you can no longer edit it, as it has now become a part
of the underlying image.
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3.13 Loading a Photograph or previously created Image

1. To get a previously created image or photo,
you can click on “Get Photos from Disk or
Floppy” from the Activity Guide, or click
on the “Open Image” icon from the Button
Bar.

2. Select the image you want from the “Open Image or
Album” dialog box. Choose the drive and directory
that your photo resides. You are given the choice of
whether or not to view a preview of the image before
loading. Click “Open.”

3. You can now view and customize the photo.
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3.14 Area Selection

Area Selection tools are used to define an area of the photo.
Once defined, an area can be copied to the clipboard, or turned
into a floating selection which can be moved, sized, flipped and
then pasted to a different area of the photo. You can select areas
using a rectangle, an ellipse, a polygon or freehand. You can
select areas at any zoom level - particularly useful for selecting
small areas.

When you select an area, a solid line defining the area will
appear in the photo. If you wish to erase the selection outline,
press [Esc]. You can click outside the selection area to cancel
the selection and start a new selection. If you move the mouse
inside the selection area, the mouse changes into a four-
cornered arrow. Click inside the area to transform it into a
floating selection. Floating selections are outlined by an
animated dashed line with square sizing handles at each corner.

Resizing Floating Selections

The sizing rectangles found in each corner of the floating selection let you resize the selection.
Move the mouse inside the sizing rectangle and the mouse changes to a diagonal, double-ended
arrow. Click the left mouse button and drag to stretch the selection. Release it and the selection
will be resized. If you hold down the [Shift] key while dragging the mouse, the original
selection's aspect ratio will be maintained.

You can also move or enlarge floating selections incrementally using the keyboard, which may
be preferable to using the mouse, for delicate work.

To move – use the Arrow keys while holding down the [Control] key.
To enlarge – use the Right or Down Arrow keys while holding down the [Shift] key.

Selecting a Rectangular Area

Click on this icon to select a rectangular area of the photo. Move the mouse to the start
of the rectangle, click and hold the left mouse button while dragging the mouse to define the
selection rectangle. The Help line will display the coordinates of the top left corner of the
selection rectangle as well as the width and height.

Hold down the [Shift] key and press the cursor keys to resize the selection rectangle, one pixel at
a time. Hold down the [Ctrl] key and press the cursor keys to move the selection rectangle
around the image window. Click inside the selection rectangle to turn it into a floating selection.
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You can drag the floating selection to a new location by holding down the left mouse button,
while the mouse is inside the selection, and dragging the selection to a new location.

To paste the selection into
the current image, move the
mouse outside the floating
selection and click the left
mouse button. Remember,
you can select Undo to
restore the image if you
paste a selection
accidentally.

Selecting an
Elliptical or
Circular Area

Click on this icon to select
an elliptical or circular area
of the photo. Move the
mouse to the center of the
area you wish to select, click
and hold the left mouse
button while dragging the
mouse to define the selection
area. Pressing the [Shift] key
while you drag the mouse
will make the selection area
circular. Release the mouse
button to complete the
selection. If you wish to
erase the selection, press
[Esc]. To create a floating
selection, move the mouse
inside the selected area and
click the left mouse button.
You can move, size and
paste the floating selection as
described for rectangular
selections.
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Selecting a Similar Area by Magic Wand

The Magic Wand targets areas of similar color, allowing you to quickly select an area of
your photo. Move the wand to the area of the photograph you want to select and scribble

over part of the area with the left mouse button held down. When you release the mouse button,
the wand will pick the entire area up and allow you to move a copy of it wherever you want.

For example, you could select only the yellow feathers by scribbling with the Smart Magic Wand
over that part of the Parrot's body. The area covered by the yellow feathers will be selected (the
Magic Wand works best on areas with fairly uniform color; other parts of the photo may not
yield the same results). If you wish to erase the selection, press [Esc]. To create a floating
selection, move the mouse inside the selected area and click the left mouse button. You can
move, size and paste the floating selection as described for rectangular selections.

The yellow feathers were
selected with the Magic
Wand and then moved with
the mouse.

Selecting a Polygonal or Freehand Area

Click on this icon to select an irregularly shaped area of the photo using a polygon or
freehand outline. Move the mouse to the starting location and click the left mouse button. To
define the selection area (with a series of connected lines), move the mouse and click on one or
more locations to define the endpoints of each line. You can also click and hold the left mouse
button while dragging the mouse to define a selection area. To close the selection area, click the
right mouse button. To erase the selection, press [Esc].
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To create a floating selection, move the mouse inside the selected area and click the left mouse
button. You can move, size and paste the floating selection as described for rectangular and
elliptical selections.

3.15 Creating a Photo
Collage from Floating
Sections

You can create an interesting
photo collage – an image made
up of parts of other photos –
using the selection tools and
the clipboard.

1. Create a new image, or open the photo you want to paste other images to.

2. Open the photo(s) you want to incorporate into your collage.

3. Select an area of a photo using any of the methods described above. Click on the
Copy icon to copy the area onto the Clipboard.

4. Select the photo you want to add the selection to,
and click on the Paste icon.
The area will be added to your photo.

5. You can move or resize the selected area with the
mouse. Click outside the area to deselect it.

You can “drag and drop” selections from one photo to
another, without using the clipboard. Simply select an area of
your photo and click inside the area to select it. Next, click
and hold with the mouse while you drag the selection to
another open photo.
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3.2 Fun With Your Photos

3.21 Apply Special Effects

1. Open a photo from your hard disk, floppy disk, or Photo CD.

2. Click on the “Apply Special Effects” icon from the button bar.

You will be presented with the Apply Special Effect dialog box:

3. Choose any one of the many special effects available. You can apply more than one effect to
the same image for interesting results. Or use a selection tool to apply the effect only to a
selected area. In addition, most special effects allow a degree of customization. Experiment!

You can retrieve the previous image by selecting “Revert to Saved” from the File menu. This
will reload the last saved version of the current image. You can also reverse the most recent
command by selecting “Undo” from the Edit menu.

Note: Not all filters can be applied to all photo images. Some filters only work on 24-bit (16
million color) photos, and are indicated below with an asterisk: *. These filters are marked in the
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Special Effects window with an X if an image has less than the required color depth. See section
3.63, Increase/Decrease Colors (Depth).

If you would like to apply one of the special effects only available in 16 million colors to a photo
that does not have enough colors, choose “Increase Colors" and then “16 million" from the Photo
menu. The photo will be converted to 16-million colors and you will then be able to apply the
special effect.

Original Image

Examples of Special Effects:

Coloring Book*

The Coloring Book filter enhances the appearance of edges and blank
areas of the image that do not have edges. The entire image appears as
an etching on a surface, resembling a coloring book effect that children
of all ages are sure to enjoy. Choose a strong, medium or weak
application of this effect from the sliding bar.

Emboss*

The embossing filter creates a three dimensional effect by selectively
enhancing edges in the image. The photo image appears to be raised as
if it has been formed from an imprint on clay. Choose a strong, medium
or weak application of this effect.
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Sharpen Details*

The sharpening filter creates a destination photo image with sharper
edges than the source photo. The result is a kind of hyper realism that
makes your photo even more lifelike. You can choose between a strong,
medium or weak application of this effect.

Soften Details*

The softening filter creates a destination photo image with softer edges
than the source photo. This function is particularly useful for minimizing
undesirable patterns, which may be a side effect of scanning printed
images. Choose a strong, medium or weak application of this effect.

Mosaic

Use this filter to reduce the apparent resolution of the current photo by
replacing the pixels in the photo according to the average color of the
pixels in a specified area. Choose the mosaic pattern size through the
Apply Special Effect window's sliding bar to determine the size of the
averaged areas. For example, choosing a pattern size of 6 replaces each
6x6 pixel area in the
image with the average color in that area.

Splatter

This effect is similar to Mosaic in that pixels in a specified area are
averaged together. However, the edges of the resulting square are
randomly distorted to give a more irregular pattern. Choose 'strong' to
produce a very random pattern, 'medium' for a moderately random
pattern and 'weak' for a fairly regular pattern.
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Crystallize

This filter is used to apply the Crystallize special effect to the photo.
This effect is similar to the Splatter effect except that a hexagonal
pattern is applied, then randomly distorted. Choose 'strong' to produce a
highly random pattern, 'medium' for a moderately random pattern and
'weak' for a fairly regular pattern.

Posterize

Use this filter to reduce the number of colors in the current photo.
Choose the number of color steps to apply and click on OK. If, for
example, you select 4 color steps, the resulting image will contain at
most four different levels of red, green and blue. Note: The Posterize
effect is not available for 16-color and monochrome images.

Enhance Edges

This special effect will enhance the edges of your photo so that the
image stands out and seems to brighten. Choose a strong, medium or
weak application of this effect.

Relief *

Relief gives your photo a 3-D effect, making it stand out and appear to
have texture. Use this special effect to make your photos look like they
have another dimension. For example, a picture of the moon's surface
would appear very real, or tactile, when the Relief effect is applied.
Choose a strong, medium or weak application of this effect.
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Gaussian Blur *

This will give your photo a blurred effect, which softens and distorts the
photo so it appears fuzzy. You can choose to have the blurring streak up
and down ('vertical') the photo, across it ('horizontal') , or in both
directions ('both') for an overall fuzzy effect. As well, you can select the
blur radius you want, which determines the thickness of each blur streak.

Remove Scratches *

Choose this filter to clean up your photo when desired, removing dots or
scratches you don't want to see in the picture. Choose a dark, median, or
light application of this effect.

Mirage *

Mirage will duplicate the primary subject in the center of the photo and
display a sheer copy of it under the original appearing, in effect, like a
reflection or mirage. This second, ghost like image would be fun to
apply to a photo of a child in a scary Halloween costume, for example.
Choose the intensity you want from the sliding bar.

The mirage effect appears always to come from the top down. If you
want to reflect the bottom of the image up to the top, turn it upside down
first, using the Rotate Image feature.

Smoked Glass*

Using the Smoked Glass effect is like looking through a tinted window –
it allows you to see your photo behind a dark filter for a mysterious
effect. Choose a strong, medium or weak application of this effect and
adjust the color using the sliding bar.
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Cartoonize *

Now you can make a funny joke out of a favorite photo of your best
friend by turning it into a color cartoon with the Cartoonize effect. Why
not add a word balloon to make it into a real comic! (Access Add a
Word Balloon through the Activity Guide under “Fun.” Click on Fun
with Photos. Next, just add text to the balloon through the Add Text tool
on the tool bar at the left of
your screen).

Swirl

Swirl literally stirs your photo into a swirl of colors. You choose the
angle (the degree) that you wish to apply this effect. Apply this effect
lightly for a simple curled distortion of the image. Apply it more
intensely to twist and turn the photo into a true color swirl.

Oval Frame*

This effect puts your photo in an oval frame. You choose the intensity –
the greater the intensity the softer the framing effect; the lower the
intensity the sharper the oval frame appears. A wedding photo looks
very special when placed in an oval frame with softened edges, while a
sports photo, for example, would likely suit a stronger oval frame.

Spherize

Spherize appears to stretch the photo over a curved shape. It will appear
as if it were being stretched over a ball or sphere, taking on elongated
proportions. Choose the height of the sphere effect you want by using
the sliding bar. More height makes the photo image appear to wrap
around the outside of a ball (pushing the image toward you) while less
height makes it look pulled in (away from you) – almost as if it is lining
the inside of a ball.
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Ripple

This gives your photo a rippled or bumpy effect, that appear in a series
of concentric rings. Choose a strong, medium or weak application of this
effect. You can also choose the number of ripples by using the sliding
bar. With more ripples (up to 20) each one is thin; with less ripples, each
one is thicker. You can use the Ripple effect to make your photo appear
like it's actually
under the surface of water. Try it and see!

Tile*

This very interesting special effect breaks up your photo into a series of
square tiles with dark spaces in between each one. Applied weakly, the
tiles appear in a fairly uniform grid pattern, like bathroom tiles on a
wall. Applied strongly, and the tiles seem more randomly placed,
overlapping in some areas, like pieces of a puzzle that haven't yet been
put together. You can
also choose the pattern or tile size, using the sliding bar.

Oil Paint *

This is one of the special effects that will convince everyone you are a
talented artist who can whip up an impressive rendering of a favorite
photo at the drop of a hat. Really, it's just at the click of a mouse with
MGI PhotoSuite's Oil Paint Effect. This effect almost suggests the
appearance of brush strokes you've painstakingly applied to get just the
right effect. Choose a weak,
medium, or strong application of this effect and select the pattern
intensity using the sliding bar.

Stretch *

Think of pulled taffy – that's the effect you'll achieve when you apply
Stretch. You can stretch your photo up and down, from side to side, or
in both directions, for a very funny effect. You can also choose the
degree of intensity you want when you stretch your photo.
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3.22 Fun with Faces

With a little imagination, you can easily apply some amazing effects to your photos using the
special effects and drawing tools found in MGI PhotoSuite!

Have some fun with your family and friends... create funny faces by moving someone's ears to
their forehead... create cartoons by enlarging your friend's head to the size of a beach ball... the
possibilities are endless!

Original Photo After a Stretch Effect of -20
Open a favorite
photo from your
hard disk,

floppy, or CD and have
some fun with the Special
Effects.

Click on the
Special Effect icon
in the button

bar and choose Stretch.
Experiment with the
intensity levels and
direction, then click on OK
to apply the effect.
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You can have even more fun if you modify only certain
areas of your photo. In the example to the right, the eye
area of the photo was enlarged.

1. Select the area using the Select by Ellipse tool.

2. Draw an ellipse over the area you want to
enlarge.

3. Select the ellipse by moving the mouse pointer into the
area and clicking once. Size handles appear, which
indicate that the selected area can be moved or resized.

4. Enlarge the area by dragging the size handles with the
left mouse button held down, so that the eyes appear
bigger.

If the [Shift] key is held down while resizing, the aspect
ratio (length and width proportions) of the selected area
will be retained.

Another example of the stretch effect:
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The image to the right will be used to show how the Clone tool, the Eyedropper tool, and the
Airbrush can be used to easily enhance and modify your photos. Let us assume for this example
that you want to retouch a damaged photo, and then have fun by enlarging the girl's ears.

1. An appropriate pen size was chosen for the clone
tool.

2. Select the clone tool from the tool bar and move the
cursor over to an undamaged area of the girl's cheek,
near the blemish.Click once, leaving the clone
indicator (a small + sign) behind, while moving the
cursor (a larger + sign) directly over the blemish.

3. With the left mouse button held down, move the cursor (the
larger + sign) around so that the undamaged area is cloned
over top of the blemish. When the entire blemish has been
covered, you may discover that the cloned area is fairly
noticeable when compared to the,surrounding skin.

4. Use the Eyedropper tool to sample the color of the surrounding cheek.
This color will be assigned to the Airbrush.

5. Select the Airbrush tool to smooth the area around
the area you just cloned. This is done to blend the
area more realistically into the rest of the cheek.

6. Choose the Freehand Select tool and use it to trace
around one of the ears as described in section 3.04,
Area Selection. Click inside the area (this activates
the size handles), and then enlarge the ear by
dragging one of the handles with the mouse.
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You can make yourself or a friend look musclebound
by selecting only a part of the photo to modify. Use
the Select by Ellipse tool toselect the upper body of a

person (excluding the head). Click inside the ellipse to select
it. Now click on the Special Effects icon in the button bar. In
the Apply Special Effect dialog box, select the Stretch effect.
Experiment with

the different settings and levels, checking the effect preview
window as you do. When you are satisfied with the settings,
click on OK to apply the effect to your photo.

You can go one step further, if you wish, to make
the effect even more outrageous. Select the person's
head, again using the Select by Ellipse tool. After
selecting the area and opening the Apply Special
Effect dialog box, choose a negative intensity (like -

20) instead of positive, to shrink the head relative to the
body. Experiment – the more you try new things with MGI
PhotoSuite, the more fun you'll have!
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3.23 Apply Lens Effects (Filters)

Think of MGI PhotoSuite's Lens Effects as special color filters that you can apply to your photos
in varying intensities. You can have the color flush up from the bottom of your photo, down from
the top - or you can choose to have it appear uniform throughout the entire image. For each lens
effect, you will also be able to choose tonal gradations to intensify the look of your photograph.

1. Open a photo from your hard disk, floppy disk, or Photo CD.

2. Click on the Apply Lens Effects icon from the Button Bar. You will be presented with
the Apply Lens Effect dialog box, similar to the Apply Special Effects dialog box.

3. Choose any one of the many lens effects available. Most lens effects allow a degree of
customization. Experiment!

Note: Lens Effects filters only work on 24-bit (16 million color) photos.

If you would like to apply one of the lens filters only available in 16 million colors to a photo
that does not have enough colors, choose “Increase Colors" and then “16 million" from the Photo
menu. The photo will be converted to 16-million colors and you will then be able to apply the
lens effect.

Warm – Choose Warm to apply a warm reddish tone.

Cool – Choose Cool to apply a cool bluish tone.

Moonlight – Choose Moonlight for a soft blue incandescent light effect.

Sepia – Choose Sepia to achieve a soft rust-colored tone.

Tan – Choose Tan for a soft warm beige tone.

Antique – Choose Antique to apply a warm brown tone for an aged look. You could use this to
make family photos look like they were taken many years ago, or to make the furniture in the
garage sale flyer you've just created (in MGI PhotoSuite, of course!) look like true antiques!

Fog – Choose Fog to make your photos look like they are covered in a light mist. Use this effect
to make your photo subjects appear as though they've been caught in the rain, or to add an air of
mystery to a portrait or landscape.
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3.24 How to Create a Photo Album

When you create a PC photo album you have an at-a-glance view of the photos you want to work
with in MGI PhotoSuite. It's a great way to quickly capture and view the photos you want instead
of sifting through a directory of filenames.

1. From the Activity Guide, click on “Get Photos.” You will see the Add Images
to Album dialog box.

2. Click on “Look In”
3. Choose the drive and directory where the photos are located. Highlight only

the photos you want for the album. Select them all instantly by clicking on the
first one, holding down the shift key and clicking on the last image.

4. Click on Open and create your own photo album, complete with all stored
photos.

5. You can save your Album under “File” then “Save” from the menu bar. For
more information on Photo Albums, see section 5, Multimedia Albums.



53

3.25 How to Create a Photo Calendar

1. Select a photo from your photo album,
or click on “Get Photos.”

2. Select “Create a Poster” in the Activity
Guide.

3. From the Poster Selector drop-down
menu, choose the calendar category
and then the calendar you wish to place
your photo in. You'll notice your
selected photo appears within the
calendar frame.

4. Adjust the size of your calendar photo
by clicking and dragging the corner of
the photo. For more information, see
“How to Resize Photos to Fit a
Frame.”

5. Choose print to make a printout.

3.26 How to Create a Photo Greeting Card

1. Select a photo from your photo album,
or click on “Get Photos.”

2. Click on “Create a Greeting Card” in the
Activity Guide.  You'll notice your photo
appears within a Card frame.

3. From the Card Type selector drop-down
menu, choose a category and then a card
from the left hand selection menu by
clicking on the card you want.

4. Adjust the size of your Card photo by
clicking and dragging the corner of the
photo. For more information, see “How
to Resize Photos to Fit a Frame.”

5. Choose print to make a printout.
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3.27 How to Create a Photo Sports Card

1. Select a photo from your photo album, or
click on “Get Photos.”

2. Click on “Create a Sports Card” in the
Activity Guide.  You'll notice your photo
appears within a Card frame.

3. From the Card Type selector drop-down
menu, choose a category and then a card
from the left hand selection menu by
clicking on the card you want.

4. Adjust the size of your Card photo by
clicking and dragging  the corner of the
photo. For more information, see “How to
Resize Photos to Fit a Frame.”

5. Choose print to make a printout.

3.28 How to Create a Photo Magazine Cover

1. Select a photo from your photo album,
or click on “Get Photos.”

2. Click on “Create a Magazine Cover” in
the Activity Guide.  You'll notice your
photo appears within a Magazine
frame.

3. From the Magazine Cover Type
selector drop-down menu, choose a
category and then a magazine cover
from the left hand selection menu by
clicking on the cover you want.

4. Adjust the size of your photo by clicking on the corner of the photo. For more
information, see “How to Resize Photos to Fit a Frame.”

5. Choose print to make a printout.



55

3.3 How to Resize Photos to fit a Frame

You can resize your photo to fit your calendar, greeting card, sports card or magazine cover in
three different ways.

3.31 Manual Adjustment

One way to change the size is to click on a tab at the corner of the photo and drag to the desired
size. Adjust the photo until it fills the allowed space. Clicking the “Aspect Ratio” checkbox will
ensure that the horizontal and vertical proportions of your photo remain constant, so people or
objects will not appear too wide or too tall.

3.32 Auto Fit

If you want the picture to fit into the predefined area and keep its proportions, you can click on
the Size menu and choose “To Fit”. This sizes the picture to the predefined area with no overfill.
If, however, the proportions of the photo do not match the predefinition, there will be a blank
section wherever the photo is too narrow to fill the space. To eliminate this space and completely
fill the frame, choose “Auto Fill”.
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3.33 Auto Fill

If you want the picture to fill in the default
predefined area, click on the Size menu and
choose “To Fill”. This fills the predefined space
with the picture. If “Aspect Ratio” is checked,
the proportions will remain constant, but part of
the photo may remain hidden from view behind
the frame.

Whatever adjustment method you choose, you
can still manually resize your photo if you wish
(see section 3.21: Manual Adjustment), and then print.

3.4 How to Add Props

3.41 Add a Picture Frame

This effect does just what it suggests - puts your favorite photos in a suitable frame. There are
many frames from which you can choose, from classic frame styles to amusing ones, such as a
TV screen or film strip.

1. Select the photo you want
from your photo album or
click on “Get Photos.”

2. Select “Insert” then “Picture
Frame” from the menu bar.

3. Choose the picture frame you
want from the left hand
selection menu and click
“OK”.

4. You can print your framed
photo by selecting “File” then
“Print” from the menu bar.
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3.42 How to Create a Body Switch or create Play Money

1. Select the photo you want from your photo album or click on “Get Photos.”
2. Select “Fun with Photos” in the Activity Guide.
3. Select “Do a Body Switch”
4. Choose the cartoon body or play money you want. Your photo and the cartoon

body will appear on a split screen.
5. Highlight your photo by clicking on it.
6. Pick one of the following selections from the tool bar – Ellipse, Rectangle or

Freehand, and outline the head
area on your photo.

7. Click the left mouse button
and drag the cutout photo over
to the cartoon image. Release
the mouse button and the head
will appear on your cartoon
screen.

8. Place it on the body and adjust
the head size as required,
using the tabs outlining the
image.

3.43 How to Add Word Balloons

1. Select the photo you want from your photo album or click on “Get Photos.”
2. Select “Fun with Photos” in the Activity Guide.
3. Select “Add A Word Balloon”
4. Choose the word balloon you want and click “OK”.
5. Resize and move the balloon to the desired position, and click outside of the

outlined balloon area.
6. Select the “Add Text” tool and write the text you want in the space provided.

Adjust text size, remembering that it needs to be small enough to fit within the
balloon.

7. Click “OK” and position the text within the
balloon. If the text is too big you can delete it by
selecting “Edit”, then “Undo” from the menu
bar. Then, select the Add Text tool again, write
in your text, and choose a smaller text size.
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3.44 How to Add Props

1. Select “Fun with your Photos” in the Activity Guide.
2. Select “Add a Prop”.
3. Choose the prop you want, click “OK” and it will appear on top of your photo.

4. You can resize the prop if desired and move it to the area of your photo where
you want it to appear.

5. Click outside the dashed line and your new prop will be set in place.

3.5 How to Repair and Enhance Photos

3.51 How to Repair Damaged Photos or Remove Objects

If you have a favorite wedding photo, for example, with too many people in the picture, or an old
photo with a damaged area, you can remove or repair sections of your photo using the Clone
Tool.

1. Get the photo you want from the photo album, or by using Open Image on the  button
bar, or by choosing “File” then “Open” from the menu bar.

2. Select the Clone tool from the tool bar.
3. Find an unaffected area of the image that resembles the damaged part you wish to

cover up, so that you may clone a good area over the blemish or unwanted object.
Click on the undamaged area; a flashing cross appears. Move the cursor a short
distance and click the left mouse button so that the two crosses become linked. Now
scribble the clone tool over the
damaged area while holding
down the left mouse button.
Remember to adjust the size of
the clone tool using the pen
setting icon on the tool bar.
Scribble with the clone tool to
cover as much of the image as
necessary.
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3.52 How to Remove Red Eye

1. Get the photo you want from the
photo album or by using Open
Image at the far left of the
button bar, or by choosing
“Open” under File on the menu
bar.

2. Zoom in to the eye using the
zoom icon.

3. Select the Magic Wand from
the tool bar on the left side of
the screen.

4. Scribble the Magic Wand over
the red area of the eye by
holding down the leftmouse
button.

5. Choose the foreground portion of the
foreground/background color tool at the bottom of the Tool
Bar.

6. The Color Selector will appear. Click on the grey area at the
bottom right of the color square (cross hairs). Then select
black from the color bar on the right side of the dialog box.
Click OK.

7. Go to the scissors on the button bar and click once. That will
change the red eye pupil to normal black.

3.53 How To Adjust Brightness

1. Go to the sun icon on the button bar and click
once.

2. Move the cursor on the brightness slide bar up
for brighter or down for darker.

3. Click on “Preview” to see the changes on your
image.

4. If you are happy with the changes in brightness,
click “OK”. (You can also adjust brightness by
choosing “Image” and then “Brightness” on the
menu bar.)
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3.54 How To Enhance Colors

Enhance your image by sharpening or softening contrasts.

1. Click on the color meter button.
2. Move the cursor on the slide bar up for brighter or

down for darker.
3. Click on “Preview” to view your selected enhancement

level.
4. Click “OK” if you are satisfied with the change (you can

also enhance your image contrast by choosing “Image” and
then “Enhance Colors” on the menu bar).

3.55 How to Adjust Colors

To perform a color correction, choose “Adjust Colors" from the Image menu. The Adjust Colors
window will be displayed.

This window is used to adjust the colors of a photo, to lighten or darken the entire photo or
specific colors within it. Color, or gamma correction, uses a mathematical formula that leaves
very light and very dark color values relatively unchanged, but lightens and darkens mid-range
colors more strongly.

Use the sliders to set gamma values for “Red",
“Green" and “Blue". Click on “Preview" to see
the effect in the actual image. Click on “OK" to
accept the gamma setting. Click on “Cancel" to
restore the image to its original state. Click on
“Link Sliders" to synchronize all of the sliders
to the Green slider.

A gamma value of 1.0 leaves the color
unchanged. Values greater than 1.0 lighten the
color while values less than 1.0 darken the
color.
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3.6 How to Change your Photo’s Colors and Orientation

3.61 How to change a Color Image to a Grayscale Image

Select “Grayscale" from the Image menu to create a grayscale destination image from a color
source image.

3.62 Reverse Colors

Select “Reverse Colors" from the Image menu to create a negative version of the current photo.
Each color in the photo will be replaced by its complementary color.

3.63 Increase/Decrease Colors (Depth)

This set of options from the Image menu allow you to increase or decrease the color depth of the
current photo. Increasing the color depth enhances the image with additional colors. Reducing
the color depth decreases the memory size of a photo and may be required when you wish to
show a photo on a display that cannot show all the colors in the current photo. Select the new
color depth from the “Increase Colors" or “Decrease Colors" sub menus. The menu item
representing the current color depth is always disabled.

How to reduce to 16 or 256 Colors

Choose 16 or 256 Colors from the “Decrease Colors" sub menu to reduce a photo to 16 or 256
colors. The Color Reduction window will be displayed:

• Select “Default Palette" to use a
standardized palette for color reduction.
While this palette gives a wide range of
colors, it may not always give a good
representation of photo images that do not
have a wide range of shades.

 
• Select “Optimal Palette" to create a photo

image with colors that best represent the
colors in the original.

 
• Select “Dithered Colors" to create a photo

image that uses a standardized palette, but uses a dithering technique, to better simulate the
colors in the original photo.

You are encouraged to experiment between the different color reduction methods to obtain the
results you think look best.
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How to increase colors to 16 Million (True Color)

Select the “16 Million" menu item to create a 24-bit file. You can now use the various special
effect and lens filter tools in MGI PhotoSuite on the file.

How to Reduce to Monochrome

Select this menu item to reduce the current image to black and
white. Select “Use Dithering" to create a monochrome photo
using a dithering technique to simulate shades of gray. Select
“No Dithering" to transform the photo to black and white
without any dithering pattern.

3.64 How to Change to Windows Standard Palette

Certain applications, such as icon editors, require you to use the fixed Windows system palette.
Select this menu item to remap the colors in a 16-color photo to the standard system palette. This
menu item is only enabled for 16-color photos.

3.65 How to Resize your Photo

In the Image menu, go to “Resize…”
Select the desired size in the “Change Image Size”
window to change the size of your working area.
Decide if you want the photo to expand to cover
the working area, and if so click on the “Stretch to
Fit New Size” check box. If you want to add more
blank drawing space without enlarging the photo,
be sure that the “Stretch to Fit” box is not check
marked. Click “OK.”
To resize your image so that it maintains the
correct vertical and horizontal proportions, you
must enter a custom size that maintains the existing aspect ratio. For example, if you have an
image that measures 620 x 380 pixels and you want to increase it’s width to 800, you must
increase it’s height by the same proportion. To find out the correct height:
New width / original width = factor     Original height x factor = new width

800 / 620 = 1.29 380 x 1.29 = 490 (pixels)

You have now calculated the new custom width and height (800 x 490 pixels).
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3.66 How to Rotate your Photo

To rotate an image (or selected part of an image) 90 degrees clockwise, go to the Rotate
icon on the button bar and click once. (Or, from the Image menu choose “Rotate”). To
rotate 180 degrees (to in effect, turn it upside down), click twice. To rotate it 270
degrees, click three times. To return the photo to its original position click a fourth time.

Rotate Mirror

To rotate the image by a custom amount, choose “Rotate by Angle” from the Image menu, and
use the slider to enter the rotation angle in degrees.

3.67 How to Mirror your Photo

For a mirror image of your photo, go to the button bar and select the mirror icon (or you
can choose “Mirror” from the Image menu). This will automatically flip, or reverse the
orientation of your photo.

Note: If desired you can first select an area of the photo, then click on the mirror image or rotate
icon to mirror or rotate only that part of the photo.

3.68 How to Trim an Area of Your Photo

Choose the rectangular selection tool from the Toolbar. With the left mouse button held
down, select an area of your photo you wish to keep. Select “Trim” from the Image
menu. The area outside the square will be discarded.
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3.7 Use Your Photos to Create Great Flyers and Advertisements

There are many ways you can use photos to give your advertisements and flyers added impact.
For example, you could choose to use a photo as the entire flyer background, adding text on top
of it. Or you could arrange several photos on the same page, for example, showing the antique
table, the old bike, and other items you have for your garage sale.

For every layout you choose, simply get the photos you want and resize them to suit the flyer or
ad, and then write your advertisement using the Add Text tool. You can copy and paste your
photos into other applications, for example Microsoft Works, Microsoft Office, Microsoft
PowerPoint and Broderbund Print Shop.

3.71 Use Your Photos to Create A+ School Projects

Impress your teacher and classmates when you import your photos into your next school project.
Make your geography project on the Galapagos Islands come alive with a picture of a giant
turtle. Submit a science project complete with before and after photos of your experiment to
show graphically how your plants grew using a particular kind of fertilizer. Use MGI PhotoSuite
to alter and enhance your photos before you copy and paste them into your project. Here are a
few suggestions:

• Use the Special Effects or Lens Effects to add interest to your projects. Emboss, Crystallize,
Mirage, or other filters will create unique effects and backgrounds.

• Experiment with changing the size and orientation of your photograph.
• Create Text Captions, use a Body Switch, or surround your photo with a Picture Frame.
• Drag & drop, or Cut & Paste photos from MGI PhotoSuite or other applications.
• Get Screen Captures from other applications and the Internet to create exciting multiple

photo collages!

 3.72 Use Your Photos to Create Powerful Business Presentations
 
Imagine how impressive your next business presentation will be with photos to grace the cover or
illustrate important points. Consider how much more effective your charts and graphs will turn
out with a photo behind them, representing your topic. Use a photo as a background, or as a
centerpiece.

Presentations can easily be made more impressive with MGI PhotoSuite. Enhance your photos
using the examples given above and then import them into the word processing package,
spreadsheet or slide presentation program you want, using the Insert feature on those packages.
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 3.8 Printing

MGI PhotoSuite has been created to work well with all popular black and white as well as color
printers. When you print the photos that you've enhanced through
MGI PhotoSuite you can be assured of great printouts on the most basic printers.

MGI PhotoSuite prints using Windows printer drivers. You must install a printer driver in order
to print an image. To install or remove printer drivers, open the Windows Control Panel and
double-click on the Printers icon.

Printer Setup

Select “Printer Setup..." from the File menu to specify printer settings. The Print Setup window
will be displayed. Within this window you may select the printer you want to use, the orientation
and paper size. For information about which settings to use, refer to the documentation that
comes with your printer.

If you have more than one printer
connected to your computer or
network, click on the arrow in the
list box beside the “Name" field
to select from the list of available
printers.

Many printers have specific
settings (such as page orientation,
paper size and graphics
resolution) that you can specify
to get the printing results you
want. Click on the “Properties"
button to see specific options
available for the selected printer.

Printing Photos

To print the active photo, click on the Print icon in the button bar, or select “Print..."
from the File menu. The Print Photo window will be displayed.

The actual appearance of the output is determined by the printer driver and the capabilities of
your printer. Some printer drivers allow you to adjust the darkness of the printed output and to
optimize output for color, greyscale, or photographic images. Select the “Properties" button to
adjust settings specific to your printer.
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 3.9 Photos and the Internet

If you have an account with an Internet service provider, you can download photos from the
World Wide Web (Internet). The Internet is a popular medium for people to access and
download information such as text, drawings, and photos. There are many interesting photos to
choose from on the Internet that you can download and use as “canvases” for your own artistic
enhancements using MGI PhotoSuite.

 3.91 How to Get (download) a Photo From the Internet

Running your favorite browser program, such as Netscape Navigator or Microsoft Explorer,
locate the photo you want to capture on the Internet. Saving a photo can be done in different
ways, so consult the online help of your browser program. For Netscape Navigator (note: for
other browsers, consult the online help):

1. To select a photo from a web page, click with the right mouse button.
2. From the menu that appears, select View Image.
3. From the same menu (or from the File menu), click on Save Image As, type in a name for the
image, and save it into a hard drive directory. Once saved, your photo can be opened up, deleted
or modified in MGI PhotoSuite whenever you wish.

 3.92 Screen Capture – How to Capture Photos from the Internet

Just as MGI PhotoSuite's screen capture utility makes it easy to capture images and photos from
any other application running on your computer (see Virtual Camera, section 7.20), it can also
capture images from an Internet site. To capture images with MGI PhotoSuite's screen capture
utility,

1. Have both your Internet browser program (Netscape Navigator, Microsoft Explorer
etc.) and MGI PhotoSuite open.

2. With your Internet browser program, locate the Internet image that you wish to
capture.

3. Switch to MGI PhotoSuite.
4. Select "Virtual Camera" from the Insert menu or click on the Virtual Camera icon in

the button bar to display the Screen Capture dialog.
5. Use this dialog to specify the capture Options. There are four options to choose from

- Selected Area, Entire Window, Window Contents, or Full Screen.
6. Select the source of the capture in the Capture From dialog box. All open programs

will be listed. Select your Internet browser program.
7. If you select "Selected Area", MGI PhotoSuite will temporarily close and the Internet browser

program that you chose in step 6 will appear. A zoom window will also appear in the left
corner of the screen displaying a closeup view of the area around the mouse cursor. As you
move the cursor over the screen, the particular area will be magnified. Click the left mouse
button and drag the mouse to outline the area of the screen which you wish to capture. A
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flashing dashed box will show the area you have
selected. If you make a mistake in the selection, you
can click the left mouse button again and select a
different area. When you are satisfied with the
selection, click on the Camera icon located in the left
corner of the zoom window.

8. Your selection will automatically be transferred to
MGI PhotoSuite.

 
 
3.93 How to Catalog an Internet Site

The catalog/album utility on MGI PhotoSuite is a powerful tool that you can use with
your Internet browser to catalog an Internet site. To do this,

1. Have both your Internet browser program (Netscape Navigator, Microsoft Explorer,
etc.) and MGI PhotoSuite open, with an Album already loaded into MGI PhotoSuite
(See the section on Multimedia Albums, section 6).

2. With your Internet browser program, locate the Internet site that you wish to catalog.
3. Switch to MGI PhotoSuite.
4. From the Activity Guide select “View an Album”.
5. From the Menu Bar select Insert, From Disk or Floppy.
6. The Add Images to Album dialog box appears. In the Add Images to Album dialog

box, browse and locate the Cache directory for your Internet browser (example:
c:\program\netscape\navigator\cache).

7. Once you have located the Cache directory of you Internet browser, click Select All.
8. Click OK. MGI PhotoSuite will now make a catalog of the Internet site that you have

loaded.

For more information, see the section 5, Multimedia Albums.
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 3.94 How to Make MGI PhotoSuite Your Internet Image Viewer.
 
Most Internet Browser programs such as Netscape Navigator allow you to specify what software
to use when viewing downloaded images from the Internet. MGI PhotoSuite is an excellent
program for viewing downloaded images and we recommend that you make it your Internet
image viewer. To do this with Netscape,

1. Open Netscape Navigator
2. Select “General Preferences” from the Options menu.
3. In the General Preferences dialog box, click on the tab marked "Helpers"
4. Select "image/jpeg".
5. In the "Action" section of the General Preferences dialog box, click "Launch the

Application"
6. Browse to psuite.exe on your hard drive.

The default path for Windows 95 is C:\program files\mgi\photosuite\psuite.exe
The default path for Windows 3.x is C:\photos\psuite.exe

7. Repeat steps 4-6 for "image/tiff" and "image/gif." Click OK when done.
8. MGI PhotoSuite will now act as you Internet Image Viewer for downloaded images in

Netscape Navigator.

If you use an Internet browser program other than Netscape Navigator, consult your Internet
browser program user guide for how to install an image viewer.

3.95 How to Put a Photo onto the Internet

For photos that you intend to place on the Internet, there are a number of factors to consider. The
photo's size, number of colors, and compression methods will affect Internet transfer times.
Additionally, you should take into account the different preferences users have when they are
viewing photos from the Internet, such as their probable video mode (screen size and number of
colors) and the screen space taken up by the Internet browser used to view you photo.

 File Size

The larger an image file's size, the longer it takes to transfer the photo electronically over phone
lines to and from the Internet. The file size should therefore be as small as possible. Since many
users only have 256-color displays, we suggest you reduce photos to 256 colors and use the GIF
file format. This will result in a smaller file size than if you used a true (16.7 million) color
photo. If you prefer keeping your photos at 16.7 million colors, utilizing a file format like JPEG
offers compression, which will help minimize transfer times (see section 4.3, File Formats).
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Photo Size (number of pixels)

Computer systems have a wide range of video capabilities, with monitors from 14" to 21",
resolutions from 640 x 480 to 1280 x 1600 pixels, and colors from 16 to 16.7 million. If you
want to accommodate 98% of Internet users (who may have older systems with lower resolution
screens), you should allow for systems with a screen resolution of 640 x 480 pixels at 256 colors.
If you would like a larger image, 800 x 600 with 256 colors is probably safe for most users. This
is simply a guideline for allowing people to see your photos without scrolling – larger photos are
possible.

Converting your Photo to Web Format

MGI PhotoSuite’s Web Conversion feature automates file preparation for photos intended for
uploading to the Internet. As part of this process it will save the photo to JPEG format and resize
it, if you want, to accommodate the average PC user’s screen.

1. Open the Photo you wish to convert by clicking on the Open Image icon in the button
bar, or selecting “Open” from the File menu.

2. From the Image menu, select “Convert to Web Format.”

3. The Convert Image to Web Format dialog box will
appear. The list of preset “Target Window Size”
values are based on common display sizes used by
Windows. Choose a size that is close to the pixel
size of the photo you want to convert (the size of the
photo is listed in the photo window's title bar). The
“Actual Size” will be the new (slightly reduced) size
of your photo, with its aspect ratio preserved. If your
photo is small to begin with and does not need to be
reduced, select “Exact Size” and it will not be reduced.

The new size takes into account the estimated screen space taken up by an Internet browser. This
size conversion will help you select a photo size that can be viewed in its entirety on-screen,
without the viewer having to scroll. For example, If you select 640 x 480 Target Window Size,
the actual image size after conversion will be approximately 569 x 380 pixels for full screen
images. As you can see, more pixels are lost vertically than horizontally, since most Internet
browsers take up more vertical space with menus and icon bars. If you feel that most users will
have higher resolution screens, or if you have a large photo you don't want or need to reduce, use
a larger target window size (no larger than the photo’s original size). Selecting “Exact Size” will
not reduce the pixel size of your photo.
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4. When you select Convert, the file format JPG is automatically selected. You have the option to
choose an image quality value from 25 to 100. Lower values yield better compression, but at
the expense of image quality. A value of 100 ensures the highest quality, but the resulting file
size will be larger, increasing the uploading time for you and the viewing time for users who
may wish to view your photo. The default is 75, which offers very good quality for most
photos. See section 4.1, File Support.

 3.96 How to get your photos using PhotoNet

If you have an account with an Internet service provider, MGI PhotoSuite and PhotoCenter's
PhotoNet offer a unique way of getting your photos – downloading them directly from the
Internet!

PhotoNet is an on-line photo service that, in cooperation with your local photo developer,
processes your film into electronic images you can retrieve from the world wide web. Just take
your exposed film to any participating PhotoNet retailer and get your film processed as usual.
Don't forget to check the PhotoNet option on the print order form to have your processed photos
placed onto an online PhotoCenter home page. When your photographs are ready to be viewed,
you will automatically receive an e-mail message from PhotoNet informing you that your photos
have been processed, and the film ID number needed to access your photos.

By accessing the PhotoCenter on the Internet using your unique code, you can view and
download the photos of your choice for easy manipulation in MGI PhotoSuite. Your family and
friends can also view your photos no matter where they live, so long as they have an Internet
connection. Simply give them the address of the PhotoCenter and your unique photo ID, and they
will be able to view and download your photos!

You can register with PhotoCenter's
PhotoNet using MGI PhotoSuite's
automated registering function.
MGI PhotoSuite will automatically
access the PhotoNet home page on the
Internet.

Getting your photos from PhotoNet is
easy:

1. From the File menu, select “Get
Photos” then “From PhotoNet...”.

 



71

2. The “Log into PhotoNet”
dialog box will appear. In the
Account Type section, make
sure Online PhotoCenter is
activated. Type in your name
and the information provided
in the e-mail you received
from PhotoNet.

3. Click on the Setup button.
You will be presented with a
Billing Information box for
you to fill in, stating your
name, address, and other
information. When you have finished
typing in all data, click OK to store the
data. The next time you want to access
PhotoNet, you can skip Setup unless you
wish to change the information.

 3.97 Uploading Photos to the Internet
using PhotoNet

You can upload your own photographs to
PhotoNet, (to provide family and friends
access to your photos on-line, for example).

1. From the File menu, click
on “Send,” and then ”To
PhotoNet.”

2. Choose New Film or
Existing Film, as required.

3. Click OK. You will see the
send status dialog.

You can add new photos  to
existing film, if desired.
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 4.0 MGI PhotoSuite’s Advanced Features
 

4.1 File Support

An image can be represented in many forms, such as a painting, picture, etc. Computerized or
digitized photo images are comprised of color dots called “pixels" set in a grid of rows and
columns. Each pixel is a specific color. The number of possible colors in a photo image can vary
from two to 16.7 million. While the simplest type of image has only black and white pixels and is
referred to as a “monochrome" image, “True Color" images can contain any of 16.7 million
colors and offer the widest range of colors available for editing using MGI PhotoSuite.

Photo image sizes can vary from a single pixel to a size as large as system memory and resources
can accommodate.

4.2 Color Depths

The type of photo image data determines the range of colors the image may contain. “Color
Depth" specifies the maximum number of colors available. In the simplest type of image, each
pixel can be either black or white. Since each pixel can have only two different states, one “bit"
of information is required to store each image. However, an image with 8 bits of color
information per pixel allows 256 possible colors (2 to the power of 8 equals 256).

MGI PhotoSuite supports the following color depths; Black and White (1 bit per pixel), 16 color
(4 bits per pixel), 256 color (8 bits per pixel) and 16.7 million color (true color, 24 bits per
pixel). In addition, MGI PhotoSuite lets you work with grayscale images containing either 16 or
256 colors. The actual number of colors you will see on your monitor depends on the type of
video hardware and video drivers you are using.

MGI PhotoSuite allows the conversion, from one to another, of the following formats:

Monochrome: One-bit data type. Each pixel can be either black or white.

Grayscale: Grayscale images can contain black, white and a range of grays. 16-color (4 bits
per pixel) Grayscale images contain 16 shades of gray ranging from pure white to pure black.
256-color (8 bits per pixel) grayscale images contain 256 shades of gray ranging evenly from
pure white to pure black.

Indexed 16 and 256-color:  Indexed (or color-mapped) images contain colors specified by a
table of color values. Color values may be chosen from a larger range of available colors, but
only the colors actually in the table are displayed in the image. For example, your system may
display 256 colors simultaneously, but if you load a 16 color image, you can only draw in it
using the 16 colors contained in the color table for that image.



73

Indexed 16-color images use 4 bits per pixel to represent the image, while indexed 256-color
images use 8 bits per pixel.

True Color: True color (16.7 Million) images use values of red, green and blue to represent
colors. Each pixel can contain 256 different intensities of red, green and blue, combined to
obtain the final color. Examples: if red, green and blue all have a value of zero, the final color is
pure black; If red, green and blue all have a value of 255 (the maximum intensity), the final color
is pure white; If red and green have a value of 255 but blue is zero, then the final color is pure
yellow, since red and green combine to produce yellow when displayed on a computer monitor.

True color photo images use 24 bits per pixel to represent the image, divided into 8 bits for each
primary color (red, green and blue). Certain file formats store true color images as 32-bit images,
which have an extra 8 bits to store transparency or overlay information. MGI PhotoSuite will
load these files, but ignore the extra data.

4.3 File Formats

Photos are stored in a variety of file formats. Many image file formats have been developed for
specific applications and hardware. MGI PhotoSuite supports a large number of commonly used
file formats. These include:

Windows Bitmap (BMP)

The Windows Bitmap file format is the standard file format used by Microsoft Windows. Bitmap
files can contain either 2 (black and white), 16, 256 or 16.7 million colors. Most Windows
Bitmap files are not compressed. It is possible to save 16 and 256 color images in a compressed
format (See Run-Length Encoded below) but some applications (notably Windows Paintbrush)
are not able to read the compressed files. The default file extension for Windows Bitmap files is
“.BMP". Occasionally you may see bitmap files with the extension “.DIB".

Windows Run-Length Encoded (RLE)

The RLE format is a variation of the Windows BMP format with a modest degree of image
compression. It has two primary uses under Windows: it can be used to create compressed
wallpaper files and it can be used to replace the opening Windows logo screen with a file of your
own choosing. RLE files are always either 16 or 256 color image files. The default file extension
for Windows RLE files is “.RLE".

CompuServe Graphics Interchange Format (GIF)

The GIF file format was used by CompuServe Inc. for their on-line service. GIF files are color-
mapped files that can have anywhere from 2 to 256 colors. MGI PhotoSuite supports both the
87a and 89a versions of the GIF standard. GIF files are always compressed and offer an efficient
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way to store large images. The default file extension for CompuServe Graphics Interchange
Format files is “.GIF".

Joint Photographic Experts Group (JPG)

The JPEG format uses a method of compression that reduces photo image file size by selectively
reducing image detail and by transforming the image data into a format more suited for
compression. Photos with fewer details compress extremely well, while pictures with a high
degree of random detail may show some degree of image degradation. The relative amount of
detail removed is specified by the JPEG quality item in the “Save Image" file selector. Because
of it's efficient compression, JPEG is an excellent format to use if you plan to upload photos to
the Internet. It is not the best format to use if you plan on editing the photo, however, because
each time you re-save the photo, there will be some picture degradation. This is referred to as
“Lossy” compression, where some image information is lost in the interest of better compression.
For editing purposes, use a format like TIFF or BMP.
Tip: At the default value of 75, relatively little picture degradation will take place, and a
significant amount of compression will be obtained. Lower values will give you even better
compression, but with a marked loss of image quality. JPEG images are either true color or
greyscale (256 shades of gray).

 FlashPix (FPX) – available with the 32-bit version of MGI PhotoSuite

A FlashPix file contains the complete image plus several smaller copies, all within the same file.
This has the advantage of producing high-quality printouts using the higher resolutions, along
with fast image manipulation by using the smaller resolutions for screen display. Images at each
resolution are also divided into tiles, which enables the application to minimize the amount of
data processed while accessing, displaying or printing a portion of the screen content. MGI
PhotoSuite will load .FPX images and preserve all transformations, and has the ability to save
your image to .FPX for loading into other programs that support FlashPix. Note that FlashPix
uses JPEG compression, which means some picture degradation will take place if the file is
saved multiple times in .FPX format. For editing purposes, use a format like TIF or BMP.
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Photo CD (PCD)

Digitized photographic images on can be stored on CD-ROM disks. These photos are converted
to true color (24-bit) images when loaded into MGI PhotoSuite. Photo CD CD-ROM disks
include one or more Photo CD images plus an overview file containing small “thumbnail”
versions of each image on the disk. Photo CD image files always reside in a directory named
PHOTO_CD\IMAGES on a Photo CD disk. However, you may also encounter Photo CD image
files on networks, bulletin boards and other types of CD-ROM disks which lack the overview
file. MGI PhotoSuite can read Photo CD files even in the absence of the overview file, by using
the open file selector to select the Photo CD file by name.

MGI PhotoSuite does not save images in Photo CD file format. If you wish to save an image you
have loaded from a Photo CD file, we suggest you choose either the JPEG or TIFF file format
and save to your hard drive.

Each Photo CD file contains a number of scans of the same image at different resolutions. MGI
PhotoSuite supports the following Photo CD resolutions, expressed in pixels: 192 x 128, 384 x
256, 768 x 512 and 1536 x 1024. The 3072 x 2048 format is not currently supported by MGI
PhotoSuite under Windows 3.1. Note: If you only have four megabytes of memory installed in
your computer you may not have sufficient free memory to edit the 1536 x 1024 pixel Photo CD
format. The default file extension for Photo CD files is “.PCD".

Truevision Targa (TGA)

The Truevision Targa format was originally developed by Truevision Inc. for use with their line
of graphic display cards. The Targa format is used by several high-end paint and CAD programs.
Color resolutions range from 256 color, 65,536 (16-bit) high color, 24-bit true color and 32-bit
true color formats. The 32-bit Targa format contains 24 bits of color data as well as 8 bits of
transparency (overlay) data. MGI PhotoSuite extracts the color data from 32-bit Targa files but
ignores the transparency data. Targa images exist in both compressed and uncompressed formats.
The default file extension for Targa files is “.TGA".
 
PC Paintbrush (PCX)

PCX files were originally developed for Z-Soft's PC Paintbrush package. These files come in
monochrome, 16 color, 256 color and true color (24-bit) varieties. PCX files are compressed
using a method that offers a modest degree of compression compared to other compression
formats. The default file extension for PC Paintbrush files is “.PCX".
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Tagged Image File Format (TIF)

The TIFF format was developed by Microsoft and Aldus Corporations as a portable method of
storing bitmap photo images. MGI PhotoSuite supports the current 6.0 specification for TIFF
files. TIFF files come in monochrome, 16-color, 256-color, 16-color grayscale, 256-color
grayscale and true color (24-bit) varieties. When saving files in the TIFF format, MGI
PhotoSuite automatically recognizes that a photo image is in grayscale format and saves it in the
appropriate format.

Note: TIFF files exist in both compressed and uncompressed formats. The compression format
offers a high degree of compression. However, certain older paint programs that use an early
version of the TIFF format may have difficulty reading compressed TIFF files. If you find that a
program will not read the compressed files, try saving the file in the uncompressed format. The
default file extension for TIFF files is “.TIF".

Other Photo File Formats

From time to time, other file formats will be added to and supported by MGI PhotoSuite. For an
up-to-date list, see the “Image File Formats" topic in the MGI PhotoSuite on-line help. From the
Help menu, select “Contents,” then “Files,” and then click on “Image File Formats.”

MGI Album File (CTF)

The CTF format was developed by MGI so you can store thumbnails for cataloging your photos
and multimedia files.

Thumbnails (miniature visual representations of your photos) are great for keeping your photos
organized and in full view whenever you want them. Consider how much easier it is to choose
the photo you want to work with in MGI PhotoSuite when a whole group of your photos can be
displayed at once, in thumbnail form. As well, you can use this feature to create a series of
albums, each one containing photos relating to a particular theme, such as your wedding or
recent ski trip. From there, you can build slideshows to present the photos in any sequence you
set!

Thumbnails of photos can be either 256 or 16-million colors and one of any nine sizes. You can
change display options as desired.
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 4.4 Opening Multiple Photos

You can select more than one file at a time using the file selector that appears whenever you
“Open” a photo from the File menu. To select a range of files, click on the first file, press and
hold the [Shift] key, and click on the last file in the range. To select or undo a selection of
individual files, press and hold the [Ctrl] key and click on a file name to toggle it between
selected and not selected.

4.41 Opening Multiple Photos and Memory

While MGI PhotoSuite allows you to have multiple photos open at one time, this reduces
available memory. If you are running low on memory, close one or more photos.

4.5 Photo Information

4.51 Getting Information about a Photo

To obtain information about one or more
photos, select one or more filenames in the
file selector and click on the “File Info..."
button to display the File Information
window.

The file name, photo type, file size, width,
height, number of colors and compression
method (if applicable) will appear in the
information window. If you selected
multiple files, click on the OK button to see
information for each file.

4.52 Previewing Images

If the “Preview" checkbox is selected, MGI PhotoSuite will display a thumbnail preview of an
image file when you select it in the list of file names. The thumbnail image will appear in the
lower portion of the file selector. If you have selected more than one file, the preview window
will be disabled. To enable the automatic preview of photos, click on the “Preview" checkbox.
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4.6  Saving Photos

4.61 Saving Photos

When you open an existing file for editing purposes, MGI PhotoSuite retrieves and
copies the file from disk, temporarily stores it in the computer's memory, and displays it
on the screen. As you work, you are actually editing this copy.

Saving your file updates the file back on the disk, keeping your latest work safely stored.
It's a good idea to save your work to disk periodically. However it is recommended that you
change the file name or you will save over the original file.

If you get into this habit, you will not lose much work in the event of a power failure or some
other problem. When you save a file, your work remains open on the screen so that you can
continue working. If any changes have not been saved when you quit MGI PhotoSuite, a message
asks whether or not you want to save the changes.

4.62 Saving a New, Untitled Photo or Image

To save a new, untitled photo, select
“Save As..." from the File menu or the
Save Photo icon. The screen will display
the Save Photo file selector (similar to the
selector you saw when opening files). In
the “File name" field, type the name you
are giving the photo image, for example,
TEST.BMP. A file name (plus extension)
cannot exceed 260 characters in Windows
95 or NT 4.0. In Windows 3.1, the file
name is limited to 8 characters plus
extension.

Within the Save Photo file selector, you
also specify the file path used, including
drives and directories, for the file's storage
and future retrieval. You may select a
drive and a directory using your mouse or

by typing the complete path in the “File name" field, for example, C:\IMAGES\TEST.BMP.
Click on “Save" to save the file.
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4.63 Specifying the File Format

When you save an existing file, MGI PhotoSuite remembers the file format in which the file was
last saved on disk. The “Save as type" control will display this file format. If you save a new
photo enhancement, the “Save as type" control will display a default format. Click on the “Save
as type" list box to select a different file format. If you have already entered a file name, the file
selector will alter the file name extension as required, according to the selected file format.

4.64 Specifying the Color Depth

The “Bits Per Pixel" box will display the default color depth in which the file will be stored. If
the file format you select does not support a particular color depth, then its corresponding button
will be disabled. For example, Targa file format does not support 16-color (4 bits per pixel)
images. If you attempt to save a 16 color photo image as a Targa file, it will be saved as a
256-color (8 bits per pixel) image, the next highest available resolution.

Note: If you wish to save a photo at a lower color depth than it is at present, you must first
reduce it to the desired color depth before saving it. However, if the file format allows both 8 and
24-bit color depths, you can choose to save 24-bit photo images as 8-bit (256 color) images and
MGI PhotoSuite will automatically reduce the 24-bit photo to an 8-bit representation as it saves
the image to a file. (In this example, the photo in memory will remain as a 24-bit image.)

4.65 Specifying Compression Options

Certain photo file formats allow you to choose whether or not to compress the photo file. If the
selected file format supports this feature, the “Compression" control will be enabled. Select the
“Compression" checkbox to enable image compression. Deselect the “Compression" checkbox to
disable image compression.
Some file formats always save photos in compressed format. In those cases, the “Compression"
checkbox will always remain selected. Other file formats do not permit compression. In those
cases the “Compression" checkbox will always remain unselected.

4.66 Saving the Current Photo

To save your current photo to an existing file, click on the Save icon in the Button bar or select
“Save" from the File menu. The active file will be saved under the name and path you last
specified and in the file format in which it was last saved.

4.67 Saving a Photo using a New File Name

• Select “Save As..." from the File menu to create more than one copy of a file, or to save
copies on another disk for safekeeping. You can save each copy under a different name, or
you can save them under the same name in different directories or on different disks. Before
saving a copy to another disk, first save the file to your hard disk.
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• To save a file under a different name, select “Save As..." from the File menu. Type a new

name for the file in the “File name" field within the File Selector displayed on your screen. If
you want to save the file to a different drive or directory, you may select the new drive or
directory using your mouse, or you may type the complete path in the “File name" field.
After you have made your selections, click on the “Save" button.

If you type a file name that already exists within the directory you have selected, MGI
PhotoSuite displays a window asking you whether or not you wish to replace the existing file
with the currently active file. Click on the “Yes" button to save the new file and replace the old
one, or click on the “No" button and type a different file name. Click on the “Cancel" button to
return to the active file without saving it.

Note: If you wish to save the file to a different file format, select a format using the “Save as
type" control.

4.68 Saving all Open Photos

Select “Save All" from the File menu to save to disk all open files. Old versions of your files will
be replaced by the currently active versions. You will be prompted to specify a file name for any
new images you have created.

 4.69 Closing a Photo

Closing a photo window indicates to MGI PhotoSuite that you are finished with the currently
active photo. Close a photo window either by clicking the Close control in the upper right corner
of the image window, by selecting “Close" from the File menu, or by pressing [Ctrl]+[F4] on the
keyboard. Close all open drawing windows by selecting “Close All" from the File menu.

Note: If the file has changes that have not been saved to disk, you will be asked whether or not
you wish to save the changes.

• If you choose “Abandon", the photo window will close and your changes will not be saved
to disk.

• If you choose “Cancel", the image window will not be closed.

• If you choose “Save", the drawing file will be saved to disk. If the file is untitled, a file
selector will appear allowing you to choose a file name and file format for the image.

Saving Photos when Exiting

Select “Exit" from the File menu to exit MGI PhotoSuite. If you have not saved your work, the
Save Changes window will appear to ask whether or not you wish to save the work. Click on the
“Save" button if you do indeed wish to save your work. If you have not yet named and saved the
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file, the Save Image file selector will be displayed. To save your work, follow the same
procedure as described above under “Saving a New, Untitled Image".

If you do not wish to save your work, click on the “Abandon" button in the Save Changes
window. The program will be terminated without saving your work.
If you have already saved your work, selecting “Exit" from the File menu will immediately
terminate the program.

4.7 TIFF Horizontal Predictor

The “TIFF Horizontal Predictor" is a special compression option for TIFF files only. This option
is only available when saving TIFF 24-bit compressed image files. The Horizontal Predictor
enhances the compression of photos that contain areas with gradual changes of color and
shading.

However, this compression option may not be supported by software written for older versions of
the TIFF file format. Only select this option if you are sure that the software that will be reading
the file supports this feature.

4.8 Reverting to a Previous Photo

Select “Revert to Saved" from the File menu to reload the last saved version of the current photo.
All changes since the last save will be discarded.
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4.9 Photo CD Support

MGI PhotoSuite reads the Photo CD file format and loads photos in one of four available
resolutions. You can specify a desired resolution when opening a file through the “Open Photo"
window, or from the “Load Photo CD Image” window. Available resolutions are 192 x 128, 384
x 256, 768 x 512 and 1536 x 1024 pixels. Depending on the orientation of the original
photograph, the Photo CD image will be in landscape orientation (width greater than height) or
portrait orientation (height greater than width).

4.91 Selecting Photo CD Photos

If you have a CD-ROM disk created in Photo CD format, you can choose “Photo CD..." from the
File menu to display the Photo CD selector, which will show thumbnail views of all the photos
on the disk.

Scroll through the available Photo CD photos using the scroll bar. Select a thumbnail and click
on OK, or double-click on a thumbnail image to load the desired photo.

The highest resolution photos in a PCD file require large amounts of memory to load and edit. A
1536 x 1024 Photo CD image requires five to eight megabytes of memory, depending on the
current video mode (true color modes requires more memory than 256 color modes) plus an
additional four megabytes of memory for undo operations. If you have limited memory, you may
wish to choose a smaller size image.
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5.0 Multimedia Albums

5.1 Working with Albums

In section 3.14 we learned how to create a Photo (multimedia) Album. This section covers the
creation, use and maintenance of Multimedia Albums.

5.11 Using Multimedia Albums

The multimedia album is a powerful visual tool used to keep track of your images and
multimedia files. Small thumbnails, or miniatures, of your files are created that can be saved to,
reordered in and sorted between different albums. You can even attach descriptions to each of
your photos in the album - such as a title or the name of the photographer who took the picture
and when it was taken. A text editor is built in for any lengthy descriptions you may wish to
attach. While the most obvious application of Multimedia Albums is for your photos, you can
create albums to organize any file type you want. Create as many albums as you wish and assign
as many documents, photos, video clips, sound files, etc. as you wish to each one. You can also
assign the same photo to different albums.

Album of Sound Files ↓
Album of Photographs ↓

It's so much easier to browse through a pictorial album of your files and see small versions of the
actual photos than to browse through a long list of file names! If you would like to work with an
image, simply double-click on its thumbnail to load the original image into MGI PhotoSuite. If
you would like to change the relative position of a file in the album, just click on it and drag it to
the new position, or even into another album window.

You can even create a slideshow from your album (see section 6, Slideshows).
Click on a thumbnail with the right mouse button to view important characteristics of the file
associated with it. A small text box will appear, showing you where on your system the file is
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stored, any title you have assigned to it, the file's size and format, and the pixel size of the
thumbnail. Press [Alt]+[Enter] after clicking on a thumbnail to see and edit your own database of
information about the file.

5.12 Creating a Multimedia Album

To create a new album, from the File menu, choose “New”, then “Album...".

Note: The New Album icon is the same icon used for New Image. The window opened
depends on the type of application window currently active (highlighted). If the
application window currently active on the screen is an

Album file, then clicking on the icon will display the New Album window. If the application
window currently active on the screen is a Photo file, then clicking on the icon will display the
New Photo window.

The New Album window prompts you to specify
the size and color depth to be used for the
thumbnail photos in the new album. Choose the
desired size from the drop-down list box, check
the desired color depth and click “OK".

Tip: 16-million color thumbnails look best, but
they take more time to build, more disk space to store, and if your computer cannot display 16.7
million colors (most computers display up to 256 colors), you will be wasting your time and disk
space.

5.13 Organizing your Photos into Albums

First, make an album containing all of the photos (files) that you want to organize. Then, make a
new album for each category into which you wish to sort your photos by saving a new album
under a new name for each category you want. When making each new album, simply click
“Cancel" when presented with the “Add Thumbnails" window.

With all albums open on the display, select “Window", then “Tile" to give each some room on
your screen. Sort the files in the first album into the other albums by dragging each file from one
window to the other.
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5.14 Retrieving Information about Thumbnails

By pressing the right mouse button when the mouse pointer is over a thumbnail, the following
pop-up window appears, displaying the location of the file, its name and location, title, date, file
size and file type information:

Right-click on another thumbnail to get information about it, or press [Esc] to dismiss the
thumbnail information pop-up.

5.15 Moving Thumbnails within an Album

You can also sort the thumbnails within your catalog by simply dragging and dropping them into
position. Click and hold down the left mouse button on the thumbnail you wish to move and drag
it to its new position. You must drop it on top of another thumbnail. The thumbnail you moved
will replace the thumbnail it covers. The other thumbnails will shift toward the position the
moved thumbnail vacated.

If moving the thumbnail to the position you have selected is possible, the cursor is displayed as a
small page with the “+" sign in it. If the position is not allowed, the cursor is displayed as a circle
with a diagonal line through it.

5.16 Moving Thumbnails from one Album to Another

You can also move thumbnails from one catalog to another by simply dragging and dropping
them into position. Open a second album and choose “Tile” from the Window menu to show
both albums at the same time, in different windows. Hold down the left mouse button on the
thumbnail you wish to move from the first album and drag it to its new position in the second
album. In this case, you do not need to drop the thumbnail on top of another one. For example:
you may drop the thumbnail after the last one in the album and it will take this last position. If
you do drag the thumbnail and drop it on top of another, the replaced thumbnail and all those
below it will shift down one position in the album.

You can move more than one thumbnail at a time by selecting those you want to move, then
dragging one of them. All selected thumbnails move with the one you dragged. (Select more than
one thumbnail by [Ctrl]+clicking on each. Select a range of thumbnails by clicking on the
thumbnail at one end of the range, then [Shift] + click on the thumbnail at the other end of the
range).
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5.17 Converting an Album to another Size/Color Depth

If you have created an album of files in one size and color depth, and you would like to change
the size and/or color depth of the whole album, just create a new album with the size and color
depth you desire, copy all your thumbnails into that and update them. It's easy to do. Here's how:

1. From the File menu choose “New” and then “Album...", selecting the size and color depth you
want.

2. Open the album that you want to convert.
3. From the Edit menu, choose “Select All", then again from the Edit menu, “Copy".
4. Now select the new album you just made and choose “Paste" from the Edit menu.

All of the thumbnails you selected in the original album are instantly pasted into the new album -
but the thumbnails are all still in the same size and color depth as before.

5. Change this by choosing “Album", “Update", “All Images...", then check “All files" and click
“OK".

6. When finished updating the thumbnails, close the original album and then save the new album
by choosing “File", “Save As" and clicking on the name of the old album, then on “OK".

5.18 Making a Slideshow from an Album

First, display your album and arrange the thumbnails in the order you want them to appear in the
slideshow. Make sure you save the album before making the album into a slideshow. Click on
“View" from the Menu Bar and choose “Run Slideshow". The slideshow will be based upon the
album you have selected. If you want to make changes to your slideshow simply change the
album you are working with or create a new album for you slideshow. See section 6, Slideshows.

5.19 Opening Existing Albums

To select and load an existing catalog file, choose “Open" from the File menu.

Note: The Open Album icon is the same icon used for Open Photo. The type of file opened
depends on the type of application window currently active (highlighted). If the application
window currently active on the screen is an Album file, then clicking on the icon will display the
Open Album window. If the application window currently active on the screen is a Photo file,
then clicking on the icon will display the Open Photo window.

The Open Album file selector lets you specify the name and location of the album file (files
ending with CTF) to be opened. Select an album file and click “OK" to load the album and
display it in a new window. The file name is displayed in the title bar of the Album window. The
file name and path is displayed in the Help line located at the bottom left of the application
window. The number of thumbnails in the album and the amount of memory it occupies is
displayed in the Help line located at the bottom right of the application window. Each thumbnail
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is identified according to the Caption setting active when the album was last saved. (There are
three possible settings, “None", “Filename", or “Title").

5.2 Saving and Closing Albums

5.21 Saving Albums

To save an opened album file, choose “Save" from the “File” menu.

When you open an existing file for editing purposes, MGI PhotoSuite retrieves and copies the
file from disk, stores it temporarily in the computer's memory and displays it on the screen. As
you work, you are actually editing this copy. When you save changes, those changes written to
the original file.

When you save a file, your work remains open on the screen so that you can continue working.
When you quit MGI PhotoSuite, if any changes have not been saved, a message asks whether or
not you want to save the changes. The active file will be saved under the same name and path
specified when it was last saved.

Saving an Album using a New File Name (Save As)

When you save a new album for the first time, or wish to save an album with a new or different
name, or to a new disk, select “Save As..." from the “File” menu or the Save Album icon in the
Button Bar. The Save Album file selector - similar to the one you saw when opening files - will
be displayed.

• To save an album using a new file name: In the “File name" field, type the name you are
giving the album, for example, “Sample.CTF". All album file names are followed by the
“CTF" extension. When typing the file name, it is not necessary to type the extension; the
extension will automatically be assigned. Within the Save album file selector, you also
specify the file path used, including drives and directories, for the file's storage and future
retrieval. Select a drive and a directory using your mouse, or by typing the complete path in
the “File name" field, for example, “C:\Albums\Sample.CTF". Click on “OK" to save the
file.

 
• Select “Save As..." to create more than one copy of a file, or to save copies on another disk

for safekeeping. You can save each copy under a different name, or save them under the
same name in different directories or disks. Before saving a copy to another disk, you should
first save the file to your hard disk.

 
• To save a file under a different name, type a new name for the file in the “File name" field.

If you want to save the file to a different drive or directory, either select the new drive or
directory using your mouse, or type the complete path in the “File name" field. After you
have made your selections, click on the “OK" button. If you type a file name that already
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exists within the directory you have selected, MGI PhotoSuite displays a box asking you
whether or not you wish to replace the existing file with the currently active file. Click on the
“Yes" button to save the new file and replace the old one, or click on the “No" button and
type a different file name. Click on the “Cancel" button to return to the active file without
saving it.

Note: You cannot save a file using the same file name as an album that is already open in a
different window. However, you could save it a different location (directory) on your hard drive.

Saving all Open Albums

Select “Save All" from the File menu to save to disk all open album/image files. The old versions
of your files will be replaced by the currently active versions. You will be prompted to specify a
file name for any new albums you have created.

 5.22 Closing an Album

Closing an album window indicates to MGI PhotoSuite that you are finished with the currently
active album. Close an album window either by clicking the Close control in the upper right
corner of the catalog window, by selecting “Close Album" from the File menu, or by pressing
[Ctrl]+[F4] on the keyboard. If the file has changes that have not been saved to disk, you will be
asked whether or not you wish to save these changes. If you choose “Abandon", the album
window will close and changes will not be saved to disk. If you choose “Cancel", the album
window will not be closed. If you choose “Save", the album file will be saved to disk. If the file
is untitled, a file selector will appear allowing you to choose a file name and path for the album.

5.3 Finding Existing Albums

5.31 Including Folders and using Wildcards to Find Files (Photos)

You can also use wildcard file names in the file selector edit box. Wildcard file names include an
asterisk in the name to find all files resembling the name you typed in. If you want to view
several files with similar names, you could type the letters that all the files have in common and
an asterisk for the dissimilar characters. For example, typing *vacation*.* will show all files and
file types with “vacation” in the name of the file. All files matching the wildcard you specify will
make a thumbnail. If you check the “Include Folders” checkbox, folders (sub-directories) below
the current folder will also be searched for wildcard matches. This way, you could build an
album for all the files on a drive, by leaving the default file wildcards in the edit box, selecting
the drive's root directory and checking “Include Folders”. The entire drive will be searched for
any and all files matching the name you typed, and each one will be included in your album. If
you do not have a wildcard file name in the file selector edit box, then the “Include Folders”
checkbox is disabled.
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5.4 CD-ROM based Albums

Each thumbnail in an MGI PhotoSuite multimedia album remembers the original file's path and
file name, and, if the file is from a CD, it recalls the volume name of the CD containing the file.

Note: If you create an album from a hard drive image of a yet-
to-be mastered CD, each thumbnail will retain the correct path
and file name as expected (assuming that all the files will be in
the same directories on the hard drive as they will be on the
CD). However, because the files are not yet on a CD, a
volume name will not be recorded for the thumbnails. So, if
you double-click on a thumbnail, MGI PhotoSuite will not be
able to find the files on the CD after the hard disk image has
been transferred to the CD.
Tip: MGI PhotoSuite provides a special feature to work around this limitation. After creating an
album of the hard drive CD image, press [Ctrl]+[Shift]+[F9] and manually enter in the volume
name of your CD. Click “OK” and then save the album. This will force the specified volume
name for all of the files in the album.

5.5 Thumbnails

5.51 Viewing Thumbnails

MGI PhotoSuite supports the viewing of thumbnails with several caption styles and sort orders.

Thumbnail Captions

• Select “Caption" from the “Album” menu to specify how you wish to identify thumbnails in
the album. Your selection determines what, if any, information is displayed below each
thumbnail.

• Choose “None" to remove any thumbnail identification tags from the album display. Only
the actual thumbnails of your files will be displayed, without any identifying information.

• Pick “Filename" to display each thumbnail's file name below it.

• Choose “Title" to display the title you assigned to each thumbnail.

5.52 Sorting Thumbnails

• Select “Sort By" from the “Album” menu to sort the thumbnails within your album
according to different parameters.

• Choose “Filename" to sort your thumbnails alphabetically by file name.
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• Choose “Title" to sort your thumbnails alphabetically by the Titles shown under the
thumbnails. (Applies only if Thumbnails, Title is not set to none.)

• Choose “File Type" to sort your thumbnails alphabetically by file type as given by the file
extensions. First file types are sorted alphabetically, then file names within each file type are
sorted alphabetically.

• Choose “Size" to sort your thumbnails according to their file size.

• Choose “File Date" to sort the thumbnails according to the dates the files were originally
created. Do not confuse this file date with the date you may have previously assigned to the
thumbnail in the Edit Thumbnail Information window.

5.53 Adding Thumbnails to an Album

Select “From Disk" or “From Floppy” from the Insert menu to add images or multimedia files to
an album. The Add Images to Album window will be displayed (if you are creating a new album,
this window will be displayed automatically):

This file selector is similar to the Open Album
and Open Photo dialog box. Select the files
that you wish to add to the album and click
“Open" to load the files and display them in
the album window. (To select more than one
file, click on one of them. To select a range,
[Shift]+click on the other end of the range. To
add individual files to your selection(s),
[Ctrl]+click on each). MGI PhotoSuite will
automatically create thumbnails of the selected
files (according to the album's thumbnail size
setting) and add them to the album. If the
thumbnails are to be added to a new album, it
will create thumbnails as small or as large as you have just specified in the New Album window.
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5.54 Editing Thumbnail Information

Select “Description..." from the “Album” menu, or press [Alt]+[Enter], to add a description to a
thumbnail. The Edit Thumbnail Information dialog will appear:

 
 
 Options:

• If you wish to add a description to a particular thumbnail in the catalog, first select the
thumbnail and then select “Description..." from the Thumbnails menu (or press
[Alt]+[Enter]). The specified file to which you want to attach the description will be
represented in the Edit Thumbnail Information window.

 
• If you wish to add descriptions to a number of thumbnails, select more than one thumbnail in

the catalog ([Ctrl]+click on each thumbnail to be added to the selection list), or make sure
no thumbnail within the album is selected (by clicking within the Album window, but not on
any thumbnail). Open the Edit Thumbnail Information window. In this case, a scroll bar is
displayed below the thumbnail. Use the scroll bar to view all thumbnails (or all the selected
thumbnails) within the album. In this way, you can add descriptions to each thumbnail one
after another.

It is not necessary to fill in each and every field. Just fill in the ones of interest to you.
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Below the window's title bar are four text fields:

Title:  In this field, type in any title that you wish to attach to the thumbnail.

Photographer/Artist:   In this field, you can record the name of the photographer or artist
responsible for the file, or the original source of the file.

Date [yy-mm-dd]:  In this field, you can record the date the file was created, the date you
obtained the file, or any other date regarding this thumbnail that is important.

Format:   In this field, record the file format of the thumbnail, or the camera/film type used, or
the type of shooting session or location - whatever is important to you.

Text Editor:   Located to the right of the thumbnail, the Text Editor is used to add any further
description of the thumbnail. First click anywhere in the text field. A flashing cursor will be
displayed. Simply type the text you wish to record as you would in any standard text editor.

Note: If you wish to insert a tab in the text, you cannot just press [Tab], because this causes the
cursor to jump out of the text field and on to the next one (which is the City field). To insert a tab
in your text, you should press [Ctrl]+[Tab] instead.

Below the thumbnail and the Text Editor are five more text fields:

City:  In this field, record the city in or near which the file was created.

Activity:  In this field, you may record the activity associated with the file.

State/Province: In this field, type the state or province in which the file was created.

Location: In this field, you can record a more particular location at which the file was created.

Misc: Use this field to record any miscellaneous description.

 
5.55 Updating Thumbnails in an Album

• Select “Update" from the Album menu to update your thumbnails with any changes you may
have made to the files associated with them. If, for example, you select a thumbnail within
your album and subsequently edit its associated image within MGI PhotoSuite, then by
selecting Update, the original thumbnail in your album will be updated with the changes
made to the image.
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• Choose “Selected Images Only..." to update only the selected thumbnails in the catalog.
(Select more than one thumbnail by [Ctrl]+clicking on each. Select a range of thumbnails by
clicking on the first in the range and then [Shift]+click on the last in the range.) Once you
have chosen to update thumbnails, the Update Thumbnails window is displayed.

 
• Choose “All Images" to update all thumbnails in the album. After choosing this menu

option, the Update Thumbnails window is displayed.

This window allows you to choose between updating each thumbnail regardless of changes in the
file size or file date (“All Files" or “All Selected Files"), or to update only the thumbnails for
files with changes in size or file date (“Only files with different size or date" or “Only selected
files with different size or date").

In addition, you can specify a folder search path for
finding files that have been moved from one drive or
folder to another (“Search for files in the following
folders").
If MGI PhotoSuite tries to update a thumbnail for a
file that has been moved from one drive or folder to
another, you are presented with a window prompting
you to indicate to MGI PhotoSuite where you moved
the file. After you do this, the new folder is added to
this search path. The folders in the path are always
checked for other moved files.

Note: Moving a file does not cause it's thumbnail to be updated unless you choose “All Files" or
“All Selected Files" in the Update Thumbnails box.
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5.6 Creating an Album in HTML Format

Once you have created or loaded the album of your choice, you can save it in HTML (.HTM)
format for easy inclusion into Web pages! (Contact your Internet Service Provider about
obtaining your own Home Page on the World Wide Web).

1. Load or create a regular photo album as described in section 5 Multimedia Albums.

2. Select “Create HTML Album” from the
Album menu to save in HTML (.HTM)
format. Type in the title you want for
the album and then choose a
background for your album page, if
desired. If no background is chosen, the
thumbnails of your album will appear
over a white background. If you check
the Thumbnails only box, separate
HTML pages with the full size images
will not be generated.

3. Select a destination and name for the HTML album and click “OK.”

Pages created in this way consist of a “home” or index page with thumbnails, just as in regular
albums. The thumbnail and photo name are “links” to the larger photos. Clicking on a link brings
up a page with the full size photo and any description you have entered for the photo (see section
5.54, Editing Thumbnail Information). To return to the Album thumbnails, click on the “Back to
the Album Index” link.

These HTML pages can be used
as part of your web site, or even
as your own Home Page on the
world wide web. Contact your
Internet Service Provider for
details on adding to (and
obtaining) your own Home Page.
The information displayed with
the thumbnail depends on the
caption type selected from the
Album menu. The choices are
None, File Name, or Title. If you
choose None, no information will
be displayed under the thumbnail.
File Name will display the actual name of the file, while Title will display the title you assigned
in the description (see section 5.54, Editing Thumbnail Information).
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The HTML feature offers
limitless possibilities – you can
easily post and update your
photo portfolio for prospective
business clients to browse, or
create your family's Home Page
for friends and relatives to
view. Create several categories
of albums, showcasing your
best work in MGI PhotoSuite!

Click on the thumbnail to see
the full-size image and
description page.
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 5.7 Placing Video Files into an Album

Video files can be arranged in an album the same way as photographs. To create a new video
album, from the File menu, choose “New”, then “Album...”.

The New Album window prompts you to specify the size and color depth to be used for the
thumbnail photos in the new album. Choose the desired size from the drop-down list box, check
the desired color depth and click “OK".

The Add Images to Album window will then
be displayed.

Choose files of type: Video. The .AVI, .MOV,
MPG files will be displayed. You can choose
more than one file by holding down the
[Control] key while selecting files.

Once the video files of your choice
have been loaded, they are displayed in
the album window. You can rearrange
them in any order you wish, simply by
dragging to another location.

You can add descriptions for each
video clip thumbnail the same way you
would for photographs (see section
5.54, Editing Thumbnail Information).

When you have finished creating your
video album, choose “Save As...” from
the File menu. Type in a name to save
the video album under.

Video files can be played by
double-clicking on the thumbnail
of your choice in the album
window.
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 6.0 Slideshows

The slideshow feature allows you to create a presentation using a list of pictures, sound files and
AVI animation files.

6.1 Slideshow Manager

First, display your album and arrange the thumbnails in the order you want them to
appear in the slideshow. Make sure you save the album before making the album into a
slideshow. Click on “View" from the menu bar and choose

“Run Slideshow," or click on the Slideshow icon in the button bar. The slideshow will then be
the album you have selected. If you want to make changes to your slideshow simply change the
album you are working with or create a new album for you slideshow.

 
 
6.2 Editing a Slideshow

The display order of your images in your slideshow is controlled by the order of the thumbnails
in the album. You can drag and drop the thumbnails to re-order your albums. The slideshow
album can contain any type of photo file normally readable by MGI PhotoSuite, including sound
and animation files.
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6.21 Adding Files to a Slideshow

Select “From Disk or Floppy” from the Insert menu. You will be presented with the “Add Images
to Album” dialog box.

The slideshow list can contain any type of
photo file normally readable by
MGI PhotoSuite, plus album (*.CTF),
sound and animation files.
 
Note: Sound files include MIDI (*.MID)
files and wave (*.WAV) files. You must
have a sound card and the appropriate
multimedia drivers installed to play sound
files. Animation files have the file extension
“.AVI". You must have the Video for
Windows runtime module (distributed by
Microsoft) installed on your system to play
AVI files.

6.22 Removing Files from a Slideshow

Click on the thumbnail of the slide you wish to remove and press the Delete key or select Delete
from the Edit menu.

6.3 Slideshow Display

The slideshow settings are configured after you run the first slide. Select “Setup" and you will be
presented with the Slideshow Settings dialog box.

Select “Cycle Continuously” to play the
slideshow continuously.

Enter the number of seconds between
images in the text edit field. This
specifies the minimum delay between
images. This setting is ignored for sound
files.

Click on “Background Color...” to choose
a background color for the full screen
slideshow window.
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6.31 Background Sound

Instead of adding sound files to the slideshow list, you can specify a single sound file to play
continuously during the slideshow. Click on “Browse..." to select a background sound. Select the
“Enable" checkbox to enable the background sound.
 
Note: If you select a background sound, you will not be able to play other sound or animation
files during the slideshow as they will conflict with the background sound.

6.32 Running Slideshows

Select “Run Slideshow" from the view menu to run the slideshow, or click on the
Slideshow icon in the button bar.

6.4 Controlling Slideshows

The Slideshow dialog window will be displayed while the slideshow is running. The current slide
file name is displayed in the top portion of the window.

Click on the buttons to control the operation of the slideshow. Click on the horizontal scroll bar
and the scroll bar arrows to move from one slide to another. Click on the Exit button to exit the
slideshow.

 Other options:

• To hide the slideshow window, click on the Close icon in the top right corner of the window,
or press [Esc]. To redisplay the dialog, press the spacebar.

 
• To abort the slideshow, press [Esc] to close the slideshow window and press [Esc] again to

quit the slideshow.

 
• To change the settings of a slideshow while it is running, select “Setup". The Slideshow

Settings dialog will be displayed. Use this window to continuously cycle slideshows, change
the time between slides, and change background color.
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 7.0 Other Information
 
7.1 MGI PhotoSuite Settings

Select “Settings..." from the View menu
to display the MGI PhotoSuite Settings
window:

Use this window to configure various
MGI PhotoSuite's defaults and options.

Save Workspace

• Select "None" to instruct MGI
PhotoSuite to ignore this option.

 
• Select “Active File" to instruct MGI PhotoSuite to automatically load, the next time you run

it, the last active photo or album when you exited the program.

 
• Select “All Files" to instruct MGI PhotoSuite to load all the photos and albums, open at the

time of exiting the program, the next time you run it.

Startup Preferences

• Select “Auto New Image" to tell MGI PhotoSuite whether to create a blank image if no
image or photo is loaded.

 
• Select “Show Full Screen" to have MGI PhotoSuite open a photo in full screen view when a

photo file is opened from the Windows Explorer or File Manager.

Register File Types

Select the file type(s) that you want MGI PhotoSuite to handle when the respective photo file is
opened (double-clicked) from the Windows Explorer or File Manager.

Note: Windows 3.1 does not offer the Register File Types option, and so this area of the dialog
box is left blank.
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7.2 OLE Support

MGI PhotoSuite for Windows 95 and Windows NT supports File Drag & Drop and OLE 2.0
Image Embedding with Linking and In-Place Editing.

File Drag and Drop

MGI PhotoSuite supports plain file drag and drop. Click on and drag a photo file icon from the
Windows Explorer or File Manager and let go on top of the MGI PhotoSuite icon, or on top of
the main MGI PhotoSuite window. When you let go of the mouse button, MGI PhotoSuite will
open the photo and show it to you.
Additionally, if you drag a photo icon over top of a printer icon, and drop it there, then MGI
PhotoSuite will print the photo for you.

Embedded Images

An MGI PhotoSuite embedded image means that you can use MGI PhotoSuite to work with a
photo you might embed or place in another OLE compliant program's document. WordPad,
which comes with Windows 95, is an OLE compliant program. You could, for example, use
WordPad to type in some text and then choose “Insert" and then “Object". You will see a list of
object types that the software installed on your computer can create as an embedded object.
“PhotoSuite Image" will be listed there among the others.

• If you choose “Create New", MGI PhotoSuite will ask you what size image you want to
create. It will then insert into your WordPad document a blank image of the size you
requested, and provide you with tool and color panels in WordPad with which to create your
drawing or diagram. Essentially, you are creating a diagram in WordPad (without leaving
WordPad), even though it is MGI PhotoSuite that you are using to do the drawing in
WordPad. Clicking outside the drawing area “fixes" the drawing into your WordPad
document, and the MGI PhotoSuite panels will disappear.

 
• If you choose “Create from File" instead, you will see a standard file selection dialog box,

allowing you to type a file name, or select “Browse" to click on one. If you choose an MGI
PhotoSuite image file such as TIF or JPG, etc. then the image will be placed in your
WordPad document, and MGI PhotoSuite tool and color panels will be available in
WordPad to do any editing you wish.
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 7.21 In-Place Editing

At any time, you can double-click on an embedded image (or right-click on the image and choose
“Edit") and you will see the MGI PhotoSuite tool and color palettes again, allowing you to edit
the image without leaving WordPad. Clicking outside the image will fix the edited image into
your document and remove the tool and color palettes.

 
7.22 Linking Images

When inserting an image into another document, if you choose “Create from File" you will be
given the opportunity to choose “Link".

• If you do not choose “Link", then a copy of the image is stored in your document, and this
copy, and any changes you may make to it, are separate and independent from the original
image file and any changes made to the original image file.

 
• If you do choose “Link" then a copy of the image is stored in your document, but both the

original image file and the image in your document are kept in sync. Changes in the original
image file are always carried automatically to the embedded image in your document.

Note: If you select the “Link" option, then you cannot perform “In-Place Editing". When the
“Link" option is chosen, double-clicking on the image brings the MGI PhotoSuite program to the
foreground, with the original copy of the image opened and ready for editing. You always edit
the original copy if the image is “Linked", and when you're done, the changes are automatically
copied from the original to the embedded copy of the image.
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7.3 TWAIN Support

MGI PhotoSuite implements support for the industry-wide TWAIN specification to enable
scanners, digital cameras and other image input devices that you may have attached to your
computer.

TWAIN Device Drivers

• Under Windows 95, MGI PhotoSuite supports both 16 and 32-bit TWAIN drivers. 32-bit
drivers are preferred, if available.

 
• Under Windows NT, MGI PhotoSuite supports only 32-bit TWAIN drivers.

 
• Under Windows 3.1, only 16-bit TWAIN drivers are supported.

Note: Please consult the manual that came with your TWAIN-compatible device for information
on which version(s) of Windows are supported. As well, see the “TWAIN" topic in the MGI
PhotoSuite on-line help for additional information.

Selecting an Input Source

From the File menu, select “Get Photos” and then “Select Source..." to display a window that
enables you to choose between different image acquisition sources. Two such devices might be a
TWAIN-compatible scanner or a TWAIN-compatible video capture card.

After using this menu item to choose an image acquisition source, you can use the “From
Camera/Scanner..." menu item from the File menu to obtain an image from your chosen device.

Acquiring Photos

• From the File menu, select “Get Photos” and then “Select Source..." to display a window
that enables you to choose between different image acquisition sources, to bring an image
into MGI PhotoSuite for saving, editing, or conversion from the device chosen with the
“Select Source..." menu item.

For example, if previously you had chosen a scanner device with the “Source Select..." menu
item, then choosing “From Camera/Scanner..." will activate the scanner software installed with
your TWAIN-compatible scanner. You will then be able to use your scanner to make a digital
copy of a printed image in MGI PhotoSuite.
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7.4 Undo and Redo

Undo

Each time you make a change to the image, MGI PhotoSuite records the information required to
reverse its effect. Select “Undo" from the Edit menu to undo the most recent command. Pressing
[Ctrl]+Z or [Alt]+[Backspace], or clicking on the Undo icon, has the same effect as selecting
Undo.

Redo

Select “Redo" from the Edit menu to redo the command that has just been undone. In other
words, the effect of the most recent Undo is reversed. For example, if you draw a line, then select
Undo, the line will be removed. Selecting Redo at this point will insert the line once again.
Pressing [Ctrl]+[Shift]+Z, or clicking on the Redo icon has the same effect as selecting Redo.

7.5 Edit Commands

Delete

The Delete command is used to delete an area selection or selected thumbnail(s). You can also
press the [Del] key to perform the same operation.

Duplicate

The Duplicate command is used to create a copy of the currently active image. This allows you
to work on one image while viewing the original. For your convenience, You may resize one or
both images.

Select All

The Select All command can be used to select all items in an active album window or select the
entire contents of an active image window.

Invert Selection

The Invert Selection can be used to select all items in an active album window or select the entire
contents of an active image window. Picking this menu item will deselect selected thumbnails
and select deselected thumbnails. For an active image with an area selected, the area selected will
be reversed when Invert Selection is chosen.
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Select None

The Select None command is used to deselect a selected area. Click outside the selected area to
deselect it.

 
7.6 Using the Clipboard

The clipboard is a temporary storage area for text and graphics that you are copying from one
location to another. The clipboard is used to exchange information between applications, as well
as copying or moving items within an application.

You can Cut (remove) items from the workspace to the clipboard, including whole
images, selected areas, floating sections, or thumbnails.

The Copy command copies a photo, selected area, floating section, or thumbnails to the
clipboard. If there is no area selected, the entire image in the active window will be
copied.

The Paste command is used to paste a selection from the clipboard into the active image
or into a new photo window, (or, one or more thumbnails into an album).

If you previously copied a selection to the clipboard, the selection from the clipboard will appear
in the top left corner of the active image surrounded by an animated border. You can click and
drag inside the border to move the selection to a new location. Press [Enter] or click the left
mouse button outside the border to paste the selection into the image at the current location. If
you copied a photo to the clipboard from another application, or copied an entire photo to the
clipboard from MGI PhotoSuite, the Paste command will open a new window containing the
photo from the clipboard.
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 7.7 Virtual Camera (Screen Capture)

The virtual camera feature of MGI PhotoSuite is very useful when you wish to clip
sections or areas from other applications, manipulate them and then save them, or paste
them into another Windows application such as a word
processor.

Select “Screen Capture..." from the Insert
menu or click on the Screen Capture icon in
the button bar to display the Screen Capture
window. Use this window to specify the
capture Options, the source of the capture
(Capture From) and the destination for the
screen capture (see Advanced, below).

Options

There are four main screen capture options available in MGI PhotoSuite.
 
Selected Area

Choose “Selected Area" to capture an area of the highlighted application. After selecting this
option and clicking on the Capture button, MGI PhotoSuite will temporarily close and the
application window you chose will appear.

A zoom window will appear in the left corner of the screen displaying a close-up view of the area
around the mouse cursor. As you move the cursor over the screen application, that particular area
will be magnified. This allows you to select an area with precision. You can move this window
by clicking the mouse inside the window and dragging it to a new location. Click the left mouse
button and drag the mouse to outline the area of the screen you wish to capture. A flashing box
will show the area you have selected. If you make a mistake in selection, you can click the left
mouse button again and select a different area.
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Note: Pressing the cursor keys up,
down, left and right will move the
selection area around the screen.
Pressing the cursor keys while
holding down the [Shift] or [Ctrl]
keys will adjust different sides of
the selection area.

When you are satisfied with the
selection, click on the Camera icon
located in the left corner of the
zoom window. Your selection will
automatically be transferred to
MGI PhotoSuite or to the
destination that you specified.

Click the '+' icon to increase the magnification in the zoom window.
Click the '-' icon to decrease the magnification in the zoom window.
Click the '?' icon to display a brief help message in the zoom window.

 Entire Window

Choose “Entire Window" to capture only the entire main window of the source application, at the
size you are displaying it on the screen. After selecting this option and clicking on the Capture
button, the image you selected will automatically be captured and transferred to MGI PhotoSuite
or to the destination that you specified.

Window Contents

Choose “Window Contents" to capture the contents of a window of the highlighted application.
After selecting this option and clicking on the Capture button,
MGI PhotoSuite will temporarily close and the contents of the application window you chose
will appear. As you move the cursor, now displayed as a camera icon, around the screen, the area
under the icon will be highlighted. This highlighting indicates the area that will be captured.
Click the left mouse button to capture the highlighted area. Your selection will automatically be
transferred to MGI PhotoSuite or to the destination that you specified.
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Full Screen

Choose “Full Screen" to capture everything displayed on the full screen, including the
highlighted application window. After selecting this option and clicking on the Capture button,
MGI PhotoSuite will temporarily close and the application window you chose will appear. A
snapshot will be taken and transferred automatically to MGI PhotoSuite or to the destination that
you specified.
 
Note: You cannot switch applications or activate menus or dialog windows while performing a
screen capture. You can press [Esc] to cancel the capture operation. Also, at any time you can
press the [Print Screen] key and then paste to MGI PhotoSuite the entire screen that you have
captured. For this option there is no need to activate the Capture command.

Capture From

From this list, choose an application on which to perform the capture operation. For example, if
the image or the area you wish to clip is present in an encyclopedia, then make sure you select
the encyclopedia in this section.

Advanced

Click the “Advanced" button to display the following choices:

Destination

• Select “MGI PhotoSuite" to transfer captured photos to MGI PhotoSuite. A captured photo
will appear in a new window in the MGI PhotoSuite main window.

 
• Select “Clipboard" to transfer captured photos to the Windows clipboard. You can then

paste the captured photo into any application that supports the Windows BMP.

 
• Select “Both" to transfer captured photos to both MGI PhotoSuite and the clipboard.

7.71 How to Capture an Image from MGI PhotoSuite

1. Press Alt + Print Screen.

2. Click on the Clipboard icon and the entire MGI PhotoSuite screen plus any image that
was present in the window will be displayed. 
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 7.8 Color Selection

The Color window is used to change a color in the current Color Palette. Double-click the left
mouse button on a color in the Color Palette to display the Color window and edit the foreground
color. Double-click the right mouse button to edit the background color.

The selected color is displayed in the Color
window. The numbers inside the Red,
Green and Blue text edit fields are the
actual red, green and blue values used to
specify the color and can range from 0 to a
maximum of 255. Hue, Sat (Saturation)
and Lum (Luminosity) are used
alternatively to specify color values. Hue
specifies the shade of the color. Saturation
specifies the intensity of the color and
Luminance specifies the brightness of the
color.

• Select a color by entering color values,
or by clicking inside the color
selection boxes at the top of the Color
window. The large color selection box
in the top left of the window allows
you to select the hue and saturation.
The top of the box displays fully
saturated colors while the bottom of
the box displays colors with low
saturation. The color hue varies from 0
at the left edge of the box to 255 at the
right edge of the box. Click inside the
box and move the mouse to select a color hue and saturation.

The smaller, rectangular box at the right of the window displays the color selected on the left side
of the window in a range of luminosity values from 0 to 255, in other words, from solid black to
solid white. Click the left mouse button and drag the mouse up and down to select a luminosity
value.
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7.9 Working with Windows

MGI PhotoSuite allows you to work with multiple open photo images on the screen (subject to
your system's memory capacity). When you open several photos at a time, some windows are
hidden behind others. Use this menu to arrange the photo windows and customize the MGI
PhotoSuite tools:

Next

When you have more than one photo window open, one window is always the active window and
its title bar is highlighted. Any inactive photo windows do not have highlighted title bars. Select
Next from the Window menu, or press [Ctrl]+W, to activate the photo window immediately
beneath the currently active window.

Previous

Rather than move ahead to the next image window, select Previous from the Window menu, or
press [Ctrl]+[Shift]+W, to move back to the previous photo.

Close All

This menu item will close all open image and album windows, the program will prompt you
about saving any unsaved images or albums.

Cascade

Select this option to resize and layer your photo windows in cascading order on your screen. The
title bar of each image will be visible. Select the photo on which you wish to work by clicking
once on its title bar. The activated photo will be displayed in the foreground.
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Tiling

Tile Vertical

Select this option to resize and arrange your photo windows in a vertical manner on the screen.
The screen will display as much of each photo window as possible, subject to the allotted screen
space. Select the photo on which you wish to work by clicking once anywhere within the photo
window.

Tile Horizontal

Select this option to resize and arrange your photo windows in a horizontal manner on the screen.
The screen will display as much of each photo window as possible, subject to the allotted screen
space. Select the drawing on which you wish to work by clicking once anywhere within the photo
window.

Arranging

Arrange Icons

Select this option to arrange all minimized photo window icons along the bottom of the main
application window.

Arrange Panels

Select this option to arrange the Tool Panel and the Color Palette to the right side of the MGI
PhotoSuite application window workspace.

Window List

The bottom of the Window menu features a list of titles of the currently opened images. A check
mark appears beside the title of the currently active photo. To activate another photo, click once
on the desired title, or press the number of the title that has been assigned to it. The number
corresponds to the order in which the photos were opened or created during the current work
session.
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7.91 Using Your Photos for Desktop Windows Wallpaper

You can use MGI PhotoSuite to put your photo on the background of your computer screen.

1. Get the photo you want either from the photo album, by clicking on the Open Image
icon, or by choosing “Open” under the File menu.

2. Select Fun from the menu bar above your screen.

3. Choose Set as Windows Wallpaper. Click on that and your photo will be positioned
in the center of the page as your screen “wallpaper” or background.

7.92 Using Your Photos as a Windows Screen Saver

It's easy to turn your photo into a Screen Saver with MGI PhotoSuite.

1. Get the photo you want either from the photo album, by clicking on the  Open Image
icon, or by choosing “Open” under the File menu.

2. Select Photo from the menu bar above your screen.

3. Choose Set as Windows Screen Saver. Click on that and your photo will appear every
time you leave your PC unattended for a few minutes.
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8.0 MGI PhotoGallery

A Stunning Gallery of Over 500 Professional Photos and Images!

MGI's PhotoSuite lets you enhance your own photos in many artistic and humorous ways, but
just imagine what you could do if you had over 500 professional photos and images to work and
play with! That's exactly what you'll get with MGI's PhotoGallery CD. For just US$14.95, MGI's
PhotoGallery will give you an amazing gallery of 24-bit color images and photos, including
backgrounds, textures, landscapes, and more!
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Index

A
Acquiring Photos: 103
Activity Guide: 18
Albums, Multimedia: 83-96

CD-ROM based: 89
Creating new: 84
Converting size, color: 86
HTML: 94
Opening existing: 87
Organizing Photos: 84-85
Saving: 87-88
Saving As: 87-88
Saving All: 88
Slideshows: 97-99
Thumbnails: 83-6, 89-96

Adding: 90-91
Editing information: 91-93
Moving: 85-86
Sorting: 90
Updating: 93-94
Viewing: 89-90
Using: 83
Video: 96

Air Brush: 23
Antique: 51
Area Flood Fill: 23
Area Selection: See Selection

B
Balloons, Word: 57
BMP: 73
Body Switch: 57
Brightness, Changing: 59
Brush: See Pen
Business Presentations: 64
Button Bar: 21-22

Hide/Show: 20

C
Cartoonize: 45
Catalog MGI CTF File: 76
Circle

Draw Filled: 23
Draw Hollow: 23

Circular Selection: 38
Clipboard: 105

Copy: 21, 105
Cut: 21, 105
Paste: 21, 105

Clone: 24, 25

Color
Adjust: 60
Depth: 61
Erasing: 23
Increase/decrease: 61
Selecting: 26

Color Palette: 26
Hide/Show: 20

Coloring Book: 41
Compression: 74, 79
CompuServe, GIF: 74
Cool: 51
Copy: 21, 105
Crop: See Trim Image
Crystallize effect: 43
CTF: 76
Cut: 21, 105

D
Dithering: 62
Draw

Circle Filled: 23
Circle Hollow: 23
Clone: 24, 25
Ellipse Filled: 23
Ellipse Hollow: 23
Line: 23
Point: 23
Polygon Filled: 23
Polygon Hollow: 23
Rectangle Filled: 23
Rectangle Hollow: 23
Rectangle Round Filled: 23

Rectangle Round Hollow:
23

Square Filled: 23
Square Hollow: 23
Square Round Filled: 23
Square Round Hollow: 23
Text: 34

Drawing
Pen: 23
Tools: 22-3

Duplicate: 104

E
Effects: 40-51

Cartoonize: 45
Coloring Book: 41
Crystallize: 43
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Emboss: 41
Enhance Edges: 43
Gausian Blur: 44
Mirage: 44
Mosaic: 42
Oil Paint: 46
Oval Frame: 45
Posterize: 43
Relief: 43
Remove Scratches: 44
Ripple: 46
Sharpen Details: 42
Smoked Glass: 44
Soften Details: 42
Sperize: 45
Splatter: 42
Stretch: 46
Swirl: 45
Tile: 44

Ellipse
Draw Filled: 23
Draw Hollow: 23

Elliptical Selection: 38
Email, send photos via: 32
Embedding Images: 101
Erase: 23
Eyedropper: 24

F
Files: 30, 91
File Selection: 73-76

Naming Files: 30
Fill Area: 23
Filter Image: 51
Flip Image (mirror): 63
Floating Palettes: 20
Fog: 51
Font: 34, 57
Formats Supported: 59-62
Freehand Selection: 24, 39
Free Rotate: 63
Full Screen, viewing: 53
Fun With Faces: 47-50

G
Gamma Correction: 60
Get Photos: 31
GIF: 74
Grayscale: 61

H
Help: See On-line Help
Help Line: 27
Hide/Show tool palettes: 20

How To: 33-71
HTML Albums: 94-95

I
Icon Tool Tips: 27
Image:

Brightness, Changing: 59
Closing a photo: 81
Color Correction: 60
Creating New: 33
Flip Image: 21, 63
Gamma Correction: 60
Grayscale: 61
Information about: 77
Mirror Image: 63
Opening: 35
Opening Multiple: 77
Photo CD: 75, 82
Preview: 35, 77
Printing: 65
Resizing Images: 62
Reversing Colors: 61
Revert to Previous: 81
Rotate: 63
Saving: 78
Saving All: 80
Saving As: 80
Saving Current: 80
Saving On Exit: 81
Saving Untitled: 78

Specifying Color Depth:
79
Specifying Compression: 79
Specifying File Format:
79

Trimming Images: 63
In-Place Editing: 102
Information about Photo: 77
Installing MGI PhotoSuite: 12
Internet

Catalog Site: 67
Get Photos From: 66
Image Viewer: 68
Put Photos On: 68-70
Screen Capture: 106-108

Introduction to
MGI PhotoSuite: 8
Invert Selection: 104

J
JPG, JPEG: 74

L
Lens Effects: 51
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Line Drawing: 23
Linking Images: 102

M
Magic Wand: 23, 25
Memory Usage: 77
Menu Bar: 20
MGI PhotoSuite

Introduction: 8
Photo Editor: 20
Settings: 100

Mirage: 44
Mirror Image: 21, 63
Monochrome: 62
Moonlight: 51
Mosaic Effect: 42
Multimedia Album: 83

N
New

Album: 84
Image: 33

O
Oil Paint: 46
OLE: 101

Embedding Images: 101
In-Place Editing: 102
Linking Images: 102

On-line Help
Accessing: 28
Help Line: 27
Searching: 29

Open
Album: 87
Image: 30, 77

Optimize Palette: 60
Overview Window: 27

Hide/Show: 20
Oval Frame: 45

P
Palette: 26

Floating Palettes: 20
Paste: 21, 105
PC Paintbrush: 75
PCD: 75
PCX: 75
Pen

Drawing: 23
Shape: 24
Size: 24
Type: 24

Personalized

Calendars: 53
Greeting Cards: 53
Magazine Cover: 54
Play Money: 57
Sports Card: 54

Photo CD: 75, 82
Photo Collage: 36
PhotoNet: 70-71
Picture Frame: 56
Play Money: 57
Polygon

Draw Filled: 23
Draw Hollow: 23

Polygonal Selection: 39
Posterize Effect: 43
Preferences: 100
Presentations

Business: 64
School: 64

Preview: 35, 77
Print: 65
Printer

Drivers: 65
Setup: 65

Product Support: 113
MGI Address: 8, 113
Via On-line Services: 113

Props: 58
Put Photos Onto

Windows Screen Saver: 112
Windows Wallpaper: 112

R
Rectangle

Draw Filled: 23
Draw Hollow: 23
Round Filled: 23
Round Hollow: 23

Rectangular Selection: 37
Red Eye: 15, 59
Redo: 104
Register File Types: 100
Relief: 43
Remove Objects: 58
Remove Red Eye: 59
Repair Damaged Photo: 58
Resize Image: 55-56, 62
Resize Floating Selection

Using Mouse: 36
Using Keyboard: 36

Reverse Colors: 61
Revert to Previous: 81
Ripple: 46
RLE: 73
Rotate Image: 63
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Run Length Encoding: 73

S
Save Image: 78

in Web format: 69-70
Scanning: 16, 103
School Presentations: 64
Screen Capture: 106-108
Searching On-line Help: 29
Select All: 104
Selection

Area: 36
Circular: 38
Elliptical: 38
Freehand: 39
Polygonal: 39
Magic Wand: 38-39
Rectangular: 37
Resizing: 36

Send photos via email: 32
Sepia: 51
Settings

Application: 100
Slideshow: 97-99

Adding Files: 98
Controlling: 98, 99
Editing: 97
From Album: 86
Removing Files: 98
Running: 99

Smoked Glass: 44
Spherize: 45
Special Effects: 40-51
Splatter Effect: 42
Spray Can: see Air Brush
Square

Draw Filled: 23
Draw Hollow: 23
Round Filled: 23
Round Hollow: 23

Startup Preferences: 100
Stretch: 46-50
Swirl: 45
System Requirements: 12

T
Taking Better Photos: 14
Tan: 51
Targa: 75
Technical Support: 113
Text

Draw: 24, 34, 57
Font: 34

TGA: 75

Thumbnail: 83-85, 89-97
Add to Album: 90-91
Captions: 89-90
Edit Information: 91-93
Information About: 85
Moving: 85-86
Organizing: 84-85
Sorting: 90
Updating: 93
Viewing: 89-90

TIF, TIFF: 76, 79
Tile effect: 44
Tool Bar: 20

Hide/Show: 20
Tool Tips: 20, 27
Trim Image: 63
True Color: 68, 73
Truevision: 75
TWAIN: 103

Acquire: 103
Device Drivers: 103
Input Source: 31, 103
Scanning: 16, 103

U
Undo: 104

V
Virtual Camera: 22, 106-108

Screen Capture: 106-108

W
Warm: 51
Web format, saving in: 69-70
Window

Arrange Icons: 111
Arrange Panels: 111
Button Bar Hide/Show:

20
Cascade: 110
Color Palette Hide/Show: 20

Color Sidebar
Hide/Show: 20

Next: 110
Overview Window: 27

Hide/Show: 20
Previous: 110
Tile Horizontal: 111
Tile Vertical: 111
Tool Panel Hide/Show:

20
Tool Sidebar Hide/Show: 20

Word Balloons: 57
Working with Windows:
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110-111
Window List: 111
Window Snapshot: 106-108
Windows Bitmap: 73
Workspace Settings: 100

Z
Zoom: 22


