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 What is Publisher’s Paradise PhotoAlbum?

The PhotoAlbum is a utility which allows you to:
 Organize libraries of images

Search through these libraries
Select an image(s)
Send selected images to a desired program

You can also create new libraries and categories of images and save them.

The PhotoAlbum displays previews of the images which are divided into categories.

    Related Topics



The Publisher’s Paradise PhotoAlbum window

Click on an area of the PhotoAlbum window below to popup a description of the selected area.

    Related Topics



Menu bar: The horizontal bar containing the names of the PhotoAlbum's menus. Click on a menu name to drop-
down a list of the corresponding commands.



Control-menu icon: Click on this to display the PhotoAlbum's Control menu. By using Control menu commands 
you can resize, move, maximize, minimize, and close windows.

Keyboard shortcut: Alt Spacebar



Minimize button: Click on this to reduce the PhotoAlbum window to an icon.
When you reduce the PhotoAlbum to an icon, it continues to run but its window does not take up space on 

your desktop.



Maximize button: Click on this to enlarge the PhotoAlbum window to its maximum size.
After you enlarge the PhotoAlbum, the Maximize button is replaced by the Restore button, which contains 

two overlapping squares.    Click on the Restore button to return the PhotoAlbum window to its previous size.



Close button: closes the PhotoAlbum window and returns to the linked program.



Title bar: The title bar shows the name of the program, in this case, the PhotoAlbum.
You can maximize the PhotoAlbum by double-clicking on its title bar.    To restore it to its previous size, 

double-click on the title bar again.
To move the PhotoAlbum to a different location on your desktop, drag its title bar to the new location.



Category list area: Displays the list of category names, and their icons. The images in the selected category 
appear in the preview area on the right. 

Category names in bold have sub-categories, the sub-categories are displayed indented from the main categories.



Preview area: Displays previews of the images in the selected category.



Info line: Displays information about the PhotoAlbum.

The left-hand part of the info line displays hints on what to do next so it changes depending on what you are 
doing at the time. 

The right-hand part of the info line displays the name of the image preview at which you are pointing. It also 
displays the selected category’s associated folder.

When loading or searching for an image file, the progress is shown here with the use of a blue bar. The bar 
moves to the right as loading and file conversion nears completion. At any time you can press Escape to cancel the 
process.



Vertical bar: Drag this bar to the left or right to alter the amount of space given to the image previews and the 
category list.



File: Drops down the File menu. From this menu you can create a new library, open and save an existing library 
and exit the PhotoAlbum.



Edit: Drops down the Edit menu. From this menu you can rename a selected category or image preview, copy 
selected images to the Clipboard, select and deselect all images and make a library read only.



Category: Drops down the Category menu. From this menu you can create new and empty categories.



Image: Drops down the Image menu. From this menu you can add images to categories, remove a selected 
category or image preview from the PhotoAlbum window and move or copy an image preview into a different 
category.



Options: Drops down the Options menu. From this menu you can turn the info line on or off, choose to display the 
PhotoAlbum window in front of any other window, salvage disk space and choose how the PhotoAlbum displays 
previews and categories.



Help: Drops down the Help menu. From this menu you can select the contents page of the PhotoAlbum Help, gain 
information about what version of the PhotoAlbum you are using and display a copyright notice.



Scroll bar: Scroll this bar to view the entire range of image previews. 



Scroll bar: Scroll this bar to view the entire list of categories. 



Glossary definitions:



The vertical bar that appears to the right of the categories, and the horizontal bar that appears below the 
image previews, when not all the categories or previews are visible. By scrolling these bars the entire range of 
categories and previews can be seen.

The vertical bar that appears to the right of a drive drop down list, folder list or file list. Scroll the bar to view 
the hidden files and folders etc.



 A standard Windows menu displayed by clicking on the program icon at the top-left of a window, or clicking on a 
program running as an icon. By using Control menu commands you can resize, move, maximize, minimize and 
close windows.



To choose a command, menu, program, icon, etc. with the mouse or keyboard.



A subdivision of a dialog box containing options and controls. A dialog box may have several tab cards or none; 
click on the tab to move between cards.



A predefined setting that you can change to suit your preferences.



Files are routed to a certain destination as defined.



Information that you enter into the computer to specify or find certain files e.g.

c:\presswk\stories

c: is the drive, presswk is the program and stories is the file type.



A list of commands that drop down after selecting a topic from the menu bar e.g. Edit.



A menu that drops down when you click on a command in a main menu.



Each category has a single folder to which it is linked. This may be the one suggested by default or specified by 
you. When specifying a folder you can:

Choose one containing files of the image previews that appear in the category.
Choose a new folder and later move or copy those files into the associated folder using the Tidy Up option 

in the Options menu.



A collection of pictures, often classified by themes, which can be used in a wide variety of programs and utilities.



Short for Picture Element. One of many thousands of dots that make up an image on screen.



A window that is temporarily displayed to request information. When a dialog box appears, all interaction with the 
PhotoAlbum must be through the dialog box.



A bitmap representation of an image.



A collection of images stored under different categories.



A heading under which images of the same theme are stored e.g. Sport.



A file that cannot be overwritten. If changes are made to a read only library then you must save it under a different 
file name.



The info line is at the bottom of the PhotoAlbum window. It provides you with hints and tips as you work.



The highest category in the hierarchy of categories. It does not have a parent category.



A category that has sub-categories within it.



A category belonging to a parent category.



A graphical representation of a disk, file, category, program or any other object that you can select or open.



A structure for organizing your files onto disk. A folder can contain files, libraries and other folders called subfolders.



A subfolder belonging to a parent folder e.g.

Q:\PROJECTS\CAB\US

CAB is the subfolder



A temporary storage area used to transfer images within and between programs.



To copy an image preview to a selected category, folder or program.



To move an image preview to a selected category, folder or program.



A switch or icon which is used to turn a feature on or off.



A device used for storing information on a computer. Each drive within your system has a name. These names 
could include A: which is usually the floppy disk drive and C: which is your hard disk.



To select an image, drag it from the preview area and drop it into a category or program. This is the easiest method 
of copying images into your chosen category or program. 



The horizontal or vertical movement within the PhotoAlbum window in order to view hidden previews or 
categories.

The vertical movement within a list box to view the hidden files and folders etc.



To load an image file or category into the PhotoAlbum.



A message box or menu which appears, providing you with information.



A means of carrying out a command from the keyboard without opening a menu first. If there is a keyboard shortcut, 
it is shown after the command in the menu. Not all commands have a keyboard shortcut.



The window or icon you are currently using or that is selected. When either a window or icon is active, it is 
highlighted.



Keyboard Shortcuts

If you are familiar with Windows, you will already know that there are many keyboard equivalents to using the 
mouse.

The PhotoAlbum provides its own additional equivalents and shortcuts, and these are listed below.
           Moving around the preview area  
           Moving around the category list  
           Menu command shortcuts  



Moving around the preview area

Click on an image preview in the preview window, then use one of the following key sequences:

Press To

¯ Select the image above or below the current image.

¬® Select the image to the left or right of the current image.

PgUp/PgDn Selects the first and last image in the preview area.

Home Select the first image in the current category.

End Select the last image in the current category.

Shift Home Select all images from the currently selected image to the first image in the current category.

Shift End Select all images from the currently selected image to the last image in the current category.



Moving around the category list

Click on a category in the category window, then use one of the following key sequences:

Press To

¯ Select the category above or below the current category.

PgUp/PgDn Scroll the categories by one window then select the category at the top or bottom of the window.

Home Select the first category in the list.

End Select the last category in the list.



Menu command shortcuts

Press To

Ctrl N Create a new library.

Ctrl O Open a library.

Ctrl S Save a library.

Alt F4 Exit the PhotoAlbum.

Alt 0 to Alt 9 Open recent libraries.

Ctrl C Copy the selected image to the Clipboard.

Alt Delete Remove the selected category or image preview.

Alt Insert Create an empty category.

Insert Add images to the selected category.

F1 Open the Help.

F10 Passes control to the menu bar.

Shift Selects a range of images (in sequence). Click on the first image you want to select, then hold 
down Shift and click the last image you want to select.

Ctrl Selects a range of images (out of sequence). Hold down the Ctrl and click on each image that you 
want to select.

Enter When a parent category is selected, displays the sub-categories within that category.

When an image preview is selected, displays the shortcut menu.





Preferences dialog box

This dialog box appears when you select Preferences from the Options menu.

From this dialog box you can change the layout of the PhotoAlbum window.

Click on the tab card that you want help on.
           Image Preview tab card  
           Library Build Options tab card  



Preferences dialog box, Image Preview tab card

This tab card provides options to change the appearance of the image previews and the name displayed beneath 
each preview.

View Size group box:
Select Small Icon Size to display small image previews.
Select Maximum Size to display large image previews. The maximum size of the previews can be 64x64 

pixels or 128x128 pixels, depending on your library build options.

More previews can be displayed in the window if Small Icon Size (32 x 32 pixels) is selected, but the quality of the 
previews will be reduced and they will not have an identifying name.

Preview Caption group box:
Select File Name to display the file name beneath each image preview.
Select Picture Name to display a descriptive name of the selected image preview in the information line. 

These options are disabled when Small Icon Size is selected.

Category Preview group box:
Check the Show Category Icon check box to display an icon next to each category name. Clearing this box 

will allow more category names to be displayed without scrolling.



Preferences dialog box, Library Build Options tab card

This tab card provides options to determine the appearance of the image previews when you create new libraries.

Preview Creation Size group box:
Select Standard [64x64 pixels] to specify the maximum preview size of the previews is 64x64 pixels.
Select Large [128x128 pixels] to specify the maximum preview size of the previews is 128x128 pixels.

Preview Creation Quality group box:
Select Fast Preview Creation to build the image previews quickly. This may result in a lower quality of 

reproduction.
Select High Quality Preview Creation to build the image previews at a higher quality. This may take longer 

to build.

Image Referencing group box:

This group box offers you the option of how you want to assign image file names to the image previews in your 
libraries. 

The default option is to assign a specific drive and folder position for the image that the image preview refers to. 
When you import an image into a program, the PhotoAlbum searches for the image in the specified position so that 
it can copy the image into your program. If you move the image file, the PhotoAlbum will not be able to find the file.

The second option is to assign the image previews the filenames of the image files. When you import an image into 
a program, the PhotoAlbum searches downwards from the library file for the image file name. For this to be 
effective, the image files must be positioned below the library file in the folder structure so that the PhotoAlbum can 
search for it. 

Select Full Folder Path [including Drive name] to assign a specific position for the images on your hard 
disk.

Select Relative from Library file [*.lib] - use on Networks to assign the image a position relative to the 
library file. This is especially useful if you are working on a network.



Open dialog box

This dialog box appears when you select Open from the File menu, or when you press Ctrl O.

From this dialog box you can locate and open an existing image library so that you can resume work on it.

Look in drop-down list box

Select the disk drive and folder that contains the library you want to open. Click on a folder to select it. Libraries in 
the current folder are listed in the Library list box.

File name text box

Type the name of the library you want to open in this text box or select the library from the Library list box.

Files of type drop-down list box

Select the type of file that you are trying to locate and open from this drop-down list box. PhotoAlbum is chosen by 
default.



Save As dialog box

This dialog box appears when you select Save As from the File menu, or when you select Save or press Ctrl S for 
an untitled library. 

From this dialog box you can specify the drive, folder and filename in which to save your library.

Save in drop-down list box

Select the disk drive and folder where you want to save your library. Click on a folder to select it. Libraries in the 
current folder are listed in the Library list box.

File name text box

Type the file name for you library in this text box. If you want to overwrite an existing library, select the library by 
clicking on its file name in the Library list box. When you click on OK the PhotoAlbum warns you if you try to 
overwrite an existing library.

Save as type drop-down list box

Select the file type that you want to save the library as from this drop-down list box. PhotoAlbum is chosen by 
default.



Move/Copy Preview(s) dialog box

This dialog box appears when you select Move/Copy Preview(s) from the Image menu.

From this dialog box you can move or copy image previews to a different category.

Image Preview window

Displays the selected image preview.

Move Previews to Category list box

Select the category into which you want to move or copy the image by clicking on its name in the Move Previews 
to Category list box, or by typing its name in the Move Previews to Category text box.

Copy option

Select Copy to copy the image previews into the category selected in the Move Previews to Category list box.
The image preview will still remain in the original category.

Move option

Select Move to move the image previews into the category selected in the Move Previews to Category list box.
The image preview will be removed from the original category.



Create Empty Category dialog box

This dialog box appears when you select Create Top Level Category or Create Sub-category from the Category 
menu, or when you press Alt Insert.

From this dialog box you can create a new category, assign it to a parent category and change its associated folder.

Category Name text box

Type the name of your new category in this box.

Parent Category list box (only when you select Create Sub-category)

If you want your new category to be a sub-category, select the parent category to which you want the sub-category 
to belong. All the current categories within the current library are listed in this list box.

If necessary, use the scroll bar to scroll through the list of categories.

Associated Folder text box

Specify the folder with which you want to associate your new category by typing the folder path in this box.



Add Image File dialog box

This dialog box appears when you select Add Image File from the Image menu, or when you press Insert.

From this dialog box you can locate, preview and add images to a selected category.

File list box

Select the image you want to add by clicking on its filename in the File list box. Double click to display the file in the 
preview window. To select more than one preview, click while pressing the Shift key.

If necessary, use the scroll bar to scroll through the list of files.

Folder list box

Select the folder that contains the image you want to add. Click on a folder to select it; double-click to make it the 
current folder. Files in the current folder are listed in the File list box.

If necessary, use the scroll bar to scroll through the list of folders.

Drive drop-down list box

Select the disk drive that contains the image you want to add. Click on the arrow to the right-hand side of the this 
box to drop-down a list of all the disk drives available. Click on the disk drive you want. 

If necessary, use the scroll bar to scroll through the list of drives.

Preview window

Displays a preview of the selected image file when you click on Preview.

Select All button

Click on Select All to select of the image files listed in the File list box.

Preview button

Click on Preview to display a preview of the selected image file in the Preview window. If more than one preview is 
selected, the button will change to Preview Next after the first preview has appeared in the window. Click on this 
button to scroll through the rest of the selected previews.

Add button

Click on Add to add the selected image files to the selected category without previewing.

Deselect button

Click on Deselect to deselect the selected image previews from the File list box.



Tidy Up Library dialog box

This dialog box appears when you select Tidy Up from the Options menu.

From this dialog box you can select one of the following options:

Salvage Disk Space Only

Select this option to remove all unused image previews from the current library, and to compact the remaining 
image previews on your hard disk.

Compacting all image previews will save disk space.

MOVE Image into category folder

Select this option to remove all unused image previews from the current library, to compact the remaining image 
previews on your hard disk, and to move all image files to the folder associated with each category.

Compacting all image previews will save disk space.
Folders are associated with categories in the Create Empty Category dialog box.

COPY Image into category folder

Select this option to remove all unused image previews from the current library, to compact the remaining image 
previews on your hard disk, and to copy all image files to the folder associated with each category.

Compacting all image previews will save disk space.
Folders are associated with categories in the Create Empty Category dialog box.



Import Into Existing Category dialog box

This dialog box appears when you select To "category name" from the Add Image Folder submenu of the Image 
menu.

From this dialog box you can search and select the image that you want to import into the current category.

This dialog box is divided into two tab cards; click on the tab card for which you want help:
           Folder Selector  
           Options  



Folder Selector tab card

This tab card appears when you select it from the Import Into Existing Category dialog box.

From this tab card you can select the folders through which you want to search for images.

Folders shown

All radio button

Select All to search through each folder in the current disk drive.

Selected Only radio button

Select Selected only to search through the selected folders only, i.e. those preceded by a check mark.

Folder list box

Select the folders through which you want to search for images by checking the box preceding the folder. Files in 
the current folder are displayed in the file list box.

If necessary, use the scroll bar to scroll through the list of folders.
You can select as many folders as you want.

Files list box

Displays files within the current folder.
If necessary, use the scroll bar to scroll through the list of files.

Drive drop-down list box

Select the disk drive that contains the image you want to import. Click on the arrow to the right-hand side of this box 
to drop-down a list of all the disk drives available. Click on the disk drive you want.

If necessary, use the scroll bar to scroll through the list of drives.



Options tab card

This tab card appears when you select it from the Import Into Existing Category dialog box.

From this dialog box you can choose the format of image to search for, and specify how the image is organized 
within the category.

Image Formats group box:

Specify the image format(s) for which you want to import by checking the relevant boxes.

Folder to Category Mapping group box:

Including Sub-Folders check box

Specify if you want to include sub-folders in the search by checking the relevant box.

All in One Category option

Select this option to import all the located images into the existing category.

Turn Sub-Folder(s) into Sub-Categor(y,ies) option

Select this option to import the images located in the main director(y,ies) into the existing category, and to import 
images located in sub-folders into new sub categories. The existing category will become the parent of these sub-
categories.



Import Into New Category dialog box

This dialog box appears when you select As Top Level Category from the Add Folder Category submenu of the 
Image menu.

From this dialog box you can search for and select the image that you want to import into a new category.

This dialog box is divided into two tab cards; click on the tab card for which you want help:
               Folder Selector  
               Options  



Folder Selector tab card

This tab card appears when you select it from the Import Into New Category dialog box.

From this tab card you can select the folders through which you want to search for images.

Folders shown

All option

Select All to search through each folder in the current disk drive

Selected Only option

Select Selected only to search through the selected folders only, i.e. those preceded by a check mark.

Folder list box

Select the folders through which you want to search for images by checking the box preceding the folder. Files in 
the current folder are displayed in the file list box.

If necessary, use the scroll bar to scroll through the list of folders.
You can select as many folders as you want.

Files list box

Displays files within the current folder.
If necessary, use the scroll bar to scroll through the list of files.

Drive drop-down list box

Select the disk drive that contains the images you want to import. Click on the arrow to the right-hand side of this 
box to drop-down a list of all the disk drives available. Click on the disk drive you want.

If necessary, use the scroll bar to scroll through the list of drives.



Options Tab Card

This tab card appears when you select it from the Import Into New Category dialog box.

From this dialog box you can choose the format of images to search for, and specify how the images are organized 
within the category.

Image Formats group box:

Specify the image format(s) for which you want to import by checking the relevant boxes.

Folder to Category Mapping group box:

Including Sub-Folders check box

Specify if you want to include sub-folders in the search by checking the relevant box.

All in One Category option

Select this option to import all the located images into the new category.

Turn Sub-Folder(s) into Sub-Categor(y,ies) option

Select this option to import the images located in the main director(y,ies) into the new category, and to import 
images located in sub-folders into new sub categories. The top level category will become the parent of these sub-
categories.

Top Level Category option

Select this option to import located image from each folder into separate new top level categories.



Confirm dialog box

This dialog box appears when you have one or more image previews selected and you select Remove from the 
Image menu, or press Alt Delete.

From this dialog box you can confirm whether you want to delete the selected preview(s) from the current category 
and choose whether to delete the corresponding image file from your hard disk.

Preview window

Displays the selected image preview(s).

Delete Image file from your disk check box

Check this box to delete the selected image from your hard disk.
When this box is cleared, the image previews are removed from the current category, but the actual image 

files remain on your hard disk for future use.



HOW TO CHANGE THE LAYOUT OF THE PHOTOALBUM WINDOW 



To resize the list of categories

1. Position the mouse pointer over the vertical bar that separates the category areas. The mouse pointer changes 
shape to a double bar with two arrows.

2. Press and hold down the left mouse button and drag the vertical bar left or right.

3. Release the mouse button.

The category list is resized accordingly.

    Related Topics



To hide and display category icons

1. From the Options menu, select Preferences. The Preferences dialog box appears.

2. In the Category Preview group box, check the Show Category Icon check box to display a relevant icon next to 
each category; clear this box to hide the category icons.

3. Click on OK.

Note:

When you hide category icons you can view more categories without needing to scroll.
Category icons are displayed by default.



To resize image previews

1. From the Options menu, select Preferences. The Preferences dialog box appears.

2. From the View Size group box, select Small Icon Size to display small previews of each image; select 
Maximum Size to display large previews.

3. Click on OK.

Note:

More image previews are displayed in the preview area when small is selected, but the quality of the 
previews will be reduced and they will not have an identifying name.

Large previews are displayed by default.

    Related Topics



To view image previews at full size

1. Right-click on the image preview that you want to view at full size.

2. From the shortcut menu that appears, select Full Size Preview. The image preview is resized to fill the whole 
screen. 

Note:

You can pan across the screen to view parts of the image preview that are not visible by pressing down the 
left mouse button and dragging the pointer in the direction that you want to pan.

To return to the PhotoAlbum window:
double-click on the screen
press Esc.

    Related Topics



To display the file or picture name of image previews

1. From the Options menu, select Preferences. The Preferences dialog box appears.

2. From the Preview Caption group box, select File Name to display the file name under each preview, or select 
Picture Name to display an 8-letter descriptive name under each preview.

3. Click on OK.

Note:

You can edit the picture name under each preview by selecting Preview Text from the Edit menu, then 
typing a new name in the Preview text box.

You cannot display preview names for small image previews.

    Related Topics



To hide and display the info line

From the Options menu, select Info Line. The command is checked when the info line is displayed.

Note:

The info line is displayed by default.



To keep the PhotoAlbum window on top 

From the Options menu, select Always on Top. The command is checked when the PhotoAlbum window is 
on top.

Note:

When Always on Top is selected, the Help window may be hidden. Rearrange the desktop or minimize the 
PhotoAlbum so that the Help window is visible.

    Related Topics



To exit the PhotoAlbum

Do any of the following:
From the File menu, select Exit.
From the PhotoAlbum's Control menu,    select Close. 
Double click on the PhotoAlbum's Control-menu icon. 
Click on the Close button. 

The PhotoAlbum window is removed from the desktop.

Note:

The layout of the PhotoAlbum window is saved when you exit.

Keyboard shortcut: Alt F4

    Related Topics



HOW TO WORK WITH LIBRARIES



To open an existing library

1. From the File menu, select Open. The Open dialog box appears.

2. From the Look in drop-down list box, select the disk drive and folder that contains the library you want open.

3. From the Folder list box, select the library you want to open.

4. Click on Open. The library is opened in the PhotoAlbum window, and its filename is displayed in the window's 
title bar.

Note: 

You can also open one of up to ten libraries that you have most recently used by clicking on the relevant 
library name at the bottom of the File menu.

A large library may take a while to open. The info line indicates the progress of the open operation.

Keyboard Shortcut: To open a library, press Ctrl O. To open any one of the ten most recently used libraries, press 
ALT 0 through to ALT 9

    Related Topics



To create a new library

1. From the File menu, select New. The Create Empty Category dialog box appears.

2. In the Category Name box, type a desired name for your empty category.

3. In the Associated Folder box, type a specified folder path to associate your new category to.

4. Click on OK.

Note:

The library present in the PhotoAlbum window before selecting New will not be saved automatically. Select 
Yes or No from the message box that appears. If want to abort the New command, select Cancel.

Keyboard Shortcut: Ctrl N 

    Related Topics



Specifying the library build options

1. From the Options menu, select Preferences. The Preferences dialog box appears,

2. Select the Library Build Options tab card.

3. In the Preview Size group box, choose whether to build your image previews at a size of 64x64 pixels or 
128x128 pixels.

4. In the Preview Creation Quality group box, select whether you want to create the preview quickly or create a 
high quality preview.

5. In the Image Referencing group box, select whether you want to assign the image a specific position on your 
hard disk or assign it a position relative to the library file.

    Related Topics



Adding categories to a library

You can add categories to a library under which you can add image previews.

There are two types of category that you can add to a library; an empty category and a new category. Refer to the 
related topics and select the appropriate topic.

    Related Topics



To tidy up a library

You can tidy up a library to make it more orderly. Deleted previews and categories are removed from the library file. 
The library file is then re-organized on disk.

1. From the Options menu, select Tidy Up. The Tidy Up dialog box appears.

2. Select one of the following and click on OK.
Salvage Disk Space Only
MOVE Image into category folder
COPY Image into category folder

Note:

Make sure that you select the right option to suit your circumstances as you cannot undo the changes that 
occur after proceeding with the selected option.

    Related Topics



To make a library read only

1. From the Edit menu, select Read Only Library. 

2. A message box appears asking if you want to Disable all modify commands.

3. Click on Yes or No.

Note:

If you want to save a read only library that you have opened, you must save using the Save as command.
The Read Only setting is remembered when you save a library.

    Related Topics



Saving a library

To save a new or existing library

1. From the File menu, select Save As. The Save As dialog box appears.

2. From the Save in drop-down list box, select the disk drive and folder where you want to save the library. 

3 In the File name text box, type a name for the library. If you are renaming an existing library, delete the existing 
filename and type a new one. 

4. Click on Save.

To overwrite an existing library with the same name.

From the File menu, select Save.

Keyboard Shortcut: Ctrl S 

    Related Topics



HOW TO WORK WITH CATEGORIES



Selecting a category

There are two kinds of image categories; top level categories and sub categories.

To select a top level category

Position the mouse pointer over a category in the category list and click the left mouse button.

Some top level categories have resident sub-categories. These are indicated by the icon which is present next to a 
top level category name. 

To select a sub-category

1. Position the mouse pointer over a top level category with indicated sub-categories and click the left mouse 
button.

2. Position the mouse pointer over a sub-category and click the left mouse button.

    Related Topics



To create an empty category

1. From the Category menu, select either Create Top Level Category or Create Sub-category, depending on 
which level you want to create. The Create Empty Category dialog box appears.

2. In the Category Name box, type a desired name for your empty category.

3 In the Associated Folder box, type a specified folder path to associate your new category to.

4. Click on OK

Note:

If you selected the Create Sub-category, select a category to parent your sub-category from the Parent 
Category list.

    Related Topics



To create a new category and import images into it

1. From the Add Image Folder submenu in the Image menu, select As Top Level Category. The Import Into New 
Category dialog box appears.

2. From the Drive drop-down list, select the disk drive that contains the images you want to import. Use the scroll 
bar if necessary.

3. Select All or Selected Only from the Folders shown group box.

4. If the Selected Only option is chosen, select each folder by checking the box preceding the folder name in the 
Folder list box.

Once you have completed the above, select the Options tab card.

5. Specify the image format(s) for which you want to search by checking the relevant boxes in the Image Formats 
group box.

6. In the Folder to Category Mapping group box, check the Including Sub-Folders box if you want to search sub-
folders then select one of the following:

All in One Category
Top Level Categories Only
Turn Sub-folder(s) into Sub-categor(y,ies)

7. Click on OK to start the searching process. Press Escape to cancel the search at any time.

Note:

An extensive search may take a while to complete.

    Related Topics



To import images into an existing category

1. From the Add Image Folder submenu in the Image menu, select To "category name". The Import Into 
Existing Category dialog box appears.

2. From the Drive drop down list, select the disk drive that contains the images you want to import. Use the scroll 
bar if necessary.

3. Select All or Selected Only from the Folders shown group box.

4. If the Selected Only option is chosen, select each folder by checking the box preceding the folder name in the 
Folder list box.

Once you have completed the above, select the Options tab card.

5. Specify the image format(s) for which you want to search by checking the relevant boxes in the Image Formats 
group box.

6. In the Folder to Category Mapping group box, check the Including Sub-Folders box if you want to search sub-
folders then select one of the following:

All in One Category 
Turn Sub-folder(s) into Sub-categor(y,ies)

7. Click on OK to start the searching process. Press Escape to cancel the search at any time.

Note:

An extensive search may take a while to complete.

    Related Topics



To add a single image to a category

1. From the Image menu, select Add Image File. The Add Image File  dialog box appears.

2. From the Drive drop down list, select the disk drive that contains the images you want to add. 

3. From the Folder list box, double-click the folder that contains the images you want to add.

4. From the File list box, select the image file that you want to add. If you want to select more than one image file, 
click while pressing Shift. If you want to select all of the image files present in the File list box, click on the Select 
All button.

5. To view the selected image, click on the Preview button. 

6. If you want to add the selected image file(s) to the selected category, click on Add. Press Escape to cancel the 
loading operation at any time.

    Related Topics



To drag-and-drop images from Windows Explorer

1. From the Options menu, select Always on Top.

2. Select    Windows Explorer from the relevant program menu.

3. From the left hand window, select the drive that contains the images.

4. From either the right or left window, select the folder and/or sub-folder(s) that contain the image files.

5. Press and hold the left mouse button on the image file of your choice.

6. Move the mouse pointer into the PhotoAlbum window, above the preview area, and release the mouse button.

Note: 

If your selected category is empty, when you copy an image file, that image preview will become the 
category icon.

    Related Topics



To drag-and-drop images from another program

1. Make sure that the PhotoAlbum and the program you want to drag the image from are visible on your desktop.

2. Make sure that the category that you want to add the image to is selected.

3. Press and hold down the mouse button on the image you want to drag into the PhotoAlbum.

4. Move the mouse pointer into the PhotoAlbum window, above the preview area, and release the mouse button. 
The Save As dialog box appears, prompting you to save the image.

5. Select the drive and folder where you want to save the image, then click on Save. The image is added to the 
current category.

Note: 

If your selected category is empty, when you copy an image file, that image preview will become the 
category icon.

    Related Topics



To rename a category

1. Select the category that you want to rename.

2. From the Edit menu, select Category Text.

3. Delete the category name present in the Category text box at the bottom of the PhotoAlbum window and type 
your new category name, containing up to a maximum of 40 characters.

4. Click on the Check mark icon if you want to accept the new name or click on the Cross icon to revert back to the 
original name. You can also accept the new name by pressing Enter.

    Related Topics



To remove a category

1. Select the category that you want to remove.

2. From the Image menu, select Remove.

3. A PhotoAlbum message box will appear asking you whether you are sure that you want to remove the selected 
category.

4. Click on Yes or No.

Keyboard Shortcut: Alt Delete

    Related Topics



HOW TO WORK WITH IMAGES



Selecting images

To select an image:

Position the mouse pointer over an image preview in the Preview area and click the left mouse button. 

To select a range of images:

1. Click on the image which will start the range. 

2. While keeping the Shift key pressed, click on the last image that you want to be in the range.

To select individual images:

1. Click on an image. 

2. While pressing Ctrl, click on any other images.

To select all of the images within the PhotoAlbum window:

From the Edit menu, choose Select All Images

To clear a selection of images:

Select Clear Images from the Edit menu.

    Related Topics



To move images to another category

Dragging-and-dropping

1. Press and hold down the left mouse button and Ctrl on the image preview of you choice.

2. Drag the mouse pointer over a category in the list. 

3. Release the mouse button and Ctrl. The image preview is moved to the category.

Using the Move/Copy Preview(s) command

1. Select the image preview(s) that you want to move.

2. From the Image menu, select Move/Copy Preview(s). The Move/Copy Preview(s) dialog box appears.

3. Select a category from the Move Previews to Category list. 

4. In the Operation group box, check the Move check box.

5. Click on OK.

    Related Topics



To copy images to another category

Dragging-and-dropping

1. Press and hold down the left mouse button on the image preview of you choice.

2. Drag the mouse pointer over a category in the list. 

3. Release the mouse button. The image preview is copied to the category.

Using the Move/Copy Preview(s) command

1. Select the image preview(s) that you want to copy.

2. From the Image menu, select Move/Copy Preview(s). The Move/Copy Preview(s) dialog box appears.

3. Select a category from the Move Previews to Category list. 

4. In the Operation group box, check the Copy check box. 

5. Click on OK.

    Related Topics



To remove images from a category

1. Select the image preview that you want to remove.

2. From the Image menu, select Remove. The Confirm dialog box appears asking if you want to delete these 
previews.

3. Click on OK or Cancel.

Note:

You may want to delete the image preview from your disk as well. Before clicking on OK, check the Delete 
Image file from your disk? check box.

Keyboard Shortcut: Alt Delete

    Related Topics



To rename an image preview

1 Select the image preview that you want to rename.

2. From the Edit menu, select Preview Text.

3. Delete the image preview name present in the Preview text box at the bottom of the PhotoAlbum window and 
type your new preview name containing up to a maximum of 8 characters.

4. Click on the Check mark icon if you want to accept the new name or click on the Cross icon to revert back to the 
original name. You can also accept the new name by pressing Enter.

    Related Topics



HOW TO SEND IMAGES TO AN PROGRAM



To drag-and-drop images into a program

1. From the Options menu, select Always on Top.

2. Press and hold the left mouse button on the image file of your choice.

3. Move the mouse pointer into the relevant program window, position the hand icon where you want the image to 
be dropped and release the mouse button.

    Related Topics



To copy and paste images into a program

1. Select the image preview of your choice.

2. From the Edit menu, select Copy to Clipboard.

3. Go to the program that you have chosen to receive the image. 

4. Select the Paste command. The Paste command is usually located in the Edit menu.

Note:

You can also copy image previews into the Clipboard from the shortcut menu. Please refer to the related 
topics.

Keyboard Shortcut: Ctrl C

    Related Topics



To copy images into a program using the shortcut menu

1. Right-click on the image preview that you want to send.

2. From the shortcut menu, select a program that is currently running.

The image will be sent to your selected program.

Keyboard Shortcut: With an image preview or range selected, press Enter to display the shortcut menu.

    Related Topics



Additional information

Adding a single image to a category

If you have selected more that one image file, after clicking on the Preview button, it will change to Preview 
Next. Click on this button to preview the rest of the selected image files.

If you want to add the selected image without previewing, click on Add after you have selected your image 
file(s). If you do not want to add your selected image file(s), but remove them from the preview window, click on 
Deselect.

Creating an empty category

If there are no categories present within the Parent Category list, you can only create an empty top level 
category.

Once you have specified an associated folder for a category and exited the Create Empty Category dialog 
box, the associated folder remains linked to that category until it is deleted. You cannot change the associated folder 
once it has been specified.

General

You cannot add, rename, move, copy or remove categories and images in a read only library.
You cannot drag-and-drop images into programs that do not support OLE2 automation. You must copy and 

paste images in these programs using the Copy Clipboard command in the Edit menu.





File menu

Click on the menu command for which you want Help.

Hint: 

When you highlight a menu command, the information line displays a prompt for how to use that command.

    Related Topics



Click on this menu command to create a new library. The PhotoAlbum is cleared and a new untitled library is 
opened in the PhotoAlbum window. 



Click on this menu command to open an existing library. The Open dialog box appears. Select the library that you 
want to open. 

You can open a recently used library by selecting its name from the bottom of the File menu.



Click on this menu command to save the library in the PhotoAlbum window with its current filename. If the library is 
untitled, the Save As dialog box appears. 



Click on this menu command to name a new library or to save the current library under a different filename. The 
Save As dialog box appears. Choose a drive and folder in which to save the library and type in a filename.



Click on this menu command to close the PhotoAlbum. 



Select the library that you want to open. After a few moments the selected library is displayed in the PhotoAlbum 
window.



Edit menu

Click on the menu command for which you want Help.

Hint:

When you highlight a menu command, the information line displays a prompt for how to use that command.

    Related Topics



Click on this menu command to rename the selected category. The command is checked when selected.



Click on this menu command to rename the selected image preview. The command is checked when selected.



Click on this menu command to put the selected image on the Clipboard so that you can paste it into another 
program.

You cannot drag-and-drop images into programs that do not support OLE2 automation. You must copy and 
paste images in these programs using the Copy Clipboard command.



Click on this menu command to select all the images in the current category.



Click on this menu command to deselect all images in the current category.



Click on this menu command to make the current library a read only library. When a library is read only, this 
command is checked.



Category menu

Click on the menu command for which you want Help.

Hint: 

When you highlight a menu command, the information line displays a prompt for how to use that command.

    Related Topics



Click on this menu command to create a new unnamed top level category into which you can copy or move images. 



Click on this menu command to create a new sub-category into which you can copy or move images.



Image menu

Click on the menu command for which you want Help.

Hint: 

When you highlight a menu command, the information line displays a prompt for how to use that command.

    Related Topics



Click on this menu command to import single or multiple image files into the selected category



Click on this menu command to search for and import images of selected formats into a new top level category or 
into the selected category.



Click on this menu command to delete the selected category or image preview from the PhotoAlbum window and, if 
necessary, to delete the selected images from your hard disk.



Click on this menu command to move or copy the selected image preview(s) into a different category. 



Options menu

Click on the menu command for which you want Help.

Hint: 

When you highlight a menu command, the information line displays a prompt for how to use that command.

    Related Topics



Click on this menu command to display the Info line at the bottom of the Browser window. The command is checked 
when the Info line is displayed. 



Click on this menu command to permanently display the PhotoAlbum in front of any other window on your desktop. 
This command is checked when the Browser is on top.

When this command is selected the Help window may be hidden. Rearrange the desktop or minimize the 
PhotoAlbum so that the Help window is visible.



Click on this menu command to salvage disk space and move or copy clipart into the category folder. 



Click on this menu command to choose how the PhotoAlbum displays previews and categories. 



Help menu

Click on the menu command for which you want Help.

Hint: 

When you highlight a menu command, the information line displays a prompt for how to use that command.



Click on this menu command to display the Help Topics dialog box from where you can view help about using the 
PhotoAlbum and search for specific information.



Click on this menu command to display the PhotoAlbum billboard. This shows the version number of your copy of 
the PhotoAlbum and a copyright notice.





PREFERENCES DIALOG BOX - PICTURE PREVIEWS TAB CARD



Click on this to display a small image preview. More previews are displayed in the preview window if this option is 
selected, but the quality of the previews will be reduced and they will not have an identifying name.



Click on this to display a large image preview. Less previews are displayed in the preview window if this option is 
selected, but the quality of the previews will be increased and they will have an identifying name.



Click on this to display the file name beneath each image preview.
This option is disabled when Small Icon Size is selected.



Click on this to display an 8-letter descriptive name beneath each image preview. 
This option is disabled when Small Icon Size is selected.



Check this box to display an icon next to each category name; when this check box is cleared, more category 
names can be displayed .

This option is disabled when Small Icon Size is selected.



Click on this to display the Picture Preview tab card.



Click on this to display the Library Build Options tab card.



Select the size that you want the image previews to be displayed at.



Check this box to display an icon next to each category name; when this check box is cleared, more category 
names can be displayed .

This option is disabled when Small Icon Size is selected.



Select whether you want the file name or picture name to be displayed beneath the image previews.



PREFERENCES DIALOG BOX - LIBRARY BUILD OPTIONS TAB CARD



Click on this so that the image previews for new libraries are created at the standard size of 64x64 pixels.



Click on this so that the image previews for new libraries are created at the larger size of 128x128 pixels.



Click on this to create a new library quickly. The quality of the previews may be lower than if you select High 
Quality Preview Creation.



Click on this to create high quality previews for your new library. This may take longer than if you select Fast 
Preview Creation.



Click on this if you want to assign each image, that the image previews in the library refer to, a specific drive and 
directory. The image files are permanently placed in the position you assign to them and when you import an image 
into a program, the PhotoAlbum searches for the images in that position. 



Click on this to assign each image, that the image previews in the library refer to, a position relative to the library. 
You assign the image name to each preview and when you import an image into a program, the PhotoAlbum 
searches downwards for the image with that name. Each of the image files must be positioned below the main 
library in the folder for the PhotoAlbum to find them. This is especially useful if you are working on a network.



Choose whether you want the library to be created with image previews at 64x64 pixels or 128x128.



Choose whether you want the previews to be created quickly or at high quality (which will take longer).



Choose whether you want to assign the previews to a specific drive and folder or relative to the library.



MOVE/COPY PREVIEWS DIALOG BOX



This preview box displays the selected image preview.



Select the category that you want to move or copy the image preview into.



Type in the name of the category that you want to move or copy the image preview into.



Click on this to copy the selected image preview(s) into the selected category. The image preview(s) will still remain 
in their original category.



Click on this to move the selected image preview(s) into the selected category. The image preview(s) are removed 
from their original category.



Select the category that you want to move or copy the image preview into.



CREATE EMPTY CATEGORY DIALOG BOX



Type the name of your new category in this box.



Type the name of your new category in this box.



If you want your new category to be a sub-category, select the parent category that you want the sub-category to 
belong to. Use the scroll bar if necessary.



If you want your new category to be a sub-category, select the parent category that you want the sub-category to 
belong to. Use the scroll bar if necessary.



Type the folder path with which you want to associate your new category.



Type the folder path with which you want to associate your new category.



ADD IMAGE FILE DIALOG BOX



Select the image you want to add. Use the scroll bar if necessary.

Double click on the file to display it in the preview window. To select more than one preview, click on each file while 
pressing the Shift key. 



Select the image you want to add. Use the scroll bar if necessary.

Double click on the file to display it in the preview window. To select more than one preview, click on each file while 
pressing the Shift key.



Select the folder that contains the image you want to add. Use the scroll bar if necessary.



Select the folder that contains the image you want to add. Use the scroll bar if necessary.



Click on the arrow on the right of the box to drop-down a list of the available drives.    Select the drive from which 
you want to add images. Use the scroll bar if necessary.



Click on the arrow on the right of the box to drop-down a list of the available drives.    Select the drive from which 
you want to add images. Use the scroll bar if necessary.



Displays the current drive and folder.



Selects all of the image files listed in the File list box.



Displays a preview of the selected image file in the Preview window. If more than one preview is selected, the 
button will change to Preview Next after the first preview has appeared in the window. Click on this button to scroll 
through the rest of the selected previews.



Click on this to deselect the selected image previews.



TIDY UP LIBRARY DIALOG BOX



Click on this to remove all unused image previews from the current library, and compact the remaining image 
previews on your hard disk.



Click on this to remove all unused image previews from the current library, compact the remaining image previews 
on your hard disk and move all image files to the folder associated with each category.

Folders are associated with categories in the Create Empty Category dialog box.



Click on this to remove all unused image previews from the current library, compact the remaining image previews 
on your hard disk and copy all image files to the folder associated with each category.

Folders are associated with categories in the Create Empty Category dialog box.



IMPORT INTO EXISTING CATEGORY DIALOG BOX + IMPORT INTO NEW CATEGORY DIALOG BOX



Click on this to display the Folder Selector tab card.



Click on this to display the Options tab card.



FOLDER SELECTOR TAB CARD



Click on this to search through each and every folder in the current disk drive.



Click on this to search through the selected folders only, i.e. those preceded by a check mark.



Select the folders that you want to search through for images by checking the box preceding the folder. Use the 
scroll bar if necessary.



Select the folders that you want to search through for images by checking the box preceding the folder. Use the 
scroll bar if necessary.



Displays files within the current folder. Use the scroll bar if necessary.



Displays files within the current folder. Use the scroll bar if necessary.



Displays the current drive and folder.



Click on the arrow on the right of the box to drop-down a list of the available drives.    Select the drive from which 
you want to import images. Use the scroll bar if necessary.



Click on the arrow on the right of the box to drop-down a list of the available drives.    Select the drive from which 
you want to import images. Use the scroll bar if necessary.



OPTIONS TAB CARD



When checked, searches for JPEG files in the selected folders.



When checked, searches for TIFF (Tagged Image Format) files in the selected folders.



When checked, searches for BMP (Windows Bitmap) files in the selected folders.



When checked, searches for PCX (PC Paintbrush) files in the selected folders.



When checked, searches for CGM (Computer Graphics Metafile) files in the selected folders.



When checked, searches for EPS (Encapsulated Postscript) files in the selected folders.



When checked, searches for WMF (Windows Metafile) files in the selected folders.



When checked, searches for GEM files in the selected folders.



When checked, searches for PNG files in the selected folders.



Click on this to include subfolders in the search.



Click on this to import all located images into the existing category.



Click on this to import images located in the main folder(s) into the existing category; imports images located in 
subfolders into new sub-categories.



Select the file format(s) you want to search for in the selected folders.



Use this group box to make your selections about your category mapping.



Use this group box to make your selections about your category mapping.



JUST IMPORT INTO NEW CATEGORY DIALOG BOX



Click on this to import located images from each folder into separate new top level categories.



CONFIRM DIALOG BOX



Displays the selected image preview(s).



Deletes the selected images from your hard disk.
When this box is cleared, the image previews are removed from the current category, but the actual image 

files remain on your hard disk for future use.



Click on OK to delete the preview(s) you have selected. Click on Cancel to change your mind and cancel the 
Delete command.




