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1.1    Introduction
Graph Plotter is a package you can use to plot data and fit curves to plotted data.    It can save you a lot of 
work by plotting graphs quickly and reliably.    It also provides facilities to enter, edit and manipulate data. 

Like other packages running under Windows, Graph Plotter allows you to create a number of windows, to 
rearrange these on the screen as you would documents on your desk,    and to have considerable 
freedom in deciding what the program does next.    The commands in the menus are automatically 
enabled/disabled according to the status of the program.      If you are already an experienced Windows 
user, you will probably find some of the features of Graph Plotter familiar, such as the File, Edit, Window 
and Help menus. 



1.2    The data table
Fundamental to Graph Plotter is the idea of the data table.    The process of collecting scientific data 
usually involves measuring the values of one or more variables on a set of objects, or at points in space 
or time.    An object could be a person, plant, geographical area, rock sample etc.    A variable could be a 
measurement such as height, weight, temperature, count etc.    The data table is the arrangement of 
these values in a table such that the rows of the table correspond to the objects or points in space or 
time, and the columns of the table correspond to the variables.    (The terms variable and column are used 
interchangeably in the following.)    This implies that the data table is rectangular, i.e. all the columns are 
the same length as each other, and all the rows are the same length as each other.    Although this is 
usually true of the original data, you may want to produce new columns that are not the same length.    
Graph Plotter allows columns of different lengths in the same data table.

Individual values in a column must all be numbers in the range    -1.7E308 to 1.7E308.    By default, they 
are stored to a precision of five significant figures, but you can change this using the Data precision 
command.

It is usual to name the columns of the data table, which you can do using the Rename variable 
command.    Column names can be any combination of up to 12 characters.    The default names of the 
columns in Graph Plotter are V1, V2, V3, etc.    Note that the case of letters in a variable name is 
important: e.g. "Length" is not the same as "length".

The data table, including its variable names, is stored on a file of type GPD and loaded into Graph Plotter 
when it is needed.    Graph Plotter actually works with a temporary copy of the file so that any changes 
you make to the data table while running Graph Plotter are not made to the file on disk.    The original data 
table file is changed only if you save the changed data table using the Save or Save as command. 



1.3    The Graph Plotter screen
When you start running Graph Plotter the application window should fill the screen. 

At the top of the screen is the Graph Plotter title bar reading "S103 Graph Plotter - untitled data table".      
This text will change to show the name of the data table file after you load a data table into Graph Plotter. 

Below the title bar is the menu bar showing the menu names: File, Edit, Plot, Window and Help.    These 
menus contain the commands of Graph Plotter. 

Along the bottom of the screen is the status bar which displays a brief helpful message.    Initially the 
message is "Type data into the Data window, or use the File menu to open a data file.", which is a hint as 
to what to do next.    If you drag the mouse pointer down the menus you will see the message change to 
give a brief description of what each command does.

The area below the menu bar and above the status bar is the Graph Plotter desktop.    Windows will 
appear in this desktop area as you execute Graph Plotter commands.    Initially the desktop is filled by an 
empty data table window.



1.4    A typical Graph Plotter session
Having started the program by double-clicking on the Graph Plotter program icon, a typical run of Graph 
Plotter would proceed along the following lines.

1. You type your data into the empty data table window.    You give the columns suitable names by 
using the Rename variable command.

2. You choose a command from the Plot menu.    This produces a dialogue box for you to provide 
the information that the command needs - such as which variables to use.

3. You complete the dialogue box by selecting the variables and options you want and clicking on 
the OK button.    This causes the command to be performed and output to be produced as a new 
graphical window.

4. Steps 2 and 3 are repeated producing more graphical windows.    Eventually the Window menu 
may be used to tidy up the desktop, or some windows that are not needed may be minimized to 
icons or permanently closed.    Some windows may be printed to save their results.

5. You use the Save as... command to save the data table to a GPD file.

6. Having completed the plotting, you exit Graph Plotter or start a new data table. 

 



2.1    Type my own data into Graph Plotter?
Choose New from the File menu.    (If you are already working with a data table and have changed the 
data you will see a dialogue box asking whether you want to save the changed data table: click on Yes or 
No as appropriate.)    You will then see a dialogue box for entering the number of rows and columns.      
Type the number of rows into the "Number of rows" box.    Now move the flashing cursor to the "Number 
of columns" box by clicking on it or by pressing the TAB key.    (Do not press ENTER as this will close the 
dialogue box.)    Now type in the number of columns you want in your data table.    You should allow extra 
columns for new variables that you might want to create from the original data.    With both numbers 
correctly typed, click on OK or press ENTER.

You will then see the Data window showing the data table of the size you have specified in the dialogue.    
All the cells are initially blank.

Click on the first cell in the first row and type in your first data value.    Press the TAB key to move to the 
second value in the first row.    Enter your data value and press TAB again.    Continue entering values in 
this way.    Alternatively, if you prefer to type in columns rather than rows, press ENTER or RETURN 
instead of TAB after entering a value.    This will move the cursor to the next cell in the column.

Press ENTER after typing in the final value in the data table.    You can go back and edit any value by 
clicking on it.    You can also move back through columns by pressing the UP ARROW key.

When you are satisfied that you have typed in all your data correctly, you can save it in a Graph Plotter 
data file.    To do this, choose Save as... from the File menu.    This will display the Save dialogue box.    
Click on the File name box and use the LEFT ARROW key to move the cursor back to just after the 
asterisk.    Use the BACKSPACE key to delete the asterisk and type in a suitable name for your new data 
file.    Note that the file type should be GPD. 

If you are typing in a substantial amount of data, it is a good idea to periodically save the data table as 
you type in data.    Use the Save as... command, as described above, after typing some of the data, then 
periodically use the Save command.

Alternatively, you may prefer to type your data using some other application, such as a text editor, word 
processor or spreadsheet package, and save it as a text file that can be read into Graph Plotter - see 
Section 2.2.



2.2    Transfer data from other applications into Graph 
Plotter?
Your data may exist on a file created by some other application, such as a    spreadsheet, word processor 
or database package.    Such applications generally have their own special form of files that cannot be 
read by Graph Plotter.    However, it is usually possible to save data as text (ASCII) files that can be read 
by Graph Plotter.    These text files must consist of blank, comma or tab delimited data.    That is, each 
value in a row must be separated by one or more spaces, or by a comma, or by a tab character.    There 
must be the same number of values in each row. 

To read a text file into Graph Plotter, choose Open from the File menu.    In the Open dialogue, click on 
the "List Files of Type:" box and click on "Text(*.txt)".    If necessary, browse to the folder where the text file 
was saved.    The name of your text file should then be listed in the dialogue box.    Click on the name and 
click on OK.    Note that the text file should consist only of data values: there should be no variable names 
or other information.    Graph Plotter will use the default names V1, V2, ... .

Exactly how the text file is created depends on the application, but in a Windows application the option to 
save a text file will invariably be from the File menu, usually under Export or Save as... .    Make sure the 
saved file has type TXT: e.g. the file name might be MYDATA.TXT.

Another way of transferring data into Graph Plotter is via the Windows clipboard.    Most Windows 
applications have an Edit menu that includes a Copy command that allows you to copy selected 
(highlighted) data to the clipboard.    You can then run Graph Plotter and choose Paste from the Edit 
menu to copy the data into the data table.    Note that the copied data must represent a rectangular 
data table, i.e. have rows and columns of equal length.



2.3    Transfer data from Graph Plotter to other 
applications?
You may wish to use the data in a Graph Plotter GPD file in some other application, such as a 
spreadsheet, word processor or database package.    Such applications cannot read GPD files, but they 
usually can read tab-delimited text files.    The transfer process is therefore the reverse of the procedure 
described in Section 2.2.    To save data as a tab-delimited text file, choose Save as... from the Graph 
Plotter File menu.    In the Save dialogue, click on the "List Files of Type:" box and click on "Text(*.txt)".      
Edit the File name box to give the file the name you want with the TXT type.    Note that the text file will 
consist only of data values: no variable names will be saved. 

Exactly how the text file is read into the other application depends on the application, but in a Windows 
application the option to read a text file will invariably be from the File menu, usually under Import or 
Open . 



2.4    Change the data values?
You can change individual values by editing them in the data table.    Click on the value you want to edit.    
The value will be highlighted.    If you start typing while the value is highlighted, then the whole value is 
replaced by what you type.    If you want to just edit part of the value, then use the left or right arrow key to 
move to the characters you want to change.    The value should then not be highlighted.    Delete the 
characters you want to change using the BACKSPACE key (usually towards the top-right part of the 
keyboard with a left arrow on it) or the DELETE key that delete the character to the left or right of the 
cursor respectively.

Changed values are not written to the data file until you use the Save or Save as… commands in the File 
menu. 



2.5    Create new variables?
You can simply type new values into an empty column of the Data window.    Use the Rename variable 
command in the Edit menu to give the new column a name.

It is common to create new variables that are mathematical functions of existing variables.    For example, 
if you have columns MASS1 and MASS2 you might want to create a new column called DIFF that is 
MASS1 minus MASS2.    To evaluate expressions like these you use the Calculate command in the Edit 
menu.    In this example you would enter "MASS1" - "MASS2" in the "Calculations on variables" dialogue. 
When you click on OK, every value in the MASS2 column is subtracted from the corresponding value in 
the MASS1 column and the results stored in corresponding rows of the next vacant column of the data 
table.    This new column will be named using the first 12 characters of the expression you typed, but you 
can give the new column the name DIFF by choosing Rename variable from the Edit menu.

The Calculate command offers a wide range of mathematical functions for creating new data - see 
Section 4.3.



2.6    Plot a graph?
You can plot a graph of any two columns of variables from the data table by using the Graph command 
from the Plot menu.    The Graph dialogue box displays the variables in the data table in three lists.    
Select the variable that you want to plot on the horizontal (X) axis by clicking on the variable name in the 
list on the left, and select the variable that you want to plot on the vertical (Y) axis by clicking on the 
variable name in the list in the middle.    If you want to plot vertical error bars on your data points, then 
select the variable that you want to use for the error bars (E) by clicking on the list on the right.    Note that 
the values in the column of data selected in the right box will represent the length of the error bar either 
side of the plotted point, i.e. the top of the error bar will be plotted at Y + E and the bottom at Y - E.    Click 
on the 'Axes through origin' check box if you want the origin (X = 0, Y = 0) to appear on the graph 
regardless of the range of X and Y values.    Clicking on OK causes the Graph window to appear.



2.7    Plot a histogram?
You can plot a histogram of the values in any column of variables from the data table by using the 
Histogram command from the Plot menu.    The Histogram dialogue box displays a list of variables in the 
data table.    Select the variable for which you want to display a histogram by clicking on the variable 
name. You can specify where the first interval for the first bar of the histogram starts, and the width of 
each interval, by editing the boxes.    The Graph Plotter will then calculate the frequencies of the values of 
the selected variable for each interval. Alternatively you can leave AUTO showing in the box for width of 
intervals, so that Graph Plotter chooses the interval automatically.    Clicking on OK causes the Histogram 
window to appear.



2.8    Print a window?
Before running Graph Plotter, make sure your printer is connected and installed under Windows: see your 
Windows documentation under Print Manager.

To print a window from Graph Plotter, activate the window you want to print by clicking on its title bar or 
choosing its title from the Window menu.    Choose Print from the File menu. 



2.9    Save a graph and use it in another package?
Activate the graph window you want to save: i.e. click on the window or select its title from the Window 
menu.    Choose Save or Save as… from the File menu.    You will then see the Save plot dialogue.    The 
default file type is WMF.    Delete the asterisk in the filename box and type a suitable name for the graph 
file.    The default directory for Graph Plotter files is c:\S103\gp\data, but you can    select an alternative 
directory in which to save the file if you wish.    Click on OK to save the file.    WMF stands for Windows 
Meta File, which is a standard graphical format that can be read by some other Windows programs such 
as drawing packages, word processors and other plotting packages.    For example, if you have saved a 
Graph Plotter graph window in a file called PLOT1.WMF, you can insert the plot into a Microsoft Word 
document by choosing Picture from Word's Insert menu and selecting file PLOT1.WMF in the Insert 
Picture dialogue. 



3.1    Introduction
Windows in Graph Plotter are like sheets of paper on a scientist's desk.    One window shows the data 
and there may be several graphical windows showing various plots.    Like sheets of paper they can be 
moved around and overlap each other, with the window of interest usually being on top.    Unlike sheets of 
paper, the Data window can be scrolled through and the graphical windows can be re-sized.    Windows 
are created by choosing commands from the menus: commands in the Plot menu each create different 
kinds of plots.    The number of graphical windows that can be created is limited only by the memory of 
your computer.

All windows have a title bar, control-menu, border, minimize and maximize buttons.    The Data window 
also has scroll bars.

New windows are created with a default size and position such that they overlap in a cascading 
arrangement on your screen, but you are free to resize and arrange all the windows to suit yourself.    The 
Window menu (see Section 4.5) is useful for arranging windows.    Note that graphical windows 
(histograms and graphs) automatically rescale themselves to fit the plot into the window but the Data 
window will not show all the data if the size of the window is too small.

Some windows have pop-up menus that appear when you click on the window with the right mouse 
button.    These menus control options that are relevant to that particular window.    To use a pop-up menu, 
make sure the window is active (by clicking on it or choosing it from the Window menu).    Position the 
mouse pointer within the window and press the right mouse button.    The pop-up menu should then 
appear (if not, then that window does not have a pop-up menu associated with it).    Keeping the right 
mouse button pressed, move the pointer through the menu until the option you want is highlighted and 
release the button.    If you decide you do not want to choose any of the menu options, move the mouse 
pointer outside the menu and release the button when no options are highlighted. 

If your mouse has only one button, you can obtain the pop-up menus by pressing the shift key while 
clicking.    You will need to click again to choose the option in the pop-up menu.



3.2    Data window
The Data window allows you to view or edit the data table or type in new values.    This window shows the 
names of the variables at the top of the columns and numbers of the rows on the left. 

The Data window for all variables is automatically displayed when you open a new data table or GPD file. 
There can be only one Data window showing, corresponding to the current data table.

A value is edited/entered by moving the mouse pointer to the appropriate cell and clicking on it.    You 
should then see the value highlighted and a flashing cursor.    The existing value can be edited using the 
usual editing keys (BACKSPACE, DELETE, left and right arrows), and the required value typed in.    If you 
start typing before using one of the editing keys, then the old value completely disappears and is replaced 
by what you type.

If you are typing in rows of data, press the TAB key after typing a value to move to the next cell in the row. 
If you are typing in columns of data, press the ENTER or RETURN key after typing a value to move to the 
next cell in the column.    You can also move backwards through a row by pressing SHIFT-TAB and move 
up and down columns by pressing the up and down arrow keys.

This window can be scrolled vertically and horizontally to view all of the data values when there are too 
many rows or columns to fit on the screen. 

The values you type into a cell must be numbers in the range    -1.7E308 to 1.7E308.    By default, they 
are stored to an precision of five significant figures, but you can change this using the Data precision 
command.    You can also type mathematical expressions that will automatically be evaluated and entered 
into the cell to the current precision.    For example, if you type 1/3 and the current precision is 5, then the 
value 0.33333 will appear in the cell.    If you enter an expression that cannot be interpreted as a number, 
you will see an error message when you try to move to a new cell. 

Data can also be pasted into the data table from the Windows clipboard.    This provides a mechanism for 
transferring data from other Windows applications.    To paste data from the clipboard, activate the Data 
window and choose Paste from the Edit menu.    (The Paste command is enabled only if there is data in 
the clipboard.)    The data should appear in the first empty columns of the data table.    The success of this 
operation, however, depends on the contents of the clipboard being in a suitable form for Graph Plotter.    
The data must be ASCII text (not graphical) and the values must be separated by spaces, commas or tab 
characters.    The data must form a rectangular table of values. 



3.3    Histogram    window
This window displays the histogram for a column of data. It has a pop-up menu that allows you to change 
the style of the plot from bars to a line graph, or vice versa.    To display the pop-up menu, position the 
mouse pointer anywhere in the window and press the right mouse button.    The current style of the plot is 
indicated by a tick.    Click on the other style if you want to change it.



3.4    Graph    window
This window displays the graph for two variables. 

Clicking on this window with the right mouse button produces a pop-up menu that enables the different 
plotting symbols - plus, cross, asterisk, circle, square, diamond or pixel - to be chosen.    Points plotted 
using pixels may individually be quite small and difficult to see, depending on your screen resolution, but 
collectively may give a better picture when there is a large number of points.    The Connected option joins 
the points with straight lines to give a line graph.    The points are automatically connected if years are 
plotted on the horizontal axis.

The best-fit straight line or exponential curve can be drawn on the graph by choosing the Fit straight line 
or Fit exponential curve command from the Plot menu while this window is active.

Clicking on this window with the left mouse button when there is no best-fit curve drawn has the following 
effect.    The pointer changes to cross-hairs and the current coordinates (X,Y) are displayed in the status 
bar.    These coordinates change as you drag the cross-hairs around the window. 

Clicking on this window with the left mouse button when there is a best-fit line drawn has a similar effect 
to the above plus the following.    A vertical dashed line is drawn from X on the X-axis to the best-fit curve 
and a horizontal dashed line drawn from that point to Y* on the Y-axis where Y* is predicted by the fitted 
equation.    The status bar displays the (X,Y) position of the mouse pointer and Y*.    The last (X,Y) and 
predicted Y* stay in the status bar after you stop dragging. 



4.1    Introduction
The menu names are shown in the menu bar near the top of the screen.    The menu items represent 
commands that initiate actions/operations to be performed. 

Note that commands are disabled (faint) if the current status of the program would not allow you to use 
them.    For example, most commands are disabled until you type some data into the Data window or 
open a data table file.

In most cases, choosing a command from the menus produces a dialogue box that has to be completed 
to provide sufficient information for the command to be executed.    These dialogues vary according to the 
command, but for plots they require you to select the variables to plot and the options that affect the plot. 
While a dialogue box is on screen you are prevented from doing anything else in Graph Plotter.    You 
must click on either the OK button (or press ENTER) or Cancel button.    The OK button tells Graph Plotter 
to execute, or finish executing, the command.    The Cancel button quits the command without doing 
anything.

Commands can be chosen without using the mouse.      A menu can be chosen by pressing the ALT key 
and its underlined letter (e.g. F for the File menu), and then a command can be chosen by pressing its 
underlined letter (e.g. O for Open).

Note that the Graph Plotter menus follow the Windows menu conventions in the use of symbols to the 
right of the command names.    An ellipsis (...) indicates that a dialogue box appears when you choose the 
command.    A triangle indicates that a cascading menu appears when you choose the command. 

The following sections describe each command in detail.    They are arranged in the order they appear in 
the menus.



4.2    File menu
This menu has commands to open and save data files, print and close windows, and exit the package. 

More:
New

Open

Save

Save as...

Close

Print

Print setup

Exit



New
Creates and opens a new data table named UNTITLED with all cells in the Data window empty.    Use this 
command when you need to type a new data table into the package.

If you are already working with a data table which has been changed, you will see a dialogue box asking 
whether you want to save the changed data table: click on Yes if you want to save the changed data 
table; click on No if you want to preserve the original data table; click on Cancel if you do not want to 
create a new data table. 

You will have to complete a dialogue box specifying how many rows and columns are in the new data 
table.    Type the number of rows into the "Number of rows" box.    Now move the flashing cursor to the 
"Number of columns" box by clicking on it or by pressing the TAB key.    (Do not press ENTER as this will 
close the dialogue box.)    Now type in the number of columns you want in your data table.    With both 
numbers correctly typed, click on OK or press ENTER.

A Data window will appear with the specified numbers of rows and columns. 



Open
This command is used to read data from a file.    This file may be of the special GPD type created by 
Graph Plotter, or may be a text (ASCII) file created by some other application.

If you are already working with a data table which has been changed, you will see a dialogue box asking 
whether you want to save the changed data table: click on Yes if you want to save the changed data 
table; click on No if you want to preserve the original data table; click on Cancel if you do not want to 
create a new data table. 

You will then see a dialogue box titled Open.    This is the standard Windows dialogue for opening files 
that you will see in other Windows applications.

By default, the Open dialogue lists all the files of type GPD in the current directory, C:\S103\GP\DATA, 
which is where data files for this course will be installed.    If the file you want is not on the C drive, select 
the drive you want from the Drives list.    The Directories box allows you to list files in other directories by 
double-clicking on the directory.    You can list all text data files in the current directory by clicking on the 
down arrow in the List Files of Type box and selecting type Text(*.txt). 

Select the file you want by clicking on it in the list of files.    The name of the file should then become 
highlighted and should also appear in the File Name box.    Click on OK to open the file.    The Open 
dialogue will then disappear, and there may then be a short pause while Graph Plotter reads the file. 

The Open command will successfully open a text file only if that file conforms to the following rules.

1. The file contains only data values that are acceptable to Graph Plotter (see Section 1.2).

2. The data values are arranged in a rectangular table: i.e. there must be the same number of 
values in each row.

3. Each row is terminated by a newline character.

4. Within rows, the values are separated by one or more spaces, or by a comma, or by a tab 
character. 



Save
If the active window is the Data window, this command updates the current GPD file, saving the current 
data table and column names. This protects new data from being accidentally lost.    Note, however, that 
the current GPD file is overwritten: if you want to preserve the original data table, then use the Save as... 
command to save your current data to a file with a new name. 

If you have not previously used the Save as... command to create a GPD file for an untitled data table, 
then this command will display the Save dialogue for naming a file, as in the Save as... command.

If the active window is a Graph window, this command updates the current WMF file, saving any 
modifications to the graph.    If you want to preserve the original graph, then use the Save as... command 
to save the current graph to a file with a new name.

If you have not previously used the Save as... command to create a WMF file for the graph, then this 
command will display the 'Save plot' dialogue for naming a file, as in the Save as... command.



Save as...
If the active window is the Data window, this command will save the data table in a new file.    It displays 
the Save dialogue which allows you to select the drive, directory and name of the file to which the data is 
saved.      This command is useful if you've changed the current data table and want to save it without 
overwriting the original GPD file.    Note that if you choose the name of an existing file it will be 
overwritten. 

The Save dialogue is very similar to the Open dialogue.    The default file type is GPD.    If you want to 
save the data table in a text file that some other application may be able to read, select "Text[*.txt]" from 
the Save File as Type list so that the file type is TXT.    The text file will store only the data values (no 
variable names or other information).    Values are separated by tab characters within rows and by newline 
characters at the end of each row.    Note that if you choose the name of an existing file it will be 
overwritten. 

If the active window is a Graph window, this command will save the graph in a new file.    A 'Save plot' 
dialogue box opens with the file name field highlighted. Enter a name for the file, with the .WMF 
extension.    The default directory where the file will be saved is displayed in the middle of the box, and 
you can change the destination of the file if you wish.    WMF stands for Windows Meta File, and files of 
this type can be read by applications such as Microsoft Draw (which is part of Microsoft Works) and 
Microsoft Word.



Close
Permanently closes and deletes the active window.



Print
If you have connected and installed a printer under Windows, this command prints the active window.



Print setup
This command displays the dialogue for configuring your printer.



Exit
Quits the package.    If you have changed the current data table you will see a dialogue box asking 
whether you want to save the changed data table: click on Yes if you want to save the changed data 
table; click on No if you want to quit without changing the original data table; click on Cancel if you decide 
you do not want to quit.



4.3    Edit menu
This menu is concerned with editing actions on the data table. 

More:
Cut

Copy

Paste

Clear

Rename variable

Calculate

Data precision



Cut
Cuts all data from columns you select in the dialogue.    Select more than one column by dragging down 
the list of variable names, or by pressing the SHIFT or CTRL key while clicking.    The cut columns are 
copied to the Windows clipboard.    The data can be retrieved from the clipboard using the Paste 
command in Graph Plotter or in some other Windows application.



Copy
Copies all data from columns you select in the dialogue.    Select more than one column by dragging down 
the list of variable names, or by pressing the SHIFT or CTRL key while clicking.    The data are copied to 
the Windows clipboard.    The copied data can be retrieved from the clipboard using the Paste command 
in Graph Plotter or in some other Windows application.



Paste
Pastes the contents of the Windows clipboard into the active window.    The data may have been cut or 
copied in some other Windows application.    The data must consist of valid numbers and form a 
rectangular data table for them to be successfully pasted into the Data window.



Clear
Deletes all data from columns you select in the dialogue.    Select more than one column by dragging 
down the list of variable names, or by pressing the SHIFT or CTRL key while clicking.    The cleared 
columns are not copied to the Windows clipboard. 



Rename variable
This command displays a dialogue box that allows you to change the name that appears in a column 
heading.    Select the name you want to change by clicking on it in the list of names.    The current name 
then appears in the edit box at the top of the list.    If you want to edit the current name, click on the name. 
If you want to type in a new name entirely, start typing in the new name without clicking on the original 
name.    A variable name can be up to 12 characters long.    Click on OK or press ENTER when you have 
completed the new name.    Click on Cancel if you decide not to change the original name. 



Calculate
This command creates a new variable - in the next free column - by evaluating an expression involving 
one or more of the existing variables.    The expression can involve all the usual arithmetical operators 
and mathematical functions.    The command displays a dialogue box resembling a desk calculator.    You 
can type the expression directly into the edit box at the top of the calculator, but you will probably find it 
easier to enter the expression by clicking on the buttons and names of variables on the calculator.

To enter one of the variables in the expression to be calculated, first click on the name of the variable in 
the list on the left, and then click on "Enter selected variable". 

Arguments of the functions (operators) can be any of the following: variables: V1, V2,... or variable names 
bracketed by " (double quotes); constants: PI, any valid integer, real or E-notation number; expressions 
enclosed in brackets (). 

An expression can consist of any valid combination of the following operators.

+ addition

- subtraction

* multiplication

/ division

mod modulus: remainder from division

^ exponentiation

EXP exponential function

LN natural log function

LOG base 10 log function

SQRT square root function

SIN sine function

COS cosine function

TAN tangent function

ASIN arcsine function

ACOS arccosine function

ATAN arctangent function

Example expressions

V5*(V1+V2+V3+V4)/4

multiplies the row means of columns V1 to V4 by the values in V5.

SQRT("weight1" * "weight2")

Multiplies values in rows weight1 and weight2 together and takes the square roots of the results.    Note 
that this is not the same as 

SQRT "weight1"    *    "weight2"

Since the precedence of the SQRT function is higher than that of multiplication, this would take the 



square root of weight1 first and then multiply the result by weight2.

Variable names in expressions must be exactly the same as they appear in the Data window.    Note that 
names are case-sensitive: e.g. "Weight1" would be invalid in the expression above. 

Appropriate error messages are displayed if errors occur in the expression that is entered.    You can edit 
the expression to correct the errors.    Where the expression cannot be evaluated, corresponding    cells of 
the new column are left blank.

By default, calculated values have a precision of five significant figures.    You can change this by 
choosing the Data precision command. 

A new variable is not created if no variables appear in the expression (only constants).    In this case the 
single number result is displayed in an alert box.    Hence this command can be used as a numerical 
calculator. 



Data precision
This command displays a dialogue for changing the precision of data values displayed in the Data 
window.      You can type a number between 3 and 15, and the data will than be displayed to that number 
of significant figures. 



4.4    Plot menu
This menu provides commands that produce plots.    When a command is successful, a window is created 
showing the plot.    If the command cannot execute successfully on the variables you have selected, you 
will see an appropriate error message.    Note that the plots are not updated if you change data in the 
Data window, so if you change the values in the data table after plotting a graph, then you may 
need to plot the graph again.

More:
Histogram

Graph

Fit straight line

Fit exponential curve



Histogram
This command creates a Histogram window for a column of data that you select from the list of    column 
names in the dialogue.    You can specify where the first interval for the first bar of the histogram starts and 
the width of each interval by editing the boxes.    Graph Plotter will then use your intervals to calculate the 
frequencies.    Alternatively, you can leave AUTO showing in the box for width of intervals, so that Graph 
Plotter chooses intervals automatically.    Clicking on OK causes the Histogram window to appear.



Graph
This command creates a Graph window for a pair of variables.    You select the    variable to be plotted on 
the horizontal axis (X) and the variable to be plotted on the vertical axis (Y).    Click on the "Axes through 
origin" check box if you want the origin (X=0, Y=0) to appear on the graph regardless of the range of X 
and Y.    Optionally, you can select a third column of data (E) to be used to plot symmetrical vertical error 
bars.    Clicking on OK causes the Graph window to appear.    Note that this command ignores rows of the 
data table for which X or Y (or E if selected) is missing.



Fit straight line
This command draws the best-fit straight line on the active Graph window.    The best-fit straight line has 
the equation Y = kX + c where k is the gradient of the line and c is its intercept with the Y axis.    The 
coefficients k and c are calculated such that the total sum of squared deviations of the data points from 
the fitted line is minimized.    The values of k and c are displayed in the equation at the top of the window. 



Fit exponential curve
This command draws the best-fit exponential curve on the active Graph window.    The best-fit curve has 
the equation Y = a exp(bX)  where the coefficients a and b are calculated such that the total sum of 
squared deviations of the data points from the fitted curve is minimized.    The values of a and b are 
displayed in the equation at the top of the window.      Note that the equation Y = a exp(bX) gives the 
decay or growth curve for appropriate data. 



4.5    Window menu
The commands in this menu allow you to manage Graph Plotter windows or window icons.    In addition to 
these commands, the titles of windows are added to the end of this menu as they are created, and 
deleted from this menu as they are closed.    Clicking on the title of a window activates it. 

More:
Cascade

Tile

Arrange icons

Close all

Minimize all

Restore all



Cascade
This command rearranges the open windows to overlap so that each title bar is visible. 



Tile
This command rearranges the open windows in sizes such that they fit next to each other within the 
Graph Plotter application window. 



Arrange icons
This command rearranges the window icons, representing windows that have been minimized, along the 
lower edge of the Graph Plotter application window. 



Close all
This closes and deletes all Graph and Histogram windows.    It also closes the Data window, but if the 
data table has been changed a query box allows you to choose whether to save this before closing.



Minimize all
This changes the windows into icons.



Restore all
This changes all icons back into windows.



4.6    Help menu
The commands in this menu run the Windows Help program to provide on-line Help for Graph Plotter.    
Each command opens a Help window. 

More:
Contents

Search for Help on

How to use Help

Calculator

About



Contents
This command provides a list of all Help topics available for Graph Plotter. 



Search for Help on
This command displays a dialogue box for locating information about a specific Graph Plotter topic.



How to use Help
This command provides information about how to use Windows Help. 



Calculator
This command displays the Windows scientific calculator.. 



About 
This command displays copyright and version information about Graph Plotter. 



Glossary of terms
Active

Application

ASCII

Check box

Clipboard

Commands

Control menu

Desktop

Dialogue

Dragging

E-notation

Export

Icon

Import

Pixels

Pop-up menu

Screen resolution

Status bar

Tab-delimited

Text files

Word processor



Active

The active window appears on top of all other overlapping windows with its title bar highlighted.    A 
window can be activated by clicking on any part of it, or by selecting its title from the Window menu.



Application

An alternative term for a computer program.    Windows programs are commonly referred to as 
applications.



ASCII

American Standard Code for Information Exchange, pronounced "askey".



Check box

A check box is a small labelled square button, usually in a dialogue box, that activates some option.    The 
check box toggles on and off when it, or its label, is clicked on.    A tick in the check box indicates that the 
option is on (activated). 



Clipboard

The Windows clipboard is a common area of memory that can be accessed by any Windows program 
through commands in its Edit menu.    The Copy and Cut commands put the currently selected data into 
the clipboard; the Paste command copies data from the clipboard into the program.    The clipboard 
provides a means of transferring data between Windows applications. 



Commands

In a Windows program, commands are the items in the drop-down menus.



Control menu

A menu that temporarily appears when you click on the button in the top-left corner of a window.    This 
menu allows you to perform some standard Windows operations on the window such as closing or 
minimizing it.



Desktop

The main part of the application window below the menu bar and above the status bar in which the 
application's windows appear.



Dialogue

A dialogue box is a special kind of window for selecting variables and options.    A dialogue locks the 
program, i.e. prevents you doing anything else, until it is closed - usually by clicking on its OK or Cancel 
button.



Dragging

To drag the mouse means to move the mouse while keeping the left button on the mouse pressed.



E-notation

E-notation is a compact way of writing very large or very small numbers: e.g. 2.5E6 means 2.5 times 10 to 
the power 6 which is 2500000; 2.5E-6 means 2.5 times 10 to the power -6 which is 0.0000025.



Export

Exporting data is the process of creating a data file that can be read by another package.



Icon

A small picture representing a minimized window.    Double-clicking on the icon restores the window.



Import

Importing data is the process of reading and converting data created by another package.



Pixels

Pixel is a contraction of "picture-element".    Pixels are the dots that make up the characters or graphics 
on your screen or printer.



Pop-up menu

A small menu that temporarily appears when you click with the right mouse button on some windows.



Screen resolution

Your screen display is composed of rows and columns of pixels.    Resolution is the measure of the 
number of rows and columns.



Status bar

The status bar is a thin grey window along the bottom of the application window used to display current 
information about the status of the program, descriptions of the commands or hints as to what to do next. 



Tab-delimited

Data values separated by tab characters.    Tab-delimited data files are a common form of file for importing 
and exporting data files.



Text files

A common format for files.    Text files can be edited using a text editor such as Windows Notepad and 
viewed using the TYPE command in MS-DOS.



Word processor

A computer program designed to prepare printed documents such as letters, reports, theses etc.    
Although primarily concerned with text, most Windows    word processors can also incorporate graphical 
images (such as plots from Graph Plotter) into their documents. 



-1.7E308 means -1.7 multiplied by 10 to the power 308.    This is known as scientific or E notation.



A character is any letter, number or symbol that can be typed. 




