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SYMANTEC LICENSE AND WARRANTY

The softwate which accompanies this license (the "Software") is the property of Symantec or its licensors and is protected by copyright law. While
Symantec continues to own the Software, you will have certain rights to use the Software after your acceptance of this license. Except as may be
modified by a license addendum which accompanies this license, your rights and obligations with respect to the use of this Software are as follows:

*You may:
(i) use one copy of the Software on a single computer;

(ii) make one copy of the Software for archival purposes, or copy the software onto the hard disk of your computer and retain the original
for archival purposes;

(iii) use the Software on a netwotk, provided that you have a licensed copy of the Software for each computer that can access the Software
over that network;

(iv) after written notice to Symantec, transfer the Software on a permanent basis to another person or entity, provided that you retain no
copies of the Software and the transferee agrees to the terms of this agreement; and

(v) if a single person uses the computer on which the Software is installed at least 80% of the time, then after retuming the completed product
registration card which accompanies the Software, that person may also use the Software on a single home computer.

* Y ou may not:
(i) copy the documentation which accompanies the Software;
(i) sublicense, rent or lease any portion of the Software;

(iii) reverse engineer, decompile, disassemble, modify, translate, make any attempt to discover the source code of the Software, or create de-
rivative works from the Software; or

(iv) use a previous version or copy of the Software after you have received a disk replacement set or an upgraded version as a replacement
of the prior version, unless you donate a previous version of an upgraded version to a charity of your choice, and such charity agrees in writing that
it will be the sole end user of the product, and that it will abide by the terms of this agreement. Unless you so donate a previous version of an
upgraded version, upon upgrading the Software, all copies of the prior version must be destroyed.

* Sixty Day Money Back Guarantee:

Ifyou are the original licensee of this copy of the Software and are dissatisfied with it for any reason, you may return the complete product, together
with your receipt, to Symantec or an authoriz ed dealer, postage prepaid, fora full refund at any time during the sixty day period following the delivery
to you of the Software.

* Limited Warranty:
Symantec warrants that the media on which the Software is distributed will be free from defects for a period of sixty (60) days from the date of
delivery of the Software to you. Y our sole remedy in the event of a breach of this warranty will be that Symantec will, at its option, replace any

defective media returned to Symantec within the warranty period or refund the money you paid for the Software. Symantec does not warrant that
the Software will meet your requirements or that operation of the Software will be uninterrupted or that the Software will be error-free.

THE ABOVE WARRANTY IS EXCLUSIVE AND IN LIEU OF ALL OTHER WARRANTIES, WHETHER EXPRESS OR IMPLIED, IN-
CLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONIN-
FRINGEMENT. THIS WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS. YOU MAY HAVE OTHER RIGHTS, WHICH VARY
FROM STATE TO STATE.

* Disclaimer of Damages:

REGARDLESS OF WHETHER ANY REMEDY SET FORTH HEREIN FAILS OF ITS ESSENTIAL PURPOSE, IN NO EVENT WILL
SYMANTEC BE LIABLE TO YOU FOR ANY SPECIAL, CONSEQUENTIAL, INDIRECT ORSIMIL AR DAMAGES, INCLUDING ANY
LOST PROFITS OR LOST D ATA ARISING OUT OF THE USE OR INABILITY TO USE THE SOFTWARE EVEN IF SYMANTEC HAS
BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

SOME STATES DO NOT ALLOW THE LIMITATION OR EXCLUSION OF LIABILITY FOR INCIDENTAL OR CONSEQUENTIAL
DAMAGES SO THE ABOVE LIMITATION OR EXCLUSION MAY NOT APPLY TO YOU.

IN NO CASE SHALL SYMANTEC'S LIABILITY EXCEED THE PURCHASE PRICE FOR THE SOFTW ARE. The disclaimers and limita-
tions set forth above will apply regardless of whether you accept the Software.

* U.S. Government Restricted Rights:

RESTRICTED RIGHTS LEGEND. Use, duplication, or disclosure by the Government is subject to restrictions as set forth in subpatagraph (c)
(1) (ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 or subparagraphs (c) (1) and (2) of the Commercial
Computer Software-Restricted Rights clause at 48 CFR 52.227-19, as applicable, Symantec Corporation, 10201 Torre Avenue, Cupettino, CA
95014.

* General:

This Agreement will be governed by the laws of the State of California. This Agreement may only be modified by a license addendum which ac-
companies this license or by a written document which has been signed by both you and Symantec. Should you have any questions concerning this
Agreement, ot if you desire to contact Symantec for any reason, please write:

Symantec Customer Service, 175 W. Broadway,
Eugene, OR 97401.



* Addendum for Development Language Products

Because the Software is a Symantec development language product you have a royalty-free right to include object code derived from the libraries
in programs that you develop using the Software and you also have the right to use, distribute, and license such programs to third parties without
payment of any further fees, so long as a copyright notice sufficient to protect your copyright in the program is included in the graphic display of
your program and on the labels affixed to the media on which your program is distributed.

* Copyright and License Information

JAVA(tm) web development products are owned and licensed exclusively by Sun Microsystems, Inc. Copyright (C) 1992-96 Sun Microsystems,
Inc. All rights reserved. Java and all Java-based names and logos, including the Coffee Cup and Duke, are trademarks of Sun Microsystems, Inc.
and refer to Sun's Java Technologies. Products beating authorized "JAVA- Compatible" Logo are based upon Sun's JAVA and technology, and are
compatible with the API's for such technology.

Sun grants to you ("Licensee") a non-exclusive, non-transferable license to use the Java binary code version (hereafter, "Binary Software") without
fee. Licensee may distribute the Binary Software to third parties provided that the copyright notice and this statement appear on all copies. Licensee
agrees that the copyright notice and this statement will appear on all copies of the software, packaging, and documentation or portions thereof.

In the event Licensee creates additional classes or otherwise extends the Applet Application Programming Interface (AAPI), licensee will publish
the specifications for such extensions to the AAPI for use by third party developers of Java-based software, in connection with licensee's commercial
distribution of the Binary Software.

RESTRICTED RIGHTS: Use, duplication or disclosure by the government is subject to the restrictions as set forth in subparagraph (c) (1) (i) of
the Rights in Technical Data and Computer Software Clause as DFARS 252.227-7013 and FAR 52.227-19.

SUN MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE BINARY SOFTW ARE, EITHER EX-
PRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESSFOR
A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. SUN SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY LIC-
ENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THE BINARY SOFTWARE ORITS DERIVATIVES.

By downloading, using or copying this Binary Software, Licensee agrees to abide by the intellectual property laws, and all other applicable laws of
the U.S., and the terms of this License. Ownership of the software shall remain solely in Sun Microsystems, Inc.

Sun shall have the right to terminate this license immediately by written notice upon Licensee's breach of, or non-compliance with, any of its terms.
Licensee shall be liable for any infringement or damages resulting from Licensee's failure to abide by the terms of this License.

The JDK 1.0.2 binary release is based in part on the work of the Independent JPEG G roup.
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Introducing
Visual Cafe Pro

Symantec Visual Cafe Pro is the first Rapid Application Development (RAD)
environment for creating Web-hosted Java applets and standalone Java
applications that provide powerful database connectivity. It offers a full suite
of integrated tools for Java development, including a project manager, form
designer, component library, code editor, class browser, interaction wizard,
database wizards and navigator, and an integrated graphical debugger coupled
with a Java compiler and applet viewer. For many tasks, you don’t have to
work with raw source code at all.

Whether you are a novice user who wants to quickly create animations for a
Web page without touching Java code or a high-powered Java programmer

who wants to create sophisticated standalone applications and have control

over every line of your code, Visual Cafe Pro is for you.

What’s included

The Visual Cafe Pro package includes the following software to meet a variety
of your requirements:

*  Visual Cafe Pro— A RAD tool you use to design Java applets and
applications that can optionally contain database functionality.

* dbANYWHERE Workgroup Server — This middleware gives Java
applets and applications running on clients access to a variety of
databases. The clients require no special database software.

* Sybase SQL Anywhere standalone version — This small-footprint,
relational DBMS solution is ideal for desktop, workgroup, and mobile
users and provides multi-platform support.



1-2 Introducing Visual Cafe Pro

* Netscape Fastrack Server (if available on your CD) — This easy-to-
use, upgradable Web server software lets you create and manage a

Web site.

* Netscape Navigator Gold (if available on your CD) — This powerful
Web browser facilitates information creation, access, and sharing and
includes Web, News, and Mail applications.

Now let’s take a closer look at Java and its many advantages.

Java applets and Web browsers

If you’ve explored the Woild Wide Web (WWW) with a Java-enabled Web
browser, chances are you’ve run into Java applets such as steaming coffee
cups, fireworks, scrolling banners, hotel and airline reservation utilities, or
even adventure games. Integrating an applet into a Web page is as simple as
adding a graphic: you just add a line of Hypertext Markup Language (HTML)
code. When you access a Web page with an applet, the applet code is
transferred to your computer and executed by the browser, which reduces the
load on the Web server and makes the applet run faster.

Java is becoming very popular on the Internet because it makes Web pages
much more appealing and adds more functionality than HTML alone can
provide, so most new browser versions support Java. What's more, Java
applets are secure since they can’t access the file system on the local computer,
but they can still read from the Web server. This means that applets are less
likely to damage a user’s system or send private information back to the Web
servet.

Java makes it possible for a Web site to include much richer capabilities, such
as sound, animation, and the ability to interact real-time with data on the Web,
than is currently possible with static text or graphics. You can include new
types of data and provide associated Java bytecode programs that know how
to process the data on the client computer. For example, if you wanted your
applet to display an image that is stored in a format not supported by most
browsers, you could incorporate in the applet the ability to handle this graphics
format.

With Visual Cafe Pro, it’s easy to build Java applets that add dynamic,
interactive functionality to your Internet or intranet Web site. Y ou simply
create a new project containing a “skeleton” applet, which you use as a



Java applets and Web browsers

template. You can display the applet in the Form Designer, which enables you
to design the applet with graphical tools. To create your user interface, you can
drag onto the form a variety of components, such as a button, text field, and
even an animation or slide show, then position or resize the components as
needed.Y ou assign the component properties in a separate Property List
window and add interactions between components with the Interaction
Wizard. Visual Cate Pro automatically creates the Java code for you during this
design process. To test the applet, you can run it with Visual Cafe Pro. The
figure shows some elements of the Visual Cafe Pro environment.
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After your applet is finished, you can optionally add an HTML file to the
project. Visual Cafe Pro lets you create and view HTML files directly within its
environment, or you can create the file in another environment and add it to a

Visual Cafe Pro project.
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Because of Visual Cafe Pro’s extensive library of components, you can develop
many applets without manually creating or editing Java code. To program
other features, you can manually add Java code with Visual Cafe Pro’s Source
Editor. For example, you can add more complex custom event handling that
can’t be created with the Interaction Wizard, add custom data processing, and
write your own components then add them to the Visual Cafe Pro Component
Library.

Java standalone applications

Java applications are cross-platform, which makes them popular for intranets.
A Java application can run on all computers that have Java, so separate
applications for each environment aren’t needed. Unlike Java applets, Java
applications usually have menu bars and can access files on the local computer.
This additional functionality lets you implement features in applications that
you can’t provide in an applet, but it also makes applications less secutre than
applets. You should be aware of this if you are going to write code to access
local storage or any host other than a Web server.

Like other applications, Java applications run standalone without a Web
browser. A Java application is like a C++ application, but it’s cross-platform
and requires a standalone Java virtual machine and supporting files on your
computer to run it. For example, you could write a word processor program in
Java. Java is free: the Sun Java Developers Kit (JDK), for instance, can be
downloaded from the Sun Microsystems Web site, java.sun.com. In the future,
Java will be integrated into many operating systems.

Developing a Java application with Visual Cafe Pro is similar to developing an
applet. First, you create a project and add all of the elements of your
application to it. For your main application window, you can open an
application template in the Form Designer, which enables you to design the
Java frame with graphical tools. You can drag onto the form a variety of
components, then position or resize the components as needed.Y ou assign the
component properties in a separate Property List window, including the menu
items (the frame can have a menu bar); you can specify interactions between
components with the Interaction Wizard. Visual Cafe Pro automatically
creates the Java code for you during this design process. The figure shows
some of these elements of the Visual Cafe Pro environment.
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To test the application, you can run it with Visual Cafe Pro.

What is Java?

Java, developed by Sun Microsystems, was designed for creating applets and

applications for Internets, intranets, and any other heterogeneous, distributed
network. This language offers the following powerful features, as described in
the Java white papers published by Sun:

* Simple. Java is similar to C and C++, which many programmers are
already familiar with. Some of the more difficult features of C++,
including operator overloading, pointers and pointer arithmetic,
multiple inheritance, and extensive automatic coercions, were omitted
to make programming with Java easier. The Java automatic garbage
collection feature reduces bugs by automatically freeing unused

memory.
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Small. The Java virtual machine is relatively small in size, so it can be
downloaded over the Internet and run on computers with little
available memory. Many operating systems will include Java in the
future.

Object-oriented. Java mimics the object orientation of C++ and
includes extensions from Objective C for dynamic method resolution.
Some advantages of object-oriented programming include the
following:

* Codeis encapsulated in objects, which have a public interface and
a private implementation, so you can rapidly develop prototypes
and group code into manageable chunks — even for very complex
systems.

* Objects can inherit the characteristics of other objects and override
inherited characteristics, so you can easily reuse code, make your
code more compact, and fix or update code in one place, which
saves time and reduces bugs.

Network-ready. Creating network connections is easier in Java than
for C or C++ because Java has built-in routines for dealing with
TCP/IP, including HTTP and FTP. These routines make it as easy to
open and access objects over the network through URLSs as it is to
access a local file system.

Robust. Java eliminates problems eatly by requiring declarations, using
static typing, having the compiler perform type checks, and not
supporting pointers, which can result in overwriting memory or
corrupting data.

Secure. Because there are no pointers, Java applications can’t access
data structures or private data that they don’t have access to. This
prevents most viruses from taking hold. Applets, when run within a
Web browser on a local computer, can’t read or write to the disk,
execute programs on this computer, or connect to any other
computers except the server they were downloaded from.

Architecture-neutral and portable. The Java compiler generates an
architecture-neutral object file format and bytecode instructions, so
Java code can run on any computer that has a Java runtime system.
Bytecodes are instructions that are similar to machine code, but are not
platform-specific. During execution, the Java virtual machine either
interprets the bytecodes or converts them to machine code. Creating
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separate applications for different computer platforms is no longer an
issue.

* High-performance. Java bytecodes can be translated on the fly to
native machine instructions — for example, by a Java-enabled
browser. Linking is faster than for C or C++. Once the Java
bytecodes are converted to machine code by a Just-In-Time compiler
in a Java virtual machine, the performance is comparable to that of C
or C++.

® Multithreaded. Java code can deal with multiple things happening at
once with sophisticated synchronization primitives that are integrated
into the language, which makes them easier to use and more robust.
Multithreading improves interactive responsiveness and real-time
behavior, so is critical to high-performance Java applets because
applet execution must continue while various image and binary files
are being retrieved from one or more Web servers. In addition, the
ability to control the execution of multiple concurrent threads is
crucial for deploying real-world Web applications.

* Dynamic. New module plug-ins can be added to a Java application
with minimal overhead. Java can look up a class definition at runtime
from its name.

What is JDBC?

The many advantages of Java make it an excellent choice for use with
databases. JDBC provides Java developers with database access that’s
independent of the database and the connectivity mechanism. Its generic SQL
database access framework provides a uniform interface to a vatiety of
different database connectivity modules. Because Visual Cafe Pro is fully
compliant with the JDBC application programming interface (API), you can
use Visual Cafe Pro to create a single database interface that’s compatible with
a variety of connectivity solutions. The JDBC design is similar to the Open
Database Connectivity (ODBC) standard, so its interface is familiar to many
programmers.
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The dbANYWHERE three-tier architecture

The three tiers atre the client, the dbANYWHERE middleware, and the
database residing locally or remotely to dbANYWHERE. The client
communicates with dbANYWHERE over a network, such as the Internet, an
intranet, or a local area network (LAN). dbANYWHERE makes the database
requests and passes the data back to clients; it caches data from the database
system and sends only the request subset to a client. The client needs no

application or database software other than the standard Java files or a Java-
enabled Web browset.

The dbANYWHERE middle tier is easy to manage and secure because you
only have to maintain direct database connectivity at this tier. In addition,
three-tier systems are cost-effective because the middle tier requires fewer
connections than would be required for direct client connections.

The dbANYWHERE Workgroup Server provides heterogeneous access to
the most common database engines. This allows applets and applications to
maintain live connections to multiple database engines, with the advantages of
data buffering, reduced network traffic, and decreased hits on the database
engines.

dbANYWHERE supportts two interfaces for Java database connectivity: the
standard JDBC API and the dbANYWHERE API. The dbANYWHERE API
delivers robust functionality for Java applications while making common
database operations — including master/detail processing — easier to
implement.

Features of the Visual Cafe Pro environment

Visual Cafe Pro gives you the easy-to-use Java language in a development
environment designed to make you highly productive. It includes the following
features, which you’ll learn more about in the tour:

*  Visual, form-based development

*  Quick creation of component connections with the Interaction
Wizard

*  Two-way development, which means the visual tools and Java code
always match
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Database connectivity through a three-tier architecture and the JDBC
standard

Support for major database servers
Database wizards for simplified form development

Hierarchical view of database cataloging information with the
dbNAVIGATOR

Simplified Java database connectivity through smart dbAWARE
components that provide data binding

Rapid turnaround with fast compilers

An advanced debugger that includes expression evaluation
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Installing the Software

This chapter describes how to install Visual Cate Pro, dbANYWHERE
Workgroup Server, Sybase SQL Anywhere, and Netscape Fastrack Server and
Netscape Navigator Gold (if available on your CD). It has the following
sections:

* Installing the software needed for the tour

* Planning your installation

* Using the installer

* Starting the dbANYWHERE Workgroup Server
* Stopping the dbANYWHERE W orkgroup Server
* Starting Visual Cafe Pro

* Exiting Visual Cafe Pro

* Uninstalling Visual Cafe Pro

* Deploying applets and applications

Installing the software needed for the tour

Before starting the tour, you need to perform the tasks in the following
sections:

* Installing Visual Cafe Pro, dbBANYWHERE, Sybase SQL Anywhere,
and Netscape Navigator Gold

* Setting up the Tutorial database on a dbANYWHERE Workgroup
Server

* Installing Symantec classes
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Installing the Software

o

The tour is designed with the assumption that all three tiers run locally. In
other words, Visual Cafe Pro, a dbANYWHERE Workgroup Server, and a
Sybase SQL Anywhere database engine are running on one computer on the
local hard drive. If you’re working through the tour, you might want to install
all of this software on your development computer for the tour. If needed, you
can uninstall software later.

If you can’t run all of this software on one computer because of system
resource limitations, you can still work through the tour. However, in the
Chapter 3 section, “Looking at the Isle de Cafe Web pages,” you won’t be able
to view the applet that displays database information unless you modify the
applet to use a remote dbANYWHERE W orkgroup Server. See a following
section, “Planning your installation,” for system requirements.

Installing Visual Cafe Pro, dbbANYWHERE, Sybase SQL
Anywhere, and Netscape Navigator Gold

To use the Visual Cafe Pro database features provided in this tour, you need to
have access to the Tutorial database through the dbANYWHERE W orkgroup
Server and Sybase SQL Anywhere database engine, which are included in your
package. You also need a Java-enabled Web browser to complete the tour.
You can use the Netscape Navigator Gold browser on the CD or another
browser.

To install the software needed for the tour, follow these steps:

1 Insert the Visual Cafe Pro CD-ROM in your CD-ROM drive.
Normally, this will start the install program.

2 If step 1 didn’t start the install program, run Setup.exe.

If you need more instructions on using the installer, see a following
section, “Using the installer.”

3 Install Visual Cafe Pro, the dbANYWHERE Workgroup Server,
Sybase SQL Anywhere, and optionally Netscape Navigator Gold.

dbANYWHERE can be installed on the local computer or a remote
computer. Sybase SQL Anywhere must be on the same computer as
dbANYWHERE. If Visual Cafe Pro and dbANYWHERE are on
different computers, the computers must be able to communicate over
the network through TCP/IP.
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For dbANYWHERE, make sure you install at least the Watcom driver
so you can complete the tour.

ﬂ When installing Sybase SQL Anywhere, let the installer update the registry for

you.

4 After installing these products, you must reboot the computer.

Setting up the Tutorial database on a dbbANYWHERE
Workgroup Server

You need to register the Tutorial database file with the 32-bit ODBC
Administrator tool included with the SQL Anywhere database engine. Follow
these steps:

1 Place Tutorial.db (provided with the tour) on the same computer as
the dbANYWHERE Workgroup Server.

For example, you could place it in the sqlany50 directory.

2 On the computer with dbANYWHERE, start the ODBC
Administrator by clicking the Windows Start menu then choosing
these menu items in order: Programs, Sybase SQL Anywhere 5.0, then
ODBC Administrator. For Windows N'T 3.51, you need to run the
application ODBCADM.EXE; it’s installed in your Windows
directory.
A Data Sources window appears. It displays your registered data sources
and drivers.

Data Sources

Lloze

Help
Setup...
Delete

d

Optiong... | System DSM... | Drivers...

didildd

Now you’ll add a new data source to this list.
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3 Click Add.
The Add Data Source dialog appears.

Add Data Source E
Select which ODBC driver you want to use
fram the list, then choose OK.

Cancel |
Help |

Installed ODBC Drivers:

4 Seclect Sybase SQL Anywhere 5.0, then click OK.
The ODBC Configuration dialog appeats.

Data Source Hame: || | | 1].4 I
D ipti | | Cancel |
-C tion Inf E

Help |

User ID: |

Server Name: |(de[aull)

|
Password: | |
|
|

Database Hame: |

— Datab Startup

Database File: | | Browse. .. |
@ Local ¢ Metwork  Custom Options...
— Additional C: tion Options
Translator Hame: |(ND Translator> | Select |

[ Microsoft Applications [Keys in SQLStatistics)
[ Prevent Driver not Capable ermors

[ Delay AutoCommit until statement close

5 Type these values in the following fields:
* Data Source Name — Tutorial
¢ User ID — dba

* Password — sql
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* Database Name — Tutorial

® Database File — Location of Tutorial.db, such as
C:\sqlany50\Tutorial.db (you can click Browse to choose a path)

6 Click OK.

The Tutorial data source is added to your ODBC configuration. It can

now be located by dbANYWHERE.

Click Close in the Data Sources window.

Restart dbANYWHERE by clicking the Windows Start menu then

choosing the following menu items in order: Programs, Symantec

dbANYWHERE Workgroup Server, then Symantec

dbANYWHERE.

The dbANYWHERE window appears.

&% dbANYWHERE @ 155.64.36.113:8889 [users: 0]
Log Option: Help

Running.

hlal
=
g
S

4] | i
Running Shutdown |

o
E
E
w
It

Look at the title bar and note the IP address (or host name) and the port
number configured for dbANYWHERE. You need this information when
you work through Chapter 6, “Creating Applets with Database Functionality.
If dbANYWHERE is running locally, during the tour you can use localhost in
place of an IP address, as long as your hosts or Imhosts file contains an entry
for it (and it usually does by default).

2
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Installing Symantec classes

Make sure the most up-to-date Symantec classes are in your Visual Cafe Pro
directory:

1 Navigate to the VisualCafePro\Java\Lib directory.

2 If you see a Symantec.zip file, delete it.

3 Copy Dbaw.zip, Dbaw_awt.zip, and Sql.zip to this directory, if they’re
not already there.

The rest of this chapter contains more general-purpose install instructions.
You can look through them now, or start the tour by going directly to
Chapter 3.

Planning your installation

Visual Cafe Pro uses a three-tier architecture to provide database connectivity.
During development, you can install Visual Cafe Pro on your development
computer. You also need to install this software:

* dbANYWHERE Workgroup Server
¢ Install it on the same computer as Visual Cafe Pro.

* Or install it on a remote computer that can communicate with the
development computer through TCP/IP.

* database engine

* Local database engines must be installed on the same computer as
dbANYWHERE.

Other database engines can be installed on the same computer as
dbANYWHERE or on a remote computer (client software must
be installed on the dbANYWHERE computer so it can
communicate with the remote database).
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System requirements

To run either Visual Cafe Pro alone on a computer, or the dbANYWHERE
Workgroup Server alone on a computer (with client software to interface with
a remote database), you need:

* IBM personal computer or 100 percent compatible, Intel 486 or
above

* 16 Mb RAM; 24 Mb recommended for larger projects
*  Windows 95 or Windows N'T 3.51 or greater
* CD-ROM drive

* 30 to 40 Mb free hard disk space, depending on configuration and
data caching requirements

*  VGA; Super VGA recommended
* TCP/IP network software

6 For Windows NT, 32 Mb RAM is recommended.

To run the dbANYWHERE Workgroup Server and the local database engine
on the same computer (without Visual Cafe Pro), you need to meet the
requirements listed for Visual Cafe Pro plus:

* 16 Mb RAM; 32 Mb recommended for larger projects

* 50 to 60 Mb free hard disk space, depending on configuration and
data caching requirements

To run Visual Cafe Pro, the dbANYWHERE Workgroup Server, and the local
database engine on the same computer, you need to meet the requirements
listed for Visual Cafe Pro plus:

* 24 MB RAM minimum; 32 Mb recommended
* 50 to 60 Mb free hard disk space, depending on configuration and

data caching requirements

To use dbANYWHERE, you need to have access to at least one supported
database; see the list of supported databases in the next section for details.
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Databases supported by dbANYWHERE

Local databases, such as Sybase SQL Anywhere and MS Access, must be on
the dbANYWHERE Workgroup Server computer.

Some databases, such as Microsoft SQL Server and Oracle Server, can run
locally or remotely.

Databases that run remote from the dbANYWHERE Workgroup Server
computer require that you have client software running for the database, so
dbANYWHERE can connect to the remote database. The dbANYWHERE
Workgroup Server can connect to the following databases through the native
database libraries:

*  Microsoft SQL Server 6.x using DB-Library

*  Oracle Server 7.x using OCI (Oracle Call Interface), including UNIX
workstation versions

* Sybase SQL Server Systems 10.x and 11 x using DB-Library, including
UNIX workstation versions

* ODBC, including UNIX workstation versions

dbANYWHERE can use any of these database engines that support Win32
client software, for example, the UNIX workstation version of Oracle Server
7.X.

The dbANYWHERE Workgroup Server provides unlimited connections to
Sybase SQL Anywhere and MS Access. For the other databases listed above,
dbANYWHERE provides access for the first five active connections only.
This means that if five connections are already active (even if the connections
are to Sybase SQL Anywhere and MS Access), at that point you can only make
connections to Sybase SQL Anywhere and MS Access.

To increase the number of connections available to these databases, you must
upgrade to dbANYWHERE Server. Once you have upgraded to this version
of the server, you can purchase full licenses for other database drivers.
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Using the installer

If Visual Cafe Pro is already installed on your system, refer to the Readme.txt
file before you begin installation.

To install Visual Cafe Pro, as well as dbANYWHERE, Sybase SQL Anywhere
database engine, and Netscape software, follow these steps:

1 Read the registration instruction card (in the box). It describes how to
register through our Web site, http://cafe.symantec.com, so you can
obtain technical support, upgrades, and news about special
promotions. Use the user ID and password included with your
package.

Insert the CD-ROM in the CD-ROM drive on your system.

3 If the installer didn’t automatically start and you’re running under
Windows N'T 3.5x, choose File /Run from the Program Managers
menu.

If you are running under Windows 95 or N'T 4.0, choose Run from the
Windows Start menu to display the Run dialog box.

4 'Type: drive:\setup.exe
where drive is the CD-ROM drive identifier, and click OK.
5 Click the name of the software you want to install.

The install wizard guides you through the installation process; you can
select where to install Visual Cafe Pro and which elements to install.
Click Next to proceed through the steps.

You can install the following items separately, by clicking the appropriate
icon:

* Visual Cafe Pro
* dbANYWHERE Workgroup Server
* Sybase SQL Anywhere standalone version

* Netscape Fastrack Server and Netscape Navigator Gold (if
available on your CD)

When installing Sybase SQL Anywhere, let the installer update the registry for
you. Also, you need to reboot after installation.
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After installation, the installer returns you to the main install window,
where you can install other items, if you want to.

6 Read the Readme.txt file (on the CD-ROM) before you use the
software. It contains important last-minute information.

Information on Visual Cafe Pro and dbANYWHERE Workgroup Server is
included in this guide and in the online help. Information on other software
included with Visual Cafe Pro is described in other publications.

Starting the dbANYWHERE Workgroup Server

You can start the application in any of these ways:
o

Double-click the application icon in the Program group.

* In the Start menu of Windows 95 or NT 4.0, choose the application
from the Programs menu.

* Run the application (dbaw.exe) from the Run dialog.

The dbANYWHERE window appears.

Stopping the dbANYWHERE Workgroup Server

Close the dbANYWHERE window or click the Shutdown button. If users are
connected, you’ll be prompted.

Starting Visual Cafe Pro

You can start the application in any of these ways:

Double-click the Visual Cafe Pro application icon in the Program
group.

* In the Start menu of Windows 95 or NT 4.0, choose the application
from the Programs menu.

Run the application (vcafe.exe) or a .vpj file from the Run dialog.
The Visual Cafe Pro environment appears. After you use Visual Cafe Pro, it

remembers what windows you had open when you last used the application
and opens those windows the next time you run the product.
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To use database functionality within Visual Cafe Pro, dbANYWHERE must
be installed and running, either locally or on a remote computer, and accessible
through TCP/IP. Your local computer must also be configured with TCP/IP
connectivity. To locate dbANYWHERE, you must know the IP address (or
host name) of the PCit’s running on and the port number configured for
dbANYWHERE. When dbANYWHERE is running, it displays its IP address
and port number. The default port number is 8889. If dbANYWHERE is
running locally, you can use localhost in place of an IP address, as long as

your hosts or Imhosts file contains an entry for it (and it usually does by
default).

Exiting Visual Cafe Pro

To exit from Visual Cafe Pro, choose Exit from the File menu. You are
prompted if you have unsaved changes.

Uninstalling Visual Cafe Pro

o

To uninstall Visual Cafe Pro, follow the procedure for your Windows
environment (Windows 95 or Windows NT).

Uninstall does 7of remove any files created in the \VisualCafePro directory
tree after Visual Cafe Pro is installed (for example, sample projects) ot in the
Visual Cafe Pro group.

Uninstalling in Windows 95 or Windows NT 4.0

If you are running under Windows 95 or Windows NT 4.0, to uninstall Visual
Cafe Pro:

1 Choose Settings from the Windows Start menu.

Choose Control Panel to display the Control Panel window.
Choose Add/Remove Programs from the Control Panel window.
Click the Install/Uninstall tab and highlight Visual Cafe Pro.

Click Add/Remove and follow the instructions on the screen.

a b~ WO N
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Uninstalling in Windows NT 3.5x

If you are running under Windows N'T' 3.5x, to uninstall Visual Cafe Pro:
1 Open the Visual Cafe Program group.

2 Double-click the uninstall icon and follow the instructions on the
screen.

Deploying applets and applications

Here are some guidelines for deploying applets and applications created with
Visual Cafe Pro. This section covers the following topics:

*  Setting up dbANYWHERE and the database
* Setting up the client

* Deploying applets on a Web server

* Deploying applications

* Using the Bundler.exe utility

Setting up dbANYWHERE and the database

To deploy applets and applications that use a database, you need to install
dbANYWHERE on your Web server. In addition, if you're using a local
database, you need to install the runtime version of your database engine (such
as Sybase SQL Anywhere) on your Web server. If you’re using a remote
database, you need to install the client database software provided by your
database vendor. For applets, the applet and its supporting class files must also
be located on this Web server. The runtime version of Sybase SQL Anywhere
is located on the CD in \Sybase\runtime\win95 or \Sybase\runtime \winN'T.

Setting up the client

The system requirements for users accessing dbANYWHERE vary,
depending on the Java API client they’re using. Consult the Java API
documentation for details. Note that client database software is not needed for
usets to connect to dbANYWHERE.
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Deploying applets on a Web server

After you complete an applet in Visual Cafe Pro, you are ready to deploy it on
a Web site. You need to know how your particular Web site is set up to get
your applet up and running. However, here are some guidelines. Because your
project can contain more than one applet that appears in related Web pages,
these guidelines are for setting up a project that contains one or more applets.

* Create an applet directory on the Web server where you will store
your applet files.

* Putall of your applet class files and html files in the applet directory,
as they appeared in your Visual Cafe Pro project directory.

* When using graphics files, use relative URLs. Then place your
graphics files in the applet directory or a subordinate directory, as it
appeared in your project directory.

* Enableyour applet to access the Symantec class files it needs. You can
place an unzipped Symantec directory (and all subdirectories) in the
applet directory or use another method, such as having your classpath
point to this directory. For applets that use Visual Cafe Pro database
features, you also need to unzip (keeping all subdirectories intact)
Dbaw.zip and Dbaw_awt.zip into the Symantec directory in the applet
directory and Sql.zip into a Symjava directory in the applet directory;
or you can use another method to let your applet access these classes.
Instead of placing all of these class files on the Web server, you can
use the Bundler.exe utility, described in a following section, to learn
exactly what class files an applet uses.

* Ifyour applet uses other class files, you need to provide access to
those class files. (Remember that the Web browser should provide
access to standard Java class files.)

* For applets using Visual Cafe Pro database features, you need to make
sure the Session object refers to the correct dbANYWHERE server.

After you put your applet on a Web site and set it up, make sure you test it
from remote computers to check that it works as planned. You can also test it
on different operating systems.
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Deploying applications

After you complete an application in Visual Cafe Pro, you are ready to deploy
it. Requirements for different applications vary. However, here are some

guidelines:

Create an application directory where you will store your application
files.

Put all of your application class files in the application directory, as
they appeared in your Visual Cafe Pro project directory.

When using graphics files, use relative URLs. Then place your
graphics files in the application directory or a subordinate directory, as
it appeared in your project directory.

Enable your application to access the Symantec class files it needs.
You can place an unzipped Symantec directory (and all subdirectories)
in the application directory or use another method. For Visual Cafe
Pro applications that use database features, you also need to unzip
(keeping all subdirectories intact) Dbaw.zip and Dbaw_awt.zip into
the Symantec directory in the application directory and Sql.zip into a
Symjava directory in the application directory; or you can use another
method to let your application access these classes. Instead of placing
all of these class files in the application directory, you can use the
Bundler.exe utility, described in a following section, to learn exactly
what class files an application uses.

Your users need to obtain or you need to provide the Java virtual
machine and Java class files. The Symantec Java virtual machine must
be licensed from Symantec.

If your application uses other class files, you need to provide access to
those class files.

For applications using Visual Cafe Pro database features, you need to
make sure the Session object refers to the correct dbANYWHERE
servet.

Tell your users how to start your application. Unless you provide
another way, on a PC your users must type at a DOS prompt:

path\java application-name

path\java invokes java.exe, for example, \visualcafe \java\bin\java.
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Your application name is the same as the name of the frame for the
main application window without the .class extension; it’s case-
sensitive.

For example:

\visualcafepro\java\bin \java Amazing Tour

Make sure you test your application package so it works as planned. You can
also test it on different operating systems.

Using the Bundler.exe utility

The Bundler utility enables you to easily figure out which class files are used by
your applet or application. After your Java applet or application is finished,
enter the following command at the DOS command prompt (make sure that
\visualcafe\bin is in your path):

Bundler.exe -make -cdb mainclass.cdb -depend /Zstname.dep mainclass.java
mainclass is the name of the main class Java file in your project.

listname.dep is the file where the list of classes used by your applet or
application will be generated. The Bundler also lists the name of the zip file (if
any) where the class file was found. This helps you figure out what class files
you would need to unzip from each class zip file used by your applet or
application. The filename must have a .dep extension.

Even though the java.* class files are logged in this file, you are not actually
required to copy those to your Web server for your applets, as they are usually
available with most Web browsers.

The Bundler takes the same command line options as the sj command line
compiler. As a result, you can add additional class paths, and so on.
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Starting the Tour

Imagine that you work for a travel agency, called Amazing Adventures Travel,
that’s ready to take advantage of the money-making opportunities that the
Internet offers. You decide to add Java functionality to a series of Web pages
that advertise your upcoming package tours and your custom tour services. To
get started, you update the pages for your favorite destination, Isle de Cafe.

In this chapter, you'll look at the Isle de Cafe applets and application, some of
which you’ll create in the following chapters, plus learn some important Visual
Cafe Pro terms and concepts.

What you need

To work through the tour, you need a Java-enabled Web browser, such as
Netscape 3.0 or higher. You also need to install the Visual Cafe Pro software,
as described in the Chapter 2 section, “Installing the software needed for the

tour.” Be sure to start the local dbANYWHERE Workgroup Server before
working through the tour.

After you meet these requirements, you can start the tour with this chapter.
Then work through the following chapters in order:

Chapter 4, “Creating an Applet for the Web Page,” shows you how to create
an island map applet including an animation and integrate it into a Web page,
without needing to program in Java code.

Chapter 5, “Creating the Application and Debugging Code,” describes how to
create a simple application and how to perform advanced debugging
operations. This chapter builds on the previous chapter.

Chapter 6, “Creating an Applet with Database Functionality,” shows you how
to use many of the Visual Cafe Pro database features.
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Looking at the Isle de Cafe Web pages

Starti

= Visual Cafe Pro - Untitled1

File Edit Search Project |nsi

Your main Isle de Cafe Web page is the most important page. On this page,
you need to grab the initial interest of prospective clients, so they remember
your company and want to spend some time at your Web site. A Web page
with only HTML could potentially be a little boring. Y ou decide to add Java
applets so the page becomes dynamic and interactive.

Let’s look at the Web pages in a Web browser and identify the elements
created with Visual Cafe Pro.

ng Visual Cafe Pro

You can start the application in any of these ways:

Double-click the application icon in the program group.
* In the Start menu of Windows 95, choose the application from the
Programs menu.

Run the application or a .vpj file from the Run dialog.

When you first start Visual Cafe Pro, an unnamed project, based on the default
applet template, appears. By default, the Project, Form Designer, and Property
List windows appear.
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Opening the project

All of the applets and HTML files that make up the Isle de Cafe Web pages are
contained within the IsleWeb.vpj project. To look at the project, follow these
steps:

1 Close any open projects by clicking the Project window, then
choosing Close Project in the File menu.

You'll work with the Visual Cafe Pro applet and application templates
later in this tour.

2 Choose Open from the File menu.
The Open dialog appears.

Open 21=]
Laak in: IaBin j gl iR EEE
Components
Keyps

Macs
Projects

Files of type: IVisuaIEafeProProiect[*.vpi] j Cancel |
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3 Select the IsleWeb.vpj project in the \ VisualCafePro\ Tutotial \Applet
folder, then click Open.

The project appears.

Visual Cafe Pro = [=] 3
Filz Edit Seach Froject Inset Window Help

D[{e] s [le] 22| watses l—_lsdn \t|l IIIIEIII| » [

[h o || 5 o= | e [ 22 : =1 i 1 e e =
J Standard | dbahARE | Litiity Mulllmadlal Panelsl Additional | Shapes
Far Help, press F1 ’_ IW
- R R ]
=[] IE Plane =
[+ E SlideShow Background [ white
. IsleM ap Class java.appletApplet
Email (= Dimensions
Reserve - 0
Home N 1
[#) 1sle - Width 520
- @ Comments - Height a0
Customtours Enabled tue
(&) Inquiny - Font
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Running the applets in your default browser

Visual Cafe Pro lets you launch the browser from within its environment.

1 Choose Options from the Project menu.

The Project Options dialog appears.

Praject | Eompilerl Directoriesl Debuggerl
—Rele
ok € inal
— Project type
' Applat
Starter HTHL:  [Home. it ==

¥ Execute applet in default HTML viewer

" Application

Starter clazs e

Program arguments:

™ Parse jmparts

V' Clear Messages window before Build

()8 I Cancel |

Help |

2 Make sure Home.htm is in the Starter HTML field and the Execute
applet in default HTML viewer option is selected. Then click OK.

3 Choose Execute from the Project menu.

Visual Cafe Pro launches your default HTML browser and displays your

Web page within it.

The Isle de Cafe home page appears. The pages contain elements that
were created with HTML and with Java using Visual Cafe Pro. The
Visual Cafe Pro applets on this page are the plane animation created with
the Visual Cafe Pro Animator component and the slide show created
with the Visual Cafe Pro SlideShow component.

Some early versions of Java-enabled browsers didn’t support applets very well.
If the applets in the tour don’t run propetly in your browser, you probably
need to upgrade your browser. However, you can first try to load the page

multiple times.
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ki Metscape - [Symantec Yisual Café Tutorial - Isle de Café Tours]

File Edit “iew Go Bookmarks Option: Directory Window Help

S (B I T IR T

Bt Farward Home Fieload Iriages Cipen

Location: Ifile:.-".-".-"CINisuaIEIafePro.-"Tutorial.-"AppIet.-"Home.htm j

Wwhat's Mew? | Wwhat's Cool? | [restinations | NetSearchl FPeople | Softwarel

Frint Find Sitop

A, Home Page
* and Slide
Show

Esland Map
and Information

Comments

Custom and
Package
i Tours

E-mail §
Request Form
)
e
Online Jdz
Reservations
1| [
Tl | [ =E

On the left of the page are links to the other pages.

You use the plane animation to attract the attention of your Web site
guests. Y ou also want your potential customers to get an idea of what
Isle de Cafe offers them, so you include the slide show. The slide show
contains photos of Isle de Cafe that you've collected over the years. Y our
customers can move back and forward between the photos of the slide
show. Next to each photo is a description of the location so your
customers know what they’re looking at.

4 Scroll down to the slide show, then click the Forward button of the
slide show (the right triangle) until you’ve viewed the entire slide
show. Also try clicking the Previous button (the left triangle).
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5 Explore the other Web pages by clicking a link on the left of the page.
Make sure you look at all of the pages.

While the main Isle de Cafe Web page is important to capture people’s
initial interest, once they’re interested they may want more in-depth
information about the island.

You decide that the best way to present this detailed information is
through an island map. On the map, customers can click a location to
jump to information about it. This feature was implemented with the
ImageViewer and InvisibleHTMLLink components provided with Visual
Cafe Pro. You also decide to add an animation, implemented with the
Animator component, that draws attention to a main attraction on the
island — the ability to safely view an active volcano.

Some additional features you’d like on the Web site include a list of your
upcoming package tours, information on the custom tours you can
design for clients, an e-mail request form so clients can get additional
information, an online reservations form, and some quotes from clients
about how much they enjoyed your tours.

The online reservations applet will run propetly only if you have a
dbANYWHERE W orkgroup Server running on the same computer on the
local hard drive, the computer has enough system resoutces, and you’ve
correctly set up the Tutorial database. See Chapter 2 for more information.

It’s time to look at these Web page elements in Visual Cafe Pro directly. You
can exit your browser or keep it running so you can refer back to the
completed Web pages.
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Looking at the applets in Visual Cafe Pro

Now that you've seen how the applets look in your Web pages, let’s see how
they were created with Visual Cafe Pro.

Looking at the project

The Visual Cafe Pro full-featured project management system and flexible
editing and browsing tools let you develop and maintain even the most
complex Java applications:

1 Look at the items appearing in the Project window.

] Project - IsleWeb. vpj M= 3

[]..s

(-] SlideShow
(-] IsleMap
[l-[5] Email
[#-[3] Reserve

iy Objects | [ Packages |

You’ll notice the following applets in the Project window:
* Plane — plane animation

* SlideShow — slide show

¢ IsleMap — Isle de Cafe map with volcano eruption

¢ Email — e-mail information form

* Reserve — online reservations utility

And the following HTML files:

* Home — first page

* Isle — page with island map

¢ Comments — page containing customer comments

* Customtours — page describing custom and package tours
* Inquiry — page with e-mail questionnaire

* Reserve — page with online reservations utility
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While the Object tab is selected, you're looking at the Object view. The
Object view of the Project window shows the embodied objects of a
project, including Visual Cafe Pro forms and associated components:

* A Visual Cafe Pro component is a user interface (UI) element, such as
a button, menu, text box, or container of other components. It’s
often called a control in C++.

A Visual Cafe Pro form is a Java container — a component that can
contain another component. There are two general categories of
Java containers: windows and panels. Some types of windows are a
frame (which can have a menu bar) and a dialog. A panel is a
defined area that can appear in a window, such as an applet that
appears in a browser.

The Object view also shows HTML files, if present.

In the Project window, click the + next to an object to view the
components contained by it.

Choose Component Library from the Window menu.

The Component Library appears.

[ dbAWERE
v)--[Z7) Project Templates

[Z] Predefined TextFields
-1 Shapes

The Component Library is a repository of components. Visual Cafe Pro
provides an extensive library of components, which you can supplement
with third-party component plug-ins and your own components. In
addition to supporting the complete set of standard Java components,
Visual Cafe Pro provides many additional components. For fast access,
you can configure the Component Palette to contain your favorite
objects:

SEENEEEEEEEE |
Standard | dbaMwiaRE | Utiity | Mulimedia | Panels | Additional | Shapes |




3-10

Starting the Tour

To add a component to a Visual Cafe Pro form, drag a component from
the Component Library window to the Project window or Form
Designer, then position and resize it as needed. Or, you can click a
component on the Component Palette and draw it on the form. In
addition, the Component Library contains forms, so you can drag a form
into a Project window to add it to the project. To add an object to the
Component Palette so you can get to it more quickly, drag the object
from the Component Library to the Palette.

Close the Component Library window.
In the Project window, click the Packages tab.

The Package view shows the source files in a project, grouped as packages.
A Java package is a group of related Java classes and interfaces.

6 Click the Object tab to return to Object view.

You can double-click a form or file in the Project window to open it. In the
following sections, youll look at the applets and an HTML file in the project.
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Looking at the applets

Once the Project is opened, you can look at the applets it contains:

1 Double-click the IsleMap applet in the Project window.
The Form Designer appears.
X Visual Cafe Pro
File Edit Search Project Insert Lapout Object “Window Help
D[R] ][] [9[xe] wakspaoe [E |l"l| DEEEEE 0] Bl
NEEEERERE 3 5 1 o e e e 2 O = e
_I Standard | dbaWwARE | Utility | Multimedia | Panels | Additional | Shapes
For Help. press F1 l_ MUM
I Project - IsieWeb vpi BEE
e . IsleMap vI
1 3 [ e
javaapplet Applet
nsions
0
0
idth 523
- [@] Comments i - Height 346
i [§] Customtors e l=d true
] iy @ VENDUCA
- [] Reserve SIMERILIA ame Dialog
: ize 12
tyle
i Bold true
. s bl fal
G Obiets [ Packoges | pond I b
rit Background false
it Font false
S : it Foreground false
Clicka Madetna e
location name ‘ : . Sl
W . referred Size falze
Jfor mare information e e

The Form Designer is a true WYSIWYG form layout tool: it lets you edit
all types of forms, including applets, windows, message boxes, and dialog
boxes. To design the visual interface of your Java applications and
applets, you can drag and drop components from the Component
Palette or Component Library directly onto your forms. Visual Cafe Pro
automatically generates the Java code and changes the code as you make
modifications. Several layout managers are available, so you can pick the
one that best suits your form, or don’t use one at all.

The properties of the components are displayed in the Property List
window. To specify the properties of components on a form, you simply
fill in fields in the Property List. Visual Cafe Pro updates the component
appearance on the form and the Java code for you.
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2 To look at the properties for the Animator component, choose the

component (animatorErupt) from the pull-down menu at the top of
the Property List or click the component on the form.

The properties for the Animator component appear in the Property List
window.

To look at the undetlying Java source code for the applet, double-click
the Form Designer. Or right-click over the IsleMap object in the
Project window, then choose Edit Source from the pop-up menu.

The applet source code appears in the Source Editor.

E c:\W¥isualCafePro\Tutonal\AppletilsleM ap.java M= 3
Objects: I |slebap j Events/Methods: I j
* FY
L hasic extension of the Jjava.applet.ipplet class
e

import java.awt.¥;
import java.applet.®;

public class IsleMap extends Applet {

public void init () {
super.init (] :

/f Take out this line if you don't use sywantec.itools.r
symantec, itools. lang. Context.sethocumentBase (getDocument

/4 {{INIT_CCNTROLS
setLayout (null) ; _ILI
K| v

| | | | |Line 1 |EOI 1

Visual Cafe Pro supports two-way development by translating Java code
into a visual representation and by translating the visual representation in
the Form Designer to Java code. Y our code and your visual model
always match.

The Visual Cafe Pro Source Editor simplifies development with full-
color Java syntax and keyword highlighting and an integrated macro
language for extending the editor. A single mouse click in a menu
navigates you to any declaration inside the Java project. The Form
Designer ensures full synchronization between source code and the
visual tools. During debugging, you can use the Source window to
monitor program execution.
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4 You can also look at the plane animation by double-clicking Plane in
the Project window, the slide show by double-clicking SlideShow, the
e-mail questionnaire applet by double-clicking Email, and the online
reservations utility by double-clicking the Reserve applet.

Because these are detailed applets, you might want to close each Form
Designer window before opening another one.

To test your applet, you can run it in the Visual Cafe Pro Applet Viewer.
Visual Cafe Pro also lets you run your applets within a browser by launching
the browser for you. You'll try these features later in the tour.

Opening an HTML file

An applet runs from an HTML file. Although your project doesn’t have to
contain the HTML files that the applets run in, it’s convenient to include the
HTML files in the project. Let’s look at an HTML file in this project:

1 Double-click Home in the Project window.

The Source Editor appears.
E c:\WisualCafePro\Tutorial\VAppleti\Home_html M= 3
Objects: I j Events/Methods: I j
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN"> ﬂ
<HTHL>
<HEAD>

<META HTTP-EQUIV="Content-Type” CONTENT="text/html;:CHARSET=is0-8859-1">
<TITLE>3ymantec Visual Café Tutorial - I=zle de Café Tours</TITLE»
</HELD>

<BODY Background = "Images/GOALL.GIF"™ TEXT="#000000" EGCOLOR="HFFFFFF"
LINE="#00S000" VLINE="#S0S000" ALINE="#505000":

<Pr<ING IRC="Images/GOALLZ.gif" EORDER = O ALIGN="LEFT" HIPACE="O"
TIEMAP="HGOALLZ" ISMAP:</P>

<ULx> -
<I I 3
| | | | |Line1 |EOI‘I

The HTML file is displayed in this window. You can create and edit
HTML code here.
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2 Choose Find from the Search menu.

The Find dialog appears.
Find
Find what:
| (R .|
Previous

™ Match case

™ Match whole words anly ﬂl
™ Reqgular expression

3 Type applet code, then click Next.

The words are highlighted in the HTML code. This is part of the applet
tag that causes the Visual Cafe Pro applet to appear on the Web page. An
applet tag has the following basic format:

<APPLET code=" applet .class" width= pixw height= pixh ></APPLET>

applet is the name of the applet, pixw is the number of pixels for the
width, and pixh is the number of pixels for the height.

4 Choose Find Again from the Search menu.
Another applet tag is highlighted in the HTML file.
5 Choose Close Home.htm from the File menu.

The Source Editor closes.

Now let’s look at the application. You can close your project by closing the
Project window.

Running the custom itinerary application

A large part of your business revenue is generated from designing custom,
escorted tours to Isle de Cafe. As you expand your operations onto the WWW,
you look at ways to take full advantage of the time-saving aspects of electronic
communications.

You decide that a cross-platform Java application would be ideal for

distributing custom itineraries to clients for approval. Instead of spending time
and money putting together an itinerary on paper — especially one that looks
good enough for people purchasing a premium tour — you can put together a
polished itinerary in the form of an application. This itinerary is easily modified
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as changes are needed and includes photos of the locations the clients will
visit.
To run the itinerary application, follow these steps:

1 Ina DOS window, navigate to the directory containing
AmazingTour.class.

If you installed in the default location, it should be in the
\VisualCafePro\ Tutorial \Application directory.

2 At the DOS prompt, enter:
\visualcafepro\java\bin\java AmazingTour

Specify a different path if java.exe is not in the default Visual Cafe Pro
location, \VisualCafePro\Java\Bin.

The application appears.

E‘%Amazing Adventures Travel - Custom ltinerary Application

File Help

To start. choose Open from
the File menu and open
your data file. Your .dat file
and the graphics files must
be in the same directory.
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3 From the application, open Tour.dat, which is located in the Images
directory.

The itinerary appears.

E‘%Amazing Adventures Travel - Custom ltinerary Application

File Help

Custom Itinerary for

Stan and Flora
Robinson

Ly 7

Arrive this morning in Isle de Café, at
the tropical paradise of Bungbusi.
Check in to your deluxe seaside
resort, then enjoy the pristine
heaches just outside your door. The
sand beaches and warm waters are
ideal for relaxing and for all kinds of
water sparts, including surfing, water
skiing, and snorkeling, included at no
additional charge. The resort
gardens, three poals, gourmet
restaurants, open-air lounge with local
entertainers, and swim-up bar are at
wour disposal. Now is the time to let
the stresses fade atlsle de Café.

Previous | MHext |

4 Press the Next and Previous buttons to look through the itinerary.

5 To exit the application, choose Exit from the File menu. Then click
Yes in the dialog.

Now let’s look at the application in Visual Cafe Pro.
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Looking at the application in Visual Cafe Pro

Now that you've seen how the application works, let’s see how it was created

with Visual Cafe Pro.

To look at the itinerary application in Visual Cafe Pro, follow these steps:

1 Ifyou don’t have Visual Cafe Pro running, start it now.

2 Close any open projects.

3 Choose Open from the File menu.

The Open dialog appears.

4 Seclect the Itinerary.vpj project in the
\VisualCafePro\Tutorial \Application foldet, then click Open.

The project appears.
X Visual Cafe Pro [_ O] x]
File Edit Search Project Insert ‘window Help
] = = W = @I?l\f?l\wmspace- B - || a\ w1 =
v == s @] EEmmEE EE I EEE
5| standad [ dbemaRE [ Uity | Mubimedia | Panels | Additional | Shapes |
For Help, press F1 MUM
& Pioject - Itinerary vpj _ o] x| ES Property List - AmazingT our O] %]
+ AmazmgToulE E AmazingTour =
-] AboutDialag Background [ white
[E DuitDialog Class java. awt Frams
[=-- Dimensians
o 1]
N 0
- Width 595
- Height 550
Enabled tue
= Font
L Mame Dialog
i Size 12
=] Style
i Bold true
. o talic false
=
il ety Ueilechces Fareground | black
Inherit Background | false:
Inherit Font false
Inherit Fareground | false
Nore
Hame AmazingT our
Fiesizable e
Title Amazing Adventures Travel - Custam [tineral
Use Prefened Size | false
Wisible true
| | |

You'll notice the following objects in the Project window:

* AmazingTour — main application window
* AboutDialog — About dialog
* QuitDialog — Quit dialog
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5 In the Project window, double-click AmazingTour.
The Form Designer appears.

‘,-‘E-'J;Visual Cafe Pro =] E3
File Edit Search Project Inset Layout Object Window Help

D@ B2 El2 k]| vae e =1 g(=)E DEEEEE]] )]

lT =) ;H [a= FEd AmazingT our - Form Designer

=

EI Standard | dbaWARE

— =—————— To start. choose Open from -

Far Help, press F1 - o [ [HUM |

the File menu and open

your data file. Your .dat file - - =10l
and the graphics files must d
{5 AboutDialog be in the same directory. o 1 whits

[= QuitDialog java avk Frame

1]
o
535
3 550
true

Dialog
12

old tue

. . . jalic false
=
Ciy Objects | Sy Packages | . d IL] black

dground| false

b false

eground |false

None

Amazing ] our

true

Amazing Adventures Travel - Custom [tinera)

rred Size | false
frue

c . c Previous Hext c c | _’I

The Project window lists the names of the components on the form. To
see the components within AmazingTour, you can click the + next to
AmazingTour.

6 Close your project by closing the Project window

Visual Cafe Pro lets you launch your application from within its environment
so you can test it. You'll try this feature later in the tour.

Now you can continue with the next chapter to build and test one of the
applets.
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This chapter quickly acquaints you with the main features of Visual Cafe Pro
by showing you how to create an applet for your Isle de Cafe Web site. This
portion of the tour doesn’t involve manually creating new Java code; instead,
you use the visual design capabilities of Visual Cafe Pro to create your
complete applet. In the next chapter, you do work directly with Java code.

To learn how to add applets to your HTML page, work through the following
sections in this chapter:

* Creating and naming the project
* Creating the island map applet
* Displaying the applet in a Web browser

Before working through this chapter, you should have completed the
previous chapter “Starting the Tour.”

0 When you first install Visual Cafe Pro, you have the default environment
options. If you’ve changed your environment options since you’ve installed the
product, you might run into variations because of your settings. In particular,
make sure the keyboard is set to vcate. Choose Environment Options from the
File menu to view your environment option settings.

Creating and naming the project

The project contains the elements needed in a Web page, a group of
related Web pages, or an application, including applets, HTML files,
application windows, and so on. To get started quickly, you can use
project templates with skeleton applets and applications that you extend
with additional functionality. Y ou can also create custom templates and
add them to the Component Library, and add your favorite templates to
the Component Palette.
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To create the project that will the hold the applets and HTML file for your Isle
de Cafe Web page:

1 Close any open projects by clicking the Project window, then
choosing Close Project in the File menu.

When you first start Visual Cafe Pro, an unnamed project, based on the
default project template, appears. Here you’ll create a new project so you
can see how to choose a template.

2 Choose New Project from the File menu.

The New Project dialog appears.

Froject Templates:

% B B B 2
dbdiwARE dbéwWARE  Emply Project Basic

Template  Project Wizard Application
“Wizard

B azic Java applet with blank form.

ak. I Cancel Set Default | E
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& Visual Cafe Pro - Untitled2

3 Select the Basic Applet project template. Then click OK.

The Project and Form Designer windows appear.

File Edit Search Project Insert Lapout Object Window Help

] O | = s cn] ] e e e M R

= B A S R A S = B =

El Standard | dbéwARE [ Utity | Multimedia [ Panels [ Additional | Shapes |

(El = | o] = =

| Hum
[E Project - Untitled2 =10] x| Applet] - Form Designer 8 [=] 3
E:App\ené . . . . . . . Lpplet! =
Background ] white
Clazs java.applet.Applet
(=) Dimensiohs
¥ 1]
hd 0
“width 426
- Height 266
Enabled true
[=)-- Font
. Mame Dislog
i Size 12
= Stule
i true
wo Italie false
Sg Dokt [ Packeges ] Forogound I sk
Inheit Background true
Inherit Font true
Inherit Fareground true
Layout MNane
Marne Applet!
Use Prefened Size false
Yisible true

4 Click the Project window, then choose Save As from the File menu.

The Save As dialog appears.

Save As 21=]
Save Ia Projects j C’Fl i
File name: IUntitIed2.vpi Save I
Save as type: IVisuaI Cafe Pro Project [*.vpi) j Cancel |

5 Create a new directory structure, such as
\VisualCafePro\MyApps\Applet, to hold your applet files.

The project and all of the files contained within it should be in the same
directory. For easier project management and to prevent filename
conflicts, you should save each project in its own directory.
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6 Type MylslePg.vpj in the File name field, then click Save.

The new name appears in the titlebar of the Project window. Visual Cafe
Pro Project files have a .vpj extension.

The first time you save a project, all of the files it contains are also saved
to the new directory. After you save it once, saving just the project does
not save other files, such as applets. Save All does save all files.

Creating the island map applet

To create the applet, work through the following tasks:

Gathering the files you need

Setting the applet properties and adding the map
Adding the HTML links

Adding the volcano eruption animation

Running the applet

Gathering the files you need

To construct your Web page, you need an HTML file that your applet will run
within and the graphics files that your applet uses. You will copy an HTML file
into your project directory. You will copy the graphics files into an Images
directory subordinate to the project directory.

Visual Cafe Pro lets you specify URLs that are relative to the applet directory.
That way you can move your directory to another location and avoid the
problems associated with hardcoded file specifications.

Now you can copy the files:

1

Copy Isle.htm from the \VisualCafePro\ Tutorial \ Applet directory to
your project directory.

Create an Images directory in your project directory.

Copy these files from the \VisualCafePro\Tutorial \Applet\Images
directory to your new Images directory:

* Map.gif
* crupt01.gif through erupt16.gif
* Photo_1.gif through Photo_8.gif
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* bungbusi.gf
* venduca.gif
* simerili.gif

* moderna.gif
* Goall.gif

* Goall2.gif

Setting the applet properties and adding the map

To start, you need to customize the properties of your form. Then you can add
a picture of the island to the form. Follow these steps:

1 In the Property List, set the Name property and the Inherit
Background, Font, and Foreground properties of Appletl as follows:

&2 Property List - Map [H[=] E3

I Map vl

Background [ white
Clazs java. applet.dy
= Dimensions
..... ES u}
..... N u}
----- “width 394
----- Height 2B6
Enabled true
= Font
----- Mame Dialog
----- Size 12
= Style
i Bold true
o |talic false
Fareground Ll black
Inherit Background |falze
Inherit Font false
Inherit Foreground | falze
isible |true
<] | ]

2 Inthe Component Palette, click the Multimedia tab, then click
= ;
ImageViewer.

ToolTips shows you which button is for the ImageViewer component.
Move the cursor over a button until a pop-up message appears.
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3 Draw a rectangle (about as large as the island map) on the applet form

by clicking and dragging the cursor.

Map - Form Designer =1 E3

You can make the Form Designer window bigger by dragging the right
side or bottom of the window. The components are positioned on the
window relative to the top and left sides, so this spacing remains the
same unless you move the components in the window.

The component you just added to the applet appeats in the Project
window.

= Project - MylslePq... [H[=] E3

e

imagetiewer]

iy Objects | [=1 Packages |

While the component is selected on the form, the Property List displays
the properties of this component.

4 In the Property List, change the Name property to imageViewerMap.
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5 Double-click the URL property.

A URL dialog appears.

URL | ]

Choose a resource:

| o

Cancel |

Click the ... button.
An Add Image Files dialog appears.

Add Image Files EHE
Look in: IaBin j gl H
Components
Keyps

Macs
Projects

Filez of type: IImageFiIes[".ipg;".gif] j Cancel |

Navigate to your Images directory, select Map.gif, and click Open.

The complete path appears in the URL dialog.

Delete the first part of the URL, so the only path remaining is
Images/Map.gif.

URL E
Image Files:
IImages.-"M ap.gif J

Cancel |

This creates the relative URL.
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9 C(lick OK.

The map appears in the Form Designer.

Map - Form Designer

VENDULA

SIMERILIA

Click a
location name
Jor mare information

10 Resize the form and the component as needed, so you can see the

1"

entire image.

When a component is selected and you move the cursor over a square
(called a handle) on the edge of a component, the cursor changes to a
two-way arrow, which means you can click and drag to resize the
component.

+—r

When a component is selected and you move the cursor over it, the
cursor changes to a four-way arrow, which means you can click and drag
the component to another location.

F 3

A

-

The Form Designer window size represents the applet size. So when you
run the applet, it will appear the same size as the window.

Click the Project or Form Designer window, then choose Save All
from the File menu.

The project and all included files are saved.
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Adding the HTML links

Visual Cate Pro lets you specify clickable areas on the map by drawing
InvisibleHTMLLink components on it. These areas are associated with a
location in an HTML file, so when the applet runs clicking the area will cause a
jump to another location. Follow these steps to add these components:

1 In the Component Palette, click Additional, then click
InvisibleHTMLLink.

2 Draw the component over the image, by clicking and dragging, so it
contains the word Bungbusi and the location on the map.

Map - Form Designer =1 E3

VENDULA

: SIMERILIA

 Bunglbusi

Click a
location name !
Jor mare information

3 In the Property List, change the Name property to
invisibleH TMLLinkB.

4 In the Property List, double-click the HTML Link URL property.
An HTML Link URL dialog appears.
Type Isle.htm#Bungbusi in the dialog, then click OK.

Add InvisibleHTMLLink components for the remaining three
locations. Use the following values for the Name and HTML Link
URL properties:

®* Venduca — invisibleHTMLLinkV and Isle htm#Venduca
® Simerilia — invisibleHTMLLinkS and Isle. htm#Simerilia
®* Moderna — invisibleH TMLLinkM and Isle. htm#M oderna
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7 Click the Project or Form Designer window, then choose Save All
from the File menu.

Now you can add the final component to the applet: an eruption animation.

Adding the volcano eruption animation

The volcano eruption is an added feature of the island map that should attract
attention. Here are the steps to create the animation:

1 Resize the form and move the components as needed so you can put
the animation above the map.

Shift-click the image and each of the links, then drag to move them.
Note that the InvisibleH TMLLink components must be on top of the
ImageViewer; otherwise, you won’t be able to click them when the
applet runs.

El 2  On the Component Palette, click Multimedia, then click Animator.

Draw a rectangle (about as large as the eruption) on the applet form
by clicking and dragging the cursor.

E

o]

SIMERILIA

Click a
location name
Jfor mare information

Modern g

4 In the Property List, set the Name property to animatorErupt.
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5 In the Property List, double-click the URL List property of the
Animator component.

A URL List dialog appears.

URL List E
Image Files | Description |

6 Click Add, select the erupt01.gif file in the File dialog, then click
Open.
A dialog, asking if you want to add the files erupt*.gif, appears.
7 Click Yes to add the sequence of files.
The files appear in the URL List dialog.

8 Tor cach file specification, double-click the row then remove the first
part of each file specification up to the Images directory.

URL List [X]

Image Files - |
Images/ewptll. gif
Images/enptl2. gif
Images/enptl3. gif

Images/ewptD4. gif Add...
Images/enptls. gif
Images/eptlE. gif Remove

Images/ewptl?. gif
Images/enptD8. gif él il
Images/enptDd. gif IS
Images/ewpt]0. gif
Images/ewptl . gif
Images/ewptl 2. gif
Images/ewpt]3.gif LI
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9 Click OK to close the dialog.

An animation picture appears in the Form Designer.

Map - Form Designer =1 E3

SIMERILIA
D=

(lick a
location name
for mare information

10 Resize the Animator component as needed. Move the component
until it’s positioned where you want it in the applet.

11 Click the Project or Form Designer window, then choose Save All
from the File menu.

You have completed the animation and the applet, so you can close the Form
Designer.
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Running the applet

The integrated Applet Viewer enables you to view and test your working
Java applets within the Visual Cafe Pro environment. Now that you've
created your applet, you can compile it and look at it while it’s running:

1 Choose Execute from the Project menu to run the applet.
The applet appears in the Applet Viewer. Visual Cate Pro compiles your
applet before displaying it.

E‘%Applel Yiewer: Map.class =1 E3
Applet

VENDULA

Bungluesi

Click a Moderna \og

location name
Jor mare information

Applet started.

When you choose Execute from the Project menu, the Visual Cafe Pro
bytecode compiler creates machine-independent bytecode instructions.
Then the Symantec Just-In-Time (JIT) compiler translates these
instructions into native machine instructions, which Visual Cafe Pro runs
for you. The machine instructions are stored temporarily in memory —
no native executable is generated.

Visual Cafe Pro’s native bytecode compiler currently builds Java
programs several times faster than the standard Sun Java compiler. The
compiler also provides improved code optimizations and shows detailed
error information in the Messages window. You can double-click an
error message in this window to go to the line in the code where the
error was generated.

The enhanced JIT compiler has superior execution speed, too. To start,
it provides immediate applet and application execution by converting
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bytecodes on-the-fly to native code as needed. When compilation is
complete, the JIT compiler seamlessly starts executing the native code.

2 Choose Quit from the Applet menu.
The Applet Viewer window closes.

3 Click the Project or Form Designer window, then choose Save All
from the File menu.

Displaying the applet in a Web browser

To test your applet, you need to view it in a Web browser. This is the only way

to try your HTML links. You will work through the following procedures to
do so:

* Adding the HTML file to the project
* Adding the applet tag to the HTML file

Executing the applet within the Web page

Adding the HTML file to the project

You can add HTML files to your project as an organizational tool, butitisn’t
required to run an applet in a Web page. Visual Cafe Pro lets you create
HTML files in the Source window, or you can import existing HTML files into
a project. You already have your HTML file, so you can just add it.
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Follow these steps to add the file to the project:
1 From the Insert menu, choose Files into Project.

The Project Files dialog appears.

Project Files HE
Look jn: IaApplet j gl IE_ =

File name: || Ok I
[[esd ]

Files of type:  [Net Files [*java;* himl] = Cancel
Filez in Project: Add |
C:\WisualCafeProtMpdpps\dppletibd ap.java
Add All |
Eemoye |

2 In the Project Files dialog, select Isle.htm in your project directory,
then click Add.

The file appears in the Files in Project list.
3 Click OK to add the file to the project.

The file appears in the Project window.

= Project - MylslePq... [H[=] E3

E|" Map

imagetiewertd ap
risibleH TMLLinkE
visibleH T MLLink:
&} invisibleHTMLLinkS
3] invisibleH T LLinkM
TeL animatorEupt

-[@] Isle

iy Objects | (E Packages
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Adding the applet tag to the HTML file
Now you’re ready to add the applet you created in Visual Cafe Pro to the
HTML file:

1 To look at Isle.htm, select it in the Project window, then choose Edit
Source from the Object menu. Or double-click Isle.htm.

The Source window appears. It contains the contents of Isle.htm. You
can edit the code in this window.

E c:\WisualCafePro\MyApps\Appletilsle_htm M= 3
Objects: I j Events/Methods: I j
k!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN"> ﬂ
<HTHL:>
<HEAD>

<META HTTP-EQUIV="Content-Type” CONTENT="text/html;CHARSET=is0-8859-1">
<TITLE>3ymantec Visual Café Tutorial - I=zland Map and Information </TITI
</HELD>
<BODY Background = "Images/GOALL.GIF"™ TEXT="#000000" BGCOLOR="#FFFFFF" LINE:

<Pr<ING IRC="Images/GOALLZ.gif" EORDER = O ALIGN="LEFT" HIPACE="O"
TIEMAP="HGOALLZ" ISMAP:</P>

<ULx>

0] o

| | | | |Line 1 |EOI 1

2 Find the following applet tag in the file:
<APPLET CODE="IsleMap.class" WIDTH=594 HEIGHT=349
ALIGN=center>

<blockquote>
<hr>
If you were using a Java-enabled browser, you would see an
island map and volcano eruption instead of this paragraph.
<hr>
</blockquote>

</APPLET>
This tag causes the applet to run within the Web page. If the browser
isn’t Java-enabled, the text displays instead. When you create an HTML
document and want to include an applet, you need to add an applet tag.

3 Change the name to Map.class.
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4 If different, change the width and height in the applet tag so it
matches the width and height in the Property List for your Map

applet.

5 Close the Source window, then save any changes.

Executing the applet within the Web page

Visual Cafe Pro lets you run the applet directly within the Web page using your
default Web browser. Follow these steps:

1 Choose Options from the Project menu.

The Project Options dialog appears.

Project | Eompilerl Directoriesl Debuggerl

— Releaze type

& Debug " Einal

— Project type
& Applet

Starter HTML:  [lsle.him =] J

" Execute applet in default HTML viewer

" Application

Starter clazs e J

Program arguments:

™ Parse jmparts

V' Clear Messages window before Build

Cancel | Help |

2 Specify Isle.htm as your Starter HTML and select Execute applet in
default HTML viewer. Then click OK.
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3 Choose Execute from the Project menu to run the applet.

Visual Cafe Pro launches your default HTML browser and displays your
Web page within it.

ki Metscape - [Symantec Yisual Café Tutorial - Island Map and Information]
File Edit “iew Go Bookmarks Option: Directory  Window Help

e e iy | & [ ¥ | 2

Bt Farward Home Fieload Iriages Cipen

Location: IEI:\VisualEafePro\M_\.\Apps\Applet\lsle.htm j

Wwhat's Mew? | Wwhat's Cool? | [restinations | NetSearchl Feople | Softwarel

Frint Find Sitop

@a|®

1. Home Page
 amek Slide
Show

Esland Map i

and Information

VEHDDR

Click o
B location name
T . . .
=\ Jor wmare u;funmn’rrm

T-mail &

Reguest Form -
1| | F
Tl | =

4 Try out your applet.
5 Exit your browser.
The browser window closes.

6 Click the Project or Form Designer window, then choose Save All
from the File menu.

If your applet works properly in the Web browser, you have completed the
applet. Continue with the next chapter to create the application.



Creating the Application
and Debugging Code

This chapter builds on the previous chapter, “Creating an Applet for the Web
Page.” It teaches you some advanced features that you may want to use
particularly if you have more programming experience and want to take
advantage of all the diverse capabilities of Visual Cafe Pro. In this chapter, you
create the custom itinerary application that your clients can use to view their

custom tour itineraries. You also try some of Visual Cafe Pro’s debugging
features.

Creating the itinerary application

To create the itinerary application, work through the following tasks:

Opening and naming the new project
Gathering the files you need

Setting the properties of Framel and adding the SlideShow
component

Adding the Button components to the frame
Adding the Amazing Adventures Travel logo
Adding the labels

Specifying component interactions

Adding custom Java code

Customizing the menu bar

Customizing the About dialog

Customizing the Quit dialog

Running the application
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Opening and naming the new project

You should create a separate project for your application and save it in its own
directory. Follow these steps:

1
2

& Visual Cafe Pro - Untitled3

File Edit Seaich Project |nsett Object ‘window Help

Close any open projects.

Choose New Project from the File menu.

The New Project dialog appears.

Select the Basic Application project template. Then click OK.

The Project and Form Designer windows appear.

Ol &[%|e] S[2 k]| vk [ca 1| glEE BEEEEE o] =] e

LA o e 2 5 T
El Standard | dEAWARE | Utity | Mulimedia [ Panels | Addtionsl | Shapes |

== = i e [ R 2 i = |

=

I
& Project - Untitled3 [_ O] =] Frame1 - Form Designer _ (O] x|
|E| Frame1 -
..
[&] AboutDizlog Background [ white
- [E)] QuitDialog Class |avva. 3wt Frame
= Dimensions
- i}
Y i}
Width 428
Height 305
Enabled true
=- Font
o Mame Dialog
i Size 12
=) Shyle
b - Bold true
. [ - bl false
ol R | Facgond ik
- Inherit B ackground true
= et Font [

|nherit Faregraund

Mame

true
MNone
Frame1

Fiesizable

true

Title

A Basic Application

Use Preferred Size

false

Visible

true

A standard application project contains a Java frame (a special kind of
window) with a predefined menu bar, an About dialog, and a Quit dialog.
Two objects already included in Framel are mainM enuBar and
openFileDialogl, which are represented by icons on the Form Designer.
(The display of these icons may be different than shown here, due to
software enhancements.) If you select an icon on the Form Designer, it is
identified in the Property List.

Double-click the Form Designer.

The Source window appears.
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Choose Find from the Search menu.

The Find dialog appears.
Find
Find what: U
| = |
Previous
™ Match case

™ Match whole words anly Cancel |

™ Reqgular expression

Type void main, then click Next.

The word is highlighted in the Java code. When you use the frame in the
application template, it’s already set to be the main application window.
If you do not use the frame in the template, you need to add the main
and show methods to your main application window.

Click the Project window, then choose Save As from the File menu.
The Save As dialog appears.

Create a new directory structure, such as
\VisualCafePro\MyApps\Application, to hold your application files.

The project and all of the files contained within it should be in the same
directory. For easier project management and to prevent filename
conflicts, you should save each project in its own directory.

Navigate to your project directory, type MylslePr.vpj in the File name
field, then click Save.

The new name appears in the titlebar of the Project window, and all the
files in the project are saved to this directory.
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Gathering the files you need

To use relative URLSs, you will store your graphics files in a directory
subordinate to the project directory as follows:
1 Copy the \VisualCafePro\ Tutotial \ Application\Images directory.
2 Paste the directory in your project directory.

The Images directory contains the following files:

* Logo.gif

* Photo_1.gif through Photo_8.gif

* Tour.dat

Setting the properties of Framel and adding the SlideShow

component

The user interface of your application can be put together quickly with the
SlideShow component, which associates a picture with text and allows you to

navigate through sequential photos with button clicks.

Follow these steps to add the SlideShow component to the frame and set its

properties:
1 Set the Framel properties, including Name, Title, and Inherit

Background, Font, and Foreground, as follows:

& Property List - FrameM ain

I E Framet ain vl

Background [ white

Clazs java. awt Frame
- Dimenzions [0, 0, 334, 300]

Enabled true
[ Font [Dialog, 12, Bold]

Fareground Ll black

Inherit Background |falze

Inherit Font false

Inherit Foreground | falze

Lapout Mone

M ame Frametd ain

true

Tile | Amazing Adventures Travel - Custom Itinerary Application

Use Prefened Size | false

isible |true
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2 Click the Source window, then choose Replace from the Search menu.

The Replace dialog appears.

Find what:

| =]

Fieplace with:

™ Match case ¥ Confim changes

™ Match whole word anly I | Search oriyin selection

™ Reqgular expression

Type Framel in the Find what field and FrameMain in the Replace
with field, then click Replace.

Part of the code in the template is custom code that would not be
automatically created by Visual Cafe Pro, such as in the Form Designer.
Visual Cafe Pro only updates class names in code that it generates
automatically. So you need to make sure the name change you made in
the Property List takes effect. The fastest way is just to replace all
occurrences of Framel.

A Confirm Replacement dialog appears.

@ Replace this ocourence?

Mo | Cancel | [+ Confim

Click Yes.

The name is replaced.

Close the Source window.

On the Component Palette, click Multimedia, then click SlideShow.

ToolTips shows you which button is for the SlideShow component.
Move the cursor over a button until a2 pop-up message appears.
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7 Draw a rectangle (about as large as the photos) on the form by
clicking and dragging the cursor.

FrameMain - Form Designer

While the component is selected on the form, the Property List displays
the properties of this component. The Project window shows the new

compon ent.

[H Project - MylslePr._.. [H[=] E3

Framebd ain;
enFileDialogl
maintdenub ar
lideShowl
=] AboutDialog
-[=] QuitDialog

iy Objects | [=1 Packages |

8 In the Property List, change the Name property to slideShowltinerary.

9 Resize the slide show until it’s approximately 340 pixels in width by
235 pixels in height by typing in the Property List.
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10 In the Property List, double-click the URL List property of the
SlideShow component.

The URL List dialog appears. Normally, you would enter photo names
and text descriptions here, but for your application you will read in a file
that sets these properties at runtime.

Image Files | Description | | e DKl

11 Click Cancel.

12 Click the Project or Form Designer window, then choose Save All
from the File menu.

Adding the Button components to the frame

The slide show is controlled by button clicks. You need to add the buttons and
set their properties:

1 Resize the Form Designer window so two buttons can fit under the
SlideShow component. Move the component until it’s positioned
where you want it in the frame.

You can make the Form Designer window bigger by dragging the right
side or bottom of the window. The components are positioned on the
window relative to the top and left sides, so this spacing remains the
same unless you move the components in the window.

The Form Designer window size represents the Java frame container
size. The frame size is the same as the window size. So when you run the
application, it will appear the same size as the window.

EI 2  While the Form Designer is the active window, click the Standard tab
on the Component Palette, then click Button.
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3 Draw a button under the SlideShow component by clicking and
dragging.

FrameMain - Form Designer

4 'To copy and paste this button, choose Copy from the Edit menu,
then choose Paste from the Edit menu. You can also choose these
menu items from the pop-up menu that appears when you right-click.

A second button appears.
5 Position the buttons under the SlideShow component as follows:
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6 Select the button on the left, then set the following properties:

®* Name — buttonPrevious
® TLabel — Previous

* Visible — false (because you don’t want the button to appear until
you load a data file)

7 Seclect the button on the right, then set the following properties:

®* Name — buttonNext
® Label — Next
* Visible — false

The buttons now both have names.

8 Click the Project or Form Designer window, then choose Save All

from the File menu.

Adding the Amazing Adventures Travel logo

Now you can add your company logo:

1

In the Property List, resize FrameMain to 600 pixels in width and 530
pixels in height.

The form size changes.

Shift-click the SlideShow component, then each button, to select
them.

Drag the components to the bottom right corner of the form.
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4 In the Component Palette, click Multimedia, then click Image Viewer.
5

On the form, draw a rectangle above the SlideShow component (a
little less wide than the slide show) by clicking and dragging the

cursor.
In the Property List, change the Name property to imageViewerLogo.
Double-click the URL property.
A URL dialog appears
8 C(lick the ... button.
An Add Image Files dialog appears.
Navigate to your Images directory, select Logo.gif, and click Open.

10 To create a relative URL, delete the file specification so it displays just
Images/Logo.gif. Then click OK in the URL dialog.

The logo appears in the Form Designer.

FrameMain - Form Designer =1 E3

11 Click the Project or Form Designer window, then choose Save All
from the File menu.

Adding the labels

Your application displays text, so you need to add text fields to the form.
Follow these steps:

1 In the Component Palette, click the Additional tab, then click
WrappinglLabel.
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2 Draw a text box to the left of the SlideShow component.

The dimensions can be about 240 pixels in width by 225 pixels in height.

MHext

3 In the Property List, set the following properties:
* Name — wrappinglLabelDesc
* Font Size — 14
* Font Style — Bold false

To the left of the picture, draw two W rappingl.abel components and
underneath a Label component (in the Standard tab of the
Component Palette) as shown.

pr|

FrameMain - Form Designer =1 E3
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g| 8

In the Property List, set the properties of the top Wrappingl.abel
component as follows:

* Name — wrappingLabelTop

* Font Size — 16

¢ Text Alignment — ALIGN_CENTERED
* Text — Custom Itinerary for

To display the properties in the Property List for this component, either
select the component on the form or choose it from the drop-down list
in the Property List window.

Set the properties of the middle Wrappingl.abel component as
follows:

* Name — wrappingl.abelPeople

* FontSize — 24

* Text Alignment — ALIGN_CENTERED

Set the properties of the Label component as follows:
* Name — labelDay

* Font Size — 16

* Font Style — Italic true

¢ Alignment — CENTER

Also, delete the text in the Text field.

Now draw a Wrappingl.abel component over the top two labels as
follows:

FrameMain - Form Designer =1 E3

Custom Itinerary for
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9 Set the properties of the new Wrappingl.abel component as follows:
* Name — wrappinglLabelStart

* Font Size — 16

* Text — To start, choose Open from the File menu and open your

data file. Your .dat file and the graphics files must be in the same
directory.

10 Select wrappinglabelStart on the Form Designer, then choose Bring
to front from the Layout menu.

This ensures that the label is on top of the other labels. Because the
labels overlap, an easy way to select wrappingl.abelStart is to choose it
from the Property List drop-down menu.

11 Click the Project or Form Designer window, then choose Save All
from the File menu.

Specifying component interactions

One of the most powerful features of Visual Cafe Pro is the ability to create
interactions between components. The Interaction Wizard lets you graphically
build relationships between components, or between a component and itself
(for example, double-clicking an item in a list box could remove the item from
the list box and add it to another list box). These relationships specify the
actions to take when an event is triggered on a component. For example, in a
slide show, a button click could cause the next photo to be displayed. Visual
Cafe Pro automatically generates the necessary Java code for the specified
relationship.

In the following sections you specify interactions between components on the
application form:

*  Setting up the Previous button to display the previous image
*  Setting up the Next button to display the next image

* Disabling the Next button at the end of the slide show

* Disabling the Previous button at the start of the slide show

Making the slide show descriptions appear in the wrapping labels



514 Creating the Application and Debugging Code

Setting up the Previous button to display the previous image

Here you set up an interaction between the Previous button and the SlideShow

component so that a button click causes the previous image to be displayed.
Follow these steps:

:l 1 Click the Interaction Wizard button, then click the Previous button
il and drag a line to the SlideShow component.

The Interaction Wizard appears.

Interaction Wizard

Start an interaction for *'buttonPrevious™...

GotFocus
LostFocus

Select the item pou want to interact with...
slideShowltinerary j

Chooze what you want to happen...

. Disable the SlideShow
Disable the SlideShow on conditior...

II t Enable the SlideShow
ﬂ Enable the SlideShow on condition...

III]I}B&IIS Ill Go to the SlideShow's next image

Go to the SlideShow's previous image

what Hide the: SlideS how =l

< Back Eirrsky | Cancel I Help |
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2 Select the following items:

Start an interaction for “buttonPrevious™: Clicked
Select the item you want to interact with: slideShowltinerary
Choose what you want to happen: Go to the SlideShow’s previous image

3 Click Finish.

Setting up the Next button to display the next image
Here you set up an interaction between the Next button and the SlideShow
component so a button click causes the next image to be displayed:

:I 1 Click the Interaction Wizard button, then click the Next button and
hi drag a line to the SlideShow component.

The Interaction Wizard appears.
2 Select the following items:

Statt an interaction for “buttonNext”: Clicked
Select the item you want to interact with: slideShowltinerary
Choose what you want to happen: Go to the SlideShow’s next image

3 Click Finish.

Disabling the Next button at the end of the slide show

When you’re at the last picture, you want to indicate that by disabling the Next
button:

—«| 1 Click the Interaction Wizard button, then click the SlideShow
component and drag a line to the Next button.

The Interaction Wizard appears.
2 Select the following items:

Start an interaction for “slideShowltinerary”: SlideChanged
Select the item you want to interact with: buttonNext
Choose what you want to happen: Disable the Button on condition
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3 Click Next.
The second page of the dialog appears.

Interaction Wizard

Dizable the Button on condition uging information from...

iE shﬁum IE Frametd ain j

5=
.@' By...
2 hnﬁpen Iz enabled? j
|5 Frame resizeable?

/7 |5 not enabled?

|z not showing?

|5 not walid?
|z not vigible? LI

& boolean constant or ah expression

5 waniable

| I

< Back I Eirrsky | Cancel | Help |

4 While Another item is selected, choose slideShowltinerary and select
Is at the last image?

5 Click Finish.

Disabling the Previous button at the start of the slide show

When you're at the first picture, you want to indicate that by disabling the
Previous button:

= | 1 Click the Interacion Wizard button, then click the SlideShow
— . .
component and drag a line to the Previous button.

The Interaction Wizard appears.
2 Select the following items:

Start an interaction for “slideShowltinerary”: SlideChanged
Select the item you want to interact with: buttonPrevious
Choose what you want to happen: Disable the Button on condition

3 Click Next.
The second page of the dialog appears.

4 While Another item is selected, choose slideShowltinerary and select
Is at the first image?
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5 Click Finish.

6 Click the Project or Form Designer window, then choose Save All
from the File menu.

Making the slide show descriptions appear in the wrapping labels

You need to set up an interaction between the SlideShow component and a
WrappinglLabel component so the descriptive text associated with a picture
displays in the text field. Follow these steps:

EI 1 Click the Interaction \X/i.zard button, the.n click the SlideShow
component and drag a line to the wrappingl.abelDesc component.
The Interaction Wizard appears.
2 Select the following items:
Start an interaction for “slideShowltinerary’: SlideChanged

Select the item you want to interact with: wrappinglabelDesc
Choose what you want to happen: Set the text for Wrappingl.abel

3 Click Next.
The second page of the dialog appears.

4 While Another item is selected, choose slideShowltinerary and select
Get current description.

5 Click Finish.

Now it’s time to add the custom code. Y ou can close the Form Designer if you
want.

Adding custom Java code

Java code, including complete applets and applications, that was not created in
Visual Cafe Pro can be added to a project. If the code contains visual aspects,
Visual Cafe Pro translates the code into a visual representation that’s displayed
in the Form Designer.

Visual Cafe Pro has many features to assist you with creating new Java code.
For example, when you want to handle an event for a component, the Source
Editor helps you. Select the component in the Object pull-down menu, then
select the event you want to handle from the Events/Methods pull-down
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menu. Visual Cafe Pro creates a method for that event and puts a call to that
method in the event handler. You fill in the body of the method.

Now that Visual Cafe Pro has created the main portion of your program, you
can add custom code to read data from a file at runtime and to increment the
Day label.

The data file is a text file in the following format:

client_names
number_of_pictures
picturel _filename
picturel _text
picture2_filename
picture2_text

Here’s an easy way to add the code:

1 Choose Open from the File menu, and open
\VisualCafePro\ Tutorial \Application\AmazingTout.java.

The file appears in the Source window. The custom code is identified by
comments directly in the code.

2 In the Project window, click FrameMain, then right-click. Choose
Edit Source from the pop-up menu.

FrameMain.java appears in another Source window.
3 Copy the custom code from AmazingTour.java into your application.

You can search for the words “Custom code” in AmazingTour.java to
find the code quickly. There are several places where you need to copy
the code. Make sure you insert the code into your application directly
under the same line that appeared above it in AmazingTour.java.

4 When you're finished, click the FrameMain Source window and
choose Save All. Then close the Source windows.
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Customizing the menu bar

Follow these steps to modify the default menu bar in the application:

1 In the Project window, display the contents of mainMenuBar
(subordinate to FrameMain) by clicking the +.

[H Project - MylslePr._.. [H[=] E3

. E-E mainMenuBar =
: -5 File

-5 Edit

-] Help

E] AboutDialog
-[=] QuitDialog
4 |

iy Objects I [=1 Packages I

Select Edit, then choose Delete from the Edit menu.

Display the contents of the File menu, then delete New, Save, and
SaveAs.

4 Click the Project window, then choose Save All from the File menu.

Customizing the About dialog

The About dialog is included as part of the application template. Follow these
steps to modify it:

1 Double-click the AboutDialog object in your project.
The Form Designer appears.
2 Change the properties as follows:
* Inherit Font — false
* Inherit Background — false
* Inherit Foreground — false
Click the Label component in the Form Designer.

In the Property List, click the Text property value to highlight it, then
type Amazing Adventures Travel - Custom Itinerary Application.

The text appears in the Label.
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5 Click the Form Designer, then resize and reposition the label, button,
and form as needed.

AboutDialog - Form Designer [ |O] x|

Amazing Adventures Travel - Custom Itinerary Application

0K |

6 Click the Project or Form Designer window, then choose Save All
from the File menu.

The About dialog is saved in the project.
7 Close the Form Designer for the About dialog.

Customizing the Quit dialog

The Quit dialog is also included as part of the application project template.
Follow these steps to modify it:

1 Double-click the QuitDialog object in your project.
The Form Designer appears.
2 Change the properties as follows:
® Inherit Font — false
* Inherit Background — false
* Inherit Foreground — false

3 Click the Project or Form Designer window, then choose Save All
from the File menu.

The Quit dialog is saved in the project.
4 Close the Form Designer for the Quit dialog.

Running the application

Now that you've specified the user interface and other aspects of your
application, you're ready to run it. This is how you run the application from
within Visual Cafe Pro:

1 Choose Messages from the Window menu.

The Messages window appears.



Creating the itinerary application 5-21

2 Choose Execute from the Project menu to run the application.

Visual Cafe Pro compiles your application before displaying it. Any
warning or error messages appear in the Message window.

E Meszages =1 E3

3 -make -cdb MylslePr.cdb -g -classpath C:\YisualCafe\Mypdppsiap

4 | | | i

You can double-click an error message in this window to go to the line in
the code where the error was generated.

Println statements and certain errors are displayed in the java window.

Symantec Java! ByteCode Compiler Version 2.00b16
Copyright (C) 1996 Symantec Corporation

Then the application appears.

E‘%Amazing Adventures Travel - Custom ltinerary Application
File Help

To start. choose Open from
the File menu and open
your data file. Your .dat file
and the graphics files must
be in the same directory.
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3 Open the data file in the Images directory, and click the Next and
Previous buttons to verify your application works as planned.

E‘%Amazing Adventures Travel - Custom ltinerary Application
File Help

Custom Itinerary for

Stan and Flora
Robinson

Ly 7

Arrive this morning in Isle de Café, at
the tropical paradise of Bungbusi.
Check in to your deluxe seaside
resort, then enjoy the pristine
heaches just outside your door. The
sand beaches and warm waters are
ideal for relaxing and for all kinds of
water sparts, including surfing, water
skiing, and snorkeling, included at no
additional charge. The resort
gardens, three poals, gourmet
restaurants, open-air lounge with local
entertainers, and swim-up bar are at
wour disposal. Now is the time to let
the stresses fade atlsle de Café.

Previous MHext

Close the application.

Click the Project or Form Designer window, then choose Save All
from the File menu.

6 Make adjustments in the Form Designer as needed. Then execute the
application again. Repeat until the application looks the way you want
it.

If the application works as planned, you have completed it.
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Looking at the application in the Hierarchy Editor and the
Class Browser

Visual Cafe Pro has special object programming tools that make it easy to
understand and manage Java classes. Let’s take a look at your application in the
Hierarchy Editor and Class Browser:

1 While your application project is open, choose Hierarchy Editor from
the Window menu.

Your application appears in the Hierarchy Editor.

% Hierarchy Editor [_ O] =]
| AFsa et Ml etagae Iiava.awt.Frame |FrameMain

| java. awt. Container

| |ava. awt \Window AboutDialog
java.awt. Dialog <
QuitDialog

| AF33 st S Sl s 7| |ava. awt. Component

| java.lang. Object

K| _ |

The Hierarchy Editor lets you visually learn, modify, and extend the Java
class hierarchy for an applet or application. Drag and drop to instantly
edit the hierarchy structure — both the visual model and the source

code.
2 Right-click, then choose View Imports from the pop-up menu.

The Hierarchy Editor now shows all Java classes.
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3 In the Hierarchy Editor, double-click a class to navigate to a class
definition in the Class Browser. Then select a member in the upper

right list.

The Class Browser shows the code associated with the class member.
% Class Browser =1 E3
Classes Members of Framehd ain

f’ B Methods f’
About_Action
Exit_Action
Frametd ain
frrametd ain
LI Open_Action LI
public FrameMain(3tring title) j
this():
setTitle(title); hd
4 I I »
Frametd ain. Frametdain [Framekd | | | | |Line1 |EOI‘I

The three-pane Class Browser lists the classes in your project, and shows
each method and data member contained within a class, all of which are
individually editable to make you more productive. For example, when
you click a class in the upper left pane, its methods and data members
appear in the upper right pane. When you click a method, that
implementation of the method is extracted from the source file and
displayed in the lower pane where you can edit it. This makes it easy to
navigate to the areas you want to edit — no matter how large the source
file — and reduces the possibility of accidentally editing code outside the
scope of the selected object.

Color syntax highlighting makes your Java source more readable. The
Class Browser also has an incremental search feature when you have a
class selected: as you type the name of a class, the list of matching objects
is refined until you have automatically selected the class you want.

Visual Cafe Pro reads your Java source code so the Hierarchy Editor and
Class Browser always contain the most up-to-date information.

4 Close the Class Browser and Hierarchy Editor.

Debugging

The integrated graphical debugger provides source-level debugging and lets
you browse data and manipulate calls and threads. You can modify a variable
value and continue debugging without reloading. The Source window shows
ValueTips so you can quickly view variable values.
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While debugging, you can either step through each line of source code one at a
time (including sublevel method code, when available) or step over the
execution of method calls, which causes the debugger to execute all method
code then pause on the line following the method call.

The debugger includes the following windows:

* Breakpoints window — The breakpoints for the entire project appear
in this window. You can set simple breakpoints that stop execution at
a certain line or method, or conditional breakpoints based on an
expression.

* Threads window — Y ou can pause individual threads, which causes
their execution to cease temporarily while all other threads continue to
execute, and resume them. This helps you check for and resolve
thread synchronization errors, where more than one thread is in
contention for the execution of a method. Double-clicking a thread in
this window updates the Calls window, so it reflects the chain of
execution for the thread, and the Variables window, so it reflects the
scoping level of the thread.

*  Calls window — All code modules and methods executed by a thread,
and the current execution point and return points for each called
method, appear in this window. This view is useful for following the
flow of the code, for example.

*  Watch window — In this window, you can specify variables and
expressions that you want to watch continuously while debugging
your program. The values update when you pause execution or step
through code. You can also examine the contents of a class member
or variable. To watch all the variables accessible to a method, drag the
variable from the Variables window to the Watch window. To modify
a variable value, you can enter it and continue debugging without
having to stop and restart the debug session.

*  Variables window — This window incorporates a tree view so you
can collapse and expand the various scopes and to make it easy to
examine the values of both simple and complex data types, such as
arrays. It automatically displays the local and global variables and
objects that are local to the current method, and the vatiables that are
members of the current object. You can edit variable values.

All of the debugger windows have resizable columns so you can create the
most readable display.
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Visual Cafe Pro also lets you debug an applet or application that’s running on
another computer. One computer displays the debug windows while an applet
or application runs on a remote computer.

Working with the debugger is divided into the following sections:

* Debugging the About dialog
* Debugging the Day label

Debugging the About dialog
Although the About dialog works propetly in your application, here you can
explore some debugging features by working with the About dialog code:

1 While your application project is open, choose Run in Debugger from
the Project menu.

Visual Cafe Pro compiles your program and displays several debugger
windows. Then it displays your application.

% Visual Cafe Pro - MylslePr_vpj - [Execuling]

e Edit Seach Debug Inset Souce Window Help

Dlﬁﬂ;lm ‘Xg Ilad él '1? |¥?I ‘ ‘Workspace: |Debug 'I

WEENEEEEE
— File Help
+—| Standard | dhAWARE

Build Successiul To start, choose Open from

the File menu and open your
data file. your .dat file and

-] Framebdain; graphics files must be in the

B &boiificion .
=) Quibisk same directory.

G Dbijects | I3 Packages
B c:WisualCafePro\MyAg
Obiects: | =] FrameMain

IS
This simple &
contains &all
main window ¢

"

E
import Java.awt. ts -EIE
import symantec. i it

Condition

/¢ Custom code: ¥ e | ‘
import Jjava.io.*;

itk lic ~lase Fram
K|
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When your application is running, “Executing” appears in the titlebar of the
Visual Cafe Pro main window. Realize that when your application is paused, it
cannot redraw its window, so the application may pick up the contents of other
windows when you move them.

The Variables, Calls, and Breakpoints windows should be displayed. If
they aren’t, open the window by choosing it in the Window menu.

If it’s not already open, open FrameMain in the Source window.
Choose Watch from the Window menu.

The Watch window appears.

4 Choose Threads from the Window menu.
The Threads window appears.

Al
AT -Callback-win32 [java.lang. Thi| running

Screen Updater [zun.awt. ScreenUpr cond. waiting
Image Fetcher 0 [zun.awt.image.lma| cond. waiting
Image Fetcher 1 [sun.awt.image.lma| cond. waiting
Image Fetcher 2 [sun.awt.image. lma| cond. waiting
Image Fetcher 3 [sun.awt.image. lma| cond. waiting

The window shows the standard Java AW'T threads. There are no other
threads used in this application.

5 From the Events/Methods drop-down menu in the Soutce window,
choose About_Action.

The About_Action method appears in the window.
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6

10

1"

12

13

Click the line with the show method, right-click, then choose Set
Breakpoint from the pop-up menu.

A red triangle indicates a breakpoint was set.

E c:\W¥isualCafePro\MyApps\Application\FrameMain_java

Objects: ITD Frametd ain j Events/Methods: | About_Action j
{ =
huttonMext.enakle() ;
i
/4 ...down to here.
' [ |
void About Aetion(Event event) |
SA{CONNECTION
/4 hction from ibout Create and show as modal
- (new AboutDialog(this, true)).show():
N
N -
<I I 3
| | | | |Line12? |E0I 2

Notice the breakpoint in the Breakpoints window.
In your application, choose About from the Help menu.

The breakpoint is triggered. The Source window appears and the

breakpoint line is highlighted. Variables and their values at this point in
the code appear in the Vatiables window; the current call stack appears in

the Calls window. The titlebar of the Visual Cafe Pro main window
displays [Paused].

Choose Step Into from the Debug menu.

Another Source window appears. It displays AboutDialog.java.
Choose Step Over from the Debug menu.

The next call is highlighted.

Choose Step Out from the Debug menu.

You return to the FrameMain.java file.

Right-click over the breakpoint, then choose Clear Breakpoint from
the pop-up menu.

The breakpoint is removed.

Choose Continue from the Debug menu.

Now you can click OK in the About dialog.

Choose Open from the File menu and open Tour.dat.

The data appears in the application.
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14
15

16

17

18

19

Click the FrameMain Source window.

Choose handleEvent from the Events/Methods menu.
The event handler appears.

Set a breakpoint at handleEvent.

The breakpoint appears on the next line of code.

Click the application window.

The breakpoint is triggered.

The Visual Cafe Pro debugger lets you dynamically set breakpoints while
the program runs for more powerful debugging. The event handler is a
useful place to put a breakpoint, because in the Breakpoints window you
can disable the breakpoint by deselecting the checkbox and enable it with
a condition for particular types of events.

Clear the breakpoint, then choose Continue from the Debug menu.
The application appears.
Close the Source window displaying AboutDialog.java.

Debugging the Day label

Continue exploring the debugger with these steps that examine the Day label

code:

1 If notalready open, open the Source window for your FrameMain
application.

2 Choose buttonNext_Clicked from the Events/Methods menu.
Under buttonNext_Clicked, you’ll see this method:
slideShowltinerary.nextImage. The method is activated when the Next
button is clicked.

3 Set a breakpoint at nextlmage.

A breakpoint symbol appears next to the code.

4 Inyour application window, click the Next button.

The breakpoint is activated. The Source window appears with the
breakpoint highlighted.

5 Look at the variables in the Vatiables window.

The Variables window shows the variables and their values at this
breakpoint.
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10

1

12
13

14

15

16

17

Click the + next to this.
The variables associated with the object appear.
Type this.day.

The dayCount variable row is highlighted. This is the variable that sets
the Day value.

Drag dayCount from the Variables window to the Watch window.

dayCount appears in the Watch window. Y ou can drag the variables you
want to watch closely, no matter where they are in the Variables window
hierarchy, to this window.

Drag fileName (under dayCount) to the Watch window.
fileName appears in the Watch window.

Scroll down in the Variables window, and click the + next to
wrappinglabelDesc.

The variables associated with this component appear. You can resize
columns for a more readable display.

Drag one of the wrappinglabelDesc variables, text, to the Watch
window.

The variable appears in the Watch window.
Choose Continue in the Debug menu.
Click the Next button in the application.

The breakpoint is triggered. The Day and text values change in the
Watch window.

In the Calls window, double-click handleEvent.

The portion of code called in the event handler appears in the Source
window.

In the Calls window, double-click buttonNext_Clicked.
You return to the original breakpoint position.

Deselect the checkbox in the Breakpoints window to deactivate the
breakpoint.

In the Watch window, click the dayCount row, then click the Value
field and change the value to 2 less than its current value.
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18

19
20

21

22

23
24
25

In the Source window, highlight the dayCount variable under the
breakpoint, and leave the cursor there.

ValueTips show that the value has changed.

Choose Continue from the Debug menu.

Press the Previous and Next buttons.

Notice what has happened to the Day value in your application.

In the Breakpoints window, select the breakpoint checkbox, then click
the Next button in the application.

The breakpoint is triggered.

In the Breakpoints window, enter the following in the Condition field:
dayCount == (

Now the breakpoint triggers only when dayCount is zero.

Choose Continue from the Debug menu.

Press the Previous and Next buttons until the breakpoint is triggered.
Clear the breakpoint, then choose Stop from the Debug menu.

The debugger windows close.

Continue with the next chapter to learn about some database features of
Visual Cafe Pro.
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Creating Applets with
Database Functionality

This chapter showcases some Visual Cafe Pro database features. Here you
create an online reservation applet that your clients can use to sign up for your
package tours and an administrative applet to keep track of your reservations.
To create your applets, you work through the following tasks:

* Creating the online reservations applet
* Displaying the applet in a Web browser

* Creating an administrative applet for online resetrvations

Before beginning, make sure you've installed the dbANYWHERE W orkgroup
Server and the Sybase SQL Anywhere database engine as described in the
Chapter 2 section, “Installing the software needed for the tour.”

Creating the online reservations applet

Now you’ll create an online reservations applet that your clients can use to
browse through package tours and reserve a spot in a tour. The packages are
kept in one database table, and the reservations in another table. You work
through these tasks to create the applet:

* Using the dbAWARE Project Wizard to create a new project
* Assigning applet properties

* Gathering the files you need

* Designing the package portion of the applet

* Designing the reservation portion of the applet

* Looking at dbNAVIGATOR

* Setting initial record positions

* Making fields uneditable

* Adding component interactions

* Running the applet
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Using the dbAWARE Project Wizard to create a new project

Visual Cafe Pro has several wizards that help you set up applets and
applications that are database-aware. The wizards step you through
complicated processes and let you create new forms over existing database
tables, add database connectivity to existing forms, define master/detail joins,
and create tables and forms from predefined templates.

Here’s how you use the Project Wizard when you’re creating a new project for
an applet:

1 Make sure the dbANYWHERE server is running,

0 If you don’t set up your system as described in the Chapter 2 section,
“Installing the software needed for the tour,” you may not be able to
successfully complete this chapter.

2 C(lose any open projects.
3 Choose New Project from the File menu.

A New Project dialog appears.

Froject Templates:

% B B B 2
dbdiwARE dbéwWARE  Emply Project Basic
Template  Project Wizard Application

B azic Java applet with blank form.

ak. I Cancel Set Default | E:_E'
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4 Select the dbAWARE Project Wizard, then click OK.
The dbAW ARE Project Wizard appears.

dbAWARE Project Wizard
Create a db&WARE Project

Thiz wizard helps you create a db&WARE project. [t will assist you
in performing the following steps:

* Chooge a project type.

* Choose the dbaNTYWHERE server. data source, database
table, and database columns to access.

* Chooge the components and labels to dizsplay on the form.

* Chooge which database operations to have automatically
added to the form.

Upon completion of the wizard, you will have the opportunity to
review your selections and alter them if necessary.

d MNYWHERE

SYMANTEC,

Cancel Help

5 Click Next.

The Choose Project Type page appears. Here is where you choose
whether you want to create an applet or application.

6 Select Applet, then click Next.
The Choose a dbANYWHERE Server page appears.

7 Type the name of your dbANYWHERE server in the
dbANYWHERE Server Name field.

The screens in this tour will show the server name dba.

8 If dbANYWHERE is local, you can use the default host name and
port number. If dbANYWHERE is on a remote computer, type the
host name or IP address, and the port number, in the fields.

When dbANYWHERE is running, it displays its IP address and pozrt
number in its window; the default port number is 8889. (Remember, if
you use localhost for the host name, you must change the URL property
for the Session object before deploying an applet or application.)
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9

Click Next.
The Choose a Data Source page appears.

0 If a “Server not responding” message appears, dbANYWHERE is not

running. You need to start it.

10

1

For the Data Source Name, choose Tutorial from the pull-down
menu. Then click Next.

You’re asked for a user name and password.

Type dba for the user name then type sql for the password, and click
OK.

The Choose a Database Table page appears.

0 If the system seems to be waiting for a response, you could have a problem
with low resources. The dbANYWHERE Workgroup Server has issued a
request for the Sybase SQL Anywhere engine to start, but the engine has not
fully started. Eventually, you receive a “T'imed out” message. If you do, press
the Next button again to retry the connection to the database engine, because
the extra time may have allowed the database engine to start. Otherwise, you
probably need to increase your system resources.

12

13

14

Select DBA.packages. Then click Next.
This lets you build a form that contains information on travel packages.
The Choose Database Columns page appears.

Make sure the checkboxes for all columns are selected. Then click
Next.

The Choose Components and Labels page appears.

In the Label fields, replace each underscore (_) with a blank space.
Clear the label field for the Image column, because you don’t need an
identifier for the image. Then click Next.

The Choose Database Operations page appears.
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15

Select Move to the next record and Move to the previous record. For
the latter, change the Text field from Prev to Previous. Then click
Next.

A summary of your selections appears.
Review Your Selections

‘r'ou have made the following selections:
Froject Type: Applet

dbaNYWHERE Server: dba

Data Source: Tutorial

Databaze Table: DBA packages

D atabase Columns: Package |D, Package_Mame, Start_Date,
Mumber_of_Days, Price_Per_Perzon, Image, Description

[atabaze Operations: Mext, Previous

To change a selection, go back to the wizard page where you
made that selection.

< Back Cancel Help
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16 Look over your selections. If they look correct, click Finish. If you
need to change something, click Back and change what you need to,
then return to this window and click Finish.

The new project appears. It contains an automatically generated form
with the fields you selected. (You have to click the ImageViewer
component to see where it is.)

= Visual Cafe Pro - Untitled2
File Edit Search Project Insett Layout Object Window Help

BlEEEEE] >

D= # == §|‘?|kﬂ|‘ Workspace: |Edit |

155 2= i 1 e e e 2 Nl [ = s

EI Standard | Utility | Multimedia | db&'ARE | Panels | Additional | Shapes

= U SOl =] Applet1 - Form Designer =1 E3
I | vl
Package 1D I mage
[ white |=]
Package Hame | - Binding
i. ReMiew Mame | DBA_pacl
Start Date I ... Projection Mamg Image
Mumber of Days l— Clazs symantec. i
= Dimensions
. 156
Price Per Person | 158
100
100
true
Dialog
12
- true
Description faloe
Fareground Ll black
Inherit Background |true b
Inherit Font true
Mext Prevlous Inherit Foreground | true
N — ml

17  Click the Project window, then choose Save As from the File menu.
The Save As dialog appears.

18 Create a new directory structure, such as
\VisualCafePro\MyApps\AppletDb, to hold your applet files.

The project and all of the files contained within it should be in the same
directory. For easier project management and to prevent filename
conflicts, you should save each project in its own directory.

19 Navigate to the new project directory, type Reserve.vpj in the File
name field, then click Save.

The new name appears in the titlebar of the Project window.



Creating the online reservations applet 6-7

Assigning applet properties

Follow these steps:
1 Select Appletl in the Project window.
The properties of Applet] appear in the Property List.
In the Property List, set the Name property to Reserve.
Set the Inherit Background, Font, and Foreground properties to false.

Click the Project or Form Designer window, then choose Save All
from the File menu.

The project and all included files are saved.

Gathering the files you need

To construct your Web page, you need an HTML file that your applet will run
within and the graphics files that your applet uses. You will copy an HTML file
into your project directory. Y ou will copy the graphics files into an Images
directory subordinate to the project directory.

Copy the files as follows:

1 Copy Reservehtm from the \VisualCafePro\Tutorial \Applet
directory to your project directory.

Create a new Images directory in your project folder.

Copy the following files from the
\VisualCafePro\Tutorial \Applet\Images ditectory to the Images
directory in your project directory:

* reservgif

* register.gif
* goall.gif

* goall2.gif

Now you’re ready to design your form.
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Designing the package portion of the applet

Visual Cafe Pro has put the fields you need on the form, so now you can
arrange them:

1 Lookat the objects in the Project window (click the + next to Reserve
and keyPressManagerPanell).

] Project - Reserve_ vpj M= 3

{71 DBA_packages

= keyPresst anagerPanell
..... 4b| Package_|IDLabel

----- asb| Package_Mamelabel
..... bl Start_Datel abel

----- dsb| Mumnber_of_D aysLabel
----- asb| Price_Per_PersonLabel
----- b DescriptionLabel
&= Package_|D

&= Package_Mame

&= Start_Date

&= Number_of_Days
&= Price_Per_Person
Image

{I_‘E] Description

-2 DBA_packages_nest
-2 DBA_packages_prev

iy Objects I [ Packages I

The first three objects under the Reserve applet are invisible objects:

dba — A Session object indicating the dbANYWHERE server
youre connected to through sockets.

Tutorial — A Connectionlnfo object showing the database you’re
connected to. It includes a default user name and password, which
you can remove. This object supports multiple queries and updates
simultaneously, reducing database resource requirements.

DBA_packages — A RelationView object showing a view of the
Tutorial database (DBA.packages); a name in the Project window
can’t contain a period (.), so an underscore () is used instead. This
object provides a simple, property-driven solution for defining
database queries and updates, and for manipulating data and result
sets.

Their icons appear in the upper left corner of the Form Designer

window.
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The keyPressManagerPanell object contains all of the visual
components that have been added to the form. This panel lets users use
the Tab and Backtab keys to move between fields. The Label
components are the labels for the fields of the same name (minus the
word Label). The Next and Previous buttons are also in the list. New
visual components go into the same container.

The fields themselves are database-aware (dbAW ARE). dbAW ARE
components provide database connectivity and facilitate the binding to
database columns. Java forms built with these components communicate
with databases through the dbANYWHERE API. This provides
advantages such as three-tier data buffering, optimistic concutrency,
reduced network traffic, less complicated client software, scrolling
cursors, and mote.

Because the applet uses a layout manager of CardLayout, you need to
add new components to the KeyPressManagerPanel, not to the applet
itself. The tab order of the fields is determined by the order of the
components in the list.

Click the Form Designer window. In the Layout menu, deselect
Invisibles so you can lay out your applets without the invisible object
icons getting in the way.

The icons in the upper corner, corresponding to the dba
dbANYWHERE setver, Tutorial database, and DB A_packages table
objects, disappeat.

Move the items on the form so they appear like this:

Reserve - Form Designer =1 E3

Package Hame | Package ID I—
Start Date I—
Mumber of Days I—
Price Per Person I—

Description

Previous | MNext |
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10

You need to leave room at the top for a banner. You can click then shift-
click to move more than one item at once. (Control-click clones an item,
so be careful not to accidentally use it.) You can resize the window by
dragging the right or bottom sides.

In the Component Palette, click the Multimedia tab, then click
ImageViewer.

ToolTips shows you which button is for the ImageViewer component.
Move the cursor over a button until a pop-up message appears.

Draw a rectangle across the top of the applet form by clicking and
dragging the cursor.

Reserve - Form Designer =1 E3

Package Hame | Package ID I

In the Property List, change the Name property to
image ViewerPackage and set the Center Mode property to false.

Double-click the URL property.

A URL dialog appears.

Click the ... button.

An Add Image Files dialog appears.

Navigate to your Images directory, select Reserv.gif, and click Open.
The complete path appears in the dialog.

Delete the first part of the URL, so the only path remaining is
Images/Reserv.gif.

This creates the relative URL.
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11 Click OK.

The banner appears in the Form Designer. Reposition it as needed.

Reserve - Form Designer =1 E3

online reservations for Isle de Café package tours

Package Hame | Package ID I—
Start Date I—
Mumber of Days I—
Price Per Person I—

Description

¥
4 ¥

Previous | MNext |

12  Click the Project or Form Designer window, then choose Save All
from the File menu.

The project and all included files are saved.
13 Close your project.

14 Copy your entire project directory. You could name the new directory
\VisualCafePro\MyApps\AppAdmin.

You'll use these files later when you create an administrative page for
your database.

15 Reopen your project by choosing Reserve.vpj from the File menu.

Now you can create the lower half of your applet form.

Designing the reservation portion of the applet

The lower portion of the applet lets users make reservations.
1 In the Project window, click keyPressManagerPanell.

This ensures that new components are added to this panel.
2 Choose Add Table Wizard from the Insert menu.

The dbAW ARE Project Wizard appears.
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10

11
12

13
14

Click Next.
The next page appears.

Type dba in the dbANYWHERE Server Name field or choose it
from the pull-down menu.

The correct host name and port number should appear. If not, type
the host name or IP address, and the port number, in the fields.

When dbANYWHERE is running, it displays its IP address and port
number in its window; the default port number is 8889.

Click Next.
Choose Tutorial for the Data Source Name. Then click Next.

You are asked for a user name and password only if you're not still
logged in. Type dba for the user name then type sql for the password,
and click OK.

Select DBA.registration. Then click Next.

Make sure the checkboxes for all columns are selected, except for
Registration_ID. Then click Next.

2

- ” and
replace each remaining underscore (_) with a blank space. Then click
Next.

In the Label fields, delete each occurrence of “Customer

Select Undo changes and change the Text field to Clear.

Select Save changes and change the Text field to Send Registration.
Then click Next.

The Master View page appears.
Click Next.

Look over your selections. If they look correct, click Finish. If you
need to change something, click Back and change what you need to,
then move to this window and click Finish.

The new fields appear on the same form in the lower half of the Form
Designer.
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15 Arrange the fields as follows:
Ly ol
Previous | Mext |
Package ID I— Phone I—
First Name | Number in Party l—
Last Name | Total Cost |
E-mail |
Clear | Send Registration |

16 In the Component Palette, click the Multimedia tab, then click

ImageViewer.
17 Draw a rectangle underneath the Previous and Next buttons by

clicking and dragging the cursor.

Ly ol
Previous | Mext |
Package ID I— Phone I—
First Name | Number in Party ’—
Last Name | Total Cost |
E-mail |
Clear | Send Registration |

18 In the Property List, change the Name property to imageViewerReg

and set the Center Mode property to false.
19 Double-click the URL property.

A URL dialog appears.
20 Click the ... button.

An Add Image Files dialog appears.
21 Navigate to your Images directory, select Register.gif, and click Open.

The complete path appears in the dialog.
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22 Delete the first part of the URL, so the only path remaining is
Images/Register.gif.

This creates the relative URL.
23 Click OK.

The banner appears in the Form Designer. Reposition it as needed.

register for this tour here

Package ID I— Phone I—
First Name | Number in Party l—
Last HName | Total Cost |
E-mail |
Clear | Send Registration |

24 Click the Package ID field on the second part of your form
(Package 1D?2).

25 In the Property List, change the Text property to 780.
This initializes the field to display the first tour package 1D. Alternatively,
you could write Java code that took the first Package ID number from
the database and placed it in the registration Package ID field on
initialization.

26 Click the Project or Form Designer window, then choose Save All

from the File menu.

The project and all included files are saved.

Looking at dbNAVIGATOR

The dbNAVIGATOR provides a hierarchical view of database cataloging
information (known as meta-data). This view shows you dbANYWHERE
servers and available databases, as well as the tables and columns in each
database. You can use dbNAVIGATOR to drop fields on a form and add
fields after you’ve run the Project Wizard.
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Let’s take a look at the dbNAVIGATOR display for the Tutorial database:
1 From the Window menu, choose dbNAVIGATOR.
The dbNAVIGATOR window appears.

= dbNAVIGATOR  [Hi[=] B3

2 Click the + to open dba, then the Tutorial database, then the
DBA. registration table in the Tutorial database.

= dbNAVIGATOR =] 3
=i Tutorial =
@ DBA packages
E@ DEA e

[E] Package_|D
[E] Customer_First_Mame

[E] Customer_Last_Mame
[E] Customer_Email

[E] Customer_Phone

[E] Mumber_in_Party

[E] Total_Cost =l

You can drag fields from the dbNAVIGATOR to the
keyPressManagerPanell object in the Project window to add them to a
form. Both a field and a label are added. Because you’ve already added all
of the fields you need, you don’t need to drag a field.

3 C(Close the dbNAVIGATOR window.

Setting initial record positions

The packages information should start at the first record, while the registration
information should start at a new record:

1 Choose DBA_packages from the Property List pull-down menu.
The properties for this object appear.
Set the Initial Record Position property to First.
Choose DBA_registration from the Property List pull-down menu.
The properties for this object appeat.

4  Set the Initial Record Position property to New.
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Making fields uneditable

All of the packages fields and the following registration fields should not be

editable by a user:
*  Package ID
* Total Cost

Follow these steps for each field:
1 Click the field in the Form Designer.
2 In the Property List, set the Editable property to false.

The field is now uneditable. To indicate this, you’ll change the
background to gray.

3 For the Background property, choose gray.
The gray color appears as the background color.

& Property List - Reserve M= 3

I = Package_Mame vl

Ml cackgond  [SEEEN

=] Binding
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When you finish with the fields, your form should look like this:

Reserve - Form Designer =1 E3

online reservations for Isle de Café package tours

Package Hame | Package ID I—
Start Date I—
Mumber of Days I—
Price Per Person I—

Description

¥
4 ¥

Previous | MNext |
register for this tour here
Package ID I Phone I
First Name | Mumber in Party
Last HName | Total Cost |
E-mail |
Clear | Send Registration |

Save your project by clicking the Project or Form Designer window, then
choosing Save All from the File menu.

Adding component interactions

You need to add the following component interactions to your applet:
*  Setting up the Send Registration button
* Setting the package ID field

* Calculating the total cost



6-18 Creating Applets with Database Functionality

Setting up the Send Registration button

Whenever a record is saved, you want to get a new record so a user can register
again:
1 Select the Send Registration button and right-click.
A pop-up menu appears.
2 Choose Add Interaction.
The Interaction Wizard appears.
3 Select the following items:

Start an interaction for “DBA_registration_saveMultView”: Clicked
Select the item you want to interact with: DBA_registration
Choose what you want to happen: getNewRecord

Click Finish.
Click the Project or Form Designer window, then choose Save All
from the File menu.

Setting the package ID field

You need to set the package ID field when the following buttons are clicked:
*  Clear

* Send Registration

* Previous

® Next

Create the interaction for each button as follows:

:l 1 Click the Interaction Wizard button, then click the button and drag a
il line to the Package ID field on the registration form.

regizter Tor this tour here
Package ID : Phone I
First Name Mumber in Party I
Last HName Total Cost |

E-mail |
Clear Send Registration

The Interaction Wizard appears.
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2 Select the following items:

Start an interaction for “button”: Clicked
Select the item you want to interact with: Package 1D2
Choose what you want to happen: Set the text for TextField

3 Click Next.
The second page of the dialog appears.

4 While Another item is selected, choose Package_ID and select Get
the contents of the TextField.

5 Click Finish.
Save your project by clicking the Project or Form Designer window, then
choosing Save All from the File menu.

Calculating the total cost

The total cost should be calculated after a user enters the number of people. It
should be updated when Previous or Next is clicked, because the price might
change.

Calculating the cost when the Number in Party field changes

Follow these steps:

:I 1 Click the Interaction Wizard button, then click the Number in Party
> field and drag a line to the Total Cost field on the registration form.

register for this tour here

Package ID I— Phone I—
First Name | Mumber in Party
Last HName | Total Cost
E-mail |
Clear | Send Registration

The Interaction Wizard appears.
2 Select the following items:

Start an interaction for “Number_in_Party’: LostFocus
Select the item you want to interact with: Total_Cost
Choose what you want to happen: Set the text for TextField
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3 Click Next.
The second page of the dialog appears.

4 While A String constant or an expression is selected, deselect Add
quotes and type the following line:

String.valueOf(Float.valueOf(Price_Per_Person.getText()).floatValue() *
Float.valueOf(Number_in_Party.getText()).floatvalue())

5 Once you've typed it in, copy the entire line.
You’ll paste it later.
Click Finish.

7 Click the Project or Form Designer window, then choose Save All
from the File menu.

Calculating the cost when the package changes

For the Previous button and the Next button, set up the cost calculation as
follows:

:l 1 Click the Interaction Wizard button, then click the button and drag a
i line to the Total Cost field on the registration form.

regizter Tor this tour here
Package ID I I
First Name | Number in"™dy !
Last HName | Total Cost et
E-mail |

Clear | Send Registration

The Interaction Wizard appears.
2 Select the following items:

Start an interaction for “button”: Clicked
Select the item you want to interact with: Total_Cost
Choose what you want to happen: Set the text for Textlield

3 Click Next.
The second page of the dialog appeats.
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4 While A String constant or an expression is selected, deselect Add
quotes and paste the following line:

String.valueOf(Float.valueOf(Price_Per_Person.getText()).floatvValue() *
Float.valueOf(Number_in_Party.getText()).floatValue())

5 C(lick Finish.

Save your project by clicking the Project or Form Designer window, then
choosing Save All from the File menu.

Now you’re ready to run the applet.

Running the applet

You can compile your applet and look at it while it’s running in the
Applet Viewer:

1 Choose Execute from the Project menu to run the applet.
The applet appears in the Applet Viewer. Visual Cafe Pro compiles your
applet before displaying it.

E‘%Applel Yiewer: Reserve_class =1 E3
Applet

online reservations for Isle d  package tours

Package Name _ Package ID _
Start Date _
Number of Days _
Price Per Person _

Description

Previous | MNext |
register for this tour here
Package ID _ Phone I
First Name | Mumber in Party I
Last Name | Total Cost [

E-mail |

Clear Send Registration
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2 Tty out your applet to make sure it works.
Choose Quit from the Applet menu.
The Applet Viewer window closes.

4 Click the Project or Form Designer window, then choose Save All
from the File menu.

Displaying the applet in a Web browser

Now you can test your applet in a Web browser.

Adding the HTML file to the project

Follow these steps to add the file to the project:
1 From the Insert menu, choose Files into Project.
The Project Files dialog appears.

2 In the Project Files dialog, select Reserve.htm in your project
directory, then click Add.

The file appears in the Files in Project list.
3 Click OK to add the file to the project.
The file appears in the Project window.

E Project - Reserve.vpi [H[=l E3

e
[ Reserve

Gy Objects | [E Packages

Modifying the applet tag in the HTML file
Now you’re ready to add the applet you created in Visual Cafe Pro to the
HTML file:

1 To look at Reserve.htm, select it in the Project window, then choose
Edit Source from the Object menu. Or double-click Reserve.htm.

The Source window appears.
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2 Find the applet tag in the file:

<APPLET CODE="Reserve.class" WIDTH=713 HEIGHT=533>
3 If different, change the width and height in the applet tag so it
matches the width and height in the Property List for your Reserve

applet.

4 C(Close the Source window.

Executing the applet within the Web page

Follow these steps to run the applet directly within the Web page using your
default Web browser:

1 Choose Options from the Project menu.
The Project Options dialog appears.

2 Specify Reserve.htm as your Starter HTML and select Execute applet
in default HTML viewer. Then click OK.

3 Choose Execute from the Project menu to run the applet.

Visual Cafe Pro launches your default HTML browser and displays your
Web page within it.

¥i¢ Metscape - [Symantec Yisual Café Pro Tutorial - Online Reservations]

File Edit “iew Go Bookmarks Options Directory  ‘Window Help

2

Open

Print

Find | Stap |

Eack Forward Harne Edit Reload IrEfes

Lacatian: Ifile:z’./'z’CINisuaICaFeProz’M}\Appsx’AppletDbz’Fieserve.htm j

what's Mew? | ‘what's Coal? | Diestinations | NetSearchl Feople | Snftwarel

-

r’»(_:[ online reservations | : :I
[t

£, Home Page
© and Slide Package Name _ Package 1D

Show
Start Date

Number of Days

Price Per Person

Esland Map *

and Information Description

Comments

Custom and R .

Tours
_Previous | _ Newt | -
« | ;l_l
T8l [Applet Feserve nning =7 4
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Try out your applet.
Exit your browser.
The browser window closes.

6 Click the Project or Form Designer window, then choose Save All
from the File menu.

If your applet works properly in the Web browser, you have completed the
applet. Continue with the next section to create the administrative applet.

Creating an administrative applet for online reservations

L‘%’, ¥isual Cafe Pro

Eile Edit Search Project |nsert Window Help

You can quickly create an administrative applet so you can manage and view
the reservations in DB A.registration. The applet should require a password for

security. Follow these steps:
1 Close any open projects.

2 Open the project you saved in your App Admin project directory.

The project appears.
goi[=1 £

Dl|E] bEle] Z(pe] e o 5| =5E DEEEEE

LR

I &|E|E=

(| B ) e b= |;|_

_I Standard dbAw’AF!El Lllwlltyl Mu\llmedlal Fanalsl Add\t\nnall Shapesl

Far Help. press F1

Feserve:

T Objects

[ Packages

B Project - Reserve_vpj M=l EX Reserve - Form Designer =] 2 ist... x
keyPressi anagerPanel vI
online reservations for islede Café package tours — —
Background ] il
Package Name | Package ID l— Card Name
Class symant
Start Date - Dimensions
Number of Days l— A L]
hd 0
Price Per Person “width 549
Description - Height EXE]
Enabled true
;l = Font
- Mame Dialog
- Size 12
= Style [
L Bold tiue
- S ltalie |false
q ¥ Fareground |- blay
Inherit B ackgrouf tue
Inherit Font t
Previous Nest | — °|n frve _’IL/I
%

3 Add more space to the bottom of the form.
4 In the Component Palette, click dbAW ARE then click Grid.
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Draw the grid on the bottom of the form:

eserve - Form Designer

pnline reservations for Islede Café package tours

Package Hame | Package ID I—
Start Date I—
Mumber of Days I—
Price Per Person I—

Description

Previous | MNext |

In the Property List, set RelView Name to DBA_registration.
Choose dbNAVIGATOR from the Window menu.

The dbNAVIGATOR window appears.

Under the Tutorial database, look for DBA.registration.

Drag DB A registration to the Reserve applet in the Project window.

The object is added to the project. You can reposition its location in the
list by dragging it. This object should be positioned before
keyPressM anagerPanell.

] Project - Reserve.vpj M= 3

DBA:registration
+ keyPresst anagerPanell

Gy Objects | [E Packages
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10

1

12

13

14

15

Select DBA_ registration in the Project window. In the Property List,
type DBA_packages for the Parent RelaionView property.

This specifies the name of the table you want to join with the registration
table.

Click the Join Columns property, then the ... button.

The Join Definition wizard appears.
Define the: Join

Drefine the relationzhip between the master and detail views.

* Choose a column from the master view. Select a cell under
"Master Column'* and choose a column from the list that appears.

* Choose a column from the detail view. Select a cell under “Detail
Column'* and choose a column from the list that appears.

* Chooge an operator for the relationship. Select a cell under
"Operator' and choose an operator from the list that appears.

Master Colummn | Operator | [Dretail Colurnmn

< Back Cancel | Help |

To define the master/detail relationship between the columns, choose
Package 1D in the Master Column and Detail Column fields. Choose
= in the Operator field. Then click Finish.

Now let’s see if the applet runs.
Choose Execute from the Project menu.
The applet appears in the Applet Viewer.

Try out the applet to make sure it works. Then close the Applet
Viewer.

When you click Next or Previous, the list in the grid updates. Y ou can
resize the columns in the grid for the best display.

In the Property List, choose the Tutorial object from the pull-down

menu.

The properties for this object are displayed.
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16

17

18

19

20

21

22

23

Delete the values for the Password and User Name properties.
Now you’ll have to type them in to access the applet.

For convenience, you decide that you want a First button that places you
at the first record in DBA.packages. You add that next.

In the Component Palette, click Standard then the Button
component.

Draw a button on your form.

Reserve - Form Designer

pnline reservations for Isle de Café package tours

Package Hame | Package ID I—
Start Date I—
Mumber of Days I—
Price Per Person I—

Description

; button E Pleviousl MNext |

In the Property List, change the Label property to First.
The name changes on the button.

Select the First button and right-click.

A pop-up menu appears.

Choose Add Interaction.

The Interaction Wizard appears.

Select the following items:

Start an interaction for “button1” Clicked
Select the item you want to interact with: DBA_packages
Choose what you want to happen: first

Click Finish.
Let’s try the applet again.
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24 Choose Execute from the Project menu.

A User Authentication dialog appears.
Ega User Authentication =] 3

DataSource Name:  Tutorial 0K |

Cancel

UserName I

Password I

25 Type dba in the User Name field and sql in the Password field. Then
click OK.

The applet appears in the Applet Viewer.
26 Test the First button.
27 Close the Applet Viewer.

You can also test the applet in a browser.

If your applet works, you have completed the Visual Cafe Pro tour and learned
about many important Visual Cafe Pro features. Now you’re ready to build
your own applets and applications. For more in-depth information, explore
the online documentation and help provided with Visual Cafe Pro.



Support and More
Information

This chapter describes where to get more information on Java and Visual Cafe
Pro. It has the following sections:

Where to get information

Product updates

Symantec service and support solutions
Registering your Symantec product
Technical support

Electronic support

Customer service

Service and support headquarters

W orldwide service and support

0 The URLs listed in this chapter may change since publication.

Where to get information

Visual Cafe includes the following documentation:

Title To find it ...

Visual Cafe help Choose Help Topics from the Help menu.

Choose a menu command, then press F1 to see a
description.

Press F1 in any dialog box or window to display
help for that option.

Press Shift+F 1, then choose the item for which
you need help.
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Title

To find it ...

Visual Cafe User’s Guide

Choose User’s Guide from the Help menu.

Visual Cafe Samples

Go to the c:\VisualCafePro\samples directory (if
Visual Cafe Pro is installed in the default
destination). Y ou need to use the custom install to
install these samples.

Database API
Specifications

Choose Database API Reference from the Help

menu.

Sun Microsystems Java
API Specifications

Choose Java API Reference from the Help

menu.

Highlight a keyword in an Editor window and
press F1 for a description.

Sun Microsystems Java
Language Specifications

Choose Java Language Reference from the
Help menu.

Highlight a keyword in an Editor window and
press F'1 for a description.

To find the most up-to-date information about Sun Java and Visual Cafe:

For information about...

See...

Sun Microsystem’s Java

http://java.sun.com

Symantec Internet Tools

http://cafe.symantec.com

Symantec Technical Support See the section “Symantec service and

support solutions” in this chapter.

For technical support telephone numbers,
see the section “Service and support
headquarters” in this chapter.

A commercially available book that you might find useful is Hooked on Java, by
Arthur van Hoff and others (Addison-Wesley: ISBN 0-201-48837-X); for
more information about this book, see http://www.aw.com/devpress/java/

index.html).
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Product updates

Check the Symantec W eb site (cafe.symantec.com) for updates to Visual Cafe.
After you have registered your copy of Visual Cafe, you can use your login
name and password to download patches and minor updates to your current
version. If you bought your product in a box, the user ID and password are
included with your package. If you bought your product online, the user ID
and password are displayed to you on the screen.

Symantec service and support solutions

Symantec is committed to excellent service worldwide. Our goal is to provide
you with professional assistance in the use of our software, wherever you are
located.

Technical Support and Customer Service solutions vary by country. If you are
outside the United States or Canada, please refer to the Worldwide Service and
Support section at the end of this chapter.

Registering your Symantec product

If you have ordered the product online, you are automatically registered
through Customer Service. In addition, you can use the toll-free fax number
listed below to register your product, or register on the Customer Service
Home Page under Service and Support at www.symantec.com.

If your address changes, you can mail or fax your new address to Customer
Service. Please send it to the attention of the Registration Department.

Symantec Corporation
Attn: Registration Dept.
175 W. Broadway
Eugene, OR 97401

(800) 800-1438 Fax

You can also change your address on the Customer Service Home Page under
Service and Support at www.symantec.com.
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Technical support

Symantec’s Technical Support department offers expanded support options
designed for your individual needs and to help you get the most out of your
software investment.

The phone numbers listed in the “Service and support headquarters” section
are for support in North America. If you are outside the United States or
Canada, please call the local Symantec office or distributor in your area, or
refer to the information provided at the end of this chapter.

Symantec now offers different types of technical support services for you to
choose from, which are described below. Y ou are given StandardCare Support
by purchasing the product and then can choose from Symantec’s PriorityCare
and PremiumCare services to extend your level of support.

For the most current information on Symantec Support Solutions, please call
our automated fax retrieval service, located in the United States, at (800) 554-

4403 or (541) 984-2490, and request document 070. Alternatively, visit
Symantec on the World Wide Web at www.symantec.com.

StandardCare support

All registered users of Symantec products are entitled to these services at no
charge:
*  Unlimited calls for 90 days (from the date of the first call) for

installation assistance, configuration, and general usage questions. The
phone number is (541) 465-8470.

*  Unlimited technical assistance through CompuServe and America
Online. These forums offer electronic access to our technical support
staff, libraries of sample files, technical notes, and bulletins. Y ou will
also find a rich interaction and information exchange with other users
of Symantec software.

*  Unlimited use of Symantec’s Bulletin Board System (BBS). This
download BBS is kept updated with sample files and product
technical notes for quick and easy electronic access.

* Unlimited use of the Symantec Discussion Groups available from the
Service and Support section on www.symantec.com. These forums
offer electronic access to our professional technical support staff, the
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Symantec knowledge base, FAQs, and announcements. The news
server is at service.symantec.com.

* Unlimited access to company information through the Internet. With
a Web browser such as Netscape, you get the latest company news by
entering the URL for Symantec’s home page: www.symantec.com.

The Web site include links to our anonymous FTP site, where you can
download the latest software patches and drivers for Symantec products.
You can also F'TP directly to the site by entering: ftp.symantec.com. A
user ID and password is required.

*  Unlimited use of Symantec’s automated fax retrieval system for
instant printouts of technical notes, bulletins, product literature, and
general information by fax.

* StandardCare Support is available Monday through Friday, 7:00 a.m.
to 4:00 p.m. Pacific Time.

For your first 90 days of free technical support, please refer to the
StandardCare Support (541) phone number in the “Service and support
headquarters” section.

PriorityCare support

All registered users of Symantec products are entitled to these services on a
“pay-as-you-go” basis:
* The PriorityCare 800-number is charged to your VISA, MasterCard,

or American Express on a per incident basis.

* The PriorityCare 900-number is charged to your telephone bill on a
per minute basis. (As of this writing, the charge is $2 per minute, and
an equivalent 900-number service is not available outside the United
States.)

*  Average hold time will be kept to a minimum.

* PriorityCare Support is available Monday through Friday, 6:00 a.m. to
5:00 p.m. Pacific Time.

To use the PriorityCare 800- and 900-number services, please refer to those
numbers in the “Service and support headquarters” section.



7-6 Support and More Information

PremiumCare support

All registered users of Symantec products are entitled to these services on an
annual subscription basis:

PremiumCare Gold support

*  Supportt for one year for up to ten incidents per year for any Symantec
desktop product, with an option to add more incidents.

* Priority support on a a toll-free 800 line.
* Average hold time will be kept to a minimum.

*  Unlimited electronic mail support is provided with a 24-hour response
time on working days. The PremiumCare Gold Support is available
for Visual Cafe for Windows owners at
support_javawin@symantec.com and for Visual Cafe for Macintosh
owners at support(@devtools.symantec.com. Please include your
subscription ID with any e-mail.

* PremiumCare Gold Support is available Monday through Friday, 6:00
a.m. to 5:00 p.m. Pacific Time.

PremiumCare Platinum support
¢ Unlimited calls on a toll-free 800 line.
*  Average hold time will be kept to a minimum.

* A Support Center Manual with troubleshooting, installation,
configuration, and usage information.

*  Quarterly updates of technical notes and bulletins.
* Instant access to senior support staff.

* Automatic updates of inline software revisions. (Inline software
revisions do not include version upgrades.)

* After hours and weekend support is also available to PremiumCare
Platinum customets for an additional fee.

*  PremiumCare Platinum Support is charged on an annual subscription
basis per product family. The annual fee is for two subscribers; other
subscribers can be added on a per person basis.

*  PremiumCare Platinum Support is available Monday through Friday,
6:00 a.m. to 5:00 p.m. Pacific Time.
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* Electronic support for Visual Cafe for Windows owners at

support_javawin@symantec.com and for Visual Cafe for Macintosh
ownets at support@devtools.symantec.com.

To order PremiumCare Gold or Platinum support, please contact Customer
Service or your Symantec sales representative.

Electronic support

Technical information is available 24 hours a day on electronic bulletin board

systems (BBSs). Symantec provides access to its own Symantec bulletin board

system, and maintains the Symantec forums on CompuServe and America
Online.

Symantec BBS

The Symantec BBS provides a Customer Service forum, shareware and public-
domain software, “Frequently Asked Questions” (FAQs), and support forums
where you can exchange tips and information with other users. Settings for the
Symantec bulletin board are: 8 data bits, 1 stop bit, and no parity.

300- through 14,400-baud modems (541) 984-5366
300- through 28,800-baud modems (541) 484-6669
CompuServe

You can exchange information and ideas with Symantec representatives and
with other users of Symantec products on the CompuServe bulletin board.

To access the Symantec forums on CompuServe, type:

GO SYMANTEC at any | prompt.

For additional information, or to subscribe in the United States and Canada,
please call CompuServe at (800) 848-8199. Outside the United States and

Canada, please call (1) (614) 718-2800. Check with CompuServe for data
communications settings.
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America Online

To access the Symantec bulletin board on America Online, type keyword:
SYMANTEC

For additional information, or to subscribe in the United States and Canada,
please call America Online at (800) 227-6364. Check with America Online for
data communications settings.

Symantec discussion groups

Use your Web browset to go to http://www.symantec.com and go to the
Service and Support section. Here you can review the Frequently Asked
Questions, search the Symantec Knowledge Base for known solutions to
problems previously encountered, or post your own quety to a support
newsgroup.

Symantec representatives are ready to answer your questions via our support
discussion groups. All messages posted will receive a response from a
Symantec representative within 48 hours. The discussion groups are similar to
electronic bulletin boards where you post a message and then return later to
find an answer. These support forums are in Usenet newsgroup (Internet
news) format and require that you have a newsreader available.

You can FTP directly to this site to download technical notes and software
patches at: ftp.symantec.com. You can also use the news server,
service.symantec.com.

Automated fax retrieval system

Symantec’s automated fax retrieval system can be used 24 hours a day to
receive product information on your fax machine. You can call from any touch
tone phone to receive an index listing of both Technical Support and
Customer Service documents available, then have any of these specific
documents faxed to you.

To receive technical application notes and samples of “how tos,” please call
our Technical Support fax retrieval number, and choose Option 2.
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You can receive general product information, data sheets, and product
upgrade order forms from our Customer Service fax retrieval number.

® Technical Support:(541) 984-2490
* Customer Service:(800) 554-4403

In addition, you can receive a listing of Symantec offices and worldwide
service and support partners by calling the Technical Support fax retrieval
numbet, choosing Option 2, and requesting Document 1400.

Customer service

Symantec’s Customer Service department builds and maintains long-lasting
customer relations through consistent, expert service. Our Customer Service
department is available to help you:

*  Order an upgrade.

*  Subscribe to the technical support solution of your choice.

* Fulfill your request for product literature or demonstration disks.
* Find out about dealers and consultants in your area.

* Replace missing or defective pieces (disks, manuals, etc.) from your
package.

* Get status on an order or a return.
* Update your product registration with address or name changes.

* Replace lost passwords or user IDs.

You can reach Customer Service at (800) 441-7234 or under the Service and
Support section at www.symantec.com. For specific questions about how to
use your Symantec software, please contact Technical Support.

Replacing a CD-ROM

If the Visual Cafe CD-ROM is damaged or unusable, you can obtain a
replacement.

To receive a replacement or refund for a product purchased through a reseller,
please visit or contact the authorized dealer from whom you purchased the
product.
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If you ordered the product or upgrade directly from Symantec and wish to
receive an replacement or refund in accordance with our 60-day money back
guarantee, please return your CD-ROM and a letter including a brief
explanation for the return. Please send by traceable means, such as UPS or
FEDEX, to:

Symantec Corporation
ATTIN: RMA Dept.
175 West Broadway
Eugene, OR 97401

Recovering passwords

If your user ID and password become inoperative, send a message to
Customer Setvice at custserv(@symantec.com with your name, address,
daytime phone number, ID, and password and we will resolve the situation for
you within 24 to 48 hours. Type Cafe 1.5 DL Reset in the subject field of the
message.

If you have lost your Visual Cafe Pro 1D, send a message to Customer Service
at custserv(@symantec.com. If your information does not appeat in our
registration database, we will provide additional avenues so you can verify
ownership of the product.

Old version support

When a new version of this software is released, registered users may receive
upgrade information through electronic mail or the postal service. After the
release of the new version, telephone support will be provided for the previous
version for 6 months. Technical information for the older versions may still be
available on the electronic services and automated fax retrieval system.

Discontinued product support

When Symantec announces that a product will no longer be marketed or sold,
telephone support will be discontinued 60 days later. Support will only be
available for discontinued products through services such as our automated
fax retrieval system or through documentation posted on electronic services
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such as the World Wide Web, Symantec BBS, CompuServe or America

Online.

Service and support headquarters

Symantec’s service and support headquarters for North America is at the

following location.

Symantec Corporation
175 W. Broadway
Eugene, OR 97401

(800) 441-7234 (USA & Canada Customer Service)
(541) 334-6054 (all other locations)
Fax (541) 984-8020

For Visual Cafe technical support, please call the
following numbers:

StandardCare Support (541) 465-8470
PriorityCare 800 Support (800) 927-4014
PriorityCare 900 Support (900) 646-0004

or post a message in the Visual Cafe Discussion
Group at http://www.symantec.com/techsupp/
index.html.

Worldwide service and support

Symantec provides technical support and customer service worldwide.
Services vary by country and include International Partners (IPs) who
represent Symantec in regions where there is no Symantec office. Most IPs
provide customer service and technical support for Symantec products in your
local language, as close to your home or office as possible.

If your country is not listed in the International Locations section below,
please call our Technical Support automated fax retrieval service, located in the
United States, at (541) 984-2490, choose Option 2, and request Document

1400.
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International locations

European headquarters

Symantec Europe Ltd. Tel. (31) (71) 535 3111

Kanaalpark 145 Fax (31) (71) 535 3150

2321 ]V Leiden

The Netherlands

Customer Service Tel. (31) (71) 535 3294

Technical Support - Dutch Tel. (31) (71) 579 4407
French PC/Mac  Tel. (33) (1) 41 38 69 80
French Mac Tel. (33) (1) 41 38 69 81
German Tel. (49) (211) 9917 110
English Tel. (44) (1628) 788 580

Other Countties

Tel. (31) (71) 579 4425
Fax (31) (71) 535 3153

International BBS (up to 14.4 baud) Tel. (31) (71) 535 3169

Automated fax retrieval (24 hrs.)

Asia/Pacific Rim region
Symantec Australia Pty. Ltd.
408 Victoria Road
Gladesville, NSW 2111
Australia

Technical Support

BBS
Automated fax retrieval (24 hrs.)

Mexico
Symantec Mexico

Tel. (31) (71) 535 3255

Tel. (61) (2) 9850 1000
Fax (61) (2) 9850 1001

Tel. (61) (2) 9879 6577
Fax (61) (2) 9879 6594
Tel. (61) (2) 9879 6322
Tel. (61) (2) 9817 4550

Tel. (52) (5) 545 1234

Rubén Dario No. 36, Piso 2, OFNA 6 Fax (52) (5) 531 2252

Colonia Chapultapec Polanco
11560 México, D.F.
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Technical Support For Technical Support call the
automated fax retrieval service,
located in the United States, at
(541) 984-2490, and request
Document 1400.

Japan

Symantec Japan, Inc.

Pine Bldg. 6F

3-1-2, Shibuya, Shibuya-ku
Tokyo 150 JAPAN

Phone: (81)03-3498-1118
Fax: (81)03-3498-1124

Every effort has been made to ensure the accuracy of this information.
However, the information contained herein is subject to change without
notice. Symantec Corporation reserves the right for such change without prior
notice.
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Applet

An applet is a program that can be added to a Web page and run by Java-enabled Web browsers
(or the Applet Viewer). Java applets are secure because they can’t access the file system on the
local computer, but they can still read from the Web server. This means that applets are less
likely to damage a user’s system or send private information back to the Web server. (While an
applet usually doesn’t have a menu bar, it can create a Java frame that has a menu bar.)

Application

A Java application is standalone and cross-platform: it can run on all computers with a
standalone Java virtual machine and supporting files (which, for instance, you can obtain from
the Sun JDK at java.sun.com), so separate applications for each environment aren’t needed.
Java applications can have menu bars and access files on the local computer. A Java application
is like a C++ application, but it’s cross-platform and you need a Java virtual machine to run it.
For example, you could write a word processor program in Java. A Java frame is a good base
class for a main application window: it can exist by itself, contain components and menus, and
can show dialogs and windows.

Bytecode

Bytecodes are instructions that are similar to machine code, but are machine-independent.
During execution, the Java virtual machine either interprets the bytecodes with a Java
interpreter or converts them to machine code (stored temporarily in memory) with a Just-In-
Time compiler.

Class

A class is a collection of attributes and methods that defines the implementation of a particular
kind of object. A class definition defines instance variables and methods, and specifies the
interfaces the class implements and the immediate superclass of the class.

Component

A Visual Cafe Pro component is a user interface (Ul) element, such as a button, menu, text box,
or container of other components. It is any visual object that can appear on the Form Designer.
It includes more components than those that inherit from the Java Component class; it is often
called a control in C++. Components, except for invisible objects, have a screen position, a
size, and a foreground and background color. They ate either enabled or disabled and can
handle events. To create your user interface, you can drag onto a form a variety of components
from the Component Library or the Component Palette; you assign the component properties
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in a separate Property List window, and add interactions between components with the
Interaction Wizard. Visual Cafe Pro automatically creates the Java code for you during this
design process. See also event, form, invisible object, object, and visual object.

Container

A container is a component that can contain another component. There are two general
categories of Java containers: windows and panels. Some types of windows are a frame (which
can have a menu bar) and a dialog. A panel is a defined area that can appear in a window, such
as an applet that appears in a browser. In Visual Cafe Pro, a container is called a form.

Dialog

A dialog is a simple window with a title bar that can receive and process input from a user.
Dialogs cannot be used by applets, and are not suitable for use as a main window for an
application. Dialogs can contain components, but not menus. Use dialogs for temporary
windows. See also component and container.

Data source

A data source is a source of data, usually a database.

Database template

A database template is an empty database table with predefined columns. Each template is
designed for a specific type of information.

Event

An event is an action, initiated by a user or a program, to which an object can respond. Events
are typically user actions that the program can capture and respond to. Examples of events
include mouse clicks, key presses, and mouse movements.

Form

A Visual Cafe Pro form is a Java container — a component that can contain another
component. There are two general categories of Java containers: windows and panels. Some
types of windows are a frame (which can have a menu bar) and a dialog. A panel is a defined
area that can appear in a window, such as an applet that appears in a browser.

Frame

A Java frame is a general-purpose application window to which you can add components and
menus. See also component and container.
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Interaction

An interaction is a relationship that you define between components resulting in Visual Cafe
Pro—generated code. You can create an interaction between components on one form, or
between a component on one form and a top-level form component (such as having a button
click open another form). An interaction consists of one or more components, a trigger event,
and an action. For example, you can connect a button (the trigger component) to a text box (the
action component) so that when the user clicks on the button (the trigger event), the associated
text box is enabled for user input (the action).

Invisible object

Invisible objects are components that are visible during form design and invisible at runtime.
An example of an invisible object is a menu bar. Invisible objects are a subset of the visible
objects. See also wvisible object.

Java Virtual Machine

The Java Virtual Machine (Java VM) contains a bytecode translator that converts the
downloaded binary Java files into instructions to be executed by the client machine. The Java
VM also contains the library routines that are called by a Java applet.

Join

Ajoin is a definition of a master/detail relationship. Only detail views have joins. The Join
properties for a detail RelationView define a join.

Layout Manager

The layout is a property of container objects that automatically arranges components within the
container so that they display well on different platforms and screens, and at different
resolutions.

Master/detail relationship

This is a relationship between a master view and a detail view. The join of the detail view
defines the relationship.

Method

A method is a procedure that is defined as part of an object and acts on an object that is based
on that object. It is a collection of statements that perform a complex operation. When a
method is called, the instructions in the method are performed and the result is returned to the
statement that made the call.
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Non-visual object

A non-visual object in Visual Cafe Pro is a class defined in source code only. See also invisible
object, object, and visual object.

Object

An object can be a visual object or non-visual object. The Objects view in the Project window
shows visual objects only. The Package view in the Project window shows visual and non-visual
objects as a list of source files. See also invisible object, non-visnal object, and visual object.

Package

A Java package is a group of related Java classes and interfaces. It is both a way of organizing
code and a library of code. You can view the source files and packages of a project in the
Package view of the Project window.

Panel

A Java panel is a general-purpose container that can be added to another container. A panel has
no visible border and can be used to break up windows into logical regions. See also component
and container.

Project

For an application, a Visual Cafe Pro project is a collection of objects that make up the
application. For applets, a Visual Cafe Pro project is a collection of objects that make up an
applet or a group of related applets; it optionally contains one or more HTML files that the
applets run in.

Property
A propertty is a named attribute of a component. Properties define component characteristics
such as the size, color, label, and state — for example, enabled or disabled.

RelationView

This is a Visual Cafe Pro component that represents a view of data that’s defined by an SQL
statement.

Visual object

In Visual Cafe Pro, a visual object (also called a component) is a class defined by both a visual
element (which can be displayed in the Form Designer) and source code. Types of visual
objects are a form (such as a window or dialog), database, and applet. A visual object can
contain other visual objects. Visual objects can have associated properties, events, and methods.
See also component, invisible object, non-visnal object, and object.
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View

A view is a virtual database table that exists only in memory.

Window

A Java window, which is based on the Window class, is an area that has no borders and no
menu bar. See also component and container.
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	4 Close the Form Designer for the Quit dialog.

	Running the application
	1 Choose Messages from the Window menu.
	2 Choose Execute from the Project menu to run the ...
	3 Open the data file in the Images directory, and ...
	4 Close the application.
	5 Click the Project or Form Designer window, then ...
	6 Make adjustments in the Form Designer as needed....


	Looking at the application in the Hierarchy Editor...
	1 While your application project is open, choose H...
	2 Right-click, then choose View Imports from the p...
	3 In the Hierarchy Editor, double-click a class to...
	4 Close the Class Browser and Hierarchy Editor.

	Debugging
	Debugging the About dialog
	1 While your application project is open, choose R...
	2 If it’s not already open, open FrameMain in the ...
	3 Choose Watch from the Window menu.
	4 Choose Threads from the Window menu.
	5 From the Events/Methods drop-down menu in the So...
	6 Click the line with the show method, right-click...
	7 In your application, choose About from the Help ...
	8 Choose Step Into from the Debug menu.
	9 Choose Step Over from the Debug menu.
	10 Choose Step Out from the Debug menu.
	11 Right-click over the breakpoint, then choose Cl...
	12 Choose Continue from the Debug menu.
	13 Choose Open from the File menu and open Tour.da...
	14 Click the FrameMain Source window.
	15 Choose handleEvent from the Events/Methods menu...
	16 Set a breakpoint at handleEvent.
	17 Click the application window.
	18 Clear the breakpoint, then choose Continue from...
	19 Close the Source window displaying AboutDialog....

	Debugging the Day label
	1 If not already open, open the Source window for ...
	2 Choose buttonNext_Clicked from the Events/Method...
	3 Set a breakpoint at nextImage.
	4 In your application window, click the Next butto...
	5 Look at the variables in the Variables window.
	6 Click the + next to this.
	7 Type this.day.
	8 Drag dayCount from the Variables window to the W...
	9 Drag fileName (under dayCount) to the Watch wind...
	10 Scroll down in the Variables window, and click ...
	11 Drag one of the wrappingLabelDesc variables, te...
	12 Choose Continue in the Debug menu.
	13 Click the Next button in the application.
	14 In the Calls window, double-click handleEvent.
	15 In the Calls window, double-click buttonNext_Cl...
	16 Deselect the checkbox in the Breakpoints window...
	17 In the Watch window, click the dayCount row, th...
	18 In the Source window, highlight the dayCount va...
	19 Choose Continue from the Debug menu.
	20 Press the Previous and Next buttons.
	21 In the Breakpoints window, select the breakpoin...
	22 In the Breakpoints window, enter the following ...
	23 Choose Continue from the Debug menu.
	24 Press the Previous and Next buttons until the b...
	25 Clear the breakpoint, then choose Stop from the...



	Creating Applets with Database Functionality
	Creating the online reservations applet
	Using the dbAWARE Project Wizard to create a new p...
	1 Make sure the dbANYWHERE server is running.
	2 Close any open projects.
	3 Choose New Project from the File menu.
	4 Select the dbAWARE Project Wizard, then click OK...
	5 Click Next.
	6 Select Applet, then click Next.
	7 Type the name of your dbANYWHERE server in the d...
	8 If dbANYWHERE is local, you can use the default ...
	9 Click Next.
	10 For the Data Source Name, choose Tutorial from ...
	11 Type dba for the user name then type sql for th...
	12 Select DBA.packages. Then click Next.
	13 Make sure the checkboxes for all columns are se...
	14 In the Label fields, replace each underscore (_...
	15 Select Move to the next record and Move to the ...
	16 Look over your selections. If they look correct...
	17 Click the Project window, then choose Save As f...
	18 Create a new directory structure, such as \Visu...
	19 Navigate to the new project directory, type Res...

	Assigning applet properties
	1 Select Applet1 in the Project window.
	2 In the Property List, set the Name property to R...
	3 Set the Inherit Background, Font, and Foreground...
	4 Click the Project or Form Designer window, then ...

	Gathering the files you need
	1 Copy Reserve.htm from the \VisualCafePro\Tutoria...
	2 Create a new Images directory in your project fo...
	3 Copy the following files from the \VisualCafePro...

	Designing the package portion of the applet
	1 Look at the objects in the Project window (click...
	2 Click the Form Designer window. In the Layout me...
	3 Move the items on the form so they appear like t...
	4 In the Component Palette, click the Multimedia t...
	5 Draw a rectangle across the top of the applet fo...
	6 In the Property List, change the Name property t...
	7 Double-click the URL property.
	8 Click the ... button.
	9 Navigate to your Images directory, select Reserv...
	10 Delete the first part of the URL, so the only p...
	11 Click OK.
	12 Click the Project or Form Designer window, then...
	13 Close your project.
	14 Copy your entire project directory. You could n...
	15 Reopen your project by choosing Reserve.vpj fro...

	Designing the reservation portion of the applet
	1 In the Project window, click keyPressManagerPane...
	2 Choose Add Table Wizard from the Insert menu.
	3 Click Next.
	4 Type dba in the dbANYWHERE Server Name field or ...
	5 The correct host name and port number should app...
	6 Click Next.
	7 Choose Tutorial for the Data Source Name. Then c...
	8 Select DBA.registration. Then click Next.
	9 Make sure the checkboxes for all columns are sel...
	10 In the Label fields, delete each occurrence of ...
	11 Select Undo changes and change the Text field t...
	12 Select Save changes and change the Text field t...
	13 Click Next.
	14 Look over your selections. If they look correct...
	15 Arrange the fields as follows:
	16 In the Component Palette, click the Multimedia ...
	17 Draw a rectangle underneath the Previous and Ne...
	18 In the Property List, change the Name property ...
	19 Double-click the URL property.
	20 Click the ... button.
	21 Navigate to your Images directory, select Regis...
	22 Delete the first part of the URL, so the only p...
	23 Click OK.
	24 Click the Package ID field on the second part o...
	25 In the Property List, change the Text property ...
	26 Click the Project or Form Designer window, then...

	Looking at dbNAVIGATOR
	1 From the Window menu, choose dbNAVIGATOR.
	2 Click the + to open dba, then the Tutorial datab...
	3 Close the dbNAVIGATOR window.

	Setting initial record positions
	1 Choose DBA_packages from the Property List pull-...
	2 Set the Initial Record Position property to Firs...
	3 Choose DBA_registration from the Property List p...
	4 Set the Initial Record Position property to New....

	Making fields uneditable
	1 Click the field in the Form Designer.
	2 In the Property List, set the Editable property ...
	3 For the Background property, choose gray.

	Adding component interactions
	Setting up the Send Registration button
	1 Select the Send Registration button and right-cl...
	2 Choose Add Interaction.
	3 Select the following items:
	4 Click Finish.
	5 Click the Project or Form Designer window, then ...

	Setting the package ID field
	1 Click the Interaction Wizard button, then click ...
	2 Select the following items:
	3 Click Next.
	4 While Another item is selected, choose Package_I...
	5 Click Finish.

	Calculating the total cost
	Calculating the cost when the Number in Party fiel...
	1 Click the Interaction Wizard button, then click ...
	2 Select the following items:
	3 Click Next.
	4 While A String constant or an expression is sele...
	5 Once you’ve typed it in, copy the entire line.
	6 Click Finish.
	7 Click the Project or Form Designer window, then ...

	Calculating the cost when the package changes
	1 Click the Interaction Wizard button, then click ...
	2 Select the following items:
	3 Click Next.
	4 While A String constant or an expression is sele...
	5 Click Finish.



	Running the applet
	1 Choose Execute from the Project menu to run the ...
	2 Try out your applet to make sure it works.
	3 Choose Quit from the Applet menu.
	4 Click the Project or Form Designer window, then ...


	Displaying the applet in a Web browser
	Adding the HTML file to the project
	1 From the Insert menu, choose Files into Project....
	2 In the Project Files dialog, select Reserve.htm ...
	3 Click OK to add the file to the project.

	Modifying the applet tag in the HTML file
	1 To look at Reserve.htm, select it in the Project...
	2 Find the applet tag in the file:
	<APPLET CODE="Reserve.class" WIDTH=713 HEIGHT=533>...
	3 If different, change the width and height in the...
	4 Close the Source window.


	Executing the applet within the Web page
	1 Choose Options from the Project menu.
	2 Specify Reserve.htm as your Starter HTML and sel...
	3 Choose Execute from the Project menu to run the ...
	4 Try out your applet.
	5 Exit your browser.
	6 Click the Project or Form Designer window, then ...


	Creating an administrative applet for online reser...
	1 Close any open projects.
	2 Open the project you saved in your AppAdmin proj...
	3 Add more space to the bottom of the form.
	4 In the Component Palette, click dbAWARE then cli...
	5 Draw the grid on the bottom of the form:
	6 In the Property List, set RelView Name to DBA_re...
	7 Choose dbNAVIGATOR from the Window menu.
	8 Under the Tutorial database, look for DBA.regist...
	9 Drag DBA.registration to the Reserve applet in t...
	10 Select DBA_registration in the Project window. ...
	11 Click the Join Columns property, then the ... b...
	12 To define the master/detail relationship betwee...
	13 Choose Execute from the Project menu.
	14 Try out the applet to make sure it works. Then ...
	15 In the Property List, choose the Tutorial objec...
	16 Delete the values for the Password and User Nam...
	17 In the Component Palette, click Standard then t...
	18 Draw a button on your form.
	19 In the Property List, change the Label property...
	20 Select the First button and right-click.
	21 Choose Add Interaction.
	22 Select the following items:
	23 Click Finish.
	24 Choose Execute from the Project menu.
	25 Type dba in the User Name field and sql in the ...
	26 Test the First button.
	27 Close the Applet Viewer.
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