jl Four Quick Steps to a Finished Presentation

These steps get you a simple presentation fast. Click a button to see how to complete a step.
Step 1 Decide how you want to start

Ll Create pages in Preview

[ | Type text in the Outline

_| Import text from a document

J Use an existing presentation

Step 2 Ll choose a design and a color scheme

Step 3 Ll Check the spelling
Step 4 J Distribute the results

For more information on creating presentations with ASAP, click Contents or Index and then choose a topic.



Create Pages in Preview

In Preview, you develop your presentation one page at a time. ASAP's Intelligent Formatting makes it easy by
arranging elements on the page so everything fits and looks balanced. Preview also lets you experiment with different
page layouts to find the best way to express your ideas.

To start in Preview:
1 Start ASAP.

) ] ) [ EfhPreview
2 If the Preview tab isn't on top, click

ASAP displays the first page of a new presentation.
3 Replace the placeholder text with your title for the presentation, and press the Enter key.

Don't worry about where lines of text end as you're typing. When you press Enter, ASAP's Intelligent Formatting
adjusts the lines so the text fits in the Title region.

4 To add a subtitle, click LI
Click Subtitle, type the subtitle, and press Enter.
ASAP gives the page a Bullets layout, but you'll probably want the first page to have a Title layout.

To complete the page:

1 To change the page to Title layout, click E Title

ASAP puts placeholder text on the page for elements you may want to add.
2 Double-click the Author placeholder text, type your name, and press Enter.
3 Replace or delete the remaining placeholder text.

To remove unneeded placeholder text, click it and press the Delete key.
Now you're ready to add the remaining pages of the presentation.
To add a new page:
1 Drag the layout you want for the new page into the Preview area.

As you drag, the pointer becomes a wand with three stars attached. When you release the mouse button, ASAP
creates a new page. Placeholder text describes the layout you chose.

2 Replace or delete placeholder text until the text on the page is complete.

Continue dragging layouts and replacing or deleting placeholder text until you've created all the pages in your
presentation.

Notes

n In Preview, you can also add pictures to your pages and change the design and color scheme of your
presentation.

n Use placeholder text to help you choose the layout that best communicates your ideas. After you add a page,
click different layouts to see how they look and read about their purpose.

n  ASAP starts in the Outline, unless it was in Preview the last time you exited. You can change the placeholder text
in the Outline, if you prefer.

Related Topics
Understanding the Basics

Working in Preview
Working in the Outline



Type Text in the Outline

If you like to jot down and organize ideas before thinking about how your pages will look, begin your presentation in
the Outline.

To start in the Outline:

1 Start ASAP.

. . ) Dutline
2 If the Outline tab isn't on top, click

Type a title for the first page after E
Replace the New Title placeholder text, if it appears.

w

Press Enter.

Type your first point after #

Press Enter, type the next point, and press Enter.
Continue adding points and sub-points to the page.
To change a point into a sub-point, press Tab.

8 To add a new page, click EI

Notes
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n  ASAP starts in the Outline, unless it was in Preview the last time you exited.

n To change a point into a page, press Shift+Tab.

ASAP gives most pages you add in the Outline a Bullets layout. You'll probably want a different layout for some
pages. For example, you might change the first page to the Title layout.

To change the layout of a page:

! Preview \
1 Go to Preview by clicking EhP
2 If you don't see the layouts, click - = i

3 Go to a page whose layout you want to change. Click the Go to Page button and click the page title in the
list.

4 Click the layout you want. ASAP changes the current page to that layout.

Notes

n In Preview, you can also add pictures to your pages and change the design and color scheme of your
presentation.

n  Click different layouts to find the one that best communicates your ideas. After you've added points to a page, you
can see placeholder text for the new layout by clicking that layout a second time.

Related Topics
Understanding the Basics
Working in the Outline
Working in Preview




Import Text from a Document
You don't have to retype text to begin a presentation. ASAP can import a Microsoft Word or WordPerfect file, a text
file, or a file saved in Rich Text Format (RTF).
To import from Microsoft Word:
1 In Microsoft Word, open the document or outline you want to import.
You don't need to start ASAP first.
2 Select the part of your document or outline you want to use in the presentation.

To import the entire file, don't select anything.

3 On the Microsoft Word toolbar, click jl

ASAP opens and your text appears in the QOutline or Preview, depending on which view was current when ASAP
last exited.

To import a WordPerfect, plain text, or RTF file:

1 Start ASAP and click Open on the File menu.

2 Click the type of file you want to import in the Files of type drop-down list.
3 Locate the file and double-click it.

ASAP opens and your text appears in the Outline or Preview, depending on which view was current when ASAP
last exited.

Notes

n  When ASAP imports text, it uses the paragraphs, tabs, and bullets in the document to create pages, points, and
sub-points in a new presentation. You can change the structure of the presentation by changing the indent of
these items in the Outline.

n  The ASAP button does not appear on the Microsoft Word toolbar if you installed Microsoft Word after installing
ASAP.

ASAP gives most pages you import a Bullets layout. You'll probably want a different layout for some pages. For
example, you might change the first page to the Title layout.

To change the layout of a page:

) ) . o /' [EihPreview \
1 If the Preview tab isn't on top, go to Preview by clicking
2 If you don't see the layouts, click - B\

3 Go to a page whose layout you want to change. Click the Go to Page button and click the page title in the
list.

4 Click the layout you want. ASAP changes the current page to that layout.

Notes

n In Preview, you can also add pictures to your pages and change the design and color scheme of your
presentation.

n  Click different layouts to find the one that best communicates your ideas. To see placeholder text for the new
layout, click the layout a second time.

Related Topics

Understanding the Basics
Working in the Outline

Working in Preview

Importing Text from a Document



Use an Existing Presentation

You can use ASAP's Intelligent Formatting to polish a presentation begun in PowerPoint. You need PowerPoint
version 7 on your computer to open the presentation in ASAP.

To start with an existing presentation:

1 Click Open on the File menu.

2 Click PowerPoint Files in the Files of type list.
3 Locate the file and double-click it.

Note

n  ASAP chooses the design and color scheme that best preserve the look of the original presentation. It picks an
appropriate layout for each original slide. Once in ASAP, you can change the presentation's design and color
scheme, and use a different layout for some pages.

Related Topics
Understanding the Basics
Working in the Outline
Working in Preview

Opening a PowerPoint Presentation




Choose a Design and a Color Scheme

You can change the appearance of your entire presentation by using a different design or color scheme. The layouts
in a design are arranged so all elements on a page work together. Your presentation can have any combination of
design and color scheme.

To change the design:

1 In Preview, click - =] Lo

2 Click a design.
ASAP uses that design for every page in the presentation.

To change the color scheme:

1 In Preview, click - Q Lo

2 Click a color scheme.
ASAP uses that color scheme for every page in the presentation.

Note

n It doesn't matter which you choose first. You can find a design you like and try out different color schemes with it,
or you can choose a color scheme and try out different designs.

Related Topics
Choosing Layouts, Designs, and Color Schemes

Printing Tips
More on Colors



Check the Spelling

It's always a good idea to check for spelling errors before you give a presentation.

To check the entire presentation:

Outline

1 Startin the Outline. If you're in Preview, click

2 Click Spelling on the Edit menu.
ASAP begins checking. It displays the first questionable word in the Spelling dialog box.

3 Correct or accept the word.

To: Do this:

Skip the word Click Ignore

Fix the word Type a correction in the Replacement box and click Replace
Use a suggestion Double-click a word in the Suggestions box

ASAP continues checking. It displays a message when it reaches the end of the presentation.
Note
n If you are using a trial version of ASAP, the Spelling command may not be available.

Related Topics
Checking for Spelling Errors
Spelling Dialog Box



Distribute the Results

You can display your presentation on the computer screen, print its pages, print handouts from the pages, include
pages in a report, or send the presentation to others by electronic mail.

To present onscreen:

1 If you're not at the first page in the presentation, go there. Click the Go to Page button and click the first page in
the list.

! ndPrezent "1
2 Click t-‘ B

The first page fills the screen.

3 Press the Enter key to display the next page.
4 When you've finished displaying the last page, press the Esc key to leave Present.

Related Topics

Distributing the Results
Printing Tips



Knowing Which View to Use

Click a tab to use an ASAP view.

Click X =) L to:

n Jot down your ideas using page titles, major points, and sub-points

n  See an overview of a presentation
n  Change the order of pages or points
n  Move a point

n  Spell-check the entire presentation

Click - =) L to:

n  Create pages visually

n  Change the layout, design, and color scheme

n Add pictures such as ClipArt, a logo, a chart, and a background

n  Add special text such as page numbers, headers, footers, picture captions, and lead-ins

n  Change the size and font of text

! mdPrezent "1
Click wdPr to:

n Display a presentation on the computer screen



Choosing Layouts, Designs, and Color Schemes

In Preview you can select any combination of layouts, designs, and color schemes to give your presentation a unique
look. Each page can have its own layout; all pages in the presentation have the same design and color scheme.

Click =) * to select:

n A page layout that best conveys the concept or information on the page

Click =) * to select:

n  An overall design to add interest to the presentation

Click - 2D * to select:

n  Acolor scheme for the presentation

Notes

n  Use placeholder text to help you choose an appropriate layout. Add a new page by dragging a layout to the
Preview area. Then, click different layouts to see how they look and read about their purpose.

n  If you're experimenting with different layouts for an existing page, click a new layout a second time to see its
placeholder text. You can remove unneeded placeholder text by clicking the layout again.

n  If your computer is set up to use only 16 colors, use the first four color schemes for the best results. To see how a
presentation will look when printed without color, use the Black & White color scheme.

Related Topics

Printing Tips
More on Colors



Understanding Intelligent Formatting

Intelligent Formatting is the name of ASAP's built-in graphic design intelligence, which arranges and scales text and
pictures on the presentation page. If you make changes, Intelligent Formatting automatically adjusts the page so
everything fits and looks balanced.

When you work on an ASAP page in Preview, you're really working on one of three layers:
Intelligent Formatting layer

Contains text and pictures. You change the location and appearance of elements on this layer by clicking layouts
and designs or by selecting a region from the Placement drop-down list. Intelligent Formatting operates on this
layer.

Background
Contains a picture that appears beneath the Intelligent Formatting layer.
Foreground

Contains pictures that overlay text and pictures on the Intelligent Formatting layer and the Background.



Creating a Startup Template

A startup template causes ASAP to open with your choice of layout, design, and color scheme. You can add your logo
and specific text to the template so every presentation includes them automatically.

To create a startup template:

1 Open ASAP and create a presentation that includes the elements you want as the basis for future presentations.
2 Save this presentation with the name startup in the folder where you installed the ASAP program.

Notes

n  The next time you start ASAP, the program opens displaying the startup template. Use this template to create a
presentation and then save the presentation with a different name.

n Astartup template can have more than one page.



Importing Text from a Document

To import from Microsoft Word:

1
2

In Microsoft Word, open the outline or document you want to import.
Select the part you want to use in the presentation.

To import the entire file, don't select anything.

On the Microsoft Word toolbar, click -* = Lo

ASAP opens and your text appears in the Outline or Preview, depending on which view was current when ASAP
last exited.

To import a WordPerfect, text, or RTF file:

1 Click Open on ASAP's File menu.

2 Click the type of file you want to import in the Files of type drop-down list.

3 Locate the file and double-click it.
ASAP opens and your text appears in the QOutline or Preview, depending on which view was current when ASAP
last exited.

Notes

n

The list shows all the types of files on your computer that ASAP understands. If none of these match your word
processor, you can copy and paste text into ASAP.

When you import text from a document or file, ASAP creates a new presentation. To add text from a document to
an existing presentation, copy the text and paste it into a page.

When ASAP imports text, it uses the tabs, bullets, paragraphs, and pages in the document to create pages,
points, and sub-points. You can change the structure of the presentation by changing the indent of these items in
the Outline.

Related Topics

Changing the Indent of a Point or Sub-point in the Outline
Moving or Copying a Page, Point, or Sub-point in the Outline
Adding a Table from a Word Processor or Spreadsheet
Using Drag and Drop



Opening a PowerPoint Presentation

If you have PowerPoint version 7 on your computer, you can open a PowerPoint presentation in ASAP.
To open a PowerPoint presentation:

1 Click Open on ASAP's File menu.

2 Click PowerPoint Files in the Files of type list.

3 Locate the file and double-click it.

Notes

n  ASAP uses the design and color scheme that best preserve the look of the PowerPoint presentation. It picks an
appropriate layout for each PowerPoint slide. Once in ASAP, you can change the presentation's design and color
scheme, and use a different layout for most pages.

n  ASAP converts many elements of a PowerPoint presentation, but PowerPoint features that are not supported in
ASAP are not available. Be sure to check each PowerPoint slide in ASAP and make any necessary adjustments.

n  Graphs, organization charts, and tables on PowerPoint slides appear in ASAP as OLE objects. To edit a graph,
organization chart, or table, double-click it.

n Texton a PowerPoint slide that doesn't appear in PowerPoint's Outline View is placed as a picture in the
Foreground of an ASAP page. In ASAP, you can move and resize the picture by dragging, but you can't edit the
text.

Related Topic
Understanding Intelligent Formatting



Using Drag and Drop

Drag and drop is a convenient way to:

n

n

Rearrange text and pictures on an ASAP page
Import text and pictures into an ASAP presentation from another program that supports drag and drop

Notes

n

n

Drag and drop works in both the Outline and Preview.

If you are moving text only a short distance in the Outline, using drag and drop may be easier than using Cut and
Paste.

In Preview, when you drag elements on the Intelligent Formatting layer, ASAP displays drop targets. You see
rectangles as targets if you're dragging a picture. Textual drop targets appear if you drag text outside the body.

ASAP highlights the current drop target as you move the mouse. If you drop text when no target is highlighted,
the text becomes part of the body.

When you drop text or a picture after dragging it, ASAP adjusts the page so all elements fit and look balanced.

To copy instead of move, hold down the Ctrl key while you drag.



More on Colors

If your computer uses only 16 colors, choose one of ASAP's first four color schemes for best results.

You can set many computers to use more colors and improve the onscreen appearance of your presentations. See
the Windows 95 Help for instructions on changing the number of colors your computer uses.



Checking for Spelling Errors

1 Click Spelling on the Edit menu.
2 When ASAP displays a questionable word, correct or accept the word.
To: Do this:
Skip the word Click Ignore
Fix the word Type a correction in the Replacement box and click Replace
Use a suggestion Double-click a word in the Suggestions box
Notes

n

n

To check the entire presentation for spelling errors, start in the Qutline; to check only the current page, start in
Preview.

To add a word to your custom dictionary so it isn't questioned again, click Add to Dictionary.

To prevent ASAP from questioning words, like acronyms, that use only capital letters, set Ignore words in ALL
CAPS.

When ASAP checks spelling, it questions a word that differs only in capitalization from a word in your custom
dictionary. To prevent this, add the word again with the alternative capitalization.

If you are using a trial version of ASAP, the Spelling command may not be available.

Related Topics

Editing the Personal Dictionary
Spelling Dialog Box



Editing the Personal Dictionary

1 Click Personal Dictionary on the Edit menu.
2 Indicate your changes.
To: Do this:
Add a word Type the word in the Word box and click Add
Change aword  Select the word in the Personal Dictionary list, edit it in the Word box, and click Change
Delete a word Select the word in the Personal Dictionary list and click Delete
3 Click OK.
Notes

n  ASAP uses your Microsoft Office custom dictionary file as its personal dictionary. If ASAP can't find this file, it
creates a new file.

n  You can use another ASCII personal dictionary file with ASAP. Just copy the file to your ASAP folder and rename
it CUSTOM.DIC.

Related Topic
Personal Dictionary Dialog Box



Understanding the Basics

Click the topic you want help on.

Knowing Which View to Use
Choosing Layouts, Designs, and Color Schemes
Understanding Intelligent Formatting



Adding a New Page in the Outline

1 Click the page above where you want the new page.

2 click £ B\

Note

n To create a page from a point or sub-point, click the point or sub-point and press Shift+Tab until the point symbol
becomes a page symbol.

Related Topic
Moving or Copying a Page, Point, or Sub-point in the Outline



Adding a Point or Sub-point in the Outline

1 Click the point or sub-point above where you want to make the addition.
2 Press Enter.

3 Type the text for the new point or sub-point.

Notes

n ASAP adds a point or sub-point at the same level as the line at the cursor.

-
n To add a sub-point to a point, click _f’I

Related Topics
Moving or Copying a Page, Point, or Sub-point in the Outline
Changing the Indent of a Point or Sub-point in the Outline




Changing the Indent of a Point or Sub-point in the Outline

1 Click the point or sub-point you want to change.
2 To indent more, press Tab. To indent less, press Shift+Tab.

Note

n You can also change the indent by clicking il or

14



Selecting Text in the Outline

Click a symbol to select a page, point, or sub-point.

Click: To select:

A =] L8 The entire page
S By A point and all its sub-points

Notes
n Click and drag the cursor on a line to select text you want to edit or delete.

n  Double-click a word to select it.



Moving or Copying a Page, Point, or Sub-point in the Outline

1 Click the symbol of the page, point, or sub-point you want to move.

2 Drag the symbol to the new position.

Notes

n To copy a page, point, or sub-point, hold down the Ctrl key as you drag.

n You can use the Cut or Copy and Paste commands on the Edit menu instead of dragging. Before you paste,
click above the place where you want to put the page, point, or sub-point.

n  ASAP moves or copies any sub-points with a point.
n If your presentation contains many pages, it's easier to rearrange them if you collapse the outline first.

Related Topics

Collapsing and Expanding the Outline
Undoing a Cut or Delete



Collapsing and Expanding the Outline

To:

Collapse All (Hide all points and show only page titles)
Collapse (Hide the points of the page at the cursor)

Expand All (Show the points of all pages)

Lal|ll] Aol 2
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Expand (Show the points of the page at the cursor)
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If your presentation contains many pages, it's easier to rearrange them if you collapse the outline first.



Deleting a Page, Point, or Sub-point in the Outline

1 Click the symbol of the page, point, or sub-point you want to delete.
2 Press the Delete key.

Note

n  If you delete a point with sub-points, the sub-points are deleted also.

Related Topic
Undoing a Cut or Delete



Undoing a Cut or Delete

n To undo a cut or delete, click Undo on the Edit menu.
Notes
n Undo works only after using the Cut, Clear, or Delete Page command or pressing the Delete key.

n  To undo a change of layout, design, or color scheme, just click the original layout, design, or color scheme.

n If you changed the size of a picture or text by clicking the Bigger, Smaller, or Shrink One Line button, you can

return to the original size by clicking



Working in the Outline

Click the topic you want help on.

Adding a New Page in the Outline

Adding a Point or Sub-point in the Outline

Changing the Indent of a Point or Sub-point in the Outline
Selecting Text in the Outline

Moving or Copying a Page, Point, or Sub-point in the Outline

Collapsing and Expanding the Outline
Deleting a Page, Point, or Sub-point in the Outline







Adding a New Page in Preview

Drag a layout onto the current page.

Notes

n ASAP adds a new page after the current page. Double-click placeholder text in the new page and replace it with
your own text.

n To add a blank page with a Bullets layout, click - B\



Jumping to a Page

1 Click the Go to Page button.

2 Click the page you want to see.

Notes

n To go to the previous or next page in the presentation, click the arrow button to the left or right of the Go to Page
button.

n  If you double-click a page symbol in the Outline, ASAP displays the page in Preview.

n To jump to a page while presenting, right-click and then click a page in the list.



Selecting an Item in Preview

Click an item to select it.

ASAP highlights the selection. You see its current placement in the Placement drop-down list.

Notes
n To select the entire page, click Select Page on the Edit menu.
n To select only the body, click Select Body on the Edit menu.

Related Topic
Editing Text and Replacing Placeholder Text in Preview



Copying a Page in Preview

1 Click Select Page on the Edit menu.

2 Choose Copy on the Edit menu.

Notes

n  Use Paste on the Edit menu to put the copied page after the current page in an ASAP presentation.

n To copy an ASAP page to another ASAP presentation, start ASAP again and open the other presentation.

n To copy only the body and any remarks, click Select Body in step 1. You can paste the selection into an ASAP
page or another program.

Related Topics

Including a Presentation Page in a Report
Using Drag and Drop
Creating a Page with More than One Body



Deleting a Page

1 Go to the page you want to delete.
2 Click Delete Page on the Edit menu.

Related Topics

Jumping to a Page
Undoing a Cut or Delete



Deleting Items from a Page

1 Click the item you want to delete.
2 Press the Delete key.

Related Topic
Undoing a Cut or Delete



Turning Onscreen Transitions Off and On

n In Preview, click Turn Off Transitions on the Format menu.

Notes
n To turn transitions back on, click Turn On Transitions on the Format menu.

n  When transitions are turned on, ASAP uses a special effect as it displays each page during an onscreen
presentation. The transition effect depends on the design of the presentation.



Creating a Page with More than One Body

1 Create a page with one body.

You add additional body elements to this page.

Create another, temporary page with the body you want to add.

In Preview at the temporary page, click Select Body on the Edit menu.
Click Copy on the Edit menu.

Go to the page you want to have more than one body element.

Click Paste on the Edit menu.

If you want more than two body elements on the page, repeat steps 2-6.

0 N o g~ WD

When you're satisfied with the page that has more than one body element, delete the temporary pages.
Notes

n  ASAP pastes the body as a picture. You can adjust its size and position like any other picture.

n To change a pasted body element, delete it, create a new temporary page, and repeat steps 3-6.

Related Topics

Adding a New Page in Preview
Jumping to a Page

Deleting a Page

Changing the Size of Pictures
Moving a Picture

Deleting Items from a Page



Working in Preview

Click the topic you want help on.

Adding a New Page in Preview

Jumping to a Page

Selecting an ltem in Preview

Copying a Page in Preview

Deleting a Page

Deleting Items from a Page

Turning Onscreen Transitions Off and On
Working with Text

Working with Pictures






Adding a Point or Sub-point in Preview

1 Click the point or sub-point above where you want to make the addition.
2 Press Enter.

3 Type the text for the new point or sub-point and press Enter.

Notes

n  ASAP adds a point or sub-point at the same level as the point or sub-point at the cursor.

-
n To add a sub-point to a point, click _f’I

Related Topic
Changing the Indent of a Point or Sub-point in Preview




Changing the Indent of a Point or Sub-point in Preview

1 Click the point or sub-point you want to change.

2 To indent more, press Tab. To indent less, press Shift+Tab.



Adding a Subtitle, Remark, or Lead-in

1 In Preview, go to the page where you want to add a subtitle, remark, or lead-in.

2 click £ B\

3 Click the item you want to add.
4 Type over the placeholder text and press Enter.
Notes

n If the page doesn't have a title, you can add one by clicking the Insert Special button.
n  You can set the pages on which the subtitle, remark, or lead-in appears. Click Show On on the Format menu.

Related Topics

Jumping to a Page
Show On Dialog Box



Adding a Header or Footer

In Preview, click -f = v

1

2 Click Header/Footer.

3 Type text in a Header or Footer list box, or select a preformatted page number or date.
4 Change the setting of Show on first page, if you want.

5. Click OK.

Notes

n

Use the Left, Right, or Center list box depending on where you want the text, page number, or date to appear in
the header or footer.

Set Show on first page to show any header and footer on all pages of the presentation, including the first page.
If you remove the setting, no header or footer appears on the first page or on any page with the Title layout.

If you select a page number or date to appear in the header or footer, don't type any text in the box with the item
you select.

Related Topic
Header and Footer Dialog Box



Adding a Table from a Word Processor or Spreadsheet

Open the document or spreadsheet containing the table.

Select the table or the range of cells you want to add.

Open the ASAP presentation and display the page you want to come before the page with the table.
Click Paste on ASAP's Edit menu.

Notes

1
2
3 Click Copy on the Edit menu.
4
5

n ASAP creates a new page for the table after the current page. The new page has a Row Table layout.
n To transpose the table in ASAP (switch its rows and columns), change to the Column Table layout.

Related Topics

Jumping to a Page
Using Drag and Drop



Adding a Caption to a Picture

1 In Preview, click the picture you want to add a caption to.

2 Press Enter.

3 Type your caption over the placeholder text and press Enter.



Editing Text and Replacing Placeholder Text in Preview

1 Double-click the text you want to change, if it isn't already selected in a text box.

2 To replace all the text in the text box, just begin typing.

3 Press Enter or click outside the text box when you finish typing.

Notes

n To change part of the text, click inside the text box, select the text you want to edit, and type the correction.
n Don't be concerned with where lines end when you edit text. ASAP adjusts line breaks after you press Enter.

n  Some placeholder text is selected when you insert it on the page; you see the cursor in the text box. Just begin
typing to replace the placeholder text.

n Toremove unneeded placeholder text, click it and press the Delete key. After you type a point in the body, you
can delete all placeholder text by clicking the current layout on the Layout tab. Placeholder text reappears if you
click the layout again.

Related Topics

Changing the Size of Text
Numbering ltems
Changing the Presentation Font



Changing the Size of Text

1 In Preview, click the text you want to resize.

2 Click a button to change the size.
Click: To:

a
da
Notes

Make the text larger

Make the text smaller

n If you're changing the size of points or sub-points, click just one of them. ASAP changes all the points at the same
level.

n To make text as large as possible, hold down the Ctrl key when you click the Bigger button.

n  When you change text size, ASAP adjusts the size of other items on the Intelligent Formatting Layer.

T
n o return to the original size, click _al

Related Topics
Changing the Size of Pictures

Resizing the Intelligent Formatting Layer
Shrinking a Text Block One Line




Moving or Copying Text in Preview

1 Click the text you want to move to another region.

2 Click the new region in the Placement drop-down list.

Notes
n  Use Copy and Paste on the Edit menu to copy text.
n You can also move text using drag and drop.

n  When you move a picture, its caption moves with it.

Related Topics

Understanding Intelligent Formatting
Resizing the Intelligent Formatting Layer
Using Drag and Drop

Moving a Picture



Numbering Items

1 In Preview, click one of the points you want numbered.

1, e
Al
&=

2 Click
Notes

n  ASAP numbers points in the body that are grouped. For example, if you click a first level point, only points at that
level are numbered.

n Toremove the numbers, click one of the points and click the Show/Hide Numbers button again.



Shrinking a Text Block One Line

1 In Preview, click the text block that's one line too long.

2 Click '_il

Note

n  ASAP makes the text smaller so it fits without wrapping to the last line. The size of other text items with the same
placement changes too.



Changing the Presentation Font

1 In Preview, click Font on the Format menu.
2 Click the new font and then click OK.




Resizing the Intelligent Formatting Layer

1 In Preview, display the page you want to change.

2 Click Select Page on the Edit menu.
3 Drag a handle to change the size.
Note

n Text and pictures on the Intelligent Formatting layer adjust to the new size. Pictures placed in the foreground or
background are not affected.

Related Topic
Understanding Intelligent Formatting



Working with Text

Click the topic you want help on.

Adding a Point or Sub-point in Preview

Changing the Indent of a Point or Sub-point in Preview
Adding a Subtitle, Remark, or Lead-in

Adding a Header or Footer

Adding a Table from a Word Processor or Spreadsheet
Adding a Caption to a Picture

Editing Text and Replacing Placeholder Text in Preview
Changing the Size of Text

Moving or Copying Text in Preview

Numbering ltems

Shrinking a Text Block One Line

Changing the Presentation Font






Adding a Logo

1 In Preview, click 4 B

2 Click Logo.

3 Select your logo file and click Open.

Notes

n  ASAP puts the logo to the left of the title. It appears on every page in the presentation, unless you change the
pages on which it appears.

n  Your logo file can be in one of these formats:

Windows Metafile
Windows Bitmap
Tagged Image Format
CompuServe Picture
PC Paintbrush

Related Topic
Moving or Changing Pictures



Adding a Picture

1 In Preview, display the page where the picture will go.

2 Click Picture on the Insert menu.

3 Select the picture file and click Open.

Notes

n  When ASAP adds the picture, it adjusts other items to preserve the balance of the page.
n  Your picture file can be in one of these formats:

Windows Metafile
Windows Bitmap
Tagged Image Format
CompusServe Picture
PC Paintbrush

Related Topics
Moving or Changing Pictures
Adding a Caption to a Picture




Adding ClipArt or WordArt

1 In Preview, display the page where the art will go.

2 click £ B\

3 Click the type of art you want to add.

4 Select a ClipArt file, or type text in WordArt and select any special effects.
5 Click Insert or OK.

Notes

n  ClipArt and WordArt appear on ASAP's Insert Special menu if the programs are installed on your computer.
n  For help on ClipArt or WordArt options, click the Help button in the ClipArt or WordArt dialog box.

n In WordArt, leave Size set at Best Fit. You don't need to specify a point size because ASAP scales the words for
you.

Related Topics
Moving or Changing Pictures
Adding a Picture
Adding a Caption to a Picture



Adding an OLE Object

To create a link between the object in ASAP and the object file, set Link

1 In Preview, display the page where the OLE object will go.
Click Object on the Insert menu.
Set a create button.
Set: To:
Create New Create a new object
Create from File Insert an existing object file
4 Set options in the dialog box.
If you set: Do this:
Create New Click the program you'll use to create the object
Create from File Select an existing file. (Click Browse to locate the file.)
5 Click OK.
Notes

n

n

To edit an OLE object, double-click the object in the presentation.

If you don't set Link, you put a copy of the object file in the presentation. Changes you make in this copy don't
appear in the original file, and changes in the original file don't appear in the copy. Don't set Link if you plan to
distribute the presentation or display it on a different computer.

You can also add an OLE object by copying it in the source program and clicking Paste Special on ASAP's Edit

menu.

Related Topics

Moving or Changing Pictures
Insert Object Dialog Box
Paste Special Dialog Box



Adding a New Chart

1 In Preview, display the page where the chart will go.

Click “ B

Click Chart.
ASAP opens your charting program. You see a sample chart.

4 Replace the data in the sample chart's spreadsheet with your data.
5 Exit the charting program to return to ASAP.
Notes

n  Chart appears on ASAP's Insert Special menu if you installed Harvard ChartXL, Microsoft Excel, Lotus 1-2-3, or
Microsoft Graph on your computer.

n Achart you add this way is contained in the presentation. To change the chart, double-click it to start the charting
program. If you send the presentation to someone who doesn't have the charting program, they can see but not
change the chart.

n To use an existing chart, click Open on the charting program's File menu in step 4 rather than replacing sample
data.

n You can also add a chart as an OLE object.

Related Topics

Adding an Existing Chart
Moving or Changing Pictures
Adding an OLE Object



Adding an Existing Chart

1 Start the charting program and open the chart.

2 Select the chart and copy it to the clipboard.

3 In Preview, display the page in your ASAP presentation where you want the chart.
4 Click Paste on the Edit menu.

Notes

n You can also add a chart as an OLE object.

n If you want to be able to use your charting program to edit the chart in ASAP, click Paste Special in step 4
instead of Paste.

Related Topics

Adding a New Chart

Moving or Changing Pictures
Adding an OLE Object
Paste Special Dialog Box



Changing the Size of Pictures

1 In Preview, click the picture you want to change.

2 Click a button to change the size.
Click: To:

a
da
Notes

Make the picture larger

Make the picture smaller

n To make the picture as large as possible, hold down the Ctrl key when you click the Bigger button.

n To return to the original size, click EI

n When you change the size of a picture, ASAP adjusts the size of other items on the Intelligent Formatting
Layer.
n If you change the placement of a picture to Foreground or Background, you can resize the picture by

dragging one of its handles.
Related Topics

Moving a Picture

Understanding Intelligent Formatting



Moving a Picture

1 In Preview, click the picture you want to move.

2 Click the new placement in the Placement drop-down list.

Notes

n  You can also change the placement of a picture on the Intelligent Formatting layer using drag and drop.

n  When you change the placement of a picture, ASAP adjusts the picture's size and the size of other items on the
page.

n If you change the placement of a picture to Foreground or Background, you can drag the picture anywhere on
that layer.

n If two or more pictures share the same region on the Intelligent Formatting layer, you can change their alignment
in relation to one another.

n If you move a picture, its caption moves with it.

Related Topics

Understanding Intelligent Formatting
Using Drag and Drop

Aligning Pictures in a Region



Changing a Picture into a Background

1

In Preview, click the picture.

2 Click Background in the Placement drop-down list.

Notes

n

n

n

When you place a picture on the Background layer, handles appear so you can resize it.
A picture on the Background layer appears on the current page, but you can set it to appear on other pages.

ASAP scales a picture on the Background layer to fill the page. Set Normal scaling if the picture appears
distorted.

When a picture on the Background layer fills the page, text on the Intelligent Formatting layer appears on top of
the picture and might be difficult to read. To make text more visible, choose a picture that is predominantly light or
dark and choose a color scheme with a dark or light background.

If changing the color scheme doesn't make the text readable, you can resize the picture to cover only part of the
page and resize the Intelligent Formatting layer to cover the other part.

Related Topics

Adding Pictures

Changing the Pages on which a Picture Appears
Changing Scale Options

Resizing the Intelligent Formatting Layer
Changing the Size of Pictures

Understanding Intelligent Formatting



Aligning Pictures in a Region

1 In Preview, click one of the pictures in a region.

Click Picture on the Format menu.

Set the alignment.

Set: To align the pictures:

Vertical From top to bottom

Horizontal Side by side

Stack In a stack so only the top one shows completely
4 Click OK.
Note

n  The Alignment buttons set the position of a picture in relation to other pictures with the same placement.

Related Topic
Changing Scale Options



Changing Scale Options

1 In Preview, click the picture you want to change.

Click Picture on the Format menu.

Set the scaling.

Set: To:
Normal Maintain the original picture's proportions
Stretch Fill the region with the picture
None Remove any scaling from a bitmap
4 Click OK.
Notes

n  Set Normal scaling to allow ASAP to control the size of the picture. Depending on its placement, the size of the
picture might change, but its proportions remain the same.

n  Set None for a bitmap file, like a logo, that you don't want ASAP to scale. The picture's size is determined by the
number of pixels in its height and width. The size might change depending on the resolution of the output device
(printer or screen), but does not vary with placement.

n If you set Stretch, you can change the proportions of a picture placed in the foreground or background by
dragging the handle on a side of the picture.

Related Topics
Aligning Pictures in a Region
Changing the Size of Pictures



Changing the Pages on which a Picture Appears

1 In Preview, click the picture to select it.

2 Click Show On on the Format menu.

3 Set the pages the picture appears on.

Set: To show the picture on:
This page only The current page
All pages Each page in the presentation

All pages except title Every page except those with the Title layout
Note

n To display a picture on some but not all pages, copy the picture and paste it on the pages where you want it to
appear.



Working with Pictures

Click the topic you want help on.
Adding a Logo

Adding a Picture

Adding ClipArt or WordArt

Adding an OLE Object

Adding a New Chart

Adding an Existing Chart

Changing the Size of Pictures

Moving a Picture

Changing a Picture into a Background
Aligning Pictures in a Region
Changing Scale Options

Changing the Pages on which a Picture Appears



Adding Pictures

Click the topic you want help on.
Adding a Logo

Adding a Picture

Adding ClipArt or WordArt
Adding an OLE Object

Adding a New Chart

Adding an Existing Chart



Moving or Changing Pictures

Click the topic you want help on.

Changing the Size of Pictures

Moving a Picture

Changing a Picture into a Background

Aligning Pictures in a Region

Changing Scale Options

Changing the Pages on which a Picture Appears






Presenting Onscreen

1 Open the presentation.
Click the Present tab. The current page fills the screen.

Show other pages.

To show: You can:

The next page n Click the left mouse button
n Press Enter
n Press the Spacebar
n Press the Right or Down Arrow key
n Press PgDn

The previous page n Double-click
n Press the Left or Up Arrow key
n Press PgUp

A particular page n Click the right mouse button or press Tab and then click the page
The first page n Press Home
The last page n Press End

4 Press Esc to leave Present.
Notes

n  To move from page to page more quickly when presenting onscreen, close all other programs and turn transitions
off.

n If you want to present on a computer that doesn't have ASAP installed, use the ASAP WordPower Player. For
more information, see Software Publishing Corporation's home page on the World Wide Web at
http://www.spco.com/

Related Topic
Turning Onscreen Transitions Off and On



Printing Full Pages or Handouts

1 Open the presentation you want to print.
Click Print on the File menu.

In the Print list box

Select: To print:
Full Page Each page of the presentation on a separate sheet of paper
A Handouts option The specified number of presentation pages on a sheet of paper

4 Select whether to print in black and white or color.

5 Set the range of pages to print.

6 Click OK to begin printing or click Printer to change printers or print settings.

Notes

n To see how a presentation appears printed without color, select the Black & White color scheme.

n  Full pages print in landscape orientation by default. To print them in portrait orientation, change the page setup
before printing.

n  The orientation for handouts (either portrait or landscape) is preset depending on how many presentation pages
you choose to print on each sheet of paper.

Related Topics

Printing the Outline
Printing Tips



Printing the Outline

Open the presentation with the outline you want to print.
Click Save As on the File menu.

Type a new name for the file.

Select Text in the Save as type list box.

Choose another location for the file, if you want.

Click Save.
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Open and print the new file with a word processing program.



Including a Presentation Page in a Report

Open the report file in its program.

Open the presentation in ASAP.

Go to the presentation page in Preview.

Click Select Page on the Edit menu.

Click Copy on the Edit menu.

Go to the place in the report where you want to insert the presentation page.

Click Paste Special on the Edit menu.
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Select a format (either Picture or Device Independent Bitmap) and click OK.
Notes
n  To help you choose a format, use the information in the Result box.

n If you want the ASAP page to appear in portrait orientation in the report, change the page setup in ASAP before
copying the ASAP page.

n Toinclude only the body and any remarks on an ASAP page in a report, choose Select Body in step 4. Before
copying and pasting, check the color of the text. If it won't show up properly in the report (for example, if the text
is white in ASAP and the report page is also white), change the color scheme in ASAP before copying the body.



Publishing on the Internet

You can embed an ASAP presentation in a World Wide Web page.

With ASAP WebShow and Netscape Navigator version 2.0, others can view, download, and print the presentation
from the Internet.

For more information, see Software Publishing Corporation's home page at http://www.spco.com/



Sending a Presentation by Electronic Mail

1

Open the presentation you want to send.

2 Click Send on the File menu.

3 Complete the dialog boxes from your electronic mail program to address and send the message.

Notes

n

n

n

The Send command is available if you have Microsoft Mail installed on your computer.
The current presentation is automatically attached to the message.

If you want to send the presentation to someone who doesn't have ASAP installed on his or her computer, use
the ASAP WordPower Player. For more information, see Software Publishing Corporation's home page on the
World Wide Web at http://www.spco.com/



Saving in PowerPoint Format

1 Click Save As on the File menu.

2 Select PowerPoint File in the Save as type list box.

3 Choose another name and location for the file, if you want.
4 Click Save.

Notes

n

ASAP saves the entire presentation in PowerPoint format. If you need only one page or just the body of a page,
you can copy just that part.

When PowerPoint opens an ASAP presentation saved in PowerPoint format, you see a slide for each page. All
the elements on the pages appear, except background elements that are part of an ASAP design. The
presentation has an appropriate PowerPoint design template.

ASAP and PowerPoint work differently in many areas, so your ASAP presentation may not appear in PowerPoint
exactly as you expect. Check each slide in PowerPoint and make any necessary adjustments.

Keep these points in mind if you use PowerPoint to change an ASAP presentation saved in PowerPoint format.

You can edit the title and subtitle of ASAP slides in PowerPoint the same way you edit any PowerPoint
presentation.

Some elements set in ASAP to show on all pages and all pages except those with a Title layout appear on
PowerPoint's masters. If necessary, you can move or resize one of these global elements on the master.

Return to ASAP to change other elements on the slide. Then save the ASAP presentation again in PowerPoint
format.

Related Topic
Copying a Page in Preview



Printing Tips

1 It's usually a good idea to print a single test page before printing your entire presentation.
2 Keep these points in mind when you choose a color scheme:

n Black and white printing: ASAP prints in black and white unless you set True colors in the Print dialog box. If
you're printing in black and white, use the Black & White, Gray, or Mist color schemes. If your printer can convert
color to gray scale, try Aqua or USA.

n Faster printing: Color schemes that don't have bitmap backgrounds print faster. To reduce the time it takes to
get your output, choose one of these color schemes: Black & White, Gray, Blue, Aqua, USA, Midnight, Stainless
Steel, City Nights, Cabernet, Billiards, or Mist.

n  Avoiding curl and bleed: Some printers jam from curled paper; others use ink that bleeds through the paper. If
your pages curl or bleed, avoid printing dark backgrounds. Use one of these color schemes with a light
background: Black & White, Gray, Aqua, USA, Mist, and Dollars.

n Recording on film: If you're creating slides, remember that text on a light background is harder to read when
projected. Use one of these color schemes with a dark background: Blue, Midnight, Stainless Steel, City Nights,
Cabernet, Billiards, Felt, Stream, and HiTech.



Distributing the Results

Click the topic you want help on.

Presenting Onscreen

Printing Full Pages or Handouts

Printing the Outline

Including a Presentation Page in a Report
Publishing on the Internet

Sending a Presentation by Electronic Mail
Saving in PowerPoint Format







Contacting Technical Support

If you have a technical problem and you can't find the solution in online Help
1 Note the sequence of events that led to the problem, and any program messages you see.

2 Contact Technical Support. Have ASAP running on your computer if you call.

Contacting Technical Support
United States Call (970) 522-9064 (phone)
Call (970) 522-9074 (fax)

Europe To receive support, you must first register your copy of ASAP. After you register, you will be
granted 30 days of free installation support

Other Countries Contact your local distributor
Australia Call +61 2 561 5999

Ready Reference Call (800) 735-2228 in the United States and Canada

Fax-On-Demand lets you order faxes of product fact sheets, technical bulletins, program notes, upgrade forms,
and other materials.

Auto-Expert is an automated troubleshooting system that can help you solve technical problems. You can
request a fax transcript of your interactive session.

CompuServe
Go Word: GO SPCONLINE. Click SPC Support Forum.



Choose Font Dialog Box

Select the font family to use in your presentation.



Format Picture Dialog Box

Adjust the scaling of a selected picture and change the alignment of pictures in the same region using these options:

Scale buttons
Click a button to change a picture's scaling.
Normal button
Set to maintain the original picture's proportions.
Stretch button
Set to fill the region with the picture.
None button
Set for a bitmap file to remove any scaling.
Alignment buttons
Click a button to change the location of pictures in the same region.
Vertical button
Set to line up the pictures from top to bottom.
Horizontal button
Set to line up the pictures side by side.
Stack button
Set to put the pictures in a stack so only the top one shows completely.
Notes

n  Set Normal scaling to allow ASAP to control the size of the picture. Depending on its placement, the picture may
appear larger or smaller, but its proportions remain the same.

n  Set None for a bitmap file, like a logo, that you don't want ASAP to scale. The picture's size is determined by the
number of pixels in its length and width. The size may change depending on the resolution of the output device
(printer or screen), but does not vary with placement.

n If you set Stretch, you can change the proportions of a picture placed in the foreground or background by
dragging the handle on a side of the picture.



Header and Footer Dialog Box

Add a header or footer to the presentation using these options:

Header and Footer list boxes
Type text, or select a preformatted page number or date. Use the Left, Right, or Center list box depending on
where you want the text, page number, or date to appear in the header or footer.

Show on first page check box
Set to show any header and footer on all pages of the presentation, including the first page.

Notes

n If you do not set Show on first page, no header or footer appears on the first page of the presentation or on any
page with the Title layout.

n If you select a page number or date to appear in the header or footer, don't type any text in the box with the item
you select.



Insert Object Dialog Box

Add an OLE object using these options:

Create buttons
Set whether the object is new or is based on an existing file.

Object Type list
Select the type of object you want to add. This list appears when Create New is set.

File box

Type the name and location of the object's file. This box appears when Create from File is set. You can click the
Browse button to select the file.

Browse button
Click to select a file. This button appears when Create from File is set.

Link check box

Set to link the object's file to the object in ASAP. With a link, changes in the file are reflected in the object. This
box appears when Create from File is set.

Display As Icon check box
Set to use the server program's icon to represent the object. When set, the icon appears below this check box.

Change Icon button
Click to select a different server icon. This button appears when Display As Icon is set.

Result box
Describes the effect of current settings.



Insert Picture Dialog Box

Add a picture from another program to an ASAP presentation using these options:

Look in list box
Select the location that contains the picture file you want to add. The contents of that location appear in the large
list.

Up One Level button
Click to display the contents of the location above the location shown in Look In.

Create New Folder button
Click to create a new folder.

List/Details buttons
Click to change the amount of detail shown in the large list.

Contents list
Select the picture file you want to add.

File name box
Type the name of the picture file.

Files of type list box
Select the type of picture file you want to appear in the large list.



Open Dialog Box

Open an ASAP presentation or another file using these options:

Look in list box
Select the location that contains the file you want to open. The contents of that location appear in the large list.

Up One Level button
Click to display the contents of the location above the location shown in Look In.

Create New Folder button
Click to create a new folder.

List/Details buttons
Click to change the amount of detail shown in the large list.

Contents list
Select the file you want to open.

File name box
Type the name of the file you want to open.

Files of type list box
Select the type of file you want to appear in the large list.



Page Setup Dialog Box

Set the page size and orientation for the presentation using these options:

Size list box
Select a size for displaying and printing the presentation.

Orientation buttons
Set an orientation for displaying and printing the presentation.

Note

n If the settings don't match, the orientation set here takes precedence over any orientation setting made through
the Print dialog box.



Paste Special Dialog Box

Indicate how to paste text or pictures using these options:

Source field
Shows the location of the text or picture.

Paste button
Set to embed a copy of the text or picture.

Paste Link button
Set to link a copy of the text or picture.

As list
Select a format for the pasted text or picture in the presentation.

Result box
Describes the operation that will occur.

Display As Icon check box
Set to use the server program's icon to represent the pasted text or picture. When set, the icon appears below
this check box.

Change Icon button
Click to select a different server icon. This button appears when Display As Icon is set.

Note

n Inorder to create a link, be sure to save the text or picture in a file before copying the text or picture to the
clipboard.



Personal Dictionary Dialog Box

Maintain your custom dictionary using these options:

Word box
Type a word to add to the custom dictionary. Select a word from the list to delete or change.

Personal Dictionary list
Select a word in your custom dictionary to delete or change.

Add button
Click to add a word typed in the Word box to your custom dictionary.

Delete button
Click to delete the word in the Word box from your custom dictionary.

Change button
Select a word in the Personal Dictionary list, edit it in the Word box, and click this button to change that word in
the dictionary.

Note

n If you are using a trial version of ASAP, the Personal Dictionary dialog box may not be available.



Print Dialog Box

Set how you want the presentation pages printed using these options:

Print list box
Select Full Page to print each presentation page on a single sheet of paper. For handouts, select the number of
presentation pages you want printed per sheet.

Color list box
Select whether to print in black and white or color.

Range buttons
Set to print all pages in the presentation or just a range of pages. When printing only part of the presentation,
type the first and last page numbers in the range in the From and To boxes.

Printer button
Click to change printers or print settings.



Print Setup Dialog Box

Change printers or printer properties using these options:

Printer buttons
Set to print on the default or another printer.

Specific Printer list box
Select a different printer to use.

Options button
Click to change print settings.

Note

n If the settings don't match, the orientation set in the Page Setup dialog box takes precedence over any orientation
set here.



Save As Dialog Box
Save an ASAP presentation with a different name or in a different location using these options. Save the outline of a
presentation as a text file.

Save in list box
Select the location where you want to save the file. The contents of that location appear in the large list.

Up One Level button
Click to display the contents of the location above the location shown in Save in.

Create New Folder button
Click to create a new folder.

List/Details buttons
Click to change the amount of detail shown in the large list.

Contents list
Double-click a folder to see its contents.

File name box
Type a new name for the file.

Save as type list box
Select the type of file you want to save.

Notes

n Based on the type of file you choose, ASAP adds the appropriate extension to the file's name. ASAP files have
the extension .ASP.

n  Choose ASAP 1.0 Presentation in the Save as type list box only if the file will be opened by ASAP version 1.0.
Choose ASAP WordPower Presentation to use the file with ASAP WordPower versions.



Show On Dialog Box

Set to display the selected picture, subtitle, remark, lead-in, or OLE object on the current page, all pages, or all pages
except those with the Title layout.

Notes
n  The exact title of this dialog box depends on what is selected.

n To display a picture on some but not all pages, copy the picture and paste it on the pages where you want it to
appear.



Spelling Dialog Box

Correct possible spelling errors using these options:

Questionable word in page box
Displays a word that is not included in any spelling dictionary ASAP uses.

Replacement box
Accept the suggested correction for the questionable word or type a different word.

Suggestions list
Select a replacement for the questionable word.

Ignore words in ALL CAPS check box
Set to prevent ASAP from questioning words, like acronyms, that use only capital letters.

Ignore button
Click to accept the questionable word and continue checking.

Replace button
Click to change the questionable word to the word in the Replacement box.

Add to Dictionary button
Click to add the questionable word to your custom dictionary so it is not questioned again.

Notes

n If you choose Spelling in the Outline, ASAP checks all pages of the presentation. In Preview, it checks only the
current page.

n If you are using a trial version of ASAP, the Spelling dialog box may not be available.






Definitions

Click a word to see its definition.

body

caption

Color Scheme
Design

embed

footer

Go to Page button
handout

header

Intelligent Formatting
Intelligent Formatting layer

picture

pixel
placeholder text
Placement drop-down list
point

Present
Preview
Preview area
region

remark

server
sub-point
subtitle
transition




body
The main region on a page in Preview that contains points and sub-points.



caption

Text you can add to a picture in Preview. A caption appears below the picture; if you move the picture, the
caption moves with it.



Color Scheme

A = B

A feature of Intelligent Formatting that selects the colors used in a presentation.



Design

A = B

A feature of Intelligent Formatting for the overall look of a presentation. Each Design ensures that all elements on a
page are positioned to look balanced and proportional.



embed

To add text or a picture created by another program to an ASAP presentation. When you embed, you can
use the original program to edit the text or picture within ASAP. Embedded text or pictures are not linked
to the other file.



footer

Text you can add in Preview to the bottom of all pages (or all pages except the first and those pages with
Title layout). A footer can contain text you type, or the current page number and the date the presentation
was last saved.



Go to Page button
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A button indicating the current page number and the number of pages in the presentation. Click the button when you
want to go to a different page in the presentation.



handout

A printed copy of a presentation intended to be given to the presentation audience. A handout can
contain from one to eight presentation pages on a sheet of paper, with room for notes.



header

Text you can add in Preview to the top of all pages (or all pages except the first and those pages with
Title layout). A header can contain text you type, or the current page number and the date the
presentation was last saved.



Intelligent Formatting

ASAP's built-in graphic design intelligence, which arranges and scales text and pictures on the
presentation page. Regardless of changes, the page always looks balanced and proportional.



Intelligent Formatting layer

A “transparent” layer on an ASAP page, where the page Layout and Design determine the size and
placement of pictures and text.



Layout

A = B

A feature of Intelligent Formatting that arranges text and pictures according to the type of information or concept
being conveyed.



lead-in

Text you can add in Preview to the current page. A lead-in is generally displayed at the bottom of the
page and is used to introduce the next slide in a presentation.



link

To add text or a picture from another program to an ASAP presentation. You can use the original program
to edit the text or picture within ASAP. When you link, a connection is created between the original file
and the presentation; changes made in one are reflected in the other.



logo

A distinctive symbol or graphic representing a company, product, or the like. In ASAP a logo is a picture
that you can add in Preview to the left of the title.



OLE object

Text or a picture that is created with another program and added to a page in an ASAP presentation. You
can embed or link the object when you add it.



Outline

An ASAP view for jotting down ideas quickly, rearranging text and pages, and spell checking an entire
presentation.



page
The basic unit of an ASAP presentation that is displayed as a single screen in Present.



picture

A graphic image such as a logo, ClipArt, WordArt, chart, or graph that can be added to a page in
Preview. A picture can be in any of the following formats: Windows Metafile, Windows Bitmap, Tagged
Image File Format, CompuServe Picture, or PC Paintbrush.



pixel

Picture element. The smallest element of a computer screen that can be assigned color. The greater the
number of pixels, the better the clarity of a picture.



placeholder text
Built-in, helpful text supplied by ASAP that you replace with the actual text for the page.



Placement drop-down list

Body -

In Preview, a list that you use to select the region for text or pictures on the page.




point

A text item covering a detail about the main idea on a page. In the Org Chart layout, a point is a position
in the organization chart.



Present
An ASAP view for displaying a presentation on a computer screen.



Preview

An ASAP view for creating pages visually; changing the Layout, Design, and Color Scheme; and adding,
moving, and resizing text and pictures.



Preview area
The area in Preview where the current page is displayed.



region

An area of the Intelligent Formatting layer. Text regions include title, subtitle, top remark, bottom remark,
body, and lead-in. Picture regions include relative locations on the page, such as top, bottom, upper left,
and lower left.



remark

Text you can add to the top or bottom of a page in Preview.



server

In OLE, the program that is the source of the data or object that is being linked or embedded.



sub-point
Text that is a lower level than the point above it.



subtitle
A secondary title on a page that generally appears beneath the title.



transition

A visual effect displayed when going from one page to another during an onscreen presentation.









