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Overview

The objective of Splash Manager is to take a set of files, and copy one of the files from the set, to a 
destination file.    It’s that simple.    Splash Manager calls such a set of files a Cycle List.    The destination 
file assigned to a Cycle List is called the Target File.

There are 3 basic steps in setting up a new Cycle List:
1. Create a new Cycle List (press the “New” button on the main window).
2. Define the Cycle List name and Target File.
3. Choose the set of files to be contained in the new Cycle List.

Splash Manager allows you to create 1 or more Cycle Lists, because, typically, the set of files should be 
all the same file type, but there’s no restriction.    For example, you could have two Cycle Lists:    one that 
contains all your favorite bitmaps, and the other might contain all your favorite WAV files.    Then, you 
could define their Target Files as the desktop window wallpaper, and startup sound file, respectively.

Splash Manager can also help you create your own Windows 95 splash screens.    You may not know it, 
but you can change the picture that Windows 95 displays during system startup, and shutdown.    Splash 
Manager uses the Paint program that ships with Windows 95 to give you a starting picture to modify for 
each type of splash screen Windows 95 supports (startup, shutdown - “Please wait”…, and “It’s safe…”).

A built-in scheduler allows you to specify how frequently you want your Target Files to be updated.    You 
can update them every few minutes, when Windows starts up or shuts down, or even every few seconds 
(you need to drink a lot of coffee for that, though).

Splash Manager keeps your original Target Files safe by automatically backing them up.    You can 
manually backup or restore your Target Files if you like, too.

So, you may be asking, “What are some uses of Splash Manager?”    Here are just a few examples of 
how you can use Splash Manager:
1. Update your Windows Desktop Wallpaper.
2. Change your Windows 95 startup/shutdown splash screens.
3. Update your startup sound.
4. Update a network login script for your users.
5. Change an HTML page on your web site for different advertising.

Basically, any file which can be dynamically altered you can use as your Target File with Splash Manager. 
Your imagination is the limit.



Enjoy!

See also

Shareware Registration
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Shareware Registration

Splash Manager is a shareware application as opposed to a public domain or a commercial application.    
Because this application is shareware, you are entitled to review the program before you buy it for a 
period of time determined by the shareware program author.    P & J's Software finds that a review period 
of 60 days is sufficient time to make your decision.

Please note that the only functional difference between the program you are using and the registered 
version is that the registered version doesn’t have any registration reminder screens or trial period.    For 
example, in the registered version, the product never expires, your name will appear in the AboutBox, and 
no registration reminder screens will appear when you start Splash Manager.

When you register Splash Manager, you will receive the following items:

* The latest registered version of Splash Manager.    This is not a more complete version; only a 
"stamped" version indicating your registration status with P & J's Software.

* A written letter confirming your registration status.*
* A printed version of the Splash Manager User's Guide.*
* Notification of any other new P & J's Software products.
* 50% off upgrade discount to the next version of Splash Manager when it's released (2.0).
* Free lifetime support for Splash Manager.

* - Indicates that item is not available using “electronic registration” in hardcopy form.    Electronic version 
are supplied instead.

There are two main courses of action you may take during the shareware evaluation period:

1. You may register the program if you want to continue to use it longer than the trial period of 60 days.
2. You may decide Splash Manager is not for you and delete it (run the UnInstall program that gets 

installed to do this).

If you find that Splash Manager is a program you would like to continue to use, then you must register the 
program with P & J's Software.    We at P & J's Software extend our thanks to you if you do so, because it 
helps us to continue improving our products and also inspires us to create new and exciting applications 
for Win32 and Win32s!

To register Splash Manager via U.S. Postal Mail, follow these steps:

1. Fill out the data in the file REGISTER.TXT that is distributed with this program.
2. If you have a printer, just load the REGISTER.TXT file into Notepad, fill in the data and print it.    If you 

do not have a printer, you may hand write all the data, or send the completed data file electronically 
via disk or by e-mail as described in the REGISTER.TXT file.

3. Send your check or money order for the amount determined in the REGISTER.TXT file and the 
completed registration form as done above to the mailing address shown on the form.    Your order 
will not be processed until payment is received.

To register Splash Manager electronically, via CompuServe, follow these steps:

1. Logon to CompuServe as you normally would.
2. Type GO SWREG.
3. Choose the Register Shareware menu option.
4. Choose Proceed.
5. Choose your geographical location.
6. Choose the Registration ID filter, type in 1925, and press OK.



7. Choose Display Selected Titles.
8. Select Splash Manager and choose Register.
9. Follow the steps to confirm payment and you’re done!

Product support policy of P & J’s Software:

* Product support is done via e-mail, if possible.    If you are an international user (outside the 
continental United States), please understand that this is the only means by which we can offer 
product support.    You have unlimited use of this means of support as anyone does.

* Citizens of the continental United States can also contact P & J’s Software via U.S. Postal mail for 
product support.    The 1st response is free; otherwise, you must include a self-addressed stamped 
envelope.

* You must be a registered user, to be guaranteed a response, but if you have questions concerning 
the product during the evaluation period, please e-mail us and we will try our best to help you.    
Your business is important to us.

See also

Revision History
Contacting P & J's Software



Shareware Distribution

If you want to distribute Splash Manager, you may do so free of charge.    However, in order for P & J’s 
Software to maintain the highest quality distribution efforts, we ask that you follow these steps/rules:

1. You must notify P & J’s Software of the distribution.
2. You must make it known to users that Splash Manager requires Windows 95 or NT to operate.
3. You must distribute the newest version of Splash Manager.    Obtain the newest version of our 

software from our web site:    “http://members.aol.com/pjsoftware”.

Thank you for your support of the shareware industry.

See also

Contacting P & J's Software



Revision History

A revision history helps track program bug fixes, improvements, new features and other types of 
revisions.    Remember, your suggestions are important to help keep Splash Manager a premier Win32 
shareware application.    Thank you for all your input!

Version 1.0 May 17, 1997
* Initial release.



Contacting P & J's Software

You may contact P & J's Software in the following ways:

E-Mail
CompuServe: PJSoftware
Internet: PJSoftware@compuserve.com

World Wide Web
http://members.aol.com/pjsoftware

U.S. Postal Mail
P & J's Software
9316 178th PL NE, #1
Redmond, WA    98052      USA



Troubleshooting Q & A

Here are some common questions and answers that I have compiled since the testing of Splash 
Manager.    Remember to e-mail P & J’s Software if you have any problems you can’t figure out with 
Splash Manager as they will help me write a better product and hopefully I can provide you with a 
solution.

“I’m running Windows NT 4.0 and am trying to use Splash Manager to update my Desktop 
Wallpaper, but it is not working.    What am I doing wrong?”

There is a documented defect in NT 4.0 (up to and including service pack 2), which prevents external 
applications from updating the desktop wallpaper systematically.    We have found that this only occurs if 
you do not have a wallpaper currently defined for the user you are logged in as.

The solution is to define a wallpaper using Start/Settings/Control Panel/Display.    Just choose any 
wallpaper, and press OK.    Then, go back to Splash Manager and either create a new Cycle List using the 
“Desktop Wallpaper” predefined Target File, or manually update the Target File of an existing Cycle List 
with the file you just made as the wallpaper.    The former method is much easier, because Splash 
Manager figures out for you what file you made the desktop wallpaper.

“Splash Manager says it cannot find Microsoft Paint.    How can I get Microsoft Paint?”

Please refer to your Windows 95 manual for official installation instructions.    However, in a nutshell, to 
install Microsoft Paint, do... Start/Settings/Control Panel/Add-Remove Programs and then under the 
“Windows Setup” tab, double-click on “Accessories”.    Then, find “Paint” and put an ‘X’ in the check box 
to install it.    Lastly, press OK twice and Windows 95 will install Paint for you.

You should then be able to view/edit your bitmaps.

See also

Revision History
Contacting P & J's Software
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Creating a New Splash Manager Document

A Splash Manager document contains all the Cycle Lists, and Cycle List Sets you create.

To create a new document, choose the File menu (Alt+F) and then select New.    You can also press 

Ctrl+N or click the  toolbar button.



Loading an Existing Splash Manager Document

Once you have saved a Splash Manager document, you can reload it.

To load an existing document, choose the File menu (Alt+F) and then select Open.    You can also press 

Ctrl+O or click the  toolbar button.



Saving Your Data

To permanently keep your Cycle Lists and Cycle List Sets, you can save your data to a file.

To save your data, choose the File menu (Alt+F) and then select Save.    You can also press Ctrl+S or 

click the  toolbar button.



Creating a New Cycle List

A Cycle List is a set of related files; typically all of the same file type.    You create a new Cycle List any 
time you need a new Target File, because you can only have one Target File per Cycle List.

To create a new Cycle List, choose the Options menu (Alt+O) and select “New Splash Screen Cycle 

List”.    Alternatively, you can press the F3 key, or click the  toolbar button.

See Also
Creating a New Cycle List Using a Predefined Target File



Creating a New Cycle List Using a Predefined Target File

At the point of choosing a target file for you new cycle list, you can type in, or browse for the manually.    
However, there are a few types of Target Files that Splash Manager knows about that are commonly 
implemented on Windows 95 (NT doesn’t support most of them, however).

When you are in the “New Splash Screen Cycle List” dialog, the 2nd step is to type in a Target File.    
Notice that on the right of the edit box, there is a “Predefined” button.    Press this button for a list of 
predefined target files.

The list of Predefined Target Files includes the following files:
1. The Desktop Wallpaper
2. The Windows 95 Startup Splash Screen
3. The Windows 95 Shutdown “Please Wait…” Splash Screen
4. The Windows 95 Shutdown “It’s Safe…” Splash Screen

When you select one and press OK, Splash Manager will figure out what file that selection represents on 
your computer, and fill in the Target File edit box for you.

Assuming you’ve typed in a Cycle List name, you’re ready to press the “Edit Cycle List” button.

That was easy!

See Also
Creating Custom System Splash Screens



Editing a Cycle List

When a new Cycle List is created, you are automatically put in the “Edit Cycle List” dialog.    This dialog 
allows you to add, remove, and order the files which are associated with the Cycle List being edited.

To edit a Cycle List, choose the Options menu (Alt+O) and select “Edit Splash Screen Cycle List”.    

Alternatively, you can press the F4 key or click the  toolbar button.



Deleting a Cycle List

When a Cycle List is deleted, the actual files contained in the list are not removed from your hard drive or 
network, only the Splash Manger Cycle List information is removed from memory.    If you want that 
change permanent, you should save the Splash Manager document.

To delete a Cycle List, select the Cycle List you want to delete from the “Splash Screen Cycle Lists” drop-
down listbox on Splash Manager’s main window.    Then, press the Delete key or choose “Delete Splash 
Screen Cycle List” from the Options menu (Alt+O).

See Also
Saving a Splash Manager Document



Creating a New Cycle List Set

A Cycle List Set is used to categorize Cycle Lists in the current document.    They act as a view filter, 
because they only allow Splash Manager to operate on the selected Cycle List Set.

Typically, you probably won’t need to use Cycle List Sets, but if you’ve got a whole lot of Cycle Lists, and 
only want to have Splash Manager operate on a subset of those Cycle Lists, then Cycle List Sets are a 
great tool.

TIP:    Splash Manager will only operate on those Cycle Lists which appear in the “Splash Screen Cycle 
Lists” drop-down listbox on Splash Manager’s main window.    Sets merely fill this list with the subset you 
define.

To create a new Cycle List Set, choose the Options menu (Alt+O), and select “Manage Splash Screen 
Cycle List Sets”.    In the dialog that appears, press the New button.    Then, you can type in a new Set 
name and your ready to start editing your new Cycle List Set.



Selecting a Cycle List Set

When you want to restrict the Cycle Lists that Splash Manager operates on, you apply a Cycle List Set 
(a.k.a. “a Cycle List Set filter”).

To select a Cycle List Set, choose the Options menu (Alt+O), and select “Select Splash Screen Cycle 
List Set”.

Alternatively, you can press the F5 key or press the  toolbar button.

A dialog will then be displayed which contains all the available Cycle List Sets.    Choose one from the list 
and press OK to activate the selected Cycle List Set.



Deleting a Cycle List Set

When a Cycle List Set is deleted, the actual files contained in the list are not removed from your hard 
drive or network, only the Splash Manger Cycle List Set information is removed from memory.    If you 
want that change permanent, you should save the Splash Manager document.

To delete a Cycle List Set:
1. Choose the Options menu (Alt+O).
2. Select “Manage Splash Screen Cycle List Sets”.
3. In the dialog that appears, select the Set you want to delete in the “Splash Screen Cycle List Sets” 

drop-down listbox.
4. Press the Delete button.

See Also
Saving a Splash Manager Document



Removing a Cycle List Set Filter

Once you have applied a Cycle List Set “view filter”, Splash Manager will always show only a subset of all 
the Cycle Lists.

To remove any applied Cycle List Set filer, so that you can view and operate on all the available Cycle 
Lists, choose the Options menu (Alt+O), and select “Show All Splash Screen Cycle Lists”.

Alternatively, you can press the F6 key or press the  toolbar button.



Creating a New System Splash Screen

A particularly fun feature of Splash Manager is the ability to create your own Windows 95 system splash 
screens.    Windows 95 has three system splash screens, all of which you can replace with your own 
splash screens.    In fact, you may have noticed this extendibility property of Windows 95 if you installed 
the Microsoft Plus! product, because it added a “Microsoft Plus!” image to the startup splash screen.

Here are the original Windows 95 splash screens:

Startup

Shutdown - “Wait…”

Shutdown - “It’s safe…”

When you create your own system splash screen, you can either start off with these pictures, or you can 



choose from a “blank screen”, or a “clouds” background:

 “Blank Screen”

“Clouds”

To begin this selection process, choose the Options menu (Alt+O) and select “Create Custom System 

Splash Screen”.    Alternatively, you can press the F2 key or click the  toolbar button.    The “New 
System Splash Screen” dialog will appear.

In the “New System Splash Screen” dialog, you must answer two questions:    What system splash 
screen you will be using the new splash screen with, and what starting background picture you would like. 
Select the appropriate buttons that match your desired usage and press OK.

Splash Manager will create a new bitmap file based on the questions you answered and will name the file 
appropriately.    The file will be automatically, uniquely number for you as well, so you can easily create 
numerous files.    These new files are loaded into a bitmap editor that ships with Windows 95 called 
“Microsoft Paint”.

Note:    If you get an error saying that “Paint” could not be found, please refer to your Windows 95 
manual on how to install it and then try this process again (go to Control Panel’s “Add/Remove 
Programs” applet, and you’ll find Paint under the Accessories group).

TIP:    If you have a Cycle List for the type of system splash screen already selected on the main screen’s 
drop-down list, then your new splash screen will automatically be added to the Cycle List for you (you’ll 
be asked).    Otherwise, you’ll have to take note of the new file name, its location on your hard drive, and 
manually add it to the appropriate Cycle List, which isn’t hard, it’s just that the former is so much more 
easy and automated why put yourself through the extra work, right?





Updating a System Splash Screen

To update a system splash screen, you should create a new Cycle List and choose the Target File from 
the list of Predefined Target Files.    For more information, please review the “Creating a New Cycle List 
Using a Predefined Target File” topic.

If for some reason you need to do this manually, here are the mappings of the system splash screens:

Splash Screen Type Splash Screen Location
Windows 95 Startup X:\LOGO.SYS*
Windows 95 Shutdown “Wait…” X:\<windows_dir>\LOGOW.SYS
Windows 95 Shutdown “It’s Safe…” X:\<windows_dir>\LOGOS.SYS

where ‘X’ is the logical drive where Windows 95 is installed; this is ‘C’ in most cases.

* - Indicates that the file may not exist.    If it does not, the internal Windows file contained in C:\IO.SYS 
is being used.



Configuring the Cycle Schedule

Splash Manager has a simple built-in scheduler which automates the task of pressing the “Cycle Splash 
Screen Target File” button on the main window.

By default, when you turn Automatic Cycle Mode “on”, the cycle process will take place every 15 minutes. 
If you want to change this frequency, choose the Settings menu and select “Set Automatic Cycle 
Schedule”.

When the Cycle Schedule dialog appears, you may choose to allow the schedule to be turned on or not 
to.    If you allow the scheduler to be turned on, then you can choose units ranging from seconds to 
minutes.

For example, to make the cycle process occur every 30 seconds, you would type 30 in the units edit box, 
press TAB, then press the letter ‘S’ to select seconds.

When you press OK, the settings are permanently saved.

See Also
Starting Automatic Cycle Mode



Starting Automatic Cycle Mode

Splash Manager will let you update the target files manually (i.e.- you press the Cycle Splash Screen 
Target File button), or you can configure the scheduler to do it for you at a periodic interval, say, for 
example, every 15 minutes.

Once of you set up the scheduler, and have at least one Cycle List shown in the main Splash Manager 
window, you can activate the “Automatic Mode” of Splash Manager.

To start Automatic Mode, choose the Actions menu and select “Start Automatic Cycle Mode”.

When you turn on Automatic Cycle Mode, depending on your general Splash Manager Preference 
Settings, the application may get minimized.    Also, if you choose to display Splash Manager in the 
Taskbar’s System Tray, then the main window will disappear.    Double click on Splash Manager’s System 
Tray icon to display the main window again.

See Also
Stopping Automatic Cycle Mode



Stopping Automatic Cycle Mode

You can stop Automatic Cycle Mode in 3 different ways:

1. From the Actions menu, select “Stop Automatic Cycle Mode”.
2. Right click on the Splash Manager icon in the Taskbar’s System Tray and select “Stop Automatic 

Cycle Mode” from the popup context menu.
3. From the Splash Manager System Menu (Alt+Spacebar), choose “Stop Automatic Cycle Mode”.

If Splash Manager’s main window was hidden, it will reappear as it was left (i.e.- if it was minimized when 
you turned Automatic Cycle Mode on, it will be minimized when you turn it off).



Cycling a Target File

Once you have defined your Cycle List, and have put at least two files in it (yes, one file is possible, but 
that would be quiet monotonous wouldn’t it?), you can update the Target File with a file in the Cycle List.

To manually update a Target File, you can either press the Cycle Splash Screen Target File button on 

the Splash Manager main screen, press the F7 key, click the  toolbar button, or you can select 
“Cycle Splash Screen Target File” from the Actions menu.

To automatically update a Target File, you can configure the built-in scheduler and turn on Automatic 
Cycle Mode.    Refer to the topic below for more information.

See Also
Configuring the Automatic Cycle Schedule



Target File Backup Management

To manually backup or restore the Target Files of the Cycle Lists in the loaded document, open the 
Manage Splash Screen Target File Backups dialog.    Do this by choosing the Options menu (Alt+O), and 
selecting “Manage Splash Screen Target File Backups”.

This dialog has several options:

Backup Options:
Check for Existence of Backup Target Files - This will scan all the Cycle Lists and verify that their 
associated Target Files have been backed up.    The 1st 10 found that have not been backed up will be 
displayed; otherwise, a success message will be displayed.

Backup All Splash Screen Target Files Now - This manually triggers the process Splash Manager would 
normally to automatically for you.    The current Target File backup preferences are used.

Restore Options:
Restore All Splash Screen Target Files Now - Searches for all Target Files, of the currently loaded Cycle 
Lists, that have been backed up, and restores them.    If one of your Cycle Lists is the Windows Desktop, 
and it has been changed with Splash Manager, you will see it automatically update to its original state.

See Also
Choosing Your Target File Backup Preference



Viewing the Target File

To view the current contents of the Target File that is associated with the Cycle List shown in the main 
window, you can view the file with the Microsoft Paint program.

To view the Splash Screen that has most recently overwritten the target file, choose the View menu 

(Alt+V), and select “Current Splash Screen”.    Alternatively, you can press the F8 key, or click the  
toolbar button.



Configuring Cycle Properties

When a Target File is “cycled” with a file from its associated Cycle List, Splash Manager chooses the file 
it gets from the Cycle List based on a particular selection method which you can define.

Recall that the “cycle process” either occurs by you pressing the Cycle Splash Screen Target File (or 
F7, etc.), or by the periodic interval determined by the built-in scheduler when Automatic Mode is turned 
on.

To configure your Cycle Properties, you need to open the Cycle Properties dialog.    To do this, choose the 
Settings menu (Alt+S), and select “Set Cycle Properties”.

This dialog offers two configurable items:    The way Splash Manager chooses which Cycle List to grab a 
file from, and then the actual method of getting a file from the Cycle List once the Cycle List has been 
chosen:

Pick a Cycle List by the following method:
Use the Current Cycle List - The Cycle List shown in the main window’s drop-down list will be used.    This 
selection allows you to confine Target File updates to one Cycle List.

Sequentially - Splash Manager will sequentially pick a Cycle List from all the entries in the main window’s 
drop-down list.    For example, if you have 4 Cycle Lists in the drop-down list, Splash Manager would 
choose the 1st entry in the list, then the next time, it would choose the 2nd entry in the list.    When it 
reaches the bottom of the list, the next cycle will “wrap” and start over with the 1st entry.

Use All the Cycle Lists - This is really just an extension of the “Use the Current Cycle List” selection in 
that instead of choosing a Target File from the currently selected Cycle List, all Target Files are updated.    
In other words, all Cycle Lists are chosen.    This is very handy if you want to update many Target Files 
with one command.

Pick a Splash Screen from the Cycle List in the following order:
Random - The Target File(s) chosen from the Cycle List(s) is chosen at random.    This allows the most 
variety, in terms of predictability.

Sequential - Target Files are chosen in order, starting with the 1st entry in the Cycle List(s).

Once you press the OK button, your selections are permanently saved.



Target File Backup Preferences

Splash Manager updates a Target File by modifying the Target File’s contents with a file in the associated 
Cycle List.    Before the file is copied, however, Splash Manager checks your Backup preferences and 
performs the appropriate action.

You can configure Splash Manager to do 3 things before the Target File is overwritten:
1. The Target File can be copied to the same directory, using the same file name with a .BAK file 

extension.
2. The Target File can be copied to an alternate directory you specify.
3. The Target File is not backed up.

Warning:    If you choose item 3, and have not manually make a copy of the Target File, then you will lose 
the original Target File’s contents.    This option is intended for advanced users or special circumstances. 
Be careful if you use this setting.

For settings 1, and 2, if the backup file already exists, then the backup is assumed to have already been 
done, and the backup is not done again.    In other words, the backup process only happens once, just as 
you would expect.

You can configure your backup options by opening the Preferences dialog.    To do this, choose the 
Settings menu and select “Preferences”.    This will open the Preferences dialog where you are given, 
among other things, the above settings for Target File backup management.



General Application Preferences

Splash Manager has several miscellaneous configurable settings.    Bring up the Preferences dialog to 
configure them.    To do this, choose the Settings menu (Alt+S), and then select “Preferences”.

Here are all the general application settings:

Target File Backup Process
Rename the file to “<original name>.bak” - This will copy the original Target File to the same directory, 
giving the file a .BAK extension.    For example, c:\windows\clouds.bmp will be copied to c:
\windows\coulds.bak.

Copy the file... - This copies the original Target File to a directory that you specify.    For example, c:
\windows\clouds.bmp would be copied to c:\backups\bitmaps\coulds.bmp if c:
\backups\bitmaps was the directory you specified.

Don’t do anything... - Gee, this should be self-explanatory.    Nonetheless, be forewarned that if you 
choose not to backup files, then it is very likely that the contents of the original Target File will be lost (it 
will be if you don’t manually make a backup of it yourself using Explorer).

Load Splash Manager when Windows starts and use the following file
You can have Windows 95 or Windows NT automatically launch Splash Manager when they start if this 
check box is enabled.    You can also optionally specify a file to load.

Start Automatic Cycle Mode when Splash Manager starts
This is only useful if you have the previous option set with a file loaded.    Assuming as much, the file will 
load, and Splash Manager will turn on Automatic Cycle Mode.

Minimize Splash Manager when Automatic Cycle Mode is started
When Splash Manager’s Automatic Cycle Mode is active, you really can’t do much with it except turn it 
off, so often people just minimize it to get it out of sight and let it do its thing.    Having this option selected 
will minimize it and do just that.

Cycle Splash Screen when Windows shuts down
If you want the cycle process to occur when Windows shuts down, enable this option (of course Splash 
Manager needs to be running at the time Windows is shutting down for this to work).

Show Splash Manager in the Taskbar
To display Splash Manager in the Taskbar, enable this option.    The Taskbar has a place where it displays 
the clock, and potentially other application services, like the sound volume, the System Agent that comes 
with Microsoft Plus!, laptop power gauge, etc.    Enabling this option will “hide” Splash Manager when 
Automatic Cycle Mode is started.    To display Splash Manager again in this situation, double-click the tiny 
icon in the Taskbar.

Play Sound when updating the Splash Screen Target File
Enable this option to select a WAV file to play every time the cycle process occurs.




