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Welcome to NEATO CD-Face
Welcome to CD-Face™, NEATO™ software for PCs and Macintosh computers that’s easy to
install and easy to learn. CD-Face provides a fast way to create attractive label art for CD-
ROMs and accurately print labels, jewel case inserts, and tray liners on NEATO stock.

Your NEATO CD-Face CD contains all the tools you’ll need for creating label art:
• Software for designing and printing labels, jewel case inserts, and tray liners.
• 66 images that make great backgrounds for your label and jewel case inserts art.
• Pre-defined templates for each type of NEATO label, tray liner and jewel case insert
• This User’s Guide (PC and Macintosh versions)
• Online Help (PC version only)
• ReadMe file (Macintosh version only)

About this Guide
Whenever you need help using CD-Face to design and print your label art on a PC, refer to the
PC section of this Guide and the Online Help. See the Macintosh section  of the Guide and the
ReadMe file in the NEATO folder if you use a Macintosh. You’ll find tutorials that lead you
through simple procedures for working with documents and printing labels, useful tips for taking
advantage of various CD-Face features, and a “reference” section that describes in detail each
menu, command, and dialog box setting.

Printing this Guide
If you’d like to print a hard copy of this Acrobat™ file for your own use and reference, feel free
to do so.  Print it as you would any other Acrobat file from your desktop.  If you’re printing to 8
1/2 by 11 paper, just be sure you choose  “shrink to fit” in the printing dialog box, as this docu-
ment is larger  than 8 1/2  by 11.  As this is a rather lengthy guide, it would be a good idea to
print a test page or two in advance of printing the whole document to be sure it’s printing 
properly.

Register with NEATO
Please complete and return the registration card. Then we can:

• Let you know about low-cost upgrades, updates and downloads.
• Let you know about other special offers.
• Let you know about development of new products.

If you’ve misplaced your card, call us at (800) 984-9800 or email us at info@neato.com.

Contact us
If you have any questions about using NEATO, need technical support, or want to order more
labels or jewel case inserts, call us at (800) 984-9800 or (203) 466-5170. If you’re calling from
the UK or Europe, reach us at +44 (0)990 561571. We can also be reached by email at
info@neato.com, and you can visit us on the web at: http://www.neato.com. Our web site has
plenty of information about using NEATO, with details about some of the most famous users of
NEATO, plus tips on how to get the most out of your software.
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Installing CD-Face Software
To get started using CD-Face, first install the software by following these simple instructions:

1. Insert  the NEATO CD into the CD drive.  If the setup program automatically runs, follow the
instructions on your screen.  Otherwise, proceed to step 2.
2. Go to the Explorer (Windows 95) or the File Manager (Windows 3.x).
3. Select the CD-ROM drive containing the NEATO CD.
4. Open the CD-Face folder and select the setup (Windows 95) or setup.exe (3.x) file.
5. Double-click on the setup icon and follow the instructions on your screen.

Starting CD-Face
To start CD-Face (Windows 95), click the Windows Start button, choose Programs from the Start
menu, choose NEATO from the Programs sub menu, then click the CD-Face 32 icon.

To start CD-Face from the Program Manager (Windows 3.x) , locate the NEATO CD-Face icon
and double-click on it. The CD-Face Window appears on the screen, ready for you to open a lay-
out document and start work.
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Designing Your Labels
You design labels by placing text and picture fields onto a label in a CD-Face layout document.
When you complete and save a design, the layout document is saved to a file.

Here’s a quick tutorial that will take you through the process of creating a label with text and
background art, then printing the finished layout.

Open a Layout Document
As this is presumably your first time using CD-Face, we’ll start by opening a new layout docu-
ment. Choose New from the File menu (or press Ctrl-n), then, from the drop-down list, select
one of the templates that we’ve set up for each type of NEATO stock, and click OK.

Hint: Use templates beginning with “US” for 8.5 by 11 inch stock, and those beginning with “A4”
if you’re using metric A4 stock. For this exercise, choose a template that contains label layouts
(with “3UP” or “2UP” in the name) matching your label stock, rather than a jewel case booklet or
tray liner.

When the document opens, if you want a larger work area you can increase the window size by
dragging the edges of the page or clicking the Maximize button.

Select a Label
Now select the label you want to work on in the document by clicking inside it (or press F7, or
choose Next Label from the Field menu). A dotted outline surrounds the selected label.

Add Some Text
Next, let’s add some basic text, perhaps a title, to the label. Go to the Field menu and choose
Add Text to CD Label 1, (or position the cursor inside the label, click the right mouse button to
display a drop-down list, and choose Add Text to Label 1) to display the Text Field Properties
Sheet.

The General Properties page should appear on your screen (if not, click the “General”  tab now
to display it). Type a title for your CD into the box labeled “Text” and click OK. Your title appears
on the label, enclosed by a striped rectangle with black squares (the text field positioning box).
Congratulations! You have successfully added a text field to the label.

Move the Text
Try dragging the title to a different place on the label. Move the mouse until the cursor is inside
the text field positioning box (if the box has disappeared, click the text to select it again). When
the cursor changes to a four-pointed arrow, click and hold down the left mouse button, then drag
the text to a new place on the label. Release the mouse button when you’re satisfied with the
positioning.

Tip: Instead of using the mouse to drag the text, you can use the arrow keys. Use Shift+Arrow to
move the text faster.
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Change the Text’s Appearance
Maybe the text size is smaller than you’d like for a title, or you want to see how it will look in a
different font. First, with the text field selected (if it is not selected, click on the title or press F8 to
select it again), choose Field Properties from the Field menu (or click the right mouse button on
the text field and choose Field Properties from the drop-down list) to display the Text Field
Properties Sheet again.

This time, click the “Format” tab to display the next page of the properties sheet. Look at the box
labeled “Font”;  your text looks just as it does on the label. Click the Change Font button to dis-
play the Font dialog box. Here you can experiment with different fonts, change the text size, its
color, and the style. The sample text shows each change you make. When the sample text looks
the way you want, click OK until you leave the Text Field Properties Sheet. Your title now
appears on the label with the changes you made.

Add Background Art to the Label
Your label will be more interesting with some artwork added. You’ll see that adding a picture is
just as easy as adding text. For this tutorial, we’ll use a picture from the Images folder that came
with your CD-Face software. These images are printed on the Background Art brochure provided
with your software.

Once again, click on the same label to select it (if it isn’t already selected). Choose Add Picture to
CD Label 1 from the Field menu (or position the cursor inside the label, click the right mouse but-
ton to display a drop-down list, and choose Add Picture to CD Label 1). This time, you’ll see an
Open dialog box on your screen, prompting you to open a file containing the image you’re going
to use. Locate the Images folders on your PC (if you haven’t copied the images to your PC, you
can open them from the NEATO CD). Choose the folder containing images with the resolution—
72 dpi or 150 dpi—that you prefer, then select or type the name of the image file to add to the
label. Click OK to open the file.

Place the Picture on the Label
The Picture Field Properties Sheet appears. Here, you see information about the picture itself
and its name (which you can change), but we’re going to continue on by making some changes
in the Options page, so click the “Options” tab to display the page. Look at the different ways you
can place the image on your label. For now, choose “Center in label (keep size).” Look at how
the image is fitted into the label at its original size.

There are two ways to save the picture in the label layout document. For this practice session,
just leave the Saving options set to “Link.” CD-Face will remember the location of the picture file
and open it whenever you open the layout document again.

Click OK to return to your layout document. That’s all it takes to add a picture!

Display the Title in Front
You have a little more to do, however, to finish the label design. You may have noticed that when
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the picture appeared on the label, your title disappeared. No need to worry that it was erased;
it’s still there, but  the picture was placed over it . To show the title again, just click on the pic-
ture in the label to select it, and choose Move Back or Send to Back from the Field menu (or
press F4 or Shift-F4) to move the picture under the text.

Run a Test Print
We’re now ready to print the label. First, however, it is a wise practice to run a test print with
regular paper in the printer to make sure the text is correctly aligned. Choose Calibrate Printer
from the File menu, then click Test Print. Take a look at how your output prints in relation to the
label boundary that CD-Face draws around the text.

Did your text print exactly within the label, or does it run off the edge? If it needs some adjust-
ment, use the Printer Calibrate command in the File menu to move the text in the desired direc-
tion. Shift the text horizontally or vertically by entering values in one thousandths of one inch, or
stretch or shrink it until the test label looks accurate. (See the Printer Calibration section for
more detailed instructions.)

Print the Label
When you’re satisfied with the calibration, you can try printing on your regular label stock. Feed
one page into the printer.  From the File menu, select “Print.” This displays the Print dialog box.
Make sure you have the correct printer selected, then click OK. Just one page will print.

Take a well-earned break, then try creating a jewel case booklet and tray liner.

Creating a Jewel Case Booklet
Now that you understand the basics of creating a label, designing a jewel case booklet for your
CD is just as easy. As with a label, you use a template, so choose New from the File menu, and
open one of the templates named “book.” Look at the layout document that appears. It is divid-
ed into two booklet pages. For this tutorial, we’ll create a front cover (using the right page in the
layout) and a back cover (on the left page).

Add Text to the Front and Back Covers
To begin, let’s add some text to the front cover. First, choose Add Text to Book 1 from the Field
menu. Then, go through the same steps (use the Text Field Properties Sheet) to set the text’s
font, style, color, position and so on, just as you did when you designed the title for your CD
label.

Move between the two booklet pages in the layout document by clicking the mouse. Click inside
the left page to select it, then add some more text to the back cover.

Add Some Artwork
When you’re satisfied with the appearance of the text, you can place a picture on each cover.
Again, do this exactly the same way as you did to create the label. Use a picture from the CD-
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Face Images folder, or use one of your own images. Make sure you don’t cover the text when
you place the picture (use the Move Back or Send to Back command to move the picture behind
the text again).

Creating a Tray Liner
Designing tray liners is just as straightforward as creating labels or jewel case inserts. Again,
choose New from the File menu to open a template (open a file with “tray” in its name). This
time you’ll see that, unlike labels or jewel case booklets, the layout for a tray has two thin fields
along the left and right edges of the tray. These fields are where you enter text for the spines.

Add Text and Artwork to the Tray Liner
Click the square in the middle of the layout to select it, then add text and background art to the
tray liner using the same methods as you did on the label and jewel case booklet.

Add Text to the Spines
The spines of the tray liner are the narrow fields at the left and right edges of the layout docu-
ment. To add text along the spines, follow the same basic steps you’re familiar with by now.
First, click inside the left spine to select it. Choose Add Text to Left Edge 1 from the Field menu,
type some text that will run along the spine, and select the font, size, color, and so on for the
text. 

Hint: Be sure to choose a True Type font, otherwise CD-Face will not angle the text. Also, be
sure to choose a text size that will fit inside the spine.

Up to now, all the text you’ve created has been “flat;” that is, it runs horizontally from left to right.
However, you need to position text vertically in a tray liner spine, and we’ve provided a format-
ting option that allows you to do exactly that.

Click the Style button in the Text Field Properties Sheet, and click the Angled button. Tell CD-
Face the angle for the text. Enter a number in degrees—type 90 degrees to position the text
vertically. Click OK till you exit the Properties Sheet and return to the layout document, which
now shows your text running the length of the left spine. Drag the selected text field with the
mouse to place it exactly where you want it along the spine.

Return to the Text Properties Sheet by clicking on the text to select it again (if it is not selected),
then choosing Field Properties from the Field menu. From the Style page, now try entering 270
degrees, which is the second way to position angled text vertically. Click OK to return to the doc-
ument, where you’ll see that the text now runs in the opposite direction.

Click to select the spine on the right edge of the document and add some text. When you enter
the text angle this time, you can ensure that the text runs in the opposite direction by entering
the “negative” of the angle used for the left spine. In other words, if the text in the left spine is at
a 90 degree angle, set the text angle for the right spine to -90. Click OK to return to the docu-
ment and view the results.
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Handy Tips and Shortcuts
CD-Face allows for considerable flexibility in how you can add and place text and pictures in
layout documents. Here are a few tips and shortcuts to try after you become familiar with the
basic processes.

Positioning Text Fields
More than one method is available for positioning text fields. You can use the Align Left, Align
Center, and Align Right commands in the Field menu to position a text field horizontally within
its label. If you prefer, simply drag a selected text field manually using the mouse. Click and
hold down the left mouse button and drag the text to a new position. Or, use the arrow keys on
your keyboard to move the field (be sure to select the field first). To move a field more quickly,
hold down the Shift key as well as the arrow key.

Make a text field larger or smaller by clicking the text to select the field. Then, drag the grab
handles (the black boxes on the positioning box) in the desired direction.

Entering Measurements
When you use CD-Face, you’ll occasionally be asked to enter a measurement (for instance,
the distance for the Radius to Text center when you set up curved text). CD-Face recognizes
measurement units of inches, millimeters, and points, and the Ruler in the window always dis-
plays the currently selected units. The default measurement unit is set in the Page Properties
dialog box; however, you can override the default when you enter a value into a dialog box.
Just add a space and the unit’s abbreviation ( “in” for inches, “mm” for millimeters, and “pt” for
points). For example, the following two entries are exactly equivalent: “1.0 in” and “25.4 mm.”

Note: Regardless which measurement units you use, CD-Face works in tenths of a millimeter
(0.1 mm) internally when it processes your settings. As a result, when you enter values in other
units than metric, you may see some minor differences due to the conversions. The conversion
values are:

1 inch = 25.4 mm (source: Handbook of Chemistry and Physics, 55th Ed. 1974-1975)
1 point = 0.013837 inch (source: Win32 SDK, Graphics Device Interface, Fonts and Text, About
Fonts)

Working with Several Documents at Once
Although you can open more than one open layout document at a time, CD-Face runs faster
and more efficiently when a single page layout document is open. If you would like to work with
a second document and make only minor modifications, save the document under a different
name.

Working with Curved Text
Unlike flat text, which you can drag to a new position in a layout document, curved text cannot
be dragged. Instead, use the Rotate Clockwise, Rotate Counter Clockwise, or Field Properties
commands to move curved text to a different place.
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Picture Size
For working most efficiently with graphic images in a layout document, the smaller the size of
the image file, the better. If you plan to add many pictures to one layout page, consider working
with files that are not too large. Unless you save the pictures as links to files on your computer,
the entire picture is stored within the document. If you embed the picture instead of saving a
link, remember that RGB format is less memory intensive than CMYK. The resolution of the
image also affects the size of a layout document. If you are working with a printer that prints at
300 dpi, there’s no advantage  in working with images saved at 720 dpi. Smaller files take less
time to open and less time to edit.

Importing Pictures Smaller than the Label
When you use pictures (such as company logos) that are not meant to completely fill the label,
make sure you select “None” in the Picture Field Properties Sheet’s Options Page. The image is
dropped onto the label as is, at its current size. If the image needs further re-sizing, grab one of
the square black handles with the mouse and drag the handle until the image is the size you
want.

Using Databases
When you create label art, you have quite a bit of flexibility in the types of text you can enter;
you’re not restricted to simply typing text into layout documents through the Text Field Properties
Sheet. One way CD-Face does this is to take information already saved in a database and turn
it into text. You can easily set this up by using special text fields that take information from a
database and add it to a label. The text that is displayed (and printed) is not the text you enter,
but information from a database.

To step through the process of creating a Database link, see the next section, Database
Tutorial.

Database Tutorial
Note: CD-Face accesses databases using Open DataBase Connectivity (ODBC). If you don’t
have ODBC installed on your PC, the “Database Field” option is unavailable. See Using
Databases and Database Tutorial for an overview of using databases with CD-Face.

This tutorial shows you how to use database information as text on labels. To step through the
exercise exactly as it’s described here, first set up a small database with the same name,
tables, and field as the Sales Information database in the example. If you already have a data-
base to practice with, just enter the names of your database, table, and field instead of  using
the example. If you prefer not to actually use a database yet, just read over the tutorial to get a
quick idea of how databases are used.

Suppose you want to print some personalized CD labels for your customers from a database
called Sales Information. In that database is a Customers table with fields for customer names,
addresses, phone numbers, and contacts. The Customers table looks like this:
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CustName CustAddress CustPhone CustContact
Acme 123 Main Street 800-555-4111 Jane Acme
Ajax North Avenue 800-555-1111 John Doe
NEATO 250 Dodge Ave 203-466-5170 Anthony Bussio
CCC PO Box 502 203-481-6940 Matt Sanchez
US Widgits Front Street 800-555-9999 Mary Smith

On each label, you want to print the name of a customer. Here’s how.
(By the way as you follow this tutorial, if you need to refresh your memory about opening doc-
uments and creating text fields, refer to Designing Your Labels, earlier in the Guide).

Open a Layout Document
Open a new or existing label layout document, then create a text field and set up the text’s
font, size, style, color and so on, just as you’ve done before.

Link the Text Field to a Database
Now you’re ready to set up a database link. From the Text Field Properties Sheet, click the tab
marked “Special” to display the Special Properties Page. Under Computed Text, you see sev-
eral buttons. Click the button marked Database Field to display the Select a Database Field
dialog box, where you’ll identify the database and field to link to.

Choose a Database
The Databases list box lists all the databases available. Find and select the Sales Information
database from the list. You’ll immediately see the names of the database tables in the Tables
list box, including the table you want, Customers.

Choose a Table
From the Tables list box, select Customers. As soon as you select the Customers table, the
names of all the fields (in other words, information about your customers) appear in the Fields
list box, including the field you want, CustName.

Choose a Database Field
From the Fields list box, find and select the field named CustName, which is the field you plan
to display as text. CD-Face will take a customer name and place it on each label that has a
similar text field. Leave the dialog box and Properties Sheet by clicking OK.

Check the Customer Name on the Label
Now that the layout document is visible again, look at the text field you just created on the
label. You’ll see the name of the first customer in the Customers table.  You’re almost done -
that’s all it takes to link a database to a text field!

Link the other Labels in the Document
To have a customer name print on every label, duplicate the text field on the labels in the tem-
plate you’re using. Each time CD-Face prints a label, the next customer name appears on the
label
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Printing Labels with Database Links
When you’re ready to print (using the Print command or the Test Print button in the Printer
Calibration dialog box), CD-Face automatically figures out how many pages will be needed to
print a label for every entry in the database table.

Print Every Label at One Time
First, CD-Face calculates the number of pages to print, based on the number of customers
(table entries) and the number of labels on the template (remember to duplicate the text field on
each label on the layout document). Our sample table has five customers, so if you are using a
3-UP template with three labels, two pages will print. For a two-label template (2-UP), the five
labels will print on three pages.

Print a Few Labels at a Time
You don’t have to print labels for every table entry at once. Instead, you can print just a few
pages at a time. This is helpful when you are working with large databases that require printing
many labels. CD-Face keeps track of the labels that should be printed on which pages. 

If you are using 2-UP labels and you select All for the page range (in the Print dialog box), three
sheets print. On the first sheet are labels for the first two customers, Acme and Ajax. The sec-
ond sheet prints NEATO and CCC labels, and US Widgets appears on the last sheet. If you only
want page two to print, select 2 to 2 as the page range in the Print dialog box. CD-Face knows
you started on the second page, so it prints only the labels for NEATO and CCC.

Using Number Sequences
You can add another type of special text, a Number Sequence, to labels. This is a number that
CD-Face tracks, increasing it by one in each label that contains the same sequence. You’ll find
this very useful for printing labels that use a series of unique numbers such as serial numbers
and other types of counters.

A number sequence has two parts, its name and its starting number (set by you). The starting
number prints on the first text field containing the number sequence. Each time a label is printed
with the same the number sequence, CD-Face increases the number by one.

If the template you are using has more than one label, there is one item you need to be very
careful about. If you want the first number of the sequence to print the first label, and the second
number in the sequence to print on the next label in the template, make sure the text  field uses
the same sequence name on both labels. Remember, CD-Face uses the Sequence Name to
link the text field to a particular number. If you make a mistake, use the Number Sequence dia-
log box to view the sequence names and to make your corrections.
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File Menu
Use the File menu commands to open and close your CD-Face layout
documents, to calibrate and test the printer for accurate printing of label
art, and to print your design on NEATO stock.

New
Choose New from the File menu (or press Ctrl-n) to create and 
open a new CD-Face layout document. The Select Template dialog 
box appears, displaying a list of ready-to-use templates for each 
type of NEATO label stock.

From the template drop-down list, select a template that matches your NEATO stock. 
Templates beginning with “US” are for 8.5 by 11 inch stock, and those beginning with “A4” 
are for metric A4 stock. CD-Face opens your selection in a new window.

Open
Choose Open from the File menu (or press Ctrl-o)  to open an existing CD-Face layout 
document. The Open dialog box appears, where you find and select the directory and 
name of the file to open.

Hint: Instead of using Open to open a file you recently closed, you can select the file from 
the File menu (if it appears there). CD-Face immediately opens the file in a new window.

Open Dialog Box
Look in: Select the location (directo-
ry, drive, folder etc.) of the CD-Face 
layout document to open.

File name: Type the name of the file 
into the box (you can also double-
click a filename in the list box). 

Files of type: The names of all files 
in the “Look In” directory with this 
extension appear in the list box. You 
can display CD-Face layout docu-
ments (*.ntp) or every file in the 
directory (*.*). Note: Even if you choose All Files, you can only open CD-Face documents 
in the CD-Face application.

Tip: You can open and work on more than one layout document at a time. Use the 
Window menu to switch among the documents. See Window 1, 2, ... .

File Menu

Open Dialog Box
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Close
Choose Close from the File menu (or click the Close icon on the document window) to 
close a window containing an active layout document. If you made changes to the docu-
ment since it was last saved, you’ll be prompted to save it before closing.

Save
Choose Save from the File menu (or press Ctrl-s) to save a layout document to its current 
directory, with the same filename. 

When you save a layout document for the first time, the Save As dialog always appears so 
you can name the file and tell CD-Face where to store it. CD-Face saves the document 
with an extension of .NTP (for NeaTo Page).

Save As
Choose Save As to save and name a layout document. The Save As dialog box appears 
so you can rename the file and/or save it in a different location.

Save As Dialog Box
Save in: Select a directory if you want 
to store the file in a new location.

File name: Type a new name for the 
file if you want to save it under a new 
name.

Save as type: Shows the file type. “ntp”
is the extension NEATO uses for CD-
Face layout  documents.

Print
Choose Print from the File menu (or press Ctrl-p) to print the current document. A stan-
dard Print dialog box appears. Choose the printer, the range of pages and number of 
copies to print, then click OK to start printing. Click Print to file to print the document to a 
file instead of a printer.

Print Setup
Choose Print Setup when you want to change settings for your printer. A standard Print 
Setup dialog box appears. Choose the printer, paper size, which paper tray to use, the 
page orientation, then click OK to complete the setup.

Save As Dialog Box
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Printer Calibrate
Choose Printer Calibrate to calibrate and test the 
printer until you know the layout will print exactly 
on NEATO stock. 

Printer Calibration Dialog Box
Offsets (Horizontal; Vertical): Enter the amount 
(measured in thousandths of one inch) to slightly 
shift your label art horizontally and vertically until 
it fits exactly in the stock. To shift the printed out
put right by 50 thousandths of one inch (.05”), 
enter 50 in the Horizontal Offset box; to shift it left, 
enter -50. To move the output down the sheet, 
enter a positive number into the Vertical Offset 
box; enter a negative number to move the output 
further up the sheet.

Stretch (Horizontal; Vertical): Enter an amount into 
the Horizontal Stretch box to slightly expand or shrink your printed output horizontally in 
0.1 percent increments until it fits the stock. Use Stretch if your printed output lines up 
correctly on the left side of the label stock, but progressively becomes unaligned towards 
the right side. Enter an amount into the Vertical Stretch box to make vertical adjustments 
in 0.1 percent increments. Use this setting if the output lines up correctly at the top of the 
sheet, but progressively becomes unaligned towards the bottom.

Test Print: Click this button to print a test page on regular paper so you can see how your 
output lines up before you print on NEATO stock. CD-Face draws a box or a circle around 
the outside margin of each label so you can check your printer ‘s calibration. Readjust the 
calibration until you’re satisfied that the output will print exactly.

1, 2, 3, 4
The names of up to four CD-Face layout documents that you most recently closed always 
appear at the bottom of the File menu. Open one of these files by selecting the entry.

Exit
Choose Exit from the File menu (or double-click the Control menu button or press Alt-F4) 
to end your CD-Face session. If you were working on any docu-
ments with unsaved changes, the Save As dialog appears before 
closing.

Edit Menu
Use Edit menu commands to cut, copy, and paste text, shapes, and 
pictures and to undo or redo editing actions.

Printer Calibration Dialog Box

Edit Menu
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Undo
Choose Undo from the Edit menu (or click the Toolbar icon or press Ctrl-z or Alt-
Backspace) to reverse your last editing action.

Redo
Choose Redo from the Edit menu (or press Ctrl-y) to redo the effects of the last Undo 
command.

Cut field
Choose Cut field from the Edit menu (or click the Toolbar icon or press Ctrl-x) to remove 
a selected field from the layout document and place it in the clipboard, replacing the
previous contents of the clipboard. Cut field is available only when a field is selected.

Copy field
Choose Copy field from the Edit menu (or click the Toolbar icon or press Ctrl-c) to copy a 
selected field from the document to the clipboard, replacing the previous contents of the 
clipboard. Copy is available only when a field is selected.

Copy All Fields
Choose Copy All Fields to copy all fields from the current label to the clipboard, replacing 
the previous contents of the clipboard. Copy All Fields is available only when a label is 
selected.

Paste
Choose Paste (or click the Toolbar icon or press Ctrl-v) to insert the clipboard contents 
into the current label. Paste is unavailable if the clipboard is empty.

Delete field
Choose Delete (or press the Delete key) to remove a selected field from the current 
label. Delete is available only when a field is selected.

Field Menu 
Use the Field menu commands to work with text, picture, and shape fields in a layout 
document.

Add Text to…
Choose Add Text to… from the Field menu (or click inside the current label using the 
right mouse button, or click the Toolbar icon) to add a new text field to the current label. 
The Text Field Properties Sheet appears, where you type in text and set the “look” of the 
text.
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Text Field Properties Sheet
Use the Text Field Properties Sheet to add text to a text field 
and set the format, style, and special options for the text. Click 
on the General, Format, Style, and Special tabs to move 
between the four text property pages and set up the text field.

Text General 
Properties Page
Text: Type into this 
box the text you 
want on the label. 
The amount of text 
you can enter in 
the box is not 
limited to the 
visible area, so 
continue typing if 
you have more to 
add. Note: 
CD-Face ignores 
this text if you use Special Text (see Text 
Special Properties Page).

Name: This is simply a name for the text field. 
You can use the name already provided, or 
enter another. CD-Face uses this name for 
reference only, so you don’t need to follow 
normal naming conventions, other than it 
should be a unique name.

Text Format Properties Page
Background: Sets a background color for the 
text on your screen. “Same as Page” paints the 
same color background for the text and page—
white is the default. (To change the color of the 
page background, use the Page Property Sheet.) “Transparent” provides no background 
color at all. (This is the best selection for when you use curved text or when your text 
sits on top of a picture.) “Custom Color” paints a color you choose for the background. 
Select Custom Color, then click the Colors button to display a standard Color dialog box 
and choose a background color.

Change Font: Click this button to display the Font dialog box and set the font, style, size, 
color, and effects for the text. CD-Face supports all the fonts installed in your Windows 
system.

Text Field Properties Sheet

Text General Properties Page

Test Format Properties Page
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Note: Some text properties only work with certain fonts. For example, if you select the 
Angled or Curved style for the text, be certain you’ve selected a TrueType font. A
TrueType font is a font with the TT symbol.

Text Style Properties Page
Flat: Click Flat to create text that is not drawn 
at an angle on the label. You can drag flat text 
anywhere in the label using the mouse.

Use the “Alignment” settings to position flat 
text within its positioning box (the striped 
rectangle on your screen) as follows.

Horizontal Alignment: Positions flat text 
horizontally in the positioning box. Choose Left
to place the start of the text at the left margin 
of the box; choose Center to center the 
text horizontally in the box, choose Right to 
align the text exactly on the right margin.

Vertical Alignment: Positions flat text vertically in the positioning box. Choose Top to posi
tion the text flush with the top edge of the box, choose Center to center the text vertically 
in the box, and choose Bottom to align the text flush with the bottom of the positioning 
box.

Angled: Click Angled to draw text at an angle on the label. Use the “Angle” setting to 
specify the angle. You can drag angled text anywhere in the label using the mouse. Note:
Angled text is always centered within its positioning box (the striped rectangle).

Angle: The text’s angle. Enter a value (in one degree increments) between -359 and 359.
At 0 degrees, the text runs horizontally left to right and appears flat. At 90 degrees, the 
text runs bottom to top. At 180 degrees, the text is upside down.

Curved: Curved text curves around the label in an imaginary circle whose center is in 
the middle of the label.

Radius to Text Center: The distance from the centerpoint of the label to the centerline of 
the curved text.

Angle: The angle from the label’s centerpoint to the midpoint of the line of text. The 
default angle is 90 degrees. At this setting, the curved text is above the label’s center, 
and the text is equally spaced on either side of an imaginary vertical line through the 
label’s center.

Text Style Properties Page
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Character Spacing: The distance between each text character. The default is zero (no 
extra spacing is added). Hint: Because, depending on the font, the appearance of the 
text sometimes improves with additional spacing, you should experiment to see what 
looks best.

Inverted: When selected, each character prints upside-down, and the order of the 
characters is reversed. This is useful for placing curved text at the bottom of a CD label 
so it is readable without rotating the CD.

Text Special Properties Page
CD-Face can generate “computed” text for text fields to create a date, run a number 
sequence that increases by one each time you 
print, or use data from a database.

None: CD-Face uses the text you type into the 
Text General Properties Page. “None” is the 
default setting.

Date: A date is created for the text field on the 
label. Choose the date type as follows:

Date Format: From the drop-down list, select a 
format for the date that will appear on 
the label. The default format is “month, year” 
(for example, January, 1997).

Use today’s Date: Check the box to display today’s date on the label.

Date: Available only when Use today’s Date is not checked. Click to display the Set Date 
dialog box and enter a date you want to appear on your labels.

Set Date Dialog Box
Use the Set Date dialog box to enter a date as 
the text field.

Type the number of the month, the day of the 
month, and the year. For January 23 1997, 
you’d type 1, 23, and 1997.

Number Sequence: Select Number Sequence 
to create a number sequence as the text field.  
The Number sequence dialog box appears for 
you to set up the sequence. (The dialog box 

Test Special Properties Page

Set Date Dialog Box
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also appears when you open the Text Field Properties Sheet for an existing number 
sequence.  Click the Select button to display the dialog box and make any changes to 
the information in it.) For more information on using number sequences, see Using 
Number Sequences. Specify the sequence as follows:

Number Sequence Dialog Box
Sequence Name: The name of the number sequence. 
CD-Face uses this name to identify and display the 
sequence with the correct numbers.

Start Number: The starting number for the sequence. 
Each time you print a label with a text field that 
contains this number sequence, the number 
automatically increases by one. For instance, if the 
starting number is 1000 and you print two labels 
containing the same number sequence, “1000” appears 
on the first label, and “1001” on the second label.

Database Field: Use a field from a database as the text field. When selected, the Select 
a Database Field dialog box appears.

Note: CD-Face accesses databases using Open DataBase Connectivity (ODBC). If you 
don’t have ODBC installed on your PC, the “Database Field” option is unavailable. See 
Using Databases and Database Tutorial for an overview of using databases with CD-
Face.

Select a Database Field Dialog Box
Use the Select a Database Field 
dialog box to tell CD-Face to use a 
field in a database as a text field.

Databases: Lists the available data
bases on your computer. Select a 
database containing information to 
use as a text field. CD-Face 
immediately connects to the database,
reads the names of tables in the data
base, and displays the table names in 
the Tables list box.

Tables: Lists the available tables in the selected database. Select the table containing 
the field to use. When you select a table, CD-Face queries the database for the names 
of all fields (columns) in the table, then displays the field names in the Fields list box.

Set Date Dialog Box

Database Field Dialog Box
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Fields: Lists the available fields in the selected table. Select the field whose contents 
you want to use as text in your label layout.

Define: Click this button to define a new database “on the fly.” When you successfully 
define a new database, the database name appears in the Databases window. Be 
careful using “Define” unless you are comfortable configuring databases for ODBC.

OK: Click OK to confirm your selection and close the Select Database dialog box. This 
button is available only after you have selected a Database, a Table, and a Field. Click 
Cancel to leave the dialog box without making a selection.

Add Picture to…
Choose Add Picture to… (or click the Toolbar icon) to add a new picture field to the 
current label. Select a picture file and open it from the Open dialog box. The Picture 
Field Properties Sheet appears.

Note: CD-Face does not support every picture format. For example, the Compuserve 
GIF format is not supported by CD-Face due to licensing restrictions.  If you see an 
error message, it usually means that CD-Face does not recognize the file format. 

Picture Field Properties Sheet
Use the Picture Field Properties 
Sheet to view information about 
the picture field and set field 
options. Click on the tabs to move
between the General Properties 
and Options Properties Pages.

Picture General 
Properties  Page
The General Properties Page 
provides information about the 
picture field—the path and file
name of the picture file, the picture’s 
dimensions in pixels, the color resolution 
of the image (bits per pixel), and a field 
name assigned by CD-Face. Enter a 
different name for the field if you prefer.

Picture Field Properties Sheet

Picture General Properties Page
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Picture Options Properties Page
Use the Picture Options Properties 
Page to position the picture field on 
the label, and to save the picture.

Positioning: Select “None” to drop the 
picture into the label at its current 
size. The “None” setting is most useful
if you’ve created a CD-size image 
using another program, or if you are 
working with a small picture. The 
image may need further re-sizing to 
fit. 

Choose “Size to exactly fill the label” (the default setting) to import standard pictures. 
CD-Face ‘knocks out’ the part of the picture that will not appear on the label and sizes it 
to cover the full label. 

When “Center in label” is the choice, CD-Face adds the picture at its full size, but places 
it in the center of the image rather than the top left hand corner of the label (which the 
None option does).

Saving: Choose “Embed” to save the actual image in the page layout document. This 
creates a larger page layout file than if you select “Link,” but it is a more reliable option 
because CD-Face does not have to search for the picture file when it opens a layout 
document. Saving the picture in the document also lets you easily transfer the page lay
out to other CD-Face users.

Choose “Link” to save the path to the picture instead of embedding the actual image in 
the document. This method uses less disk space than when the picture is embedded in 
the page layout. If you select “Link,” however, be cautious! If you subsequently move the
picture file, or if a remote user opens the layout document, CD-Face will not be able to 
locate the linked picture file. Make sure you keep accurate records of the locations of 
linked files for ease of future use.

New Shape Field
Choose New Shape Field and choose a shape from the sub menu (or click a shape 
icon on the Palette Bar) to add a shape to the selected label. You can add these 
shapes:

Solid Line
Open Rectangle: The center of the rectangle is transparent.
Open Ellipse: The center of the ellipse is transparent 
Open Rounded Rectangle: The center of the rounded rectangle is transparent.

Picture Options Properties Page
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Filled Rectangle: The center of the rectangle is solid.
Filled Ellipse: The center of the ellipse is solid. 
Filled Rounded Rectangle: The center of the rounded rectangle is solid.

Use the Palette Bar to change the line color and thickness and the shape’s solid color. 
For details about using the Palette Bar, see Palette Bar. See also information about the 
Drawing Shape Properties Sheet in Field Properties.

Align Left
Choose Align Left (or click the Toolbar) to move a selected text or shape field 
horizontally so it is flush with the left edge of the label.

Align Center
Choose Align Center (or click the Toolbar) to move a selected text or shape field 
horizontally so it is centered within the label.

Align Right
Choose Align Right (or click the Toolbar) to move a selected text or shape field 
horizontally so it is flush with the right edge of the label.

Move Forward
Choose Move Forward (or press F3 or click the Toolbar) to move a field forward one 
layer. Moving fields forward uncovers them from overlapping layers and makes them 
visible.

Move Back
Choose Move Back (or press F4 or click the Toolbar icon) to move a field backward one 
layer. Moving fields backward may make other fields visible.

Bring to Front
Choose Bring to Front (or press Shift-F3 or click the Toolbar icon) to make the selected 
field the uppermost layer.

Send to Back
Choose Send to Back (or press Shift-F4 or click the Toolbar icon) to make the selected 
field the bottom-most layer.

Rotate Counter Clockwise
Choose Rotate Counter Clockwise (or click the Toolbar icon) to rotate Flat and Angled 
text counter clockwise by 10 degrees. Curved Text will be rotated around the label, 
maintaining its Radius to Center.

Rotate Clockwise
Choose Rotate Clockwise (or click the Toolbar icon) to rotate Flat Text and Angled Text 
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clockwise by 10 degrees. Curved Text will be rotated around the label, maintaining its 
Radius to Center.

Snap to Fit
Choose Snap to Fit (or press F5) to exactly fit the selected text field to the label 
boundaries. Note that this command affects only Flat Text and Angled Text. It has no affect 
upon Curved Text or Picture Fields.

Next Label
Choose Next Label (or press F7) to select the next label in the layout document

Next Field
Choose Next Field (or click F8) to select the field closest to the currently selected field. 
Use this command repetitively to find hidden or lost fields in your label.

Field Properties
Choose Field Properties to display the field property sheet for a selected text, picture, or 
shape field.

For information about the Text Field Properties Sheet, see Add Text to. 

For information about the Picture Field Properties Sheet, see Add Picture to.

Drawing Shape Properties Sheet
Choose Drawing Shape 
Properties Sheet from the Field 
Properties sub menu of the Field
menu.

The sheet consists of a General 
property page that describes the 
type of shape for the selected 
field and names the field. You 
can keep the default shape field 
name, or enter another name, 
and you can change the 
selected field to a different 
shape by selecting a new shape 
type from the drop-down list.

Drawing Shape Properties Sheet
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Page Menu
Use the Page Properties command in the Page
menu to set up the page for the current 
layout document.

Page Properties
Choose Page Properties to display the Page Properties Sheet

Page Properties Sheet
The Page Properties Sheet shows the current settings 
and other options for your layout document. The sheet 
contains separate pages for general properties and 
page size properties.

General Properties Page
Units: Choose the measuring unit you want 
CD-Face to use—inches, millimeters, or 
points. This is the unit of measure displayed 
on the rulers. It is also used for 
measurements in fields (such as the Radius 
to Circle value for curved text).

Color: Click Color to display the Select 
Stock Color dialog box and select a stock 
color that matches your NEATO label stock. 
This color will NOT print; it’s simply to help 
you compare color matches on screen when
you select colors for your design. 

Page Size Properties Page
Page Size: Select the page size for your 
layout document. Match the size to your 
NEATO label stock’s page size. If you select 
Custom, enter the custom width and height 
of the page.

Page Menu

Page Properties Sheet

General Properties Page

Page Size Properties Page
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View Menu
Use the View menu to change how you view
your document.

Zoom In
Choose Zoom In (or press +) to increase 
the magnification of the view by 20 percent.

Zoom Out
Choose Zoom Out (or press -) to decrease 
the magnification of the view by 20 percent.

Fit Height
Choose Fit Height to adjust the magnification of the view to fit the entire height of the 
layout page into the window.

Fit Width
Choose Fit Width to adjust the magnification of the view to fit the entire width of the lay
out page into the window. This is the default setting.

Toolbar 
Use this command to display and hide the Toolbar. 

The toolbar is displayed across the top of the application window, below the 
menu bar. It provides quick mouse access to many of the commands used 
in NEATO CD-Face.

To hide or display the Toolbar, choose Toolbar from the View menu (or press
Alt-v+t). A

check mark appears next to the Toolbar menu item when the Toolbar is 
displayed. Here’s a list of the available Toolbar items:

Open a new document
Open an existing document
Save the active document with its current name
Print the active document
Cut selected data from the document to the clipboard
Copy the selection to the clipboard
Paste the contents of the clipboard at the insertion point
Undo the last editing. Note: You cannot undo some actions
Move the selected field forward, in front of the next field
Move the selected field back, behind the next field
Rotate the selected text 10 degrees counter clockwise
Rotate the selected text 10 degrees clockwise
Align the selected field flush with the left side of the label

View Menu

Toolbar
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Align the selected field horizontally in the center of the label
Align the selected field flush with the right side of the label
Increase the magnification by 20 percent
Decrease the magnification by 20 percent
Display the CD-Face About dialog box
Enter context-sensitive Help mode

Status Bar 
Use this command to display and hide the Status Bar.

The status bar appears at the bottom of the NEATO CD-Face window. It describes the 
actions performed by selected menu items or toolbar buttons, and provides some details. To 
display or hide the status bar, use the Status Bar command in the View menu.  A check 
mark appears next to the Status Bar menu item when the Status Bar is displayed.

The left area of the status bar describes the actions of menu items as you use the arrow 
keys to navigate through menus. This area also describes the actions of each toolbar button 
as you press it. If you decide not to use the command, release the mouse button while the 
pointer is off the toolbar button.

The right areas of the status bar indicate when the Caps Lock key is latched down, and 
show the cursor’s position relative to the left and right edges of the page.

Palette Bar
Use this command to display or hide the Palette Bar, which provides shortcuts and tools for 
working with fields. The Palette bar is displayed as a separate, moveable window. A check 
mark appears next to the menu item when the Palette Bar is displayed.

The Palette Bar has three main sections. The top section provides a quick way to add text, 
pictures, and shapes to the current label. You can:

Add a text field. Shortcut for the Add Text menu command.
Add a picture field. Shortcut for the Add Picture menu command.
Add a line. Shortcut for the Add Line menu command.
Add an open rectangle. Shortcut for the Add Open Rectangle menu command.
Add an open rounded rectangle field. Shortcut for the Add Open Rounded Rectangle 

menu command.
Add an open ellipse field. Shortcut for the Add Open Ellipse menu command.
Add a filled rectangle field. Shortcut for the Add Filled Rectangle menu command.
Add a filled rounded rectangle field. Shortcut for the Add Filled Rounded Rectangle 

menu command.
Add a filled ellipse field. Shortcut for the Add Filled Ellipse menu command.

Use the middle section of the Palette Bar as a quick way to change colors in a selected text 
or shape field. The two overlaid boxes display the current colors in the field. To change the 
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color of the upper box, click on a new color using the left mouse button. To change the color of
the lower box, click on a new color using the right mouse button. The effect of the colors 
depends upon the type of field.

For text fields, the upper box shows the text’s color, and the lower box displays the back
ground color. Note that the background color does not display if you selected Transparent 
for the background in the Format page of the Text Field Property Sheet.

For lines, the upper box shows the line color (the lower box is not used). For rectangles 
and ellipses, the upper box shows the color of the outline, and the lower box displays the  
solid color of a filled shape.

The bottom section of the Palette bar provides a quick way to adjust the line widths on 
lines, rectangles and ellipses. Click a line to select a new width.

Window Menu
Use the Window menu commands to arrange your view of several open
documents in the software window.

New Window
Choose New Window to create a new window containing a second 
copy of the current document window.

Cascade
Choose Cascade to arrange multiple open windows so they overlap on the screen.

Tile
Choose Tile to arrange multiple open windows in a non-overlapped fashion.

Choose Arrange Icons to arrange the icons for minimized windows at the bottom of the 
main window. If an open document window covers the bottom of the main window, the 
icons may not be visible because they will be underneath this document window. 

Window 1, 2, ...
All open document windows are listed at the bottom of the Window menu. A check mark 
appears in front of the document name of the active window. Choose a document from this 
list to make its window active. 

Help Menu
Use the Help menu to get online help.

Help Topics
Choose Help Topics to display the CD-Face Help Index. From the opening screen, you can 
jump to step-by-step instructions for using CD-Face and also look up various types of 
reference information about menus, commands, and dialog boxes. Click the Contents 
button to return to the Index. Select Exit to return to CD-Face.

Window Menu

Help Menu
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About NEATO
Use this command to display the copyright notice and version number of your copy of 
NEATO CD-Face, and to find how to contact us at NEATO.

Glossary
Angled text: Text that is straight, but lies at some angle to horizontal on the label.

Computed text: Text that CD-Face automatically creates as a text field. Computed text 
can be a date, a number sequence, or data from a database field. Also called Special Text.

Curved text: Text that lies on an imaginary circle that is centered on the label. 

Field properties: Information about a text field, picture field, or shape field. Used by CD-
Face to draw and position the field in a layout document.

Flat text: Straight text that lies horizontally on a label, jewel case insert, or tray liner.

Layout document: A file opened from a CD-Face template, where you add designs for 
CDlabels, jewel case inserts, and tray liners. Layout documents contain outlines for all of 
NEATO’s label stock.

Number sequence: A special text field containing a number such as a serial number that 
increases by one each time a new label is printed.

ODBC: Open DataBase Connectivity, a standard method for accessing databases of 
different kinds and from different vendors.

Palette Bar: A separate, moveable window that provides a quick way to add text, pictures, 
and shapes to a layout document and to choose their colors.

Picture field: A picture used as label art. Picture fields may be embedded directly into the 
layout, or CD-Face can save a link to their location.

Positioning box: The rectangle surrounding a selected field. The positioning box has 
square black “grab” handles that you can drag to adjust the field’s size and shape.

Radius to Center: The distance from the center of a label to the center of each character 
in a curved text field. Applies to Curved Text only.

Ruler Bar: Appears at the top of the document window. Provides a guide for measuring 
the dimensions of objects in a layout document.

Scroll Bars: Appear at the right and bottom edges of the document window. The scroll 
boxes inside the scroll bars indicate your vertical and horizontal location in the document. 
Use the mouse to scroll up and down the document.
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Shape field: A geometric shape (line, rectangle, or ellipse) placed on layouts for labels, jewel 
case inserts, and tray liners.

Special Text: Text that is automatically created as a text field. It may be a date, a number 
sequence, or data from a database field. Also called Computed Text.

Status Bar: Appears at the bottom of the CD-Face window. Describes the actions performed 
by menu items or toolbar buttons.

Template: A ready-to-use layout document that contains outlines of labels, jewel case inserts, 
and tray liners matching NEATO stock. A copy of a template is opened each time the New 
command is selected from the File menu.

Text field: Text placed on labels, jewel case inserts, and tray liners in layout documents.

Title Bar: Appears along the top of a window. Contains the names of the software and the 
current open document. To move the window, drag the title bar.

Toolbar: Appears across the top of the CD-Face window, below the menu bar. Provides quick 
mouse access to the most used CD-Face commands.

Index
2UP template.......................................................................................................................9
3UP template.......................................................................................................................9
Add Text to command .......................................................................................................20
Add Picture to command...................................................................................................25
Add Shape to command ...................................................................................................26
Align Left command ..........................................................................................................27
Align Center command .....................................................................................................27
Align Right command........................................................................................................27
Angled text ........................................................................................................................13
Arrange Icons command...................................................................................................32
Bring to Front command ...................................................................................................27
Calibrate printer, see Printer calibration 
Cascade command ...........................................................................................................32
Close command ................................................................................................................18
Color

setting .........................................................................................................................11
Contacting NEATO............................................................................................................30
Copy All Fields command .................................................................................................20
Copy command .................................................................................................................20
Curved text ........................................................................................................................13
Cut command....................................................................................................................20
Database field ...................................................................................................................15
Database, using ................................................................................................................25
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Date...................................................................................................................................23
Delete command ...............................................................................................................20
Drawing Shape Properties Sheet .....................................................................................28
Edit menu ..........................................................................................................................19
Errors, see Picture Field Errors
Exit command ...................................................................................................................19
Field...................................................................................................................................20

Picture, see Picture field
Selecting.....................................................................................................................20
Shape, see Shape field
Text, see Text field

Field menu.........................................................................................................................20
Field Properties command ................................................................................................28
File menu...........................................................................................................................20
Fit Height command..........................................................................................................30
Fit Width command ...........................................................................................................30
Flat text.........................................................................................................................20/21
Font dialog box.............................................................................................................20/21
Help, see Online Help
Help menu.........................................................................................................................32
Image, see Picture Field
Installing CD-Face...............................................................................................................8
Jewel case booklet ............................................................................................................11

designing ....................................................................................................................11
printing........................................................................................................................11

Jewel case insert, see Jewel case booklet
Label

adding text....................................................................................................................9
adding pictures...........................................................................................................25
adding shapes............................................................................................................26
designing ......................................................................................................................9
printing........................................................................................................................16

Label stock ..........................................................................................................................9
Layout document

closing ..........................................................................................................................9
opening.........................................................................................................................9
saving .........................................................................................................................18

Measurement units............................................................................................................13
Move Back command .......................................................................................................27
Move Forward command ..................................................................................................27
Next Field command .........................................................................................................28
Next Label command ........................................................................................................28
New command ..................................................................................................................17
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New Shape Field command..............................................................................................26
New Window command ....................................................................................................32
Number sequence.............................................................................................................24
Number sequence dialog box ...........................................................................................24
Online Help........................................................................................................................32
Open command.................................................................................................................17
Page menu........................................................................................................................29
Page Properties command ...............................................................................................29
Page Properties Sheet......................................................................................................29
Page Size..........................................................................................................................29
Palette Bar.........................................................................................................................31
Paste command ................................................................................................................20
Picture field........................................................................................................................25

adding.........................................................................................................................25
changing properties....................................................................................................25
deleting..................................................................................................................25/26
moving...................................................................................................................25/26
saving....................................................................................................................25/26

Picture Field Errors ......................................................................................................25/26
Positioning box, see Text field positioning box
Printer calibration ..............................................................................................................19
Print command ..................................................................................................................18
Print Setup command .......................................................................................................19
Printer Calibrate command ...............................................................................................19
Printer Calibration dialog box............................................................................................19
Picture Field Properties Sheet ..........................................................................................28
Redo command.................................................................................................................19
Registering CD-Face...........................................................................................................7
Rotate Clockwise command .............................................................................................27
Rotate Counter Clockwise command ...............................................................................27
Save command .................................................................................................................18
Save As command ............................................................................................................18
Selecting

fields ...........................................................................................................................20
Text.............................................................................................................................21
Picture ........................................................................................................................25
Shape.........................................................................................................................26
labels ............................................................................................................................9

Send to Back command....................................................................................................27
Set Date dialog box...........................................................................................................23
Shape field ........................................................................................................................26

adding.........................................................................................................................26
changing properties ..............................................................................................25/27
deleting.......................................................................................................................25
moving........................................................................................................................25



Page 37

Part II Index PC Version

Special text........................................................................................................................23
Spine, Tray Liner ...............................................................................................................12
Starting CD-Face ................................................................................................................8
Status Bar..........................................................................................................................31
Test label

printing........................................................................................................................11
Template..............................................................................................................................9
Text field ............................................................................................................................21

adding.........................................................................................................................21
changing properties....................................................................................................21
deleting.......................................................................................................................21
moving........................................................................................................................21
positioning ..................................................................................................................21

Text field positioning box...................................................................................................21
Text Field Properties Sheet...............................................................................................21
Shape Field Properties Sheet...........................................................................................26
Snap to Fit command........................................................................................................28
Tile command....................................................................................................................32
Toolbar...............................................................................................................................30
Tray liner

designing ....................................................................................................................12
printing........................................................................................................................12

Undo command.................................................................................................................19
View menu.........................................................................................................................30
Window menu ...................................................................................................................32
Zoom In command ............................................................................................................30
Zoom Out command .........................................................................................................30
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System Requirements
CD-Face will run optimally on Macintosh computers with at least a 68040 processor and System
7.1 or later, with 8MB of RAM.  CD-Face will NOT run if AppleScript is turned off. Consult your
extensions manager to determine if you have AppleScript on. 

Note:  Use your extensions manager to disable all non-Mac OS extensions if you experience fre-
quent system “crashes” while using CD-Face software.  To determine which extension is causing a
conflict with the CD-Face software, enable one extension at a time until the problem recurs.  This
extension should remain disabled when using the CD-Face software.

There are a number of options for creating label art for the NEATO ™ CD labeler on your
Macintosh. 

Use Your Favorite Layout Program
You can design labels for the NEATO  CD labeler in any of the popular page layout and illustration
programs.  If you’ll be designing labels in Photoshop™, Illustrator™, or Quark Express™, drag the
templates folder onto your hard drive.  In addition to these label templates, we have provided eps
and pict formats for all of our stock. If you would like to work in a graphics program other than the
ones we’ve provided templates for, import these files into your application. Your application’s user
manual will tell you how to import and manage these files. 

NEATO CD-Face™ for Macintosh
CD-Face is NEATO’s software for creating CD Labels, jewel case inserts and tray liner cards that’s
easy to install and easy to learn. CD-Face provides a simple, efficient and fast way to create
attractive art on your Macintosh for CD-ROM labels, jewel case inserts, and tray liners and accu-
rately print  them all on NEATO stock.

Installing CD-Face Software
To get started using CD-Face, first install it by following these simple instructions:

1. Insert  the NEATO CD in the CD drive.
2. Drag the CD-Face folder onto your hard drive.  (Running the application from the hard drive is 

better because it allows you to change the memory assigned to the application if necessary).
3. Drag the Shareware folder onto your hard drive.  This folder contains two shareware graphics 

editing programs that make CD-Face easier to use. If you do use these applications, 
remember they are shareware. Support shareware! 

4. Double click on the CD-Face icon to get started.  IMPORTANT!  Read the CD-Face Read Me 
file. Just about everything you need to know regarding the use of CD-Face is in there. CD-
Face uses standard Macintosh menus and processes. 
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The IMAGES Folder
We have included 66 images that make great backgrounds for your CD labels. How you use
them will depend, of course, on what application you are working in. You’ll find specific directions
for working with images below, and they’ve been included in the CD-Face Read Me file on the
NEATO CD. 

Using the CD-Face Viewer
Use the CD-Face Viewer to look at the images and choose an image for your CD label by follow-
ing these simple instructions:

1. With the CD-Face CD in the CD drive, open the CD-Face Viewer folder ON THE CD. 
2. The Viewer should be run from the CD.  (It may not run properly if copied to a hard drive 

because of the way that it searches for and finds files. At 22.9 MB, it’s also quite large).  
3. Double-click on the CD-Face Viewer icon. CD-Face Viewer allows you to preview the entire 

portfolio of images without opening them individually. You can view them in groups, 
individually, or in a slide show format (by choosing “slide show” in the File menu). 

4. Choose an image by viewing it.  When viewing by group, you’ll see a group of thumbnail 
images.  You can see a larger version and the name/number of any thumbnail by double 
clicking on it.  After you’ve found an image you’d like to use, write down the name/number to 
remember it.

5. To use the image you’ve selected, follow the instructions below or in the CD-Face Read Me 
for working with images.

Note: If you do not have a CD drive, you will not be able to make full use of all the software 
we provide. The CD-Face software, the shareware, and the templates are available on 
floppy disc for a nominal fee.  

Starting CD-Face
To start CD-Face, find the NEATO CD-Face icon and double-click on it. The CD-Face Window
appears on the screen, with an open default document ready to start work.

Designing Your Labels
You design labels by placing text and images onto a label in a CD-Face layout document. When
you complete and save a design, the layout document is saved to a file that you name like any
other file you save on your Mac.

Here’s a quick tutorial that will take you through the process of creating a label with text and
background art, then printing the finished layout.
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Open a Layout Document
If this is your first time using CD-Face, start by using the default document opened when you start-
ed up CD-Face.  The default document is a US 3-Up CD label.    You can also choose a different
layout by going to the File menu, choose “Open”, and navigate to the CD-Face folder on your hard
drive.  In the CD-Face folder you’ll find a folder called “Stationery”  with templates for every style of
NEATO stock.  Choose the template you’d like to use from the menu.

Hint: Use templates
beginning with “US” for
8.5 by 11 inch stock,
and those beginning
with “A4” if you’re using
metric A4 stock. For this
exercise, be sure
choose a template that
contains label layouts
(with “3UP” or “2UP” in
the name) matching
your label stock, rather
than a jewel case booklet or tray liner.

When the document opens, if you want a larger work area, just increase the window size by drag-
ging the lower right corner of the document window, or by clicking the full screen square in the
upper right hand corner of the window.

Open the Tool Bar
Go to the Labels menu and choose Show Tools.  This will show you the tool bar.
You’ll use these tools to design your label.

Select a Label
Go to the tool bar and click on the arrow.  Then select the label you want to work on
in the document by clicking inside it.  The arrow will turn to a little hand and grab the
label to select it.  You’ll know it’s selected by the 8 dots which appear and show you
the outside edges of the label field area. 

Add Some Text
Next, let’s add some basic text, perhaps a title, to the label. Go to the tool bar, and
click on the “A”.  “A” lets you draw a text box. Place the cursor in the upper left hand corner of the
place you want to add a text box and draw the box. If the box is the wrong size or shape, just cut it
( X,  or choose “Cut” from the edit menu) and try again. Once you have the correct size box,
select your box with the hand (or by double clicking on the box). Once selected, you’ll see a flash-
ing cursor in the top line of the box. Type your text right into the box. 

Tool Bar Menu

Open a Layout Document
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Change the Text’s Appearance
Use the Text menu to change the font, style, size, or color
of your text. The text commands are the same as those in
most common word processor programs.  You can control
the appearance of the text two ways.  The first way is to
choose the type characteristics you want from the text
menu before you type the text in.  You must have the text
box drawn, and a blinking cursor to have your selections apply to the text you type in.  The sec-
ond way is to change it after you’ve typed it.  Select the “A” tool and highlight the text. Make
changes to the appearance of the text from the same pull down text menu.  Remember, to get
the changes made in the pull down text menu  (at the top
of your screen) to apply after the text is typed, you must
have the text highlighted. 

Nice work.  You’ve successfully added text to the label.
And it looks good, too!

Move the Text
If you’d like to move the text, drag the text box containing the title to a different place on the label.
Move the mouse until the cursor turns into a little hand over the text box (if the box has disap-
peared, click the text twice to select it again). Click and hold down the mouse button, then drag
the text to a new place on the label. Release the mouse button when you’re pleased with the
positioning.

Add Background Art to the Label
Your label will be more interesting with some artwork added. You’ll see that adding a picture is
just as easy as adding text. 

Background Art Options
There are two ways to add background art to your label.
Open Pict files can be dragged from third party applica-
tions or directly from the scrapbook and dropped onto the
area where you would like to place them if your System is
Drag/Drop savvy.    ( You’ll know it’s working because the
selected area will appear to be outlined with a thicker
than normal gray line). 
Art items may also be copied to the clipboard and pasted into a selected CD-Face area.  You can
also copy and paste, and drag images from one area on the label to another.

REMEMBER: Images are shaped to fit the area into which they are being imported. Full CD
labels will have their centers automatically knocked out.

Add Some Text

Change the Text’s Appearance

Add Background Art to the Label
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Tip: The clarity of your image will depend on the starting size of the image. If you import a very
small image into a large field it will be enlarged to fit the size of the field and the image quality will
suffer. The absolute pixel size (information provided with scrapbook images) will give you a good
indication of how well the image will import. The images in the IMAGES folder on the software CD
have been saved at 120 square millimeters. These Images fit the CD label at their actual size. 

Let’s add a background image.  We’ll use a picture from the Images folder that came with your CD-
Face software.  Once again, click on the same label to select it (if it isn’t already selected). 

Select an Image
Use the Viewer to choose an image from the NEATO CD.  Drag the icon of that image to your hard
drive.  Double click on it, and it will open in Graphic Converter.  (Be sure to register and support
shareware if you use this program regularly).  

Place the Picture on the Label
With the image open, use the Select All command from Graphic converter, then use the Copy com-
mand to place the entire image on your clipboard.  You can then Paste the image directly into the
label you’ve selected, or Copy the image to your scrapbook for use at a later time.
That’s all it takes to add a picture!  If you’re not sure whether or not a certain image is what you
want, try it out.  Remember the center of the images will be “knocked out” when pasted into the
CD label in CD-Face, creating quite a difference in how they appear when printed.

Display the Title in Front
The Macintosh version of CD-Face automatically displays text in front. 

Multiple Images on the Label
You can have more than one image on your label by using the Pointer, Rectangle, Oval or Circle
tools to draw areas for image importation.  The image will be constrained to fit the area that you’ve
drawn with the tool you’re using.  

When you’ve used a tool to create an image importation area, it’s time to choose an image to
import.  Once again you can import from the clipboard or Scrapbook, or choose an image from the
NEATO CD.  To use an image from the NEATO CD, with the image open in Graphic Converter, fol-
low the process above for importing art. You can then Paste the image directly into the area you’ve
selected. 

You now have text and image(s) on your label, and you’re ready to see it on paper.

Run a Test Print
When you’re satisfied that you have all the graphics and text in place where you want them, you’re
ready to print the label. First, however, it’s a good idea to run a test print with regular paper in the
printer to make sure the text and background art will be correctly aligned.  There’s a label template
for test printing included in the NEATO CD Labeler package.  Just photocopy this page and place it
in your printer tray. Choose “Print” or “Print One Copy” from the File menu, then click Print. Take a
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look at how your label prints in relation to the label boundary on the paper.

Did your art print exactly within the label, or did it “run off the edge”? If it
needs some adjustment, use offset printing by selecting the Preferences
dialog box under the Labels menu.  Enter the offset printing values. Make
sure that your printer is configured for offset printing. The units of measure
in the preferences dialog are pixels, set to 72 dpi.

Print the Label
When you’re satisfied with the alignment, try printing one on your NEATO
label stock. Feed one page into the printer.  From the File menu, select
“Print”. This displays the Print Dialog box. Make sure you have the correct
printer selected, select the stock source (tray or manual feed), then click
OK. Just one page will be printed.  When you’re satisfied that everything is
as you’d like it, select “Print” from the file menu.  Enter the number of
copies you’d like, select the stock source (tray or manual feed),  and click
OK.

Take a well-earned break, then try creating a jewel case booklet and tray liner.

Creating a Jewel Case Booklet
Now that you understand the basics of creating a label, designing a jewel case booklet for your
CD is just as easy. As with a label, you use a template, so choose Open from the File menu, nav-
igate to the “Stationery” folder on your hard drive or CD and double click on the template named
“US Jewel Box Front” to open it. Look at the layout document that appears. It is divided into two
booklet pages. For this tutorial, we’ll create a front cover (using the right page in the layout) and a
back cover (on the left page).

Add Text to the Front and
Back Covers
To begin, let’s add some
text to the front cover.  This
is the area on the right side.
Go to the tool bar, and click
on the “A” and draw a text
box just as you did for the
CD label, above. Then go
through the same steps to
set the text’s font, style,
color, position and so on.
Move between the two booklet pages in the layout document by double-clicking with the mouse.
To add text to the back, click inside the left page to select it, then add some more text.

Run a Test Print

Creating a Jewel Case Booklet



Part III

Page 44

Tutorial Macintosh Version

Add Some Artwork
When you’re satisfied with the appearance of the text, you can place a picture or multiple images
on each cover. Again, do this exactly the same way as when you created the label. Use a picture
from the CD-Face Images folder, or use one of your own images.  Paste into the entire cover by
selecting it and pasting in the image, or describe the area to be pasted into by using one of the
tools in the tool bar.

Print the Jewel Case Booklet
When you’re ready to print, follow the same process you did
for the Label to be sure your Jewel Case Booklet stock is
aligned perfectly.  When you’re satisfied with the alignment,
try printing on plain paper first, then print one on your
NEATO Jewel Case Booklet stock. Feed one page into the
printer.  From the File menu, select “Print”. This displays the
Print Dialog box. Make sure you have the correct printer
selected, then click OK.  Just one page will be printed.
When you’re satisfied that everything is as you’d like it,
select “Print” from the file menu.  Enter the number of copies
you’d like, select the stock source (tray or manual feed),
and click OK.

Creating a Tray Liner
Designing tray liners is just as straightforward as creating labels or jewel case inserts.  Choose
Open from the File menu, navigate to the “Stationery” folder on your hard drive or CD and open
the template named “US Jewel Box Back”.  This time you’ll see that, unlike labels or jewel case
booklets, the layout for a tray liner has two thin fields along the left and right edges of the tray.
These fields are where you enter text for the spines.

Adding Text and Artwork to the Tray Liner
Click the square in the middle of the layout to select it, then add text
and background art to the tray liner using the same methods as you
did on the label and jewel case booklet.

Adding Text to the Spines
The spines of the tray liner are the narrow fields running vertically
along the left and right edges of the layout document. Although CD-
Face does not currently offer the ability to place text vertically in a
Macintosh layout document, you can easily create and format vertical
text using other graphics or word processing software, then cut and
paste the text from that application into the spine fields in your CD-
Face layout document.

Add Some Artwork

Adding Text and Artwork to the Tray Liner
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Handy Tips and Shortcuts
CD-Face allows for considerable flexibility in how you can add and place text and pictures in lay-
out documents. Here are a few tips and shortcuts to try after you become familiar with the basic
processes.

Positioning Text
Position the text horizontally within  the text box by using the Align Left, Align Center, and Align
Right commands in the Text menu under Justify.  You can also drag a selected text box manually
using the mouse. Click and hold down the mouse button and simply drag the text to a new posi-
tion. Make a text field larger or smaller by clicking the text to select the field. Then, drag the grab
handles (the black boxes on the positioning box) in the desired direction.

Working with Several Documents at Once
Although you can open more than one open layout document at a time, CD-Face runs faster and
more efficiently when a single page layout document is open. If you would like to work with a sec-
ond document and make only minor modifications, use “Save As” under the File menu to save
the document under a different name.

Picture Size
For working most efficiently with graphic images in a layout document, the smaller the size of the
image file, the better. If you plan to add a number of pictures to one layout page, consider work-
ing with smaller files. The entire picture is stored within the document. Remember that RGB for-
mat is less memory intensive than CMYK. The resolution of the image also affects the size of a
layout document. If you are working with a printer that prints at 300 dpi, there’s no advantage  in
working with images saved at 720 dpi. Smaller files take less time to open and less time to edit.

Importing Pictures Smaller than the Label
When you use pictures (such as company logos) that are not meant to completely fill the label,
make sure you draw an appropriate size area for importation with one of the tools from the tool
bar.   If the image needs further re-sizing, grab one of the square black handles with the mouse
and drag the handle until the image is the size and shape you want.
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File Menu
New 
creates a new document with the default style, either the US 3 UP label 
or the A4 2 UP label.

Open 
allows you to open either a saved document or one of the other CD-Face
styles. To open one of the other styles or form templates , select the CD-
Face Folder, open the “Stationary” Folder, select the template or form by 
double clicking on it, or by highlighting it and pressing <return> on your 
keyboard.

Close 
allows you to close the current open document.  If you have made 
modifications since the last save, you’ll be asked if you want to save your 
work.

Save 
saves the current document.

Save As 
allows you save your document under a different name or in a different place.   Choose the 
location by navigating in the dialog box.  Change the name by typing it into the box under 
“Save this document as:”

Page Setup 
Your printer and print driver will determine the details of this dialog box.  We highly 
recommend that if you have a “larger print area” option available as part of  your page set 
up, that you select it. You can see the printable area of your document by selecting the 
‘Show Page Break’ Option under the Label Menu. When working with US 2 Up or any A4 
stock, you must change the view to landscape or you will not be able to edit the entire page.

Print 
is the standard printing option. The print dialog box will appear and you can print one or 
multiple copies of your document.  If you have multiple documents open, only the one that 
you are currently working on will print.  All pages of your document will print unless you 
specify otherwise.

Print one copy 
automatically spools one copy (all pages) of the open document to the printer. The print dia
log box will not appear.

Notes on Printing
Always save your document before printing. Occasionally, the print dialog box will cause the 
image on the screen to appear distorted. Double click the Title Bar (or Window Shade button 
if applicable) to refresh the document. Your work will not be affected.

File Menu
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Edit Menu
Undo  (  Z) 
will undo your most recent action.

Redo   (  R)  
This will undo an undo command. Not all undone commands may be 
redone. If redo is not available it will be shaded to indicate that it is 
disabled.

Cut  (  X) 
This will cut the object you have selected. If you have no object 

selected, nothing will be cut.

Copy  (  C) 
This will copy the selected object to the clipboard. Only one object may be copied and 
pasted at a time.

Show Clipboard 
will show the most recent object on the clipboard. You can import images and art into the 
application from the clipboard as well as the scrapbook. If you were working in another
application previously, the object most recently copied onto the clipboard will appear.

Labels Menu
Add Page 
will add a page to your document.

Delete Page 
will delete the last page of the document you have open and in the 
foreground.  You cannot Undo “Delete Page”.  Do not select delete 
page if you only have one page open.  (It will delete your only 
page).

Next page (  ] )  
will take you to the next page in the document.

Previous Page (  [ ) 
will take you to the previous page in the document-

Go to Page...
will ask you to “Enter Page”, then take you to that 
page in the current document . 

Background Color 
lets you choose white, gold or silver from the pre-formatted background, 
or any color from the color palette. This helps you see what your image will look like on 
various color labels and is for editing purposes only. The background color will not print.

Edit Menu

Labels Menu
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Show Tools 
shows the tool bar.  Use the tools to design your label.  There are five tools:

Pointer 
Use the pointer to select objects.

Rectangle 
lets you draw a rectangular box for image importation (see image importation). The image 
will be constrained to fit the defined area.

Oval  
lets you draw an oval shape for image importation (see image importation). The image will 
be constrained to fit the defined area.

Circle 
lets you draw a circle for image importation (see image importation). The image will be
constrained to fit the defined area.

A
lets you draw a text box. Place the cursor in the upper left hand corner of the place you 
want to add a text box and draw the box. If the box is the wrong size or shape, just cut it (
X,  or choose “Cut” from the edit menu) and try again. Once you have the correct size box, 
select it with the hand. Once selected, you’ll see a flashing cursor. Type in your text. Use the 
Text menu to change the font, style, size, or color of your text. The text commands are the 
same as those in most common word processor programs. To edit text options, you must 
either highlight the text or select the text box with the hand (above) so the blinking cursor is 
showing. To get changes made in the pull down text menu  (at the top of your screen) to 
apply, you must click on the text box or have the text highlighted.  

Show Page Breaks  
We strongly recommended that you work with this option on. The dashed lines show the 
actual printable area .

Preferences  
If you are offset printing select the preferences dialog box and enter the offset printing val
ues. Make sure that your printer is configured for offset printing. Always run a test print on 
plain paper to avoid wasting label stock. The units of measure in the preferences dialog are 
pixels, set to 72 dpi.
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Picture Menu
Notes on Image importation
Open Pict files can be dragged from third party applications or directly from the
scrapbook and dropped onto the area where you would like to place them if your
System is Drag/Drop savvy. The selected area will appear to be outlined with a
thicker than normal gray line. Items may also be pasted from the clipboard, or
dragged from one area to another. Images are shaped to fit the area into which
they are being imported. Full CD labels will have their centers automatically
knocked out.

Stretch  
will stretch an image which does not cover the entire area.

Top Left  
aligns the image in the top left hand corner of the area in which it’s been placed.

Center  
moves the image to the center of the area. Remember that the center of the CD label is 
knocked out when printing, so be careful not to place images that you want to see printed in 
the center of the CD label.

Tile 
lets you create a repeating but smaller pattern of the image. Usually four images are 
created.

Tip: The clarity of your image will depend on the starting size. If you import a very small 
image into a large field it will be enlarged to fit the size of the field and the image quality will 
suffer. The absolute pixel size (information provided with scrapbook images) will give you a 
good indication of how well the image will import. The images in the IMAGES folder on the 
software CD have been saved at 120 square millimeters. These Images fit the CD label 
at their actual size.  

Text Menu
The Text Menu allows you to change the appearance of the type on your label.
The type must be highlighted within a text box for changes to take effect.

Style  
under the text menu give you the options of making your type 

Plain,   
Bold ,   
Italic,   
underlined,   
oouuttlliinneedd,    
shadowshadow, 
Condense and  
Extended

Each of these allows you to stylize the look of your label. 

Picture Menu

Picture Menu
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Size  
lets you specify the size of  your type by points, or by growing the selected type ( = ) or 
shrinking the selected type ( -).

Font  
lets you choose your font from fonts installed in your system. 

Justify 
lets you align type left, right or center within a selected text box. 

Color  
lets you select a new text color for color printing.  The two boxes in the upper right hand 
corner compares the original and new type colors.  The boxes in the center right allow you 
to specify the hue angle and color saturation.   Enter numerical values or  using the up and 
down arrows next to each box to increase or decrease the values.  Finally, you can specify 
lightness by moving the sliding bar below the color wheel, by entering a percentage in the 
box in the lower right, or by using the up and down arrows next to that box to increase or 
decrease the lightness until you’re satisfied with how it looks.

Memory Management
The size and quality of the images that you work with in CD-Face will be largely dependent on the
amount of RAM you have available. Many images have been included on the NEATO Software
CD, but some may be too large to work with on computers with lesser amounts of RAM. Proper
memory management, as always, will increase the functionality of the CD-Face software.

Setting Your Memory For CD-Face
CD-Face has a suggested memory size of 2MB. On computers with 8MB of RAM, we recommend
that you not increase the memory requirement.  For computers with 16 MB of RAM you should be
able to run CD-Face at the preferred size of 8MB. For those computers with 24 MB of Ram, the
application can be run at 12MB. On those computers with 32 MB or more of RAM you may want to
set the preferred size as high as 16 MB.  As always, turning off unnecessary extensions in the sys-
tems manager will increase the amount of RAM available.  The only time you need to change
these settings if you plan to work with large graphics files. 

Resolving Resolution
If you save your graphics at a lower resolution, you may sacrifice some image quality, but you also
make the graphics smaller and easier to work with. Text created with CD-Face will remain sharp
regardless of the resolution of the background images. Naturally, the clarity and sharpness of
images and text printed to your labels will depend on the capabilities your printer.

Importing Images from the Scrapbook & Clipboard
CD-Face can accept images directly from the scrapbook, as well as pasted from the clipboard.
Images will be shaped to fit the field into which they are imported (full CD labels will have their
centers knocked out). 
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Importing Images Using JPEG View & GIF Converter
CD-Face does not have a built-in import function, so we have included two shareware applica-
tions: JPEG View 3.3.1 and Graphic Converter 2.4. Each of these applications comes with its
own documentation and on-line, which you can use for greater flexibility in working with images. 

These shareware applications can help you use CD-Face two ways:  

1) Opening Images. You can open images (such as those in the IMAGES folder) with either appli-
cation.  Then just copy them onto the clipboard, and paste them directly into CD-Face.

2) Converting images from other formats into PICT files. To do this, open an image, select Save
As from the File Menu, and then PICT under File Type. This PICT file may then be dragged either
directly into the Scrapbook or your CD-Face document.  The benefit of working from the
Scrapbook is that you can create labels using several different images at once without tying up
RAM by using the clipboard. The quality of images converted from other formats into PICT files
may vary.

If memory constraints are a concern, 
use this process to paste images directly into CD-Face: 

1) Before opening CD-Face, open the image editing application that you’re going to use to open 
the image (or simply drag the image onto the application icon if your system supports “drag 
and drop”). 

2) Copy the image to the clipboard, then close the application. The image will remain on the 
clipboard.

3) Open CD-Face and paste to your selected field.

You may paste the same image repetitively into selected areas in a CD-Face document. Creating
a label page this way uses less memory than creating a label page with three separate full CD
label images. 

Printing
We strongly suggest that you set your printer to print to the largest area allowed, especially when
working with the US 3 UP labels. Most Macintosh and Macintosh-compatible printers have
options available in the Page Set Up menu which allow you to select between different print area
options. For information on the specifications of your printer, please consult your printer’s user
manual. NEATO does offer US 2 UP label stock for those users in the United States who can’t
print on the entire area of the US 3 UP label. Call 800.984.9800 for details.

Remember, you can set CD-Face to show you the printable area by turning on the Show Page
Break option in the Labels Menu.

NOTE: When printing US 2 Up and A4 labels, open Page Setup and select the ‘landscape’ mode.
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In most Page Setup Menus, the landscape mode is a button which shows a person standing side-
wise on a piece of paper. Layout document: A file opened from a CD-Face template, where you
add designs for CD labels, jewel case inserts, and tray liners. Layout documents contain outlines
for all of NEATO’s label stock.

Image: A picture used as label art.

Positioning box: The rectangle surrounding a selected field. The positioning box has square black
“grab” handles that you can drag to adjust the field’s size and shape.

Ruler Bar: Appears at the top of the document window. Provides a guide for measuring the dimen-
sions of objects in a layout document.

Scroll Bars: Appear at the right and bottom edges of the document window. The scroll boxes
inside the scroll bars indicate your vertical and horizontal location in the document. Use the mouse
to scroll up and down the document.

Status Bar: Appears at the bottom of the CD-Face window. Describes the actions performed by
menu items or toolbar buttons.

Template: A ready-to-use layout document that contains outlines of labels, jewel case inserts, and
tray liners matching NEATO label stock. A copy of a template is opened each time the New com-
mand is selected from the File menu.

Title Bar : Appears along the top of a window. Contains the names of the software and the current
open document. To move the window, drag the title bar.

Toolbar: Appears across the top of the CD-Face window, below the menu bar. Provides quick
mouse access to the most used CD-Face commands.

2UP template.....................................................................................................................38
3UP template.....................................................................................................................38
Add page command..........................................................................................................47
Background Color command ............................................................................................47
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Circle Tool..........................................................................................................................48
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Contacting NEATO..............................................................................................................7
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File menu...........................................................................................................................46
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Registering CD-Face...........................................................................................................7
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Save command .................................................................................................................46
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Selecting

Text.............................................................................................................................41
Picture ........................................................................................................................42
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Show Clipboard command................................................................................................47
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