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Overview

TreeChart  is  a  program to  enable  attractive  organization  charts  (or  other  hierarchy  charts)  to  be 
produced with minimal fuss and effort.

No drawing skills are required: all box sizing and positioning is automatic. All you need to do is to 
decide what boxes look like and what text to put in them.

Whenever you change the chart, TreeChart automatically:

■ Re-calculates how large boxes need to be to contain the text
■ Re-positions boxes so that they are evenly spaced and correctly aligned
■ Re-routes connecting lines

TreeChart's benefits include:

■ Suitable for preparing:
☑ Organization Charts
☑ Work Breakdown Charts
☑ Cost Breakdown Charts
☑ Taxonomy Charts
☑ Parts Lists / Bills of Materials

... in fact, illustrating any hierarchical (or nearly hierarchical) arrangement!

■ No drawing skills required: box sizing, positioning, line routing is automatic
■ Assists you in achieving a consistent appearance, through style guides
■ Preparing a chart is easy, but preparing further similar ones is even easier
■ Import text, and prepare a chart the way you want it to look,  almost instantly
■ Outlining facilities, to enable you to concentrate on the matter in hand
■ Can print the  whole chart, or single departments / sub-systems
■ Printing can be previewed, and automatically scaled to fit on a single page
■ Simple to incorporate a chart in a word processor document
■ Can export pictures for hand-drawn embellishments using other programs
■ Special features to support common Organization Chart needs:

Assistants,
Co-Managed staff (shared employees)
Junior staff who report directly to senior staff

Chapter 2 ("Getting Started") explains how to install TreeChart on your computer and how to start the 
program. It then introduces the main parts of the TreeChart window.

Chapter 3 ("A Quick Tour") introduces most of the TreeChart tools and techniques by taking you step-
by-step through a worked example chart. If you're new to TreeChart, we recommend that you prepare  
your first chart by working through this tutorial. In this online version of the User Guide, Chapter 3 has 
been annexed to TUTORIAL.WRI.



Chapters 4 to 11 provide a detailed reference guide to working with TreeChart.

Chapter  12  ("Working  with  other  Programs") explains  how  TreeChart  can  generate  charts  from 
information  within  other  programs  and  how you  can  copy  charts  into  a  word  processor  or  DTP 
program.

1.1 Creating Charts with TreeChart

To use TreeChart effectively, it is helpful to understand how the program manages your information,  
and especially the relationship between the text in a box, and how that box appears when drawn.

What's a Chart?

On one level, you can think of a chart as being what the program outputs to the printer. To TreeChart, a  
chart is much more than this because the diagrams it produces are automatically generated from your 
information.

You could regard TreeChart as a special-purpose database program. Like a database, you enter records. 
Each record is composed of a number of fields. For example, a record might correspond to a person 
within an organization; in this case you might choose to have just two fields: the person's name, and 
his or her job title.

TreeChart then needs two further bits of information: how are the records related, and how should this 
structure be illustrated. When you save a chart to a disk file, these three sets of information (records,  
relationships & illustration options) are saved together. The pictures TreeChart makes for you are really 
just how you'd like your database to be illustrated.

TreeChart works with information that is hierarchically structured.

What's a Hierarchy?

One of the basic methods people have of organizing information is by distinguishing between whole 
objects and their constituent parts. This process happens under many different names: classification, 
decomposition, divide & rule, structuring, organizing, breakdown, etc. Whatever terms are used, the 
end result is the same: a hierarchical (or tree-like) description of the whole, where branches lead to  
other branches and ultimately leaves. Two examples:

Organization Charts

A Company is composed of people. It is organized in terms of divisions and departments. Everyone  
except the Managing Director reports to someone else.



Car Parts List

A car is composed of many components. To organize the assembly, it is logically divided into sub-
systems, assemblies and sub-assemblies.

As you can see, while you can describe a hierarchy in words alone,  pictures enable everyone to grasp  
the  structure of the information much more quickly. TreeChart stores and illustrates this structured  
information for you.

What's a Box?

As we've said, a box is TreeChart's term for a record in a hierarchically structured database.

Like a database record, the text that appears within a box is divided into Fields. Like a database, all 
boxes have the same number of Fields. When creating a chart you decide how many Fields you need.  
You don't have to get this perfect before starting a chart: you can add or delete Fields at any time.

Chapter 4 describes working with a hierarchy of boxes. Chapter 5 describes working with Fields.

Having constructed a hierarchy of boxes, the way the information is illustrated is determined by the 
Layout settings you choose.

What's a Layout?

A Layout defines how a box appears in a chart, and how it is arranged with and connected to the boxes 
hierarchically under it.

Layouts are similar to Style Guides found in more sophisticated word processors, and can greatly assist 
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you in achieving a consistent appearance to your charts. Every box in a chart uses one of the Layouts 
you have defined. When you change the settings of a Layout, it automatically affects every box using 
that Layout. You can define any number of Layouts and tell a box to use a different Layout any time 
you like.

Chapter 6 describes working with Layouts.

Can you add a border and title text when printing?

Yes. Charts contain a  Border. This can be thought of as a large box which frames your chart when  
printing, copying to the Windows clipboard as a picture, or saving as a picture-format file.

Like a box, the Border can have any number of Fields, and it uses a Layout. The Fields defined for the  
Border are different from those defined for boxes.

Chapter 8 describes working with the Border, while Chapters 9 & 12 describe printing charts and 
exporting charts for use by other programs.

What are Template Files?

A Template is simply a chart that acts as a starting point when you create a new chart or open a text-
format file. A Template contains:

■ A definition of the Fields
■ A set of Layouts
■ Border settings
■ Other chart settings

Having prepared one chart, you can save the style of the chart as a Template to speed up the creation of 
further charts in the same style.

Chapter 11 describes working with Template Files.

1.2 System Requirements

TreeChart requires Windows 3.1. It will not run under Windows 3.0

A Mouse (or similar pointing device) is not required, but is recommended; a small number of non-
essential operations are unavailable without a mouse.

Like most Windows programs, the amount of information you can store in a chart, and the number of 
charts you can open simultaneously are limited only by the amount of available memory.

Use of TrueType fonts, or comparable third-party font technology such as Adobe Type Manager, is  
highly  recommended.  Zooming  & fit-to-page  operations  in  the  program require  scaleable  fonts. 
Dialogs requesting font specifications show only scaleable fonts.

1.3 Assumed Audience



This  User  Guide  assumes  its  readers  to  be  familiar  with  working  with  programs  running  under 
Microsoft  Windows.  The basic,  common, techniques for working with Windows programs are not 
described. Chapters 1 and 2 of your Windows User's Guide provide an excellent grounding in the basic 
techniques required to control any Windows program.

1.4 The Shareware Concept

TreeChart is not free. It is not public domain. Just like a computer program costing ten times as 
much, it is copyrighted by its owners, and you must purchase a license to use it.

Unlike a computer program costing ten times as much, you have the chance to try the program 
before you commit yourself to purchasing the license. This 'try before you buy' concept is termed 
Shareware.

In essence, FineLine Software (the copyright holders) are granting you a limited-time trial-use 
license to evaluate this program to determine if it meets your needs. If, after 30 days, you wish to 
continue  using  this  program,  you  must  purchase  a  full  license  for  continued  usage.  If  you 
continue using this program beyond the 30 day trial-use license we have granted, you are doing 
so without a license. This is illegal.

See Appendix 3 for our license agreement.

Purchasing a full license is termed 'Registering the program'. Registration brings many benefits 
over and above the right to continue using the program. See Appendix 4 for the benefits  of  
registration, our upgrade policy and how to register.

This program is produced by a member of the Association of Shareware Professionals (ASP). ASP 
wants  to  make  sure  that  the  shareware  principle  works  for  you.  If  you  are  unable  to  resolve  a 
shareware-related problem with an ASP member by contacting the member directly, ASP may be able 
to help. The ASP Ombudsman can help you resolve a dispute or problem with an ASP member, but 
does not provide technical support for member products. Please write to the ASP Ombudsman at 545 
Grover Road, Muskegon, MI  49442-9427 U.S.A. or send a CompuServe message via CompuServe 
Mail to ASP Ombudsman 70007,3536. The OMB may be contacted by FAX by sending to the ASP 
FAX number:  (+1)  (616)  788-2765.  In  communication with  the  OMB please  include  a  telephone 
number and/or FAX if available.
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Getting Started

2.1 TreeChart Installation

The evaluation (or shareware) version of TreeChart is distributed in two formats. One includes a setup  
program to  simplify  installation from a  floppy diskette.  The other  minimizes  the  number  of  files  
required and collects and compacts them into an archive file. This latter format is most often used for  
distribution via bulletin boards, computer networks and shareware disk vendors.

If you have a TreeChart disk and the label provides instructions, just follow them.

TreeChart neither requires nor makes any changes to any system or Windows configuration files.

2.1.1 Packing List

Files essential to run TreeChart:

TREECHRT.EXE The main program file
TK-TALG.DLL A secondary program file
MUSCROLL.DLL A secondary program file

Files recommended when running TreeChart:

TREECHRT.HLPOnline Help

Non-essential files:

Documentation, in Windows Write format:

TREECHRT.WRI User Guide (this file)
TUTORIAL.WRI Tutorial: Preparing your first chart
README.WRI Upgrade information & late-breaking news
SAMPLES.WRI Lists and describes all sample charts & templates

Sample files:

*.TCF Sample Charts
*.TCT Sample Templates

The samples provided will vary from time to time. SAMPLES.WRI lists and describes the 
current samples.

2.1.2 Installation from a Setup Disk

The TreeChart Setup program directs you through the installation process. Simply answer the questions 
as they are displayed on your computer's screen.



To install TreeChart:

1 Make sure that computer and monitor are turned on

2 Start Windows if its not already running, and close any open applications.

■  In most cases, you can start Windows at the command prompt by typing win
■  If Windows is already running, save your work and close any open applications,
    including MS-DOS sessions, before starting the TreeChart Setup program.

3 Insert the TreeChart Setup disk in your disk drive, and close the drive door if
necessary.

4 From the Program Manager File menu, choose Run.

5 In the Command Line box, type drive letter:\setup
For example, if the TreeChart Setup disk is in drive A, type a:\setup

6 Choose the OK button

7 Follow the instructions on your screen

When installation is complete, you can find the TreeChart icon in the TreeChart program group

2.1.3 Installation from an archive file

Firstly, ensure that all files noted as essential (in 2.1.1) are available. The evaluation copy of TreeChart  
is normally distributed via shareware libraries or bulletin boards in a form which collects all associated  
files together in a single archive file, which is then compressed to reduce storage requirements. The  
format of the archive file may well vary depending on how you obtained TreeChart, and your supplier  
normally provides notes on how to extract the files within an archive.

Since you are reading this document, at least one TreeChart file has been extracted from the archive. 
Please check that all the others are, too.

If you have not already done so, please read file README.WRI before continuing. This file contains  
both introductory information and late-breaking news.

After extracting all the files in the archive, the archive file itself is no longer needed. Before deleting it, 
why not pass a copy to a friend or colleague to allow them to see how TreeChart can speed up their  
work.

Where should you put the files?

TreeChart can be run from a floppy disc, but for performance reasons it is highly recommended that 
you copy the files to a hard disc.

We strongly recommend that  you create  a  new directory exclusively  for  TreeChart,  and place  all 



TreeChart files in that directory. This makes it simpler if you need to de-install TreeChart, and also  
satisfies the program's requirements that a few of the files be in 'known' directories.

If,  for  any  reason,  you  cannot  follow  these  recommendations,  you  must ensure  that  the  files 
TREECHRT.HLP and TK-TALG.DLL are:

either in the same directory as TREECHRT.EXE
or in the Working Directory (specified when you start TreeChart)
or in the Windows directory
or in the Windows System directory
or in a directory listed in the PATH environment variable
or in one of the directories mapped in a network

The program will not run if it cannot find TK-TALG.DLL or MUSCROLL.DLL. Online Help will not 
be available if the program cannot find TREECHRT.HLP.

Creating an Icon in a Program Manager Group

One of the easiest ways to start a program under Windows is to double-click on the program's icon in  
the Program Manager. To create a TreeChart icon in the Program Manager:

1 Select the Program Group you wish the icon to be in
2 From the File menu, choose New
3 In the New Program Object dialog box , confirm Program Item
4 In the Program Item Properties dialog box, enter details of TreeChart.

For example:
Description: TreeChart
Command Line: c:\treechrt\treechrt.exe
Working Directory: c:\treechrt

Specify the directory where you installed the TreeChart files.

2.1.4 De-installation

Removing TreeChart from your system is quite straightforward.

Assuming you used the setup program or followed the recommendations when installing TreeChart,  
and placed all TreeChart files in a separate directory on your hard disc:

1 If TreeChart is running, close the application window
2 Delete all files in the TreeChart directory
3 Remove the TreeChart directory

If a Program Manager icon for TreeChart was created, delete the icon by:

1 Click on the TreeChart icon to select it
2 From the Program Manager File menu, choose Delete

If you actually ran TreeChart, two further operations are required to completely tidy up your system.



Delete the TreeChart preferences file

Delete the file TREECHRT.INI. This will be in your Windows directory.

If you omit this tidy-up, nothing serious will happen; you'll just be leaving a very small file on your  
hard disk unnecessarily.

De-register with the Windows File Manager

The first time TreeChart runs it automatically registers itself with the Windows File Manager. This  
allows the File Manager to know that it should run TreeChart if you ever double-click on a TreeChart 
data file (*.TCF file type).

In Windows File Manager...

1 From the File menu, choose Associate
In the Associate dialog box...

2 In the File with Extension edit control, enter TCF
3 In the Associate With combo, select (None)
4 Choose the OK button

If you omit this tidy-up, nothing serious will happen. If in future you double-click on a .TCF file from 
within the File Manager, Windows will simply report an error that the TreeChart program could not be 
started.

2.2 Starting TreeChart

Starting TreeChart is just like starting any other Windows program. The precise methods depend on 
what program(s) you are using to manage your desktop. In this section, we'll assume you're using the 
Windows Program Manager. If you're using other programs (e.g. Norton Desktop for Windows), the 
methods will be similar, but refer to the user guide for those programs for details.

To start TreeChart:

1 From Program Manager, open the TreeChart program group.

2 either Double-click the TreeChart icon
or Press TAB until the TreeChart icon is highlighted, then press ENTER

2.3 Getting Help

Extensive on-line Help is always available to you when you are working with TreeChart.  Help is  
offered on a context-sensitive basis. This means that the help offered normally depends on what you 
were doing when you requested help.

Command Prompts

The first level of help offered is command prompts. Whenever you highlight a menu item or press (but  



don't release) a Toolbar button, a description of the command is displayed in the Status bar prompt 
field (if the Status bar is shown).

On-line Help

TreeChart uses the standard Windows Help facility. Once the Help facility has been started, you are 
free to browse amongst topics, search for key words or phrases, add your own annotations to topics, or 
print topics. If you are unsure how to use Help, choose How to Use Help from the Help menu in either 
TreeChart or Help itself, or press F1 when you are in Help.

Help menu

The TreeChart Help menu enables you to start the Help facility with an overall contents presented. This 
can be useful if you are unsure what you need help on.

The Help menu also enables you to search the on-line Help for particular keywords.

Context-sensitive Help

Pressing F1 requests context-sensitive Help. The topic initially shown depends on what you were doing 
when you pressed F1; if you press F1 while a menu command is highlighted, rather than perform the 
command, help on the command is presented. If you press F1 while a dialog or message box is shown, 
help on that dialog or message box is presented.

Once you have started the Help facility, you are free to browse among topics as normal. 

Help mode

Pressing  SHIFT+F1 (or  clicking  the  Help  mode  button  on  the  Toolbar)  stops  normal  TreeChart 
operation, and allows you to select an item you'd like help on. In this mode the cursor changes to an  
arrow with a question mark.

Now select a menu command or click the left mouse button over a part of the TreeChart window to 
select  the help topic.  If  you select  a command, rather than performing the command, help on the  
command is presented.

Pressing ESC leaves this mode without presenting help.

If you don't have a mouse, you are limited to selecting menu commands.

2.4 The Parts of the TreeChart Window

TreeChart is a standard Windows MDI (Multiple Document Interface) program. This means that the 
program allows you to work with more than one chart at a time.

Each open chart is shown in its own window. The windows of all open charts are contained within the 
workspace of the TreeChart application window.

If  you're  unfamiliar  with  working  with  multiple  document  (chart)  windows  within  an  application 



window, chapters 1 and 2 of your Windows User's Guide provide an excellent grounding in the basic  
techniques required.

Almost every command you choose or selection you make while working with TreeChart is performed 
on the chart in the active chart window. Two exceptions to this rule are:

■ The selected printer, paper source, size & orientation
■ Program Preferences (see Appendix 1)

These  settings  determine  how  the  TreeChart  program  works,  rather  than  the  active  chart.  They 
therefore affect every open chart.

2.4.1 The Status Bar

The Status Bar is the horizontal bar at the bottom of the TreeChart window that displays information  
about the current state of the program or the current chart. See online Help for details.

To hide or show the Status Bar:

either From the View menu, choose Status Bar
or Press CTRL+F2

2.4.2 The Toolbar

The Toolbar  is  the row of buttons across the top of  the TreeChart  window. These provide mouse 
shortcuts to many of the most commonly-used TreeChart commands. See online Help for details.

To hide or show the Toolbar:

either From the View menu, choose Toolbar
or Press SHIFT+F2

2.4.3 Chart Windows

In a word processor, a document window allows you to manipulate text.  In a drawing program, a  
document window allows you to manipulate picture elements (which might include lines, rectangles 
and text).

In a TreeChart chart window, you are manipulating boxes, not lines, rectangles or text. You can insert, 
delete and re-arrange boxes directly, but you cannot directly select or change the text within boxes, the  
style of text or boxes, or how connecting lines are routed.

These attributes of boxes are changed by means of dialog boxes, each shown as a result of choosing a  
command. After you make a change, TreeChart automatically:

■ Re-calculates how large boxes need to be to contain the text
■ Re-positions boxes so that they are evenly spaced and correctly aligned
■ Re-routes connecting lines



While re-calculating the chart is automatic, you have a considerable degree of control over how the re-
calculation is done.

The background color of a chart window is the same as the Background Color you choose for the 
chart. See section 8.1 for details.

Changing the scale at which your chart is displayed

TreeChart normally displays your chart at full size. You can choose to display the chart with various 
preset scaling or zoom factors, to see more of the structure of the chart (but with illegible text) or more 
clearly see small text sizes (but fewer boxes).

The zoom factor affects only how your chart is displayed on the screen, not how it is printed.

The Toolbar zoom list indicates the current setting for the active chart. To change the zoom factor, 
select a different setting.

Other Zoom commands

To From the View menu Keyboard

Zoom in (make boxes bigger) choose Zoom In press +
Zoom out (make boxes smaller) choose Zoom Out press -
Reset to normal (100%) zoom choose Zoom Normal press =
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A Quick Tour
In  the  online  copy  of  the  User  Guide,  this  chapter  has  been  placed  in  a  separate  file.  See  
TUTORIAL.WRI.
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Working with a Hierarchy of Boxes
In deciding that TreeChart would be a  generalized hierarchy illustration tool,  rather than simply a 
Company Organization Charting program (for instance), we've also tried to leave the terminology of 
the hierarchy general.

Each position in the chart is called a box, since each position will often (but not always) be drawn as 
some text within a box. If you think of TreeChart as a special-purpose database program, each box 
corresponds to a record.

Every box is at a certain level in the chart: the box at the top of the tree is at level 1, boxes directly  
below that are at level 2, and so on. Despite that, we'll say that a box at level 2 is below a box at level 
1. A box at level 3 is  a  subordinate of the box its connected to at level 2. Boxes can only be a 
subordinate of one other box, and that other box is always one level up. The sub-tree of a box is the 
box plus all boxes below it.

Occasionally, we need to talk about a box and its subordinates. When we do, we generally refer to 
these boxes as the parent and its children.

An example:

Here,
A is at level 1; B & C at level 2; D, E, F & G at level 3; H & I at level 4
D is a subordinate of B; E, F & G are subordinates of C
When C is a parent, E, F & G are its children
The C sub-tree includes C, E, F, G, H & I

4.1 The Caret and the Current Box

In  a  word  processor,  the  current  position  for  text  entry  is  indicated  by  a  caret.  With  graphical  
information, a simple caret isn't quite sufficient. In TreeChart, the caret is a thin line which surrounds a  
box. The surrounded box is called the Current Box. The color of the caret depends on the background 
color of the chart; for a white background, it will be red.

Any  command that  can  only  operate  on  one  box  is  always  performed  on  the  Current  Box.  Any 
command that could operate on a number of boxes simultaneously is performed on the selected boxes, 
or if no boxes are selected, the Current Box. See section 4.4 for details on selecting boxes.

4.2 Moving around a chart and a window

A

B

D
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Moving the caret,  and setting the Current  Box is  much like  setting the insertion point  in  a  word 
processor. When you move the caret the Current Box is automatically scrolled to make it visible within 
the chart window.

Working with a mouse

Mouse actions largely depend on whether or not you are pointing at a box when you press the mouse 
button. When the mouse pointer is over a box, the cursor changes (see online Help for details).

To move the caret, click on a box. A number of operations automatically make the box you're pointing 
at the Current Box as part of the operation.

Working with the keyboard

To move the caret to Press

The top-left box HOME

The bottom-right box END

The previous box at the same level LEFT ARROW

The next box at the same level RIGHT ARROW

The Current Box's parent UP ARROW

The Current Box's first subordinate DOWN ARROW

The ARROW keys cycle; for instance, if you reach the end of one level, then press RIGHT, the caret steps 
to the first box at the next level down.

Stepping the caret with the ARROW keys works in terms of the hierarchy rather than where boxes are 
drawn. For example, if you press the RIGHT key, the caret will always step to the next box at the same 
level; if boxes have been drawn down the page, this box would be drawn  below the Current Box.

Note: if SCROLL LOCK is selected, the ARROW, HOME and END keys scroll the chart within the window 
without moving the caret.

4.3 Inserting Boxes

You can insert a new box above, below, to the left or to the right of an existing box. The box you insert  
next to must first be made the Current Box.

As with stepping the caret with the ARROW keys (see section 4.2), box insertion works in terms of the 
hierarchy rather  than  where  boxes  are  drawn.  For  example,  to  add  a  co-worker  under  the  same 
manager, you would always insert left (or right) of an existing box. Where the new box gets drawn in 
relationship to the existing box is a separate issue.

After a new box is inserted, the caret is  always moved to make the new box the Current Box. If 
necessary, the chart window is automatically scrolled to make the newly-inserted box visible.

If you insert a new box  below a box that has subordinates, all those subordinates are 'demoted' and 
become subordinates of the newly-inserted box. In Organization Chart terms, inserting a box below a 
manager creates a new middle manager position.



If you insert a new box above, to the left or to the right of a box marked as an Assistant, the new box is 
automatically marked as an Assistant, too. See Chapter 7 for details of marking boxes as exceptions to  
the normal Layout rules.

If you make a mistake when inserting a box, you can undo the insertion. From the Edit menu, choose 
Undo Insertion. Alternatively,  press CTRL+Z.

Inserting a box with the mouse

With the mouse, you can insert a new box next to an existing box by simply dragging from the existing  
box. See online Help for details.

Inserting a box with the keyboard or menus

Move the caret to the box you'd like the new box to be inserted next to.

To From the Edit menu Keyboard

Insert Left choose Insert/Left press ALT+LEFT

Insert Right choose Insert/Right press ALT+RIGHT

Insert Above choose Insert/Above press ALT+UP

Insert Below choose Insert/Below press ALT+DOWN

Inserting a box in an empty chart

Inserting a box in an empty chart is just like inserting subsequent boxes, except that you don't have to 
tell TreeChart which box the new box should be connected to. The keyboard and menu box insertion 
commands are unchanged.

To insert a box in an empty chart with the mouse, drag from anywhere in the chart window.

To automatically be prompted for box text when you insert a new box

1 From the File menu, choose Preferences
In the Preferences dialog:

2 Select the Prompt for Text checkbox
3 Choose the OK button to complete the Preferences dialog

What does a new box initially look like?

The  style  of  each  box  is  determined  by  which  Layout  the  box  is  using.  Newly-inserted  boxes 
automatically use one of the Layouts you have defined. While you can change which Layout a box  
uses at any time, you can speed up your work by specifying how these  initial Layouts should be 
assigned. See section 6.5.1.

4.4 Selecting Boxes

Some TreeChart commands (for example, edit text) can only meaningfully operate on one box at a  



time. These commands always work on the Current Box.

Other TreeChart commands (for example, delete boxes) can work on a set of boxes simultaneously. 
These commands will work on the selected boxes, or if no boxes are selected the Current Box.

Selected boxes are shown on the display by being drawn inverted; white boxes becoming black, for  
instance. There are four basic methods of selecting boxes:

■ individually
■ by region
■ by position
■ dependent on their marker flag settings (see section 7.2)

By combining these techniques, an arbitrary set of selected boxes can quickly be defined.

To de-select all selected boxes:

either With the mouse, click on the chart
(click on the background to avoid moving the caret)

or From the Edit menu, choose Clear Selections
or Press CTRL+G

To select or de-select an individual box:

either With the mouse, CTRL+click on the box

or 1 Move the caret to the box
2 Press SPACE

This is just like performing multiple selections in a list box (for example, selecting a group of files in 
Windows File Manager).

Selecting a group of boxes by region

This can only be done with a mouse. If you press (and hold down) the left mouse button while not over 
a box, then start to drag, a dotted rectangle will be drawn to indicate the selection region. Releasing the  
mouse button completes the operation. All boxes entirely within the selection region will be selected. If 
you  move  the  mouse  cursor  outside  of  you  chart  window  during  this  operation,  the  window 
automatically scrolls.

The caret is moved to the first box in the selection region.

If you hold down  CTRL as you commence the selection, current selections are retained, and boxes 
within the selection region are added to the set of selected boxes. If you do not hold down  CTRL, 
current selections are cleared before selecting the boxes within the selection region.

Selecting a group of boxes by position

Four commands let you select a group of boxes (all are also available as Toolbar buttons):



To Select From the Edit menu Keyboard

All boxes choose Select All press CTRL+A

All boxes at the same choose Select Level press CTRL+H

Level as the Current Box

All boxes directly below choose Select Subordinates press CTRL+I

the Current Box

The Current Box, and all choose Select Sub-Tree press CTRL+T

boxes below it

These commands always add more selections. To remove any existing selections before selecting a 
new group, use the Clear Selections command.

4.5 Deleting Boxes

To delete boxes:

1 Select the boxes you wish to delete
(if no boxes are selected, the Current Box is deleted)

2 either From the Edit menu, choose Delete
or Press DEL

When  you  delete  a  box  that  has  subordinates,  but  don't  delete  the  subordinates  themselves,  the 
subordinates are 'promoted'. For example:

After deleting the selected box:

If you make a mistake when deleting boxes, you can undo the deletion. From the Edit menu, choose 
Undo Delete, or press CTRL+Z.

A

B selected

D E

F

C

A

B D E

F

C



If you undo the deletion in this example, all the promoted boxes are demoted to restore the chart to its 
original state.

4.6 To Cut, Copy or Paste Boxes

TreeChart offers the conventional commands to copy information to or from the Windows Clipboard. 
The Clipboard can be used to transfer information to another part of the chart, to a different chart or to 
a totally different program.

This section describes Clipboard use when preparing a single chart and transferring information from 
one chart to another. For a discussion of the wider issues involved in transferring information between  
programs, see Chapter 12.

To Copy boxes to the Clipboard:

1 Select the boxes you wish to copy
(if no boxes are selected, the Current Box is copied)

2 either On the Toolbar, click the Copy button
or From the Edit menu, choose Copy
or Press CTRL+C

If the boxes you selected were connected, the relative positions are remembered; if you copy a sub-
tree, it can be pasted as a sub-tree.

To Cut boxes to the Clipboard:

1 Select the boxes you wish to cut
(if no boxes are selected, the Current Box is cut)

2 either On the Toolbar, click the Cut button
or From the Edit menu, choose Cut
or Press CTRL+X

The Cut command is equivalent to Copy followed by Delete.

If the boxes you selected were connected, the relative positions are remembered; if you cut a sub-tree,  
it can be pasted as a sub-tree.

As when you delete boxes,  if  you cut  a box that  has subordinates,  but  don't  cut  the subordinates 
themselves, the subordinates are 'promoted'.

If you make a mistake when cutting boxes, you can undo the deletion. From the Edit menu, choose  
Undo Delete, or press CTRL+Z. If you undo a cut that caused boxes to be promoted, all the promoted 
boxes are demoted to restore the chart to its original state.

To Paste boxes from the Clipboard:

Pasting boxes is similar to inserting a set of boxes. You can paste the Clipboard contents below, to the 



left or to the right of the Current Box.

Move the caret to the box you'd like the pasted boxes to be connected to.

To From the Edit menu Keyboard

Paste Below choose Paste Below press CTRL+V

Paste Left choose Paste Left press CTRL+L

Paste Right choose Paste Right press CTRL+R

Pasting Below is regarded as the 'normal' operation; it is this command that has a Toolbar button, and  
has been assigned the standard Paste shortcut key.

If you make a mistake when pasting boxes, you can undo the insertion. From the Edit menu, choose 
Undo Insertion. Alternatively, press CTRL+Z.

If  you Paste  below a box that  has  subordinates,  all  those subordinates  are  'demoted'  and become 
subordinates of the  first pasted box. In Organization Chart  terms, pasting a box below a manager 
creates a new middle manager position.

If you Paste to the left or to the right of a box marked as an Assistant, the top-most of the pasted boxes  
is automatically marked as an Assistant, too. See Chapter 7 for details on marking boxes as exceptions  
to the normal Layout rules.

Copying boxes from one chart to another

When TreeChart copies (or cuts) boxes to the Clipboard, the information it saves in the Clipboard is in  
an internal format called TreeChart Outline Text format. The information saved includes the name of 
the Layout used by each box, but not the actual Layout settings.

It works this way because its the most natural: if a number of boxes use the same Layout, pasted boxes 
will use exactly the same Layouts as they used before they were cut. If you happen to change the  
Layout  settings  after  the  cut  command,  but  before  the  paste  command,  the  pasted  boxes  will 
automatically  use  the  new  Layout  settings  (not  the  ones  in  force  when  the  cut  command  was  
performed).

If you copy boxes from one chart to another, the Layouts used by these boxes might not be defined in  
the chart  they're  being pasted into.  Alternatively,  they might  be defined,  but  with totally different 
settings.

What TreeChart does when pasting boxes is this: if a box uses a Layout whose name is defined in this  
chart, the box will use that Layout, otherwise it will use the Default Layout for the level it has been 
inserted at. See section 6.5.1 for a description of Default Layouts.

This means that if you copy boxes from one chart to another, the pasted boxes will have the style & 
appearance appropriate for the chart being pasted into, rather than the chart they were copied from.

4.7 Undoing Changes



The  Undo  command  can  reverse  certain  changes  to  your  chart,  but  only  if  you  choose  Undo 
immediately  after  making  the  change.  For  example,  if  you  accidentally  delete  some  Boxes, 
immediately choose Undo to restore them.

Currently, the TreeChart Undo command undoes only Box deletion and Box insertion.

To undo recent box insertions or deletions:

either From the Edit menu, choose Undo
or Press CTRL+Z

Any insertion or deletion will be remembered until another insertion or deletion occurs, at which time 
it will be permanently enacted, and the new insertion or deletion remembered in case you wish to undo  
it.

If you insert or delete a group of Boxes in one operation, and subsequently undo that operation, the  
whole group will be affected. In particular, undone deletions will be restored to their original positions  
in the tree, no matter how disconnected the set of Boxes.

While this Undo facility seems limited, you probably won't be too aware of the limitation in practice,  
since the only operations you perform directly within the chart  window are selecting,  inserting & 
deleting  Boxes.  Other  operations  (like  changing  a  Box's  appearance)  are  performed by  means  of 
dialogs which offer the option of proceeding with or canceling any changes you make.

4.8 Swapping box positions

If you need to change the order in which subordinates are presented, the Swap command saves you 
having to perform multiple Cut & Paste operations. The Swap command is only available if exactly 
two boxes are selected, and both boxes have the same parent box.

The Swap command exchanges the positions of the two selected boxes, and all boxes below these two.

To swap two sub-trees:

1 Select the top-most boxes of the two sub-trees you wish to swap
2 either From the Edit menu, choose Swap

or Press CTRL+W

For example:

After swapping the selected boxes:

A

selected

E F

C selected

G



4.9 Using outlining to concentrate on one part of your chart

Outlining is the technique offered by more sophisticated word processors to allow you to hide parts of 
a document, and concentrate on other parts.

For example, this describes the structure of a simple document:

The Document
Chapter 1

Section 1
Section 2

Sub-section 1
Sub-section 2

Chapter 2
Section 1
Section 2

Showing the document in this form already illustrates one aspect of outlining: hiding the actual text 
within each section or sub-section, and just concentrating on the section headings. This will have been  
achieved by using a command to collapse the sections.

If you wanted to edit the text within Chapter 1, Section 1, this heading would be expanded to show the 
text beneath it.

Another example of outlining that you may be familiar with is the directory windows of the Windows 
File Manager.

TreeChart offers outlining to perform much the same function: hiding some aspects of your chart, and 
allowing you to better concentrate on other aspects.

The example document we described above could be shown in TreeChart terms like this:

If you just wanted to have a 'top-level' view of the chart, you could select the two 'Chapter' boxes, then 
use the Collapse command. The chart would be redrawn like this:

A

selected

G

C selected

E F

The Document

Chapter 1

Section 1 Section 2

Sub-section 1 Sub-section 2

Chapter 2

Section 1 Section 2



Notice that when recalculating the box positions, the 'Chapter' boxes are now placed much closer 
together. Box placement depends only on visible boxes, so that the chart looks attractive whatever 

outlining selections you have chosen.

In an Organization Chart, Collapse is useful for viewing management, and hiding other staff.

If you insert or paste a new box below a box that has been collapsed, the collapsed box is automatically 
expanded (to show the new box), and the new box is automatically collapsed (to keep the demoted  
subordinates hidden).

If you collapse a box marked as Invisible, this is handled as a special case, as described in section 7.5.

You reveal whatever's hidden below collapsed boxes by expanding them. Two commands do this: the 
Expand command expands the selected boxes, while the Expand All command expands all collapsed 
boxes.

As well as hiding things below a box, TreeChart also allows you to hide things above a box. Returning 
to the original chart, we can focus our attention on Chapter 1 by making the 'Chapter 1' box the Current 
Box, then using the Focus command. The chart would be redrawn like this:

In saying that this hides all boxes above the Current Box, we're being a bit inaccurate; what the Focus 
command really does is leave only the Current Box and all boxes below it visible; all boxes above it or 

on different branches are hidden.

In an Organization Chart, Focus is useful for viewing just one department, and hiding all others.

You can only focus on one box at a time. When you are focusing on a box, a mark is displayed beside 
the command name on the View menu. To remove the focus, and reveal the true top-level box, choose 
the command again.

If the box you have focused on 'disappears', the focus is automatically moved to the parent of the box 
that had the focus. This is done to ensure that you can always see the context you're working in. A box 
can 'disappear' in two ways: by being deleted, or if you collapse a box marked as Invisible. See section  
7.5 for a description of how Invisible boxes are handled as special cases.

As you might expect, the Focus & Collapse commands can be combined. For example, you might wish 
to focus on Chapter 1, and then collapse the Section boxes to give you this:

The Document

Chapter 1 Chapter 2

Chapter 1

Section 1 Section 2

Sub-section 1 Sub-section 2



A Summary of Outlining commands

To From the View menu Keyboard

View the whole chart choose View All press CTRL+Q

Collapse selected boxes choose Collapse press CTRL+K

Expand selected boxes choose Expand press CTRL+E

Expand All boxes choose Expand All press CTRL+SHIFT+E

Focus on the Current Box choose Focus press CTRL+F

(or remove Focus)

The Collapse and Expand commands operate on the Current Box if no boxes are selected. The View 
All command removes focus and expands all collapsed boxes.

The  commands  are  unavailable  (dimmed)  if  they're  not  meaningful.  For  example,  the  Expand 
command  will  be  unavailable  if  the  Current  Box  (or  at  least  one  of  the  selected  boxes)  is  not  
Collapsed. The Toolbar button therefore provides feedback as to whether the Current Box is collapsed 
or not.

4.9.1 The Current View

The outlining selections you make define the Current View of the chart.

Wherever sensible, commands you select are always performed on the Current View. For example, the  
Select All command selects all boxes in the Current View. 

The only operations that are always performed on the whole chart, rather than the Current View are:

■ Saving the chart (in TreeChart format or Text format)
■ Adding, deleting or renaming a box Text Field

Working with the Current View rather than the whole chart is particularly useful when you need to 
output the finished chart:

■ When you print, its the Current View
■ If you copy a picture to the Clipboard, its the Current View
■ If you save a picture-format file, its the Current View

TreeChart offers the option of printing as a poster (on a number of sheets of paper) or fitting the chart  
to a single sheet of paper. Using outlining with an Organization Chart, for example, you could instead 
choose to print each department or layer of management as individual pages, each with its own border  
and titles.

4.9.2 The Chart Background Color

Chapter 1

Section 1 Section 2



A chart has a background color which is used for the chart window, and when choosing box colors.  
Some of the box positioning options cause boxes to be framed by other boxes. The background color 
of the framed boxes is therefore the interior (fill) color of the framing box.

If you use outlining techniques to Focus on a framed box, to hide all boxes above it and on different 
branches, you might want to temporarily adopt the framing box's interior color as the chart background 
color, rather than continue to use the normal background color. See section 8.1.

The background color used in the chart window is the background color used if you print a chart, copy 
a picture to the Clipboard or save as a picture-format file.

4.10 Charts with more than one Hierarchy

You can create charts with more than one hierarchy by inserting a number of top-level boxes.

These sub-trees are regarded as totally separate. As illustrated above, they will always be placed across 
the page with a fixed spacing. No attempt is made to position the sub-trees closer together.

If your chart requires more than one top-level box and this arrangement or spacing is unsatisfactory,  
you should insert a dummy box above the top-level boxes:

By assigning an appropriate Layout to this box, you can hide the box, omit connecting lines, and select 
the desired arrangement and spacing of its subordinates (the top-most visible boxes).

If this is a regular requirement, you could save the Layout used by the dummy box in a Template File. 
If you intend using the Template to create charts automatically from text-format files, you should also 

save the dummy box in the Template. Working with Template Files is described in Chapter 11.
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Working with Text Fields
Like a database record, the text that appears within a box is divided into Fields. Like a database, all 
boxes (records) have the same number of Fields. When creating a chart you must decide how many 
Fields you need, and what to name them. You don't have to get this perfect before starting a chart: you  
can add, delete or rename Fields at any time.

When designing a database, you would probably make a separate Field for each part of the information 
that you might later want to search for or sort on. A similar consideration applies to TreeChart: when  
illustrating the information, each Field can be hidden or shown, has a single font and a position within 
the box. Fields cannot be split into multiple lines within a box.

The way that a box's fields are illustrated is defined by which Layout the box is using. See Chapter 6.

Each Field is limited to 256 characters.

If you create a new chart, the initially defined Fields are specified by the Template File. If you create a  
new chart without selecting a Template, TreeChart initially defines two Fields: Name and Position.

Border Fields

The Border which frames your chart when printing has its own set of Fields. Working with the Border 
Fields is just like working with box Fields.

If you create a new chart without selecting a Template, TreeChart initially defines two Border Fields: 
Title and Subtitle.

5.1 Defining Fields

Before being able to enter the text associated with a particular Field in a particular box or the Border,  
the Field must be defined. The process of adding, deleting or renaming fields is the same for boxes and 
the Border.

Field Names must be unique within a chart, and must be less than 256 characters. Border Field Names  
are distinct from Box Field Names.

To define box text fields:

either From the Chart menu, choose Define Fields
or Press F3

To define border text fields:

either From the Chart menu, choose Border Fields
or Press SHIFT+F3

The Define Text Fields dialog (or the Define Border Text Fields dialog) allows you to build up a series 



of changes to the Text Fields, then proceed to alter the chart or cancel the changes. If you cancel the  
dialog, no changes will be made to your chart.

Note: the Fields list in this dialog permits several Fields to be selected. If you are unfamiliar with  
working with extended-selection lists, Appendix 2 summarizes keyboard shortcuts, while Chapter 4  
("File Manager") of your Windows User's Guide gives step-by-step instructions.

To Rename an existing Field:

1 In the Fields list, select the existing Field you wish to rename
2 In the New Name edit control, enter the new name
3 Choose the Rename button

The Rename button is only enabled when text has been entered in the New Name control, and one 
Field has been selected.

To Add a new Field:

1 In the New Name edit control, enter the name of the new Field
2 Choose the Add button

The Add button is only enabled when text has been entered in the New Name control.

To Delete an existing Field:

1 In the Fields list, select the Field (or Fields) you wish to delete
2 Choose the Delete button

The Delete button is only enabled when at least one Field has been selected, and when no text has been 
entered into the New Name control.

Any number of Fields can be deleted in one operation by selecting a group of Field Names.

Completing the operation:

Choosing the OK button causes the changes to be made to the chart.

Box Fields:

For newly added Fields, all boxes and Layouts will have the Field added. Box text for this Field will  
initially be empty, and the Field will initially be hidden in all Layouts. You will need to edit each 
Layout in which you want the Field to be visible.

For deleted Fields, all boxes and Layouts will have the Field deleted.

Border Fields:

For newly added Border Fields, text will initially be empty, and the Field will initially be visible. You  
will need to edit the Border Layout  if the default font or position of newly added Border Fields is not  



as you wish.

5.2 Entering or Changing Text

The process of entering or changing the contents of text fields is the same for boxes and the Border.

Note: You can choose to be prompted for text whenever you insert a new box. See section 4.3.

To change the text within the Current Box:

either double-click on any box (this also makes it the Current Box)
or From the Edit menu, choose Text
or Press ENTER

To change the Border text:

either double-click on the chart background (i.e. not over a box)
or From the Chart menu, choose Border Text
or Press F7

Text fields, and their associated text are presented as a table. The number of fields, and their names, 
will depend on what Text Fields or Border Text Fields have been defined for your chart.

Only the associated text can be modified, not the field names. See section 5.1 for renaming fields.

Movement around the table is similar to a spreadsheet.  Note that the  TAB key circulates the focus 
between the table, the OK button and the Cancel button. To move around the table, use the  UP and 
DOWN keys (or, with the mouse, click on a cell).

Individual text fields act like normal single line edit controls. One consequence of this is that you can 
only copy and paste individual fields (not a group of fields).

To Press

Copy selected text CTRL+C

Cut selected text CTRL+X

Paste text CTRL+V

Pasting text from another program (via the Clipboard) can result in TAB characters being placed in 
your text. These are shown in this dialog as a vertical bar, indicating a non-displayable character. When 
you complete the dialog, TreeChart converts each TAB to a single space. 

5.3 Automatically Calculated Fields

In addition to the Fields you define, a number of other fields are also available when presenting boxes 
or the Border. The contents of these fields is calculated automatically. Illustration styles for these are  
chosen in the same way as normal fields, and you can also choose from a range of available formats.



Box Fields

Field Meaning

<level> The level within the chart
<number> Unique box number. Boxes are numbered top-left to bottom-right
<relative number> Subordinate number. Subordinates are numbered left to right
<outline number> Box classification code (e.g. 1.2.3.2)

Automatically  calculated box fields  reflect  the  entire  chart.  If  you use outlining techniques,  these  
numbers don't change.

Border Fields

Field Meaning

<date/time> The date/time the chart is printed (or a picture exported)
<file name> The full pathname of the chart
<file title> The chart window title
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Working with Layouts
A Layout  defines  how a  box  appears  in  a  chart,  and  how it  arranged with  and  connected  to  its  
subordinate boxes.

Layouts are similar to Style Guides found in more sophisticated word processors, and can greatly assist 
you in achieving a consistent appearance to your charts. Layouts are also similar to form letters in as 
much that text fields are represented as placeholders. When a box is drawn, placeholders in the Layout  
its using are replaced by the text for the corresponding fields in the box.

Once you've defined a Layout, you can use it as often as you like. Every box in a chart uses one of the 
Layouts you have defined. When you change the settings of a Layout, it automatically affects every 
box using that Layout. You can tell a box to use a different Layout any time you like.

You can define any number of Layouts. Each must be assigned a unique name so that it can be referred 
to while preparing the chart. Give a bit of thought to naming your Layouts, since well-chosen names 
can make it easier for you to choose which Layout a box should use. Two possible approaches are to  
name Layouts  functionally (e.g.  Manager,  Assistant,  Other Staff)  or  descriptively (e.g.  'blue circle; 
connect centers', 5x3 cream box).

A Layout has three groups of settings:

■ Text Settings
■ Box Settings
■ Connections Settings

The Layout's Text and Box Settings apply to every box using the Layout. The Connections Settings 
apply only when a box using the Layout has subordinate boxes. For example:

The Text and Box Styles used by each box is determined by the Layout each box is using. The 
Connections Styles are used only when a box has subordinates.

In this example, boxes D, E & F are positioned and connected dependent on the Connections Styles of  
the Layout used by box D (Layout 2).

Boxes A, B, C & the D sub-tree are then positioned and connected dependent on the Connections 
Styles of the Layout used by box A (Layout 1).

A
Layout 1

B C D
Layout 2

E

F



6.1 Changing Layout Settings

Since  any  number  of  boxes  may  be  using  the  Layout  you  change,  any  changes  you  make  will  
automatically affect all boxes using the Layout. If you want just one box to look different, you should  
use a different Layout for that box. See section 6.5 for changing which Layout a box uses or section 
6.6 for creating a new Layout.

To edit the Layout used by the Current Box:

either SHIFT+double-click on any Box (this also makes it the Current Box)
or From the Layout menu, choose Edit
or Press SHIFT+ENTER

To edit any Layout in a chart:

1 either On the Toolbar, click the Define Layouts button
or From the Layouts menu, choose Define Layouts
or Press CTRL+D

In the Define Layouts dialog:
2 Select the Layout you wish to edit from the list of defined Layouts
3 Choose the Edit button

(double-clicking on the Layout name is a shortcut for steps 2 & 3)

The  Edit  Layout  dialog  allows  you  to  change  every  aspect  of  a  box's  appearance,  and  provides 
immediate feedback on the effects of any changes you make. Feel free to try various combinations of 
options; you can always cancel the changes if you want.

The sample providing feedback uses the field names to indicate Field position & appearance. When the 
Layout is subsequently used as we draw the chart, the size of the box is determined by further factors,  
such as the length of the text and the chart-wide size-matching rules. Boxes will always be made big  
enough to contain the text you have entered.

Completing the dialog causes all  changes to be reflected in all  boxes currently using this Layout.  
Canceling the dialog leaves your chart unchanged.

6.2 Text Settings

All the Text controls in the Edit Layout dialog affect only the field selected in the drop-down list of  
Field Names. You must first select the field you wish to change.

To

Hide or show the field Select the Hide checkbox

Change the font, style, size or color Choose the Font button



Move the field to a different position Use the Alignment controls (see section 6.2.1)

Add fixed text before or after the field Choose the Options button (see section 6.2.2)

Adjust spacing between fields on the Choose the Options button (see section 6.2.3)
same line, limit the number of characters
shown or tabulate fields

Change the format of calculated fields Choose the Options button (see section 6.2.4)

You can quickly change the more common text styles for any group of fields within any group of 
Layouts. Common text styles include hide or show the field, plus font, style, size and color.

To change common Text Styles:

either On the Toolbar, click the Text Styles button
or From the Layouts menu, choose Text Styles
or Press CTRL+Y

The Text Styles dialog is an extended font-selection dialog: after selecting Layouts and fields, you can  
apply changes to the various text styles and immediately see the effect. You can then continue to make 
other changes, to the same or other Layouts and fields.

Choose the Increase or Decrease buttons to immediately enlarge or reduce the point size of text, while 
maintaining relative differences. To make fields the same point size, use the Size control.

Choosing the OK button applies the changes and completes the dialog. Choosing the Apply button 
applies the changes (redrawing the chart) but you remain in the dialog. Choosing Cancel or Close 
completes the dialog without apply changes made since the last changes were applied.

6.2.1 Positioning and Aligning Fields

Fields associated with a box are displayed as a number of lines of text. Lines of text are grouped into 
paragraphs, each of which has a particular position in relation to the box:

The above, top, bottom and below-aligned paragraphs are fixed distances from the box's border. These 
margins (and the minimum distance between top, center and bottom-aligned paragraphs) can be set for 

each Layout. See section 6.3.1.

Within an individual paragraph, single line spacing is used.

above

below

top

center-1
center-2

bottom



The Vertical Alignment list allows you to move a field from one paragraph to another. The Up and 
Down buttons nudge the field up or down a line, creating and merging lines as necessary.

Within a single line, fields are grouped into columns, each of which has a particular position in relation  
to the box:

The left and right columns are fixed distances from the box's border. These margins can be set for each 
Layout. See section 6.3.1.

As shown above, columns serve only for alignment within a single line. For example, a centered field  
in one line can extend beyond a left or right-aligned field in another line.

You can have any number of fields within a single line, and you can control an individual field's width 
and the spacing between fields within a line. See section 6.2.3.

The Horizontal Alignment list allows you to move a field from one column to another within a line. 
The  < and  > buttons nudge the field left or right within a line, exchanging field order or changing 
columns as necessary.

6.2.2 Adding fixed text before or after a field

You can specify text that should precede or follow a field when it is being drawn. This can be used to  
label fields or indicate quantities. For example:

Here, only 'John Smith' and the date are actually stored in the box; the "d.o.b. " text was specified as a 
prefix. All boxes using this Layout would have the date field prefixed by "d.o.b. ".

Prefix and suffix text is shown using the same font as the field itself.

Prefix and suffix text is specified in the Text Field Options dialog. This is shown by choosing the 
Options button after selecting the required field when editing the Layout.

Enter the required prefix and suffix text in the Prefix and Suffix edit controls.

The text finally displayed is prefix + box text + suffix. If you want spaces between the prefix and box 
text, or between the box text and suffix, the spaces should be added to the prefix or suffix.

If the field is empty for a box, the prefix and suffix are normally omitted. If you want the prefix or  
suffix to be shown when the box field is empty, select the Show Prefix if Field empty or the Show 
Suffix if Field empty checkboxes.

left center right

left center right

John Smith
d.o.b. 5/10/55



6.2.3 Field Width and Spacing

The space needed to show each text field is the main factor in determining the size of a box. Normally,  
TreeChart will make each box large enough to show whatever text is associated with the box, but you 
can control how this is done.

Settings related to field width and spacing are specified in the Text Field Options dialog. This is shown  
by choosing the Options button after selecting the required field when editing the Layout.

The width of a field can either be automatically calculated or a fixed size.

Automatic

This is the default option, and the field width depends on how much text is to be shown.

The gap between fields on the same line is determined by the number of spaces that follow each  field.

You can truncate lengthy fields by limiting the number of characters to be shown. The limit specified  
in the  Max Chars control is imposed on the box text; any prefix or suffix text is unaffected. See 
'Handling Truncated Fields' (below) for further information.

Manual

Manually specified field widths are fixed distances. This allows you to tabulate and align groups of  
fields, but text will be truncated if its too wide for the fixed width. Manual field widths are particularly 
useful for tabulating fields with the same horizontal alignment.

Box text (including any prefix or suffix text) will be displayed within a fixed text width. To control 
spacing between fields on the same line, you must also specify the distances before and after this fixed 
width.

Text can be left-, center- or right-aligned within the fixed text width you have specified.

fig 1

fig 2

In the above examples, the two fields are both aligned with the left edge of a borderless box. In fig 1, 

93 David
101 Margaret
3 Peter

93 David
101 Margaret
3 Peter



the width of the number field was automatically calculated and is followed by one space. In fig 2, the 
number field has a manually set width, and the name fields now align correctly.

Handling Truncated Fields

Fields can be truncated if you manually set a fixed width or if you select a limit on the number of 
characters to be shown for an automatically calculated width.

In  both  cases,  the  right-most  characters  are  normally  omitted.  Select  the  Truncate  Start  of  Text 
checkbox if you prefer to have the left-most characters omitted.

Select the Indicate Truncated Text checkbox if you would like "..." to precede or follow the text to 
indicate that truncation has occurred.

6.2.4 Changing the format of calculated fields

As mentioned in section 5.3, a number of automatically calculated fields are available in addition to the 
fields you have defined. Most calculated fields can be presented in a number of different formats.

The field format is specified in the Text Field Options dialog. This is shown by choosing the Options 
button after selecting the required field when editing the Layout.

Select the desired option from those shown in the Format list.

Boxes

Field Format Options

<level> Counter: starting at 1, 0 a or A
<number> Counter: starting at 1, 0 a or A
<relative number> Counter: starting at 1, 0 a or A
<outline number> Box classification code, with all numbers starting at 1, 0, a or A

Border

Field Format Options

<date/time> Various (date, time or date and time)

For each of these fields, you can also choose "(default)". If this option is selected, the program-wide  
default format is used, rather than any Layout-specific format. See Appendix 1.

6.3 Box Settings

The Box controls in the Edit Layout dialog affect the way the box is presented and its size.

To

Change the box shape Select from the Shape list



Change the box border width Select from the Border Width list

Remove the box border In the Border Width list, select '(none)'

Change the box border color Choose the Border Color button

Change the box interior color Choose the Fill Color button

Make the box interior automaticallySelect the Transparent checkbox
the same color as whatever is behind
the box

Change the shadow depth or direction Select from the Shadow list

Change the shadow color Choose the Shadow Color button

Change the margins between text and the Choose the Size button (see section 6.3.1)
box, specify a minimum box size, or
specify a fixed aspect ratio for the box

6.3.1 Box Size

A Layout's Box Size settings can be changed to specify:

■ Margins between the box and the text paragraphs
■ How paragraphs above and below the box are left and right aligned
■ A minimum box size
■ A fixed height to width ratio (e.g. to make rectangles square)

To change the Box Size Settings of the Layout used by the Current Box:

either From the Layout menu, choose Size
or Press F8

You can change the Box Size of any Layout by choosing the Size button when editing the Layout.

Text Margins

Boxes are always big enough to contain their associated text, then various margins are added before  
determining the actual  box size.  The meaning of the eight margins is  illustrated by the following 
diagram:



Lines within a paragraph always have single line spacing.

The Above,  Below,  TopMiddle  and BottomMiddle  margins are  only used if  any fields  have been 
placed in the above, below, top or bottom paragraphs respectively. If this is not the case, these margins  
are totally ignored and have no effect on box size or spacing.

The Top, Bottom, Left and Right margins have, in a sense, two meanings:

In determining the initial box size, TreeChart calculates how much space is needed for the text, then  
adds these margins to determine an initial box size. If Box Size rules specify a minimum, or Match 
Box Size rules require equal sized boxes, the box may then be made bigger.

When drawing a box, these margins are subtracted from the box size to determine where to place text. 
The overall effect, therefore, is that a right-aligned text field (for example) will  always be a fixed 
distance from the right edge of the box, irrespective of how wide the box is made to satisfy size  
matching rules.

Note that centered text (both vertically and horizontally) is centered within the region defined by the 
final box size minus the Top, Bottom, Left and Right margins. If your Top and Bottom margins aren't 
equal, or if your Left and Right margins aren't equal, the text will not be centered with respect to the 
box itself.

Choosing which margins are used for text positioned above & below the box

The checkboxes Push Out Above and Push Out Below determine the Left and Right margins for the 
paragraphs above and below the box. Paragraphs inside the box are always inside the left and right 
sides of the box (the distance inside being determined by the Left and Right margins). Paragraphs  
above and below the box can use the same Left and Right margins, but if the corresponding checkbox 
is selected instead regard the outer edge of the box as the left and right margins.



Size Control

Box size calculation is by default automatic: box size being the space needed for the text plus margins.  
You can optionally specify a minimum height and/or width for a box. If you specify both a minimum 
height and a minimum width, you can also select that these settings amount to a fixed aspect ratio,  
which means that boxes using this Layout will always have the same height to width ratio.

Two examples:

To make rectangular box shapes square, or elliptical box shapes circular, select a minimum height and 
width of zero, and select Fixed Ratio. Since the minima specified are zero, there is effectively no 
minimum size to a box, but they will always be square (or circular) since the ratio is 1:1.

To force boxes to be 5x3, and have a minimum width of 2.5cm, select a minimum width of 2.5cm and 
a minimum height of 1.5cm, and select Fixed Ratio.

Selecting a fixed aspect ratio for a box affects the behavior of any box size-matching rules you may 
specify for the chart. See section 6.3.2 for details

6.3.2 Matching Box Sizes

While the size of individual boxes is determined by the text that they contain, and Layout options like 
Fonts & Box Size, TreeChart also offers a variety of options to automatically make boxes the same 
size.

To show the Match Box Size dialog:

From the Chart menu, choose Match Box Sizes

The height and width of Boxes can be controlled independently:

Independent No further size adjustments are made.

Equal Throughout Chart All Boxes will have the same size.

Equal Within Levels All Boxes at the same level will have the same size.

Equal Among Subordinates All Boxes with the same Parent will have the same size.

Equal Using Layouts All Boxes using the same Layout will have the same size.

Wherever sizes are changed, they are always increased.

Matching box sizes when Outlining

The For Sizes Scan radio buttons select whether boxes hidden by outlining should be considered when 
matching sizes:

To Select



Produce the most attractive individual charts Current View
Have consistent box sizes over a set of sub-charts Entire Chart

Marking boxes as exceptions to the size-matching rules

You can mark individual boxes as exceptions to the chosen size-matching rules. The markers allow you 
either to ignore a particularly large box (and make all other boxes the same size as the second largest  
box), or to prevent a particularly small box from being enlarged. See section 7.7 for details.

Size matching rules and fixed-ratio boxes

If you specify a fixed height to width ratio for boxes using a Layout (section 6.3.1) the height of the  
box will obey the size matching rules, and the width of the box is then be re-calculated to obey the 
aspect ratio rule.

6.4 Connections Settings

The Connections controls in the Edit Layout dialog allow you to change all options affecting how this 
box is connected to its subordinates:

■ Relative position, alignment & spacing of this box & subordinates
(the routing of connecting lines is implied by this)

■ The width & color of the connecting lines

To

Change the arrangement of a box and Select from the Style list (see section 6.4.1)
it subordinates

List some subordinates and place the Select from the Style list (see section 6.4.2)
other across

Enlarge a box to cover its subordinates Select from the Style list (see section 6.4.3)

Change a box so it frames its subordinates Select from the Style list (see section 6.4.4)

Change the routing of connecting lines Select from the Style list (see section 6.4.5)

Change the width of connecting lines Select from the Line Width list

Remove connecting lines In the Line Width list, select '(none)'

Change the color of connecting lines Choose the Line Color button

Change how subordinates are aligned Select from the Child Align list (see 6.4.6)

Change the distances between boxes Choose the Spacing button (see section 6.4.7)



or the point at which connecting lines
change direction

6.4.1 Arranging a box and its subordinates

The  selection  made  in  the  Connections  Style list  in  the  Edit  Layout  dialog  indicates  both  the 
arrangement of a box using the Layout with its subordinates, and how connecting lines are routed.

The arrangement of a box using this Layout and its subordinates is a two-step process:

1. Position the subordinates
2. Position the box using this Layout (the 'parent' box)

Positioning Subordinates

Subordinates are all placed across the page, or all placed down. See section 6.4.6 for options available 
when aligned subordinates as they are positioned.

One exception to this is the option to list some subordinates and place remaining subordinates across  
the page. See section 6.4.2.

Positioning the Parent Box

After positioning subordinates, the parent box (the box actually using this Layout) is positioned. Either 
the parent box will frame its subordinate sub-trees (see section 6.4.4) or it will be positioned relative to  
its immediate subordinates: if  subordinates are placed across,  the parent will  always be above the 
subordinates.  If  subordinates are placed down,  the parent  may be above or  to the  left  or  right  of 
subordinates.

When the parent is above its subordinates a large number of positioning options are available. These 
can be summarized as follows:

Offset Left The parent connection point is the left edge of the left-most subordinate - Offset Distance margin
Centered The parent center is the mid-point between the left-most and right-most subordinate edges

Offset Right The parent connection point is the right edge of the right-most subordinate + Offset Distance 
margin

The following options are only available where subordinates are placed across:

Above Left The parent center matches the center of left-most subordinate 
Above Center The parent center matches the center of subordinate nearest the mid-point
Above Right The parent center matches the center of right-most subordinate

Options that make use of the Offset Distance margin (see section 6.4.7) are indicated with a filled box 
in the Styles list. Options that ignore the Offset Distance margin are indicated with a hollow box.

6.4.2 Listing some subordinates

Two options in the Connections Style list in the Edit Layout dialog position some subordinates down 
the page as a list, then position this list and remaining subordinates across the page:



TreeChart automatically determines which subordinates to group into a list: it lists those subordinates 
that don't themselves have subordinates.

In an Organization Chart, managers would be positioned across, while non-managers would be listed.  
In a  parts  list,  sub-assemblies would be positioned across,  while individual components would be 
listed.

In general terms, children that are parents in their own right are positioned across, children who are not  
also parents are listed. Using outlining facilities has no effect on this: a collapsed box is still a parent,  
even though its children are hidden.

The  order of subordinates is significant for these styles, since only adjacent non-parents are formed 
into a list. To form all non-parents into a single list, they must be adjacent. Note that boxes marked as  
Assistants (as described in section 7.3) are not regarded as non-parents. If you find that non-parents 
have  unexpectedly  been  grouped  into  two lists,  its  probably  because  you've  marked  one  of  the 
subordinates as an Assistant. To group the parents into a single list, swap the position of the Assistant 
with another box. The Swap command is described in section 4.8.

Since these styles are hybrids of the basic across or down styles, they use both sets of distances to  
specify the spacing between boxes. See section 6.4.7.

6.4.3 Boxes enlarged to cover subordinates

Some options in the Connections Style list in the Edit Layout dialog have a parent box drawn wider or 
taller than normal. This means that when re-calculating the chart, TreeChart will automatically stretch 
the parent box to make it 'cover' the subordinate boxes, as illustrated here:

Stretching boxes is done after calculating their minimum size and size matching; if the parent is 
already bigger than its 'stretched' width or height, it will not be made smaller.

6.4.4 Boxes that Frame subordinates

Two options in the Connections Style list of the Edit Layout dialog cause the parent to surround (or  
frame) its subordinate sub-trees, after positioning the subordinate sub-trees across or down:

        

stretched



The size of the parent box is automatically calculated; the subordinate sub-trees effectively replace the 
vertically-centered text paragraph. The vertically centered paragraph is therefore normally hidden, but 
will be shown if the box has no subordinates, or if its subordinates have been hidden by using outlining 

techniques.

The distinction between Box Size and Spacing is less obvious with these styles: the distances between 
subordinates  are  specified  by  the  Layout's  Spacing  settings,  while  the  distances  between  the 
subordinates and the frame (& its text) are specified by the Layout's Size settings.

You can specify a specific aspect ratio for a surrounding box, but not a minimum size. Surrounding 
boxes are also ignored when matching box sizes.

If you select a box which frames other boxes, it is highlighted slightly differently: instead of inverting 
the whole box, only the area outside the surrounded sub-trees is inverted.

If you use outlining to Focus on a framed sub-tree, you can choose whether TreeChart regards the 
frame color as the chart background color, or whether the Border background color is retained. See 
section 4.9.2 for details.

6.4.5 Connecting Lines

The  selection  made  in  the  Connections  Style list  in  the  Edit  Layout  dialog  indicates  both  the 
arrangement of a box using the Layout with its subordinates, and how connecting lines are routed.

Where connecting lines have a common stem then branch to individual subordinates, the position of  
the common stem is specified by the Spacing settings of the Layout used by the parent box. See 6.4.7.

The connecting lines between a box and its subordinates are routed in a uniform style, and have a 
common line width and color.

Connecting lines and boxes marked as exceptions to the rules

While subordinates are normally positioned and connected uniformly, you can mark boxes as being 
exceptions to these rules (see Chapter 7). Some of these exceptions affect how connecting lines are 

Top-Aligned text

Bottom-Aligned text

Top-Aligned text

Bottom-aligned text



handled.

Assistants Connecting lines to boxes marked as Assistants use the same width and color as lines 
to normal subordinates.

Disconnect Boxes marked as Disconnect have the connecting line to their parent omitted, plus 
any  part  of  a  common  connector  drawn  only  to  connect  to  the  disconnected 
subordinate

Invisible For boxes marked as Invisible, the Layout used by the box determines the 
routing of connecting lines to its subordinates, but the line width and color to be used 
are inherited from the Invisible box's parent.

Co-Managers Co-Manager  connecting  lines  are  normally  the  same  width  and  color  as  the 
connectors from the marked box  to its subordinates. You can choose to show the line 
as a dotted hairline by also marking the Co-Manager box as Co-Manager Links as 
Dotted Lines.

6.4.6 Aligning Subordinates

The Child Align list in the Connections section of the Edit Layout dialog determines how subordinates 
of a box using this Layout are aligned as they positioned across or down the page.

There are six options: three align subordinate boxes, and three align subordinate sub-trees.

Some Connections Styles list  some subordinates,  then place remaining subordinates across.  Listed 
subordinates  are  always  left-aligned,  then  treated  as  a  single  large  box  when  aligning  with  the 
remaining subordinates.

6.4.7 The Spacing between a box and its subordinates

A Layout's Spacing settings can be changed to specify:

■ The distance between subordinates as they are positioned
■ The relative position of the parent box after positioning subordinates
■ The degree to which subordinate sub-trees can be tucked into or under one another
■ The point at which connecting lines change direction

To change the Spacing Settings of the Layout used by the Current Box:

either From the Layout menu, choose Spacing
or Press SHIFT+F8

You can change the Spacing of any Layout by choosing the Spacing button when editing the Layout.

Up to six distances can be specified. The distances actually used depend on the arrangement of the box 
and its subordinates, as specified in the Connections  Style list when editing the Layout used by the 
parent box.



Minimum Distance between this box and subordinates

Used  by  all  styles  except  those  that  frame  subordinate  sub-trees.  When  the  parent  is  above  its 
subordinates,  this  is  the  vertical  distance  between  the  bottom  of  the  parent  and  the  top  of  the  
subordinates. When the parent is beside its subordinates, this is the horizontal distance between the  
parent and its subordinates. For example:

Minimum Vertical and Horizontal Distances between subordinates

Used  in  all  styles  to  specify  how  close  together  subordinate  sub-trees  should  be  positioned. 
Subordinate sub-trees are normally positioned so as to minimize the size of the chart. This can involve  
tucking sub-trees into or under gaps in other subordinate sub-trees. For Example:



If you prefer isolated sub-trees, select the Prevent Subordinate Sub-trees Overlapping checkbox.

Offset Distance between this box and subordinates

Used only by certain styles (those with a solid fill to the parent box in the Style list). This indicates the 
horizontal offset from the point at which the connecting line leaves the parent box to the left or right  
edge of the subordinates. For example

Vertical and Horizontal Stem Distances

Used where the connecting line has a common portion, with a stem drawn from the parent or to each  
subordinate. These indicate the length of the stem. Also used to position Assistants. For example:



6.5 Changing which Layout boxes use

Once you've defined a Layout, you can use it as often as you like. Every box in a chart uses one of the 
Layouts you have defined. When you change the settings of a Layout, it automatically affects every 
box using that Layout. You can tell a box to use a different Layout any time you like.

You can also tell boxes to use their level-dependent Default Layouts. See section 6.5.1.

To tell a box to use a different Layout:

1 Select the boxes you which should use the different Layout
(if no boxes are selected, the Current Box is used)

2 either On the Toolbar, click the Define Layouts button
or From the Layout menu, choose Define Layouts
or Press CTRL+D

3 In the Layouts list, select the Layout the selected boxes should use

4 Choose the Use button

5 Choose the OK button



Using a different Layout takes immediate effect. If you make a mistake, repeat the Use operation.

6.5.1 Initial and Default Layouts

When a new box is inserted, it automatically uses one of the Layouts you have defined. While you can  
change which Layout a box uses at any time, you can speed up your work by specifying how these  
initial Layouts should be assigned.

There are two options for the initial Layout:

■ Use the same Layout as the box you are inserting next to
■ Use the Default Layout for the level at which the new box is inserted

To change the initial Layout option:

1 From the File menu, choose Preferences

In the Preferences dialog:
2 In the Initial Layout radio buttons,

select Level Dependent or Same as Current Box

3 Choose the OK button

The Initial Layout is a program option affecting all open charts, and is not stored with any chart.

Default Layouts are those chosen by you as being the most appropriate for each level in the hierarchy.  
The Default Layout for a particular level is determined as a two-step process:

1. If there is a specific Layout named as Default for this level, use it
2. If there is no specific Layout named for this level, use a chart-wide default.

To Specify the Default Layout for any Level:

1 From the Layout menu, choose Defaults

In the Default Layouts dialog:
2 Select  different Layouts in  the drop-down lists
3 Choose the OK button

The chart-wide default can be selected from the Default drop-down list.

Defaults for specific levels can be selected from the level-specific drop-down lists. If you don't want to  
name a specific Layout as default for a level, just select '(default)' in the list.

Only eight levels can have defaults specified, any boxes inserted at levels nine and above will always 
use the chart-wide default.

Other uses of Default Layouts



While the Default Layout for a given level is only used when inserting a new box, there are occasions  
when its useful to select a group of boxes and set them to use their Default Layouts. One occasion is  
when you copy a set of boxes to the Clipboard, then paste them somewhere else in the chart. TreeChart 
preserves a reference to the Layout they were using and (assuming its still defined) uses that when  
pasting back into the chart. Sometimes, this might not be what you want, so in these circumstances, 
select the boxes that have been pasted, then request that they use their Default Layout.

To tell a box to use its default Layout:

1 Select the boxes you which should use their Default Layouts
(if no boxes are selected, the Current Box is used)

2 either From the Layout menu, choose Use Default
or Press CTRL+U

6.6 Creating, Renaming and Deleting Layouts

You can create any number of Layouts. Each must be assigned a unique name so that it can be referred  
to while preparing the chart. Layout names must be less than 256 characters.

As you create, modify and use different Layouts, there will probably come a time when some of the  
Layouts you have created are no longer needed. As a matter of good housekeeping, you should delete  
any Layouts you are sure you won't need in future.

TreeChart itself never deletes Layouts, nor will it allow you to delete Layouts that are being used. 
There are two situations where you might think a Layout is unused, but TreeChart won't agree:

■ If a Layout is named as a Default
■ If a Layout is used by a recently deleted (undo-able) box

General Layout management commands are available from the Define Layouts dialog.

To show the Define Layouts dialog:

either On the Toolbar, click the Define Layouts button
or From the Layout menu, choose Define Layouts
or Press CTRL+D

All existing Layouts are listed, with the Layout used by the Current Box selected automatically.

Choose the Close button (or press ESC) to complete the dialog and return to your chart window.

To create a new Layout:

Newly created Layouts are always a copy of an existing Layout.

1 In the Layouts list, select one that acts as the best starting point for the new Layout.
2 In the New Name edit control, enter the name of the new Layout
3 Choose the New button



The newly-created Layout will be added to the Layout list, and automatically selected, since you are 
almost certain to want to edit it.

To edit a newly-created Layout

either In the Layouts list, double-click on the Layout name
or Choose the Edit button

To rename a Layout

1 In the Layouts list, select the Layout name
2 In the New Name edit control, enter the new name
3 Choose the Rename button

To delete unused Layouts:

1 Choose the Delete button

In the Delete Unused Layouts dialog:
2 Select the Layouts to be deleted
3 Choose the OK button

Note: Unused Layouts can also be deleted without entering the Define Layouts dialog; from the Layout 
menu, choose Delete Unused.
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Marking Boxes as Exceptions to the Rules

TreeChart minimizes the amount of work you have to do by making two assumptions:

■ That all subordinates to a box are positioned and connected uniformly
■ That the hierarchy you are illustrating is 'pure': each box has only one parent

Most of the time you'll appreciate the benefits of these assumptions, but occasionally you'll find it 
useful to be able to mark some boxes as exceptions to the rules.

You can think of boxes as having a set of flags associated with them. Each flag indicates a particular 
exception condition, and you can set a flag to mark a box as an exception to the rule. By default, all the 
flags are cleared. The flags are independent and can be used in any combination, though some flags are 
only used if other flags are set.

When you save your chart (in TreeChart native format or TreeChart Outline Text format) the flags are 
saved too. If you Cut or Copy boxes to the Clipboard then Paste them into a chart, the flags are copied 
along with the box text.

You can set or clear individual marker flags using the Mark Boxes dialog. Many of the flags also have  
shortcut keys which sometimes allow you to set or clear flags in common combinations.

You can also select boxes dependent on their marker flag settings using the Select Marked Box dialog.

The  next  two  sections  describe  how  to  use  the  Mark  Boxes  and  Select  Marked  Boxes  dialogs.  
Subsequent sections explain in detail the meaning of each individual marker flag.

7.1 The Mark Boxes Dialog

The Mark Boxes dialog box allows you to change the individual markers for the selected boxes. If no 
boxes are selected, the markers of the Current Box are changed.

To show the Mark Boxes dialog:

either On the Toolbar, click the Mark Boxes button
or From the Edit menu, choose Mark Boxes
or Press CTRL+M

Each flag has its  own checkbox,  which can be grayed as  well  as  the normal  checked or  cleared. 
Clicking on a checkbox cycles through the two or three states.

When the dialog box is initially shown:

A checkbox will be checked if the corresponding flag is set in every selected box. 
A checkbox will be clear if the corresponding flag was clear in every selected box.
A checkbox will be grayed if the corresponding flag is different in the selected boxes.



If you choose the OK button, the flags in the selected boxes will be changed:

Where a checkbox is checked, the corresponding flag is set in every selected box.
Where a checkbox is clear, the corresponding flag is cleared in every selected box.
Where a checkbox is gray, the corresponding flag remains unchanged.

7.2 The Select Marked Boxes Dialog

The Select Marked Boxes dialog box allows select all the boxes whose marker flags are in a state you 
choose. The selected boxes are added to those already selected. To de-select any current selections, 
click on the chart or use the Clear Selections command before starting this dialog.

To show the Select Marked Boxes dialog:

From the Edit menu, choose Select Marked Boxes

Each flag has its  own checkbox,  which can be grayed as  well  as  the normal  checked or  cleared. 
Clicking on a checkbox cycles through the three states. When the dialog box is initially shown all  
checkboxes will be gray.

When selecting boxes, the checkboxes combine to form a search pattern. If you choose the OK button,  
the dialog box is completed, and all boxes matching the search pattern are selected:

Where a checkbox is checked, the corresponding flag must be set for the box to be selected.
Where a checkbox is clear, the corresponding flag must be cleared for the box to be selected.
Where a checkbox is gray, the corresponding flag is ignored.

7.3 Assistants

Subordinates marked in this way are both positioned and connected to their Parent differently from 
normal subordinates. For example:

This is useful in illustrating the common requirement when preparing an Organization Chart to show 
that this subordinate is actually an assistant, secretary or has a similar relationship to a manager.

A box can have any number of its subordinates marked as assistants. Each can individually be placed 
left or right of the vertical stem. Assistants are normally placed to the right; select the  Place Left 
marker to place them to the left.

If you insert a new box above, to the left or to the right of an assistant, the new box is automatically  
marked  as  an  assistant.  If  you  insert  above  an  assistant,  the  existing  box  remains  marked  as  an 
assistant, and becomes "an assistant's assistant".

marked



To Press

Set the Assistant marker (placing Right) F12

Set the Assistant marker (placing Left) CTRL+F12

Clear the Assistant marker SHIFT+F12

7.4 Omitting Connecting Lines

Mark a box as Disconnect to omit the connecting line between the box and its parent.
For example:

As illustrated above, any part of the connector which is drawn purely to attach a disconnected box is  
omitted. If  all subordinates are marked as disconnected, any common part of the connector is also 
omitted. If you do want to omit all connecting lines, its often easier to define and use a new Layout, 
specifying a connector line width of '(none)'.

To Press

Set the Disconnect from Parent marker CTRL+F9

Clear the Disconnect from Parent marker CTRL+SHIFT+F9

7.5 Invisible Boxes

Boxes marked in this way are simply not drawn, but their connectors are. This is useful in at least two 
situations. One is if you need to illustrate Co-Managers (see section 7.6), the other is if you need a box  
to be drawn at a level different from which it logically belongs. For instance, situations like this can  
arise in an Organization Chart:

fig 1

 

marked marked

Director

Manager

Engineer Engineer

Researcher



fig 2

In hierarchical terms, both the Manager and the Researcher are at level 2 ( fig 1), since they both report 
directly to the Director. Within the organization, however, the Researcher is considered to be at the 
same level as the Engineers, since he's not regarded as managerial-grade.

Effectively, the Researcher should be positioned at level 3, with nobody above him at level 2. To 
achieve this, simply insert a box above the Researcher, then mark that new box as invisible (fig 2).

Although Invisible boxes aren't drawn they still exist, use a Layout and are subject to size matching  
rules like any other box.

If you put text in an Invisible box, it is drawn, and obscures any connecting lines that interfere with it. 
This can be useful to annotate lines.

Connector line width and color are 'inherited' from the Invisible box's Parent. This prevents the need to 
create a new Layout just to stop line characteristics changing in the middle of an Invisible box.

To Press

Set the Invisible marker F9

Clear the Invisible marker SHIFT+F9

Using Outlining with boxes marked as Invisible

If you Collapse an Invisible box that is also Disconnected from its parent, the Invisible box itself will  
be hidden. Since the Invisible box cannot be made the Current Box or selected. It therefore cannot be 
Expanded in the normal way. To expand this box:

either Collapse, then Expand the Invisible box's Parent
or use the Expand All command
or use the View All Command

7.6 Co-Managers

Boxes marked in this way have additional connecting lines drawn automatically: direct from the center  
of one box to the center of a box on an adjacent sub-tree. For example:

Director

Manager

Engineer Engineer Researcher



Co-Manage Left Sibling

     

Left and Right Siblings to Co-Manage

       

Co-Manage Right Sibling

These are useful in illustrating situations involving a dual reporting structure. For example:

The width and color of the additional connecting lines are normally the same as the connectors from 
the marked box to its subordinates. You can choose to show the line as a dotted hairline by selecting 

the Co-Manager Links as Dotted Lines marker.

To Press

Set the Co-Manage Left marker F10

Clear the Co-Manage Left marker SHIFT+F10

Set the Co-Manage Right marker CTRL+F10

marked

marked

marked

Technical Manager

Project Manager

Finance Manager



Clear the Co-Manage Right marker CTRL+SHIFT+F10

Set the Left & Right to Co-Manage marker F11 (see below)
Clear the Left & Right to Co-Manage marker SHIFT+F11 (see below)

Note: The  shortcut  keys  set  & clear  the  Co-Manager  Group  marker,  and  also set  & clear  the 
Disconnect from Parent and Invisible markers, since these are commonly used together.

7.7 Fine-tune Box Size Matching

The Ignore when Matching Heights and Ignore when Matching Widths markers enable you to fine-
tune the automatic matching of box sizes. As described in section 6.3.2, the size matching rules allow 
you to ask TreeChart to make all boxes (within various categories) the same size. All the boxes would 
then be enlarged to match the largest box.

These markers allow you either to ignore a particularly large box (and make all other boxes the same 
size as the second largest box), or to prevent a particularly small box from being enlarged.

As an example, consider the difficulty in trying to achieve some sort of consistency between the widths 
of the boxes in the following chart:

If you simply requested widths to be equal among subordinates, the result would be:

You might prefer to mark the largest box to be ignored when matching widths:

Only the remaining three boxes are compared to find the widest box, and the smaller two of these are 
then enlarged to match it.

Alternatively, you could have marked the particularly small box to be ignored when matching widths:

Jo Fred Danny Penelope Catherine

Jo Fred Danny Penelope Catherine

Jo Fred Danny Penelope Catherine

Jo Fred Danny Penelope Catherine
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Changing the Border

When your chart is to be presented, a Border is added. The Border acts as a frame around your chart,  
and can add titles, headers, footers or any other text fields that you need. The Border frames your chart 
not only when printing, but also when copying the chart to the Clipboard as a picture, and when saving  
a file in picture format. It permits results such as this:

Choosing how the Border appears is very similar to deciding how an individual Box appears:

■ Define what Text Fields you need
■ Decide what text to put in those fields
■ Define the Layout
■ Define the Margins

In most respects the Border can be thought of as a special Box which frames your chart:

■ The Border has Text Fields, but these are independent of the box fields
■ The Border has a Layout, but this has fewer settings than normal Layouts

To add, rename or delete border text fields:

either From the Chart menu, choose Border Fields
or Press SHIFT+F3

To change the Border text:

either double-click on the chart background (i.e. not over a box)
or From the Chart menu, choose Border Text
or Press F7

See Chapter 5 ("Working with Text Fields") for details.

CAF/27/B
May 10th 1993

Component Breakdown
Phase 2

Prepared by Engineering Group
(see section 1.2 for context)

Page 1
Chapter 3

A

B

E F

C D



8.1 Changing the Border Layout

To change the Border Layout:

either SHIFT+double-click on the chart background (i.e. not over a box)
or From the Chart menu, choose Border Layout
or Press SHIFT+F7

The Border Layout is a simplified version of the Layouts used by boxes. The only differences are:

■ Different Text Fields will be listed
■ Text Fields cannot be positioned in the centered paragraph (the chart goes here)
■ No elliptic Border shape is offered
■ You are choosing the chart background color rather than a box fill color
■ Border Margins replace Box Size settings, and work slightly differently (see 8.2)

To

Change Text Settings See section 6.2

Change the border shape Select from the Shape list

Change the border width Select from the Line Width list

Remove the border In the Line Width list, select '(none)'

Change the border color Choose the Border Color button

Change the chart background color Choose the Background Color button

Change the shadow depth or direction Select from the Shadow list

Change the shadow color Choose the Shadow Color button

Change the Border Margins Choose the Margins button (see section 8.2)

The Chart Background Color

The Fixed Background Color checkbox determines how the chart background should be treated when 
using outlining techniques. If this checkbox is selected, the Border Background Color you choose will 
always be used as the chart background color. If this checkbox is cleared, the chart background color  
may vary depending on outlining selections. See section 4.9.2 for details.

8.2 Changing Border Margins

The Border Margins specify the minimum distance between your chart and the border, and the absolute 
distance between the border and the Border Text Fields.



When adding the Border to your chart, the margins are interpreted in two different ways:

■ When copying a picture of your chart to the Clipboard, or saving as a picture-format 
file,  the  Border  (and Border  Margins)  are  added to  your  chart.  The  picture  will 
always be bigger than your chart; the extra area being the Border.

■ When printing your chart, the Page Margins are  subtracted from the paper size to 
determine where the Border is. The Border Margins are then also subtracted to leave 
an area of paper available for the chart itself; what happens then depends on whether 
you have selected poster or fit-to-page printing. See section 9.1.

To change the Border Margins:

either From the Chart menu, choose Border Margins
or Press CTRL+F7

or In the Edit Border Layout dialog, choose the Margins button

You can also change the Border Margins by choosing the  Margins button when editing the Border 
Layout.

The meaning of the eight individual margins is illustrated below:

Lines within a paragraph always have single line spacing.

The Above, Below, TopMiddle and BottomMiddle margins are only used if there are text fields placed 
in the above, below, top or bottom paragraphs respectively. If this is not the case, these margins are 
totally ignored.

Choosing which margins are used for text positioned above & below the border



The checkboxes Push Out Above and Push Out Below determine the Left and Right margins for the 
paragraphs above and below the border. Paragraphs inside the border are always inside the left and 
right  sides  of  the  border  (the  distance  inside  being  determined  by  the  Left  and  Right  margins).  
Paragraphs  above  and  below  the  border  can  use  the  same  Left  and  Right  margins,  but  if  the  
corresponding checkbox is selected instead regard the outer edge of the border as the left and right 
margins.
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Printing a Chart
Printing TreeChart charts is much the same as printing any Windows document.

To
Print the Current View either On the Toolbar, click the Print button

or From the File menu, choose Print.
or Press CTRL+P

Preview printing either On the Toolbar, click the Print Preview button
or From the File menu, choose Print Preview

Choose a different printer, paper From the File menu, choose Print Setup
size or printer-specific options

Change the margins between From the Chart menu, choose Page Setup
the paper edge and the Border,
the Style(poster or fit-to-page),
or the chart position

Change the margins between either From the Chart menu, choose Border Margins.
the Border and the chart or Press CTRL+F7

9.1 Different ways of printing your charts

TreeChart can print your chart in three different styles:

Poster where all your fonts, sizes & spacing 
are absolute, and your chart will be printed as a series 
of sheets of paper that you'll need to stick together.

Overlapped Poster like  Poster-style,  except  that  a  ¼"  overlap  occurs 
between page breaks. This can make assembling pages 
easier.

Fit-to-page where  all  your  fonts,  sizes  &  spacing  are 
scaled to fit on a single sheet of paper

To change the Print Style:

1 From the Chart menu, choose Page Setup

In the Page Setup dialog:
2 Select from the group of Print Style radio buttons
3 Choose the OK button to complete the Print Setup dialog

Using Outlining when printing



TreeChart always prints the Current View - that is, if you have applied Focus to any box, or collapsed  
any boxes, these outlining selections are applied to the printed chart as well as the chart displayed on  
the screen. To print the whole chart, you must view the whole chart.

One advantage of  printing the Current  View rather  than the  whole  chart,  is  that  it  allows you to 
combine outlining with fit-to-page printing to print a chart as a series of pages. With an organization 
chart,  for  example,  you could  print  top-level  management  on one page,  then each department  on 
further pages. Each page would have its own Border and titles.

9.2 Positioning the chart on the page

How the chart gets printed is determined by a series of factors:

■ Position the Border on the page, leaving an area available for the chart
■ Match the chart to the available area
■ Position the chart within the available area
■ Print the chart plus Border

Positioning the Border on the Page

The paper size is determined by the selected printer, and the paper source and orientation. The Page  
Margins specify the distance between the edge of the paper and the border rectangle.

The Border Margins (plus text styles and position) specify where Border text is placed relative to the  
border rectangle. See section 8.2 for details.

Most printers have small non-printable regions near the edges of the page. If any Border elements  
extend into the non-printable area, the Border position is automatically adjusted to prevent incomplete 
printing.

The remaining Border Margins specify a minimum distance between border elements and the chart.  
This defines the area available for the chart.



Matching the chart to the available area

If the chart is larger than the available area, either the chart is reduced to fit the available area, or the  
available area is enlarged to accommodate the chart.

If the Print Style is Fit-to-Page, the chart is proportionately reduced.

If the Print Style is Poster, additional pages are added to make the available area larger than the chart.  
The Border will remain at the same distance from the paper edge, but will only appear on 'outer' sheets 
of paper. For example:

Positioning the chart within the available area

The Chart  Alignment  selection in the Page Setup dialog determines where the chart  is  positioned 
within the available area.

To

Choose a different printer, From the File menu, choose Print Setup
paper size or orientation

Change the margins between the From the Chart menu, choose Page Setup
paper edge and the Border

Change the Print Style (poster From the Chart menu, choose Page Setup
or fit-to-page)

Change the chart's position From the Chart menu, choose Page Setup
within the available area

Change the margins between either From the Chart menu, choose Border Margins.
the Border and the chart or Press CTRL+F7

9.3 Previewing a chart before printing



The TreeChart Print Preview command lets you look at the pages of your chart as they will appear  
when you print them. By viewing the pages in this way, you can decide what printing settings best suit  
this chart before printing.

To preview a chart:

either On the Toolbar, click the Print Preview button
or From the File menu, choose Print Preview

The TreeChart window is replaced by the Print Preview window, with the first one or two pages of the 
chart displayed.

The Print Preview Toolbar at the top of the window shows the various commands available when 
previewing. The Status Bar at the bottom of the window indicates both the selected Print Style, and the  
number of the pages currently being viewed.

Viewing different pages

In print preview, you can view one or two pages at a time, and you can step through the pages as they  
would be printed.

To

Move to the next page choose the Next button

Move to the previous page choose the Previous button

View one page at a time choose the One Page button

View two pages at a time choose the Two Page button

If you have a mouse, you can also move between pages by using the vertical scroll bar, but only if you  
haven't zoomed the preview window.

Zooming the preview window

In print preview, you can look at each page three different ways:

■ In the standard view, TreeChart scales down each page, and you can see the entire 
page, including any Border Text. This is the initial view setting.

■ In half-zoom view, TreeChart displays the pages approximately one-half the size they 
would appear when printed.

■ In  full-zoom view,  TreeChart displays the pages approximately the same size that  
they would appear when printed.

To



Zoom in to the next level either Choose the Zoom In button
or Click on the page

Zoom out to the previous level Choose the Zoom Out button

When zoomed, the preview window always shows a single page. If you are showing two pages in 
standard view when you zoom in, the page you zoom in on depends on how you zoomed in. If you 
choose the Zoom In button, you'll zoom in on the left-hand page. If you click on a page to zoom in, 
you'll zoom in on the page you clicked.

Scrolling the preview window

The use of the scroll bars depends on which preview view is shown:

In the standard view, only a vertical scroll bar is shown. Scrolling moves you one page forward or 
backwards in your chart.

In the zoomed views, the scroll bars scroll the zoomed page. You need to choose the Next Page or 
Previous Page preview toolbar buttons to move between pages.

Note: A mouse is required to scroll the preview window; there are no keyboard shortcuts.

Leaving print preview

You can close the print preview window with or without printing your chart:

To

Return to the chart window and Print the chart choose the Print button

Return to the chart window choose the Cancel button
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Managing TreeChart Files

Working with TreeChart files is much the same as working with any other Windows file. For further  
information about  working with  files  and directories,  see  Chapter  2  "Application Basics"  of  your 
Windows User Guide.

The maximum size of a TreeChart file is limited only by the amount of memory in your computer. 
TreeChart files are stored in a compact special format, and normally would have a filename extension  
of .TCF. Template files are in the same format but would normally have a filename extension of .TCT 
to show that they serve a different purpose.

TreeChart can also open text-format files saved by other programs to create a new chart, and save files  
in  a  number  of  other  formats  which can then be  used by other  programs.  See Appendix  2  for  a  
description of the text file formats, and Chapter 12 ("Working with other programs") for details of how 
to work with other format files.

10.1 Creating a New Chart

To create a new chart:

either On the Toolbar, click the New button
or From the File menu, choose New
or Press CTRL+N

To speed up the process of preparing a chart, TreeChart can use a Template when creating a new chart.  
This can specify box text fields, a set of Layouts, the Border and other chart settings.

See Chapter 11 for information on working with Template Files.

10.2 Opening an Existing Chart

To open an existing chart:

1 either On the Toolbar, click the Open button
or From the File menu, choose Open
or Press CTRL+O

In the File Open dialog:
2 Choose the file name of the chart you want to open
3 Choose the OK button

10.3 Saving a Chart

When you are working with a chart - especially a large chart - you should save your chart often. Doing 
so minimizes lost work if there is a power failure.



To save a chart, using the current filename:

either On the Toolbar, click the Save button
or From the File menu, choose Save
or Press CTRL+S

When you save a newly-created chart for the first time, TreeChart prompts you for a file name.

The Save command is disabled if no changes have been made to the chart since it was opened or last 
saved. The Toolbar button (in particular) gives a useful indication of whether or not you need to save 
this chart. If you feel the need to save a chart even when the working copy is identical to the disk file,  
you'll need to use the Save As command.

To save a chart, using a new name:

1 From the File menu, choose Save As

In the File Save As dialog:
2 In the File Name box, type a name for the file.
3 Choose the OK button
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Working with Template Files
A Template is simply a chart that acts as a starting point when you create a new chart.

A Template contains:

■ Definition of Text Fields
■ A set of Layouts
■ Definition of Default Layouts
■ Border text and Layout
■ Page margins and print style (poster or fit-to-page)
■ Overall box size-matching rules
■ Custom color settings

Normally, a Template would contain no boxes, though you can store boxes in a Template file is you 
wish - these boxes would then be created automatically for you when you create a new chart. See  
section 11.4 for working with Template Files that contain boxes.

Template files are the same format as charts, but would normally have a filename extension of .TCT to 
show that they serve a different purpose.

There are two situations where a Template is used:

■ When you create a new chart
■ When you open a text-format file

In both cases, TreeChart simply reads the Template File you have specified before allowing you to 
modify the chart or reading the text-format file.

If you choose not to specify a Template File, or TreeChart is unable to read the Template File you have 
specified, TreeChart uses a built-in default Template.

11.1 Creating a Template File

Since a Template is  simply an empty chart,  creating a Template is  just like creating a chart,  then  
deleting all the chart-specific information (i.e. the boxes).

To create a new Template File:

1 Prepare a chart
To prepare a chart, you could open an existing chart whose style you wished to
use as a Template, or open an existing Template, or create a chart from scratch.

2 Delete all boxes not needed for the Template (probably all of them)

3 From the File menu, choose Save As



In the File Save As dialog:
4 In the Save File As Type drop-down list, select 'Template File (*.tct)'
5 In the File Name box, type a name for the file.
6 Choose the OK button

11.2 Changing an Existing Template File

Since a Template is  simply an empty chart,  changing a Template is just like editing a chart,  then  
deleting all the chart-specific information (i.e. the boxes).

If you change the settings of a Template File, for instance, changing some colors, this will not affect  
charts previously created from this Template, only charts created after the change.

To change an existing Template File:

1 either On the Toolbar, click the Open button
or From the File menu, choose Open
or Press CTRL+O

In the File Open dialog:
2 In the List Files of Type drop-down list, select 'Template Files (*.tct)'
3 In the File Name box, choose the Template you want to open
4 Choose the OK button

5 Temporarily insert some boxes to illustrate the changes you'll make

6 Make the desired changes

7 Delete all the temporarily inserted boxes

8 From the File menu, choose Save

11.3 Changing which Template File is used for New Charts

The Template File to be used when you create a new chart or open a text-format file is one of the  
program options.

To specify which Template File to use for newly-created charts:

1 From the File menu, choose Preferences

In the Preferences dialog box:
2 either In the Template File edit control, enter the name of the Template File

or 1 Choose the Browse button

In the Select Template dialog:
2 In the File Name box, select the Template to use



3 Choose the OK button

3 Choose the OK button to complete the Preferences dialog

The file name you enter can either be a full pathname (including drive & directories) or a relative 
pathname. If the latter, the program will look in the default working directory for the file. The default  
working directory can be specified as you start the program.

To use TreeChart's built-in default settings rather than a Template File, simply clear the Template File  
edit control.

The selected Template will continue to be used until you select a different Template File. The Template 
File  name  is  stored  in  TreeChart's  initialization  file,  and  if  you  choose  to  save  your  program 
preferences, the selected Template will also be used the next time you start TreeChart. If you don't save 
your  program preferences,  the  Template  File  will  be  reset  the  next  time you start  TreeChart.  See 
Appendix 1 for details on saving program preferences.

11.4 Template Files that contain Boxes

While Template Files would normally contain no boxes, there are occasions when this can be useful.  
Section 4.10 describes one such situation.

Opening  a  text-format  file  is  very  similar  to  opening  a  Template  then pasting the  boxes  that  are 
automatically created from the lines of text. Pasting information into a chart requires you to choose:

■ Which box should the new boxes be inserted next to
■ The direction of insertion (left, right or below)

When using the normal  Paste commands,  this  choice is  made by moving the caret  to change the 
Current Box, then choosing the Paste Left, Paste Right or Paste Below command.

A similar choice must be made if you use a Template File that contains boxes. The choice is made as  
you save the Template, and your selection is saved with the Template so that opening a text-format file  
requires no intervention by you. The selection is not saved with normal charts, so you must:

either From the File menu, choose Save for a *.TCT file
or In the Save As dialog, select 'Template File (*.tct)' in the Save File as Type list

Before you save a Template File that contains boxes, set the Current Box to the box that automatically 
created boxes will later be inserted next to.

After choosing the Save command (or choosing the OK button in the Save As dialog), a Template File 
Settings dialog will ask you to confirm the Current Box, and to select a direction for insertion.
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Working with other Programs
One aim when designing TreeChart was to recognize the importance of sharing information with other  
Windows programs. TreeChart will often be used in situations where preparing a chart is only a small 
part of a larger job, perhaps preparing a report, a newsletter or a project plan.

For programs to be able to exchange information, they must agree on the format of the information.  
TreeChart does not aim to recognize all possible formats, but it does support two of the main formats  
for data exchange used by Windows programs, enabling it to input text from another program, and 
output text or pictures for use by another program.

Text formats supported are those adopted for tabulated information: a record (Box) being one line of 
text, with special characters separating fields. In many cases, you may not need to know the details of  
these text formats, but for reference, further information is in Appendix 2.

TreeChart exports pictures as Windows Placeable Metafiles (also known as Aldus Placeable Metafiles). 
These permit resizing without any loss of picture quality.

Like most Windows programs, TreeChart can exchange information either by saving & opening files,  
or by copy & paste via the Windows Clipboard.

12.1 Using the Windows Clipboard

The Clipboard is a Windows mechanism to permit information to be exchanged between programs. 
This  normally  involves  selecting  some information  in  one  program,  Copying  it  to  the  Clipboard, 
starting or switching to the other program, selecting where the information is to be inserted, then  
Pasting the information. A further Clipboard operation Cut, is equivalent to Copy followed by Delete.

This  powerful  Windows  feature  relies  on  programs  agreeing  the  format  of  information  on  the 
Clipboard. TreeChart copies chart information in up to three different formats:

Native This format is for cut & paste within a chart or between two different charts. The 
selected boxes (and references to the Layouts they use) are copied to the Clipboard,  
or if no boxes are selected, the Current Box.

Text Tab-separated text (see Appendix 2). This format would principally be used 
for  exchanging information with a  word processor  or  spreadsheet.  No Layout  or 
organizational information is copied. The text fields of the selected boxes are copied, 
or if no boxes are selected, the text fields of the Current Box.

Metafile A scaleable picture format. This format is used for pasting a picture into a word 
processor document. TreeChart copies the entire Current View (plus the Border) - 
box selections are irrelevant.

TreeChart  always copies to the Clipboard in Native format. The use of Text & Metafile formats is  
optional. See Appendix 1.



12.1.1 Copying Text from another program into TreeChart

To a large extent, this works as you might expect. After giving two examples, we'll describe what's 
going on in the background, so that if you have any problems you might be able to work around them.

To copy text from Notepad (or similar editor / word processor):

1 Switch to the Windows Notepad accessory
2 Select the lines of text you want to copy
3 From the Edit menu, choose Copy
4 Switch to the TreeChart chart window you wish to paste into
5 Move the caret to select the Current Box
6 From the Edit menu, choose Paste Below, Paste Left or Paste Right (as necessary)

One new box will be created for each line of text you selected. Text Fields should be separated by TAB 
characters, though other options are available. See Appendix 2.

If TreeChart was unable to interpret Text Fields as you intended, either edit the Notepad document and 
repeat the operation or edit the text of each box and cut & paste between fields.

To copy text from a Spreadsheet (or a table in Microsoft Word)

This is always simpler than copying text from an editor or word processor, since identifying boxes and 
Text Fields is almost foolproof.

1 Switch to the spreadsheet program
2 Select the range of cells you wish to copy
3 From the Edit menu, choose Copy
4 Switch to the TreeChart chart window you wish to paste into
5 Move the caret to select the Current Box
6 From the Edit menu, choose Paste Below, Paste Left or Paste Right (as necessary)

One new box will be created for each row copied, and each column corresponds to a Text Field.

Background information

In almost every Windows program, when you select a region of text then choose the Copy command, 
an unformatted version of that text will be copied to the Clipboard in addition to 'richer' (formatted) 
versions that will be copied for the program's own use.

TreeChart always pastes the unformatted text into a chart. All subsequent formatting is determined by 
which Layout the resultant boxes use.

Each newly-created box initially uses the Default Layout for the level it  has been inserted at. See 
section 6.5.1 for a description of Default Layouts.

When pasting text from the Clipboard, TreeChart interprets the text as if it were opening a text file (see  
section 12.2), and automatically distinguishes between the various supported text formats. Whatever  



text format is in use, TreeChart assumes that each line of text constitutes a box, and text within that  
line is divided into fields which constitute TreeChart Text Fields.

Where no hierarchy information is available in the text to be pasted (normally the case if the text was 
copied to the Clipboard by another program), all newly created boxes will be at the same level, and all 
will initially use the Default Layout for that level.

To re-organize a flat hierarchy and have boxes use their correct Default Layouts:

1 Cut & Paste the new boxes to define the chart hierarchy

2 Select the boxes that use the 'wrong' Layout (possibly all of them)

3 either From the Layout menu, choose Use Default
or Press CTRL+U

If you're using another program purely to prepare TreeChart text, consider using TreeChart Outline 
Text format. This enables you to specify the hierarchical organization of the boxes, and you can assign 
Layouts for each box to use. See Appendix 2.

12.1.2 Copying Text from TreeChart into another program

1 Select the boxes who's text you'd like to copy
(if no boxes are selected, the text from the Current Box will be copied)

2 From the Edit menu, choose Copy
3 Switch to the program (and document window) you wish to paste into
4 Position the Insertion Point
5 From the Edit menu, choose Paste

Each box will be copied as a line of text, with TAB characters separating the Text Fields. If you paste  
into a spreadsheet each box will correspond to a row, each text field to a column.

Copying box information to the Clipboard as text is optional. See Appendix 1.

12.1.3 Copying Pictures from TreeChart into another program

1 From the Edit menu, choose Copy
2 Switch to the program (and document window) you wish to paste into
3 Position the Insertion Point
4 From the Edit menu, choose Paste

A picture of the chart will be inserted into the document. Note that box selections are irrelevant.

TreeChart copies pictures to the Clipboard in a format called Windows Metafile. Not all Windows 
programs recognize this format, but most do. If you need to copy a picture into a program that doesn't 
recognize a Metafile, it might be possible to go through an intermediate program that can convert  
formats.

When drawing the chart to copy to the Clipboard, TreeChart adds the Border you have specified (just  



as if you were printing the chart). The Border Margins determine how much space to leave around the 
chart. The Page Setup margins are not used.

Note that Windows imposes a limit on the size of a picture you can copy to the Clipboard (about 11").  
If the height or width of the chart is greater than this limit, TreeChart scales the drawing.

Copying a picture to the Clipboard is optional. See Appendix 1.

Changing picture size after pasting into another program

The Windows Metafile format allows the picture to be scaled (more or less) perfectly. In particular, the  
fonts used by text fields can be scaled along with the boxes.

One important point to note,  however, is that the way the program receiving the picture performs 
scaling determines whether or not everything in the picture is scaled proportionately. We'll illustrate 
this issue by describing one example; you may need to experiment with the specific programs that you 
are using to determine the best method of pasting pictures.

Resizing pictures with Word Processors and Drawing programs

If you want to paste a TreeChart picture into Microsoft Word, you can choose whether to paste directly 
into the document or insert a picture object (to be edited with the Microsoft Draw mini-application), 
and paste the picture into that object.

Pasting into an Microsoft Draw object allows you to add text or lines to your chart or (for example) 
change the color of individual lines, though of course TreeChart will never know about any changes 
you make.

Whichever approach you take, if you want to resize the overall picture, you should do it from within the  
word processor itself, not from within Draw.

The reason for this is that the word processors treats the picture as a single entity. TreeChart informed  
them how big it was, and they simply perform an overall scaling. Microsoft Draw, on the other hand, 
understands the constituent parts of the picture (lines, rectangles, text, etc.), and if you re-size it, you  
re-size each individual component. Microsoft Draw doesn't resize text very well, though other drawing 
packages might manage it better.

Maintaining proportions when resizing pictures

If you resize a picture produced by TreeChart, you should try to maintain the overall proportions. If 
you fail to do this, you'll find that text no longer fits inside boxes.

For example, in Microsoft Word select the picture and resize using only the corner handles (not the  
edge handles). Alternatively, from the Format menu, choose Picture. In the dialog specify identical  
scaling factors for both the height and width.

12.2 Importing Text

TreeChart  can  open  files  saved  as  text  format  by  other  applications  and  interpret  that  text  as 



information defining text fields and boxes. The formats supported are those commonly used to store  
individual  records  as  lines  of  text,  each  record  being  divided  into  a  number  of  fields.  TreeChart 
interprets this as each record being a box, and each field within that record being a Text Field.

Details of supported text file formats can be found in Appendix 2. TreeChart automatically determines 
which format is in use when opening a text file.

To speed up preparing a chart, TreeChart can use a Template when opening a text file. See Chapter 11  
for information on working with Template Files.

To open a text-format file:

1 either On the Toolbar, click the Open button
or From the File menu, choose Open
or Press CTRL+O

In the File Open dialog:
2 In the List Files of Type drop-down list, choose 'Text Files (*.TXT)'
3 In the File Name box, choose the text file you want to open
4 Choose the OK button

Where no hierarchy information is available in the text file (normally the case if the text file was saved  
by another program), all newly created boxes will be at level 1, and all will initially use the Default  
Layout for level 1.

To re-organize a flat hierarchy and have boxes use their correct Default Layouts:

1 Cut & Paste boxes to define the chart hierarchy

2 either On the Toolbar, click the Select All button
or From the Edit menu, choose Select All
or Press CTRL+A

3 either From the Layout menu, choose Use Default
or Press CTRL+U

12.3 Exporting Text

While you would normally save a file in TreeChart format, there can be occasions when you'd like to  
save it in a format that can be opened by other programs. Since saving a chart in these alternative 
formats always loses  some aspects  of  the chart  information,  you should normally save a  chart  in 
TreeChart format, and only save a copy of the chart in a different format, and specify a different file 
name (or at least a different filename extension) as you do so. Appendix 2 describes the supported text  
file formats.

All boxes are saved to the file, irrespective of any outlining settings you may have selected.

You have six possible formatting choices when you save a chart:



Use To save your chart as

TreeChart Files (.TCF) A TreeChart-format file. Use this format to retain all chart 
information. This is the normal format for TreeChart use, and the 
default selection in the Save File as Type list.

Template  Files (.TCT) A TreeChart-format file that serves as a Template.

Text & Commas (.TXT) A Windows-format data file. Suitable for use with a word 
processor or  spreadsheet.  Contains only Box text;  no Layout or 
hierarchy information.

Text & Tabs (.TXT) A Windows-format data file. Suitable for use with a word 
processor or  spreadsheet.  Contains only Box text;  no Layout or 
hierarchy information.

Outline Text (.TXT) A Windows-format data file. Similar to Text & Tabs, but 
containing  Text  Field  names  &  Box  hierarchy  and  marker 
information, plus Layout names (but not their settings).

Windows Metafile (.WMF) A picture of the chart, similar to as it would be printed (see section 
12.4)

To save a copy of a chart for use by another program:

1 From the File menu, choose Save As

In the File Save As dialog:
2 In the Save File as Type drop-down list, choose the desired format
3 In the File Name box, enter a name for the file you want to save
4 Choose the OK button

Take care to enter a new file name before choosing the OK button, otherwise you might overwrite a  
TreeChart-format file, and so lose all Layout information.

12.4 Exporting Pictures

TreeChart can save chart information as a picture, enabling you to import that picture into another  
program. Picture-format files lose most of the information used internally by TreeChart, so you would 
normally save a picture-format file in addition to TreeChart-format, not instead of TreeChart-format.

A picture of the Current View is saved, with the Border added. In other words, any outlining settings 
you may have selected are used to prepare the picture: what you see on the screen is what is saved.

To save a picture of a chart for use by another program:

1 From the File menu, choose Save As

In the File Save As dialog:



2 In the Save File as Type list, select 'Windows Metafile (*.WMF)'
3 In the File Name box, enter a name for the file you want to save
4 Choose the OK button

Take care to enter a new file name before choosing the OK button, otherwise you might overwrite a  
TreeChart-format file, and so lose all Layout information.
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Setting Program Preferences

A number of options determining the operation of TreeChart can be specified by the user. All options 
can be saved in an initialization file, and restored the next time the program is started. Most options  
can be set by means of a dialog, but some require the initialization file to be edited.

A1.1 The Preferences Dialog

To change program preferences, from the File menu, choose Preferences.

Choosing the OK button completes the dialog, and any changes to the preferences will take effect from 
then on. Choosing the Cancel button completes the dialog with preferences left unchanged.

Box Insertion

These options determine how TreeChart operates when you insert a new box.

Initial Layout

When a new box is inserted, the Layout it  initially uses can be either the level-dependent Default 
Layout, or the same Layout as the box that the new box was inserted next to. See section 6.5.1.

Note: if you press SHIFT when inserting a new box, this option is temporarily reversed.

Prompt for Text

If this checkbox is selected the Edit Text dialog appears automatically when you insert a new box, to  
allow you to enter the associated text. Disabling this option allows the structure of the chart to be 
entered without dealing with the actual text within boxes until later.

Default Formats

These options specify the default format for calculated Box or Border fields. The actual format used 
depends on the Layout (or Border Layout) settings. If  "(default)" is selected for the Layout, these 
program-wide default formats are used. See section 6.2.4 for details.

Box Fields Border Fields

Date/Time <date/time>
Counters <number>, <relative number>, <level>
Outline <outline number>

Clipboard

The checkboxes in the Clipboard group determine the optional formats the program uses when copying 



or cutting information to the Clipboard. The program always copies information in an internal format  
for its own use. Other formats are for transferring information to other programs.

There are two formats in which we can usefully copy information: as text or as a picture. TreeChart 
will happily copy both, but this can lead to difficulties in pasting information into other programs.

Choosing Paste in another program requires that program to choose one of the available Clipboard  
formats.  All  programs  tend  to  choose  one  format  in  preference  to  another.  Word  processors,  for  
example, have a tendency to paste the text copy, rather than the picture copy.

Many more recent Windows programs offer the Paste Special command, usually on an Edit menu.  
Using this you can select the format to be pasted into the document.

By setting these options, you specify in what format the information is presented to other programs,  
and either avoid the need for Paste Special (where available), or ensure they make the right choice.

Template File

As described in Chapter 11, a Template File can form the basis of a newly created chart, or a chart  
created by opening a text format file. The preference dialog enables a file to be selected for use as the  
Template. You can either type the filename of the Template, or choose from a list of available Template  
files.

If you type the filename, it  can either be a full  pathname (i.e.  including drive & directories) or a 
relative pathname. If the latter, the program will look in the default working directory for the file. The 
default working directory can be specified as you start the program.

To select from a list of available Template files, choose the Browse button.

Miscellaneous

Center Dialogs

Opinions differ as to whether dialog boxes should appear near the program window (but seemingly 
randomly positioned) or consistently in the center of the screen. Select this checkbox to have dialog 
boxes in the center of the screen.

Save Preferences On Exit

If this checkbox is selected, TreeChart automatically saves the preferences in the initialization file  
when you close the program.

Choosing the Save button causes the preferences as they appear on the dialog at that moment to be 
stored in the program's initialization file immediately.

A1.2 The Initialization File

This section details the contents of the private initialization file (TREECHRT.INI), which is stored in 



your windows directory and specifies various options which define how the program functions.

If the initialization file is not found on program startup, default settings are used for all options. If the  
initialization file is not found when saving program preferences, it is created with the current settings.

Except where noted, these options should be changed by choosing Preferences from the File menu, as 
described in Appendix A1.1. Where an option requires the initialization file to be edited the Windows 
accessory Notepad is recommended.

The TREECHRT.INI file contains several sections, each of which consists of a group of related entries.  
The sections that can appear are:

[Settings] Internal program options
[Recent File List] Recently used files, for direct opening via the File menu
[Window] Notes window size, position & status between TreeChart sessions
[Preferences] User-selected program options

These section names must not be altered, otherwise the entries under them will be not be recognized.

[Settings] Section

PreviewPages=1 | 2 Used in Print Preview, this notes whether you last previewed output as a 
single page, or two pages side by side.

[Recent File List] Section

FileN=fnam The full path name of a recently saved file. Up to four such entries 
may be present, and are added to the File menu to allow recently used files  
to be re-opened quickly. These files must be native TreeChart format files.

[Window] Section

state= Initial  program  window  status.  TreeChart  remembers 
window size, position & state (minimized, maximized, normal). When you 
start TreeChart, its window will be the same size & position as when you 
last  used it.  The one exception is  if  you explicitly  start  minimized (e.g. 
checking the Run Minimized checkbox on Program Manager Run... dialog). 
If this entry is absent, TreeChart starts with a window occupying the whole 
screen except for one row of icons at the bottom.

ShowToolbar=0 | 1 Specifies  whether  TreeChart  should  show  (1)  or  hide  (0)  the  Toolbar. 
Default: 1 (show). Modified by choosing Toolbar from the View menu.

ShowStatusbar=0 | 1 Specifies whether TreeChart  should show (1) or hide (0) the Status Bar. 
Default: 1 (show). Modified by choosing Status Bar from the View menu.

ChildFrame=1 | 3 Initial chart window status. When a new chart window is created, 
its initial  size,  position and state are based upon how you've been using 
chart windows. If you've been working with maximized chart windows, a 



new  window  will  be  maximized.  If  you've  been  working  with  non-
maximized chart windows, a new window will be a default size and position 
within  the  main  window  client  area.  Possible  values:  1  (normal),  3 
(maximized).

[Preferences] Section

SavePreferences=0 | 1 Specifies whether or not program options should be saved automatically 
when  you  close  the  program.  Default:1  (Save).  Only  entries  in  the 
[Preferences]  section are  controlled by this,  entries  in  other  sections are 
always saved on program exit.

AutoEdit=0 | 1 Specifies whether or not the Edit Text dialog should automatically 
be shown when a new Box is inserted. Default: 0 (don't edit text).

CopyText=0 | 1 Specifies  whether  the  program  should   use  Text  format  when 
copying or cutting information to the Windows Clipboard. Default: 0 (don't 
copy as  Text).  When pasting  information  from the  Clipboard  into  other 
programs,  there  may be  occasions  when if  they are  offered a  choice of 
formats, the other program may choose the wrong format for your purposes. 
This option allows you to determine what choices the other program has to 
make, and therefore ensure that it chooses the format you want.

CopyMetaFile=0 | 1 Specifies whether the program should  use Metafile picture format when 
copying or cutting information to the Windows Clipboard. Default: 1 (copy 
as  picture).  When  pasting  information  from  the  Clipboard  into  other 
programs,  there  may be  occasions  when if  they are  offered a  choice of 
formats, the other program may choose the wrong format for your purposes. 
This  option  allows  you  to  specify  what  formats  are  offered  to  other 
programs.

CenterDialogs=0 | 1 Specifies whether dialog boxes should be centered within the screen (1) or 
not (0). Many users prefer dialogs to appear in a consistent position, but this 
might be distracting if you are running two programs side by side on a large 
monitor. Default: 1 (center dialogs).

Units=0 | 1 Initial / last used units when measurements were presented. Values: 
metric (0) or imperial (1). The program defaults to the international setting 
in the Windows initialization file if this entry is absent.

TemplateFile=fnam Specifies the full pathname of the TreeChart file to use as a Template when 
creating a new chart  or when Opening a file in one of the Text formats. If 
nothing  follows  TemplateFile=,  or  if  this  line  is  missing  from  the 
initialization file, no Template will be used, and the newly created chart will 
have default settings.

DragInsertThreshold=n Specifies the size (in screen units)  of  the 'dead zone'  around the anchor 
position  when  inserting  a  new Box  by  dragging  from an  existing  Box. 
Default is 10. Reducing this setting means that dragged insertions require 



less mouse movement, but increases the likelihood of accidentally inserting 
when intending to simply select a box. Changing this option requires the 
initialization file to be edited.

TrueShadow=0 | 1 Specifies whether TreeChart should take extra time to get the sequence of 
drawing shadows, connectors and boxes perfect (1) or draw them fast (0), 
but sometimes get  the shadows and connectors in the wrong order.  This 
only affects the screen display; printing, copying a picture to the Clipboard, 
and saving as a picture are always done correctly.  Default:  1 (accurate). 
Changing this option requires the initialization file to be edited.

Dialogs3D=0 | 1 Specifies whether TreeChart should attempt to show dialogs and 
message boxes with a 3D appearance (1) or in the normal Windows style 
(0). The 3D appearance is only possible with a VGA or better display. If 
TreeChart detects that your display is not capable of the 3D appearance, the 
normal Windows style will be used irrespective of the state of this option.  
Default: 1 (3D). Changing this option requires the initialization file to be 
edited.

InitialLayout=0 | 1 Specifies  how  TreeChart  should  assign  a  newly-inserted  box's  initial 
Layout.  If  0,  the level-dependent default  Layout is  used. If  1,  the initial 
Layout is the same as the current Layout of the box that the new box is  
inserted next to.

DateFormat=n Specifies the default format for date/time fields. Specific formats 
depend on the date order settings in the Windows International settings.

CounterFormat=n Specifies the default  format for counter fields (box number,  relative box 
number, level).

OutlineFormat=n Specifies the default format for outline number fields.

DeleteAbsentFields=0 | 1 When pasting/importing text into a chart/template, this switch determines 
what happens if some box fields in the chart are unused. If 0, unused fields 
are retained. If 1, unused fields are deleted. Default: 0 (retain unused fields). 
Changing this option requires the initialization file to be edited.
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Supported Text File Formats

TreeChart imports and exports text in common Windows text  formats. Any application capable of  
handling text should be able to exchange information with TreeChart.

TreeChart cannot read or interpret formatting information embedded within text files. The text files it  
can import are those saved by applications by selecting 'Save As Text & Tabs', etc.

When importing text (either by opening a text format file or by pasting from the Clipboard) common 
text formats contain sufficient information to construct boxes, determine the required number of Text  
Fields and to initialize those Text Fields. They do  not contain any information which allows us to 
construct a hierarchy of boxes, and all boxes constructed after importing text will be at the same level  
in the hierarchy. Constructing the hierarchy then requires moving sets of boxes around,  by cut  & 
pasting (as described in section 12.2).

TreeChart Outline Text format is a simple extension of one of the common text formats which does 
allow the program to construct a hierarchy of boxes. To avoid the need to define the hierarchy by cut & 
paste after importing text in a common format, you may wish to save the text to a file in the other  
application, edit the text file to add hierarchy information (using, for example, the Windows Notepad 
accessory, though its a lot easier with a spreadsheet), then save it before opening as text from within 
TreeChart.

Character coding is the ANSI Windows standard, not PC standard. 

A2.1 Basic Text Format

TreeChart assumes text files to be composed of a number of lines, each terminated with a carriage 
return / linefeed character pair. Each line corresponds to a box, individual fields of text within a box  
being separated by some marker character.

The formats described below are as used when saving a chart in text format. When opening a chart in 
text format, TreeChart automatically detects which format is in use. One quirk of this is that like many 
other programs, TreeChart will lose the first character in a Tab-separated field if that character is a  
double-quote (").

An example chart:



In this example, Molly Jones is Charles Brown's assistant. In TreeChart terms, this means that the 
Molly Jones box is a subordinate that has been marked as an Assistant. Fred Emerson is regarded as 
having the same seniority as the Sales Managers, despite reporting directly to Charles Brown. This is 

illustrated by the Fred Emerson box being subordinate to a box marked as Invisible. Chapter 7 
describes how and why to mark boxes as exceptions to the rules.

All boxes in the example are using Layout 'Normal', except for the Molly Jones box, which uses the 
Layout 'Assistant'.

A2.2 Tab-separated Text

Fields  are  separated by TAB characters.  Any character  (except  end-of-line  or  end-of-file)  is  valid 
within a field.

The example, saved in Tab-separated text format:

Charles Brown The "Boss"
June Roberts Sales Director
Don Peterson Sales Manager, America
Sally Smith Sales Manager, Europe
Molly Jones

Fred Emerson Technical Manager

Note that the hierarchy is lost when saving in this format, and that the box marked as Invisible results 
in a blank line, since the box contained no text.

A2.3 Comma-separated Text

Fields are separated by commas (,). Because of the probability of using a comma within a field, fields  
are 'quoted' by a leading and trailing double-quote (") character. Where a double-quote character is 
actually within the field, it is duplicated. Any program offering to save text in 'Text & Commas' format 
(or some similar name) will perform all this automatically.

The example, saved in Comma-separated text format:

Charles Brown
The "Boss"

June Roberts
Sales Director

Don Peterson
Sales Manager, America

Sally Smith
Sales Manager, Europe

Molly Jones

Fred Emerson
Technical Manager



"Charles Brown","The ""Boss"""
"June Roberts","Sales Director"
"Don Peterson","Sales Manager, America"
"Sally Smith","Sales Manager, Europe"
"Molly Jones",""
"",""
"Fred Emerson","Technical Manager"

Note that the hierarchy is lost when saving in this format, and that the box marked as Invisible results 
in a blank line, since the box contained no text.

A2.4 TreeChart Outline Text

TreeChart Outline Text format is an extension of the Tab-separated text format.

The first line of text is a header containing an identification code ('TreeChart Outline Text'), followed  
by fields containing Field Names. Subsequent lines of text are preceded by a numeric field indicating 
relative level numbers within the hierarchy.

When reading this format, TreeChart performs error correction if these level numbers are sequenced  
incorrectly. The first level number encountered is regarded as a 'base': subsequent level numbers will  
be forced to be not less than this base. If any level number is more than one greater than that associated 
with the previous line of text, it will be set equal to the previous level+1.

Two pseudo-fields may optionally be present in the header line: $$LAYOUT$$ and $$MARKER$$.

If the $$LAYOUT$$ field is present (at any position), this field within subsequent records is assumed 
to contain a Layout Name. This field is removed from each line before constructing the box. If the 
Layout Name is defined within the chart, the newly-created box will initially use this Layout. If this 
pseudo-field is absent, or if the extracted Layout Name is not known to the chart, the newly-created  
box will use the Default Layout for the level it is inserted at.

If the $$MARKER$$ field is present (at any position), this field within subsequent records is assumed 
to contain the value of the exception flags for this box (as described in Chapter 7). If this field is  
absent,  newly  created  boxes  will  have  all  marker  flags  cleared.  Possible  values  for  this  field  are  
composed by ORing the following values in any combination, but the setting must be expressed as a  
decimal value:

hexadecimal decimal meaning

0x0001 1 Invisible
0x0002 2 Co-Manage Group
0x0004 4 Co-Manage Left
0x0008 8 Co-Manage Right
0x0010 16 Assistant
0x0020 32 Disconnect from Parent
0x0040 64 Ignore when matching box Heights
0x0080 128 Ignore when matching box Widths



0x0100 256 Place Assistant left of stem
0x0200 512 Draw Co-Manager links as dotted hairline

For example, a box marked as Co-Manage Group, Invisible and Disconnect from Parent would have 
the value 0x0023 hexadecimal or 35 decimal.

All other values are reserved; using other values may produce unexpected results when your chart is  
drawn.

The example, saved in TreeChart Outline Text format:

TreeChart Outline Text $$LAYOUT$$ $$MARKER$$ Name Position
1 Normal 0 Charles Brown The "Boss"
2 Normal 0 June Roberts Sales Director
3 Normal 0 Don Peterson Sales Manager, America
3 Normal 0 Sally Smith Sales Manager, Europe
2 Assistant 16 Molly Jones
2 Normal 1
3 Normal 0 Fred Emerson Technical Manager

Note that the hierarchy is retained when saving in this format, together with box Marker flags and a  
reference to the Layout used.

A2.5 Interpretation of Field Names

When importing text, either by opening a text file, or by pasting from the Clipboard, the possibility 
arises of a  mismatch in the number and names of  fields.  TreeChart  endeavors to preserve Layout 
information associated with existing text fields, and to handle additional fields intelligently.

Charts generally will have Text Fields defined before importing text. Even when opening a text file,  
TreeChart will precede loading the text by either loading the Template (if you have defined one), or by 
creating a default chart, containing the Text Fields Name & Position.

One important constraint is that all boxes in a chart will always have the same number of Fields.

If the text being imported is in TreeChart Outline Text format:

Then the imported text contains Field Names, and TreeChart attempts to match these against Field 
Names already in use in the chart.

Where an imported Field Name matches an existing Field Name, the existing Field (and its associated 
Layout information) is used.

Where an imported Field Name does not match an existing Field Name, a new Field is added to the 
chart, with the Name used in the imported text. It will be given default Layout information.

If an existing Field Name does not appear in the imported Field Names it is retained, and all boxes 
generated from the imported text will have an empty Field. A program option can be set to instead  
automatically delete unused fields if desired. See section A1.2.



If the text being imported is Tab or Comma Separated Text format:

Then no Field Names are in the text, and we simply match Fields in the imported text against existing  
Fields(and their associated Layout information), on a first-come, first-served basis.

In both cases:

If there are more Fields in the imported text than already existed in the chart, new Fields are created, 
and given a unique Name (Untitled:NNN) and default Layout information. This is performed on a line 
by line basis, and if one line of text has more fields than the others, all other boxes will have empty 
Fields added, since all boxes must have the same number of Text Fields.
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License Agreement

FINELINE SOFTWARE DISCLAIMS ALL WARRANTIES  RELATING TO THIS  SOFTWARE, 
WHETHER  EXPRESS  OR  IMPLIED,  INCLUDING  BUT NOT LIMITED  TO  ANY IMPLIED 
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, AND 
ALL SUCH WARRANTIES ARE EXPRESSLY AND SPECIFICALLY DISCLAIMED. NEITHER 
FINELINE  SOFTWARE  NOR  ANYONE  ELSE  WHO  HAS  BEEN  INVOLVED  IN  THE 
CREATION, PRODUCTION, OR DELIVERY OF THIS SOFTWARE SHALL BE LIABLE FOR 
ANY INDIRECT,  CONSEQUENTIAL,  OR INCIDENTAL DAMAGES ARISING OUT OF THE 
USE OR INABILITY TO USE SUCH SOFTWARE EVEN IF FINELINE SOFTWARE HAS BEEN 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES OR CLAIMS. IN NO EVENT SHALL 
FINELINE SOFTWARE'S LIABILITY FOR ANY DAMAGES EVER EXCEED THE PRICE PAID 
FOR THE LICENSE TO USE THE SOFTWARE, REGARDLESS OF THE FORM OF CLAIM. THE 
PERSON  USING  THE  SOFTWARE  BEARS  ALL  RISKS  AS  TO  THE  QUALITY  AND 
PERFORMANCE OF THE SOFTWARE. Some states  do not  allow the  exclusion of  the  limit  of 
liability for consequential or incidental damages, so the above limitation may not apply to you.

This agreement shall be governed by the laws of the Republic of Ireland and shall inure to the benefit  
of FineLine Software and any successors, administrators, heirs and assigns. Any action or proceeding 
brought by either party against the other arising out of or related to this agreement shall be brought 
only in a court of competent jurisdiction located in the Republic of Ireland. The parties hereby consent 
to in personam jurisdiction of said courts.

U.S.  Government  Information:   Use,  duplication,  or  disclosure  by  the  U.S.  Government  of  the  computer  software  and 
documentation in this package shall be subject to the restricted rights applicable to commercial computer software as set forth in  
subdivision (b)(3)(ii) of the Rights in Technical Data and Computer Software clause at 252.227-7013 (DFARS 52.227-7013).  
The Contractor / manufacturer is FineLine Software, Newtown, Kinvara, Co. Galway, Ireland.

Evaluation (shareware) version license:

TreeChart is NOT public domain. It is copyrighted by FineLine Software.

You are encouraged to use this program for 30 days prior to obtaining a permanent license. You may  
share the evaluation (shareware) version of this program with anyone you choose as long as you do not  
change it. You may not charge for sharing a copy unless you comply with the terms of the LIMITED 
DISTRIBUTION LICENSE detailed in file VENDINFO.DIZ. If this file is missing and you wish to 
charge for distributing TreeChart, contact FineLine Software.

You may not use, copy, rent, lease, sell, modify, decompile, disassemble, otherwise reverse engineer, or 
transfer the licensed program except as provided in this agreement. Any such unauthorized use shall  
result in immediate and automatic termination of this license.

All rights not expressly granted here are reserved to FineLine Software.

It is your responsibility to determine if the program will work reliably on your equipment and for your 
particular business environment. That's why evaluation copies are made available to you. If you don't  
agree with these conditions, delete the program files from your computer and don't send us any money.



Registered version license:

If you register, the license you purchase permits you to use a registered version of TreeChart on one  
computer. Apart from taking backup copies for your own security, the registered version of TreeChart  
may not be copied or distributed.

The license is valid only for one major version of TreeChart. You willl be issued with a registration key 
to enable you to self-register the shareware version of any subsequent minor upgrade that you may  
obtain either directly from FineLine Software or through other channels.

The registration key may be used only by the licensee specified in the original order for the license. By 
ordering a license, you acknowledge that this key represents a trade secret and agree to protect it as  
such. Misuse of a registration key or distribution of the registered version is subject to collection of 
triple the fees that should have been collected and all legal fees and costs. Licenses are not transferable  
and may not be modified.
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Registering the program
As stated in the Introduction, if, after evaluating TreeChart for up to 30 days you wish to continue  
using the program, you must purchase a license to use it. This process is termed Registration.

A4.1 The Benefits of Registration

■ Printed and bound User Guide plus Tutorial
■ The most recent copy of the program
■ Support if file format changes
■ Registration remains valid for minor upgrades
■ Notification of minor & major upgrades
■ Automatic (& free) re-registration if a major upgrade is released within six months
■ All registration reminders / 'unregistered version' messages removed
■ Its the right thing to do

Changes to the .TCF / .TCT file format

We aim to continuously improve TreeChart, and in so doing it may be necessary to change the way we 
store your information. This is of no consequence during an evaluation period, but becomes significant  
if you wish to read files saved under an old version of TreeChart into a newer version. The registered 
version of TreeChart contains code to automatically detect and handle format changes, unregistered 
versions omit this code, and can only report an error if you request an old-format file to be loaded.

See Appendix A4.4 for details of our upgrade policy.

A4.2 How To Register

Registering TreeChart  can  be  done from within  the  program itself:  From the  Help  menu,  choose 
Register.

Then follow the instructions in the registration dialog. Since we are actively seeking local agents to 
simplify the registration process for you, the precise procedure will vary.

If you have any problems, contact FineLine Software direct (see the front of this User Guide).

A4.3 Support Policy

Registered users are offered lifetime support and a money-back guarantee.

Support is provided by the developers. Where practicable, we would prefer that you contact us by 
electronic mail or post; this allows us to better manage our time, and gives us the chance to consider  
and investigate the problem.

Bugs will be fixed for free, if possible. If not, a full refund will be offered. A written description of the  
fault, a copy of your data file (.TCF), and a description of the hardware / software environment are  
essential in notifying us of a fault so that we can duplicate the problem.



Support will be provided to non-registered users on a 'play it by ear' basis. Our general view is that if 
you've gone to the effort of contacting us, you deserve a reply.

A4.4 Upgrade Policy

We aim to continuously improve TreeChart, and new versions will periodically become available.

Upgrades will be either minor or major. Either type may necessitate a change to the file format. As 
noted in Appendix A4.1, evaluation copies omit code that supports old file formats.

For minor upgrades, the main version number will not change; for instance version 1.3 to version 1.4.

For major upgrades, the main version number is changed; for instance version 1.4 to version 2.0.

Registration keys are valid for a major version number: they work irrespective of the minor version 
number. The minimum time between major upgrades will be six months.

Upgrades will be available through the normal shareware distribution channels, but registered users  
will be notified of both minor and major upgrades as soon as they are released.

Registered Users - Minor Upgrades

If you obtain the latest version from your shareware vendor, your registration key is still  valid. If 
the .TCF / .TCT file format changed, the differences are handled automatically.

Registered Users - Major Upgrades

You can choose the most appropriate route for your circumstances:

■ you can do nothing, and your license to use your current version continues.

■ you can obtain the new version from your shareware vendor for evaluation, and then 
decide what action to take.

■ you can purchase an upgrade for significantly less than the registration cost. Specific  
costs may vary, and will be announced in the upgrade notification.

If a major upgrade is issued within six months of your initial registration, you will automatically be  
upgraded to the new version, and a disc-only upgrade (without the printed manual) will be sent to you 
automatically and at no cost. If you feel you'd like the latest copy of the printed manual, a nominal 
charge may be made. Details will be included when the upgrade is sent to you.

Requests for major-version upgrades should always be referred directly to FineLine Software (see the 
front of this User Guide).
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Frequently Asked Questions

Why is TreeChart being released as shareware, rather then as a retail product?

We believe TreeChart compares very favourably to competitors' programs released as retail products.

TreeChart is being released as shareware for commercial reasons. Selling TreeChart in this way lets  
our company develop without committing a huge quantity of cash. A retail  product might require  
$200,000  to  launch:  advertising,  packaging,  dealer  margins,  etc.  If  the  launch  is  a  success,  the 
customers are paying that $200,000. If its a failure the company or the investors lose. TreeChart is  
shareware to minimize the risk to us, and to minimize the time spent seeking major investment.

How big can a chart be?

This is a bit more complicated than you might imagine.

Firstly, the physical dimensions of the chart. If the Current View is more than about 250" horizontally 
or vertically, box placement will wrap-around: boxes 'positioned' at the far right will be drawn at the 
left, for instance. TreeChart doesn't report this as an error (or even give a warning), but the effect will  
be obvious. You can still work with this chart, though since boxes might be overlapped, box selection 
can be awkward. Obviously, if you print the chart in this state it  won't look very impressive. The  
solution is to use outlining to hide some aspects of the chart; the limit is on the Current View, not the 
chart itself.

In terms of data capacity or memory use:

The names of things (Text Fields, Layouts, etc) must be less than 255 characters.
The contents of a Text Field must be less than 255 characters.
A few things (eg number of Text Fields) have a limit of about 32,000
Most other things have no fixed limit.

In general, TreeChart will happily make use of all available (physical + virtual) memory.

Why don't you offer dotted line styles or patterned fills?

Because they don't scale properly. Let's re-phrase that: Windows provides support for dotted / dashed  
lines and patterned fills, but then doesn't scale them in the same way that it scales other graphical 
information.

For dotted / dashed lines, the length of a dot or dash is fixed by the display or printer. For example, a  
dash might be one tenth of an inch long. Dotted / dashed connecting lines might look fine when your 
boxes are half an inch apart, but if they're scaled to make them a tenth of an inch apart, then your 
dotted / dashed line will look bad. Sometimes, it will disappear entirely.

For patterned fills, the same restriction applies. For example, cross-hatching lines are a fixed distance  
apart. What will look fine at normal size will look bad when the chart is re-sized.



We decided  that  correctly  scaleable  charts  (both  for  printing  and  for  copying  pictures  into  other 
documents) was too valuable for you to be disappointed with poor TreeChart output due to using 
unsuitable Windows features.

Plain English version: it looks awful and you'd blame TreeChart. We prevent this happening.

We're open to persuasion on this one.

With version 2.00, dotted lines are available for lines indicating "Co-Managers". See section 7.6.

Why don't you offer to copy or save charts as bitmapped pictures?

Bitmaps generally produce poor results when rescaled. Bitmaps tend to be device dependent. Bitmaps 
of charts will  get  very large. On the assumption that the program you're importing the image into 
supports Windows Placeable Metafiles (most do), the only circumstances where bitmaps seem at all  
useful is where the chart (or Current View) is small, you won't want to resize the image, and the fonts  
you use in the chart are unavailable when the image is drawn. This combination of circumstances 
seemed too unlikely to warrant the extra work for us.

If the chart is of a manageable size, you can convert a Metafile into a bitmap by pasting into the 
Windows Paintbrush accessory.

Why no freehand drawing tools?

There are two reasons for this. Firstly, if you added lines or text to a chart TreeChart wouldn't know 
what  to  do with  them whenever  it  recalculated box positions  for  you.  Secondly,  you've  probably 
already got a drawing program that you're happy working with. Rather than add a zillion features to 
TreeChart (and probably still not match the features of your drawing program), we simply enable you 
to import a picture of a chart into other programs.

Programs  such  as  the  Microsoft  Draw  mini-app  (bundled  with  Microsoft  Word  and  Works,  for 
example)  can  be  used  not  only  to  add text  and  lines,  but  also  to  change the  pictures  TreeChart 
produces: for instance, to change the color of one connecting line where TreeChart has colored the  
connectors uniformly. More sophisticated drawing programs will  be able to do more sophisticated 
changes.

When I try to load a chart I saved some time ago, I get an error message saying that 
TreeChart can't cope with a different data file format. What does this mean?

This message can happen in two related situations. Either  might occur if you save a chart with one 
version of TreeChart, and try to open it with a different version. We aim to continuously improve  
TreeChart, and in doing so it may be necessary to change the way we store your information. Different  
versions of TreeChart may therefore have different .TCF / .TCT file formats.

Where the file format has changed, an earlier version of TreeChart will  never be able to open a file 
saved by a later version of TreeChart. This is inevitable: if the earlier version could cope with the  
additional or changed data, there would have been no need to change the file format in the first place.

Where the file format has changed, a registered later version of TreeChart will automatically handle 



any format differences if a file has been saved by an earlier version of TreeChart (registered or not).  
Unregistered versions do not contain the required data conversion code, and will report an error if you  
try to open a file saved by an earlier version.

If you only ever use one version of TreeChart (for example, during the evaluation period), you will 
never encounter this message.

See Appendix 4 for details of other benefits of registering, and how to go about it.


