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INTRODUCTION

Welcome to Canvas, a unique, integrated graphics environment. 
Canvas lets you work with drawings, images, type, and imported 
graphics in one program. Canvas provides specialized document 
options and templates so you can create illustrations, presentations, 
and publications, without having to switch to other applications.

Whether you are a newcomer to desktop graphics, or an experienced 
designer, you’ll find many tools and features in Canvas that can help 
you be more productive.

• A complete toolbox for illustration, layout, editing, proof-
ing, and final output lets you take your projects from start to 
finish in Canvas.

• A flexible interface with floating palettes for most functions 
helps you work faster, while templates with custom settings, 
illustrations, and text give you a head start on your projects. 

• Canvas files are compatible across Mac OS and Windows 
platforms, and Canvas supports all standard file formats, so 
you can easily draw on multiple sources for your projects.

About the documentation
Please take a few minutes to read this chapter for important informa-
tion about the documentation and getting help.

In addition to the User’s Guide, Canvas documentation includes the 
on-line Help system. You should refer to the Release Notes in the on-
line Help system for the latest information, including changes to the 
documentation and updates to the program.
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Conventions used in the documentation

The Canvas documentation uses certain terms and syntax when 
describing menu commands, mouse actions, keyboard keys, and pro-
cedures for specific operating systems.

Specific editions of Canvas work with specific operating systems. 
The documentation points out functional differences when necessary. 

Mac OS The Apple Computer operating system for Macintosh and 
compatible computers. In the documentation, Mac OS refers to Sys-
tem 7 and later versions, including 7.1, 7.5, 7.5.3, and so on. When a 
certain procedure is for Mac OS only, we write “(Mac)” following 
the instructions. 

Windows The Microsoft operating system for IBM-PC compatible 
systems. In the documentation, Windows refers to 32-bit Windows, 
including Windows 95 and Windows NT 3.5.1 and later versions. 
When a certain procedure is for Windows only, we write “(Win-
dows)” following the instructions.

Keyboard keys and shortcuts

Standard names and abbreviations are used for keyboard keys on 
each platform; your particular keyboard might use different labels.

Menu commands

When the documentation tells you to use a menu command, the 
instructions are written this way: 

Key name Description

Alt The Alternate key, usually labeled “Alt” on Windows 
keyboards.

Command The key labeled “Command” or marked with a pro-
peller or Open Apple symbol on Mac OS keyboards.

Ctrl The key labeled “Control” or “Ctrl” on both Mac OS 
and Windows keyboards.

Option The key labeled “Option” on Mac OS keyboards.

Shift The Shift key, used to type capital letters.

Enter The key labeled “Enter” on Mac OS keyboards. This 
key has a different function than the “Return” key.

Return The key labeled “Return” on Mac OS and “Return” 
or “Enter” on Windows keyboards.

✔Tip
Throughout the book, you’ll 
find tips for working efficiently 
and exploring creative possibil-
ities. You should also watch for 
items labeled “Important” for 
information to help you avoid 
problems.
Canvas User’s Guide



                
Choose Paste in the Edit menu. 

This instruction tells you to: choose the paste command by opening 
the Edit menu and selecting (highlighting) the “Paste” command. 
You can also use a keyboard shortcut or speed key, if one is shown in 
the menu.

In some cases, a menu command opens a submenu of additional 
commands. When the documentation tells you to choose a submenu 
command, the instruction is written this way: 

Choose Arrange➤Bring To Front in the Object menu.

This instruction tells you to: open the Object menu, highlight the 
“Arrange” command so that the submenu opens, and then choose the 
“Bring To Front” command in the submenu.

Using modifier keys with the mouse

For some actions, you press a key at the same time you click or drag 
the mouse. For example, you can press the Shift key as you click an 
object to select it. This action is described as “Shift-click.” If you 
press the Command key, for example, at the same time you drag the 
mouse, the action is described as “Command-drag.” 

When referring to Canvas for Windows, some instructions tell you to 
“right-button click” an object. This means that you click the object 
using the right-hand button on the mouse.

Using the on-line Help system
The Canvas Help system lets you view documentation while you 
work. It’s designed to provide the same, up-to-date information and 
operate the same on both Mac OS and Windows platforms.

To view Help within Canvas (Mac OS)

Press the Help key on an extended keyboard or choose “Contents,” 
“Shortcuts,” or “Find Help On…” in the Help menu (also known as 
the Balloon Help menu) under the question mark ( ) icon.

Note: The Canvas Help system is available if you install Canvas 
using the “Easy Install” option, or if you perform a custom installa-
tion that includes the on-line Help system files.

◆ To view the Canvas release notes: Choose Contents in the 
Help menu to open the Contents page of the Canvas Help system. 
Then click “Release Notes” to view the latest information on Canvas.
Using the on-line Help system 5
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When a dialog box is open and you press the Help key, the Help sys-
tem displays the Help topic for that dialog box. Otherwise the Help 
window opens. You can view a list of topics and search for topics in 
the Help window.

To view Help within Canvas (Windows)

Press the F1 key to display Help or choose “Contents,” “Shortcuts,” 
or “Find Help On…” in the Help menu. When a dialog box is open 
and you press the F1 key, the Help system displays the Help topic for 
that dialog box. At other times, a Help window opens. You can view 
a list of topics and search for topics in the Help window.

Commands in the Help menu

The following commands in the Canvas Help menu give you quick 
access to the Help topics you want.

Contents Opens the Table of Contents for the Help system.

Find Help On Opens a Help window that lets you search for topics 
by entering a word or phrase.

Shortcuts Opens the Help topic that describes keyboard and mouse 
alternatives to Canvas commands.

Deneba Home Page Mac: If you have a web browser open, Can-
vas switches to the browser and loads the Deneba home page. Other-
wise, Canvas searches for an installed browser (Cyberdog, 
Navigator, Internet Explorer, or Mosaic, in that order), launches it, 
and loads the Deneba home page. Windows: Canvas switches to or 
launches the default browser (as designated in the system Registry), 
then loads the Deneba home page.

To view Help without Canvas

Double-click the file named Canvas Help (Mac) or Canvas.hlp (Win-
dows). This launches the Help application and opens Canvas Help.

Mac OS Help system The QuickHelp application displays the Can-
vas Help topics. If you install Canvas using the “Easy Install” option, 
the Canvas installer also installs the QuickHelp application.

Windows Help system The Windows Help application displays the 
Canvas Help topics. The Windows Help application is part of Win-
dows 95 and Windows NT operating systems.
Canvas User’s Guide
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Starting and exiting

                              
1

RUNNING CANVAS

This chapter explains how to start and end a Canvas work session. It 
also provides an overview of the Canvas interface and describes 
basic procedures, including how to 

• select tools from the Canvas toolbox

• open and arrange palettes

• use information displayed in the status bar

• undo, redo, and repeat actions

Starting and exiting Canvas
To start Canvas, use one of the following methods:

• Double-click the Canvas 5 program icon. 

• Choose the Canvas shortcut in the Start menu (Windows).

• Double-click a Canvas document to start Canvas and open 
the document.

• Double-click a Canvas template file to start Canvas and cre-
ate a new document based on the template.

When you start Canvas, it displays a start-up screen and a status indi-
cator as it loads. Then Canvas opens a blank document, or the docu-
ment you used to start the program. 

◆ To view the start-up screen during a Canvas session: Choose 
About Canvas in the Apple menu (Mac) or the Help menu (Win-
dows). You can view the start-up screen again to check your serial 
number, version number, and other information.

◆ When you want to stop using Canvas: Choose Quit (Mac) or 
Exit (Windows) in the File menu. If you try to quit without saving a 
document that has changed, Canvas asks if you want to save it first. 

Loading external tools at start up

Each time you start Canvas, you can use the ToolPicker to select 
which external tools you want to load. The tools that load at start up 
are available for the current work session. If you want to select differ-
ent tools, you can restart Canvas and use the ToolPicker again.

Canvas 5 program icon
 Canvas 9
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◆ To use the ToolPicker: Press the Spacebar as soon as the Can-
vas start-up sequence begins. Continue holding down the Spacebar 
until the ToolPicker dialog box appears. 

You can use the ToolPicker to select tools for one work session or 
select the tools you want to load every time you start Canvas. You 
can also create groups of external tools for different projects; see 
“Loading external tools” on page 93.

Checking optional software at start up

Canvas displays a message if it encounters a problem, such as miss-
ing system software components, as it starts. If a message appears, 
click OK to continue loading Canvas.

Canvas depends on some system software components for importing 
and exporting certain types of files, managing colors, and working 
with some graphics formats, such as QuickDraw 3D. The Canvas 
installer places some software, called “extensions” (Mac) or 
“Dynamic Link Libraries” (Windows), on your system, if needed. If 
Canvas can’t find the required component later, it’s possible the file 
was moved or disabled. 

If you encounter a problem when starting Canvas, refer to the “Read 
Me” file and to the on-line Help system; these include the most up-
to-date information on required software.

Overview of the Canvas interface
Canvas looks nearly identical on Mac OS and Windows systems. 
Depending on the operating system, a few items (including the menu 
bar and title bar) do look slightly different.

Some operations differ slightly on Mac OS and Windows systems, 
though the differences won’t surprise users who are familiar with 
each platform. 

For example, Mac OS users should be aware that, to select a com-
mand, they need to press the menu name and drag into the menu 
without releasing the mouse button. Windows users should know that 
they can click the menu name and the command name, and don’t 
need to hold down the mouse button to choose a command.

A similar procedure carries over to the Canvas toolbox. On Mac OS 
systems, you should press (rather than click) an icon in the toolbox to 
open a toolbar or palette. On Windows systems, you can click or 
press an icon to open a toolbar or pop-out palette.
Chapter 1: Running Canvas



          
Specialized interface items
Canvas has three types of documents, illustrations, presentations, and 
publications; each has special properties and capabilities. Some Can-
vas interface items change when you switch from one type of Canvas 
document to another. 

Layout area In illustration documents, the layout area represents 
the final page size. In publication documents, the layout area repre-
sents one page or two facing pages of the publication. In presentation 
documents, the layout area represents a slide shown on screen. 

Page and Slide buttons When you work in a publication or pre-
sentation document, you’ll see icons of pages or slides at the bottom 
of the document. The icons are buttons you can click to move 
through the document’s pages or slides. 

Layer bar In illustration documents, the Layer bar at the bottom of 
the window lets you select and move among multiple layers. The 
Layer bar doesn’t appear in publication documents, which don’t con-

The Canvas interface

This illustration identifies 
the main parts of the Can-
vas interface.

A Menu bar
B Toolbox
C Illustration / Layout area
D Layer bar (appears only 

in illustration 
documents)

E Zoom bar
F Status bar
G Scroll bars

File Edit Text Object Layout Effects Image Window Help

G

B

E

D

F

A

C

Slide buttons

Master slide Master pages

Page buttons
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tain layers, or presentation documents. In presentation documents, 
you can use the Slide Info palette to work with the layers of a slide.

Using the toolbox
The toolbox is a floating palette you can place anywhere on screen. 
When Canvas starts, the toolbox is on the left. To move the toolbox, 
drag its title bar. Selecting tools from the toolbox

The toolbox displays 10 tools at a time, and it contains more than 40 
tools for drawing, painting, creating objects, editing, and viewing. 
The tools that aren’t displayed are on toolbars that pop out from the 
toolbox.

◆ To select a tool displayed in the toolbox: Click the tool. The 
selected tool becomes shaded, like a recessed button. 

◆ To select a tool from a toolbar: Press the displayed tool at the 
toolbar location and drag to the tool you want to select on the toolbar. 
The selected tool appears in the toolbox.

◆ To bring the toolbox to the front or display the toolbox (if 
closed): Choose Palettes➤Toolbox in the Window menu.

Tool icons

Palette icons

Title bar

Selection tool (selected)

Tools in the toolbox 

Most Canvas tools appear 
on toolbars that pop out 
from the toolbox. The cur-
rent tool from each toolbar 
is visible in the toolbox.

A Selection tools
B Line tools
C Rectangle tools
D Oval tools
E Object tools
F Paint tools
G Text tools
H Path tools
I Magnifying glass tool
J Effects tools

E

G

H

I

J

B

C

D

A

Sounder tool (Mac OS only)

QuickDraw 3D and 
QuickTime tools (optional)

F
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The dimensioning and Smart Lines tools have their own toolbars. 
One dimensioning tool is displayed in the Object tools toolbar; you 
press this tool icon to open the toolbar containing all the Dimension-
ing tools. One Smart Lines tool is displayed in the Line toolbar; you 
press this tool to open the toolbar containing all the Smart Lines 
tools.

During a work session, Canvas displays the tool you selected last at 
each spot in the toolbox. For example, if the eraser was the last paint 
tool selected, Canvas displays the eraser at the upper-right corner of 
the toolbox, at the Paint toolbar location. 

Each time you start Canvas, the program returns the toolbox to its 
default arrangement of tools. 

Using palettes
The three icons at the bottom of the toolbox open palettes for apply-
ing inks and strokes. The palettes contain attributes such as colors, 
dashes, and patterns, which are grouped on tabs within the palettes.

To open a palette, press the icon. To select attributes in the palette, 
drag to the item you want to select. To switch tabs, drag to the tab 
you want to use. If some attributes aren’t visible in the palette, drag to 
the scroll bar on the right to display more. 

You can also drag a palette away from the toolbox to keep it open 
while you work. When a palette is separated from the toolbox, you 
can use the palette’s configuration manager to create custom colors, 
patterns, textures, and other attributes.

When palettes are floating (detached from the toolbox), you can han-
dle them the same as other windows. To move a palette, drag its title 
bar. To roll up a palette, double-click its title bar (Mac) or click the 
box at the right end of the title bar (Windows).

You can use menu commands to arrange palettes and clear them off 
the screen all at once.

◆ To roll up all palettes: Choose Palettes➤Clean Up Palettes in 
the Window menu. All open palettes roll up and move to the upper-
right corner of the screen.

◆ To close all palettes: Choose Palettes➤Put Away Palettes in 
the Window menu. Canvas closes all the open palettes.

This toolbar holds six types of 
Smart Lines tools.

Strokes palette

Fill Ink palette

Pen Ink palette
Overview of the Canvas interface 13
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Using the status bar
The status bar is at the bottom of the screen (Mac OS) or the bottom 
of the Canvas program window (Windows). The status bar provides 
information about commands, tools, objects, and program operations.

Message area

The message area displays tool names, tips, and status messages. 
When you move the pointer over a tool icon or other item, the mes-
sage area shows the tool’s name and function. You can use this fea-
ture to take a tour of the Canvas tools and interface.

When Canvas performs certain actions, such as saving a document, 
Canvas displays a progress bar in the message area.

Coordinates data

When you move the pointer, draw, resize, or rotate objects, the status 
bar displays measurement and position information in the coordi-
nates area. You can change the unit of measurement for this data 
using the Rulers command in the Layout menu. 

If you set up a drawing scale, the data displayed in the coordinates 
area conform to the drawing scale. For example, if you set the draw-
ing scale to 1 centimeter = 1 meter, and you draw an object that mea-
sures 5 centimeters by 5 centimeters on screen, the coordinates area 
displays: W 5 m H 5 m.

Depending on whether you are drawing or resizing objects or moving 
the pointer or objects, the coordinate area displays either dimension 
data or the pointer position.

Dimensions As you drag the pointer to draw or resize objects, in 
most cases the status bar displays the width (W) and height (H) of the 
object’s bounding box. As described in the following table, Canvas 
displays different data for resizing or drawing special objects, such as 
lines and rounded rectangles.

Pointer position When you move the pointer, the status bar shows 
the position of the pointer. The horizontal (X) coordinate is the dis-
tance horizontally from the ruler’s zero point; the vertical (Y) coordi-
nate is the distance vertically from the ruler’s zero point. When you 

Information areaCoordinatesMessage area
Chapter 1: Running Canvas



move objects, Canvas displays the change in position from the origi-
nal X and Y coordinates. 

The following table summarizes the data displayed in the status bar.

Information area

When you select an object, the information area displays the object 
type. When you select more than one object, this area displays the 
number of selected objects. If you select objects that are grouped, the 
information area displays “Group of n objects,” where n is the num-
ber of objects.

When a single object is selected, press the pointer on the information 
area to open a pop-up menu showing the height, width, area, and 
perimeter of the object. To paste the data next to the object, choose a 
data item in the pop-up menu.

When you do this The status bar displays this

Move the pointer in the document The pointer’s horizontal and vertical distance from the ruler’s zero point

Drag an object in the document The horizontal and vertical distance from the starting point

Rotate an object The angle of the top of the object’s bounding box

Draw or resize a line The length and angle of the line

Create paint images and most draw 
objects

The height and width of the object’s bounding box

Resize an object (except a line) or 
group

The height and width of the object’s bounding box

Drag an arc’s circular handle The position of the arc’s endpoint relative to the current coordinate system 
and the degrees traveled by the arc relative to its starting point

Drag a rounded rectangle’s circular 
handle

The corner’s radius

Draw with the Curve 
or Polygon tool

The pointer’s horizontal and vertical distance from the ruler’s zero point

Drag an anchor point of an object in 
edit mode

The pointer’s horizontal and vertical distance from the ruler’s zero point

Information area

Data pop-up menuWith a single object selected, 
press the information area to 
open a pop-up menu of basic 
dimension data.
Using the status bar 15
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Undoing, redoing, and repeating actions
You can easily correct mistakes, restore your work to an earlier state, 
and repeat commands using the Undo, Redo, and Again commands. 

◆ To cancel the last change that you made: Choose Undo in 
the Edit menu. You can choose Undo multiple times to cancel prior 
changes in reverse order. 

You can tell Canvas how many changes you want to be able to cancel 
with the Undo command. Initially, the number of Undo levels is set 
to 10. Because Canvas uses memory to keep track of changes you 
make in a document, you should use the lowest possible number of 
Undo levels if you are trying to conserve memory. See “General Can-
vas preferences” on page 85 for information on setting the number of 
Undo levels.

Not all actions can be canceled with the Undo command. Actions 
that can not be canceled include scrolling; closing or reverting to an 
earlier version of a document; selecting and deselecting objects; 
deleting settings in palettes; and saving documents.

◆ To restore actions you canceled using Undo: Choose Redo in 
the Edit menu. You can choose Redo multiple times to reinstate can-
celed actions in reverse order.

◆ To repeat a command or other action: Choose Again in the 
Edit menu. When an action can be repeated, the Repeat command 
includes the name of the action. For example, after you rotate an 
object, the Again command appears as “Rotate Again.”

Not all actions can be repeated. The Again command isn’t available 
if the previous action can’t be repeated.

When you select items in the 
information area’s Data pop-up 
menu, Canvas pastes the data 
next to the selected object.

Perimeter = 5.50 in
Area = 1.75 sq. in

Width = 1.75 in

Height = 1.00 in
Chapter 1: Running Canvas



Opening Canvas doc
2

DOCUMENT BASICS

Canvas documents are the containers for your work. A Canvas docu-
ment can accommodate vector drawings, text, and raster images for 
all types of illustrations, publications, and presentations. 

This chapter describes the basics of working with Canvas documents, 
including how to open, save, view, and print them.

Opening Canvas documents
You use the Open command to open Canvas 5 documents stored on 
disk. For information on opening files created by other programs and 
earlier versions of Canvas, see the chapter “File and data exchange” 
on page 57.

To open a Canvas document

1 Choose Open in the File menu. Canvas displays a standard dia-
log box for you to select a document file. By default, the dialog box 
lists the names of Canvas 5 documents in the current directory.

2 In the file list, select the document you want to open and click 
Open. Canvas displays a preview if the selected document contains 
a preview. For Mac OS, Canvas previews require that QuickTime 
extensions be installed; see “QuickTime file previews (Mac only)” 
on page 60.

Open dialog box 
(Windows 95)

Select a file

Or, type a file name

Preview image (if available)
uments 17
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◆ To open a document you worked with recently: Choose the 
document name from the list of recently opened documents in the 
File menu.

If you need additional help working with files, folders, and directo-
ries, refer to your Mac OS or Windows documentation.

You can open more than one document at a time in Canvas. When 
you open a document, Canvas loads the document into your system’s 
memory. You need to have enough memory available to hold the 
document’s contents. Documents that contain many complex objects, 
or large high-resolution images, require more memory than simple 
documents containing a few vector objects.

When you work with a document, changes you make to the docu-
ment are not saved until you use the Save or Save As command.

◆ To start Canvas and open a document simultaneously: Dou-
ble-click a Canvas document icon in a folder or directory on your 
system. The program starts and the document opens.

Open dialog box (Mac)

You can select files in the scroll 
list and see a preview of the 
selected file (previews are dis-
played only if QuickTime is 
installed).

You can also use the Show All 
Files option to see all files in a 
folder in the scroll list, even if 
Canvas can’t open the file. 
This is different from the “All” 
setting in the File Format pop-
up menu, which lets you see 
all files that Canvas can open.

If you highlight a QuickTime 
movie or Sound file in the scroll 
list, the preview area lets you 
play a movie or sound preview.

In addition, the button below 
the preview area lets you man-

age preview images.

• When the button says Cre-
ate, you can make a preview 
for a file that doesn’t have one. 
To create previews, you must 
have the appropriate Claris 
XTND Translator installed on 
your system; see “XTND file fil-

ters” on page 60.

• When the button says 
Update, this means the file and 
its preview are not consistent. 
You can click the Update but-
ton to refresh the preview so 
it matches the file.

1 C:\Documents\Floor1.cv5

2 C:\March\Orgchart.cv5

3 D:\Bob\Plotplan.cv5

4 C:\Canvas\Map.cv5

Documents opened recently are 
listed in the file menu.
Chapter 2: Document basics



Opening non-Canvas files

Canvas includes filters that let you open many types of graphics and 
text files. In the Open dialog box, the Format (Mac) or “Files of type” 
(Windows) pop-up menu lists the supported file types. You can use 
the Open and Place commands to import these files. For more infor-
mation, see “Using non-Canvas file formats” on page 58.

Substituting fonts when opening documents
If a document you open uses fonts that aren’t available on your sys-
tem, Canvas displays a dialog box before opening the document. You 
can use the dialog box to review which fonts are required by the doc-
ument and to select substitute fonts, or you can let Canvas select sub-
stitutes.

1 Select a font listed under Original Font, or Shift-click to select 
multiple fonts. This is a font specified in the document that now 
isn’t available.

2 Choose a substitute font in the pop-up menu. The name of the 
font appears in the list under Substitute Font. Canvas displays the 
font name in its corresponding type face so you can preview the 
font substitution.

3 Turn on Permanent Change to replace the missing fonts with 
the fonts you choose in this dialog box.

4 After you select substitutes for the missing fonts, click OK to 
open the document. To cancel the changes, click Clear Changes to 
let Canvas choose a substitute and open the document.

Choose substitute fonts here

Select a font for which you 
want to specify a substitute

Turn on to permanently 
replace the missing font
Opening Canvas documents 19
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Opening documents that require specific tools
When you open a Canvas document that depends on one or more 
external tools to display and print correctly, Canvas alerts you if the 
necessary external tools aren’t available. To load the required tools, 
quit Canvas, restart Canvas, and press the Spacebar to open the 
ToolPicker dialog box. Select the tools you want, or click All Tools. 

Placing documents
You can use the Place command to incorporate a document stored on 
disk into an open Canvas document. For example, you can place a 
document containing your company logo within a document in which 
you are preparing a sales brochure. 

The Place command lets you visually set the location and dimensions 
of the incorporated document. If the document that you place has 
more than one layer, you can choose which layers to place.

The Place command isn’t available if no documents are open.

To place a document in an open Canvas document

1 Choose the Place command in the File menu. 

2 In the directory dialog box, select the document that you want 
to place and click Place. (If the file contains multiple layers that 
Canvas can import, the Place Options dialog box opens; see below.) 

3 Position the Place cursor in the open document where you want 
the top-left corner of the placed document to be. 

4 To place the document at full size, click the place icon. To set 
the dimensions of the placed document, drag to create a bounding 
box for it.

Place Options dialog box

Placing a file with multiple lay-
ers opens this dialog box.

Place on current layer. Select 
to flatten the layers and place 
them on the current layer.

Place on new layer(s). Select 
to place each layer on a new 
layer in the current Canvas 
document.

Layers. Click to choose specific 
layers to place. In the dialog 
box that opens, Shift-click two 
layers to select a range, or 
Command-click (Mac) or Ctrl-
click (Windows) to select spe-
cific layers. Click OK to close 
the Layers dialog box.

Click OK to close the Place 
Options dialog box and place 
the file. If Show Place Cursor is 

on, position the Place cursor 
and click or drag to complete 
the operation.

The place cursor
Chapter 2: Document basics



Using Canvas clip art

The Canvas clip art collection is stored in Canvas documents on CD-
ROM. You can use the Open command to open a clip art document 
for editing, or use the Place command or Gallery tool to insert a clip 
art graphic into an open document. For details, see “Adding clip art to 
Canvas documents” on page 120, “Opening Canvas documents” on 
page 17, and “Placing documents” on page 20.

Because it is a locked storage medium, you can’t save documents on 
a CD-ROM. If you open a document from the CD-ROM and want to 
save an edited version, you can store it elsewhere using the Save As 
command. You can also copy files from CD-ROM to a hard disk so 
you can work with them without having the CD-ROM loaded.

Saving Canvas documents
The Save and Save As commands store a document on disk.

• The Save command updates a document file on disk and 
overwrites the previously-stored version.

• The Save As command lets you create a new file on disk 
from an open document, save documents as templates, and 
use other graphics and text file formats.

When you use these commands, the default format for storing docu-
ments is the native Canvas 5 format.

To save a new Canvas document

1 Choose Save As in the File menu. A directory dialog box 
opens.

2 Select a location to store the document and type a file name.

3 Click Save to store the document on disk.

◆ To save changes to a document as you work: Choose Save in 
the File menu to update the document file on disk.

◆ To save a document with a different name or in a new loca-
tion: Choose Save As in the File menu, type a new name or select a 
new location in the directory dialog box and click Save.

Saving selections and layers
If you want to save particular objects or layers as a new document, 
you can use the Save As command and options in the Save directory 
dialog box, shown below.

✔ Important
To avoid losing your work in 
the event of a power failure or 
system failure, use the Save 
command frequently as you 
work to store changes on disk.
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Reverting to the saved version of a document
The Revert command lets you discard changes made to a document 
since it was last saved. This is the same as closing the document 
without saving changes and then opening the original from disk.

Be certain that you want to discard all changes to a document before 
choosing the Revert command, because you cannot use the Undo 
command to restore your work after using the Revert command. 

Keep in mind that you can use the Save As command to save a docu-
ment with a new name. If you are not certain that you want to discard 
changes to a document, use Save As to store a new version on disk, 
then open the original document and compare the two.

◆ To revert to a document’s saved version: Choose Revert in 
the File menu. Before performing the command, Canvas asks you to 
confirm that you want to discard all changes.

Options for saving Canvas 
documents

In the Save dialog box, you 
can tell Canvas to save an 
entire document or only some 
objects or layers.

Save Entire Document. The 
default setting tells Canvas to 
save a complete document.

Save Selection. Choose this 
option after you select the 
objects in the document that 
you want to save as a new doc-
ument. If you don’t select any-
thing, this option is not avail-
able. 

Save Layers. Select this 
option to save one or more lay-
ers in a new document. Then, 

click Layers to specify which 
layers to save. This option isn’t 
available if the document has 
only one layer.

Use Compression. Check this 
box to reduce the size of files 
saved on disk.

Create Preview (Mac) or Save 
Preview (Windows). Turn on 
this option to save a low-reso-
lution preview of the docu-
ment. In applications that sup-

port previews, you can see a 
thumbnail image of the docu-
ment before opening the file.

Use Preview Icon. Canvas cre-
ates a finder icon (Mac OS 
only) with a preview of the doc-
ument if you select this option.

Use Extensions (Mac). Adds a 
three-character filename exten-
sion. Use this if you use Mac 
files on Windows systems.
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Closing documents
When you close a document, Canvas removes the document window 
from the screen. When you close a document, Canvas doesn’t save 
the document, although Canvas will warn you if you try to close a 
document that has changed.

◆ To close a Canvas document: Choose Close in the File menu. 
You can also click the Close box (Mac), or the Close button (Win-
dows) in the document’s title bar to close the document. 

Working with document windows
Each document you open appears in its own window. You can work 
with Canvas document windows the same as other windows. You 
can resize a window, expand it to fill the screen, and minimize or roll 
it up. Canvas provides commands to organize and select document 
windows when more than one is open.

Selecting among open documents

When you open several documents at once, only one is active. The 
Window menu displays the names of open Canvas documents. The 
name of the active document has a check mark.

◆ To make a document the active window: Choose the docu-
ment’s name in the list at the bottom of the Window menu. You can 
also click a document’s window to make the document active. 

When you open more than one document, information in the status 
bar, such as the pointer’s location, applies to the active document. 
The same is true of floating palettes; palette settings apply to the 
active document and they change when you switch documents.

Minimizing and maximizing windows
Window controls differ under Mac OS and Windows, and both oper-
ating systems offer more than one way to resize windows. For more 
information, refer to your system documentation.

Close box

Close button

If you try to close a document that 
hasn’t been saved, Canvas asks if 
you want to save it. To save, click 
Yes. To close it without saving, 
click No. To keep working, click 
Cancel.
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To minimize and restore a window

Mac To minimize a window, double-click the window’s title bar; 
the window rolls up so only its title bar is visible. To restore the win-
dow, double-click the title bar again.

Note: This method depends on the setting in the WindowShade Con-
trol Panel in System 7.5. If the setting in the control panel is different 
than two clicks, the procedure differs. If the control panel isn’t 
installed, you might not be able to roll up windows.

Windows Click the Minimize button in the window’s title bar. 
The window shrinks to an icon at the bottom of the Canvas program 
window. To restore the window, click the Restore button.

To maximize a window

Mac Click the Zoom box in the title bar at the upper-right corner of 
the window.

Windows Click the Maximize button in the window’s title bar.

Arranging windows
When you open more than one document window, you can stack or 
distribute them on screen so they are easier to work with. 

When Canvas arranges document windows, it resizes them if neces-
sary so they fit within the main program window or screen area.

◆ To stack all windows so their title bars are visible: Choose 
Stack in the Window menu.

◆ To arrange windows in rows: Choose Tile Down in the Win-
dow menu.

◆ To arrange windows in columns: Choose Tile Across in the 
Window menu.

WindowShade control panel set 
to two clicks (Mac only). 

A minimized window icon 
(Windows) with Restore, 
Maximize, and Close buttons.

Zoom box

Maximize button

Stack Tile Across Tile Down
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◆ To arrange windows in a grid: Choose Tile in the Window 
menu.

◆ To arrange icons of minimized windows (Windows): Choose 
Arrange Icons in the Window menu.

Viewing documents
This section describes how you can adjust your view of a document. 
Viewing options in Canvas let you

• control when Canvas redraws objects

• scroll to any area with the Hand tool or scroll bars

• increase or decrease the view magnification

• restore any view magnification and location

• display wireframe and process-color views

Controlling when Canvas refreshes the display
Canvas refreshes the display, which redraws all visible objects, when 
you scroll or change magnification. When you work with complex 
images, you can interrupt the redraw to save time, then refresh the 
display when you’re ready.

◆ To interrupt display redraw: Press Command+Period (Mac) 
or Esc (Windows) during normal redraw. 

◆ To refresh the display: Choose Display➤Refresh in the Lay-
out menu. You can refresh the display after interrupting the normal 
redraw or when artifacts disrupt the display.

Scrolling documents
You can use scroll bars or the Hand tool to move to areas of a docu-
ment that aren’t displayed in the document window.
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Using scroll bars

Document scroll bars represent the full document area. The position 
of the scroll box within a scroll bar indicates the current view area. 

To scroll using scroll bars, do one of the following:

• Click one of the arrows to move in the arrow direction.

• Drag the scroll box toward the part of the document you 
want to see. For example, drag up to see more of the top.

• Click the scroll bar to scroll one screen length toward the 
side of the scroll box that you clicked. For example, click to 
the right of the scroll box to move one screen to the right.

Using the Hand tool

Using the Hand tool to scroll a document is like sliding a piece 
of paper on a desktop.

To scroll with the Hand tool

1 Select the Hand tool from the toolbox. The pointer becomes a 
hand.

2 Drag to make the document follow the pointer. For example, to 
move a document up so you can see the bottom, drag toward the top 
of the screen.

Changing the view magnification
Canvas lets you change your view of a document by changing the 
view magnification. You can use the Magnifying Glass, Zoom bar, 
Zoom palette, and Zoom commands to enlarge and reduce the view. 
Changing magnification changes the appearance on screen, but 
doesn’t change the actual size of anything in the document. 

Select a zoom method based on what you want to do:

• To step to the next preset magnification level, use a Zoom 
command or a Zoom button on the Zoom bar. 

• To select an area to magnify, use the Magnifying Glass. 

• To set a specific magnification level, use the Zoom palette. 

You can use magnification levels from 3 to 3,200 percent; normal 
magnification is 100 percent.

◆ To use menu commands to zoom in or out: Choose 
Views➤Zoom In or Zoom Out in the Layout menu. Zoom In 

Scroll box

Horizontal scroll bar

Vertical scroll bar

✔Tip
To quickly and temporarily 
switch to the Hand tool while 
using another tool, press the 
Spacebar and drag with the 
hand pointer.
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increases magnification to the next higher preset level; Zoom Out 
decreases magnification to the next lower preset level.

Using the Zoom bar and Zoom palette

You can use the Zoom bar, at the bottom left of the document win-
dow, to adjust the view magnification. The zoom bar

• displays the current magnification

• changes magnification in preset increments

• opens the Zoom palette

◆ To zoom to the next preset magnification level: Click the 
Zoom-in or Zoom-out button on the Zoom bar. The Zoom-in button 
increases magnification and narrows the view. The Zoom-out button 
decreases magnification and widens the view.

◆ To select any magnification percentage: Press the center of 
the Zoom bar and drag the slider in the Zoom palette. The box at the 
lower left shows the magnification level percentage.

If you drag the Zoom palette away from the Zoom bar, it stays open 
and you can click the preset magnification levels or click anywhere 
on the slider bar. For example, click the slider bar between 50 and 
100 to set the magnification level to approximately 75 percent.

Magnifying specific areas 
You can use the Magnifying Glass to zoom in and out from an area 
that you select in the document.

1 Select the Magnifying Glass in the toolbox. The pointer 
becomes a magnifying glass with a plus sign. 

2 Click the center of the area you want to magnify. Canvas 
zooms to the next higher preset magnification level and centers the 
view at the point you clicked.

Zoom-out Zoom-in

✔Tip
To quickly magnify an object, 
select the object and click the 
Zoom-in button.

To keep the Zoom palette open 
while you work, drag it away 
from the Zoom bar.

Drag the slider to any magnification setting

Click a preset magnification level

Current magnification percentage

✔Tip
To quickly change the view 
magnification, Option+Tab-
click (to zoom in) or 
Option+Tab-Shift-click (to 
zoom out) (Mac). Or, press 
Option+ Command+Plus 
(Mac) or Ctrl+Alt+Plus (Win) 
to zoom in, or Option+ 
Command+Minus (Mac) or 
Ctrl+Alt+Minus (Win) to zoom 
out.
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3 To reduce rather than magnify, Shift-click the area you want to 
center on screen at reduced magnification.

◆ To magnify an area to fill the screen: With the Magnifying 
Glass tool, drag a box around the area you want to magnify.

Using preset and custom views
A view in Canvas stores a magnification level and location within a 
document so you can return to it later. You can use preset views and 
create your own custom views. Preset and custom views appear in the 
Views submenu in the Layout menu. Canvas puts a check mark next 
to the name of the current view.

◆ To select a view: Choose Views➤View Name in the Layout 
menu, where View Name is a view listed in the Views submenu. 

Preset views

You can select two preset views: Home View and Fit to Window. 

Home view Displays the upper-left corner of the document at nor-
mal (100 percent) magnification. 

Fit to Window Reduces or increases magnification to the maxi-
mum magnification level at which the document fills the window.

Custom views

You create custom views based on the current magnification level 
and position of the document in the Canvas window. After you create 
a custom view, you can select it the same as a preset view.

◆ To create a custom view: With the document’s magnification 
and position set, choose Views➤New View in the Layout menu. 
Type a name for the view in the dialog box and click OK.

To remove a custom view

1 Choose Views➤Delete View in the Layout menu. If only one 
custom view exists, Canvas deletes it. 

2 If more than one custom view appears in the Views submenu, 
the Delete Views dialog box opens. Select a view and click OK. 
Canvas removes the selected view from the Views submenu.

Changing display modes
In Canvas, the normal display mode shows illustrations and text with 
the inks, strokes, and other attributes as they are in the document. 

New View...
Delete View

Zoom In
Zoom Out
Fit to Window

✓ Home View
Page Center

Canvas lists custom views
under Home View
in the Views submenu.
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Canvas also provides three special-purpose display modes: Wire-
frame (described below), Gamut Warning, and CMYK Preview. 
Gamut Warning and CMYK Preview are useful for determining 
whether placed or imported RGB graphics will print correctly when 
using process color separations.

The Gamut Warning display mode analyzes the colors in the current 
document and highlights colors that are outside the CMYK gamut. 
You can select the gamut warning color using the Calibration➤ 
Gamut Warning command in the Edit menu. 

The CMYK Preview mode approximates the appearance of RGB 
colors if you print them using CMYK process color separation. For 
example, some bright RGB colors might appear more muted in 
CMYK; Canvas simulates this appearance.

Wireframe display mode

Wireframe mode is useful because it accelerates scrolling and redraw 
and lets you view objects without stroke and ink attributes.

◆ To use Wireframe mode: Choose Display➤Wireframe in the 
Layout menu. Canvas puts a check mark next to the command when 
this mode is active. To return to normal display mode, choose 
Display➤Wireframe again.

In Wireframe mode, Canvas displays attributes as the following:

Desktop printing
Canvas works with all standard desktop printing devices, including 
PostScript and non-PostScript printers. You can print Canvas docu-
ments using black-and-white or color devices.

This section focuses on the basics of printing to desktop printers. It 
describes how to select a printer and set printing options.

For information on additional printing options and special printing 
situations, refer to the Canvas on-line Help system. 

This attribute Is displayed as

Stroke (object outlines) 1-point, solid black pen

Fill and pen ink not displayed

Colors not displayed
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Selecting a printer and printer options 
The first time you print from Canvas, you might need to select a 
printer and configure printing options. This section describes how to 
do this for Mac OS and Windows.

Page setup for Mac OS

1 Select Chooser in the Apple menu. In the dialog box, select the 
printer driver that you want to use. PostScript drivers, such as 
LaserWriter 8 and PSPrinter, work only with PostScript printers. 

2 Select an available printer. If you are connected to a network, 
you might need to select a zone first and then an available printer.

For information on setting up printing options and background print-
ing, refer to your Mac OS and printer documentation.

3 In Canvas, choose Page Setup in the File menu. A dialog box 
appears with page setup options (shown on next page). The specific 
options in the dialog box might be different, depending on your 
printer driver.

Printer setup for Windows

1 Choose Printer Setup in the File menu. A dialog box appears 
(shown on next page); the specific options depend on your printer 
and printer driver.

2 Choose a printer and port in the pop-up menu, which lists 
printers installed for your system. If the printer you need is not on 
the list, use the Printers Control Panel to add it to the list.

3 If necessary, select an appropriate PPD (PostScript Printer 
Description) file. A PPD file contains setup information and 
options for PostScript printers.

4 For more options, click Setup. The available options depend on 
the printer driver you are using. Refer to your printer’s documenta-
tion or click the Help button in the dialog box for more information.

5 Check the other settings and click OK.

Printer drivers in the Chooser
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PostScript (LaserWriter) setup options

The following are options that you can set for PostScript printers in 
the Page Setup dialog box. Some of these options differ, depending 
on the printer driver you have selected. Using these options affects 
the printed output only; the original electronic document doesn’t 
change.

Page Setup (Mac OS) and 
Printer Setup (Windows)

Before you print a document, 
check the settings in these dia-
log boxes. The available 
options at the tops of the dia-
log boxes differ for PostScript 
and non-PostScript printers 
and for specific printer drivers. 

The Fit to paper, Print info, 
Center on media, and Tile 
check boxes are Canvas print-
ing features that also appear in 
the Print dialog box; the set-
tings in both locations always 
match each other. You can 
configure these settings here 
to see the impact on page 
breaks on-screen without hav-
ing to print the document first. 
See “Arranging and scaling 
printed output” on page 35 for 
more information.

For more printer and page set-
up options, you can click the 
Options button (Mac) or Setup 
button (Windows). In the dia-
log that appears, the available 
options depend on the printer 
and printer driver.

Mac OS Page Setup dialog box

Windows Printer Setup dialog box
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Flip Horizontal Produces a mirror image of the on-screen docu-
ment, so the document appears reversed from left to right on the 
printed page.

Flip Vertical Produces a mirror image of the on-screen document, 
so the document appears reversed from top to bottom on the printed 
page.

Invert Image Prints the opposites of colors in the document, so the 
output looks like a photo negative. For example, black objects will 
print as white, and colors will print as their complements.

Substitute Fonts Uses fonts installed in the printer instead of the 
fonts installed on the computer, when the same fonts (or fonts with 
the same name) are available on both.

Precision Bitmap Alignment Improves bitmapped graphics by 
reducing the image by 96 percent.

Unlimited Downloadable Fonts Reserves more memory in the 
printer for downloading fonts during printing.

Larger Print Area This option lets some printers print closer to the 
edge of the paper. You might want to experiment to determine if this 
setting has any effect on your printer.

Printing documents on desktop printers
Before printing a document, you can set up options such as the num-
ber of copies, which pages to print, printing to a file, and printing in 
color. You can also see a preview of the printed document.

To print an entire document

1 Choose Print in the File menu.

2 In the Print dialog box, select All for “Pages to print.”

3 In the Copies text box, type the number of copies to print.

4 Make sure all settings are correct and click Print (Mac) or OK 
(Windows). Canvas sends the document to the printer.
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To print to a PostScript file

You can use a PostScript printer driver to print a document to a Post-
Script file. You might want to create a PostScript file so that you can 
print by sending the PostScript file to a printer, without using Canvas. 
Some prepress utilities also operate on PostScript printer files. 

Keep in mind that you can’t open or edit a PostScript printer file the 
same as you can a Canvas document. Also, you might need a utility 
program to send the file to a printer; check your system or printer 
documentation for information on downloading printer files.

1 Choose Print in the File menu.

2 In the Print dialog box, choose File in the Destination area 
(Mac) or check “Print to file” (Windows).

3 Review other options and make changes if necessary.

4 Choose a format for the file in the Images pop-up menu. 

• ASCII files are plain text files, which are the most compati-
ble but also the largest types of printer files. 

• Binary files are smaller than ASCII files, but might not be 
compatible with all printers and networks. 

• “Level 2 ASCII” files are compatible with PostScript Level 
2 devices and are somewhat smaller than regular ASCII 
PostScript files.

5 Click Save (Mac) or OK (Windows).

6 In the directory dialog box, select a location to store the file, 
type a file name, and click Save (Mac) or OK (Windows). Canvas 
generates and stores the PostScript file in the specified location.
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Printing selected parts of documents
In the Print dialog box, you can choose what part of the document 
you want to print. Choose these options in the Print pop-up menu.

Document Prints the entire document.

Selection Prints only the selected items in the document.

Print dialog box settings

The following are options you 
can set in the Print dialog box.

A Choose All to print all pa-
ges, or type the first and last 
page numbers you want to 
print in the From and To boxes. 

B Enter the number of copies.

C Choose what to print. The 
options depend on document 
type. For details, see “Printing 
selected parts of documents,” 
next.

D Choose Composite for 
desktop printing of color or 
black and white documents.

E For presentations only; 
choose slides (full size), thumb-
nails (small size), or handouts 
(multiple slides per page, 
scaled to fit).

F Select printing options; see 
the following pages for details 
on these options.

G Select color options; see 
“Options for color printing,” 
page 36, for details.

H Select Include Images if you 
aren’t using an OPI image 
server.

I Select the image data for-
mat.

J Click to see a full-page on-
screen preview before sending 

the document to your printer. 
The preview shows the effect of 
the current Print settings. 

B

A

Mac OS Print dialog box

C

J

G

H

I

D

A
Windows Print dialog box

B

C
D

F
G
H
I

J

F

E
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Layers Available for illustration and presentation documents only, 
choose Layers to print specific layers. Click the Layers button to 
select which layers to print. 

Page Range or Slide Range These options print any pages or 
slides. Click the Range button to specify which ones to print. 

Current, Even, or Odd These options print the corresponding 
pages and slides.

Arranging and scaling printed output
At the time you print a document, you can tell Canvas how you want 
the document to appear on the paper. For example, you can scale a 
large document and center it on standard-size paper for proofing pur-
poses. You can also tell Canvas whether to print colors, blank pages, 
and printer’s marks, and to sort pages in normal or reverse order.

The following options are check boxes in the Print dialog box. If a 
check appears in the box, the option is active. Some options apply to 
specific document types only; these are noted in the descriptions 
below.

Fit to paper Scales a document to fit in the page’s printable area. 
Canvas scales the document so that no objects fall into the margin 
(about 0.4 inch on each side) in which most printers can’t print.

Skip blank pages When you print a large document as tiles on 
paper that is smaller than the document size, several pages might not 
contain any objects. Turn on this option to skip the blank pages.

Print info Prints crop marks, registration marks, file name, and 
other document details. Canvas prints the marks and information 
beyond the area occupied by objects in the document.

Center on media Moves objects to the center of the printed media. 
This option is useful when you have selected objects that you want to 
print in the center of the page, even though they might not be cen-
tered in the document.

Back to front Prints from last page to first, keeping pages in the 
correct order if the printer stacks pages face-up in the output tray 
(publication and presentation documents only).

Collate copies Prints all pages of the document in order for the 
number of copies requested, rather than printing all copies of page 1, 
then all copies of page 2, and so on (publication and presentation 
documents only).
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Facing pages If the document is formatted for spreads, Canvas 
prints facing pages on one page (publication documents only).

Print trailing blank page Prints a final blank page after every doc-
ument (publication documents only).

Tile Tells Canvas to print large illustrations and documents in 
multi-page tiles. Because printers can’t print to the edges of the 
paper, you can type an overlap amount in the text box so you can 
assemble the pages. The Tile option must be turned on to print all of 
an illustration that is larger than a printer page. 

If your illustration document is larger than the paper in your printer, 
turn on the Tile option in the Page Setup or Printer Setup dialog box. 
If this option is off and you display page breaks (with the Display ➤ 
Show Page Breaks command in the Layout menu), Canvas will dis-
play only one page on screen.

Options for color printing

By selecting a setting from the Colors pop-up menu in the print dia-
log box, you can tell Canvas how to print colors in the document. 
You should select a setting that matches the printer’s capabilities; if 
you mismatch this setting to your printer (for example, choose 
CMYK when you have an RGB printer), the colors might not be 
accurately represented in the printed output.

Normal (RGB) Sends colors to your printer using RGB color speci-
fications. On a non-color printer, colors print as shades of gray, the 
same as if you select the “Colors as Grays” setting.

Black and White Prints colors as black or white. You might want 
to use this setting for desktop separation of solid spot colors.

Colors as Grays Prints colors in the document as shades of gray on 
all printers, including color printers. When printing to black-and-
white printers, this is the same as if you select the “Normal” setting. 

Calibrated (LAB) Matches printed colors to their appearance on-
screen. However, some colors displayed on a computer monitor can’t 
be reproduced on paper with printing inks. For example, colors that 
look bright and saturated on screen, such as hot pink, cyan, and bril-
liant orange, might appear more muted in printed materials.

CMYK Sends colors to your printer using CMYK color specifica-
tions. On a non-color printer, colors print as shades of gray, the same 
as if you select the “Colors as Grays” setting.

✔Tip
A Canvas illustration docu-
ment contains only one 
“page,” although the docu-
ment can be larger than the 
paper in your printer. To print 
the entire document, turn on 
the Tile option in the Print dia-
log box. Canvas will divide 
(“tile”) the document into a 
series of pages matching the 
paper size of your printer.
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Creating new doc
3

DOCUMENT SETUP

When you create new Canvas documents, you select from three doc-
ument types. You can then use document setup options to specify 
layout size, margins, orientation, and measurement units. 

This chapter explains how to create new documents and how to set 
up columns, rulers, drawing scales, guides, and alignment grids.

Creating new documents
When you want to create a new document, you use the New com-
mand and tell Canvas to create an illustration, publication, or presen-
tation document. 

When you start Canvas, it creates a new document. The very first 
time, Canvas creates a blank illustration document. From then on, 
Canvas starts with the document type you selected when you last 
used the New command. If you also selected a template, Canvas uses 
the same template for the new document it creates at startup.

If you start Canvas by double-clicking a document icon, Canvas 
opens the document without creating a new document. 

You can create new documents any time, even with other documents 
open. The number of documents you can have open at the same time 
depends on the amount of memory available on your system.

To create a new document

1 Choose New in the File menu. 

2 In the New dialog box, select an option under “Type of Docu-
ment.” For information, see “Choosing a document type,” next.

3 To use a template for the document, select the template in the 
Use Template pop-up menu. For information, see “Using document 
templates” on page 39.

4 Click OK. Canvas creates a new document with the name 
“Untitled” (Mac) or “New” (Windows) and a document number. If 
you selected a template, the document name is based on the name 
of the template.
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Choosing a document type
When you create a new document, you can tell Canvas to make an 
illustration, publication, or presentation document. Each type of doc-
ument offers unique features.

Illustration documents 

Illustration documents are general-purpose documents for all types of 
illustrations and graphics. You can specify a custom document size 
and use multiple layers in illustration documents. This document type 
is similar to earlier versions of Canvas documents.

When the active document is an illustration, you can use the Layer 
bar at the bottom of the window to easily select and switch layers. 

Publication documents 

Publication documents are designed for multiple-page publications. 
You can set up one-sided or two-sided pages with page numbers, and 
use master pages to hold items that you want to appear throughout 
the publication. 

When the active document is a publication, you can use page icons at 
the bottom of the window to move easily among the document’s 
pages.

Presentation documents 

Presentation documents are designed for on-screen “slide show” pre-
sentations. You can use multiple layers and a master slide to hold 
background elements. You can use more than a dozen transition 
effects, including wipe and dissolve, during slide show playback. 

When the active document is a presentation, you can use slide icons 
at the bottom of the window to easily move among the slides.

Template preview 
Choose a document type

Choose a template (optional)

Click to create document

D o l o r o l u m o u s
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Using document templates
Templates are special Canvas documents that you can use as the 
basis for new documents. When you select a template in the New dia-
log box, Canvas creates a new document containing the graphics and 
text in the template and uses the template’s settings for layers, slides, 
pages, rulers, grids, guides, views, and default object attributes.

How is a template different than a regular Canvas document? When 
you choose a template in the New dialog box, Canvas creates a new 
document based on the template, but doesn’t actually open the tem-
plate file. When you make changes to the new document and save it 
to disk, the changes don’t affect the template.

Canvas treats a template in a similar way when you open one by dou-
ble-clicking its icon or using the Open command. In either case, 
rather than open the actual template document, Canvas makes a new 
document based on the template’s document type and contents.

Templates, like regular Canvas documents, come in three types: 
illustration, presentation, and publication. In the new dialog box, the 
templates listed in the “Use Template” pop-up menu match the docu-
ment type selected in the “Type of Document” area.

Setting up documents 
After you create a document, you can use the Document Setup dialog 
box to set the document’s size, orientation, and other options. 

The Document Setup dialog box presents options based on the type 
of the current document. For example, in a presentation document, 
you can set the layout area to represent a particular screen size. In a 
publication document, you can set up page margins.

To set up an illustration or presentation

1 Choose Document Setup in the Layout menu. The Document 
Setup dialog box presents options for illustrations or presentations, 
depending on the current document type.

2 To change the measurement units used for the document, 
choose an option in the Document Units pop-up menu.

Document Setup dialog box for 
illustration and presentation 
documents
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3 In the Illustration size (in an illustration document) or Screen 
size (in a presentation document) pop-up menu, choose the dimen-
sions of the document or screen. To specify a custom size (or if you 
chose Printer Pages in the Document units pop-up menu), choose 
Custom and type the dimensions in the text boxes.

4 To change the orientation of the layout area, click the portrait 
or landscape option under Orientation.

5 Check to make sure all settings are correct and click OK.

To set up a publication

1 Choose Document Setup in the Layout menu. The Document 
Setup dialog box presents options for publications.

2 To change the measurement units used for the document, 
choose an option in the Document units pop-up menu.

3 Choose the size of the publication page in the Publication size 
pop-up menu. 

• To specify a special size, choose Custom and enter horizon-
tal and vertical measurements in the text boxes. 

• You can divide the specified page area into multiple sec-
tions if you choose a multi-page layout option in Step 6.

4 To change the orientation of the layout area, choose portrait or 
landscape in the Orientation area.

5 To set margin size for two-sided publications, enter the Inside, 
Outside, Top, and Bottom margins in the boxes in the Margins area. 
For single-side publications, enter the Right, Left, Top, and Bottom 
margins. The margin is measured from the edge of the paper. On-
screen, the margins appear as a dashed line around the border of the 
layout area. The printable area of the document appears as a solid 
line around the edge of the layout area. You should make sure the 
margins are not outside the printable area.

6 To specify multiple pages per sheet, choose an option other 
than Full Page in the Sheet Layout pop-up menu.

7 To create double-sided pages, turn on Facing Pages. When this 
option is on, the document has a left and a right master page that 
you can apply to its odd- and even-numbered pages.

8 Click OK to configure the publication.

✔Tip
For illustrations or presenta-
tions larger than the current 
paper size, you can use the 
Display➤Show/Hide Page 
Breaks command in the Layout 
menu to see or hide page divi-
sions. A line around the layout 
area indicates page bound-
aries.

Document Setup dialog box for 
publication documents

✔Tip
To see or hide the printable 
area, you can use the 
Display➤Show/Hide Printable 
Area command in the Layout 
menu. Canvas indicates the 
printable area by a line around 
the border of the page.
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Setting up rulers and the drawing scale
You can set up rulers for a document using various units of measure 
and display the rulers at the top and left of the document window. 
Rulers help you track the pointer’s movement and let you create 
alignment guides in the layout area.

When you set up rulers, you also set the document’s drawing scale. 
Canvas bases the rulers and all object measurements on the drawing 
scale. 

For example, if you set the drawing scale to 1 inch = 1 foot, and draw 
a line 1 inch long on screen, Canvas displays the line’s length as 1 
foot. Canvas uses scale measurements in the Object Specs palette, the 
information area of the Status bar, and in dimension objects.

You can use inches, pixels, centimeters, and picas as a document’s 
base unit of measurement. For the drawing scale, you can relate the 
base unit to inches, feet, miles, picas, pixels, metric units, and your 
own custom units.

To set up rulers and drawing scales

1 Choose Rulers in the Layout menu. 

2 In the Rulers dialog box, choose a ruler number in the Ruler 
pop-up menu. You can use the default rulers or customize them.

3 To change the measurement units, choose the units in the Units 
pop-up menu. Canvas sets up the ruler’s major divisions based on 
the units you choose.

4 Set the drawing scale using the two text boxes and the pop-up 
menu in the Scale area. The first value is the base unit measure-
ment, the second value is its scaled equivalent. In the third box, 
enter the units for the scaled measurement. You can type a custom 
unit here; Canvas will use the first two letters (“au” for astronomi-
cal units, for example) in dialog boxes and dimensions.

5 The following table shows examples of settings for various 
drawing scales.

For this scale Enter these values

1 inch = 6 inches 1 6 inches

5 inches = 1 mile 5 1 miles

10 cm = 1 meter 10 1 meters
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6 Choose a setting for the ruler’s minor divisions in the pop-up 
menu under the Scale boxes.

7 To establish the ruler’s major divisions, drag the double arrow 
between the two rulers. Drag to the unit of the top ruler that you 
want to be the major division. The major division also determines 
the major division of the alignment grid.

8 After you configure all ruler settings, click OK.

To display and hide rulers

When you want rulers to appear on screen, choose Display➤Show 
Rulers in the Layout menu. To hide the rulers, choose Display➤Hide 
Rulers in the Layout menu. The rulers must be displayed if you want 
to create alignment guides in the layout area.

To change the rulers’ zero points

The default zero point for each ruler is at the top-left corner of the 
illustration area. To change the zero point, drag from the intersection 
of the rulers. As you drag the zero point, intersecting lines follow the 
pointer. To return the rulers to the default zero point, click the box 
where the rulers intersect.

Setting up snap-to alignment
You can tell Canvas to make the pointer and any objects you drag 
“snap” into alignment with the grid, guides, or column guides in the 
layout area. 

◆ To snap to alignment guides and column guides: Choose 
Snap To➤Guides in the Layout menu. When the snap-to feature is 
active, objects you move seem to “stick” to the document’s guides.

◆ To snap to the alignment grid: Choose Snap To➤Grid in the 
Layout menu.

The procedures for setting up alignment guides, column guides, and 
the alignment grid are described in the following sections.

Using the alignment grid
You can display a grid of vertical and horizontal lines to aid in posi-
tioning objects in a document. You can also turn on the snap-to-grid 
feature to make Canvas snap objects into alignment with the grid 
when you drag near a grid line.
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When snap-to-grid is active, the pointer movements snap to the grid 
according to the settings in the Grids dialog box.

◆ To display grid lines on screen: Choose Display➤Show Grids 
in the Layout menu. To turn off grids, choose Display➤Hide Grids.

◆ To turn on snap-to-grid: Choose Snap To➤Grid in the Layout 
menu. Choose the command again to turn off snap-to-grid.

◆ To temporarily override the grid constraint: Press Tab as you 
create, resize, or move objects.

To set up the alignment grid

1 Choose Grids in the Layout menu. The Grids dialog box 
appears.

2 Enter a snap interval in the “Snap every: division” text box. 
The interval can be a fraction of the main ruler divisions. For exam-
ple, when rulers are set to one-inch increments, 1/2 creates grid 
lines every one-half inch.

3 Turn on “Snap To X” and “Snap To Y” to make objects snap to 
one or both sets of grid lines. 

Using column guides 
Column guides are lines that you can use to align columns of text in 
publication documents. You can tell Canvas to place guides evenly 
between the page margins for multiple columns. You can also cus-
tomize the guides to set up columns of various widths on your pages. 
The Column Guides command is available only when the current 
document is a publication document.

Column guides can make it easier to position columns of text. When 
column guides are displayed, you can click the Text tool in a column 
and Canvas creates a text object within the guides. 

To use preset column guides

1 Choose Column Guides in the Layout menu to open the Col-
umn Guides dialog box.

2 To use preset column guides, click one of the buttons at the top 
of the dialog box. The button symbols use greeked text to demon-
strate the number of columns and the relative width of each column.

3 Click OK to implement the specified column guides.
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To customize column guides

1 Choose Column Guides in the Layout menu to open the Col-
umn Guides dialog box.

2 Enter the number of columns in the “# of columns” box. 

3 To tell Canvas to calculate the width and gutter spacing for col-
umns of equal size, turn on the Equal width option.

4 To set the width and gutter spacing for each column, turn off 
Equal Width and choose the column number in the Column # pop-
up menu. Canvas numbers columns from left to right. 

5 Enter the column width in the Width box. Enter the width of 
the gutter (blank space to the right of the column) in the Gutter box.

6 To place vertical rules in each gutter, turn on Line Between.

7 To see the effect of the settings, click Apply. To make the set-
tings permanent, click OK.

◆ To show and hide column guides: Choose Display➤Show 
Guides or Display➤Hide Guides in the Layout menu.

◆ To adjust a column guide: Drag the column guide left or right 
in the document to reposition it and change the size of the gutter.

Using alignment guides
Alignment guides are horizontal and vertical lines you can place in a 
document to help align objects. These lines do not print. You can 
hide a document’s alignment guides without removing the guides. 
You can also simultaneously move a guide and objects that touch it. 

To set up alignment guides

1 To display the document rulers, if they are hidden, choose 
Display➤Show Rulers in the Layout menu.

2 Point to either ruler and drag a guide into the document area. 

3 To remove a guide, drag the guide back to its ruler.

◆ To show and hide guides: Choose Display➤Show Guides or 
Display➤Hide Guides in the Layout menu.

◆ To move objects touching a guide: Press Option (Mac) or Ctrl 
(Windows) as you drag a guide.
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Features of layers, pages, an
4

LAYERS, PAGES, AND SLIDES

Layers, pages, and slides are components of the three types of docu-
ment you can create in Canvas: 

• In illustration documents, you can use layers to arrange 
objects and organize separate levels of illustrations.

• In presentation documents, you can use slides and transition 
effects to create presentations.

• In publication documents, you can use master and body 
pages for single-sided and double-sided publications.

This chapter explains how to use layers, pages, and slides, including 
how to add, delete, arrange, lock, hide, display, and navigate among 
them. It also describes how to apply color overrides and lock items to 
prevent unwanted changes.

Features of layers, pages, and slides
This section describes how layers, pages, and slides apply to the three 
types of Canvas documents and the controls you can use when work-
ing with them. Later sections in this chapter provide details about 
configuring layers, pages, and slides, setting options, and designing 
slide shows.

Illustration layers

When you create an illustration document, the document has one 
layer. You can add as many layers as you want, limited only by avail-
able memory. 

Layers are like transparent overlays that divide the stack of objects in 
a document. Layers are clear — a layer itself blocks nothing behind 
it. Objects, however, are not transparent. On a single layer, an object 
blocks whatever is behind it in the stacking order. With multiple lay-
ers, an object blocks other objects on any layer that is farther back in 
the stack of layers.

Layers can help you work more efficiently because you can perform 
operations on layers. You can hide, print, and save layers individu-
ally. You can use layers to hold different colors to produce simple 
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spot-color separations, or to keep text objects separate so you can 
hide artwork when you edit the text. 

When you work in an illustration document, the following com-
mands and options are available:

• Commands for displaying and switching layers appear in 
the Layers submenu in the Layout menu.

• The Layer Info palette lets you arrange layers and change 
layer settings.

• The Layer bar at the bottom of the document window lets 
you switch layers and open the Layer Info palette.

Presentation slides and layers

When you create a presentation document, the document has one 
master slide and one main slide. You can add as many additional 
main slides as you like, limited only by available memory. 

You arrange slides and set up optional transition effects to create a 
slide show presentation. Slide shows can be self-running or operator-
controlled. You can use the master slide to hold common elements 
that you want to appear in the background on most slides.

Each main slide can have multiple layers. During slide show play-
back, all visible layers can appear as one slide. Or, if you select the 
Progressive Build option in the Slide Show dialog box, each layer’s 
contents can be added to the base image in sequence.

When you work in a presentation document, the following com-
mands and options are available:

• Commands for displaying and switching slides and layers 
appear in the Slides submenu in the Layout menu.

• The Slide Info palette lets you arrange slides and layers and 
change their settings.

• You can use the slide icons and arrow buttons below the 
document window to navigate among the master and main 
slides. The icon representing the current slide is highlighted.

Publication pages

When you create a publication document, the document contains at 
least one body page and one master page, or two master pages (left 
and right) if you select Facing Pages in the Document Setup dialog 
box. Publication documents do not contain layers.
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When you work in a publication document, the following commands 
and options are available:

• Commands for inserting, removing, and navigating among 
pages appear in the Pages submenu in the Layout menu.

• The Page Info palette lets you arrange pages and change 
their settings.

• You can use the page icons and the arrows at the bottom of 
the document window to navigate among the master and 
main pages. The icon representing the current page number 
is highlighted.

Setting up layers, pages, and slides
You can use floating palettes to set up and work with layers, pages, 
and slides. The available palette depends on the type of document 
you are using. The Layer Info palette is available in illustration docu-
ments, the Slide Info palette is available in presentation documents, 
and the Page Info palette is available in publication documents.

The Layer Info, Slide Info, and Page Info palettes list a document’s 
layers, pages, or slides. You can also add, delete, arrange, rename, 
and change options for these components in the appropriate palette.

To open the Layer Info, Page Info, and Slide Info palettes

Choose the appropriate command in the Layout menu to open the 
Layer Info, Page Info, or Slide Info palette:

• In illustration documents, choose Layers ➤Layer Info to 
open the palette.

• In publication documents, choose Pages➤Page Info to open 
the palette.

• In presentation documents, choose Slides➤Slide Info to 
open the palette.

In illustration documents, you can open the Layer Info palette from 
the Layer bar. Press the bar at the bottom of the document window 
and drag the palette away from the bar. 

◆ To change the order of layers, pages, or slides: Drag an item 
to a new position in the list in the info palette. Canvas does not 
rename items when you change their order in the list.

Layer Info, Page Info, and Slide 
Info palettes
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◆ To rename layers, pages, or slides: Highlight its name in the 
info palette list. The name appears in the text box at the bottom of the 
palette. Type a new name in the text box.

To create new layers, pages, or slides

To create a new layer, page, or slide, click New in the info palette. A 
new item appears in the list. Canvas names the new item with the 
next number in the sequence, for example, “Page #2.”

You can also create new pages or slides by using a menu command. 
Depending on the document type, choose Pages➤Insert Page or 
Slides➤Insert Slides in the Layout menu. In the dialog box, type the 
number of items you want to insert. Also, specify where you want 
Canvas to insert the new items, and then click OK. Canvas adds 
blank pages or slides to the sequence.

To add layers to a slide

When you click New in the Slide Info dialog box, Canvas adds a new 
slide to the presentation document. To add additional layers to a 
slide, use the Slide Options dialog box.

1 Select a slide name in the Slide Info palette and click Options, 
or double-click a slide name.

2 In the Layers box of the Slide Options dialog box, type the 
number of layers for the slide. A slide must have at least one layer. 
Click OK.

The names of slide layers appear indented under the name of the slide 
in the Slide Info palette. A triangle symbol next to a slide name indi-
cates that the slide has multiple layers. Click the triangle to expand 
and contract the list when you want to show or hide layer names.

To remove layers, pages, or slides

To remove an item, highlight the name of the item in the info palette 
and click Delete.

You can also remove pages or slides using a menu command. 
Depending on the current document type, choose Pages➤Delete 
Pages or Slides➤Delete Slides in the Layout menu. In the dialog box 
that appears, specify the range of items to delete. The range can’t 
include all slides or pages, because the document must contain at 
least one slide or page. Click OK to remove the items and their con-
tents from the document. 

Expands or contracts list
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Layer, page, and slide options
You can set options for layers, pages, and slides using the Layer Info, 
Page Info, and Slide Info palettes. For all document types, you can 
specify whether a component is printable or locked. Other options 
apply to specific document types.

The following table, “How options apply to layers, pages, and 
slides,” describes the available options, and which options can be 
applied to layers, pages, and slides. Most of these options can be acti-
vated or deactivated in the Layer Info, Page Info, and Slide Info pal-
ettes. Options can be configured in the Layer Options, Page Options, 
or Slide Options dialog box. Click the Options button in the info pal-
ette to open the dialog box.

How options apply to layers, pages, and slides

Note: 1 You can use Grayed and Color Override options with illustra-
tion document layers, but not with layers in presentation documents.

Option Description Use with

Visible Must be on for a layer to appear on screen and in output Layers

Grayed Temporarily dims a layer on screen and makes it non-printing Layers1

Locked Prevents changes to any objects or properties. You can still 
select, copy, and see information about objects on a locked 
layer

Layers, Pages, Slides

Password Prevents changing the lock option unless password is entered Layers, Pages, Slides

Printable Printable components are included in output when you print an 
entire document or a range of layers, pages, or slides

Layers, Pages, Slides

Color override Temporarily applies a color you specify to all objects on a layer; 
original color information does not change

Layers1

Show master page Applied to a body page, makes all items on the document’s 
master page appear on the body page

Pages

Master slide visible Applied to a main slide, makes all items on the document’s 
master slide appear on the main slide

Slides

Transition to next slide Applies effects, including dissolves, fades, wipes, and others, 
when changing from one slide to the next during a slide show

Slides
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Using the option dialog boxes

To change an option for a layer, page, or slide, select the item in the 
list and click the Options button on the info palette to open a dialog 
box. You must use the options dialog box to configure the grayed, 
password, color override, and transition options.

Setting options in the Info palettes

By default, the Layer Info, 
Page Info, and Slide Info pal-
ettes show option settings for 
the items in the table “How 
options apply to layers, pag-
es, and slides,” above. If you 
want to hide the option col-
umns to view long layer, 
page, and slide names, 
uncheck the Show Options 
box.

Bullet symbols (•) indicate 
active options for each item in 
the list. 

To turn an option on or off, 
click in the appropriate col-
umn to add or remove the 
bullet. 

A Click here to show or hide 
option columns.

B Visible or Master slide 
visible. For a layer in the Layer 
Info or Slide Info palettes, turn 
on this option to make the lay-
er visible. For a slide, turn on 
this option to make the master 
slide visible in the main slide.

C Locked. Turn on this op-
tion to protect an item from un-
wanted changes. A pencil icon 
indicates that the item is 
locked. A padlock icon indi-
cates the item is also pass-
word-protected in the Options 
dialog box.

D Printable. Click this col-
umn to print the item.

E Color override. Click this 
column to temporarily apply a 
color to all objects on a layer.

F Show master page. Click 
this column to make all items 
on the master page appear on 
the body page.

G Transition to next slide. 
Click here to add or remove a 
slide transition.

A

C D E F GB
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You can use this method to set options for more than one item at 
once. To select multiple items, Command-click (Mac) or Ctrl-click 
(Windows) each item and then click the Options button on the info 
palette. 

Details about the master page, master slide, color override, and slide 
transition options are in the next sections. For information about 
making layers visible or hidden, see “Showing and hiding layers” on 
page 53.

Using master pages and slides
Master pages and master slides can hold common elements that you 
want to appear on most pages or slides in your document. You can 
use one or two master pages in a publication document, depending on 
whether the document is single- or double-sided. In a presentation 
document, you can use one master slide.

Master pages

A publication document can have one or two master pages. To use 
two (left and right) master pages, you must first activate the Facing 
Pages option in the Document Setup dialog box. Objects on a master 
page appear on the corresponding body pages that use the master 
page.

In the Page Info palette, the left option column shows the master page 
setting. A bullet symbol in the column indicates that the associated 
master page contents will appear on the body page.

Master slides

In presentation documents, objects on the master slide appear on 
slides that use the master slide. 

You can click the “Master slide visible” column in the Slide Info pal-
ette to turn this option on. You can also use the Slide Options dialog 
box to set the master slide option. 

◆ To apply the master slide to a main slide in the Slide Options 
dialog box: Select the slide name in the Slide Info palette and click 
Options. In the Slide Options dialog box, turn on “Master slide visi-
ble.” To remove master slide objects from a slide, turn off this option.

Applying color overrides to layers
You can apply a color override to a layer in an illustration document 
to temporarily assign a color you specify to all objects on that layer. 
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When you remove a color override, all objects on the layer revert to 
their original colors. 

Note: You cannot use color override for layers in a presentation doc-
ument.

1 Open the Layer Info palette by choosing Layers➤Layer Info in 
the Layout menu.

2 Select one or more layer names in the Layer Info palette and 
click Options.

3 In the Layer Options dialog box, turn on Color Override. A 
color button appears.

4 Press the color button and choose a color in the color tab. 

5 Click OK in the Layer Options dialog box.

To remove a color override

Once you have specified a color override for a layer, you can remove 
the override and reapply it without having to reselect the color.

1 Open the Layer Info palette by choosing Layers➤Layer Info in 
the Layout menu.

2 In the color override column (far right), click the bullet symbol 
on the row of the layer for which you want to remove the color 
override.

Specifying transitions for slides
Use the Slide Info palette and Slide Options dialog box to apply tran-
sition effects for on-screen slide shows.

When Show Options is on in the Slide Info palette, the transition 
option setting for each slide appears in the right column. A bullet in 
this column indicates that Canvas will use a transition when changing 
from the current slide to the next one. You can click the column to 
turn the transition effect off or on.

After you set up the slides and transitions in a presentation document, 
you can play the slide show using the Slide Show command in the 
Layout menu; see “Presenting slide shows” on page 55.

To select slide transitions

You can select from more than a dozen transition effects for slide 
shows. 
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1 Choose Slides➤Slide Info in the Layout menu to open the 
Slide Info palette, if necessary.

2 Click the name of a slide in the slide list and click the Options 
button. You can also double-click the name of the slide. The Slide 
Options dialog box opens.

3 Check the “Transition to next slide” option and select a transi-
tion in the Transition pop-up menu.

4 You can click the Try button to preview the effect of the transi-
tion setting.

5 If the transition offers additional options, you can click the 
Options button in the Slide Options dialog box.

Showing and hiding layers 
You can make any layer in an illustration or presentation document 
visible or hidden. A visible layer appears on screen and in output. 
Layers that aren’t visible don’t appear on screen and Canvas skips 
them when you print the document.

To make selected layers visible or hidden

1 Depending on the type of document, choose Layers➤Layer 
Info or Slides➤Slide Info in the Layout menu to open the appropri-
ate info palette, if necessary. 

2 With Show Options on, click in the column under the eye sym-
bol to change the visible setting for a layer in the scrolling list. A 
bullet symbol in the column indicates that the item is visible. In pre-
sentation documents, make sure you click in the column next to a 
layer name; if you click in the column next to a slide, it changes the 
master slide setting, not the layer visibility.

When you select a hidden layer in the info palette, Canvas makes the 
layer visible again.

In illustration documents, when you use the Layer bar to choose a 
hidden layer, Canvas makes it visible.

Using the options dialog box to show or hide layers

You can change the visible setting for multiple layers using the Layer 
Options dialog box. However, you can’t turn off the visible setting 
for the current item in the Layer Options dialog box.

✔ Important
You can’t turn off “visible” for 
the current layer (if you click in 
the “visible” column in the pal-
ette, nothing happens). To 
change the setting for the cur-
rent layer, click another item to 
select it, then change the set-
ting for the item you want.
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1 Select multiple layers in the Layer Info or Slide Info palette by 
pressing Command (Mac) or Ctrl (Windows) and clicking layer 
names. You can select the current layer, but it won’t be hidden if 
you turn the visible setting off.

2 Click Options, and then turn off the Visible option in the Layer 
Options dialog box. Click OK.

To show or hide all layers in an illustration document

You can use commands to make all layers visible, or to make all lay-
ers (except the current one) not visible.

◆ To show or hide all layers: Choose Layers➤Show Other Lay-
ers in the Layout menu to display layers. Choose Layers➤Hide Other 
Layers in the Layout menu to hide all layers except the current one.

Navigating among layers, pages, and slides
In presentation and publication documents, a highlighted icon at the 
bottom of the document window indicates the current slide or page 
(or facing pages). In illustration documents, the name of the current 
layer appears in the Layer bar.

To change from one layer, page, or slide to another, you can use Lay-
out menu commands, icons in the document window, and the Layer 
Info, Page Info, and Slide Info palettes

To navigate using the page and slide icons

To select the page or slide you want to go to, click the page or slide 
icon at the bottom of the document window. If the icon for the page 
or slide you want isn’t visible, click the arrow at the left or right of 
the icons to move through the pages or slides. To go to the docu-
ment’s master page or slide, click the “M” icon.

To navigate using the info palettes

You can switch to other layers, pages, or slides using the Layer Info, 
Page Info, or Slide Info palettes. With the palette open, click the 
name of the item you want to go to.

Document slide icons
Master slide icon

Click arrows to scroll through slides
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To use the navigation commands

Navigation commands let you move to the next and previous layers 
and slides, or go to a specific layer, page, or slide. When you use a 
command to go to a hidden layer or slide, it becomes visible. 

You can navigate by choosing the appropriate command, based on 
document type, in the Layout menu:

◆ To change illustration layers: Choose Layers➤Next Layer, or 
Layers➤Previous Layer to change layers. To go to a specific layer, 
choose Layers➤Name of layer.

◆ To go to a specific page: Choose Pages➤Go To Page. Type 
the page number in the dialog box and click OK.

◆ To change presentation slides: Choose Slides➤Next Slide, or 
Slides➤Previous Slide. 

◆ To go to a specific slide: Choose Slides➤Go To Slide, type a 
number in the dialog box, and click OK. 

◆ To change presentation layers: Choose Slides➤Next Layer, or 
Slides➤Previous Layer.

To navigate using the Layer bar

In illustration documents, you can use the Layer bar at the right of the 
Zoom bar. The current layer name appears in the bar.

To switch to the next visible layer or slide, click the up-arrow at the 
right of the bar. To switch to the previous visible layer or slide, click 
the down-arrow at the left of the bar. You can also press Option 
(Mac) or Ctrl (Windows) as you click the up- and down-arrows to 
move to the next layer (whether it’s visible or not) and simulta-
neously hide the layer you just left.

In addition, you can open the Layer Info palette from the bar. Press 
the bar and drag the palette away from the bar.

Presenting slide shows
You can display a presentation document as an on-screen slide show. 
Canvas can show slides using a time interval that you specify, or you 
can control the pace by changing slides manually.

You set up a presentation by first creating a presentation document 
using the New command in the File menu, then adding additional 
slides (and layers, if desired) using the Slide Info palette, as described 
in this chapter. You can also use the Slide Info palette to specify tran-
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sitions between slides. For more information, see “Specifying transi-
tions for slides” on page 52.

You can use the presentation document’s master slide for back-
ground objects and text. Use the Slide Info palette to apply the master 
slide to slides and to set the printable, locked, and password options 
for slides; see “Layer, page, and slide options” on page 49.

To configure a slide show

1 In a presentation document, choose Slide Show in the Layout 
menu. The Slide Show palette opens.

2 To play the slide show at the largest size possible on the cur-
rent display device, turn on Fit To Screen.

3 To make the slide show start over after displaying the last 
slide, turn on the Loop option. Otherwise the slide show stops after 
the last slide.

4 To show a pointer on-screen during playback, turn Show 
Pointer on and select a pointer in the adjacent pop-up menu.

5 If you want Canvas to sequentially add the contents of visible 
layers to main slides, turn on Progressive Build. If Progressive 
Build is off, all visible layers appear at the same time on the main 
slide.

6 If a slide includes QuickTime movies, turn on “Auto-play 
QuickTime movies” to play the movie when the slide appears.

7 To make a slide show self-running, turn on “Advance Every x 
seconds,” and type the number of seconds to display each slide.

To play a slide show

1 Choose Slide Show in the Layout menu.

2 To start a slide show, click Play. If “Advance Every x Sec-
onds” is on, Canvas displays the slides, using the specified timing. 
If the Loop option is also on, the slide show will repeat.

If the slide show is not self-running, click to advance one slide. Ctrl-
click to go back one slide.

3 To stop the slide show, press Esc (Mac) or right-click 
(Windows).
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Methods for sharing info
5

FILE AND DATA EXCHANGE

Canvas supports all standard formats for exchanging files and data 
with other programs. This chapter explains how to use non-Canvas 
file formats, and how to share data using Publish and Subscribe (in 
Mac OS), and Object Linking and Embedding (in Windows).

Methods for sharing information
You have several options for sending graphics created in Canvas to 
other programs, and for using illustrations and text from other pro-
grams in Canvas. To exchange information, you can 

• use a file format both applications support to exchange files 

• copy and paste selected objects using the Clipboard 

• create dynamic links to share objects between documents 

Exchanging files

The Open, Place, and Save As commands let you work with many 
standard and proprietary file formats. With a common file format, 
you can bring a file generated in another program into a Canvas doc-
ument, or transfer a Canvas document into another program. 

Deneba Software often updates the file formats that Canvas supports, 
so you can work with the latest versions of the most widely-used for-
mats. For the latest information, be sure to refer to the Canvas on-line 
Help system. To view the contents page for the Help system, choose 
Contents in the Help menu. On the Contents page, click the Release 
Notes topic for information about file format changes. You can also 
search for keywords, such as the name of a file format, to find the lat-
est information in the Help system.

When you want to exchange files with another program, you should 
also refer to Read Me files and release notes from that program.

For general information on file formats and procedures for opening 
and saving files, see “Using non-Canvas file formats” on page 58.
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Sharing information

Often, rather than just move a graphic, you want to share it among 
several documents, or create a link between the original and copies 
placed in other Canvas documents. For these types of data exchange, 
you can use Publish and Subscribe (in Mac OS) and Object Linking 
and Embedding (in Windows).

Publish and Subscribe lets you share information among Canvas doc-
uments and between Canvas and other applications. For details, see 
“Sharing information through Publish and Subscribe” on page 81.

Object Linking and Embedding (OLE) lets you create documents 
containing objects from various sources. You can link objects to the 
programs that created them and to the source objects themselves. For 
details, see “Using Object Linking and Embedding” on page 78.

Using non-Canvas file formats
Because the native Canvas 5 format saves all the objects, properties, 
and effects that Canvas documents can contain, you should save all 
your documents in Canvas 5 format. Still, you might want to export a 
document in a different format, or import graphics into a Canvas doc-
ument from a non-Canvas file.

When you use a non-Canvas file, you can avoid problems, such as 
lost information and printing errors, if you know the capabilities and 
limitations of the file format. For example, some formats support 
only one type of data (vector, raster, or text), while others support 
multiple types.

Exporting to raster file formats
You can export a Canvas document to several raster image formats, 
including Windows Bitmap (BMP), Graphics Interchange Format 
(GIF), and Tag Image File Format (TIFF). 

When saving a document in a raster file format, Canvas renders the 
Canvas document into one raster image in the file. The effect is the 
same as selecting all the objects in the documents and using the 
Area➤Render command in the Image menu; Canvas uses the same 
process and lets you use the same dialog box options.
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Rendering images when saving files
When you save a Canvas document in a file format  that stores 
images (not vector objects or text), Canvas renders the document—
converts the contents to a raster image—before saving the file. 

To set rendering options

The Render Image dialog box lets you set options for converting a 
document to a raster image. This dialog box appears after you click 
Save in the Save As dialog box.

1 In the Render Image dialog box, choose an image mode from 
the Mode pop-up menu. Not all file formats support all types of 
image modes. If you select an image mode that isn’t supported by 
the chosen file format, Canvas displays a message to tell you what 
image mode will be used.

2 To set the image dimensions, enter Width and Height values 
(in pixels). Changing the image dimensions also affects the resolu-
tion setting— enlarging the image results in larger pixels and lower 
resolution. 

Note: The Size shown in the Render Image dialog box is an estimate 
of the amount of data in the image, based on the color depth and res-
olution. The actual file size can vary, depending on compression and 
other factors.

3 Type the resolution in the “Res” text box. Choose pixels per 
inch (pixels/in) or pixels per centimeter (pixels/cm) from the adja-
cent pop-up menu.
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4 To soften the edges of objects in the image, turn on Anti-Alias. 

5 To make the objects a masked channel selection, turn on 
Create Mask; see “Using a channel mask to make areas transpar-
ent” on page 365 for more information. This option is not available 
for all file formats.

6 After you configure the settings, click OK. Canvas converts the 
document contents to a raster image and saves the image file.

Loading external tool file filters

Canvas uses file filters to translate files to or from its native format. 
Many file filters are external tool modules. The file formats they pro-
vide appear in the format menus in the Open and Save As dialog 
boxes. If a supported format does not appear, check that Canvas has 
loaded the necessary external tool. For more information, see “Load-
ing external tools” on page 93.

XTND file filters

In Mac OS, Canvas takes advantage of the Claris XTND System to 
provide additional file filters. 

When it is installed, the XTND extension lets programs use standard 
XTND Translators. Canvas supports XTND Translators for word 
processing and Startup Screen file formats. In Canvas, the file for-
mats provided by XTND Translators appear at the bottom of the file 
format pop-up menu (separated by a line) in the Open and Save As 
dialog boxes.

QuickTime file previews (Mac only)

Some files include a QuickTime preview image that compatible 
image browsers and page-layout programs can display. If you have 
QuickTime installed on your system, Canvas can store and display 
preview images with its native files and several other file formats. 
See the individual file format listings in this chapter and the on-line 
Help system for more information on preview images.

Claris XTND System

XTND Translator
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Opening, placing, and saving non-Canvas files
You can use the Open, Place, and Save As commands to work with 
non-Canvas files. You choose the format you want to use in the for-
mat pop-up menus in the Open and Save dialog boxes. 

Opening non-Canvas files When you use the Open command, 
Canvas imports the file into a new illustration document. 

Placing non-Canvas files When you use the Place command, Can-
vas imports the file into the current document.

Saving non-Canvas files When you save a Canvas document in a 
non-Canvas format, Canvas creates a new file on disk, but does not 
close the Canvas document or change the name of the document in 
the title bar. If you then try to close the Canvas document (without 
saving it in Canvas 5 format), a message warns you and asks you to 
confirm that you want to close the document without saving it.

When saving in certain non-Canvas formats, Canvas displays a dia-
log box with options. For details on these options, refer to on-line 
Help.

To open or place a file

1 Choose Open or Place in the File menu.

• Open creates a new Canvas document containing the file 
you select.

• Place inserts the file in the current Canvas document. Place 
is available only if a Canvas document is open.

2 Choose a file type in the File Format (Mac) or Files of type 
(Windows) pop-up menu. The file list shows files that match the 
selected format. Select “All Files” (Windows) or turn on “Show All 
Files” (Mac) to show every file in the folder (even if Canvas can’t 
open it). In Mac OS, you can also choose All in the File Format 
pop-up menu to show all files that Canvas can open.

3 In the file list, locate and select a file and click Open or Place. 
You can also double-click a file name. For some file formats, Can-
vas opens a dialog box and offers options for opening the file. If 
necessary, configure the options, then click Open or Place.

• If you open the file, Canvas creates a new document.

• If you are placing the file, a Place pointer appears. Click 
where you want to place the top-left corner of the file.
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To save a document in a non-Canvas file format

You can use the Save As command to export an entire document or 
selected objects to a non-Canvas format. Keep in mind that some 
Canvas objects might not be supported by other formats.

Selecting file formats

In the Open dialog box, the 
file list shows all files in the 
current folder that match 
the selected file format.

A Choose a file type in the 
pop-up menu.

B Type a file name or 
select a file in the file list.

A

B

Choose file format

Type file name

Choose what to save
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1 Depending on what you want to save, do one of the following:

• To save specific objects, select the objects.

• To save specific layers of a multi-layer document, make 
sure all the layers you want to save are visible.

2 Choose Save As in the File menu. 

3 In the Save As dialog box, select a format in the “File Format” 
(Mac) or “Save as type” (Windows) pop-up menu. If the format you 
want to select is not available, check that the format is compatible 
with the selected objects in the document.

4 Select an available option at the bottom of the dialog box to 
choose what to save.

5 Turn on Create Preview (Mac) or Save Preview (Windows) to 
make a preview available to applications that support them. Turn on 
Use Compression to compress the saved file. Turn on Use Exten-
sion (Mac only) to include the three-character, Windows extension 
in the file name.

6 Type a name for the file, select a location, and click Save. 

7 When you select a non-Canvas format, a warning asks you to 
confirm that you want to save the file in a non-Canvas format. Click 
Save to continue.

If the file format has options for saving, a dialog box appears; config-
ure the available options and click OK. For example, when you save 
a Canvas document in a file format that support raster data only, the 
Render Image dialog box opens. See “Rendering images when sav-
ing files” on page 59 for information on these rendering options.

✔Tip
Always save your work as a 
Canvas 5 document. Some 
objects and attributes won’t 
translate to other formats, so 
you might not be able to edit 
an exported file.

File conversion warning
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Acquiring and exporting images 
You can use the Acquire and Export commands in the Image menu to 
work with non-Canvas raster image file formats. These commands 
are especially useful because you can add new file formats by install-
ing Photoshop-compatible plug-in modules.

Exporting images

When you use the Export command, you create a file on disk from a 
selected object in a Canvas document. The Export command works 
like the Save As command, except that you must select a paint object 
before you choose the Export command. The Export command 
appears in the Image menu only if you have export plug-in modules 
installed.

1 Select the paint object you want to export. Be sure the paint 
object is not in edit mode. (A selected image has square handles, 
while an image in edit mode has crop marks at the corners.)

2 Choose Export➤Image format in the Image menu, where Image 
Format is one of the raster image formats in the Export submenu.

3 In the Save dialog box, type a file name, select a location for 
the export file, and Click Save.

Acquiring images

When you use the Acquire command, you insert an image from a file 
on disk into the active Canvas document. You can also acquire 
images from scanning devices using acquire plug-in modules.

1 In the Canvas document in which you want to insert the image, 
choose an Acquire submenu command:

• To acquire an image from a file, choose Acquire➤Image 
format in the Image menu, where Image format is an image 
format in the Acquire submenu. 

• To use a TWAIN scanning device, choose 
Acquire➤TWAIN Acquire in the Image menu.

2 In the Open dialog box, type the name of the file you want to 
acquire, or select its name in the file list and click Open. Canvas 
inserts the image into the document.

Note: If you are using an acquire module to acquire images from a 
scanner, the scanning dialog box appears. Refer to the acquire mod-
ule’s documentation for information on options and settings.
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Summary of file formats

Ext: Canvas extension. Color bits: Number of bits of color information: 1=2 colors, 4=16 colors, 8=256 
colors, 16=65,536 colors, 24=16.7 million colors. O: Open and Place. S: Save.

Name Ext Description Color bits O S

Adobe Illustrator AI Editable PostScript format supports vector objects, 
raster images, and formatted text

24 ✓

Adobe Portable Docu-
ment Format

PDF Portable Document Format files can be exchanged 
across platforms and viewed with Acrobat Reader 
software

Varies ✓ ✓

Amiga IFF IFF Raster image format 24 ✓ ✓

CALS CAL Black and white image format with Fax Group IV 
compression

1 ✓ ✓

Canvas 3.5 CVS Native format of Canvas 3.5 on Mac OS and Win-
dows platforms

24 ✓ ✓

Computer Graphics 
Metafile

CGM ANSI format for RGB color illustrations supports 
vector and raster graphics, layers, and formatted 
text

24 ✓ ✓

Drawing Exchange File 
Format

DCX Supports multiple PCX images in one file 24 ✓ ✓

Drawing Interchange 
Format

DXF Metafile format that supports plain text, 2-D and 
3-D geometric data

8 ✓ ✓

Encapsulated PostScript EPS Editable PostScript format for printing graphics in 
other applications; can include preview in TIFF, 
PICT, or WMF format

24 ✓ ✓

Enhanced Metafile EMF Windows (32-bit) format supports vector objects, 
images and text 

24 ✓ ✓

GEM Image IMG Raster image format from GEM operating system 4 (color)

8 (gray)

✓

Graphics Interchange 
Format

GIF Widely used format with compression for grayscale 
and 256-color images for Internet and online use; 
version 89a supports transparency

8 ✓ ✓

Halo CUT CUT Used by some MS-DOS-based paint programs 8 ✓

Hewlett-Packard Graph-
ics Language

PLT Vector format for plotter printing files 8 ✓

Initial Graphics 
Exchange Specification

IGS 2-D and 3-D vector graphics format used in CAD 
and rendering applications

8 ✓ ✓
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Icon ICO Windows format for bitmap icon images 8 ✓ ✓

IOCA ICA Supports CCITT G3, CCITT G4 and MMMR formats 1 ✓

Joint Photographic 
Experts Group

JPG Raster image format with variable compression; 
allows significant file size reduction at the expense 
of some image data

24 ✓ ✓

Kodak Photo CD PCD Raster image stores photos at several resolutions in 
RGB and YCC color systems

24 ✓

MacDraw Pro n/a Mac OS format for vector and text 24 ✓

MacPaint MAC Mac OS-only raster image format supports black 
and white images to 720x 576 pixels

1 ✓

Micrografx Draw DRW Proprietary format supports vector objects and text 8 ✓

QuickTime Movie MOV Sound and animation file format 24 ✓ ✓

PICT and PICT 2 PCT Mac OS QuickDraw graphics format, supports vec-
tor objects, 72 PPI images, and text. Original PICT 
supported 1-bit color and files up to 32 Kb.

24 (PICT 2)

1 (PICT)

✓ ✓

PCX - PC Paintbrush PCX Raster image format 24 ✓ ✓

Photoshop PSD Proprietary format for raster images; Canvas flattens 
layers when opening files

24 ✓ ✓

Rich Text Format RTF Text-only format in which type formatting and lay-
out information can be encoded

n/a ✓

Sound SND Mac OS audio file format used for system sounds n/a ✓ ✓

Tag Image File Format TIF Raster image format supports high resolution RGB 
and CMYK color images; proprietary tags from 
some programs can cause problems or be ignored 
when opening files

24 ✓ ✓

Text File TXT Plain text format that uses ASCII encoding, does 
not support type formatting

n/a ✓

Targa TGA Raster image format used in video and image-pro-
cessing applications

24 ✓ ✓

Windows Bitmap BMP Common raster image format for Windows; sup-
ports compression

24 ✓ ✓

Windows Metafile WMF Common metafile format for Windows applications; 
offers compression for 4- and 8-bit images

8 ✓ ✓

WordPerfect Graphics WPG Proprietary format for clip art; Canvas supports ras-
ter images in WPG files

8 ✓ ✓

Name Ext Description Color bits O S
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Additional information on file formats
This section provides background information on some of the stan-
dard graphics and text file formats supported by Canvas. For more 
information, see the Canvas On-line Help system and Release Notes.

Translating data between formats

If a file contains data for proprietary or unsupported features, the pro-
gram opening the file must convert the data to something it under-
stands, or simply omit the unfamiliar information. If you use a non-
Canvas file format to bring data into Canvas, many, but not all, 
objects, text, and images can be converted into Canvas equivalents. 
The same is true if you save a Canvas document in another format.

Adobe Illustrator

The native format of Adobe Illustrator, these files store vector objects 
and text as PostScript commands in a proprietary format. Objects and 
text remain editable when you import them into Canvas.

Canvas 3.5

The native format of the previous version of Canvas, these files are 
generally compatible with Canvas 5; most vector, text, and paint 
objects should successfully import. However, when saving Canvas 5 
files in Canvas 3.5 format, some of the new features and objects 
might not convert, or they might lose their special editing properties.

Computer Graphics Metafile

Computer Graphics Metafile (CGM) format is a standard for 
exchanging 2-D graphics and text. Variations and extensions to the 
“standard” format can create incompatibilities with the Canvas file 
filter. When you save a Canvas document in CGM format, Canvas 
makes the following image color mode conversions:

Canvas alerts you the first time each of the above conversions occurs.

Canvas image mode CGM image mode

CMYK, Duotone, Grayscale, and 
LAB color 

RGB cell arrays

Black & White CGM versions 1 and 2: RGB cell arrays

CGM version 3: Black & White

Multichannel First channel becomes an RGB cell array, 
other channels ignored
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Drawing Interchange Format

Drawing Interchange Format (DXF) is a format developed by 
Autodesk, Inc., for exchanging data with AutoCAD and other draw-
ing applications. DXF format provides platform-independent storage 
of 2- and 3-D technical drawings, and it supports multiple layers. 
Canvas supports DXF files containing ASCII data, but doesn’t sup-
port binary data files. 

When you save a document in DXF format, Canvas converts the fol-
lowing Canvas objects and attributes to DXF objects and attributes:

In addition, Canvas lets you set the following export options in this 
dialog box:

Canvas objects / attributes DXF objects / attributes

Paint object Not converted

Pen and fill patterns Solid pens and fills

Arcs Polylines

Calligraphic pen strokes Fixed-width pen strokes

Continuous dashes Dashes start in each segment

Layer names with spaces or non-
uppercase characters

Spaces removed and characters 
become uppercase

Grayed layers Objects appear in original colors

Choose a platform

Tell Canvas how to 
export these objects
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When opening a DXF file, Canvas makes the following conversions 
from DXF objects to Canvas objects: 

In addition, you can set the following scaling and coordinate options 
when you import a DXF file:

Micrografx DRW format

DRW is the native file format of Micrografx Draw 3.1 and is also 
supported by Micrografx Designer 3.1 and Charisma 2.1. This format 
supports both vector and text. Text translates to polylines in Canvas. 
Extruded objects opened in Canvas become separate rectangle, cir-
cle, oval, polygon, or multigon objects. Once opened in Canvas, you 
must ungroup DRW objects to edit them.

Enhanced Metafile

Enhanced Metafile is the improved metafile format for 32-bit Win-
dows applications. It replaced the Windows Metafile (WMF) format 

DXF objects Canvas objects

3-D lines 2-D lines

3-D Face 2-D polygon

Traces, Solids, and Quadratic 
polylines

Polygons

B-spline Polylines Bézier curve paths

Shapes and Blocks Groups

ATTDEF and ATTRIB Text objects
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of Windows 3.x. Like other metafile formats, EMF stores vector 
objects, images, and formatted text.

Encapsulated PostScript

Encapsulated PostScript (EPS) is a file format based on PostScript. 
However, EPS files don’t include document information, such as 
page size or orientation, so EPS files themselves must be placed in a 
document and printed by a graphics layout program like Canvas. 

When you import EPS files into Canvas, a dialog box gives you the 
option of placing the EPS file as an encapsulated object or converting 
the elements of the EPS file to individual, editable Canvas objects.

Desktop Color Separations An option you can choose when sav-
ing files as EPS, Desktop Color Separations (DCS) is a specification 
for CMYK color separations contained in a set of EPS files. The five-
file set includes one composite file that can be used as a preview.

EPS preview options Canvas (and other programs that support pre-
view images) can display a preview of an EPS graphic. The preview 
lets you position and size the graphic in a document. In Canvas for 
Windows, previews are stored in Enhanced Metafile format (EMF), 
and you can choose black and white, grayscale, or color previews. In 
Canvas for Mac OS, previews are stored in PICT or TIFF format.

About PostScript formats

PostScript is a programming language that 
encodes document pages as commands and 
data. PostScript is the language used by many 
inexpensive desktop printers and by high-end 
commercial imagesetters. PostScript supports 
vector objects, type, and raster images.

When printing a document to a PostScript print-
er, an application program sends information to 
a printer driver. The printer driver creates a Post-
Script program that describes the document 
and sends it to the printer. The printer (or a Post-
Script raster-image processor) interprets the 
PostScript program to reproduce the document 
on the page.

In Canvas, you can position, scale, rotate, mask, 

and apply colors to EPS graphics. If the file con-
tains a preview, you can see the effects of these 
commands on the EPS graphic. However, 
because the preview is a low-resolution version 
of the original, you should use the print preview 
feature and print a proof to check the alignment 
and appearance of an EPS graphic.

EPS and PostScript printer files include font 
specifications, but not the fonts themselves. 
Therefore, the correct fonts must be available 
when you print the EPS graphic. Otherwise, text 
won’t print correctly. You can convert text to 
paths before saving a document in EPS format, 
but this isn’t practical for more than a few lines 
of text.
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◆ To include a preview in an EPS file: Select a preview option in 
the EPS Export dialog box. Select an option supported by the pro-
gram in which you will use the EPS file.

Halo CUT

The Halo CUT format was originally created by Media Cybernetics, 
and is used by a number of MS-DOS-based painting applications. 
These files store raster image data at eight bits per pixel.

ICON

This is a Windows bitmap file format used to create application and 
file icons. You can open and save these files in Canvas for Windows; 
you can open these files in Canvas for Mac.

IOCA

Created by IBM, this format stores one-bit image data and supports 
CCITT G3, CCITTG4, and IBM’s MMMR specifications.

Hewlett-Packard Graphics Language

The Hewlett-Packard Graphics Language format is designed for doc-
uments that will be printed on Hewlett-Packard and compatible plot-
ters.

Initial Graphics Exchange Standard 

Initial Graphics Exchange Standard (IGES) format was created by 
AutoDesk for the interchange of 2-D and 3-D drawings.

Joint Photographic Experts Group

The JPEG file format stores compressed raster image files. JPEG is 
an acronym for the Joint Photographic Experts Group, which created 
the file specification. JPEG uses “lossy” compression, which means 
that file size reduction results in some loss of image quality, and a 
decompressed JPEG file is not identical to the original. 

When you save a file in JPEG format, you can choose the amount of 
compression you want to apply to the image. The more you compress 
the file, the more the image quality suffers.

MacDraw Pro (Mac)

Canvas can import files created with MacDraw Pro, and retain the 
individual layers of the illustration. However, Canvas cannot import 
the layer names, so it renames them Layer #1, Layer #2, and so on.
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MacPaint

MacPaint format is the native format of Claris Corp.’s MacPaint pro-
gram. One of the first raster image formats, MacPaint supports only 
fixed-size, black-and-white images.

PC Paintbrush 

PC Paintbrush is a format developed by ZSoft for storing raster 
images. PCX files use run-length encoding (RLE) compression. 

Photo CD

Photo CD is a format developed by Kodak for storing photographs on 
CD-ROM. The format stores each photo in an “Image Pac,” with 5 
versions of the photo at different resolutions. Color data are encoded 
in the YCC color model at 24 bits per pixel. You can convert Photo 
CD images to RGB Color, CMYK Color, or LAB Color mode for 
editing. To open a Photo CD image, you must use the Acquire com-
mand in the Image menu.

Photoshop

Photoshop is the native format of the Adobe Photoshop program. 
Photoshop files store only raster images. Native Photoshop files can 
also include layers, which Canvas “flattens” (combines into one) 
when opening. 

Photoshop uses image modes similar to those supported by Canvas: 
Bitmap, Grayscale, Indexed, CMYK Color, LAB Color, and RGB 
Color. In addition, Photoshop and Canvas file formats can contain 
compatible image alpha channel data, letting you import and export 
images and channels without losing this information. 

Although Canvas does not support Photoshop clipping paths, you can 
save the clipping path as a channel mask in Photoshop, then import 
the image into Canvas. Once the file is in Canvas, you can use the 
Channel Mask feature to create a similar effect to clipping paths; see 
“Using a channel mask to make areas transparent” on page 365. 

When exporting Canvas documents to Photoshop, keep in mind that 
Photoshop does not support vector objects or text, so Canvas vector 
and text objects must be rasterized first.

PICT

PICT is the Mac OS native file format. PICT 2, the current version, 
supports vector graphics, color images, and formatted text. PICT is 
roughly equivalent in Mac OS to the Metafile format in Windows.
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PICT is nearly universal in the Mac OS world and has gained support 
on other platforms. In the same way that almost every Mac applica-
tion can copy text and objects to the Clipboard to exchange data, 
nearly every Mac program can also read and write PICT files.

PICT has some limitations. Some application-specific variations, 
called PICT comments, can cause translation problems. PICT sup-
ports only 72 dpi integer coordinates, so it’s not well suited for high-
resolution graphics. PICT raster images can use transfer modes 
(including Or, And, Xor) for transparency effects, but these effects 
can’t be printed on PostScript printers.

PICT files can use Apple Computer’s QuickTime software to com-
press images using JPEG compression. You must have QuickTime 
installed to display a PICT file that uses JPEG compression.

QuickDraw 3D

You can place QuickDraw 3D graphics in a Canvas document and 
use the QuickDraw 3D tool to rotate, light, and change colors. The 
tool is located in the Object Tools toolbar in the toolbox.

To use QuickDraw 3D graphics

1 Select the QuickDraw 3D tool in the Object Tools toolbar.

2 Click where you want to place the object in the document. A 
directory dialog box opens.

3 Locate the QuickDraw 3D file that you want to place in the 
document and click Open. Canvas places the graphic in the docu-
ment.

4 To change lighting and display options, double-click the 
QuickDraw 3D graphic with the Selection tool; four buttons appear 
at the bottom of the object.

5 To move the 3D graphic, click a button and drag inside the 
bounding box of the graphic.

6 To use the options dialog box, click the Options button, or dou-
ble-click the QuickDraw tool. Configure the settings you want in 
the dialog box and click OK.

QuickDraw 3D tool

QuickDraw 3D options 
dialog box

Front/back

Rotate Lateral motion

Options
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You can also save QuickDraw 3D objects and Canvas extruded 
objects as QuickDraw 3D Metafiles. To do this, you must first select 
one object. Then choose Save As in the File menu, select the Save 
Selection option, and choose QuickDraw 3D Metafile in the File For-
mat pop-up menu.

QuickTime

Apple Computer’s QuickTime technology lets you record, edit, and 
play digital movies and sound files. QuickTime software is an exten-
sion included with Mac OS System 7.5 and is available as an option 
for Windows. QuickTime is required to work with some file, graphic, 
and sound formats, including QuickTime movies, sound (SND) files, 
and graphics that use JPEG compression provided by QuickTime.

Using the QuickTime tool in the Object Tools toolbar, you can create 
movie files from presentation documents, record and place sounds, 
and place and play QuickTime movies in your Canvas documents. 

You can also double-click the QuickTime tool to open a dialog box 
with playback options.

Loop Turn on to make a QuickTime movie repeat when you play it. 
To loop the movie from beginning to end, choose Normal in the pop-
up menu; choose Back and Forth to make the movie play forward and 
backward alternately.

Play Selection Only Turn on to play one selected QuickTime 
object at a time.

Show Controller Turn on to display the QuickTime movie play-
back controls with the object.

When you save a presentation document as a QuickTime movie, the 
Export Options dialog box opens. You can set the number of seconds 
to show each slide and the color depth. In the Maximize pop-up 
menu, you can choose an option:

Animation Quality makes slide transitions as smooth as possible at 
the expense of image resolution.

Image Quality uses high image resolution but might slow animation.

Compression keeps the file size to a minimum, at the cost of lower 
animation and image quality.

On Mac OS, you can also turn on “Playable on non-Apple comput-
ers” so the movie is compatible with QuickTime for Windows.

QuickTime tool
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When you save a Canvas document that contains a QuickTime movie 
object, Canvas updates the links to any movies that are in the Canvas 
document. If Canvas can’t find an original movie file, an alert box 
asks you to locate the file. Use the directory dialog box to select the 
movie file and click Open. If you can’t locate the file, click Cancel to 
continue saving and Canvas saves only the movie’s “poster” preview.

Rich Text Format

Rich Text Format stores text with formatting information such as 
font, type size, character style, indents, special characters and style 
tags. An RTF file contains only ASCII characters and can be created 
in any text editor. RTF files are used as source files for compiling 
Windows Help files and for transferring documents between word-
processing applications when a native file format isn’t available.

Sounder (Mac OS only)

You can place sound objects in Canvas documents by using the 
Sounder tool in the Object Tools toolbar in the toolbox. The 

sound plays when you double-click the sound object. These objects 
do not print.

To add an existing sound file to a document

1 Double-click the Sounder tool.

2 In the Sounder dialog box, choose Read From File and click 
OK to close the dialog box.

3 With the Sounder tool selected, click where you want to place 
the sound object in the document. A directory dialog box appears.

4 Locate the sound file in the dialog box and click Open to place 
the sound object in the document.
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To add a new sound to a document

1 Double-click the Sounder tool.

2 In the Sounder dialog box, choose Record New Sound and 
choose a sound quality level.

3 Click OK to close the dialog box.

4 With the Sounder tool selected, click where you want to place 
the sound object in the document. A sound recording control dialog 
box appears.

5 Use the recording controls to begin, stop, and play the record-
ing. When you finish, click Save and name the sound file in the dia-
log box that appears.

Tag Image File Format

Tag Image File Format is a high-resolution raster image format. Can-
vas supports both RGB and CMYK TIFFs. Although TIFF is a “stan-
dard” format, many TIFF variations exist. Different resolutions, color 
systems, previews, and compression schemes make the format flexi-
ble but can cause compatibility problems. 

TIFF files are often used for high-resolution images in desktop pub-
lishing. Because large, high-resolution images can require huge 
amounts of memory, if you have problems opening TIFF files, check 
that your system has enough available memory. You might also need 
to check free disk space if the system uses a virtual memory disk file. 

You might also have problems opening TIFF files created by a pro-
gram that uses unusual format tags. If possible, save files using the 
default settings before trying to open them in Canvas.

Text

Text is a standard format for files containing only ASCII (American 
Standard Code for Information Interchange) encoded characters.

Text format is available on nearly every computer platform; it’s the 
“plain vanilla” format, the lowest common denominator for words 
and numbers. Text files don’t include proprietary or application-spe-
cific character or formatting codes. Some punctuation marks, sym-
bols, and all accented letters are non-ASCII characters that display 
incorrectly when used in text files. Still, ASCII text can be used to 
transfer text among a variety of applications, including text editors, 
word processors, and databases. 
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When you open a text file, Canvas creates one text object containing 
the file’s contents, and assigns the default font and text formatting 
attributes to it. If the file contains more text than can fit in the Canvas 
workspace, Canvas truncates the text object and displays an overflow 
indicator. You can then flow the truncated text into other columns.

Windows Bitmap

Windows Bitmap Format was designed by Microsoft for storing ras-
ter images and is widely supported by Windows applications. 

Windows Bitmap files use a 256-color palette (with 20 colors 
reserved by the operating system) or store 24-bit color information. 
Saving a Canvas document in Windows Bitmap format changes indi-
vidual objects in the document to a single raster image.

Windows Metafile

Windows Metafile is the common file format of Windows 3.x, but 
has been replaced in 32-bit Windows applications by the Enhanced 
Metafile format (EMF). WMF files support vector objects, images 
and text, but don’t support layers or high-resolution raster images. 
Also, if you save Canvas documents in this format, Bézier paths are 
converted to polylines. This means that if you save a Canvas docu-
ment in this format, and then reopen the document in Canvas, curves 
are a series of lines. However, this should not affect the smoothness 
of curves. 
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Using Object Linking and Embedding 
In Windows, Object Linking and Embedding (OLE) lets you easily 
exchange graphics among programs. Because Canvas provides full 
OLE support, objects you exchange retain their full functionality and 
are editable with all the tools of the original application.

Windows programs provide various levels of OLE support. In OLE 
parlance, Canvas is a fully capable object and container application. 
Briefly, this means Canvas can transfer objects to and from other pro-
grams through OLE. 

Canvas is also an OLE visual editing application, which means you 
can use Canvas tools to edit Canvas objects embedded in other OLE 
containers, such as Microsoft Office applications. Also, you can edit 
objects embedded in Canvas documents using tools from other visual 
editing applications.

In the world of OLE, objects created in Canvas are identified as 
“Canvas 5 Drawing” objects. If you use the Insert Object command 
in another application, you should be able to select “Canvas 5 Draw-
ing” as a type of object to insert.

Inserting objects into Canvas documents

You can use three methods to insert objects in a Canvas document: 
the Clipboard, drag-and-drop, and the Insert Object command. The 
objects you insert can be either linked or embedded.

Clipboard When you copy Canvas objects to the Clipboard, Can-
vas places OLE formats, as well as lower-fidelity formats, on the 
Clipboard. When you paste into another program, that program 
receives the highest-fidelity format it can accept. If the other program 
is an OLE container, pasting creates an embedded OLE object. The 
same applies when pasting into Canvas; Canvas creates an embedded 
OLE object if OLE formats are available on the Clipboard.

Drag-and-drop In Windows 95, you can drag objects from Canvas 
documents to almost any destination on the Desktop (including local 
and network folders) to create a “scrap” file containing the objects. 
You can also drag Canvas objects into other documents, and drag 
objects, such as scrap files and other program’s objects, directly into 
Canvas documents. When you drag an object to another program, it 
creates an embedding. 

You can copy an object when you drag it by pressing a modifier key. 
Normally, dragging moves the object. If you want to copy the object, 
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rather than move it, Ctrl-drag the object to another document. This 
copies the object and creates an embedding. 

Insert Object The Insert Object command in the Edit menu opens a 
dialog box in which you can choose any registered OLE object type 
to insert into a document. You can create a new object or choose a 
file as the source of the embedded object.

To embed objects

When you embed an object in another document, you can use the 
original program’s tools and commands to edit the object.

Note: Not all programs support OLE and can create embeddings.

1 Select the objects you want to embed in another document.

2 Choose Copy in the Edit menu. Canvas puts the selection on 
the Clipboard.

3 Switch to the document where you want to embed the selection 
and choose Paste in the Edit menu. The object is embedded into the 
document.

To link objects 

If you want an object to be updated when it changes in the original 
document, you can create a link to the object. 

Note: Not all OLE programs support OLE linking.

1 Select the objects to link and choose Copy in the Edit menu. 

2 Switch to the document where you want to paste the linked 
object and choose Paste Special in the Edit menu. 

3 In the dialog box, Canvas 5 Drawing format is selected and 
you can click Paste Link to link the object.

To manage linked objects

You can use the Links command to check the source file of a linked 
object and repair a broken link if a source file has been moved.

1 Select a linked object in a document.

2 Choose Links in the Edit menu. The Links dialog box displays 
the link type and update method. To change the update method, 
choose the Automatic or Manual option.

3 Use the buttons to update or change the linked object:
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• To update the object from its source, click Update Now.

• To open the source document, click Open Source.

• To select a different source document, click Change Source.

• To remove the link so changes to the source do not affect 
the linked object, click Break Link.

Differences between linking and embedding

When you insert an object into a Canvas document, or insert an 
object from Canvas into another program’s document, you create an 
association between the object and its application. Linking and 
embedding create different types of associations.

Linking When you link an object, the object remains in the file 
where it was created. Only a link (reference) to the source object 
winds up in the document, which makes linking an efficient method 
of storing commonly-used objects and files. Linking makes a 
dynamic connection between an object and all documents in which it 
appears. When you edit the object, changes are automatically sent to 
linked instances of the object in all documents.

Because the object is linked by only a reference to another file, if any 
of the linked files change locations, the link will be disrupted. To 
move linked files without disrupting the references, you must move 
all linked files as well as the entire directory structure so that the rela-
tive locations of the files don’t change.

When you edit a linked object, the object’s application opens in a 
separate window. When you finish editing, you close the application 
to return to the document containing the link.
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Embedding When you embed an object in a document, the object 
itself (not just a reference) is copied into the document. Therefore, a 
document can be moved to another computer without losing the 
object.

When you edit an embedded object, the source application’s tools, 
palettes, and menu commands take over the window until you finish 
editing and select another object in the document.

Sharing information through Publish and Subscribe
Publish and Subscribe is a Mac OS technology that lets you share 
information in Canvas and with other Mac OS programs.

Publish and Subscribe is useful when you want to be able to update 
an object in several documents whenever you change the original.

To share an object, you make it a publisher. This creates an interme-
diate file, called an edition. To place the object in other documents, 
you subscribe to the edition file. Subscribing creates a subscriber, 
which is linked through the edition to the publisher. 

Publish and Subscribe creates dynamic links between documents, 
unlike moving data through the Mac Clipboard. When you change a 
publisher, Canvas can update the edition automatically. When an edi-
tion changes, its subscribers can be updated automatically. You can 
also turn off automatic updating and then update changes manually.

Publisher Edition file Subscribers

You can share an object by 
publishing it, which creates an 
edition, and then subscribing to 
the edition. 

The arrows represent manual or 
automatic updates from the 
publisher to the edition, and from 
the edition to the subscribers.

Avante
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To publish a selection

When you publish a selection, Canvas creates an edition file contain-
ing a copy of the published selection. You can subscribe to the edi-
tion from other documents. You can use the same procedure to 
publish information in another program and subscribe to it in Canvas.

1 Select the objects in Canvas that you want to publish.

2 Choose Publishing➤Create Publisher in the Edit menu. 

3 In the Create Publisher dialog box, select a location and type a 
name in the text box for the edition file, and then click Publish. 
Canvas creates the edition file on disk and displays a rectangular 
shaded border around the published selection.

Publisher borders

The rectangular border Canvas displays around a publisher is like a 
window into the document. Canvas sends objects that are within the 
border to the edition file. You can resize and move the border and 
move objects into and out of it to change the contents of the edition.

To set publisher options

The Publisher Options command lets you specify when to update a 
publisher’s edition file. It also lets you update the edition manually 
and cancel the link between the publisher and edition. The command 
is available once you save the document containing the publisher.

1 Click the publisher border to select it and choose 
Publishing➤Publisher Options in the Edit menu.

2 To update the edition immediately, click Send Edition Now. 
Canvas updates the edition file. Whether subscribers to this edition 

Preview of publisher

Type name for edition file

Publisher border
Chapter 5: File and data exchange



also get updated depends on their update setting; see “To set sub-
scriber options” on page 83. 

3 To specify when Canvas should update the edition file, choose 
an option in the Send Editions area.

On Save Tells Canvas to update the edition file whenever you save 
the publisher document.

Manually Tells Canvas not to update the edition. If you select this 
option, Canvas shows the time of the last publisher change.

4 When you finish setting publisher options, click OK.

◆ To break the link between publisher and edition: Click Can-
cel Publisher in the Publisher Options dialog box. This breaks the 
link to the edition. However, canceling the publisher does not delete 
the edition file or affect documents that subscribed to the edition.

To subscribe to a published selection

After you publish a selection, which creates an edition, you can sub-
scribe to the edition file to place the published selection in as many 
documents as you want. 

1 In the document in which you want to place the published 
objects, choose Publishing➤Subscribe To in the Edit menu.

2 In the directory dialog box, select the edition file for the pub-
lished selection and click Subscribe. The published information 
appears in the subscriber document within a non-printing gray rect-
angle. You can move and resize the subscriber border.

To set subscriber options

You can make changes to an edition file appear automatically in sub-
scriber documents or update the subscriber manually. To set these 
and other options, use the Subscriber Options command.

Edition location

Choose update method

Canvas Edition file icon
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1 Click the subscriber border to select it and choose 
Publishing➤Subscriber Options in the Edit menu.

2 To update the subscriber now from the edition, click Get Edi-
tion Now. To specify when the subscriber should get changes from 
the edition file, choose an option in the Get Editions area:

Automatically Tells Canvas to update the subscriber when you 
open the document and whenever the edition changes.

Manually Tells Canvas not to update the subscriber. If you select 
this option, Canvas shows the time of the last update.

3 When you finish setting subscriber options, click OK.

◆ To break the link between a subscriber and edition: Click 
Cancel Subscriber in the Subscriber Options dialog box.

◆ To open the publisher document: Click Open Publisher in the 
Subscriber Options dialog box.

Updating publishers and subscribers
When you work on a document containing publishers or subscribers, 
you can update all the linked items in the document at once.

◆ To update all edition files: Choose Publishing➤Send All Now 
in the Edit menu. Canvas updates all editions that are linked to the 
publishers in the document.

◆ To update all subscribers in a document: Choose 
Publishing➤Get All Now in the Edit menu. Canvas gets updates 
from all editions that are linked to the subscribers in the document.

Choose update method

Edition location
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PREFERENCES AND TOOLS

You can customize your Canvas work environment to best suit the 
needs of a specific project and to maximize your productivity. This 
chapter describes how to set Canvas preferences for

• general window environment

• drawing

• image editing

• printing

• measurement units and precision

This chapter also describes how to save document templates and cus-
tom combinations of specific tools. 

Setting preferences
Preferences are settings for certain display, tool, and command 
behaviors in Canvas. To open the Preferences dialog box, choose 
Preferences in the File menu. The dialog box has five tabs: General, 
Drawing, Painting, Printing, and Units.

◆ To set preferences: Click a tab to display the corresponding 
options. To implement the current preference settings, click OK. The 
settings available on each tab are described below. 

Note: For options that you simply turn on and off (as opposed to 
entering a number or choosing a menu option), the descriptions refer 
to the behavior of Canvas when the option is turned on.

General Canvas preferences
The options on the General preferences tab set some display and win-
dow behaviors.

Number of undo levels Enter a number in the text box to specify 
how many previous actions you want to be able to reverse using the 
Undo command in the Edit menu. Although you can specify several 
levels of undo, keep in mind that higher numbers require more sys-
tem memory to maintain.
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Freeform selection Lets you place objects in freeform mode by 
clicking already-selected objects. Otherwise, you must use the 
Effects➤Freeform command to put an object in freeform mode.

Retain selected tool Keeps the current tool selected after you use 
it, instead of reverting to the Selection tool. 

No background updates Prevents Canvas from redrawing open 
Canvas documents when you are working in another application. 
This option lets other applications run faster when Canvas is in the 
background.

Dither colors Provides the best onscreen color representation, but 
requires more system memory. If you are using Canvas for Macin-
tosh, this option requires 32-bit color capabilities.

Select across visible layers Lets you select objects on all visible 
layers in a document, rather than just the active layer.

Note: If this option is off, you can still select objects on other visible 
layers by pressing Tab and clicking an object.

Fit to Window Opens documents so the full layout area can be seen 
in the center of the window. When this option is off, documents open 
in Home View (100% magnification with the upper-left corner of the 
page in the upper-left corner of the window).

Maximize on opening Opens documents at full screen size. Other-
wise, documents open at a standard size that fits any monitor, but 
might not fill the screen completely.

Create backup when saving Saves a copy of the current document 
each time you save changes to the document. The backup copy has 
the extension “.bak,” and Canvas saves to this same file each time.
Chapter 6: Preferences and tools



Drawing preferences
The Drawing tab lets you select a coordinate system for angular mea-
surements and specify behavior for moving and copying objects. 

Coordinate system Choose the Standard or Engineering system 
for angular measurements.

When dragging objects show original objects Objects you drag 
follow the pointer, but also appear in their original position until you 
finish dragging.

Draw quality Draft quality displays shapes, especially curves, with 
less precision onscreen than Fine quality. However, Draft quality 
redraws slightly faster.

When duplicating objects offset Tells Canvas how far (in pixels) 
from the original to put object copies when you use the Duplicate or 
Paste commands in the Edit menu.

When moving objects offset Lets you specify the number of pix-
els objects move when you use a combination of modifier and arrow 
keys. For example, with the settings shown here (for Windows), 
Ctrl+Right Arrow would move a selected object 50 pixels to the 
right, and Alt+Right Arrow would move it 10 pixels to the right. 
Canvas Mac OS users can use the Command and Option keys in 
combination with arrow keys.

• Auto-scroll to selection keeps objects you are moving with 
the arrow keys in view by scrolling the document window.

Engineering

Zero degrees at 3 o’clock, 
increases counterclockwise

Standard 

Zero degrees at 12 o’clock, 
increases clockwise

0

90

180

270

90

0

270

180
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Painting preferences
The Painting tab lets you set preferences for displaying and editing 
paint objects and images in Canvas. 

Interpolation Tells Canvas how to fill new pixels created by resiz-
ing a paint object or applying certain filters.

• Nearest Neighbor fills new pixels with the same color as 
an adjacent pixel.

• Bilinear fills new pixels with colors derived from the color 
values of adjacent pixels. This creates softer edges than 
Nearest Neighbor.

Color Channels Makes channel previews in the Channels palette 
display in their respective colors instead of grays.

Video LUT Animation (Mac only) Provides faster previews of 
some image filters by modifying the color lookup table of your mon-
itor instead of redrawing the image. For example, with Video LUT 
Animation turned on, changing the brightness of an image in the 
Brightness/Contrast dialog box with the Preview option off changes 
the brightness of the entire screen and not just the image.

Anti-Aliased Clipboard Anti-aliases vector and text objects pasted 
from the Clipboard into a paint object.

Anti-Aliased Canvas Objects Anti-aliases Canvas vector and text 
objects drawn in a paint object. For example, if you add text to a paint 
object in edit mode, Canvas rasterizes and anti-aliases the text.

Plug-Ins Click this button to tell Canvas where to find Photoshop-
compatible plug-ins installed on your system so you can use them in 
Canvas. In the directory dialog box that appears, find the folder con-
taining the plug-ins. The path name of the current folder appears in 
the text box below the button. Installed plug-in filters will appear in 
the Image➤Filters submenu.

Separate Grayscales as Black When color-separating grayscale 
images, turning this option on sends all the pixel information to the 
black plate. Otherwise, Canvas creates four-color grays.
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Printing preferences
The Printing tab has settings that control the appearance of printed 
output.

Output to maximum resolution Prints Canvas documents at the 
printer’s best possible resolution. However, this setting disables 
image reduction options and fast-printing features of QuickDraw® 
printers; these features require a setting of 72 dpi.

When this option is off, you can choose the resolution (72 or 300 dots 
per inch) you want in the Resolution pop-up menu.

Halftone Lets you set custom frequency (in lines per inch) and 
angle (in degrees) of halftone screens. You can also choose to use the 
printer’s default halftone settings. For most desktop publishing pur-
poses, the printer’s defaults are the optimal settings. However, for 
commercial printing, you might need to specify a particular fre-
quency and angle for the best output. If you are sending your docu-
ments to a commercial printer, ask them for the appropriate halftone 
screen settings.
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Type preferences
The Type tab in the Preferences dialog box lets you customize the 
way you work with text.

Auto Word Select When using the I-beam pointer to highlight spe-
cific text, this option ensures that you select whole words (or all char-
acters between blank spaces) only. As you drag to highlight text, 
Canvas detects when you drag over a space. As you continue to drag, 
Canvas locates the next space and selects the characters in between.

Drag & Drop Text With this option on, you can highlight specific 
text, then drag the highlighted text to a new location within the same 
text object.

Smart Copy With this option on, if you copy and paste text that 
begins a paragraph, Canvas pastes the text as a new paragraph using 
the original paragraph settings. With this option off, Canvas pastes 
text into the current paragraph using the existing paragraph settings.

Snap text to single column In publication documents with Col-
umn Guides off, you can turn this option on to have text objects snap 
to the width and length of the page margins when you click with the 
Text tool or Text Object tool. Otherwise, Canvas inserts a text object 
where you click.

Faster Text/Poor Color (Windows) Turning this option on speeds 
up screen redraw of text at the expense of color fidelity.

Draw Text as Béziers (Windows) When using a 256-color display, 
Windows cannot dither colors in text to approximate a non-system 
color; instead, Windows uses the closest solid colors. Turning this 
option on tells Canvas to redraw text using Bézier curves so that 
Windows can dither its colors if necessary. This method is resource 
intensive and can be slow; turn this option on only if you need to see 
dithered color in text on a system that displays only 256 colors.
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Measurement unit preferences
The Units tab lets you choose measurement settings, such as units, 
precision, and numerical format. Settings on this tab affect the units 
displayed in the Strokes palette, the status bar of the Canvas window, 
the measurements in dimension objects, and the precision of settings 
in the Type palette.

Pen size units Choose inches, millimeters, points, or picas in the 
pop-up menu to specify how you want to measure pen size in the Pen 
tab of the Strokes palette.

Number form Set the precision and numerical format for numbers 
in the status bar, the Type palette, Show Size display, and other 
numerical displays. You can choose whole integers, up to four-deci-
mal precision, or fractions. The setting you choose affects the mea-
surement precision only, and does not affect the drawing precision.

Virtual Memory preferences (Mac only)
The Virtual tab lets you choose a disk and set other options for Can-
vas’ internal memory management feature. Memory management 
makes it possible to open images and files that require more memory 
than the amount of physical RAM on your system.

Selected Hard Disk Choose a mounted hard disk in this pop-up 
menu. Canvas uses this disk for virtual memory. The amount of 
available space on the disk is shown below the pop-up menu.

Use available system memory Turning this option on instructs 
Canvas to use the allocated system memory first before resorting to 
its internal virtual memory.

Dynamic disk allocation Leave this option on to let Canvas claim 
and release disk space as needed and available for particular files. If 
you turn this option off, you can use the Minimum Disk Space After 
Allocation text box to set a limit on how much space Canvas can 
claim for virtual memory. For example, if you type 50 MB in the text 
box, Canvas must leave at least 50 MB free on the disk.
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Saving document templates
You can use a special kind of Canvas document, called a template, as 
the basis for new documents. Canvas includes many ready-made 
templates, and you can create your own template documents. Then, 
when you use the New command, you can select a template — either 
one supplied with Canvas or one you have created — and Canvas 
will make a new document based on the contents and configuration 
of the template.

A template document stores almost all preferences settings, the 
options you choose with the Document Setup command, and other 
document setup options, including the following:

• document type — illustration, publication, or presentation

• setup of layers, slides, and pages

• settings for rulers, grids, guides, and views

• current inks and strokes settings

• text styles and default text settings

Canvas stores some settings with the application and not in particular 
documents, so these settings are not included in a template document. 
These settings that aren’t stored in a template include the position of 
palettes on the screen and the current set of external tools. 

To save a template document 

1 Use the New command in the File menu to create a new illus-
tration, presentation, or publication document.

2 Use the Document Setup command in the Layout menu to 
select measurement units, document size and orientation, and, for 
publications, the margins and column layout.

3 Use the Preferences command in the File menu to set the pref-
erences on the General, Drawing, Painting, Units, and Printing tabs.

4 Create or import the objects you want to store in the template.

5 Choose Save As in the File menu. In the “File Format” (Mac) 
or “Save as type” (Windows) pop-up menu, choose Canvas 5 Tem-
plate and click Save.

For more information, see “Saving Canvas documents” on page 21.

✔Tip
If you create a template with a 
small amount of type, such as 
for a letterhead, convert the 
type to paths so the template 
won’t depend on particular 
fonts being available.
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Loading external tools
Using the ToolPicker, you can choose which drawing, painting, 
image editing, typography, and import/export tools and commands 
you want to load each time you begin a Canvas work session. By 
selectively loading tools, you can streamline your work environment, 
improve system performance, and increase productivity. If you 
choose not to load certain tools, Canvas removes them from the 
menus and toolbox, minimizing onscreen clutter.

By default, Canvas will load all its tools to provide you with the full 
range of capabilities. You don’t need to use the ToolPicker to add 
functions to the program before starting your first session. You only 
need to use the ToolPicker to change the current set of tools.

Using tool sets
You can use the ToolPicker to save combinations of tools, called tool 
sets. Using tool sets makes it easy to quickly select the tools you need 
for the current Canvas session. You can create tool sets for specific 
types of projects, when you know that you will need only certain 
tools. For example, you could save a tool set specifically designed for 
image editing, which does not require many of the vector and typo-
graphic features of Canvas. Creating tool sets and loading only the 
necessary tools speeds Canvas startup time, and reduces the amount 
of system resources required to run Canvas.

◆ To save a tool set: In the ToolPicker dialog box, select the 
tools you want and click Save. In the dialog box that appears, type a 
name for the tool set and click OK. The new tool set name appears in 
the Tool Sets pop-up menu.

◆ To delete a tool set: In the Tool Sets pop-up menu, choose the 
name of the set you want to remove and click Delete. Canvas asks 
you to confirm that you want to delete the tool set; click OK to delete 
the set and close the dialog box.

Note: If you choose a tool set in the pop-up menu, then modify the 
list of selected tools and click OK, Canvas loads the currently 
selected tools and not the saved tool set. Also, the modifications you 
make to the scroll list of tools do not change the saved tool set unless 
you delete the tool set and save it again using the same name. You 
can’t save a tool set using an existing tool set name.
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Using the ToolPicker

To open the ToolPicker dialog 
box, launch Canvas and imme-
diately press and hold down 
the Spacebar until the 
ToolPicker dialog box appears. 
After selecting tools to load, 
click OK to start Canvas.

A To load a saved set of tools, 
choose a tool set in the pop-up 
menu.

B To save or delete a tool set, 
click the Save or Delete button. 
See “Using tool sets,” below.

C To sort the list of tools, click 
a column heading. Canvas sorts 
that column in alphabetical or-
der.

D To add or remove tools, 
click in the left column next to a 
tool. A check mark appears next 
to selected tools.

All Tools. Click to select all 
tools in the scroll list. Canvas 
places a check next to each 
tool.

No Tools. Click to deselect all 
tools. Canvas removes all 
check marks in the left column.

Revert. Click to select the 
same tools that were selected 
when the ToolPicker opened. 
Canvas undoes any changes 
you made to the list of tools.

Temporary. Click to use the 
selected tools for the current 
session only. The next time you 

start the program, Canvas will 
load the tools that it loaded 
before.

C

A

D

A

C

D

B

B

Windows 

Mac OS 
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OBJECTS & ATTRIBUTES

II





Types of objects and common ope
7

WORKING WITH OBJECTS

This chapter explains how to work with objects in Canvas. It tells you 
how to select objects with selection tools or the Find command. It 
describes common actions, including how to copy, group, lock, 
move, arrange, flip, and align objects, plus effects you can apply to 
all objects, including scaling, rotation, and skew. It also tells you how 
to use the object position data in the Object Specs palette.

Types of objects and common operations
An object is an item that you can select, move, rotate, copy, dupli-
cate, and delete, to name some basic operations. In Canvas, you can 
work with various types of objects:

Vector objects Geometric shapes — lines, circles, rectangles, poly-
gons, and smooth curves — made with drawing tools. Canvas defines 
them internally by formulas, which might read like this: “Draw a cir-
cle 20 millimeters in diameter starting at coordinates x15 y30.”

Paint objects Frames that hold images — photos, screen pictures, 
faxes, and paintings — created with scanners or painting tools. Can-
vas defines them as rectangular areas made of square pixels, with 
each pixel assigned a color value. As a mass of pixels, they can be 
cropped, stretched, and filtered, but manipulating millions of pixels 
and color values can consume a lot of system memory. 

Text objects Frames that hold text — numbers and letters and sym-
bols — with character formatting, such as typeface and size, and 
paragraph formatting, including indents and line spacing. A text 
object can be empty, or contain up to a full page of text, and it can be 
linked to other text objects.

Group objects Multiple objects united with the Group command. 
A group object can be made of one type of object or several types. 
When grouped, all objects in the group behave like one object.

Each type of object has unique properties, and certain commands 
apply only to certain types of objects. However, Canvas is designed 
so you can perform many functions exactly the same on any object. 
For example, a line, a headline, and a photo of a chorus line differ in 
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many respects, but in Canvas, you can use the same methods to 
select, copy, move, and arrange them in your documents. 

Selecting objects 

When you select an object, you distinguish it from other, unselected 
objects, so that when you choose a command or apply a color, Can-
vas knows to apply it to the selected object. In most cases, you select 
objects first, then apply a command or attribute. If you can’t apply an 
attribute, or a command is not available, check to be sure you have 
correctly selected an object first.

Canvas provides several tools and commands for you to select 
objects. You can use the most convenient method for each situation. 
The Selection tools in the toolbox are the primary object-selection 
tools. You can also use the Select All and Find commands to select 
objects. Refer to the table “Selection options” on page 99 for a list of 
selection tools and commands.

In some cases, you can select parts within objects. For example, you 
can select an anchor point within a vector object, a word within a text 
object, and an image area within a paint object. Refer to the following 
parts of the User’s Guide for specific selection procedures: Drawing 
& Vector Effects, beginning on page 163; Text & Typography, 
beginning on page 227; and Painting & Image Editing, beginning on 
page 303.

Selection indicators

Canvas indicates that an object is selected by displaying the object’s 
bounding box. The bounding box is a rectangle with solid squares, 
called handles, at each corner and side midpoint. When an object is 
selected, its bounding box is visible even if it has attributes (the same 
color as the background, for example) that make the object itself 
invisible. Also, a selected object’s bounding box is visible even if it’s 
covered by other objects.

When one object is selected, Canvas displays the object type at the 
right end of the status bar. When more than one object is selected, the 
status bar shows the number of selected objects.

◆ To select all objects: Choose Select All in the Edit menu. This 
command selects every object in a single-layer document. To select 
all objects on all visible layers in a multi-layer document, change the 
default selection setting in the Preferences dialog box; see “General 
Canvas preferences,” page 85.

A bounding box with handles 
surrounds a selected object.
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Selection options

Selecting objects with the Selection tools
The Selection tool (a filled arrow) selects any object you click. The 
Direct Selection tool (a hollow arrow) lets you select individual 
objects within a group object, without first ungrouping.

The Selection tool is the default tool when you start Canvas. The 
Selection tools are in a toolbar at the top-left of the toolbox. If 
another tool was selected and you need to return to the Selection tool, 
click its icon in the toolbox. 

◆ To select one or multiple objects: With the Selection tool, 
Click an object. To select multiple objects, Shift-click each object 
you want to select. For Windows only, you can also hold down the 
right mouse button and click multiple objects to select them.

With the Selection tool, you can drag a selection box around objects 
to select them. Canvas selects all objects inside the selection box.

To select Do this

A single object Click the object with a Selection tool.

Multiple objects Shift-click each object with a Selection tool. Canvas for Windows users can 
also hold down the right mouse button while clicking objects with the left 
mouse button.

Objects using a selection box Drag a box around the objects with a Selection tool.

All objects touched by a selection box With a selection tool, press Option (Mac) or Ctrl (Windows) and drag out a 
box that touches the objects.

One object within a group object Click the object with the Direct Selection tool (hollow arrow).

No objects (deselect all objects) Click a Selection tool in a blank area, or press Enter (Mac) or Esc (Windows).

All objects Choose Select All in the Edit menu.

An object behind another object Ctrl-click (Mac) or Tab-click (Windows) the object’s location until it is selected.

Unfilled object Click the object’s border, or press Tab and click inside the object.

An object on a layer other than the 
current layer, or an object on a master 
page

Tab-click the object with a Selection tool.

All objects created by a particular tool Select the tool, then choose Select All in the Edit menu.

Objects based on their attributes Use the Find command in the Edit menu.
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Copying, cutting, pasting, and deleting objects
When you have selected one or more objects, you can perform a vari-
ety of basic editing functions. You can copy and then paste the selec-
tion to duplicate it within the same document or in another document. 

Selecting objects based 
on their properties

You can use the Find com-
mand in the Edit menu to 
select objects by type and 
attributes, such as rectangles 
with red fill ink. 

In the Find palette, use the 
Objects tab to set up selection 
criteria.

A To select objects by type, 
check Type and choose an ob-
ject type icon in the pop-up 
menu. Selecting text or paint 
objects makes Fill, Stroke, and 
Pen options unavailable.

B To select objects by fill or 
pen ink, check these boxes and 
choose the inks in the pop-up 
menus. Only inks used in the 
document, plus process colors 
and white, appear in the menus.

C To select objects by stroke, 
check Stroke and choose the 
stroke in the pop-up menu. 
Only strokes used in the docu-
ment appear in the menu.

D To select objects by name, 
check Object Named. Type the 
name in the text box.

E To select objects in the cur-
rent layer only, uncheck this op-
tion.

Using selection sets
F Check to select additional 
objects without deselecting ob-
jects that are already selected.

G Click to open a window for 
working with selection sets, 
which let you broaden a search.

H Selection criteria symbols 
make up a selection set. 

I The current selection set is 
boxed. Changing selection op-
tions updates this selection set. 
Click a set to make it the current 
selection set.

Or. Click to create an empty 
selection set.

Copy. Click to duplicate the 
current selection set.

Clear. Click to delete the cur-
rent selection set. With only 
one set, Clear is unavailable.

Next Page/Slide. Click to 
advance to the page or slide 
and continue searching.

Select. Click to select objects 
based on the settings.

A

C

F

E

H

I

G

B

D
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You can delete a selection and place it on the Clipboard at the same 
time to move it to another location.

The Cut, Copy, and Paste commands use the Clipboard to tempo-
rarily store objects. The Clipboard stores the results of one editing 
action (which might include multiple objects) at a time. Whatever is 
on the Clipboard is replaced by the next selection you place there, 
even when you use Cut or Copy commands in an application other 
than Canvas.

In Canvas, you can bypass the Clipboard by using the Duplicate 
command to quickly place a copy of a selection in the same docu-
ment. Also, using the Clear command, or the Delete keyboard key, 
does not affect the contents of the Clipboard.

These are the basic editing commands in the Edit menu:

Most editing commands can also be applied to selected text, areas of 
paint objects, and segments of vector objects.

In Canvas for Mac OS, you can also use Cut Without Comments or 
Copy Without Comments to place specialized Canvas objects such as 
arrowheads, concentric circles, and grids on the Clipboard as com-
monly recognized objects. This feature is useful if you are having dif-
ficulty copying Canvas objects to other applications.

◆ To use Cut or Copy Without Comments: Press Shift, then 
open the Edit menu. Choose Cut Without Comments or Copy With-
out Comments, depending on whether you want to leave the objects 
in the current documents.

Command Result

Copy Copies a selection to the Clipboard

Cut Removes a selection and places it on the Clipboard

Clear Removes a selection without changing the Clipboard

Duplicate Copies a selection into the same document without 
changing the Clipboard

Paste Places the Clipboard contents into the active document
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Copying objects into the same document
The Duplicate command quickly copies selected objects into the 
same document, without affecting the contents of the Clipboard.

◆ To copy objects into the same document: Select the objects 
you want to copy and choose Duplicate in the Edit menu. Canvas cre-
ates, offsets, and stacks a copy of the selected objects in front of the 
original. To make additional copies, choose Duplicate again.

Using the Clipboard to copy objects
The Copy and Paste commands let you copy objects using the Clip-
board. You can use the Clipboard to copy objects within a document, 
from one Canvas document to another, and into documents created 
by other programs.

1 Select the objects that you want to copy.

2 Choose Copy in the Edit menu. Canvas puts the selection on 
the Clipboard.

3 If you want to paste the copied selection into another docu-
ment, switch to that document. You can switch to an open Canvas 
document by choosing its name at the bottom of the Window menu.

4 Choose Paste in the Edit menu. Canvas pastes the Clipboard 
contents into the current document.

The Clipboard isn’t erased after you paste its contents. You can 
choose the Paste command again to copy the Clipboard contents as 
many times as you want. However, using the Copy or Cut commands 
in any application does replace the Clipboard contents.

When you paste objects into other programs, the Clipboard uses a 
format that the receiving program understands. However, special 
types of objects and special object attributes can be lost when pasting 
objects into other applications. If you can’t transfer an object success-
fully using the Clipboard, consider using a compatible file format to 
export or import the object as a file to another program.

Creating links when copying and pasting 
(Windows only) You can use the Clipboard to place objects into 
other documents and maintain a link to the source application. In 
Windows, the Paste command creates a link between the pasted 
object and the application that created it, using Object Linking and 
Embedding (OLE).

First duplicate

Original object

Second duplicate

Canvas offsets and stacks 
duplicates in the order that 
you create them.
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Making multiple copies
You can use the Copy and Paste commands to make multiple copies 
of selected objects using the Clipboard. When you choose Copy, 
Canvas places the selected objects on the Clipboard. You can then 
choose Paste to place the Clipboard contents in the active document 
at the center of your current view. You can choose Paste as many 
times as you want to create multiple copies.

You can also use the Duplicate and Replicate commands to make 
multiple copies. The Duplicate command makes copies immediately, 
while the Replicate command lets you incrementally resize and rotate 
the copies.

To make evenly-spaced copies

When you use the Duplicate command, Canvas remembers the dis-
tance that the duplicate is placed from the original object, so you can 
create evenly-spaced copies. 

1 Select the objects that you want to copy.

2 Choose Duplicate in the Edit menu. Canvas duplicates the 
selection and places the copy a preset distance from the original. 
The preset distance is specified in the Preferences dialog; see 
“When dragging objects show original objects” on page 87.

3 Use the Selection tool or the keyboard arrow keys to move the 
copies into position. The copy must remain selected, or Canvas 
won’t remember the offset from the original.

4 Choose Duplicate in the Edit menu again. Canvas places the 
second copy the same distance from the first copy as the first copy 
is from the original selection. Repeat this step as many times as you 
want to create additional evenly-spaced copies.

To rotate and scale evenly-spaced copies

The Replicate command offers powerful capabilities for duplicating 
objects. You can use the Replicate dialog box to set the number of 
copies and to rotate, scale, and position copies simultaneously.

1 Select the objects that you want to copy.

2 Choose Replicate in the Edit menu. 

3 In the Replicate dialog box, configure the settings described 
next.

4 Click Apply to preview or click OK to replicate the selection.
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Grouping and ungrouping objects
You can use the Group command to unite objects that you want to 
keep together as one unit. You can group individual objects as well as 
already-grouped objects. 

When you apply a command to a group object, the effect is the same 
as if all the objects were selected when you apply the command. 
When you no longer want to treat a group object as a single unit, you 
can ungroup it to separate the original objects.

Keep in mind that grouping objects might change the stacking order 
of objects in the group relative to objects outside the group. For 
example, you have three overlapping objects. If you group the front 
and back objects, the group moves to the back and the middle object 
becomes the front object.

◆ To group objects: Select the objects that you want to group. 
Choose Group in the Object menu. Canvas replaces the bounding 
boxes of the individual objects with a single bounding box. 

Options in the Replicate dialog box

The settings on the Replicate 
dialog box let you rotate, 
scale, and duplicate selected 
objects simultaneously.

Copies. Enter the number of 
the copies you want to create.

Rotate. Check this option to 
incrementally rotate each copy. 
Enter the amount in degrees 
you want to rotate each copy 
relative to the previous copy. In 
the Around edit box, click a 
hollow handle (it becomes 
filled) to set the position of the 
center of rotation.

Scale. Check this option to 
incrementally change the 
dimensions of each copy. In 

the pop-up menu, choose a 
scaling method: percentage or 
ratio. Depending on the meth-
od, enter a percentage or ratio 
in the text boxes to specify the 
change in size for each copy.

Proportional. In the Scale or 
Offset areas, check this option 
to horizontally and vertically 
scale or offset objects equally.

Offset. Check this option to 
place copies a specified dis-
tance from the original or the 
previous copy. In the text box-
es, enter the amount of hori-
zontal and vertical offset. Posi-
tive numbers offset objects up 
and right, negative numbers 
offset objects down and left.

Object data. The height and 
width of the bounding box of 
the selected object. These val-
ues can’t be changed.

✔Tip
After you group objects, you 
can select an individual object 
with the Direct Selection tool 
without ungrouping them.
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◆ To ungroup objects: Select one or more grouped objects that 
you want to separate. Choose Ungroup in the Object menu. Canvas 
separates the group and leaves the individual objects selected. If any 
of these objects are group objects, you can further ungroup them by 
choosing the Ungroup command again.

Moving objects
You can move objects by dragging them and by using the keyboard 
arrow keys. You can also use the Move command to specify a posi-
tion change, and you can use the Object Specs palette to specify an 
exact coordinate position.

When you drag an object, the status bar shows the change in the 
object’s x- and y-coordinate position. You can specify the format and 
precision of this data in the Preferences dialog box.

You can make precise positioning easier by turning on the autogrid 
so that objects you drag snap to preset ruler increments. You can also 
place alignment guides that objects will snap to in a document.

◆ To move an object using the Selection tools: Position the 
pointer on the object and drag. If you drag as soon as you press the 
mouse button, an outline of the object follows the pointer. To see the 
entire object as you drag, pause after you press the mouse button, and 
then drag.

You can press modifier keys as you drag objects to constrain move-
ments and perform other functions.

◆ Moving objects using the keyboard: To move objects left, 
right, up, or down, press the corresponding arrow key. You can use 

To Do this

Constrain movement to 45 
degree increments

Press Shift while dragging

Copy objects by dragging Mac: Press Option while dragging

Windows: Press Alt while dragging

Leave a trail of object copies Mac: Press Command-Option while 
dragging

Windows: Press Ctrl-Alt while dragging
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the modifier keys shown in the following table to move greater dis-
tances.

You can change the default distances that keyboard keys move 
objects; see “When dragging objects show original objects,” page 87.

Moving objects a specified distance
Use the Move command to specify distance and direction.

1 Select the objects you want to move and then choose Move in 
the Object menu.

2 In the Move dialog box, enter values in the first or second row 
of text boxes. Use positive numbers to move up and to the right. 
Use negative numbers (type a minus sign before the numbers) to 
move down and to the left.

3 Click Apply to preview or OK to implement the Move settings.

Arranging objects in the stacking order
Each object in a Canvas document is part of a stack that holds all 
objects on the same layer (in illustration and presentation documents) 
or page (in publication documents). Each object has a position in the 
stack. Unless you rearrange objects, the newest object is in front of 

To move objects Do this

1 pixel to the left, right, up or 
down

Press left, right, up or down keyboard 
arrow key

10 pixels to the left, right, up or 
down

Mac: Press Command and an arrow key

Windows: Press Alt and an arrow key

50 pixels to the left, right, up or 
down

Mac: Press Option and an arrow key

Windows: Press Ctrl and an arrow key

Up/down value

Distance value

Left/right value

Angle value

You can specify angular move-
ment in 0.01 degree incre-
ments. The angular direction 
depends on the coordinate sys-
tem setting (standard or engi-
neering) in the Preferences dia-
log; see “When dragging 
objects show original objects” 
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the stack and the oldest object is in the back. An object that you cre-
ate or paste appears at the front of the stack. 

Stacking order affects the appearance of an illustration when you 
view it and print it. Like actual objects placed in a stack, the front 
object in the stack can block objects behind it. An object’s position in 
the stack also is a factor in alignment and combining operations. 

Commands in the Arrange submenu in the Object menu let you 
change an object’s position in the stack. You can move objects to the 
front or back, and you can move objects one level at a time toward 
the front or back of the stack.

◆ To change an object’s position in the stack: Select the object 
and choose a command in the Arrange submenu in the Object menu.

Arranging objects on layers, pages, and slides
Commands in the Arrange submenu let you move and copy objects 
from one layer to another (in illustration and presentation docu-
ments), one page to another (in publication documents), and one slide 
to another (in presentation documents). 

◆ To send or copy objects to another location: Select the 
objects and choose an Arrange command in the Object menu. (In pre-
sentation documents, to send or copy objects to another layer on the 
same slide, press Shift, then choose an Arrange command.) In the list 
of layers, pages, or slides, select the destination for the selected 
objects; click OK. The destination can’t be a locked layer, page, or 
slide. (You can’t send objects to a slide if its first layer is locked.)

Command Result

Bring to Front Moves selected objects to the front of the stack

Send to Back Moves selected objects to the back of the stack

Shuffle Up Moves selected objects one step toward the front 

Shuffle Down Moves selected objects one step toward the back

Command Result

Send to Layers/
Pages/Slides

Sends the selected object to the location you choose, 
deleting the original

Copy to Layers/
Pages/Slides

Copies the selected object to the location you 
choose, leaving the original

Select destinations for objects. 
Shift-click two items to select a 
range, or Command-click (Mac) 
or Ctrl-click (Windows) to select 
multiple items. Clear deselects 
all items. 
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Locking and unlocking objects
When you want to secure objects from unintentional changes, you 
can lock them. A locked object can’t be moved, edited or deleted, and 
its attributes can’t be changed. If you try to alter a locked object, Can-
vas alerts you that the selection is locked. However, you can select 
and copy locked objects and the copies won’t be locked.

◆ To lock or unlock objects: Select the objects that you want to 
lock or unlock. Choose Lock or Unlock in the Object menu.

How commands affect locked objects

If you apply the Align command to several selected objects, and one 
object is locked, the other objects align to the locked object. 

If you group several objects and one of the objects is locked, all the 
objects are positioned behind the locked object in the stacking order.

Aligning and distributing objects 

You can use the Align palette to quickly and precisely position 
objects. As the reference point for alignment and distribution, you 
can choose points on the objects, a page, or a document. The Align 
palette can stay onscreen as you work with different selections, mak-
ing it easy to quickly access these features.

You can apply alignment and distribution options to vector objects, 
group objects, paint objects, and text objects. You can align and dis-
tribute objects in separate or combined operations. 

Aligning objects When aligning objects, Canvas lines up key 
points on the objects in relation to the reference point you choose. 
You can choose left, right, top, bottom, or center alignment.

Distributing objects When distributing objects, Canvas spreads 
them out over a specified area and equalizes the space between the 
key points. You can choose left, right, top, bottom, inside, outside, or 
center as methods for distribution. For example, if you choose left 
edges for distribution, the left-most point in each object is an equal 
distance from the leftmost point in each of its neighbors. 

If one of the objects you select for alignment is locked, other objects 
align relative to it. When distributing objects, Canvas places all 
objects relative to each other.
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Rotating, skewing, and flipping objects
You can rotate Canvas objects clockwise or counterclockwise, flip 
them on one or both axes, and skew their bounding boxes. You can 
rotate and skew around an object’s center, or move the centerpoint to 
any location.

When you rotate an object, the object’s bounding box also rotates. If 
you drag a selection handle of a rotated object, the bounding box 
changes shape in the rotated orientation, so you can resize an object 

Align palette

Choose Align in the Object 
menu to open the palette. 
Select the objects you want to 
arrange. Click Apply to imple-
ment the current settings.

A Choose the reference for 
alignment and distribution:

Each Other: With respect to 
the other selected objects.

Grid: To the nearest grid incre-
ment.

Page: With respect to the 
printer page or tile.

Document: To a specified 
location in the document. If 
you center an object in a multi-
page illustration, portions can 
appear on multiple tiles.

In the Vertical and Horizontal 
areas, click buttons for align-
ment and distribution options. 
Active buttons are recessed. 

You can select an alignment or 
distribution option, but not 
both, in each area. 

B To specify no alignment or 

distribution, click the first button 
in the Align row.

C Vertical Align. (Left to right) 
None, top, center, and bottom.

D Vertical Distribute. Inside, 
top, center, and bottom.

E Horizontal Align. None, 
left, center, and right.

F Horizontal Distribute. In-
side, left, center, and right.

G Outside Pen. Check this 
option to use the outside edge 
of objects’ strokes when align-
ing or distributing objects. Oth-
erwise, Canvas uses the center 
of the stroke.

A

C

D

E

F

G

B

B

Align to Page

Align to Grid

Align to Each 
Other
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without distorting its basic shape. If you need to, you can also return 
the rotated bounding box to its original orientation with the Convert 
To Paths command in the Paths submenu in the Object menu.

◆ Removing effects: After you rotate, skew, or flip objects, you 
can return them to their original orientation and shape. Select the 
objects and choose Remove Effects in the Effects menu.

Rotating and skewing in freeform mode
When you put an object in freeform mode, you can rotate and skew 
it by dragging special handles.

◆ To put an object in freeform mode: Select the object and 
choose Freeform in the Effects menu. Rotation and skewing handles 
and the object’s centerpoint appear.

You can also put a selected object in freeform mode by clicking it. 
This depends on a setting in the Preferences dialog box; see “General 
Canvas preferences” on page 85.

◆ To end freeform mode: Click away from the object, or press 
Enter (Mac) or Esc (Windows).

Rotating objects in freeform mode

In freeform mode, the circular handles at each corner of the bounding 
box are rotation handles. The circle and crosshair in the center of the 
object is the point around which the object rotates.

◆ To rotate an object in freeform mode: Drag one of the four 
corner handles. An outline of the object rotates as you drag a handle.

◆ To set the center of rotation: Drag the centerpoint to a new 
location anywhere on the screen. To make the centerpoint snap to one 
of the handles or the center, press Shift as you drag.

Skewing objects in freeform mode

When an object is in freeform mode, you can slant its shape by drag-
ging the horizontal and vertical skew handles. Skewing an object 
reshapes it by changing the relationship of the horizontal and vertical 
axes to the skew centerpoint.

Canvas skews objects around a centerpoint that you can position to 
achieve the effect you want. You can drag the centerpoint to any 
position inside or outside the object. The location of the skew center-
point changes the effect of dragging a skew handle on the object. 

Object in freeform mode

Centerpoint

Rotation handles (highlighted) in 
freeform mode

Center of 
rotation
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To position the centerpoint on one of the freeform handles or in the 
center of the object, Shift-drag the centerpoint to place it.

◆ To skew an object horizontally: Drag a horizontal skew handle 
to the left or right. 

◆ To skew vertically: Drag a vertical skew handle up or down.

Rotating objects with the Rotate command
For precise rotations, you can use the Rotate command to rotate 
selected objects in 0.01 degree increments around a center of rotation 
you specify. This command is useful when you need to rotate multi-
ple objects an exact amount.

1 Select the object you want to rotate.

2 Choose Rotate in the Effects menu.

3 In the Rotate dialog box, click the clockwise or counterclock-
wise button to choose a rotation direction.

4 Enter the rotation angle in degrees in the Angle text box.

5 The Center edit box shows the center of rotation as a solid han-
dle. To change it, click one of the hollow handles on the bounding 
box; the gray handle snaps to the new location.

6 Click Apply to preview the settings, or OK to implement the 
settings and close the dialog box.

Skew handles (highlighted) in 
freeform mode Horizontal skew handle

Vertical skew handle

Center of rotation edit box
Clockwise and counterclockwise 
rotation buttons
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Editing rotated objects 

When you rotate an object, it’s bounding box also rotates. This lets 
you reshape and resize the object in rotated space: you can drag a 
handle on the object’s bounding box and the sides keep their rotated 
orientation, which prevents distortion of the original shape.

Flipping objects
You can flip objects horizontally, vertically, and both horizontally 
and vertically, with the Flip commands in the Effects menu. You can 
flip individual objects, multiple selected objects, or grouped objects. 
When you flip a group object, objects included in the group flip 
around the axes of the group’s bounding box.

◆ To flip a selected object from top to bottom: Choose 
Flip➤Vertical in the Effects menu. The Vertical command flips the 
selection’s vertical coordinates over its horizontal axis.

The bounding box of 
a rotated square also 
rotates...

... so that reshaping 
the bounding box 
maintains the same 
basic shape, shown by 
the dotted lines

If you convert the 
rotated shape to 
paths and re-orient 
the bounding box...

... the object 
distorts, shown by 
the dotted lines, 
when you reshape 
the bounding box

Original object Flip➤Horizontal Flip➤Vertical Flip➤Both Axes

Vertical axis

Horizontal axis
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◆ To flip a selected object from left to right: Choose 
Flip➤Horizontal in the Effects menu. The Horizontal command flips 
the selection’s horizontal coordinates over its vertical axis.

◆ To flip a selection around both axes: Choose Flip➤Both 
Axes in the Effects menu. Canvas flips the selection’s horizontal 
coordinates over its vertical axis and its vertical coordinates over its 
horizontal axis.

Scaling objects
The Scale command in the Object menu provides several options for 
enlarging or reducing objects. You can scale by a percentage or ratio, 
horizontally and vertically. You can also scale text and stroke 
weights along with the object.

To scale an object

1 Select one or more objects and choose Scale in the Object 
menu to open the Scale dialog box.

2 Select a scaling method in the Scale By pop-up menu. The con-
figuration of the dialog box depends on which option you choose.

Percentage You can specify vertical and horizontal percentages. 
Scaling an object 150 percent is the same as increasing the object’s 
size by a factor of 1.5, for example.

Ratio You can specify horizontal and vertical scaling factors as 
ratios by entering numbers in each set of two boxes.

Depending on the scale method 
you choose, the Scale dialog box 
displays different options.
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For example, to scale an object to one-third its original height, enter 
“1” in the first text box, and “3” in the second. 

3 To scale an object vertically and horizontally by the same 
amount, turn Proportional on.

4 To maintain the proportion between an object’s pen size the 
overall size of the object, turn Scale Pen on.

5 If one of the selected objects contains text, you can turn Scale 
Text on to change the size of the characters. Otherwise, text 
remains the same size.

6 Click Apply to implement the settings.

Object data and styles
The Object Specs palette provides information about a selected 
object. The palette contains Data, Options, and Styles tabs. These 
tabs let you 

• name an object

• change an object’s coordinate position

• view and adjust an object’s dimensions

• set printing and output options for an object

• create and apply object styles

◆ To use the Object Specs palette: Choose Object Specs in the 
Object menu. You can keep the palette open while you work; the data 
changes with each object you select. You can change coordinates, 
dimensions, or other settings and click Apply to implement them.

Data tab Displays a selected object’s type, position, and dimen-
sions. The specific information depends on the type of object you 
select. For example, Canvas displays the angular size of arcs.

Styles tab Provides descriptions and examples of object styles, and 
lets you create, modify, and apply styles.

Options tab Lets you designate an object as non-printing, and 
contains advanced printing options, including overprinting and trap-
ping for color separations. For more information on advanced print-
ing options, see Canvas on-line Help.

✔Tip
You can also scale an entire 
document when you print it, 
without changing the objects in 
the document, by specifying a 
scaling factor in the Print or 
Printer Setup dialog boxes.
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Viewing and changing object data
The Data tab displays information for a selected object or group 
object. If you select a group object, you can change the group’s size 
and coordinates but not an individual object within the group.

General dimension and position data for objects

Canvas describes an object’s position and dimensions using the loca-
tion, height, and width of the object’s bounding box relative to the 
document rulers. For line objects, the Data tab shows the horizontal 
and vertical difference between the endpoints.

In the pop-up menu at the top of the tab, you can choose what type of 
information you want to see. 

• Choose Top/Bottom to display the position of the top, bot-
tom, left, and right edges of the selected object, relative to 
the document rulers. 

• Choose Height/Width to display the vertical and horizontal 
dimensions of the selected object.

You can change the values in the text boxes to resize or reposition the 
object. If Keep Proportions is checked, Canvas maintains the propor-
tions of the object if you change either the height or width (on Mac, 
the calculation occurs when you press the Tab key or click Apply).

Area Shown when Canvas can calculate the area occupied by the 
object’s bounding box.

Perim Shown when Canvas can calculate the perimeter, or distance 
around the object’s bounding box.

Type of object, usually, the tool 
that created the object

Enter a name for the object

Dimension and position data for the 
selected object 

Select the type of data 

Object number (assigned by 
Canvas)

Turn on the relative height and 
width the same

✔Tip
If you want to display the 
Object Specs data with more 
significant digits, you can 
change the setting using the 
Preferences command in the 
File menu. If you want to use 
different measurement units, 
you can change them using the 
Document Setup command in 
the Layout menu.
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Some additional information is available for specific types of objects, 
as shown in the following table.

Working with object styles
A style is a set of attributes you can apply to objects. Styles help you 
maintain consistency and make applying attributes easier. You can 
edit and reapply styles to objects, rather than editing each attribute.

To create an object style

1 Select an object on which you want to base a style.

Type of 
object Data shown Description

Line Start/End

Delta V/H

Length/Angle

Position of the first and last endpoints of the line

Differences in vertical and horizontal positions of the endpoints of the line

Length of line and degree of pitch

Arc Start ˚

∆˚

Starting point of the arc in degrees

Length of the arc segment in degrees

You can specify the coordinate system (standard or engineering) using 
the Preferences command in the File menu.

Rounded 
rectangle

Diag Sets the roundness of the corners; can be a positive or negative value

Object styles

The Styles tab in the Object 
Specs palette lets you create, 
apply, and edit object styles.

Object style. Select saved 
object styles from the pop-up 
menu. 

The scroll list shows the fill, 
stroke, pen size, miter, dash, 
arrow and arrowhead settings 
for the selected style. 

Create. Click to create an 
object style from a the 
attributes of a selected object. 

Edit. Click to change attributes 
of the current style. 

Delete. Click to delete the cur-

rent style.

Apply. Click to apply the cur-
rent style to selected objects.

Style sample

Description of 
style attributes
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2 Click the Create button in the Object Specs palette. 

3 In the dialog box, type a style name in the Name text box. 

4 Select the check boxes for attributes you want to include in the 
object style and click OK to save the style.

The following attributes of a selected object can be saved as a style.

Fill Ink The fill ink of the object in the style. The name of the fill 
ink appears to the right of the check box.

Pen Ink The pen ink of the object in the style. The name of the pen 
ink appears to the right of the check box.

Stroke The stroke attributes of the object, such as pen size and 
miter, in the style.

Dash The dash pattern of the object in the object style.

Arrow The arrowhead style of the object in the style.

To edit a saved object style

After you create an object style, you can modify it at any time. 

1 To edit an object style, choose the style you want to edit in the 
Object Style pop-up menu.

2 Click the Edit button to open the Edit Object Style dialog box. 
The object properties for the selected style appear in the dialog box.

3 To change the name of the style, type a new name in the Name 
text box.

4 To add or remove attributes from the style, change the Fill, 
Stroke, Pen, Dash, or Arrow checkbox settings.

5 To change the style attributes, use the pop-up menus next to 
Fill, Stroke, Pen, Dash, or Arrow to select new settings.

 Fill ink name

Object style name

Pen ink nameCheck the options to include
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◆ To delete an object style: In the Object Style dialog box, 
choose the name of the style you want to delete in the Object Style 
pop-up menu and click the Delete button.

Setting print properties for specific objects
You can tell Canvas to treat specific objects differently when printing 
the document. The Options tab in the Object Specs dialog box lets 
you set objects to not print, overprint, or trap.

When performing color separations, you can set overlapping objects 
to overprint. In general, overlapping objects “punch” out an area 
from the object behind it. By turning the Overprint object setting on, 
you can tell Canvas to print overlapping colors without removing 
areas from the bottom object.

You can also tell Canvas to trap selected overlapping objects when 
printing separations. When objects of different colors overlap, there 
is the potential for a gap to appear between separated colors. Trap-
ping overlaps colors slightly to close this gap.

Canvas lets you specify two types of trap: choke and spread. A choke 
trap occurs when a background color closes a gap with another color 
in front of it. This gives the impression of slightly reducing the area 
of, or “choking,” the front object. A spread trap occurs when the front 
color expands to fill the gap with the back color.

Fill ink name

Object style name

Pen ink name
Pen attributes
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About macro objects and
8

MACRO OBJECTS AND CLIP ART

You can speed up many graphic projects by taking advantage of reus-
able macro objects and ready-made illustrations. This chapter 
describes how to use the Gallery palette to work with macro objects 
and the Canvas clip art collection.

About macro objects and clip art
The Gallery palette gives you access to macros and Canvas clip art. 
Press the Gallery tool in the Object toolbar to open the Gallery pal-
ette. To make the palette floating, drag it away from the toolbar.

Clip art is a name for ready-made illustrations. The Canvas clip art 
collection contains thousands of high-quality illustrations that you 
can use in any illustration, publication, or presentation. You can eas-
ily resize, change colors, edit, and apply special effects to the illustra-
tions in the Canvas clip art collection, the same as you would any 
vector drawing or image.

The clip art illustrations provided with Canvas are stored in Canvas 
illustration documents. Each document contains one or several small 
illustrations. You can locate specific items and preview the illustra-
tions using the Art tab of the Gallery palette.

Macro objects are illustrations that you store in the Macros tab of the 
Gallery palette. You can create a macro object from any vector, text, 
or paint object. After making an illustration a macro object, you can 
use the Gallery tool to place macro copies of the illustration. The 
copies are linked to the original macro object, and if you change the 
original, the copies also change.

Macro objects make it easy to place and change frequently used illus-
trations. You can save time by creating macro objects from elements 
you intend to use repeatedly, such as logos, symbols, and floor plans. 
For example, after designing a logo, you can make the illustration a 
macro object and use the Gallery tool to place copies in your docu-
ment. If you decide to change the logo, you can change all the copies 
at once by replacing the original macro object in the Gallery palette. 

Gallery tool
 clip art 119
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Adding clip art to Canvas documents
The Canvas software package includes an extensive collection of clip 
art ranging in topic from animals and plants to business and technical 
symbols. The clip art files are distributed among the CD-ROMs in 
the Canvas software package and are in Canvas file format.

The Art tab in the Gallery palette lets you browse Canvas clip art 
files, then choose an illustration and place it in a document. In addi-
tion, because Canvas clip art files are indexed, you can perform key-
word searches to locate all clip art files pertaining to a particular 
topic, regardless of which CD-ROM a clip art file is on.

Note: If you’re running the Mac OS and your computer has trouble 
recognizing the clip art CD-ROMs in the Canvas software package, 
make sure you have the extensions, Foreign File Access and ISO 
9660 File Access, installed and active on your system.

To browse clip art in a folder

1 Press the Gallery tool in the Object toolbar to open the Gallery 
palette. Drag the palette away from the toolbox and click the Art tab 
to bring it to the front, if necessary.

The search options shown here 
let you find clip art by file name 
in a folder or directory. When 
you search the clip art index, the 
search options are different.

Browse and select clip 
art in this scrolling grid
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2 On the Art tab of the Gallery palette, press the right-arrow but-
ton and choose View Directory in the pop-up menu.

3 In the dialog box, select any Canvas file in the directory or 
folder you want to browse and click Open. Thumbnail previews of 
the clip art illustrations in the folder or directory appear on the Art 
tab.

◆ To toggle between large and small previews: On the Art tab 
in the Gallery palette, select an illustration, press the right-arrow but-
ton and choose Toggle Cell Size in the pop-up menu.

To find clip art by name in a folder

When you’re browsing clip art on the Art tab, and you know the file 
name of an illustration you want to find, rather than scrolling 
through the tab or using View Directory to locate the file, you can 
use the search feature in the Gallery palette to find and select the 
illustration. 

1 If necessary, follow the steps under “To browse clip art in a 
folder” on page 120.

2 On the Art tab, click the triangle button at the lower-left of the 
palette to show the search options.

3 In the text box, type the text you want to search for. When you 
perform the search, Canvas will find the clip art file in the folder or 
directory you’re browsing that starts with the text you type.

✔ Tip
On the Art tab, you can browse 
any Canvas documents that 
have been saved with pre-
views. To save documents with 
previews, in the Save As dialog 
box, turn on “Create Preview” 
(Mac) or “Save Preview” (Win-
dows).

Choose Toggle Cell Size in 
the pop-up menu to switch 
between large and small 
previewsClip art file name

Art tab pop-up menu
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4 To begin searching, click Search. Canvas selects the clip art 
illustration that meets the criteria. If more than one illustration 
meets the criteria, Canvas selects the first illustration it finds.

5 To remove the current search criteria so you can enter new cri-
teria, click Clear.

To search the clip art index using keyword searches

This type of search is useful when you want to search the entire Can-
vas clip art collection, rather than a folder or directory, to find clip art 
by subject.

1 On the Art tab of the Gallery palette, press the right-arrow but-
ton and choose Open Library in the pop-up menu. 

2 In the dialog box, locate the Canvas clip art index file you want 
to search and click Open; index files have the extension “.ndx” in 
the file name. After you locate the index file and click Open, pre-
views of the clip art in the index appear on the Art tab and the Gal-
lery palette changes to show the index search options.

3 Choose a search option in the pop-up menu.

4 In the text box, type keywords to search for. You can type mul-
tiple keywords, separated by spaces, to find illustrations that match 
one or more keywords. 

• You can tell Canvas to find art with all or any of the key-
words by changing the “Search using And criteria” setting. 
For example, you can type “car tree.” With this setting off, 
Canvas searches for clip art of either cars or trees. With this 
setting on, Canvas searches for clip art of both cars and 
trees.

5 To begin searching, click Search. Canvas displays thumbnail 
previews of all clip art that meets the criteria.

6 To remove the current search criteria so you can enter new cri-
teria, click Clear. When you click Clear after performing a search, 

Choose To find

Matches Exact matches of the name you type

Contains Any name with the text you type

Starts with Any name that begins with the text you type

Ends with Any name that ends with the text you type
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Canvas redisplays all of the clip art previews. This is the equivalent 
of performing a search for all clip art.

Placing clip art

After finding a clip art illustration you want to insert, you can place 
the illustration at its original size, or scale as you place it.

◆ To place clip art: Click a thumbnail preview in the Art tab to 
select the illustration you want to place.

• To place clip art at its original size, click in the document 
where you want to place the upper-left corner of the illustra-
tion. 

• To scale clip art as you place it, drag the pointer to set the 
bounding box size. Canvas fits the illustration to the bound-
ing box.

Note: When selecting clip art from the index, remember the Art tab 
shows clip art by subject, regardless of the CD-ROM an illustration 
is on. If you try to place clip art that isn’t on the current CD-ROM, 
Canvas asks you to insert the CD-ROM containing that illustration.

Using commercial clip art packages 

You can purchase many commercial clip art packages of illustrations 
and raster images. Commercial packages use standard and propri-
etary file formats. If you want to use third-party clip art, ask the man-
ufacturer about the file format and verify that Canvas can 
successfully open the files. For more information, refer to the chapter 
“File and data exchange” on page 57.

Using macro objects
Macro objects can help you create illustrations quickly, uniformly, 
and precisely. Macro objects are especially useful for technical draw-
ings, diagrams and other frequently used illustrations. For example, a 
landscape designer can create sets of macros for trees, shrubs, and 
structures. An electrical engineer can create macros for gates, resis-
tors, and other circuit components. Project managers can build orga-
nizational charts with macros of various shadowed text boxes.

You can create, delete, and modify individual macro objects, and also 
save them as macro sets. You can store sets for specific projects, and 
load sets as you need them.

Macros are document-level objects. In other words, if you switch 
between two open document windows, each using a different macro 
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set, you will see the thumbnails in the Gallery palette switch between 
the two macro sets.

To create a macro object 

You can convert nearly any Canvas object into a macro object by 
dragging it to the Macros tab of the Gallery palette.

1 Create the illustration that you want to use as a macro.

2 If necessary, press the Gallery tool in the Object toolbar to 
open the Gallery palette. Drag the palette away from the toolbox 
and select the Macros tab.

3 Drag the object into the window on the Macros tab. In the dia-
log box, type a name for the macro in the text box and click OK. A 
preview of the macro appears in the Gallery palette.

◆ To delete a macro: On the Macros tab in the Gallery palette, 
select the macro you want to delete. Press the arrow button on the 
bottom-right of the tab and choose Delete in the pop-up menu. The 
macro is removed from the palette but copies in the document aren’t 
affected.

◆ To toggle between large and small macro previews: On the 
Macros tab in the Gallery palette, select a macro, press the right-
arrow button and choose Toggle Cell Size in the pop-up menu.

Placing macro objects
After you create macros, you can place them in a Canvas document. 
You can insert them at their original size, or scale as you place them. 

◆ To place a macro object: Click a preview in the Macros tab to 
select the macro illustration you want to place.

• To place the macro at its original size, click in the document 
where you want the top-left corner of the macro to appear.

Macros tab pop-up menu
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• To scale the macro as you place it, drag the pointer to set the 
size of the bounding box of the object you are placing. Can-
vas scales the object to fit the bounding box you specified.

To find a macro in the Gallery palette

1 On the Macros tab of the Gallery palette, click the triangle but-
ton at the lower-left of the palette to show the search options.

2 In the text box, type the text you want to search for. When you 
perform the search, Canvas will find the macro in the palette that 
starts with the text you type.

3 To begin searching, click Search. Canvas selects the macro in 
the palette that meets the criteria. If more than one macro meets the 
criteria, Canvas selects the first macro it finds.

4 To remove the current search criteria so you can enter new cri-
teria, click Clear.

Editing macro objects 
If you want to update all copies of a macro in a document, you can 
replace the original in the Macros tab. If you want to replace a macro 
with a copy based on that macro, you must first unlink the copy from 
the original. See “Unlinking macros,” next.

To edit the path of a macro copy, first select the copy and then choose 
Path➤Convert to Paths in the Object menu or unlink the object (see 
“Unlinking macros,” next); both methods let you edit the object as a 
path, but they also unlink the object from the original macro.

To replace a macro in the Gallery palette

1 Create the object you want to use to replace the macro.

2 Drag the new object to the Macros tab and drop it on the macro 
you want to change.

3 When Canvas asks if you want to replace the existing macro, 
click Yes to change all copies of the macro to the new object.

To find a macro in the 
palette, type the text you 
want to search for in the text 
box and click Search. Canvas 
will find the macro that starts 
with the text you type.
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Unlinking macros

By unlinking placed macros, you can prevent them from changing 
when the macro in the Gallery palette is modified. You also make it 
possible to use a placed macro to modify its parent macro and to use 
path-editing techniques. 

◆ To unlink a macro copy: In the document, select the macro cop-
ies you want to unlink from the original. In the Gallery palette, 
choose Unlink in the pop-up menu.

Using macro sets
You can save macros in named sets for use with specific projects or 
types of illustrations. Using this feature, you can load only the mac-
ros that you need at the time.

◆ To save all macros in the palette as a set: On the Macros tab 
of the Gallery palette, press the right-arrow button and choose Save 
Set in the pop-up menu. In the dialog box that appears, type a name 
for the set, specify a location to save the set, and click Save.

◆ To load a macro set into the palette: On the Macros tab of the 
Gallery palette, press the right-arrow button and choose Append Set 
in the pop-up menu. In the dialog box that appears, specify the file 
name and location of the macro set you want to load, and click Open. 
The macro set is added to any macros already in the palette.

◆ To load a Canvas 3.5 macro set into the palette: On the Mac-
ros tab of the Gallery palette, press the right-arrow button and choose 
Append Canvas 3.5 Set in the pop-up menu. In the dialog box that 
appears, specify the file name and location of the Canvas 3.5 macro 
set you want to load, and click Open. The macro set is added to any 
macros already in the palette.
6 Chapter 8: Macro objects and clip art



The Inks
9

INKS: COLORS AND PATTERNS

Solid colors and multi-colored patterns that you apply to vector 
objects are called inks in Canvas. You can apply inks to the interiors 
and outlines of vector objects and text characters.

This chapter describes how to create and apply inks, from basic solid 
color inks to custom multicolored inks. It also explains how to use 
various color systems to define inks.

The Inks palette
You use the Inks palette to apply inks to objects, select the current 
inks for new objects, and create new inks. To open the Inks palette, 
press the pen or fill ink icon at the bottom of the toolbox. For details, 
see “Applying preset inks” on page 130.

The Inks palette contains five types of inks on separate tabs. Each tab 
has preset inks and a manager you can use to customize inks.

Color inks Color inks (on the Color tab) are solid colors. You can 
use CMYK, RGB and HSL color systems, and commercial color ref-
erence systems, to define color inks.

Gradient inks Gradient inks (on the Gradient tab) are smooth 
blends between two or more colors.

Hatch inks Hatch inks (on the Hatch tab) are patterns of lines. 
Hatch inks can incorporate other pen and fill inks. 

Symbol inks Symbol inks (on the Symbol tab) are patterns of vector 
objects. Symbol inks can include any other ink as a background.

Texture inks Texture inks (on the Texture tab) are patterns of raster 
images. Texture inks can include other inks as backgrounds.

How inks apply to objects
You can apply inks to two areas of vector objects and text: fill inks 
cover the interior of objects and text characters; pen inks cover the 
outline stroke of objects and text characters. You can apply one fill 
ink and one pen ink to an object and to a text character.

Inks palette, with Color tab 
selected

✔Tip
You can also apply inks to the 
background of a text object. 
See the Tip on page 295.
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You can apply different types of inks to an object — a gradient fill 
ink and a texture pen ink, for example. If an object has neither a pen 
ink nor a fill ink, the object is not visible. 

Applying fill inks to open and closed paths

Whether a vector object path is open or closed affects the appearance 
of its fill ink. In a closed path, the ink completely fills the object’s 
interior; in an open path, the ink fills inside the path as if the path 
were closed by a straight segment between its endpoints.

Default and current inks 

By default, Canvas applies white fill ink, black pen ink, and a 1-point 
pen stroke to new vector objects. For new text, Canvas applies black 
fill ink, no pen ink, and no stroke to the text characters. 

The current inks are the inks that Canvas applies to new vector 
objects you draw. The squares in the pen ink and fill ink icons in the 
toolbox display the current inks. When you apply inks to existing 
objects, the current inks do not change. For text, you must set current 
inks using type styles; see “Applying type styles” on page 282.

◆ To change the current pen or fill ink: Make sure no objects are 
selected in the document, then press the pen ink or fill ink icon to 
select a current ink in the Inks palette.

This object has a pen ink and a fill 
ink; both are basic color inks.

Pen ink

Fill ink

The triangle has a pen ink but no 
fill ink, so the circle in back is 
visible through it.

This path has a pen ink and no fill 
ink.

The path above with a pen ink 
and a fill ink.

Current pen ink

Current fill ink
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Color Dropper tool
The Color Dropper tool lets you pick up colors and inks from any-
where on the screen, and make them the current pen or fill ink. You 
can also use the Color Dropper tool to apply colors and inks to exist-
ing objects.

The Color Dropper helps you make sure that you use colors consis-
tently throughout a document. In addition, this tool can help you 
identify colors from documents that you import into Canvas.

The Color Dropper is also very useful in photo-retouching, letting 
you match colors, tones, and shades in images. See “Picking colors 
from images and objects,” page 311.

To use the Color Dropper to select a current ink

In vector objects and text, the Color Dropper can pick up multi-col-
ored textures, gradients, hatches, and symbols as inks; in paint 
objects, the Color Dropper selects the solid color of the pixel you 
click.

1 Select the Color Dropper tool in the Effects Tools toolbar.

2 Click an object to use its ink as the current fill ink. Option-
click (Mac) or right-click (Windows) an object to use its ink as the 
current pen ink. 

◆ To drop the current color on an object: With the Color Drop-
per tool, Ctrl-click an object to apply the current fill ink to an object. 
Ctrl+Option-click (Mac) or Ctrl+right-click (Windows) an object to 
apply the current pen ink to a stroke.

◆ To pick up colors from outside the Canvas window: With the 
Color Dropper tool, drag from inside the Canvas window to other 
areas of the screen. As long as you hold down the mouse button, the 
Color Dropper tool stays active and samples colors. Look at the ink 
icons in the toolbox to see what color the tool is sampling.

Color Dropper tool
The Inks palette 129
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Using the Inks palette in a floating window

To keep the Inks palette open, press either ink icon in the toolbox 
and drag the palette away. The palette remains open in a floating 
window.

To apply inks to selected objects: Click the pen ink (A) or fill ink 
(B) icon, then click a preset ink. If you click an ink with no objects 
selected, the ink becomes the current ink applied to new objects.

To drag and drop inks: Drag an ink from the grid to an object’s 
outline (for a pen ink) or the inside of the object (for a fill ink).

Names: Check this box (C) to show the names of inks in the grid.

To remove an ink from the palette: Drag it to the trash can (D).

Applying preset inks 

A grid on each tab in the Inks 
palette holds preset inks that 
you can apply as pen or fill inks.

A Pen ink icon. Press to select 
pen inks for object outlines.

B Fill ink icon. Press to select 
fill inks for the insides of objects.

C Ink tabs. Select the type of 
ink you want to apply. 

D Preset inks. Select an ink in 
the grid. Use the scroll bars if all 
the preset inks aren’t visible.

E No ink. Click this tile to re-
move inks, or to make the de-
fault for new objects “no ink.” 

• To apply inks to existing 
objects, select the objects and 
then choose pen and fill inks.

• To change the inks that Can-
vas applies to new vector 
objects, deselect all objects, 
then choose pen and fill inks. 
The ink icons in the toolbox 

show the current inks (these 
inks don’t apply to text).

Because pen inks are applied 
to the strokes of objects, the 
appearance of an object’s pen 

ink is affected by the shape of 
the object’s stroke. For more 
information, see “How inks 
affect strokes” on page 145.

A

B

D

CE

Preset inks appear in the Inks palette on five tabs: Color, Gradient, 
Texture, Symbol, and Hatch.

The Inks 
palette opens 
when you 
press either of 
the ink icons in 
the toolbox. 
Select a tab 
and then an ink 
in the grid.

A C DB
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Creating and customizing inks
If preset inks don’t meet your needs, you can use the Inks configura-
tion managers to create your own inks. Managers are sets of controls 
at the bottom of the tabs in the Inks palette. You can flip open the 
managers to create inks, adjust inks in objects, and change the pal-
ette’s preset inks.

Described next are ways to change the Inks palette and use Inks man-
agers in general. The rest of the chapter explains how to customize 
color inks, gradient inks, hatch inks, symbol inks, and texture inks.

Changing the Inks palette
You can do the following to customize the Inks palette:

• Delete preset inks you no longer want to use.

• Add new inks to the palette.

• Save the preset inks on each tab in an inks file.

• Load inks from a file to replace the preset inks.

• Append inks from a file to add them to the palette.

When you add or delete inks in the palette, the changes are recorded 
in a Canvas Settings file, not in the Canvas document, so the palette 
contents remain the same the next time you use Canvas.

◆ To save, load, or clear preset inks: Press the button at the bot-
tom-right corner of the palette and choose a command in the pop-up 
menu. The commands include the name of the current ink tab, so the 
command on the Color tab is Load Colors, for example.

You can save, load, and append inks on one tab at a time in the Inks 
palette. When you load or append inks, if you select a file that doesn’t 
contain inks from the current tab, Canvas won’t load the inks.

Load... Loads inks from a palette file, replacing the tab’s preset 
inks. In the dialog box, select a file and click Open.

Append... Adds inks from a palette file to the preset inks on the 
current tab. In the dialog box, select a palette file and click Open.

Save... Saves the current tab’s preset inks in a palette file. In the 
dialog box, select a location, type a file name, and then click Save.

Clear... Removes the preset inks (except “no ink”) from the current 
tab. On the Color tab, Canvas restores black and white (CMYK) inks 
after clearing all the preset inks.
Creating and customizing inks 131
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Using Inks managers

Open the Inks managers when 
you want to create inks or 
change the preset inks on the 
tabs in the Inks palette.

A Click to flip the managers 
open or closed. If the Inks pal-
ette isn’t open, first press either 
of the ink icons in the toolbox 
and drag the palette away.

B Preview. This box shows 
the current ink. The preview 
changes as you modify the ink. 
When you click the Apply but-
ton, Canvas applies this ink. 
You can also drag the ink from 
the preview box to objects and 
into the grid of preset inks. 

To edit an object’s ink:
Click the pen (C) or fill icon 
(D), then select an object; its 
ink becomes the current ink in 
the manager. Modify the ink, 
then click Apply to apply the 
modified ink to the object.

To make a new ink:
Use the manager to custom-
ize the current ink. To name it, 
type in the text box (E). Then 
do any of the following:

• To add the ink to the palette, 
drag from the preview box (B) 
to the grid of preset inks.

• To make the ink the default, 
click the pen (C) or fill (D) 
icon, then click Apply.

• To apply the ink to a non-
selected object, drag from the 
preview box (B) to the inside 
or outline of the object.

When you create a new ink, be 
sure to add it to the palette or 
drag it to an object before 
selecting anything. Otherwise, 
the selection’s ink replaces the 
new ink in the manager.

A pop-up menu (F) contains 
commands that let you save 
inks and load inks on the cur-
rent tab. You can also clear the 
current tab’s preset inks to start 
with an empty palette.

Gradient manager

Symbol manager

Color manager

A

E

B

F

C

Hatch manager

B

B

D

E

E

Texture manager

B

E

B

E
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Color inks
You use the Color tab in the Inks palette to apply solid color inks. 
The Color manager lets you customize color inks, use several color 
reference systems, and specify spot colors.

For general instructions on using the Inks managers, see “Creating 
and customizing inks” on page 131.

Choosing color systems 

When the Color manager is open, you can choose from six color sys-
tems to define color inks. Canvas also offers several color models, or 
views, of the color systems. When you want to create a color ink, you 
choose a color system and color model. 

CMYK The default color system in Canvas is CMYK, from the 
four-color process used in commercial printing. In this system, you 
define colors as mixtures of cyan (C), magenta (M), yellow (Y), and 
black (K). To work with CMYK colors, you can choose CMYK 
Bars, CMYK Swatch, and CMYK Tints color models.

RGB Computer video displays mix red (R), green (G), and blue (B) 
to create colors. The RGB system is appropriate for graphics you will 
display on a monitor. You should avoid RGB colors in documents 
intended for commercial printing. To work with RGB colors, you can 
choose RGB Bars and RGB Tints color models.

HSL This system defines colors using hue (H), saturation (S), and 
lightness (L) values. It lets you change the saturation (intensity) and 
lightness (amount of black) in a color without changing its basic hue 
(such as red, orange, or green). To work with HSL colors, you can 
choose HSL Bars and HSL Wheel color models.

Commercial color reference systems

In the Color manager, you can use commercial reference system col-
ors. Be sure to consult printed reference guides (available from the 
manufacturers) to view the actual printed appearance of these colors. 

PANTONE The PANTONE System includes textile colors and 
colors for spot- and process-color printing on various paper stocks.

Toyo The Toyo Ink system provides more than 1,000 colors in nine 
sets for process-color printing on various paper stocks.

TRUMATCH A four-color process matching system, TRUMATCH lets 
you select more than 2,000 colors based on 50 hues with 40 tints and 
shades of each hue, plus four-color grays.

✔Tip
Colors displayed on a monitor 
can only approximate the 
appearance of printed colors. 
Be sure to discuss color repro-
duction with your commercial 
printer and obtain accurate 
proofs for color projects.
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Choosing color models

When you choose a color system in the pop-up menu in the Color 
manager, you can also choose one of the following color models.

Bars Use sliders or type in values to create colors. Available for 
CMYK, HSL, and RGB color systems.

Swatch Pick colors from a swatch grid that displays blends of two, 
three, or four colors in the CMYK system.

Tints Specify a tint color and amount in CMYK and RGB color 
systems. 

• Tinting with white screens the original color; the screen per-
centage is 100 minus the tint value (80 percent tint value 
results in 20 percent of the original color, for example). 

• For other tint colors, Canvas multiplies the tint value by the 
difference between the original and tint color values, and 
then adds the result to the original color values. 

Wheel In the HSL color system, view hue and saturation on a color 
wheel and use a slider to adjust lightness, or enter numeric values for 
all three components.

Creating color inks
You can create new inks to expand the preset inks selection and con-
vert inks from one color system to another.

1 If necessary, select the Color tab and open the Color manager 
in the Inks palette. The current ink appears in the preview box. 

2 Choose a color system and model in the pop-up menu.

3 Use the Color manager controls to change the ink’s color val-
ues. To restore the original ink, click the left preview box.

4 To name the ink, type the name in the text box. To define it as 
a spot color, check the Spot Color box.

5 To apply the ink to non-selected objects, drag it from the pre-
view box to the objects. To add the ink to the palette, drag it from 
the preview box to the grid at the top of the tab. Canvas adds the 
color at the end of the preset inks grid.

Bars model

Swatch model

Wheel model
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Color manager controls

The Color manager controls 
depend on the selected color 
system and model. Some con-
trols are common among the 
different color models.

A Current ink.

B Last-applied ink.

C Bars. Use the sliders, or en-
ter values in the text boxes, to 
specify color values. 
• RGB values go from 0 to 255.
• CMYK values go from 0 to 
100 percent. 
• HSL values go from 0 to 360 
degrees (hue) and 0 to 100 per-
cent (saturation and lightness).

D Spot Color. Check to set 
up a spot color. Spot colors 
print on separate plates when 
you make color separations.

E Tint Color. Select the color 
to apply to the current color. 

F Tint value. Enter the per-
centage of tint to be applied.

G Swatchbook. Shows colors 
made from 0-100% mixtures of 
two CMYK colors. To select a 
color, click in the swatchbook; 
the color values appear in the 
text boxes.

H Select the two colors for the 
swatchbook. To add a third or 
fourth color, enter percentages 
in the C M Y K text boxes. 

I Color wheel. Click in the 
wheel or drag the selector to 
pick a color, or enter values in 
the H S L text boxes.

J Lightness. Drag the slider, 

or enter a number in the L text 
box, to set the lightness for the 
entire color wheel.

K Gamut warning. When the 
current color can’t be printed 
with CMYK inks, a warning sym-

bol and color box appear. Click 
the color box to replace the cur-
rent color with the closest color 
that is within the CMYK gamut. 

Gamut warnings appear only in 
RGB and HSL systems.

C

D

E

F

H

H

I

J

B A

D

D

D

G

B A

B A

K
HSL Wheel

CMYK Swatch

CMYK Bars CMYK Tints
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Creating custom colors in pop-up palettes
In Canvas, dialog boxes and palettes that let you choose colors have a 
color icon that opens a pop-up palette. This color icon appears in sev-
eral places throughout the program, including image-editing features 
like the Channel Options dialog box, and vector effects like the 
Extrude palette and Gradient manager.

When you press (Mac) or click (Windows) the color icon to open the 
palette, you see the preset colors currently on the Color tab of the 
Inks palette. If the color you want isn’t in the pop-up palette, you can 
specify a new color in two ways:

• Use the Color manager in the Inks palette to create a new 
color, then add it to the preset colors in the palette (see 
“Using Inks managers” on page 132 for instructions). The 
new color will appear in the pop-up color palette throughout 
the program. This is the method you should use if you want 
to use the color more than once.

Color reference systems

When you choose a PAN-
TONE, Toyo, or TRUMATCH ref-
erence system color set in the 
Color manager, you can 
search for and select colors by 
name.

A Color name. The selected 
color’s name. Names of refer-
ence colors can’t be changed.

B Color system. Choose the 
reference system you want to 
use in the pop-up menu. 

C Color list. Click a color in 
the list to select it. Use the scroll 
bar to scroll the list.

D Current color preview.

E Page. The page number of 
colors shown in the color list. 
Enter a number to go to that 

page.

F Find. Click to select a color 
by name. In the Find dialog box, 
type the color name or number 
and click OK. Canvas selects the 
color (if found) in the color list.

G Tint Value. For PANTONE 
colors (except process colors), 
enter a screen percentage to 

apply to the selected color. Use 
100% for solid color and lower 
values for screens of the solid 
color.

Spot Color option. Available 
with some color systems, this 
option lets you specify colors 
to use as spot colors in separa-
tions.

A

B

C

D

E

F

G

Color icon
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• In the pop-up color palette, drag to (Mac) or click (Win-
dows) the Custom box to open the Color Editor dialog box, 
where you can create a new color without adding it to the 
palette. Use this method if you don’t need to use the color 
again.

The Custom box lets you use new colors immediately, without hav-
ing to switch back and forth between a dialog box and the Inks pal-
ette. It’s also useful when you want to use a color for a specific 
purpose, but don’t want to clutter the color palette with colors you’ll 
only use once.

The Custom box appears in pop-up color palettes in the following 
dialog boxes and palettes:

To create a custom color in a pop-up palette

1 In the pop-up color palette, choose the Custom option to open 
the Color Editor dialog box. This dialog box is almost identical to 
the Color tab in the Inks palette, described on page 134.

2 To use a different color model or color system, choose an 
option in the pop-up menu. Depending on which option you 

Inks Gradient manager
Hatch manager (pen color pop-up only)

Strokes Neon manager
Parallel manager

Layers Layer Options dialog box

Color calibration Gamut Warning dialog box

Image editing Duotone Options dialog box
New Channel dialog box
Channel Options dialog box
Create Image dialog box

Effects Extrude palette

✔Tip
Mac OS only: To open the Col-
or Editor quickly, you can 
Option-click a color icon.

Color icon If the color you 
want isn’t in the 
palette, you can 
drag to (Mac) or 
click (Windows) 
this box to specify 
a new color

These are the 
same colors that 
appear on the 
Color tab of the 
Inks palette

This is how the color icon 
appears when you press 
(Mac) or click (Windows) it 
to open the palette.
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choose, the dialog box shows a different set of controls; see “Color 
manager controls” on page 135 for more information.

3 Use the color controls to create a custom color.

4 To specify that you want the color you define to be a spot 
color, make sure the color is named in the text box at the top, then 
turn on Spot Color.

5 When you have the color you want, click OK. The color 
appears in the palette icon.

✔ Important 
If you plan to export a Canvas 
document to another applica-
tion in EPSF format and pro-
duce spot color separations, 
make sure the names of spot 
colors in Canvas exactly match 
the names of the spot colors in 
the other application. Any vari-
ation will cause problems.

Color Editor dialog box

You can choose the Custom 
option in a pop-up color 
palette to open the Color Edi-
tor dialog box.

A Type a name for the color in 
this text box.

B Choose a color model or 
reference system in this pop-up 
menu.

C Use the controls to specify a 
color. The available controls de-
pend on the option you choose 
in the pop-up menu (B); see 
“Choosing color models” on 
page 134 for information on the 
different options.

D Current selected color that 
appears in the color palette 
icon. Click to revert the settings 
in the dialog box to this color. E Preview of the custom color 

you define
Spot Color. Turn on to define 
the custom color as a spot 
color.

A

Color models and 
reference systems in 
the pop-up menu (B)

B

C

E

D
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Gradient inks
A gradient is a blend (or “ramp”) from one color to another. You use 
the Gradient tab in the Inks palette to apply gradient inks. The Gradi-
ent manager lets you customize gradient inks.

For general instructions on using the Inks managers, see “Creating 
and customizing inks” on page 131.

Getting the best results

The appearance of gradient inks depends on several factors:

Display A gradient looks less smooth on a monitor that displays 
256 colors than on one that displays thousands or millions of colors. 

Color variation The more extreme the difference in colors, the 
coarser the gradient appears. 

Object size When a gradient has large color transitions, it appears 
smoother in an object that is large enough to show all the transitions.

Gradient tab in the Inks palette

Gradient manager

When you create a gradient, 
you choose a gradient style 
and the colors to blend.

A The bar shows the gradi-
ent color sequence. 

B End pointers indicate the 
start and end colors. These 
can’t be moved or deleted. 

C Double-click in the bar to 
add an intermediate color 
pointer ( ). You can drag a 
pointer to adjust the color spac-
ing. To delete a color, drag its 
pointer to the end of the bar

D Choose a color in the pop-
up palette for the selected 
pointer ( ). You can choose a 
preset color or define a custom 
color; see “Creating custom col-
ors in pop-up palettes” on 
page 136.

E Style. Choose a gradient 
style from the pop-up menu. 
See the table below for shape 
and editing information.

F You can drag the controls in 
this edit box to set the gradient 
shape, angle, and center.

G Gradient preview.

H Angle. For Radial and Di-
rectional styles, enter the gradi-

ent angle in the text box, or 
drag the solid dot handle in the 
edit box.

I Rainbow. Check this box to 
include the sequence of hues on 
the color wheel between the 
specified colors. Click a direc-
tion button to specify which di-
rection to travel around the col-
or wheel to create the rainbow 
hue sequence.

A

B

C

D

E

B

H

I

F

G
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Gradient styles and editing features

Hatch inks 
You use the Hatch tab in the Inks palette to apply hatch inks. The 
Hatch manager lets you customize hatch inks. For general instruc-
tions on using the Inks managers, see “Creating and customizing 
inks” on page 131.

Hatch inks are patterns made of groups of lines. You can specify the 
number of line groups and the angle, offset, and origin of each group. 
You can assign a pen size, color, and dash to each line group, and you 
can select a fill ink to be the background of the hatch ink.

Hatch inks are often used in illustrations to distinguish different 
materials in cross sections, machine diagrams, and maps. 

To select a line group for editing

When you create a hatch ink in the Hatch manager, click a line in the 
edit box to select the line group. Selection handles appear where the 
selected line group intersects the edit box. 

Style Appearance and edit controls Edit box

Radial Colors sweep in a circle around the center. To move the center point, 
drag the open dot. To set the starting angle, drag the solid dot or enter 
the angle (0 to 360 degrees) in the text box.

Directional Linear gradient in which colors blend in the direction you specify. To set 
the gradient orientation, drag the solid dot, or enter an angle from 0 to 
360 degrees in the text box.

Shape Gradient conforms to basic object shapes. To move the gradient cen-
ter, drag the rectangle. To resize the center area that contains the end 
color, drag the solid handle and resize the rectangle.

Rectangular Rectangular-shaped gradient. To move the gradient center, drag the 
rectangle. To resize the center area that contains the end color, drag 
the solid handle and resize the rectangle.

Elliptical Elliptical-shaped gradient. To move the gradient center, drag the oval. 
To resize the center area that contains the end color, drag the solid dot 
and resize the oval.

Hatch tab in the Inks palette
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Line group attributes

You can set the following attributes for each line group in a hatch 
ink. To change an attribute, select the line group you want to change 
by clicking it in the preview box in the Hatch manager, and then enter 
a new value in the appropriate text box. 

Pen The width in points (1/72 inch) of each line in the selected line 
group.

Angle The angle in degrees of the selected line group relative to 
vertical. When you add a line group, the angle is initially 0 degrees. 

Offset The horizontal starting position of the line group, measured 
in points from the left edge of the preview box. Increasing this value 
moves the line group to the right.

Origin The vertical starting position of the line group, measured in 
points from the top of the preview box. Increasing this value moves 
the line group downward.

Hatch manager

When you create a hatch ink, 
you can set the number of line 
groups and other attributes.

A Preview. Click a line group 
in the preview box to select it. 
Tiny handles appear where the 
selected group meets the edge.

B Pen color. Choose a color 
for the selected line group in the 
pop-up menu. You can choose a 
preset color or define a custom 
color; see “Creating custom col-

ors in pop-up palettes” on 
page 136.

C Fill ink. Select an ink to use 
as the hatch ink background.

D Dash. Choose a dash pat-
tern for the selected line group.

Add Line. Click to add a new 
line group to the preview box.

Clear. Click to delete the 
selected line group (unless 
only one group is present).

See the next section for infor-

mation on setting Pen, Angle, 
Offset, and Origin.

A

B C D

✔Tip
If a hatch pattern overlaps the 
edges of an object, change the 
Pen value in the Hatch manag-
er to make the width of the 
hatch lines smaller than the pen 
size of the object’s stroke.
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Symbol inks
You use the Symbol tab in the Inks palette to apply symbol inks. The 
Symbol manager lets you customize symbol inks. For general 
instructions on using the Inks managers, see “Creating and customiz-
ing inks” on page 131.

A symbol ink is a pattern of vector objects. You can control the spac-
ing and position of the objects in a symbol ink.

Creating symbol inks

You can create a symbol ink from any vector objects, as well as text 
objects, in a Canvas document. You can use any of the Canvas draw-
ing tools to create vector objects for a symbol ink. You can apply 
inks and strokes to the objects before bringing them into the Symbol 
manager to create a new symbol ink.

1 Select the vector or text objects you want to use in a symbol 
ink. You can select more than one object, including group objects.

2 Drag the selected objects from the document into the preview 
box in the Symbol manager.

3 Adjust the settings for the symbol ink in the Symbol manager.

4 To store the new symbol ink in the palette, drag the ink from 
the preview box to the grid area at the top of the Symbol tab.

Symbol tab in the Inks palette

Symbol manager

When you create a symbol ink, 
you can adjust the position and 
spacing of the objects and 
apply a backdrop ink.

A Preview box. To create a 
new ink, drag vector or text ob-
jects to the preview box. Ob-
jects you drag to the box re-
place the current contents.

B Backdrop. Select a back-
ground ink in the pop-up menu. 
You can select any ink, including 
a color, gradient, hatch, texture, 

and symbol ink. The ink you se-
lect appears behind the objects 
in the symbol ink.

C Preview zoom. Click the 
left button to reduce or the right 
button to enlarge the preview.

Align To Object. Turn on this 
option to keep a symbol ink in 
the same position if the object 
moves. Turn it off to let over-
lapping objects share a symbol 
ink without a gap.

A

B C
2 Chapter 9: Inks: colors and patterns



Symbol spacing and position settings

In the Symbol manager, you can adjust the following settings to fine-
tune a symbol ink.

Spacing These values set the distance between objects in the sym-
bol pattern as a percentage of the size of the original objects. For 
example, a spacing value of 100 percent makes the distance between 
the objects equal to their size.

X Spacing is the horizontal distance between objects.

Y Spacing is the vertical distance between objects.

Stagger A positive value offsets the second row of objects hori-
zontally relative to the first row. To keep all objects aligned, set Stag-
ger to zero. To align alternating rows of objects, enter a higher 
Stagger value. To create a pattern in which the objects are spread out 
and objects in alternating rows are aligned with the gaps in the rows 
above, set the X Spacing and Stagger values to 100 percent. 

Scale The percentage of the original object size for the symbol ink. 
A value of 100 percent maintains the original object size. To reduce 
the objects, enter a value smaller than 100 percent. To enlarge the 
objects, enter a value greater than 100 percent.

Rotation The amount of rotation, specified in degrees, that Canvas 
applies to the original objects. 
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Texture inks
You use the Texture tab in the Inks palette to apply texture inks. The 
Texture manager lets you customize texture inks. For general instruc-
tions on using the Inks managers, see “Creating and customizing 
inks” on page 131.

A texture ink is a pattern of raster images. You can control the spac-
ing, scaling, rotation, and offset of the images in a texture ink.

Canvas assembles a texture ink by repeating an image in rows and 
columns, as if it were a grid of rectangular tiles. If you enter spacing 
values that spread the images apart, you create gaps between the 
image tiles; you can also include a background ink that will show 
through the gaps.

Creating texture inks

You can create a texture ink from any raster image object.

1 Drag an image from the document into the preview box in the 
Texture manager in the Inks palette.

2 Adjust the settings for the texture ink in the Texture manager.

3 To store the new texture ink in the palette, drag the ink from 
the preview box to the grid area at the top of the Texture tab.

Texture tab in the Inks palette

Texture manager

When creating a texture ink, 
you can set the spacing and 
offset of image tiles and 
choose a background ink.

A Preview box. To create a 
new ink, drag an image to the 
preview box. The image replac-
es the current contents.

B Backdrop. You can choose 
a background ink in the pop-up 
menu. The ink appears only in 
gaps between the image tiles.

C Preview zoom. Click the 
left button to reduce or the right 

button to enlarge the preview.

Spacing. Enter the amount of 
space between tiles as a per-
centage of the tile size. X Spac-
ing is space between columns; 
Y Spacing is the space 
between the rows of tiles.

Stagger. Select the horizontal 
button (left) or vertical button 
(right) and enter the distance 
(as a percentage of tile size) to 
shift the tiles.

Align To Object. Turn on this 
option to keep a texture in the 

same position if the object 
moves. Turn it off to let over-
lapping objects share a tex-
ture without a gap.

A

B C
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Types of
10

STROKES: OUTLINE EFFECTS

When you create objects with drawing tools, Canvas applies 
attributes set in the Strokes palette to the objects. A stroke is a line 
centered on the path of vector objects or the outline of type. You can 
shape a stroke with standard and calligraphic pens, parallel lines, 
even neon tubes. You can also add dashes and arrowheads to strokes.

This chapter explains basic stroke settings, how to customize strokes, 
and how to apply strokes to objects and text.

Types of strokes
Canvas has three basic types of strokes that you can use to create 
unlimited variations. Canvas groups stroke settings on three tabs in 
the Strokes palette.

Pen Strokes made of a single line. You can specify the width, shape 
(standard or calligraphic), type of line joins, and shape of end caps. 

Parallel Strokes made of two or more lines. You can specify width, 
dashes, colors, and spacing.

Neon Strokes shaded like glowing tubes. You can specify width, 
colors, tube shape, line joins, and end caps.

Arrows and dashes can be applied to strokes for additional effects. 
Two tabs in the Strokes palette contain settings for these attributes.

Arrow You can use preset or custom arrowheads that appear at the 
endpoints of each path segment stroke. 

Dash You can apply preset or custom dash sequences that divide 
solid strokes into solid and blank segments.

How inks affect strokes

You define the colors that apply to strokes separately from the stroke 
settings. The pen ink (specified in the Inks palette) and the stroke set-
tings together produce the appearance of an object’s outline. The pen 
ink is the color (or pattern) that “paints” the object’s stroke. There-
fore, the object must have a visible pen ink for the stroke to be visi-
ble. Conversely, the object must have a stroke for the pen ink to be 
seen. 

Pen

Parallel line

Neon

Arrow

Dash
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Some inks can make strokes invisible. If the pen ink is set to “no 
ink,” the stroke won’t be visible. Also, if the pen ink is set to white or 
a color that matches the background, the stroke could disappear 
against the background.

Applying strokes
The Strokes palette is the control center for all aspects of strokes. 
You can use the Strokes palette to apply strokes to objects, create 
custom strokes, add strokes to the palette, and save strokes in files 
that you can later load into the palette.

Preset strokes and controls for customizing strokes are on the Pen, 
Parallel, and Neon tabs in the Strokes palette. Presets and controls for 
customizing arrows and dashes are on the Arrow and Dash tabs.

Current stroke

The strokes icon in the toolbox shows a sample of the current stroke, 
the stroke that Canvas applies to new vector objects you create. For 
example, if the current pen stroke is 3 points wide, new objects you 
draw will have a 3-point pen width. Canvas does not apply the cur-
rent stroke to text; see “Applying strokes to text,” next.

To change the current stroke, simply deselect all objects and apply 
the stroke you want; the stroke icon in the toolbox shows the new 
current stroke. If you select an object and change its stroke, however, 
the current stroke for new objects does not change. 

When you first install Canvas, the current stroke defaults to a 1-point 
pen stroke without dashes or arrowheads.

Applying strokes to text

You can apply strokes to text the same as to vector objects, in most 
cases. For information about selecting text objects and text charac-
ters, refer to the Text and Typography chapters in this manual.

When you first type or import text into a document, Canvas applies a 
1-point pen stroke to the text, but does not assign a pen ink, so the 
text doesn’t have a visible stroke. 

◆ To make text strokes visible: Select the text or text objects and 
apply a visible pen ink using the Inks palette. If you select a text 
object, Canvas applies a stroke to all the text it contains. If you select 
specific characters within a text object, Canvas applies the stroke to 
those characters only. 

Strokes icon
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You can apply pen, parallel, and neon strokes to text. You can also 
apply dashes to text that has a pen or neon stroke.

Note: The appearance of a parallel stroke applied to text might not 
appear as you expect, especially on characters with hollow centers 
(such as “O” and “P”) and characters with tight corners or paths that 
meet or cross (including “G” and “X”).

Also, removing a neon or parallel stroke from text (by choosing “no 
stroke” on the Neon or Parallel tab) does not remove the stroke 
entirely. Instead, the stroke reverts to a 1-point pen stroke.

Using preset strokes
The Strokes palette contains preset strokes and properties that you 
can apply to objects and to the current stroke. Using presets can help 
you save time and ensure graphic consistency.

Presets for pens, parallel lines, neon strokes, arrows, and dashes are 
displayed in scrolling lists on the associated tabs in the Strokes pal-
ette. You can use the Strokes icon in the toolbox to apply preset 
strokes.

You can also create custom strokes, arrows, or dashes and add them 
to the presets on the appropriate palette tab so you can use them 
again. For information about creating and storing strokes, see “Cus-
tomizing strokes” on page 152.

To apply preset strokes to objects

Use the following general procedure to apply a preset stroke to one or 
more objects.

1 Select the objects for which you want to change strokes.

2 Press the Strokes icon in the toolbox to open the Strokes pal-
ette. You can use the palette when it’s attached to the tool box, or 

Calligraphic pen stroke Neon stroke

✔Tip
You can drag a setting from the 
Strokes palette to an object to 
apply the setting without first 
selecting the object.
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you can drag the palette away from the toolbox to keep it open 
while you work.

3 Depending on the type of stroke you want, choose the Pen, Par-
allel, or Neon tab.

4 Choose a stroke in the preset strokes list. If necessary, use the 
scroll bar or window resize button to view additional strokes. Can-
vas applies the stroke you choose to selected objects.

To make a preset stroke the current stroke

You can choose a preset stroke as the current stroke to apply to new 
objects you create.

1 Deselect all objects in the current document. To deselect all 
objects, press Enter (Mac) or Esc (Windows) a few times, or until 
no bounding boxes are visible.

2 Press the Strokes icon in the toolbox and choose the Pen, Paral-
lel, or Neon tab, depending on the type of stroke you want.

3 Choose a stroke in the preset strokes list. Use the scroll bar to 
view additional strokes. The Strokes icon in the toolbox shows the 
current stroke.

Using standard pen strokes
The most common type of stroke is a standard pen stroke, a solid line 
of uniform width. This type of stroke is used for many situations, 
such as technical illustrations, flowcharts, callout lines, arrows, and 
dashes.

Preset strokes Use the scroll bars 
or the resize 
button to view 
more presets

Floating Strokes palette

The palette appears slightly dif-
ferent when attached to the 
toolbox; the title bar and the 
items below the scroll list are 
not displayed.
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By default, the width of pen strokes is measured in points (one point 
is 1/72 of an inch). Pen stroke widths from 1 to 20 points appear in 
the Pen tab’s presets list.

◆ To change the current pen width: Deselect all objects, then 
select a new stroke on the Pen tab of the Strokes palette.

◆ To change the stroke width of specific objects: Select one or 
more objects, then select a new stroke on the Pen tab.

To change the color of a pen stroke

The color of a stroke comes from the object’s pen ink color. The pen 
ink can be a complex multi-color pattern or gradient, or a simple, 
solid color.

1 Select one or more objects whose pen ink you want to change.

2 Press the Pen Ink icon in the toolbox. The Inks palette opens 
from the toolbox; you can drag this palette away from the toolbox 
to keep it open as you work.

3 On one of the tabs in the Inks palette, choose a color, gradient, 
hatch, symbol, or texture; see “Inks: colors and patterns” on 
page 127.

‘Invisible’ inks

A pen ink is one or more colors that Canvas uses to apply color to 
pen strokes. The pen ink can be set to “no ink,” or to a color that 
blends into the background, which renders a pen stroke invisible.

In some situations, you might want to set an object’s pen ink to “no 
ink,” rather than remove the object’s stroke. This can be useful to 
temporarily hide the stroke without removing the dash, arrow, and 
other stroke settings, for example. 

To set an object’s pen ink to “no ink”

This procedure removes the pen ink and makes the stroke invisible. 

1 Select the object and press the Pen Ink icon to open the Inks 
palette. 

2 On the Color tab of the Inks palette, choose the first item, a box 
crossed by a diagonal line. If colors are listed by name, select “no 
ink” at the top of the list. 

Pen ink color changed from 
black to Pantone 123

“No ink” setting
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Adding preset arrows to strokes
You can use preset arrowheads to create pen, parallel, and neon 
strokes with arrows. You can apply strokes with arrows to lines and 
open paths, such as those created with the Curve tool. Arrowheads 
can appear at one or both endpoints of a path. 

You can also create custom arrowheads that you can add to the preset 
arrowheads; see “Customizing arrows” on page 158.

To add arrows to strokes

Use the following procedure to apply preset arrows to objects or the 
current stroke:

1 Depending on how you want arrows to apply, do one of the fol-
lowing:

• To add an arrow to the current stroke, deselect all objects.

• To add arrows to specific objects’ strokes, select the 
objects. 

2 Press the Strokes icon in the toolbox to open the Strokes pal-
ette; select the Arrow tab. 

3 The buttons at the top of the tab let you choose between start-
ing, ending, and double-sided arrowheads. To select a placement 
click a button; the chosen button appears recessed. The arrows in 
the scroll list preview the selected arrowhead.

4 In the scroll list, choose the arrow that you want to apply. The 
arrow applies to selected objects or to the current stroke.

Adding dashes to strokes
You can add a variety of preset dash sequences to pen and neon 
strokes. You can apply a stroke with dashes to most objects, includ-
ing lines, open and closed Bézier curves, polygons, rectangles, ovals, 
and stars.

Parallel line strokes can also includes dashes. However, you select 
dashes for parallel lines when you customize the stroke on the Paral-
lel tab. For details, see “Customizing parallel line strokes” on 
page 161.

Starting arrow Ending arrow Double-sided
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To add dashes to pen and neon strokes

1 Depending on how you want dashes to apply, do one of the fol-
lowing:

• To apply dashes to the current stroke, deselect all objects.

• To apply dashes to an object that has a pen or neon stroke, 
select the object.

2 Press the Strokes icon in the toolbox to open the Strokes pal-
ette. Choose the Dash tab. 

3 Choose the dash sequence that you want in the list of presets.

Removing arrows, dashes, and strokes
You can remove a selected object’s stroke, or set the current stroke to 
“no stroke,” so you can create objects that have no stroke. An object 
that has no stroke has no visible outline. Objects drawn with the Line 
tool become invisible without a stroke; other objects are still visible if 
they have a visible fill ink. 

You can also remove dashes and arrows from a stroke. Because 
arrows and dashes are attributes of strokes, you can remove them 
without removing the entire stroke. 

Removing arrows, dashes, and strokes involves the same procedure 
as changing from one preset stroke to another.

To remove arrows or dashes

You can use the following procedure to remove arrows from pen, 
parallel, and neon strokes, and to remove dashes from pen and neon 
strokes. For details about removing dashes from parallel strokes, see 
“Customizing parallel line strokes” on page 161.

1 Depending on how you want to remove arrows or dashes, do 
one of the following:

• To remove stroke attributes from an object, select the 
object. 

• To remove stroke attributes from the current stroke, deselect 
all objects.

2 Press the Strokes icon in the toolbox to open the Strokes pal-
ette. Choose the Dash or Arrow tab, depending on the attribute you 
want to remove.
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3 Choose “no arrow” on the Arrow tab to remove arrows from a 
stroke. Choose “no dash” on the Dash tab to remove dashes.

To use “no stroke” settings

You can remove strokes entirely from objects, or use “no stroke” as 
the current setting for new objects.

1 Depending on how you want to remove strokes, do one of the 
following:

• To remove the stroke from an object, select the object. 

• To make “no stroke” the current setting, deselect all objects.

2 Press the Strokes icon in the toolbox and choose “no stroke” on 
the Pen, Neon, or Parallel tabs.

Customizing strokes
Each tab in the Strokes palette has a configuration manager, an area 
that can be rolled down at the bottom of the palette to reveal options 
for customizing strokes. 

You can use the configuration managers to

• display the strokes settings of selected objects

• create custom pen, parallel, and neon strokes

• create custom arrowheads and dash sequences

• apply custom settings to objects or the current stroke

• store custom strokes as presets in the palette

• save preset strokes in files on disk

• load preset strokes that have been saved in disk files

To use the configuration managers

You must tear off the Strokes palette from the toolbox to use the con-
figuration managers, delete presets from the palette, and load, save, 
or delete strokes saved to disk.

1 To open the Strokes palette, press the Strokes icon and drag the 
palette away from the toolbox.

The Strokes palette opens as a floating palette. You can drag the pal-
ette by its title bar to move it.

2 Click the tab you want to use to bring it to the front, if neces-
sary.
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3 Click the triangle button at the bottom left corner of the palette 
to open the configuration manager for the front tab.

The configuration manager stays open as you click other tabs in the 
palette, and the display changes to reflect the available options for the 
tab.

◆ To roll up the configuration manager: When the configura-
tion manager is open, click the down-facing triangle button at the left 
of the palette.

Choosing settings to customize

You can use the configuration managers to customize the settings of 
an object’s stroke, the current stroke, or one of the preset strokes or 
stroke attributes. You can also create custom strokes.

• To customize an object’s stroke, select the object and open 
the appropriate manager in the Strokes palette.

• To use a preset stroke as the basis for a custom setting, 
apply the preset to an object and then select the object. This 
displays the settings in the manager on the appropriate tab. 
You can also simply choose the preset in the scroll list, 
however, this also changes the current stroke or the stroke 
of any selected objects.

To apply custom settings to objects

You can apply custom settings from the Strokes palette to an object 
in two ways:

• Select one or more objects before you begin adjusting the 
settings in the configuration manager. To apply the settings 
to the selected objects, click Apply.

• If you customize the settings before selecting any objects, 
you can apply the settings to objects by dragging from the 
sample window at the bottom of the palette to an object.

Configuration manager button

✔ Important 
If you adjust the settings in a 
configuration manager, and 
then select an object, the set-
tings will change to reflect the 
object’s settings. If you don’t 
want to lose custom settings 
when no objects are selected, 
add them to the palette, or 
apply them to an object; see 
“Adding custom settings to the 
palette,” next.
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Adding custom settings to the palette

You can add custom strokes, arrows, and dashes to the Strokes pal-
ette. When you add custom items, they become presets that you can 
use the same as default preset items. You can apply a customized pre-
set to objects or make it the current stroke.

◆ To add custom settings from the configuration manager to 
the palette: Drag from the sample window at the bottom of the pal-
ette to the presets list at the top. The settings become a preset, with a 
graphic representation or description added to the end of the list.

◆ To add settings from an object to the palette: Select the 
object. Its settings appear in the appropriate configuration manager of 
the Strokes tab. Drag from the sample window at the bottom of the 
palette to the presets list at the top.

When you end a Canvas session, the program stores each tab’s pre-
sets with the program. Because Canvas stores the preset strokes and 
inks, the same presets can always be available, whether you work 
with new documents, documents you created, or documents created 
by another Canvas user.

If you create a custom stroke and want to apply it to more than one 
object, and especially if you want to use it in a later work session, you 
should store the custom settings in the presets area of the palette.

Deleting presets from the palette

You can remove default and custom presets from the Strokes palette. 
When you delete a preset, Canvas permanently removes it from the 
palette, unless you save it to disk and load it again; see “Saving and 
loading strokes settings,” next.

◆ To remove a preset from the palette: Drag the preset to the 
trash can icon below the presets scroll list. The trash can appears only 
when the Strokes palette is floating.

Note: If you delete all arrowheads from the palette, dimension 
objects will not have arrows.

Saving and loading strokes settings
You can save preset strokes, arrows, and dashes in files on disk, and 
load the presets into the Strokes palette. You can use these strokes 
files to customize the Strokes palette for particular projects or types 
of documents, and to exchange custom settings with other Canvas 
users.

Drag from the sample window to 
the scroll list, as highlighted
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Commands for saving and loading strokes files are in a pop-up menu 
on the Strokes palette. The menu icon appears only when the Strokes 
palette is separated from the toolbox.

To save strokes in a file

Use the following procedure to save the presets from one tab in the 
Strokes palette to a file on disk.

1 To open the Strokes palette, press the Strokes icon and drag the 
palette away from the toolbox. The Strokes palette opens as a float-
ing palette.

2 Click the tab you want to use to bring it to the front.

3 Adjust the settings in the palette, if necessary, until you have 
the presets you want to save.

4 Press the right-triangle button on the right of the palette and 
choose Save Strokes in the pop-up menu. A directory dialog box 
opens. 

5 Type a name for the palette file, select a location on a disk, and 
click Save.

To load strokes from a file

Use the following procedure to load presets from a strokes file on 
disk to a tab in the Strokes palette. When you load a strokes file, you 
can replace a tab’s presets with the file’s presets or add the presets 
saved in the strokes file to those currently in the palette.

1 To open the Strokes palette, press the Strokes icon and drag the 
palette away from the toolbox. The Strokes palette opens as a float-
ing palette.

2 Click the tab you want to use to being it to the front.

3 Press the right-triangle button on the right of the palette and do 
one of the following, depending on whether you want to replace the 
current presets:

• To replace the tab’s presets with those in the strokes file, 
choose Load Strokes.

• To add the presets in the strokes file to those currently in the 
palette, choose Append Strokes.

4 A directory dialog box opens. Locate the strokes file you want 
to open and click Open.

Right-triangle button 
pop-up menu
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Customizing pens
In the Pen manager, you can choose from the following options:

• standard or calligraphic pen styles, or “nibs.” Standard pens 
have a uniform width. Calligraphic pens have a separate 
width, height, and angle setting.

• bevel, miter, or round line joins

• flat, round, or square end caps

For basic information about setting pen size, see “Using standard pen 
strokes” on page 148.

◆ To create a custom pen width: In the Pen manager, choose 
Standard in the pop-up menu, and set the width in the Width text box. 
The sample window at the bottom of the manager shows the current 
settings; drag from this window to the scroll list to add the pen width 
to the presets.

To create a calligraphic pen

The calligraphic option lets you create a pen stroke with a custom 
height, width, and angle. The shape of a calligraphic stroke varies 
depending on the stroke’s path.

1 In the Pen manager, choose Calligraphic in the pop-up menu. 
Height, Width, and Angle text boxes and an editing box appear in 
the configuration manager.

2 To set the width of the pen, enter a value in the Width text box, 
or drag the thick blue arrows in the edit window. The width is the 
maximum thickness of the stroke when it is perpendicular to the 
pen angle. 

3 To set the height of the pen, enter a value in the Height text 
box, or drag the thin red arrow in the edit window. The height is the 
maximum thickness of the stroke when it is parallel to the pen 
angle.

4 To set the pen angle, enter a value in the Angle text box or drag 
an arrow in the edit window.

For the most calligraphic effect, the height and width values should 
be dissimilar (at least by a factor of three or four) and the angle set to 
approximately 45 degrees.

✔Tip
You can choose millimeters, 
inches, or picas instead of 
points as the pen size unit 
using the Preferences com-
mand in the File menu. Howev-
er, if you add a custom pen to 
the presets, Canvas converts 
the units to points.

Calligraphic pen stroke. Note 
the variations in height and 
width of the stroke.
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Choosing line joins and end caps
Pop-up menus in the Pen manager let you specify the type of line 
joins and end caps. Line joins determine appearance of two path seg-
ments that meet at a corner. End caps specify the shape of the end-
points of an open path.

Line joins

Canvas has three types of line joins: miter, round, and bevel. For pre-
set pen strokes, Canvas indicates the type of line join in the scroll list 
on the Pen tab.

Miter Joins path segments with sharp corners that extend to a single 
point. When you choose miter joins, an additional pop-up menu lets 
you set the miter limit in degrees (2, 4, 6, 8, or 10 degrees). 

The miter limit setting tells Canvas which corners are too tight to 
miter; Canvas bevels these corners instead. In other words, if the 
miter limit is set to 6 degrees, and two path segments join at an angle 
of 5 degrees, Canvas bevels the corner rather than creating a miter 
join. The miter limit lets you prevent long, spiked corners that might 
result as a combination of a wide pen size and a small angle.

Pen manager

These settings let you create 
your own pen types.

A Choose Calligraphic in the 
pop-up menu.

B Specify width, height, and 
angle of the pen nib. You can 
set the units of measure for 
these settings using the Prefer-
ences command in the File 
menu.

C Configure line joins and end 
caps using the pop-up menus; 
see the next section for informa-
tion on these settings.

D Sample window of the cur-
rent pen settings.

E Edit the size and angle of 
the nib interactively in this edit 
window (see inset).

F Use the zoom buttons to in-
crease or reduce the size of the 
nib in the edit window. This 
does not affect the actual pen 
size.

In the edit window, you can 
drag control points to adjust 
the pen nib.

G Drag to change the height 
and angle of the nib.

H Drag to change the width 
and angle of the nib.

A

B

D

C

F

G

H

E
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Round Smooths corners, so the joint is rounded instead of pointed 
or flat. 

Bevel Squares off path segment corners, so that the joint appears 
flat rather than rounded or pointed. 

End caps

Canvas has three types of end caps. For preset pen strokes, Canvas 
indicates the type of end cap in the scroll list on the Pen tab.

Flat The end of the stroke is flush and square with the end of an 
open path or dash. By default, end caps use this setting.

Round A semi-circular cap extends half the pen width beyond the 
endpoint of an open path or dash.

Square The stroke tip is square, similar to the Flat option, but 
extends half the line width beyond the endpoint, like the Round 
option.

Customizing arrows
You can create starting, ending, or double-sided arrowheads using 
the Arrow manager. You can create double-sided arrowheads that are 
identical or entirely different. Canvas has several preset arrowhead 
styles that you can use and edit, or you can use any vector, paint, or 
text object as an arrowhead. 

To create a custom arrowhead

1 Create a vector, text, or paint object to use as an arrowhead. 
You can also edit a preset arrowhead or an arrowhead style of an 
existing object by selecting the preset or object.

Round joinBevel joinMiter join, miter limit = 2˚ Miter join, miter limit = 10˚

Flush with endpoint

Rounded at endpoint

Square at endpoint
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2 With the Strokes palette floating, select the Arrow tab and roll 
down the Arrow manager, if necessary.

3 To choose whether you want to create a starting or ending 
arrowhead, or both, click a button at the top of the tab. The sample 
windows at the bottom of the configuration manager show or hide, 
depending on the button you click.

4 For double-sided arrowhead styles, click a sample window to 
choose which arrowhead you want to work with. To edit both sides 
simultaneously, turn Mirror on.

5 Drag the object you want to use as an arrowhead to the edit 
window in the configuration manager.

6 Configure the arrowhead settings described below.

A

B

DC

E

F

G

Arrow manager

Use these options to create a 
custom arrowhead or edit a 
preset arrowhead.

A You can drag objects to this 
edit window to use them as ar-
rowheads. A preview of select-
ed presets or objects also ap-
pears here.

B Use these zoom buttons to 
magnify the edit window view. 
Changing views does not chan-
ge the arrowhead’s actual size.

C Shows the starting arrow-
head, and isn’t visible when us-
ing only ending arrowheads. 
When working with double-sid-
ed arrowheads, click this win-
dow to select the starting arrow.

D Previews the ending arrow-
head and isn’t visible when us-
ing only starting arrowheads. 
When working with double-sid-
ed arrowheads, click this win-
dow to select the ending arrow.

Arrow edit window

You can move and resize the 
object in the edit window to 
fine-tune the arrowhead.

E Drag these control points to 
resize the arrowhead.

F Indicates the horizontal axis 
of the path’s endpoint.

G Indicates the vertical axis of 
the path’s endpoint.

Center. Click the buttons to 
align the center of the arrow-
head horizontally and vertical-
ly on the path’s endpoint.

Flip. Click the buttons to flip 
the arrowhead horizontally 
and vertically.

Mimic Pen. Turn size and color 
on to apply the pen width and 
ink of the path to the arrow-
head.

Place on segments. Turn this 
option on to add arrows to 
each segment of an object.

Mirror. Turn on to make dou-
ble-sided arrowheads mirror 
images of each other.
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Customizing dashes
Dashes are composed of alternating solid and blank segments. Using 
the Dash manager, you can customize the length of up to 13 seg-
ments to create new, complex dash sequences.

You can design dashes interactively using the edit window. To pre-
cisely set the length of each dash segment, you can also specify an 
exact length. The ruler in the Dash manager displays inches; how-
ever, you can enter dash lengths in inches, points, millimeters, or 
picas; see “Measurement unit preferences” on page 91 for details.

Dashes in the Strokes palette always appear as 1-point wide, black 
and white segments. However, when you apply these dashes to an 
object’s pen, the black segments adopt the color and size of the pen, 
and the white segments become transparent.

◆ To create a custom dash sequence: With the Strokes palette 
floating, select the Dash tab and open the Dash manager, if needed. 
Use the edit window and length text box to design the sequence, as 
described below. 

Dash manager

Use these controls to create 
custom dash sequences.

A Click the ruler scroll buttons 
to move the edit window view 
left and right.

B To change the length of a 
segment, drag a dash segment 
editor to the length you want. 
You can also type a number in 
the Length text box. When you 
select or drag a segment, Can-
vas highlights it.

C To add new segments, drag 
from this segment editor (ap-
pears blue on-screen) to the left. 
This segment editor remains at 

the right of the window until you 
create the thirteenth segment. 
Because you can’t create more 
than 13 segments, this segment 
editor then acts like the others.

D Displays the segment’s 
number (its order in the se-
quence) and its color. “Black” 
indicates it will appear in the 
color of the pen ink, and 
“White” indicates it will be 
transparent.

E Displays a sample of the cur-
rent settings.

F Turn Proportional on to tell 
Canvas to scale the length of the 
segments to match the pen 

width of the object. The length 
of segments in the Dash manag-
er are based on a 1-point line. 
Therefore, if the pen width is 6 
points and Proportional is se-
lected, Canvas multiplies the 
lengths by six.

C

D

B

A

F

E
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Customizing neon strokes
You can create custom neon strokes using the Neon manager in the 
Strokes palette. You can specify the width, colors, line joins, and end 
caps for neon strokes.

To create custom neon strokes

1 With the Strokes palette floating, select the Neon tab and open 
the Neon manager, if necessary. 

2 To specify the width of the neon stroke, enter a value in the 
Width text box. The preview windows reflect the current settings. 
You can use the magnification buttons below the preview window to 
get a close look at the neon effect. Keep in mind that low width set-
tings might make it difficult to see the neon effect.

3 To specify colors for the neon stroke, use the Inside color and 
Outside color pop-up menus; see “Creating custom colors in pop-
up palettes” on page 136 for more information. Canvas blends these 
colors together to create the neon effect. To make the stroke appear 
round, experiment with lighter inside colors and darker outside col-
ors. The placement of the colors depend on the Full/Partial setting.

4 To place the inside color in the center of the stroke and the out-
side color on the edges, choose Full. To place the inside color on 
one side of the stroke, choose Partial.

5 To choose line join and end cap styles, use the pop-up menus 
above the sample window at the bottom of the manager; see 
“Choosing line joins and end caps” on page 157 for more informa-
tion on these options.

Customizing parallel line strokes
You can create custom parallel line strokes using the Parallel man-
ager in the Strokes palette. You can specify the number of lines, the 
color, dash pattern, and pen size of each line, and the spacing of lines.

◆ To create custom parallel line strokes: With the Strokes pal-
ette floating, click the Parallel tab to bring it to the front and open the 
Parallel manager, if necessary. Configure the settings in the manager, 
described below.
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Parallel manager

Use these controls to create 
custom parallel line strokes.

A Enter the number of parallel 
lines you want.

B Choose a number in the 
pop-up menu to select a line to 
edit (“1” is the bottom line). You 
can also click a line in the pre-
view window (C) to select it.

C Previews the current set-
tings and indicates which line is 
selected by displaying handles.

D Use this row of pop-up 
menus to apply pen width (left), 
pen color (center), and dashes 
(right) to the selected line. The 
pop-up menus contain preset 

strokes and colors. You can also 
specify custom pen colors; 
see“Creating custom colors in 
pop-up palettes” on page 136.

E Displays a sample of the 
current settings.

Identical. Turn this option on 
to give all parallel lines the 
same pen size, color, and dash 
as the selected line.

Spacing. Enter a number to 
specify the distance between 
the selected line and the one 
below it. For Line #1, this set-
ting defines the space between 
this line and Line #2.

Equidistant. Turn on this 
option to apply the spacing 

setting for the selected line to 
all lines.

Eccentricity. Choose Cen-
tered, Above, or Below to 
specify the placement of paral-
lel lines relative to the path of 
the object.

C

B

A

D

E
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Drawing basic
11

DRAWING BASICS

This chapter describes how to draw and resize vector objects. The 
Canvas drawing tools let you easily draw basic shapes — lines, rect-
angles, ovals, and arcs — and create precise squares, circles, and 
straight lines. Specialized tools let you draw grids, stars, polygons, 
concentric circles, spirals, and “smart” lines that link objects and stay 
connected even when you move the linked objects.

Drawing basic shapes
You can use the same basic technique with any Canvas drawing tool. 
See the table titled “Basic drawing procedures” on page 166 for the 
procedures you use to draw basic shapes. Instructions for the tools 
that let you draw grids, stars, polygons, concentric circles, spirals, 
and Smart Lines appear later in the chapter.

Applying inks and strokes 

When you draw a vector object, Canvas applies the current ink and 
stroke settings to the objects you draw. The inks and stroke icons in 
the toolbox show a preview of the current settings. You can change 
these attributes before or after you draw an object. Refer to the chap-
ters titled “Inks: colors and patterns” on page 127, and “Strokes: out-
line effects” on page 145, for more information.

Selecting tools in the toolbox

Tools for drawing lines, rectangles, ovals, and arcs are grouped in 
toolbars that pop out from the toolbox. The current tool is visible in 
the toolbox. To open a toolbar to select another tool, press the current 
tool icon. To keep a toolbar open while you work, drag it away from 
the toolbox.

Drawing objects from the center

You can draw many vector objects starting from the object’s center 
by pressing a modifier key as you draw. Position the pointer where 
you want the object’s center to be, press Option (Mac) or Ctrl (Win-
dows) and drag away from the center to draw the object. 
 shapes 165
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When you draw an object from the center, you can press Shift at the 
same time if you want to also constrain the object’s bounding box to 
a square. You can use this technique to draw a perfect square or circle 
from the center outward.

Basic drawing procedures

Resizing and reshaping vector objects
You can resize and reshape vector objects by changing the size and 
shape of an object’s bounding box. You can also change the length of 

Object Tool Procedure

Lines Line tool Drag from the starting point to 
the end point in any direction

Lines at a 45˚ angle 
(horizontal, vertical, 
or diagonal)

Line tool Press Shift and drag from the 
starting point to the end point

Rectangles Rectangle tool Drag from one corner to the 
opposite corner

Squares Rectangle tool Press Shift and drag from one 
corner to the opposite corner

Rounded rectangles Rounded 
Rectangle tool

Drag from one corner to the 
opposite corner

Rounded squares Rounded 
Rectangle tool

Press Shift and drag from one 
corner to the opposite corner

Ovals Oval tool Drag from one corner to the 
opposite corner of the oval’s 
bounding box

Circles Oval tool Press Shift and drag from one 
corner to the opposite corner of 
the circle’s bounding box

Arcs Arc tool Drag from one corner to the 
opposite corner of the arc’s 
bounding box

Circle-segment arcs Arc tool Press Shift and drag from one 
corner to the opposite corner of 
the arc’s bounding box
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arc segments and the corner radius of rounded rectangles. These tech-
niques are described in the following section.

You can also edit most vector objects by changing the anchor points 
and segments that form their paths. For information on these editing 
techniques, see “Editing object paths” on page 180.

To resize an object’s bounding box

When you drag a handle on a vector object’s bounding box, you 
change the height or width (or both) of the bounding box. This also 
changes the size (and possibly the shape) of the object. For example, 
if you select a circle and drag a side handle to make the bounding box 
wider, the circle becomes an oval that is wider than it is tall.

1 Choose a Selection tool at the top-left of the toolbox. 

• Use the filled arrow to select a single object (including a 
group object)

• Use the hollow arrow to select an individual object within a 
group object.

2 Click the object to select it. Handles appear on the object’s 
bounding box.

3 Drag a handle, as described below, to resize the object.

Maintaining object proportions

When you resize vector objects and want to maintain the object’s 
height-to-width ratio, you have two options: 

To change Do this

Height Drag the top or bottom handle

Width Drag a side handle

Height and width Drag a corner handle

Height and width 
proportionally

Press Shift and drag a corner handle

Symmetrically 
(from center)

Press Option (Mac) or Ctrl (Windows) and 
drag a handle

Symmetrically and 
proportionally

Press Option-Shift (Mac) or Ctrl-Shift (Win-
dows) and drag a corner handle
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• If the object’s bounding box is a perfect square — which is 
true for circles, squares, and arcs of circles — press Shift 
and drag a corner handle to resize the object proportionally.

• If the bounding box is not a square, use the Scale command 
and specify the same horizontal and vertical scaling factor. 

To change the length of an arc

1 Select the arc. Round handles appear near the beginning and 
end of the arc segment.

2 To shorten the arc, drag the round handle back over the arc. To 
lengthen the arc, drag the round handle to continue the arc segment.

You can also adjust the length of an arc by changing its Start angle 
and Delta values in the Object Specs palette.

To change the corner radius of a rounded rectangle

1 Select the rounded rectangle. A round handle appears near the 
lower-right of the rectangle.

2 Drag the handle to change the corner diameter. You can also 
use the Diag setting in the Object Specs palette to alter the shape.

Using specialized drawing tools
Several specialized drawing tools let you quickly create complex 
shapes in Canvas. You can draw grids, stars, polygons, concentric 
circles, spirals, and Smart Lines as easily as drawing a line or oval. 

The shapes created by these tools are vector objects that you can 
move and resize the same as other objects. Some objects also have 
unique editing features. For example, you can twirl the points of a 
star, star outline, or framed star by dragging special handles. You can 
also specify the number of points for a star, the number of rows and 
columns in a grid, the number of rings in concentric circles, and the 
number of revolutions in a spiral.

You can also edit these objects by manipulating anchor points and 
segments, if you convert the objects to paths. For more information, 
see “Converting objects and text to paths” on page 191.

Drawing concentric circles
The Concentric Circles tool draws nested rings of ovals or circles. 
You can set the number and spacing of the rings before or after you 
draw concentric circles.
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1 Select the Concentric Circles tool. The tool is in the pop-up 
toolbar with the oval and arc tools.

2 Drag diagonally to specify the size of the concentric circles. To 
draw rings that are perfect circles, press Shift and drag.

◆ To change a concentric circles object: Double-click the con-
centric circles object to open the Concentric Circles dialog box. 
Adjust the settings (see below) and click OK.

To configure the Concentric Circles tool

Double-click the Concentric Circles tool icon to open the Concentric 
Circles dialog box. You can use the dialog box to change an existing 
concentric circles object and to configure the Concentric Circles tool 
before you draw with it.

Drawing spirals
The Spiral tool draws a smooth, spiraling curve. You can set the 
number of spiral turns before or after you draw a spiral object.

1 Select the Spiral tool in the toolbox. The tool is in the toolbar 
with the Oval and Arc tools.

2 Drag diagonally to specify the size of the spiral curve. To cre-
ate a circular spiral, press Shift and drag.

To configure the Spiral tool

Double-click the Spiral tool to open the Spiral dialog box. Set the 
number of spirals and click OK.

A Type the number of circles 
you want the tool to draw.

B Type the number of pixels 
between each circle. Type zero 
to evenly space the circles.
.

A

B

Set the number of turns (maximum 35) 
in the spiral
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◆ To change the number of spirals in an object: Double-click 
the object to open the Spiral dialog box. Change the number of spi-
rals and click OK.

Drawing grids
The GridMaker tool draws grids of rows and columns. You can set 
the number of rows and columns before or after you draw a grid 
object.

1 Select the GridMaker tool in the toolbox. The GridMaker tool 
is in the toolbar with the Rectangle and Rounded Rectangle tools.

2 Drag diagonally to define the grid’s bounding box. To create a 
square grid, press Shift and drag.

To configure the GridMaker tool

Double-click the GridMaker tool to open the GridMaker dialog box. 
Set the number of boxes comprising the grid and click OK.

If you set Boxes Across to 1, the grid has no vertical lines. If you set 
Boxes Down to 1, the grid has no horizontal lines.

◆ To change the configuration of a grid object: Double-click 
the grid object to open the GridMaker dialog box. Change the num-
ber of boxes and click OK.

To separate a grid into lines

You can adjust the individual lines that comprise a grid by converting 
it to a path and then ungrouping it.

1 Select the grid object and choose Path ➤ Convert to Path in the 
Object menu.

2 Choose Ungroup in the Object menu. The grid object separates 
into individual lines.

Set the number of columns

Set the number of rows
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Drawing with the Multigon tool
You can use the Multigon tool to draw all types of multi-sided 
objects, including triangles, hexagons, pentagons, octagons, stars, 
circular starbursts, and similar shapes. To set the number of sides and 
the style of a multigon, configure the Multigon tool before you draw.

◆ To draw with the Multigon tool: Select the Multigon tool in 
the Object toolbar. Drag diagonally to define the multigon’s bound-
ing box. To make the bounding box square, press Shift and drag.

◆ To configure the Multigon tool: Double-click the Multigon 
tool icon. In the dialog box, set the multigon style and other options 
(described next) and click OK.

Style Appearance

Frame No interior lines

Framed Star Combination of Frame and Star objects

Spoke No sides connecting the spoke points

Star Points connected by interior lines

Star Outline Multiple points with no interior lines

Wheel Combination of Frame and Spoke objects

Multigon dialog box

The available options depend 
on the selected multigon style.

A Choose a preset style in the 
pop-up menu.

B Click to choose a custom 
style or to save or delete one.

C Preview shows the style and 
other settings.

D For stars, framed stars, and 
star outlines, enter the number 
of star points from 3 to 100. For 
other styles, enter the number 
of sides from 3 to 100.

E Drag the slider to change 
the interior area of stars, framed 
stars, and star outlines.

F Turn this option on to 
smooth the object’s angles.

G For stars, enter a value of 
more or less than 0 degrees to 
bend the points. Negative val-
ues bend the points counter-
clockwise.

B

A

D

E

F 

G

C

Smooth option (left) 
and Pinwheel Angle 
(right)
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Saving custom Multigon settings

You can save Multigon tool settings so you can use them later. In the 
Multigon dialog box, press the triangle at the lower-left to save, 
select, and delete custom multigon styles.

◆ To save multigon settings: Choose Save Shape. Type a name 
for the shape and click OK. The name appears in the pop-up menu.

◆ To delete a style: Choose Delete Shape. In the dialog box, 
choose the shape name you want to delete and Click OK. You can’t 
delete any of the built-in styles.

Note: When you save and delete styles, they remain saved or deleted 
whether you click OK or Cancel to close the Multigon dialog box.

Editing star multigons

You can interactively edit star multigons (framed star, star, and star 
outline styles) to adjust the twirl and radius of the object’s points. The 
following procedures do not apply to frames, spokes, or wheels.

1 Double-click the star multigon to put it in interactive mode. An 
outer handle and an inner handle appear on one point of the star.

• To change the length of the star points, drag the outer han-
dle inward or outward from the center of the star.

• To twirl the points, drag the handle clockwise or counter-
clockwise.

• To change the position of the inner points, drag the inner 
handle inward or outward from the center.

2 To end interactive editing, press Enter (Mac) or Esc (Win-
dows), or double-click outside the object.

Connecting objects with Smart Lines
The Smart Lines tool draws dynamic links between objects. Smart 
Lines are useful for creating organizational charts, flow diagrams, 
and other illustrations with linked objects. 

You can use Smart Lines to link one or more objects to a single 
object. You can draw multiple Smart Lines between objects and you 
can link Smart Lines to other Smart Lines. When you resize or move 
a Smart Line, the linked objects move according to the type of Smart 
Line used.

1 Select the Smart Lines tools in the toolbox. The Smart Lines 
tool is in a pop-out toolbar with the Line tool.
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2 Press the Smart Lines tool to open the Smart Lines palette. You 
can drag the palette away from the toolbox to keep it open.

3 Select one of the Smart Lines types in the palette.

4 Drag from one object to another object. When you release the 
mouse button, Canvas creates the Smart Line.

Type Characteristics

Basic 

Smart Lines change length and angle to maintain connection 
to the linked objects

Fixed Length

Maintains a set length and linked objects move to maintain the 
length

Fixed Angle

Maintains a set angle and linked objects move to maintain the 
angle

Kinked

Uses only horizontal and vertical segments. Linked objects 
move to maintain the segments. You can set the first and last 
segments to always be vertical.

Locked

Smart Lines do not change length or angle and linked objects 
move as a group
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◆ To change the type of an existing Smart Line: Double-click 
the Smart Line to open the Smart Lines dialog box and choose a dif-
ferent type in the pop-up menu.

Type of link The link types correspond to the icons in the Smart 
Lines palette. 

Length For Fixed Length Smart Lines, you can specify the length 
of the selected Smart Line by entering a number in this text box. 

Fixed Angle For Fixed Angle Smart Lines, you can type an angle 
in degrees to specify the angle of the selected Smart Line.

Vertical Start/Vertical Stop For a Kinked link type, you can select 
Vertical Start to make the Smart Line start with a vertical segment 
and select Vertical Stop to make the Smart Line end with a vertical 
segment.
4 Chapter 11: Drawing basics



Drawing with the pa
12

DRAWING AND EDITING PATHS

In addition to basic shape tools, Canvas provides tools that let you 
draw paths of any shape. This chapter explains how to 

• draw paths with the Curve, Polygon, and Freehand tools

• edit paths by adding, deleting, and moving anchor points 
and segments

• adjust a curve segment using the control points that define 
curves

Drawing with the path tools
You can use the Curve, Polygon, and Freehand tools to draw vector 
objects as open or closed paths. When you use the Curve and Poly-
gon tools, you set anchor points to define the path segments. With the 
Freehand tool, you simply drag to draw a path. The three tools are 
grouped in a toolbar that pops out from the toolbox. 

The Polygon tool draws paths with straight segments. The Curve tool 
can draw paths with straight and curved segments. Paths drawn with 
the Freehand tool generally are made of curved segments based on 
the movement of the pointer.

When you draw with the path tools, Canvas uses the current pen ink, 
fill ink, and stroke settings for the vector objects you create.

Drawing polygons 
When you use the Polygon tool to draw an object, you set anchor 
points that define a path of straight line segments. As with any path 
object, you can later make the straight segments curved. For editing 
information, see “Editing object paths” on page 180.

1 Select the Polygon tool in the Path Tools toolbar.

2 Click to set the first anchor point, shown as a small square.

Path Tools toolbar

Curve tool

Freehand tool

Polygon tool 

Press the current path tool to 
open the toolbar and select the 
tool you want to use. To keep 
the toolbar open while you work, 
drag it away from the toolbox.
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3 Click where you want to place the second anchor point.

• You can press the pointer to display the segment, drag to 
position it, and then release the mouse button.

• To constrain placement of a segment to 45-degree intervals, 
press Shift while drawing the segment.

4 Repeat the last step to draw more segments. To remove the last 
segment you drew, press Delete.

5 To complete the polygon:

• For an open polygon, after you place the last anchor point, 
press Enter (Mac) or Esc (Windows), or double-click to 
place the last anchor point.

• For a closed polygon, click the starting anchor point, and 
then press Enter (Mac) or Esc (Windows), or double-click 
the starting anchor point.

Smoothing polygons 

You can use the Smooth command to convert a polygon — a path 
made of straight segments — to a path with smooth curves. You can 
smooth any paths made of straight segments, including rectangles 
and paths drawn with the Curve tool, as long as they have only 
straight segments. The smooth command is a convenient way for 
those who haven’t mastered curve drawing to create smooth shapes.

Click to place first point Click additional points, 
double-click last point

Completed polygon 
(selected)

Polygon finished with 
solid black fill ink 

Polygon

Smoothed
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◆ To smooth a polygon: Select the polygon and choose Path ➤ 
Smooth in the Object menu. Canvas converts the polygon’s corner 
points into smooth points, which changes the path’s straight line seg-
ments into curved segments. For more information about editing 
smooth points and curved segments, see “Reshaping paths by editing 
anchor points” on page 187.

You can use the Unsmooth command to restore the straight segments 
of a polygon that was smoothed with the Smooth command. How-
ever, you can use Unsmooth only if the smoothed polygon wasn’t 
edited after it was smoothed.

◆ To unsmooth a smoothed polygon: Select the smooth poly-
gon and choose Path➤Unsmooth in the Object menu. Canvas 
restores the polygon’s straight line segments. 

Drawing freehand paths 
You can draw objects with the Freehand tool by simply drag-
ging the pointer. The Freehand tool creates paths with curved 

segments based on the movement of the pointer.

As with any path object, you can later edit the path and reshape its 
segments; see “Editing object paths” on page 180.

◆ To draw a freehand path: Select the Freehand tool in the Path 
Tools toolbar. Position the pointer where you want the path to begin. 
Drag to create a path. To create a closed path, release the mouse but-
ton when the pointer is on the starting point.

◆ To set the curve tolerance: You can tell Canvas to use rela-
tively more or fewer anchor points to represent a curve. Double-click 
the Freehand tool to open the Freehand Tolerance dialog box. In the 
text box, type a value from 1 to 5, where a value of 5 tells Canvas to 
use as few anchor points as possible.

Paths drawn with the 
Freehand tool
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If you have difficulty drawing smooth curves with this tool, try low-
ering the speed setting in your system’s Mouse (or other pointing 
device) Control Panel. See your system documentation for informa-
tion on these settings.

Drawing curved paths
The Curve tool is the most versatile of the path tools. You can 
use it to draw precise paths with straight and curved segments. 

When you draw curved segments, you place an anchor point and a 
tangent line at the start of each segment. The position and length of 
the tangent line controls the shape of the curved segment.

 

You can also draw straight paths by clicking with the Curve tool, 
similar to the way you use the Polygon tool; see “Drawing polygons” 
on page 175.

Anchor point

Tangent line

Defining curves

Anchor points determine 
where path segments start and 
end. Tangent lines at the anchor 
points control the shapes of 
curve segments.

Handle

Curve segments (highlighted)

This tangent line 
affects the second 
segment. The tangent 
lines of adjacent 
anchor points (not 
shown) also affect the 
segment’s shape.
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To draw a path with curved segments

1 Select the Curve tool in the toolbox.

2 Where you want the path to begin, do one of the following:

• Click to set the anchor point and, before releasing the mouse 
button, drag to position its tangent line.

• Click to set the anchor point without creating a tangent line.

When you release the mouse button, the anchor point appears.

3 Where you want the segment to end, do one of the following:

• Drag to simultaneously set an anchor point and position a 
tangent line.

• Click to set the anchor point without creating a tangent line.

This finishes the first curve segment.

4 Repeat the previous step to draw additional segments.

5 To complete the path, use one of the following options:

• For an open path, after you place the last anchor point, press 
Enter (Mac) or Esc (Windows). You can also double-click 
to place the last anchor point.

• For a closed path, click the starting anchor point, and then 
press Enter (Mac) or Esc (Windows). You can also double-
click the starting anchor point.

To draw the curve shown in gray, 
press and drag to set the first 
anchor point and tangent line.

Press and drag to set the next 
anchor point and tangent line. 
The first segment (highlighted) 
grows as you draw out the 
tangent line. 

Press and drag to set the third 
anchor point; the second 
segment (highlighted) grows as 
you drag the tangent line.
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Shaping and editing segments as you draw
As you draw with the Curve tool, you can use modifier keys to con-
strain and edit the path segments.

◆ To place an anchor point at a 45-degree interval relative to 
the previous one: Press Shift as you set the second anchor point.

◆ To create a straight segment: Press Command (Mac) or Ctrl 
(Windows) as you click to set the segment’s endpoint.

◆ To remove the last segment: Press Delete. You can continue 
to remove segments in the reverse order you created them, until you 
delete the entire object.

◆ To create a corner point: Press Option (Mac) or Alt (Win-
dows) and click to set the anchor point.

◆ To constrain a tangent line to 45-degree increments: Press 
Shift as you drag the tangent line.

◆ To move an anchor point as you place it: When placing an 
anchor point, hold down the mouse button and press the Spacebar, 
then move the mouse. While the Spacebar is held down, the anchor 
point follows the mouse movement.

Editing object paths
Most vector objects in Canvas are paths. Whether you draw with path 
tools (Curve, Freehand, or Polygon tools) or shape tools (Rectangle, 
Oval, Line, or Arc tools), you create paths, and you can use the same 
path-editing techniques to modify them.

Of course, you can also change a path object by using handles on the 
bounding box when the object is selected; see “To resize an object’s 
bounding box” on page 167.

When you want to edit a path, you place the object in edit mode to 
display its anchor points. The following sections explain how to work 
in edit mode, edit anchor points, and reshape the segments of a path.
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Working with objects in edit mode
To edit points and segments of a path, you place the path object in 
edit mode. When an object is in edit mode, its anchor points appear 
as small squares along the path; every path has at least two anchor 
points. 

When an object is in edit mode, you can select one or more anchor 
points. You can even select anchor points and segments on more than 
one object at once, as long as the objects are in edit mode.

To place an object in edit mode

Do one of the following to place a path object in edit mode:

• Double-click the object.

• Select the object and choose Path ➤ Edit Path in the Object 
menu.

• After you set the last anchor point when using the Curve or 
Polygon tools, select the Selection tool in the toolbox.

◆ To place multiple objects in edit mode: You can place two or 
more objects in edit mode by selecting them, then choosing Path ➤ 
Edit Path in the Object menu.

◆ To return from edit mode: When you finish editing an object, 
double-click outside the object, or press Enter (Mac) or Esc (Win-
dows) to leave edit mode.

Object path drawn with 
Curve tool

Object in edit mode, with 
anchor points visible
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Using the path edit pop-up menu
When an object is in path edit mode, you can use the path edit pop-up 
menu to help you quickly add, delete, and change anchor points and 
tangent lines. To see this menu, Command-click (Mac) or right-click 
(Windows) with at least one object in path edit mode. The available 
options vary depending on the location of the pointer. Each option is 
described in greater detail later in this chapter.

Modifying specialized objects as paths

Some Canvas drawing tools 
create specialized objects. 
When you double-click one of 
these objects to place it in edit 
mode, Canvas displays special 
editing handles or configura-
tion options, rather than the 
anchor points and segments of 
a regular path object.

The tools that create special 
vector objects are the Concen-
tric Circles, Grid Maker, Multi-
gon, and Spiral tools.

Also, when you modify objects 
with the Envelope or Extrude 
commands, Canvas creates 
specialized objects.

If you want to use path-editing 
techniques to modify these 
objects, you can convert them 
to paths. This usually produces 
a group of objects. After you 
ungroup these objects, you will 
have regular paths that can be 
edited using the techniques in 
this chapter.

You can also convert text char-
acters to paths so that you can 
edit the shapes of individual 
characters.

For more information on edit-
ing specialized objects as 
paths, see “Converting 
objects and text to paths” on 
page 191.

Most Canvas objects can be 
edited the same way, whether 
you use shape tools, path tools, 
or techniques like Combine to 
create them.
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Delete Point Available when the pointer is on an anchor point and 
appears as a crosshair. Removes the anchor point from the path, and 
connects the adjacent anchor points with a path.

Add Point Available when the pointer is on a path segment and 
appears as a gray arrowhead. Inserts an anchor point with a tangent 
line at that location.

Break Available when the pointer is anywhere on a path. Splits the 
path segment at that location, and adds anchor points to the ends of 
the resulting segments.

Join Curves Available when you select two anchor points that are 
not connected by a straight line (the anchor points can be joined by a 
curve, or not connected at all). Connects the selected points with a 
straight line.

Cusp Available when the pointer is on a tangent line handle or an 
anchor point. On anchor points, this option deletes the point’s tangent 
lines. On tangent line handels, this option makes the path either 
smooth or cornered at the anchor point. To be smooth, the anchor 
point must have both sides of a tangent line. When smooth, the 
halves of the tangent line are always 180 degrees from each other and 
rotate around the anchor point like a propeller. When the anchor 
point is a corner, the tangent line segments can move independently 
around the anchor point, like the hands of a clock.

Delete Handle Available when the pointer is on a tangent line han-
dle and appears as a crosshair. Removes the handle and the effects of 
the tangent line on the path.

Add Handle Available when the pointer is on an anchor point and 
there are fewer than two tangent line segments attached to the anchor 
point. Adds tangent line segments to the point.

Straighten Available when the pointer is on a path segment and 
appears as a gray arrowhead. Makes the path segment straight by 
removing tangent lines from the segment’s anchor points.

Delete Point
Add Point
Break
Join Curves
Cusp/Smooth
Delete Handle
Add Handle
Straighten

The path edit pop-up menu
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Selecting anchor points and segments
When you edit paths, you need to select particular anchor points or 
segments before you can delete, move, or reshape them. Before you 
can select anchor points and segments, a path object must be in edit 
mode (see “To place an object in edit mode,” above). 

When a path is in edit mode and you point to an anchor point with the 
Selection tool, the pointer becomes a crosshair. When you point to a 
segment, the pointer becomes a gray arrowhead.

You can select points in more than one object. When you move any 
selected point, all points in the selection move the same way. This 
also works for segments belonging to separate objects.

◆ To select anchor points and segments: With the path object in 
edit mode, click an anchor point or segment to select it. To select 
multiple points or segments, use the Selection tool to drag a selection 
box around them, or Shift-click each point or segment.

◆ To select all anchor points: With the path object in edit mode, 
choose Select All in the Edit menu.

◆ To select parts of separate paths: Place the paths in edit 
mode, and Shift-click the point or segments.

When an anchor point is selected, it changes from a solid to hollow 
square. If the anchor point has tangent lines, they appear when the 
anchor point is selected. When you select a segment, the anchor point 
at each end is selected. 

Adding and deleting points and segments
If a segment’s anchor points are too far apart for you to adjust the 
shape as needed, you can add more. If you create or add more anchor 
points than you need, you can delete unnecessary ones.

Keep in mind that the more points on a path, the more complex and 
system resource-intensive it becomes. In particular, too many anchor 
points can cause printing problems. It’s best to use the fewest possi-
ble anchor points placed as far apart as possible to create a path.

◆ To add an anchor point: With an object in edit mode, Com-
mand-click (Mac) or right-click (Windows) a segment to which you 
want to add an anchor point. In the path edit pop-up menu, choose 
Add Point. You can also Option-click (Mac) or Ctrl-click (Windows) 
a segment to add a point.

When a path is in edit mode, you 
can use the Selection tool to 
drag a selection box around 
multiple anchor points to select 
them.

Selection box
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◆ To delete an anchor point: With an object in edit mode, Com-
mand-click (Mac) or right-click (Windows) the point you want to 
delete. In the path edit menu that appears, choose Delete Point. You 
can also Option+Shift-click (Mac) or Ctrl+Shift-click a point to 
delete it, or select points and press the Delete key.

◆ To delete a segment: Select a segment and press Delete. 
Deleting a segment of a closed path does not split the path open; the 
remaining segments are joined and the path remains closed.

To add segments to an open path

You can add segments to the end of an open path using the Curve 
tool or Polygon tool.

1 With the object in edit mode, select the endpoint where you 
want to add a segment.

2 Select the Curve tool (to add straight or curved segments) or 
the Polygon tool (to add straight segments) in the toolbox.

3 Click to add a straight segment beyond the selected endpoint. 
With the Curve tool, you can add a curved segment by pressing the 
mouse button to establish the new anchor point and then dragging 
to position the tangent line.

4 To add additional segments, repeat the previous step. When 
you finish, press Enter (Mac) or Esc (Windows) to leave edit mode.

Closing and opening paths
A closed path is one that starts and ends at the same anchor point. An 
open path has separate starting and ending points. You can close an 
open path by letting Canvas create a new segment to join the path’s 
two endpoints. You can open a closed path by splitting the path.

◆ To close an open path: With the path in edit mode and the 
Curve or Polygon tool selected, click one of the endpoints. You can 
also Ctrl-click (Mac) or Alt-click (Windows) an endpoint with the 
Selection tool. Canvas closes the path by connecting the endpoints 
with a new segment. If the adjacent segments are curved, the new 
segment follows the curve.

◆ To open a closed path: With the object in edit mode, Com-
mand-click (Mac) or right-click (Windows) an anchor point or seg-
ment to open the path edit pop-up menu. In the menu, choose Break; 
Canvas inserts segment end points to open the object at that location.
Editing object paths 185



18
Using the Scissors tool to open and divide paths 

You can use the Scissors tool to open a closed path and to 
divide a path into two objects. Splitting a path opens the path 

at the point where the scissors clip the path. 

1 Select the Scissors tool in the toolbox. The pointer changes to a 
pair of scissors.

2 Point to the path where you want to split it (you don’t need to 
select the object first). The pointer becomes a crosshair when it is 
on a point or segment that can be split.

3 Click the path when the crosshair is displayed. Canvas adds 
two endpoints where you click the path and the path opens.

4 If the path is closed and you want to split it into two paths, 
click the path again where you want to split it.

Joining two paths

You can use the Join command to create one path from two separate, 
open path objects.

◆ To join two paths: Select the two open path objects that you 
want to join (they should not be in edit mode). Choose Path ➤ Join in 
the Object menu. Canvas connects the two paths by extending the 
existing segments or creating a new segment, depending on the dis-
tance between the objects.

When you use the Join command to connect two objects that are 
more than 15 pixels apart, Canvas creates a new line segment 
between the two closest endpoints. When you join objects whose 
endpoints are 15 or fewer pixels apart, Canvas extends the two 
objects to a midpoint between the two closest endpoints.

When the two endpoints on the paths to be joined are 15 or fewer 
screen pixels apart, you can add a segment by pressing Shift when 
you choose Join. When the distance between the endpoints is greater 
than 15 pixels, you can extend the existing segments by pressing 
Shift when you choose Join.

To join paths at selected endpoints

Canvas, by default, joins paths at the closest endpoints. However, 
you can select which endpoints to join.

1 Place an open object or multiple open objects in edit mode; see 
“To place an object in edit mode” on page 181.
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2 Click an endpoint you want to join to another path. The end-
point becomes hollow to indicate that it is selected.

3 Shift-click another endpoint. The endpoint also becomes hol-
low to indicate that it is selected.

4 Choose Path ➤ Join in the Object menu, or Command-click 
(Mac) or right-click (Windows) one of the selected points to open 
the path edit pop-up menu. In the pop-up menu, choose Join 
Curves.

Reshaping paths by editing anchor points
A path can contain two kinds of anchor points: smooth points and 
corner points. 

Smooth point An anchor point that connects two curve segments 
where the curve flows smoothly through anchor point without a sharp 
change in direction. Circles and sine waves are examples of paths 
that have only smooth anchor points. 

Moving anchor points
and segments

With a path in edit mode, you 
can move points and segments 
to alter its shape.

Drag an anchor point or seg-
ment to move it to a new loca-
tion. You can also use the key-
board arrow keys to move 
selected points and segments. 
Canvas reshapes the segments 
adjacent to the point.

Pressing Shift while dragging 
points or segments will con-
strain their movement to 45-
degree intervals.

In these sailboat illustrations, 
the arrows show the movement 
of the selected points and seg-
ments.
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Corner point An anchor point where the path makes a sharp turn at 
the anchor point. Corner points can connect two straight segments, 
two curved segments, or one curved and one straight segment. 

Tangent lines
All smooth points, and some corner points, have tangent lines pass-
ing through them. Canvas displays the tangent lines when a point is 
selected. 

A corner point can have one, two, or no tangent lines.When you 
select a corner anchor point with two tangent lines, each tangent line 
can move independently of the other. 

When you create paths with only straight segments (using the Poly-
gon tool or the Curve tool), the path’s anchor points are corner points. 
When you draw curved segments (using the Curve or Freehand tool), 
the anchor points are smooth points. In addition, any points that you 
add to segments are smooth points by default.

To change a smooth point to a corner point

You can edit, reshape, and resize two adjoining curve segments inde-
pendently by converting their smooth anchor point to a corner point.

1 With the object in edit mode, click the anchor point to reveal 
its tangent lines.

2 Press Tab and drag one of the handles to move one of the tan-
gent lines. The tangent line pivots at the anchor point and affects 
only one side of the anchor point.

To change a corner point to a smooth point

To smooth out a sharp turn in curved segments, you can change the 
corner point between them to a smooth point.

Note: The corner point must have two tangent lines for this proce-
dure. If it has fewer than two, first add tangent lines to the point.

1 With the object in edit mode, click the anchor point to display 
its tangent lines.

2 Tab-click the handle of the tangent line you want to keep in 
place; the other tangent line snaps into alignment.

◆ To toggle between smooth and corner points using the path 
edit menu: Select an anchor point and Command-click (Mac) or 
right-button click (Windows) a tangent line handle. In the path edit 

A corner anchor point with 
independent tangent lines

Tab-click a handle of a 
corner point (highlighted); 
the other tangent line snaps 
into alignment and smooths 
the path
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pop-up menu, choose Cusp/Smooth. A corner point becomes a 
smooth point, and a smooth point becomes a corner point.

Adding and removing tangent lines
An anchor point can have as many as two tangent line segments. Cor-
ner points can have one, two, or no tangent lines, and smooth points 
must have two. You can quickly convert a smooth point to a corner 
point by deleting one of its tangent lines. Also, to convert a corner 
point with one or no tangent lines to a smooth point, you must add 
tangent lines.

To add a tangent line

1 In path edit mode, select an anchor point with one or no tan-
gent lines. The anchor point cannot be an endpoint with one tangent 
line, because endpoints can have only one tangent line.

2 Press Tab and drag away from the anchor point to place a new 
tangent line. You can also Command-click (Mac) or right-click 
(Windows) and choose Add Handle in the path edit pop-up menu.

3 Repeat the previous step to add a second tangent line.

To delete tangent lines

1 In edit mode, click an anchor point to display its tangent lines.

2 Depending on how you want to edit the anchor point, do one of 
the following:

• To delete one tangent line, Command-click (Mac) or right-
click (Windows) the tangent line handle and choose Delete 
Handle in the pop-up menu. You must use this method for 
anchor points with only one tangent line, and to delete one 
of two tangent lines attached to an anchor point.

• To delete an endpoint’s tangent line, you can also Tab-click 
the anchor point.

• To simultaneously delete both tangent lines of an anchor 
point, Tab-click the point.
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Straightening curve segments
You can straighten a curved segment by selecting it and using the 
Straighten command in the path editing pop-up menu. This command 
deletes the tangent line(s) that are curving the segment.

◆ To straighten a segment: With the object in edit mode, Com-
mand-click (Mac) or right-button click (Windows) the curved seg-
ment that you want to straighten. Choose Straighten in the pop-up 
menu.

Reshaping curve segments
To adjust the shape of a curve, in addition to moving points and seg-
ments along the path itself, you can adjust the tangent lines that con-
trol the curve. The angle of the tangent line affects the curve shape, 
while the length of the tangent line affects the size of the segment.

At a smooth anchor point, adjusting the angle of a tangent line affects 
the curves on both sides of the anchor point. At a corner anchor point, 
you can reshape the segments on each side independently. For more 
information, see “Reshaping paths by editing anchor points” on 
page 187.

To reshape a curved segment

1 With the object in edit mode, click one of the segment’s anchor 
points to display its tangent lines.

2 Drag the handle of the tangent line to change the shape of the 
associated curve. In the case of a smooth point, the tangent line 
affects both adjacent curve segments.

Path editing modifier keys
You can use modifier keys in conjunction with mouse actions to help 
you reshape and edit paths quickly. The following table describes 
available modifier keys for Mac and Windows versions of Canvas.

Middle curve segment 
straightened; Canvas deleted 
the lower tangent line segments 
of both anchor points
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Path editing modifier keys

Converting objects and text to paths
Some vector objects have specialized properties and unique edit 
modes instead of the standard path edit mode. For example, you can-
not directly edit the path segments of macros, concentric circles, 
grids, multigons, spirals, and objects modified by the Envelope or 
Extrude commands. However, you can convert these objects to paths 
so you can edit them the same as any other vector object.

If you create paths from a specialized vector object, the new shape 
does not have the same unique editing capabilities as the original. For 
example, if you convert a multigon star object to paths, you can no 
longer use the edit handles that let you adjust the depth and twirl of 

To edit a path this way Do this on Mac Do this on Windows

Add an anchor point to a segment Option-click a segment Ctrl-click a segment

Delete an anchor point Option+Shift-click an 
anchor point

Ctrl+Shift-click an anchor 
point

Move an anchor point as you place it Hold down the mouse but-
ton, then press the Space-
bar andmove the mouse 

Hold down the mouse but-
ton, then press the Space-
bar andmove the mouse 

Change the length of the tangent lines on both sides of 
a smooth anchor point at the same time

Option-drag a tangent line 
handle

Ctrl-drag a tangent line han-
dle

Constrain movement to 45-degree increments while 
changing the length of both tangent lines of a smooth 
anchor point

Option+Shift-drag a tan-
gent line handle

Ctrl+Shift-drag a tangent 
line handle

Move one side of a smooth point’s tangent line inde-
pendently of the other side (changing the anchor point 
from smooth to cusp)

Tab-drag a tangent 
line handle

Tab-drag a tangent 
line handle

Make a corner point with two tangent lines into a 
smooth point

Tab-drag a tangent 
line handle

Tab-drag a tangent 
line handle

Constrain movement to 45-degree increments while 
changing an anchor point from smooth to cusp (or cusp 
to smooth)

Tab+Shift-drag a tangent 
line handle

Tab+Shift-drag a tangent 
line handle

Add a tangent line to an anchor point that has fewer 
than two tangent lines

Tab-drag an anchor point Tab-drag an anchor point

Delete both tangent lines of an anchor point or the tan-
gent line of an endpoint

Tab-click the anchor point 
or endpoint

Tab-click the anchor point 
or endpoint

Close an open path Ctrl-click an endpoint Alt-click an endpoint
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the points. Similarly, placed macros are no longer linked to their par-
ent macros in the Gallery palette after you convert them to paths.

You can also convert text so you can reshape characters as vector 
objects. This has the benefit of making the characters independent of 
their fonts; the font is no longer required to view and print the charac-
ters properly. However, once you convert text to paths, you can no 
longer perform text operations, such as editing, spell-checking, and 
formatting, on the text. Also, characters with “holes” in them (such as 
a, b, d, e, g, o, p, r, and q) are converted to composite paths, which 
cannot be extruded.

◆ To convert an object to paths: Select the object you want to 
convert and choose Path➤Convert To Paths in the Object menu. Can-
vas converts the object to one or more paths.

Ungrouping objects made of multiple paths

When you convert multiple objects, characters, or specialized vector 
objects to paths, Canvas creates a separate path for each shape and 
groups them. You can use the Ungroup command in the Object menu 
to separate them. 

For example, if you convert a five-letter word to paths, the resulting 
object is a group of five paths. To edit just one of the five paths, first 
choose Ungroup in the Object menu. You can also use the Direct 
Selection tool to select one path without first ungrouping the object.

Making and breaking composite paths
You can create openings in a filled path by incorporating multiple 
paths into a single, composite path. Areas between the paths and 
areas where the paths intersect are transparent.

◆ To create a composite path from multiple paths: Select the 
paths you want to compose the composite path. Choose Path➤Make 
Composite in the Object menu.

◆ To separate a composite path: Select the composite path and 
choose Path➤Break Composite in the Object menu.

Gradient ink applied to a 
composite object
2 Chapter 12: Drawing and editing paths



Setting up a document’s measureme
13

PRECISION DRAWING AND 
DIMENSIONING

This chapter describes precision drawing tools and techniques that 
can help you create scale drawings, floor plans, architectural designs, 
and other types of technical drawings. This chapter explains how to

• display size information as you draw

• set up the scale for scale drawings

• add dimension objects to illustrations

• use Smart Mouse to align objects

Some of the techniques described elsewhere in this book also apply 
to precision drawing. For information on document setup and using 
rulers, refer to Chapter 3, “Document Setup.”

Setting up a document’s measurement scale
Canvas offers a variety of options for creating scale drawings. You 
can set up a ruler to control the scale of an entire document. You can 
also customize scale settings for individual dimension objects. Other 
settings affect the format of measurement and position data.

The following settings affect the measurement of objects in a docu-
ment:

Rulers You set up a document’s overall drawing scale using the 
Rulers command and Rulers dialog box. The ruler scale affects all 
object measurements, including those made with the dimensioning 
tools. The ruler scale also affects data in the Object Specs palette and 
status bar. See “Setting up rulers and the drawing scale” on page 41.

Number form A setting in the Preferences dialog box that affects 
the format of data in the status bar and other displays. This option 
controls the precision of data and the number format (decimal or frac-
tions). See “Measurement unit preferences” on page 91.

Dimensions You can create custom scale settings for dimension 
objects using the Dimensioning dialog box. You can customize indi-
vidual dimension objects, or set a custom scale for all dimension 
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objects created with a dimensioning tool. See “Customizing the 
dimensioning tools” on page 198 for more information.

Displaying dimensions as you draw
Canvas can display the horizontal and vertical dimensions of an 
object as you draw it. The Show Size command makes dimensions 
(in scale) appear at the pointer as you drag with any drawing tool. 
These dimensions do not remain in the document. 

◆ To display dimensions when you use drawing tools: Choose 
Display ➤ Show Size in the Layout menu. When you select a draw-
ing tool and drag the pointer in an illustration, the object’s vertical 
and horizontal measurements appear at the pointer.

When Show Size is on, the command changes to Hide Size.

◆ To turn off the dimensions display: Choose Display ➤ Hide 
Size in the Layout menu. This command only appears when Show 
Size is on.

Using the status bar display

The status bar at the bottom of the screen displays dimensions and 
position data that can assist you when you draw objects.

The data in the status bar are based on the overall document scale as 
defined by the current ruler setting. When you draw a vector object, 
the status bar displays the horizontal and vertical dimensions for most 
objects. When you move an object by dragging it with the Selection 
tool, the status bar displays the horizontal and vertical distance that 
the object has moved. The measurements are based on the overall 
measurement scale as defined in the Rulers dialog box.

Using the dimensioning tools
You can easily add formatted dimensions to documents with the Can-
vas dimensioning tools. These tools can measure horizontal, vertical, 
oblique and perpendicular distances; diameter, radius, angle, area, 
and perimeter; and mark the centers of arcs and ovals.

Some dimensioning tools create a single dimension, while others let 
you create baseline and chain dimensions. Baseline dimensions are a 
series of measurements made from a common starting point. Chain 
dimensions are a series of measurements in a row.

When Show Size is active, 
Canvas displays the scaled size 
of the object as you draw.
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You can create dimension objects that conform to industry standards, 
including the ANSI, DIN and JIS standards. You can also customize 
the standard settings — the size of lines, gaps, text, and tolerances. 
You can also save settings that you have customized as new stan-
dards.

The 17 dimensioning tools are grouped in a palette. To open the pal-
ette, press the dimensioning tool that appears in the Object tools pal-
ette. You can drag the palette away from the toolbox to keep it open 
while you work.

To add dimensions to an illustration

1 Select a dimensioning tool in the toolbox. When you move the 
pointer into the document, a prompt appears at the pointer. 

2 To begin dimensioning, position the pointer and click as 
directed by the prompt. The prompt varies, depending on which 
dimensioning tool you use. For example, if you use the Horizontal 
dimensioning tool, the prompt says “Click 1st Point.” 

Refer to the table “Dimensioning procedures” on page 197 for details 
on what you should do when each prompt appears.

3 When the “Anchor” prompt appears, move the pointer to posi-
tion the dimension. If you drag away from the measurement points, 
the witness lines extend and the text follows the pointer.

4 To anchor the dimension in place, click once.

5 For chain and baseline dimensions, you can click additional 
measurement points and anchor each part of the dimension object. 
After you anchor the last part, press Enter (Mac) or Esc (Windows) 
to finish the object.

✔ Tip
The Smart Mouse can help 
ensure precise measurements. 
You can set the Smart Mouse 
so the pointer snaps to corners 
and anchor points when you 
use dimensioning tools. See 
“Using Smart Mouse for pre-
cise alignment” on page 203.
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Types of dimensioning tools and measurements

You use the dimensioning tools 
to add measurements to illustra-
tions. Different tools let you cre-
ate different types of dimension 
objects.

Baseline and chain dimension-
ing tools create groups of 
dimensions. Baseline dimen-
sions contain several measure-
ments from a common starting 
point. Chain dimensions are a 
series of measurements.

A Vertical

B Oblique

C Radius

D Diameter

E Vertical Baseline

F Oblique (with aligned text)

G Vertical Chain

H Angle

I Horizontal

 19.3  ft. 

 11.7  ft. 

 16.7  ft. 

 13.9  ft. 

 28.3  ft. 

74.98°

 1
6.

7 
 ft

. 

A

B

D

C

E

F
GH

I

 2.80  cm. 

 5.75  cm. 

 0.90  cm. 

 2.86  cm. 
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Dimensioning procedures

Linking dimensions to measured objects
Because dimension objects aren’t attached to the objects they mea-
sure, dimensions do not change when you resize objects you have 
measured. However, you can group a dimension object and the object 
that it measures. When you do this and then you resize the object, the 
dimension changes accordingly.

◆ To group an object and a dimension object: Select the dimen-
sion object and the measured object and choose Group in the Object 
menu.

Attributes of dimension objects
When you create a dimension object, Canvas uses the current ink and 
stroke settings, which are shown by the pen ink, fill ink, and stroke 

Dimensioning tool Prompts Procedure

Horizontal, Oblique, and Vertical

Click 1st Point, 
Click 2nd Point

Click the start point for the measurement, then click 
the end point and anchor the dimension object.

Baseline and Chain (Horizontal, 
Oblique, and Vertical)

Click 1st Point, Click 
Next Point

Click the start point and then click the end point for 
the first measurement; anchor the first part of the 
dimension object. Click the next measurement point 
and anchor the next part of the dimension object. 
Continue until finished, then press Enter (Mac) or Esc 
(Windows).

Angle Click 1st Line, Click 
2nd Line

Click the start point for the angular measurement, 
then click the end point.

Perpendicular Click Line, Click 
Point

Click the line to measure from, then click a point any-
where to take a perpendicular measurement from the 
line to the point.

Object Side Click Object Side Click the side of the object to be measured.

Radius, Diameter, and Center

Click Arc/Ellipse Click anywhere on the arc or ellipse and then anchor 
the dimension object.

Area and Perimeter

Click Object Click anywhere on the object to be measured and 
then anchor the dimension object.
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icons in the toolbox. The dimension text uses the current text settings, 
as indicated in the Text menu by a check mark. 

You can change the current ink, stroke, and text settings for new 
dimension objects, and you can change these settings for existing 
dimension objects.

◆ To change the type attributes of a dimension object: Select 
the dimension object and use the Text menu or the Type palette to 
choose the font, size, style, and other attributes of the text. 

◆ To change the appearance of a dimension object: Select the 
object and use the Inks and Strokes palettes to select ink color, pen 
size, and arrows for the dimension object.

◆ To change attributes for new dimension objects: Make sure 
that no objects are selected in the document, and then use the Text 
menu (or the Type palette), and the Inks and Strokes palettes to 
change the current settings for new objects and text.

Customizing the dimensioning tools
You can customize the measurement units, scale, arrow position, tol-
erance text, and other settings for dimension objects. You use the 
Dimensioning dialog box to configure these settings. You can set up 
different configurations for the three categories of dimensioning tools 
— angular, linear, and radial. You can also use the Dimensioning 
dialog box to change existing dimension objects.

Using the Dimensioning dialog box

You can open the Dimensioning dialog box by double-clicking a 
dimensioning tool icon or a dimension object, depending on whether 
you want to configure the tool or edit a dimension object. Use one of 
the following three methods to open the dialog box. 

◆ To change the properties of regular dimension objects: Dou-
ble-click the dimension object to open the Dimensioning dialog box. 
To change multiple dimension objects, select them and then double-
click one of the objects.

◆ To change the properties of chain and baseline dimension 
objects: Select the dimension object and choose Ungroup in the 
Object menu. Then, double-click one of the dimension objects to 
open the Dimensioning dialog box. You can also double-click a 
dimension object with the Direct Selection tool to open the dialog 
box without ungrouping the objects first.

✔ Important
Dimension objects can not dis-
play arrows if all the preset 
arrows have been deleted from 
the Arrow tab in the Strokes 
palette.
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◆ To change the settings for dimensioning tools: Make sure 
that no dimension objects are selected, then double-click a dimen-
sioning tool icon to open the Dimensioning dialog box.

1 Choose the type of dimensions you want to configure in the 
Dimension Type pop-up menu. (If a dimension object was selected, 
the object type appears in the pop-up menu).

2 In the Style area, adjust the settings for arrow placement, text 
position, and text framing.

3 Choose the text alignment method in the Text Display pop-up 
menu.

4 To configure leaders for linear and radial dimension objects, 
select one of the following options in the Leading Character pop-up 
menu: 

5 To configure radius and diameter symbols for radial dimension 
objects, select one of the following options in the R,D Symbols 
pop-up menu:

Select this type To configure these dimensioning tools

Angular Angle

Radial Radius, Diameter, Center

Linear Horizontal, Vertical, Side, Horizontal Baseline, 
Vertical Baseline, Horizontal Chain, Vertical 
Chain, Perpendicular

Object Info Area, Perimeter

None Does not include a leader

Left Includes a left-pointing leader

Right Includes a right-pointing leader

Automatic Applies to radial dimension objects only. 
Includes a leader pointing left when dimension 
object is left of the object’s center, and a leader 
pointing right when dimension object is aligned 
with or right of the object’s center.

None Does not include any symbols.

Leading Places symbols before the dimension text.

Trailing Places symbols after the dimension text.
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6 To set the dimension precision, choose an option in the Preci-
sion pop-up menu. The options tell Canvas to use fractions or the 
specified number of decimal places in dimension text.

7 To specify the format of tolerance data in dimension objects, 
choose one of the following options in the Tolerance pop-up menu. 
Type the tolerance numbers in the text boxes.

8 To set a custom scale for dimension objects, turn Custom Units 
on. This overrides the measurement units specified for the docu-
ment rulers. Choose a measurement unit in the adjacent pop-up 
menu and type the actual measure in the first text box. Type the 
scaled measurement in the second text box. Choose the scale mea-
surement unit in the adjacent pop-up menu.

For example, if you want to use a scale of 1 centimeter equals 1 
meter, do the following: turn on Custom Units; select Centimeter in 
the first pop-up menu; type “1” in the first and second text boxes; and 
choose “m.” in the second pop-up menu.

9 Click OK to close the dialog box and implement the settings.

None Does not include any tolerance amount.

One Prints the tolerance amount from the first text 
box, with “±  “and the dimension text. 

Two Prints tolerance numbers from both text boxes. 
To use a negative number, type a minus sign (–) 
before the number.

Limit Prints two dimensions, calculated from the 
actual dimensions and the two tolerance values.
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Using industry standards for dimension objects
If you want to use industry standard settings for dimension objects, 
click the Standards button in the Dimensioning dialog box to open 
the Dimension Standards dialog box. You can choose several indus-
try standards in the pop-up menu. You can also use the Dimension 
Standards dialog box to further customize dimension objects.

Style and Text Display settings

Use the following style options 
in the Dimensioning dialog 
box to customize the appear-
ance of dimension objects.

A Arrows Inside. Dimension 
arrows appear next to the di-
mension text when this option 
is on.

B Center Text. Must be off if 
you want to drag dimension 
text outside the witness lines.

C Frame Text. Turn this op-
tion on to frame the dimension 
text.

Use the following options in 
the Text Display pop-up menu 
to format the dimension text.

Horizontal. Text is always 
aligned horizontally in all 
dimension objects.

Horz/90º. Text is aligned hori-
zontally, except text is rotated 
90º vertically for vertical 
dimension objects.

Aligned. Text is always aligned 
with the angle of the dimen-

sion arrows.

Above. Text runs above the 
dimension arrows.

Below. Text runs below the 
dimension arrows.

A

B

C2.75 ft 2.75 ft

2.75 ft2.75 ft

2.75 ft 2.75 ft

Option on Option off
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Saving and deleting settings

If you customize the settings in the Dimension Standards dialog box, 
you can save the settings as a custom standard. Press the triangle but-
ton at the bottom-left corner of the Dimension Standards dialog box 
to display a menu for saving and deleting dimension standards.

When you save or delete standards, they remain saved or deleted 
whether you click OK or Cancel to close the Dimension Standards 
dialog box.

◆ To save the settings as a new standard: Press the triangle but-
ton at the bottom-left corner of the Dimension Standards dialog box. 
In the pop-up menu, choose “Save settings as.” Type a name for the 
custom standard in the dialog box that appears. Click OK. The new 
standard will appear in the Current Standard pop-up menu.

◆ To delete a custom standard: Press the triangle button at the 
bottom-left corner of the Dimension Standards dialog box. In the 

Dimension Standards settings

The settings in the Dimension 
Standards dialog box specify 
the length and position of vari-
ous elements of dimension 
objects, based on industry 
standards.

Current standard. Choose 
from five standard measure-
ment systems: ANSI (American 
National Standards Institute) 
DIN (Deutches Institut für Nor-
mung), BS-380 (British Stan-
dards Institute), ISO (Interna-
tional Organization for 
Standardization), and JIS (Jap-
anese Industrial Standard). 

Settings you create also 
appear in this pop-up menu.

Units. Choose the measure-
ment units you want to use for 

all settings in the dialog box.

A Extension. Set the length 
of the witness lines’ extensions 
and the center line extension.

B Gap. Set the size of the gap 
between the witness lines and 
measurement points on ob-
jects; the gap between the cen-
ter extension and center point 
mark; and the gap between the 
dimension text and dimension 
arrows.

C Length. Set the length of 
the arrow lines (applies only 
when arrows are outside the 
witness lines); the length of cen-
ter extension lines’ leader char-
acters; and the length of the 
center extension line.

D Tolerance scale. The size of 

tolerance text and space be-
tween tolerance text, as a per-
centage of the dimension text 
size and spacing.

A

B

C

D
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pop-up menu, choose “Delete standard.” In the dialog box that 
appears, choose a custom standard in the pop-up menu and click OK.

Using Smart Mouse for precise alignment
Smart Mouse is a drawing aid that can help you align objects pre-
cisely. Smart Mouse is particularly useful when using dimensioning 
tools, because it can snap the pointer to the corners (and other points) 
of objects, so dimension objects are perfectly aligned.

You can use 12 types of Smart Mouse constraints. The constraints 
make the pointer (and objects that you draw or drag) snap to 

• the corners or centers of objects

• even divisions (such as the midpoints) of object segments

• specified lengths or angles

• horizontal, vertical, or diagonal movement

• tangential or perpendicular alignment with objects

• the edges of vector objects

Types of Smart Mouse constraints
Relative constraints Indicate the relationship between the begin-
ning position and current position when you draw or drag an object. 
These constraints can display pointers to indicate a constraint is met. 
The relative constraints are: Horizontal, Vertical, Diagonal, Angle, 
Multiple Angle, Length, and Tangent & Perpendicular.

Absolute constraints Indicate the relationship between the pointer 
and objects. These constraints (except Object Edges) can display 
source lines and pointers to show a constraint is met. The absolute 
constraints are: Object Corners, Object Fractions, Polygon & Bézier 
Anchors, Polygon Fractions, and Object Edges.

To activate Smart Mouse constraints
To use the Smart Mouse, select the constraints and then turn on Snap 
To Smart Mouse. Refer to the table “Smart Mouse constraints” on 
page 204 to learn how each constraint works.

1 Choose Smart Mouse in the Layout menu. This opens the 
Smart Mouse palette, which contains icons for all constraints. 

• To identify a constraint, press the icon and its name and cur-
rent value (if any) pops up. 

Constraint icons appear in the 
Smart Mouse palette. The active 
constraints are shaded.
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• To activate or deactivate a constraint, click its icon. Active 
constraint icons are highlighted. 

2 Choose Snap To ➤ Smart Mouse in the Layout menu to turn on 
the Smart Mouse. A check mark shows that Smart Mouse is active.

Note: Be sure Snap To Grid (in the Layout ➤ Snap To menu) is off 
when you use the Smart Mouse. If Snap To Grid is on, the pointer 
will snap to the grid and not to active Smart Mouse constraints.

Smart Mouse constraints

Identifying multiple constraints

Up to two Smart Mouse constraints can be met at the same time. For 
example, you can drag an object in such a way that it triggers both the 
horizontal constraint and object corner constraint. Although you can 
activate several constraints, only two constraints can affect the 
pointer at once.

When this constraint is active Smart Mouse snaps objects and constrains the pointer to

Angle A specified angle

Diagonal Straight diagonal movement — all multiples of 45º

Horizontal Straight horizontal movement— 90º and 270º, or 0º and 180º, depending on 
the current coordinate system

Vertical Straight vertical movement — 0º and 180º, or 90º and 270º, depending on 
the current coordinate system

Length A specified length in points (based on 100% magnification)

Multiple Angle All multiples of the specified angle

Object Corners The corners of the bounding boxes of vector objects

Object Edges Edges of the paths of vector objects (not their bounding boxes); when Object 
Edges is active, other constraints don’t affect the pointer

Object Fractions A specified division of vector objects; for example, specify 1/2 to snap to the 
center of objects

Object Points Any anchor point on the paths of vector objects

Object Segments Specified divisions of the segments of vector objects; for example, the pointer 
snaps to the midpoints of segments if you specify 1/2

Tangent & Perpendicular Movement in a straight line, tangent or perpendicular to vector objects
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Smart Mouse can display special pointers to indicate that constraints 
are met. You can toggle the pointer display if more than one con-
straint is active. The Pointer option (see “Constraint settings,” next) 
must be active to see Smart Mouse pointers.

◆ To toggle the Smart Mouse pointer: Press Command (Mac) 
or Alt (Windows) when a constraint pointer is visible. If another 
pointer appears, both constraints are met. The symbols won’t change 
for different settings of one constraint type, such as two different val-
ues for the Angle constraint. 

Customizing Smart Mouse constraints
You can activate constraints, change their values, and add and delete 
constraints in the Smart Mouse dialog box. 

1 Choose Smart Mouse in the Layout menu to open the Smart 
Mouse palette if necessary, then double-click a constraint icon to 
open the Smart Mouse dialog box.

2 To activate or deactivate a constraint, click to the left of the 
constraint name in the scrolling list. You can activate multiple con-
straints, but only two can affect the pointer at once.

3 Configure the constraint settings described next and click OK.

Constraint settings

The settings in the Current Constraints area at the top of the Smart 
Mouse dialog box affect the behavior of all Smart Mouse constraints. 
Select a constraint in the list to see its symbol in the Icon box.

Priority When multiple constraints are active, those at the top of the 
scrolling list take precedence over those lower in the list. To change 
the priority of a constraint, drag it to a new position in the list.

Source Lines If checked, Canvas displays a line to show that the 
pointer, or an object you are moving, is aligned horizontally or verti-
cally with a snap point — such as the corner of an object.

Pointers If checked, constraint symbols appear as you draw or drag 
objects to indicate that a constraint is met. 

Constraint Range The maximum distance, horizontally or verti-
cally, from a target point at which the constraint causes the pointer to 
snap to the target point. 

Objects Within For absolute constraints only, specifies how close 
the pointer must be to an object for the object to trigger the constraint. 

✔Tip
To temporarily hide Smart 
Mouse pointers, press the Shift 
key. Smart Mouse pointers 
reappear when you release the 
Shift key.

Constraints are listed at the top 
of the Smart Mouse dialog box, 
from High to Low priority. A 
check mark indicates active 
constraints. Constraints 
preceded by a delta symbol (∆) 
are relative constraints.
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Adding and deleting constraints

You can add new Smart Mouse constraints and delete ones you don’t 
need. When you add a constraint, it appears in the Smart Mouse win-
dow; constraints you remove no longer appear.

1 Double-click an icon in the Smart Mouse window to open the 
Smart Mouse dialog box. If the Smart Mouse Window isn’t open, 
choose Smart Mouse in the Layout menu.

2 To add a constraint, choose one in the Type pop-up menu. For 
a relative constraint, enter the constraint value in the Value box, 
and then click the Add button.

3 To delete a constraint, select the constraint in the scrolling list 
at the top of the dialog box, and then click the Remove button.

4 Click OK to implement any changes and close the Smart 
Mouse dialog box.

For this Constraint Enter this value

Object Fractions, 
Object Segments

The number of divisions. For example, type 
2 if you want the constraint to snap to the 
middle (1/2 point) of an object or segment.

Angle The angular measurement in degrees.

Length The distance in pixels.
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Masking 
14

VECTOR EFFECTS

Canvas provides several special effects that let you develop complex 
illustrations from basic objects. You can apply the effects described 
in this chapter to any vector object; some can be applied to text 
objects, too. These commands help save time by quickly generating 
new objects and letting you easily modify the appearance of existing 
objects.

This chapter explains how to use these menu commands:

Mask Uses a vector or text object to block out another vector, text, 
or paint object.

Transform The commands in the Transform submenu let you col-
orize and fractalize objects, and create offset shadows.

Combine Creates new objects from two or more objects. You can 
outline, merge, subtract, and divide overlapping objects.

Blend Creates a series of objects that merge one shape into another. 
You can use Blend to create subtle shading and to generate chains of 
gradually changing shapes.

Envelope Lets you distort objects using preset envelopes and lets 
you create custom envelopes for reshaping objects.

Extrude Adds a third dimension and lighting effects to vector 
objects. You can manipulate extruded objects interactively in three-
dimensional space.

As you apply effects to objects, keep in mind that some of these oper-
ations are system memory-intensive and might significantly increase 
the resource and storage requirements of a document.

Masking objects
In Canvas, you can use text and vector objects to selectively show 
portions of other text, vector, or paint objects behind it. This is called 
masking, and the front object is a mask object. Mask objects are like
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windows in a wall; through the transparent mask, you can see what’s 
behind it, but the rest is blocked from view.

You can mask multiple objects with one object. Canvas does not 
group these objects, letting you move the mask object or any of the 
background objects independently to get the perfect arrangement. In 
addition, you can choose to display or hide the outline of the mask 
object, or remove the mask effect entirely.

◆ To mask objects: Select at least two overlapping objects; the 
front object will become the mask object, and must be a vector or text 
object. Choose Mask➤Make in the Object menu.

◆ To hide or show the outline of a mask object: Select a mask 
object and choose Mask➤Hide/Show in the Object menu. 

◆ To remove a mask effect: Select a mask object and choose 
Mask➤Release Mask in the Object menu.

Combining objects
The Combine command makes new objects from the intersection of 
two or more vector objects. You can outline the overlapping objects, 
delete all except the overlapping area, subtract the overlapping area, 
and perform other combinations.

To combine objects

1 Select two or more objects that you want to combine. Each 
selected object must overlap at least one other selected object.

2 Choose Combine in the Effects menu to open the Combine pal-
ette, if necessary.

Text object in front of an 
image of a clam shell

The Mask command lets you 
hide portions of the image 
that are not directly behind 
the text
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3 In the Combine palette, choose a combine method from the list 
(the methods are described below). An example of the selected 
combine method appears on the right.

4 Click Apply to implement the current settings.

Selecting a combine method
In the Combine palette, you can choose various methods for combin-
ing objects. Some methods require that the paths of overlapping 
objects intersect for the effect to be visible or work properly. In addi-
tion, some methods work only with closed vector objects, and not 
with lines and open curves.

Outline Creates one path around the selected objects and fills the 
interior of the new shape with the ink of the front object.

Add Joins two objects where they overlap to create a compound 
path, and fills the new shape with the ink of the front object. Com-
pound paths can include multiple closed shapes that have holes in 
them, unlike objects created with the Outline option.

Example of selected method

Choose a combine method

Original objects: 
two circles and a 
rotated square

Objects combined 
with the Outline 
method

Outline shape smoothed 
into a heart using path- 
editing techniques
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Intersect Creates a new object from the intersection of all selected 
objects and fills the new object with the ink of the front object. All 
selected objects must be closed paths and share a common area.

Punch Removes the area where selected objects intersect and fills 
the new object with the ink of the front object. If you select more than 
two objects, Canvas starts with the back object and continues forward 
through the stacking order. 

Subtract Front Removes from the back object the areas of overlap-
ping objects in front. The back object retains its ink attributes.

Subtract Back Removes from the front object the areas of overlap-
ping objects behind it. The front object retains its ink attributes.

Crop Removes areas of objects that are not behind the top object.

With the Add method, Canvas 
merges the handle to the cup 
where they overlap, leaving a 
hole inside the handle

Original objects Combined with Add method

The Intersect method helps you 
create some useful, basic shapes. 
Here, the intersection of two 
circles (highlighted) results in an 
eye shape.

The Crop method can produce 
effects similar to “masking” an 
illustration. However, cropping 
actually removes areas, where 
masking only hides areas.

For this illustration, the artist used 
an oval to crop a vector drawing of 
pine trees. Another gradient-filled 
oval provides a background for the 
completed drawing.
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Divide Creates new objects where selected objects overlap. This 
option lets you use lines to “cut” other objects in pieces.

Slice Cuts the path of an object where it intersects with objects in 
front of it in the stacking order. Unlike other combine methods, slice 
results in open-ended paths. For example, slicing a circle in half with 
a line produces two arcs, as opposed to two closed semicircles.

Mix Creates new objects where selected objects overlap, similar to 
the Divide option. However, Canvas fills overlapping areas with a 
new color (the original colors must be solid). To determine the new 
color, Canvas compares the CMYK values of all the overlapping 
objects and uses the highest value of each color. (If you are using 
RGB colors, Canvas first converts the colors to CMYK.) For exam-
ple:

Transparency Creates new objects where selected objects overlap, 
and fills overlapping areas with a new RGB color (the original colors 
must be solid). However, transparency lets you specify the level of 
transparency. When you select the Transparency option, enter a per-
centage in the text box that appears; 100 percent is completely trans-
parent, and zero is opaque.

Note: If multiple overlapping objects are grouped, Canvas treats the 
group as a single object and doesn’t apply the transparency or mix 
effect within the group.

Cyan Magenta Yellow Black

Color 1 50 30 25 5

Color 2 25 40 20 0

New Color 50 40 25 5

Using the Divide method, the 
artist “broke” the wine glass 
with a jagged line.

Using the Transparency method, the artist created 
the illusion that you can see through the wine 
glass. Where the glass overlaps the wine bottle, 
you can faintly see the bottle’s label and shape.
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Blending objects
Using the Blend effect, you can create gradual transitions in shape, 
color, and stroke width between two or more objects. Canvas gener-
ates a series of objects (from back-to-front through the stacking 
order) that appear to transform one object into another. 

Artists often use blends to create highlights and shadows in vector 
drawings that provide the illusion of roundness and lighting. In addi-
tion, you can use blends to copy and evenly distribute objects around 
shapes to create borders.

Canvas can blend solid color inks only. If you blend objects with 
hatches, symbols, textures, or gradients, Canvas generates the blend 
objects but doesn’t fill them with an ink.

Building complex shapes

Combine makes it easy to cre-
ate complex shapes such as 
gears. 

A Small circles were distribut-
ed around the large circle using 
the Blend command (described 
in this chapter), then un-
grouped. 

B The Subtract Front method 
removed the small circles to cre-
ate the teeth of the gear. 

C The Punch method re-
moved the center of the gear.

D To create the spokes of the 
gear, Subtract Back was used to 
remove the four ovals from the 
circle. 

E Completed spokes of the 
gear.

F Punch was again used to 
create the hole for the axle.

Completed gear

D E F

A B C
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Using blends for dimensional effects
By specifying a high number of blend objects, you can create gradual 
transitions between shapes and colors. With the appropriate settings, 
colors seem to fade and mix into each other, and the blend objects do 
not appear as distinct objects. This effect is often used to add realistic 
highlights and shadows to objects so they appear three-dimensional.

When configuring the blend settings, keep in mind that the size of the 
final output affects the number of shapes required to make the blend 
appear smooth. For large posters, you might need to use a lot of 
shapes, but fewer shapes are required for small illustrations.

In addition, objects that you blend must have the same number of 
anchor points for the blend to appear smooth. Canvas uses the anchor 
points to calculate the steps and shapes in a blend; an inconsistent 
number of anchor points can cause unwanted twists and distortions.

To blend objects

Select two or more vector 
objects. If necessary, choose 
Blend in the Effects menu to 
open the palette. Configure 
the settings and click Apply.

# of shapes. The number of 
objects Canvas creates for the 
blend. Higher numbers result 
in smoother blends.

Rainbow colors. Creates a 
rainbow-like blend of colors 
between objects. This intro-
duces more color variations 
than a standard blend, which 
uses only combinations of the 
original colors. When you turn 
on this option, two buttons 
appear; choose a clockwise or 
counter-clockwise path around 
the color wheel.

Bind to a path. Turn on to use 
the path of an object (not in 
the current selection) to 
arrange blend objects. When 
you click Apply, Canvas 
prompts you to Choose Path; 
click the object to which you 
want to bind the blend 
objects.

Point to point. Available when 
blending two objects. This 
option lets you rotate blend 
objects, creating the illusion 
that one object is twisting into 
another. When you click Apply, 
Canvas prompts you to Choose 
1st Point; click an anchor point 
on one object. Canvas then 
prompts you to Choose 2nd 
Point; click an anchor point on 
the other object. To reverse 
the blend direction, Option-

click (Mac) or Ctrl-click (Win-
dows) when you choose the 
two points.

Dynamic. Lets you use the 
Direct Selection tool (hollow 
arrow) to accelerate, deceler-
ate, expand, contract, and 
redirect the blend after Can-
vas creates it. Dynamic blends 
aren’t available for specialized 
objects, such as multigons, spi-
rals, concentric circles, and 
grids.

✔Tip
To ensure that blended objects 
have the same number of 
anchor points, copy an object, 
edit its shape, and blend 
between these objects. 
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Using blends to create patterns
Although blends are often used to create gradual, smooth transitions 
between shapes and colors, you can also use the Blend command to 
create and evenly space a pattern across a layout. By specifying a low 
number of shapes and widely spacing the front and back objects, you 
can make each blend object a distinct object. This effect can be useful 
for creating borders and other patterns.

Shading with blends

By choosing the right shape 
and color combinations, you 
can use the Blend effect to 
create realistic three-dimen-
sional effects, such as 
chroming.

The airbrush shown here is a 
very complex application of 
blends, using high numbers 
of shapes to create subtle 
transitions that give the 
impression of roundness 
and reflectiveness.

The artist created this border by 
first creating a flower-like multigon, 
copying it, and drawing an oval. To 
distribute the flowers evenly 
around the oval, the artist selected 
the two multigons, turned on the 
“Bind to a path” option in the 
Blend palette, specified a relatively 
low number of shapes (15) for the 
blend, and chose the oval as the 
binding path. 
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Distorting shapes
The Envelope command lets you distort shapes and text, as if an 
illustration was drawn on a rubber sheet and then stretched.

When an object is in envelope edit mode, its bounding box acts like 
the rubber sheet. Canvas includes several envelope styles that offer 
various handles you can use to stretch an object’s bounding box. 
Using this effect, you can create new shapes, add a sense of motion to 
an illustration, or arrange text so it appears to be painted on a three-
dimensional object.

Using envelope templates
Canvas has several envelope templates that you can use to instantly 
distort shapes. The silhouettes in the template scroll list show the dis-
tortion created by each template.

In addition, you can create your own envelope templates. After you 
apply the envelope effect to an object, you can acquire the shape of 
the envelope as a template.

To apply an envelope template

1 Select a vector object.

2 Choose Envelope in the Effects menu to open the Envelope 
palette, if necessary. 

3 In the palette, choose Template in the pop-up menu. 

4 Click a preview shape in the scroll list to select it, and click 
Apply. 

Using the Envelope command, 
the artist distorted the type for 
the ship’s name to match the 
contour of the ship’s hull, giving 
the impression that the name was 
painted on the side.
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To save an envelope as a template

To store an object’s envelope as a template, you must first have used 
the envelope effect on the object. (See “To apply an envelope effect,” 
next.) You can’t acquire a standard vector shape, such as a circle, 
unless you first apply the envelope effect

1 Select an object that has been edited using the envelope effect. 
The object cannot be in envelope edit mode.

2 Choose Envelope in the Effects menu to open the Envelope 
palette, if necessary. 

3 In the pop-up menu, choose Template.

4 Click Acquire; a preview of the envelope shape appears in the 
scroll box.

◆ To delete an envelope template: In the Envelope palette, 
choose Template in the pop-up menu. Click a preview shape in the 
scroll box to select it, and click Delete.

Using envelope styles
In addition to envelope templates, Canvas has six envelope styles that 
let you edit shapes in different ways. Each style moves and changes 
the bounding box in a particular way. See the table below for infor-
mation on the attributes of each style.

To apply an envelope effect

1 Select a vector object.

2 If necessary, choose Envelope in the Effects menu to open the 
Envelope palette. 

3 In the palette, choose an envelope style in the pop-up menu and 
click Apply. 

4 Drag the envelope handles that appear on the bounding box of 
the object to edit the shape.

Example of selected envelope style

Select an envelope style

Options for Warp style only
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Envelope styles and editing options

Extruding objects
The Extrude command lets you create objects that appear to have 
three dimensions. Canvas can create parallel, circular, and semi-cir-
cular using vector objects, and parallel extrusions using text objects.

You can rotate and scale extruded objects in three-dimensional space. 
In addition, you can set the placement, intensity, and color of a simu-
lated light source and Canvas applies appropriate shading to the 
extruded object.

Although Canvas extrusions appear similar to QuickDraw 3D 
objects, they do not require installation of the QuickDraw 3D shared 
libraries, and do not use the 3DMF (3D metafile) file format. How-
ever, if you have QuickDraw 3D installed, you can save an extruded 
object in 3DMF format.

Example Style Number of handles Envelope behavior

Warp Enter the number of hori-
zontal and vertical han-
dles in the text boxes.

Each handle behaves like a path anchor point and 
can move in any direction.

Distort Four Each side of the envelope edit box is a straight line; 
handles can move in all directions. This style is useful 
for creating perspective.

Straight Line Eight All handles are connected by straight lines. Corner 
handles are constrained to right-angle movements; 
side handles can move in all directions.

Single Cusp Eight Side handles form convex or concave curves between 
corner handles. Side handles can move in any direc-
tion; corner handles are constrained to right-angle 
movements.

Double Cusp Eight Side handles form S-shaped curves between corner 
handles. Side handles can move in any direction; cor-
ner handles are constrained to right-angle move-
ments.

Bézier Eight All handles behave like smooth anchor points and 
can move in any direction.
Extruding objects 217



21
Note: Canvas uses only solid fill colors for extruded objects, and 
ignores stroke attributes, pen inks, gradients, hatches, symbols, and 
textures.

◆ To extrude objects: With a text or vector object selected, 
choose Extrude in the Effects menu. In the Extrude palette, choose 
the style of extrusion, the lighting color, and the position of the light 
source. Click Apply to implement the settings.

Choosing an Extrude style 
The pop-up menu at the top of the Extrude palette displays extrude 
styles. When you select a style, an example appears at the upper 
right. You can choose one of three extrude styles.

Extrude styles

Preview Style Result

Parallel Adds thickness to a shape, as though the shape were cut out of a slab of clay. 
You can create parallel extrusions with text objects and closed vector objects.

Circular Extrudes a shape in a circular path. You can set the diameter of the extrusion 
path and the number of steps (6-60) used to complete the extrusion (see 
“Completing a circular or sweep extrusion,” below). You can apply circular 
extrusions to open and closed vector objects, but not text.

Sweep Extrudes a shape along a circular path, and lets you specify the number of 
degrees (10 to 360) to extrude. You can also set the diameter of the extrusion 
path and the number of steps (6-60) used to complete the extrusion (see 
“Completing a circular or sweep extrusion,” below). You can apply sweep 
extrusions to open and closed vector objects, but not text. 

Preview of selected style

Lighting edit area
Extrusion and light 
source settings

Choose an extrude style
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Completing a circular or sweep extrusion

When configuring a circular or sweep extrusion, you can specify the 
number of steps you want Canvas to use. The more steps, the 
smoother and less “blocky” the extrusion appears.

◆ To specify the number of steps for a circular or sweep extru-
sion: In the Extrude palette, enter a number between six and 60 in the 
“# of Steps” text box.

After you apply a circular or sweep extrusion to an object, you also 
need to set the diameter of the extrusion path. Canvas displays a 
black bar to mark the center of the extrusion. Canvas also shows a 
mirror image of the original object to show the position of the extru-
sion at 180 degrees. 

◆ To set the extrusion diameter: Drag the black bar right, left, 
up, or down, depending on the direction you want to extrude. The 
mirror image of the original object moves as you drag the black bar. 
When the diameter is the right length, press Enter (Mac), Esc (Win-
dows), or double-click. Canvas completes the extrusion.

Original shape

...for an extrusion with no 
gap in the middle

Position the black bar 
like this...

...for an extrusion with a 
gap in the middle

Position the black bar 
like this...

Circular extrusion pointer

Circular and sweep extrusions
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Creating lighting effects
You can add lighting to extruded objects to enhance the three-dimen-
sional appearance. You can control the color and position of the light 
source to get the exact effect you want. Canvas uses shades of gray to 
create highlights and shadows. Canvas then mixes the highlights and 
shadows with the color of the light source and the fill color of the 
object.

Editing extruded objects
Canvas lets you rotate and scale extruded objects interactively. To 
rotate and scale extruded objects, the object must be in extrusion edit 
mode. Immediately after you apply the Extrude effect, the object is in 
edit mode; to exit this mode, double-click outside the object or press 
Enter (Mac) or Esc (Windows).

◆ To place an extruded object in edit mode: Double-click the 
extruded object.

In edit mode, Canvas displays three axes, representing the three 
dimensions. Each axis has a handle, and when you roll the pointer 
over a handle, it changes to an extrusion pointer. Otherwise, the 
pointer appears as a rotation pointer.

Extrusion lighting

Use the following options to 
configure lighting effects for 
extruded objects.

A Choose a light source color 
from the pop-up palette, or cre-
ate a custom color; see “Creat-
ing custom colors in pop-up 
palettes” on page 136.

B Drag the Back/Front slider 
to specify the depth of the light 
source in three-dimensional 
space (the z-position).

C Drag the Intensity slider to 
the right make the light source 
brighter.

D Drag the handle to set the 
horizontal and vertical (x- and y-
position) of the light source and 
preview the lighting effect.

E Instead of dragging the 
Back/Front slider and light 
source handle, you can enter x-, 
y-, and z-positions in the text 
boxes.

A

B

C

D

E
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To rotate an extruded object

When you first apply the Extrude effect, the object appears solid gray 
and flat because it is facing you (the z-axis points directly at you). To 
see all dimensions, rotate an edge of the object toward you. With the 
rotation pointer, drag a side in the direction you want to rotate the 
object. As you drag, Canvas displays a circle to show the space in 
which the object can rotate. Dragging inside the circle rotates the 
object in all three dimensions; dragging outside the circle rotates the 
on the plane that is facing you.

You can also rotate an extruded object in two dimensions, like other 
vector objects, using the Rotate or Freeform commands in the Effects 
menu. The object can’t be in extrusion edit mode to use these com-
mands. When you use the Rotate and Freeform commands, Canvas 
does not reapply lighting effects as with three-dimensional rotation. 
In other words, the light source appears to move with the object, 
instead of remaining in the same place as the object rotates.

Changing the shape of extruded objects

When an extruded object is not in edit mode, you can resize and 
reshape it like other two-dimensional vector objects. You can

• drag a handle on the bounding box to resize the object

• place the object in freeform mode to skew the object

• use the Scale or Object Info commands to resize the object

• apply the Envelope effect to warp and distort the object

In addition to these two-dimensional editing functions, extruded 
objects have unique, three-dimensional properties. When an object is 

Rotation pointer appears when an 
object is in extrusion edit mode

Circle appears when you drag 
with the rotation pointer
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in extrusion edit mode, you can make it thicker, wider, or taller, and 
Canvas redraws the object to account for lighting changes.

Changing the color of extruded objects

When you extrude a vector object, Canvas uses combinations of a 
solid-color fill ink, shades of gray, and the light-source color to create 
a three-dimensional appearance. After you extrude an object, you can 
apply solid color fill inks (not gradients, hatches, symbols, or tex-
tures) and change the color of the light source in the Extrude palette. 
When you change colors, Canvas redraws the object to show the 
interaction of the new colors with the object’s shape and shading.

Colorizing objects
You can use the Colorize command to tint vector objects with solid 
color fill or pen inks when you want to mix two colors, or shade one 
color with another. Doing this in the Inks palette can be complicated, 
because you have to create a custom color and set the correct values 
to approximate a two-color mixture. The Colorize command lets you 
simply select two colors and choose the percentage of each.

To colorize a vector object

1 Select at least one vector object that has a solid color fill or pen 
ink. Colorize has no effect on gradient, hatch, texture, and symbol 
inks. 

2 Choose Transform➤Colorize in the Effects menu.

3 In the Colorize dialog box, turn on the Fill and Stroke options 
to colorize both, or select the one ink you want to colorize.

4 In the pop-up color palettes, select the colors you want to add 
to the inks of the selected objects.

Square handles extrude along x- and 
y- axes (up and down, side-to-side)

Round handles extrude along the z-axis 
(forward and backward)

Editing extruded objects

When you drag a handle, Canvas 
extrudes the object outward 
from the center, along the corre-
sponding axis. In other words, 
dragging a square handle to the 
right extrudes the object to the 
right and the left simultaneously.

Extrusion pointer appears over handles
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5 Use the sliders or enter a percentage in the text boxes to set the 
amount of color to mix with the object’s color.

6 Turn on Preview to see the effect or click OK to colorize the 
object.

How colorization works

Canvas uses the percentages you specify to determine the new color 
values for the selected object. For each color value (for example, 
Red, Green, and Blue in the RGB color model), Canvas finds the dif-
ference between the tint and the original color. Then, Canvas multi-
plies the differences by the percentage you specify, and adds these 
values to the original color values.

Fractalizing objects
Fractals are mathematical transformations that simulate the irregular-
ities and patterns in natural shapes, such as coastlines and mountain 
ranges. When you fractalize a vector object, its outline becomes 
jagged. You can use the Fractalize command to add a fractal effect to 
any vector object except dimension objects and Smart Lines.

Select fill and stroke tint colors 
using these pop-up color palettesDrag the sliders or enter numbers 

in text boxes to change the 
amount of color to mix in

Colorization calculations

If an object’s color has a red val-
ue of 40%, to tint 50% with a 
color that has a red value of 
100%, Canvas calculates a new 
red value of 70%. The same cal-
culations apply to the green and 
blue values for an RGB color.

R=40% R=100%

Difference in red values: 100 - 40 = 60

Value difference multiplied by tint percentage: 60 * 50% = 30

Original color value plus tint value is new value: 40 + 30 = 70% red

R=70%

Original Tint color Result
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◆ To fractalize an object: Select at least one object and choose 
Transform➤Fractalize in the Effects menu to open the Fractalize dia-
log box. Set the amount of wiggle and density you want to use, and 
choose Bézier or Polygon fractals. Click Apply to preview the effect 
on the selected object. Click OK to accept the settings and close the 
dialog box.

Wiggle The amount a fractalized path can deviate from the original 
path. Enter a number between 0 and 20; higher numbers increase the 
amount of wiggle. 

Density The smoothness of the fractalized path. Enter a number 
between 0 and 5. Higher values increase the number of anchor points 
Canvas add to the path. Lower densities result in sharper angles.

Curves or Polygon Polygon fractals can be jagged and use many 
anchor points, while curves fractals are smoother and require fewer 
additional anchor points.

Note: Canvas fractalizes objects by adding several anchor points to 
an object’s path. High wiggle and density settings and polygon frac-
tals can add numerous anchor points, which require more memory to 
print. Lower settings and curves fractals can help to conserve system 
resources and eliminate problems you might have while printing.

Illustration using vector objects Same illustration, after fractalizing the mountains
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Creating shadows for objects
The Shadow command copies selected objects, applies a color to the 
new objects, and offsets them from the original objects by an amount 
you specify. Canvas places the shadow object directly behind the 
original in the stacking order. If you apply a shadow to a group of 
objects, Canvas groups the shadow objects and places the shadow 
behind the original group.

You can apply shadow effects to any vector or text object except 
dimension objects and Smart Lines.

◆ To create an offset shadow: Select a vector object and choose 
Shadow in the Effects menu to open the Shadow dialog box. Config-
ure the options, and click Apply to see the effect. To accept the set-
tings and close the dialog box, click OK.

Shadow depth The horizontal and vertical distance by which the 
shadow object is offset from the original object. 

Shadow color The pen and fill color of the shadow object.

Because shadow objects are vector objects, you can edit them the 
same as other objects. You can skew them to create oblique shadows, 
or convert them to paint objects and use blur filters to soften them. 
Remember that the original object and the shadow object are not 
grouped, so editing or moving one doesn’t affect the other.
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Standard offset shadow 
with gray fill ink

Original shadow reduced in height, 
then skewed

Shadow converted to paint object 
using Image➤Area➤Render 
command. Gaussian blur filter with 
radius 6.3 applied to shadow

Examples of shadows

By combining Canvas 
vector and image-editing 
capabilities, you can cre-
ate different styles of 
shadows.
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Typing new text in a do
15

TEXT EDITING AND LAYOUT

Canvas has a full range of word processing features that let you inte-
grate text with your illustrations and images. You can create, format, 
edit, and layout text in Canvas. You can also import files in a number 
of different formats and methods, including file conversion, cut and 
paste, and Object Linking and Embedding (OLE). To help you edit 
and proof text, Canvas also provides tools such as spell checking and 
search and replace. This chapter describes how to

• work with text objects

• move through text

• select, cut, copy, and paste text

• add headers and footers

• insert page numbers and the current date and time

• import text

• proof text

Typing new text in a document
In Canvas, you add text to documents by first creating text objects. 
Canvas lets you create text objects in several ways with different 
properties and uses. You can

• define text columns using the Text or Text Object tools

• insert header and footer text objects

• create linked flows between text objects using the Flow 
Text pointer

• type text along a path with the Path Text tool

• wrap text inside a vector object.

This section describes the different ways to create text objects.

Creating text layouts
The Text Object tool lets you add empty text blocks to page layouts. 
Columns created with the Text Object tool keep their width and 
length (unlike Text tool columns, which shrink and expand to fit the 
number of lines of text). This tool is especially useful for designing 

Text, Path Text, and Text 
Object tools
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templates and master pages, because you can define text areas in a 
page layout and add type later.

If you type more text than can fit in a column created with the Text 
Object tool, Canvas hides the excess text and displays the overflow 
indicator. See “Placing overflow text in another column” on 
page 234.

Note: You cannot use the Text Object tool to select text or place an 
existing text object in edit mode. For these functions, use the Text 
tool. 

◆ To create a text layout: Select the Text Object tool. With the I-
beam, drag to define the width and length of the column. You can 
begin typing in the new text object immediately, or drag the I-beam 
in another location to create more text columns.

◆ To create a text layout in a publication document: You can 
use the Text Object tool as described above, and you can also simply 
click with the I-beam between column guides. Clicking with the I-
beam creates a column that runs the full width of the column guides 
and extends from the position where you click to the bottom margin 
of the page. If the column guides are outside the printable area, the 
column remains inside the printable area.

Using the Text tool
When you create text objects with the Text tool, you can choose 
whether or not to set the column width before typing. 

• If you set the column width before typing, text will wrap to 
the next line when it reaches the right boundary of the text 
object.

• If you don’t set the column width before typing, the right 
margin expands indefinitely (except in publication docu-
ments) to accommodate the amount of text you type. 

In either case, you can change the size of the text object by selecting 
the Selection tool and dragging a selection handle. 

Whether you should set the column width before or after typing 
depends on the amount of text you want to type. For short captions or 
callouts, you might find it easier to simply type and let Canvas adjust 
the right margin. However, for paragraphs or newsletter columns, it’s 
probably easier to set the column width first.

✔Tip
When the bounding boxes of 
text objects are visible, you can 
hide them by choosing 
Display➤Hide Text Boxes in 
the Layout menu. To show text 
boxes again, choose 
Display➤Show Text Boxes in 
the Layout menu.
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To set column width before typing

1 Select the Text tool in the toolbox. The pointer becomes an I-
beam. 

2 Drag the I-beam to specify the width of the column you want to 
create, and begin typing. Text wraps to the next line when it reaches 
the right margin. You don’t need to set the length of the column, 
because Canvas contracts and expands the bottom margin of the 
text object to fit the text you type.

3 To exit text editing mode, press Enter (Mac) or Esc (Windows) 
or select another tool.

To type without setting column width

1 Select the Text tool in the toolbox. The pointer becomes an I-
beam. 

2 Click the I-beam in the document and begin typing. Canvas 
expands the right margin to fit the widest line of text you type. 

3 To exit text editing mode, press Enter (Mac) or Esc (Windows) 
or select another tool.

In publication documents, you 
can click the I-beam in a col-
umn and Canvas will align text 
to the column guides (within 
the printable area) at the verti-
cal position that you click. For 
example, if the current align-
ment setting is center-justifica-
tion, Canvas centers the inser-
tion point between the 
column guides when you click 
the I-beam. As you type, Can-
vas wraps text to the next line 
when it reaches the right 
column guide. Canvas also sets 
the length of the column to the 
bottom margin of the page.

To help you align the tops of 
columns, Canvas snaps the col-
umn to the top margin if you 
click within 10 pixels of it.

Click I-beam anywhere 
between column guides

Canvas aligns and wraps text 
between column guides
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Typing on a path
Using the Path text tool, you can type text on the path of a vector 
object; the text baseline follows the contours of the object. You can 
align existing text using the Bind command in the Effects menu. For 
more information, see “Binding text to vector objects” on page 289.

◆ To type text on a path: Select the Path Text tool in the Text 
tool palette. Click the path of a vector object and begin typing. Text 
you type follows the path of the object.

Typing inside an object
You can type text inside the boundaries of almost any object. This 
creates text with margins that fit within the sides of the object. Text 
typed inside an object is the same as wrapping text inside an object. 
See “Wrapping text inside an object” on page 285.

◆ To type text in an object: Select the object and begin typing. 
Text you type stays inside the left and right boundaries of the object. 
If you type more text than can fit in the object, the text object 
expands to accommodate it. You can resize the object to fit the text, 
or shorten the text object and flow extra text to another text object; 
see “Flowing text between columns” on page 235.

Adding headers and footers
In Canvas publication documents, you can add header and footer text 
objects using Insert submenu commands in the Text menu. Headers 
and footers are special text objects that can contain codes for the cur-
rent date, time, and page number, in addition to text you type. Canvas 
updates the date, time, and page number codes each time the screen is 
redrawn.

Canvas inserts headers at the top of the printable area (the top of the 
onscreen page layout) and footers at the bottom of the printable area. 
Both types of objects initially span the width of the page, but you can 
resize and move them just like other text objects.

◆ To create header and footer text objects: You can’t add 
headers and footers while in text edit mode; press Enter (Mac) or Esc 
(Windows) to exit text edit mode, if necessary. Choose 
Insert➤Header or Insert➤Footer in the Text menu. Canvas creates 
the object, and places it in text edit mode so you can begin typing.
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Inserting dates, times, and page numbers
In publication documents, you can insert date, time and page number 
codes in header and footer text objects that Canvas will update each 
time it redraws the screen. You can also insert the current date and 
time in standard text objects, however, Canvas does not update this 
text; they are “stamped” into the document and become regular text.

You can format the codes or stamps (for example, change fonts, 
sizes, or justification) the same way you apply formatting to normal 
text; simply select the codes or text and choose the formatting you 
want to use.

Canvas uses the date and time information as set by your operating 
system. Refer to your system documentation for information on set-
ting the current date and time.

◆ To insert the date, time, or page number in a publication doc-
ument: With a text object in edit mode, choose an option in the 
Insert submenu in the Text menu; see the table below for descriptions 
of the commands.

Date, time, and page number commands

Typing special characters
You can insert special characters using keystrokes specified in Key-
caps (Mac) or Character Map (Windows). The following table pro-
vides keystrokes for some common characters. For more 
information, refer to your operating system manual.

To insert In this type of object Do this

Updating date code Header or footer Choose Insert➤Date, or type $d

Date stamp Any text object Choose Insert➤Date Stamp

Updating time code Header or footer Choose Insert➤Time, or type $e

Time stamp Any text object Choose Insert➤Time Stamp

Current page number Header or footer (page 
count is static in normal 
text objects)

Choose Insert➤Page #, or type $p

Total page count Header or footer (page 
count is static in normal 
text objects)

Choose Insert➤Total Page #, or type $t
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Keystrokes for common characters

Arranging text objects
You can arrange text objects on the page the same way you arrange 
other types of objects. You can drag text objects with the mouse, 
resize them by dragging a selection handle, “nudge” text objects with 
keyboard arrow keys, and set coordinates and dimensions in the 
Object Specs palette in the Object menu. See “Object data and styles” 
on page 114.

You can also cut and copy text objects, send overflow text to new 
columns, and link existing columns.

Copying and removing text objects
You can use the Copy, Cut, Clear, Paste, Duplicate, and Replicate 
commands in the Edit menu to copy and delete text objects. These 
commands perform the same functions on text objects as they do for 
vector objects. In addition, pasting, duplicating, or replicating a text 
object within Canvas preserves all character and paragraph attributes. 
For more information on these commands, see “Copying, cutting, 
pasting, and deleting objects” on page 100.

Placing overflow text in another column
Canvas lets you flow text between text objects. You can flow text by 
reducing the area of an existing text object. Canvas truncates the text 
to fit the smaller bounding box, and lets you flow the excess text to 
another text object.

Character Mac Keystroke Windows keystroke

– (em dash) Option + - Alt + 0151

™ Option + 2 Alt + 0153

£ Option + 3 Alt + 0163

§ Option + 6 Alt + 0167

¶ Option + 7 Alt + 0182

• Option + 8 Alt + 0149

® Option + r Alt + 0174

© Option + g Alt + 0169
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Linking text objects in a layout
After you create text columns using the Text or Text Object 
tools, you can use the Text Link tool to create a text flow. 

When text you type reaches the bottom of a column, text flows to the 
linked text object. The linked text object can be on the same page or 
another page in the document. You can chain together several col-
umns to create a multi-page layout, such as a newsletter. This tool is 
especially useful in creating Canvas document templates.

Flowing text between 
columns

To flow text, first add a column 
of text to a document. The text 
should all be in one column to 
start.

1 Reduce the area of the text 
column by dragging a selec-
tion handle. Canvas hides 
the text that does not fit in 
the new column size and dis-
plays an overflow indicator.

2 Click the overflow indicator 
to change the pointer to a 
text flow pointer.

3 To flow text into a column 
with the same margins as 
the original column, click the 
text flow pointer where you 
want the upper-left corner of 
the new column to appear.

4 To flow text into a column 
with different margins than 
the original column, you can 
drag the text flow pointer to 
specify the column width.

You can flow text between as 
many columns as you want.

Resize a text column Click the overflow indicator 
(A) to get the text flow 
pointer (B).

Click the text flow pointer to 
place overflow text in a column 
with the same margins as the 
original column. The overflow 
indicator changes to a plus sign 
to indicate that text has been 
flowed.

A

B
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Note: If you link text objects created with the Text tool, the text 
object no longer shrinks or expands to fit the text in the object. It 
remains a fixed length, like objects created with the Text Object tool.

To link text objects

1 With the Text or Text Object tool, create at least two text 
objects. The columns can be on different pages or slides.

2 Select the Text Link tool in the toolbox. It is in a pop-out tool-
bar with the other text tools. The pointer becomes the text link 
pointer with the number “1” in it; this is text linking mode.

3 Click the first text object — the object you want to flow from. 
The text link pointer changes to the number “2”.

4 Click the next text object — the object you want to flow to. (If 
you click anything but a text object, Canvas cancels the linking 
operation.) Canvas flashes an arrow to show the flow direction.

5 To add another text object to the chain, click the last text object 
in the chain, then click the text object you want to add. 

6 When you’re done, double-click an empty area of the layout, or 
press Enter (Mac) or Esc (Windows) to end text linking mode.

◆ To temporarily display text flow arrows: Select the Text Link 
tool and press a text object; if the text object is linked, arrows appear 
to show the flow direction. The arrows disappear when you release 
the mouse button.

✔Tip
If text boxes aren’t visible, 
choose Display➤Show Text 
Boxes in the Layout menu; this 
makes it easier to find and link 
empty text objects.

Text link pointer

With the text link pointer, press 
a text object. If the text object 
is linked, a text flow arrow 
appears.

Text flow arrow
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Editing text
In Canvas, you can insert, search, replace, move, delete, copy, and 
spell check text. To edit text, you need to be familiar with the differ-
ent ways you can navigate through and select text. Some editing 
functions require that you first put a text object in edit mode or select 
some text.

Text edit mode
When a text object is in text edit mode, you can revise, delete, insert, 
and select specific text. Only one object is in text edit mode at a time. 
You can put a text object in edit mode with a Text or a Selection tool.

◆ To put a text object in edit mode with a Text tool: Select the 
Text tool in the toolbox, and click a text object with the I-beam. An 
insertion point appears where you click. 

◆ To edit text that is bound to a path: Use the Path Text tool (in 
a pop-out toolbar with the Text tool) and click the text or vector 
object with the crosshair pointer. An insertion point appears in the 
bound text.

◆ To use a Selection tool to put a text object in edit mode:
Select a Selection tool in the toolbox, and double-click a text object. 
The pointer becomes an I-beam and an insertion point appears.

Text selection and navigation methods
You can move the insertion point and select a continuous block of 
characters, words, lines, or paragraphs using the mouse or the key-
board. The mouse lets you quickly select text or text objects and 
move the insertion point. However, if you work with a lot of text, you 
might find that the keyboard techniques allow you to edit faster and 
move the insertion point with more precision than a mouse. 

Using the keyboard

In text edit mode, you can use the following key combinations to 
move the insertion point and select text.

✔Tip
To help you edit and select 
text, you can display text sym-
bols for spaces, paragraph 
breaks, and indents. Choose 
Display➤Show Text Invisibles 
in the Layout menu to display 
these symbols. To hide them, 
choose Display➤Hide Text 
Invisibles.
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Text editing keys 

Using the mouse

Using the mouse and modifier keys, you can quickly place the inser-
tion point, select specific words, and highlight large blocks of text.

◆ To place the insertion point in a text object: Select the Text 
tool in the toolbox to change the pointer to an I-beam. Click the I-
beam in a text object where you want to place the insertion point. 

◆ To select text: Place a text object in edit mode (see “Text edit 
mode,” page 237). Use the following methods to select text.

Modifier Key Cursor key Result

None Up, Down, Right, Left arrow Moves insertion point one space in the 
specified direction

Page Up, Page Down Moves insertion point up three lines on 
the left margin (Page Up) or down three 
lines on the right margin (Page Down) 

Option (Mac), Ctrl (Windows) Right, Left arrow Moves insertion point to end (Right) or 
beginning (Left) of word

Up, Down arrow Moves insertion point to beginning (Up) 
or end (Down) of line; if the insertion 
point is already at the beginning or end 
of a line, it moves up one line

Shift Right, Left arrow Extends selection one space in the 
specified direction

Shift Up arrow, Page Up Extends the selection above the inser-
tion point one line (Up) or three lines 
(Page Up)

Shift Down arrow, Page Down Extends the selection below the inser-
tion point one line (Down) or three lines 
(Page Down)

Shift + Option (Mac)

Shift + Ctrl (Windows)

Up, Down, Right, Left arrow, 
Page Up, Page Down

Moves the same way as an Option-
modified arrow key, but also selects all 
text between the original insertion 
point and the new position

To Do this

Select a continuous block of text Drag the I-beam over text.
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◆ To deselect all highlighted text: Click anywhere in the text 
object or layout. (Clicking outside the selected text object creates 
another text object at that location.)

◆ To exit edit mode: Press the Enter key (Mac) or the Esc key 
(Windows), or select another tool in the toolbox.

Copying, deleting, and moving selected text
You can cut, copy, and paste selected text within the same document, 
in another Canvas document, or to and from a non-Canvas document 
using the Clipboard. Depending on the operating system and the 
source of the text in the Clipboard, pasted text will retain or discard 
formatting information. For example, on Mac OS, text in the Clip-
board that originated in another application will be formatted with the 
current Canvas presets when pasted in a Canvas document, regard-
less of formatting applied in another application. However, in Win-
dows, text pasted from another application can be embedded in a 
Canvas document, using Object Linking and Embedding (OLE). See 
“Embedded text objects and editions containing text” on page 245.

If you copy and paste selected text (and not an entire text object) 
within Canvas, the text retains its character attributes, but not its 
paragraph-level formatting. 

◆ To remove text: Select the text you want to remove. 

• To move the selection to the Clipboard, choose Cut in the 
Edit menu.

Select all text between the inser-
tion point and another location

Press the Shift key and click where you 
want the selection to end. Windows 
users can also use the right mouse but-
ton like the Shift key; hold down the 
right button and left-click.

Deselect text between the inser-
tion point and another location 
within the selection

Press the Shift key and click within the 
highlighted text.

Select a word Double-click the word with the I-beam 
pointer.

Select a line of text Triple-click the line with the I-beam 
pointer.

Select all text in the text object Choose Select All in the Edit menu.

To Do this
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• To delete text from a document without saving it to the 
Clipboard, choose Clear in the Edit menu or press Delete. 

◆ To type over selected text: You can replace existing text by 
selecting it and typing or pasting text. This saves the extra step of 
deleting text before replacing it. 

◆ To replace all text in a text object: Select a text object and 
begin typing. The text you type will have the same formatting 
attributes of the text you replaced.

To copy selected text

When you copy and paste selected text, you can create a new text 
object or insert the text in an existing text object.

1 While in text edit mode, drag the I-beam pointer to highlight 
the text you want to copy.

2 Choose Copy in the Edit menu. Canvas copies the selection to 
the Clipboard.

3 Depending how you want to paste the selection, do one of the 
following:

• To paste text into an existing text object, place the insertion 
point where you want to insert the text.

• To paste text in a new text object, first be sure no objects are 
in text edit mode by pressing Enter (Mac) or Esc (Win-
dows). You can set the width of the column before pasting 
text by selecting the Text tool and dragging horizontally. 
Otherwise, text will be pasted in one long line, and long 
selections might extend off the screen.

4 Choose Paste in the Edit menu. Canvas inserts the contents of 
the Clipboard in the current document.

Proofreading text
Canvas has Find/Change and Spell Checking tools to help you find 
particular words or characters, make global text changes, and correct 
spelling.

Finding and changing text
You can search and replace character strings that you specify using 
the Find dialog box. In addition, Canvas lets you minimize “false 
matches” by specifying exact capitalization and word matches.
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Spell checking text
You can spell check specific words, selections, and entire documents 
using the Canvas spell checker. The spell checking feature can also 
watch for misspellings as you type, alerting you immediately to 
words not in its dictionary. In addition to the 100,000-word English 
dictionary, you can add your own words to a user dictionary.

To check the spelling of a word

You can use the Suggest Spelling option to verify the spelling of a 
specific word. 

1 Highlight the word you want to check and choose Spell 
Checker ➤ Suggest Spelling in the Text menu. The Suggest Spell-
ing menu appears with a list of suggested words and options. If the 
highlighted word appears in the list of suggestions, the word is 
spelled correctly, and you can click Cancel to close the Suggest 
Spelling menu.

To find and change text

Choose Find in the Edit menu 
to open the Find palette. If 
necessary, click the Text tab to 
bring it to the front.

Find What. Type the text you 
want to find.

Change To. To replace text 
that Canvas finds with differ-
ent text, type the new text 
here. To delete occurrences of 
the text, leave this box blank.

Match: Whole word. Turn on 
to specify that the text string in 
“Find What” is an entire word. 
For example, if you type time 
in the text box and turn on 
“Match: Whole Word,” Can-
vas will not find words like 
times, untimely, and timer.

Match: Case. Turn on to tell 

Canvas to find only text that 
has the same capitalization as 
the text you typed in “Find 
What.” For example, if you 
type Time in the text box and 
turn on “Match: Case,” Canvas 
will not find TIME or time.

Search all visible layers. (Illus-
tration and presentation docu-
ments only) Turn on to make 
Canvas look for the specified 
text string on visible layers.

Search all pages/slides. (Publi-
cation and presentation docu-
ments only) Turn on to make 
Canvas search the entire docu-
ment instead of just the visible 
page or slide.

Find next. Searches for the 
next occurrence of the text you 
specified.

Replace. To change an occur-
rence of the text you typed in 
“Find What” to the text in 
“Change To,” click this button.

Replace All. Click to change all 
occurrences of the text you 
typed in “Find What” to the 
text in “Change To.” Canvas 
changes all occurrences with-
out stopping at each instance.
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2 If the highlighted word is not in the list of suggested spellings, 
and the correct spelling appears in the list, you can click the correct 
word to replace the misspelled word in the document.

3 If the highlighted word is not in the list of suggested spellings, 
but you want to use the word anyway, you can choose Add Word to 
update the user dictionary (to allow the word in all documents) or 
Ignore Word (to allow the word in the current document).

To check spelling interactively

The interactive spell checking feature alerts you as soon as you type a 
word that is not in the Canvas or User dictionaries. (Canvas recog-
nizes a string of characters as a word when you press the Space bar.) 
You can select a sound in your operating system’s Sound Control 
Panel. Please consult your system software manual for instructions 
on selecting sounds.

◆ To turn interactive spell checking on or off: Open the Spell 
Checker submenu in the Text menu. If a check mark appears next to 
Interactive, choosing Interactive will turn this feature off. Otherwise, 
choosing Interactive will turn this feature on.

Spell checking a selection or document

You can check the spelling of highlighted blocks of text, a selected 
text object, or an entire document.

1 To limit the spell checking to specific text or text objects, 
select the text or text objects. To spell check an entire document, 
you don’t have to select anything.

2 To begin spell checking, choose Spell Checker ➤ Spell Check 
Selection or Spell Check Document in the Text menu. If Canvas 
finds an unrecognized word, the Spelling Checker dialog box 
appears (see below).
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Continuing a spelling check

If you cancel a spell check, you can choose Continue Spell Check in 
the Spell Checker submenu to pick up where you left off. Canvas 
remembers the words you chose to ignore.

Modifying the user dictionary
In addition to over 100,000 words in the Canvas dictionary, you can 
store an unlimited number of words in a personal user dictionary. By 
adding words to a user dictionary, you can “teach” Canvas new 
words and special terms, and prevent Canvas from stopping unneces-
sarily while checking spelling.

Spelling Checker

The Spelling Checker dialog 
box only appears when Canvas 
finds a word in a document 
that is not in the dictionaries.

A Canvas displays unrecog-
nized words here. You cannot 
edit the text in this box.

B You can type a new spelling 
in this text box, or click the 
down-arrow to choose from the 
list of suggested spellings.

Replace. Click this button to 
replace the unrecognized word 
with the contents of the text 

box and continue to spell 
check the document.

Add. If Canvas doesn’t rec-
ognize a word that is actually 
spelled correctly, you can 
add the word to the user dic-
tionary so that Canvas will 
recognize it in all future docu-
ments. After saving the word, 
Canvas continues to spell 
check.

Ignore. Allows an unrecog-
nized word in the current docu-
ment without adding the word 
to the dictionary. Canvas 
ignores all instances of the 

word until you close Canvas.

Skip. Allows the current 
instance of an unrecognized 
word, but Canvas alerts you 
the next time this word occurs.

Cancel. Interrupts the spell 
check and closes the dialog 
box. 

B

A
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◆ To add or delete words in the user dictionary: Choose Spell 
Checker ➤ Show Added Words in the Text menu. In the dialog box, 
type new words to add or choose words to delete.

Importing text from other applications
You can import text created in other applications into Canvas. This 
capability is especially useful if you are compiling documents from 
different applications into a Canvas layout. For example, you might 
need to assemble a publication with contributions from several writ-
ers who each use different word processors.

Canvas has several methods of importing text: opening, placing, 
pasting from the Clipboard, and object embedding (Windows only). 
Opening a text file creates a new Canvas publication document for 
the imported file. Placing, pasting, and embedding text inserts the 
text in the current document window. For information on pasting text 
from the Clipboard, see “Copying, deleting, and moving selected 
text” on page 239.

The formatting of imported text might differ from the formatting of 
the original text in its native application. Although some software 
products might have similar capabilities, the methods used can vary 
significantly. It might be necessary to reformat text using the typo-
graphic tools in Canvas.

Note: In addition to the file filters described in “File and data 
exchange” on page 57, Canvas uses Claris XTND file translators 
(Mac only) to open and place files. The file types you can import into 
Canvas depend on your system configuration and software.

You can add words to the 
dictionary by typing the word in 
this text box and clicking Add.

Words you add to the user 
dictionary are listed here in a 
scrolling list. To delete a word, click 
the word and click Delete.
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To import a text file into a new Canvas document

1 Choose Open in the File menu. 

2 In the Format (Mac) or “Files of Type” (Windows) pop-up 
menu, choose a text file format. 

3 In the list of files, select a file to import and click Open or dou-
ble-click the file name. Canvas opens a new publication document 
with approximately the same margins as the original text file. 

To place a text file in an existing Canvas document

1 Choose Place in the File menu. In the Format (Mac) or “Files 
of Type” (Windows) pop-up menu, choose atext file format . 

2 In the list of files, select a file to import and click Place, or dou-
ble-click a file name. The pointer changes to the Place icon. 

3 To place text using the same margins as the original file, click 
the Place icon in the document. If the file you are importing con-
tains text only (no images or objects), you can also drag the Place 
pointer to simultaneously import and set margins for the text. How-
ever, if the file you want to import has images or objects, dragging 
the place icon scales the text, images, and objects as a group. 

Embedded text objects and editions containing text

In Windows, you can use Object Linking and Embedding (OLE) to 
insert text in a Canvas document. You can also use Publish and Sub-
scribe in the Mac OS to subscribe to an edition that contains text.

However, Canvas treats embedded text objects and editions as 
objects, not text. You cannot apply effects, such as wraps or binds, to 
text in these objects. In addition, Canvas cannot spell check, hyphen-
ate, or format this text. All formatting and effects must be performed 
in the original application or publisher.

For more details and procedures, see “Using Object Linking and 
Embedding” on page 78 and “Sharing information through Publish 
and Subscribe” on page 81.

✔Tip

If you have difficulty opening or 
placing a text document 
because of the formatting, try 
converting the file to plain text 
before importing the file.

Also, try copying and pasting 
the text you want to import. 
This removes formatting that 
Canvas doesn’t understand.
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Exporting text to other applications
In addition to copying text from Canvas into other applications, you 
can use the Canvas file filters to save selections and documents in 
other file formats; see “File and data exchange” on page 57. For ras-
ter-only file formats, Canvas rasterizes text before saving, and you 
lose the ability to edit the text after conversion. However, a few 
application-specific filters that recognize text, such as the Canvas 3.5 
filter, let you convert text.

Canvas also supports Claris XTND file filters (Mac only). However, 
several Canvas typographic capabilities aren’t available in other 
applications. For example, character inks and strokes, text typed on a 
path, and wrapped text are unlikely to convert reliably. In some 
cases, such as rotated text, the export filters might rasterize the char-
acters, and you will not be able to edit them as text.

To export text to other file formats

1 Choose Save As in the File menu. 

2 In the File Format pop-up menu, choose a format to export to. 

3 Type a name for the file, and click Save. Canvas warns you 
that saving files in other formats might result in a lost of some 
information. Click Save to export the file.

✔Tip
Always save a copy in Canvas 
format of files you want to 
export, in case the file conver-
sion does not come out exactly 
right.
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Selecting text and 
16

FORMATTING TEXT

You can control all aspects of text formatting in Canvas. This chapter 
explains how to specify font, font styles, type size, character position 
and scaling, kerning, letter and word spacing, paragraph alignment 
and spacing, and hyphenation. This chapter also explains how to 
select text for formatting and how to apply format settings.

You can also save format settings as named character and paragraph 
styles so you can use them again. The procedure for using these type 
styles is covered in the following chapter.

Selecting text and objects
The following section is a review of some basic selection techniques 
used to format text. 

To select and deselect text objects

You can select text objects the same way you select other objects in 
Canvas. 

• To select a single object, use a Selection tool to click the 
text object or drag a selection rectangle around the object.

• To select multiple objects, hold down the shift key and click 
text objects with a Selection tool. You can also drag a selec-
tion rectangle around all the objects you want to select.

• To deselect an object, press the Shift key and click the 
object. Other objects remain selected.

• To deselect all objects, press the Enter key (Mac) or Esc key 
(Windows) twice, or click an area of the screen where there 
are no objects.
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To select all text objects

To select all text objects with a single command, select the Text tool 
in the toolbox and then choose Select All in the Edit menu. 

• In an illustration document, this procedure selects all text 
objects on the current layer. 

• In a publication document, this procedure selects all text 
objects on the current page or current two-page spread. 

• In a presentation document, this procedure selects all text 
objects on the current layer of the current slide.

To select text within a text object

Before you can select specific characters, words, lines, or paragraphs, 
the text object must be in edit mode. 

1 To place an object in edit mode, use one of these methods:

• With a Selection tool, double-click the text object. The 
pointer becomes an I-beam and an insertion point appears in 
the text.

• Click the Text tool in the toolbox. The pointer becomes an 
I-beam. Click the I-beam within the text. An insertion point 
appears.

• For bound text only, click the Path Text tool. The Path Text 
tool is in a pop-out toolbar with the Text tool.

2 Use one of the following methods to highlight the text you 
want to select.

To Do this

Select a continuous block of 
text

Drag the I-beam over text.

Select all text between the 
insertion point and another 
location

Press the Shift key and click where 
you want the selection to end.

Deselect text between the 
insertion point and another 
location within the selection

Press the Shift key and click within 
the highlighted text.

Select a word Double-click the word with the I-
beam pointer.

Select a line of text Triple-click the line with the I-beam 
pointer.
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3 To exit edit mode, press the Enter key (Mac) or the Esc key 
(Windows).

Applying text formats
Canvas provides three ways to format text: the Text menu, the Text 
Ruler, and the floating Type palette. The Text menu and Text Ruler 
provide basic formatting options, while the Type palette provides 
advanced controls and features. You might find that the Type palette 
and Text Ruler are easier to use because you can keep them open as 
you edit a document. However, using menu commands can help to 
familiarize you with the hot-key command shortcuts and make text 
formatting quicker. 

When you use menu commands or the Text Ruler to apply format-
ting, the settings you choose affect the document immediately. How-
ever, when you use the Type palette, the settings take effect when 
you click Apply. You do not have to click Apply before switching to 
another tab within the Type palette; Canvas remembers all changes 
and applies them simultaneously with one click. However, you must 
apply or save the new settings before clicking the pointer anywhere 
outside the Type palette. If you don’t, the settings will be lost. 

Depending on the text selection you make, the format settings you 
choose can be applied to existing text, stored as the preset for new 
text objects, or applied to text you are about to type. 

To format existing text

You can change the formatting of existing text by selecting a text 
object or a portion of text within the object. 

◆ To apply character formatting to existing text: Select the 
characters you want to change. Using Text menu commands, the 
Type palette, or the Text Ruler, choose the formatting you want to 
apply. 

Select all text in the text object Choose Select All in the Edit menu.

Deselect all highlighted text Click anywhere in the text object or 
layout. Clicking outside the selected 
text object creates another text 
object at that location. Choosing 
another tool in the toolbox deacti-
vates the text edit mode.

To Do this
Applying text formats 249



25
◆ To apply paragraph formatting to existing text: Select text 
in the paragraph you want to change, or place the insertion point any-
where in the paragraph. Using Text menu commands, the Type pal-
ette, or the Text Ruler, choose the formatting you want to apply.

Text menu commands and Text Ruler options affect the selection as 
soon as you choose them; Type palette changes take effect when you 
click Apply.

To establish formatting for new text objects

When you create a new text object, Canvas applies a preset format to 
text you type. You can define the preset format for new text objects. 
To establish or modify the preset, follow these steps:

1 Be sure you have not selected any text or text objects, and no 
text objects are in edit mode. To deselect all objects, press Enter 
(Mac) or Esc (Windows) twice.

2 To change format settings, use Text menu commands, the Type 
palette, or the Text Ruler. If you use the Type palette, be sure to 
click the Apply button after making changes.

Canvas uses the specified settings to format new text objects that you 
create. Existing text objects retain their formatting. Also, when you 
paste text from the Clipboard, it retains its formatting. 

To change formatting before typing new text

You can set the format for text you are about to type — without 
changing the preset format for new text objects. 

1 Place the text object in edit mode (see “To select text within a 
text object,” page 248). The pointer should appear as an I-beam and 
an insertion point (a flashing vertical line) should appear in the text. 

2 Place the insertion point by clicking the I-beam where you 
want the new formatting to begin.

3 Use the Text menu commands, the Type palette, or the Text 
Ruler to choose formatting options. If you use the Type palette, be 
sure to click the Apply button after making changes.

4 Begin typing. The text will appear with the formatting you 
chose.
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Choosing a formatting method
You can use Text menu commands, the Text Ruler, or the Type pal-
ette to format text. Depending on the circumstances, you might find 
that one is easier to use than the other, or one provides additional 
control. This section describes the general capabilities of the three 
formatting methods, and provides some guidelines to help you decide 
when to use each method.

Text menu commands

The Text menu commands let you control basic text properties, 
including font, font style, type size, justification, leading, and kern-
ing. The submenus for these properties contain standard settings. The 
Kerning, Leading, and Size submenus also let you make incremental 
adjustments to current settings. 

The Text Ruler

The Text Ruler lets you set basic paragraph-level formatting, includ-
ing justification, indents, tab stops, and leading. You can edit and 
place tabs and indents by dragging markers with the mouse, allowing 
you to visually adjust settings. 

The Type palette

The Type palette lets you manage all typographic settings, including 
those provided by the Text menu. In the Type palette, you can enter 
numeric values to set custom point sizes, kerning, leading, and super-
script and subscript elevations. In addition, the Type palette provides 
options for indents, drop caps, letter and word spacing, and hyphen-
ation. 

You can also use the Type palette to save settings as type styles, as 
explained in the following chapter, “Using type styles.”
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When to use Text menu commands
Menu commands can be quicker and more practical for some format-
ting than the other methods.

• New Canvas users might want to use menu commands 
whenever possible to become familiar with the hot-key 
shortcuts. Canvas has shortcuts for many basic formatting 
options. Learning these shortcuts can make text formatting 
quicker.

• For relatively infrequent formatting, the Type palette might 
not be practical or convenient. Depending on the speed of 
your system, opening the Type palette, choosing formatting, 
and applying the settings might take longer than simply 
choosing the same menu command. 

• In some circumstances, the Type palette might provide 
more control than necessary. For example, to apply standard 
subscript using the Text menu, you can simply choose Sub-
script in the Style submenu and let Canvas lower the base-
line by the standard amount. With the Type palette, 
however, you must specify the exact number of points to 
lower the baseline.

When to use the Text Ruler
The Text Ruler lets you set basic paragraph formatting, and provides 
some options not available with the other methods.

Text Ruler options

To display the Text Ruler, 
choose Show Text Ruler in the 
Layout➤Display submenu. To 
hide the ruler, choose Hide 
Text Ruler.

Justification. You can click a 
button to choose paragraph 
alignment.

Tabs. You can set tabs only in 
the Text Ruler. Canvas has left, 
center, right, decimal, and 

comma tabs. You can also 
specify a leader character to fill 
the tab space.

A Indents. You can interac-
tively adjust right, left, or first 
line indents by dragging an in-
dent marker. This method might 
be more intuitive than specify-
ing indents in measurement 

units as you do in the Type pal-
ette.

B Format information. The 
Text Ruler shows the current in-
dent, tab, and leading settings. 
As you click on different options 
in the ruler, the text box shows 
the current setting for the op-
tion.

A B
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When to use the Type palette
Follow these guidelines to determine if the Type palette is the appro-
priate formatting method.

• In general, to perform advanced text formatting, you should 
use the Type palette. Many Type palette options and con-
trols aren’t available in the Text menu or Text Ruler.

• To create, edit, delete, and apply type styles, you must use 
the Type palette. You can use the Text menu and Text Ruler 
in the process of designing the type style, but only the Type 
palette lets you save and apply the styles.

• If you are making frequent formatting changes, you might 
want to use the Type palette. You can change several 
attributes and apply them all at once, saving you the trouble 
of pulling down the Text menu repeatedly.

• You can monitor format settings of a selection if you keep 
the Type palette open. If you select text with multiple for-
mats applied, Canvas alerts you by “blanking” the option in 
the Type palette. For example, if you select a block of text 
that has some plain and some bold typeface characters, the 
Character tab Style button for Bold appears “blanked,” or 
white, inside.

Blanked Bold button

How to use the Type palette

When you adjust settings in the 
Type palette, the new settings 
don’t take effect until you click 
Apply. Be sure that you don’t 
click outside the palette before 
applying the settings, or they 
will be lost.

To open the Type palette, 
choose Type in the Text menu. 
The Type palette contains six 
tabs: Character, Hyphens, 
Indents, Paragraph, Spacing, 

and Styles. 

A Click a tab to bring it to the 
front. The paragraph symbol 
(¶) on some tabs indicates that 
these are paragraph-level op-
tions.

B Configure the settings you 
want and click Apply to imple-
ment them.

A

B
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Applying character formatting
Canvas gives you precise control over the appearance of each charac-
ter. You can set the font, type size, font style, kerning, capitalization 
style, scale, and baseline position using menu commands or the Char-
acter tab in the Type palette.

Character attributes are applied by selecting the specific characters 
that you want to modify. You can select any portion of text — from 
one character to entire text objects. For selection techniques, see 
“Selecting text and objects” on page 247.

Specifying fonts
You can use the Font submenu in the Text menu or the Character tab 
in the Type palette to choose any of the fonts installed on your sys-
tem. For more information, see the sidebar on font usage below.

Setting attributes in the Character tab

The Character tab lets you con-
trol all character attributes. 
Some attributes, such as type 
face, type size, font style, base-
line, and kerning, are also avail-
able in the Text menu.

Name. Choose a typeface in 
the pop-up menu.

Size. Choose a type size in the 
pop-up menu, or type a num-
ber in the text box.

Style. Click a button to select a 
font style.

Case. Choose a capitalization 
style in the pop-up menu.

Baseline. Specify subscript or 

superscript settings to one 
hundredth of a point preci-
sion.

Kerning. Tighten and loosen 
kerning by hundredths of a 
point.

Scaling. Specify percentages 
by which you want to scale 
the current type size. You can 
set individual horizontal and 
vertical scaling percentages.

A Locks. To prevent acciden-
tal or unwanted changes to the 
type face, type size, or font sty-
le of specific text, you can set 
these locks. If you want to 
change locked text, you must 
first unlock the text.

A 
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To choose a font using menu commands

1 Depending on how you want the font to apply, do one of the 
following:

• To change existing text, select the text or text objects.

• To set the font before typing, place the insertion point where 
you want the font to change.

• To apply the font to the preset format, deselect all objects.

2 Choose Font in the Text menu to open the Font submenu. A 
check appears next to the current font.

3 Choose a font in the submenu. The font setting changes.

Tips for font installation and use

On Mac OS systems, Canvas uses fonts installed 
in the Fonts folder of the System Folder. Fonts 
should be installed by dragging the font files to 
the closed System Folder icon. The system puts 
the fonts in the correct folder.

On Windows systems, Canvas uses fonts 
installed in the Fonts folder of the Windows fold-
er. You can also access the Fonts folder by the 
Fonts shortcut icon in the Control Panel. Use the 
Install New Font command in the File menu to 
add fonts to your system. You can also drag and 
drop font files or font file shortcuts to the Fonts 
folder. To specify that you want to see only 
TrueType fonts in your programs, you can use 
the Options command in the Views menu.

Canvas can only use fonts that are properly 
installed in the above locations. If fonts that you 
use in another application are not available in 
Canvas, that application probably stores its fonts 
in a different location and has its own font man-
agement capabilities.

Guidelines for choosing fonts

There are three types of fonts widely available: 
bit-mapped (or screen), PostScript, and 
TrueType. You cannot distinguish the three 

types in the Canvas menus. However, you 
should be aware of the different types of fonts 
you have, because each font is best suited for 
particular purposes. 

Bit-mapped fonts are used by your computer to 
display text onscreen. A bit-mapped font is opti-
mized for a particular point size, and appears 
jagged at other sizes. These fonts are not scal-
able for printing.

PostScript Type 1 fonts are the standard for 
imagesetting. PostScript produces high-quality 
printed text. For onscreen display, however, 
PostScript needs screen fonts. If the screen font 
for a particular point size is not installed, the text 
appears jagged onscreen. To compensate for 
this, you can use Adobe Type Manager (ATM) 
software. If a screen font is unavailable, ATM 
uses the PostScript printer font for both screen 
display and printing. In addition, ATM lets you 
print PostScript fonts to non-PostScript printers.

TrueType fonts are suitable for most desktop 
publishing purposes when you are printing in-
house. TrueType fonts produce good quality 
printed text, and their onscreen appearance 
closely resembles the printed output, even 
when the screen font is unavailable.
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To choose a font using the Type palette

1 Depending on how you want to apply the font, do one of the 
following:

• To format existing text, select the text or text objects.

• To set the font before typing, place the insertion point where 
you want the font to change.

• To apply the font to the preset format, deselect all objects.

2 If necessary, open the Type palette by choosing Type in the 
Text menu, and click the Character tab to bring it to the front.

3 Choose a font in the Name pop-up menu and click Apply.

Specifying type size
You set the type size in either the Size submenu of the Text menu or 
the Character tab of the Type palette. You can choose from standard 
type sizes using either method. Using the Size submenu, you can also 
reduce or increase the size in 1-point increments. Using the Character 
tab, you can enter any type size with precision to one-hundredth of a 
point.

To set type size using menu commands

1 Depending on how you want the type size to apply, do one of 
the following:

• To change existing text, select the text or text objects.

• To set the type size before typing, place the insertion point 
where you want the size to change.

• To set the type size of the preset format, deselect all objects.

2 Choose Size in the Text menu to open the Size submenu. A 
checkmark appears next to the current type size.

3 Choose one of the sizes in the submenu, or choose the Reduce 
or Increase commands to change the type size in 1-point incre-
ments. The size setting applies immediately. 

To set the type size using the Type palette

1 Depending on how you want the type size to apply, do one of 
the following:

• To change existing text, select the text or text objects.

Size submenu

6
8
9
10

✓ 12
14
18
24
36
48
72

Reduce Ctrl+Shift <
Increase Ctrl+Shift >
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• To set the type size before typing, place the insertion point 
where you want the size to change.

• To set the type size of the preset format, deselect all objects.

2 If necessary, open the Type palette by choosing Type in the 
Text menu, and click the Character tab to bring it to the front.

3 Choose one of the sizes in the Size pop-up menu, or enter a 
number in the box to specify a type size.

4 Click Apply to implement the type size setting.

Applying font styles
Font styles are different character types, such as bold, italic, or super-
script, as well as capitalization modes. You can apply font styles in 
the Style submenu in the Text menu or the Character tab in the Type 
palette.

Font styles can be categorized into three groups: appearance, capital-
ization, and baseline position. To the same text, you can apply multi-
ple appearance styles, but only one each of capitalization and 
baseline styles.

Types of font styles

Underline
Outline

Shadow

StrikeThrough

Plain
Bold
Italic

UPPERCASE
lowercase

Title
SMALL CAPS

CanvasTM

H20

Appearance styles Capitalization styles Baseline shift: 
“TM” superscripted
“2” subscripted
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Appearance styles

Appearance styles include plain, bold, italic, underline, outline, 
shadow, small caps, and strikethrough. With the exception of the 
Plain option, you can use as many of these appearances as you like on 
the same text. Applying the Plain setting removes other font styles 
that have been applied so that text reverts text to its standard appear-
ance. Depending on the typeface, using certain styles might not have 
the desired effect, and can even make text appear ugly when printed. 
For example, applying bold to a heavy weight typeface can make 
characters look too thick. Similarly, applying italic to an already ital-
icized font might exaggerate the slant of the characters.

Capitalization styles

Capitalization styles format text as uppercase, lowercase, or title 
(first letter of each word capitalized) styles. You can apply one of 
these capitalization styles to the same text: Normal, Upper, Lower, 
and Title.

Baseline position

The baseline of text is the imaginary horizontal line on which charac-
ters sit. To position characters above (superscript) or below (sub-
script) the normal baseline, you can shift the baseline position.

Canvas does not change the type size of superscript and subscript 
text. Unless you reduce the type size of shifted text, the line size 
increases by the amount of the baseline shift. As a result, the line 
spacing might change, depending on the leading setting. If you don’t 
want the line spacing to change, you can reduce the type size of 
shifted text by the same amount (or more) of the baseline shift, or you 
can specify leading in points (see “Setting line and paragraph spac-
ing,” page 264).

If you use the Style submenu to change baseline position, you can 
choose either Superscript or Subscript to shift text the baseline by 
roughly 27 to 33 percent of point size of the line. For example, super-
script text in a line of 12-point text appears 4.0 points above the nor-
mal baseline. 

If you use the Character tab of the Type palette to change the baseline 
position, you can specify the exact distance (in points) of the text 
above or below the normal baseline.
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To apply font styles using menu commands

1 Depending on how you want the font style to apply, do one of 
the following:

• To change existing text, select the text or text objects.

• To set the font style before typing, place the insertion point 
where you want the style to change.

• To apply the font style to the preset format, deselect all 
objects.

2 Choose Style in the Text menu to open the Style submenu. 
Canvas places checkmarks next to the active styles in the submenu.

3 Choose the font style you want to apply. Choosing an active 
style turns off the style. Canvas implements the setting immedi-
ately.

To apply font styles using the Type palette

1 Depending on how you want the font style to apply, do one of 
the following:

• To change existing text, select the text or text objects.

• To set the font style before typing, place the insertion point 
where you want the style to change.

• To apply the font style to the preset format, deselect all 
objects.

2 If necessary, open the Type palette by choosing Type in the 
Text menu, and click the Character tab to bring it to the front.

3 To change appearance styles, click the Style buttons. Clicking 
the Plain button turns off all active appearance styles. Clicking an 
active appearance style button turns the style off.

4 To change the capitalization style, choose Upper, Lower, Nor-
mal, Title or Small Caps in the Case pop-up menu.

5 To change the baseline elevation, choose Normal, Superscript, 
or Subscript in the Baseline pop-up menu. If you are applying 
superscript or subscript, specify the distance from the baseline (in 
points) in the text box. Normal baseline always has an elevation of 
zero points.

6 Click Apply to implement the font style settings.
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Specifying spacing between characters
The space between characters is defined by font designers. In Can-
vas, the Kerning option lets you adjust the amount of space to the 
right of each character, so you can bring characters closer together 
(tighten) or spread them farther apart (loosen).

Canvas can also adjust letter and word spacing for paragraphs fol-
lowing minimum, maximum, and desired guidelines that you set. See 
“Adjusting letter and word spacing” on page 273.

The Kerning submenu lets you choose a standard kerning amount: 
Very Tight, Tight, Normal, Loose, or Very Loose. You can interac-
tively kern characters in half-point increments using the Tighten and 
Loosen commands. You can also set a fine kerning amount using the 
Configure Fine Kern command, then use the Tighten Fine and 
Loosen Fine commands to kern characters by the specified amount.

On the Character tab of the Type palette, you can use the Kerning 
option to tighten or loosen kerning by an amount you specify.

To change character spacing using menu commands

1 Depending on how you want kerning to apply, do one of the 
following:

• To change existing text, select the text or text objects.

• To set the kerning before typing, place the insertion point 
where you want the kerning to change.

• To apply the kerning setting to the preset format, deselect 
all objects.

Some combinations of letters 
might have too much or too little 
space between them when typed. 
For example, the first line of Roman 
numerals is unevenly spaced. 
Using kerning controls, we 
adjusted the spacing to make the 
second line appear more even.

These five lines of text 
demonstrate the kerning 
options in the Kerning 
submenu in the Text menu.

Very Tight
Tight

Normal
Loose

Very  Loose
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2 Choose Kerning in the Text menu to open the Kerning sub-
menu and choose one of the following options.

◆ To set the fine kerning amount: Choose Kerning➤Configure 
Fine Kern in the Text menu. In the Kerning Specifications dialog 
box, specify the amount of kerning (in points) you want the Tighten 
Fine and Loosen Fine commands to apply.

To kern characters using the Type palette

1 Depending on how you want kerning to apply, do one of the 
following:

• To change existing text, select the text or text objects.

• To set the kerning before typing, place the insertion point 
where you want the kerning to change.

• To apply the kerning setting to the preset format, deselect 
all objects.

Option Result

Tight 8% less space than normal between 
characters

Very Tight 14% less space than normal between 
characters

Normal Standard spacing as defined by the 
font’s designers

Loose 8% more space than normal 
between characters

Very Loose 14% more space than normal 
between characters

Tighten Reduce kerning by 0.5 points. You 
cannot tighten kerning to less than 
the width of one character

Loosen Increase kerning by 0.5 points

Tighten Fine Reduce kerning by amount specified 
in the Kerning Specifications dialog 
box

Loosen Fine Increase kerning by amount speci-
fied in the Kerning Specifications dia-
log box
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2 If necessary, open the Type palette by choosing Type in the 
Text menu, and click the Character tab to bring it to the front.

3 To set the kerning, choose Normal, Tighten, or Loosen in the 
Kerning pop-up menu and specify the kerning amount (in points) in 
the text box. Normal always has a setting of zero.

4 Click Apply to implement the kerning setting.

Preventing changes to character attributes
Using the Character tab in the Type palette, you can lock the current 
font, type size, and font style to prevent accidental changes. This fea-
ture is especially useful when several people are using the same Can-
vas document. In addition, you can also use this feature to selectively 
exempt sections of text from global formatting changes. Once you 
lock a setting, no one can change it without first unlocking it.

To lock character attributes

1 Depending on how you want locks to apply, do one of the fol-
lowing:

• To change the lock setting of existing text, select the text or 
text objects.

• To change the lock setting before typing, place the insertion 
point where you want the locking to change.

• To apply a lock setting to the preset format, deselect all 
objects.

2 If necessary, open the Type palette by choosing Type in the 
Text menu, and click the Character tab to bring it to the front.

3 To lock an attribute, click the Lock button to the right of it. 
You can also change font attributes in this step. When you click 
Apply, Canvas first applies the new font attributes, then locks the 
new attributes. Click Apply to implement the lock settings.

Horizontal and vertical text scaling
Canvas provides independent control of horizontal and vertical scal-
ing of text. Using this feature, you can stretch characters to create 
extended and condensed letterforms. 

The lock button
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To scale an entire text object, you can also select the text object, press 
Command (Mac) or Alt (Windows), and drag a selection handle. 
Depending on the direction of the drag, Canvas scales text horizon-
tally or vertically.

To scale characters using the Type palette

1 Depending on how you want scaling to apply, do one of the 
following:

• To change existing text, select the text or text objects.

• To set the scale of text before you type it, place the insertion 
point where you want the scale to change.

• To apply scaling to the preset format, deselect all objects.

2 If necessary, open the Type palette by choosing Type in the 
Text menu, and click the Character tab to bring it to the front.

3 To specify the vertical and horizontal scale of characters, enter 
percentages in the Scale boxes. If you enter the same percentage in 
both boxes, Canvas scales the text proportionately. Canvas will 
apply these percentages to the point size displayed in the Size box. 

Canvas does not limit the percentage you can scale characters, how-
ever, extremely high and low settings can distort some fonts and 
make them unreadable. In addition, scaling requires significant 
amounts of memory for text display, which might cause performance 
problems for some systems.

4 Click Apply to implement the scaling settings.

Horizontally scaled 200%

Horizontally scaled 50%

Vertically scaled 200%

Vertically scaled 50%
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Applying paragraph formatting
In Canvas, you can control paragraph attributes, such as justification 
and leading. Paragraph attributes affect entire paragraphs, even if you 
select a single character, or place the insertion point anywhere in the 
paragraph. If you select text in multiple paragraphs, all the para-
graphs will be affected.

Paragraph-level formatting includes the following:

• leading and paragraph spacing

• indents

• tabs

• alignment (justification)

• automatic letter and word spacing

• hyphenation

• widow and orphan controls

Setting line and paragraph spacing
Using the Text menu, Text Ruler, or Type palette, you can adjust the 
spacing, or leading, between lines of text. You can also insert extra 
space before and after paragraphs using the Type palette.

Canvas provides two methods of specifying leading: ratio (or per-
centage) and point size. 

• Ratio and percentage leading are based on the normal lead-
ing of the largest type size in the preceding line. The normal 
leading is usually designed to be slightly larger than the 
point size of the type. For example, a single line of 12-point 
text usually occupies about 15 points of vertical space when 
you specify 100 percent or Single Space leading. Therefore, 
double spaced, or 200 percent, leading for 12-point text 
increases the line spacing to about 30 points.

• Leading specified in points is independent of the type size 
and normal leading of the typeface. The space from baseline 
to baseline is exactly the number of points specified, regard-
less of the size of the type. Using point size leading lets you 
maintain consistent line spacing, and fit text to specific 
space requirements. For example, you have 10 lines of text, 
and exactly 120 points of vertical space to place the text. To 
make the text fit, set the leading to 12 points.
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The Leading submenu of the Text menu lets you set Single, 11/2, or 
Double Space leading. You can also choose the Tighten or Loosen 
commands to fine-tune the current leading in 0.5-point increments. 
You can tighten and loosen the leading repeatedly, but the line spac-
ing cannot be less than zero. The Text Ruler provides the same 
options as the Leading submenu.

The Paragraph tab of the Type palette lets you adjust the leading by a 
percentage or point size that you specify. 

You can also add space between paragraphs by specifying additional 
spacing in points on the Paragraph tab of the Type palette.

To set leading using menu commands

1 Depending on how you want the leading to apply, do one of the 
following:

• To change existing text, select the paragraphs or text 
objects. To set leading for only one paragraph, place the 
insertion point anywhere in the paragraph.

• To set the leading before typing a new paragraph, place the 
insertion point at the beginning of the paragraph.

• To apply the leading setting to the preset format, deselect all 
objects.

A page of text with “after 
paragraph” spacing

A page of text that does not have 
paragraph spacing, but uses both 
“before” and “after paragraph” 
spacing for block quotes
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2 Choose Leading in the Text menu to open the Leading sub-
menu. Canvas places a checkmark next to the current leading set-
ting.

3 Choose a standard leading in the submenu, or choose Tighten 
or Loosen. Canvas applies the setting immediately.

To set leading using the Text Ruler

1 Depending on how you want the leading to apply, do one of the 
following:

• To change existing text, select the paragraphs or text 
objects. To set leading for only one paragraph, place the 
insertion point anywhere in the paragraph.

• To set the leading before typing a new paragraph, place the 
insertion point at the beginning of the paragraph.

• To apply the leading setting to the preset format, deselect all 
objects.

2 If necessary, open the Text Ruler by choosing Show Text 
Ruler in the Layout➤Display submenu.

3 Click a leading button, or click the tighten or loosen buttons. 
The text box on the ruler shows the current leading setting. Canvas 
applies the leading setting immediately.

A CB D EA Single spacing
B 1.5 spacing
C Double spacing
D Tighten leading
E Loosen leading
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To set leading using the Type palette

1 Depending on how you want the leading to apply, do one of the 
following:

• To change existing text, select the paragraphs or entire text 
objects. To set leading for only one paragraph, place the 
insertion point anywhere in the paragraph.

• To set the leading before typing a new paragraph, place the 
insertion point at the beginning of the paragraph.

• To apply the leading settings to the preset format, deselect 
all objects.

2 Configure the leading settings as described below.

Setting leading in the Type palette

Open the Type palette by 
choosing Type in the Text 
menu, if necessary. Click the 
Paragraph tab to bring it to the 
front. After configuring the set-
tings, click Apply to implement 
them.

Percentage leading. To set 
the leading using a percentage 
of the line size, choose Per-
centage in the Line Spacing 
pop-up menu and enter an 
amount in the At box. A lead-
ing of 100% is the same as the 
Normal setting in the Leading 
submenu of the Text menu. 
Double space is 200%, and 

1.5 space is 150%. 

Point size leading. To specify 
leading in points, choose 
Points in the Line Spacing pop-
up menu and enter an amount 
in the At box. Although each 
font’s standard leading might 
be different, normal leading is 
generally between 110% and 
125% of the largest type size 
on the line. Therefore, for 10-
point type, normal leading is 
approximately 12 points.

Before paragraph. To insert 
space before the first line of a 
paragraph, specify the number 

of points in the Before Para-
graph box. Before paragraph 
spacing does not apply to the 
first paragraph in a column.

After paragraph. To insert 
space after the last line of a 
paragraph, specify the number 
of points in the After Paragraph 
box. Canvas inserts space after 
every paragraph, including the 
last paragraph in a column.
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Setting indents
You can set the amount of space between the left and right borders of 
a text object and the edges of each paragraph using the Indents tab of 
the Type palette or the Text Ruler. For text wrapped around an 
object, you can also use the Indents tab to set the distance between 
the edge of the object and the text.

Note: The Text Ruler shows indent positions for one selected object 
at a time. Therefore, you cannot use the Text Ruler to set indents for 
the preset format or for multiple selected objects.

To set indents using the Text Ruler

1 Depending on how you want the indent settings to apply, do 
one of the following:

• To change existing text, select the paragraphs or text 
objects. To set indents for only one paragraph, place the 
insertion point anywhere in the paragraph.

• To set the indents before typing a new paragraph, place the 
insertion point at the beginning of the paragraph.

2 If necessary, open the Text Ruler by choosing Show Text 
Ruler in the Layout➤Display submenu.

3 To set the distance between the left border of a text object and 
the left margin of a paragraph, drag the left indent marker to the 
desired position. Canvas applies the indent setting immediately. 
The Indent Position box shows the distance between the left border 
of a text object and left indent of a paragraph. 

Left = 1 inch
Right = 1 inch

Left = 1 inch First line = 1.5 inches
Left = 1 inch

First line = 1 inch
Left = 1.5 inches
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4 To set the distance between the right border of the text object 
and the right edge of a paragraph, drag the right indent marker to 
the desired position. Canvas applies the indent setting immediately. 
The Indent Position box shows the distance between the left border 
of a text object and the right indent of a paragraph.

To set indents using the Type palette

1 Depending on how you want the indent settings to apply, do 
one of the following:

• To change existing text, select the paragraphs or text 
objects. To set indents for only one paragraph, place the 
insertion point anywhere in the paragraph.

• To set the indents before typing a new paragraph, place the 
insertion point at the beginning of the paragraph.

• To apply the indent settings to the preset format, deselect all 
objects.

2 Configure the indent settings as described below.

Settings on the Indents tab

If necessary, open the Type 
palette by choosing Type in 
the Text menu. Click the 
Indents tab to bring it to the 
front.

Left. To specify the distance 
between the left border of a 
text object and the left indent 
of a paragraph, enter the dis-
tance in the Left box. 

Right. To specify the distance 
between the right border of a 
text object and the right indent 
of a paragraph, enter the dis-
tance in the Right box.

First Line. To specify a differ-
ent indent for the first line of a 
paragraph, enter the distance 
in the First Line box. Canvas 
measures the first line indent 
from the left border of the 
bounding box.

Object Wraps. To specify the 
distance between an object 
and the edge of text wrapped 
around or inside that object, 
enter the number of points in 
the Object Wrap box.

Click Apply to implement the 
indent settings.
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Positioning tab stops
In Canvas, a new text object has tab stops at half-inch intervals 
beginning at the left border of the text object. You can move the 
insertion point to each of these tab positions by pressing the Tab key. 
You can also set new tab stops using the Text Ruler. Canvas lets you 
position five types of tabs.

Left The left edge of text is flush with the tab position.

Center Text is centered around the tab position.

Right The right edge of text is flush with the tab position.

Decimal The first decimal (or period) in a string of text aligns 
directly under the tab position. For example, if you align 
“123.45.678” to a decimal tab, the decimal between the “3” and “4” 
will fall under the tab position.

Comma The first comma in a string of text aligns directly under the 
tab position.

In addition, you can specify a leader character. A leader character 
(typically a period) fills the space inserted by a tab. Leader characters 
are often used in a table of contents to separate chapter headings from 
page numbers and make them easier to read.

Note: The Text Ruler shows tab positions for one selected object at a 
time. Therefore, you cannot use the Text Ruler to set tabs for the pre-
set format or for multiple selected objects.

To set tab stops

1 Depending on how you want the tab settings to apply, do one 
of the following:

• To change tab settings for existing text, select the para-
graphs or text objects. To set tab stops for only one para-
graph, place the insertion point anywhere in the paragraph.

• To set the tab stops before typing a new paragraph, place the 
insertion point at the beginning of the paragraph.

2 If necessary, open the Text Ruler by choosing Show Text 
Ruler in the Layout➤Display submenu. Configure the tab settings 
as described below.
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Paragraph alignment 
Canvas aligns text to the indents of a text object. Canvas has four 
alignment, or justification, settings: flush right, flush left, full (flush 
with both right and left indents), or centered. You can set alignment 
in either the Justification submenu of the Text menu, the Text Ruler, 
or the Paragraph tab of the Type palette.

 

Tab settings

Tabs. Click a button to choose 
a tab alignment: left, center, 
right, decimal, or comma.

A Click the ruler to place the 
tab stop. Canvas removes any 
default tab stops to the left of 
tabs you set.

To move an existing tab stop, 
drag a tab position marker to a 
new location within the left and 
right borders of the text object. 
Text aligned to the tab stop 
adjusts to the new position.

B This line indicates the cur-
rent tab is selected. Click a tab 
position marker to select the 
tab; double click a marker to 

open the Tabs dialog box.

Tab Position. Specify the dis-
tance between the tab and the 
left border of the text object.

Type of Tab. You can change 
the alignment setting of a tab 
by choosing one of these 
options.

Leader Character. You can 
use a character to fill tabbed 
space. To adjust the spacing of 
the leader character, you can 
use kerning options. See 
“Specifying spacing between 
characters” on page 260, for 
more information.

Click OK to implement the tab 
settings.

B

A

Left-justified Right-justified Full-justified Center-justified
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Note: Full justification may create wide letter or word spacing, espe-
cially in narrow text columns. Other justification settings (without 
hyphenation) might appear too ragged on one or both sides. You can 
set letter- and word-spacing parameters to improve the appearance of 
text. For more information, see “Adjusting letter and word spacing,” 
next.

To set justification using menu commands

1 Depending on how you want the justification settings to apply, 
do one of the following:

• To change existing text, select the paragraphs or text 
objects. To set justification for only one paragraph, place 
the insertion point anywhere in the paragraph.

• To set the justification before typing a new paragraph, place 
the insertion point at the beginning of the paragraph.

• To apply justification settings to the preset format, deselect 
all objects.

2 Choose Justification in the Text menu to open the Justification 
submenu. Canvas places a checkmark next to the current justifica-
tion setting.

3 Choose an alignment option in the submenu. Canvas applies 
the justification setting immediately.

To set justification using the Text Ruler

1 Depending on how you want the justification settings to apply, 
do one of the following:

• To change existing text, select the paragraphs or text 
objects. To set justification for only one paragraph, place 
the insertion point anywhere in the paragraph.

• To set the justification before typing a new paragraph, place 
the insertion point at the beginning of the paragraph.

• To apply the justification settings to the preset format, dese-
lect all objects.

2 If necessary, open the Text Ruler by choosing Show Text 
Ruler in the Layout➤Display submenu.

3 Click a justification button. Canvas applies the justification 
setting immediately.

Justification buttons on 
the Text Ruler
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To set justification using the Type palette

1 Depending on how you want the justification settings to apply, 
do one of the following:

• To change existing text, select the paragraphs or text 
objects. To set justification for only one paragraph, place 
the insertion point anywhere in the paragraph.

• To set the justification before a new paragraph, place the 
insertion point at the beginning of the paragraph.

• To apply justification settings to the preset format, deselect 
all objects.

2 If necessary, open the Type palette by choosing Type in the 
Text menu, and click the Paragraph tab to bring it to the front.

3 Click a Justification button.

4 Click apply to implement the justification setting.

Adjusting letter and word spacing
Depending on the type of justification you choose, you might want to 
adjust letter and word spacing to reduce raggedness or eliminate 
unusual spacing. For example, left-justified paragraphs might appear 
too ragged on the right edge, and full-justified paragraphs might have 
large spaces between characters and words. 

You can specify a minimum line width for a paragraph to reduce rag-
gedness. In addition, Canvas has letter- and word-spacing parameters 
to let you specify minimum, maximum, and desired spacing guide-
lines.

To adjust letter- and word-spacing

1 Depending on how you want the letter- and word-spacing set-
tings to apply, do one of the following:

• To change existing text, select the paragraphs or text 
objects. To set spacing for only one paragraph, place the 
insertion point anywhere in the paragraph.

• To set the spacing before typing a new paragraph, place the 
insertion point at the beginning of the paragraph.

• To apply the spacing settings to the preset format, deselect 
all objects.
Adjusting letter and word spacing 273



27
2 If necessary, open the Type palette by choosing Type in the 
Text menu.

3 To set line-width options, click the Paragraph tab to bring it to 
the front, if necessary. 

4 Depending on the type of justification applied to the text, use 
the following options on the Paragraph tab: 

• For right-, left-, and center-justified text: To set the “Mini-
mum Width of Lines,” enter a percentage in the text box. 
The percentage tells Canvas to adjust letter and word spac-
ing so that each line is at least as wide as you specify. For 
example, if you create a two-inch wide, left-justified para-
graph and set the minimum line width to 75%, Canvas 
adjusts the spacing so that each line is at least 1.5 inches 
wide. Only the last line in a paragraph is unaffected by the 
“Minimum Width of Lines” setting.

• For full-justified text: To tell Canvas when the last line of a 
paragraph is wide enough to be justified (flush with both 
right and left margins), enter a percentage in the “Justify 
Last Line Within” box. For example, you create a two-inch 
wide, full-justified paragraph and tell Canvas to justify the 
last line within 75%. If the last line is less than 1.5 inches 
wide, Canvas does not justify the line. However, if the last 
line is wider than 1.5 inches, Canvas justifies the line.

5 To set letter and word spacing parameters, click the Spacing 
tab to bring it to the front, if necessary. Set the minimum, desired, 
and maximum spacing in the Letter and Word areas. Specify each 
setting as a percentage of the current spacing. The desired spacing 
must be greater than the minimum and less than the maximum. The 
maximum spacing cannot be less than the minimum.

Canvas will try to adjust spacing to the desired percentage, but might 
not be able to depending on minimum line width and justification set-
tings. In these cases, Canvas will then try to adjust the spacing within 
the minimum and maximum percentages you specify. However, if 
the minimum and maximum spacing parameters are still in conflict 
with minimum line width or full justification settings, Canvas will 
ignore the spacing parameters.

Spacing settings are on 
the Paragraph tab.
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To change the spacing of a paragraph by a set amount, you can set the 
minimum, desired, and maximum percentages to the same value. 
This has a similar effect to kerning the entire paragraph.

Note: If you applied kerning to characters within the selection, Can-
vas adjusts the spacing as a percentage of the kerning.

6 Click Apply to implement the settings. 

Automatic hyphenation
Canvas can insert a hyphen in the last word of a line to give text 
objects a more balanced, even appearance. You can also control the 
hyphenation properties so that Canvas only hyphenates under spe-
cific circumstances.

Note: Hyphenation settings apply to entire paragraphs. To hyphenate 
a specific word, you can manually insert a hyphen.

To set hyphenation for paragraphs

1 Depending on how you want the hyphenation settings to apply, 
do one of the following:

• To change existing text, select the paragraphs or text 
objects. To set hyphenation for only one paragraph, place 
the insertion point anywhere in the paragraph.

• To allow Canvas to insert hyphens as you type a new para-
graph, place the insertion point at the beginning of the para-
graph.

• To apply hyphenation settings to the preset format, deselect 
all objects.

2 Configure the hyphenation settings as described below.
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Specifying text flow options
You can set text flow options to avoid leaving just a few lines at the 
top or bottom of a column of flowed text. The term widow describes 
the last line of a paragraph that falls at the top of a column, and 
orphan refers to the first line of a paragraph that falls at the bottom of 
a column. Canvas can prevent widows and orphans in a text flow by 
moving the page or column break higher and sending lines to the next 
page or column. In addition, you can specify that all lines in a para-
graph stay together, or that certain pairs of paragraphs always remain 
together in the same column.

Note: Although you can specify widow and orphan settings for indi-
vidual paragraphs, you should apply these settings to entire objects or 
to the preset format. This way, as you edit and move paragraphs, the 
location of the column break can change without causing widows and 
orphans.

However, to modify a column break in a particular paragraph, keep 
all lines in a paragraph together, or keep two paragraphs together, 
you should change the text flow settings for the specific paragraph 
only. In most cases, you won’t want these settings to apply to every 
column break.

Hyphenation settings

If necessary, open the Type 
palette by choosing Type in 
the Text menu. Click the 
Hyphens tab to bring it to the 
front. Turn hyphenation on and 
configure the following set-
tings.

After word beginning. Specify 
the minimum number of letters 
that must precede a hyphen.

Before word ending. Specify 
the minimum number of letters 
that must follow a hyphen.

Smallest word. Specify the 
minimum number of letters 

that a word must have to be 
hyphenated.

Consecutive line limit. Speci-
fy the number of consecutive 
lines that can end in hyphens. 
For example, if four consecu-
tive lines could end in hyphens 
but the limit is three, Canvas 
does not hyphenate the last 
word of the fourth line.

Skip capitalized words. Turn 
this option on to prevent prop-
er names and other words 
beginning with a capital letter 
from being hyphenated.

Click Apply to implement the 
hyphenation settings.
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To prevent widows and orphans

1 Depending on how you want the text flow settings to apply, do 
one of the following:

• To change text flow settings for existing text, select the text 
objects or paragraphs. To change only one paragraph, place 
the insertion point anywhere in the paragraph.

• To apply the text flow settings to the preset format, deselect 
all objects.

2 If necessary, open the Type palette by choosing Type in the 
Text menu, and click the Spacing tab to bring it to the front.

3 Configure the widows and orphans settings, as described 
below.

Widow and Orphan settings

Use the Paragraph area of the 
Spacing tab to configure wid-
ows and orphans protection 
properties.

Widow. Turn on to activate 
widow protection.

If widow protection is on, you 
can specify the minimum num-
ber of lines that can appear at 
the top of a column in a linked 
flow.

Orphan. Turn on to activate 
orphan protection.

If orphan protection is on, you 
can specify the minimum num-
ber of lines that can appear in 
the last paragraph of a column 
in a linked flow.

Keep all lines. To prevent 
Canvas from inserting a col-
umn break in a paragraph, turn 
on this option. This prevents 
widows and orphans, but 
might leave a lot of blank 
space at the bottom of a col-
umn.

Keep with next. To prevent 
two paragraphs from being 
separated by a column break, 
turn on this option. This option 
is useful for keeping a one-line 
paragraph, such as a heading, 
together with its section.

Click Apply to implement the 
text flow settings.
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Setting drop caps
Drop caps are large characters that extend below the normal baseline 
of the first line of an opening paragraph. Canvas indents the text 
below the first line to make room for the drop caps. Canvas can for-
mat drop caps for just the first paragraph of an object or any selected 
paragraphs.

To set up a drop cap

1 Depending on how you want the drop cap to apply, do one of 
the following:

2 Configure the drop cap options as described below.

To apply to Do this

First paragraph in a text 
object

Select the object or place the inser-
tion point anywhere in the first para-
graph

All other paragraphs Place the insertion point in a para-
graph, or select a paragraph. You can 
also select multiple consecutive para-
graphs.

A new paragraph you are 
about to type

Place the insertion point at the begin-
ning of the paragraph.

The preset format Deselect all objects. Canvas will apply 
drop caps to the first paragraph of all 
new text objects you create with the 
Text tool.

 
 
 

Drop Cap settings

If necessary, open the Type 
palette by choosing Type in 
the Text menu. Click the 
Indents tab to bring it to the 
front.

Lines. Specify the number of 
lines you want the drop caps to 

occupy. This determines the 
vertical height of the drop cap.

Characters. Specify the num-
ber of characters to enlarge for 
drop caps. Canvas always 
applies this setting beginning 
with the first character in a 
paragraph.

Click Apply to implement the 
drop cap settings.
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Creating new typ
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USING TYPE STYLES

You can save type formatting settings as named character and para-
graph type styles using the Styles tab in the Type palette. Canvas 
stores type styles with documents. When you open a document, Can-
vas loads the associated styles so you can apply them.

Type styles make it easy to apply formats and maintain consistency 
throughout a document. You can base styles on each other to form a 
“family” of styles, so that styles inherit the character and paragraph 
attributes of a parent style. Organizing styles in this manner makes 
global style changes a simple matter of changing the parent style.

When you change a style, text using the style also changes. In the 
case of style families, when a parent style changes, Canvas updates 
the entire style family and all text using styles in the family.

Creating new type styles
You can create two kinds of styles, character and paragraph, which 
incorporate different formatting attributes. After establishing charac-
ter and paragraph styles, you can apply them independently to create 
new combinations.

Character style attributes Paragraph style attributes

Font Leading

Type size Indents

Font style Justification

Capitalization style Drop caps

Baseline position Hyphens

Kerning Letter and word spacing

Colors (optional) Text flow settings

Character attributes and colors 
(optional)
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Using style families
When you base a style on another, the style “inherits” the attributes 
of the parent style. When the parent style changes, Canvas also 
updates all related styles. In addition to inherited attributes, the style 
possesses its own attributes, which you specify. A style’s own 
attributes always take precedence over attributes inherited from the 
parent style.

For example, you create a style, Body2, based on a parent style, 
Body1. The fonts are the same, but the type sizes are different. Body2 
uses 10 point type, while Body1 uses 12 point. If you change the font 

To create a new type style

To save the attributes of exist-
ing text as a style, place the 
insertion point in the text and 
choose Type in the Text menu 
to open the Type palette. You 
can also save current Type pal-
ette, Text menu, and Text Rul-
er settings as a style, without 
first applying them to text.

After you choose settings for a 
type style, click the Styles tab 
in the Type palette to bring it 
to the front.

Example. Displays a sample of 
text with the current formatting 
settings applied.

Description. Lists the current 
character or paragraph 
attributes. The C and ¶ buttons 
toggle between descriptions of 
character and paragraph 
attributes.

To save a type style, click Cre-
ate to open the Create Type 
Style dialog box. Configure the 
following settings.

Character or Paragraph. Click 
one of these buttons to specify 
what kind of style you want to 
create.

Based on. Choose a style 
name in this pop-up menu to 
base the style you are creating 
on an existing style. To disable 
this feature, choose None. See 
“Using style families,” 
page 280, for more informa-
tion.

Include. Select the attributes 
you want to save as part of the 
style. You can include ink set-
tings (fill and stroke attributes 
that have been applied to 
existing text) in character and 
paragraph styles. For para-
graph styles, you can also 
include font attributes and tab 
settings.

Style name. Type a name for 
the style. 

Click Save to store the style 
and close the dialog box.
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for the parent style, the font also changes for Body2. However, if the 
point size changes for the parent style, Body2 does not change, 
because Body2’s own attributes take precedence. To make Body2 
always use the same point size as Body1, you must set the point sizes 
equal, base Body2 on Body1, and save the style again. 

In addition, if you later change Body2’s font, this style will no longer 
inherit fonts from the parent style. Body2’s font will override 
Body1’s font setting.

Careful planning will save you from time-consuming corrections 
when basing styles on each other. In some cases, changing a parent 
style’s attributes may cause unwanted changes throughout the style 
family. For example, if you base ten styles on Body1, and later 
decide that you want Body1 (but not the whole family of styles) to be 
double spaced, you must first change the leading for Body1, then 
remove the leading setting from each of the other ten styles.

Saving and loading type styles
You can save type styles to files on disk and then load them into 
other documents. This feature helps maintain consistency between 
documents, and lets you share type styles with other Canvas users.

◆ To save a type style to disk: Press the triangle at the bottom-
left of the Styles tab and choose Save Style in the pop-up menu. In 
the directory dialog box, type a filename and specify a location to 
save the file, then click Save.

◆ To load a type style: Press the triangle at the bottom-left of the 
Styles tab and choose Load Style in the pop-up menu. In the directory 
dialog box, locate and select the style, then click Open.

Copying type styles between documents
You can copy named type styles from one Canvas document to 
another by copying text that uses the style and pasting it into a differ-
ent document. Canvas transfers the style with the text. When you 
save the document, Canvas also stores the transferred style.

A type style based on another style cannot inherit attributes across 
documents. For example, Body2 is based on a parent style, Body1, 
and you copy only Body2 to a new document. Body2 in the new doc-
ument no longer inherits attributes from Body1, which is still in the 
original document. 
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However, if you copy both Body1 and Body2 to a new document, the 
relationship is preserved, and Body2 will inherit attributes from its 
parent style.

Applying type styles
Applying type styles is similar to applying individual character or 
paragraph formats using the Type palette. However, instead of con-
figuring settings on each of the tabs in the palette, you can simply 
choose style names in the pop-up menu at the bottom-right corner of 
the Type palette.

The pop-up menu displays the current type style name. The C and ¶ 
indicate if the style is a character or paragraph style, or both. If “+++” 
appears to the right of a style name, the style has been modified but 
not saved. If you choose a style in the pop-up menu when “+++” 
appears next to the current style, you will lose the modifications to 
the style. Therefore, if you want to use the settings again, you should 
save the modified style with a new name before applying other styles.

◆ To apply a style to selected text or text objects: Select the 
text or text object(s) to which you want to apply a style. Choose a 
style in the pop-up menu at the bottom-right of the Type palette. 
Click Apply to implement the style. 

If the text you selected already had a style applied, Canvas replaces 
the style with the style you choose. In addition, if you apply a para-
graph style with font attributes to highlighted text, the font attributes 
affect the selection only, and the paragraph attributes affect the entire 
paragraph.

◆ To use a type style as the current format setting: If neces-
sary, deselect all text objects by pressing Enter (Mac) or Esc (Win-
dows). Choose a style in the pop-up menu on the bottom-right corner 
of the Type palette and click Apply. Canvas formats new text objects 
with the specified style.

Modifying type styles
You can change the attributes of a type style and save the style with 
the same name. When you change a style’s attributes, all styles in the 
family automatically inherit the new attributes and Canvas updates 
any existing text that uses the family of styles.

Indicates character or 
paragraph style

Style name

Indicates modified style

✔Tip
To set current inks (other than 
black) for new text, save the 
inks as a type style attribute 
and use the type style as the 
current text format. These inks 
don’t affect the current inks for 
vector objects.
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To modify a type style

1 In the Type palette, choose the style you want to edit in the 
pop-up menu at the bottom of the palette.

2 Use the Type palette to change the style’s attributes. Canvas 
displays “+++” after the style name at the bottom of the palette to 
indicate that changes were made to the style.

3 Click the Styles tab to bring it to the front, and click Create.

4 In the Create Type Styles dialog box, Canvas displays the cur-
rent style name in the Based On pop-up menu and Style Name box. 
To replace the style, do not change these settings.

5 If you want, you can include ink settings. For paragraph styles, 
you can also include font attributes.

6 Click Save. Canvas asks you to confirm that you want to 
replace the existing style with the new style. Click OK.

Deleting type styles
To minimize confusion when choosing styles to apply, you can delete 
type styles you don’t use. Text using a deleted type style retains its 
formatting, but no longer has a named style. In addition, any text 
using a style based on a deleted style also loses its named style. See 
the illustration below for other effects of deleting a type style that is 
part of a style family.

Deleting parent styles

The diagram shows the results 
of deleting type styles on 
which other styles are based. 
Arrows indicate how these type 
styles are based on each other.

A Body2 is based on Body1. 
Deleting Body1 makes Body2 
an independent style.

B Body3 is based on Body2, 
which in turn is based on Body1. 
Deleting Body2 makes Body3 
based on Body1.

Body1

Body2

Body1

Body2

Body1

Body2

Body3

Body1

Body3

A

B

Body2
Deleting type styles 283



28
◆ To delete a style: Click Delete on the Styles tab in the Type 
palette. Choose the style you want to delete in the pop-up menu and 
click OK. 

Tips on using type styles

By putting some forethought into the purpose 
and design of type styles, you can ensure that 
you are using this feature effectively. This plan-
ning will be especially useful when editing styles 
and documents, allowing you to make a few 
modifications that update entire documents.

Design a template. If several people need to 
use the styles, you might want to save the styles 
in a template document. This way, everyone 
uses a common source for the styles.

Create a “normal” type style. This will make it 
easy to revert formatted text to a basic style. 
When you apply the normal style, it will have the 
effect of removing or overriding other styles.

Name styles by their function. For example, a 
heading style might consist of boldface type. 

Rather than name this style “Bold,” name it 
“Heading,” or something that similarly 
describes its usage. This will make it easier to 
remember when to use which style.

Always apply a style. If you choose to use styles 
in documents, be sure to use them throughout. 
If you apply styles only sometimes, you might 
encounter difficulties maintaining consistency 
and performing global style changes.

Create style families when possible. You might 
want to use the Based On feature (see “Creating 
new type styles” on page 279) to create style 
families for styles that share some attributes. 
This will make global changes easier. See “Using 
style families” on page 280, for more informa-
tion. 

Style name pop-up menu
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Applying path effects
18

TYPE EFFECTS

This chapter explains how to apply different kinds of effects to type. 
In Canvas, you can apply three kinds of effects to type.

Path effects You can wrap text around objects, bind text to the 
path of an object, and slant the margins of a text object.

Ink and stroke effects You can change the color and pattern of a 
character’s outline and interior.

Vector effects You can change a text object’s shape and orienta-
tion, and convert text to paths so you can use path editing techniques 
to reshape characters. You can also create three-dimensional and 
lighting effects.

Applying path effects to type
Path effects let you change text margins and baselines to make text 
flow around or inside shapes. Canvas has two path effects, wrap and 
bind.

• Wrap effects adjust text objects’ margins so that text flows 
outside or fits inside shapes. You can use objects to set text 
boundaries or choose a menu option that lets you slant text 
margins by dragging selection handles.

• Bind effects align the text baseline to the path of an object 
you select. If the path is not straight and horizontal, Canvas 
changes the vertical orientation to match the path.

Wrapping text inside an object
When you wrap text inside a paint or vector object, Canvas adjusts 
the text object’s margins so that text fits within the boundaries of the 
object. A text object can be wrapped inside only one object at a time, 
and an object can have only one text object wrapped inside it.

Canvas has two methods of wrapping text inside an object. You can 
select an existing text object and a vector or paint object and choose 
the Wrap➤Inside Shape option in the Text menu. You can also select 
an existing paint or vector object and simply begin typing; the text 
will stay inside the boundaries of the object. 
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If you wrap text inside an open vector object, such as an arc, the text 
wraps between the bounding box and the concave side of the arc. If 
you try to wrap text to a line or a narrow arc, the text will not be visi-
ble. If this occurs, choose Wrap➤Remove Wrap in the Text menu or 
choose Undo in the Edit menu to make the text visible again.

◆ To wrap existing text inside an object: Select an object and a 
text object. Choose Wrap➤Inside Shape in the Text menu. Canvas 
places the text inside the object.

If there is more text than can fit inside the shape, Canvas inserts a col-
umn break in the text object and displays a text flow symbol. You can 
resize the object to fit the text, or flow the excess text to another col-
umn; see “Placing overflow text in another column” on page 234.

◆ To type new text inside an object: Select a vector or paint 
object and begin typing. Canvas adjusts margins so that text you type 
remains within the left and right borders of the object. 

If the object is too small to contain all the text you type, the text 
object extends below the object. You can resize the object to fit the 
text. You can also resize the text object to fit the shape, and then flow 
any excess text to another column. 

Wrapping text outside an object
The Wrap➤Outside Shape option in the Text menu lets you flow text 
around objects. When you apply an outside wrap, Canvas adjusts 
margins so text doesn’t overlap selected vector or paint objects. This 

Center-justified text wrapped inside an oval
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option is available when you select one text object and one or more 
paint or vector objects. You can simultaneously wrap one text object 
around more than one object. You can also wrap more than one text 
object around an object, but you must wrap one text object at a time.

Depending on the position of the object within the text column, text 
wraps to one side of the shape. A single column of text cannot wrap 
around both sides of an object.

Text wrapped outside objects

To wrap text around an object

Before wrapping a text object, you might want to position the text so 
it overlaps an object in approximately the desired arrangement. You 
can adjust the exact positioning later.

1 Select a text object and at least one other object. If the selected 
text object is already wrapped around a different object, Canvas 
removes that wrap. To wrap one text object around multiple 
objects, select all the objects at the same time. 

2 Choose Wrap➤Outside Shape in the Text menu. Canvas 
adjusts margins so text doesn’t overlap the selected objects.

3 If necessary, arrange the objects until they are positioned prop-
erly. Canvas adjusts the margins as you move objects.

Slanting text columns
The Wrap➤Slant Margin option in the Text menu lets you change a 
text column’s margins to form a parallelogram.

Object to one side; text 
wraps to one side

Object in center; text 
wraps to one side only

Two objects on opposite 
sides; text wraps to one 
side of each

Two columns, each 
wrapped to one side of 
two objects

✔Tip
When you wrap text outside a 
paint object, Canvas actually 
wraps text to the pixels inside 
the image based on the color 
of the pixels. Off-screen, Can-
vas converts the image to black 
and white; text wraps around 
areas that would be mapped to 
black, and overlaps areas that 
would be mapped to white.
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To slant right and left margins

1 Select a text object. 

2 Choose Wrap➤Slant Margin in the Text menu. The text 
object’s selection handles change to four corner handles.

3 To slant margins away from the bottom line of text, drag either 
of the text object’s top two selection handles horizontally. 

4 To slant margins away from the top line of text, drag either of 
the text object’s bottom two selection handles horizontally.

5 Press Enter (Mac) or Esc (Windows) when you are finished.

Removing wrap effects
You can restore text margins to the standard rectangular shape by 
choosing Wrap➤Remove Wrap in the Text menu. 

◆ To remove a wrap effect: Select a wrapped text object. Choose 
Wrap➤Remove Wrap in the Text menu.

Setting the column angle

When you choose the 
Wrap➤Slant Margin option, 
you can drag selection handles 
to specify the angle of mar-
gins.

A The bottom right handle of 
the text column is dragged to 
specify the angle of the margins 
(shown by the dashed lines).

B Canvas adjusts the margins 
to slant the text column within 
the bounding rectangle. (The 
bounding rectangle is repre-
sented by the eight selection 
handles.)

A B
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Binding text to vector objects
You can bind the baseline of text to the path of most types of vector 
objects. Canvas adjusts the vertical orientation of each character to 
match the path. You cannot bind text to objects drawn with the Con-
centric Circles, Spiral, or Grid tools.

Depending on how you want to bind text, you can use the Bind Text 
command in the Effects menu or the Path Text tool in the toolbox. 
The Bind Text command in the Effects menu lets you bind existing 
text to an object, and the Path Text tool lets you type new text 
directly on the path of a selected object.

Canvas lets you bind multiple text objects to one vector object, but a 
text object can bind to only one vector object at a time. Also, you can 
bind only one text object to a vector object using the Path Text tool. 
To bind additional text objects to the same vector object after using 
the Path Text tool, you must create a separate text object with the 
Text tool and use the Bind Text command.

To bind existing text using a menu command

1 Select a text object and a vector object.

Path Text tool

Position and direction of 
bound text

Whether you use the Bind 
Text command or Path Text 
tool, the location where you 
click the crosshair pointer 
determines the alignment 
position. 

A This text is center-justified. 
The crosshair pointer (which ap-
pears after choosing the Bind 
Text command or the Path Text 
tool) determines where text will 
bind. In the example, the point-
er is clicked in the upper-right 
quadrant of the oval. The inset 
shows the bound text, centered 
around the point where the 
pointer was clicked.

B For open-ended objects, 
such as arcs, bound text initially 
flows in the direction the object 
was drawn. In this example, the 

arrows indicate the direction the 
arcs were drawn. Text objects 
bound to these arcs follow the 
direction of the arcs.

A B
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2 Choose Bind in the Effects menu. When the pointer is on the 
edge of the selected object, the pointer becomes a crosshair.

3 With the crosshair pointer, click to place the selected text on 
the path. Text aligns to the point where you click. For example, if 
the text is center-justified, Canvas binds the text so that it is cen-
tered around the point you click.

4 To change the alignment and position of bound text, see the 
procedure later in this section.

To type on a path using the Path Text tool 

1 Select the Path Text tool in the Text tools toolbar. When the 
pointer is on the edge of an object, the pointer becomes a crosshair.

2 With the crosshair pointer, click where you want to start typing 
on the path. An insertion point appears.

3 Begin typing. Text you type aligns to the location where you 
placed the insertion point and follows the path of the object.

4 To change the alignment and position of bound text, see the 
procedure below.

Working with bound text
Once you bind text, you can change its starting position, alignment, 
baseline position, and flow direction. In addition, you can edit the 
shape and location of the vector object to which text is bound, and 
Canvas will fit the text to the new path.

You can also edit bound text by selecting the Path Text tool and 
clicking the text object, or by double-clicking a bound text object 
with a Selection tool. However, text editing might be difficult and 
slow while the text is bound to an object; you might want to remove 
the text bind, make changes, and re-bind the text.

Bound text and its binding object move together, just like grouped 
objects. However, unlike grouped objects, you can select and change 
attributes (such as stroke and ink) individually for the text and the 
object.
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To position and align bound text

Canvas has three Bind Position handles (shown in color below) that 
you can drag to place text anywhere on, above, or below an object. 
The handles appear when you select a bound text object.

Bind Position handles

Removing a text bind
You can remove a bind effect by selecting a bound text object and 
choosing Remove Effects in the Effects menu. Canvas straightens the 
text baseline and separates it from the vector object.

Handle Description Example

Reverse Flow handle Click to switch the vertical orienta-
tion of type relative to the object 
path and reverse the flow direc-
tion.

Alignment handle Drag to specify the point where 
you want type to align. For exam-
ple, center-justified text will center 
around the location of this handle.

Baseline Shift handle Drag to change the elevation of 
the baseline relative to the vector 
object.

Baseline Shift lets you insert space 
between bound type and the 
object.

Text is centered around the
alignment handle
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Binding text to a circle
In Canvas, you can create circular logos, with text on the top flowing 
clockwise and text on the bottom flowing counterclockwise. You can 
create this effect by binding two text objects to a circle and using the 
Bind Position handles to arrange the text. 

To create a circular logo

1 Create a circular object using the Oval tool in the toolbox.

2 Create two text objects and bind them to the circle. You can 
use the Path Text tool to create and bind the first text object, but 
you must then bind the second text object using the Bind Text com-
mand.

3 Center the text objects on the top and bottom of the circle by 
selecting each one and dragging its Align handle. Centering text 
objects is easier if the text is center-justified.

4 Click the Reverse Flow handle of the bottom text object so the 
text reads from left-to-right inside the circle. 

5 Now shift the bottom text object outside the circle by dragging 
its Baseline Shift handle outward from the center of the circle. As 
you drag, Canvas displays a proportionately-sized circle to show 
the location of the baseline.

Binding text to a circle

A The design consists of a cir-
cle and two text objects.

B One text object is bound to 
the top of the circle, the other 
to the bottom of the circle. Text 
initially flows clockwise.

C Clicking the Reverse Flow 
handle (highlighted in inset) 
makes “Ipsum” flow counter-
clockwise inside the circle.

D Dragging the Baseline Shift 
handle (highlighted in inset) po-
sitions “Ipsum” outside the cir-
cle. Removing the circle com-
pletes the design.

A B

DC
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Path effects with type and paint objects
In Canvas, type wrapped to an image follows the shape defined by 
dark pixels in the image. When you wrap text outside a paint object, 
Canvas actually wraps text to the pixels inside the image based on the 
color of the pixels. Canvas creates this effect by mapping the selected 
image to black and white off-screen; Canvas performs this operation 
in memory, but the original image is unaffected. 

Canvas then wraps the selected text object around areas that are 
mapped to black. However, Canvas lets text overlap areas of the 
image that are mapped to white. This effect works well when you 
have an isolated, relatively dark image on a light background.

However, when an entire image is relatively dark or light and con-
trast is low, Canvas can’t isolate areas to wrap around. Text will 
either overlap the entire image, or run around the entire image. 

To get text to wrap around the areas of the image you want it to, you 
can use a vector object that overlaps an image, then wrap text to the 
vector object. This section describes how to use vector objects to 
make text appear to wrap to an image.

Path effects using vector object outlines
If you are working with an image that doesn’t enough contrast 
between the subject and the background for Canvas to wrap text 
around the correct areas, you can draw vector objects around shapes 
in the image. You can then wrap or bind text to the vector object, and 
the text will appear to follow the shape in the image.

To add path effects to an image

1 Select a drawing tool and draw objects that follow the contours 
of shapes in the image. The Curve tool and Polygon tool are good 
for outlining complex shapes. You can also use rectangles and 
ovals to outline portions of shapes that are roughly geometric and 
group or combine the objects. To make layout easier, give the 
shapes a visible pen ink and no fill ink.
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2 Wrap or bind text objects to the vector object outlines. See 
“Wrapping text inside an object” on page 285, “Wrapping text out-
side an object” on page 286, and “Binding text to vector objects” on 
page 289.

3 To hide vector object outlines, specify no pen color in the Inks 
palette.

Applying inks and strokes to type
You can use the Inks and Strokes palettes to change the color and 
pattern of a character’s interior and outline. Canvas treats each char-
acter like a vector object, to which you can apply any combination of 
fills and strokes to create lighting or dimensional effects. This section 
provides some examples of different applications of ink and stroke 
effects on characters. In addition, this section discusses other meth-
ods for adding color to characters, such as masks and paint objects.

In Canvas, a character’s stroke is its outline, the pen ink is the color 
of the outline, and the fill ink is the color of the interior. You can 
apply inks to existing text, or use type styles to set current inks for 
new text you type; see “Applying type styles” on page 282.

Text wrapped around the polygon outline of the lighthouse

Lorem ipsum dolor sit
amet, consectetuer

adipiscing elit, sed diam
nonummy nibh

euismod tincidunt
ut laoreet dolore

magna
aliquam

erat
volutpat.  Ut

wisi
enim

ad
mini

m
ven
iam,

quis

nostrud exerci tation
ullamcorper suscipit
lobortis nisl ut aliquip

ex ea commodo
consequat.  Duis

autem vel eum
iriure
dolor in

hendrerit
in vulputate

velit
esse
mol
esti
e
con
seq

uat.

The finished product, with the polygon hidden

Lorem ipsum dolor sit
amet, consectetuer
adipiscing elit, sed diam
nonummy nibh
euismod

tincidunt
ut laoreet
dolore

mag
na

aliqu
am

erat
volu

tpat.  Ut wisi enim ad
minim veniam,
quis nostrud exerci

tation umcorper
suscipit

lobortis
nisl ut

aliquip ex
ea
co
m
mo
do
con

sequat.

Wrapping text inside
a paint object
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Applying inks to text
You can use the Inks palette to design colors, gradients, textures, and 
symbols, then apply fill and pen colors to text. Canvas treats each 
character as an individual object, and repeats the ink pattern for each 
character. For example, you create a right-to-left gradient using black 
and a color. You apply a gradient fill to a word, and each character 
blends from color to black.

◆ To apply inks to characters: Select the text or text objects to 
which you want to apply fill or pen inks. Open the Inks palette in the 
toolbox, and choose fill and pen inks. For more information, see 
“Inks: colors and patterns” on page 127.

Using masks to create continuous character fills
You can make a pattern, gradient, or image appear to span an entire 
selection, rather than begin and end within each character. For exam-
ple, instead of a gradient completing a blend pattern within each 
character of a word, you can make a gradient begin a blend in the first 
character and finish the blend in the last character.

In Canvas, you create these kinds of “continuous” fills using back-
ground objects and foreground text object masks. The intersection of 
the background and foreground objects provides the appearance of a 
continuous fill. This method lets you use elaborate background 
designs, including paint objects, to fill characters. For more informa-
tion, see “Masking objects” on page 207.

Stroke = 1 point
Fill ink = none
Pen ink = black

Stroke = none
Fill ink = PANTONE 123
Pen ink - none

Stroke - 1 point
Fill ink - PANTONE 123
Pen ink - black

✔Tip
You can also apply inks to the 
background of a text object. 
Select the text object (don’t put 
it in edit mode), hold down 
Option (Mac) or Ctrl (Windows) 
and choose a fill ink. The ink 
fills the area of the bounding 
box of the text object.

A gradient fill was designed in the 
Inks palette and applied to this 
word. Canvas filled each 
character with a blend of color 
and black.
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◆ To create a text object mask: Position the text object in front 
of the background object, and select both objects. Choose 
Mask➤Make in the Object menu.

Applying strokes to characters
You can change the attributes of a character’s stroke using the 
Strokes palette in the toolbox. You can apply any of the stroke pat-
terns to text. In general, because characters can have tight corners and 
curves, stroke patterns look better when used with large, rounded 
type faces.

◆ To apply strokes to text: Select the text or text objects to 
which you want to apply strokes. Use the Strokes palette in the tool-
box to choose and configure strokes. For more information, see 
“Strokes: outline effects” on page 145.

Text masking the background 
objects; the text appears to 
be filled with the background

Text in front of background 
objects (top - gradient-filled 
rectangle; bottom - image of 
a clamshell)
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Applying vector effects to type
You can apply the following vector effects to text objects:

• Envelope

• Extrude

• Rotate

• Freeform

• Flip

• Shadow

• Path editing

You can use these effects to add dimension to type and create striking 
designs. This section describes briefly how to apply each of these 
effects. For more information, see “Vector effects” on page 207.

Before applying vector effects to type

Depending on the number and kind of effects you apply to type, you 
might not be able to edit the text afterwards. For example, you can 
edit text after rotating and skewing, but if you also extrude the type, 
Canvas converts the text to vector objects. In addition, depending on 
the speed of your system, editing rotated and skewed text might be 
slow. Therefore, you might want to finish all text editing, formatting, 
and layout before applying effects.

Freeform and rotate effects
In Canvas, you can place a text object in freeform mode and then 
drag any of the hollow selection handles of the bounding box to 
rotate and skew text. You can also perform exact rotations using the 
Rotate command in the Effects menu.

Calligraphic pen stroke

Height = 6.38 points 
Width = 1.00 point 
Angle = 130 degrees

Full neon stroke

Inside color = white
Outside color = black
Width = 8 points
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◆ To freeform edit a text object: Select a text object using a 
Selection tool. Choose Freeform in the Effects menu. You can drag a 
circular selection handle to rotate the text object, or a square handle 
to skew the text.

◆ To rotate a text object an exact amount: Choose Rotate in the 
Effects menu to open the Rotate dialog box. You can specify the 
degrees of rotation and the center of rotation. Click Apply to see the 
effect of the settings, or click OK to accept the settings.

Flipping text
You can use the Flip options in the Effects menu to create mirror 
images of text. In Canvas, you can flip text horizontally, vertically, or 
both.

◆ To flip text: Select the text object(s) you want to flip. Depend-
ing on the direction you want to flip text, choose Horizontal, Vertical, 
or Both Axes in the Flip submenu in the Effects menu. Canvas imple-
ments the setting immediately.

Shadow effects
In Canvas, when you apply a shadow to text, the shadow is a separate 
text object that you can color, edit, and apply effects to independently 
of the original text object. By applying the right combination of 
effects, you can create oblique shadows and other lighting effects.

This design consists of rotated (black 
“EXERCI”) and skewed (colored 
“EXERCI”) type.

The overlapping effect was achieved 
by dividing each word into two text 
objects, “EXE” and “RCI” and 
arranging the stacking order.

Original

Vertical flip

Horizontal flip

Both axes
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Because Canvas creates a separate text object for the shadow, 
changes to the original text object do not change the shadow. You 
should finalize text before applying shadows to ensure that the text is 
the same for both objects.

◆ To create a shadow: Select the text object(s) you want to apply 
shadows to. Choose Shadow in the Effects➤Transform submenu to 
open the Shadow dialog box. Specify vertical and horizontal offset 
amounts and a color for shadows. Canvas creates the shadows and 
arranges them behind the original text object(s).

Text shadow effects

By combining Canvas effects, 
you can create different types 
of shadows.

A A standard shadow, slightly 
offset and shaded black.

B The shadow text object was 
skewed to create an oblique 
shadow.

C This example consists of 
three objects: the original text, a 
slightly offset shadow, and an 
oblique shadow. To blur the 
shadow, convert the text to a 
paint object with the 
Area➤Render option in the Im-
age menu. Then, choose 
Filter➤Blur➤Gaussian Blur in 
the Image menu and set the ra-
dius to 3.0.

A B

C
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Envelope text effects
You can use the Envelope effect to warp and distort type to create 
new character forms and stretch text like rubber. When you apply this 
effect to a text object, Canvas lets you drag selection handles to 
reshape text. Depending on the type of envelope you apply, text 
stretches in different ways. Using this effect, you can add perspective 
to text or simulate stretching type around a three-dimensional object.

Note: You cannot edit text after applying an envelope effect. In addi-
tion, you cannot extrude an object after changing its envelope. How-
ever, you can change the envelope of an extruded object.

◆ To edit the envelope of a text object: Select a text object and 
choose Envelope in the Effects menu. Choose a type of envelope 
effect in the pop-up menu and click Apply. Drag selection handles to 
reshape the text object.

Extruding text
You can extrude text and add lighting effects to make text appear 
three-dimensional. As with vector objects, you can rotate and scale 
extruded text to change the apparent depth, size, and orientation. For 
text, you can use only the Parallel option in the Extrude palette. You 
can also choose a color and position for the light source.

Note: You cannot edit text after extruding it. Also, Canvas removes 
stroke and fill attributes before extruding text because they can inter-
fere with the three-dimensional effect. You can add color to extruded 
objects by choosing a fill color in the Inks palette and a color for the 
light source in the Extrude palette.

The “M” and “A” are separate 
text objects that have been 
“warped.”

Envelope effect was used to 
create the impression that 
characters were painted on the 
side of this cargo ship.

Extruded text with lighting effects
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◆ To extrude text: Select a text object and choose Extrude in the 
Effects menu to open the Extrude palette. Choose Parallel in the pop-
up menu, configure the settings and click Apply. Use the extrusion 
handles to shape and rotate the text.

Converting text to paths
Canvas can create path outlines of characters so you can edit the 
shape of each character. Once you convert text to paths, Canvas treats 
the paths as objects. You cannot edit the objects as text (apply fonts 
to, change the type size of, or spell check, for example).

To edit text as paths

1 Select a text object and choose Path➤Convert to Paths in the 
Object menu. If the text object contains multiple characters, Canvas 
groups the converted text together. 

2 If you want to edit individual character outlines in a group, 
choose Ungroup in the Object menu. You can also use the Direct 
Selection tool to select shapes without ungrouping them first.

3 Double-click a character outline to place it in path edit mode. 
To put several shapes in path edit mode at the same time, you can 
select multiple character outlines and choose Path➤Edit Path in the 
Object menu.

4 Use path editing techniques to change the outline. 

5 Press Enter (Mac) or Esc (Windows) to exit edit mode.
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Editing characters as 
paths

You can create your own char-
acters and shapes using path 
editing techniques.

A The original character.

B The character in edit mode, 
after conversion to a path.

C Anchor points were edited 
to create this shape.

D The finished character.

A

C

B

D
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Creating new paint objects and
19

PAINTING AND IMAGE-EDITING 
TOOLS

Canvas provides a full palette of painting tools, including the digital 
equivalents of markers, airbrushes, and paintbrushes, plus tools for 
creating effects like neon and blends. The toolbar of painting tools 
also provides tools to select, retouch, color-correct, and clone images. 
This chapter explains how to use these painting tools, choose image 
modes, and convert objects into images.

Creating new paint objects and images
In Canvas documents, paint objects are rectangular areas that contain 
colored pixels. Using painting tools and effects, you can change the 
color of each pixel to create an image. To make a new paint object, 
you can use the Paint Object Creator tool or the Area➤Create com-
mand in the Image menu. When you create a new paint object with 
the Paint Object Creator tool, it is filled with white pixels; when you 
use the Create command, you can choose a color for the new pixels. 

About paint objects and 
images in Canvas 

“Images” are pictures defined 
by tiny dots, called pixels. A 
scanned photo, a TIFF or Pho-
toshop file, and pictures you 
paint in Canvas are all images 
composed of pixels. 

In a Canvas document, an 
image is contained in a paint 
object the same size as the 
image. Painting tools operate 
on the pixels within images, 

while object tools and com-
mands, such as the Selection 
tool or Align command, apply 
to entire paint objects.

You can perform common 
object operations, including 
move, copy, and duplicate, on 
paint objects. For details, see 
the chapter titled “Working 
with objects” on page 97.

You can create images entirely 
in Canvas by making a new 
paint object that you can paint 

in, or creating an image from 
vector or text objects, as 
described in this chapter.

You can also import images 
into Canvas documents using 
the following methods:

• Place an existing image in a 
document using the Place, 
Paste, or Acquire commands.

• Scan a photo using the 
Acquire command. See 
“Using scanners to acquire 
images” on page 337.
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Using the Paint Object Creator tool
You can drag the Paint Object Creator tool in a document to make 
new paint objects. You can use the default settings, or specify image 
mode and resolution before you use the tool. For help selecting 
painting tools, see “Using the Painting Tools toolbar” on page 309.

◆ To set the image mode: Before creating a paint object, press 
the Paint Object Creator tool and choose an image mode in the pop-
up menu. See “Image modes for Canvas paint objects” on page 328 
for more information. 

◆ To set the resolution: Before creating a paint object, press the 
Paint Object Creator tool and choose a resolution in the pop-up 
menu. If you choose Custom, a dialog box appears; type the resolu-
tion and click OK.

1 Select the Paint Object Creator tool. 

2 Drag diagonally to create a rectangular paint object. When you 
release the mouse button, Canvas creates a paint object filled with 
white pixels. The new paint object appears in edit mode. You can 
begin painting and editing the image.

3 To exit edit mode, press Enter or Esc (Mac) or Esc (Windows). 
The paint object remains selected. To deselect the paint object, 
press Enter (Mac) or Esc (Mac and Windows) again.

Paint Object Creator tool

Black & White
Grayscale

✓ RGB Color
CMYK Color
Lab Color

✓ 72 PPI
300 PPI
1200 PPI
Custom...

Current mode and resolution 
appear checked in the Paint 
Object Creator pop-up menu.

Drag the Paint Object Creator 
tool to create a new paint 
object.

New paint object 
in edit mode, 
indicated by crop 
marks (circled) at 
each corner.
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Using the Create command
You can create a paint object and fill the image with a background 
color by using the Create command.

1 Make sure that no objects are selected; you can press Enter 
(Mac) or Esc (Windows) three times to deselect all objects.

2 Choose Area➤Create in the Image menu. In the Create Image 
dialog box, choose an image mode in the Mode pop-up menu. For 
more information, see “Image modes for Canvas paint objects,” 
page 328.

3 Choose a background color for the image area in the Back-
ground pop-up color palette. The default color is white; you can 
choose a preset color or custom color; see “Creating custom colors 
in pop-up palettes” on page 136.

4 Type the width, height, and resolution for the image in the text 
boxes. Select the units of measurement for these settings in the pop-
up menus adjacent to the text boxes.

5 Click Auto to let Canvas determine the optimal resolution for 
an image based on the halftone screen to be used for printing the 
image. Clicking Auto opens the Auto Resolution dialog box; see 
“Changing image resolution” on page 345 for details.

6 Click OK to create the paint object.

Creating images from objects and text
In Canvas, you can render vector objects and text into pixels in two 
ways: you can copy the objects or text to the Clipboard, place a paint 
object in edit mode, then paste the Clipboard contents; or you can 
select objects and choose Area ➤Render in the Image menu to raster-
ize the objects.
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◆ To use the Render command: Select the objects you want to 
rasterize and choose Area➤Render in the Image menu. Configure the 
options (see “Render Image Options,” next) and click OK. Canvas 
creates an image of the objects and places it in front of the objects.

Render Image options

In the Render Image dialog 
box, you can set the following 
options when creating images:

A Dimensions. Displays the 
width and height of the paint 
object Canvas will create. 

B Choose the unit of measure-
ment for the Width and Height 
values in the Dimensions area: 
inches, centimeters (cm), points, 
or picas.

C Mode. Choose the color 
mode for the resulting image. 
Choose Black & White, Gray-
scale, Indexed Color, RGB Col-
or, CMYK Color, or LAB Color.

D Set the dimensions and res-
olution in the text boxes. When 
you change a value, Canvas ad-
justs the others to maintain the 
size and proportions of the orig-
inal objects. For resolution, 

choose pixels per inch or pix-
els per centimeter in the 
pop-up menu. The value 
next to “Size” is the amount 
of data in the image.

E Anti-Alias. Turn on this 
option to soften the edges 
of the rendered objects.

F Create Mask. Turn on 
this option to generate a 
special image channel, 
based on a silhouette of the 
rendered objects.

Because paint objects are 
always rectangular, when you 
render a non-rectangular 
shape, such as the letter “O,”, 
Canvas adds white pixels to 
the center and around the 
edges to make the paint object 
rectangular; these pixels are 
opaque, and obscure objects 
behind them. Create Mask 
generates a channel that 

“masks,” or hides, the extra 
white pixels added by Canvas, 
so you can see objects behind 
them.

For more information on chan-
nel masks, see “Using a chan-
nel mask to make areas trans-
parent,” page 365.

E

C

D

B

F

A
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Using painting tools
You can use the following procedure with most painting tools. With 
some tools, you can adjust opacity, pressure, exposure, or glow set-
tings. See the specific tool entries in this chapter for details.

1 To place a paint object in edit mode so you can paint in the 
image, double-click the object with a Selection tool. You can also 
click the object with a painting tool; the pointer becomes a hand 
( ) when you point to a paint object with a painting tool.

2 Select foreground and background colors by pressing the cor-
responding color icons in the toolbox. The “Painting tool options” 
table on page 310 shows which tools paint with foreground and 
background colors.

3 Select a brush shape and a transfer mode in the Brushes palette; 
see “Selecting brush shapes and transfer modes” on page 312.

4 Click or drag the tool in the image to apply the paint color.

Foreground color icon

Background color icon

Brushes palette icon

Using the Painting Tools 
toolbar

The Painting Tools toolbar 
opens from the icon at the 
top-right of the toolbox. The 
last tool you used appears 
there; to select that tool 
again, click its icon. To select 
a different tool, press the icon 
to open the toolbar and drag 
to the tool you want. 

You can also drag the toolbar 
away from the toolbox to 
keep it open as a floating pal-
ette.

A double arrow symbol in a 
tool icon indicates that you 
can double-click the tool to 
open a dialog box of options.

A B KIHGFEDC

USRQPONML

J

T

A Paint Object Creator
B Crop
C Wand
D Marquee
E Lasso
F Remote Move
G Pencil
H Eraser
I Marker
J Paintbrush
K Airbrush 

L Neon
M Bucket
N Blend
O Blur
P Sharpen
Q Rubber Stamp
R Smudge
S Dodge 
T Burn
U Sponge
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Painting tool options

A ✔ indicates than an option is available for the tool shown in the first column. For example, the Eraser tool 
uses options in the Brushes palette and paints with the background color. When a paint object is in edit 
mode, you can press the keyboard keys shown in the “Quick key” column to select painting tools.

Tool 
icon

Tool
name

Quick 
key

Options 
dialog box

Brushes palette
options

Foreground
color

Background
color

Tablet
options

Crop

Wand W ✔

Lasso L ✔ ✔

Marquee M

Pencil P ✔ ✔

Eraser E ✔ ✔

Marker H ✔ ✔ ✔ ✔

Paintbrush B ✔ ✔ ✔ ✔

Airbrush A ✔ ✔ ✔ ✔

Neon ✔ ✔ ✔ ✔ ✔

Bucket K ✔ ✔ ✔

Blend G ✔ ✔ ✔ ✔

Rubber 
Stamp

S ✔ ✔ ✔

Smudge U ✔ ✔ ✔ ✔

Blur F ✔ ✔ ✔

Sharpen R ✔ ✔ ✔

Dodge O ✔ ✔ ✔

Burn N ✔ ✔ ✔

Sponge D ✔ ✔ ✔

Remote 
Move

V
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Selecting colors for painting
Painting tools use the foreground or the background color, or both. In 
stead of pen and fill ink icons, two brush color icons appear in the 
toolbox when you select a painting tool. The top icon shows the fore-
ground color and the bottom icon shows the background color.

You can use any solid color for painting. However, you can’t paint 
with multi-colored inks, such as gradients, symbols, textures, or 
hatch inks. For example, if the current pen and fill inks (for objects 
and text) are gradients, when you edit an image, the foreground color 
is black and the background color is white.

Also, if you choose a spot color and edit pixels with a painting tool, 
Canvas converts the spot color to the image color mode (RGB, 
CMYK, and so on); see “Image modes for Canvas paint objects” on 
page 328. You can arrange paint objects in a document with vector 
and text objects that use spot colors, but only the vector and text 
objects will produce spot color separations.

◆ To select a color for painting: Press the foreground or back-
ground color icon in the toolbox to open the Inks palette; choose a 
color on the Color tab. If you tear the Inks palette away from the tool-
box, it becomes a floating palette you can keep open as you work. 
When the palette is floating, you can select colors by clicking color 
tiles in the Color tab. You can also create new colors in the Color 
manager. See “Creating color inks” on page 134.

You can quickly switch the foreground and background painting col-
ors by pressing “x” when a paint object is in edit mode. To restore the 
foreground color to black and the background color to white, press 
the single open quote key (‘) on the keyboard.

Picking colors from images and objects

You can use the Color Dropper tool to pick up color from an image 
or object. The color you select becomes the current background or 
foreground color that you can use for painting.

◆ To select the background color: Select the Color Dropper tool 
in the Effects Tools toolbar in the toolbox and click a color in an 
object or image.

Palette icons for object and 
text tools (left) and the palette 
icons when a painting tool is 
selected (right)

 Color Dropper tool
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◆ To select the foreground color: Select the Color Dropper tool 
in the Effects Tools toolbar and Option-click (Mac) or right-button 
click (Windows) a color in an object or image. 

Note: When a paint object is in edit mode and you change the fore-
ground or background color, the color you select stays in effect, 
becoming the current color for subsequent drawing and painting. 

Selecting brush shapes and transfer modes
The Brushes palette is the control center for all aspects of brush shape 
and mode. The palette contains preset brush shapes and also offers 
options, such as opacity, for some painting tools.

◆ To select a preset brush: With a painting tool selected, press 
the Brushes palette icon and drag to the brush shape you want. If the 
Brushes palette is open, click a brush in the palette to select it.

To keep the palette open while you work, drag it away from the tool-
box and it becomes a floating palette. The palette must be floating for 
you to adjust paint tool options and select transfer modes.

✔Tip
You can quickly select the Col-
or Dropper tool when you have 
a painting tool selected that 
uses the foreground or back-
ground colors. Pressing 
Option (Mac) or Alt (Windows) 
temporarily selects the Color 
Dropper tool.

The Brushes palette icon shows 
the current brush. Press the icon 
and drag into the palette to 
select a brush shape.

Drag the palette away from the 
toolbox to make it a floating palette.
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Brushes palette painting options

You can change some brush options using controls under the brush 
shapes in the Brushes palette. The palette must be floating for you to 
use these controls. 

For many painting tools, you can set the transparency level of the 
paint color using the Opacity slider. At 100% opacity, the paint color 
completely replaces the original image color. 

Some tools, including the Airbrush and Smudge tools, let you adjust 
a pressure, exposure, or glow setting. To increase the rate at which 
the Airbrush applies color, increase the pressure setting. By increas-
ing the pressure setting, you can also increase the effect of the 
Smudge tool. 

See the individual tool descriptions for other Brushes palette options.

Using transfer modes with painting tools

You can select transfer modes in the in the Brushes palette pop-up 
menu. Painting tools apply color using the transfer mode you select. 

Normal Paints color to every pixel the brush touches. 100% opacity 
replaces the original color.

Dissolve Applies color randomly within the brush shape, creating a 
spotted effect. To work properly, opacity must be set to less than 
100%.

Multiply Darkens pixels the brush touches. Paint with darker col-
ors to increase the effect. Painting with black results in black; paint-
ing with white does not affect the original image.

Screen Lightens pixels the brush touches. Paint with lighter colors 
to increase the effect. Painting with black does not affect the original 
image; painting with white results in white.

Overlay Paints color without destroying the highlights or shadows 
of the original image.

Soft Light Lightens or darkens pixels depending on the applied 
color’s brightness value. If it is less than 50%, the brush lightens pix-
els. If greater than 50%, the pixels are darkened. 

Hard Light Lightens or darkens pixels depending on the applied 
color’s brightness. It is similar to Soft Light. However, painting with 
black produces black; painting with white produces white.

Darken Applies color if it is darker than the original color. 

✔Tip
To quickly change the slider 
setting in the Brushes palette, 
you can press a number key; 
“1” sets the slider to 10%, “2” 
to 20%, and so on. “0” equals 
a setting of 100%.
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Lighten Applies color if it is lighter than the original color.

Difference Compares the brightness of the original and applied 
colors, subtracts the brightness value of the darker pixel from the 
lighter one, and applies that value to the original image.

Hue Changes the hue of the original color to the hue of the applied 
color without changing the saturation or luminance values.

Saturation Changes the saturation of the original color to the satu-
ration of the applied color, without changing the hue or luminance 
values. Applying gray does not affect the original image.

Color Changes the hue and saturation of the original color to the 
hue and saturation of the applied color, without affecting the shadow, 
highlights, or midtones of the original image.

Luminosity Changes the lightness of the original color to the light-
ness of the applied color, without affecting the hue or saturation.

Painting individual pixels with the Pencil

You can use the Pencil tool to apply the foreground color to a single 
pixel or create a one-pixel, freehand line. If the pixel already uses the 
foreground color, the Pencil applies the background color instead. 
You can use the Pencil tool for precise image editing at high magnifi-
cations. See “Using painting tools” on page 309.

◆ To paint a straight line: Shift -drag the Pencil to confine the 
line to 90 degree angles. 

Painting in the background color with the Eraser

You can paint with the background color using the Eraser tool. Fol-
low the procedure “Using painting tools” on page 309. 

Note: Opacity and transfer mode options are not available with the 
Eraser.

Pencil tool

Eraser tool
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Painting hard-edged strokes with the Marker

The Marker tool paints with the foreground color, applying a hard-
edged stroke. 

1 To configure the Marker tool, double-click the tool to open its 
dialog box. 

2 Select the options you want to use in the Fade area. In the 
“Fade within” text box, enter the distance in which Canvas will 
complete the fade.

• To fade the brush size, choose Size.

• To fade the color to transparent, choose Opacity.

3 To make a pressure-sensitive stylus affect the marker size or 
opacity, turn on these options under “Pressure Varies.”

4 Click OK and use the procedure “Using painting tools” on 
page 309.

Painting soft-edged strokes with the Paintbrush

The Paintbrush tool applies the foreground color. You can apply a 
soft (anti-aliased) brush stroke by choosing a soft-edged brush in the 
Brushes palette. 

1 To configure the Paintbrush tool, double-click the tool to open 
its dialog box.

2 Select the options you want to use in the Fade area. In the 
“Fade within” text box, enter the distance in which Canvas will 
complete the fade.

• To fade the brush size, choose Size.

• To fade the color to transparent, choose Opacity.

3 To make a pressure-sensitive stylus affect the paintbrush size 
or opacity, turn on these options under “Pressure Varies.”

4 Click OK and use the procedure “Using painting tools” on 
page 309.

Marker tool

Paintbrush tool
Using painting tools 315



31
Spraying soft strokes with the Airbrush

Using the Airbrush tool, you can apply the foreground color with a 
very soft (anti-aliased) stroke. The Airbrush tool paints as long as 
you press the mouse button. The Pressure setting in the Brushes pal-
ette controls how fast the Airbrush applies color. 

1 To configure the Airbrush tool, double-click the tool to open 
its dialog box. 

2 Select the options you want to use in the Fade area. In the 
“Fade within” text box, enter the distance in which Canvas will 
complete the fade.

• To fade the airbrush size, choose Size.

• To fade the amount of color applied, choose Pressure.

3 To make a pressure-sensitive stylus affect the airbrush size or 
pressure, turn on these options under “Pressure Varies.”

4 Click OK and use the procedure “Using painting tools” on 
page 309.

Coloring areas with the Bucket

You can use the Bucket tool to pour color on an image. The Bucket 
applies the foreground color where you click. You can adjust its tol-
erance so the color covers adjacent pixels of the same color only, or 
adjacent pixels of similar colors.

1 To configure the Bucket tool, double-click the tool. In the 
Bucket dialog box, adjust the settings as needed.

• To affect only identically-colored pixels, type 0 in the Tol-
erance text box. Type a larger number to affect more pixels.

• To soften the edge of the filled area, turn on Anti-Aliased.

2 Click OK and use the procedure “Using painting tools” on 
page 309.

Airbrush tool

Bucket tool
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Painting color gradients with the Blend tool

You can paint a blend of colors with the Blend tool. By default, drag-
ging the Blend tool in an image paints a blend from the foreground 
color to the background color. 

The Blend tool is very useful for creating blends from black to white 
in channels, to make selection masks that fade gradually from full 
selection to no selection. 

1 To configure the Blend tool, double-click the tool to open its 
dialog box. For more information, see “Blend options” on 
page 317. 

2 Set the transfer mode and opacity in the Brushes palette; see 
“Selecting brush shapes and transfer modes” on page 312.

3 Put the image in edit mode, if necessary. Then, select the Blend 
tool and drag to apply the blend, depending on the style selected:

• For linear blends, drag in the direction of the blend. Shift-
drag to confine the blend’s direction to a 90- or 45-degree 
angle. Canvas fills the remaining area (if any) with the fore-
ground color and background color.

• For radial blends, drag from the center of the blend. 

Blend tool

Linear blend Radial blend

Blend options

Style. Choose radial or linear. 

Offset. For Radial style, enter 
a value to set the percentage 
of starting color in the blend. 
To use more of the starting 
color in the blend, enter a 
number from 50 to 100.

Skew. To set the midpoint 
between blend colors, enter a 
number from 13 to 87. The 
default is 50.

Behavior. Choose a blending 
method. Foreground and 
Background refer to the cur-
rent colors in the toolbox. 
Transparent options fade from 

the foreground color to trans-
parency. Spectrum blends cre-
ate rainbow blends in a clock-
wise or counter-clockwise 
direction around the color 
wheel.

A Example of a blend used to 
vignette a photograph. The fol-

lowing Blend options were 
used:

Radial-style blend
Behavior = Transparent to 
Foreground
(Foreground color white)
Offset = 10
Skew = 70

Original A
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Painting two-toned “neon” strokes 

 You can paint a neon-tube stroke, with the foreground color inside 
and the background color outside, with the Neon tool. Use the Glow 
setting in the Brushes palette to adjust the color ratio. Transfer modes 
aren’t available with the Neon tool. 

If you are using a pressure-sensitive tablet, double-click the Neon 
tool to open its dialog box. You can make the stylus pressure affect 
brush size by turning on the Size in the “Pressure Varies” area and 
clicking OK. 

To paint with the Neon tool, follow the basic procedure in “Using 
painting tools” on page 309.

Editing images with painting tools
In addition to applying color to images with paintbrushes, you can 
use painting tools to alter pixels and retouch images. Canvas painting 
tools let you 

• “clone” areas within an image

• smudge parts of an image

• lighten and darken areas

• sharpen and blur areas

• saturate and desaturate colors in an image

This section provides detailed descriptions of how to use painting 
tools to perform these operations. You can also hide or remove 
unwanted areas of an image by cropping; see “Using the Crop tool to 
change image size” on page 343.

Copying areas with the Rubber Stamp tool
You can make a copy (“clone”) of an image area with the Rubber 
Stamp tool. This tool is very useful for retouching scanned photo-
graphs, removing lines and scratches, and hiding seams when com-
positing images.

Neon tool

Rubber Stamp tool
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1 To configure options for the Rubber Stamp tool, double-click 
the tool to open its dialog box. Adjust the settings and click OK.

• To fade the brush size or opacity of the cloned image, turn 
on the appropriate option in the Fade area and enter a num-
ber of pixels in the “Fade within” text box to tell Canvas the 
distance in which to complete the effect.

• Select an option in the Style pop-up menu; see “Choosing a 
cloning style” on page 319.

• With a pressure-sensitive tablet, you can make the stylus 
pressure affect size and opacity by turning on the appropri-
ate option in the “Pressure Varies” area.

2 Select the Rubber Stamp tool and click an image with the hand 
pointer ( ) to put it in edit mode, if necessary.

3 Choose a brush shape, transfer mode, and opacity setting in the 
Brushes palette; see “Selecting brush shapes and transfer modes” 
on page 312.

4 Option-click (Mac) or Ctrl-click (Windows) in the image to 
set the reference point for sampling an image area.

5 Drag in the image to paint a copy of the sampled area around 
the reference point. 

Choosing a cloning style

The effect of dragging the Rubber Stamp tool in an image depends on 
the option you choose in the Style pop-up menu of the dialog box.

Clone (aligned) The first time you drag the Rubber Stamp tool in 
the image after setting the reference point, Canvas establishes a fixed 
direction and distance from the reference point to the pointer. The 
Rubber Stamp tool copies any area of the image that is this distance 
and direction from the pointer.

Clone (non-aligned) Dragging the Rubber Stamp tool always 
begins copying the image from the same reference point.

Impressionist This option smears pixels to create an impressionistic 
effect. You don’t need to set a reference point to use this effect.

Rubber Stamp pointer 
with Option (Mac) or Ctrl 
(Windows) pressed

Rubber Stamp pointer 
without modifier key
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Smudging colors in an image
With the Smudge tool, you can pull color from one area of an image 
and drag it into adjacent areas. You can adjust the Pressure setting in 
the Brushes palette to control the distance that the tool smudges a 
color. 

1 Select the Dodge tool and click a paint object to put it in edit 
mode, if necessary.

2 To configure the Smudge tool, double-click the tool. In the dia-
log box, adjust the following settings and click OK.

• To gradually diminish the brush size as you drag, turn on 
Size; to reduce the smudge effect as you drag, turn on Pres-
sure in the Fade area. For both options, you can also type a 
number in the “Fade within” text box to set how quickly the 
effect fades.

• To smudge a little foreground color into the image, turn on 
the Finger Painting option.

• If you use a pressure-sensitive tablet and want stylus pres-
sure to affect size and pressure, turn on Size and Pressure in 
the Pressure Varies area.

3 Select a brush shape in the Brushes palette. For more informa-
tion, see “Selecting brush shapes and transfer modes” on page 312.

4 Adjust the Pressure setting in the Brushes palette. A setting of 
1 affects the image slightly; 85 drags the color through many pixels.

5 Drag the Smudge tool in the image area you want to edit.

Option-click (Mac) or 
Ctrl-click (Windows) 
to set the reference 
point for the area you 
want to clone

Original Clone (aligned)
25 subsequent drags 
with Rubber Stamp tool

Clone (non-aligned)
25 subsequent drags 
with Rubber Stamp tool

Smudge tool
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To lighten (‘dodge’) areas in an image
You can lighten specific areas of an image with the Dodge tool. 

1 Select the Dodge tool and click a paint object to put it in edit 
mode, if necessary.

2 To configure the Dodge tool, double-click the tool to open its 
dialog box. Type a number in the Distance text box to specify the 
length of the fading effect.

3 If you are using a pressure-sensitive tablet, you can make the 
stylus pressure affect size and exposure by turning on the appropri-
ate option in the “Pressure Varies” area.

4 After configuring the Dodge tool the way you want, click OK.

5 Choose a brush shape in the Brushes palette. For more infor-
mation, see “Selecting brush shapes and transfer modes” on 
page 312.

6 Adjust the Exposure setting in the Brushes palette. Increasing 
the Exposure increases the lightening effect of the tool. Decreasing 
the setting decreases the effect.

7 Choose Shadows, Midtones, or Highlights in the Mode pop-up 
menu. The Dodge tool lightens pixels that fall within the selected 
range only.

8 Drag the Dodge tool in the image area you want to edit.

To darken (‘burn’) areas in an image
You can darken specific areas of an image by dragging the Burn tool 
over the pixels you want to darken. The tool’s effect can be con-
trolled by your selection of brush and adjustment of the tool’s Fade 
setting. 

1 Select the Burn tool and click a paint object to put the image in 
edit mode, if necessary.

2 To configure the Burn tool, double-click the tool to open its dia-
log box. Type a number in the Distance text box to specify the length 
of the fading effect.

3 If you are using a pressure-sensitive tablet, you can make the 
stylus pressure affect size and exposure by turning on the appropri-
ate option in the “Pressure Varies” area.

4 After configuring the Burn tool the way you want, click OK.

Dodge tool

Burn tool
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5 Choose a brush shape in the Brushes palette. For more infor-
mation, see “Selecting brush shapes and transfer modes” on 
page 312.

6 Choose an Exposure setting in the Brushes palette. Increasing 
the Exposure setting increases the darkening effect of the tool. 
Decreasing the setting decreases the effect.

7 Choose Shadows, Midtones, or Highlights in the Mode pop-up 
menu. The Burn tool darkens pixels that fall within the selected 
range only.

8 Drag the Burn tool in the image area you want to edit. 

To blur areas in an image
You can soften specific areas in an image with the Blur tool. The 
Blur tool decreases the contrast between pixels the tool drags over.

1 Select the Blur tool and click a paint object to put the image in 
edit mode, if necessary.

2 To configure the Blur tool, double-click the tool. In the dialog 
box, adjust the following settings and click OK.

• To gradually diminish the brush size as you drag, turn on 
Size; to reduce the blur effect as you drag, turn on Pressure 
in the Fade area. For both options, you can also type a num-
ber in the “Fade within” text box to set how quickly the 
effect fades.

• If you use a pressure-sensitive tablet and want stylus pres-
sure to change size and pressure, turn on Size and Pressure 
in the Pressure Varies area.

3 Select a brush shape in the Brushes palette. For more informa-
tion, see “Selecting brush shapes and transfer modes” on page 312.

4 Adjust the Pressure setting in the Brushes palette. A setting of 
1 affects the image slightly; 85 softens the image greatly.

5 Drag the Blur tool in the image area you want to edit. Canvas 
applies the effect to pixels touched by the pointed tip of the tool.

Blur tool
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To sharpen areas in an image
You can increase the contrast between specific pixels in an image 
with the Sharpen tool. 

1 Select the Sharpen tool and click a paint object to put the image 
in edit mode, if necessary.

2 To configure the Sharpen tool, double-click the tool. In the dia-
log box, adjust the following settings and click OK.

• To gradually diminish the brush size as you drag, turn on 
Size; to reduce the sharpening effect as you drag, turn on 
Pressure in the Fade area. For both options, you can also 
type a number in the “Fade within” text box to set how 
quickly the effect fades.

• If you use a pressure-sensitive tablet and want stylus pres-
sure to affect size and pressure, turn on Size and Pressure in 
the Pressure Varies area.

3 Select a brush shape in the Brushes palette. For more informa-
tion, see “Selecting brush shapes and transfer modes” on page 312.

4 Adjust the Pressure setting in the Brushes palette. A setting of 
1 affects the image slightly; 85 dramatically sharpens the image.

5 Drag the Sharpen tool in the image area you want to edit. Can-
vas applies the sharpening effect to pixels touched by the pointed 
tip of the tool.

Saturating and desaturating colors
With the Sponge tool, you can add or remove gray content from spe-
cific areas of an image. 

1 Select the Sponge tool and click a paint object to put the image 
in edit mode, if necessary.

2 To configure the Sponge tool, double-click the tool to open its 
dialog box. 

• Type a number in the Distance text box to specify the length 
of the Sponge tool’s fading effect.

• If you are using a pressure-sensitive tablet, you can make 
the stylus pressure affect size and exposure by turning on 
the appropriate option in the “Pressure Varies” area.

3 After configuring the Sponge tool the way you want, click OK.

Sharpen tool

Sponge tool
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4 Choose a brush shape in the Brushes palette. For more infor-
mation, see “Selecting brush shapes and transfer modes” on 
page 312.

5 Adjust the Pressure setting in the Brushes palette. Increase the 
pressure to increase the effect.

6 Choose Saturate or Desaturate in the Mode pop-up menu. Satu-
rate removes gray; desaturate increases the amount of gray.

7 Choose a brush shape in the Brushes palette. See “Selecting 
brush shapes and transfer modes” on page 312.

8 Drag the Sponge tool over the image area you want to edit.

Customizing brushes for painting tools
You can use the Brushes palette to create brushes, save brushes in 
files on disk, modify existing brushes, and delete unwanted brushes.

You can add custom brushes to the list of preset brushes in the pal-
ette. When you exit Canvas, it stores the brush presets. The same set 
of brushes are available whether you work with new documents, doc-
uments you created, or documents created by another Canvas user.

To create a new brush

1 Press the right-arrow button in the Brushes palette and choose 
New Brush in the pop-up menu. 

2 In the New Brush dialog box, adjust the settings for the brush. 
For more information, see “New brush options,” page 325.

3 After entering the settings you want, click OK. The new brush 
shape appears in the Brushes palette.

To delete brushes from the palette

You can permanently remove brush shapes from the Brushes palette. 
If you think you might want to use the brush shape again, you should 
first store it in a brushes file so you can later load it back into the pal-
ette. See “Saving and loading brushes,” page 326.

◆ To delete a brush: Select the brush you want to delete. Choose 
Delete Brush in the Brushes palette pop-up menu, or Command-click 
(Mac) or Alt-click (Windows) a brush in the palette to delete it.

Brushes 
palette 
pop-up 
menu

New brushes appear in the 
Brushes palette
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Using a selection to define a brush shape

You can make a new brush shape from a selection in an image. This 
lets you create non-elliptical brush shapes.

1 Select all or part of an image; “Selecting pixels in images,” 
page 353. 

2 Choose Define Brush in the Brushes palette pop-up menu. The 
selection becomes a brush in the Brushes palette. Canvas uses the 
shape and lightness values of the selection to define the brush. 
Brush shapes do not contain color.

Modifying brush shapes
You can edit any brush shape. For brush shapes created from selec-
tions, you can change only the spacing.

1 In the Brushes palette, double-click the brush shape you want 
to modify.

2 In the Brush Options dialog box, adjust the settings you want 
and click OK; see “New brush options,” next.

You can select image areas to 
make brushes. This image 
contains rendered vector objects.

New brush options

You create brush shapes by 
specifying diameter, hardness, 
spacing, roundness and angle. 
These same options are avail-
able in the Brush Options dia-
log box.

Diameter. Enter the diameter 
in pixels of the new brush.

Hardness. Enter a percentage 
to tell Canvas how much of the 
brush shape is solid. 

Spacing. This percentage sets 
the amount of brush overlap 

when you drag a painting tool. 
Turn off Spacing to make the 
brush velocity-sensitive, so it 
skips pixels when dragged 
fast. 

Roundness. Enter 1 to 100. To 
create a circle, enter 100.

Angle. Enter a number to 
rotate the brush shape.

A Drag to change Roundness.
B Drag to change the Angle.
C Preview of the brush shape.

A B C
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Saving and loading brushes
You can save brushes in a file, and load brushes from a saved file into 
the Brushes palette. Saving brushes to disk lets you customize the 
Brushes palette for particular projects or exchange brushes with other 
Canvas users. The file format that Canvas uses to save brushes on 
disk is also compatible with the file format used by the Photoshop 
image-editing program for saving brushes.

To save brushes in a file

1 In the Brushes palette, add or remove brushes until you have 
the collection you want to save.

2 Choose Save Brushes in the Brushes palette pop-up menu. 

3 In the directory dialog box, type a name for the brushes file, 
select a location, and click Save (Mac) or OK (Windows).

To load brushes from a file

When you load brushes, you can replace the current set of brushes 
with the contents of the file, or add the brushes to those in the palette.

1 In the Brushes palette, choose one of the following commands 
in the pop-up menu:

• To replace the current brushes with those in the brushes file, 
choose Load Brushes.

• To add the presets in the brushes file to those currently in 
the palette, choose Append Brushes.

2 In the directory dialog box, locate the brushes file you want to 
open and click Open (Mac) or OK (Windows).
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Using vector and text tools in paint objects
After placing a paint object in edit mode, you can use vector tools 
and the Text tool to add shapes and type to an image. 

When you draw or type text within a paint object in edit mode, Can-
vas rasterizes the objects according to the image mode and resolution 
of the paint object, and makes a floating selection in the image. 

When you type within a paint object in edit mode, you can modify 
the font, size, and style of the type before Canvas rasterizes it. For 
more information, see “To set type within images” on page 328.

To set anti-aliasing for objects placed in images

You can set a preference so Canvas softens the edges of objects you 
draw in an image or paste into an image from the Clipboard. 

1 Choose Preferences in the File menu and click the Painting tab 
in the Preferences dialog box.

2 Set the preferences you want to apply to objects placed in 
images and click OK.

• To soften selections pasted from the Clipboard, turn on 
“Anti-Aliased Clipboard.” 

• To soften objects or type created in paint objects in edit 
mode, turn on “Anti-Aliased Canvas Objects.”

For more information, see “Painting preferences” on page 88.

To draw objects within images 

You can use any of the drawing tools in a paint object in edit mode to 
“paint” shapes. When you finish drawing the shape, Canvas raster-
izes the vectors, based on its shape and colors.

1 Double-click the paint object with the Selection tool to put it in 
edit mode, if necessary, and select a drawing tool.

2 Select ink and stroke settings. For more information, see “Inks: 
colors and patterns” on page 127 and “Strokes: outline effects” on 
page 145.

3 Drag the selected tool to draw within the paint object. For more 
information, see “Drawing basics” on page 165. The object you 
draw becomes a floating selection and you can change its opacity, 
set the transfer mode, or apply filters; see “Changing the opacity of 
floating selections” on page 360 and “Image filters and effects” on 
page 389.
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4 When you finish editing the selection, press Enter (Mac) or Esc 
(Mac or Windows) to make the selection part of the image. Press 
Enter (Mac) or Esc (Mac or Windows) again to deselect the area.

To set type within images

You can type text within a paint object in edit mode and then modify 
the attributes before Canvas converts the type to a floating selection.

1 Double-click the paint object with the Selection tool to put it in 
edit mode, if necessary, and select the Text tool in the toolbox.

2 Click the I-beam pointer in the image and type the text, which 
appears in a white box. 

• You can use the Text menu, Type palette, or Text Ruler to 
set typographic attributes.

3 Press Enter (Mac) or Esc (Windows) to make the type a float-
ing selection. 

• You can change the opacity, set the transfer mode, and 
apply filters to the selection; see “Changing the opacity of 
floating selections” on page 360 and “Image filters and 
effects” on page 389.

4 When you finish, press Enter (Mac) or Esc (Windows) to make 
the type selection part of the image. Press Enter (Mac) or Esc (Mac 
or Windows) again to deselect the area.

Image modes for Canvas paint objects
In Canvas, image modes define the color model and the number of 
colors that can be used in images. When you create a new paint 
object in Canvas, you can assign an image mode. When you select a 
paint object, Canvas displays the image mode in the information area 
at the right end of the status bar.
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How image modes affect image filters

Filters produce different results depending on the image mode. When 
you paint, the opacity setting of a brush acts differently on images in 
different modes. For the most predictable results with filters and 
paint tools, use the RGB Color mode. 

How Canvas assigns image modes

When you import an image from another source, either by opening 
an image file or by pasting an image from another program, Canvas 
assigns an image mode based on the number of colors and the color 
model used in the image. 

The following table shows the image modes that Canvas assigns 
when you import images in some common image formats.

Imported format Assigned image mode

TIFF RGB Color, CMYK Color, or Grayscale

BMP 256-color image: Indexed
24-bit image: RGB Color

MacPaint Black & White

Photoshop Same as original image mode

Posterizing a LAB image 
introduces color to light areas.

RGB image 
posterized 4 levels

Original LAB image 
posterized 4 levels
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Changing image modes 

You can change the mode of an image in Canvas. For example, you 
might want to change an RGB image to Indexed mode to reduce file 
size. You might also want to create a special effect by converting a 
Grayscale image to Duotone mode. 

◆ To change image mode: With the paint object selected (but not 
in edit mode), choose a mode in the Mode submenu in the Image 
menu. Choosing Duotone or Indexed mode opens a dialog box to let 
you specify colors; see the mode descriptions for more information.

Note: Only Grayscale images can be converted to Black & White or 
Duotone modes.

Black & White image mode
Black & White mode is appropriate for scanned line art and other 
“bitmap” images, in which pixels are only black or white. Black & 
White mode does not support shades of gray or anti-aliasing effects, 
and opacity controls aren’t available. Images in Black & White 
mode require the least amount of memory and disk space.

To convert a color image to Black & White, you must first convert 
it to Grayscale.

Grayscale image mode
Grayscale mode is appropriate for images scanned from black and 
white photographs, or when the image will never be printed in color. 
In Grayscale mode, pixels use 256 brightness levels to represent a 
range of shades from pure black to pure white. Grayscale uses 8 bits 
per pixel and requires less memory than most color modes.

If you convert a color image to Grayscale mode, Canvas discards all 
color information.
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Indexed image mode
Indexed mode uses a palette of 256 colors. Because it stores fewer 
colors, it requires less memory than RGB Color mode; this 
attributes makes it especially useful for images to be used on web 
pages and distributed through the Internet. An Indexed mode image 
includes a color table, or palette, of the colors used in the image. 
When you convert an existing image to Indexed mode, you specify 
the number of colors and their hues for the image’s color table.

Most image filters, anti-aliasing effects, and opacity controls are 
not available for indexed mode, but some third-party plug-in filters, 
and the Offset and De-interlace filters in Canvas can be used. 

To convert an existing image to Indexed mode

1 Select an image with the Selection tool and choose 
Mode➤Indexed in the Image menu. 

2 In the Indexed Color dialog box, choose a method for comput-
ing the color table in the Palette area:

3 Depending on which method you selected above, the Colors 
area in the dialog box displays different information. For the Uni-
form method, you can specify the number of colors to include in the 
color table using the Colors pop-up menu. For the Adaptive 
method, Canvas suggests a number of colors in the text box; you 
can type a new value if you want.

Exact Creates a color table from the colors in the image, if 
the image contains 256 colors or less; otherwise, this 
option isn’t available

Uniform/
System

Creates a color table based on the operating sys-
tem’s palette of 256 colors (System), or a subset of 
these colors (Uniform)

Adaptive Creates a color table from the most frequently-used 
colors in the image

Custom Lets you create a color table or load a color palette 
from a file

Previous Uses the last color table created by the Indexed 
Color dialog box during the current Canvas session
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4 Choose a color-distribution option in the Dither area:

5 After choosing the settings you want, click OK.

Creating a color table

If you choose to create a custom color table for the indexed image, 
Canvas opens the Color Table dialog box after you close the Indexed 
Color dialog box. In the dialog box is a 256-tile grid; each tile repre-
sents one color that is available for an indexed color image. The 
Table pop-up menu has a Custom option and four preset tables that 
you can use to start building a custom color table.

• Grayscale is a ramp from pure black to pure white

• Black Body is a range of sunset-like colors

• Spectrum is a set of rainbow colors

• System is the 256 standard colors of your operating system

◆ To customize a color table: Click a tile to open a color picker 
dialog box. Specify the color you want to add the table and click OK.

◆ To add a range of colors to a color table: You can blend two 
colors to fill the tiles in the color table. Drag across multiple tiles to 
select them (the more you select, the more gradual the blend will be). 
The color picker dialog box opens. Choose the first color and click 
OK. The color picker remains open; choose the second color and 
click OK. Canvas fills the selected tiles with a ramp of the two colors.

RGB Color image mode
RGB Color mode is used most often when working with high-quality 
full-color images, such as those from color scanners and digitized 
photographs stored on CD-ROM.

RGB Color mode is the most reliable mode to use for images you 
want to modify with painting tools and filters. However, the full 
range of RGB colors exceeds the range that commercial printing can 
reproduce, so you should be aware of the limitations of the printing 

None Changes colors to their closest equivalent in the 
selected color table without dithering

Pattern Estimates colors not in the palette by arranging pal-
ette color in geometric patterns (available for Uni-
form/System method only)

Diffusion Estimates non-palette colors by randomly dithering 
available colors; creates the most natural effect
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method that will be used. Also, an RGB Color image is device depen-
dent, which means that the same RGB values can look different when 
displayed on different monitors.

In RGB Color mode, each pixel has a red, green, and blue compo-
nent. Each component, referred to as a color channel, has 256 inten-
sity levels. The combination of the intensity value in each channel 
creates each pixel’s color.

CMYK Color image mode
CMYK Color mode is based on the four color inks used in commer-
cial printing (and by some desktop printers): cyan, magenta, yellow, 
and black. Some color scanners can produce CMYK images. 

In a CMYK Color image, each pixel has a cyan, magenta, yellow, 
and black component. Each of these color channels has 256 intensity 
levels. The combination of the intensity value in each channel creates 
each pixel’s color. Because monitors are RGB devices, they can’t 
display CMYK colors directly. However, Canvas attempts to display 
CMYK images as they will appear when printed. 

LAB Color image mode
The Commission Internationale d’Eclairage (CIE) developed the 
LAB Color mode as an international color standard to overcome the 
device dependency of the RGB and CMYK modes. In a LAB Color 
mode image in Canvas, each pixel has one lightness and two color 
components. The Lightness (L) channel has 256 levels of intensity. 
The two color channels, labeled A and B, provide a color range from 
red to green and yellow to blue, respectively. 

Some companies sell collections of images in LAB Color mode. 
Editing LAB Color mode images with some filters or painting tools 
can have interesting and unpredictable effects. 

Duotone image mode
In traditional graphics arts reproduction, a “duotone” is a grayscale 
image printed with black and an additional color. Canvas lets you 
create duotone images, as well as “monotone,” “tritone,” and “quad-
tone” images (printed with one, three, or four colors, respectively).
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Printing images as duotones can add interest and increase the tonal 
range reproduced from grayscale photographs, without the additional 
expense of printing full-color images. The duotone effect can be sub-
tle or striking, depending on the color used and the amount added to 
the image. In any case, the additional colors are used to reproduce the 
gray values in the image, rather than to reproduce specific colors.

To create a monotone, duotone, tritone, or quadtone in Canvas, you 
must convert a Grayscale image to Duotone mode. Unlike other 
image modes, once an image is converted to Duotone mode, you can-
not work with individual image channels. Instead, you can adjust 
curves for each color “channel” in the Duotone Options dialog box.

Note: In this section, the term “Duotone” refers to the Duotone image 
mode, not just to images printed with two inks. In Duotone mode, an 
image can be printed as a monotone, duotone, tritone, or quadtone.

To create a Duotone image

1 Select a paint object (with nothing selected in the image) and 
choose Mode➤ Grayscale in the Image menu to convert to Gray-
scale mode. Click OK when Canvas asks to discard color informa-
tion. Then choose Mode➤ Duotone in the Image menu. 

2 In the Duotone Options dialog box, choose Monotone, Duo-
tone, Tritone, or Quadtone in the Type pop-up menu. Depending on 
the Type setting, the Ink 1, Ink 2, Ink 3, and Ink 4 Curve boxes, 
color pop-up menus, and text boxes become available.

3 Choose ink colors by pressing the color palette icons and 
selecting colors in the pop-up palettes. Note: You must have 
already added the desired colors to the preset colors on the Color 
tab in the Inks palette for them to be available in the pop-up palette.

• For a monotone image, choose a single color in the Ink 1 
area. For a traditional duotone, leave “Process Black” as Ink 
1, and choose a second color in the Ink 2 area. For tritones 
and quadtones, choose additional colors for Ink 3 and Ink 4.

• Canvas puts the name of a PANTONE ink in the text box. 

• To use process colors, type the appropriate name (“Process 
Cyan,” “Process Black,” “Process Magenta,” or “Process 
Yellow,”) so colors appear on the correct plates. If you 
leave the text box blank, Canvas prompts you to enter a 
name for the ink.

✔Tips
You should assign only solid 
spot colors (PANTONE inks) or 
individual process colors for 
duotones. If you assign a color 
ink made from CMYK compo-
nents (including a TruMatch 
color), Canvas treats it like a 
spot color and prints only one 
plate for the color when you 
output color separations.

If you plan to export a duotone 
image to another graphics or 
page layout program, be sure 
the color names exactly match 
the color names in the other 
application. Otherwise, you 
might produce more color sep-
arations than necessary.
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• You should specify ink colors in descending order of light-
ness value. In other words, darker color inks should appear 
at the top, and lighter color inks should appear at the bottom 
of the dialog box.

4 If necessary, click the curve boxes to adjust curves for each ink 
color. In the Duotone Curves dialog box, drag the curve to adjust it, 
or enter values in the text boxes to map input values to the desired 
output values, and then click OK.

5 Click OK to apply the Duotone Options dialog box settings.

Duotone Options

You can select and change 
the following ink settings for 
images in Duotone mode.

A Type. Choose Monotone, 
Duotone, Tritone, or Quad-
tone.

B Inks. Click the palette icons 
and select colors in the pop-up 
palettes for each ink. Type pro-
cess color names in the text 
boxes (PANTONE names ap-
pear automatically).

C Overprint Colors. Click to 
adjust the screen display of the 
Duotone inks. Because the ap-
pearance of spot-color combi-
nations can’t be predicted 
within Canvas, you can do this 
if you have an accurate printed 
reference for the colors you se-

lect. Overprint Colors settings 
do not affect color separations, 
but will change the appear-
ance of color composites print-
ed on desktop color printers. In 
the Overprint Colors dialog 
box, click the color squares to 

open a color selector dialog 
box. Choose the color you 
want to represent the ink com-
bination on screen and then 
click OK.

A

B

C
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Adjusting duotone images

After you convert an image to Duotone mode, you can reopen the 
Duotone Options dialog box to adjust the color curves, change ink 
colors, and use the Load and Save options.

◆ To change duotone options: Select the paint object you want 
to adjust and choose Mode➤Duotone Inks in the Image menu. Adjust 
the settings in the Duotone Options dialog box and click OK to 
implement the new settings.

Loading and saving duotone information

Use the Load and Save buttons in the Duotone Options dialog box to 
work with files of duotone options information. Canvas uses a file 
format compatible with the duotone options files used by the Photo-
shop image-editing program, so you can load files saved from Photo-
shop, and files saved by Canvas can be loaded into Photoshop.

• Click Save to save the duotone options settings. In the direc-
tory dialog box, type a file name and click OK or Save.

• Click Load to use settings from a saved duotone options 
file. In the directory dialog box, select a duotone options file 
and click Open. Canvas will apply the ink and curve settings 
saved in the file to the Duotone Options dialog box.

Multichannel image mode
Multichannel image mode lets you work with multiple channels of 
grayscale information for a grayscale image. In multichannel mode, 
each channel contains lightness values as in other image modes, but 
the values do not relate to color components. 

When you convert an image to Multichannel mode, the image data 
does not change. For example, if you convert an RGB Color mode 
image to Multichannel mode, the Red, Green, and Blue channels 
retain the same pixel information, but the channels no longer repre-
sent color pixels. The channels in Multichannel mode are labeled 
numerically (#1, #2, and so on) in the Image Channels palette.

The Multichannel mode is not available if you select a paint object 
containing an image in Black & White image mode.
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Using scanners to acquire
20

SCANNING, SIZING, AND TRACING 
IMAGES 

This chapter focuses on acquiring and sizing images. It explains how 
to scan images into Canvas documents, change the size and resolu-
tion of images, and auto-trace images to create vector objects from 
them. It also describes some basics techniques you can use to 
improve scanned images and photographs imported from Photo CDs.

Using scanners to acquire images 
You can scan images directly into Canvas documents using most 
types of desktop scanners. Canvas supports scanners that work with 
Photoshop-compatible plug-in acquire modules. It also lets you use 
scanning devices that are compatible with the TWAIN standard.

Using TWAIN-compatible scanners
Scanner manufacturers created the TWAIN interface to standardize 
interaction between scanners and computer software. Scanners that 
comply with the TWAIN standard provide a “source manager” file, 
which translates scanner information into data that Canvas can use. 
You must install the TWAIN scanner software on your system before 
you can select the scanner and scan images in Canvas.

If you aren’t sure whether a scanner is TWAIN-compatible, consult 
the scanner documentation or contact the manufacturer.

To select a TWAIN scanner

1 Choose Acquire➤TWAIN Select Source in the Image menu. 
In the Select Source dialog box, a scrolling list contains the names of 
all TWAIN scanners for which Canvas can locate a data source.

2 Select the scanner you want to use and click OK. The Select 
Source dialog box closes and the scanner you selected becomes the 
active scanner. 
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To acquire images using a TWAIN scanner

1 When you scan an image, it appears in the active Canvas docu-
ment. Open an existing document or choose the New command in 
the File menu to create a new document.

2 Choose Acquire➤TWAIN Acquire in the Image menu. A dia-
log box for the scanner you are using appears. Refer to the scanner’s 
user manual for information on scanner options. 

3 Select the options you want in the scanner dialog box.

• Click Prescan to view a preview of the image. You can ver-
ify that the image is aligned and completely visible and 
reposition it if necessary.

• Depending on the available options, you can adjust scaling 
and brightness of the image.

4 Click Scan to begin scanning. When the scanner finishes, the 
scanned image appears in the active Canvas document. 

Using scanners with plug-in acquire modules
Canvas is a plug-in host program, which means that you can use 
scanners that work with acquire modules that are Photoshop plug-in 
compatible. You first should install the acquire module for your scan-
ner so it is available to Canvas. Once Canvas recognizes an acquire 
module, its name appears in the Image➤Acquire submenu.

To locate the plug-ins folder for Canvas

Canvas looks for plug-ins, including acquire modules, in the Plug-Ins 
folder inside the Canvas Tools folder (Mac) or Tools folder (Win-
dows). To tell Canvas to look for plug-ins in a particular location, use 
the Plug-Ins button on the Painting tab in the Preferences dialog box. 

1 Choose Preferences in the File menu.

2 In the Preferences dialog box, click the Painting tab and then 
click the Plug-Ins button. 

3 In the directory dialog box, navigate to the folder where plug-
ins are stored on your hard disk. Click the button labeled Select 
“folder name” (Mac) or select a plug-in file and click Open (Win-
dows).

4 Click OK to close the Preferences dialog box.

5 Exit and then re-start Canvas to activate the plug-in modules.

On the Painting tab, click 
“Plug-ins...” to select a folder 
for plug-in acquire modules
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To acquire images using plug-ins

1 When you scan an image in Canvas, the image appears in the 
active Canvas document. Either open the document you want to 
use, or use the New command to create a new document.

2 Choose Acquire in the Image menu and select a plug-in 
acquire module in the Acquire submenu. 

Note: If you do not see your scanning device in the menu, make sure 
that its acquire module is in the correct folder; see “To locate the 
plug-ins folder for Canvas,” above.

3 After selecting a device, a dialog box with options for your scan-
ner appears. Refer to the scanner’s user manual for information on 
these options and information on using the scanner; some common 
settings are described below.

4 Adjust the settings in the scanner dialog box and click Scan. 

Scanning options

Plug-in acquire modules for 
scanners offer various 
options. Some standard 
scanning options are 
described here.

Scan Mode or Color Mode. 
Choose color, black and 
white, or grayscale. These 
options correspond to the 
RGB Color, Grayscale, and 
Black & White image modes 
in Canvas. 

Resolution. Specify the scan 
resolution in pixels (or dots) 
per inch. Scanning at higher 
resolution captures more 
image information and results 
in higher memory and disk 
storage requirements.

Scaling. Enter a scaling per-
centage to reduce or enlarge 
the image.

A Use the preview area to 
check the image and make sure 
the area you want to scan is po-
sitioned correctly. 

B Many scanners let you drag 
the corner of a scan rectangle to 
select the area that will be 
scanned. The selected area de-

termines the size of the image 
object in Canvas.

C Most scanners offer bright-
ness or exposure controls. Refer 
to the scanner documentation 
for more information on adjust-
ing exposure settings. 

C

B

A
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Deciding on a scanning resolution
Digital images are composed of square pixels, and pixel size is a 
major factor affecting image quality. The resolution of an image is 
expressed as the number of pixels in a linear inch (abbreviated ppi) or 
centimeter. Smaller pixels result in higher image resolution, which 
generally indicates better image quality. With scanned images, the 
resolution is also a measure of how much information has been cap-
tured from the original artwork.

At lower resolution, such as 75 ppi, lines, edges, and character shapes 
in an image can appear jagged (see “About digital images and resolu-
tion” on page 341). Scanning at higher resolution produces smoother 
images, which also require more memory and disk space.

Use the following questions to help you decide what resolution is 
appropriate for images you scan.

Are you scanning line art or text? Line art, such as pen and ink 
drawings, and high-contrast images with sharp edges or type, should 
be scanned at the highest resolution possible. Text scans that will be 
processed with character-recognition software should also be 
scanned at high resolution for accurate translation.

What halftone screen frequency will be used for printing? For 
continuous-tone images (photographs), a common rule of thumb is to 
scan at a resolution of 1.5 or 2 times the screen frequency. For exam-
ple, for offset printing on newsprint at a screen frequency of 85 lines 
per inch (lpi), an image should be scanned at 128 to 170 ppi. For 
images printed at 133 lpi, scanning resolution should be 200 to 266 
ppi. 

Talk with service bureaus and commercial printers about the screen 
frequency used for your projects. With this information, you can let 
Canvas calculate the optimal resolution for an image. See “Resam-
pling and sharpening images” on page 347.

Will the final image be smaller or larger than the original? If 
you need to enlarge the image, you should scan it at a higher resolu-
tion to retain the most information when you resize it. If you will 
reduce the size of the image, you can scan it at a lower resolution.

Note: Because resizing tends to blur an image, you can use the 
Unsharp Mask filter to sharpen it. For more information, see “Using 
filters to sharpen images” on page 384. 
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Changing image size 
In Canvas, you can resize images the same as other objects. By 
stretching or scaling an image, you can create interesting distortions. 
You might also want to resize an image to fit a particular layout.

Keep in mind that altering the size or resolution of an image often 
degrades the quality of the image. Canvas uses interpolation to try to 
maintain the quality of the image, but this method can’t compensate 
for drastic changes.

The best way to avoid image degradation is to avoid changing the 
image size or resolution. 

• If an image is too big for a particular layout, consider crop-
ping the image rather than resizing or scaling the entire 
image to fit. 

• If a photographic image requires higher resolution, try re-
scanning the original at a higher resolution, rather than 
increasing the resolution in Canvas.

If you resize, skew, or rotate a paint object, you can restore the origi-
nal shape and resolution by choosing the Remove Effects command 
in the Effects menu.

Stretching images with the mouse

You can change the size of an image object by clicking it with the 
filled arrow Selection tool and dragging a selection handle. Stretch-
ing an image non-proportionately also stretches the pixels, which can 
cause unwanted distortion to the image. 

About digital images and resolution

Digital images, also known as 
raster and paint images, are 
composed of tiny square pix-
els. 

The number of pixels that fit in 
a linear inch or centimeter is 
the image resolution. The reso-
lution indicates how much 
information is in the image, 
independent of the resolution 

used to display the image on 
screen or to print it.

Low-resolution images have 
larger pixels and look more 
jagged than high-resolution 
images. However, while high-
resolution images look 
smoother, they also require 
more memory and disk space.

Vector 72 ppi

300 ppi 600 ppi
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Scaling images using the Scale command

You can also change the size of an image object by selecting it and 
choosing Scale in the Object menu. This can also stretch the image 
non-proportionately and cause unwanted degradation of the image.

Note: Using the Scale command on an image does not add or remove 
pixels from the original image.

Using the Crop command to change image size
You can adjust the overall size of an image using the Crop command.

• When you enlarge an image, Canvas adds white pixels. 

• When you reduce an image, Canvas crops out pixels and 
discards the image data.

1 Select a paint object (not in edit mode) and choose Area➤Crop 
in the Image menu. A dialog box displays the current size, width, 
and height.

2 Under New Size, enter the size you want the image to be. You 
can use percent, pixel, inch, centimeter, point, or pica values.

3 To set the position of the resulting image, click a square in the 
Placement grid. For example, to crop the image from the right side 
and bottom, click the upper-left square in the Placement grid. To 
expand the image on all sides, click the center square.

4 Click OK to resize the image. If you are reducing the image 
area, Canvas warns you it will delete pixels; click OK to proceed.

Using the Trim command to remove borders
The Trim command lets you remove same-color pixels that are near 
the edge of the image area. This feature is useful for removing 
unwanted white space or other borders that are not part of the main 
image. For example, you scan a photo that doesn’t fill the entire scan-
ner area, and there is a white border around the photo. The Trim com-
mand identifies the color of the pixel in the upper-left corner of the 
image, determines which pixels around the border match that color 
exactly, and deletes them.

Note: If the entire image is the same color, Canvas alerts you that the 
image can’t be trimmed because it cannot identify a border.

◆ To trim an image: Select the image you want to trim and 
choose Area➤Trim in the Image menu. Canvas removes the border.

You can specify relative or 
absolute measurements in the 
Image Crop dialog box
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Using the Crop tool to change image size
You can use the Crop tool to select a rectangular part of an image and 
hide the rest, much as you would crop a photograph traditionally for 
publication. This is called a “soft crop.” When you edit a soft cropped 
image, Canvas temporarily displays the hidden areas. When you fin-
ish editing the image and deselect the paint object, Canvas crops the 
image again.

The Crop tool also lets you “hard crop” to delete or add pixels to an 
image, as an alternative to using the Area➤Crop command in the 
Image menu.

The Crop tool by itself doesn’t delete or add pixels. However, you 
can Command-click (Mac) or Ctrl-click (Windows) with the Crop 
tool to delete and add pixels; see “To remove pixels when cropping 
an image” on page 344 and “To add pixels with the Crop tool” on 
page 345.

To crop without deleting pixels from an image

1 Select the Crop tool in the Paint toolbar and point to the image 
you want to crop.

2 With the crop pointer, click the image. Canvas displays a rect-
angle with hollow handles. This crop rectangle indicates the bound-
ary of the image after you crop it.

3 Position the cropping rectangle to frame the part of the image 
that you want to keep.

• Drag a corner to resize the cropping rectangle.

• Drag a side to move the cropping rectangle. The pointer 
changes to a hand icon when you can move the cropping 
rectangle.

4 Press Enter (Mac) or Esc (Windows) to crop the image, or 
click with the hammer icon inside the image area. Canvas hides the 
part of the image outside the cropping rectangle.

To restore a cropped image

Click the image with the Crop tool. Canvas displays the full image 
area with the cropping rectangle. Drag the corner handles outward so 
that all of the image is within the cropping rectangle.

You can also select the paint object and choose the Remove Effects 
command in the Effects menu to remove a soft crop from an image.

Crop tool 

Hard crop pointer

Hammer icon appears in 
crop mode when the 
pointer is inside the 
image area
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5 Press Enter (Mac) or Esc (Windows) or click with the hammer 
icon to re-crop the image based on the full-size cropping rectangle.

To remove pixels when cropping an image

If you want to hard crop an image, you can use the Crop tool to select 
the rectangular area that you want to keep.

1 Select the Crop tool in the Paint toolbar and Command-click 
(Mac) or Ctrl-click (Windows) the image you want to crop. Canvas 
displays a cropping rectangle around the boundary of the image. 

2 Position the cropping rectangle so it frames the part of the 
image you want to keep.

• Drag a corner to resize the cropping rectangle.

• Drag a side to move the cropping rectangle. The pointer 
changes to a hand icon when you can move the cropping 
rectangle.

3 Press Enter (Mac) or Esc (Windows) or click with the hammer 
icon to accept the hard crop.

Adjust the cropping rectangle 
(highlighted) with the Crop tool. 
Position the cropping rectangle 
to enclose the part of the image 
you want to keep, then press 
Enter (Mac) or Esc (Windows) to 
hide the cropped part of the 
image.

Cropping rectangle

Original

After cropping

✔Tip
You can also hard crop or add 
pixels to an image using the 
Selection tool and a modifier 
key. Select the paint object 
(don’t put it in edit mode), then 
Ctrl-drag a handle to crop or 
add pixels to the image. When 
you drag, the cropping rectan-
gle and handles appear. When 
you release the mouse, Canvas 
applies the hard crop.
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To add pixels with the Crop tool

1 Select the Crop tool in the Paint toolbar and point to the image 
you want to crop.

2 Command-click (Mac) or Alt-click (Windows) the image you 
want to enlarge. Canvas displays a cropping rectangle with hollow 
square handles at the corners.

3 Drag the handles of the cropping rectangle to enlarge it 

4 Press Enter (Mac) or Esc (Windows) or click with the hammer 
icon.

Changing image resolution
When you change the resolution of an image, Canvas divides the 
original pixels to increase resolution, or merges the original pixels to 
decrease resolution. 

• Decreasing the resolution (“resampling down”) decreases 
file size and memory requirements, but can result in lost 
detail. 

• Increasing the image’s resolution (“resampling up”) 
increases file size and memory requirements, but does not 
necessarily increase image quality, because Canvas must 
estimate values for the pixels it adds to the image. For more 
information, see “To specify how Canvas approximates new 
pixels” on page 348.

Original image with 
cropping rectangle

White border added to 
image

Adding a white border

When you press a modifier 
key and click an image with 
the Crop tool, you can add 
white pixels to the image.
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Note: Because of image degradation that can occur when you resam-
ple up an image, try to re-scan the original image at a higher resolu-
tion, rather than increase the image resolution in Canvas.

To change the resolution or size of an image

1 Select an image object. The image should not be in edit mode.

2 Choose Area➤Resolution in the Image menu. The Image Res-
olution dialog box displays the current size, width, height, and reso-
lution of the image.

3 When you change resolution, the size and proportions of the 
image can change. To avoid changes, use the following options:

• To keep the proportions of the original image, turn on the 
Proportions option.

• To keep the original pixel information, turn on Proportions, 
then turn on Data. This tells Canvas not to use interpolation.

• To keep the size the same, choose inches, centimeters, 
points, or picas as the Width and Height units.

4 In the New Size area, you can enter the resolution or let Canvas 
calculate the resolution based on the output screen frequency.

• To set the resolution yourself, enter the resolution in the 
“Res” text box. Select pixels per inch (“pixels/in”) or pixels 
per centimeter (“pixels/cm”) in the adjacent pop-up menu.

• To let Canvas calculate the resolution based on the screen 
frequency used for printing the image, click Auto. In the 
Auto Resolution dialog box, type the screen frequency in 
the Screen text box, choose Draft, Good, or Best, and click 
OK. Canvas calculates resolution by multiplying the screen 
frequency by factors of 1 (draft), 1.5 (good), or 2 (best). 

Type the output screen frequency

Choose the range of output quality 
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5 To change the image size and maintain the current resolution, 
enter dimensions in the Width and Height text boxes. If you turn on 
the Preserve Proportions option, enter one dimension and Canvas 
calculates the other dimension to maintain the image proportions.

6 After entering your settings, click OK to resample the image.

Original 300 ppi

Resampled down to 150 ppi

150 ppi image with Unsharp 
Mask filter applied
Amount = 80
Radius = 1.6
Threshold = 0

300 ppi image with Unsharp 
Mask filter applied
Amount = 67
Radius = 1.6
Threshold = 0

150 ppi image resampled up 
to 300 ppi

Resampling and 
sharpening images

Resizing and resampling 
causes images to appear 
softer. However, you can 
apply the Unsharp Mask filter 
to bring soft images back 
into focus. 

For more information, see 
“To apply the Unsharp Mask 
filter” on page 385.
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To specify how Canvas approximates new pixels

When increasing image resolution, Canvas uses one of two methods 
to calculate color values for the pixels it adds to an image. To change 
the method, use the Preferences command.

1 Choose Preferences in the File menu and select the Painting tab 
in the Preferences dialog box. 

2 Select an option under Interpolation and click OK. For more 
information, see “Painting preferences” on page 88.

Tracing images to create vector objects 
You can use the Auto Trace command to create vector paths that 
trace the outlines of scanned diagrams, line art, and other high-con-
trast images. Although you might need to edit the resulting paths, 
auto-tracing is much faster and more exact than using the Polygon or 
Curve tool.

When Canvas auto-traces an image, it leaves the original image 
unchanged. Canvas applies the current pen ink and fill ink to the 
resulting vector objects. When the tracing is complete, you can move 
the vector objects away from the original image.

Canvas auto-traces high-resolution images with better results than 
low-resolution images. Auto-tracing images at resolution lower than 
300 ppi can produce very jagged paths. 

Note: The Auto Trace command is available only if you select a 
Grayscale or Black & White mode image. The Auto Trace command 
is not available for color images.

To auto-trace an image

1 Select a Grayscale or Black & White image. 

2 Choose Auto Trace in the Image menu.

3 In the Auto Trace dialog box, choose a preset configuration in 
the Configuration pop-up menu, or adjust the individual settings. 
Choose a trace method by clicking the Curves or Polygons option.

• Tracing with polygons results in the most precise trace, but 
sometimes causes a jagged appearance.

• Tracing with curves results in fewer anchor points and 
smoother shapes. 

4 Click OK to trace the image.
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Adjusting sensitivity for curve tracing

When you use the Curves option for auto-tracing, you can adjust how 
closely curves follow the image with the Loose-Tight slider. 

• Drag the slider toward Tight for more exact tracing with 
more anchor points. 

• Drag the slider toward Loose for a looser tracing with fewer 
anchor points. 

Auto-trace options 

To save custom auto-trace configurations

Canvas provides preset configurations that you can choose from a 
pop-up menu in the Auto Trace dialog box. You can also save your 
own tracing configurations so you can use the same settings again.

Choose this option To do this For this tracing 

Centerline Trace one line through the middle of large solid areas 
instead of tracing along the edges. 

Curves and Polygons

Corners Create corner points that let you modify one curve 
segment without affecting the other. Use the Round-
Sharp slider to control the corner sensitivity. 

Curves

Filter Prevent the tracing of small, random elements, such 
as tiny lines and dots. 

Curves and Polygons

Fixed end Align the trace with the endpoints of the image. Curves

Smooth Trace without corner points when the Corners option 
is off. If Smooth and Corners are on, angles within the 
specified sharpness are traced as corner points.

Curves

Select the type of trace

Configuration pop-up menu

Click to preview the trace 

Click to save and delete settings
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1 Select an image and choose Auto Trace in the Image menu. 

2 In the Auto Trace dialog box, configure the options you want 
to save.

3 Press the arrow button and choose Save Settings in the pop-up 
menu. 

4 Type a name for the configuration in the dialog box and click 
Save. The configuration appears in configuration pop-up menu.

To delete custom auto-trace configurations

1 Select an image and choose Auto Trace in the Image menu.

2 In the Auto Trace dialog box, select the configuration you want 
to delete from the configuration pop-up menu.

3 Press the arrow pop-up menu and choose Delete Settings. In 
the dialog box, click OK to confirm you want to delete the settings.

Auto-tracing images

Canvas traces an image with 
curves or straight path seg-
ments. Auto-tracing usually 
produces several paths that 
follow various sections of 
the image.

After tracing, you can group 
and edit the resulting paths.

Original scan at 600 ppi resolution Paths created with the Auto Trace command

Selection handles 
(highlighted) surround 
the objects produced 
by auto-tracing the 
sailboat image.
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Using Photo CD images in Canvas
Scanned images are available from many sources in Photo CD format 
because it’s widely supported, relatively inexpensive, and versatile. 

Because Photo CD images are available in several sizes, you can 
choose the dimensions of the images you place. You can choose 
192x128 pixels (Base/16 format), 384x256 pixels (Base/4), 
768x512 pixels (Base), or 1536x1024 pixels (Base * 4). 

Canvas opens Photo CD images as 72 ppi, RGB images. You can 
increase the resolution of an image and decrease its dimensions using 
the Area➤Resolution command. See “To change the resolution or 
size of an image” on page 346 for more information.

◆ To acquire a Photo CD image: Choose Acquire➤Kodak Photo 
CD in the Image menu. In the dialog box, locate the file you want and 
click OK. The Kodak Digital Science Acquire Module dialog box 
opens. Use the dialog box to select color correction, resolution, and 
rotation options for importing the Photo CD image. 

You can select different source and destination image profiles by 
clicking the Source and Dest buttons. To see details about scanning 
method and color correction, click Info. To see a larger preview, 
click Preview. To import the image into the current Canvas docu-
ment, click OK in the main dialog box.

Kodak Digital Science Photo CD Acquire Module dialog box
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Improving Photo CD images
Photo CD scans are specifically designed to accurately reproduce 
photographic images. However, this means that a Photo CD image 
will exhibit the same problems, such as soft focus and color casts, 
that can be seen in the original photograph. 

Some Photo CD collections provide better-quality images than oth-
ers, but you can improve almost all images with a few simple steps. 
The following procedure describes how to apply the Unsharp mask 
filter to the Lightness (“L”) channel in LAB Color mode to sharpen a 
Photo CD image.

1 Use the previous procedure to acquire a Kodak Photo CD 
image into a Canvas document.

2 Select the image you just acquired and choose Mode➤LAB 
Color in the Image menu.

3 Double-click the image with the Selection tool to put it in edit 
mode.

4 Choose Show Channels in the Image menu to open the Image 
Channels palette.

5 In the Image Channels palette, click the Lightness channel to 
activate it. For more information, see “Activating channels” on 
page 364.

6 Choose Filter➤Sharpen➤Unsharp Mask in the Image menu. 
Turn on the preview option and adjust the Amount and Radius until 
the channel appears significantly sharper. Click OK.

7 If you plan to use special effect filters, choose Mode➤RGB 
Color in the Image menu to convert the image to RGB Color mode.
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Selecting pixels in
21

SELECTIONS, CHANNELS, AND MASKS

Canvas gives you several ways to select pixels in an image. When 
you select groups of pixels by area or color, you can use painting 
tools, filters, and special effects to modify the selected pixels without 
affecting the parts of the image that are not selected. 

This chapter describes how to make selections in images, save selec-
tions in alpha channels, work with color and alpha channels, and cre-
ate masks that make parts of images appear to be transparent.

Selecting pixels in images
When a paint object is in edit mode, any filters, commands, and 
painting tools that you apply can affect the entire image. When you 
have selected a group of pixels within the image, the effect of tools, 
filters, and other adjustments is confined to the selected pixels.

You can select areas in an image using painting tools and menu com-
mands. For example, you can make rectangular selections by drag-
ging the Marquee tool in an image, and you can use the Color Range 
command to select groups of pixels based on color similarity. 

Selection borders

The selected pixels in an image are referred to collectively as a selec-
tion. When you make a selection, Canvas surrounds the selected pix-
els with a moving dashed border. You can hide and display the 
border without affecting the selection. To hide the border, choose 
Select➤Hide Edges in the Image menu. To display the selection bor-
der, choose Select ➤Show Edges in the Image menu.

Deselecting an image selection

When you use a selection tool in normal mode, making a new selec-
tion replaces any existing selection in an image. To deselect pixels 
without making a new selection, choose Select➤None in the Image 
menu. You can also press Enter or Esc (Mac), or Esc (Windows) to 
deselect a selection. If a selection is floating, pressing Esc once 
defloats the selection; pressing ESC again deselects all pixels. 

A dashed border outlines the 
selected area in this photo of a 
blackboard.
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Selecting all pixels in an image

You can apply painting tools and filters to an entire image without 
first making a selection. But you can also select all the pixels in an 
image when you want to work with them as a selection. To select all 
pixels, with a paint object in edit mode, choose Select➤All in the 
Image menu. A selection border appears around the entire image.

Selecting with the Marquee and Lasso tools
You can use the Marquee and Lasso tools to select areas in images. 
You can select rectangular areas with the Marquee tool, while the 
Lasso tool lets you make non-rectangular selections. With either tool, 
you can add to an existing selection, subtract from a selection, or 
select only the overlap (intersection) of two selection areas.

To use the Marquee tool

1 Select the Marquee tool in the Paint Tools toolbar and point to 
the image you want to edit. 

• If the paint object is in edit mode, the pointer becomes a 
crosshair.

• If the paint object is not in edit mode, the pointer becomes a 
hand ( ). Click the paint object to put it in edit mode. 

2 Drag diagonally in the image to make a selection.

◆ To add to a selection: Shift-drag the Marquee tool in the 
image. The pointer displays a crosshair with a ‘+’ to show that it adds 
to the current selection.

◆ To subtract from a selection: Command-drag (Mac) or Ctrl-
drag (Windows) the Marquee tool in the image. The pointer displays 
a ‘-’ to show that it subtracts from the current selection.

◆ To select the intersection of an existing selection and a new 
selection: Press Shift+Command (Mac) or Shift+Ctrl (Windows) as 
you drag the Marquee tool to select the intersection of the existing 
and the new selections.

To use the Lasso tool

The Lasso tool lets you drag in an image to select non-rectangular 
areas. You can set several options before using the Lasso tool. 

1 Select the Lasso tool in the Paint Tools toolbar.

Marquee tool

Lasso tool
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2 Point to the image you want to edit. If the paint object is not in 
edit mode, the pointer becomes a hand ( ). Click the paint object 
to put it in edit mode. The pointer becomes a lasso.

3 Drag in the image to outline a selection. Canvas connects the 
starting and ending points with a straight line.

◆ To add to a selection: Shift-drag the Lasso in the image. The 
pointer displays a ‘+’ to show that it adds to the current selection.

◆ To subtract from a selection: Command-drag (Mac) or Ctrl-
drag (Windows) the Lasso in the image. The pointer displays a lasso 
with a ‘-’ to show that it subtracts from the current selection.

◆ To select the intersection of an existing selection and a new 
selection: Press Shift+Command (Mac) or Shift+Ctrl (Windows) as 
you drag the Lasso tool to select the intersection of the new and exist-
ing selections.

◆ To define a polygon selection: Hold down Option (Mac) or 
Alt (Windows) and click around the area you want to select. Canvas 
connects the points you click with a straight selection line.

◆ To set Lasso options: Double-click the Lasso tool, choose from 
the following options, and click OK before using the tool:

• To soften the edges of the selection, type the number of pix-
els to feather in the Feather Radius text box. For more infor-
mation, see “Feathering the edges of a selection” on 
page 358.

• To slightly soften the selection edge, turn on Anti-Aliased.

• To omit pixels of the current background color from the 
selection, turn on Omit Background Color. This can help 
you isolate an image on a solid color background. You can 
use the Color Dropper tool to pick the background color 
before using the Lasso tool.

Selecting areas based on color
You can use the Wand tool and the Color Range command to select 
pixels in an image according to color. To select a contiguous area of 
similarly-colored pixels, use the Wand tool. To select all pixels of a 
particular color, use the Color Range command
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To use the Wand tool

1 Select the Wand tool in the Paint Tools toolbar palette and 
point to the object you want to edit. If the paint object is not in edit 
mode, the pointer becomes a hand ( ). Click the object to put the 
image in edit mode. The pointer becomes a wand.

2 Click the color area you want to select.

◆ To add to a selection: Shift-click the Wand in the image. The 
pointer displays a ‘+’ to show that it adds to the current selection.

◆ To subtract from a selection: Command-click (Mac) or Ctrl-
click (Windows) the Wand in the image. The pointer displays a wand 
with a ‘-’ to show that it subtracts from the current selection.

To adjust the tolerance of the Wand tool

You can broaden or narrow the range of colors the Wand tool selects 
by adjusting its tolerance. A tolerance of zero, for example, selects 
pixels that exactly match the color of the pixel you click.

◆ To configure the Wand tool: Double-click the Wand icon. In 
the Wand dialog box, type a tolerance value from zero to 255. To 
smooth the edges of the selection, turn on the Anti-Aliased option. 

Selecting a color range
You can use the Color Range command to select all areas of similar 
color in an image. The command creates a grayscale selection mask 
similar to an alpha channel. 

You can use the Load and Save buttons in the dialog box to work 
with color range selection files. The file format that Canvas uses for 
these files is compatible with Photoshop Color Range files. On Win-
dows, these files use the extension .AXT.

To select a color range interactively

1 With a paint object in edit mode, choose Select➤Color Range 
in the Image menu.

2 In the Color Range dialog box, choose Sampled Colors in the 
Select pop-up menu.

3 Adjust the Fuzziness setting. To select pixels of exactly the 
same color, set the Fuzziness to zero. Increase the Fuzziness to 
widen the range of colors to be selected.

Wand tool
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4 Click the preview image in the dialog box. Canvas selects a 
range of similarly colored pixels, depending on the Fuzziness set-
ting.

• To add colors to the selection, click the ‘+’ dropper icon, 
then click a color in the image in the dialog box.

• To subtract colors from the selection, click the ‘-’ dropper 
icon, then click in the image in the dialog box.

5 To view the selected pixels, click the Selection option. Gray 
areas indicate pixels that the Color Range command selects at a 
reduced opacity. Filters and painting tools affect these areas to a 
lesser degree than areas that are 100 percent selected. Click OK to 
apply the selection to the image.

Color Range options

Use this dialog box to select 
image areas based on color.

A Select. In the pop-up 
menu, choose the color (red, 
green, blue, cyan, magenta, 
yellow), or tonal range (shad-
ows, midtones, highlights) you 
want to select. 

To select a color interactively 
by clicking in the preview win-
dow, choose Sampled Colors.

B Fuzziness. When using the 
Sampled Colors option, enter a 
low value to select a narrow col-
or range; enter a higher value to 
select a wider range. 

C Choose Selection to pre-
view the selection, with white 
representing selected pixels, in 
the preview window. Choose 
Image to see the actual image 
so you can sample colors with 
the dropper.

D With Sampled Colors cho-
sen (A), click the dropper in the 

preview window to select col-
ors. Use the ‘+’ dropper to add 
to the selection; use the ‘-’ drop-
per to subtract from it.

E Selection Preview. Choose 
an option to preview the selec-
tion in the image itself (or 
choose None for no preview). 
Grayscale shows the selection 
as it would appear in a channel, 

with white for selected pixels 
and black showing non-selected 
areas. 

The Matte and Mask options 
show the original colors in 
selected areas. In non-select-
ed areas, Black Matte shows 
black, White matte shows 
white, and Mask shows trans-
parent red. 

D

E

A

B

C
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Selecting unselected areas
You can use the Inverse command to simultaneously select all pixels 
not in the current selection while deselecting the current selection. 

◆ To select areas not included in the current selection:
Choose Select➤Inverse in the Image menu.

Working with image selections

After you make a selection, you can clear it, soften its edges, make it 
floating, move it, and change its opacity. 

Clearing and copying a selection
You can replace the pixels in a selection with the current background 
color by pressing the Delete key, or by choosing Cut in the Edit 
menu. (The Cut command also transfers the selection to the Clip-
board.) Canvas replaces the selected pixels with the color currently 
displayed in the background color icon. Keep in mind that “deleting” 
a selection doesn’t leave a hole or transparent area in the paint object. 

To place a copy of a selection on the Clipboard without clearing the 
area in the original image, choose Copy in the Edit menu. When a 
selection has been placed on the Clipboard, you can paste it into 
another paint object in edit mode, where it will become a floating 
selection, or paste it into the document to create a new paint object.

Feathering the edges of a selection
You can feather (soften) the edges of a selection so that it blends 
more naturally into the original image. You can use the Feather com-
mand to soften the hard edge of a selection and spread the selection 
over a larger area.

A moving dashed edge 
surrounds the black star, a 
selected area (left). When the 
selection is inversed, the gray 
background becomes selected 
and the star is deselected (right).

✔Tip
If you want Canvas to recall a 
selection, be sure to save it 
before leaving edit mode. See 
“Saving and loading selections 
in channels” on page 360.
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1 With a paint object in edit mode, make a selection and choose 
Select➤Feather in the Image menu. 

2 In the Feather dialog box, enter the number of pixels to feather 
the selection in the Radius text box. The larger the radius value, the 
more Canvas softens the selection edge.

3 Click OK to feather the selection. 

Floating and moving selections
You can move and manipulate a selection without affecting the origi-
nal image by making it a floating selection. 

When a selection is floating, it sits on an invisible plane above the 
original image. When you type text in an image, or paste an object 
from the Clipboard, Canvas makes the text or pasted item a floating 
selection. 

Moving a selection that is part of the original image creates a floating 
selection, but also leaves behind an area filled with the background 
color.

◆ To float a copy of a selection: Make a selection in an image 
and choose Select➤Float in the Image menu. 

Deselecting and defloating selections

Deselecting a floating selection makes it part of the original image. 
To deselect a floating selection, press Esc or Enter twice (Mac) or 
Esc twice (Windows), or choose Select➤None in the Image menu.

To make the floating selection part of the image but still retain the 
selection, you can press Esc or Enter (Mac) or Esc (Windows), or 
choose Select➤Defloat in the Image menu.

Moving selections 
To move a selection, you can press the keyboard arrow keys or drag 
the selection with the Marquee, Lasso, or Wand tools. If a selection is 
not floating, it becomes floating when you move it. 

To keep the pointer from interfering with your view of a small selec-
tion, select the Remote Move tool in the Paint Tools toolbar and drag 
it anywhere in the drawing area. Canvas moves the selection in the 
direction you move the pointer.

✔Tip
To float a selection and fill 
behind it with the background 
color, hold down Option (Mac) 
or Alt (Windows) and choose 
Select➤Float in the Image 
menu. 

To use the Opacity slider in 
the Image Channels palette to 
lighten a floating selection, fill 
behind the selection with 
white or a light color.

Dragging a selection floats it and 
leaves an area filled with the 
current background color (A).

A

Remote Move tool
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Changing the opacity of floating selections
You can change the opacity of a floating selection and make the pix-
els behind it partially visible. You can also change the transfer mode 
to produce different effects. Note: You cannot make selections par-
tially transparent in Indexed or Black & White image modes.

1 With a paint object in edit mode, select part of the image.

2 From the background color palette icon in the toolbox, select a 
color to use behind the floating selection. This color will start to 
appear when you make the selection transparent.

3 Hold down the Option key (Mac) or Alt key (Windows) and 
choose Select➤Float in the Image menu. Canvas floats the selection 
and fills behind it with the background color.

4 Choose Show Channels in the Image menu to open the Image 
Channels palette. Set the Floating Opacity value to less than 100 
percent to make the selection become transparent and reveal the 
background color behind the selection.

5 To change the transfer mode, choose a new mode from the 
Mode pop-up menu. For more information, see “Using transfer 
modes with painting tools” on page 313.

Saving and loading selections in channels
When you have made a selection in an image, you can create an 
alpha channel from the selection. An alpha channel preserves the 
shape and opacity of a selection, so you can use it to select the same 
part of an image again. 

You can think of an alpha channel as a stencil or mask for making 
image selections. And, because alpha channels make precise selec-
tions of varying intensities, alpha channels let you control which 
areas in an image will be affected by painting and filters, and how 
strongly they will be affected. 

When you view an alpha channel, you see a grayscale image. When 
the channel is made from a selection, it contains white areas repre-
senting fully selected pixels, black areas representing unselected pix-
els, and gray areas representing pixels that are partially selected, with 
the gray lightness values corresponding to the selection opacity.

For more information on channels, see “Understanding image chan-
nels” on page 361.

In the Image Channels palette, 
the Floating Opacity setting 
affects the transparency of the 
current floating selection.
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This section describes how to save a selection in a channel, and how 
to load a channel to make a selection in an image, using dialog boxes. 
You can also use shortcuts in the Image Channels palette, as 
described under “Image Channels palette options” on page 362.

To save a selection in a channel

1 With an active selection in an image, choose Select➤Save in 
the Image menu.

2 Choose New in the Channel pop-up menu.

3 In the Operation area, select New Channel and click OK.

You can also click the Selection button ( ) in the Image Channels 
palette to save the current selection in a new channel.

To load a selection from a channel

1 With a paint object in edit mode, choose Select➤Load in the 
Image menu. 

2 In the Load Selection dialog box, choose a channel name in the 
Channel pop-up menu. To invert the selection, click Invert. 

3 Choose an option in the Operation area and click OK.

Understanding image channels
Canvas uses up to 24 channels to store information for a digital 
image. There are two types of channels: color and alpha channels. 

• Color channels store information about the color in an 
image. The image mode determines the number of color 
channels: RGB Color images have red, green, and blue 
color channels, CMYK Color images have cyan, magenta, 

Option Result

New Selection Removes any current selections and cre-
ates a new selection

Add to Selection Preserves the current selection and selects 
additional pixels based on the channel

Subtract from Selection Removes pixels from the current selection 
based on the channel

Intersect with Selection Creates a new selection composed of pix-
els that appear in both the current selec-
tion and the channel you are loading
Understanding image channels 361
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yellow, and black channels, and LAB Color images have 
“A” and “B” color channels and a Lightness channel (“L”).

• Alpha channels use grayscale images as “masks” for selec-
tions. You can make a selection, save it as an alpha channel, 
then load it later. By default, black in an alpha channel indi-
cates masked (non-selected) areas, white indicates selected 
pixels, and gray represents different levels of opacity for 
selected pixels.

Image Channels palette options

The Image Channels palette 
displays the channels of an 
image in edit mode.You can 
use the palette to create, 
duplicate, and delete channels, 
rename channels and change 
channel options, and load 
channels as selections. 

A Composite channel. Select 
this channel to make all color 
channels visible and active. This 
channel is labeled “CMYK” for a 
CMYK Color image. 

B Color and alpha channels. 
Color channels appear above al-
pha channels.

C An eye indicates which 
channels are visible. Click or 
drag in the column to make 

channels visible.

D The active channel is 
shaded. Image editing affects 
only the active channel.

E Drag this box to resize the 
Image Channels window.

F Click to make a new chan-
nel with default settings. Drag 
a channel here to duplicate it.

G Click to save the current 
selection as a new channel. 
Drag a channel here to load it. 

To add to the current selec-
tion, Shift-drag the channel to 
the button. To subtract from 
the current selection, Com-
mand-drag (Mac) or Ctrl-drag 
the channel to the button. To 

select the intersection of a 
channel and the current selec-
tion, press Command+Shift 
(Mac) or Ctrl+Shift (Windows) 
and drag a channel to the 
Selection button.

H Drag alpha channels to the 
trash to delete them.

E

A

B

D
C

F G H

Alpha channel; white 
indicates selected area

Alpha channel loaded 
as selection (in color)

Applied blend affects 
selected area only

Original image
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Viewing previews in the Image Channels palette

To view previews in the Image Channels palette, choose Palette 
Options in the palette’s pop-up menu. Click the size of the preview 
you want to display, or click None. Click OK to close the Palette 
Options dialog box.

Creating and deleting channels
Canvas provides several methods for creating and deleting channels. 
You can specify more options by using the pop-up menu at the 
lower-right corner of the Image Channels palette. 

To create a new channel 

1 With an image in edit mode, open the Image Channels palette 
by choosing Show Channels in the Image menu.

2 Press the arrow in the bottom-right corner of the Image Chan-
nels palette and choose New Channel in the pop-up menu.

3 In the Channel Options dialog box, select options for the new 
channel. For more information, see “To specify channel options” 
on page 364.

4 After entering the settings you want, click OK.

Deleting alpha channels

Although Canvas can store up to 24 channels in an image, you might 
want to delete unnecessary ones to save memory and disk space. You 
cannot delete color channels.

◆ To delete a channel: With an image in edit mode, choose Show 
Channels in the Image menu to open the Image Channels palette. 
Drag the alpha channel you want to delete to the trash can icon at the 
bottom of the Image Channels palette.

Customizing alpha channels
You can change the name, color indication, and opacity of an alpha 
channel in the Channel Options dialog box. By default, Canvas num-
bers alpha channels, sets them at 50% opacity, and assigns a color to 
masked areas.

Note: Canvas provides the color and opacity settings in the Channel 
Options dialog box as visual aids only. These settings do not affect 
the original image or channel.

Image Channels pop-up menu
Creating and deleting channels 363
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To specify channel options

1 With a paint object in edit mode, choose Show Channels in the 
Image menu to open the Image Channels palette.

2 Click an alpha channel and select Channel Options in the pop-up 
menu, or double-click the channel you want to edit to open the 
Channel Options dialog box.

3 To rename the channel, type a new name in the Name text box. 

4 The options in the Color Indicates area control whether white 
or black pixels in the channel will select pixels in the image when 
you load the channel. 

• If you want the white pixels in the channel to indicate 
selected pixels, choose Masked Area. 

• If you choose Selected Area, the normal operation of the 
channel will be inverted, so that black pixels in the channel 
will select pixels when the channel is loaded. If you use this 
option, keep in mind that the channel will make selections 
that are the inverse of normal channel selections.

5 To change the mask tint color for the channel, select a color 
from the Color pop-up menu. Canvas displays the tint when an 
alpha channel and at least one other channel are visible. To change 
the opacity of the tint color, enter a value from 1 to 100% in the 
Opacity text box.

6 After entering the settings you want, click OK.

Activating channels
To edit a channel, click the channel name in the Image Channels pal-
ette to make it active. Canvas uses shading to indicate that a channel 
is active. Painting tools and filters affect active channels only.

You can make more than one channel active by Shift-clicking the 
names of the channels in the palette. If you want to make a channel 
visible but not active, click the left column until an eye icon appears. 
You can also make more than one channel visible by dragging in this 
column. See “Image Channels palette options” on page 362 for more 
information.

To make all color channels in an image both visible and active, click 
the composite channel in the Image Channels palette. Canvas always 
lists the composite channel first.

All channels visible. Only the 
active channel “Red” will be 
affected by editing.
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Editing an alpha channel selection mask
You can apply painting tools, filters, and effects to the image in an 
alpha channel. By editing the image, you can adjust what the channel 
will select when you load it as a selection.

1 With an image in edit mode, choose Show Channels in the 
Image menu.

2 Create a new channel to use as a selection mask by doing one 
of the following:

• If you have a selection in the image that you want to cus-
tomize by editing in a channel, use the Save command to 
create a channel from the selection; see “To save a selection 
in a channel,” page 361.

• To start with a “blank” alpha channel, use the New Channel 
command. Be sure to choose the Masked Area option under 
Color Indicates in the New Channel dialog box; see “To 
create a new channel,” page 363.

3 In the Image Channels palette, click the new channel to acti-
vate it. The channel appears shaded in the palette and the image 
changes to show only the channel. Now click in the left column of 
the first (composite) channel. The original image appears with a 
transparent colored “mask” on the image. The color mask indicates 
the areas that will be masked — not selected — by the channel.

4 Use painting tools or filters to edit in the image; see “Channel-
editing with painting tools” on page 367 for details. The changes 
you make affect only the active channel selection mask. 

5 To make a selection with the channel, load the channel by 
choosing Select➤Load in the Image menu. Choose the channel 
name in the pop-up menu and then click OK.

Using a channel mask to make areas transparent
A paint object is an opaque rectangular area, and the image it con-
tains will block any other objects placed behind it. However, Canvas 
lets you use a special channel mask to make parts of the image appear 
to be transparent, as if they had been cut out.

In a channel used for this type of masking, pixels that are 50% black 
or darker (lightness level of 127 or less) designate the areas that will 
be masked, or made to appear transparent, in the paint object. You 
can use painting tools and commands in this channel to change the 

Canvas displays a shaded mask 
when an alpha channel is active 
and the composite channel is 
also visible.
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areas that will be masked. By adding black or white pixels, you can 
increase or decrease the transparent area.

Unlike alpha channels, in the channel mask all pixels are treated as 
either black or white; gray pixels to do indicate partial selection. 
Therefore, the mask created by the channel is a hard-edged mask.

Creating a channel mask
Canvas can create a channel mask when you rasterize a vector object 
(except a rectangular object) or text. To tell Canvas to create the 
mask, select the Create Mask option in the Render dialog box. For 
more information on rendering objects, see “Creating images from 
objects and text” on page 307. The channel mask Canvas creates will 
have black pixels corresponding to blank areas in or around the origi-
nal objects.

C

B

D

Hiding the background
with a channel mask

To isolate a main subject, 
like the shell in this photo-
graph (A), you can’t just use 
a white background. All pix-
els in an image, including 
white ones, block out any 
objects appearing behind 
the image (B).

When you want to achieve a 
transparent effect within an 
image (C), you can create a 
channel mask from a selec-
tion. The channel mask (D) 
lets the image appear 
through white areas in the 
channel, and hides parts of 
the image where there are 
black pixels in the channel.

A
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When you make a new paint object by pasting a non-rectangular 
selection copied from an image, Canvas automatically makes a chan-
nel mask to hide white pixels surrounding the selection.

Using an existing channel as a channel mask

In the Image Channels palette, you can designate an existing channel 
to be a channel mask for a paint object.

1 In the pop-up menu in the Image Channels palette, choose 
Channel Mask. The Channel Mask dialog box appears.

2 In the Channel Mask dialog box, choose the channel you want 
to use as a mask in the pop-up menu and click OK.

◆ To remove a mask from an image: With a paint object in edit 
mode, choose Channel Mask from the pop-up menu in the Image 
Channels palette. In the dialog box, select “None” and click OK.

Channel-editing with painting tools
You can edit a channel with painting tools, including the Pencil tool, 
brushes, Blur and Sharpen tools, and so on. Gray areas in an alpha 
channel select pixels at a reduced opacity, so using tools like the Air-
brush and Blend let you create fading effects, such as the vignette.

Original Vignette effect
Channel-editing with painting tools 367
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Creating a vignette using an alpha channel

1 With a paint object in edit mode, choose Show Channels in the 
Image menu to open the Image Channels palette.

2 Create a new channel by selecting New Channel from the pop-
up menu in the lower-right corner of the Image Channels palette. 

3 In the New Channel dialog box, choose Masked Areas in the 
Color Indicates area, and then click OK.

4 Click the new channel in the Image Channels palette to make it 
active. The solid black channel is displayed in the document.

5 In the toolbox, select black as the foreground color and white 
as the background color.

6 Double-click the Blend tool in the Paint Tools toolbar to open 
the Blend dialog box. 

7 Choose Radial in the Style area. Type 50 in the Skew text box 
and 20 in the Offset text box. In the Behavior pop-up menu, choose 
Foreground to Background.

8 Drag the pointer from the center of the image outward to create 
a radial blend in the alpha channel. 

9 Click the composite channel in the Image Channels palette to 
make it active.

10 Choose Select➤Load in the Image menu, select the new chan-
nel in the pop-up menu, and click OK.

11 Press Delete to fill the selection with the background color and 
complete the vignette effect. 

New Channel dialog box

Blend options dialog box

Alpha channel 
loaded as selection 
(highlighted)

Completed alpha 
channel
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Working with image-adjustment dialog
22

IMAGE ADJUSTMENT AND 
CORRECTION

You can adjust images in Canvas using built-in filters and third-party 
plug-ins. For example, you can use the Levels filter to adjust image 
highlights and shadows, and sharpen scanned photos with the 
Unsharp Mask filter.

This chapter describes the commands you can use to adjust image 
color and brightness. It also describes commands for sharpening, 
softening, and refining images. 

◆ Putting paint objects in edit mode: When you want to use 
image-adjustment commands, you first place a paint object in edit 
mode. You can do this by double-clicking a paint object with the 
Selection tool, or clicking on an image with any painting tool. 

When you select a paint object, Canvas displays selection handles 
and a bounding box around the object. When you put a paint object in 
edit mode, Canvas displays crop marks at the object’s corners.

Working with image-adjustment dialog boxes
Many dialog boxes for Canvas commands include histograms and 
preview options to help you achieve the effect you want.

Understanding histograms

A histogram plots the relative number of pixels in each brightness 
level in an image.

Brightness levels

Amount of pixels

Minimum (0) Maximum (255)

More

Fewer
 boxes 369
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In the histogram above, shorter bars on the left indicate that the 
image doesn’t contain large areas of very dark pixels. Higher bars 
toward the right of the graph show that the image does contain large 
areas of medium and very bright pixels. 

◆ To view an image’s histogram at any time: With an image in 
edit mode, choose Filter➤View➤Histogram.

Using the Preview option

Most dialog boxes for image-adjustment commands include a Pre-
view check box. Turn on the Preview option to see how settings 
affect the image.

Consolidating colors
The Threshold and Posterize commands let you consolidate color 
values in an image or selection. Besides producing interesting effects 
with these commands, you can use them in alpha channels to help 
isolate areas within an image.

These commands operate on paint objects that are in edit mode. If 
you select an area within an image, Canvas applies the adjustment 
only to that area. Otherwise, Canvas adjusts the entire image.

Setting a brightness threshold
You can use the Threshold command to convert any image to black 
and white. The Threshold command compares each pixel’s bright-
ness value to a threshold value that you set. It changes brighter pixels 
to white and darker pixels to black. The threshold setting is based on 
a scale of brightness values from 0 (black) to 255 (white). 

For example, if you set a threshold value of 128, pixels that are 
brighter than medium gray become white, while pixels darker than 
medium gray become black.

✔Tip (Mac OS only)
When working with large ima-
ges, you can improve speed by 
using video LUT animation 
instead of previews; see “Paint-
ing preferences” on page 88.
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To map an image to black and white

1 With a paint object in edit mode, choose Adjust➤Threshold in 
the Image menu. 

2 In the Threshold dialog box, enter the threshold value by drag-
ging the slider or typing a number in the text box. If you want Can-
vas to convert half the pixels to black and half to white, click Auto.

3 After entering the setting you want, click OK.

To isolate selections, you can apply the Threshold command in con-
junction with the High Pass filter to an image in an alpha channel. 
See “Isolating areas using the High Pass filter” on page 394.

Creating high-contrast ‘posterized’ images
You can condense the brightness variations in an image with the Pos-
terize command. If you apply the Posterize command to a photo-
graph, it creates a high-contrast image by compressing hundreds of 
brightness levels into only a few. You set the number of brightness 
levels you want to retain, and Canvas reduces each color channel to 
that number of values.

The Posterize command’s effect depends on the mode of the image 
you posterize. 

For example, if you apply the Posterize command with a setting of 2 
levels to a grayscale-mode image, the image becomes black and 
white. If you apply the same setting to an RGB-mode image (even if 
it contains only grays), the command converts each pixel’s red, 
green, and blue value to either zero or full color, reducing the image 
to eight colors — red, green, blue, red-green, red-blue, blue-green, 
black, and white.

Threshold dialog box

Original RGB image Posterize 4 levelsPosterize 8 levels Posterize 2 levels
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To posterize an image

1 With a paint object in edit mode, choose Adjust➤Posterize in 
the Image Menu.

2 Enter a level from 2 to 255. Higher numbers produce subtle 
effects. Lower numbers produce high-contrast images.

3 After you enter the posterization setting, click OK.

Changing color and contrast 
You can use the Invert, Desaturate, and Brightness/Contrast com-
mands to create special effects and correct lightness levels in images. 
These commands apply changes equally to all color values. 

To apply these commands, first put a paint object in edit mode. If you 
select an area of an image, Canvas applies the command to only that 
area. Otherwise, Canvas applies the command to the entire image. 

Inverting colors in images
You can use the Invert command to reverse the colors in an image, as 
in a photographic negative. The command converts each pixel’s color 
into its opposite hue in the color spectrum. It does this by inverting 
the brightness value of each pixel in each color channel.

For example, if a pixel is pure red, its brightness levels are 255, 0, 0 
in RGB mode. When inverted, this pixel’s brightness values become 
0, 255, 255, changing it to pure blue-green, its opposite in hue.

The Invert command can be particularly useful in channel editing, as 
colored pixels can denote either masked or selected areas.

◆ To invert an image: With a paint object in edit mode, choose 
Adjust➤Invert in the Image menu.

Posterize dialog box

Invert filter 
examples
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Desaturating image colors 
You can use the Desaturate command to completely remove color 
from images, while retaining the relative brightness levels of shad-
ows, midtones, and highlights. The command converts an entire 
image to shades of gray without changing the image mode.

◆ To desaturate an image: With a paint object in edit mode, 
choose Adjust➤Desaturate in the Image menu.

Adjusting brightness and contrast
You can adjust the brightness and contrast of an entire image or spe-
cific channels with the Brightness/Contrast command. Brightness 
refers to the lightness of an image. Contrast is the difference in 
brightness between two pixels. 

Because the Brightness/Contrast command adjusts all pixels equally, 
you should avoid using it to lighten an image that appears too dark, 
because the image can lose shadow detail. To preserve shadows or 
highlights when adjusting the brightness of an image, you can use the 
Levels or Curves commands. See “Using the Levels command” on 
page 374 and “Adjusting brightness curves” on page 377.

To use the Brightness/Contrast command

1 With a paint object in edit mode, choose Adjust➤Brightness/
Contrast in the Image menu. 

2 Enter a Brightness value from -100 to 100. Higher values can 
wash out midtones and shadows. Lower values can dull highlights.

3 Enter a Contrast value from -100 to 100. Increasing contrast 
moves the color values of pixels to the extremes of the brightness 
spectrum. Decreasing contrast moves color values toward medium 
gray.

4 After entering the settings you want, click OK.

Brightness/Contrast dialog box
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Targeting shadows, midtones, and highlights
You can use the Levels and Color Balance commands to adjust 
ranges of colors. By adjusting the shadows, midtones, and highlights 
separately, you can correct color and brightness and maintain the 
original image integrity.

Using the Levels command
You can adjust the brightness of shadows, highlights, or midtones by 
using the Levels command. Brightness values range from 0 (zero 
intensity) to 255 (full intensity). For colored pixels, brightness is the 
brightness value in each color channel.

To brighten highlights

You can vitalize real-life images by brightening highlights.

1 With a paint object in edit mode, choose Adjust➤Levels in the 
Image menu.

2 Select a channel or combination of channels in the pop-up 
menu. The Levels command will affect only the specified channels.

Adjusting color balance

The Color Balance command 
lets you adjust color in shad-
ows, midtones, and highlights. 
You can use it with images in 
CMYK, RGB, or LAB modes.

With a paint object in edit 
mode, choose Adjust➤Color 
Balance in the Image menu. 
The dialog box options 
depend on the image mode.

A Click Shadows, Midtones, 
or Highlights to select the tonal 
range you want to adjust. You 
can set the color levels indepen-
dently for each tonal range.

B Drag a slider toward a color 
label to increase the amount of 

that color. The letters indi-
cate the primary color val-
ues: Cyan, Red, Magenta, 
Green, Yellow, and Blue. 

When you increase the 
amount of a color, you 
also reduce its inverse, 
which is the color labeled 
at the other end of the 
slider.

C Turn on Preserve Lumi-
nosity to maintain the over-
all brightness of the image. 
This prevents darker colors 
from replacing highlights, 
or pastels from washing 
out shadows.

LAB Color mode

CMYK Color or RGB Color mode

B

B

A

A

C

C
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3 Enter a positive number less than 255 in the right Input Levels 
text box or drag the white slider located under the histogram. Can-
vas assigns the maximum output level to all pixels on the right of 
the slider. 

4 After entering the settings you want, click OK.

To lighten shadows

You can lighten shadows to prevent ink from oversaturating a printed 
medium.

1 With a paint object in edit mode, choose Adjust➤Levels in the 
Image menu.

2 Select a channel or combination of channels in the pop-up 
menu. The Levels command will affect only the specified channels.

Levels dialog box

You can use the Levels dialog 
box to control different 
aspects of brightness levels. 

A Choose an individual color 
channel or the composite chan-
nel.

B Enter numbers in the text 
boxes or drag the slider under 
the histogram to set the mini-
mum input level, midtone ratio, 
and maximum input level.

C Enter numbers in the text 
boxes or drag the sliders to set 
the minimum and maximum 
output levels.

D The histogram graphs 
brightness levels for the select-
ed channel.

E Click Auto for Canvas to 
map the darkest values in the 
selection to black and the light-
est value to white. 

E

D 

B 

A 

B 

C 
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3 Enter a number greater than zero in the left Output Levels text 
box or drag the black slider under Output Levels to increase the 
minimum output level. This value becomes the darkest value 
allowed in the image.

4 After entering the settings you want, click OK.

To darken highlights

You can darken the highlights on one particular color channel to 
bring brighter colors back into the printable color range.

1 With a paint object in edit mode, choose Adjust➤Levels in the 
Image menu.

2 Select a channel or combination of channels in the pop-up 
menu. The Levels command will affect only the specified channels.

3 Enter a positive number less than 255 in the right Output Lev-
els text box or drag the white slider under Output Levels to 
decrease the maximum output level. This value becomes the bright-
est value allowed in the image.

4 After entering the settings you want, click OK.

To deepen shadows

You can create more contrast in an image by making shadows darker.

1 With a paint object in edit mode, choose Adjust➤Levels in the 
Image menu.

2 Select a channel or combination of channels in the pop-up 
menu. The Levels command will affect only the specified channels.

3 Enter a number greater than zero in the left Input Levels text 
box or drag the black slider under the histogram. Canvas assigns the 
minimum output level to all pixels on the left of the slider.

4 After entering the settings you want, click OK.

To lighten or darken middle tones

1 With a paint object in edit mode, choose Adjust➤Levels in the 
Image menu.

2 Select a channel or combination of channels in the pop-up 
menu. The Levels command will affect only the specified channels.

3 Enter a value in the center Input Levels text box or drag the 
gray slider under the histogram to the left:
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• To lighten midtones, enter a value from 1.01 to 9.99 or drag 
the slider to the left. All pixels on the right of the slider will 
be brighter than medium gray.

• To darken midtones, enter a value from 0.1 to 1.00 or drag 
the slider to the right. All pixels on the left of the slider will 
be darker than medium gray.

4 After entering the settings you want, click OK.

Saving and loading Levels settings

You can save Levels settings on disk to use again. For example, after 
correcting a scanned photo, you can save the settings and use them to 
correct other images scanned from the same source. 

◆ To save Levels settings: In the Levels dialog box, click Save. 
Type a name for the settings file, select a location, and click Save.

◆ To load previously-saved Levels: In the Levels dialog box, 
click Load. A directory dialog box opens. Locate the settings file you 
want to open, and click Open. 

Changing specific color values
You can adjust brightness and color with the Curves, Hue/Saturation, 
and Color Equalization commands. These commands let you fine-
tune any color value and make sure all colors in an image fall within 
the color range of an output device. 

You can apply these commands to a paint object in edit mode. If you 
select part of an image, Canvas adjusts only the selected area. Other-
wise, Canvas applies the command to the entire image. 

Adjusting brightness curves
You can adjust the tonal range of an image with the Curves com-
mand. Unlike the Levels command, which limits you to highlight, 
midtone, and shadow adjustments, curves let you map up to 19 tonal 
ranges to a specific brightness level. Curves give you much more 
control than other methods over subtle contrast and brightness quali-
ties of an image.

The Curves dialog box uses a line graph to map current brightness 
values to ones you specify. For RGB images, the default scale of 
brightness values ranges from 0 to 255 (maximum brightness); for 
CMYK images, the default scale ranges from 0 percent (maximum 
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brightness) to 100 percent. You can switch the scales for an image, 
depending on which scale is more intuitive to you.

A typical setting is a gentle S-curve (or inverted S-curve, depending 
on the scale you use) which adds contrast to an image without 
appearing too harsh. For wild effects, try using a rounded M-shape 
curve to create dramatic contrast.

To adjust brightness curves

1 With a paint object in edit mode, choose Adjust➤Curves in the 
Image menu.

2 In the Channel pop-up menu, choose the channel(s) you want 
to adjust. To adjust curves for specific color channels at the same 
time, Shift-select the channels in the Image Channels palette before 
choosing the Curves command.

Curves dialog box

The graph shows how Canvas 
maps input brightness values 
to output values. Turn on Pre-
view so you can see the effect 
on the image.

A Choose channels to adjust.

B The grayscale ramp below 
the graph shows the input tonal 
range. By default, RGB images 
range from 0-255 (dark to light) 
from left to right. CMYK images 
range from 0-100 percent (light 
to dark). You can reverse this 
ramp and the curve at any time 
by clicking the ramp.

C Brightness values for the 
pointer’s position (circled). 
Here, pixels of 158 brightness 
are lightened to 164.

D Click this icon and drag a 

point on the curve to reshape 
the curve. Click the curve to add 
up to 19 control points. Drag 
points off the curve to delete 
them.

E To draw a disconnected 

segment, click this icon and 
drag in the graph.

F With the pencil icon D se-
lected, click to smooth the 
curve.

D

E

F

A

C
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ut
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Input brightness
B
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3 To change the shape of the existing curve, make sure the curve 
button at the bottom-left is selected.

4 Turn on Preview so you can see the changes in the image.

5 Click any points on the curve that you want to stay the same; 
drag points on the curve that you want to change. For example, to 
keep the midtones the same while you adjust other tonal ranges, 
click the center of the curve, then drag other areas of the curve. To 
adjust midtones without affecting highlights and shadows, click the 
quarter and three-quarter points of the curve, and drag the middle.

• To brighten a tonal range, drag the curve up.

• To darken a tonal range, drag the curve down.

6 If you draw disjointed segments with the pencil, you can click 
Smooth to create one continuous curve.

7 Click OK to apply the current settings to the image.

Saving and loading Curves dialog box settings

You can save Curves dialog box settings on disk to use again. For 
example, after correcting the brightness curve for a particular Photo 
CD image, you can save these settings and later apply them to other 
images from the same source.

◆ To save Curves settings: In the Curves dialog box, click Save. 
In the directory dialog box, type a name for the settings file, select a 
location, and click Save.

◆ To load Curves settings: In the Curves dialog box, click Load. 
In the directory dialog box, locate the settings file and click Open.

Modifying colors
You can modify the tint and purity of specific colors with the Hue/
Saturation command. In terms of image editing, saturation refers to 
the amount of gray in colors. 

The Hue/Saturation dialog box varies slightly depending on the color 
mode. For RGB and CMYK images, you can modify red, yellow, 
green, cyan, blue, or magenta color ranges. For LAB mode images, 
you can modify blue, magenta, yellow, or green color ranges. 

The Hue/Saturation command is available when you work with 
CMYK, RGB, or LAB mode images. Before choosing the Hue/Satu-
ration command, make the composite channel active. For more infor-
mation, see “Activating channels” on page 364.

✔Tip
To completely redraw the 
curve, or to create sharp 
changes in brightness for a ton-
al range, click the pencil button 
at the bottom-left and draw a 
new curve or segment.
Changing specific color values 379



38
To adjust the hue of a color range

1 With a paint object in edit mode, choose Adjust➤Hue/Satura-
tion in the Image menu.

2 On the left side of the dialog box, click the color range you 
want to adjust, or click Master to affect all colors equally. 

3 To change the selected color, enter the amount of the color 
shift, from -180 to180 degrees, in the Hue text box. Negative values 
indicate a counter-clockwise shift around the color wheel; positive 
values indicate a clockwise shift. For example, with the Master 
option selected, setting Hue to 60 changes red to magenta, magenta 
to blue, blue to cyan, and so on.

4 To apply the current settings to the image, click OK.

To adjust the saturation of a color range

1 With a paint object in edit mode, choose Adjust➤Hue/Satura-
tion in the Image menu.

2 Click the option button of the color you want to adjust, or click 
the Master option button to affect all colors equally.

3 Enter a value from -100 to 100 in the Saturation text box or 
drag the slider. Positive values decrease the amount of gray in the 
selected colors. Negative values increase the amount of gray.

4 To apply the current settings to the image, click OK.

Hue/Saturation dialog box

A Choose the color to adjust. 
Click Master to affect all colors.

B Enter numbers in the text 
boxes or drag the sliders to ad-
just hue, saturation, and light-
ness.

C The color wheel illustrates 
changes made in the settings. 

D Turn on to add the same 
hue to the entire image.

A C

B

D

Color wheel
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To adjust the brightness of a color range

1 With a paint object in edit mode, choose Adjust➤Hue/Satura-
tion in the Image menu.

2 Choose a specific color range or choose Master to equally 
affect all colors.

3 Enter a value from -100 to 100 in the Lightness text box or 
drag the slider. Positive values increase the amount of white in the 
color range. Negative values decrease the amount of white.

4 To apply the current settings to the image, click OK. 

For more control of brightness adjustments, use the Levels or Curves 
command. For more information, see “Using the Levels command” 
on page 374 and “Adjusting brightness curves” on page 377.

To colorize an image

You can use the Colorize option in the Hue/Saturation dialog box to 
apply the same color to an entire image.

1 With a paint object in edit mode, choose Adjust➤Hue/Satura-
tion in the Image menu.

2 Choose a specific color range or choose Master to equally 
affect all colors.

3 Turn on the Colorize option. This applies the same hue and sat-
uration to all pixels that are not 100 percent black or white. The 
Colorize option does not affect the lightness levels of pixels. 

4 Enter a value from -120 to 120 degrees in the Hue text box. 
With the Colorize option on, a Hue value of zero indicates red. 
Enter positive values to select colors located clockwise around the 
color wheel at the specified number of degrees. Enter negative val-
ues to select colors located counter-clockwise around the color 
wheel. For example, changing the hue to 120 creates a “greenscale” 
version of the original image.

5 Enter a value in the Saturation text box or drag the slider. 

6 After entering the settings you want, click OK.
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Adjusting saturation
You can graphically adjust the saturation of different color ranges 
with the Color Equalization command. This command lets you add 
or remove gray from various color ranges.

To use the Color Equalization command

1 With a paint object in edit mode, choose Adjust➤Color Equal-
ization in the Image menu. Turn on Preview to see the effect of the 
settings on the image.

2 Drag the bars in the color equalizer window to change the satu-
ration of the various color ranges:

• To increase the saturation of a color range, drag the bar 
toward the top of the window.

• To decrease the saturation of a color range, drag toward the 
bottom of the window.

3 To increase the saturation of all colors, click Saturate.

4 To decrease the saturation of all colors, click Desaturate.

5 Click Normalize to return all colors to their original saturation. 

6 When you finish adjusting saturation settings, click OK.

Using blur, noise, and other filters
The Blur, Sharpen, Noise, and Video filters change the contrast 
between pixels in specific areas of an image. You can use them to 
correct imperfect scanned images and to refocus scaled images. 

You can apply these filters to paint objects in edit mode. If you select 
part of an image, Canvas applies the filter only to the selection. Oth-
erwise, Canvas applies the filter to the entire image.

Using blur filters 
All blur filters soften images by decreasing the contrast between 
neighboring pixels. The Blur filter only slightly modifies an image. 
The Blur More filter is about four times stronger than the Blur filter 
and, therefore, creates a more noticeable effect.

Color Equalization window
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◆ To blur an image: With a paint object in edit mode, choose 
Filter➤Blur and choose a filter from the Blur submenu.

Comparing Gaussian and Average blurs
You can create a softening effect by using the Gaussian Blur or Aver-
age blur filters. Their effects are similar, but the Gaussian Blur filter 
does not affect an image as strongly as the Average blur filter.

The Gaussian Blur filter changes the color value of each pixel by 
applying a weighted average based on the color values of pixels 
within a specified distance. Color values at the edge of the specified 
distance influence the final color value less than closer pixels. 

The Average filter determines the new color value for each pixel by 
equally averaging all color values within the specified radius. 

To apply a Gaussian Blur or Average blur

1 With a paint object in edit mode, choose 
Filter➤Blur➤Gaussian Blur or Filter➤Blur➤Average in the Image 
menu.

2 Specify a radius value from 0.1 to 250.0 in the Gaussian Blur 
dialog box, or 1 to 16 in the Average dialog box. Smaller radius 
values produce more subtle effects than larger ones.

Average Blur 
Radius = 6 pixels

Gaussian Blur 
Radius = 6 pixels

Original

Blur applied 10 times

Blur More applied 10 times

Text was converted to an image, 
then the blur filter applied.

Average Blur dialog box

Gaussian Blur dialog box
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3 After entering the setting you want, click OK.

Depending on the size of the radius, applying a Gaussian or Average 
blur can take longer than other Blur filters.

Using filters to sharpen images
All sharpen filters increase the contrast between adjacent pixels, 
which can make an image appear more distinct. The Sharpen filter 
modifies an image only slightly. The effect of the Sharpen More filter 
is about four times stronger than the Sharpen filter.

You can use the Sharpen Edges filter to make edges more distinct. 
This filter affects only high-contrast areas, leaving the rest of the 
image untouched. 

The Unsharp Mask filter provides additional control over the sharp-
ening effect. When you use the Unsharp Mask filter, you can specify 
the amount, radius, and threshold of the sharpening effect.

◆ To sharpen an image: With a paint object in edit mode, choose 
Filter➤Sharpen. Choose a filter from the Sharpen submenu.

✔Tip
Although the Sharpen and Blur 
filters have opposite effects, 
they do not negate each other. 
To reverse the effects of a 
Sharpen filter, choose Undo in 
the Edit menu.

Original Sharpen More 
applied 5 times 

Sharpen Edges 
applied 8 times 

Unsharp Mask 
Amount = 113
Radius = 4.5
Threshold = 0
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To apply the Unsharp Mask filter

1 With a paint object in edit mode, choose Filter➤Sharpen➤Un-
sharp Mask in the Image menu.

2 Enter a number from 1 to 500 percent in the Amount text box. 
Enter a number less than 100 percent to sharpen the image slightly; 
enter a higher number for more dramatic sharpening.

3 Enter a number from 0.1 to 250.0 in the Radius text box. This 
specifies how far from the filter will look to determine the new 
color value for the original pixel. Small Radius values focus the 
sharpening effect on high-contrast edges. Greater values spread the 
sharpening effect over a larger area. 

4 Enter a number from 0 to 255 in the Threshold text box. Enter 
0 to filter all pixels. Enter a larger value to filter only high-contrast 
edges.

5 After entering the settings you want, click OK.

Adding and removing noise
In images, “noise” refers to randomly-colored pixels. Noise can be 
good or a bad. For example, you can apply noise to computer-gener-
ated graphics to make them appear more photographic. You can also 
use a filter that removes noise to minimize the appearance of tiny 
scratches or other artifacts present in the source material or intro-
duced during digitizing.

To add noise to selections

1 With a paint object in edit mode, choose Filters➤Noise➤Add 
Noise in the Image menu.

2 Enter an amount from 1 to 999 to specify how far the color of 
the noise can vary from the original color. 

3 Choose the Uniform or Gaussian distribution option:

• Choose Uniform to apply colors randomly picked within the 
Amount specified. Canvas evenly distributes the color of 
the noise across a range of colors. This option gives the 
smoothest effect.

• If you want the noise to favor lighter and darker colors 
within the specified range, choose the Gaussian option. This 
option creates a more pronounced effect than Uniform.

Unsharp Mask dialog box

Add Noise dialog box
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4 If you want all added noise to be different brightness levels of 
the original color, turn on the Monochromatic option. 

5 After entering the settings you want, click OK.

Removing noise from selections

You can remove noise from an image or selection using the Median, 
Despeckle, or Dust & Scratches filters. The Median filter removes 
noise by averaging the color of pixels. The Despeckle and Dust & 
Scratches filters remove noise by selectively blurring regions of the 
selection. 

Comparing noise

A Original image

B Uniform 
Amount = 302 

C Gaussian 
Amount = 302 

D Gaussian 
Amount = 80 
Monochromatic

E Original image

F Uniform
Amount = 52 
(The white of the eye was not 
filtered.)

G Gaussian 
Amount = 52
(The white of the eye was not 
filtered.)

A B C D

F

E

G
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To use the Median filter

On a pixel-by-pixel basis, the Median filter applies the median color 
value of all pixels within the specified radius. Although the filter 
ignores extreme values in its computations, higher radius values can 
still wash out an image. 

1 With a paint object in edit mode, choose Filter➤Noise➤ 
Median in the Image menu. 

2 Type a value from 1 to 16 in the Radius text box, or drag the 
slider. Smaller radius values produce subtler effects.

3 After entering the setting you want, click OK.

To use the Despeckle filter 

The Despeckle filter creates a smoothing effect by finding the higher-
contrast edges in an image and then slightly blurring the other areas. 

◆ To apply the Despeckle filter: With a paint object in edit 
mode, choose Filter➤Noise➤Despeckle in the Image menu.

To reduce dust and scratch marks from scans

1 With a paint object in edit mode, choose Filter➤Noise➤Dust & 
Scratches in the Image menu.

2 Enter a value from 1 to 16 in the Radius text box. Smaller 
radius values produce a subtler effect than larger ones.

3 Type a value from 0 to 255 in the Threshold text box. Higher 
values make the filter less sensitive to contrast between pixels.

4 After entering the settings you want, click OK.

Median dialog box

Dust and Scratches dialog box
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Smoothing video images
Because video images contain two interlaced pictures, you can some-
times see a slight banding effect in images acquired from video-
recording devices. You can correct this in Canvas by using the De-
Interlace filter and then applying the Unsharp Mask filter. 

To smooth video images

1 With a paint object in edit mode, choose Filters➤Video➤De-
Interlace in the Image menu. 

2 Click Odd fields or Even fields to select bands to eliminate.

3 Choose a replacement method for the eliminated pixels: 

• Click Duplication to fill the area by inserting a copy of an 
adjacent band. 

• Click Interpolation to fill the area by inserting intermediate 
color values based on the color values of neighboring pix-
els. This option creates a smoother, more accurate fill than 
Duplication.

4 After entering the settings you want, click OK.

De-interlace dialog box
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Putting paint objects in ed
23

IMAGE FILTERS AND EFFECTS

Canvas provides filters you can use to transform images with artistic 
effects. You can also correct selections with subtle modifications and 
merge image channels for photo montages and graphic designs. You 
can apply the effects described in this chapter to entire images, spe-
cific selections, or individual image channels. 

This chapter explains how to use the filters in the following sub-
menus in the Image menu: 

Render You can use the Render filters to paint clouds and color 
spectrums in an image.

Stylize You can use the Stylize filters to emboss, solarize, and trace 
the contours of an image.

Other With the filters in this submenu, you can offset selections, 
accentuate high-contrast edges, and resize the lighter areas of an 
image. You can also create custom filters to design your own effects.

Calculate You can combine image channels to adjust the shadows 
and highlights or create effects such as type embossed in an image.

Putting paint objects in edit mode
Before you can apply filters to an image, you must place it in edit 
mode. Crop marks appear at the corners of the image when it is in 
edit mode.

Selected paint 
object

Paint object in edit
mode
it mode 389
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◆ To put a paint object in edit mode, do one of the following:

• Double-click the object with a selection tool.

• Select a painting tool in the Paint toolbar. Point to the image 
you want to edit. Click the image when the pointer becomes 
a .

Applying effect filters
You can use the Render, Stylize, and Offset filters to transform 
images. The filters in the Render submenu apply forms or textures to 
an image. The Stylize filters apply a conceptual effect to an image. 
Stylize filters include Emboss, Trace Contour, and Solarize. The Off-
set filter shifts an image.

Rendering clouds
You can apply texture to areas in an image, such as skies or walls, by 
applying the Clouds filter. The Clouds filter renders soft swirls of 
color using the foreground and background colors. 

Note: The Clouds filter completely replaces the original image or 
selection.

◆ To apply a swirl of color to an image: With a paint object in 
edit mode, choose Filter➤Render➤Clouds in the Image menu. 

To render translucent clouds

You can use alpha channels to render translucent clouds.

1 With a paint object in edit mode, choose Select All in the Edit 
menu and then choose Copy in the Edit menu to copy the image to 
the Clipboard.

2 Choose Channels in the Image menu to open the Channels pal-
ette and choose New Channel in the palette options pop-up menu. 

3 Click the new channel in the Channels palette to make it active 
and choose Paste in the Edit menu to paste the image.

4 In the areas where you want clouds to replace the original 
image, apply white using the Paintbrush or Eraser. In areas where 
you want a translucent effect, apply gray. The darker the shade, the 
less the clouds will obscure the original image.

5 In the Channels palette, click the first item listed to make the 
composite active. 

Image with translucent 
clouds

Completed alpha channel
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6 Choose Select➤Load in the Image menu and select the channel 
you edited in step four. 

7 Choose Filter➤Render➤Clouds in the Image menu.

Rendering a color wheel 
You can fill a selection with a radial blend of colors by choosing 
Filter➤Render➤Wheel in the Image menu. The rendered effect looks 
like the color wheel preview in the Hue/Saturation dialog box.

Unless you make a selection in the image, the Wheel filter replaces 
the entire image. If you want to apply a translucent wheel effect, fol-
low the steps for the procedure “To render translucent clouds” on 
page 390, but in the seventh step, use the Wheel filter. 

Embossing an image
You can make an image appear raised with the Emboss filter. This 
filter converts low-contrast areas to gray and accentuates high-con-
trast areas with color (or black and white if the image is Grayscale 
mode) according to the placement of a theoretical light source. 

To apply the emboss filter

1 With a paint object in edit mode, select the area of the image 
you want to emboss. If you don’t make a selection, the Emboss fil-
ter affects the entire image.

2 Choose Filter➤Stylize➤Emboss in the Image menu.

3 Enter an Angle from 1 to 360.

4 Enter a height from 1 to 32 pixels to set the height of the effect.

5 Enter a number from 1 to 500 in the Amount text box. To 
retain more color along high-contrast borders, increase this value.

Original 

Embossed

Angle = 163
Height = 5
Amount = 260

You can adjust the Angle, 
Height, and Amount 
individually by dragging 
these sliders...

...Or, drag this 
handle to set the 
Angle, Height, 
and Amount 
values 
simultaneously.
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Solarizing images
You can create surrealistic effects in an image by applying the Solar-
ize filter. The Solarize filter mimics a photographic darkroom proce-
dure that exposes film to light during development.

You can solarize CMYK Color, RGB Color and Grayscale mode 
images. If you make a selection, Canvas filters only selected pixels.

◆ To solarize an image: With an image in edit mode, choose 
Filter➤Stylize➤Solarize in the Image menu. 

Outlining areas based on color value
With the Trace Contour filter, you can outline image areas that bor-
der a particular color. This filter makes color outlines if you are 
working with a color image, and black outlines if you are working 
with a Grayscale mode image.

To use the Trace Contour filter

1 With an image in edit mode, select the area you want to trace. 
If you don’t make a selection, Canvas filters the entire image.

2 Choose Filter➤Stylize➤Trace Contour in the Image menu.

3 Enter a Level value from 0 to 255. The Trace Contour filter 
uses this color brightness value to determine the areas to trace.

4 Select Upper or Lower in the Edge area. To outline areas with 
higher brightness levels than the one specified, choose Upper. 
Choose Lower to outline areas with lower brightness levels.

5 To see the effect of the settings, turn on Preview. When the set-
tings are correct, click OK.

Original Solarized
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Offsetting selections
You can shift an image area with the Offset filter. Canvas fills the 
vacated area with color, duplicated pixels, or parts of the offset area.

To offset image areas

1 With an image in edit mode, select an image area. 

2 Choose Filter➤Other➤Offset in the Image menu.

3 Enter horizontal and vertical offset amounts in pixels. The fil-
ter offsets to the right and down from the original location.

4 Choose an option under Undefined Areas. 

Choose this option For this effect

Set to Background Fills area with the background color 

Repeat edge pixels Duplicates edge pixels until they fill 
the area vacated by the offset 

Wrap around Moves pixels cut off by the offset 
into the vacated area 

Original Level =169 
Edge = Lower

Level =169 
Edge = Upper

Original Set to 
Background

Repeat Edge 
Pixels

Wrap Around
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5 To see the effect of the settings, turn on Preview. When the set-
tings are correct, click OK.

Using the High Pass, Maximum, and Minimum filters
This section describes how you can create selections in alpha chan-
nels and resize bright areas in color channels. You can isolate areas in 
an image using the High Pass filter and Threshold command. You 
can use the Maximum and Minimum filters to spread color areas you 
might need to trap for commercial printing purposes. 

Isolating areas using the High Pass filter
The High Pass filter isolates high-contrast edges in an image by 
removing low-contrast detail. The filter makes pixels located in low-
contrast areas gray. In color images, the High Pass filter outlines 
high-contrast edges in color. Otherwise, it outlines these edges in 
dark gray.

To apply the High Pass filter

1 With an image in edit mode, select an area. If you don’t make a 
selection, Canvas filters the entire image.

2 Choose Filter➤Other➤High Pass in the Image menu.

3 Enter a radius from 0.1 to 250.0 pixels. To retain more of the 
original image surrounding high-contrast edges, enter a high num-
ber. If you enter a low number, the filter makes more of the image 
gray. 
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Maximizing and minimizing bright areas in an image

You can increase or decrease light areas in an image with the Maxi-
mum and Minimum filters. The Maximum filter adds light to shad-
ows. The Minimum filter shrinks light areas.

When you apply these filters, Canvas compares each pixel to its 
neighbors within the radius you specify, then replaces it with the 
lightest or darkest pixel in the group. 

Isolating images with the 
High Pass filter

For more information, see 
“Understanding image chan-
nels” on page 361.

1 With an image in edit mode, 
choose Select All and then 
choose Copy in the Edit 
menu.

2 Choose Channels in the Ima-
ge menu. Create a new 
channel by clicking the but-
ton in the lower-left corner of 
the Channels palette. 

3 Click the new channel and 
choose Paste in the Edit 
menu.

4 Choose Filter➤Other➤High 
Pass in the Image menu and 
enter a radius value. 

5 Choose Adjust➤Threshold 
in the Image menu. Adjust 
the threshold until you out-
line the areas you want. 

6 Paint areas white to include 
them in the selection. Fill the 
rest of the image with black.

7 Click the composite channel. 
Choose Select➤Load in the 
Image menu to load the 

channel and select an area. 

8 In this example, the image 
was finished by choosing 
Select➤Inverse in the Image 
menu and applying a Gauss-
ian blur of 3.0 pixels.

Original Image High Pass filter Threshold filter

Editing with 
painting tools

Finished alpha 
channel

Isolated subject

✔ Tip
To manually apply a choke or 
spread to an image, use the 
Maximum or Minimum filters in 
a color channel.

Original Maximum 4 pixels Minimum 4 pixels
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To use the Minimum and Maximum filters

1 With an image in edit mode, select an image area. If you do not 
make a selection, Canvas filters the entire image.

2 To maximize the light areas in an image, choose 
Filter➤Other➤Maximum in the Image menu and enter a radius 
from 1 to 16 pixels. 

3 To minimize the light areas in an image, choose 
Filter➤Other➤Minimum in the Image menu and enter a radius 
from 1 to 16 pixels.

4 Turn on Preview to check the settings and then click OK. 

Filling selections with color
The Filter➤Other➤Fill command in the Image menu lets you quickly 
and uniformly fill a selection with the foreground or background 
color, black, white, or gray. In addition, you change the opacity and 
transfer mode of the color.

To fill a selection with a color

1 With an area of an image selected, choose Filter➤Other➤Fill 
in the Image menu.

2 In the Fill dialog box, choose a color to fill the selection with in 
the Use pop-up menu.

3 To make the color appear transparent, set the Opacity level to 
less than 100%.

4 To use a different transfer mode effect, choose an option in the 
Mode pop-up menu. See “Using transfer modes with painting 
tools,” page 313.

5 Click OK to fill the selection.

Creating your own image filters
You can create your own special-effect and image-correcting filters 
using the Custom command. You can also save custom filters and 
use them in future Canvas documents. 

Filters work with an image one pixel at a time. Using a mathematical 
formula and the color values of pixels within a specified radius, fil-
ters assign each pixel a new color value. In a custom filter, you sup-
ply the numbers the filter uses to calculate the new color values.
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The same filter can produce different effects in other images. To get 
the most out of custom filters, spend time experimenting.

To use Custom filters

1 With an image in edit mode, select an area of the image. If you 
don’t make a selection, Canvas filters the entire image.

2 Choose Filter➤Other➤Custom in the Image menu to open the 
Custom dialog box. 

3 In the configuration grid, type a value from -999 to 999 in as 
many boxes as you want. Canvas ignores blank boxes.

4 Enter a Scale value from 1 to 9,999. To retain the general 
appearance of the original image, the scale should equal the sum of 
the entries in the configuration grid. For example:

Grid entries Sum Scale

2  2  1  -1  -1  3 2+2+1-1-1+3=6 6

-15 7 4 -3 2 8 -15+7+4-3+2+8=3 3

Custom filter Blurred image Custom filter Embossed 
image

Original

Configuration grid 
Original pixel
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5 Enter an Offset value from -9,999 to 9,999. Positive values 
increase the brightness of the final outcome while negative values 
decrease the brightness.

6 Turn on the Preview option to check the filter effect. When the 
settings are correct, click OK.

◆ To save a custom filter: In the Custom dialog box, enter the fil-
ter settings and click Save. Enter a name and location for the filter 
and click Save. 

◆ To load a custom filter: In the Custom dialog box, click Load. 
In the dialog box that appears, locate the filter and click Open. 

Combining image channels
You can combine image channels with the Calculate command to 
create effects such as embossing text in an image. By adding, sub-
tracting, and multiplying channels, you can also enhance shadows 
and highlights. 

The Calculate command combines corresponding pixels from two 
channels by the method you choose. You can place the result in a new 
or existing channel. 

To combine channels

1 With an image in edit mode, choose Calculate in the Image 
menu.

2 Choose the first channel in the Source 1 pop-up menu. If you 
want to invert the channel, turn on Invert. For more information, 
see “Inverting colors in images” on page 372.

3 In the Source 2 pop-up menu, choose the channel you want to 
combine with the first channel. If you want to invert the channel, 
turn on Invert. 

4 In the Blending area, choose a method in the Use pop-up menu. 
See “Descriptions of Calculate blending options,” next. 

5 Enter an opacity from 0 to 100 percent for Source 1. Other 
options are available for some Blending methods. For more infor-
mation, see “Descriptions of Calculate blending options” on 
page 399.

6 If you want to mask Source 1, turn on Mask in the Blending 
area. Then choose a channel in the pop-up menu. To invert the 
mask, turn on Invert in the Blending area.
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7 Choose a destination channel or New in the Result pop-up 
menu. If you select an existing channel, Canvas replaces all con-
tents of the existing channel with the results of the calculation.

8 Turn on the Preview option to check the results of the calcula-
tion. When the settings are correct, click OK.

Descriptions of Calculate blending options

You can select various blending 
methods in the Calculate 
Image dialog box. 

Normal. Places Source 1 over 
Source 2 at the specified opaci-
ty. 100 percent opacity replaces 
Source 2 with Source 1.

Multiply. Creates a darker chan-
nel than the source channels. 
Black areas in either source cre-
ate black areas in the resulting 
channel. White areas do not 
affect the result. 

Screen. Creates a lighter chan-
nel than the source channels. 
White areas in either source cre-
ate white areas in the resulting 
channel. Black areas do not 
affect the result.

Overlay. Places Source 1 over 
Source 2 without destroying 
the shadows or highlights of 
Source 2. 

Soft Light. Lightens or darkens 
pixels in Source 2 depending on 
the brightness value of the cor-
responding pixels in Source 1. 
Pixels in Source 1 that are light-
er than 50% black lighten 
Source 2. Pixels in source 1 that 
are darker than 50% black dark-

en Source 2.

Hard Light. Lightens or darkens 
pixels in Source 2 depending on 
the brightness value of the cor-
responding pixels in Source 1. 
Hard Light works similarly to 
Soft Light. However, black in 
Source 1 produces black in the 
resulting channel and white pro-
duces white.

Darker. Replaces pixels in 
Source 2 with the correspond-
ing pixels in Source 1, if the pix-
els in Source 1 are darker.

Lighter. Replaces pixels in 
Source 2 with the correspond-
ing pixels in Source 1, if the pix-
els in Source 1 are lighter.

Add. Creates a lighter channel 
than the source channels. Add is 
similar to Screen but usually 
produces a higher-contrast 
image. 

If you select the Add option, 
you can enter a Scale value from 
1 to 2 with a precision of three 
decimal places. To calculate 
the average brightness value of 
two channels, choose Add and 
enter a Scale of 2.

You can brighten or darken the 

resulting channel by specifying 
an Offset value. To lighten the 
overall image, enter an offset 
from 1 to 255. To darken the 
image, enter an offset from -1 to 
-255. 

Subtract. Creates a darker 
channel than the source chan-
nels. Subtract is similar to Multi-
ply. However, corresponding 
pixels of the same color pro-
duce black in the resulting chan-
nel. 

If you select the Subtract 
option, you can enter a Scale 
value from 1 to 2 with a preci-
sion of three decimal places. 

You can brighten or darken the 
resulting channel by specifying 
an Offset value. To lighten the 
overall image, enter an offset 
from 1 to 255. To darken the 
image, enter an offset from -1 to 
-255. 

Difference. Compares the color 
value of each pixel in Source 1 
with the corresponding pixel in 
Source 2, subtracts the darker 
value from the lighter, and then 
uses this difference in the result-
ing channel.
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Examples of Calculate blending options

Source 1 Source 2 Multiply

Screen Overlay Soft Light

Hard Light Darker Lighter

Add Subtract Difference
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Creating an embossed image effect
You can use the Calculate command to apply shadows and highlights 
that create the illusion of objects or type imprinted in an image. The 
following procedure outlines the steps for creating this embossed 
effect. For this example, we used a 72-ppi image to demonstrate the 
concepts; other image types and resolutions might require slightly 
different procedures. 

1 With a 72-ppi paint object in edit mode, choose Show Chan-
nels in the Image menu.

2 Create a new channel by pressing the right-arrow button in the 
Channels palette and choosing New Channel in the menu. In the 
dialog box that opens, type “Original Text” in the Name text box 
and choose Masked Area in the Color Indicates area. Click OK. 

3 Click the Original Text channel in the Channels palette to 
make it active.

4 Select the Text tool, click the I-beam in the image, and begin 
typing. Press Enter (Mac) or Esc (Windows) when you finish (see 
“To set type within images” on page 328). Canvas creates a selec-
tion from the characters you typed.

5 Choose Filter➤Other➤Fill in the Image menu. In the Use pop-
up menu in the Contents area, choose White. Set Opacity to 100, 
and choose Normal in the Mode pop-up menu. Click OK; Canvas 
fills the selection with white.

6 Press Esc to deselect the characters you just filled with white.

7 In the Image Channels palette, make a copy of the Original 
Text channel by dragging the channel to the New Channel icon at 
the bottom left of the palette. Canvas creates a channel called 
“Original Text copy.”

8 Double-click “Original Text copy” to open the Channel 
Options dialog box. Rename the channel “Blurred Text.” Click OK.

9 Choose Filter➤Blur➤Gaussian Blur to soften the text slightly. 
For our image, we used a Gaussian blur radius of 2 pixels.

10 Choose Filter➤Other➤Offset in the Image menu and set the 
Horizontal Offset to 5 and the Vertical Offset to 3. Choose “Repeat 
Edge Pixels” under Undefined Areas and click OK.

11 Choose Calculate in the Image menu. For Source 1, choose 
Original Text. For Source 2, choose Blurred Text. In the Blending 

Embossed text effect
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pop-up menu, choose Subtract, and set Opacity to 100, Scale to 1, 
and Offset to 0. In the Result pop-up menu, choose New. Click OK.

12 Name the newly-calculated channel “Shadow” using the Chan-
nel Options dialog box, as you did in step 8. Make sure that Masked 
Area is selected in the Color Indicates area.

13 Click the Blurred Text channel in the Channels palette. Choose 
Filter➤Other➤Offset in the Image menu and set the horizontal off-
set to -7 and the vertical offset to -4. Click OK.

14 Choose Calculate in the Image menu. For Source 1, choose 
Original Text. For Source 2, choose Blurred Text. In the Blending 
pop-up menu, choose Subtract and set Opacity to 100, Scale to 1, 
and Offset to 0. In the Result pop-up menu, choose New. Click OK.

15 Name the channel you just created “Highlight.” Again, make 
sure that Masked Area is selected in the Color Indicates area.

16 Click the composite channel (the first channel in the list) in the 
Image Channels palette to make it active.

17 Option-click (Mac) or Alt-click (Windows) the Shadow chan-
nel to load the channel as a selection. You can also choose 
Select➤ Hide Edges in the Image menu to hide the marching ants.

18 Choose Filter➤Other➤Fill in the Image menu. In the Use pop-
up menu in the Contents area, choose Black. Turn on the Preview 
option. Choose Normal in the Mode pop-up menu. Adjust the 
Opacity value until you get a shadow effect that you like. Click OK; 
Canvas adds the shadow to the image.

19 Option-click (Mac) or Alt-click (Windows) the Highlight 
channel to load the channel as a selection. Choose Select➤ Hide 
Edges to turn off the marching ants.

20 Choose Filter➤Other➤Fill in the Image menu. In the Use pop-
up menu in the Contents area, choose White. Turn on the Preview 
option. Choose Normal in the Mode pop-up menu. Adjust the 
Opacity value until you get a highlight effect that you like. Click 
OK; Canvas adds the highlight to the image.

You’ve now created an embossed text image effect. Press Esc twice 
to deselect the highlight area and end paint edit mode.
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GLOSSARY

ACTIVATE To make a window active by clicking anywhere in it.

ACTIVE WINDOW The window with the program’s focus, usually in 

front. Tools and commands work in the active window.

ALERT BOX A box that appears on the screen to give a warning or 

to report an error message.

ALPHA CHANNELS A grayscale duplicate of an image on which 

you can store masks and selections.

ANCHOR POINT The starting or ending point of a path segment. 

Anchor points appear only when an object is in edit mode. 

When selected, anchor points of curve segments display one 

or two direction lines.

ANSI  American National Standards Institute. One of the standards 

available to specify dimension object properties. 

ANTI-ALIAS To soften the edges of an applied brush stroke, effect 

or selection. When something is anti-aliased, the color on the 

edges fades to transparency instead of stopping abruptly. 

ASCII Acronym for American Standard Code for Information 

Interchange (pronounced “ASK-ee”). ASCII is used for rep-

resenting text inside a computer and for transmitting text 

between computers.

BASELINE An imaginary line on which a line of text rests. The 

descenders of characters such as g, j, and p extend below the 

baseline.

Anchor point

Anti-aliased line

b a s e l i n e
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BEVEL JOIN A style of connection between two segments in a vec-

tor object, in which the stroke lines appear to be trimmed 

diagonally.

BÉZIER CURVE A curve, named after French mathematician Pierre 

Bézier, defined by the position of anchor points and tangent 

lines.

BIND To align the baseline of text so it follows the contours of a 

path.

BITMAP A digital image composed of pixels; technically, an image 

containing only black and white. See also Image.

BITMAPPED FONT A font made up of characters composed of pix-

els, rather than vector data. Fonts displayed on a computer 

screen are bitmapped fonts, for example, and usually aren’t 

suitable for printing.

BLACK AND WHITE A method of digital imaging that uses pure 

black and pure white pixels. The frequency of black or white 

pixels create the illusion of shades.

BLEND A smooth transition of shape and color between two vector 

objects through intermediate objects created by Canvas.

BOUNDING BOX An invisible rectangle that defines the boundaries 

of an object. Canvas displays an object’s bounding box when 

the object is selected.

BULLET A special text character, usually a filled circle (•), avail-

able in many fonts, especially symbol fonts.

BUTTON A pushbutton-like image in dialog boxes where you click 

to designate, confirm, or cancel an action.

CANVAS TEMPLATE A Canvas document that includes options and 

settings and is used as the basis for new documents. 

CCITT (Consultative Committee on International Telegraphy and 

Telephony); its standards include data transmission formats.

Bevel join

Vector (left) and bitmapped 
fonts

R

Bounding boxes 
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CD-ROM Acronym for compact disc read-only memory; a compact 

disc 120 mm (4.72 inches) in diameter that can store 550 MB 

of information. The disc is “read-only” memory because a 

drive can read the information but can’t record information.

CENTER EXTENSION The distance that Center dimension lines 

extend beyond the dimensioned object.

CENTER GAP The space between a Center dimension crosshair and 

the lines that extend from it.

CENTER LENGTH The Center dimension crosshair length.

CHANNEL In digital images, a layer of primary color in a full-color 

image. For example, an RGB image has at least three color 

channels (one each for red, green, and blue) and a composite 

channel, which adds the three channels together to create a 

full-color image.

CHARACTER Any symbol, such as letters, numbers, and punctua-

tion, that can convey information. Some characters can be 

displayed on the monitor screen and printed on a printer.

CHARACTER STYLE A set of attributes, such as color, typeface, and 

style, that can be applied as a group to text characters.

CHOOSER A Mac OS desk accessory that lets you connect to and 

disconnect from network and peripheral devices, such as 

printers and file servers.

CLICK (v.) To position the pointer on something, and then press 

and quickly release the mouse (or other pointing device) but-

ton. (n.) The act of clicking.

CLIP ART Electronic pictures that you can use in documents. The 

term comes from using scissors to clip pictures on paper.

Center length, center gap, 
center extension 
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CLIPBOARD A holding place in system memory for the last infor-

mation cut or copied from a document. You can paste infor-

mation from the Clipboard into a document. Information 

remains on the Clipboard until replaced by another cut or 

copied selection.

CLOSED PATH A vector path that does not have separate starting 

and ending points.

CMYK COLOR A color system based on the four colors used in 

color printing: cyan, magenta, yellow, and black. Also, a 

color mode used to define colors in a digital image. See Pro-

cess Color.

COLOR PALETTE A collection of colors used in a document, from 

which you can select colors to apply.

COLOR SEPARATIONS Computer files, printed output, or film, in 

which the colors in a document are divided into their primary 

or custom color components. Color separations are used to 

produce printing plates for commercial color printing. See 

Process Color and Spot Color.

COLOR WHEEL A two-dimensional view of color showing hue and 

saturation. Hue is the position of a color on the circumference 

of the wheel. Moving clockwise and starting at twelve 

o’clock, the colors are yellow, red, magenta, blue, cyan, and 

green. Colors toward the center of the wheel have more gray 

than those near the edge.

COMMAND KEY On Mac OS system keyboards, a key (usually 

with a propeller symbol and sometimes labeled “Command”) 

that modifies an action when pressed.

COMPOSITE CHANNEL The combination of all color channels in an 

image. In the Channels palette, the first channel listed, identi-

fied by RGB, CMYK, LAB, or Black, depending on the 

image mode.

Closed paths
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CONTROL KEY A keyboard key, usually marked “Ctrl,” that modi-

fies an action when pressed.

CONTROL PANEL A Mac OS or Windows system program that lets 

you change features of the operating system, such as settings 

for the display, keyboard, and networking.

CORNER POINT An anchor point where path segments meet at an 

angle, rather than with a smooth transition.

CROP To trim an image to a specified rectangular area.

CROP MARKS Small lines placed at the page edge that mark where 

printed material will be trimmed.

CURRENT INK The ink, or color, that applies to new objects you 

draw, set by applying an ink when no objects are selected; 

this setting does not change when you set the ink for a spe-

cific object. For example, if you set the current fill ink to red, 

new objects you draw will be filled with red; if you then 

change an object’s color from red to green, however, the cur-

rent ink remains red.

CURRENT STROKE The stroke that applies to new objects you draw, 

set by applying a stroke when no objects are selected; this set-

ting does not change when you set the stroke for a specific 

object. For example, if you set the current stroke to a 5-point 

pen, new objects you draw will have a 5-point pen width; if 

you then change an object’s stroke from 5 to 10 points, how-

ever, the current pen width remains 5 points.

CUSTOM VIEW A recording of a screen position and magnification 

level in a Canvas document. 

DECIMAL TAB A tab, represented by a decimal tab marker, that 

aligns columns of numbers at the decimal point position.

DESATURATE To increase the gray content of a color.

DIALOG BOX A box that an application displays to request infor-

mation or to report that it is waiting for a process to complete. 

Corner point
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DIMENSION OBJECT Object created with the Dimensioning tool.

DIMENSION TEXT GAP The space between the dimension text and 

arrow.

DIN STANDARD (Deutches Institut für Normung) standard; one of 

several used to specify the properties of dimension objects.

DIRECTORY DIALOG BOX A type of dialog box you use to navigate 

a computer file system when you save or open a file.

DITHER To arrange pixels of several colors into patterns to give the 

appearance of a broader range of colors.

DOCUMENT The container for information and objects you work 

with in Canvas. Canvas has three types of documents — 

illustration, presentation, and publication.

DOT GAIN In commercial printing, the amount of size increase of 

halftone dots caused by ink spreading on the printed medium.

DOUBLE-CLICK (v.) To press and release the button on a mouse (or 

other pointing device) twice in quick succession.

DPI Abbreviation for “dots per inch,” the unit of measurement of 

the resolution of a printing device.

DRAG To press and hold down the button on a mouse (or other 

pointing device), move the device, and then release the but-

ton.

EMULSION Photosensitive coating on film or paper.

ENCAPSULATED POSTSCRIPT (EPS) A format for storing graphics 

and text in a file using the PostScript language. An EPS file 

can include a preview image. See PostScript.

ESC KEY A keyboard key that lets you stop a procedure. 

EXTERNAL TOOLS Individual program modules that provide fea-

tures, tools, and commands in the Canvas program.

 0.37 ' 

 1.00 ' 

Dimension objects
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FADE Gradual decrease of a painting tool effect until there is no 

noticeable change in the image. For example, if “Fade Size 

within 32 steps” is selected in the Paintbrush manager, the 

brush becomes smaller as you drag. 

FILE Any named, ordered collection of information stored on a 

disk.

FILL INK The ink that Canvas applies to the inside, as opposed to 

the outline, of objects and text.

FLAT END CAP A style of stroke end in which the stroke end is 

squared off, perpendicular and flush to the end of the stroke.

FLOATING SELECTION An image area that “floats” above an image. 

You can move and edit the floating selection without chang-

ing the underlying image until you defloat, or “drop,” the 

selection on the image.

FONT A complete set of characters in one design, size, and style. 

In typography, a font can be restricted to a particular size and 

style (such as 10-point Helvetica) or can comprise multiple 

sizes, or multiple sizes and styles, of a typeface design.

FOLDER A container for documents, applications, and other folders 

in the Mac OS and Windows file systems.

FRAME A technical term for the outline of an object or text, to 

which Canvas applies stroke settings, such as dashes.

GAMUT The range or extent of a color model’s spectrum. 

GRADIENT A gradual transition or blend between two or more col-

ors. The direction and shape of a gradient can be radial, lin-

ear, elliptical, or shape-derived.

GRAYSCALE An image mode that uses eight bits of information per 

pixel for up to 256 brightness levels, from black to white 

through shades of gray.

GROUP (v.) To associate two or more objects so they behave as a 

unified object; (n.) the resulting object.

Flat end cap

Folders (Mac OS)
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GUIDES Non-printing lines to which objects can be aligned.

HALFTONE A pattern of tiny black and white dots that appear to 

the human eye as shades of gray; a photograph or other image 

converted to such a pattern for commercial printing.

HANDLES (1) Small squares, usually at the corners and midpoints 

of an object’s bounding box, displayed when an object is 

selected; you can drag handles to resize the object. (2) Small 

circles at the ends of tangent lines; you can drag a handle to 

change the length or angle of a tangent line.

HATCH PATTERN Object-based fill pattern made of line groups.

HIGHLIGHT To make something visually distinct. For example, 

when you select a block of text in Canvas, the selected text 

appears against a colored background.

HUE A color’s main characteristic; its name, as in blue, red, or 

orange, defined by its position on the color wheel.

I-BEAM A type of pointer shaped like the capital letter “I.” 

ILLUSTRATION AREA The rectangular area on screen in a Canvas 

illustration document, which represents the extent of the illus-

tration and may cover multiple printed pages, depending on 

the size of paper used for printing.

IMAGE A picture composed of pixels; sometimes referred to as a 

“raster image,” “paint image” or “bitmap.” See Image Mode.

IMAGE MODE The system used to define colors in an image. Can-

vas image modes include Black and White, RGB Color, 

CMYK Color, Grayscale, Indexed, and LAB Color.

IMPORT To use any of several techniques to move graphics or text 

from another program into a Canvas document.

INDEXED A digital image mode that lets you specify a palette of up 

to 256 colors used in the image. Usually used for on-screen 

display and electronic distribution of images, because it 

requires less memory than RGB or CMYK color modes.

Tangent line handles

Illustration area
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INK Colors, symbols, hatch patterns, textures, and gradients that 

can be applied to objects.

INSERTION POINT A blinking vertical line where text you type will 

appear in a text object or dialog box.

ISO STANDARD  (International Organization for Standardization); 

one of several standards used to specify the properties of 

dimension objects.

JIS STANDARD (Japanese Industrial Standard) standard; one of 

several used to specify the properties of dimension objects.

JUSTIFICATION The method used to align paragraphs of text within 

a text object’s margins, either left, right, center, or full.

KERNING Adjusting the normal space between characters in text; 

also, the amount of the adjustment.

LAB COLOR An image mode in which the color components are 

divided into a lightness channel and A and B color channels.

LANDSCAPE Orientation of an illustration or page that is wider 

than it is tall.

LAYER A level in a Canvas document used to organize parts of 

illustrations so they can be easily selected.

LEADER CHARACTER A character, usually a period (“.”) used to fill 

space between the character before a tab space and the char-

acter immediately following the tab space.

LEADER CHARACTER LENGTH The length of the horizontal portion 

of the witness line of a dimension object.

LEADING Space between lines of text, measured in points from the 

baseline of one line to the next.

LIGHTNESS The amount of black or white in a color.

LINE GROUP A set of parallel lines in a hatch pattern that have 

identical properties.

Insertion point

Text without kerning (top) and 
with kerning applied (bottom)

 2.30  pica 

Leader character length
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LINE CAP The shape of the end of a pen stroke.

LINE JOIN The shape of the pen stroke where two path segments 

meet. 

LPI Abbreviation of “lines per inch,” a measure of halftone screen 

resolution.

MAC OS The Apple Computer operating system used on Macin-

tosh and on compatible personal computers.

MACRO OBJECT A vector object that can be used to place copies of 

itself in documents; the copies remain linked to the original.

MARQUEE A selection in an image defined by a rectangular flash-

ing border; also, the tool used to make a marquee selection.

MASTER PAGE A special page in a publication document. Items on 

the master are visible and print on every page in the docu-

ment.

MASK To use a vector or text object to selectively show portions of 

another object behind it.

MASTER SLIDE A special slide in a presentation document. Items 

on the master slide are visible and print on every slide in the 

document.

MEGABYTE (MB) A unit of measurement equal to 1024 kilobytes, or 

1,048,576 bytes.

MEMORY A hardware component of a computer system that can 

store information for later retrieval.

MITER JOIN A style of connection between two segments in a vec-

tor object in which the stroke lines fit together to form a 

point.

MODIFIER KEY A general term for a key that changes the meaning 

of other keys or mouse actions; for example, Command, Con-

trol, Option, and Shift.

Text used to mask a photo 

Miter join
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NTSC (National Television Standards Committee); the standard 

video format defined by the NTSC, also called composite 

because it combines all the video information, including 

color, into a single signal.

OBJECT A discrete vector path, block of text characters, or raster 

image, contained within an invisible rectangular frame. You 

can select an object and perform standard operations on it, 

including move, copy, delete, cut, rotate, flip, and skew.

OPACITY The amount of transparency of a brush stroke, filter or 

channel calculation. At 100% opacity, the applied effect com-

pletely covers the background image. Lower opacity levels 

allow the original image to show through.

OPEN PATH A path defined by separate starting and ending points.

OPTION KEY A Mac OS keyboard modifier key, usually labeled 

“Option.”

OUTSIDE LINE LENGTH Dimension object arrow length, when the 

Arrows Inside option is not selected.

OVERPRINT A technique where two or more colors are printed on 

top of each other. For example, if you overprint yellow on 

blue, the combination appears green.

PAINT OBJECT An object that contains a raster image. The term 

was used in earlier Canvas versions and is synonymous with 

image object.

PAINTING TOOL Any of several tools used to create or edit a paint 

object.

PALETTE A type of dialog box that can remain open on screen. A 

palette contains tools, attributes, or options for commands.

PALETTE ICON A toolbox icon that opens a palette.

PARAGRAPH STYLE A set of attributes, such as font, leading, 

indents, and tab settings, that can be applied to a paragraph of 

text.

 0.50 ' 

Outside line length
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PATH One or more connected segments, generally created with a 

drawing tool, within a vector object. The path itself is invisi-

ble unless it has visible fill ink, or pen ink and stroke, applied 

to it.

PEN INK The colors and patterns applied to an object’s stroke.

PICA A unit of measurement equal to 12 points or 1/6 of an inch, 

abbreviated “pc.”

PIXEL Short for picture element; a single tiny dot of a raster image 

or a computer display.

PLUG-IN A program module that can be used by Canvas to provide 

an additional image-editing function.

POINT A unit of measurement for type equal to 1 ⁄72 inch; abbrevi-

ated “pt.”

POINTER A small shape that follows the movement of the mouse 

on screen or shows where your next action will take place. 

The pointer can be an arrow, an I-beam, or other shapes.

PORTRAIT The orientation of a page or illustration so that the 

height is larger than the width.

POSTSCRIPT® (1) An Adobe Systems, Inc. computer language that 

defines the appearance of printed type and images. (2) A type 

of font that relies on PostScript to be printed.

POSTSCRIPT PRINTER DESCRIPTION (PPD) A text file that provides 

information about a specific printer to the operating system 

and application programs.

PPI Pixels per inch, a measure of the resolution of an image.

PRESS (1) To point to an item on screen and press and hold down 

the mouse button without moving the mouse. (2) To push a 

key down and then release it; you hold a key down only when 

using a modifier key with another key, for example, when 

instructed to press Ctrl+A.
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PRINTER DRIVER A program that controls the exchange of informa-

tion between the computer and a specific type of printer.

PROCESS COLOR The method for printing a full range of colors 

using only cyan, magenta, yellow, and black; also, any one of 

these colors. Compare to Spot Color.

QUICKDRAW The part of the Mac OS operating system that per-

forms graphic operations for display, printing, and data 

exchange.

RANDOM-ACCESS MEMORY (RAM) The part of the computer’s 

memory that stores information temporarily while you’re 

working on it.

RASTER IMAGE A picture made up of a matrix of pixels, created by 

digitizing or scanning an image, which is contained in a paint 

object.

REGISTRATION MARK A small mark, several of which are used 

together to align films and plates for commercial printing.

RGB COLOR Method of defining colors, based on combinations of 

the primary colors, red, green, and blue. Also, a color mode 

for digital images.

RESOLUTION A measure of the amount of information in a digital 

image, expressed in pixels per inch (ppi); also, a measure of 

the smallest dot or pixel that can be used by a computer dis-

play or output device, expressed in dots per inch.

ROUND END CAP A style of stroke end, in which the end of the 

stroke is capped with a semicircle.

SATURATE To increase color intensity by removing gray.

SCANNER Any input device that converts printed matter, such as a 

photographic print or transparency, into digital data.

Registration mark

Round end cap
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SHIFT-CLICK A technique that allows you to extend or shorten a 

selection by positioning the pointer at the end of what you 

want to select and holding down the Shift key while clicking 

the mouse button.

SHIFT KEY A key that, when pressed, causes the subsequent letter 

you type to appear in uppercase or the top symbol on a two-

character key to be produced. The Shift key can also modify 

mouse actions.

SEGMENT A line or curve between two endpoints in a path.

SELECTION The information or items that will be affected by the 

next command, including objects or a series of characters.

SELECTION BOX A dashed rectangle that appears as you drag a 

Selection tool over objects to select them.

SEPARATIONS See Color Separations.

SLIDE SHOW The display of different screens of information — 

“slides” — in sequence. Canvas changes the screens after a 

set time interval or when you click the mouse.

SMART POINTER A pointer symbol representing the Smart Mouse 

constraint that is in effect.

SMOOTH POLYGON A polygon with rounded segments and cor-

ners.

SNAP GRID A grid of horizontal and vertical lines you can display. 

The pointer can snap into alignment with the snap grid.

SOURCE LINE Dotted line that points to the part of the object defin-

ing a Smart Mouse constraint that is in effect.

SPACEBAR The long, unlabeled bar in the bottom row of keys on a 

computer keyboard that you press to insert space between 

characters.

SPOT COLOR Customized color representing a particular ink that 

will be used to print the color. Compare to Process Color.

Path segment
8 SHIFT-CLICK / SPOT COLOR



SQUARE END CAP A style of stroke end, in which the end of the 

stroke is squared off and extends half the line width beyond 

the endpoint of the path.

STATUS BAR The area at the bottom of the Canvas window or the 

screen the displays information on tools, the position of the 

pointer, and selected objects.

SYMBOL INK A repeating pattern, created from vector objects, that 

can be applied to vector objects and text as a fill ink or stroke 

ink.

TAB KEY A keyboard key that moves the insertion point to the next 

tab marker, or to the next place to enter information in a dia-

log box. The Tab key is also used as a modifier key.

TANGENT LINE Line passing through an anchor point on a vector 

path; visible when the path is in edit mode and an anchor 

point with tangent lines is selected. Its angle and length 

affects the shape of adjacent segments.

TEMPLATE See Canvas Template.

TEXT OBJECT An object containing text.

TEXT BOX A place in a dialog box where you can type information.

TEXT FILE A file that contains information stored in the form of 

readable characters encoded in ASCII format.

TEXTURE INK A repeating pattern, created from a raster image, that 

can be applied as a fill ink or pen ink.

TILING Dividing a large illustration into multiple pages, or “tiles,” 

for printing on a desktop printing device. You can select the 

Tile option in the Page Setup (Mac OS) or Printer Setup 

(Windows) dialog box, or in the Print dialog box.

Square end cap

Tangent lines

Tiling for printing
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TOLERANCE In image editing, a value setting the threshold for sim-

ilarity between colors before an effect occurs. For example, if 

the Wand tool tolerance is set to 0, it selects only pixels of the 

exact same color. If the tolerance is set higher, the tool selects 

pixels of similar colors.

TOLERANCE DOWNSPACE Amount of space (leading) between tol-

erance text in dimensions with two tolerance measurements.

TOLERANCE TEXT SCALE  Size of tolerance text in a dimension in 

proportion to the dimension text.

TRANSFER MODE Method by which a color blends with a back-

ground color. Transfer modes include Dissolve, Multiply, 

Screen, Lighten, and Saturation.

UNGROUP Use the Ungroup command to divide a group object 

into its original component objects.

VECTOR OBJECT An object containing a path or a shape drawn 

with the Multigon, Spiral, or another specialized drawing 

tool. 

WINDOWS (1) The brand name of a family of Microsoft operating 

systems, including Windows 95 and Windows NT. (2) The 

separate areas on screen in which programs display informa-

tion.

WITNESS EXTENSION Witness line part extending past dimension 

arrows.

WITNESS GAP Space between an object and dimension witness 

lines.

WRAP To change text margins so text flows around or remains 

inside a vector object.

X-HEIGHT The height of a lowercase x in a given font; the height, 

measured from the base line, of the main portion of most low-

ercase letters in a font, excluding ascenders and descenders.

ZOOM To increase or decrease the magnification of a document.

 0.38 ' 

 0.80 ' 

Witness extensions
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