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Welcome

Leave your fears behind!

Now it’s time to get your feet wet with digital paint and get creative! Welcome to a
world of unparalleled creative freedom. Fasten your wings and get ready to fly! In my
Power Tools class and my User Conference session | will share with you fun, simple and
effective art exercises you can do on your personal computer that will empower you to
fully express yourself on the digital canvas. This workbook was designed to accompany
the Power Tools class. | have decided to share it with all User Conference attendees to
give you some ideas to try out. If you’d like to follow up with an in-depth hands-on
class please visit my educational web site http://www.paintercreativity.com where
you’ll find details about my forthcoming classes (including an introductory class
February 7 - 11 here in San Francisco).

What’s Included on the CD

You will find three other files included on the Macworld User Conference CD along
with these notes—two PDF files, excerpts from my new book Painter IX Creativity:
Digital Artist’s Handbook, and a QuickTime movie, an excerpt from my new 4-DVD set
Painter IX Simplified for Photographers (supplied with a bonus DVD Unleashing Your
Creativity!) You can order the book and DVDs from my paintercreativity.com web site
or by filling in the Order Form on page 24 of these notes.

Celebrate the Unexpected!

Let go of any preconceptions about making art. Enjoy an open-minded approach to
creating and transforming your imagery. Think beyond just applying a single effect or
technique. Entering a journey of continual transformation. Every image suggests its
own path as you experiment and improvise and generate variations. Listen to your
intuition, allow yourself to be spontaneous, embrace serendipity and treat every
unexpected result as an opportunity to explore a new direction.

Laboratory for Experimentation

Treat working in Painter as a wonderful opportunity for you to stretch yourself
creatively on every level. If you are new to Painter enjoy your voyage of discovery as
you try out the amazing Painter brushes. If you are already a Painter user then try new
brushes you haven’t used before. Be bold. Have fun and enjoy!

Enjoy the journey and welcome aboard.
Happy painting!

Cheers,




Nine Ways...

...to Get the Most Out of Class

1. Be on time

Be committed to being back from breaks on time. This will ensure you will not miss
anything important and allow the class to progress more efficiently.

2. Be present

Be fully present. Let go of worrying about everyday life. Allow yourself to be
immersed in creativity! Please turn off cell phones unless you need to be on call.

3. Be organized

Organize your folders and name your files consistently. Back up and archive your
work after the class onto CDs or DVDs.

4. Make notes

When you come across questions please write them down. When you find a
particular brush variant you really love, make a note of it. You will find these
notes an invaluable source of reference information at a later date.

5. Ask questions

Ask questions! There’s no such thing as a dumb question.

6. Learn from each other

We are all privileged to have the opportunity to learn from each other. There is a
huge pool of shared experience, knowledge and talent in this classroom. Take
advantage of it. Look at other people’s work. Introduce yourself to other students.
Talk to each other. Help each other.

7. Be bold

Take risks—think bold, be bold.

8. Don’t try to remember everything

You will retain what you need. Focus on remembering the underlying basic
principles rather than steps.

9. Have FUN!!

It’ll be difficult not to...



Inspirations and Goals

Sharing Your Story

“In welcoming students to a recent three day workshop, | greeted then with these
words: “Day one, we study spelling. Day two, we write a sentence. Day three, we
write a novel.”

“My students laughed. After all, this was a painting workshop. Yet, my choice of words
was accurate, because art is a language. What is most important is what you want to

say—what story and point of view you want to share.”
Hongnian Zhang, The Yin/Yang of Painting

My goal in taking this class is:
| am inspired by:

What | want to convey or share in my art is:

My goal in creating art is:



Key Tools

Computers can be intimidating, especially when all you want to do is paint! We
start off this session setting up the preferences and getting familiarized and
comfortable with the main tools in your digital art studio. You’ll learn how to
adjust your tablet and Painter for optimum efficiency. You’ll learn how to
access and control the brushes and art materials in Painter. Our goal here is to
get so comfortable with the tools that they ‘disappear’ and you can realize
your full creative potential.

Let’s start by considering the three main tools that form the foundation of your
digital art studio—your computer, tablet and software.

Tool #1 : Your Computer

Whether you are working on a Macintosh or Windows machine, you will have
the most creative power at your fingertips with the fastest, most RAM-filled
computer you can afford, plus with a lot of free hard drive storage space. |
recommend you use the most recent operating system.

Tool #2 : Your Tablet

You will need a pressure sensitive tablet. There are two models | particularly
recommend if you want the best tools for the job. They are the Wacom Intuos3
6x8 tablet or the Wacom Cintiq 18SX LCD tablet. The Cintiq has a built in LCD
display so you paint directly on the screen. This is very intuitive, though the
unit is considerably more expensive than the Wacom Intuos3 6x8 tablet. The 6
X 8 is compact and convenient, though it does not have a screen built in. The
technical details for setting up the tablet and the driver are covered in the
Chapter 1 (Foundation I: Getting Started) extract (included in the Conference
CD) from my new book, Painter IX Creativity: Digital Artist’s Handbook.

Tool #3 : Your Software

Your digital art studio needs two main pieces of software— (i) Adobe Photoshop
CS, primarily for image preparation, manipulation and printing, and (ii) Corel
Painter IX, the heart and soul of your art studio. If you have earlier versions of
Painter, upgrade to version IX. The detailed set up instructions for Painter are
in the same Chapter 1 (Foundation I: Getting Started) as referred to earlier.

Other factors to consider in setting up your digital art studio are controllable
lighting, comfortable temperature, an ergonomic table and chair, library of
inspiring art books and magazines, a digital camera, printer and scanner (useful
for collage projects).



Loosen Up!

Time to get up and stretch. Breathe deeply, raise your arms and then slowly
exhale as you lower them. You may enjoy doing this to relaxing music.
Warming up our physical muscles is a prelude to warming up our creative
muscles.

Exploring Marks in Black and White

Explore the variety of marks you can make. Relax your hand, arm and body.
Breathe. Open a new canvas, say 1000 pixels wide by 800 pixels high. Keep to
black as the selected color. Make as wide variety of marks with a single brush
as possible, changing pressure and speed as you paint. Have fun. Make a mess!
When you’ve pushed a brush to the limits of its mark-making capabilities
change to another brush. Don’t try and paint a picture “of” anything, just
enjoy the abstract nature of the marks. Focus on the quality of marks. Don’t
undo. As you build up an abstract image note the way the shapes and forms
interact with each other and the boundary of your canvas. Continue until you
have filled your canvas with brush strokes. When the canvas is full of marks
start exploring the Blenders and brushes that move paint around. Build up your
brush strokes over the existing brush strokes.

Exploring Marks in Color

Now repeat this exercise on a new canvas adding the dimension of color as you
paint. What difference does color make?

Abstracts out of Abstracts

Pick a small section of your color abstract. Crop it. Resize it to have the
maximum dimension of 1000 pixels. Continue painting on it. Then crop a small
section of your new stage. Work on that. Repeat this process a total of five
times. Compare all the resulting abstracts. Which do you like the most and
why?

Expressing Feelings

Create a painting that expresses your mood. Explore ways you can
communicate about your mood through use of line quality, brush stroke
thickness, colors, tone, texture, and so on. Try this exercise twice, once using
your favored hand and once using your non-favored hand. What difference do
you notice?



It’s all an lllusion!

Seeing and Perceiving

What we perceive we see is the picture our mind constructs based on data input from
our retina in combination with our expectations, cultural conditioning, and so on. Our
mind is constantly interpreting visual data and deciding what to make of it. Thus what
we perceive we see is not what is there but an illusion that we take as being reality.
That is why optical illusions work—they lead us to think that something is obviously so,
and then we experience surprise when we find what we thought was obviously so is, in
fact, not so.

Q. So what’s all this got to do with painting and expanding our creativity?
A. Everything.

A painting creates the illusion of three-dimensional form by triggering the same
perceptions and interpretations of data that our brain is constantly doing every
conscious moment when it, for instance, interprets a soft transition from light to dark
as being a continuous curved surface, etc. No matter what we refer to for our visual
source, whether imagination or memory, or direct observation of our subject or using
a photographic reference, the painting process, when depicting a subject, is one of
generating an illusion based on our use of shape, contour, tone, color and detail. Thus
as an artist creating a representational artwork (ie art depicting a physical subject) we
first deconstruct the illusion (looking at our source reference) and then reconstruct
the illusion on our canvas. To do this process we need to short circuit our natural way
of interpreting the world, making the familiar unfamiliar. Hence the bag of “tricks” to
see things in different ways.



Painting from Life

Painting from life means painting a subject based on direct observation of the
subject, as opposed to using a photo. Observing a subject directly gives us
much more information and many more points of view than looking at a photo.
Whilst painting from life is more challenging than painting from a photo it is a
useful starting point since it forces you to look carefully and build up your
hand-eye coordination, powerful skills you can apply to working from photos.

First Reference Painting

Choose a subject to paint. You could choose yourself (with use of a mirror);
another person or arrange an object or group of objects in front of you. Take a
few minutes just to observe your subject. Look carefully at the light and
shadows. Decide where the edge of the canvas will be and how much of your
canvas your subject will fill. Open a new canvas in Painter and spend thirty
minutes making a painting of your subject. At the end of class you will make
another painting of the same subject and be able to compare the two.

Preliminary Studies

A study is a preliminary painting or sketch that helps build your understanding
of your subject and experiment with ideas. Follow the instructions below to
make a series of studies of the same subject, spending no more than ten
minutes on each study (some will take much less time). In each case open a
new canvas (1000 x 800 pixels) in Painter and save the resulting study.

1. Gesture—use the Calligraphy > Dry Ink with black on a white canvas to
make a single energetic stroke that symbolizes the essence of the
subject, the lines of flow and movement. Make five of these studies.

2. Take a line for walk—use the Pen > Scratchboard Tool with black on a
white canvas to make a single contour that follows the contours (edges)
you see in your subject and background. After doing this with your
favored hand, save the study and do another one with your non-favored
hand. Now try the same exercise (with favored and non-favored hands)
without looking at your canvas as you paint. Just look at your subject.

3. Shapes—use the Pen > Scratchboard Tool with black on a white canvas
and depict your composition as a series of basic shapes (triangles, circles
and squares). Start with big shapes and work down to smaller shapes.

4. Tone—Tone is the lightness and darkness we see, the light and the
shadow. Also known as value. Use the Acrylics > Captured Bristle on a
mid-gray canvas to build up blocks of tone, starting with the extremes
(lightest and darkest blocks) and working towards the less extremes.
Start with rough general blocks and work towards smaller finer detail
and greater range of tone. Half-close your eyes to help see tone.

There are many more exercises that you can try out. Betty Edward’s book
Drawing on the Right Side of the Brain has many good ideas. | also recommend
going to a traditional (i.e. non-computer) drawing class.
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Painting from Photos

Photos, whilst presenting us with a constrained point of view and a limited
range of color and tone compared to what we see in life, can capture fleeting
moments in time that would be difficult to capture or convey when painting
from life. Photos can be beautiful works of art in themselves and don’t
necessarily need any modification to enhance their power or beauty. However
in many cases creating a painting based on a photo can dramatically enhance
the emotional impact, power and beauty of the image and transform a good
photographic image into a magnificent work of fine art. Paintings can have a
much greater and richer range of color, tone, detail and contrasts than is
present in a photo. Through use of paint you can shape, fine-tune and control
the focus, the story, the message. Creating paintings based on your photos is a
great opportunity for you to expand your creativity, as well as have fun at the
same time!

Photography is part of a long line of technologies used by artists for visual
reference. Leonardo da Vinci made use of a device called the camera obscura
to project scenes onto a flat surface to get accurate proportion and
perspective in his paintings. Edgar Degas used photographic reference for some
of his ballet dancer pictures.

Making use of a photo to create a painting can be done in the following ways :

1. Sticking a print of the photo next to your canvas (or having it visible on
your computer screens while you paint),

2. Dividing the photo into squares and then painting each square on your
canvas,

3. Painting over a photo,

4. Using tracing paper to look through your canvas onto the photo, and

5. Using “clone’ color to pick up color from a source photo while you paint
on another canvas.

Chalky Pastel Technique

We are going to start with a simple technique that transforms a photo into a
chalky pastel painting. The technique is described in detail on pages 104
through 127 in the Chapter 4 (Photo Techniques I: Pastel, Watercolor and Oil)
excerpt of my new book, Painter IX Creativity: Digital Artist’s Handbook.

Muck Up Technique
An important and powerful element of this technique is the creation of a “muck
up’ stage. The muck up is a rough under-painting that is made of large brush
strokes which capture the movement, energy and flow of the composition, and
that describe basic tonal and color areas. All detail is lost and the canvas is
completely filled with brush strokes. After the muck up is complete, detail is
selectively introduced. The result is a painting in which only certain focal areas
are well defined and stand out.
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Liberation through Limitation!

Sounds odd but it works. Limitations do liberate. Working within limitations is a
powerful way to expand your creativity. Limitations force you to adopt new
points of view. New points of view help you overcome your brain’s natural way
of interpreting the world and allow you to see things for what they are, rather
than what you think they are. Limitations help you see the familiar as
unfamiliar and consequently allow you to make fresh, engaging, creative work.

1. One Minute Paintings—set yourself one minute to paint a subject and
see what you manage to describe within that time. Repeat this exercise
five times and see if you start to hone in on the essence of the subject.

2. Four Hour Paintings—put aside four hours during a day to complete a
painting. You can take short breaks but complete the painting within a
single day. Use the full four hours. Don’t stop sooner.

3. One Brush Painting—stick to one brush for an entire painting. Explore
the full dynamic range of mark-making possibilities that the brush has to
offer. Allow thirty minutes for this exercise.

4. Super Selective Detail—create a rough muck up and then see how little
detail you need to add to evoke your subject.

5. Turn Your Photo Upside Down—Use the clone technique to paint but
with the photo turned upside down. When finished you can turn the
painting the ‘right” way round.

6. Dividing Into Squares— follow an ages old method of image transference
and rescaling, the grid system. Set up a square grid on your photo
(Canvas > Show Grid and Grid Options) and treat each square as an
abstract that you copy onto your canvas with paint.

7. Color Constraints—limit the regions of the Hue Wheel and/or Saturation-
Value Triangle that you use for a specific painting. Try high saturation
only, low saturation only, mid-saturation only, mid-values only, light
values only, dark values only, complementary colors only (opposites on
Hue Wheel), analogous colors only (next to each other on Hue Wheel),
primary colors only, and secondary colors only. These technical color
terms will be explained in class.

8. No Limitations! The final painting of classisonein which there are no
constraints. Just have fun.



What Now?

Start with the End in Mind

At the beginning of the class | asked you to project forward and describe your artistic
goals. Apply this approach to every painting project. Start with the end in mind.
Before painting ask yourself the following questions :

How do you want to display your artwork?

Using which printer and on what substrate, paper or canvas?

How will you mount or frame the picture?

How large will it be?

Will you want to paint or add gels or varnish on the final print.

Will you want a soft blended edge to your painting or will a hard straight edge be OK?
The answers to these questions will determine how large a file you need to work on
and whether you need to add a border to your original image if you’re working from a
photograph.

If you decide you are going to create a blended border add extra canvas (Canvas > Add
Canvas) to your original source image before cloning. The Add Canvas command adds
current paper color (set in Canvas > Paper Color). The default paper color is white.

End with the Start in Mind

You started this curriculum looking at your inspiration and goals. You took time to
look, to breathe and contemplate what inspires you and what it was you wanted to
say. Look back at the answers you wrote on page 3. Have you accomplished the goals
you set out? When you’ve completed a painting, or brought it to a stage your satisfied
with, step back, take some time to look at it and ask yourself if you’ve succeeded in
communicating or expressing or achieving whatever your goals were.

Keep Exercising Your Creative Muscle

Keep up your creative momentum by integrating some of the techniques and exercises
covered here into your regular work. Make time each week for exercising your creative
muscle, even if it’s just an hour a week. Remember, you’ve always got your One
Minute Paintings if you’re really short for time!

Wishing you a joyful and creative New Year.

Happy painting!

Cheers,
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Appendix |
Food for Thought

Captivate the Human Eye

“The principles of value and color, of composition and shape, are no less applicable to
what comes out of your printer than what comes off another artist’s easel. Your
computer is just a new medium. The means and tools may be different but the end
result is still intended to captivate the human eye.”

Harley Brown, Harley Brown’s eternal truths for every artist

Harmony of Opposites

“All entities include their opposite as part of their nature. Two things that are against
each other also support each other in a balanced relationship. Good paintings always
exude an energy that flows from a harmonious balance of contrasts.”

Hongnian Zhang and Lois Wooley, The Yin/Yang of Painting

Lighting Up

“Something | always tell my kids, great films have as many flaws and bad things about
them as bad films. | could take you through Citizen Kane, or any number of films, and
just point out all the flaws and give notes on all that’s wrong with them. The
difference is the good films light up, the illusion works, so when you see them you’re
not looking at the flaws. What it tells me when someone sees a film and says | don’t
like that, or it gets bad reviews, the film didn’t light up for them, so that you tend to
only see the bad things.

“I tell my kids it’s the cigarette lighter theory: you have a cigarette lighter and that’s
your movie. You try to light it and you flick it and it doesn’t light. Then you pull the
wick out and do it and it doesn’t light. Then you pour more fluid and you put too much
and it doesn’t light. You dry it off with a hairdryer and it doesn’t light. Then you pull
the wick out some more and all of a sudden it lights! And once it lights all the bad
things that didn’t have the conditions of lighting go away because it’s lit. That’s what
a movie is like. You have this thing and it doesn’t work. The audience comes out and
they just talk about the bad things. But then you change it, you move it around, you
move it here, you do this, and you tweak it a little. And when it lights all the bad
things go away. They don’t go away. But you don’t look at them any more because
you’re lost in the illusion.”

Francis Ford Coppola, interview on NPR’s Forum radio program

Less is More

“You may not always succeed, but attempt to produce the greatest effect in
the viewer’s mind by the least number of things on screen. Why? Because you
want to do only what is necessary to engage the imagination of the audience.
Suggestion is always more effective than exposition. Past a certain point, the
more effort you put into wealth of detail, the more you encourage the
audience to become spectators rather than participants.”

Walter Murch, In the Blink of an Eye
11



Art

“We use a mirror to see our faces, we use art to see our soul.”
George Bernard Shaw

Color and the Soul

“Color is the keyboard, the eyes are the harmonies, the soul is the piano with many
strings. The artist is the hand that plays, touching one key or another, to cause
vibrations in the soul.”

~ Vasily Kandinsky

A Painter is a Dancer with a Brush

“We all know the difference between self-consciously watching ourselves dance and
being swept up with the music. When we simply allow our body to move, the mind
empties. Knowing we are free and one with the music, we experience an exhilarating
feeling of release. The energy that comes from being directly connected to inner self
is so powerful that even those who do not consider them selves dancers will, at such
moments, want to “dance all night”.

“Painting, like dancing and many other everyday activities — bike riding, roller-
skating, cooking, writing, even typing — can be viewed as a form of meditation. There
comes a moment when you are totally absorbed in being what you do. You and your
activity become one.”

Paul Siudzinski, Sumi-e: a meditation in ink

12



Appendix I
Resources

The Web

Please visit www.paintercreativity.com. This web site is a central source of useful
information and resource references for those interested in developing their mastery
of Painter. Included in the web site are articles, tutorials, links and details of
forthcoming Painter Panache classes (the next introductory class is February 7 - 11).

Painter Books and DVDs

o |L._'|l,,.r au ikl ® -,snu'J:l..-'H !

Painter IX Creativity - Digital Artist's Handbook (Focal Press 2005) by Jeremy Sutton
A comprehensive Painter IX workbook with a focus on creative process. It is a practical
creativity workbook with illustrated step by step tutorial projects.

Il ={'soas I-H-J;_ml LT

Painter 1X

Painter IX Simplified for Photographers

by Jeremy Sutton (PhotoVision 2005)

This 4-DVD Tutorial is unique learning tool that will teach you fast and simple
techniques to transform your photographs into beautiful pastels, water colors or oil
painting.
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There are many other excellent resources for learning Painter. | recommend learning
from different teachers and resources - all have unique strengths to offer. Other books
include Cher Threinen-Pendarvis' Painter 8 Wow! book and Don Seegmiller's Digital
Character Design and Painting (ISBN 1-58450-232-0).

Books on Making Art

A Proven Strategy for Creating Great Art
By Dan McCaw (International Artist 2002)

Art & Fear - Observations on the Perils (and Rewards) of Artmaking
by David Bayles and Ted Orland (Image Continuum ISBN 0-9614547-3-3).
A 'must read' for anyone involved with creating art!

Color Workbook
by Becky Koenig (Prentice Hall 2003) ISBN 0-13-093317-1. A thorough review of color
theory throughout the history of art, including exercises to try out. Very informative.

Creative Computer Tools for Artists: Using Software to Develop Drawings and Paintings
by Jann Lawrence Pollard, Jerry James Little

Creative Color, History of Color in Painting, and Color Perception in Art
by Faber Birren

Conversations in Paint
by Charles Dunn

Nature's Basic Color Concept, How to Use Color in Portraits, Color (Simplified Steps in
Painting Color), and Color With Palette Knife and Brush by Merlin Enabnit;

Creative lllustration
by Andrew Loomis

Design and Form

by Johannes Itten (Thames & Hudson ISBN 0-500-27067-8).

A succinct and fascinating overview of the Basic Course in design and form that Itten
developed at the Bauhaus school following the First World War. Many ideas that can be
usefully applied to portrait painting.

Drawing on the Right Side of the Brain

by Betty Edwards (Tarcher 1979 ISBN 0-87477-088-2).

A popular book full of great exercises designed to bring out your creative and artistic
side. You can apply most of Edward's suggestions to working on the computer.

Drawing with Colour
by Judy Martin

Exploring Color
by Nita Leland

Harley Brown's Eternal Truths for Every Artist

14



by Harley Brown, Lewis Barrett Lehrman

How to See Color and Paint It

by Arthur Stern (Watson-Guptill 1984 ISBN 0-8230-2469-5).

Straight forward description of color theory and a series of traditional oil painting
exercises designed to develop the artist's application of color in painting from life.

In the Blink of an Eye

by Walter Murch (Sillman-James Press ISBN 1-879505-23-1).

A perspective on the creative process of film-editing which has many interesting
parallels with painting.

Interaction of Color

by Josef Albers (Yale University Press1975 ISBN 0-300-01846-0).

A series of well explained practical exercises that lead the reader through an
experiential appreciation of color.

Mastering Digital Printing: The Photographer's and Artist's Guide to High-Quality Digital
Output
by Harald Johnson (Musk & Lipman 2002) ISBN 1-929685-65-3.

Real World Color Management
by Bruce Fraser, Chris Murphy & Fred Bunting (Peachpit Press 2003)

Secrets of Award-Winning Digital Artists
by Jeremy Sutton / Daryl Wise (Wiley 2002)
47 artists share their inspirational artwork and creative insights.

The Art of Colour

by Johannes Itten (Von Nostrand Reinhold 1973 ISBN 0-442-24037-6).

A large colorful explanation of practical color theory for the fine artist. Includes
fascinating color analysis of many historic paintings.

The Elements of Colour
by Johannes Itten (Chapman & Hall ISBN 0-412-38390-X).
Small paperback based on Itten's color theory expounded in The Art of Colour.

The Natural Way to Draw

by Kimon Nicolaides (Houghton Mifflin 1941).

Thorough workbook full of exercises that teach traditional drawing skills. A classic
tome that is timeless.

The Yin/Yang of Painting : A Contemporary Master Reveals the Secrets of Painting
Found in Ancient Chinese Philosophy
By Hongnian Zhang and Lois Woolley (Watson Guptill 2000)

Vision and Art: The Biology of Seeing

by Margaret Livingstone (Abrams 2002) ISBN 0-8109-0406-3. A must read for anyone
who really wants a deep understanding of how we perceive color and how that effects
our use and perception of color in art. Highly recommended.

15



SUMI-E: A MEDITATION IN INK
Paul Siudzinski

0-8473-1659-9

BEGINNER'S MIND

Zen painters approach painting in the spirit
of meditation. They paint like beginners, straight-
forwardly, simply, innocently. They do not try
to paint pictures that are beautiful or skillful
or try to make the subject look the way it is
“supposed to.” Because they “pay attention,”
as if seeing something for the first time, their
paintings are full of vitality. To pay attention
like this is to capture the inner spirit of the sub-
ject. To follow the way of the brush is to paint
with the beginner's mind.

16

A Painter Is a Dancer with a Brush

We all know the difference between self-conscious-
Iy watching ourselves dance and being swept up by
the music. When we simply allow our body to
move, the mind empties. Knowing we are free and
one with the music, we experience an exhilarating
feeling of release. The energy that comes from be-
ing directly connected to our inner self is so power-
ful that even those who do not consider them-
selves dancers will, at such moments, want to
“dance all night.”

Painting, like dancing and many other everyday
activities — bike riding, roller-skating, cooking,
writing, even typing — can be viewed as a form of
meditation. There comes a moment when you are
totally absorbed in being what you do. You and
your activity have become one.

Yet there is a part of you that stands aside —

a still part — and watches the process without in-
terfering. This observer, this inner eye, knows
what you are about in a very clear-sighted way.
The way of the brush is to pay attention with the
inner eye.

What keeps us from paying attention? We have
already noted the chattering in our heads. There
is yet another element that overcomes us — habit
— a boring fellow. He is always sleeping. For
example, listening to a popular song, we may not
actually “hear" it, because we know it so well,
The same is true of the things we look at every
day without seeing, the talks we have without com-
municating, the motions we make without touch-
ing. Habit.

Paradox 1: Look around you at this moment
and see what you are not paying attention to.

Paradox 2: Look at something without know-
ing its name.

Paying attention means to “see” something and
not know what it is. When we paint a leaf, each
moment of seeing is new. This newness is what
moves our brush. The leaf simply moves through
us onto the paper, like a dancer whose energy
maoves the body gracefully through space. A paint-

eris like 3 dancer with a hruch



Most with the Least

ou can never judge the quality of a sound mix

simply by counting the number of tracks it ok
to produce it. Termble mixes have been produced from
a hundred tracks. By the same token, wonderful mixes
have been made from only three mracks. It depends
on the initial choices that were made, the quality of
the sounds, and how capable the blend of those
sounds was of exciting emotions hidden in the heans
of the audience. The undedying principle: Always try
to do the most with the least—with the emphasis on
try. You may not always succeed, but attemfi to pro-
duce the greatest offect in the viewer's mind by the
least number of things on screen. Why? Because you
want 1o do only what is necessary to engage the imag-
nation of the audience—suggestion is always more
effective than exposition. Past a cemain point, the mone
effort vou put into wealth of detail, the more you
encourage the audience 1o become spectators tather
than participants. The same principle applies to all
the various crafts of filmmaking: acting, an direction,
photography, music, costume, eic.

And, of course, it applies o editng as well. You
would never say that a cerain film was well-edited
because it had more cuts in it Frequenty, it takes

more work and discernment to decide where not 1o
cut—don't feel you have o cut just because you are
being paid to. You are being paid to make decisions,
and as far as whether to cut or not, the edior is actu-
ally making twenty-four decisions a second: "No. No.
Mo No. No, No. No. No. Na. No. Yes!”
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An overctive editor, who changes shots too fre
quently, is like a vour guide who can’t stop pointing
things out: “And up there we have the Sistine Ceiling,
and over here we have the Mona Lisa, and, by the
way, look at these foor tles . . .~ If you are on 3 tour,
you do want the guide to point things out for you, of
course, but some of the time you just want o walk
around and see what you see. If the guide—that is w0
say, the editor—doesn't have the confidence to let
prople themselves occasionally choose what they wint
1o look at, or to leave things to their imagination, then
he is pursuing a goal (complete control) that in the
end is self-defeating. People will eventually feel con-
strained and then resentful from the consiant pres-
sure of his hand an the backs of their necks.

Well, if what I'm saying is to do more with less,
then is there any way to say how much less? Is ot
possible to take this right to its absurd logical conclu-
sion and say, “Don’t cut at all?* Now we've come back
to our first problem: Film is cut for practical reasons
e film is cut because cutting—that sudden disrup-
tion of reality—can be an effective ool in itself. So, if
the goal is as few cuts as possible, when you bave o
make a cut, what is it that makes it a good one?



Appendix I
Instructor Bio

Jeremy Sutton is an internationally renowned portrait
artist, speaker, author and educator. Originally from
London, Jeremy has a Master of Arts degree in Physics
from Oxford University, and studied art at the Ruskin
School for Drawing and Fine Art, Oxford University,
and at the Vrije Akademie, The Hague, in The
Netherlands. Jeremy, a former faculty member of the
Academy of Art College, San Francisco, has spoken at
major conferences and taught workshops and seminars
all over the world.

His publications include the following:

Painter IX Creativity: Digital Artist's Handbook (Focal Press, 2005)

Painter IX Simplified for Photographers 4 DVD Tutorial Set (PhotoVision, 2005)
Painter 8 Creativity: Digital Artist's Handbook (Focal Press, 2003)

Painter Creativity for Professional Portrait and Wedding Photographers 4 DVD
Tutorial Set (PhotoVision, 2003)

Secrets of Award-Winning Digital Artists (co-author Daryl Wise, Wiley, 2002)
Total Painter Video Series (Total Training, 1998)

Painter 4 Video Series (MacAcademy, 1996)

Fractal Design Painter Creative Techniques (Hayden Books, 1996)

Articles and artwork by Jeremy have been featured in numerous magazines and
books world-wide.

Contact Info

Jeremy Sutton

Painter Creativity

Phone 415.626.3971

Fax  415.626.3901

jeremy@paintercreativity.com
http://www.paintercreativity.com Training & Resources
http://www.jeremysutton.com Contemporary Portraiture
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Appendix IV
landy Keyboard Shortcuts

Here are a few handy default keyboard shortcuts. Remember that in the Preferences >
Customize Keys you can set almost any menu item to be almost any keyboard shortcut.

Cmd/Ctrl-N new file

Cmd/Ctrl-O open file

Cmd/Ctrl-M mounts (or unmounts) your canvas on the screen
b Brush tool

Tab Hides/shows palettes

Space bar held down when the Brush tool is selected turns the cursor into a Grabber
Hand that you can use to reposition your canvas (by clicking and dragging on the

canvas).

Cmd/Ctrl-““+” zoom in
Cmd/Ctrl-“-* zoom out
Cmd/Ctrl-0 zoom to fit

Shift-Option-Cmd/Shift-Alt-Ctrl when Brush tool selected allows you to click and drag
within image to resize brush.
Shift- -Cmd-S/Shift-Ctrl-S Save As - allows you to rename file and save versions

Cmd/Ctrl-S Save - updates current file

Shift-x exchanges the Regular and Additional colors
Shift drag and reposition contents of Custom Palettes
] increases brush size

[ decreases brush size

Brush cursor click with Ctrl (Mac)/right click (Win) - pop-up menu with variants list
(plus save variant etc)

d Dropper tool

Option/Alt Brush tool becomes Dropper tool if clone color NOT active, OR
resets clone source start position if clone color active.

r Rectangular Selection tool

c Crop tool

f Layer Adjuster tool (useful when you are working with layers in a

photo-collage)
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Appendix V
Choosing Brushes

Here are some brushes | like to use (the Jeremy Faves brush category is on the Painter
8 Creativity book companion CD and a Jeremy Faves 2.0 category will be included with
the Painter IX Creativity book). | almost always adjust the Property Bar parameters
such as size and opacity from their default values. |1 normally work with medium to low
brush opacity so | have more control and subtlety. This list is not meant to be an
exhaustive list or to be used as recipe. Explore all the Painter brushes for yourself. I’'m
sure you’ll discover lots of great brushes I’ve overlooked! Please let me know of any
great gems you discover.

Diffuse and Oily Blending Effects

Acrylics > Captured Bristle

Blenders > Oily Blender, Runny, Smear

Distortion > Diffuser, Smeary Bristles

Jeremy Faves > Artist Palette Knife, Ron’s Blender, Shmear
Sponges > Smeary Wet Sponge

Tinting > Directional Diffuser

Diffuse Soft Water Color Blending

Blenders > Just Add Water

Distortion > Water Bubbles

F-X > Confusion, Hair Spray

Jeremy Faves > Sable Chisel Tip Water
Tinting > Diffuser2

Diffuse Soft Water Color Coloring

Digital Water Color > Diffuse Water

Pastel/Chalky Looks

Chalk > Large Chalk
Oil Pastels > Soft Oil Pastel (adjust Jitter), Chunky Oil Pastel (adjust Jitter)
Pastels > Square Hard Pastel (Resat 15%, Bleed 93% - more blended)

Artistic Thick Oily Looks (Good for Muck Up)

Artists > Impressionist, Sargent

Cloners > Oil Brush Cloner (impasto adjusted to color only), Smeary Camel Cloner
Jeremy Faves > Big Wet Luscious, Big Wet Spreckly, Den’s Oil Brush Luscious, Den’s Qil
Funky Chunky, Jeremy’s MishMash, Jeremy’s MishMashPull, modern art in a can,
Sherron’s Blender Wood, Wood

Smooth Oily Face and Skin Work

Oil > Bristle Oil
Acrylics > Captured Bristle
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Appendix VI
Customizing Brushes

During the course of emulating different looks you will need to make time for brush
research. This is when you explore brushes, find ones that come close to what you
want, and then start tweaking all the sliders in the Brush Property bar until you find
the look that works for you. There are more advanced ways to modify brush behavior
in the Brush Creator (Window > Brush Creator) but we will not go into those here.

In the course of your brush research you will come across modified variant you wish to
save for future use. That is when you will want to save your customized variant. Here
is a brief summary of how to do that, and also how to organize your brushes by
creating new categories and moving brushes between categories. There is a whole
chapter of Painter IX Creativity: Digital Artist’s Handbook devoted to this topic.

Saving a Simple Custom Variant in Painting Mode

1. Select Save Variant from the Brush Selector pop-up menu.

Name the new variant, eg. “Distorto-Color-Fine,” or something appropriately
descriptive.

2. Click OK. The new variant appears as one of the variants listed in the current brush
category.

Saving a Custom Variant Using the Brush Creator

The Brush Creator tools, art materials and color palettes are accessible through the
Windows menu (different from the standard painting mode Windows menu). When you
are ready to save a custom variant created in the Brush Creator you choose Variant >
Save Variant from the top menu.

Restoring Default Variants

Select the variant in the Brushes palette and then select Restore Default Variant from
the Brush Selecting pop-up menu .

Creating a New Brush Category

1. Drag the Rectangular Selection tool over a portion of an image you want to capture
as the new category icon.

2. Choose Window > Show Brush Creator (Cmd/Ctrl-B).

3. Select Brush > Capture Brush from the top menu.

4. Name the new Brush Category and click OK. The new brush category has a single
variant, name same as category.

Copying a Variant from One Category into Another

Select Copy Variant from the Brush Selector pop-up menu (or Copy from the Brush
Creator Variant menu).
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Deleting an Unwanted Custom Variant
Select Delete Variant from the Brush Selector pop-up menu (or Delete from the Brush
Creator Variant menu).

Sharing Variants between Computers

Copy the appropriate .xml file, together with any associated .jpg file, from one
computer into the appropriate brush category folder of the Painter Brushes library in

the other computer.
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Evaluation Form

Please complete and hand in at end of the Macworld PowerTools PF
class or send in after the Macworld User Conference session S123.

Name:
Address:

Phone:

Email:

Web:

Would you like to hear about future Jeremy workshops and educational resources? Y/N
May | quote from this form in promoting future workshops? Y/N

Were you in the Power Tools class PF / session S123 / both?

What is your over all impression of the class/session?

Did it meet, fail to meet, or exceed, your expectations? Please explain.
What was your favorite part and why?
What was your least favorite part and why?

Please characterize your instructor’s skills on a scale of 1 (poor) to 10 (excellent) and
add any comments you may have that explain grading (especially if less than 10):
Technical knowledge of Painter

Organization of material

Presentation

Pacing

Hand-outs

Teaching style

Effectiveness as a teacher

What would you like to learn in future workshops by Jeremy?

Any other suggestions to improve future courses or other comments?

2%



Order Form

Please complete the relevant parts of this form and hand in (or fax to 415.626.3901).
Any information given is kept strictly confidential.

Name:
Address:

Phone:
Email:
Web:

My interests are:

[ 1 Educational resources for learning Painter

[ ] Painter Panache Intro Class

[ ] Painter Panache Master Series Class

[ 1 Commissioning a portrait by Jeremy

[ 1 Knowing about gallery showings of Jeremy’s artwork

Registering and Ordering

| wish to:

[ 1 Register for Painter Panache Intro Class, Feb 7 - 11, 2005 (fee $795)

[ 1 Purchase the 4 DVD set Painter IX Simplified for Photographers ($149 + $12.66 CA
sales tax + $5 shipping). Supplied with bonus DVD Unleashing Your Creativity!

[ ] Painter IX Educational Bundle which includes the new 4 DVD set Painter IX
Simplified for Photographers, Unleashing your Creativity! DVD, Digital Innovator DVD
and the new book Painter IX Creativity: Digital Artist’s Handbook, due March, 2005.
Bundle price $215 + $18.28 CA sales tax + $15 shipping (items will be shipped
separately as they come in).

Payment

| am paying with:

[ 1Cash

[ 1Check (made payable to Jeremy Sutton)
[ ] Visa

[ ] Mastercard

[ 1 American Express

Credit card account no.:

Expiry date (MM/YY):
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481 8th Avenus - Sulte 1738, New York, NY 10001

(:00 | G ruph i (S‘I’Uf{com Phone: 212-504-4373, Fax: 212-504-1550

®
www .coolgraphicstuff.com/jeremysutton. html
WACOM Authorized Dealer 3
| for North and South America B
JEREMY SUTTON SPECIAL GOUPON!

' intLIOS.s 6x8 USB TABLET
°'$309.99! T

[retail price: $349.99]

Comes with Intuos3 Grip Pen, Intuos3 Five-button Mouse, Intuos3 Tablet
with one set of Expresskeys and one Touch Strip, Corel Painter Essentials 2,
Adobe Photoshop Elements 2, and nik Color Efex Pro 2 |E.

Limited Lifetime Warranty.

System Requirements: PC- Windows 985E, 2000, Ma, or XP; powered USE port, CD-ROM drive, & color monitor
Mac- OF 10.2.6 & higher; powered USB port, CO-ROM drive, & color menitor

FREE UPS GROUND SHIPPING AVAILABLE!

The Coupon Code is "JEREMY" to recsive the Special Price. Free UFS Ground Shipping. Also avallable Shipping for USPS Priority with delivery confirmation for APO, AK and HI orders). 8.625%
MY sales tax to New Yark customers only. 7 Day return policy of Intuos3 Gx3 USE tablat purchase. Please contact us to request a return of merchand lse authorization number [RMA] to prepare and
refund your order. Customer |s responsible for return shipping fees. All returns are subject to a 15% restocking fee.
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4 PAINTER IX CREATIVITY: DIGITAL ARTIST'S HANDBOOK

Every child is an artist. The problem is how to remain an artist once he grows up.
—Pablo Picasso

1.1 Introduction

The journey we are embarking on is to unleash your full creative potential, the potential in all of us
that Picasso alludes to in his quote. We start this journey with the Fundamentals, building up a solid
foundation from which to grow. The first two Fundamentals chapters cover essential knowledge and
skills. The third Fundamentals chapter covers advanced brush creation and customization, not essen-
tial but ultimately useful if you wish to fully realize your creative potential.

This first chapter introduces you to Painter and guides you through some initial setting up and
getting to know the “where to” and “how to” for basic operations, such as opening a new canvas,
selecting a brush, changing color, clearing your canvas, saving your image, and so on. The chapter
concludes with an exploration of some types of brushes that can confuse the first-time Painter user.

By the end of this chapter you'll be familiar with the Painter interface and you'll be comfortable
choosing, applying and controlling the brushes, which are at the heart of Painter.

1.2 What's This Thing Called “Painter”?

In a Nutshell

Corel Painter IX is a phenomenal image creation program, with the richest variety and versatility of
brushes available anywhere, as well as offering powerful special effects, pattern-making, and anima-
tion capabilities and industry standard text, layers, channels, and masking. Painter is a valuable tool
for fine art, photography, and all forms of image manipulation, design, illustration, collage, and video.
Whatever your application, the key to Painter’s magic is the ability it offers to apply brushstrokes by
hand (using a graphics tablet with pressure-sensitive stylus), as opposed to just applying uniform
special effects (though Painter has many great special effects that may be successfully incorporated
into a final image). Through the use of your hand you express your heart in your art.

The brushes are at the heart of Painter’s uniqueness and strength. Some brushes emulate
traditional natural media, such as chalks, watercolors, and oils, while other brushes create unique
effects that don’t exist outside Painter in the “traditional,” nondigital world. There are so many
brushes that come with Painter that they have been divided into 33 groups, or types, known as
categories. Within each brush category is a collection of individual brushes known as variants. See
the Visual Glossary at the front of this handbook to get an overview of the variety of brush looks
available in each category.

o
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1.3 Which Tools to Use When?

Painter and Photoshop—Your Foundation Tools

Corel Painter IX, your digital art studio, is an essential part of your digital imaging toolkit and is a
perfect complement to Adobe Photoshop CS, your digital darkroom. These two foundation tools,
Painter and Photoshop, are primarily bitmap programs; that is, they deal primarily in imagery com-
posed of pixels (though there are resolution-independent text and vector shapes in Painter). Besides

GETTING STARTED

these two great tools, you may also find it useful to have a good graphics drawing program with pow-
erful vector-based drawing and text capabilities, such as Adobe Illustrator, CorelDRAW, or Macro-
media Freehand. T have outlined here the main digital workflow tasks you might come across as you
work on a digital image and shared my opinions as to which tools are best suited to each task. There
is some overlap in functionality between all of the programs mentioned, and consequently there are
many alternative ways to accomplish the same task. There are no hard and fast rules here, and you
will find many different approaches to workflow. Do what works best for you and what you're most
comfortable with.
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Photographic Capture, Cropping, and Orientation

For browsing, scanning, rotating, adjusting perspective, and cropping photographs, Photoshop is
often the best tool (though Corel Painter IX has introduced entire canvas rotation, so if it's just rota-
tion you need, you can do that equally easily in either program). Digital photo image capture soft-
ware packages, such as iPhoto, ACDSee, and iView Media Pro, also offer browsing, rotating, and

cropping capability.

Basic Image Editing

Photoshop is great for almost any kind of image-editing need, such as enhancing your source image
and adjusting levels, hue, saturation, contrast, and brightness. Photoshop offers the optimum control
and flexibility for image adjustments using Adjustment Layers. When using Photoshop’s Adjustment
Layers I recommend saving a Photoshop file format master document with the Adjustment Layers
and then flattening the layers and resaving a flat version of the file in TIFF format for opening in
Painter. The reason for making a flattened version of the file is that Painter does not recognize the
Photoshop Adjustment Layer properties. If you are already working on an image in Painter and want
to make tonal or color adjustments, then you could use Painter’s built-in tools under Effects > Tonal
Control, though these are not as editable or as powerful as those offered through Photoshop’s Adjust-
ment Layers.

o
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6 PAINTER IX CREATIVITY: DIGITAL ARTIST'S HANDBOOK

Hand-Painted Artistic Effects

Corel Painter IX is the tool to use when you want an organic, artistic, painterly, hand-painted look
and feel to your image. This applies equally whether you are creating a painting from scratch or trans-
forming a photographic image. While Photoshop has an extensive set of brushes and numerous won-
derful built-in and third-party filters and effects, there is no substitute for the versatility, variety, and
richness of Painter’s brushes and textures. You can also start with effects and brushes in Photoshop
and then rework your image in Painter, finally bringing it back to Photoshop for final refinement and
color adjustment.

Selections and Layers

Both Painter and Photoshop have comparable and largely compatible facilities for making and saving
selections (including compatible Channels and Alpha Channels) and for controlling, adjusting, and
organizing layers.

The Photoshop Lasso tool has the added flexibility of having a feather setting (in the Tool Prop-
erty Bar) and a point-to-point feature when the Option/Alt modifier key is held down. This makes
precise selections easier and faster to do in Photoshop than in Painter (where, for the most precise
selections, you would use the Bezier Pen tool to create a Shape and then convert that Shape to a
Selection).

Layer Masks are compatible between the two programs (providing you save your files as Photo-
shop format files). Although Photoshop Layer Blending Modes are similar to Painter Layer Com-
posite Methods, there are Photoshop Layer Blending Modes, such as Color Burn and Vivid Light, that
don’t exist in Painter, and there are Painter Layer Composite Methods, such as Gel and Magic
Combine, that don’t exist in Photoshop. When either program comes across a layer blending
mode/composite method it doesn’t recognize, it just substitutes the Normal (Photoshop) mode or
Default (Painter) method. When using Layer Composite Methods in Painter, save your file in RIFF file
format. RIFF is the native file format for Painter. RIFF files preserve the most data but cannot be
opened in Photoshop. Before being able to open a RIFF file in Photoshop you will need to resave the
image in Photoshop or TIFF file format. If you are using Gel or Magic Combine composite methods it
is best to flatten your image in Painter before resaving, to preserve the effect of the composite methods
on the colors in your image.

Note that besides some Layer Composite Methods, there are other special layers and modes in
Painter (Watercolor, Liquid Ink, Impasto, Digital Watercolor, and Mosaic) that lose their special prop-
erties and editability when you convert from a RIFF format file to a Photoshop format file (the full
editability of these special Painter layers and modes is preserved only in the RIFF format).
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Generally vector programs, such as Adobe Illustrator, CorelDRAW, or Macromedia Freehand, are

Type and Design

great for sharp, editable, scalable, resolution-independent type, for setting type on a curve, and for
keeping file sizes small. Use type in Photoshop or Painter only when you wish to apply a special effect
to it or the sharpness of the type is not crucial.

Both Photoshop and Painter have versatile text tools that allow you to experiment with different

GETTING STARTED

fonts, orientation, positioning, alignment, and spacing. In Painter, by converting to resolution-
independent vector-based Shapes you can also skew and distort lettering individually or as a group.
The special properties of Painter’s Text and Shape layers are only preserved in the RIFF file format. If
you convert the file to Photoshop format so that it can be opened in Photoshop, the Painter Text and
Shape layers are converted to regular bitmap image layers. Likewise Photoshop Text layers are con-
verted to regular bitmap image layers when opened up in Painter. Thus while you need editability of
your text layers, you should stay in the program in which you created the text and keep the file format
appropriate (RIFF format for Painter Text, Photoshop format for Photoshop Text). By converting your
Painter Text or Shape layers to default image layers in Painter, you can apply all of Painter’s brushes
and effects, including instant drop shadows (Effects > Objects > Create Drop Shadow).
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If you want to wrap text accurately around a circle or a path, then you should create the text in
a vector-based program like Adobe Illustrator, CoreIDRAW, or Macromedia Freehand. If you wish to
add effects to the text or integrate the text into a bitmap (pixel) image in Painter, then you can always
import the Illustrator- or Freehand-generated text as a layer, or series of layers, into either Photoshop
or Painter. In Painter, Illustrator text is imported as a group of Shapes (File > Acquire > Adobe Illus-
trator File).

If you are preparing a piece for print and want the most precise, accurate, sharp-looking text
possible and the text will be a plain color without gradients, transparency, or drop shadows, then you
are better off either creating the text in Illustrator (or other vector program) and converting it to out-
lines or saving as a PDF document. Keep a copy of the original (non-outline) document for your

records for future editing and resolution-independent resizing. You can also create sharp text mixed
in with graphics in layout programs such as Adobe InDesign and Quark Xpress.

Publishing on the Web

Publishing artwork on the Web involves a number of conflicting considerations:
n Keeping your file size as small as possible to minimize download time and avoid the need for
scrolling and thus create a better viewer experience.

n Showing your artwork in sufficient scale, detail, quality, accuracy, and consistency of color to
impact viewers and do justice to your talents.

ﬂ Protecting your imagery from being used without your permission and therefore not publishing
such high-quality imagery that people can make good prints from them.
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8 PAINTER IX CREATIVITY: DIGITAL ARTIST'S HANDBOOK

Similar considerations apply to preparing images to send and share as e-mail attachments. With
regard to digital imaging workflow, Photoshop CS offers a useful File > Save for Web option, which
allows you to see how your image will look depending on what quality or format you choose. I rec-
ommend that you use this option when saving from Photoshop for the Web. For further Web imaging
capabilities you can choose File > Edit in Image Ready.

My Web gallery images typically end up being about 400 to 600 pixels in the maximum dimen-
sion at 72 ppi. I create my original artwork at higher resolution as RIFF files in Painter and then resize
and resave them (also in Painter) as High-Quality JPEGs. Every time you save anything as a JPEG, the
quality of the file is reduced, and if you resave as a JPEG, then the quality is reduced even more. Only
save as a JPEG once. Creating images at higher resolution gives you the flexibility to reuse the images
for printing at a later time.

For helping protect your files from misuse you can, in Photoshop, choose Filter > Digimarc, which
allows you to embed a watermark with your copyright notice.

Printing

I have successfully printed from both Painter and Photoshop with excellent results. If you print
from Photoshop I recommend using the File > Print with Preview option, which allows you more
control in positioning your image on the paper. A key concern when you come to print your digital
artwork is getting good consistency between the colors you see on the screen when you create your
artwork and the colors you see in your final printed image. Painter IX has new color management
tools built into it that are worthwhile using. Refer to the User Manual and Help > Help Topics
for further information on that. Here are two books that can help you color manage your creative
workflow:

Mastering Digital Printing by Harald Johnson (Muska & Lipman, 2003, ISBN 1-929685-65-3)—this
is a comprehensive book on digital printing that is written in a chatty, easy-to-follow style and has a
chapter on Understanding and Managing Color.

Real World Color Management by Bruce Fraser et al. (Peachpit Press, 2003, ISBN 0-201-77340-6)—
a highly detailed technical book that tells you all you could wish to know about the ins and outs of
color management.

One factor to be aware of with regard to printing is that different printers and printing technology
may require your files to be in one of two different color modes, namely, RGB (red—green—blue) for
most fine art inkjet printers and CMYK (cyan—magenta—yellow—black) for commercial offset printing.
Painter is an RGB program, in that all color data is stored with RGB values, and I recommend only
saving RGB files from Painter. Photoshop allows you to work in different color modes. If you are
working with traditional offset lithography printers, use Photoshop to convert your files from RGB to
CMYK. Be aware that many options and filters are not available in Photoshop when working in
CMYK, so leave CMYK conversion to the end of your workflow, always saving a backup RGB version
of your file before changing color modes.

o
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When working on a QuickTime movie for video, I generally start my projects in Painter at the required

Video

final video resolution, typically 720 pixels x 480 pixels at 72 ppi. This keeps everything simple and
straightforward and allows me to use the resulting QuickTime movie directly without any need
for resizing. You can generate a frame stack from the replay of a script and subsequently generate
a QuickTime movie (or AVI movie or numbered files) from the frame stack. (This is explained in

GETTING STARTED

Chapter 10.) You can also open numbered files or a QuickTime movie in Painter, where it appears as
a frame stack. You can then paint on and apply effects to individual frames or across the whole movie.
Once your frame stack is exported as a QuickTime movie you can then open that movie in any
animation or special effects program (such as Adobe Premiere and After Effects, and Apple Final
Cut Pro).

1.4 First Things First
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Get Comfortable

It’s important to feel good about your environment. Take a look around. Is the surface on which the
computer monitor and keyboard are situated clear of clutter? Is the computer screen in a position
and orientation where you won't be disturbed by reflected light from a window? Adjust your envi-
ronment so you feel good about it. You want to avoid distractions once you sit down to create art on
the computer.

Before sitting down at your computer, do some simple stretching and relaxation exercises. These
could be as simple as some deep breaths accompanied by slowly raising and lowering your arms,
gently rotating your head, and softly rolling your shoulders. You may find it pleasant to put on some

relaxing music to accompany this movement. When you've completed some stretching and relax-
ation exercises, finish by shaking out your feet and hands. Stand upright with your arms relaxed at
your side. Observe your posture. Breathe deep into your diaphragm, hold your head upright, and keep
your shoulders down. Now sit at your computer.

I recommend getting up and stretching (and drinking some water) at least every hour, prefer-
ably every 20 minutes. Since time flies by when you're absorbed in a project, you may find it useful
to set a small kitchen timer as your stretch time reminder.

Creating should be fun! Make it easy and comfortable for yourself. Observe your posture now
that you are sitting. Maintain a relaxed upright posture with your head held high (not slouched
forward) and shoulders down (not hunched up). Sit comfortably facing the screen. Make sure
your eyes are in line roughly with the center of your screen. If you find you are straining your
neck by being forced to look up or down, then adjust your seat and/or monitor height until you are
comfortable.
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Make the Tablet Your Friend

Harmony Between Human and Computer

The graphics tablet is the key to unlocking the computer as an art tool. The graphics tablet is an input
device that replaces the mouse or trackball (though you can still use other input devices if you wish).
The graphics tablet has an active surface which corresponds to the computer screen. You apply a
special pen, also known as a ‘stylus’, to this active surface and thus control the cursor on your screen.
The tablet will become your friend, an extension of yourself. The company that supplies almost all
tablets is Wacom (pronounced wah’-kum). Wa is from the Japanese word for “harmony” and com is
short for “computer.” Thus Wacom means harmony between human and computer. This is a very
apt name since that’s exactly what we need as artists—harmony between our tools and ourselves.
The tablet I personally use, and highly recommend, for most of my art is the Wacom Intuos3 6x8/A5
(Figure 1.1).

I also enjoy using the Wacom Cintiq 18SX tablet, particularly for my live portrait sessions. The
Cintiq combines an LCD display with the tablet so you actually paint directly on your screen. It is very
intuitive and can be easily rotated and positioned for comfort. When painting live subjects I like the
fact that the Cintiq avoids having a vertical computer display screen between my model and I.

I share here some tips for using the Intuos3 and setting up the Wacom tablet Control Panel for
optimum ease of use in Painter. The new series of Wacom Intuos3 tablets come with an excellent
User’s Manual in PDF format. Take some time to review the manual so that you are aware of the
content. Wacom has kindly permitted me to reproduce some of the illustrations from their Intuos3
User’s Manual in this book. The Intuos3 Control Panel screen shots were taken on a Windows PC.

Customizable
Tablel Keys:

Touch Strip contrals

MNote: 4x5/A6 tablet

single Touch Siry

locatad to the lalt of the

lablel's active area,
Tablet work surface

m The Wacom Intuos3 6x8/A5 tablet.
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Relaxed Grip
Place your tablet centrally in front of you, between you and the screen. I find it most comfortable with
the tablet resting on my lap, and sometimes with the upper section of the tablet resting on the edge
of the desk. Rest the side of your favored hand on the tablet active surface. The standard Wacom pen
that comes with the Intuos3 tablet is known as a Grip Pen. Lightly hold the Grip Pen with a relaxed
grip close to the tip and slightly more upright than you would a normal pen or pencil. Your hand and
arm should feel totally relaxed. There should be no strain (Figure 1.2).

Keep the side of your hand in contact with the tablet at all times. This gives you maximum

GETTING STARTED

comfort and much greater control. If you hold the pen with your hand floating in the air, which is a
natural tendency for many, it is difficult to control and you'll find yourself accidentally clicking when
you don’t intend to.

Using the Wacom Grip Pen

The Grip Pen position determines precisely and uniquely where the cursor appears on the screen. The
Grip Pen is not relational like a mouse. There is absolute and unique correspondence between every
point on the tablet surface and every point on the screen. A Grip Pen does all the functions of a mouse
(and more). A light tap is a click. Two light taps is a double-click. Click and drag is a depression of the
pen at one position, maintaining the pressure while sliding the pen to another position, and then
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lifting the pen tip away from the surface of the tablet. From now on put your mouse or trackball to
one side and use the Grip Pen for all operations on the computer, both within Painter as well as outside
Painter. You'll find once you get used to it you won't ever want to use a mouse again!

The Grip Pen is supplied with three replacement standard white nibs, a grey spring-loaded Stroke
nib which gives a dampened feel to the pen and is designed to feel more like a brush, and a black Felt
nib which gives the feel of more resistance as you paint and is designed to feel more like a marker
pen. I personally like using the Stroke nib.

m Holding the Wacom Grip Pen.
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Wacom Intuos3 Control Panel

The tablet driver installs a Control Panel (Figure 1.3). Make sure you have the most up-to-
date driver installed on your computer (see www.wacom.com for free download of the
current drivers).

In Mac OS X select System Preferences > Other > Wacom Tablet. In Windows click Start >
Settings > Control Panel and double-click on the Wacom Tablet icon. If you ever need to
uninstall the Wacom control panel in Mac OS X, you’ll find an uninstall icon in Applica-
tions > Tablet.

Making Double-Clicking Easier

Select the Grip Pen icon in the Tools menu at the top of the Wacom Tablet Control Panel
(Wacom Tablet Properties on Windows).

Select the Pen tab.

Move the Tip Double Click Distance slider towards the right (Large). This makes it easier
to double-click (Figure 1.4). The compromise here is that you dont want to make it
too easy to double click or you'll find yourself accidentally double clicking when you don’t
wish to.

Click on the Details button in the Pen tab. This reveals the Feel Details window
(Figure 1.5).

Imos3 Mouse
e e e
for the salacted ol T —— e —
e
| v frog fow o =]
Tore
2
Mﬂ]ﬂﬂm Ml et Py Tip Dot i gt
o | o | CALSD L The DEFAULT buiton
Tyt Frpmry resels
iwtttfaﬁlﬂﬂﬂ P l e e gt
T Dianoans = = —== " oo
dialogbot, — 1 wes | [ | - |
| |
Displays advanced options. Displays User's Manual,

m The Wacom Control Panel with Pen Tab selected.
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m The Feel Details window.

Lower the Click Threshold slightly. This will make your pen more sensitive to registering a
click when you tap lightly. Experiment after you've set this. If you find you are accidentally
clicking too much, then return to this setting and increase the Click Threshold slightly.

You may also wish to adjust the Sensitivity setting in this Feel Details window to suit your
hand. If you find it difficult to make a mark in the Try Here: scratch pad (lower right corner
of the Feel Details window), then see if a higher Sensitivity setting helps. Click OK.

You are now back in the main Pen tab window. The Tip Feel slider in the Pen tab window
also gives you control over the pressure sensitivity of your pen tip. You will be further fine-
tuning your pressure sensitivity within Painter, so don’t worry about getting it exactly right
at this stage.

o
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LiEIERES The button-function pop-up menu.

Selecting Button Functions
The button on the side of the stylus is a two-function button. Each end of the button can be pro-
grammed to choose a separate function.

Click on the upper button-function pop-up menu, located in the upper right of the Pens
tab window. You will see a pop-up menu with a list of optional functions that you can set
that button function to be (Figure 1.6).

Select the function you desire for the back of the button (that is, the end of the button
furthest from the stylus tip). This is a matter of personal choice and convenience. Some
Windows users like to set this function to be Right Click or Alt. Personally | like simplicity
and | set both button functions on my stylus to be Disabled.

Repeat this for the lower button-function pop-up menu, which controls the function of
the front of the button (the end that is nearest the stylus tip).

Customizing the Tablet Keys

Click on the Functions icon in the Tools menu at the top of the Wacom Tablet Control
Panel.

Click on the Tablet Keys tab.

Go through the pull-down menus and decide what you wish to set each Key to be
(Figure 1.7).

Customizing the Touch Strip

Click on the Touch Strip tab.
Set your Touch Strip function and speed (Figure 1.8).

o
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Hls[ll= 1 The Touch Strip customization window.

You may find your stylus hand inadvertently activates the Touch Strip as you move around the tablet
and in that case you may wish to set the Touch Strip function on that side to disabled.

Please note that there are other functionalities within the Wacom Intuos3 tablet that I haven't
covered here, such as the Pop-Up Menu option. See the Intuos3 User’s Manual for further details.

Basic Stylus Tasks
If you are new to using a tablet, it is useful first to get used to some basic tasks. If you are already
comfortable using a Wacom tablet, then skip this section.

With your Finder/Desktop visible on your screen, click on one of the icons (for instance,
the hard drive icon on the Macintosh or the My Computer icon on Windows) so that it
becomes highlighted. Then click on the desktop background so that the icon is no longer
highlighted.

o
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Repeat this and see how light a tap can cause a click. You'll be amazed at how little pres-
sure you need to apply. Remember to relax your grip.

Click on the same icon, and this time keep pressure applied to your Grip Pen so that it
remains in contact with the tablet active surface, and drag the stylus across the tablet.
Observe the icon being dragged across the desktop.

Double-click on the icon so that it opens into a window (or an application, depending what
the icon is).

Close the window.

Drag the icon back to its original position.

Move the cursor to each corner and along the edges of the screen, keeping the stylus tip
about 1/4 inch above the tablet surface at all times. It is important to be able to move the

cursor around without accidentally clicking or dragging. Get a feel for the physical rela-
tionship between the boundaries of the screen and the boundaries of the tablet.

Create a Painter Alias (Mac OS X)

Locate the Painter IX folder in your computer.
Open the Painter IX folder and locate the Painter IX application icon.

Click and drag the Painter IX application icon into the Dock (usually located at the bottom
of the screen). You will see a Painter alias appear in the Dock.

A single click on the Painter icon in the Dock opens Painter.

I like to set up the Dock with small icons on the right of my screen. You can do this through
the Apple > Dock > Dock Preferences.

Create a Painter Alias (Windows)

Locate the Painter IX folder in your computer.

Open the Painter IX folder and locate the Painter IX application icon.
Right-Click on the Painter IX application icon and select Shortcut.
Drag the Shortcut onto your desktop.

Add Painter to the Start Menu (Windows)

If a Painter shortcut icon is on your desktop, hold down the Alt key and then click and
drag the Painter shortcut icon onto the Start button. Painter can now be launched from
the Start menu.

o
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The Brushes folder containing the Painter
Brushes library folder.

If the Painter icon is not on your desktop, click Start > Run and type Explorer.
Open the Program Files folder and then open the main Corel Painter IX folder.

Hold down the Alt key and then click and drag the Painter application icon (.exe file) over
the Start button. This creates a Painter shortcut icon and places it in the Start menu. Painter
can now be launched from the Start menu.

Load Jeremy Faves 2.0 Brush Category (Macintosh)

On the Companion Resource CD that comes with this handbook you will find the Jeremy Faves 2.0
brush category which contains many great brush variants, some from older versions of Painter and
some unique custom brushes made by myself or generously shared by others. These brushes will
enrich your experience in Painter.
Put the Companion Resource CD that comes with this handbook in your computer.
Double-click on the CD icon.

Locate and open the “Goodies_Mac_0OSX" folder. You will see a folder “Jeremy Faves 2.0”
and a JPEG file “Jeremy Faves 2.0.jpg.” Keep this window open and drag it to the right of
your screen.

Choose Go > Applications.
Open the Corel Painter IX application folder.
Open the Brushes folder within the Corel Painter IX application folder.

You will see a Painter Brushes folder within the Brushes folder (Figure 1.9). Place this
window, showing the Painter Brushes folder, on the left of your screen.

Drag the “Jeremy Faves 2.0” folder and the “Jeremy Faves 2.0.jpg” file into the Painter
Brushes folder. You have now successfully added the “Jeremy Faves 2.0” brush category to
your Painter Brushes library (Figure 1.10).

o
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WETEREER Copying Jeremy Faves 2.0 brush category
folder and icon to the Painter Brushes directory.

The Painter Brushes folder, the default brush library in Painter, contains all the brush cate-
gories. If you open the Painter Brushes folder you’ll see a long sequence of folders with brush
category names, each accompanied by a JPEG file of the same name, for instance, “Artists”
and “Artists.jpg.” These JPEG files are 30 x 30-pixel icons that represent each brush category
in the Brush Selector Bar within Painter. The brush category folders contain the individual brush
variants. Open one of the brush category folders and observe the mixture of .xml and other
files, which contain the brush data for each individual Painter IX brush variant. Seeing this will
give you a good understanding of the Painter brush hierarchy (Library > Category > Variant).

Double check that both the Jeremy Faves 2.0 folder and JPEG have been added to the Painter
Brushes folder. If they are not in that folder you will not be able to access the Jeremy Faves 2.0 brushes.
Note that since there is a space at the front of the file name the Jeremy Faves 2.0 brush category is
located at the top of the list of categories.

Load Jeremy Faves 2.0 Brush Category (Windows)

On the Companion Resource CD that comes with this handbook you will find the Jeremy Faves 2.0
brush category which contains many great brush variants, some from older versions of Painter and
some unique custom brushes made by myself or generously shared by others. These brushes will
enrich your experience in Painter.

Open My Computer.

Locate the Companion Resource CD (typically on the D Drive, but this may vary from com-
puter to computer).

o



0l.gxd 10/29/04 07:55 PM Page 19 $

PAINTER IX CREATIVITY: DIGITAL ARTIST'S HANDBOOK 19

Open the “Goodies_Win_XP_2000" folder if using Windows XP or Windows 2000.
Select the”Jeremy_Faves_2" folder and Jeremy_Faves_2.jpg JPEG.

Right-click on the two highlighted items and drag to Copy to Folder (or choose Edit > Copy
to Folder).

In the Copy Items window locate Local Disk C > Program Files > Corel > Corel Painter IX >
Brushes > Painter Brushes. Copy both items into that location (Figure 1.11).

If you are on Windows XP or Windows 2000, insure the Read Only property is unchecked for

GETTING STARTED

all the files you've copied.

Locate the two copied items.

Select each item (Jeremy_Faves_2 folder and Jeremy_Faves_2.jpg file).
Right-click and choose Properties (File > Properties).

Uncheck the Read Only box if you find it is unchecked.

Click Apply.

Choose the option “Apply to this folder, subfolders and files.”

Click OK.
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Check the individual files to make sure the Read Only property has been removed.

What to Do with Your Old Jeremy Faves Brush Category?

If you already have the earlier version of my custom brush category, Jeremy Faves, loaded
onto your computer from the Painter 8 Creativity: Digital Artist's Handbook, | suggest you do
not copy it over to Painter IX but instead use the new Jeremy Faves 2.0 category that comes
with this handbook. If you've already copied it over, you may wish to remove it to keep your
brush library efficient (you don’'t want to have too many categories because the category list

becomes too long). | have kept key brushes from my earlier Jeremy Faves category and added
some wonderful new ones, so Jeremy Faves 2.0 is an even bigger and better collection of
brushes.

Make a Backup Copy of Your Brushes Folder

At this stage make a backup copy of your Brushes folder, the one that is within your Corel Painter IX
application folder. On Macintosh OSX hold down the Option key while you drag the Brushes folder to
another location within the Corel Painter IX folder. This will create a copy of the folder called Brushes
Copy. On Windows first select the Brushes folder and then choose Copy (Ctrl-C) followed by Paste (Ctrl-
V). This will generate a folder called Copy of Brushes. It will be useful to have the Brushes folder
backed up in case if you ever have a brush variant file become corrupt and need replacing (which

unfortunately may happen from time to time).
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20 PAINTER IX CREATIVITY: DIGITAL ARTIST'S HANDBOOK

Backing Up Custom Data

In Chapter 3, “Brush Creation,” you will find further instructions about backing up the
Painter customization data, which is stored in another location on your computer. | recom-
mend that you back up custom data every few months to ensure your custom brushes are
preserved.

Loading Other Goodies

Copy the remaining contents of the appropriate Goodies folder into your Corel Painter IX applica-
tion folder. This extra content includes extra papers, patterns and color sets. The extra color sets are
contained in a special custom folder “Jeremy Xtra Color Sets” / “Jeremy_Xtra_Color_Sets”. I suggest
you copy this folder, along with the extra paper textures and patterns, directly into the Corel Painter
IX application folder. This will mean you end up with the default Color Sets folder, the standard Painter
Colors color set and the custom folder “Jeremy Xtra Color Sets” / “Jeremy_Xtra_Color_Sets”, all at
the same level of hierarchy.

If you are using Windows XP or 2000 make sure the Read Only property is unchecked for every-
thing you copy over from the Companion Resource CD.

1.5 Welcome to Painter

Open and Mount a Canvas in Painter

In this section we're going to start by opening a new canvas in Painter so that you have a scratch pad
to try brushes out on. We'll make some basic adjustments in the Preferences to make things more
comfortable and convenient.

Opening a New Canvas

Open Painter.
Select from the top menu bar File > New (Cmd/Ctrl-N).

In the New Picture window set the canvas size to 700 pixels wide by 750 pixels high.
Leave the resolution at 72 pixels per inch, the paper color white, and the picture type as
Image.

Click OK.

Mount and Reposition Your Canvas

Mount your canvas by selecting the keyboard shortcut Cmd/Ctrl-M. This is equivalent to
going to the top menu Window > Screen Mode Toggle. You now see your canvas appear-
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ing against an inert gray background that you can click on and drag over without acci-
dentally going back to the Finder (Mac users). It is also visually simpler than having the
canvas border frame around the canvas. Always work in screen mode unless there's a
specific reason not to.

Move the cursor over the canvas.

Hold down the spacebar on your keyboard (or you can use the lower function button
on the Wacom Intuos3 tablet which is set by default to be the space bar). The cursor
changes into a hand (the same Grabber Hand as in the Tools palette). Click and drag the
canvas, still holding the spacebar down, and move the canvas so it fits snugly in the top
left corner.

Set Up Painter Preferences

In this section you will be introduced to each of the Preferences in Painter. Some you may not need
to adjust, but it is still useful to be aware of the default settings and how to access them.

General Preferences

Choose Cmd/Ctrl-K (Corel Painter IX / Edit on Windows > Preferences > General).

In the General Preferences window adjust the cursor angle. If you are right-handed you
may prefer your cursor to point toward the upper left (Figure 1.12). If you are left-handed,
you may prefer it pointing to the upper right.

Freferences

(i =

Dirawing Cursor Libraries
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You may wish to uncheck the “Enable Brush Ghosting” checkbox. By default this option is
checked, which results in a preview of the brush shape and size, visible on the canvas when
you're about to paint, which disappears when you actually paint. The advantage of brush
ghosting is that you know immediately when you place your cursor on your canvas how
big your brush size is and the shape of the brush. The disadvantage is that with very small
brushes it is difficult to see where your cursor is, and with large brushes it is difficult to
know exactly the point at which your brushstroke will start. Try it with and without
the brush ghost and decide for yourself. | personally prefer to have the brush ghosting
disabled.

Under Quick Clone uncheck Switch to Cloner Brushes.
Check “Draw zoomed-out views using area-averaging.”

Click OK to return to your canvas.

Brush Tracking Preferences

In the top right corner of your Painter desktop you will see a brush selector with two icons
and a description of the current brush category and variant (these terms will be explained
in more detail later in this chapter). Click on the left icon. You will see a pop-up menu that
lists the brush categories.

At first you will just see five categories listed in the pop-up menu. Click and drag the
bottom right corner of the category pop-up menu downward until you see a complete list
of categories visible on your screen (ends with Watercolor).

Select the Artists category.

Click on the right-hand icon. You will see a pop-up menu that lists the brush variants con-
tained within the Artists category. It is a good idea to get into the habit initially of click-
ing and dragging down the bottom right corner of each variant pop-up menu to make
sure you are seeing all the variants available.

Select the Sargent Brush variant.

Make a brushstroke on your canvas starting with very soft pressure and ending with hard
pressure. Does your brushstroke smoothly go from thin to thick, or is there an abrupt “jog”
in the stroke where it suddenly gets thick? If the latter, then adjusting the Brush Tracking
Preferences can help. Try a few brushstrokes like this to be sure. Don’t be afraid to press
hard! Note how the thickness responds to pressure. Make sure you test out the full range
of thickness by going to extremes of light and heavy pressure. You should be able to com-
fortably control the thickness across the full range. Sometimes you may find that the brush
is either too sensitive or too insensitive in response to the pressure you apply. We all apply
a different natural range of stylus pressure when we paint. Brush Tracking allows Painter
and your stylus to be sensitive to your natural pressure range.

Choose Cmd/Ctrl-K.
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Click on the Preferences pop-up menu (where you see the word General) and select Brush
Tracking.

Make a note of the four slider settings, since once you adjust them and click OK to try
out the new settings, you can’t go back and cancel or reset the sliders to their previous
values.

Make a single light stroke in the Brush Tracking Preferences window (Figure 1.13).

Click OK.

Try out a light to hard brushstroke on your canvas and see if the transition from thick to
thin is now smoother and better controlled than before. If needed you can return to the
Brush Tracking Preferences and repeat the process.

Customize Keys Preferences

Choose Cmd/Ctrl-K.

Click on the Preferences pop-up menu (where you see the word General) and select Cus-
tomize Keys. You will see here a summary of all the main menu and submenu application
commands (those that you see along the top of your screen) with all the default keyboard
shortcuts (Figure 1.14). You can click in the shortcuts column next to any menu item and
type in your own shortcut. This incredible facility is heaven for anyone who likes using key-
board shortcuts in their workflow. If you find there is an operation you keep doing regu-
larly that doesn’t have a shortcut, this is the place to go to create one.

The two Customize Keys shortcuts I recommend adjusting immediately for ease of use are the
shortcuts for Tools > Scissors and Other > ColorTalk (ColorTalk is a programming language that

o
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allows you to automate tasks). The default for Scissors is “Z,” which is easily accidentally chosen if
you try to choose Cmd/Ctrl-Z (undo) and miss depressing the Cmd/Ctrl key in time. I recommend
making the Scissor shortcut “Shift-Z". The default shortcut for Other > ColorTalk is “N,” which is
easily accidentally hit when you mean to hit the “B” key. I recommend changing the ColorTalk short-
cut to Option-Shift-N/Alt-Shift-N (Shift-N is already taken by ColorTalk Movie).

Undo Preferences

Click on the Preferences pop-up menu and select Undo. You will see that the default is set
to the maximum of 32 (Figure 1.15). | suggest leaving this as is. This means you can repeat
Cmd/Ctrl-Z 32 times and sequentially undo your last 32 actions on the canvas (brushstrokes,
commands, effects).

Shapes Preferences

Click on the Preferences pop-up menu and select Shapes (Figure 1.16).

Uncheck the defaults of Stroke in Current Color on Draw and Fill with Current Color on
Close.

Check Big Handles.

These settings help keep your paths simple and unobtrusive when you use the Pen tool to create and
edit a path for the purposes of selection.

Note that the Shapes Preferences window also contains an Align Brush to Path Tolerance setting
for the snap-to-path painting feature.

Internet Preferences

Click on the Preferences pop-up menu and select Internet. You will see the default library
address used by the Help menu. Just leave this as is.

o
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Save Preferences

Click on the Preferences pop-up menu and select Save.

For Mac users choose Append Always (the default is Never) and check Use Lower Case
(Figure 1.17).

For Mac and Windows users make the Color Space RGB for both TIFF and Photoshop (PSD)
files. The defaults are Prompt on Save.

Palettes and Ul Preferences

Click on the Preferences pop-up menu and select Palettes and Ul.

If you wish to change the window background color from gray (this is the background
color you see surrounding your canvas when it is mounted in Screen Mode), then select
the color in your Colors palette and click on the Window Background: Use Current Color
button. I use this for presentations when | prefer a dark gray or black background color
rather than the default mid gray (Figure 1.18).

Memory and Scratch Preferences

Click on the Preferences pop-up menu and select Memory and Scratch (Figure 1.19).

If you wish to maximize the potential power of Painter when working on large files, you
change the Memory Usage from 80% to 100% of available.

Make sure the Scratch Disk you have assigned has plenty of free space.

Register

If you haven't registered your copy of Painter, do so by selecting Help > Register.
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Set Up Your Painter Desktop

We take a look at the Painter desktop and review what's what and what’s where. We look at how you
can control your desktop and explore the brushes hierarchy.

Desktop Overview

The Painter IX desktop comprises four main interface elements: Toolbox, Property Bar, Brush Selec-
tor Bar, and Palettes. The palettes that are initially displayed by default when you first open Painter
are the Color palettes (Colors, Mixer, Color Sets, and Color Info) and the Layers and Channels palettes.
There are many other palettes available through the Window menu (Figure 1.20). Palettes are listed
under the Window menu with either Hide or Show preceding the palette name, depending on whether

o
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they are already visible on your desktop. Under the Window menu some palettes have been grouped
together by type (Brush Controls, Color Palettes, Library Palettes).

All of these elements can be moved around, rearranged, or hidden. Thus you have complete flex-
ibility in controlling your Painter IX environment. My intention here is to give you a quick overview
of what’s where rather than go into detail and describe every palette and menu item in detail. For a
more detailed description of the Painter desktop elements please refer to the Painter IX User Manual
and Getting Started Guide.

GETTING STARTED

Toolbox

The Toolbox lets you access the Painter IX tools plus a variety of art materials, such as the papers,
patterns, gradients, nozzles, weaves, and brush looks (Figure 1.21). Note that a small triangle in the
bottom right corner of a Toolbox icon indicates that a pop-up menu is accessible if you hold your
cursor down on the icon. Take a few moments to explore the Toolbox.

Property Bar
The Property Bar provides easy access to commonly needed parameters related to the currently
selected tool. Notice as you change the tool choice how the Property Bar changes. For the Brush tool
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the parameters displayed in the Property Bar are dependent on the specific brush variant that is cur-
rently selected. Greater in-depth adjustment of brush parameters is possible through the Brush Con-
trols group of palettes (Window > Brush Controls) or by choosing the Brush Creator mode (Window
> Show Brush Creator).

Brush Selector Bar

Brushes are at the heart of Painter’s magic. The phenomenal range and ability of Painter’s brushes
empowers you to express yourself freely on the digital canvas. The Brush Selector is where you choose
the specific brush you wish to use. It comprises a Category pop-up menu on the left and, immediately
to the right of the Category pop-up, the Variant pop-up menu (Figure 1.22). Always select Category

—_— m The Toolbox.
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first and Variant second, since each brush category (grouping, type, or family of brushes with similar
behaviors) contains a separate set of brush variants (individual brushes). You can think of brush cat-
egories like drawers in an art cabinet, with each drawer containing a different collection of related
art tools (oil paint brushes, crayons, pens, pencils, etc.). When you first open either the Category pop-
up menu or the Variant pop-up menu, you will see just the first five items listed and a scroll bar on
the right of the menu. I recommend you drag the bottom right corner of the menu down as far as it
will go to show the complete list.

The consistent hierarchy of brushes in Painter is Library > Category > Variant. Understanding
this hierarchy is vital to using Painter.

There is a Brushes pop-up menu (Figure 1.23), accessible by holding the cursor down on the tri-
angle in the top right of the Brush Selector window. This menu allows you to choose commands for
saving custom variants when you create a new brush you like and for returning the current variant
to its default settings.

Palettes

There are thirty five palettes that come with Painter (more can be created using Window > Custom
Palettes). Nineteen of these palettes are grouped within the Brush Controls palette. Many palettes
have pop-up menus on the far right of the palette title bar (click on the triangle). You may find you
want different combinations of palettes showing for different tasks. For instance, when painting you
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may just want to see Colors and Layers. For working with text you will also want to see the text palette.
For working on collage the layers and channels palettes will be needed. Palettes can be conveniently
grouped or ungrouped (for instance, the Color palettes are initially all grouped together) and opened
or closed (when closed, you just see the palette title bar), as well as hidden or shown. Thus you can
make the best use of your working space and avoid getting it too cluttered.

Moving Palettes

To move palettes into or out of a group of palettes or to change their order within a group of palettes,
you simply click and drag on the center of the title bar (the cursor becomes a Grabber Hand as you
pass over the center of the palette title bars).

Opening and Closing Palettes
To open or close a palette you click on the left of the palette title bar, where the solid black triangle
and palette name are visible.

Hiding and Showing Palettes

To hide a palette you click on the close button on the right side of the palette title bar. To access the
palette pop-up menu you click on the small solid black triangle on the far right of the palette title bar
(Figure 1.24).

Custom Palettes
Custom Palettes are ideal for making convenient desktop shortcuts for frequently used commands
and menu items. They can also be used to create shortcut buttons for your favorite brushes.

Make a “Save As” Button

A “Save As” button encourages you to save versions of your work regularly and avoids your acci-
dentally overwriting your files with File > Save instead of File > Save As. The Save As command takes
you to the Save As window, in which you can enter the file name, determine file format, and choose
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where to save the file. I recommend that you save your work in progress as a RIFF file (the native
format of Painter) and your final image for printing as an RGB TIFF. You will find a detailed discus-
sion regarding strategies for naming and saving your artwork in the next chapter. For the remainder
of this chapter I suggest you save any images you create as RIFF files in an appropriately named folder,
such as “Painter Projects ChptO1.”

Iterative Save

There is an Iterative Save command (File > Iterative Save), which automatically saves your work
in progress with sequentially named files. Each Iterative Save file name ends with a three digit
number, such as _001, _002, and so on, immediately preceding the file format tag (such as .rif
or .tif tag). The Save As command is useful even if you choose to use the Iterative Save func-
tion, since there will be times you wish to rename a file, such as after making a clone copy
(duplicate).

Make sure there is a file open in Painter (File > New, Cmd/Ctrl-N, or File > Open.
Cmd/Ctrl-0).
Drag down to Window > Custom Palette > Add Command.

Select File > Save As. You will see Menu Item: Save As in the Add Command window
(Figure 1.25).

Click OK. This generates a custom palette called Custom-1 containing a “Save As” button.
Choose Window > Custom Palette > Organizer.
Locate the new Custom-1 palette in the Organizer and click on it so that it is highlighted.

Choose Rename and rename Custom-1 “Shortcuts.”
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m The Add to: menu in the Add Command window.

Make a “Quick Clone” Button

Quick Clone is a useful feature that does several steps in one command. The steps are determined in
the General Preferences. It is handy to have this as a shortcut button when you are working from
photographs.

Choose Window > Custom Palette > Add Command.

Choose Shortcuts, or whatever you named your custom palette, from the Add to: menu in
the Add Command window (Figure 1.26).

=2
2
[
<
[a]
=2
=)
(©]
w
-
o
w
-
o
<
I
v

Choose File > Quick Clone.

Click OK.

Adding Other Menu Commands to Your Shortcuts Custom Palette

Other menu commands you may find useful to add to your shortcuts custom palette, besides Save As
and Quick Clone, are File > Clone, Window > Screen Mode Toggle, and Window > Zoom To Fit. You
may eventually wish to create different custom palettes for different types of projects, such as one
specifically for working with photographs and another for working with layers (including a Layers >
Drop All button). Name each custom palette appropriately so that you can easily recognize which

one it is.

Adding Brush Variants to Your Custom Palette

Besides using the Add Command function to add further buttons to your Shortcuts custom palette
(such as adding the File > Clone command, which is very useful for photography), you can drag icons
from any of the libraries (Brushes, Gradations, Papers, Patterns, Scripts, etc.) into your custom
palette. This is very useful if you find yourself using the same few brush variants for a particular
project.

Moving Buttons and Icons within Your Custom Palette

By default, icons and buttons line up horizontally in the custom palette. If you want a vertical
arrangement of icons and buttons in the custom palette or wish to move the buttons around and
change their order, hold down the Shift key and click and drag on the icons and buttons.

o
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Hiding and Showing Custom Palettes
To hide a custom palette, click on the palette close button (top left on Macintosh, top right in
Windows). To show a custom palette, choose Window > Custom Palette > palette name.

Deleting Custom Palettes

You can use the Custom Palette Organizer to delete extra custom palettes that you no longer want or
that you create accidentally (easily done when dragging brush icons onto your desktop). To delete
icons or buttons, choose Window > Custom Palettes > Organizer. Select the name of the custom
palette you wish to delete in the custom palette Organizer. Click the Delete button in the Organizer to
delete the selected custom palette.

Showing Brush Size
I find it useful to see a graphical representation of my brush size as I paint and therefore recommend
the following:

Choose Window > Brush Controls > Show Size.
Drag the Size palette up to the top of the Brush Controls group of palettes.

Drag the bottom right corner of the Brush Controls upward until you can just see the Brush
Size palette down to the Size slider.

Library Selectors and Palettes

Painter has a variety of Libraries, or collections, that can be accessed through Selectors. In the case
of the brushes, the brushes library is a collection of brush categories, each of which is a grouping of
individual Variants. As we have seen, to select a brush you use the Brush Selector Bar to choose first
the Brush Category and then the Brush Variant.

The Paper, Gradient, Pattern, Weave, Look, and Nozzle Selectors are all accessible at the bottom
of the Toolbox as well as via the Window menu (except for Look and Nozzle Selectors, which are only
accessible through the Toolbox). The Scripts, Selection Portfolio, and Image Portfolio Library Selec-
tors are accessible through the Window menu. The content of all libraries, other than the brush
library, are edited and controlled via Movers (typically listed at or near the bottom of the corre-
sponding palette pop-up menu).

Initially the library palette you are most likely to want to see on your desktop is the Papers palette
(Window > Library Palettes > Show Papers). This gives you a preview and control of the paper texture
applied with grainy brushes.

Saving Palette Arrangements

As you work in Painter you'll find you rearrange your desktop to suit different tasks, hiding or
showing those palettes that are relevant, creating custom palettes as appropriate. When you have a
palette arrangement you like and that you wish to be able to return to in an instant at any time,
choose Window > Arrange Palettes > Save Layout (Figure 1.27). Name your layout with a descrip-
tive name that relates to the task it is good for (e.g., Simple Paint).
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Hleli il Saving a palette arrangement.

If you ever wish to return to the standard palette arrangement, select Window > Arrange Palettes
> Default.

1.6 Foundation Skills

Foundation skills are the nuts and bolts of painting. You've already learned how to open, mount, and

save a canvas and how to select your brush variant from the Brush Selector Bar. The remaining foun-
dation skills you need to learn are how to control your brush size, how to pick color, and how to
remove paint.

Controlling Your Brush Size

Some brushstrokes vary in width according to the pressure you apply with your stylus. If you want
more variation of brush thickness than that provided by pressure control, then you need to adjust
the Brush Size. You can do this by a number of different means.

Selecting Size in the Property Bar
Click on the right side of the size box in the Property Bar to reveal the pop-up size slider.
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The Size Preview and Slider in the Size Palette

Choose Window > Brush Controls > Show Size if it is not already showing on your desktop.
The preview window on the upper left indicates brush diameter (Figure 1.28). The outside
of the solid black circle is the brush diameter. Some brushes, such as the Artists > Impres-
sionist variant, have a variation of diameter built in (Min Size slider less than 100%), in
which case you will see an inner solid black circle, indicating the minimum diameter, and
an outer gray ring, indicating the maximum diameter.

If you click on the Brush Dab Preview Window in the Size section you see a depiction of how the
pigment is distributed (Figure 1.29). Click again and it returns to the original solid circles. Have the
preview set to show the solid black (or black and gray) circle.

The twelve small brush dab profile icons, located on the upper right of the Size preview, show
the way pigment will be distributed across the width of the stroke.

Key Shortcuts

You can use the key command combination Cmd-Option-Shift/Ctrl-Alt-Shift and click and drag on
the canvas to change size rapidly over a large range. For a small incremental increase or decrease in
the brush size, you can use the bracket keys (the “[‘key for decrease, the’]” key for increase).

Picking Color

Painter has four Color Palettes: Colors, Mixer, Color Sets, and Color Info. You can adjust and select
color from any of these four palettes, plus you can sample color from an existing image using the
Dropper tool. These different ways (except the Color Info palette) to pick color are reviewed here.

o
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Color Palette

Standard Colors

The Color palette has two ways of displaying color. The default display is the Standard Colors color
picker, with an outer Hue Ring (based on a representation of the color spectrum known traditionally
as the color wheel) and a Saturation/Value Triangle in the center. The other color picker, Small Colors,
combines a single horizontal hue bar with a Saturation/Value Triangle. You choose between the Stan-
dard Colors and the Small Colors in the Color palette pop-up menu (small solid black triangle in the
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top right of the Colors palette). I reccommend sticking with the Standard Colors color picker, which is
the one that will be shown throughout this handbook (Figure 1.30).

To choose a color in the Standard Colors color picker you have to adjust both the small circular
cursor in the outer Hue Ring and the one in the central Saturation/Value Triangle. To select either
white or black in the Color Picker, take the Saturation/Value Triangle cursor to the upper left corner
for white or to the lower left corner for black. The hue is not relevant when selecting white or black.
It is easy to leave the Saturation/Value Triangle cursor in one of the corners (black lower left or white
upper left) and wonder why you are not getting the color indicated by the cursor position in the hue
ring. You will find a more in-depth discussion of color in Chapter 11.

Main and Additional Colors

Notice the two overlapping squares of color in the lower left corner of the Colors section and also in
the Tools palette. These are the Main and Additional colors. The Main Color is indicated by the fore-
most of the two overlapping squares. Behind the Main Color square is the Additional Color square.
You make the square active by clicking on it. The active square is highlighted by a bold black border
in the Tools palette. When you first open Painter, the Main Color square is always active.

Although these color squares closely resemble the Foreground and Background color of Photo-
shop, they have quite different functions in Painter. Most brushes apply only the Main Color. The Addi-
tional Color has several uses, such as specifying a two-color gradient (the Two Point gradient in the
Gradients palette), the pressure-sensitive colors seen in the F-X > Gradient Flat Brush), and provid-
ing a tint color for Image Hose nozzles (when the Grain slider in the Property Bar is moved to the left).
I recommend that you always have the Main Color active and use the exchange arrows to toggle
between the Main and Additional colors when you need to.
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Choosing Paper Color

Do not confuse the Additional Color with background or Paper Color. The Additional and Main
Color squares in Painter look deceptively similar to the Background and Foreground color rec-
tangles in Adobe Photoshop. The Paper Color in Painter is determined in the New File dialog
box or by choosing Canvas > Set Paper Color, at which point the Paper Color becomes the
current Main Color for the current active image (if you then open another image, the Paper
Color will return to the default white). The Eraser family of brushes—and the Select All > Delete
commands—erase to the current Paper Color. When you enlarge a canvas by choosing Canvas
> Canvas Size, the extra canvas added on is the color of the current Paper Color. You can use
this fact to add colored borders to your work. The default Paper Color is white.

Clone Color

The little icon that looks like the Photoshop Rubberstamp icon, located below the Hue Wheel in the
Colors palette, is the Clone Color button. It can be activated/deactivated for any brush by clicking on
it or using the keyboard shortcut “U.” When the Clone Color button is activated, the Hue Wheel, Value
Saturation Triangle, and Main and Additional Color rectangles are all grayed out, and the current
color is determined by the current clone source (see File > Clone Source). Note that the Cloners
brushes have clone color activated but that the Hue Wheel, Value Saturation Triangle and Main and
Additional Color rectangles are not grayed out.

Mixer Palette

The Mixer palette (Figure 1.31) is based on a traditional artist’s palette. There is a scratch pad known
as the Mixer Pad on which you can apply, mix, blend, and sample colors using a variety of special
Mixer tools. These tools are accessed by clicking on small icons displayed below the Mixer Pad.

(&)

} Colors = »

-Jl:ki Swatch to Color Set...
Mixer Swatches — B0 B @E@ ) & New Color Set from Mixer Pad

Load Mixer Colors...
Sava Mixer Colors...
Reset Mixer Colors

Use Subtractive Mixing

Mixer Pad —
Open Mixer Pad...
Save Mixer Pad...
Clzar Mixer Pad
Change Mixer Background. ..
—
Mixer Tools —
» Co.lnr Sets - 4
} Color Info B »

WETERERR The Mixer palette.
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From the Mixer pop-up menu (small solid black triangle in upper right corner) you can save the
Mixer Pad colors and image or convert the Mixer colors into a new color set.

Color Sets

Color Sets can offer you power, elegance, and consistency in your choice and application of color.
Color sets allow you to restrict your palette to a particular range of colors and easily pick those colors
just by clicking on the color squares. They are ideal if you wish to limit your palette of colors and
keep consistency of colors throughout a project. There are many different color sets supplied with

GETTING STARTED

Painter, and it is easy to create your own custom color sets.

When you first open the Color Sets palette you'll see a series of color swatches displayed, with
the name of each color listed beside the swatch. Unless you need to know the actual names of colors,
I recommend going to the Color Sets pop-up menu (click on the small solid black triangle in the upper
right of the palette) and uncheck Display Name (Figure 1.32). You will then see all the swatches
visible simultaneously. The Color Sets principle is simple: you click on a swatch, and that becomes
your current color.

The default color set has a range of traditional oil paint pigment colors. To access other color
sets, choose Open Color Set from the pop-up menu. Then locate the Color Sets folder in the Corel
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Painter IX application folder and select a color set from those listed within the folder. Note that the
default color set is called Painter Colors and is located in the Corel Painter IX application folder outside
of the Colors Sets folder. The JeremyXtraColorSets folder can be copied over from the Painter Cre-
ativity Companion CD into the Corel Painter IX application folder, and its contents will then be acces-
sible through the Open Color Set command.

If you choose New Empty Color Set from the Color Sets pop-up menu, you can pick your own
colors from the Colors palette or from an image and save them one at a time into your new custom
color set (you would simply click on the Add Color to Color Set button, second from the right at the
bottom of the Color Sets palette). You can edit any color set, adding or taking away colors, at any

p Calors » |
P Mixer

New Empty Color Set

New Color S8t from Image
Mew Color Sat from Layer
Mew Color Set from Selectian

Wew Color Set from Mixer Pad

DOpen Coler Set...
Append Color Set..
Save Color Set...

Show Grid
Display Name

Find Swatch...

p Color Infa 3

Sort Order

Swatch Size [GE[IERIERE The Color Sets palette
—— -
showing pop-up menu.
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time from within the Color Sets palette. Adding colors to a color set as you work can be useful in build-
ing up a color set of your favorite colors over time.

One of the useful applications of creating your own color sets is when you wish to emulate the
color palette of an artist. You can open a scanned image of that artist’s artwork and then select New
Color Set from Image in the pop-up menu. You'll instantaneously generate a new color set based on
the colors that artist used. After creating a custom color set, choose Save Color set, give it a suitable
name, and save it in the Color Sets folder (or any other location) in the Corel Painter IX application
folder.

Sampling from an Image

The Dropper tool can be used to sample color from any active image in Painter. When you have the
brush tool selected and do NOT have the clone color button checked in the Color palette, then the
Option/Alt key turns your cursor into the Dropper tool.

Resetting the Clone Source Point

If you use the key shortcut Option/Alt when painting with the clone color button checked, you
will reset the clone source point to wherever you click in the image (your cursor will become
a crosshair when you press the key followed by a green dot and the number “1"” when you
click in the image).

Removing Paint

When you're painting, I encourage you to avoid the temptation of erasing, deleting, and undoing
brushstrokes to get things perfect. Although the computer offers many convenient ways to edit and
remove paint, your paintings will take on greater depth, richness, and interest if you build up your
brushstrokes, even when you're not happy with them, rather than deleting them. Be committed to
your marks. Let every mark contribute to the fabric of your painting. Having said that, here’s a brief
synopsis of what options are at your fingertips when you do wish to remove paint.

Erasing

The Eraser variants in the Erasers category of brushes erase to the paper color (which is white by
default but can be set for the active canvas to be the current Main Color by selecting Canvas > Set
Paper Color). The Bleach variant simply bleaches out the color on the canvas until it is white, inde-
pendent of the Paper Color. The bleach gives a similar effect to the Dodge variant in the Photo cate-
gory of brushes. Try the Eraser variants on your painted image. You can also simply turn your stylus
over on its end and use the large eraser at the opposite end of the stylus tip (although I find this a bit
cumbersome). You can also just paint with white using any brush that adds color to the canvas.

o
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Deleting Selected Regions of Your Canvas

You can use a selection tool (e.g., lasso or rectangular/oval selection tool) to select a region of canvas.
If you want a soft edge to your deletion, choose Select > Feather and feather the selection by 10 pixels
or so. Then select Delete/Backspace to delete to the Paper Color.

Clearing Your Whole Canvas

Select Cmd/Ctrl-A (equivalent of choosing Select > All). You'll see dancing ants around the

GETTING STARTED

perimeter of your canvas (unless the perimeter is beyond the limits of the screen).

Click the Delete/Backspace key on the keyboard. Your canvas clears to the paper color,
white by default, unless you have created any Watercolor or Liquid Ink layers, in which
case you'll see those remaining (you cleared only the background canvas).

Undoing Individual Brushstrokes
To undo individual strokes, use the Cmd/Ctrl-Z (up to 32 levels of undo).

Fading a Brush Stroke or Effect
It is also possible to partially undo a brushstroke or effect by selecting Edit > Fade. This is a particu-
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larly useful feature for effects, since the small preview windows in the effects dialog boxes often lead
you to underestimate the influence of the effect when applied to the whole canvas.

1.7 Brushes That May Make You Scratch Your Head

Most brushes are straightforward to use and behave in logical, predictable ways. You just pick the
brush and then paint with it directly on your canvas. You'll typically see color painted onto the canvas
or interaction with color already on the canvas or both. You'll notice a myriad of subtle differences

in behavior, such as some brushes covering up other colors, some mixing with other colors, some
showing paper textures, some changing size with pressure, and so on. You don’t need to know any-
thing special; just try them and see what they do.

As you explore Painter’s brushes you will inevitably run into some mysteries. Some brushes don’t
seem to paint any color (some Blenders and Distortion brushes, for instance). Some brushes paint
with a color different from that chosen in the Colors palette color picker (cloners take color from the
default clone source, the currently selected pattern in the Patterns library). Some brushes (Water-
color and Liquid Ink) paint into special layers, and when you try painting with other brushes after
using either of those, you get a warning telling you that only Watercolor/Liquid Ink brushes can be
used on Watercolor/Liquid Ink layers. These are all examples of brushes that may make you scratch
your head.

What follows are the few extra steps you need to follow to realize the full potential of these
“scratch your head” brushes: Image Hose, Cloners, Watercolor, Liquid Ink, and Impasto.
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Image Hose

Painting with Sequences of Image Elements

The Image Hose Brush Category is represented by the icon showing a garden hose nozzle with green
clover leaves spewing out of the end. When you paint with it, you will see a succession of images
being painted onto the canvas.

Nozzle Selector
The set of images that are being painted are known as a Nozzle. The Nozzle selector is located in the
lower right corner of the Toolbox (Figure 1.33).

Image Hose Variants

The variants for this brush category are unlike all others (Figure 1.34); they do not indicate differ-
ent brush variants but simply different ways that the nozzle elements are distributed as they leave the
Image Hose. For instance, in the “Spray-Size-P Angle-D” variant, “Spray-Size-P” means the size of
the elements, and their proximity to each other as they are sprayed out is determined by stylus
pressure. “Angle-D” means the direction of the Nozzle image elements follows the direction of your
brushstroke.

- Image Hose »
prav-Size-P Angle-D

ﬁmg .

=8 .
4/0) | # Linear-Angle-W

s [T{% ® Llinear-Size-P

' M @ Linear-Size-P Angle-R ’
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variant list.
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Select different nozzles and try them out. Choose different variant options and see their effect.
Try light pressure as well as heavy pressure. Try short dabs as well as long strokes.

Picking up the Additional Color in the Image Hose

Choose a bright color in the Color Picker.

Click on the exchange arrows to make that bright color go to the Additional Color rec-
tangle.

Move the Grain slider to the left in the Property Bar.

Make a brushstroke and note how the nozzle color changes when you paint.

Creating Your Own Image Hose Nozzles

Paste your nozzle contents as layers in a file.

Select all the layers in the Layers palette by clicking on each one with the Shift key held
down or choosing Select All in the Layers pop-up menu.

Select Cmd/Ctrl-G to group the layers.

Select Make Nozzle from Group from the Nozzles pop-up menu located in the top right
of the Nozzles selector in the Tools palette.

Save the resulting file as a RIFF file with the name you wish to call your nozzle.
Choose Cmd/Ctrl-L.

Locate your nozzle file and click Open.

Apply the nozzle on your canvas.

Select Add Nozzle to Library. Your custom nozzle will now be part of the current Nozzle
Library.

Cloners

Powerful Image Transformation Tools
The Cloners variants look at a clone source for their source of color, rather than the Colors palette
color picker (which is usually grayed out when Clone Color is active). There are numerous different
Cloner variants, many of which act as artistic filters that you selectively apply by hand rather than
apply instantaneously and globally over the whole image, as you do when applying an effect.

You are not restricted to the Brush Variants of the Cloners Brush Category to clone from one
image (source image) into another (destination image). You can turn almost any brush in Painter
into a Cloner brush simply by checking the Clone Color Box in the Colors palette. This makes Painter

o
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a phenomenally powerful image transformation tool, since you can hand-paint a clone transforma-
tion using an almost unlimited variety of brushes. Please refer to Chapters 4 and 5 for in-depth infor-
mation on how to transform photographs with the use of cloning brushes.

The Default Clone Source

The default clone source in Painter is the currently selected pattern (Window > Library Palettes >
Show Patterns). When you first use the Cloners you'll often see a mysterious grey pattern appear on
your canvas, which happens to be the colors in the default current pattern. Changing the pattern in
the Pattern Selector will change what the cloning brushes paint if the pattern is the current clone
source. The current clone source can be identified by choosing File > Clone Source and seeing what
has a checkmark by it (Figure 1.35).

Starting with a Photograph

If you start with a photograph open in Painter and then choose either File > Clone and File >
Quick Clone, a duplicate image is generated (clone copy) and the original photograph is auto-
matically made the clone source. The Quick Clone function may also delete the clone copy
image and turn on Tracing Paper. All this is explained in Chapters 4 and 5.

Watercolor and Liquid Ink

Layers
Watercolor brushes give beautiful, soft watercolor washes and effects. Liquid Ink brushes produce
some astounding graphic and resist effects. Both Watercolor and Liquid Ink brushes paint into special

' IRl Ed Carvas  Layers  Seleci Shapes  Effects  Movie Window Halp
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layers that are separate from, and sit above, the regular background canvas (Figure 1.36). These
layers are generated automatically as soon as you apply a Watercolor/Liquid Ink brush to your image.
You can see these layers listed in the Layers palette.

After you've applied Watercolor /Liquid Ink brushes, if you then try to apply a non-Watercolor/
Liquid Ink brush, you'll get a warning “Only Watercolor / Liquid Ink brushes can be used on Water-
color/ Liquid Ink layers.” Outlined next are several alternative ways you can overcome this error.

Painting Beneath a Watercolor/Liquid Ink Layer
To preserve the Watercolor/Liquid Ink layer and paint underneath it with other non-

GETTING STARTED

Watercolor/Liquid Ink brushes, click on the Canvas layer in the Layers palette. The Canvas layer will
now be highlighted and you can continue painting with non-Watercolor/Liquid Ink brushes on the
background canvas beneath the Watercolor/Liquid Ink layer. Any time you wish to add Water-
color/Liquid Ink brushstrokes to the Watercolor/Liquid Ink layer, just reselect that layer. Note that
the editability of Watercolor/Liquid Ink layers with Watercolor/Liquid Ink brushes is only preserved
in the RIFF file format.

Deleting Watercolor/Liquid Ink Layer

Click on the Watercolor/Liquid Ink layer in the Layers palette. If you have more than one
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layer you wish to delete, hold down the Shift key as you select each layer.

Click on the trashcan icon in the lower right of the Layers palette.
Dropping Watercolor/Liquid Ink Layer

Click on the Watercolor/Liquid Ink layer in the Layers palette. If you have more than one
layer you wish to delete hold, down the Shift key as you select each layer.
Click on the left-hand icon in the lower left of the Layers palette and drag down to Drop.

This flattens your image, placing what was in the Watercolor or Liquid Ink Layer onto the background
canvas, and allows you to paint over those marks with other brushes.

Digital Watercolor

The Digital Watercolor brushes paint directly onto either the background canvas or a regular image
layer. They act as if they are in a separate layer and are not affected by the blending tools in other
brush categories. If you wish to paint over Digital Watercolor or blend it into the background, choose
Dry Digital Watercolor from the Layers palette pop-up menu.

Impasto

Adding the lllusion of Depth
The Impasto category of brushes is a group of brushes that add three-dimensional depth to their
brushstrokes, almost as if you are embossing the canvas as you paint. They are designed to emulate

o
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Hle[l= =7/ Impasto brushes add the appearance of depth.

the traditional painting technique of applying thick paint to your canvas (Figure 1.37). They can give
you some fabulous effects but also cause much confusion and frustration. Once you have painted with
an Impasto brush, the three-dimensional embossing appears to remain in your image, even when
you try to paint over it with other, non-Impasto brushes. It is as if the Impasto depth is recorded in
a separate layer (one that does not appear in the Layers palette). You can control whether an Impasto
brush actually generates the depth by choosing Window > Brush Controls > Show Impasto. By chang-
ing the “Draw to” pop-up menu from “Color and Depth” to “Color,” you change the Impasto brush
into one that doesn’t add depth. Whether you like the depth is a matter of taste.

Turning Off the Impasto Layer

You can turn the impasto effect off and on by clicking on the small purple “bubble-gum” star-shaped
icon that appears in the upper right of the image window frame. You have to go out of screen mode
to see this icon by choosing Cmd/Ctrl-M if your canvas is mounted.

Dropping the Impasto Layer

If you wish to drop the impasto depth layer onto the background canvas, either so you can paint over
it in Painter or so you can preserve the impasto depth effect when you open the image up in Photo-
shop, then choose Save As and save the file as a TIFF file. Close the TIFF file and then reopen it. This
will automatically flatten the impasto depth layer.

o
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Erasing a Portion of the Impasto Layer

There are two erasers within the Impasto brush category, the Depth Color Eraser, which erases every-
thing, including the depth effect and any color on the canvas, and the Depth Eraser, which seems to
leave a subtle indentation. If you wish to erase just a portion of the impasto depth, I suggest you save
two versions of your file, one with impasto on and one with impasto off, clone one, set the other as
clone source (File > Clone Source), and then use the Cloners > Soft Cloner to clone from one into the
other.

GETTING STARTED

1.8 Foundation Projects

The “How I Feel” Painting Project

Choose Cmd/Ctrl-N.
Open a new canvas 700 pixels wide by 700 pixels high.

Choose Cmd/Ctrl-M to mount the canvas in screen mode.
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Play with the brushes on the canvas. Create an image that expresses how you feel. It can
be abstract. Don’t undo or erase, just keep building up brushstrokes on top of one another.
Use this painting as a way to explore the multitude of wonderful brush variants contained
in all the different brush categories. Explore the effect of different pressure, speeds, and
directions. Spend 30 minutes on this project.

The “Visual Glossary” Project (Optional)

This project is the creation of your own visual glossary of brushes. The goal is to create a series of

paintings that capture the look and feel of the brushes from each category, like the ones shown earlier
in this chapter. The experience of making your own visual glossary will familiarize you with the
brushes. You could choose a theme and make each painting a variation on that theme.

Choose Cmd/Ctrl-N.

Open a new canvas 500 pixels wide by 500 pixels high.

Choose Cmd/Ctrl-M to mount the canvas in screen mode.

Paint with all the variants from the Acrylics brush category.

When you have filled your canvas with paint, select File > Save As and save the file as
acrylicspainting.rif into your “Painter Projects Chpt01” folder.

Repeat steps 1 through 5 for all the brush categories. Note some categories, such as
Blenders, will require painting over an existing image. You can use another category of
painting for this purpose.
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1.9 Wrap

Congratulations on mastering the Painter basics. You are now familiar with the Painter desktop and
know how to select, control, and apply brushes. If you run into any problems, refer to Appendix II:
Troubleshooting.

You are ready to move onto the next step, which is not just how to use Painter, but how to use
it smartly. In Chapter 2, “Foundation II: Creative Empowerment,” you'll learn about the three guiding
principles of making the most of Painter—Simplify, Organize, and Optimize. These principles will help
you be more creative, more productive, and more efficient.
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There are painters who transform the sun into a yellow spot, but there are others who, thanks
to their art and intelligence, transform a yellow spot into the sun.
—Pablo Picasso

4.1 Introduction

This chapter introduces a few techniques and ideas for transforming your photographs into artistic
interpretations that emulate the look of traditional drawing and painting media, such as pencil, char-
coal, pastels, watercolors, and oils. I use the word transform in the context of basing an artwork on
a photographic source reference image. The artwork that results is an “interpretation” or “painterly
rendition” of the original photograph. Your source photograph serves as an inspiration and founda-
tion for your creative process.

This chapter is not intended to be a comprehensive and exhaustive analysis of natural media
techniques, but simply a starting point from which you can explore further and develop your own
techniques. The techniques shared here are intended to be not exact formulae or recipes to follow pre-
cisely, but helpful guidelines and suggestions to set you on your journey. In practice every picture sug-
gests its own path, and I encourage you to continually experiment. You may find yourself mixing
many different types of media together when using Painter. The beauty of Painter is that it offers
unlimited possibilities—the only limit is your imagination.

The individual techniques presented here are each described in the context of a case study, where
I lead you through my process in creating a painting from start to finish (as much as any artwork is
ever finished) and share the transitions that each painting goes through along the way. I share some
of the specific brushes I use, my custom settings, and other technical details. There is some repetition
of steps that are common to the different case studies, though I go into more detail the first time I
address a particular step. Repetition of these steps helps solidify the basic working method until it
becomes second nature. T suggest you first follow along the step-by-step techniques with one of your
own images. If you are new to Painter and want to quickly grasp the basic techniques, then ignore
all the Tips that go into deeper technical detail. Conversely, if you are an experienced Painter user and
want to understand the program at a deeper level, then take the time to read the Tips.

Following my case studies will help you understand my decision-making process as I paint and
also familiarize you with the brushes I use. However, once you have followed my case studies in detail
I recommend that you start experimenting, discovering your own favorite brushes, exploring your
own custom settings, and seeing what gives you effects you like. The goal here is not for you to learn
precise recipes but to empower you to create your own unique style of artwork that reflects who you
are and how you see the world. As musician Loreena McKennitt so eloquently says: “One of the most
important steps on our journey is the one in which we throw away the map”.

Although in this chapter I concentrate on emulation of a few traditional drawing and painting
media, there are numerous other amazing painting effects you can achieve with Painter. Many of

o
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them are unique to Painter and take you into realms that cannot easily be categorized and that cross
the boundaries of painting and printmaking. I've selected a few of these to highlight in the following
chapter.

4.2 Goals

Before embarking on the process of transforming your photographs into paintings, take a moment
to consider what your goals are. Why bother to transform your photographs? How does painting add
to your image? What is special about paintings? Visit a local art museum or gallery and look at paint-
ings. Look closely at the richness of colors, textures, and abstract forms in the brushstrokes. Step back
and look at the way the artist’s use of color, texture, tone, lighting, and brushstroke movement have
succeeded in creating a powerful evocative image. Notice the way the artist draws you into the paint-

PASTEL, WATERCOLOR, AND OIL

ing, taking away detail here, adding detail there, leading your attention to the focal point. The suc-
cessful painter, as Picasso says, is able to “transform a yellow spot into the sun.” In other words a
successful painter can create an effective illusion with the use of color, tone, texture, and so on. Paint-
ings offer a greater range and depth of color and tone than a photograph and hence can create a
more striking image. Painting also offers you complete control over the level of detail and contrast in
all parts of an image, allowing you to selectively focus the viewer’s attention and take your photo-
graphic image to the next level.

We are going to start this journey of transformation by going back to basics and creating a simple
black-and-white sketch from a photograph (Figures 4.1 and 4.2).
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4.3 Pencil Sketch

Technique Overview

This technique uses the Tracing Paper facility of Painter in its most basic form, as a simple visual ref-
erence for creating a pencil sketch. This is an example where the File > Quick Clone command saves
time in preparing your canvas. Getting an authentic pencil look may take a little brush research. The
variant choice and brush settings I share with you here were the end product of considerable trial
and error. Although the plain pencil sketch could be the final image, I couldn’t resist mixing a little
of the original photograph with the pencil drawing. While the mix is not an authentic pencil sketch
look, T still liked the result and wanted to share it with you here in case it is something you wish to
try yourself.

Steps

Start with a Vision

The model for my sketch is my cute nephew, Bradley, whom I photographed on a recent visit to
Brighton, England, where he lives. I liked the quizzical look he had on his face in this picture and
wanted to capture his curiosity in the drawing.

Prepare your Canvas

Enhance and crop your source image in either Photoshop or Painter.
Open your source image in Painter.

Choose File > Quick Clone (or click your Quick Clone button if you've created one in your
shortcuts custom palette) (Figure 4.3).

As discussed in Chapter 1, you can set the action of the Quick Clone command in the Corel
Painter IX/Edit > Preferences > General window. I have the Quick Clone set to make a clone copy of
the original photograph, clear the clone copy canvas to the paper color (default is white), and turn
Tracing Paper on. Thus when I applied Quick Clone, a new white canvas opened up, the same size as
the original photograph, with the original photograph showing through at 50% opacity. Choose
Cmd/Ctrl-T to turn the Tracing Paper off and on (it toggles between the two states). Leave the Tracing
Paper off for the next step, which is brush research.

Brush Research

Now that we have a blank white canvas before us, we can start experimenting with different brushes
and brush settings to get the right look and feel. There’s no fixed formula for getting a particular look,
and much depends on your personal preference and the goal you have in mind for your image. In the
example shown here I wanted the look of a soft lead pencil, 3B or 4B, that makes a grainy mid-gray
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m Clicking the Quick Clone shortcut button.

mark when you press lightly and gradually gets darker as you press with more pressure. I tried out
all the brush variants in the Pencils category. The one that seemed to give the effect closest to what I
was looking for was the Thick and Thin Pencil variant. Here's how you would get what I did.

Choose a middle gray in the Colors palette by dragging the cursor in the Saturation/Value
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Triangle all the way to the left (making the Hue and Saturation 0%) and in the middle
(making the Value about 50%).

Lower the brush opacity from 100% (the default) to about 15%.

Lower the Grain in the Brush Property bar from 24% (the default) to about 15%.

Choose Window > Library Palettes > Show Papers. Select a suitable paper from the Papers
Selector. | chose the Rough Charcoal Paper.

Adjust the brush size to suit the scale and resolution of your canvas.

Save Your New Variant

At this point you may wish to save this variant for future use. To do that choose Save Variant
from the Brush Selector pop-up menu. If you wanted to save the paper texture information as
well as the special brush settings, then you’d need to save a brush look. You do so by select-
ing New Look from the Look Selector pop-up menu (the Look selector is in the bottom left
corner of the Toolbox).
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Create Line Work
Now that you have selected the Pencils > Thick and Thin Pencil, clear any trial marks off
the canvas (Cmd/Ctrl-A followed by Delete/Backspace).
Turn on Tracing Paper (Cmd/Ctrl-T).
Start sketching in the main contours (Figure 4.4).

Choose File > Save As. Rename the clone copy canvas with the subject, version number,
and a note about which brush you used. | called my file “bradleysketch-01-thkthnpncl.rif.”
Since | was not using any special layers | could have saved my file in Photoshop or TFF
format.

Create “Soft Shading” Effect
Once you have established a framework of contours on your canvas, increase the size of your brush

PASTEL, WATERCOLOR, AND OIL

and lower the opacity. Now make soft brushstrokes to block out areas with soft shading (Figure 4.5).
In addition to adding shading with a large, low-opacity brush, you can create the effect of
shading in a sketch by use of crosshatching with a small, high-opacity brush. Crosshatching is the
technique where you make a close series of parallel lines and then go over the same region with
another series of parallel lines at right angles (or thereabouts) to the first series. You can see a little
crosshatching in Bradley’s hair and sweater.
At this stage you have completed the sketch. Save your file.

Mixing the Original Photo with the Sketch

Choose the Cloners > Soft Cloner.
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Lower the brush opacity.

Choose Cmd/Ctrl-T to turn Tracing Paper off.
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el 2ies Sketching in the main contours with Tracing Paper on.
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iSRS Creating soft shading with a large, low-opacity brush.

|| With soft pressure gently clone some of the original photograph into the sketch (Figure
4.6).

B Choose File > Save As and save this version, with the photograph cloned back in.
If you go too far (and clone too much of the original photo), you can either use Cmd/Ctrl-Z to

undo your brushstrokes or open the sketch version, set it as clone source (File > Clone Source), and
then use the Soft Cloner to restore the sketch.
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Hls[ll{=1 215 Cloning in the original photograph.
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4.4 Charcoal Drawing

Technique Overview

This technique, suggested by Wes Pack of Corel Corporation, involves using a black-and-white source
image, working into it with chalky brushes, capturing it as the current paper texture, and then using
a chalky brush with varying degrees of grain on a white canvas. The result mixes different textures
in a way that gives more richness to the chalk marks on your paper than simply creating a straight-
forward grainy brush clone drawing. The example shown in Figure 4.7 is based on a photograph I
took of the legendary pioneer of the Lindy Hop swing dance, Frankie Manning. Frankie toured inter-
nationally with Whitey's Lindy Hoppers in the 1930s and appeared in a number of films, such as
Hellzapoppin’. Since the 1980s Frankie has been teaching the Lindy Hop, inspiring and enthusing
people all over the world. This photo was taken as he walked into a surprise 90th birthday party
arranged for him at the Jumpin’ at the Woodside swing dance festival in Gloucester, England. You can
see from his big smile what a joyful man he is.

Steps

Open the source image in Painter.

If the image is a color image, as in my case, choose Effects > Tonal Control > Adjust Color
(Figure 4.8).

With Using: Uniform Color, take the Saturation slider to the minimum (-139%). Click OK.
This makes the image appear black and white (Figure 4.9) (in fact all images in Painter are
RGB images—Painter does not have other color modes like Photoshop).

Choose File > Clone.

Choose File > Save As and rename the clone copy.

Choose Cmd/Ctrl-M.

Choose a chalky brush. In my case | chose Chalk > Square Chalk 35.
Check the Clone Color icon in the Colors palette.

Choose a paper texture in the Papers palette (Window > Library Palettes > Show Papers).
In my case | chose Load Library from the Papers pop-up menu and opened one of my
custom paper libraries, Papers Artsy, which you can find on the Painter Creativity Resource
CD. | selected the paper Forest Unryu. It is a Japanese paper with a great hairy texture. |
increased the contrast setting in the Papers palette (second slider down) from 100% to
about 184%. This makes the paper texture stronger.

Lower the Grain setting slightly to get more texture showing in your brushstrokes.

Apply the Square Chalk in the image (Figure 4.10).
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Increasing the
contrast in the image.

Resave the image.

Choose Effects > Tonal Control > Equalize (Cmd/Ctrl-E). Adjust the settings to increase the
contrast of the image. This will make it a better paper texture (Figure 4.11).

Resave your image with another version number.
Choose Cmd/Ctrl-A (Select > Select All).
Choose Capture Paper from the Papers palette pop-up menu (Figure 4.12).

Name the paper and move the Crossfade slider to zero (this avoids softening of the edge)
(Figure 4.13).

Choose Backspace/Delete so you clear your canvas.

Choose Cmd/Ctrl-T so you turn on Tracing Paper and can see your original image through
the paper.
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[iETEEEED The Save Paper

window.

LEIEEEF Capturing the image as a

paper texture.

s Applying the Square Chalk with clone color in the cleared canvas with Tracing Paper
turned on.

Start applying the chalk on the canvas, varying the Grain setting to control the texture
effect (Figure 4.14).

For the final touch | added a signature using Hand Made paper from the same paper library
(Figure 4.15).

4.5 Chalky Pastel

Technique Overview

Figure 4.16 shows the original photograph, taken by a client of her daughter, Lindsay, with her horse,
Oscar; Figure 4.17 shows the final painting, a chalky pastel rendition that was reproduced as a mag-
nificent 48-inch print on 100% rag fine art paper.
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CHAPTER 4 PHOTO TECHNIQUES I:

el il The original source

photograph of Lindsay and her
horse, Oscar (photography: Julie
Douglass).
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Steps

1. Start with a Vision

As you compose and design your photograph prior to capturing an image with your camera, think
ahead about the mood, feel, and artistic style you wish to end up creating in your final artwork. In
this case Julie wanted to express the close bond between Lindsay and her horse, Oscar. She envisaged
a dreamy, gentle, and feminine painting with soft pastel colors, nothing too harsh or garish.

2. Capture Your Source Image

In capturing your source imagery, work with the maximum flexibility and quality. If using a digital
SLR or digital back camera, save your files in RAW format. This will give greater latitude later to adjust
for exposure than capturing JPEG files. If you are using a consumer digital camera, adjust your set-
tings for maximum resolution. Download your pictures from your digital camera memory card onto
an appropriately labeled folder on your computer. It is generally best (and fastest) to use a dedicated
card reader to download pictures rather than connecting your camera directly to the computer.

If you are downloading JPEG files from your digital camera, you can open these up in Painter
right away; there is no need to use any other software. There are a number of software programs you
may find convenient to use that are dedicated to browsing and organizing your digital photographs
and running slide shows. Photoshop, the industry standard for photographic workflow, offers the
most in-depth and versatile image adjustment tools available, plus it has a very convenient browse
function that will show you thumbnails of all your photographs. For that reason the following initial
steps are in Photoshop.

3. Select Your Image (Photoshop)

Open Adobe Photoshop CS and use the File > Browse function to conveniently select an image. If you
are using RAW images, make sure you have the most current RAW plug-in for Photoshop CS. This
will provide you with a convenient window where you can adjust such characteristics as the color
temperature, tint, exposure, and contrast. If your image needs rotating, then use Image > Rotate
Canvas > 90°CW or 90°CCW, as appropriate.

4. Crop to Maximize Impact (Photoshop)

Consider your overall composition—will it be enhanced by cropping? Experiment with cropping the
image. To crop, select the Crop tool (third icon down on the left of the tools palette) and drag in the
image (Figure 4.18). Use the crop control handles to adjust the boundaries if needed, drag in the crop
to change its location on the canvas, and press the Return/Enter key when you wish to finalize the
crop. If it doesn’t look right, use Cmd/Ctrl-Z to undo the crop and try again. See if closer crops improve
the power and impact of the image. The key here is to have a vision of what you want to say and
where you want to go with your image. In this case I found a closer crop created a more dynamic
composition for use as a basis for a painting.
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ol ikl Cropping your image.

5. Determine File Size (Photoshop)
File size can mean a number of things when dealing with digital files.

The number of megabytes (MB) of computer memory the file takes up.

The number of pixels it contains in total (such as the use of the units of megapixels in
describing how large a file a digital camera can capture).

The pixel size (number of pixels wide by number of pixels high).

The physical dimensions, for instance, in inches, of a printed image based on the digital
file when printed out by a printer at a particular resolution of a certain number of dots
per inch (dpi). The dots that are referred to in printer resolution correspond to the pixels
in a digital file, whereas the typical unit of pixel resolution is pixels per inch (ppi).

In this case the painting I am creating is a commissioned artwork that must end up being deliv-
ered to my client as a beautiful print, not as a digital file. Thus what concerns me is the ultimate size
of my print and ensuring that I have sufficient pixels for a high-quality image (too few pixels can lead
to a soft, pixilated printed image). The physical size and medium you envisage for your final printed
artwork determines the pixel resolution (ppi) you need to work at in Painter, and thus the file size you
need to start with. Generally you will find an adequate range of digital file resolutions will lie between
300 ppi at final printed size for commercial offset reproduction in magazines, down to 150 ppi for an
inkjet print on fine art paper or artist’s canvas (also known as Gicleés, pronounced jee-CLAY, in the
fine art world).
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With Painter images I generally work at 150 ppi at final size. I started off planning a final print
26 inches high and therefore wanted to make my image height, in pixels, at least 26 x 150 = 3900
pixels. I selected Image > Image Size. In the Image Size window (Figure 4.19) I unchecked Resample
so that I could change the number of pixels in the file. The source photographic file I was using was
3720 pixels high, slightly smaller than I wanted. In the Document Size section of the Photoshop
Image Size window I entered 26 in the Height box and 150 in the Resolution box.

Note that you cannot change the aspect ratio (height:width ratio) in the Image Size window.
If you need a specific aspect ratio, for instance, 24 inches wide by 30 inches high at 150 ppi,
then it is best to select the Crop tool and write in “24 in” in the Crop tool property bar Width
box, “30 in” in the Crop tool property bar Height box, and 150 in the Crop tool property bar
Resolution box, with pixels/inch selected as the unit. Drag the crop tool in the image and
it'll be restricted to the aspect ratio set in the Crop tool property bar. You can move the crop
around and change its scale. When you choose Return/Enter, the crop and resizing occur
simultaneously.

In the end | created a magnificent 48-inch print from the final image. My final digital file,
after my painting was completed, was resampled up by the Master Printer | used (Gus Grubba,
Aeon Master Printer, 415/462-5702) from a 25-MB file to a 133-MB file (36 inches by 48 inches
at 180 ppi). The bottom line is that you do not need to work on huge files in Painter to be able
to get great results. This is important to know since some of Painter’s brushes and effects are
quite memory intensive, and it can be slow working on files that are very large (for instance,
100 MB and up).

6. Optimize Tone and Color in Your Source Image (Photoshop)

Working on an image with Painter gives you a lot of latitude with regard to adjusting color, tone,
lighting, level of detail, sharpness of contrasts, texture, and composition. Fine adjustments to your
source image are not always a necessity since you can always adjust them with paint. Having said
that, T add that a stronger source image can only help your final image. Choose Layers > New Adjust-
ment Layer > Levels, click OK, and look at the histogram (Figure 4.20), a graphical display of the dif-
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Hle[l= 2] The Photoshop Levels

window.
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ferent amount of lights and darks in the image. Move the black-and-white cursor triangles so they
are close to the outer edges of the histogram, where the mountains rise up from the plateau. Does
the overall image need lightening or darkening? Experiment with the black, gray, and white sliding
triangle cursors immediately along the base of the histogram. In this case I moved the gray triangle
slightly to the left to lighten the image and bring out a little more detail in the shadows.

If you feel the color needs adjusting I recommend using the Hue/Saturation Adjustment Layer.
There are many more ways to approach fine-tuning an image in Photoshop, and if you are interested
in this area there is a wealth of excellent resources available (see www.paintercreativity.com for links
to some). When you are satisfied, save your file in Photoshop (PSD) file format. This will be your master
file that preserves the flexibility of all the Adjustment Layers for future editing in Photoshop (the
special properties of Adjustment Layers are not recognized in Painter). Flatten the file (Layers pop-
up menu) and resave a flat TIFF version. This will be the source image you open in Painter.
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7. Continue Your Vision (Painter)
Open your prepared source image in Painter. Choose Cmd/Ctrl-M (Window > Screen Mode Toggle),

followed by Cmd/Ctrl-0 (that's a numeral zero, not the letter oh) (Window > Zoom to Fit), and finally
the Tab key (Window > Hide Palettes). Take some time to look at the photograph and open yourself
to a vision of where the photograph suggests going, continuing the process that started with your
vision before you took the original photograph. What inspires you about the image? What do you
wish to communicate? What is the story you wish to tell? What needs emphasizing or omitting in the
photograph to most powerfully communicate the story you wish to tell? In this case I was inspired by
the beautiful bond between Lindsay and Oscar and their harmony with the natural setting. These
were the themes that I envisioned expressing in my painting.

8. Decide on a Border

Consider what style of final artwork you wish to end up with and how it will be mounted and dis-
played. This will determine whether or not you should add a border to your source image. For works
on paper, such as a watercolor or pastel style of painting, where the print may well be float mounted
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and where you may want your brushstrokes to blend softly into the paper at the edge of the picture,
choose Canvas > Canvas Size to add a border around your image before you start painting (Figure
4.21). Type in the number of pixels to add, followed by Tab, and repeat that four times to fill in each
box (for each direction). By default these pixels will be white, which is what you want for a water-
color. Use the ppi resolution to determine how many pixels to add. I chose to add 100 pixels in each
direction, which, for a 150-ppi file, adds three quarters of an inch in each direction.

For an oil style of painting I typically do not add a border to my original image since I print onto
canvas and either frame it to the edge or stretch it with a gallery wrap.

9. Save Your Source Image

Choose File > Save As (Figure 4.22). Rename your source image with a name that includes the
subject, version number (-00), and a note that this is your original image on which you are going to
base your painting (-orig). If you added a border, you may want to indicate that as well (brdr). Save
this source image as a TIFFE. Thus your file name should have a format similar to: subject-00-
origbrdr.tif.

If you wish to take advantage of the convenient Iterative Save feature (under the File menu)
introduced in Painter IX, save your original as subject_000.tif. The advantage of Iterative Save is that
it instantly renames each iterative-saved file with a sequential number at the end of the file name:
_000, _001, _002, etc. The disadvantage is that it doesn’t give you the opportunity to add a useful
note into the file name indicating, for instance, what brush you just used. If you add any notes after
the three-digit number, you will disrupt the Tterative Save sequence (it'll start from _001 again). If
you add a note before the three-digit number, the alphanumeric order of the files will not match the
version number sequence. This you need to adopt one system or another. If you choose Iterative Save,
then you won't be making notes in the file names. Since I am a meticulous documenter and I want
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to be able to recall every brush I use, I add notes in my file names and therefore don't use the Itera-
tive Save. Whatever naming system you adopt, save this file in the project folder where you will be
saving all the versions of the image for this project as you work on it. This is important, since it is
easy to lose track of your original image if you leave it with its default name in a folder full of other
photographs with similar names.

10. Make a Clone Copy

When you are working from photographs in Painter, always work on a clone copy (duplicate), not
on your original image. In making a clone copy in Painter you have two choices: either choose
File > Clone, which makes a clone copy duplicate of your original image (with the duplicate image
on the clone copy canvas), or choose File > Quick Clone, which, by default, makes a clone copy and
which then automatically deletes the image from the clone copy (leaving a plain white canvas) and

PASTEL, WATERCOLOR, AND OIL

turns on Clone Color in the Colors palette. You can adjust the Quick Clone settings in the General
Preferences window (Figure 4.23). I generally choose my brushes, and adjust whether or not they
use clone color, after creating a clone copy. I typically use brushes that are not in the Cloners cate-
gory. For this reason I uncheck Switch to Cloner Brushes and leave Clone Color unchecked in the
Quick Clone settings.

The Quick Clone command, where an image in cloned and then the clone copy canvas is cleared
automatically, can be useful for all styles of artwork, while the File > Clone command, where the
duplicate image is left on the clone canvas, is particularly suited to oil styles. In this case T wanted to
make a duplicate image and fill the canvas with a color, so File > Clone worked fine for me.

11. Mount Clone Copy
Choose Cmd/Ctrl-M (Window > Screen Mode Toggle).
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12. Pick Color from Image

Select the Dropper tool (Figure 4.24). You can do this either by clicking once on the “D” key or by
holding down the Option/Alt key while you have the brush tool selected and Clone Color inactive in
the Colors Palette. Click in your image on a color you wish to use as a background color.

13. Fill with Current Color

Choose Cmd/Ctrl-F (Effects > Fill) (Figure 4.25). Fill with the Current Color (which you have just
picked from the image with the Dropper tool). Watch out: If you accidentally fill with Weave, you may
be shocked by the bright tartan pattern that fills your canvas!

At this stage you may want to consider adding a subtle texture to the background. If you
are going to print out your final image on a textured fine art paper, it may be unnecessary since
your image will be imbued naturally with the paper texture of the print substrate. That is what
Tdecided in this case. If you do wish to add a paper texture, first choose Window > Show Papers
and click on the papers selector pop-up library menu (upper right of the Papers palette). Choose
your paper (I like the Italian and French Watercolor Papers). The effect I like to use to apply
paper texture is Effects > Surface Control > Dye Concentration (Figure 4.26). Change the Using
menu from Uniform Color to Paper. Adjust the Maximum and Minimum sliders until you like
what you see in the preview window. Click OK.

If overdone, as effects so easily are, select Edit > Fade and fade back the effect.

14. Rename the Clone Copy

Choose File > Save As (even if you intend to use the Iterative Save) (Figure 4.27). Delete the default
“Clone of . ..” at the beginning of the file name. Change the version number to —01 in the naming
system if you are going to add notes, or change it to _001 if you are going to use the Iterative Save
feature. If you are following the note system and have “origbrdr” written in, replace that note with
“bkgnd” (you only want to have one file that has “orig” in the name so that you can immediately
identify which file should be the clone source). Save the file as a RIFF file. RIFF is the native format of
Painter and preserves maximum flexibility, though it cannot be opened in Photoshop.
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Always Back Up Your Work
As a precaution I recommend that before you close down Painter, when in the middle of a project,

you first make a backup of your most recent working image as a TIFF (if no layers) or as a Photoshop
format file (if there are layers). You can do this simply by choosing File > Save As and altering the file
format from RIFF to either TIFF or Photoshop. There have been cases in earlier versions of Painter
where very large RIFF files became corrupted. This should no longer be a problem with Painter IX,
but I would still recommend erring on the side of caution.

Resetting Your Clone Source Manually

The Clone (or Quick Clone) operation automatically assigns the original image from which you are
cloning to be the Clone Source. You can see a checkmark by the file name of your original under the
File > Clone Source menu. If you are working on a project, close Painter and then return to the project
later; you will need to open up both the latest working image and your original image. You will also
need to manually reset the original image to be the clone source (which defaults to the current
pattern) by going back to the File > Clone Source menu and selecting your original image.
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15. Select Brush Category and Variant

Select the Chalk brush category (click on the left-hand icon of the Brush Selector Bar to reveal the
brush category pop-up menu). Then select the Square Chalk brush variant from within the Chalk
category (click on the right-hand icon of the Brush Selector Bar to reveal the brush variant pop-up
menu) (Figure 4.28). Make a test brushstroke on your canvas. This grainy brush gives a nice chalky
effect that reflects the current paper texture.

Please note that there are many wonderful grainy brushes you could choose from that would
work just as well as the Square Chalk. Another one of my favorites is the Pastels > Artist Pastel Chalk.
I encourage you to take time to do brush research prior to finalizing your selection of which brush
to use.

16. Select Paper Texture

Choose Window > Show Papers (unless you already have the Papers palette visible). Click on the
Papers palette selector icon (upper right of the palette). This reveals a pop-up menu with a list of all
the papers available in the current paper library. You may need to drag down the bottom right corner
of the pop-up menu to see the whole library in one go. As mentioned earlier, my favorite papers in
the default library are the Italian and French Watercolor papers. Pick a paper you like. Make another
test brushstroke on your canvas and see the effect of the new paper texture (Figures 4.29, 4.30, and
4.31).

About Paper Texture

Paper texture in Painter is actually a repeating grayscale tile that acts like a mask to filter
certain grainy brushes. The paper preview you see in the Papers palette shows the grayscale

" @ CorelPainter9 Flle Edit Camas Lavers Salect Shapes Effects

e[l aivsd Selecting

the Square Chalk variant.

e[t vil Square Chalk and Basic Paper with default settings.
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LR square Chalk and Italian Watercolor Paper.

tile, or a portion of it, where the dark regions act like the mountains of the paper grain, picking
up pigment, and the light regions act like the valleys of the paper grain, remaining clear of
pigment. Only certain brush variants reflect paper grain, such as those contained in the cat-
egories Chalk, Charcoal, Colored Pencils, Conte, Crayons, Digital Watercolor, Oil Pastels, Pastels,
Pencils, and Sponges. There are also brush variants in other categories that exhibit the prop-
erty of graininess, such as the Blenders > Grainy Water brush. If you select Window > Brush
Controls > Show General, or select Cmd/Ctrl-B (Window > Show Brush Creator) and look under
the Stroke Designer > General subpalette, you will see that all brushes that respond to paper
texture have the word grainy included in their Method Subcategory property (Figure 4.32).

o
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w The Brush Creator >

Stroke Designer window.

All grainy brushes have a Grain slider included in the Brush Property Bar (visible in the
regular painting mode of Painter). You can alter the scale of the paper texture (also referred
to as grain) in the Papers palette (first slider). You can also make the grain more distinct by
increasing the grain contrast (second slider in the Papers palette) and by reducing the Grain
slider in the Brush Property Bar, though not to zero (at which point there is no pigment
deposited anywhere).

About Brush Looks

When you customize the settings of a brush variant, such as changing the size and opacity or
changing any other settings in the Brush Property Bar or in the Brush Creator, you can save
those settings for repeated future use by saving your custom variant (Brush Select Bar pop-up
menu > Save Variant). After naming your custom variant, you'll find it has been added to the
variant list of the current brush category, handy for future use. The custom variant informa-
tion does not, however, include any changes you may have made to the Paper Texture settings,
such as scale or contrast, or changes made to any other art materials. To save custom paper
settings with your custom variant settings, you need to save a Brush Look.

Make a brushstroke on the canvas for you to use as an icon.

Choose the rectangular selection tool (second tool down on the left of the Tools palette).
Drag the rectangular selection tool over a portion of your brushstroke.

Choose the Brush tool.

Click on the bottom leftmost icon in the Tools/Selectors palette. This reveals the Brush Looks
library.

Click on the small black triangle in the top right of the Brush Looks library. This reveals the
Brush Looks pop-up menu (Figure 4.33).

o
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16. Activate the Clone Color Button

Click on the Clone Color button in the Colors palette (looks like the Photoshop Rubber Stamp icon).
Notice that the color wheel and value-saturation triangle become grayed out and inactive. Activat-
ing the Clone Color button causes the current brush variant, in this case the Square Chalk, to pick

up its color from the current clone source rather than from the color picker. The clone operation you
did earlier automatically defined the original image as clone source (look under File > Clone Source,
where you will see a checkmark by the original file name). Thus the Square Chalk now paints color
based on your original photograph.

About the Clone Color Button

The Clone Color button is a very powerful feature of Painter, especially for photographers,
since it allows you to covert almost any brush that paints color onto the canvas into a Cloners
brush that you can use to pick up color from your original source photograph. For this reason
| sometimes refer to this button as the photographer’s magic button. Note that when using
any brushes from the Cloners brush category you do not need to activate this button, since the

default behavior of all Cloners has the function automatically activated. Note also that every

o
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time you close Painter and then reopen it, the clone source defaults back to the current pattern.
Thus you will need to reopen both the original image as well as your working file and then
manually reset the clone source (File > Clone Source) in order to be able to continue working
on your artwork with cloners (Figure 4.34).

17. Apply Large General Brushstrokes
Use a large, medium-opacity Square Chalk with the Clone Color button checked to make large, rough
brushstrokes that follow the forms of your composition and that block out the main regions of tone
and color, particularly in the main center of focus. Turn Tracing Paper on and off using Cmd/Ctrl-T
(Canvas > Tracing Paper) for a visual reference of where you are on the canvas as you paint. Don’t
get attached to details. Keep your brush size large (Figure 4.35) so that you are forced to work in an
abstract way. Don’t be afraid of making a mess, or a muck up.

These rough, general, gestural brushstrokes capture movement, energy, and flow. They form a
foundation, or underpainting or muck up, onto which you will build up finer details. Figure 4.36
shows the resulting roughed-out image.
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All About Tracing Paper

What Is Tracing Paper?

The Tracing Paper function in Painter, which is toggled on and off by the Cmd/Ctrl-T shortcut or
Canvas > Tracing Paper (Figures 4.37 and 4.38), allows you to see a 50% opacity representation of
a clone source image (that may or not be your original photograph) superimposed on a 50% opacity
representation of a destination image (which may or may not be a clone copy of your original), where
both images must have exactly the same pixel dimensions (width and height). If your destination
image is the same as your clone source, then you don't see any effect of Tracing Paper. The Tracing
Paper function in Painter creates an illusion of traditional tracing paper, where you appear to be able
to see through your destination image into the clone source image “behind.” It is very useful when
starting off painting on a clone copy after you've cleared the copy or filled with a background color,
since you can then make brushstrokes that correspond to the features and forms in your original
image. Note, though, in the two figures that once Tracing Paper is turned on, you can’t see the
brushstrokes.
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The Problems with Tracing Paper

The problem with Painter’s Tracing Paper is that it is very misleading—you can’t see what you're
painting and are often surprised when you turn Tracing Paper off. It is also very easy to
accidentally have Tracing Paper turned on without realizing it and work for a considerable
time before recognizing that you are not seeing your actual image. Tracing Paper has no flex-
ibility—you cannot vary the percentage of each image (source versus destination). Finally, if
you really like how your image looks with Tracing Paper turned on, you can’t save the image
like that—it's only a mirage, a temporary visual illusion.

An Alternative
One solution to these problems is to recreate the effect of Tracing Paper by making a special
Tracing Paper layer in your working image (destination image). Here are the steps to do this.
Go to your original (clone source) document.
Select > All (Cmd/Ctrl-A).
Edit > Copy (Cmd/Ctrl-C).
Select > Deselect (Cmd/Ctrl-D).
Go to your working image.

Hold down the Spacebar and click once. This centers your image. An alternative is to choose
Cmd/Ctrl-0 (that’s the numeral zero, not the letter oh) to Zoom to Fit, which also centers
the image. Centering the image is important since otherwise your pasted Tracing Paper
layer will be misaligned.

Edit > Paste (Cmd/Ctrl-V).

In the Layers palette double-click on the Layer 1 that you've just pasted.
Rename the layer Tracing Paper.

Reduce the Tracing Paper layer opacity to suit (20% often looks about right).

Select Canvas in the Layers palette. This is important since otherwise you may end up
accidentally painting on your Tracing Paper layer.

Use the little eye icon to the left of the Tracing Paper layer to turn it on and off.

Save the file as a RIFF to preserve the layer. Before closing Painter, back up as a PSD.

18. Save Your Rough Version

At this stage choose File > Save As (changing the version number and adding a note like “squchlk-
rough”) or Iterative Save. Keep saving sequentially numbered versions at regular intervals, especially
just before you are about to change your brush or make a strategic step in the creative path of trans-
formation (such as changing from working in large abstract forms to working on smaller levels of
detail).

o
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19. Finer Brushstrokes for Finer Detail

After creating the general foundation, reduce your brush size and start bringing out more detailed
forms, particularly in the focal points of your image. In this case I concentrated the finer brushstrokes
on the faces of Lindsay and Oscar (Figure 4.39).
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20. Soft Cloner for Focal Point Detail

There were some details in the image, such as the eyes, where I wanted to bring in a greater degree
of realism. To do this I selected the Cloners category > Soft Cloner, a soft-edged variant that brushes
in the original photograph without any distortion (Figure 4.40). The Soft Cloner gives you the

freedom to take risks and be bold with your transformations—no matter how messy you make an
image, you can always use the Soft Cloner to brush back the original.

After applying the Soft Cloner I went back over the region with a fine Square Chalk at low opacity
to bring back the rough texture of the chalk. Smooth photographic detail in the middle of a painterly
or chalky painting stands out and looks wrong. That is why I recommend discretion and subtlety
when applying the Soft Cloner.

21. Add Your Own Color

With the Square Chalk selected, uncheck the Clone Color button. Hold down the Option/Alt key while
clicking in the image to pick up colors already there. Then apply those colors back into the image,
making adjustments to the hue and luminosity according to what effect you want to achieve. In
my case I wanted to reduce the intensity and contrasts in the background and on Oscar’s flank
in order to bring the viewer’s attention to the heads. My goal wasn't to add wild colors. T had been
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recede into the background.

asked specifically by my client to keep my palette muted, so I decided to use just colors already there
(Figure 4.41).

22. Final Touches

My final touches in Painter were to add a few highlights in the face. I also took a step back from the
painting and ensured that the over tonal balance worked. I added my digital signature in the bottom

o
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right corner, using a small, high-opacity version of the same Square Chalk and picking the signature
color from within the image. I then saved a TIFF version of the final image, adding an F after the
version number so I could easily identify which file it was. I reopened the final TIFF file in Photoshop
and adjusted the Levels to get the file ready for printing. I worked closely with my printer to further
adjust the digital file for the best-quality print possible.

Chalky Pastel Example: The Ballerina

I based the Ballerina image on a photograph taken by David Taylor (Figure 4.42). David’s intention
when capturing his photograph was to create the feel of an Edgar Degas pastel drawing. I continued
that vision with use primarily of the Pastels > Artist Pastel Chalk brush, following a similar technique
to that described earlier for Lindsay. With the Ballerina image I added color patches and then softly

PASTEL, WATERCOLOR, AND OIL

blended these color patches into the rest of the picture using the Artist Pastel Chalk with Clone Color

and using the Blenders > Just Add Water variant with soft pressure, low opacity, and medium size
(Figures 4.43 and 4.44).

w
w
2
(o4
=
I
v
L
-
(e]
[
()
I
o
<
o
('8
-
o
<
I
v

AL The original source Sl iEl Anintermediate stage.

photograph (photography: David Taylor).
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Chalky Pastel Example: Strummin’

Strummin’ is based on a photograph I took of musician Todd Gilbert playing guitar and singing in
Half Moon Bay, California (Figure 4.45). My goal in painting was to convey the soul and passion with
which Todd plays his music. I used the Chalks > Square Chalk for the main brushwork and brought
back some detail with the Cloners > Soft Cloner, adding some color accents with a small Artists >
Sargent brush and blending with Blenders > Grainy Water (Figures 4.46 and 4.47). You will find
another version of Strummin’, one that uses the Woodcut effect, in the following chapter.

4.6 Watercolor Sketch

Technique Overview

This case study shares an approach that emulates the look and feel of a loose watercolor sketch, where
watercolor paint and a pencil sketch are combined and the paint fades off at the edges into the white
paper. The subject is Columbus Avenue in San Francisco’s North Beach neighborhood. These tech-
niques can equally be applied to portraiture or any other subject matter. The watercolor style
typically works best with high key (predominantly light-valued) images.

The original source An intermediate stage.

photograph.
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An Aside on Watercolor

Traditional watercolor paintings are typically built up from light washes to darker colors, often
with a translucent quality to the paint. Digital watercolor tools allow the creation of water-
color paintings that have much greater color depth and intensity than traditional watercolors.
When building up paint in a traditional watercolor, you can wait until one layer of paint is dry
and then add your next layer (wet-on-dry), allowing fine detail and well-defined edges, or you
can add paint on top of still-wet paint (wet-on-wet), which results in running, mixing, and
blending of colors on the paper.

The artifacts associated with both wet-on-dry and wet-on-wet techniques can be emulated
with brushes and effects in Painter. There are two categories of dedicated watercolor brushes
in Painter: Digital Watercolor (whose variants paint directly onto the background canvas
though sometimes acting as if on a separate layer) and Watercolor (whose variants paint into
a separate Watercolor layer). The special properties of both these types of brushes are only
preserved within RIFFs. These brushes can give some beautiful effects that emulate natural
watercolor phenomena, such as the dispersion of paint into the grain of the paper, wet fringes,
running paint, and the absorption of salt. These watercolor brushes involve mainly a “buildup”
method (see Windows > Brush Controls > General), which means they build up to a dark value
quite quickly when brushstrokes overlap, and this sometimes makes it difficult to achieve subtle
light colors.

Steps

1. Start with a Vision

The final image called “North Beach” (Figure 4.48) was based on the photographic image in Figure
4.49, which appealed to me because of its strong diagonals, its nostalgic pastel coloring, and the
classic Edwardian architecture counterbalanced by the distant spires of Saints Peter and Paul Church.
My vision for this was a loose, rough sketch style of painting in the tradition of plein air painting (from
the French en plain air, meaning “in the open air”). I was particularly inspired by the beautiful water-
color sketches of John Singer Sargent made during his visits to Italy. In Sargent’s watercolors the
heavy grain of the watercolor paper was visible in the way the paint soaked into the paper, and the
paint was applied lightly, with patches of white paper showing though here and there. The details
of people and buildings were not there, but the quality of light, the mood, and the atmosphere were
conveyed.

2. Prepare Your Source Image (Photoshop)
This photograph was captured as a RAW file. I opened it from the Photoshop browser and made some
initial adjustments to the exposure and saturation in the RAW window (Figure 4.50).

o



04.gxd 10/28/04 05:55 PM Page 130 $

=
(o]
Q
=
<
o<
Qo
-l
(o]
S}
<
W
<
S
-
w
~
[
<
Q

CHAPTER 4 PHOTO TECHNIQUES I:

130 PAINTER IX CREATIVITY: DIGITAL ARTIST'S HANDBOOK

Hlel il The source photograph.

As you can see, my initial image had a slight perspective distortion due to the wide-angle lens. I
used the Photoshop Crop tool, with the perspective option checked in the Tool Property Bar to correct
the perspective (making the buildings vertical) and crop the image. I saved a TIFF version of this
cropped image (named nthbch-00-orig.tif). Note that the same proviso applies here as in the earlier
case study: If you are intending to use the Iterative Save, then end your file name (before the .tif)
with _000.

2. Apply Watercolor filter (Photoshop)

T am a great believer in the power of hand brushstrokes and tend to avoid applying any form of global
filter or effect. However, the Photoshop Watercolor filter can provide you with a handy shortcut to
generating a rough undercoat painting from which to base a painting in Painter (Figure 4.51). In
this case I selected, in Photoshop, Filter > Artistic > Watercolor, increased the Brush Detail setting,

o
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and reduced the Shadow Intensity and Texture settings. For an even more drastic effect, the KPT Col-
lection Pyramid Paint offers an interesting plug-in filter you can use from within either Photoshop
or Painter.

I saved the resulting image as nthbch-01-wcorig.tif (“wc” for watercolor). This filtered image is
the one I then opened in Painter.

3. Choose Paper Texture (Painter)

With the filtered image open in Painter, choose Window > Library Palettes > Show Papers. Click on
the small Papers selector icon (upper right of Papers palette) to reveal the Papers library menu. Select
a paper you feel will suit your image. In this case I selected the Coarse Cotton Canvas (Figure 4.52),
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since this texture seemed closest to the look and feel of the texture of paper that Sargent used, which
was a very coarse, thick watercolor paper.

3. Apply Paper Texture to the Filtered Image

Choose Effects > Surface Control > Apply Surface Texture (Figure 4.53). Make sure the Using: menu
is set to Using: Paper. Reduce the Shine slider to zero. Reduce the Amount slider so the texture is not
overwhelming the image. This is the time to decide whether or not to adjust the scale of the paper. If
you have a very large file size, your paper grain may look a little small with respect to the features in
the image. In that case, increase the Scale slider in the Papers palette (first slider). In this case the
default scale (100%) worked fine.

Click OK to apply the texture. If the texture appears overwhelming, choose Edit > Fade and fade
back the effect accordingly. Save the resulting image with a name that indicates the addition of
texture, keeping consistent with the file-naming convention you are adopting (I called this stage
nthbch-02-wectxtrorig.tif).

4. Add Border
Since the loose watercolor sketch technique requires a rough edge where the paint blends and fades
away into the watercolor paper, it is a good idea to add a white border to your source image before
making a clone copy of it. This white border acts as breathing space into which you flow with your
brushstrokes, extending the paint beyond the original photographic border. Choose Canvas > Canvas
Size (Figure 4.54). Decide on how large a border to add. You may need to do this by trial and error.
In this case I added 200 pixels all the way round (using the Tab key to go to each box in turn on the
Canvas Size window).

Click OK and a plain white border will be added. There is no need to add any texture to this white
border since the goal is to end up printing onto fine art paper that has its own paper grain.
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White is the default paper color. If you find that a color other than white is added, choose
Cmd/Ctrl-Z to undo the Canvas Size operation, select white in the Color palette, choose Canvas > Set
Paper Color, and repeat the Canvas Size operation.

5. Rename Your Source Image

Choose File > Save As and rename your source image with a note about the border (I called this stage
nthbch-03-orig200brdr.tif).

6. Create Clone Copy
Choose File > Quick Clone. This makes a clone copy of the filtered image, automatically clearing the
canvas and turning Tracing Paper on.

(%]
w
=)
(o4
=
I
v
L
-
o
-
(©)
o
o
<
o
('8
-
o
<
I
v

7. Rename Clone Copy
Choose File > Save As. Get rid of “clone of” in the file name and add the next sequential version
number and, if you wish, a note that this is the image on which you will start painting (I named my

file nthbch-04-start.rif). Save your working files as RIFF files to ensure maximum versatility, remem-
bering to back up as TIFF or Photoshop before closing Painter.

8. Mount Clone Copy
Choose Cmd/Ctrl-M (Window > Screen Mode Toggle). This mounts your clone copy, simplifying your
desktop and ensuring that you do not accidentally paint on your original.

9. Brush Research

You are now ready for real painting action! I decided with this image to start with a rough pencil
sketch and then paint over those lines so they show through a little, combining the dynamism, spon-
taneity, and energy of pencil line with the power and impact of broad brushstrokes. Thus I knew I
wanted to start with a pencil but was not sure which one. I decided to do some research, just like the
research I did for the pencil sketch technique at the beginning of this chapter. I choose Cmd/Ctrl-T,

o
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which turns the Tracing Paper effect off so that I just had a plain white canvas. I then selected the
Pencils category in the Brush Selector Bar (click on the small left-hand icon). I then went through all
the variants in this category (the variant menu is accessed by clicking on the small right-hand icon
in the Brush Selector Bar). With each variant I made test brushstrokes on my canvas and played with
the Property Bar sliders. I was aiming at a pencil stroke that displayed some grain, that was not too
dark or thick, and yet that was not too soft either. I ended settling on the Flattened Pencil variant with
lower Opacity, Grain, and Resat values than the default settings.

Saving Custom Variants

After finding settings for a brush that you like, you may subsequently change the settings of
the variant or return all variants to their default settings, in which case you'd lose your custom
settings unless you had saved the variant. The advantage of saving custom variants is that your
brush settings will be preserved for future use. In this case, having found a brush | liked, |
selected Save Variant from the Brush Selector Bar pop-up menu (click on the small black
triangle in the upper right corner) (Figure 4.55).

I then named the custom variant “JS-Flattened Pencil.” Notice that | name my custom vari-
ants with a space at the beginning of the name so they go to the top of the variant menu
(which lists items alphanumerically) and with my initials so that | can easily differentiate my
custom variants from the default ones. After clicking OK, this custom variant will be added to
the Pencils variants list. The variant listed in the variants list will still be the original variant (in
this case Flattened Pencil). To access your custom variant in the future, you'll need to select it
in the variants list.

You can always restore the original factory settings for your current variant by selecting
Restore Default Variant from the Brush Selector pop-up menu. You can reset all variants to
their default settings by choosing Restore All Default Variants. In one fell swoop, you can also,
by holding down the Shift key when you launch Painter, reset every setting in Painter to the
factory default settings. Be wary when doing the Shift key reset since you can easily loose your
custom variants and art materials when doing this (you need to back them up first).

sae 908 || opaory. 20 || g 0% [ ]| mosar #9¢ [| pees| 0% [ ] gt 000 |

Eapstarn i Cotmpey
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WETEEE The Save Variant menu option.
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Locking Your Favorite Brushes in the Tracker

The Tracker is a useful device in Painter that, as the name suggests, keeps track of all the brush
variants you use. They are listed with the most recently used variants at the top. | recommend
having the Tracker set up so that it lists the names of the variants (it is difficult to identify vari-
ants from their thumbnails or strokes). If your Tracker shows thumbnails or strokes, click on
the Tracker pop-up menu (small black triangle in upper right corner of the Tracker palette) and
select List.

The Tracker retains its contents from Painter session to painter session. If you find there
are a few brush variants you keep using, you can lock them in place at the top of the Tracker
window. You do this by selecting that variant in the Tracker menu (you will see it highlighted)
and then clicking on the padlock icon in the lower left corner of the Tracker palette (Figure
4.56).

You will see a padlock icon appear to the right of the variant name in the Tracker. All

PASTEL, WATERCOLOR, AND OIL

locked variants appear at the top of the Tracker for convenience. To unlock a locked variant,
select that variant and click on the padlock icon in the lower left corner.

Note that you can also drag variants out into custom palettes (literally just drag the variant
icon onto your desktop or into an existing custom palette). When you click on the icon in the
custom palette, that particular variant becomes the current variant. The problem with variant
shortcuts in custom palettes is that all you see is the category icon without any way to iden-
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el Locking a variant in the Tracker.
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tify which variant it is. That can make it confusing, especially if you drag in more than one
variant from the same category.

If you accidentally create custom palettes and need to clean up and delete some, you can
do so by choosing Window > Custom Palette > Organizer, selecting the unwanted custom
palettes, and clicking the Delete button.

10. Clear Canvas
Choose Cmd/Ctrl-A (Select > All) followed by Backspace/Delete. This clears your canvas of your brush
research marks.

11. Turn on Tracing Paper
Choose Cm/Ctrl-T (Canvas > Tracing Paper) to turn on Tracing Paper.

12. Make Pencil Sketch
With the Tracing Paper image as reference and using your selected pencil variant, make a quick line
sketch (Figure 4.57). Don’t worry about getting all the detail. This will just form a loose framework
over which to build your painting.

From time to time, turn off Tracing Paper (Cmd/Ctrl-T toggles Tracing Paper on and off) to see
what you've drawn (Figure 4.58). Also intermittently choose File > Save As (or Iterative Save). I saved
the file as nthbch-05-fltpencil.rif). When complete, leave Tracing Paper off.

12. Save Pencil Sketch
When you have completed your pencil sketch stage, choose File > Save As and save your image with

the next sequential version number and note that it is the final pencil sketch stage (I saved the file as
“nthbch-06-pencilsketchfinal.rif ).

Fi 4. Pencil sketch with Traci

e[l ers Pencil sketch with Tracing encil sketch with Tracing
Paper off.

Paper on.
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13. Find Good Brushes for Painting

Having completed the initial underlying pencil sketch stage, the next step is to select brushes for the
painting. In this example I decided to explore the Tinting brush category. As with the Pencils brush
category, I used my canvas as a scratch pad for trying out all the variants in the Tinting category,
making adjustments to the Brush Property Bar settings as I explored. When I came across brush vari-
ants I liked, I locked them into the Tracker (Figure 4.59). If I had also changed the Brush Property
Bar settings, then I saved the variant (as described earlier).

If you change the paper texture settings from the defaults, you may wish to save your brush
variant as a brush look (see earlier), since this saves paper texture as well as brush setting informa-
tion. I found, during my brush research, that increasing the Coarse Cotton Canvas paper scale from
100% to 178% and the paper texture contrast from 100% to 230% worked better with this image
than the default paper settings. I therefore saved a brush look to preserve that setting.

PASTEL, WATERCOLOR, AND OIL

14. Revert Canvas Back to Pencil Sketch
When you are satisfied with the variants you have found, choose File > Revert and revert the canvas
back to the last saved version, which was the pencil sketch.

14. Build Up Background Brushwork
Choose the Tinting > Grainy Glazing Round 15 brush variant. Increase its size and decrease its
opacity. Check the Clone Color button in the Colors palette so the color wheel is grayed out. Now apply
soft brushstrokes in the background regions of your image (Figure 4.60). In this case I worked into
the sky first. I also saved this variant as a custom variant.

Where possible, make your brushstrokes follow the forms and compositional lines of your source
image. The Grainy Glazing Round 15 variant is well suited for this style of painting since its graini-
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Hl i Adding detail with a smaller brush.

ness exhibits the paper texture nicely and its translucency allows the pencil line work to show
through.

15. Reduce Brush Size and Add More Detail

Slightly reduce your brush size and start working into more detail, though still with light, general,
and slightly abstract brushstrokes (Figure 4.61). From time to time turn Tracing Paper on (Cmd/
Ctrl-T) for reference of specific features. Remember to turn Tracing Paper off again, though, so you
can see what you're painting (otherwise you'll tend to paint too heavily and be in for an unpleasant
surprise when you turn Tracing Paper off later). Also start to turn the Clone Color button off and
add your own color. In this example I added clouds by turning the Clone Color off, picking a light blue
from the sky, and then lightening the value (moving the cursor upward in the Value-Saturation tri-

o
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angle of the Colors palette). I also added a little extra green for the trees and maroon for the base of
the building in the foreground.

16. Further Refinement with the Soft Grainy Round
Choose Tinting > Soft Grainy Round. Increase the Grain setting slightly and lower the opacity and
size. Use this brush to apply further refinement to the image (Figure 4.62).

Make sure you do a File > Save As at this stage and at every stage when you are about to change
brushes or brush size, in each case giving an appropriate file name with sequential version number
and short descriptor.

17. Subtle Application of the Soft Cloner
Choose Cloners > Soft Cloner. Increase the size and lower the opacity (Figure 4.63). Very gently start

PASTEL, WATERCOLOR, AND OIL

cloning in portions of the source image (the textured watercolor version, not the pure photographic

L o ooy 0 | 0] | a0 et o [ e [

(%]
w
2
(o4
=
I
v
w
-
o
-
o
o
o
<
o
w
-
o
<
I
v

= HE s Applying the Soft Cloner.




04.gxd 10/28/04 05:56 PM Page 140 $

PASTEL, WATERCOLOR, AND OIL

wv
w
°2
(o4
2
I
v
w
-
o
-
o
I
o
<
o
w
-
o
<
I
(%)

140 PAINTER IX CREATIVITY: DIGITAL ARTIST'S HANDBOOK

version). The trick here is to leave enough of the rough brushwork and not bring in too much detail.
Bring in more detail in the focal points of your image. In this case I brought back most detail in the
nearest part of the foreground, the Edwardian building, with its round corner and fire escape trellis-
work on the side.

Getting Rid of Too Much Detail

If you find you bring back too much detail or there’s a particular feature that stands out too
much, open the last saved version, the one just before you applied the Soft Cloner. The quick-
est way to do this is from the bottom of the File menu, where the five most recently saved
files are listed. Then choose File > Clone Source and set this file, the one before you applied
the Soft Cloner, to be clone source (by dragging to its name in the Clone Source pop-up menu).
The use the Soft Cloner to clone from the earlier version into the current version, getting rid
of the excess detail or unwanted contrast.

18. Softening Edges with the Diffuser2

Cloning in the filtered source image has two effects, one good, one bad. The good effect is that the
crisp edges, applied subtly, give the illusion of the wet fringe that occurs in traditional watercolor
painting. The bad effect is that the edges are sometimes too sharp, too perfect, too straight and have
too much contrast. The solution is to choose the Tinting > Diffuser2 variant (Figure 4.64). Apply this
softly along those edges that need softening. The Diffuser2 creates the illusion that the paint is dif-
fusing into the paper grain, just as it would in a traditional watercolor painting on an absorbent fine
art paper.

s B e 58 ) 5| e 98]}

el i The Diffuser2 variant being applied to soften edge details.
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After you've applied the Diffuser2, choose Cmd/Ctrl-O (zero) or Window > Zoom to Fit. Hide the
palettes (Window > Hide Palettes). Step back and look at your image. Are there any hard edges? Look
out for any signs of the rectangular edge of your original photographic image. If you see any hard
edges, soften them with the Diffuser2 or by painting over them with the Grainy Soft Round.

19. Signature
For the signature, return to the Tinting > Flattened Pencil with low opacity (Figure 4.65). Using the
same variant that you did the sketch with keeps the signature in harmony and consistency with the
rest of the picture.

This could be considered the completion of the artwork. However, I wanted to push it a little
further, adding to its intensity and photographic detail (Figure 4.66). For that reason I returned to
the original source photograph (before applying the Photoshop watercolor filter) and opened that

PASTEL, WATERCOLOR, AND OIL

photograph in Painter.

20. Prepare an Unfiltered Photographic Clone Source

Open up your original source photograph in Painter.

Add the same 200-pixel white border to your photo that you previously added to your
filtered image using Canvas > Canvas Size.

Set this image as your clone source (File > Clone Source).

21. Mix from Different Clone Sources
Gently clone in (using the Soft Cloner and light pressure) directly from the source photograph, not
from the filtered version. You may find you need to go back and forth between different clone sources
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(pure photo versus filtered image versus painted image) to get the right balance. You may also find

el Adding the signature with the Flattened Pencil variant.
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e[l Version of “North Beach” with no added photorealism.

you wish to add more of your own coloring, blending your added colors with clone colors. Subtly
blend the photo and paint with Blenders > Grainy Water and Blenders > Just Add Water, both at low
opacity.

22. Equalize
As a final touch you may wish to pump up the contrast of the image with Cmd/Ctrl-E (Effects > Tonal
Control > Equalize).

Mixing More Photorealism with the Watercolor
Sketch Technique

There may be cases where you wish to have more realism than is apparent in “North Beach,”
particularly in the professional portrait industry. Treat the technique demonstrated here as one
arrow in your quiver. For a more photorealistic image, follow a similar methodology to the one
described here, except reduce the prominence of the paper texture and clone in more of the
original photograph. Keep the paper texture contrast setting low and the Brush Property Bar
Grain settings slightly higher than the values shown here.

o
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el iev. Original photograph of Lisa Evans and her daughter Quinn.

Watercolor Example: Precious

I based my next image on a photograph I took of Lisa Evans and her daughter Quinn (Figure 4.67).
The moment caught in this photograph was very precious and captured the special loving relation-
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ship between mother and child. It was those feelings I wanted to convey in my painting (Figure 4.68).
I added a white border to the original photograph in Painter, cloned it, and then worked over the clone
copy with a variety of brushes, mainly from the Acrylic category. I blended with some Blenders > Just
Add Water. This is an alternative approach to the Watercolor Sketch technique, but one that still has

a watercolor feel. This picture received the Northern California Professional Photographers 2003
People’s Choice First Place Award.

4.7 Classic Oil Realism

Technique Overview

By classic oil realism I am referring to a painting that remains close to the original photograph in terms
of colors and forms and where brushstrokes are kept subtle. This form of painting uses paint to subtly
retouch and enhance the photograph, enriching and altering colors slightly but not to the extent that
the original photograph is lost. There is paint everywhere on the canvas, even though that may not
be obvious at first glance.
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Al il Precious.

Steps

Start with a Vision

The example shown in Figures 4.69 and 4.70, “Story Time,” was a commissioned portrait of Joyce
with two of her grandchildren, Mia and Robin. I picked this image from the photo shoot since it
showed all three engaged and connected and was at the same time an interesting composition with
strong positive and negative spaces. The hand-crocheted blanket that Mia was leaning on was knitted
for her by Joyce when Mia was born, which brings a circle of time into the picture and adds an extra
layer of significance to the image. Joyce had mentioned that she liked the bold colors that her late
husband, Fred, used in his paintings, so I photographed one of his paintings and used that to create
a color set for use in this project. My primary goal was to create a beautiful work of art that captured
the warmth and love between a grandmother and her grandchildren.
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e[l 47l Selecting New Color Set from Image.

Capture a Custom Color Set

Before I started painting I first opened the image of Fred's painting and selected New Color Set from
Image in the bottom left-hand icon pop-up menu of the Color Sets palette (Figure 4.71).  named the
new color set and kept it visible as I was painting. This is an optional step. I did this only because I
was endeavoring to fulfill my client’s request for inclusion of certain colors.
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Prepare Your Canvas

Open your source photograph in Painter.

Choose File > Clone. Do not use Quick Clone for this technique since we do not wish to
clear the canvas.

Choose File > Save As. Rename and save the clone copy as a RIFF file. Include a version
number.

Choose Cmd/Ctrl-M. This mounts your canvas.

Create a Mild Muck Up (Figure 4.72)

Choose Artists > Sargent Brush.

Click on the Clone Color icon in the Colors palette. You should see the Hue Wheel and
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Saturation/Value Triangle grayed out (indicating that clone color is active).

Start painting brushstrokes that follow the forms of your composition. The result is that
you lose detail. This may seem contrary to the “realism” of this technique, but in fact cre-
ating a mild muck up (meaning slight mess) is a valuable part of the technique. It will serve
as your underpainting.

Refine the Painting

Once you have covered the entire canvas with Sargent Brush brushstrokes, choose the
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Choose Window > Brush Controls > Open Impasto.

Change the Draw To: from Color and Depth to Color. This turns off the impasto depth
effect and results in a smooth oily brush with fine bristly structure (Figure 4.73).

Choose Save Variant from the Brush Selector pop-up menu. Save this variant for future use.

Apply this brush in the areas of the image that need smoothing, such as the skin (Figure
4.74).
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U= el Modify the Oil Brush Cloner
to turn off the impasto depth effect.
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Hle[1l= 7T Using the Soft Cloner to bring back some of the original photograph.

Where needed, use the Cloners > Soft Cloner to bring back some of the original photo-
graph (Figure 4.75).

Add Your Own Color
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Choose the Acrylics > Captured Bristle brush.
Ensure the Clone Color icon is not active.

Hold the Option/Alt key down as you click in a highlight area. This turns the cursor into a

Dropper tool and picks color from the spot where you click in the image.

Increase the value and saturation of the selected color by lifting the cursor in the Satura-
tion/Value Triangle upward and slightly to the right.

Paint in this lighter, brighter color in the highlight (Figure 4.76).

Check the Clone Color icon and use the same Captured Bristle brush with clone color to
blend the added color into the surrounding color (Figure 4.77).

Continue this process of adding your own color and then blending it in with varying size
brushstrokes and color choices to suit different areas of the image (Figure 4.78).

Increasing Contrast and Saturation
In looking at the image I felt that it lacked punch and vibrancy. Therefore I took steps to increase the
contrast and saturation of the image. These steps may or may not be needed for your own image.
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Adding lighter, brighter color.

Adding color to Mia’s hair.

Choose Cmd/Ctrl-E (Effects > Tonal Control > Equalize) (Figure 4.79).

When you select Equalize in Painter there is an automatic adjustment to your image that
increases contrast. Sometimes this is enough and you do not need to make any further
adjustments. Other times it helps to adjust the black-and-white points (Figure 4.80).

After applying the Equalize command, select Effects > Tonal Control > Adjust Colors (Figure
4.81).

Increase the saturation slider in the Adjust Colors window until you're satisfied with the
result (which you can see in the preview window) (Figure 4.82).

o



04.gxd 10/28/04 05:56 PM Page 151 $

Accentuating the
highlight on Robin’s nose.

Shapey m Movie Window Help
il Apply Lighning =/ 1
E Apply Serisce Textune L

Crientakion

Fill i
Caonrecy Colors. KK
| Adjust Colori. 0 XA
| Adjust Selected Colors..
| BrighimessComirast.. OXE

| Negatve
| Pouterize...
Video Legal Cobor...

Postertze Using Color Set

Choosing the Equalize
command.

The Equalize window.

Final Touches

Choose Acrylics > Captured Bristle, if it is not already selected.
Make sure clone color is off.
Hold down the Option/Alt key as you click in the image to pick a color.

Now apply that color in another part of the image. In this example | picked some of the
pinks from the lower left and added them as background atmosphere brushstrokes in the
upper right (Figure 4.83).

I then picked an orange color from Robin’s hand in the lower right and applied that color
in the upper left background. This approach creates subtle resonances that unify the com-
position and create a sense of harmony and balance.
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e[l vl The Adjust Color window.
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Aokl Selecting Adjust

Colors.
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e iEl Adding background

atmosphere brushstrokes.

Choose the Blenders > Smear.

Smear areas that need further blending or smoothing out. In this example | applied the
Smear brush in the background to make the brushstroke structure more diffuse and less
obtrusive. | wanted the background to fade away and the viewer’s attention to go to the
faces and to circle around between the faces and the hands (Figure 4.84).
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4.8 Expressive Oil Impressionism

Technique Overview

This case study (Figure 4.85) shares an approach to interpreting a photograph (Figure 4.86) in a
style influenced by the use of impressionistic color by artists such as Monet and the use of thick,
expressive brushstrokes by artists such as Vincent Van Gogh, hence the term expressive oil impres-
sionism. The basic principles and methodology covered here can be applied to rendering a photograph
in almost any painting style or media. The key part of the process described here, as in the previous
case study, is the muck up, the letting go of detail and perfection, the creating of a simple foundation
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on which to build up your image.

Art Movements That Influenced “Hand in Hand”

The art movements that influenced the creation of “Hand in Hand” included Impressionism,
Post-Impressionism, Fauvism, and Expressionism. Impressionism, which began in France in the
mid- to late 19th century (examples include Claude Monet and Pierre-Auguste Renoir), is a
spontaneous style of art that strives to capture the impression of natural light in a scene. The
Post-Impressionists were artists in the late 19th century, such as Paul Cezanne, Paul Gauguin,
and Vincent van Gogh, who were influenced by Impressionism, though they took their art in
different directions, using bold brushstrokes and gestures. Fauvism, based primarily in France
at the end of the 19th century (examples include Henri Matisse and André Derain), was a style
of art that used “wild,” unnatural colors (a critic had labeled the artists /es fauves, or “wild
beasts”). Expressionism, centered in Germany in the first half of the 20th century (examples
include Wassily Kandinsky and Egon Schiele), is a movement where the artists express their
inner feelings and state in the way they depict a subject.
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Steps

Start with a Vision

The inspiration for this image was a photograph I took of my friends Heidi and Steve (www.bal-
boaswing.com) at their wedding. They were walking past the roses in the Descano Gardens, La
Canada, California, just minutes after getting married. The play of light and shade suggested so many
colors. I envisioned thick, luscious brushstrokes that followed the forms in the image, picking up the
rich, warm colors of the afternoon sun and of nature. I envisioned focusing in on Heidi and Steve in
a style of brushstroke that was both impressionistic, in catching the effect of natural light, and expres-
sionistic (and a little fauvist) in using intense and sometimes contrasting colors that came from my
imagination as well as what was in the original photograph.

PASTEL, WATERCOLOR, AND OIL

Prepare Your Source Image (Photoshop)

As with the techniques described earlier in this chapter, start by preparing your digital file for paint-
ing, first in Photoshop, where you use Adjustment layers to optimize the tonal and color balance of
the image. Flatten the file and then crop if needed. Resize if needed. Resave as a TIFF (or Photoshop)
file and open it in Painter.

Decide on Border (Painter)

Before making a clone copy to paint on, you must decide whether or not to add a border to your orig-
inal source image. In this case, since we are emulating an oil painting and the final image will be
printed on canvas, stretched or mounted in a frame or with a gallery wrap (stretched canvas with
either paint or thin wood or tape over sides), the paintwork will go right until the edge of the canvas.
Thus there is no need, in this case, for adding any border.
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Create a Custom Shortcuts Palette

For convenience | recommend setting up a custom shortcuts palette with buttons for such fre-
quently used commands as Save As and Clone. Here's how to do it.
Choose Window > Custom Palette > Add Command

Choose File > Save As. The advantage of making a Save As button is that you can avoid
accidentally selecting File > Save instead of File > Save As.

Click OK. You have now created a custom palette called Custom 1 with a Save As button
in it.

Choose Window > Custom Palette > Organize.

Select Custom 1.

Click Rename. Rename the Custom 1 palette “Shortcuts” (or you can be more task specific
and have different custom palettes for different tasks).

o
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Choose Window > Custom Palette > Add Command.
Choose Add to: Shortcuts.

Choose File > Clone. Click OK. You can add any menu commands you wish, plus you can
drag in variants from the Brush Selector Bar. If you are going to use the Iterative Save
feature, | recommend also creating an Iterative Save button.

If you accidentally generate too many custom palettes, you can delete them in the Window >
Custom Palette > Organizer. To rearrange buttons in the custom palettes or to drag them out
of the palettes, hold the Shift key down while you drag on the buttons.

Resave Original Photograph

With your original source image open in Painter, choose File > Save As. Name this file with a consis-
tent beginning that you will use for all files in this project, and then add version number, for instance,
“handinhand-00-orig.tif” (unless you plan to use the Iterative Save feature, in which case you'd use
“subject_000.tif”). I often save my original image as a TIFF file and then subsequent working files as
RIFFs, backing up periodically as either TTFF or Photoshop. Save your original image into a prepared
folder for this project. All subsequent versions of this file as you work on and develop the image will
be saved into the same folder location with consistent file names and consecutive version numbers.
Doing this ensures you have easy access to your original image and all intermediate versions any time

you wish to continue working on the project.

Save Your Palette Arrangement

Once you have gotten used to Painter and have your palettes arranged in a way that works
for you, it is a good idea to save the palette arrangement. That allows you to conveniently
access the same palette arrangement at any time in the future. It also allows you to create a
variety of arrangements for different tasks.

Choose Window > Arrange Palettes > Save Layout.

Name your layout. In this case | named it Basic Paint. The layout has now been added to
the Arrange Palettes drop-down menu.

Note that palette arrangements are screen resolution dependent, so if you go between dif-
ferent screen resolutions you may wish to include a note of resolution in the layout name. If
in doubt you can always select Window > Arrange Palettes > Default, which will fit to what-
ever your current screen resolution is.

Make a Clone Copy

Choose File > Clone (or click on your Clone shortcuts button). This creates a duplicate image that has
Clone of . . . at the beginning of the file name. This clone copy is referred to here as your working
image since it is the image you will be painting on.
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Original Automatically Defined as Clone Source

In using the Clone command on an original image, you automatically define your original
image as Clone Source and will see the image name with a checkmark by it when you look at
the File > Clone Source menu. This means that all cloner brushes (brush variants from the
Cloners category or brushes that have the Clone Color icon activated in the Colors palette) will
look to the original image for their color. Cloning in Painter is like using the Rubber Stamp
tool in Photoshop, except it is much more versatile. In Painter you can turn almost any brush
that adds color to the canvas into a cloner brush just by activating the Clone Color icon in the
Colors palette.

Mount Your Working Image
Choose Cmd/Ctrl-M (Window > Screen Mode Toggle). This mounts your working image so your

desktop is as uncluttered as possible. I recommend working in screen mode whenever possible.

Fill Your Working Image with a Background Color

Choose a background color in the Colors palette (or by using the Dropper tool to pick color from within
the image). I chose a blue color to contrast with the greens, pinks, and yellows in the image (Figure
4.87).

Fill with: ) Currant Codar
) Clone: Source
) Gradignt

Filling the Working Image with a background color.
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Save Your Working Image

Choose File > Save As (or click on your Save As shortcuts button). Delete “Clone of . . .” from the file
name, change the version number, and add a note that this is your start image. Save the working file
as a RIFF for maximum versatility. In this case I called the clone copy “handinhand-01-bkgnd.rif.”
Remember to save sequentially numbered versions regularly as you work, and always back up your
most recent version as a TIFF or Photoshop document before you close Painter.

Choose a Good Muck up Brush
The first stage of this painting is the muck up stage. Creating a muck up involves working over the
entire canvas with thick brushstrokes. These brushstrokes simplify the image into regions of light and
dark tone and the main color blocks. The muck up brushstrokes embody movement, energy, and flow
that form a dynamic foundation, or underpainting, on which you can selectively bring back detail
and add color and contrast as required.

There are many brushes and combinations of brushes that can work well as muck up brushes.
My all-time favorites are Den’s Oil Funky Chunky and Big Wet Luscious, both of which you'll find
in the Jeremy Faves 2.0 brush category (contained on the companion Resource CD). Other great
muck up brushes include Artists > Sargent, Artists > Impressionist, Palette Knives > Loaded
Palette Knife, and Blenders > Oil Blender 40. In the example shown here I decided to use the Artists
> Impressionist brush.

Brush Research

Use a section of your working image to do brush research and explore different oily brushes.
Check the Clone Color icon in the Colors palette as you test muck up brushes so that the colors
are based on the original photograph. Don’t be afraid of experimenting with the sliders in the
Brush Property Bar at the top of your screen. The jitter slider, when it appears, can give great
results. If you find a brush setting you love, save the variant and lock it into the Brush Tracker.

When you have completed your brush research, use multiple Cmd/Ctrl-Z commands to undo
the strokes (you have up to 32 levels of undo) or select File > Revert and revert the file back
to its last saved version.

Create a Muck Up
Turn Tracing Paper on (Cmd/Ctrl-T) so that you can see the original photograph through
the working image.
Make sure the Clone Color icon is activated in the Colors palette.

Start moving, smearing, and blending imagery with your chosen muck up brush. Cover the
entire canvas in brushstrokes using clone color. Don’t worry about preserving detail any-
where. The goal is to create a painting that embodies the essence of the original compo-
sition. Use brushstrokes that follow the form of the features (Figure 4.88).
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Al Using the Impressionist brush with Tracing Paper turned on.

Increase Saturation of the Clone Source

As part of the process of introducing more “punch” and vitality into the final image, I increased the
contrast and saturation in my clone source and cloned in colors from the adjusted clone source. You
can do this from within Painter by doing the following.

Select your original image from the bottom of the Window menu.
Choose Effects > Tonal Control > Equalize (Cmd/Ctrl-E).

Adjust the sliders until satisfied.
Click OK.
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Select Effects > Tonal Control > Adjust Color.

Leave the Using pop-up menu on Uniform Color. Adjust the Hue and Saturation sliders to
generate an interesting color scheme in the image preview.

Click OK.

An alternative would be to prepare a saturated version of the original image in Photoshop using the
Layers > Adjustment Layers > Levels and Hue Saturation. In this case you'd need to flatten your image
prior to opening it in Painter (Figures 4.89 and 4.90).

Whichever way you choose to increase the saturation of your original image, resave the satu-
rated version with a new name, to identify it. Then manually set it to be clone source by choosing it
in the File > Clone Source menu. (Figure 4.91)

Clone In from Adjusted Clone Source

Choose the Cloners > Soft Cloner. Lower the Opacity slider in the Brush Property Bar to about 20%.
Gently brush in some of the newly adjusted original image. Use other clone brushes too to bring in
the more vibrant colors (Figure 4.92).
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More Brush Research

Once you've mucked up the image and introduced some more saturated color, the remaining stages
of the painting process involve selectively adding detail, color, and contrast. I wanted to get a rich,
organic feel to my brushstroke texture. Experiment with more brushes until you find several that will

work well with your image (Figure 4.93).
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Al iyl Adding Impressionist clone brushstrokes with color from the saturated original.
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Al ieEl Adding JS-Impasto Luscious brushstrokes with clone color.

Add Your Own Accent, Highlight, and Shadow Colors

At this stage click on the Clone Color icon in the Colors palette to deactivate it. Choose your own color
from the Colors palette (or from the Mixer or Color Sets palettes or from sampling color from within
the image with the Dropper tool). Add color accents that liven the image, bring attention to your focal
points, and help shape the forms (Figure 4.94).
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e[l els Adding your own color (not clone color) with the JS-Impasto Pressionist brush.

Defining Form Through Value

As you add your own colors, always bear in mind the value, or luminance, the perceived light-
ness and darkness of a color. Value informs our perception of three-dimensional form. The per-
ceived value of the colors you apply in your image shape the shading and highlights and thus
define form on your canvas. A painter develops the skill of judging value independent of color.
You can use Painter’s Effects > Tonal Control > Adjust Colors with the Saturation slider set all
the way to the left (-39%) to simulate a luminance-only (grayscale) version of your artwork.
Choose Cmd/Ctrl-Z (Edit > Undo) to get back to full color (Figure 4.95).

Blend in Colors as Needed
After adding your own color, you can blend them by reactivating clone color or by using brushes such
as Jeremy Faves 2.0 > Sable Chisel Tip Water, Blenders > Smear and Blenders > Oily blender.

Use Brush Resize Shortcut

When you wish to change brush size while painting, you can hold down Shift-Option-
Cmd/Shift-Alt-Ctrl. Then click and drag and you will see a circle that indicates the adjusted
brush diameter. This shortcut allows you to rapidly make big changes in brush size.

Work into the Face and Hands.

In the closing stages of your painting, work to bring out your focal points. In this example T worked
into the faces, trying out different approaches (Figure 4.96). In the end, with Steve’s head, I wasn’t
satisfied with my initial brushstrokes, so I used the Cloners > Soft Cloner to bring in a little of the
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el ielsl Adding color to Steve's head.
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original photograph and then worked over that region with the Impasto Luscious brush, making sure
I completely covered all the photographic image that had been soft-cloned in. When you do use the
Soft Cloner, do so sparingly, and make sure you brush over and blend out any photographic grain that
appears.

Add Surface Texture

My intention with this image was to have the effect of thick paint. Some of the brushes I used had a
small amount of Impasto depth in their brush behavior. When I got to this stage of the painting I
decided to experiment with adding a little extra brush texture. I chose Effects > Surface Control >
Apply Surface Texture. I selected Using: Image Luminance in the Apply Surface Texture window,
reduced the Amount slider to a small value, and took the Shine slider to zero (Figure 4.97).

After applying the Apply Surface Texture effect I used the Edit > Fade command to fade the effect
back a little (it’s easy to overdo an effect). I then saved the image as another version. I then opened
the version from before applying this effect, made it the clone source, and used the Soft Cloner to clone
away some of the texture.

Increase Contrast and Saturation of Final Image

When you have completely covered your canvas in brushstrokes and gone back over the image to
add selective detail and color, take a step back and look at your image. You may find you want to
generate more value contrast and color saturation. To do this you can follow a similar procedure
to that described earlier for increasing the contrast and saturation of the clone source, using

Apply Surface Textune

Using: | Image Luminance 8]

Earmens A

Diiphey A0S & oS0

 shaw Light leons

el ers Apply Surface Texture window.
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either Equalize and Adjust Colors in Painter or the Levels and Hue Saturation adjustments layers in
Photoshop.

Add Final Highlights and Accents
Add final detail touches. Take a look at where highlights need to be brought out and accents added.

Sign Off
Don't forget to add your digital signature. I added mine with a small Jeremy Faves 2.0 > Big Wet
Luscious, picking up a color from within the image.

Example Image: Quinn Between

Figures 4.98, a photograph of Quinn taken by her mother, Lisa Evans, at Camp Swing (a swing
dance camp) in Mendocino, California, was the basis for the muck up stage (Figure 4.99) and then
for the final painting (Figure 4.100), which is also featured on the front cover of this book. In this
case I added a white border and left a rough edge to the work. I used a variety of different brushes,
including Jeremy Faves 2.0 > Sherron’s Blender Wood, Pastels > Artist Pastel Chalk, and Acrylic >
Captured Bristle, for mucking up and refining the image. This image combines media and has
qualities of both pastel and oil paint. I show this both as an illustration of the muck up process and
as an example of alternative media approaches. In other words don't feel yourself bound to accu-
rately emulate one specific traditional medium or another. Painter offers you a whole new vista of
combined media.

Original photograph of Quinn reading Archie’s (photography: Lisa Evans).
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Muck up stage.

“Quinn Between.”
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4.9 Student Gallery

Appreciation

I wish to take this opportunity to thank all my students over the years for their inspiration and enthu-
siasm. I would like to share all their wonderful artwork with you, but space allows only a few pieces
to be included in this Student Gallery. I have selected a small sampling of student work that relates
to the styles covered in this chapter (you will find artwork by two other students in Chapter 12). This
small sampling of work is just a taste of the phenomenal body of magnificent work that my students
at all levels have created in my classes over the years. All photography and Painter artwork is by the
student in whose section the artwork appears. The students shown here have all participated in my
Painter Panache Master Series Seminars, and most of the artworks shown were created as seminar
projects during class time. The pieces shown here are not necessarily completed artworks but are
studies with which the student explored different techniques and themes. Where possible T have
included the original and the muck up stage of the paintings, which tell you so much about the artist’s
creative process. I have also included what the students wrote to me about their process and how
Painter has influenced their art. You will see even from this small sampling the incredible diversity of
what is possible.

Fuzzy Duenkel (Figures 4.101 Through 4.105)

Original photograph. Muck up stage.
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4

Original photograph. “Candi.”

Painter is a program that I have long wanted to be comfortable with, because I feel that it is
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the direction that the more advanced portraitists are headed. We've reached a point where our portrait skills
seem to be near a plateau. And yet we still yearn for some way to make the final image match the image in
our minds. Photographic techniques, diffusion, and special effects are wonderful to produce an image that

conveys an intended message. But often an image needs something more. Painter is that extra touch that
allows us to transform an image from a raw state to the finished state. I cringe when I hear that it turns
pictures into art. That’s silly. Art is a not a filter or a technique. It’s a complete, emotional statement that
touches the viewer. Painter is simply the final brushstroke that the image needed, and was destined for; from
conception.

Why paint an image? 1 feel that Painter permits the maker to obscure details that interfere with his or her
vision of the piece’s feeling. Sometimes it needs to be in black and white. Sometimes all that is necessary is
to diffuse the image. Sometimes it needs extensive Photoshop manipulation. Painter is another tool in our
repertoire of knowledge.

It is extremely versatile and powerful, so much that it that can completely alter an image. In fact, with that
power comes the danger of relying on its abilities, rather than our own. It can take over. And that’s OK too.
But at all times, the maker needs to be able to know what is best for the image. Sometimes it’s better to stay
focused on our original intent. Other times it’s wise to let happy accidents happen, and go with that. But at
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no time should the effect overpower the core image. At that point it ceases to be art and becomes an exercise
in heartless technique. Much like a barrage of heavy-handed lightning-fast guitar notes, excessive computer
manipulation can lead to an image that impresses the viewer . . . for short while.

Art is as timeless as we are. It can express a dated moment. Or it can share a feeling that could have been felt
at any moment in the history of human existence. But it should be capable of being appreciated and under-
stood for all time.

Scott Dupras (Figures 4.106 Through 4.110)

PASTEL, WATERCOLOR, AND OIL
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el bis Original photograph.
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St by "An Artistic Passion.”
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s Original photograph.
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Flelt= il Muck up stage.
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Al k) “Three Ballerinas.”
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Myra Gordon (Figures 4.111 Through 4.113)

Painter allowed me to transition from photography to painting, creating my own unique artistry. Photogra-
phy sees light as it is. Painting sees color as I feel. Painter allows my heart to mix light and color, capturing
slices of life more realistically than it ever was.

During my 20 years of private practice as a marriage, family, and child counselor I listened to and analyzed
life with verbal communication. My job was to guide others into thinking about a new way of interacting
with the world around them. Painter allows me to analyze life with color and form as I wish others to see it.
Rather than using verbal skills, I have asked others to open their eyes to see the world through feeling. Once
again, I have touched the hearts and minds of those around me, but through arousing all of their senses.

I now write with light and color about the very pixels of life. Those pixels are my story and I choose not to
leave out any. I indeed have the world on my screen.

Sam Gray

The techniques that I have acquired through the Painter program and through studying under
Jeremy's Painter Panache Master Series have transformed my work. After 35 years I am more excited
about my work than I have ever been. I believe this has opened up a whole new creative avenue for
me that does not exist through the medium of photography alone. I am able to express emotions in
my work that truly reflect the essence of art. Being able to create one-of-a-kind art pieces for indi-
viduals, which they can display as one would any fine art but with the unique advantage of being
personalized, is truly rewarding to me as an artist.

After satisfying the client’s wishes I wanted to create an abstract of this young ballerina. My goal
in “Dancer at Rest” was to paint this image in such a way that any admirer of fine art and ballet
would appreciate the fluidity and grace of this young performer. [See Figures 4.114 Through 4.116.]

My intention in “The Kiss” was to capture a moment in time for this couple. I allowed the brush-
strokes to create the serene, pensive, and romantic mood obviously being shared by the two. Again
the techniques used were paramount in accomplishing this scene—photography alone would have
fallen short in setting the mood and raising this image to a level worthy of the description of fine art.
[See Figures 4.117 and 4.118.]



04.gxd 10/28/04 05:57 PM Page 175 $

PAINTER IX CREATIVITY: DIGITAL ARTIST'S HANDBOOK 175

PASTEL, WATERCOLOR, AND OIL
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LEITEEEEFY Muck up stage.
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EIELE] *ana Smile.
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SETEVEEET Original photograph. LEITEEEEE] Muck up stage.

PASTEL, WATERCOLOR, AND OIL

w
w
2
o
=
I
v
L
-
(e]
[
()
I
o
<
o
('8
-
o
<
I
v

Hleie ke “Dancer at Rest.”
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Original photograph.

“The Kiss."”
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Jolyn Montgomery (Figures 4.119 and 4.120)
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Hlelie kel Original photograph.
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lelt= Pl “Destorto.”

Sherron Sheppard (Figures 4.121 Through 4.126)

Painter has given me many new tools for unlimited experimentation, and the ability to “undo” has freed me
from the fear of ruining a piece of work while trying out new ideas. I love to sit down with an ordinary image,
create “something from nothing,” and then see how far I can “push” that image in painter. Painter has
expanded my creativity by opening a whole new artistic world. Through Painter, I have been able to explore
new ideas as well as give new life to existing methods.

o
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Original photograph. Mid-stage.

“0Old Car at Sonoma.”
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Original photograph. Mid-stage.

"Red Rose Wonder.”

Paul Tumason (Figures 4.127 Through 4.129)

Without a doubt, Painter has pushed me into an arena in which I never thought I would be allowed
to enter. I always thought my work was well planned and executed photographically and reminded
clients and colleagues alike to ask if my portraits were painted in any way. I would always appreci-
ate that sentiment because I always wanted to paint portraits. But my photographic portraits would
never have the nuances that would be painted by a skilled artist. T hope to achieve those subtleties,

o
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Original photograph. Mid-stage.

"\oice."



04.gxd 10/28/04 05:57 PM Page 183 $

PAINTER IX CREATIVITY: DIGITAL ARTIST'S HANDBOOK 183

and more. I must admit, though, that I can’t believe how humbling this program is. I have a long
way to go. But it’s like a rebirth for my portraiture and has brought me to a higher level of achieve-
ment. Thank you.

4.10 Wrap

Congratulations on familiarizing yourself with the techniques covered in this chapter. I hope you've
already made wonderful discoveries along the way and are itching to explore deeper! What T have
shared in this chapter is just scratching the surface of what’s possible. As I stated in the chapter intro-
duction, the case studies are not recipes to be followed exactly, but frameworks from which you can
branch out using your own combination of brushes and settings and procedures. These case studies
do not represent the definitive way to achieve a Chalky Pastel or a Watercolor Sketch or Oil Impres-

PASTEL, WATERCOLOR, AND OIL

sionism. They each represent just one of many approaches.

The following chapter expands your horizons as to what you can do with your photographs in
Painter. I have included a variety of different techniques and looks that I think may interest you. Once
you have completed working through the next chapter you'll have a rich and diverse range of options
at your fingertips whenever you approach transforming a photograph.

Do not get stuck on techniques, but focus always on your vision, on the story you wish to share.
Techniques are secondary to your vision. Your vision is what moves others and, ultimately, changes
the world.
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